What is ISIS Xpress?

Accusoft.ISISXpress4.Net | Accusoft Pegasus
What is ISIS Xpress?
See Also Send Feedback |
Introduction > What is ISIS Xpress?

Glossary Item Box

ISIS® Xpress™ Version 4 is a powerful, complete, and low-cost software development kit (SDK) used to control high-speed ISIS scanners. ISIS® Xpress can be used as a .NET component or an ActiveX COM component. Designed for high-speed scanning of black/white, grayscale and color documents, it supports simultaneous image capture (multi-streaming), and provides access to ISIS scanner features. ISIS® is a registered trademark of EMC Corporation.

New Features in Version 4

  • Updated support of all high-speed ISIS®-driven scanners to the Version 8 of the EMC Corporation's ISIS® PixTools® library.

Additional Classes, Methods & Properties

  • GetConnectedDriversAndScannerModels - This class implements scanner and driver methods and properties for listing all connected scanners.
  • Select - Now has an optional parameter to have a modal dialog.
  • SelectConnected - Shows a dialog box for only connected scanners, with an optional parameter for a modal dialog.
  • DriverDirectory - Controls the location of the ISIS driver files.
  • DriverDirectoryDefault - The default location of the ISIS driver files.

Primary Features Include

Scanner Support

  • Provides complete control over all high-speed ISIS®-driven scanners that EMC Corporation's ISIS PixTools supports.
  • Scan directly to memory.
  • Resolution can range from 50 dots-per-inch (dpi) to 2400 dpi or more depending on scanner capability.
  • Automatic feeder, printer/endorsers, and transparency units are supported.
  • Interfaces with SCSI, USB, serial port, video, parallel port, GPIB, and proprietary interfaces.
  • Access performance scanners from Canon, Agfa, BancTec, Bell & Howell, Epson, Fujitsu, Hewlett-Packard, Inotec, Kodak, Microtek, Minolta, Panasonic, Ricoh, Sharp, and Umax.

Compression & File Formats

  • Compress to standard document image file formats:
    • TIFF (Raw, Packbits, Binary CCITT Group 3, Binary CCITT Group 3 Modified, Binary CCITT Group 4)
    • Color and grayscale JPEG (24-bit sequential and 8-bit gray sequential).
    • DCX
  • For .NET, output to:
    • Bitmap
    • HBitmap
    • HDIB
  • Add on ImagXpress™ for decompression, conversion, or display of the file formats listed above plus support for many additional file formats.
  • Add on PDF Xpress™ for PDF support.

Advanced Tags

The component supports Advanced Tags, which offers developers great flexibility in utilizing scanner specific features. These are scanner processing instructions which are provided as parameters passed as tag values to the control, and consequently passed directly through to the scanner. Assuming the correct tags are passed to the scanner, they will instruct the scanner what actions to take.

Multi-Streaming Support

  • Take full advantage of scanners supporting MultiStream technology with Duplex or Multi-Streaming:
    • Duplex - Scans both front and back simultaneously.
    • MultiStreaming - Scans two images from the same side.
    • Combine both by using duplex with multi-streaming and capture four images with two on the front and two from the back.
  • Scanning modes could include full-color, black-and-white, grayscale, binary or RGB color dropout.

Image Viewing, Annotation, & Printing

Add on ImagXpress for image viewing, thumbnail image support, document image processing and editing, TWAIN scanning, annotation, printing and more.

Bitonal Image Cleanup

Add on ScanFix Xpress® for advanced bitonal image cleanup technology such as dot shading removal, line removal, character smoothing, inverse text correction, hole punch removal, deskew, despeckle, rotate, mirror, flip and more.

Additional Accusoft Pegasus Components

Additional components are available for purchase separately, and integrate easily to provide a comprehensive imaging solution:

  • PDF Xpress™ – PDF creation, viewing, and annotating
  • Barcode Xpress™ – recognize barcodes
  • ScanFix Xpress™ – advanced image cleanup
  • FormFix™ – form ID, dropout, and OMR
  • SmartZone™ ICR / OCR – character recognition
  • ImageGear for .NET - Fully managed code to create cutting edge imaging applications
  • ImageGear for Silverlight - Comprehensive SDK for building Web imaging applications
  • ImageGear for .NET Compact Framework - Create reliable and secure imaging applications for mobile devices

See www.accusoft.com for product packaging and sales information.

ISIS® is a registered trademark of EMC Corporation.

See Also

Getting Support
Software License Agreement
Operating Requirements

©2010. Pegasus Imaging Corporation, DBA Accusoft Pegasus. All Rights Reserved.


Getting Support
See Also Send Feedback |
Introduction > Getting Support

Glossary Item Box

Getting Support

Benefits of Registering your Development Kit

Purchasers of development kits need to register with Accusoft Pegasus in order to be notified of updates and receive support now or in the future. Registration is automatic when purchased directly from the Accusoft Pegasus web site. If purchased through an Accusoft Pegasus reseller, please register your purchase by filling out the form at www.accusoft.com/registration.htm.

Vehicles for Support

Samples

Samples are included in the downloaded installation.

The product installation program installs a common sample folder accessible via the Start Menu.

Samples for the .NET framework:

  • Microsoft VisualBasic.Net
  • Microsoft C#

Access the Samples

  • Through the Windows Start menu: Start | Programs | Accusoft | ISISXpress | Samples
  • Sample image files included

Web Support

Visit the Accusoft Pegasus web site frequently asked questions page www.accusoft.com/faq.htm for the fastest answers to common questions. The web site also provides other support options that are accessible at www.accusoft.com/supportagree.htm.

E-mail Support

Both pre-sale and post-sale e-mail support is offered free of charge. Questions are answered on a First-Come-First-Served basis. Support@accusoft.com responds instantly to e-mail received with a helpful set of locations to find additional information on Accusoft Pegasus' products including FAQ's, sample code, and other current information pertaining to the use of the products. The support request is then added to the queue of outstanding requests. The goal of the support team to respond to each e-mail within 1 business day.

The sales team is always available as a backup to the support team. If you feel you have an urgent support or sales issue please contact Sales@accusoft.com. They will assist you promptly.

On-Demand Phone Support

On-demand priority phone support can be purchased in 15 minute increments with a credit card via the Accusoft Pegasus web site Support, General Info page. If you decide to purchase "on-demand" phone support, instructions will immediately be e-mailed upon receipt of your purchase.

Additionally, Accusoft Pegasus offers three support plans for those customers whose commercial products or projects are sensitive or critical in nature, where immediate response and 'latest release' code are important.

1. Chariot Support

All Accusoft Pegasus customers are given the opportunity to purchase a Chariot Support agreement. This is a maintenance and upgrade agreement that entitles customers to priority e-mail service, direct phone support from the support and development staff and free product upgrades for the covered products. Since upgrades are included for Chariot customers at no additional charge, Chariot customers can frequently save money, plus obtain the benefits of phone and expedited support. Accusoft Pegasus reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at www.accusoft.com/contactform.htm for more information.

2. Galleon Support

Customers are given the opportunity to purchase Galleon Support for Accusoft Pegasus products that are applications and for products that require run time licensing. Galleon Support includes licensing of product upgrades for deployed installations at no additional license fee cost. Accusoft Pegasus reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at www.accusoft.com/contactform.htm for more information.

3. Atlas Support

All Accusoft Pegasus customers are given the opportunity to purchase an Atlas Support agreement on currently supported products. This is an agreement that entitles customers to priority e-mail service and direct phone support from the support and development staff. It differs from Chariot Support in that it does not include version upgrades free of charge. Accusoft Pegasus reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at www.accusoft.com/contactform.htm for more information.

For the latest and most up-to-date support information, access www.accusoft.com/contact.htm

See Also

Operating Requirements
Trial Mode
Installing on a Development Machine


Pegasus Imaging Corporation, DBA Accusoft Pegasus

Accusoft.ISISXpress4.Net | Accusoft Pegasus
Pegasus Imaging Corporation, DBA Accusoft Pegasus
See Also Send Feedback |
Introduction > Pegasus Imaging Corporation, DBA Accusoft Pegasus

Glossary Item Box

Accusoft Pegasus is the largest single source provider of imaging software development kits (SDKs) and image viewers. Features include barcode, compression, DICOM, editing, forms processing, OCR, PDF, scanning, video, and viewing. Technology is delivered for multiple platforms and development environments.

Whether you’re building new applications or enhancing existing workflows, Accusoft Pegasus Software Development Kits (SDKs) get you there faster. Our mission is to help you seamlessly and quickly integrate superior imaging functionality into your application. We provide very generous support from our software engineers, unlimited downloads and trial licensing that won’t time out, and full access to all product features prior to purchase. When you need imaging, we’ve got your code.

Visit www.accusoft.com for product descriptions, downloads, demos, support FAQ's, and licensing information.

Accusoft Pegasus
4001 North Riverside Drive
Tampa, FL 33603
Sales: 813-875-7575

Copyrights & Trademarks

Accusoft, ColorDrop, ColorEnhance, ColorFind, ColorForms, CompressDirector, Digital Mark Recognition (DMR), FormFix, Image Detergent, ImageGear, ImagXpress, NetVue, ScanFix, Pegasus, Prizm, ViewDirector, Virtual Scoring Center (VSC), and the Pegasus Horse Logo are registered marks (®) of Pegasus Imaging Corporation, DBA Accusoft Pegasus.

Barcode Xpress, CapturePRO, FilePrinter, FormAssist, FormDirector, FormSuite, ISIS Xpress, The JPEG Wizard, MICR Xpress MedXpress, NotateXpress, OCR Xpress, PDF Xpress, PICTools, ePIC, PICVideo, PrintPRO, SmartScan Xpress, SmartZone, ThumbnailXpress, TwainPRO and the Accusoft Pegasus Logo, are trademarks (™) of Accusoft Pegasus.

Accusoft Pegasus and/or its agents use these marks and brand names in connection with its goods and/or services, in the United States and other countries. Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Accusoft Pegasus.

Microsoft, Internet Explorer, Microsoft.NET, Silverlight, Visual Basic, Visual Studio and Visual Studio.NET are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries. Itanium is a registered trademark of Intel Corporation in the United States and other countries. All other product and brand names are the property of their respective owners.

See Also

Software License Agreement


Operating Requirements
See Also Send Feedback |
Getting Started > Operating Requirements

Glossary Item Box

Operating Requirements

Operating Systems

ISIS® Xpress™ runs on supported Microsoft Operating Systems:

  • Windows 2000
  • Windows XP, XP Professional
  • Windows Vista
  • Windows 7
  • Windows Server 2000
  • Windows Server 2003
  • Windows Server 2008
ISIS Xpress runs in 64-bit and 32-bit executables.

Development Environment

ISIS Xpress is supported on the following development environments:

  • Microsoft .NET Framework 2.0, 3.0
  • Microsoft Visual Studio 2005
  • Microsoft Visual Studio 2008

See Also

Getting Support
Installing on a Development Machine
Run Time Licensing


Installing on a Development Machine
See Also Send Feedback |
Getting Started > Installing on a Development Machine

Glossary Item Box

Installing on a Development Machine

To Install ISIS® Xpress™ Component

Run the downloaded setup program which installs the development kit on your development machine.

The downloaded development kit includes code samples for supported platforms. Samples are available through the Start | Programs | Accusoft | ISISXpress menu.

By default this will register trial licensing which allows you to develop applications but not to distribute them. The trial license allows testing of all the functions and features.

Please see the section Distributing ISIS Xpress to understand the limits and details to convert licensing editions.

In order to distribute your finished application you must purchase and install a fully paid license from Accusoft Pegasus. The paid licenses override trial licenses.

To Use ISIS Xpress Help Files

Stand-alone Help File

You will have access to the following stand-alone help file:

  • Accusoft.ISISXpress4.Net.chm

Access the ISISXpress stand-alone help through the Windows Start menu: Start | Programs | Accusoft | ISISXpress

The stand-alone complied Help chm file is created with MS Help system version 1. To view Help 1 files, you must have:

  • Windows 2000 or higher (to view the file via the Windows HTML Help Viewer)
  • Internet Explorer 6.x or 7.0
  • MS HTML Help Viewer

Compiled Collection Help File

You will have access to the following compiled collection help file:

  • Accusoft.ISISXpress4.Net.hxs

Help 2 collection files install into Visual Studio.NET (VS). To view Help 2 files, you must have:

  • Windows 2000 or higher
  • Internet Explorer 6 or higher
  • Visual Studio .NET 2002 or higher
  • MS Help version 2

When ISIS Xpress installs, if the system installation requirements for Help 2 files are met, the Help 2 file is included on the Start shortcut menu. If the installation requirements for Help 2 files are not met, then the Help 1 file installs on the Start shortcut.

Plugging ISIS Xpress Help into Visual Studio

ISIS Xpress Help 2 files integrate within the Help system in Visual Studio .NET. To access ISIS Xpress Help within Visual Studio, do the following:

  • Ensure that the MSDN Library is installed in your Visual Studio environment. If it is not installed, re-install it from your VS.NET disc.
  • Ensure that MS Help Integration Kit is installed in your Visual Studio environment. If you do not have it installed:
  1. Download the Help Integration kit from MSDN.
  2. Close Visual Studio.
  • Re-open Visual Studio, select the Help Menu and the Contents submenu. Verify Help files for Accusoft Pegasus controls are listed. If Accusoft PegasusHelp is not listed:
  1. Search for "VSCC" in Visual Studio Help, leaving the "Filtered by:" list box blank. Select the "Visual Studio .NET Combined Help Collection Manager" topic.
  2. Select the Help 2 collections available on your PC under the heading "Collections available for inclusion in VSCC."
  3. Take care when excluding Help collections from the default VSCC collection. These collections may be necessary to view required documentation. Instead, use the "Filtered by:" field on the Contents tab of the Help panel to focus searches on Accusoft Pegasus topics. Leave the "Filtered by:" list box empty to view the entire Accusoft Pegasus Help files.
  4. Select the Update VSCC button.
  5. Close all instances of Visual Studio and Microsoft Document Explorer. When you restart Visual Studio, the VSCC Help collection revises with your changes. (Note: this may take several minutes.)
  6. Check the Visual Studio Help/Contents tab again to see the Help collections available to you.
  • Select the ISIS Xpress Help file to view Help content.

See Also

Operating Requirements
Run Time Licensing
Development Mode
Software License Agreement
Distributing ISIS Xpress


Trial Mode
See Also Send Feedback |
Licensing > Trial Mode

Glossary Item Box

Trial Mode

Default Installation

The default installation installs Trial Mode licensing. This allows you to test features and functions and develop applications but not distribute them. Installing ISIS® Xpress™ in trial mode provides you with access to all features and functionality of the ISIS Xpress product. E-mail support is available with the trial license.

When using the trial version of ISIS Xpress, an evaluation dialog box displays periodically. Applications built with a trial license can only be run on a computer that has ISIS Xpress Licensing installed on it.

Changing Trial Mode Behavior

You have the flexibility to change the behavior of ISIS Xpress in evaluation mode as follows:

  • To facilitate server/service mode evaluations, you can choose to halt the component processing after 5 minutes in lieu of displaying an evaluation dialog box periodically. This is the TimeOut setting for the Licensing.EvaluationMode property.

See Also

Development Mode
Run Time Licensing
Software License Agreement
Getting Support


Development Mode
See Also Send Feedback |
Licensing > Development Mode

Glossary Item Box

Development Mode

To suppress the evaluation dialog box and deploy your application, or attain technical support (beyond e-mail), as well as future product updates and upgrade notifications, you must update from a trial version to a paid version of the ISIS® Xpress™ development kit.

1. Purchase Development Kit(s)

To purchase licensing of the ISIS Xpress development kit, use one of the following options:

  • Purchase online at www.accusoft.com.
  • Contact Sales via the web at www.accusoft.com/contactform.htm for more information.
  • Contact an Accusoft Pegasus reseller.

When the development kit is purchased, we e-mail a serial number & registration code to you. You need these codes to upgrade from trial to paid licensing.

2. Register the ISIS Xpress Product

When you purchase ISIS Xpress online or through Sales@jpg.com, your product ownership is automatically registered.

To register products purchased through a reseller, use the form found at www.accusoft.com/registration.htm.

See Getting Support for a discussion of benefits to providing your name to Accusoft Pegasus. We never sell our customer information.

If your registration information should change, visit www.accusoft.com/contact.htm for forms to update registration information.

3. Update Your ISIS Xpress Product Version from Trial to Paid Licensing

Updating your ISIS Xpress from trial to paid licensing will suppress the trial behavior, including the evaluation dialog box or timeout. This must be done for each component within the ISIS Xpress toolkit that you are using (for example, ISIS Xpress, ImagXpress, NotateXpress or other included components). The email you receive when you purchase the product will include entries for each component included in the ISIS Xpress product.

To update components from trial to paid licensing:

  • Enter your new license codes using one of the following options:
    • Enter licensing information (serial number, registration code and personal registration information) during component installation while downloading the latest release from www.accusoft.com (the recommended approach).
    • Alternatively, licensing information (serial number, registration code and personal registration information) can be entered through the Visual Development Environment in response to the dialog display.

For more information on Runtime Licensing, see the Accusoft Pegasus website for more detailed information regarding Run Times and Deployment Licensing.

See Also

Trial Mode
Run Time Licensing
Software License Agreement
Getting Support


Run Time Licensing
See Also Send Feedback |
Licensing > Run Time Licensing

Glossary Item Box

Run Time Licensing

All copyrights to Accusoft Pegasus development kits and software are retained by Pegasus Imaging Corporation, DBA Accusoft Pegasus. ALL RIGHTS RESERVED. Your use of any of Accusoft Pegasus software or run-times created with Accusoft Pegasus software is allowed under license terms granted by Accusoft Pegasus. It is the Licensee's responsibility to honor the terms of such license grants.

Locking Mechanism

ISIS® Xpress™ contains a locking mechanism that does not permit you to distribute applications created with evaluation versions of ISIS Xpress. Prior to distributing an application that utilizes ISIS Xpress, you must purchase and enable run-time licensing. If the application will be delivered on the web, you must also purchase and enable web application licensing.

Obtaining Appropriate Licensing

The Licensee is required to purchase one copy of our development kit(s) for each developer in addition to obtaining the appropriate license agreement prior to deploying applications which contain Accusoft Pegasus code.

Accusoft Pegasus software applications and development tools are limited for use on a single CPU. Any run times or copies created must be granted by a direct license from Accusoft Pegasus. These "end user" licenses provide the terms and limits of number and usage.

All prospective customers have every opportunity to evaluate Accusoft Pegasus' products prior to purchasing. Product licensing is priced to cover what is considered to be normal (and even high) use. In addition, Accusoft Pegasus fully supports and warrants its code and pricing reflects those costs as well. The larger and more valuable an application deployment is, the higher the support and warranty risk is for Pegasus.

Review the licensing categories, and select the one that matches your deployment. Special circumstances should be discussed with a Accusoft Pegasus representative.

For more information on Run Time licensing, see the Accusoft Pegasus website for more detailed information regarding Run Times and Deployment Licensing.

See Also

www.accusoft.com
Getting Support
Development Mode
Software License Agreement
Distributing ISIS Xpress


Software License Agreement
See Also Send Feedback |
Licensing > Software License Agreement

Glossary Item Box

Software License Agreement

GRANT OF LICENSE

This Pegasus Imaging Corporation DBA Accusoft Pegasus ("PEGASUS") Agreement ("License") grants LICENSEE ("LICENSEE") a non-exclusive and non-transferable right to use one copy of a properly registered Pegasus Development Toolkit ("TOOLKIT") for development purposes on any single computer, provided the TOOLKIT is in use on only one computer at any time. TOOLKIT is "in-use" on a computer when it loads into temporary memory (that is, RAM) or installed into the permanent memory (that is, hard disk, CD-ROM, or other storage device) of that computer. The TOOLKIT is not to be used on a site-wide basis, via a server or other networked connection.

REDISTRIBUTION OF THE TOOLKIT RUNTIMES

PEGASUS does not grant LICENSEE any rights to deploy, license, sell or otherwise distribute runtime licenses with the TOOLKIT purchase, unless LICENSEE meets and adheres to the specific exemptions described on PEGASUS’ licensing web pages. For Runtime Licensing information, please visit our web site (www.accusoft.com/licensing.htm), or contact our sales staff. LICENSEE agrees to notify PEGASUS immediately of any violations or changes in status.

In the event that PEGASUS grants LICENSEE a right to use, reproduce, display or otherwise distribute or transfer copies of TOOLKIT runtimes, LICENSEE agrees to acknowledge and uphold the terms and conditions of this Agreement. In such events, LICENSEE may distribute TOOLKIT runtimes as part of the LICENSEE's software application or derivative works ("PRODUCT") upon agreeing to the following:

a) LICENSEE’s PRODUCT shall not compete to any degree with the TOOLKIT. Such competitive PRODUCTS are defined as imaging software development toolkits intended for use by application programmers and/or system integrators.

b) LICENSEE’s PRODUCT must be substantially greater in scope with greater functionality and features than those of the TOOLKIT.

c) LICENSEE will not use PEGASUS' name, logo, or trademarks to market PRODUCT without prior written approval of PEGASUS.

d) LICENSEE agrees to indemnify, hold harmless and defend PEGASUS from and against any claims or lawsuits, including attorney's fees, which arise or result from the use or distribution of PRODUCT.

e) LICENSEE agrees to only distribute the TOOLKIT runtimes. No license or other rights are granted to LICENSEE for any distribution of the TOOLKIT development kit, documentation, source code, or the distribution unlock codes.

f) LICENSEE will only distribute the TOOLKIT runtimes on the hardware and operating system(s) for which the TOOLKIT runtimes are intended to be used.

g) LICENSEE will include a statement substantially similar to the following within derivative work's documentation and about box: "This product contains portions of imaging code owned by Pegasus Imaging Corporation, Tampa, FL, (www.accusoft.com). ALL RIGHTS RESERVED."

If ANY of the above terms are not applicable to LICENSEE'S situation, any of the above cannot be complied with, or LICENSEE needs modifications to this license for any reason, LICENSEE shall contact PEGASUS about obtain an expanded direct license from PEGASUS for derivative works, (available by phone at: 813-875-7575, x321, by e-mail at: Sales@accusoft.com or by fax at: 813-875-7705).

In the event that LICENSEE distributes one or more unlicensed TOOLKIT runtimes, PEGASUS reserves the right to charge the LICENSEE up to ten times the normal license price for each unlicensed copy of PRODUCT. LICENSEE agrees and acknowledges that this pricing shall be deemed liquidated damages for such unlicensed distribution and not a penalty.

This license grants rights to LICENSEE for only the PEGASUS code (TOOLKIT) mentioned above and does not convey any other rights of use or distribution to PEGASUS technology.

INTELLECTUAL PROPERTY

LICENSEE recognizes and acknowledges the exclusive right of PEGASUS in and to all patents, trademarks, service marks, trade names, copyrights, and other intellectual property and proprietary rights in and to the TOOLKIT, and that such patents, trademarks, service marks, trade names, copyrights, and other intellectual property and proprietary rights are the sole and exclusive property of PEGASUS and protected by United States law and by international treaties.

LICENSEE may not remove or alter the copyright notice from any copy of the Software or any copy of the written materials, accompanying the Software.

LICENSEE waives its right to contest any of PEGASUS’ patents, trademarks, service marks, trade names, copyrights, and other intellectual property and proprietary rights in and to the TOOLKIT.

LICENSEE shall not use such trademarks, service marks, and trade names except where permitted under this Agreement without receiving PEGASUS’ prior written approval of such use. If such approval is granted, LICENSEE’s right to use such trademarks, service marks, and trade names shall end upon the termination of this Agreement.

OTHER RESTRICTIONS

This PEGASUS License Agreement is LICENSEE's proof of license to exercise the rights granted herein and must be retained by LICENSEE.

LICENSEE may not rent, lease or transfer TOOLKIT or parts thereof. LICENSEE may not alter, modify, reverse engineer, decompile or disassemble TOOLKIT in any way or manner.

NO WARRANTY

ANY USE BY LICENSEE OF THE SOFTWARE IS AT THE LICENSEE'S OWN RISK. THE SOFTWARE IS PROVIDED FOR USE "AS IS" WITHOUT WARRANTY OF ANY KIND. TO THE MAXIMUM EXTENT PERMITTED BY LAW, PEGASUS DISCLAIMS ALL WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, PERFORMANCE RESULTS AND NONINFRINGEMENT. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE TOOLKIT IS WITH LICENSEE. PEGASUS IS NOT OBLIGATED TO PROVIDE ANY UPDATES TO THE SOFTWARE.

NO LIABILITY FOR DAMAGES

In no event shall PEGASUS be liable for any damages whatsoever (including, without limitation, incidental, special, direct, indirect and consequential damages, damages for loss of business profits, lost savings, business interruption, loss of business information, or other pecuniary loss) arising out of the use or inability to use this PEGASUS product, even if PEGASUS has been advised of the possibility of such damages. Because some states/countries do not allow the exclusion or limitation of liability for consequential, incidental or special damages, the above limitation may not apply to LICENSEE. In such states/countries and to the extent possible, any warranty is limited to thirty (30) days.

INDEMNIFICATION BY LICENSEE

If LICENSEE distributes TOOLKIT in violation of this Agreement, LICENSEE agrees to indemnify, hold harmless and defend PEGASUS and its suppliers from and against any claims or lawsuits, including attorney's fees that arise or result from the use or distribution of TOOLKIT in violation of this Agreement.

TERM AND TERMINATION

Unless otherwise agreed to by the parties, this Agreement shall become effective upon LICENSEE’s installation of the TOOLKIT and shall continue in full force and effect until terminated in accordance with the terms set forth in this Agreement.

Any material breach of this Agreement shall automatically and immediately terminate this Agreement. In the event that LICENSEE ceases to do business or is adjudged bankrupt or insolvent, PEGASUS may, at its sole option, terminate this Agreement, by giving ten (10) Business Days written notice of such termination, which notice shall identify and describe the basis for such termination.

In the event of any termination of this Agreement, LICENSEE shall stop using the TOOLKIT, manufacturing the PRODUCT and, if such distribution rights were granted by Pegasus, distributing the PRODUCT containing the TOOLKIT runtime licenses. LICENSEE shall also require its resellers, OEMs, and other distribution channels (if any) to likewise stop manufacturing and Distributing the PRODUCT. Within ten (10) Business Days thereafter, LICENSEE shall return or, at PEGASUS’ option, destroy the TOOLKIT and all copies in whole or in part thereof, whether or not incorporated in or with the PRODUCT, and within LICENSEE's possession, custody and control, and shall certify to PEGASUS in writing within ten (10) Business Days thereafter that it has complied with the foregoing obligation.

The portions entitled Intellectual Property, No Warranty, No Liability for Damages, Indemnification by Licensee, and Miscellaneous shall continue in full force and effect, notwithstanding any such termination of this Agreement.

MISCELLANEOUS

This Agreement constitutes the entire understanding and agreement between PEGASUS and LICENSEE regarding its subject matter, and supercedes all previous oral and written communications, agreements, memoranda, representations, or understandings between PEGASUS and LICENSEE regarding this Agreement. No other rights or licenses are granted to LICENSEE, except as expressly provided herein.

This Agreement shall not be amended, altered, changed or modified in any way, unless agreed to in writing by both PEGASUS and LICENSEE. Such writing must be executed by a duly authorized representative of PEGASUS and a duly authorized representative of LICENSEE.

This Agreement is not transferable or assignable by LICENSEE under any circumstances, without the prior written consent of PEGASUS. PEGASUS will not unreasonably withhold such consent. This agreement shall be binding upon, and is made for the benefit of, each party, its successors, and permitted assignees (if any). For the purposes of this Agreement, any change in control of LICENSEE shall constitute an assignment or transfer of this Agreement. As used in this section, a change in control is defined as (i) any change in ownership of more than fifty percent (50%) of the voting interest in LICENSEE, whether by merger, purchase, foreclosure of a security interest or other transaction, or (ii) a sale of all or substantially all of the assets of LICENSEE.

The relationship established by this Agreement between LICENSEE and PEGASUS shall be that of Licensor and Licensee. Nothing contained in this Agreement shall be construed as creating a relationship of agency, joint venture or partnership between LICENSEE and PEGASUS. Neither party shall have any right whatsoever to incur any liabilities or obligations on behalf of the other party.

The laws of the State of Florida shall govern this Agreement, excluding that body of law known as conflict of laws and the United Nations Convention on Contracts for the Sale of Goods. Any action or proceeding brought by either party against the other arising out of, or related to, this Agreement shall be brought only in a state or federal court of competent jurisdiction located in the State of Florida and the parties hereby consent to the personal jurisdiction of said courts.

The program and data contained in this TOOLKIT Product are provided with Restricted Rights. Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in FAR 52.227-14 (Alternate III) or subparagraph (c)(1)(II) of the rights in technical data and computer software clause at 252.227-7013. Manufacturer is Pegasus Imaging Corporation, 4001 Riverside Drive, Tampa, FL, USA 33603.

In the event that any provision of this Agreement is found invalid or unenforceable pursuant to a judicial decree or decision, the remainder of this Agreement shall remain valid and enforceable according to its terms.

PEGASUS’ failure to perform any term or condition of this Agreement as a result of conditions beyond its control such as, but not limited to, war, strikes, fires, floods, acts of God, governmental restrictions, power failures, or damage or destruction of any network facilities or servers, shall not be deemed a breach of this Agreement.

In the event of suit or any legal action due to any breach of this Agreement is commenced to enforce this Agreement or otherwise relating to this Agreement, the prevailing party shall be entitled to all attorneys’ fees and costs incurred in connection therewith.

The headings provided in this Agreement are for convenience and reference purposes only. In the event of a conflict between the terms and conditions listed in this Agreement, and the attached Schedules, the terms and conditions shall govern.

A waiver of a breach, violation, or default under this Agreement shall not be a waiver of any subsequent breach, violation or default. Failure of either party to enforce compliance with any term or condition of this Agreement shall not constitute a waiver of such term or condition.

All notices and communications shall be in writing and shall be deemed to have been duly given when delivered or three (3) Business Days after mailing by certified mail, return receipt requested, postage prepaid, addressed to the parties at their respective addresses set forth on the Order Form or at such other addresses as the parties may designate by written notice in accordance with this section.

For questions concerning this Agreement, or to contact PEGASUS for any reason, please contact Pegasus Imaging Corporation by phone at 1-813-875-7575 x321 or email Sales@accusoft.com.

See Also

Trial Mode
Development Mode
Run Time Licensing
Distributing ISIS Xpress


Verify You're Using the Latest Service Pack
See Also Send Feedback |
Distributing Applications & Deployment > Verify You're Using the Latest Service Pack

Glossary Item Box

Verify You're Using the Latest Service Pack

Service pack updates will not overwrite paid licensing. Your paid licensing will continue to work and you will not be required to re-enter your purchased registration codes. Service pack updates do not include any changes that might "break" previously developed and/or deployed code.

Verify Latest Development Components

To verify you are using the latest version of an Accusoft Pegasus Development Component or Components, please use the PegConnect utility program. Please note that a Help File for each product may be found on the Start Bar under Accusoft, or in C:\Windows\Help.

PegConnect is installed by all component product installers and is accessible through the Windows Start menu: Start | Programs | Accusoft | Common | Utilities

PegConnect Allows You To:

  1. Check with Accusoft Pegasus via online connection and verify that the installed version of the component includes all the most recent updates.
  2. Update to the latest version automatically with your permission.
  3. Determine if a control is registered or unregistered on the machine.
  4. Easily change the registration status from registered to non-registered, or non-registered to registered.

Alternatively, you can see the currently released product build numbers at www.accusoft.com/latestbuilds.htm.

If you require further assistance or have questions or comments, please see the topic on Getting Support for more detailed information.

See Also

Getting Support
Installing on a Development Machine


Distributing ISIS Xpress

Accusoft.ISISXpress4.Net | Accusoft Pegasus
Distributing ISIS Xpress
See Also Send Feedback |
Distributing Applications & Deployment > Distributing ISIS Xpress

Glossary Item Box

Distributing ISIS® Xpress™

There are a number of EMC Corporation's ISIS PixTools files that must be installed according to the target system. There is a EMC Corporation's ISIS PixTools PixTran subdirectory in the directory where ISIS Xpress was installed. The PixTran subdirectory contains four subdirectories that include all the necessary EMC Corporation's ISIS PixTools files. The directories are:

  • PixTran – Install these files to the target windows\pixtran directory.
  • Sysdir – Install these files to the target windows\system directory (windows\system32 if the target is WinNT, 2000, or XP).
The above files should be installed in the specified order.

DLL File to Distribute

The following file must be distributed with the application that uses the ISIS Xpress .NET control:

  • Accusoft.ISISXpress4.Net.dll

See Also

Getting Support
Installing on a Development Machine
Development Mode
Run Time Licensing
Software License Agreement
Verify You're Using the Latest Service Pack


Overview of ISIS Xpress

Accusoft.ISISXpress4.Net | Accusoft Pegasus
Overview of ISIS Xpress
Send Feedback |
Concepts > Overview of ISIS Xpress

Glossary Item Box

Overview of ISIS® Xpress™

Basic Scanning

There are only a few steps required for basic scanning; unlocking the ISIS Xpress control, creating the ISIS Xpress object, unlocking the run time, setting the output path and filename, and invoking the ScanSingle method.
IsisXpress isis = new IsisXpress();
isis.Licensing.UnlockRuntime(12345, 12345, 12345, 12345);
isis.Output.Filename = "C:\temp\image.tif";
isis.Scanner.ScanSingle();

Scanner Settings

ISIS Xpress also provides properties for scanner settings and naming schemes for batch scanning.
All settings are accessed based on the value of the Setting.ScanSetting property. This property uses the ScanSettingInfo enumeration which has the following values:

XResolution = 0,
YResolution = 1,
PageSize = 2,
Brightness = 3,
Contrast = 4,
XPosition = 5,
YPosition = 6,
ImageWidth = 7,
ImageLength = 8,
ResUnit = 9,
Source = 10,
ScanAhead = 11,
ScanAheadMaxPages = 12,
ScanAheadPages = 13,
SamplesPerPixel = 14,
BitsPerSample = 15,
AdvancedTag =16

This property must be set before a scanner setting can be queried or set.
The following code could be used to set the scanner mode to 256-level gray scale.
isis.Scanner.Setting.ScanSetting = ScanSettingInfo.SamplesPerPixel;
isis.Scanner.Setting.Long = 1;
isis.Scanner.Setting.ScanSetting = ScanSettingInfo.BitsPerSample;
isis.Scanner.Setting.Long = 8;

The following code could be used to set the Brightness for the scanner.

isis.Scanner.Setting.ScanSetting = ScanSettingInfo.Brightness;
isis.Scanner.Setting.Long = 23;

Not all settings have an integer setting such as Brightness. The ScanSettingInfo.PageSize property is usually a string and must be set with the Setting.StringValue property. For Example:

isis.Scanner.Setting.ScanSetting = ScanSettingInfo.PageSize;
isis.Scanner.Setting.String = "scanner’s maximum";

The Setting.DataType property can be used to determine the setting type. This property uses the DataTypeInfo enumeration which has the following values.

RangeLong = 0,
ListLong = 1,
ListString = 2,
String = 3,
Long = 4,
Rational = 5,
ListRational = 6,
RangeRational = 7

Scanner settings can vary widely between different kinds of scanners. For this reason it is important to know what values are legal for a particular setting. ISIS® Xpress provides several properties to query the available choices for a setting.

If the Setting.DataType property equals RangeLong or RangeRational for a setting, then the following properties are used to determine what range of values is legal.

For Long values:

Setting.RangeMinimumLong
Setting.RangeMaximumLong

For Rational values:

Setting.RangeMinimumRational
Setting.RangeMaximumRational

Any value between and including the Min and Max values can be set to the Setting.LongValue or Setting.RationalValue property for this setting. A Long range of choices is the typical Setting.DataType for the following scanner settings:

ScanSettingInfo.Brightness
ScanSettingInfo.Contrast
ScanSettingInfo.XPosition
ScanSettingInfo.YPosition
ScanSettingInfo.ImageWidth
ScanSettingInfo.ImageLength
ScanSettingInfo.ScanAhead
ScanSettingInfo.ScanAheadMaxPages

If the Setting.DataType property equals DataTypeInfo.ListLong, DataTypeInfo.ListString, or DataTypeInfo.ListRational, then the possible values for the setting are contained in a list and can be queried with these properties:

Setting.ListLong
Setting.ListString
Setting.ListRational

Setting.ListLong, Setting.ListString, and Setting.ListRational are property arrays where the Index value can be from 0 to Setting.ListCount – 1. Setting.ListLong or Setting.ListString are the typical Setting.DataType for the following scanner settings:

ScanSettingInfo.XResolution
ScanSettingInfo.YResolution
ScanSettingInfo.PageSize

Advanced Tags

The component supports Advanced Tags, which offers developers great flexibility in utilizing scanner specific features. These are scanner processing instructions which are provided as parameters passed as tag values to the control, and consequently passed directly through to the scanner. Assuming the correct tags are passed to the scanner, they will instruct the scanner what actions to take.

The following methods and properties are used with advanced tags:

Methods:

LongDefault - Gets a long value at the specified index in the list of long values for the default scan setting.

RationalDefault - Gets a rational value at the specified index in the list of rational values for the default scan setting.

StringDefault - Gets a string value for the default scan setting.

Properties:

Advanced - Gets and sets the advanced tag number.

Batch Scanning

ISIS Xpress provides the Scanner.ScanBatch method for batch scanning. Scanners that have a document feeder will scan until the feeder is empty or until the Scanner.Cancel method is called. ISIS Xpress will generate a FeederEmpty event when the feeder is empty. ISIS Xpress also generates a Scanning and Scanned event for each page that is scanned. The Scanning event can be used to modify the filename before the scan takes place. Scanners without a document feeder trigger a FeederEmpty event before each page is scanned, allowing the user to cancel the operation.

After issuing the Scanner.ScanBatch method, ISIS Xpress will continue to scan images for the device until the StopScan parameter of the FeederEmpty event is set to true or the method Scanner.Cancel is called. The FeederEmpty event is the correct place to pop up a dialog or message box asking the user to load the scanner, cancel the operation, load a new batch, etc.

Naming Schemes

ISIS Xpress provides properties to generate filenames for use with batch scanning. The following properties are used:

Output.UseSchema
Output.Root
Output.Directory
Output.FileSchema

The Output.UseSchema property must be set to true before ISIS Xpress will generate filenames. Once set to true, the other properties are used to generate a file name. For example, if you want the filenames to be C:\Docs\File001.tif, C:\Docs\File002.tif, etc., these are the correct settings:

Output.Root = "File";
Output.Directory = "C:\Docs";
Output.FileSchema = "$###" ;

For the Output.FileSchema property, the "$" symbol represents the Output.Root, and the "#" represents the page number. The number of #’s used determines the number of leading 0’s to use in the filename. For example, "$##" generates File01.tif, while "$####" generates File0001.tif. Any extra $ symbols are ignored; "$###" is equivalent to "$$$###".

During batch scanning, a Scanning event is fired before each page is scanned. At this time the Output.Filename property will be equal to the filename used for that page. The user can change the Output.Filename property at this time if desired.

Memory Images

ISIS Xpress can generate a memory image at the time of scanning by setting the Output.CreateDib property to true. If this property is set to true, the image becomes valid in the Scanned event. The image can then be obtained using the ToHdib, ToHBitmap or ToBitmap methods and passed to another control such as Accusoft Pegasus' ImagXpress. It is possible to only use memory images by setting the image to true and the Output.CreateFiles property to false . In this case, nothing is saved to disk, only to memory. This can provide faster operation if you wish the user to be able to view and modify the image before saving. In such a case, you would pass the image to the ImagXpress control, and then the ImagXpress control would save the file after acceptance.

The image can only be read once per scan. Subsequent reads will throw a DibUnavailableException.

Dependencies

There are a number of EMC Corporation's ISIS PixTools files that must be installed according to the target system. There is a PixTran subdirectory in the directory where ISIS Xpress was installed. The PixTran subdirectory contains four subdirectories that include all the necessary EMC Corporation's ISIS PixTools files. The directories are:

PixTran – Install these files to the target windows\pixtran directory.
Sysdir – Install these files to the target windows\system directory (windows\system32 if the target is WinNT, 2000, or XP).

The above files should be installed in the specified order.


Glossary

Accusoft.ISISXpress4.Net Accusoft Pegasus
Glossary
Send Feedback

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

A

Aspect Ratio
There are two kinds of aspect ratio that you need to be aware of when working with 2D images; the image aspect ratio and the pixel aspect ratio.The image aspect ratio is the ratio of the width of the image to the height of the image. It's important when resizing an image to keep this ratio as close to unchanged as possible or the image may become distorted.The pixel aspect ratio is the shape of the pixels in the image. For computers this is normally square (1:1) or close to it depending on the monitor settings. For some video sources, however, the pixels may be slightly rectangular.

B

BMP
The Microsoft Windows Bitmap file format is based on the Microsoft Windows internal bitmap data structures. The BMP format is very widely used and it is quick and easy to read. Although most BMP files are uncompressed, a type of run length encoding is supported.

BPP
Bits per pixel

C

CCITT
CCITT is the most widely used compression scheme for transmitting binary (black and white) image data. CCITT was established by the International Telegraph and Telephone Consultative Committee. The Group 3 and Group 4 CCITT compression standards are widely used for transmitting fax data. CCITT compressed images are typically stored in the TIFF image format.

D

DCX
An image format containing multiple PCX images. A DCX file can contain a maximum of 1024 images.

DDB
Microsoft Device Dependent Bitmap. The actual in-memory information used to display an image.

DEP
Data Execution Prevention (computer security)

DIB
Microsoft Device Independent Bitmap. An alternative file extension used by the Microsoft Windows Bitmap.

Dispose
Releases the resources used by the Component.

F

Float
Denotes a simple type that stores 32-bit floating-point values.

G

GIF
Graphical Interchange File, originally developed by CompuServe as a machine independent format. GIF is one of the most popular image formats for storing 8-bit digitized images. GIF files are typically smaller than uncompressed formats like BMP due to the LZW compression algorithm that GIF uses.

Grey-scale
If the pixels of a grey-scale image have N bits, they may take values from zero, representing black up to 2^N-1, representing white with intermediate values representing increasingly light shades of grey. If N=1, the image is not called grey-scale, but could be called monochrome.

H

Halftone
Pertaining to pictures in which gradation of tone in the photograph is reproduced by a graduated system of dotted and checkered spots, usually nearly invisible to the unaided eye, produced by the interposition between the camera and the object of a screen. The name alludes to the fact that this process was the first that was practically successful in reproducing the half tones of the photograph.

I

ICO
Microsoft Windows Icon file format.

Inverse
To reverse something or change it to its opposite. For example, to invert the colors on a monochrome display means to change light to dark and dark to light. In a digital electrical signal, to replace a high level by a low level and vice versa. This type of operation is the electronic equivalent of a Boolean NOT operation.

J

JIF
An alternative image file extension used for a JFIF compliant JPEG file. Because many early versions of JPEG contained a JPG extension but did not adhere to the JFIF specifications, the JIF extension was created to identify JPEG files that are JFIF compliant. As the popularity of JPEG grew, JFIF compliance became synonymous with the JPG extension and thus the JIF extension is rarely used.

JPEG
The JPEG (Joint Photographic Experts Group) standard is one of the most important image data compression standards. It is widely used in many industries including graphic arts, desktop publishing, medical imaging, and many more. It is also becoming one of the most widely used image formats on the Internet. Although JPEG supports a lossless mode, it most commonly uses lossy compression. This allows JPEG to achieve very high compression ratios. JPEG compression uses several compression modes. First, an image is transformed to the frequency domain using the discrete cosine transform. The smaller valued frequency components are discarded leaving only the larger valued components. The remaining components are DPCM coded and then Huffman coded. Fortunately, ImagXpress™ handles all of this for you! The compression level is adjustable. Higher quality settings produce a larger image file size with higher image quality. Lower quality settings produce a smaller image file size with lower image quality. Typically, we have found that compression ratios of 10:1 or 15:1 (A 640x480x24-bit image is 921,600 bytes; a 15:1 compressed image would compress to only 61k) produce generally acceptable image quality for photographic type images. Images compressed at higher ratios begin to show more noticeable and sometimes objectionable artifacts and clarity loss. JPEG is a 24-bit format and works only with 24-bit images. If you compress an 8-bit image, ImagXpress™ automatically converts it to 24-bit to do the compression, however, you will obtain better quality when the source image is 24-bit because 8-bit images only contain 256 colors. JPEG works best with photographic type images. It does not work well with solid colors, 16-color images, cartoon like images, or drawings. Progressive JPEG is a multiple-scan sequential JPEG format that is becoming popular on the Internet for the ability to display images in progressively clearer segments.

L

Little-endian
Describes a computer architecture in which, within a given 16- or 32-bit word, bytes at lower addresses have lower significance (the word is stored "little-end-first"). The PDP-11/VAX families of computers, Intel microprocessors, plus a lot of communications and networking hardware are little-endian. The term is sometimes used to describe the ordering of units other than bytes; most often, bits within a byte.

Luminance
One of the 3 components of the HSL (Hue, Saturation and Luminance) color space. Luminance controls the overall brightness of an image.

LZW
Lempel-Ziv-Welch (algorithm)

P

PBM
Portable bitmap image format, a very simple uncompressed 1-bit (black and white) image format. Data can be stored in either binary or ASCII format.

PGM
Portable Graymap image format. PGM is a very simple uncompressed 8-bit grayscale image format. Data can be stored in either binary or ASCII format.

PNG
Portable Network Graphics (pronounced "ping") provides a portable, legally unencumbered (royalty-free), well-compressed, well-specified standard for lossless bitmapped image files. The initial motivation for developing PNG was to provide a royalty-free alternative to GIF. The design retains many of the features of GIF that make it an attractive format for transmission of images, such as lossless compression and progressive display capabilities. Additionally, it provides several advantages including 24-bit image support and generally better compression, although decompression is typically somewhat slower than GIF. PNG's success will be ultimately determined by its acceptability on the Internet. At the time of this writing, however, PNG has not been incorporated as part of the major Internet browsers.

PPM
Portable Pixmap image format, a very simple uncompressed 24-bit image format. Data is stored in RGB triplets and can be stored in either binary or ASCII format.

R

RGB
Red, Green Blue. Bitmapped images are most generally stored as RGB data. Each pixel or data point in a true color (24-bit) image contains 3 components, red, green and blue, that describe the color of the pixel. Each of the components can have a value between 0 and 255, 0 being the darkest shade of color and 255 being the lightest shade of color. Since each component can be stored in one byte (8-bits), the 3 components take up 3 bytes or 24-bits per pixel. 8-bit images contain one byte (8-bit) indexes for each pixel that map to a color table called a palette which contains a maximum of 256 RGB entries. Likewise, 4-bit images contain 4-bit indexes for each pixel that map to a palette which contains a maximum of 16 RGB entries. 1-bit images contain 1-bit per pixel. Each bit in a 1-bit image represents either black or white.

RLE
RLE stands for Run Length Encoding. It is a lossless algorithm that only offers decent compression ratios in specific types of data.

T

TGA
Targa Image File) format was developed by TrueVision for its Targa line of products. TGA is one of the earliest image formats and was the first popular format to support 24-bit color. TGA supports uncompressed and RLE compressed formats.

TIFF
Tag Image File Format, originally released by Aldus Corporation is a standard file format found in most paint, imaging, and desktop publishing programs. TIFF is extremely powerful, flexible, and extensible. However, because of its many nuances and its wide scope, TIFF can be a difficult format to understand as well as a difficult format to support. ImagXpress™ supports a wide range of TIFF 6.0 formats including uncompressed, CCITT RLE, CCITT Group 3 Fax, CCITT Group 4 Fax, LZW, Pack Bits, JPEG, and deflate compression types. ImagXpress™ supports black and white, RGB, and RGB palette images but it does not support transparency mask, CMYK, YCbCr, or CIELab.

TWAIN
TWAIN (Technology Without An Interesting Name) is a standard for controlling and acquiring image data from raster-generating devices such as scanners, digital cameras, and video digitizers. Manufacturers write the TWAIN driver (called the Source) for their device. Applications that are TWAIN compliant can be used with any TWAIN compliant Source. Likewise, a TWAIN compliant Source can be used with any TWAIN compliant application. Applications that you build with ImagXpress™ can be used to interface TWAIN compliant Sources to acquire image data. TWAIN compliant applications should provide the following: The capability to select the Source. This is required because you may have more than one TWAIN device connected to a computer. Use the TWAINSelect method to select the source. The ability to acquire image data. Use the TWAINAcquire method to acquire the image data. If Accusoft Pegasus' TWAIN Acquire method is successful, the image data is converted to a DIB and the control's hDIB property is set to the resulting DIB handle. Once the image is acquired, you may use any of the image processing methods to alter or save the DIB. The TWAIN sample in the SAMPLES directory and the ImagXpress™ Demo application demonstrate how easy it is to add TWAIN support to your applications.

twip
Twips describe the sizes of characters produced by dot matrix printers, which were constrained to multiples of either 12 or 10 dots per inch.

W

Wintel
A term describing the combination of Microsoft Windows operating system running on PCs with Intel or compatible processors. Dominance of the wintel platform began with MS-DOS on PCs with Intel's 8-bit 8088 processors in 1979.

WMF
The Microsoft Windows Metafile format is used to store vector and bitmap image data. Because of its popularity and wide use, many Windows and non-Windows applications support WMF.

X

XP
Microsoft says the Windows "XP" designation originates from the word "experience". Windows XP brings many features previously available only in the server- and workstation-oriented Windows NT and Windows 2000 families, such as greater stability and efficiency due to its pure 32-bit kernel, instead of the hybrid 16-bit/32-bit kernel in prior consumer versions of Windows. (The version number of Windows XP is 5.1 just as Windows 2000 was version 5.0, to denote two OS as descendants of Windows NT 4.0.)


Accusoft.ISISXpressSdk Namespace

Accusoft Pegasus
Accusoft.ISISXpress4.Net
Accusoft.ISISXpressSdk Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | CancelException | This class implements the CancelExceptions to throw when a cancel is performed.
Class | ConfigFileException | This class implements the ConfigFileExceptions to throw when there is a problem with the configuration file.
Class | DibUnavailableException | This class implements the DibUnavailableExceptions to throw when the DIB (Device Independent Bitmap) is not available.
Class | DriverAndScanner | This class is the element type of the DriverAndScannerList class. It holds a DriverName and ScannerModel available for use in ISISXpress.
Class | DriverAndScannerList | This class implements a list of available ISIS drivers and scanner models.
Class | FeederEmptyEventArgs | This class implements the event arguments for the IsisXpress.FeederEmpty event.
Class | GeneralIsisException | This class implements the GeneralIsisExceptions thrown when there is a general ISIS issue.
Class | InvalidLicenseException | This class implements the InvalidLicenseExceptions thrown when the license key is invalid.
Class | InvalidSchemaException | This class implements the InvalidSchemaExceptions when the filename schema is invalid.
Class | InvalidSettingException | This class implements the InvalidSettingExceptions when there is an invalid scanner setting.
Class | IsisDriverException | This class implements ISIS driver exceptions.
Class | IsisXpress | This class is the main controller for the ISIS Xpress component.
Class | IsisXpressLibraryException | This class implements application exceptions.
Class | Licensing | This class implements the licensing for the ISIS Xpress component.
Class | OutOfMemoryException | This class implements the OutOfMemoryExceptions to be thrown when there is not enough memory available.
Class | OutOfRangeException | This class implements the OutOfRangeExceptions when a parameter or index is out of range.
Class | Output | This class implemented how scanned images are saved.
Class | ProgressEventArgs | This class implements the event arguments for the IsisXpress.Progress event.
Class | RationalType | This class implements a rational number with the numerator and denominator stored in their normal form.
Class | SaveTypeException | This class implements the SaveTypeExceptions to throw when there is a problem with the save type.
Class | ScannedEventArgs | This class implements the event arguments for the IsisXpress.Scanned event.
Class | Scanner | This class implements the specific Scanner settings, methods and properties.
Class | ScannerLoadedException | This class implements the ScannerLoadedExceptions.
Class | ScanningEventArgs | This class implements the event arguments for the IsisXpress.Scanning event.
Class | SequenceException | This class implements the SequenceExceptions to throw when there is a sequence problem.
Class | Setting | This class implements the scanner settings.
Class | SettingUnavailableException | This class implements the SettingUnavailableException to throw when the setting is not available.
Class | StringTooLongException | This class implements the StringToolLongExceptions when the string is too long.

Delegates

 | Delegate | Description
Delegate | IsisXpress.FeederEmptyEventHandler | Indicates that the scanner feeder is empty.
Delegate | IsisXpress.ProgressEventHandler | Indicates how much of the scan has completed. If the Scanner.UseCompression property is true then the Progress event is not fired during the scan.
Delegate | IsisXpress.ScannedEventHandler | Fired after a scan to allow the user to check or set the Output.ToHdib property.
Delegate | IsisXpress.ScanningEventHandler | Fired before a scan to allow the user to check or modify the Output.Filename property.

Enumerations

 | Enumeration | Description
Enumeration | DataTypeInfo | Option values for the data type the information is encoded in for the current scanner setting.
Enumeration | ErrorLevelInfo | Option values to set the error level to use.
Enumeration | EvaluationChoice | Option values for licensing the evaluation version within the component.
Enumeration | FileTypeInfo | Option values for the file format to use when saving images.
Enumeration | ScanAhead | Option values for determining the scan ahead settings.
Enumeration | ScanSettingInfo | Option values for determining which scanner setting to query or set.
Enumeration | SetupOptions | Option values to modify what is displayed by the predefined scanner settings dialog.
Enumeration | Source | Option values to set the scanning source information.

See Also

Reference

Accusoft.ISISXpress4.Net Assembly


Accusoft.ISISXpressSdk Namespace Inheritance Hierarchy

Accusoft Pegasus
Accusoft.ISISXpressSdk Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Accusoft.ISISXpressSdk.DriverAndScanner
Accusoft.ISISXpressSdk.Licensing
Accusoft.ISISXpressSdk.Output
Accusoft.ISISXpressSdk.RationalType
Accusoft.ISISXpressSdk.Scanner
Accusoft.ISISXpressSdk.Setting
System.Collections.Generic.List<DriverAndScanner>
Accusoft.ISISXpressSdk.DriverAndScannerList
System.EventArgs
Accusoft.ISISXpressSdk.FeederEmptyEventArgs
Accusoft.ISISXpressSdk.ProgressEventArgs
Accusoft.ISISXpressSdk.ScannedEventArgs
Accusoft.ISISXpressSdk.ScanningEventArgs
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.CancelException
Accusoft.ISISXpressSdk.ConfigFileException
Accusoft.ISISXpressSdk.DibUnavailableException
Accusoft.ISISXpressSdk.GeneralIsisException
Accusoft.ISISXpressSdk.InvalidLicenseException
Accusoft.ISISXpressSdk.InvalidSchemaException
Accusoft.ISISXpressSdk.InvalidSettingException
Accusoft.ISISXpressSdk.IsisDriverException
Accusoft.ISISXpressSdk.OutOfMemoryException
Accusoft.ISISXpressSdk.OutOfRangeException
Accusoft.ISISXpressSdk.SaveTypeException
Accusoft.ISISXpressSdk.ScannerLoadedException
Accusoft.ISISXpressSdk.SequenceException
Accusoft.ISISXpressSdk.SettingUnavailableException
Accusoft.ISISXpressSdk.StringTooLongException
System.MarshalByRefObject
System.ComponentModel.Component
Accusoft.ISISXpressSdk.IsisXpress

See Also

Reference

Accusoft.ISISXpress4.Net Assembly


CancelException Class

[image] Accusoft Pegasus
CancelException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : CancelException Class

This class implements the CancelExceptions to throw when a cancel is performed.

Object Model

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public NotInheritable Class CancelException
   Inherits IsisXpressLibraryException
Visual Basic (Usage) Copy Code
Dim instance As CancelException
C#
[SerializableAttribute()]
public sealed class CancelException : IsisXpressLibraryException
Managed Extensions for C++
[SerializableAttribute()]
public __gc __sealed class CancelException : public IsisXpressLibraryException
C++/CLI
[SerializableAttribute()]
public ref class CancelException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.CancelException

See Also

Reference

CancelException Members
Accusoft.ISISXpressSdk Namespace


CancelException Class Members

CancelException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : CancelException Class

The following tables list the members exposed by CancelException.

Public Constructors

 | Name | Description
Public Constructor | CancelException Constructor | Overloaded. The main constructor for the CancelException class to throw when a cancel is performed.
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CancelException Class
Accusoft.ISISXpressSdk Namespace


CancelException Class Methods

CancelException Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : CancelException Class

For a list of all members of this type, see CancelException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CancelException Class
Accusoft.ISISXpressSdk Namespace


CancelException Class Properties

CancelException Class Properties
Accusoft.ISISXpressSdk Namespace : CancelException Class

For a list of all members of this type, see CancelException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CancelException Class
Accusoft.ISISXpressSdk Namespace


CancelException Constructor

CancelException Constructor
Accusoft.ISISXpressSdk Namespace > CancelException Class : CancelException Constructor

The main constructor for the CancelException class to throw when a cancel is performed.

Overload List

Overload | Description
CancelException Constructor() | The main constructor for the CancelException class to throw when a cancel is performed.
CancelException Constructor(Int32) | A CancelException which allows passing in an error number.
CancelException Constructor(Int32,String) | A CancelException which allows passing in an error number and an error message.
CancelException Constructor(String) | A CancelException which allows passing in an error message.
CancelException Constructor(String,Exception) | A CancelException which allows passing in an error message and an inner exception.

See Also

Reference

CancelException Class
CancelException Members


CancelException Constructor()

CancelException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > CancelException Class > CancelException Constructor : CancelException Constructor()

The main constructor for the CancelException class to throw when a cancel is performed.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CancelException()
C#
public CancelException()
Managed Extensions for C++
public: CancelException();
C++/CLI
public:
CancelException();

See Also

Reference

CancelException Class
CancelException Members
Overload List


CancelException Constructor(Int32)

CancelException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > CancelException Class > CancelException Constructor : CancelException Constructor(Int32)

errorNumber
An integer which represents the error number.
A CancelException which allows passing in an error number.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer

Dim instance As CancelException(errorNumber)
C#
public CancelException(
   int errorNumber
)
Managed Extensions for C++
public: CancelException(
   int errorNumber
)
C++/CLI
public:
CancelException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

CancelException Class
CancelException Members
Overload List


CancelException Constructor(Int32,String)

CancelException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > CancelException Class > CancelException Constructor : CancelException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string value which represents the error message.
A CancelException which allows passing in an error number and an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer
Dim message As String

Dim instance As CancelException(errorNumber, message)
C#
public CancelException(
   int errorNumber,
   string message
)
Managed Extensions for C++
public: CancelException(
   int errorNumber,
   string* message
)
C++/CLI
public:
CancelException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string value which represents the error message.

See Also

Reference

CancelException Class
CancelException Members
Overload List


CancelException Constructor(String)

CancelException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > CancelException Class > CancelException Constructor : CancelException Constructor(String)

message
A string value which represents the error message.
A CancelException which allows passing in an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As CancelException(message)
C#
public CancelException(
   string message
)
Managed Extensions for C++
public: CancelException(
   string* message
)
C++/CLI
public:
CancelException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

CancelException Class
CancelException Members
Overload List


CancelException Constructor(String,Exception)

CancelException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > CancelException Class > CancelException Constructor : CancelException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
A CancelException which allows passing in an error message and an inner exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As CancelException(message, innerException)
C#
public CancelException(
   string message,
   Exception innerException
)
Managed Extensions for C++
public: CancelException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
CancelException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

CancelException Class
CancelException Members
Overload List


ConfigFileException Class

ConfigFileException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : ConfigFileException Class

This class implements the ConfigFileExceptions to throw when there is a problem with the configuration file.

Object Model

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public NotInheritable Class ConfigFileException
   Inherits IsisXpressLibraryException
Visual Basic (Usage) Copy Code
Dim instance As ConfigFileException
C#
[SerializableAttribute()]
public sealed class ConfigFileException : IsisXpressLibraryException
Managed Extensions for C++
[SerializableAttribute()]
public __gc __sealed class ConfigFileException : public IsisXpressLibraryException
C++/CLI
[SerializableAttribute()]
public ref class ConfigFileException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.ConfigFileException

See Also

Reference

ConfigFileException Members
Accusoft.ISISXpressSdk Namespace


ConfigFileException Class Members

ConfigFileException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : ConfigFileException Class

The following tables list the members exposed by ConfigFileException.

Public Constructors

 | Name | Description
Public Constructor | ConfigFileException Constructor | Overloaded. The main constructor for the ConfigFileException to throw when there is a problem with the configuration file.
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ConfigFileException Class
Accusoft.ISISXpressSdk Namespace


ConfigFileException Class Methods

ConfigFileException Class Methods
Accusoft.ISISXpressSdk Namespace : ConfigFileException Class

For a list of all members of this type, see ConfigFileException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ConfigFileException Class
Accusoft.ISISXpressSdk Namespace


ConfigFileException Class Properties

ConfigFileException Class Properties
Accusoft.ISISXpressSdk Namespace : ConfigFileException Class

For a list of all members of this type, see ConfigFileException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ConfigFileException Class
Accusoft.ISISXpressSdk Namespace


ConfigFileException Constructor

ConfigFileException Constructor
Accusoft.ISISXpressSdk Namespace > ConfigFileException Class : ConfigFileException Constructor

The main constructor for the ConfigFileException to throw when there is a problem with the configuration file.

Overload List

Overload | Description
ConfigFileException Constructor() | The main constructor for the ConfigFileException to throw when there is a problem with the configuration file.
ConfigFileException Constructor(Int32) | A ConfigFileException which allows passing in an error number.
ConfigFileException Constructor(Int32,String) | A ConfigFileException which allows passing in an error number and an error message.
ConfigFileException Constructor(String) | A ConfigFileException which allows passing in an error message.
ConfigFileException Constructor(String,Exception) | A ConfigFileException which allows passing in an error message and an inner exception.

See Also

Reference

ConfigFileException Class
ConfigFileException Members


ConfigFileException Constructor()

ConfigFileException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ConfigFileException Class > ConfigFileException Constructor : ConfigFileException Constructor()

The main constructor for the ConfigFileException to throw when there is a problem with the configuration file.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ConfigFileException()
C#
public ConfigFileException()
Managed Extensions for C++
public: ConfigFileException();
C++/CLI
public:
ConfigFileException();

See Also

Reference

ConfigFileException Class
ConfigFileException Members
Overload List


ConfigFileException Constructor(Int32)

ConfigFileException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ConfigFileException Class > ConfigFileException Constructor : ConfigFileException Constructor(Int32)

errorNumber
An integer value which represents the error number.
A ConfigFileException which allows passing in an error number.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer

Dim instance As ConfigFileException(errorNumber)
C#
public ConfigFileException(
   int errorNumber
)
Managed Extensions for C++
public: ConfigFileException(
   int errorNumber
)
C++/CLI
public:
ConfigFileException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

ConfigFileException Class
ConfigFileException Members
Overload List


ConfigFileException Constructor(Int32,String)

ConfigFileException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ConfigFileException Class > ConfigFileException Constructor : ConfigFileException Constructor(Int32,String)

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.
A ConfigFileException which allows passing in an error number and an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer
Dim message As String

Dim instance As ConfigFileException(errorNumber, message)
C#
public ConfigFileException(
   int errorNumber,
   string message
)
Managed Extensions for C++
public: ConfigFileException(
   int errorNumber,
   string* message
)
C++/CLI
public:
ConfigFileException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

Reference

ConfigFileException Class
ConfigFileException Members
Overload List


ConfigFileException Constructor(String)

ConfigFileException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ConfigFileException Class > ConfigFileException Constructor : ConfigFileException Constructor(String)

message
A string value which represents an error message.
A ConfigFileException which allows passing in an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As ConfigFileException(message)
C#
public ConfigFileException(
   string message
)
Managed Extensions for C++
public: ConfigFileException(
   string* message
)
C++/CLI
public:
ConfigFileException(
   String^ message
)

Parameters

message
A string value which represents an error message.

See Also

Reference

ConfigFileException Class
ConfigFileException Members
Overload List


ConfigFileException Constructor(String,Exception)

ConfigFileException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ConfigFileException Class > ConfigFileException Constructor : ConfigFileException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
A ConfigFileException which allows passing in an error message and an inner exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As ConfigFileException(message, innerException)
C#
public ConfigFileException(
   string message,
   Exception innerException
)
Managed Extensions for C++
public: ConfigFileException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
ConfigFileException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

ConfigFileException Class
ConfigFileException Members
Overload List


DibUnavailableException Class

DibUnavailableException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : DibUnavailableException Class

This class implements the DibUnavailableExceptions to throw when the DIB (Device Independent Bitmap) is not available.

Object Model

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public NotInheritable Class DibUnavailableException
   Inherits IsisXpressLibraryException
Visual Basic (Usage) Copy Code
Dim instance As DibUnavailableException
C#
[SerializableAttribute()]
public sealed class DibUnavailableException : IsisXpressLibraryException
Managed Extensions for C++
[SerializableAttribute()]
public __gc __sealed class DibUnavailableException : public IsisXpressLibraryException
C++/CLI
[SerializableAttribute()]
public ref class DibUnavailableException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.DibUnavailableException

See Also

Reference

DibUnavailableException Members
Accusoft.ISISXpressSdk Namespace


DibUnavailableException Class Members

DibUnavailableException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : DibUnavailableException Class

The following tables list the members exposed by DibUnavailableException.

Public Constructors

 | Name | Description
Public Constructor | DibUnavailableException Constructor | Overloaded. The main constructor for the DibUnavailableException class to throw when the DIB is unavailable.
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DibUnavailableException Class
Accusoft.ISISXpressSdk Namespace


DibUnavailableException Class Methods

DibUnavailableException Class Methods
Accusoft.ISISXpressSdk Namespace : DibUnavailableException Class

For a list of all members of this type, see DibUnavailableException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DibUnavailableException Class
Accusoft.ISISXpressSdk Namespace


DibUnavailableException Class Properties

DibUnavailableException Class Properties
Accusoft.ISISXpressSdk Namespace : DibUnavailableException Class

For a list of all members of this type, see DibUnavailableException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DibUnavailableException Class
Accusoft.ISISXpressSdk Namespace


DibUnavailableException Constructor

DibUnavailableException Constructor
Accusoft.ISISXpressSdk Namespace > DibUnavailableException Class : DibUnavailableException Constructor

The main constructor for the DibUnavailableException class to throw when the DIB is unavailable.

Overload List

Overload | Description
DibUnavailableException Constructor() | The main constructor for the DibUnavailableException class to throw when the DIB is unavailable.
DibUnavailableException Constructor(Int32) | A DibUnavailableException which allows passing in an error number.
DibUnavailableException Constructor(Int32,String) | A DibUnavailableException which allows passing in an error number and an error message.
DibUnavailableException Constructor(String) | A DibUnavailableException which allows passing in an error number.
DibUnavailableException Constructor(String,Exception) | A DibUnavailableException which allows passing in an error message and an inner exception.

See Also

Reference

DibUnavailableException Class
DibUnavailableException Members


DibUnavailableException Constructor()

DibUnavailableException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > DibUnavailableException Class > DibUnavailableException Constructor : DibUnavailableException Constructor()

The main constructor for the DibUnavailableException class to throw when the DIB is unavailable.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DibUnavailableException()
C#
public DibUnavailableException()
Managed Extensions for C++
public: DibUnavailableException();
C++/CLI
public:
DibUnavailableException();

See Also

Reference

DibUnavailableException Class
DibUnavailableException Members
Overload List


DibUnavailableException Constructor(Int32)

DibUnavailableException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > DibUnavailableException Class > DibUnavailableException Constructor : DibUnavailableException Constructor(Int32)

errorNumber
An integer value which represents the error number.
A DibUnavailableException which allows passing in an error number.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer

Dim instance As DibUnavailableException(errorNumber)
C#
public DibUnavailableException(
   int errorNumber
)
Managed Extensions for C++
public: DibUnavailableException(
   int errorNumber
)
C++/CLI
public:
DibUnavailableException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

DibUnavailableException Class
DibUnavailableException Members
Overload List


DibUnavailableException Constructor(Int32,String)

DibUnavailableException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > DibUnavailableException Class > DibUnavailableException Constructor : DibUnavailableException Constructor(Int32,String)

errorNumber
An integer value which represents the error number
message
A string value which represents the error message.
A DibUnavailableException which allows passing in an error number and an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer
Dim message As String

Dim instance As DibUnavailableException(errorNumber, message)
C#
public DibUnavailableException(
   int errorNumber,
   string message
)
Managed Extensions for C++
public: DibUnavailableException(
   int errorNumber,
   string* message
)
C++/CLI
public:
DibUnavailableException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number
message
A string value which represents the error message.

See Also

Reference

DibUnavailableException Class
DibUnavailableException Members
Overload List


DibUnavailableException Constructor(String)

DibUnavailableException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > DibUnavailableException Class > DibUnavailableException Constructor : DibUnavailableException Constructor(String)

message
A string value which represents the error message.
A DibUnavailableException which allows passing in an error number.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As DibUnavailableException(message)
C#
public DibUnavailableException(
   string message
)
Managed Extensions for C++
public: DibUnavailableException(
   string* message
)
C++/CLI
public:
DibUnavailableException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

DibUnavailableException Class
DibUnavailableException Members
Overload List


DibUnavailableException Constructor(String,Exception)

DibUnavailableException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > DibUnavailableException Class > DibUnavailableException Constructor : DibUnavailableException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
A DibUnavailableException which allows passing in an error message and an inner exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As DibUnavailableException(message, innerException)
C#
public DibUnavailableException(
   string message,
   Exception innerException
)
Managed Extensions for C++
public: DibUnavailableException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
DibUnavailableException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

DibUnavailableException Class
DibUnavailableException Members
Overload List


DriverAndScanner Class

DriverAndScanner Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : DriverAndScanner Class

This class is the element type of the DriverAndScannerList class. It holds a DriverName and ScannerModel available for use in ISISXpress.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DriverAndScanner
Visual Basic (Usage) Copy Code
Dim instance As DriverAndScanner
C#
public class DriverAndScanner
Managed Extensions for C++
public __gc class DriverAndScanner
C++/CLI
public ref class DriverAndScanner

Inheritance Hierarchy

System.Object
Accusoft.ISISXpressSdk.DriverAndScanner

See Also

Reference

DriverAndScanner Members
Accusoft.ISISXpressSdk Namespace


DriverAndScanner Class Members

DriverAndScanner Class Members
See Also Properties Send Feedback
Accusoft.ISISXpressSdk Namespace : DriverAndScanner Class

The following tables list the members exposed by DriverAndScanner.

Public Constructors

 | Name | Description
Public Constructor | DriverAndScanner Constructor |
Top

Public Properties

 | Name | Description
Public Property | DriverName | Gets and sets the scanner driver name.
Public Property | ScannerModel | Gets and sets the scanner model name.
Top

See Also

Reference

DriverAndScanner Class
Accusoft.ISISXpressSdk Namespace


DriverAndScanner Class Properties

DriverAndScanner Class Properties
Accusoft.ISISXpressSdk Namespace : DriverAndScanner Class

For a list of all members of this type, see DriverAndScanner members.

Public Properties

 | Name | Description
Public Property | DriverName | Gets and sets the scanner driver name.
Public Property | ScannerModel | Gets and sets the scanner model name.
Top

See Also

Reference

DriverAndScanner Class
Accusoft.ISISXpressSdk Namespace


DriverAndScanner Constructor

DriverAndScanner Constructor
Accusoft.ISISXpressSdk Namespace > DriverAndScanner Class : DriverAndScanner Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DriverAndScanner()
C#
public DriverAndScanner()
Managed Extensions for C++
public: DriverAndScanner();
C++/CLI
public:
DriverAndScanner();

See Also

Reference

DriverAndScanner Class
DriverAndScanner Members


DriverName Property

DriverName Property
Accusoft.ISISXpressSdk Namespace > DriverAndScanner Class : DriverName Property

Gets and sets the scanner driver name.

Syntax

Visual Basic (Declaration)
Public Property DriverName As String
Visual Basic (Usage) Copy Code
Dim instance As DriverAndScanner
Dim value As String

instance.DriverName = value

value = instance.DriverName
C#
public string DriverName {get; set;}
Managed Extensions for C++
public: __property string* get_DriverName();
public: __property void set_DriverName(
   string* value
);
C++/CLI
public:
property String^ DriverName {
   String^ get();
   void set (String^value);
}

Return Value

A string value which represents the name of the driver.

See Also

Reference

DriverAndScanner Class
DriverAndScanner Members


ScannerModel Property

ScannerModel Property
Accusoft.ISISXpressSdk Namespace > DriverAndScanner Class : ScannerModel Property

Gets and sets the scanner model name.

Syntax

Visual Basic (Declaration)
Public Property ScannerModel As String
Visual Basic (Usage) Copy Code
Dim instance As DriverAndScanner
Dim value As String

instance.ScannerModel = value

value = instance.ScannerModel
C#
public string ScannerModel {get; set;}
Managed Extensions for C++
public: __property string* get_ScannerModel();
public: __property void set_ScannerModel(
   string* value
);
C++/CLI
public:
property String^ ScannerModel {
   String^ get();
   void set (String^value);
}

Return Value

A string value which represents the name of the scanner model.

See Also

Reference

DriverAndScanner Class
DriverAndScanner Members


DriverAndScannerList Class

DriverAndScannerList Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : DriverAndScannerList Class

This class implements a list of available ISIS drivers and scanner models.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DriverAndScannerList
   Inherits List(Of DriverAndScanner)
Visual Basic (Usage) Copy Code
Dim instance As DriverAndScannerList
C#
public class DriverAndScannerList : List<DriverAndScanner>
Managed Extensions for C++
public __gc class DriverAndScannerList : public List<DriverAndScanner>
C++/CLI
public ref class DriverAndScannerList : public List<DriverAndScanner>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<DriverAndScanner>
Accusoft.ISISXpressSdk.DriverAndScannerList

See Also

Reference

DriverAndScannerList Members
Accusoft.ISISXpressSdk Namespace


DriverAndScannerList Class Members

DriverAndScannerList Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : DriverAndScannerList Class

The following tables list the members exposed by DriverAndScannerList.

Public Constructors

 | Name | Description
Public Constructor | DriverAndScannerList Constructor |
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | AddRange | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Clear | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Contains | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Exists | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Find | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | FindAll | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | FindLast | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | ForEach | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | GetRange | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Insert | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Remove | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | ToArray | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Property | Count | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Property | Item | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Top

See Also

Reference

DriverAndScannerList Class
Accusoft.ISISXpressSdk Namespace


DriverAndScannerList Class Methods

DriverAndScannerList Class Methods
Accusoft.ISISXpressSdk Namespace : DriverAndScannerList Class

For a list of all members of this type, see DriverAndScannerList members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | AddRange | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Clear | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Contains | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Exists | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Find | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | FindAll | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | FindLast | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | ForEach | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | GetRange | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Insert | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Remove | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | ToArray | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Top

See Also

Reference

DriverAndScannerList Class
Accusoft.ISISXpressSdk Namespace


DriverAndScannerList Class Properties

DriverAndScannerList Class Properties
Accusoft.ISISXpressSdk Namespace : DriverAndScannerList Class

For a list of all members of this type, see DriverAndScannerList members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Property | Count | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Property | Item | (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Top

See Also

Reference

DriverAndScannerList Class
Accusoft.ISISXpressSdk Namespace


DriverAndScannerList Constructor

DriverAndScannerList Constructor
Accusoft.ISISXpressSdk Namespace > DriverAndScannerList Class : DriverAndScannerList Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DriverAndScannerList()
C#
public DriverAndScannerList()
Managed Extensions for C++
public: DriverAndScannerList();
C++/CLI
public:
DriverAndScannerList();

See Also

Reference

DriverAndScannerList Class
DriverAndScannerList Members


FeederEmptyEventArgs Class

FeederEmptyEventArgs Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : FeederEmptyEventArgs Class

This class implements the event arguments for the IsisXpress.FeederEmpty event.

Object Model

Syntax

Visual Basic (Declaration)
Public Class FeederEmptyEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As FeederEmptyEventArgs
C#
public class FeederEmptyEventArgs : EventArgs
Managed Extensions for C++
public __gc class FeederEmptyEventArgs : public EventArgs
C++/CLI
public ref class FeederEmptyEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ISISXpressSdk.FeederEmptyEventArgs

See Also

Reference

FeederEmptyEventArgs Members
Accusoft.ISISXpressSdk Namespace


FeederEmptyEventArgs Class Members

FeederEmptyEventArgs Class Members
See Also Properties Send Feedback
Accusoft.ISISXpressSdk Namespace : FeederEmptyEventArgs Class

The following tables list the members exposed by FeederEmptyEventArgs.

Public Constructors

 | Name | Description
Public Constructor | FeederEmptyEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | PageNumber | Gets the page number of the scan that just completed.
Public Property | StopScan | Sets an indicator if the batch process should end.
Top

See Also

Reference

FeederEmptyEventArgs Class
Accusoft.ISISXpressSdk Namespace


FeederEmptyEventArgs Class Properties

FeederEmptyEventArgs Class Properties
Accusoft.ISISXpressSdk Namespace : FeederEmptyEventArgs Class

For a list of all members of this type, see FeederEmptyEventArgs members.

Public Properties

 | Name | Description
Public Property | PageNumber | Gets the page number of the scan that just completed.
Public Property | StopScan | Sets an indicator if the batch process should end.
Top

See Also

Reference

FeederEmptyEventArgs Class
Accusoft.ISISXpressSdk Namespace


FeederEmptyEventArgs Constructor

FeederEmptyEventArgs Constructor
Accusoft.ISISXpressSdk Namespace > FeederEmptyEventArgs Class : FeederEmptyEventArgs Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FeederEmptyEventArgs()
C#
public FeederEmptyEventArgs()
Managed Extensions for C++
public: FeederEmptyEventArgs();
C++/CLI
public:
FeederEmptyEventArgs();

See Also

Reference

FeederEmptyEventArgs Class
FeederEmptyEventArgs Members


PageNumber Property

PageNumber Property
Accusoft.ISISXpressSdk Namespace > FeederEmptyEventArgs Class : PageNumber Property

Gets the page number of the scan that just completed.

Syntax

Visual Basic (Declaration)
Public Property PageNumber As Integer
Visual Basic (Usage) Copy Code
Dim instance As FeederEmptyEventArgs
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
C#
public int PageNumber {get; set;}
Managed Extensions for C++
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
C++/CLI
public:
property int PageNumber {
   int get();
   void set (intvalue);
}

Return Value

An integer value which represents the page number.

See Also

Reference

FeederEmptyEventArgs Class
FeederEmptyEventArgs Members


StopScan Property

StopScan Property
Accusoft.ISISXpressSdk Namespace > FeederEmptyEventArgs Class : StopScan Property

Sets an indicator if the batch process should end.

Syntax

Visual Basic (Declaration)
Public Property StopScan As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FeederEmptyEventArgs
Dim value As Boolean

instance.StopScan = value

value = instance.StopScan
C#
public bool StopScan {get; set;}
Managed Extensions for C++
public: __property bool get_StopScan();
public: __property void set_StopScan(
   bool value
);
C++/CLI
public:
property bool StopScan {
   bool get();
   void set (boolvalue);
}

Return Value

A boolean value which is true if the batch process should end. Otherwise, false should be returned.

Remarks

Note: The Scanner.ScanBatch method does not finish until this property is set to true and the IsisXpress.FeederEmpty event fires to indicate that the batch is complete.

When the scanner feeder is empty, a __Delegates.IsisXpress+FeederEmptyEventHandler event is fired. This event may fire after each scan if a scanner is being used that does not have a feeder or cannot detect paper in the feeder.

See Also

Reference

FeederEmptyEventArgs Class
FeederEmptyEventArgs Members


GeneralIsisException Class

GeneralIsisException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : GeneralIsisException Class

This class implements the GeneralIsisExceptions thrown when there is a general ISIS issue.

Object Model

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public NotInheritable Class GeneralIsisException
   Inherits IsisXpressLibraryException
Visual Basic (Usage) Copy Code
Dim instance As GeneralIsisException
C#
[SerializableAttribute()]
public sealed class GeneralIsisException : IsisXpressLibraryException
Managed Extensions for C++
[SerializableAttribute()]
public __gc __sealed class GeneralIsisException : public IsisXpressLibraryException
C++/CLI
[SerializableAttribute()]
public ref class GeneralIsisException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.GeneralIsisException

See Also

Reference

GeneralIsisException Members
Accusoft.ISISXpressSdk Namespace


GeneralIsisException Class Members

GeneralIsisException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : GeneralIsisException Class

The following tables list the members exposed by GeneralIsisException.

Public Constructors

 | Name | Description
Public Constructor | GeneralIsisException Constructor | Overloaded. The main constructor for the GeneralIsisException class thrown when there is a general ISIS issue.
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

GeneralIsisException Class
Accusoft.ISISXpressSdk Namespace


GeneralIsisException Class Methods

GeneralIsisException Class Methods
Accusoft.ISISXpressSdk Namespace : GeneralIsisException Class

For a list of all members of this type, see GeneralIsisException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

GeneralIsisException Class
Accusoft.ISISXpressSdk Namespace


GeneralIsisException Class Properties

GeneralIsisException Class Properties
Accusoft.ISISXpressSdk Namespace : GeneralIsisException Class

For a list of all members of this type, see GeneralIsisException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

GeneralIsisException Class
Accusoft.ISISXpressSdk Namespace


GeneralIsisException Constructor

GeneralIsisException Constructor
Accusoft.ISISXpressSdk Namespace > GeneralIsisException Class : GeneralIsisException Constructor

The main constructor for the GeneralIsisException class thrown when there is a general ISIS issue.

Overload List

Overload | Description
GeneralIsisException Constructor() | The main constructor for the GeneralIsisException class thrown when there is a general ISIS issue.
GeneralIsisException Constructor(Int32) | A GeneralIsisException which allows passing in an error number.
GeneralIsisException Constructor(Int32,String) | A GeneralIsisException which allows passing in an error number and an error message.
GeneralIsisException Constructor(String) | A GeneralIsisException which allows passing in an error message.
GeneralIsisException Constructor(String,Exception) | A GeneralIsisException which allows passing in an error message and an inner exception.

See Also

Reference

GeneralIsisException Class
GeneralIsisException Members


GeneralIsisException Constructor()

GeneralIsisException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > GeneralIsisException Class > GeneralIsisException Constructor : GeneralIsisException Constructor()

The main constructor for the GeneralIsisException class thrown when there is a general ISIS issue.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As GeneralIsisException()
C#
public GeneralIsisException()
Managed Extensions for C++
public: GeneralIsisException();
C++/CLI
public:
GeneralIsisException();

See Also

Reference

GeneralIsisException Class
GeneralIsisException Members
Overload List


GeneralIsisException Constructor(Int32)

GeneralIsisException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > GeneralIsisException Class > GeneralIsisException Constructor : GeneralIsisException Constructor(Int32)

errorNumber
An integer value which represents the error number.
A GeneralIsisException which allows passing in an error number.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer

Dim instance As GeneralIsisException(errorNumber)
C#
public GeneralIsisException(
   int errorNumber
)
Managed Extensions for C++
public: GeneralIsisException(
   int errorNumber
)
C++/CLI
public:
GeneralIsisException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

GeneralIsisException Class
GeneralIsisException Members
Overload List


GeneralIsisException Constructor(Int32,String)

GeneralIsisException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > GeneralIsisException Class > GeneralIsisException Constructor : GeneralIsisException Constructor(Int32,String)

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.
A GeneralIsisException which allows passing in an error number and an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer
Dim message As String

Dim instance As GeneralIsisException(errorNumber, message)
C#
public GeneralIsisException(
   int errorNumber,
   string message
)
Managed Extensions for C++
public: GeneralIsisException(
   int errorNumber,
   string* message
)
C++/CLI
public:
GeneralIsisException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

Reference

GeneralIsisException Class
GeneralIsisException Members
Overload List


GeneralIsisException Constructor(String)

GeneralIsisException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > GeneralIsisException Class > GeneralIsisException Constructor : GeneralIsisException Constructor(String)

message
A string value which represents the error message.
A GeneralIsisException which allows passing in an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As GeneralIsisException(message)
C#
public GeneralIsisException(
   string message
)
Managed Extensions for C++
public: GeneralIsisException(
   string* message
)
C++/CLI
public:
GeneralIsisException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

GeneralIsisException Class
GeneralIsisException Members
Overload List


GeneralIsisException Constructor(String,Exception)

GeneralIsisException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > GeneralIsisException Class > GeneralIsisException Constructor : GeneralIsisException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
A GeneralIsisException which allows passing in an error message and an inner exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As GeneralIsisException(message, innerException)
C#
public GeneralIsisException(
   string message,
   Exception innerException
)
Managed Extensions for C++
public: GeneralIsisException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
GeneralIsisException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

GeneralIsisException Class
GeneralIsisException Members
Overload List


InvalidLicenseException Class

InvalidLicenseException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : InvalidLicenseException Class

This class implements the InvalidLicenseExceptions thrown when the license key is invalid.

Object Model

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public NotInheritable Class InvalidLicenseException
   Inherits IsisXpressLibraryException
Visual Basic (Usage) Copy Code
Dim instance As InvalidLicenseException
C#
[SerializableAttribute()]
public sealed class InvalidLicenseException : IsisXpressLibraryException
Managed Extensions for C++
[SerializableAttribute()]
public __gc __sealed class InvalidLicenseException : public IsisXpressLibraryException
C++/CLI
[SerializableAttribute()]
public ref class InvalidLicenseException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.InvalidLicenseException

See Also

Reference

InvalidLicenseException Members
Accusoft.ISISXpressSdk Namespace


InvalidLicenseException Class Members

InvalidLicenseException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : InvalidLicenseException Class

The following tables list the members exposed by InvalidLicenseException.

Public Constructors

 | Name | Description
Public Constructor | InvalidLicenseException Constructor | Overloaded. The main constructor for the InvalidLicenseException class thrown when the license key is invalid.
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidLicenseException Class
Accusoft.ISISXpressSdk Namespace


InvalidLicenseException Class Methods

InvalidLicenseException Class Methods
Accusoft.ISISXpressSdk Namespace : InvalidLicenseException Class

For a list of all members of this type, see InvalidLicenseException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidLicenseException Class
Accusoft.ISISXpressSdk Namespace


InvalidLicenseException Class Properties

InvalidLicenseException Class Properties
Accusoft.ISISXpressSdk Namespace : InvalidLicenseException Class

For a list of all members of this type, see InvalidLicenseException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidLicenseException Class
Accusoft.ISISXpressSdk Namespace


InvalidLicenseException Constructor

InvalidLicenseException Constructor
Accusoft.ISISXpressSdk Namespace > InvalidLicenseException Class : InvalidLicenseException Constructor

The main constructor for the InvalidLicenseException class thrown when the license key is invalid.

Overload List

Overload | Description
InvalidLicenseException Constructor() | The main constructor for the InvalidLicenseException class thrown when the license key is invalid.
InvalidLicenseException Constructor(Int32) | An InvalidLicenseException which allows passing in an error number.
InvalidLicenseException Constructor(Int32,String) | An InvalidLicenseException which allows passing in an error number and an error message.
InvalidLicenseException Constructor(String) | An InvalidLicenseException which allows passing in an error message.
InvalidLicenseException Constructor(String,Exception) | An InvalidLicenseException which allows passing in an error message and an inner exception.

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members


InvalidLicenseException Constructor()

InvalidLicenseException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor()

The main constructor for the InvalidLicenseException class thrown when the license key is invalid.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As InvalidLicenseException()
C#
public InvalidLicenseException()
Managed Extensions for C++
public: InvalidLicenseException();
C++/CLI
public:
InvalidLicenseException();

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members
Overload List


InvalidLicenseException Constructor(Int32)

InvalidLicenseException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(Int32)

errorNumber
An integer value which represents the error number.
An InvalidLicenseException which allows passing in an error number.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer

Dim instance As InvalidLicenseException(errorNumber)
C#
public InvalidLicenseException(
   int errorNumber
)
Managed Extensions for C++
public: InvalidLicenseException(
   int errorNumber
)
C++/CLI
public:
InvalidLicenseException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members
Overload List


InvalidLicenseException Constructor(Int32,String)

InvalidLicenseException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(Int32,String)

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.
An InvalidLicenseException which allows passing in an error number and an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer
Dim message As String

Dim instance As InvalidLicenseException(errorNumber, message)
C#
public InvalidLicenseException(
   int errorNumber,
   string message
)
Managed Extensions for C++
public: InvalidLicenseException(
   int errorNumber,
   string* message
)
C++/CLI
public:
InvalidLicenseException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members
Overload List


InvalidLicenseException Constructor(String)

InvalidLicenseException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(String)

message
A string value which represents the error message.
An InvalidLicenseException which allows passing in an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As InvalidLicenseException(message)
C#
public InvalidLicenseException(
   string message
)
Managed Extensions for C++
public: InvalidLicenseException(
   string* message
)
C++/CLI
public:
InvalidLicenseException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members
Overload List


InvalidLicenseException Constructor(String,Exception)

InvalidLicenseException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
An InvalidLicenseException which allows passing in an error message and an inner exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As InvalidLicenseException(message, innerException)
C#
public InvalidLicenseException(
   string message,
   Exception innerException
)
Managed Extensions for C++
public: InvalidLicenseException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
InvalidLicenseException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members
Overload List


InvalidSchemaException Class

InvalidSchemaException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : InvalidSchemaException Class

This class implements the InvalidSchemaExceptions when the filename schema is invalid.

Object Model

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public NotInheritable Class InvalidSchemaException
   Inherits IsisXpressLibraryException
Visual Basic (Usage) Copy Code
Dim instance As InvalidSchemaException
C#
[SerializableAttribute()]
public sealed class InvalidSchemaException : IsisXpressLibraryException
Managed Extensions for C++
[SerializableAttribute()]
public __gc __sealed class InvalidSchemaException : public IsisXpressLibraryException
C++/CLI
[SerializableAttribute()]
public ref class InvalidSchemaException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.InvalidSchemaException

See Also

Reference

InvalidSchemaException Members
Accusoft.ISISXpressSdk Namespace


InvalidSchemaException Class Members

InvalidSchemaException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : InvalidSchemaException Class

The following tables list the members exposed by InvalidSchemaException.

Public Constructors

 | Name | Description
Public Constructor | InvalidSchemaException Constructor | Overloaded. The main constructor for the InvalidSchemaException class when the filename schema is invalid.
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidSchemaException Class
Accusoft.ISISXpressSdk Namespace


InvalidSchemaException Class Methods

InvalidSchemaException Class Methods
Accusoft.ISISXpressSdk Namespace : InvalidSchemaException Class

For a list of all members of this type, see InvalidSchemaException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidSchemaException Class
Accusoft.ISISXpressSdk Namespace


InvalidSchemaException Class Properties

InvalidSchemaException Class Properties
Accusoft.ISISXpressSdk Namespace : InvalidSchemaException Class

For a list of all members of this type, see InvalidSchemaException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidSchemaException Class
Accusoft.ISISXpressSdk Namespace


InvalidSchemaException Constructor

InvalidSchemaException Constructor
Accusoft.ISISXpressSdk Namespace > InvalidSchemaException Class : InvalidSchemaException Constructor

The main constructor for the InvalidSchemaException class when the filename schema is invalid.

Overload List

Overload | Description
InvalidSchemaException Constructor() | The main constructor for the InvalidSchemaException class when the filename schema is invalid.
InvalidSchemaException Constructor(Int32) | An InvalidSchemaException which allows passing in an error number.
InvalidSchemaException Constructor(Int32,String) | An InvalidSchemaException which allows passing in an error number and an error message.
InvalidSchemaException Constructor(String) | An InvalidSchemaException which allows passing in an error message.
InvalidSchemaException Constructor(String,Exception) | An InvalidSchemaException which allows passing in an error message and an inner exception.

See Also

Reference

InvalidSchemaException Class
InvalidSchemaException Members


InvalidSchemaException Constructor()

InvalidSchemaException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSchemaException Class > InvalidSchemaException Constructor : InvalidSchemaException Constructor()

The main constructor for the InvalidSchemaException class when the filename schema is invalid.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As InvalidSchemaException()
C#
public InvalidSchemaException()
Managed Extensions for C++
public: InvalidSchemaException();
C++/CLI
public:
InvalidSchemaException();

See Also

Reference

InvalidSchemaException Class
InvalidSchemaException Members
Overload List


InvalidSchemaException Constructor(Int32)

InvalidSchemaException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSchemaException Class > InvalidSchemaException Constructor : InvalidSchemaException Constructor(Int32)

errorNumber
An integer value which represents the error number.
An InvalidSchemaException which allows passing in an error number.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer

Dim instance As InvalidSchemaException(errorNumber)
C#
public InvalidSchemaException(
   int errorNumber
)
Managed Extensions for C++
public: InvalidSchemaException(
   int errorNumber
)
C++/CLI
public:
InvalidSchemaException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

InvalidSchemaException Class
InvalidSchemaException Members
Overload List


InvalidSchemaException Constructor(Int32,String)

InvalidSchemaException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSchemaException Class > InvalidSchemaException Constructor : InvalidSchemaException Constructor(Int32,String)

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.
An InvalidSchemaException which allows passing in an error number and an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer
Dim message As String

Dim instance As InvalidSchemaException(errorNumber, message)
C#
public InvalidSchemaException(
   int errorNumber,
   string message
)
Managed Extensions for C++
public: InvalidSchemaException(
   int errorNumber,
   string* message
)
C++/CLI
public:
InvalidSchemaException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

Reference

InvalidSchemaException Class
InvalidSchemaException Members
Overload List


InvalidSchemaException Constructor(String)

InvalidSchemaException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSchemaException Class > InvalidSchemaException Constructor : InvalidSchemaException Constructor(String)

message
A string value which represents the error message.
An InvalidSchemaException which allows passing in an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As InvalidSchemaException(message)
C#
public InvalidSchemaException(
   string message
)
Managed Extensions for C++
public: InvalidSchemaException(
   string* message
)
C++/CLI
public:
InvalidSchemaException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

InvalidSchemaException Class
InvalidSchemaException Members
Overload List


InvalidSchemaException Constructor(String,Exception)

InvalidSchemaException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSchemaException Class > InvalidSchemaException Constructor : InvalidSchemaException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
An InvalidSchemaException which allows passing in an error message and an inner exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As InvalidSchemaException(message, innerException)
C#
public InvalidSchemaException(
   string message,
   Exception innerException
)
Managed Extensions for C++
public: InvalidSchemaException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
InvalidSchemaException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

InvalidSchemaException Class
InvalidSchemaException Members
Overload List


InvalidSettingException Class

InvalidSettingException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : InvalidSettingException Class

This class implements the InvalidSettingExceptions when there is an invalid scanner setting.

Object Model

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public NotInheritable Class InvalidSettingException
   Inherits IsisXpressLibraryException
Visual Basic (Usage) Copy Code
Dim instance As InvalidSettingException
C#
[SerializableAttribute()]
public sealed class InvalidSettingException : IsisXpressLibraryException
Managed Extensions for C++
[SerializableAttribute()]
public __gc __sealed class InvalidSettingException : public IsisXpressLibraryException
C++/CLI
[SerializableAttribute()]
public ref class InvalidSettingException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.InvalidSettingException

See Also

Reference

InvalidSettingException Members
Accusoft.ISISXpressSdk Namespace


InvalidSettingException Class Members

InvalidSettingException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : InvalidSettingException Class

The following tables list the members exposed by InvalidSettingException.

Public Constructors

 | Name | Description
Public Constructor | InvalidSettingException Constructor | Overloaded. The main constructor for the InvalidSettingException class to be thrown when there is an invalid scanner setting.
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidSettingException Class
Accusoft.ISISXpressSdk Namespace


InvalidSettingException Class Methods

InvalidSettingException Class Methods
Accusoft.ISISXpressSdk Namespace : InvalidSettingException Class

For a list of all members of this type, see InvalidSettingException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidSettingException Class
Accusoft.ISISXpressSdk Namespace


InvalidSettingException Class Properties

InvalidSettingException Class Properties
Accusoft.ISISXpressSdk Namespace : InvalidSettingException Class

For a list of all members of this type, see InvalidSettingException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidSettingException Class
Accusoft.ISISXpressSdk Namespace


InvalidSettingException Constructor

InvalidSettingException Constructor
Accusoft.ISISXpressSdk Namespace > InvalidSettingException Class : InvalidSettingException Constructor

The main constructor for the InvalidSettingException class to be thrown when there is an invalid scanner setting.

Overload List

Overload | Description
InvalidSettingException Constructor() | The main constructor for the InvalidSettingException class to be thrown when there is an invalid scanner setting.
InvalidSettingException Constructor(Int32) | An InvalidSettingException which allows passing in an error number.
InvalidSettingException Constructor(Int32,String) | An InvalidSettingException which allows passing in an error number and an error message.
InvalidSettingException Constructor(String) | An InvalidSettingException which allows passing in an error message.
InvalidSettingException Constructor(String,Exception) | An InvalidSettingException which allows passing in an error message and an inner exception.

See Also

Reference

InvalidSettingException Class
InvalidSettingException Members


InvalidSettingException Constructor()

InvalidSettingException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSettingException Class > InvalidSettingException Constructor : InvalidSettingException Constructor()

The main constructor for the InvalidSettingException class to be thrown when there is an invalid scanner setting.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As InvalidSettingException()
C#
public InvalidSettingException()
Managed Extensions for C++
public: InvalidSettingException();
C++/CLI
public:
InvalidSettingException();

See Also

Reference

InvalidSettingException Class
InvalidSettingException Members
Overload List


InvalidSettingException Constructor(Int32)

InvalidSettingException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSettingException Class > InvalidSettingException Constructor : InvalidSettingException Constructor(Int32)

errorNumber
An integer which represents the error number.
An InvalidSettingException which allows passing in an error number.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer

Dim instance As InvalidSettingException(errorNumber)
C#
public InvalidSettingException(
   int errorNumber
)
Managed Extensions for C++
public: InvalidSettingException(
   int errorNumber
)
C++/CLI
public:
InvalidSettingException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidSettingException Class
InvalidSettingException Members
Overload List


InvalidSettingException Constructor(Int32,String)

InvalidSettingException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSettingException Class > InvalidSettingException Constructor : InvalidSettingException Constructor(Int32,String)

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.
An InvalidSettingException which allows passing in an error number and an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer
Dim message As String

Dim instance As InvalidSettingException(errorNumber, message)
C#
public InvalidSettingException(
   int errorNumber,
   string message
)
Managed Extensions for C++
public: InvalidSettingException(
   int errorNumber,
   string* message
)
C++/CLI
public:
InvalidSettingException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

Reference

InvalidSettingException Class
InvalidSettingException Members
Overload List


InvalidSettingException Constructor(String)

InvalidSettingException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSettingException Class > InvalidSettingException Constructor : InvalidSettingException Constructor(String)

message
An integer which represents the error message.
An InvalidSettingException which allows passing in an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As InvalidSettingException(message)
C#
public InvalidSettingException(
   string message
)
Managed Extensions for C++
public: InvalidSettingException(
   string* message
)
C++/CLI
public:
InvalidSettingException(
   String^ message
)

Parameters

message
An integer which represents the error message.

See Also

Reference

InvalidSettingException Class
InvalidSettingException Members
Overload List


InvalidSettingException Constructor(String,Exception)

InvalidSettingException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSettingException Class > InvalidSettingException Constructor : InvalidSettingException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
An InvalidSettingException which allows passing in an error message and an inner exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As InvalidSettingException(message, innerException)
C#
public InvalidSettingException(
   string message,
   Exception innerException
)
Managed Extensions for C++
public: InvalidSettingException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
InvalidSettingException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

InvalidSettingException Class
InvalidSettingException Members
Overload List


IsisDriverException Class

IsisDriverException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisDriverException Class

This class implements ISIS driver exceptions.

Object Model

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public NotInheritable Class IsisDriverException
   Inherits IsisXpressLibraryException
Visual Basic (Usage) Copy Code
Dim instance As IsisDriverException
C#
[SerializableAttribute()]
public sealed class IsisDriverException : IsisXpressLibraryException
Managed Extensions for C++
[SerializableAttribute()]
public __gc __sealed class IsisDriverException : public IsisXpressLibraryException
C++/CLI
[SerializableAttribute()]
public ref class IsisDriverException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.IsisDriverException

See Also

Reference

IsisDriverException Members
Accusoft.ISISXpressSdk Namespace


IsisDriverException Class Members

IsisDriverException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisDriverException Class

The following tables list the members exposed by IsisDriverException.

Public Constructors

 | Name | Description
Public Constructor | IsisDriverException Constructor | Overloaded. The main constructor to create a new instance of the IsisDriverException.
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

IsisDriverException Class
Accusoft.ISISXpressSdk Namespace


IsisDriverException Class Methods

IsisDriverException Class Methods
Accusoft.ISISXpressSdk Namespace : IsisDriverException Class

For a list of all members of this type, see IsisDriverException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

IsisDriverException Class
Accusoft.ISISXpressSdk Namespace


IsisDriverException Class Properties

IsisDriverException Class Properties
Accusoft.ISISXpressSdk Namespace : IsisDriverException Class

For a list of all members of this type, see IsisDriverException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

IsisDriverException Class
Accusoft.ISISXpressSdk Namespace


IsisDriverException Constructor

IsisDriverException Constructor
Accusoft.ISISXpressSdk Namespace > IsisDriverException Class : IsisDriverException Constructor

The main constructor to create a new instance of the IsisDriverException.

Overload List

Overload | Description
IsisDriverException Constructor() | The main constructor to create a new instance of the IsisDriverException.
IsisDriverException Constructor(Int32) | An IsisDriverException constructor which allows passing in an error number.
IsisDriverException Constructor(Int32,String) | An IsisDriverException constructor which allows passing in an error number and an error message.
IsisDriverException Constructor(String) | An IsisDriverException constructor which allows passing in an error message.
IsisDriverException Constructor(String,Exception) | An IsisDriverException constructor which allows passing in an error message and inner exception.

See Also

Reference

IsisDriverException Class
IsisDriverException Members


IsisDriverException Constructor()

IsisDriverException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisDriverException Class > IsisDriverException Constructor : IsisDriverException Constructor()

The main constructor to create a new instance of the IsisDriverException.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As IsisDriverException()
C#
public IsisDriverException()
Managed Extensions for C++
public: IsisDriverException();
C++/CLI
public:
IsisDriverException();

See Also

Reference

IsisDriverException Class
IsisDriverException Members
Overload List


IsisDriverException Constructor(Int32)

IsisDriverException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisDriverException Class > IsisDriverException Constructor : IsisDriverException Constructor(Int32)

errorNumber
An integer value which represents the error number.
An IsisDriverException constructor which allows passing in an error number.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer

Dim instance As IsisDriverException(errorNumber)
C#
public IsisDriverException(
   int errorNumber
)
Managed Extensions for C++
public: IsisDriverException(
   int errorNumber
)
C++/CLI
public:
IsisDriverException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

IsisDriverException Class
IsisDriverException Members
Overload List


IsisDriverException Constructor(Int32,String)

IsisDriverException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisDriverException Class > IsisDriverException Constructor : IsisDriverException Constructor(Int32,String)

errorNumber
An integer value which represents an error number.
message
A string value which represents an error message.
An IsisDriverException constructor which allows passing in an error number and an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer
Dim message As String

Dim instance As IsisDriverException(errorNumber, message)
C#
public IsisDriverException(
   int errorNumber,
   string message
)
Managed Extensions for C++
public: IsisDriverException(
   int errorNumber,
   string* message
)
C++/CLI
public:
IsisDriverException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents an error number.
message
A string value which represents an error message.

See Also

Reference

IsisDriverException Class
IsisDriverException Members
Overload List


IsisDriverException Constructor(String)

IsisDriverException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisDriverException Class > IsisDriverException Constructor : IsisDriverException Constructor(String)

message
A string value which represents the error message.
An IsisDriverException constructor which allows passing in an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As IsisDriverException(message)
C#
public IsisDriverException(
   string message
)
Managed Extensions for C++
public: IsisDriverException(
   string* message
)
C++/CLI
public:
IsisDriverException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

IsisDriverException Class
IsisDriverException Members
Overload List


IsisDriverException Constructor(String,Exception)

IsisDriverException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisDriverException Class > IsisDriverException Constructor : IsisDriverException Constructor(String,Exception)

message
A string value which represents an error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
An IsisDriverException constructor which allows passing in an error message and inner exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As IsisDriverException(message, innerException)
C#
public IsisDriverException(
   string message,
   Exception innerException
)
Managed Extensions for C++
public: IsisDriverException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
IsisDriverException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents an error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

IsisDriverException Class
IsisDriverException Members
Overload List


IsisXpress Class

IsisXpress Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisXpress Class

This class is the main controller for the ISIS Xpress component.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute()>
<ComVisibleAttribute(True)>
Public Class IsisXpress
   Inherits Component
Visual Basic (Usage) Copy Code
Dim instance As IsisXpress
C#
[ToolboxBitmapAttribute()]
[ComVisibleAttribute(true)]
public class IsisXpress : Component
Managed Extensions for C++
[ToolboxBitmapAttribute()]
[ComVisibleAttribute(true)]
public __gc class IsisXpress : public Component
C++/CLI
[ToolboxBitmapAttribute()]
[ComVisibleAttribute(true)]
public ref class IsisXpress : public Component

Remarks

This class includes basic component functions like licensing, about box, progress and scanning events.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Accusoft.ISISXpressSdk.IsisXpress

See Also

Reference

IsisXpress Members
Accusoft.ISISXpressSdk Namespace


IsisXpress Class Members

IsisXpress Class Members
See Also Properties Methods Events Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisXpress Class

The following tables list the members exposed by IsisXpress.

Public Constructors

 | Name | Description
Public Constructor | IsisXpress Constructor | The default constructor to instantiate a new IsisXpress instance.
Top

Public Methods

 | Name | Description
Public Method | AboutBox | Displays a dialog window with the ISIS Xpress version number, Pegasus Imaging Corporation contact information, and general information about this component.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases all resources used by the Component. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Top

Public Properties

 | Name | Description
Public Property | Container | Gets the IContainer that contains the Component. (Inherited from System.ComponentModel.Component)
Public Property | Debug | Gets and sets an indicator if debug information is generated and written to the DebugLogFile.
Public Property | DebugLogFile | Gets and sets the filename of the debug log file.
Public Property | ErrorLevel | Gets and sets the ErrorLevelInfo enumeration value for the error level of information to write to the DebugLogFile.
Public Property | Licensing | An ISIS® Xpress license object instance for setting the license information.
Public Property | Output | Gets the current instance of the Output object.
Public Property | Scanner | Gets the current instance of the Scanner object.
Public Property | Site | Gets or sets the ISite of the Component. (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from System.ComponentModel.Component)
Public Event | FeederEmpty | Fired when the scanner feeder is empty.
Public Event | Progress | Fired to indicate how much of the scan has completed.
Public Event | Scanned | Fired to indicate when a scan has completed.
Public Event | Scanning | Fired to indicate a scan is starting.
Top

See Also

Reference

IsisXpress Class
Accusoft.ISISXpressSdk Namespace


IsisXpress Class Events

IsisXpress Class Events
Accusoft.ISISXpressSdk Namespace : IsisXpress Class

For a list of all members of this type, see IsisXpress members.

Public Events

 | Name | Description
Public Event | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from System.ComponentModel.Component)
Public Event | FeederEmpty | Fired when the scanner feeder is empty.
Public Event | Progress | Fired to indicate how much of the scan has completed.
Public Event | Scanned | Fired to indicate when a scan has completed.
Public Event | Scanning | Fired to indicate a scan is starting.
Top

See Also

Reference

IsisXpress Class
Accusoft.ISISXpressSdk Namespace


IsisXpress Class Methods

IsisXpress Class Methods
Accusoft.ISISXpressSdk Namespace : IsisXpress Class

For a list of all members of this type, see IsisXpress members.

Public Methods

 | Name | Description
Public Method | AboutBox | Displays a dialog window with the ISIS Xpress version number, Pegasus Imaging Corporation contact information, and general information about this component.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases all resources used by the Component. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

IsisXpress Class
Accusoft.ISISXpressSdk Namespace


IsisXpress Class Properties

IsisXpress Class Properties
Accusoft.ISISXpressSdk Namespace : IsisXpress Class

For a list of all members of this type, see IsisXpress members.

Public Properties

 | Name | Description
Public Property | Container | Gets the IContainer that contains the Component. (Inherited from System.ComponentModel.Component)
Public Property | Debug | Gets and sets an indicator if debug information is generated and written to the DebugLogFile.
Public Property | DebugLogFile | Gets and sets the filename of the debug log file.
Public Property | ErrorLevel | Gets and sets the ErrorLevelInfo enumeration value for the error level of information to write to the DebugLogFile.
Public Property | Licensing | An ISIS® Xpress license object instance for setting the license information.
Public Property | Output | Gets the current instance of the Output object.
Public Property | Scanner | Gets the current instance of the Scanner object.
Public Property | Site | Gets or sets the ISite of the Component. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

IsisXpress Class
Accusoft.ISISXpressSdk Namespace


IsisXpress Constructor

IsisXpress Constructor
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : IsisXpress Constructor

The default constructor to instantiate a new IsisXpress instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As IsisXpress()
C#
public IsisXpress()
Managed Extensions for C++
public: IsisXpress();
C++/CLI
public:
IsisXpress();

See Also

Reference

IsisXpress Class
IsisXpress Members


AboutBox Method

AboutBox Method
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : AboutBox Method

Displays a dialog window with the ISIS Xpress version number, Pegasus Imaging Corporation contact information, and general information about this component.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("IsisXpress")>
Public Sub AboutBox()
Visual Basic (Usage) Copy Code
Dim instance As IsisXpress

instance.AboutBox()
C#
[CategoryAttribute("IsisXpress")]
public void AboutBox()
Managed Extensions for C++
[CategoryAttribute("IsisXpress")]
public: void AboutBox();
C++/CLI
[CategoryAttribute("IsisXpress")]
public:
void AboutBox();

See Also

Reference

IsisXpress Class
IsisXpress Members


Debug Property

Debug Property
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : Debug Property

Gets and sets an indicator if debug information is generated and written to the DebugLogFile.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property Debug As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IsisXpress
Dim value As Boolean

instance.Debug = value

value = instance.Debug
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public bool Debug {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_Debug();
public: __property void set_Debug(
   bool value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property bool Debug {
   bool get();
   void set (boolvalue);
}

Return Value

A boolean value which is true to write debug information to the DebugLogFile. Otherwise, false is returned.

See Also

Reference

IsisXpress Class
IsisXpress Members


DebugLogFile Property

DebugLogFile Property
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : DebugLogFile Property

Gets and sets the filename of the debug log file.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property DebugLogFile As String
Visual Basic (Usage) Copy Code
Dim instance As IsisXpress
Dim value As String

instance.DebugLogFile = value

value = instance.DebugLogFile
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public string DebugLogFile {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property string* get_DebugLogFile();
public: __property void set_DebugLogFile(
   string* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property String^ DebugLogFile {
   String^ get();
   void set (String^value);
}

Example

...

// Set the DebugLogFile path and name

IsisXpress.DebugLogFile = "c:\logFile.txt";

...

Remarks

This property allows you to control the location of the debug log file.

Valid value: Any valid filename.

Default value: "temp\ISISXpress4.log"

Note: This property will have no effect if you set the Debug property to false.

See Also

Reference

IsisXpress Class
IsisXpress Members


ErrorLevel Property

ErrorLevel Property
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : ErrorLevel Property

Gets and sets the ErrorLevelInfo enumeration value for the error level of information to write to the DebugLogFile.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
Public Property ErrorLevel As ErrorLevelInfo
Visual Basic (Usage) Copy Code
Dim instance As IsisXpress
Dim value As ErrorLevelInfo

instance.ErrorLevel = value

value = instance.ErrorLevel
C#
[BrowsableAttribute(true)]
public ErrorLevelInfo ErrorLevel {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
public: __property ErrorLevelInfo get_ErrorLevel();
public: __property void set_ErrorLevel(
   ErrorLevelInfo value
);
C++/CLI
[BrowsableAttribute(true)]
public:
property ErrorLevelInfo ErrorLevel {
   ErrorLevelInfo get();
   void set (ErrorLevelInfovalue);
}

Return Value

The ErrorLevelInfo enumeration value set.

Remarks

The default value is Production.

Set this property appropriately to speed up processing when not debugging. When debugging, set this property to Detailed to obtain detailed error information.

See Also

Reference

IsisXpress Class
IsisXpress Members


Licensing Property

Licensing Property
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : Licensing Property

An ISIS® Xpress license object instance for setting the license information.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Licensing As Licensing
Visual Basic (Usage) Copy Code
Dim instance As IsisXpress
Dim value As Licensing

value = instance.Licensing
C#
[BrowsableAttribute(false)]
public Licensing Licensing {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Licensing* get_Licensing();
C++/CLI
[BrowsableAttribute(false)]
public:
property Licensing^ Licensing {
   Licensing^ get();
}

Return Value

The current Licensing object.

See Also

Reference

IsisXpress Class
IsisXpress Members


Output Property

Output Property
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : Output Property

Gets the current instance of the Output object.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Output As Output
Visual Basic (Usage) Copy Code
Dim instance As IsisXpress
Dim value As Output

value = instance.Output
C#
[BrowsableAttribute(false)]
public Output Output {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Output* get_Output();
C++/CLI
[BrowsableAttribute(false)]
public:
property Output^ Output {
   Output^ get();
}

Return Value

The current instance of the Output object set.

See Also

Reference

IsisXpress Class
IsisXpress Members


Scanner Property

Scanner Property
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : Scanner Property

Gets the current instance of the Scanner object.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Scanner As Scanner
Visual Basic (Usage) Copy Code
Dim instance As IsisXpress
Dim value As Scanner

value = instance.Scanner
C#
[BrowsableAttribute(false)]
public Scanner Scanner {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Scanner* get_Scanner();
C++/CLI
[BrowsableAttribute(false)]
public:
property Scanner^ Scanner {
   Scanner^ get();
}

Return Value

The instance of the Scanner object set.

See Also

Reference

IsisXpress Class
IsisXpress Members


FeederEmpty Event

FeederEmpty Event
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : FeederEmpty Event

Fired when the scanner feeder is empty.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("IsisXpress")>
Public Event FeederEmpty() As IsisXpress.FeederEmptyEventHandler
Visual Basic (Usage) Copy Code
Dim instance As IsisXpress
Dim handler As IsisXpress.FeederEmptyEventHandler

AddHandler instance.FeederEmpty, handler
C#
[CategoryAttribute("IsisXpress")]
public event IsisXpress.FeederEmptyEventHandler FeederEmpty()
Managed Extensions for C++
[CategoryAttribute("IsisXpress")]
public: __event IsisXpress.FeederEmptyEventHandler* FeederEmpty
C++/CLI
[CategoryAttribute("IsisXpress")]
public:
event IsisXpress::FeederEmptyEventHandler^ FeederEmpty

Event Data

The event handler receives an argument of type FeederEmptyEventArgs containing data related to this event. The following FeederEmptyEventArgs properties provide information specific to this event.

Property | Description
PageNumber | Gets the page number of the scan that just completed.
StopScan | Sets an indicator if the batch process should end.

See Also

Reference

IsisXpress Class
IsisXpress Members


Progress Event

Progress Event
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : Progress Event

Fired to indicate how much of the scan has completed.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("IsisXpress")>
Public Event Progress() As IsisXpress.ProgressEventHandler
Visual Basic (Usage) Copy Code
Dim instance As IsisXpress
Dim handler As IsisXpress.ProgressEventHandler

AddHandler instance.Progress, handler
C#
[CategoryAttribute("IsisXpress")]
public event IsisXpress.ProgressEventHandler Progress()
Managed Extensions for C++
[CategoryAttribute("IsisXpress")]
public: __event IsisXpress.ProgressEventHandler* Progress
C++/CLI
[CategoryAttribute("IsisXpress")]
public:
event IsisXpress::ProgressEventHandler^ Progress

Event Data

The event handler receives an argument of type ProgressEventArgs containing data related to this event. The following ProgressEventArgs properties provide information specific to this event.

Property | Description
Percent | Gets the percentage the scan has progressed.

See Also

Reference

IsisXpress Class
IsisXpress Members


Scanned Event

Scanned Event
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : Scanned Event

Fired to indicate when a scan has completed.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("IsisXpress")>
Public Event Scanned() As IsisXpress.ScannedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As IsisXpress
Dim handler As IsisXpress.ScannedEventHandler

AddHandler instance.Scanned, handler
C#
[CategoryAttribute("IsisXpress")]
public event IsisXpress.ScannedEventHandler Scanned()
Managed Extensions for C++
[CategoryAttribute("IsisXpress")]
public: __event IsisXpress.ScannedEventHandler* Scanned
C++/CLI
[CategoryAttribute("IsisXpress")]
public:
event IsisXpress::ScannedEventHandler^ Scanned

Event Data

The event handler receives an argument of type ScannedEventArgs containing data related to this event. The following ScannedEventArgs properties provide information specific to this event.

Property | Description
PageNumber | Gets the page number of the scan that just completed.

See Also

Reference

IsisXpress Class
IsisXpress Members


Scanning Event

Scanning Event
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : Scanning Event

Fired to indicate a scan is starting.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("IsisXpress")>
Public Event Scanning() As IsisXpress.ScanningEventHandler
Visual Basic (Usage) Copy Code
Dim instance As IsisXpress
Dim handler As IsisXpress.ScanningEventHandler

AddHandler instance.Scanning, handler
C#
[CategoryAttribute("IsisXpress")]
public event IsisXpress.ScanningEventHandler Scanning()
Managed Extensions for C++
[CategoryAttribute("IsisXpress")]
public: __event IsisXpress.ScanningEventHandler* Scanning
C++/CLI
[CategoryAttribute("IsisXpress")]
public:
event IsisXpress::ScanningEventHandler^ Scanning

Event Data

The event handler receives an argument of type ScanningEventArgs containing data related to this event. The following ScanningEventArgs properties provide information specific to this event.

Property | Description
PageNumber | Gets the page number of the scan that is starting.

See Also

Reference

IsisXpress Class
IsisXpress Members


IsisXpressLibraryException Class

IsisXpressLibraryException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisXpressLibraryException Class

This class implements application exceptions.

Object Model

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class IsisXpressLibraryException
   Inherits ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As IsisXpressLibraryException
C#
[SerializableAttribute()]
public class IsisXpressLibraryException : ApplicationException
Managed Extensions for C++
[SerializableAttribute()]
public __gc class IsisXpressLibraryException : public ApplicationException
C++/CLI
[SerializableAttribute()]
public ref class IsisXpressLibraryException : public ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.CancelException
Accusoft.ISISXpressSdk.ConfigFileException
Accusoft.ISISXpressSdk.DibUnavailableException
Accusoft.ISISXpressSdk.GeneralIsisException
Accusoft.ISISXpressSdk.InvalidLicenseException
Accusoft.ISISXpressSdk.InvalidSchemaException
Accusoft.ISISXpressSdk.InvalidSettingException
Accusoft.ISISXpressSdk.IsisDriverException
Accusoft.ISISXpressSdk.OutOfMemoryException
Accusoft.ISISXpressSdk.OutOfRangeException
Accusoft.ISISXpressSdk.SaveTypeException
Accusoft.ISISXpressSdk.ScannerLoadedException
Accusoft.ISISXpressSdk.SequenceException
Accusoft.ISISXpressSdk.SettingUnavailableException
Accusoft.ISISXpressSdk.StringTooLongException

See Also

Reference

IsisXpressLibraryException Members
Accusoft.ISISXpressSdk Namespace


IsisXpressLibraryException Class Members

IsisXpressLibraryException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisXpressLibraryException Class

The following tables list the members exposed by IsisXpressLibraryException.

Public Constructors

 | Name | Description
Public Constructor | IsisXpressLibraryException Constructor | Overloaded. The main constructor for the ISIS Xpress component exceptions.
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred.
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

IsisXpressLibraryException Class
Accusoft.ISISXpressSdk Namespace


IsisXpressLibraryException Class Methods

IsisXpressLibraryException Class Methods
Accusoft.ISISXpressSdk Namespace : IsisXpressLibraryException Class

For a list of all members of this type, see IsisXpressLibraryException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

IsisXpressLibraryException Class
Accusoft.ISISXpressSdk Namespace


IsisXpressLibraryException Class Properties

IsisXpressLibraryException Class Properties
Accusoft.ISISXpressSdk Namespace : IsisXpressLibraryException Class

For a list of all members of this type, see IsisXpressLibraryException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred.
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

IsisXpressLibraryException Class
Accusoft.ISISXpressSdk Namespace


IsisXpressLibraryException Constructor

IsisXpressLibraryException Constructor
Accusoft.ISISXpressSdk Namespace > IsisXpressLibraryException Class : IsisXpressLibraryException Constructor

The main constructor for the ISIS Xpress component exceptions.

Overload List

Overload | Description
IsisXpressLibraryException Constructor() | The main constructor for the ISIS Xpress component exceptions.
IsisXpressLibraryException Constructor(Int32) | An IsisXpressLibraryException constructor which allows passing in an error number.
IsisXpressLibraryException Constructor(Int32,String) | An IsisXpressLibraryException constructor which allows passing in an error number and an error message.
IsisXpressLibraryException Constructor(String) | An IsisXpressLibraryException constructor which allows passing in an error message.
IsisXpressLibraryException Constructor(String,Exception) | An IsisXpressLibraryException constructor which allows passing in an error message and an inner exception.

See Also

Reference

IsisXpressLibraryException Class
IsisXpressLibraryException Members


IsisXpressLibraryException Constructor()

IsisXpressLibraryException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpressLibraryException Class > IsisXpressLibraryException Constructor : IsisXpressLibraryException Constructor()

The main constructor for the ISIS Xpress component exceptions.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As IsisXpressLibraryException()
C#
public IsisXpressLibraryException()
Managed Extensions for C++
public: IsisXpressLibraryException();
C++/CLI
public:
IsisXpressLibraryException();

See Also

Reference

IsisXpressLibraryException Class
IsisXpressLibraryException Members
Overload List


IsisXpressLibraryException Constructor(Int32)

IsisXpressLibraryException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpressLibraryException Class > IsisXpressLibraryException Constructor : IsisXpressLibraryException Constructor(Int32)

errorNumber
An integer value which represents an error number.
An IsisXpressLibraryException constructor which allows passing in an error number.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer

Dim instance As IsisXpressLibraryException(errorNumber)
C#
public IsisXpressLibraryException(
   int errorNumber
)
Managed Extensions for C++
public: IsisXpressLibraryException(
   int errorNumber
)
C++/CLI
public:
IsisXpressLibraryException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents an error number.

See Also

Reference

IsisXpressLibraryException Class
IsisXpressLibraryException Members
Overload List


IsisXpressLibraryException Constructor(Int32,String)

IsisXpressLibraryException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpressLibraryException Class > IsisXpressLibraryException Constructor : IsisXpressLibraryException Constructor(Int32,String)

errorNumber
An integer value which represents the error numbe.
message
A string value which represents the error message.
An IsisXpressLibraryException constructor which allows passing in an error number and an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer
Dim message As String

Dim instance As IsisXpressLibraryException(errorNumber, message)
C#
public IsisXpressLibraryException(
   int errorNumber,
   string message
)
Managed Extensions for C++
public: IsisXpressLibraryException(
   int errorNumber,
   string* message
)
C++/CLI
public:
IsisXpressLibraryException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error numbe.
message
A string value which represents the error message.

See Also

Reference

IsisXpressLibraryException Class
IsisXpressLibraryException Members
Overload List


IsisXpressLibraryException Constructor(String)

IsisXpressLibraryException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpressLibraryException Class > IsisXpressLibraryException Constructor : IsisXpressLibraryException Constructor(String)

message
A string value which represents the error message.
An IsisXpressLibraryException constructor which allows passing in an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As IsisXpressLibraryException(message)
C#
public IsisXpressLibraryException(
   string message
)
Managed Extensions for C++
public: IsisXpressLibraryException(
   string* message
)
C++/CLI
public:
IsisXpressLibraryException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

IsisXpressLibraryException Class
IsisXpressLibraryException Members
Overload List


IsisXpressLibraryException Constructor(String,Exception)

IsisXpressLibraryException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpressLibraryException Class > IsisXpressLibraryException Constructor : IsisXpressLibraryException Constructor(String,Exception)

message
A string which represents an error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
An IsisXpressLibraryException constructor which allows passing in an error message and an inner exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As IsisXpressLibraryException(message, innerException)
C#
public IsisXpressLibraryException(
   string message,
   Exception innerException
)
Managed Extensions for C++
public: IsisXpressLibraryException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
IsisXpressLibraryException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents an error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

IsisXpressLibraryException Class
IsisXpressLibraryException Members
Overload List


Number Property

Number Property
Accusoft.ISISXpressSdk Namespace > IsisXpressLibraryException Class : Number Property

Gets the number or ID of the specific error that occurred.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Number As Integer
Visual Basic (Usage) Copy Code
Dim instance As IsisXpressLibraryException
Dim value As Integer

value = instance.Number
C#
public int Number {get;}
Managed Extensions for C++
public: __property int get_Number();
C++/CLI
public:
property int Number {
   int get();
}

Return Value

An integer value which represents the number.

See Also

Reference

IsisXpressLibraryException Class
IsisXpressLibraryException Members


Licensing Class

Licensing Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : Licensing Class

This class implements the licensing for the ISIS Xpress component.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Licensing
Visual Basic (Usage) Copy Code
Dim instance As Licensing
C#
public class Licensing
Managed Extensions for C++
public __gc class Licensing
C++/CLI
public ref class Licensing

Inheritance Hierarchy

System.Object
Accusoft.ISISXpressSdk.Licensing

See Also

Reference

Licensing Members
Accusoft.ISISXpressSdk Namespace


Licensing Class Members

Licensing Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : Licensing Class

The following tables list the members exposed by Licensing.

Public Constructors

 | Name | Description
Public Constructor | Licensing Constructor | The main constructor to initialize the licensing with a given instance ID.
Top

Public Methods

 | Name | Description
Public Method | UnlockRuntime | Unlocks the component for use in runtime environments.
Public Method | UnlockWeb | Unlocks the component for use in web servers.
Top

Public Properties

 | Name | Description
Public Property | EvaluationMode | Gets and sets the EvaluationChoice enumeration value for the control.
Top

See Also

Reference

Licensing Class
Accusoft.ISISXpressSdk Namespace


Licensing Class Methods

Licensing Class Methods
Accusoft.ISISXpressSdk Namespace : Licensing Class

For a list of all members of this type, see Licensing members.

Public Methods

 | Name | Description
Public Method | UnlockRuntime | Unlocks the component for use in runtime environments.
Public Method | UnlockWeb | Unlocks the component for use in web servers.
Top

See Also

Reference

Licensing Class
Accusoft.ISISXpressSdk Namespace


Licensing Class Properties

Licensing Class Properties
Accusoft.ISISXpressSdk Namespace : Licensing Class

For a list of all members of this type, see Licensing members.

Public Properties

 | Name | Description
Public Property | EvaluationMode | Gets and sets the EvaluationChoice enumeration value for the control.
Top

See Also

Reference

Licensing Class
Accusoft.ISISXpressSdk Namespace


Licensing Constructor

Licensing Constructor
Accusoft.ISISXpressSdk Namespace > Licensing Class : Licensing Constructor

instanceId
An integer value which represents the ISIS Xpress instance ID.
The main constructor to initialize the licensing with a given instance ID.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal instanceId As IntPtr _
)
Visual Basic (Usage) Copy Code
Dim instanceId As IntPtr

Dim instance As Licensing(instanceId)
C#
public Licensing(
   IntPtr instanceId
)
Managed Extensions for C++
public: Licensing(
   IntPtr instanceId
)
C++/CLI
public:
Licensing(
   IntPtr instanceId
)

Parameters

instanceId
An integer value which represents the ISIS Xpress instance ID.

See Also

Reference

Licensing Class
Licensing Members


UnlockRuntime Method

UnlockRuntime Method
Accusoft.ISISXpressSdk Namespace > Licensing Class : UnlockRuntime Method

code1
One of the unlock codes.
code2
One of the unlock codes.
code3
One of the unlock codes.
code4
One of the unlock codes.
Unlocks the component for use in runtime environments.

Syntax

Visual Basic (Declaration)
Public Sub UnlockRuntime( _
   ByVal code1 As Integer, _
   ByVal code2 As Integer, _
   ByVal code3 As Integer, _
   ByVal code4 As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Licensing
Dim code1 As Integer
Dim code2 As Integer
Dim code3 As Integer
Dim code4 As Integer

instance.UnlockRuntime(code1, code2, code3, code4)
C#
public void UnlockRuntime(
   int code1,
   int code2,
   int code3,
   int code4
)
Managed Extensions for C++
public: void UnlockRuntime(
   int code1,
   int code2,
   int code3,
   int code4
)
C++/CLI
public:
void UnlockRuntime(
   int code1,
   int code2,
   int code3,
   int code4
)

Parameters

code1
One of the unlock codes.
code2
One of the unlock codes.
code3
One of the unlock codes.
code4
One of the unlock codes.

Remarks

You must call this method before your application uses this component. It unlocks the component for your use, according to the license that you have purchased. If you do not call this function, your application will only work on a machine with the component development environment installed on it.

If you lose your unlock codes, you can retrieve them on our website: www.Accusoft.com

See Also

Reference

Licensing Class
Licensing Members


UnlockWeb Method

UnlockWeb Method
Accusoft.ISISXpressSdk Namespace > Licensing Class : UnlockWeb Method

webUnlockKey
The element to search for in the collection.
Unlocks the component for use in web servers.

Syntax

Visual Basic (Declaration)
Public Sub UnlockWeb( _
   ByVal webUnlockKey As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Licensing
Dim webUnlockKey As String

instance.UnlockWeb(webUnlockKey)
C#
public void UnlockWeb(
   string webUnlockKey
)
Managed Extensions for C++
public: void UnlockWeb(
   string* webUnlockKey
)
C++/CLI
public:
void UnlockWeb(
   String^ webUnlockKey
)

Parameters

webUnlockKey
The element to search for in the collection.

Remarks

You must call this method before your application uses this component. It unlocks the component for your use, according to the license that you have purchased. If you do not call this function, your application will only work on a machine with the component development environment installed on it.

If you lose your unlock string, you can retrieve it on our website: www.Accusoft.com

See Also

Reference

Licensing Class
Licensing Members


EvaluationMode Property

EvaluationMode Property
Accusoft.ISISXpressSdk Namespace > Licensing Class : EvaluationMode Property

Gets and sets the EvaluationChoice enumeration value for the control.

Syntax

Visual Basic (Declaration)
Public Property EvaluationMode As EvaluationChoice
Visual Basic (Usage) Copy Code
Dim instance As Licensing
Dim value As EvaluationChoice

instance.EvaluationMode = value

value = instance.EvaluationMode
C#
public EvaluationChoice EvaluationMode {get; set;}
Managed Extensions for C++
public: __property EvaluationChoice get_EvaluationMode();
public: __property void set_EvaluationMode(
   EvaluationChoice value
);
C++/CLI
public:
property EvaluationChoice EvaluationMode {
   EvaluationChoice get();
   void set (EvaluationChoicevalue);
}

Return Value

The EvaluationChoice enumeration value.

See Also

Reference

Licensing Class
Licensing Members


OutOfMemoryException Class

OutOfMemoryException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : OutOfMemoryException Class

This class implements the OutOfMemoryExceptions to be thrown when there is not enough memory available.

Object Model

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public NotInheritable Class OutOfMemoryException
   Inherits IsisXpressLibraryException
Visual Basic (Usage) Copy Code
Dim instance As OutOfMemoryException
C#
[SerializableAttribute()]
public sealed class OutOfMemoryException : IsisXpressLibraryException
Managed Extensions for C++
[SerializableAttribute()]
public __gc __sealed class OutOfMemoryException : public IsisXpressLibraryException
C++/CLI
[SerializableAttribute()]
public ref class OutOfMemoryException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.OutOfMemoryException

See Also

Reference

OutOfMemoryException Members
Accusoft.ISISXpressSdk Namespace


OutOfMemoryException Class Members

OutOfMemoryException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : OutOfMemoryException Class

The following tables list the members exposed by OutOfMemoryException.

Public Constructors

 | Name | Description
Public Constructor | OutOfMemoryException Constructor | Overloaded. The main constructor to thrown when there is not enough memory.
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OutOfMemoryException Class
Accusoft.ISISXpressSdk Namespace


OutOfMemoryException Class Methods

OutOfMemoryException Class Methods
Accusoft.ISISXpressSdk Namespace : OutOfMemoryException Class

For a list of all members of this type, see OutOfMemoryException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OutOfMemoryException Class
Accusoft.ISISXpressSdk Namespace


OutOfMemoryException Class Properties

OutOfMemoryException Class Properties
Accusoft.ISISXpressSdk Namespace : OutOfMemoryException Class

For a list of all members of this type, see OutOfMemoryException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OutOfMemoryException Class
Accusoft.ISISXpressSdk Namespace


OutOfMemoryException Constructor

OutOfMemoryException Constructor
Accusoft.ISISXpressSdk Namespace > OutOfMemoryException Class : OutOfMemoryException Constructor

The main constructor to thrown when there is not enough memory.

Overload List

Overload | Description
OutOfMemoryException Constructor() | The main constructor to thrown when there is not enough memory.
OutOfMemoryException Constructor(Int32) | An OutOfMemoryException which allows passing in an error number.
OutOfMemoryException Constructor(Int32,String) | An OutOfMemoryException which allows passing in an error number and an error message.
OutOfMemoryException Constructor(String) | An OutOfMemoryException which allows passing in an error message.
OutOfMemoryException Constructor(String,Exception) | An OutOfMemoryException which allows passing in an error message and an inner exception.

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members


OutOfMemoryException Constructor()

OutOfMemoryException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor()

The main constructor to thrown when there is not enough memory.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As OutOfMemoryException()
C#
public OutOfMemoryException()
Managed Extensions for C++
public: OutOfMemoryException();
C++/CLI
public:
OutOfMemoryException();

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
Overload List


OutOfMemoryException Constructor(Int32)

OutOfMemoryException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(Int32)

errorNumber
An integer value which represents the error number.
An OutOfMemoryException which allows passing in an error number.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer

Dim instance As OutOfMemoryException(errorNumber)
C#
public OutOfMemoryException(
   int errorNumber
)
Managed Extensions for C++
public: OutOfMemoryException(
   int errorNumber
)
C++/CLI
public:
OutOfMemoryException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
Overload List


OutOfMemoryException Constructor(Int32,String)

OutOfMemoryException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(Int32,String)

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.
An OutOfMemoryException which allows passing in an error number and an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer
Dim message As String

Dim instance As OutOfMemoryException(errorNumber, message)
C#
public OutOfMemoryException(
   int errorNumber,
   string message
)
Managed Extensions for C++
public: OutOfMemoryException(
   int errorNumber,
   string* message
)
C++/CLI
public:
OutOfMemoryException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
Overload List


OutOfMemoryException Constructor(String)

OutOfMemoryException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(String)

message
A string value which represents the error message.
An OutOfMemoryException which allows passing in an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As OutOfMemoryException(message)
C#
public OutOfMemoryException(
   string message
)
Managed Extensions for C++
public: OutOfMemoryException(
   string* message
)
C++/CLI
public:
OutOfMemoryException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
Overload List


OutOfMemoryException Constructor(String,Exception)

OutOfMemoryException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
An OutOfMemoryException which allows passing in an error message and an inner exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As OutOfMemoryException(message, innerException)
C#
public OutOfMemoryException(
   string message,
   Exception innerException
)
Managed Extensions for C++
public: OutOfMemoryException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
OutOfMemoryException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
Overload List


OutOfRangeException Class

OutOfRangeException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : OutOfRangeException Class

This class implements the OutOfRangeExceptions when a parameter or index is out of range.

Object Model

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public NotInheritable Class OutOfRangeException
   Inherits IsisXpressLibraryException
Visual Basic (Usage) Copy Code
Dim instance As OutOfRangeException
C#
[SerializableAttribute()]
public sealed class OutOfRangeException : IsisXpressLibraryException
Managed Extensions for C++
[SerializableAttribute()]
public __gc __sealed class OutOfRangeException : public IsisXpressLibraryException
C++/CLI
[SerializableAttribute()]
public ref class OutOfRangeException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.OutOfRangeException

See Also

Reference

OutOfRangeException Members
Accusoft.ISISXpressSdk Namespace


OutOfRangeException Class Members

OutOfRangeException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : OutOfRangeException Class

The following tables list the members exposed by OutOfRangeException.

Public Constructors

 | Name | Description
Public Constructor | OutOfRangeException Constructor | Overloaded. The main constructor for throwing exceptions when a parameter or index is out of range.
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OutOfRangeException Class
Accusoft.ISISXpressSdk Namespace


OutOfRangeException Class Methods

OutOfRangeException Class Methods
Accusoft.ISISXpressSdk Namespace : OutOfRangeException Class

For a list of all members of this type, see OutOfRangeException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OutOfRangeException Class
Accusoft.ISISXpressSdk Namespace


OutOfRangeException Class Properties

OutOfRangeException Class Properties
Accusoft.ISISXpressSdk Namespace : OutOfRangeException Class

For a list of all members of this type, see OutOfRangeException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OutOfRangeException Class
Accusoft.ISISXpressSdk Namespace


OutOfRangeException Constructor

OutOfRangeException Constructor
Accusoft.ISISXpressSdk Namespace > OutOfRangeException Class : OutOfRangeException Constructor

The main constructor for throwing exceptions when a parameter or index is out of range.

Overload List

Overload | Description
OutOfRangeException Constructor() | The main constructor for throwing exceptions when a parameter or index is out of range.
OutOfRangeException Constructor(Int32) | An OutOfRangeException exception which allows passing in an error number.
OutOfRangeException Constructor(Int32,String) | An OutOfRangeException exception which allows passing in an error number and an error message.
OutOfRangeException Constructor(String) | An OutOfRangeException which allows passing in an error message.
OutOfRangeException Constructor(String,Exception) | An OutOfRangeException exception which allows passing in an error message and an inner exception.

See Also

Reference

OutOfRangeException Class
OutOfRangeException Members


OutOfRangeException Constructor()

OutOfRangeException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfRangeException Class > OutOfRangeException Constructor : OutOfRangeException Constructor()

The main constructor for throwing exceptions when a parameter or index is out of range.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As OutOfRangeException()
C#
public OutOfRangeException()
Managed Extensions for C++
public: OutOfRangeException();
C++/CLI
public:
OutOfRangeException();

See Also

Reference

OutOfRangeException Class
OutOfRangeException Members
Overload List


OutOfRangeException Constructor(Int32)

OutOfRangeException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfRangeException Class > OutOfRangeException Constructor : OutOfRangeException Constructor(Int32)

errorNumber
An integer value which represents the error number.
An OutOfRangeException exception which allows passing in an error number.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer

Dim instance As OutOfRangeException(errorNumber)
C#
public OutOfRangeException(
   int errorNumber
)
Managed Extensions for C++
public: OutOfRangeException(
   int errorNumber
)
C++/CLI
public:
OutOfRangeException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

OutOfRangeException Class
OutOfRangeException Members
Overload List


OutOfRangeException Constructor(Int32,String)

OutOfRangeException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfRangeException Class > OutOfRangeException Constructor : OutOfRangeException Constructor(Int32,String)

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.
An OutOfRangeException exception which allows passing in an error number and an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer
Dim message As String

Dim instance As OutOfRangeException(errorNumber, message)
C#
public OutOfRangeException(
   int errorNumber,
   string message
)
Managed Extensions for C++
public: OutOfRangeException(
   int errorNumber,
   string* message
)
C++/CLI
public:
OutOfRangeException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

Reference

OutOfRangeException Class
OutOfRangeException Members
Overload List


OutOfRangeException Constructor(String)

OutOfRangeException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfRangeException Class > OutOfRangeException Constructor : OutOfRangeException Constructor(String)

message
A string value which represents an error message.
An OutOfRangeException which allows passing in an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As OutOfRangeException(message)
C#
public OutOfRangeException(
   string message
)
Managed Extensions for C++
public: OutOfRangeException(
   string* message
)
C++/CLI
public:
OutOfRangeException(
   String^ message
)

Parameters

message
A string value which represents an error message.

See Also

Reference

OutOfRangeException Class
OutOfRangeException Members
Overload List


OutOfRangeException Constructor(String,Exception)

OutOfRangeException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfRangeException Class > OutOfRangeException Constructor : OutOfRangeException Constructor(String,Exception)

message
A string value which represents an error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
An OutOfRangeException exception which allows passing in an error message and an inner exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As OutOfRangeException(message, innerException)
C#
public OutOfRangeException(
   string message,
   Exception innerException
)
Managed Extensions for C++
public: OutOfRangeException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
OutOfRangeException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents an error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

OutOfRangeException Class
OutOfRangeException Members
Overload List


Output Class

Output Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : Output Class

This class implemented how scanned images are saved.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Output
Visual Basic (Usage) Copy Code
Dim instance As Output
C#
public class Output
Managed Extensions for C++
public __gc class Output
C++/CLI
public ref class Output

Inheritance Hierarchy

System.Object
Accusoft.ISISXpressSdk.Output

See Also

Reference

Output Members
Accusoft.ISISXpressSdk Namespace


Output Class Members

Output Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : Output Class

The following tables list the members exposed by Output.

Public Constructors

 | Name | Description
Public Constructor | Output Constructor | The main constructor for the Output class which takes in an instance ID for the ISIS Xpress component.
Top

Public Methods

 | Name | Description
Public Method | ToBitmap | Gets a Bitmap for the current scanned image.
Public Method | ToHBitmap | Gets a HBITMAP handle for the current scanned image.
Public Method | ToHdib | Gets a handle to an DIB (Device Independent Bitmap) for the current scanned image.
Top

Public Properties

 | Name | Description
Public Property | CreateDib | Gets and sets an indicator if a DIB is created while scanning so the ToHdib property is valid after each use.
Public Property | CreateFiles | Gets and sets an indicator if the scanned in data is saved to a file using the full path and filename specified in the Filename property.
Public Property | DibBitsPerPixel | Get the Bits per pixel for the current scanned image. An integer value with the current bits per pixel
Public Property | DibFlip | Gets and sets an indicator whether to flip the DIB that is stored in the ToHdib property.
Public Property | DibHeight | Gets the height of the current scanned image contained in the DIB represented by the ToHdib property.
Public Property | DibWidth | Gets the width of the current scanned image contained in the DIB represented by the ToHdib property.
Public Property | Directory | Gets and sets the base directory used for the file naming schema during batch scans when the UseSchema property is set to true.
Public Property | Filename | Gets and sets the full path and filename where the scanned image is saved.
Public Property | FileSchema | Gets and sets the file schema used to generate filenames during batch scanning.
Public Property | FileType | Gets and sets the file format to use when saving images.
Public Property | MultiplePages | Gets and sets an indicator if the TIFF file should be saved as a multi-page TIFF file.
Public Property | Root | Gets and sets the root prefix used to generate filenames during a batch scan when the UseSchema property is set to true.
Public Property | UseSchema | Gets and sets an indicator if a naming schema is used during batch scanning.
Top

See Also

Reference

Output Class
Accusoft.ISISXpressSdk Namespace


Output Class Methods

Output Class Methods
Accusoft.ISISXpressSdk Namespace : Output Class

For a list of all members of this type, see Output members.

Public Methods

 | Name | Description
Public Method | ToBitmap | Gets a Bitmap for the current scanned image.
Public Method | ToHBitmap | Gets a HBITMAP handle for the current scanned image.
Public Method | ToHdib | Gets a handle to an DIB (Device Independent Bitmap) for the current scanned image.
Top

See Also

Reference

Output Class
Accusoft.ISISXpressSdk Namespace


Output Class Properties

Output Class Properties
Accusoft.ISISXpressSdk Namespace : Output Class

For a list of all members of this type, see Output members.

Public Properties

 | Name | Description
Public Property | CreateDib | Gets and sets an indicator if a DIB is created while scanning so the ToHdib property is valid after each use.
Public Property | CreateFiles | Gets and sets an indicator if the scanned in data is saved to a file using the full path and filename specified in the Filename property.
Public Property | DibBitsPerPixel | Get the Bits per pixel for the current scanned image. An integer value with the current bits per pixel
Public Property | DibFlip | Gets and sets an indicator whether to flip the DIB that is stored in the ToHdib property.
Public Property | DibHeight | Gets the height of the current scanned image contained in the DIB represented by the ToHdib property.
Public Property | DibWidth | Gets the width of the current scanned image contained in the DIB represented by the ToHdib property.
Public Property | Directory | Gets and sets the base directory used for the file naming schema during batch scans when the UseSchema property is set to true.
Public Property | Filename | Gets and sets the full path and filename where the scanned image is saved.
Public Property | FileSchema | Gets and sets the file schema used to generate filenames during batch scanning.
Public Property | FileType | Gets and sets the file format to use when saving images.
Public Property | MultiplePages | Gets and sets an indicator if the TIFF file should be saved as a multi-page TIFF file.
Public Property | Root | Gets and sets the root prefix used to generate filenames during a batch scan when the UseSchema property is set to true.
Public Property | UseSchema | Gets and sets an indicator if a naming schema is used during batch scanning.
Top

See Also

Reference

Output Class
Accusoft.ISISXpressSdk Namespace


Output Constructor

Output Constructor
Accusoft.ISISXpressSdk Namespace > Output Class : Output Constructor

instanceId
An integer value which represents an ISIS Xpress instance ID.
The main constructor for the Output class which takes in an instance ID for the ISIS Xpress component.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal instanceId As IntPtr _
)
Visual Basic (Usage) Copy Code
Dim instanceId As IntPtr

Dim instance As Output(instanceId)
C#
public Output(
   IntPtr instanceId
)
Managed Extensions for C++
public: Output(
   IntPtr instanceId
)
C++/CLI
public:
Output(
   IntPtr instanceId
)

Parameters

instanceId
An integer value which represents an ISIS Xpress instance ID.

See Also

Reference

Output Class
Output Members


ToBitmap Method

ToBitmap Method
Accusoft.ISISXpressSdk Namespace > Output Class : ToBitmap Method

Gets a Bitmap for the current scanned image.

Syntax

Visual Basic (Declaration)
Public Function ToBitmap() As Bitmap
Visual Basic (Usage) Copy Code
Dim instance As Output
Dim value As Bitmap

value = instance.ToBitmap()
C#
public Bitmap ToBitmap()
Managed Extensions for C++
public: Bitmap* ToBitmap();
C++/CLI
public:
Bitmap^ ToBitmap();

Return Value

A Bitmap.

Remarks

The image may only be retrived once for each scanned image.

Note: This property throws a DibUnavailableException if the image is not available.

See Also

Reference

Output Class
Output Members


ToHBitmap Method

ToHBitmap Method
Accusoft.ISISXpressSdk Namespace > Output Class : ToHBitmap Method

Gets a HBITMAP handle for the current scanned image.

Syntax

Visual Basic (Declaration)
Public Function ToHBitmap() As IntPtr
Visual Basic (Usage) Copy Code
Dim instance As Output
Dim value As IntPtr

value = instance.ToHBitmap()
C#
public IntPtr ToHBitmap()
Managed Extensions for C++
public: IntPtr ToHBitmap();
C++/CLI
public:
IntPtr ToHBitmap();

Return Value

A HBITMAP.

Remarks

The IsisXpress object transfers ownership of the HBITMAP to the caller.

It is the callers responsiblity to free the HBITMAP.

Note: The image may only be retrived once for each scanned image.

Note: This property throws a DibUnavailableException if the image is not available.

See Also

Reference

Output Class
Output Members


ToHdib Method

ToHdib Method
Accusoft.ISISXpressSdk Namespace > Output Class : ToHdib Method

Gets a handle to an DIB (Device Independent Bitmap) for the current scanned image.

Syntax

Visual Basic (Declaration)
Public Function ToHdib() As IntPtr
Visual Basic (Usage) Copy Code
Dim instance As Output
Dim value As IntPtr

value = instance.ToHdib()
C#
public IntPtr ToHdib()
Managed Extensions for C++
public: IntPtr ToHdib();
C++/CLI
public:
IntPtr ToHdib();

Return Value

A HDIB.

Remarks

The IsisXpress object transfers ownership of the HDIB to the caller.

It is the callers responsiblity to free the HDIB.

Note: The image may only be retrived once for each scanned image.

Note: This property throws a DibUnavailableException if the image is not available.

See Also

Reference

Output Class
Output Members


CreateDib Property

CreateDib Property
Accusoft.ISISXpressSdk Namespace > Output Class : CreateDib Property

Gets and sets an indicator if a DIB is created while scanning so the ToHdib property is valid after each use.

Syntax

Visual Basic (Declaration)
Public Property CreateDib As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Output
Dim value As Boolean

instance.CreateDib = value

value = instance.CreateDib
C#
public bool CreateDib {get; set;}
Managed Extensions for C++
public: __property bool get_CreateDib();
public: __property void set_CreateDib(
   bool value
);
C++/CLI
public:
property bool CreateDib {
   bool get();
   void set (boolvalue);
}

Return Value

A boolean value which is true if a DIB should be created or false if a DIB should not be created.

Remarks

The default value is false.

This DIB can only be created if the Scanner.UseCompression property is set to false. When hardware compression is enabled, the scanner sends compressed data to the computer and this cannot be used to construct a DIB.

See Also

Reference

Output Class
Output Members


CreateFiles Property

CreateFiles Property
Accusoft.ISISXpressSdk Namespace > Output Class : CreateFiles Property

Gets and sets an indicator if the scanned in data is saved to a file using the full path and filename specified in the Filename property.

Syntax

Visual Basic (Declaration)
Public Property CreateFiles As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Output
Dim value As Boolean

instance.CreateFiles = value

value = instance.CreateFiles
C#
public bool CreateFiles {get; set;}
Managed Extensions for C++
public: __property bool get_CreateFiles();
public: __property void set_CreateFiles(
   bool value
);
C++/CLI
public:
property bool CreateFiles {
   bool get();
   void set (boolvalue);
}

Return Value

A boolean value which is true if the scanned in data is saved to a file. Otherwise, falseis returned.

Remarks

The default value is true.

Note: Set this value to false only if a DIB is desired. It is possible to set both the CreateDib and the CreateFiles properties to false but then there is no output.

See Also

Reference

Output Class
Output Members


DibBitsPerPixel Property

DibBitsPerPixel Property
Accusoft.ISISXpressSdk Namespace > Output Class : DibBitsPerPixel Property

Get the Bits per pixel for the current scanned image. An integer value with the current bits per pixel

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DibBitsPerPixel As Integer
Visual Basic (Usage) Copy Code
Dim instance As Output
Dim value As Integer

value = instance.DibBitsPerPixel
C#
public int DibBitsPerPixel {get;}
Managed Extensions for C++
public: __property int get_DibBitsPerPixel();
C++/CLI
public:
property int DibBitsPerPixel {
   int get();
}

See Also

Reference

Output Class
Output Members


DibFlip Property

DibFlip Property
Accusoft.ISISXpressSdk Namespace > Output Class : DibFlip Property

Gets and sets an indicator whether to flip the DIB that is stored in the ToHdib property.

Syntax

Visual Basic (Declaration)
Public Property DibFlip As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Output
Dim value As Boolean

instance.DibFlip = value

value = instance.DibFlip
C#
public bool DibFlip {get; set;}
Managed Extensions for C++
public: __property bool get_DibFlip();
public: __property void set_DibFlip(
   bool value
);
C++/CLI
public:
property bool DibFlip {
   bool get();
   void set (boolvalue);
}

Return Value

A boolean value which is true to flip the DIB. Otherwise, false is returned.

Remarks

This property only affects the DIB that is stored in the ToHdib property and has no bearing on saved files.

See Also

Reference

Output Class
Output Members


DibHeight Property

DibHeight Property
Accusoft.ISISXpressSdk Namespace > Output Class : DibHeight Property

Gets the height of the current scanned image contained in the DIB represented by the ToHdib property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DibHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As Output
Dim value As Integer

value = instance.DibHeight
C#
public int DibHeight {get;}
Managed Extensions for C++
public: __property int get_DibHeight();
C++/CLI
public:
property int DibHeight {
   int get();
}

Return Value

An integer value which represents the height of the current scanned image.

Remarks

This property is used to obtain the height of the current scanned image. This value may be different from the ScanSettingInfo.ImageLength scan setting if a scanner's page size detection setting is enabled. DibHeight is available at runtime in the IsisXpress.Scanned events and it is available until the ToHdib property is no longer valid.

See Also

Reference

Output Class
Output Members


DibWidth Property

DibWidth Property
Accusoft.ISISXpressSdk Namespace > Output Class : DibWidth Property

Gets the width of the current scanned image contained in the DIB represented by the ToHdib property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DibWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As Output
Dim value As Integer

value = instance.DibWidth
C#
public int DibWidth {get;}
Managed Extensions for C++
public: __property int get_DibWidth();
C++/CLI
public:
property int DibWidth {
   int get();
}

Return Value

An integer value which represents the width of the current scanned image.

Remarks

This property is used to obtain the width of the current scanned image. This value may be different from the ScanSettingInfo.ImageWidth scan setting if a scanner's page size detection setting is enabled. DibWidth is available at runtime in the IsisXpress.Scanned events and it is available until the ToHdib property is no longer valid.

See Also

Reference

Output Class
Output Members


Directory Property

Directory Property
Accusoft.ISISXpressSdk Namespace > Output Class : Directory Property

Gets and sets the base directory used for the file naming schema during batch scans when the UseSchema property is set to true.

Syntax

Visual Basic (Declaration)
Public Property Directory As String
Visual Basic (Usage) Copy Code
Dim instance As Output
Dim value As String

instance.Directory = value

value = instance.Directory
C#
public string Directory {get; set;}
Managed Extensions for C++
public: __property string* get_Directory();
public: __property void set_Directory(
   string* value
);
C++/CLI
public:
property String^ Directory {
   String^ get();
   void set (String^value);
}

Return Value

A string which represents the file name for the schema.

See Also

Reference

Output Class
Output Members


Filename Property

Filename Property
Accusoft.ISISXpressSdk Namespace > Output Class : Filename Property

Gets and sets the full path and filename where the scanned image is saved.

Syntax

Visual Basic (Declaration)
Public Property Filename As String
Visual Basic (Usage) Copy Code
Dim instance As Output
Dim value As String

instance.Filename = value

value = instance.Filename
C#
public string Filename {get; set;}
Managed Extensions for C++
public: __property string* get_Filename();
public: __property void set_Filename(
   string* value
);
C++/CLI
public:
property String^ Filename {
   String^ get();
   void set (String^value);
}

Return Value

A string which represents the path and name.

Remarks

The default value is an empty string "".

If the UseSchema property is set to true, then this property is modified before each scan and can be checked or modified in the IsisXpress.Scanning event.

See Also

Reference

Output Class
Output Members


FileSchema Property

FileSchema Property
Accusoft.ISISXpressSdk Namespace > Output Class : FileSchema Property

Gets and sets the file schema used to generate filenames during batch scanning.

Syntax

Visual Basic (Declaration)
Public Property FileSchema As String
Visual Basic (Usage) Copy Code
Dim instance As Output
Dim value As String

instance.FileSchema = value

value = instance.FileSchema
C#
public string FileSchema {get; set;}
Managed Extensions for C++
public: __property string* get_FileSchema();
public: __property void set_FileSchema(
   string* value
);
C++/CLI
public:
property String^ FileSchema {
   String^ get();
   void set (String^value);
}

Return Value

A string which represents the file schema.

Remarks

The following symbols can be used to specify a schema:

  • $ = root
  • # = page number

The following items are example schemas and the files they would generate:

  • $## = file01, file02, etc.
  • $#### = file0001, file0002, etc.

See Also

Reference

Output Class
Output Members


FileType Property

FileType Property
Accusoft.ISISXpressSdk Namespace > Output Class : FileType Property

Gets and sets the file format to use when saving images.

Syntax

Visual Basic (Declaration)
Public Property FileType As FileTypeInfo
Visual Basic (Usage) Copy Code
Dim instance As Output
Dim value As FileTypeInfo

instance.FileType = value

value = instance.FileType
C#
public FileTypeInfo FileType {get; set;}
Managed Extensions for C++
public: __property FileTypeInfo get_FileType();
public: __property void set_FileType(
   FileTypeInfo value
);
C++/CLI
public:
property FileTypeInfo FileType {
   FileTypeInfo get();
   void set (FileTypeInfovalue);
}

Return Value

A FileTypeInfo enumeration value option.

Remarks

1 bit (black and white) images can be saved to any of the five TIFF file formats or to the DCX file format. 8 bit (gray scale) images can be saved to the TiffRaw, TiffPackbits or JpegGray file formats. 24 bit (color) images can be saved to the TiffRaw, TiffPackbits or JPEG file formats.

See Also

Reference

Output Class
Output Members


MultiplePages Property

MultiplePages Property
Accusoft.ISISXpressSdk Namespace > Output Class : MultiplePages Property

Gets and sets an indicator if the TIFF file should be saved as a multi-page TIFF file.

Syntax

Visual Basic (Declaration)
Public Property MultiplePages As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Output
Dim value As Boolean

instance.MultiplePages = value

value = instance.MultiplePages
C#
public bool MultiplePages {get; set;}
Managed Extensions for C++
public: __property bool get_MultiplePages();
public: __property void set_MultiplePages(
   bool value
);
C++/CLI
public:
property bool MultiplePages {
   bool get();
   void set (boolvalue);
}

Return Value

A boolean value which is true to save the TIFF file as a multi-page. Otherwise, false is returned.

Remarks

The default value is false.

Note: This property and the UseSchema property cannot be used at the same time.

See Also

Reference

Output Class
Output Members


Root Property

Root Property
Accusoft.ISISXpressSdk Namespace > Output Class : Root Property

Gets and sets the root prefix used to generate filenames during a batch scan when the UseSchema property is set to true.

Syntax

Visual Basic (Declaration)
Public Property Root As String
Visual Basic (Usage) Copy Code
Dim instance As Output
Dim value As String

instance.Root = value

value = instance.Root
C#
public string Root {get; set;}
Managed Extensions for C++
public: __property string* get_Root();
public: __property void set_Root(
   string* value
);
C++/CLI
public:
property String^ Root {
   String^ get();
   void set (String^value);
}

Return Value

A string which represents the root prefix.

Remarks

This property value is "image" if the desired filenames are image01.tif, image02.tif, and etc.

See Also

Reference

Output Class
Output Members


UseSchema Property

UseSchema Property
Accusoft.ISISXpressSdk Namespace > Output Class : UseSchema Property

Gets and sets an indicator if a naming schema is used during batch scanning.

Syntax

Visual Basic (Declaration)
Public Property UseSchema As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Output
Dim value As Boolean

instance.UseSchema = value

value = instance.UseSchema
C#
public bool UseSchema {get; set;}
Managed Extensions for C++
public: __property bool get_UseSchema();
public: __property void set_UseSchema(
   bool value
);
C++/CLI
public:
property bool UseSchema {
   bool get();
   void set (boolvalue);
}

Return Value

A boolean value which is true if a naming schema is used. Otherwise, false is returned.

Remarks

The default value is false.

The values of the Directory, Root, and FileSchema properties are used to determine the full path and filenames of the output files.

Note: The MultiplePages property and the UseSchema property cannot be used at the same time.

See Also

Reference

Output Class
Output Members


ProgressEventArgs Class

ProgressEventArgs Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : ProgressEventArgs Class

This class implements the event arguments for the IsisXpress.Progress event.

Object Model

Syntax

Visual Basic (Declaration)
Public Class ProgressEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ProgressEventArgs
C#
public class ProgressEventArgs : EventArgs
Managed Extensions for C++
public __gc class ProgressEventArgs : public EventArgs
C++/CLI
public ref class ProgressEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ISISXpressSdk.ProgressEventArgs

See Also

Reference

ProgressEventArgs Members
Accusoft.ISISXpressSdk Namespace


ProgressEventArgs Class Members

ProgressEventArgs Class Members
See Also Properties Send Feedback
Accusoft.ISISXpressSdk Namespace : ProgressEventArgs Class

The following tables list the members exposed by ProgressEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ProgressEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Percent | Gets the percentage the scan has progressed.
Top

See Also

Reference

ProgressEventArgs Class
Accusoft.ISISXpressSdk Namespace


ProgressEventArgs Class Properties

ProgressEventArgs Class Properties
Accusoft.ISISXpressSdk Namespace : ProgressEventArgs Class

For a list of all members of this type, see ProgressEventArgs members.

Public Properties

 | Name | Description
Public Property | Percent | Gets the percentage the scan has progressed.
Top

See Also

Reference

ProgressEventArgs Class
Accusoft.ISISXpressSdk Namespace


ProgressEventArgs Constructor

ProgressEventArgs Constructor
Accusoft.ISISXpressSdk Namespace > ProgressEventArgs Class : ProgressEventArgs Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ProgressEventArgs()
C#
public ProgressEventArgs()
Managed Extensions for C++
public: ProgressEventArgs();
C++/CLI
public:
ProgressEventArgs();

See Also

Reference

ProgressEventArgs Class
ProgressEventArgs Members


Percent Property

Percent Property
Accusoft.ISISXpressSdk Namespace > ProgressEventArgs Class : Percent Property

Gets the percentage the scan has progressed.

Syntax

Visual Basic (Declaration)
Public Property Percent As Integer
Visual Basic (Usage) Copy Code
Dim instance As ProgressEventArgs
Dim value As Integer

instance.Percent = value

value = instance.Percent
C#
public int Percent {get; set;}
Managed Extensions for C++
public: __property int get_Percent();
public: __property void set_Percent(
   int value
);
C++/CLI
public:
property int Percent {
   int get();
   void set (intvalue);
}

Return Value

An integer value which represents the percentage of completion.

See Also

Reference

ProgressEventArgs Class
ProgressEventArgs Members


RationalType Class

RationalType Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : RationalType Class

This class implements a rational number with the numerator and denominator stored in their normal form.

Object Model

Syntax

Visual Basic (Declaration)
Public Class RationalType
Visual Basic (Usage) Copy Code
Dim instance As RationalType
C#
public class RationalType
Managed Extensions for C++
public __gc class RationalType
C++/CLI
public ref class RationalType

Inheritance Hierarchy

System.Object
Accusoft.ISISXpressSdk.RationalType

See Also

Reference

RationalType Members
Accusoft.ISISXpressSdk Namespace


RationalType Class Members

RationalType Class Members
See Also Properties Send Feedback
Accusoft.ISISXpressSdk Namespace : RationalType Class

The following tables list the members exposed by RationalType.

Public Constructors

 | Name | Description
Public Constructor | RationalType Constructor | Overloaded. The main constructor for the RationalType class.
Top

Public Properties

 | Name | Description
Public Property | Denominator | Gets and sets the denominator for the rational type.
Public Property | Numerator | Gets and sets the numerator for the rational type.
Top

See Also

Reference

RationalType Class
Accusoft.ISISXpressSdk Namespace


RationalType Class Properties

RationalType Class Properties
Accusoft.ISISXpressSdk Namespace : RationalType Class

For a list of all members of this type, see RationalType members.

Public Properties

 | Name | Description
Public Property | Denominator | Gets and sets the denominator for the rational type.
Public Property | Numerator | Gets and sets the numerator for the rational type.
Top

See Also

Reference

RationalType Class
Accusoft.ISISXpressSdk Namespace


RationalType Constructor

RationalType Constructor
Accusoft.ISISXpressSdk Namespace > RationalType Class : RationalType Constructor

The main constructor for the RationalType class.

Overload List

Overload | Description
RationalType Constructor() | The main constructor for the RationalType class.
RationalType Constructor(Int64,Int64) | A RationalType constructor which takes in a numerator and denominator for the rational type.

See Also

Reference

RationalType Class
RationalType Members


RationalType Constructor()

RationalType Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > RationalType Class > RationalType Constructor : RationalType Constructor()

The main constructor for the RationalType class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RationalType()
C#
public RationalType()
Managed Extensions for C++
public: RationalType();
C++/CLI
public:
RationalType();

See Also

Reference

RationalType Class
RationalType Members
Overload List


RationalType Constructor(Int64,Int64)

RationalType Constructor(Int64,Int64)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > RationalType Class > RationalType Constructor : RationalType Constructor(Int64,Int64)

numerator
An integer value which represents the numerator.
denominator
A long value which represents the denominator.
A RationalType constructor which takes in a numerator and denominator for the rational type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal numerator As Long, _
   ByVal denominator As Long _
)
Visual Basic (Usage) Copy Code
Dim numerator As Long
Dim denominator As Long

Dim instance As RationalType(numerator, denominator)
C#
public RationalType(
   long numerator,
   long denominator
)
Managed Extensions for C++
public: RationalType(
   long numerator,
   long denominator
)
C++/CLI
public:
RationalType(
   long long numerator,
   long long denominator
)

Parameters

numerator
An integer value which represents the numerator.
denominator
A long value which represents the denominator.

See Also

Reference

RationalType Class
RationalType Members
Overload List


Denominator Property

Denominator Property
Accusoft.ISISXpressSdk Namespace > RationalType Class : Denominator Property

Gets and sets the denominator for the rational type.

Syntax

Visual Basic (Declaration)
Public Property Denominator As Long
Visual Basic (Usage) Copy Code
Dim instance As RationalType
Dim value As Long

instance.Denominator = value

value = instance.Denominator
C#
public long Denominator {get; set;}
Managed Extensions for C++
public: __property long get_Denominator();
public: __property void set_Denominator(
   long value
);
C++/CLI
public:
property long long Denominator {
   long long get();
   void set (long longvalue);
}

Return Value

A long value which represents the denominator for the rational type.

See Also

Reference

RationalType Class
RationalType Members


Numerator Property

Numerator Property
Accusoft.ISISXpressSdk Namespace > RationalType Class : Numerator Property

Gets and sets the numerator for the rational type.

Syntax

Visual Basic (Declaration)
Public Property Numerator As Long
Visual Basic (Usage) Copy Code
Dim instance As RationalType
Dim value As Long

instance.Numerator = value

value = instance.Numerator
C#
public long Numerator {get; set;}
Managed Extensions for C++
public: __property long get_Numerator();
public: __property void set_Numerator(
   long value
);
C++/CLI
public:
property long long Numerator {
   long long get();
   void set (long longvalue);
}

Return Value

A long value which represents the numerator.

See Also

Reference

RationalType Class
RationalType Members


SaveTypeException Class

SaveTypeException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : SaveTypeException Class

This class implements the SaveTypeExceptions to throw when there is a problem with the save type.

Object Model

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public NotInheritable Class SaveTypeException
   Inherits IsisXpressLibraryException
Visual Basic (Usage) Copy Code
Dim instance As SaveTypeException
C#
[SerializableAttribute()]
public sealed class SaveTypeException : IsisXpressLibraryException
Managed Extensions for C++
[SerializableAttribute()]
public __gc __sealed class SaveTypeException : public IsisXpressLibraryException
C++/CLI
[SerializableAttribute()]
public ref class SaveTypeException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.SaveTypeException

See Also

Reference

SaveTypeException Members
Accusoft.ISISXpressSdk Namespace


SaveTypeException Class Members

SaveTypeException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : SaveTypeException Class

The following tables list the members exposed by SaveTypeException.

Public Constructors

 | Name | Description
Public Constructor | SaveTypeException Constructor | Overloaded. The main constructor for the SaveTypeException class to throw when there is a problem with the save type.
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SaveTypeException Class
Accusoft.ISISXpressSdk Namespace


SaveTypeException Class Methods

SaveTypeException Class Methods
Accusoft.ISISXpressSdk Namespace : SaveTypeException Class

For a list of all members of this type, see SaveTypeException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SaveTypeException Class
Accusoft.ISISXpressSdk Namespace


SaveTypeException Class Properties

SaveTypeException Class Properties
Accusoft.ISISXpressSdk Namespace : SaveTypeException Class

For a list of all members of this type, see SaveTypeException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SaveTypeException Class
Accusoft.ISISXpressSdk Namespace


SaveTypeException Constructor

SaveTypeException Constructor
Accusoft.ISISXpressSdk Namespace > SaveTypeException Class : SaveTypeException Constructor

The main constructor for the SaveTypeException class to throw when there is a problem with the save type.

Overload List

Overload | Description
SaveTypeException Constructor() | The main constructor for the SaveTypeException class to throw when there is a problem with the save type.
SaveTypeException Constructor(Int32) | A SaveTypeException which allows passing in an error number.
SaveTypeException Constructor(Int32,String) | A SaveTypeException which allows passing in an error number.
SaveTypeException Constructor(String) | A SaveTypeException which allows passing in an error message.
SaveTypeException Constructor(String,Exception) | A SaveTypeException which allows passing in an error message and an inner exception.

See Also

Reference

SaveTypeException Class
SaveTypeException Members


SaveTypeException Constructor()

SaveTypeException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SaveTypeException Class > SaveTypeException Constructor : SaveTypeException Constructor()

The main constructor for the SaveTypeException class to throw when there is a problem with the save type.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SaveTypeException()
C#
public SaveTypeException()
Managed Extensions for C++
public: SaveTypeException();
C++/CLI
public:
SaveTypeException();

See Also

Reference

SaveTypeException Class
SaveTypeException Members
Overload List


SaveTypeException Constructor(Int32)

SaveTypeException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SaveTypeException Class > SaveTypeException Constructor : SaveTypeException Constructor(Int32)

errorNumber
An integer value which represents the error number.
A SaveTypeException which allows passing in an error number.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer

Dim instance As SaveTypeException(errorNumber)
C#
public SaveTypeException(
   int errorNumber
)
Managed Extensions for C++
public: SaveTypeException(
   int errorNumber
)
C++/CLI
public:
SaveTypeException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

SaveTypeException Class
SaveTypeException Members
Overload List


SaveTypeException Constructor(Int32,String)

SaveTypeException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SaveTypeException Class > SaveTypeException Constructor : SaveTypeException Constructor(Int32,String)

errorNumber
An integer value which represents an error number.
message
A string value which represents the error message.
A SaveTypeException which allows passing in an error number.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer
Dim message As String

Dim instance As SaveTypeException(errorNumber, message)
C#
public SaveTypeException(
   int errorNumber,
   string message
)
Managed Extensions for C++
public: SaveTypeException(
   int errorNumber,
   string* message
)
C++/CLI
public:
SaveTypeException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents an error number.
message
A string value which represents the error message.

See Also

Reference

SaveTypeException Class
SaveTypeException Members
Overload List


SaveTypeException Constructor(String)

SaveTypeException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SaveTypeException Class > SaveTypeException Constructor : SaveTypeException Constructor(String)

message
A string value which represents the error message.
A SaveTypeException which allows passing in an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As SaveTypeException(message)
C#
public SaveTypeException(
   string message
)
Managed Extensions for C++
public: SaveTypeException(
   string* message
)
C++/CLI
public:
SaveTypeException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

SaveTypeException Class
SaveTypeException Members
Overload List


SaveTypeException Constructor(String,Exception)

SaveTypeException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SaveTypeException Class > SaveTypeException Constructor : SaveTypeException Constructor(String,Exception)

message
A string value which represents an error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
A SaveTypeException which allows passing in an error message and an inner exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As SaveTypeException(message, innerException)
C#
public SaveTypeException(
   string message,
   Exception innerException
)
Managed Extensions for C++
public: SaveTypeException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
SaveTypeException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents an error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

SaveTypeException Class
SaveTypeException Members
Overload List


ScannedEventArgs Class

ScannedEventArgs Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : ScannedEventArgs Class

This class implements the event arguments for the IsisXpress.Scanned event.

Object Model

Syntax

Visual Basic (Declaration)
Public Class ScannedEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ScannedEventArgs
C#
public class ScannedEventArgs : EventArgs
Managed Extensions for C++
public __gc class ScannedEventArgs : public EventArgs
C++/CLI
public ref class ScannedEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ISISXpressSdk.ScannedEventArgs

See Also

Reference

ScannedEventArgs Members
Accusoft.ISISXpressSdk Namespace


ScannedEventArgs Class Members

ScannedEventArgs Class Members
See Also Properties Send Feedback
Accusoft.ISISXpressSdk Namespace : ScannedEventArgs Class

The following tables list the members exposed by ScannedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ScannedEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | PageNumber | Gets the page number of the scan that just completed.
Top

See Also

Reference

ScannedEventArgs Class
Accusoft.ISISXpressSdk Namespace


ScannedEventArgs Class Properties

ScannedEventArgs Class Properties
Accusoft.ISISXpressSdk Namespace : ScannedEventArgs Class

For a list of all members of this type, see ScannedEventArgs members.

Public Properties

 | Name | Description
Public Property | PageNumber | Gets the page number of the scan that just completed.
Top

See Also

Reference

ScannedEventArgs Class
Accusoft.ISISXpressSdk Namespace


ScannedEventArgs Constructor

ScannedEventArgs Constructor
Accusoft.ISISXpressSdk Namespace > ScannedEventArgs Class : ScannedEventArgs Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ScannedEventArgs()
C#
public ScannedEventArgs()
Managed Extensions for C++
public: ScannedEventArgs();
C++/CLI
public:
ScannedEventArgs();

See Also

Reference

ScannedEventArgs Class
ScannedEventArgs Members


PageNumber Property

PageNumber Property
Accusoft.ISISXpressSdk Namespace > ScannedEventArgs Class : PageNumber Property

Gets the page number of the scan that just completed.

Syntax

Visual Basic (Declaration)
Public Property PageNumber As Integer
Visual Basic (Usage) Copy Code
Dim instance As ScannedEventArgs
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
C#
public int PageNumber {get; set;}
Managed Extensions for C++
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
C++/CLI
public:
property int PageNumber {
   int get();
   void set (intvalue);
}

Return Value

An integer value which represents the page number.

See Also

Reference

ScannedEventArgs Class
ScannedEventArgs Members


Scanner Class

Scanner Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : Scanner Class

This class implements the specific Scanner settings, methods and properties.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Scanner
Visual Basic (Usage) Copy Code
Dim instance As Scanner
C#
public class Scanner
Managed Extensions for C++
public __gc class Scanner
C++/CLI
public ref class Scanner

Inheritance Hierarchy

System.Object
Accusoft.ISISXpressSdk.Scanner

See Also

Reference

Scanner Members
Accusoft.ISISXpressSdk Namespace


Scanner Class Members

Scanner Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : Scanner Class

The following tables list the members exposed by Scanner.

Public Constructors

 | Name | Description
Public Constructor | Scanner Constructor | The main constructor for the Scanner class which passes in an instance ID.
Top

Public Methods

 | Name | Description
Public Method | Cancel | Overloaded. Cancels the scanning process.
Public Method | ClearScanAheadPages | Clears the scanner's buffers of any scanned in ahead pages.
Public Method | GetConnectedDriversAndScannerModels | Gets a list of connected ISIS drivers and scanner models and places them in the given driverAndScannerList object.
Public Method | GetDriversAndScannerModels | Gets a list of available ISIS drivers and scanner models and places them in the given driverAndScannerList object.
Public Method | LoadDriver | Preloads the ISIS drivers used for scanning and saving an image.
Public Method | LoadSettings | Loads the settings for the current scanner from an .ini file.
Public Method | SaveSettings | Saves the settings for the current scanner to an .ini file.
Public Method | ScanBatch | Starts a batch scan process.
Public Method | ScanSingle | Scans a single page and stores it in the file specified in the Filename property. A single page is a defined as one side of a page, in a single bit depth. If multi stream is enabled this call will only pull in one part of the image for each time it is called.
Public Method | Select | Overloaded. Displays a predefined dialog box that allows the user to choose a scanner, add a scanner, or configure a scanner.
Public Method | SelectConnected | Overloaded. Displays a predefined dialog box that allows the user to choose a connected scanner, add a scanner, or configure a scanner.
Public Method | Setup | Overloaded. Displays a pre-defined dialog that allows the user to change driver specific scanner settings.
Top

Public Properties

 | Name | Description
Public Property | DriverDirectory | Gets and sets the location of the ISIS driver files.
Public Property | DriverDirectoryDefault | Gets the default location of the ISIS driver files.
Public Property | DriverLoaded | Gets an indicator if the scanner driver is loaded.
Public Property | Name | Gets and sets the name of the scanner driver.
Public Property | Setting | Gets the current scanner settings.
Public Property | UseCompression | Gets and sets an indicator to enable hardware compression if the scanner supports it.
Top

See Also

Reference

Scanner Class
Accusoft.ISISXpressSdk Namespace


Scanner Class Methods

Scanner Class Methods
Accusoft.ISISXpressSdk Namespace : Scanner Class

For a list of all members of this type, see Scanner members.

Public Methods

 | Name | Description
Public Method | Cancel | Overloaded. Cancels the scanning process.
Public Method | ClearScanAheadPages | Clears the scanner's buffers of any scanned in ahead pages.
Public Method | GetConnectedDriversAndScannerModels | Gets a list of connected ISIS drivers and scanner models and places them in the given driverAndScannerList object.
Public Method | GetDriversAndScannerModels | Gets a list of available ISIS drivers and scanner models and places them in the given driverAndScannerList object.
Public Method | LoadDriver | Preloads the ISIS drivers used for scanning and saving an image.
Public Method | LoadSettings | Loads the settings for the current scanner from an .ini file.
Public Method | SaveSettings | Saves the settings for the current scanner to an .ini file.
Public Method | ScanBatch | Starts a batch scan process.
Public Method | ScanSingle | Scans a single page and stores it in the file specified in the Filename property. A single page is a defined as one side of a page, in a single bit depth. If multi stream is enabled this call will only pull in one part of the image for each time it is called.
Public Method | Select | Overloaded. Displays a predefined dialog box that allows the user to choose a scanner, add a scanner, or configure a scanner.
Public Method | SelectConnected | Overloaded. Displays a predefined dialog box that allows the user to choose a connected scanner, add a scanner, or configure a scanner.
Public Method | Setup | Overloaded. Displays a pre-defined dialog that allows the user to change driver specific scanner settings.
Top

See Also

Reference

Scanner Class
Accusoft.ISISXpressSdk Namespace


Scanner Class Properties

Scanner Class Properties
Accusoft.ISISXpressSdk Namespace : Scanner Class

For a list of all members of this type, see Scanner members.

Public Properties

 | Name | Description
Public Property | DriverDirectory | Gets and sets the location of the ISIS driver files.
Public Property | DriverDirectoryDefault | Gets the default location of the ISIS driver files.
Public Property | DriverLoaded | Gets an indicator if the scanner driver is loaded.
Public Property | Name | Gets and sets the name of the scanner driver.
Public Property | Setting | Gets the current scanner settings.
Public Property | UseCompression | Gets and sets an indicator to enable hardware compression if the scanner supports it.
Top

See Also

Reference

Scanner Class
Accusoft.ISISXpressSdk Namespace


Scanner Constructor

Scanner Constructor
Accusoft.ISISXpressSdk Namespace > Scanner Class : Scanner Constructor

instanceId
An integer value which represents the ISIS Xpress instance ID.
The main constructor for the Scanner class which passes in an instance ID.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal instanceId As IntPtr _
)
Visual Basic (Usage) Copy Code
Dim instanceId As IntPtr

Dim instance As Scanner(instanceId)
C#
public Scanner(
   IntPtr instanceId
)
Managed Extensions for C++
public: Scanner(
   IntPtr instanceId
)
C++/CLI
public:
Scanner(
   IntPtr instanceId
)

Parameters

instanceId
An integer value which represents the ISIS Xpress instance ID.

See Also

Reference

Scanner Class
Scanner Members


Cancel Method

Cancel Method
Accusoft.ISISXpressSdk Namespace > Scanner Class : Cancel Method

Cancels the scanning process.

Overload List

Overload | Description
Cancel() | Cancels the scanning process.
Cancel(Boolean) | Cancels the scanning process allowing to pass in a boolean value.

See Also

Reference

Scanner Class
Scanner Members


Cancel() Method

Cancel() Method
Accusoft.ISISXpressSdk Namespace > Scanner Class > Cancel Method : Cancel() Method

Cancels the scanning process.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Cancel()
Visual Basic (Usage) Copy Code
Dim instance As Scanner

instance.Cancel()
C#
public void Cancel()
Managed Extensions for C++
public: void Cancel();
C++/CLI
public:
void Cancel();

Remarks

Immediately cancels the scanning process. This cancellation occurs even if ISIS Xpress is in the middle of transferring data from the scanner.

See Also

Reference

Scanner Class
Scanner Members
Overload List


Cancel(Boolean) Method

Cancel(Boolean) Method
Accusoft.ISISXpressSdk Namespace > Scanner Class > Cancel Method : Cancel(Boolean) Method

immediate
A boolean value which should be set to true to immediately cancel the process. Otherwise, false should be set to wait until the current page is transferred from the scanner.
Cancels the scanning process allowing to pass in a boolean value.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Cancel( _
   ByVal immediate As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Scanner
Dim immediate As Boolean

instance.Cancel(immediate)
C#
public void Cancel(
   bool immediate
)
Managed Extensions for C++
public: void Cancel(
   bool immediate
)
C++/CLI
public:
void Cancel(
   bool immediate
)

Parameters

immediate
A boolean value which should be set to true to immediately cancel the process. Otherwise, false should be set to wait until the current page is transferred from the scanner.

Remarks

If the immediate parameter is false, this method causes the scanner to wait til the current page is transferred from the scanner before the scanning process is cancelled. If the ScanSettingInfo ScanAhead value is enabled and the scanner driver supports the ScanSettingInfo ScanAheadPages setting, then ISIS Xpress processes those pages that have been scanned ahead, otherwise ISIS Xpress stops processing all pages.

See Also

Reference

Scanner Class
Scanner Members
Overload List


ClearScanAheadPages Method

ClearScanAheadPages Method
Accusoft.ISISXpressSdk Namespace > Scanner Class : ClearScanAheadPages Method

Clears the scanner's buffers of any scanned in ahead pages.

Syntax

Visual Basic (Declaration)
Public Sub ClearScanAheadPages()
Visual Basic (Usage) Copy Code
Dim instance As Scanner

instance.ClearScanAheadPages()
C#
public void ClearScanAheadPages()
Managed Extensions for C++
public: void ClearScanAheadPages();
C++/CLI
public:
void ClearScanAheadPages();

Remarks

Call this method if a Cancel method was performed while the scanner was set to scan ahead with the ScanSettingInfo scan setting set to ScanAhead.On. This flushes the scanner's buffers of any unprocessed pages.

See Also

Reference

Scanner Class
Scanner Members


GetConnectedDriversAndScannerModels Method

GetConnectedDriversAndScannerModels Method
Accusoft.ISISXpressSdk Namespace > Scanner Class : GetConnectedDriversAndScannerModels Method

driverAndScannerList
A DriverAndScannerList object.
Gets a list of connected ISIS drivers and scanner models and places them in the given driverAndScannerList object.

Syntax

Visual Basic (Declaration)
Public Sub GetConnectedDriversAndScannerModels( _
   ByRef driverAndScannerList As DriverAndScannerList _
)
Visual Basic (Usage) Copy Code
Dim instance As Scanner
Dim driverAndScannerList As DriverAndScannerList

instance.GetConnectedDriversAndScannerModels(driverAndScannerList)
C#
public void GetConnectedDriversAndScannerModels(
   out DriverAndScannerList driverAndScannerList
)
Managed Extensions for C++
public: void GetConnectedDriversAndScannerModels(
   [PARAMFLAG::Out] DriverAndScannerList* driverAndScannerList
)
C++/CLI
public:
void GetConnectedDriversAndScannerModels(
   [Out] DriverAndScannerList^ driverAndScannerList
)

Parameters

driverAndScannerList
A DriverAndScannerList object.

See Also

Reference

Scanner Class
Scanner Members


GetDriversAndScannerModels Method

GetDriversAndScannerModels Method
Accusoft.ISISXpressSdk Namespace > Scanner Class : GetDriversAndScannerModels Method

driverAndScannerList
A DriverAndScannerList object.
Gets a list of available ISIS drivers and scanner models and places them in the given driverAndScannerList object.

Syntax

Visual Basic (Declaration)
Public Sub GetDriversAndScannerModels( _
   ByRef driverAndScannerList As DriverAndScannerList _
)
Visual Basic (Usage) Copy Code
Dim instance As Scanner
Dim driverAndScannerList As DriverAndScannerList

instance.GetDriversAndScannerModels(driverAndScannerList)
C#
public void GetDriversAndScannerModels(
   out DriverAndScannerList driverAndScannerList
)
Managed Extensions for C++
public: void GetDriversAndScannerModels(
   [PARAMFLAG::Out] DriverAndScannerList* driverAndScannerList
)
C++/CLI
public:
void GetDriversAndScannerModels(
   [Out] DriverAndScannerList^ driverAndScannerList
)

Parameters

driverAndScannerList
A DriverAndScannerList object.

See Also

Reference

Scanner Class
Scanner Members


LoadDriver Method

LoadDriver Method
Accusoft.ISISXpressSdk Namespace > Scanner Class : LoadDriver Method

Preloads the ISIS drivers used for scanning and saving an image.

Syntax

Visual Basic (Declaration)
Public Sub LoadDriver()
Visual Basic (Usage) Copy Code
Dim instance As Scanner

instance.LoadDriver()
C#
public void LoadDriver()
Managed Extensions for C++
public: void LoadDriver();
C++/CLI
public:
void LoadDriver();

Remarks

This is an optimization method that can be used to improve performance. If this method is not called, there is a slight delay before the first scan is started because the control must first load the ISIS drivers. This method should only be called one time.

The following properties affect the ISIS drivers and can cause them to be reloaded:

  • Output.FileType property
  • Output.CreateFiles property
  • Scanner.UseCompression property

If the properties need to be changed they should be modified and then this method called so the control is ready to scan. This results in the scan starting immediately when the ScanSingle or Scanner.ScanBatch methods are called since the ISIS drivers have already been preloaded.

See Also

Reference

Scanner Class
Scanner Members


LoadSettings Method

LoadSettings Method
Accusoft.ISISXpressSdk Namespace > Scanner Class : LoadSettings Method

filename
A string which represents the filename.
Loads the settings for the current scanner from an .ini file.

Syntax

Visual Basic (Declaration)
Public Sub LoadSettings( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Scanner
Dim filename As String

instance.LoadSettings(filename)
C#
public void LoadSettings(
   string filename
)
Managed Extensions for C++
public: void LoadSettings(
   string* filename
)
C++/CLI
public:
void LoadSettings(
   String^ filename
)

Parameters

filename
A string which represents the filename.

Remarks

The same .ini file can be used for multiple scanners because the settings are saved under a different section for each scanner. The section name used in the .ini file is the name of the scanner driver.

See Also

Reference

Scanner Class
Scanner Members


SaveSettings Method

SaveSettings Method
Accusoft.ISISXpressSdk Namespace > Scanner Class : SaveSettings Method

filename
A string which represents the filename.
Saves the settings for the current scanner to an .ini file.

Syntax

Visual Basic (Declaration)
Public Sub SaveSettings( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Scanner
Dim filename As String

instance.SaveSettings(filename)
C#
public void SaveSettings(
   string filename
)
Managed Extensions for C++
public: void SaveSettings(
   string* filename
)
C++/CLI
public:
void SaveSettings(
   String^ filename
)

Parameters

filename
A string which represents the filename.

Remarks

The same .ini file can be used for multiple scanners because the settings are saved under a different section for each scanner. The section name used in the .ini file is the name of the scanner driver.

See Also

Reference

Scanner Class
Scanner Members


ScanBatch Method

ScanBatch Method
Accusoft.ISISXpressSdk Namespace > Scanner Class : ScanBatch Method

Starts a batch scan process.

Syntax

Visual Basic (Declaration)
Public Sub ScanBatch()
Visual Basic (Usage) Copy Code
Dim instance As Scanner

instance.ScanBatch()
C#
public void ScanBatch()
Managed Extensions for C++
public: void ScanBatch();
C++/CLI
public:
void ScanBatch();

Remarks

During the scan process, an IsisXpress.Scanning event is fired before the scan to allow the filename to be changed. If the Scanner.UseCompression property is false, then the IsisXpress.Progress events are fired during the scan. After a page has completed, the IsisXpress.Scanned event fires.

Note: If the UseSchema property is true, then ISIS Xpress generates a naming schema to use for filenames. The generated filename can be checked and changed in each IsisXpress.Scanning event.

IMPORTANT! This method does not finish until the FeederEmptyEventArgs.StopScan property is set to true in the IsisXpress.FeederEmpty event to indicate the batch is done or until the Cancel method is called.

When the scanner feeder is empty, an IsisXpress.FeederEmpty event is fired. This event may fire after each scan if you are using a scanner that does not have a feeder or a scanner that cannot detect paper in the feeder.

See Also

Reference

Scanner Class
Scanner Members


ScanSingle Method

ScanSingle Method
Accusoft.ISISXpressSdk Namespace > Scanner Class : ScanSingle Method

Scans a single page and stores it in the file specified in the Filename property. A single page is a defined as one side of a page, in a single bit depth. If multi stream is enabled this call will only pull in one part of the image for each time it is called.

Syntax

Visual Basic (Declaration)
Public Sub ScanSingle()
Visual Basic (Usage) Copy Code
Dim instance As Scanner

instance.ScanSingle()
C#
public void ScanSingle()
Managed Extensions for C++
public: void ScanSingle();
C++/CLI
public:
void ScanSingle();

See Also

Reference

Scanner Class
Scanner Members


Select Method

Select Method
Accusoft.ISISXpressSdk Namespace > Scanner Class : Select Method

Displays a predefined dialog box that allows the user to choose a scanner, add a scanner, or configure a scanner.

Overload List

Overload | Description
Select() | Displays a predefined dialog box that allows the user to choose a scanner, add a scanner, or configure a scanner.
Select(IntPtr) | Displays a predefined dialog box that allows the user to choose a scanner, add a scanner, or configure a scanner. A valid application window handle will present this dialog as modal.

See Also

Reference

Scanner Class
Scanner Members


Select() Method

Select() Method
Accusoft.ISISXpressSdk Namespace > Scanner Class > Select Method : Select() Method

Displays a predefined dialog box that allows the user to choose a scanner, add a scanner, or configure a scanner.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Select()
Visual Basic (Usage) Copy Code
Dim instance As Scanner

instance.Select()
C#
public void Select()
Managed Extensions for C++
public: void Select();
C++/CLI
public:
void Select();

See Also

Reference

Scanner Class
Scanner Members
Overload List


Select(IntPtr) Method

Select(IntPtr) Method
Accusoft.ISISXpressSdk Namespace > Scanner Class > Select Method : Select(IntPtr) Method

hWnd
A pointer to the application window handle.
Displays a predefined dialog box that allows the user to choose a scanner, add a scanner, or configure a scanner. A valid application window handle will present this dialog as modal.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Select( _
   ByVal hWnd As IntPtr _
)
Visual Basic (Usage) Copy Code
Dim instance As Scanner
Dim hWnd As IntPtr

instance.Select(hWnd)
C#
public void Select(
   IntPtr hWnd
)
Managed Extensions for C++
public: void Select(
   IntPtr hWnd
)
C++/CLI
public:
void Select(
   IntPtr hWnd
)

Parameters

hWnd
A pointer to the application window handle.

See Also

Reference

Scanner Class
Scanner Members
Overload List


SelectConnected Method

SelectConnected Method
Accusoft.ISISXpressSdk Namespace > Scanner Class : SelectConnected Method

Displays a predefined dialog box that allows the user to choose a connected scanner, add a scanner, or configure a scanner.

Overload List

Overload | Description
SelectConnected() | Displays a predefined dialog box that allows the user to choose a connected scanner, add a scanner, or configure a scanner.
SelectConnected(IntPtr) | Displays a predefined dialog box that allows the user to choose a connected scanner, add a scanner, or configure a scanner. A valid application window handle will present this dialog as modal.

See Also

Reference

Scanner Class
Scanner Members


SelectConnected() Method

SelectConnected() Method
Accusoft.ISISXpressSdk Namespace > Scanner Class > SelectConnected Method : SelectConnected() Method

Displays a predefined dialog box that allows the user to choose a connected scanner, add a scanner, or configure a scanner.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SelectConnected()
Visual Basic (Usage) Copy Code
Dim instance As Scanner

instance.SelectConnected()
C#
public void SelectConnected()
Managed Extensions for C++
public: void SelectConnected();
C++/CLI
public:
void SelectConnected();

See Also

Reference

Scanner Class
Scanner Members
Overload List


SelectConnected(IntPtr) Method

SelectConnected(IntPtr) Method
Accusoft.ISISXpressSdk Namespace > Scanner Class > SelectConnected Method : SelectConnected(IntPtr) Method

hWnd
A pointer to the application window handle.
Displays a predefined dialog box that allows the user to choose a connected scanner, add a scanner, or configure a scanner. A valid application window handle will present this dialog as modal.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SelectConnected( _
   ByVal hWnd As IntPtr _
)
Visual Basic (Usage) Copy Code
Dim instance As Scanner
Dim hWnd As IntPtr

instance.SelectConnected(hWnd)
C#
public void SelectConnected(
   IntPtr hWnd
)
Managed Extensions for C++
public: void SelectConnected(
   IntPtr hWnd
)
C++/CLI
public:
void SelectConnected(
   IntPtr hWnd
)

Parameters

hWnd
A pointer to the application window handle.

See Also

Reference

Scanner Class
Scanner Members
Overload List


Setup Method

Setup Method
Accusoft.ISISXpressSdk Namespace > Scanner Class : Setup Method

Displays a pre-defined dialog that allows the user to change driver specific scanner settings.

Overload List

Overload | Description
Setup() | Displays a pre-defined dialog that allows the user to change driver specific scanner settings.
Setup(SetupOptions) | Displays a pre-defined dialog that allows the user to change driver specific scanner settings and allows passing in a SetupOptions enumeration value parameter.
Setup(Int32,SetupOptions) | Displays a pre-defined dialog that allows the user to change driver specific scanner settings and allows passing in a SetupOptions enumeration value parameter.

See Also

Reference

Scanner Class
Scanner Members


Setup() Method

Setup() Method
Accusoft.ISISXpressSdk Namespace > Scanner Class > Setup Method : Setup() Method

Displays a pre-defined dialog that allows the user to change driver specific scanner settings.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Setup()
Visual Basic (Usage) Copy Code
Dim instance As Scanner

instance.Setup()
C#
public void Setup()
Managed Extensions for C++
public: void Setup();
C++/CLI
public:
void Setup();

See Also

Reference

Scanner Class
Scanner Members
Overload List


Setup(SetupOptions) Method

Setup(SetupOptions) Method
Accusoft.ISISXpressSdk Namespace > Scanner Class > Setup Method : Setup(SetupOptions) Method

setupOption
An SetupOptions enumeration value option.
Displays a pre-defined dialog that allows the user to change driver specific scanner settings and allows passing in a SetupOptions enumeration value parameter.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Setup( _
   ByVal setupOption As SetupOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As Scanner
Dim setupOption As SetupOptions

instance.Setup(setupOption)
C#
public void Setup(
   SetupOptions setupOption
)
Managed Extensions for C++
public: void Setup(
   SetupOptions setupOption
)
C++/CLI
public:
void Setup(
   SetupOptions setupOption
)

Parameters

setupOption
An SetupOptions enumeration value option.

See Also

Reference

Scanner Class
Scanner Members
Overload List


Setup(Int32,SetupOptions) Method

Setup(Int32,SetupOptions) Method
Accusoft.ISISXpressSdk Namespace > Scanner Class > Setup Method : Setup(Int32,SetupOptions) Method

windowHandle
An integer value which represents the window handle.
setupOption
An SetupOptions enumeration value option.
Displays a pre-defined dialog that allows the user to change driver specific scanner settings and allows passing in a SetupOptions enumeration value parameter.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Setup( _
   ByVal windowHandle As Integer, _
   ByVal setupOption As SetupOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As Scanner
Dim windowHandle As Integer
Dim setupOption As SetupOptions

instance.Setup(windowHandle, setupOption)
C#
public void Setup(
   int windowHandle,
   SetupOptions setupOption
)
Managed Extensions for C++
public: void Setup(
   int windowHandle,
   SetupOptions setupOption
)
C++/CLI
public:
void Setup(
   int windowHandle,
   SetupOptions setupOption
)

Parameters

windowHandle
An integer value which represents the window handle.
setupOption
An SetupOptions enumeration value option.

See Also

Reference

Scanner Class
Scanner Members
Overload List


DriverDirectory Property

DriverDirectory Property
Accusoft.ISISXpressSdk Namespace > Scanner Class : DriverDirectory Property

Gets and sets the location of the ISIS driver files.

Syntax

Visual Basic (Declaration)
Public Property DriverDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As Scanner
Dim value As String

instance.DriverDirectory = value

value = instance.DriverDirectory
C#
public string DriverDirectory {get; set;}
Managed Extensions for C++
public: __property string* get_DriverDirectory();
public: __property void set_DriverDirectory(
   string* value
);
C++/CLI
public:
property String^ DriverDirectory {
   String^ get();
   void set (String^value);
}

Return Value

A string which represents the location of the ISIS driver files.

See Also

Reference

Scanner Class
Scanner Members


DriverDirectoryDefault Property

DriverDirectoryDefault Property
Accusoft.ISISXpressSdk Namespace > Scanner Class : DriverDirectoryDefault Property

Gets the default location of the ISIS driver files.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DriverDirectoryDefault As String
Visual Basic (Usage) Copy Code
Dim instance As Scanner
Dim value As String

value = instance.DriverDirectoryDefault
C#
public string DriverDirectoryDefault {get;}
Managed Extensions for C++
public: __property string* get_DriverDirectoryDefault();
C++/CLI
public:
property String^ DriverDirectoryDefault {
   String^ get();
}

Return Value

A string which represents the default location of the ISIS driver files.

See Also

Reference

Scanner Class
Scanner Members


DriverLoaded Property

DriverLoaded Property
Accusoft.ISISXpressSdk Namespace > Scanner Class : DriverLoaded Property

Gets an indicator if the scanner driver is loaded.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DriverLoaded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Scanner
Dim value As Boolean

value = instance.DriverLoaded
C#
public bool DriverLoaded {get;}
Managed Extensions for C++
public: __property bool get_DriverLoaded();
C++/CLI
public:
property bool DriverLoaded {
   bool get();
}

Return Value

A boolean value which is true if the scanner driver is loaded. Otherwise, false is returned.

See Also

Reference

Scanner Class
Scanner Members


Name Property

Name Property
Accusoft.ISISXpressSdk Namespace > Scanner Class : Name Property

Gets and sets the name of the scanner driver.

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As Scanner
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (String^value);
}

Return Value

A string which represents the name of the scanner driver.

Remarks

The default scanner is loaded at creation.

Note: This property fails if it is set with a name that is not spelled exactly correct.

See Also

Reference

Scanner Class
Scanner Members


Setting Property

Setting Property
Accusoft.ISISXpressSdk Namespace > Scanner Class : Setting Property

Gets the current scanner settings.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Setting As Setting
Visual Basic (Usage) Copy Code
Dim instance As Scanner
Dim value As Setting

value = instance.Setting
C#
[BrowsableAttribute(false)]
public Setting Setting {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Setting* get_Setting();
C++/CLI
[BrowsableAttribute(false)]
public:
property Setting^ Setting {
   Setting^ get();
}

Return Value

A Setting object that contains the current scanner settings.

See Also

Reference

Scanner Class
Scanner Members


UseCompression Property

UseCompression Property
Accusoft.ISISXpressSdk Namespace > Scanner Class : UseCompression Property

Gets and sets an indicator to enable hardware compression if the scanner supports it.

Syntax

Visual Basic (Declaration)
Public Property UseCompression As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Scanner
Dim value As Boolean

instance.UseCompression = value

value = instance.UseCompression
C#
public bool UseCompression {get; set;}
Managed Extensions for C++
public: __property bool get_UseCompression();
public: __property void set_UseCompression(
   bool value
);
C++/CLI
public:
property bool UseCompression {
   bool get();
   void set (boolvalue);
}

Return Value

A boolean value which is true to enable hardware compression. Otherwise, false is returned.

See Also

Reference

Scanner Class
Scanner Members


ScannerLoadedException Class

ScannerLoadedException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : ScannerLoadedException Class

This class implements the ScannerLoadedExceptions.

Object Model

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public NotInheritable Class ScannerLoadedException
   Inherits IsisXpressLibraryException
Visual Basic (Usage) Copy Code
Dim instance As ScannerLoadedException
C#
[SerializableAttribute()]
public sealed class ScannerLoadedException : IsisXpressLibraryException
Managed Extensions for C++
[SerializableAttribute()]
public __gc __sealed class ScannerLoadedException : public IsisXpressLibraryException
C++/CLI
[SerializableAttribute()]
public ref class ScannerLoadedException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.ScannerLoadedException

See Also

Reference

ScannerLoadedException Members
Accusoft.ISISXpressSdk Namespace


ScannerLoadedException Class Members

ScannerLoadedException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : ScannerLoadedException Class

The following tables list the members exposed by ScannerLoadedException.

Public Constructors

 | Name | Description
Public Constructor | ScannerLoadedException Constructor | Overloaded. The main constructor for throwing errors when loading the scanner.
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ScannerLoadedException Class
Accusoft.ISISXpressSdk Namespace


ScannerLoadedException Class Methods

ScannerLoadedException Class Methods
Accusoft.ISISXpressSdk Namespace : ScannerLoadedException Class

For a list of all members of this type, see ScannerLoadedException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ScannerLoadedException Class
Accusoft.ISISXpressSdk Namespace


ScannerLoadedException Class Properties

ScannerLoadedException Class Properties
Accusoft.ISISXpressSdk Namespace : ScannerLoadedException Class

For a list of all members of this type, see ScannerLoadedException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ScannerLoadedException Class
Accusoft.ISISXpressSdk Namespace


ScannerLoadedException Constructor

ScannerLoadedException Constructor
Accusoft.ISISXpressSdk Namespace > ScannerLoadedException Class : ScannerLoadedException Constructor

The main constructor for throwing errors when loading the scanner.

Overload List

Overload | Description
ScannerLoadedException Constructor() | The main constructor for throwing errors when loading the scanner.
ScannerLoadedException Constructor(Int32) | A ScannerLoadedException constructor which allows passing in an error number.
ScannerLoadedException Constructor(Int32,String) | A ScannerLoadedException constructor which allows passing in an error number and an error message.
ScannerLoadedException Constructor(String) | A ScannerLoadedException constructor which allows passing in an error message.
ScannerLoadedException Constructor(String,Exception) | A ScannerLoadedException constructor which allows passing in an error message and an inner exception.

See Also

Reference

ScannerLoadedException Class
ScannerLoadedException Members


ScannerLoadedException Constructor()

ScannerLoadedException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ScannerLoadedException Class > ScannerLoadedException Constructor : ScannerLoadedException Constructor()

The main constructor for throwing errors when loading the scanner.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ScannerLoadedException()
C#
public ScannerLoadedException()
Managed Extensions for C++
public: ScannerLoadedException();
C++/CLI
public:
ScannerLoadedException();

See Also

Reference

ScannerLoadedException Class
ScannerLoadedException Members
Overload List


ScannerLoadedException Constructor(Int32)

ScannerLoadedException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ScannerLoadedException Class > ScannerLoadedException Constructor : ScannerLoadedException Constructor(Int32)

errorNumber
An integer value which represents the error number.
A ScannerLoadedException constructor which allows passing in an error number.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer

Dim instance As ScannerLoadedException(errorNumber)
C#
public ScannerLoadedException(
   int errorNumber
)
Managed Extensions for C++
public: ScannerLoadedException(
   int errorNumber
)
C++/CLI
public:
ScannerLoadedException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

ScannerLoadedException Class
ScannerLoadedException Members
Overload List


ScannerLoadedException Constructor(Int32,String)

ScannerLoadedException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ScannerLoadedException Class > ScannerLoadedException Constructor : ScannerLoadedException Constructor(Int32,String)

errorNumber
An integer value which represents an error number.
message
A string value which represents an error message.
A ScannerLoadedException constructor which allows passing in an error number and an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer
Dim message As String

Dim instance As ScannerLoadedException(errorNumber, message)
C#
public ScannerLoadedException(
   int errorNumber,
   string message
)
Managed Extensions for C++
public: ScannerLoadedException(
   int errorNumber,
   string* message
)
C++/CLI
public:
ScannerLoadedException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents an error number.
message
A string value which represents an error message.

See Also

Reference

ScannerLoadedException Class
ScannerLoadedException Members
Overload List


ScannerLoadedException Constructor(String)

ScannerLoadedException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ScannerLoadedException Class > ScannerLoadedException Constructor : ScannerLoadedException Constructor(String)

message
A string value which represents an error message.
A ScannerLoadedException constructor which allows passing in an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As ScannerLoadedException(message)
C#
public ScannerLoadedException(
   string message
)
Managed Extensions for C++
public: ScannerLoadedException(
   string* message
)
C++/CLI
public:
ScannerLoadedException(
   String^ message
)

Parameters

message
A string value which represents an error message.

See Also

Reference

ScannerLoadedException Class
ScannerLoadedException Members
Overload List


ScannerLoadedException Constructor(String,Exception)

ScannerLoadedException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ScannerLoadedException Class > ScannerLoadedException Constructor : ScannerLoadedException Constructor(String,Exception)

message
A string value which represents an error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
A ScannerLoadedException constructor which allows passing in an error message and an inner exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As ScannerLoadedException(message, innerException)
C#
public ScannerLoadedException(
   string message,
   Exception innerException
)
Managed Extensions for C++
public: ScannerLoadedException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
ScannerLoadedException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents an error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

ScannerLoadedException Class
ScannerLoadedException Members
Overload List


ScanningEventArgs Class

ScanningEventArgs Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : ScanningEventArgs Class

This class implements the event arguments for the IsisXpress.Scanning event.

Object Model

Syntax

Visual Basic (Declaration)
Public Class ScanningEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ScanningEventArgs
C#
public class ScanningEventArgs : EventArgs
Managed Extensions for C++
public __gc class ScanningEventArgs : public EventArgs
C++/CLI
public ref class ScanningEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ISISXpressSdk.ScanningEventArgs

See Also

Reference

ScanningEventArgs Members
Accusoft.ISISXpressSdk Namespace


ScanningEventArgs Class Members

ScanningEventArgs Class Members
See Also Properties Send Feedback
Accusoft.ISISXpressSdk Namespace : ScanningEventArgs Class

The following tables list the members exposed by ScanningEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ScanningEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | PageNumber | Gets the page number of the scan that is starting.
Top

See Also

Reference

ScanningEventArgs Class
Accusoft.ISISXpressSdk Namespace


ScanningEventArgs Class Properties

ScanningEventArgs Class Properties
Accusoft.ISISXpressSdk Namespace : ScanningEventArgs Class

For a list of all members of this type, see ScanningEventArgs members.

Public Properties

 | Name | Description
Public Property | PageNumber | Gets the page number of the scan that is starting.
Top

See Also

Reference

ScanningEventArgs Class
Accusoft.ISISXpressSdk Namespace


ScanningEventArgs Constructor

ScanningEventArgs Constructor
Accusoft.ISISXpressSdk Namespace > ScanningEventArgs Class : ScanningEventArgs Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ScanningEventArgs()
C#
public ScanningEventArgs()
Managed Extensions for C++
public: ScanningEventArgs();
C++/CLI
public:
ScanningEventArgs();

See Also

Reference

ScanningEventArgs Class
ScanningEventArgs Members


PageNumber Property

PageNumber Property
Accusoft.ISISXpressSdk Namespace > ScanningEventArgs Class : PageNumber Property

Gets the page number of the scan that is starting.

Syntax

Visual Basic (Declaration)
Public Property PageNumber As Integer
Visual Basic (Usage) Copy Code
Dim instance As ScanningEventArgs
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
C#
public int PageNumber {get; set;}
Managed Extensions for C++
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
C++/CLI
public:
property int PageNumber {
   int get();
   void set (intvalue);
}

Return Value

An integer value which represents the page number.

See Also

Reference

ScanningEventArgs Class
ScanningEventArgs Members


SequenceException Class

SequenceException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : SequenceException Class

This class implements the SequenceExceptions to throw when there is a sequence problem.

Object Model

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public NotInheritable Class SequenceException
   Inherits IsisXpressLibraryException
Visual Basic (Usage) Copy Code
Dim instance As SequenceException
C#
[SerializableAttribute()]
public sealed class SequenceException : IsisXpressLibraryException
Managed Extensions for C++
[SerializableAttribute()]
public __gc __sealed class SequenceException : public IsisXpressLibraryException
C++/CLI
[SerializableAttribute()]
public ref class SequenceException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.SequenceException

See Also

Reference

SequenceException Members
Accusoft.ISISXpressSdk Namespace


SequenceException Class Members

SequenceException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : SequenceException Class

The following tables list the members exposed by SequenceException.

Public Constructors

 | Name | Description
Public Constructor | SequenceException Constructor | Overloaded. The main constructor for the SequenceException class to throw when there is a sequence problem.
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SequenceException Class
Accusoft.ISISXpressSdk Namespace


SequenceException Class Methods

SequenceException Class Methods
Accusoft.ISISXpressSdk Namespace : SequenceException Class

For a list of all members of this type, see SequenceException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SequenceException Class
Accusoft.ISISXpressSdk Namespace


SequenceException Class Properties

SequenceException Class Properties
Accusoft.ISISXpressSdk Namespace : SequenceException Class

For a list of all members of this type, see SequenceException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SequenceException Class
Accusoft.ISISXpressSdk Namespace


SequenceException Constructor

SequenceException Constructor
Accusoft.ISISXpressSdk Namespace > SequenceException Class : SequenceException Constructor

The main constructor for the SequenceException class to throw when there is a sequence problem.

Overload List

Overload | Description
SequenceException Constructor() | The main constructor for the SequenceException class to throw when there is a sequence problem.
SequenceException Constructor(Int32) | A SequenceException which allows passing in an error number.
SequenceException Constructor(Int32,String) | A SequenceException which allows passing in an error number and an error message.
SequenceException Constructor(String) | A SequenceException which allows passing in an error message.
SequenceException Constructor(String,Exception) | A SequenceException which allows passing in an error message and an inner exception.

See Also

Reference

SequenceException Class
SequenceException Members


SequenceException Constructor()

SequenceException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SequenceException Class > SequenceException Constructor : SequenceException Constructor()

The main constructor for the SequenceException class to throw when there is a sequence problem.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SequenceException()
C#
public SequenceException()
Managed Extensions for C++
public: SequenceException();
C++/CLI
public:
SequenceException();

See Also

Reference

SequenceException Class
SequenceException Members
Overload List


SequenceException Constructor(Int32)

SequenceException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SequenceException Class > SequenceException Constructor : SequenceException Constructor(Int32)

errorNumber
An integer value which represents the error number.
A SequenceException which allows passing in an error number.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer

Dim instance As SequenceException(errorNumber)
C#
public SequenceException(
   int errorNumber
)
Managed Extensions for C++
public: SequenceException(
   int errorNumber
)
C++/CLI
public:
SequenceException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

SequenceException Class
SequenceException Members
Overload List


SequenceException Constructor(Int32,String)

SequenceException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SequenceException Class > SequenceException Constructor : SequenceException Constructor(Int32,String)

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.
A SequenceException which allows passing in an error number and an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer
Dim message As String

Dim instance As SequenceException(errorNumber, message)
C#
public SequenceException(
   int errorNumber,
   string message
)
Managed Extensions for C++
public: SequenceException(
   int errorNumber,
   string* message
)
C++/CLI
public:
SequenceException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

Reference

SequenceException Class
SequenceException Members
Overload List


SequenceException Constructor(String)

SequenceException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SequenceException Class > SequenceException Constructor : SequenceException Constructor(String)

message
A string value which represents the error message.
A SequenceException which allows passing in an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As SequenceException(message)
C#
public SequenceException(
   string message
)
Managed Extensions for C++
public: SequenceException(
   string* message
)
C++/CLI
public:
SequenceException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

SequenceException Class
SequenceException Members
Overload List


SequenceException Constructor(String,Exception)

SequenceException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SequenceException Class > SequenceException Constructor : SequenceException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
A SequenceException which allows passing in an error message and an inner exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As SequenceException(message, innerException)
C#
public SequenceException(
   string message,
   Exception innerException
)
Managed Extensions for C++
public: SequenceException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
SequenceException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

SequenceException Class
SequenceException Members
Overload List


Setting Class

Setting Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : Setting Class

This class implements the scanner settings.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Setting
Visual Basic (Usage) Copy Code
Dim instance As Setting
C#
public class Setting
Managed Extensions for C++
public __gc class Setting
C++/CLI
public ref class Setting

Inheritance Hierarchy

System.Object
Accusoft.ISISXpressSdk.Setting

See Also

Reference

Setting Members
Accusoft.ISISXpressSdk Namespace


Setting Class Members

Setting Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : Setting Class

The following tables list the members exposed by Setting.

Public Constructors

 | Name | Description
Public Constructor | Setting Constructor | The main constructor that allows passing in an ISIS Xpress instance ID.
Top

Public Methods

 | Name | Description
Public Method | ListLong | Overloaded. Returns a long value when the Setting.DataType property is a long list for the current scan setting.
Public Method | ListRational | Overloaded. Returns a rational value when the Setting.DataType property is a rational list for the current scan setting. The ListIndex property must be set to the index of the rational value to retrieve from the rational list before calling this property.
Public Method | ListString | Overloaded. Returns a string value when the Setting.DataType property is a string list for the current scan setting. The ListIndex property must be set to the index of the string value to retrieve from the string list before calling this property.
Public Method | LongDefault | Overloaded. Returns a long value at the specified index from the list of values for the default scan setting.
Public Method | RangeMaximumRational | Returns the highest possible rational value for the current scan setting when the scan setting is a range of values.
Public Method | RangeMinimumRational | Returns the lowest possible rational value for the current scan setting when the scan setting is a range of values.
Public Method | RationalDefault | Overloaded. Returns a rational value at the given index in the list of rational values for the default scan setting.
Public Method | RationalStep | Returns the increment or step of rationals when changing values.
Public Method | StringDefault | Returns a string value for the default scan setting.
Top

Public Properties

 | Name | Description
Public Property | Advanced | Gets and sets the advanced tag number.
Public Property | DataType | Gets the data type encoded information for the current scanner setting.
Public Property | ListCount | Gets the number of available choices when the Setting.DataType property is a list for the current scan setting.
Public Property | ListIndex | Gets and sets the index for the list item to access when the Setting.DataType property is a list of the current scan setting.
Public Property | LongValue | Gets and sets a long value for the current scanner setting.
Public Property | RangeMaximumLong | Gets the highest possible long value for the current scan setting when the scan setting is a range of values.
Public Property | RangeMinimumLong | Gets the lowest possible long value for the current scan setting when the scan setting is a range of values.
Public Property | RationalValue | Gets and sets a rational for the current scanner setting.
Public Property | ScanSetting | Gets and sets the ScanSettingInfo enumeration scanner setting.
Public Property | StringValue | Gets and sets a string for the current scanner setting.
Public Property | Supported | Gets an indicator if the current scan setting is supported.
Top

See Also

Reference

Setting Class
Accusoft.ISISXpressSdk Namespace


Setting Class Methods

Setting Class Methods
Accusoft.ISISXpressSdk Namespace : Setting Class

For a list of all members of this type, see Setting members.

Public Methods

 | Name | Description
Public Method | ListLong | Overloaded. Returns a long value when the Setting.DataType property is a long list for the current scan setting.
Public Method | ListRational | Overloaded. Returns a rational value when the Setting.DataType property is a rational list for the current scan setting. The ListIndex property must be set to the index of the rational value to retrieve from the rational list before calling this property.
Public Method | ListString | Overloaded. Returns a string value when the Setting.DataType property is a string list for the current scan setting. The ListIndex property must be set to the index of the string value to retrieve from the string list before calling this property.
Public Method | LongDefault | Overloaded. Returns a long value at the specified index from the list of values for the default scan setting.
Public Method | RangeMaximumRational | Returns the highest possible rational value for the current scan setting when the scan setting is a range of values.
Public Method | RangeMinimumRational | Returns the lowest possible rational value for the current scan setting when the scan setting is a range of values.
Public Method | RationalDefault | Overloaded. Returns a rational value at the given index in the list of rational values for the default scan setting.
Public Method | RationalStep | Returns the increment or step of rationals when changing values.
Public Method | StringDefault | Returns a string value for the default scan setting.
Top

See Also

Reference

Setting Class
Accusoft.ISISXpressSdk Namespace


Setting Class Properties

Setting Class Properties
Accusoft.ISISXpressSdk Namespace : Setting Class

For a list of all members of this type, see Setting members.

Public Properties

 | Name | Description
Public Property | Advanced | Gets and sets the advanced tag number.
Public Property | DataType | Gets the data type encoded information for the current scanner setting.
Public Property | ListCount | Gets the number of available choices when the Setting.DataType property is a list for the current scan setting.
Public Property | ListIndex | Gets and sets the index for the list item to access when the Setting.DataType property is a list of the current scan setting.
Public Property | LongValue | Gets and sets a long value for the current scanner setting.
Public Property | RangeMaximumLong | Gets the highest possible long value for the current scan setting when the scan setting is a range of values.
Public Property | RangeMinimumLong | Gets the lowest possible long value for the current scan setting when the scan setting is a range of values.
Public Property | RationalValue | Gets and sets a rational for the current scanner setting.
Public Property | ScanSetting | Gets and sets the ScanSettingInfo enumeration scanner setting.
Public Property | StringValue | Gets and sets a string for the current scanner setting.
Public Property | Supported | Gets an indicator if the current scan setting is supported.
Top

See Also

Reference

Setting Class
Accusoft.ISISXpressSdk Namespace


Setting Constructor

Setting Constructor
Accusoft.ISISXpressSdk Namespace > Setting Class : Setting Constructor

instanceId
The instance ID for the ISIS Xpress component.
The main constructor that allows passing in an ISIS Xpress instance ID.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal instanceId As IntPtr _
)
Visual Basic (Usage) Copy Code
Dim instanceId As IntPtr

Dim instance As Setting(instanceId)
C#
public Setting(
   IntPtr instanceId
)
Managed Extensions for C++
public: Setting(
   IntPtr instanceId
)
C++/CLI
public:
Setting(
   IntPtr instanceId
)

Parameters

instanceId
The instance ID for the ISIS Xpress component.

See Also

Reference

Setting Class
Setting Members


ListLong Method

ListLong Method
Accusoft.ISISXpressSdk Namespace > Setting Class : ListLong Method

Returns a long value when the Setting.DataType property is a long list for the current scan setting.

Overload List

Overload | Description
ListLong() | Returns a long value when the Setting.DataType property is a long list for the current scan setting.
ListLong(Int32) | Returns a long value when the Setting.DataType property is a long list for the current scan setting passing in an index value.

See Also

Reference

Setting Class
Setting Members


ListLong() Method

ListLong() Method
Accusoft.ISISXpressSdk Namespace > Setting Class > ListLong Method : ListLong() Method

Returns a long value when the Setting.DataType property is a long list for the current scan setting.

Syntax

Visual Basic (Declaration)
Public Overloads Function ListLong() As Integer
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim value As Integer

value = instance.ListLong()
C#
public int ListLong()
Managed Extensions for C++
public: int ListLong();
C++/CLI
public:
int ListLong();

Return Value

An integer value which represents a long value when the Setting.DataType property is a long list for the current scan setting.

Remarks

The ListIndex property must be set to the index of the long value to retrieve from the long list before calling this property.

See Also

Reference

Setting Class
Setting Members
Overload List


ListLong(Int32) Method

ListLong(Int32) Method
Accusoft.ISISXpressSdk Namespace > Setting Class > ListLong Method : ListLong(Int32) Method

index
An integer value which represents the index of the long list.
Returns a long value when the Setting.DataType property is a long list for the current scan setting passing in an index value.

Syntax

Visual Basic (Declaration)
Public Overloads Function ListLong( _
   ByVal index As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim index As Integer
Dim value As Integer

value = instance.ListLong(index)
C#
public int ListLong(
   int index
)
Managed Extensions for C++
public: int ListLong(
   int index
)
C++/CLI
public:
int ListLong(
   int index
)

Parameters

index
An integer value which represents the index of the long list.

Return Value

An integer value which represents a long value when the Setting.DataType property is a long list for the current scan setting.

Remarks

The ListIndex property must be set to the index of the rational value to retrieve from the rational list before calling this property.

See Also

Reference

Setting Class
Setting Members
Overload List


ListRational Method

ListRational Method
Accusoft.ISISXpressSdk Namespace > Setting Class : ListRational Method

Returns a rational value when the Setting.DataType property is a rational list for the current scan setting. The ListIndex property must be set to the index of the rational value to retrieve from the rational list before calling this property.

Overload List

Overload | Description
ListRational() | Returns a rational value when the Setting.DataType property is a rational list for the current scan setting. The ListIndex property must be set to the index of the rational value to retrieve from the rational list before calling this property.
ListRational(Int32) | Returns a rational value allowing passing in a given index.

See Also

Reference

Setting Class
Setting Members


ListRational() Method

ListRational() Method
Accusoft.ISISXpressSdk Namespace > Setting Class > ListRational Method : ListRational() Method

Returns a rational value when the Setting.DataType property is a rational list for the current scan setting. The ListIndex property must be set to the index of the rational value to retrieve from the rational list before calling this property.

Syntax

Visual Basic (Declaration)
Public Overloads Function ListRational() As RationalType
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim value As RationalType

value = instance.ListRational()
C#
public RationalType ListRational()
Managed Extensions for C++
public: RationalType* ListRational();
C++/CLI
public:
RationalType^ ListRational();

Return Value

An integer value which represents a rational value when the Setting.DataType is a rational list for the current scan setting.

Remarks

The ListIndex property must be set to the index of the rational value to retrieve from the rational list before calling this property.

See Also

Reference

Setting Class
Setting Members
Overload List


ListRational(Int32) Method

ListRational(Int32) Method
Accusoft.ISISXpressSdk Namespace > Setting Class > ListRational Method : ListRational(Int32) Method

index
An integer value which represents an index value from the list of values.
Returns a rational value allowing passing in a given index.

Syntax

Visual Basic (Declaration)
Public Overloads Function ListRational( _
   ByVal index As Integer _
) As RationalType
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim index As Integer
Dim value As RationalType

value = instance.ListRational(index)
C#
public RationalType ListRational(
   int index
)
Managed Extensions for C++
public: RationalType* ListRational(
   int index
)
C++/CLI
public:
RationalType^ ListRational(
   int index
)

Parameters

index
An integer value which represents an index value from the list of values.

Return Value

An integer value which represents the rational value from the list of values.

See Also

Reference

Setting Class
Setting Members
Overload List


ListString Method

ListString Method
Accusoft.ISISXpressSdk Namespace > Setting Class : ListString Method

Returns a string value when the Setting.DataType property is a string list for the current scan setting. The ListIndex property must be set to the index of the string value to retrieve from the string list before calling this property.

Overload List

Overload | Description
ListString() | Returns a string value when the Setting.DataType property is a string list for the current scan setting. The ListIndex property must be set to the index of the string value to retrieve from the string list before calling this property.
ListString(Int32) | Returns a string value when the Setting.DataType property is a string list for the current scan setting.

See Also

Reference

Setting Class
Setting Members


ListString() Method

ListString() Method
Accusoft.ISISXpressSdk Namespace > Setting Class > ListString Method : ListString() Method

Returns a string value when the Setting.DataType property is a string list for the current scan setting. The ListIndex property must be set to the index of the string value to retrieve from the string list before calling this property.

Syntax

Visual Basic (Declaration)
Public Overloads Function ListString() As String
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim value As String

value = instance.ListString()
C#
public string ListString()
Managed Extensions for C++
public: string* ListString();
C++/CLI
public:
String^ ListString();

Return Value

An integer value which represents a string value when the Setting.DataType property is a string list for the current scan setting.

See Also

Reference

Setting Class
Setting Members
Overload List


ListString(Int32) Method

ListString(Int32) Method
Accusoft.ISISXpressSdk Namespace > Setting Class > ListString Method : ListString(Int32) Method

index
An integer which represents the index of the string to retrieve from the string list.
Returns a string value when the Setting.DataType property is a string list for the current scan setting.

Syntax

Visual Basic (Declaration)
Public Overloads Function ListString( _
   ByVal index As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim index As Integer
Dim value As String

value = instance.ListString(index)
C#
public string ListString(
   int index
)
Managed Extensions for C++
public: string* ListString(
   int index
)
C++/CLI
public:
String^ ListString(
   int index
)

Parameters

index
An integer which represents the index of the string to retrieve from the string list.

Return Value

A string value which represents the current scan setting.

See Also

Reference

Setting Class
Setting Members
Overload List


LongDefault Method

LongDefault Method
Accusoft.ISISXpressSdk Namespace > Setting Class : LongDefault Method

Returns a long value at the specified index from the list of values for the default scan setting.

Overload List

Overload | Description
LongDefault(Int32) | Returns a long value at the specified index from the list of values for the default scan setting.
LongDefault() | Returns a long value for the default scan setting.

See Also

Reference

Setting Class
Setting Members


LongDefault(Int32) Method

LongDefault(Int32) Method
Accusoft.ISISXpressSdk Namespace > Setting Class > LongDefault Method : LongDefault(Int32) Method

index
An integer which represents an index in the list of long values.
Returns a long value at the specified index from the list of values for the default scan setting.

Syntax

Visual Basic (Declaration)
Public Overloads Function LongDefault( _
   ByVal index As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim index As Integer
Dim value As Integer

value = instance.LongDefault(index)
C#
public int LongDefault(
   int index
)
Managed Extensions for C++
public: int LongDefault(
   int index
)
C++/CLI
public:
int LongDefault(
   int index
)

Parameters

index
An integer which represents an index in the list of long values.

Return Value

An integer which represents a long value at the given index within the collection.

See Also

Reference

Setting Class
Setting Members
Overload List


LongDefault() Method

LongDefault() Method
Accusoft.ISISXpressSdk Namespace > Setting Class > LongDefault Method : LongDefault() Method

Returns a long value for the default scan setting.

Syntax

Visual Basic (Declaration)
Public Overloads Function LongDefault() As Integer
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim value As Integer

value = instance.LongDefault()
C#
public int LongDefault()
Managed Extensions for C++
public: int LongDefault();
C++/CLI
public:
int LongDefault();

Return Value

An integer value which represents the value for the default scan setting.

Remarks

This method is only available for Advanced settings.

See Also

Reference

Setting Class
Setting Members
Overload List


RangeMaximumRational Method

RangeMaximumRational Method
Accusoft.ISISXpressSdk Namespace > Setting Class : RangeMaximumRational Method

Returns the highest possible rational value for the current scan setting when the scan setting is a range of values.

Syntax

Visual Basic (Declaration)
Public Function RangeMaximumRational() As RationalType
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim value As RationalType

value = instance.RangeMaximumRational()
C#
public RationalType RangeMaximumRational()
Managed Extensions for C++
public: RationalType* RangeMaximumRational();
C++/CLI
public:
RationalType^ RangeMaximumRational();

Return Value

A RationalType object which represents the highest possible rational value for the current scan setting when the scan setting is a range of values.

Remarks

Check all values against this property before applying it because the lowest rational value can vary widely between different types of scanners.

See Also

Reference

Setting Class
Setting Members


RangeMinimumRational Method

RangeMinimumRational Method
Accusoft.ISISXpressSdk Namespace > Setting Class : RangeMinimumRational Method

Returns the lowest possible rational value for the current scan setting when the scan setting is a range of values.

Syntax

Visual Basic (Declaration)
Public Function RangeMinimumRational() As RationalType
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim value As RationalType

value = instance.RangeMinimumRational()
C#
public RationalType RangeMinimumRational()
Managed Extensions for C++
public: RationalType* RangeMinimumRational();
C++/CLI
public:
RationalType^ RangeMinimumRational();

Return Value

A RationalType object which represents the lowest possible rational value for the current scan setting when the scan setting is a range of values.

Remarks

Check all values against this property before applying it because the lowest rational value can vary widely between different types of scanners.

See Also

Reference

Setting Class
Setting Members


RationalDefault Method

RationalDefault Method
Accusoft.ISISXpressSdk Namespace > Setting Class : RationalDefault Method

Returns a rational value at the given index in the list of rational values for the default scan setting.

Overload List

Overload | Description
RationalDefault(Int32) | Returns a rational value at the given index in the list of rational values for the default scan setting.
RationalDefault() | Returns a rational value for the default scan setting.

See Also

Reference

Setting Class
Setting Members


RationalDefault(Int32) Method

RationalDefault(Int32) Method
Accusoft.ISISXpressSdk Namespace > Setting Class > RationalDefault Method : RationalDefault(Int32) Method

index
An integer which represents an index into the list of rational values.
Returns a rational value at the given index in the list of rational values for the default scan setting.

Syntax

Visual Basic (Declaration)
Public Overloads Function RationalDefault( _
   ByVal index As Integer _
) As RationalType
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim index As Integer
Dim value As RationalType

value = instance.RationalDefault(index)
C#
public RationalType RationalDefault(
   int index
)
Managed Extensions for C++
public: RationalType* RationalDefault(
   int index
)
C++/CLI
public:
RationalType^ RationalDefault(
   int index
)

Parameters

index
An integer which represents an index into the list of rational values.

Return Value

A rational value at the given index.

See Also

Reference

Setting Class
Setting Members
Overload List


RationalDefault() Method

RationalDefault() Method
Accusoft.ISISXpressSdk Namespace > Setting Class > RationalDefault Method : RationalDefault() Method

Returns a rational value for the default scan setting.

Syntax

Visual Basic (Declaration)
Public Overloads Function RationalDefault() As RationalType
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim value As RationalType

value = instance.RationalDefault()
C#
public RationalType RationalDefault()
Managed Extensions for C++
public: RationalType* RationalDefault();
C++/CLI
public:
RationalType^ RationalDefault();

Return Value

A RationalType object that represents the rational value for the default scan setting.

See Also

Reference

Setting Class
Setting Members
Overload List


RationalStep Method

RationalStep Method
Accusoft.ISISXpressSdk Namespace > Setting Class : RationalStep Method

Returns the increment or step of rationals when changing values.

Syntax

Visual Basic (Declaration)
Public Function RationalStep() As RationalType
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim value As RationalType

value = instance.RationalStep()
C#
public RationalType RationalStep()
Managed Extensions for C++
public: RationalType* RationalStep();
C++/CLI
public:
RationalType^ RationalStep();

Return Value

A RationalType object that represents the increment or step of rationals when changing values.

See Also

Reference

Setting Class
Setting Members


StringDefault Method

StringDefault Method
Accusoft.ISISXpressSdk Namespace > Setting Class : StringDefault Method

Returns a string value for the default scan setting.

Syntax

Visual Basic (Declaration)
Public Function StringDefault() As String
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim value As String

value = instance.StringDefault()
C#
public string StringDefault()
Managed Extensions for C++
public: string* StringDefault();
C++/CLI
public:
String^ StringDefault();

Return Value

A string which represents a value for the default scan setting.

Remarks

This method is only available for Advanced settings.

See Also

Reference

Setting Class
Setting Members


Advanced Property

Advanced Property
Accusoft.ISISXpressSdk Namespace > Setting Class : Advanced Property

Gets and sets the advanced tag number.

Syntax

Visual Basic (Declaration)
Public Property Advanced As Integer
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim value As Integer

instance.Advanced = value

value = instance.Advanced
C#
public int Advanced {get; set;}
Managed Extensions for C++
public: __property int get_Advanced();
public: __property void set_Advanced(
   int value
);
C++/CLI
public:
property int Advanced {
   int get();
   void set (intvalue);
}

Return Value

An integer value which represents the advanced tag number.

See Also

Reference

Setting Class
Setting Members


DataType Property

DataType Property
Accusoft.ISISXpressSdk Namespace > Setting Class : DataType Property

Gets the data type encoded information for the current scanner setting.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataType As DataTypeInfo
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim value As DataTypeInfo

value = instance.DataType
C#
public DataTypeInfo DataType {get;}
Managed Extensions for C++
public: __property DataTypeInfo get_DataType();
C++/CLI
public:
property DataTypeInfo DataType {
   DataTypeInfo get();
}

Return Value

The DataTypeInfo enumeration value set.

See Also

Reference

Setting Class
Setting Members
DataTypeInfo Enumeration


ListCount Property

ListCount Property
Accusoft.ISISXpressSdk Namespace > Setting Class : ListCount Property

Gets the number of available choices when the Setting.DataType property is a list for the current scan setting.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ListCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim value As Integer

value = instance.ListCount
C#
public int ListCount {get;}
Managed Extensions for C++
public: __property int get_ListCount();
C++/CLI
public:
property int ListCount {
   int get();
}

Return Value

An integer value which represents the number of choices when the Setting.DataType property is a list of the current scan setting.

Remarks

This property is used to get the maximum value that can be used to access the ListLong, ListRational, or ListString property arrays. The maximum value is ListCount property -1.

See Also

Reference

Setting Class
Setting Members


ListIndex Property

ListIndex Property
Accusoft.ISISXpressSdk Namespace > Setting Class : ListIndex Property

Gets and sets the index for the list item to access when the Setting.DataType property is a list of the current scan setting.

Syntax

Visual Basic (Declaration)
Public Property ListIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim value As Integer

instance.ListIndex = value

value = instance.ListIndex
C#
public int ListIndex {get; set;}
Managed Extensions for C++
public: __property int get_ListIndex();
public: __property void set_ListIndex(
   int value
);
C++/CLI
public:
property int ListIndex {
   int get();
   void set (intvalue);
}

See Also

Reference

Setting Class
Setting Members


LongValue Property

LongValue Property
Accusoft.ISISXpressSdk Namespace > Setting Class : LongValue Property

Gets and sets a long value for the current scanner setting.

Syntax

Visual Basic (Declaration)
Public Property LongValue As Integer
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim value As Integer

instance.LongValue = value

value = instance.LongValue
C#
public int LongValue {get; set;}
Managed Extensions for C++
public: __property int get_LongValue();
public: __property void set_LongValue(
   int value
);
C++/CLI
public:
property int LongValue {
   int get();
   void set (intvalue);
}

Return Value

An integer value which represents the current scanner setting.

See Also

Reference

Setting Class
Setting Members


RangeMaximumLong Property

RangeMaximumLong Property
Accusoft.ISISXpressSdk Namespace > Setting Class : RangeMaximumLong Property

Gets the highest possible long value for the current scan setting when the scan setting is a range of values.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RangeMaximumLong As Integer
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim value As Integer

value = instance.RangeMaximumLong
C#
public int RangeMaximumLong {get;}
Managed Extensions for C++
public: __property int get_RangeMaximumLong();
C++/CLI
public:
property int RangeMaximumLong {
   int get();
}

Return Value

An integer value which represents the highest possible long value for the current scan setting when the scan setting is a range of values.

Remarks

A value should always be checked against this property before applying it because the highest long value can vary widely between different types of scanners.

See Also

Reference

Setting Class
Setting Members


RangeMinimumLong Property

RangeMinimumLong Property
Accusoft.ISISXpressSdk Namespace > Setting Class : RangeMinimumLong Property

Gets the lowest possible long value for the current scan setting when the scan setting is a range of values.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RangeMinimumLong As Integer
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim value As Integer

value = instance.RangeMinimumLong
C#
public int RangeMinimumLong {get;}
Managed Extensions for C++
public: __property int get_RangeMinimumLong();
C++/CLI
public:
property int RangeMinimumLong {
   int get();
}

Return Value

An integer value which represents the lowest possible long value for the current scan setting when the scan setting is a range of values.

Remarks

A value should always be checked against this property before applying it because the lowest long value can vary widely between different types of scanners.

See Also

Reference

Setting Class
Setting Members


RationalValue Property

RationalValue Property
Accusoft.ISISXpressSdk Namespace > Setting Class : RationalValue Property

Gets and sets a rational for the current scanner setting.

Syntax

Visual Basic (Declaration)
Public Property RationalValue As RationalType
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim value As RationalType

instance.RationalValue = value

value = instance.RationalValue
C#
public RationalType RationalValue {get; set;}
Managed Extensions for C++
public: __property RationalType* get_RationalValue();
public: __property void set_RationalValue(
   RationalType* value
);
C++/CLI
public:
property RationalType^ RationalValue {
   RationalType^ get();
   void set (RationalType^value);
}

Return Value

A RationalType object for the current scanner setting.

See Also

Reference

Setting Class
Setting Members


ScanSetting Property

ScanSetting Property
Accusoft.ISISXpressSdk Namespace > Setting Class : ScanSetting Property

Gets and sets the ScanSettingInfo enumeration scanner setting.

Syntax

Visual Basic (Declaration)
Public Property ScanSetting As ScanSettingInfo
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim value As ScanSettingInfo

instance.ScanSetting = value

value = instance.ScanSetting
C#
public ScanSettingInfo ScanSetting {get; set;}
Managed Extensions for C++
public: __property ScanSettingInfo get_ScanSetting();
public: __property void set_ScanSetting(
   ScanSettingInfo value
);
C++/CLI
public:
property ScanSettingInfo ScanSetting {
   ScanSettingInfo get();
   void set (ScanSettingInfovalue);
}

Return Value

A ScanSettingInfo enumeration value set.

Remarks

All scanner settings are modified by setting the Scanner.Setting property's ScanSetting property to the appropriate setting and then using one of the setting properties such as the Setting.LongValue property or the Setting.StringValue property to set up the scanner.

Setting this property also automatically sets the Advanced property to true.

See Also

Reference

Setting Class
Setting Members


StringValue Property

StringValue Property
Accusoft.ISISXpressSdk Namespace > Setting Class : StringValue Property

Gets and sets a string for the current scanner setting.

Syntax

Visual Basic (Declaration)
Public Property StringValue As String
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim value As String

instance.StringValue = value

value = instance.StringValue
C#
public string StringValue {get; set;}
Managed Extensions for C++
public: __property string* get_StringValue();
public: __property void set_StringValue(
   string* value
);
C++/CLI
public:
property String^ StringValue {
   String^ get();
   void set (String^value);
}

See Also

Reference

Setting Class
Setting Members


Supported Property

Supported Property
Accusoft.ISISXpressSdk Namespace > Setting Class : Supported Property

Gets an indicator if the current scan setting is supported.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Supported As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Setting
Dim value As Boolean

value = instance.Supported
C#
public bool Supported {get;}
Managed Extensions for C++
public: __property bool get_Supported();
C++/CLI
public:
property bool Supported {
   bool get();
}

Return Value

A boolean value which is true if the current scan setting is supported. Otherwise, false is returned.

See Also

Reference

Setting Class
Setting Members


SettingUnavailableException Class

SettingUnavailableException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : SettingUnavailableException Class

This class implements the SettingUnavailableException to throw when the setting is not available.

Object Model

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public NotInheritable Class SettingUnavailableException
   Inherits IsisXpressLibraryException
Visual Basic (Usage) Copy Code
Dim instance As SettingUnavailableException
C#
[SerializableAttribute()]
public sealed class SettingUnavailableException : IsisXpressLibraryException
Managed Extensions for C++
[SerializableAttribute()]
public __gc __sealed class SettingUnavailableException : public IsisXpressLibraryException
C++/CLI
[SerializableAttribute()]
public ref class SettingUnavailableException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.SettingUnavailableException

See Also

Reference

SettingUnavailableException Members
Accusoft.ISISXpressSdk Namespace


SettingUnavailableException Class Members

SettingUnavailableException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : SettingUnavailableException Class

The following tables list the members exposed by SettingUnavailableException.

Public Constructors

 | Name | Description
Public Constructor | SettingUnavailableException Constructor | Overloaded. The main constructor for the SettingUnavailableException class to throw when the setting is not available.
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SettingUnavailableException Class
Accusoft.ISISXpressSdk Namespace


SettingUnavailableException Class Methods

SettingUnavailableException Class Methods
Accusoft.ISISXpressSdk Namespace : SettingUnavailableException Class

For a list of all members of this type, see SettingUnavailableException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SettingUnavailableException Class
Accusoft.ISISXpressSdk Namespace


SettingUnavailableException Class Properties

SettingUnavailableException Class Properties
Accusoft.ISISXpressSdk Namespace : SettingUnavailableException Class

For a list of all members of this type, see SettingUnavailableException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SettingUnavailableException Class
Accusoft.ISISXpressSdk Namespace


SettingUnavailableException Constructor

SettingUnavailableException Constructor
Accusoft.ISISXpressSdk Namespace > SettingUnavailableException Class : SettingUnavailableException Constructor

The main constructor for the SettingUnavailableException class to throw when the setting is not available.

Overload List

Overload | Description
SettingUnavailableException Constructor() | The main constructor for the SettingUnavailableException class to throw when the setting is not available.
SettingUnavailableException Constructor(Int32) | A SettingUnavailableException which allows passing in an error number.
SettingUnavailableException Constructor(Int32,String) | A SettingUnavailableException which allows passing in an error number and an error message.
SettingUnavailableException Constructor(String) | A SettingUnavailableException which allows passing in an error message.
SettingUnavailableException Constructor(String,Exception) | A SettingUnavailableException which allows passing in an error message and an inner exception.

See Also

Reference

SettingUnavailableException Class
SettingUnavailableException Members


SettingUnavailableException Constructor()

SettingUnavailableException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SettingUnavailableException Class > SettingUnavailableException Constructor : SettingUnavailableException Constructor()

The main constructor for the SettingUnavailableException class to throw when the setting is not available.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SettingUnavailableException()
C#
public SettingUnavailableException()
Managed Extensions for C++
public: SettingUnavailableException();
C++/CLI
public:
SettingUnavailableException();

See Also

Reference

SettingUnavailableException Class
SettingUnavailableException Members
Overload List


SettingUnavailableException Constructor(Int32)

SettingUnavailableException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SettingUnavailableException Class > SettingUnavailableException Constructor : SettingUnavailableException Constructor(Int32)

errorNumber
An integer value which represents the error number.
A SettingUnavailableException which allows passing in an error number.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer

Dim instance As SettingUnavailableException(errorNumber)
C#
public SettingUnavailableException(
   int errorNumber
)
Managed Extensions for C++
public: SettingUnavailableException(
   int errorNumber
)
C++/CLI
public:
SettingUnavailableException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

SettingUnavailableException Class
SettingUnavailableException Members
Overload List


SettingUnavailableException Constructor(Int32,String)

SettingUnavailableException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SettingUnavailableException Class > SettingUnavailableException Constructor : SettingUnavailableException Constructor(Int32,String)

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.
A SettingUnavailableException which allows passing in an error number and an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer
Dim message As String

Dim instance As SettingUnavailableException(errorNumber, message)
C#
public SettingUnavailableException(
   int errorNumber,
   string message
)
Managed Extensions for C++
public: SettingUnavailableException(
   int errorNumber,
   string* message
)
C++/CLI
public:
SettingUnavailableException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

Reference

SettingUnavailableException Class
SettingUnavailableException Members
Overload List


SettingUnavailableException Constructor(String)

SettingUnavailableException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SettingUnavailableException Class > SettingUnavailableException Constructor : SettingUnavailableException Constructor(String)

message
A string value which represents the error message.
A SettingUnavailableException which allows passing in an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As SettingUnavailableException(message)
C#
public SettingUnavailableException(
   string message
)
Managed Extensions for C++
public: SettingUnavailableException(
   string* message
)
C++/CLI
public:
SettingUnavailableException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

SettingUnavailableException Class
SettingUnavailableException Members
Overload List


SettingUnavailableException Constructor(String,Exception)

SettingUnavailableException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SettingUnavailableException Class > SettingUnavailableException Constructor : SettingUnavailableException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
A SettingUnavailableException which allows passing in an error message and an inner exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As SettingUnavailableException(message, innerException)
C#
public SettingUnavailableException(
   string message,
   Exception innerException
)
Managed Extensions for C++
public: SettingUnavailableException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
SettingUnavailableException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

SettingUnavailableException Class
SettingUnavailableException Members
Overload List


StringTooLongException Class

StringTooLongException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : StringTooLongException Class

This class implements the StringToolLongExceptions when the string is too long.

Object Model

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public NotInheritable Class StringTooLongException
   Inherits IsisXpressLibraryException
Visual Basic (Usage) Copy Code
Dim instance As StringTooLongException
C#
[SerializableAttribute()]
public sealed class StringTooLongException : IsisXpressLibraryException
Managed Extensions for C++
[SerializableAttribute()]
public __gc __sealed class StringTooLongException : public IsisXpressLibraryException
C++/CLI
[SerializableAttribute()]
public ref class StringTooLongException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.StringTooLongException

See Also

Reference

StringTooLongException Members
Accusoft.ISISXpressSdk Namespace


StringTooLongException Class Members

StringTooLongException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : StringTooLongException Class

The following tables list the members exposed by StringTooLongException.

Public Constructors

 | Name | Description
Public Constructor | StringTooLongException Constructor | Overloaded. The main constructor to throw when a string is too long.
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

StringTooLongException Class
Accusoft.ISISXpressSdk Namespace


StringTooLongException Class Methods

StringTooLongException Class Methods
Accusoft.ISISXpressSdk Namespace : StringTooLongException Class

For a list of all members of this type, see StringTooLongException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

StringTooLongException Class
Accusoft.ISISXpressSdk Namespace


StringTooLongException Class Properties

StringTooLongException Class Properties
Accusoft.ISISXpressSdk Namespace : StringTooLongException Class

For a list of all members of this type, see StringTooLongException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

StringTooLongException Class
Accusoft.ISISXpressSdk Namespace


StringTooLongException Constructor

StringTooLongException Constructor
Accusoft.ISISXpressSdk Namespace > StringTooLongException Class : StringTooLongException Constructor

The main constructor to throw when a string is too long.

Overload List

Overload | Description
StringTooLongException Constructor() | The main constructor to throw when a string is too long.
StringTooLongException Constructor(Int32) | A StringTooLongException which allows passing in an error number.
StringTooLongException Constructor(Int32,String) | A StringTooLongException which allows passing in an error number and an error message.
StringTooLongException Constructor(String) | A StringTooLongException which allows passing in an error message.
StringTooLongException Constructor(String,Exception) | A StringTooLongException which allows passing in an error message and inner exception.

See Also

Reference

StringTooLongException Class
StringTooLongException Members


StringTooLongException Constructor()

StringTooLongException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > StringTooLongException Class > StringTooLongException Constructor : StringTooLongException Constructor()

The main constructor to throw when a string is too long.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StringTooLongException()
C#
public StringTooLongException()
Managed Extensions for C++
public: StringTooLongException();
C++/CLI
public:
StringTooLongException();

See Also

Reference

StringTooLongException Class
StringTooLongException Members
Overload List


StringTooLongException Constructor(Int32)

StringTooLongException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > StringTooLongException Class > StringTooLongException Constructor : StringTooLongException Constructor(Int32)

errorNumber
An integer value which represents the error number.
A StringTooLongException which allows passing in an error number.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer

Dim instance As StringTooLongException(errorNumber)
C#
public StringTooLongException(
   int errorNumber
)
Managed Extensions for C++
public: StringTooLongException(
   int errorNumber
)
C++/CLI
public:
StringTooLongException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

StringTooLongException Class
StringTooLongException Members
Overload List


StringTooLongException Constructor(Int32,String)

StringTooLongException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > StringTooLongException Class > StringTooLongException Constructor : StringTooLongException Constructor(Int32,String)

errorNumber
An integer value which represents an error number.
message
A string value which represents the error message.
A StringTooLongException which allows passing in an error number and an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim errorNumber As Integer
Dim message As String

Dim instance As StringTooLongException(errorNumber, message)
C#
public StringTooLongException(
   int errorNumber,
   string message
)
Managed Extensions for C++
public: StringTooLongException(
   int errorNumber,
   string* message
)
C++/CLI
public:
StringTooLongException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents an error number.
message
A string value which represents the error message.

See Also

Reference

StringTooLongException Class
StringTooLongException Members
Overload List


StringTooLongException Constructor(String)

StringTooLongException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > StringTooLongException Class > StringTooLongException Constructor : StringTooLongException Constructor(String)

message
A string value which represents the error message.
A StringTooLongException which allows passing in an error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As StringTooLongException(message)
C#
public StringTooLongException(
   string message
)
Managed Extensions for C++
public: StringTooLongException(
   string* message
)
C++/CLI
public:
StringTooLongException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

StringTooLongException Class
StringTooLongException Members
Overload List


StringTooLongException Constructor(String,Exception)

StringTooLongException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > StringTooLongException Class > StringTooLongException Constructor : StringTooLongException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
A StringTooLongException which allows passing in an error message and inner exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As StringTooLongException(message, innerException)
C#
public StringTooLongException(
   string message,
   Exception innerException
)
Managed Extensions for C++
public: StringTooLongException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
StringTooLongException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

StringTooLongException Class
StringTooLongException Members
Overload List


DataTypeInfo Enumeration

DataTypeInfo Enumeration
Accusoft.ISISXpressSdk Namespace : DataTypeInfo Enumeration

Option values for the data type the information is encoded in for the current scanner setting.

Syntax

Visual Basic (Declaration)
Public Enum DataTypeInfo
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataTypeInfo
C#
public enum DataTypeInfo : Enum
Managed Extensions for C++
__value public enum DataTypeInfo : public Enum
C++/CLI
public enum class DataTypeInfo : public Enum

Members

Member | Description
RangeLong | 0 - A range of longs. For example 0 - 99.
ListLong | 1 - A list or array of longs. For example 200, 300, 400, 500.
ListString | 2 - A list or array of strings. For example "8.5 x 11 letter", "8.5 x 14 legal", and etc..
String | 3. - A string.
Long | 4 - A long. This can also be used for a byte or a short.
Rational | 5 - A rational. See the RationalType for more information. This data type is only available for Advanced settings.
ListRational | 6 - A list or array of rationals. For example 200/1, 300/1, 400/1, 500/1. This data type is only available for Advanced settings.
RangeRational | 7 - A range of rationals. For example 1/1 - 1200/1. See the Setting.RationalStep method for the increment between rationals. This data type is only available for Advanced settings.

Remarks

This value is set by using the Setting.DataType property.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ISISXpressSdk.DataTypeInfo

See Also

Reference

Accusoft.ISISXpressSdk Namespace


ErrorLevelInfo Enumeration

ErrorLevelInfo Enumeration
Accusoft.ISISXpressSdk Namespace : ErrorLevelInfo Enumeration

Option values to set the error level to use.

Syntax

Visual Basic (Declaration)
Public Enum ErrorLevelInfo
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ErrorLevelInfo
C#
public enum ErrorLevelInfo : Enum
Managed Extensions for C++
__value public enum ErrorLevelInfo : public Enum
C++/CLI
public enum class ErrorLevelInfo : public Enum

Members

Member | Description
Production | 0 - This setting produces the minimum amount of error information.
Development | 1 - This setting produces additional error information useful during development.
Detailed | 2 - This setting produces detailed error information useful when debugging a problem during development.

Remarks

The default value is Production.

This value is set using the IsisXpress.ErrorLevel property which can help in debugging an application during development.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ISISXpressSdk.ErrorLevelInfo

See Also

Reference

Accusoft.ISISXpressSdk Namespace


EvaluationChoice Enumeration

EvaluationChoice Enumeration
Accusoft.ISISXpressSdk Namespace : EvaluationChoice Enumeration

Option values for licensing the evaluation version within the component.

Syntax

Visual Basic (Declaration)
Public Enum EvaluationChoice
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As EvaluationChoice
C#
public enum EvaluationChoice : Enum
Managed Extensions for C++
__value public enum EvaluationChoice : public Enum
C++/CLI
public enum class EvaluationChoice : public Enum

Members

Member | Description
TrialDialog | 0 - After the trial period has expired, this option displays a dialog box each time the ISIS Xpess toolkit is accessed.
Timeout | 1 - After the trial period has expired, the ISIS Xpress component no longer functions.

Remarks

These values are set by using the Licensing.EvaluationMode property.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ISISXpressSdk.EvaluationChoice

See Also

Reference

Accusoft.ISISXpressSdk Namespace


FileTypeInfo Enumeration

FileTypeInfo Enumeration
Accusoft.ISISXpressSdk Namespace : FileTypeInfo Enumeration

Option values for the file format to use when saving images.

Syntax

Visual Basic (Declaration)
Public Enum FileTypeInfo
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As FileTypeInfo
C#
public enum FileTypeInfo : Enum
Managed Extensions for C++
__value public enum FileTypeInfo : public Enum
C++/CLI
public enum class FileTypeInfo : public Enum

Members

Member | Description
TiffRaw | 0 - No compression.
TiffPackBits | 1 - Packbits compression.
TiffG3 | 2 - CCITT (International Telegraph and Telephone Consultative Committee) Fax Group 3 compression.
TiffG3M | 3 - CCITT Fax Modified Group 3 compression.
TiffG4 | 4 - CCITT Fax Group 4 compression.
JpegColor | 5 - JPEG color compression.
JpegGray | 6 - JPEG Gray compression.
Dcx | 7 - DCX compression.

Remarks

This value is set by using the Output.FileType property.

1 bit (black and white) images can be saved to any of the five TIFF file formats or to the DCX file format. 8 bit (Gray Scale) images can be saved to the TiffRaw, TiffPackbits or JpegGray file formats. 24 bit (color) images can be saved to the TiffRaw, TiffPackbits or JPEG file formats.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ISISXpressSdk.FileTypeInfo

See Also

Reference

Accusoft.ISISXpressSdk Namespace


ScanAhead Enumeration

ScanAhead Enumeration
Accusoft.ISISXpressSdk Namespace : ScanAhead Enumeration

Option values for determining the scan ahead settings.

Syntax

Visual Basic (Declaration)
Public Enum ScanAhead
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ScanAhead
C#
public enum ScanAhead : Enum
Managed Extensions for C++
__value public enum ScanAhead : public Enum
C++/CLI
public enum class ScanAhead : public Enum

Members

Member | Description
Off | 0 - Scan ahead is off or disabled.
On | 1 - Scan ahead is on or enabled.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ISISXpressSdk.ScanAhead

See Also

Reference

Accusoft.ISISXpressSdk Namespace


ScanSettingInfo Enumeration

ScanSettingInfo Enumeration
Accusoft.ISISXpressSdk Namespace : ScanSettingInfo Enumeration

Option values for determining which scanner setting to query or set.

Syntax

Visual Basic (Declaration)
Public Enum ScanSettingInfo
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ScanSettingInfo
C#
public enum ScanSettingInfo : Enum
Managed Extensions for C++
__value public enum ScanSettingInfo : public Enum
C++/CLI
public enum class ScanSettingInfo : public Enum

Members

Member | Description
XResolution | 0 - The scanner's horizontal resolution in DPI (Dots Per Inch).
YResolution | 1 - The scanner's vertical resolution in DPI.
PageSize | 2 - The total area available to the scanner.
Brightness | 3 - The scanner's brightness. If available, -3 will set to auto brightness, -2 will auto darken, and -1 will auto lighten. Values from 0 to the Setting.RangeMaximumLong property incrementally change the brightness.
Contrast | 4 - The scanner's contrast. A value of 0 means auto contrast or no contrast control is available.
XPosition | 5 - Specifies the distance in pixels from the left edge of the page to the start of the image.
YPosition | 6 - Specifies the distance in pixels from the top edge of the page to the start of the image.
ImageWidth | 7 - Specifies the number of columns of pixels (width) in an image.
ImageLength | 8 - Specifies the number of rows of pixels (height) in an image.
ResUnit | 9 - Specifies the unit of measurement for XResolution and YResolution. This setting is not available for all scanners and if it is not available, the units are assumed to be DPI. 1. No absolute unit of measurement. Used for images that may have a non-square aspect ratio, but no meaningful absolute dimensions. 2. Resolution is specified in dots per inch (DPI). 3. Resolution is specified in dots per centimeter.
Source | 10 - Specifies the scanning source (flatbed, feeder, and etc.) on those scanners that support this functionality. See the Source enumeration for more information.
ScanAhead | 11 - Specifies if the scanning source has enabled the ability to continuously scan pages ahead of the current page the application is processing on those scanners that support this functionality. See the ScanAhead enumeration for more information.
ScanAheadMaxPages | 12 - If the ScanAhead is enabled, this setting specifies the maximum number of pages to scan ahead. A zero value means to scan until the feeder is empty.
ScanAheadPages | 13 - If the ScanAhead is enabled and this setting is supported, it determines how many pages have been scanned in ahead. On some scanners this value is not an accurate measurement for how many pages are scanned in ahead. Therefore, use this setting as a general indicator that there are pages waiting that have been scanned in ahead. This setting is read-only.
SamplesPerPixel | 14 - Indicates how many values each pixel uses to represent the data. Possible values are: 1 sample per pixel = Binary (black/white) and gray scale images; 3 samples per pixel = RGB color images.
BitsPerSample | 15 - Indicates how big a sample is. Typical values are: 1 = Binary; 4 = four-bit gray scale (16 shades of gray); 8 = eight-bit gray scale (256 shades of gray); 24 = 24-bit color.
AdvancedTag | 16 - Specifies the scanner's advanced tag number.

Remarks

All scanner settings are modified by setting the Setting.ScanSetting property to the appropriate setting and then using one of the setting properties such as the Setting.LongValue property or the Setting.StringValue property to set up the scanner.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ISISXpressSdk.ScanSettingInfo

See Also

Reference

Accusoft.ISISXpressSdk Namespace


SetupOptions Enumeration

SetupOptions Enumeration
Accusoft.ISISXpressSdk Namespace : SetupOptions Enumeration

Option values to modify what is displayed by the predefined scanner settings dialog.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum SetupOptions
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As SetupOptions
C#
[FlagsAttribute()]
public enum SetupOptions : Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum SetupOptions : public Enum
C++/CLI
[FlagsAttribute()]
public enum class SetupOptions : public Enum

Members

Member | Description
Normal | 0 - Displays the normal scanner settings dialog.
Binary | 1 - Displays a scanner settings dialog that only allows binary modes. This prevents the user from choosing grayscale or color modes.
Area | 2 - Displays a scanner settings dialog that shows the Area button. When the Area button is clicked, and Area dialog is displayed.
Return | 4 - Displays a scanner settings dialog that returns SCANERR_CANCEL if the user clicks the Cancel button. If this flag is not set, then the settings dialog is always returned with no error.
AreaPreview | 8 - Displays a scanner dialog that displays the Area button. When the Area button is clicked, an Area dialog, containing a preview window is displayed.

Remarks

These values are used with the Scanner.Setup methods.

This enumeration is a FlagsAttribute enumeration that can be treated as a bit field or a set of flags. The following example shows how this enumeration can be used:

ISISX.Scanner.Setup(Accusoft.ISISXpressSdk.SetupOptions.Binary | Accusoft.ISISXpressSdk.SetupOptions.Return);

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ISISXpressSdk.SetupOptions

See Also

Reference

Accusoft.ISISXpressSdk Namespace


Source Enumeration

Source Enumeration
Accusoft.ISISXpressSdk Namespace : Source Enumeration

Option values to set the scanning source information.

Syntax

Visual Basic (Declaration)
Public Enum Source
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As Source
C#
public enum Source : Enum
Managed Extensions for C++
__value public enum Source : public Enum
C++/CLI
public enum class Source : public Enum

Members

Member | Description
Automatic | 0 - Scan from the Automatic Document Feeder (ADF) if detected; otherwise, scan from the flatbed.
Transparency | 1 - Scan from the transparency unit.
Flatbed | 2 - Scan from the flatbed.
Feeder | 3 - Scan from the feeder (front side only if duplex).
Duplex | 4 - Scan in duplex mode.
BackFront | 5 - Scan in duplex mode, but return the back side of the page first.
BackOnly | 6 - Scan only the back side of the page (duplex scanner).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ISISXpressSdk.Source

See Also

Reference

Accusoft.ISISXpressSdk Namespace


IsisXpress.FeederEmptyEventHandler Delegate

IsisXpress.FeederEmptyEventHandler Delegate
Accusoft.ISISXpressSdk Namespace : IsisXpress.FeederEmptyEventHandler Delegate

sender
An Object.
e
The FeederEmptyEventArgs.
Indicates that the scanner feeder is empty.

Syntax

Visual Basic (Declaration)
Public Delegate Sub IsisXpress.FeederEmptyEventHandler( _
   ByVal sender As Object, _
   ByVal e As FeederEmptyEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New FeederEmptyEventHandler(AddressOf HandlerMethod)
C#
public delegate void IsisXpress.FeederEmptyEventHandler(
   object sender,
   FeederEmptyEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void IsisXpress.FeederEmptyEventHandler(
   Object* sender,
   FeederEmptyEventArgs* e
)
C++/CLI
public delegate void IsisXpress.FeederEmptyEventHandler(
   Object^ sender,
   FeederEmptyEventArgs^ e
)

Parameters

sender
An Object.
e
The FeederEmptyEventArgs.

Remarks

This event is used to notify the user that the scanner feeder is empty during a batch scanning process.

See Also

Reference

Accusoft.ISISXpressSdk Namespace


IsisXpress.ProgressEventHandler Delegate

IsisXpress.ProgressEventHandler Delegate
Accusoft.ISISXpressSdk Namespace : IsisXpress.ProgressEventHandler Delegate

sender
An Object.
e
The ProgressEventArgs.
Indicates how much of the scan has completed. If the Scanner.UseCompression property is true then the Progress event is not fired during the scan.

Syntax

Visual Basic (Declaration)
Public Delegate Sub IsisXpress.ProgressEventHandler( _
   ByVal sender As Object, _
   ByVal e As ProgressEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ProgressEventHandler(AddressOf HandlerMethod)
C#
public delegate void IsisXpress.ProgressEventHandler(
   object sender,
   ProgressEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void IsisXpress.ProgressEventHandler(
   Object* sender,
   ProgressEventArgs* e
)
C++/CLI
public delegate void IsisXpress.ProgressEventHandler(
   Object^ sender,
   ProgressEventArgs^ e
)

Parameters

sender
An Object.
e
The ProgressEventArgs.

See Also

Reference

Accusoft.ISISXpressSdk Namespace


IsisXpress.ScannedEventHandler Delegate

IsisXpress.ScannedEventHandler Delegate
Accusoft.ISISXpressSdk Namespace : IsisXpress.ScannedEventHandler Delegate

sender
An Object.
e
The ScannedEventArgs.
Fired after a scan to allow the user to check or set the ToHdib property.

Syntax

Visual Basic (Declaration)
Public Delegate Sub IsisXpress.ScannedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ScannedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ScannedEventHandler(AddressOf HandlerMethod)
C#
public delegate void IsisXpress.ScannedEventHandler(
   object sender,
   ScannedEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void IsisXpress.ScannedEventHandler(
   Object* sender,
   ScannedEventArgs* e
)
C++/CLI
public delegate void IsisXpress.ScannedEventHandler(
   Object^ sender,
   ScannedEventArgs^ e
)

Parameters

sender
An Object.
e
The ScannedEventArgs.

See Also

Reference

Accusoft.ISISXpressSdk Namespace


IsisXpress.ScanningEventHandler Delegate

IsisXpress.ScanningEventHandler Delegate
Accusoft.ISISXpressSdk Namespace : IsisXpress.ScanningEventHandler Delegate

sender
An Object.
e
The ScanningEventArgs.
Fired before a scan to allow the user to check or modify the Filename property.

Syntax

Visual Basic (Declaration)
Public Delegate Sub IsisXpress.ScanningEventHandler( _
   ByVal sender As Object, _
   ByVal e As ScanningEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ScanningEventHandler(AddressOf HandlerMethod)
C#
public delegate void IsisXpress.ScanningEventHandler(
   object sender,
   ScanningEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void IsisXpress.ScanningEventHandler(
   Object* sender,
   ScanningEventArgs* e
)
C++/CLI
public delegate void IsisXpress.ScanningEventHandler(
   Object^ sender,
   ScanningEventArgs^ e
)

Parameters

sender
An Object.
e
The ScanningEventArgs.

See Also

Reference

Accusoft.ISISXpressSdk Namespace


Empty Index Entry
Send Feedback

Glossary Item Box

Empty Index Entry

The index entry you selected has no target topics associated with it.

If you have chosen a parent entry, please select a child entry.


Topic Not Found
Send Feedback

Glossary Item Box

Topic Not Found

The link you just clicked was not able to connect to the target page.

Some possible reasons and remedies are as follows:

Reason | Remedy
Destination topic is not part of the area you specified in the Filtered by field. | Either select another filter or select (no filter).
The URL of the destination topic is incorrect or has changed. | Use the index or the search function instead.
Problems with the help installation. | Rerun Setup for the product this help is related to and select the 'Repair' option.

Additional help is available for filters, search, and the index.

Click Back to return to the page you were on.

The target parameters are:

Keyword:
Index Moniker:
URL:


Assembly Overview

Accusoft Pegasus
Accusoft.ISISXpress4.Net Assembly
See Also Send Feedback

Namespaces

Namespace | Description
Accusoft.ISISXpressSdk |


Getting Started - Accusoft.ISISXpress4.Net

Accusoft.ISISXpress4.Net Accusoft Pegasus
Getting Started
Send Feedback


Introduction - Accusoft.ISISXpress4.Net

Accusoft.ISISXpress4.Net Accusoft Pegasus
Introduction
Send Feedback