ScanFix Xpress User Assistance Dashboard

Accusoft.ScanFixXpress8.Net
ScanFix Xpress User Assistance Dashboard

Welcome

  • Overview of ScanFix Xpress
  • What is ScanFix Xpress

Getting Started

  • Operating Requirements & Installation
    • Operating Requirements
    • Upgrading from ScanFix Xpress 7 to ScanFix Xpress 8
    • Installing on a Development Machine
  • Licensing & Deployment
    • Licensing
    • Distributing ScanFix Xpress
    • Software License Agreement
    • Accusoft Corporation Copyrights & Trademarks

Developer's Guide

  • User Guide

    • Concepts

      • Introduction to Image Processing
      • Glossary
    • How To
      • Solve Problems with ScanFix Xpress
      • Use a Series of Cleanup Operations
      • Save Enhancements Objects
      • Error Codes
    • API Reference Guide
      • Accusoft.ScanFixXpressSdk Namespace

Additional Resources

  • Online Demo & Video Tutorial
  • White papers & Case Studies
  • FAQs
  • Customer Support
    • Customer Support
    • Support Overview
    • Support Plans/Agreement

Provide Feedback

  • Email us
  • Take our survey

©2015. Accusoft Corporation. All Rights Reserved.

Send Feedback


ScanFix Xpress 8 for .Net - User Guide

Accusoft.ScanFixXpress8.Net
ScanFix Xpress 8 for .Net - User Guide

ScanFix Xpress 8 online help includes:

  • Introduction
  • Getting Started
  • Licensing
  • Distributing Applications and Deployment
  • Concepts
  • How To


Introduction

Accusoft.ScanFixXpress8.Net
Introduction
ScanFix Xpress 8 for .Net - User Guide > Introduction

The Introduction section provides information on:

  • What is ScanFix Xpress?
  • Getting Support
  • Accusoft Corporation Copyrights & Trademarks
  • The ScanFix Xpress Team


What is ScanFix Xpress?

Accusoft.ScanFixXpress8.Net
What is ScanFix Xpress?
ScanFix Xpress 8 for .Net - User Guide > Introduction > What is ScanFix Xpress?

ScanFix® Xpress Version 8 improves image quality and increases content recognition accuracy by applying image processing and enhancements to color, grayscale, and black and white images.

ScanFix Xpress provides brightness/contrast correction, clean up of noisy colors, color detection, color drop out or color extract, plus many additional image cleanup features. Remove lines and dot shading, smooth and repair characters, and eliminate unnecessary borders.

An Auto Binarize operation easily converts images from color or grayscale to black and white. ScanFix Xpress includes the ImagXpress component, and integrates easily with other Accusoft components to create document capture systems.

New Features in Version 8

  • Updated the binarization function to improve conversion of grayscale and color images to bitonal images.
  • Added new API for line detection and removal.
  • Automatically correct the perspective distortion of an image taken at an angle with a camera or smart phone.

Primary Features

  • Fast and effective image cleanup on bitonal, grayscale, and color images.
  • Color detection, brightness/contrast adjustment, color drop, noise reduction, and various filters applied to 24-bit and 8-bit images.
  • Deskew, auto-negate, auto-border crop, image registration, blank page and blank rectangle detection, flip, dilate, erode, mirror, rescale, rotate, and shear applied to 1-bit, 8-bit and 24-bit images.
  • Despeckle, line removal, blob and hole removal, automatic rotation, dot shading removal, correction of inverse text, and comb removal applied to 1-bit images.
  • Confidence reporting on clean up results.
  • Save batch processing instructions to support application workflow among other components including FormFix, FormDirector, SmartZone, and Barcode Xpress components.
  • Seamlessly integrate with other Accusoft components, including ImagXpress, Notate Xpress, TwainPRO, PrintPRO, ImageGear and others.

ScanFix Xpress Editions

ScanFix Xpress is offered in two editions:

  • ScanFix Xpress ActiveX supports development in ActiveX/COM development environments, and deploys to 32-bit processors and to 64-bit processors as 32-bit applications.
  • ScanFix Xpress .NET supports development in .NET/C#/VB.NET development environments, and deploys to 64-bit and 32-bit processors as AnyCPU-compiled applications.

Accusoft Components Shipped with ScanFix Xpress

  • ImagXpress® for loading, saving, and viewing images.
  • NotateXpress™ for adding image annotations.
  • PrintPRO™ for printing.
  • ThumbnailXpress™ to view thumbnail images.
  • TwainPRO™ to acquire images from TWAIN devices.
  • ISIS® Xpress™ for ISIS image acquisition. License sold separately.

See www.accusoft.com for product packaging and sales information.

See Also
Getting Support
Software License Agreement
Operating Requirements


Getting Support

Accusoft.ScanFixXpress8.Net
Getting Support
ScanFix Xpress 8 for .Net - User Guide > Introduction > Getting Support

For information about Accusoft Support, please refer to the Software Support and Maintenance Policy on the Accusoft web site or call Accusoft at 813-875-7575.

See Also
Operating Requirements
Installing on a Development Machine


Accusoft Corporation Copyrights & Trademarks

Accusoft.ScanFixXpress8.Net
Accusoft Corporation Copyrights & Trademarks
ScanFix Xpress 8 for .Net - User Guide > Introduction > Accusoft Corporation Copyrights & Trademarks

©2015 Accusoft Corporation. All rights reserved.

Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Accusoft® Corporation.

This manual and the software described in it are both products of the USA.

Accusoft Corporation
4001 North Riverside Drive
Tampa, FL 33603
Sales: 813-875-7575
www.accusoft.com

Accusoft Trademarks

The following are trademarks (™) or registered marks (®) of Accusoft Corporation:

  • Accusoft®
  • Accusoft Logo™
  • Accusoft Pegasus Logo™
  • Adeptol®
  • AIMTools™
  • Barcode Xpress™
  • Accusoft® Barcode Scanner™
  • Barcode Xpress Mobile™
  • CapturePro™
  • Digital Mark Recognition® (DMR)
  • FolderBots™
  • FormAssist™
  • FormDirector™
  • FormFix™
  • FormSuite™
  • ImageGear® for .NET
  • ImageGear® for .NET Compact Framework
  • ImageGear® for Silverlight
  • ImageGear® for Java
  • ImageGear® Medical
  • ImageGear® Professional
  • ImageGear®
  • ImageTransport MD™
  • ImagXpress®
  • ISIS® Xpress™
    • ISIS is a registered trademark of EMC Corporation
    • ISIS Xpress is a trademark of Accusoft Corporation
  • MICR Xpress™
  • NetVue™
  • NotateXpress™
  • PDF Xpress™
  • Pegasus®
  • PICTools™
  • PICTools™ Document
  • PICTools™ Fingerprint
  • PICTools™ Medical
  • PICTools™ Photo
  • PICVideo™ M-JPEG Codec
  • PrintPRO™
  • Prizm®
  • Prizm® Content Connect™
  • Prizm® Content Connect™ for SharePoint
  • Prizm® Content Connect™ for Documentum
  • Prizm® Document Converter™
  • Prizm® Viewer™
  • Prizm® ActiveX Viewer™
  • Prizm® Cloud™
  • Prizm® Share™
  • Prizm® Image™
  • Prizm® Capture™
  • ScanFix® Xpress™
  • SmartZone™
  • The JPEG Wizard™
  • ThinPic™
  • ThumbnailXpress™
  • TwainPRO™
  • USB Scanner™
  • USB Scanner SDK™

Accusoft and/or its agents use these marks and brand names in connection with its goods and/or services, in the United States and other countries.

Microsoft, Internet Explorer, Microsoft.NET, Silverlight, Visual Basic, Visual Studio, and Visual Studio.NET are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

Itanium is a registered trademark of Intel Corporation in the United States and other countries.

All other product and brand names are the property of their respective owners.

Accusoft Patents

ScanFix Xpress utilizes technology owned by Accusoft Corporation that is protected by U.S. Patents 5,590,224; 5,579,414; 5,625,719; 5,778,103; 5,729,635; 5,594,815; 5,594,814; 7,817,854; 7,756,340; 8,351,699 and U.S. Patents Pending.

See Also
What is ScanFix Xpress?
Software License Agreement


The ScanFix Xpress Team

Accusoft.ScanFixXpress8.Net
The ScanFix Xpress Team
ScanFix Xpress 8 for .Net - User Guide > Introduction > The ScanFix Xpress Team

The following individuals contributed to the development and release of ScanFix Xpress:

  • Michael Archambault, Software Engineer
  • Joe Carioti, Software Engineer
  • Forrest Dix, Software Engineer
  • Alexander Gluschenko, Software Engineer in Test
  • Jeff Hodges, Sr. Software Engineer
  • Ed Krajcik, Sr. Software Engineer
  • Stephen Martucci, Scientist
  • Vatsal Patel, Software Development Manager
  • John Reynolds, Software Engineer
  • Rachel Samuel, Technical Writer
  • Tom Setzer, Director of Recognition & Native Groups
  • Jody Shumaker, Software Configuration Architect
  • Sylvia Traxler, Quality Assurance Lead


Getting Started

Accusoft.ScanFixXpress8.Net
Getting Started
ScanFix Xpress 8 for .Net - User Guide > Getting Started

The Getting Started section provides information on:

  • Operating Requirements
  • Installing on a Development Machine
  • Upgrading from ScanFix Xpress 7 to ScanFix Xpress 8
  • Upgrading Runtime Licensing
  • Dispose Method Required
  • ScanFix Samples


Operating Requirements

Accusoft.ScanFixXpress8.Net
Operating Requirements
ScanFix Xpress 8 for .Net - User Guide > Getting Started > Operating Requirements

Operating Systems

ScanFix® Xpress runs on supported Microsoft Operating Systems:

  • Windows Vista
  • Windows 7
  • Windows 8.0 and 8.1
  • Windows Server 2008, 2008 R2
  • Windows Server 2012, 2012 R2
ScanFix Xpress runs in 64-bit, 32-bit, and AnyCPU-compiled executables.

Threading

ScanFix Xpress is a synchronous or asynchronous multi-thread control. Accusoft Corporation considers thread-safe to be when an application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.

There is also a ScanFix Xpress ActiveX control available.

Development Environment

  • Requires Microsoft .NET Framework 2.0
  • Compatible with Microsoft .NET Framework 3.0, 3.5, 4.0, 4.5, 4.5.1
  • Microsoft Visual Studio 2010, 2012, 2013
See Also
Getting Support
Installing on a Development Machine


Installing on a Development Machine

Accusoft.ScanFixXpress8.Net
Installing on a Development Machine
ScanFix Xpress 8 for .Net - User Guide > Getting Started > Installing on a Development Machine

To Install ScanFix® Xpress Component

Run the downloaded setup program which installs the development kit on your development machine.

The downloaded development kit includes code samples for supported platforms. Samples are available through:

Start | Programs | Accusoft | ScanFix Xpress menu.

By default this will register trial licensing which allows you to develop applications but not to distribute them. The trial license allows testing of all the functions and features.

Please see the section Distributing ScanFix Xpress to understand the limits and details to convert licensing editions.
In order to distribute your finished application you must purchase and install a fully paid license from Accusoft Corporation. The paid licenses override trial licenses.

To Use ScanFix Xpress Help Files

Once you have installed ScanFix Xpress, you will have access to the following stand-alone help file:

  • Accusoft.ScanFixXpress8.Net.chm - Access the ScanFix Xpress stand-alone help through the Windows Start menu: Start | Programs | Accusoft | ScanFix Xpress 8.0

In addition, you will have access to the following compiled collection help file:

  • Accusoft.ScanFixXpress8_Net.cab - MHV (Microsoft Help Viewer). If you have Visual Studio 2010, 2012, or 2013, these MHV files will be registered.

See Also
Operating Requirements
Software License Agreement
Distributing ScanFix Xpress


Upgrading from ScanFix Xpress 7 to ScanFix Xpress 8

Accusoft.ScanFixXpress8.Net
Upgrading from ScanFix Xpress 7 to ScanFix Xpress 8
ScanFix Xpress 8 for .Net - User Guide > Getting Started > Upgrading from ScanFix Xpress 7 to ScanFix Xpress 8

This section describes how to upgrade from ScanFix Xpress 7 to ScanFix Xpress 8. While generally you'll be able to replace ScanFix Xpress 7 with ScanFix Xpress 8, there are a few important changes you may need to consider. This section provides information about those changes.

New API

ScanFix Xpress 8 introduces changes to its API as described in this section.

New Classes

  • GraphicLine
  • GraphicLineDetectionOptions
  • GraphicLineDetectionResults
  • GraphicLineRemovalOptions
  • GraphicLineRemovalResults
  • PerspectiveAdjustResults
  • PerspectiveAdjustOptions

New ScanFix Methods

  • PerspectiveAdjust
  • DetectGraphicLines
  • RemoveGraphicLines

Changed API

Result Classes

ALL the Result Class constructors have been changed to internal. So, the following Results classes cannot be instantiated outside of the ScanFix SDK:

AutoBinarizeResults, AutoBrightnessContrastResults, AutoDespeckleResults, AutoInverseTextResults, AutoRemoveHolePunchResults,

AutoRotateResults, AutoSmoothBackgroundResults, BinarizeResults, BlankPageDetectResults, BlankRectangleDetectResults,

BlobRemovalResults, BorderRemovalResults, BrightnessContrastResults, ColorDropResults, CombRemovalResults, DeskewResults, DespeckleResults,

DetectColorResults, DilateResults, DotShadingRemovalResults, ErodeResults, FilterResults, FlipResults, GetRectangleResults, GraphicLineDetectionResults,

GraphicLineRemovalResults, ImageDetergentResults, ImageRegistrationResults, InverseTextResults, LineRemovalResults, MirrorResults,

NegateResults, NegativeCorrectionResults, PerspectiveAdjustResults, RescaleResults, RotateResults, ShearResults, SmoothObjectsResults,

SmoothZoomResults, and VirtualBulbResults.

Deprecated API

The following methods are now marked as deprecated and will be removed from the next release of ScanFix:

  • Rescale(Double,Double) Method
  • Rotate(Double,Color) Method
  • SmoothObjects(Int32) Method

If you encounter any porting issues, please contact support@accusoft.com for assistance.


Upgrading Runtime Licensing

Accusoft.ScanFixXpress8.Net
Upgrading Runtime Licensing
ScanFix Xpress 8 for .Net - User Guide > Getting Started > Upgrading Runtime Licensing

This section describes how to upgrade to Accusoft's new Runtime Licensing.

Prior to ScanFix Xpress 7, runtime licensing was accomplished using the UnlockRuntime method.

In ScanFix Xpress 7, the default licensing model is Automatically Reported Runtime Licensing. However, based on your contracted usage of this software, you may be eligible for Manually Reported Runtime Licensing. Your Accusoft Sales Representative (sales@accusoft.com) can help you determine which model is appropriate.

Refer to the following sections for information about upgrading to the new Runtime Licensing models:

  • Upgrading to Automatically Reported Runtime Licensing
  • Upgrading to Manually Reported Runtime Licensing

Upgrading to Automatically Reported Runtime Licensing

Automatically Reported Runtime Licensing requires a license to be installed on the end-user's machine. See the Licensing section for more information.

In your ScanFix Xpress 6 codebase, find any existing calls to the UnlockRuntime method.

C#
Copy Code
 scanfixXpress1.Licensing.UnlockRuntime(12345,12345,12345,12345);
VB.NET
Copy Code
 scanfixXpress1.Licensing.UnlockRuntime(12345,12345,12345,12345)

In your ScanFix Xpress 7 or later codebase, replace the UnlockRuntime method with calls to the SetSolutionName and SetSolutionKey methods.

C#
Copy Code
 scanfixXpress1.Licensing.SetSolutionName("YourSolutionName");
 scanfixXpress1.Licensing.SetSolutionKey(12345,12345,12345,12345);
VB.NET
Copy Code
 scanfixXpress1.Licensing.SetSolutionName("YourSolutionName")
 scanfixXpress1.Licensing.SetSolutionKey(12345,12345,12345,12345)

Upgrading to Manually Reported Runtime Licensing

In your ScanFix Xpress 6 codebase, find any existing calls to the UnlockRuntime method.

C#
Copy Code
 scanfixXpress1.Licensing.UnlockRuntime(12345,12345,12345,12345);
VB.NET
Copy Code
 scanfixXpress1.Licensing.UnlockRuntime(12345,12345,12345,12345)

In your ScanFix Xpress 7 or later codebase, replace the UnlockRuntime method with calls to the SetSolutionName, SetSolutionKey, and SetOEMLicenseKey methods.

C#
Copy Code
 scanfixXpress1.Licensing.SetSolutionName("YourSolutionName");
 scanfixXpress1.Licensing.SetSolutionKey(12345,12345,12345,12345);
 scanfixXpress1.Licensing.SetOEMLicenseKey("1.0.AStringForOEMLicensing…");
VB.NET
Copy Code
 scanfixXpress1.Licensing.SetSolutionName("YourSolutionName")
 scanfixXpress1.Licensing.SetSolutionKey(12345,12345,12345,12345)
 scanfixXpress1.Licensing.SetOEMLicenseKey("1.0.AStringForOEMLicensing…")

There is no longer a separate method for web licensing. That functionality has been integrated into the SetOEMLicenseKey method.

If you encounter any porting issues, please contact support@accusoft.com for assistance.


Dispose Method Required

Accusoft.ScanFixXpress8.Net
Dispose Method Required
ScanFix Xpress 8 for .Net - User Guide > Getting Started > Dispose Method Required

The ScanFix® Xpress .NET Windows Forms component implements the Dispose pattern which is defined by the IDisposable interface. Because ScanFix Xpress encapsulates unmanaged resources and is a non-windowed component, the Dispose method MUST be called for each instance of the ScanFix Xpress object, to allow the release of all resources.

It is recommended to call the ScanFix Xpress Dispose method from the components' container. For example, in all .NET Windows Forms applications, you will find a generated call to Dispose such as:

C# Example
Copy Code
protected override void Dispose (bool disposing)
{
if (disposing)
{
if (components != NULL)
{
components.Dispose ();
}
 //added for ScanFix
scanFix1.Dispose ();
}
base.Disposing (disposing);
}

While the above is the recommended approach, the application developer is not required to call Dispose at this location. Essentially, the developer can make the call to clean up these resources at any desired time during the components' containers lifetime. Adding this line means that the Dispose method of the control gets explicitly called when the form is disposed of.

Additionally, if ScanFix Xpress instances are created dynamically at runtime, each instance must call its own Dispose method to allow all resources to be released.


ScanFix Samples

Accusoft.ScanFixXpress8.Net
ScanFix Samples
ScanFix Xpress 8 for .Net - User Guide > Getting Started > ScanFix Samples

ScanFix has the following samples:

Name | Description
Enhancements

Demonstrates the use of the Enhancements class to create a series of clean up operations and then easily apply that series on multiple images. This sample also contains the code to save that series of clean up operations and reload it to be run on additional images.

This sample demonstrates the following operations: Adjust Brightness Contrast, AutoBinarize, Deskew.

ImageCleanUp

Demonstrates the various ways the options and results are used by ScanFix Xpress operations while showing how to call several cleanup operations.

This sample demonstrates the following operations: Flip, Unsharp Filter, Rotate, Deskew, Custom Filter, Image Detergent, Adjust Brightness Contrast, Image Transfer.

SmartBinarize

Demonstrates the use of one operation to make decisions on subsequent operations. In this case, AutoBinarize is only performed when DetectColor indicates a color photograph or drawing is present.

This sample demonstrates the following operations: AutoBinarize, DetectColor, Binarize.

ScanFixXpressDemo | Demonstrates many of the operations available in ScanFix Xpress and shows how to use Enhancements. This demonstration comes with numerous pre-defined scenarios that show common image problems and the appropriate combination of operations to address them.


Licensing

Accusoft.ScanFixXpress8.Net
Licensing
ScanFix Xpress 8 for .Net - User Guide > Licensing

Accusoft has introduced a new licensing structure, which provides the following benefits:

  • Toolkit Licensing (also known as Developer or SDK licensing) has been simplified, no longer requiring manual entry of license registration codes.
  • Runtime Licensing (also known as Deployment licensing) has been made more flexible, enabling support for a number of different deployment scenarios.

During evaluation of Accusoft products, Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups, timeouts, or evaluation watermarks.

Accusoft requires customers to purchase licenses for both development and deployment.

  • Development/Toolkit Licensing: When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups, timeouts, and evaluation watermarks while you develop your application.
  • Deployment/Runtime Licensing: Once you have an application that is ready for distribution, you have several options for deployment. Your own deployment scenario will dictate which option is the most appropriate. There are also cost considerations for each licensing model; see the product's "pricing" page or speak with an Accusoft Sales Representative (sales@accusoft.com) for more information.
    • Manually Reported Runtime Licensing: In this model, you embed all of the licensing information directly into your application. You must manually provide royalty reporting to Accusoft for the actual licenses deployed. This model will be the best choice for you if you are not connected to the Internet at runtime, as might be the case in an defense or financial application.
    • Automatically Reported Runtime Licensing using the Server Licensing Utility (SLU): In this model, you run a small GUI tool one time on each deployment target to configure licensing. This model will be the best choice for you if you handle the deployments yourself.
    • Automatically Reported Runtime Licensing using the Licensing Development Kit (LDK): In this model, you embed function calls into your application that perform the license verification at runtime. This model will be the best choice for you if you wish to hide licensing from your end users.

See Also
Licensing Glossary


Evaluation Licensing

Accusoft.ScanFixXpress8.Net
Evaluation Licensing
ScanFix Xpress 8 for .Net - User Guide > Licensing > Evaluation Licensing

During evaluation of Accusoft products, Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups, timeouts, or evaluation watermarks. When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups, timeouts, and evaluation watermarks.

An evaluation dialog similar to the following is displayed when you have a valid evaluation license:

However, if you attempt to execute a function that is not licensed in the edition license you are using (e.g., if you have a paid license for a component's Standard edition and attempt to execute a function available only in the Professional edition), an evaluation dialog similar to the following is displayed.

If no license is found in the registry, a dialog similar to the following will be displayed.


Toolkit Licensing

Accusoft.ScanFixXpress8.Net
Toolkit Licensing
ScanFix Xpress 8 for .Net - User Guide > Licensing > Toolkit Licensing

Accusoft requires customers who are developing code that uses Accusoft components to have a Toolkit license for each developer.

This section provides information about the following:

  • Assigned Toolkit License
  • License Manager
  • Product Editions
  • Registration
    • Registering When Connected to the Internet
    • Registering When Disconnected from the Internet
  • Developing Code


Assigned Toolkit License

Accusoft.ScanFixXpress8.Net
Assigned Toolkit License
ScanFix Xpress 8 for .Net - User Guide > Licensing > Toolkit Licensing > Assigned Toolkit License

When licenses are purchased for developers at an organization, a representative is designated to assign the licenses to developers at the organization. Each developer must create an account on Accusoft’s website prior to the assignment of licenses. The organization’s designated representative may request that licenses be reassigned as a result of personnel changes.


License Manager

Accusoft.ScanFixXpress8.Net
License Manager
ScanFix Xpress 8 for .Net - User Guide > Licensing > Toolkit Licensing > License Manager

The License Manager is a GUI application that is used by a developer to register and activate Toolkit licenses on their development system. When a paid Toolkit license is registered, the License Manager:

  • Communicates the developer credentials and the hardware information for the development system to the licensing web service.
  • Installs the returned license key on that system.

Activation involves the developer choosing a Toolkit license, either evaluation or paid, so that the license is active on the system.


Product Editions

Accusoft.ScanFixXpress8.Net
Product Editions
ScanFix Xpress 8 for .Net - User Guide > Licensing > Toolkit Licensing > Product Editions

Accusoft products may have multiple editions, each of which supports different features. Products that support multiple editions are installed with multiple evaluation Toolkit licenses, one evaluation Toolkit license per edition.

Selecting An Edition (Activating a Toolkit License)

Evaluation licenses allow developers to try features in different product editions. Since each license supports only a single edition of a product, the developer can switch between editions by activating the corresponding Toolkit license, either purchased or evaluation, using the License Manager.

When a customer downloads an evaluation Toolkit, the evaluation Toolkit license for the edition with the most features is installed by default. However, the developer may run the License Manager to change the Toolkit license to a lower edition in order to determine if that edition will serve their needs.

If a customer has purchased multiple editions of the same product, they may install both editions on a development system, but only one edition may be active at a time. Once a license has been activated for a particular system, it may be deactivated (replaced by activating another edition) or reactivated at any time. Similarly, customers who own a lower featured edition may activate a higher featured edition evaluation Toolkit license and then switch back to their paid, lower-featured Toolkit edition license at any time. For example, you can go from a paid Standard edition to an evaluation Professional edition by activating the Professional edition evaluation Toolkit license.


Registration

Accusoft.ScanFixXpress8.Net
Registration
ScanFix Xpress 8 for .Net - User Guide > Licensing > Toolkit Licensing > Registration

Registration is the process of creating a paid Toolkit license key for a particular system. Registration for Toolkit licenses is always done through the License Manager. This enables the features for the purchased edition to operate without nag dialogs or watermarks.

Registration for each license is only required to be performed once per development system. After a license has been registered on a system, the developer can use the license without further interaction with the License Manager.

Also refer to the following sections:

  • Registering When Connected to the Internet
  • Registering When Disconnected from the Internet


Registering When Connected to the Internet

Accusoft.ScanFixXpress8.Net
Registering When Connected to the Internet
ScanFix Xpress 8 for .Net - User Guide > Licensing > Toolkit Licensing > Registration > Registering When Connected to the Internet

When the development system is connected to the Internet, registration is a fairly simple process.

  1. Start the License Manager.
  2. When prompted, enter your Accusoft login and password.

    The License Manager then displays the available evaluation and purchased licenses assigned to you.
  3. Select a toolkit and click the link to activate the license for that toolkit.

The License Manager then requests a new license key from the licensing web service and installs it; this completes the registration process.

If the selected license cannot be installed on the development system due to connection failures or other reasons, a temporary 15 day "grace" license is installed so as not to interrupt development while a new license is obtained for the development system.


Registering When Disconnected from the Internet

Accusoft.ScanFixXpress8.Net
Registering When Disconnected from the Internet
ScanFix Xpress 8 for .Net - User Guide > Licensing > Toolkit Licensing > Registration > Registering When Disconnected from the Internet

When the development system is not connected to the Internet during registration, as is the case in some defense or financial institutions, registration is only slightly less simple.

  1. Run the License Manager (LM) and attempt to log in.

The LM detects that the system is not registered and displays the following dialog:

  2. Select the Install Offline option to begin the offline registration process.

  3. Copy the URL to removable media, such as a thumb drive.

  4. Take the thumb drive to a system that is connected to the Internet.
  5. From the connected system, paste the URL into a browser, which automatically displays the toolkits available.
  6. Upon selecting a toolkit, a license is generated, which you then save to the removable media device.
  7. Return to the offline system where the new license is to be installed.
  8. Use the License Manager to browse to the file and install the Toolkit license.


Developing Code

Accusoft.ScanFixXpress8.Net
Developing Code
ScanFix Xpress 8 for .Net - User Guide > Licensing > Toolkit Licensing > Developing Code

Once an evaluation or paid Toolkit license has been activated on the development system, no additional code is required to use the Accusoft products on this system.

If moving the resulting executable code to a new system, you will need to install Toolkit licenses or incorporate Runtime licenses into your code.


Runtime Licensing

Accusoft.ScanFixXpress8.Net
Runtime Licensing
ScanFix Xpress 8 for .Net - User Guide > Licensing > Runtime Licensing

When an application that uses one or more Accusoft products is deployed, it requires a Runtime License for each installation. There are two main types of Runtime Licenses:

  • Automatically Reported - Distribution of Automatically Reported Runtime licenses is handled automatically through the use of licensing software components and web services.
  • Manually Reported - Manually Reported Runtime licensing requires you to provide the number of licenses distributed on a contractually agreed upon basis.

These licensing types are each described in detail in the following sections:

  • Automatically Reported Runtime (Node-Locked)
    • Licensing API
    • License Pools
    • License Configuration Files
    • LDK vs. SLU
      • Server Licensing Utility (SLU)
      • Licensing Development Kit (LDK)
    • Deployment Proxy Service (DPS)
  • Manually Reported Runtime (Non-Node-Locked)
    • Solution Key
    • Solution Name
    • OEM License Key
If you are upgrading from an earlier version of ScanFix Xpress, please see the Upgrading Runtime Licensing section for important information.


Automatically Reported Runtime (Node-Locked)

Accusoft.ScanFixXpress8.Net
Automatically Reported Runtime (Node-Locked)
ScanFix Xpress 8 for .Net - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked)

Automatically Reported Runtime licenses use a mechanism similar to Toolkit licensing to activate a license for a particular system. In this case, each installation has a unique license that is pulled from the pool of licenses purchased by the customer. When the license key is generated, it contains hardware information that identifies the system on which the license is to be installed.

The Licensing Development Kit component, which interacts with the licensing web service and installs the newly generated license key, may be used directly by the application or it may be used through a simple tool known as the Server Licensing Utility.

  • The Licensing Development Kit requires integration with the application or installation utility to perform license activation.
  • The Server Licensing Utility is a stand-alone application that integrates the Licensing Development Kit to perform the registration.

This topic provides information about the following:

  • Licensing API
  • License Pools
  • License Configuration Files
  • LDK vs. SLU
    • Server Licensing Utility (SLU)
    • Licensing Development Kit (LDK)
  • Deployment Proxy Service (DPS)


Licensing API

Accusoft.ScanFixXpress8.Net
Licensing API
ScanFix Xpress 8 for .Net - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > Licensing API

The Licensing API is used in the developer’s code to specify Runtime Licensing deployment information. This is used to unlock the Accusoft products and enable all licensed features at runtime. Both the "Solution Name" and "Solution Key" values used in the API described below are provided by Accusoft, along with the License Configuration file, at the time of purchase of a Runtime License.

Solution Name

The solution name is the name assigned by Accusoft to the licenses purchased for runtime deployment. It is a character string that is set for a component prior to use in a deployment environment and is typically the name of the organization that purchased the runtime licenses. It is set via the SetSolutionName method of the component’s Licensing class. For example:

Copy Code
ScanFix sx = new ScanFix();
sx.License.SetSolutionName("ACMEImaging");

The Solution Name must be set in order to use runtime licensing.

Solution Key

The Solution Key is a set of four numbers assigned when the licenses are purchased for runtime deployment; the Solution Key also identifies the organization that purchased the runtime licenses. The Solution Key is set via the SetSolutionKey method of the component’s Licensing class. For example:

Copy Code
ScanFix sx = new ScanFix();
sx.License.SetSolutionName("ACMEImaging");
sx.License.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);

The Solution Key must be set in order to use runtime licensing.


License Pools

Accusoft.ScanFixXpress8.Net
License Pools
ScanFix Xpress 8 for .Net - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > License Pools

When Automatically Reported Runtime licenses are purchased, they are organized into pools of a specific version and platform for a particular toolkit. For example, if a customer developed two applications using ImagXpress, one using 32-bit ActiveX and the other using .NET, they would purchase two pools of runtime licenses, one for the ActiveX platform and one for the .NET platform.

At installation, a new license would be pulled from the appropriate pool, depending upon which platform the application is using.


License Configuration Files

Accusoft.ScanFixXpress8.Net
License Configuration Files
ScanFix Xpress 8 for .Net - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > License Configuration Files

When an Automatically Reported Runtime license is purchased, a License Configuration file is created and distributed to the customer along with their assigned Solution Name and Solution Key.

The License Configuration file contains information about the Runtime licenses for a particular platform and version of a toolkit. It is used by the Server Licensing Utility or License Development Kit to activate licenses when the customer’s application is installed on their users' systems.

See Also
Licensing API


LDK vs. SLU

Accusoft.ScanFixXpress8.Net
LDK vs. SLU
ScanFix Xpress 8 for .Net - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU

Both the Licensing Deployment Kit and the Server Licensing Utility perform the same function of registering the Runtime license for the system on which it will be run. Both are provided in order to give you some options.

When installing the license, the user you are running as must have Administrator access so that the Registry can be accessed and the license can be added to the system.
  • If you are deploying to your own systems (e.g., for enterprise IT staff), the use of an Accusoft branded Server Licensing Utility may meet your needs.

    Similarly, if you handle the deployment onto end users systems, you may also find the Server Licensing Utility to be sufficient.
  • If you wish to hide this licensing registration from end users, you will likely choose the Licensing Deployment Kit, which allows you to integrate the registration process into your application. The Licensing Deployment Kit also allows for the optional assignment of Access Keys to specific users, which lets you manage your licenses more directly and limits the distribution of licenses.


Server Licensing Utility (SLU)

Accusoft.ScanFixXpress8.Net
Server Licensing Utility (SLU)
ScanFix Xpress 8 for .Net - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU > Server Licensing Utility (SLU)

The Server Licensing Utility is a simple Windows application that uses License Configuration Files to request a license key from the purchased Runtime licenses. The Server Licensing Utility registers that Runtime license on the system where your application will be running. This utility can be used by developers for testing, by your deployment team, or by your end users to register their Runtime license.

When installing the license, the user you are running as must have Administrator access so that the Registry can be accessed and the license can be added to the system.

In the Server Licensing Utility dialog, add your License Configuration file(s) as follows:

  1. Click Add and navigate to your License Configuration file(s).
  2. Select the appropriate License Configuration file(s) and click Open.
  3. After all applicable License Configuration files have been added, click Auto Register or Manually Register, depending on whether or not you are connected to the Internet. Refer to the sections below for more information.

Auto Register Toolkit (Connected to Internet)

Automatic registration works in much the same way as connected Toolkit registration and requires an Internet connection on the system where your application software will be deployed.

The license information along with the system’s hardware information is sent over the Internet to the Accusoft licensing web service. If an unused license is available, a new license key containing information for the system is generated, returned, and is then automatically installed by the Server Licensing Utility.

Manually Register Toolkit (Disconnected from Internet)

Manual registration is used when the system where your application software will be deployed is not connected to the Internet and therefore cannot be registered automatically. This operation is similar to Disconnected Registration with the License Manager.

  1. Copy the Hardware Key and URL to a removable media device, such as a thumb drive, and then take it to a system that is connected to the Internet.
  2. From the connected system, paste the URL into a browser. A page will appear that contains a field into which you enter the hardware key.
  3. After this hardware key is entered, a license file with the license key is downloaded, which you then save to the removable media device.
  4. Return to the offline system with the removable media device onto which you have saved the license file.
  5. Click Open License File and navigate to the license file. Click OK in the file selection dialog.
    Alternatively, you can open the license file with a text editor, copy the license key to the clipboard, and click Paste License Key to paste the new license key into the License Key field.
  6. Click the License button; the new license will be installed.


Licensing Development Kit (LDK)

Accusoft.ScanFixXpress8.Net
Licensing Development Kit (LDK)
ScanFix Xpress 8 for .Net - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU > Licensing Development Kit (LDK)

The Licensing Development Kit is an ActiveX component that may be used instead of the Server Licensing Utility. (Actually, the Server Licensing Utility is only a user interface for the Licensing Development Kit.) The Licensing Development Kit provides an interface for a developer to set the License Configuration File path and other properties as well as initiate requests to the licensing web service to generate license keys.

When installing the license, the user you are running as must have Administrator access so that the Registry can be accessed and the license can be added to the system.

This topic contains these sections:
  • Assigned Access Keys
  • Automatic (Connected) Mode Registration
  • Manual (Disconnected) Mode Registration
  • Evaluation
  • Licensing Development Kit Interface
  • Licensing Development Kit Properties
  • Licensing Development Kit Methods

Assigned Access Keys

Unlike the Server Licensing Utility, the Licensing Development Kit allows for the optional assignment of Access Keys to specific users. By doing this, you can specify which of your licenses are assigned to your users. This also limits the distribution of licenses. When Runtime licenses are purchased, a list of Access Keys is distributed to you for this use.

Automatic (Connected) Mode Registration

This mode corresponds to the Automatic (Connected) Registration section described in the Server Licensing Utility section. The process is shown in the C# sample code below:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Attempt to get the next available license.
// Note that you may alternately pass an Access Key
ldk.GetLicKeyAuto("");

if (ldk.ResultCode != enumLdkErrorCodes.LDK_SUCCESS)
{
    // Automatic Registration Failed - A temporary license
    // has been installed but will expire in 15 days.
    // TODO add code to notify user of issue and 15 day expiration.

    if (ldk.ResultCode == enumLdkErrorCodes.LDK_ERR_INET_CONN_BROKEN)
    {
        // No Internet Connection – Optionally do manual registration
    }
}
else
{
    // The license has been registered and installed.
}

The registration process is then complete. If any part of the registration process fails, a temporary license key is installed and is typically valid for 15 days. During this time, you are allowed to use the product while resolving any licensing related problems.

Manual (Disconnected) Mode Registration

This mode corresponds to the Manual (Disconnected) Registration section described in the Server Licensing Utility section. The process is shown in the C# code below:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Get the hardware key for the system.  Note
// that you may alternately pass an Access Key
string hardwareKey = ldk.GetHdwKey("");

// Write the hardware key to some type of removable media.
ApplicationSpecificMethodToWriteHardwareKey(hardwareKey);

At this point, you have the hardware key on some type of removable media. Take the media to a system that is connected to the Internet, acquire the license key by uploading the hardware key, write the new license key to the removable media, and then return to the disconnected system. The application then reads the license key from the removable media and installs the license key as shown below.

Copy Code
// After taking the hardware key to a system with an Internet
// connection and acquiring the license key string from the
// manual registration web site, read the key into your
// application.
string manuallyAcquiredLicenseKey = ApplicationSpecificMethodToReadLicenseKey();

// Install the license key
ldk.LicKey = manuallyAcquiredLicenseKey;

The manual license registration and installation is then complete. Like the automatic case above, if any error occurs during the setting of the license key, a temporary license is installed.

Evaluation

The Licensing Development Kit also has the ability to install an Evaluation License for purchased runtime products. This process is simply:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Install an evaluation license
ldk.StartEvalPeriod();

Licensing Development Kit Interface

The interface to the Licensing Development Kit is shown below:

Copy Code
interface IDeploymentComponent : IDispatch
{
   [propget, id(1)] HRESULT LicKey([out, retval] BSTR* pVal);
   [propput, id(1)] HRESULT LicKey([in] BSTR newVal);
   [propget, id(2)] HRESULT srvURL([out, retval] BSTR* pVal);
   [propput, id(2)] HRESULT srvURL([in] BSTR newVal);
   [propget, id(3)] HRESULT ConfigPath([out, retval] BSTR* pVal);
   [propput, id(3)] HRESULT ConfigPath([in] BSTR newVal);
   [propget, id(4)] HRESULT ResultString([out, retval] BSTR* pVal);
   [propget, id(5)] HRESULT ResultCode([out, retval] enumLdkErrorCodes* pVal);
   [id(6)]           HRESULT GetLicKeyAuto([in] BSTR accKey);
   [id(7)]           HRESULT GetHdwKey([in] BSTR accKey, [out,retval] BSTR* hdwKey);
   [id(8)]           HRESULT StartEvalPeriod(void);
   [propget]         HRESULT LicenseInfo([out, retval] BSTR* pVal);
   [propput]         HRESULT LicenseInfo([in] BSTR newVal);
   [id(10)]          HRESULT GetEvalPeriod([out, retval] long* pVal);
};

Licensing Development Kit Properties

  • LicKey - Stores the License Key to the registry when it is set, and reads it from the registry during the get operation.
  • srvURL - Gets and sets the URL path to the licensing web service. The default is the URL path to Accusoft’s Deployment Licensing Service.
  • ConfigPath - Gets and sets a path to the deployment configuration file. Multiple products can be registered at one time by setting the filenames as a semicolon-delimited list: e.g., “c:\config.txt;c:\config2.txt”.
  • ResultString - Contains the string descriptions of any error that may have occurred during the last operation.
  • ResultCode - Can be used to contain any of the error codes described in Licensing Component Error Codes and Messages.
  • LicenseInfo - Used to transfer license information onto new system hardware. To transfer the license information into new system hardware, do the following:
  1. Get the LicenseInfo value and store it in a safe place.
  2. Change the system hardware.
  3. Set the LicenseInfo to the value you saved in step (1).
  4. Run the GetLicKeyAuto method (or perform its manual analog) to obtain a license for the new system hardware.

Licensing Development Kit Methods

  • GetLicKeyAuto - Obtains a License Key for the end user’s system using the automatic (or connected) scenario. It takes an Access Key as its input parameter, and stores the obtained license key in the registry. If you choose not to distribute individual Access Keys, the accKey argument should be an empty string.
  • GetHdwKey - Obtains a hardware key from the current machine and returns it (as hdwKey). If you choose not to distribute individual access keys, the accKey argument should be an empty string.
  • StartEvalPeriod - Sets an evaluation licensing mode for the product and starts an evaluation period. This method is provided so you can distribute an evaluation version of your application, without having to distribute Access Keys to people who would like to evaluate your software. Using this method you can license Accusoft components on the end user’s system for a limited time – the default is 30 days, but it can be customized per request to Accusoft. If the evaluators purchase your software, you can then issue them an access key using either the automatic or manual scenarios to obtain permanent component licenses, just as Accusoft does for its evaluators.
  • GetEvalPeriod - Obtains the remaining time on an evaluation (in days). It returns EvalPeriod < 0 if the evaluation period is expired.


Deployment Proxy Service (DPS)

Accusoft.ScanFixXpress8.Net
Deployment Proxy Service (DPS)
ScanFix Xpress 8 for .Net - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > Deployment Proxy Service (DPS)

For systems where the deployed application will not have direct access to the Accusoft licensing web services, you can use the Deployment Proxy Service as a bridge to reroute the licensing communication. The Proxy Service will act as a trusted "go-between" for the Accusoft licensing system and the deployed application. This tool can be useful if the application will be deployed in a secured environment, where limited systems have external network access.

Additionally, the Proxy Service allows Accusoft customers to manage license registration more directly. The source for the Deployment Proxy Service is provided, allowing users to integrate the licensing process into their CRM, ERP, or other systems for tracking Automatically Reported Runtime Licenses.

For more information about the Deployment Proxy Service, please contact our Support team.


Manually Reported Runtime (Non-Node-Locked)

Accusoft.ScanFixXpress8.Net
Manually Reported Runtime (Non-Node-Locked)
ScanFix Xpress 8 for .Net - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked)

Manually Reported Runtime licensing embeds all of the licensing information directly into your application. Installation does not require any further licensing interaction. However, it is your responsibility to provide royalty reporting to Accusoft for the actual licenses deployed.

This section provides information about the following:

  • Solution Key
  • Solution Name
  • OEM License Key


Solution Key

Accusoft.ScanFixXpress8.Net
Solution Key
ScanFix Xpress 8 for .Net - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > Solution Key

The Solution Key:

  • is a set of four numbers assigned when the licenses are purchased for runtime deployment.
  • also identifies the organization that purchased the runtime licenses.
  • is set via the SetSolutionKey method of the component’s Licensing class. For example:
Copy Code
ScanFix sx = new ScanFix();
sx.License.SetSolutionName("ACMEImaging");
sx.License.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);

The Solution Key must be set in order to use runtime licensing.


Solution Name

Accusoft.ScanFixXpress8.Net
Solution Name
ScanFix Xpress 8 for .Net - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > Solution Name

The Solution Name is:

  • a name assigned by Accusoft to the licenses purchased for runtime deployment.
  • a character string that is set for a component prior to use in a deployment environment and is typically the name of the organization that purchased the runtime licenses.
  • set via the SetSolutionName method of the component’s Licensing class. For example:
Copy Code
ScanFix sx = new ScanFix();
sx.License.SetSolutionName("ACMEImaging");

The Solution Name must be set in order to use runtime licensing.


OEM License Key

Accusoft.ScanFixXpress8.Net
OEM License Key
ScanFix Xpress 8 for .Net - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > OEM License Key

The OEMLicense Key:

  • is for use only by customers who choose to use Manually Reported Runtime licensing.
  • uniquely identifies the customer, product, version, edition, and platforms for which the license is valid.
  • is set via the SetOEMLicenseKey method of the component’s Licensing class, then the component is completely licensed and can be distributed without any further licensing operations.
Copy Code
ScanFix sx = new ScanFix();
sx.License.SetSolutionName("ACMEImaging");
sx.License.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);
sx.License.SetOEMLicenseKey("1.0.GQCC0EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDPP");

This property is not required for Automatically Reported Runtime licensing.


Licensing Glossary

Accusoft.ScanFixXpress8.Net
Licensing Glossary
ScanFix Xpress 8 for .Net - User Guide > Licensing > Licensing Glossary
The following sections each describe a licensing term:
  • Access Key
  • Accusoft Products
  • Activation
  • Assigned Access Key
  • Automatically Reported Runtime Licensing
  • Customers, Developers, and Users
  • Edition
  • Evaluation License
  • Hardware Key
  • License Configuration File
  • Licensing Development Kit (LDK)
  • License Key
  • License Manager
  • Manually Reported Runtime Licensing
  • Node-Locked Licensing
  • Non-Node-Locked Licensing
  • Paid License
  • Registration
  • Runtime (Deployment) Licensing
  • Server Licensing Utility (SLU)
  • Toolkit Licensing
  • Web Services

Access Key

All licenses are assigned a unique identifier known as an Access Key. Access Keys are associated with the organization that purchased the license.

Accusoft Products

An Accusoft product may be licensed with either a Toolkit License or a Runtime License.

Activation

Activation is the process of selecting a previously registered toolkit license. Licenses may be paid (Toolkit) or evaluation, and may be for one of many product editions, for products with multiple editions.

Assigned Access Key

An assigned Access Key is one that is assigned to a specific user or users. The assignment of Access Keys to specific users can be done using the Licensing Development Kit (LDK).

Automatically Reported Runtime Licensing

Runtimes may be licensed in one of two ways: automatic reporting or manual reporting. With automatic reporting, you do not need to worry about royalty reporting; it is handled by the licensing layer.

Customers, Developers, and Users

Customers are simply any person who has purchased an Accusoft product. Developers are customers who possess a license for an Toolkit. Users are typically the customers of Accusoft's customers who use applications built around Accusoft components and are assigned a runtime license.

Edition

Some Accusoft products have multiple editions. Editions may offer multiple levels of product speed or product features, allowing customers to find a price-performance mix that is appropriate for them. Products that support multiple editions register multiple Toolkit licenses at installation time, one Toolkit license per edition. Developers must select an edition to activate using the License Manager.

Evaluation License

An evaluation license is a Toolkit license that is unpaid. When an Accusoft Toolkit is installed, evaluation licenses for all applicable product editions are installed and registered, and the edition with the most features is activated. Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups, timeouts, or evaluation watermarks. When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups, timeouts, and evaluation watermarks.

Hardware Key

When a license is activated for a product, the system information that identifies the installation hardware is contained within an encrypted string and is used to generate the license key for the product. The string containing the encrypted hardware information is known as the Hardware Key.

License Configuration File

When a Toolkit or an Automatically Reported Runtime license is purchased, a configuration file is provided that contains information about the license that was purchased. This file is used by the licensing utilities (License Manager, Server License Utility, and License Development Kit) to install a license on the system.

Licensing Development Kit (LDK)

The Licensing Development Kit (LDK) is an ActiveX component that may be used for Runtime Licensing. The LDK is one mechanism for Automatically Reported Runtime Licensing; the Server Licensing Utility (SLU) is the other.

License Key

Each product license has a unique key associated with it that uniquely identifies the customer, product, version, edition, and platforms, and, in some cases, the hardware for which the license is valid.

License Manager

The License Manager is a GUI application that is used by a developer to register and activate Toolkit licenses on their development system.

Manually Reported Runtime Licensing

Runtimes may be licensed in one of two ways: automatic reporting or manual reporting. With Manually Reported Runtime Licensing, you embed all of the licensing information directly into your application. You must manually provide royalty reporting to Accusoft for the actual licenses deployed. This model will be the best choice for you if you are not connected to the Internet at runtime, as might be the case in an defense or financial application.

Node-Locked Licensing

Another name for Automatically Reported Runtime Licensing.

Non-Node-Locked Licensing

Another name for Manually Reported Runtime Licensing.

Paid License

A paid license is a Toolkit license that you have purchased from Accusoft. It is ready to be used in production, with no trial dialog pop-ups, timeouts, or evaluation watermarks. If you wish to test other editions of the Accusoft product for which you have purchased a Paid License, you may activate an Evaluation license for that edition; a complete set of Evaluation licenses for all editions is registered at installation time.

Registration

Registration is the process of informing the License Manager about a new Toolkit license you have purchased. It uses this information to create a license key on your system; this allows you to activate the product for development with no restrictions, such as trial dialog pop-ups, timeouts, or evaluation watermarks.

Runtime (Deployment) Licensing

When deploying an application, a Runtime License is also required for each user’s installation. You must purchase runtime licenses, which are consumed as licenses are registered. There are two Runtime licensing models: Automatically Reported Runtime License; and Manually Reported Runtime License.

Server Licensing Utility (SLU)

The Server Licensing Utility (SLU) is a small GUI application that allows you to request a license key from the Runtime licenses you have purchased. The SLU is one mechanism for Automatically Reported Runtime Licensing; the Licensing Development Kit (LDK) is the other.

Toolkit Licensing

Each Toolkit is assigned to a specific developer who has a registered account with Accusoft. When the developer installs the Toolkit, it is not fully functional until they have activated the license through the use of the License Manager application. When the developer starts the License Manager, they are required to provide login credentials that identify and allow them to activate their license on a development system. See Toolkit Licensing.

Web Services

When a license is registered, information that uniquely identifies the customer’s or user’s hardware is passed along with the license information over the Internet to a web service. The web service validates the licensing request, generates a key that includes the hardware information, and returns the new license key to the application that made the licensing request. The license key is then stored on the requested system and used by the component when it is executed. It is also possible to register systems that are not directly connected to the Internet through the use of removable media and a different system that is connected to the Internet.


Software License Agreement

Accusoft.ScanFixXpress8.Net
Software License Agreement
ScanFix Xpress 8 for .Net - User Guide > Licensing > Software License Agreement

PLEASE READ THE FOLLOWING SOFTWARE LICENSE AGREEMENT WHICH GOVERNS YOUR RIGHT TO USE OF THE TOOLKIT. YOU MUST ACCEPT THESE TERMS BEFORE YOU ARE ALLOWED TO INSTALL THE TOOLKIT. YOU EXPRESSLY AGREE THAT YOU HAVE THE AUTHORITY TO CONTRACTUALLY BIND THE ORGANIZATION AGREEING TO THESE TERMS.

BY CLICKING "I ACCEPT," OR INSTALLING TOOLKIT, OR PLACING TOOLKIT IN-USE, LICENSEE IS AGREEING TO BE BOUND BY THIS AGREEMENT.

1. GRANT OF AGREEMENT

This Accusoft Corporation, ("ACCUSOFT") Software License Agreement ("AGREEMENT") grants the organization contracting under this agreement as licensee ("LICENSEE") a limited, nontransferable, nonexclusive and non-assignable license to use the trial mode version of this ACCUSOFT Development Toolkit ("TOOLKIT") on a single computer for evaluation of fitness only and not for any commercial purpose; or to use a properly purchased and registered TOOLKIT, for development purposes only on a single computer, provided the TOOLKIT is IN-USE on only one computer at any time. (However additional TOOLKIT licenses may be purchased.) TOOLKIT is "IN-USE" on a computer when it becomes loaded by any means for any purpose into temporary memory (that is, including but not limited to RAM) or when it becomes copied or installed to less temporary storage by any means for any purpose (that is, including but not limited to hard disk, CD-ROM or other removable disk or tape, USB or other flash memory drive or card, or other local, networked, or cloud storage device) when it is accessible to that computer. The TOOLKIT is explicitly not to be used on a site-wide basis, via a server or other networked connection.

2. REDISTRIBUTION OF TOOLKIT RUNTIMES

ACCUSOFT does not grant LICENSEE any rights to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer TOOLKIT or any portion of TOOLKIT ("PORTION") except as provided in Section 1. GRANT OF AGREEMENT. For licensing information about any other distribution of TOOLKIT or PORTION, please visit our web site (www.accusoft.com/licensing.htm), or contact our sales staff. LICENSEE agrees to notify ACCUSOFT immediately of any violations or changes in status regarding LICENSEE's compliance with any term of this AGREEMENT.

In the event that ACCUSOFT grants LICENSEE in a written separate runtime license agreement ("RUNTIME AGREEMENT") a right to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer PORTIONS, the RUNTIME AGREEMENT will specify what PORTIONS may be distributed ("RUNTIME"). LICENSEE agrees to acknowledge and uphold the terms and conditions of this AGREEMENT as well as the terms of the RUNTIME AGREEMENT itself, which will be provided only in writing. In such event, LICENSEE may distribute RUNTIMES as part of the LICENSEE's software application or derivative works ("PRODUCT") upon additionally agreeing to the following:

a) LICENSEE understands and acknowledges that in order to receive any discounted pricing for RUNTIME distribution licensing fees based on the type of installation, it must either: 1) prepay for a number of RUNTIME licenses that is sufficient to qualify for ACCUSOFT's then-current published quantity discount, or 2) it must pay for the licenses in accordance with a written contract between LICENSEE and ACCUSOFT.

b) LICENSEE's PRODUCT shall not compete to any degree with the TOOLKIT. Such competitive PRODUCTS are defined as software development toolkits that include similar functionality as TOOLKIT and that are intended for use by software developers and/or system integrators.

c) LICENSEE's PRODUCT must be substantially greater in scope with greater functionality and features than those of the TOOLKIT.

d) LICENSEE will not use ACCUSOFT's name, logo, or trademarks to market PRODUCT without prior written approval of ACCUSOFT except LICENSEE will include a statement substantially similar to the following within PRODUCT documentation and about box: "Portions of this product contain imaging and other technology owned by Accusoft Corporation, Tampa, FL, (www.accusoft.com). ALL RIGHTS RESERVED."

e) LICENSEE agrees to only distribute the RUNTIMES. No license or other rights are granted to LICENSEE for any distribution of the TOOLKIT or PORTIONS including, but not limited to, documentation, source code, or the RUNTIME distribution unlock codes.

g) LICENSEE will only distribute the RUNTIMES on the hardware and operating system(s) for which the RUNTIMES are intended to be used according to the RUNTIME AGREEMENT.

If ANY of the terms of this AGREEMENT are not applicable to LICENSEE'S situation, or if any of the terms of this AGREEMENT cannot be complied with, or if LICENSEE needs modifications to this AGREEMENT or the license granted for any reason, LICENSEE must contact ACCUSOFT about obtaining an expanded license from ACCUSOFT (available by phone at: 813-875-7575, x321, by e-mail at: Sales@accusoft.com or by fax at: 813-875-7705).

This AGREEMENT grants rights to LICENSEE only for the TOOLKIT and does not convey any other rights of use or distribution to ACCUSOFT technology.

3. OWNERSHIP

LICENSEE acknowledges and agrees that ACCUSOFT owns all rights, title and interest in the TOOLKIT, in all forms, including without limitation any and all worldwide proprietary rights therein, including but not limited to trademarks, copyrights, patent rights, patent continuations, trade secrets and confidential information.

LICENSEE may not remove or alter the copyright notice from any copy of the TOOLKIT or any copy of the written materials, accompanying the TOOLKIT.

LICENSEE waives its right to contest any of ACCUSOFT's patents, trademarks, service marks, trade names, copyrights, and other intellectual property and proprietary rights in and to the TOOLKIT.

LICENSEE shall not use such trademarks, service marks, and trade names except where and as permitted under this AGREEMENT without receiving ACCUSOFT's prior written approval of such use. If such approval is granted, LICENSEE’s right to use such trademarks, service marks, and trade names shall end upon the termination of this AGREEMENT.

4. RESTRICTIONS AND RESERVATIONS.

All rights and licenses not expressly granted to LICENSEE are reserved to ACCUSOFT. LICENSEE is strictly prohibited from reproducing, copying, marketing, selling, distributing, licensing, sublicensing, leasing, timesharing or renting the TOOLKIT or PORTION, and LICENSEE is strictly prohibited from any use of the TOOLKIT or PORTION except as permitted by this AGREEMENT, and such actions are expressly prohibited. LICENSEE is strictly prohibited from incorporating or including the TOOLKIT or PORTION into or as part of any PRODUCT or service of LICENSEE except as provided by this AGREEMENT, regardless of the functionality of TOOLKIT (or lack thereof) within or as part of such PRODUCT or service of LICENSEE. LICENSEE shall not for any reason disassemble, decompile, decrypt or reverse engineer the TOOLKIT or PORTION or in any manner attempt to discover or reproduce the source code or any other copyrightable, proprietary, or trade secret aspect of the TOOLKIT or PORTION. Nor shall LICENSEE use the TOOLKIT or PORTION, directly or indirectly, in developing LICENSEE's own PRODUCT with, or including, similar functionality. LICENSEE shall not make any copies of the TOOLKIT or PORTION for any purpose whatsoever except as permitted by this AGREEMENT. Source code that is provided with TOOLKIT for sample or demonstration purposes may be used directly or indirectly in developing PRODUCT, however it may not be distributed in source form in whole or in part with or as part of PRODUCT.

5. WARRANTY DISCLAIMER

LICENSEE ACKNOWLEDGES AND AGREES THAT THE TOOLKIT IS PROVIDED "AS IS." ACCUSOFT DISCLAIMS ANY AND ALL REPRESENTATIONS AND WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND AGAINST INFRINGEMENT.

6. LIMITATION OF LIABILITY

ACCUSOFT SHALL HAVE NO LIABILITY TO LICENSEE, LICENSEE AFFILIATES, SUBSIDIARIES, SHAREHOLDERS, OFFICERS, DIRECTORS, EMPLOYEES, REPRESENTATIVES OR ANY THIRD PARTY, WHETHER IN CONTRACT, TORT, NEGLIGENCE OR PRODUCTS LIABILITY, FOR ANY CLAIM, LOSS OR DAMAGE, INCLUDING BUT NOT LIMITED TO, LOST PROFITS, LOSS OF USE, BUSINESS INTERRUPTION, LOST DATA, LOST FILES, OR FOR ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES OF ANY KIND OR NATURE WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH USE OF OR INABILITY TO USE THE TOOLKIT, OR THE PERFORMANCE OR OPERATION OF THE TOOLKIT, EVEN IF ACCUSOFT HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

7. INDEMNIFICATION BY LICENSEE

LICENSEE SHALL INDEMNIFY, HOLD HARMLESS AND DEFEND ACCUSOFT FOR ANY LOSS, CLAIM, ACTION OR PROCEEDING THAT ARISES OR RESULTS FROM ANY ACTIONS OR OMISSIONS OF LICENSEE PERTAINING TO THE PRODUCT OR THE TOOLKIT AND FROM ANY ACTIONS OF LICENSEE THAT ARE IN VIOLATION OF THIS AGREEMENT.

8. TERM AND TERMINATION

Unless otherwise agreed to by the parties, this AGREEMENT shall become effective upon the earlier of LICENSEE's clicking of "I Accept" or LICENSEE'S installing or placing TOOLKIT IN_USE ("Effective Date") and shall continue in full force and effect until terminated in accordance with the terms set forth in this AGREEMENT.

Any material breach of this AGREEMENT shall automatically and immediately terminate this AGREEMENT. In the event that LICENSEE ceases to do business or is adjudged bankrupt or insolvent, ACCUSOFT may, at its sole option, terminate this AGREEMENT, by giving ten (10) Business Days written notice of such termination, which notice shall identify and describe the basis for such termination.

In the event of any termination of this AGREEMENT, any RUNTIME AGREEMENT is simultaneously terminated and LICENSEE shall stop using the TOOLKIT and PORTION, shall cease manufacturing the PRODUCT containing TOOLKIT or PORTION, and shall cease distributing PRODUCT containing TOOLKIT or PORTION. LICENSEE shall also require its resellers, OEMs, and other distribution channels (if any) to likewise stop manufacturing and distributing the PRODUCT containing TOOLKIT or PORTION. Within ten (10) Business Days thereafter, LICENSEE shall return or, at ACCUSOFT's option, destroy, the TOOLKIT and all PORTIONS, whether or not incorporated in or with the PRODUCT, that are within LICENSEE’s possession, custody and control, and shall certify to ACCUSOFT in writing within ten (10) Business Days after that return or destruction that it has complied with the foregoing obligation.

All Sections except Section 1. GRANT OF LICENSE shall continue in full force and effect, notwithstanding any termination of this AGREEMENT.

9. LIQUIDATED DAMAGES

In the event LICENSEE (a) copies the TOOLKIT or PORTION except as permitted by this AGREEMENT, (b) uses the TOOLKIT or PORTION for any reason other than as permitted by this AGREEMENT, (c) installs or uses the TOOLKIT or PORTION on more than a single computer, or (d) otherwise violates or breaches this Agreement, LICENSEE agrees that ACCUSOFT is entitled to obtain as liquidated damages and not as a penalty the greater of the amount of (v) the published quantity one distribution price based upon the type of distribution, or (w) $99 per each user of each PRODUCT or service of LICENSEE in which the TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; (x) $100 per copy of TOOLKIT or PORTION; (y) $100 per copy of any PRODUCT in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; or (z) 3% of all revenues realized by LICENSEE pertaining to any PRODUCTS or services of LICENSEE in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible. THE LICENSEE EXPRESSLY AGREES THAT THE FOREGOING LIQUIDATED DAMAGES ARE NOT A PENALTY.

10. CONFIDENTIALITY

LICENSEE acknowledges that the TOOLKIT contains ACCUSOFT know-how, confidential and trade secret information ("PROPRIETARY INFORMATION"). LICENSEE agrees: (a) to hold the PROPRIETARY INFORMATION in the strictest confidence, (b) not to, directly or indirectly, copy, reproduce, distribute, manufacture, duplicate, reveal, report, publish, disclose, cause to be disclosed, or otherwise transfer the PROPRIETARY INFORMATION to any third party, (c) not to make use of the PROPRIETARY INFORMATION other than as permitted by this AGREEMENT, and (d) to disclose the PROPRIETARY INFORMATION only to LICENSEE's representatives requiring such material for effective performance of this AGREEMENT and who have undertaken an obligation of confidentiality and limitation of use consistent with this AGREEMENT. This obligation shall continue as long as allowed under applicable law.

11. INJUNCTIVE RELIEF

LICENSEE agrees that any violation or threat of violation of this AGREEMENT will result in irreparable harm to ACCUSOFT for which damages would be an inadequate remedy. Therefore, in addition to its rights and remedies available at law (including but not limited to the recovery of damages for breach of this AGREEMENT), ACCUSOFT shall be entitled to immediate injunctive relief to prevent any violation of ACCUSOFT's copyright, trademark, trade secret rights regarding the TOOLKIT, or to prevent any violation of this AGREEMENT, including, but not limited to, unauthorized use, copying, distribution or disclosure of or regarding the TOOLKIT or PORTION, as well as any other equitable relief as the court may deem proper under the circumstances.

12. NO REDUCED PRICING

In any determination of ACCUSOFT's damages (whether liquidated damages or actual damages), or any determination of any licensing fees or royalties due ACCUSOFT under this AGREEMENT due to a breach by LICENSEE hereunder, LICENSEE shall not be entitled to any discounts (volume or otherwise) or reduced licensing fees or royalties. The foregoing sentence shall be applicable unless LICENSEE has negotiated and entered into a written, signed agreement with ACCUSOFT for such reduced or discounted licensing fees or royalties and paid ACCUSOFT such fees or royalties in advance of any: (a) distribution of the TOOLKIT or PORTION, (b) copying of the TOOLKIT or PORTION, or (c) incorporation or use of the TOOLKIT or PORTION in or pertaining to any PRODUCT or service of LICENSEE. Further, LICENSEE agrees that it shall not be entitled to reduced licensing fees or royalties when determining ACCUSOFT's damages due to any undertaking or activity by LICENSEE regarding the TOOLKIT or PORTION outside of or exceeding the scope of permission or other terms of this AGREEMENT, or LICENSEE's actions otherwise in violation of this AGREEMENT.

13. ATTORNEYS' FEES AND COSTS

In the event of any lawsuit or other proceeding brought as a result of any actual or alleged breach of this AGREEMENT, to enforce any provisions of this AGREEMENT, or to enforce any intellectual property or other rights in or pertaining to the TOOLKIT or PORTION, the prevailing party shall be entitled to an award of its reasonable attorneys’ fees and costs, including the costs of any expert witnesses, incurred at all levels of proceedings.

14. GOVERNING LAW

This AGREEMENT shall be construed, governed and enforced in accordance with the laws of the State of Florida, without regard to any conflicts of laws rules. Any action related to or arising out of this AGREEMENT will be filed only in the Florida courts and LICENSEE consents to the exclusive jurisdiction and venue of the state and federal courts located in Tampa, Florida.

15. SEVERABILITY

If any provision of this AGREEMENT is determined to be invalid by any court of final jurisdiction, then it shall be omitted and the remainder of the AGREEMENT shall continue to be binding and enforceable. In addition, the Court is hereby authorized to enforce any provision of the AGREEMENT that the Court otherwise deems unenforceable, to whatever lesser extent the Court deems reasonable and appropriate, rather than invalidating the entire provision. Without limiting the generality of the foregoing, LICENSEE expressly agrees that should LICENSEE be found to have breached the AGREEMENT, under no circumstances shall LICENSEE be entitled to any volume or other discount, or reduced licensing fee or royalty in the determination of ACCUSOFT's damages, or otherwise in the determination of any licensing fee or royalty owed to ACCUSOFT.

16. GOVERNMENT RIGHTS

The TOOLKIT and accompanying documentation have been developed at private expense and are sold commercially. They are provided under any U.S. government contracts or subcontracts with the most restricted and the most limited rights permitted by law and regulation. Whenever so permitted, the government and any intermediaries will obtain only those rights specified in ACCUSOFT's standard commercial license. Thus, the TOOLKIT referenced herein, and the documentation provided by Accusoft hereunder, which are provided to any agency of the U.S. Government or U.S. Government contractor or subcontractor at any tier shall be subject to the maximum restrictions on use as permitted by FAR 52.227-19 (June 1987) or DFARS 227.7202-3(a) (Jan. 1, 2000) or successor regulations. Manufacturer is Accusoft Corporation, 4001 N. Riverside Drive Tampa, FL 33603.

17. ENTIRE AGREEMENT

This AGREEMENT represents the entire understanding of the parties concerning the subject matter hereof and supersedes all prior communications and agreements, whether oral or written, relating to the subject matter of this AGREEMENT. Only a writing signed by the parties may modify this AGREEMENT. In the event of any modification in writing, of this AGREEMENT, including an expanded license agreement, all sections of this Agreement survive except Section 2. Limited License.

18. CONTACT US

Should you have any questions concerning this AGREEMENT, or if you desire to contact ACCUSOFT for any reason, please contact ACCUSOFT at 1-813-875-7575.

19. OTHER RESTRICTIONS

a) This AGREEMENT shall not be amended, altered, changed or modified in any way, unless agreed to in writing by both ACCUSOFT and LICENSEE. Such writing must be executed by a duly authorized representative of ACCUSOFT and a duly authorized representative of LICENSEE.

b) This AGREEMENT is not transferable or assignable by LICENSEE under any circumstances, without the prior written consent of ACCUSOFT. ACCUSOFT will not unreasonably withhold such consent. This AGREEMENT shall be binding upon, and is made for the benefit of, each party, its successors, and permitted assignees (if any). For the purposes of this AGREEMENT, any change in control of LICENSEE shall constitute an assignment or transfer of this AGREEMENT requiring prior written consent of ACCUSOFT. As used in this section, a change in control is defined as (i) any change in ownership of more than fifty percent (50%) of the voting interest in LICENSEE, whether by merger, purchase, foreclosure of a security interest or other transaction, or (ii) a sale of all or substantially all of the assets of LICENSEE.

c) The relationship established by this AGREEMENT between LICENSEE and ACCUSOFT shall be that of Licensee and Licensor. Nothing contained in this AGREEMENT shall be construed as creating a relationship of agency, joint venture or partnership between LICENSEE and ACCUSOFT. Neither party shall have any right whatsoever to incur any liabilities or obligations on behalf of the other party.

d) ACCUSOFT's failure to perform any term or condition of this AGREEMENT as a result of conditions beyond its control such as, but not limited to, war, strikes, fires, floods, acts of God, governmental restrictions, power failures, or damage or destruction of any network facilities or servers, shall not be deemed a breach of this AGREEMENT.

e) The headings provided in this AGREEMENT are for convenience and reference purposes only. In the event of a conflict between the terms and conditions listed in this AGREEMENT, and any attached Schedules or Appendices, the terms and conditions of this AGREEMENT shall govern.

f) A waiver of a breach, violation, or default under this AGREEMENT shall not be a waiver of any subsequent breach, violation or default. Failure of either party to enforce compliance with any term or condition of this AGREEMENT shall not constitute a waiver by the party of such term or condition.

g) All notices and communications shall be in writing and shall be deemed to have been duly given the earlier of when delivered or three (3) Business Days after mailing by certified mail, return receipt requested, postage prepaid, or by international delivery service, addressed to the parties at their respective addresses set forth on the Order Form or at such other addresses as the parties may designate by written notice in accordance with this section.

Rev. 20120112

See Also
Distributing ScanFix Xpress


Distributing Applications and Deployment

Accusoft.ScanFixXpress8.Net
Distributing Applications and Deployment
ScanFix Xpress 8 for .Net - User Guide > Distributing Applications and Deployment

The Distributing Applications and Deployment section provides information on:

  • Verify You Are Using the Latest Service Pack
  • Distributing ScanFix Xpress


Verify You Are Using the Latest Service Pack

Accusoft.ScanFixXpress8.Net
Verify You Are Using the Latest Service Pack
ScanFix Xpress 8 for .Net - User Guide > Distributing Applications and Deployment > Verify You Are Using the Latest Service Pack

Service pack updates will not overwrite paid licensing. Your paid licensing will continue to work and you will not be required to re-enter your purchased registration codes. Service pack updates do not include any changes that might "break" previously developed and/or deployed code.

Verify Latest Development Components

To verify you are using the latest version of an Accusoft Development Component or Components, please refer to the currently released product build numbers at www.accusoft.com/latestbuilds.htm

If you require further assistance or have questions or comments, please see the section Getting Support for more detailed information.

See Also
Getting Support
Installing on a Development Machine


Distributing ScanFix Xpress

Accusoft.ScanFixXpress8.Net
Distributing ScanFix Xpress
ScanFix Xpress 8 for .Net - User Guide > Distributing Applications and Deployment > Distributing ScanFix Xpress

DLL File to Distribute

After purchasing and registering ScanFix Xpress, distribute the appropriate assembly DLL file with applications using the ScanFix Xpress .NET component:

  • Accusoft.ScanFixXpress8.NET.dll
See Also
Getting Support
Installing on a Development Machine
Software License Agreement
Verify You Are Using the Latest Service Pack


Concepts

Accusoft.ScanFixXpress8.Net
Concepts
ScanFix Xpress 8 for .Net - User Guide > Concepts

The Concepts sections provides information on:

  • Overview of ScanFix Xpress
  • ScanFix Operations vs Supported Images
  • Introduction to Image Processing
    • Bitonal Images
    • Continuous Tone Images
    • Contrast Correction
    • Colorspace Theory
    • Colorspace Use in ScanFix Xpress
  • Glossary


Overview of ScanFix Xpress

Accusoft.ScanFixXpress8.Net
Overview of ScanFix Xpress
ScanFix Xpress 8 for .Net - User Guide > Concepts > Overview of ScanFix Xpress

ScanFix Xpress leverages powerful document image enhancement technology to improve quality and increase content recognition accuracy, on color, grayscale, and black and white images, in document imaging applications. ScanFix Xpress provides bitonal, color, and grayscale form enhancement and cleanup, preparing your data for the next steps in your form processing workflow.

ScanFix Xpress is delivered as a .NET or ActiveX SDK and offers:

  • Fast and effective image cleanup
  • Robust image editing
  • Efficient image processing
  • TWAIN scanning support
  • Confidence reporting on cleanup results
  • Seamless integration with other Accusoft Corporation components
ScanFix Xpress is designed to work on images with high contrast data contents, such as black text on a white or mono-color background, or white text on a dark or black background. Images that do not exhibit this high contrast data, such as images containing photographs, may not benefit from ScanFix Xpress cleanup actions.

For an introduction to image processing, please read the following topics:

  • Bitonal Images
  • Continuous Tone Images
  • Contrast Correction
  • Colorspace Theory
  • Colorspace Use in ScanFix Xpress


ScanFix Operations vs Supported Images

Accusoft.ScanFixXpress8.Net
ScanFix Operations vs Supported Images
ScanFix Xpress 8 for .Net - User Guide > Concepts > ScanFix Operations vs Supported Images

ScanFix supports images of certain bit depths for its various operations. The table below lists the ScanFix operations and the supported image bpp (bits per pixel).

ScanFix Xpress Operation | Supported Image Type
 | Bitonal (1 bpp) | Gray scale(8 bpp) | Color (24 bpp)
AdjustBrightnessContrast |  | X | X
Apply Filters |  | X | X
AutoBinarize |  | X | X
AutoImageDetergent |  |  | X
Binarize | X | X | X
ColorDrop |  |  | X
CorrectInverseText | X |  |
CorrectNegativePage | X | X | X
Deskew | X | X | X
Despeckle | X |  |
DetectBlankPage | X | X | X
DetectBlankRectangle | X | X | X
DetectColor |  |  | X
Dilate | X | X | X
Erode | X | X | X
Flip | X | X | X
GetRectangle | X | X | X
ImageDetergent |  |  | X
Mirror | X | X | X
Negate | X | X | X
RegisterImage | X | X | X
RemoveBlobs | X |  |
RemoveBorder | X | X | X
RemoveCombs | X |  |
RemoveDotShading | X |  |
RemoveLines | X |  |
Rescale | X | X | X
Rotate | X | X | X
Shear | X | X | X
SmoothObject | X |  |
SmoothZoom | X |  |
VirtualBulb |  |  | X
AutoRotate | X |  |
AutoAdjustBrightnessContrast |  | X | X
AutoCorrectInverseText | X |  |
AutoDespeckle | X |  |
AutoRemoveHolePunch | X |  |
AutoSmoothBackground |  | X | X


Introduction to Image Processing

Accusoft.ScanFixXpress8.Net
Introduction to Image Processing
ScanFix Xpress 8 for .Net - User Guide > Concepts > Introduction to Image Processing

Introduction to Image Processing includes information on:

  • Bitonal Images
  • Continuous Tone Images
  • Contrast Correction
  • Colorspace Theory
  • Colorspace Use in ScanFix Xpress


Bitonal Images

Accusoft.ScanFixXpress8.Net
Bitonal Images
ScanFix Xpress 8 for .Net - User Guide > Concepts > Introduction to Image Processing > Bitonal Images

Bitonal images are images that use only two colors, black and white, to build up the image. Bitonal images are commonly encountered in document imaging, because text information is readily stored in bitonal format. Bitonal format provides excellent readability and efficient lossless compression of document images, but also results in a number of limitations.

Documents are not always readily converted into clean bitonal images, and information that is presented in varying colors and shades of gray are often lost. Photographic content must be dithered or halftoned, resulting in much information loss. Bitonal images are also prone to produce artifacts when manipulated; rotating a line, for example, will result in a stair-step appearance, because it is not possible to interpolate the brightness of the pixels.

Some image processing operations, particularly ones that deal with grouping pixels together, work best in the domain of bitonal images. Bitonal images provide clearly delineated boundaries for pixel groups, and operations that remove such groups, such as despeckle, blob, line, and comb removal, are limited to the bitonal domain in ScanFix® Xpress.


Continuous Tone Images

Accusoft.ScanFixXpress8.Net
Continuous Tone Images
ScanFix Xpress 8 for .Net - User Guide > Concepts > Introduction to Image Processing > Continuous Tone Images

Continuous tone images are images that are stored in a format where there are many shades of brightness for each color component. Grayscale images and 24-bit color images are both continuous tone images; grayscale images contain 256 shades of brightness, while 24-bit color images contain 256 shades of brightness of red, green, and blue, which are mixed to create the full range of reproducible color. Continuous tone images preserve a much greater amount of information than bitonal images, as well as providing room for interpolation of pixel values when pixels are moved or scaled.

However, the jump from 1-bit per pixel to 8-bit or 24-bits results in a far greater image size than bitonal images, and the continuous tone format’s ability to store subtle differences in brightness makes the standard run length encoding used by lossless bitonal compression formats far less effective. Compression methods for continuous tone images typically attempt to break the image data down into curves or wavelets, and in the process discard information likely to be unimportant. At high compression factors, this process can also lead to the creation of artifacts, particularly around sharp, high contrast boundaries.

Some image processing operations, particularly ones that deal with color differences and brightness and contrast, work best in the domain of continuous tone images. Operations dealing with brightness and contrast work on any continuous tone image, while operations dealing with color aspects are limited to color images only.


Contrast Correction
ScanFix Xpress 8 for .Net - User Guide > Concepts > Introduction to Image Processing > Contrast Correction

Introduction

Sometimes it is desirable to alter the contrast of an image, either to darken faint text or to lighten a dark background, and increase the readability of the data on the image. ScanFix Xpress provides functionality to analyze an image, to determine the degree of contrast, and two methods for increasing the contrast of the image. This functionality works on gray and color images only.

Contrast Analysis

The analysis phase of contrast correction takes place during the initialization phase. In analysis, the image is sampled along a grid whose spacing is calculated using the quality setting. Higher qualities examine more samples, lower qualities examine fewer samples. The samples are used to generate a histogram of the brightness of the image at various locations on the image (the higher the quality, the more locations) and estimate brightness, contrast, noise, and variance in the image.

The background brightness is calculated by looking at the median brightness (which is a more accurate measure for this purpose than the average) at regions across the image, and calculating the average of those medians. The top percent of brightest and darkest pixels are also calculated, and used to determine the amount of noise and contrast. Since the algorithm assumes dark text on a light background, the range above the median is used to estimate the noise radius, and the range below the median is used to estimate the contrast. The difference in the median values between different regions of the image is used to detect a varying background color, and may affect the correction method chosen. If the measured contrast is lower than the noise radius, the image will be reported as uncorrectable. The algorithm described here assumes document images consisting of dark text on a light colored background. If the image consists of light text on a dark background, the image may be processed inverted (see detect negative for information on automatically detecting light-on-dark images).

Contrast Correction

Contrast correction parameters are based on percentile brightness, so a basic understanding of what the percentile brightness represents is important to allow a proper choice of minimum and maximum values. Percentile brightness is based on a percentage, so values of 0 to 100 cover the range of brightness in the image. The Nth percentile brightness specifies a brightness brighter than N percent of the pixels in the image, and darker than (100 – N) percent of the pixels. For example, the 90th percentile brightness would represent a brightness where 90% of the sampled image pixels are darker, and 10% of the sampled pixels are brighter. The 50th percentile, where half the pixels are brighter and half are darker, is the same as the median value, and is a good estimate for the typical background brightness. The 0th percentile value will be the brightness of the darkest pixel sampled, while the 100th percentile value will be the brightness of the brightest pixel sampled. Values of -1 and 101 can also be provided for percentiles; these values DO NOT change based on the samples, but are fixed at a brightness of 0 and 255 respectively, representing the darkest and lightest possible brightness. These values are used to force the contrast correction to shift the image brightness in only one direction, as will be explained below.

<BR>

Contrast correction works by taking two brightness levels, specified by minimum and maximum percentiles, and maximizing the contrast between those levels. This is done by moving all pixels darker than the minimum percentile to a brightness of 0, and all pixels brighter than the maximum percentile to a brightness of 255. Values in between the minimum and maximum will be proportionately distributed in the range of 0 to 255. For example, setting the minimum to the 0th percentile and the maximum to the 100th percentile will take the darkest pixel sampled and drop it and any darker pixels to a brightness of 0, and will take the brightest pixel sample and raise it and all brighter pixels to a brightness of 255. Since the percentile brightness is based in the image content, very dark images will be brightened, and washed out images will be darkened, whichever is needed to maximize the desired percentile range. See the section below for tips on choosing the right percentiles for your documents.

Adaptive vs. Global Correction

Global correction is the method that will most often apply to document images. In global correction, the minimum and maximum percentile will be chosen based on the average percentiles for the entire image, and the same brightness remapping will be applied to the entire image. This is the best approach to use for images where the background variance is low, because it is faster and easier to use.

Where background variance is high, such as images with varying background brightness, then using the same brightness values for the contrast enhancement may not work on all regions. In this case, the adaptive correction is the solution. The adaptive correction looks only at the contrast in the regions adjacent to each pixel, and chooses the brightness values based on that data. This means that the 50th percentile in one region of the image might correspond to a brightness of 240, while in another region with a shaded background, the 50th percentile might correspond to a brightness of 170. The quality factor chosen determines how big the regions are; a low quality will divide the image into only a few regions, while a high quality factor will divide the image into many regions. Higher qualities make the algorithm more responsive, so that it will adapt to changes in the background in a very short distance, while lower qualities result in changes over a larger distance.

The adaptive correction, especially at high quality levels, will very aggressively enhance the contrast—for example, in some cases it is capable of extracting faint text bleed-through from the back of documents; it is capable of expanding a difference in brightness of only a few percent to fill the entire range of brightness. This can be useful if it is applied to carbon copies where the data is very faint, but can be undesirable if it is magnifying a section where there is no desirable data. The aggressiveness of adaptive correction is controlled by the contrast limit parameters. The contrast limit determines how much the brightness of a pixel can be changed; a limit of 0 means that the brightness of the pixel will not be changed at all, while a limit of 255 means that any contrast at all can be expanded to the full range, pulling out even the faintest data. The contrast limit is set by three parameters, corresponding to high, medium, and low brightness values. For example, high contrast limit on bright pixels and a low limit on medium and dark pixels will allow light gray text to be darkened, but will prevent dark gray dot shading from becoming brighter.

Choosing the Right Percentiles

Ideally, all text in a scanned image would be pure black, and the background color would be a pure, bright color, but that is rarely the case. Inks reflect some light, while the paper absorbs some, the textures create inconsistencies in the brightness levels, and compression artifacts add additional noise. The following image shows a highly magnified section of very clear scan of black text on a white background, saved as a high quality JPEG image:

<BR>

Note the specks in the background, caused in this case primarily by compression artifacts, as well as the highly variable brightness of the “black” pixels. Add to this the fact that the percentile brightness will vary based on the amount of text in a given region, and the result is a percentile graph that is probably not as straightforward as one would expect. The analysis portion of the contrast correction will return a percentile graph, and it can be very instructive to plot that graph for problem images, to get an understanding of how the brightness changes as a function of the percentile, so that an intelligent choice can be made. This section will look at three different document images and compare the percentile graphs to demonstrate what happens when these images are processed.

<BR>

The image on the left is a clean, bright image containing only black text on a white background; this is the same image from which the “invention” image above was taken. The next image is a gray scan of an image printed with colored ink on colored paper, which yields a low contrast image. The last is the same scan as the first, but with margins and colored letterhead left in place.

<BR>

The text and letterhead images follow a very similar curve, but the margins in the letterhead image pushes up the brightness, especially at lower percentiles, due to the lower ratio of dark to light pixels. This means it’s important to err on the low side when picking a percentile to represent the text; even the 0th percentile values are very bright, representing the lightest pixels in the text.

The low contrast image has a similar shape as well, but with much less change from the 0th to 100th percentile. This shows how the use of percentile brightness is relatively insensitive to changes in background and text color, because the same set of carefully chosen percentiles applied to all of these images will result in good output. This also illustrates the values chosen for noise and contrast in the analysis phase; contrast (difference between 1st and 50th percentile) will be 70 or greater for the letterhead image, and only 40 for the low contrast image. Noise(difference between 50th and 99th percentile) in both cases will be less than 10.

For document images, the 0th or 1st percentile is typically a good value to choose to represent the text, as this will choose the darker pixels of the text. A typical section of text contains a maximum of around 15% text pixels, so any value above that is likely to represent the background color. The 50th percentile is the obvious choice, but if the background is noisy, choosing a value around the 30th percentile will push much of the background noise to pure white, in effect brightening and cleaning the background. For images containing photographs that must be preserved, the 0th to 100th percentile stretch is the safest, as it will minimize the number of pixels pushed to the extremes of the brightness range.


Colorspace Theory

Accusoft.ScanFixXpress8.Net
Colorspace Theory
ScanFix Xpress 8 for .Net - User Guide > Concepts > Introduction to Image Processing > Colorspace Theory

A basic understanding of the function of the human eye is essential to understanding imaging technology, especially when applied to color images. The printing process, the capture process, image compression, processing techniques, and OCR are all attempts to do, by machine, what the human eye does naturally. Scanners, printers, and monitors are all designed to fit human vision, its resolution and three-color perception.

The human eye contains four types of light receptors; the rods, for general light sensing, and three types of cones that respond to different wavelengths of light, which we perceive as colors. This makes humans trichromats capable of seeing three dimensions of color. Other species’ eye’s differ; most mammals are dichromats, possessing rods and two types of cone, while many species of fish, reptiles, amphibians, birds, and even insects are thought to be tetrachromats, with four types of cones.

<BR>

Human color vision responds to wavelengths of light from approximately 680 nm, a shade of red, to 400 nm, a shade of violet. The rods are relatively insensitive to light, absorbing from about 20% of the incoming red and green light, down to a mere 2% of the incoming blue light. The rods, which absorb wavelengths from 400 nm to 700 nm, are far more sensitive than the cones, but see only in shades of gray. There are around 100 million rods, and only 7 million cones in the eye; however, the fovea, which is the center of the visual field, contains almost all cones. This concentration provides humans with better color perception than most other trichromatic mammals.

The function of the eye tells us a couple of things. First, color is very important, as the central field of vision is geared to perceive color. Second, the existence of three types of cones in our eyes means that our eyes can be fooled into seeing most colors by simply combining different amounts of red, green, and blue light, rather than having to produce all possible wavelengths between 400 nm and 700 nm.

The first tells us why color imaging is important, and the second tells us how it works. There are two theories of color perception, both proposed in the 18th century, and both of which are useful for understanding and dealing with color image data. The first is the trichromatic or tristimulus theory, which states that the three types of cones are responsive to red, green, and blue light, and the opponent process theory, which states that the eyes interpret light as red vs. green, blue vs. yellow, and white vs. black. The trichromatic theory is why monitors mix red, green, and blue light in varying amounts to generate all the producible colors. The opponent process theory is why the YIQ colorspace used by NTSC television encodes information in the form of black/white, red/green, and blue/yellow components.

The trichromatic theory is the basis behind the RGB colorspace used in many imaging applications. Display hardware mixes red, green, and blue light in varying amounts to generate the image you see. This direct mapping to the display hardware makes RGB very convenient, and simple file formats, such as the Windows Bitmap, typically use the RGB format for storage as well. CMY and CMYK colorspaces are closely related to the RGB colorspace, but are targeted at print media, which is absorbent rather than emissive, and uses different primary colors. However, since these colorspaces are oriented towards the image display or printing hardware, they are not an intuitive means of dealing with color, nor are they ideal for various image processing operations.

The largest difference opponent process theory based colorspaces have is that they all put the black/white line parallel to an axis, where RGB places it at a diagonal. Since a change in brightness is perceived by more than one type of cone, due to the overlap in sensitivity, the black/white axis is the most important.

Take for instance the YIQ colorspace, used by broadcast television in North America through the advent of digital television. The Y represented the black/white axis, the I an orange/blue axis, and the Q a purple/green axis. When broadcast, the Y component gets 4 MHz of bandwidth, the I component gets 1.3 MHz, and the Q component gets only 0.4 MHz of bandwidth. This system was designed specifically to minimize the amount of bandwidth needed to add color, while preserving the visual quality of the previously used black and white television. The orange/blue axis gets a far greater portion of the bandwidth than the purple/green axis, because the eye is more sensitive to changes along the orange/blue axis than it is to changes along the purple/green axis.

The JPEG compression method uses a similar system, YCbCr, with Y being black/white, Cb being blue/yellow, and Cr being red/yellow; the Cb and Cr components are typically downsampled 2:1 spatially (i.e. a 200 dpi JPEG has 200 dpi Y and 100 dpi Cb and Cr) which results in an immediate compression of 50%, even before the application of the DCT compression.

<BR>

Artists color models are also useful in dealing with color images. The HSV color model is an artists’ model, with V (for “volume” or “value”), representing the black/white axis, H representing the hue, and S representing the saturation, and is typically represented as a cone. This model dates back to the 18th century, and has been used by artists since, as it provides an easy means of understanding how basic colors are blended to generate a desired color.

Starting with a color on the perimeter of the base of the cone, white can be added to reduce the saturation, moving the color in towards the center, and black can be added to reduce the brightness, moving the color towards the point. In addition to providing an intuitive method for dealing with color, this property is also useful when dealing with scanned images, because the interaction between zones of color, black text, and white paper will result in changes in saturation and brightness, but remain a constant hue.


Colorspace Use in ScanFix Xpress

Accusoft.ScanFixXpress8.Net
Colorspace Use in ScanFix Xpress
ScanFix Xpress 8 for .Net - User Guide > Concepts > Introduction to Image Processing > Colorspace Use in ScanFix Xpress

RGB Colorspace

ScanFix Xpress stores color data in RGB format, and most operations that do not specifically involve color work in the RGB colorspace. The RGB format is also used by the Color Drop and Image Detergent functions, because the RGB colorspace is closer to perceptual uniformity than other simple colorspaces, such as YIQ and HSV, and because it is a close match to the abilities of the capture and display hardware. Color Drop and Virtual Bulb will both operate on spheres of color in the RGB colorspace.

Example of RGB Colorspace:

HSV Colorspace

Virtual Bulb and Detect Color both operate in the HSV colorspace, as they are dependent on the concepts of hue and saturation. Viewing the HSV colorspace as a cube, they operate on rectangular sections of hue. In the HSV colorspace, changes in hue, saturation, or brightness are independent of each other; this independence allows for a simpler, more robust implementation of these features than would be possible working in the RGB colorspace.

Example of HSV Colorspace:

Comparing RGB & HSV Colorspaces

Different colorspaces have different densities of color, which can be seen by a simple comparison of the RGB and HSV colorspaces. Values along the “V” axis, which represent pure grays, have a saturation of 0. At 0 saturation, the hue becomes irrelevant, so every gray value has 256 possible hues that will correspond to a single RGB value. When the brightness reaches 0, saturation ceases to matter as well. This means that any color with a 0 value for “V” in the HSV colorspace, of which there are 65,536 possibilities, corresponds to the single value 0, 0, 0 in the RGB colorspace.

A number of color operations use a 15-bit depth conversion, which greatly speeds up the colorspace calculations with minimal impact in quality. The difference in densities between colorspaces and the use of 15-bit color depths will result in some visible quantization of colors in machine generated images, but the level of quantization is low enough to be below the noise threshold on scanned images.

How Virtual Bulb Uses Colorspace Theory

The Virtual Bulb operation uses a custom colorspace to provide a flexible color dropout method. A traditional dropout scanner works by using a monochromatic sensor, to record a gray image, and a bulb colored to match the drop-out form's ink. With a red ink, a red bulb would be used; the red parts of the page would reflect nearly 100% of the red light, as would the white parts, resulting in both red and white appearing as white in the gray image. Green, blue, and black would all absorb nearly 100% of the red light, resulting in black. The same effect can be emulated on a color scanner by using just the input from the red sensors.

Example of the Virtual Bulb Operation:

The Virtual Bulb operation uses a custom colorspace that provides the ability to emulate a dropout scanner. In the simplest case, shown on the top right, Virtual Bulb works exactly like a dropout scanner would, generating a gray image equal to just the red values. However, unlike a dropout scanner, Virtual Bulb can warp the colorspace to achieve results not possible with a scanner. It can squeeze the colorspace, and shown on the lower left (radius of 1), or stretch it out, as shown on the lower right (radius of 884). By doing this, the effective range of the dropout can be narrowed to an extremely tight band of pure reds, or spread out to encompass nearly the entire spectrum. The inner radius still goes to white, and the outer radius to shades of gray, although the ratio no longer looks like half and half. Any color can be dropped by rotating the spectrum to put a different color in the middle; 42 to drop yellow or 170 to drop blue. Stretching the colorspace a different direction will brighten the target hue to remove “shadows” from the final form (refer to the topic, I Have Forms Scanned in Color & Need to Remove Some Colors or Data).

To be consistent with the Color Drop and Image Detergent functions, the term "radius" is used when setting up a Virtual Bulb drop, and values of 1 to 884 are used for the radius (lower left is a radius of 1, lower right, 884). However, since the operation itself isn't done by actually setting a radius, but rather by warping the colorspace, the results will not be the same linear response. The function used in the colorspace warping generates an exponential curve, which will provide approximately linear results near 170, but increasingly less perceptible changes as the values approach 1 and 884.


Glossary

Accusoft.ScanFixXpress8.Net
Glossary
A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

A

Aliasing
Aliasing is the appearance of jagged lines caused by digital sampling of curves or diagonal lines. Aliasing is most prevalent in low resolution, low color depth images.

Anti-aliasing
Anti-aliasing is a process by which the effects of aliasing are reduced by blending the colors of pixels along sharp borders.

Artifact
An artifact is a shape that appears in an digitized image that was not in the original, but was created during sampling or image processing steps. The jagged edges produced by aliasing are a type of artifact caused by sampling, while the specks near edges in JPEG images are an artifact caused by the DCT compression algorithm.

Aspect Ratio
There are two kinds of aspect ratio that you need to be aware of when working with 2D images; the image aspect ratio and the pixel aspect ratio.

  • The image aspect ratio is the ratio of the width of the image to the height of the image.
  • The pixel aspect ratio is the shape of the pixels in the image. ScanFix® Xpress requires a pixel aspect ratio of 1:1, to prevent distortions from occurring during morphological operations. A 1:1 aspect ratio means having horizontal and vertical resolutions the same; if they are not, the image should be scaled before any morphological operations are performed.

Average Filter
See Box Filter.

B

Bitonal

A bitonal image is an image that consists of only two colors, black and white. Bitonal images are commonly dealt with in document imaging processing, because:

  • They provided the minimum amount of data needed to represent text.
  • They compress efficiently and losslessly.
  • They are readily broken down into groups of connected pixels which can be manipulated.

BMP
The Microsoft Windows Bitmapped file format is based on the Microsoft Windows internal bitmap data structures. The BMP format is very widely used and it is quick and easy to read. Although most BMP files are uncompressed, a type of run length encoding is supported.

Box Filter
Box filters are used for smoothing, and provide fast, aggressive smoothing to the image. A box filter, or average filter, is a convolution filter with a matrix of all 1's, which has the result of outputting the average pixel value for the window. However, large box filters also tend to produce visibly boxy results due to the use of a rectangular window.

BPP
Bits per pixel. The color depths supported by ScanFix® Xpress are: 1 bpp for bitonal images, 8 bpp for gray, and 24 bpp for color.

Brightness
The intensity of a pixel, usually expressed in the range of 0 (black) to 255 (white or fully bright color). Brightness of a color image may be defined in a number of ways, depending on the colorspace used.

C

CCITT
CCITT is the most widely used compression scheme for transmitting binary (black and white) image data. CCITT was established by the International Telegraph and Telephone Consultative Committee. The Group 3 and Group 4 CCITT compression standards are widely used for transmitting fax data. CCITT compressed images are typically stored in the TIFF image format.

Color Depth
The color depth of an image, expressed in bits per pixel (BPP), is the amount of space needed to store the information to describe the color of a single pixel. ScanFix® Xpress supports bit depths of 1, 8 and 24 BPP.

Color Space
A colorspace is a means of representing a set of colors, typically by mapping a subset of the realm of visible colors onto a three dimensional space so that each possible color can be represented by a set of three values. There are many different colorspaces which serve different purposes. ScanFix® Xpress uses the RGB (Red, Green, Blue) and HSV (Hue, Saturation, Value) colorspaces.

Comb
A comb is a set of boxes, with closed or open tops, that are used on forms, where each box is typically intended to be filled with a single character. The "teeth", or short vertical lines in the combs, are removed during the comb removal function, leaving only the contents of the boxes.

Container
The container for the component. An object implementing the IContainer interface that represents the component's container, or a null reference (Nothing in Visual Basic) if the component does not have a site.

Continuous Tone
A continuous tone image is one where all the colors in the gamut are evenly distributed, allowing blending of pixel values. Bitonal and paletted images are not considered continuous tone, but 8-bit grayscale and 24-bit color images are.

Contrast
Contrast is the difference between the darkest and the lightest valued pixels in a given region of an image. Contrast does not apply to bitonal images, which have only pure black and pure white pixels. Contrast is very important in color and gray images, because low contrast data can be difficult to read and process.

Convolution Filter
A convolution filter alters each pixel's color based on its current color and the colors of neighboring pixels within the filter window, using a matrix of values to determine the weight given to each pixel in the area. When a pixel is processed, its color value is multiplied by the coefficient in the center of the matrix, and any pixels within the window are multiplied by the corresponding coefficients in the matrix. The sum of the products, divided by the Divisor, provides the output value for the center pixel. The convolution filter is typically used for sharpening, softening, and edge enhancement.

D

DCT
A DCT, or discrete cosine transform, is a method of turning sampled data into a collection of cosine waves of varying frequencies. The DCT is most commonly used in the JPEG compression format, where it is used to convert blocks of pixels into waves, and then remove low amplitude elements that do not contribute significantly to the image. The remaining frequencies are stored, and by reversing the DCT, convert the waves back into pixel values can be used to reconstruct a visually similar image. The DCT is typically used as a lossy compression format, which yields very high compression ratios with little loss in quality of the restored image.

DCX
An image format containing multiple PCX images. A DCX file can contain a maximum of 1024 images.

DDB
Microsoft Device Dependent Bitmap. The actual in-memory information used to display an image.

DEP
Data Execution Prevention (computer security).

Depth, Color
See Color Depth.

Despeckle
A process intended to remove specks from an image. See Speck.

DIB
Microsoft Device Independent Bitmap. An alternative file extension used by the Microsoft Windows Bitmap.

DICOM
Digital Imaging and Communication, a standard for handling digital medical images.

Difference of Gaussian
See Unsharp Mask Filter.

Dilate
Dilate is an operation that "grows" objects in an image. In ScanFix® Xpress, the bitonal image processing definition is used, which means that the dilate operation makes black objects get larger, and white objects get smaller.

Dispose
Releases the resources used by the Component.

Dithering
A technique used in computer graphics to create the illusion of varying shades of gray on a monochrome display or printer, or additional colors on a color display or printer. See also Dot Shading and Halftoning.

DoG
See Unsharp Mask Filter.

Dot Shading
Dot shading refers to the use of halftoning or dithering to create an area of lighter color in a printed document. Dot shaded regions are commonly found in printed forms, and provide special difficulties in removal. ScanFix® Xpress offers a function designed specifically to remove the dots from dot shaded regions in bitonal images. For continuous tone images, a Gaussian filter will often convert dot shading into a solid color.

E

Eight-way Connected
Eight-way connected refers to a method of grouping bitonal pixels into an object. An eight-way connected object is one in which pixels that meet on the diagonals are considered connected. See also, Four-way Connected.

Erode
Erode is an operation that "shrinks" objects in an image. In ScanFix® Xpress, the bitonal image processing definition is used, which means that the erode operation makes black objects get smaller, and white objects get larger.

EXIF
Exchangeable Image File (Japan Electronic Industry Development Association, JEIDA), compressed image format used in digital cameras.

F

Float
Denotes a simple type that stores 32-bit floating-point values.

Four-way Connected
Four-way Connected refers to a method of grouping bitonal pixels into an object. A Four-way Connected object is one in which pixels that meet on the top, bottom, or sides are considered connected, but diagonals are not. See also, Eight-way Connected.

Frequency
Frequency in imaging terms refers to the rate of change in value of a line of pixels. High frequency data consists of rapidly changing brightness or colors, while low frequency data consists of gradually changing brightness or color.

G

Gamut
All possible colors representable by a given colorspace and/or bit depth.

Gaussian Filter
A Gaussian filter is a type of convolution filter that uses matrix values generated using a Gaussian curve. Gaussian filters are used to smooth an image, and provide high quality results. However, Gaussian filters tend to be slower than other filters, such as the box filter, because a larger filter window needs to be used to provide the same degree of smoothing as, for example, the box filter.

GDI
Acronym for Graphical Device Interface. In Windows, a graphics display system used by applications to display or print bitmapped text (TrueType fonts), images, and other graphical elements. The GDI is responsible for drawing dialog boxes, buttons, and other elements in a consistent style on screen by calling the appropriate screen drivers and passing them the information on the item to be drawn. The GDI also works with GDI printers, which have limited ability to prepare a page for printing. Instead, the GDI handles that task by calling the appropriate printer drivers and moving the image or document directly to the printer, rather than reformatting the image or document in PostScript or another printer language.

GIF
Graphical Interchange File, originally developed by CompuServe as a machine independent format. GIF is one of the most popular image formats for storing 8-bit digitized images. GIF files are typically smaller than uncompressed formats like BMP due to the LZW compression algorithm that GIF uses.

Grayscale or Greyscale
A format of an image that contains only brightness information, but differs from bitonal in that it contains more than 2 colors. Grayscale images supported by ScanFix® Xpress use 8 bits of brightness information, for a range of 0 (black) to 255 (white).

H

Halftone
Pertaining to pictures in which gradation of tone in the photograph is reproduced by a graduated system of dotted and checkered spots, usually nearly invisible to the unaided eye, produced by the interposition between the camera and the object of a screen. The name alludes to the fact that this process was the first that was practically successful in reproducing the half tones of the photograph. Halftoning is often used for dot shaded regions in document images, and can be difficult to remove with despeckle algorithms because the halftone dots are often connected. ScanFix® Xpress provides a special dot shading removal algorithm to handle these cases. See also Dithering, Dot Shading.

High Pass Filter
A high pass filter is a filter that preserves high frequency information, while removing low frequency information. In imaging, high pass filters are used for edge detection and sharpening. See also Low Pass Filter, Frequency.

HSV
HSV is a colorspace consisting of three components called Hue, Saturation, and Value (or Volume). This colorspace is often used by artists, because it provides an easier and more intuitive means of describing color than most other colorspaces. The HSV colorspace is also used by a number of features in ScanFix® Xpress, where the separation of hue, saturation, and value are useful. See also Hue, Saturation, and Value.

Hue
One of the 3 components of the HSV color space. The hue represents where on the color wheel a color falls. While Hue is often represented with values from 0 to 359, indicating degrees of a circle, ScanFix® Xpress uses values between 0 and 255, so that the representation will fit in one byte of data.

I

Inverse
To reverse something or change it to its opposite. For example, to invert the colors on a monochrome display means to change light to dark and dark to light. In a digital electrical signal, to replace a high level by a low level and vice versa. This type of operation is the electronic equivalent of a Boolean NOT operation.

IOD
Information Object Definition.

J

Jaggies
See Aliasing.

JIF
An alternative image file extension used for a JFIF compliant JPEG file. Because many early versions of JPEG contained a JPG extension but did not adhere to the JFIF specifications, the JIF extension was created to identify JPEG files that are JFIF compliant. As the popularity of JPEG grew, JFIF compliance became synonymous with the JPG extension and thus the JIF extension is rarely used.

JPEG
The JPEG (Joint Photographic Experts Group) standard is one of the most important image data compression standards. It is widely used in many industries including graphic arts, desktop publishing, medical imaging, and many more. It is also becoming one of the most widely used image formats on the Internet. Although JPEG supports a lossless mode, it most commonly uses lossy compression, wherein a DCT is used to eliminate less important frequencies from the image. The lossy compression allows JPEG to achieve very high compression ratios with little visual impact, though at the pixel level it can result in a significant number of artifacts in the image.

L

Laplacian Filter
The Laplacian filter is a convolution filter that works as a high pass edge detection filter, detecting edges in all directions. See also High Pass Filter, Sobel Filter, Prewitt Filter.

Lossless Compression
Lossless compression is a compression method that preserves all the data in the original, so that the reconstructed image will be exactly the same as the original image. Lossless compression is very poorly suited to dealing the noise typically found in sampled continuous tone images, so it is usually reserved for simpler data such as bitonal images. Most bitonal TIFF compression formats are lossless formats.

Lossy Compression
Lossy compression is a compression method that discards relatively unimportant data during compression, so that the reconstructed image will be very similar, but not exactly the same as the original image. Lossy compression algorithms are very common when dealing with audio, video, and image data, as they provide extremely high compression with minimal loss in perceptible quality. Formats that can or do use lossy compression include the JPEG image format, MPEG video, and MP3 audio.

Low Pass Filter
A low pass filter is a filter that preserves low frequency information, while removing high frequency information. In imaging, low pass filters are used for smoothing. See also, High Pass Filter, Frequency.

LZW
A compression algorithm named after Abraham Lempel and Jakob Ziv (creators of Lempel Ziv compression) and LZW designer Terry Welch that makes use of repeating strings of data in its compression of character streams into code streams. It is also the basis of GIF compression.

M

Median Filter
A median filter is a filter that uses the statistical median value of a window of pixels to generate the output pixel. Median filters operate in a manner similar to high pass filters, but they have the advantage of preserving sharp edges, while eliminating high contrast specks far more effectively than a comparably sized box or Gaussian filter.

Morphology
Morphology means shape or form. In imaging, morphology refers to the shape of groups of pixels, and algorithms that can alter these shapes. An example of a morphological operation is dilate, which makes black objects get larger, or deskew, which rotates the image contents.

N

Negate
Negate reverses the brightness of each pixel in an image, creating a photo negative of the original image.

Noise
Noise is any data in an image that is considered irrelevant and obscures the desirable data in the image. Noise can take many forms, but the most common forms encountered in imaging are the result of either sampling issues or artifacts of processing performed on the image. Sampling issues are caused by dust or other foreign matter on the scanned document or scanner bed, or defects inherent in the document, such as highly textured paper or shaded regions that interfere with text recognition. Artifacts may be cause when thresholding, either on the scanner or by later processing software, produces dots out of shaded regions or sampled noise, or when lossy compression methods such as that used by JPEG results in specks surrounding sharp edges in the image.

O

Object
An object is any group of connected pixels in a bitonal image; objects in ScanFix® Xpress are generated using Four-way Connection. Objects are important in many ScanFix Xpress functions, such as despeck, blob removal, line removal, and color and blank detection.

Overscan
Overscan refers to the region outside the page but within the scanned region of a document image. Overscan may be black or white.

P

Palette
A palette is an indexed list of colors used to generate an image. Palettes are typically found in non-continuous tone color images, though some image formats, such as the BMP format, do not discriminate between 8 bit continuous tone gray images and 8 bit palette color images. ScanFix® Xpress only handles a limited set of paletted images; those which contain only black and white, and those which contain only 256 shades of gray.

PBM
Portable bitmap image format, a very simple uncompressed 1-bit (black and white) image format. Data can be stored in either binary or ASCII format.

PCX
The PCX image format was originally developed by ZSoft for PC Paintbrush. A version of PC Paintbrush called Microsoft Paintbrush is bundled with Microsoft Windows which established the importance of PCX support. The PCX format uses an RLE encoding scheme which attempts to reduce the size of the image, however, detailed images may result in negative compression which means the file size may be actually be larger after compression.

PGM
Portable Gray Map image format. PGM is a very simple uncompressed 8-bit grayscale image format. Data can be stored in either binary or ASCII format.

Pixel
A pixel, short for "picture element", is a single sampled value from a digital image. Document images are typically sampled at a resolution of between 100 and 300 pixels per inch (PPI).

PNG
Portable Network Graphics (pronounced "ping") provides a portable, legally unencumbered (royalty-free), well-compressed, well-specified standard for lossless bitmapped image files. The initial motivation for developing PNG was to provide a royalty-free alternative to GIF. The design retains many of the features of GIF that make it an attractive format for transmission of images, such as lossless compression and progressive display capabilities. Additionally, it provides several advantages including 24-bit image support and generally better compression, although decompression is typically somewhat slower than GIF. PNG's success will be ultimately determined by its acceptability on the Internet. At the time of this writing, however, PNG has not been incorporated as part of the major Internet browsers.

PPM
Portable Pixmap image format, a very simple uncompressed 24-bit image format. Data is stored in RGB triplets and can be stored in either binary or ASCII format.

Prewitt Filter
The Prewitt filter is a convolution filter used for detecting horizontal or vertical edges. Pixels corresponding to an appropriate edge will show as bright values in the output image, while non-edge pixels will show as dark. The Prewitt filter provides a strong response to horizontal or vertical lines, but less response to diagonals. See also, Sobel Filter, Laplacian Filter.

R

Resolution
The resolution of a digital image is the rate at which the original was sample, and in document images is expressed in terms of the number of pixels per unit of measure, typically pixels per inch (PPI). Document images are typically scanned at resolutions between 100 and 300 PPI.

RGB
Red, Green Blue. Bitmapped images are most generally stored as RGB data. Each pixel or data point in a true color (24-bit) image contains 3 components, red, green and blue, that describe the color of the pixel. Each of the components can have a value between 0 and 255, 0 being the darkest shade of color and 255 being the lightest shade of color. Since each component can be stored in one byte (8-bits), the 3 components take up 3 bytes or 24-bits per pixel.

RLE
RLE stands for Run Length Encoding. It is a lossless compression algorithm that only offers decent compression ratios in specific types of data, typically bitonal or continuous tone images with large regions of flat color.

S

Sampling
Sampling is the process of measuring values at certain intervals to generate a digital reproduction of an item. Images are sampled by breaking the image down into a rectangular grid of pixels, then measuring the color or brightness of each pixel.

Saturation
One of the 3 components of the HSV colorspace. Saturation controls the purity of a color. Higher saturations result in richer, deeper colors. Lower saturations add gray, resulting in paler colors. Saturation is expressed as a value from 0 to 255.

Sharpen
Sharpening is the use of a high pass filter to emphasize the high frequency elements of an image. Sharpening and smoothing are opposite operations, and most sharpening filters are created by subtracting a smoothing filter from a no-change filter. See also, Unsharp Mask Filter, High Pass Filter.

Size of an Image

The term "size" can refer to many things when applied to a digital image. These include:

  • Pixel size. This is the number of pixels in the image, either as a width times height, or as a total pixel count in megapixels. This size may be change by cropping or rescaling the image.
  • File size. This is the number of bytes of storage required by the image. This size can be greatly reduced by the use of compression and noise removal, or by reducing the color depth.
  • Print size. This is the size of the original document if printed at "actual size". This unit is obtained by by multiplying the pixel size by the resolution, and may be changed by altering the pixel size or the resolution.

Smooth
Smoothing is the process of de-emphasizing sharp, high contrast edges in the image, typically by using a low pass filter. Smoothing algorithms are often used to remove noise in continuous tone images. See also Sharpen.

Sobel Filter
The Sobel filter is a convolution filter used for detecting horizontal or vertical edges. Pixels corresponding to an appropriate edge will show as bright values in the output image, while non-edge pixels will show as dark. The Sobel filter provides a stronger response to diagonals than the similar Prewitt filter. See also, Prewitt Filter, Laplacian Filter.

Speck
A speck is small group of pixels that appear as high contrast noise. In bitonal images, specks usually appear is one or more black pixels, while in continuous tone images they may appear as any color that contrasts with the background. For bitonal images, specks may be removed by the Despeckle or dot shading removal algorithms, and for continuous tone images, a smoothing or median filter can be used.

T

TGA
Targa Image File format was developed by TrueVision for its Targa line of products. TGA is one of the earliest image formats and was the first popular format to support 24-bit color. TGA supports uncompressed and RLE compressed formats.

TIFF
Tag Image File Format, originally released by Aldus Corporation is a standard file format found in most paint, imaging, and desktop publishing programs. TIFF is extremely powerful, flexible, and extensible. However, because of its many nuances and its wide scope, TIFF can be a difficult format to understand as well as a difficult format to support.

U

Unsharp Mask Filter
The unsharp mask filter, also called the difference of Gaussian or DoG filter, is a type of convolution filter used for sharpening an image. The unsharp mask gets its backwards sounding name from the fact that it takes a Gaussian filtered version of the image and takes the difference between it and the original image to de-emphasize the low frequency components, and thus emphasize the high frequency components of the image.

V

Value/Volume
The brightness of a pixel in the HSV colorspace.

W

WMF
The Microsoft Windows Metafile format is used to store vector and bitmap image data. Because of its popularity and wide use, many Windows and non-Windows applications support WMF.


How To

Accusoft.ScanFixXpress8.Net
How To
ScanFix Xpress 8 for .Net - User Guide > How To

The How To section provides information on:

  • Solve Problems with ScanFix Xpress
    • My Content isn't Straight
    • I Need My Images to Line Up
    • I Need to Remove Noise from My Image
    • My Image has Dark Borders Around It
    • I Need My Images to be a Consistent Size
    • My Characters are Faint, Broken, or Ragged
    • I Need to Remove Lines & Hole Punches
    • My Image has Regions of White on Black Text
    • I Need to Get Data from a Specific Area on a Form
    • My Color & Gray Images are too Light or Dark
    • I Have Forms Scanned in Color & Need to Remove Some Colors or Data
    • I Need to Find Which of My Images Have Color Data
    • I Need to Convert a Gray Image to Bitonal
    • I Need to Convert a Color Image to Bitonal
    • My Images are Scanned Sideways, Backwards, or Upside Down
    • My Images Need to be Larger or Smaller
    • I Need to Determine Which Images or Regions Have Data
  • Use a Series of Cleanup Operations
  • Save Enhancements Objects
  • Import and Export Images
    • Import Image Data to ScanFix Xpress
    • Export an Image Data from ScanFix Xpress
  • Pass Image Data Between Different Accusoft Components
  • Error Codes


Solve Problems with ScanFix Xpress

Accusoft.ScanFixXpress8.Net
Solve Problems with ScanFix Xpress
ScanFix Xpress 8 for .Net - User Guide > How To > Solve Problems with ScanFix Xpress

Solve Problems with ScanFix Xpress provides you with solutions for the following situations:

  • My Content isn't Straight
  • I Need My Images to Line Up
  • I Need to Remove Noise from My Image
  • My Image has Dark Borders Around It
  • I Need My Images to be a Consistent Size
  • My Characters are Faint, Broken, or Ragged
  • I Need to Remove Lines & Hole Punches
  • My Image has Regions of White on Black Text
  • I Need to Get Data from a Specific Area on a Form
  • My Color & Gray Images are too Light or Dark
  • I Have Forms Scanned in Color & Need to Remove Some Colors or Data
  • I Need to Find Which of My Images Have Color Data
  • I Need to Convert a Gray Image to Bitonal
  • I Need to Convert a Color Image to Bitonal
  • My Images are Scanned Sideways, Backwards, or Upside Down
  • My Images Need to be Larger or Smaller
  • I Need to Determine Which Images or Regions Have Data


My Content isn't Straight

Accusoft.ScanFixXpress8.Net
My Content isn't Straight
ScanFix Xpress 8 for .Net - User Guide > How To > Solve Problems with ScanFix Xpress > My Content isn't Straight

Deskew

The ScanFix® Xpress Deskew method examines the current image to determine how straight the content is, and if it is not straight, it will rotate the image to make it straight. The detection process looks for groups of pixels on the image, such as lines and text that appear to be grouped horizontally or vertically. By measuring how much the image would need to be shifted to make these groups horizontal or vertical, the process can determine how much rotation the image has, and therefore how much the image will need to be rotated to become straight.

A number of likely areas are analyzed before the process makes a decision, and the degree to which these different areas agree provides a confidence value that tells you how likely the result is to be correct. This tool is best suited for images that have items like text and horizontal and vertical lines; it does not work well on images such as photographs and line drawings that contain lines with many different angles.

Example of Deskew:

<BR>

Border Removal

BorderRemovalOptions has an option to deskew an image as well, but rather than examining the contents of the image, it looks for the edge of the document in the image, and straightens the image based on that edge. Remove Border works only on images that have a dark overscan-like border, as shown, but it will detect the skew no matter what is within the document, including photographs, line drawings, or even a blank page.

Example of Border Removal:

<BR>


I Need My Images to Line Up

Accusoft.ScanFixXpress8.Net
I Need My Images to Line Up
ScanFix Xpress 8 for .Net - User Guide > How To > Solve Problems with ScanFix Xpress > I Need My Images to Line Up

Registration

The RegisterImage method is a tool that looks at the contents of an image, and shifts the content to create a specified margin. The Registration operation looks for significant features starting from the left and top edges, and moves those features to a specified distance from the top and left edges of the page. All image content is shifted by this operation. The features can be the start of the data, or a line parallel to the image edge. Registration only looks at the left and top edges, and is intended to work on images where the background and any overscan are the same color as the document.

It also functions best on straight images, so it may be necessary to run deskew on the images before registering them. If you want to have all your documents the same size, such as 8.5 by 11 inches, then after you run registration you can use Get Rectangle to get an 8.5 by 11 inch rectangle from the image; any excess will be cut off, and any place where the rectangle goes outside the image bounds will be filled with the fill color.

While Registration only works from the upper left corner, if you need to have consistent margins on all sides of your page, you can rotate the image 180 degrees, run registration a second time, and rotate it back 180 degrees after processing. This will register the top left and bottom right corners, thus setting all four margins.

Example of Register Image:

<BR>

Border Removal

The RemoveBorder method can be used on images with a dark overscan outside the image bounds. By using the DeskewBorder and CropBorder options in BorderRemovalOptions, the image will be straightened, and all of the border area removed, leaving just the original page. If all your pages contain consistently positioned data within the page, this will be sufficient. If the data within the page is not correct, then registration can be used on the resulting image to further align the data.

Example of Remove Border:

<BR>


I Need to Remove Noise from My Image

Accusoft.ScanFixXpress8.Net
I Need to Remove Noise from My Image
ScanFix Xpress 8 for .Net - User Guide > How To > Solve Problems with ScanFix Xpress > I Need to Remove Noise from My Image

Despeckle

The Despeckle method is used to remove small groups of pixels, called specks, from the image. Specks are removed by examining each group of 4-way connected pixels and removing any group below the selected size threshold. Despeckle works only on bitonal images, and is designed to remove randomly distributed specks from the image.

Example of Despeckle:

<BR>

AutoDespeckle

AutoDespeckle works only on bitonal images. This operation automatically detects and removes small groups of black pixels, called specks, that may have been introduced into the image from dust on the scanner or through the binarization process. You do not require to specify the size of the specks in this process.

When the resolution of the input images vary from image to image, the typical speck size in pixels can vary as well.

  • If you expect to have a diverse set of images and can't set the speck size for each image, then use AutoDespeckle.
  • If you know the resolution of every image and the font size of characters on the images, then use Despeckle and specify the maximum spec height and width.

Example of AutoDespeckle

<BR>

Auto Smooth Background

AutoSmoothBackground works only on color and grayscale images. This operation smoothes background colors to eliminate or de-emphasize noise that may have originated from dust on scanners or artifacts introduced from the scanning process. It leaves text and other prominent foreground features alone, not modifying their pixels.

Example of AutoSmoothBackground - before & after

<BR>

<BR>

Dot Shading Removal

The RemoveDotShading method is designed to remove shaded regions from bitonal images. These regions may be caused by halftone printing, or by halftone or dither patterns applied during thresholding. Shaded regions include groups of regularly spaced dots, typically larger than random specks. Remove Dot Shading uses several parameters to define regions where shading might occur. Remove Dot Shading will only work on these large regions; Despeckle should be used when dealing with randomly located specks.

Example of Remove Dot Shading:

<BR>

Auto Image Detergent

AutoImageDetergent and ImageDetergent colorspace-based filtering methods work only on color images. Image Detergent works by changing pixels of similar color values to a central color value, which has the result of smoothing the image wherever regions of those colors appear. Since it works based on color value rather than location, Image Detergent is very effective at smoothing out text in high contrast regions without blurring or otherwise distorting the characters.

JPEG compression artifacts around characters can be removed with this operation. This operation can be run prior to Binarization for improved file compression, reduced bitonal noise and better OCR results. The example below shows the results of Image Detergent smoothing the white, black and orange colors of the image.

Example of Image Detergent:

<BR>

Gaussian, Average, & Median Filters

Smooth continuous tone images using Gaussian, average, and median filters. ScanFix® Xpress provides a number of filters that are designed for smoothing and removing noise in color and gray images, each of which has different strengths and weaknesses. The image below has a number of features that will show the strengths and weaknesses of each filtering method.

Example of an Image Before Filters are Applied:

<BR>

The simplest noise removal filter is the ApplyAverageFilter, which controls an average, or box filter. This filter examines a “window” of a given size around each pixel, and replaces the pixel with the average of the pixels in the region. This filter is very fast and provides a large degree of smoothing, but the use of a rectangular window tends to produce sharp edged artifacts in the output image.

Example of Apply Average Filter:

<BR>

The ApplyGaussianFilter method works similarly, but uses a Gaussian bell-shaped curve to produce a weighted average, with pixels near the center of the window contributing more to the final average than pixels near the edge of the window. This eliminates the artifacting seen with the average filter, but a Gaussian filter requires a larger window size to produce the same degree of smoothing as the box filter, meaning it runs slower.

Example of Apply Gaussian Filter:

<BR>

The ApplyMedianFilter method also works using a window, but rather than averaging the pixel values in the window, it sorts the pixels by brightness and takes the middle value. What this means in practice is that while the Average and Gaussian filters blur sharp edges, the Median filter keeps them sharp, while very effectively filling in small specks of darker or lighter color. The disadvantages of the Median filter are speed, since each pixel to be filtered requires sorting a window-sized list of values, and its tendency to remove thin lines and round off corners. A Median filter must be used very carefully with text, because it can easily filter out portions of characters.

Example of Apply Median Filter:

<BR>

All of these filters work well on photographic images, with the Median filter generally producing the best results if there are no fine details that it will remove. All of these can be used on high resolution images with text, but they all risk blurring or removing text along with the undesirable noise. Image Detergent is generally the best choice for removing noise around text, when it can be applied.


My Image has Dark Borders Around It

Accusoft.ScanFixXpress8.Net
My Image has Dark Borders Around It
ScanFix Xpress 8 for .Net - User Guide > How To > Solve Problems with ScanFix Xpress > My Image has Dark Borders Around It

Border Removal Options

BorderRemovalOptions has a number of options for removing dark borders from an image, such as those caused by overscan on a dark background. The options for removal include removing the border by reducing the image size, cutting off the dark areas, or replacing the border with white, leaving the image size the same. If your border is irregular, such as a folded corner, below, then a combination of the two options may be desirable.

Example of Border Removal:

<BR>

Other Options

With pages that are not straight, such as shown above, removing the border will not work well, as CropBorder only cuts along horizontal and vertical lines. While replacing the border would bleach this remainder out, in almost all cases it is desirable to turn on the DeskewBorder operation as well, which will attempt to detect the amount of rotation by looking at the edges of the border, and straighten the image to provide a better crop.

CropBorder does not require deskew, as it handles edges that are irregular or at an angle, but using deskew at this point may be a better option than a separate deskew operation; first, because doing the two operations at once is usually faster, and second, because the existence of a document edge allows skew detection to work even if there is little or no content usable by the standard skew detection within the page. All three options can be used together, which will straighten the image, cut off the dark border, and bleach out any remaining dark data along the edges.


I Need My Images to be a Consistent Size

Accusoft.ScanFixXpress8.Net
I Need My Images to be a Consistent Size
ScanFix Xpress 8 for .Net - User Guide > How To > Solve Problems with ScanFix Xpress > I Need My Images to be a Consistent Size

Often documents you are trying to process will have different sizes. The Deskew process, for example, generally enlarges the size of the image to make room for the corners of the original, which may contain information that would be lost if the image were clipped back to its original size. If your documents use a consistent paper size, and have a black overscanned border, then the remove border tool may be the best choice; see the topic My Image has Dark Borders Around It for information on removing these borders.

In other cases, images may be generated from documents of differing sizes, or may have a white overscan that prevents border removal from being used. In this case, the solution is to process the images in two steps:

  1. Use RegisterImage to align the upper left corner of the image in the desired location. For example, if you want the documents to have one-inch margins, then set the resultant margin to 1 times the image resolution. (Set the margin to "300" pixels when processing images with a 300 dpi resolution.)

    Example of Register Image:
  2. Use GetRectangle to generate an image of the desired size. If the original document is larger than the specified rectangle, any excess data will be cut off; if the document is smaller than the specified rectangle, then the extra space will be filled with the pad color.

    Example of Get Rectangle:


My Characters are Faint, Broken, or Ragged

Accusoft.ScanFixXpress8.Net
My Characters are Faint, Broken, or Ragged
ScanFix Xpress 8 for .Net - User Guide > How To > Solve Problems with ScanFix Xpress > My Characters are Faint, Broken, or Ragged

Growing Characters

Older dot matrix printers often produce text where the dots don’t quite touch enough to form solid characters. If the image resolution is high enough, it is possible to use a morphological filter to "grow" those pixels together into a solid object. The Dilate method will make dark objects get bigger. It does this by using a filter that looks at all pixels in the filter window, and choosing the darkest pixel there to put in the output image. This will grow the dots in dot matrix text together, but it also makes them bolder.

The Close filter runs the Dilate filter followed by an Erode filter of the same size, which works the opposite way, making the dark object smaller. While it seems like the Erode operation would undo the work of the Dilate operation, most objects that grew together will stay together, because they will not erode along the edges that were joined by the grow. This will produce solid characters, and then thin them back to their original thickness rather than leaving them bold.

This feature should be used carefully, and only on high resolution images, however; a large filter window or a low resolution image can result in filling in the white islands in characters, or blending adjacent characters together.

Example of Growing Characters:

<BR>

The definitions of dilate and erode are taken from bitonal image processing, where they apply to the behavior on dark pixels. These functions will behave the same way on color and gray images, dilating and eroding the dark pixels in the image. The ApplyOpenFilter and ApplyCloseFilter filters work the opposite way.

Since these filters only work on continuous tone (color or grayscale) images, their behavior is taken from the field of color image processing, where the terms dilate and erode mean the opposite.

Smooth Objects

The SmoothObjects method, which only works on bitonal images, looks at groups of pixels, and finds isolated bumps and pits in the edges of those objects, and fills them in. This is helpful for improving the appearance of text, improving OCR recognition rates and also results in a decrease in the size of the compressed file.

Example of Smooth Objects:

<BR>


I Need to Remove Lines & Hole Punches

Accusoft.ScanFixXpress8.Net
I Need to Remove Lines & Hole Punches
ScanFix Xpress 8 for .Net - User Guide > How To > Solve Problems with ScanFix Xpress > I Need to Remove Lines & Hole Punches

Lines often interfere with OCR, particularly when they cross characters. If your images are color and have lines of a different color than the data you are trying to OCR, the VirtualBulb method is typically the best approach. Virtual Bulb acts like a dropout scanner, dropping a given hue to white and all other hues to gray or black, generating a gray output from a color input image. Virtual Bulb is also capable of doing things that real dropout scanners cannot, such as drop multiple hues at once, compensate for dark ink without losing faint fill data, and even extracting a given color and converting everything else to white.

Example of Virtual Bulb:

If your images are bitonal, ScanFix® Xpress includes two different tools for removing lines with minimal damage to intersecting characters. The RemoveLines method removes horizontal and/or vertical lines of a given minimum length from bitonal images, with settings for dealing with broken lines and reconstructing characters and lines that cross the removed lines. The RemoveCombs method removes both combs and fill-in-the-box elements of forms, using spatial frequency analysis to find the "teeth" and remove them, while leaving the vertical strokes of the characters.

Example of Remove Combs:

The AutoRemoveHolePunch method automatically detects and removes hole punch marks from a bitonal image. No user parameters are required to be set.

The RemoveBlobs method can be manually configured to remove large, high density objects from a bitonal image. This includes allowing the removal of items such as punched holes and graphical logos that might interfere with other processing. You must specify the area, size, and density of the blobs to remove.

Example of Remove Blobs:

Forms processing technology can also be used to remove background form content such as lines, guide text and other graphical content. Contact Accusoft Corporation for additional information.


My Image has Regions of White on Black Text

Accusoft.ScanFixXpress8.Net
My Image has Regions of White on Black Text
ScanFix Xpress 8 for .Net - User Guide > How To > Solve Problems with ScanFix Xpress > My Image has Regions of White on Black Text

Often forms will contain guide text printed in white-on-black text, and this text might need to be OCR'd to allow a field to be identified.

The AutoCorrectInverseText method automatically finds and inverts regions of black that contain white text. This method operates on a full image and you are not required to set any parameters.

The CorrectInverseText method looks for regions of black of a specified size that appear to contain white data, and inverts these regions to generate black-on-white text.

Example of Correct Inverse Text:

<BR>


I Need to Get Data from a Specific Area on a Form

Accusoft.ScanFixXpress8.Net
I Need to Get Data from a Specific Area on a Form
ScanFix Xpress 8 for .Net - User Guide > How To > Solve Problems with ScanFix Xpress > I Need to Get Data from a Specific Area on a Form

Often, data will be needed from a specific area or areas of an image, which will be known ahead of time. The GetRectangle method will return the contents of a rectangle on the page, given an X, Y location, and a width and height in pixels. GetRectangle is not very useful, however, if the data isn't where it should be. GetRectangle is best used after either RemoveBorder or RegisterImage is used to position the image.

GetRectangle works on all supported color depths. If part of the specified rectangle falls outside of the image bounds, the out of bounds portion will be filled with the given pad color.

Example of Get Rectangle:

<BR>

Forms processing technology can also be used to extract specific regions of a form image. Contact Accusoft Corporation for additional information.


My Color & Gray Images are too Light or Dark

Accusoft.ScanFixXpress8.Net
My Color & Gray Images are too Light or Dark
ScanFix Xpress 8 for .Net - User Guide > How To > Solve Problems with ScanFix Xpress > My Color & Gray Images are too Light or Dark

Color and gray images allow more options to deal with questionable data because, unlike bitonal images, very faint or very dark data is often still salvageable. Whether working with a faint carbon copy or normal print on heat-exposed thermal paper, there is still contrast between the background and foreground. You just need to expand the contrast between the two.

Automatic Brightness and Contrast Adjustment

This functionality is targeted at document images (as opposed to photos). The process analyzes an image and automatically adjusts brightness and contrast based on the analysis, without user settings. It results in an image where contents are easier to see and forms processing accuracy and OCR accuracy are improved. This method works on grayscale and color images.

Manual Brightness and Contrast Adjustment

The AdjustBrightnessContrast method has two different modes of contrast correction, global and adaptive. Both types of correction take a minimum and maximum percentile which is used to determine the foreground and background colors. The 0th percentile, which represents the darkest pixel found, is typically a good choice for the minimum, while 50th percentile, which represents the average color of the region, is a good choice for the maximum. Setting the minimum to -1 will prevent the image from being darkened, while setting the maximum to 101 will prevent the image from being lightened.

Global Correction

Global correction automatically chooses a single correction for the entire page, while adaptive correction adapts to changing characteristics across the page. In most cases, global correction is sufficient, and will provide more consistent results.

Example of Global Correction:

<BR>

Adaptive Correction

Adaptive correction is for the worst case images, where brightness and contrast varies considerably across the page. Adaptive correction is capable of pulling extremely faint text out (even making the text on the back side of a scanned page readable in some cases), but it is also capable of making high contrast noise out of a blank scanned page. The contrast limits for adaptive correction let you choose how aggressively to increase the contrast for dark, mid-range, and light pixels.

Example of Adaptive Correction (faint text):

<BR>

Adaptive correction also works well on photographs. Set the minimum to 0 and the maximum to 100, and it will maximize the contrast across the photograph, bringing out hidden details that were lost in under- or over-exposed areas of the photograph.

Example of Adaptive Correction (under-exposed color photograph):

<BR>


I Have Forms Scanned in Color & Need to Remove Some Colors or Data

Accusoft.ScanFixXpress8.Net
I Have Forms Scanned in Color & Need to Remove Some Colors or Data
ScanFix Xpress 8 for .Net - User Guide > How To > Solve Problems with ScanFix Xpress > I Have Forms Scanned in Color & Need to Remove Some Colors or Data

Drop out forms, those designed to be scanned with a red or green bulb, are best handled by the VirtualBulb method. It works in the same basic way as a dropout scanner, converting a specific hue to white, and all other hues to black. This method necessarily produces a gray output image, but is very tolerant of minor changes in ink color, scanner brightness, and other variables.

Example of Virtual Bulb:

<BR>

Since Virtual Bulb does its work in software, it is not subject to the limitations of a dropout scanner. Virtual Bulb uses a custom generated color space that allows for complex manipulations that are not possible with a dropout scanner. This allows Virtual Bulb to selectively increase the brightness of the dropout hue, to allow multiple hues to be dropped, and to allow very narrow ranges of hue to be dropped. It even allows the dropout operation to be reversed, allowing it to extract only items of the specified hue from the image. The gray image resulting from this operation can be easily binarized for OCR or other recognition activities.

Locating Items of a Certain Color

If you need to locate items of a certain color on the page, you can do so with the following actions. The first step is to use the ColorDrop method to extract the color of the items you want to locate, dropping all else in the image to black or white, whichever contrasts most with the color you are extracting. You can then use DetectColor with appropriate settings to return a list of bounding boxes for each zone of colored data, which can be applied back to the original image with GetRectangle to extract the desired data. If the color you wish to look for is not a saturated color (such as black), then a second ColorDrop step can be added to drop the target color to a saturated color before DetectColor is run.

Example of Color Drop:

<BR>

Example of Color Detect:

<BR>

If you are looking for regions of color that might be broken, such as highlighter over text, then the ApplyOpenFilter or ApplyCloseFilter method can be used to blend the colors together just before DetectColor is run. For example, if the target colors have been converted to red on black, then a close filter would grow the red data by the given number of pixels, blending the discrete red objects together, and then shrink the red back down, leaving a solid object behind. For red on white, an open filter would be used.

Example of Apply Filter Open/Close before Detect Color:

<BR>


I Need to Find Which of My Images Have Color Data

Accusoft.ScanFixXpress8.Net
I Need to Find Which of My Images Have Color Data
ScanFix Xpress 8 for .Net - User Guide > How To > Solve Problems with ScanFix Xpress > I Need to Find Which of My Images Have Color Data

Detecting Color Data

Detecting whether or not an image scanned on a color scanner actually has color data in it seems like an easy task; if there are any pixels where red, blue, and green values do not equal each other, then the image is color. However, while this is certainly a simple approach, it is unlikely to be useful in real life situations. Variations in paper and ink, scanner calibration, dirt, stray marks and a number of other factors can result in an image that is technically color, but does not have any significant color information. Even some obvious cases of color data, such as a form printed on bright yellow paper, may be treated the same as non-color documents, if that color can be dropped without loss of information in the text.

Since the definition of a "color" document is very subjective, the DetectColor method uses a number of user-settable thresholds that separate "color" from "not color." The first of these is the saturation and brightness required for a pixel to be considered "color." Pixels darker or less saturated than the levels you choose will be ignored, and the remaining pixels will be grouped together to form objects.

Example of Color Detect:

The next step is to analyze those colored objects, and filter those by size. To be considered "color", the image will need to have a number of objects over the minimum size; this number is controlled by the sensitivity. At 100% sensitivity, a single object over the threshold will trigger a "color" response; the number needed increases with decreasing sensitivity, until thousands of objects (or an object thousands of times the minimum size, or some combination of the two) are needed for a "color" response.

In cases where it is desirable to treat an image with colored paper as a "not color" image, there is an IgnorePaperColor option that can be used. That option will detect the average hue of the image, and drop that color to white using a process similar to Virtual Bulb, but one that preserves other hues. The resulting white background image will then be processed to determine if the remaining data meets the "color" criteria.

Example of Detect Color and Ignore Paper Color:

The detect color function will return a number of parameters in addition to the yes/no value and confidence level. These parameters indicate what it found out about the image, and why it made the decision it did. These parameters will let you process a set of sample images, and choose appropriate thresholds for the different selection criteria.


I Need to Convert a Gray Image to Bitonal

Accusoft.ScanFixXpress8.Net
I Need to Convert a Gray Image to Bitonal
ScanFix Xpress 8 for .Net - User Guide > How To > Solve Problems with ScanFix Xpress > I Need to Convert a Gray Image to Bitonal

Auto Binarize

Autobinarize automatically computes all necessary parameters by analyzing the input data before actually performing the binarization. The algorithm is tuned to typical document images, consisting of dark text on brighter background. It is robust to shadows, noise and background images.

Example of Autobinarize:

Binarize

Binarization works 1-bit, 8-bit and 24-bit input images creating 1-bit output of the same dimensions. Parameter options should be selected according to the type of image and desired results. This operation modifies the color palette associated with the image and sets it to two colors, with black as color 0 and white as color 1.

Local Contrast Enhancement

The LceFactor property increases the contrast in each region of the image. When used as a prelude to binarization it increases the sensitivity of the binarization to detail in all regions of the image.

Example of original image:

Example of local contrast enhancement:

Example of local contrast enhancement and binarization:

BinarizeBlur

The BinarizeBlur enumeration can be used with the LceFactor property when the original digitization is fine enough to reveal the halftone grid on the original document. It ensures that shades of gray are interpreted as such, rather than a combination of black and white. There are three options: Gaussian, Smart and none.

Example of an image binarized with local-contrast enhancement without pre-blur:

Example of image binarized with local-contrast enhancement with Gaussian pre-blur:


I Need to Convert a Color Image to Bitonal

Accusoft.ScanFixXpress8.Net
I Need to Convert a Color Image to Bitonal
ScanFix Xpress 8 for .Net - User Guide > How To > Solve Problems with ScanFix Xpress > I Need to Convert a Color Image to Bitonal

When converting an image scanned in color to bitonal, it is often best to do this in stages, rather than all at once. Color images contain data that can be used to provide preliminary cleanup, which will produce a better bitonal image. An example of a process that might be useful in a color to bitonal conversion are:

  1. Use ImageDetergent to clean the background color, so there will be less potential for noise in the bitonal image.
  2. Use ColorDrop to drop bright colors to darker colors, so they will threshold to black, or to light colors so they will threshold to white.
  3. Use VirtualBulb to drop out forms, or to drop colored paper to white.
  4. Use AdjustBrightnessContrast to make sure all images have bright whites and dark blacks.

Once the image is converted to a more suitable form, then Binarize or AutoBinarize should be used to complete the conversion to bitonal.

Examples

The following section shows examples of images from steps 1-4 above.

Example of Image Detergent:

<BR>

Example of Color Drop:

<BR>

Example of Virtual Bulb:

<BR>

Example of Adjust Brightness Contrast:

<BR>

Example of Autobinarize:

<BR>


My Images are Scanned Sideways, Backwards, or Upside Down

Accusoft.ScanFixXpress8.Net
My Images are Scanned Sideways, Backwards, or Upside Down
ScanFix Xpress 8 for .Net - User Guide > How To > Solve Problems with ScanFix Xpress > My Images are Scanned Sideways, Backwards, or Upside Down

ScanFix® Xpress contains a number of basic image manipulation functions that can be used to flip, mirror, and rotate images to the desired orientation. The different options are:

  • AutoRotate - This operation automatically rotates document images (as opposed to photographs) to the upright, readable orientation. This method requires no user input for settings and only operates on bitonal images.
  • Rotate - This operation rotates the image any number of degrees clockwise, and can also be used to shear an image if the horizontal and vertical rotations are set to different values. Since rotation may clip corners off the original image, there is an option to maintain the original image size, which prevents this from occurring.
  • Flip - This swaps the top and bottom of the image. This is NOT the same as a 180 degree rotation, so this will change an image to its mirror image as well.
  • Mirror - This swaps the left and right sides of the image, creating a mirror image.


My Images Need to be Larger or Smaller

Accusoft.ScanFixXpress8.Net
My Images Need to be Larger or Smaller
ScanFix Xpress 8 for .Net - User Guide > How To > Solve Problems with ScanFix Xpress > My Images Need to be Larger or Smaller

While the concept of "size" in a digital image is somewhat ambiguous, most often when people want to make their images larger or smaller, they want to re-sample the images to change the number of pixels in the image. The most basic way to change the number or pixels in the image is to use the Rescale method. The rescale operation takes a horizontal and a vertical magnification amount, which are typically set to the same value to preserve the aspect ratio. Values of greater than 1.0 will make the image larger, while values of less than 1.0 will make the image smaller. To make an image 50% larger, for example, set the magnification values to 1.5; to make the image 1/3 smaller, set the magnification values to .6667.

Scaling is done differently for continuous tone and bitonal images; scaling of continuous tone images blends the colors of adjacent pixels together to get a new color for the result. This blending is not possible with bitonal images, so they must choose black or white. This limitation means that scaling bitonal images up in size tends to result in blocky images. There is a special option available for doubling the size of bitonal images, called SmoothZoom. This operation has special rules for zooming each possible 2 x 3 block of input pixels. The resulting output rounds off some of the corners which is more visually pleasing.

Sometimes, rather than resampling the image to change the scaling, the size needs to be changed by adding or removing pixels from the image without rescaling. The GetRectangle method can be used to extract just a given rectangle of data from the image, or, if provided with coordinates specifying a rectangle outside the original image, be used to add pixels of the pad color. If the image is not consistently positioned, then RemoveBorder or RegisterImage can be used to remove margins of the image. In the case of a dark border, RemoveBorder can be used to remove the black areas around the edge of the image. With white borders, RegisterImage can be used to remove the white around the data.


I Need to Determine Which Images or Regions Have Data

Accusoft.ScanFixXpress8.Net
I Need to Determine Which Images or Regions Have Data
ScanFix Xpress 8 for .Net - User Guide > How To > Solve Problems with ScanFix Xpress > I Need to Determine Which Images or Regions Have Data

DetectBlankPage and DetectBlankRectangle are similar functions that examine a given area for significant amounts of data. What is "significant" is defined in terms of object size. For example, a group of just a few pixels is probably a speck, while a group of pixels over 20 pixels in width or height is probably a deliberate mark. There is a GapFill option which runs a dilate black operation on the image during detect, which can be used to grow individual characters into word or sentence sized objects. This is useful for ignoring large noise, such as stray pencil marks, while accurately detecting data such as words.

The continuous tone detection algorithm may, in this operation, provide different results from the bitonal algorithm, even with visually identical input data. This is due to the use of a high pass filter in the continuous tone version to handle images with varying brightness and contrast. If any objects that are found exceed the minimum size, the image or region will be declared "not blank". The confidence value returned by the operation depends on the number of objects found; large numbers of objects near or over the size threshold will return a high confidence "not blank" result, while large numbers of objects just under the size threshold will return a low confidence "blank" result.

DetectBlankPage is intended for use on entire pages, and therefore its options are relative to the edges of the image. Values can be set for the margins, telling BlankPageDetect to skip over certain areas (such as hole punches that are expected in the left or right margins). BlankPageDetect also has a fast but rudimentary border detection algorithm that will skip over dark borders, so that they are not interpreted as data. Margins are relative to any detected border. If the simple algorithm used by the IgnoreBorder option is not sufficient to detect the borders of your images, then you should process the images first with the RemoveBorder method, then run DetectBlankPage on the resulting output.

DetectBlankRectangle is intended for use on portions of an image, and therefore its options are relative to a given set of rectangle coordinates. This means your images must be aligned before DetectBlankRectangle can be reliably run; refer to the topic I Need to Get Data from a Specific Area on a Form for more information. The IgnoreBorder option is available, and will run inside the given rectangle.


Use a Series of Cleanup Operations

Accusoft.ScanFixXpress8.Net
Use a Series of Cleanup Operations
ScanFix Xpress 8 for .Net - User Guide > How To > Use a Series of Cleanup Operations

The Enhancements object in ScanFix® Xpress can be used to setup, execute, save, and load a series of ScanFix Xpress cleanup operations. This mechanism can be used to develop applications that perform a fixed series of operations on one or more images. The Enhancements sample application demonstrates using the Enhancements object API.

Set Up Series of Operations

The Enhancements object holds an ordered list of “option” objects. Each option contains the operation and properties for a single ScanFix Xpress cleanup operation. Options will be performed in the order they are stored in the options list.

With most operations, the option object is the same object that holds properties for a single operation. For example, a DeskewOptions object is used for Deskew cleanup operation properties.

For methods that do not have an options object there are special objects for use with the Enhancements options list. For example, to add a Flip operation you would create a FlipOptions object (which has no properties) and add it to the Enhancements list.

In Summary:

  • Create Enhancements object.
  • For each operation:
    • Create options object.
    • Set properties in options object.
    • Add options object to Enhancements object’s options list.

Execute Series of Operations

The operations in an Enhancements options list can be applied to the image held by a ScanFix Xpress object calling the ExecuteEnhancements method. This will execute, in sequence, each option in the list.

The results from each cleanup operation will be a single results object. After successful execution, the Enhancements object will contain a list of results objects, where each results object contains results for the corresponding options list object.

If there is an error or exception during execution of any operation, then the results list will be incomplete or empty. In this case, the results list will contain results objects for each operation before the failing operation. The ScanFixException object will contain Number and Message properties for the operation that failed.

In Summary:

  1. Create and configure Enhancements object (see "Set Up Series of Operations" above).
  2. Create ScanFix Xpress object.
  3. Load image into ScanFix Xpress object.
  4. Call ScanFixObject’s ExecuteEnhancements() method and pass the configured Enhancements object.
  5. Compare Enhancements object results list size with options list size to see if all operations were completed successfully.
  6. Transfer processed image from ScanFix Xpress object.
Steps 3-6 can be repeated to process a series of images using a single Enhancements object.


Save Enhancements Objects

Accusoft.ScanFixXpress8.Net
Save Enhancements Objects
ScanFix Xpress 8 for .Net - User Guide > How To > Save Enhancements Objects

ScanFix® Xpress provides the ability to read and write a stream using the ReadFromStream and WriteToStream methods within the Enhancements object. These streaming methods are provided to work with the Accusoft Corporation FormDirector component for reading and writing ScanFix Xpress enhancement options, processing information and operations as needed to integrate into the Accusoft Corporation Forms Processing Suite of components.

The stream contains all Enhancements object operation 'Options' (which is the complete set of instructions for configuring an Enhancements object). The stream will not save any Enhancements object operation 'Results'.

WriteToStream

The WriteToStream method will create an XML stream from the current Enhancements List. When the WriteToStream method is called passing in a list of requested enhancements, ScanFix Xpress will generate an XML string containing the Enhancements list. This list can then be read in later using the ReadFromStream method in ScanFix Xpress or some other Accusoft Corporation component.

ReadFromStream

The ReadFromStream method will use the formatted XML string enhancements list prepared by the WriteToStream method. Once the XML string has been read in, ScanFix Xpress will translate the enhancement options and operations contained in the string to perform image processing.

If the XML stream is not formatted properly, ScanFix Xpress will throw the error code 14550.


Import and Export Images

Accusoft.ScanFixXpress8.Net
Import and Export Images
ScanFix Xpress 8 for .Net - User Guide > How To > Import and Export Images

Image import/export is crucial to using ScanFix Xpress, as you will need to load image data to the component prior to using any image cleanup features, and after cleanup, you may need to read the post processed data. We provide interfaces to make it really easy to accomplish these tasks.

  • Import Image Data to ScanFix Xpress
  • Export an Image Data from ScanFix Xpress


Import Image Data to ScanFix Xpress

Accusoft.ScanFixXpress8.Net
Import Image Data to ScanFix Xpress
ScanFix Xpress 8 for .Net - User Guide > How To > Import and Export Images > Import Image Data to ScanFix Xpress

FromHdib(System.IntPtr hdib), FromBitmap(System.Drawing.Bitmap bitmap), FromHbitmap(System.IntPtr hbitmap), FromImage(System.Drawing.Image image) allow you to load image data from a variety of types to ScanFix Xpress. You may use them to pass image data from either applicable Accusoft objects, or any compatible data external to Accusoft. Among these formats, Hdib is the preferred one for performance reasons.

To make it even easier for passing images between Accusoft components, an additional methods, CopyTo() and TransferTo() was added to our components, including ScanFix Xpress. It is the preferred way of handling image data for a number of reasons. See Pass Image Data Between Different Accusoft Components for details.

From Accusoft components

The following C# code demonstrates importing from Accusoft’s ImagXpress component.

C# Example
Copy Code
using Accusoft.ImagXpressSdk;
using Accusoft.ScanFixXpressSdk;
……
ScanFix scanFix1 = new ScanFix();
ImagXpress imagXpress1 = new ImagXpress();
ImageX imageX = new ImageX(imagXpress1, 50, 50, 24, Color.Red);
imageX.CopyTo(scanFix1);
OR
imageX.TransferTo(scanFix1);
OR
scanFix1.FromHdib(imageX.ToHdib(false));
OR
scanFix1.FromHbitmap(imageX.ToHbitmap(false));
OR
scanFix1.FromBitmap(imageX.ToBitmap(false));

Outside of Accusoft components

C# Example
Copy Code
System.Drawing.Bitmap bitmap = new Bitmap(@"C:\image.bmp");
scanFix1.FromBitmap(bitmap);
OR
scanFix1.FromImage(bitmap);
OR
scanFix1.FromHbitmap(bitmap.GetHbitmap());


Export an Image Data from ScanFix Xpress

Accusoft.ScanFixXpress8.Net
Export an Image Data from ScanFix Xpress
ScanFix Xpress 8 for .Net - User Guide > How To > Import and Export Images > Export an Image Data from ScanFix Xpress

Similar to imports, ToBitmap(System.Drawing.Bitmap bitmap), ToHdib(System.IntPtr hdib), ToImage(System.Drawing.Image image) allow you to output the image data to desired formats either internal or external to Accusoft components.

As an additional alternative for exporting to other Accusoft components, calling CopyTo() or TransferTo() from ScanFix Xpress are the preferred way of achieving this goal. See Pass Image Data Between Different Accusoft Components for details.

The following C# code demonstrates how to export data from ScanFix Xpress.

To Accusoft components

C# Example
Copy Code
ScanFix scanFix1 = new ScanFix();
ImagXpress imagXpress1 = new Accusoft.ImagXpressSdk.ImagXpress();
ImageX imageX;
……
// scanFix1 has some image data already at this point
scanFix1.TransferTo(imageX);
OR
scanFix1.CopyTo(imageX);
OR
imageX = ImageX.FromBitmap(imagXpress1, scanFix1.ToBitmap());
OR
imageX = ImageX.FromHdib(imagXpress1, scanFix1.ToHdib(true));

To objects outside of Accusoft

C# Example
Copy Code
// scanFix1 has some image data already at this point
System.Drawing.Bitmap bitmap = scanFix1.ToBitmap();
OR
System.Drawing.Bitmap bitmap = (Bitmap)scanFix1.ToImage();

Also see documentation for all the introduced methods by following the links.


Pass Image Data Between Different Accusoft Components

Accusoft.ScanFixXpress8.Net
Pass Image Data Between Different Accusoft Components
ScanFix Xpress 8 for .Net - User Guide > How To > Pass Image Data Between Different Accusoft Components

Traditionally, transferring image data between Accusoft components has required passing the image data in a DIB format. But, beginning with the release of ScanFix Xpress 7, new methods were added throughout our products which allow you to easily copy or transfer image data between different Accusoft objects with just a single method call.

Regardless of its product or component assembly, any Accusoft image class which supports easily sending its image data to another Accusoft object will implement two methods: CopyTo(object destination) and TransferTo(object destination). And any Accusoft image class which supports easily receiving this image data (that is, being the destination object) will be noted in its class documentation.

A CopyTo method makes a complete copy of the image data. When called, both the source and destination objects will contain their own separate copies of identical image data. A TransferTo method, on the other hand, completely transfers the image data from one object to another. When finished, the source object will no longer contain image data; the image will be owned by the destination object.

Within the ScanFix Xpress

Within the ScanFix Xpress component, there is a class which supports sending and/or receiving its image data via CopyTo and TransferTo methods. It is the ScanFix class.

Other Accusoft products may contain additional classes which can send and receive image data.

How to Transfer Image Data from One ScanFix Object to Another

You can use this new approach to easily copy or transfer image data from a ScanFix object to objects of other Accusoft components.

Here's an example for transferring between a ScanFix and an ImageX object from the ImagXpress component.

C# Example
Copy Code
using System.Drawing;
using Accusoft.ScanFixXpressSdk;

namespace ConsoleExample
{
    class Program
    {
        static void Main(string[] args)
        {
            using (ImagXpress ix = new ImagXpress())
            using (imageX ixImage = new ImageX(ix, 400, 400, 24, Color.Red))
            using (ScanFix sx = new ScanFix())
            {
                ixImage.Save("original.bmp");
                ixImage.TransferTo(sx);
                sx.AutoBinarize();
                    sx.TransferTo(ixImage);
                ixImage.Save("binarized.bmp");
            }
        }
    }
}

In the above example, we create a small, 24-bit red image object named ixImage and save its image data to disk as "original.bmp". If you open this file, you will see a small red image.

Then, we transfer its image data to the sx object, perform an automatic binarization operation using sx, transfer data back to ixImage, and then save it as "binarized.bmp". Since the image data inside the sx object was completely transferred to the ixImage object, if you open this second file you will see a binarized version of the original image.


Error Codes

Accusoft.ScanFixXpress8.Net
Error Codes
ScanFix Xpress 8 for .Net - User Guide > How To > Error Codes

This section covers .NET Framework and ScanFix® Xpress Error Codes, their descriptions, and possible causes.

.NET Framework

Error Codes | Description | Cause
14000 | Null Argument | Exception thrown when a parameter is set to null. The exception string will indicate the name of the null parameter.
14001 | Argument Out of Range | This exception is thrown when a parameter is outside the acceptable range. The exception string will indicate the name of the parameter that was out of range.
14002 | Invalid Operation | This exception is thrown when an invalid operation is attempted. The exception string will indicate the name of the operation.
14003 | Invalid Enumeration Argument | This exception is thrown when an enumeration is set to an invalid value. The exception string will indicate the name of the enumeration.
14004 | Out of Memory | This exception is thrown when the system does not have enough memory to perform the requested operation.
14100 | Unsupported Image | This exception is thrown when trying to process an image that is unsupported.

ScanFix Xpress

Error Codes | Error Type | Cause
14150 | Parameter Mismatch | This error can occur during a call to GetRectangle if the height and width are not greater than zero or padding is attempted when not allowed. It may be followed by one of these error strings: "Width and height must both be greater than zero, re-check parameters." "Padding not permitted, re-check parameters."
14151 | Parameter Mismatch | This error can occur during a call to Dilate or Erode if the Direction and OnlyDiagonal properties are set to conflicting values. If OnlyDiagonal is set to true, Direction must be set to exactly two adjacent directions. It may be followed by this error string: "options.direction indicates an invalid direction for diagonal only operation."
14200 | HANDLE Error | This error can occur during a call to any of the enhancement methods if the image handle is in use. It may be followed by this string: "Image is locked and cannot be modified."
14201 | HANDLE Error | This error can occur during the DIB conversion process and may be followed by this string: "Could not retrieve data from handle."
14300 | Internal Error | This is an internal error and may be followed by this string: "Failure loading ScanFix operation code."
14301 | Internal Error | This is an internal error and may be followed by a string such as: "... internal initialization exception." "... internal execution exception." "... internal termination exception."
14500 | Licensing Error | This error will occur when attempting to perform a function that is not allowed under the current license and may be followed by this string: "The component is not licensed to perform this function.
14550 | Read from Stream Error | This error will occur when attempting to read from a stream and that stream is not formatted properly. This message will display: "An error occurred while reading the stream input in.... "
14551 | Write to Stream Error | This error will occur when attempting to write to a stream. This message will display: "An error occurred while writing the stream output in.... "
14898 | Miscellaneous Error | This is a miscellaneous error that can occur and may be followed by a string such as: "An unexpected error occurred in ..." "Provided handle was not an HBITMAP." "Unable to get object information." "Could not create context for converting to HBITMAP"
14900 | Application-level Error | This is an operating system error that can occur when accessing Microsoft objects.


Accusoft.ScanFixXpress8.Net Assembly

Accusoft.ScanFixXpress8.Net
Accusoft.ScanFixXpress8.Net Assembly
Namespaces
Namespace | Description
Accusoft.ScanFixXpressSdk |


ScanFix Xpress 8 for .Net - API Reference

Accusoft.ScanFixXpress8.Net
ScanFix Xpress 8 for .Net - API Reference

The API Reference provides information on the namespace and its members.

  • Accusoft.ScanFixXpressSdk Namespace


Accusoft.ScanFixXpressSdk Namespace

Accusoft.ScanFixXpress8.Net
Accusoft.ScanFixXpressSdk Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | AutoBinarizeOptions | Defines a place holder class for the ScanFix.AutoBinarize image enhancement. This class does not contain any parameters that can be set. An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Class | AutoBinarizeResults | Defines a place holder class for the AutoBinarize enhancement result.
Class | AutoBrightnessContrastOptions | Defines a place holder class for the ScanFix.AutoAdjustBrightnessContrast image enhancement. This class does not contain any parameters that can be set.
Class | AutoBrightnessContrastResults | Defines a place holder class for the AutoAdjustBrightnessContrast enhancement result.
Class | AutoDespeckleOptions | Defines a place holder class for the ScanFix.AutoDespeckle image enhancement. This class does not contain any parameters that can be set.
Class | AutoDespeckleResults | Contains information generated during the ScanFix.AutoDespeckle enhancement.
Class | AutoImageDetergentOptions | Contains parameters that control the ScanFix.AutoImageDetergent process.
Class | AutoInverseTextOptions | Defines a place holder class for the AutoCorrectInverseText image enhancement. This class does not contain any parameters that can be set. An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Class | AutoInverseTextResults | Contains information generanted during the ScanFix.AutoCorrectInverseText enhancement.
Class | AutoRemoveHolePunchOptions | Defines a place holder class that controls options for the ScanFix.AutoRemoveHolePunch image enhancement. This class does not contain parameters that can be set. An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Class | AutoRemoveHolePunchResults | Contains information generated during the ScanFix.AutoRemoveHolePunch enhancement.
Class | AutoRotateOptions | Defines a placeholder class the controls the options for the ScanFix.AutoRotate process. This class does not contain any parameters that can be set.
Class | AutoRotateResults | Contains information generated during the ScanFix.AutoRotate enhancement.
Class | AutoSmoothBackgroundOptions | Defines a placeholder class that controls options for the ScanFix.AutoSmoothBackground process. This class does not contain any parameters that can be set.
Class | AutoSmoothBackgroundResults | Defines a place holder class for the AutoAdjustBrightnessContrast enhancement result.
Class | BinarizeOptions | Contains parameters for the ScanFix.Binarize process.
Class | BinarizeResults | Defines a place holder class for the Binarize enhancement result.
Class | BlankPageDetectOptions | Contains parameters for the ScanFix.DetectBlankPage process.
Class | BlankPageDetectResults | Contains output values from the blank page detect process.
Class | BlankRectangleDetectOptions | Contains parameters for the ScanFix.DetectBlankRectangle process.
Class | BlankRectangleDetectResults | Contains output values from the blank rectangle detect process.
Class | BlobRemovalOptions | Contains parameters that control the ScanFix.RemoveBlobs process.
Class | BlobRemovalResults | Contains output values from the blob removal process.
Class | BorderRemovalOptions | Contains parameters that control the ScanFix.RemoveBorder process.
Class | BorderRemovalResults | Contains output values from the border removal process.
Class | BrightnessContrastOptions | Contains parameters for the ScanFix.AdjustBrightnessContrast process.
Class | BrightnessContrastResults | Contains the output values from the contrast adjustment process.
Class | ColorDropOptions | Contains parameters for the ScanFix.ColorDrop process.
Class | ColorDropResults | Defines a place holder class for the ColorDrop enhancement result.
Class | ColorRadius | Lists a range of colors used by ImageDetergent and ColorDrop operations.
Class | CombRemovalOptions | Contains parameters that control the ScanFix.RemoveCombs process.
Class | CombRemovalResults | Contains output values from the comb removal process.
Class | DeskewOptions | Contains parameters for the ScanFix.Deskew process.
Class | DeskewResults | Contains output values from the deskew process.
Class | DespeckleOptions | Contains parameters for the ScanFix.Despeckle process.
Class | DespeckleResults | Contains output values from the despeckle process.
Class | DetectColorOptions | Contains parameters for the ScanFix.DetectColor process.
Class | DetectColorResults | Contains output values from the DetectColor process.
Class | DilateOptions | Contains parameters for the ScanFix.Dilate process.
Class | DilateResults | Defines a place holder class for the Dilate enhancement result.
Class | DotShadingRemovalOptions | Contains parameters that control the ScanFix.RemoveDotShading enhancement process.
Class | DotShadingRemovalResults | Contains output values from the dot shading removal process.
Class | EnhancementOption | Contains options that control the enhancment options. This is the base class for all Enhancement option classes.
Class | EnhancementOptionsCollection | Implements a list which will only accept enhancement options used with the ScanFix component
Class | EnhancementResult | Base class for all Enhancement result classes
Class | EnhancementResultsCollection | Implements a list which will only accept enhancement options used with the ScanFix component
Class | Enhancements | Holds a list of enhancement options which can be performed on an image. It provides functionality to read and write an XML formated string to load and save the state of the enhancements.
Class | ErodeOptions | Contains parameters for the ScanFix.Erode process.
Class | ErodeResults | Defines a place holder class for the Erode enhancement result.
Class | FilterAverageOptions | Contains parameters for the ScanFix.ApplyAverageFilter filter process.
Class | FilterCloseOptions | Contains parameters for the ScanFix.ApplyCloseFilter filter process.
Class | FilterCustomOptions | Contains parameters for the ScanFix.ApplyCustomFilter filter process.
Class | FilterGaussianOptions | Contains parameters for the ScanFix.ApplyGaussianFilter filter process.
Class | FilterLaplacianOptions | Defines a place holder class for options that control the ScanFix.ApplyLaplacianFilter filter process. This class does not contain any parameters that can be set.
Class | FilterMedianOptions | Contains parameters for the ScanFix.ApplyMedianFilter filter process.
Class | FilterOpenOptions | Contains parameters for the ScanFix.ApplyOpenFilter filter process.
Class | FilterPrewittOptions | Contains parameters for the ScanFix.ApplyPrewittFilter filter process.
Class | FilterResults | Defines a place holder class for the Filter enhancement result.
Class | FilterSobelOptions | Contains parameters for the ScanFix.ApplySobelFilter filter process.
Class | FilterUnsharpOptions | Contains parameters for the ScanFix.ApplyUnsharpFilter filter process.
Class | FlipOptions | Defines a place holder class for the Flip image enhancement operation. This class does not contain any parameters for the ScanFix.Flip operation.
Class | FlipResults | Defines a place holder class for the Flip enhancement result.
Class | GetRectangleOptions | Contains parameters that control the ScanFix.GetRectangle process.
Class | GetRectangleResults | Defines a place holder class for the GetRectangle enhancement result.
Class | GraphicLine | Contains graphic line detection data along with line information such as start and end points, line style, width, and line orientation.
Class | GraphicLineDetectionOptions | Contains parameters that control the ScanFix.DetectGraphicLines process.
Class | GraphicLineDetectionResults | Contains output values from the ScanFix.DetectGraphicLines method.
Class | GraphicLineRemovalOptions | Contains parameters for the ScanFix.RemoveGraphicLines process.
Class | GraphicLineRemovalResults | Contains output values from the ScanFix.RemoveGraphicLines method.
Class | HueRadius | Lists a range of Hues used by VirtualBulb.
Class | ImageDetergentOptions | Contains parameters that control the ScanFix.ImageDetergent process.
Class | ImageDetergentResults | Defines a place holder class for the ImageDetergent enhancement result.
Class | ImageRegistrationOptions | Contains parameters that control the ScanFix.RegisterImage process.
Class | ImageRegistrationResults | Contains output values from the image registration process.
Class | InverseTextOptions | Contains parameters for the ScanFix.CorrectInverseText process.
Class | InverseTextResults | Contains output values from the inverse text removal process.
Class | Licensing | Validates and manages the license for the ScanFix Xpress SDK.
Class | LineRemovalOptions | Contains parameters that control the ScanFix.RemoveLines process.
Class | LineRemovalResults | Contains output values from the line removal process.
Class | MirrorOptions | Defines a place holder class for the Mirror image enhancement. This class does not contain any parameters to control the ScanFix.Mirror process.
Class | MirrorResults | Defines a place holder class for the Mirror enhancement result.
Class | NegateOptions | Defines a place holder class for the Negate image enhancement. This class does not contain any parameters to control the ScanFix.Negate process.
Class | NegateResults | Defines a place holder class for the Negate enhancement result.
Class | NegativeCorrectionOptions | Contains parameters for the ScanFix.CorrectNegativePage process.
Class | NegativeCorrectionResults | Contains output values from the negative correction process.
Class | PerspectiveAdjustOptions | Contains parameters for the ScanFix.PerspectiveAdjust process.
Class | PerspectiveAdjustResults | Contains output values obtained from the PerspectiveAdjust enhancement process.
Class | RescaleOptions | Contains parameters that control the ScanFix.Rescale process.
Class | RescaleResults | Defines a place holder class for the Rescale enhancement result.
Class | Resolution | Manages the resolution of the current image in the ScanFix object.
Class | RotateOptions | Contains parameters that control the ScanFix.Rotate process.
Class | RotateResults | Defines a place holder class for the Rotate enhancement result.
Class | ScanFix | Implements the image processing operations for the ScanFixXpress SDK. This is the main component object class for ScanFix. Instances of this class can be used as the destination of Accusoft's standard methods for passing images between different components: CopyTo(object destination) and TransferTo(object destination).
Class | ScanFixException | Provides a base class that handles all the exceptions generated by ScanFix Xpress.
Class | ScanFixUnsupportedImageException | Handles exceptions in the case an image is not supported by ScanFix.
Class | ShearOptions | Contains parameters that control the ScanFix.Shear enhancement process.
Class | ShearResults | Defines a place holder class for the Shear enhancement result.
Class | SmoothObjectsOptions | Contains parameters that control the ScanFix.SmoothObjects enhancement operation.
Class | SmoothObjectsResults | Defines a place holder class for the SmoothObjects enhancement result.
Class | SmoothZoomOptions | Defines a place holder class for options that control the ScanFix.SmoothZoom image enhancement. This class does not contain any parameters that can be set.
Class | SmoothZoomResults | Defines a place holder class for the SmoothZoom enhancement result.
Class | VirtualBulbOptions | Contains parameters that control the ScanFix.VirtualBulb process.
Class | VirtualBulbResults | Defines a place holder class for the VirtualBulb enhancement result.
Enumerations
 | Enumeration | Description
Enumeration | AutomaticMode | Modes for automatic ImageDetergent operation
Enumeration | BinarizeBlur | Binarize Blur is used to set the pre-blur option of the Binarize feature.
Enumeration | BrightnessContrastAdjustment | AdjustBrightnessContrast Adjustment specification values
Enumeration | BrightnessContrastSuggestion | BrightnessContrast adjustment suggestion values
Enumeration | ColorFindings | Values for collection of findings returned by DetectColor
Enumeration | EnhancementDirections | Erode and Dilate direction flag values
Enumeration | ErrorLevel | Error level defines the amount of error information in the debug log.
Enumeration | EvaluationChoice | Choices for control behavior when licensed for trial use
Enumeration | FilterDirection | Direction options for filter
Enumeration | GraphicLineOrientation | Values for the orientation of lines that are detected.
See Also

Reference

Accusoft.ScanFixXpress8.Net Assembly


Accusoft.ScanFixXpressSdk Namespace Inheritance Hierarchy

Accusoft.ScanFixXpress8.Net
Accusoft.ScanFixXpressSdk Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Accusoft.ScanFixXpressSdk.ColorRadius
Accusoft.ScanFixXpressSdk.EnhancementOption
A.c0d658c977a82bf9a2ddf9da96892d262
A.c367a47b5c5677745cab308863e6bd23c
Accusoft.ScanFixXpressSdk.AutoBinarizeOptions
Accusoft.ScanFixXpressSdk.AutoBrightnessContrastOptions
Accusoft.ScanFixXpressSdk.AutoDespeckleOptions
Accusoft.ScanFixXpressSdk.AutoImageDetergentOptions
Accusoft.ScanFixXpressSdk.AutoInverseTextOptions
Accusoft.ScanFixXpressSdk.AutoRemoveHolePunchOptions
Accusoft.ScanFixXpressSdk.AutoRotateOptions
Accusoft.ScanFixXpressSdk.AutoSmoothBackgroundOptions
Accusoft.ScanFixXpressSdk.BinarizeOptions
Accusoft.ScanFixXpressSdk.BlankPageDetectOptions
Accusoft.ScanFixXpressSdk.BlankRectangleDetectOptions
Accusoft.ScanFixXpressSdk.BlobRemovalOptions
Accusoft.ScanFixXpressSdk.BorderRemovalOptions
Accusoft.ScanFixXpressSdk.BrightnessContrastOptions
Accusoft.ScanFixXpressSdk.ColorDropOptions
Accusoft.ScanFixXpressSdk.CombRemovalOptions
Accusoft.ScanFixXpressSdk.DeskewOptions
Accusoft.ScanFixXpressSdk.DespeckleOptions
Accusoft.ScanFixXpressSdk.DetectColorOptions
Accusoft.ScanFixXpressSdk.DilateOptions
Accusoft.ScanFixXpressSdk.DotShadingRemovalOptions
Accusoft.ScanFixXpressSdk.ErodeOptions
Accusoft.ScanFixXpressSdk.FilterAverageOptions
Accusoft.ScanFixXpressSdk.FilterCloseOptions
Accusoft.ScanFixXpressSdk.FilterCustomOptions
Accusoft.ScanFixXpressSdk.FilterGaussianOptions
Accusoft.ScanFixXpressSdk.FilterLaplacianOptions
Accusoft.ScanFixXpressSdk.FilterMedianOptions
Accusoft.ScanFixXpressSdk.FilterOpenOptions
Accusoft.ScanFixXpressSdk.FilterPrewittOptions
Accusoft.ScanFixXpressSdk.FilterSobelOptions
Accusoft.ScanFixXpressSdk.FilterUnsharpOptions
Accusoft.ScanFixXpressSdk.FlipOptions
Accusoft.ScanFixXpressSdk.GetRectangleOptions
Accusoft.ScanFixXpressSdk.GraphicLineDetectionOptions
Accusoft.ScanFixXpressSdk.GraphicLineRemovalOptions
Accusoft.ScanFixXpressSdk.ImageDetergentOptions
Accusoft.ScanFixXpressSdk.ImageRegistrationOptions
Accusoft.ScanFixXpressSdk.InverseTextOptions
Accusoft.ScanFixXpressSdk.LineRemovalOptions
Accusoft.ScanFixXpressSdk.MirrorOptions
Accusoft.ScanFixXpressSdk.NegateOptions
Accusoft.ScanFixXpressSdk.NegativeCorrectionOptions
Accusoft.ScanFixXpressSdk.PerspectiveAdjustOptions
Accusoft.ScanFixXpressSdk.RescaleOptions
Accusoft.ScanFixXpressSdk.RotateOptions
Accusoft.ScanFixXpressSdk.ShearOptions
Accusoft.ScanFixXpressSdk.SmoothObjectsOptions
Accusoft.ScanFixXpressSdk.SmoothZoomOptions
Accusoft.ScanFixXpressSdk.VirtualBulbOptions
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.AutoBinarizeResults
Accusoft.ScanFixXpressSdk.AutoBrightnessContrastResults
Accusoft.ScanFixXpressSdk.AutoDespeckleResults
Accusoft.ScanFixXpressSdk.AutoInverseTextResults
Accusoft.ScanFixXpressSdk.AutoRemoveHolePunchResults
Accusoft.ScanFixXpressSdk.AutoRotateResults
Accusoft.ScanFixXpressSdk.AutoSmoothBackgroundResults
Accusoft.ScanFixXpressSdk.BinarizeResults
Accusoft.ScanFixXpressSdk.BlankPageDetectResults
Accusoft.ScanFixXpressSdk.BlankRectangleDetectResults
Accusoft.ScanFixXpressSdk.BlobRemovalResults
Accusoft.ScanFixXpressSdk.BorderRemovalResults
Accusoft.ScanFixXpressSdk.BrightnessContrastResults
Accusoft.ScanFixXpressSdk.ColorDropResults
Accusoft.ScanFixXpressSdk.CombRemovalResults
Accusoft.ScanFixXpressSdk.DeskewResults
Accusoft.ScanFixXpressSdk.DespeckleResults
Accusoft.ScanFixXpressSdk.DetectColorResults
Accusoft.ScanFixXpressSdk.DilateResults
Accusoft.ScanFixXpressSdk.DotShadingRemovalResults
Accusoft.ScanFixXpressSdk.ErodeResults
Accusoft.ScanFixXpressSdk.FilterResults
Accusoft.ScanFixXpressSdk.FlipResults
Accusoft.ScanFixXpressSdk.GetRectangleResults
Accusoft.ScanFixXpressSdk.GraphicLineDetectionResults
Accusoft.ScanFixXpressSdk.GraphicLineRemovalResults
Accusoft.ScanFixXpressSdk.ImageDetergentResults
Accusoft.ScanFixXpressSdk.ImageRegistrationResults
Accusoft.ScanFixXpressSdk.InverseTextResults
Accusoft.ScanFixXpressSdk.LineRemovalResults
Accusoft.ScanFixXpressSdk.MirrorResults
Accusoft.ScanFixXpressSdk.NegateResults
Accusoft.ScanFixXpressSdk.NegativeCorrectionResults
Accusoft.ScanFixXpressSdk.PerspectiveAdjustResults
Accusoft.ScanFixXpressSdk.RescaleResults
Accusoft.ScanFixXpressSdk.RotateResults
Accusoft.ScanFixXpressSdk.ShearResults
Accusoft.ScanFixXpressSdk.SmoothObjectsResults
Accusoft.ScanFixXpressSdk.SmoothZoomResults
Accusoft.ScanFixXpressSdk.VirtualBulbResults
Accusoft.ScanFixXpressSdk.Enhancements
Accusoft.ScanFixXpressSdk.GraphicLine
Accusoft.ScanFixXpressSdk.HueRadius
Accusoft.ScanFixXpressSdk.Licensing
Accusoft.ScanFixXpressSdk.Resolution
System.Collections.CollectionBase
Accusoft.ScanFixXpressSdk.EnhancementOptionsCollection
Accusoft.ScanFixXpressSdk.EnhancementResultsCollection
System.Exception
Accusoft.ScanFixXpressSdk.ScanFixException
Accusoft.ScanFixXpressSdk.ScanFixUnsupportedImageException
System.MarshalByRefObject
System.ComponentModel.Component
Accusoft.ScanFixXpressSdk.ScanFix
See Also

Reference

Accusoft.ScanFixXpress8.Net Assembly


AutoBinarizeOptions Class

Accusoft.ScanFixXpress8.Net
AutoBinarizeOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : AutoBinarizeOptions Class
Defines a place holder class for the ScanFix.AutoBinarize image enhancement. This class does not contain any parameters that can be set. An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Object Model
AutoBinarizeOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AutoBinarizeOptions
   Inherits EnhancementOption
'Usage

Dim instance As AutoBinarizeOptions
public class AutoBinarizeOptions : EnhancementOption
public __gc class AutoBinarizeOptions : public EnhancementOption
public ref class AutoBinarizeOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.AutoBinarizeOptions

See Also

Reference

AutoBinarizeOptions Members
Accusoft.ScanFixXpressSdk Namespace


AutoBinarizeOptions Class Members

Accusoft.ScanFixXpress8.Net
AutoBinarizeOptions Class Members

Accusoft.ScanFixXpressSdk Namespace : AutoBinarizeOptions Class

The following tables list the members exposed by AutoBinarizeOptions.

Public Constructors
 | Name | Description
Public Constructor | AutoBinarizeOptions Constructor | Initializes a new instance of the AutoBinarizeOptions class with the default options.
Top
See Also

Reference

AutoBinarizeOptions Class
Accusoft.ScanFixXpressSdk Namespace


AutoBinarizeOptions Constructor

Accusoft.ScanFixXpress8.Net
AutoBinarizeOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > AutoBinarizeOptions Class : AutoBinarizeOptions Constructor
Initializes a new instance of the AutoBinarizeOptions class with the default options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New AutoBinarizeOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public AutoBinarizeOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: AutoBinarizeOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
AutoBinarizeOptions();
Remarks
There are no options available in this class. This is only used to instantiate the class in order to add this operation to an enhancements list.
See Also

Reference

AutoBinarizeOptions Class
AutoBinarizeOptions Members


AutoBinarizeResults Class

Accusoft.ScanFixXpress8.Net
AutoBinarizeResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : AutoBinarizeResults Class
Defines a place holder class for the AutoBinarize enhancement result.
Object Model
AutoBinarizeResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AutoBinarizeResults
   Inherits EnhancementResult
'Usage

Dim instance As AutoBinarizeResults
public class AutoBinarizeResults : EnhancementResult
public __gc class AutoBinarizeResults : public EnhancementResult
public ref class AutoBinarizeResults : public EnhancementResult
Remarks
This class contains no data. Its presence in the results list is used to determine that the operation has run successfully.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.AutoBinarizeResults

See Also

Reference

AutoBinarizeResults Members
Accusoft.ScanFixXpressSdk Namespace


AutoBinarizeResults Class Members

Accusoft.ScanFixXpress8.Net
AutoBinarizeResults Class Members

Accusoft.ScanFixXpressSdk Namespace : AutoBinarizeResults Class

The following tables list the members exposed by AutoBinarizeResults.

See Also

Reference

AutoBinarizeResults Class
Accusoft.ScanFixXpressSdk Namespace


AutoBrightnessContrastOptions Class

Accusoft.ScanFixXpress8.Net
AutoBrightnessContrastOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : AutoBrightnessContrastOptions Class
Defines a place holder class for the ScanFix.AutoAdjustBrightnessContrast image enhancement. This class does not contain any parameters that can be set.
Object Model
AutoBrightnessContrastOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AutoBrightnessContrastOptions
   Inherits EnhancementOption
'Usage

Dim instance As AutoBrightnessContrastOptions
public class AutoBrightnessContrastOptions : EnhancementOption
public __gc class AutoBrightnessContrastOptions : public EnhancementOption
public ref class AutoBrightnessContrastOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.AutoBrightnessContrastOptions

See Also

Reference

AutoBrightnessContrastOptions Members
Accusoft.ScanFixXpressSdk Namespace


AutoBrightnessContrastOptions Class Members

Accusoft.ScanFixXpress8.Net
AutoBrightnessContrastOptions Class Members

Accusoft.ScanFixXpressSdk Namespace : AutoBrightnessContrastOptions Class

The following tables list the members exposed by AutoBrightnessContrastOptions.

Public Constructors
 | Name | Description
Public Constructor | AutoBrightnessContrastOptions Constructor | Instantiates a new BrightnessContrastOptions object.
Top
See Also

Reference

AutoBrightnessContrastOptions Class
Accusoft.ScanFixXpressSdk Namespace


AutoBrightnessContrastOptions Constructor

Accusoft.ScanFixXpress8.Net
AutoBrightnessContrastOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > AutoBrightnessContrastOptions Class : AutoBrightnessContrastOptions Constructor
Instantiates a new BrightnessContrastOptions object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New AutoBrightnessContrastOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public AutoBrightnessContrastOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: AutoBrightnessContrastOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
AutoBrightnessContrastOptions();
Remarks
Use this to initialize the class before adding it to an Enhancements list.
See Also

Reference

AutoBrightnessContrastOptions Class
AutoBrightnessContrastOptions Members


AutoBrightnessContrastResults Class

Accusoft.ScanFixXpress8.Net
AutoBrightnessContrastResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : AutoBrightnessContrastResults Class
Defines a place holder class for the AutoAdjustBrightnessContrast enhancement result.
Object Model
AutoBrightnessContrastResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AutoBrightnessContrastResults
   Inherits EnhancementResult
'Usage

Dim instance As AutoBrightnessContrastResults
public class AutoBrightnessContrastResults : EnhancementResult
public __gc class AutoBrightnessContrastResults : public EnhancementResult
public ref class AutoBrightnessContrastResults : public EnhancementResult
Remarks
This class contains no data. Its presence in the Enhancements.Results list is used to determine that the operation has run successfully.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.AutoBrightnessContrastResults

See Also

Reference

AutoBrightnessContrastResults Members
Accusoft.ScanFixXpressSdk Namespace


AutoBrightnessContrastResults Class Members

Accusoft.ScanFixXpress8.Net
AutoBrightnessContrastResults Class Members

Accusoft.ScanFixXpressSdk Namespace : AutoBrightnessContrastResults Class

The following tables list the members exposed by AutoBrightnessContrastResults.

See Also

Reference

AutoBrightnessContrastResults Class
Accusoft.ScanFixXpressSdk Namespace


AutoDespeckleOptions Class

Accusoft.ScanFixXpress8.Net
AutoDespeckleOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : AutoDespeckleOptions Class
Defines a place holder class for the ScanFix.AutoDespeckle image enhancement. This class does not contain any parameters that can be set.
Object Model
AutoDespeckleOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AutoDespeckleOptions
   Inherits EnhancementOption
'Usage

Dim instance As AutoDespeckleOptions
public class AutoDespeckleOptions : EnhancementOption
public __gc class AutoDespeckleOptions : public EnhancementOption
public ref class AutoDespeckleOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.AutoDespeckleOptions

See Also

Reference

AutoDespeckleOptions Members
Accusoft.ScanFixXpressSdk Namespace


AutoDespeckleOptions Class Members

Accusoft.ScanFixXpress8.Net
AutoDespeckleOptions Class Members

Accusoft.ScanFixXpressSdk Namespace : AutoDespeckleOptions Class

The following tables list the members exposed by AutoDespeckleOptions.

Public Constructors
 | Name | Description
Public Constructor | AutoDespeckleOptions Constructor | Instantiates a new AutoDespeckleOptions object.
Top
See Also

Reference

AutoDespeckleOptions Class
Accusoft.ScanFixXpressSdk Namespace


AutoDespeckleOptions Constructor

Accusoft.ScanFixXpress8.Net
AutoDespeckleOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > AutoDespeckleOptions Class : AutoDespeckleOptions Constructor
Instantiates a new AutoDespeckleOptions object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New AutoDespeckleOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public AutoDespeckleOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: AutoDespeckleOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
AutoDespeckleOptions();
Remarks
Use this to initialize the class before adding it to an Enhancements list.
See Also

Reference

AutoDespeckleOptions Class
AutoDespeckleOptions Members


AutoDespeckleResults Class

Accusoft.ScanFixXpress8.Net
AutoDespeckleResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : AutoDespeckleResults Class
Contains information generated during the ScanFix.AutoDespeckle enhancement.
Object Model
AutoDespeckleResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AutoDespeckleResults
   Inherits EnhancementResult
'Usage

Dim instance As AutoDespeckleResults
public class AutoDespeckleResults : EnhancementResult
public __gc class AutoDespeckleResults : public EnhancementResult
public ref class AutoDespeckleResults : public EnhancementResult
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.AutoDespeckleResults

See Also

Reference

AutoDespeckleResults Members
Accusoft.ScanFixXpressSdk Namespace


AutoDespeckleResults Class Members

Accusoft.ScanFixXpress8.Net
AutoDespeckleResults Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : AutoDespeckleResults Class

The following tables list the members exposed by AutoDespeckleResults.

Public Properties
 | Name | Description
Public Property | CountOfSpecksFound | Gets the number of speckles found and removed from image
Top
See Also

Reference

AutoDespeckleResults Class
Accusoft.ScanFixXpressSdk Namespace


AutoDespeckleResults Class Properties

Accusoft.ScanFixXpress8.Net
AutoDespeckleResults Class Properties

Accusoft.ScanFixXpressSdk Namespace : AutoDespeckleResults Class

For a list of all members of this type, see AutoDespeckleResults members.

Public Properties
 | Name | Description
Public Property | CountOfSpecksFound | Gets the number of speckles found and removed from image
Top
See Also

Reference

AutoDespeckleResults Class
Accusoft.ScanFixXpressSdk Namespace


CountOfSpecksFound Property (AutoDespeckleResults)

Accusoft.ScanFixXpress8.Net
CountOfSpecksFound Property (AutoDespeckleResults)

Accusoft.ScanFixXpressSdk Namespace > AutoDespeckleResults Class : CountOfSpecksFound Property
Gets the number of speckles found and removed from image
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CountOfSpecksFound As Integer
'Usage

Dim instance As AutoDespeckleResults
Dim value As Integer

value = instance.CountOfSpecksFound
public int CountOfSpecksFound {get;}
public: __property int get_CountOfSpecksFound();
public:
property int CountOfSpecksFound {
   int get();
}

Property Value

An integer that represents the number of speckles.
See Also

Reference

AutoDespeckleResults Class
AutoDespeckleResults Members


AutoImageDetergentOptions Class

Accusoft.ScanFixXpress8.Net
AutoImageDetergentOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : AutoImageDetergentOptions Class
Contains parameters that control the ScanFix.AutoImageDetergent process.
Object Model
AutoImageDetergentOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AutoImageDetergentOptions
   Inherits EnhancementOption
'Usage

Dim instance As AutoImageDetergentOptions
public class AutoImageDetergentOptions : EnhancementOption
public __gc class AutoImageDetergentOptions : public EnhancementOption
public ref class AutoImageDetergentOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.AutoImageDetergentOptions

See Also

Reference

AutoImageDetergentOptions Members
Accusoft.ScanFixXpressSdk Namespace


AutoImageDetergentOptions Class Members

Accusoft.ScanFixXpress8.Net
AutoImageDetergentOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : AutoImageDetergentOptions Class

The following tables list the members exposed by AutoImageDetergentOptions.

Public Constructors
 | Name | Description
Public Constructor | AutoImageDetergentOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ColorCount | Gets and sets number of dominant colors to find for Mode=ColorCount.
Public Property | Mode | Gets and sets value for automatic ImageDetergent operation mode.
Top
See Also

Reference

AutoImageDetergentOptions Class
Accusoft.ScanFixXpressSdk Namespace


AutoImageDetergentOptions Class Properties

Accusoft.ScanFixXpress8.Net
AutoImageDetergentOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : AutoImageDetergentOptions Class

For a list of all members of this type, see AutoImageDetergentOptions members.

Public Properties
 | Name | Description
Public Property | ColorCount | Gets and sets number of dominant colors to find for Mode=ColorCount.
Public Property | Mode | Gets and sets value for automatic ImageDetergent operation mode.
Top
See Also

Reference

AutoImageDetergentOptions Class
Accusoft.ScanFixXpressSdk Namespace


AutoImageDetergentOptions Constructor

Accusoft.ScanFixXpress8.Net
AutoImageDetergentOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > AutoImageDetergentOptions Class : AutoImageDetergentOptions Constructor
Overload List
Overload | Description
AutoImageDetergentOptions Constructor() | Instantiates a new AutoImageDetergentOptions object setting the default values.
AutoImageDetergentOptions Constructor(AutomaticMode,Int32) | Instantiates a new AutoImageDetergentOptions object setting the specified values.
See Also

Reference

AutoImageDetergentOptions Class
AutoImageDetergentOptions Members


AutoImageDetergentOptions Constructor()

Accusoft.ScanFixXpress8.Net
AutoImageDetergentOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > AutoImageDetergentOptions Class > AutoImageDetergentOptions Constructor : AutoImageDetergentOptions Constructor()
Instantiates a new AutoImageDetergentOptions object setting the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New AutoImageDetergentOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public AutoImageDetergentOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: AutoImageDetergentOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
AutoImageDetergentOptions();
See Also

Reference

AutoImageDetergentOptions Class
AutoImageDetergentOptions Members
Overload List


AutoImageDetergentOptions Constructor(AutomaticMode,Int32)

Accusoft.ScanFixXpress8.Net
AutoImageDetergentOptions Constructor(AutomaticMode,Int32)

Accusoft.ScanFixXpressSdk Namespace > AutoImageDetergentOptions Class > AutoImageDetergentOptions Constructor : AutoImageDetergentOptions Constructor(AutomaticMode,Int32)
Mode for AutoImageDetergent operation
Number of dominant colors to find for ColorCount mode
Instantiates a new AutoImageDetergentOptions object setting the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New( _
   ByVal mode As AutomaticMode, _
   ByVal colorCount As Integer _
)
'Usage

Dim mode As AutomaticMode
Dim colorCount As Integer

Dim instance As New AutoImageDetergentOptions(mode, colorCount)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public AutoImageDetergentOptions(
   AutomaticMode mode,
   int colorCount
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: AutoImageDetergentOptions(
   AutomaticMode mode,
   int colorCount
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
AutoImageDetergentOptions(
   AutomaticMode mode,
   int colorCount
)

Parameters

mode
Mode for AutoImageDetergent operation
colorCount
Number of dominant colors to find for ColorCount mode
See Also

Reference

AutoImageDetergentOptions Class
AutoImageDetergentOptions Members
Overload List


ColorCount Property

Accusoft.ScanFixXpress8.Net
ColorCount Property

Accusoft.ScanFixXpressSdk Namespace > AutoImageDetergentOptions Class : ColorCount Property
Gets and sets number of dominant colors to find for Mode=ColorCount.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColorCount As Integer
'Usage

Dim instance As AutoImageDetergentOptions
Dim value As Integer

instance.ColorCount = value

value = instance.ColorCount
public int ColorCount {get; set;}
public: __property int get_ColorCount();
public: __property void set_ColorCount(
   int value
);
public:
property int ColorCount {
   int get();
   void set (    int value);
}
See Also

Reference

AutoImageDetergentOptions Class
AutoImageDetergentOptions Members


Mode Property

Accusoft.ScanFixXpress8.Net
Mode Property

Accusoft.ScanFixXpressSdk Namespace > AutoImageDetergentOptions Class : Mode Property
Gets and sets value for automatic ImageDetergent operation mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Mode As AutomaticMode
'Usage

Dim instance As AutoImageDetergentOptions
Dim value As AutomaticMode

instance.Mode = value

value = instance.Mode
public AutomaticMode Mode {get; set;}
public: __property AutomaticMode get_Mode();
public: __property void set_Mode(
   AutomaticMode value
);
public:
property AutomaticMode Mode {
   AutomaticMode get();
   void set (    AutomaticMode value);
}
See Also

Reference

AutoImageDetergentOptions Class
AutoImageDetergentOptions Members


AutoInverseTextOptions Class

Accusoft.ScanFixXpress8.Net
AutoInverseTextOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : AutoInverseTextOptions Class
Defines a place holder class for the AutoCorrectInverseText image enhancement. This class does not contain any parameters that can be set. An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Object Model
AutoInverseTextOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AutoInverseTextOptions
   Inherits EnhancementOption
'Usage

Dim instance As AutoInverseTextOptions
public class AutoInverseTextOptions : EnhancementOption
public __gc class AutoInverseTextOptions : public EnhancementOption
public ref class AutoInverseTextOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.AutoInverseTextOptions

See Also

Reference

AutoInverseTextOptions Members
Accusoft.ScanFixXpressSdk Namespace


AutoInverseTextOptions Class Members

Accusoft.ScanFixXpress8.Net
AutoInverseTextOptions Class Members

Accusoft.ScanFixXpressSdk Namespace : AutoInverseTextOptions Class

The following tables list the members exposed by AutoInverseTextOptions.

Public Constructors
 | Name | Description
Public Constructor | AutoInverseTextOptions Constructor | Instantiates a new empty AutoInverseTextOptions object.
Top
See Also

Reference

AutoInverseTextOptions Class
Accusoft.ScanFixXpressSdk Namespace


AutoInverseTextOptions Constructor

Accusoft.ScanFixXpress8.Net
AutoInverseTextOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > AutoInverseTextOptions Class : AutoInverseTextOptions Constructor
Instantiates a new empty AutoInverseTextOptions object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New AutoInverseTextOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public AutoInverseTextOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: AutoInverseTextOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
AutoInverseTextOptions();
See Also

Reference

AutoInverseTextOptions Class
AutoInverseTextOptions Members


AutoInverseTextResults Class

Accusoft.ScanFixXpress8.Net
AutoInverseTextResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : AutoInverseTextResults Class
Contains information generanted during the ScanFix.AutoCorrectInverseText enhancement.
Object Model
AutoInverseTextResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AutoInverseTextResults
   Inherits EnhancementResult
'Usage

Dim instance As AutoInverseTextResults
public class AutoInverseTextResults : EnhancementResult
public __gc class AutoInverseTextResults : public EnhancementResult
public ref class AutoInverseTextResults : public EnhancementResult
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.AutoInverseTextResults

See Also

Reference

AutoInverseTextResults Members
Accusoft.ScanFixXpressSdk Namespace


AutoInverseTextResults Class Members

Accusoft.ScanFixXpress8.Net
AutoInverseTextResults Class Members
Properties Methods

Accusoft.ScanFixXpressSdk Namespace : AutoInverseTextResults Class

The following tables list the members exposed by AutoInverseTextResults.

Public Properties
 | Name | Description
Public Property | CountOfAreasFound | Gets the number of inverse text areas found and corrected.
Top
Public Methods
 | Name | Description
Public Method | Area | Gets the location and size of a particular area found.
Top
See Also

Reference

AutoInverseTextResults Class
Accusoft.ScanFixXpressSdk Namespace


AutoInverseTextResults Class Properties

Accusoft.ScanFixXpress8.Net
AutoInverseTextResults Class Properties

Accusoft.ScanFixXpressSdk Namespace : AutoInverseTextResults Class

For a list of all members of this type, see AutoInverseTextResults members.

Public Properties
 | Name | Description
Public Property | CountOfAreasFound | Gets the number of inverse text areas found and corrected.
Top
See Also

Reference

AutoInverseTextResults Class
Accusoft.ScanFixXpressSdk Namespace


AutoInverseTextResults Class Methods

Accusoft.ScanFixXpress8.Net
AutoInverseTextResults Class Methods

Accusoft.ScanFixXpressSdk Namespace : AutoInverseTextResults Class

For a list of all members of this type, see AutoInverseTextResults members.

Public Methods
 | Name | Description
Public Method | Area | Gets the location and size of a particular area found.
Top
See Also

Reference

AutoInverseTextResults Class
Accusoft.ScanFixXpressSdk Namespace


Area Method (AutoInverseTextResults)

Accusoft.ScanFixXpress8.Net
Area Method (AutoInverseTextResults)

Accusoft.ScanFixXpressSdk Namespace > AutoInverseTextResults Class : Area Method
Index of the requested area
Gets the location and size of a particular area found.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function Area( _
   ByVal index As Integer _
) As Rectangle
'Usage

Dim instance As AutoInverseTextResults
Dim index As Integer
Dim value As Rectangle

value = instance.Area(index)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public Rectangle Area(
   int index
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: Rectangle Area(
   int index
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
Rectangle Area(
   int index
)

Parameters

index
Index of the requested area

Return Value

A Rectangle object that represents the location and size of the requested area.
See Also

Reference

AutoInverseTextResults Class
AutoInverseTextResults Members


CountOfAreasFound Property (AutoInverseTextResults)

Accusoft.ScanFixXpress8.Net
CountOfAreasFound Property (AutoInverseTextResults)

Accusoft.ScanFixXpressSdk Namespace > AutoInverseTextResults Class : CountOfAreasFound Property
Gets the number of inverse text areas found and corrected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CountOfAreasFound As Integer
'Usage

Dim instance As AutoInverseTextResults
Dim value As Integer

value = instance.CountOfAreasFound
public int CountOfAreasFound {get;}
public: __property int get_CountOfAreasFound();
public:
property int CountOfAreasFound {
   int get();
}

Property Value

An integer value which represents the number of areas.
See Also

Reference

AutoInverseTextResults Class
AutoInverseTextResults Members


AutoRemoveHolePunchOptions Class

Accusoft.ScanFixXpress8.Net
AutoRemoveHolePunchOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : AutoRemoveHolePunchOptions Class
Defines a place holder class that controls options for the ScanFix.AutoRemoveHolePunch image enhancement. This class does not contain parameters that can be set. An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Object Model
AutoRemoveHolePunchOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AutoRemoveHolePunchOptions
   Inherits EnhancementOption
'Usage

Dim instance As AutoRemoveHolePunchOptions
public class AutoRemoveHolePunchOptions : EnhancementOption
public __gc class AutoRemoveHolePunchOptions : public EnhancementOption
public ref class AutoRemoveHolePunchOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.AutoRemoveHolePunchOptions

See Also

Reference

AutoRemoveHolePunchOptions Members
Accusoft.ScanFixXpressSdk Namespace


AutoRemoveHolePunchOptions Class Members

Accusoft.ScanFixXpress8.Net
AutoRemoveHolePunchOptions Class Members

Accusoft.ScanFixXpressSdk Namespace : AutoRemoveHolePunchOptions Class

The following tables list the members exposed by AutoRemoveHolePunchOptions.

Public Constructors
 | Name | Description
Public Constructor | AutoRemoveHolePunchOptions Constructor | Instantiates a new AutoRemoveHolePunchOptions object.
Top
See Also

Reference

AutoRemoveHolePunchOptions Class
Accusoft.ScanFixXpressSdk Namespace


AutoRemoveHolePunchOptions Constructor

Accusoft.ScanFixXpress8.Net
AutoRemoveHolePunchOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > AutoRemoveHolePunchOptions Class : AutoRemoveHolePunchOptions Constructor
Instantiates a new AutoRemoveHolePunchOptions object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New AutoRemoveHolePunchOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public AutoRemoveHolePunchOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: AutoRemoveHolePunchOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
AutoRemoveHolePunchOptions();
Remarks
Use this to initialize the class before adding it to an Enhancements list.
See Also

Reference

AutoRemoveHolePunchOptions Class
AutoRemoveHolePunchOptions Members


AutoRemoveHolePunchResults Class

Accusoft.ScanFixXpress8.Net
AutoRemoveHolePunchResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : AutoRemoveHolePunchResults Class
Contains information generated during the ScanFix.AutoRemoveHolePunch enhancement.
Object Model
AutoRemoveHolePunchResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AutoRemoveHolePunchResults
   Inherits EnhancementResult
'Usage

Dim instance As AutoRemoveHolePunchResults
public class AutoRemoveHolePunchResults : EnhancementResult
public __gc class AutoRemoveHolePunchResults : public EnhancementResult
public ref class AutoRemoveHolePunchResults : public EnhancementResult
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.AutoRemoveHolePunchResults

See Also

Reference

AutoRemoveHolePunchResults Members
Accusoft.ScanFixXpressSdk Namespace


AutoRemoveHolePunchResults Class Members

Accusoft.ScanFixXpress8.Net
AutoRemoveHolePunchResults Class Members
Properties Methods

Accusoft.ScanFixXpressSdk Namespace : AutoRemoveHolePunchResults Class

The following tables list the members exposed by AutoRemoveHolePunchResults.

Public Properties
 | Name | Description
Public Property | CountOfPunchesFound | Gets the number of hole punches found and removed.
Top
Public Methods
 | Name | Description
Public Method | Area | Gets the location and size of the bounding box of a particular punch.
Top
See Also

Reference

AutoRemoveHolePunchResults Class
Accusoft.ScanFixXpressSdk Namespace


AutoRemoveHolePunchResults Class Properties

Accusoft.ScanFixXpress8.Net
AutoRemoveHolePunchResults Class Properties

Accusoft.ScanFixXpressSdk Namespace : AutoRemoveHolePunchResults Class

For a list of all members of this type, see AutoRemoveHolePunchResults members.

Public Properties
 | Name | Description
Public Property | CountOfPunchesFound | Gets the number of hole punches found and removed.
Top
See Also

Reference

AutoRemoveHolePunchResults Class
Accusoft.ScanFixXpressSdk Namespace


AutoRemoveHolePunchResults Class Methods

Accusoft.ScanFixXpress8.Net
AutoRemoveHolePunchResults Class Methods

Accusoft.ScanFixXpressSdk Namespace : AutoRemoveHolePunchResults Class

For a list of all members of this type, see AutoRemoveHolePunchResults members.

Public Methods
 | Name | Description
Public Method | Area | Gets the location and size of the bounding box of a particular punch.
Top
See Also

Reference

AutoRemoveHolePunchResults Class
Accusoft.ScanFixXpressSdk Namespace


Area Method (AutoRemoveHolePunchResults)

Accusoft.ScanFixXpress8.Net
Area Method (AutoRemoveHolePunchResults)

Accusoft.ScanFixXpressSdk Namespace > AutoRemoveHolePunchResults Class : Area Method
Index of the queried hole punch area.
Gets the location and size of the bounding box of a particular punch.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function Area( _
   ByVal index As Integer _
) As Rectangle
'Usage

Dim instance As AutoRemoveHolePunchResults
Dim index As Integer
Dim value As Rectangle

value = instance.Area(index)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public Rectangle Area(
   int index
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: Rectangle Area(
   int index
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
Rectangle Area(
   int index
)

Parameters

index
Index of the queried hole punch area.

Return Value

A rectangle object that represents the location and size of the bounding box.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when index value is out of range.
See Also

Reference

AutoRemoveHolePunchResults Class
AutoRemoveHolePunchResults Members


CountOfPunchesFound Property

Accusoft.ScanFixXpress8.Net
CountOfPunchesFound Property

Accusoft.ScanFixXpressSdk Namespace > AutoRemoveHolePunchResults Class : CountOfPunchesFound Property
Gets the number of hole punches found and removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CountOfPunchesFound As Integer
'Usage

Dim instance As AutoRemoveHolePunchResults
Dim value As Integer

value = instance.CountOfPunchesFound
public int CountOfPunchesFound {get;}
public: __property int get_CountOfPunchesFound();
public:
property int CountOfPunchesFound {
   int get();
}

Property Value

An integer value which represents the number of punches.
See Also

Reference

AutoRemoveHolePunchResults Class
AutoRemoveHolePunchResults Members


AutoRotateOptions Class

Accusoft.ScanFixXpress8.Net
AutoRotateOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : AutoRotateOptions Class
Defines a placeholder class the controls the options for the ScanFix.AutoRotate process. This class does not contain any parameters that can be set.
Object Model
AutoRotateOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AutoRotateOptions
   Inherits EnhancementOption
'Usage

Dim instance As AutoRotateOptions
public class AutoRotateOptions : EnhancementOption
public __gc class AutoRotateOptions : public EnhancementOption
public ref class AutoRotateOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.AutoRotateOptions

See Also

Reference

AutoRotateOptions Members
Accusoft.ScanFixXpressSdk Namespace


AutoRotateOptions Class Members

Accusoft.ScanFixXpress8.Net
AutoRotateOptions Class Members

Accusoft.ScanFixXpressSdk Namespace : AutoRotateOptions Class

The following tables list the members exposed by AutoRotateOptions.

Public Constructors
 | Name | Description
Public Constructor | AutoRotateOptions Constructor | Instantiates a new AutoRotateOptions object.
Top
See Also

Reference

AutoRotateOptions Class
Accusoft.ScanFixXpressSdk Namespace


AutoRotateOptions Constructor

Accusoft.ScanFixXpress8.Net
AutoRotateOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > AutoRotateOptions Class : AutoRotateOptions Constructor
Instantiates a new AutoRotateOptions object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New AutoRotateOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public AutoRotateOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: AutoRotateOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
AutoRotateOptions();
Remarks
Use this to initialize the class before adding it to an Enhancements list.
See Also

Reference

AutoRotateOptions Class
AutoRotateOptions Members


AutoRotateResults Class

Accusoft.ScanFixXpress8.Net
AutoRotateResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : AutoRotateResults Class
Contains information generated during the ScanFix.AutoRotate enhancement.
Object Model
AutoRotateResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AutoRotateResults
   Inherits EnhancementResult
'Usage

Dim instance As AutoRotateResults
public class AutoRotateResults : EnhancementResult
public __gc class AutoRotateResults : public EnhancementResult
public ref class AutoRotateResults : public EnhancementResult
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.AutoRotateResults

See Also

Reference

AutoRotateResults Members
Accusoft.ScanFixXpressSdk Namespace


AutoRotateResults Class Members

Accusoft.ScanFixXpress8.Net
AutoRotateResults Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : AutoRotateResults Class

The following tables list the members exposed by AutoRotateResults.

Public Properties
 | Name | Description
Public Property | Confidence | Gets the confidence value that indicates the certainty that the process holds over the result.
Public Property | DegreesDetected | Gets the value of degrees that the image was rotated counterclockwise detected by the process.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified during the auto rotate process.
Top
See Also

Reference

AutoRotateResults Class
Accusoft.ScanFixXpressSdk Namespace


AutoRotateResults Class Properties

Accusoft.ScanFixXpress8.Net
AutoRotateResults Class Properties

Accusoft.ScanFixXpressSdk Namespace : AutoRotateResults Class

For a list of all members of this type, see AutoRotateResults members.

Public Properties
 | Name | Description
Public Property | Confidence | Gets the confidence value that indicates the certainty that the process holds over the result.
Public Property | DegreesDetected | Gets the value of degrees that the image was rotated counterclockwise detected by the process.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified during the auto rotate process.
Top
See Also

Reference

AutoRotateResults Class
Accusoft.ScanFixXpressSdk Namespace


Confidence Property (AutoRotateResults)

Accusoft.ScanFixXpress8.Net
Confidence Property (AutoRotateResults)

Accusoft.ScanFixXpressSdk Namespace > AutoRotateResults Class : Confidence Property
Gets the confidence value that indicates the certainty that the process holds over the result.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Confidence As Integer
'Usage

Dim instance As AutoRotateResults
Dim value As Integer

value = instance.Confidence
public int Confidence {get;}
public: __property int get_Confidence();
public:
property int Confidence {
   int get();
}

Property Value

An integer that represents the confidence value
See Also

Reference

AutoRotateResults Class
AutoRotateResults Members


DegreesDetected Property

Accusoft.ScanFixXpress8.Net
DegreesDetected Property

Accusoft.ScanFixXpressSdk Namespace > AutoRotateResults Class : DegreesDetected Property
Gets the value of degrees that the image was rotated counterclockwise detected by the process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DegreesDetected As Integer
'Usage

Dim instance As AutoRotateResults
Dim value As Integer

value = instance.DegreesDetected
public int DegreesDetected {get;}
public: __property int get_DegreesDetected();
public:
property int DegreesDetected {
   int get();
}

Property Value

One of 4 possible integer values 0, 90, 180, and 270.
See Also

Reference

AutoRotateResults Class
AutoRotateResults Members


ImageWasModified Property (AutoRotateResults)

Accusoft.ScanFixXpress8.Net
ImageWasModified Property (AutoRotateResults)

Accusoft.ScanFixXpressSdk Namespace > AutoRotateResults Class : ImageWasModified Property
Gets a flag that indicates whether the image was modified during the auto rotate process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageWasModified As Boolean
'Usage

Dim instance As AutoRotateResults
Dim value As Boolean

value = instance.ImageWasModified
public bool ImageWasModified {get;}
public: __property bool get_ImageWasModified();
public:
property bool ImageWasModified {
   bool get();
}
See Also

Reference

AutoRotateResults Class
AutoRotateResults Members


AutoSmoothBackgroundOptions Class

Accusoft.ScanFixXpress8.Net
AutoSmoothBackgroundOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : AutoSmoothBackgroundOptions Class
Defines a placeholder class that controls options for the ScanFix.AutoSmoothBackground process. This class does not contain any parameters that can be set.
Object Model
AutoSmoothBackgroundOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AutoSmoothBackgroundOptions
   Inherits EnhancementOption
'Usage

Dim instance As AutoSmoothBackgroundOptions
public class AutoSmoothBackgroundOptions : EnhancementOption
public __gc class AutoSmoothBackgroundOptions : public EnhancementOption
public ref class AutoSmoothBackgroundOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.AutoSmoothBackgroundOptions

See Also

Reference

AutoSmoothBackgroundOptions Members
Accusoft.ScanFixXpressSdk Namespace


AutoSmoothBackgroundOptions Class Members

Accusoft.ScanFixXpress8.Net
AutoSmoothBackgroundOptions Class Members

Accusoft.ScanFixXpressSdk Namespace : AutoSmoothBackgroundOptions Class

The following tables list the members exposed by AutoSmoothBackgroundOptions.

Public Constructors
 | Name | Description
Public Constructor | AutoSmoothBackgroundOptions Constructor | Instantiates a new AutoSmoothBackgroundOptions object.
Top
See Also

Reference

AutoSmoothBackgroundOptions Class
Accusoft.ScanFixXpressSdk Namespace


AutoSmoothBackgroundOptions Constructor

Accusoft.ScanFixXpress8.Net
AutoSmoothBackgroundOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > AutoSmoothBackgroundOptions Class : AutoSmoothBackgroundOptions Constructor
Instantiates a new AutoSmoothBackgroundOptions object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New AutoSmoothBackgroundOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public AutoSmoothBackgroundOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: AutoSmoothBackgroundOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
AutoSmoothBackgroundOptions();
Remarks
Use this to initialize the class before adding it to an Enhancements list.
See Also

Reference

AutoSmoothBackgroundOptions Class
AutoSmoothBackgroundOptions Members


AutoSmoothBackgroundResults Class

Accusoft.ScanFixXpress8.Net
AutoSmoothBackgroundResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : AutoSmoothBackgroundResults Class
Defines a place holder class for the AutoAdjustBrightnessContrast enhancement result.
Object Model
AutoSmoothBackgroundResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AutoSmoothBackgroundResults
   Inherits EnhancementResult
'Usage

Dim instance As AutoSmoothBackgroundResults
public class AutoSmoothBackgroundResults : EnhancementResult
public __gc class AutoSmoothBackgroundResults : public EnhancementResult
public ref class AutoSmoothBackgroundResults : public EnhancementResult
Remarks
This class contains no data. Its presence in the results list is used to determine that the operation has run successfully.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.AutoSmoothBackgroundResults

See Also

Reference

AutoSmoothBackgroundResults Members
Accusoft.ScanFixXpressSdk Namespace


AutoSmoothBackgroundResults Class Members

Accusoft.ScanFixXpress8.Net
AutoSmoothBackgroundResults Class Members

Accusoft.ScanFixXpressSdk Namespace : AutoSmoothBackgroundResults Class

The following tables list the members exposed by AutoSmoothBackgroundResults.

See Also

Reference

AutoSmoothBackgroundResults Class
Accusoft.ScanFixXpressSdk Namespace


BinarizeOptions Class

Accusoft.ScanFixXpress8.Net
BinarizeOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : BinarizeOptions Class
Contains parameters for the ScanFix.Binarize process.
Object Model
BinarizeOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BinarizeOptions
   Inherits EnhancementOption
'Usage

Dim instance As BinarizeOptions
public class BinarizeOptions : EnhancementOption
public __gc class BinarizeOptions : public EnhancementOption
public ref class BinarizeOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.BinarizeOptions

See Also

Reference

BinarizeOptions Members
Accusoft.ScanFixXpressSdk Namespace


BinarizeOptions Class Members

Accusoft.ScanFixXpress8.Net
BinarizeOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : BinarizeOptions Class

The following tables list the members exposed by BinarizeOptions.

Public Constructors
 | Name | Description
Public Constructor | BinarizeOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | HighThreshold | Gets and sets a value that controls letter and figure thickness.
Public Property | LceFactor | Gets and sets the sensitivity of local contrast enhancement to faint features.
Public Property | LowThreshold | Gets and sets a value that controls the background sensitivity.
Public Property | PreBlurType | Gets and sets the type of blur to apply to the image.
Top
See Also

Reference

BinarizeOptions Class
Accusoft.ScanFixXpressSdk Namespace


BinarizeOptions Class Properties

Accusoft.ScanFixXpress8.Net
BinarizeOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : BinarizeOptions Class

For a list of all members of this type, see BinarizeOptions members.

Public Properties
 | Name | Description
Public Property | HighThreshold | Gets and sets a value that controls letter and figure thickness.
Public Property | LceFactor | Gets and sets the sensitivity of local contrast enhancement to faint features.
Public Property | LowThreshold | Gets and sets a value that controls the background sensitivity.
Public Property | PreBlurType | Gets and sets the type of blur to apply to the image.
Top
See Also

Reference

BinarizeOptions Class
Accusoft.ScanFixXpressSdk Namespace


BinarizeOptions Constructor

Accusoft.ScanFixXpress8.Net
BinarizeOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > BinarizeOptions Class : BinarizeOptions Constructor
Overload List
Overload | Description
BinarizeOptions Constructor() | Instantiates a new BinarizeOptions object with the default options set.
BinarizeOptions Constructor(Int32,Int32,BinarizeBlur,Int32) | Instantiates a new BinarizeOptions object with the specified paramaters.
See Also

Reference

BinarizeOptions Class
BinarizeOptions Members


BinarizeOptions Constructor()

Accusoft.ScanFixXpress8.Net
BinarizeOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > BinarizeOptions Class > BinarizeOptions Constructor : BinarizeOptions Constructor()
Instantiates a new BinarizeOptions object with the default options set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New BinarizeOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public BinarizeOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: BinarizeOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
BinarizeOptions();
See Also

Reference

BinarizeOptions Class
BinarizeOptions Members
Overload List


BinarizeOptions Constructor(Int32,Int32,BinarizeBlur,Int32)

Accusoft.ScanFixXpress8.Net
BinarizeOptions Constructor(Int32,Int32,BinarizeBlur,Int32)

Accusoft.ScanFixXpressSdk Namespace > BinarizeOptions Class > BinarizeOptions Constructor : BinarizeOptions Constructor(Int32,Int32,BinarizeBlur,Int32)
Controls the background sensitivity. Should generally be set as high as possible without exceeding the brightness of any part of the background. Min = 0, max = 255, default = 170
Controls letter and figure thickness. Black noise appearing in the background can generally be eliminated by lowering the value of lowThreshold. Too-thick letters and figures can generally be improved by lowering the value of highThreshold. Too-thin letters and figures can generally be improved by raising the value of lowThreshold and/or highThreshold. Min = lowThreshold value, max = 255, default = 190
Controls the type of blur to apply to the image. Default = NoBlur
Controls the sensitivity of local contrast enhancement to faint features. Lower values yield less sensitivity. Min = 0, max = 255, default = 0
Instantiates a new BinarizeOptions object with the specified paramaters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal lowThreshold As Integer, _
   ByVal highThreshold As Integer, _
   ByVal preBlurType As BinarizeBlur, _
   ByVal lceFactor As Integer _
)
'Usage

Dim lowThreshold As Integer
Dim highThreshold As Integer
Dim preBlurType As BinarizeBlur
Dim lceFactor As Integer

Dim instance As New BinarizeOptions(lowThreshold, highThreshold, preBlurType, lceFactor)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public BinarizeOptions(
   int lowThreshold,
   int highThreshold,
   BinarizeBlur preBlurType,
   int lceFactor
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: BinarizeOptions(
   int lowThreshold,
   int highThreshold,
   BinarizeBlur preBlurType,
   int lceFactor
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
BinarizeOptions(
   int lowThreshold,
   int highThreshold,
   BinarizeBlur preBlurType,
   int lceFactor
)

Parameters

lowThreshold
Controls the background sensitivity. Should generally be set as high as possible without exceeding the brightness of any part of the background. Min = 0, max = 255, default = 170
highThreshold
Controls letter and figure thickness. Black noise appearing in the background can generally be eliminated by lowering the value of lowThreshold. Too-thick letters and figures can generally be improved by lowering the value of highThreshold. Too-thin letters and figures can generally be improved by raising the value of lowThreshold and/or highThreshold. Min = lowThreshold value, max = 255, default = 190
preBlurType
Controls the type of blur to apply to the image. Default = NoBlur
lceFactor
Controls the sensitivity of local contrast enhancement to faint features. Lower values yield less sensitivity. Min = 0, max = 255, default = 0
See Also

Reference

BinarizeOptions Class
BinarizeOptions Members
Overload List


HighThreshold Property

Accusoft.ScanFixXpress8.Net
HighThreshold Property

Accusoft.ScanFixXpressSdk Namespace > BinarizeOptions Class : HighThreshold Property
Gets and sets a value that controls letter and figure thickness.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HighThreshold As Integer
'Usage

Dim instance As BinarizeOptions
Dim value As Integer

instance.HighThreshold = value

value = instance.HighThreshold
public int HighThreshold {get; set;}
public: __property int get_HighThreshold();
public: __property void set_HighThreshold(
   int value
);
public:
property int HighThreshold {
   int get();
   void set (    int value);
}
Remarks

The default value is 190.

Valid values are LowThreshold to 255.

Too-thick letters and figures can generally be improved by lowering the value of HighThreshold.

Too-thin letters and figures can generally be improved by raising the value of LowThreshold and/or HighThreshold.

See Also

Reference

BinarizeOptions Class
BinarizeOptions Members


LceFactor Property

Accusoft.ScanFixXpress8.Net
LceFactor Property

Accusoft.ScanFixXpressSdk Namespace > BinarizeOptions Class : LceFactor Property
Gets and sets the sensitivity of local contrast enhancement to faint features.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LceFactor As Integer
'Usage

Dim instance As BinarizeOptions
Dim value As Integer

instance.LceFactor = value

value = instance.LceFactor
public int LceFactor {get; set;}
public: __property int get_LceFactor();
public: __property void set_LceFactor(
   int value
);
public:
property int LceFactor {
   int get();
   void set (    int value);
}
Remarks

The default value is 0.

Valid values are 0 to 255.

Lower values yield less sensitivity.

See Also

Reference

BinarizeOptions Class
BinarizeOptions Members


LowThreshold Property

Accusoft.ScanFixXpress8.Net
LowThreshold Property

Accusoft.ScanFixXpressSdk Namespace > BinarizeOptions Class : LowThreshold Property
Gets and sets a value that controls the background sensitivity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LowThreshold As Integer
'Usage

Dim instance As BinarizeOptions
Dim value As Integer

instance.LowThreshold = value

value = instance.LowThreshold
public int LowThreshold {get; set;}
public: __property int get_LowThreshold();
public: __property void set_LowThreshold(
   int value
);
public:
property int LowThreshold {
   int get();
   void set (    int value);
}
Remarks

The default value is 170.

Valid values are 0 to 255.

Should generally be set as high as possible without exceeding the brightness of any part of the background.

Black noise appearing in the background can generally be eliminated by lowering the value of LowThreshold.

Too-thin letters and figures can generally be improved by raising the value of LowThreshold and/or HighThreshold.

See Also

Reference

BinarizeOptions Class
BinarizeOptions Members


PreBlurType Property

Accusoft.ScanFixXpress8.Net
PreBlurType Property

Accusoft.ScanFixXpressSdk Namespace > BinarizeOptions Class : PreBlurType Property
Gets and sets the type of blur to apply to the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PreBlurType As BinarizeBlur
'Usage

Dim instance As BinarizeOptions
Dim value As BinarizeBlur

instance.PreBlurType = value

value = instance.PreBlurType
public BinarizeBlur PreBlurType {get; set;}
public: __property BinarizeBlur get_PreBlurType();
public: __property void set_PreBlurType(
   BinarizeBlur value
);
public:
property BinarizeBlur PreBlurType {
   BinarizeBlur get();
   void set (    BinarizeBlur value);
}
Remarks

The default value is NoBlur.

See Also

Reference

BinarizeOptions Class
BinarizeOptions Members


BinarizeResults Class

Accusoft.ScanFixXpress8.Net
BinarizeResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : BinarizeResults Class
Defines a place holder class for the Binarize enhancement result.
Object Model
BinarizeResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BinarizeResults
   Inherits EnhancementResult
'Usage

Dim instance As BinarizeResults
public class BinarizeResults : EnhancementResult
public __gc class BinarizeResults : public EnhancementResult
public ref class BinarizeResults : public EnhancementResult
Remarks
This class contains no data. Its presence in the results list is used to determine that the operation has run successfully.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.BinarizeResults

See Also

Reference

BinarizeResults Members
Accusoft.ScanFixXpressSdk Namespace


BinarizeResults Class Members

Accusoft.ScanFixXpress8.Net
BinarizeResults Class Members

Accusoft.ScanFixXpressSdk Namespace : BinarizeResults Class

The following tables list the members exposed by BinarizeResults.

See Also

Reference

BinarizeResults Class
Accusoft.ScanFixXpressSdk Namespace


BlankPageDetectOptions Class

Accusoft.ScanFixXpress8.Net
BlankPageDetectOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : BlankPageDetectOptions Class
Contains parameters for the ScanFix.DetectBlankPage process.
Object Model
BlankPageDetectOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BlankPageDetectOptions
   Inherits EnhancementOption
'Usage

Dim instance As BlankPageDetectOptions
public class BlankPageDetectOptions : EnhancementOption
public __gc class BlankPageDetectOptions : public EnhancementOption
public ref class BlankPageDetectOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.BlankPageDetectOptions

See Also

Reference

BlankPageDetectOptions Members
Accusoft.ScanFixXpressSdk Namespace


BlankPageDetectOptions Class Members

Accusoft.ScanFixXpress8.Net
BlankPageDetectOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : BlankPageDetectOptions Class

The following tables list the members exposed by BlankPageDetectOptions.

Public Constructors
 | Name | Description
Public Constructor | BlankPageDetectOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BottomMargin | Gets and sets the number of rows of pixels to ignore on the bottom edge of the image.
Public Property | GapFill | Gets and sets the maximum spacing between black objects that should be considered connected.
Public Property | IgnoreBorder | Gets and sets a flag that tells the operation to do a quick search for overscan in the border, and will adjust the detection area to move it inside the detected overscanned border.
Public Property | LeftMargin | Gets and sets the number of columns of pixels to ignore on the left edge of the image.
Public Property | MinimumContrast | Gets and sets the minimum level of contrast between background and foreground.
Public Property | MinimumObjectDimension | Gets and sets the minimum width or height of a black object that should be considered non-blank.
Public Property | RightMargin | Gets and sets the number of columns of pixels to ignore on the right edge of the image.
Public Property | TopMargin | Gets and sets the number of pixels to ignore on the top edge of the image.
Top
See Also

Reference

BlankPageDetectOptions Class
Accusoft.ScanFixXpressSdk Namespace


BlankPageDetectOptions Class Properties

Accusoft.ScanFixXpress8.Net
BlankPageDetectOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : BlankPageDetectOptions Class

For a list of all members of this type, see BlankPageDetectOptions members.

Public Properties
 | Name | Description
Public Property | BottomMargin | Gets and sets the number of rows of pixels to ignore on the bottom edge of the image.
Public Property | GapFill | Gets and sets the maximum spacing between black objects that should be considered connected.
Public Property | IgnoreBorder | Gets and sets a flag that tells the operation to do a quick search for overscan in the border, and will adjust the detection area to move it inside the detected overscanned border.
Public Property | LeftMargin | Gets and sets the number of columns of pixels to ignore on the left edge of the image.
Public Property | MinimumContrast | Gets and sets the minimum level of contrast between background and foreground.
Public Property | MinimumObjectDimension | Gets and sets the minimum width or height of a black object that should be considered non-blank.
Public Property | RightMargin | Gets and sets the number of columns of pixels to ignore on the right edge of the image.
Public Property | TopMargin | Gets and sets the number of pixels to ignore on the top edge of the image.
Top
See Also

Reference

BlankPageDetectOptions Class
Accusoft.ScanFixXpressSdk Namespace


BlankPageDetectOptions Constructor

Accusoft.ScanFixXpress8.Net
BlankPageDetectOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > BlankPageDetectOptions Class : BlankPageDetectOptions Constructor
Overload List
Overload | Description
BlankPageDetectOptions Constructor() | Instantiates a new BlankPageDetectOptions object with the default values set.
BlankPageDetectOptions Constructor(Int32,Int32,Int32,Int32,Boolean,Int32,Int32,Int32) | Instantiates a new BlankPageDetectOptions object setting the specified values.
See Also

Reference

BlankPageDetectOptions Class
BlankPageDetectOptions Members


BlankPageDetectOptions Constructor()

Accusoft.ScanFixXpress8.Net
BlankPageDetectOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > BlankPageDetectOptions Class > BlankPageDetectOptions Constructor : BlankPageDetectOptions Constructor()
Instantiates a new BlankPageDetectOptions object with the default values set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New BlankPageDetectOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public BlankPageDetectOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: BlankPageDetectOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
BlankPageDetectOptions();
See Also

Reference

BlankPageDetectOptions Class
BlankPageDetectOptions Members
Overload List


BlankPageDetectOptions Constructor(Int32,Int32,Int32,Int32,Boolean,Int32,Int32,Int32)

Accusoft.ScanFixXpress8.Net
BlankPageDetectOptions Constructor(Int32,Int32,Int32,Int32,Boolean,Int32,Int32,Int32)

Accusoft.ScanFixXpressSdk Namespace > BlankPageDetectOptions Class > BlankPageDetectOptions Constructor : BlankPageDetectOptions Constructor(Int32,Int32,Int32,Int32,Boolean,Int32,Int32,Int32)
The number of pixels to ignore on the top edge of the image.
The number of rows of pixels to ignore on the bottom edge of the image.
The number of rows of pixels to ignore on the left edge of the image.
The number of rows of pixels to ignore on the right edge of the image.
A flag that tells the operation to do a quick search for overscan in the border, and will adjust the detection area to move it inside the detected overscanned border.
The minimum width or height of a black object that should be considered non-blank.
The maximum spacing between black objects that should be considered connected.
The minimum contrast between foreground and background for color and gray images
Instantiates a new BlankPageDetectOptions object setting the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal topMargin As Integer, _
   ByVal bottomMargin As Integer, _
   ByVal leftMargin As Integer, _
   ByVal rightMargin As Integer, _
   ByVal ignoreBorder As Boolean, _
   ByVal minimumObjectDimension As Integer, _
   ByVal gapFill As Integer, _
   ByVal minimumContrast As Integer _
)
'Usage

Dim topMargin As Integer
Dim bottomMargin As Integer
Dim leftMargin As Integer
Dim rightMargin As Integer
Dim ignoreBorder As Boolean
Dim minimumObjectDimension As Integer
Dim gapFill As Integer
Dim minimumContrast As Integer

Dim instance As New BlankPageDetectOptions(topMargin, bottomMargin, leftMargin, rightMargin, ignoreBorder, minimumObjectDimension, gapFill, minimumContrast)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public BlankPageDetectOptions(
   int topMargin,
   int bottomMargin,
   int leftMargin,
   int rightMargin,
   bool ignoreBorder,
   int minimumObjectDimension,
   int gapFill,
   int minimumContrast
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: BlankPageDetectOptions(
   int topMargin,
   int bottomMargin,
   int leftMargin,
   int rightMargin,
   bool ignoreBorder,
   int minimumObjectDimension,
   int gapFill,
   int minimumContrast
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
BlankPageDetectOptions(
   int topMargin,
   int bottomMargin,
   int leftMargin,
   int rightMargin,
   bool ignoreBorder,
   int minimumObjectDimension,
   int gapFill,
   int minimumContrast
)

Parameters

topMargin
The number of pixels to ignore on the top edge of the image.
bottomMargin
The number of rows of pixels to ignore on the bottom edge of the image.
leftMargin
The number of rows of pixels to ignore on the left edge of the image.
rightMargin
The number of rows of pixels to ignore on the right edge of the image.
ignoreBorder
A flag that tells the operation to do a quick search for overscan in the border, and will adjust the detection area to move it inside the detected overscanned border.
minimumObjectDimension
The minimum width or height of a black object that should be considered non-blank.
gapFill
The maximum spacing between black objects that should be considered connected.
minimumContrast
The minimum contrast between foreground and background for color and gray images
See Also

Reference

BlankPageDetectOptions Class
BlankPageDetectOptions Members
Overload List


BottomMargin Property

Accusoft.ScanFixXpress8.Net
BottomMargin Property

Accusoft.ScanFixXpressSdk Namespace > BlankPageDetectOptions Class : BottomMargin Property
Gets and sets the number of rows of pixels to ignore on the bottom edge of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BottomMargin As Integer
'Usage

Dim instance As BlankPageDetectOptions
Dim value As Integer

instance.BottomMargin = value

value = instance.BottomMargin
public int BottomMargin {get; set;}
public: __property int get_BottomMargin();
public: __property void set_BottomMargin(
   int value
);
public:
property int BottomMargin {
   int get();
   void set (    int value);
}
Remarks

The default value is 0.

Valid values are 0 to {image height}.

See Also

Reference

BlankPageDetectOptions Class
BlankPageDetectOptions Members


GapFill Property (BlankPageDetectOptions)

Accusoft.ScanFixXpress8.Net
GapFill Property (BlankPageDetectOptions)

Accusoft.ScanFixXpressSdk Namespace > BlankPageDetectOptions Class : GapFill Property
Gets and sets the maximum spacing between black objects that should be considered connected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GapFill As Integer
'Usage

Dim instance As BlankPageDetectOptions
Dim value As Integer

instance.GapFill = value

value = instance.GapFill
public int GapFill {get; set;}
public: __property int get_GapFill();
public: __property void set_GapFill(
   int value
);
public:
property int GapFill {
   int get();
   void set (    int value);
}
Remarks

The default value is 5.

Valid values are 0 to (the larger of image width or height).

See Also

Reference

BlankPageDetectOptions Class
BlankPageDetectOptions Members


IgnoreBorder Property (BlankPageDetectOptions)

Accusoft.ScanFixXpress8.Net
IgnoreBorder Property (BlankPageDetectOptions)

Accusoft.ScanFixXpressSdk Namespace > BlankPageDetectOptions Class : IgnoreBorder Property
Gets and sets a flag that tells the operation to do a quick search for overscan in the border, and will adjust the detection area to move it inside the detected overscanned border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IgnoreBorder As Boolean
'Usage

Dim instance As BlankPageDetectOptions
Dim value As Boolean

instance.IgnoreBorder = value

value = instance.IgnoreBorder
public bool IgnoreBorder {get; set;}
public: __property bool get_IgnoreBorder();
public: __property void set_IgnoreBorder(
   bool value
);
public:
property bool IgnoreBorder {
   bool get();
   void set (    bool value);
}
Remarks

The default value is false.

See Also

Reference

BlankPageDetectOptions Class
BlankPageDetectOptions Members


LeftMargin Property

Accusoft.ScanFixXpress8.Net
LeftMargin Property

Accusoft.ScanFixXpressSdk Namespace > BlankPageDetectOptions Class : LeftMargin Property
Gets and sets the number of columns of pixels to ignore on the left edge of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LeftMargin As Integer
'Usage

Dim instance As BlankPageDetectOptions
Dim value As Integer

instance.LeftMargin = value

value = instance.LeftMargin
public int LeftMargin {get; set;}
public: __property int get_LeftMargin();
public: __property void set_LeftMargin(
   int value
);
public:
property int LeftMargin {
   int get();
   void set (    int value);
}
Remarks

The default value is 0.

Valid values are 0 to {image width}.

See Also

Reference

BlankPageDetectOptions Class
BlankPageDetectOptions Members


MinimumContrast Property (BlankPageDetectOptions)

Accusoft.ScanFixXpress8.Net
MinimumContrast Property (BlankPageDetectOptions)

Accusoft.ScanFixXpressSdk Namespace > BlankPageDetectOptions Class : MinimumContrast Property
Gets and sets the minimum level of contrast between background and foreground.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumContrast As Integer
'Usage

Dim instance As BlankPageDetectOptions
Dim value As Integer

instance.MinimumContrast = value

value = instance.MinimumContrast
public int MinimumContrast {get; set;}
public: __property int get_MinimumContrast();
public: __property void set_MinimumContrast(
   int value
);
public:
property int MinimumContrast {
   int get();
   void set (    int value);
}
Remarks

The default value is 64.

Valid values are 1 to 255.

This property is only used when analyzing color or grayscale images - it will be ignored for bitonal images.

See Also

Reference

BlankPageDetectOptions Class
BlankPageDetectOptions Members


MinimumObjectDimension Property (BlankPageDetectOptions)

Accusoft.ScanFixXpress8.Net
MinimumObjectDimension Property (BlankPageDetectOptions)

Accusoft.ScanFixXpressSdk Namespace > BlankPageDetectOptions Class : MinimumObjectDimension Property
Gets and sets the minimum width or height of a black object that should be considered non-blank.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumObjectDimension As Integer
'Usage

Dim instance As BlankPageDetectOptions
Dim value As Integer

instance.MinimumObjectDimension = value

value = instance.MinimumObjectDimension
public int MinimumObjectDimension {get; set;}
public: __property int get_MinimumObjectDimension();
public: __property void set_MinimumObjectDimension(
   int value
);
public:
property int MinimumObjectDimension {
   int get();
   void set (    int value);
}
Remarks

The default value is 10.

Valid values are 1 to (the smaller of image width or height).

See Also

Reference

BlankPageDetectOptions Class
BlankPageDetectOptions Members


RightMargin Property

Accusoft.ScanFixXpress8.Net
RightMargin Property

Accusoft.ScanFixXpressSdk Namespace > BlankPageDetectOptions Class : RightMargin Property
Gets and sets the number of columns of pixels to ignore on the right edge of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RightMargin As Integer
'Usage

Dim instance As BlankPageDetectOptions
Dim value As Integer

instance.RightMargin = value

value = instance.RightMargin
public int RightMargin {get; set;}
public: __property int get_RightMargin();
public: __property void set_RightMargin(
   int value
);
public:
property int RightMargin {
   int get();
   void set (    int value);
}
Remarks

The default value is 0.

Valid values are 0 to {image width}.

See Also

Reference

BlankPageDetectOptions Class
BlankPageDetectOptions Members


TopMargin Property

Accusoft.ScanFixXpress8.Net
TopMargin Property

Accusoft.ScanFixXpressSdk Namespace > BlankPageDetectOptions Class : TopMargin Property
Gets and sets the number of pixels to ignore on the top edge of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TopMargin As Integer
'Usage

Dim instance As BlankPageDetectOptions
Dim value As Integer

instance.TopMargin = value

value = instance.TopMargin
public int TopMargin {get; set;}
public: __property int get_TopMargin();
public: __property void set_TopMargin(
   int value
);
public:
property int TopMargin {
   int get();
   void set (    int value);
}
Remarks

The default value is 0.

Valid values are 0 to {image height}.

See Also

Reference

BlankPageDetectOptions Class
BlankPageDetectOptions Members


BlankPageDetectResults Class

Accusoft.ScanFixXpress8.Net
BlankPageDetectResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : BlankPageDetectResults Class
Contains output values from the blank page detect process.
Object Model
BlankPageDetectResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BlankPageDetectResults
   Inherits EnhancementResult
'Usage

Dim instance As BlankPageDetectResults
public class BlankPageDetectResults : EnhancementResult
public __gc class BlankPageDetectResults : public EnhancementResult
public ref class BlankPageDetectResults : public EnhancementResult
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.BlankPageDetectResults

See Also

Reference

BlankPageDetectResults Members
Accusoft.ScanFixXpressSdk Namespace


BlankPageDetectResults Class Members

Accusoft.ScanFixXpress8.Net
BlankPageDetectResults Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : BlankPageDetectResults Class

The following tables list the members exposed by BlankPageDetectResults.

Public Properties
 | Name | Description
Public Property | Confidence | Gets the confidence of the blank page detection process.
Public Property | IsBlank | Gets a flag that indicates whether the page was determined to be blank.
Top
See Also

Reference

BlankPageDetectResults Class
Accusoft.ScanFixXpressSdk Namespace


BlankPageDetectResults Class Properties

Accusoft.ScanFixXpress8.Net
BlankPageDetectResults Class Properties

Accusoft.ScanFixXpressSdk Namespace : BlankPageDetectResults Class

For a list of all members of this type, see BlankPageDetectResults members.

Public Properties
 | Name | Description
Public Property | Confidence | Gets the confidence of the blank page detection process.
Public Property | IsBlank | Gets a flag that indicates whether the page was determined to be blank.
Top
See Also

Reference

BlankPageDetectResults Class
Accusoft.ScanFixXpressSdk Namespace


Confidence Property (BlankPageDetectResults)

Accusoft.ScanFixXpress8.Net
Confidence Property (BlankPageDetectResults)

Accusoft.ScanFixXpressSdk Namespace > BlankPageDetectResults Class : Confidence Property
Gets the confidence of the blank page detection process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Confidence As Integer
'Usage

Dim instance As BlankPageDetectResults
Dim value As Integer

value = instance.Confidence
public int Confidence {get;}
public: __property int get_Confidence();
public:
property int Confidence {
   int get();
}

Property Value

An integer value which represents the confidence.
Remarks

The value range is between 0 and 100.

Higher values indicate a higher confidence that the blank page was accurately detected.

See Also

Reference

BlankPageDetectResults Class
BlankPageDetectResults Members


IsBlank Property (BlankPageDetectResults)

Accusoft.ScanFixXpress8.Net
IsBlank Property (BlankPageDetectResults)

Accusoft.ScanFixXpressSdk Namespace > BlankPageDetectResults Class : IsBlank Property
Gets a flag that indicates whether the page was determined to be blank.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsBlank As Boolean
'Usage

Dim instance As BlankPageDetectResults
Dim value As Boolean

value = instance.IsBlank
public bool IsBlank {get;}
public: __property bool get_IsBlank();
public:
property bool IsBlank {
   bool get();
}

Property Value

A boolean value which represents if the page is determined to be blank or not.
Remarks

The default value is false.

The value is based on whether any objects over the size threshold were found in the given region. More and larger objects produces a high confidence for a non-blank page, while a large number of objects near the threshold will produce a low confidence for a blank page.

See Also

Reference

BlankPageDetectResults Class
BlankPageDetectResults Members


BlankRectangleDetectOptions Class

Accusoft.ScanFixXpress8.Net
BlankRectangleDetectOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : BlankRectangleDetectOptions Class
Contains parameters for the ScanFix.DetectBlankRectangle process.
Object Model
BlankRectangleDetectOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BlankRectangleDetectOptions
   Inherits EnhancementOption
'Usage

Dim instance As BlankRectangleDetectOptions
public class BlankRectangleDetectOptions : EnhancementOption
public __gc class BlankRectangleDetectOptions : public EnhancementOption
public ref class BlankRectangleDetectOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.BlankRectangleDetectOptions

See Also

Reference

BlankRectangleDetectOptions Members
Accusoft.ScanFixXpressSdk Namespace


BlankRectangleDetectOptions Class Members

Accusoft.ScanFixXpress8.Net
BlankRectangleDetectOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : BlankRectangleDetectOptions Class

The following tables list the members exposed by BlankRectangleDetectOptions.

Public Constructors
 | Name | Description
Public Constructor | BlankRectangleDetectOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Area | Gets and sets the rectangular area that specifies the location to examine for blankness.
Public Property | GapFill | Gets and sets the maximum spacing between objects that should be considered connected.
Public Property | IgnoreBorder | Gets and sets a flag that tells the operation to do a quick search for overscan in the border, and will adjust the detection area to move it inside the detected overscanned border.
Public Property | MinimumContrast | Gets and sets the minimum level of contrast between background and foreground.
Public Property | MinimumObjectDimension | Gets and sets the minimum width or height of a object that should be considered non-blank.
Top
See Also

Reference

BlankRectangleDetectOptions Class
Accusoft.ScanFixXpressSdk Namespace


BlankRectangleDetectOptions Class Properties

Accusoft.ScanFixXpress8.Net
BlankRectangleDetectOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : BlankRectangleDetectOptions Class

For a list of all members of this type, see BlankRectangleDetectOptions members.

Public Properties
 | Name | Description
Public Property | Area | Gets and sets the rectangular area that specifies the location to examine for blankness.
Public Property | GapFill | Gets and sets the maximum spacing between objects that should be considered connected.
Public Property | IgnoreBorder | Gets and sets a flag that tells the operation to do a quick search for overscan in the border, and will adjust the detection area to move it inside the detected overscanned border.
Public Property | MinimumContrast | Gets and sets the minimum level of contrast between background and foreground.
Public Property | MinimumObjectDimension | Gets and sets the minimum width or height of a object that should be considered non-blank.
Top
See Also

Reference

BlankRectangleDetectOptions Class
Accusoft.ScanFixXpressSdk Namespace


BlankRectangleDetectOptions Constructor

Accusoft.ScanFixXpress8.Net
BlankRectangleDetectOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > BlankRectangleDetectOptions Class : BlankRectangleDetectOptions Constructor
Overload List
Overload | Description
BlankRectangleDetectOptions Constructor() | Instantiates a new BlankRectangleDetectOptions object with the default values set.
BlankRectangleDetectOptions Constructor(Rectangle,Boolean,Int32,Int32) | Instantiates a new BlankRectangleDetectOptions object with specified values.
BlankRectangleDetectOptions Constructor(Rectangle,Boolean,Int32,Int32,Int32) | Instantiates a new BlankRectangleDetectOptions object with specified values.
See Also

Reference

BlankRectangleDetectOptions Class
BlankRectangleDetectOptions Members


BlankRectangleDetectOptions Constructor()

Accusoft.ScanFixXpress8.Net
BlankRectangleDetectOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > BlankRectangleDetectOptions Class > BlankRectangleDetectOptions Constructor : BlankRectangleDetectOptions Constructor()
Instantiates a new BlankRectangleDetectOptions object with the default values set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New BlankRectangleDetectOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public BlankRectangleDetectOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: BlankRectangleDetectOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
BlankRectangleDetectOptions();
See Also

Reference

BlankRectangleDetectOptions Class
BlankRectangleDetectOptions Members
Overload List


BlankRectangleDetectOptions Constructor(Rectangle,Boolean,Int32,Int32)

Accusoft.ScanFixXpress8.Net
BlankRectangleDetectOptions Constructor(Rectangle,Boolean,Int32,Int32)

Accusoft.ScanFixXpressSdk Namespace > BlankRectangleDetectOptions Class > BlankRectangleDetectOptions Constructor : BlankRectangleDetectOptions Constructor(Rectangle,Boolean,Int32,Int32)
The rectangle specifying the location to examine for blankness.
A flag that tells the operation to do a quick search for overscan in the border, and will adjust the detection area to move it inside the detected overscanned border.
The minimum width or height of a black object that should be considered non-blank.
The maximum spacing between black objects that should be considered connected.
Instantiates a new BlankRectangleDetectOptions object with specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal area As Rectangle, _
   ByVal ignoreBorder As Boolean, _
   ByVal minimumObjectDimension As Integer, _
   ByVal gapFill As Integer _
)
'Usage

Dim area As Rectangle
Dim ignoreBorder As Boolean
Dim minimumObjectDimension As Integer
Dim gapFill As Integer

Dim instance As New BlankRectangleDetectOptions(area, ignoreBorder, minimumObjectDimension, gapFill)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public BlankRectangleDetectOptions(
   Rectangle area,
   bool ignoreBorder,
   int minimumObjectDimension,
   int gapFill
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: BlankRectangleDetectOptions(
   Rectangle area,
   bool ignoreBorder,
   int minimumObjectDimension,
   int gapFill
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
BlankRectangleDetectOptions(
   Rectangle area,
   bool ignoreBorder,
   int minimumObjectDimension,
   int gapFill
)

Parameters

area
The rectangle specifying the location to examine for blankness.
ignoreBorder
A flag that tells the operation to do a quick search for overscan in the border, and will adjust the detection area to move it inside the detected overscanned border.
minimumObjectDimension
The minimum width or height of a black object that should be considered non-blank.
gapFill
The maximum spacing between black objects that should be considered connected.
Remarks
Use this in order to maintain compatibility with the ScanFix Xpress 5 constructor for this object. The MinimumContrast property is set to default value.
See Also

Reference

BlankRectangleDetectOptions Class
BlankRectangleDetectOptions Members
Overload List


BlankRectangleDetectOptions Constructor(Rectangle,Boolean,Int32,Int32,Int32)

Accusoft.ScanFixXpress8.Net
BlankRectangleDetectOptions Constructor(Rectangle,Boolean,Int32,Int32,Int32)

Accusoft.ScanFixXpressSdk Namespace > BlankRectangleDetectOptions Class > BlankRectangleDetectOptions Constructor : BlankRectangleDetectOptions Constructor(Rectangle,Boolean,Int32,Int32,Int32)
The rectangle specifying the location to examine for blankness.
A flag that tells the operation to do a quick search for overscan in the border, and will adjust the detection area to move it inside the detected overscanned border.
The minimum width or height of a black object that should be considered non-blank.
The maximum spacing between black objects that should be considered connected.
The minimum contrast between foreground and background for color and gray images
Instantiates a new BlankRectangleDetectOptions object with specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal area As Rectangle, _
   ByVal ignoreBorder As Boolean, _
   ByVal minimumObjectDimension As Integer, _
   ByVal gapFill As Integer, _
   ByVal minimumContrast As Integer _
)
'Usage

Dim area As Rectangle
Dim ignoreBorder As Boolean
Dim minimumObjectDimension As Integer
Dim gapFill As Integer
Dim minimumContrast As Integer

Dim instance As New BlankRectangleDetectOptions(area, ignoreBorder, minimumObjectDimension, gapFill, minimumContrast)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public BlankRectangleDetectOptions(
   Rectangle area,
   bool ignoreBorder,
   int minimumObjectDimension,
   int gapFill,
   int minimumContrast
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: BlankRectangleDetectOptions(
   Rectangle area,
   bool ignoreBorder,
   int minimumObjectDimension,
   int gapFill,
   int minimumContrast
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
BlankRectangleDetectOptions(
   Rectangle area,
   bool ignoreBorder,
   int minimumObjectDimension,
   int gapFill,
   int minimumContrast
)

Parameters

area
The rectangle specifying the location to examine for blankness.
ignoreBorder
A flag that tells the operation to do a quick search for overscan in the border, and will adjust the detection area to move it inside the detected overscanned border.
minimumObjectDimension
The minimum width or height of a black object that should be considered non-blank.
gapFill
The maximum spacing between black objects that should be considered connected.
minimumContrast
The minimum contrast between foreground and background for color and gray images
Remarks
Use this in order to the MinimumContrast property is set to the desired value.
See Also

Reference

BlankRectangleDetectOptions Class
BlankRectangleDetectOptions Members
Overload List


Area Property (BlankRectangleDetectOptions)

Accusoft.ScanFixXpress8.Net
Area Property (BlankRectangleDetectOptions)

Accusoft.ScanFixXpressSdk Namespace > BlankRectangleDetectOptions Class : Area Property
Gets and sets the rectangular area that specifies the location to examine for blankness.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Area As Rectangle
'Usage

Dim instance As BlankRectangleDetectOptions
Dim value As Rectangle

instance.Area = value

value = instance.Area
public Rectangle Area {get; set;}
public: __property Rectangle get_Area();
public: __property void set_Area(
   Rectangle value
);
public:
property Rectangle Area {
   Rectangle get();
   void set (    Rectangle value);
}
Remarks

The default value is 0, 0, 0, 0.

See Also

Reference

BlankRectangleDetectOptions Class
BlankRectangleDetectOptions Members


GapFill Property (BlankRectangleDetectOptions)

Accusoft.ScanFixXpress8.Net
GapFill Property (BlankRectangleDetectOptions)

Accusoft.ScanFixXpressSdk Namespace > BlankRectangleDetectOptions Class : GapFill Property
Gets and sets the maximum spacing between objects that should be considered connected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GapFill As Integer
'Usage

Dim instance As BlankRectangleDetectOptions
Dim value As Integer

instance.GapFill = value

value = instance.GapFill
public int GapFill {get; set;}
public: __property int get_GapFill();
public: __property void set_GapFill(
   int value
);
public:
property int GapFill {
   int get();
   void set (    int value);
}
Remarks

The default value is 5.

Valid values are 0 to (the larger of image height or width).

See Also

Reference

BlankRectangleDetectOptions Class
BlankRectangleDetectOptions Members


IgnoreBorder Property (BlankRectangleDetectOptions)

Accusoft.ScanFixXpress8.Net
IgnoreBorder Property (BlankRectangleDetectOptions)

Accusoft.ScanFixXpressSdk Namespace > BlankRectangleDetectOptions Class : IgnoreBorder Property
Gets and sets a flag that tells the operation to do a quick search for overscan in the border, and will adjust the detection area to move it inside the detected overscanned border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IgnoreBorder As Boolean
'Usage

Dim instance As BlankRectangleDetectOptions
Dim value As Boolean

instance.IgnoreBorder = value

value = instance.IgnoreBorder
public bool IgnoreBorder {get; set;}
public: __property bool get_IgnoreBorder();
public: __property void set_IgnoreBorder(
   bool value
);
public:
property bool IgnoreBorder {
   bool get();
   void set (    bool value);
}
Remarks

The default value is false.

See Also

Reference

BlankRectangleDetectOptions Class
BlankRectangleDetectOptions Members


MinimumContrast Property (BlankRectangleDetectOptions)

Accusoft.ScanFixXpress8.Net
MinimumContrast Property (BlankRectangleDetectOptions)

Accusoft.ScanFixXpressSdk Namespace > BlankRectangleDetectOptions Class : MinimumContrast Property
Gets and sets the minimum level of contrast between background and foreground.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumContrast As Integer
'Usage

Dim instance As BlankRectangleDetectOptions
Dim value As Integer

instance.MinimumContrast = value

value = instance.MinimumContrast
public int MinimumContrast {get; set;}
public: __property int get_MinimumContrast();
public: __property void set_MinimumContrast(
   int value
);
public:
property int MinimumContrast {
   int get();
   void set (    int value);
}
Remarks

The default value is 64.

Valid values are 1 to 255.

This property is only used when analyzing color or grayscale images - it will be ignored for bitonal images.

See Also

Reference

BlankRectangleDetectOptions Class
BlankRectangleDetectOptions Members


MinimumObjectDimension Property (BlankRectangleDetectOptions)

Accusoft.ScanFixXpress8.Net
MinimumObjectDimension Property (BlankRectangleDetectOptions)

Accusoft.ScanFixXpressSdk Namespace > BlankRectangleDetectOptions Class : MinimumObjectDimension Property
Gets and sets the minimum width or height of a object that should be considered non-blank.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumObjectDimension As Integer
'Usage

Dim instance As BlankRectangleDetectOptions
Dim value As Integer

instance.MinimumObjectDimension = value

value = instance.MinimumObjectDimension
public int MinimumObjectDimension {get; set;}
public: __property int get_MinimumObjectDimension();
public: __property void set_MinimumObjectDimension(
   int value
);
public:
property int MinimumObjectDimension {
   int get();
   void set (    int value);
}
Remarks

The default value is 10.

Valid values are 0 to (the smaller of image height or width).

See Also

Reference

BlankRectangleDetectOptions Class
BlankRectangleDetectOptions Members


BlankRectangleDetectResults Class

Accusoft.ScanFixXpress8.Net
BlankRectangleDetectResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : BlankRectangleDetectResults Class
Contains output values from the blank rectangle detect process.
Object Model
BlankRectangleDetectResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BlankRectangleDetectResults
   Inherits EnhancementResult
'Usage

Dim instance As BlankRectangleDetectResults
public class BlankRectangleDetectResults : EnhancementResult
public __gc class BlankRectangleDetectResults : public EnhancementResult
public ref class BlankRectangleDetectResults : public EnhancementResult
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.BlankRectangleDetectResults

See Also

Reference

BlankRectangleDetectResults Members
Accusoft.ScanFixXpressSdk Namespace


BlankRectangleDetectResults Class Members

Accusoft.ScanFixXpress8.Net
BlankRectangleDetectResults Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : BlankRectangleDetectResults Class

The following tables list the members exposed by BlankRectangleDetectResults.

Public Properties
 | Name | Description
Public Property | Confidence | Gets the confidence of the blank rectangle detection process.
Public Property | IsBlank | Gets a flag that indicates whether the rectangle was determined to be blank.
Top
See Also

Reference

BlankRectangleDetectResults Class
Accusoft.ScanFixXpressSdk Namespace


BlankRectangleDetectResults Class Properties

Accusoft.ScanFixXpress8.Net
BlankRectangleDetectResults Class Properties

Accusoft.ScanFixXpressSdk Namespace : BlankRectangleDetectResults Class

For a list of all members of this type, see BlankRectangleDetectResults members.

Public Properties
 | Name | Description
Public Property | Confidence | Gets the confidence of the blank rectangle detection process.
Public Property | IsBlank | Gets a flag that indicates whether the rectangle was determined to be blank.
Top
See Also

Reference

BlankRectangleDetectResults Class
Accusoft.ScanFixXpressSdk Namespace


Confidence Property (BlankRectangleDetectResults)

Accusoft.ScanFixXpress8.Net
Confidence Property (BlankRectangleDetectResults)

Accusoft.ScanFixXpressSdk Namespace > BlankRectangleDetectResults Class : Confidence Property
Gets the confidence of the blank rectangle detection process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Confidence As Integer
'Usage

Dim instance As BlankRectangleDetectResults
Dim value As Integer

value = instance.Confidence
public int Confidence {get;}
public: __property int get_Confidence();
public:
property int Confidence {
   int get();
}

Property Value

An integer value which represents the confidence.
Remarks

The value range is between 0 and 100.

The value is based on whether any objects over the size threshold were found in the given region. More and larger objects produces a high confidence for a non-blank region, while a large number of objects near the threshold will produce a low confidence for a blank region.

See Also

Reference

BlankRectangleDetectResults Class
BlankRectangleDetectResults Members


IsBlank Property (BlankRectangleDetectResults)

Accusoft.ScanFixXpress8.Net
IsBlank Property (BlankRectangleDetectResults)

Accusoft.ScanFixXpressSdk Namespace > BlankRectangleDetectResults Class : IsBlank Property
Gets a flag that indicates whether the rectangle was determined to be blank.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsBlank As Boolean
'Usage

Dim instance As BlankRectangleDetectResults
Dim value As Boolean

value = instance.IsBlank
public bool IsBlank {get;}
public: __property bool get_IsBlank();
public:
property bool IsBlank {
   bool get();
}

Property Value

A boolean value which is true if the rectangle is determined to be blank or not. Otherwise, false is returned.
See Also

Reference

BlankRectangleDetectResults Class
BlankRectangleDetectResults Members


BlobRemovalOptions Class

Accusoft.ScanFixXpress8.Net
BlobRemovalOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : BlobRemovalOptions Class
Contains parameters that control the ScanFix.RemoveBlobs process.
Object Model
BlobRemovalOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BlobRemovalOptions
   Inherits EnhancementOption
'Usage

Dim instance As BlobRemovalOptions
public class BlobRemovalOptions : EnhancementOption
public __gc class BlobRemovalOptions : public EnhancementOption
public ref class BlobRemovalOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.BlobRemovalOptions

See Also

Reference

BlobRemovalOptions Members
Accusoft.ScanFixXpressSdk Namespace


BlobRemovalOptions Class Members

Accusoft.ScanFixXpress8.Net
BlobRemovalOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : BlobRemovalOptions Class

The following tables list the members exposed by BlobRemovalOptions.

Public Constructors
 | Name | Description
Public Constructor | BlobRemovalOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Area | Gets and sets the location and size of the rectangular area of the image where the blob removal process will search.
Public Property | MaximumPixelCount | Gets and sets the maximum number of pixels for an object to be considered a blob for removal purposes.
Public Property | MinimumDensity | Gets and sets the ratio of black pixels to all pixels within the convex hull of an object.
Public Property | MinimumPixelCount | Gets and sets the minimum number of pixels for an object to be considered a blob for removal purposes.
Top
See Also

Reference

BlobRemovalOptions Class
Accusoft.ScanFixXpressSdk Namespace


BlobRemovalOptions Class Properties

Accusoft.ScanFixXpress8.Net
BlobRemovalOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : BlobRemovalOptions Class

For a list of all members of this type, see BlobRemovalOptions members.

Public Properties
 | Name | Description
Public Property | Area | Gets and sets the location and size of the rectangular area of the image where the blob removal process will search.
Public Property | MaximumPixelCount | Gets and sets the maximum number of pixels for an object to be considered a blob for removal purposes.
Public Property | MinimumDensity | Gets and sets the ratio of black pixels to all pixels within the convex hull of an object.
Public Property | MinimumPixelCount | Gets and sets the minimum number of pixels for an object to be considered a blob for removal purposes.
Top
See Also

Reference

BlobRemovalOptions Class
Accusoft.ScanFixXpressSdk Namespace


BlobRemovalOptions Constructor

Accusoft.ScanFixXpress8.Net
BlobRemovalOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > BlobRemovalOptions Class : BlobRemovalOptions Constructor
Overload List
Overload | Description
BlobRemovalOptions Constructor() | Instantiates a new BlobRemovalOptions object setting the default values.
BlobRemovalOptions Constructor(Rectangle,Int32,Int32,Int32) | Instantiates a new BlobRemovalOptions object setting the specified values.
See Also

Reference

BlobRemovalOptions Class
BlobRemovalOptions Members


BlobRemovalOptions Constructor()

Accusoft.ScanFixXpress8.Net
BlobRemovalOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > BlobRemovalOptions Class > BlobRemovalOptions Constructor : BlobRemovalOptions Constructor()
Instantiates a new BlobRemovalOptions object setting the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New()
'Usage

Dim instance As New BlobRemovalOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public BlobRemovalOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: BlobRemovalOptions();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
BlobRemovalOptions();
See Also

Reference

BlobRemovalOptions Class
BlobRemovalOptions Members
Overload List


BlobRemovalOptions Constructor(Rectangle,Int32,Int32,Int32)

Accusoft.ScanFixXpress8.Net
BlobRemovalOptions Constructor(Rectangle,Int32,Int32,Int32)

Accusoft.ScanFixXpressSdk Namespace > BlobRemovalOptions Class > BlobRemovalOptions Constructor : BlobRemovalOptions Constructor(Rectangle,Int32,Int32,Int32)
The area of the image where the blob removal process will search.
The minimum number of pixels for an object to be considered a blob for removal purposes.
The maximum number of pixels for an object to be considered a blob for removal purposes.
The ratio of black pixels to all pixels within the convex hull of an object.
Instantiates a new BlobRemovalOptions object setting the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New( _
   ByVal area As Rectangle, _
   ByVal minimumPixelCount As Integer, _
   ByVal maximumPixelCount As Integer, _
   ByVal minimumDensity As Integer _
)
'Usage

Dim area As Rectangle
Dim minimumPixelCount As Integer
Dim maximumPixelCount As Integer
Dim minimumDensity As Integer

Dim instance As New BlobRemovalOptions(area, minimumPixelCount, maximumPixelCount, minimumDensity)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public BlobRemovalOptions(
   Rectangle area,
   int minimumPixelCount,
   int maximumPixelCount,
   int minimumDensity
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: BlobRemovalOptions(
   Rectangle area,
   int minimumPixelCount,
   int maximumPixelCount,
   int minimumDensity
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
BlobRemovalOptions(
   Rectangle area,
   int minimumPixelCount,
   int maximumPixelCount,
   int minimumDensity
)

Parameters

area
The area of the image where the blob removal process will search.
minimumPixelCount
The minimum number of pixels for an object to be considered a blob for removal purposes.
maximumPixelCount
The maximum number of pixels for an object to be considered a blob for removal purposes.
minimumDensity
The ratio of black pixels to all pixels within the convex hull of an object.
See Also

Reference

BlobRemovalOptions Class
BlobRemovalOptions Members
Overload List


Area Property (BlobRemovalOptions)

Accusoft.ScanFixXpress8.Net
Area Property (BlobRemovalOptions)

Accusoft.ScanFixXpressSdk Namespace > BlobRemovalOptions Class : Area Property
Gets and sets the location and size of the rectangular area of the image where the blob removal process will search.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Area As Rectangle
'Usage

Dim instance As BlobRemovalOptions
Dim value As Rectangle

instance.Area = value

value = instance.Area
public Rectangle Area {get; set;}
public: __property Rectangle get_Area();
public: __property void set_Area(
   Rectangle value
);
public:
property Rectangle Area {
   Rectangle get();
   void set (    Rectangle value);
}
Remarks

The default value is 0, 0, 0, 0.

See Also

Reference

BlobRemovalOptions Class
BlobRemovalOptions Members


MaximumPixelCount Property

Accusoft.ScanFixXpress8.Net
MaximumPixelCount Property

Accusoft.ScanFixXpressSdk Namespace > BlobRemovalOptions Class : MaximumPixelCount Property
Gets and sets the maximum number of pixels for an object to be considered a blob for removal purposes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaximumPixelCount As Integer
'Usage

Dim instance As BlobRemovalOptions
Dim value As Integer

instance.MaximumPixelCount = value

value = instance.MaximumPixelCount
public int MaximumPixelCount {get; set;}
public: __property int get_MaximumPixelCount();
public: __property void set_MaximumPixelCount(
   int value
);
public:
property int MaximumPixelCount {
   int get();
   void set (    int value);
}
Remarks

The default value is 10,000.

Valid values are anything larger than MinimumPixelCount.

See Also

Reference

BlobRemovalOptions Class
BlobRemovalOptions Members


MinimumDensity Property

Accusoft.ScanFixXpress8.Net
MinimumDensity Property

Accusoft.ScanFixXpressSdk Namespace > BlobRemovalOptions Class : MinimumDensity Property
Gets and sets the ratio of black pixels to all pixels within the convex hull of an object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumDensity As Integer
'Usage

Dim instance As BlobRemovalOptions
Dim value As Integer

instance.MinimumDensity = value

value = instance.MinimumDensity
public int MinimumDensity {get; set;}
public: __property int get_MinimumDensity();
public: __property void set_MinimumDensity(
   int value
);
public:
property int MinimumDensity {
   int get();
   void set (    int value);
}
Remarks

The default value is 50.

Valid values are 0 to 100.

See Also

Reference

BlobRemovalOptions Class
BlobRemovalOptions Members


MinimumPixelCount Property

Accusoft.ScanFixXpress8.Net
MinimumPixelCount Property

Accusoft.ScanFixXpressSdk Namespace > BlobRemovalOptions Class : MinimumPixelCount Property
Gets and sets the minimum number of pixels for an object to be considered a blob for removal purposes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumPixelCount As Integer
'Usage

Dim instance As BlobRemovalOptions
Dim value As Integer

instance.MinimumPixelCount = value

value = instance.MinimumPixelCount
public int MinimumPixelCount {get; set;}
public: __property int get_MinimumPixelCount();
public: __property void set_MinimumPixelCount(
   int value
);
public:
property int MinimumPixelCount {
   int get();
   void set (    int value);
}
Remarks

The default value is 300.

Valid values are 1 to {no limit}.

See Also

Reference

BlobRemovalOptions Class
BlobRemovalOptions Members


BlobRemovalResults Class

Accusoft.ScanFixXpress8.Net
BlobRemovalResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : BlobRemovalResults Class
Contains output values from the blob removal process.
Object Model
BlobRemovalResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BlobRemovalResults
   Inherits EnhancementResult
'Usage

Dim instance As BlobRemovalResults
public class BlobRemovalResults : EnhancementResult
public __gc class BlobRemovalResults : public EnhancementResult
public ref class BlobRemovalResults : public EnhancementResult
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.BlobRemovalResults

See Also

Reference

BlobRemovalResults Members
Accusoft.ScanFixXpressSdk Namespace


BlobRemovalResults Class Members

Accusoft.ScanFixXpress8.Net
BlobRemovalResults Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : BlobRemovalResults Class

The following tables list the members exposed by BlobRemovalResults.

Public Properties
 | Name | Description
Public Property | CountOfBlobsFound | Gets the number of blobs found and removed.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified during the blob removal process.
Top
See Also

Reference

BlobRemovalResults Class
Accusoft.ScanFixXpressSdk Namespace


BlobRemovalResults Class Properties

Accusoft.ScanFixXpress8.Net
BlobRemovalResults Class Properties

Accusoft.ScanFixXpressSdk Namespace : BlobRemovalResults Class

For a list of all members of this type, see BlobRemovalResults members.

Public Properties
 | Name | Description
Public Property | CountOfBlobsFound | Gets the number of blobs found and removed.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified during the blob removal process.
Top
See Also

Reference

BlobRemovalResults Class
Accusoft.ScanFixXpressSdk Namespace


CountOfBlobsFound Property

Accusoft.ScanFixXpress8.Net
CountOfBlobsFound Property

Accusoft.ScanFixXpressSdk Namespace > BlobRemovalResults Class : CountOfBlobsFound Property
Gets the number of blobs found and removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CountOfBlobsFound As Integer
'Usage

Dim instance As BlobRemovalResults
Dim value As Integer

value = instance.CountOfBlobsFound
public int CountOfBlobsFound {get;}
public: __property int get_CountOfBlobsFound();
public:
property int CountOfBlobsFound {
   int get();
}

Property Value

An integer which represents the number of blobs.
See Also

Reference

BlobRemovalResults Class
BlobRemovalResults Members


ImageWasModified Property (BlobRemovalResults)

Accusoft.ScanFixXpress8.Net
ImageWasModified Property (BlobRemovalResults)

Accusoft.ScanFixXpressSdk Namespace > BlobRemovalResults Class : ImageWasModified Property
Gets a flag that indicates whether the image was modified during the blob removal process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageWasModified As Boolean
'Usage

Dim instance As BlobRemovalResults
Dim value As Boolean

value = instance.ImageWasModified
public bool ImageWasModified {get;}
public: __property bool get_ImageWasModified();
public:
property bool ImageWasModified {
   bool get();
}

Property Value

A boolean value which is True if the image was modified. Otherwise, False is returned.
See Also

Reference

BlobRemovalResults Class
BlobRemovalResults Members


BorderRemovalOptions Class

Accusoft.ScanFixXpress8.Net
BorderRemovalOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : BorderRemovalOptions Class
Contains parameters that control the ScanFix.RemoveBorder process.
Object Model
BorderRemovalOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BorderRemovalOptions
   Inherits EnhancementOption
'Usage

Dim instance As BorderRemovalOptions
public class BorderRemovalOptions : EnhancementOption
public __gc class BorderRemovalOptions : public EnhancementOption
public ref class BorderRemovalOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.BorderRemovalOptions

See Also

Reference

BorderRemovalOptions Members
Accusoft.ScanFixXpressSdk Namespace


BorderRemovalOptions Class Members

Accusoft.ScanFixXpress8.Net
BorderRemovalOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : BorderRemovalOptions Class

The following tables list the members exposed by BorderRemovalOptions.

Public Constructors
 | Name | Description
Public Constructor | BorderRemovalOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AmountToExpandPage | Gets and sets the number of pixels to expand each of the four page edges.
Public Property | BorderSpeckSize | Gets and sets the maximum width or height (in pixels) of specks present in the border of the image.
Public Property | CropBorder | Gets and sets a flag that indicates whether the detected border pixels should be removed from the image.
Public Property | DeskewBorder | Gets and sets a flag that indicates whether the image should be deskewed based on the angle of the detected border.
Public Property | MaximumPageHeight | Gets and sets the maximum expected page height, in pixels.
Public Property | MaximumPageWidth | Gets and sets the maximum expected page width, in pixels.
Public Property | MinimumConfidence | Gets and sets the minimum detection confidence required before correction will proceed.
Public Property | MinimumPageHeight | Gets and sets the minimum expected page height, in pixels.
Public Property | MinimumPageWidth | Gets and sets the minimum expected page width, in pixels.
Public Property | PadColor | Gets and sets the color to use for pixels that are added to the image or for pixels that replace border pixels.
Public Property | PageSpeckSize | Gets and sets the maximum width or height (in pixels) of specks present in the interior (page) portion of the image.
Public Property | Quality | Gets and sets a value that indicates the amount of effort to expend analyzing the image to locate the border.
Public Property | ReplaceBorder | Gets and sets a flag that indicates whether the detected border pixels should be replaced with the fill color.
Top
See Also

Reference

BorderRemovalOptions Class
Accusoft.ScanFixXpressSdk Namespace


BorderRemovalOptions Class Properties

Accusoft.ScanFixXpress8.Net
BorderRemovalOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : BorderRemovalOptions Class

For a list of all members of this type, see BorderRemovalOptions members.

Public Properties
 | Name | Description
Public Property | AmountToExpandPage | Gets and sets the number of pixels to expand each of the four page edges.
Public Property | BorderSpeckSize | Gets and sets the maximum width or height (in pixels) of specks present in the border of the image.
Public Property | CropBorder | Gets and sets a flag that indicates whether the detected border pixels should be removed from the image.
Public Property | DeskewBorder | Gets and sets a flag that indicates whether the image should be deskewed based on the angle of the detected border.
Public Property | MaximumPageHeight | Gets and sets the maximum expected page height, in pixels.
Public Property | MaximumPageWidth | Gets and sets the maximum expected page width, in pixels.
Public Property | MinimumConfidence | Gets and sets the minimum detection confidence required before correction will proceed.
Public Property | MinimumPageHeight | Gets and sets the minimum expected page height, in pixels.
Public Property | MinimumPageWidth | Gets and sets the minimum expected page width, in pixels.
Public Property | PadColor | Gets and sets the color to use for pixels that are added to the image or for pixels that replace border pixels.
Public Property | PageSpeckSize | Gets and sets the maximum width or height (in pixels) of specks present in the interior (page) portion of the image.
Public Property | Quality | Gets and sets a value that indicates the amount of effort to expend analyzing the image to locate the border.
Public Property | ReplaceBorder | Gets and sets a flag that indicates whether the detected border pixels should be replaced with the fill color.
Top
See Also

Reference

BorderRemovalOptions Class
Accusoft.ScanFixXpressSdk Namespace


BorderRemovalOptions Constructor

Accusoft.ScanFixXpress8.Net
BorderRemovalOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalOptions Class : BorderRemovalOptions Constructor
Overload List
Overload | Description
BorderRemovalOptions Constructor() | Instantiates a new BorderRemovalOptions object with the default values.
BorderRemovalOptions Constructor(Color,Int32,Int32,Boolean,Boolean,Boolean,Int32,Int32,Int32,Int32,Int32,Int32,Int32) | Instantiates a new BorderRemovalOptions object with the specified values.
See Also

Reference

BorderRemovalOptions Class
BorderRemovalOptions Members


BorderRemovalOptions Constructor()

Accusoft.ScanFixXpress8.Net
BorderRemovalOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalOptions Class > BorderRemovalOptions Constructor : BorderRemovalOptions Constructor()
Instantiates a new BorderRemovalOptions object with the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New()
'Usage

Dim instance As New BorderRemovalOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public BorderRemovalOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: BorderRemovalOptions();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
BorderRemovalOptions();
See Also

Reference

BorderRemovalOptions Class
BorderRemovalOptions Members
Overload List


BorderRemovalOptions Constructor(Color,Int32,Int32,Boolean,Boolean,Boolean,Int32,Int32,Int32,Int32,Int32,Int32,Int32)

Accusoft.ScanFixXpress8.Net
BorderRemovalOptions Constructor(Color,Int32,Int32,Boolean,Boolean,Boolean,Int32,Int32,Int32,Int32,Int32,Int32,Int32)

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalOptions Class > BorderRemovalOptions Constructor : BorderRemovalOptions Constructor(Color,Int32,Int32,Boolean,Boolean,Boolean,Int32,Int32,Int32,Int32,Int32,Int32,Int32)
The color to use for pixels that are added to the image or for pixels that replace border pixels.
The maximum width or height (in pixels) of specks present in the border of the image.
The maximum width or height (in pixels) of specks present in the interior (page) portion of the image.
A flag that indicates whether the detected border pixels should be removed from the image.
A flag that indicates whether the detected border pixels should be replaced with the fill color.
A flag that indicates whether the image should be deskewed based on the angle of the detected border.
A value that indicates the amount of effort to expend analyzing the image to locate the border. Set to a high value to insure the most accurate possible result and to a low value for fastest operation.
A value that indicates the number of pixels to expand each of the four page edges.
A value that indicates the minimum expected page width, in pixels. Set this value as high as possible (while still being smaller than the page size) to insure best results.
A value that indicates the maximum expected page width, in pixels. Set this value as low as possible (while still being larger than the page size) to insure best results.
A value that indicates the minimum expected page height, in pixels. Set this value as high as possible (while still being smaller than the page size) to insure best results.
A value that indicates the maximum expected page height, in pixels. Set this value as low as possible (while still being larger than the page size) to insure best results.
A value that indicates the minimum detection confidence required before correction will proceed. If the detection confidence is less than this value, the image will not be modified.
Instantiates a new BorderRemovalOptions object with the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal padColor As Color, _
   ByVal borderSpeckSize As Integer, _
   ByVal pageSpeckSize As Integer, _
   ByVal cropBorder As Boolean, _
   ByVal replaceBorder As Boolean, _
   ByVal deskewBorder As Boolean, _
   ByVal quality As Integer, _
   ByVal amountToExpandPage As Integer, _
   ByVal minimumPageWidth As Integer, _
   ByVal maximumPageWidth As Integer, _
   ByVal minimumPageHeight As Integer, _
   ByVal maximumPageHeight As Integer, _
   ByVal minimumConfidence As Integer _
)
'Usage

Dim padColor As Color
Dim borderSpeckSize As Integer
Dim pageSpeckSize As Integer
Dim cropBorder As Boolean
Dim replaceBorder As Boolean
Dim deskewBorder As Boolean
Dim quality As Integer
Dim amountToExpandPage As Integer
Dim minimumPageWidth As Integer
Dim maximumPageWidth As Integer
Dim minimumPageHeight As Integer
Dim maximumPageHeight As Integer
Dim minimumConfidence As Integer

Dim instance As New BorderRemovalOptions(padColor, borderSpeckSize, pageSpeckSize, cropBorder, replaceBorder, deskewBorder, quality, amountToExpandPage, minimumPageWidth, maximumPageWidth, minimumPageHeight, maximumPageHeight, minimumConfidence)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public BorderRemovalOptions(
   Color padColor,
   int borderSpeckSize,
   int pageSpeckSize,
   bool cropBorder,
   bool replaceBorder,
   bool deskewBorder,
   int quality,
   int amountToExpandPage,
   int minimumPageWidth,
   int maximumPageWidth,
   int minimumPageHeight,
   int maximumPageHeight,
   int minimumConfidence
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: BorderRemovalOptions(
   Color padColor,
   int borderSpeckSize,
   int pageSpeckSize,
   bool cropBorder,
   bool replaceBorder,
   bool deskewBorder,
   int quality,
   int amountToExpandPage,
   int minimumPageWidth,
   int maximumPageWidth,
   int minimumPageHeight,
   int maximumPageHeight,
   int minimumConfidence
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
BorderRemovalOptions(
   Color padColor,
   int borderSpeckSize,
   int pageSpeckSize,
   bool cropBorder,
   bool replaceBorder,
   bool deskewBorder,
   int quality,
   int amountToExpandPage,
   int minimumPageWidth,
   int maximumPageWidth,
   int minimumPageHeight,
   int maximumPageHeight,
   int minimumConfidence
)

Parameters

padColor
The color to use for pixels that are added to the image or for pixels that replace border pixels.
borderSpeckSize
The maximum width or height (in pixels) of specks present in the border of the image.
pageSpeckSize
The maximum width or height (in pixels) of specks present in the interior (page) portion of the image.
cropBorder
A flag that indicates whether the detected border pixels should be removed from the image.
replaceBorder
A flag that indicates whether the detected border pixels should be replaced with the fill color.
deskewBorder
A flag that indicates whether the image should be deskewed based on the angle of the detected border.
quality
A value that indicates the amount of effort to expend analyzing the image to locate the border. Set to a high value to insure the most accurate possible result and to a low value for fastest operation.
amountToExpandPage
A value that indicates the number of pixels to expand each of the four page edges.
minimumPageWidth
A value that indicates the minimum expected page width, in pixels. Set this value as high as possible (while still being smaller than the page size) to insure best results.
maximumPageWidth
A value that indicates the maximum expected page width, in pixels. Set this value as low as possible (while still being larger than the page size) to insure best results.
minimumPageHeight
A value that indicates the minimum expected page height, in pixels. Set this value as high as possible (while still being smaller than the page size) to insure best results.
maximumPageHeight
A value that indicates the maximum expected page height, in pixels. Set this value as low as possible (while still being larger than the page size) to insure best results.
minimumConfidence
A value that indicates the minimum detection confidence required before correction will proceed. If the detection confidence is less than this value, the image will not be modified.
See Also

Reference

BorderRemovalOptions Class
BorderRemovalOptions Members
Overload List


AmountToExpandPage Property

Accusoft.ScanFixXpress8.Net
AmountToExpandPage Property

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalOptions Class : AmountToExpandPage Property
Gets and sets the number of pixels to expand each of the four page edges.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AmountToExpandPage As Integer
'Usage

Dim instance As BorderRemovalOptions
Dim value As Integer

instance.AmountToExpandPage = value

value = instance.AmountToExpandPage
public int AmountToExpandPage {get; set;}
public: __property int get_AmountToExpandPage();
public: __property void set_AmountToExpandPage(
   int value
);
public:
property int AmountToExpandPage {
   int get();
   void set (    int value);
}
Remarks

The default value is 0.

Valid values are -1000 to 1000.

See Also

Reference

BorderRemovalOptions Class
BorderRemovalOptions Members


BorderSpeckSize Property

Accusoft.ScanFixXpress8.Net
BorderSpeckSize Property

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalOptions Class : BorderSpeckSize Property
Gets and sets the maximum width or height (in pixels) of specks present in the border of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderSpeckSize As Integer
'Usage

Dim instance As BorderRemovalOptions
Dim value As Integer

instance.BorderSpeckSize = value

value = instance.BorderSpeckSize
public int BorderSpeckSize {get; set;}
public: __property int get_BorderSpeckSize();
public: __property void set_BorderSpeckSize(
   int value
);
public:
property int BorderSpeckSize {
   int get();
   void set (    int value);
}
Remarks

The default value is 3.

Valid values are 0 to 100.

See Also

Reference

BorderRemovalOptions Class
BorderRemovalOptions Members


CropBorder Property

Accusoft.ScanFixXpress8.Net
CropBorder Property

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalOptions Class : CropBorder Property
Gets and sets a flag that indicates whether the detected border pixels should be removed from the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CropBorder As Boolean
'Usage

Dim instance As BorderRemovalOptions
Dim value As Boolean

instance.CropBorder = value

value = instance.CropBorder
public bool CropBorder {get; set;}
public: __property bool get_CropBorder();
public: __property void set_CropBorder(
   bool value
);
public:
property bool CropBorder {
   bool get();
   void set (    bool value);
}
Remarks

The default value is true.

One of this property or ReplaceBorder or DeskewBorder must be set to true.

See Also

Reference

BorderRemovalOptions Class
BorderRemovalOptions Members


DeskewBorder Property

Accusoft.ScanFixXpress8.Net
DeskewBorder Property

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalOptions Class : DeskewBorder Property
Gets and sets a flag that indicates whether the image should be deskewed based on the angle of the detected border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DeskewBorder As Boolean
'Usage

Dim instance As BorderRemovalOptions
Dim value As Boolean

instance.DeskewBorder = value

value = instance.DeskewBorder
public bool DeskewBorder {get; set;}
public: __property bool get_DeskewBorder();
public: __property void set_DeskewBorder(
   bool value
);
public:
property bool DeskewBorder {
   bool get();
   void set (    bool value);
}
Remarks

The default value is true.

One of this property or ReplaceBorder or CropBorder must be set to true.

See Also

Reference

BorderRemovalOptions Class
BorderRemovalOptions Members


MaximumPageHeight Property

Accusoft.ScanFixXpress8.Net
MaximumPageHeight Property

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalOptions Class : MaximumPageHeight Property
Gets and sets the maximum expected page height, in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaximumPageHeight As Integer
'Usage

Dim instance As BorderRemovalOptions
Dim value As Integer

instance.MaximumPageHeight = value

value = instance.MaximumPageHeight
public int MaximumPageHeight {get; set;}
public: __property int get_MaximumPageHeight();
public: __property void set_MaximumPageHeight(
   int value
);
public:
property int MaximumPageHeight {
   int get();
   void set (    int value);
}
Remarks

The default value is 0.

Valid values are 0 to 2,147,483,647.

Set this value as low as possible (while still being larger than the page height) to insure best results.

See Also

Reference

BorderRemovalOptions Class
BorderRemovalOptions Members


MaximumPageWidth Property

Accusoft.ScanFixXpress8.Net
MaximumPageWidth Property

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalOptions Class : MaximumPageWidth Property
Gets and sets the maximum expected page width, in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaximumPageWidth As Integer
'Usage

Dim instance As BorderRemovalOptions
Dim value As Integer

instance.MaximumPageWidth = value

value = instance.MaximumPageWidth
public int MaximumPageWidth {get; set;}
public: __property int get_MaximumPageWidth();
public: __property void set_MaximumPageWidth(
   int value
);
public:
property int MaximumPageWidth {
   int get();
   void set (    int value);
}
Remarks

The default value is 0.

Valid values are 0 to 2,147,483,647.

Set this value as low as possible (while still being larger than the page width) to insure best results.

See Also

Reference

BorderRemovalOptions Class
BorderRemovalOptions Members


MinimumConfidence Property (BorderRemovalOptions)

Accusoft.ScanFixXpress8.Net
MinimumConfidence Property (BorderRemovalOptions)

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalOptions Class : MinimumConfidence Property
Gets and sets the minimum detection confidence required before correction will proceed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumConfidence As Integer
'Usage

Dim instance As BorderRemovalOptions
Dim value As Integer

instance.MinimumConfidence = value

value = instance.MinimumConfidence
public int MinimumConfidence {get; set;}
public: __property int get_MinimumConfidence();
public: __property void set_MinimumConfidence(
   int value
);
public:
property int MinimumConfidence {
   int get();
   void set (    int value);
}
Remarks

The default value is 50.

Valid values are 0 to 100.

If the detection confidence is less than this value, the image will not be modified.

See Also

Reference

BorderRemovalOptions Class
BorderRemovalOptions Members


MinimumPageHeight Property

Accusoft.ScanFixXpress8.Net
MinimumPageHeight Property

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalOptions Class : MinimumPageHeight Property
Gets and sets the minimum expected page height, in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumPageHeight As Integer
'Usage

Dim instance As BorderRemovalOptions
Dim value As Integer

instance.MinimumPageHeight = value

value = instance.MinimumPageHeight
public int MinimumPageHeight {get; set;}
public: __property int get_MinimumPageHeight();
public: __property void set_MinimumPageHeight(
   int value
);
public:
property int MinimumPageHeight {
   int get();
   void set (    int value);
}
Remarks

The default value is 0.

Valid values are 0 to 2,147,483,647.

Set this value as high as possible (while still being smaller than the page height) to insure best results.

See Also

Reference

BorderRemovalOptions Class
BorderRemovalOptions Members


MinimumPageWidth Property

Accusoft.ScanFixXpress8.Net
MinimumPageWidth Property

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalOptions Class : MinimumPageWidth Property
Gets and sets the minimum expected page width, in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumPageWidth As Integer
'Usage

Dim instance As BorderRemovalOptions
Dim value As Integer

instance.MinimumPageWidth = value

value = instance.MinimumPageWidth
public int MinimumPageWidth {get; set;}
public: __property int get_MinimumPageWidth();
public: __property void set_MinimumPageWidth(
   int value
);
public:
property int MinimumPageWidth {
   int get();
   void set (    int value);
}
Remarks

The default value is 0.

Valid values are 0 to 2,147,483,647.

Set this value as high as possible (while still being smaller than the page width) to insure best results.

See Also

Reference

BorderRemovalOptions Class
BorderRemovalOptions Members


PadColor Property (BorderRemovalOptions)

Accusoft.ScanFixXpress8.Net
PadColor Property (BorderRemovalOptions)

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalOptions Class : PadColor Property
Gets and sets the color to use for pixels that are added to the image or for pixels that replace border pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PadColor As Color
'Usage

Dim instance As BorderRemovalOptions
Dim value As Color

instance.PadColor = value

value = instance.PadColor
public Color PadColor {get; set;}
public: __property Color get_PadColor();
public: __property void set_PadColor(
   Color value
);
public:
property Color PadColor {
   Color get();
   void set (    Color value);
}
Remarks

The default value is White.

See Also

Reference

BorderRemovalOptions Class
BorderRemovalOptions Members


PageSpeckSize Property

Accusoft.ScanFixXpress8.Net
PageSpeckSize Property

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalOptions Class : PageSpeckSize Property
Gets and sets the maximum width or height (in pixels) of specks present in the interior (page) portion of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageSpeckSize As Integer
'Usage

Dim instance As BorderRemovalOptions
Dim value As Integer

instance.PageSpeckSize = value

value = instance.PageSpeckSize
public int PageSpeckSize {get; set;}
public: __property int get_PageSpeckSize();
public: __property void set_PageSpeckSize(
   int value
);
public:
property int PageSpeckSize {
   int get();
   void set (    int value);
}
Remarks

The default value is 2.

Valid values are 0 to 100.

See Also

Reference

BorderRemovalOptions Class
BorderRemovalOptions Members


Quality Property (BorderRemovalOptions)

Accusoft.ScanFixXpress8.Net
Quality Property (BorderRemovalOptions)

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalOptions Class : Quality Property
Gets and sets a value that indicates the amount of effort to expend analyzing the image to locate the border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Quality As Integer
'Usage

Dim instance As BorderRemovalOptions
Dim value As Integer

instance.Quality = value

value = instance.Quality
public int Quality {get; set;}
public: __property int get_Quality();
public: __property void set_Quality(
   int value
);
public:
property int Quality {
   int get();
   void set (    int value);
}
Remarks

The default value is 80.

Valid values are 1 to 100.

Set to a high value to insure the most accurate possible result and to a low value for fastest operation.

See Also

Reference

BorderRemovalOptions Class
BorderRemovalOptions Members


ReplaceBorder Property

Accusoft.ScanFixXpress8.Net
ReplaceBorder Property

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalOptions Class : ReplaceBorder Property
Gets and sets a flag that indicates whether the detected border pixels should be replaced with the fill color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReplaceBorder As Boolean
'Usage

Dim instance As BorderRemovalOptions
Dim value As Boolean

instance.ReplaceBorder = value

value = instance.ReplaceBorder
public bool ReplaceBorder {get; set;}
public: __property bool get_ReplaceBorder();
public: __property void set_ReplaceBorder(
   bool value
);
public:
property bool ReplaceBorder {
   bool get();
   void set (    bool value);
}
Remarks

The default value is false.

One of this property or CropBorder or DeskewBorder must be set to true.

See Also

Reference

BorderRemovalOptions Class
BorderRemovalOptions Members


BorderRemovalResults Class

Accusoft.ScanFixXpress8.Net
BorderRemovalResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : BorderRemovalResults Class
Contains output values from the border removal process.
Object Model
BorderRemovalResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BorderRemovalResults
   Inherits EnhancementResult
'Usage

Dim instance As BorderRemovalResults
public class BorderRemovalResults : EnhancementResult
public __gc class BorderRemovalResults : public EnhancementResult
public ref class BorderRemovalResults : public EnhancementResult
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.BorderRemovalResults

See Also

Reference

BorderRemovalResults Members
Accusoft.ScanFixXpressSdk Namespace


BorderRemovalResults Class Members

Accusoft.ScanFixXpress8.Net
BorderRemovalResults Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : BorderRemovalResults Class

The following tables list the members exposed by BorderRemovalResults.

Public Properties
 | Name | Description
Public Property | Confidence | Gets the confidence of the border removal process.
Public Property | DetectedHorizontalAngle | Gets the angle needed to correct the skew of the horizontal portion of the border (in degrees counter-clockwise.)
Public Property | DetectedVerticalAngle | Gets the angle needed to correct the skew of the vertical portion of the border (in degrees counter-clockwise.)
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified during the border removal process.
Public Property | PageHeight | Gets the height of the detected page.
Public Property | PageWidth | Gets the width of the detected page.
Public Property | PageX | Gets the X coordinate of the top-left corner of the detected page.
Public Property | PageY | Gets the Y coordinate of the top-left corner of the detected page.
Top
See Also

Reference

BorderRemovalResults Class
Accusoft.ScanFixXpressSdk Namespace


BorderRemovalResults Class Properties

Accusoft.ScanFixXpress8.Net
BorderRemovalResults Class Properties

Accusoft.ScanFixXpressSdk Namespace : BorderRemovalResults Class

For a list of all members of this type, see BorderRemovalResults members.

Public Properties
 | Name | Description
Public Property | Confidence | Gets the confidence of the border removal process.
Public Property | DetectedHorizontalAngle | Gets the angle needed to correct the skew of the horizontal portion of the border (in degrees counter-clockwise.)
Public Property | DetectedVerticalAngle | Gets the angle needed to correct the skew of the vertical portion of the border (in degrees counter-clockwise.)
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified during the border removal process.
Public Property | PageHeight | Gets the height of the detected page.
Public Property | PageWidth | Gets the width of the detected page.
Public Property | PageX | Gets the X coordinate of the top-left corner of the detected page.
Public Property | PageY | Gets the Y coordinate of the top-left corner of the detected page.
Top
See Also

Reference

BorderRemovalResults Class
Accusoft.ScanFixXpressSdk Namespace


Confidence Property (BorderRemovalResults)

Accusoft.ScanFixXpress8.Net
Confidence Property (BorderRemovalResults)

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalResults Class : Confidence Property
Gets the confidence of the border removal process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Confidence As Integer
'Usage

Dim instance As BorderRemovalResults
Dim value As Integer

value = instance.Confidence
public int Confidence {get;}
public: __property int get_Confidence();
public:
property int Confidence {
   int get();
}

Property Value

An integer value which represents the confidence.
Remarks

The value range is between 0 and 100.

Higher values indicate a higher confidence that the border was accurately located.

See Also

Reference

BorderRemovalResults Class
BorderRemovalResults Members


DetectedHorizontalAngle Property

Accusoft.ScanFixXpress8.Net
DetectedHorizontalAngle Property

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalResults Class : DetectedHorizontalAngle Property
Gets the angle needed to correct the skew of the horizontal portion of the border (in degrees counter-clockwise.)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DetectedHorizontalAngle As Double
'Usage

Dim instance As BorderRemovalResults
Dim value As Double

value = instance.DetectedHorizontalAngle
public double DetectedHorizontalAngle {get;}
public: __property double get_DetectedHorizontalAngle();
public:
property double DetectedHorizontalAngle {
   double get();
}
See Also

Reference

BorderRemovalResults Class
BorderRemovalResults Members


DetectedVerticalAngle Property

Accusoft.ScanFixXpress8.Net
DetectedVerticalAngle Property

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalResults Class : DetectedVerticalAngle Property
Gets the angle needed to correct the skew of the vertical portion of the border (in degrees counter-clockwise.)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DetectedVerticalAngle As Double
'Usage

Dim instance As BorderRemovalResults
Dim value As Double

value = instance.DetectedVerticalAngle
public double DetectedVerticalAngle {get;}
public: __property double get_DetectedVerticalAngle();
public:
property double DetectedVerticalAngle {
   double get();
}
See Also

Reference

BorderRemovalResults Class
BorderRemovalResults Members


ImageWasModified Property (BorderRemovalResults)

Accusoft.ScanFixXpress8.Net
ImageWasModified Property (BorderRemovalResults)

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalResults Class : ImageWasModified Property
Gets a flag that indicates whether the image was modified during the border removal process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageWasModified As Boolean
'Usage

Dim instance As BorderRemovalResults
Dim value As Boolean

value = instance.ImageWasModified
public bool ImageWasModified {get;}
public: __property bool get_ImageWasModified();
public:
property bool ImageWasModified {
   bool get();
}

Property Value

A boolean value which is True if the image was modified. Otherwise, False is returned.
See Also

Reference

BorderRemovalResults Class
BorderRemovalResults Members


PageHeight Property

Accusoft.ScanFixXpress8.Net
PageHeight Property

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalResults Class : PageHeight Property
Gets the height of the detected page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageHeight As Integer
'Usage

Dim instance As BorderRemovalResults
Dim value As Integer

value = instance.PageHeight
public int PageHeight {get;}
public: __property int get_PageHeight();
public:
property int PageHeight {
   int get();
}
See Also

Reference

BorderRemovalResults Class
BorderRemovalResults Members


PageWidth Property

Accusoft.ScanFixXpress8.Net
PageWidth Property

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalResults Class : PageWidth Property
Gets the width of the detected page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageWidth As Integer
'Usage

Dim instance As BorderRemovalResults
Dim value As Integer

value = instance.PageWidth
public int PageWidth {get;}
public: __property int get_PageWidth();
public:
property int PageWidth {
   int get();
}
See Also

Reference

BorderRemovalResults Class
BorderRemovalResults Members


PageX Property

Accusoft.ScanFixXpress8.Net
PageX Property

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalResults Class : PageX Property
Gets the X coordinate of the top-left corner of the detected page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageX As Integer
'Usage

Dim instance As BorderRemovalResults
Dim value As Integer

value = instance.PageX
public int PageX {get;}
public: __property int get_PageX();
public:
property int PageX {
   int get();
}
See Also

Reference

BorderRemovalResults Class
BorderRemovalResults Members


PageY Property

Accusoft.ScanFixXpress8.Net
PageY Property

Accusoft.ScanFixXpressSdk Namespace > BorderRemovalResults Class : PageY Property
Gets the Y coordinate of the top-left corner of the detected page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageY As Integer
'Usage

Dim instance As BorderRemovalResults
Dim value As Integer

value = instance.PageY
public int PageY {get;}
public: __property int get_PageY();
public:
property int PageY {
   int get();
}
See Also

Reference

BorderRemovalResults Class
BorderRemovalResults Members


BrightnessContrastOptions Class

Accusoft.ScanFixXpress8.Net
BrightnessContrastOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : BrightnessContrastOptions Class
Contains parameters for the ScanFix.AdjustBrightnessContrast process.
Object Model
BrightnessContrastOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BrightnessContrastOptions
   Inherits EnhancementOption
'Usage

Dim instance As BrightnessContrastOptions
public class BrightnessContrastOptions : EnhancementOption
public __gc class BrightnessContrastOptions : public EnhancementOption
public ref class BrightnessContrastOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.BrightnessContrastOptions

See Also

Reference

BrightnessContrastOptions Members
Accusoft.ScanFixXpressSdk Namespace


BrightnessContrastOptions Class Members

Accusoft.ScanFixXpress8.Net
BrightnessContrastOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : BrightnessContrastOptions Class

The following tables list the members exposed by BrightnessContrastOptions.

Public Constructors
 | Name | Description
Public Constructor | BrightnessContrastOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Adjustment | Gets and sets the type of contrast adjustment to perform on the image.
Public Property | ContrastLimitDark | Gets and sets the maximum contrast change for dark pixels.
Public Property | ContrastLimitLight | Gets and sets the maximum contrast change for light pixels.
Public Property | ContrastLimitMiddle | Gets and sets the maximum contrast change for middle-range pixels.
Public Property | MaximumPercentile | Gets and sets the highest brightness percentile pixels to target for adjustment.
Public Property | MinimumPercentile | Gets and sets the lowest brightness percentile pixels to target for adjustment.
Public Property | Quality | Gets and sets the amount of effort to expend analyzing the image to determine contrast.
Public Property | TargetBrightness | Gets and sets the target brightness level for background of adjusted image.
Public Property | TargetContrast | Gets and sets the target contrast between foreground and background for the adjusted image.
Public Property | TargetVariance | Gets and sets the largest allowable variance in brightness across the image.
Top
See Also

Reference

BrightnessContrastOptions Class
Accusoft.ScanFixXpressSdk Namespace


BrightnessContrastOptions Class Properties

Accusoft.ScanFixXpress8.Net
BrightnessContrastOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : BrightnessContrastOptions Class

For a list of all members of this type, see BrightnessContrastOptions members.

Public Properties
 | Name | Description
Public Property | Adjustment | Gets and sets the type of contrast adjustment to perform on the image.
Public Property | ContrastLimitDark | Gets and sets the maximum contrast change for dark pixels.
Public Property | ContrastLimitLight | Gets and sets the maximum contrast change for light pixels.
Public Property | ContrastLimitMiddle | Gets and sets the maximum contrast change for middle-range pixels.
Public Property | MaximumPercentile | Gets and sets the highest brightness percentile pixels to target for adjustment.
Public Property | MinimumPercentile | Gets and sets the lowest brightness percentile pixels to target for adjustment.
Public Property | Quality | Gets and sets the amount of effort to expend analyzing the image to determine contrast.
Public Property | TargetBrightness | Gets and sets the target brightness level for background of adjusted image.
Public Property | TargetContrast | Gets and sets the target contrast between foreground and background for the adjusted image.
Public Property | TargetVariance | Gets and sets the largest allowable variance in brightness across the image.
Top
See Also

Reference

BrightnessContrastOptions Class
Accusoft.ScanFixXpressSdk Namespace


BrightnessContrastOptions Constructor

Accusoft.ScanFixXpress8.Net
BrightnessContrastOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > BrightnessContrastOptions Class : BrightnessContrastOptions Constructor
Overload List
Overload | Description
BrightnessContrastOptions Constructor() | Instantiates a new BrightnessContrastOptions object with default values set.
BrightnessContrastOptions Constructor(BrightnessContrastAdjustment,Int32,Byte,Byte,Byte,Int32,Int32,Byte,Byte,Byte) | Instantiates a new BrightnessContrastOptions object with the specified property values.
See Also

Reference

BrightnessContrastOptions Class
BrightnessContrastOptions Members


BrightnessContrastOptions Constructor()

Accusoft.ScanFixXpress8.Net
BrightnessContrastOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > BrightnessContrastOptions Class > BrightnessContrastOptions Constructor : BrightnessContrastOptions Constructor()
Instantiates a new BrightnessContrastOptions object with default values set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New BrightnessContrastOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public BrightnessContrastOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: BrightnessContrastOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
BrightnessContrastOptions();
See Also

Reference

BrightnessContrastOptions Class
BrightnessContrastOptions Members
Overload List


BrightnessContrastOptions Constructor(BrightnessContrastAdjustment,Int32,Byte,Byte,Byte,Int32,Int32,Byte,Byte,Byte)

Accusoft.ScanFixXpress8.Net
BrightnessContrastOptions Constructor(BrightnessContrastAdjustment,Int32,Byte,Byte,Byte,Int32,Int32,Byte,Byte,Byte)

Accusoft.ScanFixXpressSdk Namespace > BrightnessContrastOptions Class > BrightnessContrastOptions Constructor : BrightnessContrastOptions Constructor(BrightnessContrastAdjustment,Int32,Byte,Byte,Byte,Int32,Int32,Byte,Byte,Byte)
Type of contrast adjustment to perform on the image.
Amount of effort to expend analyzing the image to determine contrast.
Target brightness level for background of adjusted image.
Target contrast between foreground and background for the adjusted image.
Largest possible variance in brightness across the image.
Percentile level for lowest brightness that will be adjusted.
Percentile level for highest brightness that will be adjusted.
Maximum contrast change for dark pixels.
Maximum contrast change for middle-range pixels.
Maximum contrast change for light pixels.
Instantiates a new BrightnessContrastOptions object with the specified property values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal adjustment As BrightnessContrastAdjustment, _
   ByVal quality As Integer, _
   ByVal targetBrightness As Byte, _
   ByVal targetContrast As Byte, _
   ByVal targetVariance As Byte, _
   ByVal minimumPercentile As Integer, _
   ByVal maximumPercentile As Integer, _
   ByVal contrastLimitDark As Byte, _
   ByVal contrastLimitMiddle As Byte, _
   ByVal contrastLimitLight As Byte _
)
'Usage

Dim adjustment As BrightnessContrastAdjustment
Dim quality As Integer
Dim targetBrightness As Byte
Dim targetContrast As Byte
Dim targetVariance As Byte
Dim minimumPercentile As Integer
Dim maximumPercentile As Integer
Dim contrastLimitDark As Byte
Dim contrastLimitMiddle As Byte
Dim contrastLimitLight As Byte

Dim instance As New BrightnessContrastOptions(adjustment, quality, targetBrightness, targetContrast, targetVariance, minimumPercentile, maximumPercentile, contrastLimitDark, contrastLimitMiddle, contrastLimitLight)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public BrightnessContrastOptions(
   BrightnessContrastAdjustment adjustment,
   int quality,
   byte targetBrightness,
   byte targetContrast,
   byte targetVariance,
   int minimumPercentile,
   int maximumPercentile,
   byte contrastLimitDark,
   byte contrastLimitMiddle,
   byte contrastLimitLight
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: BrightnessContrastOptions(
   BrightnessContrastAdjustment adjustment,
   int quality,
   byte targetBrightness,
   byte targetContrast,
   byte targetVariance,
   int minimumPercentile,
   int maximumPercentile,
   byte contrastLimitDark,
   byte contrastLimitMiddle,
   byte contrastLimitLight
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
BrightnessContrastOptions(
   BrightnessContrastAdjustment adjustment,
   int quality,
   byte targetBrightness,
   byte targetContrast,
   byte targetVariance,
   int minimumPercentile,
   int maximumPercentile,
   byte contrastLimitDark,
   byte contrastLimitMiddle,
   byte contrastLimitLight
)

Parameters

adjustment
Type of contrast adjustment to perform on the image.
quality
Amount of effort to expend analyzing the image to determine contrast.
targetBrightness
Target brightness level for background of adjusted image.
targetContrast
Target contrast between foreground and background for the adjusted image.
targetVariance
Largest possible variance in brightness across the image.
minimumPercentile
Percentile level for lowest brightness that will be adjusted.
maximumPercentile
Percentile level for highest brightness that will be adjusted.
contrastLimitDark
Maximum contrast change for dark pixels.
contrastLimitMiddle
Maximum contrast change for middle-range pixels.
contrastLimitLight
Maximum contrast change for light pixels.
See Also

Reference

BrightnessContrastOptions Class
BrightnessContrastOptions Members
Overload List


Adjustment Property

Accusoft.ScanFixXpress8.Net
Adjustment Property

Accusoft.ScanFixXpressSdk Namespace > BrightnessContrastOptions Class : Adjustment Property
Gets and sets the type of contrast adjustment to perform on the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Adjustment As BrightnessContrastAdjustment
'Usage

Dim instance As BrightnessContrastOptions
Dim value As BrightnessContrastAdjustment

instance.Adjustment = value

value = instance.Adjustment
public BrightnessContrastAdjustment Adjustment {get; set;}
public: __property BrightnessContrastAdjustment get_Adjustment();
public: __property void set_Adjustment(
   BrightnessContrastAdjustment value
);
public:
property BrightnessContrastAdjustment Adjustment {
   BrightnessContrastAdjustment get();
   void set (    BrightnessContrastAdjustment value);
}
Remarks

The default value is Automatic.

The Automatic setting will compare the analysis results to the target values, and pick what it considers to be the best correction to use on the given image. Changing this value will let you skip the correction step, or force the adaptive or global correction method.

See Also

Reference

BrightnessContrastOptions Class
BrightnessContrastOptions Members


ContrastLimitDark Property

Accusoft.ScanFixXpress8.Net
ContrastLimitDark Property

Accusoft.ScanFixXpressSdk Namespace > BrightnessContrastOptions Class : ContrastLimitDark Property
Gets and sets the maximum contrast change for dark pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ContrastLimitDark As Byte
'Usage

Dim instance As BrightnessContrastOptions
Dim value As Byte

instance.ContrastLimitDark = value

value = instance.ContrastLimitDark
public byte ContrastLimitDark {get; set;}
public: __property byte get_ContrastLimitDark();
public: __property void set_ContrastLimitDark(
   byte value
);
public:
property byte ContrastLimitDark {
   byte get();
   void set (    byte value);
}
Remarks

The default value is 127.

Valid values are 0 to 255.

This value determines how far in either direction a pixel in this range is allowed to shift when corrected using adaptive correction. A value of 0 will prevent any change to light pixels, while a value of 255 will allow maximum enhancement of contrast.

See Also

Reference

BrightnessContrastOptions Class
BrightnessContrastOptions Members


ContrastLimitLight Property

Accusoft.ScanFixXpress8.Net
ContrastLimitLight Property

Accusoft.ScanFixXpressSdk Namespace > BrightnessContrastOptions Class : ContrastLimitLight Property
Gets and sets the maximum contrast change for light pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ContrastLimitLight As Byte
'Usage

Dim instance As BrightnessContrastOptions
Dim value As Byte

instance.ContrastLimitLight = value

value = instance.ContrastLimitLight
public byte ContrastLimitLight {get; set;}
public: __property byte get_ContrastLimitLight();
public: __property void set_ContrastLimitLight(
   byte value
);
public:
property byte ContrastLimitLight {
   byte get();
   void set (    byte value);
}
Remarks

The default value is 127.

Valid values are 0 to 255.

This value determines how far in either direction a pixel in this range is allowed to shift when corrected using adaptive correction. A value of 0 will prevent any change to light pixels, while a value of 255 will allow maximum enhancement of contrast.

See Also

Reference

BrightnessContrastOptions Class
BrightnessContrastOptions Members


ContrastLimitMiddle Property

Accusoft.ScanFixXpress8.Net
ContrastLimitMiddle Property

Accusoft.ScanFixXpressSdk Namespace > BrightnessContrastOptions Class : ContrastLimitMiddle Property
Gets and sets the maximum contrast change for middle-range pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ContrastLimitMiddle As Byte
'Usage

Dim instance As BrightnessContrastOptions
Dim value As Byte

instance.ContrastLimitMiddle = value

value = instance.ContrastLimitMiddle
public byte ContrastLimitMiddle {get; set;}
public: __property byte get_ContrastLimitMiddle();
public: __property void set_ContrastLimitMiddle(
   byte value
);
public:
property byte ContrastLimitMiddle {
   byte get();
   void set (    byte value);
}
Remarks

The default value is 127.

Valid values are 0 to 255.

This value determines how far in either direction a pixel in this range is allowed to shift when corrected using adaptive correction. A value of 0 will prevent any change to light pixels, while a value of 255 will allow maximum enhancement of contrast.

See Also

Reference

BrightnessContrastOptions Class
BrightnessContrastOptions Members


MaximumPercentile Property

Accusoft.ScanFixXpress8.Net
MaximumPercentile Property

Accusoft.ScanFixXpressSdk Namespace > BrightnessContrastOptions Class : MaximumPercentile Property
Gets and sets the highest brightness percentile pixels to target for adjustment.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaximumPercentile As Integer
'Usage

Dim instance As BrightnessContrastOptions
Dim value As Integer

instance.MaximumPercentile = value

value = instance.MaximumPercentile
public int MaximumPercentile {get; set;}
public: __property int get_MaximumPercentile();
public: __property void set_MaximumPercentile(
   int value
);
public:
property int MaximumPercentile {
   int get();
   void set (    int value);
}
Remarks

The default value is 100.

Valid values are MinimumPercentile to 101.

This value sets the percentile brightness to be used for the contrast enhancement. For typical document images, the background color will be near the 50th percentile, so a value of 50 would push the background color to full brightness. The value 100 means to use the brightest pixel found, and a value of 101 means that the brightness will not be increased.

See Also

Reference

BrightnessContrastOptions Class
BrightnessContrastOptions Members


MinimumPercentile Property

Accusoft.ScanFixXpress8.Net
MinimumPercentile Property

Accusoft.ScanFixXpressSdk Namespace > BrightnessContrastOptions Class : MinimumPercentile Property
Gets and sets the lowest brightness percentile pixels to target for adjustment.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumPercentile As Integer
'Usage

Dim instance As BrightnessContrastOptions
Dim value As Integer

instance.MinimumPercentile = value

value = instance.MinimumPercentile
public int MinimumPercentile {get; set;}
public: __property int get_MinimumPercentile();
public: __property void set_MinimumPercentile(
   int value
);
public:
property int MinimumPercentile {
   int get();
   void set (    int value);
}
Remarks

The default value is 0.

Valid values are -1 to MaximumPercentile.

This value sets the percentile brightness to be used for the contrast enhancement. For typical document images, the text color will be at or below the 1st percentile, so a value of 1 would push the text color to pure black. The value 0 means to use the darkest pixel found, and a value of -1 means that the brightness will not be decreased.

See Also

Reference

BrightnessContrastOptions Class
BrightnessContrastOptions Members


Quality Property (BrightnessContrastOptions)

Accusoft.ScanFixXpress8.Net
Quality Property (BrightnessContrastOptions)

Accusoft.ScanFixXpressSdk Namespace > BrightnessContrastOptions Class : Quality Property
Gets and sets the amount of effort to expend analyzing the image to determine contrast.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Quality As Integer
'Usage

Dim instance As BrightnessContrastOptions
Dim value As Integer

instance.Quality = value

value = instance.Quality
public int Quality {get; set;}
public: __property int get_Quality();
public: __property void set_Quality(
   int value
);
public:
property int Quality {
   int get();
   void set (    int value);
}
Remarks

The default value is 50.

Valid values are 1 to 100.

This value sets the sampling density used during the brightness and contrast analysis. Small values will result in slightly faster performance, as well as a larger window size for adaptive correction. A high value will result in slightly slower performance, greater sensitivity to small regions of change, and a smaller window size for adaptive correction.

See Also

Reference

BrightnessContrastOptions Class
BrightnessContrastOptions Members


TargetBrightness Property

Accusoft.ScanFixXpress8.Net
TargetBrightness Property

Accusoft.ScanFixXpressSdk Namespace > BrightnessContrastOptions Class : TargetBrightness Property
Gets and sets the target brightness level for background of adjusted image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TargetBrightness As Byte
'Usage

Dim instance As BrightnessContrastOptions
Dim value As Byte

instance.TargetBrightness = value

value = instance.TargetBrightness
public byte TargetBrightness {get; set;}
public: __property byte get_TargetBrightness();
public: __property void set_TargetBrightness(
   byte value
);
public:
property byte TargetBrightness {
   byte get();
   void set (    byte value);
}
Remarks

The default value is 225.

Valid values are 0 to 255.

This value sets the target brightness level for the image background, calculated by using the 50th percentile brightness. If the calculated brightness is below the target, then a contrast correction method will be suggested.

See Also

Reference

BrightnessContrastOptions Class
BrightnessContrastOptions Members


TargetContrast Property

Accusoft.ScanFixXpress8.Net
TargetContrast Property

Accusoft.ScanFixXpressSdk Namespace > BrightnessContrastOptions Class : TargetContrast Property
Gets and sets the target contrast between foreground and background for the adjusted image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TargetContrast As Byte
'Usage

Dim instance As BrightnessContrastOptions
Dim value As Byte

instance.TargetContrast = value

value = instance.TargetContrast
public byte TargetContrast {get; set;}
public: __property byte get_TargetContrast();
public: __property void set_TargetContrast(
   byte value
);
public:
property byte TargetContrast {
   byte get();
   void set (    byte value);
}
Remarks

The default value is 127.

Valid values are 1 to 255.

This value sets the target contrast for document images, where contrast is calculated by comparing the 50th and 1st percentile brightness across the image. Images that have a contrast below the target range will have a contrast correction method recommended.

See Also

Reference

BrightnessContrastOptions Class
BrightnessContrastOptions Members


TargetVariance Property

Accusoft.ScanFixXpress8.Net
TargetVariance Property

Accusoft.ScanFixXpressSdk Namespace > BrightnessContrastOptions Class : TargetVariance Property
Gets and sets the largest allowable variance in brightness across the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TargetVariance As Byte
'Usage

Dim instance As BrightnessContrastOptions
Dim value As Byte

instance.TargetVariance = value

value = instance.TargetVariance
public byte TargetVariance {get; set;}
public: __property byte get_TargetVariance();
public: __property void set_TargetVariance(
   byte value
);
public:
property byte TargetVariance {
   byte get();
   void set (    byte value);
}
Remarks

The default value is 25.

Valid values are 0 to 255.

This value sets the allowable amount of change in the background color across an image. An example of this would be a book page scanned on a flatbed scanner, where one edge was darker than the rest due to the greater distances from the scanner bed. This image would have a relatively high background variance. The algorithm will suggest the adaptive correction method for images that exceed the allowable background variance.

See Also

Reference

BrightnessContrastOptions Class
BrightnessContrastOptions Members


BrightnessContrastResults Class

Accusoft.ScanFixXpress8.Net
BrightnessContrastResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : BrightnessContrastResults Class
Contains the output values from the contrast adjustment process.
Object Model
BrightnessContrastResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BrightnessContrastResults
   Inherits EnhancementResult
'Usage

Dim instance As BrightnessContrastResults
public class BrightnessContrastResults : EnhancementResult
public __gc class BrightnessContrastResults : public EnhancementResult
public ref class BrightnessContrastResults : public EnhancementResult
Remarks
A new BrightnessContrastResults object is created by the ScanFix.AdjustBrightnessContrast method.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.BrightnessContrastResults

See Also

Reference

BrightnessContrastResults Members
Accusoft.ScanFixXpressSdk Namespace


BrightnessContrastResults Class Members

Accusoft.ScanFixXpress8.Net
BrightnessContrastResults Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : BrightnessContrastResults Class

The following tables list the members exposed by BrightnessContrastResults.

Public Properties
 | Name | Description
Public Property | AverageBackground | Gets a value indicating average brightness of the image background.
Public Property | AverageContrast | Gets a value indicating average contrast between background (median color of a region) and foreground (dark colors in a region).
Public Property | BackgroundVariance | Gets a value indicating variance in background brightness.
Public Property | NoiseRadius | Gets a value indicating average amount of brightness variation within the background.
Public Property | PercentileGraph | Gets a collection where each value indicates brightness of pixels at that percentile.
Public Property | Suggestion | Gets a value indicating suggested contrast adjustment mechanism.
Top
See Also

Reference

BrightnessContrastResults Class
Accusoft.ScanFixXpressSdk Namespace


BrightnessContrastResults Class Properties

Accusoft.ScanFixXpress8.Net
BrightnessContrastResults Class Properties

Accusoft.ScanFixXpressSdk Namespace : BrightnessContrastResults Class

For a list of all members of this type, see BrightnessContrastResults members.

Public Properties
 | Name | Description
Public Property | AverageBackground | Gets a value indicating average brightness of the image background.
Public Property | AverageContrast | Gets a value indicating average contrast between background (median color of a region) and foreground (dark colors in a region).
Public Property | BackgroundVariance | Gets a value indicating variance in background brightness.
Public Property | NoiseRadius | Gets a value indicating average amount of brightness variation within the background.
Public Property | PercentileGraph | Gets a collection where each value indicates brightness of pixels at that percentile.
Public Property | Suggestion | Gets a value indicating suggested contrast adjustment mechanism.
Top
See Also

Reference

BrightnessContrastResults Class
Accusoft.ScanFixXpressSdk Namespace


AverageBackground Property

Accusoft.ScanFixXpress8.Net
AverageBackground Property

Accusoft.ScanFixXpressSdk Namespace > BrightnessContrastResults Class : AverageBackground Property
Gets a value indicating average brightness of the image background.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AverageBackground As Byte
'Usage

Dim instance As BrightnessContrastResults
Dim value As Byte

value = instance.AverageBackground
public byte AverageBackground {get;}
public: __property byte get_AverageBackground();
public:
property byte AverageBackground {
   byte get();
}
Remarks

This is calculated by looking at the median brightness across the image.

See Also

Reference

BrightnessContrastResults Class
BrightnessContrastResults Members


AverageContrast Property

Accusoft.ScanFixXpress8.Net
AverageContrast Property

Accusoft.ScanFixXpressSdk Namespace > BrightnessContrastResults Class : AverageContrast Property
Gets a value indicating average contrast between background (median color of a region) and foreground (dark colors in a region).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AverageContrast As Byte
'Usage

Dim instance As BrightnessContrastResults
Dim value As Byte

value = instance.AverageContrast
public byte AverageContrast {get;}
public: __property byte get_AverageContrast();
public:
property byte AverageContrast {
   byte get();
}
Remarks

This estimates the amount of contrast between the background color and dark objects such as text and lines.

See Also

Reference

BrightnessContrastResults Class
BrightnessContrastResults Members


BackgroundVariance Property

Accusoft.ScanFixXpress8.Net
BackgroundVariance Property

Accusoft.ScanFixXpressSdk Namespace > BrightnessContrastResults Class : BackgroundVariance Property
Gets a value indicating variance in background brightness.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BackgroundVariance As Byte
'Usage

Dim instance As BrightnessContrastResults
Dim value As Byte

value = instance.BackgroundVariance
public byte BackgroundVariance {get;}
public: __property byte get_BackgroundVariance();
public:
property byte BackgroundVariance {
   byte get();
}
Remarks

This is calculated by looking at the range of above median brightness across the image, which measures primarily high frequency changes.

See Also

Reference

BrightnessContrastResults Class
BrightnessContrastResults Members


NoiseRadius Property

Accusoft.ScanFixXpress8.Net
NoiseRadius Property

Accusoft.ScanFixXpressSdk Namespace > BrightnessContrastResults Class : NoiseRadius Property
Gets a value indicating average amount of brightness variation within the background.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property NoiseRadius As Byte
'Usage

Dim instance As BrightnessContrastResults
Dim value As Byte

value = instance.NoiseRadius
public byte NoiseRadius {get;}
public: __property byte get_NoiseRadius();
public:
property byte NoiseRadius {
   byte get();
}
Remarks

This is a measure of very low frequency variations, such as those caused by scanning a book on a flatbed scanner, where one edge of the image is darker due to its greater distance from the bed.

See Also

Reference

BrightnessContrastResults Class
BrightnessContrastResults Members


PercentileGraph Property

Accusoft.ScanFixXpress8.Net
PercentileGraph Property

Accusoft.ScanFixXpressSdk Namespace > BrightnessContrastResults Class : PercentileGraph Property
Gets a collection where each value indicates brightness of pixels at that percentile.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PercentileGraph As ReadOnlyCollection(Of Integer)
'Usage

Dim instance As BrightnessContrastResults
Dim value As ReadOnlyCollection(Of Integer)

value = instance.PercentileGraph
public ReadOnlyCollection<int> PercentileGraph {get;}
public: __property ReadOnlyCollection<int>* get_PercentileGraph();
public:
property ReadOnlyCollection<int>^ PercentileGraph {
   ReadOnlyCollection<int>^ get();
}
Remarks

This information can be analyzed and used during process design to choose appropriate values for the adjustment settings, or used to make further decisions about an image.

See Also

Reference

BrightnessContrastResults Class
BrightnessContrastResults Members


Suggestion Property

Accusoft.ScanFixXpress8.Net
Suggestion Property

Accusoft.ScanFixXpressSdk Namespace > BrightnessContrastResults Class : Suggestion Property
Gets a value indicating suggested contrast adjustment mechanism.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Suggestion As BrightnessContrastSuggestion
'Usage

Dim instance As BrightnessContrastResults
Dim value As BrightnessContrastSuggestion

value = instance.Suggestion
public BrightnessContrastSuggestion Suggestion {get;}
public: __property BrightnessContrastSuggestion get_Suggestion();
public:
property BrightnessContrastSuggestion Suggestion {
   BrightnessContrastSuggestion get();
}
Remarks

The suggestions depend on the required parameters. Images meeting the required parameters will not need to be corrected. Images with low AverageContrast and low BackgroundVariance should use global correct, while those with low AverageContrast and high BackgroundVariance should use adaptive correction. Images whose BackgroundVariance is too high relative to the AverageContrast will be reported as bad images.

See Also

Reference

BrightnessContrastResults Class
BrightnessContrastResults Members


ColorDropOptions Class

Accusoft.ScanFixXpress8.Net
ColorDropOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : ColorDropOptions Class
Contains parameters for the ScanFix.ColorDrop process.
Object Model
ColorDropOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ColorDropOptions
   Inherits EnhancementOption
'Usage

Dim instance As ColorDropOptions
public class ColorDropOptions : EnhancementOption
public __gc class ColorDropOptions : public EnhancementOption
public ref class ColorDropOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.ColorDropOptions

See Also

Reference

ColorDropOptions Members
Accusoft.ScanFixXpressSdk Namespace


ColorDropOptions Class Members

Accusoft.ScanFixXpress8.Net
ColorDropOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : ColorDropOptions Class

The following tables list the members exposed by ColorDropOptions.

Public Constructors
 | Name | Description
Public Constructor | ColorDropOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ColorRadiusList | Gets ColorRadius list object.
Public Property | DropToColor | Gets and sets color to which dropped colors will be converted.
Public Property | Extract | Gets and sets flag for extracting specified color regions and dropping all others to DropToColor.
Top
See Also

Reference

ColorDropOptions Class
Accusoft.ScanFixXpressSdk Namespace


ColorDropOptions Class Properties

Accusoft.ScanFixXpress8.Net
ColorDropOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : ColorDropOptions Class

For a list of all members of this type, see ColorDropOptions members.

Public Properties
 | Name | Description
Public Property | ColorRadiusList | Gets ColorRadius list object.
Public Property | DropToColor | Gets and sets color to which dropped colors will be converted.
Public Property | Extract | Gets and sets flag for extracting specified color regions and dropping all others to DropToColor.
Top
See Also

Reference

ColorDropOptions Class
Accusoft.ScanFixXpressSdk Namespace


ColorDropOptions Constructor

Accusoft.ScanFixXpress8.Net
ColorDropOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > ColorDropOptions Class : ColorDropOptions Constructor
Overload List
Overload | Description
ColorDropOptions Constructor() | Instantiates a new ColorDropOptions object with the default options.
ColorDropOptions Constructor(Boolean,Color,IEnumerable<ColorRadius>) | Instantiates a new ColorDropOptions object with the specified options.
See Also

Reference

ColorDropOptions Class
ColorDropOptions Members


ColorDropOptions Constructor()

Accusoft.ScanFixXpress8.Net
ColorDropOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > ColorDropOptions Class > ColorDropOptions Constructor : ColorDropOptions Constructor()
Instantiates a new ColorDropOptions object with the default options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New ColorDropOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public ColorDropOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: ColorDropOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
ColorDropOptions();
See Also

Reference

ColorDropOptions Class
ColorDropOptions Members
Overload List


ColorDropOptions Constructor(Boolean,Color,IEnumerable<ColorRadius>)

Accusoft.ScanFixXpress8.Net
ColorDropOptions Constructor(Boolean,Color,IEnumerable<ColorRadius>)

Accusoft.ScanFixXpressSdk Namespace > ColorDropOptions Class > ColorDropOptions Constructor : ColorDropOptions Constructor(Boolean,Color,IEnumerable<ColorRadius>)
Set to true to extract specified colors and drop all others to DropToColor.
Color that will be used for dropped colors
Color radius list
Instantiates a new ColorDropOptions object with the specified options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal extract As Boolean, _
   ByVal dropToColor As Color, _
   ByVal colorRadiusList As IEnumerable(Of ColorRadius) _
)
'Usage

Dim extract As Boolean
Dim dropToColor As Color
Dim colorRadiusList As IEnumerable(Of ColorRadius)

Dim instance As New ColorDropOptions(extract, dropToColor, colorRadiusList)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public ColorDropOptions(
   bool extract,
   Color dropToColor,
   IEnumerable<ColorRadius> colorRadiusList
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: ColorDropOptions(
   bool extract,
   Color dropToColor,
   IEnumerable<ColorRadius*>* colorRadiusList
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
ColorDropOptions(
   bool extract,
   Color dropToColor,
   IEnumerable<ColorRadius^>^ colorRadiusList
)

Parameters

extract
Set to true to extract specified colors and drop all others to DropToColor.
dropToColor
Color that will be used for dropped colors
colorRadiusList
Color radius list
Remarks
Use this to specify a custom color and radius.
See Also

Reference

ColorDropOptions Class
ColorDropOptions Members
Overload List


ColorRadiusList Property (ColorDropOptions)

Accusoft.ScanFixXpress8.Net
ColorRadiusList Property (ColorDropOptions)

Accusoft.ScanFixXpressSdk Namespace > ColorDropOptions Class : ColorRadiusList Property
Gets ColorRadius list object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ColorRadiusList As Collection(Of ColorRadius)
'Usage

Dim instance As ColorDropOptions
Dim value As Collection(Of ColorRadius)

value = instance.ColorRadiusList
public Collection<ColorRadius> ColorRadiusList {get;}
public: __property Collection<ColorRadius*>* get_ColorRadiusList();
public:
property Collection<ColorRadius^>^ ColorRadiusList {
   Collection<ColorRadius^>^ get();
}
Remarks

The ColorRadius list object holds multiple ColorRadius objects that define all color regions to drop.

See Also

Reference

ColorDropOptions Class
ColorDropOptions Members


DropToColor Property

Accusoft.ScanFixXpress8.Net
DropToColor Property

Accusoft.ScanFixXpressSdk Namespace > ColorDropOptions Class : DropToColor Property
Gets and sets color to which dropped colors will be converted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DropToColor As Color
'Usage

Dim instance As ColorDropOptions
Dim value As Color

instance.DropToColor = value

value = instance.DropToColor
public Color DropToColor {get; set;}
public: __property Color get_DropToColor();
public: __property void set_DropToColor(
   Color value
);
public:
property Color DropToColor {
   Color get();
   void set (    Color value);
}
Remarks

The default value is White.

See Also

Reference

ColorDropOptions Class
ColorDropOptions Members


Extract Property (ColorDropOptions)

Accusoft.ScanFixXpress8.Net
Extract Property (ColorDropOptions)

Accusoft.ScanFixXpressSdk Namespace > ColorDropOptions Class : Extract Property
Gets and sets flag for extracting specified color regions and dropping all others to DropToColor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Extract As Boolean
'Usage

Dim instance As ColorDropOptions
Dim value As Boolean

instance.Extract = value

value = instance.Extract
public bool Extract {get; set;}
public: __property bool get_Extract();
public: __property void set_Extract(
   bool value
);
public:
property bool Extract {
   bool get();
   void set (    bool value);
}
Remarks

The default value is false.

See Also

Reference

ColorDropOptions Class
ColorDropOptions Members


ColorDropResults Class

Accusoft.ScanFixXpress8.Net
ColorDropResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : ColorDropResults Class
Defines a place holder class for the ColorDrop enhancement result.
Object Model
ColorDropResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ColorDropResults
   Inherits EnhancementResult
'Usage

Dim instance As ColorDropResults
public class ColorDropResults : EnhancementResult
public __gc class ColorDropResults : public EnhancementResult
public ref class ColorDropResults : public EnhancementResult
Remarks
This class contains no data. Its presence in the results list is used to determine that the operation has run successfully.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.ColorDropResults

See Also

Reference

ColorDropResults Members
Accusoft.ScanFixXpressSdk Namespace


ColorDropResults Class Members

Accusoft.ScanFixXpress8.Net
ColorDropResults Class Members

Accusoft.ScanFixXpressSdk Namespace : ColorDropResults Class

The following tables list the members exposed by ColorDropResults.

See Also

Reference

ColorDropResults Class
Accusoft.ScanFixXpressSdk Namespace


ColorRadius Class

Accusoft.ScanFixXpress8.Net
ColorRadius Class
Members

Accusoft.ScanFixXpressSdk Namespace : ColorRadius Class
Lists a range of colors used by ImageDetergent and ColorDrop operations.
Object Model
ColorRadius Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ColorRadius
'Usage

Dim instance As ColorRadius
public class ColorRadius
public __gc class ColorRadius
public ref class ColorRadius
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.ColorRadius

See Also

Reference

ColorRadius Members
Accusoft.ScanFixXpressSdk Namespace


ColorRadius Class Members

Accusoft.ScanFixXpress8.Net
ColorRadius Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : ColorRadius Class

The following tables list the members exposed by ColorRadius.

Public Constructors
 | Name | Description
Public Constructor | ColorRadius Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Adaptive | Gets and sets flag for Adaptive option.
Public Property | Color | Gets and sets value for center of a region of color.
Public Property | Radius | Gets and sets radius around a specific color value in the RGB space to define a spherical region of color to operate on. This region is divided into an inner zone of half the radius and an outer zone comprising the rest of the sphere. Operations will fully convert colors in the inner half radius and then fade in effect to zero at the full radius.
Top
See Also

Reference

ColorRadius Class
Accusoft.ScanFixXpressSdk Namespace


ColorRadius Class Properties

Accusoft.ScanFixXpress8.Net
ColorRadius Class Properties

Accusoft.ScanFixXpressSdk Namespace : ColorRadius Class

For a list of all members of this type, see ColorRadius members.

Public Properties
 | Name | Description
Public Property | Adaptive | Gets and sets flag for Adaptive option.
Public Property | Color | Gets and sets value for center of a region of color.
Public Property | Radius | Gets and sets radius around a specific color value in the RGB space to define a spherical region of color to operate on. This region is divided into an inner zone of half the radius and an outer zone comprising the rest of the sphere. Operations will fully convert colors in the inner half radius and then fade in effect to zero at the full radius.
Top
See Also

Reference

ColorRadius Class
Accusoft.ScanFixXpressSdk Namespace


ColorRadius Constructor

Accusoft.ScanFixXpress8.Net
ColorRadius Constructor

Accusoft.ScanFixXpressSdk Namespace > ColorRadius Class : ColorRadius Constructor
Overload List
Overload | Description
ColorRadius Constructor() | Instantiates the default Color Radius object.
ColorRadius Constructor(Color,Int32,Boolean) | Instantiates a Color Radius object with the specified values.
See Also

Reference

ColorRadius Class
ColorRadius Members


ColorRadius Constructor()

Accusoft.ScanFixXpress8.Net
ColorRadius Constructor()

Accusoft.ScanFixXpressSdk Namespace > ColorRadius Class > ColorRadius Constructor : ColorRadius Constructor()
Instantiates the default Color Radius object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New ColorRadius()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public ColorRadius()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: ColorRadius();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
ColorRadius();
See Also

Reference

ColorRadius Class
ColorRadius Members
Overload List


ColorRadius Constructor(Color,Int32,Boolean)

Accusoft.ScanFixXpress8.Net
ColorRadius Constructor(Color,Int32,Boolean)

Accusoft.ScanFixXpressSdk Namespace > ColorRadius Class > ColorRadius Constructor : ColorRadius Constructor(Color,Int32,Boolean)
Color value.
Radius in color space.
Indicates whether to use adaptive color determination based on image data.
Instantiates a Color Radius object with the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal color As Color, _
   ByVal radius As Integer, _
   ByVal adaptive As Boolean _
)
'Usage

Dim color As Color
Dim radius As Integer
Dim adaptive As Boolean

Dim instance As New ColorRadius(color, radius, adaptive)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public ColorRadius(
   Color color,
   int radius,
   bool adaptive
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: ColorRadius(
   Color color,
   int radius,
   bool adaptive
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
ColorRadius(
   Color color,
   int radius,
   bool adaptive
)

Parameters

color
Color value.
radius
Radius in color space.
adaptive
Indicates whether to use adaptive color determination based on image data.
See Also

Reference

ColorRadius Class
ColorRadius Members
Overload List


Adaptive Property (ColorRadius)

Accusoft.ScanFixXpress8.Net
Adaptive Property (ColorRadius)

Accusoft.ScanFixXpressSdk Namespace > ColorRadius Class : Adaptive Property
Gets and sets flag for Adaptive option.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Adaptive As Boolean
'Usage

Dim instance As ColorRadius
Dim value As Boolean

instance.Adaptive = value

value = instance.Adaptive
public bool Adaptive {get; set;}
public: __property bool get_Adaptive();
public: __property void set_Adaptive(
   bool value
);
public:
property bool Adaptive {
   bool get();
   void set (    bool value);
}
Remarks

The default value is false.

When the Adaptive option is enabled ScanFix will analyze the image and shift the center of the region of color to match the largest local maximum (if one exists) in the immediate vicinity. This allows the region of color to shift to match slight changes in document colors within a set of documents to be processed.

See Also

Reference

ColorRadius Class
ColorRadius Members


Color Property

Accusoft.ScanFixXpress8.Net
Color Property

Accusoft.ScanFixXpressSdk Namespace > ColorRadius Class : Color Property
Gets and sets value for center of a region of color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Color As Color
'Usage

Dim instance As ColorRadius
Dim value As Color

instance.Color = value

value = instance.Color
public Color Color {get; set;}
public: __property Color get_Color();
public: __property void set_Color(
   Color value
);
public:
property Color Color {
   Color get();
   void set (    Color value);
}
See Also

Reference

ColorRadius Class
ColorRadius Members


Radius Property (ColorRadius)

Accusoft.ScanFixXpress8.Net
Radius Property (ColorRadius)

Accusoft.ScanFixXpressSdk Namespace > ColorRadius Class : Radius Property
Gets and sets radius around a specific color value in the RGB space to define a spherical region of color to operate on. This region is divided into an inner zone of half the radius and an outer zone comprising the rest of the sphere. Operations will fully convert colors in the inner half radius and then fade in effect to zero at the full radius.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Radius As Integer
'Usage

Dim instance As ColorRadius
Dim value As Integer

instance.Radius = value

value = instance.Radius
public int Radius {get; set;}
public: __property int get_Radius();
public: __property void set_Radius(
   int value
);
public:
property int Radius {
   int get();
   void set (    int value);
}
Remarks

The default value is 0.

Valid values are 0 to 884.

See Also

Reference

ColorRadius Class
ColorRadius Members


CombRemovalOptions Class

Accusoft.ScanFixXpress8.Net
CombRemovalOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : CombRemovalOptions Class
Contains parameters that control the ScanFix.RemoveCombs process.
Object Model
CombRemovalOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class CombRemovalOptions
   Inherits EnhancementOption
'Usage

Dim instance As CombRemovalOptions
public class CombRemovalOptions : EnhancementOption
public __gc class CombRemovalOptions : public EnhancementOption
public ref class CombRemovalOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.CombRemovalOptions

See Also

Reference

CombRemovalOptions Members
Accusoft.ScanFixXpressSdk Namespace


CombRemovalOptions Class Members

Accusoft.ScanFixXpress8.Net
CombRemovalOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : CombRemovalOptions Class

The following tables list the members exposed by CombRemovalOptions.

Public Constructors
 | Name | Description
Public Constructor | CombRemovalOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Area | Gets and sets the rectangular area of the image where the comb removal process will search.
Public Property | CombHeight | Gets and sets the typical height (in pixels) of a comb mark (measured from the top of the horizontal base line to the top of the mark).
Public Property | CombSpacing | Gets and sets the typical distance (in pixels) between comb marks.
Public Property | HorizontalLineThickness | Gets and sets the typical thickness (in pixels) of the horizontal lines that comprise the comb.
Public Property | MinimumCombLength | Gets and sets the minimum distance (in pixels) from the leftmost comb mark to the rightmost comb mark.
Public Property | MinimumConfidence | Gets and sets the confidence needed for an individual comb before it will be removed.
Public Property | VerticalLineThickness | Gets and sets the typical thickness (in pixels) of the vertical lines that comprise the comb.
Top
See Also

Reference

CombRemovalOptions Class
Accusoft.ScanFixXpressSdk Namespace


CombRemovalOptions Class Properties

Accusoft.ScanFixXpress8.Net
CombRemovalOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : CombRemovalOptions Class

For a list of all members of this type, see CombRemovalOptions members.

Public Properties
 | Name | Description
Public Property | Area | Gets and sets the rectangular area of the image where the comb removal process will search.
Public Property | CombHeight | Gets and sets the typical height (in pixels) of a comb mark (measured from the top of the horizontal base line to the top of the mark).
Public Property | CombSpacing | Gets and sets the typical distance (in pixels) between comb marks.
Public Property | HorizontalLineThickness | Gets and sets the typical thickness (in pixels) of the horizontal lines that comprise the comb.
Public Property | MinimumCombLength | Gets and sets the minimum distance (in pixels) from the leftmost comb mark to the rightmost comb mark.
Public Property | MinimumConfidence | Gets and sets the confidence needed for an individual comb before it will be removed.
Public Property | VerticalLineThickness | Gets and sets the typical thickness (in pixels) of the vertical lines that comprise the comb.
Top
See Also

Reference

CombRemovalOptions Class
Accusoft.ScanFixXpressSdk Namespace


CombRemovalOptions Constructor

Accusoft.ScanFixXpress8.Net
CombRemovalOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > CombRemovalOptions Class : CombRemovalOptions Constructor
Overload List
Overload | Description
CombRemovalOptions Constructor() | Instantiates a new CombRemovalOptions object setting the default values.
CombRemovalOptions Constructor(Rectangle,Int32,Int32,Int32,Int32,Int32,Int32) | Instantiates a new CombRemovalOptions object setting the specified values.
See Also

Reference

CombRemovalOptions Class
CombRemovalOptions Members


CombRemovalOptions Constructor()

Accusoft.ScanFixXpress8.Net
CombRemovalOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > CombRemovalOptions Class > CombRemovalOptions Constructor : CombRemovalOptions Constructor()
Instantiates a new CombRemovalOptions object setting the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New CombRemovalOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public CombRemovalOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: CombRemovalOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
CombRemovalOptions();
See Also

Reference

CombRemovalOptions Class
CombRemovalOptions Members
Overload List


CombRemovalOptions Constructor(Rectangle,Int32,Int32,Int32,Int32,Int32,Int32)

Accusoft.ScanFixXpress8.Net
CombRemovalOptions Constructor(Rectangle,Int32,Int32,Int32,Int32,Int32,Int32)

Accusoft.ScanFixXpressSdk Namespace > CombRemovalOptions Class > CombRemovalOptions Constructor : CombRemovalOptions Constructor(Rectangle,Int32,Int32,Int32,Int32,Int32,Int32)
The area of the image where the comb removal process will search.
The typical distance (in pixels) between comb marks.
The minimum distance (in pixels) from the leftmost comb mark to the rightmost comb mark.
The typical height (in pixels) of a comb mark (measured from the top of the horizontal base line to the top of the mark).
The typical thickness (in pixels) of the horizontal lines that comprise the comb.
The typical thickness (in pixels) of the vertical lines that comprise the comb.
The confidence of an individual comb before it will be removed.
Instantiates a new CombRemovalOptions object setting the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal area As Rectangle, _
   ByVal combSpacing As Integer, _
   ByVal minimumCombLength As Integer, _
   ByVal combHeight As Integer, _
   ByVal horizontalLineThickness As Integer, _
   ByVal verticalLineThickness As Integer, _
   ByVal minimumConfidence As Integer _
)
'Usage

Dim area As Rectangle
Dim combSpacing As Integer
Dim minimumCombLength As Integer
Dim combHeight As Integer
Dim horizontalLineThickness As Integer
Dim verticalLineThickness As Integer
Dim minimumConfidence As Integer

Dim instance As New CombRemovalOptions(area, combSpacing, minimumCombLength, combHeight, horizontalLineThickness, verticalLineThickness, minimumConfidence)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public CombRemovalOptions(
   Rectangle area,
   int combSpacing,
   int minimumCombLength,
   int combHeight,
   int horizontalLineThickness,
   int verticalLineThickness,
   int minimumConfidence
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: CombRemovalOptions(
   Rectangle area,
   int combSpacing,
   int minimumCombLength,
   int combHeight,
   int horizontalLineThickness,
   int verticalLineThickness,
   int minimumConfidence
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
CombRemovalOptions(
   Rectangle area,
   int combSpacing,
   int minimumCombLength,
   int combHeight,
   int horizontalLineThickness,
   int verticalLineThickness,
   int minimumConfidence
)

Parameters

area
The area of the image where the comb removal process will search.
combSpacing
The typical distance (in pixels) between comb marks.
minimumCombLength
The minimum distance (in pixels) from the leftmost comb mark to the rightmost comb mark.
combHeight
The typical height (in pixels) of a comb mark (measured from the top of the horizontal base line to the top of the mark).
horizontalLineThickness
The typical thickness (in pixels) of the horizontal lines that comprise the comb.
verticalLineThickness
The typical thickness (in pixels) of the vertical lines that comprise the comb.
minimumConfidence
The confidence of an individual comb before it will be removed.
See Also

Reference

CombRemovalOptions Class
CombRemovalOptions Members
Overload List


Area Property (CombRemovalOptions)

Accusoft.ScanFixXpress8.Net
Area Property (CombRemovalOptions)

Accusoft.ScanFixXpressSdk Namespace > CombRemovalOptions Class : Area Property
Gets and sets the rectangular area of the image where the comb removal process will search.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Area As Rectangle
'Usage

Dim instance As CombRemovalOptions
Dim value As Rectangle

instance.Area = value

value = instance.Area
public Rectangle Area {get; set;}
public: __property Rectangle get_Area();
public: __property void set_Area(
   Rectangle value
);
public:
property Rectangle Area {
   Rectangle get();
   void set (    Rectangle value);
}
Remarks

The default value is 0, 0, 0, 0.

See Also

Reference

CombRemovalOptions Class
CombRemovalOptions Members


CombHeight Property

Accusoft.ScanFixXpress8.Net
CombHeight Property

Accusoft.ScanFixXpressSdk Namespace > CombRemovalOptions Class : CombHeight Property
Gets and sets the typical height (in pixels) of a comb mark (measured from the top of the horizontal base line to the top of the mark).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CombHeight As Integer
'Usage

Dim instance As CombRemovalOptions
Dim value As Integer

instance.CombHeight = value

value = instance.CombHeight
public int CombHeight {get; set;}
public: __property int get_CombHeight();
public: __property void set_CombHeight(
   int value
);
public:
property int CombHeight {
   int get();
   void set (    int value);
}
Remarks

The default value is 20.

Valid values are 4 to 1000.

See Also

Reference

CombRemovalOptions Class
CombRemovalOptions Members


CombSpacing Property

Accusoft.ScanFixXpress8.Net
CombSpacing Property

Accusoft.ScanFixXpressSdk Namespace > CombRemovalOptions Class : CombSpacing Property
Gets and sets the typical distance (in pixels) between comb marks.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CombSpacing As Integer
'Usage

Dim instance As CombRemovalOptions
Dim value As Integer

instance.CombSpacing = value

value = instance.CombSpacing
public int CombSpacing {get; set;}
public: __property int get_CombSpacing();
public: __property void set_CombSpacing(
   int value
);
public:
property int CombSpacing {
   int get();
   void set (    int value);
}
Remarks

The default value is 25.

Valid values are 10 to 1000.

See Also

Reference

CombRemovalOptions Class
CombRemovalOptions Members


HorizontalLineThickness Property

Accusoft.ScanFixXpress8.Net
HorizontalLineThickness Property

Accusoft.ScanFixXpressSdk Namespace > CombRemovalOptions Class : HorizontalLineThickness Property
Gets and sets the typical thickness (in pixels) of the horizontal lines that comprise the comb.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HorizontalLineThickness As Integer
'Usage

Dim instance As CombRemovalOptions
Dim value As Integer

instance.HorizontalLineThickness = value

value = instance.HorizontalLineThickness
public int HorizontalLineThickness {get; set;}
public: __property int get_HorizontalLineThickness();
public: __property void set_HorizontalLineThickness(
   int value
);
public:
property int HorizontalLineThickness {
   int get();
   void set (    int value);
}
Remarks

The default value is 4.

Valid values are 1 to 20.

See Also

Reference

CombRemovalOptions Class
CombRemovalOptions Members


MinimumCombLength Property

Accusoft.ScanFixXpress8.Net
MinimumCombLength Property

Accusoft.ScanFixXpressSdk Namespace > CombRemovalOptions Class : MinimumCombLength Property
Gets and sets the minimum distance (in pixels) from the leftmost comb mark to the rightmost comb mark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumCombLength As Integer
'Usage

Dim instance As CombRemovalOptions
Dim value As Integer

instance.MinimumCombLength = value

value = instance.MinimumCombLength
public int MinimumCombLength {get; set;}
public: __property int get_MinimumCombLength();
public: __property void set_MinimumCombLength(
   int value
);
public:
property int MinimumCombLength {
   int get();
   void set (    int value);
}
Remarks

The default value is 50.

Valid values are 10 to 2,147,483,647.

See Also

Reference

CombRemovalOptions Class
CombRemovalOptions Members


MinimumConfidence Property (CombRemovalOptions)

Accusoft.ScanFixXpress8.Net
MinimumConfidence Property (CombRemovalOptions)

Accusoft.ScanFixXpressSdk Namespace > CombRemovalOptions Class : MinimumConfidence Property
Gets and sets the confidence needed for an individual comb before it will be removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumConfidence As Integer
'Usage

Dim instance As CombRemovalOptions
Dim value As Integer

instance.MinimumConfidence = value

value = instance.MinimumConfidence
public int MinimumConfidence {get; set;}
public: __property int get_MinimumConfidence();
public: __property void set_MinimumConfidence(
   int value
);
public:
property int MinimumConfidence {
   int get();
   void set (    int value);
}
Remarks

The default value is 50.

Valid values are 0 to 100.

See Also

Reference

CombRemovalOptions Class
CombRemovalOptions Members


VerticalLineThickness Property

Accusoft.ScanFixXpress8.Net
VerticalLineThickness Property

Accusoft.ScanFixXpressSdk Namespace > CombRemovalOptions Class : VerticalLineThickness Property
Gets and sets the typical thickness (in pixels) of the vertical lines that comprise the comb.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VerticalLineThickness As Integer
'Usage

Dim instance As CombRemovalOptions
Dim value As Integer

instance.VerticalLineThickness = value

value = instance.VerticalLineThickness
public int VerticalLineThickness {get; set;}
public: __property int get_VerticalLineThickness();
public: __property void set_VerticalLineThickness(
   int value
);
public:
property int VerticalLineThickness {
   int get();
   void set (    int value);
}
Remarks

The default value is 4.

Valid values are 1 to 20.

See Also

Reference

CombRemovalOptions Class
CombRemovalOptions Members


CombRemovalResults Class

Accusoft.ScanFixXpress8.Net
CombRemovalResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : CombRemovalResults Class
Contains output values from the comb removal process.
Object Model
CombRemovalResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class CombRemovalResults
   Inherits EnhancementResult
'Usage

Dim instance As CombRemovalResults
public class CombRemovalResults : EnhancementResult
public __gc class CombRemovalResults : public EnhancementResult
public ref class CombRemovalResults : public EnhancementResult
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.CombRemovalResults

See Also

Reference

CombRemovalResults Members
Accusoft.ScanFixXpressSdk Namespace


CombRemovalResults Class Members

Accusoft.ScanFixXpress8.Net
CombRemovalResults Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : CombRemovalResults Class

The following tables list the members exposed by CombRemovalResults.

Public Properties
 | Name | Description
Public Property | CountOfCombsFound | Gets the count of the combs meeting the given criteria that were found on the image.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified to remove combs.
Top
See Also

Reference

CombRemovalResults Class
Accusoft.ScanFixXpressSdk Namespace


CombRemovalResults Class Properties

Accusoft.ScanFixXpress8.Net
CombRemovalResults Class Properties

Accusoft.ScanFixXpressSdk Namespace : CombRemovalResults Class

For a list of all members of this type, see CombRemovalResults members.

Public Properties
 | Name | Description
Public Property | CountOfCombsFound | Gets the count of the combs meeting the given criteria that were found on the image.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified to remove combs.
Top
See Also

Reference

CombRemovalResults Class
Accusoft.ScanFixXpressSdk Namespace


CountOfCombsFound Property

Accusoft.ScanFixXpress8.Net
CountOfCombsFound Property

Accusoft.ScanFixXpressSdk Namespace > CombRemovalResults Class : CountOfCombsFound Property
Gets the count of the combs meeting the given criteria that were found on the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CountOfCombsFound As Integer
'Usage

Dim instance As CombRemovalResults
Dim value As Integer

value = instance.CountOfCombsFound
public int CountOfCombsFound {get;}
public: __property int get_CountOfCombsFound();
public:
property int CountOfCombsFound {
   int get();
}
See Also

Reference

CombRemovalResults Class
CombRemovalResults Members


ImageWasModified Property (CombRemovalResults)

Accusoft.ScanFixXpress8.Net
ImageWasModified Property (CombRemovalResults)

Accusoft.ScanFixXpressSdk Namespace > CombRemovalResults Class : ImageWasModified Property
Gets a flag that indicates whether the image was modified to remove combs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageWasModified As Boolean
'Usage

Dim instance As CombRemovalResults
Dim value As Boolean

value = instance.ImageWasModified
public bool ImageWasModified {get;}
public: __property bool get_ImageWasModified();
public:
property bool ImageWasModified {
   bool get();
}

Property Value

A boolean value which is True if the image was modified. Otherwise, False is returned.
See Also

Reference

CombRemovalResults Class
CombRemovalResults Members


DeskewOptions Class

Accusoft.ScanFixXpress8.Net
DeskewOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : DeskewOptions Class
Contains parameters for the ScanFix.Deskew process.
Object Model
DeskewOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DeskewOptions
   Inherits EnhancementOption
'Usage

Dim instance As DeskewOptions
public class DeskewOptions : EnhancementOption
public __gc class DeskewOptions : public EnhancementOption
public ref class DeskewOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.DeskewOptions

See Also

Reference

DeskewOptions Members
Accusoft.ScanFixXpressSdk Namespace


DeskewOptions Class Members

Accusoft.ScanFixXpress8.Net
DeskewOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : DeskewOptions Class

The following tables list the members exposed by DeskewOptions.

Public Constructors
 | Name | Description
Public Constructor | DeskewOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | MaintainOriginalSize | Gets and sets a flag to indicate whether the size of the image should be maintained unchanged, or allowed to change.
Public Property | MaximumAcceptableAngle | Gets and sets the maximum amount of skew (in degrees) that is considered acceptable by the caller.
Public Property | MinimumConfidence | Gets and sets the minimum detection confidence required before correction will proceed.
Public Property | MinimumCorrectableAngle | Gets and sets the minimum amount of skew (in degrees) that is considered correctable.
Public Property | PadColor | Gets and sets the color to use for pixels that are added to the image.
Public Property | Quality | Gets and sets a value that indicates the amount of effort to expend analyzing the image to determine skew.
Top
See Also

Reference

DeskewOptions Class
Accusoft.ScanFixXpressSdk Namespace


DeskewOptions Class Properties

Accusoft.ScanFixXpress8.Net
DeskewOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : DeskewOptions Class

For a list of all members of this type, see DeskewOptions members.

Public Properties
 | Name | Description
Public Property | MaintainOriginalSize | Gets and sets a flag to indicate whether the size of the image should be maintained unchanged, or allowed to change.
Public Property | MaximumAcceptableAngle | Gets and sets the maximum amount of skew (in degrees) that is considered acceptable by the caller.
Public Property | MinimumConfidence | Gets and sets the minimum detection confidence required before correction will proceed.
Public Property | MinimumCorrectableAngle | Gets and sets the minimum amount of skew (in degrees) that is considered correctable.
Public Property | PadColor | Gets and sets the color to use for pixels that are added to the image.
Public Property | Quality | Gets and sets a value that indicates the amount of effort to expend analyzing the image to determine skew.
Top
See Also

Reference

DeskewOptions Class
Accusoft.ScanFixXpressSdk Namespace


DeskewOptions Constructor

Accusoft.ScanFixXpress8.Net
DeskewOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > DeskewOptions Class : DeskewOptions Constructor
Overload List
Overload | Description
DeskewOptions Constructor() | Instantiates a new DeskewOptions class with the default values for the options.
DeskewOptions Constructor(Double,Int32,Color,Boolean,Int32) | Instantiates a new DeskewOptions class with the specified values for the options.
See Also

Reference

DeskewOptions Class
DeskewOptions Members


DeskewOptions Constructor()

Accusoft.ScanFixXpress8.Net
DeskewOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > DeskewOptions Class > DeskewOptions Constructor : DeskewOptions Constructor()
Instantiates a new DeskewOptions class with the default values for the options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New DeskewOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public DeskewOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: DeskewOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
DeskewOptions();
See Also

Reference

DeskewOptions Class
DeskewOptions Members
Overload List


DeskewOptions Constructor(Double,Int32,Color,Boolean,Int32)

Accusoft.ScanFixXpress8.Net
DeskewOptions Constructor(Double,Int32,Color,Boolean,Int32)

Accusoft.ScanFixXpressSdk Namespace > DeskewOptions Class > DeskewOptions Constructor : DeskewOptions Constructor(Double,Int32,Color,Boolean,Int32)
The minimum amount of skew (in degrees) that is considered correctable. Angles less than or equal to this amount will not be corrected. This value must be between 0 and 2. The default value is 0.2.
The minimum detection confidence required before correction will proceed. If the detection confidence is less than this value, the image will not be modified. This value must be an integer between 0 and 100. The default value is 50.
The color to use for pixels that are added to the image. Often, an image will be increased in size during skew correction to avoid discarding parts of the corners of the original image. Any color is acceptable, but the actual color used will be the nearest color that can be represented in the current image. The default value is white.
A flag to indicate whether the size of the image should be maintained unchanged, or allowed to change. Typically, this will be false and the deskewed image will be slightly larger than the original image. The default value is false.
A value that indicates the amount of effort to expend analyzing the image to determine skew.
Instantiates a new DeskewOptions class with the specified values for the options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New( _
   ByVal minimumCorrectableAngle As Double, _
   ByVal minimumConfidence As Integer, _
   ByVal padColor As Color, _
   ByVal maintainOriginalSize As Boolean, _
   ByVal quality As Integer _
)
'Usage

Dim minimumCorrectableAngle As Double
Dim minimumConfidence As Integer
Dim padColor As Color
Dim maintainOriginalSize As Boolean
Dim quality As Integer

Dim instance As New DeskewOptions(minimumCorrectableAngle, minimumConfidence, padColor, maintainOriginalSize, quality)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public DeskewOptions(
   double minimumCorrectableAngle,
   int minimumConfidence,
   Color padColor,
   bool maintainOriginalSize,
   int quality
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: DeskewOptions(
   double minimumCorrectableAngle,
   int minimumConfidence,
   Color padColor,
   bool maintainOriginalSize,
   int quality
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
DeskewOptions(
   double minimumCorrectableAngle,
   int minimumConfidence,
   Color padColor,
   bool maintainOriginalSize,
   int quality
)

Parameters

minimumCorrectableAngle
The minimum amount of skew (in degrees) that is considered correctable. Angles less than or equal to this amount will not be corrected. This value must be between 0 and 2. The default value is 0.2.
minimumConfidence
The minimum detection confidence required before correction will proceed. If the detection confidence is less than this value, the image will not be modified. This value must be an integer between 0 and 100. The default value is 50.
padColor
The color to use for pixels that are added to the image. Often, an image will be increased in size during skew correction to avoid discarding parts of the corners of the original image. Any color is acceptable, but the actual color used will be the nearest color that can be represented in the current image. The default value is white.
maintainOriginalSize
A flag to indicate whether the size of the image should be maintained unchanged, or allowed to change. Typically, this will be false and the deskewed image will be slightly larger than the original image. The default value is false.
quality
A value that indicates the amount of effort to expend analyzing the image to determine skew.
See Also

Reference

DeskewOptions Class
DeskewOptions Members
Overload List


MaintainOriginalSize Property

Accusoft.ScanFixXpress8.Net
MaintainOriginalSize Property

Accusoft.ScanFixXpressSdk Namespace > DeskewOptions Class : MaintainOriginalSize Property
Gets and sets a flag to indicate whether the size of the image should be maintained unchanged, or allowed to change.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaintainOriginalSize As Boolean
'Usage

Dim instance As DeskewOptions
Dim value As Boolean

instance.MaintainOriginalSize = value

value = instance.MaintainOriginalSize
public bool MaintainOriginalSize {get; set;}
public: __property bool get_MaintainOriginalSize();
public: __property void set_MaintainOriginalSize(
   bool value
);
public:
property bool MaintainOriginalSize {
   bool get();
   void set (    bool value);
}
Remarks

The default value is false.

Typically, this will be false and the deskewed image will be slightly larger than the original image.

See Also

Reference

DeskewOptions Class
DeskewOptions Members


MaximumAcceptableAngle Property

Accusoft.ScanFixXpress8.Net
MaximumAcceptableAngle Property

Accusoft.ScanFixXpressSdk Namespace > DeskewOptions Class : MaximumAcceptableAngle Property
Gets and sets the maximum amount of skew (in degrees) that is considered acceptable by the caller.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("Replaced by MinimumCorrectableAngle in ScanFix6")>
Public Property MaximumAcceptableAngle As Double
'Usage

Dim instance As DeskewOptions
Dim value As Double

instance.MaximumAcceptableAngle = value

value = instance.MaximumAcceptableAngle
[ObsoleteAttribute("Replaced by MinimumCorrectableAngle in ScanFix6")]
public double MaximumAcceptableAngle {get; set;}
[ObsoleteAttribute("Replaced by MinimumCorrectableAngle in ScanFix6")]
public: __property double get_MaximumAcceptableAngle();
public: __property void set_MaximumAcceptableAngle(
   double value
);
[ObsoleteAttribute("Replaced by MinimumCorrectableAngle in ScanFix6")]
public:
property double MaximumAcceptableAngle {
   double get();
   void set (    double value);
}
Remarks

The default value is 0.2.

Valid values are 0.0 to 2.0.

Angles less than or equal to this amount will not be corrected.

See Also

Reference

DeskewOptions Class
DeskewOptions Members


MinimumConfidence Property (DeskewOptions)

Accusoft.ScanFixXpress8.Net
MinimumConfidence Property (DeskewOptions)

Accusoft.ScanFixXpressSdk Namespace > DeskewOptions Class : MinimumConfidence Property
Gets and sets the minimum detection confidence required before correction will proceed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumConfidence As Integer
'Usage

Dim instance As DeskewOptions
Dim value As Integer

instance.MinimumConfidence = value

value = instance.MinimumConfidence
public int MinimumConfidence {get; set;}
public: __property int get_MinimumConfidence();
public: __property void set_MinimumConfidence(
   int value
);
public:
property int MinimumConfidence {
   int get();
   void set (    int value);
}
Remarks

The default value is 50.

Valid values are 0 to 100.

If the detection confidence is less than this value, the image will not be modified.

See Also

Reference

DeskewOptions Class
DeskewOptions Members


MinimumCorrectableAngle Property

Accusoft.ScanFixXpress8.Net
MinimumCorrectableAngle Property

Accusoft.ScanFixXpressSdk Namespace > DeskewOptions Class : MinimumCorrectableAngle Property
Gets and sets the minimum amount of skew (in degrees) that is considered correctable.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumCorrectableAngle As Double
'Usage

Dim instance As DeskewOptions
Dim value As Double

instance.MinimumCorrectableAngle = value

value = instance.MinimumCorrectableAngle
public double MinimumCorrectableAngle {get; set;}
public: __property double get_MinimumCorrectableAngle();
public: __property void set_MinimumCorrectableAngle(
   double value
);
public:
property double MinimumCorrectableAngle {
   double get();
   void set (    double value);
}
Remarks

The default value is 0.2.

Valid values are 0.0 to 2.0.

Angles less than or equal to this amount will not be corrected.

See Also

Reference

DeskewOptions Class
DeskewOptions Members


PadColor Property (DeskewOptions)

Accusoft.ScanFixXpress8.Net
PadColor Property (DeskewOptions)

Accusoft.ScanFixXpressSdk Namespace > DeskewOptions Class : PadColor Property
Gets and sets the color to use for pixels that are added to the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PadColor As Color
'Usage

Dim instance As DeskewOptions
Dim value As Color

instance.PadColor = value

value = instance.PadColor
public Color PadColor {get; set;}
public: __property Color get_PadColor();
public: __property void set_PadColor(
   Color value
);
public:
property Color PadColor {
   Color get();
   void set (    Color value);
}
Remarks

The default value is white.

Often, an image will be increased in size during skew correction to avoid discarding parts of the corners of the original image. Any color is acceptable, but the actual color used will be the nearest color that can be represented in the current image.

See Also

Reference

DeskewOptions Class
DeskewOptions Members


Quality Property (DeskewOptions)

Accusoft.ScanFixXpress8.Net
Quality Property (DeskewOptions)

Accusoft.ScanFixXpressSdk Namespace > DeskewOptions Class : Quality Property
Gets and sets a value that indicates the amount of effort to expend analyzing the image to determine skew.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Quality As Integer
'Usage

Dim instance As DeskewOptions
Dim value As Integer

instance.Quality = value

value = instance.Quality
public int Quality {get; set;}
public: __property int get_Quality();
public: __property void set_Quality(
   int value
);
public:
property int Quality {
   int get();
   void set (    int value);
}
Remarks

The default value is 80.

Valid values are 1 to 100.

See Also

Reference

DeskewOptions Class
DeskewOptions Members


DeskewResults Class

Accusoft.ScanFixXpress8.Net
DeskewResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : DeskewResults Class
Contains output values from the deskew process.
Object Model
DeskewResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DeskewResults
   Inherits EnhancementResult
'Usage

Dim instance As DeskewResults
public class DeskewResults : EnhancementResult
public __gc class DeskewResults : public EnhancementResult
public ref class DeskewResults : public EnhancementResult
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.DeskewResults

See Also

Reference

DeskewResults Members
Accusoft.ScanFixXpressSdk Namespace


DeskewResults Class Members

Accusoft.ScanFixXpress8.Net
DeskewResults Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : DeskewResults Class

The following tables list the members exposed by DeskewResults.

Public Properties
 | Name | Description
Public Property | Confidence | Gets the confidence of the skew detection process.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified to correct skew.
Public Property | RotationAngle | Gets the angle (in degrees) needed to rotate the image counter-clockwise to correct the skew of the image.
Public Property | Variation | Gets the amount of variation detected in the skew of the image.
Top
See Also

Reference

DeskewResults Class
Accusoft.ScanFixXpressSdk Namespace


DeskewResults Class Properties

Accusoft.ScanFixXpress8.Net
DeskewResults Class Properties

Accusoft.ScanFixXpressSdk Namespace : DeskewResults Class

For a list of all members of this type, see DeskewResults members.

Public Properties
 | Name | Description
Public Property | Confidence | Gets the confidence of the skew detection process.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified to correct skew.
Public Property | RotationAngle | Gets the angle (in degrees) needed to rotate the image counter-clockwise to correct the skew of the image.
Public Property | Variation | Gets the amount of variation detected in the skew of the image.
Top
See Also

Reference

DeskewResults Class
Accusoft.ScanFixXpressSdk Namespace


Confidence Property (DeskewResults)

Accusoft.ScanFixXpress8.Net
Confidence Property (DeskewResults)

Accusoft.ScanFixXpressSdk Namespace > DeskewResults Class : Confidence Property
Gets the confidence of the skew detection process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Confidence As Integer
'Usage

Dim instance As DeskewResults
Dim value As Integer

value = instance.Confidence
public int Confidence {get;}
public: __property int get_Confidence();
public:
property int Confidence {
   int get();
}
Remarks

The valid value range is between 0 and 100.

Higher values indicating a higher confidence that the skew was accurately detected.

See Also

Reference

DeskewResults Class
DeskewResults Members


ImageWasModified Property (DeskewResults)

Accusoft.ScanFixXpress8.Net
ImageWasModified Property (DeskewResults)

Accusoft.ScanFixXpressSdk Namespace > DeskewResults Class : ImageWasModified Property
Gets a flag that indicates whether the image was modified to correct skew.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageWasModified As Boolean
'Usage

Dim instance As DeskewResults
Dim value As Boolean

value = instance.ImageWasModified
public bool ImageWasModified {get;}
public: __property bool get_ImageWasModified();
public:
property bool ImageWasModified {
   bool get();
}
Remarks

This will be true unless the detection confidence is less than DeskewOptions.MinimumConfidence or the rotation angle is less than or equal to DeskewOptions.MaximumAcceptableAngle.

See Also

Reference

DeskewResults Class
DeskewResults Members


RotationAngle Property

Accusoft.ScanFixXpress8.Net
RotationAngle Property

Accusoft.ScanFixXpressSdk Namespace > DeskewResults Class : RotationAngle Property
Gets the angle (in degrees) needed to rotate the image counter-clockwise to correct the skew of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property RotationAngle As Double
'Usage

Dim instance As DeskewResults
Dim value As Double

value = instance.RotationAngle
public double RotationAngle {get;}
public: __property double get_RotationAngle();
public:
property double RotationAngle {
   double get();
}
Remarks

The valid value range is between -20 and 20.

Note: This number may be set to a value other than 0 even if the image was not modified. This will occur if the detection confidence is less than DeskewOptions.MinimumConfidence or if the rotation angle is less than or equal to DeskewOptions.MaximumAcceptableAngle.

See Also

Reference

DeskewResults Class
DeskewResults Members


Variation Property

Accusoft.ScanFixXpress8.Net
Variation Property

Accusoft.ScanFixXpressSdk Namespace > DeskewResults Class : Variation Property
Gets the amount of variation detected in the skew of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Variation As Integer
'Usage

Dim instance As DeskewResults
Dim value As Integer

value = instance.Variation
public int Variation {get;}
public: __property int get_Variation();
public:
property int Variation {
   int get();
}
Remarks

The valid value range is between 0 and 100.

Higher values indicating greater skew variation. This value will typically be high if the horizontal and vertical skews do not match or if different parts of the image are skewed by different amounts.

See Also

Reference

DeskewResults Class
DeskewResults Members


DespeckleOptions Class

Accusoft.ScanFixXpress8.Net
DespeckleOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : DespeckleOptions Class
Contains parameters for the ScanFix.Despeckle process.
Object Model
DespeckleOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DespeckleOptions
   Inherits EnhancementOption
'Usage

Dim instance As DespeckleOptions
public class DespeckleOptions : EnhancementOption
public __gc class DespeckleOptions : public EnhancementOption
public ref class DespeckleOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.DespeckleOptions

See Also

Reference

DespeckleOptions Members
Accusoft.ScanFixXpressSdk Namespace


DespeckleOptions Class Members

Accusoft.ScanFixXpress8.Net
DespeckleOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : DespeckleOptions Class

The following tables list the members exposed by DespeckleOptions.

Public Constructors
 | Name | Description
Public Constructor | DespeckleOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | SpeckHeight | Gets and sets the maximum pixel height that an object can have to be considered a speck.
Public Property | SpeckWidth | Gets and sets the maximum pixel width that an object can have to be considered a speck.
Top
See Also

Reference

DespeckleOptions Class
Accusoft.ScanFixXpressSdk Namespace


DespeckleOptions Class Properties

Accusoft.ScanFixXpress8.Net
DespeckleOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : DespeckleOptions Class

For a list of all members of this type, see DespeckleOptions members.

Public Properties
 | Name | Description
Public Property | SpeckHeight | Gets and sets the maximum pixel height that an object can have to be considered a speck.
Public Property | SpeckWidth | Gets and sets the maximum pixel width that an object can have to be considered a speck.
Top
See Also

Reference

DespeckleOptions Class
Accusoft.ScanFixXpressSdk Namespace


DespeckleOptions Constructor

Accusoft.ScanFixXpress8.Net
DespeckleOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > DespeckleOptions Class : DespeckleOptions Constructor
Overload List
Overload | Description
DespeckleOptions Constructor() | Instantiates a new DespeckleOptions object with the default options set.
DespeckleOptions Constructor(Int32,Int32) | Instantiates a new DespeckleOptions object setting the specified options.
See Also

Reference

DespeckleOptions Class
DespeckleOptions Members


DespeckleOptions Constructor()

Accusoft.ScanFixXpress8.Net
DespeckleOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > DespeckleOptions Class > DespeckleOptions Constructor : DespeckleOptions Constructor()
Instantiates a new DespeckleOptions object with the default options set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New()
'Usage

Dim instance As New DespeckleOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public DespeckleOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: DespeckleOptions();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
DespeckleOptions();
See Also

Reference

DespeckleOptions Class
DespeckleOptions Members
Overload List


DespeckleOptions Constructor(Int32,Int32)

Accusoft.ScanFixXpress8.Net
DespeckleOptions Constructor(Int32,Int32)

Accusoft.ScanFixXpressSdk Namespace > DespeckleOptions Class > DespeckleOptions Constructor : DespeckleOptions Constructor(Int32,Int32)
The maximum pixel width that an object can have to be considered a speck. Valid values are positive integer values of one or greater. The default value is 2.
The maximum pixel height that an object can have to be considered a speck. Valid values are positive integer values of one or greater. The default value is 2.
Instantiates a new DespeckleOptions object setting the specified options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New( _
   ByVal speckWidth As Integer, _
   ByVal speckHeight As Integer _
)
'Usage

Dim speckWidth As Integer
Dim speckHeight As Integer

Dim instance As New DespeckleOptions(speckWidth, speckHeight)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public DespeckleOptions(
   int speckWidth,
   int speckHeight
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: DespeckleOptions(
   int speckWidth,
   int speckHeight
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
DespeckleOptions(
   int speckWidth,
   int speckHeight
)

Parameters

speckWidth
The maximum pixel width that an object can have to be considered a speck. Valid values are positive integer values of one or greater. The default value is 2.
speckHeight
The maximum pixel height that an object can have to be considered a speck. Valid values are positive integer values of one or greater. The default value is 2.
See Also

Reference

DespeckleOptions Class
DespeckleOptions Members
Overload List


SpeckHeight Property

Accusoft.ScanFixXpress8.Net
SpeckHeight Property

Accusoft.ScanFixXpressSdk Namespace > DespeckleOptions Class : SpeckHeight Property
Gets and sets the maximum pixel height that an object can have to be considered a speck.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpeckHeight As Integer
'Usage

Dim instance As DespeckleOptions
Dim value As Integer

instance.SpeckHeight = value

value = instance.SpeckHeight
public int SpeckHeight {get; set;}
public: __property int get_SpeckHeight();
public: __property void set_SpeckHeight(
   int value
);
public:
property int SpeckHeight {
   int get();
   void set (    int value);
}
Remarks

The default value is 2.

Valid values are 1 to 100.

See Also

Reference

DespeckleOptions Class
DespeckleOptions Members


SpeckWidth Property

Accusoft.ScanFixXpress8.Net
SpeckWidth Property

Accusoft.ScanFixXpressSdk Namespace > DespeckleOptions Class : SpeckWidth Property
Gets and sets the maximum pixel width that an object can have to be considered a speck.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpeckWidth As Integer
'Usage

Dim instance As DespeckleOptions
Dim value As Integer

instance.SpeckWidth = value

value = instance.SpeckWidth
public int SpeckWidth {get; set;}
public: __property int get_SpeckWidth();
public: __property void set_SpeckWidth(
   int value
);
public:
property int SpeckWidth {
   int get();
   void set (    int value);
}
Remarks

The default value is 2.

Valid values are 1 to 100.

See Also

Reference

DespeckleOptions Class
DespeckleOptions Members


DespeckleResults Class

Accusoft.ScanFixXpress8.Net
DespeckleResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : DespeckleResults Class
Contains output values from the despeckle process.
Object Model
DespeckleResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DespeckleResults
   Inherits EnhancementResult
'Usage

Dim instance As DespeckleResults
public class DespeckleResults : EnhancementResult
public __gc class DespeckleResults : public EnhancementResult
public ref class DespeckleResults : public EnhancementResult
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.DespeckleResults

See Also

Reference

DespeckleResults Members
Accusoft.ScanFixXpressSdk Namespace


DespeckleResults Class Members

Accusoft.ScanFixXpress8.Net
DespeckleResults Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : DespeckleResults Class

The following tables list the members exposed by DespeckleResults.

Public Properties
 | Name | Description
Public Property | CountOfSpecksFound | Gets the number of specks found that met the input criteria.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified to remove specks.
Top
See Also

Reference

DespeckleResults Class
Accusoft.ScanFixXpressSdk Namespace


DespeckleResults Class Properties

Accusoft.ScanFixXpress8.Net
DespeckleResults Class Properties

Accusoft.ScanFixXpressSdk Namespace : DespeckleResults Class

For a list of all members of this type, see DespeckleResults members.

Public Properties
 | Name | Description
Public Property | CountOfSpecksFound | Gets the number of specks found that met the input criteria.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified to remove specks.
Top
See Also

Reference

DespeckleResults Class
Accusoft.ScanFixXpressSdk Namespace


CountOfSpecksFound Property (DespeckleResults)

Accusoft.ScanFixXpress8.Net
CountOfSpecksFound Property (DespeckleResults)

Accusoft.ScanFixXpressSdk Namespace > DespeckleResults Class : CountOfSpecksFound Property
Gets the number of specks found that met the input criteria.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CountOfSpecksFound As Integer
'Usage

Dim instance As DespeckleResults
Dim value As Integer

value = instance.CountOfSpecksFound
public int CountOfSpecksFound {get;}
public: __property int get_CountOfSpecksFound();
public:
property int CountOfSpecksFound {
   int get();
}
See Also

Reference

DespeckleResults Class
DespeckleResults Members


ImageWasModified Property (DespeckleResults)

Accusoft.ScanFixXpress8.Net
ImageWasModified Property (DespeckleResults)

Accusoft.ScanFixXpressSdk Namespace > DespeckleResults Class : ImageWasModified Property
Gets a flag that indicates whether the image was modified to remove specks.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageWasModified As Boolean
'Usage

Dim instance As DespeckleResults
Dim value As Boolean

value = instance.ImageWasModified
public bool ImageWasModified {get;}
public: __property bool get_ImageWasModified();
public:
property bool ImageWasModified {
   bool get();
}
Remarks

This will be true unless the CountOfSpecksFound parameter is zero.

See Also

Reference

DespeckleResults Class
DespeckleResults Members


DetectColorOptions Class

Accusoft.ScanFixXpress8.Net
DetectColorOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : DetectColorOptions Class
Contains parameters for the ScanFix.DetectColor process.
Object Model
DetectColorOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DetectColorOptions
   Inherits EnhancementOption
'Usage

Dim instance As DetectColorOptions
public class DetectColorOptions : EnhancementOption
public __gc class DetectColorOptions : public EnhancementOption
public ref class DetectColorOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.DetectColorOptions

See Also

Reference

DetectColorOptions Members
Accusoft.ScanFixXpressSdk Namespace


DetectColorOptions Class Members

Accusoft.ScanFixXpress8.Net
DetectColorOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : DetectColorOptions Class

The following tables list the members exposed by DetectColorOptions.

Public Constructors
 | Name | Description
Public Constructor | DetectColorOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BoxOverlap | Gets and sets the percentage of area (smaller box) that must intersect before bounding boxes are merged.
Public Property | GenerateBoxes | Gets and sets a flag for whether to generate a list of bounding boxes in the results.
Public Property | IgnorePaperColor | Gets and sets a value that indicates whether to ignore the paper color.
Public Property | MinimumBrightness | Gets and sets the minimum brightness ("V" in HSV colorspace) required for a pixel to be considered "color".
Public Property | MinimumSaturation | Gets and sets the minimum saturation ("S" in HSV colorspace) required for a pixel to be considered "color".
Public Property | MinimumSize | Gets and sets the minimum size, length or width in pixels, required for a saturated object to be considered colored data.
Public Property | Sensitivity | Gets and sets the number of saturated objects required for a high confidence IsColor result.
Top
See Also

Reference

DetectColorOptions Class
Accusoft.ScanFixXpressSdk Namespace


DetectColorOptions Class Properties

Accusoft.ScanFixXpress8.Net
DetectColorOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : DetectColorOptions Class

For a list of all members of this type, see DetectColorOptions members.

Public Properties
 | Name | Description
Public Property | BoxOverlap | Gets and sets the percentage of area (smaller box) that must intersect before bounding boxes are merged.
Public Property | GenerateBoxes | Gets and sets a flag for whether to generate a list of bounding boxes in the results.
Public Property | IgnorePaperColor | Gets and sets a value that indicates whether to ignore the paper color.
Public Property | MinimumBrightness | Gets and sets the minimum brightness ("V" in HSV colorspace) required for a pixel to be considered "color".
Public Property | MinimumSaturation | Gets and sets the minimum saturation ("S" in HSV colorspace) required for a pixel to be considered "color".
Public Property | MinimumSize | Gets and sets the minimum size, length or width in pixels, required for a saturated object to be considered colored data.
Public Property | Sensitivity | Gets and sets the number of saturated objects required for a high confidence IsColor result.
Top
See Also

Reference

DetectColorOptions Class
Accusoft.ScanFixXpressSdk Namespace


DetectColorOptions Constructor

Accusoft.ScanFixXpress8.Net
DetectColorOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > DetectColorOptions Class : DetectColorOptions Constructor
Overload List
Overload | Description
DetectColorOptions Constructor() | Instantiates a new DetectColorOptions object with the default values set.
DetectColorOptions Constructor(Boolean,Byte,Byte,Int32,Byte,Boolean,Byte) | Instantiates a new DetectColorOptions object setting the specified values.
See Also

Reference

DetectColorOptions Class
DetectColorOptions Members


DetectColorOptions Constructor()

Accusoft.ScanFixXpress8.Net
DetectColorOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > DetectColorOptions Class > DetectColorOptions Constructor : DetectColorOptions Constructor()
Instantiates a new DetectColorOptions object with the default values set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New DetectColorOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public DetectColorOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: DetectColorOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
DetectColorOptions();
See Also

Reference

DetectColorOptions Class
DetectColorOptions Members
Overload List


DetectColorOptions Constructor(Boolean,Byte,Byte,Int32,Byte,Boolean,Byte)

Accusoft.ScanFixXpress8.Net
DetectColorOptions Constructor(Boolean,Byte,Byte,Int32,Byte,Boolean,Byte)

Accusoft.ScanFixXpressSdk Namespace > DetectColorOptions Class > DetectColorOptions Constructor : DetectColorOptions Constructor(Boolean,Byte,Byte,Int32,Byte,Boolean,Byte)
Whether to ignore the paper color.
Minimum saturation ("S" in HSV color space) required for a pixel to be considered "color".
Minimum brightness ("V" in HSV color space) required for a pixel to be considered "color".
Minimum size, length and width, required for a saturated object to be considered colored data.
How many saturated objects are required for a high confidence IsColor result.
Whether to generate a list of bounding boxes in the results.
Percentage of area (smaller box) that must intersect before bounding boxes are merged.
Instantiates a new DetectColorOptions object setting the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal ignorePaperColor As Boolean, _
   ByVal minimumSaturation As Byte, _
   ByVal minimumBrightness As Byte, _
   ByVal minimumSize As Integer, _
   ByVal sensitivity As Byte, _
   ByVal generateBoxes As Boolean, _
   ByVal boxOverlap As Byte _
)
'Usage

Dim ignorePaperColor As Boolean
Dim minimumSaturation As Byte
Dim minimumBrightness As Byte
Dim minimumSize As Integer
Dim sensitivity As Byte
Dim generateBoxes As Boolean
Dim boxOverlap As Byte

Dim instance As New DetectColorOptions(ignorePaperColor, minimumSaturation, minimumBrightness, minimumSize, sensitivity, generateBoxes, boxOverlap)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public DetectColorOptions(
   bool ignorePaperColor,
   byte minimumSaturation,
   byte minimumBrightness,
   int minimumSize,
   byte sensitivity,
   bool generateBoxes,
   byte boxOverlap
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: DetectColorOptions(
   bool ignorePaperColor,
   byte minimumSaturation,
   byte minimumBrightness,
   int minimumSize,
   byte sensitivity,
   bool generateBoxes,
   byte boxOverlap
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
DetectColorOptions(
   bool ignorePaperColor,
   byte minimumSaturation,
   byte minimumBrightness,
   int minimumSize,
   byte sensitivity,
   bool generateBoxes,
   byte boxOverlap
)

Parameters

ignorePaperColor
Whether to ignore the paper color.
minimumSaturation
Minimum saturation ("S" in HSV color space) required for a pixel to be considered "color".
minimumBrightness
Minimum brightness ("V" in HSV color space) required for a pixel to be considered "color".
minimumSize
Minimum size, length and width, required for a saturated object to be considered colored data.
sensitivity
How many saturated objects are required for a high confidence IsColor result.
generateBoxes
Whether to generate a list of bounding boxes in the results.
boxOverlap
Percentage of area (smaller box) that must intersect before bounding boxes are merged.
See Also

Reference

DetectColorOptions Class
DetectColorOptions Members
Overload List


BoxOverlap Property

Accusoft.ScanFixXpress8.Net
BoxOverlap Property

Accusoft.ScanFixXpressSdk Namespace > DetectColorOptions Class : BoxOverlap Property
Gets and sets the percentage of area (smaller box) that must intersect before bounding boxes are merged.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BoxOverlap As Byte
'Usage

Dim instance As DetectColorOptions
Dim value As Byte

instance.BoxOverlap = value

value = instance.BoxOverlap
public byte BoxOverlap {get; set;}
public: __property byte get_BoxOverlap();
public: __property void set_BoxOverlap(
   byte value
);
public:
property byte BoxOverlap {
   byte get();
   void set (    byte value);
}
Remarks

The default value is 50.

Valid values are 0 to 100.

This option is used when DetectColor is used to locate colored regions on the page. In some cases, regions of color, such as highlighter over text, will be broken down into many smaller regions of color. A value of 100 will result in no boxes being combined, even if one box is located entirely within another; a value of 0 will result in all boxes that intersect to any degree being combined.

See Also

Reference

DetectColorOptions Class
DetectColorOptions Members


GenerateBoxes Property

Accusoft.ScanFixXpress8.Net
GenerateBoxes Property

Accusoft.ScanFixXpressSdk Namespace > DetectColorOptions Class : GenerateBoxes Property
Gets and sets a flag for whether to generate a list of bounding boxes in the results.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GenerateBoxes As Boolean
'Usage

Dim instance As DetectColorOptions
Dim value As Boolean

instance.GenerateBoxes = value

value = instance.GenerateBoxes
public bool GenerateBoxes {get; set;}
public: __property bool get_GenerateBoxes();
public: __property void set_GenerateBoxes(
   bool value
);
public:
property bool GenerateBoxes {
   bool get();
   void set (    bool value);
}
Remarks

The default value is false.

This option should be set to true when detect color is to be used to locate areas of color on the page. This will result in list of bounding boxes being generated for all areas that meet the minimum requirements for "color."

See Also

Reference

DetectColorOptions Class
DetectColorOptions Members


IgnorePaperColor Property

Accusoft.ScanFixXpress8.Net
IgnorePaperColor Property

Accusoft.ScanFixXpressSdk Namespace > DetectColorOptions Class : IgnorePaperColor Property
Gets and sets a value that indicates whether to ignore the paper color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IgnorePaperColor As Boolean
'Usage

Dim instance As DetectColorOptions
Dim value As Boolean

instance.IgnorePaperColor = value

value = instance.IgnorePaperColor
public bool IgnorePaperColor {get; set;}
public: __property bool get_IgnorePaperColor();
public: __property void set_IgnorePaperColor(
   bool value
);
public:
property bool IgnorePaperColor {
   bool get();
   void set (    bool value);
}
Remarks

The default value is false.

This option is used to handle cases where data is printed on colored paper. With this option enabled a modified VirtualBulb operation is performed internally, dropping the average color of the image overall to pure white. DetectColor will then consider the modified internal image to determine if color objects are present after the paper color has been removed.

See Also

Reference

DetectColorOptions Class
DetectColorOptions Members


MinimumBrightness Property

Accusoft.ScanFixXpress8.Net
MinimumBrightness Property

Accusoft.ScanFixXpressSdk Namespace > DetectColorOptions Class : MinimumBrightness Property
Gets and sets the minimum brightness ("V" in HSV colorspace) required for a pixel to be considered "color".
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumBrightness As Byte
'Usage

Dim instance As DetectColorOptions
Dim value As Byte

instance.MinimumBrightness = value

value = instance.MinimumBrightness
public byte MinimumBrightness {get; set;}
public: __property byte get_MinimumBrightness();
public: __property void set_MinimumBrightness(
   byte value
);
public:
property byte MinimumBrightness {
   byte get();
   void set (    byte value);
}
Remarks

The default value is 100,

Valid values are 0 to 255.

See Also

Reference

DetectColorOptions Class
DetectColorOptions Members


MinimumSaturation Property

Accusoft.ScanFixXpress8.Net
MinimumSaturation Property

Accusoft.ScanFixXpressSdk Namespace > DetectColorOptions Class : MinimumSaturation Property
Gets and sets the minimum saturation ("S" in HSV colorspace) required for a pixel to be considered "color".
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumSaturation As Byte
'Usage

Dim instance As DetectColorOptions
Dim value As Byte

instance.MinimumSaturation = value

value = instance.MinimumSaturation
public byte MinimumSaturation {get; set;}
public: __property byte get_MinimumSaturation();
public: __property void set_MinimumSaturation(
   byte value
);
public:
property byte MinimumSaturation {
   byte get();
   void set (    byte value);
}
Remarks

The default value is 75.

Valid values are 0 to 255.

See Also

Reference

DetectColorOptions Class
DetectColorOptions Members


MinimumSize Property

Accusoft.ScanFixXpress8.Net
MinimumSize Property

Accusoft.ScanFixXpressSdk Namespace > DetectColorOptions Class : MinimumSize Property
Gets and sets the minimum size, length or width in pixels, required for a saturated object to be considered colored data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumSize As Integer
'Usage

Dim instance As DetectColorOptions
Dim value As Integer

instance.MinimumSize = value

value = instance.MinimumSize
public int MinimumSize {get; set;}
public: __property int get_MinimumSize();
public: __property void set_MinimumSize(
   int value
);
public:
property int MinimumSize {
   int get();
   void set (    int value);
}
Remarks

The default value is 10.

Valid values are 1 to 10000.

See Also

Reference

DetectColorOptions Class
DetectColorOptions Members


Sensitivity Property

Accusoft.ScanFixXpress8.Net
Sensitivity Property

Accusoft.ScanFixXpressSdk Namespace > DetectColorOptions Class : Sensitivity Property
Gets and sets the number of saturated objects required for a high confidence IsColor result.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Sensitivity As Byte
'Usage

Dim instance As DetectColorOptions
Dim value As Byte

instance.Sensitivity = value

value = instance.Sensitivity
public byte Sensitivity {get; set;}
public: __property byte get_Sensitivity();
public: __property void set_Sensitivity(
   byte value
);
public:
property byte Sensitivity {
   byte get();
   void set (    byte value);
}
Remarks

The default value is 90.

Valid values are 0 to 100.

This value is not linear; it is used to control a sensitivity function that sets the object count threshold. A value of 100 will trigger on a single matching object, while lower values will require more objects to trigger an IsColor result. A value of zero will require thousands of objects for an IsColor result.

See Also

Reference

DetectColorOptions Class
DetectColorOptions Members


DetectColorResults Class

Accusoft.ScanFixXpress8.Net
DetectColorResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : DetectColorResults Class
Contains output values from the DetectColor process.
Object Model
DetectColorResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DetectColorResults
   Inherits EnhancementResult
'Usage

Dim instance As DetectColorResults
public class DetectColorResults : EnhancementResult
public __gc class DetectColorResults : public EnhancementResult
public ref class DetectColorResults : public EnhancementResult
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.DetectColorResults

See Also

Reference

DetectColorResults Members
Accusoft.ScanFixXpressSdk Namespace


DetectColorResults Class Members

Accusoft.ScanFixXpress8.Net
DetectColorResults Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : DetectColorResults Class

The following tables list the members exposed by DetectColorResults.

Public Properties
 | Name | Description
Public Property | AverageSaturation | Gets a value indicating average saturation value for the image.
Public Property | BigObjects | Gets a value indicating weighted count of color objects larger than DetectColorOptions.MinimumSize.
Public Property | BoxList | Gets a collection where each member contains bounding box coordinates for one object in the image.
Public Property | Confidence | Gets a value indicating confidence level for the IsColor value.
Public Property | Findings | Gets a collection with finding information from the color detection process.
Public Property | IsColor | Gets a value indicating whether image is considered to be color.
Public Property | SmallObjects | Gets a value indicating weighted count of objects near, but smaller than, DetectColorOptions.MinimumSize.
Top
See Also

Reference

DetectColorResults Class
Accusoft.ScanFixXpressSdk Namespace


DetectColorResults Class Properties

Accusoft.ScanFixXpress8.Net
DetectColorResults Class Properties

Accusoft.ScanFixXpressSdk Namespace : DetectColorResults Class

For a list of all members of this type, see DetectColorResults members.

Public Properties
 | Name | Description
Public Property | AverageSaturation | Gets a value indicating average saturation value for the image.
Public Property | BigObjects | Gets a value indicating weighted count of color objects larger than DetectColorOptions.MinimumSize.
Public Property | BoxList | Gets a collection where each member contains bounding box coordinates for one object in the image.
Public Property | Confidence | Gets a value indicating confidence level for the IsColor value.
Public Property | Findings | Gets a collection with finding information from the color detection process.
Public Property | IsColor | Gets a value indicating whether image is considered to be color.
Public Property | SmallObjects | Gets a value indicating weighted count of objects near, but smaller than, DetectColorOptions.MinimumSize.
Top
See Also

Reference

DetectColorResults Class
Accusoft.ScanFixXpressSdk Namespace


AverageSaturation Property

Accusoft.ScanFixXpress8.Net
AverageSaturation Property

Accusoft.ScanFixXpressSdk Namespace > DetectColorResults Class : AverageSaturation Property
Gets a value indicating average saturation value for the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AverageSaturation As Integer
'Usage

Dim instance As DetectColorResults
Dim value As Integer

value = instance.AverageSaturation
public int AverageSaturation {get;}
public: __property int get_AverageSaturation();
public:
property int AverageSaturation {
   int get();
}
Remarks

This value is calculated by sampling the image and calculating the mean saturation of the sampled pixels. If this value is above the value specified in DetectColorOptions.MinimumSaturation, and the paper color is not ignored, then the image will be determined "color." If paper color is ignored, then an average saturation above the thresold will trigger a dropout of the background color.

See Also

Reference

DetectColorResults Class
DetectColorResults Members


BigObjects Property

Accusoft.ScanFixXpress8.Net
BigObjects Property

Accusoft.ScanFixXpressSdk Namespace > DetectColorResults Class : BigObjects Property
Gets a value indicating weighted count of color objects larger than DetectColorOptions.MinimumSize.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BigObjects As Integer
'Usage

Dim instance As DetectColorResults
Dim value As Integer

value = instance.BigObjects
public int BigObjects {get;}
public: __property int get_BigObjects();
public:
property int BigObjects {
   int get();
}
Remarks

Objects twice DetectColorOptions.MinimumSize will count double, objects three times DetectColorOptions.MinimumSize will count triple, etc. This value can be used to determine if the size you are using is appropriate for your images.

See Also

Reference

DetectColorResults Class
DetectColorResults Members


BoxList Property

Accusoft.ScanFixXpress8.Net
BoxList Property

Accusoft.ScanFixXpressSdk Namespace > DetectColorResults Class : BoxList Property
Gets a collection where each member contains bounding box coordinates for one object in the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BoxList As ReadOnlyCollection(Of Rectangle)
'Usage

Dim instance As DetectColorResults
Dim value As ReadOnlyCollection(Of Rectangle)

value = instance.BoxList
public ReadOnlyCollection<Rectangle> BoxList {get;}
public: __property ReadOnlyCollection<Rectangle>* get_BoxList();
public:
property ReadOnlyCollection<Rectangle>^ BoxList {
   ReadOnlyCollection<Rectangle>^ get();
}
See Also

Reference

DetectColorResults Class
DetectColorResults Members


Confidence Property (DetectColorResults)

Accusoft.ScanFixXpress8.Net
Confidence Property (DetectColorResults)

Accusoft.ScanFixXpressSdk Namespace > DetectColorResults Class : Confidence Property
Gets a value indicating confidence level for the IsColor value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Confidence As Integer
'Usage

Dim instance As DetectColorResults
Dim value As Integer

value = instance.Confidence
public int Confidence {get;}
public: __property int get_Confidence();
public:
property int Confidence {
   int get();
}
Remarks

The confidence is expressed as a value from 0, indicating no confidence, to 100, indicating a high confidence. A low confidence result can be used to separate out images that might need manual processing, or to recategorize images to another appropriate processing path.

See Also

Reference

DetectColorResults Class
DetectColorResults Members


Findings Property

Accusoft.ScanFixXpress8.Net
Findings Property

Accusoft.ScanFixXpressSdk Namespace > DetectColorResults Class : Findings Property
Gets a collection with finding information from the color detection process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Findings As ReadOnlyCollection(Of ColorFindings)
'Usage

Dim instance As DetectColorResults
Dim value As ReadOnlyCollection(Of ColorFindings)

value = instance.Findings
public ReadOnlyCollection<ColorFindings> Findings {get;}
public: __property ReadOnlyCollection<ColorFindings>* get_Findings();
public:
property ReadOnlyCollection<ColorFindings>^ Findings {
   ReadOnlyCollection<ColorFindings>^ get();
}
Remarks

This information will explain what factors influenced the IsColor result. This information can be used to further classify images, or to help when setting up the decision parameters for a class of images.

See Also

Reference

DetectColorResults Class
DetectColorResults Members


IsColor Property

Accusoft.ScanFixXpress8.Net
IsColor Property

Accusoft.ScanFixXpressSdk Namespace > DetectColorResults Class : IsColor Property
Gets a value indicating whether image is considered to be color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsColor As Boolean
'Usage

Dim instance As DetectColorResults
Dim value As Boolean

value = instance.IsColor
public bool IsColor {get;}
public: __property bool get_IsColor();
public:
property bool IsColor {
   bool get();
}
See Also

Reference

DetectColorResults Class
DetectColorResults Members


SmallObjects Property

Accusoft.ScanFixXpress8.Net
SmallObjects Property

Accusoft.ScanFixXpressSdk Namespace > DetectColorResults Class : SmallObjects Property
Gets a value indicating weighted count of objects near, but smaller than, DetectColorOptions.MinimumSize.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SmallObjects As Integer
'Usage

Dim instance As DetectColorResults
Dim value As Integer

value = instance.SmallObjects
public int SmallObjects {get;}
public: __property int get_SmallObjects();
public:
property int SmallObjects {
   int get();
}
Remarks

Objects just below DetectColorOptions.MinimumSize will count near 1. Smaller objects will return smaller values, dropping to zero when they are below half of DetectColorOptions.MinimumSize. Use this value to determine if the size you are using is appropriate for your images.

See Also

Reference

DetectColorResults Class
DetectColorResults Members


DilateOptions Class

Accusoft.ScanFixXpress8.Net
DilateOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : DilateOptions Class
Contains parameters for the ScanFix.Dilate process.
Object Model
DilateOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DilateOptions
   Inherits EnhancementOption
'Usage

Dim instance As DilateOptions
public class DilateOptions : EnhancementOption
public __gc class DilateOptions : public EnhancementOption
public ref class DilateOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.DilateOptions

See Also

Reference

DilateOptions Members
Accusoft.ScanFixXpressSdk Namespace


DilateOptions Class Members

Accusoft.ScanFixXpress8.Net
DilateOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : DilateOptions Class

The following tables list the members exposed by DilateOptions.

Public Constructors
 | Name | Description
Public Constructor | DilateOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Amount | Gets and sets the distance to extend pixels.
Public Property | Direction | Gets and sets the directions to apply the dilation. Pixels will be extended in these directions.
Public Property | OnlyDiagonal | Gets and sets a flag for whether pixels should only be extended in a diagonal direction.
Top
See Also

Reference

DilateOptions Class
Accusoft.ScanFixXpressSdk Namespace


DilateOptions Class Properties

Accusoft.ScanFixXpress8.Net
DilateOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : DilateOptions Class

For a list of all members of this type, see DilateOptions members.

Public Properties
 | Name | Description
Public Property | Amount | Gets and sets the distance to extend pixels.
Public Property | Direction | Gets and sets the directions to apply the dilation. Pixels will be extended in these directions.
Public Property | OnlyDiagonal | Gets and sets a flag for whether pixels should only be extended in a diagonal direction.
Top
See Also

Reference

DilateOptions Class
Accusoft.ScanFixXpressSdk Namespace


DilateOptions Constructor

Accusoft.ScanFixXpress8.Net
DilateOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > DilateOptions Class : DilateOptions Constructor
Overload List
Overload | Description
DilateOptions Constructor() | Instantiates a new DilateOptions object setting the default values.
DilateOptions Constructor(EnhancementDirections,Int32,Boolean) | Instantiates a new DilateOptions object setting the specified values.
See Also

Reference

DilateOptions Class
DilateOptions Members


DilateOptions Constructor()

Accusoft.ScanFixXpress8.Net
DilateOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > DilateOptions Class > DilateOptions Constructor : DilateOptions Constructor()
Instantiates a new DilateOptions object setting the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New()
'Usage

Dim instance As New DilateOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public DilateOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: DilateOptions();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
DilateOptions();
See Also

Reference

DilateOptions Class
DilateOptions Members
Overload List


DilateOptions Constructor(EnhancementDirections,Int32,Boolean)

Accusoft.ScanFixXpress8.Net
DilateOptions Constructor(EnhancementDirections,Int32,Boolean)

Accusoft.ScanFixXpressSdk Namespace > DilateOptions Class > DilateOptions Constructor : DilateOptions Constructor(EnhancementDirections,Int32,Boolean)
The direction to apply the dilation. Pixels will be extended in these directions. Typically, this is set to a single direction, a pair of directions, or All.
The distance to extend pixels.
True if pixels should only be extended in a diagonal direction. Typically, this is set to false. It is an error to set this to true if Direction is not set to a pair of adjacent directions.
Instantiates a new DilateOptions object setting the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal direction As EnhancementDirections, _
   ByVal amount As Integer, _
   ByVal onlyDiagonal As Boolean _
)
'Usage

Dim direction As EnhancementDirections
Dim amount As Integer
Dim onlyDiagonal As Boolean

Dim instance As New DilateOptions(direction, amount, onlyDiagonal)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public DilateOptions(
   EnhancementDirections direction,
   int amount,
   bool onlyDiagonal
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: DilateOptions(
   EnhancementDirections direction,
   int amount,
   bool onlyDiagonal
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
DilateOptions(
   EnhancementDirections direction,
   int amount,
   bool onlyDiagonal
)

Parameters

direction
The direction to apply the dilation. Pixels will be extended in these directions. Typically, this is set to a single direction, a pair of directions, or All.
amount
The distance to extend pixels.
onlyDiagonal
True if pixels should only be extended in a diagonal direction. Typically, this is set to false. It is an error to set this to true if Direction is not set to a pair of adjacent directions.
See Also

Reference

DilateOptions Class
DilateOptions Members
Overload List


Amount Property (DilateOptions)

Accusoft.ScanFixXpress8.Net
Amount Property (DilateOptions)

Accusoft.ScanFixXpressSdk Namespace > DilateOptions Class : Amount Property
Gets and sets the distance to extend pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Amount As Integer
'Usage

Dim instance As DilateOptions
Dim value As Integer

instance.Amount = value

value = instance.Amount
public int Amount {get; set;}
public: __property int get_Amount();
public: __property void set_Amount(
   int value
);
public:
property int Amount {
   int get();
   void set (    int value);
}
Remarks

The default value is 1.

Valid values are 1 to 500.

See Also

Reference

DilateOptions Class
DilateOptions Members


Direction Property (DilateOptions)

Accusoft.ScanFixXpress8.Net
Direction Property (DilateOptions)

Accusoft.ScanFixXpressSdk Namespace > DilateOptions Class : Direction Property
Gets and sets the directions to apply the dilation. Pixels will be extended in these directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Direction As EnhancementDirections
'Usage

Dim instance As DilateOptions
Dim value As EnhancementDirections

instance.Direction = value

value = instance.Direction
public EnhancementDirections Direction {get; set;}
public: __property EnhancementDirections get_Direction();
public: __property void set_Direction(
   EnhancementDirections value
);
public:
property EnhancementDirections Direction {
   EnhancementDirections get();
   void set (    EnhancementDirections value);
}
Remarks

The default value is All.

Typically, this is set to a single direction, a pair of directions, or All from the EnhancementDirections enumeration.

See Also

Reference

DilateOptions Class
DilateOptions Members


OnlyDiagonal Property (DilateOptions)

Accusoft.ScanFixXpress8.Net
OnlyDiagonal Property (DilateOptions)

Accusoft.ScanFixXpressSdk Namespace > DilateOptions Class : OnlyDiagonal Property
Gets and sets a flag for whether pixels should only be extended in a diagonal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OnlyDiagonal As Boolean
'Usage

Dim instance As DilateOptions
Dim value As Boolean

instance.OnlyDiagonal = value

value = instance.OnlyDiagonal
public bool OnlyDiagonal {get; set;}
public: __property bool get_OnlyDiagonal();
public: __property void set_OnlyDiagonal(
   bool value
);
public:
property bool OnlyDiagonal {
   bool get();
   void set (    bool value);
}
Remarks

The default value is false.

Typically, this is set to false. It is an error to set this to true if Direction is not set to a pair of adjacent directions.

See Also

Reference

DilateOptions Class
DilateOptions Members


DilateResults Class

Accusoft.ScanFixXpress8.Net
DilateResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : DilateResults Class
Defines a place holder class for the Dilate enhancement result.
Object Model
DilateResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DilateResults
   Inherits EnhancementResult
'Usage

Dim instance As DilateResults
public class DilateResults : EnhancementResult
public __gc class DilateResults : public EnhancementResult
public ref class DilateResults : public EnhancementResult
Remarks
This class contains no data. Its presence in the results list is used to determine that the operation has run successfully.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.DilateResults

See Also

Reference

DilateResults Members
Accusoft.ScanFixXpressSdk Namespace


DilateResults Class Members

Accusoft.ScanFixXpress8.Net
DilateResults Class Members

Accusoft.ScanFixXpressSdk Namespace : DilateResults Class

The following tables list the members exposed by DilateResults.

See Also

Reference

DilateResults Class
Accusoft.ScanFixXpressSdk Namespace


DotShadingRemovalOptions Class

Accusoft.ScanFixXpress8.Net
DotShadingRemovalOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : DotShadingRemovalOptions Class
Contains parameters that control the ScanFix.RemoveDotShading enhancement process.
Object Model
DotShadingRemovalOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DotShadingRemovalOptions
   Inherits EnhancementOption
'Usage

Dim instance As DotShadingRemovalOptions
public class DotShadingRemovalOptions : EnhancementOption
public __gc class DotShadingRemovalOptions : public EnhancementOption
public ref class DotShadingRemovalOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.DotShadingRemovalOptions

See Also

Reference

DotShadingRemovalOptions Members
Accusoft.ScanFixXpressSdk Namespace


DotShadingRemovalOptions Class Members

Accusoft.ScanFixXpress8.Net
DotShadingRemovalOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : DotShadingRemovalOptions Class

The following tables list the members exposed by DotShadingRemovalOptions.

Public Constructors
 | Name | Description
Public Constructor | DotShadingRemovalOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | DensityAdjustment | Gets and sets a value used to adjust the expected density of dot shading areas.
Public Property | HorizontalSizeAdjustment | Gets and sets a value used to fine-tune the width of dots to remove.
Public Property | MaximumDotSize | Gets and sets the maximum width and height (in pixels) of individual dots to remove.
Public Property | MinimumAreaHeight | Gets and sets the height of the smallest dot-shaded area to process.
Public Property | MinimumAreaWidth | Gets and sets the width of the smallest dot-shaded area to process.
Public Property | VerticalSizeAdjustment | Gets and sets a value used to fine-tune the height of dots to remove.
Top
See Also

Reference

DotShadingRemovalOptions Class
Accusoft.ScanFixXpressSdk Namespace


DotShadingRemovalOptions Class Properties

Accusoft.ScanFixXpress8.Net
DotShadingRemovalOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : DotShadingRemovalOptions Class

For a list of all members of this type, see DotShadingRemovalOptions members.

Public Properties
 | Name | Description
Public Property | DensityAdjustment | Gets and sets a value used to adjust the expected density of dot shading areas.
Public Property | HorizontalSizeAdjustment | Gets and sets a value used to fine-tune the width of dots to remove.
Public Property | MaximumDotSize | Gets and sets the maximum width and height (in pixels) of individual dots to remove.
Public Property | MinimumAreaHeight | Gets and sets the height of the smallest dot-shaded area to process.
Public Property | MinimumAreaWidth | Gets and sets the width of the smallest dot-shaded area to process.
Public Property | VerticalSizeAdjustment | Gets and sets a value used to fine-tune the height of dots to remove.
Top
See Also

Reference

DotShadingRemovalOptions Class
Accusoft.ScanFixXpressSdk Namespace


DotShadingRemovalOptions Constructor

Accusoft.ScanFixXpress8.Net
DotShadingRemovalOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > DotShadingRemovalOptions Class : DotShadingRemovalOptions Constructor
Overload List
Overload | Description
DotShadingRemovalOptions Constructor() | Instantiates a new DotShadingRemovalOptions object with the default values.
DotShadingRemovalOptions Constructor(Int32,Int32,Int32,Int32,Int32,Int32) | Instantiates a new DotShadingRemovalOptions object setting the default specified values.
See Also

Reference

DotShadingRemovalOptions Class
DotShadingRemovalOptions Members


DotShadingRemovalOptions Constructor()

Accusoft.ScanFixXpress8.Net
DotShadingRemovalOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > DotShadingRemovalOptions Class > DotShadingRemovalOptions Constructor : DotShadingRemovalOptions Constructor()
Instantiates a new DotShadingRemovalOptions object with the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New DotShadingRemovalOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public DotShadingRemovalOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: DotShadingRemovalOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
DotShadingRemovalOptions();
See Also

Reference

DotShadingRemovalOptions Class
DotShadingRemovalOptions Members
Overload List


DotShadingRemovalOptions Constructor(Int32,Int32,Int32,Int32,Int32,Int32)

Accusoft.ScanFixXpress8.Net
DotShadingRemovalOptions Constructor(Int32,Int32,Int32,Int32,Int32,Int32)

Accusoft.ScanFixXpressSdk Namespace > DotShadingRemovalOptions Class > DotShadingRemovalOptions Constructor : DotShadingRemovalOptions Constructor(Int32,Int32,Int32,Int32,Int32,Int32)
The width of the smallest dot-shaded area to process.
The height of the smallest dot-shaded area to process.
A value used to fine-tune the height of dots to remove.
A value used to fine-tune the width of dots to remove.
A value used to adjust the expected density of dot shading areas.
The maximum width and height (in pixels) of individual dots to remove.
Instantiates a new DotShadingRemovalOptions object setting the default specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal minimumAreaWidth As Integer, _
   ByVal minimumAreaHeight As Integer, _
   ByVal verticalSizeAdjustment As Integer, _
   ByVal horizontalSizeAdjustment As Integer, _
   ByVal densityAdjustment As Integer, _
   ByVal maximumDotSize As Integer _
)
'Usage

Dim minimumAreaWidth As Integer
Dim minimumAreaHeight As Integer
Dim verticalSizeAdjustment As Integer
Dim horizontalSizeAdjustment As Integer
Dim densityAdjustment As Integer
Dim maximumDotSize As Integer

Dim instance As New DotShadingRemovalOptions(minimumAreaWidth, minimumAreaHeight, verticalSizeAdjustment, horizontalSizeAdjustment, densityAdjustment, maximumDotSize)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public DotShadingRemovalOptions(
   int minimumAreaWidth,
   int minimumAreaHeight,
   int verticalSizeAdjustment,
   int horizontalSizeAdjustment,
   int densityAdjustment,
   int maximumDotSize
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: DotShadingRemovalOptions(
   int minimumAreaWidth,
   int minimumAreaHeight,
   int verticalSizeAdjustment,
   int horizontalSizeAdjustment,
   int densityAdjustment,
   int maximumDotSize
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
DotShadingRemovalOptions(
   int minimumAreaWidth,
   int minimumAreaHeight,
   int verticalSizeAdjustment,
   int horizontalSizeAdjustment,
   int densityAdjustment,
   int maximumDotSize
)

Parameters

minimumAreaWidth
The width of the smallest dot-shaded area to process.
minimumAreaHeight
The height of the smallest dot-shaded area to process.
verticalSizeAdjustment
A value used to fine-tune the height of dots to remove.
horizontalSizeAdjustment
A value used to fine-tune the width of dots to remove.
densityAdjustment
A value used to adjust the expected density of dot shading areas.
maximumDotSize
The maximum width and height (in pixels) of individual dots to remove.
See Also

Reference

DotShadingRemovalOptions Class
DotShadingRemovalOptions Members
Overload List


DensityAdjustment Property

Accusoft.ScanFixXpress8.Net
DensityAdjustment Property

Accusoft.ScanFixXpressSdk Namespace > DotShadingRemovalOptions Class : DensityAdjustment Property
Gets and sets a value used to adjust the expected density of dot shading areas.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DensityAdjustment As Integer
'Usage

Dim instance As DotShadingRemovalOptions
Dim value As Integer

instance.DensityAdjustment = value

value = instance.DensityAdjustment
public int DensityAdjustment {get; set;}
public: __property int get_DensityAdjustment();
public: __property void set_DensityAdjustment(
   int value
);
public:
property int DensityAdjustment {
   int get();
   void set (    int value);
}
Remarks

The default value is 0.

Valid values are -50 to 50.

Values from -5 to +5 cover nearly all typical cases.

Note: Negative numbers instruct the component to search for shaded areas with more white pixels than black pixels and positive numbers instruct the opcode to search for shaded areas with more black pixels than white ones.

See Also

Reference

DotShadingRemovalOptions Class
DotShadingRemovalOptions Members


HorizontalSizeAdjustment Property

Accusoft.ScanFixXpress8.Net
HorizontalSizeAdjustment Property

Accusoft.ScanFixXpressSdk Namespace > DotShadingRemovalOptions Class : HorizontalSizeAdjustment Property
Gets and sets a value used to fine-tune the width of dots to remove.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HorizontalSizeAdjustment As Integer
'Usage

Dim instance As DotShadingRemovalOptions
Dim value As Integer

instance.HorizontalSizeAdjustment = value

value = instance.HorizontalSizeAdjustment
public int HorizontalSizeAdjustment {get; set;}
public: __property int get_HorizontalSizeAdjustment();
public: __property void set_HorizontalSizeAdjustment(
   int value
);
public:
property int HorizontalSizeAdjustment {
   int get();
   void set (    int value);
}
Remarks

The default value is 0.

Valid values are -100 to 100.

See Also

Reference

DotShadingRemovalOptions Class
DotShadingRemovalOptions Members


MaximumDotSize Property

Accusoft.ScanFixXpress8.Net
MaximumDotSize Property

Accusoft.ScanFixXpressSdk Namespace > DotShadingRemovalOptions Class : MaximumDotSize Property
Gets and sets the maximum width and height (in pixels) of individual dots to remove.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaximumDotSize As Integer
'Usage

Dim instance As DotShadingRemovalOptions
Dim value As Integer

instance.MaximumDotSize = value

value = instance.MaximumDotSize
public int MaximumDotSize {get; set;}
public: __property int get_MaximumDotSize();
public: __property void set_MaximumDotSize(
   int value
);
public:
property int MaximumDotSize {
   int get();
   void set (    int value);
}
Remarks

The default value is 5.

Valid values are 0 to 20.

See Also

Reference

DotShadingRemovalOptions Class
DotShadingRemovalOptions Members


MinimumAreaHeight Property (DotShadingRemovalOptions)

Accusoft.ScanFixXpress8.Net
MinimumAreaHeight Property (DotShadingRemovalOptions)

Accusoft.ScanFixXpressSdk Namespace > DotShadingRemovalOptions Class : MinimumAreaHeight Property
Gets and sets the height of the smallest dot-shaded area to process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumAreaHeight As Integer
'Usage

Dim instance As DotShadingRemovalOptions
Dim value As Integer

instance.MinimumAreaHeight = value

value = instance.MinimumAreaHeight
public int MinimumAreaHeight {get; set;}
public: __property int get_MinimumAreaHeight();
public: __property void set_MinimumAreaHeight(
   int value
);
public:
property int MinimumAreaHeight {
   int get();
   void set (    int value);
}
Remarks

The default value is 50.

Valid values are 0 to 20000.

See Also

Reference

DotShadingRemovalOptions Class
DotShadingRemovalOptions Members


MinimumAreaWidth Property (DotShadingRemovalOptions)

Accusoft.ScanFixXpress8.Net
MinimumAreaWidth Property (DotShadingRemovalOptions)

Accusoft.ScanFixXpressSdk Namespace > DotShadingRemovalOptions Class : MinimumAreaWidth Property
Gets and sets the width of the smallest dot-shaded area to process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumAreaWidth As Integer
'Usage

Dim instance As DotShadingRemovalOptions
Dim value As Integer

instance.MinimumAreaWidth = value

value = instance.MinimumAreaWidth
public int MinimumAreaWidth {get; set;}
public: __property int get_MinimumAreaWidth();
public: __property void set_MinimumAreaWidth(
   int value
);
public:
property int MinimumAreaWidth {
   int get();
   void set (    int value);
}
Remarks

The default value is 300.

Valid values are 0 to 20000.

See Also

Reference

DotShadingRemovalOptions Class
DotShadingRemovalOptions Members


VerticalSizeAdjustment Property

Accusoft.ScanFixXpress8.Net
VerticalSizeAdjustment Property

Accusoft.ScanFixXpressSdk Namespace > DotShadingRemovalOptions Class : VerticalSizeAdjustment Property
Gets and sets a value used to fine-tune the height of dots to remove.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VerticalSizeAdjustment As Integer
'Usage

Dim instance As DotShadingRemovalOptions
Dim value As Integer

instance.VerticalSizeAdjustment = value

value = instance.VerticalSizeAdjustment
public int VerticalSizeAdjustment {get; set;}
public: __property int get_VerticalSizeAdjustment();
public: __property void set_VerticalSizeAdjustment(
   int value
);
public:
property int VerticalSizeAdjustment {
   int get();
   void set (    int value);
}
Remarks

The default value is 0.

Valid values are -100 to 100.

See Also

Reference

DotShadingRemovalOptions Class
DotShadingRemovalOptions Members


DotShadingRemovalResults Class

Accusoft.ScanFixXpress8.Net
DotShadingRemovalResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : DotShadingRemovalResults Class
Contains output values from the dot shading removal process.
Object Model
DotShadingRemovalResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DotShadingRemovalResults
   Inherits EnhancementResult
'Usage

Dim instance As DotShadingRemovalResults
public class DotShadingRemovalResults : EnhancementResult
public __gc class DotShadingRemovalResults : public EnhancementResult
public ref class DotShadingRemovalResults : public EnhancementResult
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.DotShadingRemovalResults

See Also

Reference

DotShadingRemovalResults Members
Accusoft.ScanFixXpressSdk Namespace


DotShadingRemovalResults Class Members

Accusoft.ScanFixXpress8.Net
DotShadingRemovalResults Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : DotShadingRemovalResults Class

The following tables list the members exposed by DotShadingRemovalResults.

Public Properties
 | Name | Description
Public Property | CountOfAreasFound | Gets the number of dot shading areas found and removed.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified during the dot shading removal process.
Top
See Also

Reference

DotShadingRemovalResults Class
Accusoft.ScanFixXpressSdk Namespace


DotShadingRemovalResults Class Properties

Accusoft.ScanFixXpress8.Net
DotShadingRemovalResults Class Properties

Accusoft.ScanFixXpressSdk Namespace : DotShadingRemovalResults Class

For a list of all members of this type, see DotShadingRemovalResults members.

Public Properties
 | Name | Description
Public Property | CountOfAreasFound | Gets the number of dot shading areas found and removed.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified during the dot shading removal process.
Top
See Also

Reference

DotShadingRemovalResults Class
Accusoft.ScanFixXpressSdk Namespace


CountOfAreasFound Property (DotShadingRemovalResults)

Accusoft.ScanFixXpress8.Net
CountOfAreasFound Property (DotShadingRemovalResults)

Accusoft.ScanFixXpressSdk Namespace > DotShadingRemovalResults Class : CountOfAreasFound Property
Gets the number of dot shading areas found and removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CountOfAreasFound As Integer
'Usage

Dim instance As DotShadingRemovalResults
Dim value As Integer

value = instance.CountOfAreasFound
public int CountOfAreasFound {get;}
public: __property int get_CountOfAreasFound();
public:
property int CountOfAreasFound {
   int get();
}

Property Value

An integer representing the number of dot shading areas removed.
See Also

Reference

DotShadingRemovalResults Class
DotShadingRemovalResults Members


ImageWasModified Property (DotShadingRemovalResults)

Accusoft.ScanFixXpress8.Net
ImageWasModified Property (DotShadingRemovalResults)

Accusoft.ScanFixXpressSdk Namespace > DotShadingRemovalResults Class : ImageWasModified Property
Gets a flag that indicates whether the image was modified during the dot shading removal process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageWasModified As Boolean
'Usage

Dim instance As DotShadingRemovalResults
Dim value As Boolean

value = instance.ImageWasModified
public bool ImageWasModified {get;}
public: __property bool get_ImageWasModified();
public:
property bool ImageWasModified {
   bool get();
}

Property Value

A boolean value which is True if the image was modified. Otherwise, False is returned.
See Also

Reference

DotShadingRemovalResults Class
DotShadingRemovalResults Members


EnhancementOption Class

Accusoft.ScanFixXpress8.Net
EnhancementOption Class
Members

Accusoft.ScanFixXpressSdk Namespace : EnhancementOption Class
Contains options that control the enhancment options. This is the base class for all Enhancement option classes.
Object Model
EnhancementOption Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class EnhancementOption
'Usage

Dim instance As EnhancementOption
public class EnhancementOption
public __gc class EnhancementOption
public ref class EnhancementOption
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.AutoBinarizeOptions
Accusoft.ScanFixXpressSdk.AutoBrightnessContrastOptions
Accusoft.ScanFixXpressSdk.AutoDespeckleOptions
Accusoft.ScanFixXpressSdk.AutoImageDetergentOptions
Accusoft.ScanFixXpressSdk.AutoInverseTextOptions
Accusoft.ScanFixXpressSdk.AutoRemoveHolePunchOptions
Accusoft.ScanFixXpressSdk.AutoRotateOptions
Accusoft.ScanFixXpressSdk.AutoSmoothBackgroundOptions
Accusoft.ScanFixXpressSdk.BinarizeOptions
Accusoft.ScanFixXpressSdk.BlankPageDetectOptions
Accusoft.ScanFixXpressSdk.BlankRectangleDetectOptions
Accusoft.ScanFixXpressSdk.BlobRemovalOptions
Accusoft.ScanFixXpressSdk.BorderRemovalOptions
Accusoft.ScanFixXpressSdk.BrightnessContrastOptions
Accusoft.ScanFixXpressSdk.ColorDropOptions
Accusoft.ScanFixXpressSdk.CombRemovalOptions
Accusoft.ScanFixXpressSdk.DeskewOptions
Accusoft.ScanFixXpressSdk.DespeckleOptions
Accusoft.ScanFixXpressSdk.DetectColorOptions
Accusoft.ScanFixXpressSdk.DilateOptions
Accusoft.ScanFixXpressSdk.DotShadingRemovalOptions
Accusoft.ScanFixXpressSdk.ErodeOptions
Accusoft.ScanFixXpressSdk.FilterAverageOptions
Accusoft.ScanFixXpressSdk.FilterCloseOptions
Accusoft.ScanFixXpressSdk.FilterCustomOptions
Accusoft.ScanFixXpressSdk.FilterGaussianOptions
Accusoft.ScanFixXpressSdk.FilterLaplacianOptions
Accusoft.ScanFixXpressSdk.FilterMedianOptions
Accusoft.ScanFixXpressSdk.FilterOpenOptions
Accusoft.ScanFixXpressSdk.FilterPrewittOptions
Accusoft.ScanFixXpressSdk.FilterSobelOptions
Accusoft.ScanFixXpressSdk.FilterUnsharpOptions
Accusoft.ScanFixXpressSdk.FlipOptions
Accusoft.ScanFixXpressSdk.GetRectangleOptions
Accusoft.ScanFixXpressSdk.GraphicLineDetectionOptions
Accusoft.ScanFixXpressSdk.GraphicLineRemovalOptions
Accusoft.ScanFixXpressSdk.ImageDetergentOptions
Accusoft.ScanFixXpressSdk.ImageRegistrationOptions
Accusoft.ScanFixXpressSdk.InverseTextOptions
Accusoft.ScanFixXpressSdk.LineRemovalOptions
Accusoft.ScanFixXpressSdk.MirrorOptions
Accusoft.ScanFixXpressSdk.NegateOptions
Accusoft.ScanFixXpressSdk.NegativeCorrectionOptions
Accusoft.ScanFixXpressSdk.PerspectiveAdjustOptions
Accusoft.ScanFixXpressSdk.RescaleOptions
Accusoft.ScanFixXpressSdk.RotateOptions
Accusoft.ScanFixXpressSdk.ShearOptions
Accusoft.ScanFixXpressSdk.SmoothObjectsOptions
Accusoft.ScanFixXpressSdk.SmoothZoomOptions
Accusoft.ScanFixXpressSdk.VirtualBulbOptions

See Also

Reference

EnhancementOption Members
Accusoft.ScanFixXpressSdk Namespace


EnhancementOption Class Members

Accusoft.ScanFixXpress8.Net
EnhancementOption Class Members

Accusoft.ScanFixXpressSdk Namespace : EnhancementOption Class

The following tables list the members exposed by EnhancementOption.

See Also

Reference

EnhancementOption Class
Accusoft.ScanFixXpressSdk Namespace


EnhancementOptionsCollection Class

Accusoft.ScanFixXpress8.Net
EnhancementOptionsCollection Class
Members

Accusoft.ScanFixXpressSdk Namespace : EnhancementOptionsCollection Class
Implements a list which will only accept enhancement options used with the ScanFix component
Object Model
EnhancementOptionsCollection ClassEnhancementOption Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class EnhancementOptionsCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As EnhancementOptionsCollection
[DefaultMemberAttribute("Item")]
public class EnhancementOptionsCollection : System.Collections.CollectionBase
[DefaultMemberAttribute("Item")]
public __gc class EnhancementOptionsCollection : public System.Collections.CollectionBase
[DefaultMemberAttribute("Item")]
public ref class EnhancementOptionsCollection : public System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Accusoft.ScanFixXpressSdk.EnhancementOptionsCollection

See Also

Reference

EnhancementOptionsCollection Members
Accusoft.ScanFixXpressSdk Namespace


EnhancementOptionsCollection Class Members

Accusoft.ScanFixXpress8.Net
EnhancementOptionsCollection Class Members
Properties Methods

Accusoft.ScanFixXpressSdk Namespace : EnhancementOptionsCollection Class

The following tables list the members exposed by EnhancementOptionsCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the element at the given index.
Top
Protected Properties
 | Name | Description
Protected Property | InnerList | Gets an System.Collections.ArrayList containing the list of elements in the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Property | List | Gets an System.Collections.IList containing the list of elements in the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an element to the collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the specified element is in the collection.
Public Method | CopyTo | Provide strongly typed member for ICollection
Public Method | GetEnumerator | Provide strongly typed enumerator
Public Method | IndexOf | Determines whether the specified element is in the collection and returns its index.
Public Method | Insert | Inserts an element into the collection.
Public Method | Remove | Removes an element from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
Protected Methods
 | Name | Description
Protected Method | OnClear | Performs additional custom processes when clearing the contents of the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | Performs additional custom processes after clearing the contents of the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | Overridden. Performs type checking on the object before inserting it to the EnhancementOptionsCollection
Protected Method | OnInsertComplete | Performs additional custom processes after inserting a new element into the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemove | Overridden. Performs type checking on the object before removing it from EnhancementOptionsCollection
Protected Method | OnRemoveComplete | Performs additional custom processes after removing an element from the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | Overridden. Performs type checking prior to setting a valid options item in EnhancementOptionsCollection
Protected Method | OnSetComplete | Performs additional custom processes after setting a value in the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | Overridden. Performs type checking on the object to ensure it is a ScanFix enhancement option
Top
See Also

Reference

EnhancementOptionsCollection Class
Accusoft.ScanFixXpressSdk Namespace


EnhancementOptionsCollection Class Properties

Accusoft.ScanFixXpress8.Net
EnhancementOptionsCollection Class Properties

Accusoft.ScanFixXpressSdk Namespace : EnhancementOptionsCollection Class

For a list of all members of this type, see EnhancementOptionsCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the element at the given index.
Top
Protected Properties
 | Name | Description
Protected Property | InnerList | Gets an System.Collections.ArrayList containing the list of elements in the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Property | List | Gets an System.Collections.IList containing the list of elements in the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

EnhancementOptionsCollection Class
Accusoft.ScanFixXpressSdk Namespace


EnhancementOptionsCollection Class Methods

Accusoft.ScanFixXpress8.Net
EnhancementOptionsCollection Class Methods

Accusoft.ScanFixXpressSdk Namespace : EnhancementOptionsCollection Class

For a list of all members of this type, see EnhancementOptionsCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an element to the collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the specified element is in the collection.
Public Method | CopyTo | Provide strongly typed member for ICollection
Public Method | GetEnumerator | Provide strongly typed enumerator
Public Method | IndexOf | Determines whether the specified element is in the collection and returns its index.
Public Method | Insert | Inserts an element into the collection.
Public Method | Remove | Removes an element from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
Protected Methods
 | Name | Description
Protected Method | OnClear | Performs additional custom processes when clearing the contents of the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | Performs additional custom processes after clearing the contents of the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | Overridden. Performs type checking on the object before inserting it to the EnhancementOptionsCollection
Protected Method | OnInsertComplete | Performs additional custom processes after inserting a new element into the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemove | Overridden. Performs type checking on the object before removing it from EnhancementOptionsCollection
Protected Method | OnRemoveComplete | Performs additional custom processes after removing an element from the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | Overridden. Performs type checking prior to setting a valid options item in EnhancementOptionsCollection
Protected Method | OnSetComplete | Performs additional custom processes after setting a value in the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | Overridden. Performs type checking on the object to ensure it is a ScanFix enhancement option
Top
See Also

Reference

EnhancementOptionsCollection Class
Accusoft.ScanFixXpressSdk Namespace


Add Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpress8.Net
Add Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementOptionsCollection Class : Add Method
The element that this method will add to the end of the collection.
Adds an element to the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function Add( _
   ByVal value As EnhancementOption _
) As Integer
'Usage

Dim instance As EnhancementOptionsCollection
Dim value As EnhancementOption
Dim value As Integer

value = instance.Add(value)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public int Add(
   EnhancementOption value
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: int Add(
   EnhancementOption* value
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
int Add(
   EnhancementOption^ value
)

Parameters

value
The element that this method will add to the end of the collection.

Return Value

The zero-based index of the newly added element.
Exceptions
Exception | Description
System.ArgumentNullException | Indicates that the element is null. This method will not add null to the collection.
Remarks
This method implements a standard collection operation. It will make the collection one element longer, and then place the given element into the last index. It will not change the rest of the collection.
See Also

Reference

EnhancementOptionsCollection Class
EnhancementOptionsCollection Members
Insert Method


Contains Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpress8.Net
Contains Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementOptionsCollection Class : Contains Method
The element to search for in the collection.
Determines whether the specified element is in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function Contains( _
   ByVal value As EnhancementOption _
) As Boolean
'Usage

Dim instance As EnhancementOptionsCollection
Dim value As EnhancementOption
Dim value As Boolean

value = instance.Contains(value)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public bool Contains(
   EnhancementOption value
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: bool Contains(
   EnhancementOption* value
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
bool Contains(
   EnhancementOption^ value
)

Parameters

value
The element to search for in the collection.

Return Value

true if the given element is in the collection; false otherwise.
Remarks
This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will return true. If it cannot find a reference to it, this method will return false.
See Also

Reference

EnhancementOptionsCollection Class
EnhancementOptionsCollection Members
IndexOf Method


CopyTo Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpress8.Net
CopyTo Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementOptionsCollection Class : CopyTo Method
destination array for copied elements
start index
Provide strongly typed member for ICollection
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Sub CopyTo( _
   ByVal array() As EnhancementOption, _
   ByVal index As Integer _
)
'Usage

Dim instance As EnhancementOptionsCollection
Dim array() As EnhancementOption
Dim index As Integer

instance.CopyTo(array, index)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void CopyTo(
   EnhancementOption[] array,
   int index
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void CopyTo(
   EnhancementOption*[]* array,
   int index
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void CopyTo(
   array<EnhancementOption^>^ array,
   int index
)

Parameters

array
destination array for copied elements
index
start index
See Also

Reference

EnhancementOptionsCollection Class
EnhancementOptionsCollection Members


GetEnumerator Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpress8.Net
GetEnumerator Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementOptionsCollection Class : GetEnumerator Method
Provide strongly typed enumerator
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Shadows Function GetEnumerator() As IEnumerator(Of EnhancementOption)
'Usage

Dim instance As EnhancementOptionsCollection
Dim value As IEnumerator(Of EnhancementOption)

value = instance.GetEnumerator()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public new IEnumerator<EnhancementOption> GetEnumerator()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: new IEnumerator<EnhancementOption*>* GetEnumerator();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
new IEnumerator<EnhancementOption^>^ GetEnumerator();

Return Value

the enumerator
See Also

Reference

EnhancementOptionsCollection Class
EnhancementOptionsCollection Members


IndexOf Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpress8.Net
IndexOf Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementOptionsCollection Class : IndexOf Method
The element to search for in the collection.
Determines whether the specified element is in the collection and returns its index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function IndexOf( _
   ByVal value As EnhancementOption _
) As Integer
'Usage

Dim instance As EnhancementOptionsCollection
Dim value As EnhancementOption
Dim value As Integer

value = instance.IndexOf(value)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public int IndexOf(
   EnhancementOption value
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: int IndexOf(
   EnhancementOption* value
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
int IndexOf(
   EnhancementOption^ value
)

Parameters

value
The element to search for in the collection.

Return Value

If the element is present in the collection, this method will return the zero-based index of the first occurrence of it; otherwise this method will return -1.
Remarks
This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will return its index. If it cannot find a reference to it, this method will return -1. If the element is present more than once in the collection, this method will return the lowest index of a match.
See Also

Reference

EnhancementOptionsCollection Class
EnhancementOptionsCollection Members
Contains Method


Insert Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpress8.Net
Insert Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementOptionsCollection Class : Insert Method
The zero-based index where this method will place the element. If the value of this parameter is equal to the original number of elements in the collection, this method will perform the same operation as the Add method.
The element to search for in the collection.
Inserts an element into the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As EnhancementOption _
)
'Usage

Dim instance As EnhancementOptionsCollection
Dim index As Integer
Dim value As EnhancementOption

instance.Insert(index, value)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void Insert(
   int index,
   EnhancementOption value
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void Insert(
   int index,
   EnhancementOption* value
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void Insert(
   int index,
   EnhancementOption^ value
)

Parameters

index
The zero-based index where this method will place the element. If the value of this parameter is equal to the original number of elements in the collection, this method will perform the same operation as the Add method.
value
The element to search for in the collection.
Exceptions
Exception | Description
System.ArgumentNullException | Indicates that the element is null. This method will not add null to the collection.
Remarks
This method implements a standard collection operation. It will insert an element into the collection at the given index. It will move all elements (if any) that follow the newly added element back one place (their indices will be one greater than they were.)
See Also

Reference

EnhancementOptionsCollection Class
EnhancementOptionsCollection Members
Add Method


OnInsert Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpress8.Net
OnInsert Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementOptionsCollection Class : OnInsert Method
Index to insert the object
Enhancement option to be inserted
Performs type checking on the object before inserting it to the EnhancementOptionsCollection
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Protected Overrides Sub OnInsert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
'Usage

Dim instance As EnhancementOptionsCollection
Dim index As Integer
Dim value As Object

instance.OnInsert(index, value)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
protected override void OnInsert(
   int index,
   object value
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
protected: void OnInsert(
   int index,
   Object* value
) override
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
protected:
void OnInsert(
   int index,
   Object^ value
) override

Parameters

index
Index to insert the object
value
Enhancement option to be inserted
See Also

Reference

EnhancementOptionsCollection Class
EnhancementOptionsCollection Members


OnRemove Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpress8.Net
OnRemove Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementOptionsCollection Class : OnRemove Method
Index to remove the object
Enhancement option to be removed
Performs type checking on the object before removing it from EnhancementOptionsCollection
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Protected Overrides Sub OnRemove( _
   ByVal index As Integer, _
   ByVal value As Object _
)
'Usage

Dim instance As EnhancementOptionsCollection
Dim index As Integer
Dim value As Object

instance.OnRemove(index, value)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
protected override void OnRemove(
   int index,
   object value
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
protected: void OnRemove(
   int index,
   Object* value
) override
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
protected:
void OnRemove(
   int index,
   Object^ value
) override

Parameters

index
Index to remove the object
value
Enhancement option to be removed
See Also

Reference

EnhancementOptionsCollection Class
EnhancementOptionsCollection Members


OnSet Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpress8.Net
OnSet Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementOptionsCollection Class : OnSet Method
Index of the item to set
Old value of the options item
New value of the options item
Performs type checking prior to setting a valid options item in EnhancementOptionsCollection
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Protected Overrides Sub OnSet( _
   ByVal index As Integer, _
   ByVal oldValue As Object, _
   ByVal newValue As Object _
)
'Usage

Dim instance As EnhancementOptionsCollection
Dim index As Integer
Dim oldValue As Object
Dim newValue As Object

instance.OnSet(index, oldValue, newValue)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
protected override void OnSet(
   int index,
   object oldValue,
   object newValue
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
protected: void OnSet(
   int index,
   Object* oldValue,
   Object* newValue
) override
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
protected:
void OnSet(
   int index,
   Object^ oldValue,
   Object^ newValue
) override

Parameters

index
Index of the item to set
oldValue
Old value of the options item
newValue
New value of the options item
See Also

Reference

EnhancementOptionsCollection Class
EnhancementOptionsCollection Members


OnValidate Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpress8.Net
OnValidate Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementOptionsCollection Class : OnValidate Method
Value to be checked
Performs type checking on the object to ensure it is a ScanFix enhancement option
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Protected Overrides Sub OnValidate( _
   ByVal value As Object _
)
'Usage

Dim instance As EnhancementOptionsCollection
Dim value As Object

instance.OnValidate(value)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
protected override void OnValidate(
   object value
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
protected: void OnValidate(
   Object* value
) override
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
protected:
void OnValidate(
   Object^ value
) override

Parameters

value
Value to be checked
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when value parameter is null
See Also

Reference

EnhancementOptionsCollection Class
EnhancementOptionsCollection Members


Remove Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpress8.Net
Remove Method (EnhancementOptionsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementOptionsCollection Class : Remove Method
The element to remove from the collection.
Removes an element from the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Sub Remove( _
   ByVal value As EnhancementOption _
)
'Usage

Dim instance As EnhancementOptionsCollection
Dim value As EnhancementOption

instance.Remove(value)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void Remove(
   EnhancementOption value
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void Remove(
   EnhancementOption* value
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void Remove(
   EnhancementOption^ value
)

Parameters

value
The element to remove from the collection.
Exceptions
Exception | Description
System.ArgumentException | Indicates that the specified element is not present in the collection.
Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will delete it from the collection. If there are any elements following that one, this method will move them up (their indices will be one less than they were.)

If the specified element is present more than once in the collection, this method will remove the one with the lowest index.

See Also

Reference

EnhancementOptionsCollection Class
EnhancementOptionsCollection Members
IndexOf Method


Item Property (EnhancementOptionsCollection)

Accusoft.ScanFixXpress8.Net
Item Property (EnhancementOptionsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementOptionsCollection Class : Item Property
The zero-based index in the collection to get or set.
Gets or sets the element at the given index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As EnhancementOption
'Usage

Dim instance As EnhancementOptionsCollection
Dim index As Integer
Dim value As EnhancementOption

instance.Item(index) = value

value = instance.Item(index)
public EnhancementOption this[
   int index
]; {get; set;}
public: __property EnhancementOption* get_Item   int index
;
public: __property void set_Item   int index,
   EnhancementOption* value
;
public:
property EnhancementOption^ default [int] {
   EnhancementOption^ get(int index);
   void set (int index, EnhancementOption^ value);
}

Parameters

index
The zero-based index in the collection to get or set.
Remarks
This method implements a standard collection operation. It is the principle method you will use to read or change elements in the collection. You can read or modify any element in the collection with this method.
See Also

Reference

EnhancementOptionsCollection Class
EnhancementOptionsCollection Members


EnhancementResult Class

Accusoft.ScanFixXpress8.Net
EnhancementResult Class
Members

Accusoft.ScanFixXpressSdk Namespace : EnhancementResult Class
Base class for all Enhancement result classes
Object Model
EnhancementResult Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class EnhancementResult
'Usage

Dim instance As EnhancementResult
public class EnhancementResult
public __gc class EnhancementResult
public ref class EnhancementResult
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.AutoBinarizeResults
Accusoft.ScanFixXpressSdk.AutoBrightnessContrastResults
Accusoft.ScanFixXpressSdk.AutoDespeckleResults
Accusoft.ScanFixXpressSdk.AutoInverseTextResults
Accusoft.ScanFixXpressSdk.AutoRemoveHolePunchResults
Accusoft.ScanFixXpressSdk.AutoRotateResults
Accusoft.ScanFixXpressSdk.AutoSmoothBackgroundResults
Accusoft.ScanFixXpressSdk.BinarizeResults
Accusoft.ScanFixXpressSdk.BlankPageDetectResults
Accusoft.ScanFixXpressSdk.BlankRectangleDetectResults
Accusoft.ScanFixXpressSdk.BlobRemovalResults
Accusoft.ScanFixXpressSdk.BorderRemovalResults
Accusoft.ScanFixXpressSdk.BrightnessContrastResults
Accusoft.ScanFixXpressSdk.ColorDropResults
Accusoft.ScanFixXpressSdk.CombRemovalResults
Accusoft.ScanFixXpressSdk.DeskewResults
Accusoft.ScanFixXpressSdk.DespeckleResults
Accusoft.ScanFixXpressSdk.DetectColorResults
Accusoft.ScanFixXpressSdk.DilateResults
Accusoft.ScanFixXpressSdk.DotShadingRemovalResults
Accusoft.ScanFixXpressSdk.ErodeResults
Accusoft.ScanFixXpressSdk.FilterResults
Accusoft.ScanFixXpressSdk.FlipResults
Accusoft.ScanFixXpressSdk.GetRectangleResults
Accusoft.ScanFixXpressSdk.GraphicLineDetectionResults
Accusoft.ScanFixXpressSdk.GraphicLineRemovalResults
Accusoft.ScanFixXpressSdk.ImageDetergentResults
Accusoft.ScanFixXpressSdk.ImageRegistrationResults
Accusoft.ScanFixXpressSdk.InverseTextResults
Accusoft.ScanFixXpressSdk.LineRemovalResults
Accusoft.ScanFixXpressSdk.MirrorResults
Accusoft.ScanFixXpressSdk.NegateResults
Accusoft.ScanFixXpressSdk.NegativeCorrectionResults
Accusoft.ScanFixXpressSdk.PerspectiveAdjustResults
Accusoft.ScanFixXpressSdk.RescaleResults
Accusoft.ScanFixXpressSdk.RotateResults
Accusoft.ScanFixXpressSdk.ShearResults
Accusoft.ScanFixXpressSdk.SmoothObjectsResults
Accusoft.ScanFixXpressSdk.SmoothZoomResults
Accusoft.ScanFixXpressSdk.VirtualBulbResults

See Also

Reference

EnhancementResult Members
Accusoft.ScanFixXpressSdk Namespace


EnhancementResult Class Members

Accusoft.ScanFixXpress8.Net
EnhancementResult Class Members

Accusoft.ScanFixXpressSdk Namespace : EnhancementResult Class

The following tables list the members exposed by EnhancementResult.

See Also

Reference

EnhancementResult Class
Accusoft.ScanFixXpressSdk Namespace


EnhancementResultsCollection Class

Accusoft.ScanFixXpress8.Net
EnhancementResultsCollection Class
Members

Accusoft.ScanFixXpressSdk Namespace : EnhancementResultsCollection Class
Implements a list which will only accept enhancement options used with the ScanFix component
Object Model
EnhancementResultsCollection ClassEnhancementResult Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class EnhancementResultsCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As EnhancementResultsCollection
[DefaultMemberAttribute("Item")]
public class EnhancementResultsCollection : System.Collections.CollectionBase
[DefaultMemberAttribute("Item")]
public __gc class EnhancementResultsCollection : public System.Collections.CollectionBase
[DefaultMemberAttribute("Item")]
public ref class EnhancementResultsCollection : public System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Accusoft.ScanFixXpressSdk.EnhancementResultsCollection

See Also

Reference

EnhancementResultsCollection Members
Accusoft.ScanFixXpressSdk Namespace


EnhancementResultsCollection Class Members

Accusoft.ScanFixXpress8.Net
EnhancementResultsCollection Class Members
Properties Methods

Accusoft.ScanFixXpressSdk Namespace : EnhancementResultsCollection Class

The following tables list the members exposed by EnhancementResultsCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the element at the given index.
Top
Protected Properties
 | Name | Description
Protected Property | InnerList | Gets an System.Collections.ArrayList containing the list of elements in the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Property | List | Gets an System.Collections.IList containing the list of elements in the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an element to the collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the specified element is in the collection.
Public Method | CopyTo | Provide strongly typed member for ICollection
Public Method | GetEnumerator | Provide strongly typed enumerator
Public Method | IndexOf | Determines whether the specified element is in the collection and returns its index.
Public Method | Insert | Inserts an element into the collection.
Public Method | Remove | Removes an element from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
Protected Methods
 | Name | Description
Protected Method | OnClear | Performs additional custom processes when clearing the contents of the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | Performs additional custom processes after clearing the contents of the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | Overridden. Performs type checking on the object before inserting it to the EnhancementResultsCollection
Protected Method | OnInsertComplete | Performs additional custom processes after inserting a new element into the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemove | Overridden. Performs type checking on the object before removing it from EnhancementResultsCollection
Protected Method | OnRemoveComplete | Performs additional custom processes after removing an element from the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | Overridden. Performs type checking prior to setting a valid results item in EnhancementResultsCollection
Protected Method | OnSetComplete | Performs additional custom processes after setting a value in the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | Overridden. Performs type checking on the object to ensure it is a ScanFix enhancement option
Top
See Also

Reference

EnhancementResultsCollection Class
Accusoft.ScanFixXpressSdk Namespace


EnhancementResultsCollection Class Properties

Accusoft.ScanFixXpress8.Net
EnhancementResultsCollection Class Properties

Accusoft.ScanFixXpressSdk Namespace : EnhancementResultsCollection Class

For a list of all members of this type, see EnhancementResultsCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the element at the given index.
Top
Protected Properties
 | Name | Description
Protected Property | InnerList | Gets an System.Collections.ArrayList containing the list of elements in the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Property | List | Gets an System.Collections.IList containing the list of elements in the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

EnhancementResultsCollection Class
Accusoft.ScanFixXpressSdk Namespace


EnhancementResultsCollection Class Methods

Accusoft.ScanFixXpress8.Net
EnhancementResultsCollection Class Methods

Accusoft.ScanFixXpressSdk Namespace : EnhancementResultsCollection Class

For a list of all members of this type, see EnhancementResultsCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an element to the collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the specified element is in the collection.
Public Method | CopyTo | Provide strongly typed member for ICollection
Public Method | GetEnumerator | Provide strongly typed enumerator
Public Method | IndexOf | Determines whether the specified element is in the collection and returns its index.
Public Method | Insert | Inserts an element into the collection.
Public Method | Remove | Removes an element from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
Protected Methods
 | Name | Description
Protected Method | OnClear | Performs additional custom processes when clearing the contents of the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | Performs additional custom processes after clearing the contents of the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | Overridden. Performs type checking on the object before inserting it to the EnhancementResultsCollection
Protected Method | OnInsertComplete | Performs additional custom processes after inserting a new element into the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemove | Overridden. Performs type checking on the object before removing it from EnhancementResultsCollection
Protected Method | OnRemoveComplete | Performs additional custom processes after removing an element from the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | Overridden. Performs type checking prior to setting a valid results item in EnhancementResultsCollection
Protected Method | OnSetComplete | Performs additional custom processes after setting a value in the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | Overridden. Performs type checking on the object to ensure it is a ScanFix enhancement option
Top
See Also

Reference

EnhancementResultsCollection Class
Accusoft.ScanFixXpressSdk Namespace


Add Method (EnhancementResultsCollection)

Accusoft.ScanFixXpress8.Net
Add Method (EnhancementResultsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementResultsCollection Class : Add Method
The element that this method will add to the end of the collection.
Adds an element to the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function Add( _
   ByVal value As EnhancementResult _
) As Integer
'Usage

Dim instance As EnhancementResultsCollection
Dim value As EnhancementResult
Dim value As Integer

value = instance.Add(value)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public int Add(
   EnhancementResult value
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: int Add(
   EnhancementResult* value
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
int Add(
   EnhancementResult^ value
)

Parameters

value
The element that this method will add to the end of the collection.

Return Value

The zero-based index of the newly added element.
Exceptions
Exception | Description
System.ArgumentNullException | Indicates that the element is null. This method will not add null to the collection.
Remarks
This method implements a standard collection operation. It will make the collection one element longer, and then place the given element into the last index. It will not change the rest of the collection.
See Also

Reference

EnhancementResultsCollection Class
EnhancementResultsCollection Members
Insert Method


Contains Method (EnhancementResultsCollection)

Accusoft.ScanFixXpress8.Net
Contains Method (EnhancementResultsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementResultsCollection Class : Contains Method
The element to search for in the collection.
Determines whether the specified element is in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function Contains( _
   ByVal value As EnhancementResult _
) As Boolean
'Usage

Dim instance As EnhancementResultsCollection
Dim value As EnhancementResult
Dim value As Boolean

value = instance.Contains(value)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public bool Contains(
   EnhancementResult value
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: bool Contains(
   EnhancementResult* value
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
bool Contains(
   EnhancementResult^ value
)

Parameters

value
The element to search for in the collection.

Return Value

true if the given element is in the collection; false otherwise.
Remarks
This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will return true. If it cannot find a reference to it, this method will return false.
See Also

Reference

EnhancementResultsCollection Class
EnhancementResultsCollection Members
IndexOf Method


CopyTo Method (EnhancementResultsCollection)

Accusoft.ScanFixXpress8.Net
CopyTo Method (EnhancementResultsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementResultsCollection Class : CopyTo Method
Destination array for copied elements
The index in the source collection to start copying from.
Provide strongly typed member for ICollection
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Sub CopyTo( _
   ByVal array() As EnhancementResult, _
   ByVal index As Integer _
)
'Usage

Dim instance As EnhancementResultsCollection
Dim array() As EnhancementResult
Dim index As Integer

instance.CopyTo(array, index)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void CopyTo(
   EnhancementResult[] array,
   int index
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void CopyTo(
   EnhancementResult*[]* array,
   int index
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void CopyTo(
   array<EnhancementResult^>^ array,
   int index
)

Parameters

array
Destination array for copied elements
index
The index in the source collection to start copying from.
See Also

Reference

EnhancementResultsCollection Class
EnhancementResultsCollection Members


GetEnumerator Method (EnhancementResultsCollection)

Accusoft.ScanFixXpress8.Net
GetEnumerator Method (EnhancementResultsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementResultsCollection Class : GetEnumerator Method
Provide strongly typed enumerator
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Shadows Function GetEnumerator() As IEnumerator(Of EnhancementResult)
'Usage

Dim instance As EnhancementResultsCollection
Dim value As IEnumerator(Of EnhancementResult)

value = instance.GetEnumerator()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public new IEnumerator<EnhancementResult> GetEnumerator()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: new IEnumerator<EnhancementResult*>* GetEnumerator();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
new IEnumerator<EnhancementResult^>^ GetEnumerator();

Return Value

The enumerator
See Also

Reference

EnhancementResultsCollection Class
EnhancementResultsCollection Members


IndexOf Method (EnhancementResultsCollection)

Accusoft.ScanFixXpress8.Net
IndexOf Method (EnhancementResultsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementResultsCollection Class : IndexOf Method
The element to search for in the collection.
Determines whether the specified element is in the collection and returns its index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function IndexOf( _
   ByVal value As EnhancementResult _
) As Integer
'Usage

Dim instance As EnhancementResultsCollection
Dim value As EnhancementResult
Dim value As Integer

value = instance.IndexOf(value)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public int IndexOf(
   EnhancementResult value
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: int IndexOf(
   EnhancementResult* value
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
int IndexOf(
   EnhancementResult^ value
)

Parameters

value
The element to search for in the collection.

Return Value

If the element is present in the collection, this method will return the zero-based index of the first occurrence of it; otherwise this method will return -1.
Remarks
This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will return its index. If it cannot find a reference to it, this method will return -1. If the element is present more than once in the collection, this method will return the lowest index of a match.
See Also

Reference

EnhancementResultsCollection Class
EnhancementResultsCollection Members
Contains Method


Insert Method (EnhancementResultsCollection)

Accusoft.ScanFixXpress8.Net
Insert Method (EnhancementResultsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementResultsCollection Class : Insert Method
The zero-based index where this method will place the element. If the value of this parameter is equal to the original number of elements in the collection, this method will perform the same operation as the Add method.
The element to search for in the collection.
Inserts an element into the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As EnhancementResult _
)
'Usage

Dim instance As EnhancementResultsCollection
Dim index As Integer
Dim value As EnhancementResult

instance.Insert(index, value)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void Insert(
   int index,
   EnhancementResult value
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void Insert(
   int index,
   EnhancementResult* value
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void Insert(
   int index,
   EnhancementResult^ value
)

Parameters

index
The zero-based index where this method will place the element. If the value of this parameter is equal to the original number of elements in the collection, this method will perform the same operation as the Add method.
value
The element to search for in the collection.
Exceptions
Exception | Description
System.ArgumentNullException | Indicates that the element is null. This method will not add null to the collection.
Remarks
This method implements a standard collection operation. It will insert an element into the collection at the given index. It will move all elements (if any) that follow the newly added element back one place (their indices will be one greater than they were.)
See Also

Reference

EnhancementResultsCollection Class
EnhancementResultsCollection Members
Add Method


OnInsert Method (EnhancementResultsCollection)

Accusoft.ScanFixXpress8.Net
OnInsert Method (EnhancementResultsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementResultsCollection Class : OnInsert Method
Index to insert the object
Enhancement result to be inserted
Performs type checking on the object before inserting it to the EnhancementResultsCollection
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Protected Overrides Sub OnInsert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
'Usage

Dim instance As EnhancementResultsCollection
Dim index As Integer
Dim value As Object

instance.OnInsert(index, value)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
protected override void OnInsert(
   int index,
   object value
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
protected: void OnInsert(
   int index,
   Object* value
) override
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
protected:
void OnInsert(
   int index,
   Object^ value
) override

Parameters

index
Index to insert the object
value
Enhancement result to be inserted
See Also

Reference

EnhancementResultsCollection Class
EnhancementResultsCollection Members


OnRemove Method (EnhancementResultsCollection)

Accusoft.ScanFixXpress8.Net
OnRemove Method (EnhancementResultsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementResultsCollection Class : OnRemove Method
Index to remove the object
Enhancement result to be removed
Performs type checking on the object before removing it from EnhancementResultsCollection
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Protected Overrides Sub OnRemove( _
   ByVal index As Integer, _
   ByVal value As Object _
)
'Usage

Dim instance As EnhancementResultsCollection
Dim index As Integer
Dim value As Object

instance.OnRemove(index, value)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
protected override void OnRemove(
   int index,
   object value
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
protected: void OnRemove(
   int index,
   Object* value
) override
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
protected:
void OnRemove(
   int index,
   Object^ value
) override

Parameters

index
Index to remove the object
value
Enhancement result to be removed
See Also

Reference

EnhancementResultsCollection Class
EnhancementResultsCollection Members


OnSet Method (EnhancementResultsCollection)

Accusoft.ScanFixXpress8.Net
OnSet Method (EnhancementResultsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementResultsCollection Class : OnSet Method
Index of the item to set
Old value of results item
New value of results item
Performs type checking prior to setting a valid results item in EnhancementResultsCollection
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Protected Overrides Sub OnSet( _
   ByVal index As Integer, _
   ByVal oldValue As Object, _
   ByVal newValue As Object _
)
'Usage

Dim instance As EnhancementResultsCollection
Dim index As Integer
Dim oldValue As Object
Dim newValue As Object

instance.OnSet(index, oldValue, newValue)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
protected override void OnSet(
   int index,
   object oldValue,
   object newValue
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
protected: void OnSet(
   int index,
   Object* oldValue,
   Object* newValue
) override
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
protected:
void OnSet(
   int index,
   Object^ oldValue,
   Object^ newValue
) override

Parameters

index
Index of the item to set
oldValue
Old value of results item
newValue
New value of results item
See Also

Reference

EnhancementResultsCollection Class
EnhancementResultsCollection Members


OnValidate Method (EnhancementResultsCollection)

Accusoft.ScanFixXpress8.Net
OnValidate Method (EnhancementResultsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementResultsCollection Class : OnValidate Method
Value to be checked
Performs type checking on the object to ensure it is a ScanFix enhancement option
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Protected Overrides Sub OnValidate( _
   ByVal value As Object _
)
'Usage

Dim instance As EnhancementResultsCollection
Dim value As Object

instance.OnValidate(value)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
protected override void OnValidate(
   object value
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
protected: void OnValidate(
   Object* value
) override
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
protected:
void OnValidate(
   Object^ value
) override

Parameters

value
Value to be checked
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when value parameter is null
See Also

Reference

EnhancementResultsCollection Class
EnhancementResultsCollection Members


Remove Method (EnhancementResultsCollection)

Accusoft.ScanFixXpress8.Net
Remove Method (EnhancementResultsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementResultsCollection Class : Remove Method
The element to remove from the collection.
Removes an element from the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Sub Remove( _
   ByVal value As EnhancementResult _
)
'Usage

Dim instance As EnhancementResultsCollection
Dim value As EnhancementResult

instance.Remove(value)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void Remove(
   EnhancementResult value
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void Remove(
   EnhancementResult* value
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void Remove(
   EnhancementResult^ value
)

Parameters

value
The element to remove from the collection.
Exceptions
Exception | Description
System.ArgumentException | Indicates that the specified element is not present in the collection.
Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will delete it from the collection. If there are any elements following that one, this method will move them up (their indices will be one less than they were.)

If the specified element is present more than once in the collection, this method will remove the one with the lowest index.

See Also

Reference

EnhancementResultsCollection Class
EnhancementResultsCollection Members
IndexOf Method


Item Property (EnhancementResultsCollection)

Accusoft.ScanFixXpress8.Net
Item Property (EnhancementResultsCollection)

Accusoft.ScanFixXpressSdk Namespace > EnhancementResultsCollection Class : Item Property
The zero-based index in the collection to get or set.
Gets or sets the element at the given index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As EnhancementResult
'Usage

Dim instance As EnhancementResultsCollection
Dim index As Integer
Dim value As EnhancementResult

instance.Item(index) = value

value = instance.Item(index)
public EnhancementResult this[
   int index
]; {get; set;}
public: __property EnhancementResult* get_Item   int index
;
public: __property void set_Item   int index,
   EnhancementResult* value
;
public:
property EnhancementResult^ default [int] {
   EnhancementResult^ get(int index);
   void set (int index, EnhancementResult^ value);
}

Parameters

index
The zero-based index in the collection to get or set.
Remarks
This method implements a standard collection operation. It is the principle method you will use to read or change elements in the collection. You can read or modify any element in the collection with this method.
See Also

Reference

EnhancementResultsCollection Class
EnhancementResultsCollection Members


Enhancements Class

Accusoft.ScanFixXpress8.Net
Enhancements Class
Members

Accusoft.ScanFixXpressSdk Namespace : Enhancements Class
Holds a list of enhancement options which can be performed on an image. It provides functionality to read and write an XML formated string to load and save the state of the enhancements.
Object Model
Enhancements ClassEnhancementOptionsCollection ClassEnhancementOption ClassEnhancementResultsCollection ClassEnhancementResult Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class Enhancements
'Usage

Dim instance As Enhancements
public class Enhancements
public __gc class Enhancements
public ref class Enhancements
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.Enhancements

See Also

Reference

Enhancements Members
Accusoft.ScanFixXpressSdk Namespace


Enhancements Class Members

Accusoft.ScanFixXpress8.Net
Enhancements Class Members
Properties Methods

Accusoft.ScanFixXpressSdk Namespace : Enhancements Class

The following tables list the members exposed by Enhancements.

Public Constructors
 | Name | Description
Public Constructor | Enhancements Constructor | Initializes a new instance of the Enhancements class
Top
Public Properties
 | Name | Description
Public Property | Options | Gets a list of enhancements to be applied.
Public Property | Results | Gets a list of enhancement results. This list is generated by the ScanFix.ExecuteEnhancements. These values will only be valid after that.
Top
Public Methods
 | Name | Description
Public Method | ReadFromStream | Reads a specially-formatted stream and places the values into properties of this object.
Public Method | WriteToStream | Writes some properties of this object to a specially-formatted stream.
Top
See Also

Reference

Enhancements Class
Accusoft.ScanFixXpressSdk Namespace


Enhancements Class Properties

Accusoft.ScanFixXpress8.Net
Enhancements Class Properties

Accusoft.ScanFixXpressSdk Namespace : Enhancements Class

For a list of all members of this type, see Enhancements members.

Public Properties
 | Name | Description
Public Property | Options | Gets a list of enhancements to be applied.
Public Property | Results | Gets a list of enhancement results. This list is generated by the ScanFix.ExecuteEnhancements. These values will only be valid after that.
Top
See Also

Reference

Enhancements Class
Accusoft.ScanFixXpressSdk Namespace


Enhancements Class Methods

Accusoft.ScanFixXpress8.Net
Enhancements Class Methods

Accusoft.ScanFixXpressSdk Namespace : Enhancements Class

For a list of all members of this type, see Enhancements members.

Public Methods
 | Name | Description
Public Method | ReadFromStream | Reads a specially-formatted stream and places the values into properties of this object.
Public Method | WriteToStream | Writes some properties of this object to a specially-formatted stream.
Top
See Also

Reference

Enhancements Class
Accusoft.ScanFixXpressSdk Namespace


Enhancements Constructor

Accusoft.ScanFixXpress8.Net
Enhancements Constructor

Accusoft.ScanFixXpressSdk Namespace > Enhancements Class : Enhancements Constructor
Initializes a new instance of the Enhancements class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New()
'Usage

Dim instance As New Enhancements()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public Enhancements()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: Enhancements();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
Enhancements();
See Also

Reference

Enhancements Class
Enhancements Members


ReadFromStream Method

Accusoft.ScanFixXpress8.Net
ReadFromStream Method

Accusoft.ScanFixXpressSdk Namespace > Enhancements Class : ReadFromStream Method
A stream that the WriteToStream method created.
An instance of the ScanFix component
Reads a specially-formatted stream and places the values into properties of this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Sub ReadFromStream( _
   ByVal stream As String, _
   ByVal sf As ScanFix _
)
'Usage

Dim instance As Enhancements
Dim stream As String
Dim sf As ScanFix

instance.ReadFromStream(stream, sf)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void ReadFromStream(
   string stream,
   ScanFix sf
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void ReadFromStream(
   string* stream,
   ScanFix* sf
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void ReadFromStream(
   String^ stream,
   ScanFix^ sf
)

Parameters

stream
A stream that the WriteToStream method created.
sf
An instance of the ScanFix component
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when sf parameter is null
Remarks

This method reads a stream, which contains the values of properties for this object. It provides a convenient way to store and retrieve the values and preserves as much future compatibility as possible.

This method should read any stream that the WriteToStream method created, even if an older version of this toolkit created it. This method will fail to read a stream that a newer version of this toolkit created.

Note: You should retrieve the value for the stream from the Operations property of a FormDirector FormSet object. When the Type property of that object is "ScanFix/Enhancement", the Content property contains a string that you should send to this method.

The properties that this method reads from the stream are:

  • Options
See Also

Reference

Enhancements Class
Enhancements Members
WriteToStream Method


WriteToStream Method

Accusoft.ScanFixXpress8.Net
WriteToStream Method

Accusoft.ScanFixXpressSdk Namespace > Enhancements Class : WriteToStream Method
An instance of the ScanFix component
Writes some properties of this object to a specially-formatted stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function WriteToStream( _
   ByVal sf As ScanFix _
) As String
'Usage

Dim instance As Enhancements
Dim sf As ScanFix
Dim value As String

value = instance.WriteToStream(sf)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public string WriteToStream(
   ScanFix sf
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: string* WriteToStream(
   ScanFix* sf
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
String^ WriteToStream(
   ScanFix^ sf
)

Parameters

sf
An instance of the ScanFix component

Return Value

A stream that can be reloaded using ReadFromStream.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when sf parameter is null
Remarks

This method writes certain properties of this object to a stream. The stream is intended for use only by the ReadFromStream method and its format may change in a future release of this toolkit. However, even if the format changes, future versions of this toolkit will be able to read strings that this method generates.

Note: You should save the stream in the Operations property of a FormDirector FormSet object. You should set the Type to "ScanFix/Enhancement" and the Content to the value that this method returns.

The properties that this method writes to the stream are:

  • Options
See Also

Reference

Enhancements Class
Enhancements Members


Options Property

Accusoft.ScanFixXpress8.Net
Options Property

Accusoft.ScanFixXpressSdk Namespace > Enhancements Class : Options Property
Gets a list of enhancements to be applied.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Options As EnhancementOptionsCollection
'Usage

Dim instance As Enhancements
Dim value As EnhancementOptionsCollection

value = instance.Options
public EnhancementOptionsCollection Options {get;}
public: __property EnhancementOptionsCollection* get_Options();
public:
property EnhancementOptionsCollection^ Options {
   EnhancementOptionsCollection^ get();
}
Remarks
Add items to this list and then call ScanFix.ExecuteEnhancements to execute a series of enhancments.
See Also

Reference

Enhancements Class
Enhancements Members


Results Property

Accusoft.ScanFixXpress8.Net
Results Property

Accusoft.ScanFixXpressSdk Namespace > Enhancements Class : Results Property
Gets a list of enhancement results. This list is generated by the ScanFix.ExecuteEnhancements. These values will only be valid after that.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Results As EnhancementResultsCollection
'Usage

Dim instance As Enhancements
Dim value As EnhancementResultsCollection

value = instance.Results
public EnhancementResultsCollection Results {get;}
public: __property EnhancementResultsCollection* get_Results();
public:
property EnhancementResultsCollection^ Results {
   EnhancementResultsCollection^ get();
}
Remarks
This list is generated by the ScanFix.ExecuteEnhancements. These values will only be valid after that.
See Also

Reference

Enhancements Class
Enhancements Members


ErodeOptions Class

Accusoft.ScanFixXpress8.Net
ErodeOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : ErodeOptions Class
Contains parameters for the ScanFix.Erode process.
Object Model
ErodeOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ErodeOptions
   Inherits EnhancementOption
'Usage

Dim instance As ErodeOptions
public class ErodeOptions : EnhancementOption
public __gc class ErodeOptions : public EnhancementOption
public ref class ErodeOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.ErodeOptions

See Also

Reference

ErodeOptions Members
Accusoft.ScanFixXpressSdk Namespace


ErodeOptions Class Members

Accusoft.ScanFixXpress8.Net
ErodeOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : ErodeOptions Class

The following tables list the members exposed by ErodeOptions.

Public Constructors
 | Name | Description
Public Constructor | ErodeOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Amount | Gets and sets the distance to reduce black pixels.
Public Property | Direction | Gets and sets directions to apply the erosion. Pixels will be reduced in these directions.
Public Property | OnlyDiagonal | Gets and sets a value to reduce pixels in the diagonal direction.
Top
See Also

Reference

ErodeOptions Class
Accusoft.ScanFixXpressSdk Namespace


ErodeOptions Class Properties

Accusoft.ScanFixXpress8.Net
ErodeOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : ErodeOptions Class

For a list of all members of this type, see ErodeOptions members.

Public Properties
 | Name | Description
Public Property | Amount | Gets and sets the distance to reduce black pixels.
Public Property | Direction | Gets and sets directions to apply the erosion. Pixels will be reduced in these directions.
Public Property | OnlyDiagonal | Gets and sets a value to reduce pixels in the diagonal direction.
Top
See Also

Reference

ErodeOptions Class
Accusoft.ScanFixXpressSdk Namespace


ErodeOptions Constructor

Accusoft.ScanFixXpress8.Net
ErodeOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > ErodeOptions Class : ErodeOptions Constructor
Overload List
Overload | Description
ErodeOptions Constructor() | Instantiates a new ErodeOptions object setting the default values.
ErodeOptions Constructor(EnhancementDirections,Int32,Boolean) | Instantiates a new ErodeOptions object setting the specified values.
See Also

Reference

ErodeOptions Class
ErodeOptions Members


ErodeOptions Constructor()

Accusoft.ScanFixXpress8.Net
ErodeOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > ErodeOptions Class > ErodeOptions Constructor : ErodeOptions Constructor()
Instantiates a new ErodeOptions object setting the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New ErodeOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public ErodeOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: ErodeOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
ErodeOptions();
See Also

Reference

ErodeOptions Class
ErodeOptions Members
Overload List


ErodeOptions Constructor(EnhancementDirections,Int32,Boolean)

Accusoft.ScanFixXpress8.Net
ErodeOptions Constructor(EnhancementDirections,Int32,Boolean)

Accusoft.ScanFixXpressSdk Namespace > ErodeOptions Class > ErodeOptions Constructor : ErodeOptions Constructor(EnhancementDirections,Int32,Boolean)
The direction to apply the erosion. Pixels will be reduced in these directions. Typically, this is set to a single direction, a pair of directions, or All.
The distance to reduce pixels.
True if pixels should only be reduced in a diagonal direction. Typically, this is set to false. It is an error to set this to true if Direction is not set to a pair of adjacent directions.
Instantiates a new ErodeOptions object setting the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New( _
   ByVal direction As EnhancementDirections, _
   ByVal amount As Integer, _
   ByVal onlyDiagonal As Boolean _
)
'Usage

Dim direction As EnhancementDirections
Dim amount As Integer
Dim onlyDiagonal As Boolean

Dim instance As New ErodeOptions(direction, amount, onlyDiagonal)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public ErodeOptions(
   EnhancementDirections direction,
   int amount,
   bool onlyDiagonal
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: ErodeOptions(
   EnhancementDirections direction,
   int amount,
   bool onlyDiagonal
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
ErodeOptions(
   EnhancementDirections direction,
   int amount,
   bool onlyDiagonal
)

Parameters

direction
The direction to apply the erosion. Pixels will be reduced in these directions. Typically, this is set to a single direction, a pair of directions, or All.
amount
The distance to reduce pixels.
onlyDiagonal
True if pixels should only be reduced in a diagonal direction. Typically, this is set to false. It is an error to set this to true if Direction is not set to a pair of adjacent directions.
See Also

Reference

ErodeOptions Class
ErodeOptions Members
Overload List


Amount Property (ErodeOptions)

Accusoft.ScanFixXpress8.Net
Amount Property (ErodeOptions)

Accusoft.ScanFixXpressSdk Namespace > ErodeOptions Class : Amount Property
Gets and sets the distance to reduce black pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Amount As Integer
'Usage

Dim instance As ErodeOptions
Dim value As Integer

instance.Amount = value

value = instance.Amount
public int Amount {get; set;}
public: __property int get_Amount();
public: __property void set_Amount(
   int value
);
public:
property int Amount {
   int get();
   void set (    int value);
}
Remarks

The default value is 1.

Valid values are 1 to 500.

See Also

Reference

ErodeOptions Class
ErodeOptions Members


Direction Property (ErodeOptions)

Accusoft.ScanFixXpress8.Net
Direction Property (ErodeOptions)

Accusoft.ScanFixXpressSdk Namespace > ErodeOptions Class : Direction Property
Gets and sets directions to apply the erosion. Pixels will be reduced in these directions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Direction As EnhancementDirections
'Usage

Dim instance As ErodeOptions
Dim value As EnhancementDirections

instance.Direction = value

value = instance.Direction
public EnhancementDirections Direction {get; set;}
public: __property EnhancementDirections get_Direction();
public: __property void set_Direction(
   EnhancementDirections value
);
public:
property EnhancementDirections Direction {
   EnhancementDirections get();
   void set (    EnhancementDirections value);
}
Remarks

The default value is All.

Typically, this is set to a single direction, a pair of directions, or All from the EnhancementDirections enumeration.

See Also

Reference

ErodeOptions Class
ErodeOptions Members


OnlyDiagonal Property (ErodeOptions)

Accusoft.ScanFixXpress8.Net
OnlyDiagonal Property (ErodeOptions)

Accusoft.ScanFixXpressSdk Namespace > ErodeOptions Class : OnlyDiagonal Property
Gets and sets a value to reduce pixels in the diagonal direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OnlyDiagonal As Boolean
'Usage

Dim instance As ErodeOptions
Dim value As Boolean

instance.OnlyDiagonal = value

value = instance.OnlyDiagonal
public bool OnlyDiagonal {get; set;}
public: __property bool get_OnlyDiagonal();
public: __property void set_OnlyDiagonal(
   bool value
);
public:
property bool OnlyDiagonal {
   bool get();
   void set (    bool value);
}
Remarks

The default value is false.

Typically, this is set to false. It is an error to set this to true if Direction is not set to a pair of adjacent directions.

See Also

Reference

ErodeOptions Class
ErodeOptions Members


ErodeResults Class

Accusoft.ScanFixXpress8.Net
ErodeResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : ErodeResults Class
Defines a place holder class for the Erode enhancement result.
Object Model
ErodeResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ErodeResults
   Inherits EnhancementResult
'Usage

Dim instance As ErodeResults
public class ErodeResults : EnhancementResult
public __gc class ErodeResults : public EnhancementResult
public ref class ErodeResults : public EnhancementResult
Remarks
This class contains no data. Its presence in the results list is used to determine that the operation has run successfully.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.ErodeResults

See Also

Reference

ErodeResults Members
Accusoft.ScanFixXpressSdk Namespace


ErodeResults Class Members

Accusoft.ScanFixXpress8.Net
ErodeResults Class Members

Accusoft.ScanFixXpressSdk Namespace : ErodeResults Class

The following tables list the members exposed by ErodeResults.

See Also

Reference

ErodeResults Class
Accusoft.ScanFixXpressSdk Namespace


FilterAverageOptions Class

Accusoft.ScanFixXpress8.Net
FilterAverageOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : FilterAverageOptions Class
Contains parameters for the ScanFix.ApplyAverageFilter filter process.
Object Model
FilterAverageOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FilterAverageOptions
   Inherits EnhancementOption
'Usage

Dim instance As FilterAverageOptions
public class FilterAverageOptions : EnhancementOption
public __gc class FilterAverageOptions : public EnhancementOption
public ref class FilterAverageOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.FilterAverageOptions

See Also

Reference

FilterAverageOptions Members
Accusoft.ScanFixXpressSdk Namespace


FilterAverageOptions Class Members

Accusoft.ScanFixXpress8.Net
FilterAverageOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : FilterAverageOptions Class

The following tables list the members exposed by FilterAverageOptions.

Public Constructors
 | Name | Description
Public Constructor | FilterAverageOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | CenterX | Gets and sets horizontal value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | CenterY | Gets and sets vertical value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | Height | Gets and sets height in pixels of the region sampled for filter calculations.
Public Property | Width | Gets and sets width in pixels of the region sampled for filter calculations.
Top
See Also

Reference

FilterAverageOptions Class
Accusoft.ScanFixXpressSdk Namespace


FilterAverageOptions Class Properties

Accusoft.ScanFixXpress8.Net
FilterAverageOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : FilterAverageOptions Class

For a list of all members of this type, see FilterAverageOptions members.

Public Properties
 | Name | Description
Public Property | CenterX | Gets and sets horizontal value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | CenterY | Gets and sets vertical value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | Height | Gets and sets height in pixels of the region sampled for filter calculations.
Public Property | Width | Gets and sets width in pixels of the region sampled for filter calculations.
Top
See Also

Reference

FilterAverageOptions Class
Accusoft.ScanFixXpressSdk Namespace


FilterAverageOptions Constructor

Accusoft.ScanFixXpress8.Net
FilterAverageOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > FilterAverageOptions Class : FilterAverageOptions Constructor
Overload List
Overload | Description
FilterAverageOptions Constructor() | Instantiates a new FilterAverageOptions object with the default values.
FilterAverageOptions Constructor(Int32,Int32,Int32,Int32) | Instantiates a new FilterAverageOptions object with the specified values.
See Also

Reference

FilterAverageOptions Class
FilterAverageOptions Members


FilterAverageOptions Constructor()

Accusoft.ScanFixXpress8.Net
FilterAverageOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > FilterAverageOptions Class > FilterAverageOptions Constructor : FilterAverageOptions Constructor()
Instantiates a new FilterAverageOptions object with the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New()
'Usage

Dim instance As New FilterAverageOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public FilterAverageOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: FilterAverageOptions();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
FilterAverageOptions();
See Also

Reference

FilterAverageOptions Class
FilterAverageOptions Members
Overload List


FilterAverageOptions Constructor(Int32,Int32,Int32,Int32)

Accusoft.ScanFixXpress8.Net
FilterAverageOptions Constructor(Int32,Int32,Int32,Int32)

Accusoft.ScanFixXpressSdk Namespace > FilterAverageOptions Class > FilterAverageOptions Constructor : FilterAverageOptions Constructor(Int32,Int32,Int32,Int32)
Value for height of custom filter.
Value for width of custom filter.
Horizontal value for center point of the filter. -1 for center of defined size.
Vertical value for center point of the filter. -1 for center of defined size.
Instantiates a new FilterAverageOptions object with the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New( _
   ByVal height As Integer, _
   ByVal width As Integer, _
   ByVal centerX As Integer, _
   ByVal centerY As Integer _
)
'Usage

Dim height As Integer
Dim width As Integer
Dim centerX As Integer
Dim centerY As Integer

Dim instance As New FilterAverageOptions(height, width, centerX, centerY)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public FilterAverageOptions(
   int height,
   int width,
   int centerX,
   int centerY
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: FilterAverageOptions(
   int height,
   int width,
   int centerX,
   int centerY
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
FilterAverageOptions(
   int height,
   int width,
   int centerX,
   int centerY
)

Parameters

height
Value for height of custom filter.
width
Value for width of custom filter.
centerX
Horizontal value for center point of the filter. -1 for center of defined size.
centerY
Vertical value for center point of the filter. -1 for center of defined size.
See Also

Reference

FilterAverageOptions Class
FilterAverageOptions Members
Overload List


CenterX Property (FilterAverageOptions)

Accusoft.ScanFixXpress8.Net
CenterX Property (FilterAverageOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterAverageOptions Class : CenterX Property
Gets and sets horizontal value for center point of filter. A value of -1 will automatically set the center based on region size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CenterX As Integer
'Usage

Dim instance As FilterAverageOptions
Dim value As Integer

instance.CenterX = value

value = instance.CenterX
public int CenterX {get; set;}
public: __property int get_CenterX();
public: __property void set_CenterX(
   int value
);
public:
property int CenterX {
   int get();
   void set (    int value);
}
Remarks

The default value is -1.

Valid values are -1 or 0 to {Width} - 1.

See Also

Reference

FilterAverageOptions Class
FilterAverageOptions Members


CenterY Property (FilterAverageOptions)

Accusoft.ScanFixXpress8.Net
CenterY Property (FilterAverageOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterAverageOptions Class : CenterY Property
Gets and sets vertical value for center point of filter. A value of -1 will automatically set the center based on region size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CenterY As Integer
'Usage

Dim instance As FilterAverageOptions
Dim value As Integer

instance.CenterY = value

value = instance.CenterY
public int CenterY {get; set;}
public: __property int get_CenterY();
public: __property void set_CenterY(
   int value
);
public:
property int CenterY {
   int get();
   void set (    int value);
}
Remarks

The default value is -1.

Valid values are -1 or 0 to {Height} - 1.

See Also

Reference

FilterAverageOptions Class
FilterAverageOptions Members


Height Property (FilterAverageOptions)

Accusoft.ScanFixXpress8.Net
Height Property (FilterAverageOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterAverageOptions Class : Height Property
Gets and sets height in pixels of the region sampled for filter calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As FilterAverageOptions
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}
Remarks

The default value is 3.

Valid values are 1 to {no limit}.

See Also

Reference

FilterAverageOptions Class
FilterAverageOptions Members


Width Property (FilterAverageOptions)

Accusoft.ScanFixXpress8.Net
Width Property (FilterAverageOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterAverageOptions Class : Width Property
Gets and sets width in pixels of the region sampled for filter calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As FilterAverageOptions
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}
Remarks

The default value is 3.

Valid values are 1 to {no limit}.

See Also

Reference

FilterAverageOptions Class
FilterAverageOptions Members


FilterCloseOptions Class

Accusoft.ScanFixXpress8.Net
FilterCloseOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : FilterCloseOptions Class
Contains parameters for the ScanFix.ApplyCloseFilter filter process.
Object Model
FilterCloseOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FilterCloseOptions
   Inherits EnhancementOption
'Usage

Dim instance As FilterCloseOptions
public class FilterCloseOptions : EnhancementOption
public __gc class FilterCloseOptions : public EnhancementOption
public ref class FilterCloseOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.FilterCloseOptions

See Also

Reference

FilterCloseOptions Members
Accusoft.ScanFixXpressSdk Namespace


FilterCloseOptions Class Members

Accusoft.ScanFixXpress8.Net
FilterCloseOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : FilterCloseOptions Class

The following tables list the members exposed by FilterCloseOptions.

Public Constructors
 | Name | Description
Public Constructor | FilterCloseOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | CenterX | Gets and sets horizontal value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | CenterY | Gets and sets vertical value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | Height | Gets and sets height in pixels of the region sampled for filter calculations.
Public Property | Width | Gets and sets width in pixels of the region sampled for filter calculations.
Top
See Also

Reference

FilterCloseOptions Class
Accusoft.ScanFixXpressSdk Namespace


FilterCloseOptions Class Properties

Accusoft.ScanFixXpress8.Net
FilterCloseOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : FilterCloseOptions Class

For a list of all members of this type, see FilterCloseOptions members.

Public Properties
 | Name | Description
Public Property | CenterX | Gets and sets horizontal value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | CenterY | Gets and sets vertical value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | Height | Gets and sets height in pixels of the region sampled for filter calculations.
Public Property | Width | Gets and sets width in pixels of the region sampled for filter calculations.
Top
See Also

Reference

FilterCloseOptions Class
Accusoft.ScanFixXpressSdk Namespace


FilterCloseOptions Constructor

Accusoft.ScanFixXpress8.Net
FilterCloseOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > FilterCloseOptions Class : FilterCloseOptions Constructor
Overload List
Overload | Description
FilterCloseOptions Constructor() | Instantiates a new FilterCloseOptions object with the default values.
FilterCloseOptions Constructor(Int32,Int32,Int32,Int32) | Instantiates a new FilterCloseOptions object with the specified values.
See Also

Reference

FilterCloseOptions Class
FilterCloseOptions Members


FilterCloseOptions Constructor()

Accusoft.ScanFixXpress8.Net
FilterCloseOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > FilterCloseOptions Class > FilterCloseOptions Constructor : FilterCloseOptions Constructor()
Instantiates a new FilterCloseOptions object with the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New()
'Usage

Dim instance As New FilterCloseOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public FilterCloseOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: FilterCloseOptions();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
FilterCloseOptions();
See Also

Reference

FilterCloseOptions Class
FilterCloseOptions Members
Overload List


FilterCloseOptions Constructor(Int32,Int32,Int32,Int32)

Accusoft.ScanFixXpress8.Net
FilterCloseOptions Constructor(Int32,Int32,Int32,Int32)

Accusoft.ScanFixXpressSdk Namespace > FilterCloseOptions Class > FilterCloseOptions Constructor : FilterCloseOptions Constructor(Int32,Int32,Int32,Int32)
Value for height of custom filter.
Value for width of custom filter.
Horizontal value for center point of the filter. -1 for center of defined size.
Vertical value for center point of the filter. -1 for center of defined size.
Instantiates a new FilterCloseOptions object with the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New( _
   ByVal height As Integer, _
   ByVal width As Integer, _
   ByVal centerX As Integer, _
   ByVal centerY As Integer _
)
'Usage

Dim height As Integer
Dim width As Integer
Dim centerX As Integer
Dim centerY As Integer

Dim instance As New FilterCloseOptions(height, width, centerX, centerY)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public FilterCloseOptions(
   int height,
   int width,
   int centerX,
   int centerY
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: FilterCloseOptions(
   int height,
   int width,
   int centerX,
   int centerY
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
FilterCloseOptions(
   int height,
   int width,
   int centerX,
   int centerY
)

Parameters

height
Value for height of custom filter.
width
Value for width of custom filter.
centerX
Horizontal value for center point of the filter. -1 for center of defined size.
centerY
Vertical value for center point of the filter. -1 for center of defined size.
See Also

Reference

FilterCloseOptions Class
FilterCloseOptions Members
Overload List


CenterX Property (FilterCloseOptions)

Accusoft.ScanFixXpress8.Net
CenterX Property (FilterCloseOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterCloseOptions Class : CenterX Property
Gets and sets horizontal value for center point of filter. A value of -1 will automatically set the center based on region size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CenterX As Integer
'Usage

Dim instance As FilterCloseOptions
Dim value As Integer

instance.CenterX = value

value = instance.CenterX
public int CenterX {get; set;}
public: __property int get_CenterX();
public: __property void set_CenterX(
   int value
);
public:
property int CenterX {
   int get();
   void set (    int value);
}
Remarks

The default value is -1.

Valid values are -1 or 0 to {Width} - 1.

See Also

Reference

FilterCloseOptions Class
FilterCloseOptions Members


CenterY Property (FilterCloseOptions)

Accusoft.ScanFixXpress8.Net
CenterY Property (FilterCloseOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterCloseOptions Class : CenterY Property
Gets and sets vertical value for center point of filter. A value of -1 will automatically set the center based on region size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CenterY As Integer
'Usage

Dim instance As FilterCloseOptions
Dim value As Integer

instance.CenterY = value

value = instance.CenterY
public int CenterY {get; set;}
public: __property int get_CenterY();
public: __property void set_CenterY(
   int value
);
public:
property int CenterY {
   int get();
   void set (    int value);
}
Remarks

The default value is -1.

Valid values are -1 or 0 to {Height} - 1.

See Also

Reference

FilterCloseOptions Class
FilterCloseOptions Members


Height Property (FilterCloseOptions)

Accusoft.ScanFixXpress8.Net
Height Property (FilterCloseOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterCloseOptions Class : Height Property
Gets and sets height in pixels of the region sampled for filter calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As FilterCloseOptions
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}
Remarks

The default value is 3.

Valid values are 1 to {no limit}.

See Also

Reference

FilterCloseOptions Class
FilterCloseOptions Members


Width Property (FilterCloseOptions)

Accusoft.ScanFixXpress8.Net
Width Property (FilterCloseOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterCloseOptions Class : Width Property
Gets and sets width in pixels of the region sampled for filter calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As FilterCloseOptions
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}
Remarks

The default value is 3.

Valid values are 1 to {no limit}.

See Also

Reference

FilterCloseOptions Class
FilterCloseOptions Members


FilterCustomOptions Class

Accusoft.ScanFixXpress8.Net
FilterCustomOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : FilterCustomOptions Class
Contains parameters for the ScanFix.ApplyCustomFilter filter process.
Object Model
FilterCustomOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FilterCustomOptions
   Inherits EnhancementOption
'Usage

Dim instance As FilterCustomOptions
public class FilterCustomOptions : EnhancementOption
public __gc class FilterCustomOptions : public EnhancementOption
public ref class FilterCustomOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.FilterCustomOptions

See Also

Reference

FilterCustomOptions Members
Accusoft.ScanFixXpressSdk Namespace


FilterCustomOptions Class Members

Accusoft.ScanFixXpress8.Net
FilterCustomOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : FilterCustomOptions Class

The following tables list the members exposed by FilterCustomOptions.

Public Constructors
 | Name | Description
Public Constructor | FilterCustomOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | CenterX | Gets and sets horizontal value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | CenterY | Gets and sets vertical value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | Divisor | Gets and sets the matrix divisor used by custom filter.
Public Property | Height | Gets value for height of custom filter.
Public Property | Offset | Gets and sets value for offset added to output of the convolution, used to bias the result up or down.
Public Property | Weights | Gets and sets filter weights matrix.
Public Property | Width | Gets value for width of custom filter.
Top
See Also

Reference

FilterCustomOptions Class
Accusoft.ScanFixXpressSdk Namespace


FilterCustomOptions Class Properties

Accusoft.ScanFixXpress8.Net
FilterCustomOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : FilterCustomOptions Class

For a list of all members of this type, see FilterCustomOptions members.

Public Properties
 | Name | Description
Public Property | CenterX | Gets and sets horizontal value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | CenterY | Gets and sets vertical value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | Divisor | Gets and sets the matrix divisor used by custom filter.
Public Property | Height | Gets value for height of custom filter.
Public Property | Offset | Gets and sets value for offset added to output of the convolution, used to bias the result up or down.
Public Property | Weights | Gets and sets filter weights matrix.
Public Property | Width | Gets value for width of custom filter.
Top
See Also

Reference

FilterCustomOptions Class
Accusoft.ScanFixXpressSdk Namespace


FilterCustomOptions Constructor

Accusoft.ScanFixXpress8.Net
FilterCustomOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > FilterCustomOptions Class : FilterCustomOptions Constructor
Overload List
Overload | Description
FilterCustomOptions Constructor() | Instantiates a new FilterCustomOptions object with the default values.
FilterCustomOptions Constructor(Int32[,],Int32,Int32,Int32,Int32) | Instantiates a new FilterCustomOptions object with the default values.
See Also

Reference

FilterCustomOptions Class
FilterCustomOptions Members


FilterCustomOptions Constructor()

Accusoft.ScanFixXpress8.Net
FilterCustomOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > FilterCustomOptions Class > FilterCustomOptions Constructor : FilterCustomOptions Constructor()
Instantiates a new FilterCustomOptions object with the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New FilterCustomOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public FilterCustomOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: FilterCustomOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
FilterCustomOptions();
See Also

Reference

FilterCustomOptions Class
FilterCustomOptions Members
Overload List


FilterCustomOptions Constructor(Int32[,],Int32,Int32,Int32,Int32)

Accusoft.ScanFixXpress8.Net
FilterCustomOptions Constructor(Int32[,],Int32,Int32,Int32,Int32)

Accusoft.ScanFixXpressSdk Namespace > FilterCustomOptions Class > FilterCustomOptions Constructor : FilterCustomOptions Constructor(Int32[,],Int32,Int32,Int32,Int32)
Instantiates a new FilterCustomOptions object with the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New( _
   ByVal weights(,) As Integer, _
   ByVal centerX As Integer, _
   ByVal centerY As Integer, _
   ByVal divisor As Integer, _
   ByVal offset As Integer _
)
'Usage

Dim weights() As Integer
Dim centerX As Integer
Dim centerY As Integer
Dim divisor As Integer
Dim offset As Integer

Dim instance As New FilterCustomOptions(weights, centerX, centerY, divisor, offset)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public FilterCustomOptions(
   int[,] weights,
   int centerX,
   int centerY,
   int divisor,
   int offset
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: FilterCustomOptions(
   int[,]* weights,
   int centerX,
   int centerY,
   int divisor,
   int offset
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
FilterCustomOptions(
   array<int>^ weights,
   int centerX,
   int centerY,
   int divisor,
   int offset
)

Parameters

weights
centerX
centerY
divisor
offset
See Also

Reference

FilterCustomOptions Class
FilterCustomOptions Members
Overload List


CenterX Property (FilterCustomOptions)

Accusoft.ScanFixXpress8.Net
CenterX Property (FilterCustomOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterCustomOptions Class : CenterX Property
Gets and sets horizontal value for center point of filter. A value of -1 will automatically set the center based on region size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CenterX As Integer
'Usage

Dim instance As FilterCustomOptions
Dim value As Integer

instance.CenterX = value

value = instance.CenterX
public int CenterX {get; set;}
public: __property int get_CenterX();
public: __property void set_CenterX(
   int value
);
public:
property int CenterX {
   int get();
   void set (    int value);
}
Remarks

The default value is -1.

Valid values are -1 or 0 to {Width} - 1.

See Also

Reference

FilterCustomOptions Class
FilterCustomOptions Members


CenterY Property (FilterCustomOptions)

Accusoft.ScanFixXpress8.Net
CenterY Property (FilterCustomOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterCustomOptions Class : CenterY Property
Gets and sets vertical value for center point of filter. A value of -1 will automatically set the center based on region size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CenterY As Integer
'Usage

Dim instance As FilterCustomOptions
Dim value As Integer

instance.CenterY = value

value = instance.CenterY
public int CenterY {get; set;}
public: __property int get_CenterY();
public: __property void set_CenterY(
   int value
);
public:
property int CenterY {
   int get();
   void set (    int value);
}
Remarks

The default value is -1.

Valid values are -1 or 0 to {Width} - 1.

See Also

Reference

FilterCustomOptions Class
FilterCustomOptions Members


Divisor Property

Accusoft.ScanFixXpress8.Net
Divisor Property

Accusoft.ScanFixXpressSdk Namespace > FilterCustomOptions Class : Divisor Property
Gets and sets the matrix divisor used by custom filter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Divisor As Integer
'Usage

Dim instance As FilterCustomOptions
Dim value As Integer

instance.Divisor = value

value = instance.Divisor
public int Divisor {get; set;}
public: __property int get_Divisor();
public: __property void set_Divisor(
   int value
);
public:
property int Divisor {
   int get();
   void set (    int value);
}
Remarks

The default value is 0.

Valid values are 1 to {no limit}.

See Also

Reference

FilterCustomOptions Class
FilterCustomOptions Members


Height Property (FilterCustomOptions)

Accusoft.ScanFixXpress8.Net
Height Property (FilterCustomOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterCustomOptions Class : Height Property
Gets value for height of custom filter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Integer
'Usage

Dim instance As FilterCustomOptions
Dim value As Integer

value = instance.Height
public int Height {get;}
public: __property int get_Height();
public:
property int Height {
   int get();
}
See Also

Reference

FilterCustomOptions Class
FilterCustomOptions Members


Offset Property

Accusoft.ScanFixXpress8.Net
Offset Property

Accusoft.ScanFixXpressSdk Namespace > FilterCustomOptions Class : Offset Property
Gets and sets value for offset added to output of the convolution, used to bias the result up or down.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Offset As Integer
'Usage

Dim instance As FilterCustomOptions
Dim value As Integer

instance.Offset = value

value = instance.Offset
public int Offset {get; set;}
public: __property int get_Offset();
public: __property void set_Offset(
   int value
);
public:
property int Offset {
   int get();
   void set (    int value);
}
Remarks

The default value is 0.

Valid values are -{no limit} to {no limit}.

See Also

Reference

FilterCustomOptions Class
FilterCustomOptions Members


Weights Property

Accusoft.ScanFixXpress8.Net
Weights Property

Accusoft.ScanFixXpressSdk Namespace > FilterCustomOptions Class : Weights Property
Gets and sets filter weights matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Weights As Integer(,)
'Usage

Dim instance As FilterCustomOptions
Dim value() As Integer

instance.Weights = value

value = instance.Weights
public int[,] Weights {get; set;}
public: __property int[,]* get_Weights();
public: __property void set_Weights(
   int[]* value
);
public:
property array<int,>^ Weights {
   array<int,>^ get();
   void set (    array<int>^ value);
}
See Also

Reference

FilterCustomOptions Class
FilterCustomOptions Members


Width Property (FilterCustomOptions)

Accusoft.ScanFixXpress8.Net
Width Property (FilterCustomOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterCustomOptions Class : Width Property
Gets value for width of custom filter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Width As Integer
'Usage

Dim instance As FilterCustomOptions
Dim value As Integer

value = instance.Width
public int Width {get;}
public: __property int get_Width();
public:
property int Width {
   int get();
}
See Also

Reference

FilterCustomOptions Class
FilterCustomOptions Members


FilterGaussianOptions Class

Accusoft.ScanFixXpress8.Net
FilterGaussianOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : FilterGaussianOptions Class
Contains parameters for the ScanFix.ApplyGaussianFilter filter process.
Object Model
FilterGaussianOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FilterGaussianOptions
   Inherits EnhancementOption
'Usage

Dim instance As FilterGaussianOptions
public class FilterGaussianOptions : EnhancementOption
public __gc class FilterGaussianOptions : public EnhancementOption
public ref class FilterGaussianOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.FilterGaussianOptions

See Also

Reference

FilterGaussianOptions Members
Accusoft.ScanFixXpressSdk Namespace


FilterGaussianOptions Class Members

Accusoft.ScanFixXpress8.Net
FilterGaussianOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : FilterGaussianOptions Class

The following tables list the members exposed by FilterGaussianOptions.

Public Constructors
 | Name | Description
Public Constructor | FilterGaussianOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | CenterX | Gets and sets horizontal value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | CenterY | Gets and sets vertical value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | Height | Gets and sets height in pixels of the region sampled for filter calculations.
Public Property | Width | Gets and sets width in pixels of the region sampled for filter calculations.
Top
See Also

Reference

FilterGaussianOptions Class
Accusoft.ScanFixXpressSdk Namespace


FilterGaussianOptions Class Properties

Accusoft.ScanFixXpress8.Net
FilterGaussianOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : FilterGaussianOptions Class

For a list of all members of this type, see FilterGaussianOptions members.

Public Properties
 | Name | Description
Public Property | CenterX | Gets and sets horizontal value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | CenterY | Gets and sets vertical value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | Height | Gets and sets height in pixels of the region sampled for filter calculations.
Public Property | Width | Gets and sets width in pixels of the region sampled for filter calculations.
Top
See Also

Reference

FilterGaussianOptions Class
Accusoft.ScanFixXpressSdk Namespace


FilterGaussianOptions Constructor

Accusoft.ScanFixXpress8.Net
FilterGaussianOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > FilterGaussianOptions Class : FilterGaussianOptions Constructor
Overload List
Overload | Description
FilterGaussianOptions Constructor() | Instantiates a new FilterGaussianOptions object with the default values.
FilterGaussianOptions Constructor(Int32,Int32,Int32,Int32) | Instantiates a new FilterGaussianOptions object with the specified values.
See Also

Reference

FilterGaussianOptions Class
FilterGaussianOptions Members


FilterGaussianOptions Constructor()

Accusoft.ScanFixXpress8.Net
FilterGaussianOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > FilterGaussianOptions Class > FilterGaussianOptions Constructor : FilterGaussianOptions Constructor()
Instantiates a new FilterGaussianOptions object with the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New()
'Usage

Dim instance As New FilterGaussianOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public FilterGaussianOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: FilterGaussianOptions();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
FilterGaussianOptions();
See Also

Reference

FilterGaussianOptions Class
FilterGaussianOptions Members
Overload List


FilterGaussianOptions Constructor(Int32,Int32,Int32,Int32)

Accusoft.ScanFixXpress8.Net
FilterGaussianOptions Constructor(Int32,Int32,Int32,Int32)

Accusoft.ScanFixXpressSdk Namespace > FilterGaussianOptions Class > FilterGaussianOptions Constructor : FilterGaussianOptions Constructor(Int32,Int32,Int32,Int32)
Value for height of custom filter.
Value for width of custom filter.
Horizontal value for center point of the filter. -1 for center of defined size.
Vertical value for center point of the filter. -1 for center of defined size.
Instantiates a new FilterGaussianOptions object with the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal height As Integer, _
   ByVal width As Integer, _
   ByVal centerX As Integer, _
   ByVal centerY As Integer _
)
'Usage

Dim height As Integer
Dim width As Integer
Dim centerX As Integer
Dim centerY As Integer

Dim instance As New FilterGaussianOptions(height, width, centerX, centerY)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public FilterGaussianOptions(
   int height,
   int width,
   int centerX,
   int centerY
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: FilterGaussianOptions(
   int height,
   int width,
   int centerX,
   int centerY
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
FilterGaussianOptions(
   int height,
   int width,
   int centerX,
   int centerY
)

Parameters

height
Value for height of custom filter.
width
Value for width of custom filter.
centerX
Horizontal value for center point of the filter. -1 for center of defined size.
centerY
Vertical value for center point of the filter. -1 for center of defined size.
See Also

Reference

FilterGaussianOptions Class
FilterGaussianOptions Members
Overload List


CenterX Property (FilterGaussianOptions)

Accusoft.ScanFixXpress8.Net
CenterX Property (FilterGaussianOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterGaussianOptions Class : CenterX Property
Gets and sets horizontal value for center point of filter. A value of -1 will automatically set the center based on region size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CenterX As Integer
'Usage

Dim instance As FilterGaussianOptions
Dim value As Integer

instance.CenterX = value

value = instance.CenterX
public int CenterX {get; set;}
public: __property int get_CenterX();
public: __property void set_CenterX(
   int value
);
public:
property int CenterX {
   int get();
   void set (    int value);
}
Remarks

The default value is -1.

Valid values are -1 or 0 to {Width} - 1.

See Also

Reference

FilterGaussianOptions Class
FilterGaussianOptions Members


CenterY Property (FilterGaussianOptions)

Accusoft.ScanFixXpress8.Net
CenterY Property (FilterGaussianOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterGaussianOptions Class : CenterY Property
Gets and sets vertical value for center point of filter. A value of -1 will automatically set the center based on region size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CenterY As Integer
'Usage

Dim instance As FilterGaussianOptions
Dim value As Integer

instance.CenterY = value

value = instance.CenterY
public int CenterY {get; set;}
public: __property int get_CenterY();
public: __property void set_CenterY(
   int value
);
public:
property int CenterY {
   int get();
   void set (    int value);
}
Remarks

The default value is -1.

Valid values are -1 or 0 to {Height} - 1.

See Also

Reference

FilterGaussianOptions Class
FilterGaussianOptions Members


Height Property (FilterGaussianOptions)

Accusoft.ScanFixXpress8.Net
Height Property (FilterGaussianOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterGaussianOptions Class : Height Property
Gets and sets height in pixels of the region sampled for filter calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As FilterGaussianOptions
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}
Remarks

The default value is 3.

Valid values are 1 to {no limit}.

See Also

Reference

FilterGaussianOptions Class
FilterGaussianOptions Members


Width Property (FilterGaussianOptions)

Accusoft.ScanFixXpress8.Net
Width Property (FilterGaussianOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterGaussianOptions Class : Width Property
Gets and sets width in pixels of the region sampled for filter calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As FilterGaussianOptions
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}
Remarks

The default value is 3.

Valid values are 1 to {no limit}.

See Also

Reference

FilterGaussianOptions Class
FilterGaussianOptions Members


FilterLaplacianOptions Class

Accusoft.ScanFixXpress8.Net
FilterLaplacianOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : FilterLaplacianOptions Class
Defines a place holder class for options that control the ScanFix.ApplyLaplacianFilter filter process. This class does not contain any parameters that can be set.
Object Model
FilterLaplacianOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FilterLaplacianOptions
   Inherits EnhancementOption
'Usage

Dim instance As FilterLaplacianOptions
public class FilterLaplacianOptions : EnhancementOption
public __gc class FilterLaplacianOptions : public EnhancementOption
public ref class FilterLaplacianOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.FilterLaplacianOptions

See Also

Reference

FilterLaplacianOptions Members
Accusoft.ScanFixXpressSdk Namespace


FilterLaplacianOptions Class Members

Accusoft.ScanFixXpress8.Net
FilterLaplacianOptions Class Members

Accusoft.ScanFixXpressSdk Namespace : FilterLaplacianOptions Class

The following tables list the members exposed by FilterLaplacianOptions.

Public Constructors
 | Name | Description
Public Constructor | FilterLaplacianOptions Constructor | Instantiates a new FilterLaplacianOptions object with the default (empty) values.
Top
See Also

Reference

FilterLaplacianOptions Class
Accusoft.ScanFixXpressSdk Namespace


FilterLaplacianOptions Constructor

Accusoft.ScanFixXpress8.Net
FilterLaplacianOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > FilterLaplacianOptions Class : FilterLaplacianOptions Constructor
Instantiates a new FilterLaplacianOptions object with the default (empty) values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New()
'Usage

Dim instance As New FilterLaplacianOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public FilterLaplacianOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: FilterLaplacianOptions();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
FilterLaplacianOptions();
See Also

Reference

FilterLaplacianOptions Class
FilterLaplacianOptions Members


FilterMedianOptions Class

Accusoft.ScanFixXpress8.Net
FilterMedianOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : FilterMedianOptions Class
Contains parameters for the ScanFix.ApplyMedianFilter filter process.
Object Model
FilterMedianOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FilterMedianOptions
   Inherits EnhancementOption
'Usage

Dim instance As FilterMedianOptions
public class FilterMedianOptions : EnhancementOption
public __gc class FilterMedianOptions : public EnhancementOption
public ref class FilterMedianOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.FilterMedianOptions

See Also

Reference

FilterMedianOptions Members
Accusoft.ScanFixXpressSdk Namespace


FilterMedianOptions Class Members

Accusoft.ScanFixXpress8.Net
FilterMedianOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : FilterMedianOptions Class

The following tables list the members exposed by FilterMedianOptions.

Public Constructors
 | Name | Description
Public Constructor | FilterMedianOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | CenterX | Gets and sets horizontal value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | CenterY | Gets and sets vertical value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | Height | Gets and sets height in pixels of the region sampled for filter calculations.
Public Property | Width | Gets and sets width in pixels of the region sampled for filter calculations.
Top
See Also

Reference

FilterMedianOptions Class
Accusoft.ScanFixXpressSdk Namespace


FilterMedianOptions Class Properties

Accusoft.ScanFixXpress8.Net
FilterMedianOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : FilterMedianOptions Class

For a list of all members of this type, see FilterMedianOptions members.

Public Properties
 | Name | Description
Public Property | CenterX | Gets and sets horizontal value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | CenterY | Gets and sets vertical value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | Height | Gets and sets height in pixels of the region sampled for filter calculations.
Public Property | Width | Gets and sets width in pixels of the region sampled for filter calculations.
Top
See Also

Reference

FilterMedianOptions Class
Accusoft.ScanFixXpressSdk Namespace


FilterMedianOptions Constructor

Accusoft.ScanFixXpress8.Net
FilterMedianOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > FilterMedianOptions Class : FilterMedianOptions Constructor
Overload List
Overload | Description
FilterMedianOptions Constructor() | Instantiates a new FilterMedianOptions object with the default values.
FilterMedianOptions Constructor(Int32,Int32,Int32,Int32) | Instantiates a new FilterMedianOptions object with the specified values.
See Also

Reference

FilterMedianOptions Class
FilterMedianOptions Members


FilterMedianOptions Constructor()

Accusoft.ScanFixXpress8.Net
FilterMedianOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > FilterMedianOptions Class > FilterMedianOptions Constructor : FilterMedianOptions Constructor()
Instantiates a new FilterMedianOptions object with the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New FilterMedianOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public FilterMedianOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: FilterMedianOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
FilterMedianOptions();
See Also

Reference

FilterMedianOptions Class
FilterMedianOptions Members
Overload List


FilterMedianOptions Constructor(Int32,Int32,Int32,Int32)

Accusoft.ScanFixXpress8.Net
FilterMedianOptions Constructor(Int32,Int32,Int32,Int32)

Accusoft.ScanFixXpressSdk Namespace > FilterMedianOptions Class > FilterMedianOptions Constructor : FilterMedianOptions Constructor(Int32,Int32,Int32,Int32)
Value for height of custom filter.
Value for width of custom filter.
Horizontal value for center point of the filter. -1 for center of defined size.
Vertical value for center point of the filter. -1 for center of defined size.
Instantiates a new FilterMedianOptions object with the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New( _
   ByVal height As Integer, _
   ByVal width As Integer, _
   ByVal centerX As Integer, _
   ByVal centerY As Integer _
)
'Usage

Dim height As Integer
Dim width As Integer
Dim centerX As Integer
Dim centerY As Integer

Dim instance As New FilterMedianOptions(height, width, centerX, centerY)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public FilterMedianOptions(
   int height,
   int width,
   int centerX,
   int centerY
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: FilterMedianOptions(
   int height,
   int width,
   int centerX,
   int centerY
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
FilterMedianOptions(
   int height,
   int width,
   int centerX,
   int centerY
)

Parameters

height
Value for height of custom filter.
width
Value for width of custom filter.
centerX
Horizontal value for center point of the filter. -1 for center of defined size.
centerY
Vertical value for center point of the filter. -1 for center of defined size.
See Also

Reference

FilterMedianOptions Class
FilterMedianOptions Members
Overload List


CenterX Property (FilterMedianOptions)

Accusoft.ScanFixXpress8.Net
CenterX Property (FilterMedianOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterMedianOptions Class : CenterX Property
Gets and sets horizontal value for center point of filter. A value of -1 will automatically set the center based on region size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CenterX As Integer
'Usage

Dim instance As FilterMedianOptions
Dim value As Integer

instance.CenterX = value

value = instance.CenterX
public int CenterX {get; set;}
public: __property int get_CenterX();
public: __property void set_CenterX(
   int value
);
public:
property int CenterX {
   int get();
   void set (    int value);
}
Remarks

The default value is -1.

Valid values are -1 or 0 to {Width} - 1.

See Also

Reference

FilterMedianOptions Class
FilterMedianOptions Members


CenterY Property (FilterMedianOptions)

Accusoft.ScanFixXpress8.Net
CenterY Property (FilterMedianOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterMedianOptions Class : CenterY Property
Gets and sets vertical value for center point of filter. A value of -1 will automatically set the center based on region size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CenterY As Integer
'Usage

Dim instance As FilterMedianOptions
Dim value As Integer

instance.CenterY = value

value = instance.CenterY
public int CenterY {get; set;}
public: __property int get_CenterY();
public: __property void set_CenterY(
   int value
);
public:
property int CenterY {
   int get();
   void set (    int value);
}
Remarks

The default value is -1.

Valid values are -1 or 0 to {Height} - 1.

See Also

Reference

FilterMedianOptions Class
FilterMedianOptions Members


Height Property (FilterMedianOptions)

Accusoft.ScanFixXpress8.Net
Height Property (FilterMedianOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterMedianOptions Class : Height Property
Gets and sets height in pixels of the region sampled for filter calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As FilterMedianOptions
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}
Remarks

The default value is 3.

Valid values are 1 to {no limit}.

See Also

Reference

FilterMedianOptions Class
FilterMedianOptions Members


Width Property (FilterMedianOptions)

Accusoft.ScanFixXpress8.Net
Width Property (FilterMedianOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterMedianOptions Class : Width Property
Gets and sets width in pixels of the region sampled for filter calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As FilterMedianOptions
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}
Remarks

The default value is 3.

Valid values are 1 to {no limit}.

See Also

Reference

FilterMedianOptions Class
FilterMedianOptions Members


FilterOpenOptions Class

Accusoft.ScanFixXpress8.Net
FilterOpenOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : FilterOpenOptions Class
Contains parameters for the ScanFix.ApplyOpenFilter filter process.
Object Model
FilterOpenOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FilterOpenOptions
   Inherits EnhancementOption
'Usage

Dim instance As FilterOpenOptions
public class FilterOpenOptions : EnhancementOption
public __gc class FilterOpenOptions : public EnhancementOption
public ref class FilterOpenOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.FilterOpenOptions

See Also

Reference

FilterOpenOptions Members
Accusoft.ScanFixXpressSdk Namespace


FilterOpenOptions Class Members

Accusoft.ScanFixXpress8.Net
FilterOpenOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : FilterOpenOptions Class

The following tables list the members exposed by FilterOpenOptions.

Public Constructors
 | Name | Description
Public Constructor | FilterOpenOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | CenterX | Gets and sets horizontal value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | CenterY | Gets and sets vertical value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | Height | Gets and sets height in pixels of the region sampled for filter calculations.
Public Property | Width | Gets and sets width in pixels of the region sampled for filter calculations.
Top
See Also

Reference

FilterOpenOptions Class
Accusoft.ScanFixXpressSdk Namespace


FilterOpenOptions Class Properties

Accusoft.ScanFixXpress8.Net
FilterOpenOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : FilterOpenOptions Class

For a list of all members of this type, see FilterOpenOptions members.

Public Properties
 | Name | Description
Public Property | CenterX | Gets and sets horizontal value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | CenterY | Gets and sets vertical value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | Height | Gets and sets height in pixels of the region sampled for filter calculations.
Public Property | Width | Gets and sets width in pixels of the region sampled for filter calculations.
Top
See Also

Reference

FilterOpenOptions Class
Accusoft.ScanFixXpressSdk Namespace


FilterOpenOptions Constructor

Accusoft.ScanFixXpress8.Net
FilterOpenOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > FilterOpenOptions Class : FilterOpenOptions Constructor
Overload List
Overload | Description
FilterOpenOptions Constructor() | Instantiates a new FilterOpenOptions object with the default values.
FilterOpenOptions Constructor(Int32,Int32,Int32,Int32) | Instantiates a new FilterOpenOptions object with the specified values.
See Also

Reference

FilterOpenOptions Class
FilterOpenOptions Members


FilterOpenOptions Constructor()

Accusoft.ScanFixXpress8.Net
FilterOpenOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > FilterOpenOptions Class > FilterOpenOptions Constructor : FilterOpenOptions Constructor()
Instantiates a new FilterOpenOptions object with the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New()
'Usage

Dim instance As New FilterOpenOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public FilterOpenOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: FilterOpenOptions();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
FilterOpenOptions();
See Also

Reference

FilterOpenOptions Class
FilterOpenOptions Members
Overload List


FilterOpenOptions Constructor(Int32,Int32,Int32,Int32)

Accusoft.ScanFixXpress8.Net
FilterOpenOptions Constructor(Int32,Int32,Int32,Int32)

Accusoft.ScanFixXpressSdk Namespace > FilterOpenOptions Class > FilterOpenOptions Constructor : FilterOpenOptions Constructor(Int32,Int32,Int32,Int32)
Value for height of custom filter.
Value for width of custom filter.
Horizontal value for center point of the filter. -1 for center of defined size.
Vertical value for center point of the filter. -1 for center of defined size.
Instantiates a new FilterOpenOptions object with the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New( _
   ByVal height As Integer, _
   ByVal width As Integer, _
   ByVal centerX As Integer, _
   ByVal centerY As Integer _
)
'Usage

Dim height As Integer
Dim width As Integer
Dim centerX As Integer
Dim centerY As Integer

Dim instance As New FilterOpenOptions(height, width, centerX, centerY)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public FilterOpenOptions(
   int height,
   int width,
   int centerX,
   int centerY
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: FilterOpenOptions(
   int height,
   int width,
   int centerX,
   int centerY
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
FilterOpenOptions(
   int height,
   int width,
   int centerX,
   int centerY
)

Parameters

height
Value for height of custom filter.
width
Value for width of custom filter.
centerX
Horizontal value for center point of the filter. -1 for center of defined size.
centerY
Vertical value for center point of the filter. -1 for center of defined size.
See Also

Reference

FilterOpenOptions Class
FilterOpenOptions Members
Overload List


CenterX Property (FilterOpenOptions)

Accusoft.ScanFixXpress8.Net
CenterX Property (FilterOpenOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterOpenOptions Class : CenterX Property
Gets and sets horizontal value for center point of filter. A value of -1 will automatically set the center based on region size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CenterX As Integer
'Usage

Dim instance As FilterOpenOptions
Dim value As Integer

instance.CenterX = value

value = instance.CenterX
public int CenterX {get; set;}
public: __property int get_CenterX();
public: __property void set_CenterX(
   int value
);
public:
property int CenterX {
   int get();
   void set (    int value);
}
Remarks

The default value is -1.

Valid values are -1 or 0 to {Width} - 1.

See Also

Reference

FilterOpenOptions Class
FilterOpenOptions Members


CenterY Property (FilterOpenOptions)

Accusoft.ScanFixXpress8.Net
CenterY Property (FilterOpenOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterOpenOptions Class : CenterY Property
Gets and sets vertical value for center point of filter. A value of -1 will automatically set the center based on region size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CenterY As Integer
'Usage

Dim instance As FilterOpenOptions
Dim value As Integer

instance.CenterY = value

value = instance.CenterY
public int CenterY {get; set;}
public: __property int get_CenterY();
public: __property void set_CenterY(
   int value
);
public:
property int CenterY {
   int get();
   void set (    int value);
}
Remarks

The default value is -1.

Valid values are -1 or 0 to {Height} - 1.

See Also

Reference

FilterOpenOptions Class
FilterOpenOptions Members


Height Property (FilterOpenOptions)

Accusoft.ScanFixXpress8.Net
Height Property (FilterOpenOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterOpenOptions Class : Height Property
Gets and sets height in pixels of the region sampled for filter calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As FilterOpenOptions
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}
Remarks

The default value is 3.

Valid values are 1 to {no limit}.

See Also

Reference

FilterOpenOptions Class
FilterOpenOptions Members


Width Property (FilterOpenOptions)

Accusoft.ScanFixXpress8.Net
Width Property (FilterOpenOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterOpenOptions Class : Width Property
Gets and sets width in pixels of the region sampled for filter calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As FilterOpenOptions
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}
Remarks

The default value is 3.

Valid values are 1 to {no limit}.

See Also

Reference

FilterOpenOptions Class
FilterOpenOptions Members


FilterPrewittOptions Class

Accusoft.ScanFixXpress8.Net
FilterPrewittOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : FilterPrewittOptions Class
Contains parameters for the ScanFix.ApplyPrewittFilter filter process.
Object Model
FilterPrewittOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FilterPrewittOptions
   Inherits EnhancementOption
'Usage

Dim instance As FilterPrewittOptions
public class FilterPrewittOptions : EnhancementOption
public __gc class FilterPrewittOptions : public EnhancementOption
public ref class FilterPrewittOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.FilterPrewittOptions

See Also

Reference

FilterPrewittOptions Members
Accusoft.ScanFixXpressSdk Namespace


FilterPrewittOptions Class Members

Accusoft.ScanFixXpress8.Net
FilterPrewittOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : FilterPrewittOptions Class

The following tables list the members exposed by FilterPrewittOptions.

Public Constructors
 | Name | Description
Public Constructor | FilterPrewittOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Direction | Gets and sets value for Direction of custom filter.
Top
See Also

Reference

FilterPrewittOptions Class
Accusoft.ScanFixXpressSdk Namespace


FilterPrewittOptions Class Properties

Accusoft.ScanFixXpress8.Net
FilterPrewittOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : FilterPrewittOptions Class

For a list of all members of this type, see FilterPrewittOptions members.

Public Properties
 | Name | Description
Public Property | Direction | Gets and sets value for Direction of custom filter.
Top
See Also

Reference

FilterPrewittOptions Class
Accusoft.ScanFixXpressSdk Namespace


FilterPrewittOptions Constructor

Accusoft.ScanFixXpress8.Net
FilterPrewittOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > FilterPrewittOptions Class : FilterPrewittOptions Constructor
Overload List
Overload | Description
FilterPrewittOptions Constructor() | Instantiates a new FilterPrewittOptions object with the default values.
FilterPrewittOptions Constructor(FilterDirection) | Instantiates a new FilterPrewittOptions object with the default values.
See Also

Reference

FilterPrewittOptions Class
FilterPrewittOptions Members


FilterPrewittOptions Constructor()

Accusoft.ScanFixXpress8.Net
FilterPrewittOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > FilterPrewittOptions Class > FilterPrewittOptions Constructor : FilterPrewittOptions Constructor()
Instantiates a new FilterPrewittOptions object with the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New FilterPrewittOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public FilterPrewittOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: FilterPrewittOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
FilterPrewittOptions();
See Also

Reference

FilterPrewittOptions Class
FilterPrewittOptions Members
Overload List


FilterPrewittOptions Constructor(FilterDirection)

Accusoft.ScanFixXpress8.Net
FilterPrewittOptions Constructor(FilterDirection)

Accusoft.ScanFixXpressSdk Namespace > FilterPrewittOptions Class > FilterPrewittOptions Constructor : FilterPrewittOptions Constructor(FilterDirection)
Direction for filter operation
Instantiates a new FilterPrewittOptions object with the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New( _
   ByVal direction As FilterDirection _
)
'Usage

Dim direction As FilterDirection

Dim instance As New FilterPrewittOptions(direction)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public FilterPrewittOptions(
   FilterDirection direction
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: FilterPrewittOptions(
   FilterDirection direction
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
FilterPrewittOptions(
   FilterDirection direction
)

Parameters

direction
Direction for filter operation
See Also

Reference

FilterPrewittOptions Class
FilterPrewittOptions Members
Overload List


Direction Property (FilterPrewittOptions)

Accusoft.ScanFixXpress8.Net
Direction Property (FilterPrewittOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterPrewittOptions Class : Direction Property
Gets and sets value for Direction of custom filter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Direction As FilterDirection
'Usage

Dim instance As FilterPrewittOptions
Dim value As FilterDirection

instance.Direction = value

value = instance.Direction
public FilterDirection Direction {get; set;}
public: __property FilterDirection get_Direction();
public: __property void set_Direction(
   FilterDirection value
);
public:
property FilterDirection Direction {
   FilterDirection get();
   void set (    FilterDirection value);
}
Remarks

The default value is Horizontal.

See Also

Reference

FilterPrewittOptions Class
FilterPrewittOptions Members


FilterResults Class

Accusoft.ScanFixXpress8.Net
FilterResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : FilterResults Class
Defines a place holder class for the Filter enhancement result.
Object Model
FilterResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FilterResults
   Inherits EnhancementResult
'Usage

Dim instance As FilterResults
public class FilterResults : EnhancementResult
public __gc class FilterResults : public EnhancementResult
public ref class FilterResults : public EnhancementResult
Remarks
This class contains no data. Its presence in the results list is used to determine that the operation has run successfully.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.FilterResults

See Also

Reference

FilterResults Members
Accusoft.ScanFixXpressSdk Namespace


FilterResults Class Members

Accusoft.ScanFixXpress8.Net
FilterResults Class Members

Accusoft.ScanFixXpressSdk Namespace : FilterResults Class

The following tables list the members exposed by FilterResults.

See Also

Reference

FilterResults Class
Accusoft.ScanFixXpressSdk Namespace


FilterSobelOptions Class

Accusoft.ScanFixXpress8.Net
FilterSobelOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : FilterSobelOptions Class
Contains parameters for the ScanFix.ApplySobelFilter filter process.
Object Model
FilterSobelOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FilterSobelOptions
   Inherits EnhancementOption
'Usage

Dim instance As FilterSobelOptions
public class FilterSobelOptions : EnhancementOption
public __gc class FilterSobelOptions : public EnhancementOption
public ref class FilterSobelOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.FilterSobelOptions

See Also

Reference

FilterSobelOptions Members
Accusoft.ScanFixXpressSdk Namespace


FilterSobelOptions Class Members

Accusoft.ScanFixXpress8.Net
FilterSobelOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : FilterSobelOptions Class

The following tables list the members exposed by FilterSobelOptions.

Public Constructors
 | Name | Description
Public Constructor | FilterSobelOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Direction | Gets and sets value for direction of custom filter.
Top
See Also

Reference

FilterSobelOptions Class
Accusoft.ScanFixXpressSdk Namespace


FilterSobelOptions Class Properties

Accusoft.ScanFixXpress8.Net
FilterSobelOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : FilterSobelOptions Class

For a list of all members of this type, see FilterSobelOptions members.

Public Properties
 | Name | Description
Public Property | Direction | Gets and sets value for direction of custom filter.
Top
See Also

Reference

FilterSobelOptions Class
Accusoft.ScanFixXpressSdk Namespace


FilterSobelOptions Constructor

Accusoft.ScanFixXpress8.Net
FilterSobelOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > FilterSobelOptions Class : FilterSobelOptions Constructor
Overload List
Overload | Description
FilterSobelOptions Constructor() | Instantiates a new FilterSobelOptions object with the default values.
FilterSobelOptions Constructor(FilterDirection) | Instantiates a new FilterSobelOptions object with the specified values.
See Also

Reference

FilterSobelOptions Class
FilterSobelOptions Members


FilterSobelOptions Constructor()

Accusoft.ScanFixXpress8.Net
FilterSobelOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > FilterSobelOptions Class > FilterSobelOptions Constructor : FilterSobelOptions Constructor()
Instantiates a new FilterSobelOptions object with the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New FilterSobelOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public FilterSobelOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: FilterSobelOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
FilterSobelOptions();
See Also

Reference

FilterSobelOptions Class
FilterSobelOptions Members
Overload List


FilterSobelOptions Constructor(FilterDirection)

Accusoft.ScanFixXpress8.Net
FilterSobelOptions Constructor(FilterDirection)

Accusoft.ScanFixXpressSdk Namespace > FilterSobelOptions Class > FilterSobelOptions Constructor : FilterSobelOptions Constructor(FilterDirection)
Direction for filter operation
Instantiates a new FilterSobelOptions object with the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New( _
   ByVal direction As FilterDirection _
)
'Usage

Dim direction As FilterDirection

Dim instance As New FilterSobelOptions(direction)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public FilterSobelOptions(
   FilterDirection direction
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: FilterSobelOptions(
   FilterDirection direction
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
FilterSobelOptions(
   FilterDirection direction
)

Parameters

direction
Direction for filter operation
See Also

Reference

FilterSobelOptions Class
FilterSobelOptions Members
Overload List


Direction Property (FilterSobelOptions)

Accusoft.ScanFixXpress8.Net
Direction Property (FilterSobelOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterSobelOptions Class : Direction Property
Gets and sets value for direction of custom filter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Direction As FilterDirection
'Usage

Dim instance As FilterSobelOptions
Dim value As FilterDirection

instance.Direction = value

value = instance.Direction
public FilterDirection Direction {get; set;}
public: __property FilterDirection get_Direction();
public: __property void set_Direction(
   FilterDirection value
);
public:
property FilterDirection Direction {
   FilterDirection get();
   void set (    FilterDirection value);
}
Remarks

The default value is Horizontal.

See Also

Reference

FilterSobelOptions Class
FilterSobelOptions Members


FilterUnsharpOptions Class

Accusoft.ScanFixXpress8.Net
FilterUnsharpOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : FilterUnsharpOptions Class
Contains parameters for the ScanFix.ApplyUnsharpFilter filter process.
Object Model
FilterUnsharpOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FilterUnsharpOptions
   Inherits EnhancementOption
'Usage

Dim instance As FilterUnsharpOptions
public class FilterUnsharpOptions : EnhancementOption
public __gc class FilterUnsharpOptions : public EnhancementOption
public ref class FilterUnsharpOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.FilterUnsharpOptions

See Also

Reference

FilterUnsharpOptions Members
Accusoft.ScanFixXpressSdk Namespace


FilterUnsharpOptions Class Members

Accusoft.ScanFixXpress8.Net
FilterUnsharpOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : FilterUnsharpOptions Class

The following tables list the members exposed by FilterUnsharpOptions.

Public Constructors
 | Name | Description
Public Constructor | FilterUnsharpOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | CenterX | Gets and sets horizontal value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | CenterY | Gets and sets vertical value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | Height | Gets and sets height in pixels of the region sampled for filter calculations.
Public Property | Width | Gets and sets width in pixels of the region sampled for filter calculations.
Top
See Also

Reference

FilterUnsharpOptions Class
Accusoft.ScanFixXpressSdk Namespace


FilterUnsharpOptions Class Properties

Accusoft.ScanFixXpress8.Net
FilterUnsharpOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : FilterUnsharpOptions Class

For a list of all members of this type, see FilterUnsharpOptions members.

Public Properties
 | Name | Description
Public Property | CenterX | Gets and sets horizontal value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | CenterY | Gets and sets vertical value for center point of filter. A value of -1 will automatically set the center based on region size.
Public Property | Height | Gets and sets height in pixels of the region sampled for filter calculations.
Public Property | Width | Gets and sets width in pixels of the region sampled for filter calculations.
Top
See Also

Reference

FilterUnsharpOptions Class
Accusoft.ScanFixXpressSdk Namespace


FilterUnsharpOptions Constructor

Accusoft.ScanFixXpress8.Net
FilterUnsharpOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > FilterUnsharpOptions Class : FilterUnsharpOptions Constructor
Overload List
Overload | Description
FilterUnsharpOptions Constructor() | Instantiates a new FilterUnsharpOptions object with the default values.
FilterUnsharpOptions Constructor(Int32,Int32,Int32,Int32) | Instantiates a new FilterUnsharpOptions object with the specified values.
See Also

Reference

FilterUnsharpOptions Class
FilterUnsharpOptions Members


FilterUnsharpOptions Constructor()

Accusoft.ScanFixXpress8.Net
FilterUnsharpOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > FilterUnsharpOptions Class > FilterUnsharpOptions Constructor : FilterUnsharpOptions Constructor()
Instantiates a new FilterUnsharpOptions object with the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New()
'Usage

Dim instance As New FilterUnsharpOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public FilterUnsharpOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: FilterUnsharpOptions();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
FilterUnsharpOptions();
See Also

Reference

FilterUnsharpOptions Class
FilterUnsharpOptions Members
Overload List


FilterUnsharpOptions Constructor(Int32,Int32,Int32,Int32)

Accusoft.ScanFixXpress8.Net
FilterUnsharpOptions Constructor(Int32,Int32,Int32,Int32)

Accusoft.ScanFixXpressSdk Namespace > FilterUnsharpOptions Class > FilterUnsharpOptions Constructor : FilterUnsharpOptions Constructor(Int32,Int32,Int32,Int32)
Value for height of custom filter.
Value for width of custom filter.
Horizontal value for center point of the filter. -1 for center of defined size.
Vertical value for center point of the filter. -1 for center of defined size.
Instantiates a new FilterUnsharpOptions object with the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal height As Integer, _
   ByVal width As Integer, _
   ByVal centerX As Integer, _
   ByVal centerY As Integer _
)
'Usage

Dim height As Integer
Dim width As Integer
Dim centerX As Integer
Dim centerY As Integer

Dim instance As New FilterUnsharpOptions(height, width, centerX, centerY)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public FilterUnsharpOptions(
   int height,
   int width,
   int centerX,
   int centerY
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: FilterUnsharpOptions(
   int height,
   int width,
   int centerX,
   int centerY
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
FilterUnsharpOptions(
   int height,
   int width,
   int centerX,
   int centerY
)

Parameters

height
Value for height of custom filter.
width
Value for width of custom filter.
centerX
Horizontal value for center point of the filter. -1 for center of defined size.
centerY
Vertical value for center point of the filter. -1 for center of defined size.
See Also

Reference

FilterUnsharpOptions Class
FilterUnsharpOptions Members
Overload List


CenterX Property (FilterUnsharpOptions)

Accusoft.ScanFixXpress8.Net
CenterX Property (FilterUnsharpOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterUnsharpOptions Class : CenterX Property
Gets and sets horizontal value for center point of filter. A value of -1 will automatically set the center based on region size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CenterX As Integer
'Usage

Dim instance As FilterUnsharpOptions
Dim value As Integer

instance.CenterX = value

value = instance.CenterX
public int CenterX {get; set;}
public: __property int get_CenterX();
public: __property void set_CenterX(
   int value
);
public:
property int CenterX {
   int get();
   void set (    int value);
}
Remarks

The default value is -1.

Valid values are -1 or 0 to {Width} - 1.

See Also

Reference

FilterUnsharpOptions Class
FilterUnsharpOptions Members


CenterY Property (FilterUnsharpOptions)

Accusoft.ScanFixXpress8.Net
CenterY Property (FilterUnsharpOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterUnsharpOptions Class : CenterY Property
Gets and sets vertical value for center point of filter. A value of -1 will automatically set the center based on region size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CenterY As Integer
'Usage

Dim instance As FilterUnsharpOptions
Dim value As Integer

instance.CenterY = value

value = instance.CenterY
public int CenterY {get; set;}
public: __property int get_CenterY();
public: __property void set_CenterY(
   int value
);
public:
property int CenterY {
   int get();
   void set (    int value);
}
Remarks

The default value is -1.

Valid values are -1 or 0 to {Height} - 1.

See Also

Reference

FilterUnsharpOptions Class
FilterUnsharpOptions Members


Height Property (FilterUnsharpOptions)

Accusoft.ScanFixXpress8.Net
Height Property (FilterUnsharpOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterUnsharpOptions Class : Height Property
Gets and sets height in pixels of the region sampled for filter calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As FilterUnsharpOptions
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}
Remarks

The default value is 3.

Valid values are 1 to {no limit}.

See Also

Reference

FilterUnsharpOptions Class
FilterUnsharpOptions Members


Width Property (FilterUnsharpOptions)

Accusoft.ScanFixXpress8.Net
Width Property (FilterUnsharpOptions)

Accusoft.ScanFixXpressSdk Namespace > FilterUnsharpOptions Class : Width Property
Gets and sets width in pixels of the region sampled for filter calculations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As FilterUnsharpOptions
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}
Remarks

The default value is 3.

Valid values are 1 to {no limit}.

See Also

Reference

FilterUnsharpOptions Class
FilterUnsharpOptions Members


FlipOptions Class

Accusoft.ScanFixXpress8.Net
FlipOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : FlipOptions Class
Defines a place holder class for the Flip image enhancement operation. This class does not contain any parameters for the ScanFix.Flip operation.
Object Model
FlipOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FlipOptions
   Inherits EnhancementOption
'Usage

Dim instance As FlipOptions
public class FlipOptions : EnhancementOption
public __gc class FlipOptions : public EnhancementOption
public ref class FlipOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.FlipOptions

See Also

Reference

FlipOptions Members
Accusoft.ScanFixXpressSdk Namespace


FlipOptions Class Members

Accusoft.ScanFixXpress8.Net
FlipOptions Class Members

Accusoft.ScanFixXpressSdk Namespace : FlipOptions Class

The following tables list the members exposed by FlipOptions.

Public Constructors
 | Name | Description
Public Constructor | FlipOptions Constructor | Instantiates a new FlipOptions object.
Top
See Also

Reference

FlipOptions Class
Accusoft.ScanFixXpressSdk Namespace


FlipOptions Constructor

Accusoft.ScanFixXpress8.Net
FlipOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > FlipOptions Class : FlipOptions Constructor
Instantiates a new FlipOptions object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New()
'Usage

Dim instance As New FlipOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public FlipOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: FlipOptions();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
FlipOptions();
See Also

Reference

FlipOptions Class
FlipOptions Members


FlipResults Class

Accusoft.ScanFixXpress8.Net
FlipResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : FlipResults Class
Defines a place holder class for the Flip enhancement result.
Object Model
FlipResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FlipResults
   Inherits EnhancementResult
'Usage

Dim instance As FlipResults
public class FlipResults : EnhancementResult
public __gc class FlipResults : public EnhancementResult
public ref class FlipResults : public EnhancementResult
Remarks
This class contains no data. Its presence in the results list is used to determine that the operation has run successfully.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.FlipResults

See Also

Reference

FlipResults Members
Accusoft.ScanFixXpressSdk Namespace


FlipResults Class Members

Accusoft.ScanFixXpress8.Net
FlipResults Class Members

Accusoft.ScanFixXpressSdk Namespace : FlipResults Class

The following tables list the members exposed by FlipResults.

See Also

Reference

FlipResults Class
Accusoft.ScanFixXpressSdk Namespace


GetRectangleOptions Class

Accusoft.ScanFixXpress8.Net
GetRectangleOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : GetRectangleOptions Class
Contains parameters that control the ScanFix.GetRectangle process.
Object Model
GetRectangleOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class GetRectangleOptions
   Inherits EnhancementOption
'Usage

Dim instance As GetRectangleOptions
public class GetRectangleOptions : EnhancementOption
public __gc class GetRectangleOptions : public EnhancementOption
public ref class GetRectangleOptions : public EnhancementOption
Remarks

An instance of this class can be placed in the Enhancements to be processed in a sequence of enhancements.

If the specified area extends beyond the boundaries of the original image, either pixels of the PadColor will be added or an error will occur depending upon the value of the AllowPadding property.

Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.GetRectangleOptions

See Also

Reference

GetRectangleOptions Members
Accusoft.ScanFixXpressSdk Namespace


GetRectangleOptions Class Members

Accusoft.ScanFixXpress8.Net
GetRectangleOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : GetRectangleOptions Class

The following tables list the members exposed by GetRectangleOptions.

Public Constructors
 | Name | Description
Public Constructor | GetRectangleOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AllowPadding | Gets and sets a flag indicating whether padding or an exception occurs if the 'area' is outside of the image bounds.
Public Property | Area | Gets and sets the rectangular area to extract from the original image.
Public Property | PadColor | Gets and sets the color used for new pixels if necessary.
Top
See Also

Reference

GetRectangleOptions Class
Accusoft.ScanFixXpressSdk Namespace


GetRectangleOptions Class Properties

Accusoft.ScanFixXpress8.Net
GetRectangleOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : GetRectangleOptions Class

For a list of all members of this type, see GetRectangleOptions members.

Public Properties
 | Name | Description
Public Property | AllowPadding | Gets and sets a flag indicating whether padding or an exception occurs if the 'area' is outside of the image bounds.
Public Property | Area | Gets and sets the rectangular area to extract from the original image.
Public Property | PadColor | Gets and sets the color used for new pixels if necessary.
Top
See Also

Reference

GetRectangleOptions Class
Accusoft.ScanFixXpressSdk Namespace


GetRectangleOptions Constructor

Accusoft.ScanFixXpress8.Net
GetRectangleOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > GetRectangleOptions Class : GetRectangleOptions Constructor
Overload List
Overload | Description
GetRectangleOptions Constructor() | Instantiates a new GetRectangleOptions object setting the default values.
GetRectangleOptions Constructor(Rectangle,Color,Boolean) | Instantiates a new GetRectangleOptions object setting the specified values.
See Also

Reference

GetRectangleOptions Class
GetRectangleOptions Members


GetRectangleOptions Constructor()

Accusoft.ScanFixXpress8.Net
GetRectangleOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > GetRectangleOptions Class > GetRectangleOptions Constructor : GetRectangleOptions Constructor()
Instantiates a new GetRectangleOptions object setting the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New()
'Usage

Dim instance As New GetRectangleOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public GetRectangleOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: GetRectangleOptions();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
GetRectangleOptions();
See Also

Reference

GetRectangleOptions Class
GetRectangleOptions Members
Overload List


GetRectangleOptions Constructor(Rectangle,Color,Boolean)

Accusoft.ScanFixXpress8.Net
GetRectangleOptions Constructor(Rectangle,Color,Boolean)

Accusoft.ScanFixXpressSdk Namespace > GetRectangleOptions Class > GetRectangleOptions Constructor : GetRectangleOptions Constructor(Rectangle,Color,Boolean)
The area to extract from the original image.
The color used for new pixels if necessary.
Flag indicating whether padding or an error occurs if the 'area' is outside of the image bounds.
Instantiates a new GetRectangleOptions object setting the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal area As Rectangle, _
   ByVal padColor As Color, _
   ByVal allowPadding As Boolean _
)
'Usage

Dim area As Rectangle
Dim padColor As Color
Dim allowPadding As Boolean

Dim instance As New GetRectangleOptions(area, padColor, allowPadding)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public GetRectangleOptions(
   Rectangle area,
   Color padColor,
   bool allowPadding
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: GetRectangleOptions(
   Rectangle area,
   Color padColor,
   bool allowPadding
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
GetRectangleOptions(
   Rectangle area,
   Color padColor,
   bool allowPadding
)

Parameters

area
The area to extract from the original image.
padColor
The color used for new pixels if necessary.
allowPadding
Flag indicating whether padding or an error occurs if the 'area' is outside of the image bounds.
See Also

Reference

GetRectangleOptions Class
GetRectangleOptions Members
Overload List


AllowPadding Property

Accusoft.ScanFixXpress8.Net
AllowPadding Property

Accusoft.ScanFixXpressSdk Namespace > GetRectangleOptions Class : AllowPadding Property
Gets and sets a flag indicating whether padding or an exception occurs if the 'area' is outside of the image bounds.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowPadding As Boolean
'Usage

Dim instance As GetRectangleOptions
Dim value As Boolean

instance.AllowPadding = value

value = instance.AllowPadding
public bool AllowPadding {get; set;}
public: __property bool get_AllowPadding();
public: __property void set_AllowPadding(
   bool value
);
public:
property bool AllowPadding {
   bool get();
   void set (    bool value);
}
Remarks

The default value is true.

"true" indicates that the image should be padded (using PadColor) if the requested area is outside the original image bounds.

"false" indicates an exception occurs if the requested area is outside the original image bounds.

See Also

Reference

GetRectangleOptions Class
GetRectangleOptions Members


Area Property (GetRectangleOptions)

Accusoft.ScanFixXpress8.Net
Area Property (GetRectangleOptions)

Accusoft.ScanFixXpressSdk Namespace > GetRectangleOptions Class : Area Property
Gets and sets the rectangular area to extract from the original image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Area As Rectangle
'Usage

Dim instance As GetRectangleOptions
Dim value As Rectangle

instance.Area = value

value = instance.Area
public Rectangle Area {get; set;}
public: __property Rectangle get_Area();
public: __property void set_Area(
   Rectangle value
);
public:
property Rectangle Area {
   Rectangle get();
   void set (    Rectangle value);
}
Remarks

The default value is 0, 0, 0, 0.

See Also

Reference

GetRectangleOptions Class
GetRectangleOptions Members


PadColor Property (GetRectangleOptions)

Accusoft.ScanFixXpress8.Net
PadColor Property (GetRectangleOptions)

Accusoft.ScanFixXpressSdk Namespace > GetRectangleOptions Class : PadColor Property
Gets and sets the color used for new pixels if necessary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PadColor As Color
'Usage

Dim instance As GetRectangleOptions
Dim value As Color

instance.PadColor = value

value = instance.PadColor
public Color PadColor {get; set;}
public: __property Color get_PadColor();
public: __property void set_PadColor(
   Color value
);
public:
property Color PadColor {
   Color get();
   void set (    Color value);
}
Remarks

The default value is White.

See Also

Reference

GetRectangleOptions Class
GetRectangleOptions Members


GetRectangleResults Class

Accusoft.ScanFixXpress8.Net
GetRectangleResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : GetRectangleResults Class
Defines a place holder class for the GetRectangle enhancement result.
Object Model
GetRectangleResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class GetRectangleResults
   Inherits EnhancementResult
'Usage

Dim instance As GetRectangleResults
public class GetRectangleResults : EnhancementResult
public __gc class GetRectangleResults : public EnhancementResult
public ref class GetRectangleResults : public EnhancementResult
Remarks
This class contains no data. Its presence in the results list is used to determine that the operation has run successfully.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.GetRectangleResults

See Also

Reference

GetRectangleResults Members
Accusoft.ScanFixXpressSdk Namespace


GetRectangleResults Class Members

Accusoft.ScanFixXpress8.Net
GetRectangleResults Class Members

Accusoft.ScanFixXpressSdk Namespace : GetRectangleResults Class

The following tables list the members exposed by GetRectangleResults.

See Also

Reference

GetRectangleResults Class
Accusoft.ScanFixXpressSdk Namespace


GraphicLine Class

Accusoft.ScanFixXpress8.Net
GraphicLine Class
Members

Accusoft.ScanFixXpressSdk Namespace : GraphicLine Class
Contains graphic line detection data along with line information such as start and end points, line style, width, and line orientation.
Object Model
GraphicLine Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class GraphicLine
'Usage

Dim instance As GraphicLine
public class GraphicLine
public __gc class GraphicLine
public ref class GraphicLine
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.GraphicLine

See Also

Reference

GraphicLine Members
Accusoft.ScanFixXpressSdk Namespace


GraphicLine Class Members

Accusoft.ScanFixXpress8.Net
GraphicLine Class Members
Properties Methods

Accusoft.ScanFixXpressSdk Namespace : GraphicLine Class

The following tables list the members exposed by GraphicLine.

Public Properties
 | Name | Description
Public Property | End | Represents the end point of the line.
Public Property | IsDashed | Boolean will be set to true if the detected line is a dashed line. If false, the line is solid.
Public Property | Start | Represents the start point of the line.
Public Property | Width | Represents the average width of the line.
Top
Public Methods
 | Name | Description
Public Method | ToString |
Top
See Also

Reference

GraphicLine Class
Accusoft.ScanFixXpressSdk Namespace


GraphicLine Class Properties

Accusoft.ScanFixXpress8.Net
GraphicLine Class Properties

Accusoft.ScanFixXpressSdk Namespace : GraphicLine Class

For a list of all members of this type, see GraphicLine members.

Public Properties
 | Name | Description
Public Property | End | Represents the end point of the line.
Public Property | IsDashed | Boolean will be set to true if the detected line is a dashed line. If false, the line is solid.
Public Property | Start | Represents the start point of the line.
Public Property | Width | Represents the average width of the line.
Top
See Also

Reference

GraphicLine Class
Accusoft.ScanFixXpressSdk Namespace


GraphicLine Class Methods

Accusoft.ScanFixXpress8.Net
GraphicLine Class Methods

Accusoft.ScanFixXpressSdk Namespace : GraphicLine Class

For a list of all members of this type, see GraphicLine members.

Public Methods
 | Name | Description
Public Method | ToString |
Top
See Also

Reference

GraphicLine Class
Accusoft.ScanFixXpressSdk Namespace


ToString Method

Accusoft.ScanFixXpress8.Net
ToString Method

Accusoft.ScanFixXpressSdk Namespace > GraphicLine Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overrides Function ToString() As String
'Usage

Dim instance As GraphicLine
Dim value As String

value = instance.ToString()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public override string ToString()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: string* ToString(); override
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
String^ ToString(); override
See Also

Reference

GraphicLine Class
GraphicLine Members


End Property

Accusoft.ScanFixXpress8.Net
End Property

Accusoft.ScanFixXpressSdk Namespace > GraphicLine Class : End Property
Represents the end point of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property End As Point
'Usage

Dim instance As GraphicLine
Dim value As Point

instance.End = value

value = instance.End
public Point End {get; set;}
public: __property Point get_End();
public: __property void set_End(
   Point value
);
public:
property Point End {
   Point get();
   void set (    Point value);
}
See Also

Reference

GraphicLine Class
GraphicLine Members


IsDashed Property

Accusoft.ScanFixXpress8.Net
IsDashed Property

Accusoft.ScanFixXpressSdk Namespace > GraphicLine Class : IsDashed Property
Boolean will be set to true if the detected line is a dashed line. If false, the line is solid.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsDashed As Boolean
'Usage

Dim instance As GraphicLine
Dim value As Boolean

instance.IsDashed = value

value = instance.IsDashed
public bool IsDashed {get; set;}
public: __property bool get_IsDashed();
public: __property void set_IsDashed(
   bool value
);
public:
property bool IsDashed {
   bool get();
   void set (    bool value);
}
See Also

Reference

GraphicLine Class
GraphicLine Members


Start Property

Accusoft.ScanFixXpress8.Net
Start Property

Accusoft.ScanFixXpressSdk Namespace > GraphicLine Class : Start Property
Represents the start point of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Start As Point
'Usage

Dim instance As GraphicLine
Dim value As Point

instance.Start = value

value = instance.Start
public Point Start {get; set;}
public: __property Point get_Start();
public: __property void set_Start(
   Point value
);
public:
property Point Start {
   Point get();
   void set (    Point value);
}
See Also

Reference

GraphicLine Class
GraphicLine Members


Width Property (GraphicLine)

Accusoft.ScanFixXpress8.Net
Width Property (GraphicLine)

Accusoft.ScanFixXpressSdk Namespace > GraphicLine Class : Width Property
Represents the average width of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Double
'Usage

Dim instance As GraphicLine
Dim value As Double

instance.Width = value

value = instance.Width
public double Width {get; set;}
public: __property double get_Width();
public: __property void set_Width(
   double value
);
public:
property double Width {
   double get();
   void set (    double value);
}
See Also

Reference

GraphicLine Class
GraphicLine Members


GraphicLineDetectionOptions Class

Accusoft.ScanFixXpress8.Net
GraphicLineDetectionOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : GraphicLineDetectionOptions Class
Contains parameters that control the ScanFix.DetectGraphicLines process.
Object Model
GraphicLineDetectionOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class GraphicLineDetectionOptions
   Inherits EnhancementOption
'Usage

Dim instance As GraphicLineDetectionOptions
public class GraphicLineDetectionOptions : EnhancementOption
public __gc class GraphicLineDetectionOptions : public EnhancementOption
public ref class GraphicLineDetectionOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.GraphicLineDetectionOptions

See Also

Reference

GraphicLineDetectionOptions Members
Accusoft.ScanFixXpressSdk Namespace


GraphicLineDetectionOptions Class Members

Accusoft.ScanFixXpress8.Net
GraphicLineDetectionOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : GraphicLineDetectionOptions Class

The following tables list the members exposed by GraphicLineDetectionOptions.

Public Constructors
 | Name | Description
Public Constructor | GraphicLineDetectionOptions Constructor | Instantiates a new GraphicLineDetectionOptions object setting the default values.
Top
Public Properties
 | Name | Description
Public Property | DetectCombs | Gets and sets a boolean value whether combs are detected.
Public Property | DetectDashedLines | Gets and sets whether dashed lines are detected.
Public Property | GraphicLineOrientation | Gets and sets the orientation of lines you wish to search for.
Public Property | RegionOfInterest | Gets and sets the area on the image to search for lines.
Top
See Also

Reference

GraphicLineDetectionOptions Class
Accusoft.ScanFixXpressSdk Namespace


GraphicLineDetectionOptions Class Properties

Accusoft.ScanFixXpress8.Net
GraphicLineDetectionOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : GraphicLineDetectionOptions Class

For a list of all members of this type, see GraphicLineDetectionOptions members.

Public Properties
 | Name | Description
Public Property | DetectCombs | Gets and sets a boolean value whether combs are detected.
Public Property | DetectDashedLines | Gets and sets whether dashed lines are detected.
Public Property | GraphicLineOrientation | Gets and sets the orientation of lines you wish to search for.
Public Property | RegionOfInterest | Gets and sets the area on the image to search for lines.
Top
See Also

Reference

GraphicLineDetectionOptions Class
Accusoft.ScanFixXpressSdk Namespace


GraphicLineDetectionOptions Constructor

Accusoft.ScanFixXpress8.Net
GraphicLineDetectionOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > GraphicLineDetectionOptions Class : GraphicLineDetectionOptions Constructor
Instantiates a new GraphicLineDetectionOptions object setting the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New GraphicLineDetectionOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public GraphicLineDetectionOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: GraphicLineDetectionOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
GraphicLineDetectionOptions();
Remarks
DetectCombs defaults to True. DetectDashedLines defaults to True. GraphicLineOrientation defaults to Any.
See Also

Reference

GraphicLineDetectionOptions Class
GraphicLineDetectionOptions Members


DetectCombs Property

Accusoft.ScanFixXpress8.Net
DetectCombs Property

Accusoft.ScanFixXpressSdk Namespace > GraphicLineDetectionOptions Class : DetectCombs Property
Gets and sets a boolean value whether combs are detected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DetectCombs As Boolean
'Usage

Dim instance As GraphicLineDetectionOptions
Dim value As Boolean

instance.DetectCombs = value

value = instance.DetectCombs
public bool DetectCombs {get; set;}
public: __property bool get_DetectCombs();
public: __property void set_DetectCombs(
   bool value
);
public:
property bool DetectCombs {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which indicates whether combs will be detected in the image.
Remarks
The default value is false. Set this to true if you wish to have combs returned in the results list.
See Also

Reference

GraphicLineDetectionOptions Class
GraphicLineDetectionOptions Members


DetectDashedLines Property

Accusoft.ScanFixXpress8.Net
DetectDashedLines Property

Accusoft.ScanFixXpressSdk Namespace > GraphicLineDetectionOptions Class : DetectDashedLines Property
Gets and sets whether dashed lines are detected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DetectDashedLines As Boolean
'Usage

Dim instance As GraphicLineDetectionOptions
Dim value As Boolean

instance.DetectDashedLines = value

value = instance.DetectDashedLines
public bool DetectDashedLines {get; set;}
public: __property bool get_DetectDashedLines();
public: __property void set_DetectDashedLines(
   bool value
);
public:
property bool DetectDashedLines {
   bool get();
   void set (    bool value);
}

Property Value

An boolean value which indicates the current value of dashed line detection.
Remarks
The default value is false. Set this to true if you wish to have dashed lines returned.
See Also

Reference

GraphicLineDetectionOptions Class
GraphicLineDetectionOptions Members


GraphicLineOrientation Property

Accusoft.ScanFixXpress8.Net
GraphicLineOrientation Property

Accusoft.ScanFixXpressSdk Namespace > GraphicLineDetectionOptions Class : GraphicLineOrientation Property
Gets and sets the orientation of lines you wish to search for.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GraphicLineOrientation As GraphicLineOrientation
'Usage

Dim instance As GraphicLineDetectionOptions
Dim value As GraphicLineOrientation

instance.GraphicLineOrientation = value

value = instance.GraphicLineOrientation
public GraphicLineOrientation GraphicLineOrientation {get; set;}
public: __property GraphicLineOrientation get_GraphicLineOrientation();
public: __property void set_GraphicLineOrientation(
   GraphicLineOrientation value
);
public:
property GraphicLineOrientation GraphicLineOrientation {
   GraphicLineOrientation get();
   void set (    GraphicLineOrientation value);
}

Property Value

A GraphicLineOrientation which indicates the current oriention of lines being detected.
Remarks
The default value is Any. Valid values are determined by the GraphicLineOrientation enumeration.
See Also

Reference

GraphicLineDetectionOptions Class
GraphicLineDetectionOptions Members


RegionOfInterest Property

Accusoft.ScanFixXpress8.Net
RegionOfInterest Property

Accusoft.ScanFixXpressSdk Namespace > GraphicLineDetectionOptions Class : RegionOfInterest Property
Gets and sets the area on the image to search for lines.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RegionOfInterest As Rectangle
'Usage

Dim instance As GraphicLineDetectionOptions
Dim value As Rectangle

instance.RegionOfInterest = value

value = instance.RegionOfInterest
public Rectangle RegionOfInterest {get; set;}
public: __property Rectangle get_RegionOfInterest();
public: __property void set_RegionOfInterest(
   Rectangle value
);
public:
property Rectangle RegionOfInterest {
   Rectangle get();
   void set (    Rectangle value);
}

Property Value

A Rectangle object which indicates the current region of interest of the image.
Remarks
Use this when you wish to specify a region on the image to look at. If you want to search the entire image, do not set this.
See Also

Reference

GraphicLineDetectionOptions Class
GraphicLineDetectionOptions Members


GraphicLineDetectionResults Class

Accusoft.ScanFixXpress8.Net
GraphicLineDetectionResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : GraphicLineDetectionResults Class
Contains output values from the ScanFix.DetectGraphicLines method.
Object Model
GraphicLineDetectionResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class GraphicLineDetectionResults
   Inherits EnhancementResult
'Usage

Dim instance As GraphicLineDetectionResults
public class GraphicLineDetectionResults : EnhancementResult
public __gc class GraphicLineDetectionResults : public EnhancementResult
public ref class GraphicLineDetectionResults : public EnhancementResult
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.GraphicLineDetectionResults

See Also

Reference

GraphicLineDetectionResults Members
Accusoft.ScanFixXpressSdk Namespace


GraphicLineDetectionResults Class Members

Accusoft.ScanFixXpress8.Net
GraphicLineDetectionResults Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : GraphicLineDetectionResults Class

The following tables list the members exposed by GraphicLineDetectionResults.

Public Properties
 | Name | Description
Public Property | GraphicLines | A read-only property that gets a list of GraphicLine objects returned by the ScanFix.DetectGraphicLines method.
Top
See Also

Reference

GraphicLineDetectionResults Class
Accusoft.ScanFixXpressSdk Namespace


GraphicLineDetectionResults Class Properties

Accusoft.ScanFixXpress8.Net
GraphicLineDetectionResults Class Properties

Accusoft.ScanFixXpressSdk Namespace : GraphicLineDetectionResults Class

For a list of all members of this type, see GraphicLineDetectionResults members.

Public Properties
 | Name | Description
Public Property | GraphicLines | A read-only property that gets a list of GraphicLine objects returned by the ScanFix.DetectGraphicLines method.
Top
See Also

Reference

GraphicLineDetectionResults Class
Accusoft.ScanFixXpressSdk Namespace


GraphicLines Property (GraphicLineDetectionResults)

Accusoft.ScanFixXpress8.Net
GraphicLines Property (GraphicLineDetectionResults)

Accusoft.ScanFixXpressSdk Namespace > GraphicLineDetectionResults Class : GraphicLines Property
A read-only property that gets a list of GraphicLine objects returned by the ScanFix.DetectGraphicLines method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property GraphicLines As List(Of GraphicLine)
'Usage

Dim instance As GraphicLineDetectionResults
Dim value As List(Of GraphicLine)

value = instance.GraphicLines
public List<GraphicLine> GraphicLines {get;}
public: __property List<GraphicLine*>* get_GraphicLines();
public:
property List<GraphicLine^>^ GraphicLines {
   List<GraphicLine^>^ get();
}
See Also

Reference

GraphicLineDetectionResults Class
GraphicLineDetectionResults Members


GraphicLineRemovalOptions Class

Accusoft.ScanFixXpress8.Net
GraphicLineRemovalOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : GraphicLineRemovalOptions Class
Contains parameters for the ScanFix.RemoveGraphicLines process.
Object Model
GraphicLineRemovalOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class GraphicLineRemovalOptions
   Inherits EnhancementOption
'Usage

Dim instance As GraphicLineRemovalOptions
public class GraphicLineRemovalOptions : EnhancementOption
public __gc class GraphicLineRemovalOptions : public EnhancementOption
public ref class GraphicLineRemovalOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.GraphicLineRemovalOptions

See Also

Reference

GraphicLineRemovalOptions Members
Accusoft.ScanFixXpressSdk Namespace


GraphicLineRemovalOptions Class Members

Accusoft.ScanFixXpress8.Net
GraphicLineRemovalOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : GraphicLineRemovalOptions Class

The following tables list the members exposed by GraphicLineRemovalOptions.

Public Constructors
 | Name | Description
Public Constructor | GraphicLineRemovalOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | GraphicLines | Gets the list of graphic lines that are to be removed from the image.
Top
See Also

Reference

GraphicLineRemovalOptions Class
Accusoft.ScanFixXpressSdk Namespace


GraphicLineRemovalOptions Class Properties

Accusoft.ScanFixXpress8.Net
GraphicLineRemovalOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : GraphicLineRemovalOptions Class

For a list of all members of this type, see GraphicLineRemovalOptions members.

Public Properties
 | Name | Description
Public Property | GraphicLines | Gets the list of graphic lines that are to be removed from the image.
Top
See Also

Reference

GraphicLineRemovalOptions Class
Accusoft.ScanFixXpressSdk Namespace


GraphicLineRemovalOptions Constructor

Accusoft.ScanFixXpress8.Net
GraphicLineRemovalOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > GraphicLineRemovalOptions Class : GraphicLineRemovalOptions Constructor
Overload List
Overload | Description
GraphicLineRemovalOptions Constructor(List<GraphicLine>) | Instantiates a new GraphicLineRemovalOptions object setting the specified list of lines.
GraphicLineRemovalOptions Constructor() | Instantiates a new GraphicLineRemovalOptions object.
See Also

Reference

GraphicLineRemovalOptions Class
GraphicLineRemovalOptions Members


GraphicLineRemovalOptions Constructor(List<GraphicLine>)

Accusoft.ScanFixXpress8.Net
GraphicLineRemovalOptions Constructor(List<GraphicLine>)

Accusoft.ScanFixXpressSdk Namespace > GraphicLineRemovalOptions Class > GraphicLineRemovalOptions Constructor : GraphicLineRemovalOptions Constructor(List<GraphicLine>)
A list of GraphicLine objects obtained from the ScanFix.DetectGraphicLines method.
Instantiates a new GraphicLineRemovalOptions object setting the specified list of lines.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New( _
   ByVal graphicLines As List(Of GraphicLine) _
)
'Usage

Dim graphicLines As List(Of GraphicLine)

Dim instance As New GraphicLineRemovalOptions(graphicLines)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public GraphicLineRemovalOptions(
   List<GraphicLine> graphicLines
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: GraphicLineRemovalOptions(
   List<GraphicLine*>* graphicLines
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
GraphicLineRemovalOptions(
   List<GraphicLine^>^ graphicLines
)

Parameters

graphicLines
A list of GraphicLine objects obtained from the ScanFix.DetectGraphicLines method.
Remarks
You must use the results from the DetectGraphicLines method to specify the lines that will be removed. Lines that you do not wish to remove can be deleted from the list. Lines cannot be added to the list.
See Also

Reference

GraphicLineRemovalOptions Class
GraphicLineRemovalOptions Members
Overload List


GraphicLineRemovalOptions Constructor()

Accusoft.ScanFixXpress8.Net
GraphicLineRemovalOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > GraphicLineRemovalOptions Class > GraphicLineRemovalOptions Constructor : GraphicLineRemovalOptions Constructor()
Instantiates a new GraphicLineRemovalOptions object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New()
'Usage

Dim instance As New GraphicLineRemovalOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public GraphicLineRemovalOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: GraphicLineRemovalOptions();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
GraphicLineRemovalOptions();
Remarks
This constructor creates a new empty GraphicLineRemovalOptions. The GraphicLines property must be set before calling ScanFix.RemoveGraphicLines in order to set which lines will be removed. If this is not set, then no lines will be removed.
See Also

Reference

GraphicLineRemovalOptions Class
GraphicLineRemovalOptions Members
Overload List


GraphicLines Property (GraphicLineRemovalOptions)

Accusoft.ScanFixXpress8.Net
GraphicLines Property (GraphicLineRemovalOptions)

Accusoft.ScanFixXpressSdk Namespace > GraphicLineRemovalOptions Class : GraphicLines Property
Gets the list of graphic lines that are to be removed from the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property GraphicLines As List(Of GraphicLine)
'Usage

Dim instance As GraphicLineRemovalOptions
Dim value As List(Of GraphicLine)

value = instance.GraphicLines
public List<GraphicLine> GraphicLines {get;}
public: __property List<GraphicLine*>* get_GraphicLines();
public:
property List<GraphicLine^>^ GraphicLines {
   List<GraphicLine^>^ get();
}
See Also

Reference

GraphicLineRemovalOptions Class
GraphicLineRemovalOptions Members


GraphicLineRemovalResults Class

Accusoft.ScanFixXpress8.Net
GraphicLineRemovalResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : GraphicLineRemovalResults Class
Contains output values from the ScanFix.RemoveGraphicLines method.
Object Model
GraphicLineRemovalResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class GraphicLineRemovalResults
   Inherits EnhancementResult
'Usage

Dim instance As GraphicLineRemovalResults
public class GraphicLineRemovalResults : EnhancementResult
public __gc class GraphicLineRemovalResults : public EnhancementResult
public ref class GraphicLineRemovalResults : public EnhancementResult
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.GraphicLineRemovalResults

See Also

Reference

GraphicLineRemovalResults Members
Accusoft.ScanFixXpressSdk Namespace


GraphicLineRemovalResults Class Members

Accusoft.ScanFixXpress8.Net
GraphicLineRemovalResults Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : GraphicLineRemovalResults Class

The following tables list the members exposed by GraphicLineRemovalResults.

Public Properties
 | Name | Description
Public Property | CountOfLinesRemoved | Gets the actual count of the lines that were removed from the image.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified to remove lines.
Top
See Also

Reference

GraphicLineRemovalResults Class
Accusoft.ScanFixXpressSdk Namespace


GraphicLineRemovalResults Class Properties

Accusoft.ScanFixXpress8.Net
GraphicLineRemovalResults Class Properties

Accusoft.ScanFixXpressSdk Namespace : GraphicLineRemovalResults Class

For a list of all members of this type, see GraphicLineRemovalResults members.

Public Properties
 | Name | Description
Public Property | CountOfLinesRemoved | Gets the actual count of the lines that were removed from the image.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified to remove lines.
Top
See Also

Reference

GraphicLineRemovalResults Class
Accusoft.ScanFixXpressSdk Namespace


CountOfLinesRemoved Property

Accusoft.ScanFixXpress8.Net
CountOfLinesRemoved Property

Accusoft.ScanFixXpressSdk Namespace > GraphicLineRemovalResults Class : CountOfLinesRemoved Property
Gets the actual count of the lines that were removed from the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CountOfLinesRemoved As Integer
'Usage

Dim instance As GraphicLineRemovalResults
Dim value As Integer

value = instance.CountOfLinesRemoved
public int CountOfLinesRemoved {get;}
public: __property int get_CountOfLinesRemoved();
public:
property int CountOfLinesRemoved {
   int get();
}

Property Value

An integer value which indicates the number of lines removed.
Remarks
The number of lines removed from the image may not be equal to the number of lines in the Graphic Lines list.
See Also

Reference

GraphicLineRemovalResults Class
GraphicLineRemovalResults Members


ImageWasModified Property (GraphicLineRemovalResults)

Accusoft.ScanFixXpress8.Net
ImageWasModified Property (GraphicLineRemovalResults)

Accusoft.ScanFixXpressSdk Namespace > GraphicLineRemovalResults Class : ImageWasModified Property
Gets a flag that indicates whether the image was modified to remove lines.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageWasModified As Boolean
'Usage

Dim instance As GraphicLineRemovalResults
Dim value As Boolean

value = instance.ImageWasModified
public bool ImageWasModified {get;}
public: __property bool get_ImageWasModified();
public:
property bool ImageWasModified {
   bool get();
}

Property Value

A boolean value which is True if the image was modified. Otherwise, False is returned.
Remarks

The default value is True.

When the CountOfLinesRemoved property value is 0, this property will return False. The count of lines removed will only be 0 if there were not lines passed in to remove, or when there is an error removing the lines.

See Also

Reference

GraphicLineRemovalResults Class
GraphicLineRemovalResults Members


HueRadius Class

Accusoft.ScanFixXpress8.Net
HueRadius Class
Members

Accusoft.ScanFixXpressSdk Namespace : HueRadius Class
Lists a range of Hues used by VirtualBulb.
Object Model
HueRadius Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class HueRadius
'Usage

Dim instance As HueRadius
public class HueRadius
public __gc class HueRadius
public ref class HueRadius
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.HueRadius

See Also

Reference

HueRadius Members
Accusoft.ScanFixXpressSdk Namespace


HueRadius Class Members

Accusoft.ScanFixXpress8.Net
HueRadius Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : HueRadius Class

The following tables list the members exposed by HueRadius.

Public Constructors
 | Name | Description
Public Constructor | HueRadius Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Adaptive | Gets and sets flag for adaptive color determination based on image data.
Public Property | Brightness | Gets and sets flag for hue-specific brightness correction.
Public Property | Hue | Gets and sets hue value.
Public Property | Radius | Gets and sets size of region of effect around hue value in HSV colorspace.
Top
See Also

Reference

HueRadius Class
Accusoft.ScanFixXpressSdk Namespace


HueRadius Class Properties

Accusoft.ScanFixXpress8.Net
HueRadius Class Properties

Accusoft.ScanFixXpressSdk Namespace : HueRadius Class

For a list of all members of this type, see HueRadius members.

Public Properties
 | Name | Description
Public Property | Adaptive | Gets and sets flag for adaptive color determination based on image data.
Public Property | Brightness | Gets and sets flag for hue-specific brightness correction.
Public Property | Hue | Gets and sets hue value.
Public Property | Radius | Gets and sets size of region of effect around hue value in HSV colorspace.
Top
See Also

Reference

HueRadius Class
Accusoft.ScanFixXpressSdk Namespace


HueRadius Constructor

Accusoft.ScanFixXpress8.Net
HueRadius Constructor

Accusoft.ScanFixXpressSdk Namespace > HueRadius Class : HueRadius Constructor
Overload List
Overload | Description
HueRadius Constructor() | Instantiates a default HueRadius object.
HueRadius Constructor(Byte,Int32,Boolean,Boolean) | Instantiates a HueRadius object with the specified values.
See Also

Reference

HueRadius Class
HueRadius Members


HueRadius Constructor()

Accusoft.ScanFixXpress8.Net
HueRadius Constructor()

Accusoft.ScanFixXpressSdk Namespace > HueRadius Class > HueRadius Constructor : HueRadius Constructor()
Instantiates a default HueRadius object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New HueRadius()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public HueRadius()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: HueRadius();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
HueRadius();
See Also

Reference

HueRadius Class
HueRadius Members
Overload List


HueRadius Constructor(Byte,Int32,Boolean,Boolean)

Accusoft.ScanFixXpress8.Net
HueRadius Constructor(Byte,Int32,Boolean,Boolean)

Accusoft.ScanFixXpressSdk Namespace > HueRadius Class > HueRadius Constructor : HueRadius Constructor(Byte,Int32,Boolean,Boolean)
Hue value in HSV color space.
Radius in HSV color space.
Indicates whether to use adaptive color determination based on image data.
Indicates whether to apply brightness enhancement for this hue.
Instantiates a HueRadius object with the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal hue As Byte, _
   ByVal radius As Integer, _
   ByVal adaptive As Boolean, _
   ByVal brightness As Boolean _
)
'Usage

Dim hue As Byte
Dim radius As Integer
Dim adaptive As Boolean
Dim brightness As Boolean

Dim instance As New HueRadius(hue, radius, adaptive, brightness)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public HueRadius(
   byte hue,
   int radius,
   bool adaptive,
   bool brightness
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: HueRadius(
   byte hue,
   int radius,
   bool adaptive,
   bool brightness
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
HueRadius(
   byte hue,
   int radius,
   bool adaptive,
   bool brightness
)

Parameters

hue
Hue value in HSV color space.
radius
Radius in HSV color space.
adaptive
Indicates whether to use adaptive color determination based on image data.
brightness
Indicates whether to apply brightness enhancement for this hue.
See Also

Reference

HueRadius Class
HueRadius Members
Overload List


Adaptive Property (HueRadius)

Accusoft.ScanFixXpress8.Net
Adaptive Property (HueRadius)

Accusoft.ScanFixXpressSdk Namespace > HueRadius Class : Adaptive Property
Gets and sets flag for adaptive color determination based on image data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Adaptive As Boolean
'Usage

Dim instance As HueRadius
Dim value As Boolean

instance.Adaptive = value

value = instance.Adaptive
public bool Adaptive {get; set;}
public: __property bool get_Adaptive();
public: __property void set_Adaptive(
   bool value
);
public:
property bool Adaptive {
   bool get();
   void set (    bool value);
}
Remarks

The default value is false.

Setting this flag instructs the algorithm to analyze the image and change the value of the hue up to 21 in either direction (1/12 of the spectrum) to match the nearest peak in the hue histogram of the image. This is the most useful with narrow drop widths, where a slightly off-center hue can leave an undesirable amout of data on the image.

Use of this adaptive feature is slower, however, as it requires analysis of each individual image before processing to find the approximate peak. A larger radius, if it can safely be used, will provide better performance.

See Also

Reference

HueRadius Class
HueRadius Members


Brightness Property

Accusoft.ScanFixXpress8.Net
Brightness Property

Accusoft.ScanFixXpressSdk Namespace > HueRadius Class : Brightness Property
Gets and sets flag for hue-specific brightness correction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Brightness As Boolean
'Usage

Dim instance As HueRadius
Dim value As Boolean

instance.Brightness = value

value = instance.Brightness
public bool Brightness {get; set;}
public: __property bool get_Brightness();
public: __property void set_Brightness(
   bool value
);
public:
property bool Brightness {
   bool get();
   void set (    bool value);
}
Remarks

The default value is false.

This option attempts to determine the average level of brightness of the given hue and will adjust the brightness level of all pixels with that hue so that the virtual bulb operation will convert those pixels to pure white. This operation should only be used on images with a white, or nearly white, background.

Use this operation if there are "shadows" of the dropped color left in the output image.

An exception will be thrown if you attempt to set this HueRadius option with the VirtualBulbOptions.Extract option set to true.

See Also

Reference

HueRadius Class
HueRadius Members


Hue Property

Accusoft.ScanFixXpress8.Net
Hue Property

Accusoft.ScanFixXpressSdk Namespace > HueRadius Class : Hue Property
Gets and sets hue value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Hue As Byte
'Usage

Dim instance As HueRadius
Dim value As Byte

instance.Hue = value

value = instance.Hue
public byte Hue {get; set;}
public: __property byte get_Hue();
public: __property void set_Hue(
   byte value
);
public:
property byte Hue {
   byte get();
   void set (    byte value);
}
Remarks

The default value is 0 which is the hue value for Red.

Valid values are 0 to 255.

Zero (0) indicates pure red, 85 indicates pure green, 172 indicates pure blue and 255 returns back to pure red.

See Also

Reference

HueRadius Class
HueRadius Members


Radius Property (HueRadius)

Accusoft.ScanFixXpress8.Net
Radius Property (HueRadius)

Accusoft.ScanFixXpressSdk Namespace > HueRadius Class : Radius Property
Gets and sets size of region of effect around hue value in HSV colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Radius As Integer
'Usage

Dim instance As HueRadius
Dim value As Integer

instance.Radius = value

value = instance.Radius
public int Radius {get; set;}
public: __property int get_Radius();
public: __property void set_Radius(
   int value
);
public:
property int Radius {
   int get();
   void set (    int value);
}
Remarks

The default value is 170.

Valid values are 0 to 884.

The radius used is non-linear. A Radius of approximately 172 corresponds to 2/3 of the spectrum and will emulate the same range of dropout that a color scanner would generate. Larger values will drop a greater range of color, while smaller values will drop a narrower range of color.

Colors in the inner half of the radius will drop fully to white while colors in the outer half radius will shade to black.

See Also

Reference

HueRadius Class
HueRadius Members


ImageDetergentOptions Class

Accusoft.ScanFixXpress8.Net
ImageDetergentOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : ImageDetergentOptions Class
Contains parameters that control the ScanFix.ImageDetergent process.
Object Model
ImageDetergentOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImageDetergentOptions
   Inherits EnhancementOption
'Usage

Dim instance As ImageDetergentOptions
public class ImageDetergentOptions : EnhancementOption
public __gc class ImageDetergentOptions : public EnhancementOption
public ref class ImageDetergentOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.ImageDetergentOptions

See Also

Reference

ImageDetergentOptions Members
Accusoft.ScanFixXpressSdk Namespace


ImageDetergentOptions Class Members

Accusoft.ScanFixXpress8.Net
ImageDetergentOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : ImageDetergentOptions Class

The following tables list the members exposed by ImageDetergentOptions.

Public Constructors
 | Name | Description
Public Constructor | ImageDetergentOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ColorRadiusList | Gets ColorRadius list object that contains multiple ColorRadius objects that define all color regions to clean.
Top
See Also

Reference

ImageDetergentOptions Class
Accusoft.ScanFixXpressSdk Namespace


ImageDetergentOptions Class Properties

Accusoft.ScanFixXpress8.Net
ImageDetergentOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : ImageDetergentOptions Class

For a list of all members of this type, see ImageDetergentOptions members.

Public Properties
 | Name | Description
Public Property | ColorRadiusList | Gets ColorRadius list object that contains multiple ColorRadius objects that define all color regions to clean.
Top
See Also

Reference

ImageDetergentOptions Class
Accusoft.ScanFixXpressSdk Namespace


ImageDetergentOptions Constructor

Accusoft.ScanFixXpress8.Net
ImageDetergentOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > ImageDetergentOptions Class : ImageDetergentOptions Constructor
Overload List
Overload | Description
ImageDetergentOptions Constructor() | Instantiates a new ImageDetergentOptions object setting the default values.
ImageDetergentOptions Constructor(IEnumerable<ColorRadius>) | Instantiates a new ImageDetergentOptions object setting the specified values.
See Also

Reference

ImageDetergentOptions Class
ImageDetergentOptions Members


ImageDetergentOptions Constructor()

Accusoft.ScanFixXpress8.Net
ImageDetergentOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > ImageDetergentOptions Class > ImageDetergentOptions Constructor : ImageDetergentOptions Constructor()
Instantiates a new ImageDetergentOptions object setting the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New()
'Usage

Dim instance As New ImageDetergentOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public ImageDetergentOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: ImageDetergentOptions();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
ImageDetergentOptions();
See Also

Reference

ImageDetergentOptions Class
ImageDetergentOptions Members
Overload List


ImageDetergentOptions Constructor(IEnumerable<ColorRadius>)

Accusoft.ScanFixXpress8.Net
ImageDetergentOptions Constructor(IEnumerable<ColorRadius>)

Accusoft.ScanFixXpressSdk Namespace > ImageDetergentOptions Class > ImageDetergentOptions Constructor : ImageDetergentOptions Constructor(IEnumerable<ColorRadius>)
Color radius list object that holds multiple ColorRadius objects that define all color regions to clean
Instantiates a new ImageDetergentOptions object setting the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal colorRadiusList As IEnumerable(Of ColorRadius) _
)
'Usage

Dim colorRadiusList As IEnumerable(Of ColorRadius)

Dim instance As New ImageDetergentOptions(colorRadiusList)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public ImageDetergentOptions(
   IEnumerable<ColorRadius> colorRadiusList
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: ImageDetergentOptions(
   IEnumerable<ColorRadius*>* colorRadiusList
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
ImageDetergentOptions(
   IEnumerable<ColorRadius^>^ colorRadiusList
)

Parameters

colorRadiusList
Color radius list object that holds multiple ColorRadius objects that define all color regions to clean
See Also

Reference

ImageDetergentOptions Class
ImageDetergentOptions Members
Overload List


ColorRadiusList Property (ImageDetergentOptions)

Accusoft.ScanFixXpress8.Net
ColorRadiusList Property (ImageDetergentOptions)

Accusoft.ScanFixXpressSdk Namespace > ImageDetergentOptions Class : ColorRadiusList Property
Gets ColorRadius list object that contains multiple ColorRadius objects that define all color regions to clean.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ColorRadiusList As Collection(Of ColorRadius)
'Usage

Dim instance As ImageDetergentOptions
Dim value As Collection(Of ColorRadius)

value = instance.ColorRadiusList
public Collection<ColorRadius> ColorRadiusList {get;}
public: __property Collection<ColorRadius*>* get_ColorRadiusList();
public:
property Collection<ColorRadius^>^ ColorRadiusList {
   Collection<ColorRadius^>^ get();
}
See Also

Reference

ImageDetergentOptions Class
ImageDetergentOptions Members


ImageDetergentResults Class

Accusoft.ScanFixXpress8.Net
ImageDetergentResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : ImageDetergentResults Class
Defines a place holder class for the ImageDetergent enhancement result.
Object Model
ImageDetergentResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImageDetergentResults
   Inherits EnhancementResult
'Usage

Dim instance As ImageDetergentResults
public class ImageDetergentResults : EnhancementResult
public __gc class ImageDetergentResults : public EnhancementResult
public ref class ImageDetergentResults : public EnhancementResult
Remarks
This class contains no data. Its presence in the results list is used to determine that the operation has run successfully.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.ImageDetergentResults

See Also

Reference

ImageDetergentResults Members
Accusoft.ScanFixXpressSdk Namespace


ImageDetergentResults Class Members

Accusoft.ScanFixXpress8.Net
ImageDetergentResults Class Members

Accusoft.ScanFixXpressSdk Namespace : ImageDetergentResults Class

The following tables list the members exposed by ImageDetergentResults.

See Also

Reference

ImageDetergentResults Class
Accusoft.ScanFixXpressSdk Namespace


ImageRegistrationOptions Class

Accusoft.ScanFixXpress8.Net
ImageRegistrationOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : ImageRegistrationOptions Class
Contains parameters that control the ScanFix.RegisterImage process.
Object Model
ImageRegistrationOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImageRegistrationOptions
   Inherits EnhancementOption
'Usage

Dim instance As ImageRegistrationOptions
public class ImageRegistrationOptions : EnhancementOption
public __gc class ImageRegistrationOptions : public EnhancementOption
public ref class ImageRegistrationOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.ImageRegistrationOptions

See Also

Reference

ImageRegistrationOptions Members
Accusoft.ScanFixXpressSdk Namespace


ImageRegistrationOptions Class Members

Accusoft.ScanFixXpress8.Net
ImageRegistrationOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : ImageRegistrationOptions Class

The following tables list the members exposed by ImageRegistrationOptions.

Public Constructors
 | Name | Description
Public Constructor | ImageRegistrationOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | HorizontalActive | Gets and sets a flag that enables registration of the left edge of the text.
Public Property | HorizontalAddOnly | Gets and sets a flag that indicates whether any pixels will be removed during horizontal registration, even if the desired margin is smaller than the existing margin.
Public Property | HorizontalCentralFocus | Gets and sets a flag that indicates whether the middle portion of the image border will be used for registration, ignoring edge noise, letterheads, and logos.
Public Property | HorizontalIgnoreHoles | Gets and sets a flag that indicates whether binder holes and other left-edge noise are ignored during horizontal registration.
Public Property | HorizontalMinimumActivity | Gets and sets a value that controls how intense the activity has to be for it to be considered real activity.
Public Property | HorizontalMinimumBackground | Gets and sets a value that controls how dense and consistent image data should be for it to be considered edge noise.
Public Property | HorizontalMinimumForeground | Gets and sets a value that controls how much activity determines what is valid data.
Public Property | HorizontalResultantMargin | Gets and sets a value that indicates how many pixels will remain as a left margin after processing.
Public Property | HorizontalSkipActive | Gets and sets a flag that indicates whether a set number of scan lines will be skipped before the toolkit starts looking for valid information for registration.
Public Property | HorizontalSkipDistance | Gets and sets a value that indicates how many vertical scan lines will be skipped if HorizontalSkipActive is true, otherwise this value is ignored.
Public Property | HorizontalToLineActive | Gets and sets a flag that indicates whether the component will position the text in the image based on the position of a vertical line, or to what is determined to be the edge of the text.
Public Property | HorizontalToLineCheckThinLinesActive | Gets and sets a flag that indicates the vertical line to register to is very thin (1 or 2 pixels) when HorizontalToLineActive is true, otherwise this value is ignored.
Public Property | HorizontalToLineMaximumLineGap | Gets and sets a value that indicates the maximum allowable size (in pixels) of gaps within the vertical line to register to.
Public Property | HorizontalToLineMaximumLineThickness | Gets and sets a value that indicates the maximum allowable width (in pixels) of the vertical line to register to.
Public Property | HorizontalToLineMinimumLineLength | Gets and sets a value that indicates the minimum allowable length (in pixels) of the vertical line to register to.
Public Property | VerticalActive | Gets and sets a flag that enables registration of the top edge of the text.
Public Property | VerticalAddOnly | Gets and sets a flag that indicates whether any pixels will be removed during vertical registration, even if the desired margin is smaller than the existing margin.
Public Property | VerticalCentralFocus | Gets and sets a flag that indicates whether the middle portion of the image border will be used for registration, ignoring edge noise, letterheads, and logos.
Public Property | VerticalMinimumActivity | Gets and sets a value that controls how intense the activity has to be for it to be considered real activity.
Public Property | VerticalMinimumBackground | Gets and sets a value that controls how dense and consistent image data should be for it to be considered edge noise.
Public Property | VerticalMinimumForeground | Gets and sets a value that controls how much activity determines what is valid data.
Public Property | VerticalResultantMargin | Gets and sets a value that indicates how many pixels will remain as a top margin after processing.
Public Property | VerticalSkipActive | Gets and sets a flag that indicates whether a set number of scan lines will be skipped before the toolkit starts looking for valid information for registration.
Public Property | VerticalSkipDistance | Gets and sets a value that indicates how many horizontal scan lines will be skipped if VerticalSkipActive is true, otherwise this value is ignored.
Public Property | VerticalToLineActive | Gets and sets a flag that indicates whether the component will position the text in the image based on the position of a horizontal line, or to what is determined to be the edge of the text.
Public Property | VerticalToLineCheckThinLinesActive | Gets and sets a flag that indicates the horizontal line to register to is very thin (1 or 2 pixels) when VerticalToLineActive is true, otherwise this value is ignored.
Public Property | VerticalToLineMaximumLineGap | Gets and sets a value that indicates the maximum allowable size (in pixels) of gaps within the horizontal line to register to.
Public Property | VerticalToLineMaximumLineThickness | Gets and sets a value that indicates the maximum allowable width (in pixels) of the horizontal line to register to.
Public Property | VerticalToLineMinimumLineLength | Gets and sets a value that indicates the minimum allowable length (in pixels) of the horizontal line to register to.
Top
See Also

Reference

ImageRegistrationOptions Class
Accusoft.ScanFixXpressSdk Namespace


ImageRegistrationOptions Class Properties

Accusoft.ScanFixXpress8.Net
ImageRegistrationOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : ImageRegistrationOptions Class

For a list of all members of this type, see ImageRegistrationOptions members.

Public Properties
 | Name | Description
Public Property | HorizontalActive | Gets and sets a flag that enables registration of the left edge of the text.
Public Property | HorizontalAddOnly | Gets and sets a flag that indicates whether any pixels will be removed during horizontal registration, even if the desired margin is smaller than the existing margin.
Public Property | HorizontalCentralFocus | Gets and sets a flag that indicates whether the middle portion of the image border will be used for registration, ignoring edge noise, letterheads, and logos.
Public Property | HorizontalIgnoreHoles | Gets and sets a flag that indicates whether binder holes and other left-edge noise are ignored during horizontal registration.
Public Property | HorizontalMinimumActivity | Gets and sets a value that controls how intense the activity has to be for it to be considered real activity.
Public Property | HorizontalMinimumBackground | Gets and sets a value that controls how dense and consistent image data should be for it to be considered edge noise.
Public Property | HorizontalMinimumForeground | Gets and sets a value that controls how much activity determines what is valid data.
Public Property | HorizontalResultantMargin | Gets and sets a value that indicates how many pixels will remain as a left margin after processing.
Public Property | HorizontalSkipActive | Gets and sets a flag that indicates whether a set number of scan lines will be skipped before the toolkit starts looking for valid information for registration.
Public Property | HorizontalSkipDistance | Gets and sets a value that indicates how many vertical scan lines will be skipped if HorizontalSkipActive is true, otherwise this value is ignored.
Public Property | HorizontalToLineActive | Gets and sets a flag that indicates whether the component will position the text in the image based on the position of a vertical line, or to what is determined to be the edge of the text.
Public Property | HorizontalToLineCheckThinLinesActive | Gets and sets a flag that indicates the vertical line to register to is very thin (1 or 2 pixels) when HorizontalToLineActive is true, otherwise this value is ignored.
Public Property | HorizontalToLineMaximumLineGap | Gets and sets a value that indicates the maximum allowable size (in pixels) of gaps within the vertical line to register to.
Public Property | HorizontalToLineMaximumLineThickness | Gets and sets a value that indicates the maximum allowable width (in pixels) of the vertical line to register to.
Public Property | HorizontalToLineMinimumLineLength | Gets and sets a value that indicates the minimum allowable length (in pixels) of the vertical line to register to.
Public Property | VerticalActive | Gets and sets a flag that enables registration of the top edge of the text.
Public Property | VerticalAddOnly | Gets and sets a flag that indicates whether any pixels will be removed during vertical registration, even if the desired margin is smaller than the existing margin.
Public Property | VerticalCentralFocus | Gets and sets a flag that indicates whether the middle portion of the image border will be used for registration, ignoring edge noise, letterheads, and logos.
Public Property | VerticalMinimumActivity | Gets and sets a value that controls how intense the activity has to be for it to be considered real activity.
Public Property | VerticalMinimumBackground | Gets and sets a value that controls how dense and consistent image data should be for it to be considered edge noise.
Public Property | VerticalMinimumForeground | Gets and sets a value that controls how much activity determines what is valid data.
Public Property | VerticalResultantMargin | Gets and sets a value that indicates how many pixels will remain as a top margin after processing.
Public Property | VerticalSkipActive | Gets and sets a flag that indicates whether a set number of scan lines will be skipped before the toolkit starts looking for valid information for registration.
Public Property | VerticalSkipDistance | Gets and sets a value that indicates how many horizontal scan lines will be skipped if VerticalSkipActive is true, otherwise this value is ignored.
Public Property | VerticalToLineActive | Gets and sets a flag that indicates whether the component will position the text in the image based on the position of a horizontal line, or to what is determined to be the edge of the text.
Public Property | VerticalToLineCheckThinLinesActive | Gets and sets a flag that indicates the horizontal line to register to is very thin (1 or 2 pixels) when VerticalToLineActive is true, otherwise this value is ignored.
Public Property | VerticalToLineMaximumLineGap | Gets and sets a value that indicates the maximum allowable size (in pixels) of gaps within the horizontal line to register to.
Public Property | VerticalToLineMaximumLineThickness | Gets and sets a value that indicates the maximum allowable width (in pixels) of the horizontal line to register to.
Public Property | VerticalToLineMinimumLineLength | Gets and sets a value that indicates the minimum allowable length (in pixels) of the horizontal line to register to.
Top
See Also

Reference

ImageRegistrationOptions Class
Accusoft.ScanFixXpressSdk Namespace


ImageRegistrationOptions Constructor

Accusoft.ScanFixXpress8.Net
ImageRegistrationOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : ImageRegistrationOptions Constructor
Overload List
Overload | Description
ImageRegistrationOptions Constructor() | Instantiates a new ImageRegistrationOptions object setting the default values.
ImageRegistrationOptions Constructor(Boolean,Boolean) | Instantiates a new ImageRegistrationOptions object setting the specified values.
ImageRegistrationOptions Constructor(Boolean,Boolean,Boolean,Boolean,Int32,Int32,Int32,Int32,Boolean,Int32,Boolean,Boolean,Int32,Int32,Int32,Boolean,Boolean,Boolean,Int32,Int32,Int32,Int32,Boolean,Int32,Boolean,Boolean,Int32,Int32,Int32) | Instantiates a new ImageRegistrationOptions object setting the specified values.
See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


ImageRegistrationOptions Constructor()

Accusoft.ScanFixXpress8.Net
ImageRegistrationOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class > ImageRegistrationOptions Constructor : ImageRegistrationOptions Constructor()
Instantiates a new ImageRegistrationOptions object setting the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New ImageRegistrationOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public ImageRegistrationOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: ImageRegistrationOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
ImageRegistrationOptions();
See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members
Overload List


ImageRegistrationOptions Constructor(Boolean,Boolean)

Accusoft.ScanFixXpress8.Net
ImageRegistrationOptions Constructor(Boolean,Boolean)

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class > ImageRegistrationOptions Constructor : ImageRegistrationOptions Constructor(Boolean,Boolean)
Enables registration of the left edge of the text.
Enables registration of the top edge of the text.
Instantiates a new ImageRegistrationOptions object setting the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New( _
   ByVal horizontalActive As Boolean, _
   ByVal verticalActive As Boolean _
)
'Usage

Dim horizontalActive As Boolean
Dim verticalActive As Boolean

Dim instance As New ImageRegistrationOptions(horizontalActive, verticalActive)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public ImageRegistrationOptions(
   bool horizontalActive,
   bool verticalActive
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: ImageRegistrationOptions(
   bool horizontalActive,
   bool verticalActive
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
ImageRegistrationOptions(
   bool horizontalActive,
   bool verticalActive
)

Parameters

horizontalActive
Enables registration of the left edge of the text.
verticalActive
Enables registration of the top edge of the text.
See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members
Overload List


ImageRegistrationOptions Constructor(Boolean,Boolean,Boolean,Boolean,Int32,Int32,Int32,Int32,Boolean,Int32,Boolean,Boolean,Int32,Int32,Int32,Boolean,Boolean,Boolean,Int32,Int32,Int32,Int32,Boolean,Int32,Boolean,Boolean,Int32,Int32,Int32)

Accusoft.ScanFixXpress8.Net
ImageRegistrationOptions Constructor(Boolean,Boolean,Boolean,Boolean,Int32,Int32,Int32,Int32,Boolean,Int32,Boolean,Boolean,Int32,Int32,Int32,Boolean,Boolean,Boolean,Int32,Int32,Int32,Int32,Boolean,Int32,Boolean,Boolean,Int32,Int32,Int32)

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class > ImageRegistrationOptions Constructor : ImageRegistrationOptions Constructor(Boolean,Boolean,Boolean,Boolean,Int32,Int32,Int32,Int32,Boolean,Int32,Boolean,Boolean,Int32,Int32,Int32,Boolean,Boolean,Boolean,Int32,Int32,Int32,Int32,Boolean,Int32,Boolean,Boolean,Int32,Int32,Int32)
A flag that enables registration of the left edge of the text.
A flag that indicates whether any pixels will be removed during horizontal registration
A flag that indicates whether the middle portion of the image border will be used for registration, ignoring edge noise, letterheads, and logos.
A flag that indicates whether binder holes and other left-edge noise are ignored during horizontal registration.
A value that controls how intense the activity has to be for it to be considered real activity.
A value that controls how dense and consistent image data should be for it to be considered edge noise.
A value that controls how much activity determines what is valid data.
A value that indicates how many pixels will remain as a left margin after processing.
A flag that indicates whether a set number of scan lines will be skipped before the toolkit starts looking for valid information for registration.
A flag that indicates whether a set number of scan lines will be skipped before the toolkit starts looking for valid information for registration.
A flag that indicates whether the component will position the text in the image based on the position of a vertical line, or to what is determined to be the edge of the text.
A flag that indicates the vertical line to register to is very thin (1 or 2 pixels) when HorizontalToLineActive is true, otherwise this value is ignored.
A value that indicates the maximum allowable size (in pixels) of gaps within the vertical line to register to.
A value that indicates the maximum allowable width (in pixels) of the vertical line to register to.
A value that indicates the minimum allowable length (in pixels) of the vertical line to register to.
A flag that enables registration of the top edge of the text.
A flag that indicates whether any pixels will be removed during vertical registration, even if the desired margin is smaller than the existing margin.
A flag that indicates whether the middle portion of the image border will be used for registration, ignoring edge noise, letterheads, and logos.
A value that controls how intense the activity has to be for it to be considered real activity.
A value that controls how dense and consistent image data should be for it to be considered edge noise.
A value that controls how much activity determines what is valid data.
A value that indicates how many pixels will remain as a top margin after processing.
A flag that indicates whether a set number of scan lines will be skipped before the toolkit starts looking for valid information for registration.
A value that indicates how many horizontal scan lines will be skipped if VerticalSkipActive is true, otherwise this value is ignored.
A flag that indicates whether the component will position the text in the image based on the position of a horizontal line, or to what is determined to be the edge of the text.
A flag that indicates the horizontal line to register to is very thin (1 or 2 pixels) when VerticalToLineActive is true, otherwise this value is ignored.
A value that indicates the maximum allowable size (in pixels) of gaps within the horizontal line to register to.
A value that indicates the maximum allowable size (in pixels) of gaps within the horizontal line to register to.
A value that indicates the maximum allowable width (in pixels) of the horizontal line to register to.
Instantiates a new ImageRegistrationOptions object setting the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New( _
   ByVal horizontalActive As Boolean, _
   ByVal horizontalAddOnly As Boolean, _
   ByVal horizontalCentralFocus As Boolean, _
   ByVal horizontalIgnoreHoles As Boolean, _
   ByVal horizontalMinActivity As Integer, _
   ByVal horizontalMinBackground As Integer, _
   ByVal horizontalMinForeground As Integer, _
   ByVal horizontalResultantMargin As Integer, _
   ByVal horizontalSkipActive As Boolean, _
   ByVal horizontalSkipDistance As Integer, _
   ByVal horizontalToLineActive As Boolean, _
   ByVal horizontalToLineCheckThinLinesActive As Boolean, _
   ByVal horizontalToLineMaxLineGap As Integer, _
   ByVal horizontalToLineMaxLineThickness As Integer, _
   ByVal horizontalToLineMinLineLength As Integer, _
   ByVal verticalActive As Boolean, _
   ByVal verticalAddOnly As Boolean, _
   ByVal verticalCentralFocus As Boolean, _
   ByVal verticalMinActivity As Integer, _
   ByVal verticalMinBackground As Integer, _
   ByVal verticalMinForeground As Integer, _
   ByVal verticalResultantMargin As Integer, _
   ByVal verticalSkipActive As Boolean, _
   ByVal verticalSkipDistance As Integer, _
   ByVal verticalToLineActive As Boolean, _
   ByVal verticalToLineCheckThinLinesActive As Boolean, _
   ByVal verticalToLineMaxLineGap As Integer, _
   ByVal verticalToLineMaxLineThickness As Integer, _
   ByVal verticalToLineMinLineLength As Integer _
)
'Usage

Dim horizontalActive As Boolean
Dim horizontalAddOnly As Boolean
Dim horizontalCentralFocus As Boolean
Dim horizontalIgnoreHoles As Boolean
Dim horizontalMinActivity As Integer
Dim horizontalMinBackground As Integer
Dim horizontalMinForeground As Integer
Dim horizontalResultantMargin As Integer
Dim horizontalSkipActive As Boolean
Dim horizontalSkipDistance As Integer
Dim horizontalToLineActive As Boolean
Dim horizontalToLineCheckThinLinesActive As Boolean
Dim horizontalToLineMaxLineGap As Integer
Dim horizontalToLineMaxLineThickness As Integer
Dim horizontalToLineMinLineLength As Integer
Dim verticalActive As Boolean
Dim verticalAddOnly As Boolean
Dim verticalCentralFocus As Boolean
Dim verticalMinActivity As Integer
Dim verticalMinBackground As Integer
Dim verticalMinForeground As Integer
Dim verticalResultantMargin As Integer
Dim verticalSkipActive As Boolean
Dim verticalSkipDistance As Integer
Dim verticalToLineActive As Boolean
Dim verticalToLineCheckThinLinesActive As Boolean
Dim verticalToLineMaxLineGap As Integer
Dim verticalToLineMaxLineThickness As Integer
Dim verticalToLineMinLineLength As Integer

Dim instance As New ImageRegistrationOptions(horizontalActive, horizontalAddOnly, horizontalCentralFocus, horizontalIgnoreHoles, horizontalMinActivity, horizontalMinBackground, horizontalMinForeground, horizontalResultantMargin, horizontalSkipActive, horizontalSkipDistance, horizontalToLineActive, horizontalToLineCheckThinLinesActive, horizontalToLineMaxLineGap, horizontalToLineMaxLineThickness, horizontalToLineMinLineLength, verticalActive, verticalAddOnly, verticalCentralFocus, verticalMinActivity, verticalMinBackground, verticalMinForeground, verticalResultantMargin, verticalSkipActive, verticalSkipDistance, verticalToLineActive, verticalToLineCheckThinLinesActive, verticalToLineMaxLineGap, verticalToLineMaxLineThickness, verticalToLineMinLineLength)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public ImageRegistrationOptions(
   bool horizontalActive,
   bool horizontalAddOnly,
   bool horizontalCentralFocus,
   bool horizontalIgnoreHoles,
   int horizontalMinActivity,
   int horizontalMinBackground,
   int horizontalMinForeground,
   int horizontalResultantMargin,
   bool horizontalSkipActive,
   int horizontalSkipDistance,
   bool horizontalToLineActive,
   bool horizontalToLineCheckThinLinesActive,
   int horizontalToLineMaxLineGap,
   int horizontalToLineMaxLineThickness,
   int horizontalToLineMinLineLength,
   bool verticalActive,
   bool verticalAddOnly,
   bool verticalCentralFocus,
   int verticalMinActivity,
   int verticalMinBackground,
   int verticalMinForeground,
   int verticalResultantMargin,
   bool verticalSkipActive,
   int verticalSkipDistance,
   bool verticalToLineActive,
   bool verticalToLineCheckThinLinesActive,
   int verticalToLineMaxLineGap,
   int verticalToLineMaxLineThickness,
   int verticalToLineMinLineLength
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: ImageRegistrationOptions(
   bool horizontalActive,
   bool horizontalAddOnly,
   bool horizontalCentralFocus,
   bool horizontalIgnoreHoles,
   int horizontalMinActivity,
   int horizontalMinBackground,
   int horizontalMinForeground,
   int horizontalResultantMargin,
   bool horizontalSkipActive,
   int horizontalSkipDistance,
   bool horizontalToLineActive,
   bool horizontalToLineCheckThinLinesActive,
   int horizontalToLineMaxLineGap,
   int horizontalToLineMaxLineThickness,
   int horizontalToLineMinLineLength,
   bool verticalActive,
   bool verticalAddOnly,
   bool verticalCentralFocus,
   int verticalMinActivity,
   int verticalMinBackground,
   int verticalMinForeground,
   int verticalResultantMargin,
   bool verticalSkipActive,
   int verticalSkipDistance,
   bool verticalToLineActive,
   bool verticalToLineCheckThinLinesActive,
   int verticalToLineMaxLineGap,
   int verticalToLineMaxLineThickness,
   int verticalToLineMinLineLength
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
ImageRegistrationOptions(
   bool horizontalActive,
   bool horizontalAddOnly,
   bool horizontalCentralFocus,
   bool horizontalIgnoreHoles,
   int horizontalMinActivity,
   int horizontalMinBackground,
   int horizontalMinForeground,
   int horizontalResultantMargin,
   bool horizontalSkipActive,
   int horizontalSkipDistance,
   bool horizontalToLineActive,
   bool horizontalToLineCheckThinLinesActive,
   int horizontalToLineMaxLineGap,
   int horizontalToLineMaxLineThickness,
   int horizontalToLineMinLineLength,
   bool verticalActive,
   bool verticalAddOnly,
   bool verticalCentralFocus,
   int verticalMinActivity,
   int verticalMinBackground,
   int verticalMinForeground,
   int verticalResultantMargin,
   bool verticalSkipActive,
   int verticalSkipDistance,
   bool verticalToLineActive,
   bool verticalToLineCheckThinLinesActive,
   int verticalToLineMaxLineGap,
   int verticalToLineMaxLineThickness,
   int verticalToLineMinLineLength
)

Parameters

horizontalActive
A flag that enables registration of the left edge of the text.
horizontalAddOnly
A flag that indicates whether any pixels will be removed during horizontal registration
horizontalCentralFocus
A flag that indicates whether the middle portion of the image border will be used for registration, ignoring edge noise, letterheads, and logos.
horizontalIgnoreHoles
A flag that indicates whether binder holes and other left-edge noise are ignored during horizontal registration.
horizontalMinActivity
A value that controls how intense the activity has to be for it to be considered real activity.
horizontalMinBackground
A value that controls how dense and consistent image data should be for it to be considered edge noise.
horizontalMinForeground
A value that controls how much activity determines what is valid data.
horizontalResultantMargin
A value that indicates how many pixels will remain as a left margin after processing.
horizontalSkipActive
A flag that indicates whether a set number of scan lines will be skipped before the toolkit starts looking for valid information for registration.
horizontalSkipDistance
A flag that indicates whether a set number of scan lines will be skipped before the toolkit starts looking for valid information for registration.
horizontalToLineActive
A flag that indicates whether the component will position the text in the image based on the position of a vertical line, or to what is determined to be the edge of the text.
horizontalToLineCheckThinLinesActive
A flag that indicates the vertical line to register to is very thin (1 or 2 pixels) when HorizontalToLineActive is true, otherwise this value is ignored.
horizontalToLineMaxLineGap
A value that indicates the maximum allowable size (in pixels) of gaps within the vertical line to register to.
horizontalToLineMaxLineThickness
A value that indicates the maximum allowable width (in pixels) of the vertical line to register to.
horizontalToLineMinLineLength
A value that indicates the minimum allowable length (in pixels) of the vertical line to register to.
verticalActive
A flag that enables registration of the top edge of the text.
verticalAddOnly
A flag that indicates whether any pixels will be removed during vertical registration, even if the desired margin is smaller than the existing margin.
verticalCentralFocus
A flag that indicates whether the middle portion of the image border will be used for registration, ignoring edge noise, letterheads, and logos.
verticalMinActivity
A value that controls how intense the activity has to be for it to be considered real activity.
verticalMinBackground
A value that controls how dense and consistent image data should be for it to be considered edge noise.
verticalMinForeground
A value that controls how much activity determines what is valid data.
verticalResultantMargin
A value that indicates how many pixels will remain as a top margin after processing.
verticalSkipActive
A flag that indicates whether a set number of scan lines will be skipped before the toolkit starts looking for valid information for registration.
verticalSkipDistance
A value that indicates how many horizontal scan lines will be skipped if VerticalSkipActive is true, otherwise this value is ignored.
verticalToLineActive
A flag that indicates whether the component will position the text in the image based on the position of a horizontal line, or to what is determined to be the edge of the text.
verticalToLineCheckThinLinesActive
A flag that indicates the horizontal line to register to is very thin (1 or 2 pixels) when VerticalToLineActive is true, otherwise this value is ignored.
verticalToLineMaxLineGap
A value that indicates the maximum allowable size (in pixels) of gaps within the horizontal line to register to.
verticalToLineMaxLineThickness
A value that indicates the maximum allowable size (in pixels) of gaps within the horizontal line to register to.
verticalToLineMinLineLength
A value that indicates the maximum allowable width (in pixels) of the horizontal line to register to.
See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members
Overload List


HorizontalActive Property

Accusoft.ScanFixXpress8.Net
HorizontalActive Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : HorizontalActive Property
Gets and sets a flag that enables registration of the left edge of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HorizontalActive As Boolean
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Boolean

instance.HorizontalActive = value

value = instance.HorizontalActive
public bool HorizontalActive {get; set;}
public: __property bool get_HorizontalActive();
public: __property void set_HorizontalActive(
   bool value
);
public:
property bool HorizontalActive {
   bool get();
   void set (    bool value);
}

Property Value

A boolean which is set to true to enable registration on the left edge of the text. Otherwise, false is returned.
Remarks

Default value: True

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


HorizontalAddOnly Property

Accusoft.ScanFixXpress8.Net
HorizontalAddOnly Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : HorizontalAddOnly Property
Gets and sets a flag that indicates whether any pixels will be removed during horizontal registration, even if the desired margin is smaller than the existing margin.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HorizontalAddOnly As Boolean
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Boolean

instance.HorizontalAddOnly = value

value = instance.HorizontalAddOnly
public bool HorizontalAddOnly {get; set;}
public: __property bool get_HorizontalAddOnly();
public: __property void set_HorizontalAddOnly(
   bool value
);
public:
property bool HorizontalAddOnly {
   bool get();
   void set (    bool value);
}

Property Value

A boolean which is set to true to preserve exising pixels during horizontal registration.
Remarks

When this property is true and the value specified in the ImageRegistrationResults.HorizontalMarginAdjustment property is less than 0, no modification to the left margin of the current image will have occured. In this case, the value returned by the ImageRegistrationResults.HorizontalMarginAdjustment property represents the adjustment that would have been applied to the left margin if Registration were permitted to remove pixels.

Default value: False

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


HorizontalCentralFocus Property

Accusoft.ScanFixXpress8.Net
HorizontalCentralFocus Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : HorizontalCentralFocus Property
Gets and sets a flag that indicates whether the middle portion of the image border will be used for registration, ignoring edge noise, letterheads, and logos.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HorizontalCentralFocus As Boolean
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Boolean

instance.HorizontalCentralFocus = value

value = instance.HorizontalCentralFocus
public bool HorizontalCentralFocus {get; set;}
public: __property bool get_HorizontalCentralFocus();
public: __property void set_HorizontalCentralFocus(
   bool value
);
public:
property bool HorizontalCentralFocus {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which returns true if the middle portion of the image border is used for registration. Otherwise, false is returned.
Remarks

Default value: False

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


HorizontalIgnoreHoles Property

Accusoft.ScanFixXpress8.Net
HorizontalIgnoreHoles Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : HorizontalIgnoreHoles Property
Gets and sets a flag that indicates whether binder holes and other left-edge noise are ignored during horizontal registration.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HorizontalIgnoreHoles As Boolean
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Boolean

instance.HorizontalIgnoreHoles = value

value = instance.HorizontalIgnoreHoles
public bool HorizontalIgnoreHoles {get; set;}
public: __property bool get_HorizontalIgnoreHoles();
public: __property void set_HorizontalIgnoreHoles(
   bool value
);
public:
property bool HorizontalIgnoreHoles {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which returns true if binder holes are ignored during horizontal registration. Otherwise, false is returned.
Remarks

Note: Set this property to false, unless you have holes or similar noise to avoid.

This feature only applies to horizontal registration.

Default value: False

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


HorizontalMinimumActivity Property

Accusoft.ScanFixXpress8.Net
HorizontalMinimumActivity Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : HorizontalMinimumActivity Property
Gets and sets a value that controls how intense the activity has to be for it to be considered real activity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HorizontalMinimumActivity As Integer
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Integer

instance.HorizontalMinimumActivity = value

value = instance.HorizontalMinimumActivity
public int HorizontalMinimumActivity {get; set;}
public: __property int get_HorizontalMinimumActivity();
public: __property void set_HorizontalMinimumActivity(
   int value
);
public:
property int HorizontalMinimumActivity {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the minimum level of activity.
Remarks

Notes: Setting this value higher can improve performance when you find the component registering to edge noise.

Valid values: Any number from 1 to 1000

Default value: 3

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


HorizontalMinimumBackground Property

Accusoft.ScanFixXpress8.Net
HorizontalMinimumBackground Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : HorizontalMinimumBackground Property
Gets and sets a value that controls how dense and consistent image data should be for it to be considered edge noise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HorizontalMinimumBackground As Integer
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Integer

instance.HorizontalMinimumBackground = value

value = instance.HorizontalMinimumBackground
public int HorizontalMinimumBackground {get; set;}
public: __property int get_HorizontalMinimumBackground();
public: __property void set_HorizontalMinimumBackground(
   int value
);
public:
property int HorizontalMinimumBackground {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the minimum density of edge noise.
Remarks

A very high value can cause edge noise to be treated as valid data. If you use a lower value, valid data may be considered edge noise.

Valid values: Any number from 2 to 1000

Default value: 5

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


HorizontalMinimumForeground Property

Accusoft.ScanFixXpress8.Net
HorizontalMinimumForeground Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : HorizontalMinimumForeground Property
Gets and sets a value that controls how much activity determines what is valid data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HorizontalMinimumForeground As Integer
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Integer

instance.HorizontalMinimumForeground = value

value = instance.HorizontalMinimumForeground
public int HorizontalMinimumForeground {get; set;}
public: __property int get_HorizontalMinimumForeground();
public: __property void set_HorizontalMinimumForeground(
   int value
);
public:
property int HorizontalMinimumForeground {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the minimum density of valid data.
Remarks

Individual characters are usually about 20 pixels wide, so values around 20 (on a 300 dpi image) often work well, consistently ignoring perpendicular lines. Lower values can increase the likelihood of registering to edge noise. You may need to use values as low as 1 when you are dealing with dot matrix print.

Valid values: Any number from 1 to 1000

Default value: 5

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


HorizontalResultantMargin Property

Accusoft.ScanFixXpress8.Net
HorizontalResultantMargin Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : HorizontalResultantMargin Property
Gets and sets a value that indicates how many pixels will remain as a left margin after processing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HorizontalResultantMargin As Integer
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Integer

instance.HorizontalResultantMargin = value

value = instance.HorizontalResultantMargin
public int HorizontalResultantMargin {get; set;}
public: __property int get_HorizontalResultantMargin();
public: __property void set_HorizontalResultantMargin(
   int value
);
public:
property int HorizontalResultantMargin {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the size of the left margin after processing.
Remarks

Setting this value to 0 places text flush with left edge of the image. A negative value crops the specified number of pixels from the left edge of the text.

Valid values: Any number from -{image width} to +20000

Default value: 150

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


HorizontalSkipActive Property

Accusoft.ScanFixXpress8.Net
HorizontalSkipActive Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : HorizontalSkipActive Property
Gets and sets a flag that indicates whether a set number of scan lines will be skipped before the toolkit starts looking for valid information for registration.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HorizontalSkipActive As Boolean
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Boolean

instance.HorizontalSkipActive = value

value = instance.HorizontalSkipActive
public bool HorizontalSkipActive {get; set;}
public: __property bool get_HorizontalSkipActive();
public: __property void set_HorizontalSkipActive(
   bool value
);
public:
property bool HorizontalSkipActive {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which returns true if vertical scan lines are skipped before looking for valid registration information. Otherwise, false is returned.
Remarks

The skip feature is particularly valuable for dealing with unwanted data on the edge of an image. In some cases, you may want to skip over a form line or margin note. In other cases, this feature can be useful to skip over scanner artifacts that look like lines or data.

When this property is true, the value set in the HorizontalSkipDistance property determines the number of vertical scan lines that are skipped. If this property is set to false, the HorizontalSkipDistance property is ignored.

Default value: False

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


HorizontalSkipDistance Property

Accusoft.ScanFixXpress8.Net
HorizontalSkipDistance Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : HorizontalSkipDistance Property
Gets and sets a value that indicates how many vertical scan lines will be skipped if HorizontalSkipActive is true, otherwise this value is ignored.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HorizontalSkipDistance As Integer
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Integer

instance.HorizontalSkipDistance = value

value = instance.HorizontalSkipDistance
public int HorizontalSkipDistance {get; set;}
public: __property int get_HorizontalSkipDistance();
public: __property void set_HorizontalSkipDistance(
   int value
);
public:
property int HorizontalSkipDistance {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the number of vertical scan lines to skip.
Remarks

This property gets or sets the number of scan lines to skip if the HorizontalSkipActive property is set to true. If the HorizontalSkipActive property is set to false, this property is ignored.

Valid values: Any number from 0 to 20000

Default value: 20

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


HorizontalToLineActive Property

Accusoft.ScanFixXpress8.Net
HorizontalToLineActive Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : HorizontalToLineActive Property
Gets and sets a flag that indicates whether the component will position the text in the image based on the position of a vertical line, or to what is determined to be the edge of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HorizontalToLineActive As Boolean
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Boolean

instance.HorizontalToLineActive = value

value = instance.HorizontalToLineActive
public bool HorizontalToLineActive {get; set;}
public: __property bool get_HorizontalToLineActive();
public: __property void set_HorizontalToLineActive(
   bool value
);
public:
property bool HorizontalToLineActive {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which returns true to position the text in the image based on the position of a vertical line. Otherwise, false is returned.
Remarks

This is a powerful feature for precise registration on forms, especially on forms with edge noise. The vertical line should be significantly larger than any text characters (in particular, those characters to the left of this line).

Default value: False

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


HorizontalToLineCheckThinLinesActive Property

Accusoft.ScanFixXpress8.Net
HorizontalToLineCheckThinLinesActive Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : HorizontalToLineCheckThinLinesActive Property
Gets and sets a flag that indicates the vertical line to register to is very thin (1 or 2 pixels) when HorizontalToLineActive is true, otherwise this value is ignored.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HorizontalToLineCheckThinLinesActive As Boolean
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Boolean

instance.HorizontalToLineCheckThinLinesActive = value

value = instance.HorizontalToLineCheckThinLinesActive
public bool HorizontalToLineCheckThinLinesActive {get; set;}
public: __property bool get_HorizontalToLineCheckThinLinesActive();
public: __property void set_HorizontalToLineCheckThinLinesActive(
   bool value
);
public:
property bool HorizontalToLineCheckThinLinesActive {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which returns true if the vertical line to register is very thin. Otherwise, false is returned.
Remarks

Note: This value is ignored if HorizontalToLineActive is false.

Default value: False

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


HorizontalToLineMaximumLineGap Property

Accusoft.ScanFixXpress8.Net
HorizontalToLineMaximumLineGap Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : HorizontalToLineMaximumLineGap Property
Gets and sets a value that indicates the maximum allowable size (in pixels) of gaps within the vertical line to register to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HorizontalToLineMaximumLineGap As Integer
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Integer

instance.HorizontalToLineMaximumLineGap = value

value = instance.HorizontalToLineMaximumLineGap
public int HorizontalToLineMaximumLineGap {get; set;}
public: __property int get_HorizontalToLineMaximumLineGap();
public: __property void set_HorizontalToLineMaximumLineGap(
   int value
);
public:
property int HorizontalToLineMaximumLineGap {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the maximum allowable size (in pixels) of gaps within the vertical line to register to.
Remarks

When this property is set to a value of 3 or less, the toolkit simply ignores short gaps. However, setting this value over 3 tells the toolkit to employ its Super-Line algorithms. These algorithms re-assemble broken lines into a whole line for registration purposes, and can dramatically improve the success rate when HorizontalToLineActive is true.

Note: This value is ignored if HorizontalToLineActive is false.

Valid values: Any number from 0 to 50

Default value: 2

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


HorizontalToLineMaximumLineThickness Property

Accusoft.ScanFixXpress8.Net
HorizontalToLineMaximumLineThickness Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : HorizontalToLineMaximumLineThickness Property
Gets and sets a value that indicates the maximum allowable width (in pixels) of the vertical line to register to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HorizontalToLineMaximumLineThickness As Integer
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Integer

instance.HorizontalToLineMaximumLineThickness = value

value = instance.HorizontalToLineMaximumLineThickness
public int HorizontalToLineMaximumLineThickness {get; set;}
public: __property int get_HorizontalToLineMaximumLineThickness();
public: __property void set_HorizontalToLineMaximumLineThickness(
   int value
);
public:
property int HorizontalToLineMaximumLineThickness {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the maximum allowable width (in pixels) of the vertical line to register to.
Remarks

This value lets you select the maximum thickness to consider when registering to a vertical line so you can set the maximum line thickness lower than the width of the text.

Note: This value is ignored if HorizontalToLineActive is false.

Valid values: Any number from 0 to 100

Default value: 22

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


HorizontalToLineMinimumLineLength Property

Accusoft.ScanFixXpress8.Net
HorizontalToLineMinimumLineLength Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : HorizontalToLineMinimumLineLength Property
Gets and sets a value that indicates the minimum allowable length (in pixels) of the vertical line to register to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HorizontalToLineMinimumLineLength As Integer
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Integer

instance.HorizontalToLineMinimumLineLength = value

value = instance.HorizontalToLineMinimumLineLength
public int HorizontalToLineMinimumLineLength {get; set;}
public: __property int get_HorizontalToLineMinimumLineLength();
public: __property void set_HorizontalToLineMinimumLineLength(
   int value
);
public:
property int HorizontalToLineMinimumLineLength {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the minimum allowable length (in pixels) of the vertical line to register to.
Remarks

This value should be larger than the height of the text characters. The component will examine the image from left to right, until it locates a vertical line segment larger than this value, or until it reaches one quarter the image width. It then shifts the image so that the line is the distance from the left edge of the image as specified by HorizontalResultantMargin.

Note: This value is ignored if HorizontalToLineActive is false.

Valid values: Any number from 0 to 20000

Default value: 300

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


VerticalActive Property

Accusoft.ScanFixXpress8.Net
VerticalActive Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : VerticalActive Property
Gets and sets a flag that enables registration of the top edge of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VerticalActive As Boolean
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Boolean

instance.VerticalActive = value

value = instance.VerticalActive
public bool VerticalActive {get; set;}
public: __property bool get_VerticalActive();
public: __property void set_VerticalActive(
   bool value
);
public:
property bool VerticalActive {
   bool get();
   void set (    bool value);
}

Property Value

A boolean which is set to true to enable registration on the top edge of the text. Otherwise, false is returned.
Remarks

Default value: True

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


VerticalAddOnly Property

Accusoft.ScanFixXpress8.Net
VerticalAddOnly Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : VerticalAddOnly Property
Gets and sets a flag that indicates whether any pixels will be removed during vertical registration, even if the desired margin is smaller than the existing margin.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VerticalAddOnly As Boolean
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Boolean

instance.VerticalAddOnly = value

value = instance.VerticalAddOnly
public bool VerticalAddOnly {get; set;}
public: __property bool get_VerticalAddOnly();
public: __property void set_VerticalAddOnly(
   bool value
);
public:
property bool VerticalAddOnly {
   bool get();
   void set (    bool value);
}

Property Value

A boolean which is set to true to preserve exising pixels during vertical registration.
Remarks

When this property is true and the value specified in the ImageRegistrationResults.VerticalMarginAdjustment property is less than 0, no modification to the top margin of the current image will have occured. In this case, the value returned by the ImageRegistrationResults.VerticalMarginAdjustment property represents the adjustment that would have been applied to the top margin if Registration were permitted to remove pixels.

Default value: False

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


VerticalCentralFocus Property

Accusoft.ScanFixXpress8.Net
VerticalCentralFocus Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : VerticalCentralFocus Property
Gets and sets a flag that indicates whether the middle portion of the image border will be used for registration, ignoring edge noise, letterheads, and logos.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VerticalCentralFocus As Boolean
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Boolean

instance.VerticalCentralFocus = value

value = instance.VerticalCentralFocus
public bool VerticalCentralFocus {get; set;}
public: __property bool get_VerticalCentralFocus();
public: __property void set_VerticalCentralFocus(
   bool value
);
public:
property bool VerticalCentralFocus {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which returns true if the middle portion of the image border is used for registration. Otherwise, false is returned.
Remarks

Default value: False

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


VerticalMinimumActivity Property

Accusoft.ScanFixXpress8.Net
VerticalMinimumActivity Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : VerticalMinimumActivity Property
Gets and sets a value that controls how intense the activity has to be for it to be considered real activity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VerticalMinimumActivity As Integer
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Integer

instance.VerticalMinimumActivity = value

value = instance.VerticalMinimumActivity
public int VerticalMinimumActivity {get; set;}
public: __property int get_VerticalMinimumActivity();
public: __property void set_VerticalMinimumActivity(
   int value
);
public:
property int VerticalMinimumActivity {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the minimum level of activity.
Remarks

Notes: Setting this value higher can improve performance when you find the component registering to edge noise.

Valid values: Any number from 1 to 1000

Default value: 3

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


VerticalMinimumBackground Property

Accusoft.ScanFixXpress8.Net
VerticalMinimumBackground Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : VerticalMinimumBackground Property
Gets and sets a value that controls how dense and consistent image data should be for it to be considered edge noise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VerticalMinimumBackground As Integer
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Integer

instance.VerticalMinimumBackground = value

value = instance.VerticalMinimumBackground
public int VerticalMinimumBackground {get; set;}
public: __property int get_VerticalMinimumBackground();
public: __property void set_VerticalMinimumBackground(
   int value
);
public:
property int VerticalMinimumBackground {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the minimum density of edge noise.
Remarks

A very high value can cause edge noise to be treated as valid data. If you use a lower value, valid data may be considered edge noise.

Valid values: Any number from 2 to 1000

Default value: 5

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


VerticalMinimumForeground Property

Accusoft.ScanFixXpress8.Net
VerticalMinimumForeground Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : VerticalMinimumForeground Property
Gets and sets a value that controls how much activity determines what is valid data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VerticalMinimumForeground As Integer
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Integer

instance.VerticalMinimumForeground = value

value = instance.VerticalMinimumForeground
public int VerticalMinimumForeground {get; set;}
public: __property int get_VerticalMinimumForeground();
public: __property void set_VerticalMinimumForeground(
   int value
);
public:
property int VerticalMinimumForeground {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the minimum density of valid data.
Remarks

Individual characters are usually about 20 pixels wide, so values around 20 (on a 300 dpi image) often work well, consistently ignoring perpendicular lines. Lower values can increase the likelihood of registering to edge noise. You may need to use values as low as 1 when you are dealing with dot matrix print.

Valid values: Any number from 1 to 1000

Default value: 5

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


VerticalResultantMargin Property

Accusoft.ScanFixXpress8.Net
VerticalResultantMargin Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : VerticalResultantMargin Property
Gets and sets a value that indicates how many pixels will remain as a top margin after processing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VerticalResultantMargin As Integer
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Integer

instance.VerticalResultantMargin = value

value = instance.VerticalResultantMargin
public int VerticalResultantMargin {get; set;}
public: __property int get_VerticalResultantMargin();
public: __property void set_VerticalResultantMargin(
   int value
);
public:
property int VerticalResultantMargin {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the size of the top margin after processing.
Remarks

Setting this value to 0 places text flush with top edge of the image. A negative value crops the specified number of pixels from the top edge of the text.

Valid values: Any number from -{image height} to +20000

Default value: 150

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


VerticalSkipActive Property

Accusoft.ScanFixXpress8.Net
VerticalSkipActive Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : VerticalSkipActive Property
Gets and sets a flag that indicates whether a set number of scan lines will be skipped before the toolkit starts looking for valid information for registration.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VerticalSkipActive As Boolean
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Boolean

instance.VerticalSkipActive = value

value = instance.VerticalSkipActive
public bool VerticalSkipActive {get; set;}
public: __property bool get_VerticalSkipActive();
public: __property void set_VerticalSkipActive(
   bool value
);
public:
property bool VerticalSkipActive {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which returns true if horizontal scan lines are skipped before looking for valid registration information. Otherwise, false is returned.
Remarks

The skip feature is particularly valuable for dealing with unwanted data on the edge of an image. In some cases, you may want to skip over a form line or margin note. In other cases, this feature can be useful to skip over scanner artifacts that look like lines or data.

When this property is true, the value set in the VerticalSkipDistance property determines the number of horizontal scan lines that are skipped. If this property is set to false, the VerticalSkipDistance property is ignored.

Default value: False

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


VerticalSkipDistance Property

Accusoft.ScanFixXpress8.Net
VerticalSkipDistance Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : VerticalSkipDistance Property
Gets and sets a value that indicates how many horizontal scan lines will be skipped if VerticalSkipActive is true, otherwise this value is ignored.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VerticalSkipDistance As Integer
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Integer

instance.VerticalSkipDistance = value

value = instance.VerticalSkipDistance
public int VerticalSkipDistance {get; set;}
public: __property int get_VerticalSkipDistance();
public: __property void set_VerticalSkipDistance(
   int value
);
public:
property int VerticalSkipDistance {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the number of horizontal scan lines to skip.
Remarks

This property gets and sets the number of scan lines to skip if the VerticalSkipActive property is set to true. If the VerticalSkipActive property is set to false, this property is ignored.

Valid values: Any number from 0 to 20000

Default value: 20

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


VerticalToLineActive Property

Accusoft.ScanFixXpress8.Net
VerticalToLineActive Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : VerticalToLineActive Property
Gets and sets a flag that indicates whether the component will position the text in the image based on the position of a horizontal line, or to what is determined to be the edge of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VerticalToLineActive As Boolean
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Boolean

instance.VerticalToLineActive = value

value = instance.VerticalToLineActive
public bool VerticalToLineActive {get; set;}
public: __property bool get_VerticalToLineActive();
public: __property void set_VerticalToLineActive(
   bool value
);
public:
property bool VerticalToLineActive {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which returns true to position the text in the image based on the position of a horizontal line. Otherwise, false is returned.
Remarks

This is a powerful feature for precise registration on forms, especially on forms with edge noise. The horizontal line should be significantly larger than any text characters (in particular, those characters to the top of this line).

Default value: False

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


VerticalToLineCheckThinLinesActive Property

Accusoft.ScanFixXpress8.Net
VerticalToLineCheckThinLinesActive Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : VerticalToLineCheckThinLinesActive Property
Gets and sets a flag that indicates the horizontal line to register to is very thin (1 or 2 pixels) when VerticalToLineActive is true, otherwise this value is ignored.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VerticalToLineCheckThinLinesActive As Boolean
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Boolean

instance.VerticalToLineCheckThinLinesActive = value

value = instance.VerticalToLineCheckThinLinesActive
public bool VerticalToLineCheckThinLinesActive {get; set;}
public: __property bool get_VerticalToLineCheckThinLinesActive();
public: __property void set_VerticalToLineCheckThinLinesActive(
   bool value
);
public:
property bool VerticalToLineCheckThinLinesActive {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which returns true if the horizontal line to register is very thin. Otherwise, false is returned.
Remarks

Note: This value is ignored if VerticalToLineActive is false.

Default value: False

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


VerticalToLineMaximumLineGap Property

Accusoft.ScanFixXpress8.Net
VerticalToLineMaximumLineGap Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : VerticalToLineMaximumLineGap Property
Gets and sets a value that indicates the maximum allowable size (in pixels) of gaps within the horizontal line to register to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VerticalToLineMaximumLineGap As Integer
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Integer

instance.VerticalToLineMaximumLineGap = value

value = instance.VerticalToLineMaximumLineGap
public int VerticalToLineMaximumLineGap {get; set;}
public: __property int get_VerticalToLineMaximumLineGap();
public: __property void set_VerticalToLineMaximumLineGap(
   int value
);
public:
property int VerticalToLineMaximumLineGap {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the maximum allowable size (in pixels) of gaps within the horizontal line to register to.
Remarks

When this property is set to a value of 3 or less, the toolkit simply ignores short gaps. However, setting this value over 3 tells the toolkit to employ its Super-Line algorithms. These algorithms re-assemble broken lines into a whole line for registration purposes, and can dramatically improve the success rate when VerticalToLineActive is true.

Note: This value is ignored if VerticalToLineActive is false.

Valid values: Any number from 0 to 50

Default value: 2

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


VerticalToLineMaximumLineThickness Property

Accusoft.ScanFixXpress8.Net
VerticalToLineMaximumLineThickness Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : VerticalToLineMaximumLineThickness Property
Gets and sets a value that indicates the maximum allowable width (in pixels) of the horizontal line to register to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VerticalToLineMaximumLineThickness As Integer
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Integer

instance.VerticalToLineMaximumLineThickness = value

value = instance.VerticalToLineMaximumLineThickness
public int VerticalToLineMaximumLineThickness {get; set;}
public: __property int get_VerticalToLineMaximumLineThickness();
public: __property void set_VerticalToLineMaximumLineThickness(
   int value
);
public:
property int VerticalToLineMaximumLineThickness {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the maximum allowable width (in pixels) of the horizontal line to register to.
Remarks

This value lets you select the maximum thickness to consider when registering to a horizontal line so you can set the maximum line thickness lower than the height of the text.

Note: This value is ignored if VerticalToLineActive is false.

Valid values: Any number from 0 to 100

Default value: 22

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


VerticalToLineMinimumLineLength Property

Accusoft.ScanFixXpress8.Net
VerticalToLineMinimumLineLength Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationOptions Class : VerticalToLineMinimumLineLength Property
Gets and sets a value that indicates the minimum allowable length (in pixels) of the horizontal line to register to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VerticalToLineMinimumLineLength As Integer
'Usage

Dim instance As ImageRegistrationOptions
Dim value As Integer

instance.VerticalToLineMinimumLineLength = value

value = instance.VerticalToLineMinimumLineLength
public int VerticalToLineMinimumLineLength {get; set;}
public: __property int get_VerticalToLineMinimumLineLength();
public: __property void set_VerticalToLineMinimumLineLength(
   int value
);
public:
property int VerticalToLineMinimumLineLength {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the minimum allowable length (in pixels) of the horizontal line to register to.
Remarks

This value should be larger than the width of the text characters. The component will examine the image from top to bottom, until it locates a horizontal line segment larger than this value, or until it reaches one quarter the image height. It then shifts the image so that the line is the distance from the top edge of the image as specified by VerticalResultantMargin.

Note: This value is ignored if VerticalToLineActive is false.

Valid values: Any number from 0 to 20000

Default value: 300

See Also

Reference

ImageRegistrationOptions Class
ImageRegistrationOptions Members


ImageRegistrationResults Class

Accusoft.ScanFixXpress8.Net
ImageRegistrationResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : ImageRegistrationResults Class
Contains output values from the image registration process.
Object Model
ImageRegistrationResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImageRegistrationResults
   Inherits EnhancementResult
'Usage

Dim instance As ImageRegistrationResults
public class ImageRegistrationResults : EnhancementResult
public __gc class ImageRegistrationResults : public EnhancementResult
public ref class ImageRegistrationResults : public EnhancementResult
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.ImageRegistrationResults

See Also

Reference

ImageRegistrationResults Members
Accusoft.ScanFixXpressSdk Namespace


ImageRegistrationResults Class Members

Accusoft.ScanFixXpress8.Net
ImageRegistrationResults Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : ImageRegistrationResults Class

The following tables list the members exposed by ImageRegistrationResults.

Public Properties
 | Name | Description
Public Property | HorizontalMarginAdjustment | Gets the number of pixel columns added to the left margin. A negative number denotes that pixels were removed from the left margin.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified during the registration process.
Public Property | VerticalMarginAdjustment | Gets the number of pixel rows added to the top margin. A negative number denotes that pixels were removed from the top margin.
Top
See Also

Reference

ImageRegistrationResults Class
Accusoft.ScanFixXpressSdk Namespace


ImageRegistrationResults Class Properties

Accusoft.ScanFixXpress8.Net
ImageRegistrationResults Class Properties

Accusoft.ScanFixXpressSdk Namespace : ImageRegistrationResults Class

For a list of all members of this type, see ImageRegistrationResults members.

Public Properties
 | Name | Description
Public Property | HorizontalMarginAdjustment | Gets the number of pixel columns added to the left margin. A negative number denotes that pixels were removed from the left margin.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified during the registration process.
Public Property | VerticalMarginAdjustment | Gets the number of pixel rows added to the top margin. A negative number denotes that pixels were removed from the top margin.
Top
See Also

Reference

ImageRegistrationResults Class
Accusoft.ScanFixXpressSdk Namespace


HorizontalMarginAdjustment Property

Accusoft.ScanFixXpress8.Net
HorizontalMarginAdjustment Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationResults Class : HorizontalMarginAdjustment Property
Gets the number of pixel columns added to the left margin. A negative number denotes that pixels were removed from the left margin.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property HorizontalMarginAdjustment As Integer
'Usage

Dim instance As ImageRegistrationResults
Dim value As Integer

value = instance.HorizontalMarginAdjustment
public int HorizontalMarginAdjustment {get;}
public: __property int get_HorizontalMarginAdjustment();
public:
property int HorizontalMarginAdjustment {
   int get();
}

Property Value

An integer which represents the number of pixel colums added to the left margin.
Remarks

A value less than 0 indicates that pixels were removed from the left margin, making the image smaller. A value greater than 0 indicates that pixels were added to the left margin, making the image larger.

When the ImageRegistrationOptions.HorizontalAddOnly flag is true and the value specified in the property is less than 0, no modification to the left margin of the current image will have occured. In this case, the value returned by this property represents the adjustment that would have been applied to the left margin if Registration were permitted to remove pixels.

Note: When Registration adds pixels to the image, the added pixels are always white.

See Also

Reference

ImageRegistrationResults Class
ImageRegistrationResults Members


ImageWasModified Property (ImageRegistrationResults)

Accusoft.ScanFixXpress8.Net
ImageWasModified Property (ImageRegistrationResults)

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationResults Class : ImageWasModified Property
Gets a flag that indicates whether the image was modified during the registration process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageWasModified As Boolean
'Usage

Dim instance As ImageRegistrationResults
Dim value As Boolean

value = instance.ImageWasModified
public bool ImageWasModified {get;}
public: __property bool get_ImageWasModified();
public:
property bool ImageWasModified {
   bool get();
}

Property Value

A boolean value which is True if the image was modified. Otherwise, False is returned.
See Also

Reference

ImageRegistrationResults Class
ImageRegistrationResults Members


VerticalMarginAdjustment Property

Accusoft.ScanFixXpress8.Net
VerticalMarginAdjustment Property

Accusoft.ScanFixXpressSdk Namespace > ImageRegistrationResults Class : VerticalMarginAdjustment Property
Gets the number of pixel rows added to the top margin. A negative number denotes that pixels were removed from the top margin.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property VerticalMarginAdjustment As Integer
'Usage

Dim instance As ImageRegistrationResults
Dim value As Integer

value = instance.VerticalMarginAdjustment
public int VerticalMarginAdjustment {get;}
public: __property int get_VerticalMarginAdjustment();
public:
property int VerticalMarginAdjustment {
   int get();
}

Property Value

An integer which represents the number of pixel rows added to the top margin.
Remarks

A value less than 0 indicates that pixels were removed from the top margin, making the image smaller. A value greater than 0 indicates that pixels were added to the top margin, making the image larger.

When the ImageRegistrationOptions.VerticalAddOnly flag is true and the value specified in the property is less than 0, no modification to the top margin of the current image will have occured. In this case, the value returned by this property represents the adjustment that would have been applied to the top margin if Registration were permitted to remove pixels.

Note: When Registration adds pixels to the image, the added pixels are always white.

See Also

Reference

ImageRegistrationResults Class
ImageRegistrationResults Members


InverseTextOptions Class

Accusoft.ScanFixXpress8.Net
InverseTextOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : InverseTextOptions Class
Contains parameters for the ScanFix.CorrectInverseText process.
Object Model
InverseTextOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class InverseTextOptions
   Inherits EnhancementOption
'Usage

Dim instance As InverseTextOptions
public class InverseTextOptions : EnhancementOption
public __gc class InverseTextOptions : public EnhancementOption
public ref class InverseTextOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.InverseTextOptions

See Also

Reference

InverseTextOptions Members
Accusoft.ScanFixXpressSdk Namespace


InverseTextOptions Class Members

Accusoft.ScanFixXpress8.Net
InverseTextOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : InverseTextOptions Class

The following tables list the members exposed by InverseTextOptions.

Public Constructors
 | Name | Description
Public Constructor | InverseTextOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | MinimumAreaHeight | Gets and sets the minimum height, in pixels, of the smallest expected zone of inverse text.
Public Property | MinimumAreaWidth | Gets and sets the minimum width, in pixels, of the smallest expected zone of inverse text.
Public Property | MinimumBlankOnEdges | Gets and sets the minimum horizontal length of the shortest run of black pixels along the left or right edge of an inverse zone.
Top
See Also

Reference

InverseTextOptions Class
Accusoft.ScanFixXpressSdk Namespace


InverseTextOptions Class Properties

Accusoft.ScanFixXpress8.Net
InverseTextOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : InverseTextOptions Class

For a list of all members of this type, see InverseTextOptions members.

Public Properties
 | Name | Description
Public Property | MinimumAreaHeight | Gets and sets the minimum height, in pixels, of the smallest expected zone of inverse text.
Public Property | MinimumAreaWidth | Gets and sets the minimum width, in pixels, of the smallest expected zone of inverse text.
Public Property | MinimumBlankOnEdges | Gets and sets the minimum horizontal length of the shortest run of black pixels along the left or right edge of an inverse zone.
Top
See Also

Reference

InverseTextOptions Class
Accusoft.ScanFixXpressSdk Namespace


InverseTextOptions Constructor

Accusoft.ScanFixXpress8.Net
InverseTextOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > InverseTextOptions Class : InverseTextOptions Constructor
Overload List
Overload | Description
InverseTextOptions Constructor() | Instantiates a new InverseTextOptions object, setting default values for the options.
InverseTextOptions Constructor(Int32,Int32,Int32) | Instantiates a new InverseTextOptions object, setting the specified values for the options.
See Also

Reference

InverseTextOptions Class
InverseTextOptions Members


InverseTextOptions Constructor()

Accusoft.ScanFixXpress8.Net
InverseTextOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > InverseTextOptions Class > InverseTextOptions Constructor : InverseTextOptions Constructor()
Instantiates a new InverseTextOptions object, setting default values for the options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New()
'Usage

Dim instance As New InverseTextOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public InverseTextOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: InverseTextOptions();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
InverseTextOptions();
See Also

Reference

InverseTextOptions Class
InverseTextOptions Members
Overload List


InverseTextOptions Constructor(Int32,Int32,Int32)

Accusoft.ScanFixXpress8.Net
InverseTextOptions Constructor(Int32,Int32,Int32)

Accusoft.ScanFixXpressSdk Namespace > InverseTextOptions Class > InverseTextOptions Constructor : InverseTextOptions Constructor(Int32,Int32,Int32)
The minimum width, in pixels, of the smallest expected zone of inverse text.
The minimum height, in pixels, of the smallest expected zone of inverse text.
The minimum horizontal length of the shortest run of black pixels along the left or right edge of an inverse zone.
Instantiates a new InverseTextOptions object, setting the specified values for the options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal minimumAreaWidth As Integer, _
   ByVal minimumAreaHeight As Integer, _
   ByVal minimumBlankOnEdges As Integer _
)
'Usage

Dim minimumAreaWidth As Integer
Dim minimumAreaHeight As Integer
Dim minimumBlankOnEdges As Integer

Dim instance As New InverseTextOptions(minimumAreaWidth, minimumAreaHeight, minimumBlankOnEdges)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public InverseTextOptions(
   int minimumAreaWidth,
   int minimumAreaHeight,
   int minimumBlankOnEdges
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: InverseTextOptions(
   int minimumAreaWidth,
   int minimumAreaHeight,
   int minimumBlankOnEdges
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
InverseTextOptions(
   int minimumAreaWidth,
   int minimumAreaHeight,
   int minimumBlankOnEdges
)

Parameters

minimumAreaWidth
The minimum width, in pixels, of the smallest expected zone of inverse text.
minimumAreaHeight
The minimum height, in pixels, of the smallest expected zone of inverse text.
minimumBlankOnEdges
The minimum horizontal length of the shortest run of black pixels along the left or right edge of an inverse zone.
Remarks
Use this constructor to initialize the options to the desired values when creating the object.
See Also

Reference

InverseTextOptions Class
InverseTextOptions Members
Overload List


MinimumAreaHeight Property (InverseTextOptions)

Accusoft.ScanFixXpress8.Net
MinimumAreaHeight Property (InverseTextOptions)

Accusoft.ScanFixXpressSdk Namespace > InverseTextOptions Class : MinimumAreaHeight Property
Gets and sets the minimum height, in pixels, of the smallest expected zone of inverse text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumAreaHeight As Integer
'Usage

Dim instance As InverseTextOptions
Dim value As Integer

instance.MinimumAreaHeight = value

value = instance.MinimumAreaHeight
public int MinimumAreaHeight {get; set;}
public: __property int get_MinimumAreaHeight();
public: __property void set_MinimumAreaHeight(
   int value
);
public:
property int MinimumAreaHeight {
   int get();
   void set (    int value);
}
Remarks

The default value is 50.

Valid values are 1 to 20000.

See Also

Reference

InverseTextOptions Class
InverseTextOptions Members


MinimumAreaWidth Property (InverseTextOptions)

Accusoft.ScanFixXpress8.Net
MinimumAreaWidth Property (InverseTextOptions)

Accusoft.ScanFixXpressSdk Namespace > InverseTextOptions Class : MinimumAreaWidth Property
Gets and sets the minimum width, in pixels, of the smallest expected zone of inverse text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumAreaWidth As Integer
'Usage

Dim instance As InverseTextOptions
Dim value As Integer

instance.MinimumAreaWidth = value

value = instance.MinimumAreaWidth
public int MinimumAreaWidth {get; set;}
public: __property int get_MinimumAreaWidth();
public: __property void set_MinimumAreaWidth(
   int value
);
public:
property int MinimumAreaWidth {
   int get();
   void set (    int value);
}
Remarks

The default value is 300.

Valid values are 1 to 20000.

See Also

Reference

InverseTextOptions Class
InverseTextOptions Members


MinimumBlankOnEdges Property

Accusoft.ScanFixXpress8.Net
MinimumBlankOnEdges Property

Accusoft.ScanFixXpressSdk Namespace > InverseTextOptions Class : MinimumBlankOnEdges Property
Gets and sets the minimum horizontal length of the shortest run of black pixels along the left or right edge of an inverse zone.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumBlankOnEdges As Integer
'Usage

Dim instance As InverseTextOptions
Dim value As Integer

instance.MinimumBlankOnEdges = value

value = instance.MinimumBlankOnEdges
public int MinimumBlankOnEdges {get; set;}
public: __property int get_MinimumBlankOnEdges();
public: __property void set_MinimumBlankOnEdges(
   int value
);
public:
property int MinimumBlankOnEdges {
   int get();
   void set (    int value);
}
Remarks

The default value is 10.

Valid values are 1 to 100.

See Also

Reference

InverseTextOptions Class
InverseTextOptions Members


InverseTextResults Class

Accusoft.ScanFixXpress8.Net
InverseTextResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : InverseTextResults Class
Contains output values from the inverse text removal process.
Object Model
InverseTextResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class InverseTextResults
   Inherits EnhancementResult
'Usage

Dim instance As InverseTextResults
public class InverseTextResults : EnhancementResult
public __gc class InverseTextResults : public EnhancementResult
public ref class InverseTextResults : public EnhancementResult
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.InverseTextResults

See Also

Reference

InverseTextResults Members
Accusoft.ScanFixXpressSdk Namespace


InverseTextResults Class Members

Accusoft.ScanFixXpress8.Net
InverseTextResults Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : InverseTextResults Class

The following tables list the members exposed by InverseTextResults.

Public Properties
 | Name | Description
Public Property | CountOfAreasFound | Gets the number of inverse text areas found and removed.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified during the inverse text removal process.
Top
See Also

Reference

InverseTextResults Class
Accusoft.ScanFixXpressSdk Namespace


InverseTextResults Class Properties

Accusoft.ScanFixXpress8.Net
InverseTextResults Class Properties

Accusoft.ScanFixXpressSdk Namespace : InverseTextResults Class

For a list of all members of this type, see InverseTextResults members.

Public Properties
 | Name | Description
Public Property | CountOfAreasFound | Gets the number of inverse text areas found and removed.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified during the inverse text removal process.
Top
See Also

Reference

InverseTextResults Class
Accusoft.ScanFixXpressSdk Namespace


CountOfAreasFound Property (InverseTextResults)

Accusoft.ScanFixXpress8.Net
CountOfAreasFound Property (InverseTextResults)

Accusoft.ScanFixXpressSdk Namespace > InverseTextResults Class : CountOfAreasFound Property
Gets the number of inverse text areas found and removed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CountOfAreasFound As Integer
'Usage

Dim instance As InverseTextResults
Dim value As Integer

value = instance.CountOfAreasFound
public int CountOfAreasFound {get;}
public: __property int get_CountOfAreasFound();
public:
property int CountOfAreasFound {
   int get();
}

Property Value

An integer representing the number of dot shading areas removed.
See Also

Reference

InverseTextResults Class
InverseTextResults Members


ImageWasModified Property (InverseTextResults)

Accusoft.ScanFixXpress8.Net
ImageWasModified Property (InverseTextResults)

Accusoft.ScanFixXpressSdk Namespace > InverseTextResults Class : ImageWasModified Property
Gets a flag that indicates whether the image was modified during the inverse text removal process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageWasModified As Boolean
'Usage

Dim instance As InverseTextResults
Dim value As Boolean

value = instance.ImageWasModified
public bool ImageWasModified {get;}
public: __property bool get_ImageWasModified();
public:
property bool ImageWasModified {
   bool get();
}

Property Value

A boolean value which is True if the image was modified. Otherwise, False is returned.
See Also

Reference

InverseTextResults Class
InverseTextResults Members


Licensing Class

Accusoft.ScanFixXpress8.Net
Licensing Class
Members

Accusoft.ScanFixXpressSdk Namespace : Licensing Class
Validates and manages the license for the ScanFix Xpress SDK.
Object Model
Licensing Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class Licensing
'Usage

Dim instance As Licensing
public class Licensing
public __gc class Licensing
public ref class Licensing
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.Licensing

See Also

Reference

Licensing Members
Accusoft.ScanFixXpressSdk Namespace


Licensing Class Members

Accusoft.ScanFixXpress8.Net
Licensing Class Members
Properties Methods

Accusoft.ScanFixXpressSdk Namespace : Licensing Class

The following tables list the members exposed by Licensing.

Public Properties
 | Name | Description
Public Property | EvaluationMode | Gets or sets the evaluation mode
Top
Public Methods
 | Name | Description
Public Method | SetOEMLicenseKey | Set the Scanfix control runtime OEM license key. This is required for User Platinum licensing. The OEM licensing key is provided in the purchase confirmation email of Platinum licenses.
Public Method | SetSolutionKey | Set the Scanfix control runtime license deployment key. The four long integers are provided in the puchase confirmation email of runtime license(s).
Public Method | SetSolutionName | Set the Scanfix Xpress control runtime license deployment solution name. The solution name is provided in the purchase confirmation email of runtime license(s).
Top
See Also

Reference

Licensing Class
Accusoft.ScanFixXpressSdk Namespace


Licensing Class Properties

Accusoft.ScanFixXpress8.Net
Licensing Class Properties

Accusoft.ScanFixXpressSdk Namespace : Licensing Class

For a list of all members of this type, see Licensing members.

Public Properties
 | Name | Description
Public Property | EvaluationMode | Gets or sets the evaluation mode
Top
See Also

Reference

Licensing Class
Accusoft.ScanFixXpressSdk Namespace


Licensing Class Methods

Accusoft.ScanFixXpress8.Net
Licensing Class Methods

Accusoft.ScanFixXpressSdk Namespace : Licensing Class

For a list of all members of this type, see Licensing members.

Public Methods
 | Name | Description
Public Method | SetOEMLicenseKey | Set the Scanfix control runtime OEM license key. This is required for User Platinum licensing. The OEM licensing key is provided in the purchase confirmation email of Platinum licenses.
Public Method | SetSolutionKey | Set the Scanfix control runtime license deployment key. The four long integers are provided in the puchase confirmation email of runtime license(s).
Public Method | SetSolutionName | Set the Scanfix Xpress control runtime license deployment solution name. The solution name is provided in the purchase confirmation email of runtime license(s).
Top
See Also

Reference

Licensing Class
Accusoft.ScanFixXpressSdk Namespace


SetOEMLicenseKey Method

Accusoft.ScanFixXpress8.Net
SetOEMLicenseKey Method

Accusoft.ScanFixXpressSdk Namespace > Licensing Class : SetOEMLicenseKey Method
The string needed to license ScanFix in a non-node locked fashion.
Set the Scanfix control runtime OEM license key. This is required for User Platinum licensing. The OEM licensing key is provided in the purchase confirmation email of Platinum licenses.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Sub SetOEMLicenseKey( _
   ByVal oemKey As String _
)
'Usage

Dim instance As Licensing
Dim oemKey As String

instance.SetOEMLicenseKey(oemKey)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void SetOEMLicenseKey(
   string oemKey
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void SetOEMLicenseKey(
   string* oemKey
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void SetOEMLicenseKey(
   String^ oemKey
)

Parameters

oemKey
The string needed to license ScanFix in a non-node locked fashion.
See Also

Reference

Licensing Class
Licensing Members


SetSolutionKey Method

Accusoft.ScanFixXpress8.Net
SetSolutionKey Method

Accusoft.ScanFixXpressSdk Namespace > Licensing Class : SetSolutionKey Method
Solution key 1
Solution key 2
Solution key 3
Solution key 4
Set the Scanfix control runtime license deployment key. The four long integers are provided in the puchase confirmation email of runtime license(s).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Sub SetSolutionKey( _
   ByVal code1 As Long, _
   ByVal code2 As Long, _
   ByVal code3 As Long, _
   ByVal code4 As Long _
)
'Usage

Dim instance As Licensing
Dim code1 As Long
Dim code2 As Long
Dim code3 As Long
Dim code4 As Long

instance.SetSolutionKey(code1, code2, code3, code4)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void SetSolutionKey(
   long code1,
   long code2,
   long code3,
   long code4
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void SetSolutionKey(
   long code1,
   long code2,
   long code3,
   long code4
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void SetSolutionKey(
   int64 code1,
   int64 code2,
   int64 code3,
   int64 code4
)

Parameters

code1
Solution key 1
code2
Solution key 2
code3
Solution key 3
code4
Solution key 4
See Also

Reference

Licensing Class
Licensing Members


SetSolutionName Method

Accusoft.ScanFixXpress8.Net
SetSolutionName Method

Accusoft.ScanFixXpressSdk Namespace > Licensing Class : SetSolutionName Method
The string representing solution name provided after purchasing runtime license.
Set the Scanfix Xpress control runtime license deployment solution name. The solution name is provided in the purchase confirmation email of runtime license(s).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Sub SetSolutionName( _
   ByVal solutionName As String _
)
'Usage

Dim instance As Licensing
Dim solutionName As String

instance.SetSolutionName(solutionName)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void SetSolutionName(
   string solutionName
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void SetSolutionName(
   string* solutionName
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void SetSolutionName(
   String^ solutionName
)

Parameters

solutionName
The string representing solution name provided after purchasing runtime license.
See Also

Reference

Licensing Class
Licensing Members


EvaluationMode Property

Accusoft.ScanFixXpress8.Net
EvaluationMode Property

Accusoft.ScanFixXpressSdk Namespace > Licensing Class : EvaluationMode Property
Gets or sets the evaluation mode
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EvaluationMode As EvaluationChoice
'Usage

Dim instance As Licensing
Dim value As EvaluationChoice

instance.EvaluationMode = value

value = instance.EvaluationMode
public EvaluationChoice EvaluationMode {get; set;}
public: __property EvaluationChoice get_EvaluationMode();
public: __property void set_EvaluationMode(
   EvaluationChoice value
);
public:
property EvaluationChoice EvaluationMode {
   EvaluationChoice get();
   void set (    EvaluationChoice value);
}
See Also

Reference

Licensing Class
Licensing Members


LineRemovalOptions Class

Accusoft.ScanFixXpress8.Net
LineRemovalOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : LineRemovalOptions Class
Contains parameters that control the ScanFix.RemoveLines process.
Object Model
LineRemovalOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class LineRemovalOptions
   Inherits EnhancementOption
'Usage

Dim instance As LineRemovalOptions
public class LineRemovalOptions : EnhancementOption
public __gc class LineRemovalOptions : public EnhancementOption
public ref class LineRemovalOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.LineRemovalOptions

See Also

Reference

LineRemovalOptions Members
Accusoft.ScanFixXpressSdk Namespace


LineRemovalOptions Class Members

Accusoft.ScanFixXpress8.Net
LineRemovalOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : LineRemovalOptions Class

The following tables list the members exposed by LineRemovalOptions.

Public Constructors
 | Name | Description
Public Constructor | LineRemovalOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | MaximumCharacterRepairSize | Gets and sets the maximum size for character repair after line removal.
Public Property | MaximumGap | Gets and sets the maximum allowed gap in a line for the line to still be considered one object.
Public Property | MaximumThickness | Gets and sets the maximum thickness, in pixels, a line can have to meet the removal criteria.
Public Property | MinimumAspectRatio | Gets and sets the ratio of the line length to the line width (i.e., length / width).
Public Property | MinimumHorizontalLength | Gets and sets the minimum length, in pixels, a horizontal line can be to meet the removal criteria.
Public Property | MinimumLength | Gets and sets the minimum length, in pixels, a line can be to meet the removal criteria.
Public Property | MinimumVerticalLength | Gets and sets the minimum length, in pixels, a vertical line can be to meet the removal criteria.
Top
See Also

Reference

LineRemovalOptions Class
Accusoft.ScanFixXpressSdk Namespace


LineRemovalOptions Class Properties

Accusoft.ScanFixXpress8.Net
LineRemovalOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : LineRemovalOptions Class

For a list of all members of this type, see LineRemovalOptions members.

Public Properties
 | Name | Description
Public Property | MaximumCharacterRepairSize | Gets and sets the maximum size for character repair after line removal.
Public Property | MaximumGap | Gets and sets the maximum allowed gap in a line for the line to still be considered one object.
Public Property | MaximumThickness | Gets and sets the maximum thickness, in pixels, a line can have to meet the removal criteria.
Public Property | MinimumAspectRatio | Gets and sets the ratio of the line length to the line width (i.e., length / width).
Public Property | MinimumHorizontalLength | Gets and sets the minimum length, in pixels, a horizontal line can be to meet the removal criteria.
Public Property | MinimumLength | Gets and sets the minimum length, in pixels, a line can be to meet the removal criteria.
Public Property | MinimumVerticalLength | Gets and sets the minimum length, in pixels, a vertical line can be to meet the removal criteria.
Top
See Also

Reference

LineRemovalOptions Class
Accusoft.ScanFixXpressSdk Namespace


LineRemovalOptions Constructor

Accusoft.ScanFixXpress8.Net
LineRemovalOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > LineRemovalOptions Class : LineRemovalOptions Constructor
Overload List
Overload | Description
LineRemovalOptions Constructor() | Instantiates a new LineRemovalOptions object setting the default values.
LineRemovalOptions Constructor(Int32,Int32,Double,Int32,Int32) | Instantiates a new LineRemovalOptions object setting the specified values.
See Also

Reference

LineRemovalOptions Class
LineRemovalOptions Members


LineRemovalOptions Constructor()

Accusoft.ScanFixXpress8.Net
LineRemovalOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > LineRemovalOptions Class > LineRemovalOptions Constructor : LineRemovalOptions Constructor()
Instantiates a new LineRemovalOptions object setting the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New LineRemovalOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public LineRemovalOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: LineRemovalOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
LineRemovalOptions();
See Also

Reference

LineRemovalOptions Class
LineRemovalOptions Members
Overload List


LineRemovalOptions Constructor(Int32,Int32,Double,Int32,Int32)

Accusoft.ScanFixXpress8.Net
LineRemovalOptions Constructor(Int32,Int32,Double,Int32,Int32)

Accusoft.ScanFixXpressSdk Namespace > LineRemovalOptions Class > LineRemovalOptions Constructor : LineRemovalOptions Constructor(Int32,Int32,Double,Int32,Int32)
The minimum length, in pixels, a line can be to meet the removal criteria. Valid values are in the range 10 to 20000. The default value is 50.
The maximum thickness, in pixels, a line can have to meet the removal criteria. Valid values are in the range of 0 to 50. The default value is 20.
The ratio of the line length to the line width (i.e., length / width). Lines below this aspect ratio will not be removed. The value range is any floating point number between 1 and 1000. The default value is 10.0. This provides a range of 10 pixels long for every one pixel wide.
The maximum allowed gap in a line for the line to still be considered one object. Valid values are in the range 0 to 20. The default value is 1.
Will reconstruct intersected characters within the given size after performing line removal. Valid values are in the range 0 to 100. The default value is 20.
Instantiates a new LineRemovalOptions object setting the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal minimumLength As Integer, _
   ByVal maximumThickness As Integer, _
   ByVal minimumAspectRatio As Double, _
   ByVal maximumGap As Integer, _
   ByVal maximumCharacterRepairSize As Integer _
)
'Usage

Dim minimumLength As Integer
Dim maximumThickness As Integer
Dim minimumAspectRatio As Double
Dim maximumGap As Integer
Dim maximumCharacterRepairSize As Integer

Dim instance As New LineRemovalOptions(minimumLength, maximumThickness, minimumAspectRatio, maximumGap, maximumCharacterRepairSize)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public LineRemovalOptions(
   int minimumLength,
   int maximumThickness,
   double minimumAspectRatio,
   int maximumGap,
   int maximumCharacterRepairSize
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: LineRemovalOptions(
   int minimumLength,
   int maximumThickness,
   double minimumAspectRatio,
   int maximumGap,
   int maximumCharacterRepairSize
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
LineRemovalOptions(
   int minimumLength,
   int maximumThickness,
   double minimumAspectRatio,
   int maximumGap,
   int maximumCharacterRepairSize
)

Parameters

minimumLength
The minimum length, in pixels, a line can be to meet the removal criteria. Valid values are in the range 10 to 20000. The default value is 50.
maximumThickness
The maximum thickness, in pixels, a line can have to meet the removal criteria. Valid values are in the range of 0 to 50. The default value is 20.
minimumAspectRatio
The ratio of the line length to the line width (i.e., length / width). Lines below this aspect ratio will not be removed. The value range is any floating point number between 1 and 1000. The default value is 10.0. This provides a range of 10 pixels long for every one pixel wide.
maximumGap
The maximum allowed gap in a line for the line to still be considered one object. Valid values are in the range 0 to 20. The default value is 1.
maximumCharacterRepairSize
Will reconstruct intersected characters within the given size after performing line removal. Valid values are in the range 0 to 100. The default value is 20.
See Also

Reference

LineRemovalOptions Class
LineRemovalOptions Members
Overload List


MaximumCharacterRepairSize Property

Accusoft.ScanFixXpress8.Net
MaximumCharacterRepairSize Property

Accusoft.ScanFixXpressSdk Namespace > LineRemovalOptions Class : MaximumCharacterRepairSize Property
Gets and sets the maximum size for character repair after line removal.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaximumCharacterRepairSize As Integer
'Usage

Dim instance As LineRemovalOptions
Dim value As Integer

instance.MaximumCharacterRepairSize = value

value = instance.MaximumCharacterRepairSize
public int MaximumCharacterRepairSize {get; set;}
public: __property int get_MaximumCharacterRepairSize();
public: __property void set_MaximumCharacterRepairSize(
   int value
);
public:
property int MaximumCharacterRepairSize {
   int get();
   void set (    int value);
}
Remarks

The default value is 20.

Valid values are 0 to 100.

See Also

Reference

LineRemovalOptions Class
LineRemovalOptions Members


MaximumGap Property

Accusoft.ScanFixXpress8.Net
MaximumGap Property

Accusoft.ScanFixXpressSdk Namespace > LineRemovalOptions Class : MaximumGap Property
Gets and sets the maximum allowed gap in a line for the line to still be considered one object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaximumGap As Integer
'Usage

Dim instance As LineRemovalOptions
Dim value As Integer

instance.MaximumGap = value

value = instance.MaximumGap
public int MaximumGap {get; set;}
public: __property int get_MaximumGap();
public: __property void set_MaximumGap(
   int value
);
public:
property int MaximumGap {
   int get();
   void set (    int value);
}
Remarks

The default value is 1.

Valid values are 0 to 20.

See Also

Reference

LineRemovalOptions Class
LineRemovalOptions Members


MaximumThickness Property

Accusoft.ScanFixXpress8.Net
MaximumThickness Property

Accusoft.ScanFixXpressSdk Namespace > LineRemovalOptions Class : MaximumThickness Property
Gets and sets the maximum thickness, in pixels, a line can have to meet the removal criteria.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaximumThickness As Integer
'Usage

Dim instance As LineRemovalOptions
Dim value As Integer

instance.MaximumThickness = value

value = instance.MaximumThickness
public int MaximumThickness {get; set;}
public: __property int get_MaximumThickness();
public: __property void set_MaximumThickness(
   int value
);
public:
property int MaximumThickness {
   int get();
   void set (    int value);
}
Remarks

The default value is 20.

Valid values are 0 to 50.

See Also

Reference

LineRemovalOptions Class
LineRemovalOptions Members


MinimumAspectRatio Property

Accusoft.ScanFixXpress8.Net
MinimumAspectRatio Property

Accusoft.ScanFixXpressSdk Namespace > LineRemovalOptions Class : MinimumAspectRatio Property
Gets and sets the ratio of the line length to the line width (i.e., length / width).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumAspectRatio As Double
'Usage

Dim instance As LineRemovalOptions
Dim value As Double

instance.MinimumAspectRatio = value

value = instance.MinimumAspectRatio
public double MinimumAspectRatio {get; set;}
public: __property double get_MinimumAspectRatio();
public: __property void set_MinimumAspectRatio(
   double value
);
public:
property double MinimumAspectRatio {
   double get();
   void set (    double value);
}
Remarks

The default value is 10.0

Valid values are 1.0 to 1000.0. This provides a range of 10 pixels long for every one pixel wide.

Lines below this aspect ratio will not be removed.

See Also

Reference

LineRemovalOptions Class
LineRemovalOptions Members


MinimumHorizontalLength Property

Accusoft.ScanFixXpress8.Net
MinimumHorizontalLength Property

Accusoft.ScanFixXpressSdk Namespace > LineRemovalOptions Class : MinimumHorizontalLength Property
Gets and sets the minimum length, in pixels, a horizontal line can be to meet the removal criteria.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumHorizontalLength As Integer
'Usage

Dim instance As LineRemovalOptions
Dim value As Integer

instance.MinimumHorizontalLength = value

value = instance.MinimumHorizontalLength
public int MinimumHorizontalLength {get; set;}
public: __property int get_MinimumHorizontalLength();
public: __property void set_MinimumHorizontalLength(
   int value
);
public:
property int MinimumHorizontalLength {
   int get();
   void set (    int value);
}
Remarks

The default value is 50.

Valid values are 0 to 20000.

Horizontal lines that have lengths greater than or equal to this value will be removed. Any horizontal line smaller than this value, will not be removed.

Note: This parameter is very sensitive to the image resolution and should generally be thought of in inches. If the value is set too low, this operation will begin to remove parts of characters. This value should be set larger than the width of text character because of this.

See Also

Reference

LineRemovalOptions Class
LineRemovalOptions Members


MinimumLength Property

Accusoft.ScanFixXpress8.Net
MinimumLength Property

Accusoft.ScanFixXpressSdk Namespace > LineRemovalOptions Class : MinimumLength Property
Gets and sets the minimum length, in pixels, a line can be to meet the removal criteria.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumLength As Integer
'Usage

Dim instance As LineRemovalOptions
Dim value As Integer

instance.MinimumLength = value

value = instance.MinimumLength
public int MinimumLength {get; set;}
public: __property int get_MinimumLength();
public: __property void set_MinimumLength(
   int value
);
public:
property int MinimumLength {
   int get();
   void set (    int value);
}
Remarks

The default value is 50.

Valid values are 0 to 20000.

Lines that have lengths greater than or equal to this value will be removed. Any line smaller than this value, will not be removed.

This property sets both the MinimumHorizontalLength and MinimumVerticalLength to a single specified value. In the case that the MinimumHorizontalLength and MinimumVerticalLength have been set to different values, this will return the average of the two.

Note: This parameter is very sensitive to the image resolution and should generally be thought of in inches. If the value is set too low, this operation will begin to remove parts of characters. This value should be set larger than the width of text character because of this.

See Also

Reference

LineRemovalOptions Class
LineRemovalOptions Members


MinimumVerticalLength Property

Accusoft.ScanFixXpress8.Net
MinimumVerticalLength Property

Accusoft.ScanFixXpressSdk Namespace > LineRemovalOptions Class : MinimumVerticalLength Property
Gets and sets the minimum length, in pixels, a vertical line can be to meet the removal criteria.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumVerticalLength As Integer
'Usage

Dim instance As LineRemovalOptions
Dim value As Integer

instance.MinimumVerticalLength = value

value = instance.MinimumVerticalLength
public int MinimumVerticalLength {get; set;}
public: __property int get_MinimumVerticalLength();
public: __property void set_MinimumVerticalLength(
   int value
);
public:
property int MinimumVerticalLength {
   int get();
   void set (    int value);
}
Remarks

The default value is 50.

Valid values are 0 to 20000.

Vertical lines that have lengths greater than or equal to this value will be removed. Any vertical line smaller than this value, will not be removed.

Note: This parameter is very sensitive to the image resolution and should generally be thought of in inches. If the value is set too low, this operation will begin to remove parts of characters. This value should be set larger than the height of text character because of this.

See Also

Reference

LineRemovalOptions Class
LineRemovalOptions Members


LineRemovalResults Class

Accusoft.ScanFixXpress8.Net
LineRemovalResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : LineRemovalResults Class
Contains output values from the line removal process.
Object Model
LineRemovalResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class LineRemovalResults
   Inherits EnhancementResult
'Usage

Dim instance As LineRemovalResults
public class LineRemovalResults : EnhancementResult
public __gc class LineRemovalResults : public EnhancementResult
public ref class LineRemovalResults : public EnhancementResult
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.LineRemovalResults

See Also

Reference

LineRemovalResults Members
Accusoft.ScanFixXpressSdk Namespace


LineRemovalResults Class Members

Accusoft.ScanFixXpress8.Net
LineRemovalResults Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : LineRemovalResults Class

The following tables list the members exposed by LineRemovalResults.

Public Properties
 | Name | Description
Public Property | CountOfLinesFound | Gets count of the lines meeting the given criteria that were found on the image.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified to remove lines.
Top
See Also

Reference

LineRemovalResults Class
Accusoft.ScanFixXpressSdk Namespace


LineRemovalResults Class Properties

Accusoft.ScanFixXpress8.Net
LineRemovalResults Class Properties

Accusoft.ScanFixXpressSdk Namespace : LineRemovalResults Class

For a list of all members of this type, see LineRemovalResults members.

Public Properties
 | Name | Description
Public Property | CountOfLinesFound | Gets count of the lines meeting the given criteria that were found on the image.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was modified to remove lines.
Top
See Also

Reference

LineRemovalResults Class
Accusoft.ScanFixXpressSdk Namespace


CountOfLinesFound Property

Accusoft.ScanFixXpress8.Net
CountOfLinesFound Property

Accusoft.ScanFixXpressSdk Namespace > LineRemovalResults Class : CountOfLinesFound Property
Gets count of the lines meeting the given criteria that were found on the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CountOfLinesFound As Integer
'Usage

Dim instance As LineRemovalResults
Dim value As Integer

value = instance.CountOfLinesFound
public int CountOfLinesFound {get;}
public: __property int get_CountOfLinesFound();
public:
property int CountOfLinesFound {
   int get();
}

Property Value

An integer value which indicates the number of lines removed.
See Also

Reference

LineRemovalResults Class
LineRemovalResults Members


ImageWasModified Property (LineRemovalResults)

Accusoft.ScanFixXpress8.Net
ImageWasModified Property (LineRemovalResults)

Accusoft.ScanFixXpressSdk Namespace > LineRemovalResults Class : ImageWasModified Property
Gets a flag that indicates whether the image was modified to remove lines.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageWasModified As Boolean
'Usage

Dim instance As LineRemovalResults
Dim value As Boolean

value = instance.ImageWasModified
public bool ImageWasModified {get;}
public: __property bool get_ImageWasModified();
public:
property bool ImageWasModified {
   bool get();
}

Property Value

A boolean value which is True if the image was modified. Otherwise, False is returned.
Remarks

The default value is True.

When the CountOfLinesFound property value is 0, this property will return False.

See Also

Reference

LineRemovalResults Class
LineRemovalResults Members


MirrorOptions Class

Accusoft.ScanFixXpress8.Net
MirrorOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : MirrorOptions Class
Defines a place holder class for the Mirror image enhancement. This class does not contain any parameters to control the ScanFix.Mirror process.
Object Model
MirrorOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class MirrorOptions
   Inherits EnhancementOption
'Usage

Dim instance As MirrorOptions
public class MirrorOptions : EnhancementOption
public __gc class MirrorOptions : public EnhancementOption
public ref class MirrorOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.MirrorOptions

See Also

Reference

MirrorOptions Members
Accusoft.ScanFixXpressSdk Namespace


MirrorOptions Class Members

Accusoft.ScanFixXpress8.Net
MirrorOptions Class Members

Accusoft.ScanFixXpressSdk Namespace : MirrorOptions Class

The following tables list the members exposed by MirrorOptions.

Public Constructors
 | Name | Description
Public Constructor | MirrorOptions Constructor | Instantiates a new MirrorOptions object.
Top
See Also

Reference

MirrorOptions Class
Accusoft.ScanFixXpressSdk Namespace


MirrorOptions Constructor

Accusoft.ScanFixXpress8.Net
MirrorOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > MirrorOptions Class : MirrorOptions Constructor
Instantiates a new MirrorOptions object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New()
'Usage

Dim instance As New MirrorOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public MirrorOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: MirrorOptions();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
MirrorOptions();
See Also

Reference

MirrorOptions Class
MirrorOptions Members


MirrorResults Class

Accusoft.ScanFixXpress8.Net
MirrorResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : MirrorResults Class
Defines a place holder class for the Mirror enhancement result.
Object Model
MirrorResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class MirrorResults
   Inherits EnhancementResult
'Usage

Dim instance As MirrorResults
public class MirrorResults : EnhancementResult
public __gc class MirrorResults : public EnhancementResult
public ref class MirrorResults : public EnhancementResult
Remarks
This class contains no data. Its presence in the results list is used to determine that the operation has run successfully.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.MirrorResults

See Also

Reference

MirrorResults Members
Accusoft.ScanFixXpressSdk Namespace


MirrorResults Class Members

Accusoft.ScanFixXpress8.Net
MirrorResults Class Members

Accusoft.ScanFixXpressSdk Namespace : MirrorResults Class

The following tables list the members exposed by MirrorResults.

See Also

Reference

MirrorResults Class
Accusoft.ScanFixXpressSdk Namespace


NegateOptions Class

Accusoft.ScanFixXpress8.Net
NegateOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : NegateOptions Class
Defines a place holder class for the Negate image enhancement. This class does not contain any parameters to control the ScanFix.Negate process.
Object Model
NegateOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class NegateOptions
   Inherits EnhancementOption
'Usage

Dim instance As NegateOptions
public class NegateOptions : EnhancementOption
public __gc class NegateOptions : public EnhancementOption
public ref class NegateOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.NegateOptions

See Also

Reference

NegateOptions Members
Accusoft.ScanFixXpressSdk Namespace


NegateOptions Class Members

Accusoft.ScanFixXpress8.Net
NegateOptions Class Members

Accusoft.ScanFixXpressSdk Namespace : NegateOptions Class

The following tables list the members exposed by NegateOptions.

Public Constructors
 | Name | Description
Public Constructor | NegateOptions Constructor | Instantiates a new NegateOptions object.
Top
See Also

Reference

NegateOptions Class
Accusoft.ScanFixXpressSdk Namespace


NegateOptions Constructor

Accusoft.ScanFixXpress8.Net
NegateOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > NegateOptions Class : NegateOptions Constructor
Instantiates a new NegateOptions object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New NegateOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public NegateOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: NegateOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
NegateOptions();
See Also

Reference

NegateOptions Class
NegateOptions Members


NegateResults Class

Accusoft.ScanFixXpress8.Net
NegateResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : NegateResults Class
Defines a place holder class for the Negate enhancement result.
Object Model
NegateResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class NegateResults
   Inherits EnhancementResult
'Usage

Dim instance As NegateResults
public class NegateResults : EnhancementResult
public __gc class NegateResults : public EnhancementResult
public ref class NegateResults : public EnhancementResult
Remarks
This class contains no data. Its presence in the results list is used to determine that the operation has run successfully.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.NegateResults

See Also

Reference

NegateResults Members
Accusoft.ScanFixXpressSdk Namespace


NegateResults Class Members

Accusoft.ScanFixXpress8.Net
NegateResults Class Members

Accusoft.ScanFixXpressSdk Namespace : NegateResults Class

The following tables list the members exposed by NegateResults.

See Also

Reference

NegateResults Class
Accusoft.ScanFixXpressSdk Namespace


NegativeCorrectionOptions Class

Accusoft.ScanFixXpress8.Net
NegativeCorrectionOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : NegativeCorrectionOptions Class
Contains parameters for the ScanFix.CorrectNegativePage process.
Object Model
NegativeCorrectionOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class NegativeCorrectionOptions
   Inherits EnhancementOption
'Usage

Dim instance As NegativeCorrectionOptions
public class NegativeCorrectionOptions : EnhancementOption
public __gc class NegativeCorrectionOptions : public EnhancementOption
public ref class NegativeCorrectionOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.NegativeCorrectionOptions

See Also

Reference

NegativeCorrectionOptions Members
Accusoft.ScanFixXpressSdk Namespace


NegativeCorrectionOptions Class Members

Accusoft.ScanFixXpress8.Net
NegativeCorrectionOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : NegativeCorrectionOptions Class

The following tables list the members exposed by NegativeCorrectionOptions.

Public Constructors
 | Name | Description
Public Constructor | NegativeCorrectionOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ApplyCorrection | Gets and sets a flag to indicate whether negative images should be automatically corrected.
Public Property | MinimumConfidence | Gets and sets the minimum detection confidence required before correction will proceed.
Public Property | Quality | Gets and sets a value that indicates the amount of effort to expend analyzing the image to determine if it is a negative.
Top
See Also

Reference

NegativeCorrectionOptions Class
Accusoft.ScanFixXpressSdk Namespace


NegativeCorrectionOptions Class Properties

Accusoft.ScanFixXpress8.Net
NegativeCorrectionOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : NegativeCorrectionOptions Class

For a list of all members of this type, see NegativeCorrectionOptions members.

Public Properties
 | Name | Description
Public Property | ApplyCorrection | Gets and sets a flag to indicate whether negative images should be automatically corrected.
Public Property | MinimumConfidence | Gets and sets the minimum detection confidence required before correction will proceed.
Public Property | Quality | Gets and sets a value that indicates the amount of effort to expend analyzing the image to determine if it is a negative.
Top
See Also

Reference

NegativeCorrectionOptions Class
Accusoft.ScanFixXpressSdk Namespace


NegativeCorrectionOptions Constructor

Accusoft.ScanFixXpress8.Net
NegativeCorrectionOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > NegativeCorrectionOptions Class : NegativeCorrectionOptions Constructor
Overload List
Overload | Description
NegativeCorrectionOptions Constructor() | Instantiates a new NegativeCorrectionOptions object.
NegativeCorrectionOptions Constructor(Boolean,Int32,Int32) | Instantiates a new NegativeCorrectionOptions object with the specified values.
See Also

Reference

NegativeCorrectionOptions Class
NegativeCorrectionOptions Members


NegativeCorrectionOptions Constructor()

Accusoft.ScanFixXpress8.Net
NegativeCorrectionOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > NegativeCorrectionOptions Class > NegativeCorrectionOptions Constructor : NegativeCorrectionOptions Constructor()
Instantiates a new NegativeCorrectionOptions object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New NegativeCorrectionOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public NegativeCorrectionOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: NegativeCorrectionOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
NegativeCorrectionOptions();
See Also

Reference

NegativeCorrectionOptions Class
NegativeCorrectionOptions Members
Overload List


NegativeCorrectionOptions Constructor(Boolean,Int32,Int32)

Accusoft.ScanFixXpress8.Net
NegativeCorrectionOptions Constructor(Boolean,Int32,Int32)

Accusoft.ScanFixXpressSdk Namespace > NegativeCorrectionOptions Class > NegativeCorrectionOptions Constructor : NegativeCorrectionOptions Constructor(Boolean,Int32,Int32)
A flag to indicate whether negative images should be automatically corrected.
A value that indicates the amount of effort to expend analyzing the image to determine if it is a negative.
The minimum detection confidence required before correction will proceed.
Instantiates a new NegativeCorrectionOptions object with the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New( _
   ByVal applyCorrection As Boolean, _
   ByVal quality As Integer, _
   ByVal minimumConfidence As Integer _
)
'Usage

Dim applyCorrection As Boolean
Dim quality As Integer
Dim minimumConfidence As Integer

Dim instance As New NegativeCorrectionOptions(applyCorrection, quality, minimumConfidence)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public NegativeCorrectionOptions(
   bool applyCorrection,
   int quality,
   int minimumConfidence
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: NegativeCorrectionOptions(
   bool applyCorrection,
   int quality,
   int minimumConfidence
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
NegativeCorrectionOptions(
   bool applyCorrection,
   int quality,
   int minimumConfidence
)

Parameters

applyCorrection
A flag to indicate whether negative images should be automatically corrected.
quality
A value that indicates the amount of effort to expend analyzing the image to determine if it is a negative.
minimumConfidence
The minimum detection confidence required before correction will proceed.
See Also

Reference

NegativeCorrectionOptions Class
NegativeCorrectionOptions Members
Overload List


ApplyCorrection Property

Accusoft.ScanFixXpress8.Net
ApplyCorrection Property

Accusoft.ScanFixXpressSdk Namespace > NegativeCorrectionOptions Class : ApplyCorrection Property
Gets and sets a flag to indicate whether negative images should be automatically corrected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ApplyCorrection As Boolean
'Usage

Dim instance As NegativeCorrectionOptions
Dim value As Boolean

instance.ApplyCorrection = value

value = instance.ApplyCorrection
public bool ApplyCorrection {get; set;}
public: __property bool get_ApplyCorrection();
public: __property void set_ApplyCorrection(
   bool value
);
public:
property bool ApplyCorrection {
   bool get();
   void set (    bool value);
}
Remarks

The default value is true.

See Also

Reference

NegativeCorrectionOptions Class
NegativeCorrectionOptions Members


MinimumConfidence Property (NegativeCorrectionOptions)

Accusoft.ScanFixXpress8.Net
MinimumConfidence Property (NegativeCorrectionOptions)

Accusoft.ScanFixXpressSdk Namespace > NegativeCorrectionOptions Class : MinimumConfidence Property
Gets and sets the minimum detection confidence required before correction will proceed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumConfidence As Integer
'Usage

Dim instance As NegativeCorrectionOptions
Dim value As Integer

instance.MinimumConfidence = value

value = instance.MinimumConfidence
public int MinimumConfidence {get; set;}
public: __property int get_MinimumConfidence();
public: __property void set_MinimumConfidence(
   int value
);
public:
property int MinimumConfidence {
   int get();
   void set (    int value);
}
Remarks

The default value is 50.

Valid values are 0 to 100.

See Also

Reference

NegativeCorrectionOptions Class
NegativeCorrectionOptions Members


Quality Property (NegativeCorrectionOptions)

Accusoft.ScanFixXpress8.Net
Quality Property (NegativeCorrectionOptions)

Accusoft.ScanFixXpressSdk Namespace > NegativeCorrectionOptions Class : Quality Property
Gets and sets a value that indicates the amount of effort to expend analyzing the image to determine if it is a negative.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Quality As Integer
'Usage

Dim instance As NegativeCorrectionOptions
Dim value As Integer

instance.Quality = value

value = instance.Quality
public int Quality {get; set;}
public: __property int get_Quality();
public: __property void set_Quality(
   int value
);
public:
property int Quality {
   int get();
   void set (    int value);
}
Remarks

The default value is 80.

Valid values are 1 to 100.

See Also

Reference

NegativeCorrectionOptions Class
NegativeCorrectionOptions Members


NegativeCorrectionResults Class

Accusoft.ScanFixXpress8.Net
NegativeCorrectionResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : NegativeCorrectionResults Class
Contains output values from the negative correction process.
Object Model
NegativeCorrectionResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class NegativeCorrectionResults
   Inherits EnhancementResult
'Usage

Dim instance As NegativeCorrectionResults
public class NegativeCorrectionResults : EnhancementResult
public __gc class NegativeCorrectionResults : public EnhancementResult
public ref class NegativeCorrectionResults : public EnhancementResult
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.NegativeCorrectionResults

See Also

Reference

NegativeCorrectionResults Members
Accusoft.ScanFixXpressSdk Namespace


NegativeCorrectionResults Class Members

Accusoft.ScanFixXpress8.Net
NegativeCorrectionResults Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : NegativeCorrectionResults Class

The following tables list the members exposed by NegativeCorrectionResults.

Public Properties
 | Name | Description
Public Property | Confidence | Gets the confidence of the blank page detection process.
Public Property | ImageIsNormal | Gets a flag that indicates whether the image was determined to be a negative or not.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was corrected if a negative was detected.
Top
See Also

Reference

NegativeCorrectionResults Class
Accusoft.ScanFixXpressSdk Namespace


NegativeCorrectionResults Class Properties

Accusoft.ScanFixXpress8.Net
NegativeCorrectionResults Class Properties

Accusoft.ScanFixXpressSdk Namespace : NegativeCorrectionResults Class

For a list of all members of this type, see NegativeCorrectionResults members.

Public Properties
 | Name | Description
Public Property | Confidence | Gets the confidence of the blank page detection process.
Public Property | ImageIsNormal | Gets a flag that indicates whether the image was determined to be a negative or not.
Public Property | ImageWasModified | Gets a flag that indicates whether the image was corrected if a negative was detected.
Top
See Also

Reference

NegativeCorrectionResults Class
Accusoft.ScanFixXpressSdk Namespace


Confidence Property (NegativeCorrectionResults)

Accusoft.ScanFixXpress8.Net
Confidence Property (NegativeCorrectionResults)

Accusoft.ScanFixXpressSdk Namespace > NegativeCorrectionResults Class : Confidence Property
Gets the confidence of the blank page detection process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Confidence As Integer
'Usage

Dim instance As NegativeCorrectionResults
Dim value As Integer

value = instance.Confidence
public int Confidence {get;}
public: __property int get_Confidence();
public:
property int Confidence {
   int get();
}

Property Value

An integer value which represents the confidence.
Remarks

The value range is between 0 and 100.

Higher values indicate a higher confidence that the negative was or was not accurately detected.

See Also

Reference

NegativeCorrectionResults Class
NegativeCorrectionResults Members


ImageIsNormal Property

Accusoft.ScanFixXpress8.Net
ImageIsNormal Property

Accusoft.ScanFixXpressSdk Namespace > NegativeCorrectionResults Class : ImageIsNormal Property
Gets a flag that indicates whether the image was determined to be a negative or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageIsNormal As Boolean
'Usage

Dim instance As NegativeCorrectionResults
Dim value As Boolean

value = instance.ImageIsNormal
public bool ImageIsNormal {get;}
public: __property bool get_ImageIsNormal();
public:
property bool ImageIsNormal {
   bool get();
}
See Also

Reference

NegativeCorrectionResults Class
NegativeCorrectionResults Members


ImageWasModified Property (NegativeCorrectionResults)

Accusoft.ScanFixXpress8.Net
ImageWasModified Property (NegativeCorrectionResults)

Accusoft.ScanFixXpressSdk Namespace > NegativeCorrectionResults Class : ImageWasModified Property
Gets a flag that indicates whether the image was corrected if a negative was detected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageWasModified As Boolean
'Usage

Dim instance As NegativeCorrectionResults
Dim value As Boolean

value = instance.ImageWasModified
public bool ImageWasModified {get;}
public: __property bool get_ImageWasModified();
public:
property bool ImageWasModified {
   bool get();
}
See Also

Reference

NegativeCorrectionResults Class
NegativeCorrectionResults Members


PerspectiveAdjustOptions Class

Accusoft.ScanFixXpress8.Net
PerspectiveAdjustOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : PerspectiveAdjustOptions Class
Contains parameters for the ScanFix.PerspectiveAdjust process.
Object Model
PerspectiveAdjustOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PerspectiveAdjustOptions
   Inherits EnhancementOption
'Usage

Dim instance As PerspectiveAdjustOptions
public class PerspectiveAdjustOptions : EnhancementOption
public __gc class PerspectiveAdjustOptions : public EnhancementOption
public ref class PerspectiveAdjustOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.PerspectiveAdjustOptions

See Also

Reference

PerspectiveAdjustOptions Members
Accusoft.ScanFixXpressSdk Namespace


PerspectiveAdjustOptions Class Members

Accusoft.ScanFixXpress8.Net
PerspectiveAdjustOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : PerspectiveAdjustOptions Class

The following tables list the members exposed by PerspectiveAdjustOptions.

Public Constructors
 | Name | Description
Public Constructor | PerspectiveAdjustOptions Constructor | Instantiates a new PerspectiveAdjustOptions object setting the default options.
Top
Public Properties
 | Name | Description
Public Property | BottomLeft | Gets and sets a System.Drawing.Point object that indicates the bottom left point of a quadrilateral in the image that represents a warped object.
Public Property | BottomRight | Gets and sets a System.Drawing.Point object that indicates the top left point of a quadrilateral in the image that represents a warped object.
Public Property | MaintainDimensions | Gets and sets a boolean value indicating if the width and height of the original image will be maintained.
Public Property | OutputImageHeight | Gets and sets an integer value indicating the desired output image width.
Public Property | OutputImageWidth | Gets and sets an integer value indicating the desired output image height.
Public Property | TopLeft | Gets and sets a System.Drawing.Point object that indicates the top left point of a quadrilateral in the image that represents a warped object.
Public Property | TopRight | Gets and sets a System.Drawing.Point object that indicates the top right point of a quadrilateral in the image that represents a warped object.
Top
See Also

Reference

PerspectiveAdjustOptions Class
Accusoft.ScanFixXpressSdk Namespace


PerspectiveAdjustOptions Class Properties

Accusoft.ScanFixXpress8.Net
PerspectiveAdjustOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : PerspectiveAdjustOptions Class

For a list of all members of this type, see PerspectiveAdjustOptions members.

Public Properties
 | Name | Description
Public Property | BottomLeft | Gets and sets a System.Drawing.Point object that indicates the bottom left point of a quadrilateral in the image that represents a warped object.
Public Property | BottomRight | Gets and sets a System.Drawing.Point object that indicates the top left point of a quadrilateral in the image that represents a warped object.
Public Property | MaintainDimensions | Gets and sets a boolean value indicating if the width and height of the original image will be maintained.
Public Property | OutputImageHeight | Gets and sets an integer value indicating the desired output image width.
Public Property | OutputImageWidth | Gets and sets an integer value indicating the desired output image height.
Public Property | TopLeft | Gets and sets a System.Drawing.Point object that indicates the top left point of a quadrilateral in the image that represents a warped object.
Public Property | TopRight | Gets and sets a System.Drawing.Point object that indicates the top right point of a quadrilateral in the image that represents a warped object.
Top
See Also

Reference

PerspectiveAdjustOptions Class
Accusoft.ScanFixXpressSdk Namespace


PerspectiveAdjustOptions Constructor

Accusoft.ScanFixXpress8.Net
PerspectiveAdjustOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > PerspectiveAdjustOptions Class : PerspectiveAdjustOptions Constructor
Instantiates a new PerspectiveAdjustOptions object setting the default options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New()
'Usage

Dim instance As New PerspectiveAdjustOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public PerspectiveAdjustOptions()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: PerspectiveAdjustOptions();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
PerspectiveAdjustOptions();
See Also

Reference

PerspectiveAdjustOptions Class
PerspectiveAdjustOptions Members


BottomLeft Property

Accusoft.ScanFixXpress8.Net
BottomLeft Property

Accusoft.ScanFixXpressSdk Namespace > PerspectiveAdjustOptions Class : BottomLeft Property
Gets and sets a System.Drawing.Point object that indicates the bottom left point of a quadrilateral in the image that represents a warped object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BottomLeft As Point
'Usage

Dim instance As PerspectiveAdjustOptions
Dim value As Point

instance.BottomLeft = value

value = instance.BottomLeft
public Point BottomLeft {get; set;}
public: __property Point get_BottomLeft();
public: __property void set_BottomLeft(
   Point value
);
public:
property Point BottomLeft {
   Point get();
   void set (    Point value);
}
Remarks

Use this if you know the location of an object you wish to adjust the perspective of. If this property is set (has a value > 0), then the ScanFix.PerspectiveAdjust method will not automatically search for a warped object.

Note:The origin (the point (0,0)) of the image is the top left hand corner.

See Also

Reference

PerspectiveAdjustOptions Class
PerspectiveAdjustOptions Members


BottomRight Property

Accusoft.ScanFixXpress8.Net
BottomRight Property

Accusoft.ScanFixXpressSdk Namespace > PerspectiveAdjustOptions Class : BottomRight Property
Gets and sets a System.Drawing.Point object that indicates the top left point of a quadrilateral in the image that represents a warped object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BottomRight As Point
'Usage

Dim instance As PerspectiveAdjustOptions
Dim value As Point

instance.BottomRight = value

value = instance.BottomRight
public Point BottomRight {get; set;}
public: __property Point get_BottomRight();
public: __property void set_BottomRight(
   Point value
);
public:
property Point BottomRight {
   Point get();
   void set (    Point value);
}
Remarks

Use this if you know the location of an object you wish to adjust the perspective of. If this property is set (has a value > 0), then the ScanFix.PerspectiveAdjust method will not automatically search for a warped object.

Note:The origin (the point (0,0)) of the image is the top left hand corner.

See Also

Reference

PerspectiveAdjustOptions Class
PerspectiveAdjustOptions Members


MaintainDimensions Property

Accusoft.ScanFixXpress8.Net
MaintainDimensions Property

Accusoft.ScanFixXpressSdk Namespace > PerspectiveAdjustOptions Class : MaintainDimensions Property
Gets and sets a boolean value indicating if the width and height of the original image will be maintained.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaintainDimensions As Boolean
'Usage

Dim instance As PerspectiveAdjustOptions
Dim value As Boolean

instance.MaintainDimensions = value

value = instance.MaintainDimensions
public bool MaintainDimensions {get; set;}
public: __property bool get_MaintainDimensions();
public: __property void set_MaintainDimensions(
   bool value
);
public:
property bool MaintainDimensions {
   bool get();
   void set (    bool value);
}
Remarks
This property will will take precedence if the OutputImageHeight and OutputImageWidth are set.
See Also

Reference

PerspectiveAdjustOptions Class
PerspectiveAdjustOptions Members


OutputImageHeight Property (PerspectiveAdjustOptions)

Accusoft.ScanFixXpress8.Net
OutputImageHeight Property (PerspectiveAdjustOptions)

Accusoft.ScanFixXpressSdk Namespace > PerspectiveAdjustOptions Class : OutputImageHeight Property
Gets and sets an integer value indicating the desired output image width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OutputImageHeight As Integer
'Usage

Dim instance As PerspectiveAdjustOptions
Dim value As Integer

instance.OutputImageHeight = value

value = instance.OutputImageHeight
public int OutputImageHeight {get; set;}
public: __property int get_OutputImageHeight();
public: __property void set_OutputImageHeight(
   int value
);
public:
property int OutputImageHeight {
   int get();
   void set (    int value);
}
Remarks

Use this to specify the size of the output image. If this property is set (has a value > 0), then the image will be resized.

If the MaintainDimensions property is true, then this will be ignored and the output image will have the same height as the input image.

See Also

Reference

PerspectiveAdjustOptions Class
PerspectiveAdjustOptions Members


OutputImageWidth Property (PerspectiveAdjustOptions)

Accusoft.ScanFixXpress8.Net
OutputImageWidth Property (PerspectiveAdjustOptions)

Accusoft.ScanFixXpressSdk Namespace > PerspectiveAdjustOptions Class : OutputImageWidth Property
Gets and sets an integer value indicating the desired output image height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OutputImageWidth As Integer
'Usage

Dim instance As PerspectiveAdjustOptions
Dim value As Integer

instance.OutputImageWidth = value

value = instance.OutputImageWidth
public int OutputImageWidth {get; set;}
public: __property int get_OutputImageWidth();
public: __property void set_OutputImageWidth(
   int value
);
public:
property int OutputImageWidth {
   int get();
   void set (    int value);
}
Remarks

Use this to specify the size of the output image. If this property is set (has a value > 0), then the image will be resized.

If the MaintainDimensions property is true, then this will be ignored, and the output image will have the same width as the input image.

See Also

Reference

PerspectiveAdjustOptions Class
PerspectiveAdjustOptions Members


TopLeft Property

Accusoft.ScanFixXpress8.Net
TopLeft Property

Accusoft.ScanFixXpressSdk Namespace > PerspectiveAdjustOptions Class : TopLeft Property
Gets and sets a System.Drawing.Point object that indicates the top left point of a quadrilateral in the image that represents a warped object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TopLeft As Point
'Usage

Dim instance As PerspectiveAdjustOptions
Dim value As Point

instance.TopLeft = value

value = instance.TopLeft
public Point TopLeft {get; set;}
public: __property Point get_TopLeft();
public: __property void set_TopLeft(
   Point value
);
public:
property Point TopLeft {
   Point get();
   void set (    Point value);
}
Remarks

Use this if you know the location of an object you wish to adjust the perspective of. If this property is set (has a value > 0), then the ScanFix.PerspectiveAdjust method will not automatically search for a warped object.

Note:The origin (the point (0,0)) of the image is the top left hand corner.

See Also

Reference

PerspectiveAdjustOptions Class
PerspectiveAdjustOptions Members


TopRight Property

Accusoft.ScanFixXpress8.Net
TopRight Property

Accusoft.ScanFixXpressSdk Namespace > PerspectiveAdjustOptions Class : TopRight Property
Gets and sets a System.Drawing.Point object that indicates the top right point of a quadrilateral in the image that represents a warped object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TopRight As Point
'Usage

Dim instance As PerspectiveAdjustOptions
Dim value As Point

instance.TopRight = value

value = instance.TopRight
public Point TopRight {get; set;}
public: __property Point get_TopRight();
public: __property void set_TopRight(
   Point value
);
public:
property Point TopRight {
   Point get();
   void set (    Point value);
}
Remarks

Use this if you know the location of an object you wish to adjust the perspective of. If this property is set (has a value > 0), then the ScanFix.PerspectiveAdjust method will not automatically search for a warped object.

Note:The origin (the point (0,0)) of the image is the top left hand corner.

See Also

Reference

PerspectiveAdjustOptions Class
PerspectiveAdjustOptions Members


PerspectiveAdjustResults Class

Accusoft.ScanFixXpress8.Net
PerspectiveAdjustResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : PerspectiveAdjustResults Class
Contains output values obtained from the PerspectiveAdjust enhancement process.
Object Model
PerspectiveAdjustResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PerspectiveAdjustResults
   Inherits EnhancementResult
'Usage

Dim instance As PerspectiveAdjustResults
public class PerspectiveAdjustResults : EnhancementResult
public __gc class PerspectiveAdjustResults : public EnhancementResult
public ref class PerspectiveAdjustResults : public EnhancementResult
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.PerspectiveAdjustResults

See Also

Reference

PerspectiveAdjustResults Members
Accusoft.ScanFixXpressSdk Namespace


PerspectiveAdjustResults Class Members

Accusoft.ScanFixXpress8.Net
PerspectiveAdjustResults Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : PerspectiveAdjustResults Class

The following tables list the members exposed by PerspectiveAdjustResults.

Public Properties
 | Name | Description
Public Property | OutputImageHeight | Gets the height of the image returned by the ScanFix.PerspectiveAdjust method.
Public Property | OutputImageWidth | Gets the width of the image returned by the ScanFix.PerspectiveAdjust method.
Top
See Also

Reference

PerspectiveAdjustResults Class
Accusoft.ScanFixXpressSdk Namespace


PerspectiveAdjustResults Class Properties

Accusoft.ScanFixXpress8.Net
PerspectiveAdjustResults Class Properties

Accusoft.ScanFixXpressSdk Namespace : PerspectiveAdjustResults Class

For a list of all members of this type, see PerspectiveAdjustResults members.

Public Properties
 | Name | Description
Public Property | OutputImageHeight | Gets the height of the image returned by the ScanFix.PerspectiveAdjust method.
Public Property | OutputImageWidth | Gets the width of the image returned by the ScanFix.PerspectiveAdjust method.
Top
See Also

Reference

PerspectiveAdjustResults Class
Accusoft.ScanFixXpressSdk Namespace


OutputImageHeight Property (PerspectiveAdjustResults)

Accusoft.ScanFixXpress8.Net
OutputImageHeight Property (PerspectiveAdjustResults)

Accusoft.ScanFixXpressSdk Namespace > PerspectiveAdjustResults Class : OutputImageHeight Property
Gets the height of the image returned by the ScanFix.PerspectiveAdjust method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OutputImageHeight As Integer
'Usage

Dim instance As PerspectiveAdjustResults
Dim value As Integer

value = instance.OutputImageHeight
public int OutputImageHeight {get;}
public: __property int get_OutputImageHeight();
public:
property int OutputImageHeight {
   int get();
}
See Also

Reference

PerspectiveAdjustResults Class
PerspectiveAdjustResults Members


OutputImageWidth Property (PerspectiveAdjustResults)

Accusoft.ScanFixXpress8.Net
OutputImageWidth Property (PerspectiveAdjustResults)

Accusoft.ScanFixXpressSdk Namespace > PerspectiveAdjustResults Class : OutputImageWidth Property
Gets the width of the image returned by the ScanFix.PerspectiveAdjust method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OutputImageWidth As Integer
'Usage

Dim instance As PerspectiveAdjustResults
Dim value As Integer

value = instance.OutputImageWidth
public int OutputImageWidth {get;}
public: __property int get_OutputImageWidth();
public:
property int OutputImageWidth {
   int get();
}
See Also

Reference

PerspectiveAdjustResults Class
PerspectiveAdjustResults Members


RescaleOptions Class

Accusoft.ScanFixXpress8.Net
RescaleOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : RescaleOptions Class
Contains parameters that control the ScanFix.Rescale process.
Object Model
RescaleOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class RescaleOptions
   Inherits EnhancementOption
'Usage

Dim instance As RescaleOptions
public class RescaleOptions : EnhancementOption
public __gc class RescaleOptions : public EnhancementOption
public ref class RescaleOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.RescaleOptions

See Also

Reference

RescaleOptions Members
Accusoft.ScanFixXpressSdk Namespace


RescaleOptions Class Members

Accusoft.ScanFixXpress8.Net
RescaleOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : RescaleOptions Class

The following tables list the members exposed by RescaleOptions.

Public Constructors
 | Name | Description
Public Constructor | RescaleOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Horizontal | Gets and sets the horizontal magnification to apply to the image.
Public Property | Vertical | Gets and sets the vertical magnification to apply to the image.
Top
See Also

Reference

RescaleOptions Class
Accusoft.ScanFixXpressSdk Namespace


RescaleOptions Class Properties

Accusoft.ScanFixXpress8.Net
RescaleOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : RescaleOptions Class

For a list of all members of this type, see RescaleOptions members.

Public Properties
 | Name | Description
Public Property | Horizontal | Gets and sets the horizontal magnification to apply to the image.
Public Property | Vertical | Gets and sets the vertical magnification to apply to the image.
Top
See Also

Reference

RescaleOptions Class
Accusoft.ScanFixXpressSdk Namespace


RescaleOptions Constructor

Accusoft.ScanFixXpress8.Net
RescaleOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > RescaleOptions Class : RescaleOptions Constructor
Overload List
Overload | Description
RescaleOptions Constructor() | Instantiates a new RescaleOptions object setting the default values.
RescaleOptions Constructor(Double,Double) | Instantiates a new RescaleOptions object setting the specified values.
See Also

Reference

RescaleOptions Class
RescaleOptions Members


RescaleOptions Constructor()

Accusoft.ScanFixXpress8.Net
RescaleOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > RescaleOptions Class > RescaleOptions Constructor : RescaleOptions Constructor()
Instantiates a new RescaleOptions object setting the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New RescaleOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public RescaleOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: RescaleOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
RescaleOptions();
See Also

Reference

RescaleOptions Class
RescaleOptions Members
Overload List


RescaleOptions Constructor(Double,Double)

Accusoft.ScanFixXpress8.Net
RescaleOptions Constructor(Double,Double)

Accusoft.ScanFixXpressSdk Namespace > RescaleOptions Class > RescaleOptions Constructor : RescaleOptions Constructor(Double,Double)
The horizontal magnification to apply to the image.
The vertical magnification to apply to the image.
Instantiates a new RescaleOptions object setting the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal horizontal As Double, _
   ByVal vertical As Double _
)
'Usage

Dim horizontal As Double
Dim vertical As Double

Dim instance As New RescaleOptions(horizontal, vertical)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public RescaleOptions(
   double horizontal,
   double vertical
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: RescaleOptions(
   double horizontal,
   double vertical
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
RescaleOptions(
   double horizontal,
   double vertical
)

Parameters

horizontal
The horizontal magnification to apply to the image.
vertical
The vertical magnification to apply to the image.
See Also

Reference

RescaleOptions Class
RescaleOptions Members
Overload List


Horizontal Property

Accusoft.ScanFixXpress8.Net
Horizontal Property

Accusoft.ScanFixXpressSdk Namespace > RescaleOptions Class : Horizontal Property
Gets and sets the horizontal magnification to apply to the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Horizontal As Double
'Usage

Dim instance As RescaleOptions
Dim value As Double

instance.Horizontal = value

value = instance.Horizontal
public double Horizontal {get; set;}
public: __property double get_Horizontal();
public: __property void set_Horizontal(
   double value
);
public:
property double Horizontal {
   double get();
   void set (    double value);
}
Remarks

The default value is 1.0.

Valid values are 0.0001 to 10000.

See Also

Reference

RescaleOptions Class
RescaleOptions Members


Vertical Property

Accusoft.ScanFixXpress8.Net
Vertical Property

Accusoft.ScanFixXpressSdk Namespace > RescaleOptions Class : Vertical Property
Gets and sets the vertical magnification to apply to the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Vertical As Double
'Usage

Dim instance As RescaleOptions
Dim value As Double

instance.Vertical = value

value = instance.Vertical
public double Vertical {get; set;}
public: __property double get_Vertical();
public: __property void set_Vertical(
   double value
);
public:
property double Vertical {
   double get();
   void set (    double value);
}
Remarks

The default value is 1.0.

Valid values are 0.0001 to 10000.

See Also

Reference

RescaleOptions Class
RescaleOptions Members


RescaleResults Class

Accusoft.ScanFixXpress8.Net
RescaleResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : RescaleResults Class
Defines a place holder class for the Rescale enhancement result.
Object Model
RescaleResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class RescaleResults
   Inherits EnhancementResult
'Usage

Dim instance As RescaleResults
public class RescaleResults : EnhancementResult
public __gc class RescaleResults : public EnhancementResult
public ref class RescaleResults : public EnhancementResult
Remarks
This class contains no data. Its presence in the results list is used to determine that the operation has run successfully.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.RescaleResults

See Also

Reference

RescaleResults Members
Accusoft.ScanFixXpressSdk Namespace


RescaleResults Class Members

Accusoft.ScanFixXpress8.Net
RescaleResults Class Members

Accusoft.ScanFixXpressSdk Namespace : RescaleResults Class

The following tables list the members exposed by RescaleResults.

See Also

Reference

RescaleResults Class
Accusoft.ScanFixXpressSdk Namespace


Resolution Class

Accusoft.ScanFixXpress8.Net
Resolution Class
Members

Accusoft.ScanFixXpressSdk Namespace : Resolution Class
Manages the resolution of the current image in the ScanFix object.
Object Model
Resolution Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class Resolution
'Usage

Dim instance As Resolution
public class Resolution
public __gc class Resolution
public ref class Resolution
Remarks
This class cannot be instantiated outside of the ScanFix Xpress SDK. An instance of this class can be obtained from the ScanFix.ImageResolution property after an image is set.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.Resolution

See Also

Reference

Resolution Members
Accusoft.ScanFixXpressSdk Namespace


Resolution Class Members

Accusoft.ScanFixXpress8.Net
Resolution Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : Resolution Class

The following tables list the members exposed by Resolution.

Public Properties
 | Name | Description
Public Property | Dimensions | Gets or sets the horizontal and vertical resolution of the image.
Public Property | Units | Gets or sets the unit of measure for the horizontal and vertical resolutions.
Top
See Also

Reference

Resolution Class
Accusoft.ScanFixXpressSdk Namespace


Resolution Class Properties

Accusoft.ScanFixXpress8.Net
Resolution Class Properties

Accusoft.ScanFixXpressSdk Namespace : Resolution Class

For a list of all members of this type, see Resolution members.

Public Properties
 | Name | Description
Public Property | Dimensions | Gets or sets the horizontal and vertical resolution of the image.
Public Property | Units | Gets or sets the unit of measure for the horizontal and vertical resolutions.
Top
See Also

Reference

Resolution Class
Accusoft.ScanFixXpressSdk Namespace


Dimensions Property

Accusoft.ScanFixXpress8.Net
Dimensions Property

Accusoft.ScanFixXpressSdk Namespace > Resolution Class : Dimensions Property
Gets or sets the horizontal and vertical resolution of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Dimensions As SizeF
'Usage

Dim instance As Resolution
Dim value As SizeF

instance.Dimensions = value

value = instance.Dimensions
public SizeF Dimensions {get; set;}
public: __property SizeF get_Dimensions();
public: __property void set_Dimensions(
   SizeF value
);
public:
property SizeF Dimensions {
   SizeF get();
   void set (    SizeF value);
}
See Also

Reference

Resolution Class
Resolution Members


Units Property

Accusoft.ScanFixXpress8.Net
Units Property

Accusoft.ScanFixXpressSdk Namespace > Resolution Class : Units Property
Gets or sets the unit of measure for the horizontal and vertical resolutions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Units As GraphicsUnit
'Usage

Dim instance As Resolution
Dim value As GraphicsUnit

instance.Units = value

value = instance.Units
public GraphicsUnit Units {get; set;}
public: __property GraphicsUnit get_Units();
public: __property void set_Units(
   GraphicsUnit value
);
public:
property GraphicsUnit Units {
   GraphicsUnit get();
   void set (    GraphicsUnit value);
}
See Also

Reference

Resolution Class
Resolution Members


RotateOptions Class

Accusoft.ScanFixXpress8.Net
RotateOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : RotateOptions Class
Contains parameters that control the ScanFix.Rotate process.
Object Model
RotateOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class RotateOptions
   Inherits EnhancementOption
'Usage

Dim instance As RotateOptions
public class RotateOptions : EnhancementOption
public __gc class RotateOptions : public EnhancementOption
public ref class RotateOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.RotateOptions

See Also

Reference

RotateOptions Members
Accusoft.ScanFixXpressSdk Namespace


RotateOptions Class Members

Accusoft.ScanFixXpress8.Net
RotateOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : RotateOptions Class

The following tables list the members exposed by RotateOptions.

Public Constructors
 | Name | Description
Public Constructor | RotateOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | PadColor | Gets and sets the color to use to pad the image.
Public Property | RotateAngle | Gets and sets the angle to rotate the image (measured in degrees).
Top
See Also

Reference

RotateOptions Class
Accusoft.ScanFixXpressSdk Namespace


RotateOptions Class Properties

Accusoft.ScanFixXpress8.Net
RotateOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : RotateOptions Class

For a list of all members of this type, see RotateOptions members.

Public Properties
 | Name | Description
Public Property | PadColor | Gets and sets the color to use to pad the image.
Public Property | RotateAngle | Gets and sets the angle to rotate the image (measured in degrees).
Top
See Also

Reference

RotateOptions Class
Accusoft.ScanFixXpressSdk Namespace


RotateOptions Constructor

Accusoft.ScanFixXpress8.Net
RotateOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > RotateOptions Class : RotateOptions Constructor
Overload List
Overload | Description
RotateOptions Constructor() | Instantiates a new RotateOptions object setting the default values.
RotateOptions Constructor(Double,Color) | Instantiates a new RotateOptions object setting the specified values.
See Also

Reference

RotateOptions Class
RotateOptions Members


RotateOptions Constructor()

Accusoft.ScanFixXpress8.Net
RotateOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > RotateOptions Class > RotateOptions Constructor : RotateOptions Constructor()
Instantiates a new RotateOptions object setting the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New RotateOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public RotateOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: RotateOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
RotateOptions();
See Also

Reference

RotateOptions Class
RotateOptions Members
Overload List


RotateOptions Constructor(Double,Color)

Accusoft.ScanFixXpress8.Net
RotateOptions Constructor(Double,Color)

Accusoft.ScanFixXpressSdk Namespace > RotateOptions Class > RotateOptions Constructor : RotateOptions Constructor(Double,Color)
The angle to rotate the image (measured in degrees).
The color to use to pad the image. If rotationAngle is a multiple of 90 degrees, no padding will be needed.
Instantiates a new RotateOptions object setting the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal rotateAngle As Double, _
   ByVal padColor As Color _
)
'Usage

Dim rotateAngle As Double
Dim padColor As Color

Dim instance As New RotateOptions(rotateAngle, padColor)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public RotateOptions(
   double rotateAngle,
   Color padColor
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: RotateOptions(
   double rotateAngle,
   Color padColor
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
RotateOptions(
   double rotateAngle,
   Color padColor
)

Parameters

rotateAngle
The angle to rotate the image (measured in degrees).
padColor
The color to use to pad the image. If rotationAngle is a multiple of 90 degrees, no padding will be needed.
See Also

Reference

RotateOptions Class
RotateOptions Members
Overload List


PadColor Property (RotateOptions)

Accusoft.ScanFixXpress8.Net
PadColor Property (RotateOptions)

Accusoft.ScanFixXpressSdk Namespace > RotateOptions Class : PadColor Property
Gets and sets the color to use to pad the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PadColor As Color
'Usage

Dim instance As RotateOptions
Dim value As Color

instance.PadColor = value

value = instance.PadColor
public Color PadColor {get; set;}
public: __property Color get_PadColor();
public: __property void set_PadColor(
   Color value
);
public:
property Color PadColor {
   Color get();
   void set (    Color value);
}
Remarks

The default value is White.

If RotateAngle is a multiple of 90 degrees, no padding will be needed.

See Also

Reference

RotateOptions Class
RotateOptions Members


RotateAngle Property

Accusoft.ScanFixXpress8.Net
RotateAngle Property

Accusoft.ScanFixXpressSdk Namespace > RotateOptions Class : RotateAngle Property
Gets and sets the angle to rotate the image (measured in degrees).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RotateAngle As Double
'Usage

Dim instance As RotateOptions
Dim value As Double

instance.RotateAngle = value

value = instance.RotateAngle
public double RotateAngle {get; set;}
public: __property double get_RotateAngle();
public: __property void set_RotateAngle(
   double value
);
public:
property double RotateAngle {
   double get();
   void set (    double value);
}
Remarks

The default value is 0.0.

Valid values are -360.0 to 360.0.

See Also

Reference

RotateOptions Class
RotateOptions Members


RotateResults Class

Accusoft.ScanFixXpress8.Net
RotateResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : RotateResults Class
Defines a place holder class for the Rotate enhancement result.
Object Model
RotateResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class RotateResults
   Inherits EnhancementResult
'Usage

Dim instance As RotateResults
public class RotateResults : EnhancementResult
public __gc class RotateResults : public EnhancementResult
public ref class RotateResults : public EnhancementResult
Remarks
This class contains no data. Its presence in the results list is used to determine that the operation has run successfully.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.RotateResults

See Also

Reference

RotateResults Members
Accusoft.ScanFixXpressSdk Namespace


RotateResults Class Members

Accusoft.ScanFixXpress8.Net
RotateResults Class Members

Accusoft.ScanFixXpressSdk Namespace : RotateResults Class

The following tables list the members exposed by RotateResults.

See Also

Reference

RotateResults Class
Accusoft.ScanFixXpressSdk Namespace


ScanFix Class

Accusoft.ScanFixXpress8.Net
ScanFix Class
Members

Accusoft.ScanFixXpressSdk Namespace : ScanFix Class

Implements the image processing operations for the ScanFixXpress SDK.

This is the main component object class for ScanFix. Instances of this class can be used as the destination of Accusoft's standard methods for passing images between different components: CopyTo(object destination) and TransferTo(object destination).

Object Model
ScanFix ClassBrightnessContrastResults ClassAutoInverseTextResults ClassAutoDespeckleResults ClassAutoRemoveHolePunchResults ClassAutoRotateResults ClassInverseTextResults ClassNegativeCorrectionResults ClassDeskewResults ClassDespeckleResults ClassBlankPageDetectResults ClassBlankRectangleDetectResults ClassDetectColorResults ClassGraphicLineDetectionResults ClassResolution ClassLicensing ClassPerspectiveAdjustResults ClassImageRegistrationResults ClassBlobRemovalResults ClassBorderRemovalResults ClassCombRemovalResults ClassDotShadingRemovalResults ClassGraphicLineRemovalResults ClassLineRemovalResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ToolboxBitmapAttribute()>
Public Class ScanFix
   Inherits System.ComponentModel.Component
'Usage

Dim instance As ScanFix
[ToolboxBitmapAttribute()]
public class ScanFix : System.ComponentModel.Component
[ToolboxBitmapAttribute()]
public __gc class ScanFix : public System.ComponentModel.Component
[ToolboxBitmapAttribute()]
public ref class ScanFix : public System.ComponentModel.Component
Remarks
Instances of this class only accept bitonal images with 1 bit per pixel, grayscale images with 8 bits per pixel, and color images with 24 bits per pixel.
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Accusoft.ScanFixXpressSdk.ScanFix

See Also

Reference

ScanFix Members
Accusoft.ScanFixXpressSdk Namespace


ScanFix Class Members

Accusoft.ScanFixXpress8.Net
ScanFix Class Members
Properties Methods Events

Accusoft.ScanFixXpressSdk Namespace : ScanFix Class

The following tables list the members exposed by ScanFix.

Public Constructors
 | Name | Description
Public Constructor | ScanFix Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Debug | Gets and sets a flag to indicate if debug information is sent to a debug file.
Public Property | DebugLogFile | Gets and sets the debug log file name.
Public Property | ErrorLevel | Gets and sets level for items to be written to the debug log file.
Public Property | HorizontalResolution | Gets and sets the horizontal resolution of the current image in units determined by the current ResolutionUnits property setting.
Public Property | ImageHeight | Gets height of the current image in pixels.
Public Property | ImageResolution | Gets resolution object for ScanFix.
Public Property | ImageWidth | Gets width of the current image in pixels.
Public Property | Licensing | Gets licensing information object for ScanFix.
Public Property | ResolutionUnits | Gets and sets the unit of measure for the vertical and horizontal resolutions.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | VerticalResolution | Gets and sets the vertical resolution of the current image in units determined by the current ResolutionUnits property setting.
Top
Protected Properties
 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top
Public Methods
 | Name | Description
Public Method | AboutBox | Overloaded. Displays a dialog box showing ScanFix version and copyright information.
Public Method | AdjustBrightnessContrast | Overloaded. Analyzes and/or automatically increases the contrast of an image.
Public Method | ApplyAverageFilter | Overloaded. Performs a 3x3 Average filter smoothing operation on the image, placing the output in the center of the window.
Public Method | ApplyCloseFilter | Overloaded. Performs a 3x3 Close filter operation on the image, closing light colored pixels.
Public Method | ApplyCustomFilter | Performs a custom convolution filter operation on image.
Public Method | ApplyGaussianFilter | Overloaded. Performs a 3x3 Gaussian smoothing filter operation on the image.
Public Method | ApplyLaplacianFilter | Performs a 3x3 Laplacian edge detection filter operation on the image.
Public Method | ApplyMedianFilter | Overloaded. Performs a 3x3 Median smoothing filter operation on the image.
Public Method | ApplyOpenFilter | Overloaded. Performs a 3x3 Open filter operation on the image, opening light colored pixels.
Public Method | ApplyPrewittFilter | Overloaded. Performs a 3x3 Prewitt horizontal edge detection filter operation on the image.
Public Method | ApplySobelFilter | Overloaded. Performs a 3x3 Sobel horizontal edge detection filter operation on the image.
Public Method | ApplyUnsharpFilter | Overloaded. Performs an Unsharp mask sharpening filter operation on the image.
Public Method | AutoAdjustBrightnessContrast | Automatically adjust brightness and contrast of image to enhance the text on image
Public Method | AutoBinarize | Creates an enhanced 1-bit output DIB of the same dimensions as a 1-bit, 8-bit or 24-bit input DIB using an automatic, intelligent algorithm.
Public Method | AutoCorrectInverseText | Automactically detects areas with white text on black background, such as table column headers or guide text, and negate them so that text is black and background is white.
Public Method | AutoDespeckle | Automatically detects speckles on an image and remove them.
Public Method | AutoImageDetergent | Overloaded. Removes noise from a color image by converting colors near each selected color to the selected color. This function automatically selects the colors to clean.
Public Method | AutoRemoveHolePunch | Automatically detects dark marks that resemble hole punches and remove them from image.
Public Method | AutoRotate | Automatically detects the image's orientation and rotates it so that the text on it is upright oriented
Public Method | AutoSmoothBackground | Automatically smoothes the image background and removes texture while retaining text quality
Public Method | Binarize | Creates an enhanced 1-bit output DIB of the same dimensions as a 1-bit, 8-bit or 24-bit input DIB using the settings provided by the caller.
Public Method | ColorDrop | Cleans an image by changing groups of similar color pixels to a single color.
Public Method | CopyTo | Designed to make passing image data between different Accusoft components easier, this method makes a copy of this object's image data and gives the new image data to another object which can be defined in a different Accusoft assembly. When finished, both this object and the destination object will contain separate copies of the same image data.
Public Method | CorrectInverseText | Overloaded. Detects and removes (reverses) inverse (white on black) text in a bitonal image.
Public Method | CorrectNegativePage | Overloaded. Determines if the image is black on white (normal) or white on black (negative), and optionally negate the image if it is, in fact, a negative.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Deskew | Overloaded. Detects the skew angle of the current image and rotates the image to remove that skew.
Public Method | Despeckle | Overloaded. Detects and removes specks from the current image.
Public Method | DetectBlankPage | Overloaded. Analyzes an image to determine if the amount of data there is low enough for the page to be considered blank.
Public Method | DetectBlankRectangle | Analyzes a rectangular area of an image to determine if the amount of data there is low enough to be considered blank.
Public Method | DetectColor | Overloaded. Examines an image looking for significant amounts of color data.
Public Method | DetectGraphicLines | Detects graphical lines from the current image.
Public Method | Dilate | Overloaded. Expands dark color pixels in the image by one in each direction.
Public Method | Dispose | Overloaded. Overridden. This method cleans up any resources being used.
Public Method | Erode | Overloaded. Removes dark color pixels in the image by one in each direction.
Public Method | ExecuteEnhancements | Execute the input enhancements on the current image.
Public Method | Flip | Flips the image (swap the top and bottom).
Public Method | FromBitmap | Sets the current image to a copy of the given Bitmap object.
Public Method | FromHbitmap | Sets the current image to a copy of the given HBITMAP object.
Public Method | FromHdib | Sets the current image to the given HDIB object.
Public Method | FromImage | Sets the current image to a copy of the given Image object.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetRectangle | Replaces the current image with a subset of the original image.
Public Method | ImageDetergent | Removes noise from a color image by converting colors near each selected color to the selected color. The user must specify the selected colors.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Mirror | Mirrors the image (swap the left and right sides).
Public Method | Negate | Inverts all colors in the image.
Public Method | PerspectiveAdjust | Detects and adjusts the perspective of a rectangular object in an image that is distorted.
Public Method | RegisterImage | Overloaded. Automatically positions text horizontally and vertically in the current image, providing a consistent left and top margin for documents. Use this function if the default control parameters are adequate.
Public Method | RemoveBlobs | Overloaded. Locates and removes large black objects in bitonal images.
Public Method | RemoveBorder | Overloaded. Locates border pixels and will replace them with the specified pad color and/or remove the pixels from the image.
Public Method | RemoveCombs | Overloaded. Detects and removes combs from the current image.
Public Method | RemoveDotShading | Overloaded. Removes dot shading areas from a bitonal image, including actual black-on-white shading.
Public Method | RemoveGraphicLines | Removes specified graphical lines from the current image.
Public Method | RemoveLines | Overloaded. Detects and removes lines from the current image.
Public Method | Rescale | Overloaded. Deprecated - Use 'Rescale(Accusoft.ScanFixXpressSdk.RescaleOptions options)' constructor instead. Rescales the image with the vertical and horizontal axis rescaled independently from each other.
Public Method | Rotate | Overloaded. Rotates the image by a given angle.
Public Method | Shear | Shears the image by the given amount.
Public Method | SmoothObjects | Overloaded. Smoothes the edges of characters in a bitonal image by the amount specified in the options.
Public Method | SmoothZoom | Replaces the current image with a new image whose width and height have been doubled and whose pixels have been smoothed.
Public Method | ToBitmap | Returns a new Bitmap object that contains a copy of this component's current image.
Public Method | ToHdib | Returns the DIB containing the component's current image.
Public Method | ToImage | Returns a new Image object that contains a copy of this component's current image.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | TransferTo | Designed to make passing image data between different Accusoft components easier, this method transfers this object's image data to another object which can be defined in a different Accusoft assembly. When finished, this object will no longer contain image data; the image data will be owned by the destination object.
Public Method | VirtualBulb | Emulates a dropout scanner, and cleans an image by converting the selected hues to white, nearby hues to shades of gray and all other hues to black.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current System.MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

ScanFix Class
Accusoft.ScanFixXpressSdk Namespace


ScanFix Class Properties

Accusoft.ScanFixXpress8.Net
ScanFix Class Properties

Accusoft.ScanFixXpressSdk Namespace : ScanFix Class

For a list of all members of this type, see ScanFix members.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Debug | Gets and sets a flag to indicate if debug information is sent to a debug file.
Public Property | DebugLogFile | Gets and sets the debug log file name.
Public Property | ErrorLevel | Gets and sets level for items to be written to the debug log file.
Public Property | HorizontalResolution | Gets and sets the horizontal resolution of the current image in units determined by the current ResolutionUnits property setting.
Public Property | ImageHeight | Gets height of the current image in pixels.
Public Property | ImageResolution | Gets resolution object for ScanFix.
Public Property | ImageWidth | Gets width of the current image in pixels.
Public Property | Licensing | Gets licensing information object for ScanFix.
Public Property | ResolutionUnits | Gets and sets the unit of measure for the vertical and horizontal resolutions.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | VerticalResolution | Gets and sets the vertical resolution of the current image in units determined by the current ResolutionUnits property setting.
Top
Protected Properties
 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

ScanFix Class
Accusoft.ScanFixXpressSdk Namespace


ScanFix Class Methods

Accusoft.ScanFixXpress8.Net
ScanFix Class Methods

Accusoft.ScanFixXpressSdk Namespace : ScanFix Class

For a list of all members of this type, see ScanFix members.

Public Methods
 | Name | Description
Public Method | AboutBox | Overloaded. Displays a dialog box showing ScanFix version and copyright information.
Public Method | AdjustBrightnessContrast | Overloaded. Analyzes and/or automatically increases the contrast of an image.
Public Method | ApplyAverageFilter | Overloaded. Performs a 3x3 Average filter smoothing operation on the image, placing the output in the center of the window.
Public Method | ApplyCloseFilter | Overloaded. Performs a 3x3 Close filter operation on the image, closing light colored pixels.
Public Method | ApplyCustomFilter | Performs a custom convolution filter operation on image.
Public Method | ApplyGaussianFilter | Overloaded. Performs a 3x3 Gaussian smoothing filter operation on the image.
Public Method | ApplyLaplacianFilter | Performs a 3x3 Laplacian edge detection filter operation on the image.
Public Method | ApplyMedianFilter | Overloaded. Performs a 3x3 Median smoothing filter operation on the image.
Public Method | ApplyOpenFilter | Overloaded. Performs a 3x3 Open filter operation on the image, opening light colored pixels.
Public Method | ApplyPrewittFilter | Overloaded. Performs a 3x3 Prewitt horizontal edge detection filter operation on the image.
Public Method | ApplySobelFilter | Overloaded. Performs a 3x3 Sobel horizontal edge detection filter operation on the image.
Public Method | ApplyUnsharpFilter | Overloaded. Performs an Unsharp mask sharpening filter operation on the image.
Public Method | AutoAdjustBrightnessContrast | Automatically adjust brightness and contrast of image to enhance the text on image
Public Method | AutoBinarize | Creates an enhanced 1-bit output DIB of the same dimensions as a 1-bit, 8-bit or 24-bit input DIB using an automatic, intelligent algorithm.
Public Method | AutoCorrectInverseText | Automactically detects areas with white text on black background, such as table column headers or guide text, and negate them so that text is black and background is white.
Public Method | AutoDespeckle | Automatically detects speckles on an image and remove them.
Public Method | AutoImageDetergent | Overloaded. Removes noise from a color image by converting colors near each selected color to the selected color. This function automatically selects the colors to clean.
Public Method | AutoRemoveHolePunch | Automatically detects dark marks that resemble hole punches and remove them from image.
Public Method | AutoRotate | Automatically detects the image's orientation and rotates it so that the text on it is upright oriented
Public Method | AutoSmoothBackground | Automatically smoothes the image background and removes texture while retaining text quality
Public Method | Binarize | Creates an enhanced 1-bit output DIB of the same dimensions as a 1-bit, 8-bit or 24-bit input DIB using the settings provided by the caller.
Public Method | ColorDrop | Cleans an image by changing groups of similar color pixels to a single color.
Public Method | CopyTo | Designed to make passing image data between different Accusoft components easier, this method makes a copy of this object's image data and gives the new image data to another object which can be defined in a different Accusoft assembly. When finished, both this object and the destination object will contain separate copies of the same image data.
Public Method | CorrectInverseText | Overloaded. Detects and removes (reverses) inverse (white on black) text in a bitonal image.
Public Method | CorrectNegativePage | Overloaded. Determines if the image is black on white (normal) or white on black (negative), and optionally negate the image if it is, in fact, a negative.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Deskew | Overloaded. Detects the skew angle of the current image and rotates the image to remove that skew.
Public Method | Despeckle | Overloaded. Detects and removes specks from the current image.
Public Method | DetectBlankPage | Overloaded. Analyzes an image to determine if the amount of data there is low enough for the page to be considered blank.
Public Method | DetectBlankRectangle | Analyzes a rectangular area of an image to determine if the amount of data there is low enough to be considered blank.
Public Method | DetectColor | Overloaded. Examines an image looking for significant amounts of color data.
Public Method | DetectGraphicLines | Detects graphical lines from the current image.
Public Method | Dilate | Overloaded. Expands dark color pixels in the image by one in each direction.
Public Method | Dispose | Overloaded. Overridden. This method cleans up any resources being used.
Public Method | Erode | Overloaded. Removes dark color pixels in the image by one in each direction.
Public Method | ExecuteEnhancements | Execute the input enhancements on the current image.
Public Method | Flip | Flips the image (swap the top and bottom).
Public Method | FromBitmap | Sets the current image to a copy of the given Bitmap object.
Public Method | FromHbitmap | Sets the current image to a copy of the given HBITMAP object.
Public Method | FromHdib | Sets the current image to the given HDIB object.
Public Method | FromImage | Sets the current image to a copy of the given Image object.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetRectangle | Replaces the current image with a subset of the original image.
Public Method | ImageDetergent | Removes noise from a color image by converting colors near each selected color to the selected color. The user must specify the selected colors.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Mirror | Mirrors the image (swap the left and right sides).
Public Method | Negate | Inverts all colors in the image.
Public Method | PerspectiveAdjust | Detects and adjusts the perspective of a rectangular object in an image that is distorted.
Public Method | RegisterImage | Overloaded. Automatically positions text horizontally and vertically in the current image, providing a consistent left and top margin for documents. Use this function if the default control parameters are adequate.
Public Method | RemoveBlobs | Overloaded. Locates and removes large black objects in bitonal images.
Public Method | RemoveBorder | Overloaded. Locates border pixels and will replace them with the specified pad color and/or remove the pixels from the image.
Public Method | RemoveCombs | Overloaded. Detects and removes combs from the current image.
Public Method | RemoveDotShading | Overloaded. Removes dot shading areas from a bitonal image, including actual black-on-white shading.
Public Method | RemoveGraphicLines | Removes specified graphical lines from the current image.
Public Method | RemoveLines | Overloaded. Detects and removes lines from the current image.
Public Method | Rescale | Overloaded. Deprecated - Use 'Rescale(Accusoft.ScanFixXpressSdk.RescaleOptions options)' constructor instead. Rescales the image with the vertical and horizontal axis rescaled independently from each other.
Public Method | Rotate | Overloaded. Rotates the image by a given angle.
Public Method | Shear | Shears the image by the given amount.
Public Method | SmoothObjects | Overloaded. Smoothes the edges of characters in a bitonal image by the amount specified in the options.
Public Method | SmoothZoom | Replaces the current image with a new image whose width and height have been doubled and whose pixels have been smoothed.
Public Method | ToBitmap | Returns a new Bitmap object that contains a copy of this component's current image.
Public Method | ToHdib | Returns the DIB containing the component's current image.
Public Method | ToImage | Returns a new Image object that contains a copy of this component's current image.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | TransferTo | Designed to make passing image data between different Accusoft components easier, this method transfers this object's image data to another object which can be defined in a different Accusoft assembly. When finished, this object will no longer contain image data; the image data will be owned by the destination object.
Public Method | VirtualBulb | Emulates a dropout scanner, and cleans an image by converting the selected hues to white, nearby hues to shades of gray and all other hues to black.
Top
Protected Methods
 | Name | Description
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current System.MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
Top
See Also

Reference

ScanFix Class
Accusoft.ScanFixXpressSdk Namespace


ScanFix Class Events

Accusoft.ScanFixXpress8.Net
ScanFix Class Events

Accusoft.ScanFixXpressSdk Namespace : ScanFix Class

For a list of all members of this type, see ScanFix members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

ScanFix Class
Accusoft.ScanFixXpressSdk Namespace


ScanFix Constructor

Accusoft.ScanFixXpress8.Net
ScanFix Constructor

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ScanFix Constructor
Overload List
Overload | Description
ScanFix Constructor(IContainer) | Instantiates the ScanFix object setting the parent container to that specified.
ScanFix Constructor() | Instantiates the default ScanFix object.
See Also

Reference

ScanFix Class
ScanFix Members


ScanFix Constructor(IContainer)

Accusoft.ScanFixXpress8.Net
ScanFix Constructor(IContainer)

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > ScanFix Constructor : ScanFix Constructor(IContainer)
Parent container for component
Instantiates the ScanFix object setting the parent container to that specified.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New( _
   ByVal container As IContainer _
)
'Usage

Dim container As IContainer

Dim instance As New ScanFix(container)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public ScanFix(
   IContainer container
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: ScanFix(
   IContainer* container
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
ScanFix(
   IContainer^ container
)

Parameters

container
Parent container for component
See Also

Reference

ScanFix Class
ScanFix Members
Overload List


ScanFix Constructor()

Accusoft.ScanFixXpress8.Net
ScanFix Constructor()

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > ScanFix Constructor : ScanFix Constructor()
Instantiates the default ScanFix object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New ScanFix()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public ScanFix()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: ScanFix();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
ScanFix();
See Also

Reference

ScanFix Class
ScanFix Members
Overload List


AboutBox Method

Accusoft.ScanFixXpress8.Net
AboutBox Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : AboutBox Method
Displays a dialog box showing ScanFix version and copyright information.
Overload List
Overload | Description
AboutBox() | Displays a dialog box showing ScanFix version and copyright information.
AboutBox(IWin32Window) | Displays a dialog box showing ScanFix version and copyright information.
See Also

Reference

ScanFix Class
ScanFix Members


AboutBox() Method

Accusoft.ScanFixXpress8.Net
AboutBox() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > AboutBox Method : AboutBox() Method
Displays a dialog box showing ScanFix version and copyright information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Sub AboutBox()
'Usage

Dim instance As ScanFix

instance.AboutBox()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void AboutBox()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void AboutBox();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void AboutBox();
See Also

Reference

ScanFix Class
ScanFix Members
Overload List


AboutBox(IWin32Window) Method

Accusoft.ScanFixXpress8.Net
AboutBox(IWin32Window) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > AboutBox Method : AboutBox(IWin32Window) Method
Parent window for dialog box
Displays a dialog box showing ScanFix version and copyright information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Sub AboutBox( _
   ByVal owner As IWin32Window _
)
'Usage

Dim instance As ScanFix
Dim owner As IWin32Window

instance.AboutBox(owner)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void AboutBox(
   IWin32Window owner
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void AboutBox(
   IWin32Window* owner
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void AboutBox(
   IWin32Window^ owner
)

Parameters

owner
Parent window for dialog box
See Also

Reference

ScanFix Class
ScanFix Members
Overload List


AdjustBrightnessContrast Method

Accusoft.ScanFixXpress8.Net
AdjustBrightnessContrast Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : AdjustBrightnessContrast Method
Analyzes and/or automatically increases the contrast of an image.
Overload List
Overload | Description
AdjustBrightnessContrast() | Analyzes and/or automatically increases the contrast of an image.
AdjustBrightnessContrast(BrightnessContrastOptions) | Analyzes and/or automatically increases the contrast of an image.
See Also

Reference

ScanFix Class
ScanFix Members


AdjustBrightnessContrast() Method

Accusoft.ScanFixXpress8.Net
AdjustBrightnessContrast() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > AdjustBrightnessContrast Method : AdjustBrightnessContrast() Method
Analyzes and/or automatically increases the contrast of an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Function AdjustBrightnessContrast() As BrightnessContrastResults
'Usage

Dim instance As ScanFix
Dim value As BrightnessContrastResults

value = instance.AdjustBrightnessContrast()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public BrightnessContrastResults AdjustBrightnessContrast()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: BrightnessContrastResults* AdjustBrightnessContrast();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
BrightnessContrastResults^ AdjustBrightnessContrast();

Return Value

A BrightnessContrastResults object containing information about the results of the automatic contrast and brighten process.
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Use this function if the default control parameters are adequate.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


AdjustBrightnessContrast(BrightnessContrastOptions) Method

Accusoft.ScanFixXpress8.Net
AdjustBrightnessContrast(BrightnessContrastOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > AdjustBrightnessContrast Method : AdjustBrightnessContrast(BrightnessContrastOptions) Method
An object containing parameters that control the enhancement process
Analyzes and/or automatically increases the contrast of an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Function AdjustBrightnessContrast( _
   ByVal options As BrightnessContrastOptions _
) As BrightnessContrastResults
'Usage

Dim instance As ScanFix
Dim options As BrightnessContrastOptions
Dim value As BrightnessContrastResults

value = instance.AdjustBrightnessContrast(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public BrightnessContrastResults AdjustBrightnessContrast(
   BrightnessContrastOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: BrightnessContrastResults* AdjustBrightnessContrast(
   BrightnessContrastOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
BrightnessContrastResults^ AdjustBrightnessContrast(
   BrightnessContrastOptions^ options
)

Parameters

options
An object containing parameters that control the enhancement process

Return Value

A BrightnessContrastResults object containing information about the results of the automatic contrast and brighten process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


ApplyAverageFilter Method

Accusoft.ScanFixXpress8.Net
ApplyAverageFilter Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ApplyAverageFilter Method
Performs a 3x3 Average filter smoothing operation on the image, placing the output in the center of the window.
Overload List
Overload | Description
ApplyAverageFilter() | Performs a 3x3 Average filter smoothing operation on the image, placing the output in the center of the window.
ApplyAverageFilter(FilterAverageOptions) | Performs an Average filter smoothing operation on the image. All pixel values in a window of the given size will be averaged together, and placed in the specified center location.
See Also

Reference

ScanFix Class
ScanFix Members


ApplyAverageFilter() Method

Accusoft.ScanFixXpress8.Net
ApplyAverageFilter() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > ApplyAverageFilter Method : ApplyAverageFilter() Method
Performs a 3x3 Average filter smoothing operation on the image, placing the output in the center of the window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Sub ApplyAverageFilter()
'Usage

Dim instance As ScanFix

instance.ApplyAverageFilter()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void ApplyAverageFilter()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void ApplyAverageFilter();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void ApplyAverageFilter();
Exceptions
Exception | Description
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Use this function if the default control parameters are adequate.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


ApplyAverageFilter(FilterAverageOptions) Method

Accusoft.ScanFixXpress8.Net
ApplyAverageFilter(FilterAverageOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > ApplyAverageFilter Method : ApplyAverageFilter(FilterAverageOptions) Method
An object containing parameters that control the process.
Performs an Average filter smoothing operation on the image. All pixel values in a window of the given size will be averaged together, and placed in the specified center location.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Sub ApplyAverageFilter( _
   ByVal options As FilterAverageOptions _
)
'Usage

Dim instance As ScanFix
Dim options As FilterAverageOptions

instance.ApplyAverageFilter(options)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void ApplyAverageFilter(
   FilterAverageOptions options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void ApplyAverageFilter(
   FilterAverageOptions* options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void ApplyAverageFilter(
   FilterAverageOptions^ options
)

Parameters

options
An object containing parameters that control the process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown if required argument value is null
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


ApplyCloseFilter Method

Accusoft.ScanFixXpress8.Net
ApplyCloseFilter Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ApplyCloseFilter Method
Performs a 3x3 Close filter operation on the image, closing light colored pixels.
Overload List
Overload | Description
ApplyCloseFilter() | Performs a 3x3 Close filter operation on the image, closing light colored pixels.
ApplyCloseFilter(FilterCloseOptions) | Performs a Close filter operation of the given size on the image, closing light colored pixels and placing the output in the specified center location.
See Also

Reference

ScanFix Class
ScanFix Members


ApplyCloseFilter() Method

Accusoft.ScanFixXpress8.Net
ApplyCloseFilter() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > ApplyCloseFilter Method : ApplyCloseFilter() Method
Performs a 3x3 Close filter operation on the image, closing light colored pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Sub ApplyCloseFilter()
'Usage

Dim instance As ScanFix

instance.ApplyCloseFilter()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void ApplyCloseFilter()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void ApplyCloseFilter();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void ApplyCloseFilter();
Exceptions
Exception | Description
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Use this function if the default control parameters are adequate.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


ApplyCloseFilter(FilterCloseOptions) Method

Accusoft.ScanFixXpress8.Net
ApplyCloseFilter(FilterCloseOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > ApplyCloseFilter Method : ApplyCloseFilter(FilterCloseOptions) Method
An object containing parameters that control the process.
Performs a Close filter operation of the given size on the image, closing light colored pixels and placing the output in the specified center location.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Sub ApplyCloseFilter( _
   ByVal options As FilterCloseOptions _
)
'Usage

Dim instance As ScanFix
Dim options As FilterCloseOptions

instance.ApplyCloseFilter(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void ApplyCloseFilter(
   FilterCloseOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void ApplyCloseFilter(
   FilterCloseOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void ApplyCloseFilter(
   FilterCloseOptions^ options
)

Parameters

options
An object containing parameters that control the process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown if required argument value is null
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


ApplyCustomFilter Method

Accusoft.ScanFixXpress8.Net
ApplyCustomFilter Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ApplyCustomFilter Method
An object containing parameters that control the process.
Performs a custom convolution filter operation on image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Sub ApplyCustomFilter( _
   ByVal options As FilterCustomOptions _
)
'Usage

Dim instance As ScanFix
Dim options As FilterCustomOptions

instance.ApplyCustomFilter(options)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void ApplyCustomFilter(
   FilterCustomOptions options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void ApplyCustomFilter(
   FilterCustomOptions* options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void ApplyCustomFilter(
   FilterCustomOptions^ options
)

Parameters

options
An object containing parameters that control the process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown if required argument value is null
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
See Also

Reference

ScanFix Class
ScanFix Members


ApplyGaussianFilter Method

Accusoft.ScanFixXpress8.Net
ApplyGaussianFilter Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ApplyGaussianFilter Method
Performs a 3x3 Gaussian smoothing filter operation on the image.
Overload List
Overload | Description
ApplyGaussianFilter() | Performs a 3x3 Gaussian smoothing filter operation on the image.
ApplyGaussianFilter(FilterGaussianOptions) | Performs a Gaussian smoothing filter operation of the specified size on the image, placing the output in the specified center location.
See Also

Reference

ScanFix Class
ScanFix Members


ApplyGaussianFilter() Method

Accusoft.ScanFixXpress8.Net
ApplyGaussianFilter() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > ApplyGaussianFilter Method : ApplyGaussianFilter() Method
Performs a 3x3 Gaussian smoothing filter operation on the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Sub ApplyGaussianFilter()
'Usage

Dim instance As ScanFix

instance.ApplyGaussianFilter()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void ApplyGaussianFilter()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void ApplyGaussianFilter();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void ApplyGaussianFilter();
Exceptions
Exception | Description
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Use this function if the default control parameters are adequate.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


ApplyGaussianFilter(FilterGaussianOptions) Method

Accusoft.ScanFixXpress8.Net
ApplyGaussianFilter(FilterGaussianOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > ApplyGaussianFilter Method : ApplyGaussianFilter(FilterGaussianOptions) Method
An object containing parameters that control the process.
Performs a Gaussian smoothing filter operation of the specified size on the image, placing the output in the specified center location.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Sub ApplyGaussianFilter( _
   ByVal options As FilterGaussianOptions _
)
'Usage

Dim instance As ScanFix
Dim options As FilterGaussianOptions

instance.ApplyGaussianFilter(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void ApplyGaussianFilter(
   FilterGaussianOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void ApplyGaussianFilter(
   FilterGaussianOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void ApplyGaussianFilter(
   FilterGaussianOptions^ options
)

Parameters

options
An object containing parameters that control the process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown if required argument value is null
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

This filter has internal optimization for faster operation when the filter window is set to 3x3 or 5x5 size and output at the center of the window.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


ApplyLaplacianFilter Method

Accusoft.ScanFixXpress8.Net
ApplyLaplacianFilter Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ApplyLaplacianFilter Method
Performs a 3x3 Laplacian edge detection filter operation on the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Sub ApplyLaplacianFilter()
'Usage

Dim instance As ScanFix

instance.ApplyLaplacianFilter()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void ApplyLaplacianFilter()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void ApplyLaplacianFilter();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void ApplyLaplacianFilter();
Exceptions
Exception | Description
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
See Also

Reference

ScanFix Class
ScanFix Members


ApplyMedianFilter Method

Accusoft.ScanFixXpress8.Net
ApplyMedianFilter Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ApplyMedianFilter Method
Performs a 3x3 Median smoothing filter operation on the image.
Overload List
Overload | Description
ApplyMedianFilter() | Performs a 3x3 Median smoothing filter operation on the image.
ApplyMedianFilter(FilterMedianOptions) | Performs a Median smothing filter operation of the specified size on the image, placing the output in the specified center location.
See Also

Reference

ScanFix Class
ScanFix Members


ApplyMedianFilter() Method

Accusoft.ScanFixXpress8.Net
ApplyMedianFilter() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > ApplyMedianFilter Method : ApplyMedianFilter() Method
Performs a 3x3 Median smoothing filter operation on the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Sub ApplyMedianFilter()
'Usage

Dim instance As ScanFix

instance.ApplyMedianFilter()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void ApplyMedianFilter()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void ApplyMedianFilter();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void ApplyMedianFilter();
Exceptions
Exception | Description
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Use this function if the default control parameters are adequate.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


ApplyMedianFilter(FilterMedianOptions) Method

Accusoft.ScanFixXpress8.Net
ApplyMedianFilter(FilterMedianOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > ApplyMedianFilter Method : ApplyMedianFilter(FilterMedianOptions) Method
An object containing parameters that control the process.
Performs a Median smothing filter operation of the specified size on the image, placing the output in the specified center location.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Sub ApplyMedianFilter( _
   ByVal options As FilterMedianOptions _
)
'Usage

Dim instance As ScanFix
Dim options As FilterMedianOptions

instance.ApplyMedianFilter(options)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void ApplyMedianFilter(
   FilterMedianOptions options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void ApplyMedianFilter(
   FilterMedianOptions* options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void ApplyMedianFilter(
   FilterMedianOptions^ options
)

Parameters

options
An object containing parameters that control the process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown if required argument value is null
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


ApplyOpenFilter Method

Accusoft.ScanFixXpress8.Net
ApplyOpenFilter Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ApplyOpenFilter Method
Performs a 3x3 Open filter operation on the image, opening light colored pixels.
Overload List
Overload | Description
ApplyOpenFilter() | Performs a 3x3 Open filter operation on the image, opening light colored pixels.
ApplyOpenFilter(FilterOpenOptions) | Performs an Open filter operation of the specified size on the image, opening light colored pixels and placing the output in the specified center location.
See Also

Reference

ScanFix Class
ScanFix Members


ApplyOpenFilter() Method

Accusoft.ScanFixXpress8.Net
ApplyOpenFilter() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > ApplyOpenFilter Method : ApplyOpenFilter() Method
Performs a 3x3 Open filter operation on the image, opening light colored pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Sub ApplyOpenFilter()
'Usage

Dim instance As ScanFix

instance.ApplyOpenFilter()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void ApplyOpenFilter()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void ApplyOpenFilter();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void ApplyOpenFilter();
Exceptions
Exception | Description
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Use this function if the default control parameters are adequate.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


ApplyOpenFilter(FilterOpenOptions) Method

Accusoft.ScanFixXpress8.Net
ApplyOpenFilter(FilterOpenOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > ApplyOpenFilter Method : ApplyOpenFilter(FilterOpenOptions) Method
An object containing parameters that control the process.
Performs an Open filter operation of the specified size on the image, opening light colored pixels and placing the output in the specified center location.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Sub ApplyOpenFilter( _
   ByVal options As FilterOpenOptions _
)
'Usage

Dim instance As ScanFix
Dim options As FilterOpenOptions

instance.ApplyOpenFilter(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void ApplyOpenFilter(
   FilterOpenOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void ApplyOpenFilter(
   FilterOpenOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void ApplyOpenFilter(
   FilterOpenOptions^ options
)

Parameters

options
An object containing parameters that control the process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown if required argument value is null
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


ApplyPrewittFilter Method

Accusoft.ScanFixXpress8.Net
ApplyPrewittFilter Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ApplyPrewittFilter Method
Performs a 3x3 Prewitt horizontal edge detection filter operation on the image.
Overload List
Overload | Description
ApplyPrewittFilter() | Performs a 3x3 Prewitt horizontal edge detection filter operation on the image.
ApplyPrewittFilter(FilterPrewittOptions) | Performs a 3x3 Prewitt edge detection filter operation on the image, in the specified direction.
See Also

Reference

ScanFix Class
ScanFix Members


ApplyPrewittFilter() Method

Accusoft.ScanFixXpress8.Net
ApplyPrewittFilter() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > ApplyPrewittFilter Method : ApplyPrewittFilter() Method
Performs a 3x3 Prewitt horizontal edge detection filter operation on the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Sub ApplyPrewittFilter()
'Usage

Dim instance As ScanFix

instance.ApplyPrewittFilter()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void ApplyPrewittFilter()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void ApplyPrewittFilter();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void ApplyPrewittFilter();
Exceptions
Exception | Description
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Use this function if the default control parameters are adequate.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


ApplyPrewittFilter(FilterPrewittOptions) Method

Accusoft.ScanFixXpress8.Net
ApplyPrewittFilter(FilterPrewittOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > ApplyPrewittFilter Method : ApplyPrewittFilter(FilterPrewittOptions) Method
An object containing parameters that control the process.
Performs a 3x3 Prewitt edge detection filter operation on the image, in the specified direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Sub ApplyPrewittFilter( _
   ByVal options As FilterPrewittOptions _
)
'Usage

Dim instance As ScanFix
Dim options As FilterPrewittOptions

instance.ApplyPrewittFilter(options)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void ApplyPrewittFilter(
   FilterPrewittOptions options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void ApplyPrewittFilter(
   FilterPrewittOptions* options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void ApplyPrewittFilter(
   FilterPrewittOptions^ options
)

Parameters

options
An object containing parameters that control the process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown if required argument value is null
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


ApplySobelFilter Method

Accusoft.ScanFixXpress8.Net
ApplySobelFilter Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ApplySobelFilter Method
Performs a 3x3 Sobel horizontal edge detection filter operation on the image.
Overload List
Overload | Description
ApplySobelFilter() | Performs a 3x3 Sobel horizontal edge detection filter operation on the image.
ApplySobelFilter(FilterSobelOptions) | Performs a 3x3 Sobel edge detection filter operation on the image, in the specified direction.
See Also

Reference

ScanFix Class
ScanFix Members


ApplySobelFilter() Method

Accusoft.ScanFixXpress8.Net
ApplySobelFilter() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > ApplySobelFilter Method : ApplySobelFilter() Method
Performs a 3x3 Sobel horizontal edge detection filter operation on the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Sub ApplySobelFilter()
'Usage

Dim instance As ScanFix

instance.ApplySobelFilter()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void ApplySobelFilter()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void ApplySobelFilter();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void ApplySobelFilter();
Exceptions
Exception | Description
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Use this function if the default control parameters are adequate.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


ApplySobelFilter(FilterSobelOptions) Method

Accusoft.ScanFixXpress8.Net
ApplySobelFilter(FilterSobelOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > ApplySobelFilter Method : ApplySobelFilter(FilterSobelOptions) Method
An object containing parameters that control the process.
Performs a 3x3 Sobel edge detection filter operation on the image, in the specified direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Sub ApplySobelFilter( _
   ByVal options As FilterSobelOptions _
)
'Usage

Dim instance As ScanFix
Dim options As FilterSobelOptions

instance.ApplySobelFilter(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void ApplySobelFilter(
   FilterSobelOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void ApplySobelFilter(
   FilterSobelOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void ApplySobelFilter(
   FilterSobelOptions^ options
)

Parameters

options
An object containing parameters that control the process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown if required argument value is null
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


ApplyUnsharpFilter Method

Accusoft.ScanFixXpress8.Net
ApplyUnsharpFilter Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ApplyUnsharpFilter Method
Performs an Unsharp mask sharpening filter operation on the image.
Overload List
Overload | Description
ApplyUnsharpFilter() | Performs an Unsharp mask sharpening filter operation on the image.
ApplyUnsharpFilter(FilterUnsharpOptions) | Performs an Unsharp mask sharpening filter operation of the specified size on the image.
See Also

Reference

ScanFix Class
ScanFix Members


ApplyUnsharpFilter() Method

Accusoft.ScanFixXpress8.Net
ApplyUnsharpFilter() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > ApplyUnsharpFilter Method : ApplyUnsharpFilter() Method
Performs an Unsharp mask sharpening filter operation on the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Sub ApplyUnsharpFilter()
'Usage

Dim instance As ScanFix

instance.ApplyUnsharpFilter()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void ApplyUnsharpFilter()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void ApplyUnsharpFilter();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void ApplyUnsharpFilter();
Exceptions
Exception | Description
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Use this function if the default control parameters are adequate.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


ApplyUnsharpFilter(FilterUnsharpOptions) Method

Accusoft.ScanFixXpress8.Net
ApplyUnsharpFilter(FilterUnsharpOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > ApplyUnsharpFilter Method : ApplyUnsharpFilter(FilterUnsharpOptions) Method
An object containing parameters that control the process.
Performs an Unsharp mask sharpening filter operation of the specified size on the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Sub ApplyUnsharpFilter( _
   ByVal options As FilterUnsharpOptions _
)
'Usage

Dim instance As ScanFix
Dim options As FilterUnsharpOptions

instance.ApplyUnsharpFilter(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void ApplyUnsharpFilter(
   FilterUnsharpOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void ApplyUnsharpFilter(
   FilterUnsharpOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void ApplyUnsharpFilter(
   FilterUnsharpOptions^ options
)

Parameters

options
An object containing parameters that control the process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown if required argument value is null
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


AutoAdjustBrightnessContrast Method

Accusoft.ScanFixXpress8.Net
AutoAdjustBrightnessContrast Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : AutoAdjustBrightnessContrast Method
Automatically adjust brightness and contrast of image to enhance the text on image
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Sub AutoAdjustBrightnessContrast()
'Usage

Dim instance As ScanFix

instance.AutoAdjustBrightnessContrast()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void AutoAdjustBrightnessContrast()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void AutoAdjustBrightnessContrast();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void AutoAdjustBrightnessContrast();
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to adjust brightness and contrast without setting parameters.

See Also

Reference

ScanFix Class
ScanFix Members


AutoBinarize Method

Accusoft.ScanFixXpress8.Net
AutoBinarize Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : AutoBinarize Method
Creates an enhanced 1-bit output DIB of the same dimensions as a 1-bit, 8-bit or 24-bit input DIB using an automatic, intelligent algorithm.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Sub AutoBinarize()
'Usage

Dim instance As ScanFix

instance.AutoBinarize()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void AutoBinarize()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void AutoBinarize();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void AutoBinarize();
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

AutoBinarize logic is significantly improved from the logic in ScanFix Xpress v5. See Binarize for details about how to replicate the ScanFix v5 auto-binarize settings.

See Also

Reference

ScanFix Class
ScanFix Members


AutoCorrectInverseText Method

Accusoft.ScanFixXpress8.Net
AutoCorrectInverseText Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : AutoCorrectInverseText Method
Automactically detects areas with white text on black background, such as table column headers or guide text, and negate them so that text is black and background is white.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function AutoCorrectInverseText() As AutoInverseTextResults
'Usage

Dim instance As ScanFix
Dim value As AutoInverseTextResults

value = instance.AutoCorrectInverseText()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public AutoInverseTextResults AutoCorrectInverseText()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: AutoInverseTextResults* AutoCorrectInverseText();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
AutoInverseTextResults^ AutoCorrectInverseText();

Return Value

An AutoInverseTextResults object containing information about the results of the automatic text inversion process.
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note:Use this function if you wish to correct inverse text without setting paramaters

See Also

Reference

ScanFix Class
ScanFix Members


AutoDespeckle Method

Accusoft.ScanFixXpress8.Net
AutoDespeckle Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : AutoDespeckle Method
Automatically detects speckles on an image and remove them.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function AutoDespeckle() As AutoDespeckleResults
'Usage

Dim instance As ScanFix
Dim value As AutoDespeckleResults

value = instance.AutoDespeckle()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public AutoDespeckleResults AutoDespeckle()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: AutoDespeckleResults* AutoDespeckle();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
AutoDespeckleResults^ AutoDespeckle();

Return Value

An AutoDespeckleResults object containing information about the results of the automatic despeckling process.
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note:Use this method if you wish to remove speckles without setting any parameters

See Also

Reference

ScanFix Class
ScanFix Members


AutoImageDetergent Method

Accusoft.ScanFixXpress8.Net
AutoImageDetergent Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : AutoImageDetergent Method
Removes noise from a color image by converting colors near each selected color to the selected color. This function automatically selects the colors to clean.
Overload List
Overload | Description
AutoImageDetergent() | Removes noise from a color image by converting colors near each selected color to the selected color. This function automatically selects the colors to clean.
AutoImageDetergent(AutoImageDetergentOptions) | Removes noise from a color image by converting colors near each selected color to the selected color. This function automatically selects the colors to clean.
See Also

Reference

ScanFix Class
ScanFix Members


AutoImageDetergent() Method

Accusoft.ScanFixXpress8.Net
AutoImageDetergent() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > AutoImageDetergent Method : AutoImageDetergent() Method
Removes noise from a color image by converting colors near each selected color to the selected color. This function automatically selects the colors to clean.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Sub AutoImageDetergent()
'Usage

Dim instance As ScanFix

instance.AutoImageDetergent()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void AutoImageDetergent()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void AutoImageDetergent();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void AutoImageDetergent();
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
See Also

Reference

ScanFix Class
ScanFix Members
Overload List


AutoImageDetergent(AutoImageDetergentOptions) Method

Accusoft.ScanFixXpress8.Net
AutoImageDetergent(AutoImageDetergentOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > AutoImageDetergent Method : AutoImageDetergent(AutoImageDetergentOptions) Method
An object containing parameters that control the process.
Removes noise from a color image by converting colors near each selected color to the selected color. This function automatically selects the colors to clean.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Sub AutoImageDetergent( _
   ByVal options As AutoImageDetergentOptions _
)
'Usage

Dim instance As ScanFix
Dim options As AutoImageDetergentOptions

instance.AutoImageDetergent(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void AutoImageDetergent(
   AutoImageDetergentOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void AutoImageDetergent(
   AutoImageDetergentOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void AutoImageDetergent(
   AutoImageDetergentOptions^ options
)

Parameters

options
An object containing parameters that control the process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
See Also

Reference

ScanFix Class
ScanFix Members
Overload List


AutoRemoveHolePunch Method

Accusoft.ScanFixXpress8.Net
AutoRemoveHolePunch Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : AutoRemoveHolePunch Method
Automatically detects dark marks that resemble hole punches and remove them from image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function AutoRemoveHolePunch() As AutoRemoveHolePunchResults
'Usage

Dim instance As ScanFix
Dim value As AutoRemoveHolePunchResults

value = instance.AutoRemoveHolePunch()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public AutoRemoveHolePunchResults AutoRemoveHolePunch()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: AutoRemoveHolePunchResults* AutoRemoveHolePunch();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
AutoRemoveHolePunchResults^ AutoRemoveHolePunch();

Return Value

An AutoRemoveHolePunchResults object containing information about the results of the auto hole removal process.
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this method if you wish to remove hole punches without setting any parameters.

See Also

Reference

ScanFix Class
ScanFix Members


AutoRotate Method

Accusoft.ScanFixXpress8.Net
AutoRotate Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : AutoRotate Method
Automatically detects the image's orientation and rotates it so that the text on it is upright oriented
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function AutoRotate() As AutoRotateResults
'Usage

Dim instance As ScanFix
Dim value As AutoRotateResults

value = instance.AutoRotate()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public AutoRotateResults AutoRotate()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: AutoRotateResults* AutoRotate();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
AutoRotateResults^ AutoRotate();

Return Value

An AutoRotateResults object containing information about the results of the auto rotation process.
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Deskewing the image before applying AutoRotate is recommended, as it may help increasing the accuracy of this enhancement.

If auto rotate is performing inaccurately on form images with a large number of lines, applying line removal prior to auto rotate may help.

See Also

Reference

ScanFix Class
ScanFix Members
Deskew Method
RemoveLines Method


AutoSmoothBackground Method

Accusoft.ScanFixXpress8.Net
AutoSmoothBackground Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : AutoSmoothBackground Method
Automatically smoothes the image background and removes texture while retaining text quality
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Sub AutoSmoothBackground()
'Usage

Dim instance As ScanFix

instance.AutoSmoothBackground()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void AutoSmoothBackground()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void AutoSmoothBackground();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void AutoSmoothBackground();
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
See Also

Reference

ScanFix Class
ScanFix Members


Binarize Method

Accusoft.ScanFixXpress8.Net
Binarize Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : Binarize Method
An object containing parameters that control the binarization process.
Creates an enhanced 1-bit output DIB of the same dimensions as a 1-bit, 8-bit or 24-bit input DIB using the settings provided by the caller.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Sub Binarize( _
   ByVal options As BinarizeOptions _
)
'Usage

Dim instance As ScanFix
Dim options As BinarizeOptions

instance.Binarize(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void Binarize(
   BinarizeOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void Binarize(
   BinarizeOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void Binarize(
   BinarizeOptions^ options
)

Parameters

options
An object containing parameters that control the binarization process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

To replicate ScanFix Xpress v5 AutoBinarize for bitonal images use the following settings:

LowThreshold = 0

HighThreshold = 0

LceFactor = 0

PreBlurType = SmartBlur

To replicate ScanFix Xpress v5 AutoBinarize for gray or color images use the following settings:

LowThreshold = 170

HighThreshold = 190

LceFactor = 0

PreBlurType = NoBlur

See Also

Reference

ScanFix Class
ScanFix Members


ColorDrop Method

Accusoft.ScanFixXpress8.Net
ColorDrop Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ColorDrop Method
An object containing parameters that control the process.
Cleans an image by changing groups of similar color pixels to a single color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Sub ColorDrop( _
   ByVal options As ColorDropOptions _
)
'Usage

Dim instance As ScanFix
Dim options As ColorDropOptions

instance.ColorDrop(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void ColorDrop(
   ColorDropOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void ColorDrop(
   ColorDropOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void ColorDrop(
   ColorDropOptions^ options
)

Parameters

options
An object containing parameters that control the process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
See Also

Reference

ScanFix Class
ScanFix Members


CopyTo Method (ScanFix)

Accusoft.ScanFixXpress8.Net
CopyTo Method (ScanFix)

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : CopyTo Method
Desired object to receive copy of image data.
Designed to make passing image data between different Accusoft components easier, this method makes a copy of this object's image data and gives the new image data to another object which can be defined in a different Accusoft assembly. When finished, both this object and the destination object will contain separate copies of the same image data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Sub CopyTo( _
   ByVal Destination As Object _
)
'Usage

Dim instance As ScanFix
Dim Destination As Object

instance.CopyTo(Destination)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void CopyTo(
   object Destination
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void CopyTo(
   Object* Destination
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void CopyTo(
   Object^ Destination
)

Parameters

Destination
Desired object to receive copy of image data.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentException | Thrown when Destination object is not capable of accepting the image.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks
Not all object types are valid destinations for this method. If the destination object does not support being copied to, a System.ArgumentException will be thrown. Refer to the documentation of a particular class to see if it officially supports being the destination of a CopyTo method.
See Also

Reference

ScanFix Class
ScanFix Members


CorrectInverseText Method

Accusoft.ScanFixXpress8.Net
CorrectInverseText Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : CorrectInverseText Method
Detects and removes (reverses) inverse (white on black) text in a bitonal image.
Overload List
Overload | Description
CorrectInverseText() | Detects and removes (reverses) inverse (white on black) text in a bitonal image.
CorrectInverseText(InverseTextOptions) | Detects and removes (reverses) inverse (white on black) text in a bitonal image.
See Also

Reference

ScanFix Class
ScanFix Members


CorrectInverseText() Method

Accusoft.ScanFixXpress8.Net
CorrectInverseText() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > CorrectInverseText Method : CorrectInverseText() Method
Detects and removes (reverses) inverse (white on black) text in a bitonal image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Function CorrectInverseText() As InverseTextResults
'Usage

Dim instance As ScanFix
Dim value As InverseTextResults

value = instance.CorrectInverseText()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public InverseTextResults CorrectInverseText()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: InverseTextResults* CorrectInverseText();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
InverseTextResults^ CorrectInverseText();

Return Value

An InverseTextResults object containing information about the results of the inverse text correction process.
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Use this function if the default control parameters are adequate.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


CorrectInverseText(InverseTextOptions) Method

Accusoft.ScanFixXpress8.Net
CorrectInverseText(InverseTextOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > CorrectInverseText Method : CorrectInverseText(InverseTextOptions) Method
An object containing parameters that control the enhancement process.
Detects and removes (reverses) inverse (white on black) text in a bitonal image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Function CorrectInverseText( _
   ByVal options As InverseTextOptions _
) As InverseTextResults
'Usage

Dim instance As ScanFix
Dim options As InverseTextOptions
Dim value As InverseTextResults

value = instance.CorrectInverseText(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public InverseTextResults CorrectInverseText(
   InverseTextOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: InverseTextResults* CorrectInverseText(
   InverseTextOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
InverseTextResults^ CorrectInverseText(
   InverseTextOptions^ options
)

Parameters

options
An object containing parameters that control the enhancement process.

Return Value

An InverseTextResults object containing information about the results of the inverse text correction process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


CorrectNegativePage Method

Accusoft.ScanFixXpress8.Net
CorrectNegativePage Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : CorrectNegativePage Method
Determines if the image is black on white (normal) or white on black (negative), and optionally negate the image if it is, in fact, a negative.
Overload List
Overload | Description
CorrectNegativePage() | Determines if the image is black on white (normal) or white on black (negative), and optionally negate the image if it is, in fact, a negative.
CorrectNegativePage(NegativeCorrectionOptions) | Determines if the image is black on white (normal) or white on black (negative), and optionally negate the image if it is, in fact, a negative.
See Also

Reference

ScanFix Class
ScanFix Members


CorrectNegativePage() Method

Accusoft.ScanFixXpress8.Net
CorrectNegativePage() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > CorrectNegativePage Method : CorrectNegativePage() Method
Determines if the image is black on white (normal) or white on black (negative), and optionally negate the image if it is, in fact, a negative.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Function CorrectNegativePage() As NegativeCorrectionResults
'Usage

Dim instance As ScanFix
Dim value As NegativeCorrectionResults

value = instance.CorrectNegativePage()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public NegativeCorrectionResults CorrectNegativePage()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: NegativeCorrectionResults* CorrectNegativePage();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
NegativeCorrectionResults^ CorrectNegativePage();

Return Value

A NegativeCorrectionResults object containing information about the results of the negative page correction process.
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Use this function if the default control parameters are adequate.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


CorrectNegativePage(NegativeCorrectionOptions) Method

Accusoft.ScanFixXpress8.Net
CorrectNegativePage(NegativeCorrectionOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > CorrectNegativePage Method : CorrectNegativePage(NegativeCorrectionOptions) Method
An object containing parameters that control the enhancement process.
Determines if the image is black on white (normal) or white on black (negative), and optionally negate the image if it is, in fact, a negative.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Function CorrectNegativePage( _
   ByVal options As NegativeCorrectionOptions _
) As NegativeCorrectionResults
'Usage

Dim instance As ScanFix
Dim options As NegativeCorrectionOptions
Dim value As NegativeCorrectionResults

value = instance.CorrectNegativePage(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public NegativeCorrectionResults CorrectNegativePage(
   NegativeCorrectionOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: NegativeCorrectionResults* CorrectNegativePage(
   NegativeCorrectionOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
NegativeCorrectionResults^ CorrectNegativePage(
   NegativeCorrectionOptions^ options
)

Parameters

options
An object containing parameters that control the enhancement process.

Return Value

A NegativeCorrectionResults object containing information about the results of the negative page correction process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


Deskew Method

Accusoft.ScanFixXpress8.Net
Deskew Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : Deskew Method
Detects the skew angle of the current image and rotates the image to remove that skew.
Overload List
Overload | Description
Deskew() | Detects the skew angle of the current image and rotates the image to remove that skew.
Deskew(DeskewOptions) | Detects the skew angle of the current image and rotates the image to remove that skew.
See Also

Reference

ScanFix Class
ScanFix Members


Deskew() Method

Accusoft.ScanFixXpress8.Net
Deskew() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > Deskew Method : Deskew() Method
Detects the skew angle of the current image and rotates the image to remove that skew.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Function Deskew() As DeskewResults
'Usage

Dim instance As ScanFix
Dim value As DeskewResults

value = instance.Deskew()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public DeskewResults Deskew()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: DeskewResults* Deskew();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
DeskewResults^ Deskew();

Return Value

A DeskewResults object containing information about the results of the deskew process.
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

The deskew enhancement is capable of correcting skews ranging from -20 to +20 degrees by rotating the image to 0 degree. It is recommended to use this enhancement on images with skews within the valid range.

Use this function if the default control parameters are adequate.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


Deskew(DeskewOptions) Method

Accusoft.ScanFixXpress8.Net
Deskew(DeskewOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > Deskew Method : Deskew(DeskewOptions) Method
An object containing parameters that control the enhancement process
Detects the skew angle of the current image and rotates the image to remove that skew.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Function Deskew( _
   ByVal options As DeskewOptions _
) As DeskewResults
'Usage

Dim instance As ScanFix
Dim options As DeskewOptions
Dim value As DeskewResults

value = instance.Deskew(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public DeskewResults Deskew(
   DeskewOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: DeskewResults* Deskew(
   DeskewOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
DeskewResults^ Deskew(
   DeskewOptions^ options
)

Parameters

options
An object containing parameters that control the enhancement process

Return Value

A DeskewResults object containing information about the results of the deskew process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

The deskew enhancement is capable of correcting skews ranging from -20 to +20 degrees by rotating the image to 0 degree. It is recommended to use this enhancement on images with skews within the valid range.

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


Despeckle Method

Accusoft.ScanFixXpress8.Net
Despeckle Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : Despeckle Method
Detects and removes specks from the current image.
Overload List
Overload | Description
Despeckle() | Detects and removes specks from the current image.
Despeckle(DespeckleOptions) | Detects and removes specks from the current image.
See Also

Reference

ScanFix Class
ScanFix Members


Despeckle() Method

Accusoft.ScanFixXpress8.Net
Despeckle() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > Despeckle Method : Despeckle() Method
Detects and removes specks from the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Function Despeckle() As DespeckleResults
'Usage

Dim instance As ScanFix
Dim value As DespeckleResults

value = instance.Despeckle()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public DespeckleResults Despeckle()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: DespeckleResults* Despeckle();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
DespeckleResults^ Despeckle();

Return Value

A DespeckleResults object containing information about the results of the despeckling process.
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Use this function if the default control parameters are adequate.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


Despeckle(DespeckleOptions) Method

Accusoft.ScanFixXpress8.Net
Despeckle(DespeckleOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > Despeckle Method : Despeckle(DespeckleOptions) Method
An object containing parameters that control the enhancement process.
Detects and removes specks from the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Function Despeckle( _
   ByVal options As DespeckleOptions _
) As DespeckleResults
'Usage

Dim instance As ScanFix
Dim options As DespeckleOptions
Dim value As DespeckleResults

value = instance.Despeckle(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public DespeckleResults Despeckle(
   DespeckleOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: DespeckleResults* Despeckle(
   DespeckleOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
DespeckleResults^ Despeckle(
   DespeckleOptions^ options
)

Parameters

options
An object containing parameters that control the enhancement process.

Return Value

A DespeckleResults object containing information about the results of the despeckling process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


DetectBlankPage Method

Accusoft.ScanFixXpress8.Net
DetectBlankPage Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : DetectBlankPage Method
Analyzes an image to determine if the amount of data there is low enough for the page to be considered blank.
Overload List
Overload | Description
DetectBlankPage() | Analyzes an image to determine if the amount of data there is low enough for the page to be considered blank.
DetectBlankPage(BlankPageDetectOptions) | Analyzes an image to determine if the amount of data there is low enough for the page to be considered blank.
See Also

Reference

ScanFix Class
ScanFix Members


DetectBlankPage() Method

Accusoft.ScanFixXpress8.Net
DetectBlankPage() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > DetectBlankPage Method : DetectBlankPage() Method
Analyzes an image to determine if the amount of data there is low enough for the page to be considered blank.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Function DetectBlankPage() As BlankPageDetectResults
'Usage

Dim instance As ScanFix
Dim value As BlankPageDetectResults

value = instance.DetectBlankPage()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public BlankPageDetectResults DetectBlankPage()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: BlankPageDetectResults* DetectBlankPage();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
BlankPageDetectResults^ DetectBlankPage();

Return Value

A BlankPageDetectResults object containing information about the results of the detection process.
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Use this function if the default control parameters are adequate.

Note: This method is designed to work with document images only. Using this with photograph images may yield inaccurate or erroneous results.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


DetectBlankPage(BlankPageDetectOptions) Method

Accusoft.ScanFixXpress8.Net
DetectBlankPage(BlankPageDetectOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > DetectBlankPage Method : DetectBlankPage(BlankPageDetectOptions) Method
An object containing parameters that control the enhancement process.
Analyzes an image to determine if the amount of data there is low enough for the page to be considered blank.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Function DetectBlankPage( _
   ByVal options As BlankPageDetectOptions _
) As BlankPageDetectResults
'Usage

Dim instance As ScanFix
Dim options As BlankPageDetectOptions
Dim value As BlankPageDetectResults

value = instance.DetectBlankPage(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public BlankPageDetectResults DetectBlankPage(
   BlankPageDetectOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: BlankPageDetectResults* DetectBlankPage(
   BlankPageDetectOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
BlankPageDetectResults^ DetectBlankPage(
   BlankPageDetectOptions^ options
)

Parameters

options
An object containing parameters that control the enhancement process.

Return Value

A BlankPageDetectResults object containing information about the results of the detection process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Use this function if you wish to modify the parameters controlling the analysis.

Note: This method is designed to work with document images only. Using this with photograph images may yield inaccurate or erroneous results.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


DetectBlankRectangle Method

Accusoft.ScanFixXpress8.Net
DetectBlankRectangle Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : DetectBlankRectangle Method
An object containing parameters that control the enhancement process.
Analyzes a rectangular area of an image to determine if the amount of data there is low enough to be considered blank.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function DetectBlankRectangle( _
   ByVal options As BlankRectangleDetectOptions _
) As BlankRectangleDetectResults
'Usage

Dim instance As ScanFix
Dim options As BlankRectangleDetectOptions
Dim value As BlankRectangleDetectResults

value = instance.DetectBlankRectangle(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public BlankRectangleDetectResults DetectBlankRectangle(
   BlankRectangleDetectOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: BlankRectangleDetectResults* DetectBlankRectangle(
   BlankRectangleDetectOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
BlankRectangleDetectResults^ DetectBlankRectangle(
   BlankRectangleDetectOptions^ options
)

Parameters

options
An object containing parameters that control the enhancement process.

Return Value

A BlankRectangleDetectResults object containing information about the results of the rectangle detection process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: This method is designed to work with document images only. Using this with photograph images may yield inaccurate or erroneous results.

See Also

Reference

ScanFix Class
ScanFix Members


DetectColor Method

Accusoft.ScanFixXpress8.Net
DetectColor Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : DetectColor Method
Examines an image looking for significant amounts of color data.
Overload List
Overload | Description
DetectColor() | Examines an image looking for significant amounts of color data.
DetectColor(DetectColorOptions) | Examines an image looking for significant amounts of color data, and optionally reports the location of the color data
See Also

Reference

ScanFix Class
ScanFix Members


DetectColor() Method

Accusoft.ScanFixXpress8.Net
DetectColor() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > DetectColor Method : DetectColor() Method
Examines an image looking for significant amounts of color data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Function DetectColor() As DetectColorResults
'Usage

Dim instance As ScanFix
Dim value As DetectColorResults

value = instance.DetectColor()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public DetectColorResults DetectColor()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: DetectColorResults* DetectColor();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
DetectColorResults^ DetectColor();

Return Value

A DetectColorResults object containing information about the results of the color detection process.
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Use this function if the default control parameters are adequate.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


DetectColor(DetectColorOptions) Method

Accusoft.ScanFixXpress8.Net
DetectColor(DetectColorOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > DetectColor Method : DetectColor(DetectColorOptions) Method
An object containing parameters that control the enhancement process
Examines an image looking for significant amounts of color data, and optionally reports the location of the color data
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Function DetectColor( _
   ByVal options As DetectColorOptions _
) As DetectColorResults
'Usage

Dim instance As ScanFix
Dim options As DetectColorOptions
Dim value As DetectColorResults

value = instance.DetectColor(options)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public DetectColorResults DetectColor(
   DetectColorOptions options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: DetectColorResults* DetectColor(
   DetectColorOptions* options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
DetectColorResults^ DetectColor(
   DetectColorOptions^ options
)

Parameters

options
An object containing parameters that control the enhancement process

Return Value

A DetectColorResults object containing information about the results of the color detection process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


DetectGraphicLines Method

Accusoft.ScanFixXpress8.Net
DetectGraphicLines Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : DetectGraphicLines Method
An object containing parameters that control the detection process.
Detects graphical lines from the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function DetectGraphicLines( _
   ByVal options As GraphicLineDetectionOptions _
) As GraphicLineDetectionResults
'Usage

Dim instance As ScanFix
Dim options As GraphicLineDetectionOptions
Dim value As GraphicLineDetectionResults

value = instance.DetectGraphicLines(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public GraphicLineDetectionResults DetectGraphicLines(
   GraphicLineDetectionOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: GraphicLineDetectionResults* DetectGraphicLines(
   GraphicLineDetectionOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
GraphicLineDetectionResults^ DetectGraphicLines(
   GraphicLineDetectionOptions^ options
)

Parameters

options
An object containing parameters that control the detection process.

Return Value

A GraphicLineDetectionResults object containing a list lines discovered by the line detection process.
See Also

Reference

ScanFix Class
ScanFix Members


Dilate Method

Accusoft.ScanFixXpress8.Net
Dilate Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : Dilate Method
Expands dark color pixels in the image by one in each direction.
Overload List
Overload | Description
Dilate() | Expands dark color pixels in the image by one in each direction.
Dilate(DilateOptions) | Expands similar color pixels in the image by the given amount in the given direction.
See Also

Reference

ScanFix Class
ScanFix Members


Dilate() Method

Accusoft.ScanFixXpress8.Net
Dilate() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > Dilate Method : Dilate() Method
Expands dark color pixels in the image by one in each direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Sub Dilate()
'Usage

Dim instance As ScanFix

instance.Dilate()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void Dilate()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void Dilate();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void Dilate();
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
See Also

Reference

ScanFix Class
ScanFix Members
Overload List


Dilate(DilateOptions) Method

Accusoft.ScanFixXpress8.Net
Dilate(DilateOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > Dilate Method : Dilate(DilateOptions) Method
An object containing parameters that control the enhancement process.
Expands similar color pixels in the image by the given amount in the given direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Sub Dilate( _
   ByVal options As DilateOptions _
)
'Usage

Dim instance As ScanFix
Dim options As DilateOptions

instance.Dilate(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void Dilate(
   DilateOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void Dilate(
   DilateOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void Dilate(
   DilateOptions^ options
)

Parameters

options
An object containing parameters that control the enhancement process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


Dispose Method

Accusoft.ScanFixXpress8.Net
Dispose Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : Dispose Method
This method cleans up any resources being used.
Overload List
Overload | Description
Dispose(Boolean) | This method cleans up any resources being used.
Dispose() | (Inherited from System.ComponentModel.Component)
See Also

Reference

ScanFix Class
ScanFix Members


Dispose(Boolean) Method

Accusoft.ScanFixXpress8.Net
Dispose(Boolean) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > Dispose Method : Dispose(Boolean) Method

Boolean flag to indicate behavior of this method.

Set to true to release both managed and unmanaged resources; false to release only unmanaged resources.

This method cleans up any resources being used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As ScanFix
Dim disposing As Boolean

instance.Dispose(disposing)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
protected override void Dispose(
   bool disposing
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
protected: void Dispose(
   bool disposing
) override
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing

Boolean flag to indicate behavior of this method.

Set to true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


Erode Method

Accusoft.ScanFixXpress8.Net
Erode Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : Erode Method
Removes dark color pixels in the image by one in each direction.
Overload List
Overload | Description
Erode() | Removes dark color pixels in the image by one in each direction.
Erode(ErodeOptions) | Removes dark color pixels in the image by the amount specified in the options.
See Also

Reference

ScanFix Class
ScanFix Members


Erode() Method

Accusoft.ScanFixXpress8.Net
Erode() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > Erode Method : Erode() Method
Removes dark color pixels in the image by one in each direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Sub Erode()
'Usage

Dim instance As ScanFix

instance.Erode()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void Erode()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void Erode();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void Erode();
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
See Also

Reference

ScanFix Class
ScanFix Members
Overload List


Erode(ErodeOptions) Method

Accusoft.ScanFixXpress8.Net
Erode(ErodeOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > Erode Method : Erode(ErodeOptions) Method
An object containing parameters that control the enhancement process.
Removes dark color pixels in the image by the amount specified in the options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Sub Erode( _
   ByVal options As ErodeOptions _
)
'Usage

Dim instance As ScanFix
Dim options As ErodeOptions

instance.Erode(options)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void Erode(
   ErodeOptions options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void Erode(
   ErodeOptions* options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void Erode(
   ErodeOptions^ options
)

Parameters

options
An object containing parameters that control the enhancement process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


ExecuteEnhancements Method

Accusoft.ScanFixXpress8.Net
ExecuteEnhancements Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ExecuteEnhancements Method
The enhancements to be performed on the current image.
Execute the input enhancements on the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Sub ExecuteEnhancements( _
   ByVal enhancements As Enhancements _
)
'Usage

Dim instance As ScanFix
Dim enhancements As Enhancements

instance.ExecuteEnhancements(enhancements)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void ExecuteEnhancements(
   Enhancements enhancements
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void ExecuteEnhancements(
   Enhancements* enhancements
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void ExecuteEnhancements(
   Enhancements^ enhancements
)

Parameters

enhancements
The enhancements to be performed on the current image.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

This method will apply the ScanFix enhancements to the current image in the order which they appear in the enhancement list.

Note: If an error is encountered, execution will stop at the enhancement option which causes the error and an exception will be thrown. No result will be added for an enhancement option that causes an error.

See Also

Reference

ScanFix Class
ScanFix Members


Flip Method

Accusoft.ScanFixXpress8.Net
Flip Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : Flip Method
Flips the image (swap the top and bottom).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Sub Flip()
'Usage

Dim instance As ScanFix

instance.Flip()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void Flip()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void Flip();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void Flip();
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members


FromBitmap Method

Accusoft.ScanFixXpress8.Net
FromBitmap Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : FromBitmap Method
Bitmap object to copy.
Sets the current image to a copy of the given Bitmap object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Sub FromBitmap( _
   ByVal bitmap As Bitmap _
)
'Usage

Dim instance As ScanFix
Dim bitmap As Bitmap

instance.FromBitmap(bitmap)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void FromBitmap(
   Bitmap bitmap
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void FromBitmap(
   Bitmap* bitmap
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void FromBitmap(
   Bitmap^ bitmap
)

Parameters

bitmap
Bitmap object to copy.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
See Also

Reference

ScanFix Class
ScanFix Members


FromHbitmap Method

Accusoft.ScanFixXpress8.Net
FromHbitmap Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : FromHbitmap Method
Handle to the bitmap to copy.
Sets the current image to a copy of the given HBITMAP object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Sub FromHbitmap( _
   ByVal hbitmap As IntPtr _
)
'Usage

Dim instance As ScanFix
Dim hbitmap As IntPtr

instance.FromHbitmap(hbitmap)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void FromHbitmap(
   IntPtr hbitmap
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void FromHbitmap(
   IntPtr hbitmap
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void FromHbitmap(
   IntPtr hbitmap
)

Parameters

hbitmap
Handle to the bitmap to copy.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
See Also

Reference

ScanFix Class
ScanFix Members


FromHdib Method

Accusoft.ScanFixXpress8.Net
FromHdib Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : FromHdib Method
Handle to the DIB to transfer into this component.
Sets the current image to the given HDIB object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Sub FromHdib( _
   ByVal hdib As IntPtr _
)
'Usage

Dim instance As ScanFix
Dim hdib As IntPtr

instance.FromHdib(hdib)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void FromHdib(
   IntPtr hdib
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void FromHdib(
   IntPtr hdib
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void FromHdib(
   IntPtr hdib
)

Parameters

hdib
Handle to the DIB to transfer into this component.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when argument is null.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks
Note that this component will take ownership of the DIB, so the caller must either make a copy or relinquish ownership of the DIB.
See Also

Reference

ScanFix Class
ScanFix Members


FromImage Method

Accusoft.ScanFixXpress8.Net
FromImage Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : FromImage Method
Image object to copy into this component.
Sets the current image to a copy of the given Image object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Sub FromImage( _
   ByVal image As Image _
)
'Usage

Dim instance As ScanFix
Dim image As Image

instance.FromImage(image)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void FromImage(
   Image image
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void FromImage(
   Image* image
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void FromImage(
   Image^ image
)

Parameters

image
Image object to copy into this component.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
See Also

Reference

ScanFix Class
ScanFix Members


GetRectangle Method

Accusoft.ScanFixXpress8.Net
GetRectangle Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : GetRectangle Method
A GetRectangleOptions object specifying options for the area to obtain
Replaces the current image with a subset of the original image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Sub GetRectangle( _
   ByVal options As GetRectangleOptions _
)
'Usage

Dim instance As ScanFix
Dim options As GetRectangleOptions

instance.GetRectangle(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void GetRectangle(
   GetRectangleOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void GetRectangle(
   GetRectangleOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void GetRectangle(
   GetRectangleOptions^ options
)

Parameters

options
A GetRectangleOptions object specifying options for the area to obtain
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

If the specified area extends beyond the boundaries of the original image, either pixels of the PadColor will be added or an error will occur depending upon the value of the AllowPadding property.

See Also

Reference

ScanFix Class
ScanFix Members


ImageDetergent Method

Accusoft.ScanFixXpress8.Net
ImageDetergent Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ImageDetergent Method
An object containing parameters that control the process.
Removes noise from a color image by converting colors near each selected color to the selected color. The user must specify the selected colors.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Sub ImageDetergent( _
   ByVal options As ImageDetergentOptions _
)
'Usage

Dim instance As ScanFix
Dim options As ImageDetergentOptions

instance.ImageDetergent(options)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void ImageDetergent(
   ImageDetergentOptions options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void ImageDetergent(
   ImageDetergentOptions* options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void ImageDetergent(
   ImageDetergentOptions^ options
)

Parameters

options
An object containing parameters that control the process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
See Also

Reference

ScanFix Class
ScanFix Members


Mirror Method

Accusoft.ScanFixXpress8.Net
Mirror Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : Mirror Method
Mirrors the image (swap the left and right sides).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Sub Mirror()
'Usage

Dim instance As ScanFix

instance.Mirror()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void Mirror()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void Mirror();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void Mirror();
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members


Negate Method

Accusoft.ScanFixXpress8.Net
Negate Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : Negate Method
Inverts all colors in the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Sub Negate()
'Usage

Dim instance As ScanFix

instance.Negate()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void Negate()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void Negate();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void Negate();
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

This operation turns the image into a photo-negative of itself. In color images, the invert will be performed in the RGB colorspace.

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members


PerspectiveAdjust Method

Accusoft.ScanFixXpress8.Net
PerspectiveAdjust Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : PerspectiveAdjust Method
A PerspectiveAdjustOptions that contains options to control the perspective adjustment process.
Detects and adjusts the perspective of a rectangular object in an image that is distorted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function PerspectiveAdjust( _
   ByVal options As PerspectiveAdjustOptions _
) As PerspectiveAdjustResults
'Usage

Dim instance As ScanFix
Dim options As PerspectiveAdjustOptions
Dim value As PerspectiveAdjustResults

value = instance.PerspectiveAdjust(options)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public PerspectiveAdjustResults PerspectiveAdjust(
   PerspectiveAdjustOptions options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: PerspectiveAdjustResults* PerspectiveAdjust(
   PerspectiveAdjustOptions* options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
PerspectiveAdjustResults^ PerspectiveAdjust(
   PerspectiveAdjustOptions^ options
)

Parameters

options
A PerspectiveAdjustOptions that contains options to control the perspective adjustment process.

Return Value

A PerspectiveAdjustResults object that contains the results of the perspective adjustment process.
See Also

Reference

ScanFix Class
ScanFix Members


RegisterImage Method

Accusoft.ScanFixXpress8.Net
RegisterImage Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : RegisterImage Method
Automatically positions text horizontally and vertically in the current image, providing a consistent left and top margin for documents. Use this function if the default control parameters are adequate.
Overload List
Overload | Description
RegisterImage() | Automatically positions text horizontally and vertically in the current image, providing a consistent left and top margin for documents. Use this function if the default control parameters are adequate.
RegisterImage(ImageRegistrationOptions) | Automatically positions text horizontally and vertically in the current image, providing a consistent left and top margin for documents. Use this function if you wish to modify the parameters controlling the enhancement.
See Also

Reference

ScanFix Class
ScanFix Members


RegisterImage() Method

Accusoft.ScanFixXpress8.Net
RegisterImage() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > RegisterImage Method : RegisterImage() Method
Automatically positions text horizontally and vertically in the current image, providing a consistent left and top margin for documents. Use this function if the default control parameters are adequate.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Function RegisterImage() As ImageRegistrationResults
'Usage

Dim instance As ScanFix
Dim value As ImageRegistrationResults

value = instance.RegisterImage()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public ImageRegistrationResults RegisterImage()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: ImageRegistrationResults* RegisterImage();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
ImageRegistrationResults^ RegisterImage();

Return Value

A ImageRegistrationResults object containing information about the results of the image registration process.
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Registration is helpful for Document Imaging and Forms Processing applications where accurate positioning is critical, since it makes OCR zoning of text fields in forms much more reliable.

For horizontal registration, the leftmost edge of the text is located, and positioned a fixed distance from the left edge of the image. For vertical registration, the topmost edge of the text is located, and positioned a fixed distance from the top edge of the image.

Note: When Registration adds pixels to the image, the added pixels are always white.

This method will use the default values specified in the ImageRegistrationOptions object. This means that both horizontal and vertical registration will be enabled. For more control over the registration process, see the RegisterImage(ImageRegistrationOptions) method.

Note: When using RegisterImage, we recommend that you first Deskew the image, unless you know the original is perfectly straight.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


RegisterImage(ImageRegistrationOptions) Method

Accusoft.ScanFixXpress8.Net
RegisterImage(ImageRegistrationOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > RegisterImage Method : RegisterImage(ImageRegistrationOptions) Method
An object containing parameters that control the enhancement process.
Automatically positions text horizontally and vertically in the current image, providing a consistent left and top margin for documents. Use this function if you wish to modify the parameters controlling the enhancement.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Function RegisterImage( _
   ByVal options As ImageRegistrationOptions _
) As ImageRegistrationResults
'Usage

Dim instance As ScanFix
Dim options As ImageRegistrationOptions
Dim value As ImageRegistrationResults

value = instance.RegisterImage(options)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public ImageRegistrationResults RegisterImage(
   ImageRegistrationOptions options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: ImageRegistrationResults* RegisterImage(
   ImageRegistrationOptions* options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
ImageRegistrationResults^ RegisterImage(
   ImageRegistrationOptions^ options
)

Parameters

options
An object containing parameters that control the enhancement process.

Return Value

A ImageRegistrationResults object containing information about the results of the image registration process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Registration is helpful for Document Imaging and Forms Processing applications where accurate positioning is critical, since it makes OCR zoning of text fields in forms much more reliable.

For horizontal registration, the leftmost edge of the text is located, and positioned a fixed distance from the left edge of the image. For vertical registration, the topmost edge of the text is located, and positioned a fixed distance from the top edge of the image.

Note: When Registration adds pixels to the image, the added pixels are always white.

With this overloaded method, you can activate and set the parameters for Horizontal and Vertical Registration separately. For most operations where you require a consistent left margin, you should activate Horizontal Registration. In many cases, you can leave Vertical Registration deactivated. For applications where precise text location is important, both Horizontal and Vertical Registration should be activated.

Note: When using RegisterImage, we recommend that you first Deskew the image, unless you know the original is perfectly straight.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


RemoveBlobs Method

Accusoft.ScanFixXpress8.Net
RemoveBlobs Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : RemoveBlobs Method
Locates and removes large black objects in bitonal images.
Overload List
Overload | Description
RemoveBlobs() | Locates and removes large black objects in bitonal images.
RemoveBlobs(BlobRemovalOptions) | Locates and removes large black objects in bitonal images.
See Also

Reference

ScanFix Class
ScanFix Members


RemoveBlobs() Method

Accusoft.ScanFixXpress8.Net
RemoveBlobs() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > RemoveBlobs Method : RemoveBlobs() Method
Locates and removes large black objects in bitonal images.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Function RemoveBlobs() As BlobRemovalResults
'Usage

Dim instance As ScanFix
Dim value As BlobRemovalResults

value = instance.RemoveBlobs()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public BlobRemovalResults RemoveBlobs()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: BlobRemovalResults* RemoveBlobs();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
BlobRemovalResults^ RemoveBlobs();

Return Value

A BlobRemovalResults object containing information about the results of the blob removal process.
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Use this function if the default control parameters are adequate.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


RemoveBlobs(BlobRemovalOptions) Method

Accusoft.ScanFixXpress8.Net
RemoveBlobs(BlobRemovalOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > RemoveBlobs Method : RemoveBlobs(BlobRemovalOptions) Method
An object containing parameters that control the enhancement process.
Locates and removes large black objects in bitonal images.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Function RemoveBlobs( _
   ByVal options As BlobRemovalOptions _
) As BlobRemovalResults
'Usage

Dim instance As ScanFix
Dim options As BlobRemovalOptions
Dim value As BlobRemovalResults

value = instance.RemoveBlobs(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public BlobRemovalResults RemoveBlobs(
   BlobRemovalOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: BlobRemovalResults* RemoveBlobs(
   BlobRemovalOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
BlobRemovalResults^ RemoveBlobs(
   BlobRemovalOptions^ options
)

Parameters

options
An object containing parameters that control the enhancement process.

Return Value

A BlobRemovalResults object containing information about the results of the blob removal process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


RemoveBorder Method

Accusoft.ScanFixXpress8.Net
RemoveBorder Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : RemoveBorder Method
Locates border pixels and will replace them with the specified pad color and/or remove the pixels from the image.
Overload List
Overload | Description
RemoveBorder() | Locates border pixels and will replace them with the specified pad color and/or remove the pixels from the image.
RemoveBorder(BorderRemovalOptions) | Locates border pixels and will replace them with the specified pad color and/or remove the pixels from the image. Optionally, it can also deskew the image based on the angle of the detected border.
See Also

Reference

ScanFix Class
ScanFix Members


RemoveBorder() Method

Accusoft.ScanFixXpress8.Net
RemoveBorder() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > RemoveBorder Method : RemoveBorder() Method
Locates border pixels and will replace them with the specified pad color and/or remove the pixels from the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Function RemoveBorder() As BorderRemovalResults
'Usage

Dim instance As ScanFix
Dim value As BorderRemovalResults

value = instance.RemoveBorder()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public BorderRemovalResults RemoveBorder()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: BorderRemovalResults* RemoveBorder();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
BorderRemovalResults^ RemoveBorder();

Return Value

A BorderRemovalResults object containing information about the results of the border removal process.
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Optionally, it can also deskew the image based on the angle of the detected border.

Note:Use this function if the default control parameters are adequate.

When to use border removal and what results to expect:

Border removal attempts to find "border-like" characteristics of an image. On images that it finds no suitable borders, or multiple suitable borders, a low confidence will likely to be returned. Border removal in most cases tolerates white specks in the border and black specks in the page unless the specks account for a susbstantial portion, say more than 25%, of all the pixels in a large area. Thick black or white streaks on images may cause reduced accuracy for border removal, as they resemble nice, straight edges. Irregular borders, such as the ones with white areas in the border, may cause some portions of the border to be left on the image.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


RemoveBorder(BorderRemovalOptions) Method

Accusoft.ScanFixXpress8.Net
RemoveBorder(BorderRemovalOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > RemoveBorder Method : RemoveBorder(BorderRemovalOptions) Method
An object containing parameters that control the enhancement process.
Locates border pixels and will replace them with the specified pad color and/or remove the pixels from the image. Optionally, it can also deskew the image based on the angle of the detected border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Function RemoveBorder( _
   ByVal options As BorderRemovalOptions _
) As BorderRemovalResults
'Usage

Dim instance As ScanFix
Dim options As BorderRemovalOptions
Dim value As BorderRemovalResults

value = instance.RemoveBorder(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public BorderRemovalResults RemoveBorder(
   BorderRemovalOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: BorderRemovalResults* RemoveBorder(
   BorderRemovalOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
BorderRemovalResults^ RemoveBorder(
   BorderRemovalOptions^ options
)

Parameters

options
An object containing parameters that control the enhancement process.

Return Value

A BorderRemovalResults object containing information about the results of the border removal process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

When to use border removal and what results to expect:

Border removal attempts to find "border-like" characteristics of an image. On images that it finds no suitable borders, or multiple suitable borders, a low confidence will likely to be returned. Border removal in most cases tolerates white specks in the border and black specks in the page unless the specks account for a susbstantial portion, say more than 25%, of all the pixels in a large area. Thick black or white streaks on images may cause reduced accuracy for border removal, as they resemble nice, straight edges. Irregular borders, such as the ones with white areas in the border, may cause some portions of the border to be left on the image.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


RemoveCombs Method

Accusoft.ScanFixXpress8.Net
RemoveCombs Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : RemoveCombs Method
Detects and removes combs from the current image.
Overload List
Overload | Description
RemoveCombs() | Detects and removes combs from the current image.
RemoveCombs(CombRemovalOptions) | Detects and removes combs from the current image.
See Also

Reference

ScanFix Class
ScanFix Members


RemoveCombs() Method

Accusoft.ScanFixXpress8.Net
RemoveCombs() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > RemoveCombs Method : RemoveCombs() Method
Detects and removes combs from the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Function RemoveCombs() As CombRemovalResults
'Usage

Dim instance As ScanFix
Dim value As CombRemovalResults

value = instance.RemoveCombs()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public CombRemovalResults RemoveCombs()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: CombRemovalResults* RemoveCombs();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
CombRemovalResults^ RemoveCombs();

Return Value

A CombRemovalResults object containing information about the results of the comb removal process.
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Use this function if the default control parameters are adequate.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


RemoveCombs(CombRemovalOptions) Method

Accusoft.ScanFixXpress8.Net
RemoveCombs(CombRemovalOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > RemoveCombs Method : RemoveCombs(CombRemovalOptions) Method
An object containing parameters that control the enhancement process.
Detects and removes combs from the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Function RemoveCombs( _
   ByVal options As CombRemovalOptions _
) As CombRemovalResults
'Usage

Dim instance As ScanFix
Dim options As CombRemovalOptions
Dim value As CombRemovalResults

value = instance.RemoveCombs(options)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public CombRemovalResults RemoveCombs(
   CombRemovalOptions options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: CombRemovalResults* RemoveCombs(
   CombRemovalOptions* options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
CombRemovalResults^ RemoveCombs(
   CombRemovalOptions^ options
)

Parameters

options
An object containing parameters that control the enhancement process.

Return Value

A CombRemovalResults object containing information about the results of the comb removal process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


RemoveDotShading Method

Accusoft.ScanFixXpress8.Net
RemoveDotShading Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : RemoveDotShading Method
Removes dot shading areas from a bitonal image, including actual black-on-white shading.
Overload List
Overload | Description
RemoveDotShading() | Removes dot shading areas from a bitonal image, including actual black-on-white shading.
RemoveDotShading(DotShadingRemovalOptions) | Removes dot shading areas from a bitonal image, including actual black-on-white shading.
See Also

Reference

ScanFix Class
ScanFix Members


RemoveDotShading() Method

Accusoft.ScanFixXpress8.Net
RemoveDotShading() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > RemoveDotShading Method : RemoveDotShading() Method
Removes dot shading areas from a bitonal image, including actual black-on-white shading.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Function RemoveDotShading() As DotShadingRemovalResults
'Usage

Dim instance As ScanFix
Dim value As DotShadingRemovalResults

value = instance.RemoveDotShading()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public DotShadingRemovalResults RemoveDotShading()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: DotShadingRemovalResults* RemoveDotShading();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
DotShadingRemovalResults^ RemoveDotShading();

Return Value

A DotShadingRemovalResults object containing information about the results of the dot-shading removal process.
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Use this function if the default control parameters are adequate.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


RemoveDotShading(DotShadingRemovalOptions) Method

Accusoft.ScanFixXpress8.Net
RemoveDotShading(DotShadingRemovalOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > RemoveDotShading Method : RemoveDotShading(DotShadingRemovalOptions) Method
An object containing parameters that control the enhancement process.
Removes dot shading areas from a bitonal image, including actual black-on-white shading.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Function RemoveDotShading( _
   ByVal options As DotShadingRemovalOptions _
) As DotShadingRemovalResults
'Usage

Dim instance As ScanFix
Dim options As DotShadingRemovalOptions
Dim value As DotShadingRemovalResults

value = instance.RemoveDotShading(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public DotShadingRemovalResults RemoveDotShading(
   DotShadingRemovalOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: DotShadingRemovalResults* RemoveDotShading(
   DotShadingRemovalOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
DotShadingRemovalResults^ RemoveDotShading(
   DotShadingRemovalOptions^ options
)

Parameters

options
An object containing parameters that control the enhancement process.

Return Value

A DotShadingRemovalResults object containing information about the results of the dot-shading removal process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


RemoveGraphicLines Method

Accusoft.ScanFixXpress8.Net
RemoveGraphicLines Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : RemoveGraphicLines Method
A GraphicLineRemovalOptions object containing parameters that control the line removal process.
Removes specified graphical lines from the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function RemoveGraphicLines( _
   ByVal options As GraphicLineRemovalOptions _
) As GraphicLineRemovalResults
'Usage

Dim instance As ScanFix
Dim options As GraphicLineRemovalOptions
Dim value As GraphicLineRemovalResults

value = instance.RemoveGraphicLines(options)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public GraphicLineRemovalResults RemoveGraphicLines(
   GraphicLineRemovalOptions options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: GraphicLineRemovalResults* RemoveGraphicLines(
   GraphicLineRemovalOptions* options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
GraphicLineRemovalResults^ RemoveGraphicLines(
   GraphicLineRemovalOptions^ options
)

Parameters

options
A GraphicLineRemovalOptions object containing parameters that control the line removal process.

Return Value

A GraphicLineRemovalResults object containing information about the results of the line removal process.
Remarks

Note: Use this function to remove graphical lines from an image. The lines to be removed are determined by the list of lines specified in the GraphicLineRemovalOptions parameter.

See Also

Reference

ScanFix Class
ScanFix Members


RemoveLines Method

Accusoft.ScanFixXpress8.Net
RemoveLines Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : RemoveLines Method
Detects and removes lines from the current image.
Overload List
Overload | Description
RemoveLines() | Detects and removes lines from the current image.
RemoveLines(LineRemovalOptions) | Detects and removes lines from the current image.
See Also

Reference

ScanFix Class
ScanFix Members


RemoveLines() Method

Accusoft.ScanFixXpress8.Net
RemoveLines() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > RemoveLines Method : RemoveLines() Method
Detects and removes lines from the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Function RemoveLines() As LineRemovalResults
'Usage

Dim instance As ScanFix
Dim value As LineRemovalResults

value = instance.RemoveLines()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public LineRemovalResults RemoveLines()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: LineRemovalResults* RemoveLines();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
LineRemovalResults^ RemoveLines();

Return Value

A LineRemovalResults object containing information about the results of the line removal process.
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Use this function if the default control parameters are adequate.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


RemoveLines(LineRemovalOptions) Method

Accusoft.ScanFixXpress8.Net
RemoveLines(LineRemovalOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > RemoveLines Method : RemoveLines(LineRemovalOptions) Method
A LineRemovalOptions object containing parameters that control the line removal process.
Detects and removes lines from the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Function RemoveLines( _
   ByVal options As LineRemovalOptions _
) As LineRemovalResults
'Usage

Dim instance As ScanFix
Dim options As LineRemovalOptions
Dim value As LineRemovalResults

value = instance.RemoveLines(options)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public LineRemovalResults RemoveLines(
   LineRemovalOptions options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: LineRemovalResults* RemoveLines(
   LineRemovalOptions* options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
LineRemovalResults^ RemoveLines(
   LineRemovalOptions^ options
)

Parameters

options
A LineRemovalOptions object containing parameters that control the line removal process.

Return Value

A LineRemovalResults object containing information about the results of the line removal process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


Rescale Method

Accusoft.ScanFixXpress8.Net
Rescale Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : Rescale Method
Deprecated - Use 'Rescale(Accusoft.ScanFixXpressSdk.RescaleOptions options)' constructor instead. Rescales the image with the vertical and horizontal axis rescaled independently from each other.
Overload List
Overload | Description
Rescale(Double,Double) | Deprecated - Use 'Rescale(Accusoft.ScanFixXpressSdk.RescaleOptions options)' constructor instead. Rescales the image with the vertical and horizontal axis rescaled independently from each other.
Rescale(RescaleOptions) | Rescales the image with the vertical and horizontal axis rescaled independently from each other.
See Also

Reference

ScanFix Class
ScanFix Members


Rescale(Double,Double) Method

Accusoft.ScanFixXpress8.Net
Rescale(Double,Double) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > Rescale Method : Rescale(Double,Double) Method
The horizontal magnification to apply to the image.
The vertical magnification to apply to the image.
Deprecated - Use 'Rescale(Accusoft.ScanFixXpressSdk.RescaleOptions options)' constructor instead. Rescales the image with the vertical and horizontal axis rescaled independently from each other.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Sub Rescale( _
   ByVal horizontal As Double, _
   ByVal vertical As Double _
)
'Usage

Dim instance As ScanFix
Dim horizontal As Double
Dim vertical As Double

instance.Rescale(horizontal, vertical)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void Rescale(
   double horizontal,
   double vertical
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void Rescale(
   double horizontal,
   double vertical
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void Rescale(
   double horizontal,
   double vertical
)

Parameters

horizontal
The horizontal magnification to apply to the image.
vertical
The vertical magnification to apply to the image.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


Rescale(RescaleOptions) Method

Accusoft.ScanFixXpress8.Net
Rescale(RescaleOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > Rescale Method : Rescale(RescaleOptions) Method
A RescaleOptions object containing parameters to control resizing process.
Rescales the image with the vertical and horizontal axis rescaled independently from each other.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Sub Rescale( _
   ByVal options As RescaleOptions _
)
'Usage

Dim instance As ScanFix
Dim options As RescaleOptions

instance.Rescale(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void Rescale(
   RescaleOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void Rescale(
   RescaleOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void Rescale(
   RescaleOptions^ options
)

Parameters

options
A RescaleOptions object containing parameters to control resizing process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


Rotate Method

Accusoft.ScanFixXpress8.Net
Rotate Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : Rotate Method
Rotates the image by a given angle.
Overload List
Overload | Description
Rotate(RotateOptions) | Rotates the image by a given angle.
Rotate(Double,Color) | Deprecated - Use 'Rotate(Accusoft.ScanFixXpressSdk.RotateOptions options)' constructor instead. Rotates the image by a given angle.
See Also

Reference

ScanFix Class
ScanFix Members


Rotate(RotateOptions) Method

Accusoft.ScanFixXpress8.Net
Rotate(RotateOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > Rotate Method : Rotate(RotateOptions) Method
A RotateOptions object that specifies how to rotate the image.
Rotates the image by a given angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Sub Rotate( _
   ByVal options As RotateOptions _
)
'Usage

Dim instance As ScanFix
Dim options As RotateOptions

instance.Rotate(options)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void Rotate(
   RotateOptions options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void Rotate(
   RotateOptions* options
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void Rotate(
   RotateOptions^ options
)

Parameters

options
A RotateOptions object that specifies how to rotate the image.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
See Also

Reference

ScanFix Class
ScanFix Members
Overload List


Rotate(Double,Color) Method

Accusoft.ScanFixXpress8.Net
Rotate(Double,Color) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > Rotate Method : Rotate(Double,Color) Method
The angle to rotate the image (measured in degrees).
The color to use to pad the image. If rotationAngle is a multiple of 90 degrees, no padding will be needed.
Deprecated - Use 'Rotate(Accusoft.ScanFixXpressSdk.RotateOptions options)' constructor instead. Rotates the image by a given angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Overloads Sub Rotate( _
   ByVal rotationAngle As Double, _
   ByVal padColor As Color _
)
'Usage

Dim instance As ScanFix
Dim rotationAngle As Double
Dim padColor As Color

instance.Rotate(rotationAngle, padColor)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public void Rotate(
   double rotationAngle,
   Color padColor
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: void Rotate(
   double rotationAngle,
   Color padColor
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
void Rotate(
   double rotationAngle,
   Color padColor
)

Parameters

rotationAngle
The angle to rotate the image (measured in degrees).
padColor
The color to use to pad the image. If rotationAngle is a multiple of 90 degrees, no padding will be needed.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
See Also

Reference

ScanFix Class
ScanFix Members
Overload List


Shear Method

Accusoft.ScanFixXpress8.Net
Shear Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : Shear Method
A ShearOptions object specifying the
Shears the image by the given amount.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Sub Shear( _
   ByVal options As ShearOptions _
)
'Usage

Dim instance As ScanFix
Dim options As ShearOptions

instance.Shear(options)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void Shear(
   ShearOptions options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void Shear(
   ShearOptions* options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void Shear(
   ShearOptions^ options
)

Parameters

options
A ShearOptions object specifying the
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members


SmoothObjects Method

Accusoft.ScanFixXpress8.Net
SmoothObjects Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : SmoothObjects Method
Smoothes the edges of characters in a bitonal image by the amount specified in the options.
Overload List
Overload | Description
SmoothObjects(SmoothObjectsOptions) | Smoothes the edges of characters in a bitonal image by the amount specified in the options.
SmoothObjects(Int32) | Deprecated - Use 'SmoothObjects(Accusoft.ScanFixXpressSdk.SmoothObjectsOptions options)' constructor instead. Smoothes the edges of characters in a bitonal image by the amount specified in the options.
SmoothObjects() | Smoothes edges in the image by the default amount in a bitonal image.
See Also

Reference

ScanFix Class
ScanFix Members


SmoothObjects(SmoothObjectsOptions) Method

Accusoft.ScanFixXpress8.Net
SmoothObjects(SmoothObjectsOptions) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > SmoothObjects Method : SmoothObjects(SmoothObjectsOptions) Method
A SmoothObjectsOptions object that specifies how to smooth the image.
Smoothes the edges of characters in a bitonal image by the amount specified in the options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Sub SmoothObjects( _
   ByVal options As SmoothObjectsOptions _
)
'Usage

Dim instance As ScanFix
Dim options As SmoothObjectsOptions

instance.SmoothObjects(options)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void SmoothObjects(
   SmoothObjectsOptions options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void SmoothObjects(
   SmoothObjectsOptions* options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void SmoothObjects(
   SmoothObjectsOptions^ options
)

Parameters

options
A SmoothObjectsOptions object that specifies how to smooth the image.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


SmoothObjects(Int32) Method

Accusoft.ScanFixXpress8.Net
SmoothObjects(Int32) Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > SmoothObjects Method : SmoothObjects(Int32) Method
The size limit of pits and bumps to smooth in the given image.
Deprecated - Use 'SmoothObjects(Accusoft.ScanFixXpressSdk.SmoothObjectsOptions options)' constructor instead. Smoothes the edges of characters in a bitonal image by the amount specified in the options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Sub SmoothObjects( _
   ByVal amount As Integer _
)
'Usage

Dim instance As ScanFix
Dim amount As Integer

instance.SmoothObjects(amount)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void SmoothObjects(
   int amount
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void SmoothObjects(
   int amount
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void SmoothObjects(
   int amount
)

Parameters

amount
The size limit of pits and bumps to smooth in the given image.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


SmoothObjects() Method

Accusoft.ScanFixXpress8.Net
SmoothObjects() Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class > SmoothObjects Method : SmoothObjects() Method
Smoothes edges in the image by the default amount in a bitonal image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Overloads Sub SmoothObjects()
'Usage

Dim instance As ScanFix

instance.SmoothObjects()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void SmoothObjects()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void SmoothObjects();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void SmoothObjects();
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this method if the default amount of 3 is acceptable.

See Also

Reference

ScanFix Class
ScanFix Members
Overload List


SmoothZoom Method

Accusoft.ScanFixXpress8.Net
SmoothZoom Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : SmoothZoom Method
Replaces the current image with a new image whose width and height have been doubled and whose pixels have been smoothed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Sub SmoothZoom()
'Usage

Dim instance As ScanFix

instance.SmoothZoom()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void SmoothZoom()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void SmoothZoom();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void SmoothZoom();
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

Note: Use this function if you wish to modify the parameters controlling the enhancement.

See Also

Reference

ScanFix Class
ScanFix Members


ToBitmap Method

Accusoft.ScanFixXpress8.Net
ToBitmap Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ToBitmap Method
Returns a new Bitmap object that contains a copy of this component's current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function ToBitmap() As Bitmap
'Usage

Dim instance As ScanFix
Dim value As Bitmap

value = instance.ToBitmap()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public Bitmap ToBitmap()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: Bitmap* ToBitmap();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
Bitmap^ ToBitmap();

Return Value

Bitmap object containing a copy of the current image.
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
See Also

Reference

ScanFix Class
ScanFix Members


ToHdib Method

Accusoft.ScanFixXpress8.Net
ToHdib Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ToHdib Method
Set true to force this component to release ownership of the DIB or false for the component to retain ownership of the DIB.
Returns the DIB containing the component's current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function ToHdib( _
   ByVal release As Boolean _
) As IntPtr
'Usage

Dim instance As ScanFix
Dim release As Boolean
Dim value As IntPtr

value = instance.ToHdib(release)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public IntPtr ToHdib(
   bool release
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: IntPtr ToHdib(
   bool release
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
IntPtr ToHdib(
   bool release
)

Parameters

release
Set true to force this component to release ownership of the DIB or false for the component to retain ownership of the DIB.

Return Value

Handle to a DIB containing the current image.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks
If the caller wishes to take ownership of the DIB (the normal case), then the release parameter should be set to true.
See Also

Reference

ScanFix Class
ScanFix Members


ToImage Method

Accusoft.ScanFixXpress8.Net
ToImage Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ToImage Method
Returns a new Image object that contains a copy of this component's current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function ToImage() As Image
'Usage

Dim instance As ScanFix
Dim value As Image

value = instance.ToImage()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public Image ToImage()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: Image* ToImage();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
Image^ ToImage();

Return Value

Image object containing a copy of the current image.
Exceptions
Exception | Description
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
See Also

Reference

ScanFix Class
ScanFix Members


TransferTo Method

Accusoft.ScanFixXpress8.Net
TransferTo Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : TransferTo Method
Desired new owner of the image data.
Designed to make passing image data between different Accusoft components easier, this method transfers this object's image data to another object which can be defined in a different Accusoft assembly. When finished, this object will no longer contain image data; the image data will be owned by the destination object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Sub TransferTo( _
   ByVal Destination As Object _
)
'Usage

Dim instance As ScanFix
Dim Destination As Object

instance.TransferTo(Destination)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void TransferTo(
   object Destination
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void TransferTo(
   Object* Destination
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void TransferTo(
   Object^ Destination
)

Parameters

Destination
Desired new owner of the image data.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentException | Thrown when Destination object is not capable of accepting the image.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks
Not all object types are valid destinations for this method. If the destination object does not support being transferred to, a System.ArgumentException will be thrown. Refer to the documentation of a particular class to see if it officially supports being the destination of a TransferTo method.
See Also

Reference

ScanFix Class
ScanFix Members


VirtualBulb Method

Accusoft.ScanFixXpress8.Net
VirtualBulb Method

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : VirtualBulb Method
An object containing parameters that control the process.
Emulates a dropout scanner, and cleans an image by converting the selected hues to white, nearby hues to shades of gray and all other hues to black.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Sub VirtualBulb( _
   ByVal options As VirtualBulbOptions _
)
'Usage

Dim instance As ScanFix
Dim options As VirtualBulbOptions

instance.VirtualBulb(options)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public void VirtualBulb(
   VirtualBulbOptions options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: void VirtualBulb(
   VirtualBulbOptions* options
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
void VirtualBulb(
   VirtualBulbOptions^ options
)

Parameters

options
An object containing parameters that control the process.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
See Also

Reference

ScanFix Class
ScanFix Members


Debug Property

Accusoft.ScanFixXpress8.Net
Debug Property

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : Debug Property
Gets and sets a flag to indicate if debug information is sent to a debug file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Debug As Boolean
'Usage

Dim instance As ScanFix
Dim value As Boolean

instance.Debug = value

value = instance.Debug
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public bool Debug {get; set;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property bool get_Debug();
public: __property void set_Debug(
   bool value
);
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property bool Debug {
   bool get();
   void set (    bool value);
}
Remarks

The default value is false.

This property allows you to turn the debug log file on or off without changing any of the other debug settings. When this is true, the toolkit will write items to the debug log file, as specified by the DebugLogFile and ErrorLevel properties.

See Also

Reference

ScanFix Class
ScanFix Members


DebugLogFile Property

Accusoft.ScanFixXpress8.Net
DebugLogFile Property

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : DebugLogFile Property
Gets and sets the debug log file name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property DebugLogFile As String
'Usage

Dim instance As ScanFix
Dim value As String

instance.DebugLogFile = value

value = instance.DebugLogFile
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public string DebugLogFile {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property string* get_DebugLogFile();
public: __property void set_DebugLogFile(
   string* value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property String^ DebugLogFile {
   String^ get();
   void set (    String^ value);
}
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

This property allows you to control the location and name of the debug log file.

The default value is "[Temp Files]\ScanFix6.log". If the ScanFix component is being run inside a web browser then the default value cannot be changed.

Valid values are any valid filename and path.

The default value for this property is suitable for interactive use. If you are using the component in a service or other type of system that runs in the background, you should set the filename to a more suitable value.

Note: This property will have no effect if you set the Debug property to false.

See Also

Reference

ScanFix Class
ScanFix Members


ErrorLevel Property

Accusoft.ScanFixXpress8.Net
ErrorLevel Property

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ErrorLevel Property
Gets and sets level for items to be written to the debug log file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property ErrorLevel As ErrorLevel
'Usage

Dim instance As ScanFix
Dim value As ErrorLevel

instance.ErrorLevel = value

value = instance.ErrorLevel
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ErrorLevel ErrorLevel {get; set;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property ErrorLevel get_ErrorLevel();
public: __property void set_ErrorLevel(
   ErrorLevel value
);
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property ErrorLevel ErrorLevel {
   ErrorLevel get();
   void set (    ErrorLevel value);
}
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
Remarks

The default value is Production.

Valid values are from the ErrorLevel enumeration which includes Production, Development and Detailed.

This property allows you to control the amount of information that is written into the DebugLogFile.

Note: Since it takes some amount of time to generate and write debug log items, you should set this to write the least amount of information that you will find useful.

Note: This property will have no effect if you set the Debug property to false.

See Also

Reference

ScanFix Class
ScanFix Members


HorizontalResolution Property

Accusoft.ScanFixXpress8.Net
HorizontalResolution Property

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : HorizontalResolution Property
Gets and sets the horizontal resolution of the current image in units determined by the current ResolutionUnits property setting.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property HorizontalResolution As Single
'Usage

Dim instance As ScanFix
Dim value As Single

instance.HorizontalResolution = value

value = instance.HorizontalResolution
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public float HorizontalResolution {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property float get_HorizontalResolution();
public: __property void set_HorizontalResolution(
   float value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property float HorizontalResolution {
   float get();
   void set (    float value);
}
See Also

Reference

ScanFix Class
ScanFix Members


ImageHeight Property

Accusoft.ScanFixXpress8.Net
ImageHeight Property

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ImageHeight Property
Gets height of the current image in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public ReadOnly Property ImageHeight As Integer
'Usage

Dim instance As ScanFix
Dim value As Integer

value = instance.ImageHeight
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public int ImageHeight {get;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property int get_ImageHeight();
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property int ImageHeight {
   int get();
}

Property Value

An Int32 containing the height of the image.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
See Also

Reference

ScanFix Class
ScanFix Members


ImageResolution Property

Accusoft.ScanFixXpress8.Net
ImageResolution Property

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ImageResolution Property
Gets resolution object for ScanFix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property ImageResolution As Resolution
'Usage

Dim instance As ScanFix
Dim value As Resolution

value = instance.ImageResolution
[BrowsableAttribute(false)]
public Resolution ImageResolution {get;}
[BrowsableAttribute(false)]
public: __property Resolution* get_ImageResolution();
[BrowsableAttribute(false)]
public:
property Resolution^ ImageResolution {
   Resolution^ get();
}
See Also

Reference

ScanFix Class
ScanFix Members


ImageWidth Property

Accusoft.ScanFixXpress8.Net
ImageWidth Property

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ImageWidth Property
Gets width of the current image in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public ReadOnly Property ImageWidth As Integer
'Usage

Dim instance As ScanFix
Dim value As Integer

value = instance.ImageWidth
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public int ImageWidth {get;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property int get_ImageWidth();
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property int ImageWidth {
   int get();
}
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
See Also

Reference

ScanFix Class
ScanFix Members


Licensing Property

Accusoft.ScanFixXpress8.Net
Licensing Property

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : Licensing Property
Gets licensing information object for ScanFix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Licensing As Licensing
'Usage

Dim instance As ScanFix
Dim value As Licensing

value = instance.Licensing
[BrowsableAttribute(false)]
public Licensing Licensing {get;}
[BrowsableAttribute(false)]
public: __property Licensing* get_Licensing();
[BrowsableAttribute(false)]
public:
property Licensing^ Licensing {
   Licensing^ get();
}
See Also

Reference

ScanFix Class
ScanFix Members


ResolutionUnits Property

Accusoft.ScanFixXpress8.Net
ResolutionUnits Property

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : ResolutionUnits Property
Gets and sets the unit of measure for the vertical and horizontal resolutions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
Public Property ResolutionUnits As GraphicsUnit
'Usage

Dim instance As ScanFix
Dim value As GraphicsUnit

instance.ResolutionUnits = value

value = instance.ResolutionUnits
[BrowsableAttribute(true)]
public GraphicsUnit ResolutionUnits {get; set;}
[BrowsableAttribute(true)]
public: __property GraphicsUnit get_ResolutionUnits();
public: __property void set_ResolutionUnits(
   GraphicsUnit value
);
[BrowsableAttribute(true)]
public:
property GraphicsUnit ResolutionUnits {
   GraphicsUnit get();
   void set (    GraphicsUnit value);
}
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when required argument value is null.
System.ArgumentOutOfRangeException | Thrown when argument is out of range.
System.ComponentModel.InvalidEnumArgumentException | Thrown when argument enum value is invalid.
System.InvalidOperationException | Thrown when method cannot operate correctly.
ScanFixUnsupportedImageException | Thrown when image type is unsupported.
ScanFixException | Thrown when operation failed.
See Also

Reference

ScanFix Class
ScanFix Members


VerticalResolution Property

Accusoft.ScanFixXpress8.Net
VerticalResolution Property

Accusoft.ScanFixXpressSdk Namespace > ScanFix Class : VerticalResolution Property
Gets and sets the vertical resolution of the current image in units determined by the current ResolutionUnits property setting.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property VerticalResolution As Single
'Usage

Dim instance As ScanFix
Dim value As Single

instance.VerticalResolution = value

value = instance.VerticalResolution
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public float VerticalResolution {get; set;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property float get_VerticalResolution();
public: __property void set_VerticalResolution(
   float value
);
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property float VerticalResolution {
   float get();
   void set (    float value);
}
See Also

Reference

ScanFix Class
ScanFix Members


ScanFixException Class

Accusoft.ScanFixXpress8.Net
ScanFixException Class
Members

Accusoft.ScanFixXpressSdk Namespace : ScanFixException Class
Provides a base class that handles all the exceptions generated by ScanFix Xpress.
Object Model
ScanFixException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class ScanFixException
   Inherits System.Exception
'Usage

Dim instance As ScanFixException
[SerializableAttribute()]
public class ScanFixException : System.Exception
[SerializableAttribute()]
public __gc class ScanFixException : public System.Exception
[SerializableAttribute()]
public ref class ScanFixException : public System.Exception
Inheritance Hierarchy

System.Object
System.Exception
Accusoft.ScanFixXpressSdk.ScanFixException
Accusoft.ScanFixXpressSdk.ScanFixUnsupportedImageException

See Also

Reference

ScanFixException Members
Accusoft.ScanFixXpressSdk Namespace


ScanFixException Class Members

Accusoft.ScanFixXpress8.Net
ScanFixException Class Members
Properties Methods Events

Accusoft.ScanFixXpressSdk Namespace : ScanFixException Class

The following tables list the members exposed by ScanFixException.

Public Constructors
 | Name | Description
Public Constructor | ScanFixException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the error number
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | Overridden. Completes ISerializable implementation to satisfy CA2240
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
Protected Events
 | Name | Description
Protected Event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from System.Exception)
Top
See Also

Reference

ScanFixException Class
Accusoft.ScanFixXpressSdk Namespace


ScanFixException Class Properties

Accusoft.ScanFixXpress8.Net
ScanFixException Class Properties

Accusoft.ScanFixXpressSdk Namespace : ScanFixException Class

For a list of all members of this type, see ScanFixException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the error number
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

ScanFixException Class
Accusoft.ScanFixXpressSdk Namespace


ScanFixException Class Methods

Accusoft.ScanFixXpress8.Net
ScanFixException Class Methods

Accusoft.ScanFixXpressSdk Namespace : ScanFixException Class

For a list of all members of this type, see ScanFixException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | Overridden. Completes ISerializable implementation to satisfy CA2240
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

ScanFixException Class
Accusoft.ScanFixXpressSdk Namespace


ScanFixException Class Events

Accusoft.ScanFixXpress8.Net
ScanFixException Class Events

Accusoft.ScanFixXpressSdk Namespace : ScanFixException Class

For a list of all members of this type, see ScanFixException members.

Protected Events
 | Name | Description
Protected Event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from System.Exception)
Top
See Also

Reference

ScanFixException Class
Accusoft.ScanFixXpressSdk Namespace


ScanFixException Constructor

Accusoft.ScanFixXpress8.Net
ScanFixException Constructor

Accusoft.ScanFixXpressSdk Namespace > ScanFixException Class : ScanFixException Constructor
Overload List
Overload | Description
ScanFixException Constructor() | Instantiates a default exception
ScanFixException Constructor(String) | Instantiates an exception containing a message.
ScanFixException Constructor(String,Int32) | Instantiates an exception containing a Message and number.
ScanFixException Constructor(String,Exception) | Instantiates an exception containing a Message and inner exception.
ScanFixException Constructor(SerializationInfo,StreamingContext) | Instantiates an exception containing SerializationInfo and StreamingContext.
See Also

Reference

ScanFixException Class
ScanFixException Members


ScanFixException Constructor()

Accusoft.ScanFixXpress8.Net
ScanFixException Constructor()

Accusoft.ScanFixXpressSdk Namespace > ScanFixException Class > ScanFixException Constructor : ScanFixException Constructor()
Instantiates a default exception
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New ScanFixException()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public ScanFixException()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: ScanFixException();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
ScanFixException();
See Also

Reference

ScanFixException Class
ScanFixException Members
Overload List


ScanFixException Constructor(String)

Accusoft.ScanFixXpress8.Net
ScanFixException Constructor(String)

Accusoft.ScanFixXpressSdk Namespace > ScanFixException Class > ScanFixException Constructor : ScanFixException Constructor(String)
Brief description of the exception.
Instantiates an exception containing a message.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New ScanFixException(message)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public ScanFixException(
   string message
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: ScanFixException(
   string* message
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
ScanFixException(
   String^ message
)

Parameters

message
Brief description of the exception.
See Also

Reference

ScanFixException Class
ScanFixException Members
Overload List


ScanFixException Constructor(String,Int32)

Accusoft.ScanFixXpress8.Net
ScanFixException Constructor(String,Int32)

Accusoft.ScanFixXpressSdk Namespace > ScanFixException Class > ScanFixException Constructor : ScanFixException Constructor(String,Int32)
Error message of the exception.
Integer indicating exception number.
Instantiates an exception containing a Message and number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal message As String, _
   ByVal number As Integer _
)
'Usage

Dim message As String
Dim number As Integer

Dim instance As New ScanFixException(message, number)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public ScanFixException(
   string message,
   int number
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: ScanFixException(
   string* message,
   int number
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
ScanFixException(
   String^ message,
   int number
)

Parameters

message
Error message of the exception.
number
Integer indicating exception number.
See Also

Reference

ScanFixException Class
ScanFixException Members
Overload List


ScanFixException Constructor(String,Exception)

Accusoft.ScanFixXpress8.Net
ScanFixException Constructor(String,Exception)

Accusoft.ScanFixXpressSdk Namespace > ScanFixException Class > ScanFixException Constructor : ScanFixException Constructor(String,Exception)
Error message of the exception.
An exception from the system.
Instantiates an exception containing a Message and inner exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New ScanFixException(message, innerException)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public ScanFixException(
   string message,
   Exception innerException
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: ScanFixException(
   string* message,
   Exception* innerException
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
ScanFixException(
   String^ message,
   Exception^ innerException
)

Parameters

message
Error message of the exception.
innerException
An exception from the system.
See Also

Reference

ScanFixException Class
ScanFixException Members
Overload List


ScanFixException Constructor(SerializationInfo,StreamingContext)

Accusoft.ScanFixXpress8.Net
ScanFixException Constructor(SerializationInfo,StreamingContext)

Accusoft.ScanFixXpressSdk Namespace > ScanFixException Class > ScanFixException Constructor : ScanFixException Constructor(SerializationInfo,StreamingContext)
Instantiates an exception containing SerializationInfo and StreamingContext.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Protected Function New( _
   ByVal c0c5d47c3550304ab280358243ab66bd5 As SerializationInfo, _
   ByVal cdb337b54bb8e308f8a34cd92a6ec60df As StreamingContext _
)
'Usage

Dim c0c5d47c3550304ab280358243ab66bd5 As SerializationInfo
Dim cdb337b54bb8e308f8a34cd92a6ec60df As StreamingContext

Dim instance As New ScanFixException(c0c5d47c3550304ab280358243ab66bd5, cdb337b54bb8e308f8a34cd92a6ec60df)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
protected ScanFixException(
   SerializationInfo c0c5d47c3550304ab280358243ab66bd5,
   StreamingContext cdb337b54bb8e308f8a34cd92a6ec60df
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
protected: ScanFixException(
   SerializationInfo* c0c5d47c3550304ab280358243ab66bd5,
   StreamingContext cdb337b54bb8e308f8a34cd92a6ec60df
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
protected:
ScanFixException(
   SerializationInfo^ c0c5d47c3550304ab280358243ab66bd5,
   StreamingContext cdb337b54bb8e308f8a34cd92a6ec60df
)

Parameters

c0c5d47c3550304ab280358243ab66bd5
cdb337b54bb8e308f8a34cd92a6ec60df
See Also

Reference

ScanFixException Class
ScanFixException Members
Overload List


GetObjectData Method

Accusoft.ScanFixXpress8.Net
GetObjectData Method

Accusoft.ScanFixXpressSdk Namespace > ScanFixException Class : GetObjectData Method
serialization info
streaming context
Completes ISerializable implementation to satisfy CA2240
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
<SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
<SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As ScanFixException
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
[SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
[SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
[SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
[SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
[SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
[SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
serialization info
context
streaming context
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when info parameter is null
See Also

Reference

ScanFixException Class
ScanFixException Members


Number Property

Accusoft.ScanFixXpress8.Net
Number Property

Accusoft.ScanFixXpressSdk Namespace > ScanFixException Class : Number Property
Gets the error number
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Number As Integer
'Usage

Dim instance As ScanFixException
Dim value As Integer

value = instance.Number
public int Number {get;}
public: __property int get_Number();
public:
property int Number {
   int get();
}

Property Value

A specific integer value for the exception condition.
See Also

Reference

ScanFixException Class
ScanFixException Members


ScanFixUnsupportedImageException Class

Accusoft.ScanFixXpress8.Net
ScanFixUnsupportedImageException Class
Members

Accusoft.ScanFixXpressSdk Namespace : ScanFixUnsupportedImageException Class
Handles exceptions in the case an image is not supported by ScanFix.
Object Model
ScanFixUnsupportedImageException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class ScanFixUnsupportedImageException
   Inherits ScanFixException
'Usage

Dim instance As ScanFixUnsupportedImageException
[SerializableAttribute()]
public class ScanFixUnsupportedImageException : ScanFixException
[SerializableAttribute()]
public __gc class ScanFixUnsupportedImageException : public ScanFixException
[SerializableAttribute()]
public ref class ScanFixUnsupportedImageException : public ScanFixException
Inheritance Hierarchy

System.Object
System.Exception
Accusoft.ScanFixXpressSdk.ScanFixException
Accusoft.ScanFixXpressSdk.ScanFixUnsupportedImageException

See Also

Reference

ScanFixUnsupportedImageException Members
Accusoft.ScanFixXpressSdk Namespace


ScanFixUnsupportedImageException Class Members

Accusoft.ScanFixXpress8.Net
ScanFixUnsupportedImageException Class Members
Properties Methods Events

Accusoft.ScanFixXpressSdk Namespace : ScanFixUnsupportedImageException Class

The following tables list the members exposed by ScanFixUnsupportedImageException.

Public Constructors
 | Name | Description
Public Constructor | ScanFixUnsupportedImageException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the error number (Inherited from Accusoft.ScanFixXpressSdk.ScanFixException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | Completes ISerializable implementation to satisfy CA2240 (Inherited from Accusoft.ScanFixXpressSdk.ScanFixException)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
Protected Events
 | Name | Description
Protected Event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from System.Exception)
Top
See Also

Reference

ScanFixUnsupportedImageException Class
Accusoft.ScanFixXpressSdk Namespace


ScanFixUnsupportedImageException Class Properties

Accusoft.ScanFixXpress8.Net
ScanFixUnsupportedImageException Class Properties

Accusoft.ScanFixXpressSdk Namespace : ScanFixUnsupportedImageException Class

For a list of all members of this type, see ScanFixUnsupportedImageException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the error number (Inherited from Accusoft.ScanFixXpressSdk.ScanFixException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

ScanFixUnsupportedImageException Class
Accusoft.ScanFixXpressSdk Namespace


ScanFixUnsupportedImageException Class Methods

Accusoft.ScanFixXpress8.Net
ScanFixUnsupportedImageException Class Methods

Accusoft.ScanFixXpressSdk Namespace : ScanFixUnsupportedImageException Class

For a list of all members of this type, see ScanFixUnsupportedImageException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | Completes ISerializable implementation to satisfy CA2240 (Inherited from Accusoft.ScanFixXpressSdk.ScanFixException)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

ScanFixUnsupportedImageException Class
Accusoft.ScanFixXpressSdk Namespace


ScanFixUnsupportedImageException Class Events

Accusoft.ScanFixXpress8.Net
ScanFixUnsupportedImageException Class Events

Accusoft.ScanFixXpressSdk Namespace : ScanFixUnsupportedImageException Class

For a list of all members of this type, see ScanFixUnsupportedImageException members.

Protected Events
 | Name | Description
Protected Event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from System.Exception)
Top
See Also

Reference

ScanFixUnsupportedImageException Class
Accusoft.ScanFixXpressSdk Namespace


ScanFixUnsupportedImageException Constructor

Accusoft.ScanFixXpress8.Net
ScanFixUnsupportedImageException Constructor

Accusoft.ScanFixXpressSdk Namespace > ScanFixUnsupportedImageException Class : ScanFixUnsupportedImageException Constructor
Overload List
Overload | Description
ScanFixUnsupportedImageException Constructor() | Instantiates an exception containing the default information.
ScanFixUnsupportedImageException Constructor(String) | Instantiates an exception containing a message.
ScanFixUnsupportedImageException Constructor(String,Int32) | Instantiates an exception containing a Message and number.
ScanFixUnsupportedImageException Constructor(String,Exception) | Instantiates an exception containing a Message and inner exception.
ScanFixUnsupportedImageException Constructor(SerializationInfo,StreamingContext) | Instantiates an exception containing SerializationInfo and a StreamingContext.
See Also

Reference

ScanFixUnsupportedImageException Class
ScanFixUnsupportedImageException Members


ScanFixUnsupportedImageException Constructor()

Accusoft.ScanFixXpress8.Net
ScanFixUnsupportedImageException Constructor()

Accusoft.ScanFixXpressSdk Namespace > ScanFixUnsupportedImageException Class > ScanFixUnsupportedImageException Constructor : ScanFixUnsupportedImageException Constructor()
Instantiates an exception containing the default information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New()
'Usage

Dim instance As New ScanFixUnsupportedImageException()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public ScanFixUnsupportedImageException()
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: ScanFixUnsupportedImageException();
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
ScanFixUnsupportedImageException();
See Also

Reference

ScanFixUnsupportedImageException Class
ScanFixUnsupportedImageException Members
Overload List


ScanFixUnsupportedImageException Constructor(String)

Accusoft.ScanFixXpress8.Net
ScanFixUnsupportedImageException Constructor(String)

Accusoft.ScanFixXpressSdk Namespace > ScanFixUnsupportedImageException Class > ScanFixUnsupportedImageException Constructor : ScanFixUnsupportedImageException Constructor(String)
Error message of the exception.
Instantiates an exception containing a message.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New ScanFixUnsupportedImageException(message)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public ScanFixUnsupportedImageException(
   string message
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: ScanFixUnsupportedImageException(
   string* message
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
ScanFixUnsupportedImageException(
   String^ message
)

Parameters

message
Error message of the exception.
See Also

Reference

ScanFixUnsupportedImageException Class
ScanFixUnsupportedImageException Members
Overload List


ScanFixUnsupportedImageException Constructor(String,Int32)

Accusoft.ScanFixXpress8.Net
ScanFixUnsupportedImageException Constructor(String,Int32)

Accusoft.ScanFixXpressSdk Namespace > ScanFixUnsupportedImageException Class > ScanFixUnsupportedImageException Constructor : ScanFixUnsupportedImageException Constructor(String,Int32)
Error message of the exception.
An integer that represents the error number.
Instantiates an exception containing a Message and number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal message As String, _
   ByVal number As Integer _
)
'Usage

Dim message As String
Dim number As Integer

Dim instance As New ScanFixUnsupportedImageException(message, number)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public ScanFixUnsupportedImageException(
   string message,
   int number
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: ScanFixUnsupportedImageException(
   string* message,
   int number
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
ScanFixUnsupportedImageException(
   String^ message,
   int number
)

Parameters

message
Error message of the exception.
number
An integer that represents the error number.
See Also

Reference

ScanFixUnsupportedImageException Class
ScanFixUnsupportedImageException Members
Overload List


ScanFixUnsupportedImageException Constructor(String,Exception)

Accusoft.ScanFixXpress8.Net
ScanFixUnsupportedImageException Constructor(String,Exception)

Accusoft.ScanFixXpressSdk Namespace > ScanFixUnsupportedImageException Class > ScanFixUnsupportedImageException Constructor : ScanFixUnsupportedImageException Constructor(String,Exception)
Error message of the exception.
An inner exception from the base constructor.
Instantiates an exception containing a Message and inner exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New ScanFixUnsupportedImageException(message, innerException)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public ScanFixUnsupportedImageException(
   string message,
   Exception innerException
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: ScanFixUnsupportedImageException(
   string* message,
   Exception* innerException
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
ScanFixUnsupportedImageException(
   String^ message,
   Exception^ innerException
)

Parameters

message
Error message of the exception.
innerException
An inner exception from the base constructor.
See Also

Reference

ScanFixUnsupportedImageException Class
ScanFixUnsupportedImageException Members
Overload List


ScanFixUnsupportedImageException Constructor(SerializationInfo,StreamingContext)

Accusoft.ScanFixXpress8.Net
ScanFixUnsupportedImageException Constructor(SerializationInfo,StreamingContext)

Accusoft.ScanFixXpressSdk Namespace > ScanFixUnsupportedImageException Class > ScanFixUnsupportedImageException Constructor : ScanFixUnsupportedImageException Constructor(SerializationInfo,StreamingContext)
Instantiates an exception containing SerializationInfo and a StreamingContext.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Protected Function New( _
   ByVal c0c5d47c3550304ab280358243ab66bd5 As SerializationInfo, _
   ByVal cdb337b54bb8e308f8a34cd92a6ec60df As StreamingContext _
)
'Usage

Dim c0c5d47c3550304ab280358243ab66bd5 As SerializationInfo
Dim cdb337b54bb8e308f8a34cd92a6ec60df As StreamingContext

Dim instance As New ScanFixUnsupportedImageException(c0c5d47c3550304ab280358243ab66bd5, cdb337b54bb8e308f8a34cd92a6ec60df)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
protected ScanFixUnsupportedImageException(
   SerializationInfo c0c5d47c3550304ab280358243ab66bd5,
   StreamingContext cdb337b54bb8e308f8a34cd92a6ec60df
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
protected: ScanFixUnsupportedImageException(
   SerializationInfo* c0c5d47c3550304ab280358243ab66bd5,
   StreamingContext cdb337b54bb8e308f8a34cd92a6ec60df
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
protected:
ScanFixUnsupportedImageException(
   SerializationInfo^ c0c5d47c3550304ab280358243ab66bd5,
   StreamingContext cdb337b54bb8e308f8a34cd92a6ec60df
)

Parameters

c0c5d47c3550304ab280358243ab66bd5
cdb337b54bb8e308f8a34cd92a6ec60df
See Also

Reference

ScanFixUnsupportedImageException Class
ScanFixUnsupportedImageException Members
Overload List


ShearOptions Class

Accusoft.ScanFixXpress8.Net
ShearOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : ShearOptions Class
Contains parameters that control the ScanFix.Shear enhancement process.
Object Model
ShearOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ShearOptions
   Inherits EnhancementOption
'Usage

Dim instance As ShearOptions
public class ShearOptions : EnhancementOption
public __gc class ShearOptions : public EnhancementOption
public ref class ShearOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.ShearOptions

See Also

Reference

ShearOptions Members
Accusoft.ScanFixXpressSdk Namespace


ShearOptions Class Members

Accusoft.ScanFixXpress8.Net
ShearOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : ShearOptions Class

The following tables list the members exposed by ShearOptions.

Public Constructors
 | Name | Description
Public Constructor | ShearOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | PadColor | The color to use to pad the image.
Public Property | ShearAngle | Gets and sets the amount of shear to apply to the image.
Top
See Also

Reference

ShearOptions Class
Accusoft.ScanFixXpressSdk Namespace


ShearOptions Class Properties

Accusoft.ScanFixXpress8.Net
ShearOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : ShearOptions Class

For a list of all members of this type, see ShearOptions members.

Public Properties
 | Name | Description
Public Property | PadColor | The color to use to pad the image.
Public Property | ShearAngle | Gets and sets the amount of shear to apply to the image.
Top
See Also

Reference

ShearOptions Class
Accusoft.ScanFixXpressSdk Namespace


ShearOptions Constructor

Accusoft.ScanFixXpress8.Net
ShearOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > ShearOptions Class : ShearOptions Constructor
Overload List
Overload | Description
ShearOptions Constructor() | Instantiates a new ShearOptions object with the default values.
ShearOptions Constructor(Double,Color) | Instantiates a new ShearOptions object setting the specified values.
See Also

Reference

ShearOptions Class
ShearOptions Members


ShearOptions Constructor()

Accusoft.ScanFixXpress8.Net
ShearOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > ShearOptions Class > ShearOptions Constructor : ShearOptions Constructor()
Instantiates a new ShearOptions object with the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New ShearOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public ShearOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: ShearOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
ShearOptions();
See Also

Reference

ShearOptions Class
ShearOptions Members
Overload List


ShearOptions Constructor(Double,Color)

Accusoft.ScanFixXpress8.Net
ShearOptions Constructor(Double,Color)

Accusoft.ScanFixXpressSdk Namespace > ShearOptions Class > ShearOptions Constructor : ShearOptions Constructor(Double,Color)
The amount of shear to apply to the image.
The color used for new pixels that are added to the image.
Instantiates a new ShearOptions object setting the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<DebuggerStepThroughAttribute()>
Public Function New( _
   ByVal shearAngle As Double, _
   ByVal padColor As Color _
)
'Usage

Dim shearAngle As Double
Dim padColor As Color

Dim instance As New ShearOptions(shearAngle, padColor)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public ShearOptions(
   double shearAngle,
   Color padColor
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public: ShearOptions(
   double shearAngle,
   Color padColor
)
[DebuggerNonUserCodeAttribute()]
[DebuggerStepThroughAttribute()]
public:
ShearOptions(
   double shearAngle,
   Color padColor
)

Parameters

shearAngle
The amount of shear to apply to the image.
padColor
The color used for new pixels that are added to the image.
See Also

Reference

ShearOptions Class
ShearOptions Members
Overload List


PadColor Property (ShearOptions)

Accusoft.ScanFixXpress8.Net
PadColor Property (ShearOptions)

Accusoft.ScanFixXpressSdk Namespace > ShearOptions Class : PadColor Property
The color to use to pad the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PadColor As Color
'Usage

Dim instance As ShearOptions
Dim value As Color

instance.PadColor = value

value = instance.PadColor
public Color PadColor {get; set;}
public: __property Color get_PadColor();
public: __property void set_PadColor(
   Color value
);
public:
property Color PadColor {
   Color get();
   void set (    Color value);
}
Remarks

The default value is White.

See Also

Reference

ShearOptions Class
ShearOptions Members


ShearAngle Property

Accusoft.ScanFixXpress8.Net
ShearAngle Property

Accusoft.ScanFixXpressSdk Namespace > ShearOptions Class : ShearAngle Property
Gets and sets the amount of shear to apply to the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ShearAngle As Double
'Usage

Dim instance As ShearOptions
Dim value As Double

instance.ShearAngle = value

value = instance.ShearAngle
public double ShearAngle {get; set;}
public: __property double get_ShearAngle();
public: __property void set_ShearAngle(
   double value
);
public:
property double ShearAngle {
   double get();
   void set (    double value);
}
Remarks

The default value is 0.0.

Valid values are -360.0 to 360.0.

See Also

Reference

ShearOptions Class
ShearOptions Members


ShearResults Class

Accusoft.ScanFixXpress8.Net
ShearResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : ShearResults Class
Defines a place holder class for the Shear enhancement result.
Object Model
ShearResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ShearResults
   Inherits EnhancementResult
'Usage

Dim instance As ShearResults
public class ShearResults : EnhancementResult
public __gc class ShearResults : public EnhancementResult
public ref class ShearResults : public EnhancementResult
Remarks
This class contains no data. Its presence in the results list is used to determine that the operation has run successfully.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.ShearResults

See Also

Reference

ShearResults Members
Accusoft.ScanFixXpressSdk Namespace


ShearResults Class Members

Accusoft.ScanFixXpress8.Net
ShearResults Class Members

Accusoft.ScanFixXpressSdk Namespace : ShearResults Class

The following tables list the members exposed by ShearResults.

See Also

Reference

ShearResults Class
Accusoft.ScanFixXpressSdk Namespace


SmoothObjectsOptions Class

Accusoft.ScanFixXpress8.Net
SmoothObjectsOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : SmoothObjectsOptions Class
Contains parameters that control the ScanFix.SmoothObjects enhancement operation.
Object Model
SmoothObjectsOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SmoothObjectsOptions
   Inherits EnhancementOption
'Usage

Dim instance As SmoothObjectsOptions
public class SmoothObjectsOptions : EnhancementOption
public __gc class SmoothObjectsOptions : public EnhancementOption
public ref class SmoothObjectsOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.SmoothObjectsOptions

See Also

Reference

SmoothObjectsOptions Members
Accusoft.ScanFixXpressSdk Namespace


SmoothObjectsOptions Class Members

Accusoft.ScanFixXpress8.Net
SmoothObjectsOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : SmoothObjectsOptions Class

The following tables list the members exposed by SmoothObjectsOptions.

Public Constructors
 | Name | Description
Public Constructor | SmoothObjectsOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Amount | Gets and sets the size limit of pits and bumps to smooth in the given image.
Top
See Also

Reference

SmoothObjectsOptions Class
Accusoft.ScanFixXpressSdk Namespace


SmoothObjectsOptions Class Properties

Accusoft.ScanFixXpress8.Net
SmoothObjectsOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : SmoothObjectsOptions Class

For a list of all members of this type, see SmoothObjectsOptions members.

Public Properties
 | Name | Description
Public Property | Amount | Gets and sets the size limit of pits and bumps to smooth in the given image.
Top
See Also

Reference

SmoothObjectsOptions Class
Accusoft.ScanFixXpressSdk Namespace


SmoothObjectsOptions Constructor

Accusoft.ScanFixXpress8.Net
SmoothObjectsOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > SmoothObjectsOptions Class : SmoothObjectsOptions Constructor
Overload List
Overload | Description
SmoothObjectsOptions Constructor() | Instantiates a new SmoothObjectsOptions object setting the default values.
SmoothObjectsOptions Constructor(Int32) | Instantiates a new SmoothObjectsOptions object setting the specified value.
See Also

Reference

SmoothObjectsOptions Class
SmoothObjectsOptions Members


SmoothObjectsOptions Constructor()

Accusoft.ScanFixXpress8.Net
SmoothObjectsOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > SmoothObjectsOptions Class > SmoothObjectsOptions Constructor : SmoothObjectsOptions Constructor()
Instantiates a new SmoothObjectsOptions object setting the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New SmoothObjectsOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public SmoothObjectsOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: SmoothObjectsOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
SmoothObjectsOptions();
See Also

Reference

SmoothObjectsOptions Class
SmoothObjectsOptions Members
Overload List


SmoothObjectsOptions Constructor(Int32)

Accusoft.ScanFixXpress8.Net
SmoothObjectsOptions Constructor(Int32)

Accusoft.ScanFixXpressSdk Namespace > SmoothObjectsOptions Class > SmoothObjectsOptions Constructor : SmoothObjectsOptions Constructor(Int32)
The size limit of pits and bumps to smooth in the given image.
Instantiates a new SmoothObjectsOptions object setting the specified value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal amount As Integer _
)
'Usage

Dim amount As Integer

Dim instance As New SmoothObjectsOptions(amount)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public SmoothObjectsOptions(
   int amount
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: SmoothObjectsOptions(
   int amount
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
SmoothObjectsOptions(
   int amount
)

Parameters

amount
The size limit of pits and bumps to smooth in the given image.
See Also

Reference

SmoothObjectsOptions Class
SmoothObjectsOptions Members
Overload List


Amount Property (SmoothObjectsOptions)

Accusoft.ScanFixXpress8.Net
Amount Property (SmoothObjectsOptions)

Accusoft.ScanFixXpressSdk Namespace > SmoothObjectsOptions Class : Amount Property
Gets and sets the size limit of pits and bumps to smooth in the given image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Amount As Integer
'Usage

Dim instance As SmoothObjectsOptions
Dim value As Integer

instance.Amount = value

value = instance.Amount
public int Amount {get; set;}
public: __property int get_Amount();
public: __property void set_Amount(
   int value
);
public:
property int Amount {
   int get();
   void set (    int value);
}
Remarks

The default value is 3.

Valid values are 1 to 1000.

See Also

Reference

SmoothObjectsOptions Class
SmoothObjectsOptions Members


SmoothObjectsResults Class

Accusoft.ScanFixXpress8.Net
SmoothObjectsResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : SmoothObjectsResults Class
Defines a place holder class for the SmoothObjects enhancement result.
Object Model
SmoothObjectsResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SmoothObjectsResults
   Inherits EnhancementResult
'Usage

Dim instance As SmoothObjectsResults
public class SmoothObjectsResults : EnhancementResult
public __gc class SmoothObjectsResults : public EnhancementResult
public ref class SmoothObjectsResults : public EnhancementResult
Remarks
This class contains no data. Its presence in the results list is used to determine that the operation has run successfully.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.SmoothObjectsResults

See Also

Reference

SmoothObjectsResults Members
Accusoft.ScanFixXpressSdk Namespace


SmoothObjectsResults Class Members

Accusoft.ScanFixXpress8.Net
SmoothObjectsResults Class Members

Accusoft.ScanFixXpressSdk Namespace : SmoothObjectsResults Class

The following tables list the members exposed by SmoothObjectsResults.

See Also

Reference

SmoothObjectsResults Class
Accusoft.ScanFixXpressSdk Namespace


SmoothZoomOptions Class

Accusoft.ScanFixXpress8.Net
SmoothZoomOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : SmoothZoomOptions Class
Defines a place holder class for options that control the ScanFix.SmoothZoom image enhancement. This class does not contain any parameters that can be set.
Object Model
SmoothZoomOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SmoothZoomOptions
   Inherits EnhancementOption
'Usage

Dim instance As SmoothZoomOptions
public class SmoothZoomOptions : EnhancementOption
public __gc class SmoothZoomOptions : public EnhancementOption
public ref class SmoothZoomOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.SmoothZoomOptions

See Also

Reference

SmoothZoomOptions Members
Accusoft.ScanFixXpressSdk Namespace


SmoothZoomOptions Class Members

Accusoft.ScanFixXpress8.Net
SmoothZoomOptions Class Members

Accusoft.ScanFixXpressSdk Namespace : SmoothZoomOptions Class

The following tables list the members exposed by SmoothZoomOptions.

Public Constructors
 | Name | Description
Public Constructor | SmoothZoomOptions Constructor | Instantiates a new SmoothZoomOptions object.
Top
See Also

Reference

SmoothZoomOptions Class
Accusoft.ScanFixXpressSdk Namespace


SmoothZoomOptions Constructor

Accusoft.ScanFixXpress8.Net
SmoothZoomOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > SmoothZoomOptions Class : SmoothZoomOptions Constructor
Instantiates a new SmoothZoomOptions object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New SmoothZoomOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public SmoothZoomOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: SmoothZoomOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
SmoothZoomOptions();
See Also

Reference

SmoothZoomOptions Class
SmoothZoomOptions Members


SmoothZoomResults Class

Accusoft.ScanFixXpress8.Net
SmoothZoomResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : SmoothZoomResults Class
Defines a place holder class for the SmoothZoom enhancement result.
Object Model
SmoothZoomResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SmoothZoomResults
   Inherits EnhancementResult
'Usage

Dim instance As SmoothZoomResults
public class SmoothZoomResults : EnhancementResult
public __gc class SmoothZoomResults : public EnhancementResult
public ref class SmoothZoomResults : public EnhancementResult
Remarks
This class contains no data. Its presence in the results list is used to determine that the operation has run successfully.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.SmoothZoomResults

See Also

Reference

SmoothZoomResults Members
Accusoft.ScanFixXpressSdk Namespace


SmoothZoomResults Class Members

Accusoft.ScanFixXpress8.Net
SmoothZoomResults Class Members

Accusoft.ScanFixXpressSdk Namespace : SmoothZoomResults Class

The following tables list the members exposed by SmoothZoomResults.

See Also

Reference

SmoothZoomResults Class
Accusoft.ScanFixXpressSdk Namespace


VirtualBulbOptions Class

Accusoft.ScanFixXpress8.Net
VirtualBulbOptions Class
Members

Accusoft.ScanFixXpressSdk Namespace : VirtualBulbOptions Class
Contains parameters that control the ScanFix.VirtualBulb process.
Object Model
VirtualBulbOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class VirtualBulbOptions
   Inherits EnhancementOption
'Usage

Dim instance As VirtualBulbOptions
public class VirtualBulbOptions : EnhancementOption
public __gc class VirtualBulbOptions : public EnhancementOption
public ref class VirtualBulbOptions : public EnhancementOption
Remarks
An instance of this class can be placed in an Enhancements object to be processed in a sequence of enhancements.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementOption
Accusoft.ScanFixXpressSdk.VirtualBulbOptions

See Also

Reference

VirtualBulbOptions Members
Accusoft.ScanFixXpressSdk Namespace


VirtualBulbOptions Class Members

Accusoft.ScanFixXpress8.Net
VirtualBulbOptions Class Members
Properties

Accusoft.ScanFixXpressSdk Namespace : VirtualBulbOptions Class

The following tables list the members exposed by VirtualBulbOptions.

Public Constructors
 | Name | Description
Public Constructor | VirtualBulbOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Extract | Gets and sets flag to extract specified list of hues by converting them to black and drop all other hues (including black) to white.
Public Property | HueRadiusList | Gets HueRadius list object.
Top
See Also

Reference

VirtualBulbOptions Class
Accusoft.ScanFixXpressSdk Namespace


VirtualBulbOptions Class Properties

Accusoft.ScanFixXpress8.Net
VirtualBulbOptions Class Properties

Accusoft.ScanFixXpressSdk Namespace : VirtualBulbOptions Class

For a list of all members of this type, see VirtualBulbOptions members.

Public Properties
 | Name | Description
Public Property | Extract | Gets and sets flag to extract specified list of hues by converting them to black and drop all other hues (including black) to white.
Public Property | HueRadiusList | Gets HueRadius list object.
Top
See Also

Reference

VirtualBulbOptions Class
Accusoft.ScanFixXpressSdk Namespace


VirtualBulbOptions Constructor

Accusoft.ScanFixXpress8.Net
VirtualBulbOptions Constructor

Accusoft.ScanFixXpressSdk Namespace > VirtualBulbOptions Class : VirtualBulbOptions Constructor
Overload List
Overload | Description
VirtualBulbOptions Constructor() | Instantiates a new VirtualBulbOptions object with the default values.
VirtualBulbOptions Constructor(Boolean,IEnumerable<HueRadius>) | Instantiates a new VirtualBulbOptions object setting the specified values.
See Also

Reference

VirtualBulbOptions Class
VirtualBulbOptions Members


VirtualBulbOptions Constructor()

Accusoft.ScanFixXpress8.Net
VirtualBulbOptions Constructor()

Accusoft.ScanFixXpressSdk Namespace > VirtualBulbOptions Class > VirtualBulbOptions Constructor : VirtualBulbOptions Constructor()
Instantiates a new VirtualBulbOptions object with the default values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New()
'Usage

Dim instance As New VirtualBulbOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public VirtualBulbOptions()
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: VirtualBulbOptions();
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
VirtualBulbOptions();
See Also

Reference

VirtualBulbOptions Class
VirtualBulbOptions Members
Overload List


VirtualBulbOptions Constructor(Boolean,IEnumerable<HueRadius>)

Accusoft.ScanFixXpress8.Net
VirtualBulbOptions Constructor(Boolean,IEnumerable<HueRadius>)

Accusoft.ScanFixXpressSdk Namespace > VirtualBulbOptions Class > VirtualBulbOptions Constructor : VirtualBulbOptions Constructor(Boolean,IEnumerable<HueRadius>)
Set to true to extract specified hues and drop all others.
HueRadius list
Instantiates a new VirtualBulbOptions object setting the specified values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DebuggerStepThroughAttribute()>
<DebuggerNonUserCodeAttribute()>
Public Function New( _
   ByVal extract As Boolean, _
   ByVal hueRadiusList As IEnumerable(Of HueRadius) _
)
'Usage

Dim extract As Boolean
Dim hueRadiusList As IEnumerable(Of HueRadius)

Dim instance As New VirtualBulbOptions(extract, hueRadiusList)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public VirtualBulbOptions(
   bool extract,
   IEnumerable<HueRadius> hueRadiusList
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public: VirtualBulbOptions(
   bool extract,
   IEnumerable<HueRadius*>* hueRadiusList
)
[DebuggerStepThroughAttribute()]
[DebuggerNonUserCodeAttribute()]
public:
VirtualBulbOptions(
   bool extract,
   IEnumerable<HueRadius^>^ hueRadiusList
)

Parameters

extract
Set to true to extract specified hues and drop all others.
hueRadiusList
HueRadius list
See Also

Reference

VirtualBulbOptions Class
VirtualBulbOptions Members
Overload List


Extract Property (VirtualBulbOptions)

Accusoft.ScanFixXpress8.Net
Extract Property (VirtualBulbOptions)

Accusoft.ScanFixXpressSdk Namespace > VirtualBulbOptions Class : Extract Property
Gets and sets flag to extract specified list of hues by converting them to black and drop all other hues (including black) to white.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Extract As Boolean
'Usage

Dim instance As VirtualBulbOptions
Dim value As Boolean

instance.Extract = value

value = instance.Extract
public bool Extract {get; set;}
public: __property bool get_Extract();
public: __property void set_Extract(
   bool value
);
public:
property bool Extract {
   bool get();
   void set (    bool value);
}
Remarks

The default value is false.

Normal operation is to drop specified hues to white and convert all other hues to black. Enabling Extract will keep only the specified hues.

See Also

Reference

VirtualBulbOptions Class
VirtualBulbOptions Members


HueRadiusList Property

Accusoft.ScanFixXpress8.Net
HueRadiusList Property

Accusoft.ScanFixXpressSdk Namespace > VirtualBulbOptions Class : HueRadiusList Property
Gets HueRadius list object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property HueRadiusList As Collection(Of HueRadius)
'Usage

Dim instance As VirtualBulbOptions
Dim value As Collection(Of HueRadius)

value = instance.HueRadiusList
public Collection<HueRadius> HueRadiusList {get;}
public: __property Collection<HueRadius*>* get_HueRadiusList();
public:
property Collection<HueRadius^>^ HueRadiusList {
   Collection<HueRadius^>^ get();
}
Remarks
VirtualBulb can drop multiple color regions. This list contains HueRadius objects for the multiple drop regions.
See Also

Reference

VirtualBulbOptions Class
VirtualBulbOptions Members


VirtualBulbResults Class

Accusoft.ScanFixXpress8.Net
VirtualBulbResults Class
Members

Accusoft.ScanFixXpressSdk Namespace : VirtualBulbResults Class
Defines a place holder class for the VirtualBulb enhancement result.
Object Model
VirtualBulbResults Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class VirtualBulbResults
   Inherits EnhancementResult
'Usage

Dim instance As VirtualBulbResults
public class VirtualBulbResults : EnhancementResult
public __gc class VirtualBulbResults : public EnhancementResult
public ref class VirtualBulbResults : public EnhancementResult
Remarks
This class contains no data. Its presence in the results list is used to determine that the operation has run successfully.
Inheritance Hierarchy

System.Object
Accusoft.ScanFixXpressSdk.EnhancementResult
Accusoft.ScanFixXpressSdk.VirtualBulbResults

See Also

Reference

VirtualBulbResults Members
Accusoft.ScanFixXpressSdk Namespace


VirtualBulbResults Class Members

Accusoft.ScanFixXpress8.Net
VirtualBulbResults Class Members

Accusoft.ScanFixXpressSdk Namespace : VirtualBulbResults Class

The following tables list the members exposed by VirtualBulbResults.

See Also

Reference

VirtualBulbResults Class
Accusoft.ScanFixXpressSdk Namespace


AutomaticMode Enumeration

Accusoft.ScanFixXpress8.Net
AutomaticMode Enumeration

Accusoft.ScanFixXpressSdk Namespace : AutomaticMode Enumeration
Modes for automatic ImageDetergent operation
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum AutomaticMode
   Inherits System.Enum
'Usage

Dim instance As AutomaticMode
public enum AutomaticMode : System.Enum
__value public enum AutomaticMode : public System.Enum
public enum class AutomaticMode : public System.Enum
Members
Member | Value | Description
Auto3Color | 0 | Automatically cleans image for these colors: Black, White and Dominant hue.
Auto8Color | 1 | Automatically cleans image for these colors: Black, White, Red, Green, Blue, Cyan, Magenta and Yellow.
ColorCount | 2 | Automatically cleans image for the specified (ColorCount field) number of dominant colors.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ScanFixXpressSdk.AutomaticMode

See Also

Reference

Accusoft.ScanFixXpressSdk Namespace


BinarizeBlur Enumeration

Accusoft.ScanFixXpress8.Net
BinarizeBlur Enumeration

Accusoft.ScanFixXpressSdk Namespace : BinarizeBlur Enumeration
Binarize Blur is used to set the pre-blur option of the Binarize feature.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum BinarizeBlur
   Inherits System.Enum
'Usage

Dim instance As BinarizeBlur
public enum BinarizeBlur : System.Enum
__value public enum BinarizeBlur : public System.Enum
public enum class BinarizeBlur : public System.Enum
Members
Member | Value | Description
GaussianBlur | 1 | This setting will apply a Gaussian blur to the image before the local contrast enhancement/binarization process.
NoBlur | 0 | This setting will not blur the image before the local contrast enhancement/binarization process.
SmartBlur | 2 | This setting removes dither-like artifacts introduced into many images already binarized to 1-bit by other software or hardware operations.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ScanFixXpressSdk.BinarizeBlur

See Also

Reference

Accusoft.ScanFixXpressSdk Namespace


BrightnessContrastAdjustment Enumeration

Accusoft.ScanFixXpress8.Net
BrightnessContrastAdjustment Enumeration

Accusoft.ScanFixXpressSdk Namespace : BrightnessContrastAdjustment Enumeration
AdjustBrightnessContrast Adjustment specification values
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum BrightnessContrastAdjustment
   Inherits System.Enum
'Usage

Dim instance As BrightnessContrastAdjustment
public enum BrightnessContrastAdjustment : System.Enum
__value public enum BrightnessContrastAdjustment : public System.Enum
public enum class BrightnessContrastAdjustment : public System.Enum
Members
Member | Value | Description
Automatic | 1 | Automatic contrast adjustment.
ForceAdaptive | 2 | Force to use adaptive contrast adjustment.
ForceGlobal | 3 | Force to use global contrast adjustment.
NoFix | 0 | Do not change image for contrast, analyze and generate results only.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ScanFixXpressSdk.BrightnessContrastAdjustment

See Also

Reference

Accusoft.ScanFixXpressSdk Namespace


BrightnessContrastSuggestion Enumeration

Accusoft.ScanFixXpress8.Net
BrightnessContrastSuggestion Enumeration

Accusoft.ScanFixXpressSdk Namespace : BrightnessContrastSuggestion Enumeration
BrightnessContrast adjustment suggestion values
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum BrightnessContrastSuggestion
   Inherits System.Enum
'Usage

Dim instance As BrightnessContrastSuggestion
public enum BrightnessContrastSuggestion : System.Enum
__value public enum BrightnessContrastSuggestion : public System.Enum
public enum class BrightnessContrastSuggestion : public System.Enum
Members
Member | Value | Description
Adaptive | 2 | Adaptive contrast adjustment should be used.
Bad | 1 | Image has insufficient difference between contrast and noise to adjust.
Global | 3 | Global contrast adjustment should be used.
Ok | 0 | No image change required to achive desired contrast targets.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ScanFixXpressSdk.BrightnessContrastSuggestion

See Also

Reference

Accusoft.ScanFixXpressSdk Namespace


ColorFindings Enumeration

Accusoft.ScanFixXpress8.Net
ColorFindings Enumeration

Accusoft.ScanFixXpressSdk Namespace : ColorFindings Enumeration
Values for collection of findings returned by DetectColor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ColorFindings
   Inherits System.Enum
'Usage

Dim instance As ColorFindings
public enum ColorFindings : System.Enum
__value public enum ColorFindings : public System.Enum
public enum class ColorFindings : public System.Enum
Members
Member | Value | Description
FewItems | 3 | Indicates that large, saturated objects were found, but not a number sufficient to trigger. an "is color" result.
FoundItems | 6 | Indicates that the image had a sufficient number of large, saturated color objects.
NoItems | 2 | No significant saturated items found in the image.
PaperColorIgnored | 7 | Image is more that 50% of MiminumSaturation and domininant hue pixels were ignored.
Saturated | 5 | Indicates the overall saturation of the image was above MinimumSaturation.
SmallItems | 4 | Indicates that objects of more than 50% of MinimumSize, but less than MinimumSize, were found.
Unsaturated | 1 | Set if overall saturation of the image is less than MinimumSaturation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ScanFixXpressSdk.ColorFindings

See Also

Reference

Accusoft.ScanFixXpressSdk Namespace


EnhancementDirections Enumeration

Accusoft.ScanFixXpress8.Net
EnhancementDirections Enumeration

Accusoft.ScanFixXpressSdk Namespace : EnhancementDirections Enumeration
Erode and Dilate direction flag values
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum EnhancementDirections
   Inherits System.Enum
'Usage

Dim instance As EnhancementDirections
[FlagsAttribute()]
public enum EnhancementDirections : System.Enum
[FlagsAttribute()]
__value public enum EnhancementDirections : public System.Enum
[FlagsAttribute()]
public enum class EnhancementDirections : public System.Enum
Members
Member | Value | Description
All | 15 | Dilate or Erode All Directions.
Down | 8 | Dilate or Erode Down.
Left | 1 | Dilate or Erode Left.
Right | 2 | Dilate or Erode Right.
Up | 4 | Dilate or Erode Up.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ScanFixXpressSdk.EnhancementDirections

See Also

Reference

Accusoft.ScanFixXpressSdk Namespace


ErrorLevel Enumeration

Accusoft.ScanFixXpress8.Net
ErrorLevel Enumeration

Accusoft.ScanFixXpressSdk Namespace : ErrorLevel Enumeration
Error level defines the amount of error information in the debug log.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ErrorLevel
   Inherits System.Enum
'Usage

Dim instance As ErrorLevel
public enum ErrorLevel : System.Enum
__value public enum ErrorLevel : public System.Enum
public enum class ErrorLevel : public System.Enum
Members
Member | Value | Description
Detailed | 2 | This setting will produce detailed error information that is useful when debugging a problem during the development process.
Development | 1 | This setting will produce additional error information that is useful during the development process.
Production | 0 | The default error level. This setting will produce the minimum amount of error information.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ScanFixXpressSdk.ErrorLevel

See Also

Reference

Accusoft.ScanFixXpressSdk Namespace


EvaluationChoice Enumeration

Accusoft.ScanFixXpress8.Net
EvaluationChoice Enumeration

Accusoft.ScanFixXpressSdk Namespace : EvaluationChoice Enumeration
Choices for control behavior when licensed for trial use
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum EvaluationChoice
   Inherits System.Enum
'Usage

Dim instance As EvaluationChoice
public enum EvaluationChoice : System.Enum
__value public enum EvaluationChoice : public System.Enum
public enum class EvaluationChoice : public System.Enum
Members
Member | Value | Description
Timeout | 1 | After 5 minutes the control will stop working successfully.
TrialDialog | 0 | A dialog box will be displayed every 5 minutes. This choice will automatically be changed to Timeout if the control detects operation in an environment where a dialog box cannot be displayed.
Watermark | 2 | The control will stamp every image produced with a watermark.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ScanFixXpressSdk.EvaluationChoice

See Also

Reference

Accusoft.ScanFixXpressSdk Namespace


FilterDirection Enumeration

Accusoft.ScanFixXpress8.Net
FilterDirection Enumeration

Accusoft.ScanFixXpressSdk Namespace : FilterDirection Enumeration
Direction options for filter
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum FilterDirection
   Inherits System.Enum
'Usage

Dim instance As FilterDirection
public enum FilterDirection : System.Enum
__value public enum FilterDirection : public System.Enum
public enum class FilterDirection : public System.Enum
Members
Member | Value | Description
Horizontal | 0 | Detects horizontal edges.
Vertical | 1 | Detects vertical edges.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ScanFixXpressSdk.FilterDirection

See Also

Reference

Accusoft.ScanFixXpressSdk Namespace


GraphicLineOrientation Enumeration

Accusoft.ScanFixXpress8.Net
GraphicLineOrientation Enumeration

Accusoft.ScanFixXpressSdk Namespace : GraphicLineOrientation Enumeration
Values for the orientation of lines that are detected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum GraphicLineOrientation
   Inherits System.Enum
'Usage

Dim instance As GraphicLineOrientation
public enum GraphicLineOrientation : System.Enum
__value public enum GraphicLineOrientation : public System.Enum
public enum class GraphicLineOrientation : public System.Enum
Members
Member | Value | Description
Any | 0 | Detect a line of any orientation.
Horizontal | 2 | Detects lines that have a horizontal orientation.
Vertical | 1 | Detects lines that have a vertical orientation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ScanFixXpressSdk.GraphicLineOrientation

See Also

Reference

Accusoft.ScanFixXpressSdk Namespace