CollapsedRegionAdornmentAutomationPeer Methods

Actipro Universal Windows Controls Documentation
CollapsedRegionAdornmentAutomationPeer Methods

The CollapsedRegionAdornmentAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the ID of the object that is associated with the automation peer. (Overrides AutomationPeerGetAutomationIdCore.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Returns the child UI Automation peers. (Overrides AutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets text that conveys the visual status of the object that is associated with this automation peer. (Overrides AutomationPeerGetItemStatusCore.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the value that the automation peer reports as the UI Automation name for the associated control. (Overrides AutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

CollapsedRegionAdornmentAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


CollapsedRegionAdornmentAutomationPeer.GetAutomationControlTypeCore Method

CollapsedRegionAdornmentAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

CollapsedRegionAdornmentAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


CollapsedRegionAdornmentAutomationPeer.GetAutomationIdCore Method

CollapsedRegionAdornmentAutomationPeerGetAutomationIdCore Method
Gets the ID of the object that is associated with the automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetAutomationIdCore()
Protected Overrides Function GetAutomationIdCore As String

Return Value

Type: String
The ID of the object that is associated with the automation peer.
See Also

Reference

CollapsedRegionAdornmentAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


CollapsedRegionAdornmentAutomationPeer.GetChildrenCore Method

CollapsedRegionAdornmentAutomationPeerGetChildrenCore Method
Returns the child UI Automation peers.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<AutomationPeer> GetChildrenCore()
Protected Overrides Function GetChildrenCore As IList(Of AutomationPeer)

Return Value

Type: IList AutomationPeer
The child UI Automation peers.
See Also

Reference

CollapsedRegionAdornmentAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


CollapsedRegionAdornmentAutomationPeer.GetClassNameCore Method

CollapsedRegionAdornmentAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

CollapsedRegionAdornmentAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


CollapsedRegionAdornmentAutomationPeer.GetItemStatusCore Method

CollapsedRegionAdornmentAutomationPeerGetItemStatusCore Method
Gets text that conveys the visual status of the object that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetItemStatusCore()
Protected Overrides Function GetItemStatusCore As String

Return Value

Type: String
Text that conveys the visual status of the object that is associated with this automation peer.
See Also

Reference

CollapsedRegionAdornmentAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


CollapsedRegionAdornmentAutomationPeer.GetLocalizedControlTypeCore Method

CollapsedRegionAdornmentAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

CollapsedRegionAdornmentAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


CollapsedRegionAdornmentAutomationPeer.GetNameCore Method

CollapsedRegionAdornmentAutomationPeerGetNameCore Method
Gets the value that the automation peer reports as the UI Automation name for the associated control.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetNameCore()
Protected Overrides Function GetNameCore As String

Return Value

Type: String
The value that the automation peer reports as the UI Automation name for the associated control.
See Also

Reference

CollapsedRegionAdornmentAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorIndicatorMarginAutomationPeer Class

EditorIndicatorMarginAutomationPeer Class
Exposes EditorIndicatorMargin types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.PeersEditorIndicatorMarginAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EditorIndicatorMarginAutomationPeer : FrameworkElementAutomationPeer
Public Class EditorIndicatorMarginAutomationPeer
    Inherits FrameworkElementAutomationPeer

The EditorIndicatorMarginAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | EditorIndicatorMarginAutomationPeer | Initializes a new instance of the EditorIndicatorMarginAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorIndicatorMarginAutomationPeer Constructor

EditorIndicatorMarginAutomationPeer Constructor
Initializes a new instance of the EditorIndicatorMarginAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EditorIndicatorMarginAutomationPeer(
    EditorIndicatorMargin owner
)
Public Sub New (
    owner As EditorIndicatorMargin
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.PrimitivesEditorIndicatorMargin
The owner element.
See Also

Reference

EditorIndicatorMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorIndicatorMarginAutomationPeer Properties

EditorIndicatorMarginAutomationPeer Properties

The EditorIndicatorMarginAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

EditorIndicatorMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorIndicatorMarginAutomationPeer Methods

EditorIndicatorMarginAutomationPeer Methods

The EditorIndicatorMarginAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

EditorIndicatorMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorIndicatorMarginAutomationPeer.GetAutomationControlTypeCore Method

EditorIndicatorMarginAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

EditorIndicatorMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorIndicatorMarginAutomationPeer.GetClassNameCore Method

EditorIndicatorMarginAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

EditorIndicatorMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorIndicatorMarginAutomationPeer.GetLocalizedControlTypeCore Method

EditorIndicatorMarginAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

EditorIndicatorMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorLineNumberMarginAutomationPeer Class

EditorLineNumberMarginAutomationPeer Class
Exposes EditorLineNumberMargin types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.PeersEditorLineNumberMarginAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EditorLineNumberMarginAutomationPeer : FrameworkElementAutomationPeer
Public Class EditorLineNumberMarginAutomationPeer
    Inherits FrameworkElementAutomationPeer

The EditorLineNumberMarginAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | EditorLineNumberMarginAutomationPeer | Initializes a new instance of the EditorLineNumberMarginAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorLineNumberMarginAutomationPeer Constructor

EditorLineNumberMarginAutomationPeer Constructor
Initializes a new instance of the EditorLineNumberMarginAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EditorLineNumberMarginAutomationPeer(
    EditorLineNumberMargin owner
)
Public Sub New (
    owner As EditorLineNumberMargin
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.PrimitivesEditorLineNumberMargin
The owner element.
See Also

Reference

EditorLineNumberMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorLineNumberMarginAutomationPeer Properties

EditorLineNumberMarginAutomationPeer Properties

The EditorLineNumberMarginAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

EditorLineNumberMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorLineNumberMarginAutomationPeer Methods

EditorLineNumberMarginAutomationPeer Methods

The EditorLineNumberMarginAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

EditorLineNumberMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorLineNumberMarginAutomationPeer.GetAutomationControlTypeCore Method

EditorLineNumberMarginAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

EditorLineNumberMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorLineNumberMarginAutomationPeer.GetClassNameCore Method

EditorLineNumberMarginAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

EditorLineNumberMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorLineNumberMarginAutomationPeer.GetLocalizedControlTypeCore Method

EditorLineNumberMarginAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

EditorLineNumberMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorOutliningMarginAutomationPeer Class

EditorOutliningMarginAutomationPeer Class
Exposes EditorOutliningMargin types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.PeersEditorOutliningMarginAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EditorOutliningMarginAutomationPeer : FrameworkElementAutomationPeer
Public Class EditorOutliningMarginAutomationPeer
    Inherits FrameworkElementAutomationPeer

The EditorOutliningMarginAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | EditorOutliningMarginAutomationPeer | Initializes a new instance of the EditorOutliningMarginAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorOutliningMarginAutomationPeer Constructor

EditorOutliningMarginAutomationPeer Constructor
Initializes a new instance of the EditorOutliningMarginAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EditorOutliningMarginAutomationPeer(
    EditorOutliningMargin owner
)
Public Sub New (
    owner As EditorOutliningMargin
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.PrimitivesEditorOutliningMargin
The owner element.
See Also

Reference

EditorOutliningMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorOutliningMarginAutomationPeer Properties

EditorOutliningMarginAutomationPeer Properties

The EditorOutliningMarginAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

EditorOutliningMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorOutliningMarginAutomationPeer Methods

EditorOutliningMarginAutomationPeer Methods

The EditorOutliningMarginAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

EditorOutliningMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorOutliningMarginAutomationPeer.GetAutomationControlTypeCore Method

EditorOutliningMarginAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

EditorOutliningMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorOutliningMarginAutomationPeer.GetClassNameCore Method

EditorOutliningMarginAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

EditorOutliningMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorOutliningMarginAutomationPeer.GetLocalizedControlTypeCore Method

EditorOutliningMarginAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

EditorOutliningMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorSelectionMarginAutomationPeer Class

EditorSelectionMarginAutomationPeer Class
Exposes EditorSelectionMargin types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.PeersEditorSelectionMarginAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EditorSelectionMarginAutomationPeer : FrameworkElementAutomationPeer
Public Class EditorSelectionMarginAutomationPeer
    Inherits FrameworkElementAutomationPeer

The EditorSelectionMarginAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | EditorSelectionMarginAutomationPeer | Initializes a new instance of the EditorSelectionMarginAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorSelectionMarginAutomationPeer Constructor

EditorSelectionMarginAutomationPeer Constructor
Initializes a new instance of the EditorSelectionMarginAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EditorSelectionMarginAutomationPeer(
    EditorSelectionMargin owner
)
Public Sub New (
    owner As EditorSelectionMargin
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.PrimitivesEditorSelectionMargin
The owner element.
See Also

Reference

EditorSelectionMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorSelectionMarginAutomationPeer Properties

EditorSelectionMarginAutomationPeer Properties

The EditorSelectionMarginAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

EditorSelectionMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorSelectionMarginAutomationPeer Methods

EditorSelectionMarginAutomationPeer Methods

The EditorSelectionMarginAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

EditorSelectionMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorSelectionMarginAutomationPeer.GetAutomationControlTypeCore Method

EditorSelectionMarginAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

EditorSelectionMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorSelectionMarginAutomationPeer.GetClassNameCore Method

EditorSelectionMarginAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

EditorSelectionMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorSelectionMarginAutomationPeer.GetLocalizedControlTypeCore Method

EditorSelectionMarginAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

EditorSelectionMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer Class

EditorViewAutomationPeer Class
Exposes EditorView types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.PeersEditorViewAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EditorViewAutomationPeer : FrameworkElementAutomationPeer,
    ITextProvider2, ITextProvider, IValueProvider
Public Class EditorViewAutomationPeer
    Inherits FrameworkElementAutomationPeer
    Implements ITextProvider2, ITextProvider, IValueProvider

The EditorViewAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | EditorViewAutomationPeer | Initializes a new instance of the EditorViewAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DocumentRange | Gets a text range that encloses the main text of a document.
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | IsReadOnly | Gets a value that indicates whether the value of a control is read-only.
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Public property | SupportedTextSelection | Gets a value that specifies whether a text provider supports selection, and if it does, the type of selection that is supported.
Public property | Value | Gets the value of the control.
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Returns the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the ID of the object that is associated with the automation peer. (Overrides AutomationPeerGetAutomationIdCore.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetCaretRange | Provides a zero-length text range at the location of the caret that belongs to the text-based control.
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClassName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Gets the control pattern that is associated with the specified PatternInterface. (Overrides AutomationPeerGetPatternCore(PatternInterface).)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSelection | Retrieves a collection of disjoint text ranges that are associated with the current text selection or selections.
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | GetVisibleRanges | Retrieves an array of disjoint text ranges from a text container. Each text range begins with the first partially visible line and ends with the last partially visible line.
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Returns a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Overrides AutomationPeerIsControlElementCore.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the element can accept keyboard focus. (Overrides AutomationPeerIsKeyboardFocusableCore.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | RangeFromAnnotation | Exposes a text range that contains the text that is the target of the annotation associated with the specified annotation element.
Public method | RangeFromChild | Retrieves a text range that encloses a child element, such as an image, hyperlink, or other embedded object.
Public method | RangeFromPoint | Retrieves a text range from the vicinity of a screen coordinate.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue(String) | Sets the value of a control.
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer Constructor

EditorViewAutomationPeer Constructor
Initializes a new instance of the EditorViewAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EditorViewAutomationPeer(
    FrameworkElement owner
)
Public Sub New (
    owner As FrameworkElement
)

Parameters

owner
Type: Windows.UI.XamlFrameworkElement
The owner element.
See Also

Reference

EditorViewAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer Properties

EditorViewAutomationPeer Properties

The EditorViewAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DocumentRange | Gets a text range that encloses the main text of a document.
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | IsReadOnly | Gets a value that indicates whether the value of a control is read-only.
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Public property | SupportedTextSelection | Gets a value that specifies whether a text provider supports selection, and if it does, the type of selection that is supported.
Public property | Value | Gets the value of the control.
Top
See Also

Reference

EditorViewAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer.DocumentRange Property

EditorViewAutomationPeerDocumentRange Property
Gets a text range that encloses the main text of a document.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextRangeProvider DocumentRange { get; }
Public ReadOnly Property DocumentRange As ITextRangeProvider
    Get

Property Value

Type: ITextRangeProvider
A text range that encloses the main text of a document.

Implements

ITextProviderDocumentRange
See Also

Reference

EditorViewAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer.IsReadOnly Property

EditorViewAutomationPeerIsReadOnly Property
Gets a value that indicates whether the value of a control is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the value is read-only; false if it can be modified.

Implements

IValueProviderIsReadOnly
See Also

Reference

EditorViewAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer.SupportedTextSelection Property

EditorViewAutomationPeerSupportedTextSelection Property
Gets a value that specifies whether a text provider supports selection, and if it does, the type of selection that is supported.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SupportedTextSelection SupportedTextSelection { get; }
Public ReadOnly Property SupportedTextSelection As SupportedTextSelection
    Get

Property Value

Type: SupportedTextSelection
A value of SupportedTextSelection.

Implements

ITextProviderSupportedTextSelection
See Also

Reference

EditorViewAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer.Value Property

EditorViewAutomationPeerValue Property
Gets the value of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Value { get; }
Public ReadOnly Property Value As String
    Get

Property Value

Type: String
The value of the control.

Implements

IValueProviderValue
See Also

Reference

EditorViewAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer Methods

EditorViewAutomationPeer Methods

The EditorViewAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Returns the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the ID of the object that is associated with the automation peer. (Overrides AutomationPeerGetAutomationIdCore.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetCaretRange | Provides a zero-length text range at the location of the caret that belongs to the text-based control.
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClassName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Gets the control pattern that is associated with the specified PatternInterface. (Overrides AutomationPeerGetPatternCore(PatternInterface).)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSelection | Retrieves a collection of disjoint text ranges that are associated with the current text selection or selections.
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | GetVisibleRanges | Retrieves an array of disjoint text ranges from a text container. Each text range begins with the first partially visible line and ends with the last partially visible line.
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Returns a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Overrides AutomationPeerIsControlElementCore.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Gets a value that indicates whether the element can accept keyboard focus. (Overrides AutomationPeerIsKeyboardFocusableCore.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | RangeFromAnnotation | Exposes a text range that contains the text that is the target of the annotation associated with the specified annotation element.
Public method | RangeFromChild | Retrieves a text range that encloses a child element, such as an image, hyperlink, or other embedded object.
Public method | RangeFromPoint | Retrieves a text range from the vicinity of a screen coordinate.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue(String) | Sets the value of a control.
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

EditorViewAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer.GetAutomationControlTypeCore Method

EditorViewAutomationPeerGetAutomationControlTypeCore Method
Returns the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

EditorViewAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer.GetAutomationIdCore Method

EditorViewAutomationPeerGetAutomationIdCore Method
Gets the ID of the object that is associated with the automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetAutomationIdCore()
Protected Overrides Function GetAutomationIdCore As String

Return Value

Type: String
The ID of the object that is associated with the automation peer.
See Also

Reference

EditorViewAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer.GetCaretRange Method

EditorViewAutomationPeerGetCaretRange Method
Provides a zero-length text range at the location of the caret that belongs to the text-based control.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextRangeProvider GetCaretRange(
    out bool isActive
)
Public Function GetCaretRange (
    <OutAttribute> ByRef isActive As Boolean
) As ITextRangeProvider

Parameters

isActive
Type: SystemBoolean
Whether the text-based control that contains the caret has keyboard focus.

Return Value

Type: ITextRangeProvider
A text range that represents the current location of the caret that belongs to the text-based control.

Implements

ITextProvider2GetCaretRange(Boolean)
See Also

Reference

EditorViewAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer.GetLocalizedControlTypeCore Method

EditorViewAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

EditorViewAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer.GetPatternCore Method

EditorViewAutomationPeerGetPatternCore Method
Gets the control pattern that is associated with the specified PatternInterface.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object GetPatternCore(
    PatternInterface patternInterface
)
Protected Overrides Function GetPatternCore (
    patternInterface As PatternInterface
) As Object

Parameters

patternInterface
Type: Windows.UI.Xaml.Automation.PeersPatternInterface
A value from the PatternInterface enumeration.

Return Value

Type: Object
The object that implements the pattern interface; if the peer does not support this interface.
See Also

Reference

EditorViewAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer.GetSelection Method

EditorViewAutomationPeerGetSelection Method
Retrieves a collection of disjoint text ranges that are associated with the current text selection or selections.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextRangeProvider[] GetSelection()
Public Function GetSelection As ITextRangeProvider()

Return Value

Type: ITextRangeProvider
A collection of disjoint text ranges.

Implements

ITextProviderGetSelection
See Also

Reference

EditorViewAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer.GetVisibleRanges Method

EditorViewAutomationPeerGetVisibleRanges Method
Retrieves an array of disjoint text ranges from a text container. Each text range begins with the first partially visible line and ends with the last partially visible line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextRangeProvider[] GetVisibleRanges()
Public Function GetVisibleRanges As ITextRangeProvider()

Return Value

Type: ITextRangeProvider
The collection of visible text ranges within a container or an empty array. This method never returns null.

Implements

ITextProviderGetVisibleRanges
See Also

Reference

EditorViewAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer.IsControlElementCore Method

EditorViewAutomationPeerIsControlElementCore Method
Returns a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsControlElementCore()
Protected Overrides Function IsControlElementCore As Boolean

Return Value

Type: Boolean
true if the element is a control; otherwise, false.
See Also

Reference

EditorViewAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer.IsKeyboardFocusableCore Method

EditorViewAutomationPeerIsKeyboardFocusableCore Method
Gets a value that indicates whether the element can accept keyboard focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsKeyboardFocusableCore()
Protected Overrides Function IsKeyboardFocusableCore As Boolean

Return Value

Type: Boolean
true if the element can accept keyboard focus; otherwise, false.
See Also

Reference

EditorViewAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer.RangeFromAnnotation Method

EditorViewAutomationPeerRangeFromAnnotation Method
Exposes a text range that contains the text that is the target of the annotation associated with the specified annotation element.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextRangeProvider RangeFromAnnotation(
    IRawElementProviderSimple annotationElement
)
Public Function RangeFromAnnotation (
    annotationElement As IRawElementProviderSimple
) As ITextRangeProvider

Parameters

annotationElement
Type: Windows.UI.Xaml.Automation.ProviderIRawElementProviderSimple
The provider for an element that implements the IAnnotationProvider interface.

Return Value

Type: ITextRangeProvider
A text range that contains the annotation target text.

Implements

ITextProvider2RangeFromAnnotation(IRawElementProviderSimple)
See Also

Reference

EditorViewAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer.RangeFromChild Method

EditorViewAutomationPeerRangeFromChild Method
Retrieves a text range that encloses a child element, such as an image, hyperlink, or other embedded object.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextRangeProvider RangeFromChild(
    IRawElementProviderSimple childElement
)
Public Function RangeFromChild (
    childElement As IRawElementProviderSimple
) As ITextRangeProvider

Parameters

childElement
Type: Windows.UI.Xaml.Automation.ProviderIRawElementProviderSimple
The enclosed object.

Return Value

Type: ITextRangeProvider
A range that spans the child element.

Implements

ITextProviderRangeFromChild(IRawElementProviderSimple)
See Also

Reference

EditorViewAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer.RangeFromPoint Method

EditorViewAutomationPeerRangeFromPoint Method
Retrieves a text range from the vicinity of a screen coordinate.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextRangeProvider RangeFromPoint(
    Point screenLocation
)
Public Function RangeFromPoint (
    screenLocation As Point
) As ITextRangeProvider

Parameters

screenLocation
Type: Windows.FoundationPoint
The coordinate screen location.

Return Value

Type: ITextRangeProvider
A range that contains text.
See Also

Reference

EditorViewAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer.SetValue Method

EditorViewAutomationPeerSetValue Method
Overload List
 | Name | Description
Public method | SetValue(String) | Sets the value of a control.
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Top
See Also

Reference

EditorViewAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorViewAutomationPeer.SetValue Method (String)

EditorViewAutomationPeerSetValue Method (String)
Sets the value of a control.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void SetValue(
    string value
)
Public Sub SetValue (
    value As String
)

Parameters

value
Type: SystemString
The value to set. The provider is responsible for converting the value to the appropriate data type.

Implements

IValueProviderSetValue(String)
See Also

Reference

EditorViewAutomationPeer Class
SetValue Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorWordWrapGlyphMarginAutomationPeer Class

EditorWordWrapGlyphMarginAutomationPeer Class
Exposes EditorWordWrapGlyphMargin types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.PeersEditorWordWrapGlyphMarginAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EditorWordWrapGlyphMarginAutomationPeer : FrameworkElementAutomationPeer
Public Class EditorWordWrapGlyphMarginAutomationPeer
    Inherits FrameworkElementAutomationPeer

The EditorWordWrapGlyphMarginAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | EditorWordWrapGlyphMarginAutomationPeer | Initializes a new instance of the EditorWordWrapGlyphMarginAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorWordWrapGlyphMarginAutomationPeer Constructor

EditorWordWrapGlyphMarginAutomationPeer Constructor
Initializes a new instance of the EditorWordWrapGlyphMarginAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EditorWordWrapGlyphMarginAutomationPeer(
    EditorWordWrapGlyphMargin owner
)
Public Sub New (
    owner As EditorWordWrapGlyphMargin
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.PrimitivesEditorWordWrapGlyphMargin
The owner element.
See Also

Reference

EditorWordWrapGlyphMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorWordWrapGlyphMarginAutomationPeer Properties

EditorWordWrapGlyphMarginAutomationPeer Properties

The EditorWordWrapGlyphMarginAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

EditorWordWrapGlyphMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorWordWrapGlyphMarginAutomationPeer Methods

EditorWordWrapGlyphMarginAutomationPeer Methods

The EditorWordWrapGlyphMarginAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

EditorWordWrapGlyphMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorWordWrapGlyphMarginAutomationPeer.GetAutomationControlTypeCore Method

EditorWordWrapGlyphMarginAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

EditorWordWrapGlyphMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorWordWrapGlyphMarginAutomationPeer.GetClassNameCore Method

EditorWordWrapGlyphMarginAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

EditorWordWrapGlyphMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


EditorWordWrapGlyphMarginAutomationPeer.GetLocalizedControlTypeCore Method

EditorWordWrapGlyphMarginAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

EditorWordWrapGlyphMarginAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


IntelliPromptCompletionListAutomationPeer Class

IntelliPromptCompletionListAutomationPeer Class
Exposes IntelliPromptCompletionList types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.PeersIntelliPromptCompletionListAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class IntelliPromptCompletionListAutomationPeer : FrameworkElementAutomationPeer
Public Class IntelliPromptCompletionListAutomationPeer
    Inherits FrameworkElementAutomationPeer

The IntelliPromptCompletionListAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | IntelliPromptCompletionListAutomationPeer | Initializes a new instance of the IntelliPromptCompletionListAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


IntelliPromptCompletionListAutomationPeer Constructor

IntelliPromptCompletionListAutomationPeer Constructor
Initializes a new instance of the IntelliPromptCompletionListAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IntelliPromptCompletionListAutomationPeer(
    IntelliPromptCompletionList owner
)
Public Sub New (
    owner As IntelliPromptCompletionList
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.PrimitivesIntelliPromptCompletionList
The owner element.
See Also

Reference

IntelliPromptCompletionListAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


IntelliPromptCompletionListAutomationPeer Properties

IntelliPromptCompletionListAutomationPeer Properties

The IntelliPromptCompletionListAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

IntelliPromptCompletionListAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


IntelliPromptCompletionListAutomationPeer Methods

IntelliPromptCompletionListAutomationPeer Methods

The IntelliPromptCompletionListAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

IntelliPromptCompletionListAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


IntelliPromptCompletionListAutomationPeer.GetAutomationControlTypeCore Method

IntelliPromptCompletionListAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

IntelliPromptCompletionListAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


IntelliPromptCompletionListAutomationPeer.GetClassNameCore Method

IntelliPromptCompletionListAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

IntelliPromptCompletionListAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


IntelliPromptCompletionListAutomationPeer.GetLocalizedControlTypeCore Method

IntelliPromptCompletionListAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

IntelliPromptCompletionListAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


IntelliPromptParameterInfoAutomationPeer Class

IntelliPromptParameterInfoAutomationPeer Class
Exposes IntelliPromptParameterInfo types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.PeersIntelliPromptParameterInfoAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class IntelliPromptParameterInfoAutomationPeer : FrameworkElementAutomationPeer
Public Class IntelliPromptParameterInfoAutomationPeer
    Inherits FrameworkElementAutomationPeer

The IntelliPromptParameterInfoAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | IntelliPromptParameterInfoAutomationPeer | Initializes a new instance of the IntelliPromptParameterInfoAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


IntelliPromptParameterInfoAutomationPeer Constructor

IntelliPromptParameterInfoAutomationPeer Constructor
Initializes a new instance of the IntelliPromptParameterInfoAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IntelliPromptParameterInfoAutomationPeer(
    IntelliPromptParameterInfo owner
)
Public Sub New (
    owner As IntelliPromptParameterInfo
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.PrimitivesIntelliPromptParameterInfo
The owner element.
See Also

Reference

IntelliPromptParameterInfoAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


IntelliPromptParameterInfoAutomationPeer Properties

IntelliPromptParameterInfoAutomationPeer Properties

The IntelliPromptParameterInfoAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

IntelliPromptParameterInfoAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


IntelliPromptParameterInfoAutomationPeer Methods

IntelliPromptParameterInfoAutomationPeer Methods

The IntelliPromptParameterInfoAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

IntelliPromptParameterInfoAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


IntelliPromptParameterInfoAutomationPeer.GetAutomationControlTypeCore Method

IntelliPromptParameterInfoAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

IntelliPromptParameterInfoAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


IntelliPromptParameterInfoAutomationPeer.GetClassNameCore Method

IntelliPromptParameterInfoAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

IntelliPromptParameterInfoAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


IntelliPromptParameterInfoAutomationPeer.GetLocalizedControlTypeCore Method

IntelliPromptParameterInfoAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

IntelliPromptParameterInfoAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


IntelliPromptQuickInfoAutomationPeer Class

IntelliPromptQuickInfoAutomationPeer Class
Exposes IntelliPromptQuickInfo types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.PeersIntelliPromptQuickInfoAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class IntelliPromptQuickInfoAutomationPeer : FrameworkElementAutomationPeer
Public Class IntelliPromptQuickInfoAutomationPeer
    Inherits FrameworkElementAutomationPeer

The IntelliPromptQuickInfoAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | IntelliPromptQuickInfoAutomationPeer | Initializes a new instance of the IntelliPromptQuickInfoAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


IntelliPromptQuickInfoAutomationPeer Constructor

IntelliPromptQuickInfoAutomationPeer Constructor
Initializes a new instance of the IntelliPromptQuickInfoAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IntelliPromptQuickInfoAutomationPeer(
    IntelliPromptQuickInfo owner
)
Public Sub New (
    owner As IntelliPromptQuickInfo
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.PrimitivesIntelliPromptQuickInfo
The owner element.
See Also

Reference

IntelliPromptQuickInfoAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


IntelliPromptQuickInfoAutomationPeer Properties

IntelliPromptQuickInfoAutomationPeer Properties

The IntelliPromptQuickInfoAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

IntelliPromptQuickInfoAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


IntelliPromptQuickInfoAutomationPeer Methods

IntelliPromptQuickInfoAutomationPeer Methods

The IntelliPromptQuickInfoAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

IntelliPromptQuickInfoAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


IntelliPromptQuickInfoAutomationPeer.GetAutomationControlTypeCore Method

IntelliPromptQuickInfoAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

IntelliPromptQuickInfoAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


IntelliPromptQuickInfoAutomationPeer.GetClassNameCore Method

IntelliPromptQuickInfoAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

IntelliPromptQuickInfoAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


IntelliPromptQuickInfoAutomationPeer.GetLocalizedControlTypeCore Method

IntelliPromptQuickInfoAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

IntelliPromptQuickInfoAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


SyntaxEditorAutomationPeer Class

SyntaxEditorAutomationPeer Class
Exposes SyntaxEditor types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.PeersSyntaxEditorAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SyntaxEditorAutomationPeer : FrameworkElementAutomationPeer
Public Class SyntaxEditorAutomationPeer
    Inherits FrameworkElementAutomationPeer

The SyntaxEditorAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxEditorAutomationPeer | Initializes a new instance of the SyntaxEditorAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Returns the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClassName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLocalizedControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


SyntaxEditorAutomationPeer Constructor

SyntaxEditorAutomationPeer Constructor
Initializes a new instance of the SyntaxEditorAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SyntaxEditorAutomationPeer(
    FrameworkElement owner
)
Public Sub New (
    owner As FrameworkElement
)

Parameters

owner
Type: Windows.UI.XamlFrameworkElement
The owner element.
See Also

Reference

SyntaxEditorAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


SyntaxEditorAutomationPeer Properties

SyntaxEditorAutomationPeer Properties

The SyntaxEditorAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

SyntaxEditorAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


SyntaxEditorAutomationPeer Methods

SyntaxEditorAutomationPeer Methods

The SyntaxEditorAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Returns the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClassName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLocalizedControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

SyntaxEditorAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


SyntaxEditorAutomationPeer.GetAutomationControlTypeCore Method

SyntaxEditorAutomationPeerGetAutomationControlTypeCore Method
Returns the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

SyntaxEditorAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions Namespace

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions Namespace
Contains IEditAction implementation types.
Classes
 | Class | Description
Public class | BackspaceAction | Represents an IEditAction that deletes the currently selected text if text is selected; otherwise, deletes the previous character.
Public class | BackspaceToPreviousWordAction | Represents an IEditAction that backspaces and deletes text to the beginning of the previous word.
Public class | CancelMacroRecordingAction | Represents an IEditAction that cancels recording a macro.
Public class | CapitalizeAction | Represents an IEditAction that capitalizes the first letter of each word in the selection.
Public class | ChangeCharacterCasingAction | Represents an IEditAction that changes the character casing of the selected text.
Public class | CodeBlockSelectionContractAction | Represents an IEditAction that contracts the code block selection level.
Public class | CodeBlockSelectionExpandAction | Represents an IEditAction that expands the code block selection level.
Public class | CollapseSelectionAction | Represents an IEditAction that collapses the selection to the caret.
Public class | CollapseToDefinitionsAction | Represents an IEditAction that collapses all outlining nodes that have an IsImplementation value of true.
Public class | CommentLinesAction | Represents an IEditAction that comments the currently selected lines.
Public class | ConvertSpacesToTabsAction | Represents an IEditAction that converts all spaces in the selection to an equivalent number of tabs.
Public class | ConvertTabsToSpacesAction | Represents an IEditAction that converts all tabs in the selection to an equivalent number of spaces.
Public class | CopyAndAppendToClipboardAction | Represents an IEditAction that copies and appends the currently selected text to the clipboard.
Public class | CopyToClipboardAction | Represents an IEditAction that copies the currently selected text to the clipboard.
Public class | CutAndAppendToClipboardAction | Represents an IEditAction that cuts and appends the currently selected text to the clipboard.
Public class | CutLineToClipboardAction | Represents an IEditAction that cuts the current view line's text to the clipboard.
Public class | CutToClipboardAction | Represents an IEditAction that cuts the currently selected text to the clipboard.
Public class | DeleteAction | Represents an IEditAction that deletes the currently selected text if text is selected; otherwise, deletes the next character.
Public class | DeleteBlankLinesAction | Represents an IEditAction that deletes the blank lines in the selected text, or the current view line if no text is selected and it is blank.
Public class | DeleteHorizontalWhitespaceAction | Represents an IEditAction that deletes the horizontal whitespace within the current selection.
Public class | DeleteLineAction | Represents an IEditAction that deletes the currently active view line.
Public class | DeleteToLineEndAction | Represents an IEditAction that deletes the currently selected text through to the end of the current view line.
Public class | DeleteToLineStartAction | Represents an IEditAction that deletes the currently selected text through to the start of the current view line.
Public class | DeleteToNextWordAction | Represents an IEditAction that deletes text to the beginning of the next word.
Public class | DuplicateLineAction | Represents an IEditAction that duplicates the current document line.
Public class | FormatDocumentAction | Represents an IEditAction that formats the document.
Public class | FormatSelectionAction | Represents an IEditAction that formats the currently selected lines.
Public class | HideSelectionAction | Represents an IEditAction that collapses the current selection.
Public class | IncrementalSearchAction | Represents an IEditAction that performs a forward incremental search.
Public class | IndentAction | Represents an IEditAction that indents the currently selected lines.
Public class | InsertLineBreakAction | Represents an IEditAction that inserts a line break at the current position.
Public class | InsertTabStopOrIndentAction | Represents an IEditAction that inserts whitespace to bring the caret to the next tab stop if there is no selection, or alternatively indents the currently selected lines.
Public class | MacroAction | Represents an IEditAction that contains a list of IEditAction objects that can be executed in a macro.
Public class | MakeLowercaseAction | Represents an IEditAction that changes the character casing of the selected text to lowercase.
Public class | MakeUppercaseAction | Represents an IEditAction that changes the character casing of the selected text to uppercase.
Public class | MoveDownAction | Represents an IEditAction that moves the caret down a line.
Public class | MoveLeftAction | Represents an IEditAction that moves the caret left a character.
Public class | MovePageDownAction | Represents an IEditAction that moves the caret down a page.
Public class | MovePageUpAction | Represents an IEditAction that moves the caret up a page.
Public class | MoveRightAction | Represents an IEditAction that moves the caret right a character.
Public class | MoveSelectedLinesDownAction | Represents an IEditAction that moves the selected lines down.
Public class | MoveSelectedLinesUpAction | Represents an IEditAction that moves the selected lines up.
Public class | MoveToDocumentEndAction | Represents an IEditAction that moves the caret to the end of the document.
Public class | MoveToDocumentStartAction | Represents an IEditAction that moves the caret to the start of the document.
Public class | MoveToLineEndAction | Represents an IEditAction that moves the caret to the end of the line.
Public class | MoveToLineStartAction | Represents an IEditAction that moves the caret to the start of the line.
Public class | MoveToLineStartAfterIndentationAction | Represents an IEditAction that moves the caret to the first non-whitespace character on the current view line.
Public class | MoveToMatchingBracketAction | Represents an IEditAction that moves the caret to the matching bracket, if any.
Public class | MoveToNextLineStartAfterIndentationAction | Represents an IEditAction that moves the caret to the first non-whitespace character on the next view line.
Public class | MoveToNextWordAction | Represents an IEditAction that moves the caret to the next word.
Public class | MoveToPreviousLineStartAfterIndentationAction | Represents an IEditAction that moves the caret to the first non-whitespace character on the previous view line.
Public class | MoveToPreviousWordAction | Represents an IEditAction that moves the caret to the previous word.
Public class | MoveToVisibleBottomAction | Represents an IEditAction that moves the caret to the bottom of the view.
Public class | MoveToVisibleTopAction | Represents an IEditAction that moves the caret to the top of the view.
Public class | MoveUpAction | Represents an IEditAction that moves the caret up a line.
Public class | OpenLineAboveAction | Represents an IEditAction that inserts a new line above the current view line.
Public class | OpenLineBelowAction | Represents an IEditAction that inserts a new line below the current view line.
Public class | OutdentAction | Represents an IEditAction that outdents the currently selected lines.
Public class | PasteFromClipboardAction | Represents an IEditAction that pastes text from the clipboard into the editor view.
Public class | PauseResumeMacroRecordingAction | Represents an IEditAction that pauses or resumes recording a macro, depending on the current state of macro recording.
Public class | RedoAction | Represents an IEditAction that performs a redo operation.
Public class | RemoveTabStopOrOutdentAction | Represents an IEditAction that removes whitespace to bring the caret to the previous tab stop if there is no selection, or alternatively outdents the currently selected lines.
Public class | RequestIntelliPromptAutoCompleteAction | Represents an IEditAction that performs an auto-complete if the language supports an IntelliPrompt completion session at the current offset.
Public class | RequestIntelliPromptCompletionSessionAction | Represents an IEditAction that displays a completion list if the language supports an IntelliPrompt completion session at the current offset.
Public class | RequestIntelliPromptInsertSnippetSessionAction | Represents an IEditAction that allows for IntelliPrompt 'expansion' code snippet selection at the current offset.
Public class | RequestIntelliPromptParameterInfoSessionAction | Represents an IEditAction that displays IntelliPrompt parameter info based on the current context.
Public class | RequestIntelliPromptQuickInfoSessionAction | Represents an IEditAction that displays IntelliPrompt quick info based on the current context.
Public class | RequestIntelliPromptSurroundWithSessionAction | Represents an IEditAction that allows for IntelliPrompt 'surrounds with' code snippet selection at the current offset.
Public class | ReverseIncrementalSearchAction | Represents an IEditAction that performs a reverse incremental search.
Public class | RunMacroAction | Represents an IEditAction that runs the macro that was last recorded.
Public class | ScrollDownAction | Represents an IEditAction that scrolls down a line.
Public class | ScrollLeftAction | Represents an IEditAction that scrolls left a column.
Public class | ScrollLineToVisibleBottomAction | Represents an IEditAction that scrolls the current view line to the bottom of the view.
Public class | ScrollLineToVisibleMiddleAction | Represents an IEditAction that scrolls the current view line to the middle of the view.
Public class | ScrollLineToVisibleTopAction | Represents an IEditAction that scrolls the current view line to the top of the view.
Public class | ScrollPageDownAction | Represents an IEditAction that scrolls down a page.
Public class | ScrollPageUpAction | Represents an IEditAction that scrolls up a page.
Public class | ScrollRightAction | Represents an IEditAction that scrolls right a column.
Public class | ScrollToDocumentEndAction | Represents an IEditAction that scrolls to the document end.
Public class | ScrollToDocumentStartAction | Represents an IEditAction that scrolls to the document start.
Public class | ScrollUpAction | Represents an IEditAction that scrolls up a line.
Public class | SelectAllAction | Represents an IEditAction that selects all the text.
Public class | SelectBlockDownAction | Represents an IEditAction that extends the block selection down a line.
Public class | SelectBlockLeftAction | Represents an IEditAction that extends the block selection left a character.
Public class | SelectBlockRightAction | Represents an IEditAction that extends the block selection right a character.
Public class | SelectBlockToNextWordAction | Represents an IEditAction that extends the block selection to the next word.
Public class | SelectBlockToPreviousWordAction | Represents an IEditAction that extends the block selection to the previous word.
Public class | SelectBlockUpAction | Represents an IEditAction that extends the block selection up a line.
Public class | SelectDownAction | Represents an IEditAction that extends the selection down a line.
Public class | SelectLeftAction | Represents an IEditAction that extends the selection left a character.
Public class | SelectPageDownAction | Represents an IEditAction that extends the selection down a page.
Public class | SelectPageUpAction | Represents an IEditAction that extends the selection up a page.
Public class | SelectRightAction | Represents an IEditAction that extends the selection right a character.
Public class | SelectToDocumentEndAction | Represents an IEditAction that extends the selection to the end of the document.
Public class | SelectToDocumentStartAction | Represents an IEditAction that extends the selection to the start of the document.
Public class | SelectToLineEndAction | Represents an IEditAction that extends the selection to the end of the line.
Public class | SelectToLineStartAction | Represents an IEditAction that extends the selection to the start of the line.
Public class | SelectToLineStartAfterIndentationAction | Represents an IEditAction that extends the selection to the first non-whitespace character on the current view line.
Public class | SelectToMatchingBracketAction | Represents an IEditAction that extends the selection to the matching bracket, if any.
Public class | SelectToNextWordAction | Represents an IEditAction that extends the selection to the next word.
Public class | SelectToPreviousWordAction | Represents an IEditAction that extends the selection to the previous word.
Public class | SelectToVisibleBottomAction | Represents an IEditAction that extends the selection to the bottom of the view.
Public class | SelectToVisibleTopAction | Represents an IEditAction that extends the selection to the top of the view.
Public class | SelectUpAction | Represents an IEditAction that extends the selection up a line.
Public class | SelectWordAction | Represents an IEditAction that selects the current word.
Public class | StartAutomaticOutliningAction | Represents an IEditAction that is used to start automatic outlining.
Public class | StopHidingCurrentAction | Represents an IEditAction that is used to stop hiding the outlining node that currently contains the caret, if any.
Public class | StopOutliningAction | Represents an IEditAction that is used to stop outlining.
Public class | TabifySelectedLinesAction | Represents an IEditAction that converts spaces at the beginning of the active view lines to tabs.
Public class | ToggleAllOutliningExpansionAction | Represents an IEditAction that toggles the collapsed state of all outlining nodes.
Public class | ToggleCharacterCasingAction | Represents an IEditAction that toggles the character casing of the selected text.
Public class | ToggleMacroRecordingAction | Represents an IEditAction that starts or stops recording a macro, depending on the current state of macro recording.
Public class | ToggleOutliningExpansionAction | Represents an IEditAction that toggles the outlining nodes that intersect with the view line that contains the caret.
Public class | ToggleOverwriteModeAction | Represents an IEditAction that toggles overwrite mode.
Public class | TransposeCharactersAction | Represents an IEditAction that transposes the characters before and after the caret.
Public class | TransposeLinesAction | Represents an IEditAction that transposes the current view line with the next view line.
Public class | TransposeWordsAction | Represents an IEditAction that transposes the words before and after the caret.
Public class | TrimAllTrailingWhitespaceAction | Represents an IEditAction that trims the trailing whitespace off all the lines in the document.
Public class | TrimTrailingWhitespaceAction | Represents an IEditAction that trims the trailing whitespace off all the lines in the selected text, or the current document line if no text is selected.
Public class | TypingAction | Represents an IEditAction that performs typing in a document.
Public class | UncommentLinesAction | Represents an IEditAction that uncomments the currently selected lines.
Public class | UndoAction | Represents an IEditAction that performs an undo operation.
Public class | UntabifySelectedLinesAction | Represents an IEditAction that converts tabs at the beginning of the active view lines to spaces.


BackspaceAction Class

BackspaceAction Class
Represents an IEditAction that deletes the currently selected text if text is selected; otherwise, deletes the previous character.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsBackspaceAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BackspaceAction : EditActionBase
Public Class BackspaceAction
    Inherits EditActionBase

The BackspaceAction type exposes the following members.

Constructors
 | Name | Description
Public method | BackspaceAction | Initializes a new instance of the BackspaceAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions Namespace


BackspaceAction Constructor

BackspaceAction Constructor
Initializes a new instance of the BackspaceAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BackspaceAction()
Public Sub New
See Also

Reference

BackspaceAction Class


BackspaceAction Properties

BackspaceAction Properties

The BackspaceAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

BackspaceAction Class


BackspaceAction Methods

BackspaceAction Methods

The BackspaceAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

BackspaceAction Class


BackspaceAction.CanExecute Method

BackspaceActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

BackspaceAction Class


BackspaceAction.Execute Method

BackspaceActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

BackspaceAction Class


BackspaceToPreviousWordAction Class

BackspaceToPreviousWordAction Class
Represents an IEditAction that backspaces and deletes text to the beginning of the previous word.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsBackspaceToPreviousWordAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BackspaceToPreviousWordAction : EditActionBase
Public Class BackspaceToPreviousWordAction
    Inherits EditActionBase

The BackspaceToPreviousWordAction type exposes the following members.

Constructors
 | Name | Description
Public method | BackspaceToPreviousWordAction | Initializes a new instance of the BackspaceToPreviousWordAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


BackspaceToPreviousWordAction Constructor

BackspaceToPreviousWordAction Constructor
Initializes a new instance of the BackspaceToPreviousWordAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BackspaceToPreviousWordAction()
Public Sub New
See Also

Reference

BackspaceToPreviousWordAction Class


BackspaceToPreviousWordAction Properties

BackspaceToPreviousWordAction Properties

The BackspaceToPreviousWordAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

BackspaceToPreviousWordAction Class


BackspaceToPreviousWordAction Methods

BackspaceToPreviousWordAction Methods

The BackspaceToPreviousWordAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

BackspaceToPreviousWordAction Class


BackspaceToPreviousWordAction.CanExecute Method

BackspaceToPreviousWordActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

BackspaceToPreviousWordAction Class


BackspaceToPreviousWordAction.Execute Method

BackspaceToPreviousWordActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

BackspaceToPreviousWordAction Class


CancelMacroRecordingAction Class

CancelMacroRecordingAction Class
Represents an IEditAction that cancels recording a macro.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCancelMacroRecordingAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CancelMacroRecordingAction : EditActionBase
Public Class CancelMacroRecordingAction
    Inherits EditActionBase

The CancelMacroRecordingAction type exposes the following members.

Constructors
 | Name | Description
Public method | CancelMacroRecordingAction | Initializes a new instance of the CancelMacroRecordingAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Overrides EditActionBaseCanRecordInMacro.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


CancelMacroRecordingAction Constructor

CancelMacroRecordingAction Constructor
Initializes a new instance of the CancelMacroRecordingAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CancelMacroRecordingAction()
Public Sub New
See Also

Reference

CancelMacroRecordingAction Class


CancelMacroRecordingAction Properties

CancelMacroRecordingAction Properties

The CancelMacroRecordingAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Overrides EditActionBaseCanRecordInMacro.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

CancelMacroRecordingAction Class


CancelMacroRecordingAction.CanRecordInMacro Property

CancelMacroRecordingActionCanRecordInMacro Property
Gets whether the action can be recorded in a macro.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanRecordInMacro { get; }
Public Overrides ReadOnly Property CanRecordInMacro As Boolean
    Get

Property Value

Type: Boolean
true if the action can be recorded in a macro; otherwise, false.

Implements

IEditActionCanRecordInMacro
See Also

Reference

CancelMacroRecordingAction Class


CancelMacroRecordingAction Methods

CancelMacroRecordingAction Methods

The CancelMacroRecordingAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

CancelMacroRecordingAction Class


CancelMacroRecordingAction.CanExecute Method

CancelMacroRecordingActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

CancelMacroRecordingAction Class


CancelMacroRecordingAction.Execute Method

CancelMacroRecordingActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

CancelMacroRecordingAction Class


CapitalizeAction Class

CapitalizeAction Class
Represents an IEditAction that capitalizes the first letter of each word in the selection.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsChangeCharacterCasingAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCapitalizeAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CapitalizeAction : ChangeCharacterCasingAction
Public Class CapitalizeAction
    Inherits ChangeCharacterCasingAction

The CapitalizeAction type exposes the following members.

Constructors
 | Name | Description
Public method | CapitalizeAction | Initializes a new instance of the CapitalizeAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Protected property | Casing | Gets the CharacterCasing to apply. (Overrides ChangeCharacterCasingActionCasing.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from ChangeCharacterCasingAction.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Inherited from ChangeCharacterCasingAction.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
Remarks
If no text is currently selected, only the character after the caret is changed.
See Also

Reference


CapitalizeAction Constructor

CapitalizeAction Constructor
Initializes a new instance of the CapitalizeAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CapitalizeAction()
Public Sub New
See Also

Reference

CapitalizeAction Class


CapitalizeAction Properties

CapitalizeAction Properties

The CapitalizeAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Protected property | Casing | Gets the CharacterCasing to apply. (Overrides ChangeCharacterCasingActionCasing.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

CapitalizeAction Class


CapitalizeAction.Casing Property

CapitalizeActionCasing Property
Gets the CharacterCasing to apply.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override CharacterCasing Casing { get; }
Protected Overrides ReadOnly Property Casing As CharacterCasing
    Get

Property Value

Type: CharacterCasing
The CharacterCasing to apply.
See Also

Reference

CapitalizeAction Class


CapitalizeAction Methods

CapitalizeAction Methods

The CapitalizeAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from ChangeCharacterCasingAction.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Inherited from ChangeCharacterCasingAction.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

CapitalizeAction Class


ChangeCharacterCasingAction Class

ChangeCharacterCasingAction Class
Represents an IEditAction that changes the character casing of the selected text.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsChangeCharacterCasingAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCapitalizeAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMakeLowercaseAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMakeUppercaseAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class ChangeCharacterCasingAction : EditActionBase
Public MustInherit Class ChangeCharacterCasingAction
    Inherits EditActionBase

The ChangeCharacterCasingAction type exposes the following members.

Constructors
 | Name | Description
Protected method | ChangeCharacterCasingAction | Initializes a new instance of the ChangeCharacterCasingAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Protected property | Casing | Gets the CharacterCasing to apply.
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
Remarks
If no text is currently selected, only the character after the caret is changed.
See Also

Reference


ChangeCharacterCasingAction Constructor

ChangeCharacterCasingAction Constructor
Initializes a new instance of the ChangeCharacterCasingAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected ChangeCharacterCasingAction()
Protected Sub New
See Also

Reference

ChangeCharacterCasingAction Class


ChangeCharacterCasingAction Properties

ChangeCharacterCasingAction Properties

The ChangeCharacterCasingAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Protected property | Casing | Gets the CharacterCasing to apply.
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

ChangeCharacterCasingAction Class


ChangeCharacterCasingAction.Casing Property

ChangeCharacterCasingActionCasing Property
Gets the CharacterCasing to apply.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract CharacterCasing Casing { get; }
Protected MustOverride ReadOnly Property Casing As CharacterCasing
    Get

Property Value

Type: CharacterCasing
The CharacterCasing to apply.
See Also

Reference

ChangeCharacterCasingAction Class


ChangeCharacterCasingAction Methods

ChangeCharacterCasingAction Methods

The ChangeCharacterCasingAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

ChangeCharacterCasingAction Class


ChangeCharacterCasingAction.CanExecute Method

ChangeCharacterCasingActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

ChangeCharacterCasingAction Class


ChangeCharacterCasingAction.Execute Method

ChangeCharacterCasingActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

ChangeCharacterCasingAction Class


CodeBlockSelectionContractAction Class

CodeBlockSelectionContractAction Class
Represents an IEditAction that contracts the code block selection level.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCodeBlockSelectionContractAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CodeBlockSelectionContractAction : EditActionBase
Public Class CodeBlockSelectionContractAction
    Inherits EditActionBase

The CodeBlockSelectionContractAction type exposes the following members.

Constructors
 | Name | Description
Public method | CodeBlockSelectionContractAction | Initializes a new instance of the CodeBlockSelectionContractAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


CodeBlockSelectionContractAction Constructor

CodeBlockSelectionContractAction Constructor
Initializes a new instance of the CodeBlockSelectionContractAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CodeBlockSelectionContractAction()
Public Sub New
See Also

Reference

CodeBlockSelectionContractAction Class


CodeBlockSelectionContractAction Properties

CodeBlockSelectionContractAction Properties

The CodeBlockSelectionContractAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

CodeBlockSelectionContractAction Class


CodeBlockSelectionContractAction Methods

CodeBlockSelectionContractAction Methods

The CodeBlockSelectionContractAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

CodeBlockSelectionContractAction Class


CodeBlockSelectionContractAction.CanExecute Method

CodeBlockSelectionContractActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

CodeBlockSelectionContractAction Class


CodeBlockSelectionContractAction.Execute Method

CodeBlockSelectionContractActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

CodeBlockSelectionContractAction Class


CodeBlockSelectionExpandAction Class

CodeBlockSelectionExpandAction Class
Represents an IEditAction that expands the code block selection level.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCodeBlockSelectionExpandAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CodeBlockSelectionExpandAction : EditActionBase
Public Class CodeBlockSelectionExpandAction
    Inherits EditActionBase

The CodeBlockSelectionExpandAction type exposes the following members.

Constructors
 | Name | Description
Public method | CodeBlockSelectionExpandAction | Initializes a new instance of the CodeBlockSelectionExpandAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


CodeBlockSelectionExpandAction Constructor

CodeBlockSelectionExpandAction Constructor
Initializes a new instance of the CodeBlockSelectionExpandAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CodeBlockSelectionExpandAction()
Public Sub New
See Also

Reference

CodeBlockSelectionExpandAction Class


CodeBlockSelectionExpandAction Properties

CodeBlockSelectionExpandAction Properties

The CodeBlockSelectionExpandAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

CodeBlockSelectionExpandAction Class


CodeBlockSelectionExpandAction Methods

CodeBlockSelectionExpandAction Methods

The CodeBlockSelectionExpandAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

CodeBlockSelectionExpandAction Class


CodeBlockSelectionExpandAction.CanExecute Method

CodeBlockSelectionExpandActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

CodeBlockSelectionExpandAction Class


CodeBlockSelectionExpandAction.Execute Method

CodeBlockSelectionExpandActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

CodeBlockSelectionExpandAction Class


CollapseSelectionAction Class

CollapseSelectionAction Class
Represents an IEditAction that collapses the selection to the caret.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCollapseSelectionAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CollapseSelectionAction : EditActionBase
Public Class CollapseSelectionAction
    Inherits EditActionBase

The CollapseSelectionAction type exposes the following members.

Constructors
 | Name | Description
Public method | CollapseSelectionAction | Initializes a new instance of the CollapseSelectionAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


CollapseSelectionAction Constructor

CollapseSelectionAction Constructor
Initializes a new instance of the CollapseSelectionAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CollapseSelectionAction()
Public Sub New
See Also

Reference

CollapseSelectionAction Class


CollapseSelectionAction Properties

CollapseSelectionAction Properties

The CollapseSelectionAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

CollapseSelectionAction Class


CollapseSelectionAction Methods

CollapseSelectionAction Methods

The CollapseSelectionAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

CollapseSelectionAction Class


CollapseSelectionAction.CanExecute Method

CollapseSelectionActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

CollapseSelectionAction Class


CollapseSelectionAction.Execute Method

CollapseSelectionActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

CollapseSelectionAction Class


CollapseToDefinitionsAction Class

CollapseToDefinitionsAction Class
Represents an IEditAction that collapses all outlining nodes that have an IsImplementation value of true.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCollapseToDefinitionsAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CollapseToDefinitionsAction : EditActionBase
Public Class CollapseToDefinitionsAction
    Inherits EditActionBase

The CollapseToDefinitionsAction type exposes the following members.

Constructors
 | Name | Description
Public method | CollapseToDefinitionsAction | Initializes a new instance of the CollapseToDefinitionsAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


CollapseToDefinitionsAction Constructor

CollapseToDefinitionsAction Constructor
Initializes a new instance of the CollapseToDefinitionsAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CollapseToDefinitionsAction()
Public Sub New
See Also

Reference

CollapseToDefinitionsAction Class


CollapseToDefinitionsAction Properties

CollapseToDefinitionsAction Properties

The CollapseToDefinitionsAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

CollapseToDefinitionsAction Class


CollapseToDefinitionsAction Methods

CollapseToDefinitionsAction Methods

The CollapseToDefinitionsAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

CollapseToDefinitionsAction Class


CollapseToDefinitionsAction.CanExecute Method

CollapseToDefinitionsActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

CollapseToDefinitionsAction Class


CollapseToDefinitionsAction.Execute Method

CollapseToDefinitionsActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

CollapseToDefinitionsAction Class


CommentLinesAction Class

CommentLinesAction Class
Represents an IEditAction that comments the currently selected lines.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCommentLinesAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CommentLinesAction : EditActionBase
Public Class CommentLinesAction
    Inherits EditActionBase

The CommentLinesAction type exposes the following members.

Constructors
 | Name | Description
Public method | CommentLinesAction | Initializes a new instance of the CommentLinesAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


CommentLinesAction Constructor

CommentLinesAction Constructor
Initializes a new instance of the CommentLinesAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CommentLinesAction()
Public Sub New
See Also

Reference

CommentLinesAction Class


CommentLinesAction Properties

CommentLinesAction Properties

The CommentLinesAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

CommentLinesAction Class


CommentLinesAction Methods

CommentLinesAction Methods

The CommentLinesAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

CommentLinesAction Class


CommentLinesAction.CanExecute Method

CommentLinesActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

CommentLinesAction Class


CommentLinesAction.Execute Method

CommentLinesActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

CommentLinesAction Class


ConvertSpacesToTabsAction Class

ConvertSpacesToTabsAction Class
Represents an IEditAction that converts all spaces in the selection to an equivalent number of tabs.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsConvertSpacesToTabsAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ConvertSpacesToTabsAction : EditActionBase
Public Class ConvertSpacesToTabsAction
    Inherits EditActionBase

The ConvertSpacesToTabsAction type exposes the following members.

Constructors
 | Name | Description
Public method | ConvertSpacesToTabsAction | Initializes a new instance of the ConvertSpacesToTabsAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


ConvertSpacesToTabsAction Constructor

ConvertSpacesToTabsAction Constructor
Initializes a new instance of the ConvertSpacesToTabsAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ConvertSpacesToTabsAction()
Public Sub New
See Also

Reference

ConvertSpacesToTabsAction Class


ConvertSpacesToTabsAction Properties

ConvertSpacesToTabsAction Properties

The ConvertSpacesToTabsAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

ConvertSpacesToTabsAction Class


ConvertSpacesToTabsAction Methods

ConvertSpacesToTabsAction Methods

The ConvertSpacesToTabsAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

ConvertSpacesToTabsAction Class


ConvertSpacesToTabsAction.CanExecute Method

ConvertSpacesToTabsActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

ConvertSpacesToTabsAction Class


ConvertSpacesToTabsAction.Execute Method

ConvertSpacesToTabsActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

ConvertSpacesToTabsAction Class


ConvertTabsToSpacesAction Class

ConvertTabsToSpacesAction Class
Represents an IEditAction that converts all tabs in the selection to an equivalent number of spaces.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsConvertTabsToSpacesAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ConvertTabsToSpacesAction : EditActionBase
Public Class ConvertTabsToSpacesAction
    Inherits EditActionBase

The ConvertTabsToSpacesAction type exposes the following members.

Constructors
 | Name | Description
Public method | ConvertTabsToSpacesAction | Initializes a new instance of the ConvertTabsToSpacesAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


ConvertTabsToSpacesAction Constructor

ConvertTabsToSpacesAction Constructor
Initializes a new instance of the ConvertTabsToSpacesAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ConvertTabsToSpacesAction()
Public Sub New
See Also

Reference

ConvertTabsToSpacesAction Class


ConvertTabsToSpacesAction Properties

ConvertTabsToSpacesAction Properties

The ConvertTabsToSpacesAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

ConvertTabsToSpacesAction Class


ConvertTabsToSpacesAction Methods

ConvertTabsToSpacesAction Methods

The ConvertTabsToSpacesAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

ConvertTabsToSpacesAction Class


ConvertTabsToSpacesAction.CanExecute Method

ConvertTabsToSpacesActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

ConvertTabsToSpacesAction Class


ConvertTabsToSpacesAction.Execute Method

ConvertTabsToSpacesActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

ConvertTabsToSpacesAction Class


CopyAndAppendToClipboardAction Class

CopyAndAppendToClipboardAction Class
Represents an IEditAction that copies and appends the currently selected text to the clipboard.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCopyToClipboardAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCopyAndAppendToClipboardAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CopyAndAppendToClipboardAction : CopyToClipboardAction
Public Class CopyAndAppendToClipboardAction
    Inherits CopyToClipboardAction

The CopyAndAppendToClipboardAction type exposes the following members.

Constructors
 | Name | Description
Public method | CopyAndAppendToClipboardAction | Initializes a new instance of the CopyAndAppendToClipboardAction class
Top
Properties
 | Name | Description
Protected property | Append | Gets whether to append the copied text to the existing clipboard contents instead of overwriting them. (Overrides CopyToClipboardActionAppend.)
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Inherited from CopyToClipboardAction.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


CopyAndAppendToClipboardAction Constructor

CopyAndAppendToClipboardAction Constructor
Initializes a new instance of the CopyAndAppendToClipboardAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CopyAndAppendToClipboardAction()
Public Sub New
See Also

Reference

CopyAndAppendToClipboardAction Class


CopyAndAppendToClipboardAction Properties

CopyAndAppendToClipboardAction Properties

The CopyAndAppendToClipboardAction type exposes the following members.

Properties
 | Name | Description
Protected property | Append | Gets whether to append the copied text to the existing clipboard contents instead of overwriting them. (Overrides CopyToClipboardActionAppend.)
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

CopyAndAppendToClipboardAction Class


CopyAndAppendToClipboardAction.Append Property

CopyAndAppendToClipboardActionAppend Property
Gets whether to append the copied text to the existing clipboard contents instead of overwriting them.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool Append { get; }
Protected Overrides ReadOnly Property Append As Boolean
    Get

Property Value

Type: Boolean
true if the copied text should be appended; otherwise, false.
See Also

Reference

CopyAndAppendToClipboardAction Class


CopyAndAppendToClipboardAction Methods

CopyAndAppendToClipboardAction Methods

The CopyAndAppendToClipboardAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Inherited from CopyToClipboardAction.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

CopyAndAppendToClipboardAction Class


CopyToClipboardAction Class

CopyToClipboardAction Class
Represents an IEditAction that copies the currently selected text to the clipboard.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCopyToClipboardAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCopyAndAppendToClipboardAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CopyToClipboardAction : EditActionBase
Public Class CopyToClipboardAction
    Inherits EditActionBase

The CopyToClipboardAction type exposes the following members.

Constructors
 | Name | Description
Public method | CopyToClipboardAction | Initializes a new instance of the CopyToClipboardAction class
Top
Properties
 | Name | Description
Protected property | Append | Gets whether to append the copied text to the existing clipboard contents instead of overwriting them.
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


CopyToClipboardAction Constructor

CopyToClipboardAction Constructor
Initializes a new instance of the CopyToClipboardAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CopyToClipboardAction()
Public Sub New
See Also

Reference

CopyToClipboardAction Class


CopyToClipboardAction Properties

CopyToClipboardAction Properties

The CopyToClipboardAction type exposes the following members.

Properties
 | Name | Description
Protected property | Append | Gets whether to append the copied text to the existing clipboard contents instead of overwriting them.
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

CopyToClipboardAction Class


CopyToClipboardAction.Append Property

CopyToClipboardActionAppend Property
Gets whether to append the copied text to the existing clipboard contents instead of overwriting them.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool Append { get; }
Protected Overridable ReadOnly Property Append As Boolean
    Get

Property Value

Type: Boolean
true if the copied text should be appended; otherwise, false.
See Also

Reference

CopyToClipboardAction Class


CopyToClipboardAction Methods

CopyToClipboardAction Methods

The CopyToClipboardAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

CopyToClipboardAction Class


CopyToClipboardAction.Execute Method

CopyToClipboardActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

CopyToClipboardAction Class


CutAndAppendToClipboardAction Class

CutAndAppendToClipboardAction Class
Represents an IEditAction that cuts and appends the currently selected text to the clipboard.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCutToClipboardAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCutAndAppendToClipboardAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CutAndAppendToClipboardAction : CutToClipboardAction
Public Class CutAndAppendToClipboardAction
    Inherits CutToClipboardAction

The CutAndAppendToClipboardAction type exposes the following members.

Constructors
 | Name | Description
Public method | CutAndAppendToClipboardAction | Initializes a new instance of the CutAndAppendToClipboardAction class
Top
Properties
 | Name | Description
Protected property | Append | Gets whether to append the copied text to the existing clipboard contents instead of overwriting them. (Overrides CutToClipboardActionAppend.)
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from CutToClipboardAction.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Inherited from CutToClipboardAction.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


CutAndAppendToClipboardAction Constructor

CutAndAppendToClipboardAction Constructor
Initializes a new instance of the CutAndAppendToClipboardAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CutAndAppendToClipboardAction()
Public Sub New
See Also

Reference

CutAndAppendToClipboardAction Class


CutAndAppendToClipboardAction Properties

CutAndAppendToClipboardAction Properties

The CutAndAppendToClipboardAction type exposes the following members.

Properties
 | Name | Description
Protected property | Append | Gets whether to append the copied text to the existing clipboard contents instead of overwriting them. (Overrides CutToClipboardActionAppend.)
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

CutAndAppendToClipboardAction Class


CutAndAppendToClipboardAction.Append Property

CutAndAppendToClipboardActionAppend Property
Gets whether to append the copied text to the existing clipboard contents instead of overwriting them.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool Append { get; }
Protected Overrides ReadOnly Property Append As Boolean
    Get

Property Value

Type: Boolean
true if the copied text should be appended; otherwise, false.
See Also

Reference

CutAndAppendToClipboardAction Class


CutAndAppendToClipboardAction Methods

CutAndAppendToClipboardAction Methods

The CutAndAppendToClipboardAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from CutToClipboardAction.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Inherited from CutToClipboardAction.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

CutAndAppendToClipboardAction Class


CutLineToClipboardAction Class

CutLineToClipboardAction Class
Represents an IEditAction that cuts the current view line's text to the clipboard.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCutLineToClipboardAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CutLineToClipboardAction : EditActionBase
Public Class CutLineToClipboardAction
    Inherits EditActionBase

The CutLineToClipboardAction type exposes the following members.

Constructors
 | Name | Description
Public method | CutLineToClipboardAction | Initializes a new instance of the CutLineToClipboardAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


CutLineToClipboardAction Constructor

CutLineToClipboardAction Constructor
Initializes a new instance of the CutLineToClipboardAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CutLineToClipboardAction()
Public Sub New
See Also

Reference

CutLineToClipboardAction Class


CutLineToClipboardAction Properties

CutLineToClipboardAction Properties

The CutLineToClipboardAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

CutLineToClipboardAction Class


CutLineToClipboardAction Methods

CutLineToClipboardAction Methods

The CutLineToClipboardAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

CutLineToClipboardAction Class


CutLineToClipboardAction.CanExecute Method

CutLineToClipboardActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

CutLineToClipboardAction Class


CutLineToClipboardAction.Execute Method

CutLineToClipboardActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

CutLineToClipboardAction Class


CutToClipboardAction Class

CutToClipboardAction Class
Represents an IEditAction that cuts the currently selected text to the clipboard.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCutToClipboardAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCutAndAppendToClipboardAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CutToClipboardAction : EditActionBase
Public Class CutToClipboardAction
    Inherits EditActionBase

The CutToClipboardAction type exposes the following members.

Constructors
 | Name | Description
Public method | CutToClipboardAction | Initializes a new instance of the CutToClipboardAction class
Top
Properties
 | Name | Description
Protected property | Append | Gets whether to append the copied text to the existing clipboard contents instead of overwriting them.
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


CutToClipboardAction Constructor

CutToClipboardAction Constructor
Initializes a new instance of the CutToClipboardAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CutToClipboardAction()
Public Sub New
See Also

Reference

CutToClipboardAction Class


CutToClipboardAction Properties

CutToClipboardAction Properties

The CutToClipboardAction type exposes the following members.

Properties
 | Name | Description
Protected property | Append | Gets whether to append the copied text to the existing clipboard contents instead of overwriting them.
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

CutToClipboardAction Class


CutToClipboardAction.Append Property

CutToClipboardActionAppend Property
Gets whether to append the copied text to the existing clipboard contents instead of overwriting them.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool Append { get; }
Protected Overridable ReadOnly Property Append As Boolean
    Get

Property Value

Type: Boolean
true if the copied text should be appended; otherwise, false.
See Also

Reference

CutToClipboardAction Class


CutToClipboardAction Methods

CutToClipboardAction Methods

The CutToClipboardAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

CutToClipboardAction Class


CutToClipboardAction.CanExecute Method

CutToClipboardActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

CutToClipboardAction Class


CutToClipboardAction.Execute Method

CutToClipboardActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

CutToClipboardAction Class


DeleteAction Class

DeleteAction Class
Represents an IEditAction that deletes the currently selected text if text is selected; otherwise, deletes the next character.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsDeleteAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DeleteAction : EditActionBase
Public Class DeleteAction
    Inherits EditActionBase

The DeleteAction type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteAction | Initializes a new instance of the DeleteAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


DeleteAction Constructor

DeleteAction Constructor
Initializes a new instance of the DeleteAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DeleteAction()
Public Sub New
See Also

Reference

DeleteAction Class


DeleteAction Properties

DeleteAction Properties

The DeleteAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

DeleteAction Class


DeleteAction Methods

DeleteAction Methods

The DeleteAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

DeleteAction Class


DeleteAction.CanExecute Method

DeleteActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

DeleteAction Class


DeleteAction.Execute Method

DeleteActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

DeleteAction Class


DeleteBlankLinesAction Class

DeleteBlankLinesAction Class
Represents an IEditAction that deletes the blank lines in the selected text, or the current view line if no text is selected and it is blank.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsDeleteBlankLinesAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DeleteBlankLinesAction : EditActionBase
Public Class DeleteBlankLinesAction
    Inherits EditActionBase

The DeleteBlankLinesAction type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteBlankLinesAction | Initializes a new instance of the DeleteBlankLinesAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
Remarks
If there is no selection and the current line is not blank, any blank view lines immediately before the current view line will be deleted.
See Also

Reference


DeleteBlankLinesAction Constructor

DeleteBlankLinesAction Constructor
Initializes a new instance of the DeleteBlankLinesAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DeleteBlankLinesAction()
Public Sub New
See Also

Reference

DeleteBlankLinesAction Class


DeleteBlankLinesAction Properties

DeleteBlankLinesAction Properties

The DeleteBlankLinesAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

DeleteBlankLinesAction Class


DeleteBlankLinesAction Methods

DeleteBlankLinesAction Methods

The DeleteBlankLinesAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

DeleteBlankLinesAction Class


DeleteBlankLinesAction.CanExecute Method

DeleteBlankLinesActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

DeleteBlankLinesAction Class


DeleteBlankLinesAction.Execute Method

DeleteBlankLinesActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

DeleteBlankLinesAction Class


DeleteHorizontalWhitespaceAction Class

DeleteHorizontalWhitespaceAction Class
Represents an IEditAction that deletes the horizontal whitespace within the current selection.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsDeleteHorizontalWhitespaceAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DeleteHorizontalWhitespaceAction : EditActionBase
Public Class DeleteHorizontalWhitespaceAction
    Inherits EditActionBase

The DeleteHorizontalWhitespaceAction type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteHorizontalWhitespaceAction | Initializes a new instance of the DeleteHorizontalWhitespaceAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
Remarks
If there is no selection and the current line is not blank, any blank view lines immediately before the current view line will be deleted.
See Also

Reference


DeleteHorizontalWhitespaceAction Constructor

DeleteHorizontalWhitespaceAction Constructor
Initializes a new instance of the DeleteHorizontalWhitespaceAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DeleteHorizontalWhitespaceAction()
Public Sub New
See Also

Reference

DeleteHorizontalWhitespaceAction Class


DeleteHorizontalWhitespaceAction Properties

DeleteHorizontalWhitespaceAction Properties

The DeleteHorizontalWhitespaceAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

DeleteHorizontalWhitespaceAction Class


DeleteHorizontalWhitespaceAction Methods

DeleteHorizontalWhitespaceAction Methods

The DeleteHorizontalWhitespaceAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

DeleteHorizontalWhitespaceAction Class


DeleteHorizontalWhitespaceAction.CanExecute Method

DeleteHorizontalWhitespaceActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

DeleteHorizontalWhitespaceAction Class


DeleteHorizontalWhitespaceAction.Execute Method

DeleteHorizontalWhitespaceActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

DeleteHorizontalWhitespaceAction Class


DeleteLineAction Class

DeleteLineAction Class
Represents an IEditAction that deletes the currently active view line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsDeleteLineAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DeleteLineAction : EditActionBase
Public Class DeleteLineAction
    Inherits EditActionBase

The DeleteLineAction type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteLineAction | Initializes a new instance of the DeleteLineAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


DeleteLineAction Constructor

DeleteLineAction Constructor
Initializes a new instance of the DeleteLineAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DeleteLineAction()
Public Sub New
See Also

Reference

DeleteLineAction Class


DeleteLineAction Properties

DeleteLineAction Properties

The DeleteLineAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

DeleteLineAction Class


DeleteLineAction Methods

DeleteLineAction Methods

The DeleteLineAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

DeleteLineAction Class


DeleteLineAction.CanExecute Method

DeleteLineActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

DeleteLineAction Class


DeleteLineAction.Execute Method

DeleteLineActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

DeleteLineAction Class


DeleteToLineEndAction Class

DeleteToLineEndAction Class
Represents an IEditAction that deletes the currently selected text through to the end of the current view line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsDeleteToLineEndAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DeleteToLineEndAction : EditActionBase
Public Class DeleteToLineEndAction
    Inherits EditActionBase

The DeleteToLineEndAction type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteToLineEndAction | Initializes a new instance of the DeleteToLineEndAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


DeleteToLineEndAction Constructor

DeleteToLineEndAction Constructor
Initializes a new instance of the DeleteToLineEndAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DeleteToLineEndAction()
Public Sub New
See Also

Reference

DeleteToLineEndAction Class


DeleteToLineEndAction Properties

DeleteToLineEndAction Properties

The DeleteToLineEndAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

DeleteToLineEndAction Class


DeleteToLineEndAction Methods

DeleteToLineEndAction Methods

The DeleteToLineEndAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

DeleteToLineEndAction Class


DeleteToLineEndAction.CanExecute Method

DeleteToLineEndActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

DeleteToLineEndAction Class


DeleteToLineEndAction.Execute Method

DeleteToLineEndActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

DeleteToLineEndAction Class


DeleteToLineStartAction Class

DeleteToLineStartAction Class
Represents an IEditAction that deletes the currently selected text through to the start of the current view line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsDeleteToLineStartAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DeleteToLineStartAction : EditActionBase
Public Class DeleteToLineStartAction
    Inherits EditActionBase

The DeleteToLineStartAction type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteToLineStartAction | Initializes a new instance of the DeleteToLineStartAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


DeleteToLineStartAction Constructor

DeleteToLineStartAction Constructor
Initializes a new instance of the DeleteToLineStartAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DeleteToLineStartAction()
Public Sub New
See Also

Reference

DeleteToLineStartAction Class


DeleteToLineStartAction Properties

DeleteToLineStartAction Properties

The DeleteToLineStartAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

DeleteToLineStartAction Class


DeleteToLineStartAction Methods

DeleteToLineStartAction Methods

The DeleteToLineStartAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

DeleteToLineStartAction Class


DeleteToLineStartAction.CanExecute Method

DeleteToLineStartActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

DeleteToLineStartAction Class


DeleteToLineStartAction.Execute Method

DeleteToLineStartActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

DeleteToLineStartAction Class


DeleteToNextWordAction Class

DeleteToNextWordAction Class
Represents an IEditAction that deletes text to the beginning of the next word.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsDeleteToNextWordAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DeleteToNextWordAction : EditActionBase
Public Class DeleteToNextWordAction
    Inherits EditActionBase

The DeleteToNextWordAction type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteToNextWordAction | Initializes a new instance of the DeleteToNextWordAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


DeleteToNextWordAction Constructor

DeleteToNextWordAction Constructor
Initializes a new instance of the DeleteToNextWordAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DeleteToNextWordAction()
Public Sub New
See Also

Reference

DeleteToNextWordAction Class


DeleteToNextWordAction Properties

DeleteToNextWordAction Properties

The DeleteToNextWordAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

DeleteToNextWordAction Class


DeleteToNextWordAction Methods

DeleteToNextWordAction Methods

The DeleteToNextWordAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

DeleteToNextWordAction Class


DeleteToNextWordAction.CanExecute Method

DeleteToNextWordActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

DeleteToNextWordAction Class


DeleteToNextWordAction.Execute Method

DeleteToNextWordActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

DeleteToNextWordAction Class


DuplicateLineAction Class

DuplicateLineAction Class
Represents an IEditAction that duplicates the current document line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsDuplicateLineAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DuplicateLineAction : EditActionBase
Public Class DuplicateLineAction
    Inherits EditActionBase

The DuplicateLineAction type exposes the following members.

Constructors
 | Name | Description
Public method | DuplicateLineAction | Initializes a new instance of the DuplicateLineAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


DuplicateLineAction Constructor

DuplicateLineAction Constructor
Initializes a new instance of the DuplicateLineAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DuplicateLineAction()
Public Sub New
See Also

Reference

DuplicateLineAction Class


DuplicateLineAction Properties

DuplicateLineAction Properties

The DuplicateLineAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

DuplicateLineAction Class


DuplicateLineAction Methods

DuplicateLineAction Methods

The DuplicateLineAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

DuplicateLineAction Class


DuplicateLineAction.CanExecute Method

DuplicateLineActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

DuplicateLineAction Class


DuplicateLineAction.Execute Method

DuplicateLineActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

DuplicateLineAction Class


FormatDocumentAction Class

FormatDocumentAction Class
Represents an IEditAction that formats the document.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsFormatDocumentAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FormatDocumentAction : EditActionBase
Public Class FormatDocumentAction
    Inherits EditActionBase

The FormatDocumentAction type exposes the following members.

Constructors
 | Name | Description
Public method | FormatDocumentAction | Initializes a new instance of the FormatDocumentAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


FormatDocumentAction Constructor

FormatDocumentAction Constructor
Initializes a new instance of the FormatDocumentAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FormatDocumentAction()
Public Sub New
See Also

Reference

FormatDocumentAction Class


FormatDocumentAction Properties

FormatDocumentAction Properties

The FormatDocumentAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

FormatDocumentAction Class


FormatDocumentAction Methods

FormatDocumentAction Methods

The FormatDocumentAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

FormatDocumentAction Class


FormatDocumentAction.CanExecute Method

FormatDocumentActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

FormatDocumentAction Class


FormatDocumentAction.Execute Method

FormatDocumentActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

FormatDocumentAction Class


FormatSelectionAction Class

FormatSelectionAction Class
Represents an IEditAction that formats the currently selected lines.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsFormatSelectionAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FormatSelectionAction : EditActionBase
Public Class FormatSelectionAction
    Inherits EditActionBase

The FormatSelectionAction type exposes the following members.

Constructors
 | Name | Description
Public method | FormatSelectionAction | Initializes a new instance of the FormatSelectionAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


FormatSelectionAction Constructor

FormatSelectionAction Constructor
Initializes a new instance of the FormatSelectionAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FormatSelectionAction()
Public Sub New
See Also

Reference

FormatSelectionAction Class


FormatSelectionAction Properties

FormatSelectionAction Properties

The FormatSelectionAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

FormatSelectionAction Class


FormatSelectionAction Methods

FormatSelectionAction Methods

The FormatSelectionAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

FormatSelectionAction Class


FormatSelectionAction.CanExecute Method

FormatSelectionActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

FormatSelectionAction Class


FormatSelectionAction.Execute Method

FormatSelectionActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

FormatSelectionAction Class


HideSelectionAction Class

HideSelectionAction Class
Represents an IEditAction that collapses the current selection.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsHideSelectionAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class HideSelectionAction : EditActionBase
Public Class HideSelectionAction
    Inherits EditActionBase

The HideSelectionAction type exposes the following members.

Constructors
 | Name | Description
Public method | HideSelectionAction | Initializes a new instance of the HideSelectionAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


HideSelectionAction Constructor

HideSelectionAction Constructor
Initializes a new instance of the HideSelectionAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public HideSelectionAction()
Public Sub New
See Also

Reference

HideSelectionAction Class


HideSelectionAction Properties

HideSelectionAction Properties

The HideSelectionAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

HideSelectionAction Class


HideSelectionAction Methods

HideSelectionAction Methods

The HideSelectionAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

HideSelectionAction Class


HideSelectionAction.CanExecute Method

HideSelectionActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

HideSelectionAction Class


HideSelectionAction.Execute Method

HideSelectionActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

HideSelectionAction Class


IncrementalSearchAction Class

IncrementalSearchAction Class
Represents an IEditAction that performs a forward incremental search.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsIncrementalSearchAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class IncrementalSearchAction : EditActionBase
Public Class IncrementalSearchAction
    Inherits EditActionBase

The IncrementalSearchAction type exposes the following members.

Constructors
 | Name | Description
Public method | IncrementalSearchAction | Initializes a new instance of the IncrementalSearchAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


IncrementalSearchAction Constructor

IncrementalSearchAction Constructor
Initializes a new instance of the IncrementalSearchAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IncrementalSearchAction()
Public Sub New
See Also

Reference

IncrementalSearchAction Class


IncrementalSearchAction Properties

IncrementalSearchAction Properties

The IncrementalSearchAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

IncrementalSearchAction Class


IncrementalSearchAction Methods

IncrementalSearchAction Methods

The IncrementalSearchAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

IncrementalSearchAction Class


IncrementalSearchAction.Execute Method

IncrementalSearchActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

IncrementalSearchAction Class


IndentAction Class

IndentAction Class
Represents an IEditAction that indents the currently selected lines.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsIndentAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsInsertTabStopOrIndentAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class IndentAction : EditActionBase
Public Class IndentAction
    Inherits EditActionBase

The IndentAction type exposes the following members.

Constructors
 | Name | Description
Public method | IndentAction | Initializes a new instance of the IndentAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


IndentAction Constructor

IndentAction Constructor
Initializes a new instance of the IndentAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IndentAction()
Public Sub New
See Also

Reference

IndentAction Class


IndentAction Properties

IndentAction Properties

The IndentAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

IndentAction Class


IndentAction Methods

IndentAction Methods

The IndentAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

IndentAction Class


IndentAction.CanExecute Method

IndentActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

IndentAction Class


IndentAction.Execute Method

IndentActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

IndentAction Class


InsertLineBreakAction Class

InsertLineBreakAction Class
Represents an IEditAction that inserts a line break at the current position.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsInsertLineBreakAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class InsertLineBreakAction : EditActionBase
Public Class InsertLineBreakAction
    Inherits EditActionBase

The InsertLineBreakAction type exposes the following members.

Constructors
 | Name | Description
Public method | InsertLineBreakAction | Initializes a new instance of the InsertLineBreakAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


InsertLineBreakAction Constructor

InsertLineBreakAction Constructor
Initializes a new instance of the InsertLineBreakAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InsertLineBreakAction()
Public Sub New
See Also

Reference

InsertLineBreakAction Class


InsertLineBreakAction Properties

InsertLineBreakAction Properties

The InsertLineBreakAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

InsertLineBreakAction Class


InsertLineBreakAction Methods

InsertLineBreakAction Methods

The InsertLineBreakAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

InsertLineBreakAction Class


InsertLineBreakAction.CanExecute Method

InsertLineBreakActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

InsertLineBreakAction Class


InsertLineBreakAction.Execute Method

InsertLineBreakActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

InsertLineBreakAction Class


InsertTabStopOrIndentAction Class

InsertTabStopOrIndentAction Class
Represents an IEditAction that inserts whitespace to bring the caret to the next tab stop if there is no selection, or alternatively indents the currently selected lines.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsIndentAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsInsertTabStopOrIndentAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class InsertTabStopOrIndentAction : IndentAction
Public Class InsertTabStopOrIndentAction
    Inherits IndentAction

The InsertTabStopOrIndentAction type exposes the following members.

Constructors
 | Name | Description
Public method | InsertTabStopOrIndentAction | Initializes a new instance of the InsertTabStopOrIndentAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from IndentAction.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides IndentActionExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


InsertTabStopOrIndentAction Constructor

InsertTabStopOrIndentAction Constructor
Initializes a new instance of the InsertTabStopOrIndentAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InsertTabStopOrIndentAction()
Public Sub New
See Also

Reference

InsertTabStopOrIndentAction Class


InsertTabStopOrIndentAction Properties

InsertTabStopOrIndentAction Properties

The InsertTabStopOrIndentAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

InsertTabStopOrIndentAction Class


InsertTabStopOrIndentAction Methods

InsertTabStopOrIndentAction Methods

The InsertTabStopOrIndentAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from IndentAction.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides IndentActionExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

InsertTabStopOrIndentAction Class


InsertTabStopOrIndentAction.Execute Method

InsertTabStopOrIndentActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

InsertTabStopOrIndentAction Class


MacroAction Class

MacroAction Class
Represents an IEditAction that contains a list of IEditAction objects that can be executed in a macro.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMacroAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MacroAction : EditActionBase,
    IEnumerable<IEditAction>, IEnumerable
Public Class MacroAction
    Inherits EditActionBase
    Implements IEnumerable(Of IEditAction), IEnumerable

The MacroAction type exposes the following members.

Constructors
 | Name | Description
Public method | MacroAction | Initializes a new instance of the MacroAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Overrides EditActionBaseCanRecordInMacro.)
Public property | Count | Gets the number of actions in the macro.
Public property | Item | Gets the IEditAction at the specified index. [C#] In C#, this property is the indexer for the MacroAction class.
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds an IEditAction to the end of the macro.
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Overrides EditActionBaseReadFromXml(XmlReader).)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Overrides EditActionBaseWriteToXml(XmlWriter).)
Top
See Also

Reference


MacroAction Constructor

MacroAction Constructor
Initializes a new instance of the MacroAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MacroAction()
Public Sub New
See Also

Reference

MacroAction Class


MacroAction Properties

MacroAction Properties

The MacroAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Overrides EditActionBaseCanRecordInMacro.)
Public property | Count | Gets the number of actions in the macro.
Public property | Item | Gets the IEditAction at the specified index. [C#] In C#, this property is the indexer for the MacroAction class.
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MacroAction Class


MacroAction.CanRecordInMacro Property

MacroActionCanRecordInMacro Property
Gets whether the action can be recorded in a macro.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanRecordInMacro { get; }
Public Overrides ReadOnly Property CanRecordInMacro As Boolean
    Get

Property Value

Type: Boolean
true if the action can be recorded in a macro; otherwise, false.

Implements

IEditActionCanRecordInMacro
See Also

Reference

MacroAction Class


MacroAction.Count Property

MacroActionCount Property
Gets the number of actions in the macro.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of actions in the macro.
See Also

Reference

MacroAction Class


MacroAction.Item Property

MacroActionItem Property
Gets the IEditAction at the specified index.

[C#] In C#, this property is the indexer for the MacroAction class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEditAction this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As IEditAction
    Get

Parameters

index
Type: SystemInt32
The index of the IEditAction to return.

Property Value

Type: IEditAction
The IEditAction at the specified index.
See Also

Reference

MacroAction Class


MacroAction Methods

MacroAction Methods

The MacroAction type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an IEditAction to the end of the macro.
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Overrides EditActionBaseReadFromXml(XmlReader).)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Overrides EditActionBaseWriteToXml(XmlWriter).)
Top
See Also

Reference

MacroAction Class


MacroAction.Add Method

MacroActionAdd Method
Adds an IEditAction to the end of the macro.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Add(
    IEditAction action
)
Public Sub Add (
    action As IEditAction
)

Parameters

action
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditAction
The IEditAction to add.
See Also

Reference

MacroAction Class


MacroAction.Execute Method

MacroActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

MacroAction Class


MacroAction.GetEnumerator Method

MacroActionGetEnumerator Method
Retrieves an IEnumerator object for the entire collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerator<IEditAction> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of IEditAction)

Return Value

Type: IEnumerator IEditAction
An IEnumerator object for the entire collection

Implements

IEnumerableTGetEnumerator
Remarks
Enumerators are intended to be used only to read data in the collection. Enumerators cannot be used to modify the underlying collection.

The enumerator does not have exclusive access to the collection.

When an enumerator is instantiated, it takes a snapshot of the current state of the collection. If changes are made to the collection, such as adding, modifying or deleting elements, the snapshot gets out of sync and the enumerator throws an InvalidOperationException. Two enumerators instantiated from the same collection at the same time can have different snapshots of the collection.

See Also

Reference

MacroAction Class


MacroAction.ReadFromXml Method

MacroActionReadFromXml Method
Deserializes the data for the IEditAction from XML.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void ReadFromXml(
    XmlReader reader
)
Public Overrides Sub ReadFromXml (
    reader As XmlReader
)

Parameters

reader
Type: System.XmlXmlReader
The XmlReader to use.

Implements

IEditActionReadFromXml(XmlReader)
Remarks
This method is used for macro serialization.
See Also

Reference

MacroAction Class


MacroAction.WriteToXml Method

MacroActionWriteToXml Method
Serializes the data for the IEditAction to XML.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void WriteToXml(
    XmlWriter writer
)
Public Overrides Sub WriteToXml (
    writer As XmlWriter
)

Parameters

writer
Type: System.XmlXmlWriter
The XmlWriter to use.

Implements

IEditActionWriteToXml(XmlWriter)
Remarks
This method is used for macro serialization.
See Also

Reference

MacroAction Class


MakeLowercaseAction Class

MakeLowercaseAction Class
Represents an IEditAction that changes the character casing of the selected text to lowercase.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsChangeCharacterCasingAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMakeLowercaseAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MakeLowercaseAction : ChangeCharacterCasingAction
Public Class MakeLowercaseAction
    Inherits ChangeCharacterCasingAction

The MakeLowercaseAction type exposes the following members.

Constructors
 | Name | Description
Public method | MakeLowercaseAction | Initializes a new instance of the MakeLowercaseAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Protected property | Casing | Gets the CharacterCasing to apply. (Overrides ChangeCharacterCasingActionCasing.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from ChangeCharacterCasingAction.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Inherited from ChangeCharacterCasingAction.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
Remarks
If no text is currently selected, only the character after the caret is changed.
See Also

Reference


MakeLowercaseAction Constructor

MakeLowercaseAction Constructor
Initializes a new instance of the MakeLowercaseAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MakeLowercaseAction()
Public Sub New
See Also

Reference

MakeLowercaseAction Class


MakeLowercaseAction Properties

MakeLowercaseAction Properties

The MakeLowercaseAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Protected property | Casing | Gets the CharacterCasing to apply. (Overrides ChangeCharacterCasingActionCasing.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MakeLowercaseAction Class


MakeLowercaseAction.Casing Property

MakeLowercaseActionCasing Property
Gets the CharacterCasing to apply.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override CharacterCasing Casing { get; }
Protected Overrides ReadOnly Property Casing As CharacterCasing
    Get

Property Value

Type: CharacterCasing
The CharacterCasing to apply.
See Also

Reference

MakeLowercaseAction Class


MakeLowercaseAction Methods

MakeLowercaseAction Methods

The MakeLowercaseAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from ChangeCharacterCasingAction.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Inherited from ChangeCharacterCasingAction.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MakeLowercaseAction Class


MakeUppercaseAction Class

MakeUppercaseAction Class
Represents an IEditAction that changes the character casing of the selected text to uppercase.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsChangeCharacterCasingAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMakeUppercaseAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MakeUppercaseAction : ChangeCharacterCasingAction
Public Class MakeUppercaseAction
    Inherits ChangeCharacterCasingAction

The MakeUppercaseAction type exposes the following members.

Constructors
 | Name | Description
Public method | MakeUppercaseAction | Initializes a new instance of the MakeUppercaseAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Protected property | Casing | Gets the CharacterCasing to apply. (Overrides ChangeCharacterCasingActionCasing.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from ChangeCharacterCasingAction.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Inherited from ChangeCharacterCasingAction.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
Remarks
If no text is currently selected, only the character after the caret is changed.
See Also

Reference


MakeUppercaseAction Constructor

MakeUppercaseAction Constructor
Initializes a new instance of the MakeUppercaseAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MakeUppercaseAction()
Public Sub New
See Also

Reference

MakeUppercaseAction Class


MakeUppercaseAction Properties

MakeUppercaseAction Properties

The MakeUppercaseAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Protected property | Casing | Gets the CharacterCasing to apply. (Overrides ChangeCharacterCasingActionCasing.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MakeUppercaseAction Class


MakeUppercaseAction.Casing Property

MakeUppercaseActionCasing Property
Gets the CharacterCasing to apply.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override CharacterCasing Casing { get; }
Protected Overrides ReadOnly Property Casing As CharacterCasing
    Get

Property Value

Type: CharacterCasing
The CharacterCasing to apply.
See Also

Reference

MakeUppercaseAction Class


MakeUppercaseAction Methods

MakeUppercaseAction Methods

The MakeUppercaseAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from ChangeCharacterCasingAction.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Inherited from ChangeCharacterCasingAction.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MakeUppercaseAction Class


MoveDownAction Class

MoveDownAction Class
Represents an IEditAction that moves the caret down a line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveDownAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MoveDownAction : EditActionBase
Public Class MoveDownAction
    Inherits EditActionBase

The MoveDownAction type exposes the following members.

Constructors
 | Name | Description
Public method | MoveDownAction | Initializes a new instance of the MoveDownAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


MoveDownAction Constructor

MoveDownAction Constructor
Initializes a new instance of the MoveDownAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MoveDownAction()
Public Sub New
See Also

Reference

MoveDownAction Class


MoveDownAction Properties

MoveDownAction Properties

The MoveDownAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveDownAction Class


MoveDownAction Methods

MoveDownAction Methods

The MoveDownAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveDownAction Class


MoveDownAction.Execute Method

MoveDownActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

MoveDownAction Class


MoveLeftAction Class

MoveLeftAction Class
Represents an IEditAction that moves the caret left a character.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveLeftAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MoveLeftAction : EditActionBase
Public Class MoveLeftAction
    Inherits EditActionBase

The MoveLeftAction type exposes the following members.

Constructors
 | Name | Description
Public method | MoveLeftAction | Initializes a new instance of the MoveLeftAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


MoveLeftAction Constructor

MoveLeftAction Constructor
Initializes a new instance of the MoveLeftAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MoveLeftAction()
Public Sub New
See Also

Reference

MoveLeftAction Class


MoveLeftAction Properties

MoveLeftAction Properties

The MoveLeftAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveLeftAction Class


MoveLeftAction Methods

MoveLeftAction Methods

The MoveLeftAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveLeftAction Class


MoveLeftAction.Execute Method

MoveLeftActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

MoveLeftAction Class


MovePageDownAction Class

MovePageDownAction Class
Represents an IEditAction that moves the caret down a page.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMovePageDownAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MovePageDownAction : EditActionBase
Public Class MovePageDownAction
    Inherits EditActionBase

The MovePageDownAction type exposes the following members.

Constructors
 | Name | Description
Public method | MovePageDownAction | Initializes a new instance of the MovePageDownAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


MovePageDownAction Constructor

MovePageDownAction Constructor
Initializes a new instance of the MovePageDownAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MovePageDownAction()
Public Sub New
See Also

Reference

MovePageDownAction Class


MovePageDownAction Properties

MovePageDownAction Properties

The MovePageDownAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MovePageDownAction Class


MovePageDownAction Methods

MovePageDownAction Methods

The MovePageDownAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MovePageDownAction Class


MovePageDownAction.Execute Method

MovePageDownActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

MovePageDownAction Class


MovePageUpAction Class

MovePageUpAction Class
Represents an IEditAction that moves the caret up a page.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMovePageUpAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MovePageUpAction : EditActionBase
Public Class MovePageUpAction
    Inherits EditActionBase

The MovePageUpAction type exposes the following members.

Constructors
 | Name | Description
Public method | MovePageUpAction | Initializes a new instance of the MovePageUpAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


MovePageUpAction Constructor

MovePageUpAction Constructor
Initializes a new instance of the MovePageUpAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MovePageUpAction()
Public Sub New
See Also

Reference

MovePageUpAction Class


MovePageUpAction Properties

MovePageUpAction Properties

The MovePageUpAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MovePageUpAction Class


MovePageUpAction Methods

MovePageUpAction Methods

The MovePageUpAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MovePageUpAction Class


MovePageUpAction.Execute Method

MovePageUpActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

MovePageUpAction Class


MoveRightAction Class

MoveRightAction Class
Represents an IEditAction that moves the caret right a character.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveRightAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MoveRightAction : EditActionBase
Public Class MoveRightAction
    Inherits EditActionBase

The MoveRightAction type exposes the following members.

Constructors
 | Name | Description
Public method | MoveRightAction | Initializes a new instance of the MoveRightAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


MoveRightAction Constructor

MoveRightAction Constructor
Initializes a new instance of the MoveRightAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MoveRightAction()
Public Sub New
See Also

Reference

MoveRightAction Class


MoveRightAction Properties

MoveRightAction Properties

The MoveRightAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveRightAction Class


MoveRightAction Methods

MoveRightAction Methods

The MoveRightAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveRightAction Class


MoveRightAction.Execute Method

MoveRightActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

MoveRightAction Class


MoveSelectedLinesDownAction Class

MoveSelectedLinesDownAction Class
Represents an IEditAction that moves the selected lines down.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveSelectedLinesDownAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MoveSelectedLinesDownAction : EditActionBase
Public Class MoveSelectedLinesDownAction
    Inherits EditActionBase

The MoveSelectedLinesDownAction type exposes the following members.

Constructors
 | Name | Description
Public method | MoveSelectedLinesDownAction | Initializes a new instance of the MoveSelectedLinesDownAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


MoveSelectedLinesDownAction Constructor

MoveSelectedLinesDownAction Constructor
Initializes a new instance of the MoveSelectedLinesDownAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MoveSelectedLinesDownAction()
Public Sub New
See Also

Reference

MoveSelectedLinesDownAction Class


MoveSelectedLinesDownAction Properties

MoveSelectedLinesDownAction Properties

The MoveSelectedLinesDownAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveSelectedLinesDownAction Class


MoveSelectedLinesDownAction Methods

MoveSelectedLinesDownAction Methods

The MoveSelectedLinesDownAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveSelectedLinesDownAction Class


MoveSelectedLinesDownAction.CanExecute Method

MoveSelectedLinesDownActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

MoveSelectedLinesDownAction Class


MoveSelectedLinesDownAction.Execute Method

MoveSelectedLinesDownActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

MoveSelectedLinesDownAction Class


MoveSelectedLinesUpAction Class

MoveSelectedLinesUpAction Class
Represents an IEditAction that moves the selected lines up.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveSelectedLinesUpAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MoveSelectedLinesUpAction : EditActionBase
Public Class MoveSelectedLinesUpAction
    Inherits EditActionBase

The MoveSelectedLinesUpAction type exposes the following members.

Constructors
 | Name | Description
Public method | MoveSelectedLinesUpAction | Initializes a new instance of the MoveSelectedLinesUpAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


MoveSelectedLinesUpAction Constructor

MoveSelectedLinesUpAction Constructor
Initializes a new instance of the MoveSelectedLinesUpAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MoveSelectedLinesUpAction()
Public Sub New
See Also

Reference

MoveSelectedLinesUpAction Class


MoveSelectedLinesUpAction Properties

MoveSelectedLinesUpAction Properties

The MoveSelectedLinesUpAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveSelectedLinesUpAction Class


MoveSelectedLinesUpAction Methods

MoveSelectedLinesUpAction Methods

The MoveSelectedLinesUpAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveSelectedLinesUpAction Class


MoveSelectedLinesUpAction.CanExecute Method

MoveSelectedLinesUpActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

MoveSelectedLinesUpAction Class


MoveSelectedLinesUpAction.Execute Method

MoveSelectedLinesUpActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

MoveSelectedLinesUpAction Class


MoveToDocumentEndAction Class

MoveToDocumentEndAction Class
Represents an IEditAction that moves the caret to the end of the document.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToDocumentEndAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MoveToDocumentEndAction : EditActionBase
Public Class MoveToDocumentEndAction
    Inherits EditActionBase

The MoveToDocumentEndAction type exposes the following members.

Constructors
 | Name | Description
Public method | MoveToDocumentEndAction | Initializes a new instance of the MoveToDocumentEndAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


MoveToDocumentEndAction Constructor

MoveToDocumentEndAction Constructor
Initializes a new instance of the MoveToDocumentEndAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MoveToDocumentEndAction()
Public Sub New
See Also

Reference

MoveToDocumentEndAction Class


MoveToDocumentEndAction Properties

MoveToDocumentEndAction Properties

The MoveToDocumentEndAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToDocumentEndAction Class


MoveToDocumentEndAction Methods

MoveToDocumentEndAction Methods

The MoveToDocumentEndAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToDocumentEndAction Class


MoveToDocumentEndAction.Execute Method

MoveToDocumentEndActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

MoveToDocumentEndAction Class


MoveToDocumentStartAction Class

MoveToDocumentStartAction Class
Represents an IEditAction that moves the caret to the start of the document.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToDocumentStartAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MoveToDocumentStartAction : EditActionBase
Public Class MoveToDocumentStartAction
    Inherits EditActionBase

The MoveToDocumentStartAction type exposes the following members.

Constructors
 | Name | Description
Public method | MoveToDocumentStartAction | Initializes a new instance of the MoveToDocumentStartAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


MoveToDocumentStartAction Constructor

MoveToDocumentStartAction Constructor
Initializes a new instance of the MoveToDocumentStartAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MoveToDocumentStartAction()
Public Sub New
See Also

Reference

MoveToDocumentStartAction Class


MoveToDocumentStartAction Properties

MoveToDocumentStartAction Properties

The MoveToDocumentStartAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToDocumentStartAction Class


MoveToDocumentStartAction Methods

MoveToDocumentStartAction Methods

The MoveToDocumentStartAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToDocumentStartAction Class


MoveToDocumentStartAction.Execute Method

MoveToDocumentStartActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

MoveToDocumentStartAction Class


MoveToLineEndAction Class

MoveToLineEndAction Class
Represents an IEditAction that moves the caret to the end of the line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToLineEndAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MoveToLineEndAction : EditActionBase
Public Class MoveToLineEndAction
    Inherits EditActionBase

The MoveToLineEndAction type exposes the following members.

Constructors
 | Name | Description
Public method | MoveToLineEndAction | Initializes a new instance of the MoveToLineEndAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


MoveToLineEndAction Constructor

MoveToLineEndAction Constructor
Initializes a new instance of the MoveToLineEndAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MoveToLineEndAction()
Public Sub New
See Also

Reference

MoveToLineEndAction Class


MoveToLineEndAction Properties

MoveToLineEndAction Properties

The MoveToLineEndAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToLineEndAction Class


MoveToLineEndAction Methods

MoveToLineEndAction Methods

The MoveToLineEndAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToLineEndAction Class


MoveToLineEndAction.Execute Method

MoveToLineEndActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

MoveToLineEndAction Class


MoveToLineStartAction Class

MoveToLineStartAction Class
Represents an IEditAction that moves the caret to the start of the line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToLineStartAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MoveToLineStartAction : EditActionBase
Public Class MoveToLineStartAction
    Inherits EditActionBase

The MoveToLineStartAction type exposes the following members.

Constructors
 | Name | Description
Public method | MoveToLineStartAction | Initializes a new instance of the MoveToLineStartAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


MoveToLineStartAction Constructor

MoveToLineStartAction Constructor
Initializes a new instance of the MoveToLineStartAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MoveToLineStartAction()
Public Sub New
See Also

Reference

MoveToLineStartAction Class


MoveToLineStartAction Properties

MoveToLineStartAction Properties

The MoveToLineStartAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToLineStartAction Class


MoveToLineStartAction Methods

MoveToLineStartAction Methods

The MoveToLineStartAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToLineStartAction Class


MoveToLineStartAction.Execute Method

MoveToLineStartActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

MoveToLineStartAction Class


MoveToLineStartAfterIndentationAction Class

MoveToLineStartAfterIndentationAction Class
Represents an IEditAction that moves the caret to the first non-whitespace character on the current view line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToLineStartAfterIndentationAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MoveToLineStartAfterIndentationAction : EditActionBase
Public Class MoveToLineStartAfterIndentationAction
    Inherits EditActionBase

The MoveToLineStartAfterIndentationAction type exposes the following members.

Constructors
 | Name | Description
Public method | MoveToLineStartAfterIndentationAction | Initializes a new instance of the MoveToLineStartAfterIndentationAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


MoveToLineStartAfterIndentationAction Constructor

MoveToLineStartAfterIndentationAction Constructor
Initializes a new instance of the MoveToLineStartAfterIndentationAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MoveToLineStartAfterIndentationAction()
Public Sub New
See Also

Reference

MoveToLineStartAfterIndentationAction Class


MoveToLineStartAfterIndentationAction Properties

MoveToLineStartAfterIndentationAction Properties

The MoveToLineStartAfterIndentationAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToLineStartAfterIndentationAction Class


MoveToLineStartAfterIndentationAction Methods

MoveToLineStartAfterIndentationAction Methods

The MoveToLineStartAfterIndentationAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToLineStartAfterIndentationAction Class


MoveToLineStartAfterIndentationAction.Execute Method

MoveToLineStartAfterIndentationActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

MoveToLineStartAfterIndentationAction Class


MoveToMatchingBracketAction Class

MoveToMatchingBracketAction Class
Represents an IEditAction that moves the caret to the matching bracket, if any.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToMatchingBracketAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MoveToMatchingBracketAction : EditActionBase
Public Class MoveToMatchingBracketAction
    Inherits EditActionBase

The MoveToMatchingBracketAction type exposes the following members.

Constructors
 | Name | Description
Public method | MoveToMatchingBracketAction | Initializes a new instance of the MoveToMatchingBracketAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


MoveToMatchingBracketAction Constructor

MoveToMatchingBracketAction Constructor
Initializes a new instance of the MoveToMatchingBracketAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MoveToMatchingBracketAction()
Public Sub New
See Also

Reference

MoveToMatchingBracketAction Class


MoveToMatchingBracketAction Properties

MoveToMatchingBracketAction Properties

The MoveToMatchingBracketAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToMatchingBracketAction Class


MoveToMatchingBracketAction Methods

MoveToMatchingBracketAction Methods

The MoveToMatchingBracketAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToMatchingBracketAction Class


MoveToMatchingBracketAction.CanExecute Method

MoveToMatchingBracketActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

MoveToMatchingBracketAction Class


MoveToMatchingBracketAction.Execute Method

MoveToMatchingBracketActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

MoveToMatchingBracketAction Class


MoveToNextLineStartAfterIndentationAction Class

MoveToNextLineStartAfterIndentationAction Class
Represents an IEditAction that moves the caret to the first non-whitespace character on the next view line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToNextLineStartAfterIndentationAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MoveToNextLineStartAfterIndentationAction : EditActionBase
Public Class MoveToNextLineStartAfterIndentationAction
    Inherits EditActionBase

The MoveToNextLineStartAfterIndentationAction type exposes the following members.

Constructors
 | Name | Description
Public method | MoveToNextLineStartAfterIndentationAction | Initializes a new instance of the MoveToNextLineStartAfterIndentationAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


MoveToNextLineStartAfterIndentationAction Constructor

MoveToNextLineStartAfterIndentationAction Constructor
Initializes a new instance of the MoveToNextLineStartAfterIndentationAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MoveToNextLineStartAfterIndentationAction()
Public Sub New
See Also

Reference

MoveToNextLineStartAfterIndentationAction Class


MoveToNextLineStartAfterIndentationAction Properties

MoveToNextLineStartAfterIndentationAction Properties

The MoveToNextLineStartAfterIndentationAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToNextLineStartAfterIndentationAction Class


MoveToNextLineStartAfterIndentationAction Methods

MoveToNextLineStartAfterIndentationAction Methods

The MoveToNextLineStartAfterIndentationAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToNextLineStartAfterIndentationAction Class


MoveToNextLineStartAfterIndentationAction.Execute Method

MoveToNextLineStartAfterIndentationActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

MoveToNextLineStartAfterIndentationAction Class


MoveToNextWordAction Class

MoveToNextWordAction Class
Represents an IEditAction that moves the caret to the next word.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToNextWordAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MoveToNextWordAction : EditActionBase
Public Class MoveToNextWordAction
    Inherits EditActionBase

The MoveToNextWordAction type exposes the following members.

Constructors
 | Name | Description
Public method | MoveToNextWordAction | Initializes a new instance of the MoveToNextWordAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


MoveToNextWordAction Constructor

MoveToNextWordAction Constructor
Initializes a new instance of the MoveToNextWordAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MoveToNextWordAction()
Public Sub New
See Also

Reference

MoveToNextWordAction Class


MoveToNextWordAction Properties

MoveToNextWordAction Properties

The MoveToNextWordAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToNextWordAction Class


MoveToNextWordAction Methods

MoveToNextWordAction Methods

The MoveToNextWordAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToNextWordAction Class


MoveToNextWordAction.Execute Method

MoveToNextWordActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

MoveToNextWordAction Class


MoveToPreviousLineStartAfterIndentationAction Class

MoveToPreviousLineStartAfterIndentationAction Class
Represents an IEditAction that moves the caret to the first non-whitespace character on the previous view line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToPreviousLineStartAfterIndentationAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MoveToPreviousLineStartAfterIndentationAction : EditActionBase
Public Class MoveToPreviousLineStartAfterIndentationAction
    Inherits EditActionBase

The MoveToPreviousLineStartAfterIndentationAction type exposes the following members.

Constructors
 | Name | Description
Public method | MoveToPreviousLineStartAfterIndentationAction | Initializes a new instance of the MoveToPreviousLineStartAfterIndentationAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


MoveToPreviousLineStartAfterIndentationAction Constructor

MoveToPreviousLineStartAfterIndentationAction Constructor
Initializes a new instance of the MoveToPreviousLineStartAfterIndentationAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MoveToPreviousLineStartAfterIndentationAction()
Public Sub New
See Also

Reference

MoveToPreviousLineStartAfterIndentationAction Class


MoveToPreviousLineStartAfterIndentationAction Properties

MoveToPreviousLineStartAfterIndentationAction Properties

The MoveToPreviousLineStartAfterIndentationAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToPreviousLineStartAfterIndentationAction Class


MoveToPreviousLineStartAfterIndentationAction Methods

MoveToPreviousLineStartAfterIndentationAction Methods

The MoveToPreviousLineStartAfterIndentationAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToPreviousLineStartAfterIndentationAction Class


MoveToPreviousLineStartAfterIndentationAction.Execute Method

MoveToPreviousLineStartAfterIndentationActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

MoveToPreviousLineStartAfterIndentationAction Class


MoveToPreviousWordAction Class

MoveToPreviousWordAction Class
Represents an IEditAction that moves the caret to the previous word.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToPreviousWordAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MoveToPreviousWordAction : EditActionBase
Public Class MoveToPreviousWordAction
    Inherits EditActionBase

The MoveToPreviousWordAction type exposes the following members.

Constructors
 | Name | Description
Public method | MoveToPreviousWordAction | Initializes a new instance of the MoveToPreviousWordAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


MoveToPreviousWordAction Constructor

MoveToPreviousWordAction Constructor
Initializes a new instance of the MoveToPreviousWordAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MoveToPreviousWordAction()
Public Sub New
See Also

Reference

MoveToPreviousWordAction Class


MoveToPreviousWordAction Properties

MoveToPreviousWordAction Properties

The MoveToPreviousWordAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToPreviousWordAction Class


MoveToPreviousWordAction Methods

MoveToPreviousWordAction Methods

The MoveToPreviousWordAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToPreviousWordAction Class


MoveToPreviousWordAction.Execute Method

MoveToPreviousWordActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

MoveToPreviousWordAction Class


MoveToVisibleBottomAction Class

MoveToVisibleBottomAction Class
Represents an IEditAction that moves the caret to the bottom of the view.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToVisibleBottomAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MoveToVisibleBottomAction : EditActionBase
Public Class MoveToVisibleBottomAction
    Inherits EditActionBase

The MoveToVisibleBottomAction type exposes the following members.

Constructors
 | Name | Description
Public method | MoveToVisibleBottomAction | Initializes a new instance of the MoveToVisibleBottomAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


MoveToVisibleBottomAction Constructor

MoveToVisibleBottomAction Constructor
Initializes a new instance of the MoveToVisibleBottomAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MoveToVisibleBottomAction()
Public Sub New
See Also

Reference

MoveToVisibleBottomAction Class


MoveToVisibleBottomAction Properties

MoveToVisibleBottomAction Properties

The MoveToVisibleBottomAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToVisibleBottomAction Class


MoveToVisibleBottomAction Methods

MoveToVisibleBottomAction Methods

The MoveToVisibleBottomAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToVisibleBottomAction Class


MoveToVisibleBottomAction.Execute Method

MoveToVisibleBottomActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

MoveToVisibleBottomAction Class


MoveToVisibleTopAction Class

MoveToVisibleTopAction Class
Represents an IEditAction that moves the caret to the top of the view.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToVisibleTopAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MoveToVisibleTopAction : EditActionBase
Public Class MoveToVisibleTopAction
    Inherits EditActionBase

The MoveToVisibleTopAction type exposes the following members.

Constructors
 | Name | Description
Public method | MoveToVisibleTopAction | Initializes a new instance of the MoveToVisibleTopAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


MoveToVisibleTopAction Constructor

MoveToVisibleTopAction Constructor
Initializes a new instance of the MoveToVisibleTopAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MoveToVisibleTopAction()
Public Sub New
See Also

Reference

MoveToVisibleTopAction Class


MoveToVisibleTopAction Properties

MoveToVisibleTopAction Properties

The MoveToVisibleTopAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToVisibleTopAction Class


MoveToVisibleTopAction Methods

MoveToVisibleTopAction Methods

The MoveToVisibleTopAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveToVisibleTopAction Class


MoveToVisibleTopAction.Execute Method

MoveToVisibleTopActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

MoveToVisibleTopAction Class


MoveUpAction Class

MoveUpAction Class
Represents an IEditAction that moves the caret up a line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveUpAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MoveUpAction : EditActionBase
Public Class MoveUpAction
    Inherits EditActionBase

The MoveUpAction type exposes the following members.

Constructors
 | Name | Description
Public method | MoveUpAction | Initializes a new instance of the MoveUpAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


MoveUpAction Constructor

MoveUpAction Constructor
Initializes a new instance of the MoveUpAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MoveUpAction()
Public Sub New
See Also

Reference

MoveUpAction Class


MoveUpAction Properties

MoveUpAction Properties

The MoveUpAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveUpAction Class


MoveUpAction Methods

MoveUpAction Methods

The MoveUpAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

MoveUpAction Class


MoveUpAction.Execute Method

MoveUpActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

MoveUpAction Class


OpenLineAboveAction Class

OpenLineAboveAction Class
Represents an IEditAction that inserts a new line above the current view line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsOpenLineAboveAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class OpenLineAboveAction : EditActionBase
Public Class OpenLineAboveAction
    Inherits EditActionBase

The OpenLineAboveAction type exposes the following members.

Constructors
 | Name | Description
Public method | OpenLineAboveAction | Initializes a new instance of the OpenLineAboveAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


OpenLineAboveAction Constructor

OpenLineAboveAction Constructor
Initializes a new instance of the OpenLineAboveAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public OpenLineAboveAction()
Public Sub New
See Also

Reference

OpenLineAboveAction Class


OpenLineAboveAction Properties

OpenLineAboveAction Properties

The OpenLineAboveAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

OpenLineAboveAction Class


OpenLineAboveAction Methods

OpenLineAboveAction Methods

The OpenLineAboveAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

OpenLineAboveAction Class


OpenLineAboveAction.CanExecute Method

OpenLineAboveActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

OpenLineAboveAction Class


OpenLineAboveAction.Execute Method

OpenLineAboveActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

OpenLineAboveAction Class


OpenLineBelowAction Class

OpenLineBelowAction Class
Represents an IEditAction that inserts a new line below the current view line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsOpenLineBelowAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class OpenLineBelowAction : EditActionBase
Public Class OpenLineBelowAction
    Inherits EditActionBase

The OpenLineBelowAction type exposes the following members.

Constructors
 | Name | Description
Public method | OpenLineBelowAction | Initializes a new instance of the OpenLineBelowAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


OpenLineBelowAction Constructor

OpenLineBelowAction Constructor
Initializes a new instance of the OpenLineBelowAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public OpenLineBelowAction()
Public Sub New
See Also

Reference

OpenLineBelowAction Class


OpenLineBelowAction Properties

OpenLineBelowAction Properties

The OpenLineBelowAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

OpenLineBelowAction Class


OpenLineBelowAction Methods

OpenLineBelowAction Methods

The OpenLineBelowAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

OpenLineBelowAction Class


OpenLineBelowAction.CanExecute Method

OpenLineBelowActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

OpenLineBelowAction Class


OpenLineBelowAction.Execute Method

OpenLineBelowActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

OpenLineBelowAction Class


OutdentAction Class

OutdentAction Class
Represents an IEditAction that outdents the currently selected lines.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsOutdentAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsRemoveTabStopOrOutdentAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class OutdentAction : EditActionBase
Public Class OutdentAction
    Inherits EditActionBase

The OutdentAction type exposes the following members.

Constructors
 | Name | Description
Public method | OutdentAction | Initializes a new instance of the OutdentAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


OutdentAction Constructor

OutdentAction Constructor
Initializes a new instance of the OutdentAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public OutdentAction()
Public Sub New
See Also

Reference

OutdentAction Class


OutdentAction Properties

OutdentAction Properties

The OutdentAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

OutdentAction Class


OutdentAction Methods

OutdentAction Methods

The OutdentAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

OutdentAction Class


OutdentAction.CanExecute Method

OutdentActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

OutdentAction Class


OutdentAction.Execute Method

OutdentActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

OutdentAction Class


PasteFromClipboardAction Class

PasteFromClipboardAction Class
Represents an IEditAction that pastes text from the clipboard into the editor view.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsPasteFromClipboardAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PasteFromClipboardAction : EditActionBase
Public Class PasteFromClipboardAction
    Inherits EditActionBase

The PasteFromClipboardAction type exposes the following members.

Constructors
 | Name | Description
Public method | PasteFromClipboardAction | Initializes a new instance of the PasteFromClipboardAction class.
Public method | PasteFromClipboardAction(IDataStore) | Initializes a new instance of the PasteFromClipboardAction class.
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Overrides EditActionBaseReadFromXml(XmlReader).)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Overrides EditActionBaseWriteToXml(XmlWriter).)
Top
See Also

Reference


PasteFromClipboardAction Constructor

PasteFromClipboardAction Constructor
Overload List
 | Name | Description
Public method | PasteFromClipboardAction | Initializes a new instance of the PasteFromClipboardAction class.
Public method | PasteFromClipboardAction(IDataStore) | Initializes a new instance of the PasteFromClipboardAction class.
Top
See Also

Reference

PasteFromClipboardAction Class


PasteFromClipboardAction Constructor

PasteFromClipboardAction Constructor
Initializes a new instance of the PasteFromClipboardAction class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PasteFromClipboardAction()
Public Sub New
Remarks
The default constructor initializes all fields to their default values.
See Also

Reference

PasteFromClipboardAction Class
PasteFromClipboardAction Overload


PasteFromClipboardAction Constructor (IDataStore)

PasteFromClipboardAction Constructor (IDataStore)
Initializes a new instance of the PasteFromClipboardAction class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PasteFromClipboardAction(
    IDataStore clipboardData
)
Public Sub New (
    clipboardData As IDataStore
)

Parameters

clipboardData
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIDataStore
The IDataStore containing clipboard data to use for the paste.
See Also

Reference

PasteFromClipboardAction Class
PasteFromClipboardAction Overload


PasteFromClipboardAction Properties

PasteFromClipboardAction Properties

The PasteFromClipboardAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

PasteFromClipboardAction Class


PasteFromClipboardAction Methods

PasteFromClipboardAction Methods

The PasteFromClipboardAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Overrides EditActionBaseReadFromXml(XmlReader).)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Overrides EditActionBaseWriteToXml(XmlWriter).)
Top
See Also

Reference

PasteFromClipboardAction Class


PasteFromClipboardAction.CanExecute Method

PasteFromClipboardActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

PasteFromClipboardAction Class


PasteFromClipboardAction.Execute Method

PasteFromClipboardActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

PasteFromClipboardAction Class


PasteFromClipboardAction.ReadFromXml Method

PasteFromClipboardActionReadFromXml Method
Deserializes the data for the IEditAction from XML.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void ReadFromXml(
    XmlReader reader
)
Public Overrides Sub ReadFromXml (
    reader As XmlReader
)

Parameters

reader
Type: System.XmlXmlReader
The XmlReader to use.

Implements

IEditActionReadFromXml(XmlReader)
Remarks
This method is used for macro serialization.
See Also

Reference

PasteFromClipboardAction Class


PasteFromClipboardAction.WriteToXml Method

PasteFromClipboardActionWriteToXml Method
Serializes the data for the IEditAction to XML.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void WriteToXml(
    XmlWriter writer
)
Public Overrides Sub WriteToXml (
    writer As XmlWriter
)

Parameters

writer
Type: System.XmlXmlWriter
The XmlWriter to use.

Implements

IEditActionWriteToXml(XmlWriter)
Remarks
This method is used for macro serialization.
See Also

Reference

PasteFromClipboardAction Class


PauseResumeMacroRecordingAction Class

PauseResumeMacroRecordingAction Class
Represents an IEditAction that pauses or resumes recording a macro, depending on the current state of macro recording.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsPauseResumeMacroRecordingAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PauseResumeMacroRecordingAction : EditActionBase
Public Class PauseResumeMacroRecordingAction
    Inherits EditActionBase

The PauseResumeMacroRecordingAction type exposes the following members.

Constructors
 | Name | Description
Public method | PauseResumeMacroRecordingAction | Initializes a new instance of the PauseResumeMacroRecordingAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Overrides EditActionBaseCanRecordInMacro.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


PauseResumeMacroRecordingAction Constructor

PauseResumeMacroRecordingAction Constructor
Initializes a new instance of the PauseResumeMacroRecordingAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PauseResumeMacroRecordingAction()
Public Sub New
See Also

Reference

PauseResumeMacroRecordingAction Class


PauseResumeMacroRecordingAction Properties

PauseResumeMacroRecordingAction Properties

The PauseResumeMacroRecordingAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Overrides EditActionBaseCanRecordInMacro.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

PauseResumeMacroRecordingAction Class


PauseResumeMacroRecordingAction.CanRecordInMacro Property

PauseResumeMacroRecordingActionCanRecordInMacro Property
Gets whether the action can be recorded in a macro.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanRecordInMacro { get; }
Public Overrides ReadOnly Property CanRecordInMacro As Boolean
    Get

Property Value

Type: Boolean
true if the action can be recorded in a macro; otherwise, false.

Implements

IEditActionCanRecordInMacro
See Also

Reference

PauseResumeMacroRecordingAction Class


PauseResumeMacroRecordingAction Methods

PauseResumeMacroRecordingAction Methods

The PauseResumeMacroRecordingAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

PauseResumeMacroRecordingAction Class


PauseResumeMacroRecordingAction.CanExecute Method

PauseResumeMacroRecordingActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

PauseResumeMacroRecordingAction Class


PauseResumeMacroRecordingAction.Execute Method

PauseResumeMacroRecordingActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

PauseResumeMacroRecordingAction Class


RedoAction Class

RedoAction Class
Represents an IEditAction that performs a redo operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsRedoAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RedoAction : EditActionBase
Public Class RedoAction
    Inherits EditActionBase

The RedoAction type exposes the following members.

Constructors
 | Name | Description
Public method | RedoAction | Initializes a new instance of the RedoAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


RedoAction Constructor

RedoAction Constructor
Initializes a new instance of the RedoAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RedoAction()
Public Sub New
See Also

Reference

RedoAction Class


RedoAction Properties

RedoAction Properties

The RedoAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

RedoAction Class


RedoAction Methods

RedoAction Methods

The RedoAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

RedoAction Class


RedoAction.CanExecute Method

RedoActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

RedoAction Class


RedoAction.Execute Method

RedoActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

RedoAction Class


RemoveTabStopOrOutdentAction Class

RemoveTabStopOrOutdentAction Class
Represents an IEditAction that removes whitespace to bring the caret to the previous tab stop if there is no selection, or alternatively outdents the currently selected lines.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsOutdentAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsRemoveTabStopOrOutdentAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RemoveTabStopOrOutdentAction : OutdentAction
Public Class RemoveTabStopOrOutdentAction
    Inherits OutdentAction

The RemoveTabStopOrOutdentAction type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveTabStopOrOutdentAction | Initializes a new instance of the RemoveTabStopOrOutdentAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from OutdentAction.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides OutdentActionExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


RemoveTabStopOrOutdentAction Constructor

RemoveTabStopOrOutdentAction Constructor
Initializes a new instance of the RemoveTabStopOrOutdentAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RemoveTabStopOrOutdentAction()
Public Sub New
See Also

Reference

RemoveTabStopOrOutdentAction Class


RemoveTabStopOrOutdentAction Properties

RemoveTabStopOrOutdentAction Properties

The RemoveTabStopOrOutdentAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

RemoveTabStopOrOutdentAction Class


RemoveTabStopOrOutdentAction Methods

RemoveTabStopOrOutdentAction Methods

The RemoveTabStopOrOutdentAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from OutdentAction.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides OutdentActionExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

RemoveTabStopOrOutdentAction Class


RemoveTabStopOrOutdentAction.Execute Method

RemoveTabStopOrOutdentActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

RemoveTabStopOrOutdentAction Class


RequestIntelliPromptAutoCompleteAction Class

RequestIntelliPromptAutoCompleteAction Class
Represents an IEditAction that performs an auto-complete if the language supports an IntelliPrompt completion session at the current offset.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsRequestIntelliPromptAutoCompleteAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RequestIntelliPromptAutoCompleteAction : EditActionBase
Public Class RequestIntelliPromptAutoCompleteAction
    Inherits EditActionBase

The RequestIntelliPromptAutoCompleteAction type exposes the following members.

Constructors
 | Name | Description
Public method | RequestIntelliPromptAutoCompleteAction | Initializes a new instance of the RequestIntelliPromptAutoCompleteAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


RequestIntelliPromptAutoCompleteAction Constructor

RequestIntelliPromptAutoCompleteAction Constructor
Initializes a new instance of the RequestIntelliPromptAutoCompleteAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RequestIntelliPromptAutoCompleteAction()
Public Sub New
See Also

Reference

RequestIntelliPromptAutoCompleteAction Class


RequestIntelliPromptAutoCompleteAction Properties

RequestIntelliPromptAutoCompleteAction Properties

The RequestIntelliPromptAutoCompleteAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

RequestIntelliPromptAutoCompleteAction Class


RequestIntelliPromptAutoCompleteAction Methods

RequestIntelliPromptAutoCompleteAction Methods

The RequestIntelliPromptAutoCompleteAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

RequestIntelliPromptAutoCompleteAction Class


RequestIntelliPromptAutoCompleteAction.CanExecute Method

RequestIntelliPromptAutoCompleteActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

RequestIntelliPromptAutoCompleteAction Class


RequestIntelliPromptAutoCompleteAction.Execute Method

RequestIntelliPromptAutoCompleteActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

RequestIntelliPromptAutoCompleteAction Class


RequestIntelliPromptCompletionSessionAction Class

RequestIntelliPromptCompletionSessionAction Class
Represents an IEditAction that displays a completion list if the language supports an IntelliPrompt completion session at the current offset.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsRequestIntelliPromptCompletionSessionAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RequestIntelliPromptCompletionSessionAction : EditActionBase
Public Class RequestIntelliPromptCompletionSessionAction
    Inherits EditActionBase

The RequestIntelliPromptCompletionSessionAction type exposes the following members.

Constructors
 | Name | Description
Public method | RequestIntelliPromptCompletionSessionAction | Initializes a new instance of the RequestIntelliPromptCompletionSessionAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


RequestIntelliPromptCompletionSessionAction Constructor

RequestIntelliPromptCompletionSessionAction Constructor
Initializes a new instance of the RequestIntelliPromptCompletionSessionAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RequestIntelliPromptCompletionSessionAction()
Public Sub New
See Also

Reference

RequestIntelliPromptCompletionSessionAction Class


RequestIntelliPromptCompletionSessionAction Properties

RequestIntelliPromptCompletionSessionAction Properties

The RequestIntelliPromptCompletionSessionAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

RequestIntelliPromptCompletionSessionAction Class


RequestIntelliPromptCompletionSessionAction Methods

RequestIntelliPromptCompletionSessionAction Methods

The RequestIntelliPromptCompletionSessionAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

RequestIntelliPromptCompletionSessionAction Class


RequestIntelliPromptCompletionSessionAction.CanExecute Method

RequestIntelliPromptCompletionSessionActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

RequestIntelliPromptCompletionSessionAction Class


RequestIntelliPromptCompletionSessionAction.Execute Method

RequestIntelliPromptCompletionSessionActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

RequestIntelliPromptCompletionSessionAction Class


RequestIntelliPromptInsertSnippetSessionAction Class

RequestIntelliPromptInsertSnippetSessionAction Class
Represents an IEditAction that allows for IntelliPrompt 'expansion' code snippet selection at the current offset.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsRequestIntelliPromptInsertSnippetSessionAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RequestIntelliPromptInsertSnippetSessionAction : EditActionBase
Public Class RequestIntelliPromptInsertSnippetSessionAction
    Inherits EditActionBase

The RequestIntelliPromptInsertSnippetSessionAction type exposes the following members.

Constructors
 | Name | Description
Public method | RequestIntelliPromptInsertSnippetSessionAction | Initializes a new instance of the RequestIntelliPromptInsertSnippetSessionAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


RequestIntelliPromptInsertSnippetSessionAction Constructor

RequestIntelliPromptInsertSnippetSessionAction Constructor
Initializes a new instance of the RequestIntelliPromptInsertSnippetSessionAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RequestIntelliPromptInsertSnippetSessionAction()
Public Sub New
See Also

Reference

RequestIntelliPromptInsertSnippetSessionAction Class


RequestIntelliPromptInsertSnippetSessionAction Properties

RequestIntelliPromptInsertSnippetSessionAction Properties

The RequestIntelliPromptInsertSnippetSessionAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

RequestIntelliPromptInsertSnippetSessionAction Class


RequestIntelliPromptInsertSnippetSessionAction Methods

RequestIntelliPromptInsertSnippetSessionAction Methods

The RequestIntelliPromptInsertSnippetSessionAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

RequestIntelliPromptInsertSnippetSessionAction Class


RequestIntelliPromptInsertSnippetSessionAction.CanExecute Method

RequestIntelliPromptInsertSnippetSessionActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

RequestIntelliPromptInsertSnippetSessionAction Class


RequestIntelliPromptInsertSnippetSessionAction.Execute Method

RequestIntelliPromptInsertSnippetSessionActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

RequestIntelliPromptInsertSnippetSessionAction Class


RequestIntelliPromptParameterInfoSessionAction Class

RequestIntelliPromptParameterInfoSessionAction Class
Represents an IEditAction that displays IntelliPrompt parameter info based on the current context.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsRequestIntelliPromptParameterInfoSessionAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RequestIntelliPromptParameterInfoSessionAction : EditActionBase
Public Class RequestIntelliPromptParameterInfoSessionAction
    Inherits EditActionBase

The RequestIntelliPromptParameterInfoSessionAction type exposes the following members.

Constructors
 | Name | Description
Public method | RequestIntelliPromptParameterInfoSessionAction | Initializes a new instance of the RequestIntelliPromptParameterInfoSessionAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


RequestIntelliPromptParameterInfoSessionAction Constructor

RequestIntelliPromptParameterInfoSessionAction Constructor
Initializes a new instance of the RequestIntelliPromptParameterInfoSessionAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RequestIntelliPromptParameterInfoSessionAction()
Public Sub New
See Also

Reference

RequestIntelliPromptParameterInfoSessionAction Class


RequestIntelliPromptParameterInfoSessionAction Properties

RequestIntelliPromptParameterInfoSessionAction Properties

The RequestIntelliPromptParameterInfoSessionAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

RequestIntelliPromptParameterInfoSessionAction Class


RequestIntelliPromptParameterInfoSessionAction Methods

RequestIntelliPromptParameterInfoSessionAction Methods

The RequestIntelliPromptParameterInfoSessionAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

RequestIntelliPromptParameterInfoSessionAction Class


RequestIntelliPromptParameterInfoSessionAction.CanExecute Method

RequestIntelliPromptParameterInfoSessionActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

RequestIntelliPromptParameterInfoSessionAction Class


RequestIntelliPromptParameterInfoSessionAction.Execute Method

RequestIntelliPromptParameterInfoSessionActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

RequestIntelliPromptParameterInfoSessionAction Class


RequestIntelliPromptQuickInfoSessionAction Class

RequestIntelliPromptQuickInfoSessionAction Class
Represents an IEditAction that displays IntelliPrompt quick info based on the current context.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsRequestIntelliPromptQuickInfoSessionAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RequestIntelliPromptQuickInfoSessionAction : EditActionBase
Public Class RequestIntelliPromptQuickInfoSessionAction
    Inherits EditActionBase

The RequestIntelliPromptQuickInfoSessionAction type exposes the following members.

Constructors
 | Name | Description
Public method | RequestIntelliPromptQuickInfoSessionAction | Initializes a new instance of the RequestIntelliPromptQuickInfoSessionAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Public property | TargetOffset | Gets or sets the optional target offset.
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


RequestIntelliPromptQuickInfoSessionAction Constructor

RequestIntelliPromptQuickInfoSessionAction Constructor
Initializes a new instance of the RequestIntelliPromptQuickInfoSessionAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RequestIntelliPromptQuickInfoSessionAction()
Public Sub New
See Also

Reference

RequestIntelliPromptQuickInfoSessionAction Class


RequestIntelliPromptQuickInfoSessionAction Properties

RequestIntelliPromptQuickInfoSessionAction Properties

The RequestIntelliPromptQuickInfoSessionAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Public property | TargetOffset | Gets or sets the optional target offset.
Top
See Also

Reference

RequestIntelliPromptQuickInfoSessionAction Class


RequestIntelliPromptQuickInfoSessionAction.TargetOffset Property

RequestIntelliPromptQuickInfoSessionActionTargetOffset Property
Gets or sets the optional target offset.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> TargetOffset { get; set; }
Public Property TargetOffset As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional target offset.
Remarks
When no target offset is specified, the caret's offset will be used.
See Also

Reference

RequestIntelliPromptQuickInfoSessionAction Class


RequestIntelliPromptQuickInfoSessionAction Methods

RequestIntelliPromptQuickInfoSessionAction Methods

The RequestIntelliPromptQuickInfoSessionAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

RequestIntelliPromptQuickInfoSessionAction Class


RequestIntelliPromptQuickInfoSessionAction.CanExecute Method

RequestIntelliPromptQuickInfoSessionActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

RequestIntelliPromptQuickInfoSessionAction Class


RequestIntelliPromptQuickInfoSessionAction.Execute Method

RequestIntelliPromptQuickInfoSessionActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

RequestIntelliPromptQuickInfoSessionAction Class


RequestIntelliPromptSurroundWithSessionAction Class

RequestIntelliPromptSurroundWithSessionAction Class
Represents an IEditAction that allows for IntelliPrompt 'surrounds with' code snippet selection at the current offset.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsRequestIntelliPromptSurroundWithSessionAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RequestIntelliPromptSurroundWithSessionAction : EditActionBase
Public Class RequestIntelliPromptSurroundWithSessionAction
    Inherits EditActionBase

The RequestIntelliPromptSurroundWithSessionAction type exposes the following members.

Constructors
 | Name | Description
Public method | RequestIntelliPromptSurroundWithSessionAction | Initializes a new instance of the RequestIntelliPromptSurroundWithSessionAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


RequestIntelliPromptSurroundWithSessionAction Constructor

RequestIntelliPromptSurroundWithSessionAction Constructor
Initializes a new instance of the RequestIntelliPromptSurroundWithSessionAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RequestIntelliPromptSurroundWithSessionAction()
Public Sub New
See Also

Reference

RequestIntelliPromptSurroundWithSessionAction Class


RequestIntelliPromptSurroundWithSessionAction Properties

RequestIntelliPromptSurroundWithSessionAction Properties

The RequestIntelliPromptSurroundWithSessionAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

RequestIntelliPromptSurroundWithSessionAction Class


RequestIntelliPromptSurroundWithSessionAction Methods

RequestIntelliPromptSurroundWithSessionAction Methods

The RequestIntelliPromptSurroundWithSessionAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

RequestIntelliPromptSurroundWithSessionAction Class


RequestIntelliPromptSurroundWithSessionAction.CanExecute Method

RequestIntelliPromptSurroundWithSessionActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

RequestIntelliPromptSurroundWithSessionAction Class


RequestIntelliPromptSurroundWithSessionAction.Execute Method

RequestIntelliPromptSurroundWithSessionActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

RequestIntelliPromptSurroundWithSessionAction Class


ReverseIncrementalSearchAction Class

ReverseIncrementalSearchAction Class
Represents an IEditAction that performs a reverse incremental search.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsReverseIncrementalSearchAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ReverseIncrementalSearchAction : EditActionBase
Public Class ReverseIncrementalSearchAction
    Inherits EditActionBase

The ReverseIncrementalSearchAction type exposes the following members.

Constructors
 | Name | Description
Public method | ReverseIncrementalSearchAction | Initializes a new instance of the ReverseIncrementalSearchAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


ReverseIncrementalSearchAction Constructor

ReverseIncrementalSearchAction Constructor
Initializes a new instance of the ReverseIncrementalSearchAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReverseIncrementalSearchAction()
Public Sub New
See Also

Reference

ReverseIncrementalSearchAction Class


ReverseIncrementalSearchAction Properties

ReverseIncrementalSearchAction Properties

The ReverseIncrementalSearchAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

ReverseIncrementalSearchAction Class


ReverseIncrementalSearchAction Methods

ReverseIncrementalSearchAction Methods

The ReverseIncrementalSearchAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

ReverseIncrementalSearchAction Class


ReverseIncrementalSearchAction.Execute Method

ReverseIncrementalSearchActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

ReverseIncrementalSearchAction Class


RunMacroAction Class

RunMacroAction Class
Represents an IEditAction that runs the macro that was last recorded.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsRunMacroAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RunMacroAction : EditActionBase
Public Class RunMacroAction
    Inherits EditActionBase

The RunMacroAction type exposes the following members.

Constructors
 | Name | Description
Public method | RunMacroAction | Initializes a new instance of the RunMacroAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Overrides EditActionBaseCanRecordInMacro.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


RunMacroAction Constructor

RunMacroAction Constructor
Initializes a new instance of the RunMacroAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RunMacroAction()
Public Sub New
See Also

Reference

RunMacroAction Class


RunMacroAction Properties

RunMacroAction Properties

The RunMacroAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Overrides EditActionBaseCanRecordInMacro.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

RunMacroAction Class


RunMacroAction.CanRecordInMacro Property

RunMacroActionCanRecordInMacro Property
Gets whether the action can be recorded in a macro.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanRecordInMacro { get; }
Public Overrides ReadOnly Property CanRecordInMacro As Boolean
    Get

Property Value

Type: Boolean
true if the action can be recorded in a macro; otherwise, false.

Implements

IEditActionCanRecordInMacro
See Also

Reference

RunMacroAction Class


RunMacroAction Methods

RunMacroAction Methods

The RunMacroAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

RunMacroAction Class


RunMacroAction.CanExecute Method

RunMacroActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

RunMacroAction Class


RunMacroAction.Execute Method

RunMacroActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

RunMacroAction Class


ScrollDownAction Class

ScrollDownAction Class
Represents an IEditAction that scrolls down a line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollDownAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ScrollDownAction : EditActionBase
Public Class ScrollDownAction
    Inherits EditActionBase

The ScrollDownAction type exposes the following members.

Constructors
 | Name | Description
Public method | ScrollDownAction | Initializes a new instance of the ScrollDownAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


ScrollDownAction Constructor

ScrollDownAction Constructor
Initializes a new instance of the ScrollDownAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ScrollDownAction()
Public Sub New
See Also

Reference

ScrollDownAction Class


ScrollDownAction Properties

ScrollDownAction Properties

The ScrollDownAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollDownAction Class


ScrollDownAction Methods

ScrollDownAction Methods

The ScrollDownAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollDownAction Class


ScrollDownAction.Execute Method

ScrollDownActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

ScrollDownAction Class


ScrollLeftAction Class

ScrollLeftAction Class
Represents an IEditAction that scrolls left a column.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollLeftAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ScrollLeftAction : EditActionBase
Public Class ScrollLeftAction
    Inherits EditActionBase

The ScrollLeftAction type exposes the following members.

Constructors
 | Name | Description
Public method | ScrollLeftAction | Initializes a new instance of the ScrollLeftAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


ScrollLeftAction Constructor

ScrollLeftAction Constructor
Initializes a new instance of the ScrollLeftAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ScrollLeftAction()
Public Sub New
See Also

Reference

ScrollLeftAction Class


ScrollLeftAction Properties

ScrollLeftAction Properties

The ScrollLeftAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollLeftAction Class


ScrollLeftAction Methods

ScrollLeftAction Methods

The ScrollLeftAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollLeftAction Class


ScrollLeftAction.Execute Method

ScrollLeftActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

ScrollLeftAction Class


ScrollLineToVisibleBottomAction Class

ScrollLineToVisibleBottomAction Class
Represents an IEditAction that scrolls the current view line to the bottom of the view.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollLineToVisibleBottomAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ScrollLineToVisibleBottomAction : EditActionBase
Public Class ScrollLineToVisibleBottomAction
    Inherits EditActionBase

The ScrollLineToVisibleBottomAction type exposes the following members.

Constructors
 | Name | Description
Public method | ScrollLineToVisibleBottomAction | Initializes a new instance of the ScrollLineToVisibleBottomAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


ScrollLineToVisibleBottomAction Constructor

ScrollLineToVisibleBottomAction Constructor
Initializes a new instance of the ScrollLineToVisibleBottomAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ScrollLineToVisibleBottomAction()
Public Sub New
See Also

Reference

ScrollLineToVisibleBottomAction Class


ScrollLineToVisibleBottomAction Properties

ScrollLineToVisibleBottomAction Properties

The ScrollLineToVisibleBottomAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollLineToVisibleBottomAction Class


ScrollLineToVisibleBottomAction Methods

ScrollLineToVisibleBottomAction Methods

The ScrollLineToVisibleBottomAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollLineToVisibleBottomAction Class


ScrollLineToVisibleBottomAction.Execute Method

ScrollLineToVisibleBottomActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

ScrollLineToVisibleBottomAction Class


ScrollLineToVisibleMiddleAction Class

ScrollLineToVisibleMiddleAction Class
Represents an IEditAction that scrolls the current view line to the middle of the view.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollLineToVisibleMiddleAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ScrollLineToVisibleMiddleAction : EditActionBase
Public Class ScrollLineToVisibleMiddleAction
    Inherits EditActionBase

The ScrollLineToVisibleMiddleAction type exposes the following members.

Constructors
 | Name | Description
Public method | ScrollLineToVisibleMiddleAction | Initializes a new instance of the ScrollLineToVisibleMiddleAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


ScrollLineToVisibleMiddleAction Constructor

ScrollLineToVisibleMiddleAction Constructor
Initializes a new instance of the ScrollLineToVisibleMiddleAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ScrollLineToVisibleMiddleAction()
Public Sub New
See Also

Reference

ScrollLineToVisibleMiddleAction Class


ScrollLineToVisibleMiddleAction Properties

ScrollLineToVisibleMiddleAction Properties

The ScrollLineToVisibleMiddleAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollLineToVisibleMiddleAction Class


ScrollLineToVisibleMiddleAction Methods

ScrollLineToVisibleMiddleAction Methods

The ScrollLineToVisibleMiddleAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollLineToVisibleMiddleAction Class


ScrollLineToVisibleMiddleAction.Execute Method

ScrollLineToVisibleMiddleActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

ScrollLineToVisibleMiddleAction Class


ScrollLineToVisibleTopAction Class

ScrollLineToVisibleTopAction Class
Represents an IEditAction that scrolls the current view line to the top of the view.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollLineToVisibleTopAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ScrollLineToVisibleTopAction : EditActionBase
Public Class ScrollLineToVisibleTopAction
    Inherits EditActionBase

The ScrollLineToVisibleTopAction type exposes the following members.

Constructors
 | Name | Description
Public method | ScrollLineToVisibleTopAction | Initializes a new instance of the ScrollLineToVisibleTopAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


ScrollLineToVisibleTopAction Constructor

ScrollLineToVisibleTopAction Constructor
Initializes a new instance of the ScrollLineToVisibleTopAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ScrollLineToVisibleTopAction()
Public Sub New
See Also

Reference

ScrollLineToVisibleTopAction Class


ScrollLineToVisibleTopAction Properties

ScrollLineToVisibleTopAction Properties

The ScrollLineToVisibleTopAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollLineToVisibleTopAction Class


ScrollLineToVisibleTopAction Methods

ScrollLineToVisibleTopAction Methods

The ScrollLineToVisibleTopAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollLineToVisibleTopAction Class


ScrollLineToVisibleTopAction.Execute Method

ScrollLineToVisibleTopActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

ScrollLineToVisibleTopAction Class


ScrollPageDownAction Class

ScrollPageDownAction Class
Represents an IEditAction that scrolls down a page.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollPageDownAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ScrollPageDownAction : EditActionBase
Public Class ScrollPageDownAction
    Inherits EditActionBase

The ScrollPageDownAction type exposes the following members.

Constructors
 | Name | Description
Public method | ScrollPageDownAction | Initializes a new instance of the ScrollPageDownAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


ScrollPageDownAction Constructor

ScrollPageDownAction Constructor
Initializes a new instance of the ScrollPageDownAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ScrollPageDownAction()
Public Sub New
See Also

Reference

ScrollPageDownAction Class


ScrollPageDownAction Properties

ScrollPageDownAction Properties

The ScrollPageDownAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollPageDownAction Class


ScrollPageDownAction Methods

ScrollPageDownAction Methods

The ScrollPageDownAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollPageDownAction Class


ScrollPageDownAction.Execute Method

ScrollPageDownActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

ScrollPageDownAction Class


ScrollPageUpAction Class

ScrollPageUpAction Class
Represents an IEditAction that scrolls up a page.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollPageUpAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ScrollPageUpAction : EditActionBase
Public Class ScrollPageUpAction
    Inherits EditActionBase

The ScrollPageUpAction type exposes the following members.

Constructors
 | Name | Description
Public method | ScrollPageUpAction | Initializes a new instance of the ScrollPageUpAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


ScrollPageUpAction Constructor

ScrollPageUpAction Constructor
Initializes a new instance of the ScrollPageUpAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ScrollPageUpAction()
Public Sub New
See Also

Reference

ScrollPageUpAction Class


ScrollPageUpAction Properties

ScrollPageUpAction Properties

The ScrollPageUpAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollPageUpAction Class


ScrollPageUpAction Methods

ScrollPageUpAction Methods

The ScrollPageUpAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollPageUpAction Class


ScrollPageUpAction.Execute Method

ScrollPageUpActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

ScrollPageUpAction Class


ScrollRightAction Class

ScrollRightAction Class
Represents an IEditAction that scrolls right a column.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollRightAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ScrollRightAction : EditActionBase
Public Class ScrollRightAction
    Inherits EditActionBase

The ScrollRightAction type exposes the following members.

Constructors
 | Name | Description
Public method | ScrollRightAction | Initializes a new instance of the ScrollRightAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


ScrollRightAction Constructor

ScrollRightAction Constructor
Initializes a new instance of the ScrollRightAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ScrollRightAction()
Public Sub New
See Also

Reference

ScrollRightAction Class


ScrollRightAction Properties

ScrollRightAction Properties

The ScrollRightAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollRightAction Class


ScrollRightAction Methods

ScrollRightAction Methods

The ScrollRightAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollRightAction Class


ScrollRightAction.Execute Method

ScrollRightActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

ScrollRightAction Class


ScrollToDocumentEndAction Class

ScrollToDocumentEndAction Class
Represents an IEditAction that scrolls to the document end.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollToDocumentEndAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ScrollToDocumentEndAction : EditActionBase
Public Class ScrollToDocumentEndAction
    Inherits EditActionBase

The ScrollToDocumentEndAction type exposes the following members.

Constructors
 | Name | Description
Public method | ScrollToDocumentEndAction | Initializes a new instance of the ScrollToDocumentEndAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


ScrollToDocumentEndAction Constructor

ScrollToDocumentEndAction Constructor
Initializes a new instance of the ScrollToDocumentEndAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ScrollToDocumentEndAction()
Public Sub New
See Also

Reference

ScrollToDocumentEndAction Class


ScrollToDocumentEndAction Properties

ScrollToDocumentEndAction Properties

The ScrollToDocumentEndAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollToDocumentEndAction Class


ScrollToDocumentEndAction Methods

ScrollToDocumentEndAction Methods

The ScrollToDocumentEndAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollToDocumentEndAction Class


ScrollToDocumentEndAction.Execute Method

ScrollToDocumentEndActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

ScrollToDocumentEndAction Class


ScrollToDocumentStartAction Class

ScrollToDocumentStartAction Class
Represents an IEditAction that scrolls to the document start.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollToDocumentStartAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ScrollToDocumentStartAction : EditActionBase
Public Class ScrollToDocumentStartAction
    Inherits EditActionBase

The ScrollToDocumentStartAction type exposes the following members.

Constructors
 | Name | Description
Public method | ScrollToDocumentStartAction | Initializes a new instance of the ScrollToDocumentStartAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


ScrollToDocumentStartAction Constructor

ScrollToDocumentStartAction Constructor
Initializes a new instance of the ScrollToDocumentStartAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ScrollToDocumentStartAction()
Public Sub New
See Also

Reference

ScrollToDocumentStartAction Class


ScrollToDocumentStartAction Properties

ScrollToDocumentStartAction Properties

The ScrollToDocumentStartAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollToDocumentStartAction Class


ScrollToDocumentStartAction Methods

ScrollToDocumentStartAction Methods

The ScrollToDocumentStartAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollToDocumentStartAction Class


ScrollToDocumentStartAction.Execute Method

ScrollToDocumentStartActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

ScrollToDocumentStartAction Class


ScrollUpAction Class

ScrollUpAction Class
Represents an IEditAction that scrolls up a line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollUpAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ScrollUpAction : EditActionBase
Public Class ScrollUpAction
    Inherits EditActionBase

The ScrollUpAction type exposes the following members.

Constructors
 | Name | Description
Public method | ScrollUpAction | Initializes a new instance of the ScrollUpAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


ScrollUpAction Constructor

ScrollUpAction Constructor
Initializes a new instance of the ScrollUpAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ScrollUpAction()
Public Sub New
See Also

Reference

ScrollUpAction Class


ScrollUpAction Properties

ScrollUpAction Properties

The ScrollUpAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollUpAction Class


ScrollUpAction Methods

ScrollUpAction Methods

The ScrollUpAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

ScrollUpAction Class


ScrollUpAction.Execute Method

ScrollUpActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

ScrollUpAction Class


SelectAllAction Class

SelectAllAction Class
Represents an IEditAction that selects all the text.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectAllAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectAllAction : EditActionBase
Public Class SelectAllAction
    Inherits EditActionBase

The SelectAllAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectAllAction | Initializes a new instance of the SelectAllAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectAllAction Constructor

SelectAllAction Constructor
Initializes a new instance of the SelectAllAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectAllAction()
Public Sub New
See Also

Reference

SelectAllAction Class


SelectAllAction Properties

SelectAllAction Properties

The SelectAllAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectAllAction Class


SelectAllAction Methods

SelectAllAction Methods

The SelectAllAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectAllAction Class


SelectAllAction.Execute Method

SelectAllActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectAllAction Class


SelectBlockDownAction Class

SelectBlockDownAction Class
Represents an IEditAction that extends the block selection down a line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectBlockDownAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectBlockDownAction : EditActionBase
Public Class SelectBlockDownAction
    Inherits EditActionBase

The SelectBlockDownAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectBlockDownAction | Initializes a new instance of the SelectBlockDownAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectBlockDownAction Constructor

SelectBlockDownAction Constructor
Initializes a new instance of the SelectBlockDownAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectBlockDownAction()
Public Sub New
See Also

Reference

SelectBlockDownAction Class


SelectBlockDownAction Properties

SelectBlockDownAction Properties

The SelectBlockDownAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectBlockDownAction Class


SelectBlockDownAction Methods

SelectBlockDownAction Methods

The SelectBlockDownAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectBlockDownAction Class


SelectBlockDownAction.Execute Method

SelectBlockDownActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectBlockDownAction Class


SelectBlockLeftAction Class

SelectBlockLeftAction Class
Represents an IEditAction that extends the block selection left a character.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectBlockLeftAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectBlockLeftAction : EditActionBase
Public Class SelectBlockLeftAction
    Inherits EditActionBase

The SelectBlockLeftAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectBlockLeftAction | Initializes a new instance of the SelectBlockLeftAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectBlockLeftAction Constructor

SelectBlockLeftAction Constructor
Initializes a new instance of the SelectBlockLeftAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectBlockLeftAction()
Public Sub New
See Also

Reference

SelectBlockLeftAction Class


SelectBlockLeftAction Properties

SelectBlockLeftAction Properties

The SelectBlockLeftAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectBlockLeftAction Class


SelectBlockLeftAction Methods

SelectBlockLeftAction Methods

The SelectBlockLeftAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectBlockLeftAction Class


SelectBlockLeftAction.Execute Method

SelectBlockLeftActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectBlockLeftAction Class


SelectBlockRightAction Class

SelectBlockRightAction Class
Represents an IEditAction that extends the block selection right a character.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectBlockRightAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectBlockRightAction : EditActionBase
Public Class SelectBlockRightAction
    Inherits EditActionBase

The SelectBlockRightAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectBlockRightAction | Initializes a new instance of the SelectBlockRightAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectBlockRightAction Constructor

SelectBlockRightAction Constructor
Initializes a new instance of the SelectBlockRightAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectBlockRightAction()
Public Sub New
See Also

Reference

SelectBlockRightAction Class


SelectBlockRightAction Properties

SelectBlockRightAction Properties

The SelectBlockRightAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectBlockRightAction Class


SelectBlockRightAction Methods

SelectBlockRightAction Methods

The SelectBlockRightAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectBlockRightAction Class


SelectBlockRightAction.Execute Method

SelectBlockRightActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectBlockRightAction Class


SelectBlockToNextWordAction Class

SelectBlockToNextWordAction Class
Represents an IEditAction that extends the block selection to the next word.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectBlockToNextWordAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectBlockToNextWordAction : EditActionBase
Public Class SelectBlockToNextWordAction
    Inherits EditActionBase

The SelectBlockToNextWordAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectBlockToNextWordAction | Initializes a new instance of the SelectBlockToNextWordAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectBlockToNextWordAction Constructor

SelectBlockToNextWordAction Constructor
Initializes a new instance of the SelectBlockToNextWordAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectBlockToNextWordAction()
Public Sub New
See Also

Reference

SelectBlockToNextWordAction Class


SelectBlockToNextWordAction Properties

SelectBlockToNextWordAction Properties

The SelectBlockToNextWordAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectBlockToNextWordAction Class


SelectBlockToNextWordAction Methods

SelectBlockToNextWordAction Methods

The SelectBlockToNextWordAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectBlockToNextWordAction Class


SelectBlockToNextWordAction.Execute Method

SelectBlockToNextWordActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectBlockToNextWordAction Class


SelectBlockToPreviousWordAction Class

SelectBlockToPreviousWordAction Class
Represents an IEditAction that extends the block selection to the previous word.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectBlockToPreviousWordAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectBlockToPreviousWordAction : EditActionBase
Public Class SelectBlockToPreviousWordAction
    Inherits EditActionBase

The SelectBlockToPreviousWordAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectBlockToPreviousWordAction | Initializes a new instance of the SelectBlockToPreviousWordAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectBlockToPreviousWordAction Constructor

SelectBlockToPreviousWordAction Constructor
Initializes a new instance of the SelectBlockToPreviousWordAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectBlockToPreviousWordAction()
Public Sub New
See Also

Reference

SelectBlockToPreviousWordAction Class


SelectBlockToPreviousWordAction Properties

SelectBlockToPreviousWordAction Properties

The SelectBlockToPreviousWordAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectBlockToPreviousWordAction Class


SelectBlockToPreviousWordAction Methods

SelectBlockToPreviousWordAction Methods

The SelectBlockToPreviousWordAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectBlockToPreviousWordAction Class


SelectBlockToPreviousWordAction.Execute Method

SelectBlockToPreviousWordActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectBlockToPreviousWordAction Class


SelectBlockUpAction Class

SelectBlockUpAction Class
Represents an IEditAction that extends the block selection up a line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectBlockUpAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectBlockUpAction : EditActionBase
Public Class SelectBlockUpAction
    Inherits EditActionBase

The SelectBlockUpAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectBlockUpAction | Initializes a new instance of the SelectBlockUpAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectBlockUpAction Constructor

SelectBlockUpAction Constructor
Initializes a new instance of the SelectBlockUpAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectBlockUpAction()
Public Sub New
See Also

Reference

SelectBlockUpAction Class


SelectBlockUpAction Properties

SelectBlockUpAction Properties

The SelectBlockUpAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectBlockUpAction Class


SelectBlockUpAction Methods

SelectBlockUpAction Methods

The SelectBlockUpAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectBlockUpAction Class


SelectBlockUpAction.Execute Method

SelectBlockUpActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectBlockUpAction Class


SelectDownAction Class

SelectDownAction Class
Represents an IEditAction that extends the selection down a line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectDownAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectDownAction : EditActionBase
Public Class SelectDownAction
    Inherits EditActionBase

The SelectDownAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectDownAction | Initializes a new instance of the SelectDownAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectDownAction Constructor

SelectDownAction Constructor
Initializes a new instance of the SelectDownAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectDownAction()
Public Sub New
See Also

Reference

SelectDownAction Class


SelectDownAction Properties

SelectDownAction Properties

The SelectDownAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectDownAction Class


SelectDownAction Methods

SelectDownAction Methods

The SelectDownAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectDownAction Class


SelectDownAction.Execute Method

SelectDownActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectDownAction Class


SelectLeftAction Class

SelectLeftAction Class
Represents an IEditAction that extends the selection left a character.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectLeftAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectLeftAction : EditActionBase
Public Class SelectLeftAction
    Inherits EditActionBase

The SelectLeftAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectLeftAction | Initializes a new instance of the SelectLeftAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectLeftAction Constructor

SelectLeftAction Constructor
Initializes a new instance of the SelectLeftAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectLeftAction()
Public Sub New
See Also

Reference

SelectLeftAction Class


SelectLeftAction Properties

SelectLeftAction Properties

The SelectLeftAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectLeftAction Class


SelectLeftAction Methods

SelectLeftAction Methods

The SelectLeftAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectLeftAction Class


SelectLeftAction.Execute Method

SelectLeftActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectLeftAction Class


SelectPageDownAction Class

SelectPageDownAction Class
Represents an IEditAction that extends the selection down a page.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectPageDownAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectPageDownAction : EditActionBase
Public Class SelectPageDownAction
    Inherits EditActionBase

The SelectPageDownAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectPageDownAction | Initializes a new instance of the SelectPageDownAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectPageDownAction Constructor

SelectPageDownAction Constructor
Initializes a new instance of the SelectPageDownAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectPageDownAction()
Public Sub New
See Also

Reference

SelectPageDownAction Class


SelectPageDownAction Properties

SelectPageDownAction Properties

The SelectPageDownAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectPageDownAction Class


SelectPageDownAction Methods

SelectPageDownAction Methods

The SelectPageDownAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectPageDownAction Class


SelectPageDownAction.Execute Method

SelectPageDownActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectPageDownAction Class


SelectPageUpAction Class

SelectPageUpAction Class
Represents an IEditAction that extends the selection up a page.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectPageUpAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectPageUpAction : EditActionBase
Public Class SelectPageUpAction
    Inherits EditActionBase

The SelectPageUpAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectPageUpAction | Initializes a new instance of the SelectPageUpAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectPageUpAction Constructor

SelectPageUpAction Constructor
Initializes a new instance of the SelectPageUpAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectPageUpAction()
Public Sub New
See Also

Reference

SelectPageUpAction Class


SelectPageUpAction Properties

SelectPageUpAction Properties

The SelectPageUpAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectPageUpAction Class


SelectPageUpAction Methods

SelectPageUpAction Methods

The SelectPageUpAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectPageUpAction Class


SelectPageUpAction.Execute Method

SelectPageUpActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectPageUpAction Class


SelectRightAction Class

SelectRightAction Class
Represents an IEditAction that extends the selection right a character.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectRightAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectRightAction : EditActionBase
Public Class SelectRightAction
    Inherits EditActionBase

The SelectRightAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectRightAction | Initializes a new instance of the SelectRightAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectRightAction Constructor

SelectRightAction Constructor
Initializes a new instance of the SelectRightAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectRightAction()
Public Sub New
See Also

Reference

SelectRightAction Class


SelectRightAction Properties

SelectRightAction Properties

The SelectRightAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectRightAction Class


SelectRightAction Methods

SelectRightAction Methods

The SelectRightAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectRightAction Class


SelectRightAction.Execute Method

SelectRightActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectRightAction Class


SelectToDocumentEndAction Class

SelectToDocumentEndAction Class
Represents an IEditAction that extends the selection to the end of the document.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectToDocumentEndAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectToDocumentEndAction : EditActionBase
Public Class SelectToDocumentEndAction
    Inherits EditActionBase

The SelectToDocumentEndAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectToDocumentEndAction | Initializes a new instance of the SelectToDocumentEndAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectToDocumentEndAction Constructor

SelectToDocumentEndAction Constructor
Initializes a new instance of the SelectToDocumentEndAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectToDocumentEndAction()
Public Sub New
See Also

Reference

SelectToDocumentEndAction Class


SelectToDocumentEndAction Properties

SelectToDocumentEndAction Properties

The SelectToDocumentEndAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectToDocumentEndAction Class


SelectToDocumentEndAction Methods

SelectToDocumentEndAction Methods

The SelectToDocumentEndAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectToDocumentEndAction Class


SelectToDocumentEndAction.Execute Method

SelectToDocumentEndActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectToDocumentEndAction Class


SelectToDocumentStartAction Class

SelectToDocumentStartAction Class
Represents an IEditAction that extends the selection to the start of the document.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectToDocumentStartAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectToDocumentStartAction : EditActionBase
Public Class SelectToDocumentStartAction
    Inherits EditActionBase

The SelectToDocumentStartAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectToDocumentStartAction | Initializes a new instance of the SelectToDocumentStartAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectToDocumentStartAction Constructor

SelectToDocumentStartAction Constructor
Initializes a new instance of the SelectToDocumentStartAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectToDocumentStartAction()
Public Sub New
See Also

Reference

SelectToDocumentStartAction Class


SelectToDocumentStartAction Properties

SelectToDocumentStartAction Properties

The SelectToDocumentStartAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectToDocumentStartAction Class


SelectToDocumentStartAction Methods

SelectToDocumentStartAction Methods

The SelectToDocumentStartAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectToDocumentStartAction Class


SelectToDocumentStartAction.Execute Method

SelectToDocumentStartActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectToDocumentStartAction Class


SelectToLineEndAction Class

SelectToLineEndAction Class
Represents an IEditAction that extends the selection to the end of the line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectToLineEndAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectToLineEndAction : EditActionBase
Public Class SelectToLineEndAction
    Inherits EditActionBase

The SelectToLineEndAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectToLineEndAction | Initializes a new instance of the SelectToLineEndAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectToLineEndAction Constructor

SelectToLineEndAction Constructor
Initializes a new instance of the SelectToLineEndAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectToLineEndAction()
Public Sub New
See Also

Reference

SelectToLineEndAction Class


SelectToLineEndAction Properties

SelectToLineEndAction Properties

The SelectToLineEndAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectToLineEndAction Class


SelectToLineEndAction Methods

SelectToLineEndAction Methods

The SelectToLineEndAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectToLineEndAction Class


SelectToLineEndAction.Execute Method

SelectToLineEndActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectToLineEndAction Class


SelectToLineStartAction Class

SelectToLineStartAction Class
Represents an IEditAction that extends the selection to the start of the line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectToLineStartAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectToLineStartAction : EditActionBase
Public Class SelectToLineStartAction
    Inherits EditActionBase

The SelectToLineStartAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectToLineStartAction | Initializes a new instance of the SelectToLineStartAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectToLineStartAction Constructor

SelectToLineStartAction Constructor
Initializes a new instance of the SelectToLineStartAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectToLineStartAction()
Public Sub New
See Also

Reference

SelectToLineStartAction Class


SelectToLineStartAction Properties

SelectToLineStartAction Properties

The SelectToLineStartAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectToLineStartAction Class


SelectToLineStartAction Methods

SelectToLineStartAction Methods

The SelectToLineStartAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectToLineStartAction Class


SelectToLineStartAction.Execute Method

SelectToLineStartActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectToLineStartAction Class


SelectToLineStartAfterIndentationAction Class

SelectToLineStartAfterIndentationAction Class
Represents an IEditAction that extends the selection to the first non-whitespace character on the current view line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectToLineStartAfterIndentationAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectToLineStartAfterIndentationAction : EditActionBase
Public Class SelectToLineStartAfterIndentationAction
    Inherits EditActionBase

The SelectToLineStartAfterIndentationAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectToLineStartAfterIndentationAction | Initializes a new instance of the SelectToLineStartAfterIndentationAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectToLineStartAfterIndentationAction Constructor

SelectToLineStartAfterIndentationAction Constructor
Initializes a new instance of the SelectToLineStartAfterIndentationAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectToLineStartAfterIndentationAction()
Public Sub New
See Also

Reference

SelectToLineStartAfterIndentationAction Class


SelectToLineStartAfterIndentationAction Properties

SelectToLineStartAfterIndentationAction Properties

The SelectToLineStartAfterIndentationAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectToLineStartAfterIndentationAction Class


SelectToLineStartAfterIndentationAction Methods

SelectToLineStartAfterIndentationAction Methods

The SelectToLineStartAfterIndentationAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectToLineStartAfterIndentationAction Class


SelectToLineStartAfterIndentationAction.Execute Method

SelectToLineStartAfterIndentationActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectToLineStartAfterIndentationAction Class


SelectToMatchingBracketAction Class

SelectToMatchingBracketAction Class
Represents an IEditAction that extends the selection to the matching bracket, if any.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectToMatchingBracketAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectToMatchingBracketAction : EditActionBase
Public Class SelectToMatchingBracketAction
    Inherits EditActionBase

The SelectToMatchingBracketAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectToMatchingBracketAction | Initializes a new instance of the SelectToMatchingBracketAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectToMatchingBracketAction Constructor

SelectToMatchingBracketAction Constructor
Initializes a new instance of the SelectToMatchingBracketAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectToMatchingBracketAction()
Public Sub New
See Also

Reference

SelectToMatchingBracketAction Class


SelectToMatchingBracketAction Properties

SelectToMatchingBracketAction Properties

The SelectToMatchingBracketAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectToMatchingBracketAction Class


SelectToMatchingBracketAction Methods

SelectToMatchingBracketAction Methods

The SelectToMatchingBracketAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectToMatchingBracketAction Class


SelectToMatchingBracketAction.CanExecute Method

SelectToMatchingBracketActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

SelectToMatchingBracketAction Class


SelectToMatchingBracketAction.Execute Method

SelectToMatchingBracketActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectToMatchingBracketAction Class


SelectToNextWordAction Class

SelectToNextWordAction Class
Represents an IEditAction that extends the selection to the next word.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectToNextWordAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectToNextWordAction : EditActionBase
Public Class SelectToNextWordAction
    Inherits EditActionBase

The SelectToNextWordAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectToNextWordAction | Initializes a new instance of the SelectToNextWordAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectToNextWordAction Constructor

SelectToNextWordAction Constructor
Initializes a new instance of the SelectToNextWordAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectToNextWordAction()
Public Sub New
See Also

Reference

SelectToNextWordAction Class


SelectToNextWordAction Properties

SelectToNextWordAction Properties

The SelectToNextWordAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectToNextWordAction Class


SelectToNextWordAction Methods

SelectToNextWordAction Methods

The SelectToNextWordAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectToNextWordAction Class


SelectToNextWordAction.Execute Method

SelectToNextWordActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectToNextWordAction Class


SelectToPreviousWordAction Class

SelectToPreviousWordAction Class
Represents an IEditAction that extends the selection to the previous word.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectToPreviousWordAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectToPreviousWordAction : EditActionBase
Public Class SelectToPreviousWordAction
    Inherits EditActionBase

The SelectToPreviousWordAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectToPreviousWordAction | Initializes a new instance of the SelectToPreviousWordAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectToPreviousWordAction Constructor

SelectToPreviousWordAction Constructor
Initializes a new instance of the SelectToPreviousWordAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectToPreviousWordAction()
Public Sub New
See Also

Reference

SelectToPreviousWordAction Class


SelectToPreviousWordAction Properties

SelectToPreviousWordAction Properties

The SelectToPreviousWordAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectToPreviousWordAction Class


SelectToPreviousWordAction Methods

SelectToPreviousWordAction Methods

The SelectToPreviousWordAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectToPreviousWordAction Class


SelectToPreviousWordAction.Execute Method

SelectToPreviousWordActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectToPreviousWordAction Class


SelectToVisibleBottomAction Class

SelectToVisibleBottomAction Class
Represents an IEditAction that extends the selection to the bottom of the view.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectToVisibleBottomAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectToVisibleBottomAction : EditActionBase
Public Class SelectToVisibleBottomAction
    Inherits EditActionBase

The SelectToVisibleBottomAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectToVisibleBottomAction | Initializes a new instance of the SelectToVisibleBottomAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectToVisibleBottomAction Constructor

SelectToVisibleBottomAction Constructor
Initializes a new instance of the SelectToVisibleBottomAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectToVisibleBottomAction()
Public Sub New
See Also

Reference

SelectToVisibleBottomAction Class


SelectToVisibleBottomAction Properties

SelectToVisibleBottomAction Properties

The SelectToVisibleBottomAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectToVisibleBottomAction Class


SelectToVisibleBottomAction Methods

SelectToVisibleBottomAction Methods

The SelectToVisibleBottomAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectToVisibleBottomAction Class


SelectToVisibleBottomAction.Execute Method

SelectToVisibleBottomActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectToVisibleBottomAction Class


SelectToVisibleTopAction Class

SelectToVisibleTopAction Class
Represents an IEditAction that extends the selection to the top of the view.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectToVisibleTopAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectToVisibleTopAction : EditActionBase
Public Class SelectToVisibleTopAction
    Inherits EditActionBase

The SelectToVisibleTopAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectToVisibleTopAction | Initializes a new instance of the SelectToVisibleTopAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectToVisibleTopAction Constructor

SelectToVisibleTopAction Constructor
Initializes a new instance of the SelectToVisibleTopAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectToVisibleTopAction()
Public Sub New
See Also

Reference

SelectToVisibleTopAction Class


SelectToVisibleTopAction Properties

SelectToVisibleTopAction Properties

The SelectToVisibleTopAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectToVisibleTopAction Class


SelectToVisibleTopAction Methods

SelectToVisibleTopAction Methods

The SelectToVisibleTopAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectToVisibleTopAction Class


SelectToVisibleTopAction.Execute Method

SelectToVisibleTopActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectToVisibleTopAction Class


SelectUpAction Class

SelectUpAction Class
Represents an IEditAction that extends the selection up a line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectUpAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectUpAction : EditActionBase
Public Class SelectUpAction
    Inherits EditActionBase

The SelectUpAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectUpAction | Initializes a new instance of the SelectUpAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectUpAction Constructor

SelectUpAction Constructor
Initializes a new instance of the SelectUpAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectUpAction()
Public Sub New
See Also

Reference

SelectUpAction Class


SelectUpAction Properties

SelectUpAction Properties

The SelectUpAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectUpAction Class


SelectUpAction Methods

SelectUpAction Methods

The SelectUpAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectUpAction Class


SelectUpAction.Execute Method

SelectUpActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectUpAction Class


SelectWordAction Class

SelectWordAction Class
Represents an IEditAction that selects the current word.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectWordAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectWordAction : EditActionBase
Public Class SelectWordAction
    Inherits EditActionBase

The SelectWordAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectWordAction | Initializes a new instance of the SelectWordAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


SelectWordAction Constructor

SelectWordAction Constructor
Initializes a new instance of the SelectWordAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectWordAction()
Public Sub New
See Also

Reference

SelectWordAction Class


SelectWordAction Properties

SelectWordAction Properties

The SelectWordAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectWordAction Class


SelectWordAction Methods

SelectWordAction Methods

The SelectWordAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

SelectWordAction Class


SelectWordAction.Execute Method

SelectWordActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

SelectWordAction Class


StartAutomaticOutliningAction Class

StartAutomaticOutliningAction Class
Represents an IEditAction that is used to start automatic outlining.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsStartAutomaticOutliningAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StartAutomaticOutliningAction : EditActionBase
Public Class StartAutomaticOutliningAction
    Inherits EditActionBase

The StartAutomaticOutliningAction type exposes the following members.

Constructors
 | Name | Description
Public method | StartAutomaticOutliningAction | Initializes a new instance of the StartAutomaticOutliningAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


StartAutomaticOutliningAction Constructor

StartAutomaticOutliningAction Constructor
Initializes a new instance of the StartAutomaticOutliningAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StartAutomaticOutliningAction()
Public Sub New
See Also

Reference

StartAutomaticOutliningAction Class


StartAutomaticOutliningAction Properties

StartAutomaticOutliningAction Properties

The StartAutomaticOutliningAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

StartAutomaticOutliningAction Class


StartAutomaticOutliningAction Methods

StartAutomaticOutliningAction Methods

The StartAutomaticOutliningAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

StartAutomaticOutliningAction Class


StartAutomaticOutliningAction.CanExecute Method

StartAutomaticOutliningActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

StartAutomaticOutliningAction Class


StartAutomaticOutliningAction.Execute Method

StartAutomaticOutliningActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

StartAutomaticOutliningAction Class


StopHidingCurrentAction Class

StopHidingCurrentAction Class
Represents an IEditAction that is used to stop hiding the outlining node that currently contains the caret, if any.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsStopHidingCurrentAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StopHidingCurrentAction : EditActionBase
Public Class StopHidingCurrentAction
    Inherits EditActionBase

The StopHidingCurrentAction type exposes the following members.

Constructors
 | Name | Description
Public method | StopHidingCurrentAction | Initializes a new instance of the StopHidingCurrentAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


StopHidingCurrentAction Constructor

StopHidingCurrentAction Constructor
Initializes a new instance of the StopHidingCurrentAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StopHidingCurrentAction()
Public Sub New
See Also

Reference

StopHidingCurrentAction Class


StopHidingCurrentAction Properties

StopHidingCurrentAction Properties

The StopHidingCurrentAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

StopHidingCurrentAction Class


StopHidingCurrentAction Methods

StopHidingCurrentAction Methods

The StopHidingCurrentAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

StopHidingCurrentAction Class


StopHidingCurrentAction.CanExecute Method

StopHidingCurrentActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

StopHidingCurrentAction Class


StopHidingCurrentAction.Execute Method

StopHidingCurrentActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

StopHidingCurrentAction Class


StopOutliningAction Class

StopOutliningAction Class
Represents an IEditAction that is used to stop outlining.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsStopOutliningAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StopOutliningAction : EditActionBase
Public Class StopOutliningAction
    Inherits EditActionBase

The StopOutliningAction type exposes the following members.

Constructors
 | Name | Description
Public method | StopOutliningAction | Initializes a new instance of the StopOutliningAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


StopOutliningAction Constructor

StopOutliningAction Constructor
Initializes a new instance of the StopOutliningAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StopOutliningAction()
Public Sub New
See Also

Reference

StopOutliningAction Class


StopOutliningAction Properties

StopOutliningAction Properties

The StopOutliningAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

StopOutliningAction Class


StopOutliningAction Methods

StopOutliningAction Methods

The StopOutliningAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

StopOutliningAction Class


StopOutliningAction.CanExecute Method

StopOutliningActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

StopOutliningAction Class


StopOutliningAction.Execute Method

StopOutliningActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

StopOutliningAction Class


TabifySelectedLinesAction Class

TabifySelectedLinesAction Class
Represents an IEditAction that converts spaces at the beginning of the active view lines to tabs.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsTabifySelectedLinesAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TabifySelectedLinesAction : EditActionBase
Public Class TabifySelectedLinesAction
    Inherits EditActionBase

The TabifySelectedLinesAction type exposes the following members.

Constructors
 | Name | Description
Public method | TabifySelectedLinesAction | Initializes a new instance of the TabifySelectedLinesAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


TabifySelectedLinesAction Constructor

TabifySelectedLinesAction Constructor
Initializes a new instance of the TabifySelectedLinesAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TabifySelectedLinesAction()
Public Sub New
See Also

Reference

TabifySelectedLinesAction Class


TabifySelectedLinesAction Properties

TabifySelectedLinesAction Properties

The TabifySelectedLinesAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

TabifySelectedLinesAction Class


TabifySelectedLinesAction Methods

TabifySelectedLinesAction Methods

The TabifySelectedLinesAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

TabifySelectedLinesAction Class


TabifySelectedLinesAction.CanExecute Method

TabifySelectedLinesActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

TabifySelectedLinesAction Class


TabifySelectedLinesAction.Execute Method

TabifySelectedLinesActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

TabifySelectedLinesAction Class


ToggleAllOutliningExpansionAction Class

ToggleAllOutliningExpansionAction Class
Represents an IEditAction that toggles the collapsed state of all outlining nodes.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsToggleAllOutliningExpansionAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ToggleAllOutliningExpansionAction : EditActionBase
Public Class ToggleAllOutliningExpansionAction
    Inherits EditActionBase

The ToggleAllOutliningExpansionAction type exposes the following members.

Constructors
 | Name | Description
Public method | ToggleAllOutliningExpansionAction | Initializes a new instance of the ToggleAllOutliningExpansionAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


ToggleAllOutliningExpansionAction Constructor

ToggleAllOutliningExpansionAction Constructor
Initializes a new instance of the ToggleAllOutliningExpansionAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToggleAllOutliningExpansionAction()
Public Sub New
See Also

Reference

ToggleAllOutliningExpansionAction Class


ToggleAllOutliningExpansionAction Properties

ToggleAllOutliningExpansionAction Properties

The ToggleAllOutliningExpansionAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

ToggleAllOutliningExpansionAction Class


ToggleAllOutliningExpansionAction Methods

ToggleAllOutliningExpansionAction Methods

The ToggleAllOutliningExpansionAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

ToggleAllOutliningExpansionAction Class


ToggleAllOutliningExpansionAction.CanExecute Method

ToggleAllOutliningExpansionActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

ToggleAllOutliningExpansionAction Class


ToggleAllOutliningExpansionAction.Execute Method

ToggleAllOutliningExpansionActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

ToggleAllOutliningExpansionAction Class


ToggleCharacterCasingAction Class

ToggleCharacterCasingAction Class
Represents an IEditAction that toggles the character casing of the selected text.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsToggleCharacterCasingAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ToggleCharacterCasingAction : EditActionBase
Public Class ToggleCharacterCasingAction
    Inherits EditActionBase

The ToggleCharacterCasingAction type exposes the following members.

Constructors
 | Name | Description
Public method | ToggleCharacterCasingAction | Initializes a new instance of the ToggleCharacterCasingAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
Remarks
If no text is currently selected, only the character after the caret is changed.
See Also

Reference


ToggleCharacterCasingAction Constructor

ToggleCharacterCasingAction Constructor
Initializes a new instance of the ToggleCharacterCasingAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToggleCharacterCasingAction()
Public Sub New
See Also

Reference

ToggleCharacterCasingAction Class


ToggleCharacterCasingAction Properties

ToggleCharacterCasingAction Properties

The ToggleCharacterCasingAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

ToggleCharacterCasingAction Class


ToggleCharacterCasingAction Methods

ToggleCharacterCasingAction Methods

The ToggleCharacterCasingAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

ToggleCharacterCasingAction Class


ToggleCharacterCasingAction.CanExecute Method

ToggleCharacterCasingActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

ToggleCharacterCasingAction Class


ToggleCharacterCasingAction.Execute Method

ToggleCharacterCasingActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

ToggleCharacterCasingAction Class


ToggleMacroRecordingAction Class

ToggleMacroRecordingAction Class
Represents an IEditAction that starts or stops recording a macro, depending on the current state of macro recording.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsToggleMacroRecordingAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ToggleMacroRecordingAction : EditActionBase
Public Class ToggleMacroRecordingAction
    Inherits EditActionBase

The ToggleMacroRecordingAction type exposes the following members.

Constructors
 | Name | Description
Public method | ToggleMacroRecordingAction | Initializes a new instance of the ToggleMacroRecordingAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Overrides EditActionBaseCanRecordInMacro.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


ToggleMacroRecordingAction Constructor

ToggleMacroRecordingAction Constructor
Initializes a new instance of the ToggleMacroRecordingAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToggleMacroRecordingAction()
Public Sub New
See Also

Reference

ToggleMacroRecordingAction Class


ToggleMacroRecordingAction Properties

ToggleMacroRecordingAction Properties

The ToggleMacroRecordingAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Overrides EditActionBaseCanRecordInMacro.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

ToggleMacroRecordingAction Class


ToggleMacroRecordingAction.CanRecordInMacro Property

ToggleMacroRecordingActionCanRecordInMacro Property
Gets whether the action can be recorded in a macro.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanRecordInMacro { get; }
Public Overrides ReadOnly Property CanRecordInMacro As Boolean
    Get

Property Value

Type: Boolean
true if the action can be recorded in a macro; otherwise, false.

Implements

IEditActionCanRecordInMacro
See Also

Reference

ToggleMacroRecordingAction Class


ToggleMacroRecordingAction Methods

ToggleMacroRecordingAction Methods

The ToggleMacroRecordingAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

ToggleMacroRecordingAction Class


ToggleMacroRecordingAction.Execute Method

ToggleMacroRecordingActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

ToggleMacroRecordingAction Class


ToggleOutliningExpansionAction Class

ToggleOutliningExpansionAction Class
Represents an IEditAction that toggles the outlining nodes that intersect with the view line that contains the caret.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsToggleOutliningExpansionAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ToggleOutliningExpansionAction : EditActionBase
Public Class ToggleOutliningExpansionAction
    Inherits EditActionBase

The ToggleOutliningExpansionAction type exposes the following members.

Constructors
 | Name | Description
Public method | ToggleOutliningExpansionAction | Initializes a new instance of the ToggleOutliningExpansionAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


ToggleOutliningExpansionAction Constructor

ToggleOutliningExpansionAction Constructor
Initializes a new instance of the ToggleOutliningExpansionAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToggleOutliningExpansionAction()
Public Sub New
See Also

Reference

ToggleOutliningExpansionAction Class


ToggleOutliningExpansionAction Properties

ToggleOutliningExpansionAction Properties

The ToggleOutliningExpansionAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

ToggleOutliningExpansionAction Class


ToggleOutliningExpansionAction Methods

ToggleOutliningExpansionAction Methods

The ToggleOutliningExpansionAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

ToggleOutliningExpansionAction Class


ToggleOutliningExpansionAction.CanExecute Method

ToggleOutliningExpansionActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

ToggleOutliningExpansionAction Class


ToggleOutliningExpansionAction.Execute Method

ToggleOutliningExpansionActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

ToggleOutliningExpansionAction Class


ToggleOverwriteModeAction Class

ToggleOverwriteModeAction Class
Represents an IEditAction that toggles overwrite mode.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsToggleOverwriteModeAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ToggleOverwriteModeAction : EditActionBase
Public Class ToggleOverwriteModeAction
    Inherits EditActionBase

The ToggleOverwriteModeAction type exposes the following members.

Constructors
 | Name | Description
Public method | ToggleOverwriteModeAction | Initializes a new instance of the ToggleOverwriteModeAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


ToggleOverwriteModeAction Constructor

ToggleOverwriteModeAction Constructor
Initializes a new instance of the ToggleOverwriteModeAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToggleOverwriteModeAction()
Public Sub New
See Also

Reference

ToggleOverwriteModeAction Class


ToggleOverwriteModeAction Properties

ToggleOverwriteModeAction Properties

The ToggleOverwriteModeAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

ToggleOverwriteModeAction Class


ToggleOverwriteModeAction Methods

ToggleOverwriteModeAction Methods

The ToggleOverwriteModeAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

ToggleOverwriteModeAction Class


ToggleOverwriteModeAction.Execute Method

ToggleOverwriteModeActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

ToggleOverwriteModeAction Class


TransposeCharactersAction Class

TransposeCharactersAction Class
Represents an IEditAction that transposes the characters before and after the caret.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsTransposeCharactersAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TransposeCharactersAction : EditActionBase
Public Class TransposeCharactersAction
    Inherits EditActionBase

The TransposeCharactersAction type exposes the following members.

Constructors
 | Name | Description
Public method | TransposeCharactersAction | Initializes a new instance of the TransposeCharactersAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


TransposeCharactersAction Constructor

TransposeCharactersAction Constructor
Initializes a new instance of the TransposeCharactersAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TransposeCharactersAction()
Public Sub New
See Also

Reference

TransposeCharactersAction Class


TransposeCharactersAction Properties

TransposeCharactersAction Properties

The TransposeCharactersAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

TransposeCharactersAction Class


TransposeCharactersAction Methods

TransposeCharactersAction Methods

The TransposeCharactersAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

TransposeCharactersAction Class


TransposeCharactersAction.CanExecute Method

TransposeCharactersActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

TransposeCharactersAction Class


TransposeCharactersAction.Execute Method

TransposeCharactersActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

TransposeCharactersAction Class


TransposeLinesAction Class

TransposeLinesAction Class
Represents an IEditAction that transposes the current view line with the next view line.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsTransposeLinesAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TransposeLinesAction : EditActionBase
Public Class TransposeLinesAction
    Inherits EditActionBase

The TransposeLinesAction type exposes the following members.

Constructors
 | Name | Description
Public method | TransposeLinesAction | Initializes a new instance of the TransposeLinesAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


TransposeLinesAction Constructor

TransposeLinesAction Constructor
Initializes a new instance of the TransposeLinesAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TransposeLinesAction()
Public Sub New
See Also

Reference

TransposeLinesAction Class


TransposeLinesAction Properties

TransposeLinesAction Properties

The TransposeLinesAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

TransposeLinesAction Class


TransposeLinesAction Methods

TransposeLinesAction Methods

The TransposeLinesAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

TransposeLinesAction Class


TransposeLinesAction.CanExecute Method

TransposeLinesActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

TransposeLinesAction Class


TransposeLinesAction.Execute Method

TransposeLinesActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

TransposeLinesAction Class


TransposeWordsAction Class

TransposeWordsAction Class
Represents an IEditAction that transposes the words before and after the caret.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsTransposeWordsAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TransposeWordsAction : EditActionBase
Public Class TransposeWordsAction
    Inherits EditActionBase

The TransposeWordsAction type exposes the following members.

Constructors
 | Name | Description
Public method | TransposeWordsAction | Initializes a new instance of the TransposeWordsAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


TransposeWordsAction Constructor

TransposeWordsAction Constructor
Initializes a new instance of the TransposeWordsAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TransposeWordsAction()
Public Sub New
See Also

Reference

TransposeWordsAction Class


TransposeWordsAction Properties

TransposeWordsAction Properties

The TransposeWordsAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

TransposeWordsAction Class


TransposeWordsAction Methods

TransposeWordsAction Methods

The TransposeWordsAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

TransposeWordsAction Class


TransposeWordsAction.CanExecute Method

TransposeWordsActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

TransposeWordsAction Class


TransposeWordsAction.Execute Method

TransposeWordsActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

TransposeWordsAction Class


TrimAllTrailingWhitespaceAction Class

TrimAllTrailingWhitespaceAction Class
Represents an IEditAction that trims the trailing whitespace off all the lines in the document.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsTrimAllTrailingWhitespaceAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TrimAllTrailingWhitespaceAction : EditActionBase
Public Class TrimAllTrailingWhitespaceAction
    Inherits EditActionBase

The TrimAllTrailingWhitespaceAction type exposes the following members.

Constructors
 | Name | Description
Public method | TrimAllTrailingWhitespaceAction | Initializes a new instance of the TrimAllTrailingWhitespaceAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


TrimAllTrailingWhitespaceAction Constructor

TrimAllTrailingWhitespaceAction Constructor
Initializes a new instance of the TrimAllTrailingWhitespaceAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TrimAllTrailingWhitespaceAction()
Public Sub New
See Also

Reference

TrimAllTrailingWhitespaceAction Class


TrimAllTrailingWhitespaceAction Properties

TrimAllTrailingWhitespaceAction Properties

The TrimAllTrailingWhitespaceAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

TrimAllTrailingWhitespaceAction Class


TrimAllTrailingWhitespaceAction Methods

TrimAllTrailingWhitespaceAction Methods

The TrimAllTrailingWhitespaceAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

TrimAllTrailingWhitespaceAction Class


TrimAllTrailingWhitespaceAction.CanExecute Method

TrimAllTrailingWhitespaceActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

TrimAllTrailingWhitespaceAction Class


TrimAllTrailingWhitespaceAction.Execute Method

TrimAllTrailingWhitespaceActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

TrimAllTrailingWhitespaceAction Class


TrimTrailingWhitespaceAction Class

TrimTrailingWhitespaceAction Class
Represents an IEditAction that trims the trailing whitespace off all the lines in the selected text, or the current document line if no text is selected.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsTrimTrailingWhitespaceAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TrimTrailingWhitespaceAction : EditActionBase
Public Class TrimTrailingWhitespaceAction
    Inherits EditActionBase

The TrimTrailingWhitespaceAction type exposes the following members.

Constructors
 | Name | Description
Public method | TrimTrailingWhitespaceAction | Initializes a new instance of the TrimTrailingWhitespaceAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


TrimTrailingWhitespaceAction Constructor

TrimTrailingWhitespaceAction Constructor
Initializes a new instance of the TrimTrailingWhitespaceAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TrimTrailingWhitespaceAction()
Public Sub New
See Also

Reference

TrimTrailingWhitespaceAction Class


TrimTrailingWhitespaceAction Properties

TrimTrailingWhitespaceAction Properties

The TrimTrailingWhitespaceAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

TrimTrailingWhitespaceAction Class


TrimTrailingWhitespaceAction Methods

TrimTrailingWhitespaceAction Methods

The TrimTrailingWhitespaceAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

TrimTrailingWhitespaceAction Class


TrimTrailingWhitespaceAction.CanExecute Method

TrimTrailingWhitespaceActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

TrimTrailingWhitespaceAction Class


TrimTrailingWhitespaceAction.Execute Method

TrimTrailingWhitespaceActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

TrimTrailingWhitespaceAction Class


TypingAction Class

TypingAction Class
Represents an IEditAction that performs typing in a document.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsTypingAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TypingAction : EditActionBase
Public Class TypingAction
    Inherits EditActionBase

The TypingAction type exposes the following members.

Constructors
 | Name | Description
Public method | TypingAction | Initializes a new instance of the TypingCommand class.
Public method | TypingAction(String, Boolean) | Initializes a new instance of the TypingCommand class.
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Public property | Overwrite | Gets whether the text will be added in overwrite mode.
Public property | Text | Gets the text that will be typed.
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Overrides EditActionBaseReadFromXml(XmlReader).)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Overrides EditActionBaseWriteToXml(XmlWriter).)
Top
See Also

Reference


TypingAction Constructor

TypingAction Constructor
Overload List
 | Name | Description
Public method | TypingAction | Initializes a new instance of the TypingCommand class.
Public method | TypingAction(String, Boolean) | Initializes a new instance of the TypingCommand class.
Top
See Also

Reference

TypingAction Class


TypingAction Constructor

TypingAction Constructor
Initializes a new instance of the TypingCommand class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TypingAction()
Public Sub New
See Also

Reference

TypingAction Class
TypingAction Overload


TypingAction Constructor (String, Boolean)

TypingAction Constructor (String, Boolean)
Initializes a new instance of the TypingCommand class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TypingAction(
    string text,
    bool overwrite
)
Public Sub New (
    text As String,
    overwrite As Boolean
)

Parameters

text
Type: SystemString
The text that will be typed.
overwrite
Type: SystemBoolean
Whether the text will be added in overwrite mode.
See Also

Reference

TypingAction Class
TypingAction Overload


TypingAction Properties

TypingAction Properties

The TypingAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Public property | Overwrite | Gets whether the text will be added in overwrite mode.
Public property | Text | Gets the text that will be typed.
Top
See Also

Reference

TypingAction Class


TypingAction.Overwrite Property

TypingActionOverwrite Property
Gets whether the text will be added in overwrite mode.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Overwrite { get; }
Public ReadOnly Property Overwrite As Boolean
    Get

Property Value

Type: Boolean
true if the text will be added in overwrite mode; otherwise, false.
See Also

Reference

TypingAction Class


TypingAction.Text Property

TypingActionText Property
Gets the text that will be typed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get

Property Value

Type: String
The text that will be typed.
See Also

Reference

TypingAction Class


TypingAction Methods

TypingAction Methods

The TypingAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Inherited from EditActionBase.)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Overrides EditActionBaseReadFromXml(XmlReader).)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Overrides EditActionBaseWriteToXml(XmlWriter).)
Top
See Also

Reference

TypingAction Class


TypingAction.Execute Method

TypingActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

TypingAction Class


TypingAction.ReadFromXml Method

TypingActionReadFromXml Method
Deserializes the data for the IEditAction from XML.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void ReadFromXml(
    XmlReader reader
)
Public Overrides Sub ReadFromXml (
    reader As XmlReader
)

Parameters

reader
Type: System.XmlXmlReader
The XmlReader to use.

Implements

IEditActionReadFromXml(XmlReader)
Remarks
This method is used for macro serialization.
See Also

Reference

TypingAction Class


TypingAction.WriteToXml Method

TypingActionWriteToXml Method
Serializes the data for the IEditAction to XML.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void WriteToXml(
    XmlWriter writer
)
Public Overrides Sub WriteToXml (
    writer As XmlWriter
)

Parameters

writer
Type: System.XmlXmlWriter
The XmlWriter to use.

Implements

IEditActionWriteToXml(XmlWriter)
Remarks
This method is used for macro serialization.
See Also

Reference

TypingAction Class


UncommentLinesAction Class

UncommentLinesAction Class
Represents an IEditAction that uncomments the currently selected lines.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsUncommentLinesAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class UncommentLinesAction : EditActionBase
Public Class UncommentLinesAction
    Inherits EditActionBase

The UncommentLinesAction type exposes the following members.

Constructors
 | Name | Description
Public method | UncommentLinesAction | Initializes a new instance of the UncommentLinesAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


UncommentLinesAction Constructor

UncommentLinesAction Constructor
Initializes a new instance of the UncommentLinesAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public UncommentLinesAction()
Public Sub New
See Also

Reference

UncommentLinesAction Class


UncommentLinesAction Properties

UncommentLinesAction Properties

The UncommentLinesAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

UncommentLinesAction Class


UncommentLinesAction Methods

UncommentLinesAction Methods

The UncommentLinesAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

UncommentLinesAction Class


UncommentLinesAction.CanExecute Method

UncommentLinesActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

UncommentLinesAction Class


UncommentLinesAction.Execute Method

UncommentLinesActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

UncommentLinesAction Class


UndoAction Class

UndoAction Class
Represents an IEditAction that performs an undo operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsUndoAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class UndoAction : EditActionBase
Public Class UndoAction
    Inherits EditActionBase

The UndoAction type exposes the following members.

Constructors
 | Name | Description
Public method | UndoAction | Initializes a new instance of the UndoAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


UndoAction Constructor

UndoAction Constructor
Initializes a new instance of the UndoAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public UndoAction()
Public Sub New
See Also

Reference

UndoAction Class


UndoAction Properties

UndoAction Properties

The UndoAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

UndoAction Class


UndoAction Methods

UndoAction Methods

The UndoAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

UndoAction Class


UndoAction.CanExecute Method

UndoActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

UndoAction Class


UndoAction.Execute Method

UndoActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

UndoAction Class


UntabifySelectedLinesAction Class

UntabifySelectedLinesAction Class
Represents an IEditAction that converts tabs at the beginning of the active view lines to spaces.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsUntabifySelectedLinesAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class UntabifySelectedLinesAction : EditActionBase
Public Class UntabifySelectedLinesAction
    Inherits EditActionBase

The UntabifySelectedLinesAction type exposes the following members.

Constructors
 | Name | Description
Public method | UntabifySelectedLinesAction | Initializes a new instance of the UntabifySelectedLinesAction class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference


UntabifySelectedLinesAction Constructor

UntabifySelectedLinesAction Constructor
Initializes a new instance of the UntabifySelectedLinesAction class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public UntabifySelectedLinesAction()
Public Sub New
See Also

Reference

UntabifySelectedLinesAction Class


UntabifySelectedLinesAction Properties

UntabifySelectedLinesAction Properties

The UntabifySelectedLinesAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro. (Inherited from EditActionBase.)
Public property | Key | Gets the string key that uniquely identifies the edit action. (Inherited from EditActionBase.)
Top
See Also

Reference

UntabifySelectedLinesAction Class


UntabifySelectedLinesAction Methods

UntabifySelectedLinesAction Methods

The UntabifySelectedLinesAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView. (Overrides EditActionBaseCanExecute(IEditorView).)
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView. (Overrides EditActionBaseExecute(IEditorView).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML. (Inherited from EditActionBase.)
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML. (Inherited from EditActionBase.)
Top
See Also

Reference

UntabifySelectedLinesAction Class


UntabifySelectedLinesAction.CanExecute Method

UntabifySelectedLinesActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanExecute(
    IEditorView view
)
Public Overrides Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

UntabifySelectedLinesAction Class


UntabifySelectedLinesAction.Execute Method

UntabifySelectedLinesActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Execute(
    IEditorView view
)
Public Overrides Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

UntabifySelectedLinesAction Class


ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace
Contains types related to highlighting.
Classes
 | Class | Description
Public class | AmbientHighlightingStyleRegistry | Represents the global registry of IHighlightingStyle data.
Public class | HighlightingStyleBorderCornerStyle | Specifies the corner style of an IHighlightingStyle border.
Public class | HighlightingStyleLineStyle | Specifies the style of an IHighlightingStyle line, used for borders, strike-throughs, and underlines.
Interfaces
 | Interface | Description
Public interface | IHighlightingStyle | Represents the base requirements for a highlighting style that is applied to a span of text.
Public interface | IHighlightingStyleRegistry | Provides the base requirements for a registry of IClassificationType to IHighlightingStyle mapping data.
Public interface | IHighlightingStyleRegistryProvider | Provides the base requirements for an object that can provide a custom IHighlightingStyleRegistry.


AmbientHighlightingStyleRegistry Class

AmbientHighlightingStyleRegistry Class
Represents the global registry of IHighlightingStyle data.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.ImplementationHighlightingStyleRegistry
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.HighlightingAmbientHighlightingStyleRegistry

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class AmbientHighlightingStyleRegistry : HighlightingStyleRegistry
Public NotInheritable Class AmbientHighlightingStyleRegistry
    Inherits HighlightingStyleRegistry

The AmbientHighlightingStyleRegistry type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationTypes | Gets the collection of IClassificationType objects that have been registered. (Inherited from HighlightingStyleRegistry.)
Public property | Count | Gets the number of entries in the registry. (Inherited from HighlightingStyleRegistry.)
Public property | Description | Gets or sets the description of the registry. (Inherited from HighlightingStyleRegistry.)
Public property | HighlightingStyles | Gets the collection of IHighlightingStyle objects that have been registered. (Inherited from HighlightingStyleRegistry.)
 | Instance | Gets an instance of the global classification type registry.
Public property | Item | Gets the IHighlightingStyle registered with the specified IClassificationType. [C#] In C#, this property is the indexer for the IHighlightingStyleRegistry interface. (Inherited from HighlightingStyleRegistry.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetClassificationType | Returns the IClassificationType, if any, that has been registered with the specified key. (Inherited from HighlightingStyleRegistry.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from HighlightingStyleRegistry.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event. (Inherited from HighlightingStyleRegistry.)
Public method | Register(IClassificationType, IHighlightingStyle) | Attempts to adds an IHighlightingStyle for the specified IClassificationType into the registry, as long as there is no existing IHighlightingStyle registered with the same IClassificationType. (Inherited from HighlightingStyleRegistry.)
Public method | Register(IClassificationType, IHighlightingStyle, Boolean) | Adds an IHighlightingStyle into the registry, optionally overwriting any existing IHighlightingStyle registered with the same IClassificationType. (Inherited from HighlightingStyleRegistry.)
Public method | ToString | (Inherited from Object.)
Public method | Unregister | Removes a registry entry with the specified IClassificationType from the registry. (Inherited from HighlightingStyleRegistry.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after a change has occurred to the items in the registry. (Inherited from HighlightingStyleRegistry.)
Top
Remarks
This class is a singleton.
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


AmbientHighlightingStyleRegistry Properties

AmbientHighlightingStyleRegistry Properties

The AmbientHighlightingStyleRegistry type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationTypes | Gets the collection of IClassificationType objects that have been registered. (Inherited from HighlightingStyleRegistry.)
Public property | Count | Gets the number of entries in the registry. (Inherited from HighlightingStyleRegistry.)
Public property | Description | Gets or sets the description of the registry. (Inherited from HighlightingStyleRegistry.)
Public property | HighlightingStyles | Gets the collection of IHighlightingStyle objects that have been registered. (Inherited from HighlightingStyleRegistry.)
 | Instance | Gets an instance of the global classification type registry.
Public property | Item | Gets the IHighlightingStyle registered with the specified IClassificationType. [C#] In C#, this property is the indexer for the IHighlightingStyleRegistry interface. (Inherited from HighlightingStyleRegistry.)
Top
See Also

Reference

AmbientHighlightingStyleRegistry Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


AmbientHighlightingStyleRegistry.Instance Property

AmbientHighlightingStyleRegistryInstance Property
Gets an instance of the global classification type registry.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IHighlightingStyleRegistry Instance { get; }
Public Shared ReadOnly Property Instance As IHighlightingStyleRegistry
    Get

Property Value

Type: IHighlightingStyleRegistry
An instance of the global classification type registry.
See Also

Reference

AmbientHighlightingStyleRegistry Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


AmbientHighlightingStyleRegistry Methods

AmbientHighlightingStyleRegistry Methods

The AmbientHighlightingStyleRegistry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetClassificationType | Returns the IClassificationType, if any, that has been registered with the specified key. (Inherited from HighlightingStyleRegistry.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from HighlightingStyleRegistry.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event. (Inherited from HighlightingStyleRegistry.)
Public method | Register(IClassificationType, IHighlightingStyle) | Attempts to adds an IHighlightingStyle for the specified IClassificationType into the registry, as long as there is no existing IHighlightingStyle registered with the same IClassificationType. (Inherited from HighlightingStyleRegistry.)
Public method | Register(IClassificationType, IHighlightingStyle, Boolean) | Adds an IHighlightingStyle into the registry, optionally overwriting any existing IHighlightingStyle registered with the same IClassificationType. (Inherited from HighlightingStyleRegistry.)
Public method | ToString | (Inherited from Object.)
Public method | Unregister | Removes a registry entry with the specified IClassificationType from the registry. (Inherited from HighlightingStyleRegistry.)
Top
See Also

Reference

AmbientHighlightingStyleRegistry Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


AmbientHighlightingStyleRegistry Events

AmbientHighlightingStyleRegistry Events

The AmbientHighlightingStyleRegistry type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after a change has occurred to the items in the registry. (Inherited from HighlightingStyleRegistry.)
Top
See Also

Reference

AmbientHighlightingStyleRegistry Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


HighlightingStyleBorderCornerStyle Class

HighlightingStyleBorderCornerStyle Class
Specifies the corner style of an IHighlightingStyle border.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.HighlightingHighlightingStyleBorderCornerStyle

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class HighlightingStyleBorderCornerStyle : Enum
Public NotInheritable Class HighlightingStyleBorderCornerStyle
    Inherits Enum

The HighlightingStyleBorderCornerStyle type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | SinglePixelRounded | Draws a single-pixel rounded border.
 | Square | Draw a square border.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


HighlightingStyleBorderCornerStyle Methods

HighlightingStyleBorderCornerStyle Methods

The HighlightingStyleBorderCornerStyle type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

HighlightingStyleBorderCornerStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


HighlightingStyleBorderCornerStyle Fields

HighlightingStyleBorderCornerStyle Fields

The HighlightingStyleBorderCornerStyle type exposes the following members.

Fields
 | Name | Description
 | SinglePixelRounded | Draws a single-pixel rounded border.
 | Square | Draw a square border.
Public field | value__ |
Top
See Also

Reference

HighlightingStyleBorderCornerStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


HighlightingStyleBorderCornerStyle.SinglePixelRounded Field

HighlightingStyleBorderCornerStyleSinglePixelRounded Field
Draws a single-pixel rounded border.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const HighlightingStyleBorderCornerStyle SinglePixelRounded = 1
Public Const SinglePixelRounded As HighlightingStyleBorderCornerStyle = 1

Field Value

Type: HighlightingStyleBorderCornerStyle
See Also

Reference

HighlightingStyleBorderCornerStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


HighlightingStyleBorderCornerStyle.Square Field

HighlightingStyleBorderCornerStyleSquare Field
Draw a square border.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const HighlightingStyleBorderCornerStyle Square = 0
Public Const Square As HighlightingStyleBorderCornerStyle = 0

Field Value

Type: HighlightingStyleBorderCornerStyle
See Also

Reference

HighlightingStyleBorderCornerStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


HighlightingStyleBorderCornerStyle.value__ Field

HighlightingStyleBorderCornerStylevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.HighlightingStyleBorderCornerStyle.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

HighlightingStyleBorderCornerStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


HighlightingStyleLineStyle Class

HighlightingStyleLineStyle Class
Specifies the style of an IHighlightingStyle line, used for borders, strike-throughs, and underlines.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.HighlightingHighlightingStyleLineStyle

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class HighlightingStyleLineStyle : Enum
Public NotInheritable Class HighlightingStyleLineStyle
    Inherits Enum

The HighlightingStyleLineStyle type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Dash | Draw a line with a dash pattern.
 | DashDot | Draw a line with a dash-dot pattern.
 | Default | Use the default resolved settings.
 | Dot | Draw a line with a dot pattern.
 | None | Don't draw a line.
 | Solid | Draw a solid line.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


HighlightingStyleLineStyle Methods

HighlightingStyleLineStyle Methods

The HighlightingStyleLineStyle type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

HighlightingStyleLineStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


HighlightingStyleLineStyle Fields

HighlightingStyleLineStyle Fields

The HighlightingStyleLineStyle type exposes the following members.

Fields
 | Name | Description
 | Dash | Draw a line with a dash pattern.
 | DashDot | Draw a line with a dash-dot pattern.
 | Default | Use the default resolved settings.
 | Dot | Draw a line with a dot pattern.
 | None | Don't draw a line.
 | Solid | Draw a solid line.
Public field | value__ |
Top
See Also

Reference

HighlightingStyleLineStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


HighlightingStyleLineStyle.Dash Field

HighlightingStyleLineStyleDash Field
Draw a line with a dash pattern.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const HighlightingStyleLineStyle Dash = 3
Public Const Dash As HighlightingStyleLineStyle = 3

Field Value

Type: HighlightingStyleLineStyle
See Also

Reference

HighlightingStyleLineStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


HighlightingStyleLineStyle.DashDot Field

HighlightingStyleLineStyleDashDot Field
Draw a line with a dash-dot pattern.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const HighlightingStyleLineStyle DashDot = 1
Public Const DashDot As HighlightingStyleLineStyle = 1

Field Value

Type: HighlightingStyleLineStyle
See Also

Reference

HighlightingStyleLineStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


HighlightingStyleLineStyle.Default Field

HighlightingStyleLineStyleDefault Field
Use the default resolved settings.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const HighlightingStyleLineStyle Default = 6
Public Const Default As HighlightingStyleLineStyle = 6

Field Value

Type: HighlightingStyleLineStyle
See Also

Reference

HighlightingStyleLineStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


HighlightingStyleLineStyle.Dot Field

HighlightingStyleLineStyleDot Field
Draw a line with a dot pattern.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const HighlightingStyleLineStyle Dot = 2
Public Const Dot As HighlightingStyleLineStyle = 2

Field Value

Type: HighlightingStyleLineStyle
See Also

Reference

HighlightingStyleLineStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


HighlightingStyleLineStyle.None Field

HighlightingStyleLineStyleNone Field
Don't draw a line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const HighlightingStyleLineStyle None = 5
Public Const None As HighlightingStyleLineStyle = 5

Field Value

Type: HighlightingStyleLineStyle
See Also

Reference

HighlightingStyleLineStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


HighlightingStyleLineStyle.Solid Field

HighlightingStyleLineStyleSolid Field
Draw a solid line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const HighlightingStyleLineStyle Solid = 0
Public Const Solid As HighlightingStyleLineStyle = 0

Field Value

Type: HighlightingStyleLineStyle
See Also

Reference

HighlightingStyleLineStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


HighlightingStyleLineStyle.value__ Field

HighlightingStyleLineStylevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.HighlightingStyleLineStyle.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

HighlightingStyleLineStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle Interface

IHighlightingStyle Interface
Represents the base requirements for a highlighting style that is applied to a span of text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IHighlightingStyle : INotifyPropertyChanged
Public Interface IHighlightingStyle
    Inherits INotifyPropertyChanged

The IHighlightingStyle type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush of the highlighting style.
Public property | BackgroundSpansVirtualSpace | Gets or sets a nullable Boolean indicating whether the background should span virtual space when the styled range includes a line terminator.
Public property | Bold | Gets or sets a nullable Boolean indicating whether the highlighting style uses boldface.
Public property | BorderBrush | Gets or sets the border brush of the highlighting style.
Public property | BorderCornerStyle | Gets or sets a HighlightingStyleBorderCornerStyle indicating the style of border corners.
Public property | BorderStyle | Gets or sets a HighlightingStyleLineStyle indicating the style of border to use.
Public property | FontFamilyName | Gets or sets the name of the font family to use for drawing text with the highlighting style.
Public property | FontSize | Gets or sets the size of the font to use for drawing text with the highlighting style.
Public property | Foreground | Gets or sets the foreground brush of the highlighting style.
Public property | HasBackground | Gets whether the highlighting style contains has a background.
Public property | HasBorder | Gets whether the highlighting style has a border.
Public property | HasDefaultFormatting | Gets whether the highlighting style contains all default values for formatting properties.
Public property | HasFontChange | Gets whether the highlighting style contains a font-related change.
Public property | IsBackgroundEditable | Gets whether the Background property is editable in an options dialog.
Public property | IsBoldEditable | Gets whether the Bold property is editable in an options dialog.
Public property | IsBorderEditable | Gets whether the BorderBrush and related properties are editable in an options dialog.
Public property | IsForegroundEditable | Gets whether the Foreground property is editable in an options dialog.
Public property | IsItalicEditable | Gets whether the Italic property is editable in an options dialog.
Public property | Italic | Gets or sets a nullable Boolean indicating whether the highlighting style uses italics.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.ImplementationHighlightingStyle


IHighlightingStyle Properties

IHighlightingStyle Properties

The IHighlightingStyle type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush of the highlighting style.
Public property | BackgroundSpansVirtualSpace | Gets or sets a nullable Boolean indicating whether the background should span virtual space when the styled range includes a line terminator.
Public property | Bold | Gets or sets a nullable Boolean indicating whether the highlighting style uses boldface.
Public property | BorderBrush | Gets or sets the border brush of the highlighting style.
Public property | BorderCornerStyle | Gets or sets a HighlightingStyleBorderCornerStyle indicating the style of border corners.
Public property | BorderStyle | Gets or sets a HighlightingStyleLineStyle indicating the style of border to use.
Public property | FontFamilyName | Gets or sets the name of the font family to use for drawing text with the highlighting style.
Public property | FontSize | Gets or sets the size of the font to use for drawing text with the highlighting style.
Public property | Foreground | Gets or sets the foreground brush of the highlighting style.
Public property | HasBackground | Gets whether the highlighting style contains has a background.
Public property | HasBorder | Gets whether the highlighting style has a border.
Public property | HasDefaultFormatting | Gets whether the highlighting style contains all default values for formatting properties.
Public property | HasFontChange | Gets whether the highlighting style contains a font-related change.
Public property | IsBackgroundEditable | Gets whether the Background property is editable in an options dialog.
Public property | IsBoldEditable | Gets whether the Bold property is editable in an options dialog.
Public property | IsBorderEditable | Gets whether the BorderBrush and related properties are editable in an options dialog.
Public property | IsForegroundEditable | Gets whether the Foreground property is editable in an options dialog.
Public property | IsItalicEditable | Gets whether the Italic property is editable in an options dialog.
Public property | Italic | Gets or sets a nullable Boolean indicating whether the highlighting style uses italics.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle.Background Property

IHighlightingStyleBackground Property
Gets or sets the background brush of the highlighting style.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Brush Background { get; set; }
Property Background As Brush
    Get
    Set

Property Value

Type: Brush
A Brush indicating the background brush of the highlighting style.
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle.BackgroundSpansVirtualSpace Property

IHighlightingStyleBackgroundSpansVirtualSpace Property
Gets or sets a nullable Boolean indicating whether the background should span virtual space when the styled range includes a line terminator.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<bool> BackgroundSpansVirtualSpace { get; set; }
Property BackgroundSpansVirtualSpace As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean indicating whether the background should span virtual space when the styled range includes a line terminator.
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle.Bold Property

IHighlightingStyleBold Property
Gets or sets a nullable Boolean indicating whether the highlighting style uses boldface.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<bool> Bold { get; set; }
Property Bold As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean indicating whether the highlighting style uses boldface.
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle.BorderBrush Property

IHighlightingStyleBorderBrush Property
Gets or sets the border brush of the highlighting style.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Brush BorderBrush { get; set; }
Property BorderBrush As Brush
    Get
    Set

Property Value

Type: Brush
A Brush indicating the border brush of the highlighting style.
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle.BorderCornerStyle Property

IHighlightingStyleBorderCornerStyle Property
Gets or sets a HighlightingStyleBorderCornerStyle indicating the style of border corners.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
HighlightingStyleBorderCornerStyle BorderCornerStyle { get; set; }
Property BorderCornerStyle As HighlightingStyleBorderCornerStyle
    Get
    Set

Property Value

Type: HighlightingStyleBorderCornerStyle
A HighlightingStyleBorderCornerStyle indicating the style of border corners. Specify HighlightingStyleBorderCornerStyle.Default to use a default style, which is the default property value.
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle.BorderStyle Property

IHighlightingStyleBorderStyle Property
Gets or sets a HighlightingStyleLineStyle indicating the style of border to use.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
HighlightingStyleLineStyle BorderStyle { get; set; }
Property BorderStyle As HighlightingStyleLineStyle
    Get
    Set

Property Value

Type: HighlightingStyleLineStyle
A HighlightingStyleLineStyle indicating the style of border to use.
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle.FontFamilyName Property

IHighlightingStyleFontFamilyName Property
Gets or sets the name of the font family to use for drawing text with the highlighting style.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string FontFamilyName { get; set; }
Property FontFamilyName As String
    Get
    Set

Property Value

Type: String
The name of the font family to use for drawing text with the highlighting style.
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle.FontSize Property

IHighlightingStyleFontSize Property
Gets or sets the size of the font to use for drawing text with the highlighting style.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
double FontSize { get; set; }
Property FontSize As Double
    Get
    Set

Property Value

Type: Double
The size of the font to use for drawing text with the highlighting style. Specify 0 to use a default value, which is the default property value.
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle.Foreground Property

IHighlightingStyleForeground Property
Gets or sets the foreground brush of the highlighting style.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Brush Foreground { get; set; }
Property Foreground As Brush
    Get
    Set

Property Value

Type: Brush
A Brush indicating the foreground brush of the highlighting style.
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle.HasBackground Property

IHighlightingStyleHasBackground Property
Gets whether the highlighting style contains has a background.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasBackground { get; }
ReadOnly Property HasBackground As Boolean
    Get

Property Value

Type: Boolean
true if the highlighting style contains has a background; otherwise, false.
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle.HasBorder Property

IHighlightingStyleHasBorder Property
Gets whether the highlighting style has a border.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasBorder { get; }
ReadOnly Property HasBorder As Boolean
    Get

Property Value

Type: Boolean
true if the highlighting style has a border; otherwise, false.
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle.HasDefaultFormatting Property

IHighlightingStyleHasDefaultFormatting Property
Gets whether the highlighting style contains all default values for formatting properties.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasDefaultFormatting { get; }
ReadOnly Property HasDefaultFormatting As Boolean
    Get

Property Value

Type: Boolean
true if the highlighting style contains all default values for formatting properties; otherwise, false.
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle.HasFontChange Property

IHighlightingStyleHasFontChange Property
Gets whether the highlighting style contains a font-related change.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasFontChange { get; }
ReadOnly Property HasFontChange As Boolean
    Get

Property Value

Type: Boolean
true if the highlighting style contains a font-related change; otherwise, false.
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle.IsBackgroundEditable Property

IHighlightingStyleIsBackgroundEditable Property
Gets whether the Background property is editable in an options dialog.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsBackgroundEditable { get; set; }
Property IsBackgroundEditable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Background property is editable in an options dialog; otherwise, false. The default value is true.
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle.IsBoldEditable Property

IHighlightingStyleIsBoldEditable Property
Gets whether the Bold property is editable in an options dialog.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsBoldEditable { get; set; }
Property IsBoldEditable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Bold property is editable in an options dialog; otherwise, false. The default value is true.
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle.IsBorderEditable Property

IHighlightingStyleIsBorderEditable Property
Gets whether the BorderBrush and related properties are editable in an options dialog.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsBorderEditable { get; set; }
Property IsBorderEditable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the BorderBrush and related properties are editable in an options dialog; otherwise, false. The default value is false.
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle.IsForegroundEditable Property

IHighlightingStyleIsForegroundEditable Property
Gets whether the Foreground property is editable in an options dialog.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsForegroundEditable { get; set; }
Property IsForegroundEditable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Foreground property is editable in an options dialog; otherwise, false. The default value is true.
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle.IsItalicEditable Property

IHighlightingStyleIsItalicEditable Property
Gets whether the Italic property is editable in an options dialog.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsItalicEditable { get; set; }
Property IsItalicEditable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Italic property is editable in an options dialog; otherwise, false. The default value is true.
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle.Italic Property

IHighlightingStyleItalic Property
Gets or sets a nullable Boolean indicating whether the highlighting style uses italics.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<bool> Italic { get; set; }
Property Italic As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean indicating whether the highlighting style uses italics.
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle.Tag Property

IHighlightingStyleTag Property
Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Tag { get; set; }
Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the style. The default is .
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyle Events

IHighlightingStyle Events

The IHighlightingStyle type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IHighlightingStyle Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyleRegistry Interface

IHighlightingStyleRegistry Interface
Provides the base requirements for a registry of IClassificationType to IHighlightingStyle mapping data.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IHighlightingStyleRegistry : IClassificationTypeRegistry,
    IEnumerable<IClassificationType>, IEnumerable, IEnumerable<KeyValuePair<IClassificationType, IHighlightingStyle>>
Public Interface IHighlightingStyleRegistry
    Inherits IClassificationTypeRegistry, IEnumerable(Of IClassificationType), IEnumerable,
    IEnumerable(Of KeyValuePair(Of IClassificationType, IHighlightingStyle))

The IHighlightingStyleRegistry type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationTypes | Gets the collection of IClassificationType objects that have been registered.
Public property | Count | Gets the number of entries in the registry. (Inherited from IClassificationTypeRegistry.)
Public property | Description | Gets or sets the description of the registry.
Public property | HighlightingStyles | Gets the collection of IHighlightingStyle objects that have been registered.
Public property | ItemString | Gets the IClassificationType with the specified key. [C#] In C#, this property is the indexer for the IClassificationTypeRegistry interface. (Inherited from IClassificationTypeRegistry.)
Public property | ItemIClassificationType | Gets the IHighlightingStyle registered with the specified IClassificationType. [C#] In C#, this property is the indexer for the IHighlightingStyleRegistry interface.
Top
Methods
 | Name | Description
Public method | GetClassificationType | Returns the IClassificationType, if any, that has been registered with the specified key.
Public method | GetEnumerator | (Inherited from IEnumerable IClassificationType .)
Public method | Register(IClassificationType, IHighlightingStyle) | Attempts to adds an IHighlightingStyle for the specified IClassificationType into the registry, as long as there is no existing IHighlightingStyle registered with the same IClassificationType.
Public method | Register(IClassificationType, IHighlightingStyle, Boolean) | Adds an IHighlightingStyle into the registry, optionally overwriting any existing IHighlightingStyle registered with the same IClassificationType.
Public method | Unregister | Removes a registry entry with the specified IClassificationType from the registry.
Top
Events
 | Name | Description
Public event | Changed | Occurs after a change has occurred to the items in the registry.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.ImplementationHighlightingStyleRegistry


IHighlightingStyleRegistry Properties

IHighlightingStyleRegistry Properties

The IHighlightingStyleRegistry type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationTypes | Gets the collection of IClassificationType objects that have been registered.
Public property | Count | Gets the number of entries in the registry. (Inherited from IClassificationTypeRegistry.)
Public property | Description | Gets or sets the description of the registry.
Public property | HighlightingStyles | Gets the collection of IHighlightingStyle objects that have been registered.
Public property | ItemString | Gets the IClassificationType with the specified key. [C#] In C#, this property is the indexer for the IClassificationTypeRegistry interface. (Inherited from IClassificationTypeRegistry.)
Public property | ItemIClassificationType | Gets the IHighlightingStyle registered with the specified IClassificationType. [C#] In C#, this property is the indexer for the IHighlightingStyleRegistry interface.
Top
See Also

Reference

IHighlightingStyleRegistry Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyleRegistry.ClassificationTypes Property

IHighlightingStyleRegistryClassificationTypes Property
Gets the collection of IClassificationType objects that have been registered.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ICollection<IClassificationType> ClassificationTypes { get; }
ReadOnly Property ClassificationTypes As ICollection(Of IClassificationType)
    Get

Property Value

Type: ICollection IClassificationType
The collection of IClassificationType objects that have been registered.
See Also

Reference

IHighlightingStyleRegistry Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyleRegistry.Description Property

IHighlightingStyleRegistryDescription Property
Gets or sets the description of the registry.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Description { get; set; }
Property Description As String
    Get
    Set

Property Value

Type: String
The description of the registry.
See Also

Reference

IHighlightingStyleRegistry Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyleRegistry.HighlightingStyles Property

IHighlightingStyleRegistryHighlightingStyles Property
Gets the collection of IHighlightingStyle objects that have been registered.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ICollection<IHighlightingStyle> HighlightingStyles { get; }
ReadOnly Property HighlightingStyles As ICollection(Of IHighlightingStyle)
    Get

Property Value

Type: ICollection IHighlightingStyle
The collection of IHighlightingStyle objects that have been registered.
See Also

Reference

IHighlightingStyleRegistry Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyleRegistry.Item Property

IHighlightingStyleRegistryItem Property
Overload List
 | Name | Description
Public property | ItemString | Gets the IClassificationType with the specified key. [C#] In C#, this property is the indexer for the IClassificationTypeRegistry interface. (Inherited from IClassificationTypeRegistry.)
Public property | ItemIClassificationType | Gets the IHighlightingStyle registered with the specified IClassificationType. [C#] In C#, this property is the indexer for the IHighlightingStyleRegistry interface.
Top
See Also

Reference

IHighlightingStyleRegistry Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyleRegistry.Item Property (IClassificationType)

IHighlightingStyleRegistryItem Property (IClassificationType)
Gets the IHighlightingStyle registered with the specified IClassificationType.

[C#] In C#, this property is the indexer for the IHighlightingStyleRegistry interface.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IHighlightingStyle this[
    IClassificationType classificationType
] { get; }
ReadOnly Property Item (
    classificationType As IClassificationType
) As IHighlightingStyle
    Get

Parameters

classificationType
Type: ActiproSoftware.TextIClassificationType
The IClassificationType for which to search.

Property Value

Type: IHighlightingStyle
The IHighlightingStyle registered with the specified IClassificationType.
See Also

Reference

IHighlightingStyleRegistry Interface
Item Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyleRegistry Methods

IHighlightingStyleRegistry Methods

The IHighlightingStyleRegistry type exposes the following members.

Methods
 | Name | Description
Public method | GetClassificationType | Returns the IClassificationType, if any, that has been registered with the specified key.
Public method | GetEnumerator | (Inherited from IEnumerable IClassificationType .)
Public method | Register(IClassificationType, IHighlightingStyle) | Attempts to adds an IHighlightingStyle for the specified IClassificationType into the registry, as long as there is no existing IHighlightingStyle registered with the same IClassificationType.
Public method | Register(IClassificationType, IHighlightingStyle, Boolean) | Adds an IHighlightingStyle into the registry, optionally overwriting any existing IHighlightingStyle registered with the same IClassificationType.
Public method | Unregister | Removes a registry entry with the specified IClassificationType from the registry.
Top
See Also

Reference

IHighlightingStyleRegistry Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyleRegistry.GetClassificationType Method

IHighlightingStyleRegistryGetClassificationType Method
Returns the IClassificationType, if any, that has been registered with the specified key.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType GetClassificationType(
    string key
)
Function GetClassificationType (
    key As String
) As IClassificationType

Parameters

key
Type: SystemString
The key for which to search.

Return Value

Type: IClassificationType
The IClassificationType, if any, that has been registered with the specified key.
See Also

Reference

IHighlightingStyleRegistry Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyleRegistry.Register Method

IHighlightingStyleRegistryRegister Method
Overload List
 | Name | Description
Public method | Register(IClassificationType, IHighlightingStyle) | Attempts to adds an IHighlightingStyle for the specified IClassificationType into the registry, as long as there is no existing IHighlightingStyle registered with the same IClassificationType.
Public method | Register(IClassificationType, IHighlightingStyle, Boolean) | Adds an IHighlightingStyle into the registry, optionally overwriting any existing IHighlightingStyle registered with the same IClassificationType.
Top
See Also

Reference

IHighlightingStyleRegistry Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyleRegistry.Register Method (IClassificationType, IHighlightingStyle)

IHighlightingStyleRegistryRegister Method (IClassificationType, IHighlightingStyle)
Attempts to adds an IHighlightingStyle for the specified IClassificationType into the registry, as long as there is no existing IHighlightingStyle registered with the same IClassificationType.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Register(
    IClassificationType classificationType,
    IHighlightingStyle style
)
Function Register (
    classificationType As IClassificationType,
    style As IHighlightingStyle
) As Boolean

Parameters

classificationType
Type: ActiproSoftware.TextIClassificationType
The IClassificationType with which to register the IHighlightingStyle.
style
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.HighlightingIHighlightingStyle
The IHighlightingStyle to register.

Return Value

Type: Boolean
true if the IHighlightingStyle was added; otherwise, false.
Remarks
This method only returns false if there is already an IHighlightingStyle registered with the same IClassificationType.
See Also

Reference

IHighlightingStyleRegistry Interface
Register Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyleRegistry.Register Method (IClassificationType, IHighlightingStyle, Boolean)

IHighlightingStyleRegistryRegister Method (IClassificationType, IHighlightingStyle, Boolean)
Adds an IHighlightingStyle into the registry, optionally overwriting any existing IHighlightingStyle registered with the same IClassificationType.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Register(
    IClassificationType classificationType,
    IHighlightingStyle style,
    bool overwriteExisting
)
Function Register (
    classificationType As IClassificationType,
    style As IHighlightingStyle,
    overwriteExisting As Boolean
) As Boolean

Parameters

classificationType
Type: ActiproSoftware.TextIClassificationType
The IClassificationType with which to register the IHighlightingStyle.
style
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.HighlightingIHighlightingStyle
The IHighlightingStyle to register.
overwriteExisting
Type: SystemBoolean
Whether to overwrite existing highlighting styles with the same IClassificationType.

Return Value

Type: Boolean
true if the IHighlightingStyle was added; otherwise, false.
Remarks
This method only returns false if overwriteExisting is false and there is already an IHighlightingStyle registered with the same IClassificationType.
See Also

Reference

IHighlightingStyleRegistry Interface
Register Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyleRegistry.Unregister Method

IHighlightingStyleRegistryUnregister Method
Removes a registry entry with the specified IClassificationType from the registry.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Unregister(
    IClassificationType classificationType
)
Function Unregister (
    classificationType As IClassificationType
) As Boolean

Parameters

classificationType
Type: ActiproSoftware.TextIClassificationType
The IClassificationType to unregister.

Return Value

Type: Boolean
true if the registry entry was removed; otherwise, false.
See Also

Reference

IHighlightingStyleRegistry Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyleRegistry Events

IHighlightingStyleRegistry Events

The IHighlightingStyleRegistry type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after a change has occurred to the items in the registry.
Top
See Also

Reference

IHighlightingStyleRegistry Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyleRegistry.Changed Event

IHighlightingStyleRegistryChanged Event
Occurs after a change has occurred to the items in the registry.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler Changed
Event Changed As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

IHighlightingStyleRegistry Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyleRegistryProvider Interface

IHighlightingStyleRegistryProvider Interface
Provides the base requirements for an object that can provide a custom IHighlightingStyleRegistry.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IHighlightingStyleRegistryProvider
Public Interface IHighlightingStyleRegistryProvider

The IHighlightingStyleRegistryProvider type exposes the following members.

Properties
 | Name | Description
Public property | HighlightingStyleRegistry | Gets the custom IHighlightingStyleRegistry associated with this object.
Top
Remarks
This interface can be implemented by IClassificationTag instances to use custom highlighting style registries for that particular tag.
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyleRegistryProvider Properties

IHighlightingStyleRegistryProvider Properties

The IHighlightingStyleRegistryProvider type exposes the following members.

Properties
 | Name | Description
Public property | HighlightingStyleRegistry | Gets the custom IHighlightingStyleRegistry associated with this object.
Top
See Also

Reference

IHighlightingStyleRegistryProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


IHighlightingStyleRegistryProvider.HighlightingStyleRegistry Property

IHighlightingStyleRegistryProviderHighlightingStyleRegistry Property
Gets the custom IHighlightingStyleRegistry associated with this object.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IHighlightingStyleRegistry HighlightingStyleRegistry { get; }
ReadOnly Property HighlightingStyleRegistry As IHighlightingStyleRegistry
    Get

Property Value

Type: IHighlightingStyleRegistry
The custom IHighlightingStyleRegistry associated with this object.
See Also

Reference

IHighlightingStyleRegistryProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting Namespace


ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace
Contains implementation types related to highlighting.
Classes
 | Class | Description
Public class | HighlightingStyle | A highlighting style that is applied to a span of text.
Public class | HighlightingStyleRegistry | Represents a registry of IClassificationType to IHighlightingStyle mapping data.


HighlightingStyle Class

HighlightingStyle Class
A highlighting style that is applied to a span of text.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.ImplementationHighlightingStyle

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class HighlightingStyle : IHighlightingStyle,
    INotifyPropertyChanged
Public Class HighlightingStyle
    Implements IHighlightingStyle, INotifyPropertyChanged

The HighlightingStyle type exposes the following members.

Constructors
 | Name | Description
Public method | HighlightingStyle | Initializes the HighlightingStyle class.
Public method | HighlightingStyle(Brush) | Initializes the HighlightingStyle class.
Public method | HighlightingStyle(Brush, Brush) | Initializes the HighlightingStyle class.
Public method | HighlightingStyle(Brush, Brush, NullableBoolean, NullableBoolean, HighlightingStyleLineStyle) | Initializes the HighlightingStyle class.
Public method | HighlightingStyle(Brush, Brush, NullableBoolean, NullableBoolean, HighlightingStyleLineStyle, NullableBoolean) | Initializes the HighlightingStyle class.
Top
Properties
 | Name | Description
Public property | Background | Gets or sets the background brush of the highlighting style.
Public property | BackgroundSpansVirtualSpace | Gets or sets a nullable Boolean indicating whether the background should span virtual space when the styled range includes a line terminator.
Public property | Bold | Gets or sets a nullable Boolean indicating whether the highlighting style uses boldface.
Public property | BorderBrush | Gets or sets the border brush of the highlighting style.
Public property | BorderCornerStyle | Gets or sets a HighlightingStyleBorderCornerStyle indicating the style of border corners.
Public property | BorderStyle | Gets or sets a HighlightingStyleLineStyle indicating the style of border to use.
Public property | FontFamilyName | Gets or sets the name of the font family to use for drawing text with the highlighting style.
Public property | FontSize | Gets or sets the size of the font to use for drawing text with the highlighting style.
Public property | Foreground | Gets or sets the foreground brush of the highlighting style.
Public property | HasBackground | Gets whether the highlighting style contains has a background.
Public property | HasBorder | Gets whether the highlighting style has a border.
Public property | HasDefaultFormatting | Gets whether the highlighting style contains all default values for formatting properties.
Public property | HasFontChange | Gets whether the highlighting style contains a font-related change.
Public property | IsBackgroundEditable | Gets whether the Background property is editable in an options dialog.
Public property | IsBoldEditable | Gets whether the Bold property is editable in an options dialog.
Public property | IsBorderEditable | Gets whether the BorderBrush and related properties are editable in an options dialog.
Public property | IsForegroundEditable | Gets whether the Foreground property is editable in an options dialog.
Public property | IsItalicEditable | Gets whether the Italic property is editable in an options dialog.
Public property | Italic | Gets or sets a nullable Boolean indicating whether the highlighting style uses italics.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property's value has changed.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value is changed.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle Constructor

HighlightingStyle Constructor
Overload List
 | Name | Description
Public method | HighlightingStyle | Initializes the HighlightingStyle class.
Public method | HighlightingStyle(Brush) | Initializes the HighlightingStyle class.
Public method | HighlightingStyle(Brush, Brush) | Initializes the HighlightingStyle class.
Public method | HighlightingStyle(Brush, Brush, NullableBoolean, NullableBoolean, HighlightingStyleLineStyle) | Initializes the HighlightingStyle class.
Public method | HighlightingStyle(Brush, Brush, NullableBoolean, NullableBoolean, HighlightingStyleLineStyle, NullableBoolean) | Initializes the HighlightingStyle class.
Top
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle Constructor

HighlightingStyle Constructor
Initializes the HighlightingStyle class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public HighlightingStyle()
Public Sub New
See Also

Reference

HighlightingStyle Class
HighlightingStyle Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle Constructor (Brush)

HighlightingStyle Constructor (Brush)
Initializes the HighlightingStyle class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public HighlightingStyle(
    Brush foreground
)
Public Sub New (
    foreground As Brush
)

Parameters

foreground
Type: Windows.UI.Xaml.MediaBrush
The foreground Brush of the highlighting style.
See Also

Reference

HighlightingStyle Class
HighlightingStyle Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle Constructor (Brush, Brush)

HighlightingStyle Constructor (Brush, Brush)
Initializes the HighlightingStyle class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public HighlightingStyle(
    Brush foreground,
    Brush background
)
Public Sub New (
    foreground As Brush,
    background As Brush
)

Parameters

foreground
Type: Windows.UI.Xaml.MediaBrush
The foreground Brush of the highlighting style.
background
Type: Windows.UI.Xaml.MediaBrush
The background Brush of the highlighting style.
See Also

Reference

HighlightingStyle Class
HighlightingStyle Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle Constructor (Brush, Brush, Nullable(Boolean), Nullable(Boolean), HighlightingStyleLineStyle)

HighlightingStyle Constructor (Brush, Brush, NullableBoolean, NullableBoolean, HighlightingStyleLineStyle)
Initializes the HighlightingStyle class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public HighlightingStyle(
    Brush foreground,
    Brush background,
    Nullable<bool> bold,
    Nullable<bool> italic,
    HighlightingStyleLineStyle underlineStyle
)
Public Sub New (
    foreground As Brush,
    background As Brush,
    bold As Nullable(Of Boolean),
    italic As Nullable(Of Boolean),
    underlineStyle As HighlightingStyleLineStyle
)

Parameters

foreground
Type: Windows.UI.Xaml.MediaBrush
The foreground Brush of the highlighting style.
background
Type: Windows.UI.Xaml.MediaBrush
The background Brush of the highlighting style.
bold
Type: SystemNullable Boolean
A nullable Boolean indicating whether the highlighting style uses boldface.
italic
Type: SystemNullable Boolean
A nullable Boolean indicating whether the highlighting style uses italics.
underlineStyle
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.HighlightingHighlightingStyleLineStyle
A HighlightingStyleLineStyle indicating the underline style.
See Also

Reference

HighlightingStyle Class
HighlightingStyle Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle Constructor (Brush, Brush, Nullable(Boolean), Nullable(Boolean), HighlightingStyleLineStyle, Nullable(Boolean))

HighlightingStyle Constructor (Brush, Brush, NullableBoolean, NullableBoolean, HighlightingStyleLineStyle, NullableBoolean)
Initializes the HighlightingStyle class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public HighlightingStyle(
    Brush foreground,
    Brush background,
    Nullable<bool> bold,
    Nullable<bool> italic,
    HighlightingStyleLineStyle underlineStyle,
    Nullable<bool> backgroundSpansVirtualSpace
)
Public Sub New (
    foreground As Brush,
    background As Brush,
    bold As Nullable(Of Boolean),
    italic As Nullable(Of Boolean),
    underlineStyle As HighlightingStyleLineStyle,
    backgroundSpansVirtualSpace As Nullable(Of Boolean)
)

Parameters

foreground
Type: Windows.UI.Xaml.MediaBrush
The foreground Brush of the highlighting style.
background
Type: Windows.UI.Xaml.MediaBrush
The background Brush of the highlighting style.
bold
Type: SystemNullable Boolean
A nullable Boolean indicating whether the highlighting style uses boldface.
italic
Type: SystemNullable Boolean
A nullable Boolean indicating whether the highlighting style uses italics.
underlineStyle
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.HighlightingHighlightingStyleLineStyle
A HighlightingStyleLineStyle indicating the underline style.
backgroundSpansVirtualSpace
Type: SystemNullable Boolean
A nullable Boolean indicating whether the background should span virtual space when the styled range includes a line terminator.
See Also

Reference

HighlightingStyle Class
HighlightingStyle Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle Properties

HighlightingStyle Properties

The HighlightingStyle type exposes the following members.

Properties
 | Name | Description
Public property | Background | Gets or sets the background brush of the highlighting style.
Public property | BackgroundSpansVirtualSpace | Gets or sets a nullable Boolean indicating whether the background should span virtual space when the styled range includes a line terminator.
Public property | Bold | Gets or sets a nullable Boolean indicating whether the highlighting style uses boldface.
Public property | BorderBrush | Gets or sets the border brush of the highlighting style.
Public property | BorderCornerStyle | Gets or sets a HighlightingStyleBorderCornerStyle indicating the style of border corners.
Public property | BorderStyle | Gets or sets a HighlightingStyleLineStyle indicating the style of border to use.
Public property | FontFamilyName | Gets or sets the name of the font family to use for drawing text with the highlighting style.
Public property | FontSize | Gets or sets the size of the font to use for drawing text with the highlighting style.
Public property | Foreground | Gets or sets the foreground brush of the highlighting style.
Public property | HasBackground | Gets whether the highlighting style contains has a background.
Public property | HasBorder | Gets whether the highlighting style has a border.
Public property | HasDefaultFormatting | Gets whether the highlighting style contains all default values for formatting properties.
Public property | HasFontChange | Gets whether the highlighting style contains a font-related change.
Public property | IsBackgroundEditable | Gets whether the Background property is editable in an options dialog.
Public property | IsBoldEditable | Gets whether the Bold property is editable in an options dialog.
Public property | IsBorderEditable | Gets whether the BorderBrush and related properties are editable in an options dialog.
Public property | IsForegroundEditable | Gets whether the Foreground property is editable in an options dialog.
Public property | IsItalicEditable | Gets whether the Italic property is editable in an options dialog.
Public property | Italic | Gets or sets a nullable Boolean indicating whether the highlighting style uses italics.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.Background Property

HighlightingStyleBackground Property
Gets or sets the background brush of the highlighting style.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush Background { get; set; }
Public Property Background As Brush
    Get
    Set

Property Value

Type: Brush
A Brush indicating the background brush of the highlighting style.

Implements

IHighlightingStyleBackground
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.BackgroundSpansVirtualSpace Property

HighlightingStyleBackgroundSpansVirtualSpace Property
Gets or sets a nullable Boolean indicating whether the background should span virtual space when the styled range includes a line terminator.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<bool> BackgroundSpansVirtualSpace { get; set; }
Public Property BackgroundSpansVirtualSpace As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean indicating whether the background should span virtual space when the styled range includes a line terminator.

Implements

IHighlightingStyleBackgroundSpansVirtualSpace
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.Bold Property

HighlightingStyleBold Property
Gets or sets a nullable Boolean indicating whether the highlighting style uses boldface.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<bool> Bold { get; set; }
Public Property Bold As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean indicating whether the highlighting style uses boldface.

Implements

IHighlightingStyleBold
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.BorderBrush Property

HighlightingStyleBorderBrush Property
Gets or sets the border brush of the highlighting style.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush BorderBrush { get; set; }
Public Property BorderBrush As Brush
    Get
    Set

Property Value

Type: Brush
A Brush indicating the border brush of the highlighting style.

Implements

IHighlightingStyleBorderBrush
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.BorderCornerStyle Property

HighlightingStyleBorderCornerStyle Property
Gets or sets a HighlightingStyleBorderCornerStyle indicating the style of border corners.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public HighlightingStyleBorderCornerStyle BorderCornerStyle { get; set; }
Public Property BorderCornerStyle As HighlightingStyleBorderCornerStyle
    Get
    Set

Property Value

Type: HighlightingStyleBorderCornerStyle
A HighlightingStyleBorderCornerStyle indicating the style of border corners. Specify HighlightingStyleBorderCornerStyle.Default to use a default style, which is the default property value.

Implements

IHighlightingStyleBorderCornerStyle
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.BorderStyle Property

HighlightingStyleBorderStyle Property
Gets or sets a HighlightingStyleLineStyle indicating the style of border to use.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public HighlightingStyleLineStyle BorderStyle { get; set; }
Public Property BorderStyle As HighlightingStyleLineStyle
    Get
    Set

Property Value

Type: HighlightingStyleLineStyle
A HighlightingStyleLineStyle indicating the style of border to use.

Implements

IHighlightingStyleBorderStyle
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.FontFamilyName Property

HighlightingStyleFontFamilyName Property
Gets or sets the name of the font family to use for drawing text with the highlighting style.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string FontFamilyName { get; set; }
Public Property FontFamilyName As String
    Get
    Set

Property Value

Type: String
The name of the font family to use for drawing text with the highlighting style.

Implements

IHighlightingStyleFontFamilyName
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.FontSize Property

HighlightingStyleFontSize Property
Gets or sets the size of the font to use for drawing text with the highlighting style.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double FontSize { get; set; }
Public Property FontSize As Double
    Get
    Set

Property Value

Type: Double
The size of the font to use for drawing text with the highlighting style. Specify 0 to use a default value, which is the default property value.

Implements

IHighlightingStyleFontSize
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.Foreground Property

HighlightingStyleForeground Property
Gets or sets the foreground brush of the highlighting style.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush Foreground { get; set; }
Public Property Foreground As Brush
    Get
    Set

Property Value

Type: Brush
A Brush indicating the foreground brush of the highlighting style.

Implements

IHighlightingStyleForeground
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.HasBackground Property

HighlightingStyleHasBackground Property
Gets whether the highlighting style contains has a background.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasBackground { get; }
Public ReadOnly Property HasBackground As Boolean
    Get

Property Value

Type: Boolean
true if the highlighting style contains has a background; otherwise, false.

Implements

IHighlightingStyleHasBackground
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.HasBorder Property

HighlightingStyleHasBorder Property
Gets whether the highlighting style has a border.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasBorder { get; }
Public ReadOnly Property HasBorder As Boolean
    Get

Property Value

Type: Boolean
true if the highlighting style has a border; otherwise, false.

Implements

IHighlightingStyleHasBorder
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.HasDefaultFormatting Property

HighlightingStyleHasDefaultFormatting Property
Gets whether the highlighting style contains all default values for formatting properties.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasDefaultFormatting { get; }
Public ReadOnly Property HasDefaultFormatting As Boolean
    Get

Property Value

Type: Boolean
true if the highlighting style contains all default values for formatting properties; otherwise, false.

Implements

IHighlightingStyleHasDefaultFormatting
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.HasFontChange Property

HighlightingStyleHasFontChange Property
Gets whether the highlighting style contains a font-related change.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasFontChange { get; }
Public ReadOnly Property HasFontChange As Boolean
    Get

Property Value

Type: Boolean
true if the highlighting style contains a font-related change; otherwise, false.

Implements

IHighlightingStyleHasFontChange
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.IsBackgroundEditable Property

HighlightingStyleIsBackgroundEditable Property
Gets whether the Background property is editable in an options dialog.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsBackgroundEditable { get; set; }
Public Property IsBackgroundEditable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Background property is editable in an options dialog; otherwise, false. The default value is true.

Implements

IHighlightingStyleIsBackgroundEditable
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.IsBoldEditable Property

HighlightingStyleIsBoldEditable Property
Gets whether the Bold property is editable in an options dialog.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsBoldEditable { get; set; }
Public Property IsBoldEditable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Bold property is editable in an options dialog; otherwise, false. The default value is true.

Implements

IHighlightingStyleIsBoldEditable
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.IsBorderEditable Property

HighlightingStyleIsBorderEditable Property
Gets whether the BorderBrush and related properties are editable in an options dialog.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsBorderEditable { get; set; }
Public Property IsBorderEditable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the BorderBrush and related properties are editable in an options dialog; otherwise, false. The default value is false.

Implements

IHighlightingStyleIsBorderEditable
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.IsForegroundEditable Property

HighlightingStyleIsForegroundEditable Property
Gets whether the Foreground property is editable in an options dialog.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsForegroundEditable { get; set; }
Public Property IsForegroundEditable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Foreground property is editable in an options dialog; otherwise, false. The default value is true.

Implements

IHighlightingStyleIsForegroundEditable
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.IsItalicEditable Property

HighlightingStyleIsItalicEditable Property
Gets whether the Italic property is editable in an options dialog.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsItalicEditable { get; set; }
Public Property IsItalicEditable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Italic property is editable in an options dialog; otherwise, false. The default value is true.

Implements

IHighlightingStyleIsItalicEditable
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.Italic Property

HighlightingStyleItalic Property
Gets or sets a nullable Boolean indicating whether the highlighting style uses italics.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<bool> Italic { get; set; }
Public Property Italic As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean indicating whether the highlighting style uses italics.

Implements

IHighlightingStyleItalic
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.Tag Property

HighlightingStyleTag Property
Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .

Implements

IHighlightingStyleTag
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle Methods

HighlightingStyle Methods

The HighlightingStyle type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property's value has changed.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.NotifyPropertyChanged Method

HighlightingStyleNotifyPropertyChanged Method
Notifies that a property's value has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void NotifyPropertyChanged(
    string name
)
Protected Sub NotifyPropertyChanged (
    name As String
)

Parameters

name
Type: SystemString
The name of the property.
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.ToString Method

HighlightingStyleToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle Events

HighlightingStyle Events

The HighlightingStyle type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value is changed.
Top
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyle.PropertyChanged Event

HighlightingStylePropertyChanged Event
Occurs when a property value is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

HighlightingStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyleRegistry Class

HighlightingStyleRegistry Class
Represents a registry of IClassificationType to IHighlightingStyle mapping data.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.ImplementationHighlightingStyleRegistry
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.HighlightingAmbientHighlightingStyleRegistry

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class HighlightingStyleRegistry : IHighlightingStyleRegistry,
    IClassificationTypeRegistry, IEnumerable<IClassificationType>, IEnumerable, IEnumerable<KeyValuePair<IClassificationType, IHighlightingStyle>>
Public Class HighlightingStyleRegistry
    Implements IHighlightingStyleRegistry, IClassificationTypeRegistry, IEnumerable(Of IClassificationType),
    IEnumerable, IEnumerable(Of KeyValuePair(Of IClassificationType, IHighlightingStyle))

The HighlightingStyleRegistry type exposes the following members.

Constructors
 | Name | Description
Public method | HighlightingStyleRegistry | Initializes a new instance of the HighlightingStyleRegistry class
Top
Properties
 | Name | Description
Public property | ClassificationTypes | Gets the collection of IClassificationType objects that have been registered.
Public property | Count | Gets the number of entries in the registry.
Public property | Description | Gets or sets the description of the registry.
Public property | HighlightingStyles | Gets the collection of IHighlightingStyle objects that have been registered.
Public property | Item | Gets the IHighlightingStyle registered with the specified IClassificationType. [C#] In C#, this property is the indexer for the IHighlightingStyleRegistry interface.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetClassificationType | Returns the IClassificationType, if any, that has been registered with the specified key.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event.
Public method | Register(IClassificationType, IHighlightingStyle) | Attempts to adds an IHighlightingStyle for the specified IClassificationType into the registry, as long as there is no existing IHighlightingStyle registered with the same IClassificationType.
Public method | Register(IClassificationType, IHighlightingStyle, Boolean) | Adds an IHighlightingStyle into the registry, optionally overwriting any existing IHighlightingStyle registered with the same IClassificationType.
Public method | ToString | (Inherited from Object.)
Public method | Unregister | Removes a registry entry with the specified IClassificationType from the registry.
Top
Events
 | Name | Description
Public event | Changed | Occurs after a change has occurred to the items in the registry.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyleRegistry Constructor

HighlightingStyleRegistry Constructor
Initializes a new instance of the HighlightingStyleRegistry class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public HighlightingStyleRegistry()
Public Sub New
See Also

Reference

HighlightingStyleRegistry Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyleRegistry Properties

HighlightingStyleRegistry Properties

The HighlightingStyleRegistry type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationTypes | Gets the collection of IClassificationType objects that have been registered.
Public property | Count | Gets the number of entries in the registry.
Public property | Description | Gets or sets the description of the registry.
Public property | HighlightingStyles | Gets the collection of IHighlightingStyle objects that have been registered.
Public property | Item | Gets the IHighlightingStyle registered with the specified IClassificationType. [C#] In C#, this property is the indexer for the IHighlightingStyleRegistry interface.
Top
See Also

Reference

HighlightingStyleRegistry Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyleRegistry.ClassificationTypes Property

HighlightingStyleRegistryClassificationTypes Property
Gets the collection of IClassificationType objects that have been registered.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICollection<IClassificationType> ClassificationTypes { get; }
Public ReadOnly Property ClassificationTypes As ICollection(Of IClassificationType)
    Get

Property Value

Type: ICollection IClassificationType
The collection of IClassificationType objects that have been registered.

Implements

IHighlightingStyleRegistryClassificationTypes
See Also

Reference

HighlightingStyleRegistry Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyleRegistry.Count Property

HighlightingStyleRegistryCount Property
Gets the number of entries in the registry.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of entries in the registry.

Implements

IClassificationTypeRegistryCount
See Also

Reference

HighlightingStyleRegistry Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyleRegistry.Description Property

HighlightingStyleRegistryDescription Property
Gets or sets the description of the registry.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
The description of the registry.

Implements

IHighlightingStyleRegistryDescription
See Also

Reference

HighlightingStyleRegistry Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyleRegistry.HighlightingStyles Property

HighlightingStyleRegistryHighlightingStyles Property
Gets the collection of IHighlightingStyle objects that have been registered.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICollection<IHighlightingStyle> HighlightingStyles { get; }
Public ReadOnly Property HighlightingStyles As ICollection(Of IHighlightingStyle)
    Get

Property Value

Type: ICollection IHighlightingStyle
The collection of IHighlightingStyle objects that have been registered.

Implements

IHighlightingStyleRegistryHighlightingStyles
See Also

Reference

HighlightingStyleRegistry Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyleRegistry.Item Property

HighlightingStyleRegistryItem Property
Gets the IHighlightingStyle registered with the specified IClassificationType.

[C#] In C#, this property is the indexer for the IHighlightingStyleRegistry interface.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IHighlightingStyle this[
    IClassificationType classificationType
] { get; }
Public ReadOnly Property Item (
    classificationType As IClassificationType
) As IHighlightingStyle
    Get

Parameters

classificationType
Type: ActiproSoftware.TextIClassificationType
The IClassificationType for which to search.

Property Value

Type: IHighlightingStyle
The IHighlightingStyle registered with the specified IClassificationType.

Implements

IHighlightingStyleRegistryItemIClassificationType
See Also

Reference

HighlightingStyleRegistry Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyleRegistry Methods

HighlightingStyleRegistry Methods

The HighlightingStyleRegistry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetClassificationType | Returns the IClassificationType, if any, that has been registered with the specified key.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event.
Public method | Register(IClassificationType, IHighlightingStyle) | Attempts to adds an IHighlightingStyle for the specified IClassificationType into the registry, as long as there is no existing IHighlightingStyle registered with the same IClassificationType.
Public method | Register(IClassificationType, IHighlightingStyle, Boolean) | Adds an IHighlightingStyle into the registry, optionally overwriting any existing IHighlightingStyle registered with the same IClassificationType.
Public method | ToString | (Inherited from Object.)
Public method | Unregister | Removes a registry entry with the specified IClassificationType from the registry.
Top
See Also

Reference

HighlightingStyleRegistry Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyleRegistry.GetClassificationType Method

HighlightingStyleRegistryGetClassificationType Method
Returns the IClassificationType, if any, that has been registered with the specified key.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType GetClassificationType(
    string key
)
Public Function GetClassificationType (
    key As String
) As IClassificationType

Parameters

key
Type: SystemString
The key for which to search.

Return Value

Type: IClassificationType
The IClassificationType, if any, that has been registered with the specified key.

Implements

IHighlightingStyleRegistryGetClassificationType(String)
See Also

Reference

HighlightingStyleRegistry Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyleRegistry.GetEnumerator Method

HighlightingStyleRegistryGetEnumerator Method
Retrieves an IEnumerator object for the entire collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerator<KeyValuePair<IClassificationType, IHighlightingStyle>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of IClassificationType, IHighlightingStyle))

Return Value

Type: IEnumerator KeyValuePair IClassificationType, IHighlightingStyle
An IEnumerator object for the entire collection

Implements

IEnumerableTGetEnumerator
Remarks
Enumerators are intended to be used only to read data in the collection. Enumerators cannot be used to modify the underlying collection.

The enumerator does not have exclusive access to the collection.

When an enumerator is instantiated, it takes a snapshot of the current state of the collection. If changes are made to the collection, such as adding, modifying or deleting elements, the snapshot gets out of sync and the enumerator throws an InvalidOperationException. Two enumerators instantiated from the same collection at the same time can have different snapshots of the collection.

See Also

Reference

HighlightingStyleRegistry Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyleRegistry.OnChanged Method

HighlightingStyleRegistryOnChanged Method
Raises the Changed event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnChanged(
    EventArgs e
)
Protected Overridable Sub OnChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

HighlightingStyleRegistry Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyleRegistry.Register Method

HighlightingStyleRegistryRegister Method
Overload List
 | Name | Description
Public method | Register(IClassificationType, IHighlightingStyle) | Attempts to adds an IHighlightingStyle for the specified IClassificationType into the registry, as long as there is no existing IHighlightingStyle registered with the same IClassificationType.
Public method | Register(IClassificationType, IHighlightingStyle, Boolean) | Adds an IHighlightingStyle into the registry, optionally overwriting any existing IHighlightingStyle registered with the same IClassificationType.
Top
See Also

Reference

HighlightingStyleRegistry Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyleRegistry.Register Method (IClassificationType, IHighlightingStyle)

HighlightingStyleRegistryRegister Method (IClassificationType, IHighlightingStyle)
Attempts to adds an IHighlightingStyle for the specified IClassificationType into the registry, as long as there is no existing IHighlightingStyle registered with the same IClassificationType.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Register(
    IClassificationType classificationType,
    IHighlightingStyle style
)
Public Function Register (
    classificationType As IClassificationType,
    style As IHighlightingStyle
) As Boolean

Parameters

classificationType
Type: ActiproSoftware.TextIClassificationType
The IClassificationType with which to register the IHighlightingStyle.
style
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.HighlightingIHighlightingStyle
The IHighlightingStyle to register.

Return Value

Type: Boolean
true if the IHighlightingStyle was added; otherwise, false.

Implements

IHighlightingStyleRegistryRegister(IClassificationType, IHighlightingStyle)
Remarks
This method only returns false if there is already an IHighlightingStyle registered with the same IClassificationType.
See Also

Reference

HighlightingStyleRegistry Class
Register Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyleRegistry.Register Method (IClassificationType, IHighlightingStyle, Boolean)

HighlightingStyleRegistryRegister Method (IClassificationType, IHighlightingStyle, Boolean)
Adds an IHighlightingStyle into the registry, optionally overwriting any existing IHighlightingStyle registered with the same IClassificationType.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Register(
    IClassificationType classificationType,
    IHighlightingStyle style,
    bool overwriteExisting
)
Public Function Register (
    classificationType As IClassificationType,
    style As IHighlightingStyle,
    overwriteExisting As Boolean
) As Boolean

Parameters

classificationType
Type: ActiproSoftware.TextIClassificationType
The IClassificationType with which to register the IHighlightingStyle.
style
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.HighlightingIHighlightingStyle
The IHighlightingStyle to register.
overwriteExisting
Type: SystemBoolean
Whether to overwrite existing highlighting styles with the same IClassificationType.

Return Value

Type: Boolean
true if the IHighlightingStyle was added; otherwise, false.

Implements

IHighlightingStyleRegistryRegister(IClassificationType, IHighlightingStyle, Boolean)
Remarks
This method only returns false if overwriteExisting is false and there is already an IHighlightingStyle registered with the same IClassificationType.
See Also

Reference

HighlightingStyleRegistry Class
Register Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyleRegistry.Unregister Method

HighlightingStyleRegistryUnregister Method
Removes a registry entry with the specified IClassificationType from the registry.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Unregister(
    IClassificationType classificationType
)
Public Function Unregister (
    classificationType As IClassificationType
) As Boolean

Parameters

classificationType
Type: ActiproSoftware.TextIClassificationType
The IClassificationType to unregister.

Return Value

Type: Boolean
true if the registry entry was removed; otherwise, false.

Implements

IHighlightingStyleRegistryUnregister(IClassificationType)
See Also

Reference

HighlightingStyleRegistry Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyleRegistry Events

HighlightingStyleRegistry Events

The HighlightingStyleRegistry type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after a change has occurred to the items in the registry.
Top
See Also

Reference

HighlightingStyleRegistry Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


HighlightingStyleRegistry.Changed Event

HighlightingStyleRegistryChanged Event
Occurs after a change has occurred to the items in the registry.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler Changed
Public Event Changed As EventHandler

Value

Type: SystemEventHandler

Implements

IHighlightingStyleRegistryChanged
See Also

Reference

HighlightingStyleRegistry Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation Namespace


ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace
Contains implementation types related to SyntaxEditor.
Classes
 | Class | Description
Public class | DelimiterIndentProvider | Provides an implementation (generally a base class) for a language indent provider service that can auto-indent curly and/or square braces.
Public class | EditActionBase | Provides a base implementation for an edit action that can be performed in an IEditorView.
Public class | EditActionCommand | Provides a command implementation for edit actions.
Public class | EditorSearchOptions | Stores find/replace options for searching within a view.
Public class | EditorViewTextChangeOptions | Represents options that are applied to an ITextChange, and are created from an IEditorView.
Public class | PrintSettings | Represents the default implementation of an object that supports printing the contents of a SyntaxEditor.


DelimiterIndentProvider Class

DelimiterIndentProvider Class
Provides an implementation (generally a base class) for a language indent provider service that can auto-indent curly and/or square braces.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationDelimiterIndentProvider
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpIndentProvider
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptIndentProvider
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonIndentProvider
ActiproSoftware.Text.Languages.Python.ImplementationPythonIndentProvider

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DelimiterIndentProvider : IIndentProvider,
    IEditorDocumentTextChangeEventSink
Public Class DelimiterIndentProvider
    Implements IIndentProvider, IEditorDocumentTextChangeEventSink

The DelimiterIndentProvider type exposes the following members.

Constructors
 | Name | Description
Public method | DelimiterIndentProvider | Initializes a new instance of the DelimiterIndentProvider class.
Top
Properties
 | Name | Description
Public property | CanAutoIndentCurlyBraces | Gets or sets whether curly braces can be auto-indented.
Public property | CanAutoIndentSquareBraces | Gets or sets whether square braces can be auto-indented.
Public property | CloseCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that a close curly brace character is valid.
Public property | CloseDelimiterIndentLevel | Gets or sets the additional indent level to apply to close delimiters when auto-indenting them.
Public property | CloseSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that a close square brace character is valid.
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text.
Public property | OpenCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that an open curly brace character is valid.
Public property | OpenSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that an open square brace character is valid.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.
Public method | GetType | (Inherited from Object.)
Protected method | IsValidEndDelimiter | Returns whether an IToken represents the specified end delimiter.
Protected method | IsValidStartDelimiter | Returns whether an IToken represents the specified start delimiter.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


DelimiterIndentProvider Constructor

DelimiterIndentProvider Constructor
Initializes a new instance of the DelimiterIndentProvider class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DelimiterIndentProvider()
Public Sub New
See Also

Reference

DelimiterIndentProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


DelimiterIndentProvider Properties

DelimiterIndentProvider Properties

The DelimiterIndentProvider type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoIndentCurlyBraces | Gets or sets whether curly braces can be auto-indented.
Public property | CanAutoIndentSquareBraces | Gets or sets whether square braces can be auto-indented.
Public property | CloseCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that a close curly brace character is valid.
Public property | CloseDelimiterIndentLevel | Gets or sets the additional indent level to apply to close delimiters when auto-indenting them.
Public property | CloseSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that a close square brace character is valid.
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text.
Public property | OpenCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that an open curly brace character is valid.
Public property | OpenSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that an open square brace character is valid.
Top
See Also

Reference

DelimiterIndentProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


DelimiterIndentProvider.CanAutoIndentCurlyBraces Property

DelimiterIndentProviderCanAutoIndentCurlyBraces Property
Gets or sets whether curly braces can be auto-indented.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanAutoIndentCurlyBraces { get; set; }
Public Property CanAutoIndentCurlyBraces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if curly braces can be auto-indented; otherwise, false. The default value is true.
See Also

Reference

DelimiterIndentProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


DelimiterIndentProvider.CanAutoIndentSquareBraces Property

DelimiterIndentProviderCanAutoIndentSquareBraces Property
Gets or sets whether square braces can be auto-indented.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanAutoIndentSquareBraces { get; set; }
Public Property CanAutoIndentSquareBraces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if square braces can be auto-indented; otherwise, false. The default value is false.
See Also

Reference

DelimiterIndentProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


DelimiterIndentProvider.CloseCurlyBraceTokenId Property

DelimiterIndentProviderCloseCurlyBraceTokenId Property
Gets or sets the optional token ID value used to ensure that a close curly brace character is valid.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> CloseCurlyBraceTokenId { get; set; }
Public Property CloseCurlyBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that a close curly brace character is valid.
Remarks
Leave the value if token validation is not required for curly braces.
See Also

Reference

DelimiterIndentProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


DelimiterIndentProvider.CloseDelimiterIndentLevel Property

DelimiterIndentProviderCloseDelimiterIndentLevel Property
Gets or sets the additional indent level to apply to close delimiters when auto-indenting them.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int CloseDelimiterIndentLevel { get; set; }
Public Property CloseDelimiterIndentLevel As Integer
    Get
    Set

Property Value

Type: Int32
The additional indent level. The default value is 0.
Remarks
This property can be set to 1 if the close delimiter should be indented one tab stop beyond normal.
See Also

Reference

DelimiterIndentProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


DelimiterIndentProvider.CloseSquareBraceTokenId Property

DelimiterIndentProviderCloseSquareBraceTokenId Property
Gets or sets the optional token ID value used to ensure that a close square brace character is valid.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> CloseSquareBraceTokenId { get; set; }
Public Property CloseSquareBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that a close square brace character is valid.
Remarks
Leave the value if token validation is not required for square braces.
See Also

Reference

DelimiterIndentProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


DelimiterIndentProvider.Mode Property

DelimiterIndentProviderMode Property
Gets the IndentMode that specifies the mode by which to indent text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IndentMode Mode { get; }
Public Overridable ReadOnly Property Mode As IndentMode
    Get

Property Value

Type: IndentMode
The IndentMode that specifies the mode by which to indent text.

Implements

IIndentProviderMode
See Also

Reference

DelimiterIndentProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


DelimiterIndentProvider.OpenCurlyBraceTokenId Property

DelimiterIndentProviderOpenCurlyBraceTokenId Property
Gets or sets the optional token ID value used to ensure that an open curly brace character is valid.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> OpenCurlyBraceTokenId { get; set; }
Public Property OpenCurlyBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open curly brace character is valid.
Remarks
Leave the value if token validation is not required for curly braces.
See Also

Reference

DelimiterIndentProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


DelimiterIndentProvider.OpenSquareBraceTokenId Property

DelimiterIndentProviderOpenSquareBraceTokenId Property
Gets or sets the optional token ID value used to ensure that an open square brace character is valid.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> OpenSquareBraceTokenId { get; set; }
Public Property OpenSquareBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open square brace character is valid.
Remarks
Leave the value if token validation is not required for square braces.
See Also

Reference

DelimiterIndentProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


DelimiterIndentProvider Methods

DelimiterIndentProvider Methods

The DelimiterIndentProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.
Public method | GetType | (Inherited from Object.)
Protected method | IsValidEndDelimiter | Returns whether an IToken represents the specified end delimiter.
Protected method | IsValidStartDelimiter | Returns whether an IToken represents the specified start delimiter.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DelimiterIndentProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


DelimiterIndentProvider.GetIndentAmount Method

DelimiterIndentProviderGetIndentAmount Method
Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual int GetIndentAmount(
    TextSnapshotOffset snapshotOffset,
    int defaultAmount
)
Public Overridable Function GetIndentAmount (
    snapshotOffset As TextSnapshotOffset,
    defaultAmount As Integer
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset whose line should be examined.
defaultAmount
Type: SystemInt32
The default indent amount, which is the amount used in Block mode.

Return Value

Type: Int32
The ideal amount of indent, always in columns, for the line containing the snapshot offset.

Implements

IIndentProviderGetIndentAmount(TextSnapshotOffset, Int32)
Remarks
This method is called when the IndentMode is Smart. The containing ITextDocument is accessible via the snapshot range's ITextSnapshot.
See Also

Reference

DelimiterIndentProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


DelimiterIndentProvider.IsValidEndDelimiter Method

DelimiterIndentProviderIsValidEndDelimiter Method
Returns whether an IToken represents the specified end delimiter.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool IsValidEndDelimiter(
    IToken token,
    char endDelimiter
)
Protected Overridable Function IsValidEndDelimiter (
    token As IToken,
    endDelimiter As Char
) As Boolean

Parameters

token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.
endDelimiter
Type: SystemChar
The end delimiter.

Return Value

Type: Boolean
true if the IToken represents the specified end delimiter; otherwise, false.
Remarks
The default implementation of this method compares the token ID to the ID specified in the CloseCurlyBraceTokenId property. This method is called when determining whether to perform delimiter auto-indent.
See Also

Reference

DelimiterIndentProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


DelimiterIndentProvider.IsValidStartDelimiter Method

DelimiterIndentProviderIsValidStartDelimiter Method
Returns whether an IToken represents the specified start delimiter.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool IsValidStartDelimiter(
    IToken token,
    char startDelimiter
)
Protected Overridable Function IsValidStartDelimiter (
    token As IToken,
    startDelimiter As Char
) As Boolean

Parameters

token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.
startDelimiter
Type: SystemChar
The start delimiter.

Return Value

Type: Boolean
true if the IToken represents the specified start delimiter; otherwise, false.
Remarks
The default implementation of this method compares the token ID to the ID specified in the OpenCurlyBraceTokenId property. This method is called when determining whether to perform delimiter auto-indent.
See Also

Reference

DelimiterIndentProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


DelimiterIndentProvider.OnDocumentTextChanged Method

DelimiterIndentProviderOnDocumentTextChanged Method
Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

DelimiterIndentProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


DelimiterIndentProvider.OnDocumentTextChanging Method

DelimiterIndentProviderOnDocumentTextChanging Method
Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

DelimiterIndentProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditActionBase Class

EditActionBase Class
Provides a base implementation for an edit action that can be performed in an IEditorView.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
More...

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class EditActionBase : IEditAction,
    IKeyedObject
Public MustInherit Class EditActionBase
    Implements IEditAction, IKeyedObject

The EditActionBase type exposes the following members.

Constructors
 | Name | Description
Protected method | EditActionBase | Initializes a new instance of the EditActionBase class
Top
Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro.
Public property | Key | Gets the string key that uniquely identifies the edit action.
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView.
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView.
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
 | GetKeyText | Gets the string version of a keyboard shortcut.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML.
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionBase
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsBackspaceAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsBackspaceToPreviousWordAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCancelMacroRecordingAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsChangeCharacterCasingAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCodeBlockSelectionContractAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCodeBlockSelectionExpandAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCollapseSelectionAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCollapseToDefinitionsAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCommentLinesAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsConvertSpacesToTabsAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsConvertTabsToSpacesAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCopyToClipboardAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCutLineToClipboardAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsCutToClipboardAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsDeleteAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsDeleteBlankLinesAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsDeleteHorizontalWhitespaceAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsDeleteLineAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsDeleteToLineEndAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsDeleteToLineStartAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsDeleteToNextWordAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsDuplicateLineAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsFormatDocumentAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsFormatSelectionAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsHideSelectionAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsIncrementalSearchAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsIndentAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsInsertLineBreakAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMacroAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveDownAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveLeftAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMovePageDownAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMovePageUpAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveRightAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveSelectedLinesDownAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveSelectedLinesUpAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToDocumentEndAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToDocumentStartAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToLineEndAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToLineStartAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToLineStartAfterIndentationAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToMatchingBracketAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToNextLineStartAfterIndentationAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToNextWordAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToPreviousLineStartAfterIndentationAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToPreviousWordAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToVisibleBottomAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveToVisibleTopAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsMoveUpAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsOpenLineAboveAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsOpenLineBelowAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsOutdentAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsPasteFromClipboardAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsPauseResumeMacroRecordingAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsRedoAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsRequestIntelliPromptAutoCompleteAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsRequestIntelliPromptCompletionSessionAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsRequestIntelliPromptInsertSnippetSessionAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsRequestIntelliPromptParameterInfoSessionAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsRequestIntelliPromptQuickInfoSessionAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsRequestIntelliPromptSurroundWithSessionAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsReverseIncrementalSearchAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsRunMacroAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollDownAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollLeftAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollLineToVisibleBottomAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollLineToVisibleMiddleAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollLineToVisibleTopAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollPageDownAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollPageUpAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollRightAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollToDocumentEndAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollToDocumentStartAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsScrollUpAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectAllAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectBlockDownAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectBlockLeftAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectBlockRightAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectBlockToNextWordAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectBlockToPreviousWordAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectBlockUpAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectDownAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectLeftAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectPageDownAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectPageUpAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectRightAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectToDocumentEndAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectToDocumentStartAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectToLineEndAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectToLineStartAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectToLineStartAfterIndentationAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectToMatchingBracketAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectToNextWordAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectToPreviousWordAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectToVisibleBottomAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectToVisibleTopAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectUpAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsSelectWordAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsStartAutomaticOutliningAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsStopHidingCurrentAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsStopOutliningAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsTabifySelectedLinesAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsToggleAllOutliningExpansionAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsToggleCharacterCasingAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsToggleMacroRecordingAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsToggleOutliningExpansionAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsToggleOverwriteModeAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsTransposeCharactersAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsTransposeLinesAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsTransposeWordsAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsTrimAllTrailingWhitespaceAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsTrimTrailingWhitespaceAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsTypingAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsUncommentLinesAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsUndoAction
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActionsUntabifySelectedLinesAction


EditActionBase Constructor

EditActionBase Constructor
Initializes a new instance of the EditActionBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected EditActionBase()
Protected Sub New
See Also

Reference

EditActionBase Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditActionBase Properties

EditActionBase Properties

The EditActionBase type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro.
Public property | Key | Gets the string key that uniquely identifies the edit action.
Top
See Also

Reference

EditActionBase Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditActionBase.CanRecordInMacro Property

EditActionBaseCanRecordInMacro Property
Gets whether the action can be recorded in a macro.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool CanRecordInMacro { get; }
Public Overridable ReadOnly Property CanRecordInMacro As Boolean
    Get

Property Value

Type: Boolean
true if the action can be recorded in a macro; otherwise, false.

Implements

IEditActionCanRecordInMacro
See Also

Reference

EditActionBase Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditActionBase.Key Property

EditActionBaseKey Property
Gets the string key that uniquely identifies the edit action.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual string Key { get; }
Public Overridable ReadOnly Property Key As String
    Get

Property Value

Type: String
The string key that uniquely identifies the edit action.

Implements

IKeyedObjectKey
See Also

Reference

EditActionBase Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditActionBase Methods

EditActionBase Methods

The EditActionBase type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView.
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the edit action in the specified IEditorView.
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
 | GetKeyText | Gets the string version of a keyboard shortcut.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML.
Public method | ToString | (Inherited from Object.)
Public method | WriteToXml | Serializes the data for the IEditAction to XML.
Top
See Also

Reference

EditActionBase Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditActionBase.CanExecute Method

EditActionBaseCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool CanExecute(
    IEditorView view
)
Public Overridable Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.

Implements

IEditActionCanExecute(IEditorView)
See Also

Reference

EditActionBase Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditActionBase.Execute Method

EditActionBaseExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract void Execute(
    IEditorView view
)
Public MustOverride Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.

Implements

IEditActionExecute(IEditorView)
See Also

Reference

EditActionBase Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditActionBase.GetKeyText Method

EditActionBaseGetKeyText Method
Gets the string version of a keyboard shortcut.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static string GetKeyText(
    VirtualKeyModifiers modifiers,
    VirtualKey key
)
Public Shared Function GetKeyText (
    modifiers As VirtualKeyModifiers,
    key As VirtualKey
) As String

Parameters

modifiers
Type: Windows.SystemVirtualKeyModifiers
The VirtualKeyModifiers to examine.
key
Type: Windows.SystemVirtualKey
The VirtualKey to examine.

Return Value

Type: String
The string version of a keyboard shortcut.
See Also

Reference

EditActionBase Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditActionBase.ReadFromXml Method

EditActionBaseReadFromXml Method
Deserializes the data for the IEditAction from XML.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void ReadFromXml(
    XmlReader reader
)
Public Overridable Sub ReadFromXml (
    reader As XmlReader
)

Parameters

reader
Type: System.XmlXmlReader
The XmlReader to use.

Implements

IEditActionReadFromXml(XmlReader)
Remarks
This method is used for macro serialization.
See Also

Reference

EditActionBase Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditActionBase.WriteToXml Method

EditActionBaseWriteToXml Method
Serializes the data for the IEditAction to XML.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void WriteToXml(
    XmlWriter writer
)
Public Overridable Sub WriteToXml (
    writer As XmlWriter
)

Parameters

writer
Type: System.XmlXmlWriter
The XmlWriter to use.

Implements

IEditActionWriteToXml(XmlWriter)
Remarks
This method is used for macro serialization.
See Also

Reference

EditActionBase Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditActionCommand Class

EditActionCommand Class
Provides a command implementation for edit actions.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditActionCommand

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EditActionCommand : ICommand
Public Class EditActionCommand
    Implements ICommand

The EditActionCommand type exposes the following members.

Constructors
 | Name | Description
Public method | EditActionCommand | Initializes an instance of the EditActionCommand class.
Top
Properties
 | Name | Description
Public property | Action | Gets the IEditAction associated with the command.
Public property | Text | Gets the command text.
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the command can execute.
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the command.
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RaiseCanExecuteChanged | Raises the CanExecuteChanged event.
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CanExecuteChanged | Occurs after the can-execute state has changed.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditActionCommand Constructor

EditActionCommand Constructor
Initializes an instance of the EditActionCommand class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EditActionCommand(
    string text,
    IEditAction action
)
Public Sub New (
    text As String,
    action As IEditAction
)

Parameters

text
Type: SystemString
The command text.
action
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditAction
The IEditAction to wrap.
See Also

Reference

EditActionCommand Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditActionCommand Properties

EditActionCommand Properties

The EditActionCommand type exposes the following members.

Properties
 | Name | Description
Public property | Action | Gets the IEditAction associated with the command.
Public property | Text | Gets the command text.
Top
See Also

Reference

EditActionCommand Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditActionCommand.Action Property

EditActionCommandAction Property
Gets the IEditAction associated with the command.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEditAction Action { get; }
Public ReadOnly Property Action As IEditAction
    Get

Property Value

Type: IEditAction
The IEditAction associated with the command.
See Also

Reference

EditActionCommand Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditActionCommand.Text Property

EditActionCommandText Property
Gets the command text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get

Property Value

Type: String
The command text.
See Also

Reference

EditActionCommand Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditActionCommand Methods

EditActionCommand Methods

The EditActionCommand type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the command can execute.
Public method | Equals | (Inherited from Object.)
Public method | Execute | Executes the command.
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RaiseCanExecuteChanged | Raises the CanExecuteChanged event.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

EditActionCommand Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditActionCommand.CanExecute Method

EditActionCommandCanExecute Method
Returns whether the command can execute.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanExecute(
    IEditorView parameter
)
Public Function CanExecute (
    parameter As IEditorView
) As Boolean

Parameters

parameter
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The parameter to examine.

Return Value

Type: Boolean
true if the command can execute; otherwise, false.
See Also

Reference

EditActionCommand Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditActionCommand.Execute Method

EditActionCommandExecute Method
Executes the command.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Execute(
    IEditorView parameter
)
Public Sub Execute (
    parameter As IEditorView
)

Parameters

parameter
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The parameter to examine.
See Also

Reference

EditActionCommand Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditActionCommand.RaiseCanExecuteChanged Method

EditActionCommandRaiseCanExecuteChanged Method
Raises the CanExecuteChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void RaiseCanExecuteChanged()
Public Sub RaiseCanExecuteChanged
See Also

Reference

EditActionCommand Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditActionCommand Events

EditActionCommand Events

The EditActionCommand type exposes the following members.

Events
 | Name | Description
Public event | CanExecuteChanged | Occurs after the can-execute state has changed.
Top
See Also

Reference

EditActionCommand Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditActionCommand.CanExecuteChanged Event

EditActionCommandCanExecuteChanged Event
Occurs after the can-execute state has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler CanExecuteChanged
Public Event CanExecuteChanged As EventHandler

Value

Type: SystemEventHandler

Implements

ICommandCanExecuteChanged
See Also

Reference

EditActionCommand Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorSearchOptions Class

EditorSearchOptions Class
Stores find/replace options for searching within a view.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditorSearchOptions

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EditorSearchOptions : IEditorSearchOptions,
    ISearchOptions, INotifyPropertyChanged
Public Class EditorSearchOptions
    Implements IEditorSearchOptions, ISearchOptions, INotifyPropertyChanged

The EditorSearchOptions type exposes the following members.

Constructors
 | Name | Description
Public method | EditorSearchOptions | Initializes a new instance of the EditorSearchOptions class
Top
Properties
 | Name | Description
Public property | FindText | Gets or sets the text to find.
Public property | MatchCase | Gets or sets whether searches should be case sensitive.
Public property | MatchWholeWord | Gets or sets whether searches should only match whole words.
Public property | MaximumResultCount | Gets or sets the maximum number of results that can be found.
Public property | PatternProvider | Gets or sets the search pattern provider (normal, regular expression, wildcard, etc.).
Public property | ReplaceText | Gets or sets the text with which to replace.
Public property | Scope | Gets or sets an EditorSearchScope that indicates the scope in which to search.
Public property | SearchUp | Gets or sets whether to search backwards.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property's value has changed.
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value is changed.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorSearchOptions Constructor

EditorSearchOptions Constructor
Initializes a new instance of the EditorSearchOptions class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EditorSearchOptions()
Public Sub New
See Also

Reference

EditorSearchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorSearchOptions Properties

EditorSearchOptions Properties

The EditorSearchOptions type exposes the following members.

Properties
 | Name | Description
Public property | FindText | Gets or sets the text to find.
Public property | MatchCase | Gets or sets whether searches should be case sensitive.
Public property | MatchWholeWord | Gets or sets whether searches should only match whole words.
Public property | MaximumResultCount | Gets or sets the maximum number of results that can be found.
Public property | PatternProvider | Gets or sets the search pattern provider (normal, regular expression, wildcard, etc.).
Public property | ReplaceText | Gets or sets the text with which to replace.
Public property | Scope | Gets or sets an EditorSearchScope that indicates the scope in which to search.
Public property | SearchUp | Gets or sets whether to search backwards.
Top
See Also

Reference

EditorSearchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorSearchOptions.FindText Property

EditorSearchOptionsFindText Property
Gets or sets the text to find.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string FindText { get; set; }
Public Property FindText As String
    Get
    Set

Property Value

Type: String
The text to find.

Implements

ISearchOptionsFindText
See Also

Reference

EditorSearchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorSearchOptions.MatchCase Property

EditorSearchOptionsMatchCase Property
Gets or sets whether searches should be case sensitive.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool MatchCase { get; set; }
Public Property MatchCase As Boolean
    Get
    Set

Property Value

Type: Boolean
true if searches should be case sensitive; otherwise, false.

Implements

ISearchOptionsMatchCase
See Also

Reference

EditorSearchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorSearchOptions.MatchWholeWord Property

EditorSearchOptionsMatchWholeWord Property
Gets or sets whether searches should only match whole words.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool MatchWholeWord { get; set; }
Public Property MatchWholeWord As Boolean
    Get
    Set

Property Value

Type: Boolean
true if searches should only match whole words; otherwise, false.

Implements

ISearchOptionsMatchWholeWord
See Also

Reference

EditorSearchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorSearchOptions.MaximumResultCount Property

EditorSearchOptionsMaximumResultCount Property
Gets or sets the maximum number of results that can be found.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int MaximumResultCount { get; set; }
Public Property MaximumResultCount As Integer
    Get
    Set

Property Value

Type: Int32
The maximum number of results that can be found.

Implements

ISearchOptionsMaximumResultCount
Remarks
The count must be larger than zero.
See Also

Reference

EditorSearchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorSearchOptions.PatternProvider Property

EditorSearchOptionsPatternProvider Property
Gets or sets the search pattern provider (normal, regular expression, wildcard, etc.).

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ISearchPatternProvider PatternProvider { get; set; }
Public Property PatternProvider As ISearchPatternProvider
    Get
    Set

Property Value

Type: ISearchPatternProvider
A ISearchPatternProvider specifying the search pattern provider.

Implements

ISearchOptionsPatternProvider
See Also

Reference

EditorSearchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorSearchOptions.ReplaceText Property

EditorSearchOptionsReplaceText Property
Gets or sets the text with which to replace.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ReplaceText { get; set; }
Public Property ReplaceText As String
    Get
    Set

Property Value

Type: String
The text with which to replace.

Implements

ISearchOptionsReplaceText
See Also

Reference

EditorSearchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorSearchOptions.Scope Property

EditorSearchOptionsScope Property
Gets or sets an EditorSearchScope that indicates the scope in which to search.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EditorSearchScope Scope { get; set; }
Public Property Scope As EditorSearchScope
    Get
    Set

Property Value

Type: EditorSearchScope
An EditorSearchScope that indicates the scope in which to search.

Implements

IEditorSearchOptionsScope
See Also

Reference

EditorSearchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorSearchOptions.SearchUp Property

EditorSearchOptionsSearchUp Property
Gets or sets whether to search backwards.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool SearchUp { get; set; }
Public Property SearchUp As Boolean
    Get
    Set

Property Value

Type: Boolean
true if searches should be performed backwards; otherwise, false.

Implements

ISearchOptionsSearchUp
See Also

Reference

EditorSearchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorSearchOptions Methods

EditorSearchOptions Methods

The EditorSearchOptions type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property's value has changed.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

EditorSearchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorSearchOptions.Clone Method

EditorSearchOptionsClone Method
Creates a new object that is a copy of the current instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object

Return Value

Type: Object
A new object that is a copy of this instance.
See Also

Reference

EditorSearchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorSearchOptions.Equals Method

EditorSearchOptionsEquals Method
Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.
See Also

Reference

EditorSearchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorSearchOptions.GetHashCode Method

EditorSearchOptionsGetHashCode Method
Serves as a hash function for a particular type.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for the current Object.
See Also

Reference

EditorSearchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorSearchOptions.NotifyPropertyChanged Method

EditorSearchOptionsNotifyPropertyChanged Method
Notifies that a property's value has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void NotifyPropertyChanged(
    string name
)
Protected Sub NotifyPropertyChanged (
    name As String
)

Parameters

name
Type: SystemString
The name of the property.
See Also

Reference

EditorSearchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorSearchOptions Events

EditorSearchOptions Events

The EditorSearchOptions type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value is changed.
Top
See Also

Reference

EditorSearchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorSearchOptions.PropertyChanged Event

EditorSearchOptionsPropertyChanged Event
Occurs when a property value is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

EditorSearchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorViewTextChangeOptions Class

EditorViewTextChangeOptions Class
Represents options that are applied to an ITextChange, and are created from an IEditorView.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationTextChangeOptions
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditorViewTextChangeOptions

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EditorViewTextChangeOptions : TextChangeOptions,
    IEditorViewTextChangeOptions, ITextChangeOptions
Public Class EditorViewTextChangeOptions
    Inherits TextChangeOptions
    Implements IEditorViewTextChangeOptions, ITextChangeOptions

The EditorViewTextChangeOptions type exposes the following members.

Constructors
 | Name | Description
Public method | EditorViewTextChangeOptions | Initializes a new instance of the EditorViewTextChangeOptions class.
Public method | EditorViewTextChangeOptions(Object) | Initializes a new instance of the EditorViewTextChangeOptions class.
Top
Properties
 | Name | Description
Public property | BlockEditRangeAdjustFunc | Gets or sets a function that can adjust a block selection line's character Range prior to modification.
Public property | CanApplyToBlockEdit | Gets or sets whether the text change can apply to each line in a block edit when applicable.
Public property | CanMergeIntoPreviousChange | Gets or sets whether this text change can merge into the previous text change in the undo stack. (Inherited from TextChangeOptions.)
Public property | CheckReadOnly | Gets or sets whether to prevent the text change from occurring if the text range to modify is flagged as read-only. (Inherited from TextChangeOptions.)
Public property | CustomData | Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on. (Inherited from TextChangeOptions.)
Public property | IsBlock | Gets or sets whether the text change is a block change.
Public property | OffsetDelta | Gets or sets how an ITextChange's ITextChangeOperation offsets are modified based on previously-added operations. (Inherited from TextChangeOptions.)
Public property | RetainSelection | Gets or sets whether to prevent the caret from moving to the end of the text change in the active view. (Inherited from TextChangeOptions.)
Public property | SelectInsertedText | Gets or sets whether to select the text that is inserted into the document.
Public property | Source | Gets or sets the optional source of the text change, which is most often an editor view if specified. (Inherited from TextChangeOptions.)
Public property | VirtualCharacterFill | Gets or sets whether when at a virtual character position, the text change will insert whitespace into the document to fill up to the insertion point's TextPosition.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorViewTextChangeOptions Constructor

EditorViewTextChangeOptions Constructor
Overload List
 | Name | Description
Public method | EditorViewTextChangeOptions | Initializes a new instance of the EditorViewTextChangeOptions class.
Public method | EditorViewTextChangeOptions(Object) | Initializes a new instance of the EditorViewTextChangeOptions class.
Top
See Also

Reference

EditorViewTextChangeOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorViewTextChangeOptions Constructor

EditorViewTextChangeOptions Constructor
Initializes a new instance of the EditorViewTextChangeOptions class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EditorViewTextChangeOptions()
Public Sub New
See Also

Reference

EditorViewTextChangeOptions Class
EditorViewTextChangeOptions Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorViewTextChangeOptions Constructor (Object)

EditorViewTextChangeOptions Constructor (Object)
Initializes a new instance of the EditorViewTextChangeOptions class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EditorViewTextChangeOptions(
    Object source
)
Public Sub New (
    source As Object
)

Parameters

source
Type: SystemObject
The optional source of the text change, which is most often a editor view if specified.
See Also

Reference

EditorViewTextChangeOptions Class
EditorViewTextChangeOptions Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorViewTextChangeOptions Properties

EditorViewTextChangeOptions Properties

The EditorViewTextChangeOptions type exposes the following members.

Properties
 | Name | Description
Public property | BlockEditRangeAdjustFunc | Gets or sets a function that can adjust a block selection line's character Range prior to modification.
Public property | CanApplyToBlockEdit | Gets or sets whether the text change can apply to each line in a block edit when applicable.
Public property | CanMergeIntoPreviousChange | Gets or sets whether this text change can merge into the previous text change in the undo stack. (Inherited from TextChangeOptions.)
Public property | CheckReadOnly | Gets or sets whether to prevent the text change from occurring if the text range to modify is flagged as read-only. (Inherited from TextChangeOptions.)
Public property | CustomData | Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on. (Inherited from TextChangeOptions.)
Public property | IsBlock | Gets or sets whether the text change is a block change.
Public property | OffsetDelta | Gets or sets how an ITextChange's ITextChangeOperation offsets are modified based on previously-added operations. (Inherited from TextChangeOptions.)
Public property | RetainSelection | Gets or sets whether to prevent the caret from moving to the end of the text change in the active view. (Inherited from TextChangeOptions.)
Public property | SelectInsertedText | Gets or sets whether to select the text that is inserted into the document.
Public property | Source | Gets or sets the optional source of the text change, which is most often an editor view if specified. (Inherited from TextChangeOptions.)
Public property | VirtualCharacterFill | Gets or sets whether when at a virtual character position, the text change will insert whitespace into the document to fill up to the insertion point's TextPosition.
Top
See Also

Reference

EditorViewTextChangeOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorViewTextChangeOptions.BlockEditRangeAdjustFunc Property

EditorViewTextChangeOptionsBlockEditRangeAdjustFunc Property
Gets or sets a function that can adjust a block selection line's character Range prior to modification.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Func<IEditorViewLine, Range, Range> BlockEditRangeAdjustFunc { get; set; }
Public Property BlockEditRangeAdjustFunc As Func(Of IEditorViewLine, Range, Range)
    Get
    Set

Property Value

Type: Func IEditorViewLine, Range, Range
A function that can adjust a block selection line's character Range prior to modification.

Implements

IEditorViewTextChangeOptionsBlockEditRangeAdjustFunc
Remarks
This option is only used in editor view change methods such as ReplaceSelectedText. This property is generally used to handle zero-width character Range scenarios during block edits.
See Also

Reference

EditorViewTextChangeOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorViewTextChangeOptions.CanApplyToBlockEdit Property

EditorViewTextChangeOptionsCanApplyToBlockEdit Property
Gets or sets whether the text change can apply to each line in a block edit when applicable.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanApplyToBlockEdit { get; set; }
Public Property CanApplyToBlockEdit As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the text change can apply to each line in a block edit when applicable; otherwise, false.

Implements

IEditorViewTextChangeOptionsCanApplyToBlockEdit
Remarks
This option is only used in editor view change methods such as ReplaceSelectedText.
See Also

Reference

EditorViewTextChangeOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorViewTextChangeOptions.IsBlock Property

EditorViewTextChangeOptionsIsBlock Property
Gets or sets whether the text change is a block change.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsBlock { get; set; }
Public Property IsBlock As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the text change is a block change; otherwise, false.

Implements

IEditorViewTextChangeOptionsIsBlock
Remarks
This option is only used in editor view change methods such as ReplaceSelectedText.
See Also

Reference

EditorViewTextChangeOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorViewTextChangeOptions.SelectInsertedText Property

EditorViewTextChangeOptionsSelectInsertedText Property
Gets or sets whether to select the text that is inserted into the document.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool SelectInsertedText { get; set; }
Public Property SelectInsertedText As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the inserted text should be selected; otherwise, false.

Implements

IEditorViewTextChangeOptionsSelectInsertedText
Remarks
This option is only used in editor view change methods such as ReplaceSelectedText.
See Also

Reference

EditorViewTextChangeOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorViewTextChangeOptions.VirtualCharacterFill Property

EditorViewTextChangeOptionsVirtualCharacterFill Property
Gets or sets whether when at a virtual character position, the text change will insert whitespace into the document to fill up to the insertion point's TextPosition.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool VirtualCharacterFill { get; set; }
Public Property VirtualCharacterFill As Boolean
    Get
    Set

Property Value

Type: Boolean
true if whitespace will be inserted; otherwise, false.

Implements

IEditorViewTextChangeOptionsVirtualCharacterFill
Remarks
This option is only used in editor view change methods such as ReplaceSelectedText. It is generally used by text changes such as line feed insertion or open line actions.
See Also

Reference

EditorViewTextChangeOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


EditorViewTextChangeOptions Methods

EditorViewTextChangeOptions Methods

The EditorViewTextChangeOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

EditorViewTextChangeOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


PrintSettings Class

PrintSettings Class
Represents the default implementation of an object that supports printing the contents of a SyntaxEditor.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationPrintSettings

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PrintSettings : IPrintSettings
Public Class PrintSettings
    Implements IPrintSettings

The PrintSettings type exposes the following members.

Constructors
 | Name | Description
Public method | PrintSettings | Initializes a new instance of the PrintSettings class.
Top
Properties
 | Name | Description
Public property | DocumentTitle | Gets or sets the document title that should appear at the top of every page.
Public property | HighlightingStyleRegistry | Gets or sets the IHighlightingStyleRegistry to use for printouts, if different than the active registry in the editor.
Public property | IsDocumentTitleMarginVisible | Gets or sets whether the document title margin is visible.
Public property | IsLineNumberMarginVisible | Gets or sets whether the line number margin is visible.
Public property | IsPageNumberMarginVisible | Gets or sets whether the page number margin is visible.
Public property | IsSyntaxHighlightingEnabled | Gets or sets whether syntax highlighting is enabled.
Public property | IsWhitespaceVisible | Gets or sets whether whitespace (spaces and tabs) is visible.
Public property | IsWordWrapGlyphMarginVisible | Gets or sets whether the word wrap glyph margin is visible.
Public property | ViewMarginFactories | Gets the collection that contains the IPrinterViewMarginFactory objects used to generate the margins for an IPrinterView.
Top
Methods
 | Name | Description
Public method | CreatePrintDocument | Creates a PrintDocument that is prepared to create a representation of the editor contents, allowing for printing.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


PrintSettings Constructor

PrintSettings Constructor
Initializes a new instance of the PrintSettings class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PrintSettings()
Public Sub New
See Also

Reference

PrintSettings Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


PrintSettings Properties

PrintSettings Properties

The PrintSettings type exposes the following members.

Properties
 | Name | Description
Public property | DocumentTitle | Gets or sets the document title that should appear at the top of every page.
Public property | HighlightingStyleRegistry | Gets or sets the IHighlightingStyleRegistry to use for printouts, if different than the active registry in the editor.
Public property | IsDocumentTitleMarginVisible | Gets or sets whether the document title margin is visible.
Public property | IsLineNumberMarginVisible | Gets or sets whether the line number margin is visible.
Public property | IsPageNumberMarginVisible | Gets or sets whether the page number margin is visible.
Public property | IsSyntaxHighlightingEnabled | Gets or sets whether syntax highlighting is enabled.
Public property | IsWhitespaceVisible | Gets or sets whether whitespace (spaces and tabs) is visible.
Public property | IsWordWrapGlyphMarginVisible | Gets or sets whether the word wrap glyph margin is visible.
Public property | ViewMarginFactories | Gets the collection that contains the IPrinterViewMarginFactory objects used to generate the margins for an IPrinterView.
Top
See Also

Reference

PrintSettings Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


PrintSettings.DocumentTitle Property

PrintSettingsDocumentTitle Property
Gets or sets the document title that should appear at the top of every page.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string DocumentTitle { get; set; }
Public Property DocumentTitle As String
    Get
    Set

Property Value

Type: String
The document title that should appear at the top of every page.

Implements

IPrintSettingsDocumentTitle
Remarks
This is often set to the filename of the document.
See Also

Reference

PrintSettings Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


PrintSettings.HighlightingStyleRegistry Property

PrintSettingsHighlightingStyleRegistry Property
Gets or sets the IHighlightingStyleRegistry to use for printouts, if different than the active registry in the editor.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IHighlightingStyleRegistry HighlightingStyleRegistry { get; set; }
Public Property HighlightingStyleRegistry As IHighlightingStyleRegistry
    Get
    Set

Property Value

Type: IHighlightingStyleRegistry
The IHighlightingStyleRegistry to use for printouts, if different than the active registry in the editor.

Implements

IPrintSettingsHighlightingStyleRegistry
Remarks
If this property is , the active registry in the editor will be used. This property should generally be set when the editor is using a dark theme, since printouts require a light theme.
See Also

Reference

PrintSettings Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


PrintSettings.IsDocumentTitleMarginVisible Property

PrintSettingsIsDocumentTitleMarginVisible Property
Gets or sets whether the document title margin is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsDocumentTitleMarginVisible { get; set; }
Public Property IsDocumentTitleMarginVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the document title margin is visible; otherwise, false. The default value is true.

Implements

IPrintSettingsIsDocumentTitleMarginVisible
See Also

Reference

PrintSettings Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


PrintSettings.IsLineNumberMarginVisible Property

PrintSettingsIsLineNumberMarginVisible Property
Gets or sets whether the line number margin is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsLineNumberMarginVisible { get; set; }
Public Property IsLineNumberMarginVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the line number margin is visible; otherwise, false. The default value is false.

Implements

IPrintSettingsIsLineNumberMarginVisible
See Also

Reference

PrintSettings Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


PrintSettings.IsPageNumberMarginVisible Property

PrintSettingsIsPageNumberMarginVisible Property
Gets or sets whether the page number margin is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsPageNumberMarginVisible { get; set; }
Public Property IsPageNumberMarginVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the page number margin is visible; otherwise, false. The default value is true.

Implements

IPrintSettingsIsPageNumberMarginVisible
See Also

Reference

PrintSettings Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


PrintSettings.IsSyntaxHighlightingEnabled Property

PrintSettingsIsSyntaxHighlightingEnabled Property
Gets or sets whether syntax highlighting is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSyntaxHighlightingEnabled { get; set; }
Public Property IsSyntaxHighlightingEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if syntax highlighting is enabled; otherwise, false. The default value is true.

Implements

IPrintSettingsIsSyntaxHighlightingEnabled
See Also

Reference

PrintSettings Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


PrintSettings.IsWhitespaceVisible Property

PrintSettingsIsWhitespaceVisible Property
Gets or sets whether whitespace (spaces and tabs) is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsWhitespaceVisible { get; set; }
Public Property IsWhitespaceVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if whitespace (spaces and tabs) is visible; otherwise, false. The default value is false.

Implements

IPrintSettingsIsWhitespaceVisible
See Also

Reference

PrintSettings Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


PrintSettings.IsWordWrapGlyphMarginVisible Property

PrintSettingsIsWordWrapGlyphMarginVisible Property
Gets or sets whether the word wrap glyph margin is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsWordWrapGlyphMarginVisible { get; set; }
Public Property IsWordWrapGlyphMarginVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the word wrap glyph margin is visible; otherwise, false. The default value is true.

Implements

IPrintSettingsIsWordWrapGlyphMarginVisible
See Also

Reference

PrintSettings Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


PrintSettings.ViewMarginFactories Property

PrintSettingsViewMarginFactories Property
Gets the collection that contains the IPrinterViewMarginFactory objects used to generate the margins for an IPrinterView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IPrinterViewMarginFactoryCollection ViewMarginFactories { get; }
Public ReadOnly Property ViewMarginFactories As IPrinterViewMarginFactoryCollection
    Get

Property Value

Type: IPrinterViewMarginFactoryCollection
A IPrinterViewMarginFactoryCollection that contains the factories. The default collection contains a DefaultPrinterViewMarginFactory.

Implements

IPrintSettingsViewMarginFactories
See Also

Reference

PrintSettings Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


PrintSettings Methods

PrintSettings Methods

The PrintSettings type exposes the following members.

Methods
 | Name | Description
Public method | CreatePrintDocument | Creates a PrintDocument that is prepared to create a representation of the editor contents, allowing for printing.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PrintSettings Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


PrintSettings.CreatePrintDocument Method

PrintSettingsCreatePrintDocument Method
Creates a PrintDocument that is prepared to create a representation of the editor contents, allowing for printing.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PrintDocument CreatePrintDocument(
    SyntaxEditor syntaxEditor
)
Public Function CreatePrintDocument (
    syntaxEditor As SyntaxEditor
) As PrintDocument

Parameters

syntaxEditor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor for which to create a PrintDocument.

Field Value

Type: PrintDocument
The PrintDocument that was created.

Return Value

Type: PrintDocument

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation.PrintSettings.CreatePrintDocument(ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.SyntaxEditor)"]

Implements

IPrintSettingsCreatePrintDocument(SyntaxEditor)
See Also

Reference

PrintSettings Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation Namespace


ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace
Contains types related to working with indicators.
Interfaces
 | Interface | Description
Public interface | IBookmarkIndicatorManager | Provides the base requirements for a class containing helper methods related to working with bookmark indicators.
Public interface | IBreakpointIndicatorManager | Provides the base requirements for a class containing helper methods related to working with breakpoint indicators.
Public interface | ICurrentStatementIndicatorManager | Provides the base requirements for a class containing helper methods related to working with a current statement indicator.
Public interface | IIndicatorManager | Provides the base requirements for a manager that works with the indicators associated with an IEditorDocument.
Public interface | ILineIndicatorManagerTTagger, TTag | Provides the base requirements for a class containing helper methods related to working with an IEditorDocument's line-based indicators.
Public interface | ISingleTextRangeIndicatorManagerTTagger, TTag | Provides the base requirements for a class containing helper methods related to working with an IEditorDocument's text range-based indicators, where a single indicator instance is ever present.
Public interface | ITextRangeIndicatorManagerTTagger, TTag | Provides the base requirements for a class containing helper methods related to working with an IEditorDocument's text range-based indicators.


IBookmarkIndicatorManager Interface

IBookmarkIndicatorManager Interface
Provides the base requirements for a class containing helper methods related to working with bookmark indicators.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IBookmarkIndicatorManager : ILineIndicatorManager<BookmarkIndicatorTagger, BookmarkIndicatorTag>
Public Interface IBookmarkIndicatorManager
    Inherits ILineIndicatorManager(Of BookmarkIndicatorTagger, BookmarkIndicatorTag)

The IBookmarkIndicatorManager type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of indicators. (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public property | Item | Gets the tag range that points to the specified indicator tag. [C#] In C#, this property is the indexer for the type. (Inherited from ILineIndicatorManagerTTagger, TTag.)
Top
Methods
 | Name | Description
Public method | Add(ITextSnapshotLine) | Adds a new indicator that is associated with a single snapshot line. (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public method | Add(ITextSnapshotLine, TTag) | Adds a new indicator that is associated with a single snapshot line. (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public method | Clear | Removes all indicators. (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public method | FindNext | (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public method | GetInstances | Returns all indicator tag ranges. (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public method | GetInstances(ITextSnapshotLine) | Returns all indicator tag ranges that occur within the specified ITextSnapshotLine. (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public method | Remove | Removes a specific indicator. (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public method | RemoveAll | (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public method | Toggle(ITextSnapshotLine) | Toggles whether an indicator is associated with a single snapshot line. (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public method | Toggle(ITextSnapshotLine, TTag) | Toggles whether an indicator is associated with a single snapshot line. (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public method | ToggleEnabledState | Toggles the enabled state of the specified bookmark.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IBookmarkIndicatorManager Properties

IBookmarkIndicatorManager Properties

The IBookmarkIndicatorManager type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of indicators. (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public property | Item | Gets the tag range that points to the specified indicator tag. [C#] In C#, this property is the indexer for the type. (Inherited from ILineIndicatorManagerTTagger, TTag.)
Top
See Also

Reference

IBookmarkIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IBookmarkIndicatorManager Methods

IBookmarkIndicatorManager Methods

The IBookmarkIndicatorManager type exposes the following members.

Methods
 | Name | Description
Public method | Add(ITextSnapshotLine) | Adds a new indicator that is associated with a single snapshot line. (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public method | Add(ITextSnapshotLine, TTag) | Adds a new indicator that is associated with a single snapshot line. (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public method | Clear | Removes all indicators. (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public method | FindNext | (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public method | GetInstances | Returns all indicator tag ranges. (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public method | GetInstances(ITextSnapshotLine) | Returns all indicator tag ranges that occur within the specified ITextSnapshotLine. (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public method | Remove | Removes a specific indicator. (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public method | RemoveAll | (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public method | Toggle(ITextSnapshotLine) | Toggles whether an indicator is associated with a single snapshot line. (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public method | Toggle(ITextSnapshotLine, TTag) | Toggles whether an indicator is associated with a single snapshot line. (Inherited from ILineIndicatorManagerTTagger, TTag.)
Public method | ToggleEnabledState | Toggles the enabled state of the specified bookmark.
Top
See Also

Reference

IBookmarkIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IBookmarkIndicatorManager.ToggleEnabledState Method

IBookmarkIndicatorManagerToggleEnabledState Method
Toggles the enabled state of the specified bookmark.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ToggleEnabledState(
    BookmarkIndicatorTag tag
)
Function ToggleEnabledState (
    tag As BookmarkIndicatorTag
) As Boolean

Parameters

tag
Type: ActiproSoftware.Text.Tagging.ImplementationBookmarkIndicatorTag
The indicator tag to examine.

Return Value

Type: Boolean
true if the enabled state was toggled; otherwise, false.
See Also

Reference

IBookmarkIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IBreakpointIndicatorManager Interface

IBreakpointIndicatorManager Interface
Provides the base requirements for a class containing helper methods related to working with breakpoint indicators.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IBreakpointIndicatorManager : ITextRangeIndicatorManager<BreakpointIndicatorTagger, BreakpointIndicatorTag>
Public Interface IBreakpointIndicatorManager
    Inherits ITextRangeIndicatorManager(Of BreakpointIndicatorTagger, BreakpointIndicatorTag)

The IBreakpointIndicatorManager type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of indicators. (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public property | Item | Gets the tag range that points to the specified indicator tag. [C#] In C#, this property is the indexer for the type. (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Top
Methods
 | Name | Description
Public method | Add(TextSnapshotRange) | Adds a new default indicator that is applied to a snapshot text range. (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public method | Add(TextSnapshotRange, TTag) | Adds a new indicator that is applied to a snapshot text range. (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public method | Clear | Removes all indicators. (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public method | FindNext | (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public method | GetInstances | Returns all indicator tag ranges. (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public method | GetInstances(TextSnapshotRange) | Returns all indicator tag ranges that occur within the specified TextSnapshotRange. (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public method | Remove | Removes a specific indicator. (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public method | RemoveAll | (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public method | Toggle(TextSnapshotRange) | Toggles whether an indicator is associated with a snapshot text range. (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public method | Toggle(TextSnapshotRange, TTag) | Toggles whether an indicator is associated with a snapshot text range. (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public method | ToggleEnabledState | Toggles the enabled state of the specified breakpoint.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IBreakpointIndicatorManager Properties

IBreakpointIndicatorManager Properties

The IBreakpointIndicatorManager type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of indicators. (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public property | Item | Gets the tag range that points to the specified indicator tag. [C#] In C#, this property is the indexer for the type. (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Top
See Also

Reference

IBreakpointIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IBreakpointIndicatorManager Methods

IBreakpointIndicatorManager Methods

The IBreakpointIndicatorManager type exposes the following members.

Methods
 | Name | Description
Public method | Add(TextSnapshotRange) | Adds a new default indicator that is applied to a snapshot text range. (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public method | Add(TextSnapshotRange, TTag) | Adds a new indicator that is applied to a snapshot text range. (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public method | Clear | Removes all indicators. (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public method | FindNext | (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public method | GetInstances | Returns all indicator tag ranges. (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public method | GetInstances(TextSnapshotRange) | Returns all indicator tag ranges that occur within the specified TextSnapshotRange. (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public method | Remove | Removes a specific indicator. (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public method | RemoveAll | (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public method | Toggle(TextSnapshotRange) | Toggles whether an indicator is associated with a snapshot text range. (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public method | Toggle(TextSnapshotRange, TTag) | Toggles whether an indicator is associated with a snapshot text range. (Inherited from ITextRangeIndicatorManagerTTagger, TTag.)
Public method | ToggleEnabledState | Toggles the enabled state of the specified breakpoint.
Top
See Also

Reference

IBreakpointIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IBreakpointIndicatorManager.ToggleEnabledState Method

IBreakpointIndicatorManagerToggleEnabledState Method
Toggles the enabled state of the specified breakpoint.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ToggleEnabledState(
    BreakpointIndicatorTag tag
)
Function ToggleEnabledState (
    tag As BreakpointIndicatorTag
) As Boolean

Parameters

tag
Type: ActiproSoftware.Text.Tagging.ImplementationBreakpointIndicatorTag
The indicator tag to examine.

Return Value

Type: Boolean
true if the enabled state was toggled; otherwise, false.
See Also

Reference

IBreakpointIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ICurrentStatementIndicatorManager Interface

ICurrentStatementIndicatorManager Interface
Provides the base requirements for a class containing helper methods related to working with a current statement indicator.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICurrentStatementIndicatorManager : ISingleTextRangeIndicatorManager<CurrentStatementIndicatorTagger, CurrentStatementIndicatorTag>
Public Interface ICurrentStatementIndicatorManager
    Inherits ISingleTextRangeIndicatorManager(Of CurrentStatementIndicatorTagger, CurrentStatementIndicatorTag)

The ICurrentStatementIndicatorManager type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the tag range that points to the specified indicator tag. [C#] In C#, this property is the indexer for the type. (Inherited from ISingleTextRangeIndicatorManagerTTagger, TTag.)
Top
Methods
 | Name | Description
Public method | Clear | Removes all indicators. (Inherited from ISingleTextRangeIndicatorManagerTTagger, TTag.)
Public method | GetInstance | Returns the single indicator tag range. (Inherited from ISingleTextRangeIndicatorManagerTTagger, TTag.)
Public method | SetInstance(TextSnapshotRange) | Removes any other existing indicator and adds new default indicator that is applied to a snapshot text range. (Inherited from ISingleTextRangeIndicatorManagerTTagger, TTag.)
Public method | SetInstance(TextSnapshotRange, TTag) | Removes any other existing indicator and adds new indicator that is applied to a snapshot text range. (Inherited from ISingleTextRangeIndicatorManagerTTagger, TTag.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ICurrentStatementIndicatorManager Properties

ICurrentStatementIndicatorManager Properties

The ICurrentStatementIndicatorManager type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the tag range that points to the specified indicator tag. [C#] In C#, this property is the indexer for the type. (Inherited from ISingleTextRangeIndicatorManagerTTagger, TTag.)
Top
See Also

Reference

ICurrentStatementIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ICurrentStatementIndicatorManager Methods

ICurrentStatementIndicatorManager Methods

The ICurrentStatementIndicatorManager type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes all indicators. (Inherited from ISingleTextRangeIndicatorManagerTTagger, TTag.)
Public method | GetInstance | Returns the single indicator tag range. (Inherited from ISingleTextRangeIndicatorManagerTTagger, TTag.)
Public method | SetInstance(TextSnapshotRange) | Removes any other existing indicator and adds new default indicator that is applied to a snapshot text range. (Inherited from ISingleTextRangeIndicatorManagerTTagger, TTag.)
Public method | SetInstance(TextSnapshotRange, TTag) | Removes any other existing indicator and adds new indicator that is applied to a snapshot text range. (Inherited from ISingleTextRangeIndicatorManagerTTagger, TTag.)
Top
See Also

Reference

ICurrentStatementIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager Interface

IIndicatorManager Interface
Provides the base requirements for a manager that works with the indicators associated with an IEditorDocument.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IIndicatorManager
Public Interface IIndicatorManager

The IIndicatorManager type exposes the following members.

Properties
 | Name | Description
Public property | Bookmarks | Gets the IBookmarkIndicatorManager that can be used to manage bookmark indicators.
Public property | Breakpoints | Gets the IBreakpointIndicatorManager that can be used to manage breakpoint indicators.
Public property | CurrentStatement | Gets the ICurrentStatementIndicatorManager that can be used to manage a current statement indicator.
Public property | Document | Gets the document to which this manager is attached.
Top
Methods
 | Name | Description
Public method | AddTTagger, TTag(ITextSnapshotLine, TTag) | Adds a new indicator that is associated with a single snapshot line (e.g. a bookmark indicator).
Public method | AddTTagger, TTag(TextSnapshotRange, TTag) | Adds a new indicator that is applied to a snapshot text range (e.g. a breakpoint indicator).
Public method | ClearTTagger, TTag | Removes all indicators.
Public method | FindNextTTagger, TTag(ITextSnapshotLine, ITagSearchOptionsTTag) | Finds the next line-based indicator (e.g. a bookmark indicator), using the specified search options.
Public method | FindNextTTagger, TTag(TextSnapshotOffset, ITagSearchOptionsTTag) | Finds the next text range-based indicator (e.g. a breakpoint indicator), using the specified search options.
Public method | GetCountTTagger, TTag | Returns the number of indicators.
Public method | GetInstanceTTagger, TTag | Returns the tag range that points to the specified indicator tag.
Public method | GetInstancesTTagger, TTag | Returns all indicator tag ranges.
Public method | GetInstancesTTagger, TTag(ITextSnapshotLine) | Returns all indicator tag ranges that occur within the specified ITextSnapshotLine.
Public method | GetInstancesTTagger, TTag(TextSnapshotRange) | Returns all indicator tag ranges that occur within the specified TextSnapshotRange.
Public method | RemoveTTagger, TTag | Removes a specific indicator.
Public method | RemoveAllTTagger, TTag | Removes all indicator tag ranges that match the conditions defined by the specified predicate.
Public method | ToggleTTagger, TTag(ITextSnapshotLine, TTag) | Toggles whether an indicator is associated with a single snapshot line (e.g. a bookmark indicator).
Public method | ToggleTTagger, TTag(TextSnapshotRange, TTag) | Toggles whether an indicator is associated with a snapshot text range (e.g. a breakpoint indicator).
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager Properties

IIndicatorManager Properties

The IIndicatorManager type exposes the following members.

Properties
 | Name | Description
Public property | Bookmarks | Gets the IBookmarkIndicatorManager that can be used to manage bookmark indicators.
Public property | Breakpoints | Gets the IBreakpointIndicatorManager that can be used to manage breakpoint indicators.
Public property | CurrentStatement | Gets the ICurrentStatementIndicatorManager that can be used to manage a current statement indicator.
Public property | Document | Gets the document to which this manager is attached.
Top
See Also

Reference

IIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.Bookmarks Property

IIndicatorManagerBookmarks Property
Gets the IBookmarkIndicatorManager that can be used to manage bookmark indicators.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IBookmarkIndicatorManager Bookmarks { get; }
ReadOnly Property Bookmarks As IBookmarkIndicatorManager
    Get

Property Value

Type: IBookmarkIndicatorManager
The IBookmarkIndicatorManager that can be used to manage bookmark indicators.
See Also

Reference

IIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.Breakpoints Property

IIndicatorManagerBreakpoints Property
Gets the IBreakpointIndicatorManager that can be used to manage breakpoint indicators.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IBreakpointIndicatorManager Breakpoints { get; }
ReadOnly Property Breakpoints As IBreakpointIndicatorManager
    Get

Property Value

Type: IBreakpointIndicatorManager
The IBreakpointIndicatorManager that can be used to manage breakpoint indicators.
See Also

Reference

IIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.CurrentStatement Property

IIndicatorManagerCurrentStatement Property
Gets the ICurrentStatementIndicatorManager that can be used to manage a current statement indicator.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ICurrentStatementIndicatorManager CurrentStatement { get; }
ReadOnly Property CurrentStatement As ICurrentStatementIndicatorManager
    Get

Property Value

Type: ICurrentStatementIndicatorManager
The ICurrentStatementIndicatorManager that can be used to manage a current statement indicator.
See Also

Reference

IIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.Document Property

IIndicatorManagerDocument Property
Gets the document to which this manager is attached.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorDocument Document { get; }
ReadOnly Property Document As IEditorDocument
    Get

Property Value

Type: IEditorDocument
The document to which this manager is attached.
See Also

Reference

IIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager Methods

IIndicatorManager Methods

The IIndicatorManager type exposes the following members.

Methods
 | Name | Description
Public method | AddTTagger, TTag(ITextSnapshotLine, TTag) | Adds a new indicator that is associated with a single snapshot line (e.g. a bookmark indicator).
Public method | AddTTagger, TTag(TextSnapshotRange, TTag) | Adds a new indicator that is applied to a snapshot text range (e.g. a breakpoint indicator).
Public method | ClearTTagger, TTag | Removes all indicators.
Public method | FindNextTTagger, TTag(ITextSnapshotLine, ITagSearchOptionsTTag) | Finds the next line-based indicator (e.g. a bookmark indicator), using the specified search options.
Public method | FindNextTTagger, TTag(TextSnapshotOffset, ITagSearchOptionsTTag) | Finds the next text range-based indicator (e.g. a breakpoint indicator), using the specified search options.
Public method | GetCountTTagger, TTag | Returns the number of indicators.
Public method | GetInstanceTTagger, TTag | Returns the tag range that points to the specified indicator tag.
Public method | GetInstancesTTagger, TTag | Returns all indicator tag ranges.
Public method | GetInstancesTTagger, TTag(ITextSnapshotLine) | Returns all indicator tag ranges that occur within the specified ITextSnapshotLine.
Public method | GetInstancesTTagger, TTag(TextSnapshotRange) | Returns all indicator tag ranges that occur within the specified TextSnapshotRange.
Public method | RemoveTTagger, TTag | Removes a specific indicator.
Public method | RemoveAllTTagger, TTag | Removes all indicator tag ranges that match the conditions defined by the specified predicate.
Public method | ToggleTTagger, TTag(ITextSnapshotLine, TTag) | Toggles whether an indicator is associated with a single snapshot line (e.g. a bookmark indicator).
Public method | ToggleTTagger, TTag(TextSnapshotRange, TTag) | Toggles whether an indicator is associated with a snapshot text range (e.g. a breakpoint indicator).
Top
See Also

Reference

IIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.Add Method

IIndicatorManagerAdd Method
Overload List
 | Name | Description
Public method | AddTTagger, TTag(ITextSnapshotLine, TTag) | Adds a new indicator that is associated with a single snapshot line (e.g. a bookmark indicator).
Public method | AddTTagger, TTag(TextSnapshotRange, TTag) | Adds a new indicator that is applied to a snapshot text range (e.g. a breakpoint indicator).
Top
See Also

Reference

IIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.Add(TTagger, TTag) Method (ITextSnapshotLine, TTag)

IIndicatorManagerAddTTagger, TTag Method (ITextSnapshotLine, TTag)
Adds a new indicator that is associated with a single snapshot line (e.g. a bookmark indicator).

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> Add<TTagger, TTag>(
    ITextSnapshotLine snapshotLine,
    TTag tag
)
where TTagger : class, Object, ICollectionTagger<TTag>
where TTag : IIndicatorTag

Function Add(Of TTagger As {Class, Object, ICollectionTagger(Of TTag)}, TTag As IIndicatorTag) (
    snapshotLine As ITextSnapshotLine,
    tag As TTag
) As TagVersionRange(Of TTag)

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine
The target ITextSnapshotLine.
tag
Type: TTag
The IIndicatorTag to add.

Type Parameters

TTagger
The indicator tagger type.
TTag
The indicator tag type.

Return Value

Type: TagVersionRange TTag
The TagVersionRangeT that was created.
See Also

Reference

IIndicatorManager Interface
Add Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.Add(TTagger, TTag) Method (TextSnapshotRange, TTag)

IIndicatorManagerAddTTagger, TTag Method (TextSnapshotRange, TTag)
Adds a new indicator that is applied to a snapshot text range (e.g. a breakpoint indicator).

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> Add<TTagger, TTag>(
    TextSnapshotRange snapshotRange,
    TTag tag
)
where TTagger : class, Object, ICollectionTagger<TTag>
where TTag : IIndicatorTag

Function Add(Of TTagger As {Class, Object, ICollectionTagger(Of TTag)}, TTag As IIndicatorTag) (
    snapshotRange As TextSnapshotRange,
    tag As TTag
) As TagVersionRange(Of TTag)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The target TextSnapshotRange.
tag
Type: TTag
The IIndicatorTag to add.

Type Parameters

TTagger
The indicator tagger type.
TTag
The indicator tag type.

Return Value

Type: TagVersionRange TTag
The TagVersionRangeT that was created.
See Also

Reference

IIndicatorManager Interface
Add Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.Clear(TTagger, TTag) Method

IIndicatorManagerClearTTagger, TTag Method
Removes all indicators.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Clear<TTagger, TTag>()
where TTagger : class, Object, ICollectionTagger<TTag>
where TTag : IIndicatorTag

Sub Clear(Of TTagger As {Class, Object, ICollectionTagger(Of TTag)}, TTag As IIndicatorTag)

Type Parameters

TTagger
The indicator tagger type.
TTag
The indicator tag type.
See Also

Reference

IIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.FindNext Method

IIndicatorManagerFindNext Method
Overload List
 | Name | Description
Public method | FindNextTTagger, TTag(ITextSnapshotLine, ITagSearchOptionsTTag) | Finds the next line-based indicator (e.g. a bookmark indicator), using the specified search options.
Public method | FindNextTTagger, TTag(TextSnapshotOffset, ITagSearchOptionsTTag) | Finds the next text range-based indicator (e.g. a breakpoint indicator), using the specified search options.
Top
See Also

Reference

IIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.FindNext(TTagger, TTag) Method (ITextSnapshotLine, ITagSearchOptions(TTag))

IIndicatorManagerFindNextTTagger, TTag Method (ITextSnapshotLine, ITagSearchOptionsTTag)
Finds the next line-based indicator (e.g. a bookmark indicator), using the specified search options.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> FindNext<TTagger, TTag>(
    ITextSnapshotLine snapshotLine,
    ITagSearchOptions<TTag> options
)
where TTagger : class, Object, ICollectionTagger<TTag>
where TTag : IIndicatorTag

Function FindNext(Of TTagger As {Class, Object, ICollectionTagger(Of TTag)}, TTag As IIndicatorTag) (
    snapshotLine As ITextSnapshotLine,
    options As ITagSearchOptions(Of TTag)
) As TagVersionRange(Of TTag)

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine
The ITextSnapshotLine from which to start the search.
options
Type: ActiproSoftware.Text.TaggingITagSearchOptions TTag
The optional ITagSearchOptionsT that specifies search options.

Type Parameters

TTagger
The indicator tagger type.
TTag
The indicator tag type.

Return Value

Type: TagVersionRange TTag
The TagVersionRangeT that was found, if any.
See Also

Reference

IIndicatorManager Interface
FindNext Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.FindNext(TTagger, TTag) Method (TextSnapshotOffset, ITagSearchOptions(TTag))

IIndicatorManagerFindNextTTagger, TTag Method (TextSnapshotOffset, ITagSearchOptionsTTag)
Finds the next text range-based indicator (e.g. a breakpoint indicator), using the specified search options.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> FindNext<TTagger, TTag>(
    TextSnapshotOffset snapshotOffset,
    ITagSearchOptions<TTag> options
)
where TTagger : class, Object, ICollectionTagger<TTag>
where TTag : IIndicatorTag

Function FindNext(Of TTagger As {Class, Object, ICollectionTagger(Of TTag)}, TTag As IIndicatorTag) (
    snapshotOffset As TextSnapshotOffset,
    options As ITagSearchOptions(Of TTag)
) As TagVersionRange(Of TTag)

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset from which to start the search.
options
Type: ActiproSoftware.Text.TaggingITagSearchOptions TTag
The optional ITagSearchOptionsT that specifies search options.

Type Parameters

TTagger
The indicator tagger type.
TTag
The indicator tag type.

Return Value

Type: TagVersionRange TTag
The TagVersionRangeT that was found, if any.
See Also

Reference

IIndicatorManager Interface
FindNext Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.GetCount(TTagger, TTag) Method

IIndicatorManagerGetCountTTagger, TTag Method
Returns the number of indicators.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int GetCount<TTagger, TTag>()
where TTagger : class, Object, ICollectionTagger<TTag>
where TTag : IIndicatorTag

Function GetCount(Of TTagger As {Class, Object, ICollectionTagger(Of TTag)}, TTag As IIndicatorTag) As Integer

Type Parameters

TTagger
The indicator tagger type.
TTag
The indicator tag type.

Return Value

Type: Int32
The number of indicators.
See Also

Reference

IIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.GetInstance(TTagger, TTag) Method

IIndicatorManagerGetInstanceTTagger, TTag Method
Returns the tag range that points to the specified indicator tag.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> GetInstance<TTagger, TTag>(
    TTag tag
)
where TTagger : class, Object, ICollectionTagger<TTag>
where TTag : IIndicatorTag

Function GetInstance(Of TTagger As {Class, Object, ICollectionTagger(Of TTag)}, TTag As IIndicatorTag) (
    tag As TTag
) As TagVersionRange(Of TTag)

Parameters

tag
Type: TTag
The indicator tag for which to search.

Type Parameters

TTagger
The indicator tagger type.
TTag
The indicator tag type.

Return Value

Type: TagVersionRange TTag
The indicator tag range that points to the specified tag.
See Also

Reference

IIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.GetInstances Method

IIndicatorManagerGetInstances Method
Overload List
 | Name | Description
Public method | GetInstancesTTagger, TTag | Returns all indicator tag ranges.
Public method | GetInstancesTTagger, TTag(ITextSnapshotLine) | Returns all indicator tag ranges that occur within the specified ITextSnapshotLine.
Public method | GetInstancesTTagger, TTag(TextSnapshotRange) | Returns all indicator tag ranges that occur within the specified TextSnapshotRange.
Top
See Also

Reference

IIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.GetInstances(TTagger, TTag) Method

IIndicatorManagerGetInstancesTTagger, TTag Method
Returns all indicator tag ranges.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<TagVersionRange<TTag>> GetInstances<TTagger, TTag>()
where TTagger : class, Object, ICollectionTagger<TTag>
where TTag : IIndicatorTag

Function GetInstances(Of TTagger As {Class, Object, ICollectionTagger(Of TTag)}, TTag As IIndicatorTag) As IEnumerable(Of TagVersionRange(Of TTag))

Type Parameters

TTagger
The indicator tagger type.
TTag
The indicator tag type.

Return Value

Type: IEnumerable TagVersionRange TTag
The collection of indicator tag ranges.
See Also

Reference

IIndicatorManager Interface
GetInstances Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.GetInstances(TTagger, TTag) Method (ITextSnapshotLine)

IIndicatorManagerGetInstancesTTagger, TTag Method (ITextSnapshotLine)
Returns all indicator tag ranges that occur within the specified ITextSnapshotLine.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<TagVersionRange<TTag>> GetInstances<TTagger, TTag>(
    ITextSnapshotLine snapshotLine
)
where TTagger : class, Object, ICollectionTagger<TTag>
where TTag : IIndicatorTag

Function GetInstances(Of TTagger As {Class, Object, ICollectionTagger(Of TTag)}, TTag As IIndicatorTag) (
    snapshotLine As ITextSnapshotLine
) As IEnumerable(Of TagVersionRange(Of TTag))

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine
The target ITextSnapshotLine.

Type Parameters

TTagger
The indicator tagger type.
TTag
The indicator tag type.

Return Value

Type: IEnumerable TagVersionRange TTag
The collection of indicator tag ranges.
See Also

Reference

IIndicatorManager Interface
GetInstances Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.GetInstances(TTagger, TTag) Method (TextSnapshotRange)

IIndicatorManagerGetInstancesTTagger, TTag Method (TextSnapshotRange)
Returns all indicator tag ranges that occur within the specified TextSnapshotRange.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<TagVersionRange<TTag>> GetInstances<TTagger, TTag>(
    TextSnapshotRange snapshotRange
)
where TTagger : class, Object, ICollectionTagger<TTag>
where TTag : IIndicatorTag

Function GetInstances(Of TTagger As {Class, Object, ICollectionTagger(Of TTag)}, TTag As IIndicatorTag) (
    snapshotRange As TextSnapshotRange
) As IEnumerable(Of TagVersionRange(Of TTag))

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The target TextSnapshotRange.

Type Parameters

TTagger
The indicator tagger type.
TTag
The indicator tag type.

Return Value

Type: IEnumerable TagVersionRange TTag
The collection of indicator tag ranges.
See Also

Reference

IIndicatorManager Interface
GetInstances Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.Remove(TTagger, TTag) Method

IIndicatorManagerRemoveTTagger, TTag Method
Removes a specific indicator.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Remove<TTagger, TTag>(
    TTag tag
)
where TTagger : class, Object, ICollectionTagger<TTag>
where TTag : IIndicatorTag

Function Remove(Of TTagger As {Class, Object, ICollectionTagger(Of TTag)}, TTag As IIndicatorTag) (
    tag As TTag
) As Boolean

Parameters

tag
Type: TTag
The IIndicatorTag to remove.

Type Parameters

TTagger
The indicator tagger type.
TTag
The indicator tag type.

Return Value

Type: Boolean
true if the tag was removed; otherwise, false.
See Also

Reference

IIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.RemoveAll(TTagger, TTag) Method

IIndicatorManagerRemoveAllTTagger, TTag Method
Removes all indicator tag ranges that match the conditions defined by the specified predicate.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int RemoveAll<TTagger, TTag>(
    Predicate<TagVersionRange<TTag>> match
)
where TTagger : class, Object, ICollectionTagger<TTag>
where TTag : IIndicatorTag

Function RemoveAll(Of TTagger As {Class, Object, ICollectionTagger(Of TTag)}, TTag As IIndicatorTag) (
    match As Predicate(Of TagVersionRange(Of TTag))
) As Integer

Parameters

match
Type: SystemPredicate TagVersionRange TTag
The predicate that defines the conditions for removal.

Type Parameters

TTagger
The indicator tagger type.
TTag
The indicator tag type.

Return Value

Type: Int32
The number of indicator tag ranges that were removed.
See Also

Reference

IIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.Toggle Method

IIndicatorManagerToggle Method
Overload List
 | Name | Description
Public method | ToggleTTagger, TTag(ITextSnapshotLine, TTag) | Toggles whether an indicator is associated with a single snapshot line (e.g. a bookmark indicator).
Public method | ToggleTTagger, TTag(TextSnapshotRange, TTag) | Toggles whether an indicator is associated with a snapshot text range (e.g. a breakpoint indicator).
Top
See Also

Reference

IIndicatorManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.Toggle(TTagger, TTag) Method (ITextSnapshotLine, TTag)

IIndicatorManagerToggleTTagger, TTag Method (ITextSnapshotLine, TTag)
Toggles whether an indicator is associated with a single snapshot line (e.g. a bookmark indicator).

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> Toggle<TTagger, TTag>(
    ITextSnapshotLine snapshotLine,
    TTag tag
)
where TTagger : class, Object, ICollectionTagger<TTag>
where TTag : IIndicatorTag

Function Toggle(Of TTagger As {Class, Object, ICollectionTagger(Of TTag)}, TTag As IIndicatorTag) (
    snapshotLine As ITextSnapshotLine,
    tag As TTag
) As TagVersionRange(Of TTag)

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine
The target ITextSnapshotLine.
tag
Type: TTag
The IIndicatorTag to add, if no indicator is already on the line.

Type Parameters

TTagger
The indicator tagger type.
TTag
The indicator tag type.

Return Value

Type: TagVersionRange TTag
The TagVersionRangeT that was created, if an indicator was added.
See Also

Reference

IIndicatorManager Interface
Toggle Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


IIndicatorManager.Toggle(TTagger, TTag) Method (TextSnapshotRange, TTag)

IIndicatorManagerToggleTTagger, TTag Method (TextSnapshotRange, TTag)
Toggles whether an indicator is associated with a snapshot text range (e.g. a breakpoint indicator).

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> Toggle<TTagger, TTag>(
    TextSnapshotRange snapshotRange,
    TTag tag
)
where TTagger : class, Object, ICollectionTagger<TTag>
where TTag : IIndicatorTag

Function Toggle(Of TTagger As {Class, Object, ICollectionTagger(Of TTag)}, TTag As IIndicatorTag) (
    snapshotRange As TextSnapshotRange,
    tag As TTag
) As TagVersionRange(Of TTag)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The target TextSnapshotRange.
tag
Type: TTag
The IIndicatorTag to add, if no indicator is already on the line.

Type Parameters

TTagger
The indicator tagger type.
TTag
The indicator tag type.

Return Value

Type: TagVersionRange TTag
The TagVersionRangeT that was created, if an indicator was added.
See Also

Reference

IIndicatorManager Interface
Toggle Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ILineIndicatorManager(TTagger, TTag) Interface

ILineIndicatorManagerTTagger, TTag Interface
Provides the base requirements for a class containing helper methods related to working with an IEditorDocument's line-based indicators.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ILineIndicatorManager<TTagger, TTag>
where TTagger : class, Object, ICollectionTagger<TTag>
where TTag : new(), IIndicatorTag

Public Interface ILineIndicatorManager(Of TTagger As {Class, Object, ICollectionTagger(Of TTag)}, TTag As {New, IIndicatorTag})

Type Parameters

TTagger

[Missing <typeparam name="TTagger"/> documentation for "T:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators.ILineIndicatorManager`2"]

TTag

[Missing <typeparam name="TTag"/> documentation for "T:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators.ILineIndicatorManager`2"]

The ILineIndicatorManagerTTagger, TTag type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of indicators.
Public property | Item | Gets the tag range that points to the specified indicator tag. [C#] In C#, this property is the indexer for the type.
Top
Methods
 | Name | Description
Public method | Add(ITextSnapshotLine) | Adds a new indicator that is associated with a single snapshot line.
Public method | Add(ITextSnapshotLine, TTag) | Adds a new indicator that is associated with a single snapshot line.
Public method | Clear | Removes all indicators.
Public method | FindNext |
Public method | GetInstances | Returns all indicator tag ranges.
Public method | GetInstances(ITextSnapshotLine) | Returns all indicator tag ranges that occur within the specified ITextSnapshotLine.
Public method | Remove | Removes a specific indicator.
Public method | RemoveAll |
Public method | Toggle(ITextSnapshotLine) | Toggles whether an indicator is associated with a single snapshot line.
Public method | Toggle(ITextSnapshotLine, TTag) | Toggles whether an indicator is associated with a single snapshot line.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ILineIndicatorManager(TTagger, TTag) Properties

ILineIndicatorManagerTTagger, TTag Properties

The ILineIndicatorManagerTTagger, TTag generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of indicators.
Public property | Item | Gets the tag range that points to the specified indicator tag. [C#] In C#, this property is the indexer for the type.
Top
See Also

Reference

ILineIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ILineIndicatorManager(TTagger, TTag).Count Property

ILineIndicatorManagerTTagger, TTagCount Property
Gets the number of indicators.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of indicators.
See Also

Reference

ILineIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ILineIndicatorManager(TTagger, TTag).Item Property

ILineIndicatorManagerTTagger, TTagItem Property
Gets the tag range that points to the specified indicator tag.

[C#] In C#, this property is the indexer for the type.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> this[
    TTag tag
] { get; }
ReadOnly Property Item (
    tag As TTag
) As TagVersionRange(Of TTag)
    Get

Parameters

tag
Type: TTag
The indicator tag for which to search.

Property Value

Type: TagVersionRange TTag
The indicator tag range that points to the specified tag.
See Also

Reference

ILineIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ILineIndicatorManager(TTagger, TTag) Methods

ILineIndicatorManagerTTagger, TTag Methods

The ILineIndicatorManagerTTagger, TTag generic type exposes the following members.

Methods
 | Name | Description
Public method | Add(ITextSnapshotLine) | Adds a new indicator that is associated with a single snapshot line.
Public method | Add(ITextSnapshotLine, TTag) | Adds a new indicator that is associated with a single snapshot line.
Public method | Clear | Removes all indicators.
Public method | FindNext |
Public method | GetInstances | Returns all indicator tag ranges.
Public method | GetInstances(ITextSnapshotLine) | Returns all indicator tag ranges that occur within the specified ITextSnapshotLine.
Public method | Remove | Removes a specific indicator.
Public method | RemoveAll |
Public method | Toggle(ITextSnapshotLine) | Toggles whether an indicator is associated with a single snapshot line.
Public method | Toggle(ITextSnapshotLine, TTag) | Toggles whether an indicator is associated with a single snapshot line.
Top
See Also

Reference

ILineIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ILineIndicatorManager(TTagger, TTag).Add Method

ILineIndicatorManagerTTagger, TTagAdd Method
Overload List
 | Name | Description
Public method | Add(ITextSnapshotLine) | Adds a new indicator that is associated with a single snapshot line.
Public method | Add(ITextSnapshotLine, TTag) | Adds a new indicator that is associated with a single snapshot line.
Top
See Also

Reference

ILineIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ILineIndicatorManager(TTagger, TTag).Add Method (ITextSnapshotLine)

ILineIndicatorManagerTTagger, TTagAdd Method (ITextSnapshotLine)
Adds a new indicator that is associated with a single snapshot line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> Add(
    ITextSnapshotLine snapshotLine
)
Function Add (
    snapshotLine As ITextSnapshotLine
) As TagVersionRange(Of TTag)

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine
The target ITextSnapshotLine.

Return Value

Type: TagVersionRange TTag
The TagVersionRangeT that was created.
See Also

Reference

ILineIndicatorManagerTTagger, TTag Interface
Add Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ILineIndicatorManager(TTagger, TTag).Add Method (ITextSnapshotLine, TTag)

ILineIndicatorManagerTTagger, TTagAdd Method (ITextSnapshotLine, TTag)
Adds a new indicator that is associated with a single snapshot line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> Add(
    ITextSnapshotLine snapshotLine,
    TTag tag
)
Function Add (
    snapshotLine As ITextSnapshotLine,
    tag As TTag
) As TagVersionRange(Of TTag)

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine
The target ITextSnapshotLine.
tag
Type: TTag
The IIndicatorTag to add.

Return Value

Type: TagVersionRange TTag
The TagVersionRangeT that was created.
See Also

Reference

ILineIndicatorManagerTTagger, TTag Interface
Add Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ILineIndicatorManager(TTagger, TTag).Clear Method

ILineIndicatorManagerTTagger, TTagClear Method
Removes all indicators.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Clear()
Sub Clear
See Also

Reference

ILineIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ILineIndicatorManager(TTagger, TTag).FindNext Method

ILineIndicatorManagerTTagger, TTagFindNext Method

[Missing <summary> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators.ILineIndicatorManager`2.FindNext(ActiproSoftware.Text.ITextSnapshotLine,ActiproSoftware.Text.Tagging.ITagSearchOptions{`1})"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> FindNext(
    ITextSnapshotLine snapshotLine,
    ITagSearchOptions<TTag> options
)
Function FindNext (
    snapshotLine As ITextSnapshotLine,
    options As ITagSearchOptions(Of TTag)
) As TagVersionRange(Of TTag)

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine

[Missing <param name="snapshotLine"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators.ILineIndicatorManager`2.FindNext(ActiproSoftware.Text.ITextSnapshotLine,ActiproSoftware.Text.Tagging.ITagSearchOptions{`1})"]

options
Type: ActiproSoftware.Text.TaggingITagSearchOptions TTag

[Missing <param name="options"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators.ILineIndicatorManager`2.FindNext(ActiproSoftware.Text.ITextSnapshotLine,ActiproSoftware.Text.Tagging.ITagSearchOptions{`1})"]

Return Value

Type: TagVersionRange TTag

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators.ILineIndicatorManager`2.FindNext(ActiproSoftware.Text.ITextSnapshotLine,ActiproSoftware.Text.Tagging.ITagSearchOptions{`1})"]

See Also

Reference

ILineIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ILineIndicatorManager(TTagger, TTag).GetInstances Method

ILineIndicatorManagerTTagger, TTagGetInstances Method
Overload List
 | Name | Description
Public method | GetInstances | Returns all indicator tag ranges.
Public method | GetInstances(ITextSnapshotLine) | Returns all indicator tag ranges that occur within the specified ITextSnapshotLine.
Top
See Also

Reference

ILineIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ILineIndicatorManager(TTagger, TTag).GetInstances Method

ILineIndicatorManagerTTagger, TTagGetInstances Method
Returns all indicator tag ranges.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<TagVersionRange<TTag>> GetInstances()
Function GetInstances As IEnumerable(Of TagVersionRange(Of TTag))

Return Value

Type: IEnumerable TagVersionRange TTag
The collection of indicator tag ranges.
See Also

Reference

ILineIndicatorManagerTTagger, TTag Interface
GetInstances Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ILineIndicatorManager(TTagger, TTag).GetInstances Method (ITextSnapshotLine)

ILineIndicatorManagerTTagger, TTagGetInstances Method (ITextSnapshotLine)
Returns all indicator tag ranges that occur within the specified ITextSnapshotLine.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<TagVersionRange<TTag>> GetInstances(
    ITextSnapshotLine snapshotLine
)
Function GetInstances (
    snapshotLine As ITextSnapshotLine
) As IEnumerable(Of TagVersionRange(Of TTag))

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine
The target ITextSnapshotLine.

Return Value

Type: IEnumerable TagVersionRange TTag
The collection of indicator tag ranges.
See Also

Reference

ILineIndicatorManagerTTagger, TTag Interface
GetInstances Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ILineIndicatorManager(TTagger, TTag).Remove Method

ILineIndicatorManagerTTagger, TTagRemove Method
Removes a specific indicator.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Remove(
    TTag tag
)
Function Remove (
    tag As TTag
) As Boolean

Parameters

tag
Type: TTag
The IIndicatorTag to remove.

Return Value

Type: Boolean
true if the tag was removed; otherwise, false.
See Also

Reference

ILineIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ILineIndicatorManager(TTagger, TTag).RemoveAll Method

ILineIndicatorManagerTTagger, TTagRemoveAll Method

[Missing <summary> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators.ILineIndicatorManager`2.RemoveAll(System.Predicate{ActiproSoftware.Text.Tagging.TagVersionRange{`1}})"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int RemoveAll(
    Predicate<TagVersionRange<TTag>> match
)
Function RemoveAll (
    match As Predicate(Of TagVersionRange(Of TTag))
) As Integer

Parameters

match
Type: SystemPredicate TagVersionRange TTag

[Missing <param name="match"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators.ILineIndicatorManager`2.RemoveAll(System.Predicate{ActiproSoftware.Text.Tagging.TagVersionRange{`1}})"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators.ILineIndicatorManager`2.RemoveAll(System.Predicate{ActiproSoftware.Text.Tagging.TagVersionRange{`1}})"]

See Also

Reference

ILineIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ILineIndicatorManager(TTagger, TTag).Toggle Method

ILineIndicatorManagerTTagger, TTagToggle Method
Overload List
 | Name | Description
Public method | Toggle(ITextSnapshotLine) | Toggles whether an indicator is associated with a single snapshot line.
Public method | Toggle(ITextSnapshotLine, TTag) | Toggles whether an indicator is associated with a single snapshot line.
Top
See Also

Reference

ILineIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ILineIndicatorManager(TTagger, TTag).Toggle Method (ITextSnapshotLine)

ILineIndicatorManagerTTagger, TTagToggle Method (ITextSnapshotLine)
Toggles whether an indicator is associated with a single snapshot line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> Toggle(
    ITextSnapshotLine snapshotLine
)
Function Toggle (
    snapshotLine As ITextSnapshotLine
) As TagVersionRange(Of TTag)

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine
The target ITextSnapshotLine.

Return Value

Type: TagVersionRange TTag
The TagVersionRangeT that was created, if an indicator was added.
See Also

Reference

ILineIndicatorManagerTTagger, TTag Interface
Toggle Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ILineIndicatorManager(TTagger, TTag).Toggle Method (ITextSnapshotLine, TTag)

ILineIndicatorManagerTTagger, TTagToggle Method (ITextSnapshotLine, TTag)
Toggles whether an indicator is associated with a single snapshot line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> Toggle(
    ITextSnapshotLine snapshotLine,
    TTag tag
)
Function Toggle (
    snapshotLine As ITextSnapshotLine,
    tag As TTag
) As TagVersionRange(Of TTag)

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine
The target ITextSnapshotLine.
tag
Type: TTag
The IIndicatorTag to add, if no indicator is already on the line.

Return Value

Type: TagVersionRange TTag
The TagVersionRangeT that was created, if an indicator was added.
See Also

Reference

ILineIndicatorManagerTTagger, TTag Interface
Toggle Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ISingleTextRangeIndicatorManager(TTagger, TTag) Interface

ISingleTextRangeIndicatorManagerTTagger, TTag Interface
Provides the base requirements for a class containing helper methods related to working with an IEditorDocument's text range-based indicators, where a single indicator instance is ever present.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ISingleTextRangeIndicatorManager<TTagger, TTag>
where TTagger : class, Object, ICollectionTagger<TTag>
where TTag : new(), IIndicatorTag

Public Interface ISingleTextRangeIndicatorManager(Of TTagger As {Class, Object, ICollectionTagger(Of TTag)}, TTag As {New, IIndicatorTag})

Type Parameters

TTagger

[Missing <typeparam name="TTagger"/> documentation for "T:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators.ISingleTextRangeIndicatorManager`2"]

TTag

[Missing <typeparam name="TTag"/> documentation for "T:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators.ISingleTextRangeIndicatorManager`2"]

The ISingleTextRangeIndicatorManagerTTagger, TTag type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the tag range that points to the specified indicator tag. [C#] In C#, this property is the indexer for the type.
Top
Methods
 | Name | Description
Public method | Clear | Removes all indicators.
Public method | GetInstance | Returns the single indicator tag range.
Public method | SetInstance(TextSnapshotRange) | Removes any other existing indicator and adds new default indicator that is applied to a snapshot text range.
Public method | SetInstance(TextSnapshotRange, TTag) | Removes any other existing indicator and adds new indicator that is applied to a snapshot text range.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ISingleTextRangeIndicatorManager(TTagger, TTag) Properties

ISingleTextRangeIndicatorManagerTTagger, TTag Properties

The ISingleTextRangeIndicatorManagerTTagger, TTag generic type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the tag range that points to the specified indicator tag. [C#] In C#, this property is the indexer for the type.
Top
See Also

Reference

ISingleTextRangeIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ISingleTextRangeIndicatorManager(TTagger, TTag).Item Property

ISingleTextRangeIndicatorManagerTTagger, TTagItem Property
Gets the tag range that points to the specified indicator tag.

[C#] In C#, this property is the indexer for the type.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> this[
    TTag tag
] { get; }
ReadOnly Property Item (
    tag As TTag
) As TagVersionRange(Of TTag)
    Get

Parameters

tag
Type: TTag
The indicator tag for which to search.

Property Value

Type: TagVersionRange TTag
The indicator tag range that points to the specified tag.
See Also

Reference

ISingleTextRangeIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ISingleTextRangeIndicatorManager(TTagger, TTag) Methods

ISingleTextRangeIndicatorManagerTTagger, TTag Methods

The ISingleTextRangeIndicatorManagerTTagger, TTag generic type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes all indicators.
Public method | GetInstance | Returns the single indicator tag range.
Public method | SetInstance(TextSnapshotRange) | Removes any other existing indicator and adds new default indicator that is applied to a snapshot text range.
Public method | SetInstance(TextSnapshotRange, TTag) | Removes any other existing indicator and adds new indicator that is applied to a snapshot text range.
Top
See Also

Reference

ISingleTextRangeIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ISingleTextRangeIndicatorManager(TTagger, TTag).Clear Method

ISingleTextRangeIndicatorManagerTTagger, TTagClear Method
Removes all indicators.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Clear()
Sub Clear
See Also

Reference

ISingleTextRangeIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ISingleTextRangeIndicatorManager(TTagger, TTag).GetInstance Method

ISingleTextRangeIndicatorManagerTTagger, TTagGetInstance Method
Returns the single indicator tag range.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> GetInstance()
Function GetInstance As TagVersionRange(Of TTag)

Return Value

Type: TagVersionRange TTag
The collection of indicator tag ranges.
See Also

Reference

ISingleTextRangeIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ISingleTextRangeIndicatorManager(TTagger, TTag).SetInstance Method

ISingleTextRangeIndicatorManagerTTagger, TTagSetInstance Method
Overload List
 | Name | Description
Public method | SetInstance(TextSnapshotRange) | Removes any other existing indicator and adds new default indicator that is applied to a snapshot text range.
Public method | SetInstance(TextSnapshotRange, TTag) | Removes any other existing indicator and adds new indicator that is applied to a snapshot text range.
Top
See Also

Reference

ISingleTextRangeIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ISingleTextRangeIndicatorManager(TTagger, TTag).SetInstance Method (TextSnapshotRange)

ISingleTextRangeIndicatorManagerTTagger, TTagSetInstance Method (TextSnapshotRange)
Removes any other existing indicator and adds new default indicator that is applied to a snapshot text range.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> SetInstance(
    TextSnapshotRange snapshotRange
)
Function SetInstance (
    snapshotRange As TextSnapshotRange
) As TagVersionRange(Of TTag)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The target TextSnapshotRange.

Return Value

Type: TagVersionRange TTag
The TagVersionRangeT that was created.
See Also

Reference

ISingleTextRangeIndicatorManagerTTagger, TTag Interface
SetInstance Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ISingleTextRangeIndicatorManager(TTagger, TTag).SetInstance Method (TextSnapshotRange, TTag)

ISingleTextRangeIndicatorManagerTTagger, TTagSetInstance Method (TextSnapshotRange, TTag)
Removes any other existing indicator and adds new indicator that is applied to a snapshot text range.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> SetInstance(
    TextSnapshotRange snapshotRange,
    TTag tag
)
Function SetInstance (
    snapshotRange As TextSnapshotRange,
    tag As TTag
) As TagVersionRange(Of TTag)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The target TextSnapshotRange.
tag
Type: TTag
The IIndicatorTag to add.

Return Value

Type: TagVersionRange TTag
The TagVersionRangeT that was created.
See Also

Reference

ISingleTextRangeIndicatorManagerTTagger, TTag Interface
SetInstance Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ITextRangeIndicatorManager(TTagger, TTag) Interface

ITextRangeIndicatorManagerTTagger, TTag Interface
Provides the base requirements for a class containing helper methods related to working with an IEditorDocument's text range-based indicators.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextRangeIndicatorManager<TTagger, TTag>
where TTagger : class, Object, ICollectionTagger<TTag>
where TTag : new(), IIndicatorTag

Public Interface ITextRangeIndicatorManager(Of TTagger As {Class, Object, ICollectionTagger(Of TTag)}, TTag As {New, IIndicatorTag})

Type Parameters

TTagger

[Missing <typeparam name="TTagger"/> documentation for "T:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators.ITextRangeIndicatorManager`2"]

TTag

[Missing <typeparam name="TTag"/> documentation for "T:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators.ITextRangeIndicatorManager`2"]

The ITextRangeIndicatorManagerTTagger, TTag type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of indicators.
Public property | Item | Gets the tag range that points to the specified indicator tag. [C#] In C#, this property is the indexer for the type.
Top
Methods
 | Name | Description
Public method | Add(TextSnapshotRange) | Adds a new default indicator that is applied to a snapshot text range.
Public method | Add(TextSnapshotRange, TTag) | Adds a new indicator that is applied to a snapshot text range.
Public method | Clear | Removes all indicators.
Public method | FindNext |
Public method | GetInstances | Returns all indicator tag ranges.
Public method | GetInstances(TextSnapshotRange) | Returns all indicator tag ranges that occur within the specified TextSnapshotRange.
Public method | Remove | Removes a specific indicator.
Public method | RemoveAll |
Public method | Toggle(TextSnapshotRange) | Toggles whether an indicator is associated with a snapshot text range.
Public method | Toggle(TextSnapshotRange, TTag) | Toggles whether an indicator is associated with a snapshot text range.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ITextRangeIndicatorManager(TTagger, TTag) Properties

ITextRangeIndicatorManagerTTagger, TTag Properties

The ITextRangeIndicatorManagerTTagger, TTag generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of indicators.
Public property | Item | Gets the tag range that points to the specified indicator tag. [C#] In C#, this property is the indexer for the type.
Top
See Also

Reference

ITextRangeIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ITextRangeIndicatorManager(TTagger, TTag).Count Property

ITextRangeIndicatorManagerTTagger, TTagCount Property
Gets the number of indicators.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of indicators.
See Also

Reference

ITextRangeIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ITextRangeIndicatorManager(TTagger, TTag).Item Property

ITextRangeIndicatorManagerTTagger, TTagItem Property
Gets the tag range that points to the specified indicator tag.

[C#] In C#, this property is the indexer for the type.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> this[
    TTag tag
] { get; }
ReadOnly Property Item (
    tag As TTag
) As TagVersionRange(Of TTag)
    Get

Parameters

tag
Type: TTag
The indicator tag for which to search.

Property Value

Type: TagVersionRange TTag
The indicator tag range that points to the specified tag.
See Also

Reference

ITextRangeIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ITextRangeIndicatorManager(TTagger, TTag) Methods

ITextRangeIndicatorManagerTTagger, TTag Methods

The ITextRangeIndicatorManagerTTagger, TTag generic type exposes the following members.

Methods
 | Name | Description
Public method | Add(TextSnapshotRange) | Adds a new default indicator that is applied to a snapshot text range.
Public method | Add(TextSnapshotRange, TTag) | Adds a new indicator that is applied to a snapshot text range.
Public method | Clear | Removes all indicators.
Public method | FindNext |
Public method | GetInstances | Returns all indicator tag ranges.
Public method | GetInstances(TextSnapshotRange) | Returns all indicator tag ranges that occur within the specified TextSnapshotRange.
Public method | Remove | Removes a specific indicator.
Public method | RemoveAll |
Public method | Toggle(TextSnapshotRange) | Toggles whether an indicator is associated with a snapshot text range.
Public method | Toggle(TextSnapshotRange, TTag) | Toggles whether an indicator is associated with a snapshot text range.
Top
See Also

Reference

ITextRangeIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ITextRangeIndicatorManager(TTagger, TTag).Add Method

ITextRangeIndicatorManagerTTagger, TTagAdd Method
Overload List
 | Name | Description
Public method | Add(TextSnapshotRange) | Adds a new default indicator that is applied to a snapshot text range.
Public method | Add(TextSnapshotRange, TTag) | Adds a new indicator that is applied to a snapshot text range.
Top
See Also

Reference

ITextRangeIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ITextRangeIndicatorManager(TTagger, TTag).Add Method (TextSnapshotRange)

ITextRangeIndicatorManagerTTagger, TTagAdd Method (TextSnapshotRange)
Adds a new default indicator that is applied to a snapshot text range.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> Add(
    TextSnapshotRange snapshotRange
)
Function Add (
    snapshotRange As TextSnapshotRange
) As TagVersionRange(Of TTag)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The target TextSnapshotRange.

Return Value

Type: TagVersionRange TTag
The TagVersionRangeT that was created.
See Also

Reference

ITextRangeIndicatorManagerTTagger, TTag Interface
Add Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ITextRangeIndicatorManager(TTagger, TTag).Add Method (TextSnapshotRange, TTag)

ITextRangeIndicatorManagerTTagger, TTagAdd Method (TextSnapshotRange, TTag)
Adds a new indicator that is applied to a snapshot text range.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> Add(
    TextSnapshotRange snapshotRange,
    TTag tag
)
Function Add (
    snapshotRange As TextSnapshotRange,
    tag As TTag
) As TagVersionRange(Of TTag)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The target TextSnapshotRange.
tag
Type: TTag
The IIndicatorTag to add.

Return Value

Type: TagVersionRange TTag
The TagVersionRangeT that was created.
See Also

Reference

ITextRangeIndicatorManagerTTagger, TTag Interface
Add Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ITextRangeIndicatorManager(TTagger, TTag).Clear Method

ITextRangeIndicatorManagerTTagger, TTagClear Method
Removes all indicators.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Clear()
Sub Clear
See Also

Reference

ITextRangeIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ITextRangeIndicatorManager(TTagger, TTag).FindNext Method

ITextRangeIndicatorManagerTTagger, TTagFindNext Method

[Missing <summary> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators.ITextRangeIndicatorManager`2.FindNext(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.Tagging.ITagSearchOptions{`1})"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> FindNext(
    TextSnapshotOffset snapshotOffset,
    ITagSearchOptions<TTag> options
)
Function FindNext (
    snapshotOffset As TextSnapshotOffset,
    options As ITagSearchOptions(Of TTag)
) As TagVersionRange(Of TTag)

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset

[Missing <param name="snapshotOffset"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators.ITextRangeIndicatorManager`2.FindNext(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.Tagging.ITagSearchOptions{`1})"]

options
Type: ActiproSoftware.Text.TaggingITagSearchOptions TTag

[Missing <param name="options"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators.ITextRangeIndicatorManager`2.FindNext(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.Tagging.ITagSearchOptions{`1})"]

Return Value

Type: TagVersionRange TTag

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators.ITextRangeIndicatorManager`2.FindNext(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.Tagging.ITagSearchOptions{`1})"]

See Also

Reference

ITextRangeIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ITextRangeIndicatorManager(TTagger, TTag).GetInstances Method

ITextRangeIndicatorManagerTTagger, TTagGetInstances Method
Overload List
 | Name | Description
Public method | GetInstances | Returns all indicator tag ranges.
Public method | GetInstances(TextSnapshotRange) | Returns all indicator tag ranges that occur within the specified TextSnapshotRange.
Top
See Also

Reference

ITextRangeIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ITextRangeIndicatorManager(TTagger, TTag).GetInstances Method

ITextRangeIndicatorManagerTTagger, TTagGetInstances Method
Returns all indicator tag ranges.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<TagVersionRange<TTag>> GetInstances()
Function GetInstances As IEnumerable(Of TagVersionRange(Of TTag))

Return Value

Type: IEnumerable TagVersionRange TTag
The collection of indicator tag ranges.
See Also

Reference

ITextRangeIndicatorManagerTTagger, TTag Interface
GetInstances Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ITextRangeIndicatorManager(TTagger, TTag).GetInstances Method (TextSnapshotRange)

ITextRangeIndicatorManagerTTagger, TTagGetInstances Method (TextSnapshotRange)
Returns all indicator tag ranges that occur within the specified TextSnapshotRange.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<TagVersionRange<TTag>> GetInstances(
    TextSnapshotRange snapshotRange
)
Function GetInstances (
    snapshotRange As TextSnapshotRange
) As IEnumerable(Of TagVersionRange(Of TTag))

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The target TextSnapshotRange.

Return Value

Type: IEnumerable TagVersionRange TTag
The collection of indicator tag ranges.
See Also

Reference

ITextRangeIndicatorManagerTTagger, TTag Interface
GetInstances Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ITextRangeIndicatorManager(TTagger, TTag).Remove Method

ITextRangeIndicatorManagerTTagger, TTagRemove Method
Removes a specific indicator.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Remove(
    TTag tag
)
Function Remove (
    tag As TTag
) As Boolean

Parameters

tag
Type: TTag
The IIndicatorTag to remove.

Return Value

Type: Boolean
true if the tag was removed; otherwise, false.
See Also

Reference

ITextRangeIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ITextRangeIndicatorManager(TTagger, TTag).RemoveAll Method

ITextRangeIndicatorManagerTTagger, TTagRemoveAll Method

[Missing <summary> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators.ITextRangeIndicatorManager`2.RemoveAll(System.Predicate{ActiproSoftware.Text.Tagging.TagVersionRange{`1}})"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int RemoveAll(
    Predicate<TagVersionRange<TTag>> match
)
Function RemoveAll (
    match As Predicate(Of TagVersionRange(Of TTag))
) As Integer

Parameters

match
Type: SystemPredicate TagVersionRange TTag

[Missing <param name="match"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators.ITextRangeIndicatorManager`2.RemoveAll(System.Predicate{ActiproSoftware.Text.Tagging.TagVersionRange{`1}})"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators.ITextRangeIndicatorManager`2.RemoveAll(System.Predicate{ActiproSoftware.Text.Tagging.TagVersionRange{`1}})"]

See Also

Reference

ITextRangeIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ITextRangeIndicatorManager(TTagger, TTag).Toggle Method

ITextRangeIndicatorManagerTTagger, TTagToggle Method
Overload List
 | Name | Description
Public method | Toggle(TextSnapshotRange) | Toggles whether an indicator is associated with a snapshot text range.
Public method | Toggle(TextSnapshotRange, TTag) | Toggles whether an indicator is associated with a snapshot text range.
Top
See Also

Reference

ITextRangeIndicatorManagerTTagger, TTag Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ITextRangeIndicatorManager(TTagger, TTag).Toggle Method (TextSnapshotRange)

ITextRangeIndicatorManagerTTagger, TTagToggle Method (TextSnapshotRange)
Toggles whether an indicator is associated with a snapshot text range.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> Toggle(
    TextSnapshotRange snapshotRange
)
Function Toggle (
    snapshotRange As TextSnapshotRange
) As TagVersionRange(Of TTag)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The target TextSnapshotRange.

Return Value

Type: TagVersionRange TTag
The TagVersionRangeT that was created, if an indicator was added.
See Also

Reference

ITextRangeIndicatorManagerTTagger, TTag Interface
Toggle Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ITextRangeIndicatorManager(TTagger, TTag).Toggle Method (TextSnapshotRange, TTag)

ITextRangeIndicatorManagerTTagger, TTagToggle Method (TextSnapshotRange, TTag)
Toggles whether an indicator is associated with a snapshot text range.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<TTag> Toggle(
    TextSnapshotRange snapshotRange,
    TTag tag
)
Function Toggle (
    snapshotRange As TextSnapshotRange,
    tag As TTag
) As TagVersionRange(Of TTag)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The target TextSnapshotRange.
tag
Type: TTag
The IIndicatorTag to add, if no indicator is already on the line.

Return Value

Type: TagVersionRange TTag
The TagVersionRangeT that was created, if an indicator was added.
See Also

Reference

ITextRangeIndicatorManagerTTagger, TTag Interface
Toggle Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators Namespace


ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace
Contains IntelliPrompt-related types for the SyntaxEditor product.
Classes
 | Class | Description
Public class | CodeSnippetKind | Indicates the kind of code snippet.
Public class | CodeSnippetTypes | Indicates the types of actions that can be performed by a code snippet.
Public class | CompletionMatchOptions | Specifies options for how an IntelliPrompt completion matches items.
Public class | CompletionSelection | Represents the current selection within an ICompletionSession.
Public class | CompletionSelectionState | Specifies the selection state of an IntelliPrompt completion item.
Public class | ImageSourceProviderConverter | Represents a value converter that returns an ImageSource from an IImageSourceProvider.
Public class | IntelliPromptSessionTypes | Provides access to the built-in IIntelliPromptSessionType instances.
Public class | NavigableRequestContexts | Provides access to the built-in INavigableRequestContext instances, that indicate the context of a navigable request.
Public class | QuickInfoProviderKeys | Specifies the string keys of the built-in IQuickInfoProvider objects that are included with this product.
Interfaces
 | Interface | Description
Public interface | ICodeSnippet | Provides the base requirements for a code snippet.
Public interface | ICodeSnippetAssemblyReference | Provides the base requirements for an assembly reference within a code snippet.
Public interface | ICodeSnippetDeclaration | Provides the base requirements for a code snippet declaration.
Public interface | ICodeSnippetFolder | Provides the base requirements for a folder that can contain ICodeSnippetProvider objects and other child folders.
Public interface | ICodeSnippetLiteralDeclaration | Provides the base requirements for a code snippet literal declaration.
Public interface | ICodeSnippetMetadata | Provides the base requirements for an object that contains metadata information about an ICodeSnippet and can provide the full snippet on demand.
Public interface | ICodeSnippetObjectDeclaration | Provides the base requirements for a code snippet object declaration.
Public interface | ICodeSnippetProvider | Provides the base requirements for an object that can manage the available code snippets and handle requests for display of IntelliPrompt code snippet sessions.
Public interface | ICodeSnippetSelectionSession | Provides the base requirements for an object that represents an IntelliPrompt code snippet selection session.
Public interface | ICodeSnippetTemplateSession | Provides the base requirements for an object that represents an IntelliPrompt code snippet template session.
Public interface | ICodeSnippetTemplateSessionEventSink | Provides the base requirements for an object that can be notified of events that occur within an open ICodeSnippetTemplateSession.
Public interface | ICompletionFilter | Provides the base requirements for an object that can filter out items from an IntelliPrompt completion list.
Public interface | ICompletionFilterCollection | Provides the base requirements for an object that represents a collection of ICompletionFilter objects.
Public interface | ICompletionItem | Provides the base requirements for an IntelliPrompt completion item.
Public interface | ICompletionItemCollection | Provides the base requirements for an object that represents a collection of ICompletionItem objects.
Public interface | ICompletionItemMatcher | Provides the base requirements for an object that can match completion items based on supplied text.
Public interface | ICompletionItemMatcherCollection | Provides the base requirements for an object that represents a collection of ICompletionItemMatcher objects.
Public interface | ICompletionProvider | Provides the base requirements for an object that can handle requests for display of an IntelliPrompt completion list.
Public interface | ICompletionSession | Provides the base requirements for an object that represents an IntelliPrompt completion session.
Public interface | IContentProvider | Provides the base requirements for an object that generates content to be used in various IntelliPrompt popups.
Public interface | IImageSourceProvider | Provides the base requirements for an object that provides IntelliPrompt with an ImageSource.
Public interface | IIntelliPromptManager | Provides the base requirements for an object that represents a manager of IntelliPrompt user interface functionality.
Public interface | IIntelliPromptSession | Provides the base requirements for an object that represents an IntelliPrompt session.
Public interface | IIntelliPromptSessionCollection | Provides the base requirements for an object that represents a collection of IIntelliPromptSession objects.
Public interface | IIntelliPromptSessionType | Provides the base requirements for an object that represents an IntelliPrompt session type.
Public interface | INavigableRequestContext | Provides the base requirements for a context in which a INavigableSymbolProvider is called.
Public interface | INavigableSymbol | Provides the base requirements for a symbol (type, member, etc.) to which navigation can be made.
Public interface | INavigableSymbolProvider | Provides the base requirements for a language service that can return navigable symbols.
Public interface | INavigableSymbolSet | Provides the base requirements for a class that stores the results of a navigable symbol request.
Public interface | IParameterInfoProvider | Provides the base requirements for an object that can handle requests for display of an IntelliPrompt parameter info popup.
Public interface | IParameterInfoSession | Provides the base requirements for an object that represents an IntelliPrompt parameter info session.
Public interface | IParameterizedContentProvider | Provides the base requirements for an object that generates content to be used in various IntelliPrompt popups, and can provide additional detail for a specific parameter.
Public interface | IQuickInfoProvider | Provides the base requirements for an object that can handle requests for display of an IntelliPrompt quick info popup.
Public interface | IQuickInfoSession | Provides the base requirements for an object that represents an IntelliPrompt quick info session.
Public interface | ISignatureItem | Provides the base requirements for a signature item, used with IntelliPrompt parameter info.
Public interface | ISignatureItemCollection | Provides the base requirements for an object that represents a collection of ISignatureItem objects.


CodeSnippetKind Class

CodeSnippetKind Class
Indicates the kind of code snippet.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptCodeSnippetKind

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class CodeSnippetKind : Enum
Public NotInheritable Class CodeSnippetKind
    Inherits Enum

The CodeSnippetKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Any | The snippet can be inserted anywhere.
 | File | The snippet is a full code file.
 | MemberBody | The snippet is intended for usage within a member body.
 | MemberDeclaration | The snippet is a member declaration, and can ony be inserted inside a type.
 | TypeDeclaration | The snippet is a type declaration, and can only be inserted inside a type or namespace.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CodeSnippetKind Methods

CodeSnippetKind Methods

The CodeSnippetKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

CodeSnippetKind Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CodeSnippetKind Fields

CodeSnippetKind Fields

The CodeSnippetKind type exposes the following members.

Fields
 | Name | Description
 | Any | The snippet can be inserted anywhere.
 | File | The snippet is a full code file.
 | MemberBody | The snippet is intended for usage within a member body.
 | MemberDeclaration | The snippet is a member declaration, and can ony be inserted inside a type.
 | TypeDeclaration | The snippet is a type declaration, and can only be inserted inside a type or namespace.
Public field | value__ |
Top
See Also

Reference

CodeSnippetKind Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CodeSnippetKind.Any Field

CodeSnippetKindAny Field
The snippet can be inserted anywhere.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CodeSnippetKind Any = 0
Public Const Any As CodeSnippetKind = 0

Field Value

Type: CodeSnippetKind
See Also

Reference

CodeSnippetKind Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CodeSnippetKind.File Field

CodeSnippetKindFile Field
The snippet is a full code file.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CodeSnippetKind File = 1
Public Const File As CodeSnippetKind = 1

Field Value

Type: CodeSnippetKind
See Also

Reference

CodeSnippetKind Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CodeSnippetKind.MemberBody Field

CodeSnippetKindMemberBody Field
The snippet is intended for usage within a member body.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CodeSnippetKind MemberBody = 4
Public Const MemberBody As CodeSnippetKind = 4

Field Value

Type: CodeSnippetKind
See Also

Reference

CodeSnippetKind Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CodeSnippetKind.MemberDeclaration Field

CodeSnippetKindMemberDeclaration Field
The snippet is a member declaration, and can ony be inserted inside a type.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CodeSnippetKind MemberDeclaration = 3
Public Const MemberDeclaration As CodeSnippetKind = 3

Field Value

Type: CodeSnippetKind
See Also

Reference

CodeSnippetKind Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CodeSnippetKind.TypeDeclaration Field

CodeSnippetKindTypeDeclaration Field
The snippet is a type declaration, and can only be inserted inside a type or namespace.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CodeSnippetKind TypeDeclaration = 2
Public Const TypeDeclaration As CodeSnippetKind = 2

Field Value

Type: CodeSnippetKind
See Also

Reference

CodeSnippetKind Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CodeSnippetKind.value__ Field

CodeSnippetKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.CodeSnippetKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

CodeSnippetKind Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CodeSnippetTypes Class

CodeSnippetTypes Class
Indicates the types of actions that can be performed by a code snippet.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptCodeSnippetTypes

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class CodeSnippetTypes : Enum
<FlagsAttribute>
Public NotInheritable Class CodeSnippetTypes
    Inherits Enum

The CodeSnippetTypes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Expansion | Allows the code snippet to be inserted at the cursor.
 | None | No actions are defined.
 | Refactoring | Allows for code refactoring. This is currently unsupported by SyntaxEditor.
 | SurroundsWith | Allows the code snippet to be placed around a selected piece of code.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CodeSnippetTypes Methods

CodeSnippetTypes Methods

The CodeSnippetTypes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

CodeSnippetTypes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CodeSnippetTypes Fields

CodeSnippetTypes Fields

The CodeSnippetTypes type exposes the following members.

Fields
 | Name | Description
 | Expansion | Allows the code snippet to be inserted at the cursor.
 | None | No actions are defined.
 | Refactoring | Allows for code refactoring. This is currently unsupported by SyntaxEditor.
 | SurroundsWith | Allows the code snippet to be placed around a selected piece of code.
Public field | value__ |
Top
See Also

Reference

CodeSnippetTypes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CodeSnippetTypes.Expansion Field

CodeSnippetTypesExpansion Field
Allows the code snippet to be inserted at the cursor.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CodeSnippetTypes Expansion = 1
Public Const Expansion As CodeSnippetTypes = 1

Field Value

Type: CodeSnippetTypes
See Also

Reference

CodeSnippetTypes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CodeSnippetTypes.None Field

CodeSnippetTypesNone Field
No actions are defined.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CodeSnippetTypes None = 0
Public Const None As CodeSnippetTypes = 0

Field Value

Type: CodeSnippetTypes
See Also

Reference

CodeSnippetTypes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CodeSnippetTypes.Refactoring Field

CodeSnippetTypesRefactoring Field
Allows for code refactoring. This is currently unsupported by SyntaxEditor.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CodeSnippetTypes Refactoring = 4
Public Const Refactoring As CodeSnippetTypes = 4

Field Value

Type: CodeSnippetTypes
See Also

Reference

CodeSnippetTypes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CodeSnippetTypes.SurroundsWith Field

CodeSnippetTypesSurroundsWith Field
Allows the code snippet to be placed around a selected piece of code.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CodeSnippetTypes SurroundsWith = 2
Public Const SurroundsWith As CodeSnippetTypes = 2

Field Value

Type: CodeSnippetTypes
See Also

Reference

CodeSnippetTypes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CodeSnippetTypes.value__ Field

CodeSnippetTypesvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.CodeSnippetTypes.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

CodeSnippetTypes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionMatchOptions Class

CompletionMatchOptions Class
Specifies options for how an IntelliPrompt completion matches items.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptCompletionMatchOptions

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class CompletionMatchOptions : Enum
<FlagsAttribute>
Public NotInheritable Class CompletionMatchOptions
    Inherits Enum

The CompletionMatchOptions type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | IsCaseInsensitive | Matching will accept the first case insensitive match found instead of looking for a case sensitive match that may be lower in the list. Note that even if this option is not set, when no case sensitive match is found, the first case insensitive match is used anyhow.
 | None | The default options.
 | RequiresExact | A full match only occurs if the text being matched is the same as the matched item's text.
 | TargetsDisplayText | Matching should target the display text instead of the auto-complete pre-text.
 | UseAcronyms | Enable an additional acronym matching algorithm.
 | UseShorthand | Enable an additional shorthand matching algorithm.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionMatchOptions Methods

CompletionMatchOptions Methods

The CompletionMatchOptions type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

CompletionMatchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionMatchOptions Fields

CompletionMatchOptions Fields

The CompletionMatchOptions type exposes the following members.

Fields
 | Name | Description
 | IsCaseInsensitive | Matching will accept the first case insensitive match found instead of looking for a case sensitive match that may be lower in the list. Note that even if this option is not set, when no case sensitive match is found, the first case insensitive match is used anyhow.
 | None | The default options.
 | RequiresExact | A full match only occurs if the text being matched is the same as the matched item's text.
 | TargetsDisplayText | Matching should target the display text instead of the auto-complete pre-text.
 | UseAcronyms | Enable an additional acronym matching algorithm.
 | UseShorthand | Enable an additional shorthand matching algorithm.
Public field | value__ |
Top
See Also

Reference

CompletionMatchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionMatchOptions.IsCaseInsensitive Field

CompletionMatchOptionsIsCaseInsensitive Field
Matching will accept the first case insensitive match found instead of looking for a case sensitive match that may be lower in the list. Note that even if this option is not set, when no case sensitive match is found, the first case insensitive match is used anyhow.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CompletionMatchOptions IsCaseInsensitive = 1
Public Const IsCaseInsensitive As CompletionMatchOptions = 1

Field Value

Type: CompletionMatchOptions
See Also

Reference

CompletionMatchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionMatchOptions.None Field

CompletionMatchOptionsNone Field
The default options.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CompletionMatchOptions None = 0
Public Const None As CompletionMatchOptions = 0

Field Value

Type: CompletionMatchOptions
See Also

Reference

CompletionMatchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionMatchOptions.RequiresExact Field

CompletionMatchOptionsRequiresExact Field
A full match only occurs if the text being matched is the same as the matched item's text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CompletionMatchOptions RequiresExact = 16
Public Const RequiresExact As CompletionMatchOptions = 16

Field Value

Type: CompletionMatchOptions
See Also

Reference

CompletionMatchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionMatchOptions.TargetsDisplayText Field

CompletionMatchOptionsTargetsDisplayText Field
Matching should target the display text instead of the auto-complete pre-text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CompletionMatchOptions TargetsDisplayText = 2
Public Const TargetsDisplayText As CompletionMatchOptions = 2

Field Value

Type: CompletionMatchOptions
See Also

Reference

CompletionMatchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionMatchOptions.UseAcronyms Field

CompletionMatchOptionsUseAcronyms Field
Enable an additional acronym matching algorithm.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CompletionMatchOptions UseAcronyms = 4
Public Const UseAcronyms As CompletionMatchOptions = 4

Field Value

Type: CompletionMatchOptions
See Also

Reference

CompletionMatchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionMatchOptions.UseShorthand Field

CompletionMatchOptionsUseShorthand Field
Enable an additional shorthand matching algorithm.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CompletionMatchOptions UseShorthand = 8
Public Const UseShorthand As CompletionMatchOptions = 8

Field Value

Type: CompletionMatchOptions
See Also

Reference

CompletionMatchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionMatchOptions.value__ Field

CompletionMatchOptionsvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.CompletionMatchOptions.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

CompletionMatchOptions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionSelection Class

CompletionSelection Class
Represents the current selection within an ICompletionSession.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptCompletionSelection

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CompletionSelection
Public Class CompletionSelection

The CompletionSelection type exposes the following members.

Constructors
 | Name | Description
Public method | CompletionSelection | Initializes a new instance of the CompletionSelection class.
Top
Properties
 | Name | Description
Public property | Item | Gets the ICompletionItem that is selected.
Public property | State | Gets a CompletionSelectionState indicating the selection state of Item.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionSelection Constructor

CompletionSelection Constructor
Initializes a new instance of the CompletionSelection class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CompletionSelection(
    ICompletionItem item,
    CompletionSelectionState state
)
Public Sub New (
    item As ICompletionItem,
    state As CompletionSelectionState
)

Parameters

item
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptICompletionItem
The ICompletionItem that is selected.
state
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptCompletionSelectionState
A CompletionSelectionState indicating the selection state of Item.
See Also

Reference

CompletionSelection Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionSelection Properties

CompletionSelection Properties

The CompletionSelection type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the ICompletionItem that is selected.
Public property | State | Gets a CompletionSelectionState indicating the selection state of Item.
Top
See Also

Reference

CompletionSelection Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionSelection.Item Property

CompletionSelectionItem Property
Gets the ICompletionItem that is selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICompletionItem Item { get; }
Public ReadOnly Property Item As ICompletionItem
    Get

Property Value

Type: ICompletionItem
The ICompletionItem that is selected.
See Also

Reference

CompletionSelection Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionSelection.State Property

CompletionSelectionState Property
Gets a CompletionSelectionState indicating the selection state of Item.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CompletionSelectionState State { get; }
Public ReadOnly Property State As CompletionSelectionState
    Get

Property Value

Type: CompletionSelectionState
A CompletionSelectionState indicating the selection state of Item.
See Also

Reference

CompletionSelection Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionSelection Methods

CompletionSelection Methods

The CompletionSelection type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CompletionSelection Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionSelection.Equals Method

CompletionSelectionEquals Method
Indicates whether this instance and a specified object are equal.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
Another object to compare to.

Return Value

Type: Boolean
true if obj and this instance are the same type and represent the same value; otherwise, false.
See Also

Reference

CompletionSelection Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionSelection.GetHashCode Method

CompletionSelectionGetHashCode Method
Returns the hash code for this instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A 32-bit signed integer that is the hash code for this instance.
See Also

Reference

CompletionSelection Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionSelectionState Class

CompletionSelectionState Class
Specifies the selection state of an IntelliPrompt completion item.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptCompletionSelectionState

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class CompletionSelectionState : Enum
Public NotInheritable Class CompletionSelectionState
    Inherits Enum

The CompletionSelectionState type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Full | The item is fully-selected.
 | Partial | The item is partially-selected.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionSelectionState Methods

CompletionSelectionState Methods

The CompletionSelectionState type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

CompletionSelectionState Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionSelectionState Fields

CompletionSelectionState Fields

The CompletionSelectionState type exposes the following members.

Fields
 | Name | Description
 | Full | The item is fully-selected.
 | Partial | The item is partially-selected.
Public field | value__ |
Top
See Also

Reference

CompletionSelectionState Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionSelectionState.Full Field

CompletionSelectionStateFull Field
The item is fully-selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CompletionSelectionState Full = 1
Public Const Full As CompletionSelectionState = 1

Field Value

Type: CompletionSelectionState
See Also

Reference

CompletionSelectionState Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionSelectionState.Partial Field

CompletionSelectionStatePartial Field
The item is partially-selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CompletionSelectionState Partial = 0
Public Const Partial As CompletionSelectionState = 0

Field Value

Type: CompletionSelectionState
See Also

Reference

CompletionSelectionState Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


CompletionSelectionState.value__ Field

CompletionSelectionStatevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.CompletionSelectionState.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

CompletionSelectionState Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippet Interface

ICodeSnippet Interface
Provides the base requirements for a code snippet.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICodeSnippet : ICodeSnippetMetadata
Public Interface ICodeSnippet
    Inherits ICodeSnippetMetadata

The ICodeSnippet type exposes the following members.

Properties
 | Name | Description
Public property | Author | Gets the name of the code snippet author.
Public property | CodeDelimiter | Gets the character used to describe literals and objects in the code.
Public property | CodeKind | Gets a CodeSnippetKind indicating the kind of code contained by the snippet. (Inherited from ICodeSnippetMetadata.)
Public property | CodeLanguage | Gets the language in which the snippet's code is written. (Inherited from ICodeSnippetMetadata.)
Public property | CodeText | Gets the code that is inserted when the code snippet is activated.
Public property | Declarations | Gets the collection of declarations.
Public property | Description | Gets descriptive information about the code snippet contents. (Inherited from ICodeSnippetMetadata.)
Public property | HelpUrl | Gets a URL that provides more information about the code snippet.
Public property | ImportedNamespaces | Gets the collection of imported namespaces.
Public property | Keywords | Gets the collection of keywords that describe the code snippet.
Public property | References | Gets the collection of assembly references.
Public property | Shortcut | Gets the shortcut text used to insert the code snippet. (Inherited from ICodeSnippetMetadata.)
Public property | SnippetTypes | Gets the types of actions that can be performed by the code snippet. (Inherited from ICodeSnippetMetadata.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Title | Gets the code snippet title. (Inherited from ICodeSnippetMetadata.)
Top
Methods
 | Name | Description
Public method | GetCodeSnippet | Returns the full associated ICodeSnippet. (Inherited from ICodeSnippetMetadata.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippet Properties

ICodeSnippet Properties

The ICodeSnippet type exposes the following members.

Properties
 | Name | Description
Public property | Author | Gets the name of the code snippet author.
Public property | CodeDelimiter | Gets the character used to describe literals and objects in the code.
Public property | CodeKind | Gets a CodeSnippetKind indicating the kind of code contained by the snippet. (Inherited from ICodeSnippetMetadata.)
Public property | CodeLanguage | Gets the language in which the snippet's code is written. (Inherited from ICodeSnippetMetadata.)
Public property | CodeText | Gets the code that is inserted when the code snippet is activated.
Public property | Declarations | Gets the collection of declarations.
Public property | Description | Gets descriptive information about the code snippet contents. (Inherited from ICodeSnippetMetadata.)
Public property | HelpUrl | Gets a URL that provides more information about the code snippet.
Public property | ImportedNamespaces | Gets the collection of imported namespaces.
Public property | Keywords | Gets the collection of keywords that describe the code snippet.
Public property | References | Gets the collection of assembly references.
Public property | Shortcut | Gets the shortcut text used to insert the code snippet. (Inherited from ICodeSnippetMetadata.)
Public property | SnippetTypes | Gets the types of actions that can be performed by the code snippet. (Inherited from ICodeSnippetMetadata.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Title | Gets the code snippet title. (Inherited from ICodeSnippetMetadata.)
Top
See Also

Reference

ICodeSnippet Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippet.Author Property

ICodeSnippetAuthor Property
Gets the name of the code snippet author.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Author { get; }
ReadOnly Property Author As String
    Get

Property Value

Type: String
The name of the code snippet author.
See Also

Reference

ICodeSnippet Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippet.CodeDelimiter Property

ICodeSnippetCodeDelimiter Property
Gets the character used to describe literals and objects in the code.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string CodeDelimiter { get; }
ReadOnly Property CodeDelimiter As String
    Get

Property Value

Type: String
The character used to describe literals and objects in the code.
See Also

Reference

ICodeSnippet Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippet.CodeText Property

ICodeSnippetCodeText Property
Gets the code that is inserted when the code snippet is activated.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string CodeText { get; }
ReadOnly Property CodeText As String
    Get

Property Value

Type: String
The code that is inserted when the code snippet is activated.
See Also

Reference

ICodeSnippet Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippet.Declarations Property

ICodeSnippetDeclarations Property
Gets the collection of declarations.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<ICodeSnippetDeclaration> Declarations { get; }
ReadOnly Property Declarations As IList(Of ICodeSnippetDeclaration)
    Get

Property Value

Type: IList ICodeSnippetDeclaration
The collection of declarations.
See Also

Reference

ICodeSnippet Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippet.HelpUrl Property

ICodeSnippetHelpUrl Property
Gets a URL that provides more information about the code snippet.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string HelpUrl { get; }
ReadOnly Property HelpUrl As String
    Get

Property Value

Type: String
A URL that provides more information about the code snippet.
See Also

Reference

ICodeSnippet Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippet.ImportedNamespaces Property

ICodeSnippetImportedNamespaces Property
Gets the collection of imported namespaces.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<string> ImportedNamespaces { get; }
ReadOnly Property ImportedNamespaces As IList(Of String)
    Get

Property Value

Type: IList String
The collection of imported namespaces.
See Also

Reference

ICodeSnippet Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippet.Keywords Property

ICodeSnippetKeywords Property
Gets the collection of keywords that describe the code snippet.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<string> Keywords { get; }
ReadOnly Property Keywords As IList(Of String)
    Get

Property Value

Type: IList String
The collection of keywords that describe the code snippet.
See Also

Reference

ICodeSnippet Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippet.References Property

ICodeSnippetReferences Property
Gets the collection of assembly references.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<ICodeSnippetAssemblyReference> References { get; }
ReadOnly Property References As IList(Of ICodeSnippetAssemblyReference)
    Get

Property Value

Type: IList ICodeSnippetAssemblyReference
The collection of assembly references.
See Also

Reference

ICodeSnippet Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippet.Tag Property

ICodeSnippetTag Property
Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Tag { get; set; }
Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

ICodeSnippet Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippet Methods

ICodeSnippet Methods

The ICodeSnippet type exposes the following members.

Methods
 | Name | Description
Public method | GetCodeSnippet | Returns the full associated ICodeSnippet. (Inherited from ICodeSnippetMetadata.)
Top
See Also

Reference

ICodeSnippet Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetAssemblyReference Interface

ICodeSnippetAssemblyReference Interface
Provides the base requirements for an assembly reference within a code snippet.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICodeSnippetAssemblyReference
Public Interface ICodeSnippetAssemblyReference

The ICodeSnippetAssemblyReference type exposes the following members.

Properties
 | Name | Description
Public property | Assembly | Gets the name of the assembly to reference.
Public property | Url | Gets the URL that provides more information about the referenced assembly.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetAssemblyReference Properties

ICodeSnippetAssemblyReference Properties

The ICodeSnippetAssemblyReference type exposes the following members.

Properties
 | Name | Description
Public property | Assembly | Gets the name of the assembly to reference.
Public property | Url | Gets the URL that provides more information about the referenced assembly.
Top
See Also

Reference

ICodeSnippetAssemblyReference Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetAssemblyReference.Assembly Property

ICodeSnippetAssemblyReferenceAssembly Property
Gets the name of the assembly to reference.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Assembly { get; }
ReadOnly Property Assembly As String
    Get

Property Value

Type: String
The name of the assembly to reference.
See Also

Reference

ICodeSnippetAssemblyReference Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetAssemblyReference.Url Property

ICodeSnippetAssemblyReferenceUrl Property
Gets the URL that provides more information about the referenced assembly.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Url { get; }
ReadOnly Property Url As String
    Get

Property Value

Type: String
The URL that provides more information about the referenced assembly.
See Also

Reference

ICodeSnippetAssemblyReference Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetDeclaration Interface

ICodeSnippetDeclaration Interface
Provides the base requirements for a code snippet declaration.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICodeSnippetDeclaration
Public Interface ICodeSnippetDeclaration

The ICodeSnippetDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | DefaultText | Gets the default text value of the declaration, when the code snippet has been inserted.
Public property | FunctionInvocation | Gets a function to execute when the declaration receives focus.
Public property | Id | Gets a unique identifier for the declaration.
Public property | IsEditable | Gets whether the declaration is editable by the end-user once the code snippet has been inserted.
Public property | ToolTip | Gets a description of the expected value and usage of the declaration, that can be used in a tooltip.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetDeclaration Properties

ICodeSnippetDeclaration Properties

The ICodeSnippetDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | DefaultText | Gets the default text value of the declaration, when the code snippet has been inserted.
Public property | FunctionInvocation | Gets a function to execute when the declaration receives focus.
Public property | Id | Gets a unique identifier for the declaration.
Public property | IsEditable | Gets whether the declaration is editable by the end-user once the code snippet has been inserted.
Public property | ToolTip | Gets a description of the expected value and usage of the declaration, that can be used in a tooltip.
Top
See Also

Reference

ICodeSnippetDeclaration Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetDeclaration.DefaultText Property

ICodeSnippetDeclarationDefaultText Property
Gets the default text value of the declaration, when the code snippet has been inserted.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string DefaultText { get; }
ReadOnly Property DefaultText As String
    Get

Property Value

Type: String
The default text value of the declaration, when the code snippet has been inserted.
See Also

Reference

ICodeSnippetDeclaration Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetDeclaration.FunctionInvocation Property

ICodeSnippetDeclarationFunctionInvocation Property
Gets a function to execute when the declaration receives focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string FunctionInvocation { get; }
ReadOnly Property FunctionInvocation As String
    Get

Property Value

Type: String
A function to execute when the declaration receives focus.
See Also

Reference

ICodeSnippetDeclaration Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetDeclaration.Id Property

ICodeSnippetDeclarationId Property
Gets a unique identifier for the declaration.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Id { get; }
ReadOnly Property Id As String
    Get

Property Value

Type: String
A unique identifier for the declaration.
See Also

Reference

ICodeSnippetDeclaration Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetDeclaration.IsEditable Property

ICodeSnippetDeclarationIsEditable Property
Gets whether the declaration is editable by the end-user once the code snippet has been inserted.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsEditable { get; }
ReadOnly Property IsEditable As Boolean
    Get

Property Value

Type: Boolean
true if the declaration is editable by the end-user once the code snippet has been inserted; otherwise, false.
See Also

Reference

ICodeSnippetDeclaration Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetDeclaration.ToolTip Property

ICodeSnippetDeclarationToolTip Property
Gets a description of the expected value and usage of the declaration, that can be used in a tooltip.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string ToolTip { get; }
ReadOnly Property ToolTip As String
    Get

Property Value

Type: String
A description of the expected value and usage of the declaration.
See Also

Reference

ICodeSnippetDeclaration Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetFolder Interface

ICodeSnippetFolder Interface
Provides the base requirements for a folder that can contain ICodeSnippetProvider objects and other child folders.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICodeSnippetFolder
Public Interface ICodeSnippetFolder

The ICodeSnippetFolder type exposes the following members.

Properties
 | Name | Description
Public property | Folders | Gets the collection of child folders.
Public property | Items | Gets the collection of code snippet metadata items in the folder.
Public property | Name | Gets the name of the folder.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
Methods
 | Name | Description
Public method | FindItemByShortcut | Recursively searches for an item with the specified shortcut.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetFolder Properties

ICodeSnippetFolder Properties

The ICodeSnippetFolder type exposes the following members.

Properties
 | Name | Description
Public property | Folders | Gets the collection of child folders.
Public property | Items | Gets the collection of code snippet metadata items in the folder.
Public property | Name | Gets the name of the folder.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
See Also

Reference

ICodeSnippetFolder Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetFolder.Folders Property

ICodeSnippetFolderFolders Property
Gets the collection of child folders.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<ICodeSnippetFolder> Folders { get; }
ReadOnly Property Folders As IList(Of ICodeSnippetFolder)
    Get

Property Value

Type: IList ICodeSnippetFolder
The collection of child folders.
See Also

Reference

ICodeSnippetFolder Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetFolder.Items Property

ICodeSnippetFolderItems Property
Gets the collection of code snippet metadata items in the folder.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<ICodeSnippetMetadata> Items { get; }
ReadOnly Property Items As IList(Of ICodeSnippetMetadata)
    Get

Property Value

Type: IList ICodeSnippetMetadata
The collection of code snippet metadata items in the folder.
See Also

Reference

ICodeSnippetFolder Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetFolder.Name Property

ICodeSnippetFolderName Property
Gets the name of the folder.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
The name of the folder.
See Also

Reference

ICodeSnippetFolder Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetFolder.Tag Property

ICodeSnippetFolderTag Property
Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Tag { get; set; }
Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

ICodeSnippetFolder Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetFolder Methods

ICodeSnippetFolder Methods

The ICodeSnippetFolder type exposes the following members.

Methods
 | Name | Description
Public method | FindItemByShortcut | Recursively searches for an item with the specified shortcut.
Top
See Also

Reference

ICodeSnippetFolder Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetFolder.FindItemByShortcut Method

ICodeSnippetFolderFindItemByShortcut Method
Recursively searches for an item with the specified shortcut.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ICodeSnippetMetadata FindItemByShortcut(
    string shortcut,
    bool isCaseSensitive
)
Function FindItemByShortcut (
    shortcut As String,
    isCaseSensitive As Boolean
) As ICodeSnippetMetadata

Parameters

shortcut
Type: SystemString
The shortcut text.
isCaseSensitive
Type: SystemBoolean
Whether the comparison should be case-sensitive.

Return Value

Type: ICodeSnippetMetadata
The ICodeSnippetMetadata that was found, if any.
See Also

Reference

ICodeSnippetFolder Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetLiteralDeclaration Interface

ICodeSnippetLiteralDeclaration Interface
Provides the base requirements for a code snippet literal declaration.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICodeSnippetLiteralDeclaration : ICodeSnippetDeclaration
Public Interface ICodeSnippetLiteralDeclaration
    Inherits ICodeSnippetDeclaration

The ICodeSnippetLiteralDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | DefaultText | Gets the default text value of the declaration, when the code snippet has been inserted. (Inherited from ICodeSnippetDeclaration.)
Public property | FunctionInvocation | Gets a function to execute when the declaration receives focus. (Inherited from ICodeSnippetDeclaration.)
Public property | Id | Gets a unique identifier for the declaration. (Inherited from ICodeSnippetDeclaration.)
Public property | IsEditable | Gets whether the declaration is editable by the end-user once the code snippet has been inserted. (Inherited from ICodeSnippetDeclaration.)
Public property | ToolTip | Gets a description of the expected value and usage of the declaration, that can be used in a tooltip. (Inherited from ICodeSnippetDeclaration.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetLiteralDeclaration Properties

ICodeSnippetLiteralDeclaration Properties

The ICodeSnippetLiteralDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | DefaultText | Gets the default text value of the declaration, when the code snippet has been inserted. (Inherited from ICodeSnippetDeclaration.)
Public property | FunctionInvocation | Gets a function to execute when the declaration receives focus. (Inherited from ICodeSnippetDeclaration.)
Public property | Id | Gets a unique identifier for the declaration. (Inherited from ICodeSnippetDeclaration.)
Public property | IsEditable | Gets whether the declaration is editable by the end-user once the code snippet has been inserted. (Inherited from ICodeSnippetDeclaration.)
Public property | ToolTip | Gets a description of the expected value and usage of the declaration, that can be used in a tooltip. (Inherited from ICodeSnippetDeclaration.)
Top
See Also

Reference

ICodeSnippetLiteralDeclaration Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetMetadata Interface

ICodeSnippetMetadata Interface
Provides the base requirements for an object that contains metadata information about an ICodeSnippet and can provide the full snippet on demand.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICodeSnippetMetadata
Public Interface ICodeSnippetMetadata

The ICodeSnippetMetadata type exposes the following members.

Properties
 | Name | Description
Public property | CodeKind | Gets a CodeSnippetKind indicating the kind of code contained by the snippet.
Public property | CodeLanguage | Gets the language in which the snippet's code is written.
Public property | Description | Gets descriptive information about the code snippet contents.
Public property | Shortcut | Gets the shortcut text used to insert the code snippet.
Public property | SnippetTypes | Gets the types of actions that can be performed by the code snippet.
Public property | Title | Gets the code snippet title.
Top
Methods
 | Name | Description
Public method | GetCodeSnippet | Returns the full associated ICodeSnippet.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetMetadata Properties

ICodeSnippetMetadata Properties

The ICodeSnippetMetadata type exposes the following members.

Properties
 | Name | Description
Public property | CodeKind | Gets a CodeSnippetKind indicating the kind of code contained by the snippet.
Public property | CodeLanguage | Gets the language in which the snippet's code is written.
Public property | Description | Gets descriptive information about the code snippet contents.
Public property | Shortcut | Gets the shortcut text used to insert the code snippet.
Public property | SnippetTypes | Gets the types of actions that can be performed by the code snippet.
Public property | Title | Gets the code snippet title.
Top
See Also

Reference

ICodeSnippetMetadata Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetMetadata.CodeKind Property

ICodeSnippetMetadataCodeKind Property
Gets a CodeSnippetKind indicating the kind of code contained by the snippet.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
CodeSnippetKind CodeKind { get; }
ReadOnly Property CodeKind As CodeSnippetKind
    Get

Property Value

Type: CodeSnippetKind
A CodeSnippetKind indicating the kind of code contained by the snippet.
See Also

Reference

ICodeSnippetMetadata Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetMetadata.CodeLanguage Property

ICodeSnippetMetadataCodeLanguage Property
Gets the language in which the snippet's code is written.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string CodeLanguage { get; }
ReadOnly Property CodeLanguage As String
    Get

Property Value

Type: String
The language in which the snippet's code is written.
See Also

Reference

ICodeSnippetMetadata Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetMetadata.Description Property

ICodeSnippetMetadataDescription Property
Gets descriptive information about the code snippet contents.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String
Descriptive information about the code snippet contents.
See Also

Reference

ICodeSnippetMetadata Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetMetadata.Shortcut Property

ICodeSnippetMetadataShortcut Property
Gets the shortcut text used to insert the code snippet.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Shortcut { get; }
ReadOnly Property Shortcut As String
    Get

Property Value

Type: String
The shortcut text used to insert the code snippet.
See Also

Reference

ICodeSnippetMetadata Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetMetadata.SnippetTypes Property

ICodeSnippetMetadataSnippetTypes Property
Gets the types of actions that can be performed by the code snippet.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
CodeSnippetTypes SnippetTypes { get; }
ReadOnly Property SnippetTypes As CodeSnippetTypes
    Get

Property Value

Type: CodeSnippetTypes
A CodeSnippetTypes that specifies the types of actions that can be performed by the code snippet.
See Also

Reference

ICodeSnippetMetadata Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetMetadata.Title Property

ICodeSnippetMetadataTitle Property
Gets the code snippet title.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Title { get; }
ReadOnly Property Title As String
    Get

Property Value

Type: String
The code snippet title.
See Also

Reference

ICodeSnippetMetadata Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetMetadata Methods

ICodeSnippetMetadata Methods

The ICodeSnippetMetadata type exposes the following members.

Methods
 | Name | Description
Public method | GetCodeSnippet | Returns the full associated ICodeSnippet.
Top
See Also

Reference

ICodeSnippetMetadata Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetMetadata.GetCodeSnippet Method

ICodeSnippetMetadataGetCodeSnippet Method
Returns the full associated ICodeSnippet.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ICodeSnippet GetCodeSnippet()
Function GetCodeSnippet As ICodeSnippet

Return Value

Type: ICodeSnippet
The full associated ICodeSnippet.
See Also

Reference

ICodeSnippetMetadata Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetObjectDeclaration Interface

ICodeSnippetObjectDeclaration Interface
Provides the base requirements for a code snippet object declaration.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICodeSnippetObjectDeclaration : ICodeSnippetDeclaration
Public Interface ICodeSnippetObjectDeclaration
    Inherits ICodeSnippetDeclaration

The ICodeSnippetObjectDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | DefaultText | Gets the default text value of the declaration, when the code snippet has been inserted. (Inherited from ICodeSnippetDeclaration.)
Public property | FunctionInvocation | Gets a function to execute when the declaration receives focus. (Inherited from ICodeSnippetDeclaration.)
Public property | Id | Gets a unique identifier for the declaration. (Inherited from ICodeSnippetDeclaration.)
Public property | IsEditable | Gets whether the declaration is editable by the end-user once the code snippet has been inserted. (Inherited from ICodeSnippetDeclaration.)
Public property | ToolTip | Gets a description of the expected value and usage of the declaration, that can be used in a tooltip. (Inherited from ICodeSnippetDeclaration.)
Public property | Type | Gets the type of the declaration.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetObjectDeclaration Properties

ICodeSnippetObjectDeclaration Properties

The ICodeSnippetObjectDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | DefaultText | Gets the default text value of the declaration, when the code snippet has been inserted. (Inherited from ICodeSnippetDeclaration.)
Public property | FunctionInvocation | Gets a function to execute when the declaration receives focus. (Inherited from ICodeSnippetDeclaration.)
Public property | Id | Gets a unique identifier for the declaration. (Inherited from ICodeSnippetDeclaration.)
Public property | IsEditable | Gets whether the declaration is editable by the end-user once the code snippet has been inserted. (Inherited from ICodeSnippetDeclaration.)
Public property | ToolTip | Gets a description of the expected value and usage of the declaration, that can be used in a tooltip. (Inherited from ICodeSnippetDeclaration.)
Public property | Type | Gets the type of the declaration.
Top
See Also

Reference

ICodeSnippetObjectDeclaration Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetObjectDeclaration.Type Property

ICodeSnippetObjectDeclarationType Property
Gets the type of the declaration.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Type { get; }
ReadOnly Property Type As String
    Get

Property Value

Type: String
The type of the declaration.
See Also

Reference

ICodeSnippetObjectDeclaration Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetProvider Interface

ICodeSnippetProvider Interface
Provides the base requirements for an object that can manage the available code snippets and handle requests for display of IntelliPrompt code snippet sessions.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICodeSnippetProvider : IOrderable,
    IKeyedObject
Public Interface ICodeSnippetProvider
    Inherits IOrderable, IKeyedObject

The ICodeSnippetProvider type exposes the following members.

Properties
 | Name | Description
Public property | IsCaseSensitive | Gets whether code snippet shortcut matching requires a case-sensitive match.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from IOrderable.)
Public property | RootFolder | Gets the root ICodeSnippetFolder containing code snippets that are accessible by this provider.
Top
Methods
 | Name | Description
Public method | RequestSelectionSession | Requests that an ICodeSnippetSelectionSession be opened for the specified IEditorView.
Public method | RequestTemplateSession | Requests that an ICodeSnippetTemplateSession be opened for the specified IEditorView.
Top
Remarks
Objects implementing this provider interface can be registered as a service with an ISyntaxLanguage using the RegisterService(Object, Object) method. Any object implementing this interface will be called as needed by the language in priority order (based on IOrderable settings).
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetProvider Properties

ICodeSnippetProvider Properties

The ICodeSnippetProvider type exposes the following members.

Properties
 | Name | Description
Public property | IsCaseSensitive | Gets whether code snippet shortcut matching requires a case-sensitive match.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from IOrderable.)
Public property | RootFolder | Gets the root ICodeSnippetFolder containing code snippets that are accessible by this provider.
Top
See Also

Reference

ICodeSnippetProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetProvider.IsCaseSensitive Property

ICodeSnippetProviderIsCaseSensitive Property
Gets whether code snippet shortcut matching requires a case-sensitive match.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsCaseSensitive { get; }
ReadOnly Property IsCaseSensitive As Boolean
    Get

Property Value

Type: Boolean
true if code snippet shortcut matching requires a case-sensitive match; otherwise, false. The default value is true.
See Also

Reference

ICodeSnippetProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetProvider.RootFolder Property

ICodeSnippetProviderRootFolder Property
Gets the root ICodeSnippetFolder containing code snippets that are accessible by this provider.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ICodeSnippetFolder RootFolder { get; }
ReadOnly Property RootFolder As ICodeSnippetFolder
    Get

Property Value

Type: ICodeSnippetFolder
The root ICodeSnippetFolder containing code snippets that are accessible by this provider.
See Also

Reference

ICodeSnippetProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetProvider Methods

ICodeSnippetProvider Methods

The ICodeSnippetProvider type exposes the following members.

Methods
 | Name | Description
Public method | RequestSelectionSession | Requests that an ICodeSnippetSelectionSession be opened for the specified IEditorView.
Public method | RequestTemplateSession | Requests that an ICodeSnippetTemplateSession be opened for the specified IEditorView.
Top
See Also

Reference

ICodeSnippetProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetProvider.RequestSelectionSession Method

ICodeSnippetProviderRequestSelectionSession Method
Requests that an ICodeSnippetSelectionSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool RequestSelectionSession(
    IEditorView view,
    CodeSnippetTypes snippetType
)
Function RequestSelectionSession (
    view As IEditorView,
    snippetType As CodeSnippetTypes
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.
snippetType
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptCodeSnippetTypes
A CodeSnippetTypes indicating the type of code snippets to include.

Return Value

Type: Boolean
true if a session was opened; otherwise, false.
See Also

Reference

ICodeSnippetProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetProvider.RequestTemplateSession Method

ICodeSnippetProviderRequestTemplateSession Method
Requests that an ICodeSnippetTemplateSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool RequestTemplateSession(
    IEditorView view,
    ICodeSnippet codeSnippet
)
Function RequestTemplateSession (
    view As IEditorView,
    codeSnippet As ICodeSnippet
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.
codeSnippet
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptICodeSnippet
The ICodeSnippet template to use.

Return Value

Type: Boolean
true if a session was opened; otherwise, false.
See Also

Reference

ICodeSnippetProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetSelectionSession Interface

ICodeSnippetSelectionSession Interface
Provides the base requirements for an object that represents an IntelliPrompt code snippet selection session.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICodeSnippetSelectionSession : IIntelliPromptSession,
    IServiceLocator
Public Interface ICodeSnippetSelectionSession
    Inherits IIntelliPromptSession, IServiceLocator

The ICodeSnippetSelectionSession type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the view-relative bounds of the session's open popup, if available. (Inherited from IIntelliPromptSession.)
Public property | ClosesOnLostFocus | Returns whether this session auto-closes when the editor or any IntelliPrompt popups lose focus. (Inherited from IIntelliPromptSession.)
Public property | IsOpen | Gets whether the session is currently open. (Inherited from IIntelliPromptSession.)
Public property | Label | Gets the label text to display on the popup.
Public property | RootFolder | Gets the root ICodeSnippetFolder containing the code snippets to display.
Public property | SessionType | Gets the IIntelliPromptSessionType that identifies the type of session. (Inherited from IIntelliPromptSession.)
Public property | SnapshotRange | Gets the TextSnapshotRange containing the original TextRange in the ITextSnapshot that triggered the session. (Inherited from IIntelliPromptSession.)
Public property | View | Gets the IEditorView in which the session is opened. (Inherited from IIntelliPromptSession.)
Top
Methods
 | Name | Description
Public method | Close | Closes the session. (Inherited from IIntelliPromptSession.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from IServiceLocator.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | Open(IEditorView) | Opens the session, attaching to the specified IEditorView.
Public method | Open(IEditorView, TextRange) | Opens the session, attaching to the specified IEditorView. (Inherited from IIntelliPromptSession.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | Reposition | Notifies the session that it should reposition its user interface. (Inherited from IIntelliPromptSession.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the session is closed, with the Cancel flag on the event arguments indicating whether the close was due to a cancellation. (Inherited from IIntelliPromptSession.)
Public event | Opened | Occurs when the session is opened. (Inherited from IIntelliPromptSession.)
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from IServiceLocator.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from IServiceLocator.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetSelectionSession Properties

ICodeSnippetSelectionSession Properties

The ICodeSnippetSelectionSession type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the view-relative bounds of the session's open popup, if available. (Inherited from IIntelliPromptSession.)
Public property | ClosesOnLostFocus | Returns whether this session auto-closes when the editor or any IntelliPrompt popups lose focus. (Inherited from IIntelliPromptSession.)
Public property | IsOpen | Gets whether the session is currently open. (Inherited from IIntelliPromptSession.)
Public property | Label | Gets the label text to display on the popup.
Public property | RootFolder | Gets the root ICodeSnippetFolder containing the code snippets to display.
Public property | SessionType | Gets the IIntelliPromptSessionType that identifies the type of session. (Inherited from IIntelliPromptSession.)
Public property | SnapshotRange | Gets the TextSnapshotRange containing the original TextRange in the ITextSnapshot that triggered the session. (Inherited from IIntelliPromptSession.)
Public property | View | Gets the IEditorView in which the session is opened. (Inherited from IIntelliPromptSession.)
Top
See Also

Reference

ICodeSnippetSelectionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetSelectionSession.Label Property

ICodeSnippetSelectionSessionLabel Property
Gets the label text to display on the popup.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Label { get; }
ReadOnly Property Label As String
    Get

Property Value

Type: String
The label text to display on the popup.
See Also

Reference

ICodeSnippetSelectionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetSelectionSession.RootFolder Property

ICodeSnippetSelectionSessionRootFolder Property
Gets the root ICodeSnippetFolder containing the code snippets to display.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ICodeSnippetFolder RootFolder { get; }
ReadOnly Property RootFolder As ICodeSnippetFolder
    Get

Property Value

Type: ICodeSnippetFolder
The root ICodeSnippetFolder containing the code snippets to display.
See Also

Reference

ICodeSnippetSelectionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetSelectionSession Methods

ICodeSnippetSelectionSession Methods

The ICodeSnippetSelectionSession type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the session. (Inherited from IIntelliPromptSession.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from IServiceLocator.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | Open(IEditorView) | Opens the session, attaching to the specified IEditorView.
Public method | Open(IEditorView, TextRange) | Opens the session, attaching to the specified IEditorView. (Inherited from IIntelliPromptSession.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | Reposition | Notifies the session that it should reposition its user interface. (Inherited from IIntelliPromptSession.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Top
See Also

Reference

ICodeSnippetSelectionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetSelectionSession.Open Method

ICodeSnippetSelectionSessionOpen Method
Overload List
 | Name | Description
Public method | Open(IEditorView) | Opens the session, attaching to the specified IEditorView.
Public method | Open(IEditorView, TextRange) | Opens the session, attaching to the specified IEditorView. (Inherited from IIntelliPromptSession.)
Top
See Also

Reference

ICodeSnippetSelectionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetSelectionSession.Open Method (IEditorView)

ICodeSnippetSelectionSessionOpen Method (IEditorView)
Opens the session, attaching to the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Open(
    IEditorView view
)
Sub Open (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which the session is opened.
See Also

Reference

ICodeSnippetSelectionSession Interface
Open Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetSelectionSession Events

ICodeSnippetSelectionSession Events

The ICodeSnippetSelectionSession type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the session is closed, with the Cancel flag on the event arguments indicating whether the close was due to a cancellation. (Inherited from IIntelliPromptSession.)
Public event | Opened | Occurs when the session is opened. (Inherited from IIntelliPromptSession.)
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from IServiceLocator.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from IServiceLocator.)
Top
See Also

Reference

ICodeSnippetSelectionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetTemplateSession Interface

ICodeSnippetTemplateSession Interface
Provides the base requirements for an object that represents an IntelliPrompt code snippet template session.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICodeSnippetTemplateSession : IIntelliPromptSession,
    IServiceLocator
Public Interface ICodeSnippetTemplateSession
    Inherits IIntelliPromptSession, IServiceLocator

The ICodeSnippetTemplateSession type exposes the following members.

Properties
 | Name | Description
Public property | ActiveDeclaration | Gets the ICodeSnippetDeclaration that is currently active, if any.
Public property | Bounds | Gets the view-relative bounds of the session's open popup, if available. (Inherited from IIntelliPromptSession.)
Public property | ClosesOnLostFocus | Returns whether this session auto-closes when the editor or any IntelliPrompt popups lose focus. (Inherited from IIntelliPromptSession.)
Public property | CodeSnippet | Gets the code snippet to activate.
Public property | IsAutoIndentEnabled | Gets whether to auto-indent code snippet code based on the tabstop level of the current line.
Public property | IsOpen | Gets whether the session is currently open. (Inherited from IIntelliPromptSession.)
Public property | SessionType | Gets the IIntelliPromptSessionType that identifies the type of session. (Inherited from IIntelliPromptSession.)
Public property | SnapshotRange | Gets the TextSnapshotRange containing the original TextRange in the ITextSnapshot that triggered the session. (Inherited from IIntelliPromptSession.)
Public property | View | Gets the IEditorView in which the session is opened. (Inherited from IIntelliPromptSession.)
Top
Methods
 | Name | Description
Public method | Close | Closes the session. (Inherited from IIntelliPromptSession.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from IServiceLocator.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | Open(IEditorView) | Opens the session, attaching to the specified IEditorView, and uses the current selection as the target snapshot range.
Public method | Open(IEditorView, TextRange) | Opens the session, attaching to the specified IEditorView. (Inherited from IIntelliPromptSession.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | Reposition | Notifies the session that it should reposition its user interface. (Inherited from IIntelliPromptSession.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the session is closed, with the Cancel flag on the event arguments indicating whether the close was due to a cancellation. (Inherited from IIntelliPromptSession.)
Public event | Opened | Occurs when the session is opened. (Inherited from IIntelliPromptSession.)
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from IServiceLocator.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from IServiceLocator.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetTemplateSession Properties

ICodeSnippetTemplateSession Properties

The ICodeSnippetTemplateSession type exposes the following members.

Properties
 | Name | Description
Public property | ActiveDeclaration | Gets the ICodeSnippetDeclaration that is currently active, if any.
Public property | Bounds | Gets the view-relative bounds of the session's open popup, if available. (Inherited from IIntelliPromptSession.)
Public property | ClosesOnLostFocus | Returns whether this session auto-closes when the editor or any IntelliPrompt popups lose focus. (Inherited from IIntelliPromptSession.)
Public property | CodeSnippet | Gets the code snippet to activate.
Public property | IsAutoIndentEnabled | Gets whether to auto-indent code snippet code based on the tabstop level of the current line.
Public property | IsOpen | Gets whether the session is currently open. (Inherited from IIntelliPromptSession.)
Public property | SessionType | Gets the IIntelliPromptSessionType that identifies the type of session. (Inherited from IIntelliPromptSession.)
Public property | SnapshotRange | Gets the TextSnapshotRange containing the original TextRange in the ITextSnapshot that triggered the session. (Inherited from IIntelliPromptSession.)
Public property | View | Gets the IEditorView in which the session is opened. (Inherited from IIntelliPromptSession.)
Top
See Also

Reference

ICodeSnippetTemplateSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetTemplateSession.ActiveDeclaration Property

ICodeSnippetTemplateSessionActiveDeclaration Property
Gets the ICodeSnippetDeclaration that is currently active, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ICodeSnippetDeclaration ActiveDeclaration { get; }
ReadOnly Property ActiveDeclaration As ICodeSnippetDeclaration
    Get

Property Value

Type: ICodeSnippetDeclaration
The ICodeSnippetDeclaration that is currently active, if any.
See Also

Reference

ICodeSnippetTemplateSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetTemplateSession.CodeSnippet Property

ICodeSnippetTemplateSessionCodeSnippet Property
Gets the code snippet to activate.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ICodeSnippet CodeSnippet { get; }
ReadOnly Property CodeSnippet As ICodeSnippet
    Get

Property Value

Type: ICodeSnippet
The code snippet to activate.
See Also

Reference

ICodeSnippetTemplateSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetTemplateSession.IsAutoIndentEnabled Property

ICodeSnippetTemplateSessionIsAutoIndentEnabled Property
Gets whether to auto-indent code snippet code based on the tabstop level of the current line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsAutoIndentEnabled { get; }
ReadOnly Property IsAutoIndentEnabled As Boolean
    Get

Property Value

Type: Boolean
true if the code snippet code should be auto-indented; otherwise, false.
See Also

Reference

ICodeSnippetTemplateSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetTemplateSession Methods

ICodeSnippetTemplateSession Methods

The ICodeSnippetTemplateSession type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the session. (Inherited from IIntelliPromptSession.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from IServiceLocator.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | Open(IEditorView) | Opens the session, attaching to the specified IEditorView, and uses the current selection as the target snapshot range.
Public method | Open(IEditorView, TextRange) | Opens the session, attaching to the specified IEditorView. (Inherited from IIntelliPromptSession.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | Reposition | Notifies the session that it should reposition its user interface. (Inherited from IIntelliPromptSession.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Top
See Also

Reference

ICodeSnippetTemplateSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetTemplateSession.Open Method

ICodeSnippetTemplateSessionOpen Method
Overload List
 | Name | Description
Public method | Open(IEditorView) | Opens the session, attaching to the specified IEditorView, and uses the current selection as the target snapshot range.
Public method | Open(IEditorView, TextRange) | Opens the session, attaching to the specified IEditorView. (Inherited from IIntelliPromptSession.)
Top
See Also

Reference

ICodeSnippetTemplateSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetTemplateSession.Open Method (IEditorView)

ICodeSnippetTemplateSessionOpen Method (IEditorView)
Opens the session, attaching to the specified IEditorView, and uses the current selection as the target snapshot range.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Open(
    IEditorView view
)
Sub Open (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which the session is opened.
See Also

Reference

ICodeSnippetTemplateSession Interface
Open Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetTemplateSession Events

ICodeSnippetTemplateSession Events

The ICodeSnippetTemplateSession type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the session is closed, with the Cancel flag on the event arguments indicating whether the close was due to a cancellation. (Inherited from IIntelliPromptSession.)
Public event | Opened | Occurs when the session is opened. (Inherited from IIntelliPromptSession.)
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from IServiceLocator.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from IServiceLocator.)
Top
See Also

Reference

ICodeSnippetTemplateSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetTemplateSessionEventSink Interface

ICodeSnippetTemplateSessionEventSink Interface
Provides the base requirements for an object that can be notified of events that occur within an open ICodeSnippetTemplateSession.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICodeSnippetTemplateSessionEventSink
Public Interface ICodeSnippetTemplateSessionEventSink

The ICodeSnippetTemplateSessionEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifyDeclarationActivated | Notifies when a new declaration in the session's code snippet is activated.
Public method | NotifyDeclarationDeactivated | Notifies when a declaration in the session's code snippet is deactivated.
Public method | NotifyDeclarationTextChanged | Notifies when the text value of the active declaration in the session's code snippet is changed.
Public method | NotifySessionClosed | Notifies when a session is closed.
Public method | NotifySessionOpened | Notifies when a session is opened.
Top
Remarks
Objects implementing this event sink interface can be registered as a service with an ISyntaxLanguage using the RegisterService(Object, Object) method. Any object implementing this interface will be notified automatically when related events occur.
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetTemplateSessionEventSink Methods

ICodeSnippetTemplateSessionEventSink Methods

The ICodeSnippetTemplateSessionEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifyDeclarationActivated | Notifies when a new declaration in the session's code snippet is activated.
Public method | NotifyDeclarationDeactivated | Notifies when a declaration in the session's code snippet is deactivated.
Public method | NotifyDeclarationTextChanged | Notifies when the text value of the active declaration in the session's code snippet is changed.
Public method | NotifySessionClosed | Notifies when a session is closed.
Public method | NotifySessionOpened | Notifies when a session is opened.
Top
See Also

Reference

ICodeSnippetTemplateSessionEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetTemplateSessionEventSink.NotifyDeclarationActivated Method

ICodeSnippetTemplateSessionEventSinkNotifyDeclarationActivated Method
Notifies when a new declaration in the session's code snippet is activated.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyDeclarationActivated(
    ICodeSnippetTemplateSession session
)
Sub NotifyDeclarationActivated (
    session As ICodeSnippetTemplateSession
)

Parameters

session
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptICodeSnippetTemplateSession
The ICodeSnippetTemplateSession related to this event.
Remarks
The ActiveDeclaration property indicates the related declaration.
See Also

Reference

ICodeSnippetTemplateSessionEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetTemplateSessionEventSink.NotifyDeclarationDeactivated Method

ICodeSnippetTemplateSessionEventSinkNotifyDeclarationDeactivated Method
Notifies when a declaration in the session's code snippet is deactivated.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyDeclarationDeactivated(
    ICodeSnippetTemplateSession session
)
Sub NotifyDeclarationDeactivated (
    session As ICodeSnippetTemplateSession
)

Parameters

session
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptICodeSnippetTemplateSession
The ICodeSnippetTemplateSession related to this event.
Remarks
The ActiveDeclaration property indicates the related declaration.
See Also

Reference

ICodeSnippetTemplateSessionEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetTemplateSessionEventSink.NotifyDeclarationTextChanged Method

ICodeSnippetTemplateSessionEventSinkNotifyDeclarationTextChanged Method
Notifies when the text value of the active declaration in the session's code snippet is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyDeclarationTextChanged(
    ICodeSnippetTemplateSession session
)
Sub NotifyDeclarationTextChanged (
    session As ICodeSnippetTemplateSession
)

Parameters

session
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptICodeSnippetTemplateSession
The ICodeSnippetTemplateSession related to this event.
Remarks
The ActiveDeclaration property indicates the related declaration.
See Also

Reference

ICodeSnippetTemplateSessionEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetTemplateSessionEventSink.NotifySessionClosed Method

ICodeSnippetTemplateSessionEventSinkNotifySessionClosed Method
Notifies when a session is closed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifySessionClosed(
    ICodeSnippetTemplateSession session
)
Sub NotifySessionClosed (
    session As ICodeSnippetTemplateSession
)

Parameters

session
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptICodeSnippetTemplateSession
The ICodeSnippetTemplateSession related to this event.
See Also

Reference

ICodeSnippetTemplateSessionEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICodeSnippetTemplateSessionEventSink.NotifySessionOpened Method

ICodeSnippetTemplateSessionEventSinkNotifySessionOpened Method
Notifies when a session is opened.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifySessionOpened(
    ICodeSnippetTemplateSession session
)
Sub NotifySessionOpened (
    session As ICodeSnippetTemplateSession
)

Parameters

session
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptICodeSnippetTemplateSession
The ICodeSnippetTemplateSession related to this event.
See Also

Reference

ICodeSnippetTemplateSessionEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionFilter Interface

ICompletionFilter Interface
Provides the base requirements for an object that can filter out items from an IntelliPrompt completion list.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICompletionFilter : IKeyedObject
Public Interface ICompletionFilter
    Inherits IKeyedObject

The ICompletionFilter type exposes the following members.

Properties
 | Name | Description
Public property | IsActive | Gets or sets whether the filter is currently active.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
Methods
 | Name | Description
Public method | Filter | Returns whether the specified item should be excluded from the available completion items.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationCompletionFilter


ICompletionFilter Properties

ICompletionFilter Properties

The ICompletionFilter type exposes the following members.

Properties
 | Name | Description
Public property | IsActive | Gets or sets whether the filter is currently active.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
See Also

Reference

ICompletionFilter Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionFilter.IsActive Property

ICompletionFilterIsActive Property
Gets or sets whether the filter is currently active.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsActive { get; set; }
Property IsActive As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the filter is currently active; otherwise, false.
Remarks
When the filter is not active, it will not have its Filter(ICompletionSession, ICompletionItem) method to examine items.
See Also

Reference

ICompletionFilter Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionFilter Methods

ICompletionFilter Methods

The ICompletionFilter type exposes the following members.

Methods
 | Name | Description
Public method | Filter | Returns whether the specified item should be excluded from the available completion items.
Top
See Also

Reference

ICompletionFilter Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionFilter.Filter Method

ICompletionFilterFilter Method
Returns whether the specified item should be excluded from the available completion items.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Filter(
    ICompletionSession session,
    ICompletionItem item
)
Function Filter (
    session As ICompletionSession,
    item As ICompletionItem
) As Boolean

Parameters

session
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptICompletionSession
The ICompletionSession in which this filter is active.
item
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptICompletionItem
The ICompletionItem to examine.

Return Value

Type: Boolean
true if the item should be excluded from the available completion items; otherwise, false.
See Also

Reference

ICompletionFilter Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionFilterCollection Interface

ICompletionFilterCollection Interface
Provides the base requirements for an object that represents a collection of ICompletionFilter objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICompletionFilterCollection : IKeyedObservableCollection<ICompletionFilter>,
    IObservableCollection<ICompletionFilter>, IList<ICompletionFilter>, ICollection<ICompletionFilter>,
    IEnumerable<ICompletionFilter>, IEnumerable
Public Interface ICompletionFilterCollection
    Inherits IKeyedObservableCollection(Of ICompletionFilter), IObservableCollection(Of ICompletionFilter),
    IList(Of ICompletionFilter), ICollection(Of ICompletionFilter), IEnumerable(Of ICompletionFilter),
    IEnumerable

The ICompletionFilterCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ICompletionFilter .)
Public property | IsReadOnly | (Inherited from ICollection ICompletionFilter .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Public property | ItemInt32 | (Inherited from IList ICompletionFilter .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ICompletionFilter .)
Public method | Clear | (Inherited from ICollection ICompletionFilter .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | (Inherited from ICollection ICompletionFilter .)
Public method | CopyTo | (Inherited from ICollection ICompletionFilter .)
Public method | GetEnumerator | (Inherited from IEnumerable ICompletionFilter .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | (Inherited from IList ICompletionFilter .)
Public method | Insert | (Inherited from IList ICompletionFilter .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | (Inherited from ICollection ICompletionFilter .)
Public method | RemoveAt | (Inherited from IList ICompletionFilter .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionFilterCollection Properties

ICompletionFilterCollection Properties

The ICompletionFilterCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ICompletionFilter .)
Public property | IsReadOnly | (Inherited from ICollection ICompletionFilter .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Public property | ItemInt32 | (Inherited from IList ICompletionFilter .)
Top
See Also

Reference

ICompletionFilterCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionFilterCollection Methods

ICompletionFilterCollection Methods

The ICompletionFilterCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ICompletionFilter .)
Public method | Clear | (Inherited from ICollection ICompletionFilter .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | (Inherited from ICollection ICompletionFilter .)
Public method | CopyTo | (Inherited from ICollection ICompletionFilter .)
Public method | GetEnumerator | (Inherited from IEnumerable ICompletionFilter .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | (Inherited from IList ICompletionFilter .)
Public method | Insert | (Inherited from IList ICompletionFilter .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | (Inherited from ICollection ICompletionFilter .)
Public method | RemoveAt | (Inherited from IList ICompletionFilter .)
Top
See Also

Reference

ICompletionFilterCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionFilterCollection Events

ICompletionFilterCollection Events

The ICompletionFilterCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ICompletionFilterCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionItem Interface

ICompletionItem Interface
Provides the base requirements for an IntelliPrompt completion item.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICompletionItem
Public Interface ICompletionItem

The ICompletionItem type exposes the following members.

Properties
 | Name | Description
Public property | AutoCompletePostText | Gets the text that is inserted into the document after the caret when auto-complete is executed.
Public property | AutoCompletePreText | Gets the text that is inserted into the document before the caret when auto-complete is executed.
Public property | DescriptionProvider | Gets an IContentProvider that can provide content for a popup displaying a verbose description of the item.
Public property | ImageSourceProvider | Gets an IImageSourceProvider that can provide an ImageSource for display within a list.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Text | Gets the text for the item that is displayed within a list.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationCompletionItem


ICompletionItem Properties

ICompletionItem Properties

The ICompletionItem type exposes the following members.

Properties
 | Name | Description
Public property | AutoCompletePostText | Gets the text that is inserted into the document after the caret when auto-complete is executed.
Public property | AutoCompletePreText | Gets the text that is inserted into the document before the caret when auto-complete is executed.
Public property | DescriptionProvider | Gets an IContentProvider that can provide content for a popup displaying a verbose description of the item.
Public property | ImageSourceProvider | Gets an IImageSourceProvider that can provide an ImageSource for display within a list.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Text | Gets the text for the item that is displayed within a list.
Top
See Also

Reference

ICompletionItem Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionItem.AutoCompletePostText Property

ICompletionItemAutoCompletePostText Property
Gets the text that is inserted into the document after the caret when auto-complete is executed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string AutoCompletePostText { get; }
ReadOnly Property AutoCompletePostText As String
    Get

Property Value

Type: String
The text that is inserted into the document after the caret when auto-complete is executed.
See Also

Reference

ICompletionItem Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionItem.AutoCompletePreText Property

ICompletionItemAutoCompletePreText Property
Gets the text that is inserted into the document before the caret when auto-complete is executed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string AutoCompletePreText { get; }
ReadOnly Property AutoCompletePreText As String
    Get

Property Value

Type: String
The text that is inserted into the document before the caret when auto-complete is executed.
See Also

Reference

ICompletionItem Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionItem.DescriptionProvider Property

ICompletionItemDescriptionProvider Property
Gets an IContentProvider that can provide content for a popup displaying a verbose description of the item.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IContentProvider DescriptionProvider { get; }
ReadOnly Property DescriptionProvider As IContentProvider
    Get

Property Value

Type: IContentProvider
An IContentProvider that can provide content for a popup displaying a verbose description of the item.
See Also

Reference

ICompletionItem Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionItem.ImageSourceProvider Property

ICompletionItemImageSourceProvider Property
Gets an IImageSourceProvider that can provide an ImageSource for display within a list.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IImageSourceProvider ImageSourceProvider { get; }
ReadOnly Property ImageSourceProvider As IImageSourceProvider
    Get

Property Value

Type: IImageSourceProvider
An IImageSourceProvider that can provide an ImageSource for display within a list.
See Also

Reference

ICompletionItem Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionItem.Tag Property

ICompletionItemTag Property
Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Tag { get; set; }
Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

ICompletionItem Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionItem.Text Property

ICompletionItemText Property
Gets the text for the item that is displayed within a list.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Text { get; }
ReadOnly Property Text As String
    Get

Property Value

Type: String
The text for the item that is displayed within a list.
See Also

Reference

ICompletionItem Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionItemCollection Interface

ICompletionItemCollection Interface
Provides the base requirements for an object that represents a collection of ICompletionItem objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICompletionItemCollection : IObservableCollection<ICompletionItem>,
    IList<ICompletionItem>, ICollection<ICompletionItem>, IEnumerable<ICompletionItem>,
    IEnumerable
Public Interface ICompletionItemCollection
    Inherits IObservableCollection(Of ICompletionItem), IList(Of ICompletionItem),
    ICollection(Of ICompletionItem), IEnumerable(Of ICompletionItem), IEnumerable

The ICompletionItemCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ICompletionItem .)
Public property | IsReadOnly | (Inherited from ICollection ICompletionItem .)
Public property | Item | (Inherited from IList ICompletionItem .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ICompletionItem .)
Public method | Clear | (Inherited from ICollection ICompletionItem .)
Public method | Contains | (Inherited from ICollection ICompletionItem .)
Public method | CopyTo | (Inherited from ICollection ICompletionItem .)
Public method | GetEnumerator | (Inherited from IEnumerable ICompletionItem .)
Public method | IndexOf | (Inherited from IList ICompletionItem .)
Public method | Insert | (Inherited from IList ICompletionItem .)
Public method | Remove | (Inherited from ICollection ICompletionItem .)
Public method | RemoveAt | (Inherited from IList ICompletionItem .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionItemCollection Properties

ICompletionItemCollection Properties

The ICompletionItemCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ICompletionItem .)
Public property | IsReadOnly | (Inherited from ICollection ICompletionItem .)
Public property | Item | (Inherited from IList ICompletionItem .)
Top
See Also

Reference

ICompletionItemCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionItemCollection Methods

ICompletionItemCollection Methods

The ICompletionItemCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ICompletionItem .)
Public method | Clear | (Inherited from ICollection ICompletionItem .)
Public method | Contains | (Inherited from ICollection ICompletionItem .)
Public method | CopyTo | (Inherited from ICollection ICompletionItem .)
Public method | GetEnumerator | (Inherited from IEnumerable ICompletionItem .)
Public method | IndexOf | (Inherited from IList ICompletionItem .)
Public method | Insert | (Inherited from IList ICompletionItem .)
Public method | Remove | (Inherited from ICollection ICompletionItem .)
Public method | RemoveAt | (Inherited from IList ICompletionItem .)
Top
See Also

Reference

ICompletionItemCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionItemCollection Events

ICompletionItemCollection Events

The ICompletionItemCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ICompletionItemCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionItemMatcher Interface

ICompletionItemMatcher Interface
Provides the base requirements for an object that can match completion items based on supplied text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICompletionItemMatcher : IKeyedObject
Public Interface ICompletionItemMatcher
    Inherits IKeyedObject

The ICompletionItemMatcher type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
Methods
 | Name | Description
Public method | GetHighlightedTextRanges | Returns a collection of TextRange objects that specify the ranges of matched characters within an ICompletionItem's Text.
Public method | Match | Attempts to locate an ICompletionItem match based on specified text.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionItemMatcher Properties

ICompletionItemMatcher Properties

The ICompletionItemMatcher type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
See Also

Reference

ICompletionItemMatcher Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionItemMatcher Methods

ICompletionItemMatcher Methods

The ICompletionItemMatcher type exposes the following members.

Methods
 | Name | Description
Public method | GetHighlightedTextRanges | Returns a collection of TextRange objects that specify the ranges of matched characters within an ICompletionItem's Text.
Public method | Match | Attempts to locate an ICompletionItem match based on specified text.
Top
See Also

Reference

ICompletionItemMatcher Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionItemMatcher.GetHighlightedTextRanges Method

ICompletionItemMatcherGetHighlightedTextRanges Method
Returns a collection of TextRange objects that specify the ranges of matched characters within an ICompletionItem's Text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<TextRange> GetHighlightedTextRanges(
    ICompletionSession session,
    ICompletionItem item,
    string text
)
Function GetHighlightedTextRanges (
    session As ICompletionSession,
    item As ICompletionItem,
    text As String
) As IEnumerable(Of TextRange)

Parameters

session
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptICompletionSession
The ICompletionSession in which the match is to be made.
item
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptICompletionItem
The ICompletionItem against which to match.
text
Type: SystemString
The text to use for matching.

Return Value

Type: IEnumerable TextRange
A collection of TextRange objects that specify the ranges of matched characters within an ICompletionItem's Text.
See Also

Reference

ICompletionItemMatcher Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionItemMatcher.Match Method

ICompletionItemMatcherMatch Method
Attempts to locate an ICompletionItem match based on specified text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
CompletionSelection Match(
    ICompletionSession session,
    IEnumerable items,
    string text,
    bool uniqueFullMatchOnly
)
Function Match (
    session As ICompletionSession,
    items As IEnumerable,
    text As String,
    uniqueFullMatchOnly As Boolean
) As CompletionSelection

Parameters

session
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptICompletionSession
The ICompletionSession in which the match is to be made.
items
Type: System.CollectionsIEnumerable
The collection of items against which to match.
text
Type: SystemString
The text to use for matching.
uniqueFullMatchOnly
Type: SystemBoolean
Whether to only return a match if it is a full and unique match.

Return Value

Type: CompletionSelection
A CompletionSelection instance, if a match was made.
See Also

Reference

ICompletionItemMatcher Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionItemMatcherCollection Interface

ICompletionItemMatcherCollection Interface
Provides the base requirements for an object that represents a collection of ICompletionItemMatcher objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICompletionItemMatcherCollection : IKeyedObservableCollection<ICompletionItemMatcher>,
    IObservableCollection<ICompletionItemMatcher>, IList<ICompletionItemMatcher>, ICollection<ICompletionItemMatcher>,
    IEnumerable<ICompletionItemMatcher>, IEnumerable
Public Interface ICompletionItemMatcherCollection
    Inherits IKeyedObservableCollection(Of ICompletionItemMatcher), IObservableCollection(Of ICompletionItemMatcher),
    IList(Of ICompletionItemMatcher), ICollection(Of ICompletionItemMatcher), IEnumerable(Of ICompletionItemMatcher),
    IEnumerable

The ICompletionItemMatcherCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ICompletionItemMatcher .)
Public property | IsReadOnly | (Inherited from ICollection ICompletionItemMatcher .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Public property | ItemInt32 | (Inherited from IList ICompletionItemMatcher .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ICompletionItemMatcher .)
Public method | Clear | (Inherited from ICollection ICompletionItemMatcher .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | (Inherited from ICollection ICompletionItemMatcher .)
Public method | CopyTo | (Inherited from ICollection ICompletionItemMatcher .)
Public method | GetEnumerator | (Inherited from IEnumerable ICompletionItemMatcher .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | (Inherited from IList ICompletionItemMatcher .)
Public method | Insert | (Inherited from IList ICompletionItemMatcher .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | (Inherited from ICollection ICompletionItemMatcher .)
Public method | RemoveAt | (Inherited from IList ICompletionItemMatcher .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionItemMatcherCollection Properties

ICompletionItemMatcherCollection Properties

The ICompletionItemMatcherCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ICompletionItemMatcher .)
Public property | IsReadOnly | (Inherited from ICollection ICompletionItemMatcher .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Public property | ItemInt32 | (Inherited from IList ICompletionItemMatcher .)
Top
See Also

Reference

ICompletionItemMatcherCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionItemMatcherCollection Methods

ICompletionItemMatcherCollection Methods

The ICompletionItemMatcherCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ICompletionItemMatcher .)
Public method | Clear | (Inherited from ICollection ICompletionItemMatcher .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | (Inherited from ICollection ICompletionItemMatcher .)
Public method | CopyTo | (Inherited from ICollection ICompletionItemMatcher .)
Public method | GetEnumerator | (Inherited from IEnumerable ICompletionItemMatcher .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | (Inherited from IList ICompletionItemMatcher .)
Public method | Insert | (Inherited from IList ICompletionItemMatcher .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | (Inherited from ICollection ICompletionItemMatcher .)
Public method | RemoveAt | (Inherited from IList ICompletionItemMatcher .)
Top
See Also

Reference

ICompletionItemMatcherCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionItemMatcherCollection Events

ICompletionItemMatcherCollection Events

The ICompletionItemMatcherCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ICompletionItemMatcherCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionProvider Interface

ICompletionProvider Interface
Provides the base requirements for an object that can handle requests for display of an IntelliPrompt completion list.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICompletionProvider : IOrderable,
    IKeyedObject
Public Interface ICompletionProvider
    Inherits IOrderable, IKeyedObject

The ICompletionProvider type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from IOrderable.)
Top
Methods
 | Name | Description
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView.
Top
Remarks
Objects implementing this provider interface can be registered as a service with an ISyntaxLanguage using the RegisterService(Object, Object) method. Any object implementing this interface will be called as needed by the language in priority order (based on IOrderable settings).
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionProvider Properties

ICompletionProvider Properties

The ICompletionProvider type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from IOrderable.)
Top
See Also

Reference

ICompletionProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionProvider Methods

ICompletionProvider Methods

The ICompletionProvider type exposes the following members.

Methods
 | Name | Description
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView.
Top
See Also

Reference

ICompletionProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionProvider.RequestSession Method

ICompletionProviderRequestSession Method
Requests that an ICompletionSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool RequestSession(
    IEditorView view,
    bool canCommitWithoutPopup
)
Function RequestSession (
    view As IEditorView,
    canCommitWithoutPopup As Boolean
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.
canCommitWithoutPopup
Type: SystemBoolean
Whether the session can immediately commit if a single match is made when the session is opened, commonly known as "complete word" functionality.

Return Value

Type: Boolean
true if a session was opened; otherwise, false.
See Also

Reference

ICompletionProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession Interface

ICompletionSession Interface
Provides the base requirements for an object that represents an IntelliPrompt completion session.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICompletionSession : IIntelliPromptSession,
    IServiceLocator
Public Interface ICompletionSession
    Inherits IIntelliPromptSession, IServiceLocator

The ICompletionSession type exposes the following members.

Properties
 | Name | Description
Public property | AllowedCharacters | Gets the CharClass containing the non-letter/digit characters allowed to be typed while the completion popup is displayed.
Public property | Bounds | Gets the view-relative bounds of the session's open popup, if available. (Inherited from IIntelliPromptSession.)
Public property | CanCommitWithoutPopup | Gets whether the session can immediately commit if a single match is made when the session is opened, commonly known as "complete word" functionality.
Public property | CanFilterUnmatchedItems | Gets or sets whether to filter out items that don't match the typed text, thereby shrinking the list of visible items.
Public property | ClosesOnLostFocus | Returns whether this session auto-closes when the editor or any IntelliPrompt popups lose focus. (Inherited from IIntelliPromptSession.)
Public property | CommitCharacters | Gets or sets the CharClass containing the characters that can be typed when there is a full selection to trigger a Commit.
Public property | Context | Gets an object that describes the context in which the completion session is opened.
Public property | ControlKeyDownOpacity | Gets the opacity of the popup while the control key is pressed.
Public property | DescriptionTipMaxWidth | Gets the description tip popup's maximum width.
Public property | DescriptionTipShowDelay | Gets or sets the TimeSpan to wait after the selection is updated before showing the description tip.
Public property | Filters | Gets the collection of ICompletionFilter objects that can be applied to the session.
Public property | IsEnterKeyHandledOnCommit | Gets whether the Enter key is handled (not allowed to insert a line feed) when it commits the session.
Public property | IsOpen | Gets whether the session is currently open. (Inherited from IIntelliPromptSession.)
Public property | ItemMatchers | Gets the collection of ICompletionItemMatcher objects to use when matching items.
Public property | Items | Gets the collection of ICompletionItem objects within the completion.
Public property | MatchOptions | Gets the CompletionMatchOptions indicating the options to use when matching items.
Public property | RequiresFilterOnTextChange | Gets or sets whether to apply filters when a text change occurs.
Public property | Selection | Gets or sets a CompletionSelection indicating the current selection within the completion.
Public property | SessionType | Gets the IIntelliPromptSessionType that identifies the type of session. (Inherited from IIntelliPromptSession.)
Public property | SnapshotRange | Gets the TextSnapshotRange containing the original TextRange in the ITextSnapshot that triggered the session. (Inherited from IIntelliPromptSession.)
Public property | TypedText | Gets the text that has been used to initialize the session and/or been entered by the end user since the session opened.
Public property | View | Gets the IEditorView in which the session is opened. (Inherited from IIntelliPromptSession.)
Top
Methods
 | Name | Description
Public method | Cancel | Cancels the completion session.
Public method | Close | Closes the session. (Inherited from IIntelliPromptSession.)
Public method | CloseDescriptionTip | Closes the description tip if it is open.
Public method | Commit | Commits the completion session and performs an auto-complete if there is a Selection available.
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from IServiceLocator.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | Open(IEditorView) | Opens the session, attaching to the specified IEditorView.
Public method | Open(IEditorView, TextRange) | Opens the session, attaching to the specified IEditorView. (Inherited from IIntelliPromptSession.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | Reposition | Notifies the session that it should reposition its user interface. (Inherited from IIntelliPromptSession.)
Public method | RestartDescriptionTipTimer | Restarts the description tip display timer.
Public method | SortItems | Sorts the items in the session using the default sort comparer.
Public method | SortItems(IComparerICompletionItem) | Sorts the items in the session using a custom comparer.
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the session is closed, with the Cancel flag on the event arguments indicating whether the close was due to a cancellation. (Inherited from IIntelliPromptSession.)
Public event | Committed | Occurs after the session is committed.
Public event | Committing | Occurs before the session is committed, allowing it to be cancelled.
Public event | Opened | Occurs when the session is opened. (Inherited from IIntelliPromptSession.)
Public event | SelectionChanged | Occurs after the Selection has changed.
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from IServiceLocator.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from IServiceLocator.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationCompletionSession


ICompletionSession Properties

ICompletionSession Properties

The ICompletionSession type exposes the following members.

Properties
 | Name | Description
Public property | AllowedCharacters | Gets the CharClass containing the non-letter/digit characters allowed to be typed while the completion popup is displayed.
Public property | Bounds | Gets the view-relative bounds of the session's open popup, if available. (Inherited from IIntelliPromptSession.)
Public property | CanCommitWithoutPopup | Gets whether the session can immediately commit if a single match is made when the session is opened, commonly known as "complete word" functionality.
Public property | CanFilterUnmatchedItems | Gets or sets whether to filter out items that don't match the typed text, thereby shrinking the list of visible items.
Public property | ClosesOnLostFocus | Returns whether this session auto-closes when the editor or any IntelliPrompt popups lose focus. (Inherited from IIntelliPromptSession.)
Public property | CommitCharacters | Gets or sets the CharClass containing the characters that can be typed when there is a full selection to trigger a Commit.
Public property | Context | Gets an object that describes the context in which the completion session is opened.
Public property | ControlKeyDownOpacity | Gets the opacity of the popup while the control key is pressed.
Public property | DescriptionTipMaxWidth | Gets the description tip popup's maximum width.
Public property | DescriptionTipShowDelay | Gets or sets the TimeSpan to wait after the selection is updated before showing the description tip.
Public property | Filters | Gets the collection of ICompletionFilter objects that can be applied to the session.
Public property | IsEnterKeyHandledOnCommit | Gets whether the Enter key is handled (not allowed to insert a line feed) when it commits the session.
Public property | IsOpen | Gets whether the session is currently open. (Inherited from IIntelliPromptSession.)
Public property | ItemMatchers | Gets the collection of ICompletionItemMatcher objects to use when matching items.
Public property | Items | Gets the collection of ICompletionItem objects within the completion.
Public property | MatchOptions | Gets the CompletionMatchOptions indicating the options to use when matching items.
Public property | RequiresFilterOnTextChange | Gets or sets whether to apply filters when a text change occurs.
Public property | Selection | Gets or sets a CompletionSelection indicating the current selection within the completion.
Public property | SessionType | Gets the IIntelliPromptSessionType that identifies the type of session. (Inherited from IIntelliPromptSession.)
Public property | SnapshotRange | Gets the TextSnapshotRange containing the original TextRange in the ITextSnapshot that triggered the session. (Inherited from IIntelliPromptSession.)
Public property | TypedText | Gets the text that has been used to initialize the session and/or been entered by the end user since the session opened.
Public property | View | Gets the IEditorView in which the session is opened. (Inherited from IIntelliPromptSession.)
Top
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.AllowedCharacters Property

ICompletionSessionAllowedCharacters Property
Gets the CharClass containing the non-letter/digit characters allowed to be typed while the completion popup is displayed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
CharClass AllowedCharacters { get; }
ReadOnly Property AllowedCharacters As CharClass
    Get

Property Value

Type: CharClass
The CharClass containing the non-letter/digit characters allowed to be typed while the completion popup is displayed.
Remarks
All letter and digit characters are automatically allowed by the completion popup and therefore do not need to added to this property. This property should only contain additional non-letter/digit characters that need to be allowed.

When a character is typed, it's first checked to see if it's a letter, number, or is in the AllowedCharacters collection. If any of those cases is true, the character is entered into the editor and the session remains open. If instead the character is in the CommitCharacters collection and there is a full selection in the completion list, a Commit occurs. Otherwise, the session is cancelled.

See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.CanCommitWithoutPopup Property

ICompletionSessionCanCommitWithoutPopup Property
Gets whether the session can immediately commit if a single match is made when the session is opened, commonly known as "complete word" functionality.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanCommitWithoutPopup { get; }
ReadOnly Property CanCommitWithoutPopup As Boolean
    Get

Property Value

Type: Boolean
true if the session can immediately commit if a single match is made when the session is opened; otherwise, false.
Remarks
A value of false will force the popup list to always display, even if a single match is made upon open.
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.CanFilterUnmatchedItems Property

ICompletionSessionCanFilterUnmatchedItems Property
Gets or sets whether to filter out items that don't match the typed text, thereby shrinking the list of visible items.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanFilterUnmatchedItems { get; }
ReadOnly Property CanFilterUnmatchedItems As Boolean
    Get

Property Value

Type: Boolean
true if items that don't match the typed text should be filtered out, thereby shrinking the list of visible items; otherwise, false.
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.CommitCharacters Property

ICompletionSessionCommitCharacters Property
Gets or sets the CharClass containing the characters that can be typed when there is a full selection to trigger a Commit.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
CharClass CommitCharacters { get; }
ReadOnly Property CommitCharacters As CharClass
    Get

Property Value

Type: CharClass
The CharClass containing the characters that can be typed when there is a full selection to trigger a Commit.
Remarks
The default value of this property is a CharClass that contains all characters.

When a character is typed, it's first checked to see if it's a letter, number, or is in the AllowedCharacters collection. If any of those cases is true, the character is entered into the editor and the session remains open. If instead the character is in the CommitCharacters collection and there is a full selection in the completion list, a Commit occurs. Otherwise, the session is cancelled.

See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.Context Property

ICompletionSessionContext Property
Gets an object that describes the context in which the completion session is opened.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Context { get; }
ReadOnly Property Context As Object
    Get

Property Value

Type: Object
An object that describes the context in which the completion session is opened.
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.ControlKeyDownOpacity Property

ICompletionSessionControlKeyDownOpacity Property
Gets the opacity of the popup while the control key is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
double ControlKeyDownOpacity { get; }
ReadOnly Property ControlKeyDownOpacity As Double
    Get

Property Value

Type: Double
The opacity of the popup while the control key is pressed.
Remarks
Set the value to 1.0 to prevent opacity changes when the control key is pressed.
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.DescriptionTipMaxWidth Property

ICompletionSessionDescriptionTipMaxWidth Property
Gets the description tip popup's maximum width.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
double DescriptionTipMaxWidth { get; }
ReadOnly Property DescriptionTipMaxWidth As Double
    Get

Property Value

Type: Double
The description tip popup's maximum width, or NaN to indicate no constraint.
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.DescriptionTipShowDelay Property

ICompletionSessionDescriptionTipShowDelay Property
Gets or sets the TimeSpan to wait after the selection is updated before showing the description tip.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TimeSpan DescriptionTipShowDelay { get; }
ReadOnly Property DescriptionTipShowDelay As TimeSpan
    Get

Property Value

Type: TimeSpan
The TimeSpan to wait after the selection is updated before showing the description tip. The default value is 400ms.
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.Filters Property

ICompletionSessionFilters Property
Gets the collection of ICompletionFilter objects that can be applied to the session.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ICompletionFilterCollection Filters { get; }
ReadOnly Property Filters As ICompletionFilterCollection
    Get

Property Value

Type: ICompletionFilterCollection
The collection of ICompletionFilter objects that can be applied to the session.
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.IsEnterKeyHandledOnCommit Property

ICompletionSessionIsEnterKeyHandledOnCommit Property
Gets whether the Enter key is handled (not allowed to insert a line feed) when it commits the session.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsEnterKeyHandledOnCommit { get; }
ReadOnly Property IsEnterKeyHandledOnCommit As Boolean
    Get

Property Value

Type: Boolean
true if the Enter key is handled (not allowed to insert a line feed) when it commits the session; otherwise, false.
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.ItemMatchers Property

ICompletionSessionItemMatchers Property
Gets the collection of ICompletionItemMatcher objects to use when matching items.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ICompletionItemMatcherCollection ItemMatchers { get; }
ReadOnly Property ItemMatchers As ICompletionItemMatcherCollection
    Get

Property Value

Type: ICompletionItemMatcherCollection
The collection of ICompletionItemMatcher objects to use when matching items.
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.Items Property

ICompletionSessionItems Property
Gets the collection of ICompletionItem objects within the completion.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ICompletionItemCollection Items { get; }
ReadOnly Property Items As ICompletionItemCollection
    Get

Property Value

Type: ICompletionItemCollection
The collection of ICompletionItem objects within the completion.
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.MatchOptions Property

ICompletionSessionMatchOptions Property
Gets the CompletionMatchOptions indicating the options to use when matching items.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
CompletionMatchOptions MatchOptions { get; }
ReadOnly Property MatchOptions As CompletionMatchOptions
    Get

Property Value

Type: CompletionMatchOptions
The CompletionMatchOptions indicating the options to use when matching items.
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.RequiresFilterOnTextChange Property

ICompletionSessionRequiresFilterOnTextChange Property
Gets or sets whether to apply filters when a text change occurs.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool RequiresFilterOnTextChange { get; set; }
Property RequiresFilterOnTextChange As Boolean
    Get
    Set

Property Value

Type: Boolean
true if filters should be applied when a text change occurs; otherwise, false.
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.Selection Property

ICompletionSessionSelection Property
Gets or sets a CompletionSelection indicating the current selection within the completion.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
CompletionSelection Selection { get; set; }
Property Selection As CompletionSelection
    Get
    Set

Property Value

Type: CompletionSelection
A CompletionSelection indicating the current selection within the completion.
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.TypedText Property

ICompletionSessionTypedText Property
Gets the text that has been used to initialize the session and/or been entered by the end user since the session opened.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string TypedText { get; }
ReadOnly Property TypedText As String
    Get

Property Value

Type: String
The text that has been used to initialize the session and/or been entered by the end user since the session opened.
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession Methods

ICompletionSession Methods

The ICompletionSession type exposes the following members.

Methods
 | Name | Description
Public method | Cancel | Cancels the completion session.
Public method | Close | Closes the session. (Inherited from IIntelliPromptSession.)
Public method | CloseDescriptionTip | Closes the description tip if it is open.
Public method | Commit | Commits the completion session and performs an auto-complete if there is a Selection available.
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from IServiceLocator.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | Open(IEditorView) | Opens the session, attaching to the specified IEditorView.
Public method | Open(IEditorView, TextRange) | Opens the session, attaching to the specified IEditorView. (Inherited from IIntelliPromptSession.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | Reposition | Notifies the session that it should reposition its user interface. (Inherited from IIntelliPromptSession.)
Public method | RestartDescriptionTipTimer | Restarts the description tip display timer.
Public method | SortItems | Sorts the items in the session using the default sort comparer.
Public method | SortItems(IComparerICompletionItem) | Sorts the items in the session using a custom comparer.
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Top
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.Cancel Method

ICompletionSessionCancel Method
Cancels the completion session.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Cancel()
Sub Cancel
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.CloseDescriptionTip Method

ICompletionSessionCloseDescriptionTip Method
Closes the description tip if it is open.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void CloseDescriptionTip()
Sub CloseDescriptionTip
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.Commit Method

ICompletionSessionCommit Method
Commits the completion session and performs an auto-complete if there is a Selection available.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Commit()
Sub Commit
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.Open Method

ICompletionSessionOpen Method
Overload List
 | Name | Description
Public method | Open(IEditorView) | Opens the session, attaching to the specified IEditorView.
Public method | Open(IEditorView, TextRange) | Opens the session, attaching to the specified IEditorView. (Inherited from IIntelliPromptSession.)
Top
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.Open Method (IEditorView)

ICompletionSessionOpen Method (IEditorView)
Opens the session, attaching to the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Open(
    IEditorView view
)
Sub Open (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which the session is opened.
See Also

Reference

ICompletionSession Interface
Open Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.RestartDescriptionTipTimer Method

ICompletionSessionRestartDescriptionTipTimer Method
Restarts the description tip display timer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void RestartDescriptionTipTimer()
Sub RestartDescriptionTipTimer
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.SortItems Method

ICompletionSessionSortItems Method
Overload List
 | Name | Description
Public method | SortItems | Sorts the items in the session using the default sort comparer.
Public method | SortItems(IComparerICompletionItem) | Sorts the items in the session using a custom comparer.
Top
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.SortItems Method

ICompletionSessionSortItems Method
Sorts the items in the session using the default sort comparer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SortItems()
Sub SortItems
Remarks
Items should always be sorted before the session is opened for an optimal user experience. This method should be called to sort the items right before the session is opened if the items were not pre-sorted.
See Also

Reference

ICompletionSession Interface
SortItems Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.SortItems Method (IComparer(ICompletionItem))

ICompletionSessionSortItems Method (IComparerICompletionItem)
Sorts the items in the session using a custom comparer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SortItems(
    IComparer<ICompletionItem> comparer
)
Sub SortItems (
    comparer As IComparer(Of ICompletionItem)
)

Parameters

comparer
Type: System.Collections.GenericIComparer ICompletionItem
The IComparerT to use.
Remarks
Items should always be sorted before the session is opened for an optimal user experience. This method should be called to sort the items right before the session is opened if the items were not pre-sorted.
See Also

Reference

ICompletionSession Interface
SortItems Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession Events

ICompletionSession Events

The ICompletionSession type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the session is closed, with the Cancel flag on the event arguments indicating whether the close was due to a cancellation. (Inherited from IIntelliPromptSession.)
Public event | Committed | Occurs after the session is committed.
Public event | Committing | Occurs before the session is committed, allowing it to be cancelled.
Public event | Opened | Occurs when the session is opened. (Inherited from IIntelliPromptSession.)
Public event | SelectionChanged | Occurs after the Selection has changed.
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from IServiceLocator.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from IServiceLocator.)
Top
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.Committed Event

ICompletionSessionCommitted Event
Occurs after the session is committed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler Committed
Event Committed As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.Committing Event

ICompletionSessionCommitting Event
Occurs before the session is committed, allowing it to be cancelled.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler<CancelEventArgs> Committing
Event Committing As EventHandler(Of CancelEventArgs)

Value

Type: SystemEventHandler CancelEventArgs
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ICompletionSession.SelectionChanged Event

ICompletionSessionSelectionChanged Event
Occurs after the Selection has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler SelectionChanged
Event SelectionChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ICompletionSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IContentProvider Interface

IContentProvider Interface
Provides the base requirements for an object that generates content to be used in various IntelliPrompt popups.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IContentProvider
Public Interface IContentProvider

The IContentProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetContent | Returns the content to use in various IntelliPrompt popups.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IContentProvider Methods

IContentProvider Methods

The IContentProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetContent | Returns the content to use in various IntelliPrompt popups.
Top
See Also

Reference

IContentProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IContentProvider.GetContent Method

IContentProviderGetContent Method
Returns the content to use in various IntelliPrompt popups.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object GetContent()
Function GetContent As Object

Return Value

Type: Object
The content to use in various IntelliPrompt popups.
See Also

Reference

IContentProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IImageSourceProvider Interface

IImageSourceProvider Interface
Provides the base requirements for an object that provides IntelliPrompt with an ImageSource.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IImageSourceProvider
Public Interface IImageSourceProvider

The IImageSourceProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetImageSource | Returns the ImageSource to use in an IntelliPrompt user interface element.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationDirectImageSourceProvider
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationCommonImageSourceProvider


IImageSourceProvider Methods

IImageSourceProvider Methods

The IImageSourceProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetImageSource | Returns the ImageSource to use in an IntelliPrompt user interface element.
Top
See Also

Reference

IImageSourceProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IImageSourceProvider.GetImageSource Method

IImageSourceProviderGetImageSource Method
Returns the ImageSource to use in an IntelliPrompt user interface element.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ImageSource GetImageSource()
Function GetImageSource As ImageSource

Return Value

Type: ImageSource
The ImageSource to use in an IntelliPrompt user interface element.
See Also

Reference

IImageSourceProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptManager Interface

IIntelliPromptManager Interface
Provides the base requirements for an object that represents a manager of IntelliPrompt user interface functionality.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IIntelliPromptManager
Public Interface IIntelliPromptManager

The IIntelliPromptManager type exposes the following members.

Properties
 | Name | Description
Public property | Sessions | Gets the read-only collection of open sessions.
Top
Methods
 | Name | Description
Public method | CloseAllSessions | Closes all open sessions.
Public method | CloseSessions | Closes any open session of the specified IIntelliPromptSessionType.
Public method | RepositionAll | Notifies all sessions to reposition their user interface.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptManager Properties

IIntelliPromptManager Properties

The IIntelliPromptManager type exposes the following members.

Properties
 | Name | Description
Public property | Sessions | Gets the read-only collection of open sessions.
Top
See Also

Reference

IIntelliPromptManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptManager.Sessions Property

IIntelliPromptManagerSessions Property
Gets the read-only collection of open sessions.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IIntelliPromptSessionCollection Sessions { get; }
ReadOnly Property Sessions As IIntelliPromptSessionCollection
    Get

Property Value

Type: IIntelliPromptSessionCollection
The read-only collection of open sessions.
See Also

Reference

IIntelliPromptManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptManager Methods

IIntelliPromptManager Methods

The IIntelliPromptManager type exposes the following members.

Methods
 | Name | Description
Public method | CloseAllSessions | Closes all open sessions.
Public method | CloseSessions | Closes any open session of the specified IIntelliPromptSessionType.
Public method | RepositionAll | Notifies all sessions to reposition their user interface.
Top
See Also

Reference

IIntelliPromptManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptManager.CloseAllSessions Method

IIntelliPromptManagerCloseAllSessions Method
Closes all open sessions.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void CloseAllSessions()
Sub CloseAllSessions
See Also

Reference

IIntelliPromptManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptManager.CloseSessions Method

IIntelliPromptManagerCloseSessions Method
Closes any open session of the specified IIntelliPromptSessionType.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void CloseSessions(
    IIntelliPromptSessionType sessionType
)
Sub CloseSessions (
    sessionType As IIntelliPromptSessionType
)

Parameters

sessionType
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptIIntelliPromptSessionType
The IIntelliPromptSessionType for which to search.
See Also

Reference

IIntelliPromptManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptManager.RepositionAll Method

IIntelliPromptManagerRepositionAll Method
Notifies all sessions to reposition their user interface.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void RepositionAll()
Sub RepositionAll
See Also

Reference

IIntelliPromptManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSession Interface

IIntelliPromptSession Interface
Provides the base requirements for an object that represents an IntelliPrompt session.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IIntelliPromptSession : IServiceLocator
Public Interface IIntelliPromptSession
    Inherits IServiceLocator

The IIntelliPromptSession type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the view-relative bounds of the session's open popup, if available.
Public property | ClosesOnLostFocus | Returns whether this session auto-closes when the editor or any IntelliPrompt popups lose focus.
Public property | IsOpen | Gets whether the session is currently open.
Public property | SessionType | Gets the IIntelliPromptSessionType that identifies the type of session.
Public property | SnapshotRange | Gets the TextSnapshotRange containing the original TextRange in the ITextSnapshot that triggered the session.
Public property | View | Gets the IEditorView in which the session is opened.
Top
Methods
 | Name | Description
Public method | Close | Closes the session.
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from IServiceLocator.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | Open | Opens the session, attaching to the specified IEditorView.
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | Reposition | Notifies the session that it should reposition its user interface.
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the session is closed, with the Cancel flag on the event arguments indicating whether the close was due to a cancellation.
Public event | Opened | Occurs when the session is opened.
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from IServiceLocator.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from IServiceLocator.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSession Properties

IIntelliPromptSession Properties

The IIntelliPromptSession type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the view-relative bounds of the session's open popup, if available.
Public property | ClosesOnLostFocus | Returns whether this session auto-closes when the editor or any IntelliPrompt popups lose focus.
Public property | IsOpen | Gets whether the session is currently open.
Public property | SessionType | Gets the IIntelliPromptSessionType that identifies the type of session.
Public property | SnapshotRange | Gets the TextSnapshotRange containing the original TextRange in the ITextSnapshot that triggered the session.
Public property | View | Gets the IEditorView in which the session is opened.
Top
See Also

Reference

IIntelliPromptSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSession.Bounds Property

IIntelliPromptSessionBounds Property
Gets the view-relative bounds of the session's open popup, if available.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<Rect> Bounds { get; }
ReadOnly Property Bounds As Nullable(Of Rect)
    Get

Property Value

Type: Nullable Rect
The view-relative bounds of the session's open popup, if available.
See Also

Reference

IIntelliPromptSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSession.ClosesOnLostFocus Property

IIntelliPromptSessionClosesOnLostFocus Property
Returns whether this session auto-closes when the editor or any IntelliPrompt popups lose focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ClosesOnLostFocus { get; }
ReadOnly Property ClosesOnLostFocus As Boolean
    Get

Property Value

Type: Boolean
true if this session auto-closes when the editor or any IntelliPrompt popups lose focus; otherwise, false.
See Also

Reference

IIntelliPromptSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSession.IsOpen Property

IIntelliPromptSessionIsOpen Property
Gets whether the session is currently open.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsOpen { get; }
ReadOnly Property IsOpen As Boolean
    Get

Property Value

Type: Boolean
true if the session is currently open; otherwise, false.
See Also

Reference

IIntelliPromptSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSession.SessionType Property

IIntelliPromptSessionSessionType Property
Gets the IIntelliPromptSessionType that identifies the type of session.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IIntelliPromptSessionType SessionType { get; }
ReadOnly Property SessionType As IIntelliPromptSessionType
    Get

Property Value

Type: IIntelliPromptSessionType
The IIntelliPromptSessionType that identifies the type of session.
See Also

Reference

IIntelliPromptSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSession.SnapshotRange Property

IIntelliPromptSessionSnapshotRange Property
Gets the TextSnapshotRange containing the original TextRange in the ITextSnapshot that triggered the session.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotRange SnapshotRange { get; }
ReadOnly Property SnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
The TextSnapshotRange containing the original TextRange in the ITextSnapshot that triggered the session.
Remarks
This member should only be used while the session is open.
See Also

Reference

IIntelliPromptSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSession.View Property

IIntelliPromptSessionView Property
Gets the IEditorView in which the session is opened.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorView View { get; }
ReadOnly Property View As IEditorView
    Get

Property Value

Type: IEditorView
The IEditorView in which the session is opened.
Remarks
This member should only be used while the session is open.
See Also

Reference

IIntelliPromptSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSession Methods

IIntelliPromptSession Methods

The IIntelliPromptSession type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the session.
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from IServiceLocator.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | Open | Opens the session, attaching to the specified IEditorView.
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | Reposition | Notifies the session that it should reposition its user interface.
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Top
See Also

Reference

IIntelliPromptSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSession.Close Method

IIntelliPromptSessionClose Method
Closes the session.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Close(
    bool cancelled
)
Sub Close (
    cancelled As Boolean
)

Parameters

cancelled
Type: SystemBoolean
Whether the session was closed due to a cancellation.
See Also

Reference

IIntelliPromptSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSession.Open Method

IIntelliPromptSessionOpen Method
Opens the session, attaching to the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Open(
    IEditorView view,
    TextRange textRange
)
Sub Open (
    view As IEditorView,
    textRange As TextRange
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which the session is opened.
textRange
Type: ActiproSoftware.TextTextRange
The source TextRange in the view's current ITextSnapshot.
See Also

Reference

IIntelliPromptSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSession.Reposition Method

IIntelliPromptSessionReposition Method
Notifies the session that it should reposition its user interface.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Reposition()
Sub Reposition
See Also

Reference

IIntelliPromptSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSession Events

IIntelliPromptSession Events

The IIntelliPromptSession type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the session is closed, with the Cancel flag on the event arguments indicating whether the close was due to a cancellation.
Public event | Opened | Occurs when the session is opened.
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from IServiceLocator.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from IServiceLocator.)
Top
See Also

Reference

IIntelliPromptSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSession.Closed Event

IIntelliPromptSessionClosed Event
Occurs when the session is closed, with the Cancel flag on the event arguments indicating whether the close was due to a cancellation.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler<CancelEventArgs> Closed
Event Closed As EventHandler(Of CancelEventArgs)

Value

Type: SystemEventHandler CancelEventArgs
See Also

Reference

IIntelliPromptSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSession.Opened Event

IIntelliPromptSessionOpened Event
Occurs when the session is opened.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler Opened
Event Opened As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

IIntelliPromptSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSessionCollection Interface

IIntelliPromptSessionCollection Interface
Provides the base requirements for an object that represents a collection of IIntelliPromptSession objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IIntelliPromptSessionCollection : IObservableCollection<IIntelliPromptSession>,
    IList<IIntelliPromptSession>, ICollection<IIntelliPromptSession>, IEnumerable<IIntelliPromptSession>,
    IEnumerable
Public Interface IIntelliPromptSessionCollection
    Inherits IObservableCollection(Of IIntelliPromptSession), IList(Of IIntelliPromptSession),
    ICollection(Of IIntelliPromptSession), IEnumerable(Of IIntelliPromptSession), IEnumerable

The IIntelliPromptSessionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IIntelliPromptSession .)
Public property | IsReadOnly | (Inherited from ICollection IIntelliPromptSession .)
Public property | ItemInt32 | (Inherited from IList IIntelliPromptSession .)
Public property | ItemIIntelliPromptSessionType | Gets the first IIntelliPromptSession with the specified type. [C#] In C#, this property is the indexer for the IIntelliPromptSessionCollection interface.
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IIntelliPromptSession .)
Public method | Clear | (Inherited from ICollection IIntelliPromptSession .)
Public method | Contains(T) | (Inherited from ICollection IIntelliPromptSession .)
Public method | Contains(IIntelliPromptSessionType) | Determines whether an IIntelliPromptSession with the specified type is in the collection.
Public method | CopyTo | (Inherited from ICollection IIntelliPromptSession .)
Public method | GetEnumerator | (Inherited from IEnumerable IIntelliPromptSession .)
Public method | IndexOf(T) | (Inherited from IList IIntelliPromptSession .)
Public method | IndexOf(IIntelliPromptSessionType) | Searches for an IIntelliPromptSession with the specified type and returns the zero-based index of the first occurrence within the entire collection.
Public method | Insert | (Inherited from IList IIntelliPromptSession .)
Public method | Remove | (Inherited from ICollection IIntelliPromptSession .)
Public method | RemoveAt | (Inherited from IList IIntelliPromptSession .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSessionCollection Properties

IIntelliPromptSessionCollection Properties

The IIntelliPromptSessionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IIntelliPromptSession .)
Public property | IsReadOnly | (Inherited from ICollection IIntelliPromptSession .)
Public property | ItemInt32 | (Inherited from IList IIntelliPromptSession .)
Public property | ItemIIntelliPromptSessionType | Gets the first IIntelliPromptSession with the specified type. [C#] In C#, this property is the indexer for the IIntelliPromptSessionCollection interface.
Top
See Also

Reference

IIntelliPromptSessionCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSessionCollection.Item Property

IIntelliPromptSessionCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from IList IIntelliPromptSession .)
Public property | ItemIIntelliPromptSessionType | Gets the first IIntelliPromptSession with the specified type. [C#] In C#, this property is the indexer for the IIntelliPromptSessionCollection interface.
Top
See Also

Reference

IIntelliPromptSessionCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSessionCollection.Item Property (IIntelliPromptSessionType)

IIntelliPromptSessionCollectionItem Property (IIntelliPromptSessionType)
Gets the first IIntelliPromptSession with the specified type.

[C#] In C#, this property is the indexer for the IIntelliPromptSessionCollection interface.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IIntelliPromptSession this[
    IIntelliPromptSessionType sessionType
] { get; }
ReadOnly Property Item (
    sessionType As IIntelliPromptSessionType
) As IIntelliPromptSession
    Get

Parameters

sessionType
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptIIntelliPromptSessionType
The IIntelliPromptSessionType to locate in the collection.

Property Value

Type: IIntelliPromptSession
The first IIntelliPromptSession with the specified type.
See Also

Reference

IIntelliPromptSessionCollection Interface
Item Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSessionCollection Methods

IIntelliPromptSessionCollection Methods

The IIntelliPromptSessionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IIntelliPromptSession .)
Public method | Clear | (Inherited from ICollection IIntelliPromptSession .)
Public method | Contains(T) | (Inherited from ICollection IIntelliPromptSession .)
Public method | Contains(IIntelliPromptSessionType) | Determines whether an IIntelliPromptSession with the specified type is in the collection.
Public method | CopyTo | (Inherited from ICollection IIntelliPromptSession .)
Public method | GetEnumerator | (Inherited from IEnumerable IIntelliPromptSession .)
Public method | IndexOf(T) | (Inherited from IList IIntelliPromptSession .)
Public method | IndexOf(IIntelliPromptSessionType) | Searches for an IIntelliPromptSession with the specified type and returns the zero-based index of the first occurrence within the entire collection.
Public method | Insert | (Inherited from IList IIntelliPromptSession .)
Public method | Remove | (Inherited from ICollection IIntelliPromptSession .)
Public method | RemoveAt | (Inherited from IList IIntelliPromptSession .)
Top
See Also

Reference

IIntelliPromptSessionCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSessionCollection.Contains Method

IIntelliPromptSessionCollectionContains Method
Overload List
 | Name | Description
Public method | Contains(T) | (Inherited from ICollection IIntelliPromptSession .)
Public method | Contains(IIntelliPromptSessionType) | Determines whether an IIntelliPromptSession with the specified type is in the collection.
Top
See Also

Reference

IIntelliPromptSessionCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSessionCollection.Contains Method (IIntelliPromptSessionType)

IIntelliPromptSessionCollectionContains Method (IIntelliPromptSessionType)
Determines whether an IIntelliPromptSession with the specified type is in the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Contains(
    IIntelliPromptSessionType sessionType
)
Function Contains (
    sessionType As IIntelliPromptSessionType
) As Boolean

Parameters

sessionType
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptIIntelliPromptSessionType
The IIntelliPromptSessionType to locate in the collection.

Return Value

Type: Boolean
true if an IIntelliPromptSession with the specified type is found in the collection; otherwise, false.
See Also

Reference

IIntelliPromptSessionCollection Interface
Contains Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSessionCollection.IndexOf Method

IIntelliPromptSessionCollectionIndexOf Method
Overload List
 | Name | Description
Public method | IndexOf(T) | (Inherited from IList IIntelliPromptSession .)
Public method | IndexOf(IIntelliPromptSessionType) | Searches for an IIntelliPromptSession with the specified type and returns the zero-based index of the first occurrence within the entire collection.
Top
See Also

Reference

IIntelliPromptSessionCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSessionCollection.IndexOf Method (IIntelliPromptSessionType)

IIntelliPromptSessionCollectionIndexOf Method (IIntelliPromptSessionType)
Searches for an IIntelliPromptSession with the specified type and returns the zero-based index of the first occurrence within the entire collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int IndexOf(
    IIntelliPromptSessionType sessionType
)
Function IndexOf (
    sessionType As IIntelliPromptSessionType
) As Integer

Parameters

sessionType
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptIIntelliPromptSessionType
The IIntelliPromptSessionType to locate in the collection.

Return Value

Type: Int32
The zero-based index of the first occurrence of an IIntelliPromptSession with the specified type within the entire collection, if found; otherwise, -1.
See Also

Reference

IIntelliPromptSessionCollection Interface
IndexOf Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSessionCollection Events

IIntelliPromptSessionCollection Events

The IIntelliPromptSessionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IIntelliPromptSessionCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSessionType Interface

IIntelliPromptSessionType Interface
Provides the base requirements for an object that represents an IntelliPrompt session type.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IIntelliPromptSessionType : IKeyedObject
Public Interface IIntelliPromptSessionType
    Inherits IKeyedObject

The IIntelliPromptSessionType type exposes the following members.

Properties
 | Name | Description
Public property | AreMultipleSessionsAllowed | Gets whether multiple sessions of this type are permitted.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationIntelliPromptSessionType


IIntelliPromptSessionType Properties

IIntelliPromptSessionType Properties

The IIntelliPromptSessionType type exposes the following members.

Properties
 | Name | Description
Public property | AreMultipleSessionsAllowed | Gets whether multiple sessions of this type are permitted.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
See Also

Reference

IIntelliPromptSessionType Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IIntelliPromptSessionType.AreMultipleSessionsAllowed Property

IIntelliPromptSessionTypeAreMultipleSessionsAllowed Property
Gets whether multiple sessions of this type are permitted.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool AreMultipleSessionsAllowed { get; }
ReadOnly Property AreMultipleSessionsAllowed As Boolean
    Get

Property Value

Type: Boolean
true if multiple sessions of this type are permitted; otherwise, false.
See Also

Reference

IIntelliPromptSessionType Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ImageSourceProviderConverter Class

ImageSourceProviderConverter Class
Represents a value converter that returns an ImageSource from an IImageSourceProvider.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptImageSourceProviderConverter

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ImageSourceProviderConverter : IValueConverter
Public Class ImageSourceProviderConverter
    Implements IValueConverter

The ImageSourceProviderConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ImageSourceProviderConverter | Initializes a new instance of the ImageSourceProviderConverter class
Top
Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ImageSourceProviderConverter Constructor

ImageSourceProviderConverter Constructor
Initializes a new instance of the ImageSourceProviderConverter class

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ImageSourceProviderConverter()
Public Sub New
See Also

Reference

ImageSourceProviderConverter Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ImageSourceProviderConverter Methods

ImageSourceProviderConverter Methods

The ImageSourceProviderConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ImageSourceProviderConverter Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ImageSourceProviderConverter.Convert Method

ImageSourceProviderConverterConvert Method
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    string language
)
Public Function Convert (
    value As Object,
    targetType As Type,
    parameter As Object,
    language As String
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
language
Type: SystemString
The language of the conversion.

Return Value

Type: Object
A converted value.
See Also

Reference

ImageSourceProviderConverter Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ImageSourceProviderConverter.ConvertBack Method

ImageSourceProviderConverterConvertBack Method
Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    string language
)
Public Function ConvertBack (
    value As Object,
    targetType As Type,
    parameter As Object,
    language As String
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
language
Type: SystemString
The language of the conversion.

Return Value

Type: Object
A converted value.
See Also

Reference

ImageSourceProviderConverter Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


INavigableRequestContext Interface

INavigableRequestContext Interface
Provides the base requirements for a context in which a INavigableSymbolProvider is called.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface INavigableRequestContext : IKeyedObject
Public Interface INavigableRequestContext
    Inherits IKeyedObject

The INavigableRequestContext type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


INavigableRequestContext Properties

INavigableRequestContext Properties

The INavigableRequestContext type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
See Also

Reference

INavigableRequestContext Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


INavigableSymbol Interface

INavigableSymbol Interface
Provides the base requirements for a symbol (type, member, etc.) to which navigation can be made.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface INavigableSymbol
Public Interface INavigableSymbol

The INavigableSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ContentProvider | Gets an IContentProvider that creates the content to render for the symbol within UI.
Public property | HierarchyLevel | Gets the symbol's hierarchy level, which may sometimes be reflected in UI.
Public property | NavigationSnapshotOffset | Gets the TextSnapshotOffset within the symbol's source file to navigate when the symbol is selected.
Public property | SnapshotRange | Gets a TextSnapshotRange indicating the offset range of the symbol within its source file.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


INavigableSymbol Properties

INavigableSymbol Properties

The INavigableSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ContentProvider | Gets an IContentProvider that creates the content to render for the symbol within UI.
Public property | HierarchyLevel | Gets the symbol's hierarchy level, which may sometimes be reflected in UI.
Public property | NavigationSnapshotOffset | Gets the TextSnapshotOffset within the symbol's source file to navigate when the symbol is selected.
Public property | SnapshotRange | Gets a TextSnapshotRange indicating the offset range of the symbol within its source file.
Top
See Also

Reference

INavigableSymbol Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


INavigableSymbol.ContentProvider Property

INavigableSymbolContentProvider Property
Gets an IContentProvider that creates the content to render for the symbol within UI.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IContentProvider ContentProvider { get; }
ReadOnly Property ContentProvider As IContentProvider
    Get

Property Value

Type: IContentProvider
An IContentProvider that creates the content to render for the symbol within UI.
See Also

Reference

INavigableSymbol Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


INavigableSymbol.HierarchyLevel Property

INavigableSymbolHierarchyLevel Property
Gets the symbol's hierarchy level, which may sometimes be reflected in UI.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int HierarchyLevel { get; }
ReadOnly Property HierarchyLevel As Integer
    Get

Property Value

Type: Int32
The symbol's hierarchy level, which may sometimes be reflected in UI.
See Also

Reference

INavigableSymbol Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


INavigableSymbol.NavigationSnapshotOffset Property

INavigableSymbolNavigationSnapshotOffset Property
Gets the TextSnapshotOffset within the symbol's source file to navigate when the symbol is selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotOffset> NavigationSnapshotOffset { get; }
ReadOnly Property NavigationSnapshotOffset As Nullable(Of TextSnapshotOffset)
    Get

Property Value

Type: Nullable TextSnapshotOffset
The TextSnapshotOffset within the symbol's source file to navigate when the symbol is selected.
See Also

Reference

INavigableSymbol Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


INavigableSymbol.SnapshotRange Property

INavigableSymbolSnapshotRange Property
Gets a TextSnapshotRange indicating the offset range of the symbol within its source file.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotRange SnapshotRange { get; }
ReadOnly Property SnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
A TextSnapshotRange indicating the offset range of the symbol within its source file.
See Also

Reference

INavigableSymbol Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


INavigableSymbolProvider Interface

INavigableSymbolProvider Interface
Provides the base requirements for a language service that can return navigable symbols.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface INavigableSymbolProvider
Public Interface INavigableSymbolProvider

The INavigableSymbolProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


INavigableSymbolProvider Methods

INavigableSymbolProvider Methods

The INavigableSymbolProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol.
Top
See Also

Reference

INavigableSymbolProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


INavigableSymbolProvider.GetSymbols Method

INavigableSymbolProviderGetSymbols Method
Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
INavigableSymbolSet GetSymbols(
    INavigableRequestContext context,
    TextSnapshotOffset snapshotOffset,
    INavigableSymbol parentSymbol
)
Function GetSymbols (
    context As INavigableRequestContext,
    snapshotOffset As TextSnapshotOffset,
    parentSymbol As INavigableSymbol
) As INavigableSymbolSet

Parameters

context
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptINavigableRequestContext
An INavigableRequestContext that provides the context of the request.
snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset that contains the ITextSnapshot to examine, along with a contextual offset.
parentSymbol
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptINavigableSymbol
The optional parent INavigableSymbol to examine, or a null value if the root symbols are requested.

Return Value

Type: INavigableSymbolSet
An INavigableSymbolSet containing the INavigableSymbol objects that were located.
See Also

Reference

INavigableSymbolProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


INavigableSymbolSet Interface

INavigableSymbolSet Interface
Provides the base requirements for a class that stores the results of a navigable symbol request.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface INavigableSymbolSet
Public Interface INavigableSymbolSet

The INavigableSymbolSet type exposes the following members.

Properties
 | Name | Description
Public property | IsPartial | Gets whether the set contains a partial set of results, that may require requerying as context changes.
Public property | Symbols | Gets the collection of INavigableSymbol objects.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


INavigableSymbolSet Properties

INavigableSymbolSet Properties

The INavigableSymbolSet type exposes the following members.

Properties
 | Name | Description
Public property | IsPartial | Gets whether the set contains a partial set of results, that may require requerying as context changes.
Public property | Symbols | Gets the collection of INavigableSymbol objects.
Top
See Also

Reference

INavigableSymbolSet Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


INavigableSymbolSet.IsPartial Property

INavigableSymbolSetIsPartial Property
Gets whether the set contains a partial set of results, that may require requerying as context changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsPartial { get; }
ReadOnly Property IsPartial As Boolean
    Get

Property Value

Type: Boolean
true if the set contains a partial set of results; otherwise, false.
See Also

Reference

INavigableSymbolSet Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


INavigableSymbolSet.Symbols Property

INavigableSymbolSetSymbols Property
Gets the collection of INavigableSymbol objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<INavigableSymbol> Symbols { get; }
ReadOnly Property Symbols As IEnumerable(Of INavigableSymbol)
    Get

Property Value

Type: IEnumerable INavigableSymbol
The collection of INavigableSymbol objects.
See Also

Reference

INavigableSymbolSet Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IntelliPromptSessionTypes Class

IntelliPromptSessionTypes Class
Provides access to the built-in IIntelliPromptSessionType instances.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptIntelliPromptSessionTypes

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class IntelliPromptSessionTypes
Public NotInheritable Class IntelliPromptSessionTypes

The IntelliPromptSessionTypes type exposes the following members.

Properties
Name | Description
CodeSnippet | Obsolete. Gets the IIntelliPromptSessionType for a code snippet.
CodeSnippetSelection | Gets the IIntelliPromptSessionType for a code snippet selection.
CodeSnippetTemplate | Gets the IIntelliPromptSessionType for a code snippet template.
Completion | Gets the IIntelliPromptSessionType for a completion.
CompletionDescriptionTip | Gets the IIntelliPromptSessionType for a completion description tip.
ParameterInfo | Gets the IIntelliPromptSessionType for parameter info.
QuickInfo | Gets the IIntelliPromptSessionType for quick info.
SmartTag | Gets the IIntelliPromptSessionType for a smart tag.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IntelliPromptSessionTypes Properties

IntelliPromptSessionTypes Properties

The IntelliPromptSessionTypes type exposes the following members.

Properties
Name | Description
CodeSnippet | Obsolete. Gets the IIntelliPromptSessionType for a code snippet.
CodeSnippetSelection | Gets the IIntelliPromptSessionType for a code snippet selection.
CodeSnippetTemplate | Gets the IIntelliPromptSessionType for a code snippet template.
Completion | Gets the IIntelliPromptSessionType for a completion.
CompletionDescriptionTip | Gets the IIntelliPromptSessionType for a completion description tip.
ParameterInfo | Gets the IIntelliPromptSessionType for parameter info.
QuickInfo | Gets the IIntelliPromptSessionType for quick info.
SmartTag | Gets the IIntelliPromptSessionType for a smart tag.
Top
See Also

Reference

IntelliPromptSessionTypes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IntelliPromptSessionTypes.CodeSnippet Property

IntelliPromptSessionTypesCodeSnippet Property

Note: This API is now obsolete.

Gets the IIntelliPromptSessionType for a code snippet.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[ObsoleteAttribute("Use the 'IntelliPromptSessionTypes.CodeSnippetTemplate' property instead.",
    false)]
public static IIntelliPromptSessionType CodeSnippet { get; }
<ObsoleteAttribute("Use the 'IntelliPromptSessionTypes.CodeSnippetTemplate' property instead.",
    false)>
Public Shared ReadOnly Property CodeSnippet As IIntelliPromptSessionType
    Get

Property Value

Type: IIntelliPromptSessionType
The IIntelliPromptSessionType for a code snippet.
See Also

Reference

IntelliPromptSessionTypes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IntelliPromptSessionTypes.CodeSnippetSelection Property

IntelliPromptSessionTypesCodeSnippetSelection Property
Gets the IIntelliPromptSessionType for a code snippet selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IIntelliPromptSessionType CodeSnippetSelection { get; }
Public Shared ReadOnly Property CodeSnippetSelection As IIntelliPromptSessionType
    Get

Property Value

Type: IIntelliPromptSessionType
The IIntelliPromptSessionType for a code snippet selection.
See Also

Reference

IntelliPromptSessionTypes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IntelliPromptSessionTypes.CodeSnippetTemplate Property

IntelliPromptSessionTypesCodeSnippetTemplate Property
Gets the IIntelliPromptSessionType for a code snippet template.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IIntelliPromptSessionType CodeSnippetTemplate { get; }
Public Shared ReadOnly Property CodeSnippetTemplate As IIntelliPromptSessionType
    Get

Property Value

Type: IIntelliPromptSessionType
The IIntelliPromptSessionType for a code snippet template.
See Also

Reference

IntelliPromptSessionTypes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IntelliPromptSessionTypes.Completion Property

IntelliPromptSessionTypesCompletion Property
Gets the IIntelliPromptSessionType for a completion.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IIntelliPromptSessionType Completion { get; }
Public Shared ReadOnly Property Completion As IIntelliPromptSessionType
    Get

Property Value

Type: IIntelliPromptSessionType
The IIntelliPromptSessionType for a completion.
See Also

Reference

IntelliPromptSessionTypes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IntelliPromptSessionTypes.CompletionDescriptionTip Property

IntelliPromptSessionTypesCompletionDescriptionTip Property
Gets the IIntelliPromptSessionType for a completion description tip.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IIntelliPromptSessionType CompletionDescriptionTip { get; }
Public Shared ReadOnly Property CompletionDescriptionTip As IIntelliPromptSessionType
    Get

Property Value

Type: IIntelliPromptSessionType
The IIntelliPromptSessionType for a completion description tip.
See Also

Reference

IntelliPromptSessionTypes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IntelliPromptSessionTypes.ParameterInfo Property

IntelliPromptSessionTypesParameterInfo Property
Gets the IIntelliPromptSessionType for parameter info.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IIntelliPromptSessionType ParameterInfo { get; }
Public Shared ReadOnly Property ParameterInfo As IIntelliPromptSessionType
    Get

Property Value

Type: IIntelliPromptSessionType
The IIntelliPromptSessionType for parameter info.
See Also

Reference

IntelliPromptSessionTypes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IntelliPromptSessionTypes.QuickInfo Property

IntelliPromptSessionTypesQuickInfo Property
Gets the IIntelliPromptSessionType for quick info.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IIntelliPromptSessionType QuickInfo { get; }
Public Shared ReadOnly Property QuickInfo As IIntelliPromptSessionType
    Get

Property Value

Type: IIntelliPromptSessionType
The IIntelliPromptSessionType for quick info.
See Also

Reference

IntelliPromptSessionTypes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IntelliPromptSessionTypes.SmartTag Property

IntelliPromptSessionTypesSmartTag Property
Gets the IIntelliPromptSessionType for a smart tag.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IIntelliPromptSessionType SmartTag { get; }
Public Shared ReadOnly Property SmartTag As IIntelliPromptSessionType
    Get

Property Value

Type: IIntelliPromptSessionType
The IIntelliPromptSessionType for a smart tag.
See Also

Reference

IntelliPromptSessionTypes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterInfoProvider Interface

IParameterInfoProvider Interface
Provides the base requirements for an object that can handle requests for display of an IntelliPrompt parameter info popup.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IParameterInfoProvider : IOrderable,
    IKeyedObject
Public Interface IParameterInfoProvider
    Inherits IOrderable, IKeyedObject

The IParameterInfoProvider type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from IOrderable.)
Top
Methods
 | Name | Description
Public method | RequestSession | Requests that an IParameterInfoSession be opened for the specified IEditorView.
Top
Remarks
Objects implementing this provider interface can be registered as a service with an ISyntaxLanguage using the RegisterService(Object, Object) method. Any object implementing this interface will be called as needed by the language in priority order (based on IOrderable settings).
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterInfoProvider Properties

IParameterInfoProvider Properties

The IParameterInfoProvider type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from IOrderable.)
Top
See Also

Reference

IParameterInfoProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterInfoProvider Methods

IParameterInfoProvider Methods

The IParameterInfoProvider type exposes the following members.

Methods
 | Name | Description
Public method | RequestSession | Requests that an IParameterInfoSession be opened for the specified IEditorView.
Top
See Also

Reference

IParameterInfoProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterInfoProvider.RequestSession Method

IParameterInfoProviderRequestSession Method
Requests that an IParameterInfoSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool RequestSession(
    IEditorView view
)
Function RequestSession (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.

Return Value

Type: Boolean
true if a session was opened; otherwise, false.
See Also

Reference

IParameterInfoProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterInfoSession Interface

IParameterInfoSession Interface
Provides the base requirements for an object that represents an IntelliPrompt parameter info session.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IParameterInfoSession : IIntelliPromptSession,
    IServiceLocator
Public Interface IParameterInfoSession
    Inherits IIntelliPromptSession, IServiceLocator

The IParameterInfoSession type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the view-relative bounds of the session's open popup, if available. (Inherited from IIntelliPromptSession.)
Public property | ClosesOnLostFocus | Returns whether this session auto-closes when the editor or any IntelliPrompt popups lose focus. (Inherited from IIntelliPromptSession.)
Public property | Content | Gets the content to display in the parameter info popup.
Public property | DisplaySelectedIndex | Gets the one-based index of the Selection.
Public property | IsArrowKeySelectionEnabled | Gets whether the up and down arrow keys can be used to change the Selection.
Public property | IsOpen | Gets whether the session is currently open. (Inherited from IIntelliPromptSession.)
Public property | Items | Gets the collection of ISignatureItem objects within the parameter info.
Public property | MaxWidth | Gets the quick info popup's maximum width.
Public property | Selection | Gets or sets a ISignatureItem indicating the current selection within the parameter info.
Public property | SessionType | Gets the IIntelliPromptSessionType that identifies the type of session. (Inherited from IIntelliPromptSession.)
Public property | SnapshotRange | Gets the TextSnapshotRange containing the original TextRange in the ITextSnapshot that triggered the session. (Inherited from IIntelliPromptSession.)
Public property | View | Gets the IEditorView in which the session is opened. (Inherited from IIntelliPromptSession.)
Top
Methods
 | Name | Description
Public method | Close | Closes the session. (Inherited from IIntelliPromptSession.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from IServiceLocator.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | Open | Opens the session, attaching to the specified IEditorView. (Inherited from IIntelliPromptSession.)
Public method | Refresh | Refreshes the displayed content from the selected item's content provider, and repositions the popup.
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | Reposition | Notifies the session that it should reposition its user interface. (Inherited from IIntelliPromptSession.)
Public method | SelectNext | Selects the next item.
Public method | SelectPrevious | Selects the previous item.
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the session is closed, with the Cancel flag on the event arguments indicating whether the close was due to a cancellation. (Inherited from IIntelliPromptSession.)
Public event | Opened | Occurs when the session is opened. (Inherited from IIntelliPromptSession.)
Public event | SelectionChanged | Occurs after the Selection has changed.
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from IServiceLocator.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from IServiceLocator.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterInfoSession Properties

IParameterInfoSession Properties

The IParameterInfoSession type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the view-relative bounds of the session's open popup, if available. (Inherited from IIntelliPromptSession.)
Public property | ClosesOnLostFocus | Returns whether this session auto-closes when the editor or any IntelliPrompt popups lose focus. (Inherited from IIntelliPromptSession.)
Public property | Content | Gets the content to display in the parameter info popup.
Public property | DisplaySelectedIndex | Gets the one-based index of the Selection.
Public property | IsArrowKeySelectionEnabled | Gets whether the up and down arrow keys can be used to change the Selection.
Public property | IsOpen | Gets whether the session is currently open. (Inherited from IIntelliPromptSession.)
Public property | Items | Gets the collection of ISignatureItem objects within the parameter info.
Public property | MaxWidth | Gets the quick info popup's maximum width.
Public property | Selection | Gets or sets a ISignatureItem indicating the current selection within the parameter info.
Public property | SessionType | Gets the IIntelliPromptSessionType that identifies the type of session. (Inherited from IIntelliPromptSession.)
Public property | SnapshotRange | Gets the TextSnapshotRange containing the original TextRange in the ITextSnapshot that triggered the session. (Inherited from IIntelliPromptSession.)
Public property | View | Gets the IEditorView in which the session is opened. (Inherited from IIntelliPromptSession.)
Top
See Also

Reference

IParameterInfoSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterInfoSession.Content Property

IParameterInfoSessionContent Property
Gets the content to display in the parameter info popup.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Content { get; }
ReadOnly Property Content As Object
    Get

Property Value

Type: Object
The content to display in the parameter info popup.
See Also

Reference

IParameterInfoSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterInfoSession.DisplaySelectedIndex Property

IParameterInfoSessionDisplaySelectedIndex Property
Gets the one-based index of the Selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int DisplaySelectedIndex { get; }
ReadOnly Property DisplaySelectedIndex As Integer
    Get

Property Value

Type: Int32
The one-based index of the Selection.
See Also

Reference

IParameterInfoSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterInfoSession.IsArrowKeySelectionEnabled Property

IParameterInfoSessionIsArrowKeySelectionEnabled Property
Gets whether the up and down arrow keys can be used to change the Selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsArrowKeySelectionEnabled { get; }
ReadOnly Property IsArrowKeySelectionEnabled As Boolean
    Get

Property Value

Type: Boolean
true if the up and down arrow keys can be used to change the Selection; otherwise, false.
See Also

Reference

IParameterInfoSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterInfoSession.Items Property

IParameterInfoSessionItems Property
Gets the collection of ISignatureItem objects within the parameter info.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISignatureItemCollection Items { get; }
ReadOnly Property Items As ISignatureItemCollection
    Get

Property Value

Type: ISignatureItemCollection
The collection of ISignatureItem objects within the parameter info.
See Also

Reference

IParameterInfoSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterInfoSession.MaxWidth Property

IParameterInfoSessionMaxWidth Property
Gets the quick info popup's maximum width.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
double MaxWidth { get; }
ReadOnly Property MaxWidth As Double
    Get

Property Value

Type: Double
The quick info popup's maximum width, or NaN to indicate no constraint.
See Also

Reference

IParameterInfoSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterInfoSession.Selection Property

IParameterInfoSessionSelection Property
Gets or sets a ISignatureItem indicating the current selection within the parameter info.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISignatureItem Selection { get; set; }
Property Selection As ISignatureItem
    Get
    Set

Property Value

Type: ISignatureItem
A ISignatureItem indicating the current selection within the parameter info.
See Also

Reference

IParameterInfoSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterInfoSession Methods

IParameterInfoSession Methods

The IParameterInfoSession type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the session. (Inherited from IIntelliPromptSession.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from IServiceLocator.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | Open | Opens the session, attaching to the specified IEditorView. (Inherited from IIntelliPromptSession.)
Public method | Refresh | Refreshes the displayed content from the selected item's content provider, and repositions the popup.
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | Reposition | Notifies the session that it should reposition its user interface. (Inherited from IIntelliPromptSession.)
Public method | SelectNext | Selects the next item.
Public method | SelectPrevious | Selects the previous item.
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Top
See Also

Reference

IParameterInfoSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterInfoSession.Refresh Method

IParameterInfoSessionRefresh Method
Refreshes the displayed content from the selected item's content provider, and repositions the popup.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Refresh()
Sub Refresh
See Also

Reference

IParameterInfoSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterInfoSession.SelectNext Method

IParameterInfoSessionSelectNext Method
Selects the next item.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectNext()
Sub SelectNext
See Also

Reference

IParameterInfoSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterInfoSession.SelectPrevious Method

IParameterInfoSessionSelectPrevious Method
Selects the previous item.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectPrevious()
Sub SelectPrevious
See Also

Reference

IParameterInfoSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterInfoSession Events

IParameterInfoSession Events

The IParameterInfoSession type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the session is closed, with the Cancel flag on the event arguments indicating whether the close was due to a cancellation. (Inherited from IIntelliPromptSession.)
Public event | Opened | Occurs when the session is opened. (Inherited from IIntelliPromptSession.)
Public event | SelectionChanged | Occurs after the Selection has changed.
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from IServiceLocator.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from IServiceLocator.)
Top
See Also

Reference

IParameterInfoSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterInfoSession.SelectionChanged Event

IParameterInfoSessionSelectionChanged Event
Occurs after the Selection has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler SelectionChanged
Event SelectionChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

IParameterInfoSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterizedContentProvider Interface

IParameterizedContentProvider Interface
Provides the base requirements for an object that generates content to be used in various IntelliPrompt popups, and can provide additional detail for a specific parameter.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IParameterizedContentProvider : IContentProvider
Public Interface IParameterizedContentProvider
    Inherits IContentProvider

The IParameterizedContentProvider type exposes the following members.

Properties
 | Name | Description
Public property | ParameterIndex | Gets or sets the index of the parameter for which to provide additional detail, if known.
Top
Methods
 | Name | Description
Public method | GetContent | Returns the content to use in various IntelliPrompt popups. (Inherited from IContentProvider.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterizedContentProvider Properties

IParameterizedContentProvider Properties

The IParameterizedContentProvider type exposes the following members.

Properties
 | Name | Description
Public property | ParameterIndex | Gets or sets the index of the parameter for which to provide additional detail, if known.
Top
See Also

Reference

IParameterizedContentProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterizedContentProvider.ParameterIndex Property

IParameterizedContentProviderParameterIndex Property
Gets or sets the index of the parameter for which to provide additional detail, if known.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<int> ParameterIndex { get; set; }
Property ParameterIndex As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The index of the parameter for which to provide additional detail, if known.
See Also

Reference

IParameterizedContentProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IParameterizedContentProvider Methods

IParameterizedContentProvider Methods

The IParameterizedContentProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetContent | Returns the content to use in various IntelliPrompt popups. (Inherited from IContentProvider.)
Top
See Also

Reference

IParameterizedContentProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IQuickInfoProvider Interface

IQuickInfoProvider Interface
Provides the base requirements for an object that can handle requests for display of an IntelliPrompt quick info popup.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IQuickInfoProvider : IEditorViewMouseInputEventSink,
    IOrderable, IKeyedObject
Public Interface IQuickInfoProvider
    Inherits IEditorViewMouseInputEventSink, IOrderable, IKeyedObject

The IQuickInfoProvider type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from IOrderable.)
Top
Methods
 | Name | Description
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any.
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any.
Public method | NotifyMouseDown | Occurs when a mouse button is pressed over the specified IEditorView. (Inherited from IEditorViewMouseInputEventSink.)
Public method | NotifyMouseEnter | Occurs when the mouse enters the specified IEditorView. (Inherited from IEditorViewMouseInputEventSink.)
Public method | NotifyMouseHover | Occurs when the mouse hovers over the specified IEditorView. (Inherited from IEditorViewMouseInputEventSink.)
Public method | NotifyMouseLeave | Occurs when the mouse leaves the specified IEditorView. (Inherited from IEditorViewMouseInputEventSink.)
Public method | NotifyMouseMove | Occurs when the mouse moves within the specified IEditorView. (Inherited from IEditorViewMouseInputEventSink.)
Public method | NotifyMouseUp | Occurs when a mouse button is released over the specified IEditorView. (Inherited from IEditorViewMouseInputEventSink.)
Public method | NotifyMouseWheel | Occurs when the mouse wheel is turned over the specified IEditorView. (Inherited from IEditorViewMouseInputEventSink.)
Public method | RequestSession | Requests that an IQuickInfoSession be opened for the specified IEditorView.
Top
Remarks
Objects implementing this provider interface can be registered as a service with an ISyntaxLanguage using the RegisterService(Object, Object) method. Any object implementing this interface will be called as needed by the language in priority order (based on IOrderable settings).
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IQuickInfoProvider Properties

IQuickInfoProvider Properties

The IQuickInfoProvider type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from IOrderable.)
Top
See Also

Reference

IQuickInfoProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IQuickInfoProvider Methods

IQuickInfoProvider Methods

The IQuickInfoProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any.
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any.
Public method | NotifyMouseDown | Occurs when a mouse button is pressed over the specified IEditorView. (Inherited from IEditorViewMouseInputEventSink.)
Public method | NotifyMouseEnter | Occurs when the mouse enters the specified IEditorView. (Inherited from IEditorViewMouseInputEventSink.)
Public method | NotifyMouseHover | Occurs when the mouse hovers over the specified IEditorView. (Inherited from IEditorViewMouseInputEventSink.)
Public method | NotifyMouseLeave | Occurs when the mouse leaves the specified IEditorView. (Inherited from IEditorViewMouseInputEventSink.)
Public method | NotifyMouseMove | Occurs when the mouse moves within the specified IEditorView. (Inherited from IEditorViewMouseInputEventSink.)
Public method | NotifyMouseUp | Occurs when a mouse button is released over the specified IEditorView. (Inherited from IEditorViewMouseInputEventSink.)
Public method | NotifyMouseWheel | Occurs when the mouse wheel is turned over the specified IEditorView. (Inherited from IEditorViewMouseInputEventSink.)
Public method | RequestSession | Requests that an IQuickInfoSession be opened for the specified IEditorView.
Top
See Also

Reference

IQuickInfoProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IQuickInfoProvider.GetContext Method

IQuickInfoProviderGetContext Method
Overload List
 | Name | Description
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any.
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any.
Top
See Also

Reference

IQuickInfoProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IQuickInfoProvider.GetContext Method (IHitTestResult)

IQuickInfoProviderGetContext Method (IHitTestResult)
Returns an object describing the quick info context for the specified IHitTestResult, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object GetContext(
    IHitTestResult hitTestResult
)
Function GetContext (
    hitTestResult As IHitTestResult
) As Object

Parameters

hitTestResult
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIHitTestResult
The IHitTestResult to examine.

Return Value

Type: Object
An object describing the quick info context for the specified IHitTestResult, if any. A value indicates that no context is available.
Remarks
This method is called in response to mouse events.
See Also

Reference

IQuickInfoProvider Interface
GetContext Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IQuickInfoProvider.GetContext Method (IEditorView, Int32)

IQuickInfoProviderGetContext Method (IEditorView, Int32)
Returns an object describing the quick info context for the specified text offset, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object GetContext(
    IEditorView view,
    int offset
)
Function GetContext (
    view As IEditorView,
    offset As Integer
) As Object

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which the offset is located.
offset
Type: SystemInt32
The text offset to examine.

Return Value

Type: Object
An object describing the quick info context for the specified text offset, if any. A value indicates that no context is available.
Remarks
This method is called in response to keyboard events.
See Also

Reference

IQuickInfoProvider Interface
GetContext Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IQuickInfoProvider.RequestSession Method

IQuickInfoProviderRequestSession Method
Requests that an IQuickInfoSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool RequestSession(
    IEditorView view,
    Object context,
    bool canTrackMouse
)
Function RequestSession (
    view As IEditorView,
    context As Object,
    canTrackMouse As Boolean
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.
context
Type: SystemObject
A context object returned by GetContext(IHitTestResult).
canTrackMouse
Type: SystemBoolean
Whether to track mouse input and allow mouse movement/hovers to possibly open another quick info session.

Return Value

Type: Boolean
true if a session was opened; otherwise, false.
See Also

Reference

IQuickInfoProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IQuickInfoSession Interface

IQuickInfoSession Interface
Provides the base requirements for an object that represents an IntelliPrompt quick info session.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IQuickInfoSession : IIntelliPromptSession,
    IServiceLocator
Public Interface IQuickInfoSession
    Inherits IIntelliPromptSession, IServiceLocator

The IQuickInfoSession type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the view-relative bounds of the session's open popup, if available. (Inherited from IIntelliPromptSession.)
Public property | ClosesOnLostFocus | Returns whether this session auto-closes when the editor or any IntelliPrompt popups lose focus. (Inherited from IIntelliPromptSession.)
Public property | Content | Gets the content to display in the quick info popup.
Public property | Context | Gets an object that describes the context in which the quick info popup is displayed.
Public property | ControlKeyDownOpacity | Gets the opacity of the popup while the control key is pressed.
Public property | IsOpen | Gets whether the session is currently open. (Inherited from IIntelliPromptSession.)
Public property | MaxWidth | Gets the quick info popup's maximum width.
Public property | SessionType | Gets the IIntelliPromptSessionType that identifies the type of session. (Inherited from IIntelliPromptSession.)
Public property | SnapshotRange | Gets the TextSnapshotRange containing the original TextRange in the ITextSnapshot that triggered the session. (Inherited from IIntelliPromptSession.)
Public property | View | Gets the IEditorView in which the session is opened. (Inherited from IIntelliPromptSession.)
Top
Methods
 | Name | Description
Public method | Close | Closes the session. (Inherited from IIntelliPromptSession.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from IServiceLocator.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | Open(IEditorView, TextRange) | Opens the session, attaching to the specified IEditorView. (Inherited from IIntelliPromptSession.)
Public method | Open(IEditorView, PlacementMode, UIElement, Rect) | Opens the session around a placement target, attaching to the specified IEditorView.
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | Reposition | Notifies the session that it should reposition its user interface. (Inherited from IIntelliPromptSession.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the session is closed, with the Cancel flag on the event arguments indicating whether the close was due to a cancellation. (Inherited from IIntelliPromptSession.)
Public event | Opened | Occurs when the session is opened. (Inherited from IIntelliPromptSession.)
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from IServiceLocator.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from IServiceLocator.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IQuickInfoSession Properties

IQuickInfoSession Properties

The IQuickInfoSession type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the view-relative bounds of the session's open popup, if available. (Inherited from IIntelliPromptSession.)
Public property | ClosesOnLostFocus | Returns whether this session auto-closes when the editor or any IntelliPrompt popups lose focus. (Inherited from IIntelliPromptSession.)
Public property | Content | Gets the content to display in the quick info popup.
Public property | Context | Gets an object that describes the context in which the quick info popup is displayed.
Public property | ControlKeyDownOpacity | Gets the opacity of the popup while the control key is pressed.
Public property | IsOpen | Gets whether the session is currently open. (Inherited from IIntelliPromptSession.)
Public property | MaxWidth | Gets the quick info popup's maximum width.
Public property | SessionType | Gets the IIntelliPromptSessionType that identifies the type of session. (Inherited from IIntelliPromptSession.)
Public property | SnapshotRange | Gets the TextSnapshotRange containing the original TextRange in the ITextSnapshot that triggered the session. (Inherited from IIntelliPromptSession.)
Public property | View | Gets the IEditorView in which the session is opened. (Inherited from IIntelliPromptSession.)
Top
See Also

Reference

IQuickInfoSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IQuickInfoSession.Content Property

IQuickInfoSessionContent Property
Gets the content to display in the quick info popup.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Content { get; }
ReadOnly Property Content As Object
    Get

Property Value

Type: Object
The content to display in the quick info popup.
See Also

Reference

IQuickInfoSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IQuickInfoSession.Context Property

IQuickInfoSessionContext Property
Gets an object that describes the context in which the quick info popup is displayed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Context { get; }
ReadOnly Property Context As Object
    Get

Property Value

Type: Object
An object that describes the context in which the quick info popup is displayed.
See Also

Reference

IQuickInfoSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IQuickInfoSession.ControlKeyDownOpacity Property

IQuickInfoSessionControlKeyDownOpacity Property
Gets the opacity of the popup while the control key is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
double ControlKeyDownOpacity { get; }
ReadOnly Property ControlKeyDownOpacity As Double
    Get

Property Value

Type: Double
The opacity of the popup while the control key is pressed.
Remarks
Set the value to 1.0 to prevent opacity changes when the control key is pressed.
See Also

Reference

IQuickInfoSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IQuickInfoSession.MaxWidth Property

IQuickInfoSessionMaxWidth Property
Gets the quick info popup's maximum width.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
double MaxWidth { get; }
ReadOnly Property MaxWidth As Double
    Get

Property Value

Type: Double
The quick info popup's maximum width, or NaN to indicate no constraint.
See Also

Reference

IQuickInfoSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IQuickInfoSession Methods

IQuickInfoSession Methods

The IQuickInfoSession type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the session. (Inherited from IIntelliPromptSession.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from IServiceLocator.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | Open(IEditorView, TextRange) | Opens the session, attaching to the specified IEditorView. (Inherited from IIntelliPromptSession.)
Public method | Open(IEditorView, PlacementMode, UIElement, Rect) | Opens the session around a placement target, attaching to the specified IEditorView.
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | Reposition | Notifies the session that it should reposition its user interface. (Inherited from IIntelliPromptSession.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Top
See Also

Reference

IQuickInfoSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IQuickInfoSession.Open Method

IQuickInfoSessionOpen Method
Overload List
 | Name | Description
Public method | Open(IEditorView, TextRange) | Opens the session, attaching to the specified IEditorView. (Inherited from IIntelliPromptSession.)
Public method | Open(IEditorView, PlacementMode, UIElement, Rect) | Opens the session around a placement target, attaching to the specified IEditorView.
Top
See Also

Reference

IQuickInfoSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IQuickInfoSession.Open Method (IEditorView, PlacementMode, UIElement, Rect)

IQuickInfoSessionOpen Method (IEditorView, PlacementMode, UIElement, Rect)
Opens the session around a placement target, attaching to the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Open(
    IEditorView view,
    PlacementMode placement,
    UIElement placementTarget,
    Rect placementRectangle
)
Sub Open (
    view As IEditorView,
    placement As PlacementMode,
    placementTarget As UIElement,
    placementRectangle As Rect
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which the session is opened.
placement
Type: Windows.UI.Xaml.Controls.PrimitivesPlacementMode
A PlacementMode indicating the mode by which to display the quick info.
placementTarget
Type: Windows.UI.XamlUIElement
The target UIElement for placing the quick info.
placementRectangle
Type: Windows.FoundationRect
The target-relative Rect around which to display the quick info.
See Also

Reference

IQuickInfoSession Interface
Open Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


IQuickInfoSession Events

IQuickInfoSession Events

The IQuickInfoSession type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the session is closed, with the Cancel flag on the event arguments indicating whether the close was due to a cancellation. (Inherited from IIntelliPromptSession.)
Public event | Opened | Occurs when the session is opened. (Inherited from IIntelliPromptSession.)
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from IServiceLocator.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from IServiceLocator.)
Top
See Also

Reference

IQuickInfoSession Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ISignatureItem Interface

ISignatureItem Interface
Provides the base requirements for a signature item, used with IntelliPrompt parameter info.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ISignatureItem
Public Interface ISignatureItem

The ISignatureItem type exposes the following members.

Properties
 | Name | Description
Public property | ContentProvider | Gets the IContentProvider to use when generating content for the signature.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationSignatureItem


ISignatureItem Properties

ISignatureItem Properties

The ISignatureItem type exposes the following members.

Properties
 | Name | Description
Public property | ContentProvider | Gets the IContentProvider to use when generating content for the signature.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
See Also

Reference

ISignatureItem Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ISignatureItem.ContentProvider Property

ISignatureItemContentProvider Property
Gets the IContentProvider to use when generating content for the signature.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IContentProvider ContentProvider { get; }
ReadOnly Property ContentProvider As IContentProvider
    Get

Property Value

Type: IContentProvider
The IContentProvider to use when generating content for the signature.
Remarks
Use an IParameterizedContentProvider if current parameter display is desired.
See Also

Reference

ISignatureItem Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ISignatureItem.Tag Property

ISignatureItemTag Property
Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Tag { get; set; }
Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

ISignatureItem Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ISignatureItemCollection Interface

ISignatureItemCollection Interface
Provides the base requirements for an object that represents a collection of ISignatureItem objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ISignatureItemCollection : IObservableCollection<ISignatureItem>,
    IList<ISignatureItem>, ICollection<ISignatureItem>, IEnumerable<ISignatureItem>,
    IEnumerable
Public Interface ISignatureItemCollection
    Inherits IObservableCollection(Of ISignatureItem), IList(Of ISignatureItem),
    ICollection(Of ISignatureItem), IEnumerable(Of ISignatureItem), IEnumerable

The ISignatureItemCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ISignatureItem .)
Public property | IsReadOnly | (Inherited from ICollection ISignatureItem .)
Public property | Item | (Inherited from IList ISignatureItem .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ISignatureItem .)
Public method | Clear | (Inherited from ICollection ISignatureItem .)
Public method | Contains | (Inherited from ICollection ISignatureItem .)
Public method | CopyTo | (Inherited from ICollection ISignatureItem .)
Public method | GetEnumerator | (Inherited from IEnumerable ISignatureItem .)
Public method | IndexOf | (Inherited from IList ISignatureItem .)
Public method | Insert | (Inherited from IList ISignatureItem .)
Public method | Remove | (Inherited from ICollection ISignatureItem .)
Public method | RemoveAt | (Inherited from IList ISignatureItem .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ISignatureItemCollection Properties

ISignatureItemCollection Properties

The ISignatureItemCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ISignatureItem .)
Public property | IsReadOnly | (Inherited from ICollection ISignatureItem .)
Public property | Item | (Inherited from IList ISignatureItem .)
Top
See Also

Reference

ISignatureItemCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ISignatureItemCollection Methods

ISignatureItemCollection Methods

The ISignatureItemCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ISignatureItem .)
Public method | Clear | (Inherited from ICollection ISignatureItem .)
Public method | Contains | (Inherited from ICollection ISignatureItem .)
Public method | CopyTo | (Inherited from ICollection ISignatureItem .)
Public method | GetEnumerator | (Inherited from IEnumerable ISignatureItem .)
Public method | IndexOf | (Inherited from IList ISignatureItem .)
Public method | Insert | (Inherited from IList ISignatureItem .)
Public method | Remove | (Inherited from ICollection ISignatureItem .)
Public method | RemoveAt | (Inherited from IList ISignatureItem .)
Top
See Also

Reference

ISignatureItemCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


ISignatureItemCollection Events

ISignatureItemCollection Events

The ISignatureItemCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ISignatureItemCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


NavigableRequestContexts Class

NavigableRequestContexts Class
Provides access to the built-in INavigableRequestContext instances, that indicate the context of a navigable request.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptNavigableRequestContexts

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class NavigableRequestContexts
Public NotInheritable Class NavigableRequestContexts

The NavigableRequestContexts type exposes the following members.

Properties
Name | Description
NavigableSymbolSelector | Gets the INavigableRequestContext for a navigable symbol selector control.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


NavigableRequestContexts Properties

NavigableRequestContexts Properties

The NavigableRequestContexts type exposes the following members.

Properties
Name | Description
NavigableSymbolSelector | Gets the INavigableRequestContext for a navigable symbol selector control.
Top
See Also

Reference

NavigableRequestContexts Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


NavigableRequestContexts.NavigableSymbolSelector Property

NavigableRequestContextsNavigableSymbolSelector Property
Gets the INavigableRequestContext for a navigable symbol selector control.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static INavigableRequestContext NavigableSymbolSelector { get; }
Public Shared ReadOnly Property NavigableSymbolSelector As INavigableRequestContext
    Get

Property Value

Type: INavigableRequestContext
The INavigableRequestContext for a navigable symbol selector control.
See Also

Reference

NavigableRequestContexts Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


QuickInfoProviderKeys Class

QuickInfoProviderKeys Class
Specifies the string keys of the built-in IQuickInfoProvider objects that are included with this product.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptQuickInfoProviderKeys

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class QuickInfoProviderKeys
Public NotInheritable Class QuickInfoProviderKeys

The QuickInfoProviderKeys type exposes the following members.

Fields
Name | Description
CodeSnippetField | The provider that displays quick info tips for code snippet fields.
CollapsedRegion | The provider that displays quick info tips for collapsed regions of text.
Indicator | The provider that displays quick info tips for indicator glyphs in the indicator margin.
SquiggleTag | The provider that displays quick info tips providing squiggle line descriptions.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


QuickInfoProviderKeys Fields

QuickInfoProviderKeys Fields

The QuickInfoProviderKeys type exposes the following members.

Fields
Name | Description
CodeSnippetField | The provider that displays quick info tips for code snippet fields.
CollapsedRegion | The provider that displays quick info tips for collapsed regions of text.
Indicator | The provider that displays quick info tips for indicator glyphs in the indicator margin.
SquiggleTag | The provider that displays quick info tips providing squiggle line descriptions.
Top
See Also

Reference

QuickInfoProviderKeys Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


QuickInfoProviderKeys.CodeSnippetField Field

QuickInfoProviderKeysCodeSnippetField Field
The provider that displays quick info tips for code snippet fields.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const string CodeSnippetField = "CodeSnippetField"
Public Const CodeSnippetField As String = "CodeSnippetField"

Field Value

Type: String
See Also

Reference

QuickInfoProviderKeys Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


QuickInfoProviderKeys.CollapsedRegion Field

QuickInfoProviderKeysCollapsedRegion Field
The provider that displays quick info tips for collapsed regions of text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const string CollapsedRegion = "CollapsedRegion"
Public Const CollapsedRegion As String = "CollapsedRegion"

Field Value

Type: String
See Also

Reference

QuickInfoProviderKeys Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


QuickInfoProviderKeys.Indicator Field

QuickInfoProviderKeysIndicator Field
The provider that displays quick info tips for indicator glyphs in the indicator margin.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const string Indicator = "Indicator"
Public Const Indicator As String = "Indicator"

Field Value

Type: String
See Also

Reference

QuickInfoProviderKeys Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace


QuickInfoProviderKeys.SquiggleTag Field

QuickInfoProviderKeysSquiggleTag Field
The provider that displays quick info tips providing squiggle line descriptions.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const string SquiggleTag = "SquiggleTag"
Public Const SquiggleTag As String = "SquiggleTag"

Field Value

Type: String
See Also

Reference

QuickInfoProviderKeys Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt Namespace