ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Assembly

Active Query Builder 2 .NET
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Assembly
Object Model
QueryBuilderControl ClassPlainTextSQLBuilder ClassQueryBuilder Class
Namespaces
Namespace | Description
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control | Active Query Builder main namespace.
Send Feedback


ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace
Inheritance Hierarchy
Active Query Builder main namespace.
Classes
 | Class | Description
Class | BaseControl | Base control for all web controls of Active Query Builder ASP.NET component.
Class | Canvas | Web control representing the Diagram Pane (also called as Design Area, Query Building Area).
Class | Grid | Web control representing the Query Columns Pane.
Class | ObjectTree | Web control representing the Database Schema Tree.
Class | QueryBuilderControl | Service web control of Active Query Builder ASP.NET component.
Class | SqlEditor | Web control representing the SQL query text editor.
Class | StatusBar | Web control representing the status bar that displays status messages and component's state.
See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Assembly


BaseControl Class

BaseControl Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : BaseControl Class
Base control for all web controls of Active Query Builder ASP.NET component.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public MustInherit Class BaseControl
   Inherits System.Web.UI.WebControls.WebControl
'Usage

Dim instance As BaseControl
public abstract class BaseControl : System.Web.UI.WebControls.WebControl
public __gc abstract class BaseControl : public System.Web.UI.WebControls.WebControl
Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.BaseControl
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.Canvas
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.Grid
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.ObjectTree
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.QueryBuilderControl
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.StatusBar

Requirements

See Also

Reference

BaseControl Members
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


BaseControl Class Members

BaseControl Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : BaseControl Class

The following tables list the members exposed by BaseControl.

Public Properties
 | Name | Description
Public Property | Direction | Gets or sets the direction in which to display the control.
Public Property | Version | Gets the version string.
Top
See Also

Reference

BaseControl Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


BaseControl Class Properties

BaseControl Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : BaseControl Class

For a list of all members of this type, see BaseControl members.

Public Properties
 | Name | Description
Public Property | Direction | Gets or sets the direction in which to display the control.
Public Property | Version | Gets the version string.
Top
See Also

Reference

BaseControl Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


Direction Property (BaseControl)

Direction Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : Direction Property
Gets or sets the direction in which to display the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Direction As System.Web.UI.WebControls.ContentDirection
'Usage

Dim instance As BaseControl
Dim value As System.Web.UI.WebControls.ContentDirection

instance.Direction = value

value = instance.Direction
public virtual System.Web.UI.WebControls.ContentDirection Direction {get; set;}
public: __property virtual System.Web.UI.WebControls.ContentDirection get_Direction();
public: __property virtual void set_Direction(
   System.Web.UI.WebControls.ContentDirection value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


Version Property

Version Property

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : Version Property
Gets the version string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Version As System.String
'Usage

Dim instance As BaseControl
Dim value As System.String

value = instance.Version
public System.string Version {get;}
public: __property System.string* get_Version();

Property Value

Version string in format "major.minor.build"
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


Canvas Class

Canvas Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : Canvas Class
Web control representing the Diagram Pane (also called as Design Area, Query Building Area).
Object Model
Canvas ClassFieldListOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class Canvas
   Inherits BaseControl
'Usage

Dim instance As Canvas
public class Canvas : BaseControl
public __gc class Canvas : public BaseControl
Remarks
This control allows to browse database objects of the query, to remove them, to select their fields to the Query Column List, to create links between database objects.
Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.BaseControl
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.Canvas

Requirements

See Also

Reference

Canvas Members
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


Canvas Class Members

Canvas Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : Canvas Class

The following tables list the members exposed by Canvas.

Public Properties
 | Name | Description
Public Property | AllowLinkManipulations | Instructs the component to allow or deny some types of manipulations with links between DataSource objects at the Design Pane by the user.
Public Property | DefaultDatasourceWidth | Gets or sets the default DataSource width.
Public Property | FieldListOptions | Determines field list options of DataSource objects within the Design Pane.
Public Property | MaxDefaultDatasourceHeight | Gets or sets the maximum height of the DataSource added to the Diagram Pane.
Top
See Also

Reference

Canvas Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


Canvas Class Properties

Canvas Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : Canvas Class

For a list of all members of this type, see Canvas members.

Public Properties
 | Name | Description
Public Property | AllowLinkManipulations | Instructs the component to allow or deny some types of manipulations with links between DataSource objects at the Design Pane by the user.
Public Property | DefaultDatasourceWidth | Gets or sets the default DataSource width.
Public Property | FieldListOptions | Determines field list options of DataSource objects within the Design Pane.
Public Property | MaxDefaultDatasourceHeight | Gets or sets the maximum height of the DataSource added to the Diagram Pane.
Top
See Also

Reference

Canvas Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


AllowLinkManipulations Property

AllowLinkManipulations Property

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : AllowLinkManipulations Property
Instructs the component to allow or deny some types of manipulations with links between DataSource objects at the Design Pane by the user.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AllowLinkManipulations As LinkManipulations
'Usage

Dim instance As Canvas
Dim value As LinkManipulations

instance.AllowLinkManipulations = value

value = instance.AllowLinkManipulations
public LinkManipulations AllowLinkManipulations {get; set;}
public: __property LinkManipulations get_AllowLinkManipulations();
public: __property void set_AllowLinkManipulations(
   LinkManipulations value
);

Property Value

Allow if all link manipulations are allowed,
Deny if all link manipulations are denied,
AllowJoinTypeChanging if changing of join type is allowed, the rest of manipulations are denied.

Remarks

Setting this property to Deny or AllowJoinTypeChanging denies manual creation and removal of links between objects as well as changing of join expression by the user.
Changing of join type (INNER, LEFT/RIGHT/FULL OUTER JOIN) is allowed if this property is set to Allow or AllowJoinTypeChanging.

Active Query Builder creates links between objects automatically according to the information about foreign keys retrieved from the database. Denial of manipulations with links is useful when you afraid of creating unacceptable joins by users who are not familiar with SQL principles.

Requirements

See Also

Reference

Canvas Class
Canvas Members


DefaultDatasourceWidth Property

DefaultDatasourceWidth Property

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : DefaultDatasourceWidth Property
Gets or sets the default DataSource width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DefaultDatasourceWidth As System.String
'Usage

Dim instance As Canvas
Dim value As System.String

instance.DefaultDatasourceWidth = value

value = instance.DefaultDatasourceWidth
public System.string DefaultDatasourceWidth {get; set;}
public: __property System.string* get_DefaultDatasourceWidth();
public: __property void set_DefaultDatasourceWidth(
   System.string* value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


FieldListOptions Property

FieldListOptions Property

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : FieldListOptions Property
Determines field list options of DataSource objects within the Design Pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property FieldListOptions As FieldListOptions
'Usage

Dim instance As Canvas
Dim value As FieldListOptions

instance.FieldListOptions = value

value = instance.FieldListOptions
public FieldListOptions FieldListOptions {get; set;}
public: __property FieldListOptions* get_FieldListOptions();
public: __property void set_FieldListOptions(
   FieldListOptions* value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


MaxDefaultDatasourceHeight Property

MaxDefaultDatasourceHeight Property

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : MaxDefaultDatasourceHeight Property
Gets or sets the maximum height of the DataSource added to the Diagram Pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property MaxDefaultDatasourceHeight As System.String
'Usage

Dim instance As Canvas
Dim value As System.String

instance.MaxDefaultDatasourceHeight = value

value = instance.MaxDefaultDatasourceHeight
public System.string MaxDefaultDatasourceHeight {get; set;}
public: __property System.string* get_MaxDefaultDatasourceHeight();
public: __property void set_MaxDefaultDatasourceHeight(
   System.string* value
);

Property Value

Zero means no constraint for maximum height.
Remarks
The height od a newly added datasource will fit the height of it's field list, but not higher than the MaxDefaultDatasourceHeight value.
Requirements

See Also

Reference

Canvas Class
Canvas Members


Grid Class

Grid Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : Grid Class
Web control representing the Query Columns Pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class Grid
   Inherits BaseControl
'Usage

Dim instance As Grid
public class Grid : BaseControl
public __gc class Grid : public BaseControl
Remarks
This control allows to deal with the Query Column List. This list determines output query columns (fields and expressions), defines their sort order, grouping and criteria.
Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.BaseControl
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.Grid

Requirements

See Also

Reference

Grid Members
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


Grid Class Members

Grid Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : Grid Class

The following tables list the members exposed by Grid.

See Also

Reference

Grid Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


ObjectTree Class

ObjectTree Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : ObjectTree Class
Web control representing the Database Schema Tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class ObjectTree
   Inherits BaseControl
'Usage

Dim instance As ObjectTree
public class ObjectTree : BaseControl
public __gc class ObjectTree : public BaseControl
Remarks
This control allows to browse database schema, to add database objects and their fields to the query by dragging them to the Diagram Pane or to the Query Columns Pane.
Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.BaseControl
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.ObjectTree

Requirements

See Also

Reference

ObjectTree Members
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


ObjectTree Class Members

ObjectTree Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : ObjectTree Class

The following tables list the members exposed by ObjectTree.

Public Properties
 | Name | Description
Public Property | GroupingType | Determines the grouping select lists visible to the user.
Public Property | ItemsPerPage | Determines the number of objects visible at the single page.
Public Property | PreloadedPagesCount | Determines the number of pages for which to load database objects initially.
Public Property | ShowAllItemInGroupingSelectLists | Instructs to show the "All" item in grouping select lists.
Public Property | ShowFields | Determines visibility of database object fields within the Database Schema Tree.
Public Property | SortingType | Determines the way database objects are sorted in the list.
Public Property | VisiblePaginationLinksCount | Determines the number of pagination links visible to the user at a time.
Top
See Also

Reference

ObjectTree Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


ObjectTree Class Properties

ObjectTree Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : ObjectTree Class

For a list of all members of this type, see ObjectTree members.

Public Properties
 | Name | Description
Public Property | GroupingType | Determines the grouping select lists visible to the user.
Public Property | ItemsPerPage | Determines the number of objects visible at the single page.
Public Property | PreloadedPagesCount | Determines the number of pages for which to load database objects initially.
Public Property | ShowAllItemInGroupingSelectLists | Instructs to show the "All" item in grouping select lists.
Public Property | ShowFields | Determines visibility of database object fields within the Database Schema Tree.
Public Property | SortingType | Determines the way database objects are sorted in the list.
Public Property | VisiblePaginationLinksCount | Determines the number of pagination links visible to the user at a time.
Top
See Also

Reference

ObjectTree Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


GroupingType Property

GroupingType Property

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : GroupingType Property
Determines the grouping select lists visible to the user.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property GroupingType As ActiveDatabaseSoftware.ActiveQueryBuilder.ObjectsGroupingType
'Usage

Dim instance As ObjectTree
Dim value As ActiveDatabaseSoftware.ActiveQueryBuilder.ObjectsGroupingType

instance.GroupingType = value

value = instance.GroupingType
public ActiveDatabaseSoftware.ActiveQueryBuilder.ObjectsGroupingType GroupingType {get; set;}
public: __property ActiveDatabaseSoftware.ActiveQueryBuilder.ObjectsGroupingType get_GroupingType();
public: __property void set_GroupingType(
   ActiveDatabaseSoftware.ActiveQueryBuilder.ObjectsGroupingType value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


ItemsPerPage Property

ItemsPerPage Property

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : ItemsPerPage Property
Determines the number of objects visible at the single page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ItemsPerPage As System.Integer
'Usage

Dim instance As ObjectTree
Dim value As System.Integer

instance.ItemsPerPage = value

value = instance.ItemsPerPage
public System.int ItemsPerPage {get; set;}
public: __property System.int get_ItemsPerPage();
public: __property void set_ItemsPerPage(
   System.int value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


PreloadedPagesCount Property

PreloadedPagesCount Property

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : PreloadedPagesCount Property
Determines the number of pages for which to load database objects initially.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property PreloadedPagesCount As System.Integer
'Usage

Dim instance As ObjectTree
Dim value As System.Integer

instance.PreloadedPagesCount = value

value = instance.PreloadedPagesCount
public System.int PreloadedPagesCount {get; set;}
public: __property System.int get_PreloadedPagesCount();
public: __property void set_PreloadedPagesCount(
   System.int value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


ShowAllItemInGroupingSelectLists Property

ShowAllItemInGroupingSelectLists Property

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : ShowAllItemInGroupingSelectLists Property
Instructs to show the "All" item in grouping select lists.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ShowAllItemInGroupingSelectLists As System.Boolean
'Usage

Dim instance As ObjectTree
Dim value As System.Boolean

instance.ShowAllItemInGroupingSelectLists = value

value = instance.ShowAllItemInGroupingSelectLists
public System.bool ShowAllItemInGroupingSelectLists {get; set;}
public: __property System.bool get_ShowAllItemInGroupingSelectLists();
public: __property void set_ShowAllItemInGroupingSelectLists(
   System.bool value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


ShowFields Property (ObjectTree)

ShowFields Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : ShowFields Property
Determines visibility of database object fields within the Database Schema Tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ShowFields As System.Boolean
'Usage

Dim instance As ObjectTree
Dim value As System.Boolean

instance.ShowFields = value

value = instance.ShowFields
public System.bool ShowFields {get; set;}
public: __property System.bool get_ShowFields();
public: __property void set_ShowFields(
   System.bool value
);

Property Value

true if fields are shown, false if not.
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


SortingType Property (ObjectTree)

SortingType Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : SortingType Property
Determines the way database objects are sorted in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SortingType As ObjectsSortingType
'Usage

Dim instance As ObjectTree
Dim value As ObjectsSortingType

instance.SortingType = value

value = instance.SortingType
public ObjectsSortingType SortingType {get; set;}
public: __property ObjectsSortingType get_SortingType();
public: __property void set_SortingType(
   ObjectsSortingType value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


VisiblePaginationLinksCount Property

VisiblePaginationLinksCount Property

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : VisiblePaginationLinksCount Property
Determines the number of pagination links visible to the user at a time.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property VisiblePaginationLinksCount As System.Integer
'Usage

Dim instance As ObjectTree
Dim value As System.Integer

instance.VisiblePaginationLinksCount = value

value = instance.VisiblePaginationLinksCount
public System.int VisiblePaginationLinksCount {get; set;}
public: __property System.int get_VisiblePaginationLinksCount();
public: __property void set_VisiblePaginationLinksCount(
   System.int value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


QueryBuilderControl Class

QueryBuilderControl Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : QueryBuilderControl Class
Service web control of Active Query Builder ASP.NET component.
Object Model
QueryBuilderControl ClassPlainTextSQLBuilder ClassQueryBuilder Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class QueryBuilderControl
   Inherits BaseControl
'Usage

Dim instance As QueryBuilderControl
public class QueryBuilderControl : BaseControl
public __gc class QueryBuilderControl : public BaseControl
Remarks
Service web control that holds generic properties of the component and refers to the server-side SQL parsing and SQL generation components.
Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.BaseControl
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.QueryBuilderControl

Requirements

See Also

Reference

QueryBuilderControl Members
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


QueryBuilderControl Class Members

QueryBuilderControl Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : QueryBuilderControl Class

The following tables list the members exposed by QueryBuilderControl.

Public Properties
 | Name | Description
Public Property | Language | Gets or sets the component's UI language by it's code.
Public Property | LayoutSQL | Gets or sets the XML string containing SQL query text with layout.
Public Property | MultipleQueriesPerSession | Gets or sets the MultipleQueriesPerSession mode.
Public Property | PlainTextSQLBuilder | Refers to the SQL query text generation server-side object.
Public Property | QueryBuilder | Refers to the SQL parsing and modification server-side object.
Public Property | SessonID | Gets the identifier of the current session.
Public Property | UseCustomLanguageFiles | Gets or sets a value indicating whether this object use custom language files.
Top
Public Events
 | Name | Description
Public Event | CustomizeDatasourceCaption | Is called to customize the caption of a DataSource at the Design Area.
Public Event | CustomizeDatasourceControlFieldList | Is called to customize the field list of a DataSource at the Design Area.
Public Event | CustomizeDatasourceFieldList | Is called to customize the field list of a DataSource at the Design Area.
Public Event | DatasourceAdded | Invoked when DataSource is added by the user.
Public Event | DatasourceFieldAdded | Invoked when Field is added to the query by checking it at the DataSource field list.
Public Event | DatasourceFieldRemoved | Invoked when Field is removed from the query by unchecking it at the DataSource field list.
Public Event | Init | Invoked when the component is initialized.
Public Event | LinkCreated | Invoked when the link between datasources is created by the user.
Public Event | QueryColumnListItemChanged | Invoked when one of the Query Columns Grid Control cells is changed by the user.
Public Event | SleepModeChanged | Invoked when the component is turns the "Sleep" mode on and off.
Public Event | SqlError | Invoked on SQL text parsing error.
Public Event | SQLUpdated | Occurs each time the component updates the output SQL query text.
Public Event | SyntaxProviderChanged | Fired when the QueryBuilder.SyntaxProvider property is changed.
Public Event | UserDataReceived | Occurs on each exchange when user data is received.
Top
See Also

Reference

QueryBuilderControl Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


QueryBuilderControl Class Properties

QueryBuilderControl Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : QueryBuilderControl Class

For a list of all members of this type, see QueryBuilderControl members.

Public Properties
 | Name | Description
Public Property | Language | Gets or sets the component's UI language by it's code.
Public Property | LayoutSQL | Gets or sets the XML string containing SQL query text with layout.
Public Property | MultipleQueriesPerSession | Gets or sets the MultipleQueriesPerSession mode.
Public Property | PlainTextSQLBuilder | Refers to the SQL query text generation server-side object.
Public Property | QueryBuilder | Refers to the SQL parsing and modification server-side object.
Public Property | SessonID | Gets the identifier of the current session.
Public Property | UseCustomLanguageFiles | Gets or sets a value indicating whether this object use custom language files.
Top
See Also

Reference

QueryBuilderControl Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


Language Property (QueryBuilderControl)

Language Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : Language Property
Gets or sets the component's UI language by it's code.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Language As System.String
'Usage

Dim instance As QueryBuilderControl
Dim value As System.String

instance.Language = value

value = instance.Language
public System.string Language {get; set;}
public: __property System.string* get_Language();
public: __property void set_Language(
   System.string* value
);
Remarks
The list of available languages can be taken from the Localizer.Languages field.
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


LayoutSQL Property (QueryBuilderControl)

LayoutSQL Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : LayoutSQL Property
Gets or sets the XML string containing SQL query text with layout.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property LayoutSQL As System.String
'Usage

Dim instance As QueryBuilderControl
Dim value As System.String

instance.LayoutSQL = value

value = instance.LayoutSQL
public System.string LayoutSQL {get; set;}
public: __property System.string* get_LayoutSQL();
public: __property void set_LayoutSQL(
   System.string* value
);

Property Value

The SQL query with layout XML string.
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


MultipleQueriesPerSession Property

MultipleQueriesPerSession Property

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : MultipleQueriesPerSession Property
Gets or sets the MultipleQueriesPerSession mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property MultipleQueriesPerSession As System.Boolean
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Boolean

instance.MultipleQueriesPerSession = value

value = instance.MultipleQueriesPerSession
public System.bool MultipleQueriesPerSession {get; set;}
public: __property System.bool get_MultipleQueriesPerSession();
public: __property void set_MultipleQueriesPerSession(
   System.bool value
);
Remarks
When the MultipleQueriesPerSession mode is on, the user is able to build different queries in separate browser windows; otherwise the user will see the same query in all browser windows.
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


PlainTextSQLBuilder Property

PlainTextSQLBuilder Property

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : PlainTextSQLBuilder Property
Refers to the SQL query text generation server-side object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property PlainTextSQLBuilder As PlainTextSQLBuilder
'Usage

Dim instance As QueryBuilderControl
Dim value As PlainTextSQLBuilder

value = instance.PlainTextSQLBuilder
public PlainTextSQLBuilder PlainTextSQLBuilder {get;}
public: __property PlainTextSQLBuilder* get_PlainTextSQLBuilder();

Property Value

The reference to the plain text sql builder object.
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members
PlainTextSQLBuilder class


QueryBuilder Property (QueryBuilderControl)

QueryBuilder Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : QueryBuilder Property
Refers to the SQL parsing and modification server-side object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property QueryBuilder As QueryBuilder
'Usage

Dim instance As QueryBuilderControl
Dim value As QueryBuilder

value = instance.QueryBuilder
public QueryBuilder QueryBuilder {get;}
public: __property QueryBuilder* get_QueryBuilder();

Property Value

The reference to the query builder object.
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members
QueryBuilder Сlass


SessonID Property

SessonID Property

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : SessonID Property
Gets the identifier of the current session.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property SessonID As System.String
'Usage

Dim instance As QueryBuilderControl
Dim value As System.String

value = instance.SessonID
public System.string SessonID {get;}
public: __property System.string* get_SessonID();
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


UseCustomLanguageFiles Property

UseCustomLanguageFiles Property

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : UseCustomLanguageFiles Property
Gets or sets a value indicating whether this object use custom language files.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property UseCustomLanguageFiles As System.Boolean
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Boolean

instance.UseCustomLanguageFiles = value

value = instance.UseCustomLanguageFiles
public System.bool UseCustomLanguageFiles {get; set;}
public: __property System.bool get_UseCustomLanguageFiles();
public: __property void set_UseCustomLanguageFiles(
   System.bool value
);

Property Value

true if use custom language files, false if not.
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


QueryBuilderControl Class Events

QueryBuilderControl Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : QueryBuilderControl Class

For a list of all members of this type, see QueryBuilderControl members.

Public Events
 | Name | Description
Public Event | CustomizeDatasourceCaption | Is called to customize the caption of a DataSource at the Design Area.
Public Event | CustomizeDatasourceControlFieldList | Is called to customize the field list of a DataSource at the Design Area.
Public Event | CustomizeDatasourceFieldList | Is called to customize the field list of a DataSource at the Design Area.
Public Event | DatasourceAdded | Invoked when DataSource is added by the user.
Public Event | DatasourceFieldAdded | Invoked when Field is added to the query by checking it at the DataSource field list.
Public Event | DatasourceFieldRemoved | Invoked when Field is removed from the query by unchecking it at the DataSource field list.
Public Event | Init | Invoked when the component is initialized.
Public Event | LinkCreated | Invoked when the link between datasources is created by the user.
Public Event | QueryColumnListItemChanged | Invoked when one of the Query Columns Grid Control cells is changed by the user.
Public Event | SleepModeChanged | Invoked when the component is turns the "Sleep" mode on and off.
Public Event | SqlError | Invoked on SQL text parsing error.
Public Event | SQLUpdated | Occurs each time the component updates the output SQL query text.
Public Event | SyntaxProviderChanged | Fired when the QueryBuilder.SyntaxProvider property is changed.
Public Event | UserDataReceived | Occurs on each exchange when user data is received.
Top
See Also

Reference

QueryBuilderControl Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


CustomizeDatasourceCaption Event (QueryBuilderControl)

CustomizeDatasourceCaption Event (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : CustomizeDatasourceCaption Event
Is called to customize the caption of a DataSource at the Design Area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event CustomizeDatasourceCaption As CustomizeDatasourceCaptionEventHandler
'Usage

Dim instance As QueryBuilderControl
Dim handler As CustomizeDatasourceCaptionEventHandler

AddHandler instance.CustomizeDatasourceCaption, handler
public event CustomizeDatasourceCaptionEventHandler CustomizeDatasourceCaption
public: __event CustomizeDatasourceCaptionEventHandler* CustomizeDatasourceCaption
Remarks
The datasource parameter refers to the DataSource being added to the Design Area.
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members
CustomizeDatasourceFieldList Event


CustomizeDatasourceControlFieldList Event

CustomizeDatasourceControlFieldList Event
Example

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : CustomizeDatasourceControlFieldList Event
Is called to customize the field list of a DataSource at the Design Area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event CustomizeDatasourceControlFieldList As CustomizeDatasourceFieldListEventHandler
'Usage

Dim instance As QueryBuilderControl
Dim handler As CustomizeDatasourceFieldListEventHandler

AddHandler instance.CustomizeDatasourceControlFieldList, handler
public event CustomizeDatasourceFieldListEventHandler CustomizeDatasourceControlFieldList
public: __event CustomizeDatasourceFieldListEventHandler* CustomizeDatasourceControlFieldList
Remarks

CustomizeDatasourceControlFieldList event allows to sort fields within the list or remove unwanted fields from the list.

This event differs from the CustomizeDatasourceFieldList Event in that it's fired more frequently, but only after the SQL parsing is complete, so you may examine the QueryBuilder.QueryStatistics collections and other internal query structure objects in this event's handler.

The field list to be customized is passed through the fieldList parameter.
The datasource parameter refers to the DataSource being added to the Design Area.

Example
This sample demonstrates usage of the QueryBuilder.QueryStatistics.UsedDatabaseObjectColumns collection to remove unused fields from the DataSource field lists at the Design Area.
  • C#
protected void QueryBuilderControl1_CustomizeDatasourceFieldList(QueryBuilder queryBuilder, DataSource datasource, MetadataFieldList fieldList)
{
    if (datasource.MetadataObject == null) return;
    for (int i = fieldList.Count - 1; i > 0; i--)
    {
        bool found = false;
        for (int j = 0; j < queryBuilder.QueryStatistics.UsedDatabaseObjectColumns.Count; j++)
            if (datasource.MetadataObject.NameStr == queryBuilder.QueryStatistics.UsedDatabaseObjectColumns[j].ObjectName.Token &&
                fieldList[i].NameStr == queryBuilder.QueryStatistics.UsedDatabaseObjectColumns[j].Name.QualifiedName)
            {
                found = true;
                break;
            }
        if (!found) fieldList.Delete(i);
    }
}
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


CustomizeDatasourceFieldList Event (QueryBuilderControl)

CustomizeDatasourceFieldList Event (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : CustomizeDatasourceFieldList Event
Is called to customize the field list of a DataSource at the Design Area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event CustomizeDatasourceFieldList As CustomizeDatasourceFieldListEventHandler
'Usage

Dim instance As QueryBuilderControl
Dim handler As CustomizeDatasourceFieldListEventHandler

AddHandler instance.CustomizeDatasourceFieldList, handler
public event CustomizeDatasourceFieldListEventHandler CustomizeDatasourceFieldList
public: __event CustomizeDatasourceFieldListEventHandler* CustomizeDatasourceFieldList
Remarks

CustomizeDatasourceFieldList event allows to sort fields within the list or remove unwanted fields from the list.

Note that it is not possible to examine the QueryBuilder.QueryStatistics collections in this event's handler. Use the CustomizeDatasourceControlFieldList Event instead.

The field list to be customized is passed through the fieldList parameter.
The datasource parameter refers to the DataSource being added to the Design Area.

Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members
CustomizeDatasourceCaption Event


DatasourceAdded Event (QueryBuilderControl)

DatasourceAdded Event (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : DatasourceAdded Event
Invoked when DataSource is added by the user.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DatasourceAdded As DatasourceAddedEventHandler
'Usage

Dim instance As QueryBuilderControl
Dim handler As DatasourceAddedEventHandler

AddHandler instance.DatasourceAdded, handler
public event DatasourceAddedEventHandler DatasourceAdded
public: __event DatasourceAddedEventHandler* DatasourceAdded
Remarks

DatasourceAdded event is fired when a new datasource (database object, derived table or CTE) is added to the query.

You may use this event to add fields to the query, to link this DataSource with the others, etc.

The addedObject parameter refers to the newly added DataSource object.

Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members
DatasourceFieldAdded Event


DatasourceFieldAdded Event (QueryBuilderControl)

DatasourceFieldAdded Event (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : DatasourceFieldAdded Event
Invoked when Field is added to the query by checking it at the DataSource field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DatasourceFieldAdded As DatasourceFieldAddedEventHandler
'Usage

Dim instance As QueryBuilderControl
Dim handler As DatasourceFieldAddedEventHandler

AddHandler instance.DatasourceFieldAdded, handler
public event DatasourceFieldAddedEventHandler DatasourceFieldAdded
public: __event DatasourceFieldAddedEventHandler* DatasourceFieldAdded
Remarks

DatasourceFieldAdded event is fired when a new field is added to the query columns list.

You may use this event to specify alias or some other query column properties.

The field and datasource parameters refer to the newly added DataSource field.

Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members
DatasourceAdded Event
QueryColumnListItemChanged Event


DatasourceFieldRemoved Event (QueryBuilderControl)

DatasourceFieldRemoved Event (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : DatasourceFieldRemoved Event
Invoked when Field is removed from the query by unchecking it at the DataSource field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DatasourceFieldRemoved As DatasourceFieldRemovedEventHandler
'Usage

Dim instance As QueryBuilderControl
Dim handler As DatasourceFieldRemovedEventHandler

AddHandler instance.DatasourceFieldRemoved, handler
public event DatasourceFieldRemovedEventHandler DatasourceFieldRemoved
public: __event DatasourceFieldRemovedEventHandler* DatasourceFieldRemoved
Remarks

DatasourceFieldRemoved event is fired after the field was removed from the query.

The field and datasource parameters refer to the removed DataSource field.

Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


Init Event (QueryBuilderControl)

Init Event (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : Init Event
Invoked when the component is initialized.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Shadows Event Init As System.EventHandler
'Usage

Dim instance As QueryBuilderControl
Dim handler As System.EventHandler

AddHandler instance.Init, handler
public new event System.EventHandler Init
public: new __event System.EventHandler* Init
Remarks

The Init event handler should define metadata and syntax providers for the query builder object (QueryBuilder).

Metadata provider is necessary when you're going to retrieve metadata from a database. The alternate way to load metadata is to use pre-generated XML file.

Syntax provider determines SQL syntax rules to build and parse queries.

Example
private void QueryBuilderControl1_OnInit(object sender, EventArgs e)
            {
                // Get instance of QueryBuilder
                QueryBuilder queryBuilder = QueryBuilderControl1.QueryBuilder;

                // create an instance of the proper syntax provider for your database server.
                // - use AutoSyntaxProvider if you want to detect your database server automatically
                //   (autodetection works in case of live database connection only)
                // - use ANSI or Universal syntax provider only if you can't find the right syntax
                //   provider for your database server.
                MSSQLSyntaxProvider syntaxProvider = new MSSQLSyntaxProvider();
                queryBuilder.SyntaxProvider = syntaxProvider;

                // =======================================================
                // load database schema using live database connection
                OleDbConnection connection = new OleDbConnection();
                connection.ConnectionString = "<your connection string>";

                OLEDBMetadataProvider metadataProvider = new OLEDBMetadataProvider();
                metadataProvider.Connection = connection;
                queryBuilder.MetadataProvider = metadataProvider;

                // call the RefreshMetadata to retrieve database schema information
                queryBuilder.RefreshMetadata();

                // =======================================================
                // OR load database schema from the pre-generated XML file
                XmlDocument doc = new XmlDocument();
                doc.Load(Server.MapPath("/your/path/to/XML_file"));
                queryBuilder.MetadataContainer.LoadFromXML(doc.OuterXml);
            }
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


LinkCreated Event (QueryBuilderControl)

LinkCreated Event (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : LinkCreated Event
Invoked when the link between datasources is created by the user.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event LinkCreated As LinkCreatedEventhandler
'Usage

Dim instance As QueryBuilderControl
Dim handler As LinkCreatedEventhandler

AddHandler instance.LinkCreated, handler
public event LinkCreatedEventhandler LinkCreated
public: __event LinkCreatedEventhandler* LinkCreated
Remarks

LinkCreated event is fired when a new link is created in the query. There you may set specific properties of the link (join type, expression, etc.)

The link parameter refers to the newly created Link object.

Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


QueryColumnListItemChanged Event

QueryColumnListItemChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : QueryColumnListItemChanged Event
Invoked when one of the Query Columns Grid Control cells is changed by the user.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event QueryColumnListItemChanged As QueryColumnListItemChangedHandler
'Usage

Dim instance As QueryBuilderControl
Dim handler As QueryColumnListItemChangedHandler

AddHandler instance.QueryColumnListItemChanged, handler
public event QueryColumnListItemChangedHandler QueryColumnListItemChanged
public: __event QueryColumnListItemChangedHandler* QueryColumnListItemChanged
Remarks

QueryColumnListItemChanged event is fired when the user performs some changes in the cells of the Query Column Grid Control, i.e. changes properties of some Query Column List Item (alias, grouping, sorting or criteria).

Occurs when the user has finished editing and result is applied to the cell.

The queryColumnList and queryColumnListItem parameters refer to the Query Column List object and it's Item. The column and row parameters address a cell in the Query Columns Grid. The oldValue and newValue parameters allows you to review the cell value before and after editing.

Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


SleepModeChanged Event (QueryBuilderControl)

SleepModeChanged Event (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : SleepModeChanged Event
Invoked when the component is turns the "Sleep" mode on and off.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event SleepModeChanged As System.EventHandler
'Usage

Dim instance As QueryBuilderControl
Dim handler As System.EventHandler

AddHandler instance.SleepModeChanged, handler
public event System.EventHandler SleepModeChanged
public: __event System.EventHandler* SleepModeChanged
Remarks

The "Sleep mode" allows to suppress parsing errors on unsupported SQL statements (CREATE TABLE, INSERT, UPDATE, DELETE, etc.).

Examine the SleepMode Property to learn if the component is currently in the sleep mode or not.

Use this event to show/hide or gray out the visual query builder when the user starts to write an unsupported statement by hand in the text editor.

Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


SqlError Event (QueryBuilderControl)

SqlError Event (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : SqlError Event
Invoked on SQL text parsing error.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event SqlError As SqlErrorEvenHandler
'Usage

Dim instance As QueryBuilderControl
Dim handler As SqlErrorEvenHandler

AddHandler instance.SqlError, handler
public event SqlErrorEvenHandler SqlError
public: __event SqlErrorEvenHandler* SqlError
Remarks

You may pass an SQL query text to the QueryBuilder.SQL property and have it parsed and represented visually in the control. If the component fails to parse a query, it raises an exception. Alternate way to catch SQL parsing errors is to use the SqlError event. Having the SQLError event handler defined, the component will not raise an exception in this case, but fire the event instead.

The sql parameter is the SQL query text that failed to parse. The error parameter is the error message string. The errorToken parameter is the erroneous token string. The errorTokenPos parameter addresses the erroneous token in the SQL query text.

            public struct Pos
            {
                public int pos;  // token position in the source text (starting at 0)
                public int col;  // token column (starting at 0)
                public int line; // token line (starting at 1)
            }

You may control the behavior of the component on parsing unknown types of SQL statements or on parsing queries with unknown objects using the QueryBuilder.BehaviorOptions properties: AllowSleepMode, ParsingErrorOnUnknownObjects.

Example
            private void queryBuilder1_SqlError(object sender, string sql, string error, string errorToken, Pos errorTokenPos)
            {
                MessageBox.Show(string.Format(
                    "Unexpected token \"{0}\" at line {1}, column {2}",
                    errorToken, errorTokenPos.line, errorTokenPos.col));
            }
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


SQLUpdated Event (QueryBuilderControl)

SQLUpdated Event (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : SQLUpdated Event
Occurs each time the component updates the output SQL query text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event SQLUpdated As System.EventHandler
'Usage

Dim instance As QueryBuilderControl
Dim handler As System.EventHandler

AddHandler instance.SQLUpdated, handler
public event System.EventHandler SQLUpdated
public: __event System.EventHandler* SQLUpdated
Remarks

SQLUpdated event is fired each time the SQL query text is updated, i.e. after successful parsing of the query or after any user's actions with the control that lead to changing of the query text.

Read the QueryBuilder.SQL property or the PlainTextSQLBuilder.SQL property to get updated SQL query text.
Use the QueryBuilder.QueryStatistics to get updated information about the query.

Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


SyntaxProviderChanged Event

SyntaxProviderChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : SyntaxProviderChanged Event
Fired when the QueryBuilder.SyntaxProvider property is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event SyntaxProviderChanged As System.EventHandler
'Usage

Dim instance As QueryBuilderControl
Dim handler As System.EventHandler

AddHandler instance.SyntaxProviderChanged, handler
public event System.EventHandler SyntaxProviderChanged
public: __event System.EventHandler* SyntaxProviderChanged
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


UserDataReceived Event

UserDataReceived Event

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : UserDataReceived Event
Occurs on each exchange when user data is received.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event UserDataReceived As SessionStoreItem.UserDataReceivedHandler
'Usage

Dim instance As QueryBuilderControl
Dim handler As SessionStoreItem.UserDataReceivedHandler

AddHandler instance.UserDataReceived, handler
public event SessionStoreItem.UserDataReceivedHandler UserDataReceived
public: __event SessionStoreItem.UserDataReceivedHandler* UserDataReceived
Remarks
Allow user controls of the QueryBuilderControl to register for handling an AJAX callback with custom user data.
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


SqlEditor Class

SqlEditor Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : SqlEditor Class
Web control representing the SQL query text editor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class SqlEditor
   Inherits BaseControlWithContent
'Usage

Dim instance As SqlEditor
public class SqlEditor : BaseControlWithContent
public __gc class SqlEditor : public BaseControlWithContent
Remarks
Allows to browse and modify SQL query text.
Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.BaseControl
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.SqlEditor

Requirements

See Also

Reference

SqlEditor Members
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


SqlEditor Class Members

SqlEditor Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : SqlEditor Class

The following tables list the members exposed by SqlEditor.

Public Properties
 | Name | Description
Public Property | ControlSQL | Gets the SQL Editor control text entered at the web page.
Public Property | SQL | Gets or sets the SQL query text string.
Top
See Also

Reference

SqlEditor Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


SqlEditor Class Properties

SqlEditor Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : SqlEditor Class

For a list of all members of this type, see SqlEditor members.

Public Properties
 | Name | Description
Public Property | ControlSQL | Gets the SQL Editor control text entered at the web page.
Public Property | SQL | Gets or sets the SQL query text string.
Top
See Also

Reference

SqlEditor Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


ControlSQL Property

ControlSQL Property

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : ControlSQL Property
Gets the SQL Editor control text entered at the web page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ControlSQL As System.String
'Usage

Dim instance As SqlEditor
Dim value As System.String

value = instance.ControlSQL
public System.string ControlSQL {get;}
public: __property System.string* get_ControlSQL();
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


SQL Property (SqlEditor)

SQL Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : SQL Property
Gets or sets the SQL query text string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SQL As System.String
'Usage

Dim instance As SqlEditor
Dim value As System.String

instance.SQL = value

value = instance.SQL
public System.string SQL {get; set;}
public: __property System.string* get_SQL();
public: __property void set_SQL(
   System.string* value
);
Remarks
Read this property to get the SQL query text entered by the user to the text editor. Note that this text may not be valid due to user's modifications. Use the QueryBuilder.SQL property to get valid SQL query text parsed by the server-side component.
Assign to this property to instantiate the component with the new query text.
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


StatusBar Class

StatusBar Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : StatusBar Class
Web control representing the status bar that displays status messages and component's state.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class StatusBar
   Inherits BaseControl
'Usage

Dim instance As StatusBar
public class StatusBar : BaseControl
public __gc class StatusBar : public BaseControl
Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.BaseControl
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.StatusBar

Requirements

See Also

Reference

StatusBar Members
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


StatusBar Class Members

StatusBar Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : StatusBar Class

The following tables list the members exposed by StatusBar.

Public Properties
 | Name | Description
Public Property | Message | Gets or sets the message string displayed in the status bar.
Top
See Also

Reference

StatusBar Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


StatusBar Class Properties

StatusBar Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : StatusBar Class

For a list of all members of this type, see StatusBar members.

Public Properties
 | Name | Description
Public Property | Message | Gets or sets the message string displayed in the status bar.
Top
See Also

Reference

StatusBar Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


Message Property (StatusBar)

Message Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : Message Property
Gets or sets the message string displayed in the status bar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Message As System.String
'Usage

Dim instance As StatusBar
Dim value As System.String

instance.Message = value

value = instance.Message
public System.string Message {get; set;}
public: __property System.string* get_Message();
public: __property void set_Message(
   System.string* value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server Assembly

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server Assembly
Namespaces
Namespace | Description
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models | Active Query Builder main namespace.


ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace
Inheritance Hierarchy
Active Query Builder main namespace.
Classes
 | Class | Description
Class | FieldListBaseColumnOptions | Base class for field list column options.
Class | FieldListDescriptionColumnOptions | Defines various options of the Description column in the field list.
Class | FieldListNameColumnOptions | Defines various options of the Name column in the field list.
Class | FieldListOptions | Determines field list options of DataSource objects within the Design Pane.
Class | FieldListTypeColumnOptions | Defines various options of the Data Type column in the field list.
Enumerations
 | Enumeration | Description
Enumeration | FieldListSortType | Defines various types of DataSource field list ordering.
Enumeration | LinkManipulations | Determines variants of acceptable user manipulations with links between DataSource objects at Design Pane.
See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server Assembly


FieldListBaseColumnOptions Class

FieldListBaseColumnOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace : FieldListBaseColumnOptions Class
Base class for field list column options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class FieldListBaseColumnOptions
'Usage

Dim instance As FieldListBaseColumnOptions
public class FieldListBaseColumnOptions
public __gc class FieldListBaseColumnOptions
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models.FieldListBaseColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models.FieldListDescriptionColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models.FieldListNameColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models.FieldListTypeColumnOptions

Requirements

See Also

Reference

FieldListBaseColumnOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace


FieldListBaseColumnOptions Class Members

FieldListBaseColumnOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace : FieldListBaseColumnOptions Class

The following tables list the members exposed by FieldListBaseColumnOptions.

Public Properties
 | Name | Description
Public Property | DrawOrder | Defines order in which the column is shown in the field list.
Public Property | Postfix | Adds postfix to the column text. Allows to add closing bracket or parenthesis.
Public Property | Prefix | Adds prefix to the column text. Allows to add opening bracket or parenthesis.
Public Property | Visible | Determines visibility of the column.
Top
See Also

Reference

FieldListBaseColumnOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace


FieldListBaseColumnOptions Class Properties

FieldListBaseColumnOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace : FieldListBaseColumnOptions Class

For a list of all members of this type, see FieldListBaseColumnOptions members.

Public Properties
 | Name | Description
Public Property | DrawOrder | Defines order in which the column is shown in the field list.
Public Property | Postfix | Adds postfix to the column text. Allows to add closing bracket or parenthesis.
Public Property | Prefix | Adds prefix to the column text. Allows to add opening bracket or parenthesis.
Public Property | Visible | Determines visibility of the column.
Top
See Also

Reference

FieldListBaseColumnOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace


DrawOrder Property (FieldListBaseColumnOptions)

DrawOrder Property (FieldListBaseColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace > FieldListBaseColumnOptions Class : DrawOrder Property
Defines order in which the column is shown in the field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DrawOrder As System.Integer
'Usage

Dim instance As FieldListBaseColumnOptions
Dim value As System.Integer

instance.DrawOrder = value

value = instance.DrawOrder
public System.int DrawOrder {get; set;}
public: __property System.int get_DrawOrder();
public: __property void set_DrawOrder(
   System.int value
);

Property Value

0 means the first column, positive values mean next columns in ascending order.
Requirements

See Also

Reference

FieldListBaseColumnOptions Class
FieldListBaseColumnOptions Members


Postfix Property (FieldListBaseColumnOptions)

Postfix Property (FieldListBaseColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace > FieldListBaseColumnOptions Class : Postfix Property
Adds postfix to the column text. Allows to add closing bracket or parenthesis.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Postfix As System.String
'Usage

Dim instance As FieldListBaseColumnOptions
Dim value As System.String

instance.Postfix = value

value = instance.Postfix
public System.string Postfix {get; set;}
public: __property System.string* get_Postfix();
public: __property void set_Postfix(
   System.string* value
);
Requirements

See Also

Reference

FieldListBaseColumnOptions Class
FieldListBaseColumnOptions Members


Prefix Property (FieldListBaseColumnOptions)

Prefix Property (FieldListBaseColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace > FieldListBaseColumnOptions Class : Prefix Property
Adds prefix to the column text. Allows to add opening bracket or parenthesis.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Prefix As System.String
'Usage

Dim instance As FieldListBaseColumnOptions
Dim value As System.String

instance.Prefix = value

value = instance.Prefix
public System.string Prefix {get; set;}
public: __property System.string* get_Prefix();
public: __property void set_Prefix(
   System.string* value
);
Requirements

See Also

Reference

FieldListBaseColumnOptions Class
FieldListBaseColumnOptions Members


Visible Property (FieldListBaseColumnOptions)

Visible Property (FieldListBaseColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace > FieldListBaseColumnOptions Class : Visible Property
Determines visibility of the column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Visible As System.Boolean
'Usage

Dim instance As FieldListBaseColumnOptions
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
public System.bool Visible {get; set;}
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
Requirements

See Also

Reference

FieldListBaseColumnOptions Class
FieldListBaseColumnOptions Members


FieldListDescriptionColumnOptions Class

FieldListDescriptionColumnOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace : FieldListDescriptionColumnOptions Class
Defines various options of the Description column in the field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class FieldListDescriptionColumnOptions
   Inherits FieldListBaseColumnOptions
'Usage

Dim instance As FieldListDescriptionColumnOptions
public class FieldListDescriptionColumnOptions : FieldListBaseColumnOptions
public __gc class FieldListDescriptionColumnOptions : public FieldListBaseColumnOptions
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models.FieldListBaseColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models.FieldListDescriptionColumnOptions

Requirements

See Also

Reference

FieldListDescriptionColumnOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace


FieldListDescriptionColumnOptions Class Members

FieldListDescriptionColumnOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace : FieldListDescriptionColumnOptions Class

The following tables list the members exposed by FieldListDescriptionColumnOptions.

Public Properties
 | Name | Description
Public Property | DrawOrder |
Public Property | UseLongDescription | Instructs to show Short or Long Description from the Metadata Container for a field.
Top
See Also

Reference

FieldListDescriptionColumnOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace


FieldListDescriptionColumnOptions Class Properties

FieldListDescriptionColumnOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace : FieldListDescriptionColumnOptions Class

For a list of all members of this type, see FieldListDescriptionColumnOptions members.

Public Properties
 | Name | Description
Public Property | DrawOrder |
Public Property | UseLongDescription | Instructs to show Short or Long Description from the Metadata Container for a field.
Top
See Also

Reference

FieldListDescriptionColumnOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace


DrawOrder Property (FieldListDescriptionColumnOptions)

DrawOrder Property (FieldListDescriptionColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace > FieldListDescriptionColumnOptions Class : DrawOrder Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Shadows Property DrawOrder As System.Integer
'Usage

Dim instance As FieldListDescriptionColumnOptions
Dim value As System.Integer

instance.DrawOrder = value

value = instance.DrawOrder
public new System.int DrawOrder {get; set;}
public: __property new System.int get_DrawOrder();
public: __property new void set_DrawOrder(
   System.int value
);
Requirements

See Also

Reference

FieldListDescriptionColumnOptions Class
FieldListDescriptionColumnOptions Members


UseLongDescription Property

UseLongDescription Property

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace > FieldListDescriptionColumnOptions Class : UseLongDescription Property
Instructs to show Short or Long Description from the Metadata Container for a field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property UseLongDescription As System.Boolean
'Usage

Dim instance As FieldListDescriptionColumnOptions
Dim value As System.Boolean

instance.UseLongDescription = value

value = instance.UseLongDescription
public System.bool UseLongDescription {get; set;}
public: __property System.bool get_UseLongDescription();
public: __property void set_UseLongDescription(
   System.bool value
);

Property Value

true means getting this column value from the LongDescription, false - from the ShortDescription.
Requirements

See Also

Reference

FieldListDescriptionColumnOptions Class
FieldListDescriptionColumnOptions Members


FieldListNameColumnOptions Class

FieldListNameColumnOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace : FieldListNameColumnOptions Class
Defines various options of the Name column in the field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class FieldListNameColumnOptions
   Inherits FieldListBaseColumnOptions
'Usage

Dim instance As FieldListNameColumnOptions
public class FieldListNameColumnOptions : FieldListBaseColumnOptions
public __gc class FieldListNameColumnOptions : public FieldListBaseColumnOptions
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models.FieldListBaseColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models.FieldListNameColumnOptions

Requirements

See Also

Reference

FieldListNameColumnOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace


FieldListNameColumnOptions Class Members

FieldListNameColumnOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace : FieldListNameColumnOptions Class

The following tables list the members exposed by FieldListNameColumnOptions.

Public Properties
 | Name | Description
Public Property | DrawOrder |
Top
See Also

Reference

FieldListNameColumnOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace


FieldListNameColumnOptions Class Properties

FieldListNameColumnOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace : FieldListNameColumnOptions Class

For a list of all members of this type, see FieldListNameColumnOptions members.

Public Properties
 | Name | Description
Public Property | DrawOrder |
Top
See Also

Reference

FieldListNameColumnOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace


DrawOrder Property (FieldListNameColumnOptions)

DrawOrder Property (FieldListNameColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace > FieldListNameColumnOptions Class : DrawOrder Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Shadows Property DrawOrder As System.Integer
'Usage

Dim instance As FieldListNameColumnOptions
Dim value As System.Integer

instance.DrawOrder = value

value = instance.DrawOrder
public new System.int DrawOrder {get; set;}
public: __property new System.int get_DrawOrder();
public: __property new void set_DrawOrder(
   System.int value
);
Requirements

See Also

Reference

FieldListNameColumnOptions Class
FieldListNameColumnOptions Members


FieldListOptions Class

FieldListOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace : FieldListOptions Class
Determines field list options of DataSource objects within the Design Pane.
Object Model
FieldListOptions ClassFieldListDescriptionColumnOptions ClassFieldListBaseColumnOptions ClassFieldListNameColumnOptions ClassFieldListTypeColumnOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class FieldListOptions
'Usage

Dim instance As FieldListOptions
public class FieldListOptions
public __gc class FieldListOptions
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models.FieldListOptions

Requirements

See Also

Reference

FieldListOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace


FieldListOptions Class Members

FieldListOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace : FieldListOptions Class

The following tables list the members exposed by FieldListOptions.

Public Properties
 | Name | Description
Public Property | DescriptionColumnOptions | Determines various options for the Description column.
Public Property | FixedColumnMode | Instructs to display field list column values tabbed at fixed positions or as plain text.
Public Property | HideAsteriskItem | Instructs to show/hide the asterisk item (*) as a first item in the field list.
Public Property | KeyFieldsFirst | Instructs to show primary key fields first in the list regardless of the sort order.
Public Property | MarkColumnOptions | Determines various options for the Mark (check box) column.
Public Property | NameColumnOptions | Determines various options for the Field Name column.
Public Property | SortType | Defines field list sort order type.
Public Property | TypeColumnOptions | Determines various options for the Data Type column.
Top
See Also

Reference

FieldListOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace


FieldListOptions Class Properties

FieldListOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace : FieldListOptions Class

For a list of all members of this type, see FieldListOptions members.

Public Properties
 | Name | Description
Public Property | DescriptionColumnOptions | Determines various options for the Description column.
Public Property | FixedColumnMode | Instructs to display field list column values tabbed at fixed positions or as plain text.
Public Property | HideAsteriskItem | Instructs to show/hide the asterisk item (*) as a first item in the field list.
Public Property | KeyFieldsFirst | Instructs to show primary key fields first in the list regardless of the sort order.
Public Property | MarkColumnOptions | Determines various options for the Mark (check box) column.
Public Property | NameColumnOptions | Determines various options for the Field Name column.
Public Property | SortType | Defines field list sort order type.
Public Property | TypeColumnOptions | Determines various options for the Data Type column.
Top
See Also

Reference

FieldListOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace


DescriptionColumnOptions Property (FieldListOptions)

DescriptionColumnOptions Property (FieldListOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace > FieldListOptions Class : DescriptionColumnOptions Property
Determines various options for the Description column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DescriptionColumnOptions As FieldListDescriptionColumnOptions
'Usage

Dim instance As FieldListOptions
Dim value As FieldListDescriptionColumnOptions

instance.DescriptionColumnOptions = value

value = instance.DescriptionColumnOptions
public FieldListDescriptionColumnOptions DescriptionColumnOptions {get; set;}
public: __property FieldListDescriptionColumnOptions* get_DescriptionColumnOptions();
public: __property void set_DescriptionColumnOptions(
   FieldListDescriptionColumnOptions* value
);
Requirements

See Also

Reference

FieldListOptions Class
FieldListOptions Members


FixedColumnMode Property

FixedColumnMode Property

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace > FieldListOptions Class : FixedColumnMode Property
Instructs to display field list column values tabbed at fixed positions or as plain text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property FixedColumnMode As System.Boolean
'Usage

Dim instance As FieldListOptions
Dim value As System.Boolean

instance.FixedColumnMode = value

value = instance.FixedColumnMode
public System.bool FixedColumnMode {get; set;}
public: __property System.bool get_FixedColumnMode();
public: __property void set_FixedColumnMode(
   System.bool value
);

Property Value

true to display field list column values tabbed at fixed positions, false to display them as plain text.
Requirements

See Also

Reference

FieldListOptions Class
FieldListOptions Members


HideAsteriskItem Property (FieldListOptions)

HideAsteriskItem Property (FieldListOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace > FieldListOptions Class : HideAsteriskItem Property
Instructs to show/hide the asterisk item (*) as a first item in the field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property HideAsteriskItem As System.Boolean
'Usage

Dim instance As FieldListOptions
Dim value As System.Boolean

instance.HideAsteriskItem = value

value = instance.HideAsteriskItem
public System.bool HideAsteriskItem {get; set;}
public: __property System.bool get_HideAsteriskItem();
public: __property void set_HideAsteriskItem(
   System.bool value
);
Requirements

See Also

Reference

FieldListOptions Class
FieldListOptions Members


KeyFieldsFirst Property (FieldListOptions)

KeyFieldsFirst Property (FieldListOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace > FieldListOptions Class : KeyFieldsFirst Property
Instructs to show primary key fields first in the list regardless of the sort order.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property KeyFieldsFirst As System.Boolean
'Usage

Dim instance As FieldListOptions
Dim value As System.Boolean

instance.KeyFieldsFirst = value

value = instance.KeyFieldsFirst
public System.bool KeyFieldsFirst {get; set;}
public: __property System.bool get_KeyFieldsFirst();
public: __property void set_KeyFieldsFirst(
   System.bool value
);
Requirements

See Also

Reference

FieldListOptions Class
FieldListOptions Members


MarkColumnOptions Property (FieldListOptions)

MarkColumnOptions Property (FieldListOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace > FieldListOptions Class : MarkColumnOptions Property
Determines various options for the Mark (check box) column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property MarkColumnOptions As FieldListBaseColumnOptions
'Usage

Dim instance As FieldListOptions
Dim value As FieldListBaseColumnOptions

instance.MarkColumnOptions = value

value = instance.MarkColumnOptions
public FieldListBaseColumnOptions MarkColumnOptions {get; set;}
public: __property FieldListBaseColumnOptions* get_MarkColumnOptions();
public: __property void set_MarkColumnOptions(
   FieldListBaseColumnOptions* value
);
Requirements

See Also

Reference

FieldListOptions Class
FieldListOptions Members


NameColumnOptions Property (FieldListOptions)

NameColumnOptions Property (FieldListOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace > FieldListOptions Class : NameColumnOptions Property
Determines various options for the Field Name column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property NameColumnOptions As FieldListNameColumnOptions
'Usage

Dim instance As FieldListOptions
Dim value As FieldListNameColumnOptions

instance.NameColumnOptions = value

value = instance.NameColumnOptions
public FieldListNameColumnOptions NameColumnOptions {get; set;}
public: __property FieldListNameColumnOptions* get_NameColumnOptions();
public: __property void set_NameColumnOptions(
   FieldListNameColumnOptions* value
);
Requirements

See Also

Reference

FieldListOptions Class
FieldListOptions Members


SortType Property (FieldListOptions)

SortType Property (FieldListOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace > FieldListOptions Class : SortType Property
Defines field list sort order type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SortType As FieldListSortType
'Usage

Dim instance As FieldListOptions
Dim value As FieldListSortType

instance.SortType = value

value = instance.SortType
public FieldListSortType SortType {get; set;}
public: __property FieldListSortType get_SortType();
public: __property void set_SortType(
   FieldListSortType value
);
Requirements

See Also

Reference

FieldListOptions Class
FieldListOptions Members


TypeColumnOptions Property (FieldListOptions)

TypeColumnOptions Property (FieldListOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace > FieldListOptions Class : TypeColumnOptions Property
Determines various options for the Data Type column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property TypeColumnOptions As FieldListTypeColumnOptions
'Usage

Dim instance As FieldListOptions
Dim value As FieldListTypeColumnOptions

instance.TypeColumnOptions = value

value = instance.TypeColumnOptions
public FieldListTypeColumnOptions TypeColumnOptions {get; set;}
public: __property FieldListTypeColumnOptions* get_TypeColumnOptions();
public: __property void set_TypeColumnOptions(
   FieldListTypeColumnOptions* value
);
Requirements

See Also

Reference

FieldListOptions Class
FieldListOptions Members


FieldListTypeColumnOptions Class

FieldListTypeColumnOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace : FieldListTypeColumnOptions Class
Defines various options of the Data Type column in the field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class FieldListTypeColumnOptions
   Inherits FieldListBaseColumnOptions
'Usage

Dim instance As FieldListTypeColumnOptions
public class FieldListTypeColumnOptions : FieldListBaseColumnOptions
public __gc class FieldListTypeColumnOptions : public FieldListBaseColumnOptions
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models.FieldListBaseColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models.FieldListTypeColumnOptions

Requirements

See Also

Reference

FieldListTypeColumnOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace


FieldListTypeColumnOptions Class Members

FieldListTypeColumnOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace : FieldListTypeColumnOptions Class

The following tables list the members exposed by FieldListTypeColumnOptions.

Public Properties
 | Name | Description
Public Property | DrawOrder |
Top
See Also

Reference

FieldListTypeColumnOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace


FieldListTypeColumnOptions Class Properties

FieldListTypeColumnOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace : FieldListTypeColumnOptions Class

For a list of all members of this type, see FieldListTypeColumnOptions members.

Public Properties
 | Name | Description
Public Property | DrawOrder |
Top
See Also

Reference

FieldListTypeColumnOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace


DrawOrder Property (FieldListTypeColumnOptions)

DrawOrder Property (FieldListTypeColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace > FieldListTypeColumnOptions Class : DrawOrder Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Shadows Property DrawOrder As System.Integer
'Usage

Dim instance As FieldListTypeColumnOptions
Dim value As System.Integer

instance.DrawOrder = value

value = instance.DrawOrder
public new System.int DrawOrder {get; set;}
public: __property new System.int get_DrawOrder();
public: __property new void set_DrawOrder(
   System.int value
);
Requirements

See Also

Reference

FieldListTypeColumnOptions Class
FieldListTypeColumnOptions Members


FieldListSortType Enumeration

FieldListSortType Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace : FieldListSortType Enumeration
Defines various types of DataSource field list ordering.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum FieldListSortType
   Inherits System.Enum
'Usage

Dim instance As FieldListSortType
public enum FieldListSortType : System.Enum
__value public enum FieldListSortType : public System.Enum
Members
Member | Description
Description | Specifies field list sorting by Description.
Name | Specifies field list sorting by Field Name.
None | Denies field list sorting; fields are shown in the list as they were retrieved from a database.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models.FieldListSortType

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace


LinkManipulations Enumeration

LinkManipulations Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace : LinkManipulations Enumeration
Determines variants of acceptable user manipulations with links between DataSource objects at Design Pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum LinkManipulations
   Inherits System.Enum
'Usage

Dim instance As LinkManipulations
public enum LinkManipulations : System.Enum
__value public enum LinkManipulations : public System.Enum
Members
Member | Description
Allow | Instructs to allow all manipulations with links.
AllowJoinTypeChanging | Instructs to deny all manipulations with links except changing of join type.
Deny | Instructs to deny all manipulations with links.
Remarks
Shum, 05.03.2011.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models.LinkManipulations

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace


ActiveDatabaseSoftware.ActiveQueryBuilder2 Assembly

ActiveDatabaseSoftware.ActiveQueryBuilder2 Assembly
Object Model
QueryBuilder ClassAddObjectFormOptions ClassBehaviorOptions ClassDatabaseSchemaTreeOptions ClassDataSourceOptions ClassDesignPaneOptions ClassMetadataContainer ClassMetadataLoadingOptions ClassBaseMetadataProvider ClassMetadataStructure ClassMetadataStructureOptions ClassPanesConfigurationOptions ClassParameterList ClassParameter ClassQueryColumnListOptions ClassQueryStatistics ClassQueryStructureTreeOptions ClassBaseSQLContext ClassSQLGenerationOptions ClassBaseSyntaxProvider ClassVisualOptions Class
Namespaces
Namespace | Description
ActiveDatabaseSoftware.ActiveQueryBuilder | Active Query Builder main namespace.


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.ActiveQueryBuilder2)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.ActiveQueryBuilder2)
Inheritance Hierarchy
Active Query Builder main namespace.
Classes
 | Class | Description
Class | AddObjectFormOptions | Determines appearance of the Add Object Form.
Class | AstExtender | Abstract Syntax Tree node that extends the SQL syntax of the owner node with database server specific elements.
Class | AstNode | Abstract Syntax Tree node that can be extended with database server specific elements.
Class | AstNodeBase | Base class for any Abstract Syntax Tree node.
Class | AstToken | Abstract Syntax Tree node representing a single piece of text in the query.
Class | AstTokenIdentifier | Abstract Syntax Tree node representing an identifier.
Class | AutoSyntaxProvider | This syntax provider will try to detect database server automatically and will act as specific syntax provider for the detected database server.
Class | BaseMetadataProvider | Base class for all Metadata Provider components.
Class | BaseSQLBuilder | Base class for the PlainTextSQLBuilder and other SQL generation classes that might be implemented in the future.
Class | BaseSQLContext | Defines context for the query building, parsing and SQL generation purposes.
Class | BaseSyntaxProvider | Base class for all syntax providers.
Class | BehaviorOptions | Allows you to tune the way Active Query Builder parses and builds SQL queries.
Class | DatabaseSchemaTreeOptions | Contains various options of the Database Schema Tree.
Class | DataSourceOptions | Determines appearance of the objects within the Design Pane.
Class | DB2SyntaxProvider | Syntax provider for IBM DB2 database.
Class | DesignPaneOptions | Contains various properties of Design Pane.
Class | FieldListBaseColumnOptions | Base class for all columns in the datasource field list.
Class | FieldListDescriptionColumnOptions | Defines various options of the Description column in the field list.
Class | FieldListMarkColumnOptions | Defines various options of the Mark column in the field list.
Class | FieldListNameColumnOptions | Defines various options of the Name column in the field list.
Class | FieldListTypeColumnOptions | Defines various options of the Type column in the field list.
Class | FirebirdSyntaxProvider | Syntax provider for Firebird databases.
Class | GenericSyntaxProvider | This provider can be used with any database server. It implements most of the ANSI SQL/92 syntax standard definitions, but lacks most of server-specific SQL syntax extensions.
Class | InformixSyntaxProvider | Syntax provider for Informix database server.
Class | Localizer | Localizer is a static object that holds localization resources.
Class | MetadataAggregate |
Class | MetadataContainer | Stores the necessary metadata from database.
Class | MetadataField | Class to represent fields of database objects in the Metadata Container.
Class | MetadataFilter | Defines a set of rules to filter metadata.
Class | MetadataFilterItem | Defines single metadata filtration rule.
Class | MetadataForeignKey | Class to represent foreign key relationships in the Metadata Container.
Class | MetadataItem | Base class for all items of the Metadata Container. Represens a node in the Metadata Container tree.
Class | MetadataList | List of metadata items.
Class | MetadataLoadingOptions | Determines rules of loading metadata to the component's Metadata Container.
Class | MetadataNameList | List of field names for fields of a foreign key
Class | MetadataNamesFetcher | Helper object to get list of available namespaces in the database.
Class | MetadataNamespace | Class to represent namespace items in the Metadata Container: Server, Package, Database, Schema.
Class | MetadataObject | Class to represent database objects in the Metadata Container.
Class | MetadataParameter | Class to represent parameters of stored procedures and functions in the Metadata Container.
Class | MetadataSelection<T> | Selection of metadata items of specified types from the metadata list.
Class | MetadataSimpleFilter | Determines sets of masks for database object and schema names to be included to or excluded from loading to the Metadata Container.
Class | MetadataStructure | Complex object that determines the tree-like structure to group metadata objects within the Database Schema Tree. Root object of the structure.
Class | MetadataStructureItem | Represents a node in the metadata structure.
Class | MetadataStructureOptions | Contains various options that affect on displaying of the Metadata Structure.
Class | MSAccessSyntaxProvider | Syntax provider for MS Jet-compatible databases: MS Access, MS Excel, MS Project as well as DBF, CSV and text files.
Class | MSSQLAzureSyntaxProvider | The Syntax Provider for the Microsoft SQL Server Compact Edition dialect.
Class | MSSQLCESyntaxProvider | Syntax provider for Microsoft SQL Server Compact Edition.
Class | MSSQLSyntaxProvider | Syntax Provider for Microsoft SQL Server.
Class | MySQLSyntaxProvider | Syntax provider for MySQL.
Class | OracleSyntaxProvider | Syntax provider for Oracle Database.
Class | PanesConfigurationOptions | Allows you to configure layout of the main parts of the component: Design Pane, Query Columns Pane, Database Schema Tree and Query Structure Tree.
Class | Parameter | Describes single parameter that was found in the query.
Class | ParameterList | Lists parameters that were found in the query.
Class | PlainTextSQLBuilder | Intended for SQL query text generation in Plain Text format.
Class | PostgreSQLSyntaxProvider | Syntax provider for PostgreSQL.
Class | QueryBuilder | QueryBuilder is the component to build SQL queries visually, to parse, analyze and modify SQL queries programmatically.
Class | QueryColumnListOptions | Contains various properties of the Query Column List.
Class | QueryStatistics | Allows to retrieve various information about the query: list of used database objects and their fields, list of output query columns.
Class | QueryStructureTreeOptions | Contains various properties of the Query Structure Tree.
Class | SQL2003SyntaxProvider | Syntax provider for ANSI SQL/2003 standard.
Class | SQL89SyntaxProvider | Syntax provider for ANSI SQL/89 standard.
Class | SQL92SyntaxProvider | Syntax provider for ANSI SQL/92 standard.
Class | SQLBuilderConditionFormat | Defines SQL text formatting options of WHERE and HAVING parts of the query.
Class | SQLBuilderFromClauseFormat | Defines SQL text formatting options of FROM part of the query.
Class | SQLBuilderItemListFormat | Defines SQL text formatting options of item lists in the query, i.e. SELECT, ORDER BY and GROUP BY parts of the query.
Class | SQLBuilderSelectFormat | Defines SQL text formatting options of a single SELECT statement.
Class | SQLGenerationOptions | Determine SQL query text generation rules and display of SQL objects and expressions in the Query Builder.
Class | SQLQualifiedName | Class for representation of the SQL qualified name (can be name of database object or field in a query, etc.).
Class | SQLQualifiedNameList | List of SQL qualified names.
Class | StatisticsDatabaseObject | Describes a database object being used in the query.
Class | StatisticsDatabaseObjectList | Lists database objects used in the query (QueryStatistics.UsedDatabaseObjects).
Class | StatisticsField | Describes a database object field being used in the query.
Class | StatisticsFieldList | Lists database object fields used in the query (QueryStatistics.UsedDatabaseObjectFields).
Class | StatisticsOutputColumn | Describes a column in result set of the query.
Class | StatisticsOutputColumnList | Lists output (result set) columns of the query (QueryStatistics.OutputColumns).
Class | SybaseSyntaxProvider | Syntax provider for Sybase ASA/ASE.
Class | UserMessageEventArgs | Class to define parameters passed to the QueryBuilder.UserMessage event.
Class | VistaDBSyntaxProvider | Syntax provider for VistaDB embedded database engine.
Class | VisualOptions | Contains visual options that are not related to any pane.
Interfaces
 | Interface | Description
Interface | IPlusButton |
Enumerations
 | Enumeration | Description
Enumeration | AffectedColumns | Defines set of the Query Columns List columns to determine their behavior.
Enumeration | CollapseExpandButtonLocation | Defines various options for location of the Collapse/Expand button.
Enumeration | DB2NamingConventions | Determines possible database object naming conventions for DB2 databases.
Enumeration | DefaultImageListImageIndexes | Defines indexes of images in default metadata structure image list.
Enumeration | DesignPaneOverviewVisibility | Determines possible values for visibility of the Design Pane Overview.
Enumeration | FieldListSortType | Defines various types of datasource's field list sorting.
Enumeration | FieldTypeCase | Defines various types of case conversions.
Enumeration | FirebirdVersion | Firebird server versions enumeration.
Enumeration | GenericSyntaxServerType | Enumerates possible database server types to be used by the Generic Syntax Provider.
Enumeration | IdentCaseSensitivity | Determines various types of database server case sensitivity options.
Enumeration | IdentQuotation | Defines various options for quotation of identifiers by the SQL Builder.
Enumeration | InformixVersion | Informix Database Server versions enumeration.
Enumeration | KeywordFormat | Defines various options for keyword formatting in the generated SQL query text.
Enumeration | LinkManipulations | Defines list of permissible end-user manipulations with links during the query building process.
Enumeration | MetadataForeignKeyCardinality | Determines possible cardinality values for one side of relationship of the foreign key.
Enumeration | MetadataType | Type of MetadataItem object
Enumeration | MSAccessServerVersion | MS Jet versions enumeration
Enumeration | MSSQLServerVersion | Microsoft SQL Server versions enumeration.
Enumeration | ObjectPrefixSkipping | Defines various options for skipping the unnecessary database object prefixes in the generated SQL query text.
Enumeration | ObjectsSortingType | Defines various types of sorting database objects within the Database Schema Tree.
Enumeration | OracleServerVersion | Oracle Database server versions enumeration.
Enumeration | QueryPart | Determines the corresponding part of the query.
Enumeration | SkipKeywordMode | Defines various options for the component behavior in case of possibility of inserting an optional keyword.
Enumeration | SQLBuilderConditionFormatNL | Defines line breaking rules in conditions of the query.
Enumeration | SybaseServerVersion | Sybase Server types enumeration.
Enumeration | UserMessageId | Lists possible situations that require to warn the user.
See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder2 Assembly


AddObjectFormOptions Class

AddObjectFormOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AddObjectFormOptions Class
Determines appearance of the Add Object Form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class AddObjectFormOptions
   Inherits BatchUpdatableBase
'Usage

Dim instance As AddObjectFormOptions
public class AddObjectFormOptions : BatchUpdatableBase
public __gc class AddObjectFormOptions : public BatchUpdatableBase
Remarks
The Add Object Form allows you to add objects (database objects and CTE) to the query. You may call it using the ShowAddObjectForm Method. The user may open this form using Design Pane context menu. You may disable this form completely using the FormEnabled Property.
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.AddObjectFormOptions

Requirements

See Also

Reference

AddObjectFormOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
AddObjectFormOptions Property


AddObjectFormOptions Class Members

AddObjectFormOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AddObjectFormOptions Class

The following tables list the members exposed by AddObjectFormOptions.

Public Properties
 | Name | Description
Public Property | FormEnabled | Allows Add Object Form to be shown; also determines visibility of appropriate popup menu item.
Public Property | Height | Gets or sets the height of the Add Object Form.
Public Property | ImageListLarge | Gets or sets ImageList object to use when displaying objects as large icons in the form.
Public Property | ImageListSmall | Gets or sets ImageList object to use when displaying objects as small icons in the form.
Public Property | ListViewStyle | Specifies how objects are displayed in a ListView control on the form.
Public Property | MinimumSize | Specifies minimum size of the Add Object Form.
Public Property | Position | Gets or sets position of the upper-left corner of the Add Object Form on showing.
Public Property | SortingType | Defines order of displaying objects.
Public Property | Width | Gets or sets the width of the Add Object Form.
Top
See Also

Reference

AddObjectFormOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
AddObjectFormOptions Property


AddObjectFormOptions Class Properties

AddObjectFormOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AddObjectFormOptions Class

For a list of all members of this type, see AddObjectFormOptions members.

Public Properties
 | Name | Description
Public Property | FormEnabled | Allows Add Object Form to be shown; also determines visibility of appropriate popup menu item.
Public Property | Height | Gets or sets the height of the Add Object Form.
Public Property | ImageListLarge | Gets or sets ImageList object to use when displaying objects as large icons in the form.
Public Property | ImageListSmall | Gets or sets ImageList object to use when displaying objects as small icons in the form.
Public Property | ListViewStyle | Specifies how objects are displayed in a ListView control on the form.
Public Property | MinimumSize | Specifies minimum size of the Add Object Form.
Public Property | Position | Gets or sets position of the upper-left corner of the Add Object Form on showing.
Public Property | SortingType | Defines order of displaying objects.
Public Property | Width | Gets or sets the width of the Add Object Form.
Top
See Also

Reference

AddObjectFormOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
AddObjectFormOptions Property


FormEnabled Property

FormEnabled Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AddObjectFormOptions Class : FormEnabled Property
Allows Add Object Form to be shown; also determines visibility of appropriate popup menu item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property FormEnabled As System.Boolean
'Usage

Dim instance As AddObjectFormOptions
Dim value As System.Boolean

instance.FormEnabled = value

value = instance.FormEnabled
public System.bool FormEnabled {get; set;}
public: __property System.bool get_FormEnabled();
public: __property void set_FormEnabled(
   System.bool value
);
Requirements

See Also

Reference

AddObjectFormOptions Class
AddObjectFormOptions Members


Height Property (AddObjectFormOptions)

Height Property (AddObjectFormOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AddObjectFormOptions Class : Height Property
Gets or sets the height of the Add Object Form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Height As System.Integer
'Usage

Dim instance As AddObjectFormOptions
Dim value As System.Integer

instance.Height = value

value = instance.Height
public System.int Height {get; set;}
public: __property System.int get_Height();
public: __property void set_Height(
   System.int value
);
Requirements

See Also

Reference

AddObjectFormOptions Class
AddObjectFormOptions Members


ImageListLarge Property

ImageListLarge Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AddObjectFormOptions Class : ImageListLarge Property
Gets or sets ImageList object to use when displaying objects as large icons in the form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ImageListLarge As System.Windows.Forms.ImageList
'Usage

Dim instance As AddObjectFormOptions
Dim value As System.Windows.Forms.ImageList

instance.ImageListLarge = value

value = instance.ImageListLarge
public System.Windows.Forms.ImageList ImageListLarge {get; set;}
public: __property System.Windows.Forms.ImageList* get_ImageListLarge();
public: __property void set_ImageListLarge(
   System.Windows.Forms.ImageList* value
);
Requirements

See Also

Reference

AddObjectFormOptions Class
AddObjectFormOptions Members


ImageListSmall Property

ImageListSmall Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AddObjectFormOptions Class : ImageListSmall Property
Gets or sets ImageList object to use when displaying objects as small icons in the form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ImageListSmall As System.Windows.Forms.ImageList
'Usage

Dim instance As AddObjectFormOptions
Dim value As System.Windows.Forms.ImageList

instance.ImageListSmall = value

value = instance.ImageListSmall
public System.Windows.Forms.ImageList ImageListSmall {get; set;}
public: __property System.Windows.Forms.ImageList* get_ImageListSmall();
public: __property void set_ImageListSmall(
   System.Windows.Forms.ImageList* value
);
Requirements

See Also

Reference

AddObjectFormOptions Class
AddObjectFormOptions Members


ListViewStyle Property

ListViewStyle Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AddObjectFormOptions Class : ListViewStyle Property
Specifies how objects are displayed in a ListView control on the form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ListViewStyle As System.Windows.Forms.View
'Usage

Dim instance As AddObjectFormOptions
Dim value As System.Windows.Forms.View

instance.ListViewStyle = value

value = instance.ListViewStyle
public System.Windows.Forms.View ListViewStyle {get; set;}
public: __property System.Windows.Forms.View get_ListViewStyle();
public: __property void set_ListViewStyle(
   System.Windows.Forms.View value
);
Requirements

See Also

Reference

AddObjectFormOptions Class
AddObjectFormOptions Members


MinimumSize Property (AddObjectFormOptions)

MinimumSize Property (AddObjectFormOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AddObjectFormOptions Class : MinimumSize Property
Specifies minimum size of the Add Object Form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property MinimumSize As System.Drawing.Size
'Usage

Dim instance As AddObjectFormOptions
Dim value As System.Drawing.Size

instance.MinimumSize = value

value = instance.MinimumSize
public System.Drawing.Size MinimumSize {get; set;}
public: __property System.Drawing.Size get_MinimumSize();
public: __property void set_MinimumSize(
   System.Drawing.Size value
);
Requirements

See Also

Reference

AddObjectFormOptions Class
AddObjectFormOptions Members


Position Property

Position Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AddObjectFormOptions Class : Position Property
Gets or sets position of the upper-left corner of the Add Object Form on showing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Position As System.Windows.Forms.FormStartPosition
'Usage

Dim instance As AddObjectFormOptions
Dim value As System.Windows.Forms.FormStartPosition

instance.Position = value

value = instance.Position
public System.Windows.Forms.FormStartPosition Position {get; set;}
public: __property System.Windows.Forms.FormStartPosition get_Position();
public: __property void set_Position(
   System.Windows.Forms.FormStartPosition value
);
Requirements

See Also

Reference

AddObjectFormOptions Class
AddObjectFormOptions Members


SortingType Property (AddObjectFormOptions)

SortingType Property (AddObjectFormOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AddObjectFormOptions Class : SortingType Property
Defines order of displaying objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SortingType As ObjectsSortingType
'Usage

Dim instance As AddObjectFormOptions
Dim value As ObjectsSortingType

instance.SortingType = value

value = instance.SortingType
public ObjectsSortingType SortingType {get; set;}
public: __property ObjectsSortingType get_SortingType();
public: __property void set_SortingType(
   ObjectsSortingType value
);
Requirements

See Also

Reference

AddObjectFormOptions Class
AddObjectFormOptions Members


Width Property (AddObjectFormOptions)

Width Property (AddObjectFormOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AddObjectFormOptions Class : Width Property
Gets or sets the width of the Add Object Form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Width As System.Integer
'Usage

Dim instance As AddObjectFormOptions
Dim value As System.Integer

instance.Width = value

value = instance.Width
public System.int Width {get; set;}
public: __property System.int get_Width();
public: __property void set_Width(
   System.int value
);
Requirements

See Also

Reference

AddObjectFormOptions Class
AddObjectFormOptions Members


AstExtender Class

AstExtender Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AstExtender Class
Abstract Syntax Tree node that extends the SQL syntax of the owner node with database server specific elements.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class AstExtender
   Inherits AstNodeBase
'Usage

Dim instance As AstExtender
public class AstExtender : AstNodeBase
public __gc class AstExtender : public AstNodeBase
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.AstNodeBase
ActiveDatabaseSoftware.ActiveQueryBuilder.AstExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.AstNode

Requirements

See Also

Reference

AstExtender Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AstExtender Class Members

AstExtender Class Members
Properties Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AstExtender Class

The following tables list the members exposed by AstExtender.

See Also

Reference

AstExtender Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AstNode Class

AstNode Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AstNode Class
Abstract Syntax Tree node that can be extended with database server specific elements.
Object Model
AstNode ClassAstExtender Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class AstNode
   Inherits AstExtender
'Usage

Dim instance As AstNode
public class AstNode : AstExtender
public __gc class AstNode : public AstExtender
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.AstNodeBase
ActiveDatabaseSoftware.ActiveQueryBuilder.AstExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.AstNode
ActiveDatabaseSoftware.ActiveQueryBuilder.AstToken

Requirements

See Also

Reference

AstNode Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AstNode Class Members

AstNode Class Members
Properties Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AstNode Class

The following tables list the members exposed by AstNode.

Public Properties
 | Name | Description
Public Property | Extender | Abstract Syntax Tree object to extend the node with database server specific elements.
Top
Public Methods
 | Name | Description
Public Method | GetSQL |
Top
See Also

Reference

AstNode Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AstNode Class Methods

AstNode Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AstNode Class

For a list of all members of this type, see AstNode members.

Public Methods
 | Name | Description
Public Method | GetSQL |
Top
See Also

Reference

AstNode Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


GetSQL Method

GetSQL Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AstNode Class : GetSQL Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetSQL( _
   ByVal sqlBuilder As SQLBuilder _
) As System.String
'Usage

Dim instance As AstNode
Dim sqlBuilder As SQLBuilder
Dim value As System.String

value = instance.GetSQL(sqlBuilder)
public System.string GetSQL(
   SQLBuilder sqlBuilder
)
public: System.string* GetSQL(
   SQLBuilder* sqlBuilder
)

Parameters

sqlBuilder
Requirements

See Also

Reference

AstNode Class
AstNode Members


AstNode Class Properties

AstNode Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AstNode Class

For a list of all members of this type, see AstNode members.

Public Properties
 | Name | Description
Public Property | Extender | Abstract Syntax Tree object to extend the node with database server specific elements.
Top
See Also

Reference

AstNode Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Extender Property

Extender Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AstNode Class : Extender Property
Abstract Syntax Tree object to extend the node with database server specific elements.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Extender As AstExtender
'Usage

Dim instance As AstNode
Dim value As AstExtender

instance.Extender = value

value = instance.Extender
public AstExtender Extender {get; set;}
public: __property AstExtender* get_Extender();
public: __property void set_Extender(
   AstExtender* value
);
Requirements

See Also

Reference

AstNode Class
AstNode Members


AstNodeBase Class

AstNodeBase Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AstNodeBase Class
Base class for any Abstract Syntax Tree node.
Object Model
AstNodeBase ClassBaseSQLContext Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class AstNodeBase
'Usage

Dim instance As AstNodeBase
public class AstNodeBase
public __gc class AstNodeBase
Remarks
Introduces the SQL Context property that's required to build SQL text for node according to the syntax rules of specific Syntax Provider and the SQL Builder settings.
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.AstNodeBase
ActiveDatabaseSoftware.ActiveQueryBuilder.AstExtender

Requirements

See Also

Reference

AstNodeBase Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AstNodeBase Class Members

AstNodeBase Class Members
Properties Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AstNodeBase Class

The following tables list the members exposed by AstNodeBase.

Public Constructors
 | Name | Description
Public Constructor | AstNodeBase Constructor | Initializes a new instance of the AST node.
Top
Public Properties
 | Name | Description
Public Property | SQLContext | Gets SQL Context for the node.
Public Property | UsedDatabaseObjectFields |
Top
Public Methods
 | Name | Description
Public Method | RemoveReferencesToDatasource |
Public Method | ReplaceReferencesToDatasourceRecursive |
Top
See Also

Reference

AstNodeBase Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AstNodeBase Constructor

AstNodeBase Constructor

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AstNodeBase Class : AstNodeBase Constructor
Specifies SQL Context for the node.
Initializes a new instance of the AST node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function New( _
   ByVal sqlContext As BaseSQLContext _
)
'Usage

Dim sqlContext As BaseSQLContext

Dim instance As New AstNodeBase(sqlContext)
public AstNodeBase(
   BaseSQLContext sqlContext
)
public: AstNodeBase(
   BaseSQLContext* sqlContext
)

Parameters

sqlContext
Specifies SQL Context for the node.
Requirements

See Also

Reference

AstNodeBase Class
AstNodeBase Members


AstNodeBase Class Methods

AstNodeBase Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AstNodeBase Class

For a list of all members of this type, see AstNodeBase members.

Public Methods
 | Name | Description
Public Method | RemoveReferencesToDatasource |
Public Method | ReplaceReferencesToDatasourceRecursive |
Top
See Also

Reference

AstNodeBase Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


RemoveReferencesToDatasource Method

RemoveReferencesToDatasource Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AstNodeBase Class : RemoveReferencesToDatasource Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function RemoveReferencesToDatasource( _
   ByVal fs As SQLFromSource _
) As System.Boolean
'Usage

Dim instance As AstNodeBase
Dim fs As SQLFromSource
Dim value As System.Boolean

value = instance.RemoveReferencesToDatasource(fs)
public System.bool RemoveReferencesToDatasource(
   SQLFromSource fs
)
public: System.bool RemoveReferencesToDatasource(
   SQLFromSource* fs
)

Parameters

fs
Requirements

See Also

Reference

AstNodeBase Class
AstNodeBase Members


ReplaceReferencesToDatasourceRecursive Method

ReplaceReferencesToDatasourceRecursive Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AstNodeBase Class : ReplaceReferencesToDatasourceRecursive Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ReplaceReferencesToDatasourceRecursive( _
   ByVal fsFrom As SQLFromSource, _
   ByVal fsTo As SQLFromSource _
) As System.Boolean
'Usage

Dim instance As AstNodeBase
Dim fsFrom As SQLFromSource
Dim fsTo As SQLFromSource
Dim value As System.Boolean

value = instance.ReplaceReferencesToDatasourceRecursive(fsFrom, fsTo)
public System.bool ReplaceReferencesToDatasourceRecursive(
   SQLFromSource fsFrom,
   SQLFromSource fsTo
)
public: System.bool ReplaceReferencesToDatasourceRecursive(
   SQLFromSource* fsFrom,
   SQLFromSource* fsTo
)

Parameters

fsFrom
fsTo
Requirements

See Also

Reference

AstNodeBase Class
AstNodeBase Members


AstNodeBase Class Properties

AstNodeBase Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AstNodeBase Class

For a list of all members of this type, see AstNodeBase members.

Public Properties
 | Name | Description
Public Property | SQLContext | Gets SQL Context for the node.
Public Property | UsedDatabaseObjectFields |
Top
See Also

Reference

AstNodeBase Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQLContext Property (AstNodeBase)

SQLContext Property (AstNodeBase)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AstNodeBase Class : SQLContext Property
Gets SQL Context for the node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property SQLContext As BaseSQLContext
'Usage

Dim instance As AstNodeBase
Dim value As BaseSQLContext

value = instance.SQLContext
public BaseSQLContext SQLContext {get;}
public: __property BaseSQLContext* get_SQLContext();
Requirements

See Also

Reference

AstNodeBase Class
AstNodeBase Members


UsedDatabaseObjectFields Property (AstNodeBase)

UsedDatabaseObjectFields Property (AstNodeBase)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AstNodeBase Class : UsedDatabaseObjectFields Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property UsedDatabaseObjectFields As StatsFields
'Usage

Dim instance As AstNodeBase
Dim value As StatsFields

value = instance.UsedDatabaseObjectFields
public StatsFields UsedDatabaseObjectFields {get;}
public: __property StatsFields* get_UsedDatabaseObjectFields();
Requirements

See Also

Reference

AstNodeBase Class
AstNodeBase Members


AstToken Class

AstToken Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AstToken Class
Abstract Syntax Tree node representing a single piece of text in the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class AstToken
   Inherits AstNode
'Usage

Dim instance As AstToken
public class AstToken : AstNode
public __gc class AstToken : public AstNode
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.AstNodeBase
ActiveDatabaseSoftware.ActiveQueryBuilder.AstExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.AstNode
ActiveDatabaseSoftware.ActiveQueryBuilder.AstToken
ActiveDatabaseSoftware.ActiveQueryBuilder.AstTokenIdentifier

Requirements

See Also

Reference

AstToken Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AstToken Class Members

AstToken Class Members
Properties Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AstToken Class

The following tables list the members exposed by AstToken.

Public Properties
 | Name | Description
Public Property | Token | Gets or sets text of the token.
Top
See Also

Reference

AstToken Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AstToken Class Properties

AstToken Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AstToken Class

For a list of all members of this type, see AstToken members.

Public Properties
 | Name | Description
Public Property | Token | Gets or sets text of the token.
Top
See Also

Reference

AstToken Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Token Property

Token Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AstToken Class : Token Property
Gets or sets text of the token.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Token As System.String
'Usage

Dim instance As AstToken
Dim value As System.String

instance.Token = value

value = instance.Token
public System.string Token {get; set;}
public: __property System.string* get_Token();
public: __property void set_Token(
   System.string* value
);
Requirements

See Also

Reference

AstToken Class
AstToken Members


AstTokenIdentifier Class

AstTokenIdentifier Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AstTokenIdentifier Class
Abstract Syntax Tree node representing an identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class AstTokenIdentifier
   Inherits AstToken
'Usage

Dim instance As AstTokenIdentifier
public class AstTokenIdentifier : AstToken
public __gc class AstTokenIdentifier : public AstToken
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.AstNodeBase
ActiveDatabaseSoftware.ActiveQueryBuilder.AstExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.AstNode
ActiveDatabaseSoftware.ActiveQueryBuilder.AstToken
ActiveDatabaseSoftware.ActiveQueryBuilder.AstTokenIdentifier

Requirements

See Also

Reference

AstTokenIdentifier Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AstTokenIdentifier Class Members

AstTokenIdentifier Class Members
Properties Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AstTokenIdentifier Class

The following tables list the members exposed by AstTokenIdentifier.

Public Properties
 | Name | Description
Public Property | CaseSensitive | Gets or sets the mark indicating case sensitivity of the identifier.
Public Property | ValidIdentifier | Indicates if identifier is valid or not.
Top
See Also

Reference

AstTokenIdentifier Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AstTokenIdentifier Class Properties

AstTokenIdentifier Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AstTokenIdentifier Class

For a list of all members of this type, see AstTokenIdentifier members.

Public Properties
 | Name | Description
Public Property | CaseSensitive | Gets or sets the mark indicating case sensitivity of the identifier.
Public Property | ValidIdentifier | Indicates if identifier is valid or not.
Top
See Also

Reference

AstTokenIdentifier Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


CaseSensitive Property (AstTokenIdentifier)

CaseSensitive Property (AstTokenIdentifier)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AstTokenIdentifier Class : CaseSensitive Property
Gets or sets the mark indicating case sensitivity of the identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property CaseSensitive As System.Boolean
'Usage

Dim instance As AstTokenIdentifier
Dim value As System.Boolean

instance.CaseSensitive = value

value = instance.CaseSensitive
public System.bool CaseSensitive {get; set;}
public: __property System.bool get_CaseSensitive();
public: __property void set_CaseSensitive(
   System.bool value
);
Requirements

See Also

Reference

AstTokenIdentifier Class
AstTokenIdentifier Members


ValidIdentifier Property

ValidIdentifier Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AstTokenIdentifier Class : ValidIdentifier Property
Indicates if identifier is valid or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ValidIdentifier As System.Boolean
'Usage

Dim instance As AstTokenIdentifier
Dim value As System.Boolean

value = instance.ValidIdentifier
public System.bool ValidIdentifier {get;}
public: __property System.bool get_ValidIdentifier();
Remarks
Valid identifiers do not contain special symbols like spaces, etc., thus they do not need to be quoted.
Requirements

See Also

Reference

AstTokenIdentifier Class
AstTokenIdentifier Members


AutoSyntaxProvider Class

AutoSyntaxProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AutoSyntaxProvider Class
This syntax provider will try to detect database server automatically and will act as specific syntax provider for the detected database server.
Object Model
AutoSyntaxProvider ClassBaseSyntaxProvider Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class AutoSyntaxProvider
   Inherits BaseSyntaxProvider
'Usage

Dim instance As AutoSyntaxProvider
public class AutoSyntaxProvider : BaseSyntaxProvider
public __gc class AutoSyntaxProvider : public BaseSyntaxProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.AutoSyntaxProvider

Requirements

See Also

Reference

AutoSyntaxProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AutoSyntaxProvider Class Members

AutoSyntaxProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AutoSyntaxProvider Class

The following tables list the members exposed by AutoSyntaxProvider.

Public Properties
 | Name | Description
Public Property | DetectedSyntaxProvider | Refers to an instance of the syntax provider object detected with the DetectSyntaxProvider method call.
Top
Public Methods
 | Name | Description
Public Method | DetectSyntaxProvider | Runs the database server auto-detection routine.
Top
See Also

Reference

AutoSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AutoSyntaxProvider Class Methods

AutoSyntaxProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AutoSyntaxProvider Class

For a list of all members of this type, see AutoSyntaxProvider members.

Public Methods
 | Name | Description
Public Method | DetectSyntaxProvider | Runs the database server auto-detection routine.
Top
See Also

Reference

AutoSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


DetectSyntaxProvider Method

DetectSyntaxProvider Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AutoSyntaxProvider Class : DetectSyntaxProvider Method
SQL context to specify database connection for SQL query execution.
Runs the database server auto-detection routine.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub DetectSyntaxProvider( _
   ByVal sqlContext As BaseSQLContext _
)
'Usage

Dim instance As AutoSyntaxProvider
Dim sqlContext As BaseSQLContext

instance.DetectSyntaxProvider(sqlContext)
public void DetectSyntaxProvider(
   BaseSQLContext sqlContext
)
public: void DetectSyntaxProvider(
   BaseSQLContext* sqlContext
)

Parameters

sqlContext
SQL context to specify database connection for SQL query execution.
Remarks
The detection routine sends a series of server-specific SQL queries that allows to uniquely define the underlying database server. This information is used to instantiate the DetectedSyntaxProvider property with the right syntax provider. In case of auto-detection failure, the ANSI SQL/92 syntax (SQL92SyntaxProvider) will be used.
Requirements

See Also

Reference

AutoSyntaxProvider Class
AutoSyntaxProvider Members


AutoSyntaxProvider Class Properties

AutoSyntaxProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AutoSyntaxProvider Class

For a list of all members of this type, see AutoSyntaxProvider members.

Public Properties
 | Name | Description
Public Property | DetectedSyntaxProvider | Refers to an instance of the syntax provider object detected with the DetectSyntaxProvider method call.
Top
See Also

Reference

AutoSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


DetectedSyntaxProvider Property

DetectedSyntaxProvider Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AutoSyntaxProvider Class : DetectedSyntaxProvider Property
Refers to an instance of the syntax provider object detected with the DetectSyntaxProvider method call.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property DetectedSyntaxProvider As BaseSyntaxProvider
'Usage

Dim instance As AutoSyntaxProvider
Dim value As BaseSyntaxProvider

value = instance.DetectedSyntaxProvider
public BaseSyntaxProvider DetectedSyntaxProvider {get;}
public: __property BaseSyntaxProvider* get_DetectedSyntaxProvider();
Requirements

See Also

Reference

AutoSyntaxProvider Class
AutoSyntaxProvider Members


BaseMetadataProvider Class

BaseMetadataProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : BaseMetadataProvider Class
Base class for all Metadata Provider components.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public MustInherit Class BaseMetadataProvider
   Inherits System.ComponentModel.Component
'Usage

Dim instance As BaseMetadataProvider
public abstract class BaseMetadataProvider : System.ComponentModel.Component
public __gc abstract class BaseMetadataProvider : public System.ComponentModel.Component
Remarks

Metadata Providers are used to provide access to the database connection to get the metadata information.

Metadata Provider is intended to be assigned to the QueryBuilder.MetadataProvider Property.

Using Metadata Provider you will get the metadata information loaded to the component automatically. However, you may use the Query Builder without a Metadata Provider, for example, if you can't establish direct connection to the database working in multi-tier environment. Working without a Metadata Provider you should fill the list of database objects to the Metadata Container by yourself; otherwise you will not be able to browse the Database Schema Tree. Also you'll have to set the OfflineMode Property to true to deny execution of metadata extraction queries and set the MetadataContainer.ItemMetadataLoading Event to fill the field lists of database objects being added to the query; otherwise you will see them empty at the Design Pane.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.AdvantageMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.DB2MetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.EventMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.FirebirdMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.InformixMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLCEMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MySQLMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.ODBCMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.OLEDBMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleNativeMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.PostgreSQLMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.SybaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.UniversalMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.VistaDB4MetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.VistaDBMetadataProvider

Requirements

See Also

Reference

BaseMetadataProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


BaseMetadataProvider Class Members

BaseMetadataProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : BaseMetadataProvider Class

The following tables list the members exposed by BaseMetadataProvider.

Public Properties
 | Name | Description
Public Property | CanExecSQL | Indicates if a metadata provider is able to execute SQL queries against database connection.
Public Property | Connected | Gets or sets a value indicating whether the underlying Connection object is connected to the database.
Public Property | Connection | Gets or sets an object implementing IDbConnection interface to provide access to the database.
Public Property | Description | Gets description string for the purpose of selecting the right metadata provider from the list of available providers.
Top
Public Methods
 | Name | Description
Public Method | Connect | Opens connection to the database.
Public Method | Disconnect | Closes connection to the database.
Public Method | ExecSQL | Executes SQL query against Connection and returns the IDataReader interface in result.
Public Method | ExecSQLNoResult | Executes SQL query against Connection. Returns no result.
Public Method | GetReferencingObjectNames |
Top
Public Events
 | Name | Description
Public Event | AfterConnect | Fired after opening connection to the database.
Public Event | AfterDisconnect | Fired after closing connection to the database.
Public Event | BeforeConnect | Fired before opening connection to the database.
Public Event | BeforeDisconnect | Fired before closing connection to the database.
Top
See Also

Reference

BaseMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


BaseMetadataProvider Class Methods

BaseMetadataProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : BaseMetadataProvider Class

For a list of all members of this type, see BaseMetadataProvider members.

Public Methods
 | Name | Description
Public Method | Connect | Opens connection to the database.
Public Method | Disconnect | Closes connection to the database.
Public Method | ExecSQL | Executes SQL query against Connection and returns the IDataReader interface in result.
Public Method | ExecSQLNoResult | Executes SQL query against Connection. Returns no result.
Public Method | GetReferencingObjectNames |
Top
See Also

Reference

BaseMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Connect Method (BaseMetadataProvider)

Connect Method (BaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseMetadataProvider Class : Connect Method
Opens connection to the database.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Connect()
'Usage

Dim instance As BaseMetadataProvider

instance.Connect()
public void Connect()
public: void Connect();
Requirements

See Also

Reference

BaseMetadataProvider Class
BaseMetadataProvider Members


Disconnect Method (BaseMetadataProvider)

Disconnect Method (BaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseMetadataProvider Class : Disconnect Method
Closes connection to the database.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Disconnect()
'Usage

Dim instance As BaseMetadataProvider

instance.Disconnect()
public void Disconnect()
public: void Disconnect();
Requirements

See Also

Reference

BaseMetadataProvider Class
BaseMetadataProvider Members


ExecSQL Method (BaseMetadataProvider)

ExecSQL Method (BaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseMetadataProvider Class : ExecSQL Method
SQL query to be executed against Connection.
Flag indicating that no data fetching is needed after the SQL query execution.
Executes SQL query against Connection and returns the IDataReader interface in result.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ExecSQL( _
   ByVal sql As System.String, _
   ByVal schemaOnly As System.Boolean _
) As System.Data.IDataReader
'Usage

Dim instance As BaseMetadataProvider
Dim sql As System.String
Dim schemaOnly As System.Boolean
Dim value As System.Data.IDataReader

value = instance.ExecSQL(sql, schemaOnly)
public System.Data.IDataReader ExecSQL(
   System.string sql,
   System.bool schemaOnly
)
public: System.Data.IDataReader* ExecSQL(
   System.string* sql,
   System.bool schemaOnly
)

Parameters

sql
SQL query to be executed against Connection.
schemaOnly
Flag indicating that no data fetching is needed after the SQL query execution.

Return Value

Returns IDataReader interface to get access to the SQL query execution result.
Requirements

See Also

Reference

BaseMetadataProvider Class
BaseMetadataProvider Members


ExecSQLNoResult Method (BaseMetadataProvider)

ExecSQLNoResult Method (BaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseMetadataProvider Class : ExecSQLNoResult Method
SQL query to be executed against Connection.
Executes SQL query against Connection. Returns no result.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ExecSQLNoResult( _
   ByVal sql As System.String _
)
'Usage

Dim instance As BaseMetadataProvider
Dim sql As System.String

instance.ExecSQLNoResult(sql)
public void ExecSQLNoResult(
   System.string sql
)
public: void ExecSQLNoResult(
   System.string* sql
)

Parameters

sql
SQL query to be executed against Connection.
Requirements

See Also

Reference

BaseMetadataProvider Class
BaseMetadataProvider Members


GetReferencingObjectNames Method (BaseMetadataProvider)

GetReferencingObjectNames Method (BaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseMetadataProvider Class : GetReferencingObjectNames Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function GetReferencingObjectNames( _
   ByVal list As UpdatableObjectList(Of MetadataQualifiedName), _
   ByVal forObject As MetadataObject, _
   ByVal loadingOptions As MetadataLoadingOptions _
) As System.Boolean
'Usage

Dim instance As BaseMetadataProvider
Dim list As UpdatableObjectList(Of MetadataQualifiedName)
Dim forObject As MetadataObject
Dim loadingOptions As MetadataLoadingOptions
Dim value As System.Boolean

value = instance.GetReferencingObjectNames(list, forObject, loadingOptions)
public virtual System.bool GetReferencingObjectNames(
   UpdatableObjectList<MetadataQualifiedName> list,
   MetadataObject forObject,
   MetadataLoadingOptions loadingOptions
)
public: virtual System.bool GetReferencingObjectNames(
   UpdatableObjectList<MetadataQualifiedName*>* list,
   MetadataObject* forObject,
   MetadataLoadingOptions* loadingOptions
)

Parameters

list
forObject
loadingOptions
Requirements

See Also

Reference

BaseMetadataProvider Class
BaseMetadataProvider Members


BaseMetadataProvider Class Properties

BaseMetadataProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : BaseMetadataProvider Class

For a list of all members of this type, see BaseMetadataProvider members.

Public Properties
 | Name | Description
Public Property | CanExecSQL | Indicates if a metadata provider is able to execute SQL queries against database connection.
Public Property | Connected | Gets or sets a value indicating whether the underlying Connection object is connected to the database.
Public Property | Connection | Gets or sets an object implementing IDbConnection interface to provide access to the database.
Public Property | Description | Gets description string for the purpose of selecting the right metadata provider from the list of available providers.
Top
See Also

Reference

BaseMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


CanExecSQL Property (BaseMetadataProvider)

CanExecSQL Property (BaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseMetadataProvider Class : CanExecSQL Property
Indicates if a metadata provider is able to execute SQL queries against database connection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CanExecSQL As System.Boolean
'Usage

Dim instance As BaseMetadataProvider
Dim value As System.Boolean

value = instance.CanExecSQL
public System.bool CanExecSQL {get;}
public: __property System.bool get_CanExecSQL();
Requirements

See Also

Reference

BaseMetadataProvider Class
BaseMetadataProvider Members


Connected Property (BaseMetadataProvider)

Connected Property (BaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseMetadataProvider Class : Connected Property
Gets or sets a value indicating whether the underlying Connection object is connected to the database.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Connected As System.Boolean
'Usage

Dim instance As BaseMetadataProvider
Dim value As System.Boolean

instance.Connected = value

value = instance.Connected
public System.bool Connected {get; set;}
public: __property System.bool get_Connected();
public: __property void set_Connected(
   System.bool value
);
Requirements

See Also

Reference

BaseMetadataProvider Class
BaseMetadataProvider Members


Connection Property (BaseMetadataProvider)

Connection Property (BaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseMetadataProvider Class : Connection Property
Gets or sets an object implementing IDbConnection interface to provide access to the database.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Connection As System.Data.IDbConnection
'Usage

Dim instance As BaseMetadataProvider
Dim value As System.Data.IDbConnection

instance.Connection = value

value = instance.Connection
public virtual System.Data.IDbConnection Connection {get; set;}
public: __property virtual System.Data.IDbConnection* get_Connection();
public: __property virtual void set_Connection(
   System.Data.IDbConnection* value
);
Requirements

See Also

Reference

BaseMetadataProvider Class
BaseMetadataProvider Members


Description Property (BaseMetadataProvider)

Description Property (BaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseMetadataProvider Class : Description Property
Gets description string for the purpose of selecting the right metadata provider from the list of available providers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Description As System.String
'Usage

Dim instance As BaseMetadataProvider
Dim value As System.String

value = instance.Description
public System.string Description {get;}
public: __property System.string* get_Description();
Requirements

See Also

Reference

BaseMetadataProvider Class
BaseMetadataProvider Members


BaseMetadataProvider Class Events

BaseMetadataProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : BaseMetadataProvider Class

For a list of all members of this type, see BaseMetadataProvider members.

Public Events
 | Name | Description
Public Event | AfterConnect | Fired after opening connection to the database.
Public Event | AfterDisconnect | Fired after closing connection to the database.
Public Event | BeforeConnect | Fired before opening connection to the database.
Public Event | BeforeDisconnect | Fired before closing connection to the database.
Top
See Also

Reference

BaseMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AfterConnect Event (BaseMetadataProvider)

AfterConnect Event (BaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseMetadataProvider Class : AfterConnect Event
Fired after opening connection to the database.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterConnect As System.EventHandler
'Usage

Dim instance As BaseMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterConnect, handler
public event System.EventHandler AfterConnect
public: __event System.EventHandler* AfterConnect
Requirements

See Also

Reference

BaseMetadataProvider Class
BaseMetadataProvider Members


AfterDisconnect Event (BaseMetadataProvider)

AfterDisconnect Event (BaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseMetadataProvider Class : AfterDisconnect Event
Fired after closing connection to the database.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterDisconnect As System.EventHandler
'Usage

Dim instance As BaseMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterDisconnect, handler
public event System.EventHandler AfterDisconnect
public: __event System.EventHandler* AfterDisconnect
Requirements

See Also

Reference

BaseMetadataProvider Class
BaseMetadataProvider Members


BeforeConnect Event (BaseMetadataProvider)

BeforeConnect Event (BaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseMetadataProvider Class : BeforeConnect Event
Fired before opening connection to the database.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeConnect As System.EventHandler
'Usage

Dim instance As BaseMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeConnect, handler
public event System.EventHandler BeforeConnect
public: __event System.EventHandler* BeforeConnect
Requirements

See Also

Reference

BaseMetadataProvider Class
BaseMetadataProvider Members


BeforeDisconnect Event (BaseMetadataProvider)

BeforeDisconnect Event (BaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseMetadataProvider Class : BeforeDisconnect Event
Fired before closing connection to the database.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeDisconnect As System.EventHandler
'Usage

Dim instance As BaseMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeDisconnect, handler
public event System.EventHandler BeforeDisconnect
public: __event System.EventHandler* BeforeDisconnect
Requirements

See Also

Reference

BaseMetadataProvider Class
BaseMetadataProvider Members


BaseSQLBuilder Class

BaseSQLBuilder Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : BaseSQLBuilder Class
Base class for the PlainTextSQLBuilder and other SQL generation classes that might be implemented in the future.
Object Model
BaseSQLBuilder ClassSQLBuilderSelectFormat ClassSQLBuilderSelectFormat ClassSQLBuilderSelectFormat ClassSQLBuilderSelectFormat ClassQueryBuilder Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class BaseSQLBuilder
   Inherits System.ComponentModel.Component
'Usage

Dim instance As BaseSQLBuilder
public class BaseSQLBuilder : System.ComponentModel.Component
public __gc class BaseSQLBuilder : public System.ComponentModel.Component
Remarks
Defines SQL query text generation rules; also determines SQL text formatting options that are not related to specific output format (Plain Text, HTML, RTF etc.)
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSQLBuilder
ActiveDatabaseSoftware.ActiveQueryBuilder.PlainTextSQLBuilder

Requirements

See Also

Reference

BaseSQLBuilder Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


BaseSQLBuilder Class Members

BaseSQLBuilder Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : BaseSQLBuilder Class

The following tables list the members exposed by BaseSQLBuilder.

Public Properties
 | Name | Description
Public Property | AsKeywordInExpressionAlias | Instructs the component to insert "AS" keyword between field name and alias ("Fleld AS Alias") or not.
Public Property | AsKeywordInObjectAlias | Instructs the component to insert "AS" keyword between object name and its alias ("Table AS Alias") or not.
Public Property | CTESubQueryFormat | Determines various formatting options for Common Table Expressions.
Public Property | DerivedQueryFormat | Determines various formatting options for derived tables.
Public Property | ExpandVirtualObjects | Instructs SQL Builder to expand virtual objects and fields to appropriate expressions, sub-queries and dervied tables in result SQL query text or not.
Public Property | ExpressionSubqueryFormat | Determines various formatting options of sub-queries used in expressions.
Public Property | InnerKeywordInLinks | Instructs the component to insert "INNER" keyword before "JOIN" clause or not.
Public Property | IsUpdating | Indicates that the component is in update mode now.
Public Property | KeywordFormat | Determines keywords format in the generated SQL query text.
Public Property | MainQueryFormat | Determines various formatting options for the main query.
Public Property | ObjectPrefixSkipping | Instructs the component to skip the unnecessary database object prefixes (database, schema or both) or not.
Public Property | OuterKeywordInLinks | Instructs the component to insert "OUTER" keyword before "JOIN" clause or not.
Public Property | ParenthesizeANDGroups | Instructs the component to enclose in parentheses criteria groups joined with AND operator if they are separated by the OR operator for clarity of criteria representation in text form.
Public Property | ParenthesizeSingleCriterion | Instructs the component to enclose in parentheses single arithmetic operators for clarity of criteria representation in text form.
Public Property | QueryBuilder | Refers to the QueryBuilder object to which SQL Builder belongs to.
Public Property | QuoteAllIdentifiers | Instructs the component to quote all identifiers, even if its not necessary according to specific SQL syntax rules.
Public Property | RightMargin | Defines maximum length of lines in the generated SQL query text. Zero value means unlimited length of lines.
Public Property | SQL | Returns formatted SQL query text.
Public Property | TargetQueryPart | Instructs to generate the SQL query text not for the whole query, but for currently visible part of the query only.
Public Property | UseAltNames | Instructs to generate result SQL query text using alternate names or real database object and field names.
Top
Public Methods
 | Name | Description
Public Method | BeginUpdate | Prevents the component from SQL generation until the EndUpdate method is called.
Public Method | EndUpdate | Resumes SQL generation after it was suspended by the BeginUpdate method.
Top
Public Events
 | Name | Description
Public Event | BeginBuildSQLForNode | Fired when the SQL Builder starts build SQL text for a node.
Public Event | EndBuildSQLForNode | Fired when the SQL Builder ends build SQL text for a node.
Public Event | SQLUpdated | Fired on update of result SQL query text.
Top
See Also

Reference

BaseSQLBuilder Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


BaseSQLBuilder Class Methods

BaseSQLBuilder Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : BaseSQLBuilder Class

For a list of all members of this type, see BaseSQLBuilder members.

Public Methods
 | Name | Description
Public Method | BeginUpdate | Prevents the component from SQL generation until the EndUpdate method is called.
Public Method | EndUpdate | Resumes SQL generation after it was suspended by the BeginUpdate method.
Top
See Also

Reference

BaseSQLBuilder Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


BeginUpdate Method (BaseSQLBuilder)

BeginUpdate Method (BaseSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : BeginUpdate Method
Prevents the component from SQL generation until the EndUpdate method is called.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub BeginUpdate()
'Usage

Dim instance As BaseSQLBuilder

instance.BeginUpdate()
public void BeginUpdate()
public: void BeginUpdate();
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


EndUpdate Method (BaseSQLBuilder)

EndUpdate Method (BaseSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : EndUpdate Method
Resumes SQL generation after it was suspended by the BeginUpdate method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub EndUpdate()
'Usage

Dim instance As BaseSQLBuilder

instance.EndUpdate()
public void EndUpdate()
public: void EndUpdate();
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


BaseSQLBuilder Class Properties

BaseSQLBuilder Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : BaseSQLBuilder Class

For a list of all members of this type, see BaseSQLBuilder members.

Public Properties
 | Name | Description
Public Property | AsKeywordInExpressionAlias | Instructs the component to insert "AS" keyword between field name and alias ("Fleld AS Alias") or not.
Public Property | AsKeywordInObjectAlias | Instructs the component to insert "AS" keyword between object name and its alias ("Table AS Alias") or not.
Public Property | CTESubQueryFormat | Determines various formatting options for Common Table Expressions.
Public Property | DerivedQueryFormat | Determines various formatting options for derived tables.
Public Property | ExpandVirtualObjects | Instructs SQL Builder to expand virtual objects and fields to appropriate expressions, sub-queries and dervied tables in result SQL query text or not.
Public Property | ExpressionSubqueryFormat | Determines various formatting options of sub-queries used in expressions.
Public Property | InnerKeywordInLinks | Instructs the component to insert "INNER" keyword before "JOIN" clause or not.
Public Property | IsUpdating | Indicates that the component is in update mode now.
Public Property | KeywordFormat | Determines keywords format in the generated SQL query text.
Public Property | MainQueryFormat | Determines various formatting options for the main query.
Public Property | ObjectPrefixSkipping | Instructs the component to skip the unnecessary database object prefixes (database, schema or both) or not.
Public Property | OuterKeywordInLinks | Instructs the component to insert "OUTER" keyword before "JOIN" clause or not.
Public Property | ParenthesizeANDGroups | Instructs the component to enclose in parentheses criteria groups joined with AND operator if they are separated by the OR operator for clarity of criteria representation in text form.
Public Property | ParenthesizeSingleCriterion | Instructs the component to enclose in parentheses single arithmetic operators for clarity of criteria representation in text form.
Public Property | QueryBuilder | Refers to the QueryBuilder object to which SQL Builder belongs to.
Public Property | QuoteAllIdentifiers | Instructs the component to quote all identifiers, even if its not necessary according to specific SQL syntax rules.
Public Property | RightMargin | Defines maximum length of lines in the generated SQL query text. Zero value means unlimited length of lines.
Public Property | SQL | Returns formatted SQL query text.
Public Property | TargetQueryPart | Instructs to generate the SQL query text not for the whole query, but for currently visible part of the query only.
Public Property | UseAltNames | Instructs to generate result SQL query text using alternate names or real database object and field names.
Top
See Also

Reference

BaseSQLBuilder Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AsKeywordInExpressionAlias Property (BaseSQLBuilder)

AsKeywordInExpressionAlias Property (BaseSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : AsKeywordInExpressionAlias Property
Instructs the component to insert "AS" keyword between field name and alias ("Fleld AS Alias") or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AsKeywordInExpressionAlias As SkipKeywordMode
'Usage

Dim instance As BaseSQLBuilder
Dim value As SkipKeywordMode

instance.AsKeywordInExpressionAlias = value

value = instance.AsKeywordInExpressionAlias
public SkipKeywordMode AsKeywordInExpressionAlias {get; set;}
public: __property SkipKeywordMode get_AsKeywordInExpressionAlias();
public: __property void set_AsKeywordInExpressionAlias(
   SkipKeywordMode value
);
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members
AsKeywordInObjectAlias Property


AsKeywordInObjectAlias Property (BaseSQLBuilder)

AsKeywordInObjectAlias Property (BaseSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : AsKeywordInObjectAlias Property
Instructs the component to insert "AS" keyword between object name and its alias ("Table AS Alias") or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AsKeywordInObjectAlias As SkipKeywordMode
'Usage

Dim instance As BaseSQLBuilder
Dim value As SkipKeywordMode

instance.AsKeywordInObjectAlias = value

value = instance.AsKeywordInObjectAlias
public SkipKeywordMode AsKeywordInObjectAlias {get; set;}
public: __property SkipKeywordMode get_AsKeywordInObjectAlias();
public: __property void set_AsKeywordInObjectAlias(
   SkipKeywordMode value
);
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members
AsKeywordInExpressionAlias Property


CTESubQueryFormat Property

CTESubQueryFormat Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : CTESubQueryFormat Property
Determines various formatting options for Common Table Expressions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property CTESubQueryFormat As SQLBuilderSelectFormat
'Usage

Dim instance As BaseSQLBuilder
Dim value As SQLBuilderSelectFormat

instance.CTESubQueryFormat = value

value = instance.CTESubQueryFormat
public SQLBuilderSelectFormat CTESubQueryFormat {get; set;}
public: __property SQLBuilderSelectFormat* get_CTESubQueryFormat();
public: __property void set_CTESubQueryFormat(
   SQLBuilderSelectFormat* value
);
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


DerivedQueryFormat Property

DerivedQueryFormat Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : DerivedQueryFormat Property
Determines various formatting options for derived tables.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DerivedQueryFormat As SQLBuilderSelectFormat
'Usage

Dim instance As BaseSQLBuilder
Dim value As SQLBuilderSelectFormat

instance.DerivedQueryFormat = value

value = instance.DerivedQueryFormat
public SQLBuilderSelectFormat DerivedQueryFormat {get; set;}
public: __property SQLBuilderSelectFormat* get_DerivedQueryFormat();
public: __property void set_DerivedQueryFormat(
   SQLBuilderSelectFormat* value
);
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


ExpandVirtualObjects Property

ExpandVirtualObjects Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : ExpandVirtualObjects Property
Instructs SQL Builder to expand virtual objects and fields to appropriate expressions, sub-queries and dervied tables in result SQL query text or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ExpandVirtualObjects As System.Boolean
'Usage

Dim instance As BaseSQLBuilder
Dim value As System.Boolean

instance.ExpandVirtualObjects = value

value = instance.ExpandVirtualObjects
public System.bool ExpandVirtualObjects {get; set;}
public: __property System.bool get_ExpandVirtualObjects();
public: __property void set_ExpandVirtualObjects(
   System.bool value
);

Property Value

Set this option to true to generate SQL query text for execution against real database server.
Set this option to false to generate SQL query text for the end-user to modify or to save it between work sessions.
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


ExpressionSubqueryFormat Property

ExpressionSubqueryFormat Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : ExpressionSubqueryFormat Property
Determines various formatting options of sub-queries used in expressions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ExpressionSubqueryFormat As SQLBuilderSelectFormat
'Usage

Dim instance As BaseSQLBuilder
Dim value As SQLBuilderSelectFormat

instance.ExpressionSubqueryFormat = value

value = instance.ExpressionSubqueryFormat
public SQLBuilderSelectFormat ExpressionSubqueryFormat {get; set;}
public: __property SQLBuilderSelectFormat* get_ExpressionSubqueryFormat();
public: __property void set_ExpressionSubqueryFormat(
   SQLBuilderSelectFormat* value
);
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


InnerKeywordInLinks Property (BaseSQLBuilder)

InnerKeywordInLinks Property (BaseSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : InnerKeywordInLinks Property
Instructs the component to insert "INNER" keyword before "JOIN" clause or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property InnerKeywordInLinks As SkipKeywordMode
'Usage

Dim instance As BaseSQLBuilder
Dim value As SkipKeywordMode

instance.InnerKeywordInLinks = value

value = instance.InnerKeywordInLinks
public SkipKeywordMode InnerKeywordInLinks {get; set;}
public: __property SkipKeywordMode get_InnerKeywordInLinks();
public: __property void set_InnerKeywordInLinks(
   SkipKeywordMode value
);
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members
OuterKeywordInLinks Property


IsUpdating Property (BaseSQLBuilder)

IsUpdating Property (BaseSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : IsUpdating Property
Indicates that the component is in update mode now.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property IsUpdating As System.Boolean
'Usage

Dim instance As BaseSQLBuilder
Dim value As System.Boolean

value = instance.IsUpdating
public System.bool IsUpdating {get;}
public: __property System.bool get_IsUpdating();
Remarks
See BeginUpdate and EndUpdate methods for details.
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


KeywordFormat Property

KeywordFormat Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : KeywordFormat Property
Determines keywords format in the generated SQL query text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property KeywordFormat As KeywordFormat
'Usage

Dim instance As BaseSQLBuilder
Dim value As KeywordFormat

instance.KeywordFormat = value

value = instance.KeywordFormat
public KeywordFormat KeywordFormat {get; set;}
public: __property KeywordFormat get_KeywordFormat();
public: __property void set_KeywordFormat(
   KeywordFormat value
);
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


MainQueryFormat Property

MainQueryFormat Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : MainQueryFormat Property
Determines various formatting options for the main query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property MainQueryFormat As SQLBuilderSelectFormat
'Usage

Dim instance As BaseSQLBuilder
Dim value As SQLBuilderSelectFormat

instance.MainQueryFormat = value

value = instance.MainQueryFormat
public SQLBuilderSelectFormat MainQueryFormat {get; set;}
public: __property SQLBuilderSelectFormat* get_MainQueryFormat();
public: __property void set_MainQueryFormat(
   SQLBuilderSelectFormat* value
);
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members
DerivedQueryFormat Property
ExpressionSubqueryFormat Property


ObjectPrefixSkipping Property (BaseSQLBuilder)

ObjectPrefixSkipping Property (BaseSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : ObjectPrefixSkipping Property
Instructs the component to skip the unnecessary database object prefixes (database, schema or both) or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ObjectPrefixSkipping As ObjectPrefixSkipping
'Usage

Dim instance As BaseSQLBuilder
Dim value As ObjectPrefixSkipping

instance.ObjectPrefixSkipping = value

value = instance.ObjectPrefixSkipping
public ObjectPrefixSkipping ObjectPrefixSkipping {get; set;}
public: __property ObjectPrefixSkipping get_ObjectPrefixSkipping();
public: __property void set_ObjectPrefixSkipping(
   ObjectPrefixSkipping value
);
Remarks
The necessity of a prefix is determined in accordance with the current database connection. According to it, there could be defined a default database and default schemas that can be omitted in SQL query text. This information is retrieved by Active Query Builder from the database during metadata retrieval process and might be changed manually using the MetadataContainer.DefaultDatabaseName property and the MetadataContainer.DefaultSchemaNames collection.
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


OuterKeywordInLinks Property (BaseSQLBuilder)

OuterKeywordInLinks Property (BaseSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : OuterKeywordInLinks Property
Instructs the component to insert "OUTER" keyword before "JOIN" clause or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property OuterKeywordInLinks As SkipKeywordMode
'Usage

Dim instance As BaseSQLBuilder
Dim value As SkipKeywordMode

instance.OuterKeywordInLinks = value

value = instance.OuterKeywordInLinks
public SkipKeywordMode OuterKeywordInLinks {get; set;}
public: __property SkipKeywordMode get_OuterKeywordInLinks();
public: __property void set_OuterKeywordInLinks(
   SkipKeywordMode value
);
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members
InnerKeywordInLinks Property


ParenthesizeANDGroups Property

ParenthesizeANDGroups Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : ParenthesizeANDGroups Property
Instructs the component to enclose in parentheses criteria groups joined with AND operator if they are separated by the OR operator for clarity of criteria representation in text form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ParenthesizeANDGroups As System.Boolean
'Usage

Dim instance As BaseSQLBuilder
Dim value As System.Boolean

instance.ParenthesizeANDGroups = value

value = instance.ParenthesizeANDGroups
public System.bool ParenthesizeANDGroups {get; set;}
public: __property System.bool get_ParenthesizeANDGroups();
public: __property void set_ParenthesizeANDGroups(
   System.bool value
);

Property Value

if false, the result SQL will be: "a >1 and b > 1 or a <= 1 and b < 0";
if true: "(a >1 and b > 1) or (a <= 1 and b < 0)".
Remarks
Can be used in conjunction with the ParenthesizeSingleCriterion property.
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


ParenthesizeSingleCriterion Property

ParenthesizeSingleCriterion Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : ParenthesizeSingleCriterion Property
Instructs the component to enclose in parentheses single arithmetic operators for clarity of criteria representation in text form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ParenthesizeSingleCriterion As System.Boolean
'Usage

Dim instance As BaseSQLBuilder
Dim value As System.Boolean

instance.ParenthesizeSingleCriterion = value

value = instance.ParenthesizeSingleCriterion
public System.bool ParenthesizeSingleCriterion {get; set;}
public: __property System.bool get_ParenthesizeSingleCriterion();
public: __property void set_ParenthesizeSingleCriterion(
   System.bool value
);
Remarks
Can be used in conjunction with the ParenthesizeANDGroups property.
Example
if false, the result SQL will be: "a >1 and b > 1 or a <= 1 and b < 0";
if true: "(a >1) and (b > 1) or (a <= 1) and (b < 0)".
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


QueryBuilder Property (BaseSQLBuilder)

QueryBuilder Property (BaseSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : QueryBuilder Property
Refers to the QueryBuilder object to which SQL Builder belongs to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property QueryBuilder As QueryBuilder
'Usage

Dim instance As BaseSQLBuilder
Dim value As QueryBuilder

instance.QueryBuilder = value

value = instance.QueryBuilder
public QueryBuilder QueryBuilder {get; set;}
public: __property QueryBuilder* get_QueryBuilder();
public: __property void set_QueryBuilder(
   QueryBuilder* value
);
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


QuoteAllIdentifiers Property (BaseSQLBuilder)

QuoteAllIdentifiers Property (BaseSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : QuoteAllIdentifiers Property
Instructs the component to quote all identifiers, even if its not necessary according to specific SQL syntax rules.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property QuoteAllIdentifiers As System.Boolean
'Usage

Dim instance As BaseSQLBuilder
Dim value As System.Boolean

instance.QuoteAllIdentifiers = value

value = instance.QuoteAllIdentifiers
public System.bool QuoteAllIdentifiers {get; set;}
public: __property System.bool get_QuoteAllIdentifiers();
public: __property void set_QuoteAllIdentifiers(
   System.bool value
);
Remarks
Quotation marks are determined according to the current SQL syntax.
Example
if set to false, the result SQL will be: "Northwind.dbo.[Order details]";
if true: "[Northwind].[dbo].[Order details]".
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


RightMargin Property

RightMargin Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : RightMargin Property
Defines maximum length of lines in the generated SQL query text. Zero value means unlimited length of lines.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property RightMargin As System.Integer
'Usage

Dim instance As BaseSQLBuilder
Dim value As System.Integer

instance.RightMargin = value

value = instance.RightMargin
public System.int RightMargin {get; set;}
public: __property System.int get_RightMargin();
public: __property void set_RightMargin(
   System.int value
);
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


SQL Property (BaseSQLBuilder)

SQL Property (BaseSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : SQL Property
Returns formatted SQL query text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SQL As System.String
'Usage

Dim instance As BaseSQLBuilder
Dim value As System.String

instance.SQL = value

value = instance.SQL
public System.string SQL {get; set;}
public: __property System.string* get_SQL();
public: __property void set_SQL(
   System.string* value
);
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


TargetQueryPart Property

TargetQueryPart Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : TargetQueryPart Property
Instructs to generate the SQL query text not for the whole query, but for currently visible part of the query only.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property TargetQueryPart As QueryPart
'Usage

Dim instance As BaseSQLBuilder
Dim value As QueryPart

instance.TargetQueryPart = value

value = instance.TargetQueryPart
public QueryPart TargetQueryPart {get; set;}
public: __property QueryPart get_TargetQueryPart();
public: __property void set_TargetQueryPart(
   QueryPart value
);
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


UseAltNames Property (BaseSQLBuilder)

UseAltNames Property (BaseSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : UseAltNames Property
Instructs to generate result SQL query text using alternate names or real database object and field names.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property UseAltNames As System.Boolean
'Usage

Dim instance As BaseSQLBuilder
Dim value As System.Boolean

instance.UseAltNames = value

value = instance.UseAltNames
public System.bool UseAltNames {get; set;}
public: __property System.bool get_UseAltNames();
public: __property void set_UseAltNames(
   System.bool value
);

Property Value

Set this option to true to generate SQL query text for the end-user to modify or to save it between work sessions.
Set this option to false to generate SQL query text for execution against real database server.
Remarks
This property has no effect if alternate names aren't defined in the Metadata Container.
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members
QueryBuilder.UseAltNames


BaseSQLBuilder Class Events

BaseSQLBuilder Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : BaseSQLBuilder Class

For a list of all members of this type, see BaseSQLBuilder members.

Public Events
 | Name | Description
Public Event | BeginBuildSQLForNode | Fired when the SQL Builder starts build SQL text for a node.
Public Event | EndBuildSQLForNode | Fired when the SQL Builder ends build SQL text for a node.
Public Event | SQLUpdated | Fired on update of result SQL query text.
Top
See Also

Reference

BaseSQLBuilder Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


BeginBuildSQLForNode Event

BeginBuildSQLForNode Event
Example

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : BeginBuildSQLForNode Event
Fired when the SQL Builder starts build SQL text for a node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeginBuildSQLForNode As BuildSQLForNodeEventHandler
'Usage

Dim instance As BaseSQLBuilder
Dim handler As BuildSQLForNodeEventHandler

AddHandler instance.BeginBuildSQLForNode, handler
public event BuildSQLForNodeEventHandler BeginBuildSQLForNode
public: __event BuildSQLForNodeEventHandler* BeginBuildSQLForNode
Remarks
Used to implement custom SQL formatting rules.
Example
Adds opening parentesis before each function in the SQL text.
  • C#
private void plainTextSQLBuilder_BeginBuildSQLForNode(object sender, AstNode node)
{
    if (node is SQLExpressionFunction || node is SQLExpressionAggregate)
    {
        plainTextSQLBuilder.SQLBuilder.WriteSymbol("(");
    }
}
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


EndBuildSQLForNode Event

EndBuildSQLForNode Event
Example

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : EndBuildSQLForNode Event
Fired when the SQL Builder ends build SQL text for a node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event EndBuildSQLForNode As BuildSQLForNodeEventHandler
'Usage

Dim instance As BaseSQLBuilder
Dim handler As BuildSQLForNodeEventHandler

AddHandler instance.EndBuildSQLForNode, handler
public event BuildSQLForNodeEventHandler EndBuildSQLForNode
public: __event BuildSQLForNodeEventHandler* EndBuildSQLForNode
Remarks
Used to implement custom SQL formatting rules.
Example
Adds closing parenthesis after each function in the SQL text.
  • C#
private void plainTextSQLBuilder_EndBuildSQLForNode(object sender, AstNode node)
{
    if (node is SQLExpressionFunction || node is SQLExpressionAggregate)
    {
        plainTextSQLBuilder.SQLBuilder.WriteSymbol(")");
    }
}
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


SQLUpdated Event (BaseSQLBuilder)

SQLUpdated Event (BaseSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : SQLUpdated Event
Fired on update of result SQL query text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event SQLUpdated As System.EventHandler
'Usage

Dim instance As BaseSQLBuilder
Dim handler As System.EventHandler

AddHandler instance.SQLUpdated, handler
public event System.EventHandler SQLUpdated
public: __event System.EventHandler* SQLUpdated
Remarks
To prevent this event from firing during the update of several SQL Builder properties at once, enclose this code with BeginUpdate and EndUpdate methods.
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


BaseSQLContext Class

BaseSQLContext Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : BaseSQLContext Class
Defines context for the query building, parsing and SQL generation purposes.
Object Model
BaseSQLContext ClassMetadataContainer ClassBaseMetadataProvider ClassBaseSyntaxProvider Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class BaseSQLContext
   Inherits UpdatablePersistent
'Usage

Dim instance As BaseSQLContext
public class BaseSQLContext : UpdatablePersistent
public __gc class BaseSQLContext : public UpdatablePersistent
Remarks
This object holds links to the Syntax Provider that defines parsing and metadata retrieval rules, to the Metadata Provider that allows to retrieve metadata from the database and to the Metadata Container that holds metadata information retrieved from the database.
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSQLContext

Requirements

See Also

Reference

BaseSQLContext Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


BaseSQLContext Class Members

BaseSQLContext Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : BaseSQLContext Class

The following tables list the members exposed by BaseSQLContext.

Public Properties
 | Name | Description
Public Property | MetadataContainer |
Public Property | MetadataProvider |
Public Property | SyntaxProvider |
Top
See Also

Reference

BaseSQLContext Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


BaseSQLContext Class Properties

BaseSQLContext Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : BaseSQLContext Class

For a list of all members of this type, see BaseSQLContext members.

Public Properties
 | Name | Description
Public Property | MetadataContainer |
Public Property | MetadataProvider |
Public Property | SyntaxProvider |
Top
See Also

Reference

BaseSQLContext Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataContainer Property (BaseSQLContext)

MetadataContainer Property (BaseSQLContext)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLContext Class : MetadataContainer Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property MetadataContainer As MetadataContainer
'Usage

Dim instance As BaseSQLContext
Dim value As MetadataContainer

instance.MetadataContainer = value

value = instance.MetadataContainer
public MetadataContainer MetadataContainer {get; set;}
public: __property MetadataContainer* get_MetadataContainer();
public: __property void set_MetadataContainer(
   MetadataContainer* value
);
Requirements

See Also

Reference

BaseSQLContext Class
BaseSQLContext Members


MetadataProvider Property (BaseSQLContext)

MetadataProvider Property (BaseSQLContext)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLContext Class : MetadataProvider Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property MetadataProvider As BaseMetadataProvider
'Usage

Dim instance As BaseSQLContext
Dim value As BaseMetadataProvider

instance.MetadataProvider = value

value = instance.MetadataProvider
public BaseMetadataProvider MetadataProvider {get; set;}
public: __property BaseMetadataProvider* get_MetadataProvider();
public: __property void set_MetadataProvider(
   BaseMetadataProvider* value
);
Requirements

See Also

Reference

BaseSQLContext Class
BaseSQLContext Members


SyntaxProvider Property (BaseSQLContext)

SyntaxProvider Property (BaseSQLContext)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLContext Class : SyntaxProvider Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SyntaxProvider As BaseSyntaxProvider
'Usage

Dim instance As BaseSQLContext
Dim value As BaseSyntaxProvider

instance.SyntaxProvider = value

value = instance.SyntaxProvider
public BaseSyntaxProvider SyntaxProvider {get; set;}
public: __property BaseSyntaxProvider* get_SyntaxProvider();
public: __property void set_SyntaxProvider(
   BaseSyntaxProvider* value
);
Requirements

See Also

Reference

BaseSQLContext Class
BaseSQLContext Members


BaseSyntaxProvider Class

BaseSyntaxProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : BaseSyntaxProvider Class
Base class for all syntax providers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public MustInherit Class BaseSyntaxProvider
   Inherits System.ComponentModel.Component
'Usage

Dim instance As BaseSyntaxProvider
public abstract class BaseSyntaxProvider : System.ComponentModel.Component
public __gc abstract class BaseSyntaxProvider : public System.ComponentModel.Component
Remarks
Syntax providers determine the syntax rules of specific database servers and the rules to retrieve metadata from database servers.
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.AutoSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.DB2SyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.FirebirdSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.GenericSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.InformixSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MSAccessSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MySQLSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.PostgreSQLSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.SQL2003SyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.SQL89SyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.SQL92SyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.SybaseSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.VistaDBSyntaxProvider

Requirements

See Also

Reference

BaseSyntaxProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


BaseSyntaxProvider Class Members

BaseSyntaxProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : BaseSyntaxProvider Class

The following tables list the members exposed by BaseSyntaxProvider.

Public Properties
 | Name | Description
Public Property | Description | Gets description of the syntax provider class.
Public Property | DetectServerVersion | Instructs the component to detect database server version automatically.
Public Property | IdentCaseSens | Defines the way database server treats quoted and unquoted identifiers.
Public Property | QuoteBegin | Gets the symbol to start quotation of identifier.
Public Property | QuoteEnd | Gets the symbol to finish quotation of identifier.
Top
Public Methods
 | Name | Description
Public Method | GetReferencingObjectNames |
Public Method | LoadAggregates |
Public Method | ValidateQuery | Validates the given SQL query for compliance with the rules of SQL syntax.
Top
See Also

Reference

BaseSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


BaseSyntaxProvider Class Methods

BaseSyntaxProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : BaseSyntaxProvider Class

For a list of all members of this type, see BaseSyntaxProvider members.

Public Methods
 | Name | Description
Public Method | GetReferencingObjectNames |
Public Method | LoadAggregates |
Public Method | ValidateQuery | Validates the given SQL query for compliance with the rules of SQL syntax.
Top
See Also

Reference

BaseSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


GetReferencingObjectNames Method (BaseSyntaxProvider)

GetReferencingObjectNames Method (BaseSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSyntaxProvider Class : GetReferencingObjectNames Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function GetReferencingObjectNames( _
   ByVal list As UpdatableObjectList(Of MetadataQualifiedName), _
   ByVal forObject As MetadataObject, _
   ByVal loadingOptions As MetadataLoadingOptions _
) As System.Boolean
'Usage

Dim instance As BaseSyntaxProvider
Dim list As UpdatableObjectList(Of MetadataQualifiedName)
Dim forObject As MetadataObject
Dim loadingOptions As MetadataLoadingOptions
Dim value As System.Boolean

value = instance.GetReferencingObjectNames(list, forObject, loadingOptions)
public virtual System.bool GetReferencingObjectNames(
   UpdatableObjectList<MetadataQualifiedName> list,
   MetadataObject forObject,
   MetadataLoadingOptions loadingOptions
)
public: virtual System.bool GetReferencingObjectNames(
   UpdatableObjectList<MetadataQualifiedName*>* list,
   MetadataObject* forObject,
   MetadataLoadingOptions* loadingOptions
)

Parameters

list
forObject
loadingOptions
Requirements

See Also

Reference

BaseSyntaxProvider Class
BaseSyntaxProvider Members


LoadAggregates Method (BaseSyntaxProvider)

LoadAggregates Method (BaseSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSyntaxProvider Class : LoadAggregates Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadAggregates( _
   ByVal aggregates As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As BaseSyntaxProvider
Dim aggregates As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadAggregates(aggregates, loadingOptions)
public virtual void LoadAggregates(
   MetadataList aggregates,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadAggregates(
   MetadataList* aggregates,
   MetadataLoadingOptions* loadingOptions
)

Parameters

aggregates
loadingOptions
Requirements

See Also

Reference

BaseSyntaxProvider Class
BaseSyntaxProvider Members


ValidateQuery Method

ValidateQuery Method
Example

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSyntaxProvider Class : ValidateQuery Method
SQL query text.
SQL parsing error message string.
Validates the given SQL query for compliance with the rules of SQL syntax.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ValidateQuery( _
   ByVal sql As System.String, _
   ByRef errorInfo As System.String _
) As System.Boolean
'Usage

Dim instance As BaseSyntaxProvider
Dim sql As System.String
Dim errorInfo As System.String
Dim value As System.Boolean

value = instance.ValidateQuery(sql, errorInfo)
public System.bool ValidateQuery(
   System.string sql,
   ref System.string errorInfo
)
public: System.bool ValidateQuery(
   System.string* sql,
   ref System.string* errorInfo
)

Parameters

sql
SQL query text.
errorInfo
SQL parsing error message string.

Return Value

true if the query is valid; false otherwise.
Remarks
Please note that Active Query Builder does not perform validation against specific database context, i.e. presence of table fields, function parameters, constants, etc.
Example
Validates a query against rules of MS SQL Server syntax.
  • C#
MSSQLSyntaxProvider syntax = new MSSQLSyntaxProvider();
string errorInfo = "";

if (!syntax.ValidateQuery("select * from Orders", ref errorInfo))
{
   MessageBox.Show(errorInfo);
}
Requirements

See Also

Reference

BaseSyntaxProvider Class
BaseSyntaxProvider Members


BaseSyntaxProvider Class Properties

BaseSyntaxProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : BaseSyntaxProvider Class

For a list of all members of this type, see BaseSyntaxProvider members.

Public Properties
 | Name | Description
Public Property | Description | Gets description of the syntax provider class.
Public Property | DetectServerVersion | Instructs the component to detect database server version automatically.
Public Property | IdentCaseSens | Defines the way database server treats quoted and unquoted identifiers.
Public Property | QuoteBegin | Gets the symbol to start quotation of identifier.
Public Property | QuoteEnd | Gets the symbol to finish quotation of identifier.
Top
See Also

Reference

BaseSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Description Property (BaseSyntaxProvider)

Description Property (BaseSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSyntaxProvider Class : Description Property
Gets description of the syntax provider class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Description As System.String
'Usage

Dim instance As BaseSyntaxProvider
Dim value As System.String

value = instance.Description
public System.string Description {get;}
public: __property System.string* get_Description();
Requirements

See Also

Reference

BaseSyntaxProvider Class
BaseSyntaxProvider Members


DetectServerVersion Property

DetectServerVersion Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSyntaxProvider Class : DetectServerVersion Property
Instructs the component to detect database server version automatically.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property DetectServerVersion As System.Boolean
'Usage

Dim instance As BaseSyntaxProvider
Dim value As System.Boolean

instance.DetectServerVersion = value

value = instance.DetectServerVersion
public virtual System.bool DetectServerVersion {get; set;}
public: __property virtual System.bool get_DetectServerVersion();
public: __property virtual void set_DetectServerVersion(
   System.bool value
);
Requirements

See Also

Reference

BaseSyntaxProvider Class
BaseSyntaxProvider Members


IdentCaseSens Property (BaseSyntaxProvider)

IdentCaseSens Property (BaseSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSyntaxProvider Class : IdentCaseSens Property
Defines the way database server treats quoted and unquoted identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property IdentCaseSens As IdentCaseSensitivity
'Usage

Dim instance As BaseSyntaxProvider
Dim value As IdentCaseSensitivity

instance.IdentCaseSens = value

value = instance.IdentCaseSens
public virtual IdentCaseSensitivity IdentCaseSens {get; set;}
public: __property virtual IdentCaseSensitivity get_IdentCaseSens();
public: __property virtual void set_IdentCaseSens(
   IdentCaseSensitivity value
);
Requirements

See Also

Reference

BaseSyntaxProvider Class
BaseSyntaxProvider Members


QuoteBegin Property

QuoteBegin Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSyntaxProvider Class : QuoteBegin Property
Gets the symbol to start quotation of identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property QuoteBegin As System.String
'Usage

Dim instance As BaseSyntaxProvider
Dim value As System.String

value = instance.QuoteBegin
public System.string QuoteBegin {get;}
public: __property System.string* get_QuoteBegin();
Requirements

See Also

Reference

BaseSyntaxProvider Class
BaseSyntaxProvider Members


QuoteEnd Property

QuoteEnd Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSyntaxProvider Class : QuoteEnd Property
Gets the symbol to finish quotation of identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property QuoteEnd As System.String
'Usage

Dim instance As BaseSyntaxProvider
Dim value As System.String

value = instance.QuoteEnd
public System.string QuoteEnd {get;}
public: __property System.string* get_QuoteEnd();
Requirements

See Also

Reference

BaseSyntaxProvider Class
BaseSyntaxProvider Members


BehaviorOptions Class

BehaviorOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : BehaviorOptions Class
Allows you to tune the way Active Query Builder parses and builds SQL queries.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class BehaviorOptions
   Inherits UpdatablePersistent
'Usage

Dim instance As BehaviorOptions
public class BehaviorOptions : UpdatablePersistent
public __gc class BehaviorOptions : public UpdatablePersistent
Remarks
The ParsingErrorOnUnknownObjects and AllowSleepMode properties determine the way Active Query Builder process SQL query parsing errors.
The CreateLinksFromForeignKeys, LinkCompatibleTypesOnly and LinkManipulations properties define rules of working with links (joins) between query objects.
The AddLinkedObjects and DeleteUnusedObjects properties allow you to automate addition of necessary query objects and removing of needless ones.
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.BehaviorOptions

Requirements

See Also

Reference

BehaviorOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
BehaviorOptions Property


BehaviorOptions Class Members

BehaviorOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : BehaviorOptions Class

The following tables list the members exposed by BehaviorOptions.

Public Properties
 | Name | Description
Public Property | AddLinkedObjects | Instructs Query Builder to automatically add tables that required to link the newly added table to already existing tables in the query.
Public Property | AllowSleepMode | Allows to suppress parsing errors on unsupported SQL statements (CREATE TABLE, INSERT, UPDATE, DELETE, etc.).
Public Property | CreateColumnAliasesFromAltNames | Instructs the component to automatically create aliases for the fields with alternate names defined.
Public Property | CreateLinksByIdenticalFieldNames | Instructs the component to automatically create links (joins) in the query if objects with the same field names are added to the query.
Public Property | CreateLinksFromForeignKeys | Instructs the component to automatically create links (joins) in the query based on foreign keys information fetched from a database.
Public Property | CreateWhereJoinsByDefault | Instructs the component to create joins in WHERE clause instead of using ANSI joins.
Public Property | DeleteUnusedObjects | Instructs Query Builder to automatically remove tables that has no fields used in expressions and are no longer required to link tables in the query.
Public Property | FilterTabsByActiveQueryPart | Allows to hide the sub-query tabs that do not belong to the currently visible query part.
Public Property | LinkManipulations | Determines permissible end-user manipulations with links during the query building process.
Public Property | LoadJoinsFromWhereClause | Instructs the component to analyze WHERE clause of a query to find joins between objects and display them as links at the Design Pane.
Public Property | ParsingErrorOnUnknownObjects | Instructs the component to raise an error on parsing SQL queries with database objects not listed in the Metadata Container.
Public Property | UseAltNames | Instructs to display alternate names instead of real database object and field names in the Query Builder.
Top
See Also

Reference

BehaviorOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
BehaviorOptions Property


BehaviorOptions Class Properties

BehaviorOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : BehaviorOptions Class

For a list of all members of this type, see BehaviorOptions members.

Public Properties
 | Name | Description
Public Property | AddLinkedObjects | Instructs Query Builder to automatically add tables that required to link the newly added table to already existing tables in the query.
Public Property | AllowSleepMode | Allows to suppress parsing errors on unsupported SQL statements (CREATE TABLE, INSERT, UPDATE, DELETE, etc.).
Public Property | CreateColumnAliasesFromAltNames | Instructs the component to automatically create aliases for the fields with alternate names defined.
Public Property | CreateLinksByIdenticalFieldNames | Instructs the component to automatically create links (joins) in the query if objects with the same field names are added to the query.
Public Property | CreateLinksFromForeignKeys | Instructs the component to automatically create links (joins) in the query based on foreign keys information fetched from a database.
Public Property | CreateWhereJoinsByDefault | Instructs the component to create joins in WHERE clause instead of using ANSI joins.
Public Property | DeleteUnusedObjects | Instructs Query Builder to automatically remove tables that has no fields used in expressions and are no longer required to link tables in the query.
Public Property | FilterTabsByActiveQueryPart | Allows to hide the sub-query tabs that do not belong to the currently visible query part.
Public Property | LinkManipulations | Determines permissible end-user manipulations with links during the query building process.
Public Property | LoadJoinsFromWhereClause | Instructs the component to analyze WHERE clause of a query to find joins between objects and display them as links at the Design Pane.
Public Property | ParsingErrorOnUnknownObjects | Instructs the component to raise an error on parsing SQL queries with database objects not listed in the Metadata Container.
Public Property | UseAltNames | Instructs to display alternate names instead of real database object and field names in the Query Builder.
Top
See Also

Reference

BehaviorOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
BehaviorOptions Property


AddLinkedObjects Property

AddLinkedObjects Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BehaviorOptions Class : AddLinkedObjects Property
Instructs Query Builder to automatically add tables that required to link the newly added table to already existing tables in the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AddLinkedObjects As System.Boolean
'Usage

Dim instance As BehaviorOptions
Dim value As System.Boolean

instance.AddLinkedObjects = value

value = instance.AddLinkedObjects
public System.bool AddLinkedObjects {get; set;}
public: __property System.bool get_AddLinkedObjects();
public: __property void set_AddLinkedObjects(
   System.bool value
);
Remarks

For example, havnig three tables in the database linked with each other (Orders -> [Order Details] <- Products), the [Order Details] table will be added automatically after the user adds the Orders and the Products tables to the query.

Setting this property to true is necessary to work when Design Pane is hidden.

Requirements

See Also

Reference

BehaviorOptions Class
BehaviorOptions Members
DeleteUnusedObjects Property
DesignPaneVisible Property
ShowFields Property


AllowSleepMode Property

AllowSleepMode Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BehaviorOptions Class : AllowSleepMode Property
Allows to suppress parsing errors on unsupported SQL statements (CREATE TABLE, INSERT, UPDATE, DELETE, etc.).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AllowSleepMode As System.Boolean
'Usage

Dim instance As BehaviorOptions
Dim value As System.Boolean

instance.AllowSleepMode = value

value = instance.AllowSleepMode
public System.bool AllowSleepMode {get; set;}
public: __property System.bool get_AllowSleepMode();
public: __property void set_AllowSleepMode(
   System.bool value
);

Property Value

true allows to turns the component into "Sleep Mode" on parsing of unsupported SQL statements, false denies to do that.
Remarks
Setting this property to true is useful when you want to allow the end-user to write unsupported statements in the text editor.
Requirements

See Also

Reference

BehaviorOptions Class
BehaviorOptions Members
SleepModeChanged Event
QueryAwake Event
SleepMode Property


CreateColumnAliasesFromAltNames Property (BehaviorOptions)

CreateColumnAliasesFromAltNames Property (BehaviorOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BehaviorOptions Class : CreateColumnAliasesFromAltNames Property
Instructs the component to automatically create aliases for the fields with alternate names defined.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property CreateColumnAliasesFromAltNames As System.Boolean
'Usage

Dim instance As BehaviorOptions
Dim value As System.Boolean

instance.CreateColumnAliasesFromAltNames = value

value = instance.CreateColumnAliasesFromAltNames
public System.bool CreateColumnAliasesFromAltNames {get; set;}
public: __property System.bool get_CreateColumnAliasesFromAltNames();
public: __property void set_CreateColumnAliasesFromAltNames(
   System.bool value
);
Remarks
Setting this property to true will allow to have columns properly named in result dataset.
Requirements

See Also

Reference

BehaviorOptions Class
BehaviorOptions Members


CreateLinksByIdenticalFieldNames Property

CreateLinksByIdenticalFieldNames Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BehaviorOptions Class : CreateLinksByIdenticalFieldNames Property
Instructs the component to automatically create links (joins) in the query if objects with the same field names are added to the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property CreateLinksByIdenticalFieldNames As System.Boolean
'Usage

Dim instance As BehaviorOptions
Dim value As System.Boolean

instance.CreateLinksByIdenticalFieldNames = value

value = instance.CreateLinksByIdenticalFieldNames
public System.bool CreateLinksByIdenticalFieldNames {get; set;}
public: __property System.bool get_CreateLinksByIdenticalFieldNames();
public: __property void set_CreateLinksByIdenticalFieldNames(
   System.bool value
);
Requirements

See Also

Reference

BehaviorOptions Class
BehaviorOptions Members


CreateLinksFromForeignKeys Property

CreateLinksFromForeignKeys Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BehaviorOptions Class : CreateLinksFromForeignKeys Property
Instructs the component to automatically create links (joins) in the query based on foreign keys information fetched from a database.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property CreateLinksFromForeignKeys As System.Boolean
'Usage

Dim instance As BehaviorOptions
Dim value As System.Boolean

instance.CreateLinksFromForeignKeys = value

value = instance.CreateLinksFromForeignKeys
public System.bool CreateLinksFromForeignKeys {get; set;}
public: __property System.bool get_CreateLinksFromForeignKeys();
public: __property void set_CreateLinksFromForeignKeys(
   System.bool value
);
Requirements

See Also

Reference

BehaviorOptions Class
BehaviorOptions Members
LinkManipulations Property


CreateWhereJoinsByDefault Property

CreateWhereJoinsByDefault Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BehaviorOptions Class : CreateWhereJoinsByDefault Property
Instructs the component to create joins in WHERE clause instead of using ANSI joins.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property CreateWhereJoinsByDefault As System.Boolean
'Usage

Dim instance As BehaviorOptions
Dim value As System.Boolean

instance.CreateWhereJoinsByDefault = value

value = instance.CreateWhereJoinsByDefault
public System.bool CreateWhereJoinsByDefault {get; set;}
public: __property System.bool get_CreateWhereJoinsByDefault();
public: __property void set_CreateWhereJoinsByDefault(
   System.bool value
);
Remarks

Note that the ANSI joins still may be created if the user will make an OUTER JOIN as this join type can not be made in the WHERE clause.

For Oracle Database syntax, the component will create Oracle-style joins (+=, =+), except FULL OUTER JOIN.

Requirements

See Also

Reference

BehaviorOptions Class
BehaviorOptions Members


DeleteUnusedObjects Property

DeleteUnusedObjects Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BehaviorOptions Class : DeleteUnusedObjects Property
Instructs Query Builder to automatically remove tables that has no fields used in expressions and are no longer required to link tables in the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DeleteUnusedObjects As System.Boolean
'Usage

Dim instance As BehaviorOptions
Dim value As System.Boolean

instance.DeleteUnusedObjects = value

value = instance.DeleteUnusedObjects
public System.bool DeleteUnusedObjects {get; set;}
public: __property System.bool get_DeleteUnusedObjects();
public: __property void set_DeleteUnusedObjects(
   System.bool value
);
Remarks

For example, havnig three tables in the database linked with each other (Orders -> [Order Details] <- Products), the [Order Details] table with no fields selected will be removed automatically after the user removes the Orders or the Products table from the query.

Setting this property to true is necessary to work when Design Pane is hidden.

Requirements

See Also

Reference

BehaviorOptions Class
BehaviorOptions Members
AddLinkedObjects Property
DesignPaneVisible Property
ShowFields Property


FilterTabsByActiveQueryPart Property

FilterTabsByActiveQueryPart Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BehaviorOptions Class : FilterTabsByActiveQueryPart Property
Allows to hide the sub-query tabs that do not belong to the currently visible query part.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property FilterTabsByActiveQueryPart As QueryPart
'Usage

Dim instance As BehaviorOptions
Dim value As QueryPart

instance.FilterTabsByActiveQueryPart = value

value = instance.FilterTabsByActiveQueryPart
public QueryPart FilterTabsByActiveQueryPart {get; set;}
public: __property QueryPart get_FilterTabsByActiveQueryPart();
public: __property void set_FilterTabsByActiveQueryPart(
   QueryPart value
);
Requirements

See Also

Reference

BehaviorOptions Class
BehaviorOptions Members


LinkManipulations Property

LinkManipulations Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BehaviorOptions Class : LinkManipulations Property
Determines permissible end-user manipulations with links during the query building process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property LinkManipulations As LinkManipulations
'Usage

Dim instance As BehaviorOptions
Dim value As LinkManipulations

instance.LinkManipulations = value

value = instance.LinkManipulations
public LinkManipulations LinkManipulations {get; set;}
public: __property LinkManipulations get_LinkManipulations();
public: __property void set_LinkManipulations(
   LinkManipulations value
);
Remarks
This property is related to link creation and modification process only. If you want to deny links deletion, you should use the QueryBuilder.LinkDeleting event. Also you may specify custom permissions on creating a link using the LinkCreating and LinkDragOver events.
Requirements

See Also

Reference

BehaviorOptions Class
BehaviorOptions Members
CreateLinksFromForeignKeys Property


LoadJoinsFromWhereClause Property

LoadJoinsFromWhereClause Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BehaviorOptions Class : LoadJoinsFromWhereClause Property
Instructs the component to analyze WHERE clause of a query to find joins between objects and display them as links at the Design Pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property LoadJoinsFromWhereClause As System.Boolean
'Usage

Dim instance As BehaviorOptions
Dim value As System.Boolean

instance.LoadJoinsFromWhereClause = value

value = instance.LoadJoinsFromWhereClause
public System.bool LoadJoinsFromWhereClause {get; set;}
public: __property System.bool get_LoadJoinsFromWhereClause();
public: __property void set_LoadJoinsFromWhereClause(
   System.bool value
);
Remarks
Setting this property to false will instruct the component to add such joins to the Query Column List.
Requirements

See Also

Reference

BehaviorOptions Class
BehaviorOptions Members


ParsingErrorOnUnknownObjects Property

ParsingErrorOnUnknownObjects Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BehaviorOptions Class : ParsingErrorOnUnknownObjects Property
Instructs the component to raise an error on parsing SQL queries with database objects not listed in the Metadata Container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ParsingErrorOnUnknownObjects As System.Boolean
'Usage

Dim instance As BehaviorOptions
Dim value As System.Boolean

instance.ParsingErrorOnUnknownObjects = value

value = instance.ParsingErrorOnUnknownObjects
public System.bool ParsingErrorOnUnknownObjects {get; set;}
public: __property System.bool get_ParsingErrorOnUnknownObjects();
public: __property void set_ParsingErrorOnUnknownObjects(
   System.bool value
);
Requirements

See Also

Reference

BehaviorOptions Class
BehaviorOptions Members
SqlError Event


UseAltNames Property (BehaviorOptions)

UseAltNames Property (BehaviorOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BehaviorOptions Class : UseAltNames Property
Instructs to display alternate names instead of real database object and field names in the Query Builder.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property UseAltNames As System.Boolean
'Usage

Dim instance As BehaviorOptions
Dim value As System.Boolean

instance.UseAltNames = value

value = instance.UseAltNames
public System.bool UseAltNames {get; set;}
public: __property System.bool get_UseAltNames();
public: __property void set_UseAltNames(
   System.bool value
);

Property Value

Set this option to true to generate SQL query text for the end-user to modify or to save it between work sessions.
Set this option to false to generate SQL query text for execution against real database server.
Remarks

This property has no effect if alternate names aren't defined in the Metadata Container.

Use the SQL Builder's UseAltNames property to control generation of result SQL query text with or without alternate names.

Requirements

See Also

Reference

BehaviorOptions Class
BehaviorOptions Members
UseAltNames Property


DatabaseSchemaTreeOptions Class

DatabaseSchemaTreeOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DatabaseSchemaTreeOptions Class
Contains various options of the Database Schema Tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class DatabaseSchemaTreeOptions
   Inherits BatchUpdatableBase
'Usage

Dim instance As DatabaseSchemaTreeOptions
public class DatabaseSchemaTreeOptions : BatchUpdatableBase
public __gc class DatabaseSchemaTreeOptions : public BatchUpdatableBase
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.DatabaseSchemaTreeOptions

Requirements

See Also

Reference

DatabaseSchemaTreeOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
DatabaseSchemaTreeOptions Property


DatabaseSchemaTreeOptions Class Members

DatabaseSchemaTreeOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DatabaseSchemaTreeOptions Class

The following tables list the members exposed by DatabaseSchemaTreeOptions.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color for the Database Schema Tree Pane.
Public Property | DefaultExpandLevel | Determines the level of initial Database Schema Tree nodes expansion.
Public Property | Font | Gets or sets the font of the text displayed in the nodes of Database Schema Tree.
Public Property | SortingType | Defines order of database object nodes within a group.
Public Property | TextColor | Gets or sets the text color for the Database Schema Tree Pane.
Top
See Also

Reference

DatabaseSchemaTreeOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
DatabaseSchemaTreeOptions Property


DatabaseSchemaTreeOptions Class Properties

DatabaseSchemaTreeOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DatabaseSchemaTreeOptions Class

For a list of all members of this type, see DatabaseSchemaTreeOptions members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color for the Database Schema Tree Pane.
Public Property | DefaultExpandLevel | Determines the level of initial Database Schema Tree nodes expansion.
Public Property | Font | Gets or sets the font of the text displayed in the nodes of Database Schema Tree.
Public Property | SortingType | Defines order of database object nodes within a group.
Public Property | TextColor | Gets or sets the text color for the Database Schema Tree Pane.
Top
See Also

Reference

DatabaseSchemaTreeOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
DatabaseSchemaTreeOptions Property


BackColor Property (DatabaseSchemaTreeOptions)

BackColor Property (DatabaseSchemaTreeOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DatabaseSchemaTreeOptions Class : BackColor Property
Gets or sets the background color for the Database Schema Tree Pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property BackColor As System.Drawing.Color
'Usage

Dim instance As DatabaseSchemaTreeOptions
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
public System.Drawing.Color BackColor {get; set;}
public: __property System.Drawing.Color get_BackColor();
public: __property void set_BackColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

DatabaseSchemaTreeOptions Class
DatabaseSchemaTreeOptions Members


DefaultExpandLevel Property

DefaultExpandLevel Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DatabaseSchemaTreeOptions Class : DefaultExpandLevel Property
Determines the level of initial Database Schema Tree nodes expansion.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DefaultExpandLevel As System.Integer
'Usage

Dim instance As DatabaseSchemaTreeOptions
Dim value As System.Integer

instance.DefaultExpandLevel = value

value = instance.DefaultExpandLevel
public System.int DefaultExpandLevel {get; set;}
public: __property System.int get_DefaultExpandLevel();
public: __property void set_DefaultExpandLevel(
   System.int value
);

Property Value

Zero value instructs the component to show database schema tree collapsed; -1 value means full expansion of the tree. Positive values instructs the component to expand to the specified number of tree levels.
Requirements

See Also

Reference

DatabaseSchemaTreeOptions Class
DatabaseSchemaTreeOptions Members


Font Property (DatabaseSchemaTreeOptions)

Font Property (DatabaseSchemaTreeOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DatabaseSchemaTreeOptions Class : Font Property
Gets or sets the font of the text displayed in the nodes of Database Schema Tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Font As System.Drawing.Font
'Usage

Dim instance As DatabaseSchemaTreeOptions
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
public System.Drawing.Font Font {get; set;}
public: __property System.Drawing.Font* get_Font();
public: __property void set_Font(
   System.Drawing.Font* value
);
Requirements

See Also

Reference

DatabaseSchemaTreeOptions Class
DatabaseSchemaTreeOptions Members


SortingType Property (DatabaseSchemaTreeOptions)

SortingType Property (DatabaseSchemaTreeOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DatabaseSchemaTreeOptions Class : SortingType Property
Defines order of database object nodes within a group.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SortingType As ObjectsSortingType
'Usage

Dim instance As DatabaseSchemaTreeOptions
Dim value As ObjectsSortingType

instance.SortingType = value

value = instance.SortingType
public ObjectsSortingType SortingType {get; set;}
public: __property ObjectsSortingType get_SortingType();
public: __property void set_SortingType(
   ObjectsSortingType value
);
Requirements

See Also

Reference

DatabaseSchemaTreeOptions Class
DatabaseSchemaTreeOptions Members


TextColor Property (DatabaseSchemaTreeOptions)

TextColor Property (DatabaseSchemaTreeOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DatabaseSchemaTreeOptions Class : TextColor Property
Gets or sets the text color for the Database Schema Tree Pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property TextColor As System.Drawing.Color
'Usage

Dim instance As DatabaseSchemaTreeOptions
Dim value As System.Drawing.Color

instance.TextColor = value

value = instance.TextColor
public System.Drawing.Color TextColor {get; set;}
public: __property System.Drawing.Color get_TextColor();
public: __property void set_TextColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

DatabaseSchemaTreeOptions Class
DatabaseSchemaTreeOptions Members


DataSourceOptions Class

DataSourceOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DataSourceOptions Class
Determines appearance of the objects within the Design Pane.
Object Model
DataSourceOptions ClassFieldListDescriptionColumnOptions ClassFieldListMarkColumnOptions ClassFieldListNameColumnOptions ClassFieldListTypeColumnOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class DataSourceOptions
   Inherits UpdatablePersistent
'Usage

Dim instance As DataSourceOptions
public class DataSourceOptions : UpdatablePersistent
public __gc class DataSourceOptions : public UpdatablePersistent
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.DataSourceOptions

Requirements

See Also

Reference

DataSourceOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
DataSourceOptions Property


DataSourceOptions Class Members

DataSourceOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DataSourceOptions Class

The following tables list the members exposed by DataSourceOptions.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the background color for the DataSource objects.
Public Property | CollapseExpandButtonLocation | Determines location of the Collapse/Expand button.
Public Property | DefaultWidth | Determines width of a newly added datasource objects at the Design Pane.
Public Property | DescriptionColumnOptions | Contains various options for the Description column.
Public Property | FocusedBackgroundColor | Gets or sets the background color for the focused DataSource object.
Public Property | Font | Gets or sets the font of the text displayed by the control.
Public Property | HideAsteriskItem | Instructs the component to show/hide the asterisk item (*) as a first item in the field list.
Public Property | KeyFieldsFirst | Instructs to show primary key fields first regardless of the sorting type.
Public Property | MarkColumnOptions | Contains various options for the Mark (check box) column.
Public Property | MaxHeight | Determines maximum height of a datasource objects at the Design Pane. Zero means no constraint for this value.
Public Property | NameColumnOptions | Contains various options for the Name (field name) column.
Public Property | SelectedFieldsCountInCaption | Instructs to indicate the number of selected fields (checked items) in datasource's caption.
Public Property | ShowCollapseExpandButton | Instructs the component to show or hide the Collapse/Expand button at the bottom of each datasource.
Public Property | SortType |
Public Property | TypeColumnOptions | Contains various options for the Type (data type) column.
Top
See Also

Reference

DataSourceOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
DataSourceOptions Property


DataSourceOptions Class Properties

DataSourceOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DataSourceOptions Class

For a list of all members of this type, see DataSourceOptions members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the background color for the DataSource objects.
Public Property | CollapseExpandButtonLocation | Determines location of the Collapse/Expand button.
Public Property | DefaultWidth | Determines width of a newly added datasource objects at the Design Pane.
Public Property | DescriptionColumnOptions | Contains various options for the Description column.
Public Property | FocusedBackgroundColor | Gets or sets the background color for the focused DataSource object.
Public Property | Font | Gets or sets the font of the text displayed by the control.
Public Property | HideAsteriskItem | Instructs the component to show/hide the asterisk item (*) as a first item in the field list.
Public Property | KeyFieldsFirst | Instructs to show primary key fields first regardless of the sorting type.
Public Property | MarkColumnOptions | Contains various options for the Mark (check box) column.
Public Property | MaxHeight | Determines maximum height of a datasource objects at the Design Pane. Zero means no constraint for this value.
Public Property | NameColumnOptions | Contains various options for the Name (field name) column.
Public Property | SelectedFieldsCountInCaption | Instructs to indicate the number of selected fields (checked items) in datasource's caption.
Public Property | ShowCollapseExpandButton | Instructs the component to show or hide the Collapse/Expand button at the bottom of each datasource.
Public Property | SortType |
Public Property | TypeColumnOptions | Contains various options for the Type (data type) column.
Top
See Also

Reference

DataSourceOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
DataSourceOptions Property


BackgroundColor Property

BackgroundColor Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DataSourceOptions Class : BackgroundColor Property
Gets or sets the background color for the DataSource objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property BackgroundColor As System.Drawing.Color
'Usage

Dim instance As DataSourceOptions
Dim value As System.Drawing.Color

instance.BackgroundColor = value

value = instance.BackgroundColor
public System.Drawing.Color BackgroundColor {get; set;}
public: __property System.Drawing.Color get_BackgroundColor();
public: __property void set_BackgroundColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

DataSourceOptions Class
DataSourceOptions Members
FocusedBackgroundColor Property


CollapseExpandButtonLocation Property

CollapseExpandButtonLocation Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DataSourceOptions Class : CollapseExpandButtonLocation Property
Determines location of the Collapse/Expand button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property CollapseExpandButtonLocation As CollapseExpandButtonLocation
'Usage

Dim instance As DataSourceOptions
Dim value As CollapseExpandButtonLocation

instance.CollapseExpandButtonLocation = value

value = instance.CollapseExpandButtonLocation
public CollapseExpandButtonLocation CollapseExpandButtonLocation {get; set;}
public: __property CollapseExpandButtonLocation get_CollapseExpandButtonLocation();
public: __property void set_CollapseExpandButtonLocation(
   CollapseExpandButtonLocation value
);

Property Value

Top instructs to place the button at the top of each datasource; Bottom instructs to place the button at the bottom.
Requirements

See Also

Reference

DataSourceOptions Class
DataSourceOptions Members
ShowCollapseExpandButton Property


DefaultWidth Property

DefaultWidth Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DataSourceOptions Class : DefaultWidth Property
Determines width of a newly added datasource objects at the Design Pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DefaultWidth As System.Integer
'Usage

Dim instance As DataSourceOptions
Dim value As System.Integer

instance.DefaultWidth = value

value = instance.DefaultWidth
public System.int DefaultWidth {get; set;}
public: __property System.int get_DefaultWidth();
public: __property void set_DefaultWidth(
   System.int value
);
Requirements

See Also

Reference

DataSourceOptions Class
DataSourceOptions Members
MaxHeight Property


DescriptionColumnOptions Property (DataSourceOptions)

DescriptionColumnOptions Property (DataSourceOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DataSourceOptions Class : DescriptionColumnOptions Property
Contains various options for the Description column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DescriptionColumnOptions As FieldListDescriptionColumnOptions
'Usage

Dim instance As DataSourceOptions
Dim value As FieldListDescriptionColumnOptions

instance.DescriptionColumnOptions = value

value = instance.DescriptionColumnOptions
public FieldListDescriptionColumnOptions DescriptionColumnOptions {get; set;}
public: __property FieldListDescriptionColumnOptions* get_DescriptionColumnOptions();
public: __property void set_DescriptionColumnOptions(
   FieldListDescriptionColumnOptions* value
);
Requirements

See Also

Reference

DataSourceOptions Class
DataSourceOptions Members


FocusedBackgroundColor Property

FocusedBackgroundColor Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DataSourceOptions Class : FocusedBackgroundColor Property
Gets or sets the background color for the focused DataSource object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property FocusedBackgroundColor As System.Drawing.Color
'Usage

Dim instance As DataSourceOptions
Dim value As System.Drawing.Color

instance.FocusedBackgroundColor = value

value = instance.FocusedBackgroundColor
public System.Drawing.Color FocusedBackgroundColor {get; set;}
public: __property System.Drawing.Color get_FocusedBackgroundColor();
public: __property void set_FocusedBackgroundColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

DataSourceOptions Class
DataSourceOptions Members
BackgroundColor Property


Font Property (DataSourceOptions)

Font Property (DataSourceOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DataSourceOptions Class : Font Property
Gets or sets the font of the text displayed by the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Font As System.Drawing.Font
'Usage

Dim instance As DataSourceOptions
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
public System.Drawing.Font Font {get; set;}
public: __property System.Drawing.Font* get_Font();
public: __property void set_Font(
   System.Drawing.Font* value
);
Requirements

See Also

Reference

DataSourceOptions Class
DataSourceOptions Members


HideAsteriskItem Property (DataSourceOptions)

HideAsteriskItem Property (DataSourceOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DataSourceOptions Class : HideAsteriskItem Property
Instructs the component to show/hide the asterisk item (*) as a first item in the field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property HideAsteriskItem As System.Boolean
'Usage

Dim instance As DataSourceOptions
Dim value As System.Boolean

instance.HideAsteriskItem = value

value = instance.HideAsteriskItem
public System.bool HideAsteriskItem {get; set;}
public: __property System.bool get_HideAsteriskItem();
public: __property void set_HideAsteriskItem(
   System.bool value
);
Requirements

See Also

Reference

DataSourceOptions Class
DataSourceOptions Members


KeyFieldsFirst Property (DataSourceOptions)

KeyFieldsFirst Property (DataSourceOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DataSourceOptions Class : KeyFieldsFirst Property
Instructs to show primary key fields first regardless of the sorting type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property KeyFieldsFirst As System.Boolean
'Usage

Dim instance As DataSourceOptions
Dim value As System.Boolean

instance.KeyFieldsFirst = value

value = instance.KeyFieldsFirst
public System.bool KeyFieldsFirst {get; set;}
public: __property System.bool get_KeyFieldsFirst();
public: __property void set_KeyFieldsFirst(
   System.bool value
);
Requirements

See Also

Reference

DataSourceOptions Class
DataSourceOptions Members
SortType Property


MarkColumnOptions Property (DataSourceOptions)

MarkColumnOptions Property (DataSourceOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DataSourceOptions Class : MarkColumnOptions Property
Contains various options for the Mark (check box) column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property MarkColumnOptions As FieldListMarkColumnOptions
'Usage

Dim instance As DataSourceOptions
Dim value As FieldListMarkColumnOptions

instance.MarkColumnOptions = value

value = instance.MarkColumnOptions
public FieldListMarkColumnOptions MarkColumnOptions {get; set;}
public: __property FieldListMarkColumnOptions* get_MarkColumnOptions();
public: __property void set_MarkColumnOptions(
   FieldListMarkColumnOptions* value
);
Requirements

See Also

Reference

DataSourceOptions Class
DataSourceOptions Members


MaxHeight Property

MaxHeight Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DataSourceOptions Class : MaxHeight Property
Determines maximum height of a datasource objects at the Design Pane. Zero means no constraint for this value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property MaxHeight As System.Integer
'Usage

Dim instance As DataSourceOptions
Dim value As System.Integer

instance.MaxHeight = value

value = instance.MaxHeight
public System.int MaxHeight {get; set;}
public: __property System.int get_MaxHeight();
public: __property void set_MaxHeight(
   System.int value
);
Requirements

See Also

Reference

DataSourceOptions Class
DataSourceOptions Members
DefaultWidth Property


NameColumnOptions Property (DataSourceOptions)

NameColumnOptions Property (DataSourceOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DataSourceOptions Class : NameColumnOptions Property
Contains various options for the Name (field name) column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property NameColumnOptions As FieldListNameColumnOptions
'Usage

Dim instance As DataSourceOptions
Dim value As FieldListNameColumnOptions

instance.NameColumnOptions = value

value = instance.NameColumnOptions
public FieldListNameColumnOptions NameColumnOptions {get; set;}
public: __property FieldListNameColumnOptions* get_NameColumnOptions();
public: __property void set_NameColumnOptions(
   FieldListNameColumnOptions* value
);
Requirements

See Also

Reference

DataSourceOptions Class
DataSourceOptions Members


SelectedFieldsCountInCaption Property

SelectedFieldsCountInCaption Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DataSourceOptions Class : SelectedFieldsCountInCaption Property
Instructs to indicate the number of selected fields (checked items) in datasource's caption.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SelectedFieldsCountInCaption As System.Boolean
'Usage

Dim instance As DataSourceOptions
Dim value As System.Boolean

instance.SelectedFieldsCountInCaption = value

value = instance.SelectedFieldsCountInCaption
public System.bool SelectedFieldsCountInCaption {get; set;}
public: __property System.bool get_SelectedFieldsCountInCaption();
public: __property void set_SelectedFieldsCountInCaption(
   System.bool value
);
Requirements

See Also

Reference

DataSourceOptions Class
DataSourceOptions Members


ShowCollapseExpandButton Property

ShowCollapseExpandButton Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DataSourceOptions Class : ShowCollapseExpandButton Property
Instructs the component to show or hide the Collapse/Expand button at the bottom of each datasource.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ShowCollapseExpandButton As System.Boolean
'Usage

Dim instance As DataSourceOptions
Dim value As System.Boolean

instance.ShowCollapseExpandButton = value

value = instance.ShowCollapseExpandButton
public System.bool ShowCollapseExpandButton {get; set;}
public: __property System.bool get_ShowCollapseExpandButton();
public: __property void set_ShowCollapseExpandButton(
   System.bool value
);
Requirements

See Also

Reference

DataSourceOptions Class
DataSourceOptions Members


SortType Property (DataSourceOptions)

SortType Property (DataSourceOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DataSourceOptions Class : SortType Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SortType As FieldListSortType
'Usage

Dim instance As DataSourceOptions
Dim value As FieldListSortType

instance.SortType = value

value = instance.SortType
public FieldListSortType SortType {get; set;}
public: __property FieldListSortType get_SortType();
public: __property void set_SortType(
   FieldListSortType value
);
Requirements

See Also

Reference

DataSourceOptions Class
DataSourceOptions Members


TypeColumnOptions Property (DataSourceOptions)

TypeColumnOptions Property (DataSourceOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DataSourceOptions Class : TypeColumnOptions Property
Contains various options for the Type (data type) column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property TypeColumnOptions As FieldListTypeColumnOptions
'Usage

Dim instance As DataSourceOptions
Dim value As FieldListTypeColumnOptions

instance.TypeColumnOptions = value

value = instance.TypeColumnOptions
public FieldListTypeColumnOptions TypeColumnOptions {get; set;}
public: __property FieldListTypeColumnOptions* get_TypeColumnOptions();
public: __property void set_TypeColumnOptions(
   FieldListTypeColumnOptions* value
);
Requirements

See Also

Reference

DataSourceOptions Class
DataSourceOptions Members


DB2SyntaxProvider Class

DB2SyntaxProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DB2SyntaxProvider Class
Syntax provider for IBM DB2 database.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class DB2SyntaxProvider
   Inherits BaseSyntaxProvider
'Usage

Dim instance As DB2SyntaxProvider
public class DB2SyntaxProvider : BaseSyntaxProvider
public __gc class DB2SyntaxProvider : public BaseSyntaxProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.DB2SyntaxProvider

Requirements

See Also

Reference

DB2SyntaxProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


DB2SyntaxProvider Class Members

DB2SyntaxProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DB2SyntaxProvider Class

The following tables list the members exposed by DB2SyntaxProvider.

Public Properties
 | Name | Description
Public Property | NamingConvention | Gets or sets database objects naming convention.
Top
Public Methods
 | Name | Description
Public Method | GetReferencingObjectNames | Overridden.
Public Method | LoadDatabases | Overridden.
Public Method | LoadFields | Overridden.
Public Method | LoadForeignKeys | Overridden.
Public Method | LoadObjects | Overridden.
Public Method | LoadSchemas | Overridden.
Top
See Also

Reference

DB2SyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


DB2SyntaxProvider Class Methods

DB2SyntaxProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DB2SyntaxProvider Class

For a list of all members of this type, see DB2SyntaxProvider members.

Public Methods
 | Name | Description
Public Method | GetReferencingObjectNames | Overridden.
Public Method | LoadDatabases | Overridden.
Public Method | LoadFields | Overridden.
Public Method | LoadForeignKeys | Overridden.
Public Method | LoadObjects | Overridden.
Public Method | LoadSchemas | Overridden.
Top
See Also

Reference

DB2SyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


GetReferencingObjectNames Method (DB2SyntaxProvider)

GetReferencingObjectNames Method (DB2SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2SyntaxProvider Class : GetReferencingObjectNames Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Function GetReferencingObjectNames( _
   ByVal list As UpdatableObjectList(Of MetadataQualifiedName), _
   ByVal forObject As MetadataObject, _
   ByVal loadingOptions As MetadataLoadingOptions _
) As System.Boolean
'Usage

Dim instance As DB2SyntaxProvider
Dim list As UpdatableObjectList(Of MetadataQualifiedName)
Dim forObject As MetadataObject
Dim loadingOptions As MetadataLoadingOptions
Dim value As System.Boolean

value = instance.GetReferencingObjectNames(list, forObject, loadingOptions)
public override System.bool GetReferencingObjectNames(
   UpdatableObjectList<MetadataQualifiedName> list,
   MetadataObject forObject,
   MetadataLoadingOptions loadingOptions
)
public: System.bool GetReferencingObjectNames(
   UpdatableObjectList<MetadataQualifiedName*>* list,
   MetadataObject* forObject,
   MetadataLoadingOptions* loadingOptions
) override

Parameters

list
forObject
loadingOptions
Requirements

See Also

Reference

DB2SyntaxProvider Class
DB2SyntaxProvider Members
Base Implementation in GetReferencingObjectNames


LoadDatabases Method (DB2SyntaxProvider)

LoadDatabases Method (DB2SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2SyntaxProvider Class : LoadDatabases Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Sub LoadDatabases( _
   ByVal databases As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As DB2SyntaxProvider
Dim databases As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadDatabases(databases, loadingOptions)
public override void LoadDatabases(
   MetadataList databases,
   MetadataLoadingOptions loadingOptions
)
public: void LoadDatabases(
   MetadataList* databases,
   MetadataLoadingOptions* loadingOptions
) override

Parameters

databases
loadingOptions
Requirements

See Also

Reference

DB2SyntaxProvider Class
DB2SyntaxProvider Members
Base Implementation in LoadDatabases


LoadFields Method (DB2SyntaxProvider)

LoadFields Method (DB2SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2SyntaxProvider Class : LoadFields Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Sub LoadFields( _
   ByVal fields As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As DB2SyntaxProvider
Dim fields As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadFields(fields, loadingOptions)
public override void LoadFields(
   MetadataList fields,
   MetadataLoadingOptions loadingOptions
)
public: void LoadFields(
   MetadataList* fields,
   MetadataLoadingOptions* loadingOptions
) override

Parameters

fields
loadingOptions
Requirements

See Also

Reference

DB2SyntaxProvider Class
DB2SyntaxProvider Members
Base Implementation in LoadFields


LoadForeignKeys Method (DB2SyntaxProvider)

LoadForeignKeys Method (DB2SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2SyntaxProvider Class : LoadForeignKeys Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Sub LoadForeignKeys( _
   ByVal foreignKeys As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As DB2SyntaxProvider
Dim foreignKeys As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadForeignKeys(foreignKeys, loadingOptions)
public override void LoadForeignKeys(
   MetadataList foreignKeys,
   MetadataLoadingOptions loadingOptions
)
public: void LoadForeignKeys(
   MetadataList* foreignKeys,
   MetadataLoadingOptions* loadingOptions
) override

Parameters

foreignKeys
loadingOptions
Requirements

See Also

Reference

DB2SyntaxProvider Class
DB2SyntaxProvider Members
Base Implementation in LoadForeignKeys


LoadObjects Method (DB2SyntaxProvider)

LoadObjects Method (DB2SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2SyntaxProvider Class : LoadObjects Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Function LoadObjects( _
   ByVal objects As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
) As System.Boolean
'Usage

Dim instance As DB2SyntaxProvider
Dim objects As MetadataList
Dim loadingOptions As MetadataLoadingOptions
Dim value As System.Boolean

value = instance.LoadObjects(objects, loadingOptions)
public override System.bool LoadObjects(
   MetadataList objects,
   MetadataLoadingOptions loadingOptions
)
public: System.bool LoadObjects(
   MetadataList* objects,
   MetadataLoadingOptions* loadingOptions
) override

Parameters

objects
loadingOptions
Requirements

See Also

Reference

DB2SyntaxProvider Class
DB2SyntaxProvider Members
Base Implementation in LoadObjects


LoadSchemas Method (DB2SyntaxProvider)

LoadSchemas Method (DB2SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2SyntaxProvider Class : LoadSchemas Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Sub LoadSchemas( _
   ByVal schemas As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As DB2SyntaxProvider
Dim schemas As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadSchemas(schemas, loadingOptions)
public override void LoadSchemas(
   MetadataList schemas,
   MetadataLoadingOptions loadingOptions
)
public: void LoadSchemas(
   MetadataList* schemas,
   MetadataLoadingOptions* loadingOptions
) override

Parameters

schemas
loadingOptions
Requirements

See Also

Reference

DB2SyntaxProvider Class
DB2SyntaxProvider Members
Base Implementation in LoadSchemas


DB2SyntaxProvider Class Properties

DB2SyntaxProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DB2SyntaxProvider Class

For a list of all members of this type, see DB2SyntaxProvider members.

Public Properties
 | Name | Description
Public Property | NamingConvention | Gets or sets database objects naming convention.
Top
See Also

Reference

DB2SyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


NamingConvention Property

NamingConvention Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2SyntaxProvider Class : NamingConvention Property
Gets or sets database objects naming convention.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property NamingConvention As DB2NamingConventions
'Usage

Dim instance As DB2SyntaxProvider
Dim value As DB2NamingConventions

instance.NamingConvention = value

value = instance.NamingConvention
public DB2NamingConventions NamingConvention {get; set;}
public: __property DB2NamingConventions get_NamingConvention();
public: __property void set_NamingConvention(
   DB2NamingConventions value
);
Requirements

See Also

Reference

DB2SyntaxProvider Class
DB2SyntaxProvider Members


DesignPaneOptions Class

DesignPaneOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DesignPaneOptions Class
Contains various properties of Design Pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class DesignPaneOptions
   Inherits UpdatablePersistent
'Usage

Dim instance As DesignPaneOptions
public class DesignPaneOptions : UpdatablePersistent
public __gc class DesignPaneOptions : public UpdatablePersistent
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.DesignPaneOptions

Requirements

See Also

Reference

DesignPaneOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
DesignPaneOptions Property


DesignPaneOptions Class Members

DesignPaneOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DesignPaneOptions Class

The following tables list the members exposed by DesignPaneOptions.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color for the Design Pane.
Public Property | GridSize | Enables or disables whether objects at the Design Pane are automatically placed at grid coordinates.
Public Property | LinkStyle | Determines style of links between objects at Design Pane.
Public Property | SnapToGrid | Determines the size of each square of the grid used for snapping of the objects at Design Pane.
Top
See Also

Reference

DesignPaneOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
DesignPaneOptions Property


DesignPaneOptions Class Properties

DesignPaneOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DesignPaneOptions Class

For a list of all members of this type, see DesignPaneOptions members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color for the Design Pane.
Public Property | GridSize | Enables or disables whether objects at the Design Pane are automatically placed at grid coordinates.
Public Property | LinkStyle | Determines style of links between objects at Design Pane.
Public Property | SnapToGrid | Determines the size of each square of the grid used for snapping of the objects at Design Pane.
Top
See Also

Reference

DesignPaneOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
DesignPaneOptions Property


BackColor Property (DesignPaneOptions)

BackColor Property (DesignPaneOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DesignPaneOptions Class : BackColor Property
Gets or sets the background color for the Design Pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property BackColor As System.Drawing.Color
'Usage

Dim instance As DesignPaneOptions
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
public System.Drawing.Color BackColor {get; set;}
public: __property System.Drawing.Color get_BackColor();
public: __property void set_BackColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

DesignPaneOptions Class
DesignPaneOptions Members


GridSize Property

GridSize Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DesignPaneOptions Class : GridSize Property
Enables or disables whether objects at the Design Pane are automatically placed at grid coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property GridSize As System.Integer
'Usage

Dim instance As DesignPaneOptions
Dim value As System.Integer

instance.GridSize = value

value = instance.GridSize
public System.int GridSize {get; set;}
public: __property System.int get_GridSize();
public: __property void set_GridSize(
   System.int value
);
Requirements

See Also

Reference

DesignPaneOptions Class
DesignPaneOptions Members
SnapToGrid Property


LinkStyle Property

LinkStyle Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DesignPaneOptions Class : LinkStyle Property
Determines style of links between objects at Design Pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property LinkStyle As LinkPainter
'Usage

Dim instance As DesignPaneOptions
Dim value As LinkPainter

instance.LinkStyle = value

value = instance.LinkStyle
public LinkPainter LinkStyle {get; set;}
public: __property LinkPainter* get_LinkStyle();
public: __property void set_LinkStyle(
   LinkPainter* value
);
Remarks

You may choose from one of the following styles:

  • Simple style: circles are displayed at the ends of line in case of INNER join type; arrows replace circles in case of OUTER join types.
  • MS Access style: no markers are displayed at the ends of line in case of INNER join type; arrows are added to appropriate ends of line in case or OUTER joins. Also "1" and infinity signs are shown above the ends of line if this join has a corresponding foreign key relationship loaded from database to the Metadata Container.
  • SQL Server Management Studio style: a diamond is displayed in the middle of line in case of INNER join type; a rectangle is added to it at appropriate side of line in case of OUTER join types.
Requirements

See Also

Reference

DesignPaneOptions Class
DesignPaneOptions Members


SnapToGrid Property

SnapToGrid Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DesignPaneOptions Class : SnapToGrid Property
Determines the size of each square of the grid used for snapping of the objects at Design Pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SnapToGrid As System.Boolean
'Usage

Dim instance As DesignPaneOptions
Dim value As System.Boolean

instance.SnapToGrid = value

value = instance.SnapToGrid
public System.bool SnapToGrid {get; set;}
public: __property System.bool get_SnapToGrid();
public: __property void set_SnapToGrid(
   System.bool value
);
Requirements

See Also

Reference

DesignPaneOptions Class
DesignPaneOptions Members
GridSize Property


FieldListBaseColumnOptions Class

FieldListBaseColumnOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FieldListBaseColumnOptions Class
Base class for all columns in the datasource field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class FieldListBaseColumnOptions
   Inherits UpdatablePersistent
'Usage

Dim instance As FieldListBaseColumnOptions
public class FieldListBaseColumnOptions : UpdatablePersistent
public __gc class FieldListBaseColumnOptions : public UpdatablePersistent
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.FieldListBaseColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.FieldListDescriptionColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.FieldListMarkColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.FieldListNameColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.FieldListTypeColumnOptions

Requirements

See Also

Reference

FieldListBaseColumnOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


FieldListBaseColumnOptions Class Members

FieldListBaseColumnOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FieldListBaseColumnOptions Class

The following tables list the members exposed by FieldListBaseColumnOptions.

Public Properties
 | Name | Description
Public Property | DrawOrder | Defines order in which the column should be shown in the field list.
Public Property | Margin | Specifies left margin of the column.
Public Property | Postfix | Allows to add postfix to the column text. Can be used to add closing bracket or parenthesis.
Public Property | Prefix | Allows to add prefix to the column text. Can be used to add opening bracket or parenthesis.
Public Property | Visible | Determines visibility of the column.
Public Property | Width | Gets or sets width of the column.
Top
See Also

Reference

FieldListBaseColumnOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


FieldListBaseColumnOptions Class Properties

FieldListBaseColumnOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FieldListBaseColumnOptions Class

For a list of all members of this type, see FieldListBaseColumnOptions members.

Public Properties
 | Name | Description
Public Property | DrawOrder | Defines order in which the column should be shown in the field list.
Public Property | Margin | Specifies left margin of the column.
Public Property | Postfix | Allows to add postfix to the column text. Can be used to add closing bracket or parenthesis.
Public Property | Prefix | Allows to add prefix to the column text. Can be used to add opening bracket or parenthesis.
Public Property | Visible | Determines visibility of the column.
Public Property | Width | Gets or sets width of the column.
Top
See Also

Reference

FieldListBaseColumnOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


DrawOrder Property (FieldListBaseColumnOptions)

DrawOrder Property (FieldListBaseColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListBaseColumnOptions Class : DrawOrder Property
Defines order in which the column should be shown in the field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property DrawOrder As System.Integer
'Usage

Dim instance As FieldListBaseColumnOptions
Dim value As System.Integer

instance.DrawOrder = value

value = instance.DrawOrder
public virtual System.int DrawOrder {get; set;}
public: __property virtual System.int get_DrawOrder();
public: __property virtual void set_DrawOrder(
   System.int value
);
Requirements

See Also

Reference

FieldListBaseColumnOptions Class
FieldListBaseColumnOptions Members


Margin Property (FieldListBaseColumnOptions)

Margin Property (FieldListBaseColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListBaseColumnOptions Class : Margin Property
Specifies left margin of the column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Margin As System.Integer
'Usage

Dim instance As FieldListBaseColumnOptions
Dim value As System.Integer

instance.Margin = value

value = instance.Margin
public virtual System.int Margin {get; set;}
public: __property virtual System.int get_Margin();
public: __property virtual void set_Margin(
   System.int value
);
Requirements

See Also

Reference

FieldListBaseColumnOptions Class
FieldListBaseColumnOptions Members


Postfix Property (FieldListBaseColumnOptions)

Postfix Property (FieldListBaseColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListBaseColumnOptions Class : Postfix Property
Allows to add postfix to the column text. Can be used to add closing bracket or parenthesis.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Postfix As System.String
'Usage

Dim instance As FieldListBaseColumnOptions
Dim value As System.String

instance.Postfix = value

value = instance.Postfix
public System.string Postfix {get; set;}
public: __property System.string* get_Postfix();
public: __property void set_Postfix(
   System.string* value
);
Requirements

See Also

Reference

FieldListBaseColumnOptions Class
FieldListBaseColumnOptions Members


Prefix Property (FieldListBaseColumnOptions)

Prefix Property (FieldListBaseColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListBaseColumnOptions Class : Prefix Property
Allows to add prefix to the column text. Can be used to add opening bracket or parenthesis.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Prefix As System.String
'Usage

Dim instance As FieldListBaseColumnOptions
Dim value As System.String

instance.Prefix = value

value = instance.Prefix
public System.string Prefix {get; set;}
public: __property System.string* get_Prefix();
public: __property void set_Prefix(
   System.string* value
);
Requirements

See Also

Reference

FieldListBaseColumnOptions Class
FieldListBaseColumnOptions Members


Visible Property (FieldListBaseColumnOptions)

Visible Property (FieldListBaseColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListBaseColumnOptions Class : Visible Property
Determines visibility of the column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Visible As System.Boolean
'Usage

Dim instance As FieldListBaseColumnOptions
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
public virtual System.bool Visible {get; set;}
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
Requirements

See Also

Reference

FieldListBaseColumnOptions Class
FieldListBaseColumnOptions Members


Width Property (FieldListBaseColumnOptions)

Width Property (FieldListBaseColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListBaseColumnOptions Class : Width Property
Gets or sets width of the column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Width As System.Integer
'Usage

Dim instance As FieldListBaseColumnOptions
Dim value As System.Integer

instance.Width = value

value = instance.Width
public virtual System.int Width {get; set;}
public: __property virtual System.int get_Width();
public: __property virtual void set_Width(
   System.int value
);
Requirements

See Also

Reference

FieldListBaseColumnOptions Class
FieldListBaseColumnOptions Members


FieldListDescriptionColumnOptions Class

FieldListDescriptionColumnOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FieldListDescriptionColumnOptions Class
Defines various options of the Description column in the field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class FieldListDescriptionColumnOptions
   Inherits FieldListBaseColumnOptions
'Usage

Dim instance As FieldListDescriptionColumnOptions
public class FieldListDescriptionColumnOptions : FieldListBaseColumnOptions
public __gc class FieldListDescriptionColumnOptions : public FieldListBaseColumnOptions
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.FieldListBaseColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.FieldListDescriptionColumnOptions

Requirements

See Also

Reference

FieldListDescriptionColumnOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


FieldListDescriptionColumnOptions Class Members

FieldListDescriptionColumnOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FieldListDescriptionColumnOptions Class

The following tables list the members exposed by FieldListDescriptionColumnOptions.

Public Properties
 | Name | Description
Public Property | Color | Gets or sets font color of the text.
Public Property | DrawOrder | Overridden. Defines order in which the column should be shown in the field list.
Public Property | FontStyle | Gets or sets font style of the text.
Public Property | Margin | Overridden. Specifies left margin of the column.
Public Property | Visible | Overridden. Determines visibility of the column.
Top
See Also

Reference

FieldListDescriptionColumnOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


FieldListDescriptionColumnOptions Class Properties

FieldListDescriptionColumnOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FieldListDescriptionColumnOptions Class

For a list of all members of this type, see FieldListDescriptionColumnOptions members.

Public Properties
 | Name | Description
Public Property | Color | Gets or sets font color of the text.
Public Property | DrawOrder | Overridden. Defines order in which the column should be shown in the field list.
Public Property | FontStyle | Gets or sets font style of the text.
Public Property | Margin | Overridden. Specifies left margin of the column.
Public Property | Visible | Overridden. Determines visibility of the column.
Top
See Also

Reference

FieldListDescriptionColumnOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Color Property (FieldListDescriptionColumnOptions)

Color Property (FieldListDescriptionColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListDescriptionColumnOptions Class : Color Property
Gets or sets font color of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Color As System.Drawing.Color
'Usage

Dim instance As FieldListDescriptionColumnOptions
Dim value As System.Drawing.Color

instance.Color = value

value = instance.Color
public System.Drawing.Color Color {get; set;}
public: __property System.Drawing.Color get_Color();
public: __property void set_Color(
   System.Drawing.Color value
);
Requirements

See Also

Reference

FieldListDescriptionColumnOptions Class
FieldListDescriptionColumnOptions Members


DrawOrder Property (FieldListDescriptionColumnOptions)

DrawOrder Property (FieldListDescriptionColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListDescriptionColumnOptions Class : DrawOrder Property
Defines order in which the column should be shown in the field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property DrawOrder As System.Integer
'Usage

Dim instance As FieldListDescriptionColumnOptions
Dim value As System.Integer

instance.DrawOrder = value

value = instance.DrawOrder
public override System.int DrawOrder {get; set;}
public: __property System.int get_DrawOrder() override;
public: __property void set_DrawOrder(
   System.int value
) override;
Requirements

See Also

Reference

FieldListDescriptionColumnOptions Class
FieldListDescriptionColumnOptions Members
Base Implementation in DrawOrder


FontStyle Property (FieldListDescriptionColumnOptions)

FontStyle Property (FieldListDescriptionColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListDescriptionColumnOptions Class : FontStyle Property
Gets or sets font style of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property FontStyle As System.Drawing.FontStyle
'Usage

Dim instance As FieldListDescriptionColumnOptions
Dim value As System.Drawing.FontStyle

instance.FontStyle = value

value = instance.FontStyle
public System.Drawing.FontStyle FontStyle {get; set;}
public: __property System.Drawing.FontStyle get_FontStyle();
public: __property void set_FontStyle(
   System.Drawing.FontStyle value
);
Requirements

See Also

Reference

FieldListDescriptionColumnOptions Class
FieldListDescriptionColumnOptions Members


Margin Property (FieldListDescriptionColumnOptions)

Margin Property (FieldListDescriptionColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListDescriptionColumnOptions Class : Margin Property
Specifies left margin of the column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property Margin As System.Integer
'Usage

Dim instance As FieldListDescriptionColumnOptions
Dim value As System.Integer

instance.Margin = value

value = instance.Margin
public override System.int Margin {get; set;}
public: __property System.int get_Margin() override;
public: __property void set_Margin(
   System.int value
) override;
Requirements

See Also

Reference

FieldListDescriptionColumnOptions Class
FieldListDescriptionColumnOptions Members
Base Implementation in Margin


Visible Property (FieldListDescriptionColumnOptions)

Visible Property (FieldListDescriptionColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListDescriptionColumnOptions Class : Visible Property
Determines visibility of the column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property Visible As System.Boolean
'Usage

Dim instance As FieldListDescriptionColumnOptions
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
public override System.bool Visible {get; set;}
public: __property System.bool get_Visible() override;
public: __property void set_Visible(
   System.bool value
) override;
Requirements

See Also

Reference

FieldListDescriptionColumnOptions Class
FieldListDescriptionColumnOptions Members
Base Implementation in Visible


FieldListMarkColumnOptions Class

FieldListMarkColumnOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FieldListMarkColumnOptions Class
Defines various options of the Mark column in the field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class FieldListMarkColumnOptions
   Inherits FieldListBaseColumnOptions
'Usage

Dim instance As FieldListMarkColumnOptions
public class FieldListMarkColumnOptions : FieldListBaseColumnOptions
public __gc class FieldListMarkColumnOptions : public FieldListBaseColumnOptions
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.FieldListBaseColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.FieldListMarkColumnOptions

Requirements

See Also

Reference

FieldListMarkColumnOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


FieldListMarkColumnOptions Class Members

FieldListMarkColumnOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FieldListMarkColumnOptions Class

The following tables list the members exposed by FieldListMarkColumnOptions.

Public Properties
 | Name | Description
Public Property | DrawOrder | Overridden. Defines order in which the column should be shown in the field list.
Public Property | Margin | Overridden. Specifies left margin of the column.
Public Property | PrimaryKeyIcon | Gets or sets the image of the icon to be shown for Primary Key fields.
Public Property | Width | Overridden. Gets or sets width of the column.
Top
See Also

Reference

FieldListMarkColumnOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


FieldListMarkColumnOptions Class Properties

FieldListMarkColumnOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FieldListMarkColumnOptions Class

For a list of all members of this type, see FieldListMarkColumnOptions members.

Public Properties
 | Name | Description
Public Property | DrawOrder | Overridden. Defines order in which the column should be shown in the field list.
Public Property | Margin | Overridden. Specifies left margin of the column.
Public Property | PrimaryKeyIcon | Gets or sets the image of the icon to be shown for Primary Key fields.
Public Property | Width | Overridden. Gets or sets width of the column.
Top
See Also

Reference

FieldListMarkColumnOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


DrawOrder Property (FieldListMarkColumnOptions)

DrawOrder Property (FieldListMarkColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListMarkColumnOptions Class : DrawOrder Property
Defines order in which the column should be shown in the field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property DrawOrder As System.Integer
'Usage

Dim instance As FieldListMarkColumnOptions
Dim value As System.Integer

instance.DrawOrder = value

value = instance.DrawOrder
public override System.int DrawOrder {get; set;}
public: __property System.int get_DrawOrder() override;
public: __property void set_DrawOrder(
   System.int value
) override;
Requirements

See Also

Reference

FieldListMarkColumnOptions Class
FieldListMarkColumnOptions Members
Base Implementation in DrawOrder


Margin Property (FieldListMarkColumnOptions)

Margin Property (FieldListMarkColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListMarkColumnOptions Class : Margin Property
Specifies left margin of the column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property Margin As System.Integer
'Usage

Dim instance As FieldListMarkColumnOptions
Dim value As System.Integer

instance.Margin = value

value = instance.Margin
public override System.int Margin {get; set;}
public: __property System.int get_Margin() override;
public: __property void set_Margin(
   System.int value
) override;
Requirements

See Also

Reference

FieldListMarkColumnOptions Class
FieldListMarkColumnOptions Members
Base Implementation in Margin


PrimaryKeyIcon Property

PrimaryKeyIcon Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListMarkColumnOptions Class : PrimaryKeyIcon Property
Gets or sets the image of the icon to be shown for Primary Key fields.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property PrimaryKeyIcon As System.Drawing.Image
'Usage

Dim instance As FieldListMarkColumnOptions
Dim value As System.Drawing.Image

instance.PrimaryKeyIcon = value

value = instance.PrimaryKeyIcon
public System.Drawing.Image PrimaryKeyIcon {get; set;}
public: __property System.Drawing.Image* get_PrimaryKeyIcon();
public: __property void set_PrimaryKeyIcon(
   System.Drawing.Image* value
);
Requirements

See Also

Reference

FieldListMarkColumnOptions Class
FieldListMarkColumnOptions Members


Width Property (FieldListMarkColumnOptions)

Width Property (FieldListMarkColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListMarkColumnOptions Class : Width Property
Gets or sets width of the column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property Width As System.Integer
'Usage

Dim instance As FieldListMarkColumnOptions
Dim value As System.Integer

instance.Width = value

value = instance.Width
public override System.int Width {get; set;}
public: __property System.int get_Width() override;
public: __property void set_Width(
   System.int value
) override;
Requirements

See Also

Reference

FieldListMarkColumnOptions Class
FieldListMarkColumnOptions Members
Base Implementation in Width


FieldListNameColumnOptions Class

FieldListNameColumnOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FieldListNameColumnOptions Class
Defines various options of the Name column in the field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class FieldListNameColumnOptions
   Inherits FieldListBaseColumnOptions
'Usage

Dim instance As FieldListNameColumnOptions
public class FieldListNameColumnOptions : FieldListBaseColumnOptions
public __gc class FieldListNameColumnOptions : public FieldListBaseColumnOptions
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.FieldListBaseColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.FieldListNameColumnOptions

Requirements

See Also

Reference

FieldListNameColumnOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


FieldListNameColumnOptions Class Members

FieldListNameColumnOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FieldListNameColumnOptions Class

The following tables list the members exposed by FieldListNameColumnOptions.

Public Properties
 | Name | Description
Public Property | Color | Gets or sets font color of the text for ordinary fields.
Public Property | DrawOrder | Overridden. Defines order in which the column should be shown in the field list.
Public Property | FontStyle | Gets or sets font style of the text for ordinary fields.
Public Property | PrimaryKeyColor | Gets or sets font color of the text for Primary Key fields.
Public Property | PrimaryKeyFontStyle | Gets or sets font style of the text for Primary Key fields.
Top
See Also

Reference

FieldListNameColumnOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


FieldListNameColumnOptions Class Properties

FieldListNameColumnOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FieldListNameColumnOptions Class

For a list of all members of this type, see FieldListNameColumnOptions members.

Public Properties
 | Name | Description
Public Property | Color | Gets or sets font color of the text for ordinary fields.
Public Property | DrawOrder | Overridden. Defines order in which the column should be shown in the field list.
Public Property | FontStyle | Gets or sets font style of the text for ordinary fields.
Public Property | PrimaryKeyColor | Gets or sets font color of the text for Primary Key fields.
Public Property | PrimaryKeyFontStyle | Gets or sets font style of the text for Primary Key fields.
Top
See Also

Reference

FieldListNameColumnOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Color Property (FieldListNameColumnOptions)

Color Property (FieldListNameColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListNameColumnOptions Class : Color Property
Gets or sets font color of the text for ordinary fields.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Color As System.Drawing.Color
'Usage

Dim instance As FieldListNameColumnOptions
Dim value As System.Drawing.Color

instance.Color = value

value = instance.Color
public System.Drawing.Color Color {get; set;}
public: __property System.Drawing.Color get_Color();
public: __property void set_Color(
   System.Drawing.Color value
);
Requirements

See Also

Reference

FieldListNameColumnOptions Class
FieldListNameColumnOptions Members


DrawOrder Property (FieldListNameColumnOptions)

DrawOrder Property (FieldListNameColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListNameColumnOptions Class : DrawOrder Property
Defines order in which the column should be shown in the field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property DrawOrder As System.Integer
'Usage

Dim instance As FieldListNameColumnOptions
Dim value As System.Integer

instance.DrawOrder = value

value = instance.DrawOrder
public override System.int DrawOrder {get; set;}
public: __property System.int get_DrawOrder() override;
public: __property void set_DrawOrder(
   System.int value
) override;
Requirements

See Also

Reference

FieldListNameColumnOptions Class
FieldListNameColumnOptions Members
Base Implementation in DrawOrder


FontStyle Property (FieldListNameColumnOptions)

FontStyle Property (FieldListNameColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListNameColumnOptions Class : FontStyle Property
Gets or sets font style of the text for ordinary fields.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property FontStyle As System.Drawing.FontStyle
'Usage

Dim instance As FieldListNameColumnOptions
Dim value As System.Drawing.FontStyle

instance.FontStyle = value

value = instance.FontStyle
public System.Drawing.FontStyle FontStyle {get; set;}
public: __property System.Drawing.FontStyle get_FontStyle();
public: __property void set_FontStyle(
   System.Drawing.FontStyle value
);
Requirements

See Also

Reference

FieldListNameColumnOptions Class
FieldListNameColumnOptions Members


PrimaryKeyColor Property

PrimaryKeyColor Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListNameColumnOptions Class : PrimaryKeyColor Property
Gets or sets font color of the text for Primary Key fields.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property PrimaryKeyColor As System.Drawing.Color
'Usage

Dim instance As FieldListNameColumnOptions
Dim value As System.Drawing.Color

instance.PrimaryKeyColor = value

value = instance.PrimaryKeyColor
public System.Drawing.Color PrimaryKeyColor {get; set;}
public: __property System.Drawing.Color get_PrimaryKeyColor();
public: __property void set_PrimaryKeyColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

FieldListNameColumnOptions Class
FieldListNameColumnOptions Members


PrimaryKeyFontStyle Property

PrimaryKeyFontStyle Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListNameColumnOptions Class : PrimaryKeyFontStyle Property
Gets or sets font style of the text for Primary Key fields.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property PrimaryKeyFontStyle As System.Drawing.FontStyle
'Usage

Dim instance As FieldListNameColumnOptions
Dim value As System.Drawing.FontStyle

instance.PrimaryKeyFontStyle = value

value = instance.PrimaryKeyFontStyle
public System.Drawing.FontStyle PrimaryKeyFontStyle {get; set;}
public: __property System.Drawing.FontStyle get_PrimaryKeyFontStyle();
public: __property void set_PrimaryKeyFontStyle(
   System.Drawing.FontStyle value
);
Requirements

See Also

Reference

FieldListNameColumnOptions Class
FieldListNameColumnOptions Members


FieldListTypeColumnOptions Class

FieldListTypeColumnOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FieldListTypeColumnOptions Class
Defines various options of the Type column in the field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class FieldListTypeColumnOptions
   Inherits FieldListBaseColumnOptions
'Usage

Dim instance As FieldListTypeColumnOptions
public class FieldListTypeColumnOptions : FieldListBaseColumnOptions
public __gc class FieldListTypeColumnOptions : public FieldListBaseColumnOptions
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.FieldListBaseColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.FieldListTypeColumnOptions

Requirements

See Also

Reference

FieldListTypeColumnOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


FieldListTypeColumnOptions Class Members

FieldListTypeColumnOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FieldListTypeColumnOptions Class

The following tables list the members exposed by FieldListTypeColumnOptions.

Public Properties
 | Name | Description
Public Property | Case | Determines case conversion rules for displaying data types.
Public Property | Color | Gets or sets font color of the text.
Public Property | DrawOrder | Overridden. Defines order in which the column should be shown in the field list.
Public Property | FontStyle | Gets or sets font style of the text.
Public Property | Margin | Overridden. Specifies left margin of the column.
Top
See Also

Reference

FieldListTypeColumnOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


FieldListTypeColumnOptions Class Properties

FieldListTypeColumnOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FieldListTypeColumnOptions Class

For a list of all members of this type, see FieldListTypeColumnOptions members.

Public Properties
 | Name | Description
Public Property | Case | Determines case conversion rules for displaying data types.
Public Property | Color | Gets or sets font color of the text.
Public Property | DrawOrder | Overridden. Defines order in which the column should be shown in the field list.
Public Property | FontStyle | Gets or sets font style of the text.
Public Property | Margin | Overridden. Specifies left margin of the column.
Top
See Also

Reference

FieldListTypeColumnOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Case Property

Case Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListTypeColumnOptions Class : Case Property
Determines case conversion rules for displaying data types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Case As FieldTypeCase
'Usage

Dim instance As FieldListTypeColumnOptions
Dim value As FieldTypeCase

instance.Case = value

value = instance.Case
public FieldTypeCase Case {get; set;}
public: __property FieldTypeCase get_Case();
public: __property void set_Case(
   FieldTypeCase value
);
Requirements

See Also

Reference

FieldListTypeColumnOptions Class
FieldListTypeColumnOptions Members


Color Property (FieldListTypeColumnOptions)

Color Property (FieldListTypeColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListTypeColumnOptions Class : Color Property
Gets or sets font color of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Color As System.Drawing.Color
'Usage

Dim instance As FieldListTypeColumnOptions
Dim value As System.Drawing.Color

instance.Color = value

value = instance.Color
public System.Drawing.Color Color {get; set;}
public: __property System.Drawing.Color get_Color();
public: __property void set_Color(
   System.Drawing.Color value
);
Requirements

See Also

Reference

FieldListTypeColumnOptions Class
FieldListTypeColumnOptions Members


DrawOrder Property (FieldListTypeColumnOptions)

DrawOrder Property (FieldListTypeColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListTypeColumnOptions Class : DrawOrder Property
Defines order in which the column should be shown in the field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property DrawOrder As System.Integer
'Usage

Dim instance As FieldListTypeColumnOptions
Dim value As System.Integer

instance.DrawOrder = value

value = instance.DrawOrder
public override System.int DrawOrder {get; set;}
public: __property System.int get_DrawOrder() override;
public: __property void set_DrawOrder(
   System.int value
) override;
Requirements

See Also

Reference

FieldListTypeColumnOptions Class
FieldListTypeColumnOptions Members
Base Implementation in DrawOrder


FontStyle Property (FieldListTypeColumnOptions)

FontStyle Property (FieldListTypeColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListTypeColumnOptions Class : FontStyle Property
Gets or sets font style of the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property FontStyle As System.Drawing.FontStyle
'Usage

Dim instance As FieldListTypeColumnOptions
Dim value As System.Drawing.FontStyle

instance.FontStyle = value

value = instance.FontStyle
public System.Drawing.FontStyle FontStyle {get; set;}
public: __property System.Drawing.FontStyle get_FontStyle();
public: __property void set_FontStyle(
   System.Drawing.FontStyle value
);
Requirements

See Also

Reference

FieldListTypeColumnOptions Class
FieldListTypeColumnOptions Members


Margin Property (FieldListTypeColumnOptions)

Margin Property (FieldListTypeColumnOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FieldListTypeColumnOptions Class : Margin Property
Specifies left margin of the column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property Margin As System.Integer
'Usage

Dim instance As FieldListTypeColumnOptions
Dim value As System.Integer

instance.Margin = value

value = instance.Margin
public override System.int Margin {get; set;}
public: __property System.int get_Margin() override;
public: __property void set_Margin(
   System.int value
) override;
Requirements

See Also

Reference

FieldListTypeColumnOptions Class
FieldListTypeColumnOptions Members
Base Implementation in Margin


FirebirdSyntaxProvider Class

FirebirdSyntaxProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FirebirdSyntaxProvider Class
Syntax provider for Firebird databases.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class FirebirdSyntaxProvider
   Inherits BaseSyntaxProvider
'Usage

Dim instance As FirebirdSyntaxProvider
public class FirebirdSyntaxProvider : BaseSyntaxProvider
public __gc class FirebirdSyntaxProvider : public BaseSyntaxProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.FirebirdSyntaxProvider

Requirements

See Also

Reference

FirebirdSyntaxProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


FirebirdSyntaxProvider Class Members

FirebirdSyntaxProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FirebirdSyntaxProvider Class

The following tables list the members exposed by FirebirdSyntaxProvider.

Public Properties
 | Name | Description
Public Property | ServerVersion | Gets or sets Firebird database server version.
Top
Public Methods
 | Name | Description
Public Method | GetReferencingObjectNames | Overridden.
Top
See Also

Reference

FirebirdSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


FirebirdSyntaxProvider Class Methods

FirebirdSyntaxProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FirebirdSyntaxProvider Class

For a list of all members of this type, see FirebirdSyntaxProvider members.

Public Methods
 | Name | Description
Public Method | GetReferencingObjectNames | Overridden.
Top
See Also

Reference

FirebirdSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


GetReferencingObjectNames Method (FirebirdSyntaxProvider)

GetReferencingObjectNames Method (FirebirdSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdSyntaxProvider Class : GetReferencingObjectNames Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Function GetReferencingObjectNames( _
   ByVal list As UpdatableObjectList(Of MetadataQualifiedName), _
   ByVal forObject As MetadataObject, _
   ByVal loadingOptions As MetadataLoadingOptions _
) As System.Boolean
'Usage

Dim instance As FirebirdSyntaxProvider
Dim list As UpdatableObjectList(Of MetadataQualifiedName)
Dim forObject As MetadataObject
Dim loadingOptions As MetadataLoadingOptions
Dim value As System.Boolean

value = instance.GetReferencingObjectNames(list, forObject, loadingOptions)
public override System.bool GetReferencingObjectNames(
   UpdatableObjectList<MetadataQualifiedName> list,
   MetadataObject forObject,
   MetadataLoadingOptions loadingOptions
)
public: System.bool GetReferencingObjectNames(
   UpdatableObjectList<MetadataQualifiedName*>* list,
   MetadataObject* forObject,
   MetadataLoadingOptions* loadingOptions
) override

Parameters

list
forObject
loadingOptions
Requirements

See Also

Reference

FirebirdSyntaxProvider Class
FirebirdSyntaxProvider Members
Base Implementation in GetReferencingObjectNames


FirebirdSyntaxProvider Class Properties

FirebirdSyntaxProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FirebirdSyntaxProvider Class

For a list of all members of this type, see FirebirdSyntaxProvider members.

Public Properties
 | Name | Description
Public Property | ServerVersion | Gets or sets Firebird database server version.
Top
See Also

Reference

FirebirdSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


ServerVersion Property (FirebirdSyntaxProvider)

ServerVersion Property (FirebirdSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdSyntaxProvider Class : ServerVersion Property
Gets or sets Firebird database server version.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ServerVersion As FirebirdVersion
'Usage

Dim instance As FirebirdSyntaxProvider
Dim value As FirebirdVersion

instance.ServerVersion = value

value = instance.ServerVersion
public FirebirdVersion ServerVersion {get; set;}
public: __property FirebirdVersion get_ServerVersion();
public: __property void set_ServerVersion(
   FirebirdVersion value
);
Requirements

See Also

Reference

FirebirdSyntaxProvider Class
FirebirdSyntaxProvider Members


GenericSyntaxProvider Class

GenericSyntaxProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : GenericSyntaxProvider Class
This provider can be used with any database server. It implements most of the ANSI SQL/92 syntax standard definitions, but lacks most of server-specific SQL syntax extensions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class GenericSyntaxProvider
   Inherits BaseSyntaxProvider
'Usage

Dim instance As GenericSyntaxProvider
public class GenericSyntaxProvider : BaseSyntaxProvider
public __gc class GenericSyntaxProvider : public BaseSyntaxProvider
Remarks
Usage of specific syntax providers for supported database servers is recommended. If your database server is not uniquely defined, you may use the AutoSyntaxProvider which will try to detect database server and will use specific syntax provider for it. The generic syntax provider is also able to detect database server automatically, but this information is used only to determine correct quotation of identifiers and their case sensitivity.
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.GenericSyntaxProvider

Requirements

See Also

Reference

GenericSyntaxProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


GenericSyntaxProvider Class Members

GenericSyntaxProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : GenericSyntaxProvider Class

The following tables list the members exposed by GenericSyntaxProvider.

Public Properties
 | Name | Description
Public Property | AutoDetectServer | Allows to detect database server automatically.
Public Property | BuiltinFunctionNames | Gets or sets a list of names of the builtin functions.
Public Property | IdentCaseSens | Overridden. Defines the way database server treats quoted and unquoted identifiers.
Public Property | PreferredServer | Determines the server type for the database server detection routine to start from; uniquely determines the server type to be used if auto-detection is turned off.
Public Property | UsedServer | Returns the detected database server type; returns the PreferredServer if auto-detection is turned off.
Top
See Also

Reference

GenericSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


GenericSyntaxProvider Class Properties

GenericSyntaxProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : GenericSyntaxProvider Class

For a list of all members of this type, see GenericSyntaxProvider members.

Public Properties
 | Name | Description
Public Property | AutoDetectServer | Allows to detect database server automatically.
Public Property | BuiltinFunctionNames | Gets or sets a list of names of the builtin functions.
Public Property | IdentCaseSens | Overridden. Defines the way database server treats quoted and unquoted identifiers.
Public Property | PreferredServer | Determines the server type for the database server detection routine to start from; uniquely determines the server type to be used if auto-detection is turned off.
Public Property | UsedServer | Returns the detected database server type; returns the PreferredServer if auto-detection is turned off.
Top
See Also

Reference

GenericSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AutoDetectServer Property

AutoDetectServer Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > GenericSyntaxProvider Class : AutoDetectServer Property
Allows to detect database server automatically.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AutoDetectServer As System.Boolean
'Usage

Dim instance As GenericSyntaxProvider
Dim value As System.Boolean

instance.AutoDetectServer = value

value = instance.AutoDetectServer
public System.bool AutoDetectServer {get; set;}
public: __property System.bool get_AutoDetectServer();
public: __property void set_AutoDetectServer(
   System.bool value
);
Remarks

The detection routine sends a series of server-specific SQL queries that allows to uniquely define the underlying database server. This information is used to determine correct quotation of identifiers and their case sensitivity. It is also used to retrieve database schema from supported database servers more precisely.

Due to it's nature, the detection routine may generate a series of SQL query execution errors and it works only if connection to a database server is established.

Requirements

See Also

Reference

GenericSyntaxProvider Class
GenericSyntaxProvider Members


BuiltinFunctionNames Property

BuiltinFunctionNames Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > GenericSyntaxProvider Class : BuiltinFunctionNames Property
Gets or sets a list of names of the builtin functions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property BuiltinFunctionNames As System.Collections.Generic.List(Of String)
'Usage

Dim instance As GenericSyntaxProvider
Dim value As System.Collections.Generic.List(Of String)

instance.BuiltinFunctionNames = value

value = instance.BuiltinFunctionNames
public System.Collections.Generic.List<string> BuiltinFunctionNames {get; set;}
public: __property System.Collections.Generic.List<string*>* get_BuiltinFunctionNames();
public: __property void set_BuiltinFunctionNames(
   System.Collections.Generic.List<string*>* value
);
Requirements

See Also

Reference

GenericSyntaxProvider Class
GenericSyntaxProvider Members


IdentCaseSens Property (GenericSyntaxProvider)

IdentCaseSens Property (GenericSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > GenericSyntaxProvider Class : IdentCaseSens Property
Defines the way database server treats quoted and unquoted identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property IdentCaseSens As IdentCaseSensitivity
'Usage

Dim instance As GenericSyntaxProvider
Dim value As IdentCaseSensitivity

instance.IdentCaseSens = value

value = instance.IdentCaseSens
public override IdentCaseSensitivity IdentCaseSens {get; set;}
public: __property IdentCaseSensitivity get_IdentCaseSens() override;
public: __property void set_IdentCaseSens(
   IdentCaseSensitivity value
) override;
Requirements

See Also

Reference

GenericSyntaxProvider Class
GenericSyntaxProvider Members
Base Implementation in IdentCaseSens


PreferredServer Property

PreferredServer Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > GenericSyntaxProvider Class : PreferredServer Property
Determines the server type for the database server detection routine to start from; uniquely determines the server type to be used if auto-detection is turned off.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property PreferredServer As GenericSyntaxServerType
'Usage

Dim instance As GenericSyntaxProvider
Dim value As GenericSyntaxServerType

instance.PreferredServer = value

value = instance.PreferredServer
public GenericSyntaxServerType PreferredServer {get; set;}
public: __property GenericSyntaxServerType get_PreferredServer();
public: __property void set_PreferredServer(
   GenericSyntaxServerType value
);
Remarks
Setting this property to prospective server type will allow to reduce the number of unsuccessful attempts to detect database server.
Requirements

See Also

Reference

GenericSyntaxProvider Class
GenericSyntaxProvider Members


UsedServer Property

UsedServer Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > GenericSyntaxProvider Class : UsedServer Property
Returns the detected database server type; returns the PreferredServer if auto-detection is turned off.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property UsedServer As GenericSyntaxServerType
'Usage

Dim instance As GenericSyntaxProvider
Dim value As GenericSyntaxServerType

value = instance.UsedServer
public GenericSyntaxServerType UsedServer {get;}
public: __property GenericSyntaxServerType get_UsedServer();
Requirements

See Also

Reference

GenericSyntaxProvider Class
GenericSyntaxProvider Members


InformixSyntaxProvider Class

InformixSyntaxProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : InformixSyntaxProvider Class
Syntax provider for Informix database server.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class InformixSyntaxProvider
   Inherits BaseSyntaxProvider
'Usage

Dim instance As InformixSyntaxProvider
public class InformixSyntaxProvider : BaseSyntaxProvider
public __gc class InformixSyntaxProvider : public BaseSyntaxProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.InformixSyntaxProvider

Requirements

See Also

Reference

InformixSyntaxProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


InformixSyntaxProvider Class Members

InformixSyntaxProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : InformixSyntaxProvider Class

The following tables list the members exposed by InformixSyntaxProvider.

Public Properties
 | Name | Description
Public Property | IdentCaseSens | Overridden. Defines the way database server treats quoted and unquoted identifiers.
Public Property | ServerVersion | Gets or sets Informix database server version.
Top
See Also

Reference

InformixSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


InformixSyntaxProvider Class Properties

InformixSyntaxProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : InformixSyntaxProvider Class

For a list of all members of this type, see InformixSyntaxProvider members.

Public Properties
 | Name | Description
Public Property | IdentCaseSens | Overridden. Defines the way database server treats quoted and unquoted identifiers.
Public Property | ServerVersion | Gets or sets Informix database server version.
Top
See Also

Reference

InformixSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


IdentCaseSens Property (InformixSyntaxProvider)

IdentCaseSens Property (InformixSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixSyntaxProvider Class : IdentCaseSens Property
Defines the way database server treats quoted and unquoted identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property IdentCaseSens As IdentCaseSensitivity
'Usage

Dim instance As InformixSyntaxProvider
Dim value As IdentCaseSensitivity

instance.IdentCaseSens = value

value = instance.IdentCaseSens
public override IdentCaseSensitivity IdentCaseSens {get; set;}
public: __property IdentCaseSensitivity get_IdentCaseSens() override;
public: __property void set_IdentCaseSens(
   IdentCaseSensitivity value
) override;
Requirements

See Also

Reference

InformixSyntaxProvider Class
InformixSyntaxProvider Members
Base Implementation in IdentCaseSens


ServerVersion Property (InformixSyntaxProvider)

ServerVersion Property (InformixSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixSyntaxProvider Class : ServerVersion Property
Gets or sets Informix database server version.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ServerVersion As InformixVersion
'Usage

Dim instance As InformixSyntaxProvider
Dim value As InformixVersion

instance.ServerVersion = value

value = instance.ServerVersion
public InformixVersion ServerVersion {get; set;}
public: __property InformixVersion get_ServerVersion();
public: __property void set_ServerVersion(
   InformixVersion value
);
Requirements

See Also

Reference

InformixSyntaxProvider Class
InformixSyntaxProvider Members


Localizer Class

Localizer Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : Localizer Class
Localizer is a static object that holds localization resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class Localizer
'Usage

Dim instance As Localizer
public class Localizer
public __gc class Localizer
Remarks
Use the QueryBuilder.Language property to change language of the component.
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.Localizer

Requirements

See Also

Reference

Localizer Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Localizer Class Members

Localizer Class Members
Fields Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : Localizer Class

The following tables list the members exposed by Localizer.

Public Fields
 | Name | Description
Public Field | Languages | Lists language codes of available localizations.
Top
Public Properties
 | Name | Description
Public Property | Language | Specifies component's UI language by it's code.
Top
Public Methods
 | Name | Description
Public Method | LoadLanguageFromFile | Loads language from file.
Public Method | LoadLanguageFromStream | Loads language from stream
Public Method | LoadLanguageFromString | Loads language from string.
Top
Public Events
 | Name | Description
Public Event | LanguageChanged | Invoked when language is changed.
Top
See Also

Reference

Localizer Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Localizer Class Methods

Localizer Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : Localizer Class

For a list of all members of this type, see Localizer members.

Public Methods
 | Name | Description
Public Method | LoadLanguageFromFile | Loads language from file.
Public Method | LoadLanguageFromStream | Loads language from stream
Public Method | LoadLanguageFromString | Loads language from string.
Top
See Also

Reference

Localizer Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


LoadLanguageFromFile Method

LoadLanguageFromFile Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > Localizer Class : LoadLanguageFromFile Method
File to load language from
Loads language from file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function LoadLanguageFromFile( _
   ByVal languageFile As System.String _
) As System.Boolean
'Usage

Dim instance As Localizer
Dim languageFile As System.String
Dim value As System.Boolean

value = instance.LoadLanguageFromFile(languageFile)
public System.bool LoadLanguageFromFile(
   System.string languageFile
)
public: System.bool LoadLanguageFromFile(
   System.string* languageFile
)

Parameters

languageFile
File to load language from

Return Value

true if language is loaded successfully; false if not.
Requirements

See Also

Reference

Localizer Class
Localizer Members


LoadLanguageFromStream Method

LoadLanguageFromStream Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > Localizer Class : LoadLanguageFromStream Method
Stream to load language from
Loads language from stream
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function LoadLanguageFromStream( _
   ByVal languageStream As System.IO.Stream _
) As System.Boolean
'Usage

Dim instance As Localizer
Dim languageStream As System.IO.Stream
Dim value As System.Boolean

value = instance.LoadLanguageFromStream(languageStream)
public System.bool LoadLanguageFromStream(
   System.IO.Stream languageStream
)
public: System.bool LoadLanguageFromStream(
   System.IO.Stream* languageStream
)

Parameters

languageStream
Stream to load language from

Return Value

true if language is loaded successfully; false if not.
Requirements

See Also

Reference

Localizer Class
Localizer Members


LoadLanguageFromString Method

LoadLanguageFromString Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > Localizer Class : LoadLanguageFromString Method
String to load language from
Loads language from string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function LoadLanguageFromString( _
   ByVal xmlString As System.String _
) As System.Boolean
'Usage

Dim instance As Localizer
Dim xmlString As System.String
Dim value As System.Boolean

value = instance.LoadLanguageFromString(xmlString)
public System.bool LoadLanguageFromString(
   System.string xmlString
)
public: System.bool LoadLanguageFromString(
   System.string* xmlString
)

Parameters

xmlString
String to load language from

Return Value

true if language is loaded successfully; false if not.
Requirements

See Also

Reference

Localizer Class
Localizer Members


Localizer Class Properties

Localizer Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : Localizer Class

For a list of all members of this type, see Localizer members.

Public Properties
 | Name | Description
Public Property | Language | Specifies component's UI language by it's code.
Top
See Also

Reference

Localizer Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Language Property (Localizer)

Language Property (Localizer)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > Localizer Class : Language Property
Specifies component's UI language by it's code.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Language As System.String
'Usage

Dim instance As Localizer
Dim value As System.String

instance.Language = value

value = instance.Language
public System.string Language {get; set;}
public: __property System.string* get_Language();
public: __property void set_Language(
   System.string* value
);

Property Value

The "Auto" value means the language will be detected automatically according to CultureInfo specified for UI culture of the current thread (System.Threading.Thread.CurrentThread.CurrentUICulture).
The "Default" value means usage of default strings containing in embedded resources.
Remarks

The list of available languages can be taken from the Languages field. The language list always contains "Auto" and "Default" strings.

If specified language code doesn't exist (eg. "es-MX"), the Localizer will try to fallback to the base language ("es"). If it doesn't exist too, the Localizer will use the "Default" language.

Requirements

See Also

Reference

Localizer Class
Localizer Members


Localizer Class Fields

Localizer Class Fields

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : Localizer Class

For a list of all members of this type, see Localizer members.

Public Fields
 | Name | Description
Public Field | Languages | Lists language codes of available localizations.
Top
See Also

Reference

Localizer Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Languages Field

Languages Field

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > Localizer Class : Languages Field
Lists language codes of available localizations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Languages As System.Collections.Generic.List(Of String)
'Usage

Dim instance As Localizer
Dim value As System.Collections.Generic.List(Of String)

value = instance.Languages
public readonly System.Collections.Generic.List<string> Languages
public: readonly System.Collections.Generic.List<string*>* Languages
Requirements

See Also

Reference

Localizer Class
Localizer Members


Localizer Class Events

Localizer Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : Localizer Class

For a list of all members of this type, see Localizer members.

Public Events
 | Name | Description
Public Event | LanguageChanged | Invoked when language is changed.
Top
See Also

Reference

Localizer Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


LanguageChanged Event (Localizer)

LanguageChanged Event (Localizer)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > Localizer Class : LanguageChanged Event
Invoked when language is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event LanguageChanged As System.EventHandler
'Usage

Dim instance As Localizer
Dim handler As System.EventHandler

AddHandler instance.LanguageChanged, handler
public event System.EventHandler LanguageChanged
public: __event System.EventHandler* LanguageChanged
Requirements

See Also

Reference

Localizer Class
Localizer Members


MetadataAggregate Class

MetadataAggregate Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataAggregate Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MetadataAggregate
   Inherits MetadataItem
'Usage

Dim instance As MetadataAggregate
public class MetadataAggregate : MetadataItem
public __gc class MetadataAggregate : public MetadataItem
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataItem
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataAggregate

Requirements

See Also

Reference

MetadataAggregate Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataAggregate Class Members

MetadataAggregate Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataAggregate Class

The following tables list the members exposed by MetadataAggregate.

Public Constructors
 | Name | Description
Public Constructor | MetadataAggregate Constructor |
Top
See Also

Reference

MetadataAggregate Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataAggregate Constructor

MetadataAggregate Constructor

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataAggregate Class : MetadataAggregate Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function New( _
   ByVal parentList As MetadataList _
)
'Usage

Dim parentList As MetadataList

Dim instance As New MetadataAggregate(parentList)
public MetadataAggregate(
   MetadataList parentList
)
public: MetadataAggregate(
   MetadataList* parentList
)

Parameters

parentList
Requirements

See Also

Reference

MetadataAggregate Class
MetadataAggregate Members


MetadataContainer Class

MetadataContainer Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataContainer Class
Stores the necessary metadata from database.
Object Model
MetadataContainer ClassMetadataLoadingOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MetadataContainer
   Inherits MetadataItem
'Usage

Dim instance As MetadataContainer
public class MetadataContainer : MetadataItem
public __gc class MetadataContainer : public MetadataItem
Remarks
Metadata Container was reorganized from the plain list of objects to the hierarchical structure. There are three types of elements of this structure: namespaces, objects and sub-object items. Namespaces reflect object grouping in the database server. They can represent linked servers, databases, schemas and packages. Objects can be tables, views, synonyms, stored procedures or functions (only those procedures and functions that return dataset and can be used as data sources in the SELECT queries). The component deals with three types of sub-object items: fields, parameters and foreign keys, as these types of items are needed by the component to build queries and to represent them visually.
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataItem
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataContainer

Requirements

See Also

Reference

MetadataContainer Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataContainer Class Members

MetadataContainer Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataContainer Class

The following tables list the members exposed by MetadataContainer.

Public Properties
 | Name | Description
Public Property | LoadingOptions | Determines rules of loading database schema information to the Metadata Container.
Public Property | OfflineMode | Allows to switch the component between normal and "Offline" modes.
Public Property | XML | Gets or sets the content of Metadata Container as string in a form of XML document.
Top
Public Methods
 | Name | Description
Public Method | AbortMetadataLoading | Aborts the metadata loading process.
Public Method | ExportToXML | Overloaded. Saves the content of Metadata Container to file in a form of XML document.
Public Method | ImportFromXML | Overloaded. Loads the content of Metadata Container from file in a form of XML document.
Top
Public Events
 | Name | Description
Public Event | FilterMetadataItem | Allows to deny addition of unwanted objects to the Metadata Container.
Public Event | ItemMetadataLoaded | Fired when the component has finished loading of child metadata items for an item.
Public Event | ItemMetadataLoading | Fired when the component requests child metadata items for an item.
Top
See Also

Reference

MetadataContainer Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataContainer Class Methods

MetadataContainer Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataContainer Class

For a list of all members of this type, see MetadataContainer members.

Public Methods
 | Name | Description
Public Method | AbortMetadataLoading | Aborts the metadata loading process.
Public Method | ExportToXML | Overloaded. Saves the content of Metadata Container to file in a form of XML document.
Public Method | ImportFromXML | Overloaded. Loads the content of Metadata Container from file in a form of XML document.
Top
See Also

Reference

MetadataContainer Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AbortMetadataLoading Method

AbortMetadataLoading Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataContainer Class : AbortMetadataLoading Method
Aborts the metadata loading process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub AbortMetadataLoading()
'Usage

Dim instance As MetadataContainer

instance.AbortMetadataLoading()
public void AbortMetadataLoading()
public: void AbortMetadataLoading();
Requirements

See Also

Reference

MetadataContainer Class
MetadataContainer Members


ExportToXML Method (MetadataContainer)

ExportToXML Method (MetadataContainer)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataContainer Class : ExportToXML Method
Saves the content of Metadata Container to file in a form of XML document.
Overload List
Overload | Description
ExportToXML(String) | Saves the content of Metadata Container to file in a form of XML document.
ExportToXML(Stream) | Saves the content of Metadata Container to stream in a form of XML document.
Requirements

See Also

Reference

MetadataContainer Class
MetadataContainer Members


ExportToXML(String) Method

ExportToXML(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataContainer Class > ExportToXML Method : ExportToXML(String) Method
Saves the content of Metadata Container to file in a form of XML document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub ExportToXML( _
   ByVal fileName As System.String _
)
'Usage

Dim instance As MetadataContainer
Dim fileName As System.String

instance.ExportToXML(fileName)
public void ExportToXML(
   System.string fileName
)
public: void ExportToXML(
   System.string* fileName
)

Parameters

fileName
Requirements

See Also

Reference

MetadataContainer Class
MetadataContainer Members
Overload List


ExportToXML(Stream) Method

ExportToXML(Stream) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataContainer Class > ExportToXML Method : ExportToXML(Stream) Method
Saves the content of Metadata Container to stream in a form of XML document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub ExportToXML( _
   ByVal stream As System.IO.Stream _
)
'Usage

Dim instance As MetadataContainer
Dim stream As System.IO.Stream

instance.ExportToXML(stream)
public void ExportToXML(
   System.IO.Stream stream
)
public: void ExportToXML(
   System.IO.Stream* stream
)

Parameters

stream
Requirements

See Also

Reference

MetadataContainer Class
MetadataContainer Members
Overload List


ImportFromXML Method (MetadataContainer)

ImportFromXML Method (MetadataContainer)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataContainer Class : ImportFromXML Method
Loads the content of Metadata Container from file in a form of XML document.
Overload List
Overload | Description
ImportFromXML(String) | Loads the content of Metadata Container from file in a form of XML document.
ImportFromXML(Stream) | Loads the content of Metadata Container from stream in a form of XML document.
Requirements

See Also

Reference

MetadataContainer Class
MetadataContainer Members


ImportFromXML(String) Method

ImportFromXML(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataContainer Class > ImportFromXML Method : ImportFromXML(String) Method
Loads the content of Metadata Container from file in a form of XML document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub ImportFromXML( _
   ByVal fileName As System.String _
)
'Usage

Dim instance As MetadataContainer
Dim fileName As System.String

instance.ImportFromXML(fileName)
public void ImportFromXML(
   System.string fileName
)
public: void ImportFromXML(
   System.string* fileName
)

Parameters

fileName
Requirements

See Also

Reference

MetadataContainer Class
MetadataContainer Members
Overload List


ImportFromXML(Stream) Method

ImportFromXML(Stream) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataContainer Class > ImportFromXML Method : ImportFromXML(Stream) Method
Loads the content of Metadata Container from stream in a form of XML document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub ImportFromXML( _
   ByVal stream As System.IO.Stream _
)
'Usage

Dim instance As MetadataContainer
Dim stream As System.IO.Stream

instance.ImportFromXML(stream)
public void ImportFromXML(
   System.IO.Stream stream
)
public: void ImportFromXML(
   System.IO.Stream* stream
)

Parameters

stream
Requirements

See Also

Reference

MetadataContainer Class
MetadataContainer Members
Overload List


MetadataContainer Class Properties

MetadataContainer Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataContainer Class

For a list of all members of this type, see MetadataContainer members.

Public Properties
 | Name | Description
Public Property | LoadingOptions | Determines rules of loading database schema information to the Metadata Container.
Public Property | OfflineMode | Allows to switch the component between normal and "Offline" modes.
Public Property | XML | Gets or sets the content of Metadata Container as string in a form of XML document.
Top
See Also

Reference

MetadataContainer Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


LoadingOptions Property

LoadingOptions Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataContainer Class : LoadingOptions Property
Determines rules of loading database schema information to the Metadata Container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property LoadingOptions As MetadataLoadingOptions
'Usage

Dim instance As MetadataContainer
Dim value As MetadataLoadingOptions

instance.LoadingOptions = value

value = instance.LoadingOptions
public MetadataLoadingOptions LoadingOptions {get; set;}
public: __property MetadataLoadingOptions* get_LoadingOptions();
public: __property void set_LoadingOptions(
   MetadataLoadingOptions* value
);
Remarks
Definition of these rules is required to limit the list of database objects displayed in the tree, as well as to reduce metadata loading time (for some database servers, e.g. Oracle).
Formerly named as MetadataFilter, the new option set introduces a simpler way to define metadata loading rules using ExcludeFilter and IncludeFilter mask sets and other properties, but the old way is preserved due to higher flexibility and for compatibility reasons. The result set of objects to be loaded is determined using both old and new rules.
Requirements

See Also

Reference

MetadataContainer Class
MetadataContainer Members


OfflineMode Property (MetadataContainer)

OfflineMode Property (MetadataContainer)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataContainer Class : OfflineMode Property
Allows to switch the component between normal and "Offline" modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property OfflineMode As System.Boolean
'Usage

Dim instance As MetadataContainer
Dim value As System.Boolean

instance.OfflineMode = value

value = instance.OfflineMode
public System.bool OfflineMode {get; set;}
public: __property System.bool get_OfflineMode();
public: __property void set_OfflineMode(
   System.bool value
);
Remarks

The Offline mode is intended to suppress background query execution by the component. In normal mode the component retrieves field lists for objects used in the query and the lists of database objects by demand. Working in the Offline mode you have to provide the way to load the necessary information programmatically.

You may use the MetadataContainer.ItemMetadataLoading Event for this purpose. To decrease metadata loading time and to limit the objects visible to the end-user you may define metadata filters to limit the number of objects loaded at a time, or you may save the content of Metadata Container to the XML file and load metadata from the XML file or stream.

Requirements

See Also

Reference

MetadataContainer Class
MetadataContainer Members


XML Property (MetadataContainer)

XML Property (MetadataContainer)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataContainer Class : XML Property
Gets or sets the content of Metadata Container as string in a form of XML document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property XML As System.String
'Usage

Dim instance As MetadataContainer
Dim value As System.String

instance.XML = value

value = instance.XML
public System.string XML {get; set;}
public: __property System.string* get_XML();
public: __property void set_XML(
   System.string* value
);
Requirements

See Also

Reference

MetadataContainer Class
MetadataContainer Members


MetadataContainer Class Events

MetadataContainer Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataContainer Class

For a list of all members of this type, see MetadataContainer members.

Public Events
 | Name | Description
Public Event | FilterMetadataItem | Allows to deny addition of unwanted objects to the Metadata Container.
Public Event | ItemMetadataLoaded | Fired when the component has finished loading of child metadata items for an item.
Public Event | ItemMetadataLoading | Fired when the component requests child metadata items for an item.
Top
See Also

Reference

MetadataContainer Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


FilterMetadataItem Event

FilterMetadataItem Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataContainer Class : FilterMetadataItem Event
Allows to deny addition of unwanted objects to the Metadata Container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event FilterMetadataItem As FilterMetadataItemEventHandler
'Usage

Dim instance As MetadataContainer
Dim handler As FilterMetadataItemEventHandler

AddHandler instance.FilterMetadataItem, handler
public event FilterMetadataItemEventHandler FilterMetadataItem
public: __event FilterMetadataItemEventHandler* FilterMetadataItem
Remarks
Handler of this event should analyze the passed Metadata Item and set the abort flag to true to deny it's addition to the Metadata Container.
Requirements

See Also

Reference

MetadataContainer Class
MetadataContainer Members


ItemMetadataLoaded Event

ItemMetadataLoaded Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataContainer Class : ItemMetadataLoaded Event
Fired when the component has finished loading of child metadata items for an item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ItemMetadataLoaded As ItemMetadataLoadEventHandler
'Usage

Dim instance As MetadataContainer
Dim handler As ItemMetadataLoadEventHandler

AddHandler instance.ItemMetadataLoaded, handler
public event ItemMetadataLoadEventHandler ItemMetadataLoaded
public: __event ItemMetadataLoadEventHandler* ItemMetadataLoaded
Requirements

See Also

Reference

MetadataContainer Class
MetadataContainer Members


ItemMetadataLoading Event

ItemMetadataLoading Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataContainer Class : ItemMetadataLoading Event
Fired when the component requests child metadata items for an item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ItemMetadataLoading As ItemMetadataLoadEventHandler
'Usage

Dim instance As MetadataContainer
Dim handler As ItemMetadataLoadEventHandler

AddHandler instance.ItemMetadataLoading, handler
public event ItemMetadataLoadEventHandler ItemMetadataLoading
public: __event ItemMetadataLoadEventHandler* ItemMetadataLoading
Requirements

See Also

Reference

MetadataContainer Class
MetadataContainer Members


MetadataField Class

MetadataField Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataField Class
Class to represent fields of database objects in the Metadata Container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public NotInheritable Class MetadataField
   Inherits MetadataItem
'Usage

Dim instance As MetadataField
public sealed class MetadataField : MetadataItem
public __gc __sealed class MetadataField : public MetadataItem
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataItem
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataField

Requirements

See Also

Reference

MetadataField Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataField Class Members

MetadataField Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataField Class

The following tables list the members exposed by MetadataField.

Public Properties
 | Name | Description
Public Property | Expression | Gets or sets the SQL expression string for a virtual metadata field.
Public Property | ExpressionAST | Gets parsed SQL expression for a virtual metadata field.
Public Property | FieldType | Gets or sets field type of a field.
Public Property | FieldTypeName | Gets or sets native server data type name of a field.
Public Property | Nullable | Gets or sets the Nullable attribute of a field.
Public Property | Precision | Gets or sets the data type precision of a field.
Public Property | PrimaryKey | Gets or sets the Primary Key attribute of a field.
Public Property | ReadOnly | Gets or sets the Readonly attribute of a field.
Public Property | Scale | Gets or sets the data type scale of a field.
Public Property | Size | Gets or sets the data type size of a field.
Top
Public Methods
 | Name | Description
Public Method | IsVirtual | Indicates that the metadata object is a virtual calculated field.
Top
See Also

Reference

MetadataField Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataField Class Methods

MetadataField Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataField Class

For a list of all members of this type, see MetadataField members.

Public Methods
 | Name | Description
Public Method | IsVirtual | Indicates that the metadata object is a virtual calculated field.
Top
See Also

Reference

MetadataField Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


IsVirtual Method (MetadataField)

IsVirtual Method (MetadataField)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataField Class : IsVirtual Method
Indicates that the metadata object is a virtual calculated field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function IsVirtual() As System.Boolean
'Usage

Dim instance As MetadataField
Dim value As System.Boolean

value = instance.IsVirtual()
public System.bool IsVirtual()
public: System.bool IsVirtual();

Return Value

True if Expression is not empty; false otherwise.
Remarks
Virtual fields are replaced with expressions in result SQL query text. The Expression property of virtual metadata field must be set to valid SQL expression to be used as replacement for this field in result SQL query.
Requirements

See Also

Reference

MetadataField Class
MetadataField Members


MetadataField Class Properties

MetadataField Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataField Class

For a list of all members of this type, see MetadataField members.

Public Properties
 | Name | Description
Public Property | Expression | Gets or sets the SQL expression string for a virtual metadata field.
Public Property | ExpressionAST | Gets parsed SQL expression for a virtual metadata field.
Public Property | FieldType | Gets or sets field type of a field.
Public Property | FieldTypeName | Gets or sets native server data type name of a field.
Public Property | Nullable | Gets or sets the Nullable attribute of a field.
Public Property | Precision | Gets or sets the data type precision of a field.
Public Property | PrimaryKey | Gets or sets the Primary Key attribute of a field.
Public Property | ReadOnly | Gets or sets the Readonly attribute of a field.
Public Property | Scale | Gets or sets the data type scale of a field.
Public Property | Size | Gets or sets the data type size of a field.
Top
See Also

Reference

MetadataField Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Expression Property (MetadataField)

Expression Property (MetadataField)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataField Class : Expression Property
Gets or sets the SQL expression string for a virtual metadata field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Expression As System.String
'Usage

Dim instance As MetadataField
Dim value As System.String

instance.Expression = value

value = instance.Expression
public System.string Expression {get; set;}
public: __property System.string* get_Expression();
public: __property void set_Expression(
   System.string* value
);

Property Value

Valid SQL expression string to be used as replacement for this field in result SQL query text.
Remarks
Firtual fields are usually defined to hide complex SQL expressions or correlated sub-queries from the end-user.
Requirements

See Also

Reference

MetadataField Class
MetadataField Members


ExpressionAST Property (MetadataField)

ExpressionAST Property (MetadataField)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataField Class : ExpressionAST Property
Gets parsed SQL expression for a virtual metadata field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ExpressionAST As SQLExpressionItem
'Usage

Dim instance As MetadataField
Dim value As SQLExpressionItem

value = instance.ExpressionAST
public SQLExpressionItem ExpressionAST {get;}
public: __property SQLExpressionItem* get_ExpressionAST();
Requirements

See Also

Reference

MetadataField Class
MetadataField Members


FieldType Property (MetadataField)

FieldType Property (MetadataField)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataField Class : FieldType Property
Gets or sets field type of a field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property FieldType As System.Data.DbType
'Usage

Dim instance As MetadataField
Dim value As System.Data.DbType

instance.FieldType = value

value = instance.FieldType
public System.Data.DbType FieldType {get; set;}
public: __property System.Data.DbType get_FieldType();
public: __property void set_FieldType(
   System.Data.DbType value
);
Requirements

See Also

Reference

MetadataField Class
MetadataField Members


FieldTypeName Property

FieldTypeName Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataField Class : FieldTypeName Property
Gets or sets native server data type name of a field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property FieldTypeName As System.String
'Usage

Dim instance As MetadataField
Dim value As System.String

instance.FieldTypeName = value

value = instance.FieldTypeName
public System.string FieldTypeName {get; set;}
public: __property System.string* get_FieldTypeName();
public: __property void set_FieldTypeName(
   System.string* value
);
Requirements

See Also

Reference

MetadataField Class
MetadataField Members


Nullable Property

Nullable Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataField Class : Nullable Property
Gets or sets the Nullable attribute of a field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Nullable As System.Boolean
'Usage

Dim instance As MetadataField
Dim value As System.Boolean

instance.Nullable = value

value = instance.Nullable
public System.bool Nullable {get; set;}
public: __property System.bool get_Nullable();
public: __property void set_Nullable(
   System.bool value
);
Requirements

See Also

Reference

MetadataField Class
MetadataField Members


Precision Property (MetadataField)

Precision Property (MetadataField)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataField Class : Precision Property
Gets or sets the data type precision of a field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Precision As System.Integer
'Usage

Dim instance As MetadataField
Dim value As System.Integer

instance.Precision = value

value = instance.Precision
public System.int Precision {get; set;}
public: __property System.int get_Precision();
public: __property void set_Precision(
   System.int value
);
Requirements

See Also

Reference

MetadataField Class
MetadataField Members


PrimaryKey Property

PrimaryKey Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataField Class : PrimaryKey Property
Gets or sets the Primary Key attribute of a field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property PrimaryKey As System.Boolean
'Usage

Dim instance As MetadataField
Dim value As System.Boolean

instance.PrimaryKey = value

value = instance.PrimaryKey
public System.bool PrimaryKey {get; set;}
public: __property System.bool get_PrimaryKey();
public: __property void set_PrimaryKey(
   System.bool value
);
Requirements

See Also

Reference

MetadataField Class
MetadataField Members


ReadOnly Property

ReadOnly Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataField Class : ReadOnly Property
Gets or sets the Readonly attribute of a field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ReadOnly As System.Boolean
'Usage

Dim instance As MetadataField
Dim value As System.Boolean

instance.ReadOnly = value

value = instance.ReadOnly
public System.bool ReadOnly {get; set;}
public: __property System.bool get_ReadOnly();
public: __property void set_ReadOnly(
   System.bool value
);
Requirements

See Also

Reference

MetadataField Class
MetadataField Members


Scale Property (MetadataField)

Scale Property (MetadataField)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataField Class : Scale Property
Gets or sets the data type scale of a field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Scale As System.Integer
'Usage

Dim instance As MetadataField
Dim value As System.Integer

instance.Scale = value

value = instance.Scale
public System.int Scale {get; set;}
public: __property System.int get_Scale();
public: __property void set_Scale(
   System.int value
);
Requirements

See Also

Reference

MetadataField Class
MetadataField Members


Size Property (MetadataField)

Size Property (MetadataField)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataField Class : Size Property
Gets or sets the data type size of a field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Size As System.Integer
'Usage

Dim instance As MetadataField
Dim value As System.Integer

instance.Size = value

value = instance.Size
public System.int Size {get; set;}
public: __property System.int get_Size();
public: __property void set_Size(
   System.int value
);
Requirements

See Also

Reference

MetadataField Class
MetadataField Members


MetadataFilter Class

MetadataFilter Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataFilter Class
Defines a set of rules to filter metadata.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MetadataFilter
   Inherits ActiveDatabaseSoftware.ActiveQueryBuilder.UpdatableObjectList(Of MetadataFilterItem)
'Usage

Dim instance As MetadataFilter
public class MetadataFilter : ActiveDatabaseSoftware.ActiveQueryBuilder.UpdatableObjectList<MetadataFilterItem>
public __gc class MetadataFilter : public ActiveDatabaseSoftware.ActiveQueryBuilder.UpdatableObjectList<MetadataFilterItem>
Remarks

Each rule defined in the list is represented by MetadataFilterItem object. Metadata filter may have multiple exclusion and inclusion items (rules). If metadata filter has no inclusion items, the exculsion items will be applied to the whole database schema. If metadata filter has some inclusion items, they will constitute a subset of database schema, to which the exclusion items will be applied.

You may treat those rules as SQL conditions combined with OR operators in WHERE clause of the SELECT statement that retrieves the list of objects to be loaded to the Metadata Container. Conditions marked with the MetadataFilterItem.Exclude flag are prefixed with NOT operator. The result SQL condition will look like the following: "([inculsion rule] OR [inclusion rule] OR ...) AND NOT ([exculsion rule] OR [exclusion rule] OR ...)"

Alternate way to define metadata filtration rules is to use the MetadataLoadingOptions.ExcludeFilter and MetadataLoadingOptions.IncludeFilter. You may use both types of filters at a time: the conditions set using MetadataSimpleFilter will be converted to a set of MetadataFilterItems which will be added to the MetadataFilter.

Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataFilter

Requirements

See Also

Reference

MetadataFilter Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataFilter Class Members

MetadataFilter Class Members
Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataFilter Class

The following tables list the members exposed by MetadataFilter.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds new Metadata Filter item to collection
Public Method | Filter | Holds the list of metadata filter items.
Public Method | Insert | Overloaded. Adds new Metadata Filter item to the specified position in collection.
Top
See Also

Reference

MetadataFilter Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataFilter Class Methods

MetadataFilter Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataFilter Class

For a list of all members of this type, see MetadataFilter members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds new Metadata Filter item to collection
Public Method | Filter | Holds the list of metadata filter items.
Public Method | Insert | Overloaded. Adds new Metadata Filter item to the specified position in collection.
Top
See Also

Reference

MetadataFilter Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Add Method (MetadataFilter)

Add Method (MetadataFilter)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataFilter Class : Add Method
Adds new Metadata Filter item to collection
Overload List
Overload | Description
Add() | Adds new Metadata Filter item to collection
Requirements

See Also

Reference

MetadataFilter Class
MetadataFilter Members


Add() Method

Add() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataFilter Class > Add Method : Add() Method
Adds new Metadata Filter item to collection
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function Add() As MetadataFilterItem
'Usage

Dim instance As MetadataFilter
Dim value As MetadataFilterItem

value = instance.Add()
public MetadataFilterItem Add()
public: MetadataFilterItem* Add();

Return Value

Returns reference to the newly created item.
Requirements

See Also

Reference

MetadataFilter Class
MetadataFilter Members
Overload List


Filter Method

Filter Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataFilter Class : Filter Method
Holds the list of metadata filter items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function Filter( _
   ByVal items As System.Collections.Generic.ICollection(Of MetadataItem) _
) As System.Collections.Generic.IList(Of MetadataItem)
'Usage

Dim instance As MetadataFilter
Dim items As System.Collections.Generic.ICollection(Of MetadataItem)
Dim value As System.Collections.Generic.IList(Of MetadataItem)

value = instance.Filter(items)
public System.Collections.Generic.IList<MetadataItem> Filter(
   System.Collections.Generic.ICollection<MetadataItem> items
)
public: System.Collections.Generic.IList<MetadataItem*>* Filter(
   System.Collections.Generic.ICollection<MetadataItem*>* items
)

Parameters

items
Requirements

See Also

Reference

MetadataFilter Class
MetadataFilter Members


Insert Method (MetadataFilter)

Insert Method (MetadataFilter)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataFilter Class : Insert Method
Adds new Metadata Filter item to the specified position in collection.
Overload List
Overload | Description
Insert(Int32) | Adds new Metadata Filter item to the specified position in collection.
Requirements

See Also

Reference

MetadataFilter Class
MetadataFilter Members


Insert(Int32) Method

Insert(Int32) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataFilter Class > Insert Method : Insert(Int32) Method
specifies position for a new item
Adds new Metadata Filter item to the specified position in collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function Insert( _
   ByVal index As System.Integer _
) As MetadataFilterItem
'Usage

Dim instance As MetadataFilter
Dim index As System.Integer
Dim value As MetadataFilterItem

value = instance.Insert(index)
public MetadataFilterItem Insert(
   System.int index
)
public: MetadataFilterItem* Insert(
   System.int index
)

Parameters

index
specifies position for a new item

Return Value

Returns reference to the newly created item.
Requirements

See Also

Reference

MetadataFilter Class
MetadataFilter Members
Overload List


MetadataFilterItem Class

MetadataFilterItem Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataFilterItem Class
Defines single metadata filtration rule.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MetadataFilterItem
   Inherits AggregatedBatchUpdatableBase
'Usage

Dim instance As MetadataFilterItem
public class MetadataFilterItem : AggregatedBatchUpdatableBase
public __gc class MetadataFilterItem : public AggregatedBatchUpdatableBase
Remarks

Metadata filter item is a set of masks and flags that determines single filtration rule. Each rule can instruct to include or exclude metadata items that match the masks. Use the Exclude property to specify if this rule defines objects for exclusion or inclusion.

Masks act similar to the "LIKE" SQL operator. Use the percent sign (%) to represent any sequence of characters; use the underscore sign (_) to represent any single character. If you want to define a set of masks for specific property (schema or object name), you have to add multiple filter items.

Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataFilterItem

Requirements

See Also

Reference

MetadataFilterItem Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataFilterItem Class Members

MetadataFilterItem Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataFilterItem Class

The following tables list the members exposed by MetadataFilterItem.

Public Properties
 | Name | Description
Public Property | CaseSensitive | Instructs to treat masks as case sensitive or not.
Public Property | Database | Gets or sets database name mask.
Public Property | Exclude | Determines if this rule acts to exclude matching metadata items or include them.
Public Property | Field | Gets or sets field name mask.
Public Property | FlagSystem | Determines if this item will select matching system metadata objects or not.
Public Property | FlagUser | Determines if this item will select matching system metadata objects or not.
Public Property | Object | Gets or sets object name mask.
Public Property | ObjectTypes | Defines which types of database objects (tables, views, etc.) will be selected by this item.
Public Property | Package | Gets or sets package name mask.
Public Property | Schema | Gets or sets schema name mask.
Public Property | Server | Gets or sets server name mask.
Top
See Also

Reference

MetadataFilterItem Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataFilterItem Class Properties

MetadataFilterItem Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataFilterItem Class

For a list of all members of this type, see MetadataFilterItem members.

Public Properties
 | Name | Description
Public Property | CaseSensitive | Instructs to treat masks as case sensitive or not.
Public Property | Database | Gets or sets database name mask.
Public Property | Exclude | Determines if this rule acts to exclude matching metadata items or include them.
Public Property | Field | Gets or sets field name mask.
Public Property | FlagSystem | Determines if this item will select matching system metadata objects or not.
Public Property | FlagUser | Determines if this item will select matching system metadata objects or not.
Public Property | Object | Gets or sets object name mask.
Public Property | ObjectTypes | Defines which types of database objects (tables, views, etc.) will be selected by this item.
Public Property | Package | Gets or sets package name mask.
Public Property | Schema | Gets or sets schema name mask.
Public Property | Server | Gets or sets server name mask.
Top
See Also

Reference

MetadataFilterItem Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


CaseSensitive Property (MetadataFilterItem)

CaseSensitive Property (MetadataFilterItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataFilterItem Class : CaseSensitive Property
Instructs to treat masks as case sensitive or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property CaseSensitive As System.Boolean
'Usage

Dim instance As MetadataFilterItem
Dim value As System.Boolean

instance.CaseSensitive = value

value = instance.CaseSensitive
public System.bool CaseSensitive {get; set;}
public: __property System.bool get_CaseSensitive();
public: __property void set_CaseSensitive(
   System.bool value
);

Property Value

True to treat masks as case sensitive; false - case insensitive.
Requirements

See Also

Reference

MetadataFilterItem Class
MetadataFilterItem Members


Database Property (MetadataFilterItem)

Database Property (MetadataFilterItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataFilterItem Class : Database Property
Gets or sets database name mask.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Database As System.String
'Usage

Dim instance As MetadataFilterItem
Dim value As System.String

instance.Database = value

value = instance.Database
public System.string Database {get; set;}
public: __property System.string* get_Database();
public: __property void set_Database(
   System.string* value
);
Requirements

See Also

Reference

MetadataFilterItem Class
MetadataFilterItem Members


Exclude Property

Exclude Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataFilterItem Class : Exclude Property
Determines if this rule acts to exclude matching metadata items or include them.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Exclude As System.Boolean
'Usage

Dim instance As MetadataFilterItem
Dim value As System.Boolean

instance.Exclude = value

value = instance.Exclude
public System.bool Exclude {get; set;}
public: __property System.bool get_Exclude();
public: __property void set_Exclude(
   System.bool value
);

Property Value

True instructs to make this rule exclusive; false to make this rule inclusive.
Remarks
If metadata filter has no inclusion items, the exculsion items will be applied to the whole database schema. If metadata filter has some inclusion items, they will constitute a subset of database schema, to which the exclusion items will be applied.
Requirements

See Also

Reference

MetadataFilterItem Class
MetadataFilterItem Members


Field Property

Field Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataFilterItem Class : Field Property
Gets or sets field name mask.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Field As System.String
'Usage

Dim instance As MetadataFilterItem
Dim value As System.String

instance.Field = value

value = instance.Field
public System.string Field {get; set;}
public: __property System.string* get_Field();
public: __property void set_Field(
   System.string* value
);
Requirements

See Also

Reference

MetadataFilterItem Class
MetadataFilterItem Members


FlagSystem Property

FlagSystem Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataFilterItem Class : FlagSystem Property
Determines if this item will select matching system metadata objects or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property FlagSystem As System.Boolean
'Usage

Dim instance As MetadataFilterItem
Dim value As System.Boolean

instance.FlagSystem = value

value = instance.FlagSystem
public System.bool FlagSystem {get; set;}
public: __property System.bool get_FlagSystem();
public: __property void set_FlagSystem(
   System.bool value
);
Requirements

See Also

Reference

MetadataFilterItem Class
MetadataFilterItem Members


FlagUser Property

FlagUser Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataFilterItem Class : FlagUser Property
Determines if this item will select matching system metadata objects or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property FlagUser As System.Boolean
'Usage

Dim instance As MetadataFilterItem
Dim value As System.Boolean

instance.FlagUser = value

value = instance.FlagUser
public System.bool FlagUser {get; set;}
public: __property System.bool get_FlagUser();
public: __property void set_FlagUser(
   System.bool value
);
Requirements

See Also

Reference

MetadataFilterItem Class
MetadataFilterItem Members


Object Property (MetadataFilterItem)

Object Property (MetadataFilterItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataFilterItem Class : Object Property
Gets or sets object name mask.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Object As System.String
'Usage

Dim instance As MetadataFilterItem
Dim value As System.String

instance.Object = value

value = instance.Object
public System.string Object {get; set;}
public: __property System.string* get_Object();
public: __property void set_Object(
   System.string* value
);
Requirements

See Also

Reference

MetadataFilterItem Class
MetadataFilterItem Members


ObjectTypes Property

ObjectTypes Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataFilterItem Class : ObjectTypes Property
Defines which types of database objects (tables, views, etc.) will be selected by this item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ObjectTypes As MetadataType
'Usage

Dim instance As MetadataFilterItem
Dim value As MetadataType

instance.ObjectTypes = value

value = instance.ObjectTypes
public MetadataType ObjectTypes {get; set;}
public: __property MetadataType get_ObjectTypes();
public: __property void set_ObjectTypes(
   MetadataType value
);
Requirements

See Also

Reference

MetadataFilterItem Class
MetadataFilterItem Members


Package Property (MetadataFilterItem)

Package Property (MetadataFilterItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataFilterItem Class : Package Property
Gets or sets package name mask.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Package As System.String
'Usage

Dim instance As MetadataFilterItem
Dim value As System.String

instance.Package = value

value = instance.Package
public System.string Package {get; set;}
public: __property System.string* get_Package();
public: __property void set_Package(
   System.string* value
);
Requirements

See Also

Reference

MetadataFilterItem Class
MetadataFilterItem Members


Schema Property (MetadataFilterItem)

Schema Property (MetadataFilterItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataFilterItem Class : Schema Property
Gets or sets schema name mask.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Schema As System.String
'Usage

Dim instance As MetadataFilterItem
Dim value As System.String

instance.Schema = value

value = instance.Schema
public System.string Schema {get; set;}
public: __property System.string* get_Schema();
public: __property void set_Schema(
   System.string* value
);
Requirements

See Also

Reference

MetadataFilterItem Class
MetadataFilterItem Members


Server Property (MetadataFilterItem)

Server Property (MetadataFilterItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataFilterItem Class : Server Property
Gets or sets server name mask.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Server As System.String
'Usage

Dim instance As MetadataFilterItem
Dim value As System.String

instance.Server = value

value = instance.Server
public System.string Server {get; set;}
public: __property System.string* get_Server();
public: __property void set_Server(
   System.string* value
);
Requirements

See Also

Reference

MetadataFilterItem Class
MetadataFilterItem Members


MetadataForeignKey Class

MetadataForeignKey Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataForeignKey Class
Class to represent foreign key relationships in the Metadata Container.
Object Model
MetadataForeignKey ClassMetadataNameList ClassMetadataNameList ClassMetadataObject Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MetadataForeignKey
   Inherits MetadataItem
'Usage

Dim instance As MetadataForeignKey
public class MetadataForeignKey : MetadataItem
public __gc class MetadataForeignKey : public MetadataItem
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataItem
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataForeignKey

Requirements

See Also

Reference

MetadataForeignKey Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataForeignKey Class Members

MetadataForeignKey Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataForeignKey Class

The following tables list the members exposed by MetadataForeignKey.

Public Properties
 | Name | Description
Public Property | Cardinality | Gets or sets cardinality of the referential side of relationship.
Public Property | Fields | Gets or sets list of fields of the referential side of relationship.
Public Property | ReferencedCardinality | Gets or sets cardinality of the referenced side of relationship.
Public Property | ReferencedFields | Gets or sets list of fields of the referenced side of relationship.
Public Property | ReferencedObject | Gets or sets the referenced metadata object of relationship.
Public Property | ReferencedObjectName | Gets or sets the name of referenced metadata object of relationship.
Top
See Also

Reference

MetadataForeignKey Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataForeignKey Class Properties

MetadataForeignKey Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataForeignKey Class

For a list of all members of this type, see MetadataForeignKey members.

Public Properties
 | Name | Description
Public Property | Cardinality | Gets or sets cardinality of the referential side of relationship.
Public Property | Fields | Gets or sets list of fields of the referential side of relationship.
Public Property | ReferencedCardinality | Gets or sets cardinality of the referenced side of relationship.
Public Property | ReferencedFields | Gets or sets list of fields of the referenced side of relationship.
Public Property | ReferencedObject | Gets or sets the referenced metadata object of relationship.
Public Property | ReferencedObjectName | Gets or sets the name of referenced metadata object of relationship.
Top
See Also

Reference

MetadataForeignKey Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Cardinality Property

Cardinality Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataForeignKey Class : Cardinality Property
Gets or sets cardinality of the referential side of relationship.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Cardinality As MetadataForeignKeyCardinality
'Usage

Dim instance As MetadataForeignKey
Dim value As MetadataForeignKeyCardinality

instance.Cardinality = value

value = instance.Cardinality
public MetadataForeignKeyCardinality Cardinality {get; set;}
public: __property MetadataForeignKeyCardinality get_Cardinality();
public: __property void set_Cardinality(
   MetadataForeignKeyCardinality value
);
Requirements

See Also

Reference

MetadataForeignKey Class
MetadataForeignKey Members


Fields Property (MetadataForeignKey)

Fields Property (MetadataForeignKey)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataForeignKey Class : Fields Property
Gets or sets list of fields of the referential side of relationship.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Fields As MetadataNameList
'Usage

Dim instance As MetadataForeignKey
Dim value As MetadataNameList

instance.Fields = value

value = instance.Fields
public MetadataNameList Fields {get; set;}
public: __property MetadataNameList* get_Fields();
public: __property void set_Fields(
   MetadataNameList* value
);
Requirements

See Also

Reference

MetadataForeignKey Class
MetadataForeignKey Members


ReferencedCardinality Property

ReferencedCardinality Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataForeignKey Class : ReferencedCardinality Property
Gets or sets cardinality of the referenced side of relationship.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ReferencedCardinality As MetadataForeignKeyCardinality
'Usage

Dim instance As MetadataForeignKey
Dim value As MetadataForeignKeyCardinality

instance.ReferencedCardinality = value

value = instance.ReferencedCardinality
public MetadataForeignKeyCardinality ReferencedCardinality {get; set;}
public: __property MetadataForeignKeyCardinality get_ReferencedCardinality();
public: __property void set_ReferencedCardinality(
   MetadataForeignKeyCardinality value
);
Requirements

See Also

Reference

MetadataForeignKey Class
MetadataForeignKey Members


ReferencedFields Property

ReferencedFields Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataForeignKey Class : ReferencedFields Property
Gets or sets list of fields of the referenced side of relationship.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ReferencedFields As MetadataNameList
'Usage

Dim instance As MetadataForeignKey
Dim value As MetadataNameList

instance.ReferencedFields = value

value = instance.ReferencedFields
public MetadataNameList ReferencedFields {get; set;}
public: __property MetadataNameList* get_ReferencedFields();
public: __property void set_ReferencedFields(
   MetadataNameList* value
);
Requirements

See Also

Reference

MetadataForeignKey Class
MetadataForeignKey Members


ReferencedObject Property (MetadataForeignKey)

ReferencedObject Property (MetadataForeignKey)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataForeignKey Class : ReferencedObject Property
Gets or sets the referenced metadata object of relationship.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ReferencedObject As MetadataObject
'Usage

Dim instance As MetadataForeignKey
Dim value As MetadataObject

instance.ReferencedObject = value

value = instance.ReferencedObject
public MetadataObject ReferencedObject {get; set;}
public: __property MetadataObject* get_ReferencedObject();
public: __property void set_ReferencedObject(
   MetadataObject* value
);
Requirements

See Also

Reference

MetadataForeignKey Class
MetadataForeignKey Members


ReferencedObjectName Property (MetadataForeignKey)

ReferencedObjectName Property (MetadataForeignKey)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataForeignKey Class : ReferencedObjectName Property
Gets or sets the name of referenced metadata object of relationship.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ReferencedObjectName As MetadataQualifiedName
'Usage

Dim instance As MetadataForeignKey
Dim value As MetadataQualifiedName

instance.ReferencedObjectName = value

value = instance.ReferencedObjectName
public MetadataQualifiedName ReferencedObjectName {get; set;}
public: __property MetadataQualifiedName* get_ReferencedObjectName();
public: __property void set_ReferencedObjectName(
   MetadataQualifiedName* value
);
Requirements

See Also

Reference

MetadataForeignKey Class
MetadataForeignKey Members


MetadataItem Class

MetadataItem Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataItem Class
Base class for all items of the Metadata Container. Represens a node in the Metadata Container tree.
Object Model
MetadataItem ClassMetadataNamespace ClassMetadataList ClassMetadataContainer ClassMetadataObject ClassMetadataNamespace ClassMetadataItem ClassMetadataList ClassMetadataNamespace ClassMetadataNamespace ClassBaseSQLContext Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public MustInherit Class MetadataItem
   Inherits BatchUpdatableBase
'Usage

Dim instance As MetadataItem
public abstract class MetadataItem : BatchUpdatableBase
public __gc abstract class MetadataItem : public BatchUpdatableBase
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataItem
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataAggregate
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataContainer
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataField
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataForeignKey
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataNamespace
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataObject
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataParameter

Requirements

See Also

Reference

MetadataItem Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataItem Class Members

MetadataItem Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataItem Class

The following tables list the members exposed by MetadataItem.

Public Properties
 | Name | Description
Public Property | AltName | Alternate name of the metadata item.
Public Property | Database | Refers to the parent node of Database type.
Public Property | Default | Indicates if the namespace metadata item is default one.
Public Property | Description | Description of the metadata item.
Public Property | Items | Lists the child nodes of this one.
Public Property | MetadataContainer | Refers to the Metadata Container object to which this item belongs to.
Public Property | Name | Unquoted name of the metadata item.
Public Property | NameFull | Returns fully qualified name of the metadata item in form [database].[schema].[name].
Public Property | NameQuoted | Name of the metadata item, quoted if required.
Public Property | Object | Refers to the parent node of database object type.
Public Property | Package | Refers to the parent node of Package type.
Public Property | Parent | Points to the parent node of the tree.
Public Property | ParentItems | Points to the list of child metadata items of the parent node.
Public Property | Schema | Refers to the parent node of Schema type.
Public Property | Server | Refers to the parent node of Server type.
Public Property | SQLContext | Refers to the context for SQL generation, SQL parsing and metadata loading purposes.
Public Property | System | Indicates if the metadata item is system or user object.
Public Property | Type | Determines the type of Metadata Item (root, namespace, database object, field, etc.).
Top
Public Methods
 | Name | Description
Public Method | AddDatabase | Adds and returns new child metadata item of the Database type.
Public Method | AddField | Adds and returns new child metadata item of the Field type.
Public Method | AddForeignKey | Adds and returns new child metadata item of the Foreign Key type.
Public Method | AddNamespace | Adds and returns new child metadata item of the specified namespace type.
Public Method | AddObject | Adds and returns new child metadata item of the specified database object type.
Public Method | AddPackage | Adds and returns new child metadata item of the Package type.
Public Method | AddParameter | Adds and returns new child metadata item of the Parameter type.
Public Method | AddProcedure | Adds and returns new child metadata item of the Procedure type.
Public Method | AddSchema | Adds and returns new child metadata item of the Schema type.
Public Method | AddServer | Adds and returns new child metadata item of the Server type.
Public Method | AddSynonym | Adds and returns new child metadata item of the Synonym type.
Public Method | AddTable | Adds and returns new child metadata item of the Table type.
Public Method | AddView | Adds and returns new child metadata item of the View type.
Public Method | FindItem | Overloaded. Finds first (and loads all if not loaded) metadata item matching the specified Metadata Qualified Name of specific types in the child items hierarchy.
Public Method | FindItems | Overloaded. Finds (and loads if not loaded) metadata items according to the specified Metadata Filter of specific types in the child items hierarchy.
Public Method | LoadAll | Recursively loads metadata for all items.
Top
Public Events
 | Name | Description
Public Event | AltNameChanged | Fires on changing the alternate name of metadata item.
Public Event | DefaultChanged | Fires on changing the Default attribute of metadata item.
Public Event | FilteringPropsChanged | Fires on changing the attributes of metadata item that affect the filtering.
Public Event | MetadataChildItemAdded | Fires on adding a child metadata item to the hierarchy of child items.
Public Event | MetadataChildItemRemoving | Fires on removing a metadata item from the hierarchy of child items.
Public Event | NameChanged | Fires on changing the name of metadata item.
Public Event | SystemChanged | Fires on changing the System attribute of metadata item.
Top
See Also

Reference

MetadataItem Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataItem Class Methods

MetadataItem Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataItem Class

For a list of all members of this type, see MetadataItem members.

Public Methods
 | Name | Description
Public Method | AddDatabase | Adds and returns new child metadata item of the Database type.
Public Method | AddField | Adds and returns new child metadata item of the Field type.
Public Method | AddForeignKey | Adds and returns new child metadata item of the Foreign Key type.
Public Method | AddNamespace | Adds and returns new child metadata item of the specified namespace type.
Public Method | AddObject | Adds and returns new child metadata item of the specified database object type.
Public Method | AddPackage | Adds and returns new child metadata item of the Package type.
Public Method | AddParameter | Adds and returns new child metadata item of the Parameter type.
Public Method | AddProcedure | Adds and returns new child metadata item of the Procedure type.
Public Method | AddSchema | Adds and returns new child metadata item of the Schema type.
Public Method | AddServer | Adds and returns new child metadata item of the Server type.
Public Method | AddSynonym | Adds and returns new child metadata item of the Synonym type.
Public Method | AddTable | Adds and returns new child metadata item of the Table type.
Public Method | AddView | Adds and returns new child metadata item of the View type.
Public Method | FindItem | Overloaded. Finds first (and loads all if not loaded) metadata item matching the specified Metadata Qualified Name of specific types in the child items hierarchy.
Public Method | FindItems | Overloaded. Finds (and loads if not loaded) metadata items according to the specified Metadata Filter of specific types in the child items hierarchy.
Public Method | LoadAll | Recursively loads metadata for all items.
Top
See Also

Reference

MetadataItem Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AddDatabase Method

AddDatabase Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : AddDatabase Method
Adds and returns new child metadata item of the Database type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function AddDatabase( _
   ByVal name As System.String _
) As MetadataNamespace
'Usage

Dim instance As MetadataItem
Dim name As System.String
Dim value As MetadataNamespace

value = instance.AddDatabase(name)
public MetadataNamespace AddDatabase(
   System.string name
)
public: MetadataNamespace* AddDatabase(
   System.string* name
)

Parameters

name
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


AddField Method

AddField Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : AddField Method
Adds and returns new child metadata item of the Field type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function AddField( _
   ByVal name As System.String _
) As MetadataField
'Usage

Dim instance As MetadataItem
Dim name As System.String
Dim value As MetadataField

value = instance.AddField(name)
public MetadataField AddField(
   System.string name
)
public: MetadataField* AddField(
   System.string* name
)

Parameters

name
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


AddForeignKey Method

AddForeignKey Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : AddForeignKey Method
Adds and returns new child metadata item of the Foreign Key type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function AddForeignKey( _
   ByVal name As System.String _
) As MetadataForeignKey
'Usage

Dim instance As MetadataItem
Dim name As System.String
Dim value As MetadataForeignKey

value = instance.AddForeignKey(name)
public MetadataForeignKey AddForeignKey(
   System.string name
)
public: MetadataForeignKey* AddForeignKey(
   System.string* name
)

Parameters

name
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


AddNamespace Method

AddNamespace Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : AddNamespace Method
Adds and returns new child metadata item of the specified namespace type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function AddNamespace( _
   ByVal name As System.String, _
   ByVal type As MetadataType _
) As MetadataNamespace
'Usage

Dim instance As MetadataItem
Dim name As System.String
Dim type As MetadataType
Dim value As MetadataNamespace

value = instance.AddNamespace(name, type)
public MetadataNamespace AddNamespace(
   System.string name,
   MetadataType type
)
public: MetadataNamespace* AddNamespace(
   System.string* name,
   MetadataType type
)

Parameters

name
type
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


AddObject Method

AddObject Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : AddObject Method
Adds and returns new child metadata item of the specified database object type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function AddObject( _
   ByVal name As System.String, _
   ByVal type As MetadataType _
) As MetadataObject
'Usage

Dim instance As MetadataItem
Dim name As System.String
Dim type As MetadataType
Dim value As MetadataObject

value = instance.AddObject(name, type)
public MetadataObject AddObject(
   System.string name,
   MetadataType type
)
public: MetadataObject* AddObject(
   System.string* name,
   MetadataType type
)

Parameters

name
type
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


AddPackage Method

AddPackage Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : AddPackage Method
Adds and returns new child metadata item of the Package type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function AddPackage( _
   ByVal name As System.String _
) As MetadataNamespace
'Usage

Dim instance As MetadataItem
Dim name As System.String
Dim value As MetadataNamespace

value = instance.AddPackage(name)
public MetadataNamespace AddPackage(
   System.string name
)
public: MetadataNamespace* AddPackage(
   System.string* name
)

Parameters

name
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


AddParameter Method

AddParameter Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : AddParameter Method
Adds and returns new child metadata item of the Parameter type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function AddParameter( _
   ByVal name As System.String _
) As MetadataParameter
'Usage

Dim instance As MetadataItem
Dim name As System.String
Dim value As MetadataParameter

value = instance.AddParameter(name)
public MetadataParameter AddParameter(
   System.string name
)
public: MetadataParameter* AddParameter(
   System.string* name
)

Parameters

name
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


AddProcedure Method

AddProcedure Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : AddProcedure Method
Adds and returns new child metadata item of the Procedure type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function AddProcedure( _
   ByVal name As System.String _
) As MetadataObject
'Usage

Dim instance As MetadataItem
Dim name As System.String
Dim value As MetadataObject

value = instance.AddProcedure(name)
public MetadataObject AddProcedure(
   System.string name
)
public: MetadataObject* AddProcedure(
   System.string* name
)

Parameters

name
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


AddSchema Method

AddSchema Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : AddSchema Method
Adds and returns new child metadata item of the Schema type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function AddSchema( _
   ByVal name As System.String _
) As MetadataNamespace
'Usage

Dim instance As MetadataItem
Dim name As System.String
Dim value As MetadataNamespace

value = instance.AddSchema(name)
public MetadataNamespace AddSchema(
   System.string name
)
public: MetadataNamespace* AddSchema(
   System.string* name
)

Parameters

name
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


AddServer Method

AddServer Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : AddServer Method
Adds and returns new child metadata item of the Server type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function AddServer( _
   ByVal name As System.String _
) As MetadataNamespace
'Usage

Dim instance As MetadataItem
Dim name As System.String
Dim value As MetadataNamespace

value = instance.AddServer(name)
public MetadataNamespace AddServer(
   System.string name
)
public: MetadataNamespace* AddServer(
   System.string* name
)

Parameters

name
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


AddSynonym Method

AddSynonym Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : AddSynonym Method
Adds and returns new child metadata item of the Synonym type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function AddSynonym( _
   ByVal name As System.String _
) As MetadataObject
'Usage

Dim instance As MetadataItem
Dim name As System.String
Dim value As MetadataObject

value = instance.AddSynonym(name)
public MetadataObject AddSynonym(
   System.string name
)
public: MetadataObject* AddSynonym(
   System.string* name
)

Parameters

name
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


AddTable Method

AddTable Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : AddTable Method
Adds and returns new child metadata item of the Table type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function AddTable( _
   ByVal name As System.String _
) As MetadataObject
'Usage

Dim instance As MetadataItem
Dim name As System.String
Dim value As MetadataObject

value = instance.AddTable(name)
public MetadataObject AddTable(
   System.string name
)
public: MetadataObject* AddTable(
   System.string* name
)

Parameters

name
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


AddView Method

AddView Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : AddView Method
Adds and returns new child metadata item of the View type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function AddView( _
   ByVal name As System.String _
) As MetadataObject
'Usage

Dim instance As MetadataItem
Dim name As System.String
Dim value As MetadataObject

value = instance.AddView(name)
public MetadataObject AddView(
   System.string name
)
public: MetadataObject* AddView(
   System.string* name
)

Parameters

name
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


FindItem Method (MetadataItem)

FindItem Method (MetadataItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : FindItem Method
Finds first (and loads all if not loaded) metadata item matching the specified Metadata Qualified Name of specific types in the child items hierarchy.
Overload List
Overload | Description
FindItem<T>(MetadataQualifiedName,MetadataType) | Finds first (and loads all if not loaded) metadata item matching the specified Metadata Qualified Name of specific types in the child items hierarchy.
FindItem<T>(MetadataQualifiedName) | Finds first (and loads all if not loaded) metadata item matching the specified Metadata Qualified Name in the child items hierarchy.
FindItem<T>(SQLQualifiedName,MetadataType) | Finds first (and loads all if not loaded) item matching the specified SQL Qualified Name of specific types in the child items hierarchy.
FindItem<T>(SQLQualifiedName) | Finds first (and loads all if not loaded) metadata item matching the specified SQL Qualified Name in the child items hierarchy.
FindItem<T>(String,MetadataType) | Finds first (and loads all if not loaded) metadata item matching the specified string of specific types in the child items hierarchy.
FindItem<T>(String) | Finds first (and loads all if not loaded) metadata item matching the specified string in the child items hierarchy.
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


FindItem<T>(MetadataQualifiedName,MetadataType) Method

FindItem<T>(MetadataQualifiedName,MetadataType) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class > FindItem Method : FindItem<T>(MetadataQualifiedName,MetadataType) Method
Finds first (and loads all if not loaded) metadata item matching the specified Metadata Qualified Name of specific types in the child items hierarchy.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItem(Of T As MetadataItem)( _
   ByVal name As MetadataQualifiedName, _
   ByVal types As MetadataType _
) As T
'Usage

Dim instance As MetadataItem
Dim name As MetadataQualifiedName
Dim types As MetadataType
Dim value As T

value = instance.FindItem(Of T)(name, types)
public T FindItem<T>(
   MetadataQualifiedName name,
   MetadataType types
)
where T: MetadataItem
public: T* FindItem<T>(
   MetadataQualifiedName* name,
   MetadataType types
)
where T: MetadataItem

Parameters

name
types

Type Parameters

T
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members
Overload List


FindItem<T>(MetadataQualifiedName) Method

FindItem<T>(MetadataQualifiedName) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class > FindItem Method : FindItem<T>(MetadataQualifiedName) Method
Finds first (and loads all if not loaded) metadata item matching the specified Metadata Qualified Name in the child items hierarchy.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItem(Of T As MetadataItem)( _
   ByVal name As MetadataQualifiedName _
) As T
'Usage

Dim instance As MetadataItem
Dim name As MetadataQualifiedName
Dim value As T

value = instance.FindItem(Of T)(name)
public T FindItem<T>(
   MetadataQualifiedName name
)
where T: MetadataItem
public: T* FindItem<T>(
   MetadataQualifiedName* name
)
where T: MetadataItem

Parameters

name

Type Parameters

T
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members
Overload List


FindItem<T>(SQLQualifiedName,MetadataType) Method

FindItem<T>(SQLQualifiedName,MetadataType) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class > FindItem Method : FindItem<T>(SQLQualifiedName,MetadataType) Method
Finds first (and loads all if not loaded) item matching the specified SQL Qualified Name of specific types in the child items hierarchy.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItem(Of T As MetadataItem)( _
   ByVal name As SQLQualifiedName, _
   ByVal types As MetadataType _
) As T
'Usage

Dim instance As MetadataItem
Dim name As SQLQualifiedName
Dim types As MetadataType
Dim value As T

value = instance.FindItem(Of T)(name, types)
public T FindItem<T>(
   SQLQualifiedName name,
   MetadataType types
)
where T: MetadataItem
public: T* FindItem<T>(
   SQLQualifiedName* name,
   MetadataType types
)
where T: MetadataItem

Parameters

name
types

Type Parameters

T
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members
Overload List


FindItem<T>(SQLQualifiedName) Method

FindItem<T>(SQLQualifiedName) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class > FindItem Method : FindItem<T>(SQLQualifiedName) Method
Finds first (and loads all if not loaded) metadata item matching the specified SQL Qualified Name in the child items hierarchy.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItem(Of T As MetadataItem)( _
   ByVal name As SQLQualifiedName _
) As T
'Usage

Dim instance As MetadataItem
Dim name As SQLQualifiedName
Dim value As T

value = instance.FindItem(Of T)(name)
public T FindItem<T>(
   SQLQualifiedName name
)
where T: MetadataItem
public: T* FindItem<T>(
   SQLQualifiedName* name
)
where T: MetadataItem

Parameters

name

Type Parameters

T
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members
Overload List


FindItem<T>(String,MetadataType) Method

FindItem<T>(String,MetadataType) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class > FindItem Method : FindItem<T>(String,MetadataType) Method
Finds first (and loads all if not loaded) metadata item matching the specified string of specific types in the child items hierarchy.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItem(Of T As MetadataItem)( _
   ByVal name As System.String, _
   ByVal types As MetadataType _
) As T
'Usage

Dim instance As MetadataItem
Dim name As System.String
Dim types As MetadataType
Dim value As T

value = instance.FindItem(Of T)(name, types)
public T FindItem<T>(
   System.string name,
   MetadataType types
)
where T: MetadataItem
public: T* FindItem<T>(
   System.string* name,
   MetadataType types
)
where T: MetadataItem

Parameters

name
types

Type Parameters

T
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members
Overload List


FindItem<T>(String) Method

FindItem<T>(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class > FindItem Method : FindItem<T>(String) Method
Finds first (and loads all if not loaded) metadata item matching the specified string in the child items hierarchy.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItem(Of T As MetadataItem)( _
   ByVal name As System.String _
) As T
'Usage

Dim instance As MetadataItem
Dim name As System.String
Dim value As T

value = instance.FindItem(Of T)(name)
public T FindItem<T>(
   System.string name
)
where T: MetadataItem
public: T* FindItem<T>(
   System.string* name
)
where T: MetadataItem

Parameters

name

Type Parameters

T
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members
Overload List


FindItems Method (MetadataItem)

FindItems Method (MetadataItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : FindItems Method
Finds (and loads if not loaded) metadata items according to the specified Metadata Filter of specific types in the child items hierarchy.
Overload List
Overload | Description
FindItems<T>(MetadataFilter,MetadataType) | Finds (and loads if not loaded) metadata items according to the specified Metadata Filter of specific types in the child items hierarchy.
FindItems<T>(MetadataType) | Finds (and loads if not loaded) metadata items of specific types in the child items hierarchy.
FindItems<T>(MetadataQualifiedName,MetadataType) | Finds (and loads if not loaded) metadata items matching the specified Metadata Qualified Name of specific types in the child items hierarchy.
FindItems<T>(MetadataQualifiedName) | Finds (and loads if not loaded) metadata items matching the specified Metadata Qualified Name in the child items hierarchy.
FindItems<T>(SQLQualifiedName,MetadataType) | Finds (and loads if not loaded) metadata items matching the specified SQL Qualified Name of specific types in the child items hierarchy.
FindItems<T>(SQLQualifiedName) | Finds (and loads if not loaded) metadata items matching the specified SQL Qualified Name in the child items hierarchy.
FindItems<T>(String,MetadataType) | Finds (and loads if not loaded) metadata items matching the specified string of specific types in the child items hierarchy.
FindItems<T>(String) | Finds (and loads if not loaded) metadata items matching the specified string in the child items hierarchy.
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


FindItems<T>(MetadataFilter,MetadataType) Method

FindItems<T>(MetadataFilter,MetadataType) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class > FindItems Method : FindItems<T>(MetadataFilter,MetadataType) Method
Finds (and loads if not loaded) metadata items according to the specified Metadata Filter of specific types in the child items hierarchy.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItems(Of T As MetadataItem)( _
   ByVal filter As MetadataFilter, _
   ByVal types As MetadataType _
) As System.Collections.Generic.IList(Of T)
'Usage

Dim instance As MetadataItem
Dim filter As MetadataFilter
Dim types As MetadataType
Dim value As System.Collections.Generic.IList(Of T)

value = instance.FindItems(Of T)(filter, types)
public System.Collections.Generic.IList<T> FindItems<T>(
   MetadataFilter filter,
   MetadataType types
)
where T: MetadataItem
public: System.Collections.Generic.IList<T*>* FindItems<T>(
   MetadataFilter* filter,
   MetadataType types
)
where T: MetadataItem

Parameters

filter
types

Type Parameters

T
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members
Overload List


FindItems<T>(MetadataType) Method

FindItems<T>(MetadataType) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class > FindItems Method : FindItems<T>(MetadataType) Method
Finds (and loads if not loaded) metadata items of specific types in the child items hierarchy.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItems(Of T As MetadataItem)( _
   ByVal types As MetadataType _
) As System.Collections.Generic.IList(Of T)
'Usage

Dim instance As MetadataItem
Dim types As MetadataType
Dim value As System.Collections.Generic.IList(Of T)

value = instance.FindItems(Of T)(types)
public System.Collections.Generic.IList<T> FindItems<T>(
   MetadataType types
)
where T: MetadataItem
public: System.Collections.Generic.IList<T*>* FindItems<T>(
   MetadataType types
)
where T: MetadataItem

Parameters

types

Type Parameters

T
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members
Overload List


FindItems<T>(MetadataQualifiedName,MetadataType) Method

FindItems<T>(MetadataQualifiedName,MetadataType) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class > FindItems Method : FindItems<T>(MetadataQualifiedName,MetadataType) Method
Finds (and loads if not loaded) metadata items matching the specified Metadata Qualified Name of specific types in the child items hierarchy.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItems(Of T As MetadataItem)( _
   ByVal name As MetadataQualifiedName, _
   ByVal types As MetadataType _
) As System.Collections.Generic.IList(Of T)
'Usage

Dim instance As MetadataItem
Dim name As MetadataQualifiedName
Dim types As MetadataType
Dim value As System.Collections.Generic.IList(Of T)

value = instance.FindItems(Of T)(name, types)
public System.Collections.Generic.IList<T> FindItems<T>(
   MetadataQualifiedName name,
   MetadataType types
)
where T: MetadataItem
public: System.Collections.Generic.IList<T*>* FindItems<T>(
   MetadataQualifiedName* name,
   MetadataType types
)
where T: MetadataItem

Parameters

name
types

Type Parameters

T
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members
Overload List


FindItems<T>(MetadataQualifiedName) Method

FindItems<T>(MetadataQualifiedName) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class > FindItems Method : FindItems<T>(MetadataQualifiedName) Method
Finds (and loads if not loaded) metadata items matching the specified Metadata Qualified Name in the child items hierarchy.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItems(Of T As MetadataItem)( _
   ByVal name As MetadataQualifiedName _
) As System.Collections.Generic.IList(Of T)
'Usage

Dim instance As MetadataItem
Dim name As MetadataQualifiedName
Dim value As System.Collections.Generic.IList(Of T)

value = instance.FindItems(Of T)(name)
public System.Collections.Generic.IList<T> FindItems<T>(
   MetadataQualifiedName name
)
where T: MetadataItem
public: System.Collections.Generic.IList<T*>* FindItems<T>(
   MetadataQualifiedName* name
)
where T: MetadataItem

Parameters

name

Type Parameters

T
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members
Overload List


FindItems<T>(SQLQualifiedName,MetadataType) Method

FindItems<T>(SQLQualifiedName,MetadataType) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class > FindItems Method : FindItems<T>(SQLQualifiedName,MetadataType) Method
Finds (and loads if not loaded) metadata items matching the specified SQL Qualified Name of specific types in the child items hierarchy.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItems(Of T As MetadataItem)( _
   ByVal name As SQLQualifiedName, _
   ByVal types As MetadataType _
) As System.Collections.Generic.IList(Of T)
'Usage

Dim instance As MetadataItem
Dim name As SQLQualifiedName
Dim types As MetadataType
Dim value As System.Collections.Generic.IList(Of T)

value = instance.FindItems(Of T)(name, types)
public System.Collections.Generic.IList<T> FindItems<T>(
   SQLQualifiedName name,
   MetadataType types
)
where T: MetadataItem
public: System.Collections.Generic.IList<T*>* FindItems<T>(
   SQLQualifiedName* name,
   MetadataType types
)
where T: MetadataItem

Parameters

name
types

Type Parameters

T
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members
Overload List


FindItems<T>(SQLQualifiedName) Method

FindItems<T>(SQLQualifiedName) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class > FindItems Method : FindItems<T>(SQLQualifiedName) Method
Finds (and loads if not loaded) metadata items matching the specified SQL Qualified Name in the child items hierarchy.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItems(Of T As MetadataItem)( _
   ByVal name As SQLQualifiedName _
) As System.Collections.Generic.IList(Of T)
'Usage

Dim instance As MetadataItem
Dim name As SQLQualifiedName
Dim value As System.Collections.Generic.IList(Of T)

value = instance.FindItems(Of T)(name)
public System.Collections.Generic.IList<T> FindItems<T>(
   SQLQualifiedName name
)
where T: MetadataItem
public: System.Collections.Generic.IList<T*>* FindItems<T>(
   SQLQualifiedName* name
)
where T: MetadataItem

Parameters

name

Type Parameters

T
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members
Overload List


FindItems<T>(String,MetadataType) Method

FindItems<T>(String,MetadataType) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class > FindItems Method : FindItems<T>(String,MetadataType) Method
Finds (and loads if not loaded) metadata items matching the specified string of specific types in the child items hierarchy.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItems(Of T As MetadataItem)( _
   ByVal name As System.String, _
   ByVal types As MetadataType _
) As System.Collections.Generic.IList(Of T)
'Usage

Dim instance As MetadataItem
Dim name As System.String
Dim types As MetadataType
Dim value As System.Collections.Generic.IList(Of T)

value = instance.FindItems(Of T)(name, types)
public System.Collections.Generic.IList<T> FindItems<T>(
   System.string name,
   MetadataType types
)
where T: MetadataItem
public: System.Collections.Generic.IList<T*>* FindItems<T>(
   System.string* name,
   MetadataType types
)
where T: MetadataItem

Parameters

name
types

Type Parameters

T
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members
Overload List


FindItems<T>(String) Method

FindItems<T>(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class > FindItems Method : FindItems<T>(String) Method
Finds (and loads if not loaded) metadata items matching the specified string in the child items hierarchy.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItems(Of T As MetadataItem)( _
   ByVal name As System.String _
) As System.Collections.Generic.IList(Of T)
'Usage

Dim instance As MetadataItem
Dim name As System.String
Dim value As System.Collections.Generic.IList(Of T)

value = instance.FindItems(Of T)(name)
public System.Collections.Generic.IList<T> FindItems<T>(
   System.string name
)
where T: MetadataItem
public: System.Collections.Generic.IList<T*>* FindItems<T>(
   System.string* name
)
where T: MetadataItem

Parameters

name

Type Parameters

T
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members
Overload List


LoadAll Method

LoadAll Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : LoadAll Method
Instructs to load fields for database objects (true) or not (false).
Recursively loads metadata for all items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub LoadAll( _
   ByVal withFields As System.Boolean _
)
'Usage

Dim instance As MetadataItem
Dim withFields As System.Boolean

instance.LoadAll(withFields)
public void LoadAll(
   System.bool withFields
)
public: void LoadAll(
   System.bool withFields
)

Parameters

withFields
Instructs to load fields for database objects (true) or not (false).
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


MetadataItem Class Properties

MetadataItem Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataItem Class

For a list of all members of this type, see MetadataItem members.

Public Properties
 | Name | Description
Public Property | AltName | Alternate name of the metadata item.
Public Property | Database | Refers to the parent node of Database type.
Public Property | Default | Indicates if the namespace metadata item is default one.
Public Property | Description | Description of the metadata item.
Public Property | Items | Lists the child nodes of this one.
Public Property | MetadataContainer | Refers to the Metadata Container object to which this item belongs to.
Public Property | Name | Unquoted name of the metadata item.
Public Property | NameFull | Returns fully qualified name of the metadata item in form [database].[schema].[name].
Public Property | NameQuoted | Name of the metadata item, quoted if required.
Public Property | Object | Refers to the parent node of database object type.
Public Property | Package | Refers to the parent node of Package type.
Public Property | Parent | Points to the parent node of the tree.
Public Property | ParentItems | Points to the list of child metadata items of the parent node.
Public Property | Schema | Refers to the parent node of Schema type.
Public Property | Server | Refers to the parent node of Server type.
Public Property | SQLContext | Refers to the context for SQL generation, SQL parsing and metadata loading purposes.
Public Property | System | Indicates if the metadata item is system or user object.
Public Property | Type | Determines the type of Metadata Item (root, namespace, database object, field, etc.).
Top
See Also

Reference

MetadataItem Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AltName Property

AltName Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : AltName Property
Alternate name of the metadata item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AltName As System.String
'Usage

Dim instance As MetadataItem
Dim value As System.String

instance.AltName = value

value = instance.AltName
public System.string AltName {get; set;}
public: __property System.string* get_AltName();
public: __property void set_AltName(
   System.string* value
);
Remarks
This name will subsitute the real name when usage of the alternate names is activated.
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members
UseAltNames Property


Database Property (MetadataItem)

Database Property (MetadataItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : Database Property
Refers to the parent node of Database type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Database As MetadataNamespace
'Usage

Dim instance As MetadataItem
Dim value As MetadataNamespace

value = instance.Database
public MetadataNamespace Database {get;}
public: __property MetadataNamespace* get_Database();

Property Value

Returns the first found metadata item of the Database type from the parent items hierarchy.
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


Default Property

Default Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : Default Property
Indicates if the namespace metadata item is default one.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Default As System.Boolean
'Usage

Dim instance As MetadataItem
Dim value As System.Boolean

instance.Default = value

value = instance.Default
public System.bool Default {get; set;}
public: __property System.bool get_Default();
public: __property void set_Default(
   System.bool value
);
Remarks
if this item can be omitted in the
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


Description Property (MetadataItem)

Description Property (MetadataItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : Description Property
Description of the metadata item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Description As System.String
'Usage

Dim instance As MetadataItem
Dim value As System.String

instance.Description = value

value = instance.Description
public System.string Description {get; set;}
public: __property System.string* get_Description();
public: __property void set_Description(
   System.string* value
);
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


Items Property (MetadataItem)

Items Property (MetadataItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : Items Property
Lists the child nodes of this one.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Items As MetadataList
'Usage

Dim instance As MetadataItem
Dim value As MetadataList

instance.Items = value

value = instance.Items
public MetadataList Items {get; set;}
public: __property MetadataList* get_Items();
public: __property void set_Items(
   MetadataList* value
);

Property Value

List of the child Metadata Item objects.
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


MetadataContainer Property (MetadataItem)

MetadataContainer Property (MetadataItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : MetadataContainer Property
Refers to the Metadata Container object to which this item belongs to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property MetadataContainer As MetadataContainer
'Usage

Dim instance As MetadataItem
Dim value As MetadataContainer

value = instance.MetadataContainer
public MetadataContainer MetadataContainer {get;}
public: __property MetadataContainer* get_MetadataContainer();
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


Name Property (MetadataItem)

Name Property (MetadataItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : Name Property
Unquoted name of the metadata item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Name As System.String
'Usage

Dim instance As MetadataItem
Dim value As System.String

instance.Name = value

value = instance.Name
public System.string Name {get; set;}
public: __property System.string* get_Name();
public: __property void set_Name(
   System.string* value
);
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


NameFull Property

NameFull Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : NameFull Property
Returns fully qualified name of the metadata item in form [database].[schema].[name].
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property NameFull As System.String
'Usage

Dim instance As MetadataItem
Dim value As System.String

value = instance.NameFull
public System.string NameFull {get;}
public: __property System.string* get_NameFull();
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


NameQuoted Property

NameQuoted Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : NameQuoted Property
Name of the metadata item, quoted if required.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property NameQuoted As System.String
'Usage

Dim instance As MetadataItem
Dim value As System.String

value = instance.NameQuoted
public System.string NameQuoted {get;}
public: __property System.string* get_NameQuoted();
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


Object Property (MetadataItem)

Object Property (MetadataItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : Object Property
Refers to the parent node of database object type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Object As MetadataObject
'Usage

Dim instance As MetadataItem
Dim value As MetadataObject

value = instance.Object
public MetadataObject Object {get;}
public: __property MetadataObject* get_Object();

Property Value

Returns the first found metadata item of the database bject type from the parent items hierarchy.
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


Package Property (MetadataItem)

Package Property (MetadataItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : Package Property
Refers to the parent node of Package type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Package As MetadataNamespace
'Usage

Dim instance As MetadataItem
Dim value As MetadataNamespace

value = instance.Package
public MetadataNamespace Package {get;}
public: __property MetadataNamespace* get_Package();

Property Value

Returns the first found metadata item of the Package type from the parent items hierarchy.
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


Parent Property (MetadataItem)

Parent Property (MetadataItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : Parent Property
Points to the parent node of the tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Parent As MetadataItem
'Usage

Dim instance As MetadataItem
Dim value As MetadataItem

value = instance.Parent
public MetadataItem Parent {get;}
public: __property MetadataItem* get_Parent();

Property Value

Reference to the parent Metadata Item object. Null for the root node.
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


ParentItems Property

ParentItems Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : ParentItems Property
Points to the list of child metadata items of the parent node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ParentItems As MetadataList
'Usage

Dim instance As MetadataItem
Dim value As MetadataList

value = instance.ParentItems
public MetadataList ParentItems {get;}
public: __property MetadataList* get_ParentItems();
Remarks
This list contains the reference to itself.
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


Schema Property (MetadataItem)

Schema Property (MetadataItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : Schema Property
Refers to the parent node of Schema type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Schema As MetadataNamespace
'Usage

Dim instance As MetadataItem
Dim value As MetadataNamespace

value = instance.Schema
public MetadataNamespace Schema {get;}
public: __property MetadataNamespace* get_Schema();

Property Value

Returns the first found metadata item of the Schema type from the parent items hierarchy.
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


Server Property (MetadataItem)

Server Property (MetadataItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : Server Property
Refers to the parent node of Server type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Server As MetadataNamespace
'Usage

Dim instance As MetadataItem
Dim value As MetadataNamespace

value = instance.Server
public MetadataNamespace Server {get;}
public: __property MetadataNamespace* get_Server();

Property Value

Returns the first found metadata item of the Server type from the parent items hierarchy.
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


SQLContext Property (MetadataItem)

SQLContext Property (MetadataItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : SQLContext Property
Refers to the context for SQL generation, SQL parsing and metadata loading purposes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property SQLContext As BaseSQLContext
'Usage

Dim instance As MetadataItem
Dim value As BaseSQLContext

value = instance.SQLContext
public BaseSQLContext SQLContext {get;}
public: __property BaseSQLContext* get_SQLContext();
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


System Property

System Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : System Property
Indicates if the metadata item is system or user object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property System As System.Boolean
'Usage

Dim instance As MetadataItem
Dim value As System.Boolean

instance.System = value

value = instance.System
public System.bool System {get; set;}
public: __property System.bool get_System();
public: __property void set_System(
   System.bool value
);
Remarks
System objects are usually hidden from the database schema tree.
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


Type Property

Type Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : Type Property
Determines the type of Metadata Item (root, namespace, database object, field, etc.).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Type As MetadataType
'Usage

Dim instance As MetadataItem
Dim value As MetadataType

value = instance.Type
public MetadataType Type {get;}
public: __property MetadataType get_Type();
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


MetadataItem Class Events

MetadataItem Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataItem Class

For a list of all members of this type, see MetadataItem members.

Public Events
 | Name | Description
Public Event | AltNameChanged | Fires on changing the alternate name of metadata item.
Public Event | DefaultChanged | Fires on changing the Default attribute of metadata item.
Public Event | FilteringPropsChanged | Fires on changing the attributes of metadata item that affect the filtering.
Public Event | MetadataChildItemAdded | Fires on adding a child metadata item to the hierarchy of child items.
Public Event | MetadataChildItemRemoving | Fires on removing a metadata item from the hierarchy of child items.
Public Event | NameChanged | Fires on changing the name of metadata item.
Public Event | SystemChanged | Fires on changing the System attribute of metadata item.
Top
See Also

Reference

MetadataItem Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AltNameChanged Event

AltNameChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : AltNameChanged Event
Fires on changing the alternate name of metadata item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AltNameChanged As StringEventHandler
'Usage

Dim instance As MetadataItem
Dim handler As StringEventHandler

AddHandler instance.AltNameChanged, handler
public event StringEventHandler AltNameChanged
public: __event StringEventHandler* AltNameChanged
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members
AltName Property


DefaultChanged Event

DefaultChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : DefaultChanged Event
Fires on changing the Default attribute of metadata item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DefaultChanged As NotifyEventHandler
'Usage

Dim instance As MetadataItem
Dim handler As NotifyEventHandler

AddHandler instance.DefaultChanged, handler
public event NotifyEventHandler DefaultChanged
public: __event NotifyEventHandler* DefaultChanged
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members
Default Property


FilteringPropsChanged Event

FilteringPropsChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : FilteringPropsChanged Event
Fires on changing the attributes of metadata item that affect the filtering.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event FilteringPropsChanged As NotifyEventHandler
'Usage

Dim instance As MetadataItem
Dim handler As NotifyEventHandler

AddHandler instance.FilteringPropsChanged, handler
public event NotifyEventHandler FilteringPropsChanged
public: __event NotifyEventHandler* FilteringPropsChanged
Remarks
The event is fired on changing the AltName, Name, Default and System properties.
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


MetadataChildItemAdded Event

MetadataChildItemAdded Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : MetadataChildItemAdded Event
Fires on adding a child metadata item to the hierarchy of child items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event MetadataChildItemAdded As MetadataItemEventHandler
'Usage

Dim instance As MetadataItem
Dim handler As MetadataItemEventHandler

AddHandler instance.MetadataChildItemAdded, handler
public event MetadataItemEventHandler MetadataChildItemAdded
public: __event MetadataItemEventHandler* MetadataChildItemAdded
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


MetadataChildItemRemoving Event

MetadataChildItemRemoving Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : MetadataChildItemRemoving Event
Fires on removing a metadata item from the hierarchy of child items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event MetadataChildItemRemoving As MetadataItemEventHandler
'Usage

Dim instance As MetadataItem
Dim handler As MetadataItemEventHandler

AddHandler instance.MetadataChildItemRemoving, handler
public event MetadataItemEventHandler MetadataChildItemRemoving
public: __event MetadataItemEventHandler* MetadataChildItemRemoving
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members


NameChanged Event

NameChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : NameChanged Event
Fires on changing the name of metadata item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event NameChanged As StringEventHandler
'Usage

Dim instance As MetadataItem
Dim handler As StringEventHandler

AddHandler instance.NameChanged, handler
public event StringEventHandler NameChanged
public: __event StringEventHandler* NameChanged
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members
Name Property


SystemChanged Event

SystemChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataItem Class : SystemChanged Event
Fires on changing the System attribute of metadata item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event SystemChanged As NotifyEventHandler
'Usage

Dim instance As MetadataItem
Dim handler As NotifyEventHandler

AddHandler instance.SystemChanged, handler
public event NotifyEventHandler SystemChanged
public: __event NotifyEventHandler* SystemChanged
Requirements

See Also

Reference

MetadataItem Class
MetadataItem Members
SystemChanged Event


MetadataList Class

MetadataList Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataList Class
List of metadata items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MetadataList
   Inherits ActiveDatabaseSoftware.ActiveQueryBuilder.UpdatableObjectList(Of MetadataItem)
'Usage

Dim instance As MetadataList
public class MetadataList : ActiveDatabaseSoftware.ActiveQueryBuilder.UpdatableObjectList<MetadataItem>
public __gc class MetadataList : public ActiveDatabaseSoftware.ActiveQueryBuilder.UpdatableObjectList<MetadataItem>
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataList

Requirements

See Also

Reference

MetadataList Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataList Class Members

MetadataList Class Members
Properties Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataList Class

The following tables list the members exposed by MetadataList.

Public Properties
 | Name | Description
Public Property | Databases | Lists metadata items of the Database type.
Public Property | Fields | Lists metadata items of the Field type.
Public Property | ForeignKeys | Lists metadata items of the Foreign Key type.
Public Property | Namespaces | Lists metadata items of the all namespace types (Server, Package, Database, Schema).
Public Property | Objects | Lists metadata items of the all database object types (Table, View, Procedure, Synonym).
Public Property | Packages | Lists metadata items of the Package type.
Public Property | Parameters | Lists metadata items of the Parameter type.
Public Property | Parent | Refers to the parent metadata item.
Public Property | Procedures | Lists metadata items of the Procedure type.
Public Property | Schemas | Lists metadata items of the Schema type.
Public Property | Servers | Lists metadata items of the Server type.
Public Property | SQLContext | Refers to the context for SQL generation, SQL parsing and metadata loading purposes.
Public Property | Synonyms | Lists metadata items of the Synonym type.
Public Property | Tables | Lists metadata items of the Table type.
Public Property | Views | Lists metadata items of the View type.
Top
Public Methods
 | Name | Description
Public Method | FindForeignKey | Returns the first found metadata item of the Foreign Key type with the given fields, parent object and parent object fields.
Public Method | FindForeignKeys | Returns the list of metadata items of the Foreign Key type with the given fields, parent object and parent object fields.
Public Method | FindIndex | Overloaded. Returns the index of first found metadata item that matches the string name.
Public Method | FindIndices | Overloaded. Returns the list of indexes of metadata items that match the string name.
Public Method | FindItem | Overloaded. Returns the first found metadata item that matches the string name.
Public Method | FindItems | Overloaded. Returns the list of metadata items that match the string name.
Public Method | GetDefaultItems<T> | Returns the list of default metadata items.
Public Method | GetItems<T> | Returns the list of all metadata items.
Public Method | GetItemsRecursive<T> | Returns the list of all metadata items and items of child lists recursively.
Public Method | IsLoaded | Indicates if the specified types of metadata items have been loaded to the list.
Public Method | Load | Overloaded. Loads specified types of metadata items to the list.
Top
See Also

Reference

MetadataList Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataList Class Methods

MetadataList Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataList Class

For a list of all members of this type, see MetadataList members.

Public Methods
 | Name | Description
Public Method | FindForeignKey | Returns the first found metadata item of the Foreign Key type with the given fields, parent object and parent object fields.
Public Method | FindForeignKeys | Returns the list of metadata items of the Foreign Key type with the given fields, parent object and parent object fields.
Public Method | FindIndex | Overloaded. Returns the index of first found metadata item that matches the string name.
Public Method | FindIndices | Overloaded. Returns the list of indexes of metadata items that match the string name.
Public Method | FindItem | Overloaded. Returns the first found metadata item that matches the string name.
Public Method | FindItems | Overloaded. Returns the list of metadata items that match the string name.
Public Method | GetDefaultItems<T> | Returns the list of default metadata items.
Public Method | GetItems<T> | Returns the list of all metadata items.
Public Method | GetItemsRecursive<T> | Returns the list of all metadata items and items of child lists recursively.
Public Method | IsLoaded | Indicates if the specified types of metadata items have been loaded to the list.
Public Method | Load | Overloaded. Loads specified types of metadata items to the list.
Top
See Also

Reference

MetadataList Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


FindForeignKey Method

FindForeignKey Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : FindForeignKey Method
Returns the first found metadata item of the Foreign Key type with the given fields, parent object and parent object fields.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function FindForeignKey( _
   ByVal childFields As MetadataNameList, _
   ByVal parentObjectName As MetadataQualifiedName, _
   ByVal parentFields As MetadataNameList _
) As MetadataForeignKey
'Usage

Dim instance As MetadataList
Dim childFields As MetadataNameList
Dim parentObjectName As MetadataQualifiedName
Dim parentFields As MetadataNameList
Dim value As MetadataForeignKey

value = instance.FindForeignKey(childFields, parentObjectName, parentFields)
public MetadataForeignKey FindForeignKey(
   MetadataNameList childFields,
   MetadataQualifiedName parentObjectName,
   MetadataNameList parentFields
)
public: MetadataForeignKey* FindForeignKey(
   MetadataNameList* childFields,
   MetadataQualifiedName* parentObjectName,
   MetadataNameList* parentFields
)

Parameters

childFields
parentObjectName
parentFields
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


FindForeignKeys Method

FindForeignKeys Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : FindForeignKeys Method
Returns the list of metadata items of the Foreign Key type with the given fields, parent object and parent object fields.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function FindForeignKeys( _
   ByVal childFields As MetadataNameList, _
   ByVal parentObjectName As MetadataQualifiedName, _
   ByVal parentFields As MetadataNameList _
) As System.Collections.Generic.IList(Of MetadataForeignKey)
'Usage

Dim instance As MetadataList
Dim childFields As MetadataNameList
Dim parentObjectName As MetadataQualifiedName
Dim parentFields As MetadataNameList
Dim value As System.Collections.Generic.IList(Of MetadataForeignKey)

value = instance.FindForeignKeys(childFields, parentObjectName, parentFields)
public System.Collections.Generic.IList<MetadataForeignKey> FindForeignKeys(
   MetadataNameList childFields,
   MetadataQualifiedName parentObjectName,
   MetadataNameList parentFields
)
public: System.Collections.Generic.IList<MetadataForeignKey*>* FindForeignKeys(
   MetadataNameList* childFields,
   MetadataQualifiedName* parentObjectName,
   MetadataNameList* parentFields
)

Parameters

childFields
parentObjectName
parentFields
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


FindIndex Method (MetadataList)

FindIndex Method (MetadataList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : FindIndex Method
Returns the index of first found metadata item that matches the string name.
Overload List
Overload | Description
FindIndex<T>(String) | Returns the index of first found metadata item that matches the string name.
FindIndex<T>(String,MetadataType) | Returns the index of first found metadata item of the specified types that matches the string name.
FindIndex<T>(AstToken) | Returns the index of first found metadata item that matches the name defined by AST token identifier.
FindIndex<T>(AstToken,MetadataType) | Returns the index of first found metadata item of the specified type that matches the name defined by AST token identifier.
FindIndex<T>(MetadataQualifiedNamePart) | Returns the index of first found metadata item that matches the name defined by MetadataQualifiedNamePart.
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


FindIndex<T>(String) Method

FindIndex<T>(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > FindIndex Method : FindIndex<T>(String) Method
Returns the index of first found metadata item that matches the string name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindIndex(Of T As MetadataItem)( _
   ByVal name As System.String _
) As System.Integer
'Usage

Dim instance As MetadataList
Dim name As System.String
Dim value As System.Integer

value = instance.FindIndex(Of T)(name)
public System.int FindIndex<T>(
   System.string name
)
where T: MetadataItem
public: System.int FindIndex<T>(
   System.string* name
)
where T: MetadataItem

Parameters

name

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


FindIndex<T>(String,MetadataType) Method

FindIndex<T>(String,MetadataType) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > FindIndex Method : FindIndex<T>(String,MetadataType) Method
Returns the index of first found metadata item of the specified types that matches the string name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindIndex(Of T As MetadataItem)( _
   ByVal name As System.String, _
   ByVal types As MetadataType _
) As System.Integer
'Usage

Dim instance As MetadataList
Dim name As System.String
Dim types As MetadataType
Dim value As System.Integer

value = instance.FindIndex(Of T)(name, types)
public System.int FindIndex<T>(
   System.string name,
   MetadataType types
)
where T: MetadataItem
public: System.int FindIndex<T>(
   System.string* name,
   MetadataType types
)
where T: MetadataItem

Parameters

name
types

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


FindIndex<T>(AstToken) Method

FindIndex<T>(AstToken) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > FindIndex Method : FindIndex<T>(AstToken) Method
Returns the index of first found metadata item that matches the name defined by AST token identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindIndex(Of T As MetadataItem)( _
   ByVal name As AstToken _
) As System.Integer
'Usage

Dim instance As MetadataList
Dim name As AstToken
Dim value As System.Integer

value = instance.FindIndex(Of T)(name)
public System.int FindIndex<T>(
   AstToken name
)
where T: MetadataItem
public: System.int FindIndex<T>(
   AstToken* name
)
where T: MetadataItem

Parameters

name

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


FindIndex<T>(AstToken,MetadataType) Method

FindIndex<T>(AstToken,MetadataType) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > FindIndex Method : FindIndex<T>(AstToken,MetadataType) Method
Returns the index of first found metadata item of the specified type that matches the name defined by AST token identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindIndex(Of T As MetadataItem)( _
   ByVal name As AstToken, _
   ByVal types As MetadataType _
) As System.Integer
'Usage

Dim instance As MetadataList
Dim name As AstToken
Dim types As MetadataType
Dim value As System.Integer

value = instance.FindIndex(Of T)(name, types)
public System.int FindIndex<T>(
   AstToken name,
   MetadataType types
)
where T: MetadataItem
public: System.int FindIndex<T>(
   AstToken* name,
   MetadataType types
)
where T: MetadataItem

Parameters

name
types

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


FindIndex<T>(MetadataQualifiedNamePart) Method

FindIndex<T>(MetadataQualifiedNamePart) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > FindIndex Method : FindIndex<T>(MetadataQualifiedNamePart) Method
Returns the index of first found metadata item that matches the name defined by MetadataQualifiedNamePart.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindIndex(Of T As MetadataItem)( _
   ByVal namePart As MetadataQualifiedNamePart _
) As System.Integer
'Usage

Dim instance As MetadataList
Dim namePart As MetadataQualifiedNamePart
Dim value As System.Integer

value = instance.FindIndex(Of T)(namePart)
public System.int FindIndex<T>(
   MetadataQualifiedNamePart namePart
)
where T: MetadataItem
public: System.int FindIndex<T>(
   MetadataQualifiedNamePart* namePart
)
where T: MetadataItem

Parameters

namePart

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


FindIndices Method (MetadataList)

FindIndices Method (MetadataList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : FindIndices Method
Returns the list of indexes of metadata items that match the string name.
Overload List
Overload | Description
FindIndices<T>(String) | Returns the list of indexes of metadata items that match the string name.
FindIndices<T>(String,MetadataType) | Returns the list of indexes of metadata items of the specified types that match the string name.
FindIndices<T>(AstToken) | Returns the list of indexes of metadata items that match the name defined by AST token identifier.
FindIndices<T>(AstToken,MetadataType) | Returns the list of indexes of metadata items of the specified types that match the name defined by AST token identifier.
FindIndices<T>(MetadataQualifiedNamePart) | Returns the list of indexes of metadata items that match the name defined by MetadataQualifiedNamePart.
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


FindIndices<T>(String) Method

FindIndices<T>(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > FindIndices Method : FindIndices<T>(String) Method
Returns the list of indexes of metadata items that match the string name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindIndices(Of T As MetadataItem)( _
   ByVal name As System.String _
) As System.Collections.Generic.IList(Of Integer)
'Usage

Dim instance As MetadataList
Dim name As System.String
Dim value As System.Collections.Generic.IList(Of Integer)

value = instance.FindIndices(Of T)(name)
public System.Collections.Generic.IList<int> FindIndices<T>(
   System.string name
)
where T: MetadataItem
public: System.Collections.Generic.IList<int>* FindIndices<T>(
   System.string* name
)
where T: MetadataItem

Parameters

name

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


FindIndices<T>(String,MetadataType) Method

FindIndices<T>(String,MetadataType) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > FindIndices Method : FindIndices<T>(String,MetadataType) Method
Returns the list of indexes of metadata items of the specified types that match the string name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindIndices(Of T As MetadataItem)( _
   ByVal name As System.String, _
   ByVal types As MetadataType _
) As System.Collections.Generic.IList(Of Integer)
'Usage

Dim instance As MetadataList
Dim name As System.String
Dim types As MetadataType
Dim value As System.Collections.Generic.IList(Of Integer)

value = instance.FindIndices(Of T)(name, types)
public System.Collections.Generic.IList<int> FindIndices<T>(
   System.string name,
   MetadataType types
)
where T: MetadataItem
public: System.Collections.Generic.IList<int>* FindIndices<T>(
   System.string* name,
   MetadataType types
)
where T: MetadataItem

Parameters

name
types

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


FindIndices<T>(AstToken) Method

FindIndices<T>(AstToken) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > FindIndices Method : FindIndices<T>(AstToken) Method
Returns the list of indexes of metadata items that match the name defined by AST token identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindIndices(Of T As MetadataItem)( _
   ByVal name As AstToken _
) As System.Collections.Generic.IList(Of Integer)
'Usage

Dim instance As MetadataList
Dim name As AstToken
Dim value As System.Collections.Generic.IList(Of Integer)

value = instance.FindIndices(Of T)(name)
public System.Collections.Generic.IList<int> FindIndices<T>(
   AstToken name
)
where T: MetadataItem
public: System.Collections.Generic.IList<int>* FindIndices<T>(
   AstToken* name
)
where T: MetadataItem

Parameters

name

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


FindIndices<T>(AstToken,MetadataType) Method

FindIndices<T>(AstToken,MetadataType) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > FindIndices Method : FindIndices<T>(AstToken,MetadataType) Method
Returns the list of indexes of metadata items of the specified types that match the name defined by AST token identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindIndices(Of T As MetadataItem)( _
   ByVal name As AstToken, _
   ByVal types As MetadataType _
) As System.Collections.Generic.IList(Of Integer)
'Usage

Dim instance As MetadataList
Dim name As AstToken
Dim types As MetadataType
Dim value As System.Collections.Generic.IList(Of Integer)

value = instance.FindIndices(Of T)(name, types)
public System.Collections.Generic.IList<int> FindIndices<T>(
   AstToken name,
   MetadataType types
)
where T: MetadataItem
public: System.Collections.Generic.IList<int>* FindIndices<T>(
   AstToken* name,
   MetadataType types
)
where T: MetadataItem

Parameters

name
types

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


FindIndices<T>(MetadataQualifiedNamePart) Method

FindIndices<T>(MetadataQualifiedNamePart) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > FindIndices Method : FindIndices<T>(MetadataQualifiedNamePart) Method
Returns the list of indexes of metadata items that match the name defined by MetadataQualifiedNamePart.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindIndices(Of T As MetadataItem)( _
   ByVal namePart As MetadataQualifiedNamePart _
) As System.Collections.Generic.IList(Of Integer)
'Usage

Dim instance As MetadataList
Dim namePart As MetadataQualifiedNamePart
Dim value As System.Collections.Generic.IList(Of Integer)

value = instance.FindIndices(Of T)(namePart)
public System.Collections.Generic.IList<int> FindIndices<T>(
   MetadataQualifiedNamePart namePart
)
where T: MetadataItem
public: System.Collections.Generic.IList<int>* FindIndices<T>(
   MetadataQualifiedNamePart* namePart
)
where T: MetadataItem

Parameters

namePart

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


FindItem Method (MetadataList)

FindItem Method (MetadataList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : FindItem Method
Returns the first found metadata item that matches the string name.
Overload List
Overload | Description
FindItem<T>(String) | Returns the first found metadata item that matches the string name.
FindItem<T>(String,MetadataType) | Returns the first found metadata item of the specified types that matches the string name.
FindItem<T>(AstToken) | Returns the first found metadata item that matches the name defined by AST token identifier.
FindItem<T>(AstToken,MetadataType) | Returns the first found metadata item of the specified type that matches the name defined by AST token identifier.
FindItem<T>(MetadataQualifiedNamePart) | Returns the first found metadata item that matches the name defined by MetadataQualifiedNamePart.
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


FindItem<T>(String) Method

FindItem<T>(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > FindItem Method : FindItem<T>(String) Method
Returns the first found metadata item that matches the string name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItem(Of T As MetadataItem)( _
   ByVal name As System.String _
) As T
'Usage

Dim instance As MetadataList
Dim name As System.String
Dim value As T

value = instance.FindItem(Of T)(name)
public T FindItem<T>(
   System.string name
)
where T: MetadataItem
public: T* FindItem<T>(
   System.string* name
)
where T: MetadataItem

Parameters

name

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


FindItem<T>(String,MetadataType) Method

FindItem<T>(String,MetadataType) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > FindItem Method : FindItem<T>(String,MetadataType) Method
Returns the first found metadata item of the specified types that matches the string name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItem(Of T As MetadataItem)( _
   ByVal name As System.String, _
   ByVal types As MetadataType _
) As T
'Usage

Dim instance As MetadataList
Dim name As System.String
Dim types As MetadataType
Dim value As T

value = instance.FindItem(Of T)(name, types)
public T FindItem<T>(
   System.string name,
   MetadataType types
)
where T: MetadataItem
public: T* FindItem<T>(
   System.string* name,
   MetadataType types
)
where T: MetadataItem

Parameters

name
types

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


FindItem<T>(AstToken) Method

FindItem<T>(AstToken) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > FindItem Method : FindItem<T>(AstToken) Method
Returns the first found metadata item that matches the name defined by AST token identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItem(Of T As MetadataItem)( _
   ByVal name As AstToken _
) As T
'Usage

Dim instance As MetadataList
Dim name As AstToken
Dim value As T

value = instance.FindItem(Of T)(name)
public T FindItem<T>(
   AstToken name
)
where T: MetadataItem
public: T* FindItem<T>(
   AstToken* name
)
where T: MetadataItem

Parameters

name

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


FindItem<T>(AstToken,MetadataType) Method

FindItem<T>(AstToken,MetadataType) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > FindItem Method : FindItem<T>(AstToken,MetadataType) Method
Returns the first found metadata item of the specified type that matches the name defined by AST token identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItem(Of T As MetadataItem)( _
   ByVal name As AstToken, _
   ByVal types As MetadataType _
) As T
'Usage

Dim instance As MetadataList
Dim name As AstToken
Dim types As MetadataType
Dim value As T

value = instance.FindItem(Of T)(name, types)
public T FindItem<T>(
   AstToken name,
   MetadataType types
)
where T: MetadataItem
public: T* FindItem<T>(
   AstToken* name,
   MetadataType types
)
where T: MetadataItem

Parameters

name
types

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


FindItem<T>(MetadataQualifiedNamePart) Method

FindItem<T>(MetadataQualifiedNamePart) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > FindItem Method : FindItem<T>(MetadataQualifiedNamePart) Method
Returns the first found metadata item that matches the name defined by MetadataQualifiedNamePart.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItem(Of T As MetadataItem)( _
   ByVal namePart As MetadataQualifiedNamePart _
) As T
'Usage

Dim instance As MetadataList
Dim namePart As MetadataQualifiedNamePart
Dim value As T

value = instance.FindItem(Of T)(namePart)
public T FindItem<T>(
   MetadataQualifiedNamePart namePart
)
where T: MetadataItem
public: T* FindItem<T>(
   MetadataQualifiedNamePart* namePart
)
where T: MetadataItem

Parameters

namePart

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


FindItems Method (MetadataList)

FindItems Method (MetadataList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : FindItems Method
Returns the list of metadata items that match the string name.
Overload List
Overload | Description
FindItems<T>(String) | Returns the list of metadata items that match the string name.
FindItems<T>(String,MetadataType) | Returns the list of metadata items of the specified types that match the string name.
FindItems<T>(AstToken) | Returns the list of metadata items that match the name defined by AST token identifier.
FindItems<T>(AstToken,MetadataType) | Returns the list of metadata items of the specified types that match the name defined by AST token identifier.
FindItems<T>(MetadataQualifiedNamePart) | Returns the list of metadata items that match the name defined by MetadataQualifiedNamePart.
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


FindItems<T>(String) Method

FindItems<T>(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > FindItems Method : FindItems<T>(String) Method
Returns the list of metadata items that match the string name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItems(Of T As MetadataItem)( _
   ByVal name As System.String _
) As System.Collections.Generic.IList(Of T)
'Usage

Dim instance As MetadataList
Dim name As System.String
Dim value As System.Collections.Generic.IList(Of T)

value = instance.FindItems(Of T)(name)
public System.Collections.Generic.IList<T> FindItems<T>(
   System.string name
)
where T: MetadataItem
public: System.Collections.Generic.IList<T*>* FindItems<T>(
   System.string* name
)
where T: MetadataItem

Parameters

name

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


FindItems<T>(String,MetadataType) Method

FindItems<T>(String,MetadataType) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > FindItems Method : FindItems<T>(String,MetadataType) Method
Returns the list of metadata items of the specified types that match the string name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItems(Of T As MetadataItem)( _
   ByVal name As System.String, _
   ByVal types As MetadataType _
) As System.Collections.Generic.IList(Of T)
'Usage

Dim instance As MetadataList
Dim name As System.String
Dim types As MetadataType
Dim value As System.Collections.Generic.IList(Of T)

value = instance.FindItems(Of T)(name, types)
public System.Collections.Generic.IList<T> FindItems<T>(
   System.string name,
   MetadataType types
)
where T: MetadataItem
public: System.Collections.Generic.IList<T*>* FindItems<T>(
   System.string* name,
   MetadataType types
)
where T: MetadataItem

Parameters

name
types

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


FindItems<T>(AstToken) Method

FindItems<T>(AstToken) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > FindItems Method : FindItems<T>(AstToken) Method
Returns the list of metadata items that match the name defined by AST token identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItems(Of T As MetadataItem)( _
   ByVal name As AstToken _
) As System.Collections.Generic.IList(Of T)
'Usage

Dim instance As MetadataList
Dim name As AstToken
Dim value As System.Collections.Generic.IList(Of T)

value = instance.FindItems(Of T)(name)
public System.Collections.Generic.IList<T> FindItems<T>(
   AstToken name
)
where T: MetadataItem
public: System.Collections.Generic.IList<T*>* FindItems<T>(
   AstToken* name
)
where T: MetadataItem

Parameters

name

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


FindItems<T>(AstToken,MetadataType) Method

FindItems<T>(AstToken,MetadataType) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > FindItems Method : FindItems<T>(AstToken,MetadataType) Method
Returns the list of metadata items of the specified types that match the name defined by AST token identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItems(Of T As MetadataItem)( _
   ByVal name As AstToken, _
   ByVal types As MetadataType _
) As System.Collections.Generic.IList(Of T)
'Usage

Dim instance As MetadataList
Dim name As AstToken
Dim types As MetadataType
Dim value As System.Collections.Generic.IList(Of T)

value = instance.FindItems(Of T)(name, types)
public System.Collections.Generic.IList<T> FindItems<T>(
   AstToken name,
   MetadataType types
)
where T: MetadataItem
public: System.Collections.Generic.IList<T*>* FindItems<T>(
   AstToken* name,
   MetadataType types
)
where T: MetadataItem

Parameters

name
types

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


FindItems<T>(MetadataQualifiedNamePart) Method

FindItems<T>(MetadataQualifiedNamePart) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > FindItems Method : FindItems<T>(MetadataQualifiedNamePart) Method
Returns the list of metadata items that match the name defined by MetadataQualifiedNamePart.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItems(Of T As MetadataItem)( _
   ByVal namePart As MetadataQualifiedNamePart _
) As System.Collections.Generic.IList(Of T)
'Usage

Dim instance As MetadataList
Dim namePart As MetadataQualifiedNamePart
Dim value As System.Collections.Generic.IList(Of T)

value = instance.FindItems(Of T)(namePart)
public System.Collections.Generic.IList<T> FindItems<T>(
   MetadataQualifiedNamePart namePart
)
where T: MetadataItem
public: System.Collections.Generic.IList<T*>* FindItems<T>(
   MetadataQualifiedNamePart* namePart
)
where T: MetadataItem

Parameters

namePart

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


GetDefaultItems<T> Method (MetadataList)

GetDefaultItems<T> Method (MetadataList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : GetDefaultItems<T> Method
Returns the list of default metadata items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetDefaultItems(Of T As MetadataItem)( _
   ByVal types As MetadataType _
) As System.Collections.Generic.List(Of T)
'Usage

Dim instance As MetadataList
Dim types As MetadataType
Dim value As System.Collections.Generic.List(Of T)

value = instance.GetDefaultItems(Of T)(types)
public System.Collections.Generic.List<T> GetDefaultItems<T>(
   MetadataType types
)
where T: MetadataItem
public: System.Collections.Generic.List<T*>* GetDefaultItems<T>(
   MetadataType types
)
where T: MetadataItem

Parameters

types

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


GetItems<T> Method (MetadataList)

GetItems<T> Method (MetadataList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : GetItems<T> Method
Returns the list of all metadata items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetItems(Of T As MetadataItem)( _
   ByVal types As MetadataType _
) As System.Collections.Generic.List(Of T)
'Usage

Dim instance As MetadataList
Dim types As MetadataType
Dim value As System.Collections.Generic.List(Of T)

value = instance.GetItems(Of T)(types)
public System.Collections.Generic.List<T> GetItems<T>(
   MetadataType types
)
where T: MetadataItem
public: System.Collections.Generic.List<T*>* GetItems<T>(
   MetadataType types
)
where T: MetadataItem

Parameters

types

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


GetItemsRecursive<T> Method

GetItemsRecursive<T> Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : GetItemsRecursive<T> Method
Returns the list of all metadata items and items of child lists recursively.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetItemsRecursive(Of T As MetadataItem)( _
   ByVal types As MetadataType _
) As System.Collections.Generic.List(Of T)
'Usage

Dim instance As MetadataList
Dim types As MetadataType
Dim value As System.Collections.Generic.List(Of T)

value = instance.GetItemsRecursive(Of T)(types)
public System.Collections.Generic.List<T> GetItemsRecursive<T>(
   MetadataType types
)
where T: MetadataItem
public: System.Collections.Generic.List<T*>* GetItemsRecursive<T>(
   MetadataType types
)
where T: MetadataItem

Parameters

types

Type Parameters

T
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


IsLoaded Method (MetadataList)

IsLoaded Method (MetadataList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : IsLoaded Method
Indicates if the specified types of metadata items have been loaded to the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function IsLoaded( _
   ByVal types As MetadataType _
) As System.Boolean
'Usage

Dim instance As MetadataList
Dim types As MetadataType
Dim value As System.Boolean

value = instance.IsLoaded(types)
public System.bool IsLoaded(
   MetadataType types
)
public: System.bool IsLoaded(
   MetadataType types
)

Parameters

types
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


Load Method (MetadataList)

Load Method (MetadataList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : Load Method
Loads specified types of metadata items to the list.
Overload List
Overload | Description
Load(MetadataType,Boolean) | Loads specified types of metadata items to the list.
Load(MetadataType,String) | Loads specified types of metadata items to the list by mask.
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


Load(MetadataType,Boolean) Method

Load(MetadataType,Boolean) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > Load Method : Load(MetadataType,Boolean) Method
Types of metadata items to load to the list.
True to load metadata items recursively; false to load items of this list only.
Loads specified types of metadata items to the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub Load( _
   ByVal loadTypes As MetadataType, _
   ByVal recursive As System.Boolean _
)
'Usage

Dim instance As MetadataList
Dim loadTypes As MetadataType
Dim recursive As System.Boolean

instance.Load(loadTypes, recursive)
public void Load(
   MetadataType loadTypes,
   System.bool recursive
)
public: void Load(
   MetadataType loadTypes,
   System.bool recursive
)

Parameters

loadTypes
Types of metadata items to load to the list.
recursive
True to load metadata items recursively; false to load items of this list only.
Remarks
On loading metadata items recursively, the loadTypes parameter will be appiled to recursive calls of this method for child lists.
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


Load(MetadataType,String) Method

Load(MetadataType,String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class > Load Method : Load(MetadataType,String) Method
Types of metadata items to load to the list.
Mask that metadata item names should match.
Loads specified types of metadata items to the list by mask.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub Load( _
   ByVal loadTypes As MetadataType, _
   ByVal mask As System.String _
)
'Usage

Dim instance As MetadataList
Dim loadTypes As MetadataType
Dim mask As System.String

instance.Load(loadTypes, mask)
public void Load(
   MetadataType loadTypes,
   System.string mask
)
public: void Load(
   MetadataType loadTypes,
   System.string* mask
)

Parameters

loadTypes
Types of metadata items to load to the list.
mask
Mask that metadata item names should match.
Remarks
Mask act similar to the "LIKE" SQL operator. Use the percent sign (%) to represent any sequence of characters; use the underscore sign (_) to represent any single character.
Requirements

See Also

Reference

MetadataList Class
MetadataList Members
Overload List


MetadataList Class Properties

MetadataList Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataList Class

For a list of all members of this type, see MetadataList members.

Public Properties
 | Name | Description
Public Property | Databases | Lists metadata items of the Database type.
Public Property | Fields | Lists metadata items of the Field type.
Public Property | ForeignKeys | Lists metadata items of the Foreign Key type.
Public Property | Namespaces | Lists metadata items of the all namespace types (Server, Package, Database, Schema).
Public Property | Objects | Lists metadata items of the all database object types (Table, View, Procedure, Synonym).
Public Property | Packages | Lists metadata items of the Package type.
Public Property | Parameters | Lists metadata items of the Parameter type.
Public Property | Parent | Refers to the parent metadata item.
Public Property | Procedures | Lists metadata items of the Procedure type.
Public Property | Schemas | Lists metadata items of the Schema type.
Public Property | Servers | Lists metadata items of the Server type.
Public Property | SQLContext | Refers to the context for SQL generation, SQL parsing and metadata loading purposes.
Public Property | Synonyms | Lists metadata items of the Synonym type.
Public Property | Tables | Lists metadata items of the Table type.
Public Property | Views | Lists metadata items of the View type.
Top
See Also

Reference

MetadataList Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Databases Property

Databases Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : Databases Property
Lists metadata items of the Database type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Databases As MetadataSelection(Of MetadataNamespace)
'Usage

Dim instance As MetadataList
Dim value As MetadataSelection(Of MetadataNamespace)

value = instance.Databases
public MetadataSelection<MetadataNamespace> Databases {get;}
public: __property MetadataSelection<MetadataNamespace*>* get_Databases();
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


Fields Property (MetadataList)

Fields Property (MetadataList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : Fields Property
Lists metadata items of the Field type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Fields As MetadataSelection(Of MetadataField)
'Usage

Dim instance As MetadataList
Dim value As MetadataSelection(Of MetadataField)

value = instance.Fields
public MetadataSelection<MetadataField> Fields {get;}
public: __property MetadataSelection<MetadataField*>* get_Fields();
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


ForeignKeys Property

ForeignKeys Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : ForeignKeys Property
Lists metadata items of the Foreign Key type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ForeignKeys As MetadataSelection(Of MetadataForeignKey)
'Usage

Dim instance As MetadataList
Dim value As MetadataSelection(Of MetadataForeignKey)

value = instance.ForeignKeys
public MetadataSelection<MetadataForeignKey> ForeignKeys {get;}
public: __property MetadataSelection<MetadataForeignKey*>* get_ForeignKeys();
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


Namespaces Property

Namespaces Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : Namespaces Property
Lists metadata items of the all namespace types (Server, Package, Database, Schema).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Namespaces As MetadataSelection(Of MetadataNamespace)
'Usage

Dim instance As MetadataList
Dim value As MetadataSelection(Of MetadataNamespace)

value = instance.Namespaces
public MetadataSelection<MetadataNamespace> Namespaces {get;}
public: __property MetadataSelection<MetadataNamespace*>* get_Namespaces();
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


Objects Property (MetadataList)

Objects Property (MetadataList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : Objects Property
Lists metadata items of the all database object types (Table, View, Procedure, Synonym).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Objects As MetadataSelection(Of MetadataObject)
'Usage

Dim instance As MetadataList
Dim value As MetadataSelection(Of MetadataObject)

value = instance.Objects
public MetadataSelection<MetadataObject> Objects {get;}
public: __property MetadataSelection<MetadataObject*>* get_Objects();
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


Packages Property

Packages Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : Packages Property
Lists metadata items of the Package type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Packages As MetadataSelection(Of MetadataNamespace)
'Usage

Dim instance As MetadataList
Dim value As MetadataSelection(Of MetadataNamespace)

value = instance.Packages
public MetadataSelection<MetadataNamespace> Packages {get;}
public: __property MetadataSelection<MetadataNamespace*>* get_Packages();
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


Parameters Property (MetadataList)

Parameters Property (MetadataList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : Parameters Property
Lists metadata items of the Parameter type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Parameters As MetadataSelection(Of MetadataParameter)
'Usage

Dim instance As MetadataList
Dim value As MetadataSelection(Of MetadataParameter)

value = instance.Parameters
public MetadataSelection<MetadataParameter> Parameters {get;}
public: __property MetadataSelection<MetadataParameter*>* get_Parameters();
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


Parent Property (MetadataList)

Parent Property (MetadataList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : Parent Property
Refers to the parent metadata item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Parent As MetadataItem
'Usage

Dim instance As MetadataList
Dim value As MetadataItem

value = instance.Parent
public MetadataItem Parent {get;}
public: __property MetadataItem* get_Parent();
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


Procedures Property

Procedures Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : Procedures Property
Lists metadata items of the Procedure type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Procedures As MetadataSelection(Of MetadataObject)
'Usage

Dim instance As MetadataList
Dim value As MetadataSelection(Of MetadataObject)

value = instance.Procedures
public MetadataSelection<MetadataObject> Procedures {get;}
public: __property MetadataSelection<MetadataObject*>* get_Procedures();
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


Schemas Property (MetadataList)

Schemas Property (MetadataList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : Schemas Property
Lists metadata items of the Schema type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Schemas As MetadataSelection(Of MetadataNamespace)
'Usage

Dim instance As MetadataList
Dim value As MetadataSelection(Of MetadataNamespace)

value = instance.Schemas
public MetadataSelection<MetadataNamespace> Schemas {get;}
public: __property MetadataSelection<MetadataNamespace*>* get_Schemas();
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


Servers Property

Servers Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : Servers Property
Lists metadata items of the Server type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Servers As MetadataSelection(Of MetadataNamespace)
'Usage

Dim instance As MetadataList
Dim value As MetadataSelection(Of MetadataNamespace)

value = instance.Servers
public MetadataSelection<MetadataNamespace> Servers {get;}
public: __property MetadataSelection<MetadataNamespace*>* get_Servers();
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


SQLContext Property (MetadataList)

SQLContext Property (MetadataList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : SQLContext Property
Refers to the context for SQL generation, SQL parsing and metadata loading purposes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property SQLContext As BaseSQLContext
'Usage

Dim instance As MetadataList
Dim value As BaseSQLContext

value = instance.SQLContext
public BaseSQLContext SQLContext {get;}
public: __property BaseSQLContext* get_SQLContext();
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


Synonyms Property

Synonyms Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : Synonyms Property
Lists metadata items of the Synonym type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Synonyms As MetadataSelection(Of MetadataObject)
'Usage

Dim instance As MetadataList
Dim value As MetadataSelection(Of MetadataObject)

value = instance.Synonyms
public MetadataSelection<MetadataObject> Synonyms {get;}
public: __property MetadataSelection<MetadataObject*>* get_Synonyms();
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


Tables Property

Tables Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : Tables Property
Lists metadata items of the Table type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Tables As MetadataSelection(Of MetadataObject)
'Usage

Dim instance As MetadataList
Dim value As MetadataSelection(Of MetadataObject)

value = instance.Tables
public MetadataSelection<MetadataObject> Tables {get;}
public: __property MetadataSelection<MetadataObject*>* get_Tables();
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


Views Property

Views Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataList Class : Views Property
Lists metadata items of the View type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Views As MetadataSelection(Of MetadataObject)
'Usage

Dim instance As MetadataList
Dim value As MetadataSelection(Of MetadataObject)

value = instance.Views
public MetadataSelection<MetadataObject> Views {get;}
public: __property MetadataSelection<MetadataObject*>* get_Views();
Requirements

See Also

Reference

MetadataList Class
MetadataList Members


MetadataLoadingOptions Class

MetadataLoadingOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataLoadingOptions Class
Determines rules of loading metadata to the component's Metadata Container.
Object Model
MetadataLoadingOptions ClassMetadataSimpleFilter ClassMetadataSimpleFilter ClassMetadataFilter Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MetadataLoadingOptions
   Inherits UpdatablePersistent
'Usage

Dim instance As MetadataLoadingOptions
public class MetadataLoadingOptions : UpdatablePersistent
public __gc class MetadataLoadingOptions : public UpdatablePersistent
Remarks

Definition of these rules results in limitation of the list of database objects displayed in the tree. It may also help to reduce metadata loading time for some database servers (eg. Oracle).

Formerly named as MetadataFilter, the new option set introduces a simpler way to define metadata loading rules using ExcludeFilter and IncludeFilter mask sets and other properties, among with old way that provides higher flexibility in defining metadata filtration rules.

MetadataSimpleFilter is just a simplified view of the MetadataFilter. You may use both types of filters at a time: the masks defined in the ExcluedFilter and IncludeFilter will be converted to a set of MetadataFilterItems and joined with the items of the MetadataFilter.

Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataLoadingOptions

Requirements

See Also

Reference

MetadataLoadingOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
MetadataLoadingOptions Property


MetadataLoadingOptions Class Members

MetadataLoadingOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataLoadingOptions Class

The following tables list the members exposed by MetadataLoadingOptions.

Public Properties
 | Name | Description
Public Property | ExcludeFilter | Holds masks for database object and schema names that should NOT be loaded into the Metadata Container.
Public Property | IncludeFilter | Holds masks for database object and schema names to be loaded into the Metadata Container.
Public Property | LoadDefaultDatabaseOnly | Determines if only the default database should be loaded to the Metadata Container or all databases.
Public Property | LoadSystemObjects | Instructs to load database objects marked as System to the Metadata Container.
Public Property | MetadataFilter | Introduces more complex but flexible way to define metadata filtration rules.
Top
See Also

Reference

MetadataLoadingOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
MetadataLoadingOptions Property


MetadataLoadingOptions Class Properties

MetadataLoadingOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataLoadingOptions Class

For a list of all members of this type, see MetadataLoadingOptions members.

Public Properties
 | Name | Description
Public Property | ExcludeFilter | Holds masks for database object and schema names that should NOT be loaded into the Metadata Container.
Public Property | IncludeFilter | Holds masks for database object and schema names to be loaded into the Metadata Container.
Public Property | LoadDefaultDatabaseOnly | Determines if only the default database should be loaded to the Metadata Container or all databases.
Public Property | LoadSystemObjects | Instructs to load database objects marked as System to the Metadata Container.
Public Property | MetadataFilter | Introduces more complex but flexible way to define metadata filtration rules.
Top
See Also

Reference

MetadataLoadingOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
MetadataLoadingOptions Property


ExcludeFilter Property

ExcludeFilter Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataLoadingOptions Class : ExcludeFilter Property
Holds masks for database object and schema names that should NOT be loaded into the Metadata Container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ExcludeFilter As MetadataSimpleFilter
'Usage

Dim instance As MetadataLoadingOptions
Dim value As MetadataSimpleFilter

instance.ExcludeFilter = value

value = instance.ExcludeFilter
public MetadataSimpleFilter ExcludeFilter {get; set;}
public: __property MetadataSimpleFilter* get_ExcludeFilter();
public: __property void set_ExcludeFilter(
   MetadataSimpleFilter* value
);
Requirements

See Also

Reference

MetadataLoadingOptions Class
MetadataLoadingOptions Members
IncludeFilter Property


IncludeFilter Property

IncludeFilter Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataLoadingOptions Class : IncludeFilter Property
Holds masks for database object and schema names to be loaded into the Metadata Container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property IncludeFilter As MetadataSimpleFilter
'Usage

Dim instance As MetadataLoadingOptions
Dim value As MetadataSimpleFilter

instance.IncludeFilter = value

value = instance.IncludeFilter
public MetadataSimpleFilter IncludeFilter {get; set;}
public: __property MetadataSimpleFilter* get_IncludeFilter();
public: __property void set_IncludeFilter(
   MetadataSimpleFilter* value
);
Requirements

See Also

Reference

MetadataLoadingOptions Class
MetadataLoadingOptions Members
ExcludeFilter Property


LoadDefaultDatabaseOnly Property

LoadDefaultDatabaseOnly Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataLoadingOptions Class : LoadDefaultDatabaseOnly Property
Determines if only the default database should be loaded to the Metadata Container or all databases.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property LoadDefaultDatabaseOnly As System.Boolean
'Usage

Dim instance As MetadataLoadingOptions
Dim value As System.Boolean

instance.LoadDefaultDatabaseOnly = value

value = instance.LoadDefaultDatabaseOnly
public System.bool LoadDefaultDatabaseOnly {get; set;}
public: __property System.bool get_LoadDefaultDatabaseOnly();
public: __property void set_LoadDefaultDatabaseOnly(
   System.bool value
);
Remarks
In case there is no default database set, the component will ignore this property and load all databases to avoid emptiness of the metadata container and the database schema tree.
Requirements

See Also

Reference

MetadataLoadingOptions Class
MetadataLoadingOptions Members


LoadSystemObjects Property

LoadSystemObjects Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataLoadingOptions Class : LoadSystemObjects Property
Instructs to load database objects marked as System to the Metadata Container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property LoadSystemObjects As System.Boolean
'Usage

Dim instance As MetadataLoadingOptions
Dim value As System.Boolean

instance.LoadSystemObjects = value

value = instance.LoadSystemObjects
public System.bool LoadSystemObjects {get; set;}
public: __property System.bool get_LoadSystemObjects();
public: __property void set_LoadSystemObjects(
   System.bool value
);

Property Value

true to load system objects; false not to load them.
Remarks
You may load, but hide system database objects from the Database Schema Tree using the DatabaseSchemaTreeOptions.HideSystemObjects property.
Requirements

See Also

Reference

MetadataLoadingOptions Class
MetadataLoadingOptions Members


MetadataFilter Property (MetadataLoadingOptions)

MetadataFilter Property (MetadataLoadingOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataLoadingOptions Class : MetadataFilter Property
Introduces more complex but flexible way to define metadata filtration rules.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property MetadataFilter As MetadataFilter
'Usage

Dim instance As MetadataLoadingOptions
Dim value As MetadataFilter

instance.MetadataFilter = value

value = instance.MetadataFilter
public MetadataFilter MetadataFilter {get; set;}
public: __property MetadataFilter* get_MetadataFilter();
public: __property void set_MetadataFilter(
   MetadataFilter* value
);
Requirements

See Also

Reference

MetadataLoadingOptions Class
MetadataLoadingOptions Members


MetadataNameList Class

MetadataNameList Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataNameList Class
List of field names for fields of a foreign key
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MetadataNameList
   Inherits UpdatableStringList
'Usage

Dim instance As MetadataNameList
public class MetadataNameList : UpdatableStringList
public __gc class MetadataNameList : public UpdatableStringList
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataNameList

Requirements

See Also

Reference

MetadataNameList Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataNameList Class Members

MetadataNameList Class Members
Properties Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataNameList Class

The following tables list the members exposed by MetadataNameList.

Public Properties
 | Name | Description
Public Property | SQLContext | Refers to the context for SQL generation, SQL parsing and metadata loading purposes.
Top
Public Methods
 | Name | Description
Public Method | Compare | Compares items of this list with items of another list.
Public Method | Find | Determines if a field name exists in the list.
Public Method | FindIndex | Gets index of a field name.
Top
See Also

Reference

MetadataNameList Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataNameList Class Methods

MetadataNameList Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataNameList Class

For a list of all members of this type, see MetadataNameList members.

Public Methods
 | Name | Description
Public Method | Compare | Compares items of this list with items of another list.
Public Method | Find | Determines if a field name exists in the list.
Public Method | FindIndex | Gets index of a field name.
Top
See Also

Reference

MetadataNameList Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Compare Method

Compare Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataNameList Class : Compare Method
Compares items of this list with items of another list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function Compare( _
   ByVal right As MetadataNameList _
) As System.Integer
'Usage

Dim instance As MetadataNameList
Dim right As MetadataNameList
Dim value As System.Integer

value = instance.Compare(right)
public System.int Compare(
   MetadataNameList right
)
public: System.int Compare(
   MetadataNameList* right
)

Parameters

right

Return Value

Zero if lists are equal; non-zero otherwise.
Requirements

See Also

Reference

MetadataNameList Class
MetadataNameList Members


Find Method

Find Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataNameList Class : Find Method
Determines if a field name exists in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function Find( _
   ByVal name As System.String _
) As System.Boolean
'Usage

Dim instance As MetadataNameList
Dim name As System.String
Dim value As System.Boolean

value = instance.Find(name)
public System.bool Find(
   System.string name
)
public: System.bool Find(
   System.string* name
)

Parameters

name

Return Value

True if found, false otherwise.
Requirements

See Also

Reference

MetadataNameList Class
MetadataNameList Members


FindIndex Method (MetadataNameList)

FindIndex Method (MetadataNameList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataNameList Class : FindIndex Method
Gets index of a field name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function FindIndex( _
   ByVal name As System.String _
) As System.Integer
'Usage

Dim instance As MetadataNameList
Dim name As System.String
Dim value As System.Integer

value = instance.FindIndex(name)
public System.int FindIndex(
   System.string name
)
public: System.int FindIndex(
   System.string* name
)

Parameters

name

Return Value

Index of a field name if found; -1 otherwise.
Requirements

See Also

Reference

MetadataNameList Class
MetadataNameList Members


MetadataNameList Class Properties

MetadataNameList Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataNameList Class

For a list of all members of this type, see MetadataNameList members.

Public Properties
 | Name | Description
Public Property | SQLContext | Refers to the context for SQL generation, SQL parsing and metadata loading purposes.
Top
See Also

Reference

MetadataNameList Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQLContext Property (MetadataNameList)

SQLContext Property (MetadataNameList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataNameList Class : SQLContext Property
Refers to the context for SQL generation, SQL parsing and metadata loading purposes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property SQLContext As BaseSQLContext
'Usage

Dim instance As MetadataNameList
Dim value As BaseSQLContext

value = instance.SQLContext
public BaseSQLContext SQLContext {get;}
public: __property BaseSQLContext* get_SQLContext();
Requirements

See Also

Reference

MetadataNameList Class
MetadataNameList Members


MetadataNamesFetcher Class

MetadataNamesFetcher Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataNamesFetcher Class
Helper object to get list of available namespaces in the database.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public MustInherit NotInheritable Class MetadataNamesFetcher
'Usage

Dim instance As MetadataNamesFetcher
public static class MetadataNamesFetcher
public __gc abstract __sealed class MetadataNamesFetcher
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataNamesFetcher

Requirements

See Also

Reference

MetadataNamesFetcher Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataNamesFetcher Class Members

MetadataNamesFetcher Class Members
Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataNamesFetcher Class

The following tables list the members exposed by MetadataNamesFetcher.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetDatabaseNames | Gets list of database names available within the current connection.
static (Shared in Visual Basic) | GetDefaultDatabaseNames | Gets list of default database names available within the current connection.
static (Shared in Visual Basic) | GetDefaultSchemaNames | Gets list of default schema names available within the current connection.
static (Shared in Visual Basic) | GetPackageNames | Gets list of package names available within the current connection.
static (Shared in Visual Basic) | GetSchemaNames | Gets list of schema names available within the current connection.
static (Shared in Visual Basic) | GetServerNames | Gets list of server names available within the current connection.
Top
See Also

Reference

MetadataNamesFetcher Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataNamesFetcher Class Methods

MetadataNamesFetcher Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataNamesFetcher Class

For a list of all members of this type, see MetadataNamesFetcher members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetDatabaseNames | Gets list of database names available within the current connection.
static (Shared in Visual Basic) | GetDefaultDatabaseNames | Gets list of default database names available within the current connection.
static (Shared in Visual Basic) | GetDefaultSchemaNames | Gets list of default schema names available within the current connection.
static (Shared in Visual Basic) | GetPackageNames | Gets list of package names available within the current connection.
static (Shared in Visual Basic) | GetSchemaNames | Gets list of schema names available within the current connection.
static (Shared in Visual Basic) | GetServerNames | Gets list of server names available within the current connection.
Top
See Also

Reference

MetadataNamesFetcher Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


GetDatabaseNames Method

GetDatabaseNames Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataNamesFetcher Class : GetDatabaseNames Method
Determines the current database connection and SQL syntax.
Defines the server name to retrieve the list of databases for.
Gets list of database names available within the current connection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Shared Function GetDatabaseNames( _
   ByVal sqlContext As BaseSQLContext, _
   ByVal parentName As System.String _
) As System.Collections.Generic.IList(Of String)
'Usage

Dim sqlContext As BaseSQLContext
Dim parentName As System.String
Dim value As System.Collections.Generic.IList(Of String)

value = MetadataNamesFetcher.GetDatabaseNames(sqlContext, parentName)
public static System.Collections.Generic.IList<string> GetDatabaseNames(
   BaseSQLContext sqlContext,
   System.string parentName
)
public: static System.Collections.Generic.IList<string*>* GetDatabaseNames(
   BaseSQLContext* sqlContext,
   System.string* parentName
)

Parameters

sqlContext
Determines the current database connection and SQL syntax.
parentName
Defines the server name to retrieve the list of databases for.
Requirements

See Also

Reference

MetadataNamesFetcher Class
MetadataNamesFetcher Members


GetDefaultDatabaseNames Method

GetDefaultDatabaseNames Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataNamesFetcher Class : GetDefaultDatabaseNames Method
Determines the current database connection and SQL syntax.
Defines the server name to retrieve the list of databases for.
Gets list of default database names available within the current connection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Shared Function GetDefaultDatabaseNames( _
   ByVal sqlContext As BaseSQLContext, _
   ByVal parentName As System.String _
) As System.Collections.Generic.IList(Of String)
'Usage

Dim sqlContext As BaseSQLContext
Dim parentName As System.String
Dim value As System.Collections.Generic.IList(Of String)

value = MetadataNamesFetcher.GetDefaultDatabaseNames(sqlContext, parentName)
public static System.Collections.Generic.IList<string> GetDefaultDatabaseNames(
   BaseSQLContext sqlContext,
   System.string parentName
)
public: static System.Collections.Generic.IList<string*>* GetDefaultDatabaseNames(
   BaseSQLContext* sqlContext,
   System.string* parentName
)

Parameters

sqlContext
Determines the current database connection and SQL syntax.
parentName
Defines the server name to retrieve the list of databases for.
Requirements

See Also

Reference

MetadataNamesFetcher Class
MetadataNamesFetcher Members


GetDefaultSchemaNames Method

GetDefaultSchemaNames Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataNamesFetcher Class : GetDefaultSchemaNames Method
Determines the current database connection and SQL syntax.
Defines the server and database name to retrieve the list of schemas for. Example: "server.database" or "database".
Gets list of default schema names available within the current connection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Shared Function GetDefaultSchemaNames( _
   ByVal sqlContext As BaseSQLContext, _
   ByVal parentName As System.String _
) As System.Collections.Generic.IList(Of String)
'Usage

Dim sqlContext As BaseSQLContext
Dim parentName As System.String
Dim value As System.Collections.Generic.IList(Of String)

value = MetadataNamesFetcher.GetDefaultSchemaNames(sqlContext, parentName)
public static System.Collections.Generic.IList<string> GetDefaultSchemaNames(
   BaseSQLContext sqlContext,
   System.string parentName
)
public: static System.Collections.Generic.IList<string*>* GetDefaultSchemaNames(
   BaseSQLContext* sqlContext,
   System.string* parentName
)

Parameters

sqlContext
Determines the current database connection and SQL syntax.
parentName
Defines the server and database name to retrieve the list of schemas for. Example: "server.database" or "database".
Requirements

See Also

Reference

MetadataNamesFetcher Class
MetadataNamesFetcher Members


GetPackageNames Method

GetPackageNames Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataNamesFetcher Class : GetPackageNames Method
Determines the current database connection and SQL syntax.
Defines the server, database and schema name to retrieve the list of packages for. Example: "server.database.schema" or "database.schema".
Gets list of package names available within the current connection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Shared Function GetPackageNames( _
   ByVal sqlContext As BaseSQLContext, _
   ByVal parentName As System.String _
) As System.Collections.Generic.IList(Of String)
'Usage

Dim sqlContext As BaseSQLContext
Dim parentName As System.String
Dim value As System.Collections.Generic.IList(Of String)

value = MetadataNamesFetcher.GetPackageNames(sqlContext, parentName)
public static System.Collections.Generic.IList<string> GetPackageNames(
   BaseSQLContext sqlContext,
   System.string parentName
)
public: static System.Collections.Generic.IList<string*>* GetPackageNames(
   BaseSQLContext* sqlContext,
   System.string* parentName
)

Parameters

sqlContext
Determines the current database connection and SQL syntax.
parentName
Defines the server, database and schema name to retrieve the list of packages for. Example: "server.database.schema" or "database.schema".
Requirements

See Also

Reference

MetadataNamesFetcher Class
MetadataNamesFetcher Members


GetSchemaNames Method

GetSchemaNames Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataNamesFetcher Class : GetSchemaNames Method
Determines the current database connection and SQL syntax.
Defines the server and database name to retrieve the list of schemas for. Example: "server.database" or "database".
Gets list of schema names available within the current connection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Shared Function GetSchemaNames( _
   ByVal sqlContext As BaseSQLContext, _
   ByVal parentName As System.String _
) As System.Collections.Generic.IList(Of String)
'Usage

Dim sqlContext As BaseSQLContext
Dim parentName As System.String
Dim value As System.Collections.Generic.IList(Of String)

value = MetadataNamesFetcher.GetSchemaNames(sqlContext, parentName)
public static System.Collections.Generic.IList<string> GetSchemaNames(
   BaseSQLContext sqlContext,
   System.string parentName
)
public: static System.Collections.Generic.IList<string*>* GetSchemaNames(
   BaseSQLContext* sqlContext,
   System.string* parentName
)

Parameters

sqlContext
Determines the current database connection and SQL syntax.
parentName
Defines the server and database name to retrieve the list of schemas for. Example: "server.database" or "database".
Requirements

See Also

Reference

MetadataNamesFetcher Class
MetadataNamesFetcher Members


GetServerNames Method

GetServerNames Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataNamesFetcher Class : GetServerNames Method
Determines the current database connection and SQL syntax.
Gets list of server names available within the current connection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Shared Function GetServerNames( _
   ByVal sqlContext As BaseSQLContext _
) As System.Collections.Generic.IList(Of String)
'Usage

Dim sqlContext As BaseSQLContext
Dim value As System.Collections.Generic.IList(Of String)

value = MetadataNamesFetcher.GetServerNames(sqlContext)
public static System.Collections.Generic.IList<string> GetServerNames(
   BaseSQLContext sqlContext
)
public: static System.Collections.Generic.IList<string*>* GetServerNames(
   BaseSQLContext* sqlContext
)

Parameters

sqlContext
Determines the current database connection and SQL syntax.
Requirements

See Also

Reference

MetadataNamesFetcher Class
MetadataNamesFetcher Members


MetadataNamespace Class

MetadataNamespace Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataNamespace Class
Class to represent namespace items in the Metadata Container: Server, Package, Database, Schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public NotInheritable Class MetadataNamespace
   Inherits MetadataItem
'Usage

Dim instance As MetadataNamespace
public sealed class MetadataNamespace : MetadataItem
public __gc __sealed class MetadataNamespace : public MetadataItem
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataItem
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataNamespace

Requirements

See Also

Reference

MetadataNamespace Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataNamespace Class Members

MetadataNamespace Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataNamespace Class

The following tables list the members exposed by MetadataNamespace.

See Also

Reference

MetadataNamespace Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataObject Class

MetadataObject Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataObject Class
Class to represent database objects in the Metadata Container.
Object Model
MetadataObject ClassMetadataObject Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MetadataObject
   Inherits MetadataItem
'Usage

Dim instance As MetadataObject
public class MetadataObject : MetadataItem
public __gc class MetadataObject : public MetadataItem
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataItem
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataObject

Requirements

See Also

Reference

MetadataObject Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataObject Class Members

MetadataObject Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataObject Class

The following tables list the members exposed by MetadataObject.

Public Properties
 | Name | Description
Public Property | Expression | Gets or sets the SQL expression string for a virtual metadata object.
Public Property | ExpressionAST | Gets parsed SQL expression for a virtual metadata object.
Public Property | ReferencedObject | Gets the reference to Metadata Object referred by the ReferencedObjectName property.
Public Property | ReferencedObjectName | Gets or sets the name of referenced object for synonym.
Top
Public Methods
 | Name | Description
Public Method | GetReferencingObjects |
Public Method | IsVirtual | Indicates that the metadata object is a virtual calculated object.
Top
See Also

Reference

MetadataObject Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataObject Class Methods

MetadataObject Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataObject Class

For a list of all members of this type, see MetadataObject members.

Public Methods
 | Name | Description
Public Method | GetReferencingObjects |
Public Method | IsVirtual | Indicates that the metadata object is a virtual calculated object.
Top
See Also

Reference

MetadataObject Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


GetReferencingObjects Method

GetReferencingObjects Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataObject Class : GetReferencingObjects Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetReferencingObjects() As System.Collections.Generic.IList(Of MetadataObject)
'Usage

Dim instance As MetadataObject
Dim value As System.Collections.Generic.IList(Of MetadataObject)

value = instance.GetReferencingObjects()
public System.Collections.Generic.IList<MetadataObject> GetReferencingObjects()
public: System.Collections.Generic.IList<MetadataObject*>* GetReferencingObjects();
Requirements

See Also

Reference

MetadataObject Class
MetadataObject Members


IsVirtual Method (MetadataObject)

IsVirtual Method (MetadataObject)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataObject Class : IsVirtual Method
Indicates that the metadata object is a virtual calculated object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function IsVirtual() As System.Boolean
'Usage

Dim instance As MetadataObject
Dim value As System.Boolean

value = instance.IsVirtual()
public System.bool IsVirtual()
public: System.bool IsVirtual();

Return Value

True if Expression is not empty; false otherwise.
Remarks
Virtual objects are replaced with expressions in result SQL query text. The Expression property of virtual metadata object must be set to valid SELECT statement to be used as derived table in result SQL query.
Requirements

See Also

Reference

MetadataObject Class
MetadataObject Members


MetadataObject Class Properties

MetadataObject Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataObject Class

For a list of all members of this type, see MetadataObject members.

Public Properties
 | Name | Description
Public Property | Expression | Gets or sets the SQL expression string for a virtual metadata object.
Public Property | ExpressionAST | Gets parsed SQL expression for a virtual metadata object.
Public Property | ReferencedObject | Gets the reference to Metadata Object referred by the ReferencedObjectName property.
Public Property | ReferencedObjectName | Gets or sets the name of referenced object for synonym.
Top
See Also

Reference

MetadataObject Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Expression Property (MetadataObject)

Expression Property (MetadataObject)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataObject Class : Expression Property
Gets or sets the SQL expression string for a virtual metadata object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Expression As System.String
'Usage

Dim instance As MetadataObject
Dim value As System.String

instance.Expression = value

value = instance.Expression
public System.string Expression {get; set;}
public: __property System.string* get_Expression();
public: __property void set_Expression(
   System.string* value
);

Property Value

Valid SELECT statement string to be used as replacement for this object in result SQL query text in a form of derived table.
Requirements

See Also

Reference

MetadataObject Class
MetadataObject Members


ExpressionAST Property (MetadataObject)

ExpressionAST Property (MetadataObject)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataObject Class : ExpressionAST Property
Gets parsed SQL expression for a virtual metadata object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ExpressionAST As SQLFromSource
'Usage

Dim instance As MetadataObject
Dim value As SQLFromSource

value = instance.ExpressionAST
public SQLFromSource ExpressionAST {get;}
public: __property SQLFromSource* get_ExpressionAST();
Requirements

See Also

Reference

MetadataObject Class
MetadataObject Members


ReferencedObject Property (MetadataObject)

ReferencedObject Property (MetadataObject)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataObject Class : ReferencedObject Property
Gets the reference to Metadata Object referred by the ReferencedObjectName property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ReferencedObject As MetadataObject
'Usage

Dim instance As MetadataObject
Dim value As MetadataObject

value = instance.ReferencedObject
public MetadataObject ReferencedObject {get;}
public: __property MetadataObject* get_ReferencedObject();
Requirements

See Also

Reference

MetadataObject Class
MetadataObject Members


ReferencedObjectName Property (MetadataObject)

ReferencedObjectName Property (MetadataObject)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataObject Class : ReferencedObjectName Property
Gets or sets the name of referenced object for synonym.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ReferencedObjectName As MetadataQualifiedName
'Usage

Dim instance As MetadataObject
Dim value As MetadataQualifiedName

instance.ReferencedObjectName = value

value = instance.ReferencedObjectName
public MetadataQualifiedName ReferencedObjectName {get; set;}
public: __property MetadataQualifiedName* get_ReferencedObjectName();
public: __property void set_ReferencedObjectName(
   MetadataQualifiedName* value
);
Requirements

See Also

Reference

MetadataObject Class
MetadataObject Members


MetadataParameter Class

MetadataParameter Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataParameter Class
Class to represent parameters of stored procedures and functions in the Metadata Container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MetadataParameter
   Inherits MetadataItem
'Usage

Dim instance As MetadataParameter
public class MetadataParameter : MetadataItem
public __gc class MetadataParameter : public MetadataItem
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataItem
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataParameter

Requirements

See Also

Reference

MetadataParameter Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataParameter Class Members

MetadataParameter Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataParameter Class

The following tables list the members exposed by MetadataParameter.

Public Properties
 | Name | Description
Public Property | DataType | Gets or sets the data type of parameter.
Public Property | DataTypeName | Gets or sets native server data type name of a field.
Public Property | Direction | Gets or sets parameter direction.
Public Property | Precision | Gets or sets the data type precision of parameter.
Public Property | Scale | Gets or sets the data type scale of parameter.
Public Property | Size | Gets or sets the data type size of parameter.
Top
See Also

Reference

MetadataParameter Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataParameter Class Properties

MetadataParameter Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataParameter Class

For a list of all members of this type, see MetadataParameter members.

Public Properties
 | Name | Description
Public Property | DataType | Gets or sets the data type of parameter.
Public Property | DataTypeName | Gets or sets native server data type name of a field.
Public Property | Direction | Gets or sets parameter direction.
Public Property | Precision | Gets or sets the data type precision of parameter.
Public Property | Scale | Gets or sets the data type scale of parameter.
Public Property | Size | Gets or sets the data type size of parameter.
Top
See Also

Reference

MetadataParameter Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


DataType Property (MetadataParameter)

DataType Property (MetadataParameter)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataParameter Class : DataType Property
Gets or sets the data type of parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DataType As System.Data.DbType
'Usage

Dim instance As MetadataParameter
Dim value As System.Data.DbType

instance.DataType = value

value = instance.DataType
public System.Data.DbType DataType {get; set;}
public: __property System.Data.DbType get_DataType();
public: __property void set_DataType(
   System.Data.DbType value
);
Requirements

See Also

Reference

MetadataParameter Class
MetadataParameter Members


DataTypeName Property

DataTypeName Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataParameter Class : DataTypeName Property
Gets or sets native server data type name of a field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DataTypeName As System.String
'Usage

Dim instance As MetadataParameter
Dim value As System.String

instance.DataTypeName = value

value = instance.DataTypeName
public System.string DataTypeName {get; set;}
public: __property System.string* get_DataTypeName();
public: __property void set_DataTypeName(
   System.string* value
);
Requirements

See Also

Reference

MetadataParameter Class
MetadataParameter Members


Direction Property (MetadataParameter)

Direction Property (MetadataParameter)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataParameter Class : Direction Property
Gets or sets parameter direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Direction As System.Data.ParameterDirection
'Usage

Dim instance As MetadataParameter
Dim value As System.Data.ParameterDirection

instance.Direction = value

value = instance.Direction
public System.Data.ParameterDirection Direction {get; set;}
public: __property System.Data.ParameterDirection get_Direction();
public: __property void set_Direction(
   System.Data.ParameterDirection value
);
Requirements

See Also

Reference

MetadataParameter Class
MetadataParameter Members


Precision Property (MetadataParameter)

Precision Property (MetadataParameter)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataParameter Class : Precision Property
Gets or sets the data type precision of parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Precision As System.Integer
'Usage

Dim instance As MetadataParameter
Dim value As System.Integer

instance.Precision = value

value = instance.Precision
public System.int Precision {get; set;}
public: __property System.int get_Precision();
public: __property void set_Precision(
   System.int value
);
Requirements

See Also

Reference

MetadataParameter Class
MetadataParameter Members


Scale Property (MetadataParameter)

Scale Property (MetadataParameter)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataParameter Class : Scale Property
Gets or sets the data type scale of parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Scale As System.Integer
'Usage

Dim instance As MetadataParameter
Dim value As System.Integer

instance.Scale = value

value = instance.Scale
public System.int Scale {get; set;}
public: __property System.int get_Scale();
public: __property void set_Scale(
   System.int value
);
Requirements

See Also

Reference

MetadataParameter Class
MetadataParameter Members


Size Property (MetadataParameter)

Size Property (MetadataParameter)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataParameter Class : Size Property
Gets or sets the data type size of parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Size As System.Integer
'Usage

Dim instance As MetadataParameter
Dim value As System.Integer

instance.Size = value

value = instance.Size
public System.int Size {get; set;}
public: __property System.int get_Size();
public: __property void set_Size(
   System.int value
);
Requirements

See Also

Reference

MetadataParameter Class
MetadataParameter Members


MetadataSelection<T> Class

MetadataSelection<T> Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataSelection<T> Class
Selection of metadata items of specified types from the metadata list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MetadataSelection(Of T As MetadataItem)
'Usage

Dim instance As MetadataSelection(Of T)
public class MetadataSelection<T>
where T: MetadataItem
public __gc class MetadataSelection<T>
where T: MetadataItem
Type Parameters
T
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataSelection<T>

Requirements

See Also

Reference

MetadataSelection<T> Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataSelection<T> Class Members

MetadataSelection<T> Class Members
Properties Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataSelection<T> Class

The following tables list the members exposed by MetadataSelection<T>.

Public Properties
 | Name | Description
Public Property | Count | Gets number of items in selection.
Public Property | IsReadOnly | Indicates that selection can not be modified.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds metadata item to the list.
Public Method | Clear | Removes all items from selection.
Public Method | Contains | Indicates if selection contains an item.
Public Method | FindIndex | Overloaded. Returns the index of first found metadata item that matches the string name.
Public Method | FindIndices | Overloaded. Returns the list of indexes of metadata items that match the string name.
Public Method | FindItem | Overloaded. Returns the first found metadata item that matches the string name.
Public Method | FindItems | Overloaded. Returns the list of metadata items that match the string name.
Public Method | GetDefaultItems |
Public Method | GetItems |
Public Method | IsLoaded | Indicates if the types of metadata items sprcified in constructor have been loaded to the list.
Public Method | Load | Loads types of metadata items specified in constructor to the list.
Public Method | Remove | Removes metadata item from the list.
Top
See Also

Reference

MetadataSelection<T> Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataSelection<T> Class Methods

MetadataSelection<T> Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataSelection<T> Class

For a list of all members of this type, see MetadataSelection<T> members.

Public Methods
 | Name | Description
Public Method | Add | Adds metadata item to the list.
Public Method | Clear | Removes all items from selection.
Public Method | Contains | Indicates if selection contains an item.
Public Method | FindIndex | Overloaded. Returns the index of first found metadata item that matches the string name.
Public Method | FindIndices | Overloaded. Returns the list of indexes of metadata items that match the string name.
Public Method | FindItem | Overloaded. Returns the first found metadata item that matches the string name.
Public Method | FindItems | Overloaded. Returns the list of metadata items that match the string name.
Public Method | GetDefaultItems |
Public Method | GetItems |
Public Method | IsLoaded | Indicates if the types of metadata items sprcified in constructor have been loaded to the list.
Public Method | Load | Loads types of metadata items specified in constructor to the list.
Public Method | Remove | Removes metadata item from the list.
Top
See Also

Reference

MetadataSelection<T> Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Add Method (MetadataSelection<T>)

Add Method (MetadataSelection<T>)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class : Add Method
Adds metadata item to the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Add( _
   ByVal item As T _
)
'Usage

Dim instance As MetadataSelection(Of T)
Dim item As T

instance.Add(item)
public void Add(
   T item
)
public: void Add(
   T* item
)

Parameters

item
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members


Clear Method (MetadataSelection<T>)

Clear Method (MetadataSelection<T>)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class : Clear Method
Removes all items from selection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Clear()
'Usage

Dim instance As MetadataSelection(Of T)

instance.Clear()
public void Clear()
public: void Clear();
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members


Contains Method (MetadataSelection<T>)

Contains Method (MetadataSelection<T>)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class : Contains Method
Indicates if selection contains an item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function Contains( _
   ByVal item As T _
) As System.Boolean
'Usage

Dim instance As MetadataSelection(Of T)
Dim item As T
Dim value As System.Boolean

value = instance.Contains(item)
public System.bool Contains(
   T item
)
public: System.bool Contains(
   T* item
)

Parameters

item
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members


FindIndex Method (MetadataSelection<T>)

FindIndex Method (MetadataSelection<T>)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class : FindIndex Method
Returns the index of first found metadata item that matches the string name.
Overload List
Overload | Description
FindIndex(String) | Returns the index of first found metadata item that matches the string name.
FindIndex(AstToken) | Returns the index of first found metadata item that matches the name defined by AST token identifier.
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members


FindIndex(String) Method

FindIndex(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class > FindIndex Method : FindIndex(String) Method
Returns the index of first found metadata item that matches the string name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindIndex( _
   ByVal name As System.String _
) As System.Integer
'Usage

Dim instance As MetadataSelection(Of T)
Dim name As System.String
Dim value As System.Integer

value = instance.FindIndex(name)
public System.int FindIndex(
   System.string name
)
public: System.int FindIndex(
   System.string* name
)

Parameters

name
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members
Overload List


FindIndex(AstToken) Method

FindIndex(AstToken) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class > FindIndex Method : FindIndex(AstToken) Method
Returns the index of first found metadata item that matches the name defined by AST token identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindIndex( _
   ByVal name As AstToken _
) As System.Integer
'Usage

Dim instance As MetadataSelection(Of T)
Dim name As AstToken
Dim value As System.Integer

value = instance.FindIndex(name)
public System.int FindIndex(
   AstToken name
)
public: System.int FindIndex(
   AstToken* name
)

Parameters

name
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members
Overload List


FindIndices Method (MetadataSelection<T>)

FindIndices Method (MetadataSelection<T>)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class : FindIndices Method
Returns the list of indexes of metadata items that match the string name.
Overload List
Overload | Description
FindIndices(String) | Returns the list of indexes of metadata items that match the string name.
FindIndices(AstToken) | Returns the list of indexes of metadata items that match the name defined by AST token identifier.
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members


FindIndices(String) Method

FindIndices(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class > FindIndices Method : FindIndices(String) Method
Returns the list of indexes of metadata items that match the string name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindIndices( _
   ByVal name As System.String _
) As System.Collections.Generic.IList(Of Integer)
'Usage

Dim instance As MetadataSelection(Of T)
Dim name As System.String
Dim value As System.Collections.Generic.IList(Of Integer)

value = instance.FindIndices(name)
public System.Collections.Generic.IList<int> FindIndices(
   System.string name
)
public: System.Collections.Generic.IList<int>* FindIndices(
   System.string* name
)

Parameters

name
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members
Overload List


FindIndices(AstToken) Method

FindIndices(AstToken) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class > FindIndices Method : FindIndices(AstToken) Method
Returns the list of indexes of metadata items that match the name defined by AST token identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindIndices( _
   ByVal name As AstToken _
) As System.Collections.Generic.IList(Of Integer)
'Usage

Dim instance As MetadataSelection(Of T)
Dim name As AstToken
Dim value As System.Collections.Generic.IList(Of Integer)

value = instance.FindIndices(name)
public System.Collections.Generic.IList<int> FindIndices(
   AstToken name
)
public: System.Collections.Generic.IList<int>* FindIndices(
   AstToken* name
)

Parameters

name
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members
Overload List


FindItem Method (MetadataSelection<T>)

FindItem Method (MetadataSelection<T>)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class : FindItem Method
Returns the first found metadata item that matches the string name.
Overload List
Overload | Description
FindItem(String) | Returns the first found metadata item that matches the string name.
FindItem(AstToken) | Returns the first found metadata item that matches the name defined by AST token identifier.
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members


FindItem(String) Method

FindItem(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class > FindItem Method : FindItem(String) Method
Returns the first found metadata item that matches the string name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItem( _
   ByVal name As System.String _
) As T
'Usage

Dim instance As MetadataSelection(Of T)
Dim name As System.String
Dim value As T

value = instance.FindItem(name)
public T FindItem(
   System.string name
)
public: T* FindItem(
   System.string* name
)

Parameters

name
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members
Overload List


FindItem(AstToken) Method

FindItem(AstToken) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class > FindItem Method : FindItem(AstToken) Method
Returns the first found metadata item that matches the name defined by AST token identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItem( _
   ByVal name As AstToken _
) As T
'Usage

Dim instance As MetadataSelection(Of T)
Dim name As AstToken
Dim value As T

value = instance.FindItem(name)
public T FindItem(
   AstToken name
)
public: T* FindItem(
   AstToken* name
)

Parameters

name
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members
Overload List


FindItems Method (MetadataSelection<T>)

FindItems Method (MetadataSelection<T>)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class : FindItems Method
Returns the list of metadata items that match the string name.
Overload List
Overload | Description
FindItems(String) | Returns the list of metadata items that match the string name.
FindItems(AstToken) | Returns the list of metadata items that match the name defined by AST token identifier.
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members


FindItems(String) Method

FindItems(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class > FindItems Method : FindItems(String) Method
Returns the list of metadata items that match the string name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItems( _
   ByVal name As System.String _
) As System.Collections.Generic.IList(Of T)
'Usage

Dim instance As MetadataSelection(Of T)
Dim name As System.String
Dim value As System.Collections.Generic.IList(Of T)

value = instance.FindItems(name)
public System.Collections.Generic.IList<T> FindItems(
   System.string name
)
public: System.Collections.Generic.IList<T*>* FindItems(
   System.string* name
)

Parameters

name
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members
Overload List


FindItems(AstToken) Method

FindItems(AstToken) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class > FindItems Method : FindItems(AstToken) Method
Returns the list of metadata items that match the name defined by AST token identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindItems( _
   ByVal name As AstToken _
) As System.Collections.Generic.IList(Of T)
'Usage

Dim instance As MetadataSelection(Of T)
Dim name As AstToken
Dim value As System.Collections.Generic.IList(Of T)

value = instance.FindItems(name)
public System.Collections.Generic.IList<T> FindItems(
   AstToken name
)
public: System.Collections.Generic.IList<T*>* FindItems(
   AstToken* name
)

Parameters

name
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members
Overload List


GetDefaultItems Method (MetadataSelection<T>)

GetDefaultItems Method (MetadataSelection<T>)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class : GetDefaultItems Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetDefaultItems() As System.Collections.Generic.List(Of T)
'Usage

Dim instance As MetadataSelection(Of T)
Dim value As System.Collections.Generic.List(Of T)

value = instance.GetDefaultItems()
public System.Collections.Generic.List<T> GetDefaultItems()
public: System.Collections.Generic.List<T*>* GetDefaultItems();
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members


GetItems Method (MetadataSelection<T>)

GetItems Method (MetadataSelection<T>)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class : GetItems Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetItems() As System.Collections.Generic.List(Of T)
'Usage

Dim instance As MetadataSelection(Of T)
Dim value As System.Collections.Generic.List(Of T)

value = instance.GetItems()
public System.Collections.Generic.List<T> GetItems()
public: System.Collections.Generic.List<T*>* GetItems();
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members


IsLoaded Method (MetadataSelection<T>)

IsLoaded Method (MetadataSelection<T>)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class : IsLoaded Method
Indicates if the types of metadata items sprcified in constructor have been loaded to the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function IsLoaded() As System.Boolean
'Usage

Dim instance As MetadataSelection(Of T)
Dim value As System.Boolean

value = instance.IsLoaded()
public System.bool IsLoaded()
public: System.bool IsLoaded();
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members


Load Method (MetadataSelection<T>)

Load Method (MetadataSelection<T>)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class : Load Method
Loads types of metadata items specified in constructor to the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Load()
'Usage

Dim instance As MetadataSelection(Of T)

instance.Load()
public void Load()
public: void Load();
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members


Remove Method (MetadataSelection<T>)

Remove Method (MetadataSelection<T>)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class : Remove Method
Removes metadata item from the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function Remove( _
   ByVal item As T _
) As System.Boolean
'Usage

Dim instance As MetadataSelection(Of T)
Dim item As T
Dim value As System.Boolean

value = instance.Remove(item)
public System.bool Remove(
   T item
)
public: System.bool Remove(
   T* item
)

Parameters

item
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members


MetadataSelection<T> Class Properties

MetadataSelection<T> Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataSelection<T> Class

For a list of all members of this type, see MetadataSelection<T> members.

Public Properties
 | Name | Description
Public Property | Count | Gets number of items in selection.
Public Property | IsReadOnly | Indicates that selection can not be modified.
Top
See Also

Reference

MetadataSelection<T> Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Count Property (MetadataSelection<T>)

Count Property (MetadataSelection<T>)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class : Count Property
Gets number of items in selection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Count As System.Integer
'Usage

Dim instance As MetadataSelection(Of T)
Dim value As System.Integer

value = instance.Count
public System.int Count {get;}
public: __property System.int get_Count();
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members


IsReadOnly Property (MetadataSelection<T>)

IsReadOnly Property (MetadataSelection<T>)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSelection<T> Class : IsReadOnly Property
Indicates that selection can not be modified.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property IsReadOnly As System.Boolean
'Usage

Dim instance As MetadataSelection(Of T)
Dim value As System.Boolean

value = instance.IsReadOnly
public System.bool IsReadOnly {get;}
public: __property System.bool get_IsReadOnly();
Remarks
Not used in implementation.
Requirements

See Also

Reference

MetadataSelection<T> Class
MetadataSelection<T> Members


MetadataSimpleFilter Class

MetadataSimpleFilter Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataSimpleFilter Class
Determines sets of masks for database object and schema names to be included to or excluded from loading to the Metadata Container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MetadataSimpleFilter
   Inherits UpdatablePersistent
'Usage

Dim instance As MetadataSimpleFilter
public class MetadataSimpleFilter : UpdatablePersistent
public __gc class MetadataSimpleFilter : public UpdatablePersistent
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataSimpleFilter

Requirements

See Also

Reference

MetadataSimpleFilter Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
ExcludeFilter Property
IncludeFilter Property


MetadataSimpleFilter Class Members

MetadataSimpleFilter Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataSimpleFilter Class

The following tables list the members exposed by MetadataSimpleFilter.

Public Properties
 | Name | Description
Public Property | Objects | Holds the list of masks for database object names.
Public Property | Schemas | Holds the list of masks for database schema names.
Public Property | Types | Defines set of database object types to filter.
Top
See Also

Reference

MetadataSimpleFilter Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
ExcludeFilter Property
IncludeFilter Property


MetadataSimpleFilter Class Properties

MetadataSimpleFilter Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataSimpleFilter Class

For a list of all members of this type, see MetadataSimpleFilter members.

Public Properties
 | Name | Description
Public Property | Objects | Holds the list of masks for database object names.
Public Property | Schemas | Holds the list of masks for database schema names.
Public Property | Types | Defines set of database object types to filter.
Top
See Also

Reference

MetadataSimpleFilter Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
ExcludeFilter Property
IncludeFilter Property


Objects Property (MetadataSimpleFilter)

Objects Property (MetadataSimpleFilter)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSimpleFilter Class : Objects Property
Holds the list of masks for database object names.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Objects As StringList
'Usage

Dim instance As MetadataSimpleFilter
Dim value As StringList

instance.Objects = value

value = instance.Objects
public StringList Objects {get; set;}
public: __property StringList* get_Objects();
public: __property void set_Objects(
   StringList* value
);
Remarks
Masks act similar to the "LIKE" SQL operator. Use the percent sign (%) to represent any sequence of characters; use the underscore sign (_) to represent any single character.
Requirements

See Also

Reference

MetadataSimpleFilter Class
MetadataSimpleFilter Members


Schemas Property (MetadataSimpleFilter)

Schemas Property (MetadataSimpleFilter)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSimpleFilter Class : Schemas Property
Holds the list of masks for database schema names.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Schemas As StringList
'Usage

Dim instance As MetadataSimpleFilter
Dim value As StringList

instance.Schemas = value

value = instance.Schemas
public StringList Schemas {get; set;}
public: __property StringList* get_Schemas();
public: __property void set_Schemas(
   StringList* value
);
Remarks
Masks act similar to the "LIKE" SQL operator. Use the percent sign (%) to represent any sequence of characters; use the underscore sign (_) to represent any single character.
Requirements

See Also

Reference

MetadataSimpleFilter Class
MetadataSimpleFilter Members


Types Property

Types Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataSimpleFilter Class : Types Property
Defines set of database object types to filter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Types As MetadataType
'Usage

Dim instance As MetadataSimpleFilter
Dim value As MetadataType

instance.Types = value

value = instance.Types
public MetadataType Types {get; set;}
public: __property MetadataType get_Types();
public: __property void set_Types(
   MetadataType value
);
Requirements

See Also

Reference

MetadataSimpleFilter Class
MetadataSimpleFilter Members


MetadataStructure Class

MetadataStructure Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataStructure Class
Complex object that determines the tree-like structure to group metadata objects within the Database Schema Tree. Root object of the structure.
Object Model
MetadataStructure ClassMetadataStructureOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MetadataStructure
   Inherits MetadataStructureItem
'Usage

Dim instance As MetadataStructure
public class MetadataStructure : MetadataStructureItem
public __gc class MetadataStructure : public MetadataStructureItem
Remarks
See the MetadataStructureItem description for details.
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataStructureItem
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataStructure

Requirements

See Also

Reference

MetadataStructure Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataStructure Class Members

MetadataStructure Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataStructure Class

The following tables list the members exposed by MetadataStructure.

Public Properties
 | Name | Description
Public Property | Options | Set of options of the metadata structure.
Public Property | XML | Gets or sets the content of Metadata Container as string in a form of XML document.
Top
Public Methods
 | Name | Description
Public Method | ExportToXML | Overloaded. Saves the content of Metadata Structure to file in a form of XML document.
Public Method | ImportFromXML | Overloaded. Loads the content of Metadata Structure from file in a form of XML document.
Top
Public Events
 | Name | Description
Public Event | ItemAdded | Fired when new item is added to the structure.
Public Event | ItemBinding | Fired when the item is about to be bound to a metadata item.
Public Event | ItemBound | Fired when the item is bound to a metadata item.
Public Event | ItemRemoving | Fired when the item is about to be removed from the structure.
Public Event | ItemUnbinding | Fired when the item is about to be unbound from a metadata item.
Public Event | ItemUnbound | Fired when the item is unbound from a metadata item.
Public Event | ItemUpdated | Fired when the item updates some of it's properties.
Public Event | ItemUpdateEnded | Fired when the item ends updating it's properties.
Public Event | ItemUpdateStarted | Fired when the item begins updating it's properties.
Top
See Also

Reference

MetadataStructure Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataStructure Class Methods

MetadataStructure Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataStructure Class

For a list of all members of this type, see MetadataStructure members.

Public Methods
 | Name | Description
Public Method | ExportToXML | Overloaded. Saves the content of Metadata Structure to file in a form of XML document.
Public Method | ImportFromXML | Overloaded. Loads the content of Metadata Structure from file in a form of XML document.
Top
See Also

Reference

MetadataStructure Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


ExportToXML Method (MetadataStructure)

ExportToXML Method (MetadataStructure)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructure Class : ExportToXML Method
Saves the content of Metadata Structure to file in a form of XML document.
Overload List
Overload | Description
ExportToXML(String) | Saves the content of Metadata Structure to file in a form of XML document.
ExportToXML(Stream) | Saves the content of Metadata Structure to stream in a form of XML document.
Requirements

See Also

Reference

MetadataStructure Class
MetadataStructure Members


ExportToXML(String) Method

ExportToXML(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructure Class > ExportToXML Method : ExportToXML(String) Method
Saves the content of Metadata Structure to file in a form of XML document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub ExportToXML( _
   ByVal fileName As System.String _
)
'Usage

Dim instance As MetadataStructure
Dim fileName As System.String

instance.ExportToXML(fileName)
public void ExportToXML(
   System.string fileName
)
public: void ExportToXML(
   System.string* fileName
)

Parameters

fileName
Requirements

See Also

Reference

MetadataStructure Class
MetadataStructure Members
Overload List


ExportToXML(Stream) Method

ExportToXML(Stream) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructure Class > ExportToXML Method : ExportToXML(Stream) Method
Saves the content of Metadata Structure to stream in a form of XML document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub ExportToXML( _
   ByVal stream As System.IO.Stream _
)
'Usage

Dim instance As MetadataStructure
Dim stream As System.IO.Stream

instance.ExportToXML(stream)
public void ExportToXML(
   System.IO.Stream stream
)
public: void ExportToXML(
   System.IO.Stream* stream
)

Parameters

stream
Requirements

See Also

Reference

MetadataStructure Class
MetadataStructure Members
Overload List


ImportFromXML Method (MetadataStructure)

ImportFromXML Method (MetadataStructure)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructure Class : ImportFromXML Method
Loads the content of Metadata Structure from file in a form of XML document.
Overload List
Overload | Description
ImportFromXML(String) | Loads the content of Metadata Structure from file in a form of XML document.
ImportFromXML(Stream) | Loads the content of Metadata Structure from stream in a form of XML document.
Requirements

See Also

Reference

MetadataStructure Class
MetadataStructure Members


ImportFromXML(String) Method

ImportFromXML(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructure Class > ImportFromXML Method : ImportFromXML(String) Method
Loads the content of Metadata Structure from file in a form of XML document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub ImportFromXML( _
   ByVal fileName As System.String _
)
'Usage

Dim instance As MetadataStructure
Dim fileName As System.String

instance.ImportFromXML(fileName)
public void ImportFromXML(
   System.string fileName
)
public: void ImportFromXML(
   System.string* fileName
)

Parameters

fileName
Requirements

See Also

Reference

MetadataStructure Class
MetadataStructure Members
Overload List


ImportFromXML(Stream) Method

ImportFromXML(Stream) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructure Class > ImportFromXML Method : ImportFromXML(Stream) Method
Loads the content of Metadata Structure from stream in a form of XML document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub ImportFromXML( _
   ByVal stream As System.IO.Stream _
)
'Usage

Dim instance As MetadataStructure
Dim stream As System.IO.Stream

instance.ImportFromXML(stream)
public void ImportFromXML(
   System.IO.Stream stream
)
public: void ImportFromXML(
   System.IO.Stream* stream
)

Parameters

stream
Requirements

See Also

Reference

MetadataStructure Class
MetadataStructure Members
Overload List


MetadataStructure Class Properties

MetadataStructure Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataStructure Class

For a list of all members of this type, see MetadataStructure members.

Public Properties
 | Name | Description
Public Property | Options | Set of options of the metadata structure.
Public Property | XML | Gets or sets the content of Metadata Container as string in a form of XML document.
Top
See Also

Reference

MetadataStructure Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Options Property

Options Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructure Class : Options Property
Set of options of the metadata structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Options As MetadataStructureOptions
'Usage

Dim instance As MetadataStructure
Dim value As MetadataStructureOptions

instance.Options = value

value = instance.Options
public MetadataStructureOptions Options {get; set;}
public: __property MetadataStructureOptions* get_Options();
public: __property void set_Options(
   MetadataStructureOptions* value
);
Requirements

See Also

Reference

MetadataStructure Class
MetadataStructure Members


XML Property (MetadataStructure)

XML Property (MetadataStructure)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructure Class : XML Property
Gets or sets the content of Metadata Container as string in a form of XML document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property XML As System.String
'Usage

Dim instance As MetadataStructure
Dim value As System.String

instance.XML = value

value = instance.XML
public System.string XML {get; set;}
public: __property System.string* get_XML();
public: __property void set_XML(
   System.string* value
);
Requirements

See Also

Reference

MetadataStructure Class
MetadataStructure Members


MetadataStructure Class Events

MetadataStructure Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataStructure Class

For a list of all members of this type, see MetadataStructure members.

Public Events
 | Name | Description
Public Event | ItemAdded | Fired when new item is added to the structure.
Public Event | ItemBinding | Fired when the item is about to be bound to a metadata item.
Public Event | ItemBound | Fired when the item is bound to a metadata item.
Public Event | ItemRemoving | Fired when the item is about to be removed from the structure.
Public Event | ItemUnbinding | Fired when the item is about to be unbound from a metadata item.
Public Event | ItemUnbound | Fired when the item is unbound from a metadata item.
Public Event | ItemUpdated | Fired when the item updates some of it's properties.
Public Event | ItemUpdateEnded | Fired when the item ends updating it's properties.
Public Event | ItemUpdateStarted | Fired when the item begins updating it's properties.
Top
See Also

Reference

MetadataStructure Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


ItemAdded Event

ItemAdded Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructure Class : ItemAdded Event
Fired when new item is added to the structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ItemAdded As MetadataStructureItemNotification
'Usage

Dim instance As MetadataStructure
Dim handler As MetadataStructureItemNotification

AddHandler instance.ItemAdded, handler
public event MetadataStructureItemNotification ItemAdded
public: __event MetadataStructureItemNotification* ItemAdded
Requirements

See Also

Reference

MetadataStructure Class
MetadataStructure Members


ItemBinding Event

ItemBinding Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructure Class : ItemBinding Event
Fired when the item is about to be bound to a metadata item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ItemBinding As MetadataStructureItemNotification
'Usage

Dim instance As MetadataStructure
Dim handler As MetadataStructureItemNotification

AddHandler instance.ItemBinding, handler
public event MetadataStructureItemNotification ItemBinding
public: __event MetadataStructureItemNotification* ItemBinding
Requirements

See Also

Reference

MetadataStructure Class
MetadataStructure Members


ItemBound Event

ItemBound Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructure Class : ItemBound Event
Fired when the item is bound to a metadata item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ItemBound As MetadataStructureItemNotification
'Usage

Dim instance As MetadataStructure
Dim handler As MetadataStructureItemNotification

AddHandler instance.ItemBound, handler
public event MetadataStructureItemNotification ItemBound
public: __event MetadataStructureItemNotification* ItemBound
Requirements

See Also

Reference

MetadataStructure Class
MetadataStructure Members


ItemRemoving Event

ItemRemoving Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructure Class : ItemRemoving Event
Fired when the item is about to be removed from the structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ItemRemoving As MetadataStructureItemNotification
'Usage

Dim instance As MetadataStructure
Dim handler As MetadataStructureItemNotification

AddHandler instance.ItemRemoving, handler
public event MetadataStructureItemNotification ItemRemoving
public: __event MetadataStructureItemNotification* ItemRemoving
Requirements

See Also

Reference

MetadataStructure Class
MetadataStructure Members


ItemUnbinding Event

ItemUnbinding Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructure Class : ItemUnbinding Event
Fired when the item is about to be unbound from a metadata item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ItemUnbinding As MetadataStructureItemNotification
'Usage

Dim instance As MetadataStructure
Dim handler As MetadataStructureItemNotification

AddHandler instance.ItemUnbinding, handler
public event MetadataStructureItemNotification ItemUnbinding
public: __event MetadataStructureItemNotification* ItemUnbinding
Requirements

See Also

Reference

MetadataStructure Class
MetadataStructure Members


ItemUnbound Event

ItemUnbound Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructure Class : ItemUnbound Event
Fired when the item is unbound from a metadata item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ItemUnbound As MetadataStructureItemNotification
'Usage

Dim instance As MetadataStructure
Dim handler As MetadataStructureItemNotification

AddHandler instance.ItemUnbound, handler
public event MetadataStructureItemNotification ItemUnbound
public: __event MetadataStructureItemNotification* ItemUnbound
Requirements

See Also

Reference

MetadataStructure Class
MetadataStructure Members


ItemUpdated Event

ItemUpdated Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructure Class : ItemUpdated Event
Fired when the item updates some of it's properties.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ItemUpdated As MetadataStructureItemNotification
'Usage

Dim instance As MetadataStructure
Dim handler As MetadataStructureItemNotification

AddHandler instance.ItemUpdated, handler
public event MetadataStructureItemNotification ItemUpdated
public: __event MetadataStructureItemNotification* ItemUpdated
Remarks
Use the ItemUpdateStarted and the ItemUpdateEnded events to avoid handling of the ItemUpdated event multiple times.
Requirements

See Also

Reference

MetadataStructure Class
MetadataStructure Members


ItemUpdateEnded Event

ItemUpdateEnded Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructure Class : ItemUpdateEnded Event
Fired when the item ends updating it's properties.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ItemUpdateEnded As MetadataStructureItemNotification
'Usage

Dim instance As MetadataStructure
Dim handler As MetadataStructureItemNotification

AddHandler instance.ItemUpdateEnded, handler
public event MetadataStructureItemNotification ItemUpdateEnded
public: __event MetadataStructureItemNotification* ItemUpdateEnded
Requirements

See Also

Reference

MetadataStructure Class
MetadataStructure Members


ItemUpdateStarted Event

ItemUpdateStarted Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructure Class : ItemUpdateStarted Event
Fired when the item begins updating it's properties.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ItemUpdateStarted As MetadataStructureItemNotification
'Usage

Dim instance As MetadataStructure
Dim handler As MetadataStructureItemNotification

AddHandler instance.ItemUpdateStarted, handler
public event MetadataStructureItemNotification ItemUpdateStarted
public: __event MetadataStructureItemNotification* ItemUpdateStarted
Requirements

See Also

Reference

MetadataStructure Class
MetadataStructure Members


MetadataStructureItem Class

MetadataStructureItem Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataStructureItem Class
Represents a node in the metadata structure.
Object Model
MetadataStructureItem ClassMetadataFilter ClassMetadataItem ClassMetadataStructureItem ClassMetadataItem ClassMetadataStructure Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MetadataStructureItem
   Inherits BatchUpdatableBase
'Usage

Dim instance As MetadataStructureItem
public class MetadataStructureItem : BatchUpdatableBase
public __gc class MetadataStructureItem : public BatchUpdatableBase
Remarks

Each item in the metadata structure can be bound to the metadata item to represent it in the structure or it can be a folder that groups other items by specific feature, for example, according to the subject area. Metadata item to bind to this structure item is defined in the MetadataName property.

Metadata items are bound to structure items on calling the parent's LoadChildItems method and unbound on calling the parent's UnloadChildItems method. Binding is performed by finding in the Metadata Container a corresponding to the MetadataName property metadata item and assigning it to the MetadataItem property.

In order to customize the structure, the user may define some structure items beforehand ("static" items). The underlying items may be created in two ways:

1) Automatically according to the MetadataName property. Automatic items creation is performed in accordance with the physical database schema. This means that if you've defined a static node and specified the schema name in the MetadataName property, the child items of this node will be database objects of this schema. If you've defined a table name in the MetadataName, the child items will be fields of this table (if their creation is allowed by the MetadataStructureOptions.ShowFields property), etc. You may deny automatic creation of child nodes by setting the AllowChildAutoItems property to false.

2) Dynamically according to the set of metadata filtration rules defined by the MetadataFilter property.

Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataStructureItem
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataStructure

Requirements

See Also

Reference

MetadataStructureItem Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataStructureItem Class Members

MetadataStructureItem Class Members
Properties Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataStructureItem Class

The following tables list the members exposed by MetadataStructureItem.

Public Properties
 | Name | Description
Public Property | AllowChildAutoItems | Allows to create child structure items automatically according to the physical database schema or not.
Public Property | Caption | Gets or sets the caption text that will represent this item in the database structure tree.
Public Property | ImageIndex | Gets or sets the index of image that will be assigned
Public Property | IsBound | Indicates if metadata item is bound to this structure item.
Public Property | IsChildItemsLoaded | Indicates if child structure items are loaded (created and bound).
Public Property | IsDynamic | Indicates if item was created dynamically or it's a static item that was defined beforehand.
Public Property | Items | Gets list of child metadata structure items.
Public Property | MetadataFilter | Defines a set of metadata filtration rules to select metadata items for adding them as child structure items.
Public Property | MetadataItem | Gets or sets the reference to the Metadata Item object.
Public Property | MetadataName | Defines the name of a corresponding metadata object to map metadata item to this structure item.
Public Property | Parent | Gets reference to the parent metadata structure item.
Public Property | ParentMetadataItem | Gets reference to the metadata item assigned to the parent metadata structure item.
Public Property | Structure | Gets reference to the Metadata Structure object, i.e. the root node of the structure.
Top
Public Methods
 | Name | Description
Public Method | GetAllItems | Overloaded. Returns the list of Metadata Structure Items in the underlying hierarchy.
Public Method | GetAllMetadataItems | Overloaded. Returns the list of all Metadata Items from the underlying hierarchy of Metadata Structure Items.
Public Method | LoadChildItems | Creates dynamic child structure items and binds all child structure items to appropriate metadata items.
Public Method | UnloadChildItems | Unbinds static child structure items from metadata items and removes dynamic child structure items.
Top
See Also

Reference

MetadataStructureItem Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataStructureItem Class Methods

MetadataStructureItem Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataStructureItem Class

For a list of all members of this type, see MetadataStructureItem members.

Public Methods
 | Name | Description
Public Method | GetAllItems | Overloaded. Returns the list of Metadata Structure Items in the underlying hierarchy.
Public Method | GetAllMetadataItems | Overloaded. Returns the list of all Metadata Items from the underlying hierarchy of Metadata Structure Items.
Public Method | LoadChildItems | Creates dynamic child structure items and binds all child structure items to appropriate metadata items.
Public Method | UnloadChildItems | Unbinds static child structure items from metadata items and removes dynamic child structure items.
Top
See Also

Reference

MetadataStructureItem Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


GetAllItems Method

GetAllItems Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureItem Class : GetAllItems Method
Returns the list of Metadata Structure Items in the underlying hierarchy.
Overload List
Overload | Description
GetAllItems() | Returns the list of Metadata Structure Items in the underlying hierarchy.
GetAllItems(MetadataType) | Returns the list of Metadata Structure Items of the specified type in the underlying hierarchy.
Requirements

See Also

Reference

MetadataStructureItem Class
MetadataStructureItem Members


GetAllItems() Method

GetAllItems() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureItem Class > GetAllItems Method : GetAllItems() Method
Returns the list of Metadata Structure Items in the underlying hierarchy.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetAllItems() As System.Collections.Generic.List(Of MetadataStructureItem)
'Usage

Dim instance As MetadataStructureItem
Dim value As System.Collections.Generic.List(Of MetadataStructureItem)

value = instance.GetAllItems()
public System.Collections.Generic.List<MetadataStructureItem> GetAllItems()
public: System.Collections.Generic.List<MetadataStructureItem*>* GetAllItems();
Remarks
Execution of this method in online mode may take a long time as it will require complete loading of the underlying Metadata Structure tree among with retrieval of the corresponding Metadata Items from database.
Requirements

See Also

Reference

MetadataStructureItem Class
MetadataStructureItem Members
Overload List


GetAllItems(MetadataType) Method

GetAllItems(MetadataType) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureItem Class > GetAllItems Method : GetAllItems(MetadataType) Method
Returns the list of Metadata Structure Items of the specified type in the underlying hierarchy.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetAllItems( _
   ByVal type As MetadataType _
) As System.Collections.Generic.List(Of MetadataStructureItem)
'Usage

Dim instance As MetadataStructureItem
Dim type As MetadataType
Dim value As System.Collections.Generic.List(Of MetadataStructureItem)

value = instance.GetAllItems(type)
public System.Collections.Generic.List<MetadataStructureItem> GetAllItems(
   MetadataType type
)
public: System.Collections.Generic.List<MetadataStructureItem*>* GetAllItems(
   MetadataType type
)

Parameters

type
Remarks
Execution of this method in online mode may take a long time as it will require complete loading of the underlying Metadata Structure tree among with retrieval of the corresponding Metadata Items from database.
Requirements

See Also

Reference

MetadataStructureItem Class
MetadataStructureItem Members
Overload List


GetAllMetadataItems Method

GetAllMetadataItems Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureItem Class : GetAllMetadataItems Method
Returns the list of all Metadata Items from the underlying hierarchy of Metadata Structure Items.
Overload List
Overload | Description
GetAllMetadataItems() | Returns the list of all Metadata Items from the underlying hierarchy of Metadata Structure Items.
GetAllMetadataItems(MetadataType) | Returns the list of all child Metadata Items of the specified type from the underlying hierarchy of Metadata Structure Items.
Requirements

See Also

Reference

MetadataStructureItem Class
MetadataStructureItem Members


GetAllMetadataItems() Method

GetAllMetadataItems() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureItem Class > GetAllMetadataItems Method : GetAllMetadataItems() Method
Returns the list of all Metadata Items from the underlying hierarchy of Metadata Structure Items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetAllMetadataItems() As System.Collections.Generic.List(Of MetadataItem)
'Usage

Dim instance As MetadataStructureItem
Dim value As System.Collections.Generic.List(Of MetadataItem)

value = instance.GetAllMetadataItems()
public System.Collections.Generic.List<MetadataItem> GetAllMetadataItems()
public: System.Collections.Generic.List<MetadataItem*>* GetAllMetadataItems();
Remarks
Execution of this method in online mode may take a long time as it will require complete loading of the underlying Metadata Structure tree among with retrieval of the corresponding Metadata Items from database.
Requirements

See Also

Reference

MetadataStructureItem Class
MetadataStructureItem Members
Overload List


GetAllMetadataItems(MetadataType) Method

GetAllMetadataItems(MetadataType) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureItem Class > GetAllMetadataItems Method : GetAllMetadataItems(MetadataType) Method
Returns the list of all child Metadata Items of the specified type from the underlying hierarchy of Metadata Structure Items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetAllMetadataItems( _
   ByVal type As MetadataType _
) As System.Collections.Generic.List(Of MetadataItem)
'Usage

Dim instance As MetadataStructureItem
Dim type As MetadataType
Dim value As System.Collections.Generic.List(Of MetadataItem)

value = instance.GetAllMetadataItems(type)
public System.Collections.Generic.List<MetadataItem> GetAllMetadataItems(
   MetadataType type
)
public: System.Collections.Generic.List<MetadataItem*>* GetAllMetadataItems(
   MetadataType type
)

Parameters

type
Remarks
Execution of this method in online mode may take a long time as it will require complete loading of the underlying Metadata Structure tree among with retrieval of the corresponding Metadata Items from database.
Requirements

See Also

Reference

MetadataStructureItem Class
MetadataStructureItem Members
Overload List


LoadChildItems Method

LoadChildItems Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureItem Class : LoadChildItems Method
Creates dynamic child structure items and binds all child structure items to appropriate metadata items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub LoadChildItems()
'Usage

Dim instance As MetadataStructureItem

instance.LoadChildItems()
public void LoadChildItems()
public: void LoadChildItems();
Requirements

See Also

Reference

MetadataStructureItem Class
MetadataStructureItem Members


UnloadChildItems Method

UnloadChildItems Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureItem Class : UnloadChildItems Method
Unbinds static child structure items from metadata items and removes dynamic child structure items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub UnloadChildItems()
'Usage

Dim instance As MetadataStructureItem

instance.UnloadChildItems()
public void UnloadChildItems()
public: void UnloadChildItems();
Requirements

See Also

Reference

MetadataStructureItem Class
MetadataStructureItem Members


MetadataStructureItem Class Properties

MetadataStructureItem Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataStructureItem Class

For a list of all members of this type, see MetadataStructureItem members.

Public Properties
 | Name | Description
Public Property | AllowChildAutoItems | Allows to create child structure items automatically according to the physical database schema or not.
Public Property | Caption | Gets or sets the caption text that will represent this item in the database structure tree.
Public Property | ImageIndex | Gets or sets the index of image that will be assigned
Public Property | IsBound | Indicates if metadata item is bound to this structure item.
Public Property | IsChildItemsLoaded | Indicates if child structure items are loaded (created and bound).
Public Property | IsDynamic | Indicates if item was created dynamically or it's a static item that was defined beforehand.
Public Property | Items | Gets list of child metadata structure items.
Public Property | MetadataFilter | Defines a set of metadata filtration rules to select metadata items for adding them as child structure items.
Public Property | MetadataItem | Gets or sets the reference to the Metadata Item object.
Public Property | MetadataName | Defines the name of a corresponding metadata object to map metadata item to this structure item.
Public Property | Parent | Gets reference to the parent metadata structure item.
Public Property | ParentMetadataItem | Gets reference to the metadata item assigned to the parent metadata structure item.
Public Property | Structure | Gets reference to the Metadata Structure object, i.e. the root node of the structure.
Top
See Also

Reference

MetadataStructureItem Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AllowChildAutoItems Property

AllowChildAutoItems Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureItem Class : AllowChildAutoItems Property
Allows to create child structure items automatically according to the physical database schema or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AllowChildAutoItems As System.Boolean
'Usage

Dim instance As MetadataStructureItem
Dim value As System.Boolean

instance.AllowChildAutoItems = value

value = instance.AllowChildAutoItems
public System.bool AllowChildAutoItems {get; set;}
public: __property System.bool get_AllowChildAutoItems();
public: __property void set_AllowChildAutoItems(
   System.bool value
);
Requirements

See Also

Reference

MetadataStructureItem Class
MetadataStructureItem Members


Caption Property

Caption Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureItem Class : Caption Property
Gets or sets the caption text that will represent this item in the database structure tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Caption As System.String
'Usage

Dim instance As MetadataStructureItem
Dim value As System.String

instance.Caption = value

value = instance.Caption
public System.string Caption {get; set;}
public: __property System.string* get_Caption();
public: __property void set_Caption(
   System.string* value
);
Requirements

See Also

Reference

MetadataStructureItem Class
MetadataStructureItem Members


ImageIndex Property

ImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureItem Class : ImageIndex Property
Gets or sets the index of image that will be assigned
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ImageIndex As System.Integer
'Usage

Dim instance As MetadataStructureItem
Dim value As System.Integer

instance.ImageIndex = value

value = instance.ImageIndex
public System.int ImageIndex {get; set;}
public: __property System.int get_ImageIndex();
public: __property void set_ImageIndex(
   System.int value
);
Requirements

See Also

Reference

MetadataStructureItem Class
MetadataStructureItem Members


IsBound Property

IsBound Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureItem Class : IsBound Property
Indicates if metadata item is bound to this structure item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property IsBound As System.Boolean
'Usage

Dim instance As MetadataStructureItem
Dim value As System.Boolean

value = instance.IsBound
public System.bool IsBound {get;}
public: __property System.bool get_IsBound();
Remarks

Requirements

See Also

Reference

MetadataStructureItem Class
MetadataStructureItem Members


IsChildItemsLoaded Property

IsChildItemsLoaded Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureItem Class : IsChildItemsLoaded Property
Indicates if child structure items are loaded (created and bound).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property IsChildItemsLoaded As System.Boolean
'Usage

Dim instance As MetadataStructureItem
Dim value As System.Boolean

value = instance.IsChildItemsLoaded
public System.bool IsChildItemsLoaded {get;}
public: __property System.bool get_IsChildItemsLoaded();
Requirements

See Also

Reference

MetadataStructureItem Class
MetadataStructureItem Members


IsDynamic Property

IsDynamic Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureItem Class : IsDynamic Property
Indicates if item was created dynamically or it's a static item that was defined beforehand.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property IsDynamic As System.Boolean
'Usage

Dim instance As MetadataStructureItem
Dim value As System.Boolean

value = instance.IsDynamic
public System.bool IsDynamic {get;}
public: __property System.bool get_IsDynamic();
Requirements

See Also

Reference

MetadataStructureItem Class
MetadataStructureItem Members


Items Property (MetadataStructureItem)

Items Property (MetadataStructureItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureItem Class : Items Property
Gets list of child metadata structure items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Items As UpdatableObjectList(Of MetadataStructureItem)
'Usage

Dim instance As MetadataStructureItem
Dim value As UpdatableObjectList(Of MetadataStructureItem)

value = instance.Items
public UpdatableObjectList<MetadataStructureItem> Items {get;}
public: __property UpdatableObjectList<MetadataStructureItem*>* get_Items();
Requirements

See Also

Reference

MetadataStructureItem Class
MetadataStructureItem Members


MetadataFilter Property (MetadataStructureItem)

MetadataFilter Property (MetadataStructureItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureItem Class : MetadataFilter Property
Defines a set of metadata filtration rules to select metadata items for adding them as child structure items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property MetadataFilter As MetadataFilter
'Usage

Dim instance As MetadataStructureItem
Dim value As MetadataFilter

instance.MetadataFilter = value

value = instance.MetadataFilter
public MetadataFilter MetadataFilter {get; set;}
public: __property MetadataFilter* get_MetadataFilter();
public: __property void set_MetadataFilter(
   MetadataFilter* value
);
Requirements

See Also

Reference

MetadataStructureItem Class
MetadataStructureItem Members


MetadataItem Property

MetadataItem Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureItem Class : MetadataItem Property
Gets or sets the reference to the Metadata Item object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property MetadataItem As MetadataItem
'Usage

Dim instance As MetadataStructureItem
Dim value As MetadataItem

instance.MetadataItem = value

value = instance.MetadataItem
public MetadataItem MetadataItem {get; set;}
public: __property MetadataItem* get_MetadataItem();
public: __property void set_MetadataItem(
   MetadataItem* value
);
Requirements

See Also

Reference

MetadataStructureItem Class
MetadataStructureItem Members


MetadataName Property

MetadataName Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureItem Class : MetadataName Property
Defines the name of a corresponding metadata object to map metadata item to this structure item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property MetadataName As System.String
'Usage

Dim instance As MetadataStructureItem
Dim value As System.String

instance.MetadataName = value

value = instance.MetadataName
public System.string MetadataName {get; set;}
public: __property System.string* get_MetadataName();
public: __property void set_MetadataName(
   System.string* value
);
Requirements

See Also

Reference

MetadataStructureItem Class
MetadataStructureItem Members


Parent Property (MetadataStructureItem)

Parent Property (MetadataStructureItem)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureItem Class : Parent Property
Gets reference to the parent metadata structure item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Parent As MetadataStructureItem
'Usage

Dim instance As MetadataStructureItem
Dim value As MetadataStructureItem

value = instance.Parent
public MetadataStructureItem Parent {get;}
public: __property MetadataStructureItem* get_Parent();
Requirements

See Also

Reference

MetadataStructureItem Class
MetadataStructureItem Members


ParentMetadataItem Property

ParentMetadataItem Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureItem Class : ParentMetadataItem Property
Gets reference to the metadata item assigned to the parent metadata structure item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ParentMetadataItem As MetadataItem
'Usage

Dim instance As MetadataStructureItem
Dim value As MetadataItem

value = instance.ParentMetadataItem
public MetadataItem ParentMetadataItem {get;}
public: __property MetadataItem* get_ParentMetadataItem();
Requirements

See Also

Reference

MetadataStructureItem Class
MetadataStructureItem Members


Structure Property

Structure Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureItem Class : Structure Property
Gets reference to the Metadata Structure object, i.e. the root node of the structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Structure As MetadataStructure
'Usage

Dim instance As MetadataStructureItem
Dim value As MetadataStructure

value = instance.Structure
public MetadataStructure Structure {get;}
public: __property MetadataStructure* get_Structure();
Requirements

See Also

Reference

MetadataStructureItem Class
MetadataStructureItem Members


MetadataStructureOptions Class

MetadataStructureOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataStructureOptions Class
Contains various options that affect on displaying of the Metadata Structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MetadataStructureOptions
   Inherits BatchUpdatableBase
'Usage

Dim instance As MetadataStructureOptions
public class MetadataStructureOptions : BatchUpdatableBase
public __gc class MetadataStructureOptions : public BatchUpdatableBase
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataStructureOptions

Requirements

See Also

Reference

MetadataStructureOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataStructureOptions Class Members

MetadataStructureOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataStructureOptions Class

The following tables list the members exposed by MetadataStructureOptions.

Public Properties
 | Name | Description
Public Property | DatabaseImageIndex | Gets or sets the image list index value of the image displayed for database nodes.
Public Property | FieldImageIndex | Gets or sets the image list index value of the image displayed for field nodes.
Public Property | FolderImageIndex | Gets or sets the image list index value of the image displayed for namespace nodes (folders).
Public Property | ForeignKeyImageIndex | Gets or sets the image list index value of the image displayed for foreign key nodes.
Public Property | GroupByDatabases | Instructs to group database objects by databases or not.
Public Property | GroupBySchemas | Instructs to group database objects by schemas or not.
Public Property | GroupByServers | Instructs to group database objects by servers or not.
Public Property | GroupByTypes | Instructs to group database objects by types or not.
Public Property | ImageList | Gets or sets ImageList object used to display icons for the nodes of Database Schema Tree.
Public Property | PackageImageIndex | Gets or sets the image list index value of the image displayed for package nodes.
Public Property | ParameterImageIndex | Gets or sets the image list index value of the image displayed for procedure and function parameter nodes.
Public Property | PrimaryKeyImageIndex | Gets or sets the image list index value of the image displayed for primary key field nodes.
Public Property | ProceduresFolderText | Gets or sets the text displayed for the procedure and function grouping folders.
Public Property | SchemaImageIndex | Gets or sets the image list index value of the image displayed for schema nodes.
Public Property | ServerImageIndex | Gets or sets the image list index value of the image displayed for server nodes.
Public Property | ShowFields | Instructs the component to show fields of database objects in the tree.
Public Property | SynonymsFolderText | Gets or sets the text displayed for the synonym grouping folders.
Public Property | SystemProcedureImageIndex | Gets or sets the image list index value of the image displayed for system procedures and functions.
Public Property | SystemSynonymImageIndex | Gets or sets the image list index value of the image displayed for system synonyms.
Public Property | SystemTableImageIndex | Gets or sets the image list index value of the image displayed for system tables.
Public Property | SystemViewImageIndex | Gets or sets the image list index value of the image displayed for system views.
Public Property | TablesFolderText | Gets or sets the text displayed for the table grouping folders.
Public Property | UserProcedureImageIndex | Gets or sets the image list index value of the image displayed for user procedures and functions.
Public Property | UserSynonymImageIndex | Gets or sets the image list index value of the image displayed for user synonyms.
Public Property | UserTableImageIndex | Gets or sets the image list index value of the image displayed for user tables.
Public Property | UserViewImageIndex | Gets or sets the image list index value of the image displayed for user views.
Public Property | ViewsFolderText | Gets or sets the text displayed for the view grouping folders.
Top
See Also

Reference

MetadataStructureOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataStructureOptions Class Properties

MetadataStructureOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataStructureOptions Class

For a list of all members of this type, see MetadataStructureOptions members.

Public Properties
 | Name | Description
Public Property | DatabaseImageIndex | Gets or sets the image list index value of the image displayed for database nodes.
Public Property | FieldImageIndex | Gets or sets the image list index value of the image displayed for field nodes.
Public Property | FolderImageIndex | Gets or sets the image list index value of the image displayed for namespace nodes (folders).
Public Property | ForeignKeyImageIndex | Gets or sets the image list index value of the image displayed for foreign key nodes.
Public Property | GroupByDatabases | Instructs to group database objects by databases or not.
Public Property | GroupBySchemas | Instructs to group database objects by schemas or not.
Public Property | GroupByServers | Instructs to group database objects by servers or not.
Public Property | GroupByTypes | Instructs to group database objects by types or not.
Public Property | ImageList | Gets or sets ImageList object used to display icons for the nodes of Database Schema Tree.
Public Property | PackageImageIndex | Gets or sets the image list index value of the image displayed for package nodes.
Public Property | ParameterImageIndex | Gets or sets the image list index value of the image displayed for procedure and function parameter nodes.
Public Property | PrimaryKeyImageIndex | Gets or sets the image list index value of the image displayed for primary key field nodes.
Public Property | ProceduresFolderText | Gets or sets the text displayed for the procedure and function grouping folders.
Public Property | SchemaImageIndex | Gets or sets the image list index value of the image displayed for schema nodes.
Public Property | ServerImageIndex | Gets or sets the image list index value of the image displayed for server nodes.
Public Property | ShowFields | Instructs the component to show fields of database objects in the tree.
Public Property | SynonymsFolderText | Gets or sets the text displayed for the synonym grouping folders.
Public Property | SystemProcedureImageIndex | Gets or sets the image list index value of the image displayed for system procedures and functions.
Public Property | SystemSynonymImageIndex | Gets or sets the image list index value of the image displayed for system synonyms.
Public Property | SystemTableImageIndex | Gets or sets the image list index value of the image displayed for system tables.
Public Property | SystemViewImageIndex | Gets or sets the image list index value of the image displayed for system views.
Public Property | TablesFolderText | Gets or sets the text displayed for the table grouping folders.
Public Property | UserProcedureImageIndex | Gets or sets the image list index value of the image displayed for user procedures and functions.
Public Property | UserSynonymImageIndex | Gets or sets the image list index value of the image displayed for user synonyms.
Public Property | UserTableImageIndex | Gets or sets the image list index value of the image displayed for user tables.
Public Property | UserViewImageIndex | Gets or sets the image list index value of the image displayed for user views.
Public Property | ViewsFolderText | Gets or sets the text displayed for the view grouping folders.
Top
See Also

Reference

MetadataStructureOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


DatabaseImageIndex Property

DatabaseImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : DatabaseImageIndex Property
Gets or sets the image list index value of the image displayed for database nodes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DatabaseImageIndex As System.Integer
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Integer

instance.DatabaseImageIndex = value

value = instance.DatabaseImageIndex
public System.int DatabaseImageIndex {get; set;}
public: __property System.int get_DatabaseImageIndex();
public: __property void set_DatabaseImageIndex(
   System.int value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


FieldImageIndex Property

FieldImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : FieldImageIndex Property
Gets or sets the image list index value of the image displayed for field nodes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property FieldImageIndex As System.Integer
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Integer

instance.FieldImageIndex = value

value = instance.FieldImageIndex
public System.int FieldImageIndex {get; set;}
public: __property System.int get_FieldImageIndex();
public: __property void set_FieldImageIndex(
   System.int value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


FolderImageIndex Property

FolderImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : FolderImageIndex Property
Gets or sets the image list index value of the image displayed for namespace nodes (folders).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property FolderImageIndex As System.Integer
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Integer

instance.FolderImageIndex = value

value = instance.FolderImageIndex
public System.int FolderImageIndex {get; set;}
public: __property System.int get_FolderImageIndex();
public: __property void set_FolderImageIndex(
   System.int value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


ForeignKeyImageIndex Property

ForeignKeyImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : ForeignKeyImageIndex Property
Gets or sets the image list index value of the image displayed for foreign key nodes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ForeignKeyImageIndex As System.Integer
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Integer

instance.ForeignKeyImageIndex = value

value = instance.ForeignKeyImageIndex
public System.int ForeignKeyImageIndex {get; set;}
public: __property System.int get_ForeignKeyImageIndex();
public: __property void set_ForeignKeyImageIndex(
   System.int value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


GroupByDatabases Property

GroupByDatabases Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : GroupByDatabases Property
Instructs to group database objects by databases or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property GroupByDatabases As System.Boolean
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Boolean

instance.GroupByDatabases = value

value = instance.GroupByDatabases
public System.bool GroupByDatabases {get; set;}
public: __property System.bool get_GroupByDatabases();
public: __property void set_GroupByDatabases(
   System.bool value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


GroupBySchemas Property

GroupBySchemas Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : GroupBySchemas Property
Instructs to group database objects by schemas or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property GroupBySchemas As System.Boolean
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Boolean

instance.GroupBySchemas = value

value = instance.GroupBySchemas
public System.bool GroupBySchemas {get; set;}
public: __property System.bool get_GroupBySchemas();
public: __property void set_GroupBySchemas(
   System.bool value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


GroupByServers Property

GroupByServers Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : GroupByServers Property
Instructs to group database objects by servers or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property GroupByServers As System.Boolean
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Boolean

instance.GroupByServers = value

value = instance.GroupByServers
public System.bool GroupByServers {get; set;}
public: __property System.bool get_GroupByServers();
public: __property void set_GroupByServers(
   System.bool value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


GroupByTypes Property

GroupByTypes Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : GroupByTypes Property
Instructs to group database objects by types or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property GroupByTypes As System.Boolean
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Boolean

instance.GroupByTypes = value

value = instance.GroupByTypes
public System.bool GroupByTypes {get; set;}
public: __property System.bool get_GroupByTypes();
public: __property void set_GroupByTypes(
   System.bool value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


ImageList Property (MetadataStructureOptions)

ImageList Property (MetadataStructureOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : ImageList Property
Gets or sets ImageList object used to display icons for the nodes of Database Schema Tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ImageList As System.Windows.Forms.ImageList
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Windows.Forms.ImageList

instance.ImageList = value

value = instance.ImageList
public System.Windows.Forms.ImageList ImageList {get; set;}
public: __property System.Windows.Forms.ImageList* get_ImageList();
public: __property void set_ImageList(
   System.Windows.Forms.ImageList* value
);
Remarks

Please refer to the *ImageIndex properties to get or set icons of specific tree nodes.

There are tree properties for each type of database objects (Table, View, Synonym and Procedure). The User*ImageIndex determines the icon image index for ordinary (user) objects, the System*ImageIndex determines the icon image index for system objects; the *sFolderImageIndex determines the icon image index for grouping nodes of appropriate database object type.

Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


PackageImageIndex Property

PackageImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : PackageImageIndex Property
Gets or sets the image list index value of the image displayed for package nodes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property PackageImageIndex As System.Integer
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Integer

instance.PackageImageIndex = value

value = instance.PackageImageIndex
public System.int PackageImageIndex {get; set;}
public: __property System.int get_PackageImageIndex();
public: __property void set_PackageImageIndex(
   System.int value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


ParameterImageIndex Property

ParameterImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : ParameterImageIndex Property
Gets or sets the image list index value of the image displayed for procedure and function parameter nodes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ParameterImageIndex As System.Integer
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Integer

instance.ParameterImageIndex = value

value = instance.ParameterImageIndex
public System.int ParameterImageIndex {get; set;}
public: __property System.int get_ParameterImageIndex();
public: __property void set_ParameterImageIndex(
   System.int value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


PrimaryKeyImageIndex Property

PrimaryKeyImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : PrimaryKeyImageIndex Property
Gets or sets the image list index value of the image displayed for primary key field nodes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property PrimaryKeyImageIndex As System.Integer
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Integer

instance.PrimaryKeyImageIndex = value

value = instance.PrimaryKeyImageIndex
public System.int PrimaryKeyImageIndex {get; set;}
public: __property System.int get_PrimaryKeyImageIndex();
public: __property void set_PrimaryKeyImageIndex(
   System.int value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


ProceduresFolderText Property

ProceduresFolderText Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : ProceduresFolderText Property
Gets or sets the text displayed for the procedure and function grouping folders.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ProceduresFolderText As System.String
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.String

instance.ProceduresFolderText = value

value = instance.ProceduresFolderText
public System.string ProceduresFolderText {get; set;}
public: __property System.string* get_ProceduresFolderText();
public: __property void set_ProceduresFolderText(
   System.string* value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


SchemaImageIndex Property

SchemaImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : SchemaImageIndex Property
Gets or sets the image list index value of the image displayed for schema nodes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SchemaImageIndex As System.Integer
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Integer

instance.SchemaImageIndex = value

value = instance.SchemaImageIndex
public System.int SchemaImageIndex {get; set;}
public: __property System.int get_SchemaImageIndex();
public: __property void set_SchemaImageIndex(
   System.int value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


ServerImageIndex Property

ServerImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : ServerImageIndex Property
Gets or sets the image list index value of the image displayed for server nodes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ServerImageIndex As System.Integer
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Integer

instance.ServerImageIndex = value

value = instance.ServerImageIndex
public System.int ServerImageIndex {get; set;}
public: __property System.int get_ServerImageIndex();
public: __property void set_ServerImageIndex(
   System.int value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


ShowFields Property (MetadataStructureOptions)

ShowFields Property (MetadataStructureOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : ShowFields Property
Instructs the component to show fields of database objects in the tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ShowFields As System.Boolean
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Boolean

instance.ShowFields = value

value = instance.ShowFields
public System.bool ShowFields {get; set;}
public: __property System.bool get_ShowFields();
public: __property void set_ShowFields(
   System.bool value
);
Remarks
Setting this property to true is necessary if you want to use the component without Design Pane. See the PanesConfigurationOptions.DesignPaneVisible property for details.
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


SynonymsFolderText Property

SynonymsFolderText Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : SynonymsFolderText Property
Gets or sets the text displayed for the synonym grouping folders.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SynonymsFolderText As System.String
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.String

instance.SynonymsFolderText = value

value = instance.SynonymsFolderText
public System.string SynonymsFolderText {get; set;}
public: __property System.string* get_SynonymsFolderText();
public: __property void set_SynonymsFolderText(
   System.string* value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


SystemProcedureImageIndex Property

SystemProcedureImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : SystemProcedureImageIndex Property
Gets or sets the image list index value of the image displayed for system procedures and functions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SystemProcedureImageIndex As System.Integer
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Integer

instance.SystemProcedureImageIndex = value

value = instance.SystemProcedureImageIndex
public System.int SystemProcedureImageIndex {get; set;}
public: __property System.int get_SystemProcedureImageIndex();
public: __property void set_SystemProcedureImageIndex(
   System.int value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


SystemSynonymImageIndex Property

SystemSynonymImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : SystemSynonymImageIndex Property
Gets or sets the image list index value of the image displayed for system synonyms.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SystemSynonymImageIndex As System.Integer
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Integer

instance.SystemSynonymImageIndex = value

value = instance.SystemSynonymImageIndex
public System.int SystemSynonymImageIndex {get; set;}
public: __property System.int get_SystemSynonymImageIndex();
public: __property void set_SystemSynonymImageIndex(
   System.int value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


SystemTableImageIndex Property

SystemTableImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : SystemTableImageIndex Property
Gets or sets the image list index value of the image displayed for system tables.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SystemTableImageIndex As System.Integer
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Integer

instance.SystemTableImageIndex = value

value = instance.SystemTableImageIndex
public System.int SystemTableImageIndex {get; set;}
public: __property System.int get_SystemTableImageIndex();
public: __property void set_SystemTableImageIndex(
   System.int value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


SystemViewImageIndex Property

SystemViewImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : SystemViewImageIndex Property
Gets or sets the image list index value of the image displayed for system views.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SystemViewImageIndex As System.Integer
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Integer

instance.SystemViewImageIndex = value

value = instance.SystemViewImageIndex
public System.int SystemViewImageIndex {get; set;}
public: __property System.int get_SystemViewImageIndex();
public: __property void set_SystemViewImageIndex(
   System.int value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


TablesFolderText Property

TablesFolderText Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : TablesFolderText Property
Gets or sets the text displayed for the table grouping folders.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property TablesFolderText As System.String
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.String

instance.TablesFolderText = value

value = instance.TablesFolderText
public System.string TablesFolderText {get; set;}
public: __property System.string* get_TablesFolderText();
public: __property void set_TablesFolderText(
   System.string* value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


UserProcedureImageIndex Property

UserProcedureImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : UserProcedureImageIndex Property
Gets or sets the image list index value of the image displayed for user procedures and functions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property UserProcedureImageIndex As System.Integer
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Integer

instance.UserProcedureImageIndex = value

value = instance.UserProcedureImageIndex
public System.int UserProcedureImageIndex {get; set;}
public: __property System.int get_UserProcedureImageIndex();
public: __property void set_UserProcedureImageIndex(
   System.int value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


UserSynonymImageIndex Property

UserSynonymImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : UserSynonymImageIndex Property
Gets or sets the image list index value of the image displayed for user synonyms.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property UserSynonymImageIndex As System.Integer
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Integer

instance.UserSynonymImageIndex = value

value = instance.UserSynonymImageIndex
public System.int UserSynonymImageIndex {get; set;}
public: __property System.int get_UserSynonymImageIndex();
public: __property void set_UserSynonymImageIndex(
   System.int value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


UserTableImageIndex Property

UserTableImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : UserTableImageIndex Property
Gets or sets the image list index value of the image displayed for user tables.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property UserTableImageIndex As System.Integer
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Integer

instance.UserTableImageIndex = value

value = instance.UserTableImageIndex
public System.int UserTableImageIndex {get; set;}
public: __property System.int get_UserTableImageIndex();
public: __property void set_UserTableImageIndex(
   System.int value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


UserViewImageIndex Property

UserViewImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : UserViewImageIndex Property
Gets or sets the image list index value of the image displayed for user views.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property UserViewImageIndex As System.Integer
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.Integer

instance.UserViewImageIndex = value

value = instance.UserViewImageIndex
public System.int UserViewImageIndex {get; set;}
public: __property System.int get_UserViewImageIndex();
public: __property void set_UserViewImageIndex(
   System.int value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


ViewsFolderText Property

ViewsFolderText Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MetadataStructureOptions Class : ViewsFolderText Property
Gets or sets the text displayed for the view grouping folders.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ViewsFolderText As System.String
'Usage

Dim instance As MetadataStructureOptions
Dim value As System.String

instance.ViewsFolderText = value

value = instance.ViewsFolderText
public System.string ViewsFolderText {get; set;}
public: __property System.string* get_ViewsFolderText();
public: __property void set_ViewsFolderText(
   System.string* value
);
Requirements

See Also

Reference

MetadataStructureOptions Class
MetadataStructureOptions Members


MSAccessSyntaxProvider Class

MSAccessSyntaxProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSAccessSyntaxProvider Class
Syntax provider for MS Jet-compatible databases: MS Access, MS Excel, MS Project as well as DBF, CSV and text files.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MSAccessSyntaxProvider
   Inherits BaseSyntaxProvider
'Usage

Dim instance As MSAccessSyntaxProvider
public class MSAccessSyntaxProvider : BaseSyntaxProvider
public __gc class MSAccessSyntaxProvider : public BaseSyntaxProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MSAccessSyntaxProvider

Requirements

See Also

Reference

MSAccessSyntaxProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MSAccessSyntaxProvider Class Members

MSAccessSyntaxProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSAccessSyntaxProvider Class

The following tables list the members exposed by MSAccessSyntaxProvider.

Public Properties
 | Name | Description
Public Property | DenyIntoClause | Overridden. Instructs to deny the INTO clause parsing and generation.
Public Property | LoadLinkedTables |
Public Property | LoadQueriesWithParameters |
Public Property | ServerVersion | Gets or sets MS Jet Engine version.
Top
See Also

Reference

MSAccessSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MSAccessSyntaxProvider Class Properties

MSAccessSyntaxProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSAccessSyntaxProvider Class

For a list of all members of this type, see MSAccessSyntaxProvider members.

Public Properties
 | Name | Description
Public Property | DenyIntoClause | Overridden. Instructs to deny the INTO clause parsing and generation.
Public Property | LoadLinkedTables |
Public Property | LoadQueriesWithParameters |
Public Property | ServerVersion | Gets or sets MS Jet Engine version.
Top
See Also

Reference

MSAccessSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


DenyIntoClause Property (MSAccessSyntaxProvider)

DenyIntoClause Property (MSAccessSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSAccessSyntaxProvider Class : DenyIntoClause Property
Instructs to deny the INTO clause parsing and generation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property DenyIntoClause As System.Boolean
'Usage

Dim instance As MSAccessSyntaxProvider
Dim value As System.Boolean

instance.DenyIntoClause = value

value = instance.DenyIntoClause
public override System.bool DenyIntoClause {get; set;}
public: __property System.bool get_DenyIntoClause() override;
public: __property void set_DenyIntoClause(
   System.bool value
) override;

Property Value

false to allow INTO clause; true to deny it.
Requirements

See Also

Reference

MSAccessSyntaxProvider Class
MSAccessSyntaxProvider Members
Base Implementation in DenyIntoClause


LoadLinkedTables Property

LoadLinkedTables Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSAccessSyntaxProvider Class : LoadLinkedTables Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property LoadLinkedTables As System.Boolean
'Usage

Dim instance As MSAccessSyntaxProvider
Dim value As System.Boolean

instance.LoadLinkedTables = value

value = instance.LoadLinkedTables
public System.bool LoadLinkedTables {get; set;}
public: __property System.bool get_LoadLinkedTables();
public: __property void set_LoadLinkedTables(
   System.bool value
);
Requirements

See Also

Reference

MSAccessSyntaxProvider Class
MSAccessSyntaxProvider Members


LoadQueriesWithParameters Property

LoadQueriesWithParameters Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSAccessSyntaxProvider Class : LoadQueriesWithParameters Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property LoadQueriesWithParameters As System.Boolean
'Usage

Dim instance As MSAccessSyntaxProvider
Dim value As System.Boolean

instance.LoadQueriesWithParameters = value

value = instance.LoadQueriesWithParameters
public System.bool LoadQueriesWithParameters {get; set;}
public: __property System.bool get_LoadQueriesWithParameters();
public: __property void set_LoadQueriesWithParameters(
   System.bool value
);
Requirements

See Also

Reference

MSAccessSyntaxProvider Class
MSAccessSyntaxProvider Members


ServerVersion Property (MSAccessSyntaxProvider)

ServerVersion Property (MSAccessSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSAccessSyntaxProvider Class : ServerVersion Property
Gets or sets MS Jet Engine version.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ServerVersion As MSAccessServerVersion
'Usage

Dim instance As MSAccessSyntaxProvider
Dim value As MSAccessServerVersion

instance.ServerVersion = value

value = instance.ServerVersion
public MSAccessServerVersion ServerVersion {get; set;}
public: __property MSAccessServerVersion get_ServerVersion();
public: __property void set_ServerVersion(
   MSAccessServerVersion value
);
Requirements

See Also

Reference

MSAccessSyntaxProvider Class
MSAccessSyntaxProvider Members


MSSQLAzureSyntaxProvider Class

MSSQLAzureSyntaxProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLAzureSyntaxProvider Class
The Syntax Provider for the Microsoft SQL Server Compact Edition dialect.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MSSQLAzureSyntaxProvider
   Inherits MSSQLSyntaxProvider
'Usage

Dim instance As MSSQLAzureSyntaxProvider
public class MSSQLAzureSyntaxProvider : MSSQLSyntaxProvider
public __gc class MSSQLAzureSyntaxProvider : public MSSQLSyntaxProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLAzureSyntaxProvider

Requirements

See Also

Reference

MSSQLAzureSyntaxProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MSSQLAzureSyntaxProvider Class Members

MSSQLAzureSyntaxProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLAzureSyntaxProvider Class

The following tables list the members exposed by MSSQLAzureSyntaxProvider.

See Also

Reference

MSSQLAzureSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MSSQLCESyntaxProvider Class

MSSQLCESyntaxProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLCESyntaxProvider Class
Syntax provider for Microsoft SQL Server Compact Edition.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MSSQLCESyntaxProvider
   Inherits MSSQLSyntaxProvider
'Usage

Dim instance As MSSQLCESyntaxProvider
public class MSSQLCESyntaxProvider : MSSQLSyntaxProvider
public __gc class MSSQLCESyntaxProvider : public MSSQLSyntaxProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLCESyntaxProvider

Requirements

See Also

Reference

MSSQLCESyntaxProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MSSQLCESyntaxProvider Class Members

MSSQLCESyntaxProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLCESyntaxProvider Class

The following tables list the members exposed by MSSQLCESyntaxProvider.

Public Methods
 | Name | Description
Public Method | GetReferencingObjectNames | Overridden.
Public Method | LoadFields | Overridden.
Public Method | LoadForeignKeys | Overridden.
Public Method | LoadObjects | Overridden.
Top
See Also

Reference

MSSQLCESyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MSSQLCESyntaxProvider Class Methods

MSSQLCESyntaxProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLCESyntaxProvider Class

For a list of all members of this type, see MSSQLCESyntaxProvider members.

Public Methods
 | Name | Description
Public Method | GetReferencingObjectNames | Overridden.
Public Method | LoadFields | Overridden.
Public Method | LoadForeignKeys | Overridden.
Public Method | LoadObjects | Overridden.
Top
See Also

Reference

MSSQLCESyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


GetReferencingObjectNames Method (MSSQLCESyntaxProvider)

GetReferencingObjectNames Method (MSSQLCESyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCESyntaxProvider Class : GetReferencingObjectNames Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Function GetReferencingObjectNames( _
   ByVal list As UpdatableObjectList(Of MetadataQualifiedName), _
   ByVal forObject As MetadataObject, _
   ByVal loadingOptions As MetadataLoadingOptions _
) As System.Boolean
'Usage

Dim instance As MSSQLCESyntaxProvider
Dim list As UpdatableObjectList(Of MetadataQualifiedName)
Dim forObject As MetadataObject
Dim loadingOptions As MetadataLoadingOptions
Dim value As System.Boolean

value = instance.GetReferencingObjectNames(list, forObject, loadingOptions)
public override System.bool GetReferencingObjectNames(
   UpdatableObjectList<MetadataQualifiedName> list,
   MetadataObject forObject,
   MetadataLoadingOptions loadingOptions
)
public: System.bool GetReferencingObjectNames(
   UpdatableObjectList<MetadataQualifiedName*>* list,
   MetadataObject* forObject,
   MetadataLoadingOptions* loadingOptions
) override

Parameters

list
forObject
loadingOptions
Requirements

See Also

Reference

MSSQLCESyntaxProvider Class
MSSQLCESyntaxProvider Members
Base Implementation in GetReferencingObjectNames


LoadFields Method (MSSQLCESyntaxProvider)

LoadFields Method (MSSQLCESyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCESyntaxProvider Class : LoadFields Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Sub LoadFields( _
   ByVal fields As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MSSQLCESyntaxProvider
Dim fields As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadFields(fields, loadingOptions)
public override void LoadFields(
   MetadataList fields,
   MetadataLoadingOptions loadingOptions
)
public: void LoadFields(
   MetadataList* fields,
   MetadataLoadingOptions* loadingOptions
) override

Parameters

fields
loadingOptions
Requirements

See Also

Reference

MSSQLCESyntaxProvider Class
MSSQLCESyntaxProvider Members
Base Implementation in LoadFields


LoadForeignKeys Method (MSSQLCESyntaxProvider)

LoadForeignKeys Method (MSSQLCESyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCESyntaxProvider Class : LoadForeignKeys Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Sub LoadForeignKeys( _
   ByVal foreignKeys As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MSSQLCESyntaxProvider
Dim foreignKeys As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadForeignKeys(foreignKeys, loadingOptions)
public override void LoadForeignKeys(
   MetadataList foreignKeys,
   MetadataLoadingOptions loadingOptions
)
public: void LoadForeignKeys(
   MetadataList* foreignKeys,
   MetadataLoadingOptions* loadingOptions
) override

Parameters

foreignKeys
loadingOptions
Requirements

See Also

Reference

MSSQLCESyntaxProvider Class
MSSQLCESyntaxProvider Members
Base Implementation in LoadForeignKeys


LoadObjects Method (MSSQLCESyntaxProvider)

LoadObjects Method (MSSQLCESyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCESyntaxProvider Class : LoadObjects Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Function LoadObjects( _
   ByVal objects As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
) As System.Boolean
'Usage

Dim instance As MSSQLCESyntaxProvider
Dim objects As MetadataList
Dim loadingOptions As MetadataLoadingOptions
Dim value As System.Boolean

value = instance.LoadObjects(objects, loadingOptions)
public override System.bool LoadObjects(
   MetadataList objects,
   MetadataLoadingOptions loadingOptions
)
public: System.bool LoadObjects(
   MetadataList* objects,
   MetadataLoadingOptions* loadingOptions
) override

Parameters

objects
loadingOptions
Requirements

See Also

Reference

MSSQLCESyntaxProvider Class
MSSQLCESyntaxProvider Members
Base Implementation in LoadObjects


MSSQLSyntaxProvider Class

MSSQLSyntaxProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLSyntaxProvider Class
Syntax Provider for Microsoft SQL Server.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MSSQLSyntaxProvider
   Inherits BaseSyntaxProvider
'Usage

Dim instance As MSSQLSyntaxProvider
public class MSSQLSyntaxProvider : BaseSyntaxProvider
public __gc class MSSQLSyntaxProvider : public BaseSyntaxProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLAzureSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLCESyntaxProvider

Requirements

See Also

Reference

MSSQLSyntaxProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MSSQLSyntaxProvider Class Members

MSSQLSyntaxProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLSyntaxProvider Class

The following tables list the members exposed by MSSQLSyntaxProvider.

Public Properties
 | Name | Description
Public Property | DenyIntoClause | Overridden. Instructs to deny the INTO clause parsing and generation.
Public Property | IdentCaseSens | Overridden. Defines the way database server treats quoted and unquoted identifiers.
Public Property | ServerVersion | Gets or sets Microsoft SQL Server version.
Top
Public Methods
 | Name | Description
Public Method | GetReferencingObjectNames | Overridden.
Public Method | LoadAggregates | Overridden.
Top
See Also

Reference

MSSQLSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MSSQLSyntaxProvider Class Methods

MSSQLSyntaxProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLSyntaxProvider Class

For a list of all members of this type, see MSSQLSyntaxProvider members.

Public Methods
 | Name | Description
Public Method | GetReferencingObjectNames | Overridden.
Public Method | LoadAggregates | Overridden.
Top
See Also

Reference

MSSQLSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


GetReferencingObjectNames Method (MSSQLSyntaxProvider)

GetReferencingObjectNames Method (MSSQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLSyntaxProvider Class : GetReferencingObjectNames Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Function GetReferencingObjectNames( _
   ByVal list As UpdatableObjectList(Of MetadataQualifiedName), _
   ByVal forObject As MetadataObject, _
   ByVal loadingOptions As MetadataLoadingOptions _
) As System.Boolean
'Usage

Dim instance As MSSQLSyntaxProvider
Dim list As UpdatableObjectList(Of MetadataQualifiedName)
Dim forObject As MetadataObject
Dim loadingOptions As MetadataLoadingOptions
Dim value As System.Boolean

value = instance.GetReferencingObjectNames(list, forObject, loadingOptions)
public override System.bool GetReferencingObjectNames(
   UpdatableObjectList<MetadataQualifiedName> list,
   MetadataObject forObject,
   MetadataLoadingOptions loadingOptions
)
public: System.bool GetReferencingObjectNames(
   UpdatableObjectList<MetadataQualifiedName*>* list,
   MetadataObject* forObject,
   MetadataLoadingOptions* loadingOptions
) override

Parameters

list
forObject
loadingOptions
Requirements

See Also

Reference

MSSQLSyntaxProvider Class
MSSQLSyntaxProvider Members
Base Implementation in GetReferencingObjectNames


LoadAggregates Method (MSSQLSyntaxProvider)

LoadAggregates Method (MSSQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLSyntaxProvider Class : LoadAggregates Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Sub LoadAggregates( _
   ByVal aggregates As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MSSQLSyntaxProvider
Dim aggregates As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadAggregates(aggregates, loadingOptions)
public override void LoadAggregates(
   MetadataList aggregates,
   MetadataLoadingOptions loadingOptions
)
public: void LoadAggregates(
   MetadataList* aggregates,
   MetadataLoadingOptions* loadingOptions
) override

Parameters

aggregates
loadingOptions
Requirements

See Also

Reference

MSSQLSyntaxProvider Class
MSSQLSyntaxProvider Members
Base Implementation in LoadAggregates


MSSQLSyntaxProvider Class Properties

MSSQLSyntaxProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLSyntaxProvider Class

For a list of all members of this type, see MSSQLSyntaxProvider members.

Public Properties
 | Name | Description
Public Property | DenyIntoClause | Overridden. Instructs to deny the INTO clause parsing and generation.
Public Property | IdentCaseSens | Overridden. Defines the way database server treats quoted and unquoted identifiers.
Public Property | ServerVersion | Gets or sets Microsoft SQL Server version.
Top
See Also

Reference

MSSQLSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


DenyIntoClause Property (MSSQLSyntaxProvider)

DenyIntoClause Property (MSSQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLSyntaxProvider Class : DenyIntoClause Property
Instructs to deny the INTO clause parsing and generation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property DenyIntoClause As System.Boolean
'Usage

Dim instance As MSSQLSyntaxProvider
Dim value As System.Boolean

instance.DenyIntoClause = value

value = instance.DenyIntoClause
public override System.bool DenyIntoClause {get; set;}
public: __property System.bool get_DenyIntoClause() override;
public: __property void set_DenyIntoClause(
   System.bool value
) override;
Requirements

See Also

Reference

MSSQLSyntaxProvider Class
MSSQLSyntaxProvider Members
Base Implementation in DenyIntoClause


IdentCaseSens Property (MSSQLSyntaxProvider)

IdentCaseSens Property (MSSQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLSyntaxProvider Class : IdentCaseSens Property
Defines the way database server treats quoted and unquoted identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property IdentCaseSens As IdentCaseSensitivity
'Usage

Dim instance As MSSQLSyntaxProvider
Dim value As IdentCaseSensitivity

instance.IdentCaseSens = value

value = instance.IdentCaseSens
public override IdentCaseSensitivity IdentCaseSens {get; set;}
public: __property IdentCaseSensitivity get_IdentCaseSens() override;
public: __property void set_IdentCaseSens(
   IdentCaseSensitivity value
) override;
Requirements

See Also

Reference

MSSQLSyntaxProvider Class
MSSQLSyntaxProvider Members
Base Implementation in IdentCaseSens


ServerVersion Property (MSSQLSyntaxProvider)

ServerVersion Property (MSSQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLSyntaxProvider Class : ServerVersion Property
Gets or sets Microsoft SQL Server version.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ServerVersion As MSSQLServerVersion
'Usage

Dim instance As MSSQLSyntaxProvider
Dim value As MSSQLServerVersion

instance.ServerVersion = value

value = instance.ServerVersion
public MSSQLServerVersion ServerVersion {get; set;}
public: __property MSSQLServerVersion get_ServerVersion();
public: __property void set_ServerVersion(
   MSSQLServerVersion value
);
Requirements

See Also

Reference

MSSQLSyntaxProvider Class
MSSQLSyntaxProvider Members


MySQLSyntaxProvider Class

MySQLSyntaxProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MySQLSyntaxProvider Class
Syntax provider for MySQL.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MySQLSyntaxProvider
   Inherits BaseSyntaxProvider
'Usage

Dim instance As MySQLSyntaxProvider
public class MySQLSyntaxProvider : BaseSyntaxProvider
public __gc class MySQLSyntaxProvider : public BaseSyntaxProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MySQLSyntaxProvider

Requirements

See Also

Reference

MySQLSyntaxProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MySQLSyntaxProvider Class Members

MySQLSyntaxProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MySQLSyntaxProvider Class

The following tables list the members exposed by MySQLSyntaxProvider.

Public Properties
 | Name | Description
Public Property | AnsiQuotes | Instructs the component to quote identifiers with double quotes instead of back quotes.
Public Property | DenyIntoClause | Overridden. Instructs to deny the INTO clause parsing and generation.
Public Property | IdentCaseSens | Overridden. Defines the way database server treats quoted and unquoted identifiers.
Public Property | ServerVersion | Gets or sets MySQL server version string.
Public Property | ServerVersionInt | Gets or sets MySQL server version as integer.
Public Property | TryToSelectLinksViaDriver | Instructs the component to try to retrieve foreign keys from the database via data access component method calls in case of failing to retrieve them by querying system objects.
Top
See Also

Reference

MySQLSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MySQLSyntaxProvider Class Properties

MySQLSyntaxProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MySQLSyntaxProvider Class

For a list of all members of this type, see MySQLSyntaxProvider members.

Public Properties
 | Name | Description
Public Property | AnsiQuotes | Instructs the component to quote identifiers with double quotes instead of back quotes.
Public Property | DenyIntoClause | Overridden. Instructs to deny the INTO clause parsing and generation.
Public Property | IdentCaseSens | Overridden. Defines the way database server treats quoted and unquoted identifiers.
Public Property | ServerVersion | Gets or sets MySQL server version string.
Public Property | ServerVersionInt | Gets or sets MySQL server version as integer.
Public Property | TryToSelectLinksViaDriver | Instructs the component to try to retrieve foreign keys from the database via data access component method calls in case of failing to retrieve them by querying system objects.
Top
See Also

Reference

MySQLSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AnsiQuotes Property

AnsiQuotes Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLSyntaxProvider Class : AnsiQuotes Property
Instructs the component to quote identifiers with double quotes instead of back quotes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AnsiQuotes As System.Boolean
'Usage

Dim instance As MySQLSyntaxProvider
Dim value As System.Boolean

instance.AnsiQuotes = value

value = instance.AnsiQuotes
public System.bool AnsiQuotes {get; set;}
public: __property System.bool get_AnsiQuotes();
public: __property void set_AnsiQuotes(
   System.bool value
);
Requirements

See Also

Reference

MySQLSyntaxProvider Class
MySQLSyntaxProvider Members


DenyIntoClause Property (MySQLSyntaxProvider)

DenyIntoClause Property (MySQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLSyntaxProvider Class : DenyIntoClause Property
Instructs to deny the INTO clause parsing and generation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property DenyIntoClause As System.Boolean
'Usage

Dim instance As MySQLSyntaxProvider
Dim value As System.Boolean

instance.DenyIntoClause = value

value = instance.DenyIntoClause
public override System.bool DenyIntoClause {get; set;}
public: __property System.bool get_DenyIntoClause() override;
public: __property void set_DenyIntoClause(
   System.bool value
) override;
Requirements

See Also

Reference

MySQLSyntaxProvider Class
MySQLSyntaxProvider Members
Base Implementation in DenyIntoClause


IdentCaseSens Property (MySQLSyntaxProvider)

IdentCaseSens Property (MySQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLSyntaxProvider Class : IdentCaseSens Property
Defines the way database server treats quoted and unquoted identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property IdentCaseSens As IdentCaseSensitivity
'Usage

Dim instance As MySQLSyntaxProvider
Dim value As IdentCaseSensitivity

instance.IdentCaseSens = value

value = instance.IdentCaseSens
public override IdentCaseSensitivity IdentCaseSens {get; set;}
public: __property IdentCaseSensitivity get_IdentCaseSens() override;
public: __property void set_IdentCaseSens(
   IdentCaseSensitivity value
) override;
Requirements

See Also

Reference

MySQLSyntaxProvider Class
MySQLSyntaxProvider Members
Base Implementation in IdentCaseSens


ServerVersion Property (MySQLSyntaxProvider)

ServerVersion Property (MySQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLSyntaxProvider Class : ServerVersion Property
Gets or sets MySQL server version string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ServerVersion As System.String
'Usage

Dim instance As MySQLSyntaxProvider
Dim value As System.String

instance.ServerVersion = value

value = instance.ServerVersion
public System.string ServerVersion {get; set;}
public: __property System.string* get_ServerVersion();
public: __property void set_ServerVersion(
   System.string* value
);

Property Value

The value of this property is string represenation of the ServerVersionInt property split with dots by two digits. I.e. for MySQL version 5.1.93, the value of this property will be "5.01.93".
Requirements

See Also

Reference

MySQLSyntaxProvider Class
MySQLSyntaxProvider Members


ServerVersionInt Property

ServerVersionInt Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLSyntaxProvider Class : ServerVersionInt Property
Gets or sets MySQL server version as integer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ServerVersionInt As System.Integer
'Usage

Dim instance As MySQLSyntaxProvider
Dim value As System.Integer

instance.ServerVersionInt = value

value = instance.ServerVersionInt
public System.int ServerVersionInt {get; set;}
public: __property System.int get_ServerVersionInt();
public: __property void set_ServerVersionInt(
   System.int value
);

Property Value

For example, for MySQL version 5.1.93, the value of this propery will be 50193. To get the major version you may divide it by 10000.
Requirements

See Also

Reference

MySQLSyntaxProvider Class
MySQLSyntaxProvider Members


TryToSelectLinksViaDriver Property

TryToSelectLinksViaDriver Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLSyntaxProvider Class : TryToSelectLinksViaDriver Property
Instructs the component to try to retrieve foreign keys from the database via data access component method calls in case of failing to retrieve them by querying system objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property TryToSelectLinksViaDriver As System.Boolean
'Usage

Dim instance As MySQLSyntaxProvider
Dim value As System.Boolean

instance.TryToSelectLinksViaDriver = value

value = instance.TryToSelectLinksViaDriver
public System.bool TryToSelectLinksViaDriver {get; set;}
public: __property System.bool get_TryToSelectLinksViaDriver();
public: __property void set_TryToSelectLinksViaDriver(
   System.bool value
);
Remarks
This property was made because some ODBC drivers were failing to retrieve this information and hanged up. Note that ability to retrieve foreign keys by querying system objects was implemented only in MySQL 5.0.
Requirements

See Also

Reference

MySQLSyntaxProvider Class
MySQLSyntaxProvider Members


OracleSyntaxProvider Class

OracleSyntaxProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : OracleSyntaxProvider Class
Syntax provider for Oracle Database.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class OracleSyntaxProvider
   Inherits BaseSyntaxProvider
'Usage

Dim instance As OracleSyntaxProvider
public class OracleSyntaxProvider : BaseSyntaxProvider
public __gc class OracleSyntaxProvider : public BaseSyntaxProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSyntaxProvider

Requirements

See Also

Reference

OracleSyntaxProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


OracleSyntaxProvider Class Members

OracleSyntaxProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : OracleSyntaxProvider Class

The following tables list the members exposed by OracleSyntaxProvider.

Public Properties
 | Name | Description
Public Property | ServerVersion | Gets or sets Oracle Database server version.
Top
Public Methods
 | Name | Description
Public Method | GetReferencingObjectNames | Overridden.
Public Method | LoadAggregates | Overridden.
Top
See Also

Reference

OracleSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


OracleSyntaxProvider Class Methods

OracleSyntaxProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : OracleSyntaxProvider Class

For a list of all members of this type, see OracleSyntaxProvider members.

Public Methods
 | Name | Description
Public Method | GetReferencingObjectNames | Overridden.
Public Method | LoadAggregates | Overridden.
Top
See Also

Reference

OracleSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


GetReferencingObjectNames Method (OracleSyntaxProvider)

GetReferencingObjectNames Method (OracleSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleSyntaxProvider Class : GetReferencingObjectNames Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Function GetReferencingObjectNames( _
   ByVal list As UpdatableObjectList(Of MetadataQualifiedName), _
   ByVal forObject As MetadataObject, _
   ByVal loadingOptions As MetadataLoadingOptions _
) As System.Boolean
'Usage

Dim instance As OracleSyntaxProvider
Dim list As UpdatableObjectList(Of MetadataQualifiedName)
Dim forObject As MetadataObject
Dim loadingOptions As MetadataLoadingOptions
Dim value As System.Boolean

value = instance.GetReferencingObjectNames(list, forObject, loadingOptions)
public override System.bool GetReferencingObjectNames(
   UpdatableObjectList<MetadataQualifiedName> list,
   MetadataObject forObject,
   MetadataLoadingOptions loadingOptions
)
public: System.bool GetReferencingObjectNames(
   UpdatableObjectList<MetadataQualifiedName*>* list,
   MetadataObject* forObject,
   MetadataLoadingOptions* loadingOptions
) override

Parameters

list
forObject
loadingOptions
Requirements

See Also

Reference

OracleSyntaxProvider Class
OracleSyntaxProvider Members
Base Implementation in GetReferencingObjectNames


LoadAggregates Method (OracleSyntaxProvider)

LoadAggregates Method (OracleSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleSyntaxProvider Class : LoadAggregates Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Sub LoadAggregates( _
   ByVal aggregates As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OracleSyntaxProvider
Dim aggregates As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadAggregates(aggregates, loadingOptions)
public override void LoadAggregates(
   MetadataList aggregates,
   MetadataLoadingOptions loadingOptions
)
public: void LoadAggregates(
   MetadataList* aggregates,
   MetadataLoadingOptions* loadingOptions
) override

Parameters

aggregates
loadingOptions
Requirements

See Also

Reference

OracleSyntaxProvider Class
OracleSyntaxProvider Members
Base Implementation in LoadAggregates


OracleSyntaxProvider Class Properties

OracleSyntaxProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : OracleSyntaxProvider Class

For a list of all members of this type, see OracleSyntaxProvider members.

Public Properties
 | Name | Description
Public Property | ServerVersion | Gets or sets Oracle Database server version.
Top
See Also

Reference

OracleSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


ServerVersion Property (OracleSyntaxProvider)

ServerVersion Property (OracleSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleSyntaxProvider Class : ServerVersion Property
Gets or sets Oracle Database server version.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ServerVersion As OracleServerVersion
'Usage

Dim instance As OracleSyntaxProvider
Dim value As OracleServerVersion

instance.ServerVersion = value

value = instance.ServerVersion
public OracleServerVersion ServerVersion {get; set;}
public: __property OracleServerVersion get_ServerVersion();
public: __property void set_ServerVersion(
   OracleServerVersion value
);
Requirements

See Also

Reference

OracleSyntaxProvider Class
OracleSyntaxProvider Members


PanesConfigurationOptions Class

PanesConfigurationOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : PanesConfigurationOptions Class
Allows you to configure layout of the main parts of the component: Design Pane, Query Columns Pane, Database Schema Tree and Query Structure Tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class PanesConfigurationOptions
   Inherits UpdatablePersistent
'Usage

Dim instance As PanesConfigurationOptions
public class PanesConfigurationOptions : UpdatablePersistent
public __gc class PanesConfigurationOptions : public UpdatablePersistent
Remarks
To configure tabs above the Design Pane, see the VisualOptions property group.
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.PanesConfigurationOptions

Requirements

See Also

Reference

PanesConfigurationOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
PanesConfigurationOptions Property


PanesConfigurationOptions Class Members

PanesConfigurationOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : PanesConfigurationOptions Class

The following tables list the members exposed by PanesConfigurationOptions.

Public Properties
 | Name | Description
Public Property | DesignPaneOverviewVisible | Determines visibility of the Design Pane Overview.
Public Property | DesignPaneOverviewWidth | Gets or sets the width of the Design Pane Overview window.
Public Property | DesignPaneVisible | Determines visibility of the Design Pane.
Public Property | LeftTreePaneVisible | Determines visibility of the left tree pane.
Public Property | LeftTreePaneWidth | Determines width of the left tree pane.
Public Property | QueryColumnsPaneHeight | Determines height of the Query Columns Pane.
Public Property | QueryColumnsPaneVisible | Determines visibility of the Query Columns Pane (grid with expressions and criteria below the Design Pane).
Public Property | RightTreePaneVisible | Determines visibility of the right tree pane.
Public Property | RightTreePaneWidth | Determines width of the right tree pane.
Public Property | SubQueryTabsVisible | Determines visibility of sub-query tabs above the Design Pane.
Public Property | SwapTrees | Allows to swap Query Structure Tree and Database Schema Tree with each other.
Public Property | UnionNavBarVisible | Determines visibility of the Union Sub-query Navigation Bar (in the top right corner of Design Pane).
Top
See Also

Reference

PanesConfigurationOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
PanesConfigurationOptions Property


PanesConfigurationOptions Class Properties

PanesConfigurationOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : PanesConfigurationOptions Class

For a list of all members of this type, see PanesConfigurationOptions members.

Public Properties
 | Name | Description
Public Property | DesignPaneOverviewVisible | Determines visibility of the Design Pane Overview.
Public Property | DesignPaneOverviewWidth | Gets or sets the width of the Design Pane Overview window.
Public Property | DesignPaneVisible | Determines visibility of the Design Pane.
Public Property | LeftTreePaneVisible | Determines visibility of the left tree pane.
Public Property | LeftTreePaneWidth | Determines width of the left tree pane.
Public Property | QueryColumnsPaneHeight | Determines height of the Query Columns Pane.
Public Property | QueryColumnsPaneVisible | Determines visibility of the Query Columns Pane (grid with expressions and criteria below the Design Pane).
Public Property | RightTreePaneVisible | Determines visibility of the right tree pane.
Public Property | RightTreePaneWidth | Determines width of the right tree pane.
Public Property | SubQueryTabsVisible | Determines visibility of sub-query tabs above the Design Pane.
Public Property | SwapTrees | Allows to swap Query Structure Tree and Database Schema Tree with each other.
Public Property | UnionNavBarVisible | Determines visibility of the Union Sub-query Navigation Bar (in the top right corner of Design Pane).
Top
See Also

Reference

PanesConfigurationOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
PanesConfigurationOptions Property


DesignPaneOverviewVisible Property

DesignPaneOverviewVisible Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PanesConfigurationOptions Class : DesignPaneOverviewVisible Property
Determines visibility of the Design Pane Overview.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DesignPaneOverviewVisible As DesignPaneOverviewVisibility
'Usage

Dim instance As PanesConfigurationOptions
Dim value As DesignPaneOverviewVisibility

instance.DesignPaneOverviewVisible = value

value = instance.DesignPaneOverviewVisible
public DesignPaneOverviewVisibility DesignPaneOverviewVisible {get; set;}
public: __property DesignPaneOverviewVisibility get_DesignPaneOverviewVisible();
public: __property void set_DesignPaneOverviewVisible(
   DesignPaneOverviewVisibility value
);
Remarks
The Design Pane Overview is located in the bottom right corner of the Design Pane. It is intended to ease the navigation over large query diagrams.
Requirements

See Also

Reference

PanesConfigurationOptions Class
PanesConfigurationOptions Members


DesignPaneOverviewWidth Property

DesignPaneOverviewWidth Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PanesConfigurationOptions Class : DesignPaneOverviewWidth Property
Gets or sets the width of the Design Pane Overview window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DesignPaneOverviewWidth As System.Integer
'Usage

Dim instance As PanesConfigurationOptions
Dim value As System.Integer

instance.DesignPaneOverviewWidth = value

value = instance.DesignPaneOverviewWidth
public System.int DesignPaneOverviewWidth {get; set;}
public: __property System.int get_DesignPaneOverviewWidth();
public: __property void set_DesignPaneOverviewWidth(
   System.int value
);
Requirements

See Also

Reference

PanesConfigurationOptions Class
PanesConfigurationOptions Members


DesignPaneVisible Property

DesignPaneVisible Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PanesConfigurationOptions Class : DesignPaneVisible Property
Determines visibility of the Design Pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DesignPaneVisible As System.Boolean
'Usage

Dim instance As PanesConfigurationOptions
Dim value As System.Boolean

instance.DesignPaneVisible = value

value = instance.DesignPaneVisible
public System.bool DesignPaneVisible {get; set;}
public: __property System.bool get_DesignPaneVisible();
public: __property void set_DesignPaneVisible(
   System.bool value
);
Remarks
On hiding the Design Pane, don't forget to set the AddLinkedObjects and DeleteUnusedObjects properties to true and allow showing of fields in the database objects tree using the DatabaseSchemaTreeOptions.ShowFields property.
Requirements

See Also

Reference

PanesConfigurationOptions Class
PanesConfigurationOptions Members


LeftTreePaneVisible Property

LeftTreePaneVisible Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PanesConfigurationOptions Class : LeftTreePaneVisible Property
Determines visibility of the left tree pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property LeftTreePaneVisible As System.Boolean
'Usage

Dim instance As PanesConfigurationOptions
Dim value As System.Boolean

instance.LeftTreePaneVisible = value

value = instance.LeftTreePaneVisible
public System.bool LeftTreePaneVisible {get; set;}
public: __property System.bool get_LeftTreePaneVisible();
public: __property void set_LeftTreePaneVisible(
   System.bool value
);
Remarks
Content of the right and left tree panes is determined according to the SwapTrees property.
Requirements

See Also

Reference

PanesConfigurationOptions Class
PanesConfigurationOptions Members


LeftTreePaneWidth Property

LeftTreePaneWidth Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PanesConfigurationOptions Class : LeftTreePaneWidth Property
Determines width of the left tree pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property LeftTreePaneWidth As System.Integer
'Usage

Dim instance As PanesConfigurationOptions
Dim value As System.Integer

instance.LeftTreePaneWidth = value

value = instance.LeftTreePaneWidth
public System.int LeftTreePaneWidth {get; set;}
public: __property System.int get_LeftTreePaneWidth();
public: __property void set_LeftTreePaneWidth(
   System.int value
);
Requirements

See Also

Reference

PanesConfigurationOptions Class
PanesConfigurationOptions Members


QueryColumnsPaneHeight Property

QueryColumnsPaneHeight Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PanesConfigurationOptions Class : QueryColumnsPaneHeight Property
Determines height of the Query Columns Pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property QueryColumnsPaneHeight As System.Integer
'Usage

Dim instance As PanesConfigurationOptions
Dim value As System.Integer

instance.QueryColumnsPaneHeight = value

value = instance.QueryColumnsPaneHeight
public System.int QueryColumnsPaneHeight {get; set;}
public: __property System.int get_QueryColumnsPaneHeight();
public: __property void set_QueryColumnsPaneHeight(
   System.int value
);
Requirements

See Also

Reference

PanesConfigurationOptions Class
PanesConfigurationOptions Members


QueryColumnsPaneVisible Property

QueryColumnsPaneVisible Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PanesConfigurationOptions Class : QueryColumnsPaneVisible Property
Determines visibility of the Query Columns Pane (grid with expressions and criteria below the Design Pane).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property QueryColumnsPaneVisible As System.Boolean
'Usage

Dim instance As PanesConfigurationOptions
Dim value As System.Boolean

instance.QueryColumnsPaneVisible = value

value = instance.QueryColumnsPaneVisible
public System.bool QueryColumnsPaneVisible {get; set;}
public: __property System.bool get_QueryColumnsPaneVisible();
public: __property void set_QueryColumnsPaneVisible(
   System.bool value
);
Requirements

See Also

Reference

PanesConfigurationOptions Class
PanesConfigurationOptions Members


RightTreePaneVisible Property

RightTreePaneVisible Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PanesConfigurationOptions Class : RightTreePaneVisible Property
Determines visibility of the right tree pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property RightTreePaneVisible As System.Boolean
'Usage

Dim instance As PanesConfigurationOptions
Dim value As System.Boolean

instance.RightTreePaneVisible = value

value = instance.RightTreePaneVisible
public System.bool RightTreePaneVisible {get; set;}
public: __property System.bool get_RightTreePaneVisible();
public: __property void set_RightTreePaneVisible(
   System.bool value
);
Remarks
Content of the right and left tree panes is determined according to the SwapTrees property.
Requirements

See Also

Reference

PanesConfigurationOptions Class
PanesConfigurationOptions Members


RightTreePaneWidth Property

RightTreePaneWidth Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PanesConfigurationOptions Class : RightTreePaneWidth Property
Determines width of the right tree pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property RightTreePaneWidth As System.Integer
'Usage

Dim instance As PanesConfigurationOptions
Dim value As System.Integer

instance.RightTreePaneWidth = value

value = instance.RightTreePaneWidth
public System.int RightTreePaneWidth {get; set;}
public: __property System.int get_RightTreePaneWidth();
public: __property void set_RightTreePaneWidth(
   System.int value
);
Requirements

See Also

Reference

PanesConfigurationOptions Class
PanesConfigurationOptions Members


SubQueryTabsVisible Property

SubQueryTabsVisible Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PanesConfigurationOptions Class : SubQueryTabsVisible Property
Determines visibility of sub-query tabs above the Design Pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SubQueryTabsVisible As System.Boolean
'Usage

Dim instance As PanesConfigurationOptions
Dim value As System.Boolean

instance.SubQueryTabsVisible = value

value = instance.SubQueryTabsVisible
public System.bool SubQueryTabsVisible {get; set;}
public: __property System.bool get_SubQueryTabsVisible();
public: __property void set_SubQueryTabsVisible(
   System.bool value
);
Remarks
You may navigate sub-queries using the Query Structure Tree instead of sub-query tabs.
Requirements

See Also

Reference

PanesConfigurationOptions Class
PanesConfigurationOptions Members


SwapTrees Property

SwapTrees Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PanesConfigurationOptions Class : SwapTrees Property
Allows to swap Query Structure Tree and Database Schema Tree with each other.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SwapTrees As System.Boolean
'Usage

Dim instance As PanesConfigurationOptions
Dim value As System.Boolean

instance.SwapTrees = value

value = instance.SwapTrees
public System.bool SwapTrees {get; set;}
public: __property System.bool get_SwapTrees();
public: __property void set_SwapTrees(
   System.bool value
);

Property Value

Set to false to have the Query Structure Tree at the left and Database Schema Tree at the right; set to true to swap the trees vice versa.
Requirements

See Also

Reference

PanesConfigurationOptions Class
PanesConfigurationOptions Members


UnionNavBarVisible Property

UnionNavBarVisible Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PanesConfigurationOptions Class : UnionNavBarVisible Property
Determines visibility of the Union Sub-query Navigation Bar (in the top right corner of Design Pane).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property UnionNavBarVisible As System.Boolean
'Usage

Dim instance As PanesConfigurationOptions
Dim value As System.Boolean

instance.UnionNavBarVisible = value

value = instance.UnionNavBarVisible
public System.bool UnionNavBarVisible {get; set;}
public: __property System.bool get_UnionNavBarVisible();
public: __property void set_UnionNavBarVisible(
   System.bool value
);
Requirements

See Also

Reference

PanesConfigurationOptions Class
PanesConfigurationOptions Members


Parameter Class

Parameter Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : Parameter Class
Describes single parameter that was found in the query.
Object Model
Parameter ClassMetadataField ClassMetadataObject Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class Parameter
'Usage

Dim instance As Parameter
public class Parameter
public __gc class Parameter
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.Parameter

Requirements

See Also

Reference

Parameter Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Parameter Class Members

Parameter Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : Parameter Class

The following tables list the members exposed by Parameter.

Public Properties
 | Name | Description
Public Property | ComparedField | Returns field name that was compared with this parameter.
Public Property | ComparedObject | Returns database object name of a field that was compared with this parameter.
Public Property | CompareOperator | Returns comparison operator that was used with this parameter.
Public Property | DataType | Returns compared field data type.
Public Property | FullName | Returns full name of parameter (name and symbol).
Public Property | MetadataField | Returns a reference to MetadataField object from the Metadata Container if a corresponding field was found in it.
Public Property | MetadataObject | Returns a reference to MetadataObject object from the Metadata Container if a corresponding field's object was found in it.
Public Property | Name | Returns name of parameter. Returns empty string in case of unnamed parameter.
Public Property | Symbol | Returns parameter symbol.
Top
See Also

Reference

Parameter Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Parameter Class Properties

Parameter Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : Parameter Class

For a list of all members of this type, see Parameter members.

Public Properties
 | Name | Description
Public Property | ComparedField | Returns field name that was compared with this parameter.
Public Property | ComparedObject | Returns database object name of a field that was compared with this parameter.
Public Property | CompareOperator | Returns comparison operator that was used with this parameter.
Public Property | DataType | Returns compared field data type.
Public Property | FullName | Returns full name of parameter (name and symbol).
Public Property | MetadataField | Returns a reference to MetadataField object from the Metadata Container if a corresponding field was found in it.
Public Property | MetadataObject | Returns a reference to MetadataObject object from the Metadata Container if a corresponding field's object was found in it.
Public Property | Name | Returns name of parameter. Returns empty string in case of unnamed parameter.
Public Property | Symbol | Returns parameter symbol.
Top
See Also

Reference

Parameter Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


ComparedField Property

ComparedField Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > Parameter Class : ComparedField Property
Returns field name that was compared with this parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ComparedField As System.String
'Usage

Dim instance As Parameter
Dim value As System.String

value = instance.ComparedField
public System.string ComparedField {get;}
public: __property System.string* get_ComparedField();
Remarks
Returns empty string in case of using parameter in a complex expression.
Requirements

See Also

Reference

Parameter Class
Parameter Members
MetadataField Property
ComparedObject Property


ComparedObject Property

ComparedObject Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > Parameter Class : ComparedObject Property
Returns database object name of a field that was compared with this parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ComparedObject As System.String
'Usage

Dim instance As Parameter
Dim value As System.String

value = instance.ComparedObject
public System.string ComparedObject {get;}
public: __property System.string* get_ComparedObject();
Remarks
Returns empty string in case of using parameter in a complex expression.
Requirements

See Also

Reference

Parameter Class
Parameter Members
ComparedField Property
MetadataObject Property


CompareOperator Property

CompareOperator Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > Parameter Class : CompareOperator Property
Returns comparison operator that was used with this parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CompareOperator As System.String
'Usage

Dim instance As Parameter
Dim value As System.String

value = instance.CompareOperator
public System.string CompareOperator {get;}
public: __property System.string* get_CompareOperator();
Requirements

See Also

Reference

Parameter Class
Parameter Members
ComparedField Property
ComparedObject Property


DataType Property (Parameter)

DataType Property (Parameter)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > Parameter Class : DataType Property
Returns compared field data type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property DataType As System.Data.DbType
'Usage

Dim instance As Parameter
Dim value As System.Data.DbType

value = instance.DataType
public System.Data.DbType DataType {get;}
public: __property System.Data.DbType get_DataType();
Remarks
Returns DbType.Object value in case of using parameter in a complex expression.
Requirements

See Also

Reference

Parameter Class
Parameter Members
MetadataField Property
ComparedField Property


FullName Property (Parameter)

FullName Property (Parameter)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > Parameter Class : FullName Property
Returns full name of parameter (name and symbol).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property FullName As System.String
'Usage

Dim instance As Parameter
Dim value As System.String

value = instance.FullName
public System.string FullName {get;}
public: __property System.string* get_FullName();
Requirements

See Also

Reference

Parameter Class
Parameter Members
Name Property
Symbol Property


MetadataField Property (Parameter)

MetadataField Property (Parameter)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > Parameter Class : MetadataField Property
Returns a reference to MetadataField object from the Metadata Container if a corresponding field was found in it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property MetadataField As MetadataField
'Usage

Dim instance As Parameter
Dim value As MetadataField

value = instance.MetadataField
public MetadataField MetadataField {get;}
public: __property MetadataField* get_MetadataField();
Remarks
Returns null in case of using parameter in a complex expression.
Requirements

See Also

Reference

Parameter Class
Parameter Members
MetadataObject Property
ComparedField Property


MetadataObject Property (Parameter)

MetadataObject Property (Parameter)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > Parameter Class : MetadataObject Property
Returns a reference to MetadataObject object from the Metadata Container if a corresponding field's object was found in it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property MetadataObject As MetadataObject
'Usage

Dim instance As Parameter
Dim value As MetadataObject

value = instance.MetadataObject
public MetadataObject MetadataObject {get;}
public: __property MetadataObject* get_MetadataObject();
Remarks
Returns null in case of using parameter in a complex expression.
Requirements

See Also

Reference

Parameter Class
Parameter Members
MetadataField Property
ComparedObject Property


Name Property (Parameter)

Name Property (Parameter)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > Parameter Class : Name Property
Returns name of parameter. Returns empty string in case of unnamed parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Name As System.String
'Usage

Dim instance As Parameter
Dim value As System.String

value = instance.Name
public System.string Name {get;}
public: __property System.string* get_Name();
Requirements

See Also

Reference

Parameter Class
Parameter Members
Symbol Property
FullName Property


Symbol Property

Symbol Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > Parameter Class : Symbol Property
Returns parameter symbol.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Symbol As System.String
'Usage

Dim instance As Parameter
Dim value As System.String

value = instance.Symbol
public System.string Symbol {get;}
public: __property System.string* get_Symbol();
Remarks
The following symbols are acceptable by Active Query Builder:
"?" - unnamed parameter ("WHERE Field = ?")
":" - named parameter ("WHERE Field = :Param")
"@" - MS SQL Server named parameter (WHERE Field = @Param")
Requirements

See Also

Reference

Parameter Class
Parameter Members


ParameterList Class

ParameterList Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : ParameterList Class
Lists parameters that were found in the query.
Object Model
ParameterList ClassParameter Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class ParameterList
'Usage

Dim instance As ParameterList
public class ParameterList
public __gc class ParameterList
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.ParameterList

Requirements

See Also

Reference

ParameterList Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


ParameterList Class Members

ParameterList Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : ParameterList Class

The following tables list the members exposed by ParameterList.

Public Properties
 | Name | Description
Public Property | Count | Returns the number of parameters in the list.
Public Property | Item | Gets access to the items of the list.
Public Property | QueryBuilder | Refers to the QueryBuilder object to which this Parameters List belongs to.
Top
See Also

Reference

ParameterList Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


ParameterList Class Properties

ParameterList Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : ParameterList Class

For a list of all members of this type, see ParameterList members.

Public Properties
 | Name | Description
Public Property | Count | Returns the number of parameters in the list.
Public Property | Item | Gets access to the items of the list.
Public Property | QueryBuilder | Refers to the QueryBuilder object to which this Parameters List belongs to.
Top
See Also

Reference

ParameterList Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Count Property (ParameterList)

Count Property (ParameterList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ParameterList Class : Count Property
Returns the number of parameters in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Count As System.Integer
'Usage

Dim instance As ParameterList
Dim value As System.Integer

value = instance.Count
public System.int Count {get;}
public: __property System.int get_Count();
Requirements

See Also

Reference

ParameterList Class
ParameterList Members


Item Property (ParameterList)

Item Property (ParameterList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ParameterList Class : Item Property
Gets access to the items of the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As Parameter
'Usage

Dim instance As ParameterList
Dim index As System.Integer
Dim value As Parameter

value = instance.Item(index)
public Parameter this[
   System.int index
]; {get;}
public: __property Parameter* get_Item   System.int index
;

Parameters

index
Requirements

See Also

Reference

ParameterList Class
ParameterList Members


QueryBuilder Property (ParameterList)

QueryBuilder Property (ParameterList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ParameterList Class : QueryBuilder Property
Refers to the QueryBuilder object to which this Parameters List belongs to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property QueryBuilder As QueryBuilder
'Usage

Dim instance As ParameterList
Dim value As QueryBuilder

value = instance.QueryBuilder
public QueryBuilder QueryBuilder {get;}
public: __property QueryBuilder* get_QueryBuilder();
Requirements

See Also

Reference

ParameterList Class
ParameterList Members


PlainTextSQLBuilder Class

PlainTextSQLBuilder Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : PlainTextSQLBuilder Class
Intended for SQL query text generation in Plain Text format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class PlainTextSQLBuilder
   Inherits BaseSQLBuilder
'Usage

Dim instance As PlainTextSQLBuilder
public class PlainTextSQLBuilder : BaseSQLBuilder
public __gc class PlainTextSQLBuilder : public BaseSQLBuilder
Remarks
Requires to get connected to the QueryBuilder object via the QueryBuilder Property. Read the SQL Property to get formatted SQL query text.
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSQLBuilder
ActiveDatabaseSoftware.ActiveQueryBuilder.PlainTextSQLBuilder

Requirements

See Also

Reference

PlainTextSQLBuilder Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


PlainTextSQLBuilder Class Members

PlainTextSQLBuilder Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : PlainTextSQLBuilder Class

The following tables list the members exposed by PlainTextSQLBuilder.

Public Properties
 | Name | Description
Public Property | DynamicIndents | Allows to indent the next item in the list to the same position as the first item.
Public Property | DynamicRightMargin | Instructs the component not to take into account leading spaces when counting line lenght to wrap.
Top
See Also

Reference

PlainTextSQLBuilder Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


PlainTextSQLBuilder Class Properties

PlainTextSQLBuilder Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : PlainTextSQLBuilder Class

For a list of all members of this type, see PlainTextSQLBuilder members.

Public Properties
 | Name | Description
Public Property | DynamicIndents | Allows to indent the next item in the list to the same position as the first item.
Public Property | DynamicRightMargin | Instructs the component not to take into account leading spaces when counting line lenght to wrap.
Top
See Also

Reference

PlainTextSQLBuilder Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


DynamicIndents Property

DynamicIndents Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PlainTextSQLBuilder Class : DynamicIndents Property
Allows to indent the next item in the list to the same position as the first item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DynamicIndents As System.Boolean
'Usage

Dim instance As PlainTextSQLBuilder
Dim value As System.Boolean

instance.DynamicIndents = value

value = instance.DynamicIndents
public System.bool DynamicIndents {get; set;}
public: __property System.bool get_DynamicIndents();
public: __property void set_DynamicIndents(
   System.bool value
);
Requirements

See Also

Reference

PlainTextSQLBuilder Class
PlainTextSQLBuilder Members


DynamicRightMargin Property

DynamicRightMargin Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PlainTextSQLBuilder Class : DynamicRightMargin Property
Instructs the component not to take into account leading spaces when counting line lenght to wrap.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DynamicRightMargin As System.Boolean
'Usage

Dim instance As PlainTextSQLBuilder
Dim value As System.Boolean

instance.DynamicRightMargin = value

value = instance.DynamicRightMargin
public System.bool DynamicRightMargin {get; set;}
public: __property System.bool get_DynamicRightMargin();
public: __property void set_DynamicRightMargin(
   System.bool value
);
Requirements

See Also

Reference

PlainTextSQLBuilder Class
PlainTextSQLBuilder Members


PostgreSQLSyntaxProvider Class

PostgreSQLSyntaxProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : PostgreSQLSyntaxProvider Class
Syntax provider for PostgreSQL.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class PostgreSQLSyntaxProvider
   Inherits BaseSyntaxProvider
'Usage

Dim instance As PostgreSQLSyntaxProvider
public class PostgreSQLSyntaxProvider : BaseSyntaxProvider
public __gc class PostgreSQLSyntaxProvider : public BaseSyntaxProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.PostgreSQLSyntaxProvider

Requirements

See Also

Reference

PostgreSQLSyntaxProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


PostgreSQLSyntaxProvider Class Members

PostgreSQLSyntaxProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : PostgreSQLSyntaxProvider Class

The following tables list the members exposed by PostgreSQLSyntaxProvider.

Public Properties
 | Name | Description
Public Property | ComparisonOperators | Lists the user-defined binary (comparison) operators. See PostgreSQL help for details.
Public Property | DenyIntoClause | Overridden. Instructs to deny the INTO clause parsing and generation.
Public Property | IdentCaseSens | Overridden. Defines the way database server treats quoted and unquoted identifiers.
Top
Public Methods
 | Name | Description
Public Method | GetReferencingObjectNames | Overridden.
Top
See Also

Reference

PostgreSQLSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


PostgreSQLSyntaxProvider Class Methods

PostgreSQLSyntaxProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : PostgreSQLSyntaxProvider Class

For a list of all members of this type, see PostgreSQLSyntaxProvider members.

Public Methods
 | Name | Description
Public Method | GetReferencingObjectNames | Overridden.
Top
See Also

Reference

PostgreSQLSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


GetReferencingObjectNames Method (PostgreSQLSyntaxProvider)

GetReferencingObjectNames Method (PostgreSQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLSyntaxProvider Class : GetReferencingObjectNames Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Function GetReferencingObjectNames( _
   ByVal list As UpdatableObjectList(Of MetadataQualifiedName), _
   ByVal forObject As MetadataObject, _
   ByVal loadingOptions As MetadataLoadingOptions _
) As System.Boolean
'Usage

Dim instance As PostgreSQLSyntaxProvider
Dim list As UpdatableObjectList(Of MetadataQualifiedName)
Dim forObject As MetadataObject
Dim loadingOptions As MetadataLoadingOptions
Dim value As System.Boolean

value = instance.GetReferencingObjectNames(list, forObject, loadingOptions)
public override System.bool GetReferencingObjectNames(
   UpdatableObjectList<MetadataQualifiedName> list,
   MetadataObject forObject,
   MetadataLoadingOptions loadingOptions
)
public: System.bool GetReferencingObjectNames(
   UpdatableObjectList<MetadataQualifiedName*>* list,
   MetadataObject* forObject,
   MetadataLoadingOptions* loadingOptions
) override

Parameters

list
forObject
loadingOptions
Requirements

See Also

Reference

PostgreSQLSyntaxProvider Class
PostgreSQLSyntaxProvider Members
Base Implementation in GetReferencingObjectNames


PostgreSQLSyntaxProvider Class Properties

PostgreSQLSyntaxProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : PostgreSQLSyntaxProvider Class

For a list of all members of this type, see PostgreSQLSyntaxProvider members.

Public Properties
 | Name | Description
Public Property | ComparisonOperators | Lists the user-defined binary (comparison) operators. See PostgreSQL help for details.
Public Property | DenyIntoClause | Overridden. Instructs to deny the INTO clause parsing and generation.
Public Property | IdentCaseSens | Overridden. Defines the way database server treats quoted and unquoted identifiers.
Top
See Also

Reference

PostgreSQLSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


ComparisonOperators Property

ComparisonOperators Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLSyntaxProvider Class : ComparisonOperators Property
Lists the user-defined binary (comparison) operators. See PostgreSQL help for details.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ComparisonOperators As System.Collections.Generic.List(Of String)
'Usage

Dim instance As PostgreSQLSyntaxProvider
Dim value As System.Collections.Generic.List(Of String)

instance.ComparisonOperators = value

value = instance.ComparisonOperators
public System.Collections.Generic.List<string> ComparisonOperators {get; set;}
public: __property System.Collections.Generic.List<string*>* get_ComparisonOperators();
public: __property void set_ComparisonOperators(
   System.Collections.Generic.List<string*>* value
);
Requirements

See Also

Reference

PostgreSQLSyntaxProvider Class
PostgreSQLSyntaxProvider Members


DenyIntoClause Property (PostgreSQLSyntaxProvider)

DenyIntoClause Property (PostgreSQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLSyntaxProvider Class : DenyIntoClause Property
Instructs to deny the INTO clause parsing and generation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property DenyIntoClause As System.Boolean
'Usage

Dim instance As PostgreSQLSyntaxProvider
Dim value As System.Boolean

instance.DenyIntoClause = value

value = instance.DenyIntoClause
public override System.bool DenyIntoClause {get; set;}
public: __property System.bool get_DenyIntoClause() override;
public: __property void set_DenyIntoClause(
   System.bool value
) override;
Requirements

See Also

Reference

PostgreSQLSyntaxProvider Class
PostgreSQLSyntaxProvider Members
Base Implementation in DenyIntoClause


IdentCaseSens Property (PostgreSQLSyntaxProvider)

IdentCaseSens Property (PostgreSQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLSyntaxProvider Class : IdentCaseSens Property
Defines the way database server treats quoted and unquoted identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property IdentCaseSens As IdentCaseSensitivity
'Usage

Dim instance As PostgreSQLSyntaxProvider
Dim value As IdentCaseSensitivity

instance.IdentCaseSens = value

value = instance.IdentCaseSens
public override IdentCaseSensitivity IdentCaseSens {get; set;}
public: __property IdentCaseSensitivity get_IdentCaseSens() override;
public: __property void set_IdentCaseSens(
   IdentCaseSensitivity value
) override;
Requirements

See Also

Reference

PostgreSQLSyntaxProvider Class
PostgreSQLSyntaxProvider Members
Base Implementation in IdentCaseSens


QueryBuilder Class

QueryBuilder Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : QueryBuilder Class
QueryBuilder is the component to build SQL queries visually, to parse, analyze and modify SQL queries programmatically.
Object Model
QueryBuilder ClassAddObjectFormOptions ClassBehaviorOptions ClassDatabaseSchemaTreeOptions ClassDataSourceOptions ClassDesignPaneOptions ClassMetadataContainer ClassMetadataLoadingOptions ClassBaseMetadataProvider ClassMetadataStructure ClassMetadataStructureOptions ClassPanesConfigurationOptions ClassParameterList ClassParameter ClassQueryColumnListOptions ClassQueryStatistics ClassQueryStructureTreeOptions ClassBaseSQLContext ClassSQLGenerationOptions ClassBaseSyntaxProvider ClassVisualOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class QueryBuilder
   Inherits System.Windows.Forms.UserControl
'Usage

Dim instance As QueryBuilder
public class QueryBuilder : System.Windows.Forms.UserControl
public __gc class QueryBuilder : public System.Windows.Forms.UserControl
Remarks

QueryBuilder requires a Syntax Provider to be assigned to the QueryBuilder.SyntaxProvider property. Metadata Provider assigned to the QueryBuilder.MetadataProvider property is necessary to load database schema information from database. Alternate way to load database schema is to use pre-generated XML files. See the MetadataContainer.ImportFromXML method for details. After that the InitializeDatabaseSchemaTree method should be called.

To get the result SQL query string, use the QueryBuilder.SQL property. Use the PlainTextSQLBuilder component to get the formatted SQL query text.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
ActiveDatabaseSoftware.ActiveQueryBuilder.QueryBuilder

Requirements

See Also

Reference

QueryBuilder Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


QueryBuilder Class Members

QueryBuilder Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : QueryBuilder Class

The following tables list the members exposed by QueryBuilder.

Public Constructors
 | Name | Description
Public Constructor | QueryBuilder Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ActiveSubQuery | Provides access to the currently visible to end-user sub-query.
Public Property | AddObjectFormOptions | Determines appearance of the Add Object Form.
Public Property | BehaviorOptions | Allows you to tune the way Active Query Builder parses and builds SQL queries.
Public Property | DatabaseSchemaTree | Returns an interface to the Database Schema Tree View control.
Public Property | DatabaseSchemaTreeOptions | Contains various properties of the Database Schema Tree control.
Public Property | DataSourceOptions | Contains various properties of the Design Pane.
static (Shared in Visual Basic) | DefaultImageList | Gets the list of default icons.
Public Property | DesignPaneOptions | Determines appearance of the objects within the Design Pane.
Public Property | ExpressionEditor | Gets or sets a reference to the Expression Editor interface that allows to edit SQL expressions and criteria in a multi-line text editor with code auto-completion and syntax highlight.
Public Property | IsUpdating | Indicates that the component is in update mode now.
Public Property | Language | Gets or sets the language.
Public Property | LayoutSQL | Gets or sets the SQL query text among with layout, i.e. sizes and positions of objects within the Design Pane in XML format.
Public Property | MetadataContainer | Returns a reference to the Metadata Container, an object to hold information about database schema, database objects and their attributes.
Public Property | MetadataLoadingOptions | Determines rules of loading database schema information to the Metadata Container.
Public Property | MetadataProvider | Gets or sets a reference to the Metadata Provider object used to retrieve metadata from a database or from another source.
Public Property | MetadataStructure | Gets or sets the reference to the Metadata Structure object that represents the content of Metadata Container in a tree-like form.
Public Property | MetadataStructureOptions | Contains various properties that affect on displaying of the Metadata Structure.
Public Property | OfflineMode | Allows to switch the component between normal and "Offline" modes.
static (Shared in Visual Basic) | OverrideDevExpressThemeColors | Gets or sets a value indicating whether to override DevExpress controls theme colors.
Public Property | PanesConfigurationOptions | Allows you to configure layout of the main parts of the component: Design Pane, Query Columns List, Database Schema Tree and Query Structure Tree.
Public Property | Parameters | Allows to retrieve information about parameters that were used in the query.
Public Property | Query | Provides access to the main Query object.
Public Property | QueryColumnListOptions | Contains various properties of the Query Column List control.
Public Property | QueryStatistics | Allows to retrieve various information about the query: list of used database objects and their fields, list of output query columns.
Public Property | QueryStructureTree | Returns an interface to the Query Structure Tree View control.
Public Property | QueryStructureTreeOptions | Contains various properties of the Query Structure Tree.
Public Property | ResultQueryAST | Gets the abstract sytnax tree of result SQL query.
Public Property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
Public Property | SleepMode | Indicates that the component is in the "Sleep" Mode.
Public Property | SQL | Use this property to get or set SQL query text in response to user actions.
Public Property | SQLContext | Determines context of the query building, parsing and SQL generation processes.
Public Property | SQLGenerationOptions | Determines SQL query text generation rules for the QueryBuilder.SQL property.
Public Property | SubQueries | Lists all sub-queries in the query.
Public Property | SyntaxProvider | Gets or sets a reference to the Syntax Provider object used to define SQL syntax rules of specific database servers.
Public Property | Tabs | Returns an interface to the Sub-Query Tab control.
static (Shared in Visual Basic) | UseDevExpressControls | Allows to switch component's visual controls from standard .NET controls to DevExpress WinForms controls.
Public Property | VisualOptions | Contains visual options that are not related to any pane.
Top
Public Methods
 | Name | Description
Public Method | BeginUpdate | Prevents the component from SQL generation until the EndUpdate method is called.
Public Method | Clear | Clears the query.
static (Shared in Visual Basic) | EditMetadataContainer | Shows the Metadata Editor form to edit content of the Metadata Container.
static (Shared in Visual Basic) | EditMetadataContainerStandalone | Shows the Metadata Editor form with the content of given MetadataContainer object in the Standalone mode, i.e. as a standalone application.
Public Method | EndUpdate | Resumes SQL generation after it was suspended by the BeginUpdate method.
Public Method | GetSubQueryList | Returns list of all sub-queries in the query.
Public Method | GetUnionSubQueryList | Returns list of all union sub-queries in the query.
Public Method | InitializeDatabaseSchemaTree | Initializes the database schema tree.
Public Method | RefreshDatasourcesMetadata | Refreshes the list of fields for datasources of the current query.
static (Shared in Visual Basic) | ShowAboutDialog | Shows the About dialog window.
Public Method | ShowAddObjectForm | Shows the Add Object Form.
static (Shared in Visual Basic) | ShowMetadataContainerLoadWizard | Displays the Metadata Container load wizard.
Public Method | ShowQueryBuilderPropertiesForm | Displays the dialog that allows to set various properties of the Query Builder and the SQL Builder components visually.
Top
Public Events
 | Name | Description
Public Event | ActiveSubQueryChanged | Invoked when currently visible sub-query is changed.
Public Event | ActiveUnionSubQueryChanged | Invoked when currently visible union sub-query is changed.
Public Event | AfterPropertiesDialog | Invoked after any of the properties dialogs (Sub-query, DataSource, Link properties) are closed.
Public Event | BeforeDatasourceFieldDrag | Invoked when the user starts to drag a DataSource Field at the Design Area.
Public Event | BeforePropertiesDialog | Invoked before any of the properties dialogs (Sub-query, DataSource, Link properties) is shown.
Public Event | ControlCreated | Invoked when a control is created inside the component.
Public Event | ControlDestroying | Invoked before the control is destroyed inside the component.
Public Event | CustomExpressionBuilder | Is called to edit SQL expression of the Expression or Criteria column cell of the Query Columns Grid when the user clicks the ellipsis button.
Public Event | CustomizeDatasourceCaption | Is called to customize the caption of a DataSource at the Design Area.
Public Event | CustomizeDatasourceFieldList | Is called to customize the field list of a DataSource at the Design Area.
Public Event | DataSourceAdded | Invoked when DataSource is added by the user.
Public Event | DataSourceAdding | Invoked when DataSource is about to be added by the user.
Public Event | DataSourceDeleting | Invoked when DataSource is about to be deleted by the user.
Public Event | DatasourceFieldAdded | Invoked when Field is added to the query by checking it at the DataSource field list.
Public Event | DatasourceFieldAdding | Invoked when Field is about to be added to the query by checking it at the DataSource field list.
Public Event | DatasourceFieldRemoved | Invoked when Field is removed from the query by unchecking it at the DataSource field list.
Public Event | DatasourceFieldRemoving | Invoked when Field is about to be deleted from the query by unchecking it at the DataSource field list.
Public Event | Destroying | Occurs before the component is destroyed.
Public Event | FieldListDrawItem | Called to draw an item of the DataSource Field List.
Public Event | FocusedDesignPaneControlChanged | Occurs when a focused object at the Design Pane is changed.
Public Event | GetDiagramObjectWidth | Called to calculate width of the newly added datasource.
Public Event | GetProcedureParameters | Fired when the component requests parameter values for stored procedure or function.
Public Event | GridCellValueChanged | Invoked when one of the Query Columns Grid Control cells is changed by the user.
Public Event | GridCellValueChanging | Invoked when one of the Query Columns Grid Control cells is about to be changed by the user.
Public Event | LanguageChanged | Fired on changing the Language property.
Public Event | LinkChanged | Invoked when the Link properties are changed by the user.
Public Event | LinkChanging | Invoked when the Link properties are about to be changed by the user.
Public Event | LinkCreated | Invoked when the link between datasources is created by the user.
Public Event | LinkCreating | Invoked when the link between two datasources is about to be created by the user.
Public Event | LinkDeleting | Invoked when the link between datasources is about to be deleted by the user.
Public Event | LinkDragOver | Invoked when the user drags a DataSource Field over the other DataSource Field to create a link between these fields.
Public Event | QueryAwake | Occurs when the component is currently in the "Sleep" mode and the user starts to build a query visually.
Public Event | SleepModeChanged | Invoked when the component is turns the "Sleep" mode on and off.
Public Event | SqlError | Invoked on SQL text parsing error.
Public Event | SQLUpdated | Occurs each time the component updates the output SQL query text.
Public Event | UserMessage | Fired when the component is about to show the warning message to the user.
Public Event | ValidateContextMenu | Is called before any of the component's context menus is shown.
Top
See Also

Reference

QueryBuilder Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


QueryBuilder Constructor

QueryBuilder Constructor

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : QueryBuilder Constructor
Overload List
Overload | Description
QueryBuilder Constructor() | Initializes a new instance of the QueryBuilder component in default mode.
QueryBuilder Constructor(Boolean) | Initializes a new instance of the QueryBuilder component in Visual or Non-visual mode. (for WinForms configuration only)
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


QueryBuilder Constructor()

QueryBuilder Constructor()

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > QueryBuilder Constructor : QueryBuilder Constructor()
Initializes a new instance of the QueryBuilder component in default mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function New()
'Usage

Dim instance As New QueryBuilder()
public QueryBuilder()
public: QueryBuilder();
Remarks
The default QueryBuilder initialization mode is Visual for WinForms configuration and Non-visual for ASP.NET configuration.
In the WinForms configuration the QueryBuilder component can be used for any purposes in Visual mode (including visual building of queries) and it must be placed on a form.
In the ASP.NET configuration the QueryBuilder component is responsible for SQL parsing and generation only, thus it can not be initialized in visual mode.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


QueryBuilder Constructor(Boolean)

QueryBuilder Constructor(Boolean)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > QueryBuilder Constructor : QueryBuilder Constructor(Boolean)
true to initialize in non-visual mode, false to initialize in visual mode.
Initializes a new instance of the QueryBuilder component in Visual or Non-visual mode. (for WinForms configuration only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function New( _
   ByVal nonVisualMode As System.Boolean _
)
'Usage

Dim nonVisualMode As System.Boolean

Dim instance As New QueryBuilder(nonVisualMode)
public QueryBuilder(
   System.bool nonVisualMode
)
public: QueryBuilder(
   System.bool nonVisualMode
)

Parameters

nonVisualMode
true to initialize in non-visual mode, false to initialize in visual mode.
Remarks
In the Non-visual mode the QueryBuilder component does not create any WinForms controls and it can not be used for visual query building purposes. Use this mode to parse, analyze, modify SQL queries programmatically or to create them from scratch.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


QueryBuilder Class Methods

QueryBuilder Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : QueryBuilder Class

For a list of all members of this type, see QueryBuilder members.

Public Methods
 | Name | Description
Public Method | BeginUpdate | Prevents the component from SQL generation until the EndUpdate method is called.
Public Method | Clear | Clears the query.
static (Shared in Visual Basic) | EditMetadataContainer | Shows the Metadata Editor form to edit content of the Metadata Container.
static (Shared in Visual Basic) | EditMetadataContainerStandalone | Shows the Metadata Editor form with the content of given MetadataContainer object in the Standalone mode, i.e. as a standalone application.
Public Method | EndUpdate | Resumes SQL generation after it was suspended by the BeginUpdate method.
Public Method | GetSubQueryList | Returns list of all sub-queries in the query.
Public Method | GetUnionSubQueryList | Returns list of all union sub-queries in the query.
Public Method | InitializeDatabaseSchemaTree | Initializes the database schema tree.
Public Method | RefreshDatasourcesMetadata | Refreshes the list of fields for datasources of the current query.
static (Shared in Visual Basic) | ShowAboutDialog | Shows the About dialog window.
Public Method | ShowAddObjectForm | Shows the Add Object Form.
static (Shared in Visual Basic) | ShowMetadataContainerLoadWizard | Displays the Metadata Container load wizard.
Public Method | ShowQueryBuilderPropertiesForm | Displays the dialog that allows to set various properties of the Query Builder and the SQL Builder components visually.
Top
See Also

Reference

QueryBuilder Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


BeginUpdate Method (QueryBuilder)

BeginUpdate Method (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : BeginUpdate Method
Prevents the component from SQL generation until the EndUpdate method is called.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub BeginUpdate()
'Usage

Dim instance As QueryBuilder

instance.BeginUpdate()
public void BeginUpdate()
public: void BeginUpdate();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
EndUpdate Method


Clear Method (QueryBuilder)

Clear Method (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Clear Method
Clears the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Clear()
'Usage

Dim instance As QueryBuilder

instance.Clear()
public void Clear()
public: void Clear();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


EditMetadataContainer Method

EditMetadataContainer Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : EditMetadataContainer Method
Metadata Container to be edited.
Metadata Structure to be edited.
Metadata filtration rules initially assigned at approriate step of the Metadata Loading Wizard.
Shows the Metadata Editor form to edit content of the Metadata Container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Shared Function EditMetadataContainer( _
   ByVal metadataContainer As MetadataContainer, _
   ByVal metadataStructure As MetadataStructure, _
   ByVal loadingOptions As MetadataLoadingOptions _
) As System.Boolean
'Usage

Dim metadataContainer As MetadataContainer
Dim metadataStructure As MetadataStructure
Dim loadingOptions As MetadataLoadingOptions
Dim value As System.Boolean

value = QueryBuilder.EditMetadataContainer(metadataContainer, metadataStructure, loadingOptions)
public static System.bool EditMetadataContainer(
   MetadataContainer metadataContainer,
   MetadataStructure metadataStructure,
   MetadataLoadingOptions loadingOptions
)
public: static System.bool EditMetadataContainer(
   MetadataContainer* metadataContainer,
   MetadataStructure* metadataStructure,
   MetadataLoadingOptions* loadingOptions
)

Parameters

metadataContainer
Metadata Container to be edited.
metadataStructure
Metadata Structure to be edited.
loadingOptions
Metadata filtration rules initially assigned at approriate step of the Metadata Loading Wizard.

Return Value

true if OK button is pressed, otherwise false.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


EditMetadataContainerStandalone Method

EditMetadataContainerStandalone Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : EditMetadataContainerStandalone Method
Metadata Container to be edited.
Metadata Structure to be edited.
Shows the Metadata Editor form with the content of given MetadataContainer object in the Standalone mode, i.e. as a standalone application.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Shared Function EditMetadataContainerStandalone( _
   ByVal metadataContainer As MetadataContainer, _
   ByVal metadataStructure As MetadataStructure _
) As System.Boolean
'Usage

Dim metadataContainer As MetadataContainer
Dim metadataStructure As MetadataStructure
Dim value As System.Boolean

value = QueryBuilder.EditMetadataContainerStandalone(metadataContainer, metadataStructure)
public static System.bool EditMetadataContainerStandalone(
   MetadataContainer metadataContainer,
   MetadataStructure metadataStructure
)
public: static System.bool EditMetadataContainerStandalone(
   MetadataContainer* metadataContainer,
   MetadataStructure* metadataStructure
)

Parameters

metadataContainer
Metadata Container to be edited.
metadataStructure
Metadata Structure to be edited.
Remarks
In the Standalone mode the Metadata Editor window has an icon and minimize button and it is visible at the taskbar.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
EditMetadataContainer Method


EndUpdate Method (QueryBuilder)

EndUpdate Method (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : EndUpdate Method
Resumes SQL generation after it was suspended by the BeginUpdate method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub EndUpdate()
'Usage

Dim instance As QueryBuilder

instance.EndUpdate()
public void EndUpdate()
public: void EndUpdate();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
EndUpdate Method


GetSubQueryList Method

GetSubQueryList Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : GetSubQueryList Method
Returns list of all sub-queries in the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetSubQueryList() As System.Collections.Generic.IList(Of SubQuery)
'Usage

Dim instance As QueryBuilder
Dim value As System.Collections.Generic.IList(Of SubQuery)

value = instance.GetSubQueryList()
public System.Collections.Generic.IList<SubQuery> GetSubQueryList()
public: System.Collections.Generic.IList<SubQuery*>* GetSubQueryList();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


GetUnionSubQueryList Method

GetUnionSubQueryList Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : GetUnionSubQueryList Method
Returns list of all union sub-queries in the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetUnionSubQueryList() As System.Collections.Generic.List(Of UnionSubQuery)
'Usage

Dim instance As QueryBuilder
Dim value As System.Collections.Generic.List(Of UnionSubQuery)

value = instance.GetUnionSubQueryList()
public System.Collections.Generic.List<UnionSubQuery> GetUnionSubQueryList()
public: System.Collections.Generic.List<UnionSubQuery*>* GetUnionSubQueryList();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


InitializeDatabaseSchemaTree Method

InitializeDatabaseSchemaTree Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : InitializeDatabaseSchemaTree Method
Initializes the database schema tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub InitializeDatabaseSchemaTree()
'Usage

Dim instance As QueryBuilder

instance.InitializeDatabaseSchemaTree()
public void InitializeDatabaseSchemaTree()
public: void InitializeDatabaseSchemaTree();
Remarks

This method should be called after the SyntaxProvider and MetadataProvider properties are set to the right instances of appropriate objects.

It initializes the current Metadata Structure, i.e. unbinds it's items if they were bound and binds the root structure node. After that is expands the Database Schema Tree according to the DatabaseSchemaTreeOptions.DefaultExpandLevel property.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


RefreshDatasourcesMetadata() Method

RefreshDatasourcesMetadata() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : RefreshDatasourcesMetadata() Method
Refreshes the list of fields for datasources of the current query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub RefreshDatasourcesMetadata()
'Usage

Dim instance As QueryBuilder

instance.RefreshDatasourcesMetadata()
public void RefreshDatasourcesMetadata()
public: void RefreshDatasourcesMetadata();
Remarks
Useful when metadata is loaded in another thread to update the loaded query after the metadata loading process is finished.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ShowAboutDialog Method

ShowAboutDialog Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ShowAboutDialog Method
Shows the About dialog window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Shared Sub ShowAboutDialog()
'Usage

QueryBuilder.ShowAboutDialog()
public static void ShowAboutDialog()
public: static void ShowAboutDialog();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ShowAddObjectForm Method

ShowAddObjectForm Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ShowAddObjectForm Method
Shows the Add Object Form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ShowAddObjectForm()
'Usage

Dim instance As QueryBuilder

instance.ShowAddObjectForm()
public void ShowAddObjectForm()
public: void ShowAddObjectForm();
Remarks
Add Object Form is intended to add database objects to the query. The user may open this form by right-clicking on the Design Pane and selecting the appropriate item from context menu.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
AddObjectFormOptions Property


ShowMetadataContainerLoadWizard Method

ShowMetadataContainerLoadWizard Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ShowMetadataContainerLoadWizard Method
Displays the Metadata Container load wizard.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Shared Function ShowMetadataContainerLoadWizard( _
   ByVal metadataContainer As MetadataContainer, _
   ByVal loadingOptions As MetadataLoadingOptions _
) As System.Boolean
'Usage

Dim metadataContainer As MetadataContainer
Dim loadingOptions As MetadataLoadingOptions
Dim value As System.Boolean

value = QueryBuilder.ShowMetadataContainerLoadWizard(metadataContainer, loadingOptions)
public static System.bool ShowMetadataContainerLoadWizard(
   MetadataContainer metadataContainer,
   MetadataLoadingOptions loadingOptions
)
public: static System.bool ShowMetadataContainerLoadWizard(
   MetadataContainer* metadataContainer,
   MetadataLoadingOptions* loadingOptions
)

Parameters

metadataContainer
loadingOptions
Remarks

Metadata Container load wizard allows the end-user to establish connection to a database and to fetch metadata from it.

This wizard was intended to be called from the Metadata Container Editor that is called by the EditMetadataContainer method.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ShowQueryBuilderPropertiesForm Method

ShowQueryBuilderPropertiesForm Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ShowQueryBuilderPropertiesForm Method
Dialog title.
Flags to display dialog tabs: Non-visual, visual properties of the QueryBuilder and properties of the SQL builder object specified by the builder parameter.
SQL Builder object to change it's properties.
Displays the dialog that allows to set various properties of the Query Builder and the SQL Builder components visually.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ShowQueryBuilderPropertiesForm( _
   ByVal title As System.String, _
   ByVal flags As QueryBuilderProperties, _
   ByVal builder As BaseSQLBuilder _
)
'Usage

Dim instance As QueryBuilder
Dim title As System.String
Dim flags As QueryBuilderProperties
Dim builder As BaseSQLBuilder

instance.ShowQueryBuilderPropertiesForm(title, flags, builder)
public void ShowQueryBuilderPropertiesForm(
   System.string title,
   QueryBuilderProperties flags,
   BaseSQLBuilder builder
)
public: void ShowQueryBuilderPropertiesForm(
   System.string* title,
   QueryBuilderProperties flags,
   BaseSQLBuilder* builder
)

Parameters

title
Dialog title.
flags
Flags to display dialog tabs: Non-visual, visual properties of the QueryBuilder and properties of the SQL builder object specified by the builder parameter.
builder
SQL Builder object to change it's properties.
Remarks
The dialog groups properties into three tabs. Each tab can be hidden by switching the appropriate flag off.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


QueryBuilder Class Properties

QueryBuilder Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : QueryBuilder Class

For a list of all members of this type, see QueryBuilder members.

Public Properties
 | Name | Description
Public Property | ActiveSubQuery | Provides access to the currently visible to end-user sub-query.
Public Property | AddObjectFormOptions | Determines appearance of the Add Object Form.
Public Property | BehaviorOptions | Allows you to tune the way Active Query Builder parses and builds SQL queries.
Public Property | DatabaseSchemaTree | Returns an interface to the Database Schema Tree View control.
Public Property | DatabaseSchemaTreeOptions | Contains various properties of the Database Schema Tree control.
Public Property | DataSourceOptions | Contains various properties of the Design Pane.
static (Shared in Visual Basic) | DefaultImageList | Gets the list of default icons.
Public Property | DesignPaneOptions | Determines appearance of the objects within the Design Pane.
Public Property | ExpressionEditor | Gets or sets a reference to the Expression Editor interface that allows to edit SQL expressions and criteria in a multi-line text editor with code auto-completion and syntax highlight.
Public Property | IsUpdating | Indicates that the component is in update mode now.
Public Property | Language | Gets or sets the language.
Public Property | LayoutSQL | Gets or sets the SQL query text among with layout, i.e. sizes and positions of objects within the Design Pane in XML format.
Public Property | MetadataContainer | Returns a reference to the Metadata Container, an object to hold information about database schema, database objects and their attributes.
Public Property | MetadataLoadingOptions | Determines rules of loading database schema information to the Metadata Container.
Public Property | MetadataProvider | Gets or sets a reference to the Metadata Provider object used to retrieve metadata from a database or from another source.
Public Property | MetadataStructure | Gets or sets the reference to the Metadata Structure object that represents the content of Metadata Container in a tree-like form.
Public Property | MetadataStructureOptions | Contains various properties that affect on displaying of the Metadata Structure.
Public Property | OfflineMode | Allows to switch the component between normal and "Offline" modes.
static (Shared in Visual Basic) | OverrideDevExpressThemeColors | Gets or sets a value indicating whether to override DevExpress controls theme colors.
Public Property | PanesConfigurationOptions | Allows you to configure layout of the main parts of the component: Design Pane, Query Columns List, Database Schema Tree and Query Structure Tree.
Public Property | Parameters | Allows to retrieve information about parameters that were used in the query.
Public Property | Query | Provides access to the main Query object.
Public Property | QueryColumnListOptions | Contains various properties of the Query Column List control.
Public Property | QueryStatistics | Allows to retrieve various information about the query: list of used database objects and their fields, list of output query columns.
Public Property | QueryStructureTree | Returns an interface to the Query Structure Tree View control.
Public Property | QueryStructureTreeOptions | Contains various properties of the Query Structure Tree.
Public Property | ResultQueryAST | Gets the abstract sytnax tree of result SQL query.
Public Property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
Public Property | SleepMode | Indicates that the component is in the "Sleep" Mode.
Public Property | SQL | Use this property to get or set SQL query text in response to user actions.
Public Property | SQLContext | Determines context of the query building, parsing and SQL generation processes.
Public Property | SQLGenerationOptions | Determines SQL query text generation rules for the QueryBuilder.SQL property.
Public Property | SubQueries | Lists all sub-queries in the query.
Public Property | SyntaxProvider | Gets or sets a reference to the Syntax Provider object used to define SQL syntax rules of specific database servers.
Public Property | Tabs | Returns an interface to the Sub-Query Tab control.
static (Shared in Visual Basic) | UseDevExpressControls | Allows to switch component's visual controls from standard .NET controls to DevExpress WinForms controls.
Public Property | VisualOptions | Contains visual options that are not related to any pane.
Top
See Also

Reference

QueryBuilder Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


ActiveSubQuery Property

ActiveSubQuery Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ActiveSubQuery Property
Provides access to the currently visible to end-user sub-query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ActiveSubQuery As SubQuery
'Usage

Dim instance As QueryBuilder
Dim value As SubQuery

instance.ActiveSubQuery = value

value = instance.ActiveSubQuery
public SubQuery ActiveSubQuery {get; set;}
public: __property SubQuery* get_ActiveSubQuery();
public: __property void set_ActiveSubQuery(
   SubQuery* value
);
Remarks

Read the QueryBuilder.ActiveSubQuery.ActiveUnionSubQuery reference to get access to the currently active union sub-query. SubQuery object is a container for the UnionSubQuery objects joined with one of the following operators UNION, EXCEPT, INTERSECT, MINUS. A SubQuery contains single UnionSubQuery object if it doesn't have unions.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Query Property


AddObjectFormOptions Property

AddObjectFormOptions Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : AddObjectFormOptions Property
Determines appearance of the Add Object Form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AddObjectFormOptions As AddObjectFormOptions
'Usage

Dim instance As QueryBuilder
Dim value As AddObjectFormOptions

instance.AddObjectFormOptions = value

value = instance.AddObjectFormOptions
public AddObjectFormOptions AddObjectFormOptions {get; set;}
public: __property AddObjectFormOptions* get_AddObjectFormOptions();
public: __property void set_AddObjectFormOptions(
   AddObjectFormOptions* value
);
Remarks
The Add Object Form allows you to add objects (database objects and CTE) to the query. You may call it using the ShowAddObjectForm method. The user may open this form using Design Pane context menu. You may disable this form completely using the FormEnabled property.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


BehaviorOptions Property

BehaviorOptions Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : BehaviorOptions Property
Allows you to tune the way Active Query Builder parses and builds SQL queries.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property BehaviorOptions As BehaviorOptions
'Usage

Dim instance As QueryBuilder
Dim value As BehaviorOptions

instance.BehaviorOptions = value

value = instance.BehaviorOptions
public BehaviorOptions BehaviorOptions {get; set;}
public: __property BehaviorOptions* get_BehaviorOptions();
public: __property void set_BehaviorOptions(
   BehaviorOptions* value
);
Remarks
The ParsingErrorOnUnknownObjects and AllowSleepMode properties determine the way Active Query Builder process SQL query parsing errors.
The CreateLinksFromForeignKeys and LinkManipulations properties define rules of working with links (joins) between query objects.
The AddLinkedObjects and DeleteUnusedObjects properties allow you to automate addition of necessary query objects and removing of needless ones.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
SQLGenerationOptions Property


DatabaseSchemaTree Property

DatabaseSchemaTree Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DatabaseSchemaTree Property
Returns an interface to the Database Schema Tree View control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property DatabaseSchemaTree As ICustomTreeView
'Usage

Dim instance As QueryBuilder
Dim value As ICustomTreeView

value = instance.DatabaseSchemaTree
public ICustomTreeView DatabaseSchemaTree {get;}
public: __property ICustomTreeView* get_DatabaseSchemaTree();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


DatabaseSchemaTreeOptions Property

DatabaseSchemaTreeOptions Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DatabaseSchemaTreeOptions Property
Contains various properties of the Database Schema Tree control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DatabaseSchemaTreeOptions As DatabaseSchemaTreeOptions
'Usage

Dim instance As QueryBuilder
Dim value As DatabaseSchemaTreeOptions

instance.DatabaseSchemaTreeOptions = value

value = instance.DatabaseSchemaTreeOptions
public DatabaseSchemaTreeOptions DatabaseSchemaTreeOptions {get; set;}
public: __property DatabaseSchemaTreeOptions* get_DatabaseSchemaTreeOptions();
public: __property void set_DatabaseSchemaTreeOptions(
   DatabaseSchemaTreeOptions* value
);
Remarks
Use the MetadataStructureOptions to organize objects within the Database Schema Tree the way you need.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
QueryStructureTreeOptions Property


DataSourceOptions Property

DataSourceOptions Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DataSourceOptions Property
Contains various properties of the Design Pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DataSourceOptions As DataSourceOptions
'Usage

Dim instance As QueryBuilder
Dim value As DataSourceOptions

instance.DataSourceOptions = value

value = instance.DataSourceOptions
public DataSourceOptions DataSourceOptions {get; set;}
public: __property DataSourceOptions* get_DataSourceOptions();
public: __property void set_DataSourceOptions(
   DataSourceOptions* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
DesignPaneOptions Property


DefaultImageList Property

DefaultImageList Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DefaultImageList Property
Gets the list of default icons.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Shared ReadOnly Property DefaultImageList As System.Windows.Forms.ImageList
'Usage

Dim value As System.Windows.Forms.ImageList

value = QueryBuilder.DefaultImageList
public static System.Windows.Forms.ImageList DefaultImageList {get;}
public: __property static System.Windows.Forms.ImageList* get_DefaultImageList();
Remarks
You may override icons in this list or you may set your own image lists via the QueryStructureTreeOptions.ImageList, the MetadataStructureOptions.ImageList and the VisualOptions.TabsImageList.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


DesignPaneOptions Property

DesignPaneOptions Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DesignPaneOptions Property
Determines appearance of the objects within the Design Pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DesignPaneOptions As DesignPaneOptions
'Usage

Dim instance As QueryBuilder
Dim value As DesignPaneOptions

instance.DesignPaneOptions = value

value = instance.DesignPaneOptions
public DesignPaneOptions DesignPaneOptions {get; set;}
public: __property DesignPaneOptions* get_DesignPaneOptions();
public: __property void set_DesignPaneOptions(
   DesignPaneOptions* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
DataSourceOptions Property


ExpressionEditor Property

ExpressionEditor Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ExpressionEditor Property
Gets or sets a reference to the Expression Editor interface that allows to edit SQL expressions and criteria in a multi-line text editor with code auto-completion and syntax highlight.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ExpressionEditor As IExpressionEditor
'Usage

Dim instance As QueryBuilder
Dim value As IExpressionEditor

instance.ExpressionEditor = value

value = instance.ExpressionEditor
public IExpressionEditor ExpressionEditor {get; set;}
public: __property IExpressionEditor* get_ExpressionEditor();
public: __property void set_ExpressionEditor(
   IExpressionEditor* value
);
Remarks
The Expression Editor editor is shipped as a part of the Professional .NET Subscription only.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


IsUpdating Property (QueryBuilder)

IsUpdating Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : IsUpdating Property
Indicates that the component is in update mode now.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property IsUpdating As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

value = instance.IsUpdating
public System.bool IsUpdating {get;}
public: __property System.bool get_IsUpdating();
Remarks
The update mode is initialzed via the BeginUodate Method and finalized via the EndUpdate Metod.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
EndUpdate Method


Language Property (QueryBuilder)

Language Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Language Property
Gets or sets the language.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Language As System.String
'Usage

Dim instance As QueryBuilder
Dim value As System.String

instance.Language = value

value = instance.Language
public System.string Language {get; set;}
public: __property System.string* get_Language();
public: __property void set_Language(
   System.string* value
);

Property Value

The language.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


LayoutSQL Property (QueryBuilder)

LayoutSQL Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : LayoutSQL Property
Gets or sets the SQL query text among with layout, i.e. sizes and positions of objects within the Design Pane in XML format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property LayoutSQL As System.String
'Usage

Dim instance As QueryBuilder
Dim value As System.String

instance.LayoutSQL = value

value = instance.LayoutSQL
public System.string LayoutSQL {get; set;}
public: __property System.string* get_LayoutSQL();
public: __property void set_LayoutSQL(
   System.string* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
SQL Property


MetadataContainer Property (QueryBuilder)

MetadataContainer Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : MetadataContainer Property
Returns a reference to the Metadata Container, an object to hold information about database schema, database objects and their attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property MetadataContainer As MetadataContainer
'Usage

Dim instance As QueryBuilder
Dim value As MetadataContainer

value = instance.MetadataContainer
public MetadataContainer MetadataContainer {get;}
public: __property MetadataContainer* get_MetadataContainer();
Remarks
Use the MetadataLoadingOptions property to limit the set of database objects loaded to the Metadata Container. You may also add and remove the items of the Metadata Container programmatically via this property.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


MetadataLoadingOptions Property

MetadataLoadingOptions Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : MetadataLoadingOptions Property
Determines rules of loading database schema information to the Metadata Container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property MetadataLoadingOptions As MetadataLoadingOptions
'Usage

Dim instance As QueryBuilder
Dim value As MetadataLoadingOptions

instance.MetadataLoadingOptions = value

value = instance.MetadataLoadingOptions
public MetadataLoadingOptions MetadataLoadingOptions {get; set;}
public: __property MetadataLoadingOptions* get_MetadataLoadingOptions();
public: __property void set_MetadataLoadingOptions(
   MetadataLoadingOptions* value
);
Remarks
Definition of these rules might be needed to limit the list of database objects displayed, as well as to reduce metadata loading time for some database servers (eg. Oracle).
Formerly named as MetadataFilter, the new option set introduces a simpler way to define metadata loading rules using ExcludeFilter and IncludeFilter mask sets and other properties, among with old way that provides higher flexibility in defining metadata filtration rules.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


MetadataProvider Property (QueryBuilder)

MetadataProvider Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : MetadataProvider Property
Gets or sets a reference to the Metadata Provider object used to retrieve metadata from a database or from another source.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property MetadataProvider As BaseMetadataProvider
'Usage

Dim instance As QueryBuilder
Dim value As BaseMetadataProvider

instance.MetadataProvider = value

value = instance.MetadataProvider
public BaseMetadataProvider MetadataProvider {get; set;}
public: __property BaseMetadataProvider* get_MetadataProvider();
public: __property void set_MetadataProvider(
   BaseMetadataProvider* value
);
Remarks

Active Query Builder has metadata providers for most popular ADO.NET drivers and a Universal metadata provider to get access to a database trough generic DBConnection object.

Metadata Provider is not the only necessary object to retrieve metadata. You should also set a reference to a Syntax Provider via the SyntaxProvider Property.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


MetadataStructure Property

MetadataStructure Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : MetadataStructure Property
Gets or sets the reference to the Metadata Structure object that represents the content of Metadata Container in a tree-like form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property MetadataStructure As MetadataStructure
'Usage

Dim instance As QueryBuilder
Dim value As MetadataStructure

instance.MetadataStructure = value

value = instance.MetadataStructure
public MetadataStructure MetadataStructure {get; set;}
public: __property MetadataStructure* get_MetadataStructure();
public: __property void set_MetadataStructure(
   MetadataStructure* value
);
Remarks

You may modify the metadata structure to group the database objects not by the physical database schema structure (database-schema-type, etc.), but define your own logical structure, i.e. group objects by theis subject area or to move the most frequently used objects to the "Favorites" folder, etc.

You may perform fine tuning of the metadata structure representation via the MetadataStructureOptions property.

You may assign custom Metadata Structure objects to this property to switch between different metadata structure representations.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


MetadataStructureOptions Property

MetadataStructureOptions Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : MetadataStructureOptions Property
Contains various properties that affect on displaying of the Metadata Structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property MetadataStructureOptions As MetadataStructureOptions
'Usage

Dim instance As QueryBuilder
Dim value As MetadataStructureOptions

instance.MetadataStructureOptions = value

value = instance.MetadataStructureOptions
public MetadataStructureOptions MetadataStructureOptions {get; set;}
public: __property MetadataStructureOptions* get_MetadataStructureOptions();
public: __property void set_MetadataStructureOptions(
   MetadataStructureOptions* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


OfflineMode Property (QueryBuilder)

OfflineMode Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : OfflineMode Property
Allows to switch the component between normal and "Offline" modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property OfflineMode As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

instance.OfflineMode = value

value = instance.OfflineMode
public System.bool OfflineMode {get; set;}
public: __property System.bool get_OfflineMode();
public: __property void set_OfflineMode(
   System.bool value
);
Remarks

The Offline mode is intended to suppress background query execution by the component. In normal mode the component retrieves field lists for objects used in the query and the lists of database objects by demand. Working in the Offline mode you have to provide the way to load the necessary information programmatically.

You may use the MetadataContainer.ItemMetadataLoading Event for this purpose. To decrease metadata loading time and to limit the objects visible to the end-user you may define metadata filters to limit the number of objects loaded at a time, or you may save the content of Metadata Container to the XML file and load metadata from the XML file or stream.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


OverrideDevExpressThemeColors Property

OverrideDevExpressThemeColors Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : OverrideDevExpressThemeColors Property
Gets or sets a value indicating whether to override DevExpress controls theme colors.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Shared Property OverrideDevExpressThemeColors As System.Boolean
'Usage

Dim value As System.Boolean

QueryBuilder.OverrideDevExpressThemeColors = value

value = QueryBuilder.OverrideDevExpressThemeColors
public static System.bool OverrideDevExpressThemeColors {get; set;}
public: __property static System.bool get_OverrideDevExpressThemeColors();
public: __property static void set_OverrideDevExpressThemeColors(
   System.bool value
);
Remarks
Requires ActiveDatabaseSoftware.DevExpressControlFactory assembly to activate DevExperss user interface. It is available as a part of Professional .NET Subscription only.
Requirements
DevExpress WinForms Controls
See Also

Reference

QueryBuilder Class
QueryBuilder Members


PanesConfigurationOptions Property

PanesConfigurationOptions Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : PanesConfigurationOptions Property
Allows you to configure layout of the main parts of the component: Design Pane, Query Columns List, Database Schema Tree and Query Structure Tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property PanesConfigurationOptions As PanesConfigurationOptions
'Usage

Dim instance As QueryBuilder
Dim value As PanesConfigurationOptions

instance.PanesConfigurationOptions = value

value = instance.PanesConfigurationOptions
public PanesConfigurationOptions PanesConfigurationOptions {get; set;}
public: __property PanesConfigurationOptions* get_PanesConfigurationOptions();
public: __property void set_PanesConfigurationOptions(
   PanesConfigurationOptions* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
VisualOptions Property


Parameters Property (QueryBuilder)

Parameters Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Parameters Property
Allows to retrieve information about parameters that were used in the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Parameters As ParameterList
'Usage

Dim instance As QueryBuilder
Dim value As ParameterList

value = instance.Parameters
public ParameterList Parameters {get;}
public: __property ParameterList* get_Parameters();
Remarks
List of acceptable parameter notations
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Query Property

Query Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Query Property
Provides access to the main Query object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Query As Query
'Usage

Dim instance As QueryBuilder
Dim value As Query

value = instance.Query
public Query Query {get;}
public: __property Query* get_Query();
Remarks
Using this property you may get access to the full set of internal query representation objects: sub-queries and sub-query parts.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
ActiveSubQuery Property


QueryColumnListOptions Property

QueryColumnListOptions Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : QueryColumnListOptions Property
Contains various properties of the Query Column List control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property QueryColumnListOptions As QueryColumnListOptions
'Usage

Dim instance As QueryBuilder
Dim value As QueryColumnListOptions

instance.QueryColumnListOptions = value

value = instance.QueryColumnListOptions
public QueryColumnListOptions QueryColumnListOptions {get; set;}
public: __property QueryColumnListOptions* get_QueryColumnListOptions();
public: __property void set_QueryColumnListOptions(
   QueryColumnListOptions* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


QueryStatistics Property

QueryStatistics Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : QueryStatistics Property
Allows to retrieve various information about the query: list of used database objects and their fields, list of output query columns.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property QueryStatistics As QueryStatistics
'Usage

Dim instance As QueryBuilder
Dim value As QueryStatistics

value = instance.QueryStatistics
public QueryStatistics QueryStatistics {get;}
public: __property QueryStatistics* get_QueryStatistics();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


QueryStructureTree Property

QueryStructureTree Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : QueryStructureTree Property
Returns an interface to the Query Structure Tree View control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property QueryStructureTree As ICustomTreeView
'Usage

Dim instance As QueryBuilder
Dim value As ICustomTreeView

value = instance.QueryStructureTree
public ICustomTreeView QueryStructureTree {get;}
public: __property ICustomTreeView* get_QueryStructureTree();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
DatabaseSchemaTree Property


QueryStructureTreeOptions Property

QueryStructureTreeOptions Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : QueryStructureTreeOptions Property
Contains various properties of the Query Structure Tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property QueryStructureTreeOptions As QueryStructureTreeOptions
'Usage

Dim instance As QueryBuilder
Dim value As QueryStructureTreeOptions

instance.QueryStructureTreeOptions = value

value = instance.QueryStructureTreeOptions
public QueryStructureTreeOptions QueryStructureTreeOptions {get; set;}
public: __property QueryStructureTreeOptions* get_QueryStructureTreeOptions();
public: __property void set_QueryStructureTreeOptions(
   QueryStructureTreeOptions* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ResultQueryAST Property

ResultQueryAST Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ResultQueryAST Property
Gets the abstract sytnax tree of result SQL query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ResultQueryAST As SQLSelectStatement
'Usage

Dim instance As QueryBuilder
Dim value As SQLSelectStatement

value = instance.ResultQueryAST
public SQLSelectStatement ResultQueryAST {get;}
public: __property SQLSelectStatement* get_ResultQueryAST();
Remarks
The abstract syntax tree is a lowest query representation level that treats SQL query as a set of tokens. Higher level of the query representation objects is avaialble via the Query property.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


RightToLeftLayout Property

RightToLeftLayout Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : RightToLeftLayout Property
Gets or sets a value indicating whether right-to-left mirror placement is turned on.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property RightToLeftLayout As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

instance.RightToLeftLayout = value

value = instance.RightToLeftLayout
public virtual System.bool RightToLeftLayout {get; set;}
public: __property virtual System.bool get_RightToLeftLayout();
public: __property virtual void set_RightToLeftLayout(
   System.bool value
);

Property Value

true if right-to-left mirror placement is turned on; otherwise, false for standard child control placement. The default is false.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


SleepMode Property

SleepMode Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : SleepMode Property
Indicates that the component is in the "Sleep" Mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property SleepMode As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

value = instance.SleepMode
public System.bool SleepMode {get;}
public: __property System.bool get_SleepMode();
Remarks
In the Sleep mode the component suppresses parsing errors on unsupported SQL statements to allow writing them by hand in the text editor.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
BehaviorOptions.AllowSleepMode


SQL Property (QueryBuilder)

SQL Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : SQL Property
Use this property to get or set SQL query text in response to user actions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SQL As System.String
'Usage

Dim instance As QueryBuilder
Dim value As System.String

instance.SQL = value

value = instance.SQL
public System.string SQL {get; set;}
public: __property System.string* get_SQL();
public: __property void set_SQL(
   System.string* value
);
Remarks

Write this property to parse a query and to represent it visually. Read this property to retrieve SQL text to execute against a database server.

You should not use this property to obtain SQL text after programmatic modification of the query, but use the SyncSQL Property instead because changes to the SQL property are applied after visualization of the query, i.e. at the next message cycle. This was made to avoid message conflicts between the SQL text editor and the Query Builder on combining visual query building with direct SQL text editing.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
SyncSQL
SQLUpdated Event


SQLContext Property (QueryBuilder)

SQLContext Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : SQLContext Property
Determines context of the query building, parsing and SQL generation processes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property SQLContext As BaseSQLContext
'Usage

Dim instance As QueryBuilder
Dim value As BaseSQLContext

value = instance.SQLContext
public BaseSQLContext SQLContext {get;}
public: __property BaseSQLContext* get_SQLContext();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


SQLGenerationOptions Property

SQLGenerationOptions Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : SQLGenerationOptions Property
Determines SQL query text generation rules for the QueryBuilder.SQL property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SQLGenerationOptions As SQLGenerationOptions
'Usage

Dim instance As QueryBuilder
Dim value As SQLGenerationOptions

instance.SQLGenerationOptions = value

value = instance.SQLGenerationOptions
public SQLGenerationOptions SQLGenerationOptions {get; set;}
public: __property SQLGenerationOptions* get_SQLGenerationOptions();
public: __property void set_SQLGenerationOptions(
   SQLGenerationOptions* value
);
Remarks
SQL Generation Options control the display of object names and expressions during the visual query building process (see the ObjectPrefixSkipping, QuoteAllIdentifiers and UseAltNames properties).
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


SubQueries Property

SubQueries Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : SubQueries Property
Lists all sub-queries in the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property SubQueries As SubQueryList
'Usage

Dim instance As QueryBuilder
Dim value As SubQueryList

value = instance.SubQueries
public SubQueryList SubQueries {get;}
public: __property SubQueryList* get_SubQueries();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Query Property


SyntaxProvider Property (QueryBuilder)

SyntaxProvider Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : SyntaxProvider Property
Gets or sets a reference to the Syntax Provider object used to define SQL syntax rules of specific database servers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SyntaxProvider As BaseSyntaxProvider
'Usage

Dim instance As QueryBuilder
Dim value As BaseSyntaxProvider

instance.SyntaxProvider = value

value = instance.SyntaxProvider
public BaseSyntaxProvider SyntaxProvider {get; set;}
public: __property BaseSyntaxProvider* get_SyntaxProvider();
public: __property void set_SyntaxProvider(
   BaseSyntaxProvider* value
);
Remarks
Syntax Provider is also used to define SQL statements intended for metadata retrieval process.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
MetadataProvider Property


Tabs Property

Tabs Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Tabs Property
Returns an interface to the Sub-Query Tab control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Tabs As ICustomTabControl
'Usage

Dim instance As QueryBuilder
Dim value As ICustomTabControl

value = instance.Tabs
public ICustomTabControl Tabs {get;}
public: __property ICustomTabControl* get_Tabs();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


UseDevExpressControls Property

UseDevExpressControls Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : UseDevExpressControls Property
Allows to switch component's visual controls from standard .NET controls to DevExpress WinForms controls.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Shared Property UseDevExpressControls As System.Boolean
'Usage

Dim value As System.Boolean

QueryBuilder.UseDevExpressControls = value

value = QueryBuilder.UseDevExpressControls
public static System.bool UseDevExpressControls {get; set;}
public: __property static System.bool get_UseDevExpressControls();
public: __property static void set_UseDevExpressControls(
   System.bool value
);
Remarks
Requires ActiveDatabaseSoftware.DevExpressControlFactory assembly to activate DevExperss user interface. It is available as a part of Professional .NET Subscription only.
Requirements
DevExpress WinForms Controls
See Also

Reference

QueryBuilder Class
QueryBuilder Members


VisualOptions Property

VisualOptions Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : VisualOptions Property
Contains visual options that are not related to any pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property VisualOptions As VisualOptions
'Usage

Dim instance As QueryBuilder
Dim value As VisualOptions

instance.VisualOptions = value

value = instance.VisualOptions
public VisualOptions VisualOptions {get; set;}
public: __property VisualOptions* get_VisualOptions();
public: __property void set_VisualOptions(
   VisualOptions* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


QueryBuilder Class Events

QueryBuilder Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : QueryBuilder Class

For a list of all members of this type, see QueryBuilder members.

Public Events
 | Name | Description
Public Event | ActiveSubQueryChanged | Invoked when currently visible sub-query is changed.
Public Event | ActiveUnionSubQueryChanged | Invoked when currently visible union sub-query is changed.
Public Event | AfterPropertiesDialog | Invoked after any of the properties dialogs (Sub-query, DataSource, Link properties) are closed.
Public Event | BeforeDatasourceFieldDrag | Invoked when the user starts to drag a DataSource Field at the Design Area.
Public Event | BeforePropertiesDialog | Invoked before any of the properties dialogs (Sub-query, DataSource, Link properties) is shown.
Public Event | ControlCreated | Invoked when a control is created inside the component.
Public Event | ControlDestroying | Invoked before the control is destroyed inside the component.
Public Event | CustomExpressionBuilder | Is called to edit SQL expression of the Expression or Criteria column cell of the Query Columns Grid when the user clicks the ellipsis button.
Public Event | CustomizeDatasourceCaption | Is called to customize the caption of a DataSource at the Design Area.
Public Event | CustomizeDatasourceFieldList | Is called to customize the field list of a DataSource at the Design Area.
Public Event | DataSourceAdded | Invoked when DataSource is added by the user.
Public Event | DataSourceAdding | Invoked when DataSource is about to be added by the user.
Public Event | DataSourceDeleting | Invoked when DataSource is about to be deleted by the user.
Public Event | DatasourceFieldAdded | Invoked when Field is added to the query by checking it at the DataSource field list.
Public Event | DatasourceFieldAdding | Invoked when Field is about to be added to the query by checking it at the DataSource field list.
Public Event | DatasourceFieldRemoved | Invoked when Field is removed from the query by unchecking it at the DataSource field list.
Public Event | DatasourceFieldRemoving | Invoked when Field is about to be deleted from the query by unchecking it at the DataSource field list.
Public Event | Destroying | Occurs before the component is destroyed.
Public Event | FieldListDrawItem | Called to draw an item of the DataSource Field List.
Public Event | FocusedDesignPaneControlChanged | Occurs when a focused object at the Design Pane is changed.
Public Event | GetDiagramObjectWidth | Called to calculate width of the newly added datasource.
Public Event | GetProcedureParameters | Fired when the component requests parameter values for stored procedure or function.
Public Event | GridCellValueChanged | Invoked when one of the Query Columns Grid Control cells is changed by the user.
Public Event | GridCellValueChanging | Invoked when one of the Query Columns Grid Control cells is about to be changed by the user.
Public Event | LanguageChanged | Fired on changing the Language property.
Public Event | LinkChanged | Invoked when the Link properties are changed by the user.
Public Event | LinkChanging | Invoked when the Link properties are about to be changed by the user.
Public Event | LinkCreated | Invoked when the link between datasources is created by the user.
Public Event | LinkCreating | Invoked when the link between two datasources is about to be created by the user.
Public Event | LinkDeleting | Invoked when the link between datasources is about to be deleted by the user.
Public Event | LinkDragOver | Invoked when the user drags a DataSource Field over the other DataSource Field to create a link between these fields.
Public Event | QueryAwake | Occurs when the component is currently in the "Sleep" mode and the user starts to build a query visually.
Public Event | SleepModeChanged | Invoked when the component is turns the "Sleep" mode on and off.
Public Event | SqlError | Invoked on SQL text parsing error.
Public Event | SQLUpdated | Occurs each time the component updates the output SQL query text.
Public Event | UserMessage | Fired when the component is about to show the warning message to the user.
Public Event | ValidateContextMenu | Is called before any of the component's context menus is shown.
Top
See Also

Reference

QueryBuilder Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


ActiveSubQueryChanged Event

ActiveSubQueryChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ActiveSubQueryChanged Event
Invoked when currently visible sub-query is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ActiveSubQueryChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.ActiveSubQueryChanged, handler
public event System.EventHandler ActiveSubQueryChanged
public: __event System.EventHandler* ActiveSubQueryChanged
Example
Read the QueryBuilder.ActiveSubQuery property to get reference to the currently active sub-query.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ActiveUnionSubQueryChanged Event

ActiveUnionSubQueryChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ActiveUnionSubQueryChanged Event
Invoked when currently visible union sub-query is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ActiveUnionSubQueryChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.ActiveUnionSubQueryChanged, handler
public event System.EventHandler ActiveUnionSubQueryChanged
public: __event System.EventHandler* ActiveUnionSubQueryChanged
Example
Read the QueryBuilder.ActiveSubQuery.ActiveUnionSubQuery property to get reference to the currently active union sub-query.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


AfterPropertiesDialog Event

AfterPropertiesDialog Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : AfterPropertiesDialog Event
Invoked after any of the properties dialogs (Sub-query, DataSource, Link properties) are closed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterPropertiesDialog As AfterPropertiesDialogEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As AfterPropertiesDialogEventHandler

AddHandler instance.AfterPropertiesDialog, handler
public event AfterPropertiesDialogEventHandler AfterPropertiesDialog
public: __event AfterPropertiesDialogEventHandler* AfterPropertiesDialog
Remarks
The controlOwner parameter may be one of the following:
- UnionSubQuery in case of showing the Query Properties dialog;
- Link in case of showing the Link Properties gialog;
- DataSourceObject in case of showing the DataSource Properties dialog.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
BeforePropertiesDialog Event


BeforeDatasourceFieldDrag Event

BeforeDatasourceFieldDrag Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : BeforeDatasourceFieldDrag Event
Invoked when the user starts to drag a DataSource Field at the Design Area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeDatasourceFieldDrag As BeforeDatasourceFieldDragEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As BeforeDatasourceFieldDragEventHandler

AddHandler instance.BeforeDatasourceFieldDrag, handler
public event BeforeDatasourceFieldDragEventHandler BeforeDatasourceFieldDrag
public: __event BeforeDatasourceFieldDragEventHandler* BeforeDatasourceFieldDrag
Remarks

The field and the datasource parameters refer to the DataSource Field being dragged.

Dragging may be aborted by setting the the abort parameter to true.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
LinkDragOver Event


BeforePropertiesDialog Event

BeforePropertiesDialog Event
Example

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : BeforePropertiesDialog Event
Invoked before any of the properties dialogs (Sub-query, DataSource, Link properties) is shown.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforePropertiesDialog As BeforePropertiesDialogEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As BeforePropertiesDialogEventHandler

AddHandler instance.BeforePropertiesDialog, handler
public event BeforePropertiesDialogEventHandler BeforePropertiesDialog
public: __event BeforePropertiesDialogEventHandler* BeforePropertiesDialog
Remarks

The controlOwner parameter may be one of the following:
- UnionSubQuery in case of showing the Query Properties dialog;
- Link in case of showing the Link Properties gialog;
- DataSourceObject in case of showing the DataSource Properties dialog.

Displaying of the dialog may be aborted by setting the the abort parameter to true.

Example
  • C#
private void queryBuilder1_BeforePropertiesDialog(QueryBuilder sender, ControlOwner controlOwner, ref bool abort)
{
    String msg = "";

    if (controlOwner is UnionSubQuery) // Query Properties dialog (invoked from the design pane context menu)
    {
        msg = "Do you want to show Query Properties dialog?";
    }
    else if (controlOwner is Link) // Link Properties dialog (invoked from the link context menu)
    {
        msg = "Do you want to show Link Properties dialog?";
    }
    else if (controlOwner is DataSourceObject) // Datasource Properties dialog (invoked from the datasource context menu)
    {
        msg = "Do you want to show Datasource Properties dialog?";
    }

    if (!String.IsNullOrEmpty(msg))
    {
        if (MessageBox.Show(msg, "BeforePropertiesDialog event handler", MessageBoxButtons.YesNo) == DialogResult.No)
        {
            abort = true;
        }
    }
}
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
AfterPropertiesDialog Event


ControlCreated Event

ControlCreated Event
Example

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ControlCreated Event
Invoked when a control is created inside the component.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ControlCreated As ControlCreatedEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As ControlCreatedEventHandler

AddHandler instance.ControlCreated, handler
public event ControlCreatedEventHandler ControlCreated
public: __event ControlCreatedEventHandler* ControlCreated
Remarks

Use this event to customize internal controls and to add additional controls to the component.

The following combination of control and owner parameters are possible:

- owner is Query; control is TabPage (main query tab).
- owner is SubQuery; control is TabPage (sub-query tabs).
- owner is QueryColumnList; control is QueryColumnListControl.
- owner is DataSourceObject; control is DataSourceControl (database objects at Design Pane).
- owner is DataSourceQuery; control is DataSourceControl (sub-queries at Design Pane).
- owner is Link; control is LinkControl.
- owner is UnionSubQuery; control is UnionSubQueryPanel (you may get the link to DesignPane object here using the UnionSubQuery.DesignPane.GetControl method).
- owner is UnionSubQuery; control is UnionButton.
- owner is UnionSubQuery; control is UnionOperator.
- owner is UnionGroup; control is LeftBracket.
- owner is UnionGroup; control is RightBracket.
- owner is UnionGroup; control is UnionOperator.

Example
Adds button at the top of each sub-query DataSource control.
  • C#
private void queryBuilder1_ControlCreated(ControlOwner owner, Control control)
{
    if (owner is DataSourceQuery && control is DataSourceControl)
    {
        DataSourceControl dataSourceControl = (DataSourceControl) control;

        // insert a small button above fields list
        Button customButton = new Button();
        customButton.Height = dataSourceControl.FieldList.ItemHeight;
        customButton.Dock = DockStyle.Top;
        customButton.Click += customButton_Click;
        dataSourceControl.Controls.Add(customButton);
    }
}
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
ControlDestroying Event


ControlDestroying Event

ControlDestroying Event
Example

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ControlDestroying Event
Invoked before the control is destroyed inside the component.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ControlDestroying As ControlDestroyingEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As ControlDestroyingEventHandler

AddHandler instance.ControlDestroying, handler
public event ControlDestroyingEventHandler ControlDestroying
public: __event ControlDestroyingEventHandler* ControlDestroying
Remarks
Use this event to free resources and unbound events created in the ControlCreated Event
Example
Removes button at the top of each sub-query DataSource control created in the ControlCreated event handler.
  • C#
private void queryBuilder1_ControlDestroying(ControlOwner owner, Control control)
{
    if (owner is DataSourceQuery && control is DataSourceControl)
    {
        DataSourceControl dataSourceControl = (DataSourceControl) control;

        foreach (Control c in dataSourceControl.Controls)
        {
            if (c is Button)
            {
                // remove event handler to avoid memory leak
                c.Click -= customButton_Click;
                break;
            }
        }
    }
}
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


CustomExpressionBuilder Event

CustomExpressionBuilder Event
Example

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : CustomExpressionBuilder Event
Is called to edit SQL expression of the Expression or Criteria column cell of the Query Columns Grid when the user clicks the ellipsis button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event CustomExpressionBuilder As CustomExpressionBuilderEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As CustomExpressionBuilderEventHandler

AddHandler instance.CustomExpressionBuilder, handler
public event CustomExpressionBuilderEventHandler CustomExpressionBuilder
public: __event CustomExpressionBuilderEventHandler* CustomExpressionBuilder
Remarks

A dialog is expected to be shown in this event handler to edit the expression string passed in the expression parameter. The queryColumnListItem parameter refers to the item of QueryColumnsList object being edited.

The conditionIndex parameter equals to -1 if called to edit the Expression column value (criteriaItem.ExpressionString) and is greater than -1 to refer to the Criteria column being edited (queryColumnListItem.ConditionStrings[conditionIndex])

The ellipsis button is shown only when the UseCustomExpressionBuilder Property is set to true.

Example
  • C#
private void queryBuilder1_CustomExpressionBuilder(QueryBuilder queryBuilder, QueryColumnListItem queryColumnListItem, int conditionIndex, string expression)
{
    using (CustomExpressionEditor f = new CustomExpressionEditor())
    {
        f.textBox.Text = expression;

        if (f.ShowDialog() == DialogResult.OK)
        {
            // Update the criteria list with new expression text.

            if (conditionIndex > -1) // it's one of condition columns
            {
                queryColumnListItem.ConditionStrings[conditionIndex] = f.textBox.Text;
            }
            else // it's the Expression column
            {
                queryColumnListItem.ExpressionString = f.textBox.Text;
            }
        }
    }
}
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


CustomizeDatasourceCaption Event (QueryBuilder)

CustomizeDatasourceCaption Event (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : CustomizeDatasourceCaption Event
Is called to customize the caption of a DataSource at the Design Area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event CustomizeDatasourceCaption As CustomizeDatasourceCaptionEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As CustomizeDatasourceCaptionEventHandler

AddHandler instance.CustomizeDatasourceCaption, handler
public event CustomizeDatasourceCaptionEventHandler CustomizeDatasourceCaption
public: __event CustomizeDatasourceCaptionEventHandler* CustomizeDatasourceCaption
Remarks
The datasource parameter refers to the DataSource object being added to the Design Area.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
CustomizeDatasourceFieldList Event


CustomizeDatasourceFieldList Event (QueryBuilder)

CustomizeDatasourceFieldList Event (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : CustomizeDatasourceFieldList Event
Is called to customize the field list of a DataSource at the Design Area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event CustomizeDatasourceFieldList As CustomizeDatasourceFieldListEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As CustomizeDatasourceFieldListEventHandler

AddHandler instance.CustomizeDatasourceFieldList, handler
public event CustomizeDatasourceFieldListEventHandler CustomizeDatasourceFieldList
public: __event CustomizeDatasourceFieldListEventHandler* CustomizeDatasourceFieldList
Remarks

The field list to be customized is passed through the fieldList parameter.

The datasource parameter refers to the DataSource object being added to the Design Area.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
CustomizeDatasourceCaption Event


DataSourceAdded Event (QueryBuilder)

DataSourceAdded Event (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DataSourceAdded Event
Invoked when DataSource is added by the user.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DataSourceAdded As DataSourceAddedEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As DataSourceAddedEventHandler

AddHandler instance.DataSourceAdded, handler
public event DataSourceAddedEventHandler DataSourceAdded
public: __event DataSourceAddedEventHandler* DataSourceAdded
Remarks

The addedObject parameter refers to the newly added DataSource object.

You may use this event to add fields to the query, to link this DataSource with the others, etc.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
DataSourceAdding Event


DataSourceAdding Event

DataSourceAdding Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DataSourceAdding Event
Invoked when DataSource is about to be added by the user.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DataSourceAdding As DataSourceAddingEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As DataSourceAddingEventHandler

AddHandler instance.DataSourceAdding, handler
public event DataSourceAddingEventHandler DataSourceAdding
public: __event DataSourceAddingEventHandler* DataSourceAdding
Remarks

The pos parameter indicates position within the Design Area for the new DataSource.

The fromObject parameter defines object being added to the query. It may be one of the following types:
- SQLFromFunction in case of adding stored procedure or function. It has Name and Params properties to indentify itself.
- SQLFromObject in case of adding table, view, synonym or CTE to the query. It has the Name.QualifiedName property to retrieve the name of database object. It's CTEObject property refers to the CTE sub-query object in case of adding common table expression to the query.
- SQLFromQuery in case of adding a derived table to the query.

Set the abort parameter to true to deny adding the DataSource to the query.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
DataSourceAdded Event


DataSourceDeleting Event

DataSourceDeleting Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DataSourceDeleting Event
Invoked when DataSource is about to be deleted by the user.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DataSourceDeleting As DataSourceDeletingEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As DataSourceDeletingEventHandler

AddHandler instance.DataSourceDeleting, handler
public event DataSourceDeletingEventHandler DataSourceDeleting
public: __event DataSourceDeletingEventHandler* DataSourceDeleting
Remarks

The datasource parameter refers to the DataSource object being deleted from the query.

Set the abort parameter to true to deny deleting the DataSource.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


DatasourceFieldAdded Event (QueryBuilder)

DatasourceFieldAdded Event (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DatasourceFieldAdded Event
Invoked when Field is added to the query by checking it at the DataSource field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DatasourceFieldAdded As DatasourceFieldAddedEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As DatasourceFieldAddedEventHandler

AddHandler instance.DatasourceFieldAdded, handler
public event DatasourceFieldAddedEventHandler DatasourceFieldAdded
public: __event DatasourceFieldAddedEventHandler* DatasourceFieldAdded
Remarks

The field and datasource parameters refer to the newly added DataSource field.

You may use this event to specify alias or some other query column properties.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
DatasourceFieldAdding Event
GridCellValueChanged Event


DatasourceFieldAdding Event

DatasourceFieldAdding Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DatasourceFieldAdding Event
Invoked when Field is about to be added to the query by checking it at the DataSource field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DatasourceFieldAdding As DatasourceFieldAddingEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As DatasourceFieldAddingEventHandler

AddHandler instance.DatasourceFieldAdding, handler
public event DatasourceFieldAddingEventHandler DatasourceFieldAdding
public: __event DatasourceFieldAddingEventHandler* DatasourceFieldAdding
Remarks

The field and datasource parameters refer to the DataSource field being added.

Set the abort parameter to true to deny addition of the Field.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
DataSourceAdded Event
GridCellValueChanging Event


DatasourceFieldRemoved Event (QueryBuilder)

DatasourceFieldRemoved Event (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DatasourceFieldRemoved Event
Invoked when Field is removed from the query by unchecking it at the DataSource field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DatasourceFieldRemoved As DatasourceFieldRemovedEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As DatasourceFieldRemovedEventHandler

AddHandler instance.DatasourceFieldRemoved, handler
public event DatasourceFieldRemovedEventHandler DatasourceFieldRemoved
public: __event DatasourceFieldRemovedEventHandler* DatasourceFieldRemoved
Remarks
The field and datasource parameters refer to the removed DataSource field.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
DatasourceFieldRemoving Event


DatasourceFieldRemoving Event

DatasourceFieldRemoving Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DatasourceFieldRemoving Event
Invoked when Field is about to be deleted from the query by unchecking it at the DataSource field list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DatasourceFieldRemoving As DatasourceFieldRemovingEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As DatasourceFieldRemovingEventHandler

AddHandler instance.DatasourceFieldRemoving, handler
public event DatasourceFieldRemovingEventHandler DatasourceFieldRemoving
public: __event DatasourceFieldRemovingEventHandler* DatasourceFieldRemoving
Remarks

The field and datasource parameters refer to the DataSource field being deleted.

Set the abort parameter to true to deny removal of the Field.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
DatasourceFieldRemoved Event


Destroying Event

Destroying Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Destroying Event
Occurs before the component is destroyed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Destroying As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.Destroying, handler
public event System.EventHandler Destroying
public: __event System.EventHandler* Destroying
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


FieldListDrawItem Event

FieldListDrawItem Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : FieldListDrawItem Event
Called to draw an item of the DataSource Field List.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event FieldListDrawItem As FieldListDrawItemEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As FieldListDrawItemEventHandler

AddHandler instance.FieldListDrawItem, handler
public event FieldListDrawItemEventHandler FieldListDrawItem
public: __event FieldListDrawItemEventHandler* FieldListDrawItem
Remarks

You can use this event to perform the tasks needed to draw items in the DataSource Field List.

It contains all the information that is needed for the user to paint the specified item, including the MetadataField, the Rectangle, and the Graphics on which the drawing should be done. The state parameter specifies the state of an item that is being drawn.

Set the handled parameter to true to indicate that the event was handled.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


FocusedDesignPaneControlChanged Event

FocusedDesignPaneControlChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : FocusedDesignPaneControlChanged Event
Occurs when a focused object at the Design Pane is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event FocusedDesignPaneControlChanged As FocusedDesignPaneControlChangedEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As FocusedDesignPaneControlChangedEventHandler

AddHandler instance.FocusedDesignPaneControlChanged, handler
public event FocusedDesignPaneControlChangedEventHandler FocusedDesignPaneControlChanged
public: __event FocusedDesignPaneControlChangedEventHandler* FocusedDesignPaneControlChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


GetDiagramObjectWidth Event

GetDiagramObjectWidth Event
Example

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : GetDiagramObjectWidth Event
Called to calculate width of the newly added datasource.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event GetDiagramObjectWidth As GetDiagramObjectWidthEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As GetDiagramObjectWidthEventHandler

AddHandler instance.GetDiagramObjectWidth, handler
public event GetDiagramObjectWidthEventHandler GetDiagramObjectWidth
public: __event GetDiagramObjectWidthEventHandler* GetDiagramObjectWidth
Example
Sets the DataSource control width according to width of it's fields.
  • C#
private void queryBuilder1_GetDataSourceWidth(QueryBuilder queryBuilder, DataSource datasource, ref int width)
{
    DataSourceControl dsControl = (DataSourceControl) datasource.DSControl.GetControl();
    DataSourceFieldList flControl = dsControl.FieldList;
    Font font = queryBuilder.DiagramObjectFont;
    int maxWidth = 0;

    using (Graphics g = CreateGraphics())
    {
        foreach (TextAndObject item in flControl.Items)
        {
            maxWidth = (int) Math.Max(g.MeasureString(item.ToString(), Font).Width, maxWidth);
        }
    }

    int extra = 45; // width of checkbox, key mark column and borders
    width = maxWidth + extra;
}
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


GetProcedureParameters Event

GetProcedureParameters Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : GetProcedureParameters Event
Fired when the component requests parameter values for stored procedure or function.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event GetProcedureParameters As GetProcedureParametersEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As GetProcedureParametersEventHandler

AddHandler instance.GetProcedureParameters, handler
public event GetProcedureParametersEventHandler GetProcedureParameters
public: __event GetProcedureParametersEventHandler* GetProcedureParameters
Remarks
You may avoid displaying of the dialog requesting the user for parameter values by handling this event.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


GridCellValueChanged Event

GridCellValueChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : GridCellValueChanged Event
Invoked when one of the Query Columns Grid Control cells is changed by the user.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event GridCellValueChanged As GridCellValueChangedEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As GridCellValueChangedEventHandler

AddHandler instance.GridCellValueChanged, handler
public event GridCellValueChangedEventHandler GridCellValueChanged
public: __event GridCellValueChangedEventHandler* GridCellValueChanged
Remarks

Occurs when the user has finished editing and result is applied to the cell.

The queryColumnList and queryColumnListItem parameters refer to the Query Column List object and it's Item. The column and row parameters address a cell in the Query Columns Grid. The oldValue and newValue parameters allows you to review the cell value before and after editing.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
GridCellValueChanging Event
DatasourceFieldAdded Event


GridCellValueChanging Event

GridCellValueChanging Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : GridCellValueChanging Event
Invoked when one of the Query Columns Grid Control cells is about to be changed by the user.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event GridCellValueChanging As GridCellValueChangingEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As GridCellValueChangingEventHandler

AddHandler instance.GridCellValueChanging, handler
public event GridCellValueChangingEventHandler GridCellValueChanging
public: __event GridCellValueChangingEventHandler* GridCellValueChanging
Remarks

Occurs when the user has finished editing, but result is not applied yet to the cell.

The queryColumnList and queryColumnListItem parameters refer to the Query Column List object and it's Item. The column and row parameters address a cell in the Query Columns Grid. The oldValue and newValue parameters allows you to review the cell value before and after editing.

Set the abort parameter to true to deny editing of the cell.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
GridCellValueChanged Event
DatasourceFieldAdding Event


LanguageChanged Event (QueryBuilder)

LanguageChanged Event (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : LanguageChanged Event
Fired on changing the Language property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event LanguageChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.LanguageChanged, handler
public event System.EventHandler LanguageChanged
public: __event System.EventHandler* LanguageChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


LinkChanged Event

LinkChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : LinkChanged Event
Invoked when the Link properties are changed by the user.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event LinkChanged As LinkChangedEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As LinkChangedEventHandler

AddHandler instance.LinkChanged, handler
public event LinkChangedEventHandler LinkChanged
public: __event LinkChangedEventHandler* LinkChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


LinkChanging Event

LinkChanging Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : LinkChanging Event
Invoked when the Link properties are about to be changed by the user.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event LinkChanging As LinkChangingEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As LinkChangingEventHandler

AddHandler instance.LinkChanging, handler
public event LinkChangingEventHandler LinkChanging
public: __event LinkChangingEventHandler* LinkChanging
Remarks

Set the abort parameter to true to deny changing properties of the Link.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


LinkCreated Event (QueryBuilder)

LinkCreated Event (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : LinkCreated Event
Invoked when the link between datasources is created by the user.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event LinkCreated As LinkCreatedEventhandler
'Usage

Dim instance As QueryBuilder
Dim handler As LinkCreatedEventhandler

AddHandler instance.LinkCreated, handler
public event LinkCreatedEventhandler LinkCreated
public: __event LinkCreatedEventhandler* LinkCreated
Remarks
The link parameter refers to the newly created Link object.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
LinkCreating Event


LinkCreating Event

LinkCreating Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : LinkCreating Event
Invoked when the link between two datasources is about to be created by the user.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event LinkCreating As LinkCreatingEventhandler
'Usage

Dim instance As QueryBuilder
Dim handler As LinkCreatingEventhandler

AddHandler instance.LinkCreating, handler
public event LinkCreatingEventhandler LinkCreating
public: __event LinkCreatingEventhandler* LinkCreating
Remarks

The fromField and the fromDatasource parameters refer to the the first DataSource and it's Field. The toField and the toDatasource parameters refer to the second DataSource and it's Field. The correspondingMetadataForeignKey parameter is defined when corresponding MetadataForeignKey between these fields exists in the Metadata Container.

Creation of the link may be aborted by setting the abort parameter to true.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
LinkCreated Event


LinkDeleting Event

LinkDeleting Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : LinkDeleting Event
Invoked when the link between datasources is about to be deleted by the user.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event LinkDeleting As LinkDeletingEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As LinkDeletingEventHandler

AddHandler instance.LinkDeleting, handler
public event LinkDeletingEventHandler LinkDeleting
public: __event LinkDeletingEventHandler* LinkDeleting
Remarks

The link parameter refers to the Link being deleted from the query.

Set the abort parameter to true to deny deleting the Link.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


LinkDragOver Event

LinkDragOver Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : LinkDragOver Event
Invoked when the user drags a DataSource Field over the other DataSource Field to create a link between these fields.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event LinkDragOver As LinkCreatingEventhandler
'Usage

Dim instance As QueryBuilder
Dim handler As LinkCreatingEventhandler

AddHandler instance.LinkDragOver, handler
public event LinkCreatingEventhandler LinkDragOver
public: __event LinkCreatingEventhandler* LinkDragOver
Remarks

The fromField and fromDatasource parameters refer to the datasource field being dragged. The toField and toDatasource parameters refer to the target datasource field. The correspondingMetadataForeignKey parameter is defined when corresponding MetadataForeignKey between these fields exists in the Metadata Container.

Dropping may not be allowed by setting the abort parameter to true.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
BeforeDatasourceFieldDrag Event


QueryAwake Event

QueryAwake Event
Example

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : QueryAwake Event
Occurs when the component is currently in the "Sleep" mode and the user starts to build a query visually.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event QueryAwake As QueryAwakeEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As QueryAwakeEventHandler

AddHandler instance.QueryAwake, handler
public event QueryAwakeEventHandler QueryAwake
public: __event QueryAwakeEventHandler* QueryAwake
Remarks

This situation may happen when visual query building is combined with direct SQL text editing. Suppose that the user wrote an unsupported SQL statement in the text editor by hand, so the visual query builder fall into the "Sleep mode", and the user started to build a query visually after that. Obviously the visual query builder have to "awake" in response to user actions and start to generate SQL text, so the hand-written query will be lost. This event allows to prevent occasional awakening of the component and lets the user to save the hand-written query prior to building a new one.

Set the abort parameter to true to deny awakening of the component.

Example
  • C#
private void queryBuilder_QueryAwake(object sender, ref bool abort)
{
    if (MessageBox.Show("You are about to build a new SELECT statement. " +
        "Current query in the text editor will be replaced. Are you sure?",
        "Active Query Builder .NET Demo", MessageBoxButtons.YesNo) == DialogResult.No)
    {
        abort = true;
    }
}
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
BehaviorOptions.AllowSleepMode
SleepModeChanged Event


SleepModeChanged Event (QueryBuilder)

SleepModeChanged Event (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : SleepModeChanged Event
Invoked when the component is turns the "Sleep" mode on and off.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event SleepModeChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.SleepModeChanged, handler
public event System.EventHandler SleepModeChanged
public: __event System.EventHandler* SleepModeChanged
Remarks

The "Sleep mode" allows to suppress parsing errors on unsupported SQL statements (CREATE TABLE, INSERT, UPDATE, DELETE, etc.).

Examine the SleepMode Property to learn if the component is currently in the sleep mode or not.

Use this event to show/hide the visual query builder when the user starts to write an unsupported statement by hand in the text editor.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


SqlError Event (QueryBuilder)

SqlError Event (QueryBuilder)
Example

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : SqlError Event
Invoked on SQL text parsing error.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event SqlError As SqlErrorEvenHandler
'Usage

Dim instance As QueryBuilder
Dim handler As SqlErrorEvenHandler

AddHandler instance.SqlError, handler
public event SqlErrorEvenHandler SqlError
public: __event SqlErrorEvenHandler* SqlError
Remarks

The sql parameter is the SQL query text that failed to parse. The error parameter is the error message string. The errorToken parameter is the erroneous token string. The errorTokenPos parameter addresses the erroneous token in the SQL query text.

            public struct Pos
            {
                public int pos;  // token position in the source text (starting at 0)
                public int col;  // token column (starting at 0)
                public int line; // token line (starting at 1)
            }

You may control the behavior of the component on parsing unknown types of SQL statements or on parsing queries with unknown objects using the BehaviorOptions properties: AllowSleepMode, ParsingErrorOnUnknownObjects.

Example
  • C#
private void queryBuilder1_SqlError(object sender, string sql,
    string error, string errorToken, Pos errorTokenPos)
{
    MessageBox.Show(string.Format(
        "Unexpected token \"{0}\" at line {1}, column {2}",
        errorToken, errorTokenPos.line, errorTokenPos.col));
}
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


SQLUpdated Event (QueryBuilder)

SQLUpdated Event (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : SQLUpdated Event
Occurs each time the component updates the output SQL query text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event SQLUpdated As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.SQLUpdated, handler
public event System.EventHandler SQLUpdated
public: __event System.EventHandler* SQLUpdated
Remarks

Read the QueryBuilder.SQL Property or the PlainTextSQLBuilder.SQL Property to get updated SQL query text.

Read the QueryStatistics to get updated information about the query.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


UserMessage Event

UserMessage Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : UserMessage Event
Fired when the component is about to show the warning message to the user.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event UserMessage As UserMessageEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As UserMessageEventHandler

AddHandler instance.UserMessage, handler
public event UserMessageEventHandler UserMessage
public: __event UserMessageEventHandler* UserMessage
Event Data

The event handler receives an argument of type UserMessageEventArgs containing data related to this event. The following UserMessageEventArgs properties provide information specific to this event.

Property | Description
Message | Gets the warning message string to be displayed to the user.
MessageId | Gets the value that uniquely identifies the situation that requires to warn the user.
Remarks

You may avoid displaying of the warning message by handling this event.

Currently it is fired when multiple columns with same name appear in sub-queries in result of user actions as this may lead to inconsistence in the calling sub-query.

See the UserMessageEventArgs class for details.

Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ValidateContextMenu Event

ValidateContextMenu Event
Example

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ValidateContextMenu Event
Is called before any of the component's context menus is shown.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ValidateContextMenu As PopupMenuEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As PopupMenuEventHandler

AddHandler instance.ValidateContextMenu, handler
public event PopupMenuEventHandler ValidateContextMenu
public: __event PopupMenuEventHandler* ValidateContextMenu
Remarks

Allows to customize component's context menus.

The menu parameter refers to the ContextMenu object to be shown. Clear it's items to disable a menu.

The controlOwner parameter refers to the query object for which the context menu is called. The control parameter refers to the control representing this query object. The following combinations are possible:
- controlOwner is Link; control is LinkControl.
- controlOwner is DataSourceObject or DataSourceQuery; control is DataSourceControl.
- controlOwner is QueryColumnListItem; control is QueryColumnListControl.
- controlOwner is UnionSubQuery; control is DesignPane: design pane context menu.
- controlOwner is UnionSubQuery; control is UnionButton: context menu of the union button ("Q" button on the navigation bar).
- controlOwner is UnionSubQuery; control is UnionOperator: context menu of the union operator (union type symbol on the navigation bar).
- controlOwner is UnionGroup; control is LeftBracket: context menu of the left bracket ("(" symbol on the navigation bar).
- controlOwner is UnionGroup; control is RightBracket: context menu of the right bracket (")" symbol on the navigation bar).

Example
  • C#
private void queryBuilder1_ValidateContextMenu(Control control, ControlOwner controlOwner, ContextMenu menu)
{
    // Insert custom menu item to the top of any context menu
    menu.MenuItems.Add(0, new MenuItem("Custom Item 1"));
    menu.MenuItems.Add(1, new MenuItem("-")); // separator

    if (controlOwner is Link) // Link context menu
    {
        // Add another item in the Link's menu
        menu.MenuItems.Add("-"); // separator
        menu.MenuItems.Add("Custom Item 2");

        // control is LinkControl
    }
    else if (controlOwner is DataSourceObject) // Datasource context menu
    {
        // control is DataSourceControl
    }
    else if (controlOwner is UnionSubQuery)
    {
        if (control is DesignPane) // design pane context menu
        {

        }
        else if (control is UnionButton) // context menu of the union button ("Q" button on the navigation bar)
        {

        }
        else if (control is UnionOperator) // context menu of the union operator (union type symbol on the navigation bar)
        {
            // Delete all items from this menu.
            // The menu will not be shown.
            menu.MenuItems.Clear();
        }
    }
    else if (controlOwner is UnionGroup)
    {
        if (control is LeftBracket) // context menu of the left bracket ("(" symbol on the navigation bar)
        {

        }
        else if (control is RightBracket) // context menu of the right bracket (")" symbol on the navigation bar)
        {

        }
    }
    else if (controlOwner is QueryColumnListItem) // context menu of the row of the criteria list (grid)
    {
        // control is QueryColumnListControl
    }
}
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


QueryColumnListOptions Class

QueryColumnListOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : QueryColumnListOptions Class
Contains various properties of the Query Column List.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class QueryColumnListOptions
   Inherits UpdatablePersistent
'Usage

Dim instance As QueryColumnListOptions
public class QueryColumnListOptions : UpdatablePersistent
public __gc class QueryColumnListOptions : public UpdatablePersistent
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.QueryColumnListOptions

Requirements

See Also

Reference

QueryColumnListOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
QueryColumnListOptions Property


QueryColumnListOptions Class Members

QueryColumnListOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : QueryColumnListOptions Class

The following tables list the members exposed by QueryColumnListOptions.

Public Properties
 | Name | Description
Public Property | AggregateColumnWidth | Specifies width of the Aggregate column.
Public Property | AliasColumnWidth | Specifies width of the Alias column.
Public Property | AutoSizeColumns | Instructs the control to determine width of columns automatically to fit cell contents.
Public Property | BackColor | Gets or sets the background color for the Query Column List control.
Public Property | ConditionColumnWidth | Specifies width of the Criteria and Or columns.
Public Property | ConditionTypeColumnWidth | Specifies width of the "Criteria for" column.
Public Property | CreateColumnAliasesFromAltNames | Instruct the component to create aliases automatically for fields with Alternate Names.
Public Property | DisableDirectEditingIn | Lets you to disable direct editing of the Expression and/or condition columns of the control.
Public Property | ExpressionColumnWidth | Specifies width of the Expression column.
Public Property | Font | Gets or sets the font of the text displayed by the Query Column List control.
Public Property | GroupingColumnWidth | Specifies width of the Grouping check box column.
Public Property | GroupingTypeColumnWidth | Specifies width of the "Group By" column.
Public Property | InitialOrColumnsCount | Specifies the number of "Or" columns initially displayed in the grid.
Public Property | NullOrderingInOrderBy | Allows to display "NULLS FIRST"/"NULLS LAST" options in the Sort Type column.
Public Property | OutputColumnWidth | Specifies width of the Output check box column.
Public Property | RowHeadersWidth | Specifies width of the row header column (the most-left column for dragging rows).
Public Property | SortOrderColumnWidth | Specifies width of the "Sort Order" column.
Public Property | SortTypeColumnWidth | Specifies width of the "Sort Type" column.
Public Property | TextColor | Gets or sets the color of the text displayed by the control.
Public Property | UseCustomExpressionBuilder | Allows to use custom expression builder for Expression and/or condition columns of the control.
Public Property | UseMSStyleGrouping | Allows to change the way the end-user defines grouping for the query.
Top
See Also

Reference

QueryColumnListOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
QueryColumnListOptions Property


QueryColumnListOptions Class Properties

QueryColumnListOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : QueryColumnListOptions Class

For a list of all members of this type, see QueryColumnListOptions members.

Public Properties
 | Name | Description
Public Property | AggregateColumnWidth | Specifies width of the Aggregate column.
Public Property | AliasColumnWidth | Specifies width of the Alias column.
Public Property | AutoSizeColumns | Instructs the control to determine width of columns automatically to fit cell contents.
Public Property | BackColor | Gets or sets the background color for the Query Column List control.
Public Property | ConditionColumnWidth | Specifies width of the Criteria and Or columns.
Public Property | ConditionTypeColumnWidth | Specifies width of the "Criteria for" column.
Public Property | CreateColumnAliasesFromAltNames | Instruct the component to create aliases automatically for fields with Alternate Names.
Public Property | DisableDirectEditingIn | Lets you to disable direct editing of the Expression and/or condition columns of the control.
Public Property | ExpressionColumnWidth | Specifies width of the Expression column.
Public Property | Font | Gets or sets the font of the text displayed by the Query Column List control.
Public Property | GroupingColumnWidth | Specifies width of the Grouping check box column.
Public Property | GroupingTypeColumnWidth | Specifies width of the "Group By" column.
Public Property | InitialOrColumnsCount | Specifies the number of "Or" columns initially displayed in the grid.
Public Property | NullOrderingInOrderBy | Allows to display "NULLS FIRST"/"NULLS LAST" options in the Sort Type column.
Public Property | OutputColumnWidth | Specifies width of the Output check box column.
Public Property | RowHeadersWidth | Specifies width of the row header column (the most-left column for dragging rows).
Public Property | SortOrderColumnWidth | Specifies width of the "Sort Order" column.
Public Property | SortTypeColumnWidth | Specifies width of the "Sort Type" column.
Public Property | TextColor | Gets or sets the color of the text displayed by the control.
Public Property | UseCustomExpressionBuilder | Allows to use custom expression builder for Expression and/or condition columns of the control.
Public Property | UseMSStyleGrouping | Allows to change the way the end-user defines grouping for the query.
Top
See Also

Reference

QueryColumnListOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
QueryColumnListOptions Property


AggregateColumnWidth Property

AggregateColumnWidth Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryColumnListOptions Class : AggregateColumnWidth Property
Specifies width of the Aggregate column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AggregateColumnWidth As System.Integer
'Usage

Dim instance As QueryColumnListOptions
Dim value As System.Integer

instance.AggregateColumnWidth = value

value = instance.AggregateColumnWidth
public System.int AggregateColumnWidth {get; set;}
public: __property System.int get_AggregateColumnWidth();
public: __property void set_AggregateColumnWidth(
   System.int value
);
Requirements

See Also

Reference

QueryColumnListOptions Class
QueryColumnListOptions Members


AliasColumnWidth Property

AliasColumnWidth Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryColumnListOptions Class : AliasColumnWidth Property
Specifies width of the Alias column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AliasColumnWidth As System.Integer
'Usage

Dim instance As QueryColumnListOptions
Dim value As System.Integer

instance.AliasColumnWidth = value

value = instance.AliasColumnWidth
public System.int AliasColumnWidth {get; set;}
public: __property System.int get_AliasColumnWidth();
public: __property void set_AliasColumnWidth(
   System.int value
);
Requirements

See Also

Reference

QueryColumnListOptions Class
QueryColumnListOptions Members


AutoSizeColumns Property

AutoSizeColumns Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryColumnListOptions Class : AutoSizeColumns Property
Instructs the control to determine width of columns automatically to fit cell contents.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AutoSizeColumns As System.Boolean
'Usage

Dim instance As QueryColumnListOptions
Dim value As System.Boolean

instance.AutoSizeColumns = value

value = instance.AutoSizeColumns
public System.bool AutoSizeColumns {get; set;}
public: __property System.bool get_AutoSizeColumns();
public: __property void set_AutoSizeColumns(
   System.bool value
);
Requirements

See Also

Reference

QueryColumnListOptions Class
QueryColumnListOptions Members


BackColor Property (QueryColumnListOptions)

BackColor Property (QueryColumnListOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryColumnListOptions Class : BackColor Property
Gets or sets the background color for the Query Column List control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property BackColor As System.Drawing.Color
'Usage

Dim instance As QueryColumnListOptions
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
public System.Drawing.Color BackColor {get; set;}
public: __property System.Drawing.Color get_BackColor();
public: __property void set_BackColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

QueryColumnListOptions Class
QueryColumnListOptions Members


ConditionColumnWidth Property

ConditionColumnWidth Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryColumnListOptions Class : ConditionColumnWidth Property
Specifies width of the Criteria and Or columns.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ConditionColumnWidth As System.Integer
'Usage

Dim instance As QueryColumnListOptions
Dim value As System.Integer

instance.ConditionColumnWidth = value

value = instance.ConditionColumnWidth
public System.int ConditionColumnWidth {get; set;}
public: __property System.int get_ConditionColumnWidth();
public: __property void set_ConditionColumnWidth(
   System.int value
);
Requirements

See Also

Reference

QueryColumnListOptions Class
QueryColumnListOptions Members


ConditionTypeColumnWidth Property

ConditionTypeColumnWidth Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryColumnListOptions Class : ConditionTypeColumnWidth Property
Specifies width of the "Criteria for" column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ConditionTypeColumnWidth As System.Integer
'Usage

Dim instance As QueryColumnListOptions
Dim value As System.Integer

instance.ConditionTypeColumnWidth = value

value = instance.ConditionTypeColumnWidth
public System.int ConditionTypeColumnWidth {get; set;}
public: __property System.int get_ConditionTypeColumnWidth();
public: __property void set_ConditionTypeColumnWidth(
   System.int value
);
Requirements

See Also

Reference

QueryColumnListOptions Class
QueryColumnListOptions Members


CreateColumnAliasesFromAltNames Property (QueryColumnListOptions)

CreateColumnAliasesFromAltNames Property (QueryColumnListOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryColumnListOptions Class : CreateColumnAliasesFromAltNames Property
Instruct the component to create aliases automatically for fields with Alternate Names.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property CreateColumnAliasesFromAltNames As System.Boolean
'Usage

Dim instance As QueryColumnListOptions
Dim value As System.Boolean

instance.CreateColumnAliasesFromAltNames = value

value = instance.CreateColumnAliasesFromAltNames
public System.bool CreateColumnAliasesFromAltNames {get; set;}
public: __property System.bool get_CreateColumnAliasesFromAltNames();
public: __property void set_CreateColumnAliasesFromAltNames(
   System.bool value
);
Requirements

See Also

Reference

QueryColumnListOptions Class
QueryColumnListOptions Members
SQLGenerationOptions.UseAltNames


DisableDirectEditingIn Property

DisableDirectEditingIn Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryColumnListOptions Class : DisableDirectEditingIn Property
Lets you to disable direct editing of the Expression and/or condition columns of the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DisableDirectEditingIn As AffectedColumns
'Usage

Dim instance As QueryColumnListOptions
Dim value As AffectedColumns

instance.DisableDirectEditingIn = value

value = instance.DisableDirectEditingIn
public AffectedColumns DisableDirectEditingIn {get; set;}
public: __property AffectedColumns get_DisableDirectEditingIn();
public: __property void set_DisableDirectEditingIn(
   AffectedColumns value
);
Remarks
Useful when you want to use custom expression editor ONLY to edit content of these columns.
Requirements

See Also

Reference

QueryColumnListOptions Class
QueryColumnListOptions Members
UseCustomExpressionBuilder Property


ExpressionColumnWidth Property

ExpressionColumnWidth Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryColumnListOptions Class : ExpressionColumnWidth Property
Specifies width of the Expression column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ExpressionColumnWidth As System.Integer
'Usage

Dim instance As QueryColumnListOptions
Dim value As System.Integer

instance.ExpressionColumnWidth = value

value = instance.ExpressionColumnWidth
public System.int ExpressionColumnWidth {get; set;}
public: __property System.int get_ExpressionColumnWidth();
public: __property void set_ExpressionColumnWidth(
   System.int value
);
Requirements

See Also

Reference

QueryColumnListOptions Class
QueryColumnListOptions Members


Font Property (QueryColumnListOptions)

Font Property (QueryColumnListOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryColumnListOptions Class : Font Property
Gets or sets the font of the text displayed by the Query Column List control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Font As System.Drawing.Font
'Usage

Dim instance As QueryColumnListOptions
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
public System.Drawing.Font Font {get; set;}
public: __property System.Drawing.Font* get_Font();
public: __property void set_Font(
   System.Drawing.Font* value
);
Requirements

See Also

Reference

QueryColumnListOptions Class
QueryColumnListOptions Members


GroupingColumnWidth Property

GroupingColumnWidth Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryColumnListOptions Class : GroupingColumnWidth Property
Specifies width of the Grouping check box column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property GroupingColumnWidth As System.Integer
'Usage

Dim instance As QueryColumnListOptions
Dim value As System.Integer

instance.GroupingColumnWidth = value

value = instance.GroupingColumnWidth
public System.int GroupingColumnWidth {get; set;}
public: __property System.int get_GroupingColumnWidth();
public: __property void set_GroupingColumnWidth(
   System.int value
);
Requirements

See Also

Reference

QueryColumnListOptions Class
QueryColumnListOptions Members


GroupingTypeColumnWidth Property

GroupingTypeColumnWidth Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryColumnListOptions Class : GroupingTypeColumnWidth Property
Specifies width of the "Group By" column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property GroupingTypeColumnWidth As System.Integer
'Usage

Dim instance As QueryColumnListOptions
Dim value As System.Integer

instance.GroupingTypeColumnWidth = value

value = instance.GroupingTypeColumnWidth
public System.int GroupingTypeColumnWidth {get; set;}
public: __property System.int get_GroupingTypeColumnWidth();
public: __property void set_GroupingTypeColumnWidth(
   System.int value
);
Remarks
This column is visible only in MS-style grouping mode.
Requirements

See Also

Reference

QueryColumnListOptions Class
QueryColumnListOptions Members
UseMSStyleGrouping Property


InitialOrColumnsCount Property

InitialOrColumnsCount Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryColumnListOptions Class : InitialOrColumnsCount Property
Specifies the number of "Or" columns initially displayed in the grid.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property InitialOrColumnsCount As System.Integer
'Usage

Dim instance As QueryColumnListOptions
Dim value As System.Integer

instance.InitialOrColumnsCount = value

value = instance.InitialOrColumnsCount
public System.int InitialOrColumnsCount {get; set;}
public: __property System.int get_InitialOrColumnsCount();
public: __property void set_InitialOrColumnsCount(
   System.int value
);
Requirements

See Also

Reference

QueryColumnListOptions Class
QueryColumnListOptions Members


NullOrderingInOrderBy Property

NullOrderingInOrderBy Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryColumnListOptions Class : NullOrderingInOrderBy Property
Allows to display "NULLS FIRST"/"NULLS LAST" options in the Sort Type column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property NullOrderingInOrderBy As System.Boolean
'Usage

Dim instance As QueryColumnListOptions
Dim value As System.Boolean

instance.NullOrderingInOrderBy = value

value = instance.NullOrderingInOrderBy
public System.bool NullOrderingInOrderBy {get; set;}
public: __property System.bool get_NullOrderingInOrderBy();
public: __property void set_NullOrderingInOrderBy(
   System.bool value
);
Requirements

See Also

Reference

QueryColumnListOptions Class
QueryColumnListOptions Members


OutputColumnWidth Property

OutputColumnWidth Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryColumnListOptions Class : OutputColumnWidth Property
Specifies width of the Output check box column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property OutputColumnWidth As System.Integer
'Usage

Dim instance As QueryColumnListOptions
Dim value As System.Integer

instance.OutputColumnWidth = value

value = instance.OutputColumnWidth
public System.int OutputColumnWidth {get; set;}
public: __property System.int get_OutputColumnWidth();
public: __property void set_OutputColumnWidth(
   System.int value
);
Requirements

See Also

Reference

QueryColumnListOptions Class
QueryColumnListOptions Members


RowHeadersWidth Property

RowHeadersWidth Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryColumnListOptions Class : RowHeadersWidth Property
Specifies width of the row header column (the most-left column for dragging rows).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property RowHeadersWidth As System.Integer
'Usage

Dim instance As QueryColumnListOptions
Dim value As System.Integer

instance.RowHeadersWidth = value

value = instance.RowHeadersWidth
public System.int RowHeadersWidth {get; set;}
public: __property System.int get_RowHeadersWidth();
public: __property void set_RowHeadersWidth(
   System.int value
);
Requirements

See Also

Reference

QueryColumnListOptions Class
QueryColumnListOptions Members


SortOrderColumnWidth Property

SortOrderColumnWidth Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryColumnListOptions Class : SortOrderColumnWidth Property
Specifies width of the "Sort Order" column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SortOrderColumnWidth As System.Integer
'Usage

Dim instance As QueryColumnListOptions
Dim value As System.Integer

instance.SortOrderColumnWidth = value

value = instance.SortOrderColumnWidth
public System.int SortOrderColumnWidth {get; set;}
public: __property System.int get_SortOrderColumnWidth();
public: __property void set_SortOrderColumnWidth(
   System.int value
);
Requirements

See Also

Reference

QueryColumnListOptions Class
QueryColumnListOptions Members


SortTypeColumnWidth Property

SortTypeColumnWidth Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryColumnListOptions Class : SortTypeColumnWidth Property
Specifies width of the "Sort Type" column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SortTypeColumnWidth As System.Integer
'Usage

Dim instance As QueryColumnListOptions
Dim value As System.Integer

instance.SortTypeColumnWidth = value

value = instance.SortTypeColumnWidth
public System.int SortTypeColumnWidth {get; set;}
public: __property System.int get_SortTypeColumnWidth();
public: __property void set_SortTypeColumnWidth(
   System.int value
);
Requirements

See Also

Reference

QueryColumnListOptions Class
QueryColumnListOptions Members


TextColor Property (QueryColumnListOptions)

TextColor Property (QueryColumnListOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryColumnListOptions Class : TextColor Property
Gets or sets the color of the text displayed by the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property TextColor As System.Drawing.Color
'Usage

Dim instance As QueryColumnListOptions
Dim value As System.Drawing.Color

instance.TextColor = value

value = instance.TextColor
public System.Drawing.Color TextColor {get; set;}
public: __property System.Drawing.Color get_TextColor();
public: __property void set_TextColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

QueryColumnListOptions Class
QueryColumnListOptions Members


UseCustomExpressionBuilder Property

UseCustomExpressionBuilder Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryColumnListOptions Class : UseCustomExpressionBuilder Property
Allows to use custom expression builder for Expression and/or condition columns of the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property UseCustomExpressionBuilder As AffectedColumns
'Usage

Dim instance As QueryColumnListOptions
Dim value As AffectedColumns

instance.UseCustomExpressionBuilder = value

value = instance.UseCustomExpressionBuilder
public AffectedColumns UseCustomExpressionBuilder {get; set;}
public: __property AffectedColumns get_UseCustomExpressionBuilder();
public: __property void set_UseCustomExpressionBuilder(
   AffectedColumns value
);
Remarks

When this option is enabled for a column, the ellipsis button appears at this column while editing it's content. By clicking this button, the component fires the QueryBuilder.CustomExpressionBuilder event. The handler for this event should provide the way to edit this column's content and return the result.

Note: Active Query Builder Professional .NET Subscription includes the Expression Editor facility with code completion and syntax highlight to be used for the same purpose.

Requirements

See Also

Reference

QueryColumnListOptions Class
QueryColumnListOptions Members
DisableDirectEditingIn Property


UseMSStyleGrouping Property

UseMSStyleGrouping Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryColumnListOptions Class : UseMSStyleGrouping Property
Allows to change the way the end-user defines grouping for the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property UseMSStyleGrouping As System.Boolean
'Usage

Dim instance As QueryColumnListOptions
Dim value As System.Boolean

instance.UseMSStyleGrouping = value

value = instance.UseMSStyleGrouping
public System.bool UseMSStyleGrouping {get; set;}
public: __property System.bool get_UseMSStyleGrouping();
public: __property void set_UseMSStyleGrouping(
   System.bool value
);
Remarks
Setting this property to true turns the control to the old-style grouping mode similar to the query building facilities of MS Access and SQL Server Management Studio.
Requirements

See Also

Reference

QueryColumnListOptions Class
QueryColumnListOptions Members


QueryStatistics Class

QueryStatistics Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : QueryStatistics Class
Allows to retrieve various information about the query: list of used database objects and their fields, list of output query columns.
Object Model
QueryStatistics ClassStatisticsOutputColumnList ClassStatisticsOutputColumn ClassStatisticsFieldList ClassStatisticsField ClassStatisticsDatabaseObjectList ClassStatisticsDatabaseObject Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class QueryStatistics
   Inherits StatisticsBase
'Usage

Dim instance As QueryStatistics
public class QueryStatistics : StatisticsBase
public __gc class QueryStatistics : public StatisticsBase
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.QueryStatistics

Requirements

See Also

Reference

QueryStatistics Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


QueryStatistics Class Members

QueryStatistics Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : QueryStatistics Class

The following tables list the members exposed by QueryStatistics.

Public Properties
 | Name | Description
Public Property | OutputColumns | Gets list of the query result set expressions (output columns of the query).
Public Property | UsedDatabaseObjectFields | Gets list of database object fields that were used in the query.
Public Property | UsedDatabaseObjects | Gets list of database objects that were used in the query.
Top
See Also

Reference

QueryStatistics Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


QueryStatistics Class Properties

QueryStatistics Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : QueryStatistics Class

For a list of all members of this type, see QueryStatistics members.

Public Properties
 | Name | Description
Public Property | OutputColumns | Gets list of the query result set expressions (output columns of the query).
Public Property | UsedDatabaseObjectFields | Gets list of database object fields that were used in the query.
Public Property | UsedDatabaseObjects | Gets list of database objects that were used in the query.
Top
See Also

Reference

QueryStatistics Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


OutputColumns Property

OutputColumns Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryStatistics Class : OutputColumns Property
Gets list of the query result set expressions (output columns of the query).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property OutputColumns As StatisticsOutputColumnList
'Usage

Dim instance As QueryStatistics
Dim value As StatisticsOutputColumnList

value = instance.OutputColumns
public StatisticsOutputColumnList OutputColumns {get;}
public: __property StatisticsOutputColumnList* get_OutputColumns();
Requirements

See Also

Reference

QueryStatistics Class
QueryStatistics Members


UsedDatabaseObjectFields Property (QueryStatistics)

UsedDatabaseObjectFields Property (QueryStatistics)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryStatistics Class : UsedDatabaseObjectFields Property
Gets list of database object fields that were used in the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property UsedDatabaseObjectFields As StatisticsFieldList
'Usage

Dim instance As QueryStatistics
Dim value As StatisticsFieldList

value = instance.UsedDatabaseObjectFields
public StatisticsFieldList UsedDatabaseObjectFields {get;}
public: __property StatisticsFieldList* get_UsedDatabaseObjectFields();
Example
Use the Selected Property to get list of fields that were used for output (in the SELECT list of the query).
Requirements

See Also

Reference

QueryStatistics Class
QueryStatistics Members


UsedDatabaseObjects Property

UsedDatabaseObjects Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryStatistics Class : UsedDatabaseObjects Property
Gets list of database objects that were used in the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property UsedDatabaseObjects As StatisticsDatabaseObjectList
'Usage

Dim instance As QueryStatistics
Dim value As StatisticsDatabaseObjectList

value = instance.UsedDatabaseObjects
public StatisticsDatabaseObjectList UsedDatabaseObjects {get;}
public: __property StatisticsDatabaseObjectList* get_UsedDatabaseObjects();
Requirements

See Also

Reference

QueryStatistics Class
QueryStatistics Members


QueryStructureTreeOptions Class

QueryStructureTreeOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : QueryStructureTreeOptions Class
Contains various properties of the Query Structure Tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class QueryStructureTreeOptions
   Inherits UpdatablePersistent
'Usage

Dim instance As QueryStructureTreeOptions
public class QueryStructureTreeOptions : UpdatablePersistent
public __gc class QueryStructureTreeOptions : public UpdatablePersistent
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.QueryStructureTreeOptions

Requirements

See Also

Reference

QueryStructureTreeOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
QueryStructureTreeOptions Property


QueryStructureTreeOptions Class Members

QueryStructureTreeOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : QueryStructureTreeOptions Class

The following tables list the members exposed by QueryStructureTreeOptions.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color for the Query Structure Tree Pane.
Public Property | DataSourceImageIndex | Gets or sets the image list index value of the image displayed for query data sources (database objects or sub-queries).
Public Property | DataSourcesNodeImageIndex | Gets or sets the image list index value of the image displayed for query data sources grouping nodes.
Public Property | DataSourcesNodeText | Gets or sets the caption for node that groups query data sources.
Public Property | ExpandDataSourceNodes | Instructs the component to expand nodes that groups query data sources by default.
Public Property | ExpandExpressionNodes | Instructs the component to expand nodes that groups query expressions by default.
Public Property | ExpandQueryNodes | Instructs the component to expand sub-query nodes by default.
Public Property | ExpandUnionNodes | Instructs the component to expand nodes that groups union sub-queries by default.
Public Property | ExpressionImageIndex | Gets or sets the image list index value of the image displayed for query expressions.
Public Property | ExpressionsNodeImageIndex | Gets or sets the image list index value of the image displayed for expression grouping nodes.
Public Property | ExpressionsNodeText | Gets or sets the caption for node that groups query expressions.
Public Property | Font | Gets or sets the font of the text displayed in the nodes of Query Structure Tree.
Public Property | ImageList | Gets or sets ImageList object to use when displaying icons for the nodes of Query Structure Tree.
Public Property | QueriesImageIndex | Gets or sets the image list index value of the image displayed for sub-queries.
Public Property | ShowDataSources | Instructs the component to show query data sources in the Query Structure Tree.
Public Property | ShowExpressions | Instructs the component to show query expressions in the Query Structure Tree.
Public Property | TextColor | Gets or sets the text color for the Query Structure Tree Pane.
Public Property | UnionsNodeText | Gets or sets the caption for node that groups union sub-queries.
Top
See Also

Reference

QueryStructureTreeOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
QueryStructureTreeOptions Property


QueryStructureTreeOptions Class Properties

QueryStructureTreeOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : QueryStructureTreeOptions Class

For a list of all members of this type, see QueryStructureTreeOptions members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color for the Query Structure Tree Pane.
Public Property | DataSourceImageIndex | Gets or sets the image list index value of the image displayed for query data sources (database objects or sub-queries).
Public Property | DataSourcesNodeImageIndex | Gets or sets the image list index value of the image displayed for query data sources grouping nodes.
Public Property | DataSourcesNodeText | Gets or sets the caption for node that groups query data sources.
Public Property | ExpandDataSourceNodes | Instructs the component to expand nodes that groups query data sources by default.
Public Property | ExpandExpressionNodes | Instructs the component to expand nodes that groups query expressions by default.
Public Property | ExpandQueryNodes | Instructs the component to expand sub-query nodes by default.
Public Property | ExpandUnionNodes | Instructs the component to expand nodes that groups union sub-queries by default.
Public Property | ExpressionImageIndex | Gets or sets the image list index value of the image displayed for query expressions.
Public Property | ExpressionsNodeImageIndex | Gets or sets the image list index value of the image displayed for expression grouping nodes.
Public Property | ExpressionsNodeText | Gets or sets the caption for node that groups query expressions.
Public Property | Font | Gets or sets the font of the text displayed in the nodes of Query Structure Tree.
Public Property | ImageList | Gets or sets ImageList object to use when displaying icons for the nodes of Query Structure Tree.
Public Property | QueriesImageIndex | Gets or sets the image list index value of the image displayed for sub-queries.
Public Property | ShowDataSources | Instructs the component to show query data sources in the Query Structure Tree.
Public Property | ShowExpressions | Instructs the component to show query expressions in the Query Structure Tree.
Public Property | TextColor | Gets or sets the text color for the Query Structure Tree Pane.
Public Property | UnionsNodeText | Gets or sets the caption for node that groups union sub-queries.
Top
See Also

Reference

QueryStructureTreeOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
QueryStructureTreeOptions Property


BackColor Property (QueryStructureTreeOptions)

BackColor Property (QueryStructureTreeOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryStructureTreeOptions Class : BackColor Property
Gets or sets the background color for the Query Structure Tree Pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property BackColor As System.Drawing.Color
'Usage

Dim instance As QueryStructureTreeOptions
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
public System.Drawing.Color BackColor {get; set;}
public: __property System.Drawing.Color get_BackColor();
public: __property void set_BackColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

QueryStructureTreeOptions Class
QueryStructureTreeOptions Members


DataSourceImageIndex Property

DataSourceImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryStructureTreeOptions Class : DataSourceImageIndex Property
Gets or sets the image list index value of the image displayed for query data sources (database objects or sub-queries).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DataSourceImageIndex As System.Integer
'Usage

Dim instance As QueryStructureTreeOptions
Dim value As System.Integer

instance.DataSourceImageIndex = value

value = instance.DataSourceImageIndex
public System.int DataSourceImageIndex {get; set;}
public: __property System.int get_DataSourceImageIndex();
public: __property void set_DataSourceImageIndex(
   System.int value
);
Requirements

See Also

Reference

QueryStructureTreeOptions Class
QueryStructureTreeOptions Members


DataSourcesNodeImageIndex Property

DataSourcesNodeImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryStructureTreeOptions Class : DataSourcesNodeImageIndex Property
Gets or sets the image list index value of the image displayed for query data sources grouping nodes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DataSourcesNodeImageIndex As System.Integer
'Usage

Dim instance As QueryStructureTreeOptions
Dim value As System.Integer

instance.DataSourcesNodeImageIndex = value

value = instance.DataSourcesNodeImageIndex
public System.int DataSourcesNodeImageIndex {get; set;}
public: __property System.int get_DataSourcesNodeImageIndex();
public: __property void set_DataSourcesNodeImageIndex(
   System.int value
);
Requirements

See Also

Reference

QueryStructureTreeOptions Class
QueryStructureTreeOptions Members


DataSourcesNodeText Property

DataSourcesNodeText Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryStructureTreeOptions Class : DataSourcesNodeText Property
Gets or sets the caption for node that groups query data sources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property DataSourcesNodeText As System.String
'Usage

Dim instance As QueryStructureTreeOptions
Dim value As System.String

instance.DataSourcesNodeText = value

value = instance.DataSourcesNodeText
public System.string DataSourcesNodeText {get; set;}
public: __property System.string* get_DataSourcesNodeText();
public: __property void set_DataSourcesNodeText(
   System.string* value
);
Requirements

See Also

Reference

QueryStructureTreeOptions Class
QueryStructureTreeOptions Members


ExpandDataSourceNodes Property

ExpandDataSourceNodes Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryStructureTreeOptions Class : ExpandDataSourceNodes Property
Instructs the component to expand nodes that groups query data sources by default.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ExpandDataSourceNodes As System.Boolean
'Usage

Dim instance As QueryStructureTreeOptions
Dim value As System.Boolean

instance.ExpandDataSourceNodes = value

value = instance.ExpandDataSourceNodes
public System.bool ExpandDataSourceNodes {get; set;}
public: __property System.bool get_ExpandDataSourceNodes();
public: __property void set_ExpandDataSourceNodes(
   System.bool value
);
Requirements

See Also

Reference

QueryStructureTreeOptions Class
QueryStructureTreeOptions Members


ExpandExpressionNodes Property

ExpandExpressionNodes Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryStructureTreeOptions Class : ExpandExpressionNodes Property
Instructs the component to expand nodes that groups query expressions by default.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ExpandExpressionNodes As System.Boolean
'Usage

Dim instance As QueryStructureTreeOptions
Dim value As System.Boolean

instance.ExpandExpressionNodes = value

value = instance.ExpandExpressionNodes
public System.bool ExpandExpressionNodes {get; set;}
public: __property System.bool get_ExpandExpressionNodes();
public: __property void set_ExpandExpressionNodes(
   System.bool value
);
Requirements

See Also

Reference

QueryStructureTreeOptions Class
QueryStructureTreeOptions Members


ExpandQueryNodes Property

ExpandQueryNodes Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryStructureTreeOptions Class : ExpandQueryNodes Property
Instructs the component to expand sub-query nodes by default.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ExpandQueryNodes As System.Boolean
'Usage

Dim instance As QueryStructureTreeOptions
Dim value As System.Boolean

instance.ExpandQueryNodes = value

value = instance.ExpandQueryNodes
public System.bool ExpandQueryNodes {get; set;}
public: __property System.bool get_ExpandQueryNodes();
public: __property void set_ExpandQueryNodes(
   System.bool value
);
Requirements

See Also

Reference

QueryStructureTreeOptions Class
QueryStructureTreeOptions Members


ExpandUnionNodes Property

ExpandUnionNodes Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryStructureTreeOptions Class : ExpandUnionNodes Property
Instructs the component to expand nodes that groups union sub-queries by default.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ExpandUnionNodes As System.Boolean
'Usage

Dim instance As QueryStructureTreeOptions
Dim value As System.Boolean

instance.ExpandUnionNodes = value

value = instance.ExpandUnionNodes
public System.bool ExpandUnionNodes {get; set;}
public: __property System.bool get_ExpandUnionNodes();
public: __property void set_ExpandUnionNodes(
   System.bool value
);
Requirements

See Also

Reference

QueryStructureTreeOptions Class
QueryStructureTreeOptions Members


ExpressionImageIndex Property

ExpressionImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryStructureTreeOptions Class : ExpressionImageIndex Property
Gets or sets the image list index value of the image displayed for query expressions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ExpressionImageIndex As System.Integer
'Usage

Dim instance As QueryStructureTreeOptions
Dim value As System.Integer

instance.ExpressionImageIndex = value

value = instance.ExpressionImageIndex
public System.int ExpressionImageIndex {get; set;}
public: __property System.int get_ExpressionImageIndex();
public: __property void set_ExpressionImageIndex(
   System.int value
);
Requirements

See Also

Reference

QueryStructureTreeOptions Class
QueryStructureTreeOptions Members


ExpressionsNodeImageIndex Property

ExpressionsNodeImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryStructureTreeOptions Class : ExpressionsNodeImageIndex Property
Gets or sets the image list index value of the image displayed for expression grouping nodes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ExpressionsNodeImageIndex As System.Integer
'Usage

Dim instance As QueryStructureTreeOptions
Dim value As System.Integer

instance.ExpressionsNodeImageIndex = value

value = instance.ExpressionsNodeImageIndex
public System.int ExpressionsNodeImageIndex {get; set;}
public: __property System.int get_ExpressionsNodeImageIndex();
public: __property void set_ExpressionsNodeImageIndex(
   System.int value
);
Requirements

See Also

Reference

QueryStructureTreeOptions Class
QueryStructureTreeOptions Members


ExpressionsNodeText Property

ExpressionsNodeText Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryStructureTreeOptions Class : ExpressionsNodeText Property
Gets or sets the caption for node that groups query expressions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ExpressionsNodeText As System.String
'Usage

Dim instance As QueryStructureTreeOptions
Dim value As System.String

instance.ExpressionsNodeText = value

value = instance.ExpressionsNodeText
public System.string ExpressionsNodeText {get; set;}
public: __property System.string* get_ExpressionsNodeText();
public: __property void set_ExpressionsNodeText(
   System.string* value
);
Requirements

See Also

Reference

QueryStructureTreeOptions Class
QueryStructureTreeOptions Members


Font Property (QueryStructureTreeOptions)

Font Property (QueryStructureTreeOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryStructureTreeOptions Class : Font Property
Gets or sets the font of the text displayed in the nodes of Query Structure Tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Font As System.Drawing.Font
'Usage

Dim instance As QueryStructureTreeOptions
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
public System.Drawing.Font Font {get; set;}
public: __property System.Drawing.Font* get_Font();
public: __property void set_Font(
   System.Drawing.Font* value
);
Requirements

See Also

Reference

QueryStructureTreeOptions Class
QueryStructureTreeOptions Members


ImageList Property (QueryStructureTreeOptions)

ImageList Property (QueryStructureTreeOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryStructureTreeOptions Class : ImageList Property
Gets or sets ImageList object to use when displaying icons for the nodes of Query Structure Tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ImageList As System.Windows.Forms.ImageList
'Usage

Dim instance As QueryStructureTreeOptions
Dim value As System.Windows.Forms.ImageList

instance.ImageList = value

value = instance.ImageList
public System.Windows.Forms.ImageList ImageList {get; set;}
public: __property System.Windows.Forms.ImageList* get_ImageList();
public: __property void set_ImageList(
   System.Windows.Forms.ImageList* value
);
Requirements

See Also

Reference

QueryStructureTreeOptions Class
QueryStructureTreeOptions Members


QueriesImageIndex Property

QueriesImageIndex Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryStructureTreeOptions Class : QueriesImageIndex Property
Gets or sets the image list index value of the image displayed for sub-queries.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property QueriesImageIndex As System.Integer
'Usage

Dim instance As QueryStructureTreeOptions
Dim value As System.Integer

instance.QueriesImageIndex = value

value = instance.QueriesImageIndex
public System.int QueriesImageIndex {get; set;}
public: __property System.int get_QueriesImageIndex();
public: __property void set_QueriesImageIndex(
   System.int value
);
Requirements

See Also

Reference

QueryStructureTreeOptions Class
QueryStructureTreeOptions Members


ShowDataSources Property

ShowDataSources Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryStructureTreeOptions Class : ShowDataSources Property
Instructs the component to show query data sources in the Query Structure Tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ShowDataSources As System.Boolean
'Usage

Dim instance As QueryStructureTreeOptions
Dim value As System.Boolean

instance.ShowDataSources = value

value = instance.ShowDataSources
public System.bool ShowDataSources {get; set;}
public: __property System.bool get_ShowDataSources();
public: __property void set_ShowDataSources(
   System.bool value
);
Requirements

See Also

Reference

QueryStructureTreeOptions Class
QueryStructureTreeOptions Members


ShowExpressions Property

ShowExpressions Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryStructureTreeOptions Class : ShowExpressions Property
Instructs the component to show query expressions in the Query Structure Tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ShowExpressions As System.Boolean
'Usage

Dim instance As QueryStructureTreeOptions
Dim value As System.Boolean

instance.ShowExpressions = value

value = instance.ShowExpressions
public System.bool ShowExpressions {get; set;}
public: __property System.bool get_ShowExpressions();
public: __property void set_ShowExpressions(
   System.bool value
);
Requirements

See Also

Reference

QueryStructureTreeOptions Class
QueryStructureTreeOptions Members


TextColor Property (QueryStructureTreeOptions)

TextColor Property (QueryStructureTreeOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryStructureTreeOptions Class : TextColor Property
Gets or sets the text color for the Query Structure Tree Pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property TextColor As System.Drawing.Color
'Usage

Dim instance As QueryStructureTreeOptions
Dim value As System.Drawing.Color

instance.TextColor = value

value = instance.TextColor
public System.Drawing.Color TextColor {get; set;}
public: __property System.Drawing.Color get_TextColor();
public: __property void set_TextColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

QueryStructureTreeOptions Class
QueryStructureTreeOptions Members


UnionsNodeText Property

UnionsNodeText Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryStructureTreeOptions Class : UnionsNodeText Property
Gets or sets the caption for node that groups union sub-queries.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property UnionsNodeText As System.String
'Usage

Dim instance As QueryStructureTreeOptions
Dim value As System.String

instance.UnionsNodeText = value

value = instance.UnionsNodeText
public System.string UnionsNodeText {get; set;}
public: __property System.string* get_UnionsNodeText();
public: __property void set_UnionsNodeText(
   System.string* value
);
Requirements

See Also

Reference

QueryStructureTreeOptions Class
QueryStructureTreeOptions Members


SQL2003SyntaxProvider Class

SQL2003SyntaxProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQL2003SyntaxProvider Class
Syntax provider for ANSI SQL/2003 standard.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class SQL2003SyntaxProvider
   Inherits BaseSyntaxProvider
'Usage

Dim instance As SQL2003SyntaxProvider
public class SQL2003SyntaxProvider : BaseSyntaxProvider
public __gc class SQL2003SyntaxProvider : public BaseSyntaxProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.SQL2003SyntaxProvider

Requirements

See Also

Reference

SQL2003SyntaxProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQL2003SyntaxProvider Class Members

SQL2003SyntaxProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQL2003SyntaxProvider Class

The following tables list the members exposed by SQL2003SyntaxProvider.

Public Properties
 | Name | Description
Public Property | IdentCaseSens | Overridden. Defines the way database server treats quoted and unquoted identifiers.
Public Property | UseInformationSchema | Instructs the component to try to retrieve database schema information from the INFORMATION_SCHEMA system objects.
Top
See Also

Reference

SQL2003SyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQL2003SyntaxProvider Class Properties

SQL2003SyntaxProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQL2003SyntaxProvider Class

For a list of all members of this type, see SQL2003SyntaxProvider members.

Public Properties
 | Name | Description
Public Property | IdentCaseSens | Overridden. Defines the way database server treats quoted and unquoted identifiers.
Public Property | UseInformationSchema | Instructs the component to try to retrieve database schema information from the INFORMATION_SCHEMA system objects.
Top
See Also

Reference

SQL2003SyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


IdentCaseSens Property (SQL2003SyntaxProvider)

IdentCaseSens Property (SQL2003SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL2003SyntaxProvider Class : IdentCaseSens Property
Defines the way database server treats quoted and unquoted identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property IdentCaseSens As IdentCaseSensitivity
'Usage

Dim instance As SQL2003SyntaxProvider
Dim value As IdentCaseSensitivity

instance.IdentCaseSens = value

value = instance.IdentCaseSens
public override IdentCaseSensitivity IdentCaseSens {get; set;}
public: __property IdentCaseSensitivity get_IdentCaseSens() override;
public: __property void set_IdentCaseSens(
   IdentCaseSensitivity value
) override;
Requirements

See Also

Reference

SQL2003SyntaxProvider Class
SQL2003SyntaxProvider Members
Base Implementation in IdentCaseSens


UseInformationSchema Property (SQL2003SyntaxProvider)

UseInformationSchema Property (SQL2003SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL2003SyntaxProvider Class : UseInformationSchema Property
Instructs the component to try to retrieve database schema information from the INFORMATION_SCHEMA system objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property UseInformationSchema As System.Boolean
'Usage

Dim instance As SQL2003SyntaxProvider
Dim value As System.Boolean

instance.UseInformationSchema = value

value = instance.UseInformationSchema
public System.bool UseInformationSchema {get; set;}
public: __property System.bool get_UseInformationSchema();
public: __property void set_UseInformationSchema(
   System.bool value
);

Property Value

true to use INFORMATION_SCHEMA, false to bypass querying INFORMATION_SCHEMA objects.
Remarks
In case of failure, the component will try to retrieve this information using Metadata Provider methods to query the underlying data access components.
Requirements

See Also

Reference

SQL2003SyntaxProvider Class
SQL2003SyntaxProvider Members


SQL89SyntaxProvider Class

SQL89SyntaxProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQL89SyntaxProvider Class
Syntax provider for ANSI SQL/89 standard.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class SQL89SyntaxProvider
   Inherits BaseSyntaxProvider
'Usage

Dim instance As SQL89SyntaxProvider
public class SQL89SyntaxProvider : BaseSyntaxProvider
public __gc class SQL89SyntaxProvider : public BaseSyntaxProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.SQL89SyntaxProvider

Requirements

See Also

Reference

SQL89SyntaxProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQL89SyntaxProvider Class Members

SQL89SyntaxProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQL89SyntaxProvider Class

The following tables list the members exposed by SQL89SyntaxProvider.

Public Properties
 | Name | Description
Public Property | IdentCaseSens | Overridden. Defines the way database server treats quoted and unquoted identifiers.
Top
See Also

Reference

SQL89SyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQL89SyntaxProvider Class Properties

SQL89SyntaxProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQL89SyntaxProvider Class

For a list of all members of this type, see SQL89SyntaxProvider members.

Public Properties
 | Name | Description
Public Property | IdentCaseSens | Overridden. Defines the way database server treats quoted and unquoted identifiers.
Top
See Also

Reference

SQL89SyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


IdentCaseSens Property (SQL89SyntaxProvider)

IdentCaseSens Property (SQL89SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL89SyntaxProvider Class : IdentCaseSens Property
Defines the way database server treats quoted and unquoted identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property IdentCaseSens As IdentCaseSensitivity
'Usage

Dim instance As SQL89SyntaxProvider
Dim value As IdentCaseSensitivity

instance.IdentCaseSens = value

value = instance.IdentCaseSens
public override IdentCaseSensitivity IdentCaseSens {get; set;}
public: __property IdentCaseSensitivity get_IdentCaseSens() override;
public: __property void set_IdentCaseSens(
   IdentCaseSensitivity value
) override;
Requirements

See Also

Reference

SQL89SyntaxProvider Class
SQL89SyntaxProvider Members
Base Implementation in IdentCaseSens


SQL92SyntaxProvider Class

SQL92SyntaxProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQL92SyntaxProvider Class
Syntax provider for ANSI SQL/92 standard.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class SQL92SyntaxProvider
   Inherits BaseSyntaxProvider
'Usage

Dim instance As SQL92SyntaxProvider
public class SQL92SyntaxProvider : BaseSyntaxProvider
public __gc class SQL92SyntaxProvider : public BaseSyntaxProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.SQL92SyntaxProvider

Requirements

See Also

Reference

SQL92SyntaxProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQL92SyntaxProvider Class Members

SQL92SyntaxProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQL92SyntaxProvider Class

The following tables list the members exposed by SQL92SyntaxProvider.

Public Properties
 | Name | Description
Public Property | IdentCaseSens | Overridden. Defines the way database server treats quoted and unquoted identifiers.
Public Property | UseInformationSchema | Instructs the component to try to retrieve database schema information from the INFORMATION_SCHEMA system objects.
Top
See Also

Reference

SQL92SyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQL92SyntaxProvider Class Properties

SQL92SyntaxProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQL92SyntaxProvider Class

For a list of all members of this type, see SQL92SyntaxProvider members.

Public Properties
 | Name | Description
Public Property | IdentCaseSens | Overridden. Defines the way database server treats quoted and unquoted identifiers.
Public Property | UseInformationSchema | Instructs the component to try to retrieve database schema information from the INFORMATION_SCHEMA system objects.
Top
See Also

Reference

SQL92SyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


IdentCaseSens Property (SQL92SyntaxProvider)

IdentCaseSens Property (SQL92SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL92SyntaxProvider Class : IdentCaseSens Property
Defines the way database server treats quoted and unquoted identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property IdentCaseSens As IdentCaseSensitivity
'Usage

Dim instance As SQL92SyntaxProvider
Dim value As IdentCaseSensitivity

instance.IdentCaseSens = value

value = instance.IdentCaseSens
public override IdentCaseSensitivity IdentCaseSens {get; set;}
public: __property IdentCaseSensitivity get_IdentCaseSens() override;
public: __property void set_IdentCaseSens(
   IdentCaseSensitivity value
) override;
Requirements

See Also

Reference

SQL92SyntaxProvider Class
SQL92SyntaxProvider Members
Base Implementation in IdentCaseSens


UseInformationSchema Property (SQL92SyntaxProvider)

UseInformationSchema Property (SQL92SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL92SyntaxProvider Class : UseInformationSchema Property
Instructs the component to try to retrieve database schema information from the INFORMATION_SCHEMA system objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property UseInformationSchema As System.Boolean
'Usage

Dim instance As SQL92SyntaxProvider
Dim value As System.Boolean

instance.UseInformationSchema = value

value = instance.UseInformationSchema
public System.bool UseInformationSchema {get; set;}
public: __property System.bool get_UseInformationSchema();
public: __property void set_UseInformationSchema(
   System.bool value
);

Property Value

true to use INFORMATION_SCHEMA, false to bypass querying INFORMATION_SCHEMA objects.
Remarks
In case of failure, the component will try to retrieve this information using Metadata Provider methods to query the underlying data access components.
Requirements

See Also

Reference

SQL92SyntaxProvider Class
SQL92SyntaxProvider Members


SQLBuilderConditionFormat Class

SQLBuilderConditionFormat Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLBuilderConditionFormat Class
Defines SQL text formatting options of WHERE and HAVING parts of the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class SQLBuilderConditionFormat
   Inherits UpdatablePersistent
'Usage

Dim instance As SQLBuilderConditionFormat
public class SQLBuilderConditionFormat : UpdatablePersistent
public __gc class SQLBuilderConditionFormat : public UpdatablePersistent
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLBuilderConditionFormat

Requirements

See Also

Reference

SQLBuilderConditionFormat Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQLBuilderConditionFormat Class Members

SQLBuilderConditionFormat Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLBuilderConditionFormat Class

The following tables list the members exposed by SQLBuilderConditionFormat.

Public Properties
 | Name | Description
Public Property | IndentNestedConditions | Defines indent of nested conditions.
Public Property | NewLineAfter | Defines line breaking rules in condition.
Top
See Also

Reference

SQLBuilderConditionFormat Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQLBuilderConditionFormat Class Properties

SQLBuilderConditionFormat Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLBuilderConditionFormat Class

For a list of all members of this type, see SQLBuilderConditionFormat members.

Public Properties
 | Name | Description
Public Property | IndentNestedConditions | Defines indent of nested conditions.
Public Property | NewLineAfter | Defines line breaking rules in condition.
Top
See Also

Reference

SQLBuilderConditionFormat Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


IndentNestedConditions Property

IndentNestedConditions Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLBuilderConditionFormat Class : IndentNestedConditions Property
Defines indent of nested conditions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property IndentNestedConditions As System.Integer
'Usage

Dim instance As SQLBuilderConditionFormat
Dim value As System.Integer

instance.IndentNestedConditions = value

value = instance.IndentNestedConditions
public System.int IndentNestedConditions {get; set;}
public: __property System.int get_IndentNestedConditions();
public: __property void set_IndentNestedConditions(
   System.int value
);
Requirements

See Also

Reference

SQLBuilderConditionFormat Class
SQLBuilderConditionFormat Members


NewLineAfter Property

NewLineAfter Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLBuilderConditionFormat Class : NewLineAfter Property
Defines line breaking rules in condition.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property NewLineAfter As SQLBuilderConditionFormatNL
'Usage

Dim instance As SQLBuilderConditionFormat
Dim value As SQLBuilderConditionFormatNL

instance.NewLineAfter = value

value = instance.NewLineAfter
public SQLBuilderConditionFormatNL NewLineAfter {get; set;}
public: __property SQLBuilderConditionFormatNL get_NewLineAfter();
public: __property void set_NewLineAfter(
   SQLBuilderConditionFormatNL value
);
Requirements

See Also

Reference

SQLBuilderConditionFormat Class
SQLBuilderConditionFormat Members


SQLBuilderFromClauseFormat Class

SQLBuilderFromClauseFormat Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLBuilderFromClauseFormat Class
Defines SQL text formatting options of FROM part of the query.
Object Model
SQLBuilderFromClauseFormat ClassSQLBuilderConditionFormat Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class SQLBuilderFromClauseFormat
   Inherits UpdatablePersistent
'Usage

Dim instance As SQLBuilderFromClauseFormat
public class SQLBuilderFromClauseFormat : UpdatablePersistent
public __gc class SQLBuilderFromClauseFormat : public UpdatablePersistent
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLBuilderFromClauseFormat

Requirements

See Also

Reference

SQLBuilderFromClauseFormat Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQLBuilderFromClauseFormat Class Members

SQLBuilderFromClauseFormat Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLBuilderFromClauseFormat Class

The following tables list the members exposed by SQLBuilderFromClauseFormat.

Public Properties
 | Name | Description
Public Property | JoinConditionFormat | Determines SQL text formatting options of joining conditions in the FROM part of query.
Public Property | NewLineAfterDatasource | Instructs to insert line break after each datasource.
Public Property | NewLineAfterJoin | Instructs to insert line break after each JOIN keyword.
Public Property | NewLineBeforeComma | Instructs to insert line break before each comma that separates items in the list.
Public Property | NewLineBeforeJoinExpression | Instructs to start join expressions from new lines.
Top
See Also

Reference

SQLBuilderFromClauseFormat Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQLBuilderFromClauseFormat Class Properties

SQLBuilderFromClauseFormat Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLBuilderFromClauseFormat Class

For a list of all members of this type, see SQLBuilderFromClauseFormat members.

Public Properties
 | Name | Description
Public Property | JoinConditionFormat | Determines SQL text formatting options of joining conditions in the FROM part of query.
Public Property | NewLineAfterDatasource | Instructs to insert line break after each datasource.
Public Property | NewLineAfterJoin | Instructs to insert line break after each JOIN keyword.
Public Property | NewLineBeforeComma | Instructs to insert line break before each comma that separates items in the list.
Public Property | NewLineBeforeJoinExpression | Instructs to start join expressions from new lines.
Top
See Also

Reference

SQLBuilderFromClauseFormat Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


JoinConditionFormat Property

JoinConditionFormat Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLBuilderFromClauseFormat Class : JoinConditionFormat Property
Determines SQL text formatting options of joining conditions in the FROM part of query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property JoinConditionFormat As SQLBuilderConditionFormat
'Usage

Dim instance As SQLBuilderFromClauseFormat
Dim value As SQLBuilderConditionFormat

instance.JoinConditionFormat = value

value = instance.JoinConditionFormat
public SQLBuilderConditionFormat JoinConditionFormat {get; set;}
public: __property SQLBuilderConditionFormat* get_JoinConditionFormat();
public: __property void set_JoinConditionFormat(
   SQLBuilderConditionFormat* value
);
Requirements

See Also

Reference

SQLBuilderFromClauseFormat Class
SQLBuilderFromClauseFormat Members


NewLineAfterDatasource Property

NewLineAfterDatasource Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLBuilderFromClauseFormat Class : NewLineAfterDatasource Property
Instructs to insert line break after each datasource.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property NewLineAfterDatasource As System.Boolean
'Usage

Dim instance As SQLBuilderFromClauseFormat
Dim value As System.Boolean

instance.NewLineAfterDatasource = value

value = instance.NewLineAfterDatasource
public System.bool NewLineAfterDatasource {get; set;}
public: __property System.bool get_NewLineAfterDatasource();
public: __property void set_NewLineAfterDatasource(
   System.bool value
);
Requirements

See Also

Reference

SQLBuilderFromClauseFormat Class
SQLBuilderFromClauseFormat Members


NewLineAfterJoin Property

NewLineAfterJoin Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLBuilderFromClauseFormat Class : NewLineAfterJoin Property
Instructs to insert line break after each JOIN keyword.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property NewLineAfterJoin As System.Boolean
'Usage

Dim instance As SQLBuilderFromClauseFormat
Dim value As System.Boolean

instance.NewLineAfterJoin = value

value = instance.NewLineAfterJoin
public System.bool NewLineAfterJoin {get; set;}
public: __property System.bool get_NewLineAfterJoin();
public: __property void set_NewLineAfterJoin(
   System.bool value
);
Requirements

See Also

Reference

SQLBuilderFromClauseFormat Class
SQLBuilderFromClauseFormat Members


NewLineBeforeComma Property (SQLBuilderFromClauseFormat)

NewLineBeforeComma Property (SQLBuilderFromClauseFormat)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLBuilderFromClauseFormat Class : NewLineBeforeComma Property
Instructs to insert line break before each comma that separates items in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property NewLineBeforeComma As System.Boolean
'Usage

Dim instance As SQLBuilderFromClauseFormat
Dim value As System.Boolean

instance.NewLineBeforeComma = value

value = instance.NewLineBeforeComma
public System.bool NewLineBeforeComma {get; set;}
public: __property System.bool get_NewLineBeforeComma();
public: __property void set_NewLineBeforeComma(
   System.bool value
);
Requirements

See Also

Reference

SQLBuilderFromClauseFormat Class
SQLBuilderFromClauseFormat Members


NewLineBeforeJoinExpression Property

NewLineBeforeJoinExpression Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLBuilderFromClauseFormat Class : NewLineBeforeJoinExpression Property
Instructs to start join expressions from new lines.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property NewLineBeforeJoinExpression As System.Boolean
'Usage

Dim instance As SQLBuilderFromClauseFormat
Dim value As System.Boolean

instance.NewLineBeforeJoinExpression = value

value = instance.NewLineBeforeJoinExpression
public System.bool NewLineBeforeJoinExpression {get; set;}
public: __property System.bool get_NewLineBeforeJoinExpression();
public: __property void set_NewLineBeforeJoinExpression(
   System.bool value
);
Requirements

See Also

Reference

SQLBuilderFromClauseFormat Class
SQLBuilderFromClauseFormat Members


SQLBuilderItemListFormat Class

SQLBuilderItemListFormat Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLBuilderItemListFormat Class
Defines SQL text formatting options of item lists in the query, i.e. SELECT, ORDER BY and GROUP BY parts of the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class SQLBuilderItemListFormat
   Inherits UpdatablePersistent
'Usage

Dim instance As SQLBuilderItemListFormat
public class SQLBuilderItemListFormat : UpdatablePersistent
public __gc class SQLBuilderItemListFormat : public UpdatablePersistent
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLBuilderItemListFormat

Requirements

See Also

Reference

SQLBuilderItemListFormat Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQLBuilderItemListFormat Class Members

SQLBuilderItemListFormat Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLBuilderItemListFormat Class

The following tables list the members exposed by SQLBuilderItemListFormat.

Public Properties
 | Name | Description
Public Property | NewLineAfterItem | Instructs to insert line break after each item in the list.
Public Property | NewLineBeforeComma | Instructs to insert line break before each comma that separates items in the list.
Top
See Also

Reference

SQLBuilderItemListFormat Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQLBuilderItemListFormat Class Properties

SQLBuilderItemListFormat Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLBuilderItemListFormat Class

For a list of all members of this type, see SQLBuilderItemListFormat members.

Public Properties
 | Name | Description
Public Property | NewLineAfterItem | Instructs to insert line break after each item in the list.
Public Property | NewLineBeforeComma | Instructs to insert line break before each comma that separates items in the list.
Top
See Also

Reference

SQLBuilderItemListFormat Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


NewLineAfterItem Property

NewLineAfterItem Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLBuilderItemListFormat Class : NewLineAfterItem Property
Instructs to insert line break after each item in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property NewLineAfterItem As System.Boolean
'Usage

Dim instance As SQLBuilderItemListFormat
Dim value As System.Boolean

instance.NewLineAfterItem = value

value = instance.NewLineAfterItem
public System.bool NewLineAfterItem {get; set;}
public: __property System.bool get_NewLineAfterItem();
public: __property void set_NewLineAfterItem(
   System.bool value
);
Requirements

See Also

Reference

SQLBuilderItemListFormat Class
SQLBuilderItemListFormat Members


NewLineBeforeComma Property (SQLBuilderItemListFormat)

NewLineBeforeComma Property (SQLBuilderItemListFormat)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLBuilderItemListFormat Class : NewLineBeforeComma Property
Instructs to insert line break before each comma that separates items in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property NewLineBeforeComma As System.Boolean
'Usage

Dim instance As SQLBuilderItemListFormat
Dim value As System.Boolean

instance.NewLineBeforeComma = value

value = instance.NewLineBeforeComma
public System.bool NewLineBeforeComma {get; set;}
public: __property System.bool get_NewLineBeforeComma();
public: __property void set_NewLineBeforeComma(
   System.bool value
);
Requirements

See Also

Reference

SQLBuilderItemListFormat Class
SQLBuilderItemListFormat Members


SQLBuilderSelectFormat Class

SQLBuilderSelectFormat Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLBuilderSelectFormat Class
Defines SQL text formatting options of a single SELECT statement.
Object Model
SQLBuilderSelectFormat ClassSQLBuilderFromClauseFormat ClassSQLBuilderItemListFormat ClassSQLBuilderConditionFormat ClassSQLBuilderItemListFormat ClassSQLBuilderItemListFormat ClassSQLBuilderConditionFormat Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class SQLBuilderSelectFormat
   Inherits UpdatablePersistent
'Usage

Dim instance As SQLBuilderSelectFormat
public class SQLBuilderSelectFormat : UpdatablePersistent
public __gc class SQLBuilderSelectFormat : public UpdatablePersistent
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLBuilderSelectFormat

Requirements

See Also

Reference

SQLBuilderSelectFormat Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQLBuilderSelectFormat Class Members

SQLBuilderSelectFormat Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLBuilderSelectFormat Class

The following tables list the members exposed by SQLBuilderSelectFormat.

Public Properties
 | Name | Description
Public Property | FromClauseFormat | Determines SQL text formatting options of FROM part of the query.
Public Property | GroupByFormat | Determines SQL text formatting options of GROUP BY part of the query.
Public Property | HavingFormat | Determines SQL text formatting options of HAVING part of the query.
Public Property | IndentGlobal | Defines indent of the whole single SELECT statement.
Public Property | IndentInPart | Defines indent of all lines of the query except the main query part keyword lines.
Public Property | MainPartsFromNewLine | Instructs the component to start main parts of the query from new lines.
Public Property | NewLineAfterPartKeywords | Instructs to insert line break after each main query part keyword (SELECT, FROM, WHERE, etc.)
Public Property | OrderByFormat | Determines SQL text formatting options of ORDER BY part of the query.
Public Property | SelectListFormat | Determines SQL text formatting options of SELECT part (list of output expressions) of the query.
Public Property | WhereFormat | Determines SQL text formatting options of WHERE part of the query.
Top
See Also

Reference

SQLBuilderSelectFormat Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQLBuilderSelectFormat Class Properties

SQLBuilderSelectFormat Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLBuilderSelectFormat Class

For a list of all members of this type, see SQLBuilderSelectFormat members.

Public Properties
 | Name | Description
Public Property | FromClauseFormat | Determines SQL text formatting options of FROM part of the query.
Public Property | GroupByFormat | Determines SQL text formatting options of GROUP BY part of the query.
Public Property | HavingFormat | Determines SQL text formatting options of HAVING part of the query.
Public Property | IndentGlobal | Defines indent of the whole single SELECT statement.
Public Property | IndentInPart | Defines indent of all lines of the query except the main query part keyword lines.
Public Property | MainPartsFromNewLine | Instructs the component to start main parts of the query from new lines.
Public Property | NewLineAfterPartKeywords | Instructs to insert line break after each main query part keyword (SELECT, FROM, WHERE, etc.)
Public Property | OrderByFormat | Determines SQL text formatting options of ORDER BY part of the query.
Public Property | SelectListFormat | Determines SQL text formatting options of SELECT part (list of output expressions) of the query.
Public Property | WhereFormat | Determines SQL text formatting options of WHERE part of the query.
Top
See Also

Reference

SQLBuilderSelectFormat Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


FromClauseFormat Property

FromClauseFormat Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLBuilderSelectFormat Class : FromClauseFormat Property
Determines SQL text formatting options of FROM part of the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property FromClauseFormat As SQLBuilderFromClauseFormat
'Usage

Dim instance As SQLBuilderSelectFormat
Dim value As SQLBuilderFromClauseFormat

instance.FromClauseFormat = value

value = instance.FromClauseFormat
public SQLBuilderFromClauseFormat FromClauseFormat {get; set;}
public: __property SQLBuilderFromClauseFormat* get_FromClauseFormat();
public: __property void set_FromClauseFormat(
   SQLBuilderFromClauseFormat* value
);
Requirements

See Also

Reference

SQLBuilderSelectFormat Class
SQLBuilderSelectFormat Members


GroupByFormat Property

GroupByFormat Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLBuilderSelectFormat Class : GroupByFormat Property
Determines SQL text formatting options of GROUP BY part of the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property GroupByFormat As SQLBuilderItemListFormat
'Usage

Dim instance As SQLBuilderSelectFormat
Dim value As SQLBuilderItemListFormat

instance.GroupByFormat = value

value = instance.GroupByFormat
public SQLBuilderItemListFormat GroupByFormat {get; set;}
public: __property SQLBuilderItemListFormat* get_GroupByFormat();
public: __property void set_GroupByFormat(
   SQLBuilderItemListFormat* value
);
Requirements

See Also

Reference

SQLBuilderSelectFormat Class
SQLBuilderSelectFormat Members


HavingFormat Property

HavingFormat Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLBuilderSelectFormat Class : HavingFormat Property
Determines SQL text formatting options of HAVING part of the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property HavingFormat As SQLBuilderConditionFormat
'Usage

Dim instance As SQLBuilderSelectFormat
Dim value As SQLBuilderConditionFormat

instance.HavingFormat = value

value = instance.HavingFormat
public SQLBuilderConditionFormat HavingFormat {get; set;}
public: __property SQLBuilderConditionFormat* get_HavingFormat();
public: __property void set_HavingFormat(
   SQLBuilderConditionFormat* value
);
Requirements

See Also

Reference

SQLBuilderSelectFormat Class
SQLBuilderSelectFormat Members


IndentGlobal Property

IndentGlobal Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLBuilderSelectFormat Class : IndentGlobal Property
Defines indent of the whole single SELECT statement.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property IndentGlobal As System.Integer
'Usage

Dim instance As SQLBuilderSelectFormat
Dim value As System.Integer

instance.IndentGlobal = value

value = instance.IndentGlobal
public System.int IndentGlobal {get; set;}
public: __property System.int get_IndentGlobal();
public: __property void set_IndentGlobal(
   System.int value
);
Requirements

See Also

Reference

SQLBuilderSelectFormat Class
SQLBuilderSelectFormat Members
IndentInPart Property


IndentInPart Property

IndentInPart Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLBuilderSelectFormat Class : IndentInPart Property
Defines indent of all lines of the query except the main query part keyword lines.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property IndentInPart As System.Integer
'Usage

Dim instance As SQLBuilderSelectFormat
Dim value As System.Integer

instance.IndentInPart = value

value = instance.IndentInPart
public System.int IndentInPart {get; set;}
public: __property System.int get_IndentInPart();
public: __property void set_IndentInPart(
   System.int value
);
Requirements

See Also

Reference

SQLBuilderSelectFormat Class
SQLBuilderSelectFormat Members
MainPartsFromNewLine Property
NewLineAfterPartKeywords Property


MainPartsFromNewLine Property

MainPartsFromNewLine Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLBuilderSelectFormat Class : MainPartsFromNewLine Property
Instructs the component to start main parts of the query from new lines.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property MainPartsFromNewLine As System.Boolean
'Usage

Dim instance As SQLBuilderSelectFormat
Dim value As System.Boolean

instance.MainPartsFromNewLine = value

value = instance.MainPartsFromNewLine
public System.bool MainPartsFromNewLine {get; set;}
public: __property System.bool get_MainPartsFromNewLine();
public: __property void set_MainPartsFromNewLine(
   System.bool value
);
Requirements

See Also

Reference

SQLBuilderSelectFormat Class
SQLBuilderSelectFormat Members
NewLineAfterPartKeywords Property
IndentInPart Property


NewLineAfterPartKeywords Property

NewLineAfterPartKeywords Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLBuilderSelectFormat Class : NewLineAfterPartKeywords Property
Instructs to insert line break after each main query part keyword (SELECT, FROM, WHERE, etc.)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property NewLineAfterPartKeywords As System.Boolean
'Usage

Dim instance As SQLBuilderSelectFormat
Dim value As System.Boolean

instance.NewLineAfterPartKeywords = value

value = instance.NewLineAfterPartKeywords
public System.bool NewLineAfterPartKeywords {get; set;}
public: __property System.bool get_NewLineAfterPartKeywords();
public: __property void set_NewLineAfterPartKeywords(
   System.bool value
);
Requirements

See Also

Reference

SQLBuilderSelectFormat Class
SQLBuilderSelectFormat Members
MainPartsFromNewLine Property


OrderByFormat Property

OrderByFormat Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLBuilderSelectFormat Class : OrderByFormat Property
Determines SQL text formatting options of ORDER BY part of the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property OrderByFormat As SQLBuilderItemListFormat
'Usage

Dim instance As SQLBuilderSelectFormat
Dim value As SQLBuilderItemListFormat

instance.OrderByFormat = value

value = instance.OrderByFormat
public SQLBuilderItemListFormat OrderByFormat {get; set;}
public: __property SQLBuilderItemListFormat* get_OrderByFormat();
public: __property void set_OrderByFormat(
   SQLBuilderItemListFormat* value
);
Requirements

See Also

Reference

SQLBuilderSelectFormat Class
SQLBuilderSelectFormat Members


SelectListFormat Property

SelectListFormat Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLBuilderSelectFormat Class : SelectListFormat Property
Determines SQL text formatting options of SELECT part (list of output expressions) of the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property SelectListFormat As SQLBuilderItemListFormat
'Usage

Dim instance As SQLBuilderSelectFormat
Dim value As SQLBuilderItemListFormat

instance.SelectListFormat = value

value = instance.SelectListFormat
public SQLBuilderItemListFormat SelectListFormat {get; set;}
public: __property SQLBuilderItemListFormat* get_SelectListFormat();
public: __property void set_SelectListFormat(
   SQLBuilderItemListFormat* value
);
Requirements

See Also

Reference

SQLBuilderSelectFormat Class
SQLBuilderSelectFormat Members


WhereFormat Property

WhereFormat Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLBuilderSelectFormat Class : WhereFormat Property
Determines SQL text formatting options of WHERE part of the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property WhereFormat As SQLBuilderConditionFormat
'Usage

Dim instance As SQLBuilderSelectFormat
Dim value As SQLBuilderConditionFormat

instance.WhereFormat = value

value = instance.WhereFormat
public SQLBuilderConditionFormat WhereFormat {get; set;}
public: __property SQLBuilderConditionFormat* get_WhereFormat();
public: __property void set_WhereFormat(
   SQLBuilderConditionFormat* value
);
Requirements

See Also

Reference

SQLBuilderSelectFormat Class
SQLBuilderSelectFormat Members
JoinConditionFormat Property


SQLGenerationOptions Class

SQLGenerationOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLGenerationOptions Class
Determine SQL query text generation rules and display of SQL objects and expressions in the Query Builder.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class SQLGenerationOptions
   Inherits UpdatablePersistent
'Usage

Dim instance As SQLGenerationOptions
public class SQLGenerationOptions : UpdatablePersistent
public __gc class SQLGenerationOptions : public UpdatablePersistent
Remarks

Control the display of object names and expressions during the visual query building process (see the ObjectPrefixSkipping, QuoteAllIdentifiers and UseAltNames properties).

Control SQL query text generation for the QueryBuilder.SQL property.

Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLGenerationOptions

Requirements

See Also

Reference

SQLGenerationOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
SQLGenerationOptions Property


SQLGenerationOptions Class Members

SQLGenerationOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLGenerationOptions Class

The following tables list the members exposed by SQLGenerationOptions.

Public Constructors
 | Name | Description
Public Constructor | SQLGenerationOptions Constructor |
Top
Public Properties
 | Name | Description
Public Property | AsKeywordInExpressionAlias | Instructs the component to insert "AS" keyword between field name and alias ("Fleld AS Alias") or not.
Public Property | AsKeywordInObjectAlias | Instructs the component to insert "AS" keyword between object name and its alias ("Table AS Alias") or not.
Public Property | InnerKeywordInLinks | Instructs the component to insert "INNER" keyword before "JOIN" clause or not.
Public Property | ObjectPrefixSkipping | Instructs the component to skip the unnecessary database object prefixes or not.
Public Property | OuterKeywordInLinks | Instructs the component to insert "OUTER" keyword before "JOIN" clause or not.
Public Property | QuoteAllIdentifiers | Instructs the component to quote all identifiers.
Top
See Also

Reference

SQLGenerationOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
SQLGenerationOptions Property


SQLGenerationOptions Constructor

SQLGenerationOptions Constructor

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLGenerationOptions Class : SQLGenerationOptions Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function New( _
   ByVal parent As UpdatablePersistent _
)
'Usage

Dim parent As UpdatablePersistent

Dim instance As New SQLGenerationOptions(parent)
public SQLGenerationOptions(
   UpdatablePersistent parent
)
public: SQLGenerationOptions(
   UpdatablePersistent* parent
)

Parameters

parent
Requirements

See Also

Reference

SQLGenerationOptions Class
SQLGenerationOptions Members


SQLGenerationOptions Class Properties

SQLGenerationOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLGenerationOptions Class

For a list of all members of this type, see SQLGenerationOptions members.

Public Properties
 | Name | Description
Public Property | AsKeywordInExpressionAlias | Instructs the component to insert "AS" keyword between field name and alias ("Fleld AS Alias") or not.
Public Property | AsKeywordInObjectAlias | Instructs the component to insert "AS" keyword between object name and its alias ("Table AS Alias") or not.
Public Property | InnerKeywordInLinks | Instructs the component to insert "INNER" keyword before "JOIN" clause or not.
Public Property | ObjectPrefixSkipping | Instructs the component to skip the unnecessary database object prefixes or not.
Public Property | OuterKeywordInLinks | Instructs the component to insert "OUTER" keyword before "JOIN" clause or not.
Public Property | QuoteAllIdentifiers | Instructs the component to quote all identifiers.
Top
See Also

Reference

SQLGenerationOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
SQLGenerationOptions Property


AsKeywordInExpressionAlias Property (SQLGenerationOptions)

AsKeywordInExpressionAlias Property (SQLGenerationOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLGenerationOptions Class : AsKeywordInExpressionAlias Property
Instructs the component to insert "AS" keyword between field name and alias ("Fleld AS Alias") or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AsKeywordInExpressionAlias As SkipKeywordMode
'Usage

Dim instance As SQLGenerationOptions
Dim value As SkipKeywordMode

instance.AsKeywordInExpressionAlias = value

value = instance.AsKeywordInExpressionAlias
public SkipKeywordMode AsKeywordInExpressionAlias {get; set;}
public: __property SkipKeywordMode get_AsKeywordInExpressionAlias();
public: __property void set_AsKeywordInExpressionAlias(
   SkipKeywordMode value
);
Requirements

See Also

Reference

SQLGenerationOptions Class
SQLGenerationOptions Members
AsKeywordInObjectAlias Property


AsKeywordInObjectAlias Property (SQLGenerationOptions)

AsKeywordInObjectAlias Property (SQLGenerationOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLGenerationOptions Class : AsKeywordInObjectAlias Property
Instructs the component to insert "AS" keyword between object name and its alias ("Table AS Alias") or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AsKeywordInObjectAlias As SkipKeywordMode
'Usage

Dim instance As SQLGenerationOptions
Dim value As SkipKeywordMode

instance.AsKeywordInObjectAlias = value

value = instance.AsKeywordInObjectAlias
public SkipKeywordMode AsKeywordInObjectAlias {get; set;}
public: __property SkipKeywordMode get_AsKeywordInObjectAlias();
public: __property void set_AsKeywordInObjectAlias(
   SkipKeywordMode value
);
Requirements

See Also

Reference

SQLGenerationOptions Class
SQLGenerationOptions Members
AsKeywordInExpressionAlias Property


InnerKeywordInLinks Property (SQLGenerationOptions)

InnerKeywordInLinks Property (SQLGenerationOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLGenerationOptions Class : InnerKeywordInLinks Property
Instructs the component to insert "INNER" keyword before "JOIN" clause or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property InnerKeywordInLinks As SkipKeywordMode
'Usage

Dim instance As SQLGenerationOptions
Dim value As SkipKeywordMode

instance.InnerKeywordInLinks = value

value = instance.InnerKeywordInLinks
public SkipKeywordMode InnerKeywordInLinks {get; set;}
public: __property SkipKeywordMode get_InnerKeywordInLinks();
public: __property void set_InnerKeywordInLinks(
   SkipKeywordMode value
);
Requirements

See Also

Reference

SQLGenerationOptions Class
SQLGenerationOptions Members
OuterKeywordInLinks Property


ObjectPrefixSkipping Property (SQLGenerationOptions)

ObjectPrefixSkipping Property (SQLGenerationOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLGenerationOptions Class : ObjectPrefixSkipping Property
Instructs the component to skip the unnecessary database object prefixes or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ObjectPrefixSkipping As ObjectPrefixSkipping
'Usage

Dim instance As SQLGenerationOptions
Dim value As ObjectPrefixSkipping

instance.ObjectPrefixSkipping = value

value = instance.ObjectPrefixSkipping
public ObjectPrefixSkipping ObjectPrefixSkipping {get; set;}
public: __property ObjectPrefixSkipping get_ObjectPrefixSkipping();
public: __property void set_ObjectPrefixSkipping(
   ObjectPrefixSkipping value
);
Remarks
The necessity of a prefix is determined in accordance with the current database connection. According to it, there could be defined a default database and default schemas that can be omitted in SQL query text. This information is retrieved by Active Query Builder from the database during metadata retrieval process and might be changed manually using the MetadataContainer.DefaultDatabase property and the MetadataContainer.DefaultSchemas collection.
Requirements

See Also

Reference

SQLGenerationOptions Class
SQLGenerationOptions Members


OuterKeywordInLinks Property (SQLGenerationOptions)

OuterKeywordInLinks Property (SQLGenerationOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLGenerationOptions Class : OuterKeywordInLinks Property
Instructs the component to insert "OUTER" keyword before "JOIN" clause or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property OuterKeywordInLinks As SkipKeywordMode
'Usage

Dim instance As SQLGenerationOptions
Dim value As SkipKeywordMode

instance.OuterKeywordInLinks = value

value = instance.OuterKeywordInLinks
public SkipKeywordMode OuterKeywordInLinks {get; set;}
public: __property SkipKeywordMode get_OuterKeywordInLinks();
public: __property void set_OuterKeywordInLinks(
   SkipKeywordMode value
);
Requirements

See Also

Reference

SQLGenerationOptions Class
SQLGenerationOptions Members
InnerKeywordInLinks Property


QuoteAllIdentifiers Property (SQLGenerationOptions)

QuoteAllIdentifiers Property (SQLGenerationOptions)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLGenerationOptions Class : QuoteAllIdentifiers Property
Instructs the component to quote all identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property QuoteAllIdentifiers As System.Boolean
'Usage

Dim instance As SQLGenerationOptions
Dim value As System.Boolean

instance.QuoteAllIdentifiers = value

value = instance.QuoteAllIdentifiers
public System.bool QuoteAllIdentifiers {get; set;}
public: __property System.bool get_QuoteAllIdentifiers();
public: __property void set_QuoteAllIdentifiers(
   System.bool value
);

Property Value

true to quote all identifiers; false to apply quotation as needed.
Remarks

Quotation marks are determined according to the current SQL syntax.

Example (MS SQL Server syntax):

"Northwind.dbo.[Order details]" - property is set to false.
"[Northwind].[dbo].[Order details]" - property is set to true.

Requirements

See Also

Reference

SQLGenerationOptions Class
SQLGenerationOptions Members


SQLQualifiedName Class

SQLQualifiedName Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLQualifiedName Class
Class for representation of the SQL qualified name (can be name of database object or field in a query, etc.).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class SQLQualifiedName
   Inherits AstTokenList
'Usage

Dim instance As SQLQualifiedName
public class SQLQualifiedName : AstTokenList
public __gc class SQLQualifiedName : public AstTokenList
Remarks
SQL qualified name is a set of identifiers separated with dots. SQL qualified name class holds list of identifiers. It allows to modify this list from left or right side (consider working in LeftToRight text direction). These sides are called "Prefix" and "Name". I.e. if you want to add an element from the right side, you should call the AddName(String,Boolean) method; if you want to remove an element from the left side, you should call the RemoveFirstPrefix method.
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.AstNodeBase
ActiveDatabaseSoftware.ActiveQueryBuilder.AstExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.AstNode
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLQualifiedName

Requirements

See Also

Reference

SQLQualifiedName Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQLQualifiedName Class Members

SQLQualifiedName Class Members
Fields Properties Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLQualifiedName Class

The following tables list the members exposed by SQLQualifiedName.

Public Fields
 | Name | Description
Public Field | DBLink | Gets or sets the DB Link qualified name (used for Oracle databases).
Top
Public Properties
 | Name | Description
Public Property | QualifiedName | Gets qualified name string (may be quoted or not quoted according the SQL Context settings).
Public Property | QualifiedNameForServer | Gets the qualified name string built by rules of the SQL Builder for direct execution against database server (used internally).
Public Property | QualifiedNameWithoutQuotes | Gets unquoted qualified name string.
Public Property | QualifiedNameWithQuotes | Gets quoted qualified name string.
Top
Public Methods
 | Name | Description
Public Method | AddName | Overloaded. Adds identifier to the right side of the qualified name.
Public Method | AddPrefix | Overloaded. Adds identifier to the left side of the qualified name.
Public Method | ExtractName | Extracts (removes and returns) an identifier from the right side of the qualified name.
Public Method | ExtractPrefix | Extracts (removes and returns) an identifier from the left side of the qualified name.
static (Shared in Visual Basic) | IsNullOrEmpty |
Public Method | RemoveFirstPrefix | Removes and disposes an identifier from the left side of the qualified name.
Public Method | RemoveLastName | Removes and disposes an identifier from the right side of the qualified name.
Public Method | StartsWith | Determines if the SQL qualified name starts with the specified set of identifiers.
Public Method | ToString | Returns string representation of the object (same as the QualifiedName property).
Top
See Also

Reference

SQLQualifiedName Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQLQualifiedName Class Methods

SQLQualifiedName Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLQualifiedName Class

For a list of all members of this type, see SQLQualifiedName members.

Public Methods
 | Name | Description
Public Method | AddName | Overloaded. Adds identifier to the right side of the qualified name.
Public Method | AddPrefix | Overloaded. Adds identifier to the left side of the qualified name.
Public Method | ExtractName | Extracts (removes and returns) an identifier from the right side of the qualified name.
Public Method | ExtractPrefix | Extracts (removes and returns) an identifier from the left side of the qualified name.
static (Shared in Visual Basic) | IsNullOrEmpty |
Public Method | RemoveFirstPrefix | Removes and disposes an identifier from the left side of the qualified name.
Public Method | RemoveLastName | Removes and disposes an identifier from the right side of the qualified name.
Public Method | StartsWith | Determines if the SQL qualified name starts with the specified set of identifiers.
Public Method | ToString | Returns string representation of the object (same as the QualifiedName property).
Top
See Also

Reference

SQLQualifiedName Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AddName Method

AddName Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class : AddName Method
Adds identifier to the right side of the qualified name.
Overload List
Overload | Description
AddName(String,Boolean) | Adds identifier to the right side from string with the specified case sensitivity flag.
AddName(String) | Adds identifier to the right side from string.
AddName(SQLQualifiedName) | Adds identifier(s) to the right side from SQL qualified name.
AddName(AstToken) | Adds AST token identifier to the right side of name.
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members


AddName(String,Boolean) Method

AddName(String,Boolean) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class > AddName Method : AddName(String,Boolean) Method
Identifier string to add to the right side of the qualified name.
Flag to override identifier case sensitivity option of the syntax provider (IdentCaseSens) specified in the SQL context.
Adds identifier to the right side from string with the specified case sensitivity flag.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub AddName( _
   ByVal name As System.String, _
   ByVal caseSensitive As System.Boolean _
)
'Usage

Dim instance As SQLQualifiedName
Dim name As System.String
Dim caseSensitive As System.Boolean

instance.AddName(name, caseSensitive)
public void AddName(
   System.string name,
   System.bool caseSensitive
)
public: void AddName(
   System.string* name,
   System.bool caseSensitive
)

Parameters

name
Identifier string to add to the right side of the qualified name.
caseSensitive
Flag to override identifier case sensitivity option of the syntax provider (IdentCaseSens) specified in the SQL context.
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members
Overload List


AddName(String) Method

AddName(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class > AddName Method : AddName(String) Method
Identifier string to add to the right side of the qualified name.
Adds identifier to the right side from string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub AddName( _
   ByVal name As System.String _
)
'Usage

Dim instance As SQLQualifiedName
Dim name As System.String

instance.AddName(name)
public void AddName(
   System.string name
)
public: void AddName(
   System.string* name
)

Parameters

name
Identifier string to add to the right side of the qualified name.
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members
Overload List


AddName(SQLQualifiedName) Method

AddName(SQLQualifiedName) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class > AddName Method : AddName(SQLQualifiedName) Method
SQL qualified name (i.e. list of identifiers) to add to the right side of the qualified name.
Adds identifier(s) to the right side from SQL qualified name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub AddName( _
   ByVal name As SQLQualifiedName _
)
'Usage

Dim instance As SQLQualifiedName
Dim name As SQLQualifiedName

instance.AddName(name)
public void AddName(
   SQLQualifiedName name
)
public: void AddName(
   SQLQualifiedName* name
)

Parameters

name
SQL qualified name (i.e. list of identifiers) to add to the right side of the qualified name.
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members
Overload List


AddName(AstToken) Method

AddName(AstToken) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class > AddName Method : AddName(AstToken) Method
AST token identifier to add to the right side of the qualified name.
Adds AST token identifier to the right side of name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub AddName( _
   ByVal name As AstToken _
)
'Usage

Dim instance As SQLQualifiedName
Dim name As AstToken

instance.AddName(name)
public void AddName(
   AstToken name
)
public: void AddName(
   AstToken* name
)

Parameters

name
AST token identifier to add to the right side of the qualified name.
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members
Overload List


AddPrefix Method

AddPrefix Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class : AddPrefix Method
Adds identifier to the left side of the qualified name.
Overload List
Overload | Description
AddPrefix(String,Boolean) | Adds identifier to the left side from string with the specified case sensitivity flag.
AddPrefix(String) | Adds identifier to the left side from string.
AddPrefix(SQLQualifiedName) | Adds identifier(s) to the left side from SQL qualified name.
AddPrefix(AstToken) | Adds AST token identifier to the left side of name.
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members


AddPrefix(String,Boolean) Method

AddPrefix(String,Boolean) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class > AddPrefix Method : AddPrefix(String,Boolean) Method
Identifier string to add to the left side of the qualified name.
Flag to override identifier case sensitivity option of the syntax provider (IdentCaseSens) specified in the SQL context.
Adds identifier to the left side from string with the specified case sensitivity flag.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub AddPrefix( _
   ByVal prefix As System.String, _
   ByVal caseSensitive As System.Boolean _
)
'Usage

Dim instance As SQLQualifiedName
Dim prefix As System.String
Dim caseSensitive As System.Boolean

instance.AddPrefix(prefix, caseSensitive)
public void AddPrefix(
   System.string prefix,
   System.bool caseSensitive
)
public: void AddPrefix(
   System.string* prefix,
   System.bool caseSensitive
)

Parameters

prefix
Identifier string to add to the left side of the qualified name.
caseSensitive
Flag to override identifier case sensitivity option of the syntax provider (IdentCaseSens) specified in the SQL context.
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members
Overload List


AddPrefix(String) Method

AddPrefix(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class > AddPrefix Method : AddPrefix(String) Method
Identifier string to add to the left side of the qualified name.
Adds identifier to the left side from string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub AddPrefix( _
   ByVal prefix As System.String _
)
'Usage

Dim instance As SQLQualifiedName
Dim prefix As System.String

instance.AddPrefix(prefix)
public void AddPrefix(
   System.string prefix
)
public: void AddPrefix(
   System.string* prefix
)

Parameters

prefix
Identifier string to add to the left side of the qualified name.
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members
Overload List


AddPrefix(SQLQualifiedName) Method

AddPrefix(SQLQualifiedName) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class > AddPrefix Method : AddPrefix(SQLQualifiedName) Method
SQL qualified name (i.e. list of identifiers) to add to the left side of the qualified name.
Adds identifier(s) to the left side from SQL qualified name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub AddPrefix( _
   ByVal prefix As SQLQualifiedName _
)
'Usage

Dim instance As SQLQualifiedName
Dim prefix As SQLQualifiedName

instance.AddPrefix(prefix)
public void AddPrefix(
   SQLQualifiedName prefix
)
public: void AddPrefix(
   SQLQualifiedName* prefix
)

Parameters

prefix
SQL qualified name (i.e. list of identifiers) to add to the left side of the qualified name.
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members
Overload List


AddPrefix(AstToken) Method

AddPrefix(AstToken) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class > AddPrefix Method : AddPrefix(AstToken) Method
AST token identifier to add to the left side of the qualified name.
Adds AST token identifier to the left side of name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub AddPrefix( _
   ByVal prefix As AstToken _
)
'Usage

Dim instance As SQLQualifiedName
Dim prefix As AstToken

instance.AddPrefix(prefix)
public void AddPrefix(
   AstToken prefix
)
public: void AddPrefix(
   AstToken* prefix
)

Parameters

prefix
AST token identifier to add to the left side of the qualified name.
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members
Overload List


ExtractName Method

ExtractName Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class : ExtractName Method
Extracts (removes and returns) an identifier from the right side of the qualified name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ExtractName() As AstToken
'Usage

Dim instance As SQLQualifiedName
Dim value As AstToken

value = instance.ExtractName()
public AstToken ExtractName()
public: AstToken* ExtractName();

Return Value

Returns AST token identifier from the right side of the qualified name.
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members


ExtractPrefix Method

ExtractPrefix Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class : ExtractPrefix Method
Extracts (removes and returns) an identifier from the left side of the qualified name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ExtractPrefix() As AstToken
'Usage

Dim instance As SQLQualifiedName
Dim value As AstToken

value = instance.ExtractPrefix()
public AstToken ExtractPrefix()
public: AstToken* ExtractPrefix();

Return Value

Returns AST token identifier from the left side of the qualified name.
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members


IsNullOrEmpty Method

IsNullOrEmpty Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class : IsNullOrEmpty Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Shared Function IsNullOrEmpty( _
   ByVal name As SQLQualifiedName _
) As System.Boolean
'Usage

Dim name As SQLQualifiedName
Dim value As System.Boolean

value = SQLQualifiedName.IsNullOrEmpty(name)
public static System.bool IsNullOrEmpty(
   SQLQualifiedName name
)
public: static System.bool IsNullOrEmpty(
   SQLQualifiedName* name
)

Parameters

name
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members


RemoveFirstPrefix Method

RemoveFirstPrefix Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class : RemoveFirstPrefix Method
Removes and disposes an identifier from the left side of the qualified name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub RemoveFirstPrefix()
'Usage

Dim instance As SQLQualifiedName

instance.RemoveFirstPrefix()
public void RemoveFirstPrefix()
public: void RemoveFirstPrefix();
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members


RemoveLastName Method

RemoveLastName Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class : RemoveLastName Method
Removes and disposes an identifier from the right side of the qualified name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub RemoveLastName()
'Usage

Dim instance As SQLQualifiedName

instance.RemoveLastName()
public void RemoveLastName()
public: void RemoveLastName();
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members


StartsWith Method

StartsWith Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class : StartsWith Method
SQL qualified name (i.e. list of identifiers) to compare with identifiers at the left side of the qualified name.
Determines if the SQL qualified name starts with the specified set of identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function StartsWith( _
   ByVal name As SQLQualifiedName _
) As System.Boolean
'Usage

Dim instance As SQLQualifiedName
Dim name As SQLQualifiedName
Dim value As System.Boolean

value = instance.StartsWith(name)
public System.bool StartsWith(
   SQLQualifiedName name
)
public: System.bool StartsWith(
   SQLQualifiedName* name
)

Parameters

name
SQL qualified name (i.e. list of identifiers) to compare with identifiers at the left side of the qualified name.

Return Value

Returns true if the SQL qualified name has the same list of identifiers from the left ("Prefix") side.
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members


ToString Method (SQLQualifiedName)

ToString Method (SQLQualifiedName)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class : ToString Method
Returns string representation of the object (same as the QualifiedName property).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Function ToString() As System.String
'Usage

Dim instance As SQLQualifiedName
Dim value As System.String

value = instance.ToString()
public override System.string ToString()
public: System.string* ToString(); override
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members
Base Implementation in ToString


SQLQualifiedName Class Properties

SQLQualifiedName Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLQualifiedName Class

For a list of all members of this type, see SQLQualifiedName members.

Public Properties
 | Name | Description
Public Property | QualifiedName | Gets qualified name string (may be quoted or not quoted according the SQL Context settings).
Public Property | QualifiedNameForServer | Gets the qualified name string built by rules of the SQL Builder for direct execution against database server (used internally).
Public Property | QualifiedNameWithoutQuotes | Gets unquoted qualified name string.
Public Property | QualifiedNameWithQuotes | Gets quoted qualified name string.
Top
See Also

Reference

SQLQualifiedName Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


QualifiedName Property

QualifiedName Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class : QualifiedName Property
Gets qualified name string (may be quoted or not quoted according the SQL Context settings).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property QualifiedName As System.String
'Usage

Dim instance As SQLQualifiedName
Dim value As System.String

value = instance.QualifiedName
public System.string QualifiedName {get;}
public: __property System.string* get_QualifiedName();
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members


QualifiedNameForServer Property

QualifiedNameForServer Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class : QualifiedNameForServer Property
Gets the qualified name string built by rules of the SQL Builder for direct execution against database server (used internally).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property QualifiedNameForServer As System.String
'Usage

Dim instance As SQLQualifiedName
Dim value As System.String

value = instance.QualifiedNameForServer
public System.string QualifiedNameForServer {get;}
public: __property System.string* get_QualifiedNameForServer();
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members


QualifiedNameWithoutQuotes Property

QualifiedNameWithoutQuotes Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class : QualifiedNameWithoutQuotes Property
Gets unquoted qualified name string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property QualifiedNameWithoutQuotes As System.String
'Usage

Dim instance As SQLQualifiedName
Dim value As System.String

value = instance.QualifiedNameWithoutQuotes
public System.string QualifiedNameWithoutQuotes {get;}
public: __property System.string* get_QualifiedNameWithoutQuotes();
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members


QualifiedNameWithQuotes Property

QualifiedNameWithQuotes Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class : QualifiedNameWithQuotes Property
Gets quoted qualified name string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property QualifiedNameWithQuotes As System.String
'Usage

Dim instance As SQLQualifiedName
Dim value As System.String

value = instance.QualifiedNameWithQuotes
public System.string QualifiedNameWithQuotes {get;}
public: __property System.string* get_QualifiedNameWithQuotes();
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members


SQLQualifiedName Class Fields

SQLQualifiedName Class Fields

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLQualifiedName Class

For a list of all members of this type, see SQLQualifiedName members.

Public Fields
 | Name | Description
Public Field | DBLink | Gets or sets the DB Link qualified name (used for Oracle databases).
Top
See Also

Reference

SQLQualifiedName Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


DBLink Field

DBLink Field

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedName Class : DBLink Field
Gets or sets the DB Link qualified name (used for Oracle databases).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public DBLink As SQLQualifiedName
'Usage

Dim instance As SQLQualifiedName
Dim value As SQLQualifiedName

value = instance.DBLink

instance.DBLink = value
public SQLQualifiedName DBLink
public: SQLQualifiedName* DBLink
Requirements

See Also

Reference

SQLQualifiedName Class
SQLQualifiedName Members


SQLQualifiedNameList Class

SQLQualifiedNameList Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLQualifiedNameList Class
List of SQL qualified names.
Object Model
SQLQualifiedNameList ClassSQLQualifiedName Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class SQLQualifiedNameList
'Usage

Dim instance As SQLQualifiedNameList
public class SQLQualifiedNameList
public __gc class SQLQualifiedNameList
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLQualifiedNameList

Requirements

See Also

Reference

SQLQualifiedNameList Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQLQualifiedNameList Class Members

SQLQualifiedNameList Class Members
Properties Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLQualifiedNameList Class

The following tables list the members exposed by SQLQualifiedNameList.

Public Constructors
 | Name | Description
Public Constructor | SQLQualifiedNameList Constructor | Initializes a new instance of the SQL qualified names list.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the list.
Public Property | IsReadOnly | Gets a value indicating whether the list is read-only.
Public Property | Item | Gets or sets the SQL qualified name in the list at the specified index.
Public Property | SQLContext | Gets the SQL Context for the SQL qualified names in the list.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds SQL qualified name to the end of the list.
Public Method | AddIdentifier | Overloaded. Creates single SQL qualified name from identifier and adds it to the end of the list.
Public Method | Clear | Clears the list.
Public Method | Contains | Determines whether the list contains a specific SQL qualified name.
Public Method | CopyTo | Copies the elements of the list to an array, starting at a particular array index.
Public Method | Extract | Removes and returns the SQL qualified name from the list.
Public Method | FindByName | Overloaded. Gets the index of the specified SQL quailfied name.
Public Method | First | Gets the first SQL qualified name in the list.
Public Method | GetEnumerator |
Public Method | IndexOf | Determines the index of a specific SQL qualified name in the list.
Public Method | Insert | Inserts SQL qualified name to the list at the specified index.
Public Method | Last | Gets the last SQL qualified name in the list.
Public Method | Move | Moves the SQL qualified name at the specified index to a new location in the list.
Public Method | Remove | Removes and disposes the SQL qualified name from the list.
Public Method | RemoveAt | Removes and disposes the SQL qualified name from the list at specified index.
Public Method | SortByNames | Sorts the SQL qualified names in the list by comparing the identifiers of SQL qualified names from left to right.
Top
See Also

Reference

SQLQualifiedNameList Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQLQualifiedNameList Constructor

SQLQualifiedNameList Constructor

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class : SQLQualifiedNameList Constructor
Specifies SQL Context for the SQL qualified names in list.
Initializes a new instance of the SQL qualified names list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function New( _
   ByVal sqlContext As BaseSQLContext _
)
'Usage

Dim sqlContext As BaseSQLContext

Dim instance As New SQLQualifiedNameList(sqlContext)
public SQLQualifiedNameList(
   BaseSQLContext sqlContext
)
public: SQLQualifiedNameList(
   BaseSQLContext* sqlContext
)

Parameters

sqlContext
Specifies SQL Context for the SQL qualified names in list.
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members


SQLQualifiedNameList Class Methods

SQLQualifiedNameList Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLQualifiedNameList Class

For a list of all members of this type, see SQLQualifiedNameList members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds SQL qualified name to the end of the list.
Public Method | AddIdentifier | Overloaded. Creates single SQL qualified name from identifier and adds it to the end of the list.
Public Method | Clear | Clears the list.
Public Method | Contains | Determines whether the list contains a specific SQL qualified name.
Public Method | CopyTo | Copies the elements of the list to an array, starting at a particular array index.
Public Method | Extract | Removes and returns the SQL qualified name from the list.
Public Method | FindByName | Overloaded. Gets the index of the specified SQL quailfied name.
Public Method | First | Gets the first SQL qualified name in the list.
Public Method | GetEnumerator |
Public Method | IndexOf | Determines the index of a specific SQL qualified name in the list.
Public Method | Insert | Inserts SQL qualified name to the list at the specified index.
Public Method | Last | Gets the last SQL qualified name in the list.
Public Method | Move | Moves the SQL qualified name at the specified index to a new location in the list.
Public Method | Remove | Removes and disposes the SQL qualified name from the list.
Public Method | RemoveAt | Removes and disposes the SQL qualified name from the list at specified index.
Public Method | SortByNames | Sorts the SQL qualified names in the list by comparing the identifiers of SQL qualified names from left to right.
Top
See Also

Reference

SQLQualifiedNameList Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Add Method (SQLQualifiedNameList)

Add Method (SQLQualifiedNameList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class : Add Method
Adds SQL qualified name to the end of the list.
Overload List
Overload | Description
Add(SQLQualifiedName) | Adds SQL qualified name to the end of the list.
Add(String) | Parses the string as SQL qualified name and adds it to the end of the list.
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members


Add(SQLQualifiedName) Method

Add(SQLQualifiedName) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class > Add Method : Add(SQLQualifiedName) Method
SQL qualified name to be added to the end of the list.
Adds SQL qualified name to the end of the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function Add( _
   ByVal obj As SQLQualifiedName _
) As System.Integer
'Usage

Dim instance As SQLQualifiedNameList
Dim obj As SQLQualifiedName
Dim value As System.Integer

value = instance.Add(obj)
public System.int Add(
   SQLQualifiedName obj
)
public: System.int Add(
   SQLQualifiedName* obj
)

Parameters

obj
SQL qualified name to be added to the end of the list.

Return Value

Returns index of the newly added SQL qualified name in the list.
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members
Overload List


Add(String) Method

Add(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class > Add Method : Add(String) Method
String to be parsed as SQL qualified name and added to the end of the list.
Parses the string as SQL qualified name and adds it to the end of the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function Add( _
   ByVal name As System.String _
) As System.Integer
'Usage

Dim instance As SQLQualifiedNameList
Dim name As System.String
Dim value As System.Integer

value = instance.Add(name)
public System.int Add(
   System.string name
)
public: System.int Add(
   System.string* name
)

Parameters

name
String to be parsed as SQL qualified name and added to the end of the list.

Return Value

Returns index of the newly added SQL qualified name in the list.
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members
Overload List


AddIdentifier Method

AddIdentifier Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class : AddIdentifier Method
Creates single SQL qualified name from identifier and adds it to the end of the list.
Overload List
Overload | Description
AddIdentifier(String,Boolean) | Creates single SQL qualified name from identifier and adds it to the end of the list with the specified case sensitivity flag.
AddIdentifier(String) | Creates single SQL qualified name from identifier string and adds it to the end of the list.
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members


AddIdentifier(String,Boolean) Method

AddIdentifier(String,Boolean) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class > AddIdentifier Method : AddIdentifier(String,Boolean) Method
Identifier string to be added as a single SQL qualified name to the list.
Flag to override identifier case sensitivity option of the syntax provider (IdentCaseSens) specified in the SQL context.
Creates single SQL qualified name from identifier and adds it to the end of the list with the specified case sensitivity flag.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function AddIdentifier( _
   ByVal name As System.String, _
   ByVal caseSensitive As System.Boolean _
) As System.Integer
'Usage

Dim instance As SQLQualifiedNameList
Dim name As System.String
Dim caseSensitive As System.Boolean
Dim value As System.Integer

value = instance.AddIdentifier(name, caseSensitive)
public System.int AddIdentifier(
   System.string name,
   System.bool caseSensitive
)
public: System.int AddIdentifier(
   System.string* name,
   System.bool caseSensitive
)

Parameters

name
Identifier string to be added as a single SQL qualified name to the list.
caseSensitive
Flag to override identifier case sensitivity option of the syntax provider (IdentCaseSens) specified in the SQL context.

Return Value

Returns index of the newly added SQL qualified name in the list.
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members
Overload List


AddIdentifier(String) Method

AddIdentifier(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class > AddIdentifier Method : AddIdentifier(String) Method
Identifier string to be added as a single SQL qualified name to the list.
Creates single SQL qualified name from identifier string and adds it to the end of the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function AddIdentifier( _
   ByVal name As System.String _
) As System.Integer
'Usage

Dim instance As SQLQualifiedNameList
Dim name As System.String
Dim value As System.Integer

value = instance.AddIdentifier(name)
public System.int AddIdentifier(
   System.string name
)
public: System.int AddIdentifier(
   System.string* name
)

Parameters

name
Identifier string to be added as a single SQL qualified name to the list.

Return Value

Returns index of the newly added SQL qualified name in the list.
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members
Overload List


Clear Method (SQLQualifiedNameList)

Clear Method (SQLQualifiedNameList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class : Clear Method
Clears the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Clear()
'Usage

Dim instance As SQLQualifiedNameList

instance.Clear()
public void Clear()
public: void Clear();
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members


Contains Method (SQLQualifiedNameList)

Contains Method (SQLQualifiedNameList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class : Contains Method
Determines whether the list contains a specific SQL qualified name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function Contains( _
   ByVal item As SQLQualifiedName _
) As System.Boolean
'Usage

Dim instance As SQLQualifiedNameList
Dim item As SQLQualifiedName
Dim value As System.Boolean

value = instance.Contains(item)
public System.bool Contains(
   SQLQualifiedName item
)
public: System.bool Contains(
   SQLQualifiedName* item
)

Parameters

item
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members


CopyTo Method

CopyTo Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class : CopyTo Method
Copies the elements of the list to an array, starting at a particular array index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub CopyTo( _
   ByVal array() As SQLQualifiedName, _
   ByVal arrayIndex As System.Integer _
)
'Usage

Dim instance As SQLQualifiedNameList
Dim array() As SQLQualifiedName
Dim arrayIndex As System.Integer

instance.CopyTo(array, arrayIndex)
public void CopyTo(
   SQLQualifiedName[] array,
   System.int arrayIndex
)
public: void CopyTo(
   SQLQualifiedName*[]* array,
   System.int arrayIndex
)

Parameters

array
arrayIndex
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members


Extract Method

Extract Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class : Extract Method
The SQL qualified name to be removed from the list.
Removes and returns the SQL qualified name from the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function Extract( _
   ByVal item As SQLQualifiedName _
) As SQLQualifiedName
'Usage

Dim instance As SQLQualifiedNameList
Dim item As SQLQualifiedName
Dim value As SQLQualifiedName

value = instance.Extract(item)
public SQLQualifiedName Extract(
   SQLQualifiedName item
)
public: SQLQualifiedName* Extract(
   SQLQualifiedName* item
)

Parameters

item
The SQL qualified name to be removed from the list.

Return Value

Returns the extracted SQL qualified name object; returns null in case the specified SQL qualified name is not found in the list.
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members


FindByName Method

FindByName Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class : FindByName Method
Gets the index of the specified SQL quailfied name.
Overload List
Overload | Description
FindByName(SQLQualifiedName) | Gets the index of the specified SQL quailfied name.
FindByName(String) | Gets the index of the specified SQL quailfied name represented as string.
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members


FindByName(SQLQualifiedName) Method

FindByName(SQLQualifiedName) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class > FindByName Method : FindByName(SQLQualifiedName) Method
The SQL qualified name to find in the list.
Gets the index of the specified SQL quailfied name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindByName( _
   ByVal obj As SQLQualifiedName _
) As System.Integer
'Usage

Dim instance As SQLQualifiedNameList
Dim obj As SQLQualifiedName
Dim value As System.Integer

value = instance.FindByName(obj)
public System.int FindByName(
   SQLQualifiedName obj
)
public: System.int FindByName(
   SQLQualifiedName* obj
)

Parameters

obj
The SQL qualified name to find in the list.

Return Value

The zero-based index of the specified SQL qualified name if found in the list; -1 otherwise.
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members
Overload List


FindByName(String) Method

FindByName(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class > FindByName Method : FindByName(String) Method
The SQL qualifed name string to find in the list.
Gets the index of the specified SQL quailfied name represented as string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function FindByName( _
   ByVal name As System.String _
) As System.Integer
'Usage

Dim instance As SQLQualifiedNameList
Dim name As System.String
Dim value As System.Integer

value = instance.FindByName(name)
public System.int FindByName(
   System.string name
)
public: System.int FindByName(
   System.string* name
)

Parameters

name
The SQL qualifed name string to find in the list.

Return Value

The zero-based index of the specified SQL qualified name if found in the list; -1 otherwise.
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members
Overload List


First Method

First Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class : First Method
Gets the first SQL qualified name in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function First() As SQLQualifiedName
'Usage

Dim instance As SQLQualifiedNameList
Dim value As SQLQualifiedName

value = instance.First()
public SQLQualifiedName First()
public: SQLQualifiedName* First();
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members


GetEnumerator Method

GetEnumerator Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class : GetEnumerator Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of SQLQualifiedName)
'Usage

Dim instance As SQLQualifiedNameList
Dim value As System.Collections.Generic.IEnumerator(Of SQLQualifiedName)

value = instance.GetEnumerator()
public System.Collections.Generic.IEnumerator<SQLQualifiedName> GetEnumerator()
public: System.Collections.Generic.IEnumerator<SQLQualifiedName*>* GetEnumerator();
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members


IndexOf Method

IndexOf Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class : IndexOf Method
Determines the index of a specific SQL qualified name in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function IndexOf( _
   ByVal item As SQLQualifiedName _
) As System.Integer
'Usage

Dim instance As SQLQualifiedNameList
Dim item As SQLQualifiedName
Dim value As System.Integer

value = instance.IndexOf(item)
public System.int IndexOf(
   SQLQualifiedName item
)
public: System.int IndexOf(
   SQLQualifiedName* item
)

Parameters

item
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members


Insert Method (SQLQualifiedNameList)

Insert Method (SQLQualifiedNameList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class : Insert Method
The zero-based index at which new SQL qualified name should be inserted.
The SQL qualified name to be inserted to the list at the specified index.
Inserts SQL qualified name to the list at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal obj As SQLQualifiedName _
)
'Usage

Dim instance As SQLQualifiedNameList
Dim index As System.Integer
Dim obj As SQLQualifiedName

instance.Insert(index, obj)
public void Insert(
   System.int index,
   SQLQualifiedName obj
)
public: void Insert(
   System.int index,
   SQLQualifiedName* obj
)

Parameters

index
The zero-based index at which new SQL qualified name should be inserted.
obj
The SQL qualified name to be inserted to the list at the specified index.
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members


Last Method

Last Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class : Last Method
Gets the last SQL qualified name in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function Last() As SQLQualifiedName
'Usage

Dim instance As SQLQualifiedNameList
Dim value As SQLQualifiedName

value = instance.Last()
public SQLQualifiedName Last()
public: SQLQualifiedName* Last();
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members


Move Method

Move Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class : Move Method
The zero-based index specifying the location of the SQL qualified name to be moved.
The zero-based index specifying the new location of the SQL qualified name.
Moves the SQL qualified name at the specified index to a new location in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Move( _
   ByVal oldIndex As System.Integer, _
   ByVal newIndex As System.Integer _
)
'Usage

Dim instance As SQLQualifiedNameList
Dim oldIndex As System.Integer
Dim newIndex As System.Integer

instance.Move(oldIndex, newIndex)
public void Move(
   System.int oldIndex,
   System.int newIndex
)
public: void Move(
   System.int oldIndex,
   System.int newIndex
)

Parameters

oldIndex
The zero-based index specifying the location of the SQL qualified name to be moved.
newIndex
The zero-based index specifying the new location of the SQL qualified name.
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members


Remove Method (SQLQualifiedNameList)

Remove Method (SQLQualifiedNameList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class : Remove Method
The SQL qualified name to be removed from the list.
Removes and disposes the SQL qualified name from the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function Remove( _
   ByVal obj As SQLQualifiedName _
) As System.Integer
'Usage

Dim instance As SQLQualifiedNameList
Dim obj As SQLQualifiedName
Dim value As System.Integer

value = instance.Remove(obj)
public System.int Remove(
   SQLQualifiedName obj
)
public: System.int Remove(
   SQLQualifiedName* obj
)

Parameters

obj
The SQL qualified name to be removed from the list.

Return Value

Returns the index of removed SQL qualified name; returns -1 in case the specified SQL qualified name is not found in the list.
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members


RemoveAt Method

RemoveAt Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class : RemoveAt Method
Index of item to remove and dispose.
Removes and disposes the SQL qualified name from the list at specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
'Usage

Dim instance As SQLQualifiedNameList
Dim index As System.Integer

instance.RemoveAt(index)
public void RemoveAt(
   System.int index
)
public: void RemoveAt(
   System.int index
)

Parameters

index
Index of item to remove and dispose.
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members


SortByNames Method

SortByNames Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class : SortByNames Method
Sorts the SQL qualified names in the list by comparing the identifiers of SQL qualified names from left to right.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub SortByNames()
'Usage

Dim instance As SQLQualifiedNameList

instance.SortByNames()
public void SortByNames()
public: void SortByNames();
Remarks
Comparison is performed over the leftmost prefixes of the SQL qualified names first, than over the next identifiers from left to right.
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members


SQLQualifiedNameList Class Properties

SQLQualifiedNameList Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLQualifiedNameList Class

For a list of all members of this type, see SQLQualifiedNameList members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the list.
Public Property | IsReadOnly | Gets a value indicating whether the list is read-only.
Public Property | Item | Gets or sets the SQL qualified name in the list at the specified index.
Public Property | SQLContext | Gets the SQL Context for the SQL qualified names in the list.
Top
See Also

Reference

SQLQualifiedNameList Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Count Property (SQLQualifiedNameList)

Count Property (SQLQualifiedNameList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class : Count Property
Gets the number of elements contained in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Count As System.Integer
'Usage

Dim instance As SQLQualifiedNameList
Dim value As System.Integer

value = instance.Count
public System.int Count {get;}
public: __property System.int get_Count();
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members


IsReadOnly Property (SQLQualifiedNameList)

IsReadOnly Property (SQLQualifiedNameList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class : IsReadOnly Property
Gets a value indicating whether the list is read-only.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property IsReadOnly As System.Boolean
'Usage

Dim instance As SQLQualifiedNameList
Dim value As System.Boolean

value = instance.IsReadOnly
public System.bool IsReadOnly {get;}
public: __property System.bool get_IsReadOnly();
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members


Item Property (SQLQualifiedNameList)

Item Property (SQLQualifiedNameList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class : Item Property
The zero-based index of the SQL qualified name to be get or set.
Gets or sets the SQL qualified name in the list at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As SQLQualifiedName
'Usage

Dim instance As SQLQualifiedNameList
Dim index As System.Integer
Dim value As SQLQualifiedName

instance.Item(index) = value

value = instance.Item(index)
public SQLQualifiedName this[
   System.int index
]; {get; set;}
public: __property SQLQualifiedName* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   SQLQualifiedName* value
;

Parameters

index
The zero-based index of the SQL qualified name to be get or set.

Property Value

The SQL qualified name at the specified index.
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members


SQLContext Property (SQLQualifiedNameList)

SQLContext Property (SQLQualifiedNameList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQLQualifiedNameList Class : SQLContext Property
Gets the SQL Context for the SQL qualified names in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property SQLContext As BaseSQLContext
'Usage

Dim instance As SQLQualifiedNameList
Dim value As BaseSQLContext

value = instance.SQLContext
public BaseSQLContext SQLContext {get;}
public: __property BaseSQLContext* get_SQLContext();
Requirements

See Also

Reference

SQLQualifiedNameList Class
SQLQualifiedNameList Members


StatisticsDatabaseObject Class

StatisticsDatabaseObject Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : StatisticsDatabaseObject Class
Describes a database object being used in the query.
Object Model
StatisticsDatabaseObject ClassMetadataObject ClassSQLQualifiedName Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class StatisticsDatabaseObject
'Usage

Dim instance As StatisticsDatabaseObject
public class StatisticsDatabaseObject
public __gc class StatisticsDatabaseObject
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.StatisticsDatabaseObject

Requirements

See Also

Reference

StatisticsDatabaseObject Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


StatisticsDatabaseObject Class Members

StatisticsDatabaseObject Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : StatisticsDatabaseObject Class

The following tables list the members exposed by StatisticsDatabaseObject.

Public Properties
 | Name | Description
Public Property | Aliases | Lists aliases that were used in the query for the database object.
Public Property | MetadataObject | Gets the reference to the MetadataObject object that corresponds to the database object.
Public Property | ObjectName | Gets fully qualified name of the database object.
Top
See Also

Reference

StatisticsDatabaseObject Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


StatisticsDatabaseObject Class Properties

StatisticsDatabaseObject Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : StatisticsDatabaseObject Class

For a list of all members of this type, see StatisticsDatabaseObject members.

Public Properties
 | Name | Description
Public Property | Aliases | Lists aliases that were used in the query for the database object.
Public Property | MetadataObject | Gets the reference to the MetadataObject object that corresponds to the database object.
Public Property | ObjectName | Gets fully qualified name of the database object.
Top
See Also

Reference

StatisticsDatabaseObject Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Aliases Property

Aliases Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsDatabaseObject Class : Aliases Property
Lists aliases that were used in the query for the database object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Aliases As AstIdentifierList
'Usage

Dim instance As StatisticsDatabaseObject
Dim value As AstIdentifierList

value = instance.Aliases
public AstIdentifierList Aliases {get;}
public: __property AstIdentifierList* get_Aliases();
Requirements

See Also

Reference

StatisticsDatabaseObject Class
StatisticsDatabaseObject Members


MetadataObject Property (StatisticsDatabaseObject)

MetadataObject Property (StatisticsDatabaseObject)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsDatabaseObject Class : MetadataObject Property
Gets the reference to the MetadataObject object that corresponds to the database object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property MetadataObject As MetadataObject
'Usage

Dim instance As StatisticsDatabaseObject
Dim value As MetadataObject

value = instance.MetadataObject
public MetadataObject MetadataObject {get;}
public: __property MetadataObject* get_MetadataObject();
Remarks
Can be null if a corresponding MetadataObject object is not found in the MetadataContainer.
Requirements

See Also

Reference

StatisticsDatabaseObject Class
StatisticsDatabaseObject Members


ObjectName Property (StatisticsDatabaseObject)

ObjectName Property (StatisticsDatabaseObject)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsDatabaseObject Class : ObjectName Property
Gets fully qualified name of the database object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ObjectName As SQLQualifiedName
'Usage

Dim instance As StatisticsDatabaseObject
Dim value As SQLQualifiedName

value = instance.ObjectName
public SQLQualifiedName ObjectName {get;}
public: __property SQLQualifiedName* get_ObjectName();
Requirements

See Also

Reference

StatisticsDatabaseObject Class
StatisticsDatabaseObject Members


StatisticsDatabaseObjectList Class

StatisticsDatabaseObjectList Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : StatisticsDatabaseObjectList Class
Lists database objects used in the query (QueryStatistics.UsedDatabaseObjects).
Object Model
StatisticsDatabaseObjectList ClassStatisticsDatabaseObject Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class StatisticsDatabaseObjectList
   Inherits StatisticsBase
'Usage

Dim instance As StatisticsDatabaseObjectList
public class StatisticsDatabaseObjectList : StatisticsBase
public __gc class StatisticsDatabaseObjectList : public StatisticsBase
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.StatisticsDatabaseObjectList

Requirements

See Also

Reference

StatisticsDatabaseObjectList Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


StatisticsDatabaseObjectList Class Members

StatisticsDatabaseObjectList Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : StatisticsDatabaseObjectList Class

The following tables list the members exposed by StatisticsDatabaseObjectList.

Public Properties
 | Name | Description
Public Property | Count | Indicates the number of items in the list.
Public Property | Item | Gets or sets the element at the specified index.
Top
See Also

Reference

StatisticsDatabaseObjectList Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


StatisticsDatabaseObjectList Class Properties

StatisticsDatabaseObjectList Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : StatisticsDatabaseObjectList Class

For a list of all members of this type, see StatisticsDatabaseObjectList members.

Public Properties
 | Name | Description
Public Property | Count | Indicates the number of items in the list.
Public Property | Item | Gets or sets the element at the specified index.
Top
See Also

Reference

StatisticsDatabaseObjectList Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Count Property (StatisticsDatabaseObjectList)

Count Property (StatisticsDatabaseObjectList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsDatabaseObjectList Class : Count Property
Indicates the number of items in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Count As System.Integer
'Usage

Dim instance As StatisticsDatabaseObjectList
Dim value As System.Integer

value = instance.Count
public System.int Count {get;}
public: __property System.int get_Count();
Requirements

See Also

Reference

StatisticsDatabaseObjectList Class
StatisticsDatabaseObjectList Members


Item Property (StatisticsDatabaseObjectList)

Item Property (StatisticsDatabaseObjectList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsDatabaseObjectList Class : Item Property
The zero-based index of the element to get or set.
Gets or sets the element at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As StatisticsDatabaseObject
'Usage

Dim instance As StatisticsDatabaseObjectList
Dim index As System.Integer
Dim value As StatisticsDatabaseObject

value = instance.Item(index)
public StatisticsDatabaseObject this[
   System.int index
]; {get;}
public: __property StatisticsDatabaseObject* get_Item   System.int index
;

Parameters

index
The zero-based index of the element to get or set.

Property Value

The element at the specified index.
Requirements

See Also

Reference

StatisticsDatabaseObjectList Class
StatisticsDatabaseObjectList Members


StatisticsField Class

StatisticsField Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : StatisticsField Class
Describes a database object field being used in the query.
Object Model
StatisticsField ClassSQLQualifiedName ClassSQLQualifiedName ClassMetadataField ClassMetadataObject ClassSQLQualifiedName Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class StatisticsField
'Usage

Dim instance As StatisticsField
public class StatisticsField
public __gc class StatisticsField
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.StatisticsField

Requirements

See Also

Reference

StatisticsField Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


StatisticsField Class Members

StatisticsField Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : StatisticsField Class

The following tables list the members exposed by StatisticsField.

Public Properties
 | Name | Description
Public Property | FieldName | Gets the name of the database object field.
Public Property | FieldType | Gets DB type for the database object field.
Public Property | FullName | Gets the fully qualified name of the database object field.
Public Property | MetadataField | Gets the reference to the MetadataField object that corresponds to the database object field.
Public Property | MetadataObject | Gets the reference to the MetadataObject object that corresponds to the database object field.
Public Property | ObjectName | Gets the database object name for the database object field.
Public Property | Selected | Indicates that the field is used in the SELECT list, i.e. it affects the query result set.
Top
See Also

Reference

StatisticsField Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


StatisticsField Class Properties

StatisticsField Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : StatisticsField Class

For a list of all members of this type, see StatisticsField members.

Public Properties
 | Name | Description
Public Property | FieldName | Gets the name of the database object field.
Public Property | FieldType | Gets DB type for the database object field.
Public Property | FullName | Gets the fully qualified name of the database object field.
Public Property | MetadataField | Gets the reference to the MetadataField object that corresponds to the database object field.
Public Property | MetadataObject | Gets the reference to the MetadataObject object that corresponds to the database object field.
Public Property | ObjectName | Gets the database object name for the database object field.
Public Property | Selected | Indicates that the field is used in the SELECT list, i.e. it affects the query result set.
Top
See Also

Reference

StatisticsField Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


FieldName Property (StatisticsField)

FieldName Property (StatisticsField)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsField Class : FieldName Property
Gets the name of the database object field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property FieldName As SQLQualifiedName
'Usage

Dim instance As StatisticsField
Dim value As SQLQualifiedName

value = instance.FieldName
public SQLQualifiedName FieldName {get;}
public: __property SQLQualifiedName* get_FieldName();
Requirements

See Also

Reference

StatisticsField Class
StatisticsField Members


FieldType Property (StatisticsField)

FieldType Property (StatisticsField)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsField Class : FieldType Property
Gets DB type for the database object field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property FieldType As System.Data.DbType
'Usage

Dim instance As StatisticsField
Dim value As System.Data.DbType

value = instance.FieldType
public System.Data.DbType FieldType {get;}
public: __property System.Data.DbType get_FieldType();

Property Value

Value is taken from the MetadataField.FieldType property; is set to DbType.Object if a corresponding field is not found in the Metadata Container.
Requirements

See Also

Reference

StatisticsField Class
StatisticsField Members


FullName Property (StatisticsField)

FullName Property (StatisticsField)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsField Class : FullName Property
Gets the fully qualified name of the database object field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property FullName As SQLQualifiedName
'Usage

Dim instance As StatisticsField
Dim value As SQLQualifiedName

value = instance.FullName
public SQLQualifiedName FullName {get;}
public: __property SQLQualifiedName* get_FullName();
Requirements

See Also

Reference

StatisticsField Class
StatisticsField Members


MetadataField Property (StatisticsField)

MetadataField Property (StatisticsField)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsField Class : MetadataField Property
Gets the reference to the MetadataField object that corresponds to the database object field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property MetadataField As MetadataField
'Usage

Dim instance As StatisticsField
Dim value As MetadataField

value = instance.MetadataField
public MetadataField MetadataField {get;}
public: __property MetadataField* get_MetadataField();
Remarks
Can be null if a corresponding field is not found in the Metadata Container.
Requirements

See Also

Reference

StatisticsField Class
StatisticsField Members


MetadataObject Property (StatisticsField)

MetadataObject Property (StatisticsField)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsField Class : MetadataObject Property
Gets the reference to the MetadataObject object that corresponds to the database object field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property MetadataObject As MetadataObject
'Usage

Dim instance As StatisticsField
Dim value As MetadataObject

value = instance.MetadataObject
public MetadataObject MetadataObject {get;}
public: __property MetadataObject* get_MetadataObject();
Remarks
Can be null if a corresponding field is not found in the Metadata Container.
Requirements

See Also

Reference

StatisticsField Class
StatisticsField Members


ObjectName Property (StatisticsField)

ObjectName Property (StatisticsField)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsField Class : ObjectName Property
Gets the database object name for the database object field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ObjectName As SQLQualifiedName
'Usage

Dim instance As StatisticsField
Dim value As SQLQualifiedName

value = instance.ObjectName
public SQLQualifiedName ObjectName {get;}
public: __property SQLQualifiedName* get_ObjectName();
Requirements

See Also

Reference

StatisticsField Class
StatisticsField Members


Selected Property

Selected Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsField Class : Selected Property
Indicates that the field is used in the SELECT list, i.e. it affects the query result set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Selected As System.Boolean
'Usage

Dim instance As StatisticsField
Dim value As System.Boolean

value = instance.Selected
public System.bool Selected {get;}
public: __property System.bool get_Selected();
Remarks
Unlike the QueryStatistics.OutputColumns, this property allows to retrieve the list of fields, not expressions that were used for output.
Requirements

See Also

Reference

StatisticsField Class
StatisticsField Members


StatisticsFieldList Class

StatisticsFieldList Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : StatisticsFieldList Class
Lists database object fields used in the query (QueryStatistics.UsedDatabaseObjectFields).
Object Model
StatisticsFieldList ClassStatisticsField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class StatisticsFieldList
   Inherits StatisticsBase
'Usage

Dim instance As StatisticsFieldList
public class StatisticsFieldList : StatisticsBase
public __gc class StatisticsFieldList : public StatisticsBase
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.StatisticsFieldList

Requirements

See Also

Reference

StatisticsFieldList Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


StatisticsFieldList Class Members

StatisticsFieldList Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : StatisticsFieldList Class

The following tables list the members exposed by StatisticsFieldList.

Public Properties
 | Name | Description
Public Property | Count | Indicates the number of items in the list.
Public Property | Item | Gets or sets the element at the specified index.
Top
See Also

Reference

StatisticsFieldList Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


StatisticsFieldList Class Properties

StatisticsFieldList Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : StatisticsFieldList Class

For a list of all members of this type, see StatisticsFieldList members.

Public Properties
 | Name | Description
Public Property | Count | Indicates the number of items in the list.
Public Property | Item | Gets or sets the element at the specified index.
Top
See Also

Reference

StatisticsFieldList Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Count Property (StatisticsFieldList)

Count Property (StatisticsFieldList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsFieldList Class : Count Property
Indicates the number of items in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Count As System.Integer
'Usage

Dim instance As StatisticsFieldList
Dim value As System.Integer

value = instance.Count
public System.int Count {get;}
public: __property System.int get_Count();
Requirements

See Also

Reference

StatisticsFieldList Class
StatisticsFieldList Members


Item Property (StatisticsFieldList)

Item Property (StatisticsFieldList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsFieldList Class : Item Property
The zero-based index of the element to get or set.
Gets or sets the element at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As StatisticsField
'Usage

Dim instance As StatisticsFieldList
Dim index As System.Integer
Dim value As StatisticsField

value = instance.Item(index)
public StatisticsField this[
   System.int index
]; {get;}
public: __property StatisticsField* get_Item   System.int index
;

Parameters

index
The zero-based index of the element to get or set.

Property Value

The element at the specified index.
Requirements

See Also

Reference

StatisticsFieldList Class
StatisticsFieldList Members


StatisticsOutputColumn Class

StatisticsOutputColumn Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : StatisticsOutputColumn Class
Describes a column in result set of the query.
Object Model
StatisticsOutputColumn ClassMetadataField ClassMetadataObject Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class StatisticsOutputColumn
'Usage

Dim instance As StatisticsOutputColumn
public class StatisticsOutputColumn
public __gc class StatisticsOutputColumn
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.StatisticsOutputColumn

Requirements

See Also

Reference

StatisticsOutputColumn Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


StatisticsOutputColumn Class Members

StatisticsOutputColumn Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : StatisticsOutputColumn Class

The following tables list the members exposed by StatisticsOutputColumn.

Public Properties
 | Name | Description
Public Property | ColumnAlias | Gets the alias of the column.
Public Property | ColumnName | Gets the name of the column.
Public Property | Expression | Gets the SQL expression string for the coumn as it is written in the SELECT list.
Public Property | FieldName | Gets the database object field name if the column is a simple database object field.
Public Property | FieldType | Gets DB type for the database object field if the column is a single database object field.
Public Property | MetadataField | Gets the reference to the MetadataField object that corresponds to the database object field.
Public Property | MetadataObject | Gets the reference to the MetadataObject object that corresponds to the database object field.
Public Property | ObjectAlias | Gets the alias of database object if the column is a single database object field.
Public Property | ObjectName | Gets the name of database object if the column is a single database object field.
Public Property | QueryColumnListItem |
Top
See Also

Reference

StatisticsOutputColumn Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


StatisticsOutputColumn Class Properties

StatisticsOutputColumn Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : StatisticsOutputColumn Class

For a list of all members of this type, see StatisticsOutputColumn members.

Public Properties
 | Name | Description
Public Property | ColumnAlias | Gets the alias of the column.
Public Property | ColumnName | Gets the name of the column.
Public Property | Expression | Gets the SQL expression string for the coumn as it is written in the SELECT list.
Public Property | FieldName | Gets the database object field name if the column is a simple database object field.
Public Property | FieldType | Gets DB type for the database object field if the column is a single database object field.
Public Property | MetadataField | Gets the reference to the MetadataField object that corresponds to the database object field.
Public Property | MetadataObject | Gets the reference to the MetadataObject object that corresponds to the database object field.
Public Property | ObjectAlias | Gets the alias of database object if the column is a single database object field.
Public Property | ObjectName | Gets the name of database object if the column is a single database object field.
Public Property | QueryColumnListItem |
Top
See Also

Reference

StatisticsOutputColumn Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


ColumnAlias Property

ColumnAlias Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsOutputColumn Class : ColumnAlias Property
Gets the alias of the column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ColumnAlias As System.String
'Usage

Dim instance As StatisticsOutputColumn
Dim value As System.String

value = instance.ColumnAlias
public System.string ColumnAlias {get;}
public: __property System.string* get_ColumnAlias();
Requirements

See Also

Reference

StatisticsOutputColumn Class
StatisticsOutputColumn Members


ColumnName Property

ColumnName Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsOutputColumn Class : ColumnName Property
Gets the name of the column.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ColumnName As System.String
'Usage

Dim instance As StatisticsOutputColumn
Dim value As System.String

value = instance.ColumnName
public System.string ColumnName {get;}
public: __property System.string* get_ColumnName();
Requirements

See Also

Reference

StatisticsOutputColumn Class
StatisticsOutputColumn Members


Expression Property (StatisticsOutputColumn)

Expression Property (StatisticsOutputColumn)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsOutputColumn Class : Expression Property
Gets the SQL expression string for the coumn as it is written in the SELECT list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Expression As System.String
'Usage

Dim instance As StatisticsOutputColumn
Dim value As System.String

value = instance.Expression
public System.string Expression {get;}
public: __property System.string* get_Expression();
Requirements

See Also

Reference

StatisticsOutputColumn Class
StatisticsOutputColumn Members


FieldName Property (StatisticsOutputColumn)

FieldName Property (StatisticsOutputColumn)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsOutputColumn Class : FieldName Property
Gets the database object field name if the column is a simple database object field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property FieldName As System.String
'Usage

Dim instance As StatisticsOutputColumn
Dim value As System.String

value = instance.FieldName
public System.string FieldName {get;}
public: __property System.string* get_FieldName();
Requirements

See Also

Reference

StatisticsOutputColumn Class
StatisticsOutputColumn Members


FieldType Property (StatisticsOutputColumn)

FieldType Property (StatisticsOutputColumn)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsOutputColumn Class : FieldType Property
Gets DB type for the database object field if the column is a single database object field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property FieldType As System.Data.DbType
'Usage

Dim instance As StatisticsOutputColumn
Dim value As System.Data.DbType

value = instance.FieldType
public System.Data.DbType FieldType {get;}
public: __property System.Data.DbType get_FieldType();

Property Value

Value is taken from the MetadataField.property FieldType; is set to DbType.Object if a corresponding field is not found in the Metadata Container or the column is not a single database object field.
Requirements

See Also

Reference

StatisticsOutputColumn Class
StatisticsOutputColumn Members


MetadataField Property (StatisticsOutputColumn)

MetadataField Property (StatisticsOutputColumn)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsOutputColumn Class : MetadataField Property
Gets the reference to the MetadataField object that corresponds to the database object field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property MetadataField As MetadataField
'Usage

Dim instance As StatisticsOutputColumn
Dim value As MetadataField

value = instance.MetadataField
public MetadataField MetadataField {get;}
public: __property MetadataField* get_MetadataField();
Remarks
Can be null if a corresponding field is not found in the Metadata Container or the column is not a single database object field.
Requirements

See Also

Reference

StatisticsOutputColumn Class
StatisticsOutputColumn Members


MetadataObject Property (StatisticsOutputColumn)

MetadataObject Property (StatisticsOutputColumn)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsOutputColumn Class : MetadataObject Property
Gets the reference to the MetadataObject object that corresponds to the database object field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property MetadataObject As MetadataObject
'Usage

Dim instance As StatisticsOutputColumn
Dim value As MetadataObject

value = instance.MetadataObject
public MetadataObject MetadataObject {get;}
public: __property MetadataObject* get_MetadataObject();
Remarks
Can be null if a corresponding field is not found in the Metadata Container or the column is not a single database object field.
Requirements

See Also

Reference

StatisticsOutputColumn Class
StatisticsOutputColumn Members


ObjectAlias Property

ObjectAlias Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsOutputColumn Class : ObjectAlias Property
Gets the alias of database object if the column is a single database object field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ObjectAlias As System.String
'Usage

Dim instance As StatisticsOutputColumn
Dim value As System.String

value = instance.ObjectAlias
public System.string ObjectAlias {get;}
public: __property System.string* get_ObjectAlias();
Requirements

See Also

Reference

StatisticsOutputColumn Class
StatisticsOutputColumn Members


ObjectName Property (StatisticsOutputColumn)

ObjectName Property (StatisticsOutputColumn)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsOutputColumn Class : ObjectName Property
Gets the name of database object if the column is a single database object field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ObjectName As System.String
'Usage

Dim instance As StatisticsOutputColumn
Dim value As System.String

value = instance.ObjectName
public System.string ObjectName {get;}
public: __property System.string* get_ObjectName();
Requirements

See Also

Reference

StatisticsOutputColumn Class
StatisticsOutputColumn Members


QueryColumnListItem Property

QueryColumnListItem Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsOutputColumn Class : QueryColumnListItem Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property QueryColumnListItem As QueryColumnListItem
'Usage

Dim instance As StatisticsOutputColumn
Dim value As QueryColumnListItem

value = instance.QueryColumnListItem
public QueryColumnListItem QueryColumnListItem {get;}
public: __property QueryColumnListItem* get_QueryColumnListItem();
Requirements

See Also

Reference

StatisticsOutputColumn Class
StatisticsOutputColumn Members


StatisticsOutputColumnList Class

StatisticsOutputColumnList Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : StatisticsOutputColumnList Class
Lists output (result set) columns of the query (QueryStatistics.OutputColumns).
Object Model
StatisticsOutputColumnList ClassStatisticsOutputColumn Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class StatisticsOutputColumnList
   Inherits StatisticsBase
'Usage

Dim instance As StatisticsOutputColumnList
public class StatisticsOutputColumnList : StatisticsBase
public __gc class StatisticsOutputColumnList : public StatisticsBase
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.StatisticsOutputColumnList

Requirements

See Also

Reference

StatisticsOutputColumnList Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


StatisticsOutputColumnList Class Members

StatisticsOutputColumnList Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : StatisticsOutputColumnList Class

The following tables list the members exposed by StatisticsOutputColumnList.

Public Properties
 | Name | Description
Public Property | Count | Indicates the number of items in the list.
Public Property | Item | Gets or sets the element at the specified index.
Top
See Also

Reference

StatisticsOutputColumnList Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


StatisticsOutputColumnList Class Properties

StatisticsOutputColumnList Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : StatisticsOutputColumnList Class

For a list of all members of this type, see StatisticsOutputColumnList members.

Public Properties
 | Name | Description
Public Property | Count | Indicates the number of items in the list.
Public Property | Item | Gets or sets the element at the specified index.
Top
See Also

Reference

StatisticsOutputColumnList Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Count Property (StatisticsOutputColumnList)

Count Property (StatisticsOutputColumnList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsOutputColumnList Class : Count Property
Indicates the number of items in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Count As System.Integer
'Usage

Dim instance As StatisticsOutputColumnList
Dim value As System.Integer

value = instance.Count
public System.int Count {get;}
public: __property System.int get_Count();
Requirements

See Also

Reference

StatisticsOutputColumnList Class
StatisticsOutputColumnList Members


Item Property (StatisticsOutputColumnList)

Item Property (StatisticsOutputColumnList)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > StatisticsOutputColumnList Class : Item Property
The zero-based index of the element to get or set.
Gets or sets the element at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As StatisticsOutputColumn
'Usage

Dim instance As StatisticsOutputColumnList
Dim index As System.Integer
Dim value As StatisticsOutputColumn

value = instance.Item(index)
public StatisticsOutputColumn this[
   System.int index
]; {get;}
public: __property StatisticsOutputColumn* get_Item   System.int index
;

Parameters

index
The zero-based index of the element to get or set.

Property Value

The element at the specified index.
Requirements

See Also

Reference

StatisticsOutputColumnList Class
StatisticsOutputColumnList Members


SybaseSyntaxProvider Class

SybaseSyntaxProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SybaseSyntaxProvider Class
Syntax provider for Sybase ASA/ASE.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class SybaseSyntaxProvider
   Inherits BaseSyntaxProvider
'Usage

Dim instance As SybaseSyntaxProvider
public class SybaseSyntaxProvider : BaseSyntaxProvider
public __gc class SybaseSyntaxProvider : public BaseSyntaxProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.SybaseSyntaxProvider

Requirements

See Also

Reference

SybaseSyntaxProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SybaseSyntaxProvider Class Members

SybaseSyntaxProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SybaseSyntaxProvider Class

The following tables list the members exposed by SybaseSyntaxProvider.

Public Properties
 | Name | Description
Public Property | IdentCaseSens | Overridden. Defines the way database server treats quoted and unquoted identifiers.
Public Property | ServerVersion | Gets or sets the Sybase server type (ASA or ASE).
Top
See Also

Reference

SybaseSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SybaseSyntaxProvider Class Properties

SybaseSyntaxProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SybaseSyntaxProvider Class

For a list of all members of this type, see SybaseSyntaxProvider members.

Public Properties
 | Name | Description
Public Property | IdentCaseSens | Overridden. Defines the way database server treats quoted and unquoted identifiers.
Public Property | ServerVersion | Gets or sets the Sybase server type (ASA or ASE).
Top
See Also

Reference

SybaseSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


IdentCaseSens Property (SybaseSyntaxProvider)

IdentCaseSens Property (SybaseSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseSyntaxProvider Class : IdentCaseSens Property
Defines the way database server treats quoted and unquoted identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property IdentCaseSens As IdentCaseSensitivity
'Usage

Dim instance As SybaseSyntaxProvider
Dim value As IdentCaseSensitivity

instance.IdentCaseSens = value

value = instance.IdentCaseSens
public override IdentCaseSensitivity IdentCaseSens {get; set;}
public: __property IdentCaseSensitivity get_IdentCaseSens() override;
public: __property void set_IdentCaseSens(
   IdentCaseSensitivity value
) override;
Requirements

See Also

Reference

SybaseSyntaxProvider Class
SybaseSyntaxProvider Members
Base Implementation in IdentCaseSens


ServerVersion Property (SybaseSyntaxProvider)

ServerVersion Property (SybaseSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseSyntaxProvider Class : ServerVersion Property
Gets or sets the Sybase server type (ASA or ASE).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ServerVersion As SybaseServerVersion
'Usage

Dim instance As SybaseSyntaxProvider
Dim value As SybaseServerVersion

instance.ServerVersion = value

value = instance.ServerVersion
public SybaseServerVersion ServerVersion {get; set;}
public: __property SybaseServerVersion get_ServerVersion();
public: __property void set_ServerVersion(
   SybaseServerVersion value
);
Requirements

See Also

Reference

SybaseSyntaxProvider Class
SybaseSyntaxProvider Members


UserMessageEventArgs Class

UserMessageEventArgs Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : UserMessageEventArgs Class
Class to define parameters passed to the QueryBuilder.UserMessage event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class UserMessageEventArgs
'Usage

Dim instance As UserMessageEventArgs
public class UserMessageEventArgs
public __gc class UserMessageEventArgs
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.UserMessageEventArgs

Requirements

See Also

Reference

UserMessageEventArgs Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


UserMessageEventArgs Class Members

UserMessageEventArgs Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : UserMessageEventArgs Class

The following tables list the members exposed by UserMessageEventArgs.

Public Properties
 | Name | Description
Public Property | Message | Gets the warning message string to be displayed to the user.
Public Property | MessageId | Gets the value that uniquely identifies the situation that requires to warn the user.
Top
See Also

Reference

UserMessageEventArgs Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


UserMessageEventArgs Class Properties

UserMessageEventArgs Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : UserMessageEventArgs Class

For a list of all members of this type, see UserMessageEventArgs members.

Public Properties
 | Name | Description
Public Property | Message | Gets the warning message string to be displayed to the user.
Public Property | MessageId | Gets the value that uniquely identifies the situation that requires to warn the user.
Top
See Also

Reference

UserMessageEventArgs Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Message Property (UserMessageEventArgs)

Message Property (UserMessageEventArgs)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UserMessageEventArgs Class : Message Property
Gets the warning message string to be displayed to the user.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Message As System.String
'Usage

Dim instance As UserMessageEventArgs
Dim value As System.String

value = instance.Message
public System.string Message {get;}
public: __property System.string* get_Message();
Requirements

See Also

Reference

UserMessageEventArgs Class
UserMessageEventArgs Members


MessageId Property

MessageId Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UserMessageEventArgs Class : MessageId Property
Gets the value that uniquely identifies the situation that requires to warn the user.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property MessageId As UserMessageId
'Usage

Dim instance As UserMessageEventArgs
Dim value As UserMessageId

value = instance.MessageId
public UserMessageId MessageId {get;}
public: __property UserMessageId get_MessageId();
Requirements

See Also

Reference

UserMessageEventArgs Class
UserMessageEventArgs Members


VistaDBSyntaxProvider Class

VistaDBSyntaxProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : VistaDBSyntaxProvider Class
Syntax provider for VistaDB embedded database engine.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class VistaDBSyntaxProvider
   Inherits BaseSyntaxProvider
'Usage

Dim instance As VistaDBSyntaxProvider
public class VistaDBSyntaxProvider : BaseSyntaxProvider
public __gc class VistaDBSyntaxProvider : public BaseSyntaxProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.VistaDBSyntaxProvider

Requirements

See Also

Reference

VistaDBSyntaxProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


VistaDBSyntaxProvider Class Members

VistaDBSyntaxProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : VistaDBSyntaxProvider Class

The following tables list the members exposed by VistaDBSyntaxProvider.

Public Properties
 | Name | Description
Public Property | DenyIntoClause | Overridden. Instructs to deny the INTO clause parsing and generation.
Public Property | IdentCaseSens | Overridden. Defines the way database server treats quoted and unquoted identifiers.
Top
See Also

Reference

VistaDBSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


VistaDBSyntaxProvider Class Properties

VistaDBSyntaxProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : VistaDBSyntaxProvider Class

For a list of all members of this type, see VistaDBSyntaxProvider members.

Public Properties
 | Name | Description
Public Property | DenyIntoClause | Overridden. Instructs to deny the INTO clause parsing and generation.
Public Property | IdentCaseSens | Overridden. Defines the way database server treats quoted and unquoted identifiers.
Top
See Also

Reference

VistaDBSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


DenyIntoClause Property (VistaDBSyntaxProvider)

DenyIntoClause Property (VistaDBSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBSyntaxProvider Class : DenyIntoClause Property
Instructs to deny the INTO clause parsing and generation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property DenyIntoClause As System.Boolean
'Usage

Dim instance As VistaDBSyntaxProvider
Dim value As System.Boolean

instance.DenyIntoClause = value

value = instance.DenyIntoClause
public override System.bool DenyIntoClause {get; set;}
public: __property System.bool get_DenyIntoClause() override;
public: __property void set_DenyIntoClause(
   System.bool value
) override;
Requirements

See Also

Reference

VistaDBSyntaxProvider Class
VistaDBSyntaxProvider Members
Base Implementation in DenyIntoClause


IdentCaseSens Property (VistaDBSyntaxProvider)

IdentCaseSens Property (VistaDBSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBSyntaxProvider Class : IdentCaseSens Property
Defines the way database server treats quoted and unquoted identifiers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property IdentCaseSens As IdentCaseSensitivity
'Usage

Dim instance As VistaDBSyntaxProvider
Dim value As IdentCaseSensitivity

instance.IdentCaseSens = value

value = instance.IdentCaseSens
public override IdentCaseSensitivity IdentCaseSens {get; set;}
public: __property IdentCaseSensitivity get_IdentCaseSens() override;
public: __property void set_IdentCaseSens(
   IdentCaseSensitivity value
) override;
Requirements

See Also

Reference

VistaDBSyntaxProvider Class
VistaDBSyntaxProvider Members
Base Implementation in IdentCaseSens


VisualOptions Class

VisualOptions Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : VisualOptions Class
Contains visual options that are not related to any pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class VisualOptions
   Inherits UpdatablePersistent
'Usage

Dim instance As VisualOptions
public class VisualOptions : UpdatablePersistent
public __gc class VisualOptions : public UpdatablePersistent
Inheritance Hierarchy

System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.VisualOptions

Requirements

See Also

Reference

VisualOptions Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
VisualOptions Property


VisualOptions Class Members

VisualOptions Class Members
Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : VisualOptions Class

The following tables list the members exposed by VisualOptions.

Public Properties
 | Name | Description
Public Property | FlatBorders | Determines appearance of the control's borders within the component.
Public Property | ShowTabIcons | Determines visibility of sub-query type icons at tabs.
Public Property | TabsAlignment | Determines alignment of sub-query tabs above the Design Pane (left or right).
Public Property | TabsAppearance | Determines appearance of sub-query tabs above the Design Pane.
Public Property | TabsImageList | Allow to specify custom ImageList for sub-query type icons at the tabs.
Top
See Also

Reference

VisualOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
VisualOptions Property


VisualOptions Class Properties

VisualOptions Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : VisualOptions Class

For a list of all members of this type, see VisualOptions members.

Public Properties
 | Name | Description
Public Property | FlatBorders | Determines appearance of the control's borders within the component.
Public Property | ShowTabIcons | Determines visibility of sub-query type icons at tabs.
Public Property | TabsAlignment | Determines alignment of sub-query tabs above the Design Pane (left or right).
Public Property | TabsAppearance | Determines appearance of sub-query tabs above the Design Pane.
Public Property | TabsImageList | Allow to specify custom ImageList for sub-query type icons at the tabs.
Top
See Also

Reference

VisualOptions Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
VisualOptions Property


FlatBorders Property

FlatBorders Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VisualOptions Class : FlatBorders Property
Determines appearance of the control's borders within the component.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property FlatBorders As System.Boolean
'Usage

Dim instance As VisualOptions
Dim value As System.Boolean

instance.FlatBorders = value

value = instance.FlatBorders
public System.bool FlatBorders {get; set;}
public: __property System.bool get_FlatBorders();
public: __property void set_FlatBorders(
   System.bool value
);

Property Value

The controls appear flat when this property is true, otherwise the control appear three-dimensional.
Requirements

See Also

Reference

VisualOptions Class
VisualOptions Members


ShowTabIcons Property

ShowTabIcons Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VisualOptions Class : ShowTabIcons Property
Determines visibility of sub-query type icons at tabs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ShowTabIcons As System.Boolean
'Usage

Dim instance As VisualOptions
Dim value As System.Boolean

instance.ShowTabIcons = value

value = instance.ShowTabIcons
public System.bool ShowTabIcons {get; set;}
public: __property System.bool get_ShowTabIcons();
public: __property void set_ShowTabIcons(
   System.bool value
);
Remarks
There are four sub-query types: main query, expression sub-query, derived table and CTE.
Requirements

See Also

Reference

VisualOptions Class
VisualOptions Members


TabsAlignment Property

TabsAlignment Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VisualOptions Class : TabsAlignment Property
Determines alignment of sub-query tabs above the Design Pane (left or right).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property TabsAlignment As TabsAlignment
'Usage

Dim instance As VisualOptions
Dim value As TabsAlignment

instance.TabsAlignment = value

value = instance.TabsAlignment
public TabsAlignment TabsAlignment {get; set;}
public: __property TabsAlignment get_TabsAlignment();
public: __property void set_TabsAlignment(
   TabsAlignment value
);
Requirements

See Also

Reference

VisualOptions Class
VisualOptions Members


TabsAppearance Property

TabsAppearance Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VisualOptions Class : TabsAppearance Property
Determines appearance of sub-query tabs above the Design Pane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property TabsAppearance As System.Windows.Forms.TabAppearance
'Usage

Dim instance As VisualOptions
Dim value As System.Windows.Forms.TabAppearance

instance.TabsAppearance = value

value = instance.TabsAppearance
public System.Windows.Forms.TabAppearance TabsAppearance {get; set;}
public: __property System.Windows.Forms.TabAppearance get_TabsAppearance();
public: __property void set_TabsAppearance(
   System.Windows.Forms.TabAppearance value
);
Requirements

See Also

Reference

VisualOptions Class
VisualOptions Members


TabsImageList Property

TabsImageList Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VisualOptions Class : TabsImageList Property
Allow to specify custom ImageList for sub-query type icons at the tabs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property TabsImageList As System.Windows.Forms.ImageList
'Usage

Dim instance As VisualOptions
Dim value As System.Windows.Forms.ImageList

instance.TabsImageList = value

value = instance.TabsImageList
public System.Windows.Forms.ImageList TabsImageList {get; set;}
public: __property System.Windows.Forms.ImageList* get_TabsImageList();
public: __property void set_TabsImageList(
   System.Windows.Forms.ImageList* value
);
Remarks
This image list should contain 4 icons: main query, expression sub-query, derived table and CTE.
Requirements

See Also

Reference

VisualOptions Class
VisualOptions Members


AffectedColumns Enumeration

AffectedColumns Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AffectedColumns Enumeration
Defines set of the Query Columns List columns to determine their behavior.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum AffectedColumns
   Inherits System.Enum
'Usage

Dim instance As AffectedColumns
public enum AffectedColumns : System.Enum
__value public enum AffectedColumns : public System.Enum
Members
Member | Description
ConditionColumns | Instructs to affect specified behavior to condition columns (Criteria and Or).
ExpressionColumn | Instructs to affect specified behavior to Expression column.
None | Instructs to disable specified behavior for all columns.
Remarks
Setting the property of AffectedColumns type to 3 instructs to affect specified behavior to both expression AND conditions columns.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.AffectedColumns

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


CollapseExpandButtonLocation Enumeration

CollapseExpandButtonLocation Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : CollapseExpandButtonLocation Enumeration
Defines various options for location of the Collapse/Expand button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum CollapseExpandButtonLocation
   Inherits System.Enum
'Usage

Dim instance As CollapseExpandButtonLocation
public enum CollapseExpandButtonLocation : System.Enum
__value public enum CollapseExpandButtonLocation : public System.Enum
Members
Member | Description
Bottom | Instructs to place the Collapse/Expand button at the bottom of datasource.
Top | Instructs to place the Collapse/Expand button at the top of datasource.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.CollapseExpandButtonLocation

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


DB2NamingConventions Enumeration

DB2NamingConventions Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DB2NamingConventions Enumeration
Determines possible database object naming conventions for DB2 databases.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum DB2NamingConventions
   Inherits System.Enum
'Usage

Dim instance As DB2NamingConventions
public enum DB2NamingConventions : System.Enum
__value public enum DB2NamingConventions : public System.Enum
Members
Member | Description
SQL | SQL naming convention: Dot (.) is used to separate parts of qualilfied identifiers.
System | SQL naming convention: Slash (/) is used to separate parts of qualilfied identifiers.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.DB2NamingConventions

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


DefaultImageListImageIndexes Enumeration

DefaultImageListImageIndexes Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DefaultImageListImageIndexes Enumeration
Defines indexes of images in default metadata structure image list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum DefaultImageListImageIndexes
   Inherits System.Enum
'Usage

Dim instance As DefaultImageListImageIndexes
public enum DefaultImageListImageIndexes : System.Enum
__value public enum DefaultImageListImageIndexes : public System.Enum
Members
Member | Description
Database |
Empty |
Field |
Fields |
Filter |
Folder |
ForeignKey |
Package |
Parameter |
PrimaryKey |
Procedure |
Query |
Schema |
Server |
Synonym |
Table |
Unknown |
View |
VirtualField |
VirtualObject |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.DefaultImageListImageIndexes

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


DesignPaneOverviewVisibility Enumeration

DesignPaneOverviewVisibility Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DesignPaneOverviewVisibility Enumeration

Determines possible values for visibility of the Design Pane Overview.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum DesignPaneOverviewVisibility
   Inherits System.Enum
'Usage

Dim instance As DesignPaneOverviewVisibility
public enum DesignPaneOverviewVisibility : System.Enum
__value public enum DesignPaneOverviewVisibility : public System.Enum
Members
Member | Description
Auto | Design Pane Overview shows up if necessary.
Hidden | Design Pane Overview is always hidden.
Visible | Design Pane Overview is always visible.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.DesignPaneOverviewVisibility

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


FieldListSortType Enumeration

FieldListSortType Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FieldListSortType Enumeration
Defines various types of datasource's field list sorting.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum FieldListSortType
   Inherits System.Enum
'Usage

Dim instance As FieldListSortType
public enum FieldListSortType : System.Enum
__value public enum FieldListSortType : public System.Enum
Members
Member | Description
Description | Specifies field list sorting by Description.
Name | Specifies field list sorting by Name.
None | Denies field list sorting; fields are shown in the list as they were retrieved from a database.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.FieldListSortType

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


FieldTypeCase Enumeration

FieldTypeCase Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FieldTypeCase Enumeration
Defines various types of case conversions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum FieldTypeCase
   Inherits System.Enum
'Usage

Dim instance As FieldTypeCase
public enum FieldTypeCase : System.Enum
__value public enum FieldTypeCase : public System.Enum
Members
Member | Description
Capitalize | Converts strings to First Upper Case.
Lowercase | Converts strings to lower case.
Uppercase | Converts strings to UPPER CASE.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.FieldTypeCase

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


FirebirdVersion Enumeration

FirebirdVersion Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FirebirdVersion Enumeration
Firebird server versions enumeration.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum FirebirdVersion
   Inherits System.Enum
'Usage

Dim instance As FirebirdVersion
public enum FirebirdVersion : System.Enum
__value public enum FirebirdVersion : public System.Enum
Members
Member | Description
Firebird1 | Firebird versions 1.x (less than 1.5)
Firebird1_5 | Firebird versions 1.5.x
Firebird2 | Firebird versions 2.0.x
Firebird2_5 | Firebird versions 2.5.x
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.FirebirdVersion

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


GenericSyntaxServerType Enumeration

GenericSyntaxServerType Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : GenericSyntaxServerType Enumeration
Enumerates possible database server types to be used by the Generic Syntax Provider.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum GenericSyntaxServerType
   Inherits System.Enum
'Usage

Dim instance As GenericSyntaxServerType
public enum GenericSyntaxServerType : System.Enum
__value public enum GenericSyntaxServerType : public System.Enum
Members
Member | Description
DB2 |
Firebird |
Informix |
MSAccess |
MSSQL |
MSSQLAzure |
MSSQLCE |
MySQL |
Oracle |
PostgreSQL |
SQLite |
SybaseAsa |
SybaseAse |
Unknown |
VistaDB |
Remarks
Used to determine correct quotation of identifiers and their case sensitivity.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.GenericSyntaxServerType

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


IdentCaseSensitivity Enumeration

IdentCaseSensitivity Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : IdentCaseSensitivity Enumeration
Determines various types of database server case sensitivity options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum IdentCaseSensitivity
   Inherits System.Enum
'Usage

Dim instance As IdentCaseSensitivity
public enum IdentCaseSensitivity : System.Enum
__value public enum IdentCaseSensitivity : public System.Enum
Members
Member | Description
Insensitive | Instructs to treat all identifiers case insensitive.
SensitiveLowerCase | Instructs to treat quoted identifies case sensitive; assumes unquoted identifies referring to objects in lower case.
SensitiveUpperCase | Instructs to treat quoted identifies case sensitive; assumes unquoted identifies referring to objects in upper case.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.IdentCaseSensitivity

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


IdentQuotation Enumeration

IdentQuotation Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : IdentQuotation Enumeration
Defines various options for quotation of identifiers by the SQL Builder.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum IdentQuotation
   Inherits System.Enum
'Usage

Dim instance As IdentQuotation
public enum IdentQuotation : System.Enum
__value public enum IdentQuotation : public System.Enum
Members
Member | Description
All | Instructs the SQL Builder to quote all identifiers.
IfNeed | Instructs the SQL Builder to quote identifiers if needed.
None | Instructs the SQL Builder not to quote identifiers.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.IdentQuotation

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


InformixVersion Enumeration

InformixVersion Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : InformixVersion Enumeration
Informix Database Server versions enumeration.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum InformixVersion
   Inherits System.Enum
'Usage

Dim instance As InformixVersion
public enum InformixVersion : System.Enum
__value public enum InformixVersion : public System.Enum
Members
Member | Description
DS10 | Informix Database Server 10
DS11 | Informix Database Server 11
DS8 | Informix Database Server 8
DS9 | Informix Database Server 9
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.InformixVersion

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


KeywordFormat Enumeration

KeywordFormat Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : KeywordFormat Enumeration
Defines various options for keyword formatting in the generated SQL query text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum KeywordFormat
   Inherits System.Enum
'Usage

Dim instance As KeywordFormat
public enum KeywordFormat : System.Enum
__value public enum KeywordFormat : public System.Enum
Members
Member | Description
FirstUpper | Instructs the component to generate keywords in First Upper Case.
LowerCase | Instructs the component to generate keywords in lower case.
UpperCase | Instructs the component to generate keywords in UPPER CASE.
Remarks
Applied to BaseSQLBuilder.KeywordFormat property.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.KeywordFormat

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


LinkManipulations Enumeration

LinkManipulations Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : LinkManipulations Enumeration
Defines list of permissible end-user manipulations with links during the query building process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum LinkManipulations
   Inherits System.Enum
'Usage

Dim instance As LinkManipulations
public enum LinkManipulations : System.Enum
__value public enum LinkManipulations : public System.Enum
Members
Member | Description
Allow | Allows manual creation of any links between objects.
AllowForeignKeysOnly

Allow manual creation of links based on foreign keys fetched from a database to the Metadata Container.

In this mode the component will not allow you to drag and drop fields from one object to another if a corresponding foreign key does not exist in the Metadata Container.
Also it is not possible to modify join expression via the Link Properties dialog in this mode.

Deny | Denies manual links creation by end-user.
LinkCompatibleTypesOnly | Allow manual creation of links for compatible data types only.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.LinkManipulations

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
LinkManipulations Property


MetadataForeignKeyCardinality Enumeration

MetadataForeignKeyCardinality Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataForeignKeyCardinality Enumeration
Determines possible cardinality values for one side of relationship of the foreign key.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum MetadataForeignKeyCardinality
   Inherits System.Enum
'Usage

Dim instance As MetadataForeignKeyCardinality
public enum MetadataForeignKeyCardinality : System.Enum
__value public enum MetadataForeignKeyCardinality : public System.Enum
Members
Member | Description
Many | Indicates that the side of relationship may have many occurences.
One | Indicates that the side of relationship may have one occurence only.
Unknown | Indicates that the cardinality of this side of relationship is unknown.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataForeignKeyCardinality

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataType Enumeration

MetadataType Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataType Enumeration
Type of MetadataItem object
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum MetadataType
   Inherits System.Enum
'Usage

Dim instance As MetadataType
public enum MetadataType : System.Enum
__value public enum MetadataType : public System.Enum
Members
Member | Description
Aggregate | Determines the aggregate function.
All | Unites all possible values of this type.
Database | Determines the Database namespace node.
Field | Determines the Field node of a database object.
ForeignKey | Determines the Foreign Key node of a database object.
Namespaces | Unites all possible namespace nodes: Server, Database, Schema, Package.
ObjectMetadata | Unites all possible child nodes of database objects: Field, Parameter, Foreign Key.
Objects | Unites all possible database object nodes: Table, View, Procedure, Synonym.
Package | Determines the Package namespace node.
Parameter | Determines the Parameter node of a database object.
Procedure | Determines the Stored Procedure or Function database object node.
Root | Determines the root node of the metadata tree.
Schema | Determines the Schema namespace node.
Server | Determines the Server namespace node.
Synonym | Determines the Synonym database object node.
Table | Determines the Table database object node.
View | Determines the View database object node.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataType

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MSAccessServerVersion Enumeration

MSAccessServerVersion Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSAccessServerVersion Enumeration
MS Jet versions enumeration
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum MSAccessServerVersion
   Inherits System.Enum
'Usage

Dim instance As MSAccessServerVersion
public enum MSAccessServerVersion : System.Enum
__value public enum MSAccessServerVersion : public System.Enum
Members
Member | Description
MSJET3 | MS Jet 3 (for MS Access 97)
MSJET4 | MS Jet 4 (for MS Access 2000 and newer)
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.MSAccessServerVersion

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MSSQLServerVersion Enumeration

MSSQLServerVersion Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLServerVersion Enumeration
Microsoft SQL Server versions enumeration.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum MSSQLServerVersion
   Inherits System.Enum
'Usage

Dim instance As MSSQLServerVersion
public enum MSSQLServerVersion : System.Enum
__value public enum MSSQLServerVersion : public System.Enum
Members
Member | Description
Auto | Instructs to detect MS SQL Server version automatically
MSSQL2000 | MS SQL Server 2000
MSSQL2005 | MS SQL Server 2005
MSSQL2008 | MS SQL Server 2008
MSSQL2012 | MS SQL Server 2012
MSSQL7 | MS SQL Server 7
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLServerVersion

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


ObjectPrefixSkipping Enumeration

ObjectPrefixSkipping Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : ObjectPrefixSkipping Enumeration
Defines various options for skipping the unnecessary database object prefixes in the generated SQL query text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum ObjectPrefixSkipping
   Inherits System.Enum
'Usage

Dim instance As ObjectPrefixSkipping
public enum ObjectPrefixSkipping : System.Enum
__value public enum ObjectPrefixSkipping : public System.Enum
Members
Member | Description
SkipAll | Instructs the component to skip all unnecessary database object prefixes.
SkipDatabase | Instructs the component to skip database object prefix possible in the current SQL context.
SkipNothing | Instructs the component to preserve all database object prefixes.
Remarks
Applied to BaseSQLBuilder.ObjectPrefixSkipping and SQLGenerationOptions.ObjectPrefixSkipping properties.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.ObjectPrefixSkipping

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


ObjectsSortingType Enumeration

ObjectsSortingType Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : ObjectsSortingType Enumeration
Defines various types of sorting database objects within the Database Schema Tree.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum ObjectsSortingType
   Inherits System.Enum
'Usage

Dim instance As ObjectsSortingType
public enum ObjectsSortingType : System.Enum
__value public enum ObjectsSortingType : public System.Enum
Members
Member | Description
Name | Instructs to sort database objects by object name.
None | Instructs not to sort database objects.
TypeName | Instructs to sort database objects by object type, then by object name.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.ObjectsSortingType

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


OracleServerVersion Enumeration

OracleServerVersion Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : OracleServerVersion Enumeration
Oracle Database server versions enumeration.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum OracleServerVersion
   Inherits System.Enum
'Usage

Dim instance As OracleServerVersion
public enum OracleServerVersion : System.Enum
__value public enum OracleServerVersion : public System.Enum
Members
Member | Description
Oracle10 | Oracle Database 10g
Oracle11 | Oracle Database 11g
Oracle7 | Oracle 7
Oracle8 | Oracle 8, 8i Database
Oracle9 | Oracle 9i Database
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleServerVersion

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


QueryPart Enumeration

QueryPart Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : QueryPart Enumeration
Determines the corresponding part of the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum QueryPart
   Inherits System.Enum
'Usage

Dim instance As QueryPart
public enum QueryPart : System.Enum
__value public enum QueryPart : public System.Enum
Members
Member | Description
Query | Instructs to correspond to the whole query.
SubQuery | Instructs to correnspond to the currently active sub-query.
UnionSubQuery | Instructs to correspond to the currently active union sub-query.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.QueryPart

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SkipKeywordMode Enumeration

SkipKeywordMode Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SkipKeywordMode Enumeration
Defines various options for the component behavior in case of possibility of inserting an optional keyword.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum SkipKeywordMode
   Inherits System.Enum
'Usage

Dim instance As SkipKeywordMode
public enum SkipKeywordMode : System.Enum
__value public enum SkipKeywordMode : public System.Enum
Members
Member | Description
DontCare | Instructs the component to preserve the end-user notation or to act in default way.
PrintAlways | Instructs the component to add an optional keyword always.
SkipIfPossible | Instructs the component to skip an optional keyword if this allowed by specific SQL dialect.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.SkipKeywordMode

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQLBuilderConditionFormatNL Enumeration

SQLBuilderConditionFormatNL Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQLBuilderConditionFormatNL Enumeration
Defines line breaking rules in conditions of the query.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum SQLBuilderConditionFormatNL
   Inherits System.Enum
'Usage

Dim instance As SQLBuilderConditionFormatNL
public enum SQLBuilderConditionFormatNL : System.Enum
__value public enum SQLBuilderConditionFormatNL : public System.Enum
Members
Member | Description
AllLogical | Instructs to insert line break after all logical operators (AND, OR, NOT, etc.)
None | Instructs not to break condition part by lines. Note that this line still might be broken if the BaseSQLBuilder.RightMargin property is not set to zero.
TopmostLogical | Instructs to insert line break after topmost logical operators of condition.
TopmostOr | Instructs to insert line break after topmost OR operators of condition.
Remarks
Applied to SQLBuilderConditionFormat.NewLineAfter property.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLBuilderConditionFormatNL

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SybaseServerVersion Enumeration

SybaseServerVersion Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SybaseServerVersion Enumeration
Sybase Server types enumeration.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum SybaseServerVersion
   Inherits System.Enum
'Usage

Dim instance As SybaseServerVersion
public enum SybaseServerVersion : System.Enum
__value public enum SybaseServerVersion : public System.Enum
Members
Member | Description
SybaseASA | Sybase Adaptive Server Anywhere
SybaseASE | Sybase Adaptive Server Enterprise
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.SybaseServerVersion

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


UserMessageId Enumeration

UserMessageId Enumeration
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : UserMessageId Enumeration
Lists possible situations that require to warn the user.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Enum UserMessageId
   Inherits System.Enum
'Usage

Dim instance As UserMessageId
public enum UserMessageId : System.Enum
__value public enum UserMessageId : public System.Enum
Members
Member | Description
ColumnNameAlreadyUsed | Notifies that the specified alias matches the name of another column. Multiple columns with same name in a sub-query may lead to inconsistence in the calling sub-query.
DeletingAliasCausesConflict | Notifies that deleting an alias leads to matching this column name to the name of another column. Multiple columns with same name in a sub-query may lead to inconsistence in the calling sub-query.
SelectingExpressionCausesConflict | Notifies that adding the expression leads to the same named columns in the sub-query. Multiple columns with same name in a sub-query may lead to inconsistence in the calling sub-query.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveDatabaseSoftware.ActiveQueryBuilder.UserMessageId

Requirements

See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


IPlusButton Interface

IPlusButton Interface
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : IPlusButton Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Interface IPlusButton
'Usage

Dim instance As IPlusButton
public interface IPlusButton
public __gc __interface IPlusButton
Requirements

See Also

Reference

IPlusButton Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


IPlusButton Interface Members

IPlusButton Interface Members
Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : IPlusButton Interface

The following tables list the members exposed by IPlusButton.

Public Methods
 | Name | Description
Method | GetControl |
Top
See Also

Reference

IPlusButton Interface
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


IPlusButton Interface Methods

IPlusButton Interface Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : IPlusButton Interface

For a list of all members of this type, see IPlusButton members.

Public Methods
 | Name | Description
Method | GetControl |
Top
See Also

Reference

IPlusButton Interface
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


GetControl Method

GetControl Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > IPlusButton Interface : GetControl Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Function GetControl() As System.Windows.Forms.Control
'Usage

Dim instance As IPlusButton
Dim value As System.Windows.Forms.Control

value = instance.GetControl()
System.Windows.Forms.Control GetControl()
System.Windows.Forms.Control* GetControl();
Requirements

See Also

Reference

IPlusButton Interface
IPlusButton Members


ActiveDatabaseSoftware.AdvantageMetadataProvider2 Assembly

ActiveDatabaseSoftware.AdvantageMetadataProvider2 Assembly
Namespaces
Namespace | Description
ActiveDatabaseSoftware.ActiveQueryBuilder | Active Query Builder main namespace.


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.AdvantageMetadataProvider2)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.AdvantageMetadataProvider2)
Inheritance Hierarchy
Active Query Builder main namespace.
Classes
 | Class | Description
Class | AdvantageMetadataProvider | Metadata Provider for Advantage DB.
See Also

Reference

ActiveDatabaseSoftware.AdvantageMetadataProvider2 Assembly


AdvantageMetadataProvider Class

AdvantageMetadataProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AdvantageMetadataProvider Class
Metadata Provider for Advantage DB.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class AdvantageMetadataProvider
   Inherits BaseMetadataProvider
'Usage

Dim instance As AdvantageMetadataProvider
public class AdvantageMetadataProvider : BaseMetadataProvider
public __gc class AdvantageMetadataProvider : public BaseMetadataProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.AdvantageMetadataProvider

Requirements

See Also

Reference

AdvantageMetadataProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AdvantageMetadataProvider Class Members

AdvantageMetadataProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AdvantageMetadataProvider Class

The following tables list the members exposed by AdvantageMetadataProvider.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

AdvantageMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AdvantageMetadataProvider Class Properties

AdvantageMetadataProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AdvantageMetadataProvider Class

For a list of all members of this type, see AdvantageMetadataProvider members.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

AdvantageMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Connection Property (AdvantageMetadataProvider)

Connection Property (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : Connection Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property Connection As System.Data.IDbConnection
'Usage

Dim instance As AdvantageMetadataProvider
Dim value As System.Data.IDbConnection

instance.Connection = value

value = instance.Connection
public override System.Data.IDbConnection Connection {get; set;}
public: __property System.Data.IDbConnection* get_Connection() override;
public: __property void set_Connection(
   System.Data.IDbConnection* value
) override;
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members
Base Implementation in Connection


ActiveDatabaseSoftware.DB2MetadataProvider2 Assembly

ActiveDatabaseSoftware.DB2MetadataProvider2 Assembly
Namespaces
Namespace | Description
ActiveDatabaseSoftware.ActiveQueryBuilder | Active Query Builder main namespace.


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.DB2MetadataProvider2)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.DB2MetadataProvider2)
Inheritance Hierarchy
Active Query Builder main namespace.
Classes
 | Class | Description
Class | DB2MetadataProvider | Metadata Provider for IBM DB2.
See Also

Reference

ActiveDatabaseSoftware.DB2MetadataProvider2 Assembly


DB2MetadataProvider Class

DB2MetadataProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DB2MetadataProvider Class
Metadata Provider for IBM DB2.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class DB2MetadataProvider
   Inherits BaseMetadataProvider
'Usage

Dim instance As DB2MetadataProvider
public class DB2MetadataProvider : BaseMetadataProvider
public __gc class DB2MetadataProvider : public BaseMetadataProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.DB2MetadataProvider

Requirements

See Also

Reference

DB2MetadataProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


DB2MetadataProvider Class Members

DB2MetadataProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DB2MetadataProvider Class

The following tables list the members exposed by DB2MetadataProvider.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

DB2MetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


DB2MetadataProvider Class Properties

DB2MetadataProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DB2MetadataProvider Class

For a list of all members of this type, see DB2MetadataProvider members.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

DB2MetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Connection Property (DB2MetadataProvider)

Connection Property (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : Connection Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property Connection As System.Data.IDbConnection
'Usage

Dim instance As DB2MetadataProvider
Dim value As System.Data.IDbConnection

instance.Connection = value

value = instance.Connection
public override System.Data.IDbConnection Connection {get; set;}
public: __property System.Data.IDbConnection* get_Connection() override;
public: __property void set_Connection(
   System.Data.IDbConnection* value
) override;
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members
Base Implementation in Connection


ActiveDatabaseSoftware.EventMetadataProvider2 Assembly

ActiveDatabaseSoftware.EventMetadataProvider2 Assembly
Namespaces
Namespace | Description
ActiveDatabaseSoftware.ActiveQueryBuilder | Active Query Builder main namespace.


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.EventMetadataProvider2)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.EventMetadataProvider2)
Inheritance Hierarchy
Active Query Builder main namespace.
Classes
 | Class | Description
Class | EventMetadataProvider | Metadata provider to work with unsupported .NET data providers or custom data sources.
See Also

Reference

ActiveDatabaseSoftware.EventMetadataProvider2 Assembly


EventMetadataProvider Class

EventMetadataProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : EventMetadataProvider Class
Metadata provider to work with unsupported .NET data providers or custom data sources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class EventMetadataProvider
   Inherits BaseMetadataProvider
'Usage

Dim instance As EventMetadataProvider
public class EventMetadataProvider : BaseMetadataProvider
public __gc class EventMetadataProvider : public BaseMetadataProvider
Remarks

Use this event on working with unsupported .NET data provider which is capable to execute SQL queries and to return the IDataReader interface in result.

See ExecSQL event for details.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.EventMetadataProvider

Requirements

See Also

Reference

EventMetadataProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


EventMetadataProvider Class Members

EventMetadataProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : EventMetadataProvider Class

The following tables list the members exposed by EventMetadataProvider.

Public Events
 | Name | Description
Public Event | ExecSQL | Invoked when the Event Metadata Provider is requested to execute the SQL statement.
Top
See Also

Reference

EventMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


EventMetadataProvider Class Events

EventMetadataProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : EventMetadataProvider Class

For a list of all members of this type, see EventMetadataProvider members.

Public Events
 | Name | Description
Public Event | ExecSQL | Invoked when the Event Metadata Provider is requested to execute the SQL statement.
Top
See Also

Reference

EventMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


ExecSQL Event

ExecSQL Event
Example

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : ExecSQL Event
Invoked when the Event Metadata Provider is requested to execute the SQL statement.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ExecSQL As ExecSQLEventHandler
'Usage

Dim instance As EventMetadataProvider
Dim handler As ExecSQLEventHandler

AddHandler instance.ExecSQL, handler
public event ExecSQLEventHandler ExecSQL
public: __event ExecSQLEventHandler* ExecSQL
Remarks
The metadataProvider parameter refers to the metadata provider invoked the event. The sql parameter contains the query to be executed. The schemaOnly flag indicates that there's no need for data retrieval for this query. Return the IDataReader interface through the dataReader parameter.
Example
  • C#
private void EventMetadataProvider_ExecSQL(BaseMetadataProvider metadataProvider, string sql, bool schemaOnly, out IDataReader dataReader)
{
    dataReader = null;

    if (dbConnection != null)
    {
        IDbCommand command = dbConnection.CreateCommand();
        command.CommandText = sql;
        dataReader = command.ExecuteReader();
    }
}
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


ActiveDatabaseSoftware.FirebirdMetadataProvider2 Assembly

ActiveDatabaseSoftware.FirebirdMetadataProvider2 Assembly
Namespaces
Namespace | Description
ActiveDatabaseSoftware.ActiveQueryBuilder | Active Query Builder main namespace.


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.FirebirdMetadataProvider2)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.FirebirdMetadataProvider2)
Inheritance Hierarchy
Active Query Builder main namespace.
Classes
 | Class | Description
Class | FirebirdMetadataProvider | Metadata Provider for Firebird databases.
See Also

Reference

ActiveDatabaseSoftware.FirebirdMetadataProvider2 Assembly


FirebirdMetadataProvider Class

FirebirdMetadataProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FirebirdMetadataProvider Class
Metadata Provider for Firebird databases.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class FirebirdMetadataProvider
   Inherits BaseMetadataProvider
'Usage

Dim instance As FirebirdMetadataProvider
public class FirebirdMetadataProvider : BaseMetadataProvider
public __gc class FirebirdMetadataProvider : public BaseMetadataProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.FirebirdMetadataProvider

Requirements

See Also

Reference

FirebirdMetadataProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


FirebirdMetadataProvider Class Members

FirebirdMetadataProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FirebirdMetadataProvider Class

The following tables list the members exposed by FirebirdMetadataProvider.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
Public Methods
 | Name | Description
Public Method | GetMetadataProviderDescription | Overridden.
Top
See Also

Reference

FirebirdMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


FirebirdMetadataProvider Class Methods

FirebirdMetadataProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FirebirdMetadataProvider Class

For a list of all members of this type, see FirebirdMetadataProvider members.

Public Methods
 | Name | Description
Public Method | GetMetadataProviderDescription | Overridden.
Top
See Also

Reference

FirebirdMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


GetMetadataProviderDescription Method (FirebirdMetadataProvider)

GetMetadataProviderDescription Method (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : GetMetadataProviderDescription Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Function GetMetadataProviderDescription() As System.String
'Usage

Dim instance As FirebirdMetadataProvider
Dim value As System.String

value = instance.GetMetadataProviderDescription()
public override System.string GetMetadataProviderDescription()
public: System.string* GetMetadataProviderDescription(); override
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members
Base Implementation in GetMetadataProviderDescription


FirebirdMetadataProvider Class Properties

FirebirdMetadataProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FirebirdMetadataProvider Class

For a list of all members of this type, see FirebirdMetadataProvider members.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

FirebirdMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Connection Property (FirebirdMetadataProvider)

Connection Property (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : Connection Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property Connection As System.Data.IDbConnection
'Usage

Dim instance As FirebirdMetadataProvider
Dim value As System.Data.IDbConnection

instance.Connection = value

value = instance.Connection
public override System.Data.IDbConnection Connection {get; set;}
public: __property System.Data.IDbConnection* get_Connection() override;
public: __property void set_Connection(
   System.Data.IDbConnection* value
) override;
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members
Base Implementation in Connection


ActiveDatabaseSoftware.InformixMetadataProvider2 Assembly

ActiveDatabaseSoftware.InformixMetadataProvider2 Assembly
Namespaces
Namespace | Description
ActiveDatabaseSoftware.ActiveQueryBuilder | Active Query Builder main namespace.


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.InformixMetadataProvider2)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.InformixMetadataProvider2)
Inheritance Hierarchy
Active Query Builder main namespace.
Classes
 | Class | Description
Class | InformixMetadataProvider | Metadata Provider for Informix Database Server.
See Also

Reference

ActiveDatabaseSoftware.InformixMetadataProvider2 Assembly


InformixMetadataProvider Class

InformixMetadataProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : InformixMetadataProvider Class
Metadata Provider for Informix Database Server.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class InformixMetadataProvider
   Inherits BaseMetadataProvider
'Usage

Dim instance As InformixMetadataProvider
public class InformixMetadataProvider : BaseMetadataProvider
public __gc class InformixMetadataProvider : public BaseMetadataProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.InformixMetadataProvider

Requirements

See Also

Reference

InformixMetadataProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


InformixMetadataProvider Class Members

InformixMetadataProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : InformixMetadataProvider Class

The following tables list the members exposed by InformixMetadataProvider.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

InformixMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


InformixMetadataProvider Class Properties

InformixMetadataProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : InformixMetadataProvider Class

For a list of all members of this type, see InformixMetadataProvider members.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

InformixMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Connection Property (InformixMetadataProvider)

Connection Property (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : Connection Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property Connection As System.Data.IDbConnection
'Usage

Dim instance As InformixMetadataProvider
Dim value As System.Data.IDbConnection

instance.Connection = value

value = instance.Connection
public override System.Data.IDbConnection Connection {get; set;}
public: __property System.Data.IDbConnection* get_Connection() override;
public: __property void set_Connection(
   System.Data.IDbConnection* value
) override;
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members
Base Implementation in Connection


ActiveDatabaseSoftware.MSSQLCEMetadataProvider2 Assembly

ActiveDatabaseSoftware.MSSQLCEMetadataProvider2 Assembly
Namespaces
Namespace | Description
ActiveDatabaseSoftware.ActiveQueryBuilder | Active Query Builder main namespace.


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.MSSQLCEMetadataProvider2)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.MSSQLCEMetadataProvider2)
Inheritance Hierarchy
Active Query Builder main namespace.
Classes
 | Class | Description
Class | MSSQLCEMetadataProvider | Metadata Provider for Microsoft SQL Server Mobile.
See Also

Reference

ActiveDatabaseSoftware.MSSQLCEMetadataProvider2 Assembly


MSSQLCEMetadataProvider Class

MSSQLCEMetadataProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLCEMetadataProvider Class
Metadata Provider for Microsoft SQL Server Mobile.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MSSQLCEMetadataProvider
   Inherits BaseMetadataProvider
'Usage

Dim instance As MSSQLCEMetadataProvider
public class MSSQLCEMetadataProvider : BaseMetadataProvider
public __gc class MSSQLCEMetadataProvider : public BaseMetadataProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLCEMetadataProvider

Requirements

See Also

Reference

MSSQLCEMetadataProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MSSQLCEMetadataProvider Class Members

MSSQLCEMetadataProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLCEMetadataProvider Class

The following tables list the members exposed by MSSQLCEMetadataProvider.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

MSSQLCEMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MSSQLCEMetadataProvider Class Properties

MSSQLCEMetadataProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLCEMetadataProvider Class

For a list of all members of this type, see MSSQLCEMetadataProvider members.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

MSSQLCEMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Connection Property (MSSQLCEMetadataProvider)

Connection Property (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : Connection Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property Connection As System.Data.IDbConnection
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim value As System.Data.IDbConnection

instance.Connection = value

value = instance.Connection
public override System.Data.IDbConnection Connection {get; set;}
public: __property System.Data.IDbConnection* get_Connection() override;
public: __property void set_Connection(
   System.Data.IDbConnection* value
) override;
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members
Base Implementation in Connection


ActiveDatabaseSoftware.MSSQLMetadataProvider2 Assembly

ActiveDatabaseSoftware.MSSQLMetadataProvider2 Assembly
Namespaces
Namespace | Description
ActiveDatabaseSoftware.ActiveQueryBuilder | Active Query Builder main namespace.


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.MSSQLMetadataProvider2)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.MSSQLMetadataProvider2)
Inheritance Hierarchy
Active Query Builder main namespace.
Classes
 | Class | Description
Class | MSSQLMetadataProvider | Metadata Provider for Microsoft SQL Server.
See Also

Reference

ActiveDatabaseSoftware.MSSQLMetadataProvider2 Assembly


MSSQLMetadataProvider Class

MSSQLMetadataProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLMetadataProvider Class
Metadata Provider for Microsoft SQL Server.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MSSQLMetadataProvider
   Inherits BaseMetadataProvider
'Usage

Dim instance As MSSQLMetadataProvider
public class MSSQLMetadataProvider : BaseMetadataProvider
public __gc class MSSQLMetadataProvider : public BaseMetadataProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLMetadataProvider

Requirements

See Also

Reference

MSSQLMetadataProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MSSQLMetadataProvider Class Members

MSSQLMetadataProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLMetadataProvider Class

The following tables list the members exposed by MSSQLMetadataProvider.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

MSSQLMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MSSQLMetadataProvider Class Properties

MSSQLMetadataProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLMetadataProvider Class

For a list of all members of this type, see MSSQLMetadataProvider members.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

MSSQLMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Connection Property (MSSQLMetadataProvider)

Connection Property (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : Connection Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property Connection As System.Data.IDbConnection
'Usage

Dim instance As MSSQLMetadataProvider
Dim value As System.Data.IDbConnection

instance.Connection = value

value = instance.Connection
public override System.Data.IDbConnection Connection {get; set;}
public: __property System.Data.IDbConnection* get_Connection() override;
public: __property void set_Connection(
   System.Data.IDbConnection* value
) override;
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members
Base Implementation in Connection


ActiveDatabaseSoftware.MySQLMetadataProvider2 Assembly

ActiveDatabaseSoftware.MySQLMetadataProvider2 Assembly
Namespaces
Namespace | Description
ActiveDatabaseSoftware.ActiveQueryBuilder | Active Query Builder main namespace.


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.MySQLMetadataProvider2)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.MySQLMetadataProvider2)
Inheritance Hierarchy
Active Query Builder main namespace.
Classes
 | Class | Description
Class | MySQLMetadataProvider | Metadata Provider for MySQL Server.
See Also

Reference

ActiveDatabaseSoftware.MySQLMetadataProvider2 Assembly


MySQLMetadataProvider Class

MySQLMetadataProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MySQLMetadataProvider Class
Metadata Provider for MySQL Server.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class MySQLMetadataProvider
   Inherits BaseMetadataProvider
'Usage

Dim instance As MySQLMetadataProvider
public class MySQLMetadataProvider : BaseMetadataProvider
public __gc class MySQLMetadataProvider : public BaseMetadataProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MySQLMetadataProvider

Requirements

See Also

Reference

MySQLMetadataProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MySQLMetadataProvider Class Members

MySQLMetadataProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MySQLMetadataProvider Class

The following tables list the members exposed by MySQLMetadataProvider.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

MySQLMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MySQLMetadataProvider Class Properties

MySQLMetadataProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MySQLMetadataProvider Class

For a list of all members of this type, see MySQLMetadataProvider members.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

MySQLMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Connection Property (MySQLMetadataProvider)

Connection Property (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : Connection Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property Connection As System.Data.IDbConnection
'Usage

Dim instance As MySQLMetadataProvider
Dim value As System.Data.IDbConnection

instance.Connection = value

value = instance.Connection
public override System.Data.IDbConnection Connection {get; set;}
public: __property System.Data.IDbConnection* get_Connection() override;
public: __property void set_Connection(
   System.Data.IDbConnection* value
) override;
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members
Base Implementation in Connection


ActiveDatabaseSoftware.ODBCMetadataProvider2 Assembly

ActiveDatabaseSoftware.ODBCMetadataProvider2 Assembly
Namespaces
Namespace | Description
ActiveDatabaseSoftware.ActiveQueryBuilder | Active Query Builder main namespace.


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.ODBCMetadataProvider2)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.ODBCMetadataProvider2)
Inheritance Hierarchy
Active Query Builder main namespace.
Classes
 | Class | Description
Class | ODBCMetadataProvider | Metadata Provider for ODBC Data Sources.
See Also

Reference

ActiveDatabaseSoftware.ODBCMetadataProvider2 Assembly


ODBCMetadataProvider Class

ODBCMetadataProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : ODBCMetadataProvider Class
Metadata Provider for ODBC Data Sources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class ODBCMetadataProvider
   Inherits BaseMetadataProvider
'Usage

Dim instance As ODBCMetadataProvider
public class ODBCMetadataProvider : BaseMetadataProvider
public __gc class ODBCMetadataProvider : public BaseMetadataProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.ODBCMetadataProvider

Requirements

See Also

Reference

ODBCMetadataProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


ODBCMetadataProvider Class Members

ODBCMetadataProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : ODBCMetadataProvider Class

The following tables list the members exposed by ODBCMetadataProvider.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

ODBCMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


ODBCMetadataProvider Class Properties

ODBCMetadataProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : ODBCMetadataProvider Class

For a list of all members of this type, see ODBCMetadataProvider members.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

ODBCMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Connection Property (ODBCMetadataProvider)

Connection Property (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : Connection Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property Connection As System.Data.IDbConnection
'Usage

Dim instance As ODBCMetadataProvider
Dim value As System.Data.IDbConnection

instance.Connection = value

value = instance.Connection
public override System.Data.IDbConnection Connection {get; set;}
public: __property System.Data.IDbConnection* get_Connection() override;
public: __property void set_Connection(
   System.Data.IDbConnection* value
) override;
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members
Base Implementation in Connection


ActiveDatabaseSoftware.OLEDBMetadataProvider2 Assembly

ActiveDatabaseSoftware.OLEDBMetadataProvider2 Assembly
Namespaces
Namespace | Description
ActiveDatabaseSoftware.ActiveQueryBuilder | Active Query Builder main namespace.


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.OLEDBMetadataProvider2)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.OLEDBMetadataProvider2)
Inheritance Hierarchy
Active Query Builder main namespace.
Classes
 | Class | Description
Class | OLEDBMetadataProvider | Metadata Provider for OLE DB Data Sources.
See Also

Reference

ActiveDatabaseSoftware.OLEDBMetadataProvider2 Assembly


OLEDBMetadataProvider Class

OLEDBMetadataProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : OLEDBMetadataProvider Class
Metadata Provider for OLE DB Data Sources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class OLEDBMetadataProvider
   Inherits BaseMetadataProvider
'Usage

Dim instance As OLEDBMetadataProvider
public class OLEDBMetadataProvider : BaseMetadataProvider
public __gc class OLEDBMetadataProvider : public BaseMetadataProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.OLEDBMetadataProvider

Requirements

See Also

Reference

OLEDBMetadataProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


OLEDBMetadataProvider Class Members

OLEDBMetadataProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : OLEDBMetadataProvider Class

The following tables list the members exposed by OLEDBMetadataProvider.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

OLEDBMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


OLEDBMetadataProvider Class Properties

OLEDBMetadataProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : OLEDBMetadataProvider Class

For a list of all members of this type, see OLEDBMetadataProvider members.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

OLEDBMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Connection Property (OLEDBMetadataProvider)

Connection Property (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : Connection Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property Connection As System.Data.IDbConnection
'Usage

Dim instance As OLEDBMetadataProvider
Dim value As System.Data.IDbConnection

instance.Connection = value

value = instance.Connection
public override System.Data.IDbConnection Connection {get; set;}
public: __property System.Data.IDbConnection* get_Connection() override;
public: __property void set_Connection(
   System.Data.IDbConnection* value
) override;
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members
Base Implementation in Connection


ActiveDatabaseSoftware.OracleMetadataProvider2 Assembly

ActiveDatabaseSoftware.OracleMetadataProvider2 Assembly
Namespaces
Namespace | Description
ActiveDatabaseSoftware.ActiveQueryBuilder | Active Query Builder main namespace.


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.OracleMetadataProvider2)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.OracleMetadataProvider2)
Inheritance Hierarchy
Active Query Builder main namespace.
Classes
 | Class | Description
Class | OracleMetadataProvider | Metadata Provider for Oracle Database through System.Data.OracleClient (Microsoft).
See Also

Reference

ActiveDatabaseSoftware.OracleMetadataProvider2 Assembly


OracleMetadataProvider Class

OracleMetadataProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : OracleMetadataProvider Class
Metadata Provider for Oracle Database through System.Data.OracleClient (Microsoft).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class OracleMetadataProvider
   Inherits BaseMetadataProvider
'Usage

Dim instance As OracleMetadataProvider
public class OracleMetadataProvider : BaseMetadataProvider
public __gc class OracleMetadataProvider : public BaseMetadataProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleMetadataProvider

Requirements

See Also

Reference

OracleMetadataProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
Metadata Provider for Oracle Database through Oracle.DataAccess.Client (Oracle)


OracleMetadataProvider Class Members

OracleMetadataProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : OracleMetadataProvider Class

The following tables list the members exposed by OracleMetadataProvider.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

OracleMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
Metadata Provider for Oracle Database through Oracle.DataAccess.Client (Oracle)


OracleMetadataProvider Class Properties

OracleMetadataProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : OracleMetadataProvider Class

For a list of all members of this type, see OracleMetadataProvider members.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

OracleMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
Metadata Provider for Oracle Database through Oracle.DataAccess.Client (Oracle)


Connection Property (OracleMetadataProvider)

Connection Property (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : Connection Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property Connection As System.Data.IDbConnection
'Usage

Dim instance As OracleMetadataProvider
Dim value As System.Data.IDbConnection

instance.Connection = value

value = instance.Connection
public override System.Data.IDbConnection Connection {get; set;}
public: __property System.Data.IDbConnection* get_Connection() override;
public: __property void set_Connection(
   System.Data.IDbConnection* value
) override;
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members
Base Implementation in Connection


ActiveDatabaseSoftware.OracleNativeMetadataProvider2 Assembly

ActiveDatabaseSoftware.OracleNativeMetadataProvider2 Assembly
Namespaces
Namespace | Description
ActiveDatabaseSoftware.ActiveQueryBuilder | Active Query Builder main namespace.


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.OracleNativeMetadataProvider2)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.OracleNativeMetadataProvider2)
Inheritance Hierarchy
Active Query Builder main namespace.
Classes
 | Class | Description
Class | OracleNativeMetadataProvider | Metadata Provider for Oracle Database through Oracle.DataAccess.Client (Oracle).
See Also

Reference

ActiveDatabaseSoftware.OracleNativeMetadataProvider2 Assembly


OracleNativeMetadataProvider Class

OracleNativeMetadataProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : OracleNativeMetadataProvider Class
Metadata Provider for Oracle Database through Oracle.DataAccess.Client (Oracle).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class OracleNativeMetadataProvider
   Inherits BaseMetadataProvider
'Usage

Dim instance As OracleNativeMetadataProvider
public class OracleNativeMetadataProvider : BaseMetadataProvider
public __gc class OracleNativeMetadataProvider : public BaseMetadataProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleNativeMetadataProvider

Requirements

See Also

Reference

OracleNativeMetadataProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
Metadata Provider for Oracle Database through System.Data.OracleClient (Microsoft)


OracleNativeMetadataProvider Class Members

OracleNativeMetadataProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : OracleNativeMetadataProvider Class

The following tables list the members exposed by OracleNativeMetadataProvider.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

OracleNativeMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
Metadata Provider for Oracle Database through System.Data.OracleClient (Microsoft)


OracleNativeMetadataProvider Class Properties

OracleNativeMetadataProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : OracleNativeMetadataProvider Class

For a list of all members of this type, see OracleNativeMetadataProvider members.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

OracleNativeMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
Metadata Provider for Oracle Database through System.Data.OracleClient (Microsoft)


Connection Property (OracleNativeMetadataProvider)

Connection Property (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : Connection Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property Connection As System.Data.IDbConnection
'Usage

Dim instance As OracleNativeMetadataProvider
Dim value As System.Data.IDbConnection

instance.Connection = value

value = instance.Connection
public override System.Data.IDbConnection Connection {get; set;}
public: __property System.Data.IDbConnection* get_Connection() override;
public: __property void set_Connection(
   System.Data.IDbConnection* value
) override;
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members
Base Implementation in Connection


ActiveDatabaseSoftware.PostgreSQLMetadataProvider2 Assembly

ActiveDatabaseSoftware.PostgreSQLMetadataProvider2 Assembly
Namespaces
Namespace | Description
ActiveDatabaseSoftware.ActiveQueryBuilder | Active Query Builder main namespace.


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.PostgreSQLMetadataProvider2)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.PostgreSQLMetadataProvider2)
Inheritance Hierarchy
Active Query Builder main namespace.
Classes
 | Class | Description
Class | PostgreSQLMetadataProvider | Metadata Provider for PostgreSQL databases.
See Also

Reference

ActiveDatabaseSoftware.PostgreSQLMetadataProvider2 Assembly


PostgreSQLMetadataProvider Class

PostgreSQLMetadataProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : PostgreSQLMetadataProvider Class
Metadata Provider for PostgreSQL databases.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class PostgreSQLMetadataProvider
   Inherits BaseMetadataProvider
'Usage

Dim instance As PostgreSQLMetadataProvider
public class PostgreSQLMetadataProvider : BaseMetadataProvider
public __gc class PostgreSQLMetadataProvider : public BaseMetadataProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.PostgreSQLMetadataProvider

Requirements

See Also

Reference

PostgreSQLMetadataProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


PostgreSQLMetadataProvider Class Members

PostgreSQLMetadataProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : PostgreSQLMetadataProvider Class

The following tables list the members exposed by PostgreSQLMetadataProvider.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

PostgreSQLMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


PostgreSQLMetadataProvider Class Properties

PostgreSQLMetadataProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : PostgreSQLMetadataProvider Class

For a list of all members of this type, see PostgreSQLMetadataProvider members.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

PostgreSQLMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Connection Property (PostgreSQLMetadataProvider)

Connection Property (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : Connection Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property Connection As System.Data.IDbConnection
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim value As System.Data.IDbConnection

instance.Connection = value

value = instance.Connection
public override System.Data.IDbConnection Connection {get; set;}
public: __property System.Data.IDbConnection* get_Connection() override;
public: __property void set_Connection(
   System.Data.IDbConnection* value
) override;
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members
Base Implementation in Connection


ActiveDatabaseSoftware.SybaseMetadataProvider2 Assembly

ActiveDatabaseSoftware.SybaseMetadataProvider2 Assembly
Namespaces
Namespace | Description
ActiveDatabaseSoftware.ActiveQueryBuilder | Active Query Builder main namespace.


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.SybaseMetadataProvider2)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.SybaseMetadataProvider2)
Inheritance Hierarchy
Active Query Builder main namespace.
Classes
 | Class | Description
Class | SybaseMetadataProvider | Metadata Provider for Sybase ASA.
See Also

Reference

ActiveDatabaseSoftware.SybaseMetadataProvider2 Assembly


SybaseMetadataProvider Class

SybaseMetadataProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SybaseMetadataProvider Class
Metadata Provider for Sybase ASA.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class SybaseMetadataProvider
   Inherits BaseMetadataProvider
'Usage

Dim instance As SybaseMetadataProvider
public class SybaseMetadataProvider : BaseMetadataProvider
public __gc class SybaseMetadataProvider : public BaseMetadataProvider
Remarks
Working with Sybase ASE, use the Universal Metadata Provider.
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.SybaseMetadataProvider

Requirements

See Also

Reference

SybaseMetadataProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SybaseMetadataProvider Class Members

SybaseMetadataProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SybaseMetadataProvider Class

The following tables list the members exposed by SybaseMetadataProvider.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

SybaseMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SybaseMetadataProvider Class Properties

SybaseMetadataProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SybaseMetadataProvider Class

For a list of all members of this type, see SybaseMetadataProvider members.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

SybaseMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Connection Property (SybaseMetadataProvider)

Connection Property (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : Connection Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property Connection As System.Data.IDbConnection
'Usage

Dim instance As SybaseMetadataProvider
Dim value As System.Data.IDbConnection

instance.Connection = value

value = instance.Connection
public override System.Data.IDbConnection Connection {get; set;}
public: __property System.Data.IDbConnection* get_Connection() override;
public: __property void set_Connection(
   System.Data.IDbConnection* value
) override;
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members
Base Implementation in Connection


ActiveDatabaseSoftware.UniversalMetadataProvider2 Assembly

ActiveDatabaseSoftware.UniversalMetadataProvider2 Assembly
Namespaces
Namespace | Description
ActiveDatabaseSoftware.ActiveQueryBuilder | Active Query Builder main namespace.


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.UniversalMetadataProvider2)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.UniversalMetadataProvider2)
Inheritance Hierarchy
Active Query Builder main namespace.
Classes
 | Class | Description
Class | UniversalMetadataProvider | Metadata Provider for generic .NET data provider (IDbConnection interface).
See Also

Reference

ActiveDatabaseSoftware.UniversalMetadataProvider2 Assembly


UniversalMetadataProvider Class

UniversalMetadataProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : UniversalMetadataProvider Class
Metadata Provider for generic .NET data provider (IDbConnection interface).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class UniversalMetadataProvider
   Inherits BaseMetadataProvider
'Usage

Dim instance As UniversalMetadataProvider
public class UniversalMetadataProvider : BaseMetadataProvider
public __gc class UniversalMetadataProvider : public BaseMetadataProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.UniversalMetadataProvider

Requirements

See Also

Reference

UniversalMetadataProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


UniversalMetadataProvider Class Members

UniversalMetadataProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : UniversalMetadataProvider Class

The following tables list the members exposed by UniversalMetadataProvider.

Public Properties
 | Name | Description
Public Property | Connection | Overridden. Refers to the object that implements the IDbConnection interface.
Top
See Also

Reference

UniversalMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


UniversalMetadataProvider Class Properties

UniversalMetadataProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : UniversalMetadataProvider Class

For a list of all members of this type, see UniversalMetadataProvider members.

Public Properties
 | Name | Description
Public Property | Connection | Overridden. Refers to the object that implements the IDbConnection interface.
Top
See Also

Reference

UniversalMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Connection Property (UniversalMetadataProvider)

Connection Property (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : Connection Property
Refers to the object that implements the IDbConnection interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property Connection As System.Data.IDbConnection
'Usage

Dim instance As UniversalMetadataProvider
Dim value As System.Data.IDbConnection

instance.Connection = value

value = instance.Connection
public override System.Data.IDbConnection Connection {get; set;}
public: __property System.Data.IDbConnection* get_Connection() override;
public: __property void set_Connection(
   System.Data.IDbConnection* value
) override;
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members
Base Implementation in Connection


ActiveDatabaseSoftware.VistaDB4MetadataProvider2 Assembly

ActiveDatabaseSoftware.VistaDB4MetadataProvider2 Assembly
Namespaces
Namespace | Description
ActiveDatabaseSoftware.ActiveQueryBuilder | Active Query Builder main namespace.


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.VistaDB4MetadataProvider2)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.VistaDB4MetadataProvider2)
Inheritance Hierarchy
Active Query Builder main namespace.
Classes
 | Class | Description
Class | VistaDB4MetadataProvider | Metadata Provider for VistaDB 4.
See Also

Reference

ActiveDatabaseSoftware.VistaDB4MetadataProvider2 Assembly


VistaDB4MetadataProvider Class

VistaDB4MetadataProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : VistaDB4MetadataProvider Class
Metadata Provider for VistaDB 4.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class VistaDB4MetadataProvider
   Inherits BaseMetadataProvider
'Usage

Dim instance As VistaDB4MetadataProvider
public class VistaDB4MetadataProvider : BaseMetadataProvider
public __gc class VistaDB4MetadataProvider : public BaseMetadataProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.VistaDB4MetadataProvider

Requirements

See Also

Reference

VistaDB4MetadataProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


VistaDB4MetadataProvider Class Members

VistaDB4MetadataProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : VistaDB4MetadataProvider Class

The following tables list the members exposed by VistaDB4MetadataProvider.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

VistaDB4MetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


VistaDB4MetadataProvider Class Properties

VistaDB4MetadataProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : VistaDB4MetadataProvider Class

For a list of all members of this type, see VistaDB4MetadataProvider members.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

VistaDB4MetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Connection Property (VistaDB4MetadataProvider)

Connection Property (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : Connection Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property Connection As System.Data.IDbConnection
'Usage

Dim instance As VistaDB4MetadataProvider
Dim value As System.Data.IDbConnection

instance.Connection = value

value = instance.Connection
public override System.Data.IDbConnection Connection {get; set;}
public: __property System.Data.IDbConnection* get_Connection() override;
public: __property void set_Connection(
   System.Data.IDbConnection* value
) override;
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members
Base Implementation in Connection


ActiveDatabaseSoftware.VistaDBMetadataProvider2 Assembly

ActiveDatabaseSoftware.VistaDBMetadataProvider2 Assembly
Namespaces
Namespace | Description
ActiveDatabaseSoftware.ActiveQueryBuilder | Active Query Builder main namespace.


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.VistaDBMetadataProvider2)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.VistaDBMetadataProvider2)
Inheritance Hierarchy
Active Query Builder main namespace.
Classes
 | Class | Description
Class | VistaDBMetadataProvider | Metadata Provider for VistaDB 3.
See Also

Reference

ActiveDatabaseSoftware.VistaDBMetadataProvider2 Assembly


VistaDBMetadataProvider Class

VistaDBMetadataProvider Class
Members

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : VistaDBMetadataProvider Class
Metadata Provider for VistaDB 3.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Class VistaDBMetadataProvider
   Inherits BaseMetadataProvider
'Usage

Dim instance As VistaDBMetadataProvider
public class VistaDBMetadataProvider : BaseMetadataProvider
public __gc class VistaDBMetadataProvider : public BaseMetadataProvider
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.VistaDBMetadataProvider

Requirements

See Also

Reference

VistaDBMetadataProvider Members
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
VistaDB 4 Metadata Provider


VistaDBMetadataProvider Class Members

VistaDBMetadataProvider Class Members
Properties Methods Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : VistaDBMetadataProvider Class

The following tables list the members exposed by VistaDBMetadataProvider.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

VistaDBMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
VistaDB 4 Metadata Provider


VistaDBMetadataProvider Class Properties

VistaDBMetadataProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : VistaDBMetadataProvider Class

For a list of all members of this type, see VistaDBMetadataProvider members.

Public Properties
 | Name | Description
Public Property | Connection | Overridden.
Top
See Also

Reference

VistaDBMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
VistaDB 4 Metadata Provider


Connection Property (VistaDBMetadataProvider)

Connection Property (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : Connection Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overrides Property Connection As System.Data.IDbConnection
'Usage

Dim instance As VistaDBMetadataProvider
Dim value As System.Data.IDbConnection

instance.Connection = value

value = instance.Connection
public override System.Data.IDbConnection Connection {get; set;}
public: __property System.Data.IDbConnection* get_Connection() override;
public: __property void set_Connection(
   System.Data.IDbConnection* value
) override;
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members
Base Implementation in Connection


AstExtender Class Methods

AstExtender Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AstExtender Class

For a list of all members of this type, see AstExtender members.

See Also

Reference

AstExtender Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AstExtender Class Properties

AstExtender Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AstExtender Class

For a list of all members of this type, see AstExtender members.

See Also

Reference

AstExtender Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AstToken Class Methods

AstToken Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AstToken Class

For a list of all members of this type, see AstToken members.

See Also

Reference

AstToken Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AstTokenIdentifier Class Methods

AstTokenIdentifier Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AstTokenIdentifier Class

For a list of all members of this type, see AstTokenIdentifier members.

See Also

Reference

AstTokenIdentifier Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AutoSyntaxProvider Class Events

AutoSyntaxProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AutoSyntaxProvider Class

For a list of all members of this type, see AutoSyntaxProvider members.

See Also

Reference

AutoSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Container Property (AutoSyntaxProvider)

Container Property (AutoSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AutoSyntaxProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As AutoSyntaxProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

AutoSyntaxProvider Class
AutoSyntaxProvider Members


CreateObjRef Method (AutoSyntaxProvider)

CreateObjRef Method (AutoSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AutoSyntaxProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As AutoSyntaxProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

AutoSyntaxProvider Class
AutoSyntaxProvider Members


Disposed Event (AutoSyntaxProvider)

Disposed Event (AutoSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AutoSyntaxProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As AutoSyntaxProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

AutoSyntaxProvider Class
AutoSyntaxProvider Members


GetLifetimeService Method (AutoSyntaxProvider)

GetLifetimeService Method (AutoSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AutoSyntaxProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As AutoSyntaxProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

AutoSyntaxProvider Class
AutoSyntaxProvider Members


InitializeLifetimeService Method (AutoSyntaxProvider)

InitializeLifetimeService Method (AutoSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AutoSyntaxProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As AutoSyntaxProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

AutoSyntaxProvider Class
AutoSyntaxProvider Members


Site Property (AutoSyntaxProvider)

Site Property (AutoSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AutoSyntaxProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As AutoSyntaxProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

AutoSyntaxProvider Class
AutoSyntaxProvider Members


Container Property (BaseMetadataProvider)

Container Property (BaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseMetadataProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As BaseMetadataProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

BaseMetadataProvider Class
BaseMetadataProvider Members


CreateObjRef Method (BaseMetadataProvider)

CreateObjRef Method (BaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseMetadataProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As BaseMetadataProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

BaseMetadataProvider Class
BaseMetadataProvider Members


Disposed Event (BaseMetadataProvider)

Disposed Event (BaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseMetadataProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As BaseMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

BaseMetadataProvider Class
BaseMetadataProvider Members


GetLifetimeService Method (BaseMetadataProvider)

GetLifetimeService Method (BaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseMetadataProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As BaseMetadataProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

BaseMetadataProvider Class
BaseMetadataProvider Members


InitializeLifetimeService Method (BaseMetadataProvider)

InitializeLifetimeService Method (BaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseMetadataProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As BaseMetadataProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

BaseMetadataProvider Class
BaseMetadataProvider Members


Site Property (BaseMetadataProvider)

Site Property (BaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseMetadataProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As BaseMetadataProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

BaseMetadataProvider Class
BaseMetadataProvider Members


Container Property (BaseSQLBuilder)

Container Property (BaseSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As BaseSQLBuilder
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


CreateObjRef Method (BaseSQLBuilder)

CreateObjRef Method (BaseSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As BaseSQLBuilder
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


Disposed Event (BaseSQLBuilder)

Disposed Event (BaseSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As BaseSQLBuilder
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


GetLifetimeService Method (BaseSQLBuilder)

GetLifetimeService Method (BaseSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As BaseSQLBuilder
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


InitializeLifetimeService Method (BaseSQLBuilder)

InitializeLifetimeService Method (BaseSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As BaseSQLBuilder
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


Site Property (BaseSQLBuilder)

Site Property (BaseSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As BaseSQLBuilder
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


ToString Method (BaseSQLBuilder)

ToString Method (BaseSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSQLBuilder Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function ToString() As System.String
'Usage

Dim instance As BaseSQLBuilder
Dim value As System.String

value = instance.ToString()
public virtual System.string ToString()
public: virtual System.string* ToString();
Requirements

See Also

Reference

BaseSQLBuilder Class
BaseSQLBuilder Members


BaseSyntaxProvider Class Events

BaseSyntaxProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : BaseSyntaxProvider Class

For a list of all members of this type, see BaseSyntaxProvider members.

See Also

Reference

BaseSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Container Property (BaseSyntaxProvider)

Container Property (BaseSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSyntaxProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As BaseSyntaxProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

BaseSyntaxProvider Class
BaseSyntaxProvider Members


CreateObjRef Method (BaseSyntaxProvider)

CreateObjRef Method (BaseSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSyntaxProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As BaseSyntaxProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

BaseSyntaxProvider Class
BaseSyntaxProvider Members


Disposed Event (BaseSyntaxProvider)

Disposed Event (BaseSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSyntaxProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As BaseSyntaxProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

BaseSyntaxProvider Class
BaseSyntaxProvider Members


GetLifetimeService Method (BaseSyntaxProvider)

GetLifetimeService Method (BaseSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSyntaxProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As BaseSyntaxProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

BaseSyntaxProvider Class
BaseSyntaxProvider Members


InitializeLifetimeService Method (BaseSyntaxProvider)

InitializeLifetimeService Method (BaseSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSyntaxProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As BaseSyntaxProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

BaseSyntaxProvider Class
BaseSyntaxProvider Members


Site Property (BaseSyntaxProvider)

Site Property (BaseSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > BaseSyntaxProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As BaseSyntaxProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

BaseSyntaxProvider Class
BaseSyntaxProvider Members


DB2SyntaxProvider Class Events

DB2SyntaxProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DB2SyntaxProvider Class

For a list of all members of this type, see DB2SyntaxProvider members.

See Also

Reference

DB2SyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Container Property (DB2SyntaxProvider)

Container Property (DB2SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2SyntaxProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As DB2SyntaxProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

DB2SyntaxProvider Class
DB2SyntaxProvider Members


CreateObjRef Method (DB2SyntaxProvider)

CreateObjRef Method (DB2SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2SyntaxProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As DB2SyntaxProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

DB2SyntaxProvider Class
DB2SyntaxProvider Members


Disposed Event (DB2SyntaxProvider)

Disposed Event (DB2SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2SyntaxProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As DB2SyntaxProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

DB2SyntaxProvider Class
DB2SyntaxProvider Members


GetLifetimeService Method (DB2SyntaxProvider)

GetLifetimeService Method (DB2SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2SyntaxProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As DB2SyntaxProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

DB2SyntaxProvider Class
DB2SyntaxProvider Members


InitializeLifetimeService Method (DB2SyntaxProvider)

InitializeLifetimeService Method (DB2SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2SyntaxProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As DB2SyntaxProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

DB2SyntaxProvider Class
DB2SyntaxProvider Members


Site Property (DB2SyntaxProvider)

Site Property (DB2SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2SyntaxProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As DB2SyntaxProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

DB2SyntaxProvider Class
DB2SyntaxProvider Members


FirebirdSyntaxProvider Class Events

FirebirdSyntaxProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FirebirdSyntaxProvider Class

For a list of all members of this type, see FirebirdSyntaxProvider members.

See Also

Reference

FirebirdSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Container Property (FirebirdSyntaxProvider)

Container Property (FirebirdSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdSyntaxProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As FirebirdSyntaxProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

FirebirdSyntaxProvider Class
FirebirdSyntaxProvider Members


CreateObjRef Method (FirebirdSyntaxProvider)

CreateObjRef Method (FirebirdSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdSyntaxProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As FirebirdSyntaxProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

FirebirdSyntaxProvider Class
FirebirdSyntaxProvider Members


Dispose Method (FirebirdSyntaxProvider)

Dispose Method (FirebirdSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdSyntaxProvider Class : Dispose Method
Requirements

See Also

Reference

FirebirdSyntaxProvider Class
FirebirdSyntaxProvider Members


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdSyntaxProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As FirebirdSyntaxProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

FirebirdSyntaxProvider Class
FirebirdSyntaxProvider Members


Disposed Event (FirebirdSyntaxProvider)

Disposed Event (FirebirdSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdSyntaxProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As FirebirdSyntaxProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

FirebirdSyntaxProvider Class
FirebirdSyntaxProvider Members


GetLifetimeService Method (FirebirdSyntaxProvider)

GetLifetimeService Method (FirebirdSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdSyntaxProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As FirebirdSyntaxProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

FirebirdSyntaxProvider Class
FirebirdSyntaxProvider Members


InitializeLifetimeService Method (FirebirdSyntaxProvider)

InitializeLifetimeService Method (FirebirdSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdSyntaxProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As FirebirdSyntaxProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

FirebirdSyntaxProvider Class
FirebirdSyntaxProvider Members


Site Property (FirebirdSyntaxProvider)

Site Property (FirebirdSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdSyntaxProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As FirebirdSyntaxProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

FirebirdSyntaxProvider Class
FirebirdSyntaxProvider Members


GenericSyntaxProvider Class Events

GenericSyntaxProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : GenericSyntaxProvider Class

For a list of all members of this type, see GenericSyntaxProvider members.

See Also

Reference

GenericSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


GenericSyntaxProvider Class Methods

GenericSyntaxProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : GenericSyntaxProvider Class

For a list of all members of this type, see GenericSyntaxProvider members.

See Also

Reference

GenericSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Container Property (GenericSyntaxProvider)

Container Property (GenericSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > GenericSyntaxProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As GenericSyntaxProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

GenericSyntaxProvider Class
GenericSyntaxProvider Members


CreateObjRef Method (GenericSyntaxProvider)

CreateObjRef Method (GenericSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > GenericSyntaxProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As GenericSyntaxProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

GenericSyntaxProvider Class
GenericSyntaxProvider Members


Dispose Method (GenericSyntaxProvider)

Dispose Method (GenericSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > GenericSyntaxProvider Class : Dispose Method
Requirements

See Also

Reference

GenericSyntaxProvider Class
GenericSyntaxProvider Members


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > GenericSyntaxProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As GenericSyntaxProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

GenericSyntaxProvider Class
GenericSyntaxProvider Members


Disposed Event (GenericSyntaxProvider)

Disposed Event (GenericSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > GenericSyntaxProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As GenericSyntaxProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

GenericSyntaxProvider Class
GenericSyntaxProvider Members


GetLifetimeService Method (GenericSyntaxProvider)

GetLifetimeService Method (GenericSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > GenericSyntaxProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As GenericSyntaxProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

GenericSyntaxProvider Class
GenericSyntaxProvider Members


InitializeLifetimeService Method (GenericSyntaxProvider)

InitializeLifetimeService Method (GenericSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > GenericSyntaxProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As GenericSyntaxProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

GenericSyntaxProvider Class
GenericSyntaxProvider Members


Site Property (GenericSyntaxProvider)

Site Property (GenericSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > GenericSyntaxProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As GenericSyntaxProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

GenericSyntaxProvider Class
GenericSyntaxProvider Members


InformixSyntaxProvider Class Events

InformixSyntaxProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : InformixSyntaxProvider Class

For a list of all members of this type, see InformixSyntaxProvider members.

See Also

Reference

InformixSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


InformixSyntaxProvider Class Methods

InformixSyntaxProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : InformixSyntaxProvider Class

For a list of all members of this type, see InformixSyntaxProvider members.

See Also

Reference

InformixSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Container Property (InformixSyntaxProvider)

Container Property (InformixSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixSyntaxProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As InformixSyntaxProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

InformixSyntaxProvider Class
InformixSyntaxProvider Members


CreateObjRef Method (InformixSyntaxProvider)

CreateObjRef Method (InformixSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixSyntaxProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As InformixSyntaxProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

InformixSyntaxProvider Class
InformixSyntaxProvider Members


Dispose Method (InformixSyntaxProvider)

Dispose Method (InformixSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixSyntaxProvider Class : Dispose Method
Requirements

See Also

Reference

InformixSyntaxProvider Class
InformixSyntaxProvider Members


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixSyntaxProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As InformixSyntaxProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

InformixSyntaxProvider Class
InformixSyntaxProvider Members


Disposed Event (InformixSyntaxProvider)

Disposed Event (InformixSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixSyntaxProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As InformixSyntaxProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

InformixSyntaxProvider Class
InformixSyntaxProvider Members


GetLifetimeService Method (InformixSyntaxProvider)

GetLifetimeService Method (InformixSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixSyntaxProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As InformixSyntaxProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

InformixSyntaxProvider Class
InformixSyntaxProvider Members


InitializeLifetimeService Method (InformixSyntaxProvider)

InitializeLifetimeService Method (InformixSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixSyntaxProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As InformixSyntaxProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

InformixSyntaxProvider Class
InformixSyntaxProvider Members


Site Property (InformixSyntaxProvider)

Site Property (InformixSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixSyntaxProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As InformixSyntaxProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

InformixSyntaxProvider Class
InformixSyntaxProvider Members


MetadataAggregate Class Events

MetadataAggregate Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataAggregate Class

For a list of all members of this type, see MetadataAggregate members.

See Also

Reference

MetadataAggregate Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataAggregate Class Methods

MetadataAggregate Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataAggregate Class

For a list of all members of this type, see MetadataAggregate members.

See Also

Reference

MetadataAggregate Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataAggregate Class Properties

MetadataAggregate Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataAggregate Class

For a list of all members of this type, see MetadataAggregate members.

See Also

Reference

MetadataAggregate Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataField Class Events

MetadataField Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataField Class

For a list of all members of this type, see MetadataField members.

See Also

Reference

MetadataField Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataForeignKey Class Events

MetadataForeignKey Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataForeignKey Class

For a list of all members of this type, see MetadataForeignKey members.

See Also

Reference

MetadataForeignKey Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataForeignKey Class Methods

MetadataForeignKey Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataForeignKey Class

For a list of all members of this type, see MetadataForeignKey members.

See Also

Reference

MetadataForeignKey Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataNamespace Class Events

MetadataNamespace Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataNamespace Class

For a list of all members of this type, see MetadataNamespace members.

See Also

Reference

MetadataNamespace Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataNamespace Class Methods

MetadataNamespace Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataNamespace Class

For a list of all members of this type, see MetadataNamespace members.

See Also

Reference

MetadataNamespace Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataNamespace Class Properties

MetadataNamespace Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataNamespace Class

For a list of all members of this type, see MetadataNamespace members.

See Also

Reference

MetadataNamespace Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataObject Class Events

MetadataObject Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataObject Class

For a list of all members of this type, see MetadataObject members.

See Also

Reference

MetadataObject Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataParameter Class Events

MetadataParameter Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataParameter Class

For a list of all members of this type, see MetadataParameter members.

See Also

Reference

MetadataParameter Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MetadataParameter Class Methods

MetadataParameter Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MetadataParameter Class

For a list of all members of this type, see MetadataParameter members.

See Also

Reference

MetadataParameter Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MSAccessSyntaxProvider Class Events

MSAccessSyntaxProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSAccessSyntaxProvider Class

For a list of all members of this type, see MSAccessSyntaxProvider members.

See Also

Reference

MSAccessSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MSAccessSyntaxProvider Class Methods

MSAccessSyntaxProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSAccessSyntaxProvider Class

For a list of all members of this type, see MSAccessSyntaxProvider members.

See Also

Reference

MSAccessSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Container Property (MSAccessSyntaxProvider)

Container Property (MSAccessSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSAccessSyntaxProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As MSAccessSyntaxProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

MSAccessSyntaxProvider Class
MSAccessSyntaxProvider Members


CreateObjRef Method (MSAccessSyntaxProvider)

CreateObjRef Method (MSAccessSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSAccessSyntaxProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As MSAccessSyntaxProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

MSAccessSyntaxProvider Class
MSAccessSyntaxProvider Members


Dispose Method (MSAccessSyntaxProvider)

Dispose Method (MSAccessSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSAccessSyntaxProvider Class : Dispose Method
Requirements

See Also

Reference

MSAccessSyntaxProvider Class
MSAccessSyntaxProvider Members


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSAccessSyntaxProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As MSAccessSyntaxProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

MSAccessSyntaxProvider Class
MSAccessSyntaxProvider Members


Disposed Event (MSAccessSyntaxProvider)

Disposed Event (MSAccessSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSAccessSyntaxProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As MSAccessSyntaxProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

MSAccessSyntaxProvider Class
MSAccessSyntaxProvider Members


GetLifetimeService Method (MSAccessSyntaxProvider)

GetLifetimeService Method (MSAccessSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSAccessSyntaxProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As MSAccessSyntaxProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

MSAccessSyntaxProvider Class
MSAccessSyntaxProvider Members


InitializeLifetimeService Method (MSAccessSyntaxProvider)

InitializeLifetimeService Method (MSAccessSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSAccessSyntaxProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As MSAccessSyntaxProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

MSAccessSyntaxProvider Class
MSAccessSyntaxProvider Members


Site Property (MSAccessSyntaxProvider)

Site Property (MSAccessSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSAccessSyntaxProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As MSAccessSyntaxProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

MSAccessSyntaxProvider Class
MSAccessSyntaxProvider Members


MSSQLAzureSyntaxProvider Class Events

MSSQLAzureSyntaxProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLAzureSyntaxProvider Class

For a list of all members of this type, see MSSQLAzureSyntaxProvider members.

See Also

Reference

MSSQLAzureSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MSSQLAzureSyntaxProvider Class Methods

MSSQLAzureSyntaxProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLAzureSyntaxProvider Class

For a list of all members of this type, see MSSQLAzureSyntaxProvider members.

See Also

Reference

MSSQLAzureSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MSSQLAzureSyntaxProvider Class Properties

MSSQLAzureSyntaxProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLAzureSyntaxProvider Class

For a list of all members of this type, see MSSQLAzureSyntaxProvider members.

See Also

Reference

MSSQLAzureSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Container Property (MSSQLAzureSyntaxProvider)

Container Property (MSSQLAzureSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLAzureSyntaxProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As MSSQLAzureSyntaxProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

MSSQLAzureSyntaxProvider Class
MSSQLAzureSyntaxProvider Members


CreateObjRef Method (MSSQLAzureSyntaxProvider)

CreateObjRef Method (MSSQLAzureSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLAzureSyntaxProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As MSSQLAzureSyntaxProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

MSSQLAzureSyntaxProvider Class
MSSQLAzureSyntaxProvider Members


Dispose Method (MSSQLAzureSyntaxProvider)

Dispose Method (MSSQLAzureSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLAzureSyntaxProvider Class : Dispose Method
Requirements

See Also

Reference

MSSQLAzureSyntaxProvider Class
MSSQLAzureSyntaxProvider Members


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLAzureSyntaxProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As MSSQLAzureSyntaxProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

MSSQLAzureSyntaxProvider Class
MSSQLAzureSyntaxProvider Members


Disposed Event (MSSQLAzureSyntaxProvider)

Disposed Event (MSSQLAzureSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLAzureSyntaxProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As MSSQLAzureSyntaxProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

MSSQLAzureSyntaxProvider Class
MSSQLAzureSyntaxProvider Members


GetLifetimeService Method (MSSQLAzureSyntaxProvider)

GetLifetimeService Method (MSSQLAzureSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLAzureSyntaxProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As MSSQLAzureSyntaxProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

MSSQLAzureSyntaxProvider Class
MSSQLAzureSyntaxProvider Members


InitializeLifetimeService Method (MSSQLAzureSyntaxProvider)

InitializeLifetimeService Method (MSSQLAzureSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLAzureSyntaxProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As MSSQLAzureSyntaxProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

MSSQLAzureSyntaxProvider Class
MSSQLAzureSyntaxProvider Members


Site Property (MSSQLAzureSyntaxProvider)

Site Property (MSSQLAzureSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLAzureSyntaxProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As MSSQLAzureSyntaxProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

MSSQLAzureSyntaxProvider Class
MSSQLAzureSyntaxProvider Members


MSSQLCESyntaxProvider Class Events

MSSQLCESyntaxProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLCESyntaxProvider Class

For a list of all members of this type, see MSSQLCESyntaxProvider members.

See Also

Reference

MSSQLCESyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MSSQLCESyntaxProvider Class Properties

MSSQLCESyntaxProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLCESyntaxProvider Class

For a list of all members of this type, see MSSQLCESyntaxProvider members.

See Also

Reference

MSSQLCESyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Container Property (MSSQLCESyntaxProvider)

Container Property (MSSQLCESyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCESyntaxProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As MSSQLCESyntaxProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

MSSQLCESyntaxProvider Class
MSSQLCESyntaxProvider Members


CreateObjRef Method (MSSQLCESyntaxProvider)

CreateObjRef Method (MSSQLCESyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCESyntaxProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As MSSQLCESyntaxProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

MSSQLCESyntaxProvider Class
MSSQLCESyntaxProvider Members


Dispose Method (MSSQLCESyntaxProvider)

Dispose Method (MSSQLCESyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCESyntaxProvider Class : Dispose Method
Requirements

See Also

Reference

MSSQLCESyntaxProvider Class
MSSQLCESyntaxProvider Members


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCESyntaxProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As MSSQLCESyntaxProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

MSSQLCESyntaxProvider Class
MSSQLCESyntaxProvider Members


Disposed Event (MSSQLCESyntaxProvider)

Disposed Event (MSSQLCESyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCESyntaxProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As MSSQLCESyntaxProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

MSSQLCESyntaxProvider Class
MSSQLCESyntaxProvider Members


GetLifetimeService Method (MSSQLCESyntaxProvider)

GetLifetimeService Method (MSSQLCESyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCESyntaxProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As MSSQLCESyntaxProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

MSSQLCESyntaxProvider Class
MSSQLCESyntaxProvider Members


InitializeLifetimeService Method (MSSQLCESyntaxProvider)

InitializeLifetimeService Method (MSSQLCESyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCESyntaxProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As MSSQLCESyntaxProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

MSSQLCESyntaxProvider Class
MSSQLCESyntaxProvider Members


Site Property (MSSQLCESyntaxProvider)

Site Property (MSSQLCESyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCESyntaxProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As MSSQLCESyntaxProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

MSSQLCESyntaxProvider Class
MSSQLCESyntaxProvider Members


MSSQLSyntaxProvider Class Events

MSSQLSyntaxProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLSyntaxProvider Class

For a list of all members of this type, see MSSQLSyntaxProvider members.

See Also

Reference

MSSQLSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Container Property (MSSQLSyntaxProvider)

Container Property (MSSQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLSyntaxProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As MSSQLSyntaxProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

MSSQLSyntaxProvider Class
MSSQLSyntaxProvider Members


CreateObjRef Method (MSSQLSyntaxProvider)

CreateObjRef Method (MSSQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLSyntaxProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As MSSQLSyntaxProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

MSSQLSyntaxProvider Class
MSSQLSyntaxProvider Members


Disposed Event (MSSQLSyntaxProvider)

Disposed Event (MSSQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLSyntaxProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As MSSQLSyntaxProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

MSSQLSyntaxProvider Class
MSSQLSyntaxProvider Members


GetLifetimeService Method (MSSQLSyntaxProvider)

GetLifetimeService Method (MSSQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLSyntaxProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As MSSQLSyntaxProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

MSSQLSyntaxProvider Class
MSSQLSyntaxProvider Members


InitializeLifetimeService Method (MSSQLSyntaxProvider)

InitializeLifetimeService Method (MSSQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLSyntaxProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As MSSQLSyntaxProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

MSSQLSyntaxProvider Class
MSSQLSyntaxProvider Members


Site Property (MSSQLSyntaxProvider)

Site Property (MSSQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLSyntaxProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As MSSQLSyntaxProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

MSSQLSyntaxProvider Class
MSSQLSyntaxProvider Members


MySQLSyntaxProvider Class Events

MySQLSyntaxProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MySQLSyntaxProvider Class

For a list of all members of this type, see MySQLSyntaxProvider members.

See Also

Reference

MySQLSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MySQLSyntaxProvider Class Methods

MySQLSyntaxProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MySQLSyntaxProvider Class

For a list of all members of this type, see MySQLSyntaxProvider members.

See Also

Reference

MySQLSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Container Property (MySQLSyntaxProvider)

Container Property (MySQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLSyntaxProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As MySQLSyntaxProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

MySQLSyntaxProvider Class
MySQLSyntaxProvider Members


CreateObjRef Method (MySQLSyntaxProvider)

CreateObjRef Method (MySQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLSyntaxProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As MySQLSyntaxProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

MySQLSyntaxProvider Class
MySQLSyntaxProvider Members


Disposed Event (MySQLSyntaxProvider)

Disposed Event (MySQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLSyntaxProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As MySQLSyntaxProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

MySQLSyntaxProvider Class
MySQLSyntaxProvider Members


GetLifetimeService Method (MySQLSyntaxProvider)

GetLifetimeService Method (MySQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLSyntaxProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As MySQLSyntaxProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

MySQLSyntaxProvider Class
MySQLSyntaxProvider Members


InitializeLifetimeService Method (MySQLSyntaxProvider)

InitializeLifetimeService Method (MySQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLSyntaxProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As MySQLSyntaxProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

MySQLSyntaxProvider Class
MySQLSyntaxProvider Members


Site Property (MySQLSyntaxProvider)

Site Property (MySQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLSyntaxProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As MySQLSyntaxProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

MySQLSyntaxProvider Class
MySQLSyntaxProvider Members


OracleSyntaxProvider Class Events

OracleSyntaxProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : OracleSyntaxProvider Class

For a list of all members of this type, see OracleSyntaxProvider members.

See Also

Reference

OracleSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Container Property (OracleSyntaxProvider)

Container Property (OracleSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleSyntaxProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As OracleSyntaxProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

OracleSyntaxProvider Class
OracleSyntaxProvider Members


CreateObjRef Method (OracleSyntaxProvider)

CreateObjRef Method (OracleSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleSyntaxProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As OracleSyntaxProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

OracleSyntaxProvider Class
OracleSyntaxProvider Members


Dispose Method (OracleSyntaxProvider)

Dispose Method (OracleSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleSyntaxProvider Class : Dispose Method
Requirements

See Also

Reference

OracleSyntaxProvider Class
OracleSyntaxProvider Members


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleSyntaxProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As OracleSyntaxProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

OracleSyntaxProvider Class
OracleSyntaxProvider Members


Disposed Event (OracleSyntaxProvider)

Disposed Event (OracleSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleSyntaxProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As OracleSyntaxProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

OracleSyntaxProvider Class
OracleSyntaxProvider Members


GetLifetimeService Method (OracleSyntaxProvider)

GetLifetimeService Method (OracleSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleSyntaxProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As OracleSyntaxProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

OracleSyntaxProvider Class
OracleSyntaxProvider Members


InitializeLifetimeService Method (OracleSyntaxProvider)

InitializeLifetimeService Method (OracleSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleSyntaxProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As OracleSyntaxProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

OracleSyntaxProvider Class
OracleSyntaxProvider Members


Site Property (OracleSyntaxProvider)

Site Property (OracleSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleSyntaxProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As OracleSyntaxProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

OracleSyntaxProvider Class
OracleSyntaxProvider Members


PlainTextSQLBuilder Class Events

PlainTextSQLBuilder Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : PlainTextSQLBuilder Class

For a list of all members of this type, see PlainTextSQLBuilder members.

See Also

Reference

PlainTextSQLBuilder Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


PlainTextSQLBuilder Class Methods

PlainTextSQLBuilder Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : PlainTextSQLBuilder Class

For a list of all members of this type, see PlainTextSQLBuilder members.

See Also

Reference

PlainTextSQLBuilder Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Container Property (PlainTextSQLBuilder)

Container Property (PlainTextSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PlainTextSQLBuilder Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As PlainTextSQLBuilder
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

PlainTextSQLBuilder Class
PlainTextSQLBuilder Members


CreateObjRef Method (PlainTextSQLBuilder)

CreateObjRef Method (PlainTextSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PlainTextSQLBuilder Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As PlainTextSQLBuilder
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

PlainTextSQLBuilder Class
PlainTextSQLBuilder Members


Dispose Method (PlainTextSQLBuilder)

Dispose Method (PlainTextSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PlainTextSQLBuilder Class : Dispose Method
Requirements

See Also

Reference

PlainTextSQLBuilder Class
PlainTextSQLBuilder Members


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PlainTextSQLBuilder Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As PlainTextSQLBuilder

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

PlainTextSQLBuilder Class
PlainTextSQLBuilder Members


Disposed Event (PlainTextSQLBuilder)

Disposed Event (PlainTextSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PlainTextSQLBuilder Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As PlainTextSQLBuilder
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

PlainTextSQLBuilder Class
PlainTextSQLBuilder Members


GetLifetimeService Method (PlainTextSQLBuilder)

GetLifetimeService Method (PlainTextSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PlainTextSQLBuilder Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As PlainTextSQLBuilder
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

PlainTextSQLBuilder Class
PlainTextSQLBuilder Members


InitializeLifetimeService Method (PlainTextSQLBuilder)

InitializeLifetimeService Method (PlainTextSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PlainTextSQLBuilder Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As PlainTextSQLBuilder
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

PlainTextSQLBuilder Class
PlainTextSQLBuilder Members


Site Property (PlainTextSQLBuilder)

Site Property (PlainTextSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PlainTextSQLBuilder Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As PlainTextSQLBuilder
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

PlainTextSQLBuilder Class
PlainTextSQLBuilder Members


ToString Method (PlainTextSQLBuilder)

ToString Method (PlainTextSQLBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PlainTextSQLBuilder Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function ToString() As System.String
'Usage

Dim instance As PlainTextSQLBuilder
Dim value As System.String

value = instance.ToString()
public virtual System.string ToString()
public: virtual System.string* ToString();
Requirements

See Also

Reference

PlainTextSQLBuilder Class
PlainTextSQLBuilder Members


PostgreSQLSyntaxProvider Class Events

PostgreSQLSyntaxProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : PostgreSQLSyntaxProvider Class

For a list of all members of this type, see PostgreSQLSyntaxProvider members.

See Also

Reference

PostgreSQLSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Container Property (PostgreSQLSyntaxProvider)

Container Property (PostgreSQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLSyntaxProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As PostgreSQLSyntaxProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

PostgreSQLSyntaxProvider Class
PostgreSQLSyntaxProvider Members


CreateObjRef Method (PostgreSQLSyntaxProvider)

CreateObjRef Method (PostgreSQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLSyntaxProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As PostgreSQLSyntaxProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

PostgreSQLSyntaxProvider Class
PostgreSQLSyntaxProvider Members


Disposed Event (PostgreSQLSyntaxProvider)

Disposed Event (PostgreSQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLSyntaxProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As PostgreSQLSyntaxProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

PostgreSQLSyntaxProvider Class
PostgreSQLSyntaxProvider Members


GetLifetimeService Method (PostgreSQLSyntaxProvider)

GetLifetimeService Method (PostgreSQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLSyntaxProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As PostgreSQLSyntaxProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

PostgreSQLSyntaxProvider Class
PostgreSQLSyntaxProvider Members


InitializeLifetimeService Method (PostgreSQLSyntaxProvider)

InitializeLifetimeService Method (PostgreSQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLSyntaxProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As PostgreSQLSyntaxProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

PostgreSQLSyntaxProvider Class
PostgreSQLSyntaxProvider Members


Site Property (PostgreSQLSyntaxProvider)

Site Property (PostgreSQLSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLSyntaxProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As PostgreSQLSyntaxProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

PostgreSQLSyntaxProvider Class
PostgreSQLSyntaxProvider Members


AccessibilityObject Property

AccessibilityObject Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : AccessibilityObject Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property AccessibilityObject As System.Windows.Forms.AccessibleObject
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.AccessibleObject

value = instance.AccessibilityObject
public System.Windows.Forms.AccessibleObject AccessibilityObject {get;}
public: __property System.Windows.Forms.AccessibleObject* get_AccessibilityObject();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


AccessibleDefaultActionDescription Property

AccessibleDefaultActionDescription Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : AccessibleDefaultActionDescription Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AccessibleDefaultActionDescription As System.String
'Usage

Dim instance As QueryBuilder
Dim value As System.String

instance.AccessibleDefaultActionDescription = value

value = instance.AccessibleDefaultActionDescription
public System.string AccessibleDefaultActionDescription {get; set;}
public: __property System.string* get_AccessibleDefaultActionDescription();
public: __property void set_AccessibleDefaultActionDescription(
   System.string* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


AccessibleDescription Property

AccessibleDescription Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : AccessibleDescription Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AccessibleDescription As System.String
'Usage

Dim instance As QueryBuilder
Dim value As System.String

instance.AccessibleDescription = value

value = instance.AccessibleDescription
public System.string AccessibleDescription {get; set;}
public: __property System.string* get_AccessibleDescription();
public: __property void set_AccessibleDescription(
   System.string* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


AccessibleName Property

AccessibleName Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : AccessibleName Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AccessibleName As System.String
'Usage

Dim instance As QueryBuilder
Dim value As System.String

instance.AccessibleName = value

value = instance.AccessibleName
public System.string AccessibleName {get; set;}
public: __property System.string* get_AccessibleName();
public: __property void set_AccessibleName(
   System.string* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


AccessibleRole Property

AccessibleRole Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : AccessibleRole Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AccessibleRole As System.Windows.Forms.AccessibleRole
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.AccessibleRole

instance.AccessibleRole = value

value = instance.AccessibleRole
public System.Windows.Forms.AccessibleRole AccessibleRole {get; set;}
public: __property System.Windows.Forms.AccessibleRole get_AccessibleRole();
public: __property void set_AccessibleRole(
   System.Windows.Forms.AccessibleRole value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ActiveControl Property

ActiveControl Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ActiveControl Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ActiveControl As System.Windows.Forms.Control
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.Control

instance.ActiveControl = value

value = instance.ActiveControl
public System.Windows.Forms.Control ActiveControl {get; set;}
public: __property System.Windows.Forms.Control* get_ActiveControl();
public: __property void set_ActiveControl(
   System.Windows.Forms.Control* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


AllowDrop Property

AllowDrop Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : AllowDrop Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property AllowDrop As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

instance.AllowDrop = value

value = instance.AllowDrop
public virtual System.bool AllowDrop {get; set;}
public: __property virtual System.bool get_AllowDrop();
public: __property virtual void set_AllowDrop(
   System.bool value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Anchor Property

Anchor Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Anchor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Anchor As System.Windows.Forms.AnchorStyles
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.AnchorStyles

instance.Anchor = value

value = instance.Anchor
public virtual System.Windows.Forms.AnchorStyles Anchor {get; set;}
public: __property virtual System.Windows.Forms.AnchorStyles get_Anchor();
public: __property virtual void set_Anchor(
   System.Windows.Forms.AnchorStyles value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


AutoScaleDimensions Property

AutoScaleDimensions Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : AutoScaleDimensions Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AutoScaleDimensions As System.Drawing.SizeF
'Usage

Dim instance As QueryBuilder
Dim value As System.Drawing.SizeF

instance.AutoScaleDimensions = value

value = instance.AutoScaleDimensions
public System.Drawing.SizeF AutoScaleDimensions {get; set;}
public: __property System.Drawing.SizeF get_AutoScaleDimensions();
public: __property void set_AutoScaleDimensions(
   System.Drawing.SizeF value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


AutoScaleMode Property

AutoScaleMode Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : AutoScaleMode Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AutoScaleMode As System.Windows.Forms.AutoScaleMode
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.AutoScaleMode

instance.AutoScaleMode = value

value = instance.AutoScaleMode
public System.Windows.Forms.AutoScaleMode AutoScaleMode {get; set;}
public: __property System.Windows.Forms.AutoScaleMode get_AutoScaleMode();
public: __property void set_AutoScaleMode(
   System.Windows.Forms.AutoScaleMode value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


AutoScroll Property

AutoScroll Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : AutoScroll Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property AutoScroll As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

instance.AutoScroll = value

value = instance.AutoScroll
public virtual System.bool AutoScroll {get; set;}
public: __property virtual System.bool get_AutoScroll();
public: __property virtual void set_AutoScroll(
   System.bool value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


AutoScrollMargin Property

AutoScrollMargin Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : AutoScrollMargin Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AutoScrollMargin As System.Drawing.Size
'Usage

Dim instance As QueryBuilder
Dim value As System.Drawing.Size

instance.AutoScrollMargin = value

value = instance.AutoScrollMargin
public System.Drawing.Size AutoScrollMargin {get; set;}
public: __property System.Drawing.Size get_AutoScrollMargin();
public: __property void set_AutoScrollMargin(
   System.Drawing.Size value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


AutoScrollMinSize Property

AutoScrollMinSize Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : AutoScrollMinSize Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AutoScrollMinSize As System.Drawing.Size
'Usage

Dim instance As QueryBuilder
Dim value As System.Drawing.Size

instance.AutoScrollMinSize = value

value = instance.AutoScrollMinSize
public System.Drawing.Size AutoScrollMinSize {get; set;}
public: __property System.Drawing.Size get_AutoScrollMinSize();
public: __property void set_AutoScrollMinSize(
   System.Drawing.Size value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


AutoScrollOffset Property

AutoScrollOffset Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : AutoScrollOffset Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property AutoScrollOffset As System.Drawing.Point
'Usage

Dim instance As QueryBuilder
Dim value As System.Drawing.Point

instance.AutoScrollOffset = value

value = instance.AutoScrollOffset
public virtual System.Drawing.Point AutoScrollOffset {get; set;}
public: __property virtual System.Drawing.Point get_AutoScrollOffset();
public: __property virtual void set_AutoScrollOffset(
   System.Drawing.Point value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


AutoScrollPosition Property

AutoScrollPosition Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : AutoScrollPosition Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AutoScrollPosition As System.Drawing.Point
'Usage

Dim instance As QueryBuilder
Dim value As System.Drawing.Point

instance.AutoScrollPosition = value

value = instance.AutoScrollPosition
public System.Drawing.Point AutoScrollPosition {get; set;}
public: __property System.Drawing.Point get_AutoScrollPosition();
public: __property void set_AutoScrollPosition(
   System.Drawing.Point value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


AutoSize Property

AutoSize Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : AutoSize Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property AutoSize As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

instance.AutoSize = value

value = instance.AutoSize
public virtual System.bool AutoSize {get; set;}
public: __property virtual System.bool get_AutoSize();
public: __property virtual void set_AutoSize(
   System.bool value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


AutoSizeChanged Event

AutoSizeChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : AutoSizeChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AutoSizeChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.AutoSizeChanged, handler
public event System.EventHandler AutoSizeChanged
public: __event System.EventHandler* AutoSizeChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


AutoSizeMode Property

AutoSizeMode Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : AutoSizeMode Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AutoSizeMode As System.Windows.Forms.AutoSizeMode
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.AutoSizeMode

instance.AutoSizeMode = value

value = instance.AutoSizeMode
public System.Windows.Forms.AutoSizeMode AutoSizeMode {get; set;}
public: __property System.Windows.Forms.AutoSizeMode get_AutoSizeMode();
public: __property void set_AutoSizeMode(
   System.Windows.Forms.AutoSizeMode value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


AutoValidate Property

AutoValidate Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : AutoValidate Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property AutoValidate As System.Windows.Forms.AutoValidate
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.AutoValidate

instance.AutoValidate = value

value = instance.AutoValidate
public virtual System.Windows.Forms.AutoValidate AutoValidate {get; set;}
public: __property virtual System.Windows.Forms.AutoValidate get_AutoValidate();
public: __property virtual void set_AutoValidate(
   System.Windows.Forms.AutoValidate value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


AutoValidateChanged Event

AutoValidateChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : AutoValidateChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AutoValidateChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.AutoValidateChanged, handler
public event System.EventHandler AutoValidateChanged
public: __event System.EventHandler* AutoValidateChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


BackColor Property (QueryBuilder)

BackColor Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : BackColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BackColor As System.Drawing.Color
'Usage

Dim instance As QueryBuilder
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
public virtual System.Drawing.Color BackColor {get; set;}
public: __property virtual System.Drawing.Color get_BackColor();
public: __property virtual void set_BackColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


BackColorChanged Event

BackColorChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : BackColorChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BackColorChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.BackColorChanged, handler
public event System.EventHandler BackColorChanged
public: __event System.EventHandler* BackColorChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


BackgroundImage Property

BackgroundImage Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : BackgroundImage Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BackgroundImage As System.Drawing.Image
'Usage

Dim instance As QueryBuilder
Dim value As System.Drawing.Image

instance.BackgroundImage = value

value = instance.BackgroundImage
public virtual System.Drawing.Image BackgroundImage {get; set;}
public: __property virtual System.Drawing.Image* get_BackgroundImage();
public: __property virtual void set_BackgroundImage(
   System.Drawing.Image* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


BackgroundImageChanged Event

BackgroundImageChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : BackgroundImageChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BackgroundImageChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.BackgroundImageChanged, handler
public event System.EventHandler BackgroundImageChanged
public: __event System.EventHandler* BackgroundImageChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


BackgroundImageLayout Property

BackgroundImageLayout Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : BackgroundImageLayout Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BackgroundImageLayout As System.Windows.Forms.ImageLayout
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.ImageLayout

instance.BackgroundImageLayout = value

value = instance.BackgroundImageLayout
public virtual System.Windows.Forms.ImageLayout BackgroundImageLayout {get; set;}
public: __property virtual System.Windows.Forms.ImageLayout get_BackgroundImageLayout();
public: __property virtual void set_BackgroundImageLayout(
   System.Windows.Forms.ImageLayout value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


BackgroundImageLayoutChanged Event

BackgroundImageLayoutChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : BackgroundImageLayoutChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BackgroundImageLayoutChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.BackgroundImageLayoutChanged, handler
public event System.EventHandler BackgroundImageLayoutChanged
public: __event System.EventHandler* BackgroundImageLayoutChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


BeginInvoke Method

BeginInvoke Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : BeginInvoke Method
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


BeginInvoke(Delegate) Method

BeginInvoke(Delegate) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > BeginInvoke Method : BeginInvoke(Delegate) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate _
) As System.IAsyncResult
'Usage

Dim instance As QueryBuilder
Dim method As System.Delegate
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method)
public System.IAsyncResult BeginInvoke(
   System.Delegate method
)
public: System.IAsyncResult* BeginInvoke(
   System.Delegate* method
)

Parameters

method
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


BeginInvoke(Delegate,Object[]) Method

BeginInvoke(Delegate,Object[]) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.IAsyncResult
'Usage

Dim instance As QueryBuilder
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method, args)
public System.IAsyncResult BeginInvoke(
   System.Delegate method,
   params System.object[] args
)
public: System.IAsyncResult* BeginInvoke(
   System.Delegate* method,
   params System.Object*[]* args
)

Parameters

method
args
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


BindingContext Property

BindingContext Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : BindingContext Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BindingContext As System.Windows.Forms.BindingContext
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.BindingContext

instance.BindingContext = value

value = instance.BindingContext
public virtual System.Windows.Forms.BindingContext BindingContext {get; set;}
public: __property virtual System.Windows.Forms.BindingContext* get_BindingContext();
public: __property virtual void set_BindingContext(
   System.Windows.Forms.BindingContext* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


BindingContextChanged Event

BindingContextChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : BindingContextChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BindingContextChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.BindingContextChanged, handler
public event System.EventHandler BindingContextChanged
public: __event System.EventHandler* BindingContextChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


BorderStyle Property (QueryBuilder)

BorderStyle Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : BorderStyle Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property BorderStyle As System.Windows.Forms.BorderStyle
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
public System.Windows.Forms.BorderStyle BorderStyle {get; set;}
public: __property System.Windows.Forms.BorderStyle get_BorderStyle();
public: __property void set_BorderStyle(
   System.Windows.Forms.BorderStyle value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Bottom Property

Bottom Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Bottom Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Bottom As System.Integer
'Usage

Dim instance As QueryBuilder
Dim value As System.Integer

value = instance.Bottom
public System.int Bottom {get;}
public: __property System.int get_Bottom();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Bounds Property

Bounds Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Bounds Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Bounds As System.Drawing.Rectangle
'Usage

Dim instance As QueryBuilder
Dim value As System.Drawing.Rectangle

instance.Bounds = value

value = instance.Bounds
public System.Drawing.Rectangle Bounds {get; set;}
public: __property System.Drawing.Rectangle get_Bounds();
public: __property void set_Bounds(
   System.Drawing.Rectangle value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


BringToFront Method

BringToFront Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : BringToFront Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub BringToFront()
'Usage

Dim instance As QueryBuilder

instance.BringToFront()
public void BringToFront()
public: void BringToFront();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


CanFocus Property

CanFocus Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : CanFocus Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CanFocus As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

value = instance.CanFocus
public System.bool CanFocus {get;}
public: __property System.bool get_CanFocus();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


CanSelect Property

CanSelect Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : CanSelect Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CanSelect As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

value = instance.CanSelect
public System.bool CanSelect {get;}
public: __property System.bool get_CanSelect();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Capture Property

Capture Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Capture Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Capture As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

instance.Capture = value

value = instance.Capture
public System.bool Capture {get; set;}
public: __property System.bool get_Capture();
public: __property void set_Capture(
   System.bool value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


CausesValidation Property

CausesValidation Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : CausesValidation Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property CausesValidation As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

instance.CausesValidation = value

value = instance.CausesValidation
public System.bool CausesValidation {get; set;}
public: __property System.bool get_CausesValidation();
public: __property void set_CausesValidation(
   System.bool value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


CausesValidationChanged Event

CausesValidationChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : CausesValidationChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event CausesValidationChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.CausesValidationChanged, handler
public event System.EventHandler CausesValidationChanged
public: __event System.EventHandler* CausesValidationChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ChangeUICues Event

ChangeUICues Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ChangeUICues Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ChangeUICues As System.Windows.Forms.UICuesEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.UICuesEventHandler

AddHandler instance.ChangeUICues, handler
public event System.Windows.Forms.UICuesEventHandler ChangeUICues
public: __event System.Windows.Forms.UICuesEventHandler* ChangeUICues
Event Data

The event handler receives an argument of type System.Windows.Forms.UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Click Event

Click Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Click Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Click As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.Click, handler
public event System.EventHandler Click
public: __event System.EventHandler* Click
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ClientRectangle Property

ClientRectangle Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ClientRectangle Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ClientRectangle As System.Drawing.Rectangle
'Usage

Dim instance As QueryBuilder
Dim value As System.Drawing.Rectangle

value = instance.ClientRectangle
public System.Drawing.Rectangle ClientRectangle {get;}
public: __property System.Drawing.Rectangle get_ClientRectangle();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ClientSize Property

ClientSize Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ClientSize Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ClientSize As System.Drawing.Size
'Usage

Dim instance As QueryBuilder
Dim value As System.Drawing.Size

instance.ClientSize = value

value = instance.ClientSize
public System.Drawing.Size ClientSize {get; set;}
public: __property System.Drawing.Size get_ClientSize();
public: __property void set_ClientSize(
   System.Drawing.Size value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ClientSizeChanged Event

ClientSizeChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ClientSizeChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ClientSizeChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.ClientSizeChanged, handler
public event System.EventHandler ClientSizeChanged
public: __event System.EventHandler* ClientSizeChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


CompanyName Property

CompanyName Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : CompanyName Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CompanyName As System.String
'Usage

Dim instance As QueryBuilder
Dim value As System.String

value = instance.CompanyName
public System.string CompanyName {get;}
public: __property System.string* get_CompanyName();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Container Property (QueryBuilder)

Container Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As QueryBuilder
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Contains Method (QueryBuilder)

Contains Method (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Contains Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function Contains( _
   ByVal ctl As System.Windows.Forms.Control _
) As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim ctl As System.Windows.Forms.Control
Dim value As System.Boolean

value = instance.Contains(ctl)
public System.bool Contains(
   System.Windows.Forms.Control ctl
)
public: System.bool Contains(
   System.Windows.Forms.Control* ctl
)

Parameters

ctl
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ContainsFocus Property

ContainsFocus Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ContainsFocus Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ContainsFocus As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

value = instance.ContainsFocus
public System.bool ContainsFocus {get;}
public: __property System.bool get_ContainsFocus();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ContextMenu Property

ContextMenu Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ContextMenu Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ContextMenu As System.Windows.Forms.ContextMenu
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.ContextMenu

instance.ContextMenu = value

value = instance.ContextMenu
public virtual System.Windows.Forms.ContextMenu ContextMenu {get; set;}
public: __property virtual System.Windows.Forms.ContextMenu* get_ContextMenu();
public: __property virtual void set_ContextMenu(
   System.Windows.Forms.ContextMenu* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ContextMenuChanged Event

ContextMenuChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ContextMenuChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ContextMenuChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.ContextMenuChanged, handler
public event System.EventHandler ContextMenuChanged
public: __event System.EventHandler* ContextMenuChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ContextMenuStrip Property

ContextMenuStrip Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ContextMenuStrip Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ContextMenuStrip As System.Windows.Forms.ContextMenuStrip
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.ContextMenuStrip

instance.ContextMenuStrip = value

value = instance.ContextMenuStrip
public virtual System.Windows.Forms.ContextMenuStrip ContextMenuStrip {get; set;}
public: __property virtual System.Windows.Forms.ContextMenuStrip* get_ContextMenuStrip();
public: __property virtual void set_ContextMenuStrip(
   System.Windows.Forms.ContextMenuStrip* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ContextMenuStripChanged Event

ContextMenuStripChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ContextMenuStripChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ContextMenuStripChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.ContextMenuStripChanged, handler
public event System.EventHandler ContextMenuStripChanged
public: __event System.EventHandler* ContextMenuStripChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ControlAdded Event

ControlAdded Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ControlAdded Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ControlAdded As System.Windows.Forms.ControlEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlAdded, handler
public event System.Windows.Forms.ControlEventHandler ControlAdded
public: __event System.Windows.Forms.ControlEventHandler* ControlAdded
Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ControlRemoved Event

ControlRemoved Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ControlRemoved Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ControlRemoved As System.Windows.Forms.ControlEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlRemoved, handler
public event System.Windows.Forms.ControlEventHandler ControlRemoved
public: __event System.Windows.Forms.ControlEventHandler* ControlRemoved
Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Controls Property (QueryBuilder)

Controls Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Controls Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Controls As System.Windows.Forms.Control.ControlCollection
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.Control.ControlCollection

value = instance.Controls
public System.Windows.Forms.Control.ControlCollection Controls {get;}
public: __property System.Windows.Forms.Control.ControlCollection* get_Controls();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


CreateControl Method

CreateControl Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : CreateControl Method
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


CreateControl() Method

CreateControl() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : CreateControl() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub CreateControl()
'Usage

Dim instance As QueryBuilder

instance.CreateControl()
public void CreateControl()
public: void CreateControl();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Created Property

Created Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Created Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Created As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

value = instance.Created
public System.bool Created {get;}
public: __property System.bool get_Created();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


CreateGraphics Method

CreateGraphics Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : CreateGraphics Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function CreateGraphics() As System.Drawing.Graphics
'Usage

Dim instance As QueryBuilder
Dim value As System.Drawing.Graphics

value = instance.CreateGraphics()
public System.Drawing.Graphics CreateGraphics()
public: System.Drawing.Graphics* CreateGraphics();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


CreateObjRef Method (QueryBuilder)

CreateObjRef Method (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As QueryBuilder
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


CurrentAutoScaleDimensions Property

CurrentAutoScaleDimensions Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : CurrentAutoScaleDimensions Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CurrentAutoScaleDimensions As System.Drawing.SizeF
'Usage

Dim instance As QueryBuilder
Dim value As System.Drawing.SizeF

value = instance.CurrentAutoScaleDimensions
public System.Drawing.SizeF CurrentAutoScaleDimensions {get;}
public: __property System.Drawing.SizeF get_CurrentAutoScaleDimensions();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Cursor Property

Cursor Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Cursor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Cursor As System.Windows.Forms.Cursor
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.Cursor

instance.Cursor = value

value = instance.Cursor
public virtual System.Windows.Forms.Cursor Cursor {get; set;}
public: __property virtual System.Windows.Forms.Cursor* get_Cursor();
public: __property virtual void set_Cursor(
   System.Windows.Forms.Cursor* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


CursorChanged Event

CursorChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : CursorChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event CursorChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.CursorChanged, handler
public event System.EventHandler CursorChanged
public: __event System.EventHandler* CursorChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


DataBindings Property

DataBindings Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DataBindings Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property DataBindings As System.Windows.Forms.ControlBindingsCollection
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.ControlBindingsCollection

value = instance.DataBindings
public System.Windows.Forms.ControlBindingsCollection DataBindings {get;}
public: __property System.Windows.Forms.ControlBindingsCollection* get_DataBindings();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


DisplayRectangle Property

DisplayRectangle Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DisplayRectangle Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property DisplayRectangle As System.Drawing.Rectangle
'Usage

Dim instance As QueryBuilder
Dim value As System.Drawing.Rectangle

value = instance.DisplayRectangle
public virtual System.Drawing.Rectangle DisplayRectangle {get;}
public: __property virtual System.Drawing.Rectangle get_DisplayRectangle();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Disposed Event (QueryBuilder)

Disposed Event (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Disposing Property

Disposing Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Disposing Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Disposing As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

value = instance.Disposing
public System.bool Disposing {get;}
public: __property System.bool get_Disposing();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Dock Property

Dock Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Dock Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Dock As System.Windows.Forms.DockStyle
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.DockStyle

instance.Dock = value

value = instance.Dock
public virtual System.Windows.Forms.DockStyle Dock {get; set;}
public: __property virtual System.Windows.Forms.DockStyle get_Dock();
public: __property virtual void set_Dock(
   System.Windows.Forms.DockStyle value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


DockChanged Event

DockChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DockChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DockChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.DockChanged, handler
public event System.EventHandler DockChanged
public: __event System.EventHandler* DockChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


DoDragDrop Method

DoDragDrop Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DoDragDrop Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function DoDragDrop( _
   ByVal data As System.Object, _
   ByVal allowedEffects As System.Windows.Forms.DragDropEffects _
) As System.Windows.Forms.DragDropEffects
'Usage

Dim instance As QueryBuilder
Dim data As System.Object
Dim allowedEffects As System.Windows.Forms.DragDropEffects
Dim value As System.Windows.Forms.DragDropEffects

value = instance.DoDragDrop(data, allowedEffects)
public System.Windows.Forms.DragDropEffects DoDragDrop(
   System.object data,
   System.Windows.Forms.DragDropEffects allowedEffects
)
public: System.Windows.Forms.DragDropEffects DoDragDrop(
   System.Object* data,
   System.Windows.Forms.DragDropEffects allowedEffects
)

Parameters

data
allowedEffects
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


DoubleClick Event

DoubleClick Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DoubleClick Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DoubleClick As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.DoubleClick, handler
public event System.EventHandler DoubleClick
public: __event System.EventHandler* DoubleClick
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


DragDrop Event

DragDrop Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DragDrop Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DragDrop As System.Windows.Forms.DragEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragDrop, handler
public event System.Windows.Forms.DragEventHandler DragDrop
public: __event System.Windows.Forms.DragEventHandler* DragDrop
Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


DragEnter Event

DragEnter Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DragEnter Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DragEnter As System.Windows.Forms.DragEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragEnter, handler
public event System.Windows.Forms.DragEventHandler DragEnter
public: __event System.Windows.Forms.DragEventHandler* DragEnter
Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


DragLeave Event

DragLeave Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DragLeave Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DragLeave As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.DragLeave, handler
public event System.EventHandler DragLeave
public: __event System.EventHandler* DragLeave
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


DragOver Event

DragOver Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DragOver Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DragOver As System.Windows.Forms.DragEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragOver, handler
public event System.Windows.Forms.DragEventHandler DragOver
public: __event System.Windows.Forms.DragEventHandler* DragOver
Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


DrawToBitmap Method

DrawToBitmap Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : DrawToBitmap Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub DrawToBitmap( _
   ByVal bitmap As System.Drawing.Bitmap, _
   ByVal targetBounds As System.Drawing.Rectangle _
)
'Usage

Dim instance As QueryBuilder
Dim bitmap As System.Drawing.Bitmap
Dim targetBounds As System.Drawing.Rectangle

instance.DrawToBitmap(bitmap, targetBounds)
public void DrawToBitmap(
   System.Drawing.Bitmap bitmap,
   System.Drawing.Rectangle targetBounds
)
public: void DrawToBitmap(
   System.Drawing.Bitmap* bitmap,
   System.Drawing.Rectangle targetBounds
)

Parameters

bitmap
targetBounds
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Enabled Property (QueryBuilder)

Enabled Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Enabled Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Enabled As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
public System.bool Enabled {get; set;}
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


EnabledChanged Event

EnabledChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : EnabledChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event EnabledChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.EnabledChanged, handler
public event System.EventHandler EnabledChanged
public: __event System.EventHandler* EnabledChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


EndInvoke Method

EndInvoke Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : EndInvoke Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function EndInvoke( _
   ByVal asyncResult As System.IAsyncResult _
) As System.Object
'Usage

Dim instance As QueryBuilder
Dim asyncResult As System.IAsyncResult
Dim value As System.Object

value = instance.EndInvoke(asyncResult)
public System.object EndInvoke(
   System.IAsyncResult asyncResult
)
public: System.Object* EndInvoke(
   System.IAsyncResult* asyncResult
)

Parameters

asyncResult
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Enter Event

Enter Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Enter Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Enter As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.Enter, handler
public event System.EventHandler Enter
public: __event System.EventHandler* Enter
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


FindForm Method

FindForm Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : FindForm Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function FindForm() As System.Windows.Forms.Form
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.Form

value = instance.FindForm()
public System.Windows.Forms.Form FindForm()
public: System.Windows.Forms.Form* FindForm();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Focus Method (QueryBuilder)

Focus Method (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Focus Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function Focus() As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

value = instance.Focus()
public System.bool Focus()
public: System.bool Focus();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Focused Property

Focused Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Focused Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Focused As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

value = instance.Focused
public virtual System.bool Focused {get;}
public: __property virtual System.bool get_Focused();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Font Property (QueryBuilder)

Font Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Font Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Font As System.Drawing.Font
'Usage

Dim instance As QueryBuilder
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
public virtual System.Drawing.Font Font {get; set;}
public: __property virtual System.Drawing.Font* get_Font();
public: __property virtual void set_Font(
   System.Drawing.Font* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


FontChanged Event

FontChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : FontChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event FontChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.FontChanged, handler
public event System.EventHandler FontChanged
public: __event System.EventHandler* FontChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ForeColor Property (QueryBuilder)

ForeColor Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ForeColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ForeColor As System.Drawing.Color
'Usage

Dim instance As QueryBuilder
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
public virtual System.Drawing.Color ForeColor {get; set;}
public: __property virtual System.Drawing.Color get_ForeColor();
public: __property virtual void set_ForeColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ForeColorChanged Event

ForeColorChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ForeColorChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ForeColorChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.ForeColorChanged, handler
public event System.EventHandler ForeColorChanged
public: __event System.EventHandler* ForeColorChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


GetChildAtPoint Method

GetChildAtPoint Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : GetChildAtPoint Method
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


GetChildAtPoint(Point) Method

GetChildAtPoint(Point) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetChildAtPoint( _
   ByVal pt As System.Drawing.Point _
) As System.Windows.Forms.Control
'Usage

Dim instance As QueryBuilder
Dim pt As System.Drawing.Point
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt)
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt
)
public: System.Windows.Forms.Control* GetChildAtPoint(
   System.Drawing.Point pt
)

Parameters

pt
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

GetChildAtPoint(Point,GetChildAtPointSkip) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetChildAtPoint( _
   ByVal pt As System.Drawing.Point, _
   ByVal skipValue As System.Windows.Forms.GetChildAtPointSkip _
) As System.Windows.Forms.Control
'Usage

Dim instance As QueryBuilder
Dim pt As System.Drawing.Point
Dim skipValue As System.Windows.Forms.GetChildAtPointSkip
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt, skipValue)
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)
public: System.Windows.Forms.Control* GetChildAtPoint(
   System.Drawing.Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)

Parameters

pt
skipValue
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


GetContainerControl Method

GetContainerControl Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : GetContainerControl Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetContainerControl() As System.Windows.Forms.IContainerControl
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.IContainerControl

value = instance.GetContainerControl()
public System.Windows.Forms.IContainerControl GetContainerControl()
public: System.Windows.Forms.IContainerControl* GetContainerControl();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


GetLifetimeService Method (QueryBuilder)

GetLifetimeService Method (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As QueryBuilder
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


GetNextControl Method

GetNextControl Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : GetNextControl Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean _
) As System.Windows.Forms.Control
'Usage

Dim instance As QueryBuilder
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim value As System.Windows.Forms.Control

value = instance.GetNextControl(ctl, forward)
public System.Windows.Forms.Control GetNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward
)
public: System.Windows.Forms.Control* GetNextControl(
   System.Windows.Forms.Control* ctl,
   System.bool forward
)

Parameters

ctl
forward
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


GetPreferredSize Method

GetPreferredSize Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : GetPreferredSize Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function GetPreferredSize( _
   ByVal proposedSize As System.Drawing.Size _
) As System.Drawing.Size
'Usage

Dim instance As QueryBuilder
Dim proposedSize As System.Drawing.Size
Dim value As System.Drawing.Size

value = instance.GetPreferredSize(proposedSize)
public virtual System.Drawing.Size GetPreferredSize(
   System.Drawing.Size proposedSize
)
public: virtual System.Drawing.Size GetPreferredSize(
   System.Drawing.Size proposedSize
)

Parameters

proposedSize
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


GiveFeedback Event

GiveFeedback Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : GiveFeedback Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event GiveFeedback As System.Windows.Forms.GiveFeedbackEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.GiveFeedbackEventHandler

AddHandler instance.GiveFeedback, handler
public event System.Windows.Forms.GiveFeedbackEventHandler GiveFeedback
public: __event System.Windows.Forms.GiveFeedbackEventHandler* GiveFeedback
Event Data

The event handler receives an argument of type System.Windows.Forms.GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


GotFocus Event

GotFocus Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : GotFocus Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event GotFocus As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.GotFocus, handler
public event System.EventHandler GotFocus
public: __event System.EventHandler* GotFocus
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Handle Property

Handle Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Handle Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Handle As System.IntPtr
'Usage

Dim instance As QueryBuilder
Dim value As System.IntPtr

value = instance.Handle
public System.IntPtr Handle {get;}
public: __property System.IntPtr get_Handle();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


HandleCreated Event

HandleCreated Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : HandleCreated Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event HandleCreated As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.HandleCreated, handler
public event System.EventHandler HandleCreated
public: __event System.EventHandler* HandleCreated
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


HandleDestroyed Event

HandleDestroyed Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : HandleDestroyed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event HandleDestroyed As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.HandleDestroyed, handler
public event System.EventHandler HandleDestroyed
public: __event System.EventHandler* HandleDestroyed
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


HasChildren Property

HasChildren Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : HasChildren Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property HasChildren As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

value = instance.HasChildren
public System.bool HasChildren {get;}
public: __property System.bool get_HasChildren();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Height Property (QueryBuilder)

Height Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Height Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Height As System.Integer
'Usage

Dim instance As QueryBuilder
Dim value As System.Integer

instance.Height = value

value = instance.Height
public System.int Height {get; set;}
public: __property System.int get_Height();
public: __property void set_Height(
   System.int value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


HelpRequested Event

HelpRequested Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : HelpRequested Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event HelpRequested As System.Windows.Forms.HelpEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.HelpEventHandler

AddHandler instance.HelpRequested, handler
public event System.Windows.Forms.HelpEventHandler HelpRequested
public: __event System.Windows.Forms.HelpEventHandler* HelpRequested
Event Data

The event handler receives an argument of type System.Windows.Forms.HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Hide Method

Hide Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Hide Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Hide()
'Usage

Dim instance As QueryBuilder

instance.Hide()
public void Hide()
public: void Hide();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


HorizontalScroll Property

HorizontalScroll Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : HorizontalScroll Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property HorizontalScroll As System.Windows.Forms.HScrollProperties
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.HScrollProperties

value = instance.HorizontalScroll
public System.Windows.Forms.HScrollProperties HorizontalScroll {get;}
public: __property System.Windows.Forms.HScrollProperties* get_HorizontalScroll();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ImeMode Property

ImeMode Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ImeMode Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property ImeMode As System.Windows.Forms.ImeMode
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.ImeMode

instance.ImeMode = value

value = instance.ImeMode
public System.Windows.Forms.ImeMode ImeMode {get; set;}
public: __property System.Windows.Forms.ImeMode get_ImeMode();
public: __property void set_ImeMode(
   System.Windows.Forms.ImeMode value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ImeModeChanged Event

ImeModeChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ImeModeChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ImeModeChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.ImeModeChanged, handler
public event System.EventHandler ImeModeChanged
public: __event System.EventHandler* ImeModeChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


InitializeLifetimeService Method (QueryBuilder)

InitializeLifetimeService Method (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As QueryBuilder
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Invalidate Method

Invalidate Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Invalidate Method
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Invalidate() Method

Invalidate() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > Invalidate Method : Invalidate() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub Invalidate()
'Usage

Dim instance As QueryBuilder

instance.Invalidate()
public void Invalidate()
public: void Invalidate();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


Invalidate(Boolean) Method

Invalidate(Boolean) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > Invalidate Method : Invalidate(Boolean) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As System.Boolean _
)
'Usage

Dim instance As QueryBuilder
Dim invalidateChildren As System.Boolean

instance.Invalidate(invalidateChildren)
public void Invalidate(
   System.bool invalidateChildren
)
public: void Invalidate(
   System.bool invalidateChildren
)

Parameters

invalidateChildren
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


Invalidate(Rectangle) Method

Invalidate(Rectangle) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > Invalidate Method : Invalidate(Rectangle) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub Invalidate( _
   ByVal rc As System.Drawing.Rectangle _
)
'Usage

Dim instance As QueryBuilder
Dim rc As System.Drawing.Rectangle

instance.Invalidate(rc)
public void Invalidate(
   System.Drawing.Rectangle rc
)
public: void Invalidate(
   System.Drawing.Rectangle rc
)

Parameters

rc
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


Invalidate(Rectangle,Boolean) Method

Invalidate(Rectangle,Boolean) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub Invalidate( _
   ByVal rc As System.Drawing.Rectangle, _
   ByVal invalidateChildren As System.Boolean _
)
'Usage

Dim instance As QueryBuilder
Dim rc As System.Drawing.Rectangle
Dim invalidateChildren As System.Boolean

instance.Invalidate(rc, invalidateChildren)
public void Invalidate(
   System.Drawing.Rectangle rc,
   System.bool invalidateChildren
)
public: void Invalidate(
   System.Drawing.Rectangle rc,
   System.bool invalidateChildren
)

Parameters

rc
invalidateChildren
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


Invalidate(Region) Method

Invalidate(Region) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > Invalidate Method : Invalidate(Region) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub Invalidate( _
   ByVal region As System.Drawing.Region _
)
'Usage

Dim instance As QueryBuilder
Dim region As System.Drawing.Region

instance.Invalidate(region)
public void Invalidate(
   System.Drawing.Region region
)
public: void Invalidate(
   System.Drawing.Region* region
)

Parameters

region
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


Invalidate(Region,Boolean) Method

Invalidate(Region,Boolean) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > Invalidate Method : Invalidate(Region,Boolean) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub Invalidate( _
   ByVal region As System.Drawing.Region, _
   ByVal invalidateChildren As System.Boolean _
)
'Usage

Dim instance As QueryBuilder
Dim region As System.Drawing.Region
Dim invalidateChildren As System.Boolean

instance.Invalidate(region, invalidateChildren)
public void Invalidate(
   System.Drawing.Region region,
   System.bool invalidateChildren
)
public: void Invalidate(
   System.Drawing.Region* region,
   System.bool invalidateChildren
)

Parameters

region
invalidateChildren
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


Invalidated Event

Invalidated Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Invalidated Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Invalidated As System.Windows.Forms.InvalidateEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.InvalidateEventHandler

AddHandler instance.Invalidated, handler
public event System.Windows.Forms.InvalidateEventHandler Invalidated
public: __event System.Windows.Forms.InvalidateEventHandler* Invalidated
Event Data

The event handler receives an argument of type System.Windows.Forms.InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Invoke Method

Invoke Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Invoke Method
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Invoke(Delegate) Method

Invoke(Delegate) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > Invoke Method : Invoke(Delegate) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function Invoke( _
   ByVal method As System.Delegate _
) As System.Object
'Usage

Dim instance As QueryBuilder
Dim method As System.Delegate
Dim value As System.Object

value = instance.Invoke(method)
public System.object Invoke(
   System.Delegate method
)
public: System.Object* Invoke(
   System.Delegate* method
)

Parameters

method
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


Invoke(Delegate,Object[]) Method

Invoke(Delegate,Object[]) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > Invoke Method : Invoke(Delegate,Object[]) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function Invoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.Object
'Usage

Dim instance As QueryBuilder
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.Object

value = instance.Invoke(method, args)
public System.object Invoke(
   System.Delegate method,
   params System.object[] args
)
public: System.Object* Invoke(
   System.Delegate* method,
   params System.Object*[]* args
)

Parameters

method
args
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


InvokeRequired Property

InvokeRequired Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : InvokeRequired Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property InvokeRequired As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

value = instance.InvokeRequired
public System.bool InvokeRequired {get;}
public: __property System.bool get_InvokeRequired();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


IsAccessible Property

IsAccessible Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : IsAccessible Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property IsAccessible As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

instance.IsAccessible = value

value = instance.IsAccessible
public System.bool IsAccessible {get; set;}
public: __property System.bool get_IsAccessible();
public: __property void set_IsAccessible(
   System.bool value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


IsDisposed Property

IsDisposed Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : IsDisposed Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property IsDisposed As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

value = instance.IsDisposed
public System.bool IsDisposed {get;}
public: __property System.bool get_IsDisposed();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


IsHandleCreated Property

IsHandleCreated Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : IsHandleCreated Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property IsHandleCreated As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

value = instance.IsHandleCreated
public System.bool IsHandleCreated {get;}
public: __property System.bool get_IsHandleCreated();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


IsMirrored Property

IsMirrored Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : IsMirrored Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property IsMirrored As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

value = instance.IsMirrored
public System.bool IsMirrored {get;}
public: __property System.bool get_IsMirrored();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


KeyDown Event

KeyDown Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : KeyDown Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event KeyDown As System.Windows.Forms.KeyEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyDown, handler
public event System.Windows.Forms.KeyEventHandler KeyDown
public: __event System.Windows.Forms.KeyEventHandler* KeyDown
Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


KeyPress Event

KeyPress Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : KeyPress Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event KeyPress As System.Windows.Forms.KeyPressEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.KeyPressEventHandler

AddHandler instance.KeyPress, handler
public event System.Windows.Forms.KeyPressEventHandler KeyPress
public: __event System.Windows.Forms.KeyPressEventHandler* KeyPress
Event Data

The event handler receives an argument of type System.Windows.Forms.KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


KeyUp Event

KeyUp Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : KeyUp Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event KeyUp As System.Windows.Forms.KeyEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyUp, handler
public event System.Windows.Forms.KeyEventHandler KeyUp
public: __event System.Windows.Forms.KeyEventHandler* KeyUp
Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Layout Event

Layout Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Layout Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Layout As System.Windows.Forms.LayoutEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.LayoutEventHandler

AddHandler instance.Layout, handler
public event System.Windows.Forms.LayoutEventHandler Layout
public: __event System.Windows.Forms.LayoutEventHandler* Layout
Event Data

The event handler receives an argument of type System.Windows.Forms.LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


LayoutEngine Property

LayoutEngine Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : LayoutEngine Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property LayoutEngine As System.Windows.Forms.Layout.LayoutEngine
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.Layout.LayoutEngine

value = instance.LayoutEngine
public virtual System.Windows.Forms.Layout.LayoutEngine LayoutEngine {get;}
public: __property virtual System.Windows.Forms.Layout.LayoutEngine* get_LayoutEngine();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Leave Event

Leave Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Leave Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Leave As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.Leave, handler
public event System.EventHandler Leave
public: __event System.EventHandler* Leave
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Left Property

Left Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Left Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Left As System.Integer
'Usage

Dim instance As QueryBuilder
Dim value As System.Integer

instance.Left = value

value = instance.Left
public System.int Left {get; set;}
public: __property System.int get_Left();
public: __property void set_Left(
   System.int value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Load Event (QueryBuilder)

Load Event (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Load Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Load As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.Load, handler
public event System.EventHandler Load
public: __event System.EventHandler* Load
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Location Property

Location Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Location Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Location As System.Drawing.Point
'Usage

Dim instance As QueryBuilder
Dim value As System.Drawing.Point

instance.Location = value

value = instance.Location
public System.Drawing.Point Location {get; set;}
public: __property System.Drawing.Point get_Location();
public: __property void set_Location(
   System.Drawing.Point value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


LocationChanged Event

LocationChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : LocationChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event LocationChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.LocationChanged, handler
public event System.EventHandler LocationChanged
public: __event System.EventHandler* LocationChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


LostFocus Event

LostFocus Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : LostFocus Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event LostFocus As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.LostFocus, handler
public event System.EventHandler LostFocus
public: __event System.EventHandler* LostFocus
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Margin Property (QueryBuilder)

Margin Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Margin Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Margin As System.Windows.Forms.Padding
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.Padding

instance.Margin = value

value = instance.Margin
public System.Windows.Forms.Padding Margin {get; set;}
public: __property System.Windows.Forms.Padding get_Margin();
public: __property void set_Margin(
   System.Windows.Forms.Padding value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


MarginChanged Event

MarginChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : MarginChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event MarginChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.MarginChanged, handler
public event System.EventHandler MarginChanged
public: __event System.EventHandler* MarginChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


MaximumSize Property

MaximumSize Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : MaximumSize Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property MaximumSize As System.Drawing.Size
'Usage

Dim instance As QueryBuilder
Dim value As System.Drawing.Size

instance.MaximumSize = value

value = instance.MaximumSize
public virtual System.Drawing.Size MaximumSize {get; set;}
public: __property virtual System.Drawing.Size get_MaximumSize();
public: __property virtual void set_MaximumSize(
   System.Drawing.Size value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


MinimumSize Property (QueryBuilder)

MinimumSize Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : MinimumSize Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property MinimumSize As System.Drawing.Size
'Usage

Dim instance As QueryBuilder
Dim value As System.Drawing.Size

instance.MinimumSize = value

value = instance.MinimumSize
public virtual System.Drawing.Size MinimumSize {get; set;}
public: __property virtual System.Drawing.Size get_MinimumSize();
public: __property virtual void set_MinimumSize(
   System.Drawing.Size value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


MouseCaptureChanged Event

MouseCaptureChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : MouseCaptureChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event MouseCaptureChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.MouseCaptureChanged, handler
public event System.EventHandler MouseCaptureChanged
public: __event System.EventHandler* MouseCaptureChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


MouseClick Event

MouseClick Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : MouseClick Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event MouseClick As System.Windows.Forms.MouseEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseClick, handler
public event System.Windows.Forms.MouseEventHandler MouseClick
public: __event System.Windows.Forms.MouseEventHandler* MouseClick
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


MouseDoubleClick Event

MouseDoubleClick Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : MouseDoubleClick Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event MouseDoubleClick As System.Windows.Forms.MouseEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDoubleClick, handler
public event System.Windows.Forms.MouseEventHandler MouseDoubleClick
public: __event System.Windows.Forms.MouseEventHandler* MouseDoubleClick
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


MouseDown Event

MouseDown Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : MouseDown Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event MouseDown As System.Windows.Forms.MouseEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDown, handler
public event System.Windows.Forms.MouseEventHandler MouseDown
public: __event System.Windows.Forms.MouseEventHandler* MouseDown
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


MouseEnter Event

MouseEnter Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : MouseEnter Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event MouseEnter As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.MouseEnter, handler
public event System.EventHandler MouseEnter
public: __event System.EventHandler* MouseEnter
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


MouseHover Event

MouseHover Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : MouseHover Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event MouseHover As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.MouseHover, handler
public event System.EventHandler MouseHover
public: __event System.EventHandler* MouseHover
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


MouseLeave Event

MouseLeave Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : MouseLeave Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event MouseLeave As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.MouseLeave, handler
public event System.EventHandler MouseLeave
public: __event System.EventHandler* MouseLeave
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


MouseMove Event

MouseMove Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : MouseMove Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event MouseMove As System.Windows.Forms.MouseEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseMove, handler
public event System.Windows.Forms.MouseEventHandler MouseMove
public: __event System.Windows.Forms.MouseEventHandler* MouseMove
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


MouseUp Event

MouseUp Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : MouseUp Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event MouseUp As System.Windows.Forms.MouseEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseUp, handler
public event System.Windows.Forms.MouseEventHandler MouseUp
public: __event System.Windows.Forms.MouseEventHandler* MouseUp
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


MouseWheel Event

MouseWheel Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : MouseWheel Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event MouseWheel As System.Windows.Forms.MouseEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseWheel, handler
public event System.Windows.Forms.MouseEventHandler MouseWheel
public: __event System.Windows.Forms.MouseEventHandler* MouseWheel
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Move Event

Move Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Move Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Move As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.Move, handler
public event System.EventHandler Move
public: __event System.EventHandler* Move
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Name Property (QueryBuilder)

Name Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Name Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Name As System.String
'Usage

Dim instance As QueryBuilder
Dim value As System.String

instance.Name = value

value = instance.Name
public System.string Name {get; set;}
public: __property System.string* get_Name();
public: __property void set_Name(
   System.string* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Padding Property

Padding Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Padding Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Padding As System.Windows.Forms.Padding
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.Padding

instance.Padding = value

value = instance.Padding
public System.Windows.Forms.Padding Padding {get; set;}
public: __property System.Windows.Forms.Padding get_Padding();
public: __property void set_Padding(
   System.Windows.Forms.Padding value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


PaddingChanged Event

PaddingChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : PaddingChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event PaddingChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.PaddingChanged, handler
public event System.EventHandler PaddingChanged
public: __event System.EventHandler* PaddingChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Paint Event

Paint Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Paint Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Paint As System.Windows.Forms.PaintEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.PaintEventHandler

AddHandler instance.Paint, handler
public event System.Windows.Forms.PaintEventHandler Paint
public: __event System.Windows.Forms.PaintEventHandler* Paint
Event Data

The event handler receives an argument of type System.Windows.Forms.PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Parent Property (QueryBuilder)

Parent Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Parent Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Parent As System.Windows.Forms.Control
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.Control

instance.Parent = value

value = instance.Parent
public System.Windows.Forms.Control Parent {get; set;}
public: __property System.Windows.Forms.Control* get_Parent();
public: __property void set_Parent(
   System.Windows.Forms.Control* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ParentChanged Event

ParentChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ParentChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event ParentChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.ParentChanged, handler
public event System.EventHandler ParentChanged
public: __event System.EventHandler* ParentChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ParentForm Property

ParentForm Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ParentForm Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ParentForm As System.Windows.Forms.Form
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.Form

value = instance.ParentForm
public System.Windows.Forms.Form ParentForm {get;}
public: __property System.Windows.Forms.Form* get_ParentForm();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


PerformAutoScale Method

PerformAutoScale Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : PerformAutoScale Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub PerformAutoScale()
'Usage

Dim instance As QueryBuilder

instance.PerformAutoScale()
public void PerformAutoScale()
public: void PerformAutoScale();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


PerformLayout Method

PerformLayout Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : PerformLayout Method
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


PerformLayout() Method

PerformLayout() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > PerformLayout Method : PerformLayout() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub PerformLayout()
'Usage

Dim instance As QueryBuilder

instance.PerformLayout()
public void PerformLayout()
public: void PerformLayout();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


PerformLayout(Control,String) Method

PerformLayout(Control,String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > PerformLayout Method : PerformLayout(Control,String) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub PerformLayout( _
   ByVal affectedControl As System.Windows.Forms.Control, _
   ByVal affectedProperty As System.String _
)
'Usage

Dim instance As QueryBuilder
Dim affectedControl As System.Windows.Forms.Control
Dim affectedProperty As System.String

instance.PerformLayout(affectedControl, affectedProperty)
public void PerformLayout(
   System.Windows.Forms.Control affectedControl,
   System.string affectedProperty
)
public: void PerformLayout(
   System.Windows.Forms.Control* affectedControl,
   System.string* affectedProperty
)

Parameters

affectedControl
affectedProperty
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


PointToClient Method

PointToClient Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : PointToClient Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function PointToClient( _
   ByVal p As System.Drawing.Point _
) As System.Drawing.Point
'Usage

Dim instance As QueryBuilder
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToClient(p)
public System.Drawing.Point PointToClient(
   System.Drawing.Point p
)
public: System.Drawing.Point PointToClient(
   System.Drawing.Point p
)

Parameters

p
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


PointToScreen Method

PointToScreen Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : PointToScreen Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function PointToScreen( _
   ByVal p As System.Drawing.Point _
) As System.Drawing.Point
'Usage

Dim instance As QueryBuilder
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToScreen(p)
public System.Drawing.Point PointToScreen(
   System.Drawing.Point p
)
public: System.Drawing.Point PointToScreen(
   System.Drawing.Point p
)

Parameters

p
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


PreferredSize Property

PreferredSize Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : PreferredSize Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property PreferredSize As System.Drawing.Size
'Usage

Dim instance As QueryBuilder
Dim value As System.Drawing.Size

value = instance.PreferredSize
public System.Drawing.Size PreferredSize {get;}
public: __property System.Drawing.Size get_PreferredSize();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


PreProcessControlMessage Method

PreProcessControlMessage Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : PreProcessControlMessage Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function PreProcessControlMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Windows.Forms.PreProcessControlState
'Usage

Dim instance As QueryBuilder
Dim msg As System.Windows.Forms.Message
Dim value As System.Windows.Forms.PreProcessControlState

value = instance.PreProcessControlMessage(msg)
public System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)
public: System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


PreProcessMessage Method

PreProcessMessage Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : PreProcessMessage Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function PreProcessMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim msg As System.Windows.Forms.Message
Dim value As System.Boolean

value = instance.PreProcessMessage(msg)
public virtual System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)
public: virtual System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


PreviewKeyDown Event

PreviewKeyDown Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : PreviewKeyDown Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event PreviewKeyDown As System.Windows.Forms.PreviewKeyDownEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.PreviewKeyDownEventHandler

AddHandler instance.PreviewKeyDown, handler
public event System.Windows.Forms.PreviewKeyDownEventHandler PreviewKeyDown
public: __event System.Windows.Forms.PreviewKeyDownEventHandler* PreviewKeyDown
Event Data

The event handler receives an argument of type System.Windows.Forms.PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ProductName Property

ProductName Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ProductName Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ProductName As System.String
'Usage

Dim instance As QueryBuilder
Dim value As System.String

value = instance.ProductName
public System.string ProductName {get;}
public: __property System.string* get_ProductName();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ProductVersion Property

ProductVersion Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ProductVersion Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ProductVersion As System.String
'Usage

Dim instance As QueryBuilder
Dim value As System.String

value = instance.ProductVersion
public System.string ProductVersion {get;}
public: __property System.string* get_ProductVersion();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


QueryAccessibilityHelp Event

QueryAccessibilityHelp Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : QueryAccessibilityHelp Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event QueryAccessibilityHelp As System.Windows.Forms.QueryAccessibilityHelpEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.QueryAccessibilityHelpEventHandler

AddHandler instance.QueryAccessibilityHelp, handler
public event System.Windows.Forms.QueryAccessibilityHelpEventHandler QueryAccessibilityHelp
public: __event System.Windows.Forms.QueryAccessibilityHelpEventHandler* QueryAccessibilityHelp
Event Data

The event handler receives an argument of type System.Windows.Forms.QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


QueryContinueDrag Event

QueryContinueDrag Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : QueryContinueDrag Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event QueryContinueDrag As System.Windows.Forms.QueryContinueDragEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.QueryContinueDragEventHandler

AddHandler instance.QueryContinueDrag, handler
public event System.Windows.Forms.QueryContinueDragEventHandler QueryContinueDrag
public: __event System.Windows.Forms.QueryContinueDragEventHandler* QueryContinueDrag
Event Data

The event handler receives an argument of type System.Windows.Forms.QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


RecreatingHandle Property

RecreatingHandle Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : RecreatingHandle Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property RecreatingHandle As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

value = instance.RecreatingHandle
public System.bool RecreatingHandle {get;}
public: __property System.bool get_RecreatingHandle();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


RectangleToClient Method

RectangleToClient Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : RectangleToClient Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function RectangleToClient( _
   ByVal r As System.Drawing.Rectangle _
) As System.Drawing.Rectangle
'Usage

Dim instance As QueryBuilder
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToClient(r)
public System.Drawing.Rectangle RectangleToClient(
   System.Drawing.Rectangle r
)
public: System.Drawing.Rectangle RectangleToClient(
   System.Drawing.Rectangle r
)

Parameters

r
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


RectangleToScreen Method

RectangleToScreen Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : RectangleToScreen Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function RectangleToScreen( _
   ByVal r As System.Drawing.Rectangle _
) As System.Drawing.Rectangle
'Usage

Dim instance As QueryBuilder
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToScreen(r)
public System.Drawing.Rectangle RectangleToScreen(
   System.Drawing.Rectangle r
)
public: System.Drawing.Rectangle RectangleToScreen(
   System.Drawing.Rectangle r
)

Parameters

r
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Refresh Method

Refresh Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Refresh Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub Refresh()
'Usage

Dim instance As QueryBuilder

instance.Refresh()
public virtual void Refresh()
public: virtual void Refresh();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


RefreshDatasourcesMetadata Method

RefreshDatasourcesMetadata Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : RefreshDatasourcesMetadata Method
Refreshes the list of fields for datasources of the current query.
Overload List
Overload | Description
RefreshDatasourcesMetadata | Refreshes the list of fields for datasources of the current query.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Region Property

Region Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Region Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Region As System.Drawing.Region
'Usage

Dim instance As QueryBuilder
Dim value As System.Drawing.Region

instance.Region = value

value = instance.Region
public System.Drawing.Region Region {get; set;}
public: __property System.Drawing.Region* get_Region();
public: __property void set_Region(
   System.Drawing.Region* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


RegionChanged Event

RegionChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : RegionChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event RegionChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.RegionChanged, handler
public event System.EventHandler RegionChanged
public: __event System.EventHandler* RegionChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ResetText Method

ResetText Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ResetText Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub ResetText()
'Usage

Dim instance As QueryBuilder

instance.ResetText()
public virtual void ResetText()
public: virtual void ResetText();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Resize Event

Resize Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Resize Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Resize As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.Resize, handler
public event System.EventHandler Resize
public: __event System.EventHandler* Resize
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ResumeLayout Method

ResumeLayout Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ResumeLayout Method
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ResumeLayout() Method

ResumeLayout() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > ResumeLayout Method : ResumeLayout() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub ResumeLayout()
'Usage

Dim instance As QueryBuilder

instance.ResumeLayout()
public void ResumeLayout()
public: void ResumeLayout();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


ResumeLayout(Boolean) Method

ResumeLayout(Boolean) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > ResumeLayout Method : ResumeLayout(Boolean) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub ResumeLayout( _
   ByVal performLayout As System.Boolean _
)
'Usage

Dim instance As QueryBuilder
Dim performLayout As System.Boolean

instance.ResumeLayout(performLayout)
public void ResumeLayout(
   System.bool performLayout
)
public: void ResumeLayout(
   System.bool performLayout
)

Parameters

performLayout
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


Right Property

Right Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Right Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Right As System.Integer
'Usage

Dim instance As QueryBuilder
Dim value As System.Integer

value = instance.Right
public System.int Right {get;}
public: __property System.int get_Right();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


RightToLeft Property

RightToLeft Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : RightToLeft Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property RightToLeft As System.Windows.Forms.RightToLeft
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.RightToLeft

instance.RightToLeft = value

value = instance.RightToLeft
public virtual System.Windows.Forms.RightToLeft RightToLeft {get; set;}
public: __property virtual System.Windows.Forms.RightToLeft get_RightToLeft();
public: __property virtual void set_RightToLeft(
   System.Windows.Forms.RightToLeft value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


RightToLeftChanged Event

RightToLeftChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : RightToLeftChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event RightToLeftChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.RightToLeftChanged, handler
public event System.EventHandler RightToLeftChanged
public: __event System.EventHandler* RightToLeftChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Scale Method

Scale Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Scale Method
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Scale(SizeF) Method

Scale(SizeF) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > Scale Method : Scale(SizeF) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub Scale( _
   ByVal factor As System.Drawing.SizeF _
)
'Usage

Dim instance As QueryBuilder
Dim factor As System.Drawing.SizeF

instance.Scale(factor)
public void Scale(
   System.Drawing.SizeF factor
)
public: void Scale(
   System.Drawing.SizeF factor
)

Parameters

factor
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


Scroll Event

Scroll Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Scroll Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Scroll As System.Windows.Forms.ScrollEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.Windows.Forms.ScrollEventHandler

AddHandler instance.Scroll, handler
public event System.Windows.Forms.ScrollEventHandler Scroll
public: __event System.Windows.Forms.ScrollEventHandler* Scroll
Event Data

The event handler receives an argument of type System.Windows.Forms.ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets or sets the new System.Windows.Forms.ScrollBar.Value of the scroll bar.
OldValue | Gets the old System.Windows.Forms.ScrollBar.Value of the scroll bar.
ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Type | Gets the type of scroll event that occurred.
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ScrollControlIntoView Method

ScrollControlIntoView Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ScrollControlIntoView Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ScrollControlIntoView( _
   ByVal activeControl As System.Windows.Forms.Control _
)
'Usage

Dim instance As QueryBuilder
Dim activeControl As System.Windows.Forms.Control

instance.ScrollControlIntoView(activeControl)
public void ScrollControlIntoView(
   System.Windows.Forms.Control activeControl
)
public: void ScrollControlIntoView(
   System.Windows.Forms.Control* activeControl
)

Parameters

activeControl
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Select Method

Select Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Select Method
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Select() Method

Select() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Select() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Select()
'Usage

Dim instance As QueryBuilder

instance.Select()
public void Select()
public: void Select();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


SelectNextControl Method

SelectNextControl Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : SelectNextControl Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function SelectNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean, _
   ByVal tabStopOnly As System.Boolean, _
   ByVal nested As System.Boolean, _
   ByVal wrap As System.Boolean _
) As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim tabStopOnly As System.Boolean
Dim nested As System.Boolean
Dim wrap As System.Boolean
Dim value As System.Boolean

value = instance.SelectNextControl(ctl, forward, tabStopOnly, nested, wrap)
public System.bool SelectNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)
public: System.bool SelectNextControl(
   System.Windows.Forms.Control* ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)

Parameters

ctl
forward
tabStopOnly
nested
wrap
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


SendToBack Method

SendToBack Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : SendToBack Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub SendToBack()
'Usage

Dim instance As QueryBuilder

instance.SendToBack()
public void SendToBack()
public: void SendToBack();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


SetAutoScrollMargin Method

SetAutoScrollMargin Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : SetAutoScrollMargin Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub SetAutoScrollMargin( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer _
)
'Usage

Dim instance As QueryBuilder
Dim x As System.Integer
Dim y As System.Integer

instance.SetAutoScrollMargin(x, y)
public void SetAutoScrollMargin(
   System.int x,
   System.int y
)
public: void SetAutoScrollMargin(
   System.int x,
   System.int y
)

Parameters

x
y
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


SetBounds Method

SetBounds Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : SetBounds Method
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


SetBounds(Int32,Int32,Int32,Int32) Method

SetBounds(Int32,Int32,Int32,Int32) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer _
)
'Usage

Dim instance As QueryBuilder
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer

instance.SetBounds(x, y, width, height)
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)
public: void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
y
width
height
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer, _
   ByVal specified As System.Windows.Forms.BoundsSpecified _
)
'Usage

Dim instance As QueryBuilder
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer
Dim specified As System.Windows.Forms.BoundsSpecified

instance.SetBounds(x, y, width, height, specified)
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)
public: void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)

Parameters

x
y
width
height
specified
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


Show Method

Show Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Show Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Show()
'Usage

Dim instance As QueryBuilder

instance.Show()
public void Show()
public: void Show();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Site Property (QueryBuilder)

Site Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As QueryBuilder
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Size Property (QueryBuilder)

Size Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Size Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Size As System.Drawing.Size
'Usage

Dim instance As QueryBuilder
Dim value As System.Drawing.Size

instance.Size = value

value = instance.Size
public System.Drawing.Size Size {get; set;}
public: __property System.Drawing.Size get_Size();
public: __property void set_Size(
   System.Drawing.Size value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


SizeChanged Event

SizeChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : SizeChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event SizeChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.SizeChanged, handler
public event System.EventHandler SizeChanged
public: __event System.EventHandler* SizeChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


StyleChanged Event

StyleChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : StyleChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event StyleChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.StyleChanged, handler
public event System.EventHandler StyleChanged
public: __event System.EventHandler* StyleChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


SuspendLayout Method

SuspendLayout Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : SuspendLayout Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub SuspendLayout()
'Usage

Dim instance As QueryBuilder

instance.SuspendLayout()
public void SuspendLayout()
public: void SuspendLayout();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


SystemColorsChanged Event

SystemColorsChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : SystemColorsChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event SystemColorsChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.SystemColorsChanged, handler
public event System.EventHandler SystemColorsChanged
public: __event System.EventHandler* SystemColorsChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


TabIndex Property (QueryBuilder)

TabIndex Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : TabIndex Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property TabIndex As System.Integer
'Usage

Dim instance As QueryBuilder
Dim value As System.Integer

instance.TabIndex = value

value = instance.TabIndex
public System.int TabIndex {get; set;}
public: __property System.int get_TabIndex();
public: __property void set_TabIndex(
   System.int value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


TabIndexChanged Event

TabIndexChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : TabIndexChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event TabIndexChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.TabIndexChanged, handler
public event System.EventHandler TabIndexChanged
public: __event System.EventHandler* TabIndexChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


TabStop Property

TabStop Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : TabStop Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property TabStop As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

instance.TabStop = value

value = instance.TabStop
public System.bool TabStop {get; set;}
public: __property System.bool get_TabStop();
public: __property void set_TabStop(
   System.bool value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


TabStopChanged Event

TabStopChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : TabStopChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event TabStopChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.TabStopChanged, handler
public event System.EventHandler TabStopChanged
public: __event System.EventHandler* TabStopChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Tag Property

Tag Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Tag Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Tag As System.Object
'Usage

Dim instance As QueryBuilder
Dim value As System.Object

instance.Tag = value

value = instance.Tag
public System.object Tag {get; set;}
public: __property System.Object* get_Tag();
public: __property void set_Tag(
   System.Object* value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Top Property

Top Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Top Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Top As System.Integer
'Usage

Dim instance As QueryBuilder
Dim value As System.Integer

instance.Top = value

value = instance.Top
public System.int Top {get; set;}
public: __property System.int get_Top();
public: __property void set_Top(
   System.int value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


TopLevelControl Property

TopLevelControl Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : TopLevelControl Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property TopLevelControl As System.Windows.Forms.Control
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.Control

value = instance.TopLevelControl
public System.Windows.Forms.Control TopLevelControl {get;}
public: __property System.Windows.Forms.Control* get_TopLevelControl();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ToString Method (QueryBuilder)

ToString Method (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function ToString() As System.String
'Usage

Dim instance As QueryBuilder
Dim value As System.String

value = instance.ToString()
public virtual System.string ToString()
public: virtual System.string* ToString();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Update Method

Update Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Update Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Update()
'Usage

Dim instance As QueryBuilder

instance.Update()
public void Update()
public: void Update();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


UseWaitCursor Property

UseWaitCursor Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : UseWaitCursor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property UseWaitCursor As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

instance.UseWaitCursor = value

value = instance.UseWaitCursor
public System.bool UseWaitCursor {get; set;}
public: __property System.bool get_UseWaitCursor();
public: __property void set_UseWaitCursor(
   System.bool value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Validate Method

Validate Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Validate Method
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Validate() Method

Validate() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > Validate Method : Validate() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function Validate() As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

value = instance.Validate()
public System.bool Validate()
public: System.bool Validate();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


Validate(Boolean) Method

Validate(Boolean) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > Validate Method : Validate(Boolean) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function Validate( _
   ByVal checkAutoValidate As System.Boolean _
) As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim checkAutoValidate As System.Boolean
Dim value As System.Boolean

value = instance.Validate(checkAutoValidate)
public System.bool Validate(
   System.bool checkAutoValidate
)
public: System.bool Validate(
   System.bool checkAutoValidate
)

Parameters

checkAutoValidate
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


ValidateChildren Method

ValidateChildren Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : ValidateChildren Method
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


ValidateChildren() Method

ValidateChildren() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > ValidateChildren Method : ValidateChildren() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Overridable Function ValidateChildren() As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

value = instance.ValidateChildren()
public virtual System.bool ValidateChildren()
public: virtual System.bool ValidateChildren();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


ValidateChildren(ValidationConstraints) Method

ValidateChildren(ValidationConstraints) Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class > ValidateChildren Method : ValidateChildren(ValidationConstraints) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Overridable Function ValidateChildren( _
   ByVal validationConstraints As System.Windows.Forms.ValidationConstraints _
) As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim validationConstraints As System.Windows.Forms.ValidationConstraints
Dim value As System.Boolean

value = instance.ValidateChildren(validationConstraints)
public virtual System.bool ValidateChildren(
   System.Windows.Forms.ValidationConstraints validationConstraints
)
public: virtual System.bool ValidateChildren(
   System.Windows.Forms.ValidationConstraints validationConstraints
)

Parameters

validationConstraints
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members
Overload List


Validated Event

Validated Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Validated Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Validated As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.Validated, handler
public event System.EventHandler Validated
public: __event System.EventHandler* Validated
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Validating Event

Validating Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Validating Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Validating As System.ComponentModel.CancelEventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.ComponentModel.CancelEventHandler

AddHandler instance.Validating, handler
public event System.ComponentModel.CancelEventHandler Validating
public: __event System.ComponentModel.CancelEventHandler* Validating
Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


VerticalScroll Property

VerticalScroll Property

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : VerticalScroll Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property VerticalScroll As System.Windows.Forms.VScrollProperties
'Usage

Dim instance As QueryBuilder
Dim value As System.Windows.Forms.VScrollProperties

value = instance.VerticalScroll
public System.Windows.Forms.VScrollProperties VerticalScroll {get;}
public: __property System.Windows.Forms.VScrollProperties* get_VerticalScroll();
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Visible Property (QueryBuilder)

Visible Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Visible Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Visible As System.Boolean
'Usage

Dim instance As QueryBuilder
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
public System.bool Visible {get; set;}
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


VisibleChanged Event

VisibleChanged Event

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : VisibleChanged Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event VisibleChanged As System.EventHandler
'Usage

Dim instance As QueryBuilder
Dim handler As System.EventHandler

AddHandler instance.VisibleChanged, handler
public event System.EventHandler VisibleChanged
public: __event System.EventHandler* VisibleChanged
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


Width Property (QueryBuilder)

Width Property (QueryBuilder)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > QueryBuilder Class : Width Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Width As System.Integer
'Usage

Dim instance As QueryBuilder
Dim value As System.Integer

instance.Width = value

value = instance.Width
public System.int Width {get; set;}
public: __property System.int get_Width();
public: __property void set_Width(
   System.int value
);
Requirements

See Also

Reference

QueryBuilder Class
QueryBuilder Members


SQL89SyntaxProvider Class Events

SQL89SyntaxProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQL89SyntaxProvider Class

For a list of all members of this type, see SQL89SyntaxProvider members.

See Also

Reference

SQL89SyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQL89SyntaxProvider Class Methods

SQL89SyntaxProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQL89SyntaxProvider Class

For a list of all members of this type, see SQL89SyntaxProvider members.

See Also

Reference

SQL89SyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Container Property (SQL89SyntaxProvider)

Container Property (SQL89SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL89SyntaxProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As SQL89SyntaxProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

SQL89SyntaxProvider Class
SQL89SyntaxProvider Members


CreateObjRef Method (SQL89SyntaxProvider)

CreateObjRef Method (SQL89SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL89SyntaxProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As SQL89SyntaxProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

SQL89SyntaxProvider Class
SQL89SyntaxProvider Members


Dispose Method (SQL89SyntaxProvider)

Dispose Method (SQL89SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL89SyntaxProvider Class : Dispose Method
Requirements

See Also

Reference

SQL89SyntaxProvider Class
SQL89SyntaxProvider Members


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL89SyntaxProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As SQL89SyntaxProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

SQL89SyntaxProvider Class
SQL89SyntaxProvider Members


Disposed Event (SQL89SyntaxProvider)

Disposed Event (SQL89SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL89SyntaxProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As SQL89SyntaxProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

SQL89SyntaxProvider Class
SQL89SyntaxProvider Members


GetLifetimeService Method (SQL89SyntaxProvider)

GetLifetimeService Method (SQL89SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL89SyntaxProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As SQL89SyntaxProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

SQL89SyntaxProvider Class
SQL89SyntaxProvider Members


InitializeLifetimeService Method (SQL89SyntaxProvider)

InitializeLifetimeService Method (SQL89SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL89SyntaxProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As SQL89SyntaxProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

SQL89SyntaxProvider Class
SQL89SyntaxProvider Members


Site Property (SQL89SyntaxProvider)

Site Property (SQL89SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL89SyntaxProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As SQL89SyntaxProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

SQL89SyntaxProvider Class
SQL89SyntaxProvider Members


SQL92SyntaxProvider Class Events

SQL92SyntaxProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQL92SyntaxProvider Class

For a list of all members of this type, see SQL92SyntaxProvider members.

See Also

Reference

SQL92SyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQL92SyntaxProvider Class Methods

SQL92SyntaxProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQL92SyntaxProvider Class

For a list of all members of this type, see SQL92SyntaxProvider members.

See Also

Reference

SQL92SyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Container Property (SQL92SyntaxProvider)

Container Property (SQL92SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL92SyntaxProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As SQL92SyntaxProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

SQL92SyntaxProvider Class
SQL92SyntaxProvider Members


CreateObjRef Method (SQL92SyntaxProvider)

CreateObjRef Method (SQL92SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL92SyntaxProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As SQL92SyntaxProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

SQL92SyntaxProvider Class
SQL92SyntaxProvider Members


Disposed Event (SQL92SyntaxProvider)

Disposed Event (SQL92SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL92SyntaxProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As SQL92SyntaxProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

SQL92SyntaxProvider Class
SQL92SyntaxProvider Members


GetLifetimeService Method (SQL92SyntaxProvider)

GetLifetimeService Method (SQL92SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL92SyntaxProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As SQL92SyntaxProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

SQL92SyntaxProvider Class
SQL92SyntaxProvider Members


InitializeLifetimeService Method (SQL92SyntaxProvider)

InitializeLifetimeService Method (SQL92SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL92SyntaxProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As SQL92SyntaxProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

SQL92SyntaxProvider Class
SQL92SyntaxProvider Members


Site Property (SQL92SyntaxProvider)

Site Property (SQL92SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL92SyntaxProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As SQL92SyntaxProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

SQL92SyntaxProvider Class
SQL92SyntaxProvider Members


SQL2003SyntaxProvider Class Events

SQL2003SyntaxProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQL2003SyntaxProvider Class

For a list of all members of this type, see SQL2003SyntaxProvider members.

See Also

Reference

SQL2003SyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SQL2003SyntaxProvider Class Methods

SQL2003SyntaxProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SQL2003SyntaxProvider Class

For a list of all members of this type, see SQL2003SyntaxProvider members.

See Also

Reference

SQL2003SyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Container Property (SQL2003SyntaxProvider)

Container Property (SQL2003SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL2003SyntaxProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As SQL2003SyntaxProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

SQL2003SyntaxProvider Class
SQL2003SyntaxProvider Members


CreateObjRef Method (SQL2003SyntaxProvider)

CreateObjRef Method (SQL2003SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL2003SyntaxProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As SQL2003SyntaxProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

SQL2003SyntaxProvider Class
SQL2003SyntaxProvider Members


Disposed Event (SQL2003SyntaxProvider)

Disposed Event (SQL2003SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL2003SyntaxProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As SQL2003SyntaxProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

SQL2003SyntaxProvider Class
SQL2003SyntaxProvider Members


GetLifetimeService Method (SQL2003SyntaxProvider)

GetLifetimeService Method (SQL2003SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL2003SyntaxProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As SQL2003SyntaxProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

SQL2003SyntaxProvider Class
SQL2003SyntaxProvider Members


InitializeLifetimeService Method (SQL2003SyntaxProvider)

InitializeLifetimeService Method (SQL2003SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL2003SyntaxProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As SQL2003SyntaxProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

SQL2003SyntaxProvider Class
SQL2003SyntaxProvider Members


Site Property (SQL2003SyntaxProvider)

Site Property (SQL2003SyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SQL2003SyntaxProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As SQL2003SyntaxProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

SQL2003SyntaxProvider Class
SQL2003SyntaxProvider Members


SybaseSyntaxProvider Class Events

SybaseSyntaxProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SybaseSyntaxProvider Class

For a list of all members of this type, see SybaseSyntaxProvider members.

See Also

Reference

SybaseSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SybaseSyntaxProvider Class Methods

SybaseSyntaxProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SybaseSyntaxProvider Class

For a list of all members of this type, see SybaseSyntaxProvider members.

See Also

Reference

SybaseSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Container Property (SybaseSyntaxProvider)

Container Property (SybaseSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseSyntaxProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As SybaseSyntaxProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

SybaseSyntaxProvider Class
SybaseSyntaxProvider Members


CreateObjRef Method (SybaseSyntaxProvider)

CreateObjRef Method (SybaseSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseSyntaxProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As SybaseSyntaxProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

SybaseSyntaxProvider Class
SybaseSyntaxProvider Members


Disposed Event (SybaseSyntaxProvider)

Disposed Event (SybaseSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseSyntaxProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As SybaseSyntaxProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

SybaseSyntaxProvider Class
SybaseSyntaxProvider Members


GetLifetimeService Method (SybaseSyntaxProvider)

GetLifetimeService Method (SybaseSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseSyntaxProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As SybaseSyntaxProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

SybaseSyntaxProvider Class
SybaseSyntaxProvider Members


InitializeLifetimeService Method (SybaseSyntaxProvider)

InitializeLifetimeService Method (SybaseSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseSyntaxProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As SybaseSyntaxProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

SybaseSyntaxProvider Class
SybaseSyntaxProvider Members


Site Property (SybaseSyntaxProvider)

Site Property (SybaseSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseSyntaxProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As SybaseSyntaxProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

SybaseSyntaxProvider Class
SybaseSyntaxProvider Members


VistaDBSyntaxProvider Class Events

VistaDBSyntaxProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : VistaDBSyntaxProvider Class

For a list of all members of this type, see VistaDBSyntaxProvider members.

See Also

Reference

VistaDBSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


VistaDBSyntaxProvider Class Methods

VistaDBSyntaxProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : VistaDBSyntaxProvider Class

For a list of all members of this type, see VistaDBSyntaxProvider members.

See Also

Reference

VistaDBSyntaxProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


Container Property (VistaDBSyntaxProvider)

Container Property (VistaDBSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBSyntaxProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As VistaDBSyntaxProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

VistaDBSyntaxProvider Class
VistaDBSyntaxProvider Members


CreateObjRef Method (VistaDBSyntaxProvider)

CreateObjRef Method (VistaDBSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBSyntaxProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As VistaDBSyntaxProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

VistaDBSyntaxProvider Class
VistaDBSyntaxProvider Members


Disposed Event (VistaDBSyntaxProvider)

Disposed Event (VistaDBSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBSyntaxProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As VistaDBSyntaxProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

VistaDBSyntaxProvider Class
VistaDBSyntaxProvider Members


GetLifetimeService Method (VistaDBSyntaxProvider)

GetLifetimeService Method (VistaDBSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBSyntaxProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As VistaDBSyntaxProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

VistaDBSyntaxProvider Class
VistaDBSyntaxProvider Members


InitializeLifetimeService Method (VistaDBSyntaxProvider)

InitializeLifetimeService Method (VistaDBSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBSyntaxProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As VistaDBSyntaxProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

VistaDBSyntaxProvider Class
VistaDBSyntaxProvider Members


Site Property (VistaDBSyntaxProvider)

Site Property (VistaDBSyntaxProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBSyntaxProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As VistaDBSyntaxProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

VistaDBSyntaxProvider Class
VistaDBSyntaxProvider Members


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.ActiveQueryBuilder2) Inheritance Hierarchy

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.ActiveQueryBuilder2) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.AstNodeBase
ActiveDatabaseSoftware.ActiveQueryBuilder.AstExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.AccessSubQuerySelectExpressionExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.AstNode
ActiveDatabaseSoftware.ActiveQueryBuilder.AstNodeNewLine
ActiveDatabaseSoftware.ActiveQueryBuilder.AstNodeSpace
ActiveDatabaseSoftware.ActiveQueryBuilder.AstNodeWithCollection
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLIdentifiersCollection
ActiveDatabaseSoftware.ActiveQueryBuilder.AstNodeWithList
ActiveDatabaseSoftware.ActiveQueryBuilder.AstAliasExpressionsList
ActiveDatabaseSoftware.ActiveQueryBuilder.AstTokenList
ActiveDatabaseSoftware.ActiveQueryBuilder.AstIdentifierList
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLQualifiedName
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLDatabaseObject
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLObjectColumn
ActiveDatabaseSoftware.ActiveQueryBuilder.DB2SQLForUpdateClause
ActiveDatabaseSoftware.ActiveQueryBuilder.FirebirdSQLForUpdateClause
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLForUpdateClause
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLModelCellAssignment
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLModelClause
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLModelColumnsList
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLModelRulesClause
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLQueryPartitionClause
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLComputeClause
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionList
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLGroupByList
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLOrderByClause
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSelectItems
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLWithClause
ActiveDatabaseSoftware.ActiveQueryBuilder.AstToken
ActiveDatabaseSoftware.ActiveQueryBuilder.AstTokenBuiltin
ActiveDatabaseSoftware.ActiveQueryBuilder.AstTokenIdentifier
ActiveDatabaseSoftware.ActiveQueryBuilder.AstTokenKeyword
ActiveDatabaseSoftware.ActiveQueryBuilder.AstTokenNumber
ActiveDatabaseSoftware.ActiveQueryBuilder.AstTokenString
ActiveDatabaseSoftware.ActiveQueryBuilder.AstTokenSymbol
ActiveDatabaseSoftware.ActiveQueryBuilder.DB2SQLForFetchOnlyClause
ActiveDatabaseSoftware.ActiveQueryBuilder.DB2SQLForReadOnlyClause
ActiveDatabaseSoftware.ActiveQueryBuilder.DB2SQLIsolationClause
ActiveDatabaseSoftware.ActiveQueryBuilder.DB2SQLOptimizeForClause
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLCollate
ActiveDatabaseSoftware.ActiveQueryBuilder.MySQLSelectIntoFile
ActiveDatabaseSoftware.ActiveQueryBuilder.MySQLSelectIntoDumpFile
ActiveDatabaseSoftware.ActiveQueryBuilder.MySQLSelectIntoOutfile
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLHierarchicalQueryClause
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLModelCellReferenceOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLModelColumn
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLModelColumnClauses
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLModelMain
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLModelReference
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLModelReturnRowsClause
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLModelRuleItem
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLPartitionClause
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLSampleClause
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLSubQueryRestrictionClause
ActiveDatabaseSoftware.ActiveQueryBuilder.PostgreSQLSelectIntoClause
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLAliasExpression
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLAliasEqualsExpression
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLAliasExpressionAlias
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLAliasObjectAlias
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLCaseFunctionItem
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLComputeItem
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionItem
ActiveDatabaseSoftware.ActiveQueryBuilder.PostgreSQLPositionalParam
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionAggregate
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionColumn
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionExpressionItem
ActiveDatabaseSoftware.ActiveQueryBuilder.PostgreSQLExpressionArraySelection
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionBrackets
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionFieldSelection
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionNot
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionOperation
ActiveDatabaseSoftware.ActiveQueryBuilder.InformixSQLSubstringOperator
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionIsNullOp
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionLogicalOperation
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionBetween
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionIn
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionInSet
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionInSubQuery
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLiteExpressionInTable
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionIs
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionIsFalse
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionIsNull
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionIsTrue
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionIsUnknown
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionLikeTemplate
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionOverlaps
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionNotNull
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionOperationExpression
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionContaining
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionStarting
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionOperator
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionCompWithSet
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionCompWithSetExpression
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionCompWithSetSetOfExpressions
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionCompWithSubQuery
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionOperatorBinary
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionOperatorPostfix
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionOperatorPrefix
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionTypeCast
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionCast
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionCastOperator
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionConvert
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionExpressionList
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionFulltextSearchItem
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionFunction
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionFunctionSubString
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionIfExpression
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionItemWithList
ActiveDatabaseSoftware.ActiveQueryBuilder.InformixSQLConctructorExpression
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionCaseFunction
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionConstant
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionItemWithExpressionList
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionLogicalCollection
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionAnd
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionOr
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionNodeList
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionParameter
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionParameterlessFunction
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionSelect
ActiveDatabaseSoftware.ActiveQueryBuilder.InformixSQLCollectionSubquery
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionSubQueryOperation
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionExists
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionSingular
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLExpressionVariable
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLFetchFirst
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLFromSource
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLFromCollection
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLFromFunction
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLFromBuiltInFunction
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLFromGroup
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLFromClause
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLFromNodeList
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLFromObject
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLFromFullTextQuery
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLFromFullTextQuery
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLFromObjectOnly
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLFromQuery
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLFromVariable
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLiteCollate
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLJoinKind
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLJoinKindCross
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLJoinKindInner
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLJoinKindOuter
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLJoinKindFull
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLJoinKindLeft
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLJoinKindRight
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLLimit
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLOffsetLimit
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLLimitOffset
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLOffset
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLOperator
ActiveDatabaseSoftware.ActiveQueryBuilder.PostgreSQLOperator
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLOrderByItem
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSelectItem
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSelectItemAllColumns
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSelectItemAllTableColumns
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSelectItemExpression
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSubQueryExpression
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSubQueryExpressions
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSubSelectStatement
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSelectStatement
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSubSelectStatementProxy
ActiveDatabaseSoftware.ActiveQueryBuilder.SubSelectStatementProxy
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSubQuerySelectExpression
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSubQuerySelectMode
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSubQuerySelectModeAll
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSubQuerySelectModeDefault
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSubQuerySelectModeDistinct
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSubQuerySelectModeDistinctRow
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSubQuerySelectModeUnique
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSubQueryTopPart
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSubQueryFirstSkipClause
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSubQueryTopRows
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSubQueryTopPercent
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSubQueryTopStartingAt
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLSubQueryTopWithTies
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLType
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLTypeStandard
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLTypeUser
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLTypeWithTypeBase
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLWithClauseItem
ActiveDatabaseSoftware.ActiveQueryBuilder.DB2SQLFromFunctionExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.DB2SQLFromObjectExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.DB2SQLFromQueryExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.DB2SQLSelectStatementExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.DB2SubQuerySelectExpressionExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.FirebirdSQLSelectStatementExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.FirebirdSQLSubQuerySelectExpressionExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.InformixSQLSelectStatementExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.InformixSQLSubQuerySelectExpressionExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLExpressionItemExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLFromSourceExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLGroupByListExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLSubQuerySelectExpressionExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLSubSelectStatementExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.MySQLastTokenStringExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.MySQLGroupByListExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.MySQLSubQuerySelectExpressionExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLFromFunctionExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLFromObjectExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLFromQueryExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLSelectStatementExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSQLSubQueryExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.PostgreSQLSubQuerySelectExpressionExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.PostgreSQLSubSelectStatementExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLiteSubSelectStatementExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLOrderByItemExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.SybaseSubQuerySelectExpressionExtender
ActiveDatabaseSoftware.ActiveQueryBuilder.DisposeNotificationBase
ActiveDatabaseSoftware.ActiveQueryBuilder.AggregatedBatchUpdatableBase
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataFilterItem
ActiveDatabaseSoftware.ActiveQueryBuilder.BatchUpdatableBase
ActiveDatabaseSoftware.ActiveQueryBuilder.AddObjectFormOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.DatabaseSchemaTreeOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataItem
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataAggregate
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataContainer
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataField
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataForeignKey
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataNamespace
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataObject
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataParameter
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataStructureItem
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataStructure
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataStructureOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.UpdatableObjectList<T>
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataFilter
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataList
ActiveDatabaseSoftware.ActiveQueryBuilder.UpdatableStringList
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataNameList
ActiveDatabaseSoftware.ActiveQueryBuilder.Localizer
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataNamesFetcher
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataSelection<T>
ActiveDatabaseSoftware.ActiveQueryBuilder.Parameter
ActiveDatabaseSoftware.ActiveQueryBuilder.ParameterList
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLQualifiedNameList
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLDatabaseObjectList
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLObjectColumnList
ActiveDatabaseSoftware.ActiveQueryBuilder.StatisticsBase
ActiveDatabaseSoftware.ActiveQueryBuilder.QueryStatistics
ActiveDatabaseSoftware.ActiveQueryBuilder.StatisticsDatabaseObjectList
ActiveDatabaseSoftware.ActiveQueryBuilder.StatisticsFieldList
ActiveDatabaseSoftware.ActiveQueryBuilder.StatisticsOutputColumnList
ActiveDatabaseSoftware.ActiveQueryBuilder.StatisticsDatabaseObject
ActiveDatabaseSoftware.ActiveQueryBuilder.StatisticsField
ActiveDatabaseSoftware.ActiveQueryBuilder.StatisticsOutputColumn
ActiveDatabaseSoftware.ActiveQueryBuilder.UpdatablePersistent
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSQLContext
ActiveDatabaseSoftware.ActiveQueryBuilder.BehaviorOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.DataSourceOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.DesignPaneOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.FieldListBaseColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.FieldListDescriptionColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.FieldListMarkColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.FieldListNameColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.FieldListTypeColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataLoadingOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.MetadataSimpleFilter
ActiveDatabaseSoftware.ActiveQueryBuilder.PanesConfigurationOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.QueryColumnListOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.QueryStructureTreeOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLBuilderConditionFormat
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLBuilderFromClauseFormat
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLBuilderItemListFormat
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLBuilderSelectFormat
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLGenerationOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.VisualOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.UserMessageEventArgs
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSQLBuilder
ActiveDatabaseSoftware.ActiveQueryBuilder.PlainTextSQLBuilder
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.AutoSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.DB2SyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.FirebirdSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.GenericSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.InformixSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MSAccessSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLAzureSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLCESyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MySQLSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.PostgreSQLSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.SQL2003SyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.SQL89SyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.SQL92SyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.SQLiteSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.SybaseSyntaxProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.VistaDBSyntaxProvider
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
ActiveDatabaseSoftware.ActiveQueryBuilder.QueryBuilder
See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder2 Assembly


BaseControl Class Events

BaseControl Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : BaseControl Class

For a list of all members of this type, see BaseControl members.

See Also

Reference

BaseControl Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


BaseControl Class Methods

BaseControl Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : BaseControl Class

For a list of all members of this type, see BaseControl members.

See Also

Reference

BaseControl Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


AccessKey Property (BaseControl)

AccessKey Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : AccessKey Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property AccessKey As System.String
'Usage

Dim instance As BaseControl
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
public virtual System.string AccessKey {get; set;}
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


ApplyStyle Method (BaseControl)

ApplyStyle Method (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : ApplyStyle Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
'Usage

Dim instance As BaseControl
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)

Parameters

s
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


ApplyStyleSheetSkin Method (BaseControl)

ApplyStyleSheetSkin Method (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : ApplyStyleSheetSkin Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
'Usage

Dim instance As BaseControl
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)

Parameters

page
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


AppRelativeTemplateSourceDirectory Property (BaseControl)

AppRelativeTemplateSourceDirectory Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : AppRelativeTemplateSourceDirectory Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AppRelativeTemplateSourceDirectory As System.String
'Usage

Dim instance As BaseControl
Dim value As System.String

instance.AppRelativeTemplateSourceDirectory = value

value = instance.AppRelativeTemplateSourceDirectory
public System.string AppRelativeTemplateSourceDirectory {get; set;}
public: __property System.string* get_AppRelativeTemplateSourceDirectory();
public: __property void set_AppRelativeTemplateSourceDirectory(
   System.string* value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


Attributes Property (BaseControl)

Attributes Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : Attributes Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Attributes As System.Web.UI.AttributeCollection
'Usage

Dim instance As BaseControl
Dim value As System.Web.UI.AttributeCollection

value = instance.Attributes
public System.Web.UI.AttributeCollection Attributes {get;}
public: __property System.Web.UI.AttributeCollection* get_Attributes();
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


BackColor Property (BaseControl)

BackColor Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : BackColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BackColor As System.Drawing.Color
'Usage

Dim instance As BaseControl
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
public virtual System.Drawing.Color BackColor {get; set;}
public: __property virtual System.Drawing.Color get_BackColor();
public: __property virtual void set_BackColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


BorderColor Property (BaseControl)

BorderColor Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : BorderColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BorderColor As System.Drawing.Color
'Usage

Dim instance As BaseControl
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
public virtual System.Drawing.Color BorderColor {get; set;}
public: __property virtual System.Drawing.Color get_BorderColor();
public: __property virtual void set_BorderColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


BorderStyle Property (BaseControl)

BorderStyle Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : BorderStyle Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BorderStyle As System.Web.UI.WebControls.BorderStyle
'Usage

Dim instance As BaseControl
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
public virtual System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}
public: __property virtual System.Web.UI.WebControls.BorderStyle get_BorderStyle();
public: __property virtual void set_BorderStyle(
   System.Web.UI.WebControls.BorderStyle value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


BorderWidth Property (BaseControl)

BorderWidth Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : BorderWidth Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BorderWidth As System.Web.UI.WebControls.Unit
'Usage

Dim instance As BaseControl
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
public virtual System.Web.UI.WebControls.Unit BorderWidth {get; set;}
public: __property virtual System.Web.UI.WebControls.Unit get_BorderWidth();
public: __property virtual void set_BorderWidth(
   System.Web.UI.WebControls.Unit value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


ClientID Property (BaseControl)

ClientID Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : ClientID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property ClientID As System.String
'Usage

Dim instance As BaseControl
Dim value As System.String

value = instance.ClientID
public virtual System.string ClientID {get;}
public: __property virtual System.string* get_ClientID();
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


ClientIDMode Property (BaseControl)

ClientIDMode Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : ClientIDMode Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
'Usage

Dim instance As BaseControl
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


Controls Property (BaseControl)

Controls Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : Controls Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Controls As System.Web.UI.ControlCollection
'Usage

Dim instance As BaseControl
Dim value As System.Web.UI.ControlCollection

value = instance.Controls
public virtual System.Web.UI.ControlCollection Controls {get;}
public: __property virtual System.Web.UI.ControlCollection* get_Controls();
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


ControlStyle Property (BaseControl)

ControlStyle Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : ControlStyle Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ControlStyle As System.Web.UI.WebControls.Style
'Usage

Dim instance As BaseControl
Dim value As System.Web.UI.WebControls.Style

value = instance.ControlStyle
public System.Web.UI.WebControls.Style ControlStyle {get;}
public: __property System.Web.UI.WebControls.Style* get_ControlStyle();
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


ControlStyleCreated Property (BaseControl)

ControlStyleCreated Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : ControlStyleCreated Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ControlStyleCreated As System.Boolean
'Usage

Dim instance As BaseControl
Dim value As System.Boolean

value = instance.ControlStyleCreated
public System.bool ControlStyleCreated {get;}
public: __property System.bool get_ControlStyleCreated();
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


CopyBaseAttributes Method (BaseControl)

CopyBaseAttributes Method (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : CopyBaseAttributes Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
'Usage

Dim instance As BaseControl
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)

Parameters

controlSrc
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


CssClass Property (BaseControl)

CssClass Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : CssClass Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property CssClass As System.String
'Usage

Dim instance As BaseControl
Dim value As System.String

instance.CssClass = value

value = instance.CssClass
public virtual System.string CssClass {get; set;}
public: __property virtual System.string* get_CssClass();
public: __property virtual void set_CssClass(
   System.string* value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


DataBind Method (BaseControl)

DataBind Method (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : DataBind Method
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


DataBind() Method

DataBind() Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : DataBind() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub DataBind()
'Usage

Dim instance As BaseControl

instance.DataBind()
public virtual void DataBind()
public: virtual void DataBind();
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


DataBinding Event (BaseControl)

DataBinding Event (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : DataBinding Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DataBinding As System.EventHandler
'Usage

Dim instance As BaseControl
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
public event System.EventHandler DataBinding
public: __event System.EventHandler* DataBinding
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


Dispose Method (BaseControl)

Dispose Method (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : Dispose Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub Dispose()
'Usage

Dim instance As BaseControl

instance.Dispose()
public virtual void Dispose()
public: virtual void Dispose();
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


Disposed Event (BaseControl)

Disposed Event (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As BaseControl
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


Enabled Property (BaseControl)

Enabled Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : Enabled Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Enabled As System.Boolean
'Usage

Dim instance As BaseControl
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
public virtual System.bool Enabled {get; set;}
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


EnableTheming Property (BaseControl)

EnableTheming Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : EnableTheming Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property EnableTheming As System.Boolean
'Usage

Dim instance As BaseControl
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
public virtual System.bool EnableTheming {get; set;}
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


EnableViewState Property (BaseControl)

EnableViewState Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : EnableViewState Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property EnableViewState As System.Boolean
'Usage

Dim instance As BaseControl
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
public virtual System.bool EnableViewState {get; set;}
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


FindControl Method (BaseControl)

FindControl Method (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : FindControl Method
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


FindControl(String) Method

FindControl(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : FindControl(String) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
'Usage

Dim instance As BaseControl
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
public virtual System.Web.UI.Control FindControl(
   System.string id
)
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)

Parameters

id
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


Focus Method (BaseControl)

Focus Method (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : Focus Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub Focus()
'Usage

Dim instance As BaseControl

instance.Focus()
public virtual void Focus()
public: virtual void Focus();
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


Font Property (BaseControl)

Font Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : Font Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
'Usage

Dim instance As BaseControl
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
public virtual System.Web.UI.WebControls.FontInfo Font {get;}
public: __property virtual System.Web.UI.WebControls.FontInfo* get_Font();
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


ForeColor Property (BaseControl)

ForeColor Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : ForeColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ForeColor As System.Drawing.Color
'Usage

Dim instance As BaseControl
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
public virtual System.Drawing.Color ForeColor {get; set;}
public: __property virtual System.Drawing.Color get_ForeColor();
public: __property virtual void set_ForeColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


GetRouteUrl Method (BaseControl)

GetRouteUrl Method (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : GetRouteUrl Method
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


GetRouteUrl(Object) Method

GetRouteUrl(Object) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class > GetRouteUrl Method : GetRouteUrl(Object) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
'Usage

Dim instance As BaseControl
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
public System.string GetRouteUrl(
   System.object routeParameters
)
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)

Parameters

routeParameters
Requirements

See Also

Reference

BaseControl Class
BaseControl Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

GetRouteUrl(RouteValueDictionary) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
'Usage

Dim instance As BaseControl
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)

Parameters

routeParameters
Requirements

See Also

Reference

BaseControl Class
BaseControl Members
Overload List


GetRouteUrl(String,Object) Method

GetRouteUrl(String,Object) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
'Usage

Dim instance As BaseControl
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)

Parameters

routeName
routeParameters
Requirements

See Also

Reference

BaseControl Class
BaseControl Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

GetRouteUrl(String,RouteValueDictionary) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
'Usage

Dim instance As BaseControl
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)

Parameters

routeName
routeParameters
Requirements

See Also

Reference

BaseControl Class
BaseControl Members
Overload List


GetUniqueIDRelativeTo Method (BaseControl)

GetUniqueIDRelativeTo Method (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : GetUniqueIDRelativeTo Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
'Usage

Dim instance As BaseControl
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)

Parameters

control
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


HasAttributes Property (BaseControl)

HasAttributes Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : HasAttributes Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property HasAttributes As System.Boolean
'Usage

Dim instance As BaseControl
Dim value As System.Boolean

value = instance.HasAttributes
public System.bool HasAttributes {get;}
public: __property System.bool get_HasAttributes();
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


HasControls Method (BaseControl)

HasControls Method (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : HasControls Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function HasControls() As System.Boolean
'Usage

Dim instance As BaseControl
Dim value As System.Boolean

value = instance.HasControls()
public virtual System.bool HasControls()
public: virtual System.bool HasControls();
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


Height Property (BaseControl)

Height Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : Height Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Height As System.Web.UI.WebControls.Unit
'Usage

Dim instance As BaseControl
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
public virtual System.Web.UI.WebControls.Unit Height {get; set;}
public: __property virtual System.Web.UI.WebControls.Unit get_Height();
public: __property virtual void set_Height(
   System.Web.UI.WebControls.Unit value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


ID Property (BaseControl)

ID Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : ID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ID As System.String
'Usage

Dim instance As BaseControl
Dim value As System.String

instance.ID = value

value = instance.ID
public virtual System.string ID {get; set;}
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


Init Event (BaseControl)

Init Event (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : Init Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Init As System.EventHandler
'Usage

Dim instance As BaseControl
Dim handler As System.EventHandler

AddHandler instance.Init, handler
public event System.EventHandler Init
public: __event System.EventHandler* Init
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


Load Event (BaseControl)

Load Event (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : Load Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Load As System.EventHandler
'Usage

Dim instance As BaseControl
Dim handler As System.EventHandler

AddHandler instance.Load, handler
public event System.EventHandler Load
public: __event System.EventHandler* Load
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


MergeStyle Method (BaseControl)

MergeStyle Method (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : MergeStyle Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
'Usage

Dim instance As BaseControl
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)

Parameters

s
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


NamingContainer Property (BaseControl)

NamingContainer Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : NamingContainer Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property NamingContainer As System.Web.UI.Control
'Usage

Dim instance As BaseControl
Dim value As System.Web.UI.Control

value = instance.NamingContainer
public virtual System.Web.UI.Control NamingContainer {get;}
public: __property virtual System.Web.UI.Control* get_NamingContainer();
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


Page Property (BaseControl)

Page Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : Page Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Page As System.Web.UI.Page
'Usage

Dim instance As BaseControl
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
public virtual System.Web.UI.Page Page {get; set;}
public: __property virtual System.Web.UI.Page* get_Page();
public: __property virtual void set_Page(
   System.Web.UI.Page* value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


Parent Property (BaseControl)

Parent Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : Parent Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Parent As System.Web.UI.Control
'Usage

Dim instance As BaseControl
Dim value As System.Web.UI.Control

value = instance.Parent
public virtual System.Web.UI.Control Parent {get;}
public: __property virtual System.Web.UI.Control* get_Parent();
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


PreRender Event (BaseControl)

PreRender Event (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : PreRender Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event PreRender As System.EventHandler
'Usage

Dim instance As BaseControl
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
public event System.EventHandler PreRender
public: __event System.EventHandler* PreRender
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


RenderBeginTag Method (BaseControl)

RenderBeginTag Method (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : RenderBeginTag Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
'Usage

Dim instance As BaseControl
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
public: virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
)

Parameters

writer
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


RenderControl Method (BaseControl)

RenderControl Method (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : RenderControl Method
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


RenderControl(HtmlTextWriter) Method

RenderControl(HtmlTextWriter) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : RenderControl(HtmlTextWriter) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
'Usage

Dim instance As BaseControl
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)

Parameters

writer
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


RenderEndTag Method (BaseControl)

RenderEndTag Method (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : RenderEndTag Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
'Usage

Dim instance As BaseControl
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
public virtual void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
public: virtual void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
)

Parameters

writer
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


RenderingCompatibility Property (BaseControl)

RenderingCompatibility Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : RenderingCompatibility Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property RenderingCompatibility As System.Version
'Usage

Dim instance As BaseControl
Dim value As System.Version

instance.RenderingCompatibility = value

value = instance.RenderingCompatibility
public virtual System.Version RenderingCompatibility {get; set;}
public: __property virtual System.Version* get_RenderingCompatibility();
public: __property virtual void set_RenderingCompatibility(
   System.Version* value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


ResolveClientUrl Method (BaseControl)

ResolveClientUrl Method (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : ResolveClientUrl Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
'Usage

Dim instance As BaseControl
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
public System.string ResolveClientUrl(
   System.string relativeUrl
)
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)

Parameters

relativeUrl
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


ResolveUrl Method (BaseControl)

ResolveUrl Method (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : ResolveUrl Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
'Usage

Dim instance As BaseControl
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
public System.string ResolveUrl(
   System.string relativeUrl
)
public: System.string* ResolveUrl(
   System.string* relativeUrl
)

Parameters

relativeUrl
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


SetRenderMethodDelegate Method (BaseControl)

SetRenderMethodDelegate Method (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : SetRenderMethodDelegate Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
'Usage

Dim instance As BaseControl
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)

Parameters

renderMethod
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


Site Property (BaseControl)

Site Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Site As System.ComponentModel.ISite
'Usage

Dim instance As BaseControl
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public System.ComponentModel.ISite Site {get; set;}
public: __property System.ComponentModel.ISite* get_Site();
public: __property void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


SkinID Property (BaseControl)

SkinID Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : SkinID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property SkinID As System.String
'Usage

Dim instance As BaseControl
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
public virtual System.string SkinID {get; set;}
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


Style Property (BaseControl)

Style Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : Style Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Style As System.Web.UI.CssStyleCollection
'Usage

Dim instance As BaseControl
Dim value As System.Web.UI.CssStyleCollection

value = instance.Style
public System.Web.UI.CssStyleCollection Style {get;}
public: __property System.Web.UI.CssStyleCollection* get_Style();
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


SupportsDisabledAttribute Property (BaseControl)

SupportsDisabledAttribute Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : SupportsDisabledAttribute Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property SupportsDisabledAttribute As System.Boolean
'Usage

Dim instance As BaseControl
Dim value As System.Boolean

value = instance.SupportsDisabledAttribute
public virtual System.bool SupportsDisabledAttribute {get;}
public: __property virtual System.bool get_SupportsDisabledAttribute();
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


TabIndex Property (BaseControl)

TabIndex Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : TabIndex Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property TabIndex As System.Short
'Usage

Dim instance As BaseControl
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
public virtual System.short TabIndex {get; set;}
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


TemplateControl Property (BaseControl)

TemplateControl Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : TemplateControl Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property TemplateControl As System.Web.UI.TemplateControl
'Usage

Dim instance As BaseControl
Dim value As System.Web.UI.TemplateControl

instance.TemplateControl = value

value = instance.TemplateControl
public System.Web.UI.TemplateControl TemplateControl {get; set;}
public: __property System.Web.UI.TemplateControl* get_TemplateControl();
public: __property void set_TemplateControl(
   System.Web.UI.TemplateControl* value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


TemplateSourceDirectory Property (BaseControl)

TemplateSourceDirectory Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : TemplateSourceDirectory Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property TemplateSourceDirectory As System.String
'Usage

Dim instance As BaseControl
Dim value As System.String

value = instance.TemplateSourceDirectory
public virtual System.string TemplateSourceDirectory {get;}
public: __property virtual System.string* get_TemplateSourceDirectory();
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


ToolTip Property (BaseControl)

ToolTip Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : ToolTip Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ToolTip As System.String
'Usage

Dim instance As BaseControl
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
public virtual System.string ToolTip {get; set;}
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


UniqueID Property (BaseControl)

UniqueID Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : UniqueID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property UniqueID As System.String
'Usage

Dim instance As BaseControl
Dim value As System.String

value = instance.UniqueID
public virtual System.string UniqueID {get;}
public: __property virtual System.string* get_UniqueID();
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


Unload Event (BaseControl)

Unload Event (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : Unload Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Unload As System.EventHandler
'Usage

Dim instance As BaseControl
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
public event System.EventHandler Unload
public: __event System.EventHandler* Unload
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


ViewStateMode Property (BaseControl)

ViewStateMode Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : ViewStateMode Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
'Usage

Dim instance As BaseControl
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


Visible Property (BaseControl)

Visible Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : Visible Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Visible As System.Boolean
'Usage

Dim instance As BaseControl
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
public virtual System.bool Visible {get; set;}
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


Width Property (BaseControl)

Width Property (BaseControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > BaseControl Class : Width Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Width As System.Web.UI.WebControls.Unit
'Usage

Dim instance As BaseControl
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
public virtual System.Web.UI.WebControls.Unit Width {get; set;}
public: __property virtual System.Web.UI.WebControls.Unit get_Width();
public: __property virtual void set_Width(
   System.Web.UI.WebControls.Unit value
);
Requirements

See Also

Reference

BaseControl Class
BaseControl Members


Canvas Class Events

Canvas Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : Canvas Class

For a list of all members of this type, see Canvas members.

See Also

Reference

Canvas Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


Canvas Class Methods

Canvas Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : Canvas Class

For a list of all members of this type, see Canvas members.

See Also

Reference

Canvas Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


AccessKey Property (Canvas)

AccessKey Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : AccessKey Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property AccessKey As System.String
'Usage

Dim instance As Canvas
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
public virtual System.string AccessKey {get; set;}
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


ApplyStyle Method (Canvas)

ApplyStyle Method (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : ApplyStyle Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
'Usage

Dim instance As Canvas
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)

Parameters

s
Requirements

See Also

Reference

Canvas Class
Canvas Members


ApplyStyleSheetSkin Method (Canvas)

ApplyStyleSheetSkin Method (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : ApplyStyleSheetSkin Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
'Usage

Dim instance As Canvas
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)

Parameters

page
Requirements

See Also

Reference

Canvas Class
Canvas Members


AppRelativeTemplateSourceDirectory Property (Canvas)

AppRelativeTemplateSourceDirectory Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : AppRelativeTemplateSourceDirectory Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AppRelativeTemplateSourceDirectory As System.String
'Usage

Dim instance As Canvas
Dim value As System.String

instance.AppRelativeTemplateSourceDirectory = value

value = instance.AppRelativeTemplateSourceDirectory
public System.string AppRelativeTemplateSourceDirectory {get; set;}
public: __property System.string* get_AppRelativeTemplateSourceDirectory();
public: __property void set_AppRelativeTemplateSourceDirectory(
   System.string* value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


Attributes Property (Canvas)

Attributes Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : Attributes Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Attributes As System.Web.UI.AttributeCollection
'Usage

Dim instance As Canvas
Dim value As System.Web.UI.AttributeCollection

value = instance.Attributes
public System.Web.UI.AttributeCollection Attributes {get;}
public: __property System.Web.UI.AttributeCollection* get_Attributes();
Requirements

See Also

Reference

Canvas Class
Canvas Members


BackColor Property (Canvas)

BackColor Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : BackColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BackColor As System.Drawing.Color
'Usage

Dim instance As Canvas
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
public virtual System.Drawing.Color BackColor {get; set;}
public: __property virtual System.Drawing.Color get_BackColor();
public: __property virtual void set_BackColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


BorderColor Property (Canvas)

BorderColor Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : BorderColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BorderColor As System.Drawing.Color
'Usage

Dim instance As Canvas
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
public virtual System.Drawing.Color BorderColor {get; set;}
public: __property virtual System.Drawing.Color get_BorderColor();
public: __property virtual void set_BorderColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


BorderStyle Property (Canvas)

BorderStyle Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : BorderStyle Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BorderStyle As System.Web.UI.WebControls.BorderStyle
'Usage

Dim instance As Canvas
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
public virtual System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}
public: __property virtual System.Web.UI.WebControls.BorderStyle get_BorderStyle();
public: __property virtual void set_BorderStyle(
   System.Web.UI.WebControls.BorderStyle value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


BorderWidth Property (Canvas)

BorderWidth Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : BorderWidth Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BorderWidth As System.Web.UI.WebControls.Unit
'Usage

Dim instance As Canvas
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
public virtual System.Web.UI.WebControls.Unit BorderWidth {get; set;}
public: __property virtual System.Web.UI.WebControls.Unit get_BorderWidth();
public: __property virtual void set_BorderWidth(
   System.Web.UI.WebControls.Unit value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


ClientIDMode Property (Canvas)

ClientIDMode Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : ClientIDMode Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
'Usage

Dim instance As Canvas
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


Controls Property (Canvas)

Controls Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : Controls Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Controls As System.Web.UI.ControlCollection
'Usage

Dim instance As Canvas
Dim value As System.Web.UI.ControlCollection

value = instance.Controls
public virtual System.Web.UI.ControlCollection Controls {get;}
public: __property virtual System.Web.UI.ControlCollection* get_Controls();
Requirements

See Also

Reference

Canvas Class
Canvas Members


ControlStyle Property (Canvas)

ControlStyle Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : ControlStyle Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ControlStyle As System.Web.UI.WebControls.Style
'Usage

Dim instance As Canvas
Dim value As System.Web.UI.WebControls.Style

value = instance.ControlStyle
public System.Web.UI.WebControls.Style ControlStyle {get;}
public: __property System.Web.UI.WebControls.Style* get_ControlStyle();
Requirements

See Also

Reference

Canvas Class
Canvas Members


ControlStyleCreated Property (Canvas)

ControlStyleCreated Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : ControlStyleCreated Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ControlStyleCreated As System.Boolean
'Usage

Dim instance As Canvas
Dim value As System.Boolean

value = instance.ControlStyleCreated
public System.bool ControlStyleCreated {get;}
public: __property System.bool get_ControlStyleCreated();
Requirements

See Also

Reference

Canvas Class
Canvas Members


CopyBaseAttributes Method (Canvas)

CopyBaseAttributes Method (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : CopyBaseAttributes Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
'Usage

Dim instance As Canvas
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)

Parameters

controlSrc
Requirements

See Also

Reference

Canvas Class
Canvas Members


CssClass Property (Canvas)

CssClass Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : CssClass Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property CssClass As System.String
'Usage

Dim instance As Canvas
Dim value As System.String

instance.CssClass = value

value = instance.CssClass
public virtual System.string CssClass {get; set;}
public: __property virtual System.string* get_CssClass();
public: __property virtual void set_CssClass(
   System.string* value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


DataBind Method (Canvas)

DataBind Method (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : DataBind Method
Requirements

See Also

Reference

Canvas Class
Canvas Members


DataBind() Method

DataBind() Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : DataBind() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub DataBind()
'Usage

Dim instance As Canvas

instance.DataBind()
public virtual void DataBind()
public: virtual void DataBind();
Requirements

See Also

Reference

Canvas Class
Canvas Members


DataBinding Event (Canvas)

DataBinding Event (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : DataBinding Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DataBinding As System.EventHandler
'Usage

Dim instance As Canvas
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
public event System.EventHandler DataBinding
public: __event System.EventHandler* DataBinding
Requirements

See Also

Reference

Canvas Class
Canvas Members


Dispose Method (Canvas)

Dispose Method (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : Dispose Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub Dispose()
'Usage

Dim instance As Canvas

instance.Dispose()
public virtual void Dispose()
public: virtual void Dispose();
Requirements

See Also

Reference

Canvas Class
Canvas Members


Disposed Event (Canvas)

Disposed Event (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As Canvas
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

Canvas Class
Canvas Members


Enabled Property (Canvas)

Enabled Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : Enabled Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Enabled As System.Boolean
'Usage

Dim instance As Canvas
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
public virtual System.bool Enabled {get; set;}
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


EnableTheming Property (Canvas)

EnableTheming Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : EnableTheming Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property EnableTheming As System.Boolean
'Usage

Dim instance As Canvas
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
public virtual System.bool EnableTheming {get; set;}
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


EnableViewState Property (Canvas)

EnableViewState Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : EnableViewState Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property EnableViewState As System.Boolean
'Usage

Dim instance As Canvas
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
public virtual System.bool EnableViewState {get; set;}
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


FindControl Method (Canvas)

FindControl Method (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : FindControl Method
Requirements

See Also

Reference

Canvas Class
Canvas Members


FindControl(String) Method

FindControl(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : FindControl(String) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
'Usage

Dim instance As Canvas
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
public virtual System.Web.UI.Control FindControl(
   System.string id
)
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)

Parameters

id
Requirements

See Also

Reference

Canvas Class
Canvas Members


Focus Method (Canvas)

Focus Method (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : Focus Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub Focus()
'Usage

Dim instance As Canvas

instance.Focus()
public virtual void Focus()
public: virtual void Focus();
Requirements

See Also

Reference

Canvas Class
Canvas Members


Font Property (Canvas)

Font Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : Font Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
'Usage

Dim instance As Canvas
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
public virtual System.Web.UI.WebControls.FontInfo Font {get;}
public: __property virtual System.Web.UI.WebControls.FontInfo* get_Font();
Requirements

See Also

Reference

Canvas Class
Canvas Members


ForeColor Property (Canvas)

ForeColor Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : ForeColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ForeColor As System.Drawing.Color
'Usage

Dim instance As Canvas
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
public virtual System.Drawing.Color ForeColor {get; set;}
public: __property virtual System.Drawing.Color get_ForeColor();
public: __property virtual void set_ForeColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


GetRouteUrl Method (Canvas)

GetRouteUrl Method (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : GetRouteUrl Method
Requirements

See Also

Reference

Canvas Class
Canvas Members


GetRouteUrl(Object) Method

GetRouteUrl(Object) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class > GetRouteUrl Method : GetRouteUrl(Object) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
'Usage

Dim instance As Canvas
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
public System.string GetRouteUrl(
   System.object routeParameters
)
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)

Parameters

routeParameters
Requirements

See Also

Reference

Canvas Class
Canvas Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

GetRouteUrl(RouteValueDictionary) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
'Usage

Dim instance As Canvas
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)

Parameters

routeParameters
Requirements

See Also

Reference

Canvas Class
Canvas Members
Overload List


GetRouteUrl(String,Object) Method

GetRouteUrl(String,Object) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
'Usage

Dim instance As Canvas
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)

Parameters

routeName
routeParameters
Requirements

See Also

Reference

Canvas Class
Canvas Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

GetRouteUrl(String,RouteValueDictionary) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
'Usage

Dim instance As Canvas
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)

Parameters

routeName
routeParameters
Requirements

See Also

Reference

Canvas Class
Canvas Members
Overload List


GetUniqueIDRelativeTo Method (Canvas)

GetUniqueIDRelativeTo Method (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : GetUniqueIDRelativeTo Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
'Usage

Dim instance As Canvas
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)

Parameters

control
Requirements

See Also

Reference

Canvas Class
Canvas Members


HasAttributes Property (Canvas)

HasAttributes Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : HasAttributes Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property HasAttributes As System.Boolean
'Usage

Dim instance As Canvas
Dim value As System.Boolean

value = instance.HasAttributes
public System.bool HasAttributes {get;}
public: __property System.bool get_HasAttributes();
Requirements

See Also

Reference

Canvas Class
Canvas Members


HasControls Method (Canvas)

HasControls Method (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : HasControls Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function HasControls() As System.Boolean
'Usage

Dim instance As Canvas
Dim value As System.Boolean

value = instance.HasControls()
public virtual System.bool HasControls()
public: virtual System.bool HasControls();
Requirements

See Also

Reference

Canvas Class
Canvas Members


Height Property (Canvas)

Height Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : Height Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Height As System.Web.UI.WebControls.Unit
'Usage

Dim instance As Canvas
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
public virtual System.Web.UI.WebControls.Unit Height {get; set;}
public: __property virtual System.Web.UI.WebControls.Unit get_Height();
public: __property virtual void set_Height(
   System.Web.UI.WebControls.Unit value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


ID Property (Canvas)

ID Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : ID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ID As System.String
'Usage

Dim instance As Canvas
Dim value As System.String

instance.ID = value

value = instance.ID
public virtual System.string ID {get; set;}
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


Init Event (Canvas)

Init Event (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : Init Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Init As System.EventHandler
'Usage

Dim instance As Canvas
Dim handler As System.EventHandler

AddHandler instance.Init, handler
public event System.EventHandler Init
public: __event System.EventHandler* Init
Requirements

See Also

Reference

Canvas Class
Canvas Members


Load Event (Canvas)

Load Event (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : Load Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Load As System.EventHandler
'Usage

Dim instance As Canvas
Dim handler As System.EventHandler

AddHandler instance.Load, handler
public event System.EventHandler Load
public: __event System.EventHandler* Load
Requirements

See Also

Reference

Canvas Class
Canvas Members


MergeStyle Method (Canvas)

MergeStyle Method (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : MergeStyle Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
'Usage

Dim instance As Canvas
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)

Parameters

s
Requirements

See Also

Reference

Canvas Class
Canvas Members


NamingContainer Property (Canvas)

NamingContainer Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : NamingContainer Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property NamingContainer As System.Web.UI.Control
'Usage

Dim instance As Canvas
Dim value As System.Web.UI.Control

value = instance.NamingContainer
public virtual System.Web.UI.Control NamingContainer {get;}
public: __property virtual System.Web.UI.Control* get_NamingContainer();
Requirements

See Also

Reference

Canvas Class
Canvas Members


Page Property (Canvas)

Page Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : Page Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Page As System.Web.UI.Page
'Usage

Dim instance As Canvas
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
public virtual System.Web.UI.Page Page {get; set;}
public: __property virtual System.Web.UI.Page* get_Page();
public: __property virtual void set_Page(
   System.Web.UI.Page* value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


Parent Property (Canvas)

Parent Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : Parent Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Parent As System.Web.UI.Control
'Usage

Dim instance As Canvas
Dim value As System.Web.UI.Control

value = instance.Parent
public virtual System.Web.UI.Control Parent {get;}
public: __property virtual System.Web.UI.Control* get_Parent();
Requirements

See Also

Reference

Canvas Class
Canvas Members


PreRender Event (Canvas)

PreRender Event (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : PreRender Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event PreRender As System.EventHandler
'Usage

Dim instance As Canvas
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
public event System.EventHandler PreRender
public: __event System.EventHandler* PreRender
Requirements

See Also

Reference

Canvas Class
Canvas Members


RenderBeginTag Method (Canvas)

RenderBeginTag Method (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : RenderBeginTag Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
'Usage

Dim instance As Canvas
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
public: virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
)

Parameters

writer
Requirements

See Also

Reference

Canvas Class
Canvas Members


RenderControl Method (Canvas)

RenderControl Method (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : RenderControl Method
Requirements

See Also

Reference

Canvas Class
Canvas Members


RenderControl(HtmlTextWriter) Method

RenderControl(HtmlTextWriter) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : RenderControl(HtmlTextWriter) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
'Usage

Dim instance As Canvas
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)

Parameters

writer
Requirements

See Also

Reference

Canvas Class
Canvas Members


RenderEndTag Method (Canvas)

RenderEndTag Method (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : RenderEndTag Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
'Usage

Dim instance As Canvas
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
public virtual void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
public: virtual void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
)

Parameters

writer
Requirements

See Also

Reference

Canvas Class
Canvas Members


RenderingCompatibility Property (Canvas)

RenderingCompatibility Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : RenderingCompatibility Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property RenderingCompatibility As System.Version
'Usage

Dim instance As Canvas
Dim value As System.Version

instance.RenderingCompatibility = value

value = instance.RenderingCompatibility
public virtual System.Version RenderingCompatibility {get; set;}
public: __property virtual System.Version* get_RenderingCompatibility();
public: __property virtual void set_RenderingCompatibility(
   System.Version* value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


ResolveClientUrl Method (Canvas)

ResolveClientUrl Method (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : ResolveClientUrl Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
'Usage

Dim instance As Canvas
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
public System.string ResolveClientUrl(
   System.string relativeUrl
)
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)

Parameters

relativeUrl
Requirements

See Also

Reference

Canvas Class
Canvas Members


ResolveUrl Method (Canvas)

ResolveUrl Method (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : ResolveUrl Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
'Usage

Dim instance As Canvas
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
public System.string ResolveUrl(
   System.string relativeUrl
)
public: System.string* ResolveUrl(
   System.string* relativeUrl
)

Parameters

relativeUrl
Requirements

See Also

Reference

Canvas Class
Canvas Members


SetRenderMethodDelegate Method (Canvas)

SetRenderMethodDelegate Method (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : SetRenderMethodDelegate Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
'Usage

Dim instance As Canvas
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)

Parameters

renderMethod
Requirements

See Also

Reference

Canvas Class
Canvas Members


Site Property (Canvas)

Site Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Site As System.ComponentModel.ISite
'Usage

Dim instance As Canvas
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public System.ComponentModel.ISite Site {get; set;}
public: __property System.ComponentModel.ISite* get_Site();
public: __property void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


SkinID Property (Canvas)

SkinID Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : SkinID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property SkinID As System.String
'Usage

Dim instance As Canvas
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
public virtual System.string SkinID {get; set;}
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


Style Property (Canvas)

Style Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : Style Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Style As System.Web.UI.CssStyleCollection
'Usage

Dim instance As Canvas
Dim value As System.Web.UI.CssStyleCollection

value = instance.Style
public System.Web.UI.CssStyleCollection Style {get;}
public: __property System.Web.UI.CssStyleCollection* get_Style();
Requirements

See Also

Reference

Canvas Class
Canvas Members


SupportsDisabledAttribute Property (Canvas)

SupportsDisabledAttribute Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : SupportsDisabledAttribute Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property SupportsDisabledAttribute As System.Boolean
'Usage

Dim instance As Canvas
Dim value As System.Boolean

value = instance.SupportsDisabledAttribute
public virtual System.bool SupportsDisabledAttribute {get;}
public: __property virtual System.bool get_SupportsDisabledAttribute();
Requirements

See Also

Reference

Canvas Class
Canvas Members


TabIndex Property (Canvas)

TabIndex Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : TabIndex Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property TabIndex As System.Short
'Usage

Dim instance As Canvas
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
public virtual System.short TabIndex {get; set;}
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


TemplateControl Property (Canvas)

TemplateControl Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : TemplateControl Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property TemplateControl As System.Web.UI.TemplateControl
'Usage

Dim instance As Canvas
Dim value As System.Web.UI.TemplateControl

instance.TemplateControl = value

value = instance.TemplateControl
public System.Web.UI.TemplateControl TemplateControl {get; set;}
public: __property System.Web.UI.TemplateControl* get_TemplateControl();
public: __property void set_TemplateControl(
   System.Web.UI.TemplateControl* value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


TemplateSourceDirectory Property (Canvas)

TemplateSourceDirectory Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : TemplateSourceDirectory Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property TemplateSourceDirectory As System.String
'Usage

Dim instance As Canvas
Dim value As System.String

value = instance.TemplateSourceDirectory
public virtual System.string TemplateSourceDirectory {get;}
public: __property virtual System.string* get_TemplateSourceDirectory();
Requirements

See Also

Reference

Canvas Class
Canvas Members


ToolTip Property (Canvas)

ToolTip Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : ToolTip Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ToolTip As System.String
'Usage

Dim instance As Canvas
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
public virtual System.string ToolTip {get; set;}
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


UniqueID Property (Canvas)

UniqueID Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : UniqueID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property UniqueID As System.String
'Usage

Dim instance As Canvas
Dim value As System.String

value = instance.UniqueID
public virtual System.string UniqueID {get;}
public: __property virtual System.string* get_UniqueID();
Requirements

See Also

Reference

Canvas Class
Canvas Members


Unload Event (Canvas)

Unload Event (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : Unload Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Unload As System.EventHandler
'Usage

Dim instance As Canvas
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
public event System.EventHandler Unload
public: __event System.EventHandler* Unload
Requirements

See Also

Reference

Canvas Class
Canvas Members


ViewStateMode Property (Canvas)

ViewStateMode Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : ViewStateMode Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
'Usage

Dim instance As Canvas
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


Visible Property (Canvas)

Visible Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : Visible Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Visible As System.Boolean
'Usage

Dim instance As Canvas
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
public virtual System.bool Visible {get; set;}
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


Width Property (Canvas)

Width Property (Canvas)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Canvas Class : Width Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Width As System.Web.UI.WebControls.Unit
'Usage

Dim instance As Canvas
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
public virtual System.Web.UI.WebControls.Unit Width {get; set;}
public: __property virtual System.Web.UI.WebControls.Unit get_Width();
public: __property virtual void set_Width(
   System.Web.UI.WebControls.Unit value
);
Requirements

See Also

Reference

Canvas Class
Canvas Members


Grid Class Events

Grid Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : Grid Class

For a list of all members of this type, see Grid members.

See Also

Reference

Grid Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


Grid Class Methods

Grid Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : Grid Class

For a list of all members of this type, see Grid members.

See Also

Reference

Grid Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


Grid Class Properties

Grid Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : Grid Class

For a list of all members of this type, see Grid members.

See Also

Reference

Grid Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


AccessKey Property (Grid)

AccessKey Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : AccessKey Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property AccessKey As System.String
'Usage

Dim instance As Grid
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
public virtual System.string AccessKey {get; set;}
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
Requirements

See Also

Reference

Grid Class
Grid Members


ApplyStyle Method (Grid)

ApplyStyle Method (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : ApplyStyle Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
'Usage

Dim instance As Grid
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)

Parameters

s
Requirements

See Also

Reference

Grid Class
Grid Members


ApplyStyleSheetSkin Method (Grid)

ApplyStyleSheetSkin Method (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : ApplyStyleSheetSkin Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
'Usage

Dim instance As Grid
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)

Parameters

page
Requirements

See Also

Reference

Grid Class
Grid Members


AppRelativeTemplateSourceDirectory Property (Grid)

AppRelativeTemplateSourceDirectory Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : AppRelativeTemplateSourceDirectory Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AppRelativeTemplateSourceDirectory As System.String
'Usage

Dim instance As Grid
Dim value As System.String

instance.AppRelativeTemplateSourceDirectory = value

value = instance.AppRelativeTemplateSourceDirectory
public System.string AppRelativeTemplateSourceDirectory {get; set;}
public: __property System.string* get_AppRelativeTemplateSourceDirectory();
public: __property void set_AppRelativeTemplateSourceDirectory(
   System.string* value
);
Requirements

See Also

Reference

Grid Class
Grid Members


Attributes Property (Grid)

Attributes Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : Attributes Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Attributes As System.Web.UI.AttributeCollection
'Usage

Dim instance As Grid
Dim value As System.Web.UI.AttributeCollection

value = instance.Attributes
public System.Web.UI.AttributeCollection Attributes {get;}
public: __property System.Web.UI.AttributeCollection* get_Attributes();
Requirements

See Also

Reference

Grid Class
Grid Members


BackColor Property (Grid)

BackColor Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : BackColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BackColor As System.Drawing.Color
'Usage

Dim instance As Grid
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
public virtual System.Drawing.Color BackColor {get; set;}
public: __property virtual System.Drawing.Color get_BackColor();
public: __property virtual void set_BackColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

Grid Class
Grid Members


BorderColor Property (Grid)

BorderColor Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : BorderColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BorderColor As System.Drawing.Color
'Usage

Dim instance As Grid
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
public virtual System.Drawing.Color BorderColor {get; set;}
public: __property virtual System.Drawing.Color get_BorderColor();
public: __property virtual void set_BorderColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

Grid Class
Grid Members


BorderStyle Property (Grid)

BorderStyle Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : BorderStyle Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BorderStyle As System.Web.UI.WebControls.BorderStyle
'Usage

Dim instance As Grid
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
public virtual System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}
public: __property virtual System.Web.UI.WebControls.BorderStyle get_BorderStyle();
public: __property virtual void set_BorderStyle(
   System.Web.UI.WebControls.BorderStyle value
);
Requirements

See Also

Reference

Grid Class
Grid Members


BorderWidth Property (Grid)

BorderWidth Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : BorderWidth Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BorderWidth As System.Web.UI.WebControls.Unit
'Usage

Dim instance As Grid
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
public virtual System.Web.UI.WebControls.Unit BorderWidth {get; set;}
public: __property virtual System.Web.UI.WebControls.Unit get_BorderWidth();
public: __property virtual void set_BorderWidth(
   System.Web.UI.WebControls.Unit value
);
Requirements

See Also

Reference

Grid Class
Grid Members


ClientIDMode Property (Grid)

ClientIDMode Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : ClientIDMode Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
'Usage

Dim instance As Grid
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
Requirements

See Also

Reference

Grid Class
Grid Members


Controls Property (Grid)

Controls Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : Controls Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Controls As System.Web.UI.ControlCollection
'Usage

Dim instance As Grid
Dim value As System.Web.UI.ControlCollection

value = instance.Controls
public virtual System.Web.UI.ControlCollection Controls {get;}
public: __property virtual System.Web.UI.ControlCollection* get_Controls();
Requirements

See Also

Reference

Grid Class
Grid Members


ControlStyle Property (Grid)

ControlStyle Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : ControlStyle Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ControlStyle As System.Web.UI.WebControls.Style
'Usage

Dim instance As Grid
Dim value As System.Web.UI.WebControls.Style

value = instance.ControlStyle
public System.Web.UI.WebControls.Style ControlStyle {get;}
public: __property System.Web.UI.WebControls.Style* get_ControlStyle();
Requirements

See Also

Reference

Grid Class
Grid Members


ControlStyleCreated Property (Grid)

ControlStyleCreated Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : ControlStyleCreated Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ControlStyleCreated As System.Boolean
'Usage

Dim instance As Grid
Dim value As System.Boolean

value = instance.ControlStyleCreated
public System.bool ControlStyleCreated {get;}
public: __property System.bool get_ControlStyleCreated();
Requirements

See Also

Reference

Grid Class
Grid Members


CopyBaseAttributes Method (Grid)

CopyBaseAttributes Method (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : CopyBaseAttributes Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
'Usage

Dim instance As Grid
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)

Parameters

controlSrc
Requirements

See Also

Reference

Grid Class
Grid Members


CssClass Property (Grid)

CssClass Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : CssClass Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property CssClass As System.String
'Usage

Dim instance As Grid
Dim value As System.String

instance.CssClass = value

value = instance.CssClass
public virtual System.string CssClass {get; set;}
public: __property virtual System.string* get_CssClass();
public: __property virtual void set_CssClass(
   System.string* value
);
Requirements

See Also

Reference

Grid Class
Grid Members


DataBind Method (Grid)

DataBind Method (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : DataBind Method
Requirements

See Also

Reference

Grid Class
Grid Members


DataBind() Method

DataBind() Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : DataBind() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub DataBind()
'Usage

Dim instance As Grid

instance.DataBind()
public virtual void DataBind()
public: virtual void DataBind();
Requirements

See Also

Reference

Grid Class
Grid Members


DataBinding Event (Grid)

DataBinding Event (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : DataBinding Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DataBinding As System.EventHandler
'Usage

Dim instance As Grid
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
public event System.EventHandler DataBinding
public: __event System.EventHandler* DataBinding
Requirements

See Also

Reference

Grid Class
Grid Members


Dispose Method (Grid)

Dispose Method (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : Dispose Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub Dispose()
'Usage

Dim instance As Grid

instance.Dispose()
public virtual void Dispose()
public: virtual void Dispose();
Requirements

See Also

Reference

Grid Class
Grid Members


Disposed Event (Grid)

Disposed Event (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As Grid
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

Grid Class
Grid Members


Enabled Property (Grid)

Enabled Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : Enabled Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Enabled As System.Boolean
'Usage

Dim instance As Grid
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
public virtual System.bool Enabled {get; set;}
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
Requirements

See Also

Reference

Grid Class
Grid Members


EnableTheming Property (Grid)

EnableTheming Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : EnableTheming Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property EnableTheming As System.Boolean
'Usage

Dim instance As Grid
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
public virtual System.bool EnableTheming {get; set;}
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
Requirements

See Also

Reference

Grid Class
Grid Members


EnableViewState Property (Grid)

EnableViewState Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : EnableViewState Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property EnableViewState As System.Boolean
'Usage

Dim instance As Grid
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
public virtual System.bool EnableViewState {get; set;}
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
Requirements

See Also

Reference

Grid Class
Grid Members


FindControl Method (Grid)

FindControl Method (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : FindControl Method
Requirements

See Also

Reference

Grid Class
Grid Members


FindControl(String) Method

FindControl(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : FindControl(String) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
'Usage

Dim instance As Grid
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
public virtual System.Web.UI.Control FindControl(
   System.string id
)
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)

Parameters

id
Requirements

See Also

Reference

Grid Class
Grid Members


Focus Method (Grid)

Focus Method (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : Focus Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub Focus()
'Usage

Dim instance As Grid

instance.Focus()
public virtual void Focus()
public: virtual void Focus();
Requirements

See Also

Reference

Grid Class
Grid Members


Font Property (Grid)

Font Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : Font Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
'Usage

Dim instance As Grid
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
public virtual System.Web.UI.WebControls.FontInfo Font {get;}
public: __property virtual System.Web.UI.WebControls.FontInfo* get_Font();
Requirements

See Also

Reference

Grid Class
Grid Members


ForeColor Property (Grid)

ForeColor Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : ForeColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ForeColor As System.Drawing.Color
'Usage

Dim instance As Grid
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
public virtual System.Drawing.Color ForeColor {get; set;}
public: __property virtual System.Drawing.Color get_ForeColor();
public: __property virtual void set_ForeColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

Grid Class
Grid Members


GetRouteUrl Method (Grid)

GetRouteUrl Method (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : GetRouteUrl Method
Requirements

See Also

Reference

Grid Class
Grid Members


GetRouteUrl(Object) Method

GetRouteUrl(Object) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class > GetRouteUrl Method : GetRouteUrl(Object) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
'Usage

Dim instance As Grid
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
public System.string GetRouteUrl(
   System.object routeParameters
)
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)

Parameters

routeParameters
Requirements

See Also

Reference

Grid Class
Grid Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

GetRouteUrl(RouteValueDictionary) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
'Usage

Dim instance As Grid
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)

Parameters

routeParameters
Requirements

See Also

Reference

Grid Class
Grid Members
Overload List


GetRouteUrl(String,Object) Method

GetRouteUrl(String,Object) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
'Usage

Dim instance As Grid
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)

Parameters

routeName
routeParameters
Requirements

See Also

Reference

Grid Class
Grid Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

GetRouteUrl(String,RouteValueDictionary) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
'Usage

Dim instance As Grid
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)

Parameters

routeName
routeParameters
Requirements

See Also

Reference

Grid Class
Grid Members
Overload List


GetUniqueIDRelativeTo Method (Grid)

GetUniqueIDRelativeTo Method (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : GetUniqueIDRelativeTo Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
'Usage

Dim instance As Grid
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)

Parameters

control
Requirements

See Also

Reference

Grid Class
Grid Members


HasAttributes Property (Grid)

HasAttributes Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : HasAttributes Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property HasAttributes As System.Boolean
'Usage

Dim instance As Grid
Dim value As System.Boolean

value = instance.HasAttributes
public System.bool HasAttributes {get;}
public: __property System.bool get_HasAttributes();
Requirements

See Also

Reference

Grid Class
Grid Members


HasControls Method (Grid)

HasControls Method (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : HasControls Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function HasControls() As System.Boolean
'Usage

Dim instance As Grid
Dim value As System.Boolean

value = instance.HasControls()
public virtual System.bool HasControls()
public: virtual System.bool HasControls();
Requirements

See Also

Reference

Grid Class
Grid Members


Height Property (Grid)

Height Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : Height Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Height As System.Web.UI.WebControls.Unit
'Usage

Dim instance As Grid
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
public virtual System.Web.UI.WebControls.Unit Height {get; set;}
public: __property virtual System.Web.UI.WebControls.Unit get_Height();
public: __property virtual void set_Height(
   System.Web.UI.WebControls.Unit value
);
Requirements

See Also

Reference

Grid Class
Grid Members


ID Property (Grid)

ID Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : ID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ID As System.String
'Usage

Dim instance As Grid
Dim value As System.String

instance.ID = value

value = instance.ID
public virtual System.string ID {get; set;}
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
Requirements

See Also

Reference

Grid Class
Grid Members


Init Event (Grid)

Init Event (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : Init Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Init As System.EventHandler
'Usage

Dim instance As Grid
Dim handler As System.EventHandler

AddHandler instance.Init, handler
public event System.EventHandler Init
public: __event System.EventHandler* Init
Requirements

See Also

Reference

Grid Class
Grid Members


Load Event (Grid)

Load Event (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : Load Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Load As System.EventHandler
'Usage

Dim instance As Grid
Dim handler As System.EventHandler

AddHandler instance.Load, handler
public event System.EventHandler Load
public: __event System.EventHandler* Load
Requirements

See Also

Reference

Grid Class
Grid Members


MergeStyle Method (Grid)

MergeStyle Method (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : MergeStyle Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
'Usage

Dim instance As Grid
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)

Parameters

s
Requirements

See Also

Reference

Grid Class
Grid Members


NamingContainer Property (Grid)

NamingContainer Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : NamingContainer Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property NamingContainer As System.Web.UI.Control
'Usage

Dim instance As Grid
Dim value As System.Web.UI.Control

value = instance.NamingContainer
public virtual System.Web.UI.Control NamingContainer {get;}
public: __property virtual System.Web.UI.Control* get_NamingContainer();
Requirements

See Also

Reference

Grid Class
Grid Members


Page Property (Grid)

Page Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : Page Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Page As System.Web.UI.Page
'Usage

Dim instance As Grid
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
public virtual System.Web.UI.Page Page {get; set;}
public: __property virtual System.Web.UI.Page* get_Page();
public: __property virtual void set_Page(
   System.Web.UI.Page* value
);
Requirements

See Also

Reference

Grid Class
Grid Members


Parent Property (Grid)

Parent Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : Parent Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Parent As System.Web.UI.Control
'Usage

Dim instance As Grid
Dim value As System.Web.UI.Control

value = instance.Parent
public virtual System.Web.UI.Control Parent {get;}
public: __property virtual System.Web.UI.Control* get_Parent();
Requirements

See Also

Reference

Grid Class
Grid Members


PreRender Event (Grid)

PreRender Event (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : PreRender Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event PreRender As System.EventHandler
'Usage

Dim instance As Grid
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
public event System.EventHandler PreRender
public: __event System.EventHandler* PreRender
Requirements

See Also

Reference

Grid Class
Grid Members


RenderBeginTag Method (Grid)

RenderBeginTag Method (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : RenderBeginTag Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
'Usage

Dim instance As Grid
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
public: virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
)

Parameters

writer
Requirements

See Also

Reference

Grid Class
Grid Members


RenderControl Method (Grid)

RenderControl Method (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : RenderControl Method
Requirements

See Also

Reference

Grid Class
Grid Members


RenderControl(HtmlTextWriter) Method

RenderControl(HtmlTextWriter) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : RenderControl(HtmlTextWriter) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
'Usage

Dim instance As Grid
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)

Parameters

writer
Requirements

See Also

Reference

Grid Class
Grid Members


RenderEndTag Method (Grid)

RenderEndTag Method (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : RenderEndTag Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
'Usage

Dim instance As Grid
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
public virtual void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
public: virtual void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
)

Parameters

writer
Requirements

See Also

Reference

Grid Class
Grid Members


RenderingCompatibility Property (Grid)

RenderingCompatibility Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : RenderingCompatibility Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property RenderingCompatibility As System.Version
'Usage

Dim instance As Grid
Dim value As System.Version

instance.RenderingCompatibility = value

value = instance.RenderingCompatibility
public virtual System.Version RenderingCompatibility {get; set;}
public: __property virtual System.Version* get_RenderingCompatibility();
public: __property virtual void set_RenderingCompatibility(
   System.Version* value
);
Requirements

See Also

Reference

Grid Class
Grid Members


ResolveClientUrl Method (Grid)

ResolveClientUrl Method (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : ResolveClientUrl Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
'Usage

Dim instance As Grid
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
public System.string ResolveClientUrl(
   System.string relativeUrl
)
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)

Parameters

relativeUrl
Requirements

See Also

Reference

Grid Class
Grid Members


ResolveUrl Method (Grid)

ResolveUrl Method (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : ResolveUrl Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
'Usage

Dim instance As Grid
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
public System.string ResolveUrl(
   System.string relativeUrl
)
public: System.string* ResolveUrl(
   System.string* relativeUrl
)

Parameters

relativeUrl
Requirements

See Also

Reference

Grid Class
Grid Members


SetRenderMethodDelegate Method (Grid)

SetRenderMethodDelegate Method (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : SetRenderMethodDelegate Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
'Usage

Dim instance As Grid
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)

Parameters

renderMethod
Requirements

See Also

Reference

Grid Class
Grid Members


Site Property (Grid)

Site Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Site As System.ComponentModel.ISite
'Usage

Dim instance As Grid
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public System.ComponentModel.ISite Site {get; set;}
public: __property System.ComponentModel.ISite* get_Site();
public: __property void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

Grid Class
Grid Members


SkinID Property (Grid)

SkinID Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : SkinID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property SkinID As System.String
'Usage

Dim instance As Grid
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
public virtual System.string SkinID {get; set;}
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
Requirements

See Also

Reference

Grid Class
Grid Members


Style Property (Grid)

Style Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : Style Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Style As System.Web.UI.CssStyleCollection
'Usage

Dim instance As Grid
Dim value As System.Web.UI.CssStyleCollection

value = instance.Style
public System.Web.UI.CssStyleCollection Style {get;}
public: __property System.Web.UI.CssStyleCollection* get_Style();
Requirements

See Also

Reference

Grid Class
Grid Members


SupportsDisabledAttribute Property (Grid)

SupportsDisabledAttribute Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : SupportsDisabledAttribute Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property SupportsDisabledAttribute As System.Boolean
'Usage

Dim instance As Grid
Dim value As System.Boolean

value = instance.SupportsDisabledAttribute
public virtual System.bool SupportsDisabledAttribute {get;}
public: __property virtual System.bool get_SupportsDisabledAttribute();
Requirements

See Also

Reference

Grid Class
Grid Members


TabIndex Property (Grid)

TabIndex Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : TabIndex Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property TabIndex As System.Short
'Usage

Dim instance As Grid
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
public virtual System.short TabIndex {get; set;}
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
Requirements

See Also

Reference

Grid Class
Grid Members


TemplateControl Property (Grid)

TemplateControl Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : TemplateControl Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property TemplateControl As System.Web.UI.TemplateControl
'Usage

Dim instance As Grid
Dim value As System.Web.UI.TemplateControl

instance.TemplateControl = value

value = instance.TemplateControl
public System.Web.UI.TemplateControl TemplateControl {get; set;}
public: __property System.Web.UI.TemplateControl* get_TemplateControl();
public: __property void set_TemplateControl(
   System.Web.UI.TemplateControl* value
);
Requirements

See Also

Reference

Grid Class
Grid Members


TemplateSourceDirectory Property (Grid)

TemplateSourceDirectory Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : TemplateSourceDirectory Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property TemplateSourceDirectory As System.String
'Usage

Dim instance As Grid
Dim value As System.String

value = instance.TemplateSourceDirectory
public virtual System.string TemplateSourceDirectory {get;}
public: __property virtual System.string* get_TemplateSourceDirectory();
Requirements

See Also

Reference

Grid Class
Grid Members


ToolTip Property (Grid)

ToolTip Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : ToolTip Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ToolTip As System.String
'Usage

Dim instance As Grid
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
public virtual System.string ToolTip {get; set;}
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
Requirements

See Also

Reference

Grid Class
Grid Members


UniqueID Property (Grid)

UniqueID Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : UniqueID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property UniqueID As System.String
'Usage

Dim instance As Grid
Dim value As System.String

value = instance.UniqueID
public virtual System.string UniqueID {get;}
public: __property virtual System.string* get_UniqueID();
Requirements

See Also

Reference

Grid Class
Grid Members


Unload Event (Grid)

Unload Event (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : Unload Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Unload As System.EventHandler
'Usage

Dim instance As Grid
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
public event System.EventHandler Unload
public: __event System.EventHandler* Unload
Requirements

See Also

Reference

Grid Class
Grid Members


ViewStateMode Property (Grid)

ViewStateMode Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : ViewStateMode Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
'Usage

Dim instance As Grid
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
Requirements

See Also

Reference

Grid Class
Grid Members


Visible Property (Grid)

Visible Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : Visible Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Visible As System.Boolean
'Usage

Dim instance As Grid
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
public virtual System.bool Visible {get; set;}
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
Requirements

See Also

Reference

Grid Class
Grid Members


Width Property (Grid)

Width Property (Grid)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > Grid Class : Width Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Width As System.Web.UI.WebControls.Unit
'Usage

Dim instance As Grid
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
public virtual System.Web.UI.WebControls.Unit Width {get; set;}
public: __property virtual System.Web.UI.WebControls.Unit get_Width();
public: __property virtual void set_Width(
   System.Web.UI.WebControls.Unit value
);
Requirements

See Also

Reference

Grid Class
Grid Members


ObjectTree Class Events

ObjectTree Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : ObjectTree Class

For a list of all members of this type, see ObjectTree members.

See Also

Reference

ObjectTree Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


ObjectTree Class Methods

ObjectTree Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : ObjectTree Class

For a list of all members of this type, see ObjectTree members.

See Also

Reference

ObjectTree Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


AccessKey Property (ObjectTree)

AccessKey Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : AccessKey Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property AccessKey As System.String
'Usage

Dim instance As ObjectTree
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
public virtual System.string AccessKey {get; set;}
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


ApplyStyle Method (ObjectTree)

ApplyStyle Method (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : ApplyStyle Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
'Usage

Dim instance As ObjectTree
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)

Parameters

s
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


ApplyStyleSheetSkin Method (ObjectTree)

ApplyStyleSheetSkin Method (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : ApplyStyleSheetSkin Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
'Usage

Dim instance As ObjectTree
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)

Parameters

page
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


AppRelativeTemplateSourceDirectory Property (ObjectTree)

AppRelativeTemplateSourceDirectory Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : AppRelativeTemplateSourceDirectory Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AppRelativeTemplateSourceDirectory As System.String
'Usage

Dim instance As ObjectTree
Dim value As System.String

instance.AppRelativeTemplateSourceDirectory = value

value = instance.AppRelativeTemplateSourceDirectory
public System.string AppRelativeTemplateSourceDirectory {get; set;}
public: __property System.string* get_AppRelativeTemplateSourceDirectory();
public: __property void set_AppRelativeTemplateSourceDirectory(
   System.string* value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


Attributes Property (ObjectTree)

Attributes Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : Attributes Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Attributes As System.Web.UI.AttributeCollection
'Usage

Dim instance As ObjectTree
Dim value As System.Web.UI.AttributeCollection

value = instance.Attributes
public System.Web.UI.AttributeCollection Attributes {get;}
public: __property System.Web.UI.AttributeCollection* get_Attributes();
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


BackColor Property (ObjectTree)

BackColor Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : BackColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BackColor As System.Drawing.Color
'Usage

Dim instance As ObjectTree
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
public virtual System.Drawing.Color BackColor {get; set;}
public: __property virtual System.Drawing.Color get_BackColor();
public: __property virtual void set_BackColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


BorderColor Property (ObjectTree)

BorderColor Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : BorderColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BorderColor As System.Drawing.Color
'Usage

Dim instance As ObjectTree
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
public virtual System.Drawing.Color BorderColor {get; set;}
public: __property virtual System.Drawing.Color get_BorderColor();
public: __property virtual void set_BorderColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


BorderStyle Property (ObjectTree)

BorderStyle Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : BorderStyle Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BorderStyle As System.Web.UI.WebControls.BorderStyle
'Usage

Dim instance As ObjectTree
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
public virtual System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}
public: __property virtual System.Web.UI.WebControls.BorderStyle get_BorderStyle();
public: __property virtual void set_BorderStyle(
   System.Web.UI.WebControls.BorderStyle value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


BorderWidth Property (ObjectTree)

BorderWidth Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : BorderWidth Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BorderWidth As System.Web.UI.WebControls.Unit
'Usage

Dim instance As ObjectTree
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
public virtual System.Web.UI.WebControls.Unit BorderWidth {get; set;}
public: __property virtual System.Web.UI.WebControls.Unit get_BorderWidth();
public: __property virtual void set_BorderWidth(
   System.Web.UI.WebControls.Unit value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


ClientIDMode Property (ObjectTree)

ClientIDMode Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : ClientIDMode Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
'Usage

Dim instance As ObjectTree
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


Controls Property (ObjectTree)

Controls Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : Controls Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Controls As System.Web.UI.ControlCollection
'Usage

Dim instance As ObjectTree
Dim value As System.Web.UI.ControlCollection

value = instance.Controls
public virtual System.Web.UI.ControlCollection Controls {get;}
public: __property virtual System.Web.UI.ControlCollection* get_Controls();
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


ControlStyle Property (ObjectTree)

ControlStyle Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : ControlStyle Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ControlStyle As System.Web.UI.WebControls.Style
'Usage

Dim instance As ObjectTree
Dim value As System.Web.UI.WebControls.Style

value = instance.ControlStyle
public System.Web.UI.WebControls.Style ControlStyle {get;}
public: __property System.Web.UI.WebControls.Style* get_ControlStyle();
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


ControlStyleCreated Property (ObjectTree)

ControlStyleCreated Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : ControlStyleCreated Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ControlStyleCreated As System.Boolean
'Usage

Dim instance As ObjectTree
Dim value As System.Boolean

value = instance.ControlStyleCreated
public System.bool ControlStyleCreated {get;}
public: __property System.bool get_ControlStyleCreated();
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


CopyBaseAttributes Method (ObjectTree)

CopyBaseAttributes Method (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : CopyBaseAttributes Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
'Usage

Dim instance As ObjectTree
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)

Parameters

controlSrc
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


CssClass Property (ObjectTree)

CssClass Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : CssClass Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property CssClass As System.String
'Usage

Dim instance As ObjectTree
Dim value As System.String

instance.CssClass = value

value = instance.CssClass
public virtual System.string CssClass {get; set;}
public: __property virtual System.string* get_CssClass();
public: __property virtual void set_CssClass(
   System.string* value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


DataBind Method (ObjectTree)

DataBind Method (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : DataBind Method
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


DataBind() Method

DataBind() Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : DataBind() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub DataBind()
'Usage

Dim instance As ObjectTree

instance.DataBind()
public virtual void DataBind()
public: virtual void DataBind();
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


DataBinding Event (ObjectTree)

DataBinding Event (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : DataBinding Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DataBinding As System.EventHandler
'Usage

Dim instance As ObjectTree
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
public event System.EventHandler DataBinding
public: __event System.EventHandler* DataBinding
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


Dispose Method (ObjectTree)

Dispose Method (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : Dispose Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub Dispose()
'Usage

Dim instance As ObjectTree

instance.Dispose()
public virtual void Dispose()
public: virtual void Dispose();
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


Disposed Event (ObjectTree)

Disposed Event (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As ObjectTree
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


Enabled Property (ObjectTree)

Enabled Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : Enabled Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Enabled As System.Boolean
'Usage

Dim instance As ObjectTree
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
public virtual System.bool Enabled {get; set;}
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


EnableTheming Property (ObjectTree)

EnableTheming Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : EnableTheming Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property EnableTheming As System.Boolean
'Usage

Dim instance As ObjectTree
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
public virtual System.bool EnableTheming {get; set;}
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


EnableViewState Property (ObjectTree)

EnableViewState Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : EnableViewState Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property EnableViewState As System.Boolean
'Usage

Dim instance As ObjectTree
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
public virtual System.bool EnableViewState {get; set;}
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


FindControl Method (ObjectTree)

FindControl Method (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : FindControl Method
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


FindControl(String) Method

FindControl(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : FindControl(String) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
'Usage

Dim instance As ObjectTree
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
public virtual System.Web.UI.Control FindControl(
   System.string id
)
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)

Parameters

id
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


Focus Method (ObjectTree)

Focus Method (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : Focus Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub Focus()
'Usage

Dim instance As ObjectTree

instance.Focus()
public virtual void Focus()
public: virtual void Focus();
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


Font Property (ObjectTree)

Font Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : Font Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
'Usage

Dim instance As ObjectTree
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
public virtual System.Web.UI.WebControls.FontInfo Font {get;}
public: __property virtual System.Web.UI.WebControls.FontInfo* get_Font();
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


ForeColor Property (ObjectTree)

ForeColor Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : ForeColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ForeColor As System.Drawing.Color
'Usage

Dim instance As ObjectTree
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
public virtual System.Drawing.Color ForeColor {get; set;}
public: __property virtual System.Drawing.Color get_ForeColor();
public: __property virtual void set_ForeColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


GetRouteUrl Method (ObjectTree)

GetRouteUrl Method (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : GetRouteUrl Method
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


GetRouteUrl(Object) Method

GetRouteUrl(Object) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class > GetRouteUrl Method : GetRouteUrl(Object) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
'Usage

Dim instance As ObjectTree
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
public System.string GetRouteUrl(
   System.object routeParameters
)
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)

Parameters

routeParameters
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

GetRouteUrl(RouteValueDictionary) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
'Usage

Dim instance As ObjectTree
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)

Parameters

routeParameters
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members
Overload List


GetRouteUrl(String,Object) Method

GetRouteUrl(String,Object) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
'Usage

Dim instance As ObjectTree
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)

Parameters

routeName
routeParameters
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

GetRouteUrl(String,RouteValueDictionary) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
'Usage

Dim instance As ObjectTree
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)

Parameters

routeName
routeParameters
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members
Overload List


GetUniqueIDRelativeTo Method (ObjectTree)

GetUniqueIDRelativeTo Method (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : GetUniqueIDRelativeTo Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
'Usage

Dim instance As ObjectTree
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)

Parameters

control
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


HasAttributes Property (ObjectTree)

HasAttributes Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : HasAttributes Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property HasAttributes As System.Boolean
'Usage

Dim instance As ObjectTree
Dim value As System.Boolean

value = instance.HasAttributes
public System.bool HasAttributes {get;}
public: __property System.bool get_HasAttributes();
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


HasControls Method (ObjectTree)

HasControls Method (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : HasControls Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function HasControls() As System.Boolean
'Usage

Dim instance As ObjectTree
Dim value As System.Boolean

value = instance.HasControls()
public virtual System.bool HasControls()
public: virtual System.bool HasControls();
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


Height Property (ObjectTree)

Height Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : Height Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Height As System.Web.UI.WebControls.Unit
'Usage

Dim instance As ObjectTree
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
public virtual System.Web.UI.WebControls.Unit Height {get; set;}
public: __property virtual System.Web.UI.WebControls.Unit get_Height();
public: __property virtual void set_Height(
   System.Web.UI.WebControls.Unit value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


ID Property (ObjectTree)

ID Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : ID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ID As System.String
'Usage

Dim instance As ObjectTree
Dim value As System.String

instance.ID = value

value = instance.ID
public virtual System.string ID {get; set;}
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


Init Event (ObjectTree)

Init Event (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : Init Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Init As System.EventHandler
'Usage

Dim instance As ObjectTree
Dim handler As System.EventHandler

AddHandler instance.Init, handler
public event System.EventHandler Init
public: __event System.EventHandler* Init
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


Load Event (ObjectTree)

Load Event (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : Load Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Load As System.EventHandler
'Usage

Dim instance As ObjectTree
Dim handler As System.EventHandler

AddHandler instance.Load, handler
public event System.EventHandler Load
public: __event System.EventHandler* Load
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


MergeStyle Method (ObjectTree)

MergeStyle Method (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : MergeStyle Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
'Usage

Dim instance As ObjectTree
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)

Parameters

s
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


NamingContainer Property (ObjectTree)

NamingContainer Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : NamingContainer Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property NamingContainer As System.Web.UI.Control
'Usage

Dim instance As ObjectTree
Dim value As System.Web.UI.Control

value = instance.NamingContainer
public virtual System.Web.UI.Control NamingContainer {get;}
public: __property virtual System.Web.UI.Control* get_NamingContainer();
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


Page Property (ObjectTree)

Page Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : Page Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Page As System.Web.UI.Page
'Usage

Dim instance As ObjectTree
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
public virtual System.Web.UI.Page Page {get; set;}
public: __property virtual System.Web.UI.Page* get_Page();
public: __property virtual void set_Page(
   System.Web.UI.Page* value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


Parent Property (ObjectTree)

Parent Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : Parent Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Parent As System.Web.UI.Control
'Usage

Dim instance As ObjectTree
Dim value As System.Web.UI.Control

value = instance.Parent
public virtual System.Web.UI.Control Parent {get;}
public: __property virtual System.Web.UI.Control* get_Parent();
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


PreRender Event (ObjectTree)

PreRender Event (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : PreRender Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event PreRender As System.EventHandler
'Usage

Dim instance As ObjectTree
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
public event System.EventHandler PreRender
public: __event System.EventHandler* PreRender
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


RenderBeginTag Method (ObjectTree)

RenderBeginTag Method (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : RenderBeginTag Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
'Usage

Dim instance As ObjectTree
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
public: virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
)

Parameters

writer
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


RenderControl Method (ObjectTree)

RenderControl Method (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : RenderControl Method
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


RenderControl(HtmlTextWriter) Method

RenderControl(HtmlTextWriter) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : RenderControl(HtmlTextWriter) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
'Usage

Dim instance As ObjectTree
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)

Parameters

writer
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


RenderEndTag Method (ObjectTree)

RenderEndTag Method (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : RenderEndTag Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
'Usage

Dim instance As ObjectTree
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
public virtual void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
public: virtual void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
)

Parameters

writer
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


RenderingCompatibility Property (ObjectTree)

RenderingCompatibility Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : RenderingCompatibility Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property RenderingCompatibility As System.Version
'Usage

Dim instance As ObjectTree
Dim value As System.Version

instance.RenderingCompatibility = value

value = instance.RenderingCompatibility
public virtual System.Version RenderingCompatibility {get; set;}
public: __property virtual System.Version* get_RenderingCompatibility();
public: __property virtual void set_RenderingCompatibility(
   System.Version* value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


ResolveClientUrl Method (ObjectTree)

ResolveClientUrl Method (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : ResolveClientUrl Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
'Usage

Dim instance As ObjectTree
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
public System.string ResolveClientUrl(
   System.string relativeUrl
)
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)

Parameters

relativeUrl
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


ResolveUrl Method (ObjectTree)

ResolveUrl Method (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : ResolveUrl Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
'Usage

Dim instance As ObjectTree
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
public System.string ResolveUrl(
   System.string relativeUrl
)
public: System.string* ResolveUrl(
   System.string* relativeUrl
)

Parameters

relativeUrl
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


SetRenderMethodDelegate Method (ObjectTree)

SetRenderMethodDelegate Method (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : SetRenderMethodDelegate Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
'Usage

Dim instance As ObjectTree
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)

Parameters

renderMethod
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


Site Property (ObjectTree)

Site Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Site As System.ComponentModel.ISite
'Usage

Dim instance As ObjectTree
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public System.ComponentModel.ISite Site {get; set;}
public: __property System.ComponentModel.ISite* get_Site();
public: __property void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


SkinID Property (ObjectTree)

SkinID Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : SkinID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property SkinID As System.String
'Usage

Dim instance As ObjectTree
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
public virtual System.string SkinID {get; set;}
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


Style Property (ObjectTree)

Style Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : Style Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Style As System.Web.UI.CssStyleCollection
'Usage

Dim instance As ObjectTree
Dim value As System.Web.UI.CssStyleCollection

value = instance.Style
public System.Web.UI.CssStyleCollection Style {get;}
public: __property System.Web.UI.CssStyleCollection* get_Style();
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


SupportsDisabledAttribute Property (ObjectTree)

SupportsDisabledAttribute Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : SupportsDisabledAttribute Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property SupportsDisabledAttribute As System.Boolean
'Usage

Dim instance As ObjectTree
Dim value As System.Boolean

value = instance.SupportsDisabledAttribute
public virtual System.bool SupportsDisabledAttribute {get;}
public: __property virtual System.bool get_SupportsDisabledAttribute();
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


TabIndex Property (ObjectTree)

TabIndex Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : TabIndex Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property TabIndex As System.Short
'Usage

Dim instance As ObjectTree
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
public virtual System.short TabIndex {get; set;}
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


TemplateControl Property (ObjectTree)

TemplateControl Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : TemplateControl Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property TemplateControl As System.Web.UI.TemplateControl
'Usage

Dim instance As ObjectTree
Dim value As System.Web.UI.TemplateControl

instance.TemplateControl = value

value = instance.TemplateControl
public System.Web.UI.TemplateControl TemplateControl {get; set;}
public: __property System.Web.UI.TemplateControl* get_TemplateControl();
public: __property void set_TemplateControl(
   System.Web.UI.TemplateControl* value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


TemplateSourceDirectory Property (ObjectTree)

TemplateSourceDirectory Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : TemplateSourceDirectory Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property TemplateSourceDirectory As System.String
'Usage

Dim instance As ObjectTree
Dim value As System.String

value = instance.TemplateSourceDirectory
public virtual System.string TemplateSourceDirectory {get;}
public: __property virtual System.string* get_TemplateSourceDirectory();
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


ToolTip Property (ObjectTree)

ToolTip Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : ToolTip Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ToolTip As System.String
'Usage

Dim instance As ObjectTree
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
public virtual System.string ToolTip {get; set;}
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


UniqueID Property (ObjectTree)

UniqueID Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : UniqueID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property UniqueID As System.String
'Usage

Dim instance As ObjectTree
Dim value As System.String

value = instance.UniqueID
public virtual System.string UniqueID {get;}
public: __property virtual System.string* get_UniqueID();
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


Unload Event (ObjectTree)

Unload Event (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : Unload Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Unload As System.EventHandler
'Usage

Dim instance As ObjectTree
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
public event System.EventHandler Unload
public: __event System.EventHandler* Unload
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


ViewStateMode Property (ObjectTree)

ViewStateMode Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : ViewStateMode Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
'Usage

Dim instance As ObjectTree
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


Visible Property (ObjectTree)

Visible Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : Visible Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Visible As System.Boolean
'Usage

Dim instance As ObjectTree
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
public virtual System.bool Visible {get; set;}
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


Width Property (ObjectTree)

Width Property (ObjectTree)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > ObjectTree Class : Width Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Width As System.Web.UI.WebControls.Unit
'Usage

Dim instance As ObjectTree
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
public virtual System.Web.UI.WebControls.Unit Width {get; set;}
public: __property virtual System.Web.UI.WebControls.Unit get_Width();
public: __property virtual void set_Width(
   System.Web.UI.WebControls.Unit value
);
Requirements

See Also

Reference

ObjectTree Class
ObjectTree Members


QueryBuilderControl Class Methods

QueryBuilderControl Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : QueryBuilderControl Class

For a list of all members of this type, see QueryBuilderControl members.

See Also

Reference

QueryBuilderControl Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


AccessKey Property (QueryBuilderControl)

AccessKey Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : AccessKey Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property AccessKey As System.String
'Usage

Dim instance As QueryBuilderControl
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
public virtual System.string AccessKey {get; set;}
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


ApplyStyle Method (QueryBuilderControl)

ApplyStyle Method (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : ApplyStyle Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
'Usage

Dim instance As QueryBuilderControl
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)

Parameters

s
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


ApplyStyleSheetSkin Method (QueryBuilderControl)

ApplyStyleSheetSkin Method (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : ApplyStyleSheetSkin Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
'Usage

Dim instance As QueryBuilderControl
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)

Parameters

page
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


AppRelativeTemplateSourceDirectory Property (QueryBuilderControl)

AppRelativeTemplateSourceDirectory Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : AppRelativeTemplateSourceDirectory Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AppRelativeTemplateSourceDirectory As System.String
'Usage

Dim instance As QueryBuilderControl
Dim value As System.String

instance.AppRelativeTemplateSourceDirectory = value

value = instance.AppRelativeTemplateSourceDirectory
public System.string AppRelativeTemplateSourceDirectory {get; set;}
public: __property System.string* get_AppRelativeTemplateSourceDirectory();
public: __property void set_AppRelativeTemplateSourceDirectory(
   System.string* value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


Attributes Property (QueryBuilderControl)

Attributes Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : Attributes Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Attributes As System.Web.UI.AttributeCollection
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Web.UI.AttributeCollection

value = instance.Attributes
public System.Web.UI.AttributeCollection Attributes {get;}
public: __property System.Web.UI.AttributeCollection* get_Attributes();
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


BackColor Property (QueryBuilderControl)

BackColor Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : BackColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BackColor As System.Drawing.Color
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
public virtual System.Drawing.Color BackColor {get; set;}
public: __property virtual System.Drawing.Color get_BackColor();
public: __property virtual void set_BackColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


BorderColor Property (QueryBuilderControl)

BorderColor Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : BorderColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BorderColor As System.Drawing.Color
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
public virtual System.Drawing.Color BorderColor {get; set;}
public: __property virtual System.Drawing.Color get_BorderColor();
public: __property virtual void set_BorderColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


BorderStyle Property (QueryBuilderControl)

BorderStyle Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : BorderStyle Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BorderStyle As System.Web.UI.WebControls.BorderStyle
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
public virtual System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}
public: __property virtual System.Web.UI.WebControls.BorderStyle get_BorderStyle();
public: __property virtual void set_BorderStyle(
   System.Web.UI.WebControls.BorderStyle value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


BorderWidth Property (QueryBuilderControl)

BorderWidth Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : BorderWidth Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BorderWidth As System.Web.UI.WebControls.Unit
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
public virtual System.Web.UI.WebControls.Unit BorderWidth {get; set;}
public: __property virtual System.Web.UI.WebControls.Unit get_BorderWidth();
public: __property virtual void set_BorderWidth(
   System.Web.UI.WebControls.Unit value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


ClientID Property (QueryBuilderControl)

ClientID Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : ClientID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property ClientID As System.String
'Usage

Dim instance As QueryBuilderControl
Dim value As System.String

value = instance.ClientID
public virtual System.string ClientID {get;}
public: __property virtual System.string* get_ClientID();
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


ClientIDMode Property (QueryBuilderControl)

ClientIDMode Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : ClientIDMode Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


Controls Property (QueryBuilderControl)

Controls Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : Controls Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Controls As System.Web.UI.ControlCollection
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Web.UI.ControlCollection

value = instance.Controls
public virtual System.Web.UI.ControlCollection Controls {get;}
public: __property virtual System.Web.UI.ControlCollection* get_Controls();
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


ControlStyle Property (QueryBuilderControl)

ControlStyle Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : ControlStyle Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ControlStyle As System.Web.UI.WebControls.Style
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Web.UI.WebControls.Style

value = instance.ControlStyle
public System.Web.UI.WebControls.Style ControlStyle {get;}
public: __property System.Web.UI.WebControls.Style* get_ControlStyle();
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


ControlStyleCreated Property (QueryBuilderControl)

ControlStyleCreated Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : ControlStyleCreated Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ControlStyleCreated As System.Boolean
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Boolean

value = instance.ControlStyleCreated
public System.bool ControlStyleCreated {get;}
public: __property System.bool get_ControlStyleCreated();
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


CopyBaseAttributes Method (QueryBuilderControl)

CopyBaseAttributes Method (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : CopyBaseAttributes Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
'Usage

Dim instance As QueryBuilderControl
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)

Parameters

controlSrc
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


CssClass Property (QueryBuilderControl)

CssClass Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : CssClass Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property CssClass As System.String
'Usage

Dim instance As QueryBuilderControl
Dim value As System.String

instance.CssClass = value

value = instance.CssClass
public virtual System.string CssClass {get; set;}
public: __property virtual System.string* get_CssClass();
public: __property virtual void set_CssClass(
   System.string* value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


DataBind Method (QueryBuilderControl)

DataBind Method (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : DataBind Method
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


DataBind() Method

DataBind() Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : DataBind() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub DataBind()
'Usage

Dim instance As QueryBuilderControl

instance.DataBind()
public virtual void DataBind()
public: virtual void DataBind();
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


DataBinding Event (QueryBuilderControl)

DataBinding Event (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : DataBinding Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DataBinding As System.EventHandler
'Usage

Dim instance As QueryBuilderControl
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
public event System.EventHandler DataBinding
public: __event System.EventHandler* DataBinding
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


Dispose Method (QueryBuilderControl)

Dispose Method (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : Dispose Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub Dispose()
'Usage

Dim instance As QueryBuilderControl

instance.Dispose()
public virtual void Dispose()
public: virtual void Dispose();
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


Disposed Event (QueryBuilderControl)

Disposed Event (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As QueryBuilderControl
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


Enabled Property (QueryBuilderControl)

Enabled Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : Enabled Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Enabled As System.Boolean
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
public virtual System.bool Enabled {get; set;}
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


EnableTheming Property (QueryBuilderControl)

EnableTheming Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : EnableTheming Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property EnableTheming As System.Boolean
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
public virtual System.bool EnableTheming {get; set;}
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


EnableViewState Property (QueryBuilderControl)

EnableViewState Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : EnableViewState Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property EnableViewState As System.Boolean
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
public virtual System.bool EnableViewState {get; set;}
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


FindControl Method (QueryBuilderControl)

FindControl Method (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : FindControl Method
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


FindControl(String) Method

FindControl(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : FindControl(String) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
'Usage

Dim instance As QueryBuilderControl
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
public virtual System.Web.UI.Control FindControl(
   System.string id
)
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)

Parameters

id
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


Focus Method (QueryBuilderControl)

Focus Method (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : Focus Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub Focus()
'Usage

Dim instance As QueryBuilderControl

instance.Focus()
public virtual void Focus()
public: virtual void Focus();
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


Font Property (QueryBuilderControl)

Font Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : Font Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
public virtual System.Web.UI.WebControls.FontInfo Font {get;}
public: __property virtual System.Web.UI.WebControls.FontInfo* get_Font();
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


ForeColor Property (QueryBuilderControl)

ForeColor Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : ForeColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ForeColor As System.Drawing.Color
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
public virtual System.Drawing.Color ForeColor {get; set;}
public: __property virtual System.Drawing.Color get_ForeColor();
public: __property virtual void set_ForeColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


GetRouteUrl Method (QueryBuilderControl)

GetRouteUrl Method (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : GetRouteUrl Method
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


GetRouteUrl(Object) Method

GetRouteUrl(Object) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class > GetRouteUrl Method : GetRouteUrl(Object) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
'Usage

Dim instance As QueryBuilderControl
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
public System.string GetRouteUrl(
   System.object routeParameters
)
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)

Parameters

routeParameters
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

GetRouteUrl(RouteValueDictionary) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
'Usage

Dim instance As QueryBuilderControl
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)

Parameters

routeParameters
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members
Overload List


GetRouteUrl(String,Object) Method

GetRouteUrl(String,Object) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
'Usage

Dim instance As QueryBuilderControl
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)

Parameters

routeName
routeParameters
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

GetRouteUrl(String,RouteValueDictionary) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
'Usage

Dim instance As QueryBuilderControl
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)

Parameters

routeName
routeParameters
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members
Overload List


GetUniqueIDRelativeTo Method (QueryBuilderControl)

GetUniqueIDRelativeTo Method (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : GetUniqueIDRelativeTo Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
'Usage

Dim instance As QueryBuilderControl
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)

Parameters

control
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


HasAttributes Property (QueryBuilderControl)

HasAttributes Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : HasAttributes Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property HasAttributes As System.Boolean
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Boolean

value = instance.HasAttributes
public System.bool HasAttributes {get;}
public: __property System.bool get_HasAttributes();
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


HasControls Method (QueryBuilderControl)

HasControls Method (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : HasControls Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function HasControls() As System.Boolean
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Boolean

value = instance.HasControls()
public virtual System.bool HasControls()
public: virtual System.bool HasControls();
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


Height Property (QueryBuilderControl)

Height Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : Height Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Height As System.Web.UI.WebControls.Unit
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
public virtual System.Web.UI.WebControls.Unit Height {get; set;}
public: __property virtual System.Web.UI.WebControls.Unit get_Height();
public: __property virtual void set_Height(
   System.Web.UI.WebControls.Unit value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


ID Property (QueryBuilderControl)

ID Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : ID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ID As System.String
'Usage

Dim instance As QueryBuilderControl
Dim value As System.String

instance.ID = value

value = instance.ID
public virtual System.string ID {get; set;}
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


Load Event (QueryBuilderControl)

Load Event (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : Load Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Load As System.EventHandler
'Usage

Dim instance As QueryBuilderControl
Dim handler As System.EventHandler

AddHandler instance.Load, handler
public event System.EventHandler Load
public: __event System.EventHandler* Load
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


MergeStyle Method (QueryBuilderControl)

MergeStyle Method (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : MergeStyle Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
'Usage

Dim instance As QueryBuilderControl
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)

Parameters

s
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


NamingContainer Property (QueryBuilderControl)

NamingContainer Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : NamingContainer Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property NamingContainer As System.Web.UI.Control
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Web.UI.Control

value = instance.NamingContainer
public virtual System.Web.UI.Control NamingContainer {get;}
public: __property virtual System.Web.UI.Control* get_NamingContainer();
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


Page Property (QueryBuilderControl)

Page Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : Page Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Page As System.Web.UI.Page
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
public virtual System.Web.UI.Page Page {get; set;}
public: __property virtual System.Web.UI.Page* get_Page();
public: __property virtual void set_Page(
   System.Web.UI.Page* value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


Parent Property (QueryBuilderControl)

Parent Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : Parent Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Parent As System.Web.UI.Control
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Web.UI.Control

value = instance.Parent
public virtual System.Web.UI.Control Parent {get;}
public: __property virtual System.Web.UI.Control* get_Parent();
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


PreRender Event (QueryBuilderControl)

PreRender Event (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : PreRender Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event PreRender As System.EventHandler
'Usage

Dim instance As QueryBuilderControl
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
public event System.EventHandler PreRender
public: __event System.EventHandler* PreRender
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


RenderBeginTag Method (QueryBuilderControl)

RenderBeginTag Method (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : RenderBeginTag Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
'Usage

Dim instance As QueryBuilderControl
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
public: virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
)

Parameters

writer
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


RenderControl Method (QueryBuilderControl)

RenderControl Method (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : RenderControl Method
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


RenderControl(HtmlTextWriter) Method

RenderControl(HtmlTextWriter) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : RenderControl(HtmlTextWriter) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
'Usage

Dim instance As QueryBuilderControl
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)

Parameters

writer
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


RenderEndTag Method (QueryBuilderControl)

RenderEndTag Method (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : RenderEndTag Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
'Usage

Dim instance As QueryBuilderControl
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
public virtual void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
public: virtual void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
)

Parameters

writer
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


RenderingCompatibility Property (QueryBuilderControl)

RenderingCompatibility Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : RenderingCompatibility Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property RenderingCompatibility As System.Version
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Version

instance.RenderingCompatibility = value

value = instance.RenderingCompatibility
public virtual System.Version RenderingCompatibility {get; set;}
public: __property virtual System.Version* get_RenderingCompatibility();
public: __property virtual void set_RenderingCompatibility(
   System.Version* value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


ResolveClientUrl Method (QueryBuilderControl)

ResolveClientUrl Method (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : ResolveClientUrl Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
'Usage

Dim instance As QueryBuilderControl
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
public System.string ResolveClientUrl(
   System.string relativeUrl
)
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)

Parameters

relativeUrl
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


ResolveUrl Method (QueryBuilderControl)

ResolveUrl Method (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : ResolveUrl Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
'Usage

Dim instance As QueryBuilderControl
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
public System.string ResolveUrl(
   System.string relativeUrl
)
public: System.string* ResolveUrl(
   System.string* relativeUrl
)

Parameters

relativeUrl
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


SetRenderMethodDelegate Method (QueryBuilderControl)

SetRenderMethodDelegate Method (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : SetRenderMethodDelegate Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
'Usage

Dim instance As QueryBuilderControl
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)

Parameters

renderMethod
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


Site Property (QueryBuilderControl)

Site Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Site As System.ComponentModel.ISite
'Usage

Dim instance As QueryBuilderControl
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public System.ComponentModel.ISite Site {get; set;}
public: __property System.ComponentModel.ISite* get_Site();
public: __property void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


SkinID Property (QueryBuilderControl)

SkinID Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : SkinID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property SkinID As System.String
'Usage

Dim instance As QueryBuilderControl
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
public virtual System.string SkinID {get; set;}
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


Style Property (QueryBuilderControl)

Style Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : Style Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Style As System.Web.UI.CssStyleCollection
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Web.UI.CssStyleCollection

value = instance.Style
public System.Web.UI.CssStyleCollection Style {get;}
public: __property System.Web.UI.CssStyleCollection* get_Style();
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


SupportsDisabledAttribute Property (QueryBuilderControl)

SupportsDisabledAttribute Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : SupportsDisabledAttribute Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property SupportsDisabledAttribute As System.Boolean
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Boolean

value = instance.SupportsDisabledAttribute
public virtual System.bool SupportsDisabledAttribute {get;}
public: __property virtual System.bool get_SupportsDisabledAttribute();
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


TabIndex Property (QueryBuilderControl)

TabIndex Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : TabIndex Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property TabIndex As System.Short
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
public virtual System.short TabIndex {get; set;}
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


TemplateControl Property (QueryBuilderControl)

TemplateControl Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : TemplateControl Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property TemplateControl As System.Web.UI.TemplateControl
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Web.UI.TemplateControl

instance.TemplateControl = value

value = instance.TemplateControl
public System.Web.UI.TemplateControl TemplateControl {get; set;}
public: __property System.Web.UI.TemplateControl* get_TemplateControl();
public: __property void set_TemplateControl(
   System.Web.UI.TemplateControl* value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


TemplateSourceDirectory Property (QueryBuilderControl)

TemplateSourceDirectory Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : TemplateSourceDirectory Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property TemplateSourceDirectory As System.String
'Usage

Dim instance As QueryBuilderControl
Dim value As System.String

value = instance.TemplateSourceDirectory
public virtual System.string TemplateSourceDirectory {get;}
public: __property virtual System.string* get_TemplateSourceDirectory();
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


ToolTip Property (QueryBuilderControl)

ToolTip Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : ToolTip Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ToolTip As System.String
'Usage

Dim instance As QueryBuilderControl
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
public virtual System.string ToolTip {get; set;}
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


UniqueID Property (QueryBuilderControl)

UniqueID Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : UniqueID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property UniqueID As System.String
'Usage

Dim instance As QueryBuilderControl
Dim value As System.String

value = instance.UniqueID
public virtual System.string UniqueID {get;}
public: __property virtual System.string* get_UniqueID();
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


Unload Event (QueryBuilderControl)

Unload Event (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : Unload Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Unload As System.EventHandler
'Usage

Dim instance As QueryBuilderControl
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
public event System.EventHandler Unload
public: __event System.EventHandler* Unload
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


ViewStateMode Property (QueryBuilderControl)

ViewStateMode Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : ViewStateMode Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


Visible Property (QueryBuilderControl)

Visible Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : Visible Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Visible As System.Boolean
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
public virtual System.bool Visible {get; set;}
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


Width Property (QueryBuilderControl)

Width Property (QueryBuilderControl)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > QueryBuilderControl Class : Width Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Width As System.Web.UI.WebControls.Unit
'Usage

Dim instance As QueryBuilderControl
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
public virtual System.Web.UI.WebControls.Unit Width {get; set;}
public: __property virtual System.Web.UI.WebControls.Unit get_Width();
public: __property virtual void set_Width(
   System.Web.UI.WebControls.Unit value
);
Requirements

See Also

Reference

QueryBuilderControl Class
QueryBuilderControl Members


SqlEditor Class Events

SqlEditor Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : SqlEditor Class

For a list of all members of this type, see SqlEditor members.

See Also

Reference

SqlEditor Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


SqlEditor Class Methods

SqlEditor Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : SqlEditor Class

For a list of all members of this type, see SqlEditor members.

See Also

Reference

SqlEditor Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


AccessKey Property (SqlEditor)

AccessKey Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : AccessKey Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property AccessKey As System.String
'Usage

Dim instance As SqlEditor
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
public virtual System.string AccessKey {get; set;}
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


ApplyStyle Method (SqlEditor)

ApplyStyle Method (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : ApplyStyle Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
'Usage

Dim instance As SqlEditor
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)

Parameters

s
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


ApplyStyleSheetSkin Method (SqlEditor)

ApplyStyleSheetSkin Method (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : ApplyStyleSheetSkin Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
'Usage

Dim instance As SqlEditor
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)

Parameters

page
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


AppRelativeTemplateSourceDirectory Property (SqlEditor)

AppRelativeTemplateSourceDirectory Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : AppRelativeTemplateSourceDirectory Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AppRelativeTemplateSourceDirectory As System.String
'Usage

Dim instance As SqlEditor
Dim value As System.String

instance.AppRelativeTemplateSourceDirectory = value

value = instance.AppRelativeTemplateSourceDirectory
public System.string AppRelativeTemplateSourceDirectory {get; set;}
public: __property System.string* get_AppRelativeTemplateSourceDirectory();
public: __property void set_AppRelativeTemplateSourceDirectory(
   System.string* value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


Attributes Property (SqlEditor)

Attributes Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : Attributes Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Attributes As System.Web.UI.AttributeCollection
'Usage

Dim instance As SqlEditor
Dim value As System.Web.UI.AttributeCollection

value = instance.Attributes
public System.Web.UI.AttributeCollection Attributes {get;}
public: __property System.Web.UI.AttributeCollection* get_Attributes();
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


BackColor Property (SqlEditor)

BackColor Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : BackColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BackColor As System.Drawing.Color
'Usage

Dim instance As SqlEditor
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
public virtual System.Drawing.Color BackColor {get; set;}
public: __property virtual System.Drawing.Color get_BackColor();
public: __property virtual void set_BackColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


BorderColor Property (SqlEditor)

BorderColor Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : BorderColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BorderColor As System.Drawing.Color
'Usage

Dim instance As SqlEditor
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
public virtual System.Drawing.Color BorderColor {get; set;}
public: __property virtual System.Drawing.Color get_BorderColor();
public: __property virtual void set_BorderColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


BorderStyle Property (SqlEditor)

BorderStyle Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : BorderStyle Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BorderStyle As System.Web.UI.WebControls.BorderStyle
'Usage

Dim instance As SqlEditor
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
public virtual System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}
public: __property virtual System.Web.UI.WebControls.BorderStyle get_BorderStyle();
public: __property virtual void set_BorderStyle(
   System.Web.UI.WebControls.BorderStyle value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


BorderWidth Property (SqlEditor)

BorderWidth Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : BorderWidth Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BorderWidth As System.Web.UI.WebControls.Unit
'Usage

Dim instance As SqlEditor
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
public virtual System.Web.UI.WebControls.Unit BorderWidth {get; set;}
public: __property virtual System.Web.UI.WebControls.Unit get_BorderWidth();
public: __property virtual void set_BorderWidth(
   System.Web.UI.WebControls.Unit value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


ClientIDMode Property (SqlEditor)

ClientIDMode Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : ClientIDMode Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
'Usage

Dim instance As SqlEditor
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


Controls Property (SqlEditor)

Controls Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : Controls Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Controls As System.Web.UI.ControlCollection
'Usage

Dim instance As SqlEditor
Dim value As System.Web.UI.ControlCollection

value = instance.Controls
public virtual System.Web.UI.ControlCollection Controls {get;}
public: __property virtual System.Web.UI.ControlCollection* get_Controls();
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


ControlStyle Property (SqlEditor)

ControlStyle Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : ControlStyle Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ControlStyle As System.Web.UI.WebControls.Style
'Usage

Dim instance As SqlEditor
Dim value As System.Web.UI.WebControls.Style

value = instance.ControlStyle
public System.Web.UI.WebControls.Style ControlStyle {get;}
public: __property System.Web.UI.WebControls.Style* get_ControlStyle();
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


ControlStyleCreated Property (SqlEditor)

ControlStyleCreated Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : ControlStyleCreated Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ControlStyleCreated As System.Boolean
'Usage

Dim instance As SqlEditor
Dim value As System.Boolean

value = instance.ControlStyleCreated
public System.bool ControlStyleCreated {get;}
public: __property System.bool get_ControlStyleCreated();
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


CopyBaseAttributes Method (SqlEditor)

CopyBaseAttributes Method (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : CopyBaseAttributes Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
'Usage

Dim instance As SqlEditor
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)

Parameters

controlSrc
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


CssClass Property (SqlEditor)

CssClass Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : CssClass Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property CssClass As System.String
'Usage

Dim instance As SqlEditor
Dim value As System.String

instance.CssClass = value

value = instance.CssClass
public virtual System.string CssClass {get; set;}
public: __property virtual System.string* get_CssClass();
public: __property virtual void set_CssClass(
   System.string* value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


DataBind Method (SqlEditor)

DataBind Method (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : DataBind Method
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


DataBind() Method

DataBind() Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : DataBind() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub DataBind()
'Usage

Dim instance As SqlEditor

instance.DataBind()
public virtual void DataBind()
public: virtual void DataBind();
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


DataBinding Event (SqlEditor)

DataBinding Event (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : DataBinding Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DataBinding As System.EventHandler
'Usage

Dim instance As SqlEditor
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
public event System.EventHandler DataBinding
public: __event System.EventHandler* DataBinding
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


Dispose Method (SqlEditor)

Dispose Method (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : Dispose Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub Dispose()
'Usage

Dim instance As SqlEditor

instance.Dispose()
public virtual void Dispose()
public: virtual void Dispose();
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


Disposed Event (SqlEditor)

Disposed Event (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As SqlEditor
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


Enabled Property (SqlEditor)

Enabled Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : Enabled Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Enabled As System.Boolean
'Usage

Dim instance As SqlEditor
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
public virtual System.bool Enabled {get; set;}
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


EnableTheming Property (SqlEditor)

EnableTheming Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : EnableTheming Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property EnableTheming As System.Boolean
'Usage

Dim instance As SqlEditor
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
public virtual System.bool EnableTheming {get; set;}
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


EnableViewState Property (SqlEditor)

EnableViewState Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : EnableViewState Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property EnableViewState As System.Boolean
'Usage

Dim instance As SqlEditor
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
public virtual System.bool EnableViewState {get; set;}
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


FindControl Method (SqlEditor)

FindControl Method (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : FindControl Method
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


FindControl(String) Method

FindControl(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : FindControl(String) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
'Usage

Dim instance As SqlEditor
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
public virtual System.Web.UI.Control FindControl(
   System.string id
)
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)

Parameters

id
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


Focus Method (SqlEditor)

Focus Method (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : Focus Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub Focus()
'Usage

Dim instance As SqlEditor

instance.Focus()
public virtual void Focus()
public: virtual void Focus();
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


Font Property (SqlEditor)

Font Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : Font Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
'Usage

Dim instance As SqlEditor
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
public virtual System.Web.UI.WebControls.FontInfo Font {get;}
public: __property virtual System.Web.UI.WebControls.FontInfo* get_Font();
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


ForeColor Property (SqlEditor)

ForeColor Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : ForeColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ForeColor As System.Drawing.Color
'Usage

Dim instance As SqlEditor
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
public virtual System.Drawing.Color ForeColor {get; set;}
public: __property virtual System.Drawing.Color get_ForeColor();
public: __property virtual void set_ForeColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


GetRouteUrl Method (SqlEditor)

GetRouteUrl Method (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : GetRouteUrl Method
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


GetRouteUrl(Object) Method

GetRouteUrl(Object) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class > GetRouteUrl Method : GetRouteUrl(Object) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
'Usage

Dim instance As SqlEditor
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
public System.string GetRouteUrl(
   System.object routeParameters
)
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)

Parameters

routeParameters
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

GetRouteUrl(RouteValueDictionary) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
'Usage

Dim instance As SqlEditor
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)

Parameters

routeParameters
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members
Overload List


GetRouteUrl(String,Object) Method

GetRouteUrl(String,Object) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
'Usage

Dim instance As SqlEditor
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)

Parameters

routeName
routeParameters
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

GetRouteUrl(String,RouteValueDictionary) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
'Usage

Dim instance As SqlEditor
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)

Parameters

routeName
routeParameters
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members
Overload List


GetUniqueIDRelativeTo Method (SqlEditor)

GetUniqueIDRelativeTo Method (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : GetUniqueIDRelativeTo Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
'Usage

Dim instance As SqlEditor
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)

Parameters

control
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


HasAttributes Property (SqlEditor)

HasAttributes Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : HasAttributes Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property HasAttributes As System.Boolean
'Usage

Dim instance As SqlEditor
Dim value As System.Boolean

value = instance.HasAttributes
public System.bool HasAttributes {get;}
public: __property System.bool get_HasAttributes();
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


HasControls Method (SqlEditor)

HasControls Method (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : HasControls Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function HasControls() As System.Boolean
'Usage

Dim instance As SqlEditor
Dim value As System.Boolean

value = instance.HasControls()
public virtual System.bool HasControls()
public: virtual System.bool HasControls();
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


Height Property (SqlEditor)

Height Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : Height Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Height As System.Web.UI.WebControls.Unit
'Usage

Dim instance As SqlEditor
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
public virtual System.Web.UI.WebControls.Unit Height {get; set;}
public: __property virtual System.Web.UI.WebControls.Unit get_Height();
public: __property virtual void set_Height(
   System.Web.UI.WebControls.Unit value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


ID Property (SqlEditor)

ID Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : ID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ID As System.String
'Usage

Dim instance As SqlEditor
Dim value As System.String

instance.ID = value

value = instance.ID
public virtual System.string ID {get; set;}
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


Init Event (SqlEditor)

Init Event (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : Init Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Init As System.EventHandler
'Usage

Dim instance As SqlEditor
Dim handler As System.EventHandler

AddHandler instance.Init, handler
public event System.EventHandler Init
public: __event System.EventHandler* Init
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


Load Event (SqlEditor)

Load Event (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : Load Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Load As System.EventHandler
'Usage

Dim instance As SqlEditor
Dim handler As System.EventHandler

AddHandler instance.Load, handler
public event System.EventHandler Load
public: __event System.EventHandler* Load
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


MergeStyle Method (SqlEditor)

MergeStyle Method (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : MergeStyle Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
'Usage

Dim instance As SqlEditor
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)

Parameters

s
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


NamingContainer Property (SqlEditor)

NamingContainer Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : NamingContainer Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property NamingContainer As System.Web.UI.Control
'Usage

Dim instance As SqlEditor
Dim value As System.Web.UI.Control

value = instance.NamingContainer
public virtual System.Web.UI.Control NamingContainer {get;}
public: __property virtual System.Web.UI.Control* get_NamingContainer();
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


Page Property (SqlEditor)

Page Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : Page Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Page As System.Web.UI.Page
'Usage

Dim instance As SqlEditor
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
public virtual System.Web.UI.Page Page {get; set;}
public: __property virtual System.Web.UI.Page* get_Page();
public: __property virtual void set_Page(
   System.Web.UI.Page* value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


Parent Property (SqlEditor)

Parent Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : Parent Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Parent As System.Web.UI.Control
'Usage

Dim instance As SqlEditor
Dim value As System.Web.UI.Control

value = instance.Parent
public virtual System.Web.UI.Control Parent {get;}
public: __property virtual System.Web.UI.Control* get_Parent();
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


PreRender Event (SqlEditor)

PreRender Event (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : PreRender Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event PreRender As System.EventHandler
'Usage

Dim instance As SqlEditor
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
public event System.EventHandler PreRender
public: __event System.EventHandler* PreRender
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


RenderBeginTag Method (SqlEditor)

RenderBeginTag Method (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : RenderBeginTag Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
'Usage

Dim instance As SqlEditor
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
public: virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
)

Parameters

writer
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


RenderControl Method (SqlEditor)

RenderControl Method (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : RenderControl Method
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


RenderControl(HtmlTextWriter) Method

RenderControl(HtmlTextWriter) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : RenderControl(HtmlTextWriter) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
'Usage

Dim instance As SqlEditor
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)

Parameters

writer
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


RenderEndTag Method (SqlEditor)

RenderEndTag Method (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : RenderEndTag Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
'Usage

Dim instance As SqlEditor
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
public virtual void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
public: virtual void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
)

Parameters

writer
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


RenderingCompatibility Property (SqlEditor)

RenderingCompatibility Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : RenderingCompatibility Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property RenderingCompatibility As System.Version
'Usage

Dim instance As SqlEditor
Dim value As System.Version

instance.RenderingCompatibility = value

value = instance.RenderingCompatibility
public virtual System.Version RenderingCompatibility {get; set;}
public: __property virtual System.Version* get_RenderingCompatibility();
public: __property virtual void set_RenderingCompatibility(
   System.Version* value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


ResolveClientUrl Method (SqlEditor)

ResolveClientUrl Method (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : ResolveClientUrl Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
'Usage

Dim instance As SqlEditor
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
public System.string ResolveClientUrl(
   System.string relativeUrl
)
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)

Parameters

relativeUrl
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


ResolveUrl Method (SqlEditor)

ResolveUrl Method (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : ResolveUrl Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
'Usage

Dim instance As SqlEditor
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
public System.string ResolveUrl(
   System.string relativeUrl
)
public: System.string* ResolveUrl(
   System.string* relativeUrl
)

Parameters

relativeUrl
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


SetRenderMethodDelegate Method (SqlEditor)

SetRenderMethodDelegate Method (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : SetRenderMethodDelegate Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
'Usage

Dim instance As SqlEditor
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)

Parameters

renderMethod
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


Site Property (SqlEditor)

Site Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Site As System.ComponentModel.ISite
'Usage

Dim instance As SqlEditor
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public System.ComponentModel.ISite Site {get; set;}
public: __property System.ComponentModel.ISite* get_Site();
public: __property void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


SkinID Property (SqlEditor)

SkinID Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : SkinID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property SkinID As System.String
'Usage

Dim instance As SqlEditor
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
public virtual System.string SkinID {get; set;}
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


Style Property (SqlEditor)

Style Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : Style Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Style As System.Web.UI.CssStyleCollection
'Usage

Dim instance As SqlEditor
Dim value As System.Web.UI.CssStyleCollection

value = instance.Style
public System.Web.UI.CssStyleCollection Style {get;}
public: __property System.Web.UI.CssStyleCollection* get_Style();
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


SupportsDisabledAttribute Property (SqlEditor)

SupportsDisabledAttribute Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : SupportsDisabledAttribute Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property SupportsDisabledAttribute As System.Boolean
'Usage

Dim instance As SqlEditor
Dim value As System.Boolean

value = instance.SupportsDisabledAttribute
public virtual System.bool SupportsDisabledAttribute {get;}
public: __property virtual System.bool get_SupportsDisabledAttribute();
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


TabIndex Property (SqlEditor)

TabIndex Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : TabIndex Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property TabIndex As System.Short
'Usage

Dim instance As SqlEditor
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
public virtual System.short TabIndex {get; set;}
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


TemplateControl Property (SqlEditor)

TemplateControl Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : TemplateControl Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property TemplateControl As System.Web.UI.TemplateControl
'Usage

Dim instance As SqlEditor
Dim value As System.Web.UI.TemplateControl

instance.TemplateControl = value

value = instance.TemplateControl
public System.Web.UI.TemplateControl TemplateControl {get; set;}
public: __property System.Web.UI.TemplateControl* get_TemplateControl();
public: __property void set_TemplateControl(
   System.Web.UI.TemplateControl* value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


TemplateSourceDirectory Property (SqlEditor)

TemplateSourceDirectory Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : TemplateSourceDirectory Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property TemplateSourceDirectory As System.String
'Usage

Dim instance As SqlEditor
Dim value As System.String

value = instance.TemplateSourceDirectory
public virtual System.string TemplateSourceDirectory {get;}
public: __property virtual System.string* get_TemplateSourceDirectory();
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


ToolTip Property (SqlEditor)

ToolTip Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : ToolTip Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ToolTip As System.String
'Usage

Dim instance As SqlEditor
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
public virtual System.string ToolTip {get; set;}
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


UniqueID Property (SqlEditor)

UniqueID Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : UniqueID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property UniqueID As System.String
'Usage

Dim instance As SqlEditor
Dim value As System.String

value = instance.UniqueID
public virtual System.string UniqueID {get;}
public: __property virtual System.string* get_UniqueID();
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


Unload Event (SqlEditor)

Unload Event (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : Unload Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Unload As System.EventHandler
'Usage

Dim instance As SqlEditor
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
public event System.EventHandler Unload
public: __event System.EventHandler* Unload
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


ViewStateMode Property (SqlEditor)

ViewStateMode Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : ViewStateMode Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
'Usage

Dim instance As SqlEditor
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


Visible Property (SqlEditor)

Visible Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : Visible Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Visible As System.Boolean
'Usage

Dim instance As SqlEditor
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
public virtual System.bool Visible {get; set;}
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


Width Property (SqlEditor)

Width Property (SqlEditor)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > SqlEditor Class : Width Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Width As System.Web.UI.WebControls.Unit
'Usage

Dim instance As SqlEditor
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
public virtual System.Web.UI.WebControls.Unit Width {get; set;}
public: __property virtual System.Web.UI.WebControls.Unit get_Width();
public: __property virtual void set_Width(
   System.Web.UI.WebControls.Unit value
);
Requirements

See Also

Reference

SqlEditor Class
SqlEditor Members


StatusBar Class Events

StatusBar Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : StatusBar Class

For a list of all members of this type, see StatusBar members.

See Also

Reference

StatusBar Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


StatusBar Class Methods

StatusBar Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace : StatusBar Class

For a list of all members of this type, see StatusBar members.

See Also

Reference

StatusBar Class
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace


AccessKey Property (StatusBar)

AccessKey Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : AccessKey Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property AccessKey As System.String
'Usage

Dim instance As StatusBar
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
public virtual System.string AccessKey {get; set;}
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


ApplyStyle Method (StatusBar)

ApplyStyle Method (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : ApplyStyle Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
'Usage

Dim instance As StatusBar
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)

Parameters

s
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


ApplyStyleSheetSkin Method (StatusBar)

ApplyStyleSheetSkin Method (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : ApplyStyleSheetSkin Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
'Usage

Dim instance As StatusBar
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)

Parameters

page
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


AppRelativeTemplateSourceDirectory Property (StatusBar)

AppRelativeTemplateSourceDirectory Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : AppRelativeTemplateSourceDirectory Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property AppRelativeTemplateSourceDirectory As System.String
'Usage

Dim instance As StatusBar
Dim value As System.String

instance.AppRelativeTemplateSourceDirectory = value

value = instance.AppRelativeTemplateSourceDirectory
public System.string AppRelativeTemplateSourceDirectory {get; set;}
public: __property System.string* get_AppRelativeTemplateSourceDirectory();
public: __property void set_AppRelativeTemplateSourceDirectory(
   System.string* value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


Attributes Property (StatusBar)

Attributes Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : Attributes Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Attributes As System.Web.UI.AttributeCollection
'Usage

Dim instance As StatusBar
Dim value As System.Web.UI.AttributeCollection

value = instance.Attributes
public System.Web.UI.AttributeCollection Attributes {get;}
public: __property System.Web.UI.AttributeCollection* get_Attributes();
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


BackColor Property (StatusBar)

BackColor Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : BackColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BackColor As System.Drawing.Color
'Usage

Dim instance As StatusBar
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
public virtual System.Drawing.Color BackColor {get; set;}
public: __property virtual System.Drawing.Color get_BackColor();
public: __property virtual void set_BackColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


BorderColor Property (StatusBar)

BorderColor Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : BorderColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BorderColor As System.Drawing.Color
'Usage

Dim instance As StatusBar
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
public virtual System.Drawing.Color BorderColor {get; set;}
public: __property virtual System.Drawing.Color get_BorderColor();
public: __property virtual void set_BorderColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


BorderStyle Property (StatusBar)

BorderStyle Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : BorderStyle Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BorderStyle As System.Web.UI.WebControls.BorderStyle
'Usage

Dim instance As StatusBar
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
public virtual System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}
public: __property virtual System.Web.UI.WebControls.BorderStyle get_BorderStyle();
public: __property virtual void set_BorderStyle(
   System.Web.UI.WebControls.BorderStyle value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


BorderWidth Property (StatusBar)

BorderWidth Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : BorderWidth Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property BorderWidth As System.Web.UI.WebControls.Unit
'Usage

Dim instance As StatusBar
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
public virtual System.Web.UI.WebControls.Unit BorderWidth {get; set;}
public: __property virtual System.Web.UI.WebControls.Unit get_BorderWidth();
public: __property virtual void set_BorderWidth(
   System.Web.UI.WebControls.Unit value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


ClientIDMode Property (StatusBar)

ClientIDMode Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : ClientIDMode Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
'Usage

Dim instance As StatusBar
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


Controls Property (StatusBar)

Controls Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : Controls Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Controls As System.Web.UI.ControlCollection
'Usage

Dim instance As StatusBar
Dim value As System.Web.UI.ControlCollection

value = instance.Controls
public virtual System.Web.UI.ControlCollection Controls {get;}
public: __property virtual System.Web.UI.ControlCollection* get_Controls();
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


ControlStyle Property (StatusBar)

ControlStyle Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : ControlStyle Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ControlStyle As System.Web.UI.WebControls.Style
'Usage

Dim instance As StatusBar
Dim value As System.Web.UI.WebControls.Style

value = instance.ControlStyle
public System.Web.UI.WebControls.Style ControlStyle {get;}
public: __property System.Web.UI.WebControls.Style* get_ControlStyle();
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


ControlStyleCreated Property (StatusBar)

ControlStyleCreated Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : ControlStyleCreated Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ControlStyleCreated As System.Boolean
'Usage

Dim instance As StatusBar
Dim value As System.Boolean

value = instance.ControlStyleCreated
public System.bool ControlStyleCreated {get;}
public: __property System.bool get_ControlStyleCreated();
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


CopyBaseAttributes Method (StatusBar)

CopyBaseAttributes Method (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : CopyBaseAttributes Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
'Usage

Dim instance As StatusBar
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)

Parameters

controlSrc
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


CssClass Property (StatusBar)

CssClass Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : CssClass Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property CssClass As System.String
'Usage

Dim instance As StatusBar
Dim value As System.String

instance.CssClass = value

value = instance.CssClass
public virtual System.string CssClass {get; set;}
public: __property virtual System.string* get_CssClass();
public: __property virtual void set_CssClass(
   System.string* value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


DataBind Method (StatusBar)

DataBind Method (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : DataBind Method
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


DataBind() Method

DataBind() Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : DataBind() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub DataBind()
'Usage

Dim instance As StatusBar

instance.DataBind()
public virtual void DataBind()
public: virtual void DataBind();
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


DataBinding Event (StatusBar)

DataBinding Event (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : DataBinding Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event DataBinding As System.EventHandler
'Usage

Dim instance As StatusBar
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
public event System.EventHandler DataBinding
public: __event System.EventHandler* DataBinding
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


Dispose Method (StatusBar)

Dispose Method (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : Dispose Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub Dispose()
'Usage

Dim instance As StatusBar

instance.Dispose()
public virtual void Dispose()
public: virtual void Dispose();
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


Disposed Event (StatusBar)

Disposed Event (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As StatusBar
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


Enabled Property (StatusBar)

Enabled Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : Enabled Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Enabled As System.Boolean
'Usage

Dim instance As StatusBar
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
public virtual System.bool Enabled {get; set;}
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


EnableTheming Property (StatusBar)

EnableTheming Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : EnableTheming Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property EnableTheming As System.Boolean
'Usage

Dim instance As StatusBar
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
public virtual System.bool EnableTheming {get; set;}
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


EnableViewState Property (StatusBar)

EnableViewState Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : EnableViewState Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property EnableViewState As System.Boolean
'Usage

Dim instance As StatusBar
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
public virtual System.bool EnableViewState {get; set;}
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


FindControl Method (StatusBar)

FindControl Method (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : FindControl Method
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


FindControl(String) Method

FindControl(String) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : FindControl(String) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
'Usage

Dim instance As StatusBar
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
public virtual System.Web.UI.Control FindControl(
   System.string id
)
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)

Parameters

id
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


Focus Method (StatusBar)

Focus Method (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : Focus Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub Focus()
'Usage

Dim instance As StatusBar

instance.Focus()
public virtual void Focus()
public: virtual void Focus();
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


Font Property (StatusBar)

Font Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : Font Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
'Usage

Dim instance As StatusBar
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
public virtual System.Web.UI.WebControls.FontInfo Font {get;}
public: __property virtual System.Web.UI.WebControls.FontInfo* get_Font();
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


ForeColor Property (StatusBar)

ForeColor Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : ForeColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ForeColor As System.Drawing.Color
'Usage

Dim instance As StatusBar
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
public virtual System.Drawing.Color ForeColor {get; set;}
public: __property virtual System.Drawing.Color get_ForeColor();
public: __property virtual void set_ForeColor(
   System.Drawing.Color value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


GetRouteUrl Method (StatusBar)

GetRouteUrl Method (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : GetRouteUrl Method
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


GetRouteUrl(Object) Method

GetRouteUrl(Object) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class > GetRouteUrl Method : GetRouteUrl(Object) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
'Usage

Dim instance As StatusBar
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
public System.string GetRouteUrl(
   System.object routeParameters
)
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)

Parameters

routeParameters
Requirements

See Also

Reference

StatusBar Class
StatusBar Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

GetRouteUrl(RouteValueDictionary) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
'Usage

Dim instance As StatusBar
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)

Parameters

routeParameters
Requirements

See Also

Reference

StatusBar Class
StatusBar Members
Overload List


GetRouteUrl(String,Object) Method

GetRouteUrl(String,Object) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
'Usage

Dim instance As StatusBar
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)

Parameters

routeName
routeParameters
Requirements

See Also

Reference

StatusBar Class
StatusBar Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

GetRouteUrl(String,RouteValueDictionary) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
'Usage

Dim instance As StatusBar
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)

Parameters

routeName
routeParameters
Requirements

See Also

Reference

StatusBar Class
StatusBar Members
Overload List


GetUniqueIDRelativeTo Method (StatusBar)

GetUniqueIDRelativeTo Method (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : GetUniqueIDRelativeTo Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
'Usage

Dim instance As StatusBar
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)

Parameters

control
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


HasAttributes Property (StatusBar)

HasAttributes Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : HasAttributes Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property HasAttributes As System.Boolean
'Usage

Dim instance As StatusBar
Dim value As System.Boolean

value = instance.HasAttributes
public System.bool HasAttributes {get;}
public: __property System.bool get_HasAttributes();
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


HasControls Method (StatusBar)

HasControls Method (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : HasControls Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function HasControls() As System.Boolean
'Usage

Dim instance As StatusBar
Dim value As System.Boolean

value = instance.HasControls()
public virtual System.bool HasControls()
public: virtual System.bool HasControls();
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


Height Property (StatusBar)

Height Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : Height Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Height As System.Web.UI.WebControls.Unit
'Usage

Dim instance As StatusBar
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
public virtual System.Web.UI.WebControls.Unit Height {get; set;}
public: __property virtual System.Web.UI.WebControls.Unit get_Height();
public: __property virtual void set_Height(
   System.Web.UI.WebControls.Unit value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


ID Property (StatusBar)

ID Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : ID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ID As System.String
'Usage

Dim instance As StatusBar
Dim value As System.String

instance.ID = value

value = instance.ID
public virtual System.string ID {get; set;}
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


Init Event (StatusBar)

Init Event (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : Init Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Init As System.EventHandler
'Usage

Dim instance As StatusBar
Dim handler As System.EventHandler

AddHandler instance.Init, handler
public event System.EventHandler Init
public: __event System.EventHandler* Init
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


Load Event (StatusBar)

Load Event (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : Load Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Load As System.EventHandler
'Usage

Dim instance As StatusBar
Dim handler As System.EventHandler

AddHandler instance.Load, handler
public event System.EventHandler Load
public: __event System.EventHandler* Load
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


MergeStyle Method (StatusBar)

MergeStyle Method (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : MergeStyle Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
'Usage

Dim instance As StatusBar
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)

Parameters

s
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


NamingContainer Property (StatusBar)

NamingContainer Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : NamingContainer Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property NamingContainer As System.Web.UI.Control
'Usage

Dim instance As StatusBar
Dim value As System.Web.UI.Control

value = instance.NamingContainer
public virtual System.Web.UI.Control NamingContainer {get;}
public: __property virtual System.Web.UI.Control* get_NamingContainer();
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


Page Property (StatusBar)

Page Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : Page Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Page As System.Web.UI.Page
'Usage

Dim instance As StatusBar
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
public virtual System.Web.UI.Page Page {get; set;}
public: __property virtual System.Web.UI.Page* get_Page();
public: __property virtual void set_Page(
   System.Web.UI.Page* value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


Parent Property (StatusBar)

Parent Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : Parent Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property Parent As System.Web.UI.Control
'Usage

Dim instance As StatusBar
Dim value As System.Web.UI.Control

value = instance.Parent
public virtual System.Web.UI.Control Parent {get;}
public: __property virtual System.Web.UI.Control* get_Parent();
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


PreRender Event (StatusBar)

PreRender Event (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : PreRender Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event PreRender As System.EventHandler
'Usage

Dim instance As StatusBar
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
public event System.EventHandler PreRender
public: __event System.EventHandler* PreRender
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


RenderBeginTag Method (StatusBar)

RenderBeginTag Method (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : RenderBeginTag Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
'Usage

Dim instance As StatusBar
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
public: virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
)

Parameters

writer
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


RenderControl Method (StatusBar)

RenderControl Method (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : RenderControl Method
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


RenderControl(HtmlTextWriter) Method

RenderControl(HtmlTextWriter) Method

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : RenderControl(HtmlTextWriter) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
'Usage

Dim instance As StatusBar
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)

Parameters

writer
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


RenderEndTag Method (StatusBar)

RenderEndTag Method (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : RenderEndTag Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
'Usage

Dim instance As StatusBar
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
public virtual void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
public: virtual void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
)

Parameters

writer
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


RenderingCompatibility Property (StatusBar)

RenderingCompatibility Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : RenderingCompatibility Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property RenderingCompatibility As System.Version
'Usage

Dim instance As StatusBar
Dim value As System.Version

instance.RenderingCompatibility = value

value = instance.RenderingCompatibility
public virtual System.Version RenderingCompatibility {get; set;}
public: __property virtual System.Version* get_RenderingCompatibility();
public: __property virtual void set_RenderingCompatibility(
   System.Version* value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


ResolveClientUrl Method (StatusBar)

ResolveClientUrl Method (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : ResolveClientUrl Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
'Usage

Dim instance As StatusBar
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
public System.string ResolveClientUrl(
   System.string relativeUrl
)
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)

Parameters

relativeUrl
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


ResolveUrl Method (StatusBar)

ResolveUrl Method (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : ResolveUrl Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
'Usage

Dim instance As StatusBar
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
public System.string ResolveUrl(
   System.string relativeUrl
)
public: System.string* ResolveUrl(
   System.string* relativeUrl
)

Parameters

relativeUrl
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


SetRenderMethodDelegate Method (StatusBar)

SetRenderMethodDelegate Method (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : SetRenderMethodDelegate Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
'Usage

Dim instance As StatusBar
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)

Parameters

renderMethod
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


Site Property (StatusBar)

Site Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Site As System.ComponentModel.ISite
'Usage

Dim instance As StatusBar
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public System.ComponentModel.ISite Site {get; set;}
public: __property System.ComponentModel.ISite* get_Site();
public: __property void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


SkinID Property (StatusBar)

SkinID Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : SkinID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property SkinID As System.String
'Usage

Dim instance As StatusBar
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
public virtual System.string SkinID {get; set;}
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


Style Property (StatusBar)

Style Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : Style Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Style As System.Web.UI.CssStyleCollection
'Usage

Dim instance As StatusBar
Dim value As System.Web.UI.CssStyleCollection

value = instance.Style
public System.Web.UI.CssStyleCollection Style {get;}
public: __property System.Web.UI.CssStyleCollection* get_Style();
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


SupportsDisabledAttribute Property (StatusBar)

SupportsDisabledAttribute Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : SupportsDisabledAttribute Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property SupportsDisabledAttribute As System.Boolean
'Usage

Dim instance As StatusBar
Dim value As System.Boolean

value = instance.SupportsDisabledAttribute
public virtual System.bool SupportsDisabledAttribute {get;}
public: __property virtual System.bool get_SupportsDisabledAttribute();
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


TabIndex Property (StatusBar)

TabIndex Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : TabIndex Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property TabIndex As System.Short
'Usage

Dim instance As StatusBar
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
public virtual System.short TabIndex {get; set;}
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


TemplateControl Property (StatusBar)

TemplateControl Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : TemplateControl Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property TemplateControl As System.Web.UI.TemplateControl
'Usage

Dim instance As StatusBar
Dim value As System.Web.UI.TemplateControl

instance.TemplateControl = value

value = instance.TemplateControl
public System.Web.UI.TemplateControl TemplateControl {get; set;}
public: __property System.Web.UI.TemplateControl* get_TemplateControl();
public: __property void set_TemplateControl(
   System.Web.UI.TemplateControl* value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


TemplateSourceDirectory Property (StatusBar)

TemplateSourceDirectory Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : TemplateSourceDirectory Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property TemplateSourceDirectory As System.String
'Usage

Dim instance As StatusBar
Dim value As System.String

value = instance.TemplateSourceDirectory
public virtual System.string TemplateSourceDirectory {get;}
public: __property virtual System.string* get_TemplateSourceDirectory();
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


ToolTip Property (StatusBar)

ToolTip Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : ToolTip Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ToolTip As System.String
'Usage

Dim instance As StatusBar
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
public virtual System.string ToolTip {get; set;}
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


UniqueID Property (StatusBar)

UniqueID Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : UniqueID Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable ReadOnly Property UniqueID As System.String
'Usage

Dim instance As StatusBar
Dim value As System.String

value = instance.UniqueID
public virtual System.string UniqueID {get;}
public: __property virtual System.string* get_UniqueID();
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


Unload Event (StatusBar)

Unload Event (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : Unload Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Unload As System.EventHandler
'Usage

Dim instance As StatusBar
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
public event System.EventHandler Unload
public: __event System.EventHandler* Unload
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


ViewStateMode Property (StatusBar)

ViewStateMode Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : ViewStateMode Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
'Usage

Dim instance As StatusBar
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


Visible Property (StatusBar)

Visible Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : Visible Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Visible As System.Boolean
'Usage

Dim instance As StatusBar
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
public virtual System.bool Visible {get; set;}
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


Width Property (StatusBar)

Width Property (StatusBar)

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace > StatusBar Class : Width Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Width As System.Web.UI.WebControls.Unit
'Usage

Dim instance As StatusBar
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
public virtual System.Web.UI.WebControls.Unit Width {get; set;}
public: __property virtual System.Web.UI.WebControls.Unit get_Width();
public: __property virtual void set_Width(
   System.Web.UI.WebControls.Unit value
);
Requirements

See Also

Reference

StatusBar Class
StatusBar Members


ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace Inheritance Hierarchy

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.BaseControl
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.BaseControlWithContent
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.SqlEditor
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.Canvas
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.Grid
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.ObjectTree
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.QueryBuilderControl
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control.StatusBar
See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control Assembly


ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace Inheritance Hierarchy

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models.FieldListBaseColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models.FieldListDescriptionColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models.FieldListNameColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models.FieldListTypeColumnOptions
ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server.Models.FieldListOptions
See Also

Reference

ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server Assembly


AdvantageMetadataProvider Class Events

AdvantageMetadataProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AdvantageMetadataProvider Class

For a list of all members of this type, see AdvantageMetadataProvider members.

See Also

Reference

AdvantageMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AdvantageMetadataProvider Class Methods

AdvantageMetadataProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : AdvantageMetadataProvider Class

For a list of all members of this type, see AdvantageMetadataProvider members.

See Also

Reference

AdvantageMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AfterConnect Event (AdvantageMetadataProvider)

AfterConnect Event (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : AfterConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterConnect As System.EventHandler
'Usage

Dim instance As AdvantageMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterConnect, handler
public event System.EventHandler AfterConnect
public: __event System.EventHandler* AfterConnect
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


AfterDisconnect Event (AdvantageMetadataProvider)

AfterDisconnect Event (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : AfterDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterDisconnect As System.EventHandler
'Usage

Dim instance As AdvantageMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterDisconnect, handler
public event System.EventHandler AfterDisconnect
public: __event System.EventHandler* AfterDisconnect
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


BeforeConnect Event (AdvantageMetadataProvider)

BeforeConnect Event (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : BeforeConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeConnect As System.EventHandler
'Usage

Dim instance As AdvantageMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeConnect, handler
public event System.EventHandler BeforeConnect
public: __event System.EventHandler* BeforeConnect
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


BeforeDisconnect Event (AdvantageMetadataProvider)

BeforeDisconnect Event (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : BeforeDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeDisconnect As System.EventHandler
'Usage

Dim instance As AdvantageMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeDisconnect, handler
public event System.EventHandler BeforeDisconnect
public: __event System.EventHandler* BeforeDisconnect
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


CanExecSQL Property (AdvantageMetadataProvider)

CanExecSQL Property (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : CanExecSQL Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CanExecSQL As System.Boolean
'Usage

Dim instance As AdvantageMetadataProvider
Dim value As System.Boolean

value = instance.CanExecSQL
public System.bool CanExecSQL {get;}
public: __property System.bool get_CanExecSQL();
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


Connect Method (AdvantageMetadataProvider)

Connect Method (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : Connect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Connect()
'Usage

Dim instance As AdvantageMetadataProvider

instance.Connect()
public void Connect()
public: void Connect();
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


Connected Property (AdvantageMetadataProvider)

Connected Property (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : Connected Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Connected As System.Boolean
'Usage

Dim instance As AdvantageMetadataProvider
Dim value As System.Boolean

instance.Connected = value

value = instance.Connected
public System.bool Connected {get; set;}
public: __property System.bool get_Connected();
public: __property void set_Connected(
   System.bool value
);
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


ConnectionObjectsCreated Property (AdvantageMetadataProvider)

ConnectionObjectsCreated Property (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : ConnectionObjectsCreated Property
Gets or sets the reference to the DB Connection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ConnectionObjectsCreated As System.Boolean
'Usage

Dim instance As AdvantageMetadataProvider
Dim value As System.Boolean

value = instance.ConnectionObjectsCreated
public System.bool ConnectionObjectsCreated {get;}
public: __property System.bool get_ConnectionObjectsCreated();
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


Container Property (AdvantageMetadataProvider)

Container Property (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As AdvantageMetadataProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


CreateObjRef Method (AdvantageMetadataProvider)

CreateObjRef Method (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As AdvantageMetadataProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


Description Property (AdvantageMetadataProvider)

Description Property (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : Description Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Description As System.String
'Usage

Dim instance As AdvantageMetadataProvider
Dim value As System.String

value = instance.Description
public System.string Description {get;}
public: __property System.string* get_Description();
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


Disconnect Method (AdvantageMetadataProvider)

Disconnect Method (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : Disconnect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Disconnect()
'Usage

Dim instance As AdvantageMetadataProvider

instance.Disconnect()
public void Disconnect()
public: void Disconnect();
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


Dispose Method (AdvantageMetadataProvider)

Dispose Method (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : Dispose Method
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As AdvantageMetadataProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


Disposed Event (AdvantageMetadataProvider)

Disposed Event (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As AdvantageMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


ExecSQL Method (AdvantageMetadataProvider)

ExecSQL Method (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : ExecSQL Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ExecSQL( _
   ByVal sql As System.String, _
   ByVal schemaOnly As System.Boolean _
) As System.Data.IDataReader
'Usage

Dim instance As AdvantageMetadataProvider
Dim sql As System.String
Dim schemaOnly As System.Boolean
Dim value As System.Data.IDataReader

value = instance.ExecSQL(sql, schemaOnly)
public System.Data.IDataReader ExecSQL(
   System.string sql,
   System.bool schemaOnly
)
public: System.Data.IDataReader* ExecSQL(
   System.string* sql,
   System.bool schemaOnly
)

Parameters

sql
schemaOnly
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


ExecSQLNoResult Method (AdvantageMetadataProvider)

ExecSQLNoResult Method (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : ExecSQLNoResult Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ExecSQLNoResult( _
   ByVal sql As System.String _
)
'Usage

Dim instance As AdvantageMetadataProvider
Dim sql As System.String

instance.ExecSQLNoResult(sql)
public void ExecSQLNoResult(
   System.string sql
)
public: void ExecSQLNoResult(
   System.string* sql
)

Parameters

sql
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


GetLifetimeService Method (AdvantageMetadataProvider)

GetLifetimeService Method (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As AdvantageMetadataProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


InitializeLifetimeService Method (AdvantageMetadataProvider)

InitializeLifetimeService Method (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As AdvantageMetadataProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


LoadDatabases Method (AdvantageMetadataProvider)

LoadDatabases Method (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : LoadDatabases Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadDatabases( _
   ByVal databases As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As AdvantageMetadataProvider
Dim databases As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadDatabases(databases, loadingOptions)
public virtual void LoadDatabases(
   MetadataList databases,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadDatabases(
   MetadataList* databases,
   MetadataLoadingOptions* loadingOptions
)

Parameters

databases
loadingOptions
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


LoadFields Method (AdvantageMetadataProvider)

LoadFields Method (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : LoadFields Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadFields( _
   ByVal fields As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As AdvantageMetadataProvider
Dim fields As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadFields(fields, loadingOptions)
public virtual void LoadFields(
   MetadataList fields,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadFields(
   MetadataList* fields,
   MetadataLoadingOptions* loadingOptions
)

Parameters

fields
loadingOptions
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


LoadForeignKeys Method (AdvantageMetadataProvider)

LoadForeignKeys Method (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : LoadForeignKeys Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadForeignKeys( _
   ByVal foreignKeys As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As AdvantageMetadataProvider
Dim foreignKeys As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadForeignKeys(foreignKeys, loadingOptions)
public virtual void LoadForeignKeys(
   MetadataList foreignKeys,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadForeignKeys(
   MetadataList* foreignKeys,
   MetadataLoadingOptions* loadingOptions
)

Parameters

foreignKeys
loadingOptions
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


LoadPackages Method (AdvantageMetadataProvider)

LoadPackages Method (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : LoadPackages Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadPackages( _
   ByVal packages As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As AdvantageMetadataProvider
Dim packages As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadPackages(packages, loadingOptions)
public virtual void LoadPackages(
   MetadataList packages,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadPackages(
   MetadataList* packages,
   MetadataLoadingOptions* loadingOptions
)

Parameters

packages
loadingOptions
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


LoadParams Method (AdvantageMetadataProvider)

LoadParams Method (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : LoadParams Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadParams( _
   ByVal params As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As AdvantageMetadataProvider
Dim params As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadParams(params, loadingOptions)
public virtual void LoadParams(
   MetadataList params,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadParams(
   MetadataList* params,
   MetadataLoadingOptions* loadingOptions
)

Parameters

params
loadingOptions
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


LoadSchemas Method (AdvantageMetadataProvider)

LoadSchemas Method (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : LoadSchemas Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadSchemas( _
   ByVal schemas As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As AdvantageMetadataProvider
Dim schemas As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadSchemas(schemas, loadingOptions)
public virtual void LoadSchemas(
   MetadataList schemas,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadSchemas(
   MetadataList* schemas,
   MetadataLoadingOptions* loadingOptions
)

Parameters

schemas
loadingOptions
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


LoadServers Method (AdvantageMetadataProvider)

LoadServers Method (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : LoadServers Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadServers( _
   ByVal servers As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As AdvantageMetadataProvider
Dim servers As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadServers(servers, loadingOptions)
public virtual void LoadServers(
   MetadataList servers,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadServers(
   MetadataList* servers,
   MetadataLoadingOptions* loadingOptions
)

Parameters

servers
loadingOptions
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


Site Property (AdvantageMetadataProvider)

Site Property (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As AdvantageMetadataProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


ToString Method (AdvantageMetadataProvider)

ToString Method (AdvantageMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > AdvantageMetadataProvider Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function ToString() As System.String
'Usage

Dim instance As AdvantageMetadataProvider
Dim value As System.String

value = instance.ToString()
public virtual System.string ToString()
public: virtual System.string* ToString();
Requirements

See Also

Reference

AdvantageMetadataProvider Class
AdvantageMetadataProvider Members


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.AdvantageMetadataProvider2) Inheritance Hierarchy

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.AdvantageMetadataProvider2) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.AdvantageMetadataProvider
See Also

Reference

ActiveDatabaseSoftware.AdvantageMetadataProvider2 Assembly


DB2MetadataProvider Class Events

DB2MetadataProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DB2MetadataProvider Class

For a list of all members of this type, see DB2MetadataProvider members.

See Also

Reference

DB2MetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


DB2MetadataProvider Class Methods

DB2MetadataProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : DB2MetadataProvider Class

For a list of all members of this type, see DB2MetadataProvider members.

See Also

Reference

DB2MetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AfterConnect Event (DB2MetadataProvider)

AfterConnect Event (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : AfterConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterConnect As System.EventHandler
'Usage

Dim instance As DB2MetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterConnect, handler
public event System.EventHandler AfterConnect
public: __event System.EventHandler* AfterConnect
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


AfterDisconnect Event (DB2MetadataProvider)

AfterDisconnect Event (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : AfterDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterDisconnect As System.EventHandler
'Usage

Dim instance As DB2MetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterDisconnect, handler
public event System.EventHandler AfterDisconnect
public: __event System.EventHandler* AfterDisconnect
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


BeforeConnect Event (DB2MetadataProvider)

BeforeConnect Event (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : BeforeConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeConnect As System.EventHandler
'Usage

Dim instance As DB2MetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeConnect, handler
public event System.EventHandler BeforeConnect
public: __event System.EventHandler* BeforeConnect
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


BeforeDisconnect Event (DB2MetadataProvider)

BeforeDisconnect Event (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : BeforeDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeDisconnect As System.EventHandler
'Usage

Dim instance As DB2MetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeDisconnect, handler
public event System.EventHandler BeforeDisconnect
public: __event System.EventHandler* BeforeDisconnect
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


CanExecSQL Property (DB2MetadataProvider)

CanExecSQL Property (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : CanExecSQL Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CanExecSQL As System.Boolean
'Usage

Dim instance As DB2MetadataProvider
Dim value As System.Boolean

value = instance.CanExecSQL
public System.bool CanExecSQL {get;}
public: __property System.bool get_CanExecSQL();
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


Connect Method (DB2MetadataProvider)

Connect Method (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : Connect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Connect()
'Usage

Dim instance As DB2MetadataProvider

instance.Connect()
public void Connect()
public: void Connect();
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


Connected Property (DB2MetadataProvider)

Connected Property (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : Connected Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Connected As System.Boolean
'Usage

Dim instance As DB2MetadataProvider
Dim value As System.Boolean

instance.Connected = value

value = instance.Connected
public System.bool Connected {get; set;}
public: __property System.bool get_Connected();
public: __property void set_Connected(
   System.bool value
);
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


ConnectionObjectsCreated Property (DB2MetadataProvider)

ConnectionObjectsCreated Property (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : ConnectionObjectsCreated Property
Gets or sets the reference to the DB Connection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ConnectionObjectsCreated As System.Boolean
'Usage

Dim instance As DB2MetadataProvider
Dim value As System.Boolean

value = instance.ConnectionObjectsCreated
public System.bool ConnectionObjectsCreated {get;}
public: __property System.bool get_ConnectionObjectsCreated();
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


Container Property (DB2MetadataProvider)

Container Property (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As DB2MetadataProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


CreateObjRef Method (DB2MetadataProvider)

CreateObjRef Method (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As DB2MetadataProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


Description Property (DB2MetadataProvider)

Description Property (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : Description Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Description As System.String
'Usage

Dim instance As DB2MetadataProvider
Dim value As System.String

value = instance.Description
public System.string Description {get;}
public: __property System.string* get_Description();
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


Disconnect Method (DB2MetadataProvider)

Disconnect Method (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : Disconnect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Disconnect()
'Usage

Dim instance As DB2MetadataProvider

instance.Disconnect()
public void Disconnect()
public: void Disconnect();
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


Dispose Method (DB2MetadataProvider)

Dispose Method (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : Dispose Method
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members
Base Implementation in Dispose


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As DB2MetadataProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


Disposed Event (DB2MetadataProvider)

Disposed Event (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As DB2MetadataProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


ExecSQL Method (DB2MetadataProvider)

ExecSQL Method (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : ExecSQL Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ExecSQL( _
   ByVal sql As System.String, _
   ByVal schemaOnly As System.Boolean _
) As System.Data.IDataReader
'Usage

Dim instance As DB2MetadataProvider
Dim sql As System.String
Dim schemaOnly As System.Boolean
Dim value As System.Data.IDataReader

value = instance.ExecSQL(sql, schemaOnly)
public System.Data.IDataReader ExecSQL(
   System.string sql,
   System.bool schemaOnly
)
public: System.Data.IDataReader* ExecSQL(
   System.string* sql,
   System.bool schemaOnly
)

Parameters

sql
schemaOnly
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


ExecSQLNoResult Method (DB2MetadataProvider)

ExecSQLNoResult Method (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : ExecSQLNoResult Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ExecSQLNoResult( _
   ByVal sql As System.String _
)
'Usage

Dim instance As DB2MetadataProvider
Dim sql As System.String

instance.ExecSQLNoResult(sql)
public void ExecSQLNoResult(
   System.string sql
)
public: void ExecSQLNoResult(
   System.string* sql
)

Parameters

sql
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


GetLifetimeService Method (DB2MetadataProvider)

GetLifetimeService Method (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As DB2MetadataProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


InitializeLifetimeService Method (DB2MetadataProvider)

InitializeLifetimeService Method (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As DB2MetadataProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


LoadDatabases Method (DB2MetadataProvider)

LoadDatabases Method (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : LoadDatabases Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadDatabases( _
   ByVal databases As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As DB2MetadataProvider
Dim databases As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadDatabases(databases, loadingOptions)
public virtual void LoadDatabases(
   MetadataList databases,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadDatabases(
   MetadataList* databases,
   MetadataLoadingOptions* loadingOptions
)

Parameters

databases
loadingOptions
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


LoadFields Method (DB2MetadataProvider)

LoadFields Method (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : LoadFields Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadFields( _
   ByVal fields As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As DB2MetadataProvider
Dim fields As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadFields(fields, loadingOptions)
public virtual void LoadFields(
   MetadataList fields,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadFields(
   MetadataList* fields,
   MetadataLoadingOptions* loadingOptions
)

Parameters

fields
loadingOptions
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


LoadPackages Method (DB2MetadataProvider)

LoadPackages Method (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : LoadPackages Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadPackages( _
   ByVal packages As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As DB2MetadataProvider
Dim packages As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadPackages(packages, loadingOptions)
public virtual void LoadPackages(
   MetadataList packages,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadPackages(
   MetadataList* packages,
   MetadataLoadingOptions* loadingOptions
)

Parameters

packages
loadingOptions
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


LoadParams Method (DB2MetadataProvider)

LoadParams Method (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : LoadParams Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadParams( _
   ByVal params As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As DB2MetadataProvider
Dim params As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadParams(params, loadingOptions)
public virtual void LoadParams(
   MetadataList params,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadParams(
   MetadataList* params,
   MetadataLoadingOptions* loadingOptions
)

Parameters

params
loadingOptions
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


LoadSchemas Method (DB2MetadataProvider)

LoadSchemas Method (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : LoadSchemas Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadSchemas( _
   ByVal schemas As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As DB2MetadataProvider
Dim schemas As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadSchemas(schemas, loadingOptions)
public virtual void LoadSchemas(
   MetadataList schemas,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadSchemas(
   MetadataList* schemas,
   MetadataLoadingOptions* loadingOptions
)

Parameters

schemas
loadingOptions
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


LoadServers Method (DB2MetadataProvider)

LoadServers Method (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : LoadServers Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadServers( _
   ByVal servers As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As DB2MetadataProvider
Dim servers As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadServers(servers, loadingOptions)
public virtual void LoadServers(
   MetadataList servers,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadServers(
   MetadataList* servers,
   MetadataLoadingOptions* loadingOptions
)

Parameters

servers
loadingOptions
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


Site Property (DB2MetadataProvider)

Site Property (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As DB2MetadataProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


ToString Method (DB2MetadataProvider)

ToString Method (DB2MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > DB2MetadataProvider Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function ToString() As System.String
'Usage

Dim instance As DB2MetadataProvider
Dim value As System.String

value = instance.ToString()
public virtual System.string ToString()
public: virtual System.string* ToString();
Requirements

See Also

Reference

DB2MetadataProvider Class
DB2MetadataProvider Members


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.DB2MetadataProvider2) Inheritance Hierarchy

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.DB2MetadataProvider2) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.DB2MetadataProvider
See Also

Reference

ActiveDatabaseSoftware.DB2MetadataProvider2 Assembly


EventMetadataProvider Class Methods

EventMetadataProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : EventMetadataProvider Class

For a list of all members of this type, see EventMetadataProvider members.

See Also

Reference

EventMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


EventMetadataProvider Class Properties

EventMetadataProvider Class Properties

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : EventMetadataProvider Class

For a list of all members of this type, see EventMetadataProvider members.

See Also

Reference

EventMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AfterConnect Event (EventMetadataProvider)

AfterConnect Event (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : AfterConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterConnect As System.EventHandler
'Usage

Dim instance As EventMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterConnect, handler
public event System.EventHandler AfterConnect
public: __event System.EventHandler* AfterConnect
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


AfterDisconnect Event (EventMetadataProvider)

AfterDisconnect Event (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : AfterDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterDisconnect As System.EventHandler
'Usage

Dim instance As EventMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterDisconnect, handler
public event System.EventHandler AfterDisconnect
public: __event System.EventHandler* AfterDisconnect
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


BeforeConnect Event (EventMetadataProvider)

BeforeConnect Event (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : BeforeConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeConnect As System.EventHandler
'Usage

Dim instance As EventMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeConnect, handler
public event System.EventHandler BeforeConnect
public: __event System.EventHandler* BeforeConnect
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


BeforeDisconnect Event (EventMetadataProvider)

BeforeDisconnect Event (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : BeforeDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeDisconnect As System.EventHandler
'Usage

Dim instance As EventMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeDisconnect, handler
public event System.EventHandler BeforeDisconnect
public: __event System.EventHandler* BeforeDisconnect
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


CanCreateInternalConnection Method

CanCreateInternalConnection Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : CanCreateInternalConnection Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CanCreateInternalConnection() As System.Boolean
'Usage

Dim instance As EventMetadataProvider
Dim value As System.Boolean

value = instance.CanCreateInternalConnection()
public virtual System.bool CanCreateInternalConnection()
public: virtual System.bool CanCreateInternalConnection();
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


CanExecSQL Property (EventMetadataProvider)

CanExecSQL Property (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : CanExecSQL Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CanExecSQL As System.Boolean
'Usage

Dim instance As EventMetadataProvider
Dim value As System.Boolean

value = instance.CanExecSQL
public System.bool CanExecSQL {get;}
public: __property System.bool get_CanExecSQL();
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


Connect Method (EventMetadataProvider)

Connect Method (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : Connect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Connect()
'Usage

Dim instance As EventMetadataProvider

instance.Connect()
public void Connect()
public: void Connect();
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


Connected Property (EventMetadataProvider)

Connected Property (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : Connected Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Connected As System.Boolean
'Usage

Dim instance As EventMetadataProvider
Dim value As System.Boolean

instance.Connected = value

value = instance.Connected
public System.bool Connected {get; set;}
public: __property System.bool get_Connected();
public: __property void set_Connected(
   System.bool value
);
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


ConnectionObjectsCreated Property (EventMetadataProvider)

ConnectionObjectsCreated Property (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : ConnectionObjectsCreated Property
Gets or sets the reference to the DB Connection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ConnectionObjectsCreated As System.Boolean
'Usage

Dim instance As EventMetadataProvider
Dim value As System.Boolean

value = instance.ConnectionObjectsCreated
public System.bool ConnectionObjectsCreated {get;}
public: __property System.bool get_ConnectionObjectsCreated();
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


Container Property (EventMetadataProvider)

Container Property (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As EventMetadataProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


CreateObjRef Method (EventMetadataProvider)

CreateObjRef Method (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As EventMetadataProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


Description Property (EventMetadataProvider)

Description Property (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : Description Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Description As System.String
'Usage

Dim instance As EventMetadataProvider
Dim value As System.String

value = instance.Description
public System.string Description {get;}
public: __property System.string* get_Description();
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


Disconnect Method (EventMetadataProvider)

Disconnect Method (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : Disconnect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Disconnect()
'Usage

Dim instance As EventMetadataProvider

instance.Disconnect()
public void Disconnect()
public: void Disconnect();
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


Dispose Method (EventMetadataProvider)

Dispose Method (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : Dispose Method
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As EventMetadataProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


Disposed Event (EventMetadataProvider)

Disposed Event (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As EventMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


ExecSQL Method (EventMetadataProvider)

ExecSQL Method (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : ExecSQL Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ExecSQL( _
   ByVal sql As System.String, _
   ByVal schemaOnly As System.Boolean _
) As System.Data.IDataReader
'Usage

Dim instance As EventMetadataProvider
Dim sql As System.String
Dim schemaOnly As System.Boolean
Dim value As System.Data.IDataReader

value = instance.ExecSQL(sql, schemaOnly)
public System.Data.IDataReader ExecSQL(
   System.string sql,
   System.bool schemaOnly
)
public: System.Data.IDataReader* ExecSQL(
   System.string* sql,
   System.bool schemaOnly
)

Parameters

sql
schemaOnly
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


ExecSQLNoResult Method (EventMetadataProvider)

ExecSQLNoResult Method (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : ExecSQLNoResult Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ExecSQLNoResult( _
   ByVal sql As System.String _
)
'Usage

Dim instance As EventMetadataProvider
Dim sql As System.String

instance.ExecSQLNoResult(sql)
public void ExecSQLNoResult(
   System.string sql
)
public: void ExecSQLNoResult(
   System.string* sql
)

Parameters

sql
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


GetLifetimeService Method (EventMetadataProvider)

GetLifetimeService Method (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As EventMetadataProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


InitializeLifetimeService Method (EventMetadataProvider)

InitializeLifetimeService Method (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As EventMetadataProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


LoadDatabases Method (EventMetadataProvider)

LoadDatabases Method (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : LoadDatabases Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadDatabases( _
   ByVal databases As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As EventMetadataProvider
Dim databases As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadDatabases(databases, loadingOptions)
public virtual void LoadDatabases(
   MetadataList databases,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadDatabases(
   MetadataList* databases,
   MetadataLoadingOptions* loadingOptions
)

Parameters

databases
loadingOptions
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


LoadFields Method (EventMetadataProvider)

LoadFields Method (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : LoadFields Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadFields( _
   ByVal fields As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As EventMetadataProvider
Dim fields As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadFields(fields, loadingOptions)
public virtual void LoadFields(
   MetadataList fields,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadFields(
   MetadataList* fields,
   MetadataLoadingOptions* loadingOptions
)

Parameters

fields
loadingOptions
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


LoadForeignKeys Method (EventMetadataProvider)

LoadForeignKeys Method (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : LoadForeignKeys Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadForeignKeys( _
   ByVal foreignKeys As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As EventMetadataProvider
Dim foreignKeys As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadForeignKeys(foreignKeys, loadingOptions)
public virtual void LoadForeignKeys(
   MetadataList foreignKeys,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadForeignKeys(
   MetadataList* foreignKeys,
   MetadataLoadingOptions* loadingOptions
)

Parameters

foreignKeys
loadingOptions
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


LoadObjects Method (EventMetadataProvider)

LoadObjects Method (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : LoadObjects Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadObjects( _
   ByVal objects As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As EventMetadataProvider
Dim objects As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadObjects(objects, loadingOptions)
public virtual void LoadObjects(
   MetadataList objects,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadObjects(
   MetadataList* objects,
   MetadataLoadingOptions* loadingOptions
)

Parameters

objects
loadingOptions
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


LoadPackages Method (EventMetadataProvider)

LoadPackages Method (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : LoadPackages Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadPackages( _
   ByVal packages As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As EventMetadataProvider
Dim packages As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadPackages(packages, loadingOptions)
public virtual void LoadPackages(
   MetadataList packages,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadPackages(
   MetadataList* packages,
   MetadataLoadingOptions* loadingOptions
)

Parameters

packages
loadingOptions
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


LoadParams Method (EventMetadataProvider)

LoadParams Method (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : LoadParams Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadParams( _
   ByVal params As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As EventMetadataProvider
Dim params As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadParams(params, loadingOptions)
public virtual void LoadParams(
   MetadataList params,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadParams(
   MetadataList* params,
   MetadataLoadingOptions* loadingOptions
)

Parameters

params
loadingOptions
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


LoadSchemas Method (EventMetadataProvider)

LoadSchemas Method (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : LoadSchemas Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadSchemas( _
   ByVal schemas As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As EventMetadataProvider
Dim schemas As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadSchemas(schemas, loadingOptions)
public virtual void LoadSchemas(
   MetadataList schemas,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadSchemas(
   MetadataList* schemas,
   MetadataLoadingOptions* loadingOptions
)

Parameters

schemas
loadingOptions
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


LoadServers Method (EventMetadataProvider)

LoadServers Method (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : LoadServers Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadServers( _
   ByVal servers As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As EventMetadataProvider
Dim servers As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadServers(servers, loadingOptions)
public virtual void LoadServers(
   MetadataList servers,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadServers(
   MetadataList* servers,
   MetadataLoadingOptions* loadingOptions
)

Parameters

servers
loadingOptions
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


Site Property (EventMetadataProvider)

Site Property (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As EventMetadataProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


ToString Method (EventMetadataProvider)

ToString Method (EventMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > EventMetadataProvider Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function ToString() As System.String
'Usage

Dim instance As EventMetadataProvider
Dim value As System.String

value = instance.ToString()
public virtual System.string ToString()
public: virtual System.string* ToString();
Requirements

See Also

Reference

EventMetadataProvider Class
EventMetadataProvider Members


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.EventMetadataProvider2) Inheritance Hierarchy

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.EventMetadataProvider2) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.EventMetadataProvider
See Also

Reference

ActiveDatabaseSoftware.EventMetadataProvider2 Assembly


FirebirdMetadataProvider Class Events

FirebirdMetadataProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : FirebirdMetadataProvider Class

For a list of all members of this type, see FirebirdMetadataProvider members.

See Also

Reference

FirebirdMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AfterConnect Event (FirebirdMetadataProvider)

AfterConnect Event (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : AfterConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterConnect As System.EventHandler
'Usage

Dim instance As FirebirdMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterConnect, handler
public event System.EventHandler AfterConnect
public: __event System.EventHandler* AfterConnect
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


AfterDisconnect Event (FirebirdMetadataProvider)

AfterDisconnect Event (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : AfterDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterDisconnect As System.EventHandler
'Usage

Dim instance As FirebirdMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterDisconnect, handler
public event System.EventHandler AfterDisconnect
public: __event System.EventHandler* AfterDisconnect
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


BeforeConnect Event (FirebirdMetadataProvider)

BeforeConnect Event (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : BeforeConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeConnect As System.EventHandler
'Usage

Dim instance As FirebirdMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeConnect, handler
public event System.EventHandler BeforeConnect
public: __event System.EventHandler* BeforeConnect
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


BeforeDisconnect Event (FirebirdMetadataProvider)

BeforeDisconnect Event (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : BeforeDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeDisconnect As System.EventHandler
'Usage

Dim instance As FirebirdMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeDisconnect, handler
public event System.EventHandler BeforeDisconnect
public: __event System.EventHandler* BeforeDisconnect
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


CanExecSQL Property (FirebirdMetadataProvider)

CanExecSQL Property (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : CanExecSQL Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CanExecSQL As System.Boolean
'Usage

Dim instance As FirebirdMetadataProvider
Dim value As System.Boolean

value = instance.CanExecSQL
public System.bool CanExecSQL {get;}
public: __property System.bool get_CanExecSQL();
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


Connect Method (FirebirdMetadataProvider)

Connect Method (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : Connect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Connect()
'Usage

Dim instance As FirebirdMetadataProvider

instance.Connect()
public void Connect()
public: void Connect();
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


Connected Property (FirebirdMetadataProvider)

Connected Property (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : Connected Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Connected As System.Boolean
'Usage

Dim instance As FirebirdMetadataProvider
Dim value As System.Boolean

instance.Connected = value

value = instance.Connected
public System.bool Connected {get; set;}
public: __property System.bool get_Connected();
public: __property void set_Connected(
   System.bool value
);
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


ConnectionObjectsCreated Property (FirebirdMetadataProvider)

ConnectionObjectsCreated Property (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : ConnectionObjectsCreated Property
Gets or sets the reference to the DB Connection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ConnectionObjectsCreated As System.Boolean
'Usage

Dim instance As FirebirdMetadataProvider
Dim value As System.Boolean

value = instance.ConnectionObjectsCreated
public System.bool ConnectionObjectsCreated {get;}
public: __property System.bool get_ConnectionObjectsCreated();
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


Container Property (FirebirdMetadataProvider)

Container Property (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As FirebirdMetadataProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


CreateObjRef Method (FirebirdMetadataProvider)

CreateObjRef Method (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As FirebirdMetadataProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


Description Property (FirebirdMetadataProvider)

Description Property (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : Description Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Description As System.String
'Usage

Dim instance As FirebirdMetadataProvider
Dim value As System.String

value = instance.Description
public System.string Description {get;}
public: __property System.string* get_Description();
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


Disconnect Method (FirebirdMetadataProvider)

Disconnect Method (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : Disconnect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Disconnect()
'Usage

Dim instance As FirebirdMetadataProvider

instance.Disconnect()
public void Disconnect()
public: void Disconnect();
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


Dispose Method (FirebirdMetadataProvider)

Dispose Method (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : Dispose Method
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As FirebirdMetadataProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


Disposed Event (FirebirdMetadataProvider)

Disposed Event (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As FirebirdMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


ExecSQL Method (FirebirdMetadataProvider)

ExecSQL Method (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : ExecSQL Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ExecSQL( _
   ByVal sql As System.String, _
   ByVal schemaOnly As System.Boolean _
) As System.Data.IDataReader
'Usage

Dim instance As FirebirdMetadataProvider
Dim sql As System.String
Dim schemaOnly As System.Boolean
Dim value As System.Data.IDataReader

value = instance.ExecSQL(sql, schemaOnly)
public System.Data.IDataReader ExecSQL(
   System.string sql,
   System.bool schemaOnly
)
public: System.Data.IDataReader* ExecSQL(
   System.string* sql,
   System.bool schemaOnly
)

Parameters

sql
schemaOnly
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


ExecSQLNoResult Method (FirebirdMetadataProvider)

ExecSQLNoResult Method (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : ExecSQLNoResult Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ExecSQLNoResult( _
   ByVal sql As System.String _
)
'Usage

Dim instance As FirebirdMetadataProvider
Dim sql As System.String

instance.ExecSQLNoResult(sql)
public void ExecSQLNoResult(
   System.string sql
)
public: void ExecSQLNoResult(
   System.string* sql
)

Parameters

sql
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


GetLifetimeService Method (FirebirdMetadataProvider)

GetLifetimeService Method (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As FirebirdMetadataProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


InitializeLifetimeService Method (FirebirdMetadataProvider)

InitializeLifetimeService Method (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As FirebirdMetadataProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


LoadDatabases Method (FirebirdMetadataProvider)

LoadDatabases Method (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : LoadDatabases Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadDatabases( _
   ByVal databases As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As FirebirdMetadataProvider
Dim databases As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadDatabases(databases, loadingOptions)
public virtual void LoadDatabases(
   MetadataList databases,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadDatabases(
   MetadataList* databases,
   MetadataLoadingOptions* loadingOptions
)

Parameters

databases
loadingOptions
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


LoadFields Method (FirebirdMetadataProvider)

LoadFields Method (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : LoadFields Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadFields( _
   ByVal fields As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As FirebirdMetadataProvider
Dim fields As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadFields(fields, loadingOptions)
public virtual void LoadFields(
   MetadataList fields,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadFields(
   MetadataList* fields,
   MetadataLoadingOptions* loadingOptions
)

Parameters

fields
loadingOptions
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


LoadPackages Method (FirebirdMetadataProvider)

LoadPackages Method (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : LoadPackages Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadPackages( _
   ByVal packages As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As FirebirdMetadataProvider
Dim packages As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadPackages(packages, loadingOptions)
public virtual void LoadPackages(
   MetadataList packages,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadPackages(
   MetadataList* packages,
   MetadataLoadingOptions* loadingOptions
)

Parameters

packages
loadingOptions
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


LoadParams Method (FirebirdMetadataProvider)

LoadParams Method (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : LoadParams Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadParams( _
   ByVal params As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As FirebirdMetadataProvider
Dim params As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadParams(params, loadingOptions)
public virtual void LoadParams(
   MetadataList params,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadParams(
   MetadataList* params,
   MetadataLoadingOptions* loadingOptions
)

Parameters

params
loadingOptions
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


LoadSchemas Method (FirebirdMetadataProvider)

LoadSchemas Method (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : LoadSchemas Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadSchemas( _
   ByVal schemas As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As FirebirdMetadataProvider
Dim schemas As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadSchemas(schemas, loadingOptions)
public virtual void LoadSchemas(
   MetadataList schemas,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadSchemas(
   MetadataList* schemas,
   MetadataLoadingOptions* loadingOptions
)

Parameters

schemas
loadingOptions
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


LoadServers Method (FirebirdMetadataProvider)

LoadServers Method (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : LoadServers Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadServers( _
   ByVal servers As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As FirebirdMetadataProvider
Dim servers As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadServers(servers, loadingOptions)
public virtual void LoadServers(
   MetadataList servers,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadServers(
   MetadataList* servers,
   MetadataLoadingOptions* loadingOptions
)

Parameters

servers
loadingOptions
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


Site Property (FirebirdMetadataProvider)

Site Property (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As FirebirdMetadataProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


ToString Method (FirebirdMetadataProvider)

ToString Method (FirebirdMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > FirebirdMetadataProvider Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function ToString() As System.String
'Usage

Dim instance As FirebirdMetadataProvider
Dim value As System.String

value = instance.ToString()
public virtual System.string ToString()
public: virtual System.string* ToString();
Requirements

See Also

Reference

FirebirdMetadataProvider Class
FirebirdMetadataProvider Members


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.FirebirdMetadataProvider2) Inheritance Hierarchy

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.FirebirdMetadataProvider2) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.FirebirdMetadataProvider
See Also

Reference

ActiveDatabaseSoftware.FirebirdMetadataProvider2 Assembly


InformixMetadataProvider Class Events

InformixMetadataProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : InformixMetadataProvider Class

For a list of all members of this type, see InformixMetadataProvider members.

See Also

Reference

InformixMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


InformixMetadataProvider Class Methods

InformixMetadataProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : InformixMetadataProvider Class

For a list of all members of this type, see InformixMetadataProvider members.

See Also

Reference

InformixMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AfterConnect Event (InformixMetadataProvider)

AfterConnect Event (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : AfterConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterConnect As System.EventHandler
'Usage

Dim instance As InformixMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterConnect, handler
public event System.EventHandler AfterConnect
public: __event System.EventHandler* AfterConnect
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


AfterDisconnect Event (InformixMetadataProvider)

AfterDisconnect Event (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : AfterDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterDisconnect As System.EventHandler
'Usage

Dim instance As InformixMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterDisconnect, handler
public event System.EventHandler AfterDisconnect
public: __event System.EventHandler* AfterDisconnect
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


BeforeConnect Event (InformixMetadataProvider)

BeforeConnect Event (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : BeforeConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeConnect As System.EventHandler
'Usage

Dim instance As InformixMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeConnect, handler
public event System.EventHandler BeforeConnect
public: __event System.EventHandler* BeforeConnect
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


BeforeDisconnect Event (InformixMetadataProvider)

BeforeDisconnect Event (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : BeforeDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeDisconnect As System.EventHandler
'Usage

Dim instance As InformixMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeDisconnect, handler
public event System.EventHandler BeforeDisconnect
public: __event System.EventHandler* BeforeDisconnect
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


CanExecSQL Property (InformixMetadataProvider)

CanExecSQL Property (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : CanExecSQL Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CanExecSQL As System.Boolean
'Usage

Dim instance As InformixMetadataProvider
Dim value As System.Boolean

value = instance.CanExecSQL
public System.bool CanExecSQL {get;}
public: __property System.bool get_CanExecSQL();
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


Connect Method (InformixMetadataProvider)

Connect Method (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : Connect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Connect()
'Usage

Dim instance As InformixMetadataProvider

instance.Connect()
public void Connect()
public: void Connect();
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


Connected Property (InformixMetadataProvider)

Connected Property (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : Connected Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Connected As System.Boolean
'Usage

Dim instance As InformixMetadataProvider
Dim value As System.Boolean

instance.Connected = value

value = instance.Connected
public System.bool Connected {get; set;}
public: __property System.bool get_Connected();
public: __property void set_Connected(
   System.bool value
);
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


ConnectionObjectsCreated Property (InformixMetadataProvider)

ConnectionObjectsCreated Property (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : ConnectionObjectsCreated Property
Gets or sets the reference to the DB Connection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ConnectionObjectsCreated As System.Boolean
'Usage

Dim instance As InformixMetadataProvider
Dim value As System.Boolean

value = instance.ConnectionObjectsCreated
public System.bool ConnectionObjectsCreated {get;}
public: __property System.bool get_ConnectionObjectsCreated();
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


Container Property (InformixMetadataProvider)

Container Property (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As InformixMetadataProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


CreateObjRef Method (InformixMetadataProvider)

CreateObjRef Method (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As InformixMetadataProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


Description Property (InformixMetadataProvider)

Description Property (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : Description Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Description As System.String
'Usage

Dim instance As InformixMetadataProvider
Dim value As System.String

value = instance.Description
public System.string Description {get;}
public: __property System.string* get_Description();
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


Disconnect Method (InformixMetadataProvider)

Disconnect Method (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : Disconnect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Disconnect()
'Usage

Dim instance As InformixMetadataProvider

instance.Disconnect()
public void Disconnect()
public: void Disconnect();
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


Dispose Method (InformixMetadataProvider)

Dispose Method (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : Dispose Method
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As InformixMetadataProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


Disposed Event (InformixMetadataProvider)

Disposed Event (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As InformixMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


ExecSQL Method (InformixMetadataProvider)

ExecSQL Method (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : ExecSQL Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ExecSQL( _
   ByVal sql As System.String, _
   ByVal schemaOnly As System.Boolean _
) As System.Data.IDataReader
'Usage

Dim instance As InformixMetadataProvider
Dim sql As System.String
Dim schemaOnly As System.Boolean
Dim value As System.Data.IDataReader

value = instance.ExecSQL(sql, schemaOnly)
public System.Data.IDataReader ExecSQL(
   System.string sql,
   System.bool schemaOnly
)
public: System.Data.IDataReader* ExecSQL(
   System.string* sql,
   System.bool schemaOnly
)

Parameters

sql
schemaOnly
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


ExecSQLNoResult Method (InformixMetadataProvider)

ExecSQLNoResult Method (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : ExecSQLNoResult Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ExecSQLNoResult( _
   ByVal sql As System.String _
)
'Usage

Dim instance As InformixMetadataProvider
Dim sql As System.String

instance.ExecSQLNoResult(sql)
public void ExecSQLNoResult(
   System.string sql
)
public: void ExecSQLNoResult(
   System.string* sql
)

Parameters

sql
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


GetLifetimeService Method (InformixMetadataProvider)

GetLifetimeService Method (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As InformixMetadataProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


InitializeLifetimeService Method (InformixMetadataProvider)

InitializeLifetimeService Method (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As InformixMetadataProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


LoadDatabases Method (InformixMetadataProvider)

LoadDatabases Method (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : LoadDatabases Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadDatabases( _
   ByVal databases As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As InformixMetadataProvider
Dim databases As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadDatabases(databases, loadingOptions)
public virtual void LoadDatabases(
   MetadataList databases,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadDatabases(
   MetadataList* databases,
   MetadataLoadingOptions* loadingOptions
)

Parameters

databases
loadingOptions
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


LoadFields Method (InformixMetadataProvider)

LoadFields Method (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : LoadFields Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadFields( _
   ByVal fields As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As InformixMetadataProvider
Dim fields As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadFields(fields, loadingOptions)
public virtual void LoadFields(
   MetadataList fields,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadFields(
   MetadataList* fields,
   MetadataLoadingOptions* loadingOptions
)

Parameters

fields
loadingOptions
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


LoadForeignKeys Method (InformixMetadataProvider)

LoadForeignKeys Method (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : LoadForeignKeys Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadForeignKeys( _
   ByVal foreignKeys As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As InformixMetadataProvider
Dim foreignKeys As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadForeignKeys(foreignKeys, loadingOptions)
public virtual void LoadForeignKeys(
   MetadataList foreignKeys,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadForeignKeys(
   MetadataList* foreignKeys,
   MetadataLoadingOptions* loadingOptions
)

Parameters

foreignKeys
loadingOptions
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


LoadObjects Method (InformixMetadataProvider)

LoadObjects Method (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : LoadObjects Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadObjects( _
   ByVal objects As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As InformixMetadataProvider
Dim objects As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadObjects(objects, loadingOptions)
public virtual void LoadObjects(
   MetadataList objects,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadObjects(
   MetadataList* objects,
   MetadataLoadingOptions* loadingOptions
)

Parameters

objects
loadingOptions
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


LoadPackages Method (InformixMetadataProvider)

LoadPackages Method (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : LoadPackages Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadPackages( _
   ByVal packages As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As InformixMetadataProvider
Dim packages As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadPackages(packages, loadingOptions)
public virtual void LoadPackages(
   MetadataList packages,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadPackages(
   MetadataList* packages,
   MetadataLoadingOptions* loadingOptions
)

Parameters

packages
loadingOptions
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


LoadParams Method (InformixMetadataProvider)

LoadParams Method (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : LoadParams Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadParams( _
   ByVal params As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As InformixMetadataProvider
Dim params As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadParams(params, loadingOptions)
public virtual void LoadParams(
   MetadataList params,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadParams(
   MetadataList* params,
   MetadataLoadingOptions* loadingOptions
)

Parameters

params
loadingOptions
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


LoadSchemas Method (InformixMetadataProvider)

LoadSchemas Method (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : LoadSchemas Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadSchemas( _
   ByVal schemas As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As InformixMetadataProvider
Dim schemas As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadSchemas(schemas, loadingOptions)
public virtual void LoadSchemas(
   MetadataList schemas,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadSchemas(
   MetadataList* schemas,
   MetadataLoadingOptions* loadingOptions
)

Parameters

schemas
loadingOptions
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


LoadServers Method (InformixMetadataProvider)

LoadServers Method (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : LoadServers Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadServers( _
   ByVal servers As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As InformixMetadataProvider
Dim servers As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadServers(servers, loadingOptions)
public virtual void LoadServers(
   MetadataList servers,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadServers(
   MetadataList* servers,
   MetadataLoadingOptions* loadingOptions
)

Parameters

servers
loadingOptions
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


Site Property (InformixMetadataProvider)

Site Property (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As InformixMetadataProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


ToString Method (InformixMetadataProvider)

ToString Method (InformixMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > InformixMetadataProvider Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function ToString() As System.String
'Usage

Dim instance As InformixMetadataProvider
Dim value As System.String

value = instance.ToString()
public virtual System.string ToString()
public: virtual System.string* ToString();
Requirements

See Also

Reference

InformixMetadataProvider Class
InformixMetadataProvider Members


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.InformixMetadataProvider2) Inheritance Hierarchy

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.InformixMetadataProvider2) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.InformixMetadataProvider
See Also

Reference

ActiveDatabaseSoftware.InformixMetadataProvider2 Assembly


MSSQLCEMetadataProvider Class Events

MSSQLCEMetadataProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLCEMetadataProvider Class

For a list of all members of this type, see MSSQLCEMetadataProvider members.

See Also

Reference

MSSQLCEMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MSSQLCEMetadataProvider Class Methods

MSSQLCEMetadataProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLCEMetadataProvider Class

For a list of all members of this type, see MSSQLCEMetadataProvider members.

See Also

Reference

MSSQLCEMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AfterConnect Event (MSSQLCEMetadataProvider)

AfterConnect Event (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : AfterConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterConnect As System.EventHandler
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterConnect, handler
public event System.EventHandler AfterConnect
public: __event System.EventHandler* AfterConnect
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


AfterDisconnect Event (MSSQLCEMetadataProvider)

AfterDisconnect Event (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : AfterDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterDisconnect As System.EventHandler
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterDisconnect, handler
public event System.EventHandler AfterDisconnect
public: __event System.EventHandler* AfterDisconnect
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


BeforeConnect Event (MSSQLCEMetadataProvider)

BeforeConnect Event (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : BeforeConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeConnect As System.EventHandler
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeConnect, handler
public event System.EventHandler BeforeConnect
public: __event System.EventHandler* BeforeConnect
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


BeforeDisconnect Event (MSSQLCEMetadataProvider)

BeforeDisconnect Event (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : BeforeDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeDisconnect As System.EventHandler
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeDisconnect, handler
public event System.EventHandler BeforeDisconnect
public: __event System.EventHandler* BeforeDisconnect
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


CanExecSQL Property (MSSQLCEMetadataProvider)

CanExecSQL Property (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : CanExecSQL Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CanExecSQL As System.Boolean
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim value As System.Boolean

value = instance.CanExecSQL
public System.bool CanExecSQL {get;}
public: __property System.bool get_CanExecSQL();
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


Connect Method (MSSQLCEMetadataProvider)

Connect Method (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : Connect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Connect()
'Usage

Dim instance As MSSQLCEMetadataProvider

instance.Connect()
public void Connect()
public: void Connect();
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


Connected Property (MSSQLCEMetadataProvider)

Connected Property (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : Connected Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Connected As System.Boolean
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim value As System.Boolean

instance.Connected = value

value = instance.Connected
public System.bool Connected {get; set;}
public: __property System.bool get_Connected();
public: __property void set_Connected(
   System.bool value
);
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


ConnectionObjectsCreated Property (MSSQLCEMetadataProvider)

ConnectionObjectsCreated Property (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : ConnectionObjectsCreated Property
Gets or sets the reference to the DB Connection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ConnectionObjectsCreated As System.Boolean
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim value As System.Boolean

value = instance.ConnectionObjectsCreated
public System.bool ConnectionObjectsCreated {get;}
public: __property System.bool get_ConnectionObjectsCreated();
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


Container Property (MSSQLCEMetadataProvider)

Container Property (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


CreateObjRef Method (MSSQLCEMetadataProvider)

CreateObjRef Method (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


Description Property (MSSQLCEMetadataProvider)

Description Property (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : Description Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Description As System.String
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim value As System.String

value = instance.Description
public System.string Description {get;}
public: __property System.string* get_Description();
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


Disconnect Method (MSSQLCEMetadataProvider)

Disconnect Method (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : Disconnect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Disconnect()
'Usage

Dim instance As MSSQLCEMetadataProvider

instance.Disconnect()
public void Disconnect()
public: void Disconnect();
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


Dispose Method (MSSQLCEMetadataProvider)

Dispose Method (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : Dispose Method
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members
Base Implementation in Dispose


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As MSSQLCEMetadataProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


Disposed Event (MSSQLCEMetadataProvider)

Disposed Event (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


ExecSQL Method (MSSQLCEMetadataProvider)

ExecSQL Method (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : ExecSQL Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ExecSQL( _
   ByVal sql As System.String, _
   ByVal schemaOnly As System.Boolean _
) As System.Data.IDataReader
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim sql As System.String
Dim schemaOnly As System.Boolean
Dim value As System.Data.IDataReader

value = instance.ExecSQL(sql, schemaOnly)
public System.Data.IDataReader ExecSQL(
   System.string sql,
   System.bool schemaOnly
)
public: System.Data.IDataReader* ExecSQL(
   System.string* sql,
   System.bool schemaOnly
)

Parameters

sql
schemaOnly
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


ExecSQLNoResult Method (MSSQLCEMetadataProvider)

ExecSQLNoResult Method (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : ExecSQLNoResult Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ExecSQLNoResult( _
   ByVal sql As System.String _
)
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim sql As System.String

instance.ExecSQLNoResult(sql)
public void ExecSQLNoResult(
   System.string sql
)
public: void ExecSQLNoResult(
   System.string* sql
)

Parameters

sql
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


GetLifetimeService Method (MSSQLCEMetadataProvider)

GetLifetimeService Method (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


InitializeLifetimeService Method (MSSQLCEMetadataProvider)

InitializeLifetimeService Method (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


LoadDatabases Method (MSSQLCEMetadataProvider)

LoadDatabases Method (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : LoadDatabases Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadDatabases( _
   ByVal databases As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim databases As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadDatabases(databases, loadingOptions)
public virtual void LoadDatabases(
   MetadataList databases,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadDatabases(
   MetadataList* databases,
   MetadataLoadingOptions* loadingOptions
)

Parameters

databases
loadingOptions
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


LoadFields Method (MSSQLCEMetadataProvider)

LoadFields Method (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : LoadFields Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadFields( _
   ByVal fields As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim fields As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadFields(fields, loadingOptions)
public virtual void LoadFields(
   MetadataList fields,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadFields(
   MetadataList* fields,
   MetadataLoadingOptions* loadingOptions
)

Parameters

fields
loadingOptions
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


LoadForeignKeys Method (MSSQLCEMetadataProvider)

LoadForeignKeys Method (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : LoadForeignKeys Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadForeignKeys( _
   ByVal foreignKeys As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim foreignKeys As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadForeignKeys(foreignKeys, loadingOptions)
public virtual void LoadForeignKeys(
   MetadataList foreignKeys,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadForeignKeys(
   MetadataList* foreignKeys,
   MetadataLoadingOptions* loadingOptions
)

Parameters

foreignKeys
loadingOptions
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


LoadObjects Method (MSSQLCEMetadataProvider)

LoadObjects Method (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : LoadObjects Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadObjects( _
   ByVal objects As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim objects As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadObjects(objects, loadingOptions)
public virtual void LoadObjects(
   MetadataList objects,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadObjects(
   MetadataList* objects,
   MetadataLoadingOptions* loadingOptions
)

Parameters

objects
loadingOptions
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


LoadPackages Method (MSSQLCEMetadataProvider)

LoadPackages Method (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : LoadPackages Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadPackages( _
   ByVal packages As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim packages As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadPackages(packages, loadingOptions)
public virtual void LoadPackages(
   MetadataList packages,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadPackages(
   MetadataList* packages,
   MetadataLoadingOptions* loadingOptions
)

Parameters

packages
loadingOptions
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


LoadParams Method (MSSQLCEMetadataProvider)

LoadParams Method (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : LoadParams Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadParams( _
   ByVal params As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim params As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadParams(params, loadingOptions)
public virtual void LoadParams(
   MetadataList params,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadParams(
   MetadataList* params,
   MetadataLoadingOptions* loadingOptions
)

Parameters

params
loadingOptions
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


LoadSchemas Method (MSSQLCEMetadataProvider)

LoadSchemas Method (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : LoadSchemas Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadSchemas( _
   ByVal schemas As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim schemas As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadSchemas(schemas, loadingOptions)
public virtual void LoadSchemas(
   MetadataList schemas,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadSchemas(
   MetadataList* schemas,
   MetadataLoadingOptions* loadingOptions
)

Parameters

schemas
loadingOptions
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


LoadServers Method (MSSQLCEMetadataProvider)

LoadServers Method (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : LoadServers Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadServers( _
   ByVal servers As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim servers As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadServers(servers, loadingOptions)
public virtual void LoadServers(
   MetadataList servers,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadServers(
   MetadataList* servers,
   MetadataLoadingOptions* loadingOptions
)

Parameters

servers
loadingOptions
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


Site Property (MSSQLCEMetadataProvider)

Site Property (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


ToString Method (MSSQLCEMetadataProvider)

ToString Method (MSSQLCEMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLCEMetadataProvider Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function ToString() As System.String
'Usage

Dim instance As MSSQLCEMetadataProvider
Dim value As System.String

value = instance.ToString()
public virtual System.string ToString()
public: virtual System.string* ToString();
Requirements

See Also

Reference

MSSQLCEMetadataProvider Class
MSSQLCEMetadataProvider Members


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.MSSQLCEMetadataProvider2) Inheritance Hierarchy

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.MSSQLCEMetadataProvider2) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLCEMetadataProvider
See Also

Reference

ActiveDatabaseSoftware.MSSQLCEMetadataProvider2 Assembly


MSSQLMetadataProvider Class Events

MSSQLMetadataProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLMetadataProvider Class

For a list of all members of this type, see MSSQLMetadataProvider members.

See Also

Reference

MSSQLMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MSSQLMetadataProvider Class Methods

MSSQLMetadataProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MSSQLMetadataProvider Class

For a list of all members of this type, see MSSQLMetadataProvider members.

See Also

Reference

MSSQLMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AfterConnect Event (MSSQLMetadataProvider)

AfterConnect Event (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : AfterConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterConnect As System.EventHandler
'Usage

Dim instance As MSSQLMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterConnect, handler
public event System.EventHandler AfterConnect
public: __event System.EventHandler* AfterConnect
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


AfterDisconnect Event (MSSQLMetadataProvider)

AfterDisconnect Event (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : AfterDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterDisconnect As System.EventHandler
'Usage

Dim instance As MSSQLMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterDisconnect, handler
public event System.EventHandler AfterDisconnect
public: __event System.EventHandler* AfterDisconnect
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


BeforeConnect Event (MSSQLMetadataProvider)

BeforeConnect Event (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : BeforeConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeConnect As System.EventHandler
'Usage

Dim instance As MSSQLMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeConnect, handler
public event System.EventHandler BeforeConnect
public: __event System.EventHandler* BeforeConnect
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


BeforeDisconnect Event (MSSQLMetadataProvider)

BeforeDisconnect Event (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : BeforeDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeDisconnect As System.EventHandler
'Usage

Dim instance As MSSQLMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeDisconnect, handler
public event System.EventHandler BeforeDisconnect
public: __event System.EventHandler* BeforeDisconnect
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


CanExecSQL Property (MSSQLMetadataProvider)

CanExecSQL Property (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : CanExecSQL Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CanExecSQL As System.Boolean
'Usage

Dim instance As MSSQLMetadataProvider
Dim value As System.Boolean

value = instance.CanExecSQL
public System.bool CanExecSQL {get;}
public: __property System.bool get_CanExecSQL();
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


Connect Method (MSSQLMetadataProvider)

Connect Method (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : Connect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Connect()
'Usage

Dim instance As MSSQLMetadataProvider

instance.Connect()
public void Connect()
public: void Connect();
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


Connected Property (MSSQLMetadataProvider)

Connected Property (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : Connected Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Connected As System.Boolean
'Usage

Dim instance As MSSQLMetadataProvider
Dim value As System.Boolean

instance.Connected = value

value = instance.Connected
public System.bool Connected {get; set;}
public: __property System.bool get_Connected();
public: __property void set_Connected(
   System.bool value
);
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


ConnectionObjectsCreated Property (MSSQLMetadataProvider)

ConnectionObjectsCreated Property (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : ConnectionObjectsCreated Property
Gets or sets the reference to the DB Connection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ConnectionObjectsCreated As System.Boolean
'Usage

Dim instance As MSSQLMetadataProvider
Dim value As System.Boolean

value = instance.ConnectionObjectsCreated
public System.bool ConnectionObjectsCreated {get;}
public: __property System.bool get_ConnectionObjectsCreated();
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


Container Property (MSSQLMetadataProvider)

Container Property (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As MSSQLMetadataProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


CreateObjRef Method (MSSQLMetadataProvider)

CreateObjRef Method (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As MSSQLMetadataProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


Description Property (MSSQLMetadataProvider)

Description Property (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : Description Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Description As System.String
'Usage

Dim instance As MSSQLMetadataProvider
Dim value As System.String

value = instance.Description
public System.string Description {get;}
public: __property System.string* get_Description();
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


Disconnect Method (MSSQLMetadataProvider)

Disconnect Method (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : Disconnect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Disconnect()
'Usage

Dim instance As MSSQLMetadataProvider

instance.Disconnect()
public void Disconnect()
public: void Disconnect();
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


Dispose Method (MSSQLMetadataProvider)

Dispose Method (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : Dispose Method
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As MSSQLMetadataProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


Disposed Event (MSSQLMetadataProvider)

Disposed Event (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As MSSQLMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


ExecSQL Method (MSSQLMetadataProvider)

ExecSQL Method (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : ExecSQL Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ExecSQL( _
   ByVal sql As System.String, _
   ByVal schemaOnly As System.Boolean _
) As System.Data.IDataReader
'Usage

Dim instance As MSSQLMetadataProvider
Dim sql As System.String
Dim schemaOnly As System.Boolean
Dim value As System.Data.IDataReader

value = instance.ExecSQL(sql, schemaOnly)
public System.Data.IDataReader ExecSQL(
   System.string sql,
   System.bool schemaOnly
)
public: System.Data.IDataReader* ExecSQL(
   System.string* sql,
   System.bool schemaOnly
)

Parameters

sql
schemaOnly
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


ExecSQLNoResult Method (MSSQLMetadataProvider)

ExecSQLNoResult Method (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : ExecSQLNoResult Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ExecSQLNoResult( _
   ByVal sql As System.String _
)
'Usage

Dim instance As MSSQLMetadataProvider
Dim sql As System.String

instance.ExecSQLNoResult(sql)
public void ExecSQLNoResult(
   System.string sql
)
public: void ExecSQLNoResult(
   System.string* sql
)

Parameters

sql
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


GetLifetimeService Method (MSSQLMetadataProvider)

GetLifetimeService Method (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As MSSQLMetadataProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


InitializeLifetimeService Method (MSSQLMetadataProvider)

InitializeLifetimeService Method (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As MSSQLMetadataProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


LoadFields Method (MSSQLMetadataProvider)

LoadFields Method (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : LoadFields Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadFields( _
   ByVal fields As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MSSQLMetadataProvider
Dim fields As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadFields(fields, loadingOptions)
public virtual void LoadFields(
   MetadataList fields,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadFields(
   MetadataList* fields,
   MetadataLoadingOptions* loadingOptions
)

Parameters

fields
loadingOptions
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


LoadForeignKeys Method (MSSQLMetadataProvider)

LoadForeignKeys Method (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : LoadForeignKeys Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadForeignKeys( _
   ByVal foreignKeys As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MSSQLMetadataProvider
Dim foreignKeys As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadForeignKeys(foreignKeys, loadingOptions)
public virtual void LoadForeignKeys(
   MetadataList foreignKeys,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadForeignKeys(
   MetadataList* foreignKeys,
   MetadataLoadingOptions* loadingOptions
)

Parameters

foreignKeys
loadingOptions
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


LoadObjects Method (MSSQLMetadataProvider)

LoadObjects Method (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : LoadObjects Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadObjects( _
   ByVal objects As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MSSQLMetadataProvider
Dim objects As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadObjects(objects, loadingOptions)
public virtual void LoadObjects(
   MetadataList objects,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadObjects(
   MetadataList* objects,
   MetadataLoadingOptions* loadingOptions
)

Parameters

objects
loadingOptions
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


LoadPackages Method (MSSQLMetadataProvider)

LoadPackages Method (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : LoadPackages Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadPackages( _
   ByVal packages As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MSSQLMetadataProvider
Dim packages As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadPackages(packages, loadingOptions)
public virtual void LoadPackages(
   MetadataList packages,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadPackages(
   MetadataList* packages,
   MetadataLoadingOptions* loadingOptions
)

Parameters

packages
loadingOptions
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


LoadParams Method (MSSQLMetadataProvider)

LoadParams Method (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : LoadParams Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadParams( _
   ByVal params As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MSSQLMetadataProvider
Dim params As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadParams(params, loadingOptions)
public virtual void LoadParams(
   MetadataList params,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadParams(
   MetadataList* params,
   MetadataLoadingOptions* loadingOptions
)

Parameters

params
loadingOptions
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


LoadSchemas Method (MSSQLMetadataProvider)

LoadSchemas Method (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : LoadSchemas Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadSchemas( _
   ByVal schemas As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MSSQLMetadataProvider
Dim schemas As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadSchemas(schemas, loadingOptions)
public virtual void LoadSchemas(
   MetadataList schemas,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadSchemas(
   MetadataList* schemas,
   MetadataLoadingOptions* loadingOptions
)

Parameters

schemas
loadingOptions
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


LoadServers Method (MSSQLMetadataProvider)

LoadServers Method (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : LoadServers Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadServers( _
   ByVal servers As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MSSQLMetadataProvider
Dim servers As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadServers(servers, loadingOptions)
public virtual void LoadServers(
   MetadataList servers,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadServers(
   MetadataList* servers,
   MetadataLoadingOptions* loadingOptions
)

Parameters

servers
loadingOptions
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


Site Property (MSSQLMetadataProvider)

Site Property (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As MSSQLMetadataProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


ToString Method (MSSQLMetadataProvider)

ToString Method (MSSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MSSQLMetadataProvider Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function ToString() As System.String
'Usage

Dim instance As MSSQLMetadataProvider
Dim value As System.String

value = instance.ToString()
public virtual System.string ToString()
public: virtual System.string* ToString();
Requirements

See Also

Reference

MSSQLMetadataProvider Class
MSSQLMetadataProvider Members


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.MSSQLMetadataProvider2) Inheritance Hierarchy

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.MSSQLMetadataProvider2) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MSSQLMetadataProvider
See Also

Reference

ActiveDatabaseSoftware.MSSQLMetadataProvider2 Assembly


MySQLMetadataProvider Class Events

MySQLMetadataProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MySQLMetadataProvider Class

For a list of all members of this type, see MySQLMetadataProvider members.

See Also

Reference

MySQLMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


MySQLMetadataProvider Class Methods

MySQLMetadataProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : MySQLMetadataProvider Class

For a list of all members of this type, see MySQLMetadataProvider members.

See Also

Reference

MySQLMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AfterConnect Event (MySQLMetadataProvider)

AfterConnect Event (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : AfterConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterConnect As System.EventHandler
'Usage

Dim instance As MySQLMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterConnect, handler
public event System.EventHandler AfterConnect
public: __event System.EventHandler* AfterConnect
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


AfterDisconnect Event (MySQLMetadataProvider)

AfterDisconnect Event (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : AfterDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterDisconnect As System.EventHandler
'Usage

Dim instance As MySQLMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterDisconnect, handler
public event System.EventHandler AfterDisconnect
public: __event System.EventHandler* AfterDisconnect
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


BeforeConnect Event (MySQLMetadataProvider)

BeforeConnect Event (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : BeforeConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeConnect As System.EventHandler
'Usage

Dim instance As MySQLMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeConnect, handler
public event System.EventHandler BeforeConnect
public: __event System.EventHandler* BeforeConnect
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


BeforeDisconnect Event (MySQLMetadataProvider)

BeforeDisconnect Event (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : BeforeDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeDisconnect As System.EventHandler
'Usage

Dim instance As MySQLMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeDisconnect, handler
public event System.EventHandler BeforeDisconnect
public: __event System.EventHandler* BeforeDisconnect
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


CanExecSQL Property (MySQLMetadataProvider)

CanExecSQL Property (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : CanExecSQL Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CanExecSQL As System.Boolean
'Usage

Dim instance As MySQLMetadataProvider
Dim value As System.Boolean

value = instance.CanExecSQL
public System.bool CanExecSQL {get;}
public: __property System.bool get_CanExecSQL();
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


Connect Method (MySQLMetadataProvider)

Connect Method (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : Connect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Connect()
'Usage

Dim instance As MySQLMetadataProvider

instance.Connect()
public void Connect()
public: void Connect();
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


Connected Property (MySQLMetadataProvider)

Connected Property (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : Connected Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Connected As System.Boolean
'Usage

Dim instance As MySQLMetadataProvider
Dim value As System.Boolean

instance.Connected = value

value = instance.Connected
public System.bool Connected {get; set;}
public: __property System.bool get_Connected();
public: __property void set_Connected(
   System.bool value
);
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


ConnectionObjectsCreated Property (MySQLMetadataProvider)

ConnectionObjectsCreated Property (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : ConnectionObjectsCreated Property
Gets or sets the reference to the DB Connection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ConnectionObjectsCreated As System.Boolean
'Usage

Dim instance As MySQLMetadataProvider
Dim value As System.Boolean

value = instance.ConnectionObjectsCreated
public System.bool ConnectionObjectsCreated {get;}
public: __property System.bool get_ConnectionObjectsCreated();
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


Container Property (MySQLMetadataProvider)

Container Property (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As MySQLMetadataProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


CreateObjRef Method (MySQLMetadataProvider)

CreateObjRef Method (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As MySQLMetadataProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


Description Property (MySQLMetadataProvider)

Description Property (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : Description Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Description As System.String
'Usage

Dim instance As MySQLMetadataProvider
Dim value As System.String

value = instance.Description
public System.string Description {get;}
public: __property System.string* get_Description();
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


Disconnect Method (MySQLMetadataProvider)

Disconnect Method (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : Disconnect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Disconnect()
'Usage

Dim instance As MySQLMetadataProvider

instance.Disconnect()
public void Disconnect()
public: void Disconnect();
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


Dispose Method (MySQLMetadataProvider)

Dispose Method (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : Dispose Method
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members
Base Implementation in Dispose


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As MySQLMetadataProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


Disposed Event (MySQLMetadataProvider)

Disposed Event (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As MySQLMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


ExecSQL Method (MySQLMetadataProvider)

ExecSQL Method (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : ExecSQL Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ExecSQL( _
   ByVal sql As System.String, _
   ByVal schemaOnly As System.Boolean _
) As System.Data.IDataReader
'Usage

Dim instance As MySQLMetadataProvider
Dim sql As System.String
Dim schemaOnly As System.Boolean
Dim value As System.Data.IDataReader

value = instance.ExecSQL(sql, schemaOnly)
public System.Data.IDataReader ExecSQL(
   System.string sql,
   System.bool schemaOnly
)
public: System.Data.IDataReader* ExecSQL(
   System.string* sql,
   System.bool schemaOnly
)

Parameters

sql
schemaOnly
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


ExecSQLNoResult Method (MySQLMetadataProvider)

ExecSQLNoResult Method (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : ExecSQLNoResult Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ExecSQLNoResult( _
   ByVal sql As System.String _
)
'Usage

Dim instance As MySQLMetadataProvider
Dim sql As System.String

instance.ExecSQLNoResult(sql)
public void ExecSQLNoResult(
   System.string sql
)
public: void ExecSQLNoResult(
   System.string* sql
)

Parameters

sql
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


GetLifetimeService Method (MySQLMetadataProvider)

GetLifetimeService Method (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As MySQLMetadataProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


InitializeLifetimeService Method (MySQLMetadataProvider)

InitializeLifetimeService Method (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As MySQLMetadataProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


LoadDatabases Method (MySQLMetadataProvider)

LoadDatabases Method (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : LoadDatabases Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadDatabases( _
   ByVal databases As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MySQLMetadataProvider
Dim databases As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadDatabases(databases, loadingOptions)
public virtual void LoadDatabases(
   MetadataList databases,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadDatabases(
   MetadataList* databases,
   MetadataLoadingOptions* loadingOptions
)

Parameters

databases
loadingOptions
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


LoadFields Method (MySQLMetadataProvider)

LoadFields Method (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : LoadFields Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadFields( _
   ByVal fields As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MySQLMetadataProvider
Dim fields As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadFields(fields, loadingOptions)
public virtual void LoadFields(
   MetadataList fields,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadFields(
   MetadataList* fields,
   MetadataLoadingOptions* loadingOptions
)

Parameters

fields
loadingOptions
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


LoadPackages Method (MySQLMetadataProvider)

LoadPackages Method (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : LoadPackages Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadPackages( _
   ByVal packages As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MySQLMetadataProvider
Dim packages As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadPackages(packages, loadingOptions)
public virtual void LoadPackages(
   MetadataList packages,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadPackages(
   MetadataList* packages,
   MetadataLoadingOptions* loadingOptions
)

Parameters

packages
loadingOptions
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


LoadParams Method (MySQLMetadataProvider)

LoadParams Method (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : LoadParams Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadParams( _
   ByVal params As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MySQLMetadataProvider
Dim params As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadParams(params, loadingOptions)
public virtual void LoadParams(
   MetadataList params,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadParams(
   MetadataList* params,
   MetadataLoadingOptions* loadingOptions
)

Parameters

params
loadingOptions
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


LoadSchemas Method (MySQLMetadataProvider)

LoadSchemas Method (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : LoadSchemas Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadSchemas( _
   ByVal schemas As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MySQLMetadataProvider
Dim schemas As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadSchemas(schemas, loadingOptions)
public virtual void LoadSchemas(
   MetadataList schemas,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadSchemas(
   MetadataList* schemas,
   MetadataLoadingOptions* loadingOptions
)

Parameters

schemas
loadingOptions
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


LoadServers Method (MySQLMetadataProvider)

LoadServers Method (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : LoadServers Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadServers( _
   ByVal servers As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As MySQLMetadataProvider
Dim servers As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadServers(servers, loadingOptions)
public virtual void LoadServers(
   MetadataList servers,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadServers(
   MetadataList* servers,
   MetadataLoadingOptions* loadingOptions
)

Parameters

servers
loadingOptions
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


Site Property (MySQLMetadataProvider)

Site Property (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As MySQLMetadataProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


ToString Method (MySQLMetadataProvider)

ToString Method (MySQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > MySQLMetadataProvider Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function ToString() As System.String
'Usage

Dim instance As MySQLMetadataProvider
Dim value As System.String

value = instance.ToString()
public virtual System.string ToString()
public: virtual System.string* ToString();
Requirements

See Also

Reference

MySQLMetadataProvider Class
MySQLMetadataProvider Members


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.MySQLMetadataProvider2) Inheritance Hierarchy

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.MySQLMetadataProvider2) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.MySQLMetadataProvider
See Also

Reference

ActiveDatabaseSoftware.MySQLMetadataProvider2 Assembly


ODBCMetadataProvider Class Events

ODBCMetadataProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : ODBCMetadataProvider Class

For a list of all members of this type, see ODBCMetadataProvider members.

See Also

Reference

ODBCMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


ODBCMetadataProvider Class Methods

ODBCMetadataProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : ODBCMetadataProvider Class

For a list of all members of this type, see ODBCMetadataProvider members.

See Also

Reference

ODBCMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AfterConnect Event (ODBCMetadataProvider)

AfterConnect Event (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : AfterConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterConnect As System.EventHandler
'Usage

Dim instance As ODBCMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterConnect, handler
public event System.EventHandler AfterConnect
public: __event System.EventHandler* AfterConnect
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


AfterDisconnect Event (ODBCMetadataProvider)

AfterDisconnect Event (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : AfterDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterDisconnect As System.EventHandler
'Usage

Dim instance As ODBCMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterDisconnect, handler
public event System.EventHandler AfterDisconnect
public: __event System.EventHandler* AfterDisconnect
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


BeforeConnect Event (ODBCMetadataProvider)

BeforeConnect Event (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : BeforeConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeConnect As System.EventHandler
'Usage

Dim instance As ODBCMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeConnect, handler
public event System.EventHandler BeforeConnect
public: __event System.EventHandler* BeforeConnect
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


BeforeDisconnect Event (ODBCMetadataProvider)

BeforeDisconnect Event (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : BeforeDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeDisconnect As System.EventHandler
'Usage

Dim instance As ODBCMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeDisconnect, handler
public event System.EventHandler BeforeDisconnect
public: __event System.EventHandler* BeforeDisconnect
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


CanExecSQL Property (ODBCMetadataProvider)

CanExecSQL Property (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : CanExecSQL Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CanExecSQL As System.Boolean
'Usage

Dim instance As ODBCMetadataProvider
Dim value As System.Boolean

value = instance.CanExecSQL
public System.bool CanExecSQL {get;}
public: __property System.bool get_CanExecSQL();
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


Connect Method (ODBCMetadataProvider)

Connect Method (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : Connect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Connect()
'Usage

Dim instance As ODBCMetadataProvider

instance.Connect()
public void Connect()
public: void Connect();
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


Connected Property (ODBCMetadataProvider)

Connected Property (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : Connected Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Connected As System.Boolean
'Usage

Dim instance As ODBCMetadataProvider
Dim value As System.Boolean

instance.Connected = value

value = instance.Connected
public System.bool Connected {get; set;}
public: __property System.bool get_Connected();
public: __property void set_Connected(
   System.bool value
);
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


ConnectionObjectsCreated Property (ODBCMetadataProvider)

ConnectionObjectsCreated Property (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : ConnectionObjectsCreated Property
Gets or sets the reference to the DB Connection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ConnectionObjectsCreated As System.Boolean
'Usage

Dim instance As ODBCMetadataProvider
Dim value As System.Boolean

value = instance.ConnectionObjectsCreated
public System.bool ConnectionObjectsCreated {get;}
public: __property System.bool get_ConnectionObjectsCreated();
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


Container Property (ODBCMetadataProvider)

Container Property (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As ODBCMetadataProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


CreateObjRef Method (ODBCMetadataProvider)

CreateObjRef Method (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As ODBCMetadataProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


Description Property (ODBCMetadataProvider)

Description Property (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : Description Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Description As System.String
'Usage

Dim instance As ODBCMetadataProvider
Dim value As System.String

value = instance.Description
public System.string Description {get;}
public: __property System.string* get_Description();
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


Disconnect Method (ODBCMetadataProvider)

Disconnect Method (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : Disconnect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Disconnect()
'Usage

Dim instance As ODBCMetadataProvider

instance.Disconnect()
public void Disconnect()
public: void Disconnect();
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


Dispose Method (ODBCMetadataProvider)

Dispose Method (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : Dispose Method
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As ODBCMetadataProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


Disposed Event (ODBCMetadataProvider)

Disposed Event (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As ODBCMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


ExecSQL Method (ODBCMetadataProvider)

ExecSQL Method (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : ExecSQL Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ExecSQL( _
   ByVal sql As System.String, _
   ByVal schemaOnly As System.Boolean _
) As System.Data.IDataReader
'Usage

Dim instance As ODBCMetadataProvider
Dim sql As System.String
Dim schemaOnly As System.Boolean
Dim value As System.Data.IDataReader

value = instance.ExecSQL(sql, schemaOnly)
public System.Data.IDataReader ExecSQL(
   System.string sql,
   System.bool schemaOnly
)
public: System.Data.IDataReader* ExecSQL(
   System.string* sql,
   System.bool schemaOnly
)

Parameters

sql
schemaOnly
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


ExecSQLNoResult Method (ODBCMetadataProvider)

ExecSQLNoResult Method (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : ExecSQLNoResult Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ExecSQLNoResult( _
   ByVal sql As System.String _
)
'Usage

Dim instance As ODBCMetadataProvider
Dim sql As System.String

instance.ExecSQLNoResult(sql)
public void ExecSQLNoResult(
   System.string sql
)
public: void ExecSQLNoResult(
   System.string* sql
)

Parameters

sql
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


GetLifetimeService Method (ODBCMetadataProvider)

GetLifetimeService Method (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As ODBCMetadataProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


InitializeLifetimeService Method (ODBCMetadataProvider)

InitializeLifetimeService Method (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As ODBCMetadataProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


LoadDatabases Method (ODBCMetadataProvider)

LoadDatabases Method (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : LoadDatabases Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadDatabases( _
   ByVal databases As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As ODBCMetadataProvider
Dim databases As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadDatabases(databases, loadingOptions)
public virtual void LoadDatabases(
   MetadataList databases,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadDatabases(
   MetadataList* databases,
   MetadataLoadingOptions* loadingOptions
)

Parameters

databases
loadingOptions
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


LoadFields Method (ODBCMetadataProvider)

LoadFields Method (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : LoadFields Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadFields( _
   ByVal fields As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As ODBCMetadataProvider
Dim fields As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadFields(fields, loadingOptions)
public virtual void LoadFields(
   MetadataList fields,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadFields(
   MetadataList* fields,
   MetadataLoadingOptions* loadingOptions
)

Parameters

fields
loadingOptions
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


LoadForeignKeys Method (ODBCMetadataProvider)

LoadForeignKeys Method (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : LoadForeignKeys Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadForeignKeys( _
   ByVal foreignKeys As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As ODBCMetadataProvider
Dim foreignKeys As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadForeignKeys(foreignKeys, loadingOptions)
public virtual void LoadForeignKeys(
   MetadataList foreignKeys,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadForeignKeys(
   MetadataList* foreignKeys,
   MetadataLoadingOptions* loadingOptions
)

Parameters

foreignKeys
loadingOptions
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


LoadPackages Method (ODBCMetadataProvider)

LoadPackages Method (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : LoadPackages Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadPackages( _
   ByVal packages As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As ODBCMetadataProvider
Dim packages As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadPackages(packages, loadingOptions)
public virtual void LoadPackages(
   MetadataList packages,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadPackages(
   MetadataList* packages,
   MetadataLoadingOptions* loadingOptions
)

Parameters

packages
loadingOptions
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


LoadParams Method (ODBCMetadataProvider)

LoadParams Method (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : LoadParams Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadParams( _
   ByVal params As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As ODBCMetadataProvider
Dim params As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadParams(params, loadingOptions)
public virtual void LoadParams(
   MetadataList params,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadParams(
   MetadataList* params,
   MetadataLoadingOptions* loadingOptions
)

Parameters

params
loadingOptions
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


LoadSchemas Method (ODBCMetadataProvider)

LoadSchemas Method (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : LoadSchemas Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadSchemas( _
   ByVal schemas As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As ODBCMetadataProvider
Dim schemas As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadSchemas(schemas, loadingOptions)
public virtual void LoadSchemas(
   MetadataList schemas,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadSchemas(
   MetadataList* schemas,
   MetadataLoadingOptions* loadingOptions
)

Parameters

schemas
loadingOptions
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


LoadServers Method (ODBCMetadataProvider)

LoadServers Method (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : LoadServers Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadServers( _
   ByVal servers As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As ODBCMetadataProvider
Dim servers As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadServers(servers, loadingOptions)
public virtual void LoadServers(
   MetadataList servers,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadServers(
   MetadataList* servers,
   MetadataLoadingOptions* loadingOptions
)

Parameters

servers
loadingOptions
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


Site Property (ODBCMetadataProvider)

Site Property (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As ODBCMetadataProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


ToString Method (ODBCMetadataProvider)

ToString Method (ODBCMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > ODBCMetadataProvider Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function ToString() As System.String
'Usage

Dim instance As ODBCMetadataProvider
Dim value As System.String

value = instance.ToString()
public virtual System.string ToString()
public: virtual System.string* ToString();
Requirements

See Also

Reference

ODBCMetadataProvider Class
ODBCMetadataProvider Members


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.ODBCMetadataProvider2) Inheritance Hierarchy

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.ODBCMetadataProvider2) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.ODBCMetadataProvider
See Also

Reference

ActiveDatabaseSoftware.ODBCMetadataProvider2 Assembly


OLEDBMetadataProvider Class Events

OLEDBMetadataProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : OLEDBMetadataProvider Class

For a list of all members of this type, see OLEDBMetadataProvider members.

See Also

Reference

OLEDBMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


OLEDBMetadataProvider Class Methods

OLEDBMetadataProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : OLEDBMetadataProvider Class

For a list of all members of this type, see OLEDBMetadataProvider members.

See Also

Reference

OLEDBMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AfterConnect Event (OLEDBMetadataProvider)

AfterConnect Event (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : AfterConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterConnect As System.EventHandler
'Usage

Dim instance As OLEDBMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterConnect, handler
public event System.EventHandler AfterConnect
public: __event System.EventHandler* AfterConnect
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


AfterDisconnect Event (OLEDBMetadataProvider)

AfterDisconnect Event (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : AfterDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterDisconnect As System.EventHandler
'Usage

Dim instance As OLEDBMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterDisconnect, handler
public event System.EventHandler AfterDisconnect
public: __event System.EventHandler* AfterDisconnect
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


BeforeConnect Event (OLEDBMetadataProvider)

BeforeConnect Event (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : BeforeConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeConnect As System.EventHandler
'Usage

Dim instance As OLEDBMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeConnect, handler
public event System.EventHandler BeforeConnect
public: __event System.EventHandler* BeforeConnect
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


BeforeDisconnect Event (OLEDBMetadataProvider)

BeforeDisconnect Event (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : BeforeDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeDisconnect As System.EventHandler
'Usage

Dim instance As OLEDBMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeDisconnect, handler
public event System.EventHandler BeforeDisconnect
public: __event System.EventHandler* BeforeDisconnect
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


CanExecSQL Property (OLEDBMetadataProvider)

CanExecSQL Property (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : CanExecSQL Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CanExecSQL As System.Boolean
'Usage

Dim instance As OLEDBMetadataProvider
Dim value As System.Boolean

value = instance.CanExecSQL
public System.bool CanExecSQL {get;}
public: __property System.bool get_CanExecSQL();
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


Connect Method (OLEDBMetadataProvider)

Connect Method (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : Connect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Connect()
'Usage

Dim instance As OLEDBMetadataProvider

instance.Connect()
public void Connect()
public: void Connect();
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


Connected Property (OLEDBMetadataProvider)

Connected Property (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : Connected Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Connected As System.Boolean
'Usage

Dim instance As OLEDBMetadataProvider
Dim value As System.Boolean

instance.Connected = value

value = instance.Connected
public System.bool Connected {get; set;}
public: __property System.bool get_Connected();
public: __property void set_Connected(
   System.bool value
);
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


ConnectionObjectsCreated Property (OLEDBMetadataProvider)

ConnectionObjectsCreated Property (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : ConnectionObjectsCreated Property
Gets or sets the reference to the DB Connection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ConnectionObjectsCreated As System.Boolean
'Usage

Dim instance As OLEDBMetadataProvider
Dim value As System.Boolean

value = instance.ConnectionObjectsCreated
public System.bool ConnectionObjectsCreated {get;}
public: __property System.bool get_ConnectionObjectsCreated();
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


Container Property (OLEDBMetadataProvider)

Container Property (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As OLEDBMetadataProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


CreateObjRef Method (OLEDBMetadataProvider)

CreateObjRef Method (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As OLEDBMetadataProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


Description Property (OLEDBMetadataProvider)

Description Property (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : Description Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Description As System.String
'Usage

Dim instance As OLEDBMetadataProvider
Dim value As System.String

value = instance.Description
public System.string Description {get;}
public: __property System.string* get_Description();
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


Disconnect Method (OLEDBMetadataProvider)

Disconnect Method (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : Disconnect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Disconnect()
'Usage

Dim instance As OLEDBMetadataProvider

instance.Disconnect()
public void Disconnect()
public: void Disconnect();
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


Dispose Method (OLEDBMetadataProvider)

Dispose Method (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : Dispose Method
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As OLEDBMetadataProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


Disposed Event (OLEDBMetadataProvider)

Disposed Event (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As OLEDBMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


ExecSQL Method (OLEDBMetadataProvider)

ExecSQL Method (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : ExecSQL Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ExecSQL( _
   ByVal sql As System.String, _
   ByVal schemaOnly As System.Boolean _
) As System.Data.IDataReader
'Usage

Dim instance As OLEDBMetadataProvider
Dim sql As System.String
Dim schemaOnly As System.Boolean
Dim value As System.Data.IDataReader

value = instance.ExecSQL(sql, schemaOnly)
public System.Data.IDataReader ExecSQL(
   System.string sql,
   System.bool schemaOnly
)
public: System.Data.IDataReader* ExecSQL(
   System.string* sql,
   System.bool schemaOnly
)

Parameters

sql
schemaOnly
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


ExecSQLNoResult Method (OLEDBMetadataProvider)

ExecSQLNoResult Method (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : ExecSQLNoResult Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ExecSQLNoResult( _
   ByVal sql As System.String _
)
'Usage

Dim instance As OLEDBMetadataProvider
Dim sql As System.String

instance.ExecSQLNoResult(sql)
public void ExecSQLNoResult(
   System.string sql
)
public: void ExecSQLNoResult(
   System.string* sql
)

Parameters

sql
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


GetLifetimeService Method (OLEDBMetadataProvider)

GetLifetimeService Method (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As OLEDBMetadataProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


InitializeLifetimeService Method (OLEDBMetadataProvider)

InitializeLifetimeService Method (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As OLEDBMetadataProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


LoadFields Method (OLEDBMetadataProvider)

LoadFields Method (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : LoadFields Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadFields( _
   ByVal fields As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OLEDBMetadataProvider
Dim fields As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadFields(fields, loadingOptions)
public virtual void LoadFields(
   MetadataList fields,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadFields(
   MetadataList* fields,
   MetadataLoadingOptions* loadingOptions
)

Parameters

fields
loadingOptions
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


LoadPackages Method (OLEDBMetadataProvider)

LoadPackages Method (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : LoadPackages Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadPackages( _
   ByVal packages As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OLEDBMetadataProvider
Dim packages As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadPackages(packages, loadingOptions)
public virtual void LoadPackages(
   MetadataList packages,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadPackages(
   MetadataList* packages,
   MetadataLoadingOptions* loadingOptions
)

Parameters

packages
loadingOptions
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


LoadParams Method (OLEDBMetadataProvider)

LoadParams Method (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : LoadParams Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadParams( _
   ByVal params As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OLEDBMetadataProvider
Dim params As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadParams(params, loadingOptions)
public virtual void LoadParams(
   MetadataList params,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadParams(
   MetadataList* params,
   MetadataLoadingOptions* loadingOptions
)

Parameters

params
loadingOptions
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


LoadSchemas Method (OLEDBMetadataProvider)

LoadSchemas Method (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : LoadSchemas Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadSchemas( _
   ByVal schemas As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OLEDBMetadataProvider
Dim schemas As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadSchemas(schemas, loadingOptions)
public virtual void LoadSchemas(
   MetadataList schemas,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadSchemas(
   MetadataList* schemas,
   MetadataLoadingOptions* loadingOptions
)

Parameters

schemas
loadingOptions
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


LoadServers Method (OLEDBMetadataProvider)

LoadServers Method (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : LoadServers Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadServers( _
   ByVal servers As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OLEDBMetadataProvider
Dim servers As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadServers(servers, loadingOptions)
public virtual void LoadServers(
   MetadataList servers,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadServers(
   MetadataList* servers,
   MetadataLoadingOptions* loadingOptions
)

Parameters

servers
loadingOptions
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


Site Property (OLEDBMetadataProvider)

Site Property (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As OLEDBMetadataProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


ToString Method (OLEDBMetadataProvider)

ToString Method (OLEDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OLEDBMetadataProvider Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function ToString() As System.String
'Usage

Dim instance As OLEDBMetadataProvider
Dim value As System.String

value = instance.ToString()
public virtual System.string ToString()
public: virtual System.string* ToString();
Requirements

See Also

Reference

OLEDBMetadataProvider Class
OLEDBMetadataProvider Members


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.OLEDBMetadataProvider2) Inheritance Hierarchy

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.OLEDBMetadataProvider2) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.OLEDBMetadataProvider
See Also

Reference

ActiveDatabaseSoftware.OLEDBMetadataProvider2 Assembly


OracleMetadataProvider Class Events

OracleMetadataProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : OracleMetadataProvider Class

For a list of all members of this type, see OracleMetadataProvider members.

See Also

Reference

OracleMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
Metadata Provider for Oracle Database through Oracle.DataAccess.Client (Oracle)


OracleMetadataProvider Class Methods

OracleMetadataProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : OracleMetadataProvider Class

For a list of all members of this type, see OracleMetadataProvider members.

See Also

Reference

OracleMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
Metadata Provider for Oracle Database through Oracle.DataAccess.Client (Oracle)


AfterConnect Event (OracleMetadataProvider)

AfterConnect Event (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : AfterConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterConnect As System.EventHandler
'Usage

Dim instance As OracleMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterConnect, handler
public event System.EventHandler AfterConnect
public: __event System.EventHandler* AfterConnect
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


AfterDisconnect Event (OracleMetadataProvider)

AfterDisconnect Event (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : AfterDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterDisconnect As System.EventHandler
'Usage

Dim instance As OracleMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterDisconnect, handler
public event System.EventHandler AfterDisconnect
public: __event System.EventHandler* AfterDisconnect
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


BeforeConnect Event (OracleMetadataProvider)

BeforeConnect Event (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : BeforeConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeConnect As System.EventHandler
'Usage

Dim instance As OracleMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeConnect, handler
public event System.EventHandler BeforeConnect
public: __event System.EventHandler* BeforeConnect
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


BeforeDisconnect Event (OracleMetadataProvider)

BeforeDisconnect Event (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : BeforeDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeDisconnect As System.EventHandler
'Usage

Dim instance As OracleMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeDisconnect, handler
public event System.EventHandler BeforeDisconnect
public: __event System.EventHandler* BeforeDisconnect
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


CanExecSQL Property (OracleMetadataProvider)

CanExecSQL Property (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : CanExecSQL Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CanExecSQL As System.Boolean
'Usage

Dim instance As OracleMetadataProvider
Dim value As System.Boolean

value = instance.CanExecSQL
public System.bool CanExecSQL {get;}
public: __property System.bool get_CanExecSQL();
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


Connect Method (OracleMetadataProvider)

Connect Method (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : Connect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Connect()
'Usage

Dim instance As OracleMetadataProvider

instance.Connect()
public void Connect()
public: void Connect();
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


Connected Property (OracleMetadataProvider)

Connected Property (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : Connected Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Connected As System.Boolean
'Usage

Dim instance As OracleMetadataProvider
Dim value As System.Boolean

instance.Connected = value

value = instance.Connected
public System.bool Connected {get; set;}
public: __property System.bool get_Connected();
public: __property void set_Connected(
   System.bool value
);
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


ConnectionObjectsCreated Property (OracleMetadataProvider)

ConnectionObjectsCreated Property (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : ConnectionObjectsCreated Property
Gets or sets the reference to the DB Connection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ConnectionObjectsCreated As System.Boolean
'Usage

Dim instance As OracleMetadataProvider
Dim value As System.Boolean

value = instance.ConnectionObjectsCreated
public System.bool ConnectionObjectsCreated {get;}
public: __property System.bool get_ConnectionObjectsCreated();
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


Container Property (OracleMetadataProvider)

Container Property (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As OracleMetadataProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


CreateObjRef Method (OracleMetadataProvider)

CreateObjRef Method (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As OracleMetadataProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


Description Property (OracleMetadataProvider)

Description Property (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : Description Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Description As System.String
'Usage

Dim instance As OracleMetadataProvider
Dim value As System.String

value = instance.Description
public System.string Description {get;}
public: __property System.string* get_Description();
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


Disconnect Method (OracleMetadataProvider)

Disconnect Method (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : Disconnect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Disconnect()
'Usage

Dim instance As OracleMetadataProvider

instance.Disconnect()
public void Disconnect()
public: void Disconnect();
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


Dispose Method (OracleMetadataProvider)

Dispose Method (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : Dispose Method
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As OracleMetadataProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


Disposed Event (OracleMetadataProvider)

Disposed Event (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As OracleMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


ExecSQL Method (OracleMetadataProvider)

ExecSQL Method (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : ExecSQL Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ExecSQL( _
   ByVal sql As System.String, _
   ByVal schemaOnly As System.Boolean _
) As System.Data.IDataReader
'Usage

Dim instance As OracleMetadataProvider
Dim sql As System.String
Dim schemaOnly As System.Boolean
Dim value As System.Data.IDataReader

value = instance.ExecSQL(sql, schemaOnly)
public System.Data.IDataReader ExecSQL(
   System.string sql,
   System.bool schemaOnly
)
public: System.Data.IDataReader* ExecSQL(
   System.string* sql,
   System.bool schemaOnly
)

Parameters

sql
schemaOnly
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


ExecSQLNoResult Method (OracleMetadataProvider)

ExecSQLNoResult Method (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : ExecSQLNoResult Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ExecSQLNoResult( _
   ByVal sql As System.String _
)
'Usage

Dim instance As OracleMetadataProvider
Dim sql As System.String

instance.ExecSQLNoResult(sql)
public void ExecSQLNoResult(
   System.string sql
)
public: void ExecSQLNoResult(
   System.string* sql
)

Parameters

sql
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


GetLifetimeService Method (OracleMetadataProvider)

GetLifetimeService Method (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As OracleMetadataProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


InitializeLifetimeService Method (OracleMetadataProvider)

InitializeLifetimeService Method (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As OracleMetadataProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


LoadDatabases Method (OracleMetadataProvider)

LoadDatabases Method (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : LoadDatabases Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadDatabases( _
   ByVal databases As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OracleMetadataProvider
Dim databases As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadDatabases(databases, loadingOptions)
public virtual void LoadDatabases(
   MetadataList databases,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadDatabases(
   MetadataList* databases,
   MetadataLoadingOptions* loadingOptions
)

Parameters

databases
loadingOptions
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


LoadFields Method (OracleMetadataProvider)

LoadFields Method (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : LoadFields Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadFields( _
   ByVal fields As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OracleMetadataProvider
Dim fields As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadFields(fields, loadingOptions)
public virtual void LoadFields(
   MetadataList fields,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadFields(
   MetadataList* fields,
   MetadataLoadingOptions* loadingOptions
)

Parameters

fields
loadingOptions
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


LoadForeignKeys Method (OracleMetadataProvider)

LoadForeignKeys Method (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : LoadForeignKeys Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadForeignKeys( _
   ByVal foreignKeys As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OracleMetadataProvider
Dim foreignKeys As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadForeignKeys(foreignKeys, loadingOptions)
public virtual void LoadForeignKeys(
   MetadataList foreignKeys,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadForeignKeys(
   MetadataList* foreignKeys,
   MetadataLoadingOptions* loadingOptions
)

Parameters

foreignKeys
loadingOptions
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


LoadObjects Method (OracleMetadataProvider)

LoadObjects Method (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : LoadObjects Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadObjects( _
   ByVal objects As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OracleMetadataProvider
Dim objects As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadObjects(objects, loadingOptions)
public virtual void LoadObjects(
   MetadataList objects,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadObjects(
   MetadataList* objects,
   MetadataLoadingOptions* loadingOptions
)

Parameters

objects
loadingOptions
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


LoadPackages Method (OracleMetadataProvider)

LoadPackages Method (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : LoadPackages Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadPackages( _
   ByVal packages As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OracleMetadataProvider
Dim packages As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadPackages(packages, loadingOptions)
public virtual void LoadPackages(
   MetadataList packages,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadPackages(
   MetadataList* packages,
   MetadataLoadingOptions* loadingOptions
)

Parameters

packages
loadingOptions
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


LoadParams Method (OracleMetadataProvider)

LoadParams Method (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : LoadParams Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadParams( _
   ByVal params As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OracleMetadataProvider
Dim params As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadParams(params, loadingOptions)
public virtual void LoadParams(
   MetadataList params,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadParams(
   MetadataList* params,
   MetadataLoadingOptions* loadingOptions
)

Parameters

params
loadingOptions
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


LoadSchemas Method (OracleMetadataProvider)

LoadSchemas Method (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : LoadSchemas Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadSchemas( _
   ByVal schemas As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OracleMetadataProvider
Dim schemas As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadSchemas(schemas, loadingOptions)
public virtual void LoadSchemas(
   MetadataList schemas,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadSchemas(
   MetadataList* schemas,
   MetadataLoadingOptions* loadingOptions
)

Parameters

schemas
loadingOptions
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


LoadServers Method (OracleMetadataProvider)

LoadServers Method (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : LoadServers Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadServers( _
   ByVal servers As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OracleMetadataProvider
Dim servers As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadServers(servers, loadingOptions)
public virtual void LoadServers(
   MetadataList servers,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadServers(
   MetadataList* servers,
   MetadataLoadingOptions* loadingOptions
)

Parameters

servers
loadingOptions
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


Site Property (OracleMetadataProvider)

Site Property (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As OracleMetadataProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


ToString Method (OracleMetadataProvider)

ToString Method (OracleMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleMetadataProvider Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function ToString() As System.String
'Usage

Dim instance As OracleMetadataProvider
Dim value As System.String

value = instance.ToString()
public virtual System.string ToString()
public: virtual System.string* ToString();
Requirements

See Also

Reference

OracleMetadataProvider Class
OracleMetadataProvider Members


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.OracleMetadataProvider2) Inheritance Hierarchy

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.OracleMetadataProvider2) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleMetadataProvider
See Also

Reference

ActiveDatabaseSoftware.OracleMetadataProvider2 Assembly


OracleNativeMetadataProvider Class Events

OracleNativeMetadataProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : OracleNativeMetadataProvider Class

For a list of all members of this type, see OracleNativeMetadataProvider members.

See Also

Reference

OracleNativeMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
Metadata Provider for Oracle Database through System.Data.OracleClient (Microsoft)


OracleNativeMetadataProvider Class Methods

OracleNativeMetadataProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : OracleNativeMetadataProvider Class

For a list of all members of this type, see OracleNativeMetadataProvider members.

See Also

Reference

OracleNativeMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
Metadata Provider for Oracle Database through System.Data.OracleClient (Microsoft)


AfterConnect Event (OracleNativeMetadataProvider)

AfterConnect Event (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : AfterConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterConnect As System.EventHandler
'Usage

Dim instance As OracleNativeMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterConnect, handler
public event System.EventHandler AfterConnect
public: __event System.EventHandler* AfterConnect
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


AfterDisconnect Event (OracleNativeMetadataProvider)

AfterDisconnect Event (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : AfterDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterDisconnect As System.EventHandler
'Usage

Dim instance As OracleNativeMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterDisconnect, handler
public event System.EventHandler AfterDisconnect
public: __event System.EventHandler* AfterDisconnect
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


BeforeConnect Event (OracleNativeMetadataProvider)

BeforeConnect Event (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : BeforeConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeConnect As System.EventHandler
'Usage

Dim instance As OracleNativeMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeConnect, handler
public event System.EventHandler BeforeConnect
public: __event System.EventHandler* BeforeConnect
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


BeforeDisconnect Event (OracleNativeMetadataProvider)

BeforeDisconnect Event (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : BeforeDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeDisconnect As System.EventHandler
'Usage

Dim instance As OracleNativeMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeDisconnect, handler
public event System.EventHandler BeforeDisconnect
public: __event System.EventHandler* BeforeDisconnect
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


CanExecSQL Property (OracleNativeMetadataProvider)

CanExecSQL Property (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : CanExecSQL Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CanExecSQL As System.Boolean
'Usage

Dim instance As OracleNativeMetadataProvider
Dim value As System.Boolean

value = instance.CanExecSQL
public System.bool CanExecSQL {get;}
public: __property System.bool get_CanExecSQL();
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


Connect Method (OracleNativeMetadataProvider)

Connect Method (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : Connect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Connect()
'Usage

Dim instance As OracleNativeMetadataProvider

instance.Connect()
public void Connect()
public: void Connect();
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


Connected Property (OracleNativeMetadataProvider)

Connected Property (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : Connected Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Connected As System.Boolean
'Usage

Dim instance As OracleNativeMetadataProvider
Dim value As System.Boolean

instance.Connected = value

value = instance.Connected
public System.bool Connected {get; set;}
public: __property System.bool get_Connected();
public: __property void set_Connected(
   System.bool value
);
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


ConnectionObjectsCreated Property (OracleNativeMetadataProvider)

ConnectionObjectsCreated Property (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : ConnectionObjectsCreated Property
Gets or sets the reference to the DB Connection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ConnectionObjectsCreated As System.Boolean
'Usage

Dim instance As OracleNativeMetadataProvider
Dim value As System.Boolean

value = instance.ConnectionObjectsCreated
public System.bool ConnectionObjectsCreated {get;}
public: __property System.bool get_ConnectionObjectsCreated();
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


Container Property (OracleNativeMetadataProvider)

Container Property (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As OracleNativeMetadataProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


CreateObjRef Method (OracleNativeMetadataProvider)

CreateObjRef Method (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As OracleNativeMetadataProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


Description Property (OracleNativeMetadataProvider)

Description Property (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : Description Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Description As System.String
'Usage

Dim instance As OracleNativeMetadataProvider
Dim value As System.String

value = instance.Description
public System.string Description {get;}
public: __property System.string* get_Description();
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


Disconnect Method (OracleNativeMetadataProvider)

Disconnect Method (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : Disconnect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Disconnect()
'Usage

Dim instance As OracleNativeMetadataProvider

instance.Disconnect()
public void Disconnect()
public: void Disconnect();
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


Dispose Method (OracleNativeMetadataProvider)

Dispose Method (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : Dispose Method
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As OracleNativeMetadataProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


Disposed Event (OracleNativeMetadataProvider)

Disposed Event (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As OracleNativeMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


ExecSQL Method (OracleNativeMetadataProvider)

ExecSQL Method (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : ExecSQL Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ExecSQL( _
   ByVal sql As System.String, _
   ByVal schemaOnly As System.Boolean _
) As System.Data.IDataReader
'Usage

Dim instance As OracleNativeMetadataProvider
Dim sql As System.String
Dim schemaOnly As System.Boolean
Dim value As System.Data.IDataReader

value = instance.ExecSQL(sql, schemaOnly)
public System.Data.IDataReader ExecSQL(
   System.string sql,
   System.bool schemaOnly
)
public: System.Data.IDataReader* ExecSQL(
   System.string* sql,
   System.bool schemaOnly
)

Parameters

sql
schemaOnly
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


ExecSQLNoResult Method (OracleNativeMetadataProvider)

ExecSQLNoResult Method (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : ExecSQLNoResult Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ExecSQLNoResult( _
   ByVal sql As System.String _
)
'Usage

Dim instance As OracleNativeMetadataProvider
Dim sql As System.String

instance.ExecSQLNoResult(sql)
public void ExecSQLNoResult(
   System.string sql
)
public: void ExecSQLNoResult(
   System.string* sql
)

Parameters

sql
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


GetLifetimeService Method (OracleNativeMetadataProvider)

GetLifetimeService Method (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As OracleNativeMetadataProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


InitializeLifetimeService Method (OracleNativeMetadataProvider)

InitializeLifetimeService Method (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As OracleNativeMetadataProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


LoadDatabases Method (OracleNativeMetadataProvider)

LoadDatabases Method (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : LoadDatabases Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadDatabases( _
   ByVal databases As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OracleNativeMetadataProvider
Dim databases As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadDatabases(databases, loadingOptions)
public virtual void LoadDatabases(
   MetadataList databases,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadDatabases(
   MetadataList* databases,
   MetadataLoadingOptions* loadingOptions
)

Parameters

databases
loadingOptions
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


LoadFields Method (OracleNativeMetadataProvider)

LoadFields Method (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : LoadFields Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadFields( _
   ByVal fields As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OracleNativeMetadataProvider
Dim fields As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadFields(fields, loadingOptions)
public virtual void LoadFields(
   MetadataList fields,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadFields(
   MetadataList* fields,
   MetadataLoadingOptions* loadingOptions
)

Parameters

fields
loadingOptions
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


LoadForeignKeys Method (OracleNativeMetadataProvider)

LoadForeignKeys Method (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : LoadForeignKeys Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadForeignKeys( _
   ByVal foreignKeys As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OracleNativeMetadataProvider
Dim foreignKeys As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadForeignKeys(foreignKeys, loadingOptions)
public virtual void LoadForeignKeys(
   MetadataList foreignKeys,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadForeignKeys(
   MetadataList* foreignKeys,
   MetadataLoadingOptions* loadingOptions
)

Parameters

foreignKeys
loadingOptions
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


LoadObjects Method (OracleNativeMetadataProvider)

LoadObjects Method (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : LoadObjects Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadObjects( _
   ByVal objects As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OracleNativeMetadataProvider
Dim objects As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadObjects(objects, loadingOptions)
public virtual void LoadObjects(
   MetadataList objects,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadObjects(
   MetadataList* objects,
   MetadataLoadingOptions* loadingOptions
)

Parameters

objects
loadingOptions
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


LoadPackages Method (OracleNativeMetadataProvider)

LoadPackages Method (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : LoadPackages Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadPackages( _
   ByVal packages As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OracleNativeMetadataProvider
Dim packages As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadPackages(packages, loadingOptions)
public virtual void LoadPackages(
   MetadataList packages,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadPackages(
   MetadataList* packages,
   MetadataLoadingOptions* loadingOptions
)

Parameters

packages
loadingOptions
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


LoadParams Method (OracleNativeMetadataProvider)

LoadParams Method (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : LoadParams Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadParams( _
   ByVal params As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OracleNativeMetadataProvider
Dim params As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadParams(params, loadingOptions)
public virtual void LoadParams(
   MetadataList params,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadParams(
   MetadataList* params,
   MetadataLoadingOptions* loadingOptions
)

Parameters

params
loadingOptions
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


LoadSchemas Method (OracleNativeMetadataProvider)

LoadSchemas Method (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : LoadSchemas Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadSchemas( _
   ByVal schemas As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OracleNativeMetadataProvider
Dim schemas As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadSchemas(schemas, loadingOptions)
public virtual void LoadSchemas(
   MetadataList schemas,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadSchemas(
   MetadataList* schemas,
   MetadataLoadingOptions* loadingOptions
)

Parameters

schemas
loadingOptions
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


LoadServers Method (OracleNativeMetadataProvider)

LoadServers Method (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : LoadServers Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadServers( _
   ByVal servers As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As OracleNativeMetadataProvider
Dim servers As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadServers(servers, loadingOptions)
public virtual void LoadServers(
   MetadataList servers,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadServers(
   MetadataList* servers,
   MetadataLoadingOptions* loadingOptions
)

Parameters

servers
loadingOptions
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


Site Property (OracleNativeMetadataProvider)

Site Property (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As OracleNativeMetadataProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


ToString Method (OracleNativeMetadataProvider)

ToString Method (OracleNativeMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > OracleNativeMetadataProvider Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function ToString() As System.String
'Usage

Dim instance As OracleNativeMetadataProvider
Dim value As System.String

value = instance.ToString()
public virtual System.string ToString()
public: virtual System.string* ToString();
Requirements

See Also

Reference

OracleNativeMetadataProvider Class
OracleNativeMetadataProvider Members


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.OracleNativeMetadataProvider2) Inheritance Hierarchy

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.OracleNativeMetadataProvider2) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.OracleNativeMetadataProvider
See Also

Reference

ActiveDatabaseSoftware.OracleNativeMetadataProvider2 Assembly


PostgreSQLMetadataProvider Class Events

PostgreSQLMetadataProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : PostgreSQLMetadataProvider Class

For a list of all members of this type, see PostgreSQLMetadataProvider members.

See Also

Reference

PostgreSQLMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


PostgreSQLMetadataProvider Class Methods

PostgreSQLMetadataProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : PostgreSQLMetadataProvider Class

For a list of all members of this type, see PostgreSQLMetadataProvider members.

See Also

Reference

PostgreSQLMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AfterConnect Event (PostgreSQLMetadataProvider)

AfterConnect Event (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : AfterConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterConnect As System.EventHandler
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterConnect, handler
public event System.EventHandler AfterConnect
public: __event System.EventHandler* AfterConnect
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


AfterDisconnect Event (PostgreSQLMetadataProvider)

AfterDisconnect Event (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : AfterDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterDisconnect As System.EventHandler
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterDisconnect, handler
public event System.EventHandler AfterDisconnect
public: __event System.EventHandler* AfterDisconnect
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


BeforeConnect Event (PostgreSQLMetadataProvider)

BeforeConnect Event (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : BeforeConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeConnect As System.EventHandler
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeConnect, handler
public event System.EventHandler BeforeConnect
public: __event System.EventHandler* BeforeConnect
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


BeforeDisconnect Event (PostgreSQLMetadataProvider)

BeforeDisconnect Event (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : BeforeDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeDisconnect As System.EventHandler
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeDisconnect, handler
public event System.EventHandler BeforeDisconnect
public: __event System.EventHandler* BeforeDisconnect
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


CanExecSQL Property (PostgreSQLMetadataProvider)

CanExecSQL Property (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : CanExecSQL Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CanExecSQL As System.Boolean
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim value As System.Boolean

value = instance.CanExecSQL
public System.bool CanExecSQL {get;}
public: __property System.bool get_CanExecSQL();
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


Connect Method (PostgreSQLMetadataProvider)

Connect Method (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : Connect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Connect()
'Usage

Dim instance As PostgreSQLMetadataProvider

instance.Connect()
public void Connect()
public: void Connect();
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


Connected Property (PostgreSQLMetadataProvider)

Connected Property (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : Connected Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Connected As System.Boolean
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim value As System.Boolean

instance.Connected = value

value = instance.Connected
public System.bool Connected {get; set;}
public: __property System.bool get_Connected();
public: __property void set_Connected(
   System.bool value
);
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


ConnectionObjectsCreated Property (PostgreSQLMetadataProvider)

ConnectionObjectsCreated Property (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : ConnectionObjectsCreated Property
Gets or sets the reference to the DB Connection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ConnectionObjectsCreated As System.Boolean
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim value As System.Boolean

value = instance.ConnectionObjectsCreated
public System.bool ConnectionObjectsCreated {get;}
public: __property System.bool get_ConnectionObjectsCreated();
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


Container Property (PostgreSQLMetadataProvider)

Container Property (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


CreateObjRef Method (PostgreSQLMetadataProvider)

CreateObjRef Method (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


Description Property (PostgreSQLMetadataProvider)

Description Property (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : Description Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Description As System.String
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim value As System.String

value = instance.Description
public System.string Description {get;}
public: __property System.string* get_Description();
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


Disconnect Method (PostgreSQLMetadataProvider)

Disconnect Method (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : Disconnect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Disconnect()
'Usage

Dim instance As PostgreSQLMetadataProvider

instance.Disconnect()
public void Disconnect()
public: void Disconnect();
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


Dispose Method (PostgreSQLMetadataProvider)

Dispose Method (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : Dispose Method
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members
Base Implementation in Dispose


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As PostgreSQLMetadataProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


Disposed Event (PostgreSQLMetadataProvider)

Disposed Event (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


ExecSQL Method (PostgreSQLMetadataProvider)

ExecSQL Method (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : ExecSQL Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ExecSQL( _
   ByVal sql As System.String, _
   ByVal schemaOnly As System.Boolean _
) As System.Data.IDataReader
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim sql As System.String
Dim schemaOnly As System.Boolean
Dim value As System.Data.IDataReader

value = instance.ExecSQL(sql, schemaOnly)
public System.Data.IDataReader ExecSQL(
   System.string sql,
   System.bool schemaOnly
)
public: System.Data.IDataReader* ExecSQL(
   System.string* sql,
   System.bool schemaOnly
)

Parameters

sql
schemaOnly
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


ExecSQLNoResult Method (PostgreSQLMetadataProvider)

ExecSQLNoResult Method (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : ExecSQLNoResult Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ExecSQLNoResult( _
   ByVal sql As System.String _
)
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim sql As System.String

instance.ExecSQLNoResult(sql)
public void ExecSQLNoResult(
   System.string sql
)
public: void ExecSQLNoResult(
   System.string* sql
)

Parameters

sql
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


GetLifetimeService Method (PostgreSQLMetadataProvider)

GetLifetimeService Method (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


InitializeLifetimeService Method (PostgreSQLMetadataProvider)

InitializeLifetimeService Method (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


LoadFields Method (PostgreSQLMetadataProvider)

LoadFields Method (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : LoadFields Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadFields( _
   ByVal fields As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim fields As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadFields(fields, loadingOptions)
public virtual void LoadFields(
   MetadataList fields,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadFields(
   MetadataList* fields,
   MetadataLoadingOptions* loadingOptions
)

Parameters

fields
loadingOptions
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


LoadForeignKeys Method (PostgreSQLMetadataProvider)

LoadForeignKeys Method (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : LoadForeignKeys Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadForeignKeys( _
   ByVal foreignKeys As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim foreignKeys As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadForeignKeys(foreignKeys, loadingOptions)
public virtual void LoadForeignKeys(
   MetadataList foreignKeys,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadForeignKeys(
   MetadataList* foreignKeys,
   MetadataLoadingOptions* loadingOptions
)

Parameters

foreignKeys
loadingOptions
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


LoadObjects Method (PostgreSQLMetadataProvider)

LoadObjects Method (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : LoadObjects Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadObjects( _
   ByVal objects As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim objects As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadObjects(objects, loadingOptions)
public virtual void LoadObjects(
   MetadataList objects,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadObjects(
   MetadataList* objects,
   MetadataLoadingOptions* loadingOptions
)

Parameters

objects
loadingOptions
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


LoadPackages Method (PostgreSQLMetadataProvider)

LoadPackages Method (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : LoadPackages Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadPackages( _
   ByVal packages As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim packages As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadPackages(packages, loadingOptions)
public virtual void LoadPackages(
   MetadataList packages,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadPackages(
   MetadataList* packages,
   MetadataLoadingOptions* loadingOptions
)

Parameters

packages
loadingOptions
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


LoadParams Method (PostgreSQLMetadataProvider)

LoadParams Method (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : LoadParams Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadParams( _
   ByVal params As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim params As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadParams(params, loadingOptions)
public virtual void LoadParams(
   MetadataList params,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadParams(
   MetadataList* params,
   MetadataLoadingOptions* loadingOptions
)

Parameters

params
loadingOptions
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


LoadSchemas Method (PostgreSQLMetadataProvider)

LoadSchemas Method (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : LoadSchemas Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadSchemas( _
   ByVal schemas As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim schemas As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadSchemas(schemas, loadingOptions)
public virtual void LoadSchemas(
   MetadataList schemas,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadSchemas(
   MetadataList* schemas,
   MetadataLoadingOptions* loadingOptions
)

Parameters

schemas
loadingOptions
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


LoadServers Method (PostgreSQLMetadataProvider)

LoadServers Method (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : LoadServers Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadServers( _
   ByVal servers As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim servers As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadServers(servers, loadingOptions)
public virtual void LoadServers(
   MetadataList servers,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadServers(
   MetadataList* servers,
   MetadataLoadingOptions* loadingOptions
)

Parameters

servers
loadingOptions
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


Site Property (PostgreSQLMetadataProvider)

Site Property (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


ToString Method (PostgreSQLMetadataProvider)

ToString Method (PostgreSQLMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > PostgreSQLMetadataProvider Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function ToString() As System.String
'Usage

Dim instance As PostgreSQLMetadataProvider
Dim value As System.String

value = instance.ToString()
public virtual System.string ToString()
public: virtual System.string* ToString();
Requirements

See Also

Reference

PostgreSQLMetadataProvider Class
PostgreSQLMetadataProvider Members


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.PostgreSQLMetadataProvider2) Inheritance Hierarchy

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.PostgreSQLMetadataProvider2) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.PostgreSQLMetadataProvider
See Also

Reference

ActiveDatabaseSoftware.PostgreSQLMetadataProvider2 Assembly


SybaseMetadataProvider Class Events

SybaseMetadataProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SybaseMetadataProvider Class

For a list of all members of this type, see SybaseMetadataProvider members.

See Also

Reference

SybaseMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


SybaseMetadataProvider Class Methods

SybaseMetadataProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : SybaseMetadataProvider Class

For a list of all members of this type, see SybaseMetadataProvider members.

See Also

Reference

SybaseMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AfterConnect Event (SybaseMetadataProvider)

AfterConnect Event (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : AfterConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterConnect As System.EventHandler
'Usage

Dim instance As SybaseMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterConnect, handler
public event System.EventHandler AfterConnect
public: __event System.EventHandler* AfterConnect
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


AfterDisconnect Event (SybaseMetadataProvider)

AfterDisconnect Event (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : AfterDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterDisconnect As System.EventHandler
'Usage

Dim instance As SybaseMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterDisconnect, handler
public event System.EventHandler AfterDisconnect
public: __event System.EventHandler* AfterDisconnect
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


BeforeConnect Event (SybaseMetadataProvider)

BeforeConnect Event (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : BeforeConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeConnect As System.EventHandler
'Usage

Dim instance As SybaseMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeConnect, handler
public event System.EventHandler BeforeConnect
public: __event System.EventHandler* BeforeConnect
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


BeforeDisconnect Event (SybaseMetadataProvider)

BeforeDisconnect Event (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : BeforeDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeDisconnect As System.EventHandler
'Usage

Dim instance As SybaseMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeDisconnect, handler
public event System.EventHandler BeforeDisconnect
public: __event System.EventHandler* BeforeDisconnect
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


CanExecSQL Property (SybaseMetadataProvider)

CanExecSQL Property (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : CanExecSQL Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CanExecSQL As System.Boolean
'Usage

Dim instance As SybaseMetadataProvider
Dim value As System.Boolean

value = instance.CanExecSQL
public System.bool CanExecSQL {get;}
public: __property System.bool get_CanExecSQL();
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


Connect Method (SybaseMetadataProvider)

Connect Method (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : Connect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Connect()
'Usage

Dim instance As SybaseMetadataProvider

instance.Connect()
public void Connect()
public: void Connect();
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


Connected Property (SybaseMetadataProvider)

Connected Property (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : Connected Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Connected As System.Boolean
'Usage

Dim instance As SybaseMetadataProvider
Dim value As System.Boolean

instance.Connected = value

value = instance.Connected
public System.bool Connected {get; set;}
public: __property System.bool get_Connected();
public: __property void set_Connected(
   System.bool value
);
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


ConnectionObjectsCreated Property (SybaseMetadataProvider)

ConnectionObjectsCreated Property (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : ConnectionObjectsCreated Property
Gets or sets the reference to the DB Connection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ConnectionObjectsCreated As System.Boolean
'Usage

Dim instance As SybaseMetadataProvider
Dim value As System.Boolean

value = instance.ConnectionObjectsCreated
public System.bool ConnectionObjectsCreated {get;}
public: __property System.bool get_ConnectionObjectsCreated();
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


Container Property (SybaseMetadataProvider)

Container Property (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As SybaseMetadataProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


CreateObjRef Method (SybaseMetadataProvider)

CreateObjRef Method (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As SybaseMetadataProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


Description Property (SybaseMetadataProvider)

Description Property (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : Description Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Description As System.String
'Usage

Dim instance As SybaseMetadataProvider
Dim value As System.String

value = instance.Description
public System.string Description {get;}
public: __property System.string* get_Description();
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


Disconnect Method (SybaseMetadataProvider)

Disconnect Method (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : Disconnect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Disconnect()
'Usage

Dim instance As SybaseMetadataProvider

instance.Disconnect()
public void Disconnect()
public: void Disconnect();
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


Dispose Method (SybaseMetadataProvider)

Dispose Method (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : Dispose Method
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members
Base Implementation in Dispose


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As SybaseMetadataProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


Disposed Event (SybaseMetadataProvider)

Disposed Event (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As SybaseMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


ExecSQL Method (SybaseMetadataProvider)

ExecSQL Method (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : ExecSQL Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ExecSQL( _
   ByVal sql As System.String, _
   ByVal schemaOnly As System.Boolean _
) As System.Data.IDataReader
'Usage

Dim instance As SybaseMetadataProvider
Dim sql As System.String
Dim schemaOnly As System.Boolean
Dim value As System.Data.IDataReader

value = instance.ExecSQL(sql, schemaOnly)
public System.Data.IDataReader ExecSQL(
   System.string sql,
   System.bool schemaOnly
)
public: System.Data.IDataReader* ExecSQL(
   System.string* sql,
   System.bool schemaOnly
)

Parameters

sql
schemaOnly
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


ExecSQLNoResult Method (SybaseMetadataProvider)

ExecSQLNoResult Method (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : ExecSQLNoResult Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ExecSQLNoResult( _
   ByVal sql As System.String _
)
'Usage

Dim instance As SybaseMetadataProvider
Dim sql As System.String

instance.ExecSQLNoResult(sql)
public void ExecSQLNoResult(
   System.string sql
)
public: void ExecSQLNoResult(
   System.string* sql
)

Parameters

sql
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


GetLifetimeService Method (SybaseMetadataProvider)

GetLifetimeService Method (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As SybaseMetadataProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


GetMetadataProviderDescription Method (SybaseMetadataProvider)

GetMetadataProviderDescription Method (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : GetMetadataProviderDescription Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function GetMetadataProviderDescription() As System.String
'Usage

Dim instance As SybaseMetadataProvider
Dim value As System.String

value = instance.GetMetadataProviderDescription()
public virtual System.string GetMetadataProviderDescription()
public: virtual System.string* GetMetadataProviderDescription();
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


InitializeLifetimeService Method (SybaseMetadataProvider)

InitializeLifetimeService Method (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As SybaseMetadataProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


LoadDatabases Method (SybaseMetadataProvider)

LoadDatabases Method (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : LoadDatabases Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadDatabases( _
   ByVal databases As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As SybaseMetadataProvider
Dim databases As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadDatabases(databases, loadingOptions)
public virtual void LoadDatabases(
   MetadataList databases,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadDatabases(
   MetadataList* databases,
   MetadataLoadingOptions* loadingOptions
)

Parameters

databases
loadingOptions
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


LoadFields Method (SybaseMetadataProvider)

LoadFields Method (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : LoadFields Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadFields( _
   ByVal fields As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As SybaseMetadataProvider
Dim fields As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadFields(fields, loadingOptions)
public virtual void LoadFields(
   MetadataList fields,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadFields(
   MetadataList* fields,
   MetadataLoadingOptions* loadingOptions
)

Parameters

fields
loadingOptions
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


LoadForeignKeys Method (SybaseMetadataProvider)

LoadForeignKeys Method (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : LoadForeignKeys Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadForeignKeys( _
   ByVal foreignKeys As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As SybaseMetadataProvider
Dim foreignKeys As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadForeignKeys(foreignKeys, loadingOptions)
public virtual void LoadForeignKeys(
   MetadataList foreignKeys,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadForeignKeys(
   MetadataList* foreignKeys,
   MetadataLoadingOptions* loadingOptions
)

Parameters

foreignKeys
loadingOptions
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


LoadObjects Method (SybaseMetadataProvider)

LoadObjects Method (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : LoadObjects Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadObjects( _
   ByVal objects As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As SybaseMetadataProvider
Dim objects As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadObjects(objects, loadingOptions)
public virtual void LoadObjects(
   MetadataList objects,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadObjects(
   MetadataList* objects,
   MetadataLoadingOptions* loadingOptions
)

Parameters

objects
loadingOptions
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


LoadPackages Method (SybaseMetadataProvider)

LoadPackages Method (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : LoadPackages Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadPackages( _
   ByVal packages As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As SybaseMetadataProvider
Dim packages As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadPackages(packages, loadingOptions)
public virtual void LoadPackages(
   MetadataList packages,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadPackages(
   MetadataList* packages,
   MetadataLoadingOptions* loadingOptions
)

Parameters

packages
loadingOptions
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


LoadParams Method (SybaseMetadataProvider)

LoadParams Method (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : LoadParams Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadParams( _
   ByVal params As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As SybaseMetadataProvider
Dim params As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadParams(params, loadingOptions)
public virtual void LoadParams(
   MetadataList params,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadParams(
   MetadataList* params,
   MetadataLoadingOptions* loadingOptions
)

Parameters

params
loadingOptions
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


LoadSchemas Method (SybaseMetadataProvider)

LoadSchemas Method (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : LoadSchemas Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadSchemas( _
   ByVal schemas As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As SybaseMetadataProvider
Dim schemas As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadSchemas(schemas, loadingOptions)
public virtual void LoadSchemas(
   MetadataList schemas,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadSchemas(
   MetadataList* schemas,
   MetadataLoadingOptions* loadingOptions
)

Parameters

schemas
loadingOptions
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


LoadServers Method (SybaseMetadataProvider)

LoadServers Method (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : LoadServers Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadServers( _
   ByVal servers As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As SybaseMetadataProvider
Dim servers As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadServers(servers, loadingOptions)
public virtual void LoadServers(
   MetadataList servers,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadServers(
   MetadataList* servers,
   MetadataLoadingOptions* loadingOptions
)

Parameters

servers
loadingOptions
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


Site Property (SybaseMetadataProvider)

Site Property (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As SybaseMetadataProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


ToString Method (SybaseMetadataProvider)

ToString Method (SybaseMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > SybaseMetadataProvider Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function ToString() As System.String
'Usage

Dim instance As SybaseMetadataProvider
Dim value As System.String

value = instance.ToString()
public virtual System.string ToString()
public: virtual System.string* ToString();
Requirements

See Also

Reference

SybaseMetadataProvider Class
SybaseMetadataProvider Members


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.SybaseMetadataProvider2) Inheritance Hierarchy

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.SybaseMetadataProvider2) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.SybaseMetadataProvider
See Also

Reference

ActiveDatabaseSoftware.SybaseMetadataProvider2 Assembly


UniversalMetadataProvider Class Events

UniversalMetadataProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : UniversalMetadataProvider Class

For a list of all members of this type, see UniversalMetadataProvider members.

See Also

Reference

UniversalMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


UniversalMetadataProvider Class Methods

UniversalMetadataProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : UniversalMetadataProvider Class

For a list of all members of this type, see UniversalMetadataProvider members.

See Also

Reference

UniversalMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AfterConnect Event (UniversalMetadataProvider)

AfterConnect Event (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : AfterConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterConnect As System.EventHandler
'Usage

Dim instance As UniversalMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterConnect, handler
public event System.EventHandler AfterConnect
public: __event System.EventHandler* AfterConnect
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


AfterDisconnect Event (UniversalMetadataProvider)

AfterDisconnect Event (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : AfterDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterDisconnect As System.EventHandler
'Usage

Dim instance As UniversalMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterDisconnect, handler
public event System.EventHandler AfterDisconnect
public: __event System.EventHandler* AfterDisconnect
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


BeforeConnect Event (UniversalMetadataProvider)

BeforeConnect Event (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : BeforeConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeConnect As System.EventHandler
'Usage

Dim instance As UniversalMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeConnect, handler
public event System.EventHandler BeforeConnect
public: __event System.EventHandler* BeforeConnect
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


BeforeDisconnect Event (UniversalMetadataProvider)

BeforeDisconnect Event (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : BeforeDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeDisconnect As System.EventHandler
'Usage

Dim instance As UniversalMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeDisconnect, handler
public event System.EventHandler BeforeDisconnect
public: __event System.EventHandler* BeforeDisconnect
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


CanExecSQL Property (UniversalMetadataProvider)

CanExecSQL Property (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : CanExecSQL Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CanExecSQL As System.Boolean
'Usage

Dim instance As UniversalMetadataProvider
Dim value As System.Boolean

value = instance.CanExecSQL
public System.bool CanExecSQL {get;}
public: __property System.bool get_CanExecSQL();
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


Connect Method (UniversalMetadataProvider)

Connect Method (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : Connect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Connect()
'Usage

Dim instance As UniversalMetadataProvider

instance.Connect()
public void Connect()
public: void Connect();
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


Connected Property (UniversalMetadataProvider)

Connected Property (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : Connected Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Connected As System.Boolean
'Usage

Dim instance As UniversalMetadataProvider
Dim value As System.Boolean

instance.Connected = value

value = instance.Connected
public System.bool Connected {get; set;}
public: __property System.bool get_Connected();
public: __property void set_Connected(
   System.bool value
);
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


ConnectionObjectsCreated Property (UniversalMetadataProvider)

ConnectionObjectsCreated Property (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : ConnectionObjectsCreated Property
Gets or sets the reference to the DB Connection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ConnectionObjectsCreated As System.Boolean
'Usage

Dim instance As UniversalMetadataProvider
Dim value As System.Boolean

value = instance.ConnectionObjectsCreated
public System.bool ConnectionObjectsCreated {get;}
public: __property System.bool get_ConnectionObjectsCreated();
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


Container Property (UniversalMetadataProvider)

Container Property (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As UniversalMetadataProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


CreateObjRef Method (UniversalMetadataProvider)

CreateObjRef Method (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As UniversalMetadataProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


Description Property (UniversalMetadataProvider)

Description Property (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : Description Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Description As System.String
'Usage

Dim instance As UniversalMetadataProvider
Dim value As System.String

value = instance.Description
public System.string Description {get;}
public: __property System.string* get_Description();
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


Disconnect Method (UniversalMetadataProvider)

Disconnect Method (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : Disconnect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Disconnect()
'Usage

Dim instance As UniversalMetadataProvider

instance.Disconnect()
public void Disconnect()
public: void Disconnect();
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


Dispose Method (UniversalMetadataProvider)

Dispose Method (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : Dispose Method
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As UniversalMetadataProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


Disposed Event (UniversalMetadataProvider)

Disposed Event (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As UniversalMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


ExecSQL Method (UniversalMetadataProvider)

ExecSQL Method (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : ExecSQL Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ExecSQL( _
   ByVal sql As System.String, _
   ByVal schemaOnly As System.Boolean _
) As System.Data.IDataReader
'Usage

Dim instance As UniversalMetadataProvider
Dim sql As System.String
Dim schemaOnly As System.Boolean
Dim value As System.Data.IDataReader

value = instance.ExecSQL(sql, schemaOnly)
public System.Data.IDataReader ExecSQL(
   System.string sql,
   System.bool schemaOnly
)
public: System.Data.IDataReader* ExecSQL(
   System.string* sql,
   System.bool schemaOnly
)

Parameters

sql
schemaOnly
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


ExecSQLNoResult Method (UniversalMetadataProvider)

ExecSQLNoResult Method (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : ExecSQLNoResult Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ExecSQLNoResult( _
   ByVal sql As System.String _
)
'Usage

Dim instance As UniversalMetadataProvider
Dim sql As System.String

instance.ExecSQLNoResult(sql)
public void ExecSQLNoResult(
   System.string sql
)
public: void ExecSQLNoResult(
   System.string* sql
)

Parameters

sql
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


GetLifetimeService Method (UniversalMetadataProvider)

GetLifetimeService Method (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As UniversalMetadataProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


InitializeLifetimeService Method (UniversalMetadataProvider)

InitializeLifetimeService Method (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As UniversalMetadataProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


LoadDatabases Method (UniversalMetadataProvider)

LoadDatabases Method (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : LoadDatabases Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadDatabases( _
   ByVal databases As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As UniversalMetadataProvider
Dim databases As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadDatabases(databases, loadingOptions)
public virtual void LoadDatabases(
   MetadataList databases,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadDatabases(
   MetadataList* databases,
   MetadataLoadingOptions* loadingOptions
)

Parameters

databases
loadingOptions
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


LoadFields Method (UniversalMetadataProvider)

LoadFields Method (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : LoadFields Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadFields( _
   ByVal fields As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As UniversalMetadataProvider
Dim fields As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadFields(fields, loadingOptions)
public virtual void LoadFields(
   MetadataList fields,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadFields(
   MetadataList* fields,
   MetadataLoadingOptions* loadingOptions
)

Parameters

fields
loadingOptions
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


LoadForeignKeys Method (UniversalMetadataProvider)

LoadForeignKeys Method (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : LoadForeignKeys Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadForeignKeys( _
   ByVal foreignKeys As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As UniversalMetadataProvider
Dim foreignKeys As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadForeignKeys(foreignKeys, loadingOptions)
public virtual void LoadForeignKeys(
   MetadataList foreignKeys,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadForeignKeys(
   MetadataList* foreignKeys,
   MetadataLoadingOptions* loadingOptions
)

Parameters

foreignKeys
loadingOptions
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


LoadObjects Method (UniversalMetadataProvider)

LoadObjects Method (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : LoadObjects Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadObjects( _
   ByVal objects As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As UniversalMetadataProvider
Dim objects As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadObjects(objects, loadingOptions)
public virtual void LoadObjects(
   MetadataList objects,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadObjects(
   MetadataList* objects,
   MetadataLoadingOptions* loadingOptions
)

Parameters

objects
loadingOptions
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


LoadPackages Method (UniversalMetadataProvider)

LoadPackages Method (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : LoadPackages Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadPackages( _
   ByVal packages As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As UniversalMetadataProvider
Dim packages As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadPackages(packages, loadingOptions)
public virtual void LoadPackages(
   MetadataList packages,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadPackages(
   MetadataList* packages,
   MetadataLoadingOptions* loadingOptions
)

Parameters

packages
loadingOptions
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


LoadParams Method (UniversalMetadataProvider)

LoadParams Method (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : LoadParams Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadParams( _
   ByVal params As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As UniversalMetadataProvider
Dim params As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadParams(params, loadingOptions)
public virtual void LoadParams(
   MetadataList params,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadParams(
   MetadataList* params,
   MetadataLoadingOptions* loadingOptions
)

Parameters

params
loadingOptions
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


LoadSchemas Method (UniversalMetadataProvider)

LoadSchemas Method (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : LoadSchemas Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadSchemas( _
   ByVal schemas As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As UniversalMetadataProvider
Dim schemas As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadSchemas(schemas, loadingOptions)
public virtual void LoadSchemas(
   MetadataList schemas,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadSchemas(
   MetadataList* schemas,
   MetadataLoadingOptions* loadingOptions
)

Parameters

schemas
loadingOptions
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


LoadServers Method (UniversalMetadataProvider)

LoadServers Method (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : LoadServers Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadServers( _
   ByVal servers As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As UniversalMetadataProvider
Dim servers As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadServers(servers, loadingOptions)
public virtual void LoadServers(
   MetadataList servers,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadServers(
   MetadataList* servers,
   MetadataLoadingOptions* loadingOptions
)

Parameters

servers
loadingOptions
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


Site Property (UniversalMetadataProvider)

Site Property (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As UniversalMetadataProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


ToString Method (UniversalMetadataProvider)

ToString Method (UniversalMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > UniversalMetadataProvider Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function ToString() As System.String
'Usage

Dim instance As UniversalMetadataProvider
Dim value As System.String

value = instance.ToString()
public virtual System.string ToString()
public: virtual System.string* ToString();
Requirements

See Also

Reference

UniversalMetadataProvider Class
UniversalMetadataProvider Members


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.UniversalMetadataProvider2) Inheritance Hierarchy

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.UniversalMetadataProvider2) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.UniversalMetadataProvider
See Also

Reference

ActiveDatabaseSoftware.UniversalMetadataProvider2 Assembly


VistaDB4MetadataProvider Class Events

VistaDB4MetadataProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : VistaDB4MetadataProvider Class

For a list of all members of this type, see VistaDB4MetadataProvider members.

See Also

Reference

VistaDB4MetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


VistaDB4MetadataProvider Class Methods

VistaDB4MetadataProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : VistaDB4MetadataProvider Class

For a list of all members of this type, see VistaDB4MetadataProvider members.

See Also

Reference

VistaDB4MetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace


AfterConnect Event (VistaDB4MetadataProvider)

AfterConnect Event (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : AfterConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterConnect As System.EventHandler
'Usage

Dim instance As VistaDB4MetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterConnect, handler
public event System.EventHandler AfterConnect
public: __event System.EventHandler* AfterConnect
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


AfterDisconnect Event (VistaDB4MetadataProvider)

AfterDisconnect Event (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : AfterDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterDisconnect As System.EventHandler
'Usage

Dim instance As VistaDB4MetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterDisconnect, handler
public event System.EventHandler AfterDisconnect
public: __event System.EventHandler* AfterDisconnect
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


BeforeConnect Event (VistaDB4MetadataProvider)

BeforeConnect Event (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : BeforeConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeConnect As System.EventHandler
'Usage

Dim instance As VistaDB4MetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeConnect, handler
public event System.EventHandler BeforeConnect
public: __event System.EventHandler* BeforeConnect
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


BeforeDisconnect Event (VistaDB4MetadataProvider)

BeforeDisconnect Event (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : BeforeDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeDisconnect As System.EventHandler
'Usage

Dim instance As VistaDB4MetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeDisconnect, handler
public event System.EventHandler BeforeDisconnect
public: __event System.EventHandler* BeforeDisconnect
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


CanExecSQL Property (VistaDB4MetadataProvider)

CanExecSQL Property (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : CanExecSQL Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CanExecSQL As System.Boolean
'Usage

Dim instance As VistaDB4MetadataProvider
Dim value As System.Boolean

value = instance.CanExecSQL
public System.bool CanExecSQL {get;}
public: __property System.bool get_CanExecSQL();
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


Connect Method (VistaDB4MetadataProvider)

Connect Method (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : Connect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Connect()
'Usage

Dim instance As VistaDB4MetadataProvider

instance.Connect()
public void Connect()
public: void Connect();
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


Connected Property (VistaDB4MetadataProvider)

Connected Property (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : Connected Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Connected As System.Boolean
'Usage

Dim instance As VistaDB4MetadataProvider
Dim value As System.Boolean

instance.Connected = value

value = instance.Connected
public System.bool Connected {get; set;}
public: __property System.bool get_Connected();
public: __property void set_Connected(
   System.bool value
);
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


ConnectionObjectsCreated Property (VistaDB4MetadataProvider)

ConnectionObjectsCreated Property (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : ConnectionObjectsCreated Property
Gets or sets the reference to the DB Connection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ConnectionObjectsCreated As System.Boolean
'Usage

Dim instance As VistaDB4MetadataProvider
Dim value As System.Boolean

value = instance.ConnectionObjectsCreated
public System.bool ConnectionObjectsCreated {get;}
public: __property System.bool get_ConnectionObjectsCreated();
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


Container Property (VistaDB4MetadataProvider)

Container Property (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As VistaDB4MetadataProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


CreateObjRef Method (VistaDB4MetadataProvider)

CreateObjRef Method (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As VistaDB4MetadataProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


Description Property (VistaDB4MetadataProvider)

Description Property (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : Description Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Description As System.String
'Usage

Dim instance As VistaDB4MetadataProvider
Dim value As System.String

value = instance.Description
public System.string Description {get;}
public: __property System.string* get_Description();
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


Disconnect Method (VistaDB4MetadataProvider)

Disconnect Method (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : Disconnect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Disconnect()
'Usage

Dim instance As VistaDB4MetadataProvider

instance.Disconnect()
public void Disconnect()
public: void Disconnect();
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


Dispose Method (VistaDB4MetadataProvider)

Dispose Method (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : Dispose Method
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As VistaDB4MetadataProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


Disposed Event (VistaDB4MetadataProvider)

Disposed Event (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As VistaDB4MetadataProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


ExecSQL Method (VistaDB4MetadataProvider)

ExecSQL Method (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : ExecSQL Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ExecSQL( _
   ByVal sql As System.String, _
   ByVal schemaOnly As System.Boolean _
) As System.Data.IDataReader
'Usage

Dim instance As VistaDB4MetadataProvider
Dim sql As System.String
Dim schemaOnly As System.Boolean
Dim value As System.Data.IDataReader

value = instance.ExecSQL(sql, schemaOnly)
public System.Data.IDataReader ExecSQL(
   System.string sql,
   System.bool schemaOnly
)
public: System.Data.IDataReader* ExecSQL(
   System.string* sql,
   System.bool schemaOnly
)

Parameters

sql
schemaOnly
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


ExecSQLNoResult Method (VistaDB4MetadataProvider)

ExecSQLNoResult Method (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : ExecSQLNoResult Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ExecSQLNoResult( _
   ByVal sql As System.String _
)
'Usage

Dim instance As VistaDB4MetadataProvider
Dim sql As System.String

instance.ExecSQLNoResult(sql)
public void ExecSQLNoResult(
   System.string sql
)
public: void ExecSQLNoResult(
   System.string* sql
)

Parameters

sql
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


GetLifetimeService Method (VistaDB4MetadataProvider)

GetLifetimeService Method (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As VistaDB4MetadataProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


InitializeLifetimeService Method (VistaDB4MetadataProvider)

InitializeLifetimeService Method (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As VistaDB4MetadataProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


LoadDatabases Method (VistaDB4MetadataProvider)

LoadDatabases Method (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : LoadDatabases Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadDatabases( _
   ByVal databases As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As VistaDB4MetadataProvider
Dim databases As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadDatabases(databases, loadingOptions)
public virtual void LoadDatabases(
   MetadataList databases,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadDatabases(
   MetadataList* databases,
   MetadataLoadingOptions* loadingOptions
)

Parameters

databases
loadingOptions
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


LoadFields Method (VistaDB4MetadataProvider)

LoadFields Method (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : LoadFields Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadFields( _
   ByVal fields As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As VistaDB4MetadataProvider
Dim fields As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadFields(fields, loadingOptions)
public virtual void LoadFields(
   MetadataList fields,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadFields(
   MetadataList* fields,
   MetadataLoadingOptions* loadingOptions
)

Parameters

fields
loadingOptions
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


LoadPackages Method (VistaDB4MetadataProvider)

LoadPackages Method (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : LoadPackages Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadPackages( _
   ByVal packages As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As VistaDB4MetadataProvider
Dim packages As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadPackages(packages, loadingOptions)
public virtual void LoadPackages(
   MetadataList packages,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadPackages(
   MetadataList* packages,
   MetadataLoadingOptions* loadingOptions
)

Parameters

packages
loadingOptions
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


LoadParams Method (VistaDB4MetadataProvider)

LoadParams Method (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : LoadParams Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadParams( _
   ByVal params As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As VistaDB4MetadataProvider
Dim params As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadParams(params, loadingOptions)
public virtual void LoadParams(
   MetadataList params,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadParams(
   MetadataList* params,
   MetadataLoadingOptions* loadingOptions
)

Parameters

params
loadingOptions
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


LoadSchemas Method (VistaDB4MetadataProvider)

LoadSchemas Method (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : LoadSchemas Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadSchemas( _
   ByVal schemas As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As VistaDB4MetadataProvider
Dim schemas As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadSchemas(schemas, loadingOptions)
public virtual void LoadSchemas(
   MetadataList schemas,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadSchemas(
   MetadataList* schemas,
   MetadataLoadingOptions* loadingOptions
)

Parameters

schemas
loadingOptions
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


LoadServers Method (VistaDB4MetadataProvider)

LoadServers Method (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : LoadServers Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadServers( _
   ByVal servers As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As VistaDB4MetadataProvider
Dim servers As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadServers(servers, loadingOptions)
public virtual void LoadServers(
   MetadataList servers,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadServers(
   MetadataList* servers,
   MetadataLoadingOptions* loadingOptions
)

Parameters

servers
loadingOptions
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


Site Property (VistaDB4MetadataProvider)

Site Property (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As VistaDB4MetadataProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


ToString Method (VistaDB4MetadataProvider)

ToString Method (VistaDB4MetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDB4MetadataProvider Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function ToString() As System.String
'Usage

Dim instance As VistaDB4MetadataProvider
Dim value As System.String

value = instance.ToString()
public virtual System.string ToString()
public: virtual System.string* ToString();
Requirements

See Also

Reference

VistaDB4MetadataProvider Class
VistaDB4MetadataProvider Members


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.VistaDB4MetadataProvider2) Inheritance Hierarchy

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.VistaDB4MetadataProvider2) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.VistaDB4MetadataProvider
See Also

Reference

ActiveDatabaseSoftware.VistaDB4MetadataProvider2 Assembly


VistaDBMetadataProvider Class Events

VistaDBMetadataProvider Class Events

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : VistaDBMetadataProvider Class

For a list of all members of this type, see VistaDBMetadataProvider members.

See Also

Reference

VistaDBMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
VistaDB 4 Metadata Provider


VistaDBMetadataProvider Class Methods

VistaDBMetadataProvider Class Methods

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace : VistaDBMetadataProvider Class

For a list of all members of this type, see VistaDBMetadataProvider members.

See Also

Reference

VistaDBMetadataProvider Class
ActiveDatabaseSoftware.ActiveQueryBuilder Namespace
VistaDB 4 Metadata Provider


AfterConnect Event (VistaDBMetadataProvider)

AfterConnect Event (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : AfterConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterConnect As System.EventHandler
'Usage

Dim instance As VistaDBMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterConnect, handler
public event System.EventHandler AfterConnect
public: __event System.EventHandler* AfterConnect
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


AfterDisconnect Event (VistaDBMetadataProvider)

AfterDisconnect Event (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : AfterDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event AfterDisconnect As System.EventHandler
'Usage

Dim instance As VistaDBMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.AfterDisconnect, handler
public event System.EventHandler AfterDisconnect
public: __event System.EventHandler* AfterDisconnect
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


BeforeConnect Event (VistaDBMetadataProvider)

BeforeConnect Event (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : BeforeConnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeConnect As System.EventHandler
'Usage

Dim instance As VistaDBMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeConnect, handler
public event System.EventHandler BeforeConnect
public: __event System.EventHandler* BeforeConnect
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


BeforeDisconnect Event (VistaDBMetadataProvider)

BeforeDisconnect Event (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : BeforeDisconnect Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event BeforeDisconnect As System.EventHandler
'Usage

Dim instance As VistaDBMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.BeforeDisconnect, handler
public event System.EventHandler BeforeDisconnect
public: __event System.EventHandler* BeforeDisconnect
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


CanExecSQL Property (VistaDBMetadataProvider)

CanExecSQL Property (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : CanExecSQL Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property CanExecSQL As System.Boolean
'Usage

Dim instance As VistaDBMetadataProvider
Dim value As System.Boolean

value = instance.CanExecSQL
public System.bool CanExecSQL {get;}
public: __property System.bool get_CanExecSQL();
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


Connect Method (VistaDBMetadataProvider)

Connect Method (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : Connect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Connect()
'Usage

Dim instance As VistaDBMetadataProvider

instance.Connect()
public void Connect()
public: void Connect();
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


Connected Property (VistaDBMetadataProvider)

Connected Property (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : Connected Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Property Connected As System.Boolean
'Usage

Dim instance As VistaDBMetadataProvider
Dim value As System.Boolean

instance.Connected = value

value = instance.Connected
public System.bool Connected {get; set;}
public: __property System.bool get_Connected();
public: __property void set_Connected(
   System.bool value
);
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


ConnectionObjectsCreated Property (VistaDBMetadataProvider)

ConnectionObjectsCreated Property (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : ConnectionObjectsCreated Property
Gets or sets the reference to the DB Connection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property ConnectionObjectsCreated As System.Boolean
'Usage

Dim instance As VistaDBMetadataProvider
Dim value As System.Boolean

value = instance.ConnectionObjectsCreated
public System.bool ConnectionObjectsCreated {get;}
public: __property System.bool get_ConnectionObjectsCreated();
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


Container Property (VistaDBMetadataProvider)

Container Property (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : Container Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
'Usage

Dim instance As VistaDBMetadataProvider
Dim value As System.ComponentModel.IContainer

value = instance.Container
public System.ComponentModel.IContainer Container {get;}
public: __property System.ComponentModel.IContainer* get_Container();
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


CreateObjRef Method (VistaDBMetadataProvider)

CreateObjRef Method (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As VistaDBMetadataProvider
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)

Parameters

requestedType
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


Description Property (VistaDBMetadataProvider)

Description Property (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : Description Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public ReadOnly Property Description As System.String
'Usage

Dim instance As VistaDBMetadataProvider
Dim value As System.String

value = instance.Description
public System.string Description {get;}
public: __property System.string* get_Description();
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


Disconnect Method (VistaDBMetadataProvider)

Disconnect Method (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : Disconnect Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Disconnect()
'Usage

Dim instance As VistaDBMetadataProvider

instance.Disconnect()
public void Disconnect()
public: void Disconnect();
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


Dispose Method (VistaDBMetadataProvider)

Dispose Method (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : Dispose Method
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


Dispose() Method

Dispose() Method

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub Dispose()
'Usage

Dim instance As VistaDBMetadataProvider

instance.Dispose()
public void Dispose()
public: void Dispose();
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


Disposed Event (VistaDBMetadataProvider)

Disposed Event (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : Disposed Event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Event Disposed As System.EventHandler
'Usage

Dim instance As VistaDBMetadataProvider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
public event System.EventHandler Disposed
public: __event System.EventHandler* Disposed
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


ExecSQL Method (VistaDBMetadataProvider)

ExecSQL Method (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : ExecSQL Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function ExecSQL( _
   ByVal sql As System.String, _
   ByVal schemaOnly As System.Boolean _
) As System.Data.IDataReader
'Usage

Dim instance As VistaDBMetadataProvider
Dim sql As System.String
Dim schemaOnly As System.Boolean
Dim value As System.Data.IDataReader

value = instance.ExecSQL(sql, schemaOnly)
public System.Data.IDataReader ExecSQL(
   System.string sql,
   System.bool schemaOnly
)
public: System.Data.IDataReader* ExecSQL(
   System.string* sql,
   System.bool schemaOnly
)

Parameters

sql
schemaOnly
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


ExecSQLNoResult Method (VistaDBMetadataProvider)

ExecSQLNoResult Method (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : ExecSQLNoResult Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Sub ExecSQLNoResult( _
   ByVal sql As System.String _
)
'Usage

Dim instance As VistaDBMetadataProvider
Dim sql As System.String

instance.ExecSQLNoResult(sql)
public void ExecSQLNoResult(
   System.string sql
)
public: void ExecSQLNoResult(
   System.string* sql
)

Parameters

sql
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


GetLifetimeService Method (VistaDBMetadataProvider)

GetLifetimeService Method (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As VistaDBMetadataProvider
Dim value As System.Object

value = instance.GetLifetimeService()
public System.object GetLifetimeService()
public: System.Object* GetLifetimeService();
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


InitializeLifetimeService Method (VistaDBMetadataProvider)

InitializeLifetimeService Method (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As VistaDBMetadataProvider
Dim value As System.Object

value = instance.InitializeLifetimeService()
public virtual System.object InitializeLifetimeService()
public: virtual System.Object* InitializeLifetimeService();
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


LoadDatabases Method (VistaDBMetadataProvider)

LoadDatabases Method (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : LoadDatabases Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadDatabases( _
   ByVal databases As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As VistaDBMetadataProvider
Dim databases As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadDatabases(databases, loadingOptions)
public virtual void LoadDatabases(
   MetadataList databases,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadDatabases(
   MetadataList* databases,
   MetadataLoadingOptions* loadingOptions
)

Parameters

databases
loadingOptions
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


LoadFields Method (VistaDBMetadataProvider)

LoadFields Method (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : LoadFields Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadFields( _
   ByVal fields As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As VistaDBMetadataProvider
Dim fields As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadFields(fields, loadingOptions)
public virtual void LoadFields(
   MetadataList fields,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadFields(
   MetadataList* fields,
   MetadataLoadingOptions* loadingOptions
)

Parameters

fields
loadingOptions
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


LoadPackages Method (VistaDBMetadataProvider)

LoadPackages Method (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : LoadPackages Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadPackages( _
   ByVal packages As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As VistaDBMetadataProvider
Dim packages As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadPackages(packages, loadingOptions)
public virtual void LoadPackages(
   MetadataList packages,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadPackages(
   MetadataList* packages,
   MetadataLoadingOptions* loadingOptions
)

Parameters

packages
loadingOptions
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


LoadParams Method (VistaDBMetadataProvider)

LoadParams Method (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : LoadParams Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadParams( _
   ByVal params As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As VistaDBMetadataProvider
Dim params As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadParams(params, loadingOptions)
public virtual void LoadParams(
   MetadataList params,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadParams(
   MetadataList* params,
   MetadataLoadingOptions* loadingOptions
)

Parameters

params
loadingOptions
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


LoadSchemas Method (VistaDBMetadataProvider)

LoadSchemas Method (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : LoadSchemas Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadSchemas( _
   ByVal schemas As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As VistaDBMetadataProvider
Dim schemas As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadSchemas(schemas, loadingOptions)
public virtual void LoadSchemas(
   MetadataList schemas,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadSchemas(
   MetadataList* schemas,
   MetadataLoadingOptions* loadingOptions
)

Parameters

schemas
loadingOptions
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


LoadServers Method (VistaDBMetadataProvider)

LoadServers Method (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : LoadServers Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Sub LoadServers( _
   ByVal servers As MetadataList, _
   ByVal loadingOptions As MetadataLoadingOptions _
)
'Usage

Dim instance As VistaDBMetadataProvider
Dim servers As MetadataList
Dim loadingOptions As MetadataLoadingOptions

instance.LoadServers(servers, loadingOptions)
public virtual void LoadServers(
   MetadataList servers,
   MetadataLoadingOptions loadingOptions
)
public: virtual void LoadServers(
   MetadataList* servers,
   MetadataLoadingOptions* loadingOptions
)

Parameters

servers
loadingOptions
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


Site Property (VistaDBMetadataProvider)

Site Property (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : Site Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
'Usage

Dim instance As VistaDBMetadataProvider
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
public virtual System.ComponentModel.ISite Site {get; set;}
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


ToString Method (VistaDBMetadataProvider)

ToString Method (VistaDBMetadataProvider)

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace > VistaDBMetadataProvider Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
'Declaration

Public Overridable Function ToString() As System.String
'Usage

Dim instance As VistaDBMetadataProvider
Dim value As System.String

value = instance.ToString()
public virtual System.string ToString()
public: virtual System.string* ToString();
Requirements

See Also

Reference

VistaDBMetadataProvider Class
VistaDBMetadataProvider Members


ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.VistaDBMetadataProvider2) Inheritance Hierarchy

ActiveDatabaseSoftware.ActiveQueryBuilder Namespace (ActiveDatabaseSoftware.VistaDBMetadataProvider2) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ActiveDatabaseSoftware.ActiveQueryBuilder.BaseMetadataProvider
ActiveDatabaseSoftware.ActiveQueryBuilder.VistaDBMetadataProvider
See Also

Reference

ActiveDatabaseSoftware.VistaDBMetadataProvider2 Assembly


Active Query Builder .NET WinForms Edition

Active Query Builder .NET WinForms Edition

Active Query Builder .NET WinForms Edition is a visual query builder component suite that allows your end-users to build SQL queries via an intuitive visual interface. It's powerful API allows to parse complex SQL queries for programmatic analysis and modification.

Active Query Builder .NET WinForms Edition supports Visual Studio .NET 2005-2010 (Windows.Forms environment). The component was successfully tested with .NET Frameworks from 2.0 up to 4.0.

Common product information about Active Query Builder:

  • Easy visual building of complex SQL queries with unions and sub-queries.
  • MS-Access style user-friendly interface with drag & drop support.
  • Two-way SQL query building (combined with SQL text editing).
  • Defining user-friendly aliases for tables and field names.
  • Powerful means of SQL query analysis and programming modification.
  • Working in offline mode, storing metadata in XML files.
  • Restricting access to unwanted objects, preventing query execution.
  • Sophisticated SQL parser, support of most popular database servers.
  • SQL query text formatting.
  • Ability to localize the component

The main object of Active Query Builder component suite is ActiveDatabaseSoftware.ActiveQueryBuilder.QueryBuilder. Place the component on a form and follow the steps of the configuration wizard to set up the component. If you don't want to use the wizard or it's unavailable, you should place a few more components to setup Active Query Builder properly. Below is the class diagram to illustrate the basics.

You may learn more in the Quick Start Guide.


Quick Start Guide for .NET WinForms Edition

Quick Start Guide for .NET WinForms Edition

  1. Place the QueryBuilder component on the form:

    using ActiveDatabaseSoftware.ActiveQueryBuilder;
...
QueryBuilder queryBuilder1 = new QueryBuilder();

  2. Place required metadata and syntax provider components on the form. Define a proper database connection object for the metadata provider:

    OleDbConnection connection = new OleDbConnection();
connection.ConnectionString = "<your connection string here>";

OLEDBMetadataProvider metadataProvider = new OLEDBMetadataProvider();
metadataProvider.Connection = connection;

GenericSyntaxProvider syntaxProvider = new GenericSyntaxProvider();

  3. Link the components above to the QueryBuilder by setting MetadataProvider and SyntaxProvider properties:

    queryBuilder1.MetadataProvider = metadataProvider;
queryBuilder1.SyntaxProvider = syntaxProvider;

  4. Place the PlainTextSQLBuilder component on the form to get SQL code generated by the QueryBuilder component with formatting. Link it to the QueryBuilder object:

    PlainTextSQLBuilder sqlBuilder = new PlainTextSQLBuilder();
sqlBuilder.QueryBuilder = queryBuilder1;

  5. Add the TextBox or any other text editing component to a form.

  6. Now you should establish connection between SQLBuilder and the TextBox components.
    Enter the following code to Leave event of TextBox component:

    if (textBox1.Modified)
{
   try
      {
         queryBuilder1.SQL = textBox1.Text;
      }
      catch (Exception ex)
      {
         MessageBox.Show(ex.Message, "Parsing error");
      }

   textBox1.Modified = false;
}

    Enter the following code to SQLUpdated event of SQLBuilder component:

    textBox1.Text = sqlBuilder.SQL;

  7. Execute the following code to activate Database Schema Tree:
    queryBuilder1.InitializeDatabaseSchemaTree();

  8. That's all! Now you can run your application.