- ExcelCreator 5.0 for .NET -
ExcelCreator 5.0 for .NET の概要

ExcelCreator 5.0 for .NET は、様々なアプリケーションの使用用途に対応するため、以下の Excel ファイル生成機能を提供します。

1. | Excel ファイルの作成・オープン
1-1. | Excel ファイルを新規作成
1-2. | 既存の Excel ファイルを読み込み専用でオープン
1-3. | 既存の Excel ファイルを読み書きオープン
1-4. オーバーレイオープン
オーバーレイ機能について
オーバーレイ機能の使用方法
1-5. オーバーレイオープン (埋め込みリソース)
埋め込みリソースのオーバーレイ
・ | リソースファイルの作成とプロジェクトへの設定・使用方法
 | オーバーレイ元ファイル (Excel ファイル) を埋め込みリソースとしてプロジェクトに登録する
 | オーバーレイ元ファイル (Excel ファイル) を元に作成したリソースファイルを埋め込みリソースとしてプロジェクトに登録する
1-6. | Excel ファイルの切り替えオープン
2. | シート、セルの操作
2-1. | データの設定 / 取得
2-2. | 属性の設定
2-3. | コピー / 貼り付け / クリア / 削除
3. | PDF ファイルの出力


システム動作環境

システム動作環境

・動作環境

OS | : | Windows 2000 (SP3 以上) / XP (SP1 以上) / Server 2003 ※.NET Framework 1.0 (SP3 以上) / 1.1 (SP1 以上) / 2.0 が必要です。 ※ASP.NET で使用する場合、IIS5.0 以上が必要です。
ハードディスク | : | 20MB 以上
メモリ | : | 256MB 以上
開発環境 | : | Visual Studio .NET (SP1 以上) / Visual Studio .NET 2003 / Visual Studio 2005
対応言語 | : | Visual Basic .NET / Visual C# .NET (Windows アプリケーション / ASP.NET アプリケーション)
対応する Excel バージョン | : | Excel 97 / 2000 / 2002(XP) / 2003


ExcelCreator 5.0 for .NET が対応する Excel の機能

【表の見方】
ExcelCreator 5.0 for .NET で Excel ファイルの作成と編集を行う時の対応する Excel の機能を表しています。
○ | ：対応
× | ：未対応

※ | 対応可能の機能でも一部制限のあるプロパティ / メソッドがあります。各プロパティ / メソッドの注意点もあわせてご確認ください。
※ | 表に記載されていない Excel の機能はサポート窓口までお問い合わせください。サポート窓口はこちらをご覧ください。

【項目の説明】
新規作成と編集 | ExcelCreator 5.0 for .NET で Excel ファイルの作成と編集、PDF ファイルを作成を行う時の対応する Excel の機能を表します。
オーバレイ | ExcelCreator 5.0 for .NET でオーバーレイ機能 (OpenBook , OpenBookEx , OpenBookEmbedEx メソッド) を使用して Excel ファイルや PDF ファイルを作成する時のオーバーレイ元ファイルに設定された Excel の機能をオーバレイ先の Excel ファイルに引き継ぐことができるかを表します。

Excel メニュー / 設定項目 | ExcelCreator 5.0 for .NET | オーバーレイ
Excel での設定：[ファイル]-[ページ設定] の [ページ] タブ
印刷の向き (縦 / 横) | ○ (Size メソッド / SizeFree メソッド) | ○
拡大縮小印刷 (拡大 / 縮小 10 ～ 400%) | ○ (Size メソッド) | ○
拡大縮小印刷 (横 : 1 ～ 32767 × 縦 : 1 ～ 32767 ページ) | × | ×
用紙サイズ | ○ (Size メソッド / SizeFree メソッド) | ○
印刷品質 | × | ○
先頭ページ番号 | × | ○
Excel での設定：[ファイル]-[ページ設定] の [余白] タブ
上 | ○ (Marginメソッド) | ○
下 | ○ (Marginメソッド) | ○
左 | ○ (Marginメソッド) | ○
右 | ○ (Marginメソッド) | ○
ヘッダー | ○ (Marginメソッド) | ○
フッター | ○ (Marginメソッド) | ○
ページ中央 (水平 / 垂直) | ○ (Center プロパティ) | ○
Excel での設定：[ファイル]-[ページ設定] の [ヘッダー / フッター] タブ / [表示]-[ヘッダーとフッター]
ヘッダー | ○ (Headerメソッド) | ○
フッター | ○ (Footerメソッド) | ○
Excel での設定：[ファイル]-[ページ設定] の [シート] タブ
印刷範囲 | ○ (PrintArea メソッド) | ○
ページの方向 (左から右へ / 上から下へ) | ○ (PageOrder プロパティ) | ○
Excel での設定：[編集]-[コピー]
セルコピー | ○ (Copyメソッド) (*3) | -
行コピー | ○ (RowCopyメソッド) (*3) | -
列コピー | ○ (ColumnCopyメソッド) (*3) | -
Excel での設定：[編集]-[貼り付け]
セル貼り付け | ○ (Pasteメソッド) (*3) | -
行貼り付け | ○ (RowPasteメソッド) (*3) | -
列貼り付け | ○ (ColumnPasteメソッド) (*3) | -
Excel での設定：[編集]-[クリア]-[すべて]
セルクリア | ○ (Clearメソッド) | -
行クリア | ○ (RowClearメソッド) | -
列クリア | ○ (ColumnClearメソッド) | -
Excel での設定：[編集]-[削除]
行削除 | ○ (RowDeleteメソッド) | -
列削除 | ○ (ColumnDeleteメソッド) | -
Excel での設定：[編集]-[シートの削除] / [シートの移動またはコピー]
ワークシートの削除 | ○ (DelSheetメソッド) | -
ワークシートの移動 | × | -
ワークシートのコピー | ○ (CopySheetメソッド) (*4) | -
Excel での設定：[表示]-[ズーム]
倍率 | ○ (Zoomプロパティ) | ○
Excel での設定：[挿入]-[行] / [列] / [改ページ]
行挿入 | ○ (RowInsertメソッド) | -
列挿入 | ○ (ColumnInsertメソッド) | -
ワークシート挿入 | ○ (AddSheetメソッド) (*2) | -
改ページ挿入 | ○ (Breakプロパティ) | -
Excel での設定：[書式]-[セル] の [表示形式] タブ
分類 | ○ (Formatプロパティ) | ○
Excel での設定：[書式]-[セル] の [配置] タブ
横位置-標準 | ○ (PosHorzプロパティ) | ○
横位置-左詰め | ○ (PosHorzプロパティ) | ○
横位置-中央揃え | ○ (PosHorzプロパティ) | ○
横位置-右詰め | ○ (PosHorzプロパティ) | ○
横位置-繰り返し | ○ (PosHorzプロパティ) | ○
横位置-両端揃え | ○ (PosHorzプロパティ) | ○
横位置-選択範囲内で中央 | ○ (PosHorzプロパティ) | ○
横位置-均等割り付け | ○ (PosHorzプロパティ) | ○
縦位置-上詰め | ○ (PosVertプロパティ) | ○
縦位置-中央揃え | ○ (PosVertプロパティ) | ○
縦位置-下詰め | ○ (PosVertプロパティ) | ○
縦位置-両端揃え | ○ (PosVertプロパティ) | ○
縦位置-均等割り付け | ○ (PosVertプロパティ) | ○
文字の制御 (折り返して全体を表示する) | ○ (OverReturnプロパティ) | ○
文字の制御 (縮小して全体を表示する) | ○ (Fitプロパティ) | ○
文字の制御 (セルを結合する) | ○ (Jointプロパティ) | ○
方向 | ○ (PosTurnプロパティ) | ○
Excel での設定：[書式]-[セル] の [フォント] タブ
フォント名 | ○ (FontNameプロパティ) | ○
スタイル | ○ (FontStyleプロパティ) | ○
サイズ | ○ (FontPointプロパティ) | ○
下線 (なし / 下線 / 二重下線) | ○ (FontULineプロパティ) | ○
色 | ○ (FontColorプロパティ) | ○
文字飾り (取り消し線) | ○ (FontStyleプロパティ) | ○
文字飾り (上付き) | ○ (FontStyleプロパティ) | ○
文字飾り (下付き) | ○ (FontStyleプロパティ) | ○
Excel での設定：[書式]-[セル] の [罫線] タブ
プリセット (外枠) | ○ (Boxメソッド) | ○
罫線 (上) | ○ (LineTopプロパティ) | ○
罫線 (下) | ○ (LineBottomプロパティ) | ○
罫線 (左) | ○ (LineLeftプロパティ) | ○
罫線 (右) | ○ (LineRightプロパティ) | ○
罫線 (左上がり) | ○ (LineLeftUpプロパティ) | ○
罫線 (右上がり) | ○ (LineRightUpプロパティ) | ○
線 (スタイル) | ○ | ○
線 (色) | ○ | ○
Excel での設定：[書式]-[セル] の [パターン] タブ
セルの網掛け (色) | ○ (BackColorプロパティ) | ○
セルの網掛け (パターン) | ○ (Patternプロパティ) | ○
Excel での設定：[書式]-[行] / [列]
高さ (行) | ○ (RowHeightプロパティ) | ○
幅 (列) | ○ (ColWidthプロパティ) | ○
表示しない / 再表示 | × | ○
Excel での設定：[書式]-[シート]
名前の変更 | ○ (SheetNameメソッド) | -
表示しない / 再表示 | × | ○
Excel での設定：[ツール]-[オプション] の [表示] タブ
ウィンドウオプション (枠線) | ○ (ModeGridプロパティ) | ○
Excel での設定：[ツール]-[オプション] の [全般] タブ
設定 (新しい Excel ファイルのシート数) | ○ (*1) | -
設定 (標準フォント名) | ○ (DefFontNameプロパティ) | ○
設定 (標準フォントサイズ) | ○ (DefFontPointプロパティ) | ○
*1：CreateBook メソッド , CreateBookEx メソッドで新規に Excel ファイルを作成する場合のみ、シート数を設定することができます。 *2：既存のシートの最後に新しいシートを追加します。 *3：同一シートのコピー / 貼り付けのみに対応しています。 *4：同一 Excel ファイルのシートコピーのみに対応しています。


ExcelCreator 5.0 for .NET - アプリケーションのライセンス体系 -

アプリケーションのライセンス体系

ExcelCreator 5.0 for .NET コンポーネントを組み込んだアプリケーションの配布は、配布するアプリケーションの種類によってライセンス体系が異なります。
※配布方法はアプリケーションの配布についてを参照してください。

・ | Windows アプリケーションの場合
 | ExcelCreator 5.0 for .NET ランタイムファイルの再配布は、ロイヤリティーフリーです。

・ Web アプリケーションの場合
ExcelCreator 5.0 for .NET ランタイムファイルを配布するサーバー機の台数分のサーバーライセンスが必要です。

サーバーライセンス
ExcelCreator 5.0 for .NET ランタイムファイルを IIS や CGI などのプロセス上で動作 (不特定多数のクライアントからアクセス) する Web アプリケーションで使用する時に必要なライセンスです。

価格 | ： | 1 サーバーあたり \126,000- (税抜:\120,000-)
製品構成 | ： | ライセンス数や契約内容を記載した契約書のみ
保守期間 | ： | 最初の 1 年間は無償。期間延長の場合は有償。

サーバーライセンスのお問い合わせは、下記の営業窓口をご利用ください。

TEL | ： | 0776-21-9008
FAX | ： | 0776-21-9022
E-Mail | ： | info@adv.co.jp


ExcelCreator 5.0 for .NET

- ExcelCreator 5.0 for .NET / フォームにコンポーネントを配置する -
Visual Studio .NET のツールボックスに追加

フォームにコンポーネントを配置する場合、Visual Studio .NET の [ツールボックス] に ExcelCreator 5.0 for .NET コンポーネントを追加します。

・ | Visual Studio 2005 の場合
 | メニュー [ツール]-[ツールボックス アイテムの選択] をクリックして [ツールボックス アイテムの選択] 画面を開きます。
・ | ・Visual Studio .NET 2003 の場合
 | メニュー [ツール]-[ツールボックスのカスタマイズ] をクリックして [ツールボックスのカスタマイズ] 画面を開きます。
・ | Visual Studio .NET 2002 の場合
 | メニュー [ツール]-[ツールボックス アイテムの追加と削除] をクリックして [ツールボックスのカスタマイズ] 画面を開きます。

[ツールボックスのカスタマイズ] 画面、もしくは [ツールボックス アイテムの選択] 画面にて、下記のコンポーネント名のチェックを入れて [OK] ボタンをクリックします。

名前 | 名前空間 / アセンブリ名
XlsCreator | ExcelCreator

※Visual Studio 2005 の画面です。

Visual Studio .NET の [ツールボックス] に追加されていれば完了です。


ExcelCreator 5.0 for .NET

- ExcelCreator 5.0 for .NET / フォームにコンポーネントを配置する -
フォームにコンポーネントを配置

Visual Studio .NET の [ツールボックス] で指定した ExcelCreator 5.0 for .NET コンポーネント「xlsCreator」のアイコンを選択して、フォームに配置します。
プロジェクトのソリューションエクスプローラの参照設定に配置したコンポーネントの名前空間が追加されます。
(Visual Studio .NET の[ツールボックス]に ExcelCreator 5.0 for .NET コンポーネントを追加する操作は Visual Studio .NET のツールボックスに追加を参照してください。)

・ Windows フォーム

※Visual Studio 2005 の画面です。

・ Web アプリケーション

※Visual Studio .NET 2003 の画面です。

Visual Studio 2005 の場合、プロジェクトの参照設定に ExcelCreator 5.0 for .NET コンポーネントを追加し、プログラム中で ExcelCreator 5.0 for .NET コンポーネントのインスタンスを生成して使用してください。(プロジェクトの参照設定に追加する操作は、参照設定に追加するを参照してください。)


ExcelCreator 5.0 for .NET

- ExcelCreator 5.0 for .NET / コンポーネントのプロジェクト組み込み -
参照設定に追加する

プロジェクトの参照設定に ExcelCreator 5.0 for .NET コンポーネントを追加し、プログラム中で ExcelCreator 5.0 for .NET コンポーネントのインスタンスを生成して使用する方法です。

1) | Visual Studio .NET のメニュー [プロジェクト]-[参照の追加] で [参照の追加] 画面を開きます。

2) | [参照の追加] 画面の [.NET] タブを選択します。

3) 下記の ExcelCreator 5.0 for .NET コンポーネントを選択します。

コンポーネント名 | パス
Advance Software ExcelCreator | \<User Folder>\XlsCrt5\Bin\ExcelCreator.dll
Advance Software ExcelCreator | \<User Folder>\XlsCrt5\Bin\ExcelCreator.XlsCrt.dll
Advance Software ExcelCreator | \<User Folder>\XlsCrt5\Bin\ExcelCreator.XlsPDF.dll

※Visual Studio .NET 2003 の画面です。

※Visual Studio 2005 の画面です。

4) Visual Studio .NET 2002 / Visual Studio .NET 2003 の場合は、上記のコンポーネントを選択した状態で[選択] ボタンをクリックし、 [選択したコンポーネント] に追加します。

※Visual Studio .NET 2003 の画面です。

Visual Studio 2005 の場合は、選択した状態で次に進みます。

5) [OK] ボタンをクリックし、[参照の追加] 画面を閉じます。

6) プロジェクトのソリューションエクスプローラの参照設定に選択したコンポーネントが追加されます。

7) 参照設定で追加したコンポーネントのインスタンスをプログラム中で生成します。
コーディング例

ExcelCreator 5.0 for .NET コンポーネントのインスタンスを生成し、Excel ファイル新規作成します。

[VB.NET]
Dim XlsCreator1 As New ExcelCreator.XlsCreator

XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile01.xls", 1, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A5").Long = 50000
XlsCreator1.CloseBook(True)

XlsCreator1.Dispose()

[C#]
private ExcelCreator.XlsCreator xlsCreator1 = new ExcelCreator.XlsCreator();

xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile01.xls", 1, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A5").Long = 50000;
xlsCreator1.CloseBook(true);

XlsCreator1.Dispose();


Excel ファイルを新規作成

Excel ファイルを新規作成

Excel ファイルを新規作成することができます。シート数や Excel ファイルバージョンも同時に指定できます。

シート数 3、Excel 2003 形式で、A1 セルに文字列を設定した Excel ファイルを新規作成します。

[VB.NET]
XlsCreator1.CreateBook(Application.StatupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A1").Value = "アドバンスソフトウェア株式会社"
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StatupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A1).Value = "アドバンスソフトウェア株式会社";
xlsCreator1.CloseBook(true);

参照
[CreateBook メソッド] | [CreateBookEx メソッド]


既存の Excel ファイルを読み込み専用でオープン

既存の Excel ファイルを読み込み専用でオープン

既存の Excel ファイルを読み込み専用でオープンし、セルのデータ取得を行うことができます。

既存の Excel ファイルを読み込み専用でオープンし、セルのデータ取得を行います。

[VB.NET]
XlsCreator1.ReadBook(Application.StatupPath & "\ExcelFile.xls")
Dim strData As String = XlsCreator1.Cell("C2").Str
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.ReadBook(Application.StatupPath + @"\ExcelFile.xls");
string strData = xlsCreator1.Cell("C2").Str;
xlsCreator1.CloseBook(true);

参照
[ReadBook メソッド] | [ReadBookEx メソッド]


既存の Excel ファイルを読み込み専用でオープン

既存の Excel ファイルを読み書きオープン

既存の Excel ファイルを読み書きオープンすることができます。
セルへデータ設定を行いながら、データ取得することができます。

既存の Excel ファイルを読み書きオープンし、セルのデータの設定や取得を行います

[VB.NET]

XlsCreator1.OpenBook(Application.StatupPath & "\ExcelFile.xls", "")
XlsCreator1.Cell("A1").Str = "アドバンスソフトウェア株式会社"
Dim strData As String = XlsCreator1.Cell("A1").Str
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.OpenBook(Application.StatupPath + @"\ExcelFile.xls", "");
xlsCreator1.Cell("A1").Str = "アドバンスソフトウェア株式会社";
string strData = xlsCreator1.Cell("A1").Str;
xlsCreator1.CloseBook(true);

参照
[OpenBook メソッド] | [OpenBookEx メソッド]


オーバーレイ機能について

オーバーレイ機能について

Excel シート内にあらかじめ変数文字を記述し、プログラム内で値を変数に代入することにより、シートにデータの埋め込みを行うことができます。これにより、あらかじめ変数定義済みのセルを利用したグラフのシートを作成しておくとプログラム上で変数に値を設定するだけでグラフが作成することができます。毎月の業務アプリケーションなどで使用すると、月々のグラフ作成を定型業務化することもできます。

オーバーレイ機能の使用方法は、こちらを参照してください。

オーバーレイ機能の制限事項
変数名について
変数名にする
 | 変数名として使用する場合は変数名の先頭に、変数名の先頭キーワード文字列として半角のアスタリスク (*) を 2 個つけます。
変数名使用可能文字
 | 以下に示す文字以外、使用することができます。変数名として設定可能文字列は、変数名の先頭キーワード文字列 ** を含め 255 文字までです。 \ ' " , ^ . [ ] (いずれも半角です)
変数の設定数
 | 変数の設定個数に制限はありません。
変数名の設定
 | 変数名を ExcelCreator 5.0 for .NET の文字列設定で記述する場合、オーバーレイ元ファイルを元に作成されるファイルについては変数名は無効となりますが、オーバーレイ元ファイルに直接上書き設定する場合には、変数名は設定可能です。
変数名の先頭キーワード文字列を設定
 | KeyWord プロパティで設定します。デフォルトは ** です。

オーバーレイ機能設定可能情報
オーバーレイ元ファイルに設定可能な情報は、ExcelCreator 5.0 for .NET が対応する Excel の機能を参照してください。


オーバーレイ機能の使用方法

オーバーレイ機能の使用方法

1. オーバーレイ用の変数を記述した Excel ファイルを作成します。
2. プログラムの記述を行います。
1) | OpenBook メソッド / OpenBookEx メソッド / OpenBookEmbedEx メソッドを使用し、作成するファイル名、元となるオーバーレイ元ファイル名を指定します。
2) | 設定対象シートを SheetNo プロパティで選択します。変数への値の設定は、現在の対象シートへの設定となります。 複数シートにわたって変数名を使用している場合、SheetNo プロパティで対象シートを切り替えて値を設定します。
3) | Cell クラスの引数に直接オーバーレイ元ファイルに記述した変数名を文字列式で記述します。
4) | オーバーレイ元ファイルに変数名を記述し、プログラム中で変数に値を設定しなかった場合、作成されるファイルの変数位置には、何も入りません。
5) | CloseBook メソッド / CloseBookEx メソッドで、ファイルのクローズを行います。

設定例
ExcelTemplate.xls をオーバーレイ元ファイルとして、ExcelFile.xls を作成します。
オーバーレイ元ファイル ExcelTemplate.xls の内容は、次のとおりです。
（A1 セルに変数 **AAA 、B1 セルに変数 **BBB を設定しています。）

・ExcelTemplate.xls

このファイルを元に ExcelFile.xls を作成します。
（A1 セルに値 123 、C1 セルに文字列 **CCC を入れます。）

XlsCreator1.OpenBook(Applicaiotn.StartopPath + "\ExcelFile.xls", _
                     Applicaiotn.StartopPath + "\ExcelTemplate.xls")
XlsCreator1.Cell("**AAA").Long = 123    '**AAA と書かれたセルに値を設定します
XlsCreator1.Cell("C1").Str = "**CCC"    'C1 セルに変数名を指定します
XlsCreator1.CloseBook(True)

実行結果、下記の Excel ファイルが作成されます。

・ExcelFile.xls

変数 **AAA が設定されている A1 セルには値 123 が入ります。
変数 **BBB が設定されている B1 セルには何も値を設定していないので、オーバーレイ元ファイルを元に作成された ExcelFile.xls の B1 セルには何も入りません。
C1 セルに設定した文字列 **CCC は変数名なので、オーバーレイ元ファイルを元に作成された ExcelFile.xls の C1 セルには何も入りません。


埋め込みリソースのオーバーレイ

埋め込みリソースのオーバーレイ

ExcelCreator 5.0 for .NET は、アプリケーションにオーバーレイ元ファイルを埋め込むことで、エンドユーザーからのデザインファイルの変更や、不用意な変更によるアプリケーションの意図しない動作を防ぐことができます。
下記のいずれかの方法でアプリケーションにデザインファイルを埋め込んで操作することができます。

・ | オーバーレイ元ファイル (Excel ファイル) を埋め込みリソースとしてプロジェクトに登録する
・ | オーバーレイ元ファイル (Excel ファイル) を元に作成したリソースファイルを埋め込みリソースとしてプロジェクトに登録する


埋め込みリソースのオーバーレイ

- ExcelCreator 5.0 for .NET / 埋め込みリソースのオーバーレイ -
オーバーレイ元ファイル (Excel ファイル) を埋め込みリソースとしてプロジェクトに登録する

オーバーレイ元ファイル (Excel ファイル) を埋め込みリソースとしてプロジェクトに登録する方法です。
※下記の手順は、Visual Studio .NET 2002 / 2003 / Visual Studio 2005 共通です。

(1) 埋め込みリソースを登録するプロジェクトを Visual Studio .NET で開き、Visual Studio .NET のメニュー [プロジェクト]-[既存項目の追加] から、オーバーレイ元ファイル (Excel ファイル) を選択して追加します。 Visual Studio .NET のメニュー[プロジェクト]-[既存項目の追加]から、オーバーレイ元ファイルの追加を行います。
ここでは、オーバーレイ元ファイル (Embed_Excel.xls) が C:\EmbedExcelFile フォルダにあると仮定します。

C:\EmbedExcelFile フォルダのオーバーレイ元ファイル名 (Embed_Excel.xls) を選択します。

※Visual Studio 2005 の画面です。

プロジェクトに選択したオーバーレイ元ファイルが追加されます。

※Visual Studio 2005 の画面です。

(2) ソリューションエクスプローラーより、追加したオーバーレイ元ファイルを右クリックで開き、プロパティを表示します。プロパティの [ビルドアクション] を「埋め込まれたリソース (Embedded Resource)」に変更します。

※Visual Studio 2005 の画面です。

(3) 埋め込みリソースの使用方法 (コーディング例)

[VB.NET]
Public Class OpenBookEmbedSample
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Dim strOutFileName As String = Application.StartupPath & "\OpenBookEmbed.Xls"
        ' リソース名="[プロジェクトのNameSpace].[埋め込みファイル名]"
        Dim strInFileName As String = "OpenBookEmbedSample.Embed_Excel.xls";

        ' 埋め込みリソースの読み込み
        System.Reflection.Assembly asmExcelFile = System.Reflection.Assembly.GetExecutingAssembly()
        System.IO.Stream srmExcelFile = asmExcelFile.GetManifestResourceStream(strInFileName)

        XlsCreator1.OpenBookEmbed(strOutFileName, srmExcelFile)
        XlsCreator1.Cell("C2").Value = "アドバンスソフトウェア株式会社"
        XlsCreator1.CloseBook(True)

        ' 読み込んだリソースを閉じる
        srmExcelFile.Close()
    End Sub
End Class

[C#]
namespace OpenBookEmbedSample
{
    private void button1_Click(object sender, System.EventArgs e)
    {
        string strOutFileName = Application.StartupPath + @"\OpenBookEmbed.Xls";
        // リソース名="[プロジェクトのNameSpace].[埋め込みファイル名]"
        string strInFileName = "OpenBookEmbedSample.Embed_Excel.xls";

        // 埋め込みリソースの読み込み
        System.Reflection.Assembly asmExcelFile = System.Reflection.Assembly.GetExecutingAssembly();
        System.IO.Stream srmExcelFile = asmExcelFile.GetManifestResourceStream(strInFileName);

        xlsCreator1.OpenBookEmbed(strOutFileName, srmExcelFile);
        xlsCreator1.Cell("C2").Value = "アドバンスソフトウェア株式会社";
        xlsCreator1.CloseBook(true);

        // 読み込んだリソースを閉じる
        srmExcelFile.Close();
    }
}


埋め込みリソースのオーバーレイ

- ExcelCreator 5.0 for .NET / 埋め込みリソースのオーバーレイ -
オーバーレイ元ファイル (Excel ファイル) を元に作成したリソースファイルを埋め込みリソースとしてプロジェクトに登録する

オーバーレイ元ファイル (Excel ファイル) を元に作成したリソースファイルを埋め込みリソースとしてプロジェクトに登録する方法です。
※下記の手順は、Visual Studio .NET 2002 / 2003 / Visual Studio 2005 共通です。

(1) オーバーレイ元ファイルから埋め込みリソースファイルの作成方法 (コーディング例)

[VB.NET]
' オーバーレイ元ファイル (Excel ファイル) をバイト配列へ置き換えて読み込み
Dim fs As System.IO.FileStream = New System.IO.FileStream("C:\EmbedExcel.xls", System.IO.FileMode.Open)
Dim byt() As Byte = New Byte(fs.Length) {}
fs.Read(byt, 0, fs.Length)

' C:\ResourceFile フォルダにリソースファイル (EmbedExcel.resources) 作成
Dim rw As System.Resources.ResourceWriter = New System.Resources.ResourceWriter("C:\ResourceFile\EmbedExcel.resources")
rw.AddResource("C:\ResourceFile\EmbedExcel.resources", byt)

' オーバーレイ元ファイル (Excel ファイル) とリソースファイルを閉じる
fs.Close()
rw.Generate()
rw.Close()

[C#]
// オーバーレイ元ファイル (Excel ファイル) をバイト配列へ置き換えて読み込み
System.IO.FileStream fs = new System.IO.FileStream(@"C:\EmbedExcel.xls", System.IO.FileMode.Open);
byte[] bytes = new byte[fs.Length];
fs.Read(bytes, 0, Convert.ToInt32(fs.Length));

// C:\ResourceFile フォルダにリソースファイル (EmbedExcel.resources) 作成
System.Resources.ResourceWriter rw = new System.Resources.ResourceWriter(@"C:\ResourceFile\EmbedExcel.resources");
rw.AddResource(@"C:\ResourceFile\EmbedExcel.resources", bytes);

// オーバーレイ元ファイル (Excel ファイル) とリソースファイルを閉じる
fs.Close();
rw.Generate();
rw.Close();

(2) 埋め込みリソースを登録するプロジェクトを Visual Studio .NET で開き、Visual Studio .NET のメニュー [プロジェクト]-[既存項目の追加] から、作成したリソースファイルを選択して追加します。
C:\ResourceFile フォルダのリソースファイル (EmbedExcel.resources) を選択します。

※Visual Studio 2005 の画面です。

プロジェクトに選択したリソースファイルが追加されます。

※Visual Studio 2005 の画面です。

(3) ソリューションエクスプローラーより、追加したリソースファイルを右クリックで開き、プロパティを表示します。プロパティの [ビルドアクション] を「埋め込まれたリソース (Embedded Resource)」に変更します。

※Visual Studio 2005 の画面です。

(4) 埋め込みリソースの使用方法 (コーディング例)

[VB.NET]
Public Class OpenBookEmbedSample
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Dim strOutFileName As String = Application.StartupPath & "\OpenBookEmbed.Xls"

        Dim bytes() As Byte  ' リソース読み込みバッファ
        Dim res As System.Resources.ResourceManager

        ' 埋め込みリソースの読み込み
        ' リソース名="[プロジェクトのNameSpace].[埋め込みリソース名]"
        res = New System.Resources.ResourceManager("OpenBookEmbedSample.EmbedExcel", Me.GetType().Assembly)
        ' リソースをバイト配列へ置き換え
        bytes = res.GetObject("ExcelFile")

        XlsCreator1.OpenBookEmbed(strOutFileName, m_bytes)
        XlsCreator1.Cell("C2").Value = "アドバンスソフトウェア株式会社"
        XlsCreator1.CloseBook(True)
    End Sub
End Class

[C#]
namespace OpenBookEmbedSample
{
    private void button1_Click(object sender, System.EventArgs e)
    {
        string strOutFileName = Application.StartupPath + @"\OpenBookEmbed.Xls";

        byte[] bytes;  // リソースから読み込むバイナリバッファ
        System.Resources.ResourceManager res;

        // 埋め込みリソースの読み込み
        // リソース名="[プロジェクトのNameSpace].[埋め込みリソース名]"
        res = new System.Resources.ResourceManager("OpenBookEmbedSample.EmbedExcel", this.GetType().Assembly);
        // リソースをバイト配列へ置き換え
        bytes = (byte[])res.GetObject("ExcelFile");

        xlsCreator1.OpenBookEmbed(strOutFileName, bytes);
        xlsCreator1.Cell("C2").Value = "アドバンスソフトウェア株式会社";
        xlsCreator1.CloseBook(true);
    }
}


Excel ファイルの切り替えオープン

Excel ファイルの切り替えオープン

CreateBookEx , ReadBookEx , OpenBookEx , OpenBookEmbed , OpenBookEmbedEx メソッドで開いた Excel ファイルの 識別 ID を元に、SelectBook メソッドで操作を行うファイルを選択することで、複数の Excel ファイルを扱うことができます。

コーディング例

[VB.NET]
Dim pID1 As UInt32
Dim pID2 As UInt32

' Excel ファイル新規作成オープン
' 1 つ目の Excel ファイルを新規作成オープン
XlsCreator1.CreateBookEx(Application.StartupPath & "\ExcelFile01.xls", 3, _
                         ExcelCreator.xlVersion.ver2003, ByRef pID1)
' 2 つ目の Excel ファイルを新規作成オープン
XlsCreator1.CreateBookEx(Application.StartupPath & "\ExcelFile02.xls", 3, _
                         ExcelCreator.xlVersion.ver2003, ByRef pID2)

' 1 つ目の Excel ファイルに対し編集
XlsCreator1.SelectBook(pID1)  ' 操作対象となる Excel ファイルの識別 ID を設定
XlsCreator1.Cell("A1").Value = "1 つ目の Excel ファイルです。"

' 2 つ目の Excel ファイルに対し編集
XlsCreator1.SelectBook(pID2)  ' 操作対象となる Excel ファイルの識別 ID を設定
XlsCreator1.Cell("A1").Value = "2 つ目の Excel ファイルです。"

' Excel ファイルクローズ
' 識別 ID を設定しクローズ
XlsCreator1.CloseBookEx(True, pID1)
XlsCreator1.CloseBookEx(True, pID2)

[C#]
UInt32 pID1 = 0;
UInt32 pID2 = 0;

// Excel ファイル新規作成オープン
// 1 つ目の Excel ファイルを新規作成オープン
xlsCreator1.CreateBookEx(Application.StartupPath + @"\ExcelFile01.xls", 3,
                         ExcelCreator.xlVersion.ver2003, ref pID1);
// 2 つ目の Excel ファイルを新規作成オープン
xlsCreator1.CreateBookEx(Application.StartupPath + @"\ExcelFile02.xls", 3,
                         ExcelCreator.xlVersion.ver2003, ref pID1);

// 1 つ目の Excel ファイルに対し編集
xlsCreator1.SelectBook(pID1);  // 操作対象となる Excel ファイルの識別 ID を設定
xlsCreator1.Cell("A1").Value = "1 つ目の Excel ファイルです。";

// 2 つ目の Excel ファイルに対し編集
xlsCreator1.SelectBook(pID2);  // 操作対象となる Excel ファイルの識別 ID を設定
xlsCreator1.Cell("A1").Value = "2 つ目の Excel ファイルです。";

// Excel ファイルクローズ
// 識別 ID を設定しクローズ
xlsCreator1.CloseBookEx(true, pID1);
xlsCreator1.CloseBookEx(true, pID2);


データの設定

データの設定 / 取得

ExcelCreator 5.0 for .NET では、以下 4 つの方法で読み書きを行うセルをプログラム中から指定します。

1) | A1 参照形式によるセルの指定
Cell クラスにより、A1 参照形式で読み書きを行うセルを指定することができます。

XlsCreator1.OpenBook(Applicaiotn.StartupPath & "\ExcelFile.xls", "")
XlsCreator1.Cell("A1").Str = "A1セルに文字列を設定"
XlsCreator1.CloseBook(True)

2) | 座標形式によるセルの指定
Pos クラスにより、A1 セルを (0,0) として座標形式で読み書きを行うセルを指定することができます。

XlsCreator1.ReadBook(Applicaiotn.StartupPath & "\ExcelFile.xls", "")
objValue = XlsCreator1.Pos(1,1).Value  'B2 セルの値を取得
XlsCreator1.CloseBook(True)

3) | セル名によるセルの指定
Excel ファイルのセルにあらかじめ設定されたセル名を Cell クラスで指定することができます。

XlsCreator1.OpenBook(Applicaiotn.StartupPath & "\ExcelFile.xls", "")
XlsCreator1.Cell("NAME").Value = "アドバンスソフトウェア"
XlsCreator1.CloseBook(True)

4) | 変数名によるセルの指定
Excel ファイルのセルにあらかじめ記述した変数文字を Cell クラスで指定することができます。ExcelCreator 5.0 for .NET は、先頭に半角の * (アスタリスク) が 2 つ付いた文字列を変数文字として認識します。
変数名をオープンする Excel ファイルのセルに設定する場合、変数名として設定可能な文字列は、先頭の ** を含め 255 文字までです。但し、\ ' " , ^ . [] の半角文字は使用できません。

' オープンする Excel ファイルの A1 セルに「**Name」が設定されている場合
XlsCreator1.OpenBook(Applicaiotn.StartupPath & "\ExcelFile.xls", "")
XlsCreator1.Cell("**Name").Value = "アドバンスソフトウェア"
XlsCreator1.CloseBook(True)

また、変数名の先頭のアスタリスクの部分を、別の文字列を使用したい場合、 KeyWord プロパティを使用することで、変数名のキーワードとなる先頭の * (アスタリスク) を任意の文字列に変更することができます。先頭キーワード文字列は Excel で文字として認識可能で、かつ、半角文字のみ設定することができます。但し、\ ' " , ^ . [] の半角文字は使用できません。

' オープンする Excel ファイルの A1 セルに「!!ZipCode」が設定されている場合
XlsCreator1.Keyword = "!!"
XlsCreator1.OpenBook(Applicaiotn.StartupPath & "\ExcelFile.xls", "")
XlsCreator1.Cell("!!ZipCode").Value = "〒918-8237"
XlsCreator1.CloseBook(True)

新規作成、読み書きオープンやオーバーレイでオープンした Excel ファイルのセルに、文字列、数値(整数、実数)、object 型、計算式と計算結果を設定できます。
読み書きや読み込み専用でオープンした Excel ファイルではセルのデータを、文字列、数値(整数、実数)、object 型を取得できます。計算結果は数値で取得できます。

1) | データの設定

新規作成した Excel ファイルにデータを設定します

[VB.NET]
xlsCreator1.CreateBook(Application.StatupPath & "\ExcelFile.xls")

' 文字列を設定します
xlsCreator1.Cell("A1").Str = "アドバンスソフトウェア株式会社"

' 整数を設定します
xlsCreator1.Cell("A2").Long = 10000

' 実数を設定します
xlsCreator1.Cell("A3").Double = 156.79

' object 型を設定します
' セルには文字列で設定されます
xlsCreator1.Cell("A4").Value = "名前"
' セルには整数で設定されます
xlsCreator1.Cell("A5").Value = 25000

' 計算式と計算結果を設定します
xlsCreator1.Cell("A6").Func("=A2+A3", "10156.79")

xlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StatupPath + @"\ExcelFile.xls");

// 文字列を設定します
xlsCreator1.Cell("A1").Str = "アドバンスソフトウェア株式会社";

// 整数を設定します
xlsCreator1.Cell("A2").Long = 10000;

// 実数を設定します
xlsCreator1.Cell("A3").Double = 156.79;

// object 型を設定します
// セルには文字列で設定されます
xlsCreator1.Cell("A4").Value = "名前";
// セルには整数で設定されます
xlsCreator1.Cell("A5").Value = 25000;

// 計算式と計算結果を設定します
xlsCreator1.Cell("A6").Func("=A2+A3", "10156.79");

xlsCreator1.CloseBook(true);
2) | データの取得

既存の Excel ファイルをオープンし、セルのデータを取得します

[VB.NET]
XlsCreator1.ReadBook(Application.StatupPath & "\ExcelFile.xls")

' 文字列を取得します
Dim strData As String = XlsCreator1.Cell("A1").Str

' 整数を取得します
Dim nNumber As Integer = XlsCreator1.Cell("A2").Long

' 実数を取得します
Dim dblNumber As Double = XlsCreator1.Cell("A3").Double

' object 型を取得します
Dim objData As Object
' 文字列が設定セルのデータを取得すると、objData に文字列で取得されます
objData = XlsCreator1.Cell("A4").Value
' 数値が設定セルのデータを取得すると、objData に数値で取得されます
objData = XlsCreator1.Cell("A5").Value

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.ReadBook(Application.StatupPath + @"\ExcelFile.xls");

// 文字列を取得します
string strData = xlsCreator1.Cell("A1").Str;

// 整数を取得します
Int32 nNumber = xlsCreator1.Cell("A2").Long;

// 実数を取得します
double dblNumber = xlsCreator1.Cell("A3").Double;

// object 型を取得します
object objData;
// 文字列が設定セルのデータを取得すると、objData に文字列で取得されます
objData = xlsCreator1.Cell("A4").Value;
// 数値が設定セルのデータを取得すると、objData に数値で取得されます
objData = xlsCreator1.Cell("A5").Value;

xlsCreator1.CloseBook(true);

参照
[Str プロパティ] | [Long プロパティ] | [Double プロパティ] | [Value プロパティ] | [Func メソッド]


属性の設定

属性の設定

新規作成、読み書きオープンやオーバーレイでオープンした Excel ファイルのセルに書式を設定することができます。
例えば、データの条件によってセルの書式をプログラム中から設定することができます。

1) | 書式

新規作成した Excel ファイルのセルに書式を設定します

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)

XlsCreator1.Cell("A1").Str = "abcde"

' 指定セル内の文字列の水平位置を設定します
XlsCreator1.Cell("A1").Attr.PosHorz = ExcelCreator.xlPosHorz.phCenter
' セル内の文字列の垂直位置を設定します
XlsCreator1.Cell("A1").Attr.PosVert = ExcelCreator.xlPosVert.pvCenter
' セル内の文字列の回転角度を設定します
XlsCreator1.Cell("A1").Attr.PosTurn = ExcelCreator.xlPosTurn.ptTurn90

' セル内の列幅をこえる文字列を列幅で折り返して表示します
XlsCreator1.Cell("A2").Str = "abcdefghijklmnopqrstuvwxyz"
XlsCreator1.Cell("A2").Attr.OverReturn = True

' セル内の文字を縮小して全体を表示します
XlsCreator1.Cell("A3").Str = "ABCDEFGHIJKLMNO"
XlsCreator1.Cell("A3").Attr.Fit = True

' セルの結合を行います
XlsCreator1.Cell("A4:B4").Attr.Joint = True

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);

xlsCreator1.Cell("A1").Str = "abcde"

// 指定セル内の文字列の水平位置を設定します
xlsCreator1.Cell("A1").Attr.PosHorz = ExcelCreator.xlPosHorz.phCenter;
// セル内の文字列の垂直位置を設定します
xlsCreator1.Cell("A1").Attr.PosVert = ExcelCreator.xlPosVert.pvCenter;
// セル内の文字列の回転角度を設定します
xlsCreator1.Cell("A1").Attr.PosTurn = ExcelCreator.xlPosTurn.ptTurn90;

// セル内の列幅をこえる文字列を列幅で折り返して表示します
xlsCreator1.Cell("A2").Str = "abcdefghijklmnopqrstuvwxyz";
xlsCreator1.Cell("A2").Attr.OverReturn = True;

// セル内の文字を縮小して全体を表示します
xlsCreator1.Cell("A3").Str = "ABCDEFGHIJKLMNO";
xlsCreator1.Cell("A3").Attr.Fit = true;

// セルの結合を行います
xlsCreator1.Cell("A4:B4").Attr.Joint = true;

xlsCreator1.CloseBook(true);

2) | 書式 (フォント)

新規作成した Excel ファイルのセルにフォント書式を設定します

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)

XlsCreator1.Cell("A1").Str = "abcde"

' セルのフォントを設定します
XlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック"
' セルのフォントサイズを設定します
XlsCreator1.Cell("A1").Attr.FontPoint = 20
' セルのフォントの色を設定します
XlsCreator1.Cell("A1").Attr.FontColor = ExcelCreator.xlColor.xcRed
' セルのフォントスタイルを設定します
XlsCreator1.Cell("A1").Attr.FontStyle = ExcelCreator.xlFontStyle.xsBold
' セルのフォントの下線スタイルを設定します
XlsCreator1.Cell("A1").Attr.FontULine = ExcelCreator.xlFontULine.fuDouble

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);

xlsCreator1.Cell("A1").Str = "abcde"

' セルのフォントを設定します
xlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック";
' セルのフォントサイズを設定します
xlsCreator1.Cell("A1").Attr.FontPoint = 20;
' セルのフォントの色を設定します
xlsCreator1.Cell("A1").Attr.FontColor = ExcelCreator.xlColor.xcRed;
' セルのフォントスタイルを設定します
xlsCreator1.Cell("A1").Attr.FontStyle = ExcelCreator.xlFontStyle.xsBold;
' セルのフォントの下線スタイルを設定します
xlsCreator1.Cell("A1").Attr.FontULine = ExcelCreator.xlFontULine.fuDouble;

xlsCreator1.CloseBook(true);

参照
[PosHorz プロパティ] | [PosVert プロパティ] | [PosTurn プロパティ] | [OverReturn プロパティ] | [Fit プロパティ] | [Joint プロパティ]
[FontName プロパティ] | [FontPoint プロパティ] | [FontColor プロパティ] | [FontStyle プロパティ] | [FontULine プロパティ]


コピー/貼り付け/クリア/削除

コピー / 貼り付け / クリア / 削除

新規作成、読み書きオープンやオーバーレイでオープンした Excel ファイルのセルに対し、コピーや貼り付け、クリアの操作を行うことができます。
また、行や列にはコピー、貼り付け、削除、挿入の操作を行うことができます。

1) | セルのコピーや貼り付け、クリア

新規作成した Excel ファイルにセルのコピー、貼り付け、クリアを行います

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)

' セルコピー元を設定
XlsCreator1.Cell("A1:B1").Attr.Pattern = ExcelCreator.xlPattern.pn03
XlsCreator1.Cell("A1:B1").Str = "セルコピー元"

' セル範囲コピー (A1:B1 範囲セルを A2 セルにコピー)
XlsCreator1.Cell("A1:B1").Copy("A2")
' 単一セルコピー (A1 セルを C2 セルにコピー)
XlsCreator1.Cell("A1").Copy("C2")

' A1 セルをメモリ上にコピーし A3 セルに貼り付け
XlsCreator1.Cell("A1").Copy("")
XlsCreator1.Cell("A3").Paste()

' A1:B1 セルをクリアします
XlsCreator1.Cell("A1:B1").Clear()

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);

// セルコピー元を設定
xlsCreator1.Cell("A1:B1").Attr.Pattern = ExcelCreator.xlPattern.pn03;
XxsCreator1.Cell("A1:B1").Str = "セルコピー元";

// セル範囲コピー (A1:B1 範囲セルを A2 セルにコピー)
xlsCreator1.Cell("A1:B1").Copy("A2");
// 単一セルコピー (A1 セルを C2 セルにコピー)
xlsCreator1.Cell("A1").Copy("C2");

// A1 セルをメモリ上にコピーし A3 セルに貼り付け
xlsCreator1.Cell("A1").Copy("");
xlsCreator1.Cell("A3").Paste();

// A1:B1 セルをクリアします
xlsCreator1.Cell("A1:B1").Clear();

xlsCreator1.CloseBook(true);
2) | 行や列のコピー、貼り付け、削除、挿入

新規作成の Excel ファイルに行のコピー、貼り付け、削除、挿入を行います

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)

' コピー元を設定
XlsCreator1.Cell("A1:B1").Attr.Pattern = ExcelCreator.xlPattern.pn03
XlsCreator1.Cell("A1:B1").Str = "コピー元"

' 1 行目を 20 行目に行コピー
XlsCreator1.RowCopy(0, 19)
' 1 行目をメモリ上に行コピーし、21 行目に貼り付け
XlsCreator1.RowCopy(0, -1)
XlsCreator1.RowPaste(20)

' 単一行の挿入 (2 行目から 1 行)
XlsCreator1.RowInsert(1, 0)
' 複数行の挿入 (2 行目から 2 行分)
XlsCreator1.RowInsert(1, 2)

' 単一行の削除 (2 行目から 1 行)
XlsCreator1.RowDelete(1, 0)
' 複数行の削除 (2 行目から 2 行分)
XlsCreator1.RowDelete(1, 2)

' 単一行のクリア (2 行目から 1 行)
XlsCreator1.RowClear(1, 0)
' 複数行のクリア (2 行目から 2 行分)
XlsCreator1.RowClear(1, 2)

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);

// コピー元を設定
xlsCreator1.Cell("A1:B1").Attr.Pattern = ExcelCreator.xlPattern.pn03;
xlsCreator1.Cell("A1:B1").Str = "コピー元";

// 1 行目を 20 行目に行コピー
xlsCreator1.RowCopy(0, 19);
// 1 行目をメモリ上に行コピーし、21 行目に貼り付け
xlsCreator1.RowCopy(0, -1);
xlsCreator1.RowPaste(20);

// 単一行の挿入 (2 行目から 1 行のみ挿入)
xlsCreator1.RowInsert(1, 0);
// 複数行の挿入 (2 行目から 2 行分挿入)
xlsCreator1.RowInsert(1, 2);

// 単一行の削除 (2 行目から 1 行のみ削除)
xlsCreator1.RowDelete(1, 0);
// 複数行の削除 (2 行目から 2 行分削除)
xlsCreator1.RowDelete(1, 2);

// 単一行のクリア (2 行目から 1 行)
xlsCreator1.RowClear(1, 0);
// 複数行のクリア (2 行目から 2 行分)
xlsCreator1.RowClear(1, 2);

xlsCreator1.CloseBook(true);

新規作成の Excel ファイルに列のコピー、貼り付け、削除、挿入を行います

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)

' コピー元を設定
XlsCreator1.Cell("A1:G1").Attr.Pattern = ExcelCreator.xlPattern.pn03
XlsCreator1.Cell("A1:G1").Str = "コピー元"

' 1 列目を 20 列目に列コピー
XlsCreator1.ColumnCopy(0, 19)
' 1 列目をメモリ上に行コピーし、21 列目に貼り付け
XlsCreator1.ColumnCopy(0, -1)
XlsCreator1.ColumnPaste(20)

' 単一列の挿入 (B 列から 1 列のみ)
XlsCreator1.ColumnInsert(1, 1)
' 複数列の挿入 (B 列から 2 列分)
XlsCreator1.ColumnInsert(1, 2)

' 単一列の削除 (E 列のみ)
XlsCreator1.ColumnDelete(4, -1)
'複数列の削除 (E 列から 2 列分)
XlsCreator1.ColumnDelete(4, 2)

'単一列のクリア (E 列のみ)
XlsCreator1.ColumnClear(4, -1)
'複数列のクリア (E 列から 2 列分)
XlsCreator1.ColumnClear(4, 2)

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);

' コピー元を設定
xlsCreator1.Cell("A1:G1").Attr.Pattern = ExcelCreator.xlPattern.pn03;
xlsCreator1.Cell("A1:G1").Str = "コピー元";

' 1 列目を 20 列目に列コピー
xlsCreator1.ColumnCopy(0, 19);
' 1 列目をメモリ上に行コピーし、21 列目に貼り付け
xlsCreator1.ColumnCopy(0, -1);
xlsCreator1.ColumnPaste(20)

' 単一列の挿入 (B 列から 1 列のみ)
xlsCreator1.ColumnInsert(1, 1);
' 複数列の挿入 (B 列から 2 列分)
xlsCreator1.ColumnInsert(1, 2);

' 単一列の削除 (E 列のみ)
xlsCreator1.ColumnDelete(4, -1);
'複数列の削除 (E 列から 2 列分)
xlsCreator1.ColumnDelete(4, 2);

'単一列のクリア (E 列のみ)
xlsCreator1.ColumnClear(4, -1);
'複数列のクリア (E 列から 2 列分)
xlsCreator1.ColumnClear(4, 2);

xlsCreator1.CloseBook(true);

参照
[Copy メソッド] | [Paste メソッド] | [Clear メソッド] | [RowCopy メソッド] | [RowPaste メソッド] | [RowInsert メソッド] | [RowDelete メソッド] | [RowClear メソッド] | [ColumnCopy メソッド] | [ColumnPaste メソッド] | [ColumnInsert メソッド] | [ColumnDelete メソッド] | [ColumnClear メソッド]


PDF ファイルの出力

PDF ファイルの出力

CloseBook、CloseBookEx メソッド実行時に作成や編集を行った Excel ファイルを元に PDF ファイルへ出力できます。
PDF ファイルの出力先は、ファイル名 [String クラス] と [System.IO.Stream クラス] で行います。

1) ファイル名 [String クラス]
CloseBook、CloseBookEx メソッド実行時に PDF ファイル名を文字列 [String クラス] で指定し、PDF ファイル出力を行います。
指定したディスクドライブやフォルダ、ファイル名で PDF ファイルを出力することができます。

新規作成した Excel ファイルを PDF ファイルに出力します
新規作成した Excel ファイルはクローズ時に削除します

[VB.NET]
XlsCreator1.CreateBook(Application.StatupPath & "\ExcelFile.xls")
XlsCreator1.Cell("C2").Value = "アドバンスソフトウェア株式会社"
XlsCreator1.CloseBook(True, Application.StatupPath & "\PDFFile.pdf", True)

[C#]
xlsCreator1.CreateBook(Application.StatupPath + @"\ExcelFile.xls");
xlsCreator1.Cell("C2").Value = "アドバンスソフトウェア株式会社";
xlsCreator1.CloseBook(true, Application.StatupPath + @"\PDFFile.pdf", true);

ExcelTemplate.xls をオーバーレイ元ファイルとし、
作成した Excel ファイルを PDF ファイルに出力します
作成した Excel ファイルは削除しません

[VB.NET]
XlsCreator1.OpenBook(Application.StatupPath & "\ExcelFile.xls", _
                     Application.StatupPath & "\ExcelTemplate.xls")
XlsCreator1.Cell("C2").Value = "アドバンスソフトウェア株式会社"
XlsCreator1.CloseBook(True, Application.StatupPath & "\PDFFile.pdf", False)

[C#]
xlsCreator1.OpenBook(Application.StatupPath + @"\ExcelFile.xls",
                     Application.StatupPath + @"\ExcelTemplate.xls");
xlsCreator1.Cell("C2").Value = "アドバンスソフトウェア株式会社";
xlsCreator1.CloseBook(true, Application.StatupPath + @"\PDFFile.pdf", false);
2) System.IO.Stream クラス
CloseBook、CloseBookEx メソッド実行時に PDF ファイル名を [System.IO.Stream クラス] で指定し、PDF ファイル出力を行います。
[System.IO.Stream クラス] で指定することにより、アプリケーション上で定義した [System.IO.Stream クラス] の変数に PDF ファイルを出力することができます。
ここでは、[System.IO.FileStream クラス] と [System.IO.MemoryStream クラス] の変数に PDF ファイルを出力するコーディング例を掲載しています。

新規作成した Excel ファイルを [System.IO.FileStream クラス] の変数に PDF ファイルに出力します
新規作成した Excel ファイルはクローズ時に削除します

[VB.NET]
Dim fileStm As System.IO.FileStream
fileStm = New System.IO.FileStream(Application.StartupPath & "\PdfFile01.xls", IO.FileMode.OpenOrCreate)

XlsCreator1.CreateBook(Application.StatupPath & "\ExcelFile01.xls")
XlsCreator1.Cell("C2").Value = "アドバンスソフトウェア株式会社"
XlsCreator1.CloseBook(True, fileStm, True)

fileStrm.Close()

[C#]
System.IO.FileStream fileStrm = new FileStream(Application.StartupPath + @"\PdfFile01.xls", FileMode.OpenOrCreate);

xlsCreator1.CreateBook(Application.StatupPath + @"\ExcelFile01.xls");
xlsCreator1.Cell("C2").Value = "アドバンスソフトウェア株式会社";
xlsCreator1.CloseBook(true, fileStrm, true);

fileStrm.Close();

ExcelTemplate.xls をオーバーレイ元ファイルとし、
作成した Excel ファイルを [System.IO.MemoryStream クラス] の変数に PDF ファイルに出力します
作成した Excel ファイルは削除しません

[VB.NET]
Dim memStm As System.IO.MemoryStream
memStm = New System.IO.MemoryStream

XlsCreator1.OpenBook(Application.StatupPath & "\ExcelFile02.xls", _
                     Application.StatupPath & "\ExcelTemplate.xls")
XlsCreator1.Cell("C2").Value = "アドバンスソフトウェア株式会社"
XlsCreator1.CloseBook(True, memStm, False)

memStrm.Close()

[C#]
System.IO.MemoryStream memStrm = new MemoryStream();

xlsCreator1.OpenBook(Application.StatupPath + @"\ExcelFile02.xls",
                     Application.StatupPath + @"\ExcelTemplate.xls");
xlsCreator1.Cell("C2").Value = "アドバンスソフトウェア株式会社";
xlsCreator1.CloseBook(true, memStrm, false);

memStrm.Close();

参照
[CloseBook メソッド] | [CloseBookEx メソッド]


ExcelCreator 5.0 for .NET コンポーネント機能一覧

F ExcelCreator 5.0 for .NET コンポーネント機能一覧
ExcelCreator 5.0 for .NET コンポーネント機能一覧

ExcelCreator
新規作成オープン
 | CreateBook メソッド | Excel ファイルの新規作成を行います。
 | CreateBookEx メソッド | Excel ファイルを新規作成し、その識別 ID を取得します。(SelectBook メソッド専用)
読み書きオープン / オーバーレイオープン
 | OpenBook メソッド | 既存 Excel ファイルをオープンします。既存の Excel ファイルを元に別の Excel ファイルをオープンすることもできます。
 | OpenBookEx メソッド | 既存 Excel ファイルをオープンし、その識別 ID を取得します。既存の Excel ファイルを元に別の Excel ファイルをオープンすることもできます。(SelectBook メソッド専用)
埋め込み Excel ファイルオーバーレイオープン
 | OpenBookEmbed メソッド | リソースに埋め込まれたバイナリデータを既存 Excel ファイルとしてオープンます。既存の Excel ファイルを元に別の Excel ファイルをオープンすることもできます。
 | OpenBookEmbedEx メソッド | リソースに埋め込まれたバイナリデータを既存 Excel ファイルとしてオープンし、その識別 ID を取得します。既存の Excel ファイルを元に別の Excel ファイルをオープンすることもできます。(SelectBook メソッド専用)
読み込みオープン
 | ReadBook メソッド | 既存 Excel ファイルを読み込み専用でオープンします。
 | ReadBookEx メソッド | 既存 Excel ファイルを読み込み専用でオープンし、その識別 ID を取得します。(SelectBook メソッド専用)
Excel ファイルのクローズ / PDF ファイル出力
 | CloseBook メソッド | Excel ファイルのクローズ、または破棄を行います。PDF ファイル出力も行うことができます。
 | CloseBookEx メソッド | CreateBookEx / ReadBookEx / OpenBookEx / OpenBookEmbedEx で Excel ファイルを操作した場合に、Excel ファイルのクローズ、または破棄を行います。PDF ファイル出力も行うことができます。(SelectBook メソッド専用)
Excel ファイル選択
 | SelectBook メソッド | CreateBookEx / ReadBookEx / OpenBookEx / OpenBookEmbedEx で Excel ファイルを操作する場合に、操作対象となる Excel ファイルの選択を行います。
エラー取得
 | ErrorNo プロパティ | エラー番号を取得します。
 | ErrorMessage プロパティ | エラーメッセージを取得します。
Excel ファイル全体
 | DefFontName プロパティ | Excel ファイル全シートのデフォルトフォント名を設定します。
 | DefFontPoint プロパティ | Excel ファイル全シートのデフォルトフォントサイズを設定します。
 | ModeGrid プロパティ | グリッド線の表示 / 非表示の設定します。
 | Zoom プロパティ | シートの表示倍率を設定します。
 | KeyWord プロパティ | 変数名の先頭キーワード文字列を設定します。
 | VarCheck プロパティ | オーバーレイ元ファイルにある変数名をチェックします。
 | VarInsertMode プロパティ | オーバーレイ元ファイルのセル変数名への差し込みモードを設定します。
シート
 | AddSheet メソッド | Excel ファイルに新規シートを追加します。
 | DelSheet メソッド | シートを削除します。
 | CopySheet メソッド | シートを設定した場所にコピーします。
 | ActiveSheet プロパティ | アクティブ シートをシート番号を取得、または、設定します。
 | SheetCount プロパティ | Excel ファイルのシート総数を取得します。
 | RefSheet プロパティ | 参照するシート名を設定します。
 | SheetNo プロパティ | 操作対象となるシートの選択を行います。
 | SheetNo2 プロパティ | シート名からシート番号を取得します。
 | SheetName プロパティ | シート名の取得、または、設定します。
 | SheetName2 プロパティ | シート番号からシート名を取得します。
行・列コピー
 | RowCopy メソッド | 行をコピーします。
 | RowPaste メソッド | RowCopy メソッドでコピーした行を貼り付けます。
 | RowDelete メソッド | 行を削除します。
 | RowClear メソッド | 行をクリア (初期化) します。
 | RowInsert メソッド | 行を挿入します。
 | ColumnCopy メソッド | 列をコピーします。
 | ColumnPaste メソッド | ColumnCopy メソッドでコピーした列を貼り付けます。
 | ColumnDelete メソッド | 列を削除します。
 | ColumnClear メソッド | 列をクリア (初期化) します。
 | ColumnInsert メソッド | 列を挿入します。
印刷設定
 | Size メソッド | 用紙情報の設定を行います。
 | SizeFree メソッド | ユーザー定義用紙の設定を行います。
 | Margin メソッド | シート単位にページ余白の設定を行います。
 | Center プロパティ | ページ中央を設定します。
 | PageOrder プロパティ | ページの印刷方向を設定します。
 | PrintArea メソッド | シートの印刷範囲を設定します。
 | Header メソッド | シートのヘッダーを設定します。
 | Footerメソッド | シートのフッタを設定します。
範囲取得
 | MaxData メソッド | データ (文字列 / 値 / 計算式) が設定されているセルの最終座標を取得します。
 | MaxArea メソッド | データ (文字列 / 値 / 計算式) の他、罫線やセルの塗りつぶし等のセル書式が設定されている、最終セルの座標を取得します。
イベント
 | Error イベント | ExcelCreator 5.0 for .NET の実行時に不正な処理を行った場合に発生します。
 | Progress イベント | PDF ファイル出力時の処理状況を通知します。

セルの属性
Cell クラス : 出力対象となるセルの範囲をセル位置 (A1 参照形式) / 変数名 / セル名で設定します。
Pos クラス : 出力対象となるセルの範囲を座標形式で設定します。

値の取得・設定
 | Value プロパティ | 数値や文字列、日付などの値を設定 / 取得します。
 | Str プロパティ | 文字列を取得 / 設定します。
 | Long プロパティ | 整数を取得 / 設定します。
 | Double プロパティ | 実数を取得 / 設定します。
 | AttrNo プロパティ | セルの属性番号を取得します。
 | Value2 メソッド | 数値や文字列、日付などの値と属性番号を設定します。
 | Str2 メソッド | 文字列と属性番号を設定します。
 | Long2 メソッド | 整数と属性番号を設定します。
 | Double2 メソッド | 実数と属性番号を設定します。
 | Func メソッド | 関数の書き込みをします。結果を示す値も同時に設定できます。
セルコピー・貼り付け、初期化
 | Copy メソッド | セルをコピーします。
 | Paste メソッド | Copy メソッドでコピーしたセルを貼り付けます。
 | Clear メソッド | セルをクリア (初期化) します。
改ページの設定、セル幅・高さの取得・設定
 | Break プロパティ | 改ページの設定 / 解除を設定します。
 | ColWidth プロパティ | セルの幅を設定します。
 | RowHeight プロパティ | セルの高さを設定します。
 | ColWidth2 プロパティ | セルの幅を取得 / 設定します。
 | RowHeight2 プロパティ | セルの高さを取得 / 設定します。
Cell/Pos.Attr クラス : セルの属性を設定します。
表示形式
Format プロパティ 表示書式を設定します。
配置
 | PosHorz プロパティ | 文字の配置 (横位置) を設定します。
 | PosVert プロパティ | 文字の配置 (縦位置) を設定します。
 | PosTurn プロパティ | 文字方向 (角度) を設定します。
 | OverReturn プロパティ | 「折り返して全体を表示」を設定します。
 | Fit プロパティ | 「縮小して全体を表示する」を設定します。
 | Joint プロパティ | 指定範囲のセルに「セルを結合する」を設定します。
フォント
 | FontName プロパティ | フォント名を設定します。
 | FontPoint プロパティ | フォントサイズを設定します。
 | FontColor プロパティ | フォント色を設定します。
 | FontStyle プロパティ | フォントスタイルを設定します。
 | FontULine プロパティ | フォントの下線スタイルを設定します。
罫線
 | LineTop プロパティ | 上罫線を設定します。
 | LineBottom プロパティ | 下罫線を設定します。
 | LineLeft プロパティ | 左罫線を設定します。
 | LineRight プロパティ | 右罫線を設定します。
 | LineLeftUp プロパティ | 左上罫線を設定します。
 | LineRightUp プロパティ | 右上罫線を設定します。
 | Box メソッド | 設定したセル領域を囲む Box 罫線を設定します。
パターン
 | Pattern プロパティ | パターンを設定します。
 | BackColor プロパティ | 背景色を設定します。

PDF
PDF クラス : 出力する PDF ファイルの各種設定を行います。

Title プロパティ | 文書プロパティの概要 [タイトル] を設定します。
Subject プロパティ | 文書プロパティの概要 [サブタイトル] を設定します。
Producer プロパティ | 文書プロパティの概要 [PDF 変換] を設定します。
Creator プロパティ | 文書プロパティの概要 [アプリケーション] を設定します。
Author プロパティ | 文書プロパティの概要 [作成者] を設定します。
EmbedFonts プロパティ | 埋め込むフォントを設定します。
ImageType プロパティ | イメージの種類を設定します。
ProgressDialog プロパティ | 処理経過を表示するプログレスダイアログの表示 / 非表示を設定します。


ExcelCreator 5.0 for .NET - コンポーネントの登録について -

コンポーネントの登録について

ExcelCreator 5.0 for .NET が提供する以下のコンポーネントのグローバルアセンブリキャッシュへの登録は、ExcelCreator 5.0 for .NET のインストーラが自動で行います。また、アンインストール時には自動で登録の解除を行います。

・ | ExcelCreator.dll | コンポーネント本体
・ | ExcelCreator.XlsCrt.dll | ExcelCreator 生成エンジン
・ | ExcelCreator.XlsPDF.dll | PDF ファイル生成エンジン
・ | XlsCrtNet5.dll | 下位互換エンジン (旧バージョン ExcelCreator .NET)

ExcelCreator 5.0 for .NET のインストーラによるグローバルアセンブリキャッシュへの登録が自動で行われなかった場合は、次の方法でコンポーネントのグローバルアセンブリキャッシュへの登録 / 解除を行ってください。
グローバルアセンブリキャッシュへの登録 / 解除の詳細については、Visual Studio .NET のオンラインヘルプを参照してください。

・グローバルアセンブリキャッシュへ登録する方法

・ | エクスプローラを使って登録します。
 | エクスプローラ上で、コンポーネントをグローバルアセンブリキャッシュフォルダ ( 例：C:\WINDOWS\assembly、Windows2000 の場合は C:\WINNT\assembly ) にドラッグ＆ドロップします。

・グローバルアセンブリキャッシュから登録を解除する方法

・ | エクスプローラを使って登録を解除します。
 | エクスプローラ上で、グローバルアセンブリキャッシュフォルダ (例：C:\WINDOWS\assembly、Windows2000 の場合は C:\WINNT\assembly) を開きます。次に、コンポーネントを選択し、右メニューの[削除]をクリックしてください。

・以前のバージョンのコンポーネントを使用する方法

ExcelCreator 5.0 for .NET のアップデートモジュールでは、常に最新のコンポーネントを利用出来る様、最新のコンポーネントの再配置とグローバルアセンブリキャッシュへの再登録を自動的に行います。
しかし、過去のプロジェクトをリビルドするなど、以前のバージョンのコンポーネントを使用する必要がある場合には、以下の手順でコンポーネントを切り替えてください。

変更の操作において、Visual Studio .NET の [ツールボックス] へ、ExcelCreator 5.0 for .NET コンポーネントの削除と追加を行います。
[ツールボックス] の削除と追加を行うための、Visual Studio .NET 2002 / Visual Studio .NET 2003 の [ツールボックスのカスタマイズ] 画面、Visual Studio 2005 の [ツールボックス アイテムの選択] 画面を開く操作は、以下の方法で行ってください。

・ | Visual Studio 2005 の場合
 | メニュー [ツール]-[ツールボックス アイテムの選択] をクリックして [ツールボックス アイテムの選択] 画面を開きます。
・ | ・Visual Studio .NET 2003 の場合
 | メニュー [ツール]-[ツールボックスのカスタマイズ] をクリックして [ツールボックスのカスタマイズ] 画面を開きます。
・ | Visual Studio .NET 2002 の場合
 | メニュー [ツール]-[ツールボックス アイテムの追加と削除] をクリックして [ツールボックスのカスタマイズ] 画面を開きます。

ここでは、Ver5.0.0.1716 から Ver5.0.0.1628 の ExcelCreator 5.0 for .NET コンポーネントへ変更すると仮定しています。

1) | Visual Studio .NET の [ツールボックス] から、ExcelCreator 5.0 for .NET コンポーネントを削除します。 [ツールボックスのカスタマイズ] 画面、もしくは、[ツールボックス アイテムの選択] 画面の [.NET Framework コンポーネント] タブの [XlsCreator] のチェックをオフにし、Visual Studio .NET を終了してください。 Visual Studio .NET 2002 、Visual Studio .NET 2003 、Visual Studio 2005 が共存する場合は、全バージョンのチェックボックスのチェックをオフにしてください。 ※Visual Studio 2005 の画面です。
2) | ExcelCreator 5.0 for .NET インストールフォルダ内の Bin フォルダにインストールされている unregGAC.bat を実行します。 ExcelCreator 5.0 for .NET コンポーネントが、グローバルアセンブリキャッシュから削除されます。
3) | ExcelCreator 5.0 for .NET インストールフォルダ内の Bin フォルダの直下にある以下のファイルを削除します。 ExcelCreator.dll ExcelCreator.XlsCrt.dll ExcelCreator.XlsPDF.dll
4) | 使用するバージョンのバックアップフォルダ内にある下記ファイルを、ExcelCreator 5.0 for .NET インストールフォルダ内の Bin フォルダへコピーします。 ExcelCreator.dll ExcelCreator.XlsCrt.dll ExcelCreator.XlsPDF.dll
5) | ExcelCreator 5.0 for .NET インストールフォルダ内の Bin フォルダにインストールされている regGAC.bat を実行します。 ExcelCreator 5.0 for .NET コンポーネントが、グローバルアセンブリキャッシュへ登録されます。
6) | Visual Studio .NET の [ツールボックス] に、ExcelCreator 5.0 for .NET コンポーネントを登録します。 [ツールボックスのカスタマイズ] 画面、もしくは、[ツールボックス アイテムの選択] 画面の [.NET Framework コンポーネント] タブの [XlsCreator] のチェックをオンにします。 Visual Studio .NET 2002 、Visual Studio .NET 2003 、Visual Studio 2005 が共存する場合は、全バージョンのチェックボックスのチェックをオンにしてください。 ※Visual Studio 2005 の画面です。

・注意事項
・ | コンポーネントの切り替えは、1 の操作を必ず行い、ExcelCreator 5.0 for .NET コンポーネントが Visual Studio .NET の [ツールボックス] に登録されていない状態 (チェックがオフ) で行ってください。
・ | コンポーネントが [ツールボックス] に登録されている状態でアセンブリの切り替えを行った場合、プロジェクトのビルド時にエラーが発生する場合があります。その場合、[ツールボックスのカスタマイズ] 画面、もしくは、[ツールボックス アイテムの選択] 画面の [.NET Framework コンポーネント] タブにて、使用するコンポーネントのチェックをオン、使用しないコンポーネントのチェックをオフにしてください。

グローバルアセンブリキャッシュへの登録や解除の詳細については、Visual Studio .NET のオンラインヘルプを参照してください。


新しいページ 1

アプリケーションの配布について

ExcelCreator 5.0 for .NET を組み込んだアプリケーションを配布する場合、以下のファイルを実行環境に配布する必要があります。

再配布可能ファイル (ExcelCreator 5.0 for .NET コンポーネント)
ファイル | 内容 | 場所
ExcelCreator.dll | コンポーネント本体 | <ExcelCreator 5.0 for .NET インストールフォルダ>\bin
ExcelCreator.XlsCrt.dll | ExcelCreator 生成エンジン | <ExcelCreator 5.0 for .NET インストールフォルダ>\bin
ExcelCreator.XlsPDF.dll | PDF ファイル生成エンジン | <ExcelCreator 5.0 for .NET インストールフォルダ>\bin

再配布可能ファイル (ExcelCreator .NET クラス)
ファイル | 内容 | 場所
XlsCrtNet5.dll | 旧バージョン ExcelCreator .NET 下位互換エンジン | <ExcelCreator 5.0 for .NET インストールフォルダ>\bin

注意点
ExcelCreator 5.0 for .NET の使用許諾に基づき、アプリケーションの種類によってライセンス体系が異なります。
詳しくは、アプリケーションのライセンス体系を参照してください。

[配布先の環境]

・ | .NET Framework 再配布可能パッケージのインストール
 | .NET Framework 対応のアプリケーションを実行するために必要な .NET Framework 再配布可能パッケージが、インストールされている必要があります。パッケージの入手・配布方法等の詳細は、Visual Studio .NET のオンラインマニュアルを参照してください。
・ | C ランタイムファイル (MSVCR71.dll) の配布
 | .NET Framework 1.0 (SP3)、もしくは .NET Framework 2.0 のみがインストールされた環境の場合、C ランタイムファイルを開発環境からコピーして配布する必要があります。 C ランタイムファイル は、アプリケーションと同一フォルダ、またはシステムフォルダに配布してください。

[配布方法]

再配布可能なファイルの配布方法は、次の 2 種類があります。

1) 任意のフォルダに配置し、グローバルアセンブリキャッシュへ登録する。
2) アプリケーションと同一フォルダに配置する。
ASP.NET 2.0 を使用する Web アプリケーションを配布する場合、再配布可能なファイルの配布は 1 の方法で行ってください。
グローバルアセンブリキャッシュへの登録は、次のいずれかの方法で登録を行ってください。

・ | グローバルアセンブリキャッシュツール (gacutil.exe) を使用する
 | .NET Framework SDK のグローバルアセンブリキャッシュツール (gacutil.exe) を使用して、グローバルアセンブリキャッシュに ExcelCreator 5.0 for .NET コンポーネントや ExcelCreator .NET クラスを登録します。コマンドプロンプトまたは［ファイル名を指定して実行］ダイアログボックスで以下のように実行します。 (登録例) C:\gacutil.exe /i "C:\Program Files\Application\ExcelCreator.dll" 登録例は、gacutil.exe が C ドライブのルートに存在し、ExcelCreator 5.0 for .NET コンポーネント (ExcelCreator.dll) が C:\Program Files\Application フォルダにあると仮定しています。
・ | エクスプローラ (Windows Explorer) 上で、グローバルアセンブリキャッシュフォルダ (例：[C:\Windows\assembly]) にドラッグ＆ドロップする。

また、登録の解除方法は下記の通りです。

・ | グローバルアセンブリキャッシュツール (gacutil.exe) を使用する
 | 登録時と同様にグローバルアセンブリキャッシュツールを使用して、グローバルアセンブリキャッシュから ExcelCreator 5.0 for .NET コンポーネントや ExcelCreator .NET クラスを解除します。コマンドプロンプトまたは［ファイル名を指定して実行］ダイアログボックスで以下のように実行します。 (登録の解除例) C:\gacutil.exe /u "C:\Program Files\Application\ExcelCreator" 登録の解除は、dll ファイル名ではなくアセンブリ名を指定することに注意してください。
・ | エクスプローラ (Windows Explorer) 上で、グローバルアセンブリキャッシュフォルダ (例：[C:\Windows\assembly]) を参照し、任意のアセンブリを選択して右クリックのメニュー [削除]、または、キーボードの [Del] キーで削除する。

登録および登録の解除時は、Administrator 権限でログオンしておく必要があります。
グローバルアセンブリキャッシュツールやグローバルアセンブリキャッシュの登録や解除方法の詳細については、Visual Studio .NET のオンラインヘルプを参照してください。


サポートサービスについて

サポートサービスについて

・ ユーザー登録について
サポートサービスをご利用いただくにあたり、製品のユーザー登録が必要になります。登録されていない場合は、サポートサービスを利用できませんので、お問合せいただく前に必ずユーザー登録を行ってください。

・ユーザー登録方法
 製品に同梱されているユーザー登録カードに、必要事項を記入してご郵送ください。
また、弊社ホームページ (http://www.adv.co.jp/) のユーザー登録ページからもご登録いただくことができます。
・ サポートサービスについて
本製品の ReadMe、および、ヘルプに記述されていない事項、または動作に関するご不明な点などについては、サポートサービスをご利用ください。
本製品のサポートサービスは以下のサービスで構成されています。

■E-Mail サポート
■電話サポート
■FAX サポート
・ お問い合わせについて
ExcelCreator 5.0 for .NET 以外の事柄やプログラミング技法など一般的なご質問、または、動作保証環境外での使用によるご質問にはお答えいたしかねます。あらかじめ、ご了承ください。
・ お問い合わせになる前に
サポートサービスでは下記の情報が必要になります。
お問い合わせいただく前に、あらかじめこれらの情報をご用意ください。

・ユーザー情報の内容

1) | ExcelCreator 5.0 for .NET のシリアルナンバー (製品 CD-ROM ケース裏面のシールをご覧ください)
2) | 会社名
3) | 部署名
4) | 担当者名
5) | 連絡先(電話番号)
6) | FAX 番号
7) | E-Mail アドレス

・お問い合わせ内容

1) | 製品名 (ExcelCreator 5.0 for .NET)
2) | ExcelCreator 5.0 for .NET の詳細バージョン
3) | 使用マシンの OS
4) | OS のサービスパック (Windows NT4.0 / 2000 / XP の場合)
5) | .NET Framework とサービスパックのバージョン
6) | Visual Studio .NET とサービスパックのバージョン

・問題となっている現象の内容

1) | 現象の詳細内容
2) | 現象発生までの経緯
3) | 現象の発生箇所
4) | 現象を再現できる簡単なプロジェクト一式、もしくは、コーディングの一部

なお、お問い合わせの前に、以下の資料をご確認ください。回答となる情報が含まれている場合もあります。

・FAQ
・弊社のサポートページ
・ お問い合わせ窓口

・製品の操作方法や仕様に関するお問い合わせ窓口
電話番号 | : | 0776-21-9172
FAX 番号 | : | 0776-21-9022
E-Mail | : | xlscrt@adv.co.jp
受付時間 | : | 10：00 ～ 12：00 / 13：30 ～ 17：00

・製品の営業に関するお問い合わせ窓口
電話番号 | : | 0776-21-9008
FAX 番号 | : | 0776-21-9022
E-Mail | : | info@adv.co.jp
受付時間 | : | 9：00 ～ 12：00 / 13：00 ～ 18：00

月曜日～金曜日 (祝祭日、弊社特別休業日を除く) にご利用いただけます。
※営業日以外にいただいた FAX/E-Mail でのお問い合わせは、翌営業日に回答いたます。


ExcelCreator 5.0 for .NET FAQ

ExcelCreator 5.0 for .NET FAQ

全般
体験版がインストールされた環境に、体験版をアンインストールせずに、製品版をインストールしても良いでしょうか。
ExcelCreator 5.0 for .NET の体験版で作成したアプリケーションを、ExcelCreator 5.0 for .NET 製品版に置き換えても、問題無く使用可能でしょうか。
ExcelCreator 5.0 for .NET 製品 CD-ROM に収録された ExcelCreator Ver3.0 をインストールしたいのですが、シリアル№が分かりません。
ExcelCreator 5.0 for .NET 製品 CD-ROM に同梱されている ExcelCreator Ver3.0 のライセンスやサポートサービス内容について教えてください。
ExcelCreator .NET がインストールされた環境に ExcelCreator 5.0 for .NET をインストールしても良いでしょうか。
PDF ファイルの作成に失敗する。または、作成した PDF ファイルを開くことができない。

動作環境
日本語環境以外の OS や開発言語での使用について。
ExcelCreator 5.0 for .NET は Excel やAccess の VBA で使用することができますか。
ターミナルサーバー(TerminalServer(Service))/メタフレーム(MetaFrame)環境での動作に対応していますか。
.NET Framework 1.0 SP3 、.NET Framework 2.0 のみがインストールされた環境で ExcelCreator 5.0 for .NET を組み込んだアプリケーションが実行できない。
ノータッチ デプロイメントには対応していますか。
ClickOnce には対応していますか。

互換性
ExcelCreator 5.0 for .NET と VB-Report 5.0 for .NET との違いについて。
ExcelCreator .NET との互換性はありますか。
ActiveX 版の Excel クリエーター Ver2 (旧バージョン) や ExcelCreator Ver3.0 との互換性はありますか。

設定
Excel ファイルの行数と列数に制限はありますか。
Excel ファイルのシート数に制限はありますか。
グラフ付きのシートに対応していますか。
色の設定で、列挙体にあるメンバ以外の色を設定する方法について。
行や列を非表示にする方法について。
印刷範囲の設定について。
改ページの設定について。
表示パーセントの設定について。
改行コード (CR+LF [0x0D 0x0A]) を含めた文字列の設定について。
シングルクォート (') を先頭につけた文字列の設定について。
アスタリスク (*) を先頭に2つ以上つけた文字列の設定について。
結合セルに罫線等の属性を設定する場合の注意点。
テキストボックスに変数名を設定し、ExcelCreator 5.0 for .NET でデータを設定することはできますか。

Excel の機能 / ExcelCreator 5.0 for .NET の制限
保護ブック / シートについて。
マクロの編集と実行。
シート / ブック間のコピーについて。
印刷タイトル (行タイトル / 列タイトル) について。
セルサイズの設定について。
画像の貼り付けについて。
ハイパーリンクについて。
条件付き書式について。
書式情報の取得について。
シート削除後にファイルサイズが減少しない。
「表示形式を追加できません」のエラーメッセージが発生する。
行追加 / 削除等でオブジェクトが移動しない。
計算方法が手動から自動に変わる。
シート削除ができない条件。
シートコピーができない条件。
計算式の計算結果について。
行・列の挿入 (RowInsert / ColumnInsert) やコピー (RowCopy / ColumnCopy) 、貼り付け (RowPaste / ColumnPaste) における、Excel との動作の違いについて。

Web
Web アプリケーションとして使用したい。
Web アプリケーションのサンプルプログラムはありますか。
既存の Excel ファイルのオープンやファイル保存ができない現象について。

ExcelCreator .NET クラス
新バージョンで追加された機能について。
新バージョンのライセンスについて。

サーバーライセンス
2 台のサーバー機を準備し、1 台はトラブル用のバックアップ機として使用する場合、サーバーライセンスは 2 本必要でしょうか。
デバッグや動作確認の目的で開発環境をサーバー機として使用する場合、サーバーライセンスは必要でしょうか。
配布先のサーバー機が 2CPU タイプの場合、サーバーライセンスは 2 本必要でしょうか。
ターミナルサーバー(TerminalServer(Service))/メタフレーム(MetaFrame)環境にプログラムを配布する場合、サーバーライセンスの必要本数を教えてください。

体験版がインストールされた環境に、体験版をアンインストールせずに、製品版をインストールしても良いでしょうか。

ExcelCreator 5.0 for .NET の体験版を事前にアンインストールしておく必要があります。
体験版をアンインストール後に製品版をインストールしてください。

先頭に戻る

ExcelCreator 5.0 for .NET の体験版で作成したアプリケーションを、ExcelCreator 5.0 for .NET 製品版に置き換えても、問題無く使用可能でしょうか。

ExcelCreator 5.0 for .NET の体験版で作成したアプリケーションは、製品版の開発環境で使用することができます。
但し、ExcelCreator 5.0 for .NET のアセンブリを作成したアプリケーションと同じフォルダにコピーして使用している場合は、ExcelCreator 5.0 for .NET 製品版のアセンブリを、作成したアプリケーションと同じフォルダにコピーしてください。

先頭に戻る

ExcelCreator 5.0 for .NET 製品 CD-ROM に収録された ExcelCreator Ver3.0 をインストールしたいのですが、シリアル№が分かりません。

製品 CD-ROM に収録されている ExcelCreator Ver3.0 (ActiveX 版) のシリアル番号は、ExcelCreator 5.0 for .NET と同じシリアル番号になります。シリアル番号は、製品 CD-ROM のケース裏面にあるシールに記載されています。
なお、インストール方法などの詳細は、製品 CD-ROM の「ExcelCreator3」フォルダにある「ExcelCreator3_インストール方法.txt」を参照してください。

先頭に戻る

ExcelCreator 5.0 for .NET 製品 CD-ROM に同梱されている ExcelCreator Ver3.0 のライセンスやサポートサービス内容について教えてください。

・「開発ライセンス」
ExcelCreator 5.0 for .NET と同じ数の開発ライセンスが適用されます。

・「アプリケーションの再配布」
Windows アプリケーションではロイヤルティーフリーです。
Web アプリケーションではサーバーライセンスが必要です。

・「サポートサービス」
ExcelCreator 5.0 for .NET と同じサポートサービスを受けることができます。
お問い合わせの時に必要なシリアル番号につきましては、ExcelCreator 5.0 for .NET のシリアル番号 (製品 CD-ROM のケース裏面に記載されています) をお伝えください。

先頭に戻る

ExcelCreator .NET がインストールされた環境に ExcelCreator 5.0 for .NET をインストールしても良いでしょうか。

ExcelCreator .NET がインストールされた環境に ExcelCreator 5.0 for .NET をインストールしても問題はありません。
なお、ExcelCreator 5.0 for .NET は、新しいバージョンの ExcelCreator .NET クラスを同梱しています。
新しいバージョンの ExcelCraetor .NET クラスに置き換える場合、下記を参照してください。
新バージョン ExcelCreator .NET クラスへの変更方法

先頭に戻る

PDF ファイルの作成に失敗する。または、作成した PDF ファイルを開くことができない。

.NET Framework のサービスパックをご確認ください。サービスパックは下記の動作環境に準拠している必要があります。

.NET Framework 1.0 の場合、SP3 以上。
.NET Framework 1.1 の場合、SP1 以上。

.NET Framework のサービスパックが適用されていない場合、最新のサービスパックを適用後、現象の再現性をご確認ください。

先頭に戻る

日本語環境以外の OS や開発言語で使用できますか。

ExcelCreator 5.0 for .NETは、日本語版の OS や開発言語のみ対応しています。
日本語版以外の OS や開発言語には対応しておりません。

先頭に戻る

ExcelCreator 5.0 for .NET は Excel やAccess の VBA で使用することができますか。

ExcelCreator 5.0 for .NET は Excel や Access の VBA で使用することはできません。

先頭に戻る

ターミナルサーバー(TerminalServer(Service))/メタフレーム(MetaFrame)環境での動作に対応していますか。

ExcelCreator 5.0 for .NET は、ターミナルサーバー(TerminalServer(Service))/メタフレーム(MetaFrame)環境での動作確認、および、動作保証を行っておりません。

先頭に戻る

.NET Framework 1.0 SP3 、.NET Framework 2.0 のみがインストールされた環境で ExcelCreator 5.0 for .NET を組み込んだアプリケーションが実行できない。

.NET Framework 1.0 SP3、.NET Framework 2.0のみがインストールされた環境にExcelCreator 5.0 for .NETを組み込んだアプリケーションを配布する場合、ExcelCreator 5.0 for .NETの再配布可能ファイル以外に、Cランタイムファイル(MSVCR71.dll)を開発環境からコピーして配布する必要があります。
なお、MSVCR71.dllの配布場所は、アプリケーションと同一フォルダ、またはシステムフォルダに配布してください。

先頭に戻る

ノータッチ デプロイメントには対応していますか。

ExcelCreator 5.0 for .NET は、ノータッチ デプロイメントで使用することが可能です。
なお、ノータッチ デプロイメントで使用する場合、サーバーに配布する ExcelCreator 5.0 for .NET の再配布可能ファイルに対して[完全な信頼]を設定する必要があります。下記の設定手順を参考にご対応ください。

・ サーバーの再配布可能ファイルに対して[完全な信頼]を設定する手順
(1) | アプリケーションと下記の再配布可能ファイルを配布します。 ExcelCreator.dll ExcelCreator.XlsCrt.dll ExcelCreator.XlsPDF.dll
(2) | コントロールパネルの[管理ツール]-[Microsoft .NET Framework Wizards]をダブルクリックします。
(3) | [.NET ウィザード]画面の[アセンブリの信頼]をクリックします。
(4) | 「何を変更しますか？」で、[このコンピュータへの変更を行う]のチェックを ON にして、[次へ]ボタンをクリックします。
(5) | 「どのアセンブリを信頼しますか？」で、[参照]ボタンをクリックして配布した ExcelCreator.dll を選択し、[次へ]ボタンをクリックします。
(6) | 「この発行者からのアセンブリ、またはすべてのアセンブリを信頼しますか？」で、[同じアセンブリ公開キーを持つすべてのアセンブリ]のチェックを ON にし、[バージョン番号を含めてください]のチェックを OFF にして、[次へ]ボタンをクリックします。
(7) | 「アセンブリに対する信頼の最低レベルを選択する」で、[完全な信頼]に上げ、[次へ]ボタンをクリックします。
(8) | 「ウィザードの完了」で、ExcelCreator.dll の信頼の最低レベルが[完全な信頼]であることを確認し、[完了]ボタンをクリックして終了します。
(9) | ExcelCreator.XlsCrt.dll 、ExcelCreator.XlsPDF.dll に対しても、(3)～(7) の操作を適用して[完全な信頼]を設定します。

サーバーの設定後、クライアントマシンでサーバーの URL に対し、セキュリティレベルを[完全な信頼]に設定する必要があります。
下記に、[信頼済みサイト]のセキュリティレベルを[完全な信頼]を設定して、[信頼済みサイト]にサーバーの URL を設定して運用する手順を記載します。

・ クライアントマシンでサーバーのURLに対して[完全な信頼]を設定する手順
(1) | コントロールパネルの [管理ツール]-[Microsoft .NET Framework Wizards]をダブルクリックします。
(2) | [.NET セキュリティ]画面の[.NET セキュリティの変更]をクリックします。
(3) | 「何を変更しますか？」で、[このコンピュータへの変更を行う]のチェックを ON にして、[次へ]ボタンをクリックします。
(4) | 「各ゾーンでのセキュリティ レベルの変更」で、[信頼済みサイト]を選択し、信頼レベルを[完全な信頼]に上げ、[次へ]ボタンをクリックします。
(5) | 「ウィザードの完了」で[信頼済みサイト]のセキュリティレベルが[完全な信頼]であることを確認し、[完了]ボタンをクリックして終了します。
(6) | Internet Explorerを起動し、メニューの[ツール]-[インターネット オプション]をクリックして、「インターネット オプション」の[セキュリティ]タブを選択します。
(7) | [信頼済みサイト]を選択し、[サイト]ボタンをクリックします。
(8) | 「信頼済みサイト」で、[次の Web サイトをゾーンに追加する」にサーバーの URL を設定します。 例えば、"http://appserver/ec5/sample.exe"に ExcelCreator 5.0 for .NET のアセンブリを配置している場合、"http://appserver/ec5" を設定します。
(9) | [このゾーンのサイトにはすべてサーバーの確認 (https:) を必要とする]のチェックを OFF にして、[追加]ボタンをクリックします。
(10) | [Web サイト]に URL が追加されたことを確認し、[OK]ボタンをクリックします。

なお、.NET Framework 1.0 SP3、.NET Framework 2.0 のみがインストールされた環境にExcelCreator 5.0 for .NETを組み込んだアプリケーションを配布する場合、ExcelCreator 5.0 for .NETの再配布可能ファイル以外に、Cランタイムファイル(MSVCR71.dll)を開発環境からコピーして配布する必要があります。

先頭に戻る

ClickOnce には対応していますか。

ClickOnce を使用して ExcelCreator 5.0 for .NET を組み込んだアプリケーションの配置が可能です。配置方法につきましては、Visual Studio 2005 のドキュメントをご確認ください。
なお、ClickOnce によるアプリケーションの配置を行う場合、ExcelCreator 5.0 for .NET の以下の再配布可能ファイルを追加して頂く必要があります。

・ | 再配布可能ファイル
 | ExcelCreator.dll ExcelCreator.XlsCrt.dll ExcelCreator.XlsPDF.dll

・ 追加手順
(1) | Visual Studio 2005 のメニュー [プロジェクト]-[プロパティ] をクリックします。
(2) | [発行]を選択し、[インストール モードと設定]の[アプリケーション ファイル]ボタンをクリックします。
(3) | [アプリケーション ファイル]画面より、再配布可能ファイルの[発行の状況]を"追加"に変更し、[OK]ボタンをクリックします。 画面上に再配布可能ファイルがない場合、プロジェクトの[参照の設定]で再配布可能ファイルを追加して再度お試しください。

先頭に戻る

ExcelCreator 5.0 for .NET と VB-Report 5.0 for .NET との違いについて。

・「ExcelCreator 5.0 for .NET」
Excel のない環境でも Excel ファイルの生成や編集ができる Excel ファイル生成支援ツールです。
また、Excel ファイルの生成は、弊社独自の技術により行いますので、パフォーマンス性にもすぐれたアプリケーションを作成することができます。

・「VB-Report 5.0 for .NET」
Excel で帳票デザインを作成する帳票ツールです。
VB-Report 独自のデザイナ機能はなく、Excel がそのまま帳票デザイナとなります。
Excel をデザイナにすることで、フォント、属性、その他のさまざまなExelの書式設定で美しい帳票デザインを作成することができ、細かなデザイン変更も比較的容易に設定することができます。

先頭に戻る

ExcelCreator .NET との互換性はありますか。

ExcelCreator 5.0 for .NET に新しいバージョンの ExcelCreator .NET クラス (XlsCrtNet5.dll) を同梱しています。
旧バージョン ExcelCreator .NET を使用したアプリケーションを新しいバージョンに置き換える場合、下記を参照してください。
新バージョン ExcelCreator .NET クラスへの変更方法

先頭に戻る

ActiveX 版の Excel クリエーター Ver2 (旧バージョン) や ExcelCreator Ver3.0 との互換性はありますか。

ExcelCreator 5.0 for .NET コンポーネントは、Excelクリエーター Ver2.0、および ExcelCreator Ver3.0 (ActiveX 版) との互換性はありません。
また、ActiveX 版のコーディングを、ExcelCreator 5.0 for .NET 対応のコーディングへ変換するツールはありません。

先頭に戻る

Excelファイルの行数と列数に制限はありますか。

Excel シートと同じ 65,536 行 × 256 列です。

先頭に戻る

Excelファイルのシート数に制限はありますか。

OpenBook メソッドのオーバーレイでオープン可能な Excel ファイルのシート数は最大 255 シートです。

先頭に戻る

グラフ付きのシートに対応していますか。

ExcelCreator 5.0 for .NET はグラフシートに対応していません。
オーバーレイ元ファイルにグラフシートが設定されている場合、オーバーレイ後の Excel ファイルへ設定は引き継がれません。
尚、Excel シート上にオブジェクトとして貼り付けられたグラフの場合は、オーバーレイ後の Excel ファイルにグラフを正しく引き継ぐことができます。

先頭に戻る

色の設定で、列挙体にあるメンバ以外の色を設定する方法について。

定数以外の色を設定することができます。
詳細につきましては、色を示す定数を参照してください。

先頭に戻る

行や列を非表示にする方法について。

行の場合は RowHeight プロパティに 0 を、列の場合は ColWidth プロパティに 0 を、それぞれ設定することで非表示とすることができます。

先頭に戻る

印刷範囲の設定について。

ExcelCreator 5.0 for .NET は、PrintArea メソッドでシート毎に印刷範囲を設定できます。

先頭に戻る

改ページの設定について。

Break プロパティで対応しています。

先頭に戻る

表示パーセントの設定について。

Zoom プロパティで対応しています。

先頭に戻る

改行コード (CR+LF [0x0D 0x0A]) を含めた文字列の設定について。

Excel はセル内で文字列を改行すると、改行コードを LF (0x0A) として設定します。そのため、ExcelCreator からセルに改行コードを含んだ文字列を設定する場合も、Excel の改行コードと同じ LF (0x0A) のみを設定して対応してください。

' コーディング例 (Visual Basic .NET)
Xls1.Cell("A1").Value = "改行前" + Convert.ToChar(10) + "改行後"
' コーディング例 (C# .NET)
Xls1.get_Cell("A1").Value = "改行前" + Convert.ToChar(10) + "改行後";

先頭に戻る

シングルクォート (') を先頭につけた文字列の設定について。

ExcelCreator 5.0 for .NET でセルに文字列を設定する場合、内部で先頭のシングルクォートを一つ削除する仕様としているため、設定する文字列には 「''TEST」 のように 2 つのシングルクォートを付加してください。
コーディング例：
Cell("A1",0,0).Value = "''TEST"

先頭に戻る

アスタリスク (*) を先頭に2つ以上つけた文字列の設定について。

先頭にアスタリスク (*) を 2 つ以上付けた文字列は、セル変数名として処理を行いますので、出力する Excel ファイルには反映されません。
アスタリスク (*) を先頭に 2 つ以上付ける文字列を設定する場合は、文字列の先頭に ['] (シングルコーテーション) を付加し対応してください。
コーディング例：
Cell("A1").Value = "'**"

先頭に戻る

結合セルに罫線等の属性を設定する場合の注意点。

結合されたセルに罫線を設定する場合、結合対象のセル全体に対し罫線を設定する必要があります。
セルの範囲指定は、変数名によるセル指定では範囲指定ができないため、セル名、セル位置 (A1 参照形式) や、Pos プロパティを使用して罫線を設定する方法で対応してください。

先頭に戻る

テキストボックスに変数名を設定し、ExcelCreator 5.0 for .NET でデータを設定することはできますか。

テキストボックスに設定した変数名にも対応しています。
但し、Integer、Double 型などの数式は設定できません。文字列のみ設定可能です。

先頭に戻る

保護ブック / シートについて。

ブックやシートの保護を設定した Excel ファイルの読み書きオープン (OpenBook メソッド) や 読み込み専用オープン (ReadBook メソッド) には対応していません。
また、新規作成 (CreateBook メソッド) で作成した Excel ファイルにブックやシートの保護を設定することも対応していません。

先頭に戻る

マクロの編集と実行。

VBA やマクロに関する部分の編集、および、動作を行うことはできません。

先頭に戻る

シート / ブック間のコピーについて。

シート間やブック間でのセルのコピーや貼り付け、ブック間でのシートのコピーや貼り付けには対応しておりません。

先頭に戻る

印刷タイトル (行タイトル / 列タイトル) について。

行タイトル、列タイトルの設定には対応していません。

先頭に戻る

セルサイズの設定について。

ExcelCreator 5.0 for .NET の場合、幅は文字数 (0 ～ 255 文字)、高さはポイント (0 ～ 409 ポイント) を設定します。
尚、非表示にする場合、行は RowHeight プロパティに 0 を、列は ColWidth プロパティに 0 を設定します。

先頭に戻る

画像の貼り付けについて。

画像を挿入することはできません。

先頭に戻る

ハイパーリンクについて。

ExcelCreator 5.0 for .NET は HYPERLINK 関数に対応していないため、プログラム中から HYPERLINK 関数を設定することは出来ません。

先頭に戻る

条件付き書式について。

ExcelCreator 5.0 for .NET は条件付き書式に対応していません。
条件付き書式を設定した Excel ファイルを オーバーレイ機能にて開き作成した Excel ファイルにも、条件付き書式の設定は引き継がれません。

先頭に戻る

シート削除後にファイルサイズが減少しない。

Excel ファイル (*.xls) は Microsoft 社独自の OLE 複合形式と呼ばれるファイル形式を採用されており、このファイル形式には Excel シート以外の Office アプリケーション等で利用可能なデータが保持されております。
Excel 上で Excel シートの削除を行いファイル保存しますと、前述の複合形式データが再配置されるためサイズの最適化が行われ、その結果、ファイルサイズが減少することになります。
但し、ExcelCreator 5.0 for .NET の DelSheet メソッドでシート削除を行った場合は、Excel に関連する部分へのみ対応した処理を行いますので、基本的にファイルサイズは影響が発生致しません。

先頭に戻る

「表示形式を追加できません」のエラーメッセージが発生する。

ファイルに設定されたセル書式設定の合計数が、Excel の制限 (4000 まで) を超えたために表示されます。
ExcelCreator 5.0 for .NET では、OpenBook メソッド、CloseBook メソッド等のオープン・クローズにて既存と追加されたセル書式設定情報の最適化を行いますが、連続して繰り返し行った場合は最適化されません。
回避するには、オープン・クローズの呼び出し回数を繰り返さずに 1 回へ減らすことにより、最適化が行われるようにしてください。ただし、その場合でもセル書式設定数が 4000 を超える場合には、Excel の制限により同じ現象が発生しますので、ご注意ください。

先頭に戻る

行追加 / 削除等でオブジェクトが移動しない。

オートシェイプや画像が設定されている Excel シートに、行・列の挿入や削除を行った場合のオートシェイプや画像の位置移動には対応しておりません。

先頭に戻る

計算方法が手動から自動に変わる。

ExcelCreator 5.0 for .NET は自動計算や再計算の機能がないため、プログラム中で計算式を設定したり、計算式が参照するセルの値を変更したブックを Excel で開いた際には、自動で Excel 上で再計算する様、編集後の Excel ファイルの[計算方法]を[自動]に設定しています。
オーバーレイ元ファイルが手動計算モードに設定されている場合でも、プログラム中で設定した数式の計算結果を反映させるため、編集後の Excel ファイルの[計算方法]を[自動]へ変更する仕様にしています。

先頭に戻る

シート削除ができない条件。

マクロを含む Excel ファイルの場合、シートを削除することはできません。

先頭に戻る

シートコピーができない条件。

マクロの設定があるオーバーレイ元ファイルのシートコピーには対応しておりません。

先頭に戻る

計算式の計算結果について。

セルに Func メソッドで計算式を設定した場合や、計算式が定義されている Excel ファイルをオーバーレイ機能で計算式が参照するセルの値を変更した Excel ファイルを、Excel で開き閉じる時に保存の確認メッセージが表示されます。このメッセージを表示させないようにするには、Func メソッドで計算結果も設定してください。

先頭に戻る

行・列の挿入 (RowInsert / ColumnInsert) やコピー (RowCopy / ColumnCopy) 、貼り付け (RowPaste / ColumnPaste) における、Excel との動作の違いについて。

行・列の挿入やコピー、貼り付けの動作は、ExcelCreator 5.0 for .NET と Excel では次の様に一部仕様が異なっております。(行コピーを除きます。)

 | ExcelCreator 5.0 for .NET | Excel
列挿入 | 左側の列と同じセル幅、フォントで挿入されます。 (A 列の場合、列幅はデフォルト値、フォントは標準フォント・サイズ) | 左側の列と同じセル幅、フォントで挿入されます。 (A 列の場合、列幅はデフォルト値、フォントは標準フォント・サイズ)
列コピー | セルのデータのみコピーされます。 (セル幅はコピーされません。) | セルのデータとセル幅がコピーされます。
行挿入 | デフォルトの行高さ、フォントで挿入されます。 | 行挿入する上の行と同じ行高さ、フォントで挿入されます。 (1 行目の場合、行高さはデフォルト値、フォントは標準フォント・サイズ)
行コピー | セルのデータと行の高さがコピーされます。 | セルのデータと行の高さがコピーされます。

先頭に戻る

Web アプリケーションとして使用したい。

ASP.NET で作成する Web アプリケーションに対応しています。

先頭に戻る

Web アプリケーションのサンプルプログラムはありますか。

Web 帳票のサンプルプログラムは、下記のサンプルフォルダにあります。

・ Visual Studio .NET 2002 / 2003
・ | Visual Basic .NET
 | \Samples\VB\Ec5WebSampleVb
・ | C#
 | \Samples\CS\Ec5WebSampleCs
・ | ReadMe
 | \Samples\ReadMe_WebSample.txt
・ Visual Studio 2005
・ | Visual Basic .NET
 | \Samples\VB\Ec5WebSampleVb2005
・ | C#
 | \Samples\CS\Ec5WebSampleCs2005
・ | ReadMe
 | \Samples\ReadMe_WebSample2005.txt

使用方法は各 ReadMe を参照してください。

先頭に戻る

既存の Excel ファイルのオープンやファイル保存ができない現象について。

ExcelCreator 5.0 for .NET では、シートやブックの保護が設定された Excel ファイルをオープンすることができません。

先頭に戻る

新バージョンで追加された機能について。

以下の SelectBook メソッド専用の Excel ファイルの各オープンメソッドの他、変数確認や変数名差し込みモードのプロパティが追加されました。

CreateBookEx メソッド
OpenBookEx メソッド
OpenBookEmbedEx メソッド
ReadBookEx メソッド
CloseBookEx メソッド
SelectBook メソッド
VarCheck プロパティ
VarInsertMode プロパティ

詳細は各メソッド / プロパティの機能一覧を参照してください。

先頭に戻る

新バージョンのライセンスについて。

旧バージョン ExcelCreator .NET の所有ライセンス (サイトライセンス、サーバーライセンス含む) を、そのまま継続できます。

先頭に戻る

2 台のサーバー機を準備し、1 台はトラブル用のバックアップ機として使用する場合、サーバーライセンスは 2 本必要でしょうか。

常にオフライン状態でトラブル発生などの条件下でのみ、バックアップ(代替)機として使用するサーバー機に対して、サーバーライセンスは必要ありません。
この場合、サーバーライセンスの必要本数は 1 本です。

先頭に戻る

デバッグや動作確認の目的で開発環境をサーバー機として使用する場合、サーバーライセンスは必要でしょうか。

デバッグや動作確認を目的として使用するサーバー機(開発環境)に対して、サーバーライセンスは必要ありません。

先頭に戻る

配布先のサーバー機が 2CPU タイプの場合、サーバーライセンスは 2 本必要でしょうか。

ExcelCreator 5.0 for .NET のサーバーライセンスは、配布先のサーバー機の CUP 数ではなく、サーバー機の台数で必要とするライセンス数を決めています。
この場合、サーバー機は 2CPU タイプですが、台数は 1 台のため、サーバーライセンスの必要本数は 1 本です。

先頭に戻る

ターミナルサーバー(TerminalServer(Service))/メタフレーム(MetaFrame)環境にプログラムを配布する場合、サーバーライセンスの必要本数を教えてください。

ターミナルサーバー(TerminalServer(Service))/メタフレーム(MetaFrame)環境に(製品名)のDLLを組み込んだプログラムを配布する場合、配布先のマシンに対して、サーバーライセンスは必要ありません。

なお、ExcelCreator 5.0 for .NET は、ターミナルサーバー(TerminalServer(Service))/メタフレーム(MetaFrame)環境での動作確認、および、動作保証を行っておりません。

先頭に戻る


セル情報の設定と取得について (Cell クラスの場合)

セル情報の設定と取得について (Cell クラスの場合)

Cell クラスにて対象セルの範囲指定を行い、各メソッドやプロパティに設定した場合、Cell クラスの範囲指定方法により属性や値の設定されるセル、値の取得されるセルに注意してください。

設定例 1.
複数の範囲セルを指定し、属性と値の設定を行った場合、次のような結果となります。
セル (A1 ～ B2 と D3 ～ C3 と D4) を対象セルとします。このセルに対してフォント名を「MS ゴシック」、フォントサイズを「12 ポイント」、背景色を「水色 (xcCyan)」、文字列「"abc"」を設定します。

XlsCreator1.CreateBook(Applicaiotn.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2002)

'セル範囲指定し、書式情報を設定します
XlsCreator1.Cell("A1:B2, D3:C3, D4").Attr.FontName = "MS ゴシック"
XlsCreator1.Cell("A1:B2, D3:C3, D4").Attr.FontPoint = 12
XlsCreator1.Cell("A1:B2, D3:C3, D4").Attr.BackColor = ExcelCreator.xlColor.xcCyan
XlsCreator1.Cell("A1:B2, D3:C3, D4").Str = "abc"

XlsCreator1.CloseBook(True)

実行結果、下記の Excel ファイルが作成されます。

・ExcelFile.xls

属性については、セル (A1 ～ B2 と C3 ～ D3 と D4) に設定されます。
値については、セル (A1 と C3 と D4) に設定されます。
尚、セル範囲指定時に XlsCreator1.Cell("B2:A1, C3:D3, D4") と指定範囲を逆に記述しても同じ結果となります。

設定例 2.
複数の範囲セルを指定し、値の取得を行った場合、次のような結果となります。
次のようなシートに対して、セル ( A1 ～ B2 と C3 ～ D3 と D4) を対象セルとします。

・ExcelFile.xls

XlsCreator1.ReadBook(Applicaiotn.StartupPath & "\ExcelFile.xls", "")

'範囲 (A1 ～ B2 と C3 ～ D3 と D4) を指定します
Dim szData1 As String = XlsCreator1.Cell("A1:B2, C3:D3, D4").Str    'szData1 には、aaa1 が入ります

'前記と範囲は同じですが、指定順序を変えると取得される値が変わります
'範囲 (C3 ～ D3 と A1 ～ B2 と D4) を指定します
Dim szData2 As String = XlsCreator1.Cell("C3:D3, A1:B2, D4").Str    'szData2 には、ccc3 が入ります

'前記と指定順序は同じで、範囲指定記述を変えても取得される値は同じです
'範囲 (C3 ～ D3 と A1 ～ B2 と D4) を指定します
Dim szData3 As String = XlsCreator1.Cell("D3:C3, B2:A1, D4").str    'szData3 には、ccc3 が入ります

XlsCreator1.CloseBook(True)

実行結果、Excel ファイルの各セルから、取得できる値は以下の通りです。

Cell("A1:B2, C3:D3, D4") と指定した場合、取得対象セルは A1 セルとなり、aaa1 を取得します。
Cell("C3:D3, A1:B2, D4") と指定した場合、取得対象セルは C3 セルとなり、ccc3 を取得します。
Cell("D3:C3, B2:A1, D4") と指定した場合、取得対象セルは C3 セルとなり、ccc3 を取得します。


セル情報の設定と取得について (Pos クラスの場合)

セル情報の設定と取得について (Pos クラスの場合)

Pos クラスにて対象セルの範囲指定を行い、各メソッドやプロパティに設定した場合、Pos クラスの範囲指定方法により属性や値の設定されるセル、値の取得されるセルに注意してください。

設定例 1.
複数の範囲セルを指定し、属性と値の設定を行った場合、次のような結果となります。
セル (A1 ～ C3) を対象セルとします。このセルに対してフォント名を「MS ゴシック」、フォントサイズを「12 ポイント」、背景色を「水色 (xcCyan)」、文字列「"abc"」を設定します。

XlsCreator1.CreateBook(Applicaiotn.StartUpPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2002)

'セル範囲指定し、書式情報を設定します
XlsCreator1.Pos(0, 0, 2, 2).Attr.FontName = "MS ゴシック"
XlsCreator1.Pos(0, 0, 2, 2).Attr.FontPoint = 12
XlsCreator1.Pos(0, 0, 2, 2).Attr.BackColor = ExcelCreator.xlColor.xcCyan
XlsCreator1.Pos(0, 0, 2, 2).Str = "abc"

XlsCreator1.CloseBook(True)

実行結果、下記の Excel ファイルが作成されます。

・ExcelFile.xls

属性については、セル (A1 ～ C3) に設定されます。
値については、セル (A1) に設定されます。
なお、セル範囲指定時に XlsCreator1.Pos(2, 2, 0, 0).Move と記述しても同じ結果となります。

設定例 2.
複数の範囲セルを指定し、値の取得を行った場合、次のような結果となります。
次のようなシートに対して、セル (A1 ～ D4) を対象セルとします。

・ExcelFile.xls

XlsCreator1.ReadBook(Applicaiotn.StartUpPath & "\ExcelFile.xls", "")

'範囲 (A1 ～ D4) を指定し、文字列を取得します
Dim szData1 As String = XlsCreator1.Pos(0, 0, 3, 3).Str    'szData1 には、aaa1 が入ります

'前記と範囲は同じで、指定順序を変えても、取得される値は変わりません
Dim szData2 As String = XlsCreator1.Pos(3, 3, 0, 0).Str    'szData2 には、aaa1 が入ります

XlsCreator1.CloseBook(True)

実行結果、Excel ファイルの各セルから、取得できる値は以下の通りです。

XlsCreator1.Pos(0, 0, 3, 3) と指定した場合、取得対象セルの範囲は A1 ～ D4 セルとなり、aaa1 を取得します。
XlsCreator1.Pos(3, 3, 0, 0) と指定した場合、取得対象セルの範囲は D4 ～ A1 セルとなり、aaa1 を取得します。

なお、Pos(0, 0, 3, 3) と指定しても、Pos(3, 3, 0, 0) と指定しても、取得対象セルは A1 セルとなり、aaa1 を取得します。


C# .NET で引数に 2 つ以上の列挙体のメンバを設定する方法

C# .NET で引数に 2 つ以上の列挙体のメンバを設定する方法

C# .NET で LineTop プロパティの様に、引数に 2 つ以上の列挙体のメンバを設定する場合、System.Int32 型にキャストした各列挙体のメンバを + 演算子で組み合わせ、全体を対応する列挙体のメンバにキャストします。
下記に LineTop プロパティを使用して、引数に罫線の種類と色を示す各列挙体のメンバを組み合わせて設定する方法を記載します。

コーディング例

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);

// セル C2 から C5 に赤色の左罫線 (太線) を設定します
xlsCreator1.Cell("C2:C5").Attr.LineTop = (ExcelCreator.xlLineStyle)((Int32)ExcelCreator.xlLineStyle.lsThick +
                                         (Int32)ExcelCreator.xlColor.xcRed);
// セル F2 から F5 に緑色の右罫線 (点線) を設定します
xlsCreator1.Cell("F2:F5").Attr.LineTop = (ExcelCreator.xlLineStyle)((Int32)ExcelCreator.xlLineStyle.lsDot +
                                         (Int32)ExcelCreator.xlColor.xcGreen);

xlsCreator1.CloseBook(true);


日付形式のセル値の取得と設定について

日付形式のセル値の取得と設定について

Excel ファイルの日付形式のセル値は、Excel ファイル内部でシリアル値 (数値) として管理されているため、そのままの日付形式で取得することはできません。
日付の表示形式で取得を行う場合、ExcelCreator 5.0 for .NET で取得した値を、各言語のサポートする書式設定関数を使用して、任意の表示形式へ変更してください。

取得するコーディング例

セルの数値を DateTime クラスで取得し、文字列に変換します

[VB.NET]
XlsCreator1.ReadBook(Application.StartupPath & "\SrcDate.xls")

Dim dtDate As DateTime = DateTime.FromOADate(Convert.ToDouble(XlsCreator1.Cell("A1").Value))
Dim strDate As String = dtDate.ToString("yyyy/MM/dd")

XlsCreator1.CloseBook(True)

MsgBox("日付:" & strDate)

[C#]
xlsCreator1.ReadBook(Application.StartupPath + @"\SrcDate.xls");

DateTime dtDate = DateTime.FromOADate(Convert.ToDouble(xlsCreator1.Cell("A1").Value));
string strDate = dtDate.ToString("yyyy/MM/dd");

xlsCreator1.CloseBook(true);

MessageBox.Show("日付:" + strDate);

また、日付形式のセルに値を設定する場合も、各言語のサポートするデータ変換関数を使用して、日付型のデータを設定してください。

設定するコーディング例

セルへ、日付文字列を Double クラスへ変換して設定し、日付型書式を設定します

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\SrcDate.xls", 1, ExcelCreator.xlVersion.ver2002)

XlsCreator1.Cell("A1").Value = Convert.ToDateTime("2004/5/20").ToOADate()
XlsCreator1.Cell("A1").Attr.Format = "yyyy/m/d"

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\SrcDate.xls", 1, ExcelCreator.xlVersion.ver2002);

xlsCreator1.Cell("A1").Value = Convert.ToDateTime("2004/5/20").ToOADate();
xlsCreator1.Cell("A1").Attr.Format = "yyyy/m/d";

xlsCreator1.CloseBook(true);

日付書式を年号 (和暦) で設定する際の注意点
実行環境にインストールされている Excel のバージョンが 2002(XP) 以降の場合、表示書式を「ee/mm/dd」と定義し、値を設定しても、「2004/02/25」のように西暦で表示されます。
Excel 2002(XP) 以降の場合、日付の書式にて年号「e」を使用する場合に、日付の言語・地域を指定する必要がありますが、ExcelCreator 5.0 for .NET では、Excel ファイルの言語・地域の指定に対応していないため、書式設定時に「日本 ([$-411]) 」を指定してください。

例 : [$-411]ee/mm/dd


PDF 出力時について

PDF 出力時について

1)パターンを設定した場合の PDF ファイル出力結果について

Pattern プロパティでパターンを設定した PDF ファイルでは、以下の様にイメージが異なって出力されます。

・Excel ファイル出力結果

・PDF ファイル出力結果

2)プリンタのインストールされていない環境で PDF ファイルへの保存について

ExcelCreator 5.0 for .NET の PDF ファイルの出力時、実行環境にインストールされている「通常使用するプリンタ」の解像度を使用します。
出力する PDF ファイルに Pattern プロパティでパターンを設定した場合、前述の「通常使用するプリンタ」の解像度を基準としますが、プリンタのインストールされていない環境では画面の解像度 96dpi を基準としますので、パターンは粗く出力されます。
また、「通常使用するプリンタ」の解像度が低い (例:120dpi) 場合でも同様にパターンは粗く出力されます。


互換性について

- ExcelCreator 5.0 for .NET - 旧バージョン ExcelCreator .NET をご使用のお客様へ -
ExcelCreator .NET との互換性

・ 互換性について
ExcelCreator 5.0 for .NET コンポーネントは、ExcelCreator .NET クラスとの互換性はありません。
なお、ExcelCreator .NET クラスをご使用のお客様用に、ExcelCreator 5.0 for .NET では新しいバージョンの ExcelCreator .NET クラスを同梱しています。ExcelCreator .NET クラスを新しいバージョンへの変更方法は下記の説明を参照してください。

・ 新バージョン ExcelCreator .NET クラスへの変更方法

プログラム中で使用している旧バージョン ExcelCreator .NET コントロールを新バージョン ExcelCreator .NET クラスに置き換えます。
プログラムのアセンブリ名は変更する必要はありません。

1) プロジェクトの参照設定から、旧バージョン ExcelCreator .NET コンポーネント (XlsCrtNet.dll) を削除します。

2) プロジェクトの参照設定へ、新バージョン ExcelCreator .NET クラスを追加します。

(1) | Visual Studio .NET のメニュー [プロジェクト]-[参照の追加] で [参照の追加] 画面を開きます。
(2) | [参照の追加] 画面の [.NET] タブを選択します。
(3) 下記の ExcelCreator .NET クラスを選択します。

コンポーネント名 | パス
Advance Software ExcelCreator | C:\Program Files\XlsCrt5\Bin\XlsCrtNet5.dll

※パスは ExcelCreator 5.0 for .NET のデフォルトインストールフォルダの場合です。

(4) Visual Studio .NET 2002 / Visual Studio .NET 2003 の場合は、上記のコンポーネントを選択した状態で[選択] ボタンをクリックし、 [選択したコンポーネント] に追加します。

※Visual Studio .NET 2003 の画面です。

Visual Studio 2005 の場合は、選択した状態で次に進みます。

※Visual Studio 2005 の画面です。

(5) [OK] ボタンをクリックし、 [参照の追加] 画面を閉じます。
ExcelCreator .NET クラスが参照設定に追加されます。

・参照設定


ExcelCreator .NET クラス機能一覧

ExcelCreator 5.0 for .NET - 旧バージョン ExcelCreator .NET をご使用のお客様へ -
ExcelCreator .NET クラス機能一覧

新規作成オープン
 | CreateBook メソッド | Excel ファイルの新規作成を行います。
 | CreateBookEx メソッド | Excel ファイルを新規作成し、その識別 ID を取得します。(SelectBook メソッド専用)
読み書きオープン / オーバーレイオープン
 | OpenBook メソッド | 既存 Excel ファイルをオープンします。既存の Excel ファイルを元に別の Excel ファイルをオープンすることもできます。
 | OpenBookEx メソッド | 既存 Excel ファイルをオープンし、その識別 ID を取得します。既存の Excel ファイルを元に別の Excel ファイルをオープンすることもできます。(SelectBook メソッド専用)
埋め込み Excel ファイルオーバーレイオープン
 | OpenBookEmbed メソッド | リソースに埋め込まれたバイナリデータを既存 Excel ファイルとしてオープンます。既存の Excel ファイルを元に別の Excel ファイルをオープンすることもできます。
 | OpenBookEmbedEx メソッド | リソースに埋め込まれたバイナリデータを既存 Excel ファイルとしてオープンし、その識別 ID を取得します。既存の Excel ファイルを元に別の Excel ファイルをオープンすることもできます。(SelectBook メソッド専用)
読み込みオープン
 | ReadBook メソッド | 既存 Excel ファイルを読み込み専用でオープンします。
 | ReadBookEx メソッド | 既存 Excel ファイルを読み込み専用でオープンし、その識別 ID を取得します。(SelectBook メソッド専用)
Excel ファイルのクローズ / PDF ファイル出力
 | CloseBook メソッド | Excel ファイルのクローズ、または破棄を行います。PDF ファイル出力も行うことができます。
 | CloseBookEx メソッド | CreateBookEx / ReadBookEx / OpenBookEx / OpenBookEmbedEx で Excel ファイルを操作した場合に、Excel ファイルのクローズ、または破棄を行います。PDF ファイル出力も行うことができます。(SelectBook メソッド専用)
Excel ファイル選択
 | SelectBook メソッド | CreateBookEx / ReadBookEx / OpenBookEx / OpenBookEmbedEx で開いた Excel ファイルの操作対象を設定します。
エラー取得
 | ErrorNo プロパティ | エラー番号を取得します。
 | ErrorMessage プロパティ | エラーメッセージを取得します。
Excel ファイル全体
 | DefFontName プロパティ | Excel ファイル全シートのデフォルトフォント名を設定します。
 | DefFontPoint プロパティ | Excel ファイル全シートのデフォルトフォントサイズを設定します。
 | ModeGrid プロパティ | グリッド線の表示 / 非表示の設定を行います。実行時にのみ設定可能です。
 | Zoom プロパティ | シートの表示倍率を設定します。
 | KeyWord プロパティ | 変数名の先頭キーワード文字列を設定します。
 | VarCheck プロパティ | 指定された文字列が変数名として存在するかを確認します。
 | VarInsertMode プロパティ | オーバーレイ元ファイルのセル変数名への差し込みモードを設定します。
シート
 | AddSheet メソッド | Excel ファイルに新規シートを追加します。
 | DelSheet メソッド | Excel ファイル内のシートを削除します。
 | CopySheet メソッド | 指定したシートを、指定した場所にコピーします。
 | ActiveSheet プロパティ | アクティブに設定されているシート番号を取得します。アクティブシートを設定することもできます。
 | SheetCount プロパティ | Excel ファイルのシート総数を取得します。
 | RefSheet プロパティ | 参照されているシート名を指定します。
 | SheetNo プロパティ | 操作対象シートを指定します。
 | SheetNo2 プロパティ | 指定したシート名からシート番号を取得します。
 | SheetName プロパティ | シート名に文字列を設定します。シート名を取得することも可能です。
 | SheetName2 プロパティ | 指定したシート番号からシート名を取得します。
行・列コピー
 | RowCopy メソッド | 指定した行をコピーします。
 | RowPaste メソッド | 指定した行へ貼り付けます。
 | RowDelete メソッド | 指定した行を削除します。
 | RowClear メソッド | 指定した行をクリア (初期化) します。
 | RowInsert メソッド | 指定した行位置に行を挿入します。
 | ColumnCopy メソッド | 指定した列をコピーします。
 | ColumnPaste メソッド | 指定した列へ貼り付けます。
 | ColumnDelete メソッド | 指定した列を削除します。
 | ColumnClear メソッド | 指定した列をクリア (初期化) します。
 | ColumnInsert メソッド | 指定した列位置に列を挿入します。
印刷設定
 | PageMode メソッド | シート単位にページ設定を行います。
 | SetMargin メソッド | シート単位にページ余白の設定を行います。
 | Header メソッド | ヘッダーを指定します。
 | Footerメソッド | フッターを指定します。
範囲取得
 | MaxData メソッド | データ (文字列 / 値 / 計算式) が設定されているセルの最終座標を取得します。
 | MaxArea メソッド | データ (文字列 / 値 / 計算式) の他、罫線やセルの塗りつぶし等のセル書式が設定されている、最終セルの座標を取得します。
イベント
Error イベント ExcelCreator .NET の実行時に不正な処理を行った場合に発生します。

セルの属性
セルの位置や範囲設定を行います。
セル位置設定
 | Cell プロパティ | A1 形式でセルの範囲設定を行います。セルまたは、セル範囲を表す Cell プロパティを返します。
 | Pos プロパティ | 座標形式でセルの範囲設定を行います。セルまたは、セル範囲を表す Pos プロパティを返します。
値の取得・設定
 | Value プロパティ | セルに値を設定します。
 | Str プロパティ | 指定したセルへ文字列を設定します。
 | Long プロパティ | 指定したセルへ整数値を設定します。
 | Double プロパティ | 指定したセルへ実数値を設定します。
 | Func メソッド | 関数の書き込みをします。
 | AttrNo プロパティ | 指定したセルの属性番号を取得します。
 | Value2 メソッド | 指定したセルへバリアント値と属性番号を設定します。
 | Str2 メソッド | 指定したセルへ文字列と属性番号を設定します。
 | Long2 メソッド | 指定したセルへ整数値と属性番号を設定します。
 | Double2 メソッド | 指定したセルへ実数値と属性番号を設定します。
セルコピー・貼り付け、初期化
 | Copy メソッド | 指定したセルをコピーします。
 | Paste メソッド | メモリ上にコピーされたセルを、指定したセルに貼り付けます。
 | Clear メソッド | 指定したセルをクリア (初期化) します。
改ページの設定、セル幅・高さの取得・設定
 | Break プロパティ | 改ページを設定します。
 | ColWidth プロパティ | セルの幅を設定します。
 | RowHeight プロパティ | セルの高さを指定します。
罫線や表示書式、フォント、パターン等のセルの属性を設定します。
表示形式
Format プロパティ 表示書式を設定します。
配置
 | PosHorz プロパティ | 文字の配置 (横位置) を設定します。
 | PosVert プロパティ | 文字の配置 (縦位置) を設定します。
 | PosTurn プロパティ | 文字方向 (角度) を設定します。
 | OverReturn プロパティ | 「折り返して全体を表示」を設定します。
 | Fit プロパティ | 「縮小して全体を表示する」を設定します。
 | Joint プロパティ | 指定範囲のセルに「セルを結合する」を設定します。
フォント
 | FontName プロパティ | フォント名を設定します。
 | FontPoint プロパティ | フォントサイズを設定します。
 | FontColor プロパティ | フォントの色を設定します。
 | FontStyle プロパティ | フォントスタイルを設定します。
 | FontULine プロパティ | フォントの下線を設定します。
罫線
 | LineTop プロパティ | 上罫線を設定します。
 | LineBottom プロパティ | 下罫線を設定します。
 | LineLeft プロパティ | 左罫線を設定します。
 | LineRight プロパティ | 右罫線を設定します。
 | LineLeftUp プロパティ | 左上罫線を設定します。
 | LineRightUp プロパティ | 右上罫線を設定します。
 | Box メソッド | 設定したセル領域を囲む Box 罫線を設定します。
パターン
 | Pattern プロパティ | セルのパターンを設定します。
 | BackColor プロパティ | セルの背景色を設定します。


旧製品との互換性

旧製品との互換性

・ ExcelCreator .NET
ExcelCreator .NET との互換性を参照してください。

・ Excel クリエーター Ver2 , ExcelCreator Ver3.0 (ActiveX 版)
Excel クリエーター Ver2 , ExcelCreator Ver3.0 (ActiveX 版) の ActiveX 版対応製品につきましては、共に ExcelCreator 5.0 for .NET との互換性はありません。
また、ActiveX 版のコーディングを、ExcelCreator 5.0 for .NET 対応のコーディングへ変換するツールはありません。


色を示す定数

色を示す定数

設定値
定数 値 内容
xcDefault | 0 | 自動 (デフォルト値)
xcBlack | 8 | 黒
xcWhite | 9 | 白
xcRed | 10 | 赤
xcGreen | 11 | 明るい緑
xcBlue | 12 | 青
xcYellow | 13 | 黄色
xcPink | 14 | ピンク
xcCyan | 15 | 水色

上記以外の色の設定する場合は、下記の値を参照してください。

濃い赤 | 暗い緑 | 濃い青
濃い黄 | 紫 | 青緑
２５％灰色 | ５０％灰色 | グレー
プラム | アイボリー | 薄い水色
濃い紫 | コーラル | オーシャンブルー
アイスブルー | 濃い青 | ピンク
黄色 | 水色 | 紫
濃い赤 | 青緑 | 青
スカイブルー | 薄い水色 | 薄い緑
薄い黄色 | ベールブルー | ローズ
ラベンダー | ベージュ | 薄い青
アクア | ライム | ゴールド
薄いオレンジ | オレンジ | ブルーグレー
４０％灰色 | 濃い青緑 | シーグリーン
濃い緑 | オリーブ | 茶
プラム | インディゴ | ８０％灰色


ActiveSheet プロパティ

ExcelCreator.ActiveSheet プロパティ

アクティブ シートをシート番号を取得、または、設定します。

書式

[VB.NET]
  Public Property ActiveSheet() As Integer

[C#]
  public int ActiveSheet [get, set]

設定値

    アクティブ シートのシート番号を取得する変数を設定します。
    アクティブにするシート番号 (0 ～) を設定します。

解説
アクティブ シートは、Excel ファイルを Excel で開いた時に最初に表示されるシートです。
セルの書式設定や値を設定・取得を行うシートの設定には、SheetNo プロパティを使用 します。

参照
[SheetNo プロパティ]

コーディング例

アクティブ シートの番号の取得を行います。

[VB.NET]
Dim nActiveSheetNo As Integer
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")
nActiveSheetNo = XlsCreator1.ActiveSheet
XlsCreator1.CloseBook(True)

[C#]
Int32 nActiveSheetNo;
xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");
nActiveSheetNo = xlsCreator1.ActiveSheet;
xlsCreator1.CloseBook(true);

2 シート目をアクティブ シートに設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.ActiveSheet = 1
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.ActiveSheet = 1;
xlsCreator1.CloseBook(true);


AddSheet メソッド

ExcelCreator.AddSheet メソッド

Excel ファイルに新規シートを追加します。

書式

[VB.NET]
  Public Sub AddSheet(ByVal count As Integer)

[C#]
  public void AddSheet(System.Int32 count)

設定値

    count
      追加するシート数 (1 ～) を設定します。

解説
新規シートは、Excel ファイルの最後に追加します。
追加したシート名「SheetN」 (N は現在の最大シート数 + 1) が設定されます。

参照
[DelSheet メソッド]

コーディング例

Excel ファイルに 5 シート追加を行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003)
XlsCreator1.AddSheet(5)
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003);
xlsCreator1.AddSheet(5);
xlsCreator1.CloseBook(true);


Cell クラス

ExcelCreator.Cell クラス

出力対象となるセルの範囲をセル位置 (A1 参照形式) / 変数名 / セル名で設定します。

書式

[VB.NET]
  Public Cell(ByVal cell As String)
  Public Cell(ByVal cell As String, ByVal cx As Integer, ByVal cy As Integer)

[C#]
  public Cell(System.String cell , System.Int32 cx , System.Int32 cy)
  public Cell(System.String cell)

設定値

    cell
      対象セルを文字列で設定します。
      セル位置 (A1 参照形式)、変数名、セル名で設定します。
    cx
      cell で設定した対象セルからの範囲を左、または右への移動量を設定します。
    cy
      cell で設定した対象セルからの範囲を上、または下への移動量を設定します。

解説
cell の範囲について
・変数名による指定方法
 Excel ファイル内に変数が記述されている場合、変数名を設定することができます。 変数は、先頭に * (アスタリスク)が2つ付加された文字列になります。

【例】Excel ファイルの A1 セルに **No と記述した場合
.Cell("**No")

また、変数名の先頭のアスタリスクの部分に別の文字列を使用したい場合、 KeyWord プロパティを使用することで、変数名のキーワードとなる先頭の * (アスタリスク) を任意の文字列に変更することができます。 先頭キーワード文字列は、Excel で文字として認識可能で、かつ、半角文字のみ 設定することができます。但し、\ ' " , ^ . [] の半角文字は使用できません。
詳しくは KeyWord プロパティを参照してください。

・セル名による指定方法
 Excel ファイル内に特定のセルに名前を設定している場合、名前による指定ができ ます。

【例】ExcelファイルのA1セルに TEL と名前をつけた場合
.Cell("TEL")

・セル位置(A1参照形式)による指定方法
 範囲を表す演算子([:]コロン)、複数の範囲を表す演算子 ([,]カンマ) を含める ことができますが、他のブックやシートを直接参照することはできません。

【例】.Cell("A1")、.Cell("A1:B1")、.Cell("A1:C3")

複数の範囲を設定する場合、カンマで区切って設定することができます。

【例】.Cell("**No, TEL, A1:B1")

範囲指定を行った場合、属性については設定した範囲に対して設定されます。

cx, cy について
指定されたセル範囲に対してオフセットを設定することができます。 オフセットを使用することによって、プログラム中にてセルを移動する際、 A1,A2,A3...と指定せずに、cx, cy にて指定されたセル範囲に対して + / -1 ～ n 移動したセルに設定することができます。 Excel の制限を無視した設定を行うとエラーが発生します。
【例】Excelファイルの A1 セルに **No と記述している場合に F5 セルに設定
.Cell("**No", 5, 4)

このクラスの全てのメンバの一覧については、以下の Cell メンバを参照してください。

メンバ

パブリック プロパティ
Break プロパティ | 改ページの設定 / 解除を設定します。
ColWidth プロパティ | セルの列幅を設定します。
RowHeight プロパティ | セルの高さを設定します。
Value プロパティ | 数値や文字列、日付などの値を設定 / 取得します。
Str プロパティ | 文字列を取得 / 設定します。
Long プロパティ | 整数を取得 / 設定します。
Double プロパティ | 実数を取得 / 設定します。
AttrNo プロパティ | セルの属性番号を取得します。

パブリック メソッド
Copy メソッド | セルをコピーします。
Paste メソッド | Copy メソッドでコピーしたセルを貼り付けます。
Clear メソッド | セルをクリア (初期化) します。
Value2 メソッド | 数値や文字列、日付などの値と属性番号を設定します。
Str2 メソッド | 文字列と属性番号を設定します。
Long2 メソッド | 整数値と属性番号を設定します。
Double2 メソッド | 実数値と属性番号を設定します。
Func メソッド | 関数の書き込みをします。結果を示す値も同時に設定できます。

参照
[Pos クラス] | [Cell.Attr クラス] | [Pos.Attr クラス]


Cell/Pos.Attr.BackColor プロパティ

ExcelCreator.Cell/Pos.Attr.BackColor プロパティ

背景色を設定します。

書式

[VB.NET]
  Public WriteOnly Property BackColor() As ExcelCreator.xlColor

[C#]
  public ExcelCreator.xlColor BackColor [set]

設定値

    xlColor
      セルの背景色を示す xlColor 列挙体のメンバ、または、色を示す定数で設定します。

      定数         内容
      xcDefault    自動(デフォルト値)
      xcBlack      黒
      xcWhite      白
      xcRed        赤
      xcGreen      明るい緑
      xcBlue       青
      xcYellow     黄色
      xcPink       ピンク
      xcCyan       水色

コーディング例

B2 ～ D3 セルにパターン、色を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("B2:D3").Attr.BackColor = ExcelCreator.xlColor.xcBlue 'セルの背景色：青色
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("B2:D3").Attr.BackColor = ExcelCreator.xlColor.xcBlue; //セルの背景色：青色
xlsCreator1.CloseBook(true);


Box メソッド

ExcelCreator.Cell/Pos.Attr.Box メソッド

設定したセル領域を囲む Box 罫線を設定します。

書式

[VB.NET]
  Public Sub Box(ByVal nType As ExcelCreator.xlBoxType, ByVal nStyle As ExcelCreator.xlLineStyle)

[C#]
  public void Box(ExcelCreator.xlBoxType nType , ExcelCreator.xlLineStyle nStyle)

設定値

    nType
      xlBoxType 列挙体のメンバで設定します。

      定数       値       内容
      btBox       0       箱線(デフォルト値)
      btLtc       1       格子線
      btOver      2       上横線
      btUnder     3       下横線
      btLeft      4       左縦線
      btRight     5       右縦線

    nStyle
      xlLineStyle 列挙体のメンバで設定します。

      定数          内容
      lsDefault     デフォルト値
      lsNone        罫線なし
      lsNormal      実線
      lsThick       太線
      lsBroken      破線
      lsDot         点線
      lsThick2      極太線
      lsDouble      二重線
      lsSlender     細実線
      lsMidBroken   中破線
      lsSlnChain1   細一点鎖線
      lsMidChain1   中一点鎖線
      lsSlnChain2   細二点鎖線
      lsMidChain2   中二点鎖線
      lsMidChains   中一点斜鎖線

    nStyle に色を設定する場合の設定値は、「補足」-「色を示す定数」を参照してください。

参照
[Cell クラス] | [Pos クラス]
[C# .NET で引数に 2 つ以上の列挙体のメンバを設定する方法]

コーディング例

セル A10 から C20 に Box 罫線 (極太線) の書き込みをします。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A20:C25").Attr.Box(ExcelCreator.xlBoxType.btBox, ExcelCreator.xlLineStyle.lsThick2)
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A20:C25").Attr.Box(ExcelCreator.xlBoxType.btBox, ExcelCreator.xlLineStyle.lsThick2);
xlsCreator1.CloseBook(true);


Cell/Pos.Attr.Fit プロパティ

ExcelCreator.Cell/Pos.Attr.Fit プロパティ

「縮小して全体を表示する」を設定します。

書式

[VB.NET]
  Public WriteOnly Property Fit() As Boolean

[C#]
  public bool Fit [set]

設定値

      値        内容
      True      縮小して全体を表示する。
      False     縮小して全体を表示しない。(デフォルト値)

解説
「縮小して全体を表示する」を設定した場合、自動的にフォントサイズは変更され ますが、FontPoint プロパティで設定したフォントサイズは変更されません。

コーディング例

D7 セルに「縮小して全体を表示する」を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("D7").Str = "abcde"
XlsCreator1.Cell("D7").Attr.Fit = True
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("D7").Str = "abcde";
xlsCreator1.Cell("D7").Attr.Fit = true;
xlsCreator1.CloseBook(true);


Cell/Pos.Attr.FontColor プロパティ

ExcelCreator.Cell/Pos.Attr.FontColor プロパティ

フォント色を設定します。

書式

[VB.NET]
  Public WriteOnly Property FontColor() As ExcelCreator.xlColor

[C#]
  public ExcelCreator.xlColor FontColor [set]

設定値

    xlColor
      フォントの色を示す xlColor 列挙体のメンバ、または、色を示す定数で設定します。

      定数         内容
      xcDefault    自動(デフォルト値)
      xcBlack      黒
      xcWhite      白
      xcRed        赤
      xcGreen      明るい緑
      xcBlue       青
      xcYellow     黄色
      xcPink       ピンク
      xcCyan       水色

コーディング例

A1 セルに「MS Pゴシック」、フォントサイズを「13ポイント」、フォント色を「赤色」、「太字」「二重下線」を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック"
XlsCreator1.Cell("A1").Attr.FontPoint = 12
XlsCreator1.Cell("A1").Attr.FontColor = ExcelCreator.xlColor.xcRed
XlsCreator1.Cell("A1").Attr.FontStyle = ExcelCreator.xlFontStyle.xsBold
XlsCreator1.Cell("A1").Attr.FontULine = ExcelCreator.xlFontULine.fuDouble
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック";
xlsCreator1.Cell("A1").Attr.FontPoint = 12;
xlsCreator1.Cell("A1").Attr.FontColor = ExcelCreator.xlColor.xcRed;
xlsCreator1.Cell("A1").Attr.FontStyle = ExcelCreator.xlFontStyle.xsBold;
xlsCreator1.Cell("A1").Attr.FontULine = ExcelCreator.xlFontULine.fuDouble;
xlsCreator1.CloseBook(true);


Cell/Pos.Attr.FontName プロパティ

ExcelCreator.Cell/Pos.Attr.FontName プロパティ

フォント名を設定します。

書式

[VB.NET]
  Public WriteOnly Property FontName() As String

[C#]
  public string FontName [set]

コーディング例

A1 セルに「MS Pゴシック」、フォントサイズを「13ポイント」、フォント色を「赤色」、「太字」「二重下線」を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック"
XlsCreator1.Cell("A1").Attr.FontPoint = 12
XlsCreator1.Cell("A1").Attr.FontColor = ExcelCreator.xlColor.xcRed
XlsCreator1.Cell("A1").Attr.FontStyle = ExcelCreator.xlFontStyle.xsBold
XlsCreator1.Cell("A1").Attr.FontULine = ExcelCreator.xlFontULine.fuDouble
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック";
xlsCreator1.Cell("A1").Attr.FontPoint = 12;
xlsCreator1.Cell("A1").Attr.FontColor = ExcelCreator.xlColor.xcRed;
xlsCreator1.Cell("A1").Attr.FontStyle = ExcelCreator.xlFontStyle.xsBold;
xlsCreator1.Cell("A1").Attr.FontULine = ExcelCreator.xlFontULine.fuDouble;
xlsCreator1.CloseBook(true);


Cell/Pos.Attr.FontPoint プロパティ

ExcelCreator.Cell/Pos.Attr.FontPoint プロパティ

フォントサイズを設定します。

書式

[VB.NET]
  Public WriteOnly Property FontPoint() As Double

[C#]
  public double FontPoint [set]

設定値

    フォントサイズを示すポイント (1 ～ 409 ポイント) を設定します。

コーディング例

A1 セルに「MS Pゴシック」、フォントサイズを「13ポイント」、フォント色を「赤色」、「太字」「二重下線」を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック"
XlsCreator1.Cell("A1").Attr.FontPoint = 12
XlsCreator1.Cell("A1").Attr.FontColor = ExcelCreator.xlColor.xcRed
XlsCreator1.Cell("A1").Attr.FontStyle = ExcelCreator.xlFontStyle.xsBold
XlsCreator1.Cell("A1").Attr.FontULine = ExcelCreator.xlFontULine.fuDouble
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック";
xlsCreator1.Cell("A1").Attr.FontPoint = 12;
xlsCreator1.Cell("A1").Attr.FontColor = ExcelCreator.xlColor.xcRed;
xlsCreator1.Cell("A1").Attr.FontStyle = ExcelCreator.xlFontStyle.xsBold;
xlsCreator1.Cell("A1").Attr.FontULine = ExcelCreator.xlFontULine.fuDouble;
xlsCreator1.CloseBook(true);


Cell/Pos.Attr.FontStyle プロパティ

ExcelCreator.Cell/Pos.Attr.FontStyle プロパティ

フォントスタイルを設定します。

書式

[VB.NET]
  Public WriteOnly Property FontStyle() As ExcelCreator.xlFontStyle

[C#]
  public ExcelCreator.xlFontStyle FontStyle [set]

設定値

    xlFontStyle
      xlFontStyle 列挙体のメンバで設定します。

      スタイル
        定数                内容
        xsNormal            標準(デフォルト値)
        xsBold              太字
        xsItalic            斜体
        xsBold + xsItalic   太字 + 斜体

      文字飾り１
        定数                内容
        xsStrike            取消し線

      文字飾り２
        定数                内容
        xsUp                上付き
        xsDown              下付き

参照
[C# .NET で引数に 2 つ以上の列挙体のメンバを設定する方法]

コーディング例

A1 セルに「MS Pゴシック」、フォントサイズを「13ポイント」、フォント色を「赤色」、「太字」「二重下線」を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック"
XlsCreator1.Cell("A1").Attr.FontPoint = 12
XlsCreator1.Cell("A1").Attr.FontColor = ExcelCreator.xlColor.xcRed
XlsCreator1.Cell("A1").Attr.FontStyle = ExcelCreator.xlFontStyle.xsBold
XlsCreator1.Cell("A1").Attr.FontULine = ExcelCreator.xlFontULine.fuDouble
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック";
xlsCreator1.Cell("A1").Attr.FontPoint = 12;
xlsCreator1.Cell("A1").Attr.FontColor = ExcelCreator.xlColor.xcRed;
xlsCreator1.Cell("A1").Attr.FontStyle = ExcelCreator.xlFontStyle.xsBold;
xlsCreator1.Cell("A1").Attr.FontULine = ExcelCreator.xlFontULine.fuDouble;
xlsCreator1.CloseBook(true);


Cell/Pos.Attr.FontULine プロパティ

ExcelCreator.Cell/Pos.Attr.FontULine プロパティ

フォントの下線スタイルを設定します。

書式

[VB.NET]
  Public WriteOnly Property FontULine() As ExcelCreator.xlFontULine

[C#]
  public ExcelCreator.xlFontULine FontULine [set]

設定値

    xlFontULine
      フォントの下線スタイルを示す xlFontULine 列挙体のメンバで設定します。

      スタイル
        定数         内容
        fuDefault    デフォルト値
        fuNone       下線なし
        fuNormal     一重下線
        fuDouble     二重下線

コーディング例

A1 セルに「MS Pゴシック」、フォントサイズを「13ポイント」、フォント色を「赤色」、「太字」「二重下線」を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック"
XlsCreator1.Cell("A1").Attr.FontPoint = 12
XlsCreator1.Cell("A1").Attr.FontColor = ExcelCreator.xlColor.xcRed
XlsCreator1.Cell("A1").Attr.FontStyle = ExcelCreator.xlFontStyle.xsBold
XlsCreator1.Cell("A1").Attr.FontULine = ExcelCreator.xlFontULine.fuDouble
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック";
xlsCreator1.Cell("A1").Attr.FontPoint = 12;
xlsCreator1.Cell("A1").Attr.FontColor = ExcelCreator.xlColor.xcRed;
xlsCreator1.Cell("A1").Attr.FontStyle = ExcelCreator.xlFontStyle.xsBold;
xlsCreator1.Cell("A1").Attr.FontULine = ExcelCreator.xlFontULine.fuDouble;
xlsCreator1.CloseBook(true);


Cell/Pos.Attr.Format プロパティ

ExcelCreator.Cell/Pos.Attr.Format プロパティ

表示形式を設定します。

書式

[VB.NET]
  Public WriteOnly Property Format() As String

[C#]
  public string Format [set]

設定値

    以下の表示形式の記号に対応しています。

      記号               意味

      #                  有効桁数のみ表示します。(ゼロは表示しません)
      0(ゼロ)            数値の桁数が設定したゼロの数よりも少ない場合、ゼロが余分に表示されます。
      ?                  数値を小数点位置で揃えたり、分数であらわす場合に除算記号で揃えるように表示します。
      ,(カンマ)          1000 単位の区切り記号として表示したり、数値を 1000 で割って四捨五入して表示します。
      %                  数値に 100 を掛けてパーセント文字を追加して表示します。
      @                  文字列として表示します。
      _(アンダーバー)    文字幅分の間隔を空けて表示します。
      *(アスタリスク)    設定した文字をセル幅に達するまで繰り返し表示します。
                         * に続けて繰り返し表示する記号を設定します。
      [色]               表示形式で色を設定するのに角カッコ([])で色を囲んで設定します。
                         色コードは、書式部分の先頭に設定する必要があります。
                         色には、黒、青、水、緑、紫、赤、白、黄を設定することができます。
      yy                 (年)00 ～ 99
      yyy                (年)1900 ～ 9999
      m                  (月)1 ～ 12
      mm                 (月)01 ～ 12
      mmm                (月)Jan ～ Dec
      mmmm               (月)January ～ December
      mmmmm              (月)J ～ D (月の頭文字))
      d                  (日)1 ～ 31
      dd                 (日)01 ～ 31
      ddd                (日)Sun ～ Sat
      dddd               (日)Sunday ～ Saturday
      h                  (時)0 ～ 23
      hh                 (時)00 ～ 23
      m                  (分)0 ～ 59
      mm                 (分)00 ～ 59
      s                  (秒)0 ～ 59
      ss                 (秒)00 ～ 59
      h AM/PM            (時)0 ～ 23 AM/PM (AM,PM は時間によりかわる)
      h:m:s am/pm        (時)0 ～ 23: (分) 0～59: (秒) 0～59 am/pm

コーディング例

セルに様々な表示形式を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A1").Attr.Format = "[色5]#.#"         '色を付けて表示
XlsCreator1.Cell("A1").Long = 100
XlsCreator1.Cell("A2").Attr.Format = "###,###,###,###"  'カンマ区切り
XlsCreator1.Cell("A2").Long = 1000000000
XlsCreator1.Cell("A3").Attr.Format = "\""\\\""000.00"   '\マークを付ける
XlsCreator1.Cell("A3").Long = 1000000
XlsCreator1.Cell("A4").Attr.Format = ";[赤]-0.0"        '値がマイナスの時に赤色にする
XlsCreator1.Cell("A4").Long = -123456
XlsCreator1.Cell("A5").Attr.Format = ";;""ZERO"""       '値が 0 の時に、ZERO と表示する
XlsCreator1.Cell("A5").Long = 0
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A1").Attr.Format = "[色5]#.#";         //色を付けて表示
xlsCreator1.Cell("A1").Long = 100;
xlsCreator1.Cell("A2").Attr.Format = "###,###,###,###";  //カンマ区切り
xlsCreator1.Cell("A2").Long = 1000000000;
xlsCreator1.Cell("A3").Attr.Format = "\\000.00";         //\\マークを付ける
xlsCreator1.Cell("A3").Long = 1000000;
xlsCreator1.Cell("A4").Attr.Format = ";[赤]-0.0";        //値がマイナスの時に赤色にする
xlsCreator1.Cell("A4").Long = -123456;
xlsCreator1.Cell("A5").Attr.Format = ";;\\ZERO\\";       //値が 0 の時に ZERO と表示する
xlsCreator1.Cell("A5").Long = 0;
xlsCreator1.CloseBook(true);


Cell/Pos.Attr.Joint プロパティ

ExcelCreator.Cell/Pos.Attr.Joint プロパティ

指定範囲のセルに「セルを結合する」を設定します。

書式

[VB.NET]
  Public WriteOnly Property Joint() As Boolean

[C#]
  public bool Joint [set]

設定値

      値        内容
      True      セルを結合する。
      False     セルを結合しない。(デフォルト値)

解説
結合したセルに書式の属性やデータの設定を行うには、結合セル全体を設定してください。
例：
Cell("A1:C2").Attr.Joint = True Cell("A1:C2").Attr.FontName = "MS 明朝"

コーディング例

A10 ～ D10 セルを結合します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A10:D10").Str = "abcde"
XlsCreator1.Cell("A10:D10").Attr.Joint = True
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A10:D10").Str = "abcde";
xlsCreator1.Cell("A10:D10").Attr.Joint = true;
xlsCreator1.CloseBook(true);

注意事項
オーバーレイ元ファイルで結合されているセルや、プログラム中で結合したセルを解除することはできません。


Cell/Pos.Attr.LineALL

ExcelCreator.Cell/Pos.Attr.LineTop プロパティ
ExcelCreator.Cell/Pos.Attr.LineBottom プロパティ
ExcelCreator.Cell/Pos.Attr.LineRight プロパティ
ExcelCreator.Cell/Pos.Attr.LineLeft プロパティ
ExcelCreator.Cell/Pos.Attr.LineRightUp プロパティ
ExcelCreator.Cell/Pos.Attr.LineLeftUp プロパティ

上、下、左、右、左上がり斜線、右上がり斜線の各罫線を設定します。

書式

書式
[VB.NET]
  Public WriteOnly Property LineTop() As ExcelCreator.xlLineStyle
  Public WriteOnly Property LineBottom() As ExcelCreator.xlLineStyle
  Public WriteOnly Property LineLeft() As ExcelCreator.xlLineStyle
  Public WriteOnly Property LineRight() As ExcelCreator.xlLineStyle
  Public WriteOnly Property LineLeftUp() As ExcelCreator.xlLineStyle
  Public WriteOnly Property LineRightUp() As ExcelCreator.xlLineStyle

[C#]
  public ExcelCreator.xlLineStyle LineTop [set]
  public ExcelCreator.xlLineStyle LineBottom [set]
  public ExcelCreator.xlLineStyle LineLeft [set]
  public ExcelCreator.xlLineStyle LineRight [set]
  public ExcelCreator.xlLineStyle LineLeftUp [set]
  public ExcelCreator.xlLineStyle LineRightUp [set]

設定値

    xlLineStyle
      xlLineStyle 列挙体のメンバで設定します。

      定数          内容
      lsDefault     デフォルト値
      lsNone        罫線なし
      lsNormal      実線
      lsThick       太線
      lsBroken      破線
      lsDot         点線
      lsThick2      極太線
      lsDouble      二重線
      lsSlender     細実線
      lsMidBroken   中破線
      lsSlnChain1   細一点鎖線
      lsMidChain1   中一点鎖線
      lsSlnChain2   細二点鎖線
      lsMidChain2   中二点鎖線
      lsMidChains   中一点斜鎖線

    色を設定する場合の設定値は、「補足」-「色を示す定数」を参照してください。

参照
[C# .NET で引数に 2 つ以上の列挙体のメンバを設定する方法]

コーディング例

セルに各罫線を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("C2:F2").Attr.LineTop = ExcelCreator.xlLineStyle.lsNormal     '実線
XlsCreator1.Cell("C5:F5").Attr.LineBottom = ExcelCreator.xlLineStyle.lsBroken  '破線
XlsCreator1.Cell("C2:C5").Attr.LineLeft = ExcelCreator.xlLineStyle.lsThick + ExcelCreator.xlColor.xcRed  '赤太線
XlsCreator1.Cell("F2:F5").Attr.LineRight = ExcelCreator.xlLineStyle.lsDot + ExcelCreator.xlColor.xcGreen '緑点線
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("C2:F2").Attr.LineTop = ExcelCreator.xlLineStyle.lsNormal;     //実線
xlsCreator1.Cell("C5:F5").Attr.LineBottom = ExcelCreator.xlLineStyle.lsBroken;  //破線
xlsCreator1.Cell("C2:C5").Attr.LineLeft = (ExcelCreator.xlLineStyle)((Int32)ExcelCreator.xlLineStyle.lsThick + (Int32)ExcelCreator.xlColor.xcRed);  //赤太線
xlsCreator1.Cell("F2:F5").Attr.LineRight = (ExcelCreator.xlLineStyle)((Int32)ExcelCreator.xlLineStyle.lsDot + (Int32)ExcelCreator.xlColor.xcGreen); //緑点線
xlsCreator1.CloseBook(true);

注意事項
LineLeftUp プロパティ、LineRightUp プロパティを同じセルに設定した場合、クロスした罫線になりますが、Excel の制限により両方の線種や色を別々に設定出来ないため、LineRightUp プロパティで設定した線種や色の値が有効になります。


Cell/Pos.Attr.OverReturn プロパティ

ExcelCreator.Cell/Pos.Attr.OverReturn プロパティ

「折り返して全体を表示」を設定します。

書式

[VB.NET]
  Public WriteOnly Property OverReturn() As Boolean

[C#]
  public bool OverReturn [set]

設定値

      値        内容
      True      「折り返して全体を表示」を設定します。
      False     「折り返して全体を表示」を設定しない。(デフォルト値)

コーディング例

D7 セルに「折り返して全体を表示」を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("D7").Str = "abcde"
XlsCreator1.Cell("D7").Attr.OverReturn = True
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("D7").Str = "abcde";
xlsCreator1.Cell("D7").Attr.OverReturn = true;
xlsCreator1.CloseBook(true);


Cell/Pos.Attr.Pattern プロパティ

ExcelCreator.Cell/Pos.Attr.Pattern プロパティ

パターンを設定します。

書式

[VB.NET]
  Public WriteOnly Property Pattern() As ExcelCreator.xlPattern

[C#]
  public ExcelCreator.xlPattern Pattern [set]

設定値

    xlPattern
      xlPattern 列挙体のメンバで設定します。

      定数      内容
      pn01      塗りつぶし(デフォルト値)
      pn02      ５０％灰色
      pn03      ７５％灰色
      pn04      ２５％灰色
      pn05      横縞
      pn06      縦縞
      pn07      右下がり斜線 縞
      pn08      左下がり斜線 縞
      pn09      左下がり斜線 格子
      pn10      極太線 左下がり斜線 格子
      pn11      実線 横縞
      pn12      実線 縦縞
      pn13      実線 右下がり斜線 縞
      pn14      実線 左下がり斜線 縞
      pn15      実線 横 格子
      pn16      実線 左下がり斜線 格子
      pn17      １２.５％灰色
      pn18      ６.２５％灰色

    色を設定する場合の設定値は、「補足」-「色を示す定数」を参照してください。

解説
パターンと色の両方を設定する場合は、「 + 」演算子で結合して設定します。

参照
[C# .NET で引数に 2 つ以上の列挙体のメンバを設定する方法]

コーディング例

B2 ～ D3 セルのパターン (左下がり斜線 縞) と背景色 (青) を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("B2:D3").Attr.Pattern = ExcelCreator.xlPattern.pn08
XlsCreator1.Cell("B2:D3").Attr.BackColor = ExcelCreator.xlColor.xcBlue
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("B2:D3").Attr.Pattern = ExcelCreator.xlPattern.pn08;
xlsCreator1.Cell("B2:D3").Attr.BackColor = ExcelCreator.xlColor.xcBlue;
xlsCreator1.CloseBook(true);


Cell/Pos.Attr.PosHorz プロパティ

ExcelCreator.Cell/Pos.Attr.PosHorz プロパティ

文字の配置 (横位置) を設定します。

書式

[VB.NET]
  Public WriteOnly Property PosHorz() As ExcelCreator.xlPosHorz

[C#]
  public ExcelCreator.xlPosHorz PosHorz [set]

設定値

    xlPosHorz
      文字の水平位置を示す xlPosHorz 列挙体のメンバを設定します。

      定数          値        内容
                     1～15    左詰めインデント値
      phNormal      20        標準 (デフォルト値)
      phLeft        21        左詰め
      phCenter      22        中央揃え
      phRight       23        右詰め
      phLoop        24        繰り返し
      phBothEven    25        両端揃え
      phSelCenter   26        選択範囲内で中央
      phEven        27        均等割付

解説
C# で左詰めインデントとして直接数値を設定するには、 (ExcelCreator.xlPosHorz.xlPosHorz)21 の様にキャストして設定します。

コーディング例

D7 ～ E8 セルの配置 (横位置) を「中央揃え」を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("D7").Str = "abcde"
XlsCreator1.Cell("D7:E8").Attr.PosHorz = ExcelCreator.xlPosHorz.phCenter
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("D7").Str = "abcde";
xlsCreator1.Cell("D7:E8").Attr.PosHorz = ExcelCreator.xlPosHorz.phCenter;
xlsCreator1.CloseBook(true);


Cell/Pos.Attr.PosTurn プロパティ

ExcelCreator.Cell/Pos.Attr.PosTurn プロパティ

文字方向 (角度) を設定します。

書式

[VB.NET]
  Public WriteOnly Property PosTurn() As ExcelCreator.xlPosTurn

[C#]
  public ExcelCreator.xlPosTurn PosTurn [set]

設定値

    xlPosTurn
      文字列の回転角度を示す xlPosTurn 列挙体のメンバで設定します。

      定数         値          内容
                  -90 ～ 90    設定した角度
      ptHorz      100          横 (デフォルト値)
      ptVert      101          縦
      ptRvTurn90  102          半時計回りに 90 度
      ptTurn90    103          時計回りに 90 度

解説
C# で設定した角度を直接数値として設定するには、(ExcelCreator.xlPosTurn.xlPosTurn)90 や (ExcelCreator.xlPosTurn.xlPosTurn)(-90) の様にキャストして設定します。

コーディング例

D7 セルの文字方向 (角度) を「時計回りに 90 度回転」に設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("D7").Str = "abcde"
XlsCreator1.Cell("D7").Attr.PosTurn = ExcelCreator.xlPosTurn.ptTurn90
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("D7").Str = "abcde";
xlsCreator1.Cell("D7").Attr.PosTurn = ExcelCreator.xlPosTurn.ptTurn90;
xlsCreator1.CloseBook(true);


Cell/Pos.Attr.PosVert プロパティ

ExcelCreator.Cell/Pos.Attr.PosVert プロパティ

文字の配置 (縦位置) を設定します。

書式

[VB.NET]
  Public WriteOnly Property PosVert() As ExcelCreator.xlPosVert

[C#]
  public ExcelCreator.xlPosVert PosVert [set]

設定値

    xlPosVert
      文字の垂直位置を示す xlPosVert 列挙体のメンバで設定します。

      定数          値    内容
      pvUp           0    上詰め
      pvCenter       1    中央揃え
      pvDown         2    下詰め (デフォルト値)
      pvBothEven     3    両端揃え
      pvEven         4    均等割付

コーディング例

D7 セルの配置 (縦位置) を「中央揃え」に設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("D7").Str = "abcde"
XlsCreator1.Cell("D7").Attr.PosVert = ExcelCreator.xlPosVert.pvCenter
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("D7").Str = "abcde";
xlsCreator1.Cell("D7").Attr.PosVert = ExcelCreator.xlPosVert.pvCenter;
xlsCreator1.CloseBook(true);


Attr クラス (Cell/Pos クラス)

ExcelCreator.Cell.Attr クラス
ExcelCreator.Pos.Attr クラス

セルの属性を設定します。

書式

[VB.NET]
  Public Cell.Attr
  Public Pos.Attr

[C#]
  public Cell.Attr
  public Pos.Attr

解説
このクラスの全てのメンバの一覧については、以下の Cell/Pos.Attr メンバを参照してください。

メンバ

パブリック プロパティ
Format プロパティ | 表示書式を設定します。
FontName プロパティ | フォント名を設定します。
FontPoint プロパティ | フォントサイズを設定します。
FontColor プロパティ | フォント色を設定します。
FontStyle プロパティ | フォントスタイルを設定します。
FontULine プロパティ | フォントの下線スタイルを設定します。
LineTop プロパティ | 上罫線を設定します。
LineBottom プロパティ | 下罫線を設定します。
LineLeft プロパティ | 左罫線を設定します。
LineRight プロパティ | 右罫線を設定します。
LineLeftUp プロパティ | 左上罫線を設定します。
LineRightUp プロパティ | 右上罫線を設定します。
Pattern プロパティ | パターンを設定します。
BackColor プロパティ | 背景色を設定します。
PosHorz プロパティ | 文字の配置 (横位置) を設定します。
PosVert プロパティ | 文字の配置 (縦位置) を設定します。
PosTurn プロパティ | 文字方向 (角度) を設定します。
OverReturn プロパティ | 「折り返して全体を表示」を設定します。
Fit プロパティ | 「縮小して全体を表示する」を設定します。
Joint プロパティ | 指定範囲のセルに「セルを結合する」を設定します。

パブリック メソッド
Box メソッド 設定したセル領域を囲む Box 罫線を設定します。


AttrNo プロパティ

ExcelCreator.Cell/Pos.AttrNo プロパティ

セルの属性番号を取得します。

書式

[VB.NET]
  Public ReadOnly Property AttrNo() As Integer

[C#]
  public int AttrNo [get]

設定値

    セルの属性番号を格納する変数を設定します。

解説
AttrNo プロパティを使用して、各セルで保持する罫線や表示形式等の書式情報を 属性番号として取得し、取得した属性番号は Long2 / Str2 / Double2 / Value2 の各メソッドを使用して、データの差し込みと同時に取得した属性番号と同じ書式情報 を設定することができます。

参照
[Long2 メソッド] | [Str2 メソッド] | [Double2 メソッド] | [Value2 メソッド]

コーディング例

セルの属性番号を取得し、Long2 / Str2 / Double2 / Value2 の各メソッドで別のセルに属性番号と値を設定します。

[VB.NET]
Dim nAttrNo As Integer
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")
nAttrNo = XlsCreator1.Cell("A1").AttrNo
XlsCreator1.Cell("B1").Long2(200, nAttrNo)
XlsCreator1.Cell("C1").Double2(200.1, nAttrNo)
XlsCreator1.Cell("D1").Str2("文字列", nAttrNo)
XlsCreator1.Cell("E1").Value2("バリアント型", nAttrNo)
XlsCreator1.CloseBook(True)

[C#]
Int32 nAttrNo;
xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");
nAttrNo = xlsCreator1.Cell("A1").AttrNo;
xlsCreator1.Cell("B1").Long2(200, nAttrNo);
xlsCreator1.Cell("C1").Double2(200.1, nAttrNo);
xlsCreator1.Cell("D1").Str2("文字列", nAttrNo);
xlsCreator1.Cell("E1").Value2("バリアント型", nAttrNo);
xlsCreator1.CloseBook(true);

注意事項
Cell クラスに変数名を設定した場合は対応しておりません。


Break プロパティ

ExcelCreator.Cell/Pos.Break プロパティ

改ページの設定 / 解除を設定します。

書式

[VB.NET]
  Public WriteOnly Property Break() As Boolean

[C#]
  public bool Break [set]

設定値

      値      内容
      True    改ページを設定します
      False   改ページを解除します。

解説
行に対する改ページ、列に対する改ページ、行列に対する改ページを設定できます。
行方向に 1026 個まで、列方向に 256 個まで設定できます。

コーディング例

A35 セルに改ページを設定設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A35").Break = True
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A35").Break = true;
xlsCreator1.CloseBook(true);


Clear メソッド

ExcelCreator.Cell/Pos.Clear メソッド

セルをクリア (初期化) します。

書式

[VB.NET]
  Public Sub Clear()

[C#]
  public void Clear()

コーディング例

A1:B1 セル、A3 セルをクリアします。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A1:B1").Attr.Pattern = ExcelCreator.xlPattern.pn02
XlsCreator1.Cell("A1:B1").Clear()
XlsCreator1.Cell("A3:B3").Attr.Pattern = ExcelCreator.xlPattern.pn03
XlsCreator1.Cell("A3").Clear()
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A1:B1").Attr.Pattern = ExcelCreator.xlPattern.pn02;
xlsCreator1.Cell("A1:B1").Clear();
xlsCreator1.Cell("A3:B3").Attr.Pattern = ExcelCreator.xlPattern.pn03;
xlsCreator1.Cell("A3").Clear();
xlsCreator1.CloseBook(true);

注意事項
Clear メソッドは Cell クラスに変数名を設定した場合は対応しておりません。


ColWidth プロパティ

ExcelCreator.Cell/Pos.ColWidth プロパティ

セルの列幅を設定します。

書式

[VB.NET]
  Public WriteOnly Property ColWidth() As Double

[C#]
  public double ColWidth [set]

解説
列幅を半角文字数 (0 ～ 255 文字) で設定します。
0 を設定した場合は非表示列となります。

参照
[RowHeight プロパティ]

コーディング例

A ～ G 列の列幅を 20 文字、10 行目の行高を 20 ポイントに設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A1:G1").ColWidth = 20
XlsCreator1.Cell("G10").RowHeight = 20
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A1:G1").ColWidth = 20;
xlsCreator1.Cell("G10").RowHeight = 20;
xlsCreator1.CloseBook(true);

注意事項
・ ColWidth2 プロパティで取得した値を ColWidth プロパティに設定しないでください。


ColWidth2 プロパティ

ExcelCreator.Cell/Pos.ColWidth2 プロパティ

セルの幅を取得 / 設定します。

書式

[VB.NET]
  Public Property ColWidth2() As Integer

[C#]
  public int ColWidth2 [get, set]

解説
ColWidth2 プロパティは、特定のセルの幅を別のセル幅に合わせる場合に使用します。
Excel 上では、セル幅は [文字数 × 256 + 余白(1/256 文字単位)] で管理され、ColWidth2 プロパティは、この値をマイナスの値として取得します。ColWidth2 プロパティで取得した値を他のセルに設定することにより、セル幅を合わせることができます。

参照
[RowHeight2 プロパティ]

コーディング例

C 列の列幅を B 列の列幅に合わせます。

[VB.NET]
Dim nCellColWidth2 As Inetger
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
nCellColWidth2 = XlsCreator1.Cell("B").ColWidth2
XlsCreator1.Cell("C").ColWidth2 = nCellColWidth2
XlsCreator1.CloseBook(True)

[C#]
int nCellColWidth2;
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
nCellColWidth2 = xlsCreator1.Cell("B").ColWidth2;
xlsCreator1.Cell("C").ColWidth2 = nCellColWidth2;
xlsCreator1.CloseBook(true);

注意事項
・ | 下記の様に、ColWidth2 プロパティの設定値に直接 ColWidtht2 プロパティを設定することはできません。ColWidth2 プロパティの取得値を変数に格納し、その変数を設定してください。 誤) XlsCreator1.Cell("A").ColWidth2 = XlsCreator1.Cell("B").ColWidth2 正) Dim nWidth As Inetger nWidth = XlsCreator1.Cell("B").ColWidth2 XlsCreator1.Cell("A").ColWidth2 = nWidth
・ | ColWidth2 プロパティで取得した値を ColWidth プロパティに設定しないでください。ColWidth プロパティは文字数で幅を設定しますが、ColWidth2 プロパティは Excel が保持する論理値を直接扱います。
・ | 結合したセルの列幅を取得した場合、セル全体の列幅ではなく、結合したセルの先頭セルの列幅を取得します。


Copy メソッド

ExcelCreator.Cell/Pos.Copy メソッド

セルをコピーします。

書式

[VB.NET]
  Public Sub Copy()
  Public Sub Copy(ByVal strCell As String)

[C#]
  public void Copy()
  public void Copy(System.String strCell)

設定値

    strCell
      コピー先のセルを設定します。

解説
コピーするセルは、単一セル、セル範囲指定に対応しています。
引数を省略した場合、セルがメモリ上にコピーされ、Paste メソッドで設定した セルに貼り付けることができます。
Pos クラスでセル範囲を設定する場合、終了座標≧開始座標と設定してください。

参照
[Paste メソッド]

コーディング例

A1:B1 範囲セルを A2 セルにコピーし、A1 セルを C2 セルにコピーします。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A1:B1").Attr.Pattern = ExcelCreator.xlPattern.pn03
XlsCreator1.Cell("A1:B1").Str = "セルコピー元"
XlsCreator1.Cell("A1:B1").Copy("A2")
XlsCreator1.Cell("A1").Copy("C2")
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A1:B1").Attr.Pattern = ExcelCreator.xlPattern.pn03;
xlsCreator1.Cell("A1:B1").Str = "セルコピー元";
xlsCreator1.Cell("A1:B1").Copy("A2");
xlsCreator1.Cell("A1").Copy("C2");
xlsCreator1.CloseBook(true);

注意事項
・ | コピー元セルのセル属性と値のみコピーします。
・ | Copy メソッドの Cell クラスに変数名を設定した場合は対応しておりません。
・ | Excel ファイルのブック間、シート間のコピー・貼り付けには対応しておりません。


Double プロパティ

ExcelCreator.Cell/Pos.Double プロパティ

実数を取得 / 設定します。

書式

[VB.NET]
  Public Property Double() As Double

[C#]
  public double Double [get, set]

設定値

    実数を設定します。

解説
設定したセルに計算式や関数式が設定されている場合は、その結果値を実数で取得する 事ができます。

参照
[セル情報の設定と取得について (Cell クラスの場合)]

コーディング例

A1 セルに値を設定し、作成したファイルのセルの値を取得します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A1").Double = 12.345    'セル A1 には 12.345 が入ります
XlsCreator1.CloseBook(True)

Dim nDouble As Double
XlsCreator1.ReadBook(Application.StartupPath & "\ExcelFile.xls")
nDouble = XlsCreator1.Cell("A1").Double    'nDouble には 12.345 が入ります
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A1").Double = 12.345;    //セル A1 には 12.345 が入ります
xlsCreator1.CloseBook(true);

Double nDouble;
xlsCreator1.ReadBook(Application.StartupPath + @"\ExcelFile.xls");
nDouble = xlsCreator1.Cell("A1").Double;    //nDouble には 12.345 が入ります
xlsCreator1.CloseBook(true);

注意事項
Cell クラスに変数名を設定した場合、取得には対応しておりません。


Double2 メソッド

ExcelCreator.Cell/Pos.Double2 メソッド

実数と属性番号を設定します。

書式

[VB.NET]
  Public Sub Double2(ByVal val As Double, ByVal attr As Integer)

[C#]
  public void Double2(System.Double val , System.Int32 attr)

設定値

    value
      属性番号の値と共に設定する実数値を設定します。
    attrno
      AttrNo プロパティで取得した属性番号の値を設定します。

解説
AttrNo プロパティを使用して、各セルで保持する罫線や表示形式等の書式情報を 属性番号として取得し、取得した属性番号は Double2 メソッドを使用して、 データの差し込みと同時に取得した属性番号と同じ書式情報を設定することができます。

参照
[AttrNo プロパティ]

コーディング例

設定したセルの属性番号を取得し、Long2 / Str2 / Double2 / Value2 の各 メソッドで、その属性番号と値を設定します。

[VB.NET]
Dim nAttrNo As Integer
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")
nAttrNo = XlsCreator1.Cell("A1").AttrNo
XlsCreator1.Cell("B1").Long2(200, nAttrNo)
XlsCreator1.Cell("C1").Double2(200.1, nAttrNo)
XlsCreator1.Cell("D1").Str2("文字列", nAttrNo)
XlsCreator1.Cell("E1").Value2("バリアント型", nAttrNo)
XlsCreator1.CloseBook(True)

[C#]
Int32 nAttrNo;
xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");
nAttrNo = xlsCreator1.Cell("A1").AttrNo;
xlsCreator1.Cell("B1").Long2(200, nAttrNo);
xlsCreator1.Cell("C1").Double2(200.1, nAttrNo);
xlsCreator1.Cell("D1").Str2("文字列", nAttrNo);
xlsCreator1.Cell("E1").Value2("バリアント型", nAttrNo);
xlsCreator1.CloseBook(true);


Func メソッド

ExcelCreator.Cell/Pos.Func メソッド

関数の書き込みをします。結果を示す値も同時に設定できます。

書式

[VB.NET]
  Public Sub Func(ByVal strFunc As String, ByVal objAns As Object)

[C#]
  public void Func(System.String strFunc , System.Object objAns)

設定値

    strFunc
      計算式や関数式を設定します。
    objAns
      strFunc に対する結果値を設定します。

解説
Func メソッドで計算結果をあらかじめ設定することで、ExcelCreator 5.0 for .NET で作成した Excel ファイルを Excel で開き、修正を行わずに終了した時に表示される保存の確認メッセージを非表示にできます。

コーディング例

A2 セルに 1000 、A4 セルに計算式 (=A2+999)、C1 セルに計算式と計算結果 (=A2+999, 1999) を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A2").Long = 1000
XlsCreator1.Cell("A4").Func("=A2+999", "")
XlsCreator1.Cell("C1").Func("=A2+999", "1999")
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A2").Long = 1000;
xlsCreator1.Cell("A4").Func("=A2+999", null);
xlsCreator1.Cell("C1").Func("=A2+999", "1999");
xlsCreator1.CloseBook(true);


Long プロパティ

ExcelCreator.Cell/Pos.Long プロパティ

整数を取得 / 設定します。

書式

[VB.NET]
  Public Property Long() As Integer

[C#]
  public int Long [get, set]

設定値

    整数を設定します。

解説
セルに計算式や関数式が設定されている場合は、その結果値を整数で取得することが できます。

参照
[セル情報の設定と取得について (Cell クラスの場合)]

コーディング例

A1 セルに値を設定し、作成したファイルのセルの値を取得します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A2").Long = 1000     'セル A2 には 1000 が入ります
XlsCreator1.CloseBook(True)

Dim nLong As Long
XlsCreator1.ReadBook(Application.StartupPath & "\ExcelFile.xls")
nLong = XlsCreator1.Cell("A2").Long    'nLong には 1000 が入ります
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A2").Long = 1000;     //セル A2 には 1000 が入ります
xlsCreator1.CloseBook(true);

int nValue;
xlsCreator1.ReadBook(Application.StartupPath + @"\ExcelFile.xls");
nValue = xlsCreator1.Cell("A2").Long;    //nLong には 1000 が入ります
xlsCreator1.CloseBook(true);

注意事項
・ | Cell クラスに変数名を設定した場合、取得には対応しておりません。
・ | Excel ファイルが保持する整数値は Int32 型の 32bit 値であるため、Int32 型の範囲を超える値を設定する場合は、Double プロパティを使用してください。


Long2 メソッド

ExcelCreator.Cell/Pos.Long2 メソッド

整数と属性番号を設定します。

書式

[VB.NET]
  Public Sub Long2(ByVal val As Integer, ByVal attr As Integer)

[C#]
  public void Long2(System.Int32 val , System.Int32 attr)

設定値

    value
      属性番号の値と共に設定する整数値を設定します。
    attrno
      AttrNo プロパティで取得した属性番号の値を設定します。

解説
AttrNo プロパティを使用して、各セルで保持する罫線や表示形式等の書式情報を 属性番号として取得し、取得した属性番号は Long2 メソッドを使用して、 データの差し込みと同時に取得した属性番号と同じ書式情報を設定することができます。

参照
[AttrNo プロパティ]

コーディング例

設定したセルの属性番号を取得し、Long2 / Str2 / Double2 / Value2 の各 メソッドで、その属性番号と値を設定します。

[VB.NET]
Dim nAttrNo As Integer
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")
nAttrNo = XlsCreator1.Cell("A1").AttrNo
XlsCreator1.Cell("B1").Long2(200, nAttrNo)
XlsCreator1.Cell("C1").Double2(200.1, nAttrNo)
XlsCreator1.Cell("D1").Str2("文字列", nAttrNo)
XlsCreator1.Cell("E1").Value2("バリアント型", nAttrNo)
XlsCreator1.CloseBook(True)

[C#]
Int32 nAttrNo;
xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");
nAttrNo = xlsCreator1.Cell("A1").AttrNo;
xlsCreator1.Cell("B1").Long2(200, nAttrNo);
xlsCreator1.Cell("C1").Double2(200.1, nAttrNo);
xlsCreator1.Cell("D1").Str2("文字列", nAttrNo);
xlsCreator1.Cell("E1").Value2("バリアント型", nAttrNo);
xlsCreator1.CloseBook(true);

注意事項
Excel ファイルが保持する整数値は Int32 型の 32bit 値であるため、Int32 型の範囲を超える値を設定する場合は、Double2 メソッドを使用してください。


Paste メソッド

ExcelCreator.Cell/Pos.Paste メソッド

Copy メソッドでコピーしたセルを貼り付けます。

書式

[VB.NET]
  Public Sub Paste()

[C#]
  public void Paste()

参照
[Copy メソッド]

コーディング例

A1 セルのコピーを A3 セルに貼り付けます。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A1").Attr.Pattern = ExcelCreator.xlPattern.pn03
XlsCreator1.Cell("A1").Str = "セルコピー元"
XlsCreator1.Cell("A1").Copy("")
XlsCreator1.Cell("A3").Paste()
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A1").Attr.Pattern = ExcelCreator.xlPattern.pn03;
xlsCreator1.Cell("A1").Str = "セルコピー元";
xlsCreator1.Cell("A1").Copy("");
xlsCreator1.Cell("A3").Paste();
xlsCreator1.CloseBook(true);

注意事項
・ | コピー元セルのセル属性と値のみコピーします。
・ | Paste メソッドの Cell クラスに変数名を設定した場合は対応しておりません。
・ | Excel ファイルのブック間、シート間のコピー・貼り付けには対応しておりません。


RowHeight プロパティ

ExcelCreator.Cell/Pos.RowHeight プロパティ

セルの高さを設定します。

書式

[VB.NET]
  Public WriteOnly Property RowHeight() As Double

[C#]
  public double RowHeight [set]

解説
高さをポイント (0 ～ 409) で設定します。
0 を設定した場合は非表示行となります。

参照
[ColWidth プロパティ]

コーディング例

A ～ G 列の列幅を 20 文字、10 行目の行高を 20 ポイントに設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A1:G1").ColWidth = 20
XlsCreator1.Cell("G10").RowHeight = 20
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A1:G1").ColWidth = 20;
xlsCreator1.Cell("G10").RowHeight = 20;
xlsCreator1.CloseBook(true);
注意事項
・ RowHeight2 プロパティで取得した値を RowHeight プロパティに設定しないでください。


RowHeight2 プロパティ

ExcelCreator.Cell/Pos.RowHeight2 プロパティ

セルの高さを取得 / 設定します。

書式

[VB.NET]
  Public Property RowHeight2() As Double

[C#]
  public double RowHeight2 [get, set]

解説
高さをポイント (0 ～ 409) で設定します。
0 を設定した場合は非表示行となります。
取得した値を他の行に設定することで、セルの高さを合わせることができます。

参照
[ColWidt2 プロパティ]

コーディング例

3 行目の行高を 2 行目の行高に合わせます。

[VB.NET]
Dim dblCellRowHeight2 As Double
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", Application.StartupPath & "\ExcelTemplate.xls")
dblCellRowHeight2 = XlsCreator1.Cell("A2").RowHeight2
XlsCreator1.Cell("A3").RowHeight2 = dblCellRowHeight2
XlsCreator1.CloseBook(True)

[C#]
double dblCellRowHeight2;
xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", Application.StartupPath + @"\ExcelTemplate.xls");
dblCellRowHeight2 = xlsCreator1.Cell("A2").RowHeight2;
xlsCreator1.Cell("A3").RowHeight2 = dblCellRowHeight2;
xlsCreator1.CloseBook(true);

注意事項
・ | 下記の様に、RowHeight2 プロパティの設定値に直接 RowHeight2 プロパティを設定することはできません。RowHeight2 プロパティの取得値を変数に格納し、その変数を設定してください。 誤) XlsCreator1.Cell("A3").RowHeight2 = XlsCreator1.Cell("A2").RowHeight2 正) Dim dblHeight As Double dblHeight = XlsCreator1.Cell("A2").RowHeight2 XlsCreator1.Cell("A3").RowHeight2 = dblHeight
・ | RowHeight2 プロパティに設定する値は、RowHeight2 プロパティで取得した値を設定してください。


Str プロパティ

ExcelCreator.Cell/Pos.Str プロパティ

文字列を取得 / 設定します。

書式

[VB.NET]
  Public Property Str() As String

[C#]
  public string Str [get, set]

解説
セルに計算式や関数式が設定されている場合は、その結果値を文字列で取得することが できます。

参照
[セル情報の設定と取得について (Cell クラスの場合)]

コーディング例

A3 セルに値を設定し、作成したファイルのセルの値を取得します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A3").Str = "abcde"    'セル A3 には abcde が入ります
XlsCreator1.CloseBook(True)

Dim str1 As String
XlsCreator1.ReadBook(Application.StartupPath & "\ExcelFile.xls")
str1 = XlsCreator1.Cell("A3").Str       'str1 には abcde が入ります
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A3").Str = "abcde";    //セル A3 には abcde が入ります
xlsCreator1.CloseBook(true);

String str1;
xlsCreator1.ReadBook(Application.StartupPath + @"\ExcelFile.xls");
str1 = xlsCreator1.Cell("A3").Str;       //str1 には abcde が入ります
xlsCreator1.CloseBook(true);

注意事項
Cell クラスに変数名を設定した場合、取得には対応しておりません。


Str2 メソッド

ExcelCreator.Cell/Pos.Str2 メソッド

文字列と属性番号を設定します。

書式

[VB.NET]
  Public Sub Str2(ByVal val As String, ByVal attr As Integer)

[C#]
  public void Str2(System.String val , System.Int32 attr)

設定値

    value
      属性番号の値と共に設定する文字列を設定します。
    attrno
      AttrNo プロパティで取得した属性番号の値を設定します。

解説
AttrNo プロパティを使用して、各セルで保持する罫線や表示形式等の書式情報を 属性番号として取得し、取得した属性番号は Str2 メソッドを使用して、 データの差し込みと同時に取得した属性番号と同じ書式情報を設定することができます。

参照
[AttrNo プロパティ]

コーディング例

設定したセルの属性番号を取得し、Long2 / Str2 / Double2 / Value2 の各 メソッドで、その属性番号と値を設定します。

[VB.NET]
Dim nAttrNo As Integer
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")
nAttrNo = XlsCreator1.Cell("A1").AttrNo
XlsCreator1.Cell("B1").Long2(200, nAttrNo)
XlsCreator1.Cell("C1").Double2(200.1, nAttrNo)
XlsCreator1.Cell("D1").Str2("文字列", nAttrNo)
XlsCreator1.Cell("E1").Value2("バリアント型", nAttrNo)
XlsCreator1.CloseBook(True)

[C#]
Int32 nAttrNo;
xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");
nAttrNo = xlsCreator1.Cell("A1").AttrNo;
xlsCreator1.Cell("B1").Long2(200, nAttrNo);
xlsCreator1.Cell("C1").Double2(200.1, nAttrNo);
xlsCreator1.Cell("D1").Str2("文字列", nAttrNo);
xlsCreator1.Cell("E1").Value2("バリアント型", nAttrNo);
xlsCreator1.CloseBook(true);


Value プロパティ

ExcelCreator.Cell/Pos.Value プロパティ

数値や文字列、日付などの値を設定 / 取得します。

書式

[VB.NET]
  Public Property Value() As Object

[C#]
  public object Value [get, set]

解説
セルに設定されている属性に関係なく、値を設定することができます。文字列を設定 した場合は文字列として値が設定され、数値で設定した場合は数値として設定されます。
また、値を取得することもできます。
計算式と共に計算結果をセルに設定する場合は、Func メソッドを使用してください。

参照
[セル情報の設定と取得について (Cell クラスの場合)]

コーディング例

各セルに実数・整数・文字列・関数を設定し作成した Excel ファイルのセルの値を取得します

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("B1").Value = 12.345     'セル B1 には 12.345 が入ります
XlsCreator1.Cell("B2").Value = 1000       'セル B2 には 1000 が入ります
XlsCreator1.Cell("B3").Value = "abcde"    'セル B3 には abcde が入ります
XlsCreator1.Cell("B4").Value = "=A2+999"  'セル B4 には =A2+999 が入ります"
XlsCreator1.CloseBook(True)

Dim objData As Object
XlsCreator1.ReadBook(Application.StartupPath & "\ExcelFile.xls")
objData = XlsCreator1.Cell("B1").Value    'objData には 12.345000 が入ります
objData = XlsCreator1.Cell("B2").Value    'objData には 1000.000000 が入ります
objData = XlsCreator1.Cell("B3").Value    'objData には abcde が入ります
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("B1").Value = 12.345;    //セル B1 には 12.345 が入ります
xlsCreator1.Cell("B2").Value = 1000;      //セル B2 には 1000 が入ります
xlsCreator1.Cell("B3").Value = "abcde";   //セル B3 には abcde が入ります
xlsCreator1.Cell("B4").Value = "=A2+999"; //セル B4 には =A2+999 が入ります"
xlsCreator1.CloseBook(true);

object objData;
xlsCreator1.ReadBook(Application.StartupPath + @"\ExcelFile.xls");
objData = xlsCreator1.Cell("B1").Value;   //objData には 12.345000 が入ります
objData = xlsCreator1.Cell("B2").Value;   //objData には 1000.000000 が入ります
objData = xlsCreator1.Cell("B3").Value;   //objData には abcde が入ります
xlsCreator1.CloseBook(true);

注意事項
Cell クラスに変数名を設定した場合、取得には対応しておりません。


Value2 メソッド

ExcelCreator.Cell/Pos.Value2 メソッド

数値や文字列、日付などの値と属性番号を設定します。

書式

[VB.NET]
  Public Sub Value2(ByVal objValue As Object, ByVal nAttrNo As Integer)

[C#]
  public void Value2(System.Object objValue , System.Int32 nAttrNo)

設定値

    objValue
      属性番号の値と共に設定する値を設定します。
    nAttrNo
      AttrNo プロパティで取得した属性番号を設定します。

解説
AttrNo プロパティを使用して、各セルで保持する罫線や表示形式等の書式情報を 属性番号として取得し、取得した属性番号は Value2 メソッドを使用して、 データの差し込みと同時に取得した属性番号と同じ書式情報を設定することができます。

参照
[AttrNo プロパティ]

コーディング例

セルの属性番号を取得し、Long2、Str2、Double2、Value2 の各 メソッドで属性番号と値を設定します。

[VB.NET]
Dim nAttrNo As Integer
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")
nAttrNo = XlsCreator1.Cell("A1").AttrNo
XlsCreator1.Cell("B1").Long2(200, nAttrNo)
XlsCreator1.Cell("C1").Double2(200.1, nAttrNo)
XlsCreator1.Cell("D1").Str2("文字列", nAttrNo)
XlsCreator1.Cell("E1").Value2("バリアント型", nAttrNo)
XlsCreator1.CloseBook(True)

[C#]
Int32 nAttrNo;
xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");
nAttrNo = xlsCreator1.Cell("A1").AttrNo;
xlsCreator1.Cell("B1").Long2(200, nAttrNo);
xlsCreator1.Cell("C1").Double2(200.1, nAttrNo);
xlsCreator1.Cell("D1").Str2("文字列", nAttrNo);
xlsCreator1.Cell("E1").Value2("バリアント型", nAttrNo);
xlsCreator1.CloseBook(true);


Center プロパティ

ExcelCreator.Center プロパティ

ページ中央を設定します。

書式

[VB.NET]
  Public WriteOnly Property Center() As ExcelCreator.xlPageCenter

[C#]
  public ExcelCreator.xlPageCenter Center [set]

設定値

    水平、垂直方向の印刷位置を、xlPageCenter 列挙体のメンバで設定します。

      定数      値    内容
      pcNone     0    指定なし。(デフォルト値)
      pcHorz     1    水平方向に中央寄せを行います。
      pcVert     2    垂直方向に中央寄せを行います。

解説
印刷の中央位置を設定します。 pcHorz と pcVert と両方設定する場合は「 + 」演算子で結合して設定します。

参照
[C# .NET で引数に 2 つ以上の列挙体のメンバを設定する方法]

コーディング例

印刷位置を水平、垂直方向に中央に設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Page.Attr.Center = ExcelCreator.xlPageCenter.pcHorz + ExcelCreator.xlPageCenter.pcVert
XlsCreator1.Cell("A1:G15").Attr.Box(ExcelCreator.xlBoxType.btLtc, ExcelCreator.xlLineStyle.lsNormal)
XlsCreator1.Cell("A1").Str = "ページ中央 : 水平 + 垂直"
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Page.Attr.Center = (ExcelCreator.xlPageCenter)(ExcelCreator.xlPageCenter.pcHorz + (Int32)ExcelCreator.xlPageCenter.pcVert);
xlsCreator1.Cell("A1:G15").Attr.Box(ExcelCreator.xlBoxType.btLtc, ExcelCreator.xlLineStyle.lsNormal);
xlsCreator1.Cell("A1").Str = "ページ中央 : 水平 + 垂直";
xlsCreator1.CloseBook(true);


CloseBook メソッド

ExcelCreator.CloseBook メソッド

Excel ファイルのクローズ、または破棄を行います。PDF ファイル出力も行うことができます。

書式

[VB.NET]
  Public Sub CloseBook(ByVal mode As Boolean)
  Public Sub CloseBook(ByVal mode As Boolean, ByVal strPDFName As String, ByVal bDelete As Boolean)
  Public Sub CloseBook(ByVal mode As Boolean, ByVal strm As System.IO.Stream, ByVal bDelete As Boolean)

[C#]
  public void CloseBook(System.Boolean mode)
  public void CloseBook(System.Boolean mode , System.String strPDFName , System.Boolean bDelete)
  public void CloseBook(System.Boolean mode , System.IO.Stream strm , System.Boolean bDelete)

設定値

    strPDFName , strm
      出力する PDF ファイルを設定します。

    mode
      定数      内容
      True      Excel ファイルをクローズします。
      False     変更内容を破棄し、オープン時点の内容に戻します。

    bDelete
      定数      内容
      True      PDF ファイル保存時に Excel ファイルを削除します。
      False     PDF ファイル保存時に Excel ファイルは削除しません。

解説
CreateBook、OpenBook、ReadBook、OpenBookEmbed メソッドでオープンした後は、 必ず、Excel ファイルのクローズ、または、破棄を行ってください。
PDF ファイルを作成した時に Excel ファイルが不要な場合は、引数 bDelete に True を設定します。

参照
[CreateBook メソッド] | [ReadBook メソッド] | [OpenBook メソッド] | [OpenBookEmbed メソッド]

コーディング例

開いているファイルを閉じます。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("D1").Str = "abcde"
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("D1").Str = "abcde";
xlsCreator1.CloseBook(true);


CloseBookEx メソッド

ExcelCreator.CloseBookEx メソッド

CreateBookEx / ReadBookEx / OpenBookEx / OpenBookEmbedEx で Excel ファイルを操作した場合に、クローズ、または破棄を行います。 PDF ファイル出力も行うことができます。

書式

[VB.NET]
  Public Sub CloseBookEx(ByVal mode As Boolean, ByVal uiID As System.UInt32)
  Public Sub CloseBookEx(ByVal mode As Boolean, ByVal uiID As System.UInt32, ByVal strPDFName As String, ByVal bDelete As Boolean)
  Public Sub CloseBookEx(ByVal mode As Boolean, ByVal uiID As System.UInt32, ByVal strm As System.IO.Stream, ByVal bDelete As Boolean)

[C#]
  public void CloseBookEx(System.Boolean mode, System.UInt32 uiID)
  public void CloseBookEx(System.Boolean mode, System.UInt32 uiID, System.IO.Stream strm, System.Boolean bDelete)
  public void CloseBookEx(System.Boolean mode, System.UInt32 uiID, System.String strPDFName, System.Boolean bDelete)

設定値

    strm , strPDFName
      出力する PDF ファイルを設定します。

    pID
      作成する Excel ファイルの識別 ID を取得する変数を設定します。

    mode
      定数      内容
      True      Excel ファイルをクローズします。(デフォルト値)
      False     変更内容を破棄し、オープン時点の内容に戻します。

    bDelete
      定数      内容
      True      PDF ファイル保存時に Excel ファイルを削除します。
      False     PDF ファイル保存時に Excel ファイルは削除しません。

解説
CreateBookEx、ReadBookEx、OpenBookEx、OpenBookEmbedEx メソッドでオープンした後は、 必ずファイルのクローズ、または、破棄を行ってください。
PDF ファイルを作成した時に Excel ファイルが不要な場合は、引数 bDelete に True を設定します。

参照
[CreateBookEx メソッド] | [ReadBookEx メソッド] | [OpenBookEx メソッド] | [OpenBookEmbedEx メソッド]

コーディング例

開いているファイルを閉じます。

[VB.NET]
Dim pID1 As UInt32
Dim pID2 As UInt32

XlsCreator1.CreateBookEx(Application.StartupPath & "\ExcelFile01.xls", 1, ExcelCreator.xlVersion.ver2003, pID1)
XlsCreator1.Cell("A1").Value = 10000

XlsCreator1.CreateBookEx(Application.StartupPath & "\ExcelFile02.xls", 1, ExcelCreator.xlVersion.ver2003, pID2)
XlsCreator1.Cell("A5").Value = 18000

' ファイルクローズ時に、オープンした ID を選択します
XlsCreator1.CloseBookEx(True, pID2)
XlsCreator1.CloseBookEx(True, pID1)

[C#]
uint pID1 = 0;
uint pID2 = 0;

xlsCreator1.CreateBookEx(Application.StartupPath + @"\ExcelFile01.xls", 1, ExcelCreator.xlVersion.ver2003, ref pID1);
xlsCreator1.Cell("A1").Value = 10000;

xlsCreator1.CreateBookEx(Application.StartupPath + @"\ExcelFile02.xls", 1, ExcelCreator.xlVersion.ver2003, ref pID2);
xlsCreator1.Cell("A5").Value = 18000;

// ファイルクローズ時に、オープンした ID を選択し閉じます
xlsCreator1.CloseBookEx(true, pID2);
xlsCreator1.CloseBookEx(true, pID1);

複数の開いているファイルを閉じます。

[VB.NET]
Dim pID1 As UInt32
Dim pID2 As UInt32

XlsCreator1.CreateBookEx(Application.StartupPath & "\ExcelFile01.xls", 1, ExcelCreator.xlVersion.ver2003, pID1)
XlsCreator1.PDF.Title = "2005 年 1 月売り上げ一覧"

XlsCreator1.CreateBookEx(Application.StartupPath & "\ExcelFile02.xls", 1, ExcelCreator.xlVersion.ver2003, pID2)
XlsCreator1.PDF.Title = "2005 年 2 月売り上げ一覧"

' ファイルクローズ時に、オープンした ID を選択し PDF ファイルへ出力します
XlsCreator1.CloseBookEx(True, pID2, Application.StartupPath & "\PdfFile02.pdf", True)
XlsCreator1.CloseBookEx(True, pID1, Application.StartupPath & "\PdfFile01.pdf", True)

[C#]
uint pID1 = 0;
uint pID2 = 0;

xlsCreator1.CreateBookEx(Application.StartupPath + @"\ExcelFile01.xls", 1, ExcelCreator.xlVersion.ver2003, ref pID1);
xlsCreator1.PDF.Title = "2005 年 1 月売り上げ一覧";

xlsCreator1.CreateBookEx(Application.StartupPath + @"\ExcelFile02.xls", 1, ExcelCreator.xlVersion.ver2003, ref pID2);
xlsCreator1.PDF.Title = "2005 年 2 月売り上げ一覧";

// ファイルクローズ時に、オープンした ID を選択し PDF ファイルへ出力します
xlsCreator1.CloseBookEx(true, pID2, Application.StartupPath + @"\PdfFile02.pdf", true);
xlsCreator1.CloseBookEx(true, pID1, Application.StartupPath + @"\PdfFile01.pdf", true);


ColumnClear メソッド

ExcelCreator.ColumnClear メソッド

列をクリア (初期化) します。

書式

[VB.NET]
  Public Sub ColumnClear(ByVal sx As Integer, ByVal count As Integer)

[C#]
  public void ColumnClear(System.Int32 sx , System.Int32 count)

設定値

    sx
      クリアする開始列番号値 (0 ～) を設定します。
    count
      クリアする列数値 (1 ～) を設定します。

解説
引数 sx の設定列から、引数 count の列数分をクリア (初期化) します。

コーディング例

E 列をクリア、E 列から 2 列分クリアします。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.ColumnClear(4, -1)
XlsCreator1.ColumnClear(4, 2)
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.ColumnClear(4, -1);
xlsCreator1.ColumnClear(4, 2);
xlsCreator1.CloseBook(true);

注意事項
列挿入を行っても、Excel シート上に設定されているオートシェイプや画像の位置は移動されません。


ColumnCopy メソッド

ExcelCreator.ColumnCopy メソッド

列をコピーします。

書式

[VB.NET]
  Public Sub ColumnCopy(ByVal sx As Integer, ByVal dx As Integer)

[C#]
  public void ColumnCopy(System.Int32 sx , System.Int32 dx)

設定値

    sx
      コピー元の列番号値 (0 ～) を設定します。
    dx
      コピー先の列番号値 (0 ～) を設定します。

解説
引数 sx の設定列を、引数 dx の列へコピーします。
引数 dx に -1 を設定した時は、引数 sx の設定列がメモリ上にコピーされます。
コピーした列は、ColumnPaste メソッドで設定した列に貼り付けることができます。

列コピーは、ExcelCreator 5.0 for .NET と Excel では次の様に一部動作仕様が異なっております。

ExcelCreator 5.0 for .NET | Excel
セルのデータのみコピーされます。 (セル幅はコピーされません。) | セルのデータとセル幅がコピーされます。

参照
[ColumnPaste メソッド]

コーディング例

1 列目を 20 列目にコピーします。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A1").Func("=sum(B1:C1)", "")
XlsCreator1.ColumnCopy(0, 19)
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A1").Func("=sum(B1:C1)", null);
xlsCreator1.ColumnCopy(0, 19);
xlsCreator1.CloseBook(true);

注意事項
・ | コピー元セルのセル属性と値のみコピーします。
・ | コピー元セルに変数名が設定されている場合、変数名はコピーされません。
・ | Excel ファイルのブック間、シート間のコピー・貼り付けには対応しておりません。


ColumnDelete メソッド

ExcelCreator.ColumnDelete メソッド

列を削除します。

書式

[VB.NET]
  Public Sub ColumnDelete(ByVal sx As Integer, ByVal count As Integer)

[C#]
  public void ColumnDelete(System.Int32 sx , System.Int32 count)

設定値

    sx
      削除する開始列番号値 (0 ～) を設定します。
    count
      削除する列数値 (1 ～) を設定します。

解説
引数 sx の設定列から、引数 count の列数分を削除します。

コーディング例

E 列を削除し、E 列から 2 列分削除します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.ColumnDelete(4, -1)
XlsCreator1.ColumnDelete(4, 2)
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.ColumnDelete(4, -1);
xlsCreator1.ColumnDelete(4, 2);
xlsCreator1.CloseBook(true);

注意事項
列削除を行っても、Excel シート上に設定されているオートシェイプや画像の位置は移動されません。


ColumnInsert メソッド

ExcelCreator.ColumnInsert メソッド

列を挿入します。

書式

[VB.NET]
  Public Sub ColumnInsert(ByVal sx As Integer, ByVal count As Integer)

[C#]
  public void ColumnInsert(System.Int32 sx , System.Int32 count)

設定値

    sx
      挿入する開始列番号値 (0 ～) を設定します。
    count
      挿入する列数値 (1 ～) を設定します。

解説
引数 sx の設定列から、引数 count の列数分を挿入します。

コーディング例

B 列から 1 列のみ挿入、B 列から 2 列分挿入します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.ColumnInsert(1, 1)
XlsCreator1.ColumnInsert(1, 2)
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.ColumnInsert(1, 1);
xlsCreator1.ColumnInsert(1, 2);
xlsCreator1.CloseBook(true);


ColumnPaste メソッド

ExcelCreator.ColumnPaste メソッド

ColumnCopy メソッドでコピーした列を貼り付けます。

書式

[VB.NET]
  Public Sub ColumnPaste(ByVal dx As Integer)

[C#]
  public void ColumnPaste(System.Int32 dx)

設定値

    dx
      貼り付けを行う列番号値 (0 ～) を設定します。

解説
ColumnCopy メソッドによりメモリ上にコピーされた列を、引数 dx に貼り付けます。 このとき、元の列は上書きされます。

参照
[ColumnCopy メソッド]

コーディング例

1 列目を 20 列目にコピーし、1 列目をメモリ上にコピーし 21 列目に貼り付けます。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A1").Func("=sum(B1:C1)", "")
XlsCreator1.ColumnCopy(0, 19)
XlsCreator1.ColumnCopy(0, -1)
XlsCreator1.ColumnPaste(20)
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A1").Func("=sum(B1:C1)", null);
xlsCreator1.ColumnCopy(0, 19);
xlsCreator1.ColumnCopy(0, -1);
xlsCreator1.ColumnPaste(20);
xlsCreator1.CloseBook(true);

注意事項
・ | コピー元セルのセル属性と値のみコピーします。
・ | コピー元セルに変数名が設定されている場合、変数名はコピーされません。
・ | Excel ファイルのブック間、シート間のコピー・貼り付けには対応しておりません。


CopySheet メソッド

ExcelCreator.CopySheet メソッド

シートを設定した場所にコピーします。

書式

[VB.NET]
  Public Sub CopySheet(ByVal sheetno As Integer, ByVal insertpos As Integer, ByVal sheetname As String)

[C#]
  public void CopySheet(System.Int32 sheetno, System.Int32 insertpos, System.String sheetname)

設定値

    sheetno
      コピー元のシート番号値 (0 ～) を設定します。
    insertpos
      コピー元のシートを挿入するシート番号値 (0 ～) を設定します。
    sheetname
      シート名を示す文字列を設定します。

コーディング例

シートのコピーを行います。
0 番目のシートを 1 番目の位置にコピーし、シート名を「コピーしたシート」に設定します。。
3 番目のシートを 5 番目の位置にコピーします。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 10, ExcelCreator.xlVersion.ver2003)
XlsCreator1.CopySheet(0, 1, "コピーしたシート")
XlsCreator1.CopySheet(3, 5, "")
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 10, ExcelCreator.xlVersion.ver2003);
xlsCreator1.CopySheet(0, 1, "コピーしたシート");
xlsCreator1.CopySheet(3, 5, "");
xlsCreator1.CloseBook(true);

注意事項
・ | コピー元シートにグラフが含まれる場合、グラフはコピーされますが、グラフ内のシート参照については変更されません。そのためグラフ内でセルのデータを参照している場合、そのシート参照が「#REF」となります。
・ | Excel ファイルのブック間のコピーには対応しておりません。


CreateBook メソッド

ExcelCreator.CreateBook メソッド

Excel ファイルの新規作成を行います。

書式

[VB.NET]
  Public Function CreateBook(ByVal strFileName As String, ByVal sheetmax As Integer, ByVal version As ExcelCreator.xlVersion) As Integer

[C#]
  public System.Int32 CreateBook(System.String strFileName , System.Int32 sheetmax , ExcelCreator.xlVersion version)

設定値

    strFileName
      作成するファイル名を文字列で設定します。
    sheetmax
      作成するシート数を整数値の値で設定します。
      省略する場合、-1 を設定してください。省略時には、デフォルト値 3 で作成されます。
    version
      Excel ファイルのバージョンを xlVersion 列挙体のメンバで設定します。

      定数       内容
      ver97      Excel 97 の形式
      ver2000    Excel 2000 の形式
      ver2002    Excel 2002 の形式
      ver2003    Excel 2003 の形式

解説
戻り値はメソッドが正常終了した場合には 0 以上の値を、それ以外の場合には 0 より小さい値を返します。 引数 strFileName に既存の Excel ファイル名を設定した場合、 既存ファイルを削除した後にファイルを新規作成します。

参照
[CreateBookEx メソッド] | [CloseBook メソッド]

コーディング例

3 シートある Excel2003 形式の Excel ファイルを新規作成します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("D1").Str = "abcde"
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("D1").Str = "abcde";
xlsCreator1.CloseBook(true);


CreateBookEx メソッド

ExcelCreator.CreateBookEx メソッド

Excel ファイルを新規作成し、その識別 ID を取得します。

書式

[VB.NET]
  Public Function CreateBookEx(ByVal strFileName As String, ByVal sheetmax As Integer, ByVal version As ExcelCreator.xlVersion, ByRef pID As System.UInt32) As Integer

[C#]
  public System.Int32 CreateBookEx(System.String strFileName, System.Int32 sheetmax, ExcelCreator.xlVersion version, System.UInt32 pID)

設定値

    strFileName
      作成するファイル名を設定します。
    sheetmax
      作成するシート数を設定します。
      省略する場合は -1 を設定してください。省略時には、デフォルト値 3 で作成されます。
    pID
      作成するファイルの識別 ID を取得する変数を設定します。
    version
      Excel ファイルのバージョンを xlVersion 列挙体のメンバで設定します。

      定数       内容
      ver97      Excel 97 の形式
      ver2000    Excel 2000 の形式
      ver2002    Excel 2002 の形式
      ver2003    Excel 2003 の形式

解説
戻り値はメソッドが正常終了した場合には 0 以上の値を、それ以外の場合には 0 より小さい値を返します。
一つの ExcelCreator 5.0 for .NET コンポーネントで複数の Excel ファイルを作成する場合、 ファイルの識別 ID を使用して操作の対象となるファイルを SelectBook メソッドで切り替えて入出力処理を行います。
CreateBookEx でファイルを作成した場合は、必ずCloseBookEx でクローズしてください。
引数 strFileName に既存のファイル名を設定した場合、既存ファイルを削除した後に ファイルを新規作成します。

参照
[CloseBookEx メソッド] | [ReadBookEx メソッド] | [OpenBookEx メソッド] | [OpenBookEmbedEx メソッド] | [SelectBook メソッド]

コーディング例

次のプログラムではファイルの新規作成を行います。

[VB.NET]
Dim pID1 As UInt32
Dim pID2 As UInt32

' Excel ファイル新規作成時に、ID を設定します
XlsCreator1.CreateBookEx(Application.StartupPath & "\ExcelFile01.xls", 1, ExcelCreator.xlVersion.ver2003, pID1)
XlsCreator1.Cell("A5").Long = 50000

XlsCreator1.CreateBookEx(Application.StartupPath & "\ExcelFile02.xls", 1, ExcelCreator.xlVersion.ver2003, pID2)
XlsCreator1.Cell("C5").Long = 75000

' ファイルクローズ時に、オープンした ID を選択し閉じます
XlsCreator1.CloseBookEx(True, pID2)
XlsCreator1.CloseBookEx(True, pID1)

[C#]
uint pID1 = 0;
uint pID2 = 0;

// Excel ファイル新規作成時に、ID を設定します
xlsCreator1.CreateBookEx(Application.StartupPath + @"\ExcelFile01.xls", 1, ExcelCreator.xlVersion.ver2003, ref pID1);
xlsCreator1.Cell("A5").Long = 50000;

xlsCreator1.CreateBookEx(Application.StartupPath + @"\ExcelFile02.xls", 1, ExcelCreator.xlVersion.ver2003, ref pID2);
xlsCreator1.Cell("C5").Long = 75000;

// ファイルクローズ時に、オープンした ID を選択し閉じます
xlsCreator1.CloseBookEx(true, pID2);
xlsCreator1.CloseBookEx(true, pID1);


DefFontName プロパティ

ExcelCreator.DefFontName プロパティ

Excel ファイルの全シートのデフォルトフォント名を設定します。

書式

[VB.NET]
  Public WriteOnly Property DefFontName() As String

[C#]
  public string DefFontName [set]

設定値

    フォント名の文字列を設定します。

解説
Excel ファイルの全シートで、フォントの書式設定を行っていないセルが設定対象に なります。

参照
[DefFontPoint プロパティ]

コーディング例

Excel ファイルの全シートのフォント名、フォントサイズを設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.DefFontName = "ＭＳ ゴシック"
XlsCreator1.DefFontPoint = 9
XlsCreator1.Cell("A1").Str = "ABCDE"
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.DefFontName = "ＭＳ ゴシック";
xlsCreator1.DefFontPoint = 9;
xlsCreator1.Cell("A1").Str = "ABCDE";
xlsCreator1.CloseBook(true);


DefFontPoint プロパティ

ExcelCreator.DefFontPoint プロパティ

Excel ファイルの全シートのデフォルトフォントサイズを設定します。

書式

[VB.NET]
  Public WriteOnly Property DefFontPoint() As Double

[C#]
  public double DefFontPoint [set]

設定値

    フォントのサイズ (1 ～ 409 ポイント) を設定します。

解説
Excel ファイルの全シートで、フォントの書式設定を行っていないセルが設定対象に なります。

参照
[DefFontName プロパティ]

コーディング例

Excel ファイルの全シートのフォント名、フォントサイズを設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.DefFontName = "ＭＳ ゴシック"
XlsCreator1.Cell("A1").Str = "ABCDE"
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.DefFontName = "ＭＳ ゴシック";
xlsCreator1.DefFontPoint = 9;
xlsCreator1.Cell("A1").Str = "ABCDE";
xlsCreator1.CloseBook(true);


DelSheet メソッド

ExcelCreator.DelSheet メソッド

シートを削除します。

書式

[VB.NET]
  Public Sub DelSheet(ByVal sheetno As Integer, ByVal count As Integer)

[C#]
  public void DelSheet(System.Int32 sheetno , System.Int32 count)

設定値

    sheetno
      削除するシート番号 (0 ～ ) を設定します。
    count
      削除するシート数 (1 ～ ) を設定します。

解説
引数 count に全シート数を超える値を設定すると、存在する全てのシートを削除します。

参照
[AddSheet メソッド]

コーディング例

Excel ファイル内の 4 シート目から 2 シート分の削除を行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003)
XlsCreator1.DelSheet(3, 2)
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003);
xlsCreator1.DelSheet(3, 2);
xlsCreator1.CloseBook(true);

注意事項
マクロを含む Excel ファイルのシートを削除することはできません。


Error イベント

ExcelCreator.Error イベント

ExcelCreator 5.0 for .NET の実行時に、不正な処理を行った場合に発生します。 実行時にエラー番号値の取得も可能です。

書式

[VB.NET]
  Protected object_Error(ByVal sender As System.Object, ByVal e As ExcelCreator.XlsCreatorEventArgs)

[C#]
  protected void object_Error(object sender, ExcelCreator.XlsCreatorEventArgs e)

設定値

    エラー番号は、次の通りです。

      定数                 値       内容
      errDontOpen           1       ファイルがオープンできない
      errFileHandle         2       無効なファイルハンドル
      errNotOpen            3       未オープンエラー
      errSheetNo            4       シート番号エラー
      errWrite              5       書き込み時のエラー
      errAction             6       動作モードエラー
      errDataCat            7       データ種別エラー
      errValue              8       エラー値
      errClear             20       クリアエラー
      errCopy              21       コピーエラー
      errPaste             22       貼り付けエラー
      errInsert            23       挿入エラー
      errDelete            24       削除エラー
      errLength            31       長さエラー
      errLocate            32       座標エラー
      errAttr              33       属性番号エラー
      errParam             34       パラメータエラー
      errNoData            35       データが無い
      errEndOfData         36       データの終わり
      errVarPoint          37       設定した変数が存在しない
      errParame            34       パラメータエラー
      errBreakCount        38       改ページ数が制限を超えた
      errMemory1           40       メモリー不足エラー１
      errMemory2           41       メモリー不足エラー２
      errOther             50       内部エラー
      errFunction         100       計算式形式エラー
      errCreate           300       ファイル作成エラー
      errTempCreate       301       Temp ファイル作成エラー
      errTempOpen         302       Temp ファイルオープンエラー
      errStream           303       ストリームエラー
      errProtect          304       保護されたファイルです
      errDoubleOpen       305       二重オープンです
      errMutex            400       ミューテックスエラー
      errMaxFileName      401       ファイル名が長すぎます
      errInvalidFileName  402       無効なファイル名
      errEmbedFile        403       埋め込みバイナリエラーです

解説
エラー発生時にエラー番号を取得する場合、XlsEventArgs 列挙体の ErrorNo プロパティの値を取得します。

参照
[ErrorNo プロパティ] | [ErrorMessage プロパティ]

コーディング例

[VB.NET]
' ExcelCreator 5.0 for .NET のインスタンスを生成します
Dim WithEvents XlsCreator1 As ExcelCreator.XlsCreator = New ExcelCreator.XlsCreator

' ExcelCreator 5.0 for .NET エラーイベント
Private Sub XlsCreator1_Error(ByVal sender As System.Object, ByVal e As ExcelCreator.XlsCreatorEventArgs) Handles XlsCreator1.Error
    MessageBox.Show(err.ErrorNo.ToString() & " : " & XlsCreator1.ErrorMessage, "Error")
End Sub

[C#]
// ExcelCreator 5.0 for .NET のインスタンスを生成します
private ExcelCreator.XlsCreator xlsCreator1 = new ExcelCreator.XlsCreator();

private void InitializeComponent()
{
    // ExcelCreator 5.0 for .NET のエラーイベントを、xlsCreator1_Error メソッドに関連付けます
    this.xlsCreator1.Error += new ExcelCreator.XlsCreatorEventHandler(xlsCreator1_Error);
}

// ExcelCreator 5.0 for .NET エラーイベント
private void xlsCreator1_Error(object sender, ExcelCreator.XlsCreatorEventArgs e)
{
    MessageBox.Show(err.ErrorNo.ToString() + " : " + xlsCreator1.ErrorMessage, "Error");
}


ErrorMessage プロパティ

ExcelCreator.ErrorMessage プロパティ

エラーメッセージを取得します。実行時に値の取得のみ可能です。

書式

[VB.NET]
  Public ReadOnly Property ErrorMessage() As String

[C#]
  public string ErrorMessage [get]

設定値

    エラーメッセージが文字列で渡されます。
    エラーメッセージについては、次の値を参照してください。

      定数                 値       内容
      errDontOpen           1       ファイルがオープンできない
      errFileHandle         2       無効なファイルハンドル
      errNotOpen            3       未オープンエラー
      errSheetNo            4       シート番号エラー
      errWrite              5       書き込み時のエラー
      errAction             6       動作モードエラー
      errDataCat            7       データ種別エラー
      errValue              8       エラー値
      errClear             20       クリアエラー
      errCopy              21       コピーエラー
      errPaste             22       貼り付けエラー
      errInsert            23       挿入エラー
      errDelete            24       削除エラー
      errLength            31       長さエラー
      errLocate            32       座標エラー
      errAttr              33       属性番号エラー
      errParam             34       パラメータエラー
      errNoData            35       データが無い
      errEndOfData         36       データの終わり
      errVarPoint          37       設定した変数が存在しない
      errParame            34       パラメータエラー
      errBreakCount        38       改ページ数が制限を超えた
      errMemory1           40       メモリー不足エラー１
      errMemory2           41       メモリー不足エラー２
      errOther             50       内部エラー
      errFunction         100       計算式形式エラー
      errCreate           300       ファイル作成エラー
      errTempCreate       301       Temp ファイル作成エラー
      errTempOpen         302       Temp ファイルオープンエラー
      errStream           303       ストリームエラー
      errProtect          304       保護されたファイルです
      errDoubleOpen       305       二重オープンです
      errMutex            400       ミューテックスエラー
      errMaxFileName      401       ファイル名が長すぎます
      errInvalidFileName  402       無効なファイル名
      errEmbedFile        403       埋め込みバイナリエラーです

解説
エラーが発生した場合、エラーメッセージを文字列型で取得します。

参照
[ErrorNo プロパティ] | [Error イベント]

コーディング例

同一ファイルを開いているため、「ファイルがオープンできない」というメッセージが表示されます

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
If XlsCreator1.ErrorNo <> ExcelCreator.xlErrorNo.errNoError Then
    MsgBox(XlsCreator1.ErrorMessage)
    Exit Sub
End If
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
if (xlsCreator1.ErrorNo != ExcelCreator.xlErrorNo.errNoError)
{
    MessageBox.Show(xlsCreator1.ErrorMessage);
    return;
}
xlsCreator1.CloseBook(true);


ErrorNo プロパティ

ExcelCreator.ErrorNo プロパティ

エラー番号を取得します。実行時に値の取得のみ可能です。

書式

[VB.NET]
  Public ReadOnly Property ErrorNo() As ExcelCreator.xlErrorNo

[C#]
  public ExcelCreator.xlErrorNo ErrorNo [get]

設定値

    xlErrorNo
      実行時のエラー番号が渡されます。
      エラー番号については、次の値を参照してください。

      定数                 値       内容
      errDontOpen           1       ファイルがオープンできない
      errFileHandle         2       無効なファイルハンドル
      errNotOpen            3       未オープンエラー
      errSheetNo            4       シート番号エラー
      errWrite              5       書き込み時のエラー
      errAction             6       動作モードエラー
      errDataCat            7       データ種別エラー
      errValue              8       エラー値
      errClear             20       クリアエラー
      errCopy              21       コピーエラー
      errPaste             22       貼り付けエラー
      errInsert            23       挿入エラー
      errDelete            24       削除エラー
      errLength            31       長さエラー
      errLocate            32       座標エラー
      errAttr              33       属性番号エラー
      errParam             34       パラメータエラー
      errNoData            35       データが無い
      errEndOfData         36       データの終わり
      errVarPoint          37       設定した変数が存在しない
      errBreakCount        38       改ページ数が制限を超えた
      errMemory1           40       メモリー不足エラー１
      errMemory2           41       メモリー不足エラー２
      errOther             50       内部エラー
      errFunction         100       計算式形式エラー
      errCreate           300       ファイル作成エラー
      errTempCreate       301       Temp ファイル作成エラー
      errTempOpen         302       Temp ファイルオープンエラー
      errStream           303       ストリームエラー
      errProtect          304       保護されたファイルです
      errDoubleOpen       305       二重オープンです
      errMutex            400       ミューテックスエラー
      errMaxFileName      401       ファイル名が長すぎます
      errInvalidFileName  402       無効なファイル名
      errEmbedFile        403       埋め込みバイナリエラーです

解説
エラーが発生した場合にエラー番号を取得します。
正常時の戻り値は 0 を返します。

参照
[ErrorMessage プロパティ] | [Error イベント]

コーディング例

ErrorNo プロパティを使用してエラー処理を行います。
ファイル名が正しくないため、エラー時にメッセージを表示して処理を抜けます。

[VB.NET]
'
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xl", 3, ExcelCreator.xlVersion.ver2003)
If XlsCreator1.ErrorNo <> 0 Then
    MsgBox("エラーです")
    Exit Sub
End If
XlsCreator1.Cell("A2").Str = "abcd"
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xl", 3, ExcelCreator.xlVersion.ver2003);
if (xlsCreator1.ErrorNo != 0)
{
    MessageBox.Show("エラーです");
    return;
}
xlsCreator1.Cell("A2").Str = "abcd";
xlsCreator1.CloseBook(true);


Footer メソッド

ExcelCreator.Footer メソッド

シートのフッタを設定します。

書式

[VB.NET]
  Public Sub Footer(ByVal left As String, ByVal center As String, ByVal right As String)

[C#]
  public void Footer(System.String left, System.String center, System.String right)

設定値

    left
      左フッタを示す文字列を設定します。
    center
      中央フッタを示す文字列を設定します。
    right
      右フッタを示す文字列を設定します。

    各文字列は、下記の特殊な文字列に対応しています。

      書式コード    内容
      &E            二重下線
      &X            上付き文字
      &Y            下付き文字
      &B            ボールド
      &I            イタリック
      &U            下線
      &S            取消線
      &P            ページ番号
      &P+99         ページ番号に値を加えて表示
                    例:先頭ページ番号を 3 とする場合 … &P + 3)
      &P-99         ページ番号に値を引いて表示
      &D            現在の日付
      &T            現在の時刻
      &A            シート見出し
      &&            ＆(アンパサンド)を表示
      &"フォント"   フォントを設定
      &99           ポイント数を設定
      &N            全体のページ数

解説
文字数の制限は書式コードを含めて 255 文字までです。
なお、引数 left、center、right に "" を設定した場合は元の設定が適用されます。

参照
[Header メソッド]

コーディング例

シートのフッタを設定します。

[VB.NET]
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")
XlsCreator1.SheetNo = 0
XlsCreator1.Footer("&""ＭＳ Ｐ明朝""&16ExcelCreator新機能一覧フッター", "&A", "&D")
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.OpenBook(Application.StartUpPath + @"\ExcelFile.xls", Application.StartUpPath + @"\ExcelTemplate.xls");
xlsCreator1.SheetNo = 0;
xlsCreator1.Footer("&\"ＭＳ Ｐ明朝\"&16ExcelCreator新機能一覧フッタ", "&A", "&D");
xlsCreator1.CloseBook(true);


Header メソッド

ExcelCreator.Header メソッド

シートのヘッダーを設定します。

書式

[VB.NET]
  Public Sub Header(ByVal left As String, ByVal center As String, ByVal right As String)

[C#]
  public void Header(System.String left, System.String center, System.String right)

設定値

    left
      左ヘッダーを示す文字列を設定します。
    center
      中央ヘッダーを示す文字列を設定します。
    right
      右ヘッダーを示す文字列を設定します。

    各文字列は、下記の特殊な文字列に対応しています。

      書式コード    内容
      &E            二重下線
      &X            上付き文字
      &Y            下付き文字
      &B            ボールド
      &I            イタリック
      &U            下線
      &S            取消線
      &P            ページ番号
      &P+99         ページ番号に値を加えて表示
                    例:先頭ページ番号を 3 とする場合 … &P + 3)
      &P-99         ページ番号に値を引いて表示
      &D            現在の日付
      &T            現在の時刻
      &A            シート見出し
      &&            ＆(アンパサンド)を表示
      &"フォント"   フォントを設定
      &99           ポイント数を設定
      &N            全体のページ数

解説
文字数の制限は書式コードを含めて 255 文字までです。
なお、引数 left、center、right に "" を設定した場合は元の設定が適用されます。

参照
[Footer メソッド]

コーディング例

シートのヘッダーを設定します。

[VB.NET]
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", Application.StartupPath & "\ExcelFile.xls")
XlsCreator1.SheetNo = 0
XlsCreator1.Header("&""ＭＳ Ｐ明朝""&16ExcelCreator新機能一覧ヘッダー", "&A", "&D")
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.OpenBook(Application.StartUpPath + @"\ExcelFile.xls", Application.StartUpPath + @"\ExcelTemplate.xls");
xlsCreator1.SheetNo = 0;
xlsCreator1.Header("&\"ＭＳ Ｐ明朝\"&16ExcelCreator新機能一覧ヘッダー", "&A", "&D");
xlsCreator1.CloseBook(true);


KeyWord プロパティ

ExcelCreator.KeyWord プロパティ

変数名の先頭キーワード文字列を設定します。

書式

[VB.NET]
  Public WriteOnly Property KeyWord() As String

[C#]
  public string KeyWord [set]

設定値

    変数文字列の先頭キーワード文字列を設定します。(最大 64 文字)

解説
変数名の先頭キーワード文字列を設定します。
デフォルトの変数名の先頭キーワード文字列 ** です。デフォルト以外を使用したい 場合に KeyWord プロパティで先頭キーワード文字列を設定できます。
先頭キーワード文字列は Excel で文字として認識可能で、かつ、半角文字のみ設定する ことができます。但し、\ ' " , ^ . [] の半角文字は使用できません。

なお、先頭キーワード文字列は ExcelCreator 5.0 for .NET コンポーネントの 1 つの オブジェクトで共通となりますので、処理の途中において先頭キーワード文字列を変更 した場合は、その後にオープンする Excel ファイルに影響を受けます。

コーディング例

変数名の先頭キーワード文字列を -- に設定します。

[VB.NET]
XlsCreator1.KeyWord = "--"
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A1").Str = "--NAME"
XlsCreator1.CloseBook(True)

XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")
XlsCreator1.Cell("--NAME").Long = 2000
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.KeyWord = "--";
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A1").Str = "--NAME";
xlsCreator1.CloseBook(true);

xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");
xlsCreator1.Cell("--NAME").Long = 2000;
xlsCreator1.CloseBook(true);


Margin メソッド

ExcelCreator.Margin メソッド

シート単位でページ余白の設定を行います。

書式

[VB.NET]
  Public Sub Margin(ByVal left As Integer, ByVal right As Integer, ByVal top As Integer, ByVal bottom As Integer, ByVal header As Integer, ByVal footer As Integer)

[C#]
  public void Margin(System.Int32 left, System.Int32 right, System.Int32 top, System.Int32 bottom, System.Int32 header, System.Int32 footer)

設定値

    left
      左余白を示す値を mm 単位で設定します。
    right
      右余白を示す値を mm 単位で設定します。
    top
      上余白を示す値を mm 単位で設定します。
    bottom
      下余白を示す値を mm 単位で設定します。
    header
      ヘッダー余白を示す値を mm 単位で設定します。
    footer
      フッター余白を示す値を mm 単位で設定します。

    省略時には -1 を設定します。デフォルト値が設定されます。

解説
設定を省略するとページ余白は、デフォルト値の上・下 は 25mm、左・右 は 20mm、 ヘッダー・フッターは 13mm になります。

参照
[Size メソッド] | [SizeFree メソッド]

コーディング例

ページとヘッダー・フッター余白の設定を行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Margin(15, 10, 10, 10, 2, 3)
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Margin(15, 10, 10, 10, 2, 3);
xlsCreator1.CloseBook(true);


MaxArea メソッド

ExcelCreator.MaxArea メソッド

データ (文字列 / 値 / 計算式) の他、罫線やセルの塗りつぶし等のセル書式が設定され ている、最終セルの座標を取得します。

書式

[VB.NET]
  Public Function MaxArea(ByVal pt As ExcelCreator.xlPoint) As System.Drawing.Size

[C#]
  public System.Drawing.Size MaxArea(ExcelCreator.xlPoint pt)

設定値

     定数          内容
     xlMaxPoint    データやセル書式が設定されているセルのうち、最下部のセルと、
                   最右部のセルが交わる地点にあるセル座標を取得します。
     xlEndPoint    データやセル書式が設定されているセルのうち、最も下にあり、
                   かつ、最も右側にあるセル座標を取得します。

解説
x 座標は Size.Width プロパティに、y 座標は Size.Height プロパティにそれぞれ設定されます。
xlEndPoint 設定時はデータが設定されているセルのうち最も下にあり、かつ、 最も右側にあるセル座標を取得します (青枠のセル座標)。
また、xlMaxPoint 設定時はデータが設定されているセルのうち、 最下部のセルと最右部のセルが交わる地点にあるセル座標を取得します (青枠のセル座標)。
赤枠や黄緑枠のセル座標の取得は、MaxData メソッドを使用します。

参照
[MaxData メソッド]

コーディング例

データやセル書式が設定されているセルのエンドポイントを取得します。

[VB.NET]
Dim sz As System.Drawing.Size
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
sz = XlsCreator1.MaxArea(ExcelCreator.xlPoint.ptEndPoint)
MsgBox("x 座標:" + sz.Width.ToString() + " / y 座標:" + sz.Height.ToString())
XlsCreator1.CloseBook(True)

[C#]
System.Drawing.Size sz;
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
sz = xlsCreator1.MaxArea(ExcelCreator.xlPoint.ptEndPoint);
MessageBox.Show("x 座標:" + sz.Width.ToString() + " / y 座標:" + sz.Height.ToString());
xlsCreator1.CloseBook(true);


MaxData メソッド

ExcelCreator.MaxData メソッド

データ (文字列 / 値 / 計算式) が設定されているセルの最終座標を取得します。

書式

[VB.NET]
  Public Function MaxData(ByVal pt As ExcelCreator.xlPoint) As System.Drawing.Size

[C#]
  public System.Drawing.Size MaxData(ExcelCreator.xlPoint pt)

設定値

     定数          内容
     xlMaxPoint    データが設定されているセルのうち、最下部のセルと最右部のセル
                   が交わる地点にあるセル座標を取得します。
     xlEndPoint    データが設定されているセルのうち、最も下にあり、かつ、
                   最も右側にあるセル座標を取得します。

解説
x 座標は Size.Width プロパティに、y 座標は Size.Height プロパティにそれぞれ設定されます。
xlEndPoint 設定時はデータが設定されているセルのうち最も下にあり、かつ、 最も右側にあるセル座標を取得します (黄緑枠のセル座標)。
また、xlMaxPoint 設定時はデータが設定されているセルのうち、 最下部のセルと最右部のセルが交わる地点にあるセル座標を取得します (赤枠のセル座標)。
青枠のセル座標の取得は、MaxArea メソッドを使用します。

参照
[MaxArea メソッド]

コーディング例

データが設定されているセルのマックスポイントを取得します。

[VB.NET]
Dim sz As System.Drawing.Size
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
sz = XlsCreator1.MaxData(ExcelCreator.xlPoint.ptMaxPoint)
MsgBox("x 座標:" + sz.Width.ToString() + " / y 座標:" + sz.Height.ToString())
XlsCreator1.CloseBook(True)

[C#]
System.Drawing.Size sz;
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
sz = xlsCreator1.MaxData(ExcelCreator.xlPoint.ptMaxPoint);
MessageBox.Show("x 座標:" + sz.Width.ToString() + " / y 座標:" + sz.Height.ToString());
xlsCreator1.CloseBook(true);


ModeGrid プロパティ

ExcelCreator.ModeGrid プロパティ

グリッド線の表示 / 非表示の設定します。

書式

[VB.NET]
  Public WriteOnly Property ModeGrid() As Boolean

[C#]
  public bool ModeGrid [set]

設定値

      定数       内容
      True       グリッド線を表示する。(デフォルト値)
      False      グリッド線を非表示にする。

コーディング例

シート内のグリッド線を非表示にします。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.ModeGrid = False
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.ModeGrid = false;
xlsCreator1.CloseBook(true);


OpenBook メソッド

ExcelCreator.OpenBook メソッド

既存 Excel ファイルを読み書きオープンします。

書式

[VB.NET]
  Public Function OpenBook(ByVal strFileName As String, ByVal strOverlay As String) As Integer

[C#]
  public System.Int32 OpenBook(System.String strFileName , System.String strOverlay)

設定値

    strFileName
      オープンする Excel ファイル名を文字列で設定します。
    strOverlay
      オーバーレイ元ファイル名を文字列で設定します。
      省略時には "" を設定します。

解説
戻り値はメソッドが正常終了した場合には 0 以上の値を、それ以外の場合には 0 より小さい値を返します。
引数 strFileName のファイルは、引数 strOverlay のファイル全体の 情報をコピーした新たなファイルとしてオープンします。
引数 strOverlay を省略した場合、引数 strFileName のファイルをオープンします。
引数 strFileName のファイルは新規で作成されるため、既存のファイル名を設定した 場合は既存ファイルは上書きされます。
オーバーレイ元ファイルにあらかじめ、変数文字やセルにセル名を設定している場合は、 変数文字やセル名を利用したセル指定で、文字列や値、属性の設定を行うこともできます。

参照
[CloseBook メソッド] | [OpenBookEx メソッド] | [OpenBookEmbed メソッド] | [OpenBookEmbedEx メソッド]

コーディング例

既存ファイルを開き、値を設定します。

[VB.NET]
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")
XlsCreator1.Cell("D1").Long = 100
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");
xlsCreator1.Cell("D1").Long = 100
xlsCreator1.CloseBook(true);

オーバーレイ用としてファイルを開き、新たなファイルを作成します
オーバーレイ用として ExcelTemplate.xls を開き、オーバーレイ用ファイル内の D1 セルに、100 と代入された新たな ExcelFile.xls を作成します

[VB.NET]
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", Application.StartupPath & "\ExcelTemplate.xls")
XlsCreator1.Cell("D1").Long = 100
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", Application.StartupPath + @"\ExcelTemplate.xls");
xlsCreator1.Cell("D1").Long = 100;
xlsCreator1.CloseBook(true);

注意事項
保護された Excel ファイルをオープンすることはできません。


OpenBookEmbed メソッド

ExcelCreator.OpenBookEmbed メソッド

リソースに埋め込まれたバイナリデータを既存 Excel ファイルとしてオープンします。

書式

[VB.NET]
  Public Function OpenBookEmbed(ByVal strFileName As String, ByVal stream As System.IO.Stream) As Integer
  Public Function OpenBookEmbed(ByVal strFileName As String, ByVal bytes() As Byte) As Integer

[C#]
  public System.Int32 OpenBookEmbed(System.String strFileName, System.IO.Stream stream)
  public System.Int32 OpenBookEmbed(System.String strFileName, byte[] bytes)

設定値

    strFileName
      オープンする Excel ファイル名を設定します。
    stream , bytes
      オーバーレイ元となるリソースに埋め込まれたバイナリデータを設定します。

解説
戻り値はメソッドが正常終了した場合には 0 以上の値を、それ以外の場合には 0 より小さい値を返します。
OpenBookEmbed でファイルを作成した場合は、必ず CloseBook でクローズしてください。

引数 strFileName のファイルは、 引数 stream や bytes の情報をコピーした新たなファイルとしてオープンします。
オーバーレイ元ファイルにあらかじめ、変数文字やセルにセル名を設定している場合は、 変数文字やセル名を利用したセル指定で、文字列や値、属性の設定を行うこともできます。

使用方法やコーディング例は、 [埋め込みリソースのオーバーレイ] / [オーバーレイ元ファイル (Excel ファイル) を埋め込みリソースとしてプロジェクトに登録する] / [オーバーレイ元ファイル (Excel ファイル) を元に作成したリソースファイルを埋め込みリソースとしてプロジェクトに登録する] を参照してください。

参照
[CloseBook メソッド]

注意事項
保護された Excel ファイルをオープンすることはできません。


OpenBookEmbedEx メソッド

ExcelCreator.OpenBookEmbedEx メソッド

リソースに埋め込まれたバイナリデータを既存 Excel ファイルとして扱い、 読み書きオープンし、その識別 ID を取得します。

書式

[VB.NET]
  Public Function OpenBookEmbedEx(ByVal strFileName As String, ByVal bytes() As Byte, ByRef pID As System.UInt32) As Integer
  Public Function OpenBookEmbedEx(ByVal strFileName As String, ByVal stream As System.IO.Stream, ByRef pID As System.UInt32) As Integer

[C#]
  public System.Int32 OpenBookEmbedEx(System.String strFileName , System.IO.Stream stream , System.UInt32 pID)
  public System.Int32 OpenBookEmbedEx(System.String strFileName , byte[] bytes , System.UInt32 pID)

設定値

    stream , bytes
      オーバーレイ元となるリソースに埋め込まれたバイナリデータを設定します。
    pID
      作成するファイルの識別 ID を取得する変数を設定します。

解説
戻り値はメソッドが正常終了した場合には 0 以上の値を、それ以外の場合には 0 より小さい値を返します。
一つの ExcelCreator 5.0 for .NET コンポーネントで複数の Excel ファイルを作成する場合、 ファイルの識別 ID を使用して操作の対象となるファイルを SelectBook メソッドで切りて入出力処理を行います。
OpenBookEmbedEx でファイルを作成した場合は、必ずCloseBookEx でクローズしてください。

引数 strFileName のファイルは、 引数 stream や bytes の情報をコピーした新たなファイルとしてオープンします。
オーバーレイ元ファイルにあらかじめ、変数文字やセルにセル名を設定している場合は、 変数文字やセル名を利用したセル指定で、文字列や値、属性の設定を行うこともできます。

使用方法やコーディング例は、 [埋め込みリソースのオーバーレイ] / [オーバーレイ元ファイル (Excel ファイル) を埋め込みリソースとしてプロジェクトに登録する] / [オーバーレイ元ファイル (Excel ファイル) を元に作成したリソースファイルを埋め込みリソースとしてプロジェクトに登録する] を参照してください。

参照
[CloseBookEx メソッド] | [SelectBook メソッド]

注意事項
保護された Excel ファイルをオープンすることはできません。


OpenBookEx メソッド

ExcelCreator.OpenBookEx メソッド

既存 Excel ファイルを読み書きオープンし、その識別 ID を取得します。

書式

[VB.NET]
  Public Function OpenBookEx(ByVal strFileName As String, ByVal strOverlay As String, ByRef pID As System.UInt32) As Integer

[C#]
  public System.Int32 OpenBookEx(System.String strFileName, System.String strOverlay, System.UInt32 pID)

設定値

    strFileName
      オープンする Excel ファイル名を設定します。
    strOverlay
      オーバーレイ元ファイル名を設定します。省略時には "" を設定します。
    pID
      オープンするファイルの識別 ID を取得する変数を設定します。

解説
戻り値はメソッドが正常終了した場合には 0 以上の値を、それ以外の場合には 0 より小さい値を返します。
一つの ExcelCreator 5.0 for .NET コンポーネントで複数の Excel ファイルを作成する場合、 ファイルの識別 ID を使用して操作の対象となる Excel ファイルを SelectBook メソッドで切り替えて入出力処理を行います。
OpenBookEx で Excel ファイルを作成した場合は、必ずCloseBookEx でクローズしてください。

引数 strFileName のファイルは、引数 strOverlay のファイルを コピーした新たなファイルとしてオープンします。
引数 strOverlay を省略した場合、引数 strFileName のファイルをオープンします。
引数 strFileName のファイルは新規で作成されるため、既存のファイル名を設定した 場合は既存ファイルは上書きされます。
オーバーレイ元ファイルにあらかじめ、変数文字やセルにセル名を設定している場合は、 変数文字やセル名を利用したセル指定で、文字列や値、属性の設定を行うこともできます。

参照
[CloseBookEx メソッド] | [OpenBookEmbed メソッド] | [OpenBookEmbedEx メソッド] | [SelectBook メソッド]

コーディング例

オーバーレイ用としてファイルを開き、新たなファイルを作成します。
オーバーレイ用として ExcelTemplate.xls を開き、セルに値を設定した新たな ExcelFile01.xls / ExcelFile02.xls を作成します。

[VB.NET]
Dim pID1 As UInt32
Dim pID2 As UInt32

' Excel ファイルのオーバーレイオープン時に、ID を設定します
XlsCreator1.OpenBookEx(Application.StartupPath & "\ExcelFile01.xls", _
   Application.StartupPath & "\ExcelTemplate.xls", pID1)
XlsCreator1.Cell("A5").Long = 50000

XlsCreator1.OpenBookEx(Application.StartupPath & "\ExcelFile02.xls", _
   Application.StartupPath & "\ExcelTemplate.xls", pID2)
XlsCreator1.Cell("C5").Long = 75000

' ファイルクローズ時に、オープンした ID を選択し閉じます
XlsCreator1.CloseBookEx(True, pID2)
XlsCreator1.CloseBookEx(True, pID1)

[C#]
uint pID1 = 0;
uint pID2 = 0;

// Excel ファイルのオーバーレイオープン時に、ID を設定します
xlsCreator1.OpenBookEx(Application.StartupPath + @"\ExcelFile01.xls",
    Application.StartupPath + @"\ExcelTemplate.xls", ref pID1);
xlsCreator1.Cell("A5").Long = 50000;

xlsCreator1.OpenBookEx(Application.StartupPath + @"\ExcelFile02.xls",
    Application.StartupPath + @"\ExcelTemplate.xls", ref pID2);
xlsCreator1.Cell("C5").Long = 75000;

// ファイルクローズ時に、オープンした ID を選択し閉じます
xlsCreator1.CloseBookEx(true, pID2);
xlsCreator1.CloseBookEx(true, pID1);

注意事項
保護された Excel ファイルをオープンすることはできません。


PageOrder プロパティ

ExcelCreator.PageOrder プロパティ

ページの印刷方向を設定します。

書式

[VB.NET]
  Public WriteOnly Property PageOrder() As ExcelCreator.xlPageOrder

[C#]
  public ExcelCreator.xlPageOrder PageOrder [set]

設定値

    ページの方向を設定する値を、xlPageOrder 列挙体のメンバで設定します。

      定数               値    内容
      poRightFromLeft     0    左から右へ印刷します。
      poBottomFromTop     1    上から下へ印刷します。

解説
省略した場合は、デザインファイル内の設定が適用されます。

左から右へ印刷

上から下へ印刷

参照
[Size メソッド] | [SizeFree メソッド] | [Margin メソッド]

コーディング例

ページの方向を「上から下」に設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003)
XlsCreator1.PageOrder = ExcelCreator.xlPageOrder.poBottomFromTop
XlsCreator1.Cell("A1:E10").Attr.Box(ExcelCreator.xlBoxType.btLtc, ExcelCreator.xlLineStyle.lsNormal)
XlsCreator1.Cell("A1").Str = "ページの方向 : 上から下 (1ページ目)"
XlsCreator1.Cell("F1:J10").Attr.Box(ExcelCreator.xlBoxType.btLtc, ExcelCreator.xlLineStyle.lsThick)
XlsCreator1.Cell("F1").Str = "ページの方向 : 上から下 (2ページ目)"
XlsCreator1.Cell("A11:E20").Attr.Box(ExcelCreator.xlBoxType.btLtc, ExcelCreator.xlLineStyle.lsSlender)
XlsCreator1.Cell("A11").Str = "ページの方向 : 上から下 (3ページ目)"
XlsCreator1.Cell("F11:J20").Attr.Box(ExcelCreator.xlBoxType.btLtc, ExcelCreator.xlLineStyle.lsThick2)
XlsCreator1.Cell("F11").Str = "ページの方向 : 上から下 (4ページ目)"
XlsCreator1.Cell("F11").Break = True
XlsCreator1.Cell("K11").Break = True
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003);
xlsCreator1.PageOrder = ExcelCreator.xlPageOrder.poBottomFromTop;
xlsCreator1.Cell("A1:E10").Attr.Box(ExcelCreator.xlBoxType.btLtc, ExcelCreator.xlLineStyle.lsNormal);
xlsCreator1.Cell("A1").Str = "ページの方向 : 上から下 (1ページ目)";
xlsCreator1.Cell("F1:J10").Attr.Box(ExcelCreator.xlBoxType.btLtc, ExcelCreator.xlLineStyle.lsThick);
xlsCreator1.Cell("F1").Str = "ページの方向 : 上から下 (2ページ目)";
xlsCreator1.Cell("A11:E20").Attr.Box(ExcelCreator.xlBoxType.btLtc, ExcelCreator.xlLineStyle.lsSlender);
xlsCreator1.Cell("A11").Str = "ページの方向 : 上から下 (3ページ目)";
xlsCreator1.Cell("F11:J20").Attr.Box(ExcelCreator.xlBoxType.btLtc, ExcelCreator.xlLineStyle.lsThick2);
xlsCreator1.Cell("F11").Str = "ページの方向 : 上から下 (4ページ目)";
xlsCreator1.Cell("F11").Break = true;
xlsCreator1.Cell("K11").Break = true;
xlsCreator1.CloseBook(true);


PDF クラス

ExcelCreator.PDF クラス

出力する PDF ファイルの各種設定を行います。

書式

[VB.NET]
  Public ReadOnly Property PDF()

[C#]
  public PDF [get]

解説
このクラスの全てのメンバの一覧については、以下の PDF メンバを参照してください。

メンバ

パブリック プロパティ
Title プロパティ | 文書プロパティの概要 [タイトル] を設定します。
Subject プロパティ | 文書プロパティの概要 [サブタイトル] を設定します。
Producer プロパティ | 文書プロパティの概要 [PDF 変換] を設定します。
Creator プロパティ | 文書プロパティの概要 [アプリケーション] を設定します。
Author プロパティ | 文書プロパティの概要 [作成者] を設定します。
EmbedFonts プロパティ | 埋め込むフォントを設定します。
ImageType プロパティ | イメージの種類を設定します。
ProgressDialog プロパティ | 処理経過を表示するプログレスダイアログの表示/非表示を設定します。


PDF.Author プロパティ

ExcelCreator.PDF.Author プロパティ

PDF ファイルの文書プロパティの概要 [作成者] を設定します。

書式

[VB.NET]
  Public WriteOnly Property Author() As String

[C#]
  public string Author [set]

解説
デフォルトは「Advance Software Corp」です。

コーディング例

PDF ファイルの文書プロパティの概要 [作成者] を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003)
XlsCreator1.PDF.Author = "作成者の名前"
XlsCreator1.CloseBook(True, Application.StartupPath & "\PdfFile.pdf", True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003);
xlsCreator1.PDF.Author = "作成者の名前";
xlsCreator1.CloseBook(true, Application.StartupPath + @"\PdfFile.pdf", true);


PDF.Creator プロパティ

ExcelCreator.PDF.Creator プロパティ

PDF ファイルの文書プロパティの概要 [アプリケーション] を設定します。

書式

[VB.NET]
  Public WriteOnly Property Creator() As String

[C#]
  public string Creator [set]

解説
デフォルトは「ExcelCreator 5.0 for .NET」です。

このプロパティで設定した内容は、Acrobat Reader 6 / 7 で開いた場合、文書プロパティの [アプリケーション] の項目として扱われます。Acrobat Reader 5 では [作成] の項目として扱われます。

コーディング例

PDF ファイルの文書プロパティの概要 [アプリケーション] を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003)
XlsCreator1.PDF.Creator = "ExcelCreator 5.0 for .NET"
XlsCreator1.CloseBook(True, Application.StartupPath & "\PdfFile.pdf", True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003);
xlsCreator1.PDF.Creator = "ExcelCreator 5.0 for .NET";
xlsCreator1.CloseBook(true, Application.StartupPath + @"\PdfFile.pdf", true);


PDF.EmbedFonts プロパティ

ExcelCreator.PDF.EmbedFonts プロパティ

PDF ファイルに埋め込むフォントを設定します。

書式

[VB.NET]
  Public WriteOnly Property EmbedFonts() As String()

[C#]
  public string[] EmbedFonts [set]

解説
PDF ファイルに埋め込むフォント名を設定します。
設定したフォントが Excel ファイル内で使用されていない場合は、PDF ファイルには埋め込まれません。
"*" を設定した場合、Excel ファイル内で使用しているフォントを全て埋め込みま す。

コーディング例

「MS ゴシック」「MS P ゴシック」を、PDF ファイルの文書で使用しているフォントとして設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003)
XlsCreator1.PDF.EmbedFonts = New String() {"MS ゴシック", "MS P ゴシック"}
XlsCreator1.CloseBook(True, Application.StartupPath & "\PdfFile.pdf", True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003);
xlsCreator1.PDF.EmbedFonts = new string[]{"MS ゴシック", "MS P ゴシック"};
xlsCreator1.CloseBook(true, Application.StartupPath + @"\PdfFile.pdf", true);


PDF.ImageType プロパティ

ExcelCreator.PDF.ImageType プロパティ

PDF ファイルのイメージの種類を設定します。

書式

[VB.NET]
  Public WriteOnly Property ImageType() As ExcelCreator.xlImageType

[C#]
  public ExcelCreator.xlImageType ImageType [set]

設定値

    xlImageType 列挙体のメンバで設定します。

      定数       内容
      BMP        ビットマップ形式
      GIF        GIF 形式
      JPEG       JPEG 形式 (デフォルト値)

コーディング例

PDF ファイルのイメージの種類を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003)
XlsCreator1.PDF.ImageType = ExcelCreator.xlImageType.BMP
XlsCreator1.CloseBook(True, Application.StartupPath & "\PdfFile.pdf", True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003);
xlsCreator1.PDF.ImageType = ExcelCreator.xlImageType.JPEG;
xlsCreator1.CloseBook(true, Application.StartupPath + @"\PdfFile.pdf", true);


PDF.Producer プロパティ

ExcelCreator.PDF.Producer プロパティ

PDF ファイルの文書プロパティの概要 [PDF 変換] を設定します。

書式

[VB.NET]
  Public WriteOnly Property Producer() As String

[C#]
  public string Producer [set]

解説
デフォルトは「ExcelCreator 5.0 for .NET」です。

コーディング例

PDF ファイルの文書プロパティの概要 [PDF 変換] を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003)
XlsCreator1.PDF.Producer = "ExcelCreator 5.0 for .NET"
XlsCreator1.CloseBook(True, Application.StartupPath & "\PdfFile.pdf", True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003);
xlsCreator1.PDF.Producer = "ExcelCreator 5.0 for .NET";
xlsCreator1.CloseBook(true, Application.StartupPath + @"\PdfFile.pdf", true);


PDF.ProgressDialog プロパティ

ExcelCreator.PDF.ProgressDialog プロパティ

PDF ファイル出力時の処理経過を表示するプログレスダイアログの表示/非表示を設定します。

書式

[VB.NET]
  Public Property ProgressDialog() As Boolean

[C#]
  public bool ProgressDialog [get, set]

設定値

      値       内容
      True     プログレスダイアログを表示する
      False    プログレスダイアログを表示しない (デフォルト値)

解説
アプリケーション中で処理の経過を制御する場合は、このプロパティを False に設定 し、Progress イベントで処理の経過を制御します。
ProgressDialog プロパティが True の場合は、Progress イベントは発生しません。

参照
[Progress イベント]

コーディング例

PDF ファイル出力時にプログレスダイアログを表示しないようにするため、
プログレスダイアログを非表示に設定します

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003)
XlsCreator1.PDF.ProgressDialog = False
XlsCreator1.CloseBook(True, Application.StartupPath & "\PdfFile.pdf", True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003);
xlsCreator1.PDF.ProgressDialog = false;
xlsCreator1.CloseBook(true, Application.StartupPath + @"\PdfFile.pdf", true);


PDF.Subject プロパティ

ExcelCreator.PDF.Subject プロパティ

PDF ファイルの文書プロパティの概要 [サブタイトル] を設定します。

書式

[VB.NET]
  Public WriteOnly Property Subject() As String

[C#]
  public string Subject [set]

解説
デフォルトはシート名です。

コーディング例

PDF ファイルの文書プロパティの概要 [サブタイトル] を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003)
XlsCreator1.PDF.Subject = "第一営業部"
XlsCreator1.CloseBook(True, Application.StartupPath & "\PdfFile.pdf", True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003);
xlsCreator1.PDF.Subject = "第一営業部";
xlsCreator1.CloseBook(true, Application.StartupPath + @"\PdfFile.pdf", true);


PDF.Title プロパティ

ExcelCreator.PDF.Title プロパティ

PDF ファイルの文書プロパティの概要 [タイトル] を設定します。

書式

[VB.NET]
  Public WriteOnly Property Title() As String

[C#]
  public string Title [set]

解説
デフォルトは「ExcelCreator 5.0 for .NET」です。

コーディング例

PDF ファイルの文書プロパティの概要 [タイトル] を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003)
XlsCreator1.PDF.Title = "2005 年度売り上げ一覧"
XlsCreator1.CloseBook(True, Application.StartupPath & "\PdfFile.pdf", True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003);
xlsCreator1.PDF.Title = "2005 年度売り上げ一覧";
xlsCreator1.CloseBook(true, Application.StartupPath + @"\PdfFile.pdf", true);


Pos クラス

ExcelCreator.Pos クラス

出力対象となるセルの範囲を座標形式で設定します。

書式

[VB.NET]
  Public Pos(ByVal sx As Integer, ByVal sy As Integer)
  Public Pos(ByVal sx As Integer, ByVal sy As Integer, ByVal ex As Integer, ByVal ey As Integer)

[C#]
  Public Pos(ByVal sx As Integer, ByVal sy As Integer)
  Public Pos(ByVal sx As Integer, ByVal sy As Integer, ByVal ex As Integer, ByVal ey As Integer)

設定値

    sx , sy
      対象セルの座標を設定します。
    ex , ey
      対象セルの範囲設定を行う場合、終了の座標を設定します。

解説
sx，ex には列を示す (0 ～ 255) の値を設定します。
sy，ey には行を示す (0 ～ 65535) の値を設定します。
Cell("A1:B2") = Pos(0,0,1,1) いずれも、対象セルは同じです。

Pos クラスで範囲指定を行った場合、属性は設定した範囲に対して設定されます。 値の設定や取得については、設定したセル範囲内で先頭座標 (0,0) に最も近い座標が対象となります。

このクラスの全てのメンバの一覧については、以下の Pos メンバを参照してください。

メンバ

パブリック プロパティ
Break プロパティ | 改ページの設定 / 解除を設定します。
ColWidth プロパティ | セルの列幅を設定します。
RowHeight プロパティ | セルの高さを設定します。
Value プロパティ | 数値や文字列、日付などの値を設定 / 取得します。
Str プロパティ | 文字列を取得 / 設定します。
Long プロパティ | 整数を取得 / 設定します。
Double プロパティ | 実数を取得 / 設定します。
AttrNo プロパティ | セルの属性番号を取得します。

パブリック メソッド
Copy メソッド | セルをコピーします。
Paste メソッド | Copy メソッドでコピーしたセルを貼り付けます。
Clear メソッド | セルをクリア(初期化)します。
Value2 メソッド | 数値や文字列、日付などの値と属性番号を設定します。
Str2 メソッド | 文字列と属性番号を設定します。
Long2 メソッド | 整数値と属性番号を設定します。
Double2 メソッド | 実数値と属性番号を設定します。
Func メソッド | 関数の書き込みをします。結果を示す値も同時に設定できます。

参照
[Cell クラス] | [Cell.Attr クラス] | [Pos.Attr クラス]


PrintArea メソッド

ExcelCreator.PrintArea メソッド

シートの印刷範囲を設定します。

書式

[VB.NET]
  Public Sub PrintArea(ByVal sx As Integer, ByVal sy As Integer, ByVal ex As Integer, ByVal ey As Integer)

[C#]
  public void PrintArea(System.Int32 sx, System.Int32 sy, System.Int32 ex, System.Int32 ey)

設定値

    sx
      印刷範囲の開始列位置を設定します。
    sy
      印刷範囲の開始行位置を設定します。
    ex
      印刷範囲の終了列位置を設定します。
    ey
      印刷範囲の終了行位置を設定します。

解説
設定するシートは SheetNo プロパティのシート番号が対象です。

参照
[SheetNo プロパティ]

コーディング例

1 番目のシートと 2 番目のシートの印刷範囲の設定を行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)

XlsCreator1.SheetNo = 0
XlsCreator1.PrintArea(0, 0, 9, 19)
XlsCreator1.Cell("A1:J20").Attr.Box(ExcelCreator.xlBoxType.btLtc, ExcelCreator.xlLineStyle.lsNormal)
XlsCreator1.Cell("A1").Str = "印刷範囲 A1:J20"

XlsCreator1.SheetNo = 1
XlsCreator1.PrintArea(0, 0, 29, 19)
XlsCreator1.Cell("A1:J30").Attr.Box(ExcelCreator.xlBoxType.btLtc, ExcelCreator.xlLineStyle.lsSlender)
XlsCreator1.Cell("A1").Str = "印刷範囲 A1:J30"

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);

xlsCreator1.SheetNo = 0;
xlsCreator1.PrintArea(0, 0, 9, 19);
xlsCreator1.Cell("A1:J20").Attr.Box(ExcelCreator.xlBoxType.btLtc, ExcelCreator.xlLineStyle.lsNormal);
xlsCreator1.Cell("A1").Str = "印刷範囲 A1:J20";

XlsCreator1.SheetNo = 1;
xlsCreator1.PrintArea(0, 0, 29, 19);
xlsCreator1.Cell("A1:J30").Attr.Box(ExcelCreator.xlBoxType.btLtc, ExcelCreator.xlLineStyle.lsSlender);
xlsCreator1.Cell("A1").Str = "印刷範囲 A1:J30";

xlsCreator1.CloseBook(true);


Progress イベント

ExcelCreator.Progress イベント

PDF ファイル出力時の処理状況を通知します。

書式

[VB.NET]
  Protected Overridable Sub OnProgress(ByVal e As ExcelCreator.XlsCreatorProgressArgs)

[C#]
  protected virtual new void OnProgress (ExcelCreator.XlsCreatorProgressArgs e)

設定値

    XlsCreatorProgressArgs の各メンバは、次の通りです。

    Type     処理を識別する、xlProgressType 列挙体のメンバです。
               pgFile  = 2 … ファイルに出力中
               pgData  = 3 … データ出力中
    Count    現在の進捗状況です。
    Total    総ページ数や総シート数を表します。
    Stop     処理を制御します。True を設定した場合、処理を中断します。

解説
Progress イベントは現在の処理の進行状況を通知します。処理の中断も可能です。
ProgressDialog プロパティで「表示しない」を設定した場合、このイベントが発生します。 ユーザー独自の処理進行状況の表示を行う場合に、このイベントで制御を行います。

参照
[ProgressDialog プロパティ]

コーディング例

出力中に「中止」ボタンを押した時点で印刷を中断します
「中止」が押されていない場合、出力ページ数を表示します

[VB.NET]
Dim WithEvents ExcelCreator1 As New ExcelCreator.ExcelCreator()

Public btnBreak As Boolean
'「中止」ボタン
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
    btnBreak = True
End Sub

Public Event Progress(ByVal sender As Object, ByVal e As ExcelCreator.XlsCreatorProgressArgs)

Private Sub ExcelCreator1_Progress(ByVal sender As Object, ByVal e As ExcelCreator.XlsCreatorProgressArgs) Handles ExcelCreator1.Progress
    If (prg.Type = ExcelCreator.xlProgressType.pgData) Then
        'btnBreak は「中止」ボタン押下時に True が入ります
        If (btnBreak = True) Then
            '処理を中止します
            prg.Stop = True
        Else
            '出力ページ数の表示を行います
            Label1.Text = prg.Count.ToString() + " / " + prg.Total.ToString()
        End If
    End If
End Sub

[C#]
ExcelCreator1.Progress += new ExcelCreator.XlsCreatorProgressHandler(ExcelCreator1_Progress);

static bool btnBreak;
//「中止」ボタン
private void button1_Click(object sender, System.EventArgs e)
{
    btnBreak = true;
}

protected void ExcelCreator1_Progress(System.Object i1 , ExcelCreator.ExcelCreatorProgressArgs prg)
{
    if (prg.Type == ExcelCreator.xlProgressType.pgData)
    {
        //btnBreak は「中止」ボタン押下時に True が入ります
        if (btnBreak)
        {
            //処理を中止します
            prg.Stop = true;
        }
        else
        {
            //出力ページ数の表示を行います
            Label1.Text = prg.Count.ToString() + " / " + prg.Total.ToString();
        }
    }
}


ReadBook メソッド

ExcelCreator.ReadBook メソッド

既存 Excel ファイルを読み込み専用でオープンします。

書式

[VB.NET]
  Public Function ReadBook(ByVal strFileName As String) As Integer

[C#]
  public System.Int32 ReadBook(System.String strFileName)

設定値

    strFileName
      読み込み専用でオープンするファイル名を文字列で設定します。

解説
戻り値はメソッドが正常終了した場合には 0 以上の値を、それ以外の場合には 0 より小さい値を返します。

参照
[CloseBook メソッド] | [ReadBookEx メソッド]

コーディング例

読み込み用としてファイルを開き、セルの値を読み込みます。

[VB.NET]
Dim nLong As Long
XlsCreator1.ReadBook(Application.StartupPath & "\ExcelFile.xls")
nLong = XlsCreator1.Cell("D1").Long
XlsCreator1.CloseBook(True)

[C#]
long  nValue;
xlsCreator1.ReadBook(Application.StartupPath + @"\ExcelFile.xls");
nValue = xlsCreator1.Cell("D1").Long;
xlsCreator1.CloseBook(true);

注意事項
・ | 保護された Excel ファイルをオープンすることはできません。
・ | ReadBook メソッドは読み込み専用で Excel ファイルをオープンするため、使用できるメソッドやプロパティに制限があります。


ReadBookEx メソッド

ExcelCreator.ReadBookEx メソッド

既存 Excel ファイルを読み込み専用オープンし、その識別 ID を取得します。

書式

[VB.NET]
  Public Function ReadBookEx(ByVal strFileName As String, ByRef pID As System.UInt32) As Integer

[C#]
  public System.Int32 ReadBookEx(System.String strFileName, System.UInt32 pID)

設定値

    strFileName
      読み込み専用でオープンする Excel ファイル名を設定します。
    pID
      作成するファイルの識別 ID を取得する変数を設定します。

解説
戻り値はメソッドが正常終了した場合には 0 以上の値を、それ以外の場合には 0 より小さい値を返します。
一つの ExcelCreator 5.0 for .NET コンポーネントで複数の Excel ファイルを作成する場合、 ファイルの識別 ID を使用して操作の対象となるファイルを SelectBook メソッドで切り替えて入出力処理を行います。
ReadBookEx でファイルを作成した場合は、必ずCloseBookEx でクローズしてください。

参照
[CloseBookEx メソッド] | [SelectBook メソッド]

コーディング例

読み込み用としてファイルを開きます。

[VB.NET]
Dim pID1 As UInt32
Dim pID2 As UInt32
Dim lValue As Long

' Excel ファイル読み込み専用オープン時に、ID を設定します
XlsCreator1.ReadBookEx(Application.StartupPath & "\ExcelFile01.xls", pID1)
lValue = XlsCreator1.Cell("A1").Long

XlsCreator1.ReadBookEx(Application.StartupPath & "\ExcelFile02.xls", pID2)
lValue = XlsCreator1.Cell("C1").Long

' ファイルクローズ時に、オープンした ID を選択し閉じます
XlsCreator1.CloseBookEx(True, pID2)
XlsCreator1.CloseBookEx(True, pID1)

[C#]
uint pID1 = 0;
uint pID2 = 0;
long lValue;

// Excel ファイル読み込み専用オープン時に、ID を設定します
xlsCreator1.ReadBookEx(Application.StartupPath + @"\ExcelFile01.xls", ref pID1);
lValue = xlsCreator1.Cell("A1").Long;

xlsCreator1.ReadBookEx(Application.StartupPath + @"\ExcelFile02.xls", ref pID2);
lValue = xlsCreator1.Cell("C1").Long;

// ファイルクローズ時に、オープンした ID を選択し閉じます
xlsCreator1.CloseBookEx(true, pID2);
xlsCreator1.CloseBookEx(true, pID1);

注意事項
・ | 保護された Excel ファイルをオープンすることはできません。
・ | ReadBookEx メソッドは、読み込み専用で Excel ファイルをオープンするため、使用できるメソッドやプロパティに制限があります。


RefSheet プロパティ

ExcelCreator.RefSheet プロパティ

参照するシート名を設定します。

書式

[VB.NET]
  Public WriteOnly Property RefSheet() As String

[C#]
  public string RefSheet [set]

設定値

    参照するシート名を設定します。
    複数のシートを参照する場合には "/" スラッシュで区切って設定します。

解説
Func メソッドの指定セルに参照シートを含む場合には、必ず Func メソッドを設定する 前に参照されているシート名を設定してください。

参照
[Func メソッド]

コーディング例

シートに対し各種設定を行います。
4 番目のシート名を 4 月に設定し、セル A1 に数値 400 を入れます。
次に 1 番目のシート(Sheet1)セル A1 に数値 100 を入れ、セル A1 に数値 100 を入れます。
1 番目のシート(Sheet1)に 他のシートのセル値を参照する関数を書き込みます。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 4, ExcelCreator.xlVersion.ver2003)

XlsCreator1.SheetNo = 3
XlsCreator1.SheetName = "４月"
XlsCreator1.Cell("A1").Long = 400

XlsCreator1.SheetNo = 0
XlsCreator1.Cell("A1").Long = 100
XlsCreator1.RefSheet = "Sheet1/４月"
XlsCreator1.Cell("A2").Func("=SUM(Sheet1:４月!A1)", "")

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 4, ExcelCreator.xlVersion.ver2003);

xlsCreator1.SheetNo = 3;
xlsCreator1.SheetName = "４月";
xlsCreator1.Cell("A1").Long = 400;

xlsCreator1.SheetNo = 0;
xlsCreator1.Cell("A1").Long = 100;
xlsCreator1.RefSheet = "Sheet1/４月";
xlsCreator1.Cell("A2").Func("=SUM(Sheet1:４月!A1)", null);

xlsCreator1.CloseBook(true);


RowClear メソッド

ExcelCreator.RowClear メソッド

行をクリア (初期化) します。

書式

[VB.NET]
  Public Sub RowClear(ByVal sy As Integer, ByVal count As Integer)

[C#]
  public void RowClear(System.Int32 sy , System.Int32 count)

設定値

    sy
      クリアする開始行番号値 (0 ～) を設定します。
    count
      クリアする行数値 (1 ～) を設定します。

解説
引数 sy の設定行から、引数 count の行数分をクリア (初期化) します。

コーディング例

2 行目から 1 行のみクリア、2 行目から 2 行分クリアします。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.RowClear(1, 0)
XlsCreator1.RowClear(1, 2)
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.RowClear(1, 0);
xlsCreator1.RowClear(1, 2);
xlsCreator1.CloseBook(true);


RowCopy メソッド

ExcelCreator.RowCopy メソッド

行をコピーします。

書式

[VB.NET]
  Public Sub RowCopy(ByVal sy As Integer, ByVal dy As Integer)

[C#]
  public void RowCopy(System.Int32 sy , System.Int32 dy)

設定値

    sy
      コピー元の行番号値 (0 ～) を設定します。
    dy
      コピー先の行番号値 (0 ～) を設定します。

解説
引数 sy の設定行を、引数 dy の行へコピーします。
引数 dy に -1 を設定した時は、引数 sy の設定行がメモリ上にコピーされます。 コピーした行は、RowPaste メソッドで設定した行に貼り付けることができます。

参照
[RowPaste メソッド]

コーディング例

A1:B1 セルのコピーを A2 セルに貼り付け、A1 セルのコピーを C2 セルに貼り付けます。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A1").Func("=sum(B1:C1)", "")
XlsCreator1.RowCopy(0, 19)
XlsCreator1.RowCopy(0, -1)
XlsCreator1.RowPaste(20)
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A1").Func("=sum(B1:C1)", null);
xlsCreator1.RowCopy(0, 19);
xlsCreator1.RowCopy(0, -1);
xlsCreator1.RowPaste(20);
xlsCreator1.CloseBook(true);

注意事項
・ | コピー元セルのセル属性と値のみコピーします。
・ | コピー元セルに変数名が設定されている場合、変数名はコピーされません。
・ | Excel ファイルのブック間、シート間のコピー・貼り付けには対応しておりません。


RowDelete メソッド

ExcelCreator.RowDelete メソッド

行を削除します。

書式

[VB.NET]
  Public Sub RowDelete(ByVal sy As Integer, ByVal count As Integer)

[C#]
  public void RowDelete(System.Int32 sy , System.Int32 count)

設定値

    sy
      削除する開始行番号値 (0 ～) を設定します。
    count
      削除する行数値 (1 ～) を設定します。

解説
引数 sy の設定行から、引数 count の行数分を削除します。

コーディング例

2 行目から 1 行のみ削除、2 行目から 2 行分削除します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.RowDelete(1, 0)
XlsCreator1.RowDelete(1, 2)
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.RowDelete(1, 0);
xlsCreator1.RowDelete(1, 2);
xlsCreator1.CloseBook(true);

注意事項
行削除を行っても、Excel シート上に設定されているオートシェイプや画像の位置は移動されません。


RowInsert メソッド

ExcelCreator.RowInsert メソッド

行を挿入します。

書式

[VB.NET]
  Public Sub RowInsert(ByVal sy As Integer, ByVal count As Integer)

[C#]
  public void RowInsert(System.Int32 sy , System.Int32 count)

設定値

    sy
      挿入する開始行番号値 (0 ～) を設定します。
    count
      挿入する行数値 (1 ～) を設定します。

解説
引数 sy の指定行から、引数 count の行数分を挿入します。

ExcelCreator 5.0 for .NET と Excel では次の様に一部動作仕様が異なっております。

ExcelCreator 5.0 for .NET | Excel
デフォルトの行高さ、フォントで挿入されます。 | 行挿入する上の行と同じ行高さ、フォントで挿入されます。 (1 行目の場合、行高さはデフォルト値、フォントは標準フォント・サイズ)

コーディング例

2 行目から 1 行のみ挿入、2 行目から 2 行分挿入します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.RowInsert(1, 0)
XlsCreator1.RowInsert(1, 2)
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.RowInsert(1, 0);
xlsCreator1.RowInsert(1, 2);
xlsCreator1.CloseBook(true);

注意事項
行挿入を行っても、Excel シート上に設定されているオートシェイプや画像の位置は移動されません。


RowPaste メソッド

ExcelCreator.RowPaste メソッド

RowCopy メソッドでコピーした行を貼り付けます。

書式

[VB.NET]
  Public Sub RowPaste(ByVal dy As Integer)

[C#]
  public void RowPaste(System.Int32 dy)

設定値

    dy
      貼り付けを行う行番号値 (0 ～) を設定します。

解説
RowCopy メソッドにより、メモリ上にコピーされた行を 引数 dy に貼り付けます。 元の行は上書きされます。

参照
[RowCopy メソッド]

コーディング例

1 行目を 20 行目にコピー、1 行目をメモリ上にコピーし 21 行目に貼り付けます。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Cell("A1").Func("=sum(B1:C1)", "")
XlsCreator1.RowCopy(0, 19)
XlsCreator1.RowCopy(0, -1)
XlsCreator1.RowPaste(20)
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Cell("A1").Func("=sum(B1:C1)", null);
xlsCreator1.RowCopy(0, 19);
xlsCreator1.RowCopy(0, -1);
xlsCreator1.RowPaste(20);
xlsCreator1.CloseBook(true);

注意事項
・ | コピー元セルのセル属性と値のみコピーします。
・ | コピー元セルに変数名が設定されている場合、変数名はコピーされません。
・ | Excel ファイルのブック間、シート間のコピー・貼り付けには対応しておりません。


SelectBook メソッド

ExcelCreator.SelectBook メソッド

CreateBookEx / ReadBookEx / OpenBookEx / OpenBookEmbedEx で Excel ファイルを操作する場合に、操作対象となる Excel ファイルの選択を行います。

書式

[VB.NET]
  Public Sub SelectBook(ByVal uiID As System.UInt32)

[C#]
  public void SelectBook(System.UInt32 uiID)

設定値

    uiID
      操作対象とする Excel ファイルの識別 ID を設定します。

参照
[CreateBookEx メソッド] | [ReadBookEx メソッド] | [OpenBookEx メソッド] | [OpenBookEmbedEx メソッド] | [CloseBookEx メソッド]

コーディング例

選択対象の Excel ファイルを変更しながら値設定を行います。

[VB.NET]
Dim pID1 As UInt32
Dim pID2 As UInt32

' Excel ファイル新規作成時に、ID を設定します
XlsCreator1.CreateBookEx(Application.StartupPath & "\ExcelFile01.xls", 1, ExcelCreator.xlVersion.ver2003, pID1)
XlsCreator1.CreateBookEx(Application.StartupPath & "\ExcelFile02.xls", 1, ExcelCreator.xlVersion.ver2003, pID2)

' 操作対象の ID を選択します
XlsCreator1.SelectBook(pID1)
XlsCreator1.Cell("A1").Value = 10000
XlsCreator1.SelectBook(pID2)
XlsCreator1.Cell("A5").Value = 18000

XlsCreator1.CloseBookEx(True, pID2)
XlsCreator1.CloseBookEx(True, pID1)

[C#]
uint pID1 = 0;
uint pID2 = 0;

// Excel ファイル新規作成時に、ID を設定します
xlsCreator1.CreateBookEx(Application.StartupPath + @"\ExcelFile01.xls", 1, ExcelCreator.xlVersion.ver2003, ref pID1);
xlsCreator1.CreateBookEx(Application.StartupPath + @"\ExcelFile02.xls", 1, ExcelCreator.xlVersion.ver2003, ref pID2);

// 操作対象の ID を選択します
xlsCreator1.SelectBook(pID1);
xlsCreator1.Cell("A1").Value = 10000;
xlsCreator1.SelectBook(pID2);
xlsCreator1.Cell("A5").Value = 18000;

xlsCreator1.CloseBookEx(true, pID2);
xlsCreator1.CloseBookEx(true, pID1);


SheetCount プロパティ

ExcelCreator.SheetCount プロパティ

Excel ファイルのシート総数を取得します。

書式

[VB.NET]
  Public ReadOnly Property SheetCount() As Integer

[C#]
  public int SheetCount [get]

コーディング例

Excel ファイルのシート総数の取得を行ないます。

[VB.NET]
Dim nSheetCount As Integer
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")
nSheetCount = XlsCreator1.SheetCount
XlsCreator1.CloseBook(True)

[C#]
Int32 nSheetCount;
xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");
nSheetCount = xlsCreator1.SheetCount;
xlsCreator1.CloseBook(true);


SheetName プロパティ

ExcelCreator.SheetName プロパティ

シート名の取得、または、設定します。

書式

[VB.NET]
  Public Property SheetName() As String

[C#]
  public string SheetName [get, set]

設定値

    半角文字数 1 ～ 31 文字で設定します。

コーディング例

シート名を 4 月に設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 4, ExcelCreator.xlVersion.ver2003)
XlsCreator1.SheetName = "４月"
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 4, ExcelCreator.xlVersion.ver2003);
xlsCreator1.SheetName = "４月";
xlsCreator1.CloseBook(true);

シート名を取得し、メッセージボックスに表示します。

[VB.NET]
XlsCreator1.ReadBook(Application.StartupPath & "\ExcelFile.xls")
MsgBox(XlsCreator1.SheetName)
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.ReadBook(Application.StartupPath + @"\ExcelFile.xls");
MessageBox.Show(xlsCreator1.SheetName);
xlsCreator1.CloseBook(true);


SheetName2 プロパティ

ExcelCreator.SheetName2 プロパティ

シート番号からシート名を取得します。

書式

[VB.NET]
  Public Function SheetName2(ByVal sheetno As Integer) As String

[C#]
  public System.String SheetName2(System.Int32 sheetno)

設定値

    sheetno
      シート番号を示す数値を設定します。

解説
シート番号には Excel ファイル内の左端シートを 0 として、 全シート数 - 1 まで設定することができます。

コーディング例

シート番号からシート名の取得を行います。

[VB.NET]
Dim strSheetName As String
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")
strSheetName = XlsCreator1.SheetName2(2)
XlsCreator1.CloseBook(True)

[C#]
string strSheetName;
xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");
strSheetName = xlsCreator1.SheetName2(2);
xlsCreator1.CloseBook(true);


SheetNo プロパティ

ExcelCreator.SheetNo プロパティ

操作対象となるシートの選択を行います。

書式

[VB.NET]
  Public WriteOnly Property SheetNo() As Integer

[C#]
  public int SheetNo [set]

設定値

    操作対象とするシートを値で設定します。
    左端シートを 0 として、全シート数 - 1 まで設定することができます。

解説
Excel ファイルをオープン後は 0 が初期状態です。

コーディング例

シートに対し各種設定を行います。
4 番目のシート名を 4 月に設定し、セル A1 に数値 400 を入れます。
シート名を取得し、メッセージボックスに表示します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 4, ExcelCreator.xlVersion.ver2003)
XlsCreator1.SheetNo = 3
XlsCreator1.SheetName = "４月"
XlsCreator1.Cell("A1").Long = 400
XlsCreator1.CloseBook(True)

XlsCreator1.ReadBook(Application.StartupPath & "\ExcelFile.xls")
XlsCreator1.SheetNo = 0
MsgBox(XlsCreator1.SheetName)
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 4, ExcelCreator.xlVersion.ver2003);
xlsCreator1.SheetNo = 3;
xlsCreator1.SheetName = "４月";
xlsCreator1.Cell("A1").Long = 400;
xlsCreator1.CloseBook(true);

xlsCreator1.ReadBook(Application.StartupPath + @"\ExcelFile.xls");
xlsCreator1.SheetNo = 0;
MessageBox.Show(xlsCreator1.SheetName);
xlsCreator1.CloseBook(true);


SheetNo2 プロパティ

ExcelCreator.SheetNo2 プロパティ

シート名からシート番号を取得します。

書式

[VB.NET]
  Public Function SheetNo2(ByVal sheetname As String) As Integer

[C#]
  public System.Int32 SheetNo2(System.String sheetname)

設定値

    sheetname
      シート番号を取得する元のシート名を示す文字列を設定します。

解説
シート番号は左端から 0 から数えた番号が取得されます。
設定したシート名が Excel ファイルに存在しない場合、戻り値は -1 となります。

コーディング例

「Sheet3」のシート番号を取得します。

[VB.NET]
Dim nSheetNo As Integer
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")
nSheetNo = XlsCreator1.SheetNo2("Sheet3")
XlsCreator1.CloseBook(True)

[C#]
Int32 nSheetNo;
xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");
nSheetNo = xlsCreator1.SheetNo2("Sheet3");
xlsCreator1.CloseBook(true);


Size メソッド

ExcelCreator.Size メソッド

用紙情報の設定を行います。

書式

[VB.NET]
  Public Sub Size(ByVal nOrientation As ExcelCreator.xlOrientation, ByVal nScale As Integer, ByVal nPaperSize As System.Drawing.Printing.PaperKind)

[C#]
  public void Size(ExcelCreator.xlOrientation nOrientation, System.Int32 nScale, System.Drawing.Printing.PaperKind nPaperSize)

設定値

    nScale
      印刷時の拡大/縮小率 (10 ～ 400%) を設定します。
    nPaperSize
      用紙サイズを System.Drawing.Printing.PaperKind のメンバで設定します。
    nOrientation
      印刷の向きをを設定します。
      定数          値       内容
      orLandscape   0        横
      orPortrait    2        縦

解説
ユーザー定義用紙サイズは、SizeFree メソッドで設定します。

参照
[SizeFree メソッド] | [Margin メソッド]

コーディング例

印刷用紙を B4 横、倍率 70% に設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003)
XlsCreator1.Size(ExcelCreator.xlOrientation.orLandscape, 70, System.Drawing.Printing.PaperKind.B4)
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003);
xlsCreator1.Size(ExcelCreator.xlOrientation.orLandscape, 70, System.Drawing.Printing.PaperKind.B4);
xlsCreator1.CloseBook(true);


SizeFree メソッド

ExcelCreator.SizeFree メソッド

ユーザー定義用紙の設定を行います。

書式

[VB.NET]
  Public Sub SizeFree(ByVal Width As Double, ByVal Height As Double, ByVal strPaperName As String)

[C#]
  public void SizeFree(System.Double Width, System.Double Height, System.String strPaperName)

設定値

    Width
      ユーザー定義用紙の幅を設定します。設定単位はミリ (mm) です。
    Height
      ユーザー定義用紙の長さを設定します。設定単位はミリ (mm) です。
    strPaperName
      ユーザー定義用紙名を設定します。

解説
・Windows NT / 2000 / XP の場合
プリントサーバーのプロパティで登録した用紙名を引数 strPaperNameに、 用紙サイズ (高さ・幅) を引数 Width と Height に設定してください。
・Windows 98 / Me の場合
引数 Width と Height には、ユーザー定義の用紙サイズ (高さ・幅) を設定してください。なお、引数 strPaperName には、"" を設定してください。

規定用紙の場合は Size メソッドで設定します。

参照
[Size メソッド] | [Margin メソッド]

コーディング例

297.0(mm)× 210.0(mm) のユーザー定義の用紙サイズを設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003)
XlsCreator1.SizeFree(297, 210, "ユーザー定義用紙")
XlsCreator1.Cell("A1:G20").Attr.Box(ExcelCreator.xlBoxType.btLtc, ExcelCreator.xlLineStyle.lsNormal)
XlsCreator1.Cell("A1").Str = "用紙サイズ : ユーザ定義用紙 297.0(mm)× 210.0(mm)"
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003);
xlsCreator1.SizeFree(297, 210, "ユーザー定義用紙");
xlsCreator1.Cell("A1:G20").Attr.Box(ExcelCreator.xlBoxType.btLtc, ExcelCreator.xlLineStyle.lsNormal);
xlsCreator1.Cell("A1").Str = "用紙サイズ : ユーザ定義用紙 297.0(mm)× 210.0(mm)";
xlsCreator1.CloseBook(true);

Windows 98 / Me にて、297.0(mm)× 210.0(mm) のユーザー定義の用紙サイズを設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003)
XlsCreator1.SizeFree(297, 210, "")
XlsCreator1.Cell("A1:G20").Attr.Box(ExcelCreator.xlBoxType.btLtc, ExcelCreator.xlLineStyle.lsNormal)
XlsCreator1.Cell("A1").Str = "用紙サイズ : 297.0(mm)× 210.0(mm)"
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 1, ExcelCreator.xlVersion.ver2003);
xlsCreator1.SizeFree(297, 210, "");
xlsCreator1.Cell("A1:G20").Attr.Box(ExcelCreator.xlBoxType.btLtc, ExcelCreator.xlLineStyle.lsNormal);
xlsCreator1.Cell("A1").Str = "用紙サイズ : 297.0(mm)× 210.0(mm)";
xlsCreator1.CloseBook(true);

注意事項
設定する幅・高さは、用紙方向の向きに関係します。 例えば幅 100mm、長さ 200mm のユーザー定義用紙の場合、 用紙方向が縦ならば引数 Width に 100 、引数 Height に 200 を設定します。 用紙方向が横ならば引数 Width に 200 、引数 Height に 100 を設定します。
・例：


VarCheck プロパティ

ExcelCreator.VarCheck プロパティ

オーバーレイ元ファイルにある変数名をチェックします。

書式

[VB.NET]
  Public Function VarCheck(ByVal strVarName As String) As Boolean

[C#]
  public System.Boolean VarCheck(System.String strVarName)

設定値

    strVarName
      チェックする変数名を設定します。

解説
存在する場合は True、存在しない場合は False が返ります。

存在しない変数名に書式や値を設定するとエラーが発生するため、あらかじめ、 変数名が存在するか確認を行うことができます。

参照
[KeyWord プロパティ]

コーディング例

変数名をチェックして、データを差し込みます。

[VB.NET]
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", Application.StartupPath & "\ExcelTemplate.xls")

' セル変数がある時にデータを設定します
If XlsCreator1.VarCheck("**POST") = True Then
    XlsCreator1.Cell("**POST").Value = "918-8237"
End If
If XlsCreator1.VarCheck("**ADDRESS") = True Then
    XlsCreator1.Cell("**ADDRESS").Value = "福井県福井市和田東1丁目222番地"
End If

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", Application.StartupPath + @"\ExcelTemplate.xls");

// セル変数がある時にデータを設定します
if (xlsCreator1.VarCheck("**POST"))
    xlsCreator1.Cell("**POST").Value = "918-8237";
if (xlsCreator1.VarCheck("**ADDRESS"))
    xlsCreator1.Cell("**ADDRESS").Value = "福井県福井市和田東1丁目222番地";

xlsCreator1.CloseBook(true);


VarInsertMode プロパティ

ExcelCreator.VarInsertMode プロパティ

オーバーレイ元ファイルのセル変数名への差し込みモードを設定します。

書式

[VB.NET]
  Public WriteOnly Property VarInsertMode() As ExcelCreator.xlVarInsertMode

[C#]
  public ExcelCreator.xlVarInsertMode VarInsertMode [set]

設定値

    xlVarInsertMode 列挙体のメンバで設定します。

    定数                値    内容
    vmValidAll           0    全ての変数名を対象 (デフォルト値)
    vmInvalidAnswer      1    関数結果の変数名は対象外
    vmInvalidTextBox     2    TextBox の変数名は対象外
    vmInvalidCellText    4    セルに直接設定した変数名は対象外

解説
計算式の結果として参照するセルに変数文字列が設定されている場合、計算式が設定されたセルの値も変数文字列となりますが、その変数文字列に差し込みを行うと、計算式が差し込んだデータに置き換わってしまいます。
例えば、A1 セルに "=A2" が設定されていて、A2 セルの内容に "**Name" などの変数文字列が設定されている場合、A1 セル、A2 セルの内容はともに "**Name" となりますが、プログラム中で "**Name" にデータ (例 : 100) を差し込むと、A1 セル、A2 セルの値はともに 100 になり、A1 セルに設定されていた計算式は上書きされます。
このようなケースで計算式の内容が置き換わらないようにするには、このプロパティで vmInvalidAnswer を設定することで、計算結果としての変数文字列には差し込みを行わないようにすることができます。

オーバーレイ元ファイルのオープン前に設定してください。 オープン後に変更した場合は、次のオープン以降で有効になります。

・「全ての変数名を対象」の場合
 オーバーレイ元のシートに定義している全ての変数名 (関数結果とテキストボックスの変数名も含む) に値を差し込みます。

・「関数結果の変数名は対象外」の場合
 例えば A1 セルに **Name 、A2 セルに =A1 と設定すると A2 セルは関数結果として変数名が表示されます。「計算結果の変数名は対象外」の場合、前述の A2 セルに値は差し込まれません。

・「TextBox の変数名は対象外」の場合
 オーバーレイ元ファイルに定義しているテキストボックスの変数名に値は差し込まれません。

・「セルに直接設定した変数名は対象外」の場合
 オーバーレイ元ファイルのセルに直接変数名文字列を定義しているセルに値は差し込まれません。
関数結果の変数名やテキストボックスの変数名には値が差し込まれます。

参照
[KeyWord プロパティ]

コーディング例

セル変数名への差し込みモードを「セルに直接設定した変数名は対象外」に設定します。
この場合、**ZIPCODE にはデータは差し込まれません。

[VB.NET]
XlsCreator1.VarInsertMode = ExcelCreator.xlVarInsertMode.vmInvalidCellText

XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", Application.StartupPath & "\ExcelTemplate.xls")

XlsCreator1.Cell("**ZIPCODE").Value = "918-8237"

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.VarInsertMode = ExcelCreator.xlVarInsertMode.vmInvalidCellText;

xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", Application.StartupPath + @"\ExcelTemplate.xls");

xlsCreator1.Cell("**ZIPCODE").Value = "918-8237";

xlsCreator1.CloseBook(true);

注意事項
・ VarInsertMode プロパティの設定は、ブック作成／オープンの前に行います。


Zoom プロパティ

ExcelCreator.Zoom プロパティ

シートの表示倍率を設定します。

書式

[VB.NET]
  Public WriteOnly Property Zoom() As Integer

[C#]
  public int Zoom [set]

設定値

    シートの表示倍率値 (10 ～ 400) を設定します。

コーディング例

シートの表示倍率を設定します。

[VB.NET]
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")
XlsCreator1.SheetNo = 0
XlsCreator1.Zoom = 90
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");
xlsCreator1.SheetNo = 0;
xlsCreator1.Zoom = 90;
xlsCreator1.CloseBook(true);


ActiveSheet プロパティ

- ExcelCreator .NET -
XlsCrt.ActiveSheet プロパティ

アクティブ シートをシート番号を取得、または、設定します。

書式

[VB.NET]
  Public Property ActiveSheet() As Integer

[C#]
  public int ActiveSheet [get, set]

設定値

    アクティブ シートのシート番号を取得する変数を設定します。
    アクティブにするシート番号 (0 ～) を設定します。

解説
アクティブ シートは、Excel ブックを Excel で開いた時に最初に表示されるシートです。
セルの書式設定や値を設定・取得を行うシートの設定には、SheetNo プロパティを使用 します。

参照
[SheetNo プロパティ]

コーディング例

アクティブ シートの番号の取得を行います。

[VB.NET]
Dim nActiveSheetNo As Integer

XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")

'Excel ブックのアクティブ シートのシート番号を取得します。
nActiveSheetNo = XlsCreator1.ActiveSheet

XlsCreator1.CloseBook(True)

[C#]
Int32 nActiveSheetNo;

xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");

//Excel ブックのアクティブ シートのシート番号を取得します。
nActiveSheetNo = xlsCreator1.ActiveSheet;

xlsCreator1.CloseBook(true);

 2 シート目をアクティブ シートに設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'Excel ブックの 2 シート目 (シート番号 : 1) をアクティブ シートに設定します。
XlsCreator1.ActiveSheet = 1

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//Excel ブックの 2 シート目 (シート番号 : 1) をアクティブ シートに設定します。
xlsCreator1.ActiveSheet = 1;

xlsCreator1.CloseBook(true);


AddSheet メソッド

- ExcelCreator .NET -
XlsCrt.AddSheet メソッド

ブックに新規にシートを追加します。

書式

[VB.NET]
  Public Sub AddSheet(ByVal count As Integer)

[C#]
  public void AddSheet(System.Int32 count)

設定値

    count
      追加するシート数 (1 ～) を設定します。

解説
新規シートは、ブックの最後に追加します。
追加したシート名「SheetN」 (N は現在の最大シート数 + 1) が設定されます。

参照
[SheetName メソッド] | [SheetNo プロパティ]

コーディング例

ブック内にシートの追加を行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 1, XlsCrt.xlVersion.ver2003)

'ブックに 5 シート追加します
XlsCreator1.AddSheet(5)
'ブックの 4 シート目から 2 シート分削除します
XlsCreator1.DelSheet(3, 2)

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 1, XlsCrt.xlVersion.ver2003);

//ブックに 5 シート追加します
xlsCreator1.AddSheet(5);
//ブックの 4 シート目から 2 シート分削除します
xlsCreator1.DelSheet(3, 2);

xlsCreator1.CloseBook(true);


Cell プロパティ

- ExcelCreator .NET -
XlsCrt.Cell プロパティ

出力対象となるセルの範囲をセル位置 (A1 参照形式) / 変数名 / セル名で設定します。

書式

[VB.NET]
  Public Function Cell(ByVal cell As String) As XlsCrt.XlsCell
  Public Function Cell(ByVal cell As String, ByVal cx As Integer, ByVal cy As Integer) As XlsCrt.XlsCell

[C#]
  public XlsCrt.XlsCell Cell(System.String cell , System.Int32 cx , System.Int32 cy)
  public XlsCrt.XlsCell Cell(System.String cell)

設定値

    cell
      対象セルを文字列で設定します。
      セル位置 (A1 参照形式)、変数名、セル名で設定します。
    cx
      cell で設定した対象セルからの範囲を左、または右への移動量を設定します。
    cy
      cell で設定した対象セルからの範囲を上、または下への移動量を設定します。

解説
cell の範囲について
・変数名による指定方法
 Excel ファイル内に変数が記述されている場合、変数名を設定することができます。 変数は、先頭に * (アスタリスク) が 2 つ付加された文字列になります。

【例】Excel ファイルの A1 セルに **No と記述した場合
.Cell("**No")

また、変数名の先頭のアスタリスクの部分に別の文字列を使用したい場合、 KeyWord プロパティを使用することで、変数名のキーワードとなる先頭の * (アスタリスク) を任意の文字列に変更することができます。 先頭キーワード文字列は、Excel で文字として認識可能で、かつ、半角文字のみ 設定することができます。但し、\ ' " , ^ . [] の半角文字は使用できません。
詳しくは KeyWord プロパティを参照してください。

・セル名による指定方法
 Excel ファイル内に特定のセルに名前を設定している場合、名前による指定ができ ます。

【例】ExcelファイルのA1セルに TEL と名前をつけた場合
.Cell("TEL")

・セル位置(A1参照形式)による指定方法
 範囲を表す演算子([:]コロン)、複数の範囲を表す演算子 ([,]カンマ) を含める ことができますが、他のブックやシートを直接参照することはできません。

【例】.Cell("A1")、.Cell("A1:B1")、.Cell("A1:C3")

複数の範囲を設定する場合、カンマで区切って設定することができます。

【例】.Cell("**No, TEL, A1:B1")

範囲指定を行った場合、属性については設定した範囲に対して設定されます。

cx, cy について
指定されたセル範囲に対してオフセットを設定することができます。 オフセットを使用することによって、プログラム中にてセルを移動する際、 A1,A2,A3...と指定せずに、cx, cy にて指定されたセル範囲に対して + / -1 ～ n 移動したセルに設定することができます。 Excel の制限を無視した設定を行うとエラーが発生します。
【例】Excelファイルの A1 セルに **No と記述している場合に F5 セルに設定
.Cell("**No", 5, 4)

参照
[SheetNo プロパティ] | [KeyWord プロパティ]
[Pos プロパティ]


Cell/Pos.Attr.BackColor プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Attr.BackColor プロパティ

背景色を設定します。

書式

[VB.NET]
  Public WriteOnly Property BackColor() As XlsCrt.xlColor

[C#]
  public XlsCrt.xlColor BackColor [set]

設定値

    xlColor
      セルの背景色を示す xlColor 列挙体のメンバ、または、色を示す定数で設定します。

      定数         内容
      xcDefault    自動(デフォルト値)
      xcBlack      黒
      xcWhite      白
      xcRed        赤
      xcGreen      明るい緑
      xcBlue       青
      xcYellow     黄色
      xcPink       ピンク
      xcCyan       水色

コーディング例

セルの背景色を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'指定セル (B2 ～ D3 列目) に、パターン、色を設定します
XlsCreator1.Cell("B2:D3").Attr.BackColor = XlsCrt.xlColor.xcBlue 'セルの背景色：青色

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//指定セル (B2 ～ D3 列目) に、パターン、色を設定します
xlsCreator1.Cell("B2:D3").Attr.BackColor = XlsCrt.xlColor.xcBlue; //セルの背景色：青色

xlsCreator1.CloseBook(true);


Box メソッド

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Attr.Box メソッド

設定したセル領域を囲む Box 罫線を設定します。

書式

[VB.NET]
  Public Sub Box(ByVal nType As XlsCrt.xlBoxType, ByVal nStyle As XlsCrt.xlLineStyle)

[C#]
  public void Box(XlsCrt.xlBoxType nType , XlsCrt.xlLineStyle nStyle)

設定値

    nType
      xlBoxType 列挙体のメンバで設定します。

      定数       値       内容
      btBox       0       箱線 (デフォルト値)
      btLtc       1       格子線
      btOver      2       上横線
      btUnder     3       下横線
      btLeft      4       左縦線
      btRight     5       右縦線

    nStyle
      xlLineStyle 列挙体のメンバで設定します。

      定数          内容
      lsDefault     デフォルト値
      lsNone        罫線なし
      lsNormal      実線
      lsThick       太線
      lsBroken      破線
      lsDot         点線
      lsThick2      極太線
      lsDouble      二重線
      lsSlender     細実線
      lsMidBroken   中破線
      lsSlnChain1   細一点鎖線
      lsMidChain1   中一点鎖線
      lsSlnChain2   細二点鎖線
      lsMidChain2   中二点鎖線
      lsMidChains   中一点斜鎖線

    nStyle に色を設定する場合の設定値は、「補足」-「色を示す定数」を参照してください。

参照
[Cell プロパティ] | [Pos プロパティ]
色を示す定数
C# .NET で引数に 2 つ以上の列挙体のメンバを設定する方法

コーディング例

セルの領域を囲む Box 罫線を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'セル A10 から C20 に Box 罫線の書き込みをします
XlsCreator1.Cell("A20:C25").Attr.Box(XlsCrt.xlBoxType.btBox, XlsCrt.xlLineStyle.lsThick2)   '極太線

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//セル A10 から C20 に Box 罫線の書き込みをします
xlsCreator1.Cell("A20:C25").Attr.Box(XlsCrt.xlBoxType.btBox, XlsCrt.xlLineStyle.lsThick2);   //極太線

xlsCreator1.CloseBook(true);


Cell/Pos.Attr.Fit プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Attr.Fit プロパティ

「縮小して全体を表示する」を設定します。

書式

[VB.NET]
  Public WriteOnly Property Fit() As Boolean

[C#]
  public bool Fit [set]

設定値

      値        内容
      True      縮小して全体を表示する。
      False     縮小して全体を表示しない。(デフォルト値)

解説
「縮小して全体を表示する」を設定した場合、自動的にフォントサイズは変更され ますが、FontPoint プロパティで設定したフォントサイズは変更されません。

コーディング例

セルの表示配置を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)
XlsCreator1.Cell("D7").Str = "abcde"

'指定セル内の文字列の水平位置を設定します
XlsCreator1.Cell("D7:E8").Attr.PosHorz = XlsCrt.xlPosHorz.phCenter   '中央揃え
'セルD7内の文字列の垂直位置を設定します
XlsCreator1.Cell("D7").Attr.PosVert = XlsCrt.xlPosVert.pvCenter      '中央揃え
'セルD7内の文字列の回転角度を設定します
XlsCreator1.Cell("D7").Attr.PosTurn = XlsCrt.xlPosTurn.ptTurn90      '時計回りに 90 度回転
'セルD8内の列幅をこえる文字列を列幅で折り返して表示します
XlsCreator1.Cell("D8").Str = "abcdefghijklmnopqrstuvwxyz"
XlsCreator1.Cell("D8").Attr.OverReturn = True
'セルD9内の文字を縮小して全体を表示します
XlsCreator1.Cell("D9").Str = "ABCDEFGHIJKLMNO"
XlsCreator1.Cell("D9").Attr.Fit = True
'セルの結合を行います
XlsCreator1.Cell("A10:D10").Attr.Joint = True        '参照セルは A10 となります

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);
xlsCreator1.Cell("D7").Str = "abcde";

//指定セル内の文字列の水平位置を設定します
xlsCreator1.Cell("D7:E8").Attr.PosHorz = XlsCrt.xlPosHorz.phCenter;   //中央揃え
//セルD7内の文字列の垂直位置を設定します
xlsCreator1.Cell("D7").Attr.PosVert = XlsCrt.xlPosVert.pvCenter;      //中央揃え
//セルD7内の文字列の回転角度を設定します
xlsCreator1.Cell("D7").Attr.PosTurn = XlsCrt.xlPosTurn.ptTurn90;      //時計回りに 90 度回転
//セルD8内の列幅をこえる文字列を列幅で折り返して表示します
xlsCreator1.Cell("D8").Str = "abcdefghijklmnopqrstuvwxyz";
xlsCreator1.Cell("D8").Attr.OverReturn = true;
//セルD9内の文字を縮小して全体を表示します
xlsCreator1.Cell("D9").Str = "ABCDEFGHIJKLMNO";
xlsCreator1.Cell("D9").Attr.Fit = true;
//セルの結合を行います
//参照セルは A10 となります
xlsCreator1.Cell("A10:D10").Attr.Joint = true;

xlsCreator1.CloseBook(true);


Cell/Pos.Attr.FontColor プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Attr.FontColor プロパティ

フォント色を設定します。

書式

[VB.NET]
  Public WriteOnly Property FontColor() As XlsCrt.xlColor

[C#]
  public XlsCrt.xlColor FontColor [set]

設定値

    xlColor
      フォントの色を示す xlColor 列挙体のメンバ、または、色を示す定数で設定します。

      定数         内容
      xcDefault    自動 (デフォルト値)
      xcBlack      黒
      xcWhite      白
      xcRed        赤
      xcGreen      明るい緑
      xcBlue       青
      xcYellow     黄色
      xcPink       ピンク
      xcCyan       水色

コーディング例

セルのフォント情報を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'セル範囲を設定してフォントの属性を設定し、文字列 "abcde" を書き込みます
XlsCreator1.Cell("A2:B5").Attr.FontName = "ＭＳ Ｐゴシック"  'フォントをＭＳ Ｐゴシック で設定します
XlsCreator1.Cell("A2:B5").Attr.FontPoint = 20                'フォントサイズを 20 ポイントで設定します
XlsCreator1.Cell("A2:B5").Attr.FontColor = XlsCrt.xlColor.xcYellow        'フォントの色を黄色で設定します
XlsCreator1.Cell("A2:B5").Attr.FontStyle = XlsCrt.xlFontStyle.xsItalic    'フォントスタイルを斜線で設定します
XlsCreator1.Cell("A2:B5").Attr.FontULine = XlsCrt.xlFontULine.fuDouble    'フォントの下線スタイルを二重下線で設定します
XlsCreator1.Cell("A2:B5").Str = "abcde"

'セルのフォントを設定します
XlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック"     'ＭＳ Ｐゴシック
'セルのフォントサイズを設定します
XlsCreator1.Cell("A1").Attr.FontPoint = 20                   '12 ポイント
'セルのフォントの色を設定します
XlsCreator1.Cell("A1").Attr.FontColor = XlsCrt.xlColor.xcRed         '赤色
'セルのフォントスタイルを設定します
XlsCreator1.Cell("A1").Attr.FontStyle = XlsCrt.xlFontStyle.xsBold    'ボールド(太字)
'セルのフォントの下線スタイルを設定します
XlsCreator1.Cell("A1").Attr.FontULine = XlsCrt.xlFontULine.fuDouble  '二重下線

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//セル範囲を設定してフォントの属性を設定し、文字列 "abcde" を書き込みます
xlsCreator1.Cell("A2:B5").Attr.FontName = "ＭＳ Ｐゴシック";    //フォントをＭＳ Ｐゴシック で設定します
xlsCreator1.Cell("A2:B5").Attr.FontPoint = 20;                  //フォントサイズを 20 ポイントで設定します
xlsCreator1.Cell("A2:B5").Attr.FontColor = XlsCrt.xlColor.xcYellow;      //フォントの色を黄色で設定します
xlsCreator1.Cell("A2:B5").Attr.FontStyle = XlsCrt.xlFontStyle.xsItalic;  //フォントスタイルを斜線で設定します
xlsCreator1.Cell("A2:B5").Attr.FontULine = XlsCrt.xlFontULine.fuDouble;  //フォントの下線スタイルを二重下線で設定します
xlsCreator1.Cell("A2:B5").Str = "abcde";

//セルのフォントを設定します
xlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック";       //ＭＳ Ｐゴシック
//セルのフォントサイズを設定します
xlsCreator1.Cell("A1").Attr.FontPoint = 20;                     //12 ポイント
//セルのフォントの色を設定します
xlsCreator1.Cell("A1").Attr.FontColor = XlsCrt.xlColor.xcRed;           //赤色
//セルのフォントスタイルを設定します
xlsCreator1.Cell("A1").Attr.FontStyle = XlsCrt.xlFontStyle.xsBold;      //ボールド(太字)
//セルのフォントの下線スタイルを設定します
xlsCreator1.Cell("A1").Attr.FontULine = XlsCrt.xlFontULine.fuDouble;    //二重下線

xlsCreator1.CloseBook(true);


Cell/Pos.Attr.FontName プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Attr.FontName プロパティ

フォント名を設定します。

書式

[VB.NET]
  Public WriteOnly Property FontName() As String

[C#]
  public string FontName [set]

コーディング例

セルのフォント情報を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'セル範囲を設定してフォントの属性を設定し、文字列 "abcde" を書き込みます
XlsCreator1.Cell("A2:B5").Attr.FontName = "ＭＳ Ｐゴシック"  'フォントをＭＳ Ｐゴシック で設定します
XlsCreator1.Cell("A2:B5").Attr.FontPoint = 20                'フォントサイズを 20 ポイントで設定します
XlsCreator1.Cell("A2:B5").Attr.FontColor = XlsCrt.xlColor.xcYellow        'フォントの色を黄色で設定します
XlsCreator1.Cell("A2:B5").Attr.FontStyle = XlsCrt.xlFontStyle.xsItalic    'フォントスタイルを斜線で設定します
XlsCreator1.Cell("A2:B5").Attr.FontULine = XlsCrt.xlFontULine.fuDouble    'フォントの下線スタイルを二重下線で設定します
XlsCreator1.Cell("A2:B5").Str = "abcde"

'セルのフォントを設定します
XlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック"     'ＭＳ Ｐゴシック
'セルのフォントサイズを設定します
XlsCreator1.Cell("A1").Attr.FontPoint = 12                   '12 ポイント
'セルのフォントの色を設定します
XlsCreator1.Cell("A1").Attr.FontColor = XlsCrt.xlColor.xcRed         '赤色
'セルのフォントスタイルを設定します
XlsCreator1.Cell("A1").Attr.FontStyle = XlsCrt.xlFontStyle.xsBold    'ボールド(太字)
'セルのフォントの下線スタイルを設定します
XlsCreator1.Cell("A1").Attr.FontULine = XlsCrt.xlFontULine.fuDouble  '二重下線

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//セル範囲を設定してフォントの属性を設定し、文字列 "abcde" を書き込みます
xlsCreator1.Cell("A2:B5").Attr.FontName = "ＭＳ Ｐゴシック";    //フォントをＭＳ Ｐゴシック で設定します
xlsCreator1.Cell("A2:B5").Attr.FontPoint = 20;                  //フォントサイズを 20 ポイントで設定します
xlsCreator1.Cell("A2:B5").Attr.FontColor = XlsCrt.xlColor.xcYellow;      //フォントの色を黄色で設定します
xlsCreator1.Cell("A2:B5").Attr.FontStyle = XlsCrt.xlFontStyle.xsItalic;  //フォントスタイルを斜線で設定します
xlsCreator1.Cell("A2:B5").Attr.FontULine = XlsCrt.xlFontULine.fuDouble;  //フォントの下線スタイルを二重下線で設定します
xlsCreator1.Cell("A2:B5").Str = "abcde";

//セルのフォントを設定します
xlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック";       //ＭＳ Ｐゴシック
//セルのフォントサイズを設定します
xlsCreator1.Cell("A1").Attr.FontPoint = 12;                     //12 ポイント
//セルのフォントの色を設定します
xlsCreator1.Cell("A1").Attr.FontColor = XlsCrt.xlColor.xcRed;           //赤色
//セルのフォントスタイルを設定します
xlsCreator1.Cell("A1").Attr.FontStyle = XlsCrt.xlFontStyle.xsBold;      //ボールド(太字)
//セルのフォントの下線スタイルを設定します
xlsCreator1.Cell("A1").Attr.FontULine = XlsCrt.xlFontULine.fuDouble;    //二重下線

xlsCreator1.CloseBook(true);


Cell/Pos.Attr.FontPoint プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Attr.FontPoint プロパティ

フォントサイズを設定します。

書式

[VB.NET]
  Public WriteOnly Property FontPoint() As Double

[C#]
  public double FontPoint [set]

設定値

    フォントサイズを示すポイント (1 ～ 409 ポイント) を設定します。

コーディング例

セルのフォント情報を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'セル範囲を設定してフォントの属性を設定し、文字列 "abcde" を書き込みます
XlsCreator1.Cell("A2:B5").Attr.FontName = "ＭＳ Ｐゴシック"  'フォントをＭＳ Ｐゴシック で設定します
XlsCreator1.Cell("A2:B5").Attr.FontPoint = 20                'フォントサイズを 20 ポイントで設定します
XlsCreator1.Cell("A2:B5").Attr.FontColor = XlsCrt.xlColor.xcYellow        'フォントの色を黄色で設定します
XlsCreator1.Cell("A2:B5").Attr.FontStyle = XlsCrt.xlFontStyle.xsItalic    'フォントスタイルを斜線で設定します
XlsCreator1.Cell("A2:B5").Attr.FontULine = XlsCrt.xlFontULine.fuDouble    'フォントの下線スタイルを二重下線で設定します
XlsCreator1.Cell("A2:B5").Str = "abcde"

'セルのフォントを設定します
XlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック"     'ＭＳ Ｐゴシック
'セルのフォントサイズを設定します
XlsCreator1.Cell("A1").Attr.FontPoint = 12                   '12 ポイント
'セルのフォントの色を設定します
XlsCreator1.Cell("A1").Attr.FontColor = XlsCrt.xlColor.xcRed         '赤色
'セルのフォントスタイルを設定します
XlsCreator1.Cell("A1").Attr.FontStyle = XlsCrt.xlFontStyle.xsBold    'ボールド(太字)
'セルのフォントの下線スタイルを設定します
XlsCreator1.Cell("A1").Attr.FontULine = XlsCrt.xlFontULine.fuDouble  '二重下線

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//セル範囲を設定してフォントの属性を設定し、文字列 "abcde" を書き込みます
xlsCreator1.Cell("A2:B5").Attr.FontName = "ＭＳ Ｐゴシック";    //フォントをＭＳ Ｐゴシック で設定します
xlsCreator1.Cell("A2:B5").Attr.FontPoint = 20;                  //フォントサイズを 20 ポイントで設定します
xlsCreator1.Cell("A2:B5").Attr.FontColor = XlsCrt.xlColor.xcYellow;      //フォントの色を黄色で設定します
xlsCreator1.Cell("A2:B5").Attr.FontStyle = XlsCrt.xlFontStyle.xsItalic;  //フォントスタイルを斜線で設定します
xlsCreator1.Cell("A2:B5").Attr.FontULine = XlsCrt.xlFontULine.fuDouble;  //フォントの下線スタイルを二重下線で設定します
xlsCreator1.Cell("A2:B5").Str = "abcde";

//セルのフォントを設定します
xlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック";       //ＭＳ Ｐゴシック
//セルのフォントサイズを設定します
xlsCreator1.Cell("A1").Attr.FontPoint = 12;                     //12 ポイント
//セルのフォントの色を設定します
xlsCreator1.Cell("A1").Attr.FontColor = XlsCrt.xlColor.xcRed;           //赤色
//セルのフォントスタイルを設定します
xlsCreator1.Cell("A1").Attr.FontStyle = XlsCrt.xlFontStyle.xsBold;      //ボールド(太字)
//セルのフォントの下線スタイルを設定します
xlsCreator1.Cell("A1").Attr.FontULine = XlsCrt.xlFontULine.fuDouble;    //二重下線

xlsCreator1.CloseBook(true);


Cell/Pos.Attr.FontStyle プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Attr.FontStyle プロパティ

フォントスタイルを設定します。

書式

[VB.NET]
  Public WriteOnly Property FontStyle() As XlsCrt.xlFontStyle

[C#]
  public XlsCrt.xlFontStyle FontStyle [set]

設定値

    xlFontStyle
      xlFontStyle 列挙体のメンバで設定します。

      スタイル
        定数                内容
        xsNormal            標準(デフォルト値)
        xsBold              太字
        xsItalic            斜体
        xsBold + xsItalic   太字 + 斜体

      文字飾り１
        定数                内容
        xsStrike            取消し線

      文字飾り２
        定数                内容
        xsUp                上付き
        xsDown              下付き

コーディング例

セルのフォント情報を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'セル範囲を設定してフォントの属性を設定し、文字列 "abcde" を書き込みます
XlsCreator1.Cell("A2:B5").Attr.FontName = "ＭＳ Ｐゴシック"  'フォントをＭＳ Ｐゴシック で設定します
XlsCreator1.Cell("A2:B5").Attr.FontPoint = 20                'フォントサイズを 20 ポイントで設定します
XlsCreator1.Cell("A2:B5").Attr.FontColor = XlsCrt.xlColor.xcYellow        'フォントの色を黄色で設定します
XlsCreator1.Cell("A2:B5").Attr.FontStyle = XlsCrt.xlFontStyle.xsItalic    'フォントスタイルを斜線で設定します
XlsCreator1.Cell("A2:B5").Attr.FontULine = XlsCrt.xlFontULine.fuDouble    'フォントの下線スタイルを二重下線で設定します
XlsCreator1.Cell("A2:B5").Str = "abcde"

'セルのフォントを設定します
XlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック"     'ＭＳ Ｐゴシック
'セルのフォントサイズを設定します
XlsCreator1.Cell("A1").Attr.FontPoint = 12                   '12 ポイント
'セルのフォントの色を設定します
XlsCreator1.Cell("A1").Attr.FontColor = XlsCrt.xlColor.xcRed         '赤色
'セルのフォントスタイルを設定します
XlsCreator1.Cell("A1").Attr.FontStyle = XlsCrt.xlFontStyle.xsBold    'ボールド(太字)
'セルのフォントの下線スタイルを設定します
XlsCreator1.Cell("A1").Attr.FontULine = XlsCrt.xlFontULine.fuDouble  '二重下線

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//セル範囲を設定してフォントの属性を設定し、文字列 "abcde" を書き込みます
xlsCreator1.Cell("A2:B5").Attr.FontName = "ＭＳ Ｐゴシック";    //フォントをＭＳ Ｐゴシック で設定します
xlsCreator1.Cell("A2:B5").Attr.FontPoint = 20;                  //フォントサイズを 20 ポイントで設定します
xlsCreator1.Cell("A2:B5").Attr.FontColor = XlsCrt.xlColor.xcYellow;      //フォントの色を黄色で設定します
xlsCreator1.Cell("A2:B5").Attr.FontStyle = XlsCrt.xlFontStyle.xsItalic;  //フォントスタイルを斜線で設定します
xlsCreator1.Cell("A2:B5").Attr.FontULine = XlsCrt.xlFontULine.fuDouble;  //フォントの下線スタイルを二重下線で設定します
xlsCreator1.Cell("A2:B5").Str = "abcde";

//セルのフォントを設定します
xlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック";       //ＭＳ Ｐゴシック
//セルのフォントサイズを設定します
xlsCreator1.Cell("A1").Attr.FontPoint = 12;                     //12 ポイント
//セルのフォントの色を設定します
xlsCreator1.Cell("A1").Attr.FontColor = XlsCrt.xlColor.xcRed;           //赤色
//セルのフォントスタイルを設定します
xlsCreator1.Cell("A1").Attr.FontStyle = XlsCrt.xlFontStyle.xsBold;      //ボールド(太字)
//セルのフォントの下線スタイルを設定します
xlsCreator1.Cell("A1").Attr.FontULine = XlsCrt.xlFontULine.fuDouble;    //二重下線

xlsCreator1.CloseBook(true);


Cell/Pos.Attr.FontULine プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Attr.FontULine プロパティ

フォントの下線スタイルを設定します。

書式

[VB.NET]
  Public WriteOnly Property FontULine() As XlsCrt.xlFontULine

[C#]
  public XlsCrt.xlFontULine FontULine [set]

設定値

    xlFontULine
      フォントの下線スタイルを示す xlFontULine 列挙体のメンバで設定します。

      スタイル
        定数         内容
        fuDefault    デフォルト値
        fuNone       下線なし
        fuNormal     一重下線
        fuDouble     二重下線

コーディング例

セルのフォント情報を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'セル範囲を設定してフォントの属性を設定し、文字列 "abcde" を書き込みます
XlsCreator1.Cell("A2:B5").Attr.FontName = "ＭＳ Ｐゴシック"  'フォントをＭＳ Ｐゴシック で設定します
XlsCreator1.Cell("A2:B5").Attr.FontPoint = 20                'フォントサイズを 20 ポイントで設定します
XlsCreator1.Cell("A2:B5").Attr.FontColor = XlsCrt.xlColor.xcYellow        'フォントの色を黄色で設定します
XlsCreator1.Cell("A2:B5").Attr.FontStyle = XlsCrt.xlFontStyle.xsItalic    'フォントスタイルを斜線で設定します
XlsCreator1.Cell("A2:B5").Attr.FontULine = XlsCrt.xlFontULine.fuDouble    'フォントの下線スタイルを二重下線で設定します
XlsCreator1.Cell("A2:B5").Str = "abcde"

'セルのフォントを設定します
XlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック"     'ＭＳ Ｐゴシック
'セルのフォントサイズを設定します
XlsCreator1.Cell("A1").Attr.FontPoint = 12                   '12 ポイント
'セルのフォントの色を設定します
XlsCreator1.Cell("A1").Attr.FontColor = XlsCrt.xlColor.xcRed         '赤色
'セルのフォントスタイルを設定します
XlsCreator1.Cell("A1").Attr.FontStyle = XlsCrt.xlFontStyle.xsBold    'ボールド(太字)
'セルのフォントの下線スタイルを設定します
XlsCreator1.Cell("A1").Attr.FontULine = XlsCrt.xlFontULine.fuDouble  '二重下線

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//セル範囲を設定してフォントの属性を設定し、文字列 "abcde" を書き込みます
xlsCreator1.Cell("A2:B5").Attr.FontName = "ＭＳ Ｐゴシック";    //フォントをＭＳ Ｐゴシック で設定します
xlsCreator1.Cell("A2:B5").Attr.FontPoint = 20;                  //フォントサイズを 20 ポイントで設定します
xlsCreator1.Cell("A2:B5").Attr.FontColor = XlsCrt.xlColor.xcYellow;      //フォントの色を黄色で設定します
xlsCreator1.Cell("A2:B5").Attr.FontStyle = XlsCrt.xlFontStyle.xsItalic;  //フォントスタイルを斜線で設定します
xlsCreator1.Cell("A2:B5").Attr.FontULine = XlsCrt.xlFontULine.fuDouble;  //フォントの下線スタイルを二重下線で設定します
xlsCreator1.Cell("A2:B5").Str = "abcde";

//セルのフォントを設定します
xlsCreator1.Cell("A1").Attr.FontName = "ＭＳ Ｐゴシック";       //ＭＳ Ｐゴシック
//セルのフォントサイズを設定します
xlsCreator1.Cell("A1").Attr.FontPoint = 12;                     //12 ポイント
//セルのフォントの色を設定します
xlsCreator1.Cell("A1").Attr.FontColor = XlsCrt.xlColor.xcRed;           //赤色
//セルのフォントスタイルを設定します
xlsCreator1.Cell("A1").Attr.FontStyle = XlsCrt.xlFontStyle.xsBold;      //ボールド(太字)
//セルのフォントの下線スタイルを設定します
xlsCreator1.Cell("A1").Attr.FontULine = XlsCrt.xlFontULine.fuDouble;    //二重下線

xlsCreator1.CloseBook(true);


Cell/Pos.Attr.Format プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Attr.Format プロパティ

表示形式を設定します。

書式

[VB.NET]
  Public WriteOnly Property Format() As String

[C#]
  public string Format [set]

設定値

    以下の表示形式の記号に対応しています。

      記号           意味

      #                  有効桁数のみ表示します。(ゼロは表示しません)
      0(ゼロ)            数値の桁数が設定したゼロの数よりも少ない場合、ゼロが余分に表示されます。
      ?                  数値を小数点位置で揃えたり、分数であらわす場合に除算記号で揃えるように表示します。
      ,(カンマ)         1000 単位の区切り記号として表示したり、数値を 1000 で割って四捨五入して表示します。
      %                  数値に 100 を掛けてパーセント文字を追加して表示します。
      @                  文字列として表示します。
      _(アンダーバー)    文字幅分の間隔を空けて表示します。
      *(アスタリスク)    設定した文字をセル幅に達するまで繰り返し表示します。
                         * に続けて繰り返し表示する記号を設定します。
      [色]               表示形式で色を設定するのに角カッコ([])で色を囲んで設定します。
                         色コードは、書式部分の先頭に設定する必要があります。
                         色には、黒、青、水、緑、紫、赤、白、黄を設定することができます。
      yy                 (年)00 ～ 99
      yyy                (年)1900 ～ 9999
      m                  (月)1 ～ 12
      mm                 (月)01 ～ 12
      mmm                (月)Jan ～ Dec
      mmmm               (月)January ～ December
      mmmmm              (月)J ～ D (月の頭文字)）
      d                  (日)1 ～ 31
      dd                 (日)01 ～ 31
      ddd                (日)Sun ～ Sat
      dddd               (日)Sunday ～ Saturday
      h                  (時)0 ～ 23
      hh                 (時)00 ～ 23
      m                  (分)0 ～ 59
      mm                 (分)00 ～ 59
      s                  (秒)0 ～ 59
      ss                 (秒)00 ～ 59
      h AM/PM            (時)0 ～ 23 AM/PM (AM,PM は時間によりかわる)
      h:m:s am/pm        (時)0 ～ 23: (分) 0～59: (秒) 0～59 am/pm

コーディング例

セルに表示形式を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003)

XlsCreator1.Cell("A1").Attr.Format = "[色5]#.#"         '色を付けて表示
XlsCreator1.Cell("A1").Long = 100
XlsCreator1.Cell("A2").Attr.Format = "###,###,###,###"  'カンマ区切り
XlsCreator1.Cell("A2").Long = 1000000000
XlsCreator1.Cell("A3").Attr.Format = "\""\\\""000.00"   '\マークを付ける
XlsCreator1.Cell("A3").Long = 1000000
XlsCreator1.Cell("A4").Attr.Format = ";[赤]-0.0"        '値がマイナスの時に赤色にする
XlsCreator1.Cell("A4").Long = -123456
XlsCreator1.Cell("A5").Attr.Format = ";;""ZERO"""       '値が 0 の時に、ZERO と表示する
XlsCreator1.Cell("A5").Long = 0

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, ExcelCreator.xlVersion.ver2003);

//各指定セルの表示書式を設定します
xlsCreator1.Cell("A1").Attr.Format = "[色5]#.#";         //色を付けて表示
xlsCreator1.Cell("A1").Long = 100;
xlsCreator1.Cell("A2").Attr.Format = "###,###,###,###";  //カンマ区切り
xlsCreator1.Cell("A2").Long = 1000000000;
xlsCreator1.Cell("A3").Attr.Format = "\\000.00";         //\\マークを付ける
xlsCreator1.Cell("A3").Long = 1000000;
xlsCreator1.Cell("A4").Attr.Format = ";[赤]-0.0";        //値がマイナスの時に赤色にする
xlsCreator1.Cell("A4").Long = -123456;
xlsCreator1.Cell("A5").Attr.Format = ";;\\ZERO\\";       //値が 0 の時に ZERO と表示する
xlsCreator1.Cell("A5").Long = 0;

xlsCreator1.CloseBook(true);


Cell/Pos.Attr.Joint プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Attr.Joint プロパティ

指定範囲のセルに「セルを結合する」を設定します。

書式

[VB.NET]
  Public WriteOnly Property Joint() As Boolean

[C#]
  public bool Joint [set]

設定値

      値        内容
      True      セルを結合する。
      False     セルを結合しない。(デフォルト値)

解説
結合したセルに書式の属性やデータの設定を行うには、結合セル全体を設定してください。
例：
Cell("A1:C2").Attr.Joint = True Cell("A1:C2").Attr.FontName = "MS 明朝"

コーディング例

セルの表示配置を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)
XlsCreator1.Cell("D7").Str = "abcde"

'指定セル内の文字列の水平位置を設定します
XlsCreator1.Cell("D7:E8").Attr.PosHorz = XlsCrt.xlPosHorz.phCenter   '中央揃え
'セルD7内の文字列の垂直位置を設定します
XlsCreator1.Cell("D7").Attr.PosVert = XlsCrt.xlPosVert.pvCenter      '中央揃え
'セルD7内の文字列の回転角度を設定します
XlsCreator1.Cell("D7").Attr.PosTurn = XlsCrt.xlPosTurn.ptTurn90      '時計回りに 90 度回転
'セルD8内の列幅をこえる文字列を列幅で折り返して表示します
XlsCreator1.Cell("D8").Str = "abcdefghijklmnopqrstuvwxyz"
XlsCreator1.Cell("D8").Attr.OverReturn = True
'セルD9内の文字を縮小して全体を表示します
XlsCreator1.Cell("D9").Str = "ABCDEFGHIJKLMNO"
XlsCreator1.Cell("D9").Attr.Fit = True
'セルの結合を行います
XlsCreator1.Cell("A10:D10").Attr.Joint = True        '参照セルは A10 となります

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);
xlsCreator1.Cell("D7").Str = "abcde";

//指定セル内の文字列の水平位置を設定します
xlsCreator1.Cell("D7:E8").Attr.PosHorz = XlsCrt.xlPosHorz.phCenter;   //中央揃え
//セルD7内の文字列の垂直位置を設定します
xlsCreator1.Cell("D7").Attr.PosVert = XlsCrt.xlPosVert.pvCenter;      //中央揃え
//セルD7内の文字列の回転角度を設定します
xlsCreator1.Cell("D7").Attr.PosTurn = XlsCrt.xlPosTurn.ptTurn90;      //時計回りに 90 度回転
//セルD8内の列幅をこえる文字列を列幅で折り返して表示します
xlsCreator1.Cell("D8").Str = "abcdefghijklmnopqrstuvwxyz";
xlsCreator1.Cell("D8").Attr.OverReturn = true;
//セルD9内の文字を縮小して全体を表示します
xlsCreator1.Cell("D9").Str = "ABCDEFGHIJKLMNO";
xlsCreator1.Cell("D9").Attr.Fit = true;
//セルの結合を行います
//参照セルは A10 となります
xlsCreator1.Cell("A10:D10").Attr.Joint = true;

xlsCreator1.CloseBook(true);

注意事項
・オーバーレイ元ファイルで結合されているセルや、プログラム中で結合したセルを解除することはできません。


Cell/Pos.Attr.LineALL

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Attr.LineTop プロパティ
XlsCrt.Cell/Pos.Attr.LineBottom プロパティ
XlsCrt.Cell/Pos.Attr.LineRight プロパティ
XlsCrt.Cell/Pos.Attr.LineLeft プロパティ
XlsCrt.Cell/Pos.Attr.LineRightUp プロパティ
XlsCrt.Cell/Pos.Attr.LineLeftUp プロパティ

上、下、左、右、左上がり斜線、右上がり斜線の各罫線を設定します。

書式

書式
[VB.NET]
  Public WriteOnly Property LineTop() As XlsCrt.xlLineStyle
  Public WriteOnly Property LineBottom() As XlsCrt.xlLineStyle
  Public WriteOnly Property LineLeft() As XlsCrt.xlLineStyle
  Public WriteOnly Property LineRight() As XlsCrt.xlLineStyle
  Public WriteOnly Property LineLeftUp() As XlsCrt.xlLineStyle
  Public WriteOnly Property LineRightUp() As XlsCrt.xlLineStyle

[C#]
  public XlsCrt.xlLineStyle LineTop [set]
  public XlsCrt.xlLineStyle LineBottom [set]
  public XlsCrt.xlLineStyle LineLeft [set]
  public XlsCrt.xlLineStyle LineRight [set]
  public XlsCrt.xlLineStyle LineLeftUp [set]
  public XlsCrt.xlLineStyle LineRightUp [set]

設定値

    xlLineStyle
      xlLineStyle 列挙体のメンバで設定します。

      定数          内容
      lsDefault     デフォルト値
      lsNone        罫線なし
      lsNormal      実線
      lsThick       太線
      lsBroken      破線
      lsDot         点線
      lsThick2      極太線
      lsDouble      二重線
      lsSlender     細実線
      lsMidBroken   中破線
      lsSlnChain1   細一点鎖線
      lsMidChain1   中一点鎖線
      lsSlnChain2   細二点鎖線
      lsMidChain2   中二点鎖線
      lsMidChains   中一点斜鎖線

    色を設定する場合の設定値は、「補足」-「色を示す定数」を参照してください。

参照
C# .NET で引数に 2 つ以上の列挙体のメンバを設定する方法

コーディング例

セルに罫線を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'セルC2からF2に上罫線を設定します
XlsCreator1.Cell("C2:F2").Attr.LineTop = XlsCrt.xlLineStyle.lsNormal     '実線
'セルC5からF5に下罫線を設定します
XlsCreator1.Cell("C5:F5").Attr.LineBottom = XlsCrt.xlLineStyle.lsBroken  '破線
'セルC2からC5に赤色で左罫線を設定します
XlsCreator1.Cell("C2:C5").Attr.LineLeft = XlsCrt.xlLineStyle.lsThick + XlsCrt.xlColor.xcRed  '赤太線
'セルF2からF5に緑色で右罫線を設定します
XlsCreator1.Cell("F2:F5").Attr.LineRight = XlsCrt.xlLineStyle.lsDot + XlsCrt.xlColor.xcGreen '緑点線

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//セルC2からF2に上罫線を設定します
xlsCreator1.Cell("C2:F2").Attr.LineTop = XlsCrt.xlLineStyle.lsNormal;     //実線
//セルC5からF5に下罫線を設定します
xlsCreator1.Cell("C5:F5").Attr.LineBottom = XlsCrt.xlLineStyle.lsBroken;  //破線
//セルC2からC5に赤色で左罫線を設定します
xlsCreator1.Cell("C2:C5").Attr.LineLeft = (XlsCrt.xlLineStyle)((int)XlsCrt.xlLineStyle.lsThick + (int)XlsCrt.xlColor.xcRed);  //赤太線
//セルF2からF5に緑色で右罫線を設定します
xlsCreator1.Cell("F2:F5").Attr.LineRight = (XlsCrt.xlLineStyle)((int)XlsCrt.xlLineStyle.lsDot + (int)XlsCrt.xlColor.xcGreen); //緑点線

xlsCreator1.CloseBook(true);

注意事項
LineLeftUp プロパティ、LineRightUp プロパティを同じセルに設定した場合、 クロスした罫線になりますが、Excel の制限により両方の線種や色を別々に設定 出来ないため、LineRightUp プロパティで設定した線種や色の値が有効になります。


Cell/Pos.Attr.OverReturn プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Attr.OverReturn プロパティ

「折り返して全体を表示」を設定します。

書式

[VB.NET]
  Public WriteOnly Property OverReturn() As Boolean

[C#]
  public bool OverReturn [set]

設定値

      値        内容
      True      「折り返して全体を表示」を設定します。
      False     「折り返して全体を表示」を設定しない。(デフォルト値)

コーディング例

セルの表示配置を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)
XlsCreator1.Cell("D7").Str = "abcde"

'指定セル内の文字列の水平位置を設定します
XlsCreator1.Cell("D7:E8").Attr.PosHorz = XlsCrt.xlPosHorz.phCenter   '中央揃え
'セルD7内の文字列の垂直位置を設定します
XlsCreator1.Cell("D7").Attr.PosVert = XlsCrt.xlPosVert.pvCenter      '中央揃え
'セルD7内の文字列の回転角度を設定します
XlsCreator1.Cell("D7").Attr.PosTurn = XlsCrt.xlPosTurn.ptTurn90      '時計回りに 90 度回転
'セルD8内の列幅をこえる文字列を列幅で折り返して表示します
XlsCreator1.Cell("D8").Str = "abcdefghijklmnopqrstuvwxyz"
XlsCreator1.Cell("D8").Attr.OverReturn = True
'セルD9内の文字を縮小して全体を表示します
XlsCreator1.Cell("D9").Str = "ABCDEFGHIJKLMNO"
XlsCreator1.Cell("D9").Attr.Fit = True
'セルの結合を行います
XlsCreator1.Cell("A10:D10").Attr.Joint = True        '参照セルは A10 となります

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);
xlsCreator1.Cell("D7").Str = "abcde";

//指定セル内の文字列の水平位置を設定します
xlsCreator1.Cell("D7:E8").Attr.PosHorz = XlsCrt.xlPosHorz.phCenter;   //中央揃え
//セルD7内の文字列の垂直位置を設定します
xlsCreator1.Cell("D7").Attr.PosVert = XlsCrt.xlPosVert.pvCenter;      //中央揃え
//セルD7内の文字列の回転角度を設定します
xlsCreator1.Cell("D7").Attr.PosTurn = XlsCrt.xlPosTurn.ptTurn90;      //時計回りに 90 度回転
//セルD8内の列幅をこえる文字列を列幅で折り返して表示します
xlsCreator1.Cell("D8").Str = "abcdefghijklmnopqrstuvwxyz";
xlsCreator1.Cell("D8").Attr.OverReturn = true;
//セルD9内の文字を縮小して全体を表示します
xlsCreator1.Cell("D9").Str = "ABCDEFGHIJKLMNO";
xlsCreator1.Cell("D9").Attr.Fit = true;
//セルの結合を行います
//参照セルは A10 となります
xlsCreator1.Cell("A10:D10").Attr.Joint = true;

xlsCreator1.CloseBook(true);


Cell/Pos.Attr. Pattern プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Attr.Pattern プロパティ

パターンを設定します。

書式

[VB.NET]
  Public WriteOnly Property Pattern() As XlsCrt.xlPattern

[C#]
  public XlsCrt.xlPattern Pattern [set]

設定値

    xlPattern
      xlPattern 列挙体のメンバで設定します。

      定数      内容
      pn01      塗りつぶし(デフォルト値)
      pn02      ５０％灰色
      pn03      ７５％灰色
      pn04      ２５％灰色
      pn05      横縞
      pn06      縦縞
      pn07      右下がり斜線 縞
      pn08      左下がり斜線 縞
      pn09      左下がり斜線 格子
      pn10      極太線 左下がり斜線 格子
      pn11      実線 横縞
      pn12      実線 縦縞
      pn13      実線 右下がり斜線 縞
      pn14      実線 左下がり斜線 縞
      pn15      実線 横 格子
      pn16      実線 左下がり斜線 格子
      pn17      １２.５％灰色
      pn18      ６.２５％灰色

    色を設定する場合の設定値は、「補足」-「色を示す定数」を参照してください。

解説
パターンと色の両方を設定する場合は、「 + 」演算子で結合して設定します。

参照
C# .NET で引数に 2 つ以上の列挙体のメンバを設定する方法

コーディング例

セルのパターンを設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'指定セル(B2 ～ D3 列目)に、パターン、色を設定します
XlsCreator1.Cell("B2:D3").Attr.Pattern = XlsCrt.xlPattern.pn08    'パターン：左下がり斜線 縞
XlsCreator1.Cell("B2:D3").Attr.BackColor = XlsCrt.xlColor.xcBlue  '色：青色

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//指定セル(B2 ～ D3 列目)に、パターン、色を設定します
xlsCreator1.Cell("B2:D3").Attr.Pattern = XlsCrt.xlPattern.pn08;    //パターン：左下がり斜線 縞
xlsCreator1.Cell("B2:D3").Attr.BackColor = XlsCrt.xlColor.xcBlue;  //色：青色

xlsCreator1.CloseBook(true);


Cell/Pos.Attr.PosHorz プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Attr.PosHorz プロパティ

文字の配置 (横位置) を設定します。

書式

[VB.NET]
  Public WriteOnly Property PosHorz() As XlsCrt.xlPosHorz

[C#]
  public XlsCrt.xlPosHorz PosHorz [set]

設定値

    xlPosHorz
      文字の水平位置を示す xlPosHorz 列挙体のメンバで設定します。

      定数          値        内容
                     1～15    左詰めインデント値
      phNormal      20        標準 (デフォルト値)
      phLeft        21        左詰め
      phCenter      22        中央揃え
      phRight       23        右詰め
      phLoop        24        繰り返し
      phBothEven    25        両端揃え
      phSelCenter   26        選択範囲内で中央
      phEven        27        均等割付

解説
C# で左詰めインデントとして直接数値を設定するには、 (XlsCrt.xlPosHorz.xlPosHorz)21 の様にキャストして設定します。

コーディング例

セルの表示配置を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)
XlsCreator1.Cell("D7").Str = "abcde"

'指定セル内の文字列の水平位置を設定します
XlsCreator1.Cell("D7:E8").Attr.PosHorz = XlsCrt.xlPosHorz.phCenter   '中央揃え
'セルD7内の文字列の垂直位置を設定します
XlsCreator1.Cell("D7").Attr.PosVert = XlsCrt.xlPosVert.pvCenter      '中央揃え
'セルD7内の文字列の回転角度を設定します
XlsCreator1.Cell("D7").Attr.PosTurn = XlsCrt.xlPosTurn.ptTurn90      '時計回りに 90 度回転
'セルD8内の列幅をこえる文字列を列幅で折り返して表示します
XlsCreator1.Cell("D8").Str = "abcdefghijklmnopqrstuvwxyz"
XlsCreator1.Cell("D8").Attr.OverReturn = True
'セルD9内の文字を縮小して全体を表示します
XlsCreator1.Cell("D9").Str = "ABCDEFGHIJKLMNO"
XlsCreator1.Cell("D9").Attr.Fit = True
'セルの結合を行います
XlsCreator1.Cell("A10:D10").Attr.Joint = True        '参照セルは A10 となります

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);
xlsCreator1.Cell("D7").Str = "abcde";

//指定セル内の文字列の水平位置を設定します
xlsCreator1.Cell("D7:E8").Attr.PosHorz = XlsCrt.xlPosHorz.phCenter;   //中央揃え
//セルD7内の文字列の垂直位置を設定します
xlsCreator1.Cell("D7").Attr.PosVert = XlsCrt.xlPosVert.pvCenter;      //中央揃え
//セルD7内の文字列の回転角度を設定します
xlsCreator1.Cell("D7").Attr.PosTurn = XlsCrt.xlPosTurn.ptTurn90;      //時計回りに 90 度回転
//セルD8内の列幅をこえる文字列を列幅で折り返して表示します
xlsCreator1.Cell("D8").Str = "abcdefghijklmnopqrstuvwxyz";
xlsCreator1.Cell("D8").Attr.OverReturn = true;
//セルD9内の文字を縮小して全体を表示します
xlsCreator1.Cell("D9").Str = "ABCDEFGHIJKLMNO";
xlsCreator1.Cell("D9").Attr.Fit = true;
//セルの結合を行います
//参照セルは A10 となります
xlsCreator1.Cell("A10:D10").Attr.Joint = true;

xlsCreator1.CloseBook(true);


Cell/Pos.Attr.PosTurn プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Attr.PosTurn プロパティ

文字方向 (角度) を設定します。

書式

[VB.NET]
  Public WriteOnly Property PosTurn() As XlsCrt.xlPosTurn

[C#]
  public XlsCrt.xlPosTurn PosTurn [set]

設定値

    xlPosTurn
      文字列の回転角度を示す xlPosTurn 列挙体のメンバで設定します。

      定数         値          内容
                  -90 ～ 90    設定した角度
      ptHorz      100          横 (デフォルト値)
      ptVert      101          縦
      ptRvTurn90  102          半時計回りに 90 度
      ptTurn90    103          時計回りに 90 度

解説
C# で設定した角度として直接数値を設定するには、(XlsCrt.xlPosTurn.xlPosTurn)90 や (XlsCrt.xlPosTurn.xlPosTurn)(-90) の様にキャストして設定します。

コーディング例

セルの表示配置を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)
XlsCreator1.Cell("D7").Str = "abcde"

'指定セル内の文字列の水平位置を設定します
XlsCreator1.Cell("D7:E8").Attr.PosHorz = XlsCrt.xlPosHorz.phCenter   '中央揃え
'セルD7内の文字列の垂直位置を設定します
XlsCreator1.Cell("D7").Attr.PosVert = XlsCrt.xlPosVert.pvCenter      '中央揃え
'セルD7内の文字列の回転角度を設定します
XlsCreator1.Cell("D7").Attr.PosTurn = XlsCrt.xlPosTurn.ptTurn90      '時計回りに 90 度回転
'セルD8内の列幅をこえる文字列を列幅で折り返して表示します
XlsCreator1.Cell("D8").Str = "abcdefghijklmnopqrstuvwxyz"
XlsCreator1.Cell("D8").Attr.OverReturn = True
'セルD9内の文字を縮小して全体を表示します
XlsCreator1.Cell("D9").Str = "ABCDEFGHIJKLMNO"
XlsCreator1.Cell("D9").Attr.Fit = True
'セルの結合を行います
XlsCreator1.Cell("A10:D10").Attr.Joint = True        '参照セルは A10 となります

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);
xlsCreator1.Cell("D7").Str = "abcde";

//指定セル内の文字列の水平位置を設定します
xlsCreator1.Cell("D7:E8").Attr.PosHorz = XlsCrt.xlPosHorz.phCenter;   //中央揃え
//セルD7内の文字列の垂直位置を設定します
xlsCreator1.Cell("D7").Attr.PosVert = XlsCrt.xlPosVert.pvCenter;      //中央揃え
//セルD7内の文字列の回転角度を設定します
xlsCreator1.Cell("D7").Attr.PosTurn = XlsCrt.xlPosTurn.ptTurn90;      //時計回りに 90 度回転
//セルD8内の列幅をこえる文字列を列幅で折り返して表示します
xlsCreator1.Cell("D8").Str = "abcdefghijklmnopqrstuvwxyz";
xlsCreator1.Cell("D8").Attr.OverReturn = true;
//セルD9内の文字を縮小して全体を表示します
xlsCreator1.Cell("D9").Str = "ABCDEFGHIJKLMNO";
xlsCreator1.Cell("D9").Attr.Fit = true;
//セルの結合を行います
//参照セルは A10 となります
xlsCreator1.Cell("A10:D10").Attr.Joint = true;

xlsCreator1.CloseBook(true);


Cell/Pos.Attr.PosVert プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Attr.PosVert プロパティ

文字の配置 (縦位置) を設定します。

書式

[VB.NET]
  Public WriteOnly Property PosVert() As XlsCrt.xlPosVert

[C#]
  public XlsCrt.xlPosVert PosVert [set]

設定値

    xlPosVert
      文字の垂直位置を示す xlPosVert 列挙体のメンバで設定します。

      定数          値    内容
      pvUp           0    上詰め
      pvCenter       1    中央揃え
      pvDown         2    下詰め (デフォルト値)
      pvBothEven     3    両端揃え
      pvEven         4    均等割付

コーディング例

セルの表示配置を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)
XlsCreator1.Cell("D7").Str = "abcde"

'指定セル内の文字列の水平位置を設定します
XlsCreator1.Cell("D7:E8").Attr.PosHorz = XlsCrt.xlPosHorz.phCenter   '中央揃え
'セルD7内の文字列の垂直位置を設定します
XlsCreator1.Cell("D7").Attr.PosVert = XlsCrt.xlPosVert.pvCenter      '中央揃え
'セルD7内の文字列の回転角度を設定します
XlsCreator1.Cell("D7").Attr.PosTurn = XlsCrt.xlPosTurn.ptTurn90      '時計回りに 90 度回転
'セルD8内の列幅をこえる文字列を列幅で折り返して表示します
XlsCreator1.Cell("D8").Str = "abcdefghijklmnopqrstuvwxyz"
XlsCreator1.Cell("D8").Attr.OverReturn = True
'セルD9内の文字を縮小して全体を表示します
XlsCreator1.Cell("D9").Str = "ABCDEFGHIJKLMNO"
XlsCreator1.Cell("D9").Attr.Fit = True
'セルの結合を行います
XlsCreator1.Cell("A10:D10").Attr.Joint = True        '参照セルは A10 となります

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);
xlsCreator1.Cell("D7").Str = "abcde";

//指定セル内の文字列の水平位置を設定します
xlsCreator1.Cell("D7:E8").Attr.PosHorz = XlsCrt.xlPosHorz.phCenter;   //中央揃え
//セルD7内の文字列の垂直位置を設定します
xlsCreator1.Cell("D7").Attr.PosVert = XlsCrt.xlPosVert.pvCenter;      //中央揃え
//セルD7内の文字列の回転角度を設定します
xlsCreator1.Cell("D7").Attr.PosTurn = XlsCrt.xlPosTurn.ptTurn90;      //時計回りに 90 度回転
//セルD8内の列幅をこえる文字列を列幅で折り返して表示します
xlsCreator1.Cell("D8").Str = "abcdefghijklmnopqrstuvwxyz";
xlsCreator1.Cell("D8").Attr.OverReturn = true;
//セルD9内の文字を縮小して全体を表示します
xlsCreator1.Cell("D9").Str = "ABCDEFGHIJKLMNO";
xlsCreator1.Cell("D9").Attr.Fit = true;
//セルの結合を行います
//参照セルは A10 となります
xlsCreator1.Cell("A10:D10").Attr.Joint = true;

xlsCreator1.CloseBook(true);


AttrNo プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.AttrNo プロパティ

設定したセルの属性番号を取得します。

書式

[VB.NET]
  Public ReadOnly Property AttrNo() As Integer

[C#]
  public int AttrNo [get]

設定値

    セルの属性番号を格納する変数を設定します。

解説
Excel ファイルでは各セルの罫線や表示書式などの書式情報を属性番号として保持 しており、AttrNo プロパティで属性番号を取得します。
取得した属性番号は、Long2、Str2、Double2、Value2 の各メソッドで設定したセル へ値や文字列と同時に設定することができます。

参照
[Long2 メソッド] | [Str2 メソッド] | [Double2 メソッド] | [Value2 メソッド]

コーディング例

セルの属性番号を取得し、Long2、Str2、Double2、Value2 の各メソッドで別のセルに属性番号と値を設定します。

[VB.NET]
Dim nAttrNo As Integer

XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)
XlsCreator1.Cell("A1").Str = "属性テスト"
XlsCreator1.Cell("A1").Attr.FontName = "MS 明朝"
XlsCreator1.Cell("A1").Attr.FontPoint = 20                                'フォントサイズを 20 ポイントで設定します
XlsCreator1.Cell("A1").Attr.FontColor = XlsCrt.xlColor.xcYellow     'フォントの色を黄色で設定します
XlsCreator1.Cell("A1").Attr.FontStyle = XlsCrt.xlFontStyle.xsItalic 'フォントスタイルを斜線で設定します
XlsCreator1.Cell("A1").Attr.FontULine = XlsCrt.xlFontULine.fuDouble 'フォントの下線スタイルを二重下線で設定します
XlsCreator1.CloseBook(True)

XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")

'属性番号と値を設定します。
'属性番号取得
nAttrNo = XlsCreator1.Cell("A1").AttrNo
'A1 セルの属性を Long 値とともに B1 セルに設定
XlsCreator1.Cell("B1").Long2(200, nAttrNo)
'A1 セルの属性を Double 値とともに C1 セルに設定
XlsCreator1.Cell("C1").Double2(200.1, nAttrNo)
'A1 セルの属性を Str 値とともに D1 セルに設定
XlsCreator1.Cell("D1").Str2("文字列", nAttrNo)
'A1 セルの属性を value 値とともに E1 セルに設定
XlsCreator1.Cell("E1").Value2("バリアント型", nAttrNo)

XlsCreator1.CloseBook(True)

[C#]
Int32 nAttrNo;

xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);
xlsCreator1.Cell("A1").Str = "属性テスト";
xlsCreator1.Cell("A1").Attr.FontName = "MS 明朝";
xlsCreator1.Cell("A1").Attr.FontPoint = 20;                          //フォントサイズを 20 ポイントで設定します
xlsCreator1.Cell("A1").Attr.FontColor = XlsCrt.xlColor.xcYellow;     //フォントの色を黄色で設定します
xlsCreator1.Cell("A1").Attr.FontStyle = XlsCrt.xlFontStyle.xsItalic; //フォントスタイルを斜線で設定します
xlsCreator1.Cell("A1").Attr.FontULine = XlsCrt.xlFontULine.fuDouble; //フォントの下線スタイルを二重下線で設定します
xlsCreator1.CloseBook(true);

xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");

//属性番号と値を設定します。
//属性番号取得
nAttrNo = xlsCreator1.Cell("A1").AttrNo;
//A1 セルの属性を Long 値とともに B1 セルに設定
xlsCreator1.Cell("B1").Long2(200, nAttrNo);
//A1 セルの属性を Double 値とともに C1 セルに設定
xlsCreator1.Cell("C1").Double2(200.1, nAttrNo);
//A1 セルの属性を Str 値とともに D1 セルに設定
xlsCreator1.Cell("D1").Str2("文字列", nAttrNo);
//A1 セルの属性を value 値とともに E1 セルに設定
xlsCreator1.Cell("E1").Value2("バリアント型", nAttrNo);

xlsCreator1.CloseBook(true);

注意事項
・Cell プロパティに変数名を設定した場合は対応しておりません。


Break プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Break プロパティ

改ページの設定 / 解除を設定します。

書式

[VB.NET]
  Public WriteOnly Property Break() As Boolean

[C#]
  public bool Break [set]

設定値

      値      内容
      True    改ページを設定します
      False   改ページを解除します。

解説
行に対する改ページ、列に対する改ページ、行列に対する改ページを指定できます。
行方向に 1026 個まで、列方向に 256 個まで指定できます。

コーディング例

A35 セルに改ページを設定設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)
XlsCreator1.Cell("A35").Break = True
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);
xlsCreator1.Cell("A35").Break = true;
xlsCreator1.CloseBook(true);


Clear メソッド

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Clear メソッド

セルをクリア (初期化) します。

書式

[VB.NET]
  Public Sub Clear()

[C#]
  public void Clear()

コーディング例

_
セルのクリア (初期化) を行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'セルクリア (初期化) 元を設定
XlsCreator1.Cell("A1:B1").Attr.Pattern = XlsCrt.xlPattern.pn02
'セルの範囲指定でクリア
XlsCreator1.Cell("A1:B1").Clear()  'A1:B1 セルをクリア (初期化) します

'セルクリア (初期化) 元を設定
XlsCreator1.Cell("A3:B3").Attr.Pattern = XlsCrt.xlPattern.pn03
'単一セルのクリア
XlsCreator1.Cell("A3").Clear()     'A3 セルをクリア (初期化) します

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//セルクリア (初期化) 元を設定
xlsCreator1.Cell("A1:B1").Attr.Pattern = XlsCrt.xlPattern.pn02;
//セルの範囲指定でクリア
xlsCreator1.Cell("A1:B1").Clear();  //A1:B1 セルをクリア (初期化) します

//セルクリア (初期化) 元を設定
xlsCreator1.Cell("A3:B3").Attr.Pattern = XlsCrt.xlPattern.pn03;
//単一セルのクリア
xlsCreator1.Cell("A3").Clear();     //A3 セルをクリア (初期化) します

xlsCreator1.CloseBook(true);

注意事項
・Clear メソッドは Cell プロパティに変数名を設定した場合は対応しておりません。


ColWidth プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.ColWidth プロパティ

セルの列幅を設定します。

書式

[VB.NET]
  Public WriteOnly Property ColWidth() As Double

[C#]
  public double ColWidth [set]

解説
指定された範囲の列幅を( 0 ～ 255 文字) の範囲で設定します。
0 を設定した場合は非表示列となります。単位は半角単位の文字数です。

参照
[RowHeight プロパティ]

コーディング例

A ～ G 列の列幅を 20 文字、10 行目の行高を 20 ポイントに設定します

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

XlsCreator1.Cell("A1:G1").ColWidth = 20
XlsCreator1.Cell("G10").RowHeight = 20

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

xlsCreator1.Cell("A1:G1").ColWidth = 20;
xlsCreator1.Cell("G10").RowHeight = 20;

xlsCreator1.CloseBook(true);


Copy メソッド

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Copy メソッド

セルをコピーします。

書式

[VB.NET]
  Public Sub Copy()
  Public Sub Copy(ByVal strCell As String)

[C#]
  public void Copy()
  public void Copy(System.String strCell)

設定値

    strCell
      コピー先のセルを設定します。

解説
コピーするセルは、単一セル、セル範囲指定に対応しています。
引数を省略した場合、セルがメモリ上にコピーされ、Paste メソッドで設定した セルに貼り付けることができます。
Pos プロパティでセル範囲を設定する場合、終了座標≧開始座標と設定してください。

参照
[Paste メソッド]

コーディング例

セルのコピーを行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'セルコピー元を設定
XlsCreator1.Cell("A1:B1").Attr.Pattern = XlsCrt.xlPattern.pn03
XlsCreator1.Cell("A1:B1").Str = "セルコピー元"

'セル範囲コピー
XlsCreator1.Cell("A1:B1").Copy("A2")     'A1:B1 範囲セルを A2 セルにコピー
'単一セルコピー
XlsCreator1.Cell("A1").Copy("C2")        'A1 セルを C2 セルにコピー

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//セルコピー元を設定
xlsCreator1.Cell("A1:B1").Attr.Pattern = XlsCrt.xlPattern.pn03;
xlsCreator1.Cell("A1:B1").Str = "セルコピー元";

//セル範囲コピー
xlsCreator1.Cell("A1:B1").Copy("A2");     //A1:B1 範囲セルを A2 セルにコピー
//単一セルコピー
xlsCreator1.Cell("A1").Copy("C2");        //A1 セルを C2 セルにコピー

xlsCreator1.CloseBook(true);

注意事項
・コピー元セルのセル属性と値のみコピーします。
・Copy メソッドの Cell プロパティに変数名を設定した場合は対応しておりません。
・ブック間、シート間のコピー・貼り付けには対応しておりません。


Double プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Double プロパティ

実数の設定と取得ができます。

書式

[VB.NET]
  Public Property Double() As Double

[C#]
  public double Double [get, set]

設定値

    実数を設定します。

解説
設定したセルに計算式や関数式が設定されている場合は、その結果値を実数で取得する 事ができます。

参照
[Long プロパティ] | [Str プロパティ] | [Value プロパティ] | [Func メソッド]
[Cell プロパティ] | [Pos プロパティ]
セル情報の設定と取得について (Cell プロパティの場合)

コーディング例

指定セル内に値を設定し、作成したファイルの指定セル内の値を取得します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'セルに実数を設定します。
XlsCreator1.Cell("A1").Double = 12.345    'セル A1 には 12.345 が入ります

XlsCreator1.CloseBook(True)

Dim nDouble As Double
XlsCreator1.ReadBook(Application.StartupPath & "\ExcelFile.xls")

'セル内の実数を取得します。
nDouble = XlsCreator1.Cell("A1").Double    'nDouble には 12.345 が入ります

XlsCreator1.CloseBook(True)

[C#]
//指定セル内に値を設定します。
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//セルに実数を設定します。
xlsCreator1.Cell("A1").Double = 12.345;    //セル A1 には 12.345 が入ります

xlsCreator1.CloseBook(true);

//上記で作成したファイルの、指定セル内の値を取得します。
Double nDouble;
xlsCreator1.ReadBook(Application.StartupPath + @"\ExcelFile.xls");

//セル内の実数を取得します。
nDouble = xlsCreator1.Cell("A1").Double;    //nDouble には 12.345 が入ります

xlsCreator1.CloseBook(true);

注意事項
・Cell プロパティに変数名を設定した場合、取得には対応しておりません。


Double2 メソッド

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Double2 メソッド

実数値と属性番号を設定します。

書式

[VB.NET]
  Public Sub Double2(ByVal val As Double, ByVal attr As Integer)

[C#]
  public void Double2(System.Double val , System.Int32 attr)

設定値

    value
      属性番号の値と共に設定する実数値を設定します。
    attrno
      AttrNo プロパティで取得した属性番号の値を設定します。

解説
AttrNo プロパティで取得した属性番号の値と共に実数値を設定します。
Excel ファイルでは、各セルの罫線や表示書式などの書式情報を、属性番号として 内部で記憶しており、AttrNo プロパティでは、設定したセルのその属性番号を 取得します。
Double2 メソッドは、設定したセルへ値と、AttrNo プロパティで取得した属性番号を 同時に設定することができますので、例えば、セルへ設定する値や文字列が同一条件時 には同じ書式情報をコピーすることを、一つのメソッドで実現することができます。

参照
[AttrNo プロパティ] | [Long2 メソッド] | [Str2 メソッド] | [Value2 メソッド]
[Cell プロパティ] | [Pos プロパティ]

コーディング例

設定したセルの属性番号を取得し、
Long2、Str2、Double2、Value2 の各 メソッドで、その属性番号と値を設定します。

[VB.NET]
Dim nAttrNo As Integer

XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)
XlsCreator1.Cell("A1").Str = "属性テスト"
XlsCreator1.Cell("A1").Attr.FontName = "MS 明朝"
XlsCreator1.Cell("A1").Attr.FontPoint = 20                                'フォントサイズを 20 ポイントで設定します
XlsCreator1.Cell("A1").Attr.FontColor = XlsCrt.xlColor.xcYellow     'フォントの色を黄色で設定します
XlsCreator1.Cell("A1").Attr.FontStyle = XlsCrt.xlFontStyle.xsItalic 'フォントスタイルを斜線で設定します
XlsCreator1.Cell("A1").Attr.FontULine = XlsCrt.xlFontULine.fuDouble 'フォントの下線スタイルを二重下線で設定します
XlsCreator1.CloseBook(True)

XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")

'属性番号と値を設定します。
'属性番号取得
nAttrNo = XlsCreator1.Cell("A1").AttrNo
'A1 セルの属性を Long 値とともに B1 セルに設定
XlsCreator1.Cell("B1").Long2(200, nAttrNo)
'A1 セルの属性を Double 値とともに C1 セルに設定
XlsCreator1.Cell("C1").Double2(200.1, nAttrNo)
'A1 セルの属性を Str 値とともに D1 セルに設定
XlsCreator1.Cell("D1").Str2("文字列", nAttrNo)
'A1 セルの属性を value 値とともに E1 セルに設定
XlsCreator1.Cell("E1").Value2("バリアント型", nAttrNo)

XlsCreator1.CloseBook(True)

[C#]
Int32 nAttrNo;

xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);
xlsCreator1.Cell("A1").Str = "属性テスト";
xlsCreator1.Cell("A1").Attr.FontName = "MS 明朝";
xlsCreator1.Cell("A1").Attr.FontPoint = 20;                          //フォントサイズを 20 ポイントで設定します
xlsCreator1.Cell("A1").Attr.FontColor = XlsCrt.xlColor.xcYellow;     //フォントの色を黄色で設定します
xlsCreator1.Cell("A1").Attr.FontStyle = XlsCrt.xlFontStyle.xsItalic; //フォントスタイルを斜線で設定します
xlsCreator1.Cell("A1").Attr.FontULine = XlsCrt.xlFontULine.fuDouble; //フォントの下線スタイルを二重下線で設定します
xlsCreator1.CloseBook(true);

xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");

//属性番号と値を設定します。
//属性番号取得
nAttrNo = xlsCreator1.Cell("A1").AttrNo;
//A1 セルの属性を Long 値とともに B1 セルに設定
xlsCreator1.Cell("B1").Long2(200, nAttrNo);
//A1 セルの属性を Double 値とともに C1 セルに設定
xlsCreator1.Cell("C1").Double2(200.1, nAttrNo);
//A1 セルの属性を Str 値とともに D1 セルに設定
xlsCreator1.Cell("D1").Str2("文字列", nAttrNo);
//A1 セルの属性を value 値とともに E1 セルに設定
xlsCreator1.Cell("E1").Value2("バリアント型", nAttrNo);

xlsCreator1.CloseBook(true);


Func メソッド

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Func メソッド

計算式と計算結果を設定します。

書式

[VB.NET]
  Public Sub Func(ByVal strFunc As String, ByVal objAns As Object)

[C#]
  public void Func(System.String strFunc , System.Object objAns)

設定値

    strFunc
      計算式や関数式を設定します。
    objAns
      strFunc に対する結果値を設定します。

解説
Func メソッドで計算結果をあらかじめ設定することで、ExcelCreator 5.0 for .NET で作成した Excel ファイルを Excel で開き、修正を行わずに終了した時に表示される保存の確認メッセージを非表示にできます。

参照
[Value プロパティ] | [ExcelMode プロパティ]

コーディング例

セルに計算式を設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

XlsCreator1.Cell("A2").Long = 1000                'A2 セルには 1000 が入ります
'セルに関数などの式を設定します。
XlsCreator1.Cell("A4").Func("=A2+999", "")        'A4 セルには =A2+999 が入ります
XlsCreator1.Cell("C1").Func("=A2+999", "1999")    'C1 セルには =A2+999 が入ります

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

xlsCreator1.Cell("A2").Long = 1000;              //A2 セルには 1000 が入ります
//セルに関数などの式を設定します。
xlsCreator1.Cell("A4").Func("=A2+999", null);    //A4 セルには =A2+999 が入ります
xlsCreator1.Cell("C1").Func("=A2+999", "1999");  //C1 セルには =A2+999 が入ります

xlsCreator1.CloseBook(true);


Long プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Long プロパティ

整数の取得、または、設定します。

書式

[VB.NET]
  Public Property Long() As Integer

[C#]
  public int Long [get, set]

設定値

    整数を設定します。

解説
セルに計算式や関数式が設定されている場合は、その結果値を整数で取得することが できます。

参照
[Double プロパティ] | [Str プロパティ] | [Value プロパティ] | [Func メソッド]
[Cell プロパティ] | [Pos プロパティ]
セル情報の設定と取得について (Cell プロパティの場合)

コーディング例

指定セル内に値を設定し、作成したファイルの指定セル内の値を取得します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'セルに整数を設定します。
XlsCreator1.Cell("A2").Long = 1000     'セル A2 には 1000 が入ります

XlsCreator1.CloseBook(True)

Dim nLong As Long

XlsCreator1.ReadBook(Application.StartupPath & "\ExcelFile.xls")

'セル内の整数を取得します。
nLong = XlsCreator1.Cell("A2").Long    'nLong には 1000 が入ります

XlsCreator1.CloseBook(True)

[C#]
//指定セル内に値を設定します。
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//セルに整数を設定します。
xlsCreator1.Cell("A2").Long = 1000;     //セル A2 には 1000 が入ります

xlsCreator1.CloseBook(true);

//上記で作成したファイルの、指定セル内の値を取得します。
int nValue;
xlsCreator1.ReadBook(Application.StartupPath + @"\ExcelFile.xls");

//セル内の整数を取得します。
nValue = xlsCreator1.Cell("A2").Long;    //nLong には 1000 が入ります

xlsCreator1.CloseBook(true);

注意事項
・Cell プロパティに変数名を設定した場合、取得には対応しておりません。 ・Excel ファイルが保持する整数値は Int32 型の 32bit 値であるため、Int32 型の範囲を超える値を設定する場合は、Double プロパティを使用してください。


Long2 メソッド

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Long2 メソッド

整数値と属性番号を設定します。

書式

[VB.NET]
  Public Sub Long2(ByVal val As Integer, ByVal attr As Integer)

[C#]
  public void Long2(System.Int32 val , System.Int32 attr)

設定値

    value
      属性番号の値と共に設定する整数値を設定します。
    attrno
      AttrNo プロパティで取得した属性番号の値を設定します。

解説
AttrNo プロパティで取得した属性番号の値と共に整数値を設定します。
Excel ファイルでは、各セルの罫線や表示書式などの書式情報を、属性番号として 内部で記憶しており、AttrNo プロパティでは、設定したセルのその属性番号を取得 します。
Long2 メソッドは、セルへ値と AttrNo プロパティで取得した属性番号を同時に設定 することができますので、例えば、セルへ設定する値や文字列が同一条件時には同じ 書式情報をコピーすることを、一つのメソッドで実現することができます。

参照
[AttrNo プロパティ] | [Str2 メソッド] | [Double2 メソッド] | [Value2 メソッド]
[Cell プロパティ] | [Pos プロパティ]

コーディング例

設定したセルの属性番号を取得し、
Long2、Str2、Double2、Value2 の各 メソッドで、その属性番号と値を設定します。

[VB.NET]
Dim nAttrNo As Integer

XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)
XlsCreator1.Cell("A1").Str = "属性テスト"
XlsCreator1.Cell("A1").Attr.FontName = "MS 明朝"
XlsCreator1.Cell("A1").Attr.FontPoint = 20                                'フォントサイズを 20 ポイントで設定します
XlsCreator1.Cell("A1").Attr.FontColor = XlsCrt.xlColor.xcYellow     'フォントの色を黄色で設定します
XlsCreator1.Cell("A1").Attr.FontStyle = XlsCrt.xlFontStyle.xsItalic 'フォントスタイルを斜線で設定します
XlsCreator1.Cell("A1").Attr.FontULine = XlsCrt.xlFontULine.fuDouble 'フォントの下線スタイルを二重下線で設定します
XlsCreator1.CloseBook(True)

XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")

'属性番号と値を設定します。
'属性番号取得
nAttrNo = XlsCreator1.Cell("A1").AttrNo
'A1 セルの属性を Long 値とともに B1 セルに設定
XlsCreator1.Cell("B1").Long2(200, nAttrNo)
'A1 セルの属性を Double 値とともに C1 セルに設定
XlsCreator1.Cell("C1").Double2(200.1, nAttrNo)
'A1 セルの属性を Str 値とともに D1 セルに設定
XlsCreator1.Cell("D1").Str2("文字列", nAttrNo)
'A1 セルの属性を value 値とともに E1 セルに設定
XlsCreator1.Cell("E1").Value2("バリアント型", nAttrNo)

XlsCreator1.CloseBook(True)

[C#]
Int32 nAttrNo;

xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);
xlsCreator1.Cell("A1").Str = "属性テスト";
xlsCreator1.Cell("A1").Attr.FontName = "MS 明朝";
xlsCreator1.Cell("A1").Attr.FontPoint = 20;                          //フォントサイズを 20 ポイントで設定します
xlsCreator1.Cell("A1").Attr.FontColor = XlsCrt.xlColor.xcYellow;     //フォントの色を黄色で設定します
xlsCreator1.Cell("A1").Attr.FontStyle = XlsCrt.xlFontStyle.xsItalic; //フォントスタイルを斜線で設定します
xlsCreator1.Cell("A1").Attr.FontULine = XlsCrt.xlFontULine.fuDouble; //フォントの下線スタイルを二重下線で設定します
xlsCreator1.CloseBook(true);

xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");

//属性番号と値を設定します。
//属性番号取得
nAttrNo = xlsCreator1.Cell("A1").AttrNo;
//A1 セルの属性を Long 値とともに B1 セルに設定
xlsCreator1.Cell("B1").Long2(200, nAttrNo);
//A1 セルの属性を Double 値とともに C1 セルに設定
xlsCreator1.Cell("C1").Double2(200.1, nAttrNo);
//A1 セルの属性を Str 値とともに D1 セルに設定
xlsCreator1.Cell("D1").Str2("文字列", nAttrNo);
//A1 セルの属性を value 値とともに E1 セルに設定
xlsCreator1.Cell("E1").Value2("バリアント型", nAttrNo);

xlsCreator1.CloseBook(true);

注意事項
・Excel ファイルが保持する整数値は Int32 型の 32bit 値であるため、Int32 型の範囲を超える値を設定する場合は、Double2 メソッドを使用してください。


Paste メソッド

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Paste メソッド

Copy メソッドでコピーしたセルを貼り付けます。

書式

[VB.NET]
  Public Sub Paste()

[C#]
  public void Paste()

参照
[Copy メソッド]

コーディング例

Copy メソッドでコピーしたセルを、設定したセルに貼り付けます。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'セルコピー元を設定
XlsCreator1.Cell("A1").Attr.Pattern = XlsCrt.xlPattern.pn03
XlsCreator1.Cell("A1").Str = "セルコピー元"

'セルコピー
XlsCreator1.Cell("A1").Copy("")    'A1 セルをメモリ上にコピー
'貼り付け
XlsCreator1.Cell("A3").Paste()     'A1 セルを A3 セルに貼り付け

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//セルコピー元を設定
xlsCreator1.Cell("A1").Attr.Pattern = XlsCrt.xlPattern.pn03;
xlsCreator1.Cell("A1").Str = "セルコピー元";

//セルコピー
xlsCreator1.Cell("A1").Copy("");   //A1 セルをメモリ上にコピー
//貼り付け
xlsCreator1.Cell("A3").Paste();     //A1 セルを A3 セルに貼り付け

xlsCreator1.CloseBook(true);

注意事項
・コピー元セルのセル属性と値のみコピーします。
・Paste メソッドの Cell プロパティに変数名を設定した場合は対応しておりません。
・ブック間、シート間のコピー・貼り付けには対応しておりません。


RowHeight プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.RowHeight プロパティ

セルの高さを設定します。

書式

[VB.NET]
  Public WriteOnly Property RowHeight() As Double

[C#]
  public double RowHeight [set]

解説
指定された範囲の高さを ( 0 ～ 409 ポイント) の範囲で設定します。
0 を設定した場合は非表示行となります。単位はポイント数です。

参照
[ColWidth プロパティ]

コーディング例

A ～ G 列の列幅を 20 文字、10 行目の行高を 20 ポイントに設定します

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

XlsCreator1.Cell("A1:G1").ColWidth = 20
XlsCreator1.Cell("G10").RowHeight = 20

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

xlsCreator1.Cell("A1:G1").ColWidth = 20;
xlsCreator1.Cell("G10").RowHeight = 20;

xlsCreator1.CloseBook(true);


Str プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Str プロパティ

文字列の取得、または設定します。

書式

[VB.NET]
  Public Property Str() As String

[C#]
  public string Str [get, set]

設定値

    文字列を示す文字列を設定します。

解説
セルに計算式や関数式が設定されている場合は、その結果値を文字列で取得することが できます。

参照
[Double プロパティ] | [Long プロパティ] | [Value プロパティ] | [Func メソッド]
[Cell プロパティ] | [Pos プロパティ]

コーディング例

指定セル内に値を設定し、作成したファイルの、指定セル内の値を取得します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'セルに文字列を設定します。
XlsCreator1.Cell("A3").Str = "abcde"    'セル A3 には abcde が入ります

XlsCreator1.CloseBook(True)

Dim str1 As String

XlsCreator1.ReadBook(Application.StartupPath & "\ExcelFile.xls")

'セル内の文字列を取得します。
str1 = XlsCreator1.Cell("A3").Str       'str1 には abcde が入ります

XlsCreator1.CloseBook(True)

[C#]
//指定セル内に値を設定します。
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//セルに文字列を設定します。
xlsCreator1.Cell("A3").Str = "abcde";    //セル A3 には abcde が入ります

xlsCreator1.CloseBook(true);

//上記で作成したファイルの、指定セル内の値を取得します。
String str1;
xlsCreator1.ReadBook(Application.StartupPath + @"\ExcelFile.xls");

//セル内の文字列を取得します。
str1 = xlsCreator1.Cell("A3").Str;       //str1 には abcde が入ります

xlsCreator1.CloseBook(true);

注意事項
・Cell プロパティに変数名を設定した場合、取得には対応しておりません。


Str2 メソッド

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Str2 メソッド

文字列と属性番号を設定します。

書式

[VB.NET]
  Public Sub Str2(ByVal val As String, ByVal attr As Integer)

[C#]
  public void Str2(System.String val , System.Int32 attr)

設定値

    value
      属性番号の値と共に設定する文字列を設定します。
    attrno
      AttrNo プロパティで取得した属性番号の値を設定します。

解説
AttrNo プロパティで取得した属性番号の値と共に文字列を設定します。
Excel ファイルでは、各セルの罫線や表示書式などの書式情報を、属性番号として 内部で記憶しており、AttrNo プロパティでは、設定したセルのその属性番号を取得 します。
文字列と AttrNo プロパティで取得した属性番号を同時に設定することができますの で、例えば、セルへ設定する値や文字列が同一条件時には同じ書式情報をコピーする ことを、一つのメソッドで実現することができます。

参照
[AttrNo プロパティ] | [Long2 メソッド] | [Double2 メソッド] | [Value2 メソッド]
[Cell プロパティ] | [Pos プロパティ]

コーディング例

設定したセルの属性番号を取得し、
Long2、Str2、Double2、Value2 の各 メソッドで、その属性番号と値を設定します。

[VB.NET]
Dim nAttrNo As Integer

XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)
XlsCreator1.Cell("A1").Str = "属性テスト"
XlsCreator1.Cell("A1").Attr.FontName = "MS 明朝"
XlsCreator1.Cell("A1").Attr.FontPoint = 20                                'フォントサイズを 20 ポイントで設定します
XlsCreator1.Cell("A1").Attr.FontColor = XlsCrt.xlColor.xcYellow     'フォントの色を黄色で設定します
XlsCreator1.Cell("A1").Attr.FontStyle = XlsCrt.xlFontStyle.xsItalic 'フォントスタイルを斜線で設定します
XlsCreator1.Cell("A1").Attr.FontULine = XlsCrt.xlFontULine.fuDouble 'フォントの下線スタイルを二重下線で設定します
XlsCreator1.CloseBook(True)

XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")

'属性番号と値を設定します。
'属性番号取得
nAttrNo = XlsCreator1.Cell("A1").AttrNo
'A1 セルの属性を Long 値とともに B1 セルに設定
XlsCreator1.Cell("B1").Long2(200, nAttrNo)
'A1 セルの属性を Double 値とともに C1 セルに設定
XlsCreator1.Cell("C1").Double2(200.1, nAttrNo)
'A1 セルの属性を Str 値とともに D1 セルに設定
XlsCreator1.Cell("D1").Str2("文字列", nAttrNo)
'A1 セルの属性を value 値とともに E1 セルに設定
XlsCreator1.Cell("E1").Value2("バリアント型", nAttrNo)

XlsCreator1.CloseBook(True)

[C#]
Int32 nAttrNo;

xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);
xlsCreator1.Cell("A1").Str = "属性テスト";
xlsCreator1.Cell("A1").Attr.FontName = "MS 明朝";
xlsCreator1.Cell("A1").Attr.FontPoint = 20;                          //フォントサイズを 20 ポイントで設定します
xlsCreator1.Cell("A1").Attr.FontColor = XlsCrt.xlColor.xcYellow;     //フォントの色を黄色で設定します
xlsCreator1.Cell("A1").Attr.FontStyle = XlsCrt.xlFontStyle.xsItalic; //フォントスタイルを斜線で設定します
xlsCreator1.Cell("A1").Attr.FontULine = XlsCrt.xlFontULine.fuDouble; //フォントの下線スタイルを二重下線で設定します
xlsCreator1.CloseBook(true);

xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");

//属性番号と値を設定します。
//属性番号取得
nAttrNo = xlsCreator1.Cell("A1").AttrNo;
//A1 セルの属性を Long 値とともに B1 セルに設定
xlsCreator1.Cell("B1").Long2(200, nAttrNo);
//A1 セルの属性を Double 値とともに C1 セルに設定
xlsCreator1.Cell("C1").Double2(200.1, nAttrNo);
//A1 セルの属性を Str 値とともに D1 セルに設定
xlsCreator1.Cell("D1").Str2("文字列", nAttrNo);
//A1 セルの属性を value 値とともに E1 セルに設定
xlsCreator1.Cell("E1").Value2("バリアント型", nAttrNo);

xlsCreator1.CloseBook(true);


Value プロパティ

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Value プロパティ

数値や文字列、日付などの値を設定します。値の取得も可能です。

書式

[VB.NET]
  Public Property Value() As Object

[C#]
  public object Value [get, set]

解説
セルに設定されている属性に関係なく、値を設定することができます。文字列を設定 した場合は文字列として値が設定され、数値で設定した場合は数値として設定されます。
また、値を取得することもできます。

計算式の設定
 Value = "=SUM(A1:A3)" のように先頭に "=" がある場合、ExcelMode プロパティ を True に設定すると、プレビュー・印刷時に計算結果が反映されます。
ただし、Excel 97 / 2000 / 2002(XP) / 2003 がインストールされているマシンに限ります。
なお、計算式と共に計算結果をセルに設定する場合や Web 上で使用する場合は、 Func メソッドを使用してください。

参照
[Double プロパティ] | [Long プロパティ] | [Str プロパティ] | [Func メソッド]
[Cell プロパティ] | [Pos プロパティ]
セル情報の設定と取得について (Cell プロパティの場合) | セル情報の設定と取得について (Pos プロパティの場合)

コーディング例

セルに実数・整数・文字列・関数を設定し作成した Excel ファイルの指定セル内の値を取得します

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'セルに実数、整数、文字列、関数を設定します。
XlsCreator1.Cell("B1").Value = 12.345     'セル B1 には 12.345 が入ります
XlsCreator1.Cell("B2").Value = 1000       'セル B2 には 1000 が入ります
XlsCreator1.Cell("B3").Value = "abcde"    'セル B3 には abcde が入ります
XlsCreator1.Cell("B4").Value = "=A2+999"  'セル B4 には =A2+999 が入ります"

XlsCreator1.CloseBook(True)

Dim objData As Object

XlsCreator1.ReadBook(Application.StartupPath & "\ExcelFile.xls")

'セル内の実数、整数、文字列を取得します。
objData = XlsCreator1.Cell("B1").Value    'objData には 12.345000 が入ります
objData = XlsCreator1.Cell("B2").Value    'objData には 1000.000000 が入ります
objData = XlsCreator1.Cell("B3").Value    'objData には abcde が入ります

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//セルに実数、整数、文字列、関数を設定します。
xlsCreator1.Cell("B1").Value = 12.345;    //セル B1 には 12.345 が入ります
xlsCreator1.Cell("B2").Value = 1000;      //セル B2 には 1000 が入ります
xlsCreator1.Cell("B3").Value = "abcde";   //セル B3 には abcde が入ります
xlsCreator1.Cell("B4").Value = "=A2+999"; //セル B4 には =A2+999 が入ります"

xlsCreator1.CloseBook(true);

//上記で作成したファイルの、指定セル内の値を取得します。
object objData;
xlsCreator1.ReadBook(Application.StartupPath + @"\ExcelFile.xls");

//セル内の実数、整数、文字列を取得します。
objData = xlsCreator1.Cell("B1").Value;   //objData には 12.345000 が入ります
objData = xlsCreator1.Cell("B2").Value;   //objData には 1000.000000 が入ります
objData = xlsCreator1.Cell("B3").Value;   //objData には abcde が入ります

xlsCreator1.CloseBook(true);

注意事項
・Cell プロパティに変数名を設定した場合、取得には対応しておりません。


Value2 メソッド

- ExcelCreator .NET -
XlsCrt.Cell/Pos.Value2 メソッド

数値や文字列、日付などの値と属性番号を設定します。

書式

[VB.NET]
  Public Sub Value2(ByVal objValue As Object, ByVal nAttrNo As Integer)

[C#]
  public void Value2(System.Object objValue , System.Int32 nAttrNo)

設定値

    objValue
      属性番号の値と共に設定する値を設定します。
    nAttrNo
      AttrNo プロパティで取得した属性番号を設定します。

解説
Excel ファイルでは各セルの罫線や表示書式などの書式情報を属性番号として保持 しており、AttrNo プロパティで属性番号を取得します。
設定したセルへ値と、AttrNo プロパティで取得した属性番号を同時に設定 することができます

参照
[AttrNo プロパティ] | [Long2 メソッド] | [Str2 メソッド] | [Double2 メソッド]

コーディング例

セルの属性番号を取得し、Long2、Str2、Double2、Value2 の各 メソッドで属性番号と値を設定します。

[VB.NET]
Dim nAttrNo As Integer

XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)
XlsCreator1.Cell("A1").Str = "属性テスト"
XlsCreator1.Cell("A1").Attr.FontName = "MS 明朝"
XlsCreator1.Cell("A1").Attr.FontPoint = 20                                'フォントサイズを 20 ポイントで設定します
XlsCreator1.Cell("A1").Attr.FontColor = XlsCrt.xlColor.xcYellow     'フォントの色を黄色で設定します
XlsCreator1.Cell("A1").Attr.FontStyle = XlsCrt.xlFontStyle.xsItalic 'フォントスタイルを斜線で設定します
XlsCreator1.Cell("A1").Attr.FontULine = XlsCrt.xlFontULine.fuDouble 'フォントの下線スタイルを二重下線で設定します
XlsCreator1.CloseBook(True)

XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")

'属性番号と値を設定します。
'属性番号取得
nAttrNo = XlsCreator1.Cell("A1").AttrNo
'A1 セルの属性を Long 値とともに B1 セルに設定
XlsCreator1.Cell("B1").Long2(200, nAttrNo)
'A1 セルの属性を Double 値とともに C1 セルに設定
XlsCreator1.Cell("C1").Double2(200.1, nAttrNo)
'A1 セルの属性を Str 値とともに D1 セルに設定
XlsCreator1.Cell("D1").Str2("文字列", nAttrNo)
'A1 セルの属性を value 値とともに E1 セルに設定
XlsCreator1.Cell("E1").Value2("バリアント型", nAttrNo)

XlsCreator1.CloseBook(True)

[C#]
Int32 nAttrNo;

xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);
xlsCreator1.Cell("A1").Str = "属性テスト";
xlsCreator1.Cell("A1").Attr.FontName = "MS 明朝";
xlsCreator1.Cell("A1").Attr.FontPoint = 20;                          //フォントサイズを 20 ポイントで設定します
xlsCreator1.Cell("A1").Attr.FontColor = XlsCrt.xlColor.xcYellow;     //フォントの色を黄色で設定します
xlsCreator1.Cell("A1").Attr.FontStyle = XlsCrt.xlFontStyle.xsItalic; //フォントスタイルを斜線で設定します
xlsCreator1.Cell("A1").Attr.FontULine = XlsCrt.xlFontULine.fuDouble; //フォントの下線スタイルを二重下線で設定します
xlsCreator1.CloseBook(true);

xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");

//属性番号と値を設定します。
//属性番号取得
nAttrNo = xlsCreator1.Cell("A1").AttrNo;
//A1 セルの属性を Long 値とともに B1 セルに設定
xlsCreator1.Cell("B1").Long2(200, nAttrNo);
//A1 セルの属性を Double 値とともに C1 セルに設定
xlsCreator1.Cell("C1").Double2(200.1, nAttrNo);
//A1 セルの属性を Str 値とともに D1 セルに設定
xlsCreator1.Cell("D1").Str2("文字列", nAttrNo);
//A1 セルの属性を value 値とともに E1 セルに設定
xlsCreator1.Cell("E1").Value2("バリアント型", nAttrNo);

xlsCreator1.CloseBook(true);


CloseBook メソッド

- ExcelCreator .NET -
XlsCrt.CloseBook メソッド

ブックのクローズ、または破棄を行います。PDF ファイル出力も行うことができます。

書式

[VB.NET]
  Public Sub CloseBook(ByVal mode As Boolean)
  Public Sub CloseBook(ByVal mode As Boolean, ByVal strPDFName As String, ByVal bDelete As Boolean)
  Public Sub CloseBook(ByVal mode As Boolean, ByVal strm As System.IO.Stream, ByVal bDelete As Boolean)

[C#]
  public void CloseBook(System.Boolean mode)
  public void CloseBook(System.Boolean mode , System.String strPDFName , System.Boolean bDelete)
  public void CloseBook(System.Boolean mode , System.IO.Stream strm , System.Boolean bDelete)

設定値

    strPDFName , strm
      出力する PDF ファイルをで設定します。

    mode

      定数      内容
      True      ブックをクローズします。
      False     変更内容を破棄し、オープン時点の内容に戻します。

    bDelete

      定数      内容
      True      PDF ファイル保存時に Excel ファイルを削除します。
      False     PDF ファイル保存時に Excel ファイルは削除しません。

解説
CreateBook、OpenBook、ReadBook、OpenBookEmbed メソッドでオープンした後は、 必ず、ブックのクローズ、または、破棄を行ってください。

参照
[CreateBook メソッド] | [ReadBook メソッド] | [OpenBook メソッド] | [OpenBookEmbed メソッド]

コーディング例

開いているファイルの終了を行います。

[VB.NET]
'開いているファイルの終了を行います
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)
XlsCreator1.Cell("D1").Str = "abcde"

XlsCreator1.CloseBook(True)  '開いているファイルを閉じます

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);
xlsCreator1.Cell("D1").Str = "abcde";

//開いているファイルを閉じます
xlsCreator1.CloseBook(true);


CloseBookEx メソッド

- ExcelCreator .NET -
XlsCrt.CloseBookEx メソッド

CreateBookEx、ReadBookEx、OpenBookEx、OpenBookEmbedEx でブックを操作した場合に、ブックのクローズ、または破棄を行います。 PDF ファイル出力も行うことができます。

書式

[VB.NET]
  Public Sub CloseBookEx(ByVal mode As Boolean, ByVal uiID As System.UInt32)
  Public Sub CloseBookEx(ByVal mode As Boolean, ByVal uiID As System.UInt32, ByVal strPDFName As String, ByVal bDelete As Boolean)
  Public Sub CloseBookEx(ByVal mode As Boolean, ByVal uiID As System.UInt32, ByVal strm As System.IO.Stream, ByVal bDelete As Boolean)

[C#]
  public void CloseBookEx(System.Boolean mode, System.UInt32 uiID)
  public void CloseBookEx(System.Boolean mode, System.UInt32 uiID, System.IO.Stream strm, System.Boolean bDelete)
  public void CloseBookEx(System.Boolean mode, System.UInt32 uiID, System.String strPDFName, System.Boolean bDelete)

設定値

    strm , strPDFName
      出力する PDF ファイルをで設定します。
    pID
      作成するブックの識別 ID を取得する変数を設定します。
    mode
      ファイルをクローズするフラグを設定します。

      定数      内容
      True      ブックをクローズします。(デフォルト値)
      False     変更内容を破棄し、オープン時点の内容に戻します。

    bDelete
      PDF ファイル出力時に Excel ファイルを削除する・しないを設定します。

      定数      内容
      True      PDF ファイル保存時に Excel ファイルを削除します。
      False     PDF ファイル保存時に Excel ファイルは削除しません。

解説
CreateBookEx、ReadBookEx、OpenBookEx、OpenBookEmbedEx メソッドでオープンした後は、 必ずブックのクローズ、または、破棄を行ってください。

参照
[CreateBookEx メソッド] | [ReadBookEx メソッド] | [OpenBookEx メソッド] | [OpenBookEmbedEx メソッド]

コーディング例

次のプログラムでは開いているファイルの終了を行います。

[VB.NET]
Dim pID1 As UInt32
Dim pID2 As UInt32

XlsCreator1.CreateBookEx(Application.StartupPath & "\ExcelFile01.xls", 1, XlsCrt.xlVersion.ver2003, pID1)
XlsCreator1.Cell("A1").Value = 10000

XlsCreator1.CreateBookEx(Application.StartupPath & "\ExcelFile02.xls", 1, XlsCrt.xlVersion.ver2003, pID2)
XlsCreator1.Cell("A5").Value = 18000

' ファイルクローズ時に、オープンした ID を選択します
XlsCreator1.CloseBookEx(True, pID2)
XlsCreator1.CloseBookEx(True, pID1)

[C#]
uint pID1 = 0;
uint pID2 = 0;

xlsCreator1.CreateBookEx(Application.StartupPath + @"\ExcelFile01.xls", 1, XlsCrt.xlVersion.ver2003, ref pID1);
xlsCreator1.Cell("A1").Value = 10000;

xlsCreator1.CreateBookEx(Application.StartupPath + @"\ExcelFile02.xls", 1, XlsCrt.xlVersion.ver2003, ref pID2);
xlsCreator1.Cell("A5").Value = 18000;

// ファイルクローズ時に、オープンした ID を選択し閉じます
xlsCreator1.CloseBookEx(true, pID2);
xlsCreator1.CloseBookEx(true, pID1);

次のプログラムでは複数の開いているファイルの終了を行います。

[VB.NET]
Dim pID1 As UInt32
Dim pID2 As UInt32

XlsCreator1.CreateBookEx(Application.StartupPath & "\ExcelFile01.xls", 1, XlsCrt.xlVersion.ver2003, pID1)
XlsCreator1.PDF.Title = "2005 年 1 月売り上げ一覧"

XlsCreator1.CreateBookEx(Application.StartupPath & "\ExcelFile02.xls", 1, XlsCrt.xlVersion.ver2003, pID2)
XlsCreator1.PDF.Title = "2005 年 2 月売り上げ一覧"

' ファイルクローズ時に、オープンした ID を選択し PDF ファイルへ出力します
XlsCreator1.CloseBookEx(True, pID2, Application.StartupPath & "\PdfFile02.pdf", True)
XlsCreator1.CloseBookEx(True, pID1, Application.StartupPath & "\PdfFile01.pdf", True)

[C#]
uint pID1 = 0;
uint pID2 = 0;

xlsCreator1.CreateBookEx(Application.StartupPath + @"\ExcelFile01.xls", 1, XlsCrt.xlVersion.ver2003, ref pID1);
xlsCreator1.PDF.Title = "2005 年 1 月売り上げ一覧";

xlsCreator1.CreateBookEx(Application.StartupPath + @"\ExcelFile02.xls", 1, XlsCrt.xlVersion.ver2003, ref pID2);
xlsCreator1.PDF.Title = "2005 年 2 月売り上げ一覧";

// ファイルクローズ時に、オープンした ID を選択し PDF ファイルへ出力します
xlsCreator1.CloseBookEx(true, pID2, Application.StartupPath + @"\PdfFile02.pdf", true);
xlsCreator1.CloseBookEx(true, pID1, Application.StartupPath + @"\PdfFile01.pdf", true);


ColumnClear メソッド

- ExcelCreator .NET -
XlsCrt.ColumnClear メソッド

列をクリア (初期化) します。

書式

[VB.NET]
  Public Sub ColumnClear(ByVal sx As Integer, ByVal count As Integer)

[C#]
  public void ColumnClear(System.Int32 sx , System.Int32 count)

設定値

    sx
      クリアする開始列番号値 (0 ～) を設定します。
    count
      クリアする列数値 (1 ～) を設定します。

解説
引数 sx で指定された列から、引数 count の列数分をクリア (初期化) します。

コーディング例

列のクリア (初期化) を行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'指定列に対する列クリア (初期化) を行います。
'単一列のクリア (初期化)
XlsCreator1.ColumnClear(4, -1)     'E 列をクリア (初期化)
'複数列のクリア (初期化)
XlsCreator1.ColumnClear(4, 2)      'E 列から 2 列分クリア (初期化)

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//指定列に対する列クリア (初期化) を行います。
//単一列のクリア (初期化)
xlsCreator1.ColumnClear(4, -1);     //E 列をクリア (初期化)
//複数列のクリア (初期化)
xlsCreator1.ColumnClear(4, 2);      //E 列から 2 列分クリア (初期化)

xlsCreator1.CloseBook(true);

注意事項
・列挿入を行っても、Excel シート上に設定されているオートシェイプや画像の位置は移動されません。


ColumnCopy メソッド

- ExcelCreator .NET -
XlsCrt.ColumnCopy メソッド

列をコピーします。

書式

[VB.NET]
  Public Sub ColumnCopy(ByVal sx As Integer, ByVal dx As Integer)

[C#]
  public void ColumnCopy(System.Int32 sx , System.Int32 dx)

設定値

    sx
      コピー元の列番号値 (0 ～) を設定します。
    dx
      コピー先の列番号値 (0 ～) を設定します。

解説
引数 sx で指定された列を、引数 dx の列へコピーします。
引数 dx に -1 を設定した時は、引数 sx で指定された列がメモリ上にコピーされます。
コピーした列は、ColumnPaste メソッドで設定した列に貼り付けることができます。

参照
[ColumnPaste メソッド]

コーディング例

列コピーを行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'指定列に対する列コピーを行います。
'コピー元を設定
XlsCreator1.Cell("A1").Func("=sum(B1:C1)", "")
'列コピー
XlsCreator1.ColumnCopy(0, 19)   '1 列目を 20 列目にコピー

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//指定列に対する列コピーを行います。
//コピー元を設定
xlsCreator1.Cell("A1").Func("=sum(B1:C1)", null);

//列コピー
xlsCreator1.ColumnCopy(0, 19);   //1 列目を 20 列目にコピー

xlsCreator1.CloseBook(true);

注意事項
・コピー元セルのセル属性と値のみコピーします。
・コピー元セルに変数名が設定されている場合、変数名はコピーされません。
・ブック間、シート間のコピー・貼り付けには対応しておりません。


ColumnDelete メソッド

- ExcelCreator .NET -
XlsCrt.ColumnDelete メソッド

列を削除します。

書式

[VB.NET]
  Public Sub ColumnDelete(ByVal sx As Integer, ByVal count As Integer)

[C#]
  public void ColumnDelete(System.Int32 sx , System.Int32 count)

設定値

    sx
      削除する開始列番号値 (0 ～) を設定します。
    count
      削除する列数値 (1 ～) を設定します。

解説
引数 sx で指定された列から、引数 count の列数分を削除します。

コーディング例

列削除を行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'指定列に対する列削除を行います。
'単一列の削除
XlsCreator1.ColumnDelete(4, -1)    'E 列を削除
'複数列の削除
XlsCreator1.ColumnDelete(4, 2)     'E 列から 2 列分削除

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//指定列に対する列削除を行います。
//単一列の削除
xlsCreator1.ColumnDelete(4, -1);    //E 列を削除
//複数列の削除
xlsCreator1.ColumnDelete(4, 2);     //E 列から 2 列分削除

xlsCreator1.CloseBook(true);

注意事項
・列削除を行っても、Excel シート上に設定されているオートシェイプや画像の位置は移動されません。


ColumnInsert メソッド

- ExcelCreator .NET -
XlsCrt.ColumnInsert メソッド

列を挿入します。

書式

[VB.NET]
  Public Sub ColumnInsert(ByVal sx As Integer, ByVal count As Integer)

[C#]
  public void ColumnInsert(System.Int32 sx , System.Int32 count)

設定値

    sx
      挿入する開始列番号値 (0 ～) を設定します。
    count
      挿入する列数値 (1 ～) を設定します。

解説
引数 sx で指定された列から、引数 count の列数分を挿入します。

コーディング例

列の挿入を行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'指定列に対する列挿入を行います。
'単一列の挿入
XlsCreator1.ColumnInsert(1, 1)     'B 列から 1 列のみ挿入
'複数列の挿入
XlsCreator1.ColumnInsert(1, 2)     'B 列から 2 列分挿入

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//指定列に対する列挿入を行います。
//単一列の挿入
xlsCreator1.ColumnInsert(1, 1);     //B 列から 1 列のみ挿入
//複数列の挿入
xlsCreator1.ColumnInsert(1, 2);     //B 列から 2 列分挿入

xlsCreator1.CloseBook(true);


ColumnPaste メソッド

- ExcelCreator .NET -
XlsCrt.ColumnPaste メソッド

列へ貼り付けます。

書式

[VB.NET]
  Public Sub ColumnPaste(ByVal dx As Integer)

[C#]
  public void ColumnPaste(System.Int32 dx)

設定値

    dx
      貼り付けを行う列番号値 (0 ～) を設定します。

解説
ColumnCopy メソッドによりメモリ上にコピーされた列を、引数 dx に貼り付けます。 このとき、元の列は上書きされます。

参照
[ColumnPaste メソッド]

コーディング例

列コピーと列の貼り付けを行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'指定列に対する列コピーと列の貼り付けを行います。
'コピー元を設定
XlsCreator1.Cell("A1").Func("=sum(B1:C1)", "")

'列コピー
XlsCreator1.ColumnCopy(0, 19)  '1 列目を 20 列目にコピー
'列の貼り付け
XlsCreator1.ColumnCopy(0, -1)  '1 列目をメモリ上にコピー
XlsCreator1.ColumnPaste(20)    'コピーされた列を 21 列目に貼り付け

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//指定列に対する列コピーと列の貼り付けを行います。
//コピー元を設定
xlsCreator1.Cell("A1").Func("=sum(B1:C1)", null);

//列コピー
xlsCreator1.ColumnCopy(0, 19);  //1 列目を 20 列目にコピー
//列の貼り付け
xlsCreator1.ColumnCopy(0, -1);  //1 列目をメモリ上にコピー
xlsCreator1.ColumnPaste(20);    //コピーされた列を 21 列目に貼り付け

xlsCreator1.CloseBook(true);

注意事項
・コピー元セルのセル属性と値のみコピーします。
・コピー元セルに変数名が設定されている場合、変数名はコピーされません。
・ブック間、シート間のコピー・貼り付けには対応しておりません。


CopySheet メソッド

- ExcelCreator .NET -
XlsCrt.CopySheet メソッド

設定したシートを設定した場所にコピーします。

書式

[VB.NET]
  Public Sub CopySheet(ByVal sheetno As Integer, ByVal insertpos As Integer, ByVal sheetname As String)

[C#]
  public void CopySheet(System.Int32 sheetno, System.Int32 insertpos, System.String sheetname)

設定値

    sheetno
      コピー元のシート番号値 (0 ～) を設定します。
    insertpos
      コピー元のシートを挿入するシート番号値 (0 ～) を設定します。
    sheetname
      シート名を示す文字列を設定します。

コーディング例

シートのコピーを行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 10, XlsCrt.xlVersion.ver2003)

'Excel ブックに対するシートのコピーを行います。
'0 番目のシートを、1 番目の位置にコピーし、
'コピー先のシート名を「コピーしたシート」に設定します。
XlsCreator1.CopySheet(0, 1, "コピーしたシート")
'3 番目のシートを、5 番目の位置にコピーします。
XlsCreator1.CopySheet(3, 5, "")

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 10, XlsCrt.xlVersion.ver2003);
//Excel ブックに対するシートのコピーを行います。
//0 番目のシートを 1 番目の位置にコピーし、
//コピー先のシート名を「コピーしたシート」に設定します。
xlsCreator1.CopySheet(0, 1, "コピーしたシート");
//3 番目のシートを 5 番目の位置にコピーします。
xlsCreator1.CopySheet(3, 5, "");

xlsCreator1.CloseBook(true);

注意事項
・ブック間のコピーには対応しておりません。


CreateBook メソッド

- ExcelCreator .NET -
XlsCrt.CreateBook メソッド

ブックの新規作成を行います。

書式

[VB.NET]
  Public Function CreateBook(ByVal strFileName As String, ByVal sheetmax As Integer, ByVal version As XlsCrt.xlVersion) As Integer

[C#]
  public System.Int32 CreateBook(System.String strFileName , System.Int32 sheetmax , XlsCrt.xlVersion version)

設定値

    strFileName
      作成するファイル名を文字列で設定します。

    sheetmax
      作成するシート数を整数値の値で設定します。
      省略する場合、-1 を設定してください。省略時には、デフォルト値 3 で作成されます。
    version
      作成する Excel ブックのバージョンを xlVersion 列挙体のメンバで設定します。

      定数       内容
      ver97      Excel 97 の形式
      ver2000    Excel 2000 の形式
      ver2002    Excel 2002 の形式
      ver2003    Excel 2003 の形式

解説
戻り値はメソッドが正常終了した場合には 0 以上の値を、それ以外の場合には 0 より小さい値を返します。 引数 strFileName に既存のファイル名を設定した場合、既存ファイルを削除した後にブックを新規作成します。

参照
[CreateBookEx メソッド] | [OpenBook メソッド] | [CloseBook メソッド]

コーディング例

ファイルの新規作成を行います。

[VB.NET]
'3 シートある Excel2003 形式のブックを作成します
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)
XlsCreator1.Cell("D1").Str = "abcde"
XlsCreator1.CloseBook(True)

[C#]
//3 シートある Excel2003 形式のブックを作成します
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);
xlsCreator1.Cell("D1").Str = "abcde";
xlsCreator1.CloseBook(true);


CreateBookEx メソッド

- ExcelCreator .NET -
XlsCrt.CreateBookEx メソッド

ブックを新規作成し、その識別 ID を取得します。

書式

[VB.NET]
  Public Function CreateBookEx(ByVal strFileName As String, ByVal sheetmax As Integer, ByVal version As XlsCrt.xlVersion, ByRef pID As System.UInt32) As Integer

[C#]
  public System.Int32 CreateBookEx(System.String strFileName, System.Int32 sheetmax, XlsCrt.xlVersion version, System.UInt32 pID)

設定値

    strFileName
      作成するファイル名を設定します。
    sheetmax
      作成するシート数を設定します。
      省略する場合は -1 を設定してください。省略時には、デフォルト値 3 で作成されます。
    pID
      作成するブックの識別 ID を取得するの変数を設定します。
    version
      作成する Excel のバージョンを xlVersion 列挙体のメンバで設定します。

      定数       内容
      ver97      Excel 97 の形式
      ver2000    Excel 2000 の形式
      ver2002    Excel 2002 の形式
      ver2003    Excel 2003 の形式

解説
戻り値はメソッドが正常終了した場合には 0 以上の値を、それ以外の場合には 0 より小さい値を返します。
一つの ExcelCreator 5.0 for .NET コンポーネントで複数のブックを作成する場合、 ブックの識別 ID を使用して操作の対象となるブックを SelectBook メソッドで切り 替え、その対象となるブックに対して入出力処理を行います。
CreateBookEx でブックを作成した場合は、必ずCloseBookEx でクローズしてください。
引数 strFileName に既存のファイル名を設定した場合、既存ファイルを削除した後に ブックを新規作成します。

参照
[CloseBookEx メソッド] | [ReadBookEx メソッド] | [OpenBookEx メソッド] | [OpenBookEmbedEx メソッド] | [SelectBook メソッド]

コーディング例

次のプログラムではファイルの新規作成を行います。

[VB.NET]
Dim pID1 As UInt32
Dim pID2 As UInt32

' Excel ファイル新規作成時に、ID を設定します
XlsCreator1.CreateBookEx(Application.StartupPath & "\ExcelFile01.xls", 1, XlsCrt.xlVersion.ver2003, pID1)
XlsCreator1.Cell("A5").Long = 50000

XlsCreator1.CreateBookEx(Application.StartupPath & "\ExcelFile02.xls", 1, XlsCrt.xlVersion.ver2003, pID2)
XlsCreator1.Cell("C5").Long = 75000

' ファイルクローズ時に、オープンした ID を選択し閉じます
XlsCreator1.CloseBookEx(True, pID2)
XlsCreator1.CloseBookEx(True, pID1)

[C#]
uint pID1 = 0;
uint pID2 = 0;

// Excel ファイル新規作成時に、ID を設定します
xlsCreator1.CreateBookEx(Application.StartupPath + @"\ExcelFile01.xls", 1, XlsCrt.xlVersion.ver2003, ref pID1);
xlsCreator1.Cell("A5").Long = 50000;

xlsCreator1.CreateBookEx(Application.StartupPath + @"\ExcelFile02.xls", 1, XlsCrt.xlVersion.ver2003, ref pID2);
xlsCreator1.Cell("C5").Long = 75000;

// ファイルクローズ時に、オープンした ID を選択し閉じます
xlsCreator1.CloseBookEx(true, pID2);
xlsCreator1.CloseBookEx(true, pID1);


DefFontName プロパティ

- ExcelCreator .NET -
XlsCrt.DefFontName プロパティ

ブック全体のデフォルトフォント名を設定します。

書式

[VB.NET]
  Public WriteOnly Property DefFontName() As String

[C#]
  public string DefFontName [set]

設定値

    フォント名の文字列を設定します。

解説
ブック内の全ワークシートで、フォントの書式設定を行っていないセルが設定対象に なります。

参照
[FontName プロパティ] | [FontPoint プロパティ] | [FontColor プロパティ] | [FontStyle プロパティ] | [FontULine プロパティ] | [DefFontPoint プロパティ]

コーディング例

ブック全体のフォント名、フォントサイズを設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

    'ブック全体のフォント名を設定します
XlsCreator1.DefFontName = "ＭＳ ゴシック"
'ブック全体のフォントサイズを設定します
XlsCreator1.DefFontPoint = 9
XlsCreator1.Cell("A1").Str = "ABCDE"    'セルに文字を設定します

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//ブック全体のフォント名を設定します
xlsCreator1.DefFontName = "ＭＳ ゴシック";
//ブック全体のフォントサイズを設定します
xlsCreator1.DefFontPoint = 9;

xlsCreator1.Cell("A1").Str = "ABCDE";    //セルに文字を設定します
xlsCreator1.CloseBook(true);


DefFontPoint プロパティ

- ExcelCreator .NET -
XlsCrt.DefFontPoint プロパティ

ブック全体のデフォルトフォントサイズを設定します。

書式

[VB.NET]
  Public WriteOnly Property DefFontPoint() As Double

[C#]
  public double DefFontPoint [set]

設定値

    フォントのサイズ (1 ～ 409 ポイント) を設定します。

解説
ブック内の全ワークシートで、フォントの書式設定を行っていないセルが設定対象に なります。

参照
[FontName プロパティ] | [FontPoint プロパティ] | [FontColor プロパティ] | [FontStyle プロパティ] | [FontULine プロパティ] | [DefFontName プロパティ]

コーディング例

ブック全体のフォント名、フォントサイズを設定します。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'ブック全体のフォント名を設定します
XlsCreator1.DefFontName = "ＭＳ ゴシック"
'ブック全体のフォントサイズを設定します
XlsCreator1.DefFontPoint = 9
XlsCreator1.Cell("A1").Str = "ABCDE"    'セルに文字を設定します

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//ブック全体のフォント名を設定します
xlsCreator1.DefFontName = "ＭＳ ゴシック";
//ブック全体のフォントサイズを設定します
xlsCreator1.DefFontPoint = 9;

xlsCreator1.Cell("A1").Str = "ABCDE";    //セルに文字を設定します
xlsCreator1.CloseBook(true);


DelSheet メソッド

- ExcelCreator .NET -
XlsCrt.DelSheet メソッド

シートを削除します。

書式

[VB.NET]
  Public Sub DelSheet(ByVal sheetno As Integer, ByVal count As Integer)

[C#]
  public void DelSheet(System.Int32 sheetno , System.Int32 count)

設定値

    sheetno
      削除するシート番号 (0 ～ ) を設定します。
    count
      削除するシート数 (1 ～ ) を設定します。

解説
引数 count に全シート数を超える値を設定すると、存在する全てのシートを削除します。

参照
[AddSheet メソッド]

コーディング例

ブック内にシートの追加と削除を行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 1, XlsCrt.xlVersion.ver2003)

'ブックに 5 シート追加します
XlsCreator1.AddSheet(5)
'ブックの 4 シート目から 2 シート分削除します
XlsCreator1.DelSheet(3, 2)

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 1, XlsCrt.xlVersion.ver2003);

//ブックに 5 シート追加します
xlsCreator1.AddSheet(5);
//ブックの 4 シート目から 2 シート分削除します
xlsCreator1.DelSheet(3, 2);

xlsCreator1.CloseBook(true);

注意事項
・マクロを含む Excel ブックのシートを削除することはできません。


Error イベント

- ExcelCreator .NET -
XlsCrt.Error イベント

ExcelCreator 5.0 for .NET の実行時に、不正な処理を行った場合に発生します。 実行時にエラー番号値の取得も可能です。

書式

[VB.NET]
  Protected object_Error(ByVal sender As Object, ByVal e As XlsCrt.XlsCreatorEventArgs)

[C#]
  protected void object_Error(System.object i1, XlsCrt.XlsCreatorEventArgs err)

設定値

    エラー番号は、次の通りです。

      定数                 値       内容
      errDontOpen           1       ファイルがオープンできない
      errFileHandle         2       無効なファイルハンドル
      errNotOpen            3       未オープンエラー
      errSheetNo            4       シート番号エラー
      errWrite              5       書き込み時のエラー
      errAction             6       動作モードエラー
      errDataCat            7       データ種別エラー
      errValue              8       エラー値
      errClear             20       クリアエラー
      errCopy              21       コピーエラー
      errPaste             22       貼り付けエラー
      errInsert            23       挿入エラー
      errDelete            24       削除エラー
      errLength            31       長さエラー
      errLocate            32       座標エラー
      errAttr              33       属性番号エラー
      errParam             34       パラメータエラー
      errNoData            35       データが無い
      errEndOfData         36       データの終わり
      errVarPoint          37       設定した変数が存在しない
      errParame            34       パラメータエラー
      errBreakCount        38       改ページ数が制限を超えた
      errMemory1           40       メモリー不足エラー１
      errMemory2           41       メモリー不足エラー２
      errOther             50       内部エラー
      errFunction         100       計算式形式エラー
      errCreate           300       ファイル作成エラー
      errTempCreate       301       Temp ファイル作成エラー
      errTempOpen         302       Temp ファイルオープンエラー
      errStream           303       ストリームエラー
      errProtect          304       保護されたファイルです
      errDoubleOpen       305       二重オープンです
      errMutex            400       ミューテックスエラー
      errMaxFileName      401       ファイル名が長すぎます
      errInvalidFileName  402       無効なファイル名
      errEmbedFile        403       埋め込みバイナリエラーです

解説
エラー発生時にエラー番号を取得する場合、XlsEventArgs 列挙体の ErrorNo プロパティの値を取得します。

参照
[ErrorNo プロパティ] | [ErrorMessage プロパティ]

コーディング例

[VB.NET]
Friend WithEvents XlsCreator1 As XlsCrt.XlsCreator

'エラーイベント
Private Sub XlsCreator1_Error(ByVal sender As Object, ByVal err As XlsEventArgs) Handles XlsCreator1.Error
    MessageBox.Show(err.ErrorNo.ToString() + " : " + XlsCreator1.ErrorMessage, "Errorイベント")

[C#]
private XlsCrt.XlsCreator XlsCreator1 = new XlsCrt.XlsCreator();
XlsCreator1.Error += new XlsEventHandler (XlsCreator1_Error);

// エラーイベント
protected void XlsCreator1_Error(System.Object i1 , XlsEventArgs err)
{
    MessageBox.Show(err.ErrorNo.ToString() + " : " + XlsCreator1.ErrorMessage, "Errorイベント");
}


ErrorMessage プロパティ

- ExcelCreator .NET -
XlsCrt.ErrorMessage プロパティ

エラーメッセージを取得します。実行時に値の取得のみ可能です。

書式

[VB.NET]
  Public ReadOnly Property ErrorMessage() As String

[C#]
  public string ErrorMessage [get]

設定値

    エラーメッセージが文字列で渡されます。
    エラーメッセージについては、次の値を参照してください。

      定数                 値       内容
      errDontOpen           1       ファイルがオープンできない
      errFileHandle         2       無効なファイルハンドル
      errNotOpen            3       未オープンエラー
      errSheetNo            4       シート番号エラー
      errWrite              5       書き込み時のエラー
      errAction             6       動作モードエラー
      errDataCat            7       データ種別エラー
      errValue              8       エラー値
      errClear             20       クリアエラー
      errCopy              21       コピーエラー
      errPaste             22       貼り付けエラー
      errInsert            23       挿入エラー
      errDelete            24       削除エラー
      errLength            31       長さエラー
      errLocate            32       座標エラー
      errAttr              33       属性番号エラー
      errParam             34       パラメータエラー
      errNoData            35       データが無い
      errEndOfData         36       データの終わり
      errVarPoint          37       設定した変数が存在しない
      errParame            34       パラメータエラー
      errBreakCount        38       改ページ数が制限を超えた
      errMemory1           40       メモリー不足エラー１
      errMemory2           41       メモリー不足エラー２
      errOther             50       内部エラー
      errFunction         100       計算式形式エラー
      errCreate           300       ファイル作成エラー
      errTempCreate       301       Temp ファイル作成エラー
      errTempOpen         302       Temp ファイルオープンエラー
      errStream           303       ストリームエラー
      errProtect          304       保護されたファイルです
      errDoubleOpen       305       二重オープンです
      errMutex            400       ミューテックスエラー
      errMaxFileName      401       ファイル名が長すぎます
      errInvalidFileName  402       無効なファイル名
      errEmbedFile        403       埋め込みバイナリエラーです

解説
エラーが発生した場合、エラーメッセージを文字列型で取得します。

参照
[ErrorNo プロパティ] | [Error イベント]

コーディング例

エラーメッセージの表示を行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)
'同一ファイルを開いているため下記でエラーになります
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'エラー時にメッセージを表示して処理を抜けます
If XlsCreator1.ErrorNo <> XlsCrt.xlErrorNo.errNoError Then
    '「ファイルがオープンできない」というメッセージが表示されます
    MsgBox(XlsCreator1.ErrorMessage)
    Exit Sub
End If

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);
//同一ファイルを開いているため下記でエラーになります
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//エラー時にメッセージを表示して処理を抜けます
if (xlsCreator1.ErrorNo != XlsCrt.xlErrorNo.errNoError)
{
    //「ファイルがオープンできない」というメッセージが表示されます
    MessageBox.Show(xlsCreator1.ErrorMessage);
    return;
}

xlsCreator1.CloseBook(true);


ErrorNo プロパティ

- ExcelCreator .NET -
XlsCrt.ErrorNo プロパティ

エラー番号を取得します。実行時に値の取得のみ可能です。

書式

[VB.NET]
  Public ReadOnly Property ErrorNo() As XlsCrt.xlErrorNo

[C#]
  public XlsCrt.xlErrorNo ErrorNo [get]

設定値

    xlErrorNo
      実行時のエラー番号が渡されます。
      エラー番号については、次の値を参照してください。

      定数                 値       内容
      errDontOpen           1       ファイルがオープンできない
      errFileHandle         2       無効なファイルハンドル
      errNotOpen            3       未オープンエラー
      errSheetNo            4       シート番号エラー
      errWrite              5       書き込み時のエラー
      errAction             6       動作モードエラー
      errDataCat            7       データ種別エラー
      errValue              8       エラー値
      errClear             20       クリアエラー
      errCopy              21       コピーエラー
      errPaste             22       貼り付けエラー
      errInsert            23       挿入エラー
      errDelete            24       削除エラー
      errLength            31       長さエラー
      errLocate            32       座標エラー
      errAttr              33       属性番号エラー
      errParam             34       パラメータエラー
      errNoData            35       データが無い
      errEndOfData         36       データの終わり
      errVarPoint          37       設定した変数が存在しない
      errParame            34       パラメータエラー
      errBreakCount        38       改ページ数が制限を超えた
      errMemory1           40       メモリー不足エラー１
      errMemory2           41       メモリー不足エラー２
      errOther             50       内部エラー
      errFunction         100       計算式形式エラー
      errCreate           300       ファイル作成エラー
      errTempCreate       301       Temp ファイル作成エラー
      errTempOpen         302       Temp ファイルオープンエラー
      errStream           303       ストリームエラー
      errProtect          304       保護されたファイルです
      errDoubleOpen       305       二重オープンです
      errMutex            400       ミューテックスエラー
      errMaxFileName      401       ファイル名が長すぎます
      errInvalidFileName  402       無効なファイル名
      errEmbedFile        403       埋め込みバイナリエラーです

解説
エラーが発生した場合にエラー番号を取得します。
正常時の戻り値は 0 を返します。

参照
[ErrorMessage プロパティ] | [Error イベント]

コーディング例

 ErrorNo プロパティを使用してエラー処理を行います。

[VB.NET]
'ファイル名が正しくないためエラーになります
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xl", 3, XlsCrt.xlVersion.ver2003)

'エラー時にメッセージを表示して処理を抜けます
If XlsCreator1.ErrorNo <> 0 Then
    MsgBox("エラーです")
    Exit Sub
End If

XlsCreator1.Cell("A2").Str = "abcd"
XlsCreator1.CloseBook(True)

[C#]
//ファイル名が正しくないためエラーになります
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xl", 3, XlsCrt.xlVersion.ver2003);

//エラー時にメッセージを表示して処理を抜けます
if (xlsCreator1.ErrorNo != 0)
{
    MessageBox.Show("エラーです");
    return;
}

xlsCreator1.Cell("A2").Str = "abcd";
xlsCreator1.CloseBook(true);


Footer メソッド

- ExcelCreator .NET -
XlsCrt.Footer メソッド

シートのフッタを設定します。

書式

[VB.NET]
  Public Sub Footer(ByVal left As String, ByVal center As String, ByVal right As String)

[C#]
  public void Footer(System.String left, System.String center, System.String right)

設定値

    left
      左フッタを示す文字列を設定します。
    center
      中央フッタを示す文字列を設定します。
    right
      右フッタを示す文字列を設定します。

    各文字列は、下記の特殊な文字列に対応しています。

      書式コード    内容
      &E            二重下線
      &X            上付き文字
      &Y            下付き文字
      &B            ボールド
      &I            イタリック
      &U            下線
      &S            取消線
      &P            ページ番号
      &P+99         ページ番号に値を加えて表示
                    例:先頭ページ番号を 3 とする場合 … &P + 3)
      &P-99         ページ番号に値を引いて表示
      &D            現在の日付
      &T            現在の時刻
      &A            シート見出し
      &&            ＆(アンパサンド)を表示
      &"フォント"   フォントを指定
      &99           ポイント数を指定
      &N            全体のページ数

解説
文字数の制限は書式コードを含めて 255 文字までです。
なお、引数 left、center、right に "" を設定した場合は元の設定が適用されます。

参照
[Header メソッド]

コーディング例

シートのフッタを設定します。

[VB.NET]
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")

'フッターを設定するシート番号を設定します。
XlsCreator1.SheetNo = 0
'フッターを設定します。
XlsCreator1.Footer("&""ＭＳ Ｐ明朝""&16ExcelCreator新機能一覧フッター", "&A", "&D")

XlsCreator1.CloseBook(True)

[C#]
XlsCreator1.OpenBook(Application.StartUpPath + @"\ExcelFile.xls", Application.StartUpPath + @"\ExcelTemplate.xls");

//ヘッダーを設定するシート番号を設定します。
XlsCreator1.SheetNo = 0;
//フッタを設定します。
XlsCreator1.Footer("&\"ＭＳ Ｐ明朝\"&16ExcelCreator新機能一覧フッタ", "&A", "&D");

XlsCreator1.CloseBook(true);


Header メソッド

- ExcelCreator .NET -
XlsCrt.Header メソッド

シートのヘッダーを設定します。

書式

[VB.NET]
  Public Sub Header(ByVal left As String, ByVal center As String, ByVal right As String)

[C#]
  public void Header(System.String left, System.String center, System.String right)

設定値

    left
      左ヘッダーを示す文字列を設定します。
    center
      中央ヘッダーを示す文字列を設定します。
    right
      右ヘッダーを示す文字列を設定します。

    各文字列は、下記の特殊な文字列に対応しています。

      書式コード    内容
      &E            二重下線
      &X            上付き文字
      &Y            下付き文字
      &B            ボールド
      &I            イタリック
      &U            下線
      &S            取消線
      &P            ページ番号
      &P+99         ページ番号に値を加えて表示
                    例:先頭ページ番号を 3 とする場合 … &P + 3)
      &P-99         ページ番号に値を引いて表示
      &D            現在の日付
      &T            現在の時刻
      &A            シート見出し
      &&            ＆(アンパサンド)を表示
      &"フォント"   フォントを指定
      &99           ポイント数を指定
      &N            全体のページ数

解説
文字数の制限は書式コードを含めて 255 文字までです。
なお、引数 left、center、right に "" を設定した場合は元の設定が適用されます。

参照
[Footer メソッド]

コーディング例

シートのヘッダーを設定します。

[VB.NET]
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", Application.StartupPath & "\ExcelFile.xls")

'ヘッダーを設定するシート番号を設定します。
XlsCreator1.SheetNo = 0
'ヘッダーを設定します。
XlsCreator1.Header("&""ＭＳ Ｐ明朝""&16ExcelCreator新機能一覧ヘッダー", "&A", "&D")

XlsCreator1.CloseBook(True)

[C#]
XlsCreator1.OpenBook(Application.StartUpPath + @"\ExcelFile.xls", Application.StartUpPath + @"\ExcelTemplate.xls");

//ヘッダーを設定するシート番号を設定します。
XlsCreator1.SheetNo = 0;
//ヘッダーを設定します。
XlsCreator1.Header("&\"ＭＳ Ｐ明朝\"&16ExcelCreator新機能一覧ヘッダー", "&A", "&D");

XlsCreator1.CloseBook(true);


KeyWord プロパティ

- ExcelCreator .NET -
XlsCrt.KeyWord プロパティ

変数名の先頭キーワード文字列を設定します。

書式

[VB.NET]
  Public WriteOnly Property KeyWord() As String

[C#]
  public string KeyWord [set]

設定値

    変数文字列の先頭キーワード文字列を設定します。(最大 64 文字)

解説
変数名の先頭キーワード文字列を設定します。
デフォルトの変数名の先頭キーワード文字列 ** です。デフォルト以外を使用したい 場合に KeyWord プロパティで先頭キーワード文字列を指定できます。
先頭キーワード文字列は Excel で文字として認識可能で、かつ、半角文字のみ設定する ことができます。但し、\ ' " , ^ . [] の半角文字は使用できません。

なお、先頭キーワード文字列は ExcelCreator 5.0 for .NET コンポーネントの 1 つの オブジェクトで共通となりますので、処理の途中において先頭キーワード文字列を変更 した場合は、その後にオープンする Excel ブックやシートに影響を受けます。

コーディング例

変数名の先頭キーワード文字列を設定します。

[VB.NET]
'変数名の先頭キーワード文字列を -- に設定します。
XlsCreator1.KeyWord = "--"

XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 1, XlsCrt.xlVersion.ver2003)
XlsCreator1.Cell("A1").Str = "--NAME"
XlsCreator1.CloseBook(True)

XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")
XlsCreator1.Cell("--NAME").Long = 2000
XlsCreator1.CloseBook(True)

[C#]
//変数名の先頭キーワード文字列を -- に設定します。
xlsCreator1.KeyWord = "--";

xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 1, XlsCrt.xlVersion.ver2003);
xlsCreator1.Cell("A1").Str = "--NAME";
xlsCreator1.CloseBook(true);

xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");
xlsCreator1.Cell("--NAME").Long = 2000;
xlsCreator1.CloseBook(true);


MaxArea メソッド

- ExcelCreator .NET -
XlsCrt.MaxArea メソッド

データ (文字列 / 値 / 計算式) の他、罫線やセルの塗りつぶし等のセル書式が設定され ている、最終セルの座標を取得します。

書式

[VB.NET]
  Public Function MaxArea(ByVal pt As XlsCrt.xlPoint) As System.Drawing.Size

[C#]
  public System.Drawing.Size MaxArea(XlsCrt.xlPoint pt)

設定値

     定数          内容
     xlMaxPoint    データやセル書式が設定されているセルのうち、最下部のセルと、
                   最右部のセルが交わる地点にあるセル座標を取得します。
     xlEndPoint    データやセル書式が設定されているセルのうち、最も下にあり、
                   かつ、最も右側にあるセル座標を取得します。

解説
x 座標は Size.Width プロパティに、y 座標は Size.Height プロパティにそれぞれ設定されます。
xlEndPoint 指定時、データが設定されているセルのうち最も下にあり、かつ、 最も右側にあるセル座標を取得します (青枠のセル座標)。
また、xlMaxPoint 指定時、データが設定されているセルのうち、 最下部のセルと最右部のセルが交わる地点にあるセル座標を取得します (青枠のセル座標)。
赤枠や黄緑枠のセル座標の取得は、MaxData メソッドを使用します。

参照
[MaxData メソッド]

コーディング例

データやセル書式が設定されているセルのエンドポイントを取得します。

[VB.NET]
Dim sz As System.Drawing.Size

XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'データやセル書式が設定されているセルの最終座標を取得します。
sz = XlsCreator1.MaxArea(XlsCrt.xlPoint.ptEndPoint)
MsgBox("x 座標:" + sz.Width.ToString() + " / y 座標:" + sz.Height.ToString())

XlsCreator1.CloseBook(True)

[C#]
System.Drawing.Size sz;

xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//データやセル書式が設定されているセルの最終座標を取得します。
sz = xlsCreator1.MaxArea(XlsCrt.xlPoint.ptEndPoint);
MessageBox.Show("x 座標:" + sz.Width.ToString() + " / y 座標:" + sz.Height.ToString());

xlsCreator1.CloseBook(true);


MaxData メソッド

- ExcelCreator .NET -
XlsCrt.MaxData メソッド

データ (文字列 / 値 / 計算式) が設定されているセルの最終座標を取得します。

書式

[VB.NET]
  Public Function MaxData(ByVal pt As XlsCrt.xlPoint) As System.Drawing.Size

[C#]
  public System.Drawing.Size MaxData(XlsCrt.xlPoint pt)

設定値

     定数          内容
     xlMaxPoint    データが設定されているセルのうち、最下部のセルと最右部のセル
                   が交わる地点にあるセル座標を取得します。
     xlEndPoint    データが設定されているセルのうち、最も下にあり、かつ、
                   最も右側にあるセル座標を取得します。

解説
x 座標は Size.Width プロパティに、y 座標は Size.Height プロパティにそれぞれ設定されます。
xlEndPoint 指定時、データが設定されているセルのうち最も下にあり、かつ、 最も右側にあるセル座標を取得します (黄緑枠のセル座標)。
また、xlMaxPoint 指定時、データが設定されているセルのうち、 最下部のセルと最右部のセルが交わる地点にあるセル座標を取得します (赤枠のセル座標)。
青枠のセル座標の取得は、MaxArea メソッドを使用します。

参照
[MaxArea メソッド]

コーディング例

データが設定されているセルのマックスポイントを取得します。

[VB.NET]
Dim sz As System.Drawing.Size

XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'データが設定されているセル座標を取得します。
sz = XlsCreator1.MaxData(XlsCrt.xlPoint.ptMaxPoint)
MsgBox("x 座標:" + sz.Width.ToString() + " / y 座標:" + sz.Height.ToString())

XlsCreator1.CloseBook(True)

[C#]
System.Drawing.Size sz;

xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//データが設定されているセル座標を取得します。
sz = xlsCreator1.MaxData(XlsCrt.xlPoint.ptMaxPoint);
MessageBox.Show("x 座標:" + sz.Width.ToString() + " / y 座標:" + sz.Height.ToString());

xlsCreator1.CloseBook(true);


ModeGrid プロパティ

- ExcelCreator .NET -
XlsCrt.ModeGrid プロパティ

グリッド線の表示/非表示の設定します。

書式

[VB.NET]
  Public WriteOnly Property ModeGrid() As Boolean

[C#]
  public bool ModeGrid [set]

設定値

      定数       内容
      True       グリッド線を表示する。(デフォルト値)
      False          〃      非表示にする。

コーディング例

シート内のグリッド線を非表示にします。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

XlsCreator1.ModeGrid = False    'グリッド線の非表示

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

xlsCreator1.ModeGrid = false;    //グリッド線の非表示

xlsCreator1.CloseBook(true);


OpenBook メソッド

- ExcelCreator .NET -
XlsCrt.OpenBook メソッド

既存ブックを読み書きにオープンします。

書式

[VB.NET]
  Public Function OpenBook(ByVal strFileName As String, ByVal strOverlay As String) As Integer

[C#]
  public System.Int32 OpenBook(System.String strFileName , System.String strOverlay)

設定値

    strFileName
      オープンするファイル名を文字列で設定します。
    strOverlay
      オーバーレイ元となるファイル名を文字列で設定します。
      省略時には "" を設定します。

解説
戻り値はメソッドが正常終了した場合には 0 以上の値を、それ以外の場合には 0 より小さい値を返します。
引数 strFileName のブックは、引数 strOverlay ブック全体の情報をコピーした 新たなブックとしてオープンします。
引数 strOverlay を省略した場合、引数 strFileName のブックをオープンします。
引数 strFileName のファイルは新規で作成されるため、既存のファイル名を設定した 場合は既存ファイルは上書きされます。
オーバーレイ元ブックにあらかじめ、変数文字やセルにセル名を設定している場合は、 変数文字やセル名を利用したセル指定で、文字列や値、属性の設定を行うこともできます。

参照
[CloseBook メソッド] | [OpenBookEx メソッド] | [OpenBookEmbed メソッド] | [OpenBookEmbedEx メソッド]

コーディング例

既存ファイルを開きます。

[VB.NET]
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")
XlsCreator1.Cell("D1").Long = 100    'D1 に 100 を設定します
XlsCreator1.CloseBook(True)

[C#]
//既存ファイルを開きます
xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");
xlsCreator1.Cell("D1").Long = 100;    //D1 に 100 を設定します
xlsCreator1.CloseBook(true);

オーバーレイ用としてファイルを開き、新たなファイルを作成します
オーバーレイ用として ExcelTemplate.xls を開き、
オーバーレイ用ファイル内の D1 セルに、100 と代入された
新たな ExcelFile.xls を作成します

[VB.NET]
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", Application.StartupPath & "\ExcelTemplate.xls")
XlsCreator1.Cell("D1").Long = 100
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", Application.StartupPath + @"\ExcelTemplate.xls");
xlsCreator1.Cell("D1").Long = 100;
xlsCreator1.CloseBook(true);

注意事項
・保護された Excel ファイルをオープンすることはできません。


OpenBookEmbed メソッド

- ExcelCreator .NET -
XlsCrt.OpenBookEmbed メソッド

リソースに埋め込まれたバイナリデータを既存ブックとしてオープンします。 あらかじめ変数文字を記述した既存のブックを元にブック内のシートに設定することもできます。

書式

[VB.NET]
  Public Function OpenBookEmbed(ByVal strFileName As String, ByVal stream As System.IO.Stream) As Integer
  Public Function OpenBookEmbed(ByVal strFileName As String, ByVal bytes() As Byte) As Integer

[C#]
  public System.Int32 OpenBookEmbed(System.String strFileName, System.IO.Stream stream)
  public System.Int32 OpenBookEmbed(System.String strFileName, byte[] bytes)

設定値

    strFileName
      オープンするファイル名を設定します。
    stream , bytes
      オーバーレイ元となるリソースに埋め込まれたバイナリデータを設定します。

解説
戻り値はメソッドが正常終了した場合には 0 以上の値を、それ以外の場合には 0 より小さい値を返します。
OpenBookEmbed でブックを作成した場合は、必ずCloseBook でクローズしてください。

引数 strFileName のブックは、引数 stream や bytes のブック全体の情報をコピーした 新たなブックとしてオープンします。
オーバーレイ元ブックにあらかじめ、変数文字やセルにセル名を設定している場合は、 変数文字やセル名を利用したセル指定で、文字列や値、属性の設定を行うこともできます。

参照
[CloseBook メソッド]
[埋め込みリソースのオーバーレイ]
[Excel ファイルをリソースとしてプロジェクトに登録・使用する]
[Excel ファイルを元にリソースファイルを作成しプロジェクトに登録・使用する]

注意事項
・保護された Excel ファイルをオープンすることはできません。


OpenBookEmbedEx メソッド

- ExcelCreator .NET -
XlsCrt.OpenBookEmbedEx メソッド

リソースに埋め込まれたバイナリデータを既存ブックとして扱い、既存ブック読み書きにオープンし、その識別 ID を取得します。

書式

[VB.NET]
  Public Function OpenBookEmbedEx(ByVal strFileName As String, ByVal bytes() As Byte, ByRef pID As System.UInt32) As Integer
  Public Function OpenBookEmbedEx(ByVal strFileName As String, ByVal stream As System.IO.Stream, ByRef pID As System.UInt32) As Integer

[C#]
  public System.Int32 OpenBookEmbedEx(System.String strFileName , System.IO.Stream stream , System.UInt32 pID)
  public System.Int32 OpenBookEmbedEx(System.String strFileName , byte[] bytes , System.UInt32 pID)

設定値

    stream , bytes
      オーバーレイ元となるリソースに埋め込まれたバイナリデータを設定します。
    pID
      作成するブックの識別 ID を取得する変数を設定します。

解説
戻り値はメソッドが正常終了した場合には 0 以上の値を、それ以外の場合には 0 より小さい値を返します。
一つの ExcelCreator 5.0 for .NET コンポーネントで複数のブックを作成する場合、 ブックの識別 ID を使用して操作の対象となるブックを SelectBook メソッドで切り 替え、その対象となるブックに対して入出力処理を行います。
OpenBookEmbedEx でブックを作成した場合は、必ずCloseBookEx でクローズしてください。

引数 strFileName のブックは、引数 stream や bytes のブック全体の情報をコピーした 新たなブックとしてオープンします。
オーバーレイ元ブックにあらかじめ、変数文字やセルにセル名を設定している場合は、 変数文字やセル名を利用したセル指定で、文字列や値、属性の設定を行うこともできます。

参照
[CloseBookEx メソッド] | [SelectBook メソッド]
[埋め込みリソースのオーバーレイ]
[Excel ファイルをリソースとしてプロジェクトに登録・使用する]
[Excel ファイルを元にリソースファイルを作成しプロジェクトに登録・使用する]

注意事項
・保護された Excel ファイルをオープンすることはできません。


OpenBookEx メソッド

- ExcelCreator .NET -
XlsCrt.OpenBookEx メソッド

既存ブックを読み書きにオープンし、その識別 ID を取得します。

書式

[VB.NET]
  Public Function OpenBookEx(ByVal strFileName As String, ByVal strOverlay As String, ByRef pID As System.UInt32) As Integer

[C#]
  public System.Int32 OpenBookEx(System.String strFileName, System.String strOverlay, System.UInt32 pID)

設定値

    strFileName
      オープンするファイル名を設定します。
    strOverlay
      オーバーレイ元となるファイル名を設定します。省略時には "" を設定します。
    pID
      作成するブックの識別 ID を取得する変数を設定します。

解説
戻り値はメソッドが正常終了した場合には 0 以上の値を、それ以外の場合には 0 より小さい値を返します。
一つの ExcelCreator 5.0 for .NET コンポーネントで複数のブックを作成する場合、 ブックの識別 ID を使用して操作の対象となるブックを SelectBook メソッドで切り 替え、その対象となるブックに対して入出力処理を行います。
OpenBookEx でブックを作成した場合は、必ずCloseBookEx でクローズしてください。

引数 strFileName のブックは、引数 strOverlay ブック全体の情報をコピーした 新たなブックとしてオープンします。
引数 strOverlay を省略した場合、引数 strFileName のブックをオープンします。
引数 strFileName のファイルは新規で作成されるため、既存のファイル名を設定した 場合は既存ファイルは上書きされます。
オーバーレイ元ブックにあらかじめ、変数文字やセルにセル名を設定している場合は、 変数文字やセル名を利用したセル指定で、文字列や値、属性の設定を行うこともできます。

参照
[CloseBookEx メソッド] | [OpenBookEmbed メソッド] | [OpenBookEmbedEx メソッド] | [SelectBook メソッド]

コーディング例

次のプログラムではオーバーレイ用としてファイルを開き、新たなファイルを作成します。
オーバーレイ用として ExcelTemplate.xls を開き、セルに値を設定した
新たなブック ExcelFile01.xls / ExcelFile02.xls を作成します。

[VB.NET]
Dim pID1 As UInt32
Dim pID2 As UInt32

' Excel ファイルのオーバーレイオープン時に、ID を設定します
XlsCreator1.OpenBookEx(Application.StartupPath & "\ExcelFile01.xls", _
   Application.StartupPath & "\ExcelTemplate.xls", pID1)
XlsCreator1.Cell("A5").Long = 50000

XlsCreator1.OpenBookEx(Application.StartupPath & "\ExcelFile02.xls", _
   Application.StartupPath & "\ExcelTemplate.xls", pID2)
XlsCreator1.Cell("C5").Long = 75000

' ファイルクローズ時に、オープンした ID を選択し閉じます
XlsCreator1.CloseBookEx(True, pID2)
XlsCreator1.CloseBookEx(True, pID1)

[C#]
uint pID1 = 0;
uint pID2 = 0;

// Excel ファイルのオーバーレイオープン時に、ID を設定します
xlsCreator1.OpenBookEx(Application.StartupPath + @"\ExcelFile01.xls",
    Application.StartupPath + @"\ExcelTemplate.xls", ref pID1);
xlsCreator1.Cell("A5").Long = 50000;

xlsCreator1.OpenBookEx(Application.StartupPath + @"\ExcelFile02.xls",
    Application.StartupPath + @"\ExcelTemplate.xls", ref pID2);
xlsCreator1.Cell("C5").Long = 75000;

// ファイルクローズ時に、オープンした ID を選択し閉じます
xlsCreator1.CloseBookEx(true, pID2);
xlsCreator1.CloseBookEx(true, pID1);

注意事項
・保護された Excel ファイルをオープンすることはできません。


PageMode メソッド

- ExcelCreator .NET -
XlsCrt.PageMode メソッド

シート毎のページ設定を行います。

書式

[VB.NET]
  Public Sub PageMode(ByVal pagemode As Integer, ByVal scale As Integer, ByVal orientation As Integer, ByVal headermargin As Integer, ByVal footermargin As Integer)

[C#]
  public void PageMode(System.Int32 pagemode , System.Int32 scale , System.Int32 orientation , System.Int32 headermargin , System.Int32 footermargin)

設定値

    pagemode        用紙の種類を示す値 [Integer 型] を設定します。
                    設定する値については、次の設定値を参照してください。
                    なお、省略時には、デフォルト値が設定されます。
    scale           拡大縮小印刷の割合 [Integer 型] を指定します。
                    縮小率として 10% まで、拡大率として 400% まで指定できます。
                    なお、省略時には -1 を指定します。デフォルト値が設定されます。
    orientation     用紙方向を指定 [Integer 型] します。
                    設定する値については、次の設定値を参照してください。
                    なお、省略時には -1 を指定します。デフォルト値が設定されます。
    headermargin    ヘッダーの余白を 1/10mm 単位 [Integer 型] で指定します。
                    なお、省略時には -1 を指定します。デフォルト値が設定されます。
    footermargin    フッタの余白を 1/10mm 単位 [Integer 型] で指定します。
                    なお、省略時には -1 を指定します。デフォルト値が設定されます。

    引数 pagemode の設定値は、次のとおりです。

      定数          値      内容
      psLetter       1      レター
      psRejoer       3      レジャー
      psRegal        5      リーガル
      psExecutive    7      エグゼクティブ
      psA3           8      Ａ３
      psA4           9      Ａ４(デフォルト値)
      psA5          11      Ａ５
      psB4          12      Ｂ４
      psB5          13      Ｂ５

    引数 orientation の設定値は次のとおりです。

      定数          値      内容
      orLandscape    0      横
      orPortrait     2      縦(デフォルト値)

解説
ページ余白を設定しない場合は、デフォルト値の上・下 ( 25 mm)、左・右 ( 20mm) の 設定となります。
ページ設定を行う場合、操作対象となるシートの変更を SheetNo プロパティで 行います。
Excel ファイルを、CreateBook メソッドや OpenBook メソッドで開いた場合に設定する ことができます。

参照
[CreateBook メソッド] | [OpenBook メソッド] | [SetMargin メソッド] | [SheetNo プロパティ]

コーディング例

シート毎にページ設定を行います

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath + "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2002)

XlsCreator1.SheetNo = 0
XlsCreator1.PageMode(13, 100, 2, -1, -1)    '用紙サイズ:B5、用紙方向:縦、余白:既定値

XlsCreator1.SheetNo = 1
XlsCreator1.PageMode(13, 100, 2, -1, -1)    '用紙サイズ:B5、用紙方向:縦、余白:既定値

XlsCreator1.SheetNo = 3
XlsCreator1.PageMode(9, 70, 0, 5, 5)        '用紙サイズ:A4、縮小率:70%、用紙方向:横、上下余白:5mm

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2002);

xlsCreator1.SheetNo = 0;
xlsCreator1.PageMode(13, 100, 2, -1, -1);    //用紙サイズ:B5、用紙方向:縦、余白:既定値

xlsCreator1.SheetNo = 1;
xlsCreator1.PageMode(13, 100, 2, -1, -1);    //用紙サイズ:B5、用紙方向:縦、余白:既定値

xlsCreator1.SheetNo = 3;
xlsCreator1.PageMode(9, 70, 0, 5, 5);        //用紙サイズ:A4、縮小率:70%、用紙方向:横、上下余白:5mm

xlsCreator1.CloseBook(true);


Pos プロパティ

- ExcelCreator .NET -
XlsCrt.Pos プロパティ

出力対象となるセルの範囲を座標形式で設定します。

書式

[VB.NET]
  Public Function Pos(ByVal sx As Integer, ByVal sy As Integer) As XlsCrt.XlsCell
  Public Function Pos(ByVal sx As Integer, ByVal sy As Integer, ByVal ex As Integer, ByVal ey As Integer) As XlsCrt.XlsCell

[C#]
  Public Function Pos(ByVal sx As Integer, ByVal sy As Integer) As XlsCrt.XlsCell
  Public Function Pos(ByVal sx As Integer, ByVal sy As Integer, ByVal ex As Integer, ByVal ey As Integer) As XlsCrt.XlsCell

設定値

    sx , sy
      対象セルの座標を設定します。
    ex , ey
      対象セルの範囲設定を行う場合、終了の座標を設定します。

解説
sx，ex には列を示す (0 ～ 255) の値を設定します。
sy，ey には行を示す (0 ～ 65535) の値を設定します。
Cell("A1:B2") = Pos(0,0,1,1) いずれも、対象セルは同じです。

Pos プロパティで範囲指定を行った場合、属性は設定した範囲に対して設定されます。 値の設定や取得については、設定したセル範囲内で先頭座標 (0,0) に最も近い座標が、 対象となります。
※「セル情報の設定と取得について (Pos プロパティの場合)」を参照してください。

参照
[Cell プロパティ]


ReadBook メソッド

- ExcelCreator .NET -
XlsCrt.ReadBook メソッド

既存ブックを読込み専用でオープンします。

書式

[VB.NET]
  Public Function ReadBook(ByVal strFileName As String) As Integer

[C#]
  public System.Int32 ReadBook(System.String strFileName)

設定値

    strFileName
      読込み専用でオープンするファイル名を文字列で設定します。

解説
戻り値はメソッドが正常終了した場合には 0 以上の値を、それ以外の場合には 0 より小さい値を返します。

参照
[CloseBook メソッド] | [ReadBookEx メソッド]

コーディング例

読込み用としてファイルを開きます。

[VB.NET]
Dim nLong As Long

'読み込み用としてファイルを開きます
XlsCreator1.ReadBook(Application.StartupPath & "\ExcelFile.xls")
nLong = XlsCreator1.Cell("D1").Long
XlsCreator1.CloseBook(True)

[C#]
long  nValue;

//読み込み用としてファイルを開きます
xlsCreator1.ReadBook(Application.StartupPath + @"\ExcelFile.xls");
nValue = xlsCreator1.Cell("D1").Long;
xlsCreator1.CloseBook(true);

注意事項
・保護された Excel ファイルをオープンすることはできません。
・ReadBook メソッドは読込み専用でブックをオープンするため、使用できるメソッドやプロパティに制限があります。


ReadBookEx メソッド

- ExcelCreator .NET -
XlsCrt.ReadBookEx メソッド

既存ブックを読込み専用でオープンし、その識別 ID を取得します。

書式

[VB.NET]
  Public Function ReadBookEx(ByVal strFileName As String, ByRef pID As System.UInt32) As Integer

[C#]
  public System.Int32 ReadBookEx(System.String strFileName, System.UInt32 pID)

設定値

    strFileName
      読込み専用でオープンするファイル名を設定します。
    pID
      作成するブックの識別 ID を取得する変数を設定します。

解説
戻り値はメソッドが正常終了した場合には 0 以上の値を、それ以外の場合には 0 より小さい値を返します。
一つの ExcelCreator 5.0 for .NET コンポーネントで複数のブックを作成する場合、 ブックの識別 ID を使用して操作の対象となるブックを SelectBook メソッドで切り 替え、その対象となるブックに対して入出力処理を行います。
ReadBookEx でブックを作成した場合は、必ずCloseBookEx でクローズしてください。

参照
[CloseBookEx メソッド] | [SelectBook メソッド]

コーディング例

次のプログラムでは読込み用としてファイルを開きます。

[VB.NET]
Dim pID1 As UInt32
Dim pID2 As UInt32
Dim lValue As Long

' Excel ファイル読み込み専用オープン時に、ID を設定します
XlsCreator1.ReadBookEx(Application.StartupPath & "\ExcelFile01.xls", pID1)
lValue = XlsCreator1.Cell("A1").Long

XlsCreator1.ReadBookEx(Application.StartupPath & "\ExcelFile02.xls", pID2)
lValue = XlsCreator1.Cell("C1").Long

' ファイルクローズ時に、オープンした ID を選択し閉じます
XlsCreator1.CloseBookEx(True, pID2)
XlsCreator1.CloseBookEx(True, pID1)

[C#]
uint pID1 = 0;
uint pID2 = 0;
long lValue;

// Excel ファイル読み込み専用オープン時に、ID を設定します
xlsCreator1.ReadBookEx(Application.StartupPath + @"\ExcelFile01.xls", ref pID1);
lValue = xlsCreator1.Cell("A1").Long;

xlsCreator1.ReadBookEx(Application.StartupPath + @"\ExcelFile02.xls", ref pID2);
lValue = xlsCreator1.Cell("C1").Long;

// ファイルクローズ時に、オープンした ID を選択し閉じます
xlsCreator1.CloseBookEx(true, pID2);
xlsCreator1.CloseBookEx(true, pID1);

注意事項
・保護された Excel ファイルをオープンすることはできません。
・ReadBookEx メソッドは、読込み専用でブックをオープンするため、使用できるメソッドやプロパティに制限があります。


RefSheet プロパティ

- ExcelCreator .NET -
XlsCrt.RefSheet プロパティ

参照するシート名を設定します。

書式

[VB.NET]
  Public WriteOnly Property RefSheet() As String

[C#]
  public string RefSheet [set]

設定値

    参照するシート名を文字列型で設定します。
    複数のシートを参照する場合には "/" スラッシュで区切って設定します。

解説
Func メソッドの指定セルに参照シートを含む場合には、必ず Func メソッドを設定する 前に参照されているシート名を設定してください。

参照
[Func メソッド] | [SheetName メソッド]

コーディング例

シートに対し各種設定を行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 4, XlsCrt.xlVersion.ver2003)

'操作対象となるシートを選択し(シートは0から数えるため
'下記では4番目のシートを選択します)、そのシートのシート名を設定し、
'A1セルに数値を書き込みます
XlsCreator1.SheetNo = 3                 '4 番目のシート(Sheet4)を操作対象シートとして選択
XlsCreator1.SheetName = "４月"          '4 番目のシート名を 4 月に設定します
XlsCreator1.Cell("A1").Long = 400       '4 番目のシート(4 月)のセル A1 に数値 400 を入れます

'操作対象となるシートを選択し
'(シートは 0 から数えるため下記では 1 番目のシートを選択します)、
'そのシートの A1 セルに数値を書き込みます
XlsCreator1.SheetNo = 0                 '1 番目のシート(Sheet1)を操作対象シートとして選択
XlsCreator1.Cell("A1").Long = 100       '1 番目のシート(Sheet1)セル A1 に数値 100 を入れます
XlsCreator1.RefSheet = "Sheet1/４月"    '計算式内にて使用する参照シート名を設定します
'1 番目のシート(Sheet1)セル A2 に関数を書き込みます(結果 500)
XlsCreator1.Cell("A2").Func("=SUM(Sheet1:４月!A1)", "")

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 4, XlsCrt.xlVersion.ver2003);

//操作対象となるシートを選択し(シートは0から数えるため
//下記では4番目のシートを選択します)、そのシートのシート名を設定し、
//A1セルに数値を書き込みます
xlsCreator1.SheetNo = 3;                 //4 番目のシート(Sheet4)を操作対象シートとして選択
xlsCreator1.SheetName = "４月";          //4 番目のシート名を 4 月に設定します
xlsCreator1.Cell("A1").Long = 400;       //4 番目のシート(4 月)のセル A1 に数値 400 を入れます

//操作対象となるシートを選択し
//(シートは 0 から数えるため下記では 1 番目のシートを選択します)、
//そのシートの A1 セルに数値を書き込みます
xlsCreator1.SheetNo = 0;                 //1 番目のシート(Sheet1)を操作対象シートとして選択
xlsCreator1.Cell("A1").Long = 100;       //1 番目のシート(Sheet1)セル A1 に数値 100 を入れます
xlsCreator1.RefSheet = "Sheet1/４月";    //計算式内にて使用する参照シート名を設定します
//1 番目のシート(Sheet1)セル A2 に関数を書き込みます(結果 500)
xlsCreator1.Cell("A2").Func("=SUM(Sheet1:４月!A1)", null);

xlsCreator1.CloseBook(true);


RowClear メソッド

- ExcelCreator .NET -
XlsCrt.RowClear メソッド

行をクリア (初期化) します。

書式

[VB.NET]
  Public Sub RowClear(ByVal sy As Integer, ByVal count As Integer)

[C#]
  public void RowClear(System.Int32 sy , System.Int32 count)

設定値

    sy
      クリアする開始行番号値 (0 ～) を設定します。
    count
      クリアする行数値 (1 ～) を設定します。

解説
引数 sy で指定された行から、引数 count の行数分をクリア (初期化) します。

コーディング例

行のクリア (初期化) を行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'指定行に対する行クリア(初期化)を行います。
'単一行のクリア(初期化)
XlsCreator1.RowClear(1, 0)     '2 行目から 1 行のみクリア(初期化)
'複数行のクリア(初期化)
XlsCreator1.RowClear(1, 2)     '2 行目から 2 行分クリア(初期化)

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//指定行に対する行クリア(初期化)を行います。
//単一行のクリア(初期化)
xlsCreator1.RowClear(1, 0);     //2 行目から 1 行のみクリア(初期化)
//複数行のクリア(初期化)
xlsCreator1.RowClear(1, 2);     //2 行目から 2 行分クリア(初期化)

xlsCreator1.CloseBook(true);


RowCopy メソッド

- ExcelCreator .NET -
XlsCrt.RowCopy メソッド

行をコピーします。

書式

[VB.NET]
  Public Sub RowCopy(ByVal sy As Integer, ByVal dy As Integer)

[C#]
  public void RowCopy(System.Int32 sy , System.Int32 dy)

設定値

    sy
      コピー元の行番号値 (0 ～) を設定します。
    dy
      コピー先の行番号値 (0 ～) を設定します。

解説
引数 sy で指定された行を、引数 dy の行へコピーします。
引数 dy に -1 を設定した時は、引数 sy で指定された行がメモリ上にコピーされます。 コピーした行は、RowPaste メソッドで設定した行に貼り付けることができます。

参照
[RowPaste メソッド]

コーディング例

行コピーと行の貼り付けを行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'指定行に対する行コピーと行の貼り付けを行います。
'コピー元を設定
XlsCreator1.Cell("A1").Func("=sum(B1:C1)", "")

'行コピー
XlsCreator1.RowCopy(0, 19)     '1 行目を 20 行目にコピー
'行の貼り付け
XlsCreator1.RowCopy(0, -1)     '1 行目をメモリ上にコピー
XlsCreator1.RowPaste(20)       'コピーされた行を 21 行目に貼り付け

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//指定行に対する行コピーと行の貼り付けを行います。
//コピー元を設定
xlsCreator1.Cell("A1").Func("=sum(B1:C1)", null);

//行コピー
xlsCreator1.RowCopy(0, 19);     //1 行目を 20 行目にコピー
//行の貼り付け
xlsCreator1.RowCopy(0, -1);     //1 行目をメモリ上にコピー
xlsCreator1.RowPaste(20);       //コピーされた行を 21 行目に貼り付け

xlsCreator1.CloseBook(true);

注意事項
・コピー元セルのセル属性と値のみコピーします。
・コピー元セルに変数名が設定されている場合、変数名はコピーされません。
・ブック間、シート間のコピー・貼り付けには対応しておりません。


RowDelete メソッド

- ExcelCreator .NET -
XlsCrt.RowDelete メソッド

行を削除します。

書式

[VB.NET]
  Public Sub RowDelete(ByVal sy As Integer, ByVal count As Integer)

[C#]
  public void RowDelete(System.Int32 sy , System.Int32 count)

設定値

    sy
      削除する開始行番号値 (0 ～) を設定します。
    count
      削除する行数値 (1 ～) を設定します。

解説
引数 sy で指定された行から、引数 count の行数分を削除します。

コーディング例

行削除を行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'指定行に対する行削除を行います。
'単一行の削除
XlsCreator1.RowDelete(1, 0)    '2 行目から 1 行のみ削除
'複数行の削除
XlsCreator1.RowDelete(1, 2)    '2 行目から 2 行分削除

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//指定行に対する行削除を行います。
//単一行の削除
xlsCreator1.RowDelete(1, 0);    //2 行目から 1 行のみ削除
//複数行の削除
xlsCreator1.RowDelete(1, 2);    //2 行目から 2 行分削除

xlsCreator1.CloseBook(true);

注意事項
・行削除を行っても、Excel シート上に設定されているオートシェイプや画像の位置は移動されません。


RowInsert メソッド

- ExcelCreator .NET -
XlsCrt.RowInsert メソッド

行を挿入します。

書式

[VB.NET]
  Public Sub RowInsert(ByVal sy As Integer, ByVal count As Integer)

[C#]
  public void RowInsert(System.Int32 sy , System.Int32 count)

設定値

    sy
      挿入する開始行番号値 (0 ～) を設定します。
    count
      挿入する行数値 (1 ～) を設定します。

解説
引数 sy で指定された行から、引数 count の行数分を挿入します。

コーディング例

行の挿入を行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'指定行に対する行挿入を行います。
'単一行の挿入
XlsCreator1.RowInsert(1, 0)    '2 行目から 1 行のみ挿入
'複数行の挿入
XlsCreator1.RowInsert(1, 2)    '2 行目から 2 行分挿入

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//指定行に対する行挿入を行います。
//単一行の挿入
xlsCreator1.RowInsert(1, 0);    //2 行目から 1 行のみ挿入
//複数行の挿入
xlsCreator1.RowInsert(1, 2);    //2 行目から 2 行分挿入

xlsCreator1.CloseBook(true);

注意事項
・行挿入を行っても、Excel シート上に設定されているオートシェイプや画像の位置は移動されません。


RowPaste メソッド

- ExcelCreator .NET -
XlsCrt.RowPaste メソッド

行へ貼り付けます。

書式

[VB.NET]
  Public Sub RowPaste(ByVal dy As Integer)

[C#]
  public void RowPaste(System.Int32 dy)

設定値

    dy
      貼り付けを行う行番号値 ( 0 ～) を設定します。

解説
RowCopy メソッドにより、メモリ上にコピーされた行を 引数 dy に貼り付けます。 元の行は上書きされます。

参照
[RowCopy メソッド]

コーディング例

行コピーと行の貼り付けを行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003)

'指定行に対する行コピーと行の貼り付けを行います。
'コピー元を設定
XlsCreator1.Cell("A1").Func("=sum(B1:C1)", "")

'行コピー
XlsCreator1.RowCopy(0, 19)     '1 行目を 20 行目にコピー
'行の貼り付け
XlsCreator1.RowCopy(0, -1)     '1 行目をメモリ上にコピー
XlsCreator1.RowPaste(20)       'コピーされた行を 21 行目に貼り付け

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2003);

//指定行に対する行コピーと行の貼り付けを行います。
//コピー元を設定
xlsCreator1.Cell("A1").Func("=sum(B1:C1)", null);

//行コピー
xlsCreator1.RowCopy(0, 19);     //1 行目を 20 行目にコピー
//行の貼り付け
xlsCreator1.RowCopy(0, -1);     //1 行目をメモリ上にコピー
xlsCreator1.RowPaste(20);       //コピーされた行を 21 行目に貼り付け

xlsCreator1.CloseBook(true);

注意事項
・コピー元セルのセル属性と値のみコピーします。
・コピー元セルに変数名が設定されている場合、変数名はコピーされません。
・ブック間、シート間のコピー・貼り付けには対応しておりません。


SelectBook メソッド

- ExcelCreator .NET -
XlsCrt.SelectBook メソッド

CreateBookEx、ReadBookEx、OpenBookEx、OpenBookEmbedEx でブックを操作する場合に、操作対象となるブックの選択を行います。

書式

[VB.NET]
  Public Sub SelectBook(ByVal uiID As System.UInt32)

[C#]
  public void SelectBook(System.UInt32 uiID)

設定値

    uiID
      操作対象とする識別 ID を設定します。

参照
[CreateBookEx メソッド] | [ReadBookEx メソッド] | [OpenBookEx メソッド] | [OpenBookEmbedEx メソッド] | [CloseBookEx メソッド]

コーディング例

次のプログラムでは選択対象ブックを変更しながら値設定を行います。

[VB.NET]
Dim pID1 As UInt32
Dim pID2 As UInt32

' Excel ファイル新規作成時に、ID を設定します
XlsCreator1.CreateBookEx(Application.StartupPath & "\ExcelFile01.xls", 1, XlsCrt.xlVersion.ver2003, pID1)
XlsCreator1.CreateBookEx(Application.StartupPath & "\ExcelFile02.xls", 1, XlsCrt.xlVersion.ver2003, pID2)

' 操作対象の ID を選択します
XlsCreator1.SelectBook(pID1)
XlsCreator1.Cell("A1").Value = 10000
XlsCreator1.SelectBook(pID2)
XlsCreator1.Cell("A5").Value = 18000

XlsCreator1.CloseBookEx(True, pID2)
XlsCreator1.CloseBookEx(True, pID1)

[C#]
uint pID1 = 0;
uint pID2 = 0;

// Excel ファイル新規作成時に、ID を設定します
xlsCreator1.CreateBookEx(Application.StartupPath + @"\ExcelFile01.xls", 1, XlsCrt.xlVersion.ver2003, ref pID1);
xlsCreator1.CreateBookEx(Application.StartupPath + @"\ExcelFile02.xls", 1, XlsCrt.xlVersion.ver2003, ref pID2);

// 操作対象の ID を選択します
xlsCreator1.SelectBook(pID1);
xlsCreator1.Cell("A1").Value = 10000;
xlsCreator1.SelectBook(pID2);
xlsCreator1.Cell("A5").Value = 18000;

xlsCreator1.CloseBookEx(true, pID2);
xlsCreator1.CloseBookEx(true, pID1);


SetMargin メソッド

- ExcelCreator .NET -
XlsCrt.SetMargin メソッド

シート単位にページ余白の設定を行います。

書式

[VB.NET]
  Public Sub SetMargin(ByVal left As Integer, ByVal right As Integer, ByVal top As Integer, ByVal bottom As Integer)

[C#]
  public void SetMargin(System.Int32 left , System.Int32 right , System.Int32 top , System.Int32 bottom)

設定値

    left      左余白を示す値を mm 単位 [Integer 型] で設定します。
              なお、省略時には -1 を設定します。デフォルト値が設定されます。
    right     右余白を示す値を mm 単位 [Integer 型] で設定します。
              なお、省略時には -1 を設定します。デフォルト値が設定されます。
    top       上余白を示す値を mm 単位 [Integer 型] で設定します。
              なお、省略時には -1 を設定します。デフォルト値が設定されます。
    bottom    下余白を示す値を mm 単位 [Integer 型] で設定します。
              なお、省略時には -1 を設定します。デフォルト値が設定されます。

解説
ページ余白の設定を行う場合、操作対象となるシートを、SheetNo プロパティで 設定します。設定を省略すると、ページ余白は、デフォルト値の上・下 (25mm)、 左・右 (20mm)になります。
Excel ファイルを、CreateBook メソッドや OpenBook メソッドで開いた場合に設定 することができます。

参照
[PageMode メソッド] | [SheetNo プロパティ]

コーディング例

ページ余白の設定を行います。

[VB.NET]
Xls1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2002)
Xls1.SetMargin(15, 10, 10, 10)
Xls1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 3, XlsCrt.xlVersion.ver2002);
xlsCreator1.SetMargin(15, 10, 10, 10);
xlsCreator1.CloseBook(true);


SheetCount プロパティ

- ExcelCreator .NET -
XlsCrt.SheetCount プロパティ

Excel ブックのシート総数を取得します。

書式

[VB.NET]
  Public ReadOnly Property SheetCount() As Integer

[C#]
  public int SheetCount [get]

コーディング例

 Excel ブック内のシート総数の取得を行ないます。

[VB.NET]
Dim nSheetCount As Integer

XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")

'Excel ブックのシート総数を取得します。
nSheetCount = XlsCreator1.SheetCount

XlsCreator1.CloseBook(True)

[C#]
Int32 nSheetCount;

xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");

//Excel ブックのシート総数を取得します。
nSheetCount = xlsCreator1.SheetCount;

xlsCreator1.CloseBook(true);


SheetName プロパティ

- ExcelCreator .NET -
XlsCrt.SheetName プロパティ

シート名の取得、または、設定します。

書式

[VB.NET]
  Public Property SheetName() As String

[C#]
  public string SheetName [get, set]

設定値

    半角文字数 1 ～ 31 文字で設定します。

参照
[SheetNo プロパティ] | [RefSheet プロパティ] | [CreateBook メソッド] | [OpenBook メソッド] | [ReadBook メソッド]

コーディング例

シートに対し各種の設定を行います。

[VB.NET]
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 4, XlsCrt.xlVersion.ver2003)
'操作対象となるシートを選択し
'(シートは 0 から数えるため下記では 4 番目のシートを選択します)、
'そのシートのシート名を設定し、A1 セルに数値を書き込みます
XlsCreator1.SheetNo = 3              '4 番目のシート (Sheet4) を操作対象シートとして選択
XlsCreator1.SheetName = "４月"       '4 番目のシート名を 4 月に設定します
XlsCreator1.Cell("A1").Long = 400    '4 番目のシート (4 月) のセル A1 に数値 400 を入れます
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 4, XlsCrt.xlVersion.ver2003);

//操作対象となるシートを選択し
//(シートは 0 から数えるため下記では 4 番目のシートを選択します)、
//そのシートのシート名を設定し、A1 セルに数値を書き込みます
xlsCreator1.SheetNo = 3;              //4 番目のシート(Sheet4)を操作対象シートとして選択
xlsCreator1.SheetName = "４月";       //4 番目のシート名を 4 月に設定します
xlsCreator1.Cell("A1").Long = 400;    //4 番目のシート( 4 月)のセル A1 に数値 400 を入れます

xlsCreator1.CloseBook(true);

シート名を取得し、メッセージボックスに表示します。

[VB.NET]
XlsCreator1.ReadBook(Application.StartupPath & "\ExcelFile.xls")
XlsCreator1.SheetNo = 0         '1 番目のシート(Sheet1)を操作対象シートとして選択
MsgBox(XlsCreator1.SheetName)   '1 番目のシート名を取得し、メッセージボックスに表示します
XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.ReadBook(Application.StartupPath + @"\ExcelFile.xls");
//1 番目のシート(Sheet1)を操作対象シートとして選択
xlsCreator1.SheetNo = 0;
//1 番目のシート名を取得し、メッセージボックスに表示します
MessageBox.Show(xlsCreator1.SheetName);

xlsCreator1.CloseBook(true);


SheetName2 プロパティ

- ExcelCreator .NET -
XlsCrt.SheetName2 プロパティ

設定したシート番号からシート名を取得します。

書式

[VB.NET]
  Public Function SheetName2(ByVal sheetno As Integer) As String

[C#]
  public System.String SheetName2(System.Int32 sheetno)

設定値

    sheetno
      シート番号を示す数値を設定します。

解説
シート番号にはブック内の左端のシートを 0 として、全シート数 - 1 まで設定する ことができます。

コーディング例

シート番号からシート名の取得を行います。

[VB.NET]
Dim strSheetName As String

XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")

'シート番号からシート名を取得します。
'シート番号 2 のシート名を取得します。
strSheetName = XlsCreator1.SheetName2(2)

XlsCreator1.CloseBook(True)

[C#]
string strSheetName;

xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");

//シート番号からシート名を取得します。
//シート番号 2 のシート名を取得します。
strSheetName = xlsCreator1.SheetName2(2);

xlsCreator1.CloseBook(true);


SheetNo プロパティ

- ExcelCreator .NET -
XlsCrt.SheetNo プロパティ

操作対象となるシートの選択を行います。

書式

[VB.NET]
  Public WriteOnly Property SheetNo() As Integer

[C#]
  public int SheetNo [set]

設定値

    操作対象とするシートを値で設定します。
    左端シートを 0 として、全シート数 - 1 まで設定することができます。

解説
既存ブックをオープンした場合には 0 が初期状態です。

参照
[SheetNo2 プロパティ]

コーディング例

シートに対し各種設定を行います。

[VB.NET]
'シートに対し各種の設定を行います
XlsCreator1.CreateBook(Application.StartupPath & "\ExcelFile.xls", 4, XlsCrt.xlVersion.ver2003)
'操作対象となるシートを選択し
'シートは 0 から数えるため下記では 4 番目のシートを選択します)、
'そのシートのシート名を設定し、A1 セルに数値を書き込みます
XlsCreator1.SheetNo = 3              '4 番目のシート (Sheet4) を操作対象シートとして選択
XlsCreator1.SheetName = "４月"       '4 番目のシート名を 4 月に設定します
XlsCreator1.Cell("A1").Long = 400    '4 番目のシート (4 月) のセル A1 に数値 400 を入れます
XlsCreator1.CloseBook(True)

'シート名を取得し、メッセージボックスに表示します。
'シート名を取得し、メッセージボックスに表示します
XlsCreator1.ReadBook(Application.StartupPath & "\ExcelFile.xls")
XlsCreator1.SheetNo = 0         '1 番目のシート (Sheet1) を操作対象シートとして選択
MsgBox(XlsCreator1.SheetName)   '1 番目のシート名を取得し、メッセージボックスに表示します
XlsCreator1.CloseBook(True)

[C#]
//シートに対し各種の設定を行います
xlsCreator1.CreateBook(Application.StartupPath + @"\ExcelFile.xls", 4, XlsCrt.xlVersion.ver2003);

//操作対象となるシートを選択し
//(シートは 0 から数えるため下記では 4 番目のシートを選択します)、
//そのシートのシート名を設定し、A1 セルに数値を書き込みます
xlsCreator1.SheetNo = 3;              //4 番目のシート(Sheet4)を操作対象シートとして選択
xlsCreator1.SheetName = "４月";       //4 番目のシート名を 4 月に設定します
xlsCreator1.Cell("A1").Long = 400;    //4 番目のシート( 4 月)のセルA1に数値400を入れます

xlsCreator1.CloseBook(true);

//シート名を取得し、メッセージボックスに表示します。
//シート名を取得し、メッセージボックスに表示します
xlsCreator1.ReadBook(Application.StartupPath + @"\ExcelFile.xls");

xlsCreator1.SheetNo = 0;         //1 番目のシート(Sheet1)を操作対象シートとして選択
MessageBox.Show(xlsCreator1.SheetName);   //1 番目のシート名を取得し、メッセージボックスに表示します

xlsCreator1.CloseBook(true);


SheetNo2 プロパティ

- ExcelCreator .NET -
XlsCrt.SheetNo2 プロパティ

設定したシート名からシート番号を取得します。

書式

[VB.NET]
  Public Function SheetNo2(ByVal sheetname As String) As Integer

[C#]
  public System.Int32 SheetNo2(System.String sheetname)

設定値

    sheetname
      シート番号を取得する元のシート名を示す文字列を設定します。
    sheetname
      設定したシート名がブックに存在しない場合、戻り値は -1 となります。

解説
シート番号は左端から 0 から数えた番号が取得されます。

コーディング例

シート名からシート番号の取得を行います。

[VB.NET]
Dim nSheetNo As Integer

XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")

'Excel ブックに対するシート名からシート番号を取得します。
'「Sheet3」のシート番号を取得します。
nSheetNo = XlsCreator1.SheetNo2("Sheet3")

XlsCreator1.CloseBook(True)

[C#]
Int32 nSheetNo;

xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");

//Excel ブックに対するシート名からシート番号を取得します。
//「Sheet3」のシート番号を取得します。
nSheetNo = xlsCreator1.SheetNo2("Sheet3");

xlsCreator1.CloseBook(true);


VarCheck プロパティ

- ExcelCreator .NET -
XlsCrt.VarCheck プロパティ

オーバーレイ元ファイルにある変数名をチェックします。

書式

[VB.NET]
  Public Function VarCheck(ByVal strVarName As String) As Boolean

[C#]
  public System.Boolean VarCheck(System.String strVarName)

設定値

    strVarName
      チェックする変数名を設定します。

解説
存在する場合は True、存在しない場合は False が返ります。

存在しない変数名に書式や値を設定するとエラーが発生するため、あらかじめ、 変数名が存在するか確認を行うことができます。

参照
[KeyWord プロパティ]

コーディング例

変数名をチェックして、データを差し込みます。

[VB.NET]
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", Application.StartupPath & "\ExcelTemplate.xls")

' セル変数がある時にデータを設定します
If XlsCreator1.VarCheck("**POST") = True Then
    XlsCreator1.Cell("**POST").Value = "918-8237"
End If
If XlsCreator1.VarCheck("**ADDRESS") = True Then
    XlsCreator1.Cell("**ADDRESS").Value = "福井県福井市和田東1丁目222番地"
End If

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", Application.StartupPath + @"\ExcelTemplate.xls");

// セル変数がある時にデータを設定します
if (xlsCreator1.VarCheck("**POST"))
    xlsCreator1.Cell("**POST").Value = "918-8237";
if (xlsCreator1.VarCheck("**ADDRESS"))
    xlsCreator1.Cell("**ADDRESS").Value = "福井県福井市和田東1丁目222番地";

xlsCreator1.CloseBook(true);


VarInsertMode プロパティ

- ExcelCreator .NET -
XlsCrt.VarInsertMode プロパティ

オーバーレイ元ファイルのセル変数名への差し込みモードを設定します。

書式

[VB.NET]
  Public WriteOnly Property VarInsertMode() As XlsCrt.xlVarInsertMode

[C#]
  public XlsCrt.xlVarInsertMode VarInsertMode [set]

設定値

    xlVarInsertMode 列挙体の定数で設定します。

    定数                値    内容
    vmValidAll           0    全ての変数名を対象 (デフォルト値)
    vmInvalidAnswer      1    計算結果の変数名は対象外
    vmInvalidTextBox     2    TextBox の変数名は対象外
    vmInvalidCellText    4    セルに直接設定した変数名は対象外

解説
オーバーレイ元ファイルのオープン前に設定してください。 オープン後に変更した場合は、次のオープン以降で有効になります。

参照
[KeyWord プロパティ]

コーディング例

セル変数名への差し込みモードを「セルに直接設定した変数名は対象外」に設定します。

[VB.NET]
' セル変数へのデータ設定を「セルに直接設定した変数名は対象外」とします
XlsCreator1.VarInsertMode = XlsCrt.xlVarInsertMode.vmInvalidCellText

XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", Application.StartupPath & "\ExcelTemplate.xls")

XlsCreator1.Cell("**TEXTBOX").Value = "テキストボックス"

XlsCreator1.CloseBook(True)

[C#]
// セル変数へのデータ設定を、「セルに直接設定した変数名は対象外」とします
xlsCreator1.VarInsertMode = XlsCrt.xlVarInsertMode.vmInvalidCellText;

xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", Application.StartupPath + @"\ExcelTemplate.xls");

xlsCreator1.Cell("**TEXTBOX").Value = "テキストボックス";

xlsCreator1.CloseBook(true);


Zoom プロパティ

- ExcelCreator .NET -
XlsCrt.Zoom プロパティ

シートの表示倍率を設定します。

書式

[VB.NET]
  Public WriteOnly Property Zoom() As Integer

[C#]
  public int Zoom [set]

設定値

    シートの表示倍率値 (10 ～ 400) を設定します。

コーディング例

シートの表示倍率を設定します。

[VB.NET]
XlsCreator1.OpenBook(Application.StartupPath & "\ExcelFile.xls", "")

'シートの表示倍率を設定するシート番号を設定します。
XlsCreator1.SheetNo = 0
'シートの表示倍率を設定します。
XlsCreator1.Zoom = 90    '90% に設定

XlsCreator1.CloseBook(True)

[C#]
xlsCreator1.OpenBook(Application.StartupPath + @"\ExcelFile.xls", "");

//シートの表示倍率を設定するシート番号を設定します。
xlsCreator1.SheetNo = 0;
//シートの表示倍率を設定します。
xlsCreator1.Zoom = 90;    //90% に設定

xlsCreator1.CloseBook(true);