ExcelWebForm の概要

[image]

ExcelWebForm
ExcelWebForm の概要

ExcelWebForm は、Excel シートの内容をダイレクトに HTML のテーブルに展開するアプリケーション、および、開発ツールです。

システム動作環境

ExcelWebForm の動作環境を説明します。

ExcelWebForm が対応する Excel の書式一覧

ExcelWebForm が対応する Excel の書式一覧を説明します。

製品のインストールとアンインストール

ExcelWebForm のインストールとアンインストールする方法を説明します。

サンプル

ExcelWebForm の付属サンプルを説明します。

アプリケーションの配布

アプリケーションを配布する方法を説明します。

ライセンス体系

ExcelWebForm のライセンス体系を説明します。

体験版について

ExcelWebForm の体験版について説明します。

サポートサービス

ExcelWebForm のサポートサービスを説明します。

ExcelWebForm ヘルプ フィードバック

このヘルプについてのご提案や障害報告をお送りいただく場合は、弊社 Web サイトの ユーザーサポートフォーム よりご連絡ください。

  • ドキュメントに表記されている会社名、製品名は一般に各社の商標または登録商標です。
  • 製品の仕様は品質改良の為、予告なく変更することがあります。

©2015 Advance Software inc. All rights reserved.


システム動作環境

[image]

ExcelWebForm
システム動作環境

ExcelWebForm の動作環境を次に示します。

このトピックは、次のセクションを含みます。

  • 開発環境
  • 実行環境
メモ:

開発、実行環境すべて日本語環境のみサポートします。

開発環境

OS

Windows Vista(SP2 以上) / Windows 7(SP1 以上) / Windows 8 / Windows 8.1 / / Windows 10 / Windows Server 2008(SP2 以上) / Windows Server 2008 R2(SP1 以上) / Windows Server 2012 / Windows Server 2012 R2

ハードディスク

100MB 以上の空き容量が必要です。

メモリ

1GB 以上の利用可能メモリが必要です。

Visual Studio

Visual Studio 2008 / 2010 / 2012 / 2013

開発言語

Visual Basic、Visual C＃

実行環境

OS

Windows Vista(SP2 以上) / Windows 7(SP1 以上) / Windows 8 / Windows 8.1 / Windows 10 / Windows Server 2008(SP2 以上) / Windows Server 2008 R2(SP1 以上) / Windows Server 2012 / Windows Server 2012 R2

.NET Framework

.NET Framework 3.5 (SP1 以上)

Microsoft Excel

Excel 2003 / 2007 / 2010 / 2013

Web ブラウザ

Internet Explorer 8 / 9 / 10 / 11


ExcelWebForm が対応する Excel の書式一覧

[image]

ExcelWebForm
ExcelWebForm が対応する Excel の書式一覧
ExcelWebForm が Excel シートから HTML テーブルに展開する際、対応する Excel の書式を一覧で表します。一覧に記載のない機能は基本的に ExcelWebForm の対応していない書式となります。詳細についてはサポートサービスよりお問い合わせください。

書式 / Excel メニュー対応一覧表

[○ = 対応、× = 未対応]

Excel 書式設定 (設定項目) | HTML 展開 (*1)
表示形式
表示形式 (分類 / 種類) | ○ (*2)
配置
横位置 (標準 / 左詰め / 中央揃え / 右詰め) | ○ (*3)
横位置 (繰り返し / 両端揃え / 選択範囲内で中央 / 均等割り付け) | ×
縦位置 (上詰め / 中央揃え / 下詰め) | ○
縦位置 (両端揃え / 均等割り付け) | ×
折り返して全体を表示する | ○
縮小して全体を表示する | ×
セルを結合する | ○
方向 (縦書き / -90~90 度) | ×
フォント
フォント名 | ○
フォントスタイル (標準 / 斜体 / 太字 / 太字斜体) | ○
フォントサイズ (1～409) | ○
下線 (なし / 下線) | ○
下線 (二重下線) | ×
フォントの色 | ○
文字飾り (取り消し線) | ○
文字飾り (上付き / 下付き) | ×
罫線
罫線 (上 / 下 / 左 / 右) | ○
罫線 (左上がり / 右上がり) | ×
線 (スタイル) | ○ (*4)
線 (色) | ○
塗りつぶし(パターン)
セルの塗りつぶしの色 | ○ (*5)
セルのパターン | ○

[○ = 対応、× = 未対応]

Excel メニュー (設定項目) | HTML 展開 (*1)
スタイル(書式)
条件付き書式 | ×
セル
行の高さ(高さ / 非表示) | ○
列の幅 (幅 / 標準の幅 / 非表示) | ○
図
図 | ○
図形 | ×
グラフ
グラフ | ×
テキスト
テキストボックス | ×
ヘッダー / フッター | ×
ワードアート | ×
テーマ
テーマ | ×
関数
ABS, AND, AVERAGE, CHOOSE, COLUMN, COLUMNS, CONCATENATE, COUNT, COUNTIF, EXACT, FIND, HLOOKUP, IF, INDEX, INDIRECT, INT, ISBLANK, ISERROR, LARGE, LEFT, LOOKUP, MATCH, MAX, MID, MIN, MOD, NOT, OFFSET, OR, PRODUCT, RANK, REPLACE, Right, ROUND, ROUNDDOWN, ROUNDUP, ROW, ROWS, SEARCH, SIGN, SMALL, Substitute, SUM, SUMIF, TRIM, TRUNC, VALUE, VLOOKUP | ○ (*6)
上記以外の関数 | ×
コメント
コメントの表示 | ×
保護
「シートの保護」が設定された Excel シートの HTML 変換 | ○
「ブックの保護」が設定された Excel ファイルのオープン | ○
パスワード
「読み取りパスワード」が設定された Excel ファイルのオープン | ×
メモ:
*1 対応する機能でも、Excel 上の描画と完全に一致するものではございません。
*2 HTML での編集では一部の数値書式のみ対応しています。
*3 インデントには対応しておりません。
*4 一部の罫線の種類は HTML 上で破線もしくは点線として表現されます。
*5 グラデーションには対応しておりません。
*6 ・Excel の計算式の四則演算( + / - * ^) の扱いが可能です。
・Excel の計算式の文字列連結子 ( & ) の扱いが可能です。
・Excel の計算式の比較演算子 ( =, >, <, >=, <=, <> ) の扱いが可能です。
・括弧による優先順位変更が可能です。
・関数内の関数の入れ子が可能です。
・計算式の指定がExcelと一部異なる場合があります。


製品のインストールとアンインストール

[image]

ExcelWebForm
製品のインストールとアンインストール

このトピックでは、ExcelWebForm のインストールで登録されるアセンブリ一覧、および、アンインストール方法を説明します。

このトピックは、次のセクションを含みます。

  • ExcelWebForm アセンブリ一覧
  • 製品のアンインストール

ExcelWebForm アセンブリ一覧

ExcelWebForm のインストールプログラムによって、グローバル アセンブリ キャッシュへ登録される DLL 一覧を以下に記載します。

グローバルアセンブリ名 | アセンブリファイル名
ExcelWebForm.Creator | ExcelWebForm.Creator.dll
ExcelWebForm.Document | ExcelWebForm.Document.dll
ExcelWebForm.HtmlControl | ExcelWebForm.HtmlControl.dll
ExcelWebForm.Html.Creator | ExcelWebForm.Html.Creator.dll
ExcelWebForm.Pdf.Creator | ExcelWebForm.Pdf.Creator.dll
ExcelWebForm.View | ExcelWebForm.View.dll
ExcelWebForm.Shared | ExcelWebForm.Shared.dll
ExcelWebForm.Xls.Core | ExcelWebForm.Xls.Core.dll
ExcelWebForm.Xlsx.Core | ExcelWebForm.Xlsx.Core.dll
メモ:

一覧にあるアセンブリは、ExcelWebForm インストールフォルダ内の Bin フォルダにインストールされます。

インストールプログラムによって登録されない場合は、「アプリケーションの配布」の [再配布可能ファイルの配置] にある方法でグローバル アセンブリ キャッシュへの登録を行ってください。

製品のアンインストール

本製品をアンインストールする場合、下記のいずれかの手順で対応してください。

スタートメニューからアンインストールするには

  1. [スタート] メニューの [プログラム] - [ExcelWebForm] - [アンインストール] をクリックします。

  2. 画面に従い、アンインストールを実行します。

「プログラムの追加と削除」からアンインストールするには

  1. [スタート] メニューの [コントロール パネル] をクリックします。

  2. [プログラムと機能] をクリックします。

  3. 一覧の [ExcelWebForm] を右クリックして、[アンインストールと変更] をクリックします。

  4. 画面に従い、アンインストールを実行します。

メモ:

インストール後に製品のファイルを移動した場合や、INSTALL.LOG ファイルを削除した場合、アンインストールされません。 また、製品に収録されているサンプル プロジェクトなど、Visual Studio によって作成、編集されたファイルについては、アンインストールできません。


サンプル

[image]

ExcelWebForm
サンプル

ExcelWebForm のサンプルについて説明します。

サンプル格納場所

サンプルの格納場所を説明します。

ExcelWeb Tool Ver2.0 サンプルを使用する

ExcelWeb Tool Ver2.0 サンプル (ToolSample) を使用する手順を説明します。

Web アプリケーションを配置する

Web サンプル (WebStandardSample) を使用して Web アプリケーションを配置する手順を説明します。


サンプルファイルの格納場所

[image]

ExcelWebForm
サンプルファイルの格納場所
参照

ExcelWebForm には、製品の動作を確認することが可能なサンプルが付属しています。

ExcelWebForm のサンプルファイルは、ExcelWeb Tool Ver2.0 のユーティリティで使用することのできるサンプル (ToolSample)、 Web アプリケーションで ExcelWebForm サーバーコントロールを使用したサンプル (WebStandardSample、WebDBSample) がインストールされます。 また、ExcelWebForm をアンインストールすると、サンプルファイルも削除されます。

サンプルファイルの既定の場所を以下の表に示します。 %install% は、ExcelWebForm のインストールフォルダ (C:\Program Files\ExcelWebForm\ など) を表します。

サンプルの種類 | サンプルの場所
ExcelWeb Tool Ver2.0 サンプル (ToolSample) | \%install%\Samples\ToolSample\Standard\
ExcelWeb Tool Ver2.0 サンプル (ToolSample) | \%install%\Samples\ToolSample\StationeryStock\
Visual Basic Web サンプル (WebStandardSample) | \%install%\Samples\WebSample\VB\WebStandardSample\
Visual Basic Web サンプル (WebDBSample) | \%install%\Samples\WebSample\VB\WebDBSample\
Visual C# Web サンプル (WebStandardSample) | \%install%\Samples\WebSample\CS\WebStandardSample\
Visual C# Web サンプル (WebDBSample) | \%install%\Samples\WebSample\CS\WebDBSample\

参照

ExcelWebForm の概要


アプリケーションの配布

[image]

ExcelWebForm
アプリケーションの配布

ExcelWebForm を使用して作成したアプリケーションを配布する場合、以下の再配布可能ファイルをアプリケーションと一緒に配布してください。

このトピックは、次のセクションを含みます。

  • 再配布可能ファイル
  • 再配布可能ファイルの格納場所
  • 再配布可能ファイルの配置
  • 再配布の条件

再配布可能ファイル

ファイル名 | 内容
ExcelWebForm.Creator.dll | Excel ファイル生成クラス
ExcelWebForm.Document.dll | ドキュメントクラス
ExcelWebForm.HtmlControl.dll | サーバーコントロールクラス
ExcelWebForm.Html.Creator.dll | テーブル生成クラス
ExcelWebForm.Pdf.Creator.dll | PDF 生成クラス
ExcelWebForm.View.dll | 描画クラス
ExcelWebForm.Shared.dll | 共有クラス
ExcelWebForm.Xls.Core.dll | Excel ファイル生成クラス (xls 形式)
ExcelWebForm.Xlsx.Core.dll | Excel ファイル生成クラス (xlsx 形式)
ExcelWebForm.Creator.resources.dll | 日本語対応リソース
ExcelWebForm.HtmlControl.resources.dll | 日本語対応リソース

再配布可能ファイルの格納場所

再配布可能ファイル (DLL) は、インストールフォルダ内の下記のフォルダに格納されます。

<%Install%>\Bin

メモ:
%install% は、ExcelWebForm のインストールフォルダ (C:\Program Files\ExcelWebForm\ など) を表します。

再配布可能ファイルの配置

再配布可能ファイル (DLL) は、以下のいずれかの方法で実行環境に配布します。

  • アプリケーションと同じフォルダに配置する
  • 下記の方法で再配布可能ファイルをグローバルアセンブリキャッシュ (GAC) へ登録する
注意:

登録および解除時は、Administrators グループのメンバとしてログオンする必要があります。

グローバルアセンブリキャッシュツール (gacutil.exe) で登録、解除をする

.NET Framework SDK のグローバルアセンブリキャッシュツール (gacutil.exe) を使用して登録します。 コマンドプロンプト、または「ファイル名を指定して実行」ダイアログボックスで以下のように実行します。

コピー登録例
C:\gacutil.exe /i "C:\Program Files\Application\ExcelWebForm.Html.Creator.dll"

登録例は、gacutil.exe が C ドライブのルートに存在し、ExcelWebForm の テーブル生成クラス (ExcelWebForm.Html.Creator.dll) が C:\Program Files\Application フォルダにあると仮定しています。 また、登録を解除する場合、以下のように実行します。

コピー解除例
C:\gacutil.exe /u "ExcelWebForm.Html.Creator"
ヒント:

登録の解除は、dll ファイル名ではなくアセンブリ名を指定します。

Windows エクスプローラ上で登録、解除をする

ExcelWebForm のアセンブリは、Windows エクスプローラ上で、グローバルアセンブリキャッシュ (例：\Windows\assembly) にドラッグ アンド ドロップすることが可能です。 なお、グローバルアセンブリキャッシュの登録や解除方法の詳細については、Visual Studio のオンラインヘルプを参照してください。

再配布の条件

著作権表示

本製品は、アドバンスソフトウェア株式会社が有する著作権により保護されております。
本製品を配布する際、可能な限り、アドバンスソフトウェアの著作権表示をしていただく必要があります。著作権表示は以下の通りに表示してください。

  • パッケージ (店頭などに配置する形態の製品の梱包物のこと) に対する表示方法
    本製品は、アドバンスソフトウェア株式会社の著作物である「ExcelWebForm」を再配布条件に基づき使用しています。
  • マニュアル、またはこれに類する物への表示方法
    本製品は、アドバンスソフトウェア株式会社の著作物である「ExcelWebForm」を再配布条件に基づき使用しています。
  • プログラム使用許諾契約書、またはこれに類する物への表示方法
    本製品は、アドバンスソフトウェア株式会社の著作物である「ExcelWebForm」を再配布条件に基づき使用しています。 アドバンスソフトウェア株式会社の著作物はバックアップの目的以外では一切の複写を許可しません。

    再配布先のサポート

    再配布先のサポートについては、一切行いません。サポートは再配布元であるお客様において行ってください。なお、サーバーライセンスを取得した配布先の弊社製品に関するサポートは、サーバーライセンスの保守契約が必要になります。サーバーライセンスの保守契約の詳細やお申し込みについては、「サポートサービス」よりお問い合わせください。

    • ©2015 Advance Software inc. All rights reserved.


ライセンス体系

[image]

ExcelWebForm
ライセンス体系

このトピックでは、ExcelWebForm のライセンス体系を説明します。ExcelWebForm は、ExcelWebForm を使用して作成したファイルやアプリケーションを配布する場合、サーバーライセンスが別途必要になります。

このトピックは、次のセクションを含みます。

  • ExcelWebForm サーバーライセンス Standard 版
  • ExcelWebForm サーバーライセンス Professional 版

ExcelWebForm サーバーライセンス Standard 版

ExcelWeb Tool Ver2.0 を使用して作成した HTML ファイルと JavaScript ファイルを配布して運用するサーバーに対し、ExcelWebForm サーバーライセンス Standard 版が必要です。

必要条件 | ExcelWeb Tool Ver2.0 を使用して作成した HTML ファイルと JavaScript ファイル配布して運用するサーバー環境(OS)数分、必要なライセンスです。
価格 | 1 ライセンスあたり / 120,000円 (税込 129,600円)
商品構成 | ライセンス数や契約内容を記載した契約書(ライセンス証書)のみになります。
保守 | 保守契約が必要となる場合、サーバーライセンス購入時にサーバーライセンス保守契約(年間)の購入が必要になります。
お問い合わせ | サーバーライセンス、サーバーライセンス保守契約のお申し込みやお問い合わせは、「サポートサービス」よりお問い合わせください。

ExcelWebForm サーバーライセンス Professional 版

ExcelWebForm サーバーコントロールを使用して作成したアプリケーションを配布して運用するサーバーに対し、ExcelWebForm サーバーライセンス Professional 版が必要です。

必要条件 | ExcelWebForm サーバーコントロールを使用して作成したサーバーアプリケーション(関連する機能を含む)を運用するサーバー環境(OS)数分、必要なライセンスです。
価格 | 1 ライセンスあたり / 240,000円 (税込 259,200円)
商品構成 | ライセンス数や契約内容を記載した契約書(ライセンス証書)のみになります。
保守 | 保守契約が必要となる場合、サーバーライセンス購入時にサーバーライセンス保守契約(年間)の購入が必要になります。
お問い合わせ | サーバーライセンス、サーバーライセンス保守契約のお申し込みやお問い合わせは、「サポートサービス」よりお問い合わせください。


体験版について

[image]

ExcelWebForm
体験版について

ExcelWebForm 体験版は、製品版と同様に全ての機能をお試しいただくことができますが、以下の制限事項がございます。

制限事項

  • 起動時に体験版であることを知らせるメッセージボックスが表示されます。製品版ではこのメッセージボックスは表示されません。
  • ExcelWeb Tool Ver2.0 で作成された HTML テーブル下部、および、ExcelWebForm サーバーコントロール下部に体験版であることを表すメッセージ文字列が出力されます。また、入力範囲は 10 列× 15 行に制限されます。
  • 体験版の DLL は実行環境での動作検証以外の目的で配布することはできません。

注意:

製品版をインストールする場合、体験版を必ずアンインストールしてからインストールを実行してください。


サポートサービス

[image]

ExcelWebForm
サポートサービス

本製品の Readme、および、ヘルプに記述されていない事項、または動作に関するご不明な点などについては、サポートサービスをご利用ください。

このトピックは、次のセクションを含みます。

  • お問い合わせについて
  • ユーザー登録について
  • お問い合わせいただく前に
  • お問い合わせ窓口

お問い合わせについて

ExcelWebForm 以外の事柄やプログラミング技法など一般的なご質問、または、動作保証環境外での使用によるご質問にはお答えいたしかねます。あらかじめ、ご了承ください。

ユーザー登録について

サポートサービスをご利用いただくにあたり、製品のユーザー登録が必要になります。 登録されていない場合は、サポートサービスを利用できませんので、お問合せいただく前に必ずユーザー登録を行ってください。 ユーザー登録は、製品に同梱されているユーザー登録カードに、必要事項を記入してご郵送いただくか、弊社 Web サイトの ユーザー登録ページ からもご登録いただくことができます。

お問い合わせいただく前に

サポートサービスでは下記の情報が必要になります。 お問い合わせいただく前に、あらかじめこれらの情報をご用意ください。 なお、弊社 Web サイトのサポート情報の内容により解決いただける場合もございます。 お問い合わせいただく前に、弊社 Web サイトの サポート情報 の内容をもう一度ご確認ください。

ユーザー情報

  1. ExcelWebForm のシリアルナンバー (製品パッケージ内「インストール情報」という用紙に記載されています。)
  2. 会社名
  3. 部署名
  4. 担当者名
  5. 連絡先 (電話番号)
  6. FAX 番号
  7. E-Mail アドレス

お問い合わせ内容

  1. 製品名
  2. ExcelWebForm の詳細バージョン
  3. 使用マシンの OS
  4. OS のサービスパック
  5. .NET Framework のバージョンとサービスパックのバージョン
  6. Visual Studio のバージョンとサービスパックのバージョン
  7. Excel のバージョンとサービスパックのバージョン
  8. アプリケーションを実行する Internet Explorer のバージョン

問題となっている現象の内容

  1. 現象の詳細内容
  2. 現象発生までの経緯
  3. 現象発生箇所
  4. 現象を再現できる簡単なプロジェクト一式、もしくは、コーディングの一部

お問い合わせ窓口

サポートサービスは、電話、FAX、E-Mail で受け付けております。 また、弊社 Web サイトの お問い合わせ窓口 では、ユーザーサポートフォームを用意しています。あわせてご確認ください。 月曜日～金曜日 (祝祭日、弊社特別休業日を除く) にご利用いただけます。 また、営業日以外にいただいた FAX / E-Mail でのお問い合わせは、翌営業日に回答いたします。

製品の操作方法や仕様に関するお問い合わせ窓口

電話番号 | 0776-21-9172
FAX 番号 | 0776-21-9022
E-Mail | excelwebform@adv.co.jp
受付時間 | 10：00 ～ 12：00 / 13：30 ～ 17：00

製品の営業に関するお問い合わせ窓口

電話番号 | 0776-21-9008
FAX 番号 | 0776-21-9022
E-Mail | info@adv.co.jp
受付時間 | 9：00 ～ 12：00 / 13：00 ～ 18：00


ExcelWeb Tool Ver2.0

[image]

ExcelWebForm
ExcelWeb Tool Ver2.0

ここでは、ExcelWeb Tool Ver2.0 の使用方法を説明します。

基本操作

ExcelWeb Tool Ver2.0 の基本操作を説明します。

ExcelWeb Tool Ver2.0 サンプルを使用する

ExcelWeb Tool Ver2.0 のサンプルを使用する方法を説明します


基本操作

[image]

ExcelWebForm
基本操作

ここでは、ExcelWeb Tool Ver2.0 の使用方法を説明します。ExcelWeb Tool Ver2.0 を使用して Excel ファイルから HTML ファイルへ変換する場合、以下の手順となります。

1. プロジェクトを作成する

ExcelWeb Tool Ver2.0 のプロジェクトを作成する方法を説明します。

2. 変換対象の Excel ファイルを追加する

ExcelWeb Tool Ver2.0 のプロジェクトに Excel ファイルを追加する方法を説明します。

3. 変換対象の Excel シートを設定する

HTML データへの変換対象となる Excel シートの設定する方法を説明します。

4. スキンを追加する

HTML データの挿入位置などの指定、HTML ファイルの作成を行うためのスキンを追加する方法を説明します。

5. HTML ファイルを作成する

指定した Excel シートを元に HTML データの変換を行い、HTML ファイルを作成する方法を説明します。

6. サーバーにファイルをアップロードする

作成後の HTML ファイルなどをサーバーにアップロードする方法を説明します。


プロジェクトを作成する

このトピックでは、ExcelWeb Tool Ver2.0 のプロジェクトの作成、保存、既存のプロジェクトの読み込み方法について説明します。

このトピックは、次のセクションを含みます。

  • プロジェクトを作成する
  • プロジェクトを保存する
  • 既存のプロジェクトを読み込む

プロジェクトを作成する

このセクションでは、ExcelWeb Tool Ver2.0 のプロジェクトを作成する方法について説明します。

  1. 画面上部メニューの [ファイル] から、[新しいプロジェクト] を選択します。

  2. プロジェクト名の設定、および、プロジェクトの場所を指定し、[OK] ボタンをクリックします。

  3. 画面左ペインに [Excel] [Skin] [Web] の3項目がツリー表示され、プロジェクトフォルダ内に同名のフォルダが作成されます。

プロジェクトを保存する

このセクションでは、編集中のプロジェクトを保存する方法について説明します。

  1. 画面上部メニューの [ファイル] から、[プロジェクトを保存] を選択します。

  2. プロジェクトの作成時に指定した [プロジェクトの場所] のフォルダにプロジェクトファイル (*.exwproj) が作成されます。

既存のプロジェクトを読み込む

このセクションでは、既存のプロジェクトを読み込む方法について説明します。

  1. 画面上部メニューの [ファイル] から、[プロジェクトを開く] を選択します。

  2. 任意のフォルダからプロジェクトファイル (*.exwproj) を開きます。

  3. 指定したプロジェクトが読み込まれます。


変換対象の Excel ファイルを追加する

[image]

ExcelWebForm
変換対象の Excel ファイルを追加する

このトピックでは、変換対象となる Excel ファイルの追加、削除、ファイル名の変更を行う方法について説明します。

このトピックは、次のセクションを含みます。

  • Excel ファイルを追加する
  • 新規に Excel ファイルを追加する
  • Excel ファイルを削除する
  • ファイル名を変更する

Excel ファイルを追加する

このセクションでは、変換対象の Excel シートを含む Excel ファイルをプロジェクトに追加する方法について説明します。

  1. 画面左ペインのツリー [Excel] をクリックして選択状態にします。

  2. 画面左ペイン上部の [image] ボタン、または、右クリックメニューより [既存のExcel Bookを追加] をクリックし、任意の Excel ファイルを指定します。
    また、既存の Excel ファイルをドラッグ アンド ドロップでツリー [Excel] に追加することもできます。

  3. ツリー [Excel] に指定した Excel ファイルのファイル名が表示され、ファイル名の下に各 Excel シートが表示されます。

新規に Excel ファイルを追加する

このセクションでは、新規に Excel ファイルをプロジェクトに追加する方法について説明します。

  1. 画面左ペインのツリー [Excel] をクリックして選択状態にします。

  2. 右クリックメニューより [新しい Excel Bookを追加] をクリックします。

  3. 新規に追加する Excel ファイルのファイル名、ファイル形式、Excel シート数を指定し、[OK] ボタンをクリックします。

  4. ツリー [Excel] に指定した Excel ファイルのファイル名が表示され、ファイル名の下に各 Excel シートが表示されます。

Excel ファイルを削除する

このセクションでは、Excel ファイルをプロジェクトから削除する方法について説明します。

  1. 画面左ペインのツリー [Excel] を展開し、プロジェクトに追加されている Excel ファイルのファイル名一覧を表示します。

  2. 削除する Excel ファイルを選択し、画面左上の [image] ボタン、または、右クリックメニューより [Excel Bookを削除] を選択します。

  3. ツリー [Excel] から対象の Excel ファイルが削除されます。
    また、プロジェクトフォルダの [Excel] フォルダ内からも Excel ファイルが削除されます。

ファイル名を変更する

このセクションでは、プロジェクトに追加された Excel ファイルのファイル名を変更する方法について説明します。

  1. 画面左ペインのツリー [Excel] を展開し、プロジェクトに追加されている Excel ファイルのファイル名一覧を表示します。

  2. 任意のファイルを選択後、右クリックメニューより [ファイル名を変更] をクリックしてファイル名を編集状態にし、任意のファイル名を設定します。

  3. ツリー [Excel] 内に表示される Excel ファイルのファイル名、および、プロジェクトフォルダの [Excel] フォルダ内に格納されている Excel ファイルのファイル名が変更されます。


変換対象の Excel シートを設定する

[image]

ExcelWebForm
変換対象の Excel シートを設定する

このトピックでは、HTML ファイルへの変換対象となる Excel シートの設定を行う方法について説明します。

このトピックは、次のセクションを含みます。

  • Excel シートの設定一覧
  • HTML ファイルへの変換有無を設定する
  • 作成する HTML ファイルのファイル名を設定する
  • HTML のキーワードを設定する
  • スキンファイル名を設定する
  • HTML のタイトルを設定する

Excel シートの設定一覧

  1. 画面左ペインのツリー [Excel] を展開し、表示された Excel ファイルの一覧から任意の Excel ファイルを展開します。

  2. 表示された Excel シートの一覧から任意の Excel シートを選択すると、画面右ペインに下記の設定項目が表示されます。

    Excel

    設定項目 | 説明
    シート名 | 選択した Excel シートのシート名が表示されます。

    HTML

    設定項目 | 説明
    HTML に変換 | HTML データへの変換有無を設定します。
    HTML ファイル名 | 作成後の HTML ファイルのファイル名を設定します。
    キーワード | HTML のキーワードを設定します。
    スキンファイル名 | HTML 変換時に使用するスキンを選択します。
    タイトル | HTML のタイトルを設定します。
    入力セル

    入力セルの制御を設定します。

    設定項目 | 説明
    NotEdit | すべてのセルの編集を許可しません。
    UnlockedCells | ロックされていないセルを入力可能にします。
    NamedCells | 名前つきのセルを入力可能にします。
    All | すべてのセルを入力可能にします。

HTML ファイルへの変換有無を設定する

このセクションでは、選択した Excel シートの HTML データへの変換有無を設定する方法について説明します。
プロジェクトに追加された Excel ファイル単位で変換を行う場合などに、変換対象から除外する Excel シートが含まれる場合に設定を行います。

  1. 画面左ペインのツリー [Excel] を展開し、設定を行う Excel シートを選択します。

  2. 画面右ペインの設定項目 [HTML に変換] の設定値を「False」に設定します。

作成する HTML ファイルのファイル名を設定する

このセクションでは、作成する HTML ファイルのファイル名を設定する方法について説明します。

  1. 画面左ペインのツリー [Excel] を展開し、設定を行う Excel シートを選択します。

  2. 画面右ペインの設定項目 [HTML ファイル名] の設定値に任意のファイル名を設定します。

  3. HTML 変換時に作成する HTML ファイルのファイル名に設定値が反映されます。

HTML のキーワードを設定する

このセクションでは、作成する HTML ファイルに対し、プロジェクトのスキンを使用してキーワードを設定する方法について説明します。
キーワードを設定するには使用するスキンにキーワード差込用の位置記号が配置されている必要があります。
スキンのキーワード差込用の位置記号についてはスキンを追加するをご確認ください。
また、キーワードは複数設定することも可能です。

  1. 画面左ペインのツリー [Excel] を展開し、設定を行う Excel シートを選択します。

  2. 画面右ペインの設定項目 [キーワード] の設定値に任意の文字列を設定します。
    ※複数のキーワードを設定する場合、カンマ区切りでキーワードを設定します。

スキンファイル名を設定する

このセクションでは、HTML データを元に HTML ファイルの作成を行うためのスキンを指定する方法を説明します。
指定するスキンは事前にプロジェクトに追加されている必要があります。
プロジェクトへのスキンの追加方法は、スキンを追加するをご確認ください。

  1. 画面左ペインのツリー [Excel] を展開し、設定を行う Excel シートを選択します。

  2. 画面右ペインの設定項目 [スキンファイル名] にプロジェクトに追加されているスキンのファイル名を指定します。

HTML のタイトルを設定する

このセクションでは、作成する HTML ファイルに対し、プロジェクトのスキンを使用してタイトルを設定する方法について説明します。
タイトルを設定するには使用するスキンにタイトル差込用の位置記号が配置されている必要があります。
スキンのタイトル差込用の位置記号についてはスキンを追加するをご確認ください。

  1. 画面左ペインのツリー [Excel] を展開し、設定を行う Excel シートを選択します。

  2. 画面右ペインの設定項目 [タイトル] の設定値に任意の文字列を設定します。


スキンを追加する

[image]

ExcelWebForm
スキンを追加する

このトピックでは、HTML データの挿入位置などの指定、HTML ファイルの作成を行うためのスキンをプロジェクトに追加する方法について説明します。

このトピックは、次のセクションを含みます。

  • スキンについて
  • 新しいスキンを追加する
  • 既存のスキンを追加する
  • スキンに対して行える設定の一覧
  • プロジェクトの既定のスキン、文字コードを設定する

スキンについて

このセクションでは、ExcelWeb Tool Ver2.0 のスキンについて説明します。

ExcelWeb Tool Ver2.0 では、Excel シートとプロジェクトに追加されたスキンにより HTML ファイルを作成します。
スキンの各種設定を元に、変換後の HTML データを反映させた多彩なレイアウトの HTML ファイルを作成する事が可能です。
また、既存の Web ページ(HTML、aspx ファイル等)に [キーワード位置記号]、[シート位置記号]、[タイトル位置記号] を追加する事で、ExcelWeb Tool Ver2.0 のスキンとして使用する事も可能です。

新しいスキンを追加する

このセクションでは、新しいスキンをプロジェクトに追加する方法について説明します。

  1. 画面左ペインのツリー [Skin] を選択します。

  2. 右クリックメニューより [新しいスキンを追加] をクリックし、追加するスキンのファイル名を入力します。

  3. ツリー [Skin] に新しいスキンが追加されます。

既存のスキンを追加する

このセクションでは、既存のスキン (テキストベース) をプロジェクトに追加する方法について説明します。

  1. 画面左ペインのツリー [Skin] を選択します。

  2. 画面左上の [image] ボタン、または、右クリックメニューより [既存のスキンを追加] をクリックし、任意のスキンファイルを指定します。
    または、任意の スキンファイルをドラッグ アンド ドロップでツリー [Skin] に追加します。

  3. ツリー [Skin] に指定したスキンが追加されます。

スキンに対して行える設定の一覧

画面左ペインのツリー [Skin] を展開し、表示されたスキンの一覧から任意のスキンを選択すると、画面右ペインに下記の設定項目が表示されます。

    スキン

    設定項目 | 説明
スキンファイル名 | 作成、読み込んだスキンのファイル名が表示されます
文字コード | スキンファイルの文字コードを指定することができます

    スキンの設定項目「文字コード」の設定値一覧

    設定項目 | 説明
Defalut (初期値) | プロジェクトの既定の文字コードが設定されます
Auto | HTML ファイルの内容により自動で設定されます
Shift_JIS | Shift_JIS に設定します
EUC-JP | EUC-JP に設定します
UTF-8 | UTF-8 に設定します

    置換

    設定項目 | 説明
キーワード位置記号 | 設定したキーワード記号の位置に、「HTML のキーワードを設定する」で設定した HTML のキーワードが置換されます
シート位置記号 | 設定したシート記号の位置に、Excel シートから変換された HTML のテーブルデータが置換されます
タイトル位置記号 | 設定したタイトル記号の位置に、「HTML のタイトルを設定する」で設定した HTML のタイトルが置換されます

プロジェクトの既定のスキン、文字コードを設定する

このセクションでは、プロジェクトの既定のスキン、文字コードを設定する方法について説明します。

  1. 画面上部メニューの [設定] から [プロジェクト] をクリックします。

  2. プロジェクトに追加されているスキンから任意のスキンを選択し、以下のリストからスキンファイルの文字コードを選択します。

    文字コード
    Shift_JIS (初期値)
    EUC-JP
    UTF-8

  3. [OK] ボタンをクリックします。


HTML ファイルを作成する

[image]

ExcelWebForm
HTML ファイルを作成する

このトピックでは、指定した Excel シートをから HTML データの変換を行い、HTML ファイルを作成する手順について説明します。
作成した HTML ファイルでは、各シートの「入力セル」で指定した内容に基づき、Excel シートを元に作成したテーブルデータを編集する事が可能です。なお、体験版では、編集可能な範囲は A1 セルから 10 列 * 15 行の範囲のセル (A1 セルから J15 セルまで) となります。

このトピックは、次のセクションを含みます。

  • Excel シート単位で HTML ファイルを作成する
  • ブック単位で HTML ファイルを作成する
  • プロジェクトに追加された全てのブックを元に HTML ファイルを作成する

Excel シート単位で HTML ファイルを作成する

このセクションでは、任意の Excel シートから HTML ファイルを作成する方法について説明します。

  1. 画面左ペインのツリー [Excel] を展開し、プロジェクトに追加されている Excel ファイルのファイル名一覧を表示します。

  2. 任意のファイル名を展開し、Excel シートの一覧を表示します。

  3. HTML データに変換する Excel シートを選択し、画面左上の [image] ボタン、または、右クリックメニューより [HTML に変換] をクリックします。

  4. HTML データへの変換が行われ、ツリー [Web] に変換後の HTML ファイルが追加されます。

ブック単位で HTML ファイルを作成する

このセクションでは、任意のブックに含まれる Excel シートから HTML ファイルを作成する方法について説明します。

  1. 画面左ペインのツリー [Excel] を展開し、プロジェクトに追加されている Excel ファイルのファイル名一覧を表示します。

  2. 任意の Excel ファイルを選択し、画面左上の [image] ボタン、または、右クリックメニューより [HTML に変換] をクリックします。

  3. 選択した Excel ファイル内の Excel シート (※) が HTML データに変換され、ツリー [Web] に変換後の HTML ファイルが追加されます。
    メモ:
    「HTML ファイルへの変換有無を設定する」で True に設定されている Excel シートのみ変換されます。

プロジェクトに追加された全てのブックを元に HTML ファイルを作成する

このセクションでは、プロジェクトに追加された全てのブック内の Excel シートをから HTML ファイルを作成する方法について説明します。

  1. 画面左ペインのツリー [Excel] を選択し、画面左上の [image] ボタン、または、右クリックメニューより [HTML に変換] をクリックします。

  2. プロジェクトに追加された全ての Excel ファイル内の Excel シート (※) が HTML データに変換され、ツリー [Web] に変換後の HTML ファイルが追加されます。
    メモ:
    「HTML ファイルへの変換有無を設定する」で True に設定されている Excel シートのみ変換されます。


サーバーにファイルをアップロードする

[image]

ExcelWebForm
サーバーにファイルをアップロードする

このトピックでは、作成した HTML ファイルなどをサーバーにアップロードする手順について説明します。

このトピックは、次のセクションを含みます。

  • アップロードの設定を行う
  • 指定したファイルのアップロードを行う

アップロードの設定を行う

このセクションでは、ファイルをアップロードする FTP サーバーの設定について説明します。

  1. 画面上部メニューの [設定] から、[ホスト] を選択します。

  2. [ホストアドレス] [ユーザー名] [パスワード] にアップロード対象のサーバーのホストアドレス、ユーザー名、パスワードを入力します。

  3. [ホストの転送先フォルダ] にファイルの転送先となるホストのフォルダを指定します。

  4. セキュリティソフトなどの影響でホストに接続できない場合、[パッシブモード] を使用します。

指定したファイルのアップロードを行う

このセクションでは、プロジェクトの [Web] フォルダ内のファイルをアップロードする方法について説明します。

  1. 画面左ペインのツリー [Web] を展開し、アップロードを行うファイルを選択します。

  2. 右クリックメニューから [Web にアップロード] をクリックします。


ExcelWeb Tool Ver2.0 サンプルを使用する

[image]

ExcelWebForm
ExcelWeb Tool Ver2.0 サンプルを使用する

製品収録の ExcelWeb Tool Ver2.0 用のサンプルプロジェクト (ToolSample) では、「Standard」「StationeryStock」の 2 種類のサンプルプロジェクトをご用意しております。サンプルプロジェクトでは、Excel シートのデータと HTML の雛形(スキン)を使用し、新しい HTML ファイルを作成しています。このトピックでは、サンプルプロジェクトの使用方法を説明します。

メモ:
サンプルプロジェクトの格納先については「サンプル」をご確認ください

このトピックは、次のセクションを含みます。

  • Standard サンプル
  • StationeryStock サンプル
  • HTML 内のコントロールについて

Standard サンプル

ここでは、サンプルプロジェクト「Standard」で動作を確認する手順について説明します。サンプルプロジェクトのプロジェクトフォルダには、予め ExcelWeb Tool Ver2.0 で作成済みの HTML ファイルが格納されています。

  1. ExcelWeb Tool Ver2.0 のサンプルプロジェクト「Standard」には、それぞれ下記のファイルが含まれています。

    Excel | 説明
    業務日報.xlsx | 変換元の Excel ファイルです
    業務日報 | HTML ファイル「業務日報.html」の元データとなるシートです
    顧客収益性分析.xlsx | 変換元の Excel ファイルです
    収益性分析 | HTML ファイル「収益性分析.html」の元データとなるシートです
    Skin | 説明
    skin.html | 変換した HTML テーブルを差し込む HTML の雛形(スキン)ファイルです
    Web | 説明
    images | 画像をを格納するフォルダです
    業務日報.html | シート「業務日報」と skin.html を元に作成した HTML ファイルです
    収益性分析.html | シート「収益性分析」と skin.html を元に作成した HTML ファイルです
    Scripts | ExcelWebForm に収録されている JavaScript の外部ファイルが格納されたフォルダです
    style.css | スタイルシートファイルです

  2. ExcelWeb Tool Ver2.0 を起動し、プロジェクトフォルダ「Standard」内のプロジェクトファイル「Standard.exwproj」を開きます。
    メモ:
    既存のプロジェクトを開く方法については「プロジェクトを作成する」をご確認ください

  3. 読み込まれたプロジェクトの [Web] を展開し、「業務日報.html」を選択します。

    読み込まれたプロジェクトの [Web] を展開し、「収益性分析.html」を選択します。

StationeryStock サンプル

ここでは、サンプルプロジェクト「StationeryStock」で動作を確認する手順について説明します。サンプルプロジェクトのプロジェクトフォルダには、予め ExcelWeb Tool Ver2.0 で作成済みの HTML ファイルが格納されています。

  1. ExcelWeb Tool Ver2.0 のサンプルプロジェクト「StationeryStock」には、それぞれ下記のファイルが含まれています。

    Excel | 説明
    在庫引当管理システム.xlsx | 変換元の Excel ファイルです
    キャンパスノート | HTML ファイル「campus.html」の元データとなるシートです
    ルーズリーフ | HTML ファイル「looseleaf.html」の元データとなるシートです
    メモパッド | HTML ファイル「memo.html」の元データとなるシートです
    Skin | 説明
    skin.html | 変換した HTML テーブルを差し込む HTML の雛形(スキン)ファイルです
    Web | 説明
    products | 作成後の HTML ファイルを格納するフォルダです
    campus.html | シート「キャンパスノート」と skin.html を元に作成した HTML ファイルです
    looseleaf.html | シート「ルーズリーフ」と skin.html を元に作成した HTML ファイルです
    memo.html | シート「メモパッド」と skin.html を元に作成した HTML ファイルです
    Scripts | ExcelWebForm に収録されている JavaScript の外部ファイルが格納されたフォルダです
    index.html | 作成後の HTML ファイルへのハイパーリンクを配置した HTML ファイルです
    style.css | スタイルシートファイルです

  2. ExcelWeb Tool Ver2.0 を起動し、プロジェクトフォルダ「StationeryStock」内のプロジェクトファイル「StationeryStock.exwproj」を開きます。
    メモ:
    既存のプロジェクトを開く方法については「プロジェクトを作成する」をご確認ください

  3. 読み込まれたプロジェクトの [Web] を展開し、「index.html」を選択します。Web ページのハイパーリンク「キャンパスノート」「ルーズリーフ」「メモパッド」をクリックすると、各 Excel シートを元に作成したそれぞれの HTML ファイルを確認することが可能です。また、各 Excel シートを元に作成されたテーブルに対して入力を行うことも可能です。

HTML 内のコントロールについて

当サンプルの HTML 内に配置されたボタンコントロールはイメージです。実際の動作をご確認いただくことはできません。
Excel ファイルへの書き込みや、編集ファイルのダウンロードの動作については、ExcelWebForm サーバーコントロールを使用したサンプルプログラム「WebSample」をご確認ください。

メモ:
サンプルプログラム「WebSample」の格納先については「サンプルファイルの格納場所」をご確認ください


ExcelWebForm サーバーコントロール

[image]

ExcelWebForm
ExcelWebForm サーバーコントロール

ここでは、ExcelWebForm サーバーコントロールの使用方法を説明します。

使用準備

ExcelWebForm サーバーコントロールを Web フォームで使用する方法を説明します。

基本操作

ExcelWebForm サーバーコントロールの基本操作を説明します。

Web アプリケーションを配置する

Web サンプル (WebStandardSample) を使用した Web アプリケーションの配置方法を説明します。

クラス ライブラリ リファレンス

ExcelWebForm のクラス ライブラリ リファレンスの一覧です。


使用準備

[image]

ExcelWebForm
使用準備

ここでは、ExcelWebForm サーバーコントロールを Web フォームで使用するための方法を説明します。

ツールボックスから ExcelWebForm サーバーコントロールを追加する

ツールボックスから ExcelWebForm サーバーコントロールを追加する方法を説明します。

HTML コードを記述して ExcelWebForm サーバーコントロールを追加する

HTML コードを記述して ExcelWebForm サーバーコントロールを追加する方法を説明します。

JavaScript の外部ファイルを追加する

JavaScript の外部ファイルを追加する方法を説明します。


ツールボックスから ExcelWebForm サーバーコントロールを追加する

[image]

ExcelWebForm
ツールボックスから ExcelWebForm サーバーコントロールを追加する

このトピックでは、Web フォームにツールボックスから ExcelWebForm サーバーコントロールを追加する手順について説明します。
ExcelWebForm サーバーコントロールの追加後、JavaScript の外部ファイルをプロジェクトに追加する必要があります。JavaScript の外部ファイルを追加する手順については「JavaScript の外部ファイルを追加する」をご覧ください。

  1. Visual Studio 上部メニューの [表示] から、[ツールボックス] をクリックします。

  2. ツールボックスにカーソルを合わせて右クリックし、[タブの追加] をクリックしてコントロールを追加するタブを作成します。この手順ではタブ名を 「AdvanceSoftware」 とします。

  3. 追加したタブにカーソルを合わせて上で右クリックし、[アイテムの選択] をクリックして [ツールボックス アイテムの選択] ダイアログを表示します。

  4. [.NET Framework コンポーネント] タブを選択し、次のチェックボックスをオンにして [OK] ボタンをクリックします。

  5. 次のコントロールが追加されます。

  6. 追加した ExcelWebForm サーバーコントロールを Web フォームにドラッグ アンド ドロップします。


HTML コードを記述して ExcelWebForm サーバーコントロールを追加する

[image]

ExcelWebForm
HTML コードを記述して ExcelWebForm サーバーコントロールを追加する

このトピックでは、参照設定に ExcelWebForm のアセンブリを追加し、HTML のコードで Web フォームに ExcelWebForm サーバーコントロールを追加する手順について説明します。
ExcelWebForm サーバーコントロールの追加後、JavaScript の外部ファイルをプロジェクトに追加する必要があります。JavaScript の外部ファイルを追加する手順については「JavaScript の外部ファイルを追加する」をご覧ください。

  1. ソリューションエクスプローラーの [参照設定] にカーソルを合わせ右クリックし、[参照の追加] をクリックします。

  2. [参照の追加] ウィンドウの [.NET] タブより、以下のアセンブリを選択し、[OK] ボタンをクリックします。

    コンポーネント名
    ExcelWebForm.Creator
    ExcelWebForm.Document
    ExcelWebForm.Html.Creator
    ExcelWebForm.HtmlControl
    ExcelWebForm.Pdf.Creator
    ExcelWebForm.View
    ExcelWebForm.Shared
    ExcelWebForm.Xls.Core
    ExcelWebForm.Xlsx.Core

  3. ソリューションエクスプローラーの [参照設定] に選択したアセンブリが追加されます。

  4. 追加されたアセンブリを選択し、プロパティウィンドウの [ローカルコピー] を [True] に設定することで、コンパイル時に ExcelWebForm のアセンブリがプロジェクトの Bin フォルダにコピーされます。

  5. ExcelWebForm サーバーコントロールを追加する Web フォームに、下記コードを記述します。

    コピーHTML
    <%@ Register assembly="ExcelWebForm.HtmlControl" namespace="AdvanceSoftware.ExcelWebForm" tagprefix="cc1" %>
    属性名 | 設定値
    assembly | ExcelWebForm.HtmlControl
    namespace | AdvanceSoftware.ExcelWebForm
    tagprefix | 任意

  6. <body> タグ配下の任意の位置に下記コードを記述する事で、ExcelWebForm サーバーコントロールが Web フォームに追加されます。

    コピーHTML
    <cc1:HtmlControl ID="HtmlControl1" runat="server" />


JavaScript の外部ファイルを追加する

[image]

ExcelWebForm
JavaScript の外部ファイルを追加する

このトピックでは、ExcelWebForm に収録されている JavaScript の外部ファイルをプロジェクトに追加する方法について説明します。
JavaScript の外部ファイルを追加する前に、ExcelWebForm サーバーコントロールを Web フォームに追加する必要があります。
ExcelWebForm サーバーコントロールの追加 手順については「ツールボックスから ExcelWebForm サーバーコントロールを追加する」または「HTML コードを記述して ExcelWebForm サーバーコントロールを追加する」をご覧ください。

  1. ExcelWebForm のインストールフォルダより、下記ファイル、および、フォルダをコピーし、プロジェクトの [Scripts] フォルダに格納します。

    JavaScript 外部ファイル、フォルダ名
    formula.js
    jquery-1.9.0.min.js
    tablecreator.js
    ui

  2. ソリューションエクスプローラーの [Scripts] を展開し、追加した JavaScript の外部ファイル、フォルダにカーソルを合わせ右クリックし、[プロジェクトに含める] をクリックします。

  3. HTML サーバーコントロールを呼び出す Web ページのソースを開き、<head> タグの配下に JavaScript の外部ファイル参照用のコードを記述します。

    コピーHTML
    <script type="text/javascript" src="Scripts/jquery-1.9.0.min.js"></script>
<script type="text/javascript" src="Scripts/ui/js/jquery-ui-1.10.0.custom.min.js"></script>
<script type="text/javascript" src="Scripts/ui/i18n/jquery.ui.datepicker-ja.js"></script>
<script type="text/javascript" src="Scripts/formula.js"></script>
<script type="text/javascript" src="Scripts/tablecreator.js"></script>


基本操作

[image]

ExcelWebForm
基本操作

ここでは、ExcelWebForm サーバーコントロールの基本操作を説明します。

オープンする Excel ファイルを指定する

ExcelWebForm サーバーコントロールでオープンする Excel ファイルを指定する方法を説明します。

表示する Excel シートを指定する

ExcelWebForm サーバーコントロールでオープンする Excel ファイルの使用するシートを指定する方法を説明します。

Excel、PDF ファイルを保存する

ExcelWebForm サーバーコントロール上で編集した内容を、Excel ファイルに書き込み保存する方法を説明します。

セルの編集を制限する

ExcelWebForm サーバーコントロール上でセルの編集制限を設定する方法を説明します。

テーブルの余白を設定する

ExcelWebForm サーバーコントロール上でテーブルの余白を設定する方法を説明します。

テーブルの表示倍率を設定する

ExcelWebForm サーバーコントロール上でテーブルの表示倍率を設定する方法を説明します。

セルを編集する

ExcelWebForm サーバーコントロール上でセルを編集する方法を説明します。

異なる Excel シートを参照する

ExcelWebForm サーバーコントロール上で異なる Excel シートのデータを参照する方法を説明します。

エラーを取得する

ExcelWebForm サーバーコントロールのエラーを取得する方法を説明します。


オープンする Excel ファイルを指定する

[image]

ExcelWebForm
オープンする Excel ファイルを指定する
参照

このトピックでは、ExcelWebForm サーバーコントロールで Excel ファイルをオープンする方法を説明します。ファイル名の指定には FileName プロパティを使用します。

次のコードは、"C:\Template\Book1.xlsx" に配置した Excel ファイルを指定するサンプルコードです。

コピーC#
HtmlControl1.FileName = @"C:\Template\Book1.xlsx";
コピーVB.NET
HtmlControl1.FileName = "C:\Template\Book1.xlsx"

参照

基本操作


表示するシートを指定する

[image]

ExcelWebForm
表示するシートを指定する
参照

このトピックでは、ExcelWebForm サーバーコントロール上で表示する Excel シートを指定する方法を説明します。 Excel シートを指定するには SheetNo プロパティにシート番号 (0～) を指定します。

次のコードは、SheetNo プロパティでシートを指定するサンプルコードです。

コピーC#
// 1シート目を指定します。
HtmlControl1.SheetNo = 0;
HtmlControl1.FileName = @"C:\Template\Book1.xlsx";
コピーVB.NET
' 1シート目を指定します。
HtmlControl1.SheetNo = 0
HtmlControl1.FileName = "C:\Template\Book1.xlsx"

参照

基本操作


Excel、PDF ファイルを保存する

[image]

ExcelWebForm
Excel、PDF ファイルを保存する
参照

このトピックでは、ExcelWebForm サーバーコントロールで Excel ファイルを保存する方法を説明します。Excel ファイルを保存するには Save メソッド、または、SaveAs メソッドを使用します。

このトピックは、次のセクションを含みます。

  • GetModifiedValues メソッドで、データの変更内容を取得する
  • Excel ファイルを保存する
  • 名前を付けて Excel、PDF ファイルを保存する
  • ストリームに Excel、PDF ファイルを保存する

GetModifiedValues メソッドで、データの変更内容を取得する

Save / SaveAs メソッドの引数には、tablecreator.js の GetModifiedValues メソッドで取得したデータの変更内容を指定する必要があります。 次のコードは、一時的にデータを保持する為の HiddenField を Web フォームに追加し、GetModifiedValues メソッドで取得したデータを設定するサンプルコードです。

コピーJavaScript
// tablecreator.js の GetModifiedValues メソッドでデータの変更内容を取得します。
document.getElementById("<%= HiddenField1.ClientID %>").value = excelcreatorTable.GetModifiedValues();

Excel ファイルを保存する

次のコードは、Save メソッドで Excel ファイルを保存するサンプルコードです。Save メソッドの引数には、GetModifiedValues メソッドで取得したデータの変更内容を指定します。また、Save メソッドでは、FileName プロパティで指定したテンプレートの Excel ファイルを上書き保存します。保存後の内容でテーブルの更新(リロード)を行う場合、第 2 引数に "true" を設定します。

コピーC#
HtmlControl1.Save(HiddenField1.Value, true);
コピーVB.NET
HtmlControl1.Save(HiddenField1.Value, True)

名前を付けて Excel、PDF ファイルを保存する

次のコードは、SaveAs メソッドで名前を付けて Excel ファイルを保存するサンプルコードです。SaveAs メソッドでは、第 1 引数に保存する Excel ファイルのファイル名、第 2 引数に保存する PDF ファイルのファイル名を指定します。保存後の内容でテーブルの更新(リロード)を行う場合、第 4 引数に "True" を設定します。

コピーC#
HtmlControl1.SaveAs(@"OutFile.xlsx", @"OutFile.pdf", HiddenField1.Value, true);
コピーVB.NET
HtmlControl1.SaveAs("OutFile.xlsx", "OutFile.pdf", HiddenField1.Value, True)

ストリームに Excel、PDF ファイルを保存する

次のコードは、SaveAs メソッドで名前を付けて Excel ファイルを保存するサンプルコードです。SaveAs メソッドでは、第 1 引数に保存する Excel ファイルのストリーム、第 2 引数に保存する PDF ファイルのストリームを指定します。保存後の内容でテーブルの更新(リロード)を行う場合、第 4 引数に "True" を設定します。

コピーC#
HtmlControl1.SaveAs(excelStream, pdfStream, HiddenField1.Value, true);
コピーVB.NET
HtmlControl1.SaveAs(excelStream, pdfStream, HiddenField1.Value, True)

参照

基本操作


セルの編集を制限する

[image]

ExcelWebForm
セルの編集を制限する
参照

ExcelWebForm サーバーコントロールは、EditMode プロパティでセルの編集を制限することが可能です。このトピックでは、EditMode プロパティの使用方法を説明します。

このトピックは、次のセクションを含みます。

  • セルの編集制限を設定する
  • 特定の名前が付けられたセルのみ編集を許可する

セルの編集制限を設定する

次のコードはセルの編集制限を設定するサンプルコードです。

コピーC#
// 全てのセルの編集を許可しません。
HtmlControl1.EditMode = AdvanceSoftware.ExcelWebForm.EditMode.NotEdit;
// ロックされていないセルのみ編集を許可します。
HtmlControl1.EditMode = AdvanceSoftware.ExcelWebForm.EditMode.UnlockedCells;
// 名前の付けられたセルのみ編集を許可します。
HtmlControl1.EditMode = AdvanceSoftware.ExcelWebForm.EditMode.NamedCells;
// すべてのセルの編集を許可します。
HtmlControl1.EditMode = AdvanceSoftware.ExcelWebForm.EditMode.All;
コピーVB.NET
' 全てのセルの編集を許可しません。
HtmlControl1.EditMode = AdvanceSoftware.ExcelWebForm.EditMode.NotEdit
' ロックされていないセルのみ編集を許可します。
HtmlControl1.EditMode = AdvanceSoftware.ExcelWebForm.EditMode.UnlockedCells
' 名前の付けられたセルのみ編集を許可します。
HtmlControl1.EditMode = AdvanceSoftware.ExcelWebForm.EditMode.NamedCells
' すべてのセルの編集を許可します。
HtmlControl1.EditMode = AdvanceSoftware.ExcelWebForm.EditMode.All

特定の名前が付けられたセルのみ編集を許可する

EditMode プロパティの設定値を "NamedCells" に設定した場合、名前の付けられたセルを全て編集することが可能となりますが、NamedCells プロパティに編集を許可するセル名を指定することで、指定した名前の付けられたセルのみ編集を行うことが可能となります。次のコードは、指定した名前を付けたセルのみ編集を行うサンプルコードです。

コピーC#
// 名前の付けられたセルのみ編集を許可します。
HtmlControl1.EditMode = AdvanceSoftware.ExcelWebForm.EditMode.NamedCells;
// 名前 "セル1" と "セル2" が付けられたセルのみ編集を許可します。
HtmlControl1.NamedCells = new string[] { "セル1", "セル2" };
コピーVB.NET
' 名前の付けられたセルのみ編集を許可します。
HtmlControl1.EditMode = AdvanceSoftware.ExcelWebForm.EditMode.NamedCells
' 名前 "セル1" と "セル2" が付けられたセルのみ編集を許可します。
HtmlControl1.NamedCells = new string() { "セル1", "セル2" }

参照

基本操作


テーブルの余白を設定する

[image]

ExcelWebForm
テーブルの余白を設定する
参照

このトピックでは、テーブルの余白を設定する方法を説明します。Margin プロパティには System.Drawing.Rectangle クラスを設定します。

次のコードは、Margin プロパティで余白を設定するサンプルコードです。

コピーC#
// テーブルの余白を設定します。
// テーブルの左余白 = 100 ピクセル
// テーブルの上余白 = 100 ピクセル
// テーブルの右余白 = 200 ピクセル
// テーブルの下余白 = 200 ピクセル
// ※Rectangle の設定値の単位は Graphics クラスの PageUnit/PageScale プロパティに依存します。
// 詳細は MSDN など、開発元の情報をご確認ください。
HtmlControl1.Margin = new System.Drawing.Rectangle(100, 100, 200, 200);
HtmlControl1.SheetNo = 0;
HtmlControl1.FileName = @"C:\Template\Book1.xlsx";
コピーVB.NET
' テーブルの余白を設定します。
' テーブルの左余白 = 100 ピクセル
' テーブルの上余白 = 100 ピクセル
' テーブルの右余白 = 200 ピクセル
' テーブルの下余白 = 200 ピクセル
' ※Rectangle の設定値の単位は Graphics クラスの PageUnit/PageScale プロパティに依存します。
' 詳細は MSDN など、開発元の情報をご確認ください。
HtmlControl1.Margin = new System.Drawing.Rectangle(100, 100, 200, 200)
HtmlControl1.SheetNo = 0
HtmlControl1.FileName = "C:\Template\Book1.xlsx"

参照

基本操作


テーブルの表示倍率を設定する

[image]

ExcelWebForm
テーブルの表示倍率を設定する
参照

このトピックでは、ExcelWebForm サーバーコントロール上で表示するテーブルの表示倍率を設定する方法を説明します。表示倍率を設定するには Scale プロパティに数値を設定します。

次のコードは Scale プロパティで表示倍率を設定するサンプルコードです。

コピーC#
// 表示倍率を 200% に設定します。
HtmlControl1.Scale = 200;
HtmlControl1.SheetNo = 0;
HtmlControl1.FileName = @"C:\Template\Book1.xlsx";
コピーVB.NET
' 表示倍率を 200% に設定します。
HtmlControl1.Scale = 200
HtmlControl1.SheetNo = 0
HtmlControl1.FileName = "C:\Template\Book1.xlsx"

参照

基本操作


セルを編集する

[image]

ExcelWebForm
セルを編集する
参照

このトピックでは、ExcelWebForm サーバーコントロール上でセルの編集をする方法を説明します。

このトピックは、次のセクションを含みます。

  • セルに値を直接設定する
  • 入力規則のリストから値を選択する
  • セルに日付を設定する

セルに値を直接設定する

ここでは、ExcelWebForm サーバーコントロール上からセルに値を入力する手順について説明します。

  1. コントロール上の任意のセルをクリックし、編集状態にします。

  2. 編集状態のセルに任意の値を入力します。

    ※値の入力は、EditMode プロパティで編集が許可されているセルのみ可能です。

入力規則のリストから値を選択する

ここでは、ExcelWebForm サーバーコントロール上の入力規則のリストから値を選択する方法について説明します。

  1. 入力規則(リスト) が設定されているセルを選択します。

  2. ExcelWebForm サーバーコントロール上に、入力規則に設定された値の選択ができるリストが表示されます。

  3. リストから任意の値を選択します。

    ※値の入力は、EditMode プロパティで編集が許可されているセルのみ可能です。

セルに日付を設定する

ここでは、ExcelWebForm サーバーコントロール上からセルに日付を入力する手順について説明します。

  1. 予め、セルの表示形式が「日付」に指定されているセルをクリックし、編集状態にします。

  2. ExcelWebForm サーバーコントロール上にカレンダーが表示される為、任意の年月日を指定します。

  3. 選択した日付が設定されます。
    ※値の入力は、EditMode プロパティで編集が許可されているセルのみ可能です。

DateFormat 列挙体のメンバ一覧

ExcelWebForm では DateFormat プロパティに DateFormat 列挙体のメンバを指定することで、日付の表示形式を下記の 3 種類の形式から選択することが可能です。

メンバ名 | 説明
Slash (初期値) | スラッシュ区切りで日付を表示します (例 : 2013/01/01)
Japanese | 年月日区切りで日付を表示します (例 : 2013年01月01日)
Hyphen | ハイフン区切りで日付を表示します (例 : 2013-01-01)

参照

基本操作


異なる Excel シートを参照する

[image]

Excel to HTML
異なる Excel シートを参照する
参照

このトピックでは、別シートの参照を含む計算式が存在する場合に、参照先の Excel シートを指定する方法について説明します。

次のコードは RefSheets プロパティにより参照先の Excel シートを選択するサンプルコードです。

コピーC#
HtmlControl1.SheetNo = 0;
// シート "Sheet2"、"Sheet3" のデータを参照します。
HtmlControl1.RefSheets = new string[] { "Sheet2", "Sheet3" };
HTMLControl1.FileName = @"C:\Template\Book1.xls";
コピーVB.NET
HtmlControl1.SheetNo = 0
' シート "Sheet2"、"Sheet3" のデータを参照します。
HtmlControl1.RefSheets = new string() { "Sheet2", "Sheet3" }
HTMLControl1.FileName = "C:\Template\Book1.xls"

参照

基本操作


エラーを取得する

[image]

ExcelWebForm
エラーを取得する
参照

このトピックでは、ExcelWebForm のエラーを取得する方法を説明します。エラーを取得する場合、ErrorNo プロパティを使用します。

次のコードは、ErrorNo プロパティでエラーを取得するサンプルコードです。

コピーC#
HtmlControl1.FileName = @"C:\Template\Book1.xlsx";
// ファイルオープン時にエラーが発生した場合、ラベルにエラーを表示します。
if (HtmlControl1.ErrorNo != 0)
{
    label1.text = HtmlControl1.ErrorNo.ToString;
}
コピーVB.NET
HtmlControl1.FileName = "C:\Template\Book1.xlsx"
' ファイルオープン時にエラーが発生した場合、ラベルにエラーを表示します。
If HtmlControl1.ErrorNo <> 0 Then
    label1.text = HtmlControl1.ErrorNo.ToString
End If

参照

基本操作


Web アプリケーションを配置する

[image]

ExcelWebForm
Web アプリケーションを配置する
参照

Web アプリケーションの配置について、ExcelWebForm サーバーコントロールが組み込まれた Web サンプル (WebStandardSample) を使用した手順を以下に示します。

Caution note 注意:

このトピックの手順で Web アプリケーションを配置する場合、ローカル コンピュータに インターネット インフォメーション サービス (IIS) がインストールされている必要があります。また、ローカル コンピュータの Administrators グループのメンバとしてログオンするか、適切な権限が委任されている必要があります。

IIS マネージャを起動して Web アプリケーションの仮想ディレクトリを作成します。

[ファイル名を指定して実行] から IIS マネージャを起動するには

  1. [スタート] メニューの [ファイル名を指定して実行] をクリックします。

  2. [名前] ボックスに "inetmgr" と入力して [OK] ボタンをクリックします。

[管理ツール] から IIS マネージャを起動するには

  1. [スタート] メニューの [コントロール パネル] をクリックします。

  2. [管理ツール] 内の [インターネット インフォメーション サービス] をクリックします。

仮想ディレクトリを作成するには (IIS 7.5)

  1. 次の Web サンプルのインストールフォルダ内に格納されているソリューションファイル (WebStandardSample.sln) からプロジェクトを開き、Visual Studio 上でサンプルをビルドします。

    Visual Basic
    \%install%\Samples\WebSample\VB\WebStandardSample
    Visual C#
    \%install%\Samples\WebSample\CS\WebStandardSample
    Note メモ:

    %install% は、ExcelWebForm のインストールフォルダ (C:\Program Files\ExcelWebForm\ など) を表します。

  2. IIS マネージャで、仮想ディレクトリを追加するローカル コンピュータおよび Web サイトを展開します。仮想ディレクトリを作成するサイトまたはフォルダを右クリックし、[仮想ディレクトリの追加] をクリックして、[仮想ディレクトリの追加] 画面を表示します。

  3. [エイリアス] ボックスに、仮想ディレクトリの名前 "ExcelWebForm" を入力します。

  4. [物理パス] ボックスのボタン ( ボタン02) をクリックして、[フォルダの参照] 画面を表示します。

  5. 次の Web サンプルのインストールフォルダを選択して [OK] ボタンをクリックします。

    Visual Basic
    \%install%\Samples\WebSample\VB\WebStandardSample
    Visual C#
    \%install%\Samples\WebSample\CS\WebStandardSample
    Note メモ:

    %install% は、ExcelWebForm のインストールフォルダ (C:\Program Files\ExcelWebForm\ など) を表します。

  6. 追加した仮想ディレクトリ "ExcelWebForm" を右クリックして、[アプリケーションへの変換] をクリックします。

  7. [アプリケーションの追加] 画面の [OK] ボタンをクリックします。

  8. IIS マネージャを終了します。

参照

サンプル


クラス ライブラリ リファレンス

[image]

ExcelWebForm
クラス ライブラリ リファレンス
このクラス ライブラリは、ExcelWebForm に含まれているクラス、インターフェイス、および値型のライブラリです。ExcelWebForm のアプリケーションを作成する場合の基礎となるようにデザインされています。

名前空間

名前空間 | 説明
AdvanceSoftware.ExcelWebForm | AdvanceSoftware.ExcelWebForm 名前空間には、Web フォーム用の ExcelWebForm サーバーコントロールが含まれています。


AdvanceSoftware.ExcelWebForm 名前空間

[image]

ExcelWebForm
AdvanceSoftware.ExcelWebForm 名前空間
AdvanceSoftware.ExcelWebForm 名前空間には、Web フォーム用の ExcelWebForm サーバーコントロールが含まれています。

クラス

 | クラス | 説明
Public class | CellNameCollection | CellNameCollection クラス
Public class | CellPosition | セル位置を扱う CellPosition クラスです。
Public class | CellPositionCollection | セル位置を配列で管理する CellPositionCollection クラス
Public class | CellValue | CellValue クラス
Public class | CellValueCollection | CellValueCollection クラス
Public class | HtmlCellValue | HtmlCellValue クラス
Public class | HtmlControl | HtmlControl クラス
Public class | PdfProperty | PDF 出力のプロパティを設定します。HtmlControl オブジェクトを通じてこのクラスにアクセスします。

列挙体

 | 列挙体 | 説明
Public enumeration | DateFormat | 日付フォーマットを示す識別子を指定します。
Public enumeration | EditMode | セルの編集モードを示す識別子を指定します。
Public enumeration | ErrorNo | エラーナンバーを示す識別子を指定します。
Public enumeration | FormulaMode | 計算式の扱い方を示す識別子を指定します。
Public enumeration | ImageType | イメージタイプを示す識別子を指定します。
Public enumeration | PdfEncryptionType | PdfEncryptionType
Public enumeration | PdfPermit | PdfPermit
Public enumeration | StreamMode | データを展開するストリームモードを示す識別子を指定します。


CellNameCollection クラス

[image]

ExcelWebForm
CellNameCollection クラス
メンバ 参照
CellNameCollection クラス

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public class CellNameCollection : List<CellPositionCollection>
Visual Basic (宣言)
Public Class CellNameCollection _
    Inherits List(Of CellPositionCollection)

継承階層

System..::..Object
System.Collections.Generic..::..List <(Of <(<' CellPositionCollection >)>)>
AdvanceSoftware.ExcelWebForm..::..CellNameCollection

参照

CellNameCollection メンバ
AdvanceSoftware.ExcelWebForm 名前空間


CellNameCollection メンバ

[image] [image]

ExcelWebForm
CellNameCollection メンバ
CellNameCollection クラス コンストラクタ 参照

CellNameCollection データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | CellNameCollection | Initializes a new instance of the CellNameCollection class

参照

CellNameCollection クラス


CellNameCollection コンストラクタ

[image]

ExcelWebForm
CellNameCollection コンストラクタ
CellNameCollection クラス 参照
Initializes a new instance of the CellNameCollection class

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public CellNameCollection()
Visual Basic (宣言)
Public Sub New

参照

CellNameCollection クラス


CellPosition クラス

[image]

ExcelWebForm
CellPosition クラス
メンバ 参照
セル位置を扱う CellPosition クラスです。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.Shared (ExcelWebForm.Shared.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public class CellPosition
Visual Basic (宣言)
Public Class CellPosition

継承階層

System..::..Object
AdvanceSoftware.ExcelWebForm..::..CellPosition

参照

CellPosition メンバ


CellPosition メンバ

[image] [image]

ExcelWebForm
CellPosition メンバ
CellPosition クラス プロパティ 参照

CellPosition データ型で公開されるメンバを以下に示します。

プロパティ

 | 名前 | 説明
Public property | CellString | セル位置を示す文字列を取得します。
Public property | ex | 終了 X 座標を取得します。
Public property | ey | 終了 Y 座標を取得します。
Public property | sx | 開始 X 座標を取得します。
Public property | sy | 開始 Y 座標を取得します。
Public property | VarName | 変数名を設定、取得します。

参照

CellPosition クラス


CellPosition プロパティ

[image] [image]

ExcelWebForm
CellPosition プロパティ
CellPosition クラス 参照

CellPosition データ型で公開されるメンバを以下に示します。

プロパティ

 | 名前 | 説明
Public property | CellString | セル位置を示す文字列を取得します。
Public property | ex | 終了 X 座標を取得します。
Public property | ey | 終了 Y 座標を取得します。
Public property | sx | 開始 X 座標を取得します。
Public property | sy | 開始 Y 座標を取得します。
Public property | VarName | 変数名を設定、取得します。

参照

CellPosition クラス


CellString プロパティ

[image]

ExcelWebForm
CellPosition..::..CellString プロパティ
CellPosition クラス 参照
セル位置を示す文字列を取得します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.Shared (ExcelWebForm.Shared.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public string CellString { get; }
Visual Basic (宣言)
Public ReadOnly Property CellString As String
    Get

参照

CellPosition クラス


ex プロパティ

[image]

ExcelWebForm
CellPosition..::..ex プロパティ
CellPosition クラス 参照
終了 X 座標を取得します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.Shared (ExcelWebForm.Shared.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public int ex { get; }
Visual Basic (宣言)
Public ReadOnly Property ex As Integer
    Get

参照

CellPosition クラス


ey プロパティ

[image]

ExcelWebForm
CellPosition..::..ey プロパティ
CellPosition クラス 参照
終了 Y 座標を取得します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.Shared (ExcelWebForm.Shared.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public int ey { get; }
Visual Basic (宣言)
Public ReadOnly Property ey As Integer
    Get

参照

CellPosition クラス


sx プロパティ

[image]

ExcelWebForm
CellPosition..::..sx プロパティ
CellPosition クラス 参照
開始 X 座標を取得します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.Shared (ExcelWebForm.Shared.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public int sx { get; }
Visual Basic (宣言)
Public ReadOnly Property sx As Integer
    Get

参照

CellPosition クラス


sy プロパティ

[image]

ExcelWebForm
CellPosition..::..sy プロパティ
CellPosition クラス 参照
開始 Y 座標を取得します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.Shared (ExcelWebForm.Shared.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public int sy { get; }
Visual Basic (宣言)
Public ReadOnly Property sy As Integer
    Get

参照

CellPosition クラス


VarName プロパティ

[image]

ExcelWebForm
CellPosition..::..VarName プロパティ
CellPosition クラス 参照
変数名を設定、取得します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.Shared (ExcelWebForm.Shared.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public string VarName { get; set; }
Visual Basic (宣言)
Public Property VarName As String
    Get
    Set

参照

CellPosition クラス


CellPositionCollection クラス

[image]

ExcelWebForm
CellPositionCollection クラス
メンバ 参照
セル位置を配列で管理する CellPositionCollection クラス

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.Shared (ExcelWebForm.Shared.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public class CellPositionCollection : List<CellPosition>
Visual Basic (宣言)
Public Class CellPositionCollection _
    Inherits List(Of CellPosition)

継承階層

System..::..Object
System.Collections.Generic..::..List <(Of <(<' CellPosition >)>)>
AdvanceSoftware.ExcelWebForm..::..CellPositionCollection

参照

CellPositionCollection メンバ


CellPositionCollection メンバ

[image] [image]

ExcelWebForm
CellPositionCollection メンバ
CellPositionCollection クラス プロパティ 参照

CellPositionCollection データ型で公開されるメンバを以下に示します。

プロパティ

 | 名前 | 説明
Public property | Name | 名前を取得します。

参照

CellPositionCollection クラス


CellPositionCollection プロパティ

[image] [image]

ExcelWebForm
CellPositionCollection プロパティ
CellPositionCollection クラス 参照

CellPositionCollection データ型で公開されるメンバを以下に示します。

プロパティ

 | 名前 | 説明
Public property | Name | 名前を取得します。

参照

CellPositionCollection クラス


Name プロパティ

[image]

ExcelWebForm
CellPositionCollection..::..Name プロパティ
CellPositionCollection クラス 参照
名前を取得します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.Shared (ExcelWebForm.Shared.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public string Name { get; }
Visual Basic (宣言)
Public ReadOnly Property Name As String
    Get

参照

CellPositionCollection クラス


CellValue クラス

[image]

ExcelWebForm
CellValue クラス
メンバ 参照
CellValue クラス

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public class CellValue
Visual Basic (宣言)
Public Class CellValue

継承階層

System..::..Object
AdvanceSoftware.ExcelWebForm..::..CellValue

参照

CellValue メンバ


CellValue メンバ

[image] [image]

ExcelWebForm
CellValue メンバ
CellValue クラス フィールド 参照

CellValue データ型で公開されるメンバを以下に示します。

フィールド

 | 名前 | 説明
Public field | t | データタイプ
Public field | value | セル値
Public field | x | x 座標
Public field | y | y 座標

参照

CellValue クラス


CellValue フィールド

[image] [image]

ExcelWebForm
CellValue フィールド
CellValue クラス 参照

CellValue データ型で公開されるメンバを以下に示します。

フィールド

 | 名前 | 説明
Public field | t | データタイプ
Public field | value | セル値
Public field | x | x 座標
Public field | y | y 座標

参照

CellValue クラス


t フィールド

[image]

ExcelWebForm
CellValue..::..t フィールド
CellValue クラス 参照
データタイプ

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public Type t
Visual Basic (宣言)
Public t As Type

参照

CellValue クラス


value フィールド

[image]

ExcelWebForm
CellValue..::..value フィールド
CellValue クラス 参照
セル値

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public Object value
Visual Basic (宣言)
Public value As Object

参照

CellValue クラス


x フィールド

[image]

ExcelWebForm
CellValue..::..x フィールド
CellValue クラス 参照
x 座標

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public int x
Visual Basic (宣言)
Public x As Integer

参照

CellValue クラス


y フィールド

[image]

ExcelWebForm
CellValue..::..y フィールド
CellValue クラス 参照
y 座標

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public int y
Visual Basic (宣言)
Public y As Integer

参照

CellValue クラス


CellValueCollection クラス

[image]

ExcelWebForm
CellValueCollection クラス
メンバ 参照
CellValueCollection クラス

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public class CellValueCollection : List<CellValue>
Visual Basic (宣言)
Public Class CellValueCollection _
    Inherits List(Of CellValue)

継承階層

System..::..Object
System.Collections.Generic..::..List <(Of <(<' CellValue >)>)>
AdvanceSoftware.ExcelWebForm..::..CellValueCollection

参照

CellValueCollection メンバ


CellValueCollection メンバ

[image] [image]

ExcelWebForm
CellValueCollection メンバ
CellValueCollection クラス コンストラクタ 参照

CellValueCollection データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | CellValueCollection | Initializes a new instance of the CellValueCollection class

参照

CellValueCollection クラス


CellValueCollection コンストラクタ

[image]

ExcelWebForm
CellValueCollection コンストラクタ
CellValueCollection クラス 参照
Initializes a new instance of the CellValueCollection class

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public CellValueCollection()
Visual Basic (宣言)
Public Sub New

参照

CellValueCollection クラス


DateFormat 列挙体

[image]

ExcelWebForm
DateFormat 列挙体
参照
日付フォーマットを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public enum DateFormat
Visual Basic (宣言)
Public Enumeration DateFormat

メンバ

メンバ名 | 説明
Slash | スラッシュ区切り
Japanese | 年月日区切り
Hyphen | ハイフン区切り

参照


EditMode 列挙体

[image]

ExcelWebForm
EditMode 列挙体
参照
セルの編集モードを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public enum EditMode
Visual Basic (宣言)
Public Enumeration EditMode

メンバ

メンバ名 | 説明
NotEdit | 編集を許可しない
UnlockedCells | ロックされていないセルを編集可能
NamedCells | 名前の付けられたセルのみ編集可能
All | すべて編集を許可

参照


ErrorNo 列挙体

[image]

ExcelWebForm
ErrorNo 列挙体
参照
エラーナンバーを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.Shared (ExcelWebForm.Shared.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public enum ErrorNo
Visual Basic (宣言)
Public Enumeration ErrorNo

メンバ

メンバ名 | 説明
NoError | エラーなし。
CannotOpen | ファイルがオープンできません。
FileHandle | 無効なファイルハンドルです。
NotOpen | 未オープンエラー。
SheetNo | シートナンバーエラー。
Write | 書き込みエラー。
Action | 動作モードエラー。
DataKind | データ種別エラー。
ErrorValue | エラー値。
ComboFile | 複合形式エラー。
Clear | クリアエラー。
Copy | コピーエラー。
Paste | 貼り付けエラー。
Insert | 挿入エラー。
Delete | 削除エラー。
Length | 長さエラー。
Locate | 座標エラー。
Attr | 属性番号エラー。
Param | パラメータエラー。
NoData | データがありません。
EndOfData | データの終わりです。
VarPoint | 指定した変数が存在しません。
BreakCount | 改ページ数が制限を越えました。
InternalMemory | 内部メモリエラー。
Memory | メモリエラー。
Internal | 内部エラー。
Function | 計算式形式エラー。
DupOpen | 既にオープンしています。
ExcelOpen | Excel がオープンできません。
NotSheet | 指定したシートが存在しません。
SaveStop | ファイルに保存を中止しました。
SaveAbort | 保存に失敗しました。
FileType | インストールされている Excel のバージョンでは処理できません。
Version | バージョンエラー。
SaveStream | 保存先ストリームエラー。
SaveDelete | Excel ファイルの削除に失敗しました。
Create | ファイル作成エラー。
TempCreate | 一時ファイルが作成できません。
TempOpen | 一時ファイルがオープンできません。
Stream | ストリームエラー。
Protect | 保護されたシートです。
Mutex | ミューテックスエラー。
MaxFileName | ファイル名が長すぎます。
InvalidFileName | 無効なファイル名です。
EmbedFile | 埋め込みエラー。

参照


FormulaMode 列挙体

[image]

ExcelWebForm
FormulaMode 列挙体
参照
計算式の扱い方を示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public enum FormulaMode
Visual Basic (宣言)
Public Enumeration FormulaMode

メンバ

メンバ名 | 説明
Default | 何もしない
Clear | 結果をクリア(InitFormulaAnser)
ReCalc | ロード時に再計算
OverWrite | 書き込み

参照


HtmlCellValue クラス

[image]

ExcelWebForm
HtmlCellValue クラス
メンバ 参照
HtmlCellValue クラス

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public class HtmlCellValue
Visual Basic (宣言)
Public Class HtmlCellValue

継承階層

System..::..Object
AdvanceSoftware.ExcelWebForm..::..HtmlCellValue

参照

HtmlCellValue メンバ


HtmlCellValue メンバ

[image] [image]

ExcelWebForm
HtmlCellValue メンバ
HtmlCellValue クラス コンストラクタ メソッド プロパティ 参照

HtmlCellValue データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | HtmlCellValue | コンストラクタ

メソッド

 | 名前 | 説明
Public method | GetValue(String) | HTML 上で入力されたセルの値を取得します。
Public method | GetValue(Int32, Int32) | HTML 上で入力されたセルの値を取得します。

プロパティ

 | 名前 | 説明
Public property | CellNameCollection | セル名一覧を取得します。
Public property | CellValueCollection | 変更されたセルの値一覧を取得します。

参照

HtmlCellValue クラス


HtmlCellValue コンストラクタ

[image]

ExcelWebForm
HtmlCellValue コンストラクタ
HtmlCellValue クラス 参照
コンストラクタ

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public HtmlCellValue()
Visual Basic (宣言)
Public Sub New

参照

HtmlCellValue クラス


HtmlCellValue メソッド

[image] [image]

ExcelWebForm
HtmlCellValue メソッド
HtmlCellValue クラス 参照

メソッド

 | 名前 | 説明
Public method | GetValue(String) | HTML 上で入力されたセルの値を取得します。
Public method | GetValue(Int32, Int32) | HTML 上で入力されたセルの値を取得します。

参照

HtmlCellValue クラス


GetValue メソッド

[image] [image]

ExcelWebForm
HtmlCellValue..::..GetValue メソッド
HtmlCellValue クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | GetValue(String) | HTML 上で入力されたセルの値を取得します。
Public method | GetValue(Int32, Int32) | HTML 上で入力されたセルの値を取得します。

参照

HtmlCellValue クラス
HtmlCellValue メンバ


GetValue メソッド (String)

[image]

ExcelWebForm
HtmlCellValue..::..GetValue メソッド (String)
HtmlCellValue クラス 使用例 参照
HTML 上で入力されたセルの値を取得します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public Object GetValue(
    string cell
)
Visual Basic (宣言)
Public Function GetValue ( _
    cell As String _
) As Object

パラメータ

cell
Type: System..::..String
セルを指定します。

戻り値

セルの値を返します。

解説

A1 参照形式、セル名で指定します。 セル名は、テンプレートの Excel ファイルに設定しておく必要があります。

使用例

コピーC#
// GetModifiedValues メソッドで取得した変更内容を指定し、HtmlCellValue を取得します。
AdvanceSoftware.ExcelWebForm.HtmlCellValue htmlCellValue = HtmlControl1.GetHtmlCellValue(HiddenField1.Value);
// A1 セルの値を取得します。
object value1 = htmlCellValue.GetValue("A1");
// セル名 "NAMAE1" の値を取得します。
object value2 = htmlCellValue.GetValue("NAMAE1");
コピーVB.NET
' GetModifiedValues メソッドで取得した変更内容を指定し、HtmlCellValue を取得します。
Dim htmlCellValue As AdvanceSoftware.ExcelWebForm.HtmlCellValue = HtmlControl1.GetHtmlCellValue(HiddenField1.Value)
' A1 セルの値を取得します。
Dim value1 As Object = htmlCellValue.GetValue("A1")
' セル名 "NAMAE1" の値を取得します。
Dim value2 As Object = htmlCellValue.GetValue("NAMAE1")

参照

HtmlCellValue クラス
GetValue オーバーロード


GetValue メソッド (Int32, Int32)

[image]

ExcelWebForm
HtmlCellValue..::..GetValue メソッド (Int32, Int32)
HtmlCellValue クラス 使用例 参照
HTML 上で入力されたセルの値を取得します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public Object GetValue(
    int x,
    int y
)
Visual Basic (宣言)
Public Function GetValue ( _
    x As Integer, _
    y As Integer _
) As Object

パラメータ

x
Type: System..::..Int32
x 座標(0～)を指定します。
y
Type: System..::..Int32
y 座標(0～)を指定します。

戻り値

セルの値を返します。

解説

A1(0, 0)を基点として、座標形式で指定します。

使用例

コピーC#
// GetModifiedValues メソッドで取得した変更内容を指定し、HtmlCellValue を取得します。
AdvanceSoftware.ExcelWebForm.HtmlCellValue htmlCellValue = HtmlControl1.GetHtmlCellValue(HiddenField1.Value);
// A1 セルの値を取得します。
object value1 = htmlCellValue.GetValue(0, 0);
コピーVB.NET
' GetModifiedValues メソッドで取得した変更内容を指定し、HtmlCellValue を取得します。
Dim htmlCellValue As AdvanceSoftware.ExcelWebForm.HtmlCellValue = HtmlControl1.GetHtmlCellValue(HiddenField1.Value)
' A1 セルの値を取得します。
Dim value1 As Object = htmlCellValue.GetValue(0, 0)

参照

HtmlCellValue クラス
GetValue オーバーロード


HtmlCellValue プロパティ

[image] [image]

ExcelWebForm
HtmlCellValue プロパティ
HtmlCellValue クラス 参照

HtmlCellValue データ型で公開されるメンバを以下に示します。

プロパティ

 | 名前 | 説明
Public property | CellNameCollection | セル名一覧を取得します。
Public property | CellValueCollection | 変更されたセルの値一覧を取得します。

参照

HtmlCellValue クラス


CellNameCollection プロパティ

[image]

ExcelWebForm
HtmlCellValue..::..CellNameCollection プロパティ
HtmlCellValue クラス 使用例 参照
セル名一覧を取得します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public CellNameCollection CellNameCollection { get; }
Visual Basic (宣言)
Public ReadOnly Property CellNameCollection As CellNameCollection
    Get

プロパティ値

セル名一覧

使用例

コピーC#
// GetModifiedValues メソッドで取得した変更内容を指定し、HtmlCellValue を取得します。
AdvanceSoftware.ExcelWebForm.HtmlCellValue htmlCellValue = HtmlControl1.GetHtmlCellValue(HiddenField1.Value);
// セル名一覧を取得します。
AdvanceSoftware.ExcelWebForm.CellNameCollection cellNameCollection = htmlCellValue.CellNameCollection;
List<object> valueList = new List<object>();
foreach (AdvanceSoftware.ExcelWebForm.CellPositionCollection cellPositionCollection in htmlCellValue.CellNameCollection)
{
    // セル名 "NAMAE1" の値を取得します。
    if (cellPositionCollection.Name == "NAMAE1")
    {
        foreach (AdvanceSoftware.ExcelWebForm.CellPosition cellPosition in cellPositionCollection)
        {
            int ex = cellPosition.ex == -1 ? cellPosition.sx : cellPosition.ex;
            int ey = cellPosition.ey == -1 ? cellPosition.sy : cellPosition.ey;
            for (int y = cellPosition.sy; y <= ey; y++)
            {
                for (int x = cellPosition.sx; x <= ex; x++)
                {
                    valueList.Add(htmlCellValue.GetValue(x, y));
                }
            }
        }
    }
}
コピーVB.NET
' GetModifiedValues メソッドで取得した変更内容を指定し、HtmlCellValue を取得します。
Dim htmlCellValue As AdvanceSoftware.ExcelWebForm.HtmlCellValue = HtmlControl1.GetHtmlCellValue(HiddenField1.Value)
' セル名一覧を取得します。
Dim cellNameCollection As AdvanceSoftware.ExcelWebForm.CellNameCollection = htmlCellValue.CellNameCollection
Dim valueList As New List(Of Object)
For Each cellPositionCollection As AdvanceSoftware.ExcelWebForm.CellPositionCollection In htmlCellValue.CellNameCollection
    ' セル名 "NAMAE1" の値を取得します。
    If (cellPositionCollection.Name = "NAMAE1") Then
        For Each cellPosition As AdvanceSoftware.ExcelWebForm.CellPosition In cellPositionCollection
            Dim ex As Integer = If(cellPosition.ex = -1, cellPosition.sx, cellPosition.ex)
            Dim ey As Integer = If(cellPosition.ey = -1, cellPosition.sy, cellPosition.ey)
            For y As Integer = cellPosition.sy To ey
                For x As Integer = cellPosition.sx To ex
                    valueList.Add(htmlCellValue.GetValue(x, y))
                Next
            Next
        Next
    End If
Next

参照

HtmlCellValue クラス


CellValueCollection プロパティ

[image]

ExcelWebForm
HtmlCellValue..::..CellValueCollection プロパティ
HtmlCellValue クラス 使用例 参照
変更されたセルの値一覧を取得します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public CellValueCollection CellValueCollection { get; }
Visual Basic (宣言)
Public ReadOnly Property CellValueCollection As CellValueCollection
    Get

プロパティ値

変更されたセルの値一覧

使用例

コピーC#
// GetModifiedValues メソッドで取得した変更内容を指定し、HtmlCellValue を取得します。
AdvanceSoftware.ExcelWebForm.HtmlCellValue htmlCellValue = HtmlControl1.GetHtmlCellValue(HiddenField1.Value);
// 変更されたセルの値一覧を取得します。
AdvanceSoftware.ExcelWebForm.CellValueCollection cellValueCollection = htmlCellValue.CellValueCollection;
foreach (AdvanceSoftware.ExcelWebForm.CellValue cellValue in cellValueCollection)
{
    // cellValue.x、cellValue.y で目的のセルを指定し、cellValue.value で値を取得できます。
    // ...
}
コピーVB.NET
' GetModifiedValues メソッドで取得した変更内容を指定し、HtmlCellValue を取得します。
Dim htmlCellValue As AdvanceSoftware.ExcelWebForm.HtmlCellValue = HtmlControl1.GetHtmlCellValue(HiddenField1.Value)
' 変更されたセルの値一覧を取得します。
Dim cellValueCollection As AdvanceSoftware.ExcelWebForm.CellValueCollection = htmlCellValue.CellValueCollection
For Each cellValue As AdvanceSoftware.ExcelWebForm.CellValue In cellValueCollection
    ' cellValue.x、cellValue.y で目的のセルを指定し、cellValue.value で値を取得できます。
    ' ...
Next

参照

HtmlCellValue クラス


HtmlControl クラス

[image]

ExcelWebForm
HtmlControl クラス
メンバ 参照
HtmlControl クラス

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public class HtmlControl : WebControl
Visual Basic (宣言)
Public Class HtmlControl _
    Inherits WebControl

継承階層

System..::..Object
System.Web.UI..::..Control
System.Web.UI.WebControls..::..WebControl
AdvanceSoftware.ExcelWebForm..::..HtmlControl

参照

HtmlControl メンバ


HtmlControl メンバ

[image] [image]

ExcelWebForm
HtmlControl メンバ
HtmlControl クラス コンストラクタ メソッド プロパティ 参照

HtmlControl データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | HtmlControl | コンストラクタ

メソッド

 | 名前 | 説明
Public method | GetHtmlCellValue | 入力されたセル値を個別に扱うための HtmlCellValue を取得します。
Public method | Save(String, Boolean) | 編集した内容で Excel ファイルを上書き保存します。
Public method | Save(Stream, String, Boolean) | 編集した内容で Excel ファイルを上書き保存、PDF ファイルを名前を付けて保存します。
Public method | Save(String, String, Boolean) | 編集した内容で Excel ファイルを上書き保存、PDF ファイルを名前を付けて保存します。
Public method | SaveAs(Stream, String, Boolean) | 編集した内容で名前を付けて Excel ファイルを保存します。
Public method | SaveAs(String, String, Boolean) | 編集した内容で名前を付けて Excel ファイルを保存します。
Public method | SaveAs(Stream, Stream, String, Boolean) | 編集した内容で名前を付けて Excel ファイル、PDF ファイルを保存します。
Public method | SaveAs(String, String, String, Boolean) | 編集した内容で名前を付けて Excel ファイル、PDF ファイルを保存します。

プロパティ

 | 名前 | 説明
Public property | DateFormat | 日付の編集フォーマットを設定します。
Public property | EditMode | セルの編集モードを設定します。
Public property | ErrorFormulaCellColor | 未対応の計算式、および、エラーとなった計算式のセルの色を指定します。
Public property | ErrorNo | エラーナンバーを取得します。
Public property | FileName | オープンする Excel ファイル名を指定します。
Public property | FormulaMode | 計算式モードを設定します。
Public property | ImagePath | イメージ用の一時フォルダとして使用するパスを指定します。
Public property | InnerText | テーブル部分の HTML テキストを取得します。
Public property | Margin | テーブルの余白を設定します。
Public property | NamedCells | 編集対象の名前の付けられたセルを設定します。
Public property | Pdf | PDF 出力のプロパティを設定するための PdfProperty を取得します。
Public property | RefSheets | データを参照するシート名を指定します。
Public property | Scale | テーブルの倍率を設定します。
Public property | SheetNo | 使用するシート番号(0～)を設定します。
Public property | TableSize | テーブルのサイズを取得します。

参照

HtmlControl クラス


HtmlControl コンストラクタ

[image]

ExcelWebForm
HtmlControl コンストラクタ
HtmlControl クラス 参照
コンストラクタ

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public HtmlControl()
Visual Basic (宣言)
Public Sub New

参照

HtmlControl クラス


HtmlControl メソッド

[image] [image]

ExcelWebForm
HtmlControl メソッド
HtmlControl クラス 参照

HtmlControl データ型で公開されるメンバを以下に示します。

メソッド

 | 名前 | 説明
Public method | GetHtmlCellValue | 入力されたセル値を個別に扱うための HtmlCellValue を取得します。
Public method | Save(String, Boolean) | 編集した内容で Excel ファイルを上書き保存します。
Public method | Save(Stream, String, Boolean) | 編集した内容で Excel ファイルを上書き保存、PDF ファイルを名前を付けて保存します。
Public method | Save(String, String, Boolean) | 編集した内容で Excel ファイルを上書き保存、PDF ファイルを名前を付けて保存します。
Public method | SaveAs(Stream, String, Boolean) | 編集した内容で名前を付けて Excel ファイルを保存します。
Public method | SaveAs(String, String, Boolean) | 編集した内容で名前を付けて Excel ファイルを保存します。
Public method | SaveAs(Stream, Stream, String, Boolean) | 編集した内容で名前を付けて Excel ファイル、PDF ファイルを保存します。
Public method | SaveAs(String, String, String, Boolean) | 編集した内容で名前を付けて Excel ファイル、PDF ファイルを保存します。

参照

HtmlControl クラス


GetHtmlCellValue メソッド

[image]

ExcelWebForm
HtmlControl..::..GetHtmlCellValue メソッド
HtmlControl クラス 使用例 参照
入力されたセル値を個別に扱うための HtmlCellValue を取得します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public HtmlCellValue GetHtmlCellValue(
    string modifiedValues
)
Visual Basic (宣言)
Public Function GetHtmlCellValue ( _
    modifiedValues As String _
) As HtmlCellValue

パラメータ

modifiedValues
Type: System..::..String
GetModifiedValues メソッドで取得した変更内容を指定します。

戻り値

HtmlCellValue を返します。

使用例

コピーC#
// GetModifiedValues メソッドで取得した変更内容を指定し、HtmlCellValue を取得します。
AdvanceSoftware.ExcelWebForm.HtmlCellValue htmlCellValue = HtmlControl1.GetHtmlCellValue(HiddenField1.Value);
// A1 セルの値を取得します。
object value1 = htmlCellValue.GetValue("A1");
// B2 セルの値を取得します。
object value2 = htmlCellValue.GetValue(1, 1);
// セル名 "NAMAE1" の値を取得します。
object value3 = htmlCellValue.GetValue("NAMAE1");
コピーVB.NET
' GetModifiedValues メソッドで取得した変更内容を指定し、HtmlCellValue を取得します。
Dim htmlCellValue As AdvanceSoftware.ExcelWebForm.HtmlCellValue = HtmlControl1.GetHtmlCellValue(HiddenField1.Value)
' A1 セルの値を取得します。
Dim value1 As Object = htmlCellValue.GetValue("A1")
' B2 セルの値を取得します。
Dim value2 As Object = htmlCellValue.GetValue(1, 1)
' セル名 "NAMAE1" の値を取得します。
Dim value3 As Object = htmlCellValue.GetValue("NAMAE1")

参照

HtmlControl クラス


Save メソッド

[image] [image]

ExcelWebForm
HtmlControl..::..Save メソッド
HtmlControl クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | Save(String, Boolean) | 編集した内容で Excel ファイルを上書き保存します。
Public method | Save(Stream, String, Boolean) | 編集した内容で Excel ファイルを上書き保存、PDF ファイルを名前を付けて保存します。
Public method | Save(String, String, Boolean) | 編集した内容で Excel ファイルを上書き保存、PDF ファイルを名前を付けて保存します。

参照

HtmlControl クラス
HtmlControl メンバ


Save メソッド (String, Boolean)

[image]

ExcelWebForm
HtmlControl..::..Save メソッド (String, Boolean)
HtmlControl クラス 使用例 参照
編集した内容で Excel ファイルを上書き保存します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public void Save(
    string modifiedValues,
    bool isReLoad
)
Visual Basic (宣言)
Public Sub Save ( _
    modifiedValues As String, _
    isReLoad As Boolean _
)

パラメータ

modifiedValues
Type: System..::..String
GetModifiedValues メソッドで取得した変更内容を指定します。
isReLoad
Type: System..::..Boolean
保存後の内容でテーブルの更新(リロード)を行うかどうかを指定します。

使用例

コピーC#
// FileName プロパティで指定した Excel ファイルに変更内容を上書き保存し、保存後の内容でテーブルを更新します。
HtmlControl1.Save(HiddenField1.Value, true);
コピーVB.NET
' FileName プロパティで指定した Excel ファイルに変更内容を上書き保存し、保存後の内容でテーブルを更新します。
HtmlControl1.Save(HiddenField1.Value, True)

参照

HtmlControl クラス
Save オーバーロード


Save メソッド (Stream, String, Boolean)

[image]

ExcelWebForm
HtmlControl..::..Save メソッド (Stream, String, Boolean)
HtmlControl クラス 使用例 参照
編集した内容で Excel ファイルを上書き保存、PDF ファイルを名前を付けて保存します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public void Save(
    Stream pdfStream,
    string modifiedValues,
    bool isReLoad
)
Visual Basic (宣言)
Public Sub Save ( _
    pdfStream As Stream, _
    modifiedValues As String, _
    isReLoad As Boolean _
)

パラメータ

pdfStream
Type: System.IO..::..Stream
保存する PDF Stream を指定します。
modifiedValues
Type: System..::..String
GetModifiedValues メソッドで取得した変更内容を指定します。
isReLoad
Type: System..::..Boolean
保存後の内容でテーブルの更新(リロード)を行うかどうかを指定します。

使用例

コピーC#
// FileName プロパティで指定した Excel ファイルに変更内容を上書き保存、PDF ファイルを pdfStream に保存し、保存後の内容でテーブルを更新します。
HtmlControl1.Save(pdfStream, HiddenField1.Value, true);
コピーVB.NET
' FileName プロパティで指定した Excel ファイルに変更内容を上書き保存、PDF ファイルを pdfStream に保存し、保存後の内容でテーブルを更新します。
HtmlControl1.Save(pdfStream, HiddenField1.Value, True)

参照

HtmlControl クラス
Save オーバーロード


Save メソッド (String, String, Boolean)

[image]

ExcelWebForm
HtmlControl..::..Save メソッド (String, String, Boolean)
HtmlControl クラス 使用例 参照
編集した内容で Excel ファイルを上書き保存、PDF ファイルを名前を付けて保存します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public void Save(
    string pdfFileName,
    string modifiedValues,
    bool isReLoad
)
Visual Basic (宣言)
Public Sub Save ( _
    pdfFileName As String, _
    modifiedValues As String, _
    isReLoad As Boolean _
)

パラメータ

pdfFileName
Type: System..::..String
保存する PDF ファイル名を指定します。
modifiedValues
Type: System..::..String
GetModifiedValues メソッドで取得した変更内容を指定します。
isReLoad
Type: System..::..Boolean
保存後の内容でテーブルの更新(リロード)を行うかどうかを指定します。

使用例

コピーC#
// FileName プロパティで指定した Excel ファイルに変更内容を上書き保存、PDF ファイルを "C:\Out1.pdf" に保存し、保存後の内容でテーブルを更新します。
HtmlControl1.Save(@"C:\Out1.pdf", HiddenField1.Value, true);
コピーVB.NET
' FileName プロパティで指定した Excel ファイルに変更内容を上書き保存、PDF ファイルを "C:\Out1.pdf" に保存し、保存後の内容でテーブルを更新します。
HtmlControl1.Save("C:\Out1.pdf", HiddenField1.Value, True)

参照

HtmlControl クラス
Save オーバーロード


SaveAs メソッド

[image] [image]

ExcelWebForm
HtmlControl..::..SaveAs メソッド
HtmlControl クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | SaveAs(Stream, String, Boolean) | 編集した内容で名前を付けて Excel ファイルを保存します。
Public method | SaveAs(String, String, Boolean) | 編集した内容で名前を付けて Excel ファイルを保存します。
Public method | SaveAs(Stream, Stream, String, Boolean) | 編集した内容で名前を付けて Excel ファイル、PDF ファイルを保存します。
Public method | SaveAs(String, String, String, Boolean) | 編集した内容で名前を付けて Excel ファイル、PDF ファイルを保存します。

参照

HtmlControl クラス
HtmlControl メンバ


SaveAs メソッド (Stream, String, Boolean)

[image]

ExcelWebForm
HtmlControl..::..SaveAs メソッド (Stream, String, Boolean)
HtmlControl クラス 使用例 参照
編集した内容で名前を付けて Excel ファイルを保存します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public void SaveAs(
    Stream outStream,
    string modifiedValues,
    bool isReLoad
)
Visual Basic (宣言)
Public Sub SaveAs ( _
    outStream As Stream, _
    modifiedValues As String, _
    isReLoad As Boolean _
)

パラメータ

outStream
Type: System.IO..::..Stream
保存する Excel Stream を指定します。
modifiedValues
Type: System..::..String
GetModifiedValues メソッドで取得した変更内容を指定します。
isReLoad
Type: System..::..Boolean
保存後の内容でテーブルの更新(リロード)を行うかどうかを指定します。

使用例

コピーC#
// Excel ファイルを excelStream に保存し、保存後の内容でテーブルを更新します。
HtmlControl1.SaveAs(excelStream, HiddenField1.Value, true);
コピーVB.NET
' Excel ファイルを excelStream に保存し、保存後の内容でテーブルを更新します。
HtmlControl1.SaveAs(excelStream, HiddenField1.Value, True)

参照

HtmlControl クラス
SaveAs オーバーロード


SaveAs メソッド (String, String, Boolean)

[image]

ExcelWebForm
HtmlControl..::..SaveAs メソッド (String, String, Boolean)
HtmlControl クラス 使用例 参照
編集した内容で名前を付けて Excel ファイルを保存します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public void SaveAs(
    string fileName,
    string modifiedValues,
    bool isReLoad
)
Visual Basic (宣言)
Public Sub SaveAs ( _
    fileName As String, _
    modifiedValues As String, _
    isReLoad As Boolean _
)

パラメータ

fileName
Type: System..::..String
保存する Excel ファイル名を指定します。
modifiedValues
Type: System..::..String
GetModifiedValues メソッドで取得した変更内容を指定します。
isReLoad
Type: System..::..Boolean
保存後の内容でテーブルの更新(リロード)を行うかどうかを指定します。

使用例

コピーC#
// Excel ファイルを "C:\Out1.xls" に保存し、保存後の内容でテーブルを更新します。
HtmlControl1.SaveAs(@"C:\Out1.xls", HiddenField1.Value, true);
コピーVB.NET
' Excel ファイルを "C:\Out1.xls" に保存し、保存後の内容でテーブルを更新します。
HtmlControl1.SaveAs("C:\Out1.xls", HiddenField1.Value, True)

参照

HtmlControl クラス
SaveAs オーバーロード


SaveAs メソッド (Stream, Stream, String, Boolean)

[image]

ExcelWebForm
HtmlControl..::..SaveAs メソッド (Stream, Stream, String, Boolean)
HtmlControl クラス 使用例 参照
編集した内容で名前を付けて Excel ファイル、PDF ファイルを保存します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public void SaveAs(
    Stream outStream,
    Stream pdfStreame,
    string modifiedValues,
    bool isReLoad
)
Visual Basic (宣言)
Public Sub SaveAs ( _
    outStream As Stream, _
    pdfStreame As Stream, _
    modifiedValues As String, _
    isReLoad As Boolean _
)

パラメータ

outStream
Type: System.IO..::..Stream
保存する Excel Stream を指定します。
pdfStreame
Type: System.IO..::..Stream
保存する PDF Stream を指定します。
modifiedValues
Type: System..::..String
GetModifiedValues メソッドで取得した変更内容を指定します。
isReLoad
Type: System..::..Boolean
保存後の内容でテーブルの更新(リロード)を行うかどうかを指定します。

使用例

コピーC#
// Excel ファイルを excelStream、PDF ファイルを pdfStream に保存し、保存後の内容でテーブルを更新します。
HtmlControl1.SaveAs(excelStream, pdfStream, HiddenField1.Value, true);
コピーVB.NET
' Excel ファイルを excelStream、PDF ファイルを pdfStream に保存し、保存後の内容でテーブルを更新します。
HtmlControl1.SaveAs(excelStream, pdfStream, HiddenField1.Value, True)

参照

HtmlControl クラス
SaveAs オーバーロード


SaveAs メソッド (String, String, String, Boolean)

[image]

ExcelWebForm
HtmlControl..::..SaveAs メソッド (String, String, String, Boolean)
HtmlControl クラス 使用例 参照
編集した内容で名前を付けて Excel ファイル、PDF ファイルを保存します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public void SaveAs(
    string fileName,
    string pdfFileName,
    string modifiedValues,
    bool isReLoad
)
Visual Basic (宣言)
Public Sub SaveAs ( _
    fileName As String, _
    pdfFileName As String, _
    modifiedValues As String, _
    isReLoad As Boolean _
)

パラメータ

fileName
Type: System..::..String
保存する Excel ファイル名を指定します。
pdfFileName
Type: System..::..String
保存する PDF ファイル名を指定します。
modifiedValues
Type: System..::..String
GetModifiedValues メソッドで取得した変更内容を指定します。
isReLoad
Type: System..::..Boolean
保存後の内容でテーブルの更新(リロード)を行うかどうかを指定します。

使用例

コピーC#
// Excel ファイルを "C:\Out1.xls"、PDF ファイルを "C:\Out1.pdf" に保存し、保存後の内容でテーブルを更新します。
HtmlControl1.SaveAs(@"C:\Out1.xls", @"C:\Out1.pdf", HiddenField1.Value, true);
コピーVB.NET
' Excel ファイルを "C:\Out1.xls"、PDF ファイルを "C:\Out1.pdf" に保存し、保存後の内容でテーブルを更新します。
HtmlControl1.SaveAs("C:\Out1.xls", "C:\Out1.pdf", HiddenField1.Value, True)

参照

HtmlControl クラス
SaveAs オーバーロード


HtmlControl プロパティ

[image] [image]

ExcelWebForm
HtmlControl プロパティ
HtmlControl クラス 参照

HtmlControl データ型で公開されるメンバを以下に示します。

プロパティ

 | 名前 | 説明
Public property | DateFormat | 日付の編集フォーマットを設定します。
Public property | EditMode | セルの編集モードを設定します。
Public property | ErrorFormulaCellColor | 未対応の計算式、および、エラーとなった計算式のセルの色を指定します。
Public property | ErrorNo | エラーナンバーを取得します。
Public property | FileName | オープンする Excel ファイル名を指定します。
Public property | FormulaMode | 計算式モードを設定します。
Public property | ImagePath | イメージ用の一時フォルダとして使用するパスを指定します。
Public property | InnerText | テーブル部分の HTML テキストを取得します。
Public property | Margin | テーブルの余白を設定します。
Public property | NamedCells | 編集対象の名前の付けられたセルを設定します。
Public property | Pdf | PDF 出力のプロパティを設定するための PdfProperty を取得します。
Public property | RefSheets | データを参照するシート名を指定します。
Public property | Scale | テーブルの倍率を設定します。
Public property | SheetNo | 使用するシート番号(0～)を設定します。
Public property | TableSize | テーブルのサイズを取得します。

参照

HtmlControl クラス


DateFormat プロパティ

[image]

ExcelWebForm
HtmlControl..::..DateFormat プロパティ
HtmlControl クラス 使用例 参照
日付の編集フォーマットを設定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public DateFormat DateFormat { set; }
Visual Basic (宣言)
Public WriteOnly Property DateFormat As DateFormat
    Set

プロパティ値

日付の表示形式を指定する DateFomat。

使用例

コピーC#
// スラッシュ区切りで日付を表示します (例 : 2013/01/01)
HtmlControl1.DateFormat = DateFormat.Slash;
// 年月日区切りで日付を表示します (例 : 2013年01月01日)
HtmlControl1.DateFormat = DateFormat.Japanese;
// ハイフン区切りで日付を表示します (例 : 2013-01-01)
HtmlControl1.DateFormat = DateFormat.Hyphen;
コピーVB.NET
' スラッシュ区切りで日付を表示します (例 : 2013/01/01)
HtmlControl1.DateFormat = DateFormat.Slash
' 年月日区切りで日付を表示します (例 : 2013年01月01日)
HtmlControl1.DateFormat = DateFormat.Japanese
' ハイフン区切りで日付を表示します (例 : 2013-01-01)
HtmlControl1.DateFormat = DateFormat.Hyphen

参照

HtmlControl クラス


EditMode プロパティ

[image]

ExcelWebForm
HtmlControl..::..EditMode プロパティ
HtmlControl クラス 使用例 参照
セルの編集モードを設定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public EditMode EditMode { set; }
Visual Basic (宣言)
Public WriteOnly Property EditMode As EditMode
    Set

プロパティ値

セルの編集を制限する EditMode。

使用例

コピーC#
// 全てのセルの編集を許可します。
HtmlControl1.EditMode = AdvanceSoftware.ExcelWebForm.EditMode.All;
// 全てのセルの編集を許可しません。
HtmlControl1.EditMode = AdvanceSoftware.ExcelWebForm.EditMode.NotEdit;
// ロックされていないセルのみ編集を許可します。
HtmlControl1.EditMode = AdvanceSoftware.ExcelWebForm.EditMode.UnlockedCells;
// 名前の付けられたセルのみ編集を許可します。
HtmlControl1.EditMode = AdvanceSoftware.ExcelWebForm.EditMode.NamedCells;
コピーVB.NET
' 全てのセルの編集を許可します。
HtmlControl1.EditMode = AdvanceSoftware.ExcelWebForm.EditMode.All
' 全てのセルの編集を許可しません。
HtmlControl1.EditMode = AdvanceSoftware.ExcelWebForm.EditMode.NotEdit
' ロックされていないセルのみ編集を許可します。
HtmlControl1.EditMode = AdvanceSoftware.ExcelWebForm.EditMode.UnlockedCells
' 名前の付けられたセルのみ編集を許可します。
HtmlControl1.EditMode = AdvanceSoftware.ExcelWebForm.EditMode.NamedCells

参照

HtmlControl クラス


ErrorFormulaCellColor プロパティ

[image]

ExcelWebForm
HtmlControl..::..ErrorFormulaCellColor プロパティ
HtmlControl クラス 使用例 参照
未対応の計算式、および、エラーとなった計算式のセルの色を指定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public Color ErrorFormulaCellColor { get; set; }
Visual Basic (宣言)
Public Property ErrorFormulaCellColor As Color
    Get
    Set

プロパティ値

セルの背景色を表す Color 構造体。(規定値 Color.Gray)

使用例

コピーC#
// 未対応の計算式、および、エラーとなった計算式のセルの背景色を赤色に設定します。
HtmlControl1.ErrorFormulaCellColor = System.Drawing.Color.Red;
コピーVB.NET
' 未対応の計算式、および、エラーとなった計算式のセルの背景色を赤色に設定します。
HtmlControl1.ErrorFormulaCellColor = System.Drawing.Color.Red

参照

HtmlControl クラス


ErrorNo プロパティ

[image]

ExcelWebForm
HtmlControl..::..ErrorNo プロパティ
HtmlControl クラス 使用例 参照
エラーナンバーを取得します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public ErrorNo ErrorNo { get; }
Visual Basic (宣言)
Public ReadOnly Property ErrorNo As ErrorNo
    Get

プロパティ値

エラーナンバーを表す ErrorNo。

使用例

コピーC#
HtmlControl1.FileName = @"C:\Template\Book1.xlsx";
// ファイルオープン時にエラーが発生した場合、ラベルにエラーを表示します。
if (HtmlControl1.ErrorNo != AdvanceSoftware.ExcelWebForm.ErrorNo.NoError)
{
    label1.Text = "エラー (エラーNo:" + HtmlControl1.ErrorNo.ToString() + ")";
}
コピーVB.NET
HtmlControl1.FileName = "C:\Template\Book1.xlsx"
' ファイルオープン時にエラーが発生した場合、ラベルにエラーを表示します。
If HtmlControl1.ErrorNo <> AdvanceSoftware.ExcelWebForm.ErrorNo.NoError Then
    label1.Text = "エラー (エラーNo:" & HtmlControl1.ErrorNo.ToString & ")"
End If

参照

HtmlControl クラス


FileName プロパティ

[image]

ExcelWebForm
HtmlControl..::..FileName プロパティ
HtmlControl クラス 使用例 参照
オープンする Excel ファイル名を指定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public string FileName { set; }
Visual Basic (宣言)
Public WriteOnly Property FileName As String
    Set

プロパティ値

オープンする Excel ファイル名のファイルパス。

使用例

コピーC#
// "C:\Template" に格納された Excel ファイル "Book1.xlsx" をオープンします。
HtmlControl1.FileName = @"C:\Template\Book1.xlsx";
コピーVB.NET
' "C:\Template" に格納された Excel ファイル "Book1.xlsx" をオープンします。
HtmlControl1.FileName = "C:\Template\Book1.xlsx"

参照

HtmlControl クラス


FormulaMode プロパティ

[image]

ExcelWebForm
HtmlControl..::..FormulaMode プロパティ
HtmlControl クラス 使用例 参照
計算式モードを設定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public FormulaMode FormulaMode { set; }
Visual Basic (宣言)
Public WriteOnly Property FormulaMode As FormulaMode
    Set

プロパティ値

計算式モード。

解説

Save メソッド実行時の再描画で計算式の扱いに関するモードを設定します。

使用例

コピーC#
// 再描画時の計算式モードを設定します。
HtmlControl1.FormulaMode = FormulaMode.Clear;
コピーVB.NET
' 再描画時の計算式モードを設定します。
HtmlControl1.FormulaMode = FormulaMode.Clear

参照

HtmlControl クラス


ImagePath プロパティ

[image]

ExcelWebForm
HtmlControl..::..ImagePath プロパティ
HtmlControl クラス 使用例 参照
イメージ用の一時フォルダとして使用するパスを指定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public string ImagePath { set; }
Visual Basic (宣言)
Public WriteOnly Property ImagePath As String
    Set

プロパティ値

画像を保存する一時フォルダへのパス。

使用例

コピーC#
// 画像を保存する一時フォルダのパスを "Images" に設定します。
HtmlControl1.ImagePath = "Images";
コピーVB.NET
' 画像を保存する一時フォルダのパスを "Images" に設定します。
HtmlControl1.ImagePath = "Images"

参照

HtmlControl クラス


InnerText プロパティ

[image]

ExcelWebForm
HtmlControl..::..InnerText プロパティ
HtmlControl クラス 使用例 参照
テーブル部分の HTML テキストを取得します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public string InnerText { get; }
Visual Basic (宣言)
Public ReadOnly Property InnerText As String
    Get

プロパティ値

HTML テキストを格納する String クラス。

使用例

コピーC#
// データテーブルの HTML テキストを取得します。
string innerText = HtmlControl1.InnerText;
コピーVB.NET
' データテーブルの HTML テキストを取得します。
Dim innerText As String = HtmlControl1.InnerText

参照

HtmlControl クラス


Margin プロパティ

[image]

ExcelWebForm
HtmlControl..::..Margin プロパティ
HtmlControl クラス 使用例 参照
テーブルの余白を設定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public Rectangle Margin { set; }
Visual Basic (宣言)
Public WriteOnly Property Margin As Rectangle
    Set

プロパティ値

余白のサイズを表す Rectangle クラス。

使用例

コピーC#
// テーブルの余白の設定を行います。
// テーブルの左余白 = 100 ピクセル
// テーブルの上余白 = 100 ピクセル
// テーブルの右余白 = 200 ピクセル
// テーブルの下余白 = 200 ピクセル
// ※Rectangle の設定値の単位は Graphics クラスの PageUnit/PageScale プロパティに依存します。詳細は MSDN 等、開発元の情報をご確認ください。
HtmlControl1.Margin = new System.Drawing.Rectangle(100, 100, 200, 200);
コピーVB.NET
' テーブルの余白の設定を行います。
' テーブルの左余白 = 100 ピクセル
' テーブルの上余白 = 100 ピクセル
' テーブルの右余白 = 200 ピクセル
' テーブルの下余白 = 200 ピクセル
' ※Rectangle の設定値の単位は Graphics クラスの PageUnit/PageScale プロパティに依存します。詳細は MSDN 等、開発元の情報をご確認ください。
HtmlControl1.Margin = new System.Drawing.Rectangle(100, 100, 200, 200)

参照

HtmlControl クラス


NamedCells プロパティ

[image]

ExcelWebForm
HtmlControl..::..NamedCells プロパティ
HtmlControl クラス 使用例 参照
編集対象の名前の付けられたセルを設定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public string[] NamedCells { set; }
Visual Basic (宣言)
Public WriteOnly Property NamedCells As String()
    Set

プロパティ値

編集を許可するセル名。

使用例

コピーC#
// 名前の付けられたセルのみ編集を許可します。
HtmlControl1.EditMode = AdvanceSoftware.ExcelWebForm.EditMode.NamedCells;
// 名前 "セル1" と "セル2" が付けられたセルのみ編集を許可します。
HtmlControl1.NamedCells = new string[] { "セル1", "セル2" };
コピーVB.NET
' 名前の付けられたセルのみ編集を許可します。
HtmlControl1.EditMode = AdvanceSoftware.ExcelWebForm.EditMode.NamedCells
' 名前 "セル1" と "セル2" が付けられたセルのみ編集を許可します。
HtmlControl1.NamedCells = new string() { "セル1", "セル2" }

参照

HtmlControl クラス


Pdf プロパティ

[image]

ExcelWebForm
HtmlControl..::..Pdf プロパティ
HtmlControl クラス 参照
PDF 出力のプロパティを設定するための PdfProperty を取得します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public PdfProperty Pdf { get; }
Visual Basic (宣言)
Public ReadOnly Property Pdf As PdfProperty
    Get

プロパティ値

PDF 出力のプロパティを設定するための PdfProperty クラス。

解説

このクラスの全てのメンバの一覧については、PdfProperty クラスのメンバを参照してください。

参照

HtmlControl クラス


RefSheets プロパティ

[image]

ExcelWebForm
HtmlControl..::..RefSheets プロパティ
HtmlControl クラス 使用例 参照
データを参照するシート名を指定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public string[] RefSheets { set; }
Visual Basic (宣言)
Public WriteOnly Property RefSheets As String()
    Set

プロパティ値

計算式の参照先のシート名。

解説

別シートの参照を含む計算式が存在する場合、参照先のシート名を指定します。

使用例

コピーC#
HtmlControl1.SheetNo = 0;
// シート "Sheet2"、"Sheet3" のデータを参照します。
HtmlControl1.RefSheets = new string[] { "Sheet2", "Sheet3" };
コピーVB.NET
HtmlControl1.SheetNo = 0
' シート "Sheet2"、"Sheet3" のデータを参照します。
HtmlControl1.RefSheets = new String() { "Sheet2", "Sheet3" }

参照

HtmlControl クラス


Scale プロパティ

[image]

ExcelWebForm
HtmlControl..::..Scale プロパティ
HtmlControl クラス 使用例 参照
テーブルの倍率を設定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public int Scale { set; }
Visual Basic (宣言)
Public WriteOnly Property Scale As Integer
    Set

プロパティ値

テーブルの表示倍率。(規定値 100%)

使用例

コピーC#
// 表示倍率を 100% に設定します。
HtmlControl1.Scale = 100;
// 表示倍率を 200% に設定します。
HtmlControl1.Scale = 200;
コピーVB.NET
' 表示倍率を 100% に設定します。
HtmlControl1.Scale = 100
' 表示倍率を 200% に設定します。
HtmlControl1.Scale = 200

参照

HtmlControl クラス


SheetNo プロパティ

[image]

ExcelWebForm
HtmlControl..::..SheetNo プロパティ
HtmlControl クラス 使用例 参照
使用するシート番号(0～)を設定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public int SheetNo { get; set; }
Visual Basic (宣言)
Public Property SheetNo As Integer
    Get
    Set

プロパティ値

使用するシート番号。

使用例

コピーC#
// 1シート目を選択します。
HtmlControl1.SheetNo = 0;
HtmlControl1.FileName = @"C:\Template\Book1.xlsx";
コピーVB.NET
' 1シート目を選択します。
HtmlControl1.SheetNo = 0
HtmlControl1.FileName = "C:\Template\Book1.xlsx"

参照

HtmlControl クラス


TableSize プロパティ

[image]

ExcelWebForm
HtmlControl..::..TableSize プロパティ
HtmlControl クラス 使用例 参照
テーブルのサイズを取得します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public Size TableSize { get; }
Visual Basic (宣言)
Public ReadOnly Property TableSize As Size
    Get

プロパティ値

作成されたテーブルのサイズ。

解説

最後に作成したテーブルのサイズを取得します。

使用例

コピーC#
// 作成したテーブルのサイズを取得します。
System.Drawing.Size size = HtmlControl1.TableSize;
コピーVB.NET
' 作成したテーブルのサイズを取得します。
Dim size As System.Drawing.Size = HtmlControl1.TableSize

参照

HtmlControl クラス


ImageType 列挙体

[image]

ExcelWebForm
ImageType 列挙体
参照
イメージタイプを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.Shared (ExcelWebForm.Shared.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public enum ImageType
Visual Basic (宣言)
Public Enumeration ImageType

メンバ

メンバ名 | 説明
JPEG | Jpeg 形式
GIF | Gif 形式
BMP | Bitmap 形式

参照


PdfEncryptionType 列挙体

[image]

ExcelWebForm
PdfEncryptionType 列挙体
参照
PdfEncryptionType

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.Shared (ExcelWebForm.Shared.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public enum PdfEncryptionType
Visual Basic (宣言)
Public Enumeration PdfEncryptionType

メンバ

メンバ名 | 説明
NoPassword | パスワードなし
Acrobat3_RC4_40 | 40-bit RC4
Acrobat5_RC4_128 | 128-bit RC4
Acrobat6_RC4_128 | 128-bit RC4

参照


PdfPermit 列挙体

[image]

ExcelWebForm
PdfPermit 列挙体
参照
PdfPermit

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.Shared (ExcelWebForm.Shared.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public enum PdfPermit
Visual Basic (宣言)
Public Enumeration PdfPermit

メンバ

メンバ名 | 説明
Print | 低解像度のみ印刷許可
Change | 文書の編集の許可
Copy | 文書の選択、コピーの許可
Comment | 注釈の編集の許可
FormField | フォームに対する入力の許可
ContentAccess | 読み上げ機能の使用の許可
DocumentAssembly | ページの挿入や削除や回転、しおり、サムネールの作成の許可
PrintHigh | 印刷許可

参照


PdfProperty クラス

[image]

ExcelWebForm
PdfProperty クラス
メンバ 参照
PDF 出力のプロパティを設定します。HtmlControl オブジェクトを通じてこのクラスにアクセスします。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public class PdfProperty
Visual Basic (宣言)
Public Class PdfProperty

継承階層

System..::..Object
AdvanceSoftware.ExcelWebForm..::..PdfProperty

参照

PdfProperty メンバ


PdfProperty メンバ

[image] [image]

ExcelWebForm
PdfProperty メンバ
PdfProperty クラス コンストラクタ プロパティ 参照

PdfProperty データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | PdfProperty | コンストラクタ

プロパティ

 | 名前 | 説明
Public property | Application | PDF のアプリケーションを設定します。
Public property | ApplyPrintArea | PDF ファイル出力時に印刷範囲を適用するかを指定します。
Public property | Author | PDF の作成者を設定します。
Public property | EmbedFonts | 埋め込むフォントを設定します。
Public property | EncryptionType | PDF ファイルの暗号化強度を設定します。PdfEncryptionType 列挙体で指定してください。
Public property | EUDCFiles | PDF ファイルで使用する外字ファイル名と対象とするフォント名を指定します。 フォントの種類毎に外字ファイルを切り替えることが可能です。
Public property | ImageType | イメージの種類を設定します。
Public property | IsReplaceYenSign | PDF ファイルに出力する文字列の"\"マークの扱いを指定します。
Public property | OwnerPassword | PDF ファイルのオーナーパスワードを設定します。
Public property | PatternQuality | PDF のパターンの解像度を設定します。
Public property | Permit | PDF ファイルの権限を設定します。複数の指定時は PdfPermit 列挙体を or(|) で連結します。
Public property | Producer | PDF 変換を設定します。
Public property | Quality | PDF の解像度を設定します。
Public property | StreamMode | PDF ファイル出力時の StreamMode を指定します。
Public property | Subject | PDF のサブタイトルを設定します。
Public property | Title | PDF のタイトルを設定します。
Public property | UserPassword | PDF ファイルのユーザーパスワードを設定します。

参照

PdfProperty クラス


PdfProperty コンストラクタ

[image]

ExcelWebForm
PdfProperty コンストラクタ
PdfProperty クラス 参照
コンストラクタ

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public PdfProperty(
    HtmlControl parent
)
Visual Basic (宣言)
Public Sub New ( _
    parent As HtmlControl _
)

パラメータ

parent
Type: AdvanceSoftware.ExcelWebForm..::..HtmlControl
AdvanceSoftware.ExcelWebForm.HtmlControl を指定します。

参照

PdfProperty クラス


PdfProperty プロパティ

[image] [image]

ExcelWebForm
PdfProperty プロパティ
PdfProperty クラス 参照

PdfProperty データ型で公開されるメンバを以下に示します。

プロパティ

 | 名前 | 説明
Public property | Application | PDF のアプリケーションを設定します。
Public property | ApplyPrintArea | PDF ファイル出力時に印刷範囲を適用するかを指定します。
Public property | Author | PDF の作成者を設定します。
Public property | EmbedFonts | 埋め込むフォントを設定します。
Public property | EncryptionType | PDF ファイルの暗号化強度を設定します。PdfEncryptionType 列挙体で指定してください。
Public property | EUDCFiles | PDF ファイルで使用する外字ファイル名と対象とするフォント名を指定します。 フォントの種類毎に外字ファイルを切り替えることが可能です。
Public property | ImageType | イメージの種類を設定します。
Public property | IsReplaceYenSign | PDF ファイルに出力する文字列の"\"マークの扱いを指定します。
Public property | OwnerPassword | PDF ファイルのオーナーパスワードを設定します。
Public property | PatternQuality | PDF のパターンの解像度を設定します。
Public property | Permit | PDF ファイルの権限を設定します。複数の指定時は PdfPermit 列挙体を or(|) で連結します。
Public property | Producer | PDF 変換を設定します。
Public property | Quality | PDF の解像度を設定します。
Public property | StreamMode | PDF ファイル出力時の StreamMode を指定します。
Public property | Subject | PDF のサブタイトルを設定します。
Public property | Title | PDF のタイトルを設定します。
Public property | UserPassword | PDF ファイルのユーザーパスワードを設定します。

参照

PdfProperty クラス


Application プロパティ

[image]

ExcelWebForm
PdfProperty..::..Application プロパティ
PdfProperty クラス 使用例 参照
PDF のアプリケーションを設定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public string Application { set; }
Visual Basic (宣言)
Public WriteOnly Property Application As String
    Set

プロパティ値

PDF ファイルの文書のプロパティ概要「アプリケーション」。(既定値:ExcelWebForm)

使用例

コピーC#
// PDF ファイルの文書のプロパティ「アプリケーション」に "アプリケーション" を設定します。
HtmlControl1.Pdf.Application = "アプリケーション";
コピーVB.NET
' PDF ファイルの文書のプロパティ「アプリケーション」に "アプリケーション" を設定します。
HtmlControl1.Pdf.Application = "アプリケーション"

参照

PdfProperty クラス


ApplyPrintArea プロパティ

[image]

ExcelWebForm
PdfProperty..::..ApplyPrintArea プロパティ
PdfProperty クラス 使用例 参照
PDF ファイル出力時に印刷範囲を適用するかを指定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public bool ApplyPrintArea { set; }
Visual Basic (宣言)
Public WriteOnly Property ApplyPrintArea As Boolean
    Set

使用例

コピーC#
// PDF ファイル出力時に印刷範囲を適用します。
HtmlControl1.Pdf.ApplyPrintArea = true;
コピーVB.NET
' PDF ファイル出力時に印刷範囲を適用します。
HtmlControl1.Pdf.ApplyPrintArea = True

参照

PdfProperty クラス


Author プロパティ

[image]

ExcelWebForm
PdfProperty..::..Author プロパティ
PdfProperty クラス 使用例 参照
PDF の作成者を設定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public string Author { set; }
Visual Basic (宣言)
Public WriteOnly Property Author As String
    Set

プロパティ値

PDF ファイルの文書のプロパティ概要「作成者」。(既定値:Advance Software Corp.)

使用例

コピーC#
// PDF ファイルの文書のプロパティ「作成者」に "作成者" を設定します。
HtmlControl1.Pdf.Author = "作成者";
コピーVB.NET
' PDF ファイルの文書のプロパティ「作成者」に "作成者" を設定します。
HtmlControl1.Pdf.Author = "作成者"

参照

PdfProperty クラス


EmbedFonts プロパティ

[image]

ExcelWebForm
PdfProperty..::..EmbedFonts プロパティ
PdfProperty クラス 使用例 参照
埋め込むフォントを設定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public string[] EmbedFonts { set; }
Visual Basic (宣言)
Public WriteOnly Property EmbedFonts As String()
    Set

プロパティ値

PDF ファイルに埋め込むフォント名。

解説

設定したフォントが帳票内で使用されていない場合は、PDF ファイルには埋め込まれません。 "*" を設定した場合、帳票内で使用しているフォントを全て埋め込みます。

使用例

コピーC#
// PDF ファイルにフォント "ＭＳ Ｐゴシック" を埋め込みます。
HtmlControl1.Pdf.EmbedFonts = new string[] { "ＭＳ Ｐゴシック" };
コピーVB.NET
' PDF ファイルにフォント "ＭＳ Ｐゴシック" を埋め込みます。
HtmlControl1.Pdf.EmbedFonts = New String() {"ＭＳ Ｐゴシック"}

参照

PdfProperty クラス


EncryptionType プロパティ

[image]

ExcelWebForm
PdfProperty..::..EncryptionType プロパティ
PdfProperty クラス 使用例 参照
PDF ファイルの暗号化強度を設定します。PdfEncryptionType 列挙体で指定してください。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public PdfEncryptionType EncryptionType { set; }
Visual Basic (宣言)
Public WriteOnly Property EncryptionType As PdfEncryptionType
    Set

使用例

コピーC#
// PDF ファイルの暗号化強度を "Acrobat6_RC4_128" に設定します。
HtmlControl1.Pdf.EncryptionType = AdvanceSoftware.ExcelWebForm.PdfEncryptionType.Acrobat6_RC4_128;
HtmlControl1.Pdf.OwnerPassword = "owner";
HtmlControl1.Pdf.UserPassword = "user";
AdvanceSoftware.ExcelWebForm.PdfPermit pdfPermit = 0;
pdfPermit = pdfPermit | AdvanceSoftware.ExcelWebForm.PdfPermit.Print | AdvanceSoftware.ExcelWebForm.PdfPermit.PrintHigh | AdvanceSoftware.ExcelWebForm.PdfPermit.Copy;
HtmlControl1.Pdf.Permit = pdfPermit;
コピーVB.NET
' PDF ファイルの暗号化強度を "Acrobat6_RC4_128" に設定します。
HtmlControl1.Pdf.EncryptionType = AdvanceSoftware.ExcelWebForm.PdfEncryptionType.Acrobat6_RC4_128
HtmlControl1.Pdf.OwnerPassword = "owner"
HtmlControl1.Pdf.UserPassword = "user"
Dim pdfPermit As AdvanceSoftware.ExcelWebForm.PdfPermit = 0
pdfPermit = pdfPermit Or AdvanceSoftware.ExcelWebForm.PdfPermit.Print Or AdvanceSoftware.ExcelWebForm.PdfPermit.PrintHigh Or AdvanceSoftware.ExcelWebForm.PdfPermit.Copy
HtmlControl1.Pdf.Permit = pdfPermit

参照

PdfProperty クラス


EUDCFiles プロパティ

[image]

ExcelWebForm
PdfProperty..::..EUDCFiles プロパティ
PdfProperty クラス 使用例 参照
PDF ファイルで使用する外字ファイル名と対象とするフォント名を指定します。 フォントの種類毎に外字ファイルを切り替えることが可能です。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public string[][] EUDCFiles { set; }
Visual Basic (宣言)
Public WriteOnly Property EUDCFiles As String()()
    Set

解説

フォント名と、ファイルパスの設定方法により、PDF で使用される外字の状態が異なります。 【フォント名】 ・パターン1・・・特定のフォント名 ファイルパスに設定された外字ファイルを参照します。 環境の同一フォントに対する外字設定は無視されます。 ・パターン2・・・SystemDefaultEUDCFont 環境に設定されたデフォルトの外字設定を、ファイルパスに設定し た外字ファイルから読み込みます。 環境のデフォルトのフォント設定は無視されます。 ・パターン3・・・空文字("") 環境に登録されたすべての外字設定を無視します。 使用する外字を全て手動で指定したい場合は、この設定を含めて ください。 【ファイルパス】 ・パターン1・・・存在するファイルパス 指定したフォントに対して、このパスの外字ファイルが取り込まれます。 ・パターン2・・・存在しないファイルパス 指定したフォントの外字設定は無視され、環境に同一フォントの 外字設定がある場合、そちらが読み込まれます。 ・パターン3・・・空文字("") 指定したフォントに対する、外字の設定を行ないません。 環境の設定も無視されます。

使用例

コピーC#
// 環境の外字設定を無視して "ＭＳ 明朝" の外字を指定します。
HtmlControl1.Pdf.EUDCFiles = new string[][] { new string[] { "ＭＳ 明朝", @"C:\ms_mintyou.TTE" }, new string[] { "", "" } };
コピーVB.NET
' 環境の外字設定を無視して "ＭＳ 明朝" の外字を指定します。
HtmlControl1.Pdf.EUDCFiles = New String()() {New String() {"ＭＳ 明朝", "C:\ms_mintyou.TTE"}, New String() {"", ""}}

参照

PdfProperty クラス


ImageType プロパティ

[image]

ExcelWebForm
PdfProperty..::..ImageType プロパティ
PdfProperty クラス 使用例 参照
イメージの種類を設定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public ImageType ImageType { set; }
Visual Basic (宣言)
Public WriteOnly Property ImageType As ImageType
    Set

プロパティ値

イメージの種類を表す ImageType。

使用例

コピーC#
// PDF ファイルのイメージの種類を "GIF 形式" に設定します。
HtmlControl1.Pdf.ImageType = AdvanceSoftware.ExcelWebForm.ImageType.GIF;
コピーVB.NET
' PDF ファイルのイメージの種類を "GIF 形式" に設定します。
HtmlControl1.Pdf.ImageType = AdvanceSoftware.ExcelWebForm.ImageType.GIF

参照

PdfProperty クラス


IsReplaceYenSign プロパティ

[image]

ExcelWebForm
PdfProperty..::..IsReplaceYenSign プロパティ
PdfProperty クラス 使用例 参照
PDF ファイルに出力する文字列の"\"マークの扱いを指定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public bool IsReplaceYenSign { set; }
Visual Basic (宣言)
Public WriteOnly Property IsReplaceYenSign As Boolean
    Set

使用例

コピーC#
// \ マークをバックスラッシュとして扱います。
HtmlControl1.Pdf.IsReplaceYenSign = false;
コピーVB.NET
' \ マークをバックスラッシュとして扱います。
HtmlControl1.Pdf.IsReplaceYenSign = False

参照

PdfProperty クラス


OwnerPassword プロパティ

[image]

ExcelWebForm
PdfProperty..::..OwnerPassword プロパティ
PdfProperty クラス 使用例 参照
PDF ファイルのオーナーパスワードを設定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public string OwnerPassword { set; }
Visual Basic (宣言)
Public WriteOnly Property OwnerPassword As String
    Set

使用例

コピーC#
HtmlControl1.Pdf.EncryptionType = AdvanceSoftware.ExcelWebForm.PdfEncryptionType.Acrobat6_RC4_128;
// PDF ファイルのオーナーパスワードを "owner" に設定します。
HtmlControl1.Pdf.OwnerPassword = "owner";
HtmlControl1.Pdf.UserPassword = "user";
AdvanceSoftware.ExcelWebForm.PdfPermit pdfPermit = 0;
pdfPermit = pdfPermit | AdvanceSoftware.ExcelWebForm.PdfPermit.Print | AdvanceSoftware.ExcelWebForm.PdfPermit.PrintHigh | AdvanceSoftware.ExcelWebForm.PdfPermit.Copy;
HtmlControl1.Pdf.Permit = pdfPermit;
コピーVB.NET
HtmlControl1.Pdf.EncryptionType = AdvanceSoftware.ExcelWebForm.PdfEncryptionType.Acrobat6_RC4_128
' PDF ファイルのオーナーパスワードを "owner" に設定します。
HtmlControl1.Pdf.OwnerPassword = "owner"
HtmlControl1.Pdf.UserPassword = "user"
Dim pdfPermit As AdvanceSoftware.ExcelWebForm.PdfPermit = 0
pdfPermit = pdfPermit Or AdvanceSoftware.ExcelWebForm.PdfPermit.Print Or AdvanceSoftware.ExcelWebForm.PdfPermit.PrintHigh Or AdvanceSoftware.ExcelWebForm.PdfPermit.Copy
HtmlControl1.Pdf.Permit = pdfPermit

参照

PdfProperty クラス


PatternQuality プロパティ

[image]

ExcelWebForm
PdfProperty..::..PatternQuality プロパティ
PdfProperty クラス 使用例 参照
PDF のパターンの解像度を設定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public int PatternQuality { set; }
Visual Basic (宣言)
Public WriteOnly Property PatternQuality As Integer
    Set

プロパティ値

PDF に出力する場合のセルパターンの解像度。

使用例

コピーC#
// PDF ファイル作成時のセルパターンの解像度を "600" に設定します。
HtmlControl1.Pdf.PatternQuality = 600;
コピーVB.NET
' PDF ファイル作成時のセルパターンの解像度を "600" に設定します。
HtmlControl1.Pdf.PatternQuality = 600

参照

PdfProperty クラス


Permit プロパティ

[image]

ExcelWebForm
PdfProperty..::..Permit プロパティ
PdfProperty クラス 使用例 参照
PDF ファイルの権限を設定します。複数の指定時は PdfPermit 列挙体を or(|) で連結します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public PdfPermit Permit { set; }
Visual Basic (宣言)
Public WriteOnly Property Permit As PdfPermit
    Set

使用例

コピーC#
HtmlControl1.Pdf.EncryptionType = AdvanceSoftware.ExcelWebForm.PdfEncryptionType.Acrobat6_RC4_128;
HtmlControl1.Pdf.OwnerPassword = "owner";
HtmlControl1.Pdf.UserPassword = "user";
// PDF ファイルの権限で「高精度な印刷」と「内容のコピー」を許可します。
AdvanceSoftware.ExcelWebForm.PdfPermit pdfPermit = 0;
pdfPermit = pdfPermit | AdvanceSoftware.ExcelWebForm.PdfPermit.Print | AdvanceSoftware.ExcelWebForm.PdfPermit.PrintHigh | AdvanceSoftware.ExcelWebForm.PdfPermit.Copy;
HtmlControl1.Pdf.Permit = pdfPermit;
コピーVB.NET
HtmlControl1.Pdf.EncryptionType = AdvanceSoftware.ExcelWebForm.PdfEncryptionType.Acrobat6_RC4_128
HtmlControl1.Pdf.OwnerPassword = "owner"
HtmlControl1.Pdf.UserPassword = "user"
' PDF ファイルの権限で「高精度な印刷」と「内容のコピー」を許可します。
Dim pdfPermit As AdvanceSoftware.ExcelWebForm.PdfPermit = 0
pdfPermit = pdfPermit Or AdvanceSoftware.ExcelWebForm.PdfPermit.Print Or AdvanceSoftware.ExcelWebForm.PdfPermit.PrintHigh Or AdvanceSoftware.ExcelWebForm.PdfPermit.Copy
HtmlControl1.Pdf.Permit = pdfPermit

参照

PdfProperty クラス


Producer プロパティ

[image]

ExcelWebForm
PdfProperty..::..Producer プロパティ
PdfProperty クラス 使用例 参照
PDF 変換を設定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public string Producer { set; }
Visual Basic (宣言)
Public WriteOnly Property Producer As String
    Set

プロパティ値

PDF ファイルの文書のプロパティ概要「PDF 変換」。(既定値:ExcelWebForm)

使用例

コピーC#
// PDF ファイルの文書のプロパティ「PDF 変換」に "PDF 変換" を設定します。
HtmlControl1.Pdf.Producer = "PDF 変換";
コピーVB.NET
' PDF ファイルの文書のプロパティ「PDF 変換」に "PDF 変換" を設定します。
HtmlControl1.Pdf.Producer = "PDF 変換"

参照

PdfProperty クラス


Quality プロパティ

[image]

ExcelWebForm
PdfProperty..::..Quality プロパティ
PdfProperty クラス 使用例 参照
PDF の解像度を設定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public int Quality { set; }
Visual Basic (宣言)
Public WriteOnly Property Quality As Integer
    Set

プロパティ値

PDF ファイルの解像度。

使用例

コピーC#
// PDF ファイル作成時の解像度を "600" に設定します。
HtmlControl1.Pdf.Quality = 600;
コピーVB.NET
' PDF ファイル作成時の解像度を "600" に設定します。
HtmlControl1.Pdf.Quality = 600

参照

PdfProperty クラス


StreamMode プロパティ

[image]

ExcelWebForm
PdfProperty..::..StreamMode プロパティ
PdfProperty クラス 使用例 参照
PDF ファイル出力時の StreamMode を指定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public StreamMode StreamMode { set; }
Visual Basic (宣言)
Public WriteOnly Property StreamMode As StreamMode
    Set

使用例

コピーC#
// PDF ファイル出力時の動作モードを File に設定します。
HtmlControl1.Pdf.StreamMode = AdvanceSoftware.ExcelWebForm.StreamMode.File;
コピーVB.NET
' PDF ファイル出力時の動作モードを File に設定します。
HtmlControl1.Pdf.StreamMode = AdvanceSoftware.ExcelWebForm.StreamMode.File

参照

PdfProperty クラス


Subject プロパティ

[image]

ExcelWebForm
PdfProperty..::..Subject プロパティ
PdfProperty クラス 使用例 参照
PDF のサブタイトルを設定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public string Subject { set; }
Visual Basic (宣言)
Public WriteOnly Property Subject As String
    Set

プロパティ値

PDF ファイルの文書のプロパティ概要「サブタイトル」。(既定値:シート名)

使用例

コピーC#
// PDF ファイルの文書のプロパティ「サブタイトル」に "サブタイトル" を設定します。
HtmlControl1.Pdf.Subject = "サブタイトル";
コピーVB.NET
' PDF ファイルの文書のプロパティ「サブタイトル」に "サブタイトル" を設定します。
HtmlControl1.Pdf.Subject = "サブタイトル"

参照

PdfProperty クラス


Title プロパティ

[image]

ExcelWebForm
PdfProperty..::..Title プロパティ
PdfProperty クラス 使用例 参照
PDF のタイトルを設定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public string Title { set; }
Visual Basic (宣言)
Public WriteOnly Property Title As String
    Set

プロパティ値

PDF ファイルの文書のプロパティ概要「タイトル」。(既定値:ExcelWebForm)

使用例

コピーC#
// PDF ファイルの文書のプロパティ「タイトル」に "タイトル" を設定します。
HtmlControl1.Pdf.Title = "タイトル";
コピーVB.NET
' PDF ファイルの文書のプロパティ「タイトル」に "タイトル" を設定します。
HtmlControl1.Pdf.Title = "タイトル"

参照

PdfProperty クラス


UserPassword プロパティ

[image]

ExcelWebForm
PdfProperty..::..UserPassword プロパティ
PdfProperty クラス 使用例 参照
PDF ファイルのユーザーパスワードを設定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.HtmlControl (ExcelWebForm.HtmlControl.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public string UserPassword { set; }
Visual Basic (宣言)
Public WriteOnly Property UserPassword As String
    Set

使用例

コピーC#
HtmlControl1.Pdf.EncryptionType = AdvanceSoftware.ExcelWebForm.PdfEncryptionType.Acrobat6_RC4_128;
HtmlControl1.Pdf.OwnerPassword = "owner";
// PDF ファイルのユーザーパスワードを "user" に設定します。
HtmlControl1.Pdf.UserPassword = "user";
AdvanceSoftware.ExcelWebForm.PdfPermit pdfPermit = 0;
pdfPermit = pdfPermit | AdvanceSoftware.ExcelWebForm.PdfPermit.Print | AdvanceSoftware.ExcelWebForm.PdfPermit.PrintHigh | AdvanceSoftware.ExcelWebForm.PdfPermit.Copy;
HtmlControl1.Pdf.Permit = pdfPermit;
コピーVB.NET
HtmlControl1.Pdf.EncryptionType = AdvanceSoftware.ExcelWebForm.PdfEncryptionType.Acrobat6_RC4_128
HtmlControl1.Pdf.OwnerPassword = "owner"
' PDF ファイルのユーザーパスワードを "user" に設定します。
HtmlControl1.Pdf.UserPassword = "user"
Dim pdfPermit As AdvanceSoftware.ExcelWebForm.PdfPermit = 0
pdfPermit = pdfPermit Or AdvanceSoftware.ExcelWebForm.PdfPermit.Print Or AdvanceSoftware.ExcelWebForm.PdfPermit.PrintHigh Or AdvanceSoftware.ExcelWebForm.PdfPermit.Copy
HtmlControl1.Pdf.Permit = pdfPermit

参照

PdfProperty クラス


StreamMode 列挙体

[image]

ExcelWebForm
StreamMode 列挙体
参照
データを展開するストリームモードを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelWebForm
アセンブリ: ExcelWebForm.Shared (ExcelWebForm.Shared.dll 内) バージョン: 1.0.5270.1006 (1.0.5270.1006)

構文

C#
public enum StreamMode
Visual Basic (宣言)
Public Enumeration StreamMode

メンバ

メンバ名 | 説明
Memory | メモリ上に展開します。
File | ファイルに展開します。

参照


よくあるご質問

[image]

ExcelWebForm
FAQ

このトピックでは、ExcelWebForm のよくあるご質問について説明します。また、弊社 Web サイトにはより詳細な FAQ を記載しています。詳細については弊社 Web サイトの「FAQ」をご確認ください。

このトピックは、次のセクションを含みます。

  • 英語版など、日本語以外の環境に対応していますか。
  • 64ビット版 Windows に対応していますか。
  • 体験版がインストールされた環境に、体験版をアンインストールせずに、製品版をインストールしても良いでしょうか。
  • 体験版で作成したアプリケーションを製品版に置き換えて使用しても問題はないでしょうか。
  • 対応する Excel バージョン、ファイル形式を教えてください。
  • 環境に Excel アプリケーションがインストールされている必要がありますか。
  • Excel のフォントや罫線などの書式も HTML に展開されますか。
  • 同一の HTML ファイルに複数の Excel シートのデータを展開することはできますか。
  • 計算式の計算結果が更新されません。
  • JavaScript 外部ファイルの改変について。

英語版など、日本語以外の環境に対応していますか。

ExcelWebForm は、日本語の環境のみ対応しています。英語版など、日本語以外の環境では動作を保証しておりません。

64ビット版 Windows に対応していますか。

ExcelWebForm に収録のアプリケーション、および、製品アセンブリファイル(.dll)は、プラットフォーム(x86,x64)による依存はありません。

体験版がインストールされた環境に、体験版をアンインストールせずに、製品版をインストールしても良いでしょうか。

ExcelWebForm の体験版を事前にアンインストールし、製品版をインストールしてください。

体験版で作成したアプリケーションを製品版に置き換えて使用しても問題はないでしょうか。

ExcelWebForm 体験版で作成したアプリケーションを、製品版に置き換えて使用することができます。ExcelWebForm のアセンブリファイルをアプリケーションフォルダに配置して実行している場合は、製品版のファイルをコピーしてご対応ください。なお、体験版の DLL は実行環境での動作検証以外の目的により、配布することはできません。

対応する Excel バージョン、ファイル形式を教えてください。

ExcelWebForm は、以下の Excel バージョン、ファイル形式に対応しています。

  • Excel 2003(xls 形式)
  • Excel 2007 / 2010 / 2013(xlsx 形式)

    • なお、Excel 2007 以降のバージョンにおいて、Excel の互換機能で作成された xls 形式の Excel ファイルにつきましては、基本的な動作に問題がないことを確認しておりますが、正式な動作保証は行っておりません。

    環境に Excel アプリケーションがインストールされている必要がありますか。

    ExcelWebForm は、環境の Excel アプリケーションに依存せず、Excel シートのデータを読み込み HTML のテーブルに展開することができるため、環境に Excel をインストールする必要はありません。但し、HTML に展開する Excel のデータは Excel アプリケーション側で作成、編集して頂く必要がございます。
    メモ:
    ExcelWeb Tool Ver2.0 では Excel ブックの新規作成が可能ですが、空のブック、シートの作成のみとなり、データの編集には対応しておりません。

    Excel のフォントや罫線などの書式も HTML に展開されますか。

    ExcelWebForm が Excel シートから HTML テーブルに展開する際、対応する Excel の書式は「ExcelWebForm が対応する Excel の書式一覧」をご覧ください。なお、一覧に記載のない書式や機能は基本的に対応しておりません。詳細は弊社 Web サイトの お問い合わせ窓口 よりお問い合わせください。

    同一の HTML ファイルに複数の Excel シートのデータを展開することはできますか。

    ExcelWebForm は、同一の HTML ファイルに複数の Excel シートのデータを展開することはできません。既に Excel シートのデータが展開されている HTML ファイルをスキンとし、異なる Excel シートのデータを展開した場合、ExcelWebForm が出力する HTML タグの ID が重複し、不正な動作となる可能性がございます。

    計算式の計算結果が更新されません。

    ExcelWebForm が対応する Excel の計算式は「ExcelWebForm が対応する Excel の書式一覧」をご確認ください。なお、展開した HTML 上で計算式の参照セルの値を編集し Excel ファイルに保存した場合、参照セルの値のみ更新され、新しい計算結果は更新されません。そのため、保存後の Excel ファイルをコントロール上で開き直した際は、新しい計算結果が反映されない動作となります。上記の場合、Excel アプリケーション側で再計算を行い、保存し直した Excel ファイルを再度読み込む方法でご対応ください。

    JavaScript 外部ファイルの改変について。

    ExcelWebForm で提供しております JavaScript 外部ファイル(tablecreator.js、など)は、提供時の状態でのみ弊社にて動作保証を行っております。そのため、コードを部分的に改変されたり、お客様が独自に作成したファイルを使用された場合の動作については、弊社にて動作保証を行っておりません。


ExcelWebForm の概要

[image]

ExcelWebForm
ExcelWebForm の概要

ExcelWebForm は、Excel シートの内容をダイレクトに HTML のテーブルに展開するアプリケーション、および、開発ツールです。

システム動作環境

ExcelWebForm の動作環境を説明します。

ExcelWebForm が対応する Excel の書式一覧

ExcelWebForm が対応する Excel の書式一覧を説明します。

製品のインストールとアンインストール

ExcelWebForm のインストールとアンインストールする方法を説明します。

サンプル

ExcelWebForm の付属サンプルを説明します。

アプリケーションの配布

アプリケーションを配布する方法を説明します。

ライセンス体系

ExcelWebForm のライセンス体系を説明します。

体験版について

ExcelWebForm の体験版について説明します。

サポートサービス

ExcelWebForm のサポートサービスを説明します。

ExcelWebForm ヘルプ フィードバック

このヘルプについてのご提案や障害報告をお送りいただく場合は、弊社 Web サイトの ユーザーサポートフォーム よりご連絡ください。

  • ドキュメントに表記されている会社名、製品名は一般に各社の商標または登録商標です。
  • 製品の仕様は品質改良の為、予告なく変更することがあります。