Yubin7 Ver2.6 の概要

[image]

Yubin7 Ver2.6
Yubin7 Ver2.6 の概要

Yubin7 Ver2.6 は、住所や郵便番号を検索をすることが可能です。ここでは、Yubin7 Ver2.6 の概要を説明します。

システム動作環境

Yubin7 Ver2.6 の動作環境を説明します。

製品のインストールとアンインストール

Yubin7 Ver2.6 のインストールとアンインストール方法を説明します。

バージョン情報

Yubin7 Ver2.6 のバージョン情報の確認方法を説明します。

体験版について

Yubin7 Ver2.6 体験版について説明します。

サンプル

Yubin7 Ver2.6 の付属サンプルについて説明します。

アプリケーションの配布

アプリケーションを配布する方法を説明します。

ライセンス体系

Yubin7 Ver2.6 のライセンス体系を説明します。

サポートサービス

Yubin7 Ver2.6 のサポートサービスを説明します。

Yubin7 Ver2.6 ヘルプ フィードバック

このヘルプについてのご意見や障害報告をお送りいただく場合は、弊社 Web サイトのお問い合わせフォーム よりご連絡ください。

  • ドキュメントに表記されている会社名、製品名は一般に各社の商標または登録商標です。
  • 製品の仕様は品質改良の為、予告なく変更することがあります。

©2014 Advance Software inc. All rights reserved.


システム動作環境

[image]

Yubin7 Ver2.6
システム動作環境

Yubin7 Ver2.6 の動作環境を次に示します。

このトピックは、次のセクションを含みます。

  • 開発環境
  • 実行環境
メモ:

開発、実行環境すべて日本語環境のみサポートします。

開発環境

OS

Windows Vista(SP2 以上) / Windows 7(SP1 以上) / Windows 8 / Windows 8.1 / Windows Server 2008(SP2 以上) / Windows Server 2008 R2(SP1 以上) / Windows Server 2012 / Windows Server 2012 R2

ハードディスク

100MB 以上の空き容量が必要です。

メモリ

1GB 以上の利用可能メモリが必要です。

Visual Studio

Visual Studio 2008 / 2010 / 2012 / 2013

開発言語

Visual Basic、Visual C＃

実行環境

OS

Windows Vista(SP2 以上) / Windows 7(SP1 以上) / Windows 8 / Windows 8.1 / Windows Server 2008(SP2 以上) / Windows Server 2008 R2(SP1 以上) / Windows Server 2012 / Windows Server 2012 R2

.NET Framework

.NET Framework 3.5 (SP1 以上)

Microsoft Excel

Excel 2003 / 2007 / 2010 / 2013

Microsoft Access

Access 2003 / 2007 / 2010 / 2013


製品のインストールとアンインストール

[image]

Yubin7 Ver2.6
製品のインストールとアンインストール

このトピックでは、Yubin7 Ver2.6 のアンインストール方法を説明します。

このトピックは、次のセクションを含みます。

  • 製品のアンインストール

製品のアンインストール

本製品をアンインストールする場合、下記のいずれかの手順で対応してください。

スタートメニューからアンインストールするには

  1. [スタート] メニューの [プログラム] - [Yubin7 Ver2.6] - [アンインストール] をクリックします。

  2. 画面に従い、アンインストールを実行します。

「プログラムの追加と削除」からアンインストールするには

  1. [スタート] メニューの [コントロール パネル] をクリックします。

  2. [プログラムと機能] をクリックします。

  3. 一覧の [Yubin7 Ver2.6] を右クリックして、[アンインストールと変更] をクリックします。

  4. 画面に従い、アンインストールを実行します。

メモ:

インストール後に製品のファイルを移動した場合や、INSTALL.LOG ファイルを削除した場合、アンインストールされません。 また、製品に収録されているサンプル プロジェクトなど、Visual Studio によって作成、編集されたファイルについては、アンインストールできません。


体験版について

[image]

Yubin7 Ver2.6
体験版について

Yubin7 Ver2.6 体験版は、以下の制限事項がございます。

制限事項

  • 先頭から50件までの変換制限があります。
  • 体験版はインストール後、60日間使用することができます。
  • .NET Framework 用アセンブリを使用することはできません。
  • 体験版の DLL は実行環境での動作検証以外の目的で配布することはできません。

注意:

製品版をインストールする場合、体験版を必ずアンインストールしてからインストールを実行してください。


サンプル

[image]

Yubin7 Ver2.6
サンプル

Yubin7 Ver2.6 のサンプルについて説明します。

サンプル格納場所

サンプルの格納場所を説明します。

Web アプリケーションを配置する

Web アプリケーションを配置する手順を説明します。


サンプルファイルの格納場所

[image]

Yubin7 Ver2.6
サンプルファイルの格納場所

Yubin7 Ver2.6 には、Visual Basic、および、Visual C# で作成したサンプルが付属しています。

Yubin7 Ver2.6 のサンプルファイルは、Visual Studio 2008 / 2010 / 2012 / 2013 共通で使用できるサンプル (Windows サンプル、Web サンプル) がインストールされます。 また、Yubin7 Ver2.6 をアンインストールすると、サンプルファイルも削除されます。

開発言語ごとにサンプル ファイルの既定の場所を以下の表に示します。 %install% は、Yubin7 Ver2.6 のインストールフォルダ (C:\Program Files\Yubin7V2\Yu7V25 など) を表します。

サンプルの種類 | サンプルの場所
Visual Basic Windows サンプル (WindowsSampleVB) | \%install%\Samples\VB\WindowsSampleVB
Visual Basic Web サンプル (WebSampleVB) | \%install%\Samples\VB\WebSampleVB
Visual C# Windows サンプル (WindowsSampleCS) | \%install%\Samples\CS\WindowsSampleCS
Visual C# Web サンプル (WebSampleCS) | \%install%\Samples\CS\WebSampleCS

参照

サンプル


Web アプリケーションを配置する

[image]

Yubin7 Ver2.6
Web アプリケーションを配置する

Web アプリケーションの配置について、Yubin7 Ver2.6 サンプルの Web サンプル (WebSample) を使用した手順を以下に示します。

Caution note 注意:

このトピックの手順で Web アプリケーションを配置する場合、ローカル コンピュータに インターネット インフォメーション サービス (IIS) がインストールされている必要があります。 また、ローカル コンピュータの Administrators グループのメンバとしてログオンするか、適切な権限が委任されている必要があります。

IIS マネージャを起動して Web アプリケーションの仮想ディレクトリを作成します。

[ファイル名を指定して実行] から IIS マネージャを起動するには

  1. [スタート] メニューの [ファイル名を指定して実行] をクリックします。

  2. [名前] ボックスに "inetmgr" と入力して [OK] ボタンをクリックします。

[管理ツール] から IIS マネージャを起動するには

  1. [スタート] メニューの [コントロール パネル] をクリックします。

  2. [管理ツール] 内の [インターネット インフォメーション サービス] をクリックします。

仮想ディレクトリを作成するには (IIS 7.5)

  1. 次の Web サンプルのインストールフォルダ内に格納されているソリューションファイル (WebSample_20XX.sln) からプロジェクトを開き、Visual Studio 上でサンプルをビルドします。

    Visual Basic
    \%install%\Samples\VB\WebSampleVB
    Visual C#
    \%install%\Samples\CS\WebSampleCS

  2. IIS マネージャで、仮想ディレクトリを追加するローカル コンピュータおよび Web サイトを展開します。仮想ディレクトリを作成するサイトまたはフォルダを右クリックし、[仮想ディレクトリの追加] をクリックして、[仮想ディレクトリの追加] 画面を表示します。

  3. [エイリアス] ボックスに、仮想ディレクトリの名前 "WebSample" を入力します。

  4. [物理パス] ボックスのボタン ( ボタン02) をクリックして、[フォルダの参照] 画面を表示します。

  5. 次の Web サンプルのインストールフォルダを選択して [OK] ボタンをクリックします。

    Visual Basic
    \%install%\Samples\VB\WebSampleVB
    Visual C#
    \%install%\Samples\CS\WebSampleCS
    Note メモ:

    %install% は、Yubin7 Ver 2.5 のインストールフォルダ (C:\Program Files\Yubin7V2\Yu7V25\ など) を表します。

  6. 追加した仮想ディレクトリ "WebSample" を右クリックして、[アプリケーションへの変換] をクリックします。

  7. [アプリケーションの追加] 画面の [OK] ボタンをクリックします。

  8. IIS マネージャを終了します。

参照

サンプル


アプリケーションの配布

[image]

Yubin7 Ver2.6
アプリケーションの配布

Yubin7 Ver2.6 を使用して作成したアプリケーションを配布する場合、以下の再配布可能ファイルをアプリケーションと一緒に配布してください。

このトピックは、次のセクションを含みます。

  • 再配布可能ファイル
  • 再配布可能ファイルの格納場所
  • 再配布可能ファイルの配置
  • 再配布の条件

再配布可能ファイル

ファイル名 | 内容
Yubin7.AdvZip.dll | 郵便番号変換エンジン
Yubin7.BarCode.dll | バーコードクラス

再配布可能ファイルの格納場所

再配布可能ファイル (DLL) は、インストールフォルダ内の下記のフォルダに格納されます。

<%Install%>\Bin

メモ:
%install% は、Yubin7 Ver2.6 のインストールフォルダ (C:\Program Files\Yubin7V2\Yu7V25\ など) を表します。

再配布可能ファイルの配置

再配布可能ファイル (DLL) は、以下のいずれかの方法で実行環境に配布します。

  • アプリケーションと同じフォルダに配置する
  • 下記の方法で再配布可能ファイルをグローバルアセンブリキャッシュ (GAC) へ登録する
注意:

登録および解除時は、Administrators グループのメンバとしてログオンする必要があります。

グローバルアセンブリキャッシュツール (gacutil.exe) で登録、解除をする

.NET Framework SDK のグローバルアセンブリキャッシュツール (gacutil.exe) を使用して登録します。 コマンドプロンプト、または「ファイル名を指定して実行」ダイアログボックスで以下のように実行します。

コピー登録例
C:\gacutil.exe /i "C:\Program Files\Application\Yubin7.AdvZip.dll"

登録例は、gacutil.exe が C ドライブのルートに存在し、Yubin7 Ver2.6 郵便番号変換エンジン (Yubin7.AdvZip.dll) が C:\Program Files\Application フォルダにあると仮定しています。 また、登録を解除する場合、以下のように実行します。

コピー解除例
C:\gacutil.exe /u "Yubin7.AdvZip"
ヒント:

登録の解除は、dll ファイル名ではなくアセンブリ名を指定します。

Windows エクスプローラ上で登録、解除をする

Yubin7 Ver2.6 のアセンブリは、Windows エクスプローラ上で、グローバルアセンブリキャッシュ (例：\Windows\assembly) にドラッグ アンド ドロップすることが可能です。 なお、グローバルアセンブリキャッシュの登録や解除方法の詳細については、Visual Studio のオンラインヘルプを参照してください。

再配布の条件

著作権表示

本製品は、アドバンスソフトウェア株式会社が有する著作権により保護されております。本製品を配布する際、可能な限り、アドバンスソフトウェアの著作権表示をしていただく必要があります。著作権表示は以下の通りに表示してください。

  • パッケージ (店頭などに配置する形態の製品の梱包物のこと) に対する表示方法
    本製品は、アドバンスソフトウェア株式会社の著作物である「Yubin7 Ver2.6」を再配布条件に基づき使用しています。
  • マニュアル、またはこれに類する物への表示方法
    本製品は、アドバンスソフトウェア株式会社の著作物である「Yubin7 Ver2.6」を再配布条件に基づき使用しています。
  • プログラム使用許諾契約書、またはこれに類する物への表示方法
    本製品は、アドバンスソフトウェア株式会社の著作物である「Yubin7 Ver2.6」を再配布条件に基づき使用しています。 アドバンスソフトウェア株式会社の著作物はバックアップの目的以外では一切の複写を許可しません。

    再配布先のサポート

    再配布先のサポートについては、一切行いません。サポートは再配布元であるお客様において行ってください。なお、サーバーライセンスを取得した配布先の弊社製品に関するサポートは、サーバーライセンスの保守契約が必要になります。サーバーライセンスの保守契約の詳細やお申し込みについては、「サポートサービス」よりお問い合わせください。

    • ©2014 Advance Software inc. All rights reserved.


ライセンス体系

[image]

Yubin7 Ver2.6
ライセンス体系

Yubin7 Ver2.6 のアセンブリ(Yubin7.AdvZip.dll、Yubin7.BarCode.dll)を組み込んだアプリケーションの配布は、アプリケーションの種類によりライセンス体系が異なります。

このトピックは、次のセクションを含みます。

  • クライアントアプリケーション
  • サーバーアプリケーション

クライアントアプリケーション

Yubin7 Ver2.6 を使用して作成したアプリケーションを運用するクライアントに対し、Yubin7 Ver2.6 郵便番号変換エンジン再配布ライセンスが必要です。

Yubin7 Ver2.6 郵便番号変換エンジン再配布ライセンス

必要条件 | Yubin7 Ver2.6 を使用して作成したクライアントアプリケーションを運用する環境 (OS) 数分、必要なライセンスです。
価格 | 1 ライセンスあたり / 20,000円 (税込 21,600円)
商品構成 | ライセンス数や契約内容を記載した契約書 (ライセンス証書) のみになります。
お問い合わせ | ライセンスのお申し込みやお問い合わせは、「サポートサービス」よりお問い合わせください。

サーバーアプリケーション

Yubin7 Ver2.6 を使用して作成したアプリケーションを運用するサーバーに対し、サーバーライセンスが必要です。

Yubin7 Ver2.6 サーバーライセンス

必要条件 | Yubin7 Ver2.6 を使用して作成したサーバーアプリケーション (関連する機能を含む) を運用するサーバー環境 (OS) 数分、必要なライセンスです。
価格 | 1 ライセンスあたり (年間) / 28,000円 (税込 30,240円)
商品構成 | ライセンス数や契約内容を記載した契約書 (ライセンス証書) のみになります。
お問い合わせ | ライセンスのお申し込みやお問い合わせは、「サポートサービス」よりお問い合わせください。


バージョン情報

[image]

Yubin7 Ver2.6
バージョン情報

バージョン情報は、シリアル番号等の他に、使用中の郵便番号変換エンジンのバージョンや郵便番号辞書ファイル、大口事業所辞書ファイルのバージョンが表示されます。このトピックでは、バージョン情報の画面項目を説明します。

メモ:
バージョン情報は、Yubin7 Ver2.6 ユーティリティ画面 [ヘルプ] メニュー内の [バージョン情報] からご確認ください。
項目 | 説明
ユーザー名 | 使用ユーザー名が表示されます。
会社名 | 使用ユーザーの会社名が表示されます。
シリアルNo | 製品のシリアル No が表示されます。
ユーティリティ | Yubin7 Ver2.6 ユーティリティのバージョンが表示されます。
郵便番号変換エンジン | 現在使用中の郵便番号変換エンジンのバージョンが表示されます。
郵便番号辞書 | 現在使用中の郵便番号辞書のバージョンが表示されます。
差分辞書 | 現在使用中の差分辞書のバージョンが表示されます。
大口事業所辞書 | 現在使用中の大口事業所辞書のバージョンが表示されます。
ボタン | 説明
OK | 画面を閉じます。


サポートサービス

[image]

Yubin7 Ver2.6
サポートサービス

本製品の Readme、および、ヘルプに記述されていない事項、または動作に関するご不明な点などについては、サポートサービスをご利用ください。

このトピックは、次のセクションを含みます。

  • お問い合わせについて
  • ユーザー登録について
  • お問い合わせいただく前に
  • お問い合わせ窓口

お問い合わせについて

Yubin7 Ver2.6 以外の事柄やプログラミング技法など一般的なご質問、または、動作保証環境外での使用によるご質問にはお答えいたしかねます。あらかじめ、ご了承ください。

ユーザー登録について

サポートサービスをご利用いただくにあたり、製品のユーザー登録が必要になります。 登録されていない場合は、サポートサービスを利用できませんので、お問合せいただく前に必ずユーザー登録を行ってください。 ユーザー登録は、製品に同梱されているユーザー登録カードに、必要事項を記入してご郵送いただくか、弊社 Web サイトの ユーザー登録ページ からもご登録いただくことができます。

お問い合わせいただく前に

サポートサービスでは下記の情報が必要になります。 お問い合わせいただく前に、あらかじめこれらの情報をご用意ください。 なお、弊社 Web サイトのサポート情報の内容により解決いただける場合もございます。 お問い合わせいただく前に、弊社 Web サイトの サポート情報 の内容をもう一度ご確認ください。

ユーザー情報

  1. Yubin7 Ver2.6 のシリアルナンバー (製品パッケージ内「インストール情報」という用紙に記載されています。)
  2. 会社名
  3. 部署名
  4. 担当者名
  5. 連絡先 (電話番号)
  6. FAX 番号
  7. E-Mail アドレス

お問い合わせ内容

  1. 製品名
  2. Yubin7 Ver2.6 の詳細バージョン (Yubin7 Ver2.6 ユーティリティ画面 [ヘルプ] メニュー内の [バージョン情報] に記載されています。)
  3. 使用マシンの OS
  4. OS のサービスパック
  5. .NET Framework のバージョンとサービスパックのバージョン
  6. Visual Studio のバージョンとサービスパックのバージョン
  7. Excel または、Access のバージョンとサービスパックのバージョン
  8. アプリケーションを実行する Internet Explorer のバージョン

問題となっている現象の内容

  1. 現象の詳細内容
  2. 現象発生までの経緯
  3. 現象発生箇所
  4. 現象を再現できる簡単なプロジェクト一式、もしくは、コーディングの一部

お問い合わせ窓口

サポートサービスは、電話、FAX、E-Mail で受け付けております。 また、弊社 Web サイトの お問い合わせ窓口 では、ユーザーサポートフォームを用意しています。あわせてご確認ください。 月曜日～金曜日 (祝祭日、弊社特別休業日を除く) にご利用いただけます。 また、営業日以外にいただいた FAX / E-Mail でのお問い合わせは、翌営業日に回答いたします。

製品の操作方法や仕様に関するお問い合わせ窓口

電話番号 | 0776-21-9172
FAX 番号 | 0776-21-9022
E-Mail | yubin7@adv.co.jp
受付時間 | 10：00 ～ 12：00 / 13：30 ～ 17：00

製品の営業に関するお問い合わせ窓口

電話番号 | 0776-21-9008
FAX 番号 | 0776-21-9022
E-Mail | info@adv.co.jp
受付時間 | 9：00 ～ 12：00 / 13：00 ～ 18：00


Yubin7 Ver2.6 新機能

[image]

Yubin7 Ver2.6
Yubin7 Ver2.6 新機能

ここでは、Yubin7 Ver2.6 新機能を説明します。

Yubin7 辞書自動更新ツール

Yubin7 辞書自動更新ツールの使用方法を説明します。

旧住所から市町村変更情報検索

旧住所から市町村変更情報を検索する方法を説明します。

開発支援

.NET Framework 用アセンブリの使用方法を説明します。


Yubin7 辞書自動更新ツール

[image]

Yubin7 Ver2.6
Yubin7 辞書自動更新ツール

Yubin7 Ver2.6 は、Yubin7 辞書自動更新ツールを使用して郵便番号辞書を自動で更新することが可能です。このトピックでは、Yubin7 辞書自動更新ツールの画面項目を説明します。

メモ:
この機能は、サーバーライセンス購入者のみ使用可能です。サーバーライセンスの詳細な内容については「ライセンス体系」を参照してください。

このトピックは、次のセクションを含みます。

  • Yubin7 辞書自動更新ツール (メイン画面)
  • Yubin7 辞書自動更新ツール (環境設定)

Yubin7 辞書自動更新ツール (メイン画面)

ここでは、Yubin7 辞書自動更新ツール (メイン画面) の画面項目を説明します。

自動更新 ON

自動更新 OFF

項目 | 説明
実行間隔 | 郵便番号辞書を自動更新する実行間隔を設定します。 一ヶ月ごと 一ヶ月ごとに自動更新をします。 一週間ごと 一週間ごとに自動更新をします。 一回のみ 一回のみ自動更新をします。
実行 | 郵便番号辞書を自動更新する日時を設定します。
最終更新 | 郵便番号辞書を更新した最終更新日時が表示されます。
ボタン | 説明
環境設定 | 環境設定をします。詳細は、「Yubin7 辞書自動更新ツール (環境設定)」を参照してください。

Yubin7 辞書自動更新ツール (環境設定)

Yubin7 辞書自動更新ツールの環境設定の画面項目を説明します。

項目 | 説明
郵便番号辞書ファイルパス | 郵便番号辞書を更新する更新先のファイルパスを設定します。ファイルパスは複数設定可能で [追加] ボタンでファイルパスを追加し、[削除] ボタンでファイルパスを削除します。
更新対象の辞書ファイル | チェック ON で更新対象とする辞書 (郵便番号辞書/大口事業所辞書/差分辞書) を設定します。
ログファイルパス | ログファイルパスを設定します。[開く] ボタンでログファイルを開きます。
更新情報をログファイルに出力する | チェック ON でログファイルパスに設定したパスにログファイルを出力します。
起動時に更新を実行して終了する | チェック ON で Yubin7 辞書自動更新ツール起動時に郵便番号辞書の更新を実行して終了します。
起動時に自動更新を開始する | チェック ON で Yubin7 辞書自動更新ツール起動時に郵便番号辞書の自動更新を開始します。
自動更新時に画面を非表示にする | チェック ON で Yubin7 辞書自動更新ツールで郵便番号辞書自動更新時に画面を非表示にします。
ボタン | 説明
OK | 設定を適用して画面を閉じます。
適用 | 設定を適用します。
キャンセル | 設定をキャンセルして画面を閉じます。

参照

Yubin7 Ver2.6 新機能

©2014 Advance Software inc. All rights reserved.


Yubin7 Ver2.6 画面

Yubin7 Ver2.6
Yubin7 Ver2.6 画面

このトピックでは、Yubin7 Ver2.6 画面のメニュー項目、ツールバーのボタン、画面の説明をします。

このトピックは、次のセクションを含みます。

  • メニュー項目
  • ツールバー

メニュー項目

[ファイル] メニュー

サブメニュー | 説明
設定ファイルを開く | 設定ファイル (.settings) を開きます。
名前を付けて保存 | 現在編集中の設定ファイル (.settings) を名前を付けて保存します。
終了 | Yubin7 Ver2.6 画面を終了します。

[検索] メニュー

サブメニュ－ 説明
住所から郵便番号検索 住所から郵便番号検索をします。
Note メモ:

住所から郵便番号検索の使用方法は、「住所から郵便番号検索」を参照してください。

郵便番号から住所検索 郵便番号から住所検索をします。
Note メモ:

郵便番号から住所検索の使用方法は、「郵便番号から住所検索」を参照してください。

町域名から検索 町域名から検索をします。
Note メモ:

町域名から検索の使用方法は、「町域名から検索」を参照してください。

指定文字列から住所検索 指定文字列から住所検索をします。
Note メモ:

指定文字列から住所検索の使用方法は、「指定文字列から住所検索」を参照してください。

大口事業所個別番号検索 大口事業所個別番号を検索をします。
Note メモ:

大口事業所個別番号検索の使用方法は、「大口事業所個別番号検索」を参照してください。

旧住所から市町村変更情報検索 旧住所から市町村変更情報を検索をします。
Note メモ:

旧住所から市町村変更情報検索の使用方法は、「旧住所から市町村変更情報検索」を参照してください。

[郵便番号変換] メニュー

サブメニュ－ 説明
Excel 変換 Excel 変換をします。
Note メモ:

Excel 変換の使用方法は、「Excel 変換」を参照してください。

Access 変換 Access 変換をします。
Note メモ:

Access 変換の使用方法は、「Access 変換」を参照してください。

CSV 変換 CSV 変換をします。
Note メモ:

CSV 変換の使用方法は、「CSV 変換」を参照してください。

テキスト変換 テキスト変換をします。
Note メモ:

テキスト変換の使用方法は、「テキスト変換」を参照してください。

[住所表記統一] メニュー

サブメニュ－ 説明
Excel 表記統一 Excel 表記統一をします。
Note メモ:

Excel 表記統一の使用方法は、「Excel 表記統一」を参照してください。

Access 表記統一 Access 表記統一をします。
Note メモ:

Access 表記統一の使用方法は、「Access 表記統一」を参照してください。

CSV 表記統一 CSV 表記統一をします。
Note メモ:

CSV 表記統一の使用方法は、「CSV 表記統一」を参照してください。

テキスト表記統一 テキスト表記統一をします。
Note メモ:

テキスト表記統一の使用方法は、「テキスト表記統一」を参照してください。

[表示] メニュー

サブメニュー | 説明
ツールバー | チェック ON でツールバーを表示します。
ステータスバー | チェック ON でステータスバーを表示します。

[オプション] メニュー

サブメニュー | 説明
環境設定 | 環境設定をします。
エラー情報出力設定 | エラー情報出力設定をします。

[ヘルプ] メニュー

サブメニュー | 説明
ヘルプの表示 | ヘルプを表示します。
更新辞書の確認 | 更新辞書の確認をします。
バージョン情報 | バージョン情報を表示します。

ツールバー

ボタン (名前) 説明
既存の設定ファイル (.settings) を開きます。
現在編集中の設定ファイル (.settings) を上書き保存します。
郵便番号検索をします。
Note メモ:

郵便番号検索の使用方法は、「郵便番号検索」を参照してください。

郵便番号変換をします。
Note メモ:

郵便番号変換の使用方法は、「郵便番号変換」を参照してください。

住所表記統一をします。
Note メモ:

住所表記統一の使用方法は、「住所表記統一」を参照してください。

環境設定をします。
Note メモ:

環境設定の使用方法は、「環境設定」を参照してください。

ヘルプを表示します。
Yubin7 Ver2.6 画面を終了します。

参照

郵便番号検索
郵便番号変換
住所表記統一


郵便番号検索

[image]

Yubin7 Ver2.6
郵便番号検索

Yubin7 Ver2.6 は、住所、郵便番号の検索をすることが可能です。ここでは、郵便番号検索をする方法を説明します。

住所から郵便番号検索

住所から、７桁郵便番号とバーコードデータ、全国地方公共団体コードを検索する方法を説明します。

郵便番号から住所検索

郵便番号から該当する住所を検索する方法を説明します。

町域名から検索

町域名から一致する住所を検索する方法を説明します。

指定文字列から住所検索

指定文字列から住所を検索する方法を説明します。

大口事業所個別番号検索

大口事業所、大口事業所個別番号を検索する方法を説明します。

旧住所から市町村変更情報検索

旧住所から市町村変更情報を検索する方法を説明します。


住所から郵便番号検索

[image]

Yubin7 Ver2.6
住所から郵便番号検索

住所から郵便番号検索は、住所から、7 桁郵便番号、バーコードデータ、全国地方公共団体コードを検索します。このトピックでは、住所から郵便番号検索の画面項目を説明します。

項目 | 説明
都道府県名 | 検索する都道府県名を選択します。都道府県名 が不明な場合は、「無指定」を選択してください。
都道府県名以降の住所 | 検索する都道府県名以降の住所文字列を設定します。
7 桁郵便番号 | 検索結果の 7 桁郵便番号が表示されます。
バーコードデータ | 検索結果のバーコードデータが表示されます。
全国地方公共団体コード | 検索結果の全国地方公共団体コードが表示されます。
ボタン | 説明
検索 | 入力された住所を基に検索します。
クリップボードにコピー | 検索された 7 桁郵便番号、バーコードデータ、全国地方公共団体コードをクリップボードに転送します。

参照

郵便番号検索

©2014 Advance Software inc. All rights reserved.


郵便番号から住所検索

[image]

Yubin7 Ver2.6
郵便番号から住所検索

郵便番号から住所検索は、郵便番号から該当する住所を検索します。このトピックでは、郵便番号から住所検索の画面項目を説明します。

項目 | 説明
郵便番号を入力して下さい。 | 検索する郵便番号を設定します。
検索結果 | 設定された郵便番号に対する住所の検索結果が表示されます。
7 桁郵便番号 | 検索結果において選択した住所の 7 桁郵便番号が表示されます。
全国地方公共団体コード | 検索結果において選択した全国地方公共団体コードが表示されます。
ボタン | 説明
検索 | 入力された郵便番号を基に検索します。
選択した住所をクリップボードにコピー | 検索結果において選択した住所をクリップボードに転送します。

参照

郵便番号検索

©2014 Advance Software inc. All rights reserved.


町域名から検索

[image]

Yubin7 Ver2.6
町域名から検索

町域名から検索は、町域名から該当する住所を検索します。このトピックでは、町域名から検索の画面項目を説明します。

項目 | 説明
町域名を入力して下さい。 | 検索する町域名を設定します。
検索結果 | 設定された町域名に対する住所の検索結果が表示されます。
7 桁郵便番号 | 検索結果において選択した住所の 7 桁郵便番号が表示されます。
全国地方公共団体コード | 検索結果において選択した全国地方公共団体コードが表示されます。
ボタン | 説明
検索 | 入力された町域名を基に検索します。
選択した住所をクリップボードにコピー | 検索結果において選択した住所をクリップボードに転送します。

参照

郵便番号検索

©2014 Advance Software inc. All rights reserved.


指定文字列から住所検索

[image]

Yubin7 Ver2.6
指定文字列から住所検索

指定文字列から住所検索は、指定文字列から該当する住所を検索します。このトピックでは、指定文字列から住所検索の画面項目を説明します。

項目 | 説明
検索の元となる住所文字列を入力して下さい。 | 検索する住所を設定します。
検索結果 | 設定された指定文字列に対する住所の検索結果が表示されます。
7 桁郵便番号 | 検索結果において選択した住所の 7 桁郵便番号が表示されます。
全国地方公共団体コード | 検索結果において選択した全国地方公共団体コードが表示されます。
ボタン | 説明
確定 | 検索された住所を確定します。
選択した住所をクリップボードにコピー | 検索結果において選択した住所をクリップボードに転送します。

参照

郵便番号検索

©2014 Advance Software inc. All rights reserved.


大口事業所個別番号検索

[image]

Yubin7 Ver2.6
大口事業所個別番号検索

大口事業所個別番号検索は、大口事業所個別番号や事業所名から大口事業所を検索します。このトピックでは、大口事業所個別番号検索の画面項目を説明します。

このトピックは、次のセクションを含みます。

  • 大口事業所個別番号で検索
  • 大口事業所名で検索

大口事業所個別番号で検索

大口事業所個別番号から大口事業所を検索します。検索元の大口事業所個別番号は、３桁/５桁/７桁のいずれでも検索可能です。

項目 | 説明
大口事業所個別番号で検索 | 大口事業所検索の検索方法を選択します。大口事業所個別番号で検索する場合 [大口事業所個別番号で検索] を選択します。
検索個別番号 | 検索する大口事業所個別番号を設定します。
検索結果 | 設定された大口事業所個別番号に対する大口事業所名の検索結果が表示されます。
ボタン | 説明
検索 | 入力された大口事業所個別番号を基に検索します。
選択した住所をクリップボードにコピー | 検索結果において選択した住所をクリップボードに転送します。

大口事業所名で検索

事業所名から大口事業所を検索します。検索する事業所名の一致条件として [あいまい検索] や [検索都市] での検索が可能です。

項目 | 説明
大口事務所名で検索 | 大口事業所検索の検索方法を選択します。大口事業所名で検索を行う場合 [大口事業所名で検索] を選択します。
検索大口事業所名 | 検索する大口事業所名を設定します。
一致条件 | 検索する一致条件を設定します。 あいまい検索 検索事業所名 の一部と一致するものを検索します。 完全一致 検索事業所名 と完全に一致するものを検索します。 完全一致 (前株・後株等は省く) 検索方法は 完全一致 と同じですが、事業所名 の前株・後株は検索条件から除きます。 検索事業所名 に「株式会社」が無くても、「株式会社」の付く 事業所名 も 検索結果 として取得します。
検索都市 | 検索する都市を設定します。 例：東京都内の事業所を検索する場合 「東京都」を選択する
検索結果 | 設定された大口事業所名に対する検索結果が表示されます。
ボタン | 説明
検索 | 入力された大口事業所名を基に検索します。
選択した住所をクリップボードにコピー | 検索結果において選択した住所をクリップボードに転送します。

参照

郵便番号検索


旧住所から市町村変更情報検索

[image]

Yubin7 Ver2.6
旧住所から市町村変更情報検索

旧住所から市町村変更情報検索は、旧住所から該当する市町村変更情報を検索します。このトピックでは、旧住所から市町村変更情報検索の画面項目を説明します。

項目 | 説明
検索する旧住所を入力して下さい。 | 検索する旧住所を設定します。
差分辞書のみ使用して検索を行う | チェック ON で差分辞書のみ使用して検索します。
検索結果 | 設定された旧住所に対する新住所の検索結果が表示されます。
ボタン | 説明
検索 | 入力された住所を基に検索します。
詳細 | 検索結果において選択した住所の詳細情報を表示します。
選択した住所をクリップボードにコピー | 検索結果において選択した住所をクリップボードに転送します。

参照

郵便番号検索

©2014 Advance Software inc. All rights reserved.


郵便番号変換

[image]

Yubin7 Ver2.6
郵便番号変換

Yubin7 Ver2.6 は、住所から郵便番号、バーコードデータ、全国地方公共団体コードへ変換することが可能です。ここでは、郵便番号を変換する方法を説明します。

Excel 変換

Excel で変換する方法を説明します。

Access 変換

Access で変換する方法を説明します。

CSV 変換

CSV で変換する方法を説明します。

テキスト変換

テキストで変換する方法を説明します。


Excel 変換

[image]

Yubin7 Ver2.6
Excel 変換

Excel 変換は、Excelファイルに登録された住所から、郵便番号、バーコードデータ、全国地方公共団体コードへ変換します。変換モードとして、住所から郵便番号、住所からバーコードデータ、住所から郵便番号 + バーコードデータ、住所から全国地方公共団体コードへの変換が可能です。また、変換時にエラーとする住所の条件を設定する住所の厳重チェックやエラーとなった住所文字列とレコード№を出力するエラー情報の設定が可能です。

メモ:
変換モード、住所の厳重チェックは、「環境設定」の [住所から郵便番号変換] タブから設定することが可能です。エラー情報は、「エラー情報出力設定」から設定可能です。
項目 | 説明
変換元 Excel ファイル名 | 変換元 Excel ファイル名を設定します。[参照] ボタンでファイルを選択します。
変換元 Excel シート名 | 変換元 Excel ファイルのシート名を設定します。
住所 1 ～ 4 列 | 変換元 Excel ファイルのシート内で住所文字列が登録されている列を設定します。
先頭行をフィールド名として使用する | チェック ON で変換元 Excel ファイルシートの先頭行を住所 1 ～ 4 列の設定項目名として使用し、2 行目以降から変換します。
変換先 Excel ファイル名 | 変換先 Excel ファイル名を設定します。[参照] ボタンでファイルを選択します。
郵便番号列 | 変換結果 (郵便番号) を出力する列名を設定します。
バーコード列 | 変換結果 (カスタマバーコードデータ) を出力する列名を設定します。
ボタン | 説明
変換 | 設定内容を基に変換します。
注意:
  • Excel 変換は、変換元 Excel ファイル のシートに直接変換するのではなく、変換元 Excel ファイル のシートを基に新規で変換先 Excel ファイル を作成して変換結果を追加します。
  • イメージ情報や計算式等の情報は移行されません。
  • 変換元 Excel ファイル のシート名は、変換先 Excel ファイル のExcelシート名と同一名で作成します。

    • 参照

    郵便番号変換

    ©2014 Advance Software inc. All rights reserved.


Access 変換

[image]

Yubin7 Ver2.6
Access 変換

Access 変換は、Accessファイルに登録された住所から、郵便番号、バーコードデータ、全国地方公共団体コードへ変換します。変換されたデータは、テーブルの指定されたフィールドに付加されます。 変換モードとして、住所から郵便番号、住所からバーコードデータ、住所から郵便番号 + バーコードデータ、住所から全国地方公共団体コードへの変換が可能です。また、変換時にエラーとする住所の条件を設定する住所の厳重チェックやエラーとなった住所文字列とレコード№を出力するエラー情報の設定が可能です。

メモ:
変換モード、住所の厳重チェックは、「環境設定」 の [住所から郵便番号変換] タブから設定することが可能です。エラー情報は、「エラー情報出力設定」から設定可能です。
項目 | 説明
Access データベース名 | 変換元 Access ファイル名を設定します。[参照] ボタンでファイルを選択します。
Access テーブル名 | 変換元 Access ファイルのテーブル名を設定します。
住所 1 ～ 4 フィールド | 変換元 Access ファイルのテーブル内で住所が設定されているフィールドを設定します。
バックアップファイルを作成する | チェック ON で変換元 Access ファイルのバックアップファイルを作成します。
郵便番号フィールド | 変換結果 (郵便番号) を出力する Access ファイルのテーブル内のフィールドを設定します。
バーコードフィールド | 変換結果 (カスタマバーコードデータ) を出力する Access ファイルのテーブル内のフィールドを設定します。
ボタン | 説明
変換 | 設定内容を基に変換します。
注意:
  • 変換結果は変換元データベースファイルのテーブルに付加されます。変換元データベースファイルのバックアップファイルを残す場合 [バックアップファイルを作成する。] にチェックを入れてください。変換元ファイルは、データベースファイル名 + 拡張子 *.bkp として残ります。
  • 変換元データベースファイルが DVD、CD-ROM 等にあり、書き込みプロテクトが掛かっている場合や、テーブルにパスワードが設定されている場合は変換できません。
  • あらかじめ変換先フィールドは用意してください。その際、フィールドのデータ型はテキスト型としてください。
  • 変換処理は、主キーで指定しているレコード順に行いますが、キーを指定していない場合は、Access 上で見た場合のレコード順と変換する際のレコード順が異なる場合があります。
  • Access 側で郵便番号／バーコードデータ出力フィールドがインデックスフィールドになっている場合に、Yubin7 Ver2.6 が誤動作を起こす場合があるため、変換前にあらかじめ、Access でフィールドのインデックス定義を外し、変換後に再定義してください。

    • 参照

    郵便番号変換

    ©2014 Advance Software inc. All rights reserved.


CSV 変換

[image]

Yubin7 Ver2.6
CSV 変換

CSV 変換は、CSV ファイルに登録された住所から、郵便番号、バーコードデータ、全国地方公共団体コードへ変換します。変換モードとして、住所から郵便番号、住所からバーコードデータ、住所から郵便番号 + バーコードデータ、住所から全国地方公共団体コードへの変換が可能です。また、変換時にエラーとする住所の条件を設定する住所の厳重チェックやエラーとなった住所文字列とレコード№を出力するエラー情報の設定が可能です。

メモ:
変換モード、住所の厳重チェックは、「環境設定」 の [住所から郵便番号変換] タブから設定することが可能です。エラー情報は、「エラー情報出力設定」から設定可能です。
項目 | 説明
変換元 CSV ファイル名 | 変換元 CSV ファイル名を設定します。[参照] ボタンでファイルを選択します。
住所 1 ～ 4 列 | 変換元 CSV ファイルで住所文字列が登録されている列を設定します。
先頭行をフィールド名として使用する | チェック ON で変換元 CSV ファイルシートの先頭行を住所 1 ～ 4 列の設定項目名として使用し、2 行目以降から変換します。
変換先 CSV ファイル名 | 変換先 CSV ファイル名を設定します。[参照] ボタンでファイルを選択します。
文字項目の囲み | 変換結果を ""(ダブルコーテーション) で囲むかどうかを選択します。囲む場合は「""で囲む」を選択します。
エラー文字出力 変換エラー時、変換結果の代わりに任意のエラー文字を出力する場合に設定します。
メモ:
チェック ON で変換エラーが発生した場合、[エラー文字]で設定した文字列が各行の先頭に付加されます。
エラー文字 | 変換エラー時、変換結果の代わりに出力する文字を設定します。
ボタン | 説明
変換 | 設定内容を基に変換します。
注意:
  • CSV 変換は、変換元CSVファイルに変換結果が付加された内容になり、変換結果 (エラー文字も含む) は、各行の先頭に付加されます。
  • データ保護のため、既存のファイル内に存在する郵便番号データ等に対し 変換結果を付加することはできません。

    • 参照

    郵便番号変換

    ©2014 Advance Software inc. All rights reserved.


テキスト変換

[image]

Yubin7 Ver2.6
テキスト変換

テキスト変換は、テキストファイルに登録された住所から、郵便番号、バーコードデータ、全国地方公共団体コードへ変換します。変換モードとして、住所から郵便番号、住所からバーコードデータ、住所から郵便番号 + バーコードデータ、住所から全国地方公共団体コードへの変換が可能です。また、変換時にエラーとする住所の条件を設定する住所の厳重チェックやエラーとなった住所文字列とレコード № を出力するエラー情報の設定が可能です。

メモ:
変換モード、住所の厳重チェックは、「環境設定」 の [住所から郵便番号変換] タブから設定することが可能です。エラー情報は、「エラー情報出力設定」から設定可能です。
/td>
項目 | 説明
変換元テキストファイル名 | 変換元テキストファイル名を設定します。[参照] ボタンでファイルを選択します。
改行文字の有無 | 変換元テキストファイルの各レコードが改行で区切られている場合、チェック ON を設定します。
レコード長 | 改行文字で「なし」を選択した場合、必ず変換元テキストファイル の レコード長を設定します。
住所 1 ～ 4 の位置 | 変換元テキストファイル内の住所文字列が登録されている位置を、桁数 (バイト) で設定します。
変換先テキストファイル名 | 変換先テキストファイル名を設定します。[参照] ボタンでファイルを選択します。
出力位置 | 変換結果の出力位置を、桁数 (バイト) で設定します。
ボタン | 説明
変換 | 設定内容を基に変換します。
注意:
  • データ保護のため、既存のファイル内に存在する郵便番号データ等に対し 変換結果を付加することはできません。
  • 変換元ファイルのレコード長は最大32,768バイトまで対応しています。

    • 参照

    郵便番号変換

    ©2014 Advance Software inc. All rights reserved.


住所表記統一

[image]

Yubin7 Ver2.6
住所表記統一

Yubin7 Ver2.6 は、住所文字列内の算用数字、英字、記号、カタカナ、ひらがなをそれぞれ全角や半角文字に統一することが可能です。ここでは、住所表記統一をする方法を説明します。

Excel 表記統一

Excel で表記統一する方法を説明します。

Access 表記統一

Access で表記統一する方法を説明します。

CSV 表記統一

CSV で表記統一する方法を説明します。

テキスト表記統一

テキストで表記統一する方法を説明します。


Excel 表記統一

[image]

Yubin7 Ver2.6
Excel 表記統一

Excel 表記統一は、Excelファイルに登録された住所文字列内の「算用数字」「英字」「記号」「カタカナ」「ひらがな」を、それぞれ全角や半角文字に統一します。

メモ:
住所表記統一モードは、「環境設定」の [住所表記統一] タブから設定することが可能です。
項目 | 説明
変換元 Excel ファイル名 | 変換元 Excel ファイル名を設定します。[参照] ボタンでファイルを選択します。
変換元 Excel シート名 | 変換元 Excel ファイルのシート名を設定します。
住所 1 ～ 4 列 | 変換元 Excel ファイルのシート内で住所文字列が登録されている列を設定します。
先頭行をフィールド名として使用する | チェック ON で変換元 Excel ファイルシートの先頭行を住所 1 ～ 4 列の設定項目として使用し、2 行目以降から表記統一します。
変換先 Excel ファイル名 | 変換先 Excel ファイル名を設定します。[参照] ボタンでファイルを選択します。
ボタン | 説明
変換 | 設定内容を基に変換します。
注意:
  • Excel 表記統一は、変換元 Excel ファイル のシートに直接変換するのではなく、変換元 Excel ファイル のシートを基に新規で変換先 Excel ファイル を作成して変換結果を追加します。
  • イメージ情報や計算式等の情報は移行されません。
  • 変換元 Excel ファイル のシート名は、変換先 Excel ファイル のExcelシート名と同一名で作成します。

    • 参照

    住所表記統一

    ©2014 Advance Software inc. All rights reserved.


Access 表記統一

[image]

Yubin7 Ver2.6
Access 表記統一

Access 表記統一は、Accessファイルに登録された住所文字列内の「算用数字」「英字」「記号」「カタカナ」「ひらがな」を、それぞれ全角や半角文字に統一します。

メモ:
住所表記統一モードは、「環境設定」の [住所表記統一] タブから設定することが可能です。
項目 | 説明
Access データベース名 | 変換元 Access ファイル名を設定します。[参照] ボタンでファイルを選択します。
Access テーブル名 | 変換元 Access ファイルのテーブル名を設定します。
住所 1 ～ 4 フィールド | 変換元 Access ファイルのテーブル内で住所が設定されているフィールドを設定します。
バックアップファイルを作成する。 | チェック ON でバックアップファイルを作成します。
ボタン | 説明
変換 | 設定内容を基に変換します。
注意:
  • 変換結果は変換元データベースファイルのテーブルに付加されます。変換元データベースファイルのバックアップファイルを残す場合 [バックアップファイルを作成する。] にチェックを入れてください。変換元ファイルは、データベースファイル名 + 拡張子 *.bkp として残ります。
  • 変換元データベースファイルが DVD、CD-ROM 等にあり、書き込みプロテクトが掛かっている場合や、テーブルにパスワードが設定されている場合は変換できません。
  • あらかじめ変換先フィールドは用意してください。その際、フィールドのデータ型はテキスト型としてください。
  • 変換処理は、主キーで指定しているレコード順に行いますが、キーを指定していない場合は、Access 上で見た場合のレコード順と変換する際のレコード順が異なる場合があります。
  • Access 側で郵便番号／バーコードデータ出力フィールドがインデックスフィールドになっている場合に、Yubin7 Ver2.6 が誤動作を起こす場合があるため、変換前にあらかじめ、Access でフィールドのインデックス定義を外し、変換後に再定義してください。

    • 参照

    住所表記統一

    ©2014 Advance Software inc. All rights reserved.


CSV 住所表記統一

[image]

Yubin7 Ver2.6
CSV 住所表記統一

CSV 表記統一は、CSV ファイルに登録された住所文字列内の「算用数字」「英字」「記号」「カタカナ」「ひらがな」を、それぞれ全角や半角文字に統一します。

メモ:
住所表記統一モードは、「環境設定」の [住所表記統一] タブから設定することが可能です。
項目 | 説明
変換元 CSV ファイル名 | 変換元 CSV ファイル名を設定します。[参照] ボタンでファイルを選択します。
住所 1 ～ 4 列 | 変換元 CSV ファイルで住所文字列が登録されている列を設定します。
先頭行をフィールド名として使用する | チェック ON で変換元 CSV ファイルシートの先頭行を住所 1 ～ 4 列の設定項目として使用し、2 行目以降から変換します。
変換先 CSV ファイル名 | 変換先 CSV ファイル名を設定します。[参照] ボタンでファイルを選択します。
文字項目の囲み | 変換結果を ""(ダブルコーテーション) で囲むかどうかを選択します。囲む場合は「""で囲む」を選択します。
ボタン | 説明
変換 | 設定内容を基に変換します。

参照

住所表記統一

©2014 Advance Software inc. All rights reserved.


テキスト住所表記統一

[image]

Yubin7 Ver2.6
テキスト住所表記統一

テキスト表記統一は、テキストファイルに登録された住所文字列内の「算用数字」「英字」「記号」「カタカナ」「ひらがな」を、それぞれ全角や半角文字に統一します。

メモ:
住所表記統一モードは、「環境設定」の [住所表記統一] タブから設定することが可能です。
項目 | 説明
変換元テキストファイル名 | 変換元テキストファイル名を設定します。[参照] ボタンでファイルを選択します。
改行文字の有無 | 変換元テキストファイルの各レコードが改行で区切られている場合、チェック ON を設定します。
レコード長 | 改行文字で「なし」を選択した場合、必ず変換元テキストファイル の レコード長を設定します
住所 1 ～ 4 の位置 | 変換元テキストファイル内の住所文字列が登録されている位置を、桁数 (バイト) で設定します。
変換先テキストファイル名 | 変換先テキストファイル名を設定します。[参照] ボタンでファイルを選択します。
出力位置 | 変換結果の出力位置を、桁数 (バイト) で設定します。
ボタン | 説明
変換 | 設定内容を基に変換します。
注意:
  • 変換元ファイルのレコード長は最大 32,768 バイトまで対応しています。

    • 参照

    住所表記統一

    ©2014 Advance Software inc. All rights reserved.


オプション

[image]

Yubin7 Ver2.6
オプション

ここでは、オプションを設定する方法を説明します。

環境設定

環境設定を説明します。

エラー情報出力設定

エラー情報出力設定を説明します。

特殊漢字テーブルファイル

特殊漢字テーブルファイルを説明します。


環境設定

[image]

Yubin7 Ver2.6
環境設定

このトピックでは、環境設定で設定可能な項目について説明します。

このトピックは、次のセクションを含みます。

  • 全般
  • 住所から郵便番号変換
  • 住所表記統一
  • 新旧住所変換

全般

[全般] タブでは、Yubin7 Ver2.6 環境設定全般に関する設定をします。

環境設定全般

項目名 | 説明
起動時にタイトル画面を表示する | チェック ON で Yubin7 Ver2.6 ユーティリティ起動時にタイトル画面を表示します。
起動時に更新された辞書を確認する | チェック ON で Yubin7 Ver2.6 ユーティリティ起動時に郵便番号辞書が更新されているかを確認します。
Yubin7 を常駐させる | チェック ON で Yubin7 Ver2.6 をタスクバーに常駐させます。
特殊漢字テーブルファイルを使用する | チェック ON で 特殊漢字テーブルファイルを使用します。
辞書のフォルダを指定する | 郵便番号辞書を格納するフォルダを設定します。[参照] ボタンでファイルを選択します。
更新確認対象の辞書ファイル | 郵便番号辞書ファイルが更新された場合、更新確認を行う辞書ファイルを設定します。チェック ON で更新確認対象とします。
ボタン | 説明
OK | 設定を適用して画面を閉じます。
適用 | 設定を適用します。
キャンセル | 設定をキャンセルします。

住所から郵便番号変換

[住所から郵便番号変換] タブでは、郵便番号変換する際の変換モード、住所の厳重チェックを設定します。

変換モード

項目 | 説明
7 桁郵便番号変換 | 変換モードを 7 桁郵便番号変換に設定します。
7 桁郵便番号 + バーコードデータ変換 | 変換モードを 7 桁郵便番号 + バーコードデータ変換に設定します。
バーコードデータ変換 | 変換モードをバーコードデータ変換に設定します。
全国地方公共団体コード変換 | 変換モードを全国地方公共団体コード変換に設定します。
郵便番号にハイフンを付ける | チェック ON で 7 桁郵便番号変換時に郵便番号の 3 桁目と4 桁目の間にハイフンが付加されます。

住所の厳重チェック

項目 | 説明
住所が「以下に掲載がない場合」に該当する場合エラーとする | チェック ON で「以下に掲載がない場合」に該当する住所の場合、エラーになります。
住所が京都省略住所の場合エラーとする | チェック ON で京都省略住所の場合、エラーになります。
住所に都道府県名がない場合エラーとする | チェック ON で都道府県名がない場合、エラーになります。
住所に市または郡名がない場合エラーとする | チェック ON で市または郡名がない場合、エラーになります。
京都の通り名表記を検索対象にする | チェック ON で京都の通り名表記がある住所を検索対象に設定します。
ボタン | 説明
OK | 設定を適用して画面を閉じます。
適用 | 設定を適用します。
キャンセル | 設定をキャンセルします。

住所表記統一

[住所表記統一] タブでは、住所表記統一の規則を設定します。

住所表記統一の規則を設定

項目 | 説明
算用数字 | 算用数字を [全角に統一]、[半角に統一] 、[統一しない] から選択します。
英字 | 英字を [全角に統一]、[半角に統一] 、[統一しない] から選択します。
記号 | 記号を [全角に統一]、[半角に統一] 、[統一しない] から選択します。
カタカナ | カタカナを [全角に統一]、[半角に統一] 、[統一しない] から選択します。
ひらがな | ひらがなを [半角にカナに統一] 、[統一しない] から選択します。
ボタン | 説明
OK | 設定を適用して画面を閉じます。
適用 | 設定を適用します。
キャンセル | 設定をキャンセルします。

新旧住所変換

[新旧住所変換] タブでは、新旧住所変換に関する設定をします。

新旧住所変換を行う

項目 | 説明
新旧住所変換を行う | チェック ON で表記統一時に新旧住所変換を有効にします。
新住所の候補が複数ある場合 | 新住所の候補が複数ある場合、選択ダイアログを表示する、または、任意の文字列を先頭項目に挿入します。
更新履歴はあるが、廃止などで新住所が存在しない場合 | 更新履歴はあるが、廃止などで新住所が存在しない場合、変換しない、または、任意の文字列を先頭項目に挿入します。
ボタン | 説明
OK | 設定を適用して画面を閉じます。
適用 | 設定を適用します。
キャンセル | 設定をキャンセルします。

参照

オプション

©2014 Advance Software inc. All rights reserved.


エラー情報出力設定

[image]

Yubin7 Ver2.6
エラー情報出力設定

エラー情報出力設定は、エラー発生時の対処方法を設定することが可能です。このトピックでは、エラー情報出力設定の画面項目を説明します。

項目 | 説明
エラー情報ファイルを出力する | チェック ON で変換時にエラーが発生した場合、エラー情報ファイルを出力します。
エラー情報ファイル名 | エラー情報ファイル名をフルパスで設定します。
一定の件数以上のエラーが発生した場合、変換を終了する | チェック ON で変換時の変換エラー件数がここで指定した件数に達すると変換処理を終了します。
ボタン | 説明
OK | 設定を適用して画面を閉じます。
キャンセル | 設定をキャンセルします。

参照

オプション

©2014 Advance Software inc. All rights reserved.


特殊漢字テーブルファイル

[image]

Yubin7 Ver2.6
特殊漢字テーブルファイル

このトピックでは、特殊漢字テーブルファイルについて説明します。 特殊漢字テーブルファイル (AdvZip.tbl) を使用することで、略字・旧地名・外字を含む住所を正確に変換すること可能です。旧漢字については 郵便番号変換エンジン (Yubin7.AdvZip.dll) で対応しておりますが、それ以外の漢字については、特殊漢字テーブルファイル (AdvZip.tbl) を使用して変換します。

このトピックは、次のセクションを含みます。

  • Yubin7 Ver2.6 ユーテリティ (Yubin7.exe) で使用する
  • .NET Framework 用アセンブリで使用する
  • 特殊漢字テーブルファイルを編集する
特殊漢字テーブルファイル使用時の注意:
  • すべてのデータに対して漢字の検索を行うため、変換スピードが低下します。
  • 「町域名から検索」には適用されません。
  • 「GetAllAddress」には適用されません。
  • 特殊漢字テーブルファイル (AdvZip.tbl) は、Yubin7 Ver2.6 インストールフォルダ内に格納されています。

    • Yubin7 Ver2.6 ユーテリティ (Yubin7.exe) で使用する

    1. Yubin7 Ver2.6 ユーテリティ (Yubin7.exe) を起動します。

    2. [環境設定] の [全般] タブ内の [特殊漢字テーブルファイルを使用する] のチェック ON で特殊漢字テーブルファイルを使用します。

      メモ:
      詳細な画面の設定項目については、「環境設定」を参照してください。

    .NET Framework 用アセンブリで使用する

    1. Yubin7 Ver2.6 の .NET Framework 用アセンブリを使用しているアプリケーションで UseAdvZipTable プロパティを True に設定します。

      メモ:
      UseAdvZipTable プロパティの詳細については、「UseAdvZipTable」を参照してください。

    2. アプリケーションを配布する環境のシステムフォルダ、または、アプリケーションと同じフォルダに特殊漢字テーブルファイル (AdvZip.tbl) を配置します。

    特殊漢字テーブルファイルを編集する

    1. テキストエディタで特殊漢字テーブルファイルを開きます。

    2. 文字列で設定する場合、「漢字1=漢字2」のように指定してください。
      例：安竜=安立

      文字コード (シフト JIS 漢字コード) で設定する場合、"¥x" に続いて 4 桁の 16 進数で設定してください。
      例：¥x824f=¥x8250

      文字コード (JIS 漢字コード) で設定する場合、"¥x" に続いて 4 桁の 16 進数で設定してください。髙 (¥xeee0) , 髙 (¥xfbfc) の二つの漢字を、両方共に「高」にする場合、下記のように 2 件設定してください。
      例：¥xeee0=高、¥xfbfc=高

    注意:
  • 「#」以降の記述はコメントになります。また、先行する半角スペースは無視されます。
  • 「=」の左側に指定する文字列、および、コードは基本的に「旧漢字コード」を設定し「半角文字」を設定しないでください。
  • 「=」の左側に指定する文字列、および、コードが重複する場合、ファイルの先頭から見て最初に設定されたデータのみが有効になります。
  • 「=」の右側に指定する文字列、および、コードは、かなを設定する必要がある場合、必ず「半角ｶﾀｶﾅ」で設定してください。
  • 「半角文字」「数字」「英字」「記号」「県」「市」「町」 および「ひらがな」「カタカナ」は設定しないでください。

    • ©2014 Advance Software inc. All rights reserved.


フラグ設定ファイル

[image]

Yubin7 Ver2.6
フラグ設定ファイル

このトピックでは、フラグ設定ファイルについて説明します。 フラグ設定ファイル (AdvZipPrm.xml) には、カスタマバーコード変換と郵便番号変換エンジン (Yubin7.AdvZip.dll) 内部の旧漢字テーブルに関する設定を行う二つのフラグ「kanjiNumberConvertLevel」と「kanjiTableOff」があります。「kanjiNumberConvertLevel」では、住所文字列の最後にくる漢数字を、カスタマバーコード変換時に使用する、使用しないのフラグ設定を行います。「kanjiTableOff」では、郵便番号変換エンジン (Yubin7.AdvZip.dll) 内部の旧漢字テーブルの使用する、使用しないのフラグ設定を行います。

このトピックは、次のセクションを含みます。

  • Yubin7 Ver2.6 ユーテリティ (Yubin7.exe) で使用する
  • .NET Framework 用アセンブリで使用する
  • フラグ設定ファイルを編集する
  • 郵便番号変換エンジン (Yubin7.AdvZip.dll) の旧漢字テーブル一覧
フラグ設定ファイル使用時の注意:
  • フラグ設定ファイル (AdvZipPrm.xml) は、Yubin7 Ver2.6 インストールフォルダ内に格納されています。

    • Yubin7 Ver2.6 ユーテリティ (Yubin7.exe) で使用する

    1. 設定ファイル (Yubin7.settings) をテキストエディタで開き、AdvZipPrm の値を "true" に変更して上書き保存します。

    2. フラグ設定ファイル (AdvZipPrm.xml) をテキストエディタで開き、「フラグ設定ファイルを編集する」を参考に設定します。

    3. フラグ設定ファイル (AdvZipPrm.xml) を郵便番号辞書ファイル (AdvZip.dic) と同じフォルダに配置します。

    4. Yubin7 Ver2.6 ユーテリティ (Yubin7.exe) を起動して動作をご確認ください。

    .NET Framework 用アセンブリで使用する

    1. Yubin7 Ver2.6 の .NET Framework 用アセンブリを使用しているアプリケーションで UseAdvZipParam プロパティを True に設定します。

      メモ:
      UseAdvZipParam プロパティの詳細については、「UseAdvZipParam」を参照してください。

    2. フラグ設定ファイル (AdvZipPrm.xml) をテキストエディタで開き、「フラグ設定ファイルを編集する」を参考に設定します。

    3. アプリケーションを配布する環境のシステムフォルダ、または、アプリケーションと同じフォルダにフラグ設定ファイル (AdvZipPrm.xml) を配置します。

    フラグ設定ファイルを編集する

    1. フラグ設定ファイル (AdvZipPrm.xml) をテキストエディタで開きます。

    2. 以下の内容を参考に値を編集して上書き保存します。

      項目 説明
      kanjiNumberConvertLevel
      kanjiNumberConvertLevel=0 住所文字列の最後にくる漢数字を、カスタマバーコード変換に使用しません。
      住所例 | カスタマバーコード
      福井県福井市和田東一丁目二三二一 | 1
      福井県福井市和田東一丁目二三二一番地 | 1-2321
      kanjiNumberConvertLevel=1 住所文字列の最後にくる漢数字を、カスタマバーコード変換に使用します。
      住所例 | カスタマバーコード
      福井県福井市和田東一丁目二三二一 | 1-2321
      福井県福井市和田東一丁目二三二一番地 | 1-2321
      注意:
      「奈良県御所市南十三」の「南十三」などの漢数字を含む町名があった場合、カスタマバーコード変換に使用するため、正しい変換結果になりません。同様に、他の似たような住所の場合も正しく変換されなくなります。
      kanjiTableOff
      kanjiTableOff=0 郵便番号変換エンジン (Yubin7.AdvZip.dll) 内部の旧漢字テーブルを使用します。
      住所例 | 郵便番号 | 変換結果
      福島県伊達郡川俣町壺ケ作 | 960-1483 | 960-1483
      福島県伊達郡川俣町壷ケ作 | 960-1483 | 960-1483
      kanjiTableOff=1 郵便番号変換エンジン (Yubin7.AdvZip.dll) 内部の旧漢字テーブルを使用しません。
      住所例 | 郵便番号 | 変換結果
      福島県伊達郡川俣町壺ケ作 | 960-1483 | 960-1483
      福島県伊達郡川俣町壷ケ作 | 960-1483 | 960-1400
      注意:
      フラグに設定する値は、半角文字の 0 と 1 です。半角文字の 0 と 1 以外の値を設定しないでください。また、フラグに設定する値以外の文字は書き換えないでください。

    郵便番号変換エンジン (Yubin7.AdvZip.dll) の旧漢字テーブル一覧

    郵便番号変換エンジン (Yubin7.AdvZip.dll) の旧漢字テーブルの詳細は以下の通りです。

    鰺=鯵 | 鶯=鴬 | 蠣=蛎 | 攪=撹 | 竈=釜 | 竃=釜 | 灌=潅 | 諫=諌
頸=頚 | 礦=砿 | 蘂=蕊 | 靱=靭 | 賤=賎 | 壺=壷 | 礪=砺 | 檮=梼
濤=涛 | 邇=迩 | 蠅=蝿 | 檜=桧 | 儘=侭 | 藪=薮 | 籠=篭 | 靫=靭
澤=沢 | 龍=竜 | 條=条 | 糟=粕 | 葦=芦 | 溪=渓 | 淵=渕 | 嶋=島
舘=館 | 峯=峰 | 曾=曽 | 櫻=桜 | 佛=仏 | 槇=槙 | 禰=祢 | 冨=富
苅=刈 | 齊=斉 | 斎=斉 | 齋=斉 | 珊=柵 | 剱=剣 | 己=巳


Access 用カスタマバーコードコントロール

[image]

Yubin7 Ver2.6
Access 用カスタマバーコードコントロール

ここでは、Access 用カスタマバーコードコントロールについて説明します。

Access 用カスタマバーコードコントロールを追加する

Access 用カスタマバーコードコントロールを追加する方法を説明します。

Access 用カスタマバーコードコントロールプロパティ一覧

Access 用カスタマバーコードコントロールプロパティ一覧を説明します。


Access 用カスタマバーコードコントロールを追加する

[image]

Yubin7 Ver2.6
Access 用カスタマバーコードコントロールを追加する

Access のレポート機能で、Access データベースのテーブルと連結して、簡単にカスタマバーコードを印刷することができます。データベースに住所フィールドが登録されていれば、その住所から郵便番号とカスタマバーコードデータを自動解析し、カスタマバーコードイメージを、レポート上に挿入したカスタマバーコードコントロールに表示します。 このトピックでは、Access 用カスタマバーコードコントロールを追加する方法を説明します。

Access データベースでレポートを作成する

  1. Access を起動して既存の住所データを開きます。ここでは、Access 2013 を使用した手順を記載します。

  2. カスタマバーコードデータの元データとなる、住所、または郵便番号 + バーコードデータが登録されているテーブルを確認します。 ここでは、住所等のデータが登録されているテーブルを [住所録] テーブルと仮定して説明します。 また、[住所録] テーブルのデザインは以下の通りと仮定します。

  3. [レポート ウィザード] の画面に従い、[住所録] テーブルを基にレポートを作成します。

  4. 作成したレポートを右クリックし、[デザイン ビュー]を選択します。

  5. [デザイン] - コントロールグループ [その他] - [ActiveX コントロール] を選択し、[ActiveX コントロールの挿入] 画面を表示します。

  6. [ActiveX コントロールの選択] リストより、"CustomBarCodeCtrl Class" を選択して [OK] ボタンをクリックします。

  7. 任意の位置にバーコードコントロールを移動してください。

  8. 挿入したバーコードコントロール "CustomBarCodeCtrl Class" を右クリックし、[プロパティ] を選択して、プロパティ シートを表示します。

  9. [データ] タブ - [コントロールソース] にカスタマバーコードの基となるデータが格納されたフィールド名を設定します。

    例：
    =[郵便番号7桁]+[バーコードデータ]
    =[都道府県名]+[住所1]+Nz([住所2])

  10. 挿入したバーコードコントロール "CustomBarCodeCtrl Class" の詳細設定をします。

    [すべて] タブ画面

    [その他] タブ画面

  11. 設定完了後、レポートのデザインを保存します。

  12. 印刷するには、レポートを直接印刷する場合、レポートを右クリックし、[印刷] をクリックします。プレビューから印刷する場合、レポートを右クリックして [印刷プレビュー] より、印刷プレビューを表示後、[印刷プレビュー] - [印刷] をクリックします。

参照

Access 用カスタマバーコードコントロール


Access 用カスタマバーコードコントロールプロパティ一覧

このトピックでは、Access 用カスタマバーコードコントロールで設定可能なプロパティ一覧を確認することが可能です。

このトピックは、次のセクションを含みます。

  • Access 用カスタマバーコードコントロールプロパティ一覧

Access 用カスタマバーコードコントロールプロパティ一覧

プロパティ名 | 説明
BlackRatio | 黒バーの太さの比率を設定、取得します。
DpiX | 横方向の解像度を設定、取得します。
DpiY | 縦方向の解像度を設定、取得します。
Point | バーコードのサイズをポイントで設定、取得します。
Rotate | バーコードの回転方向を設定、取得します。
Unit | バーコードの生成単位を設定、取得します。

参照

Access 用カスタマバーコードコントロール

©2014 Advance Software inc. All rights reserved.


開発支援

[image]

Yubin7 Ver2.6
開発支援

ここでは、Yubin7 Ver2.6 で追加された .NET Framework 用アセンブリをアプリケーションで使用するための開発支援に関する内容を説明します。

郵便番号変換エンジンを追加する

郵便番号変換エンジンを追加する方法を説明します。

バーコードクラスを追加する

バーコードクラスを追加する方法を説明します。

Yubin7 Ver2.6 オブジェクト機能一覧

Yubin7 Ver2.6 オブジェクト機能一覧を説明します。


郵便番号変換エンジンを追加する

[image]

Yubin7 Ver2.6
郵便番号変換エンジンを追加する

このトピックでは、Visual Studio のソリューションエクスプローラ上で郵便番号変換エンジンの参照を追加し、コード上でインスタンスの生成をする方法を説明します。

郵便番号変換エンジンの参照を追加する

  1. [表示] メニューの [ソリューション エクスプローラ] をクリックしてソリューションエクスプローラを表示します。

  2. ソリューションエクスプローラのプロジェクトを右クリックし、[参照の追加] をクリックして [参照の追加] ダイアログを表示します。

  3. [参照の追加] ダイアログの [参照] タブより、Yubin7 Ver2.6 インストールフォルダ内 [Bin] フォルダ内の以下のアセンブリを選択し、[OK] ボタンをクリックします。

    ファイル名
    Yubin7.AdvZip.dll

  4. ソリューションエクスプローラの [参照設定] に選択したアセンブリが追加されます。

コード上でインスタンスを生成するには

  1. 下記のコードを追加します。

    コピーC#
    private AdvanceSoftware.Yubin7.AdvZip.AdvZip advZip = new AdvanceSoftware.Yubin7.AdvZip.AdvZip();
    コピーVB.NET
    Private advZip As New AdvanceSoftware.Yubin7.AdvZip.AdvZip()

参照

開発支援


バーコードクラスを追加する

[image]

Yubin7 Ver2.6
バーコードクラスを追加する

このトピックでは、Visual Studio のソリューションエクスプローラ上でバーコードクラスの参照を追加し、コード上でインスタンスの生成をする方法を説明します。

バーコードクラスの参照を追加する

  1. [表示] メニューの [ソリューション エクスプローラ] をクリックしてソリューションエクスプローラを表示します。

  2. ソリューションエクスプローラのプロジェクトを右クリックし、[参照の追加] をクリックして [参照の追加] ダイアログを表示します。

  3. [参照の追加] ダイアログの [.NET] タブより、以下のアセンブリを選択し、[OK] ボタンをクリックします。

    コンポーネント名
    AdvanceSoftware.Yubin7.BarCode

  4. ソリューションエクスプローラの [参照設定] に選択したアセンブリが追加されます。

コード上でインスタンスを生成するには

  1. 下記のコードを追加します。

    コピーC#
    private AdvanceSoftware.Yubin7.BarCode.BarCode barCode1 = new AdvanceSoftware.Yubin7.BarCode.BarCode();
    コピーVB.NET
    Private barCode1 As New AdvanceSoftware.Yubin7.BarCode.BarCode

参照

開発支援


Yubin7 Ver2.6 オブジェクト機能一覧

[image]

Yubin7 Ver2.6
Yubin7 Ver2.6 オブジェクト機能一覧

Yubin7 Ver2.6 は、.NET Framework に対応したアセンブリを用意しております。ここでは、Yubin7 Ver2.6 の .NET Framework 用アセンブリをオブジェクト別に設定可能なオブジェクト機能一覧で説明します。クラスライブラリのオブジェクト別逆引き検索ページとしてご使用ください。

郵便番号変換エンジン

郵便番号変換エンジンのオブジェクト機能一覧を説明します。

バーコードクラス

バーコードクラスのオブジェクト機能一覧を説明します。


郵便番号変換エンジン

このトピックでは、郵便番号変換エンジンで使用可能なオブジェクト機能一覧を確認することが可能です。

このトピックは、次のセクションを含みます。

  • 郵便番号変換エンジン

郵便番号変換エンジン

メソッド名 | 説明
AdvCmpClose | 大口事業所辞書をクローズします。
AdvCmpOpen | 大口事業所辞書をオープンします。
AdvDiffClose | 差分辞書をクローズします。
AdvDiffOpen | 差分辞書をオープンします。
AdvZipClose | 郵便番号辞書をクローズします。
AdvZipOpen | 郵便番号辞書をオープンします。
GetAdvZipVersion | アセンブリのバージョンを取得します。
GetAllAddress | すべての住所情報を取得します。
GetCmpCode | 事業所名から大口事業所住所情報を取得します。
GetCmpDicVersion | 大口事業所辞書のバージョンを取得します。
GetDiffDicVersion | 差分辞書のバージョンを取得します。
GetIncAddress | 住所文字列から一致する住所情報を取得します。
GetMergeAddress | 旧住所から市町村変更情報を取得します。
GetJisCodeNow | 現在の JIS コードを取得します。
GetZipAddress | 郵便番号から住所情報と件数を取得します。
GetZipDecision | 郵便番号から確定する住所情報を取得します。
GetZipDicVersion | 郵便番号辞書のバージョンを取得します。
SeparateAddress | 住所文字列を区切ります。
Yubin5 | 住所から 5 桁郵便番号を取得します。
Yubin57 | 住所から 5 桁郵便番号と 7 桁郵便番号を取得します。
Yubin7 | 住所から 7 桁郵便番号を取得します。
プロパティ名 | 説明
DictionaryPath | 辞書ファイルのパスを指定します。
ErrorMessage | エラーメッセージを取得します。
ErrorNo | エラーナンバーを取得します。
HyphenMode | ハイフン付加モードを設定、取得します。
KyotoStreetMode | 京都住所の通り名表記の検索モードを設定します。
ReloadInterval | 辞書を再読み込みするインターバル間隔をミリ秒単位で設定します。
UseAdvZipParam | フラグ設定ファイルを使用するかを指定します。
UseAdvZipTable | 特殊漢字テーブルを使用するかを指定します。
イベント名 | 説明
Error | 変換処理に失敗した時に発生します。

参照

Yubin7 Ver2.6 オブジェクト機能一覧

©2014 Advance Software inc. All rights reserved.


バーコードクラス

このトピックでは、バーコードクラスで使用可能なオブジェクト機能一覧を確認することが可能です。

このトピックは、次のセクションを含みます。

  • バーコードクラス

バーコードクラス

メソッド名 | 説明
GetBarCodeImage | バーコードのイメージを作成します。
GetScaleSize | 指定した単位でバーコードのサイズを取得します。
プロパティ名 | 説明
BackColor | バーコードシンボルの背景色を設定、取得します。
BarColor | バーの色を設定、取得します。
BarHeight | バーコードの高さを設定、取得します。
BarWidth | バーコードの幅を設定、取得します。
BlackRatio | 黒バーの太さの比率を設定、取得します。
DpiX | X 軸方向の解像度を設定、取得します。(ピクセル単位)
DpiY | Y 軸方向の解像度を設定、取得します。(ピクセル単位)
EmfType | 拡張メタファイル(EMF)に格納されるレコードの品質を設定します。
ErrorMessage | エラーメッセージを取得します。
ErrorNo | エラーナンバーを取得します。
InternalValue | 整形後のバーコードデータを取得します。
Point | ポイントを設定、取得します。
Rotate | バーコードの回転方向を設定、取得します。
Unit | バーコードの生成単位を設定、取得します。
Value | バーコードデータを設定、取得します。(文字列)
イベント名 | 説明
Error | バーコードの作成に失敗した時に発生します。

参照

Yubin7 Ver2.6 オブジェクト機能一覧

©2014 Advance Software inc. All rights reserved.


旧バージョンとの互換性、共存

[image]

Yubin7 Ver2.6
旧バージョンとの互換性、共存

このトピックでは、旧バージョンとの互換性、共存について説明します。

このトピックは、次のセクションを含みます。

  • 旧バージョンとの互換性
  • 旧バージョンとの共存

旧バージョンとの互換性

Yubin7 Ver2.6 は、Yubin7 Ver2.0 と互換性はありません。また、移行ツールも用意されておりませんので、旧バージョンで作成したプロジェクト、アプリケーションを Yubin7 Ver2.6 で使用することはできません。この場合、新規にアプリケーションを作成していただく必要があります。

旧バージョンとの共存

開発環境の共存

Yubin7 Ver2.6 は、Yubin7 Ver2.0 アップデート版をインストールすることで追加でインストールされます。また、Yubin7 Ver2.0、Yubin7 Ver2.6 は共存することが可能です。

実行環境の共存

Yubin7 Ver2.0、Yubin7 Ver2.6 のアセンブリ (DLL) をそれぞれ使用したアプリケーションを配布し、共存させることが可能です。


クラス ライブラリ リファレンス

[image]

Yubin7 Ver2.5
クラス ライブラリ リファレンス

名前空間

名前空間 | 説明
AdvanceSoftware.Yubin7.AdvZip | AdvanceSoftware.Yubin7.AdvZip 名前空間には、郵便番号変換エンジンが含まれています。
AdvanceSoftware.Yubin7.BarCode | AdvanceSoftware.Yubin7.BarCode 名前空間には、バーコードクラスが含まれています。


AdvanceSoftware.Yubin7.AdvZip 名前空間

[image]

Yubin7 Ver2.5
AdvanceSoftware.Yubin7.AdvZip 名前空間
AdvanceSoftware.Yubin7.AdvZip 名前空間には、郵便番号変換エンジンが含まれています。

クラス

 | クラス | 説明
Public class | AdvZip | AdvZip クラス
Public class | AdvZip..::..DifferenceInfo | 差分データ情報
Public class | AdvZip..::..MergeInfo | 住所変更情報
Public class | AdvZipErrorEventArgs | AdvZip クラスの Error イベントのデータを提供します。
Public class | Tools | Tools クラス
Public class | Tools..::..AdvZipParam | AdvZipParam クラス

デリゲート

 | デリゲート | 説明
Public delegate | AdvZipErrorEventHandler | AdvZip クラスの Error イベントを処理するメソッドを表します。

列挙体

 | 列挙体 | 説明
Public enumeration | DictionaryInfo | 辞書情報
Public enumeration | ErrorNo | エラーナンバーを示す識別子を指定します。
Public enumeration | HyphenMode | ハイフン付加モード


AdvZip クラス

[image]

Yubin7 Ver2.5
AdvZip クラス
メンバ 参照
AdvZip クラス

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public class AdvZip : IDisposable
Visual Basic (宣言)
Public Class AdvZip _
    Implements IDisposable

継承階層

System..::..Object
AdvanceSoftware.Yubin7.AdvZip..::..AdvZip

参照

AdvZip メンバ
AdvanceSoftware.Yubin7.AdvZip 名前空間


AdvZip メンバ

[image] [image]

Yubin7 Ver2.5
AdvZip メンバ
AdvZip クラス コンストラクタ メソッド プロパティ イベント 参照

AdvZip データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | AdvZip | コンストラクタ

メソッド

 | 名前 | 説明
Public method | AdvCmpClose | 大口事業所辞書をクローズします。
Public method | AdvCmpOpen | 大口事業所辞書をオープンします。
Public method | AdvDiffClose | 差分辞書をクローズします。
Public method | AdvDiffOpen | 差分辞書をオープンします。
Public method | AdvZipClose | 郵便番号辞書をクローズします。
Public method | AdvZipOpen | 郵便番号辞書をオープンします。
Public method | Dispose | Dispose
Public method | GetAdvZipVersion | アセンブリのバージョンを取得します。
Public method | GetAllAddress | すべての住所情報を取得します。
Public method | GetCmpCode(Boolean, String, String, Int32, String%, String%, String%, String%, String%, String%, String%, String%, String%) | 事業所名から大口事業所住所情報を取得します。
Public method | GetCmpCode(Boolean, String, String, Int32, String%, String%, String%, String%, String%, String%, String%, String%, String%, Int32%) | 事業所名から大口事業所住所情報と件数を取得します。
Public method | GetCmpDicVersion | 大口事業所辞書のバージョンを取得します。
Public method | GetDiffDicVersion | 差分辞書のバージョンを取得します。
Public method | GetIncAddress(Boolean, String, String%, String%, String%, String%, String%) | 住所文字列から一致する住所情報を取得します。
Public method | GetIncAddress(Boolean, String, String%, String%, String%, String%, String%, Int32%) | 住所文字列から一致する住所情報と件数を取得します。
Public method | GetIncAddress(Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%) | 住所文字列から一致する住所情報を取得します。
Public method | GetIncAddress(Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, Int32%) | 住所文字列から一致する住所情報と件数を取得します。
Public method | GetJisCodeNow | 現在の JIS コードを取得します。
Public method | GetMergeAddress(String, AdvZip..::..DifferenceInfo%) | 旧住所から市町村変更情報を取得します。
Public method | GetMergeAddress(String, AdvZip..::..DifferenceInfo%, Boolean, Boolean) | 旧住所から市町村変更情報を取得します。
Public method | GetZipAddress(Boolean, String, String%, String%, String%, String%, String%, String%, String%) | 郵便番号から住所情報を取得します。
Public method | GetZipAddress(Boolean, String, String%, String%, String%, String%, String%, String%, String%, Int32%) | 郵便番号から住所情報と件数を取得します。
Public method | GetZipAddress(Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%) | 郵便番号から住所情報を取得します。
Public method | GetZipAddress(Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, Int32%) | 郵便番号から住所情報と件数を取得します。
Public method | GetZipAddressCmp(Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%) | 郵便番号から大口事業所住所情報を取得します。
Public method | GetZipAddressCmp(Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%, Int32%) | 郵便番号から大口事業所住所情報と件数を取得します。
Public method | GetZipDecision(String, String%, String%, String%, String%, String%) | 郵便番号から確定する住所情報を取得します。
Public method | GetZipDecision(String, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%) | 郵便番号から確定する住所情報を取得します。
Public method | GetZipDicVersion | 郵便番号辞書のバージョンを取得します。
Public method | SeparateAddress | 住所文字列を区切ります。
Public method | SetZip7OnlyMode | 7 桁郵便番号を取得するモードに設定します。
Public method | Yubin5(String, String%) | 住所から 5 桁郵便番号を取得します。
Public method | Yubin5(String, String%, String%) | 住所から 5 桁郵便番号とバーコードデータを取得します。
Public method | Yubin57(String, String%, String%) | 住所から 5 桁郵便番号と 7 桁郵便番号を取得します。
Public method | Yubin57(String, String%, String%, String%) | 住所から 5 桁郵便番号と 7 桁郵便番号とバーコードデータを取得します。
Public method | Yubin7(String, String%) | 住所から 7 桁郵便番号を取得します。
Public method | Yubin7(String, String%, String%) | 住所から 7 桁郵便番号とバーコードデータを取得します。
Public method | Yubin7JisCode | 住所から全国地方公共団体コードを取得します。

プロパティ

 | 名前 | 説明
Public property | DictionaryPath | 辞書ファイルのパスを指定します。
Public property | ErrorMessage | エラーメッセージを取得します。
Public property | ErrorNo | エラーナンバーを取得します。
Public property | HyphenMode | ハイフン付加モードを設定、取得します。
Public property | KyotoStreetMode | 京都住所の通り名表記の検索モードを設定します。
Public property | ReloadInterval | 辞書を再読み込みするインターバル間隔をミリ秒単位で設定します。
Public property | UseAdvZipParam | フラグ設定ファイルを使用するかを指定します。
Public property | UseAdvZipTable | 特殊漢字テーブルを使用するかを指定します。

イベント

 | 名前 | 説明
Public event | Error | 変換処理に失敗した時に発生します。

参照

AdvZip クラス


AdvZip コンストラクタ

[image]

Yubin7 Ver2.5
AdvZip コンストラクタ
AdvZip クラス 参照
コンストラクタ

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public AdvZip()
Visual Basic (宣言)
Public Sub New

参照

AdvZip クラス


AdvZip メソッド

[image] [image]

Yubin7 Ver2.5
AdvZip メソッド
AdvZip クラス 参照

AdvZip データ型で公開されるメンバを以下に示します。

メソッド

 | 名前 | 説明
Public method | AdvCmpClose | 大口事業所辞書をクローズします。
Public method | AdvCmpOpen | 大口事業所辞書をオープンします。
Public method | AdvDiffClose | 差分辞書をクローズします。
Public method | AdvDiffOpen | 差分辞書をオープンします。
Public method | AdvZipClose | 郵便番号辞書をクローズします。
Public method | AdvZipOpen | 郵便番号辞書をオープンします。
Public method | Dispose | Dispose
Public method | GetAdvZipVersion | アセンブリのバージョンを取得します。
Public method | GetAllAddress | すべての住所情報を取得します。
Public method | GetCmpCode(Boolean, String, String, Int32, String%, String%, String%, String%, String%, String%, String%, String%, String%) | 事業所名から大口事業所住所情報を取得します。
Public method | GetCmpCode(Boolean, String, String, Int32, String%, String%, String%, String%, String%, String%, String%, String%, String%, Int32%) | 事業所名から大口事業所住所情報と件数を取得します。
Public method | GetCmpDicVersion | 大口事業所辞書のバージョンを取得します。
Public method | GetDiffDicVersion | 差分辞書のバージョンを取得します。
Public method | GetIncAddress(Boolean, String, String%, String%, String%, String%, String%) | 住所文字列から一致する住所情報を取得します。
Public method | GetIncAddress(Boolean, String, String%, String%, String%, String%, String%, Int32%) | 住所文字列から一致する住所情報と件数を取得します。
Public method | GetIncAddress(Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%) | 住所文字列から一致する住所情報を取得します。
Public method | GetIncAddress(Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, Int32%) | 住所文字列から一致する住所情報と件数を取得します。
Public method | GetJisCodeNow | 現在の JIS コードを取得します。
Public method | GetMergeAddress(String, AdvZip..::..DifferenceInfo%) | 旧住所から市町村変更情報を取得します。
Public method | GetMergeAddress(String, AdvZip..::..DifferenceInfo%, Boolean, Boolean) | 旧住所から市町村変更情報を取得します。
Public method | GetZipAddress(Boolean, String, String%, String%, String%, String%, String%, String%, String%) | 郵便番号から住所情報を取得します。
Public method | GetZipAddress(Boolean, String, String%, String%, String%, String%, String%, String%, String%, Int32%) | 郵便番号から住所情報と件数を取得します。
Public method | GetZipAddress(Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%) | 郵便番号から住所情報を取得します。
Public method | GetZipAddress(Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, Int32%) | 郵便番号から住所情報と件数を取得します。
Public method | GetZipAddressCmp(Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%) | 郵便番号から大口事業所住所情報を取得します。
Public method | GetZipAddressCmp(Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%, Int32%) | 郵便番号から大口事業所住所情報と件数を取得します。
Public method | GetZipDecision(String, String%, String%, String%, String%, String%) | 郵便番号から確定する住所情報を取得します。
Public method | GetZipDecision(String, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%) | 郵便番号から確定する住所情報を取得します。
Public method | GetZipDicVersion | 郵便番号辞書のバージョンを取得します。
Public method | SeparateAddress | 住所文字列を区切ります。
Public method | SetZip7OnlyMode | 7 桁郵便番号を取得するモードに設定します。
Public method | Yubin5(String, String%) | 住所から 5 桁郵便番号を取得します。
Public method | Yubin5(String, String%, String%) | 住所から 5 桁郵便番号とバーコードデータを取得します。
Public method | Yubin57(String, String%, String%) | 住所から 5 桁郵便番号と 7 桁郵便番号を取得します。
Public method | Yubin57(String, String%, String%, String%) | 住所から 5 桁郵便番号と 7 桁郵便番号とバーコードデータを取得します。
Public method | Yubin7(String, String%) | 住所から 7 桁郵便番号を取得します。
Public method | Yubin7(String, String%, String%) | 住所から 7 桁郵便番号とバーコードデータを取得します。
Public method | Yubin7JisCode | 住所から全国地方公共団体コードを取得します。

参照

AdvZip クラス


AdvCmpClose メソッド

[image]

Yubin7 Ver2.5
AdvZip..::..AdvCmpClose メソッド
AdvZip クラス 使用例 参照
大口事業所辞書をクローズします。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public bool AdvCmpClose()
Visual Basic (宣言)
Public Function AdvCmpClose As Boolean

戻り値

エラー時：false

正常終了時：true

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetCmpCode.txt"))
{
    // 大口事業所辞書をオープンします。
    if (advZip.AdvCmpOpen() == false) MessageBox.Show("辞書ファイルのオープンに失敗しました。");

    string sourceName = "日本"; // 検索文字列
    string baseCity = "";       // 検索元地域名
    int mode = 0;               // 検索条件
    string zip5Code = null;     // 5 桁郵便番号
    string zip7Code = null;     // 7 桁郵便番号
    string jisCode = null;      // 全国地方公共団体コード
    string pref = null;         // 都道府県名
    string city1 = null;        // 市名 1
    string city2 = null;        // 市名 2
    string town = null;         // 町域名
    string townExt = null;      // 町域名以降
    string companyName = null;  // 大口事業所名
    int ret;
    // 検索文字列を基にあいまい検索を行い、該当する大口事業所住所情報を取得します。(1 回目)
    ret = advZip.GetCmpCode(true, sourceName, baseCity, mode, out zip5Code, out zip7Code, out jisCode, out pref, out city1, out city2, out town, out townExt, out companyName);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("事業所名が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    while (ret != 0)
    {
        // 取得した大口事業所住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code + "," + zip7Code + "," + jisCode + "," + pref + "," + city1 + "," + city2 + "," + town + "," + townExt + "," + companyName);
        // 検索文字列を基にあいまい検索を行い、該当する大口事業所住所情報を取得します。(2 回目以降)
        ret = advZip.GetCmpCode(false, sourceName, baseCity, mode, out zip5Code, out zip7Code, out jisCode, out pref, out city1, out city2, out town, out townExt, out companyName);
    }

    // 大口事業所辞書をクローズします。
    if (advZip.AdvCmpClose() == false) MessageBox.Show("辞書ファイルのクローズに失敗しました。");
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetCmpCode.txt")
    ' 大口事業所辞書をオープンします。
    If advZip.AdvCmpOpen() = False Then MessageBox.Show("辞書ファイルのオープンに失敗しました。")

    Dim sourceName As String = "日本"   ' 検索文字列
    Dim baseCity As String = ""         ' 検索元地域名
    Dim mode As Integer = 0             ' 検索条件
    Dim zip5Code As String = Nothing    ' 5 桁郵便番号
    Dim zip7Code As String = Nothing    ' 7 桁郵便番号
    Dim jisCode As String = Nothing     ' 全国地方公共団体コード
    Dim pref As String = Nothing        ' 都道府県名
    Dim city1 As String = Nothing       ' 市名 1
    Dim city2 As String = Nothing       ' 市名 2
    Dim town As String = Nothing        ' 町域名
    Dim townExt As String = Nothing     ' 町域名以降
    Dim companyName As String = Nothing ' 大口事業所名
    Dim ret As Integer
    ' 検索文字列を基にあいまい検索を行い、該当する大口事業所住所情報を取得します。(1 回目)
    ret = advZip.GetCmpCode(True, sourceName, baseCity, mode, zip5Code, zip7Code, jisCode, pref, city1, city2, town, townExt, companyName)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("事業所名が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    While ret <> 0
        ' 取得した大口事業所住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code & "," & zip7Code & "," & jisCode & "," & pref & "," & city1 & "," & city2 & "," & town & "," & townExt & "," & companyName)
        ' 検索文字列を基にあいまい検索を行い、該当する大口事業所住所情報を取得します。(2 回目以降)
        ret = advZip.GetCmpCode(False, sourceName, baseCity, mode, zip5Code, zip7Code, jisCode, pref, city1, city2, town, townExt, companyName)
    End While

    ' 大口事業所辞書をクローズします。
    If advZip.AdvCmpClose() = False Then MessageBox.Show("辞書ファイルのクローズに失敗しました。")
End Using

参照

AdvZip クラス


AdvCmpOpen メソッド

[image]

Yubin7 Ver2.5
AdvZip..::..AdvCmpOpen メソッド
AdvZip クラス 使用例 参照
大口事業所辞書をオープンします。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public bool AdvCmpOpen()
Visual Basic (宣言)
Public Function AdvCmpOpen As Boolean

戻り値

エラー時：false

正常終了時：true

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetCmpCode.txt"))
{
    // 大口事業所辞書をオープンします。
    if (advZip.AdvCmpOpen() == false) MessageBox.Show("辞書ファイルのオープンに失敗しました。");

    string sourceName = "日本"; // 検索文字列
    string baseCity = "";       // 検索元地域名
    int mode = 0;               // 検索条件
    string zip5Code = null;     // 5 桁郵便番号
    string zip7Code = null;     // 7 桁郵便番号
    string jisCode = null;      // 全国地方公共団体コード
    string pref = null;         // 都道府県名
    string city1 = null;        // 市名 1
    string city2 = null;        // 市名 2
    string town = null;         // 町域名
    string townExt = null;      // 町域名以降
    string companyName = null;  // 大口事業所名
    int ret;
    // 検索文字列を基にあいまい検索を行い、該当する大口事業所住所情報を取得します。(1 回目)
    ret = advZip.GetCmpCode(true, sourceName, baseCity, mode, out zip5Code, out zip7Code, out jisCode, out pref, out city1, out city2, out town, out townExt, out companyName);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("事業所名が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    while (ret != 0)
    {
        // 取得した大口事業所住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code + "," + zip7Code + "," + jisCode + "," + pref + "," + city1 + "," + city2 + "," + town + "," + townExt + "," + companyName);
        // 検索文字列を基にあいまい検索を行い、該当する大口事業所住所情報を取得します。(2 回目以降)
        ret = advZip.GetCmpCode(false, sourceName, baseCity, mode, out zip5Code, out zip7Code, out jisCode, out pref, out city1, out city2, out town, out townExt, out companyName);
    }

    // 大口事業所辞書をクローズします。
    if (advZip.AdvCmpClose() == false) MessageBox.Show("辞書ファイルのクローズに失敗しました。");
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetCmpCode.txt")
    ' 大口事業所辞書をオープンします。
    If advZip.AdvCmpOpen() = False Then MessageBox.Show("辞書ファイルのオープンに失敗しました。")

    Dim sourceName As String = "日本"   ' 検索文字列
    Dim baseCity As String = ""         ' 検索元地域名
    Dim mode As Integer = 0             ' 検索条件
    Dim zip5Code As String = Nothing    ' 5 桁郵便番号
    Dim zip7Code As String = Nothing    ' 7 桁郵便番号
    Dim jisCode As String = Nothing     ' 全国地方公共団体コード
    Dim pref As String = Nothing        ' 都道府県名
    Dim city1 As String = Nothing       ' 市名 1
    Dim city2 As String = Nothing       ' 市名 2
    Dim town As String = Nothing        ' 町域名
    Dim townExt As String = Nothing     ' 町域名以降
    Dim companyName As String = Nothing ' 大口事業所名
    Dim ret As Integer
    ' 検索文字列を基にあいまい検索を行い、該当する大口事業所住所情報を取得します。(1 回目)
    ret = advZip.GetCmpCode(True, sourceName, baseCity, mode, zip5Code, zip7Code, jisCode, pref, city1, city2, town, townExt, companyName)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("事業所名が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    While ret <> 0
        ' 取得した大口事業所住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code & "," & zip7Code & "," & jisCode & "," & pref & "," & city1 & "," & city2 & "," & town & "," & townExt & "," & companyName)
        ' 検索文字列を基にあいまい検索を行い、該当する大口事業所住所情報を取得します。(2 回目以降)
        ret = advZip.GetCmpCode(False, sourceName, baseCity, mode, zip5Code, zip7Code, jisCode, pref, city1, city2, town, townExt, companyName)
    End While

    ' 大口事業所辞書をクローズします。
    If advZip.AdvCmpClose() = False Then MessageBox.Show("辞書ファイルのクローズに失敗しました。")
End Using

参照

AdvZip クラス


AdvDiffClose メソッド

[image]

Yubin7 Ver2.5
AdvZip..::..AdvDiffClose メソッド
AdvZip クラス 使用例 参照
差分辞書をクローズします。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public bool AdvDiffClose()
Visual Basic (宣言)
Public Function AdvDiffClose As Boolean

戻り値

エラー時：false

正常終了時：true

使用例

コピーC#
// 差分辞書をオープンします。
if (advZip.AdvDiffOpen() == false)
{
    MessageBox.Show("差分辞書ファイルのオープンに失敗しました。");
    return;
}

string address = "福井県丹生郡清水町小羽";
int ret;
// 検索文字列を基に検索を行い、該当する市町村変更情報を取得します。
ret = advZip.GetMergeAddress(address, out differenceInfo, true, true);
if (ret == 0) MessageBox.Show("入力した住所の更新履歴はありません。");

// 差分辞書をクローズします。
if (advZip.AdvDiffClose() == false)
{
    MessageBox.Show("差分辞書ファイルのクローズに失敗しました。");
    return;
}
コピーVB.NET
' 差分辞書をオープンします。
If (advZip.AdvDiffOpen() = False) Then
    MessageBox.Show("差分辞書ファイルのオープンに失敗しました。")
    Return
End If

Dim address As String = "福井県丹生郡清水町小羽"
Dim ret As Integer
' 検索文字列を基に検索を行い、該当する市町村変更情報を取得します。
ret = advZip.GetMergeAddress(address, differenceInfo, True, True)
If (ret = 0) Then MessageBox.Show("入力した住所の更新履歴はありません。")

' 差分辞書をクローズします。
If (advZip.AdvDiffClose() = False) Then
    MessageBox.Show("差分辞書ファイルのクローズに失敗しました。")
    Return
End If

参照

AdvZip クラス


AdvDiffOpen メソッド

[image]

Yubin7 Ver2.5
AdvZip..::..AdvDiffOpen メソッド
AdvZip クラス 使用例 参照
差分辞書をオープンします。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public bool AdvDiffOpen()
Visual Basic (宣言)
Public Function AdvDiffOpen As Boolean

戻り値

エラー時：false

正常終了時：true

使用例

コピーC#
// 差分辞書をオープンします。
if (advZip.AdvDiffOpen() == false)
{
    MessageBox.Show("差分辞書ファイルのオープンに失敗しました。");
    return;
}

string address = "福井県丹生郡清水町小羽";
int ret;
// 検索文字列を基に検索を行い、該当する市町村変更情報を取得します。
ret = advZip.GetMergeAddress(address, out differenceInfo, true, true);
if (ret == 0) MessageBox.Show("入力した住所の更新履歴はありません。");

// 差分辞書をクローズします。
if (advZip.AdvDiffClose() == false)
{
    MessageBox.Show("差分辞書ファイルのクローズに失敗しました。");
    return;
}
コピーVB.NET
' 差分辞書をオープンします。
If (advZip.AdvDiffOpen() = False) Then
    MessageBox.Show("差分辞書ファイルのオープンに失敗しました。")
    Return
End If

Dim address As String = "福井県丹生郡清水町小羽"
Dim ret As Integer
' 検索文字列を基に検索を行い、該当する市町村変更情報を取得します。
ret = advZip.GetMergeAddress(address, differenceInfo, True, True)
If (ret = 0) Then MessageBox.Show("入力した住所の更新履歴はありません。")

' 差分辞書をクローズします。
If (advZip.AdvDiffClose() = False) Then
    MessageBox.Show("差分辞書ファイルのクローズに失敗しました。")
    Return
End If

参照

AdvZip クラス


AdvZipClose メソッド

[image]

Yubin7 Ver2.5
AdvZip..::..AdvZipClose メソッド
AdvZip クラス 使用例 参照
郵便番号辞書をクローズします。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public bool AdvZipClose()
Visual Basic (宣言)
Public Function AdvZipClose As Boolean

戻り値

エラー時：false

正常終了時：true

使用例

コピーC#
// 郵便番号辞書をオープンします。
if (advZip.AdvZipOpen() == false) MessageBox.Show("辞書ファイルのオープンに失敗しました。");

string address = "福井県福井市成和1丁目2816番地"; // 検索文字列
string zip7Code = null;                           // 7 桁郵便番号
int ret;
// 検索文字列を基に検索を行い、該当する 7 桁郵便番号を取得します。
ret = advZip.Yubin7(address, out zip7Code);
// エラーを判定します。
if (ret == 0)
{
    MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK);
    return;
}

// 郵便番号辞書をクローズします。
if (advZip.AdvZipClose() == false) MessageBox.Show("辞書ファイルのクローズに失敗しました。");
コピーVB.NET
' 郵便番号辞書をオープンします。
If advZip.AdvZipOpen() = False Then MessageBox.Show("辞書ファイルのオープンに失敗しました。")

Dim address As String = "福井県福井市成和1丁目2816番地" ' 検索文字列
Dim zip7Code As String = Nothing                        ' 7 桁郵便番号
Dim ret As Integer
' 検索文字列を基に検索を行い、該当する 7 桁郵便番号を取得します。
ret = advZip.Yubin7(address, zip7Code)
' エラーを判定します。
If (ret = 0) Then
    MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK)
    Return
End If

' 郵便番号辞書をクローズします。
If advZip.AdvZipClose() = False Then MessageBox.Show("辞書ファイルのクローズに失敗しました。")

参照

AdvZip クラス


AdvZipOpen メソッド

[image]

Yubin7 Ver2.5
AdvZip..::..AdvZipOpen メソッド
AdvZip クラス 使用例 参照
郵便番号辞書をオープンします。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public bool AdvZipOpen()
Visual Basic (宣言)
Public Function AdvZipOpen As Boolean

戻り値

エラー時：false

正常終了時：true

使用例

コピーC#
// 郵便番号辞書をオープンします。
if (advZip.AdvZipOpen() == false) MessageBox.Show("辞書ファイルのオープンに失敗しました。");

string address = "福井県福井市成和1丁目2816番地"; // 検索文字列
string zip7Code = null;                           // 7 桁郵便番号
int ret;
// 検索文字列を基に検索を行い、該当する 7 桁郵便番号を取得します。
ret = advZip.Yubin7(address, out zip7Code);
// エラーを判定します。
if (ret == 0)
{
    MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK);
    return;
}

// 郵便番号辞書をクローズします。
if (advZip.AdvZipClose() == false) MessageBox.Show("辞書ファイルのクローズに失敗しました。");
コピーVB.NET
' 郵便番号辞書をオープンします。
If advZip.AdvZipOpen() = False Then MessageBox.Show("辞書ファイルのオープンに失敗しました。")

Dim address As String = "福井県福井市成和1丁目2816番地" ' 検索文字列
Dim zip7Code As String = Nothing                        ' 7 桁郵便番号
Dim ret As Integer
' 検索文字列を基に検索を行い、該当する 7 桁郵便番号を取得します。
ret = advZip.Yubin7(address, zip7Code)
' エラーを判定します。
If (ret = 0) Then
    MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK)
    Return
End If

' 郵便番号辞書をクローズします。
If advZip.AdvZipClose() = False Then MessageBox.Show("辞書ファイルのクローズに失敗しました。")

参照

AdvZip クラス


Dispose メソッド

[image]

Yubin7 Ver2.5
AdvZip..::..Dispose メソッド
AdvZip クラス 参照
Dispose

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public void Dispose()
Visual Basic (宣言)
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

参照

AdvZip クラス


GetAdvZipVersion メソッド

[image]

Yubin7 Ver2.5
AdvZip..::..GetAdvZipVersion メソッド
AdvZip クラス 使用例 参照
アセンブリのバージョンを取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public string GetAdvZipVersion()
Visual Basic (宣言)
Public Function GetAdvZipVersion As String

戻り値

アセンブリのバージョン。(文字列)

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetAdvZipVersion.txt"))
{
    string advZipVersion;
    // アセンブリのバージョンを取得します。
    advZipVersion = advZip.GetAdvZipVersion();
    // 取得したアセンブリのバージョンをテキストファイルに書き込みます。
    streamWriter.WriteLine(advZipVersion);
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetAdvZipVersion.txt")
    Dim advZipVersion As String
    ' アセンブリのバージョンを取得します。
    advZipVersion = advZip.GetAdvZipVersion()
    ' 取得したアセンブリのバージョンをテキストファイルに書き込みます。
    streamWriter.WriteLine(advZipVersion)
End Using

参照

AdvZip クラス


GetAllAddress メソッド

[image]

Yubin7 Ver2.5
AdvZip..::..GetAllAddress メソッド
AdvZip クラス 使用例 参照
すべての住所情報を取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int GetAllAddress(
    bool findFirst,
    out string zip5Code,
    out string zip7Code,
    out string jisCode,
    out string pref,
    out string city1,
    out string city2,
    out string town,
    out string townExt,
    out string prefRuby,
    out string city1Ruby,
    out string city2Ruby,
    out string townRuby,
    out string townExtRuby
)
Visual Basic (宣言)
Public Function GetAllAddress ( _
    findFirst As Boolean, _
    <OutAttribute> ByRef zip5Code As String, _
    <OutAttribute> ByRef zip7Code As String, _
    <OutAttribute> ByRef jisCode As String, _
    <OutAttribute> ByRef pref As String, _
    <OutAttribute> ByRef city1 As String, _
    <OutAttribute> ByRef city2 As String, _
    <OutAttribute> ByRef town As String, _
    <OutAttribute> ByRef townExt As String, _
    <OutAttribute> ByRef prefRuby As String, _
    <OutAttribute> ByRef city1Ruby As String, _
    <OutAttribute> ByRef city2Ruby As String, _
    <OutAttribute> ByRef townRuby As String, _
    <OutAttribute> ByRef townExtRuby As String _
) As Integer

パラメータ

findFirst
Type: System..::..Boolean
初回取得の場合 True、初回以降、連続して該当する住所の取得を行う場合 False を指定します。
zip5Code
Type: System..::..String %
5 桁郵便番号を格納する変数を指定します。
zip7Code
Type: System..::..String %
7 桁郵便番号を格納する変数を指定します。
jisCode
Type: System..::..String %
全国地方公共団体コードを格納する変数を指定します。
pref
Type: System..::..String %
都道府県名を格納する変数を指定します。
city1
Type: System..::..String %
市名を格納する変数を指定します。
city2
Type: System..::..String %
"city1" に続く市町村名を格納する変数を指定します。
town
Type: System..::..String %
町域名を格納する変数を指定します。
townExt
Type: System..::..String %
町域名以降を格納する変数を指定します。
prefRuby
Type: System..::..String %
都道府県名(カタカナ)を格納する変数を指定します。
city1Ruby
Type: System..::..String %
市名(カタカナ)を格納する変数を指定します。
city2Ruby
Type: System..::..String %
"city1Ruby" に続く市町村名(カタカナ)を格納する変数を指定します。
townRuby
Type: System..::..String %
町域名(カタカナ)を格納する変数を指定します。
townExtRuby
Type: System..::..String %
町域名以降(カタカナ)を格納する変数を指定します。

戻り値

エラー時：0

正常時：0 以外(各ビットの値により、取得された住所の特徴を知ることができます。)

Bit0：変換ができた場合必ず「1」になります。

Bit1：「京都の省略住所」の場合「1」になります。

Bit2：「以下に掲載がない場合」という表現の場合「1」になります。

Bit3：「都道府県名省略住所」の場合「1」になります。

Bit4：「市、または郡名の省略住所」の場合「1」になります。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetAllAddress.txt"))
{
    string zip5Code = null;    // 5 桁郵便番号
    string zip7Code = null;    // 7 桁郵便番号
    string jisCode = null;     // 全国地方公共団体コード
    string pref = null;        // 都道府県名
    string city1 = null;       // 市名 1
    string city2 = null;       // 市名 2
    string town = null;        // 町域名
    string townExt = null;     // 町域名以降
    string prefRuby = null;    // 都道府県名(カタカナ)
    string city1Ruby = null;   // 市名 1(カタカナ)
    string city2Ruby = null;   // 市名 2(カタカナ)
    string townRuby = null;    // 町域名(カタカナ)
    string townExtRuby = null; // 町域名以降(カタカナ)
    int ret;
    // すべての住所情報を取得します。(1 回目)
    ret = advZip.GetAllAddress(true, out zip5Code, out zip7Code, out jisCode, out pref, out city1, out city2, out town, out townExt, out prefRuby, out city1Ruby, out city2Ruby, out townRuby, out townExtRuby);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("検索できませんでした。", "エラー", MessageBoxButtons.OK);
        return;
    }
    while (ret != 0)
    {
        // 町域名が "成和" の住所情報のみをテキストファイルに書き込みます。
        if (town == "成和") streamWriter.WriteLine(zip5Code + "," + zip7Code + "," + jisCode + "," + pref + "," + city1 + "," + city2 + "," + town + "," + townExt + "," + prefRuby + "," + city1Ruby + "," + city2Ruby + "," + townRuby + "," + townExtRuby);
        // すべての住所情報を取得します。(2 回目以降)
        ret = advZip.GetAllAddress(false, out zip5Code, out zip7Code, out jisCode, out pref, out city1, out city2, out town, out townExt, out prefRuby, out city1Ruby, out city2Ruby, out townRuby, out townExtRuby);
    }
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetAllAddress.txt")
    Dim zip5Code As String = Nothing    ' 5 桁郵便番号
    Dim zip7Code As String = Nothing    ' 7 桁郵便番号
    Dim jisCode As String = Nothing     ' 全国地方公共団体コード
    Dim pref As String = Nothing        ' 都道府県名
    Dim city1 As String = Nothing       ' 市名 1
    Dim city2 As String = Nothing       ' 市名 2
    Dim town As String = Nothing        ' 町域名
    Dim townExt As String = Nothing     ' 町域名以降
    Dim prefRuby As String = Nothing    ' 都道府県名(カタカナ)
    Dim city1Ruby As String = Nothing   ' 市名 1(カタカナ)
    Dim city2Ruby As String = Nothing   ' 市名 2(カタカナ)
    Dim townRuby As String = Nothing    ' 町域名(カタカナ)
    Dim townExtRuby As String = Nothing ' 町域名以降(カタカナ)
    Dim ret As Integer
    ' すべての住所情報を取得します。(1 回目)
    ret = advZip.GetAllAddress(True, zip5Code, zip7Code, jisCode, pref, city1, city2, town, townExt, prefRuby, city1Ruby, city2Ruby, townRuby, townExtRuby)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("検索できませんでした。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    While ret <> 0
        ' 町域名が "成和" の住所情報のみをテキストファイルに書き込みます。
        If town = "成和" Then streamWriter.WriteLine(zip5Code & "," & zip7Code & "," & jisCode & "," & pref & "," & city1 & "," & city2 & "," & town & "," & townExt & "," & prefRuby & "," & city1Ruby & "," & city2Ruby & "," & townRuby & "," & townExtRuby)
        ' すべての住所情報を取得します。(2 回目以降)
        ret = advZip.GetAllAddress(False, zip5Code, zip7Code, jisCode, pref, city1, city2, town, townExt, prefRuby, city1Ruby, city2Ruby, townRuby, townExtRuby)
    End While
End Using

参照

AdvZip クラス


GetCmpCode メソッド

[image] [image]

Yubin7 Ver2.5
AdvZip..::..GetCmpCode メソッド
AdvZip クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | GetCmpCode(Boolean, String, String, Int32, String%, String%, String%, String%, String%, String%, String%, String%, String%) | 事業所名から大口事業所住所情報を取得します。
Public method | GetCmpCode(Boolean, String, String, Int32, String%, String%, String%, String%, String%, String%, String%, String%, String%, Int32%) | 事業所名から大口事業所住所情報と件数を取得します。

参照

AdvZip クラス
AdvZip メンバ


GetCmpCode メソッド (Boolean, String, String, Int32, String, String, String, String, String, String, String, String, String)

[image]

Yubin7 Ver2.5
AdvZip..::..GetCmpCode メソッド (Boolean, String, String, Int32, String%, String%, String%, String%, String%, String%, String%, String%, String%)
AdvZip クラス 使用例 参照
事業所名から大口事業所住所情報を取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int GetCmpCode(
    bool findFirst,
    string sourceName,
    string baseCity,
    int mode,
    out string zip5Code,
    out string zip7Code,
    out string jisCode,
    out string pref,
    out string city1,
    out string city2,
    out string town,
    out string townExt,
    out string companyName
)
Visual Basic (宣言)
Public Function GetCmpCode ( _
    findFirst As Boolean, _
    sourceName As String, _
    baseCity As String, _
    mode As Integer, _
    <OutAttribute> ByRef zip5Code As String, _
    <OutAttribute> ByRef zip7Code As String, _
    <OutAttribute> ByRef jisCode As String, _
    <OutAttribute> ByRef pref As String, _
    <OutAttribute> ByRef city1 As String, _
    <OutAttribute> ByRef city2 As String, _
    <OutAttribute> ByRef town As String, _
    <OutAttribute> ByRef townExt As String, _
    <OutAttribute> ByRef companyName As String _
) As Integer

パラメータ

findFirst
Type: System..::..Boolean
初回取得の場合 True、初回以降、連続して該当する住所の取得を行う場合 False を指定します。
sourceName
Type: System..::..String
検索の基となる、大口事業所名を指定します。
baseCity
Type: System..::..String
地域を限定した検索を行う場合、都市名を指定します。
mode
Type: System..::..Int32

検索条件を指定します。

0：あいまい検索(検索文字列が大口事業所名の一部と一致するものを検索)

1：完全一致(検索文字列が大口事業所名と完全に一致するものを検索)

2：完全一致(前株・後株等は省く)(検索文字列が大口事業所名と完全に一致するものを検索。なお、前株・後株は検索条件から除く。)

zip5Code
Type: System..::..String %
5 桁郵便番号を格納する変数を指定します。
zip7Code
Type: System..::..String %
7 桁郵便番号を格納する変数を指定します。
jisCode
Type: System..::..String %
全国地方公共団体コードを格納する変数を指定します。
pref
Type: System..::..String %
都道府県名を格納する変数を指定します。
city1
Type: System..::..String %
市名を格納する変数を指定します。
city2
Type: System..::..String %
"city1" に続く市町村名を格納する変数を指定します。
town
Type: System..::..String %
町域名を格納する変数を指定します。
townExt
Type: System..::..String %
町域名以降を格納する変数を指定します。
companyName
Type: System..::..String %
大口事業所名を格納する変数を指定します。

戻り値

該当住所なし：0

該当住所あり：0 以外

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetCmpCode.txt"))
{
    string sourceName = "日本"; // 検索文字列
    string baseCity = "";       // 検索元地域名
    int mode = 0;               // 検索条件
    string zip5Code = null;     // 5 桁郵便番号
    string zip7Code = null;     // 7 桁郵便番号
    string jisCode = null;      // 全国地方公共団体コード
    string pref = null;         // 都道府県名
    string city1 = null;        // 市名 1
    string city2 = null;        // 市名 2
    string town = null;         // 町域名
    string townExt = null;      // 町域名以降
    string companyName = null;  // 大口事業所名
    int ret;
    // 検索文字列を基にあいまい検索を行い、該当する大口事業所住所情報を取得します。(1 回目)
    ret = advZip.GetCmpCode(true, sourceName, baseCity, mode, out zip5Code, out zip7Code, out jisCode, out pref, out city1, out city2, out town, out townExt, out companyName);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("事業所名が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    while (ret != 0)
    {
        // 取得した大口事業所住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code + "," + zip7Code + "," + jisCode + "," + pref + "," + city1 + "," + city2 + "," + town + "," + townExt + "," + companyName);
        // 検索文字列を基にあいまい検索を行い、該当する大口事業所住所情報を取得します。(2 回目以降)
        ret = advZip.GetCmpCode(false, sourceName, baseCity, mode, out zip5Code, out zip7Code, out jisCode, out pref, out city1, out city2, out town, out townExt, out companyName);
    }
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetCmpCode.txt")
    Dim sourceName As String = "日本"   ' 検索文字列
    Dim baseCity As String = ""         ' 検索元地域名
    Dim mode As Integer = 0             ' 検索条件
    Dim zip5Code As String = Nothing    ' 5 桁郵便番号
    Dim zip7Code As String = Nothing    ' 7 桁郵便番号
    Dim jisCode As String = Nothing     ' 全国地方公共団体コード
    Dim pref As String = Nothing        ' 都道府県名
    Dim city1 As String = Nothing       ' 市名 1
    Dim city2 As String = Nothing       ' 市名 2
    Dim town As String = Nothing        ' 町域名
    Dim townExt As String = Nothing     ' 町域名以降
    Dim companyName As String = Nothing ' 大口事業所名
    Dim ret As Integer
    ' 検索文字列を基にあいまい検索を行い、該当する大口事業所住所情報を取得します。(1 回目)
    ret = advZip.GetCmpCode(True, sourceName, baseCity, mode, zip5Code, zip7Code, jisCode, pref, city1, city2, town, townExt, companyName)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("事業所名が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    While ret <> 0
        ' 取得した大口事業所住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code & "," & zip7Code & "," & jisCode & "," & pref & "," & city1 & "," & city2 & "," & town & "," & townExt & "," & companyName)
        ' 検索文字列を基にあいまい検索を行い、該当する大口事業所住所情報を取得します。(2 回目以降)
        ret = advZip.GetCmpCode(False, sourceName, baseCity, mode, zip5Code, zip7Code, jisCode, pref, city1, city2, town, townExt, companyName)
    End While
End Using

参照

AdvZip クラス
GetCmpCode オーバーロード


GetCmpCode メソッド (Boolean, String, String, Int32, String, String, String, String, String, String, String, String, String, Int32)

[image]

Yubin7 Ver2.5
AdvZip..::..GetCmpCode メソッド (Boolean, String, String, Int32, String%, String%, String%, String%, String%, String%, String%, String%, String%, Int32%)
AdvZip クラス 使用例 参照
事業所名から大口事業所住所情報と件数を取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int GetCmpCode(
    bool findFirst,
    string sourceName,
    string baseCity,
    int mode,
    out string zip5Code,
    out string zip7Code,
    out string jisCode,
    out string pref,
    out string city1,
    out string city2,
    out string town,
    out string townExt,
    out string companyName,
    ref int dataCount
)
Visual Basic (宣言)
Public Function GetCmpCode ( _
    findFirst As Boolean, _
    sourceName As String, _
    baseCity As String, _
    mode As Integer, _
    <OutAttribute> ByRef zip5Code As String, _
    <OutAttribute> ByRef zip7Code As String, _
    <OutAttribute> ByRef jisCode As String, _
    <OutAttribute> ByRef pref As String, _
    <OutAttribute> ByRef city1 As String, _
    <OutAttribute> ByRef city2 As String, _
    <OutAttribute> ByRef town As String, _
    <OutAttribute> ByRef townExt As String, _
    <OutAttribute> ByRef companyName As String, _
    ByRef dataCount As Integer _
) As Integer

パラメータ

findFirst
Type: System..::..Boolean
初回取得の場合 True、初回以降、連続して該当する住所の取得を行う場合 False を指定します。
sourceName
Type: System..::..String
検索の基となる、大口事業所名を指定します。
baseCity
Type: System..::..String
地域を限定した検索を行う場合、都市名を指定します。
mode
Type: System..::..Int32

検索条件を指定します。

0：あいまい検索(検索文字列が大口事業所名の一部と一致するものを検索)

1：完全一致(検索文字列が大口事業所名と完全に一致するものを検索)

2：完全一致(前株・後株等は省く)(検索文字列が大口事業所名と完全に一致するものを検索。なお、前株・後株は検索条件から除く。)

zip5Code
Type: System..::..String %
5 桁郵便番号を格納する変数を指定します。
zip7Code
Type: System..::..String %
7 桁郵便番号を格納する変数を指定します。
jisCode
Type: System..::..String %
全国地方公共団体コードを格納する変数を指定します。
pref
Type: System..::..String %
都道府県名を格納する変数を指定します。
city1
Type: System..::..String %
市名を格納する変数を指定します。
city2
Type: System..::..String %
"city1" に続く市町村名を格納する変数を指定します。
town
Type: System..::..String %
町域名を格納する変数を指定します。
townExt
Type: System..::..String %
町域名以降を格納する変数を指定します。
companyName
Type: System..::..String %
大口事業所名を格納する変数を指定します。
dataCount
Type: System..::..Int32 %
件数を格納する変数を指定します。

戻り値

該当住所なし：0

該当住所あり：0 以外

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetCmpCode.txt"))
{
    string sourceName = "日本"; // 検索文字列
    string baseCity = "";       // 検索元地域名
    int mode = 0;               // 検索条件
    string zip5Code = null;     // 5 桁郵便番号
    string zip7Code = null;     // 7 桁郵便番号
    string jisCode = null;      // 全国地方公共団体コード
    string pref = null;         // 都道府県名
    string city1 = null;        // 市名 1
    string city2 = null;        // 市名 2
    string town = null;         // 町域名
    string townExt = null;      // 町域名以降
    string companyName = null;  // 大口事業所名
    int dataCount = 0;          // 件数
    int ret;
    // 検索文字列を基にあいまい検索を行い、該当する大口事業所住所情報と件数を取得します。(1 回目)
    ret = advZip.GetCmpCode(true, sourceName, baseCity, mode, out zip5Code, out zip7Code, out jisCode, out pref, out city1, out city2, out town, out townExt, out companyName, ref dataCount);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("事業所名が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    while (ret != 0)
    {
        // 取得した大口事業所住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code + "," + zip7Code + "," + jisCode + "," + pref + "," + city1 + "," + city2 + "," + town + "," + townExt + "," + companyName);
        // 検索文字列を基にあいまい検索を行い、該当する大口事業所住所情報を取得します。(2 回目以降)
        ret = advZip.GetCmpCode(false, sourceName, baseCity, mode, out zip5Code, out zip7Code, out jisCode, out pref, out city1, out city2, out town, out townExt, out companyName);
    }
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetCmpCode.txt")
    Dim sourceName As String = "日本"   ' 検索文字列
    Dim baseCity As String = ""         ' 検索元地域名
    Dim mode As Integer = 0             ' 検索条件
    Dim zip5Code As String = Nothing    ' 5 桁郵便番号
    Dim zip7Code As String = Nothing    ' 7 桁郵便番号
    Dim jisCode As String = Nothing     ' 全国地方公共団体コード
    Dim pref As String = Nothing        ' 都道府県名
    Dim city1 As String = Nothing       ' 市名 1
    Dim city2 As String = Nothing       ' 市名 2
    Dim town As String = Nothing        ' 町域名
    Dim townExt As String = Nothing     ' 町域名以降
    Dim companyName As String = Nothing ' 大口事業所名
    Dim dataCount As Integer = 0        ' 件数
    Dim ret As Integer
    ' 検索文字列を基にあいまい検索を行い、該当する大口事業所住所情報と件数を取得します。(1 回目)
    ret = advZip.GetCmpCode(True, sourceName, baseCity, mode, zip5Code, zip7Code, jisCode, pref, city1, city2, town, townExt, companyName, dataCount)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("事業所名が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    While ret <> 0
        ' 取得した大口事業所住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code & "," & zip7Code & "," & jisCode & "," & pref & "," & city1 & "," & city2 & "," & town & "," & townExt & "," & companyName)
        ' 検索文字列を基にあいまい検索を行い、該当する大口事業所住所情報を取得します。(2 回目以降)
        ret = advZip.GetCmpCode(False, sourceName, baseCity, mode, zip5Code, zip7Code, jisCode, pref, city1, city2, town, townExt, companyName)
    End While
End Using

参照

AdvZip クラス
GetCmpCode オーバーロード


GetCmpDicVersion メソッド

[image]

Yubin7 Ver2.5
AdvZip..::..GetCmpDicVersion メソッド
AdvZip クラス 使用例 参照
大口事業所辞書のバージョンを取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public string GetCmpDicVersion(
    DictionaryInfo id
)
Visual Basic (宣言)
Public Function GetCmpDicVersion ( _
    id As DictionaryInfo _
) As String

パラメータ

id
Type: AdvanceSoftware.Yubin7.AdvZip..::..DictionaryInfo
辞書情報を表す DictionaryInfo を指定します。

戻り値

大口事業所辞書のバージョン。(文字列)

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetCmpDicVersion.txt"))
{
    string version;
    string assureDate;
    string releaseDate;
    string createDate;
    // 大口事業所辞書のバージョンを取得します。
    version = advZip.GetCmpDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.Version);
    // 大口事業所辞書のデータ保証日を取得します。
    assureDate = advZip.GetCmpDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.AssureDate);
    // 大口事業所辞書のデータ公開日を取得します。
    releaseDate = advZip.GetCmpDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.ReleaseDate);
    // 大口事業所辞書のファイル生成日を取得します。
    createDate = advZip.GetCmpDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.CreateDate);
    // 取得した大口事業所の情報をテキストファイルに書き込みます。
    streamWriter.WriteLine("バージョン : " + version);
    streamWriter.WriteLine("データ保証日 : " + assureDate);
    streamWriter.WriteLine("データ公開日 : " + releaseDate);
    streamWriter.WriteLine("ファイル生成日 : " + createDate);
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetCmpDicVersion.txt")
    Dim version As String
    Dim assureDate As String
    Dim releaseDate As String
    Dim createDate As String
    ' 大口事業所辞書のバージョンを取得します。
    version = advZip.GetCmpDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.Version)
    ' 大口事業所辞書のデータ保証日を取得します。
    assureDate = advZip.GetCmpDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.AssureDate)
    ' 大口事業所辞書のデータ公開日を取得します。
    releaseDate = advZip.GetCmpDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.ReleaseDate)
    ' 大口事業所辞書のファイル生成日を取得します。
    createDate = advZip.GetCmpDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.CreateDate)
    ' 取得した大口事業所の情報をテキストファイルに書き込みます。
    streamWriter.WriteLine("バージョン : " & version)
    streamWriter.WriteLine("データ保証日 : " & assureDate)
    streamWriter.WriteLine("データ公開日 : " & releaseDate)
    streamWriter.WriteLine("ファイル生成日 : " & createDate)
End Using

参照

AdvZip クラス


GetDiffDicVersion メソッド

[image]

Yubin7 Ver2.5
AdvZip..::..GetDiffDicVersion メソッド
AdvZip クラス 使用例 参照
差分辞書のバージョンを取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public string GetDiffDicVersion(
    DictionaryInfo id
)
Visual Basic (宣言)
Public Function GetDiffDicVersion ( _
    id As DictionaryInfo _
) As String

パラメータ

id
Type: AdvanceSoftware.Yubin7.AdvZip..::..DictionaryInfo
辞書情報を表す DictionaryInfo を指定します。

戻り値

差分辞書のバージョン。(文字列)

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetDiffDicVersion.txt"))
{
    string version;
    string assureDate;
    string releaseDate;
    string createDate;
    // 差分辞書のバージョンを取得します。
    version = advZip.GetDiffDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.Version);
    // 差分辞書のデータ保証日を取得します。
    assureDate = advZip.GetDiffDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.AssureDate);
    // 差分辞書のデータ公開日を取得します。
    releaseDate = advZip.GetDiffDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.ReleaseDate);
    // 差分辞書のファイル生成日を取得します。
    createDate = advZip.GetDiffDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.CreateDate);
    // 取得した差分辞書の情報をテキストファイルに書き込みます。
    streamWriter.WriteLine("バージョン : " + version);
    streamWriter.WriteLine("データ保証日 : " + assureDate);
    streamWriter.WriteLine("データ公開日 : " + releaseDate);
    streamWriter.WriteLine("ファイル生成日 : " + createDate);
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetDiffDicVersion.txt")
    Dim version As String
    Dim assureDate As String
    Dim releaseDate As String
    Dim createDate As String
    ' 差分辞書のバージョンを取得します。
    version = advZip.GetDiffDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.Version)
    ' 差分辞書のデータ保証日を取得します。
    assureDate = advZip.GetDiffDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.AssureDate)
    ' 差分辞書のデータ公開日を取得します。
    releaseDate = advZip.GetDiffDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.ReleaseDate)
    ' 差分辞書のファイル生成日を取得します。
    createDate = advZip.GetDiffDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.CreateDate)
    ' 取得した差分辞書の情報をテキストファイルに書き込みます。
    streamWriter.WriteLine("バージョン : " & version)
    streamWriter.WriteLine("データ保証日 : " & assureDate)
    streamWriter.WriteLine("データ公開日 : " & releaseDate)
    streamWriter.WriteLine("ファイル生成日 : " & createDate)
End Using

参照

AdvZip クラス


GetIncAddress メソッド

[image] [image]

Yubin7 Ver2.5
AdvZip..::..GetIncAddress メソッド
AdvZip クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | GetIncAddress(Boolean, String, String%, String%, String%, String%, String%) | 住所文字列から一致する住所情報を取得します。
Public method | GetIncAddress(Boolean, String, String%, String%, String%, String%, String%, Int32%) | 住所文字列から一致する住所情報と件数を取得します。
Public method | GetIncAddress(Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%) | 住所文字列から一致する住所情報を取得します。
Public method | GetIncAddress(Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, Int32%) | 住所文字列から一致する住所情報と件数を取得します。

参照

AdvZip クラス
AdvZip メンバ


GetIncAddress メソッド (Boolean, String, String, String, String, String, String)

[image]

Yubin7 Ver2.5
AdvZip..::..GetIncAddress メソッド (Boolean, String, String%, String%, String%, String%, String%)
AdvZip クラス 使用例 参照
住所文字列から一致する住所情報を取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int GetIncAddress(
    bool findFirst,
    string address,
    out string pref,
    out string city1,
    out string city2,
    out string town,
    out string townExt
)
Visual Basic (宣言)
Public Function GetIncAddress ( _
    findFirst As Boolean, _
    address As String, _
    <OutAttribute> ByRef pref As String, _
    <OutAttribute> ByRef city1 As String, _
    <OutAttribute> ByRef city2 As String, _
    <OutAttribute> ByRef town As String, _
    <OutAttribute> ByRef townExt As String _
) As Integer

パラメータ

findFirst
Type: System..::..Boolean
初回取得の場合 True、初回以降、連続して該当する住所の取得を行う場合 False を指定します。
address
Type: System..::..String
検索の基となる、住所文字列を指定します。
pref
Type: System..::..String %
都道府県名を格納する変数を指定します。
city1
Type: System..::..String %
市名を格納する変数を指定します。
city2
Type: System..::..String %
"city1" に続く市町村名を格納する変数を指定します。
town
Type: System..::..String %
町域名を格納する変数を指定します。
townExt
Type: System..::..String %
町域名以降を格納する変数を指定します。

戻り値

該当住所なし：0

該当住所あり：0 以外

解説

address に設定する文字列は、漢字、ひらがな、半角、全角カタカナを使用する事が可能です。

・文字列の指定と取得例

例 1：「と」を指定すると、「栃木県」「東京都」「富山県」「鳥取県」「徳島県」が取得されます。

例 2：「とう」を指定すると、「東京都」が取得されます。

例 3：「東京都ち」を指定すると、「東京都千代田区」「東京都中央区」「東京都調布市」が取得されます。

・各レベル先頭に「*(半角アスタリスク)」を指定する事でレベル以下全てが一致する住所が取得されます。

例 1：「*」を指定すると、47 都道府県全てが取得されます。

例 2：「東京都*」を指定すると、東京都の全ての区、市、郡名が取得されます。

例 3：「東京都中央区 *」を指定すると、東京都中央区の全ての町域名が取得されます。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetIncAddress.txt"))
{
    string address = "福井県*"; // 検索文字列
    string pref = null;         // 都道府県名
    string city1 = null;        // 市名 1
    string city2 = null;        // 市名 2
    string town = null;         // 町域名
    string townExt = null;      // 町域名以降
    int ret;
    // 検索文字列を基に検索を行い、該当する住所情報を取得します。(1 回目)
    ret = advZip.GetIncAddress(true, address, out pref, out city1, out city2, out town, out townExt);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    while (ret != 0)
    {
        // 取得した住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(pref + "," + city1 + "," + city2 + "," + town + "," + townExt);
        // 検索文字列を基に検索を行い、該当する住所情報を取得します。(2 回目以降)
        ret = advZip.GetIncAddress(false, address, out pref, out city1, out city2, out town, out townExt);
    }
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetIncAddress.txt")
    Dim address As String = "福井県*" ' 検索文字列
    Dim pref As String = Nothing      ' 都道府県名
    Dim city1 As String = Nothing     ' 市名 1
    Dim city2 As String = Nothing     ' 市名 2
    Dim town As String = Nothing      ' 町域名
    Dim townExt As String = Nothing   ' 町域名以降
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、該当する住所情報を取得します。(1 回目)
    ret = advZip.GetIncAddress(True, address, pref, city1, city2, town, townExt)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    While ret <> 0
        ' 取得した住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(pref & "," & city1 & "," & city2 & "," & town & "," & townExt)
        ' 検索文字列を基に検索を行い、該当する住所情報を取得します。(2 回目以降)
        ret = advZip.GetIncAddress(False, address, pref, city1, city2, town, townExt)
    End While
End Using

参照

AdvZip クラス
GetIncAddress オーバーロード


GetIncAddress メソッド (Boolean, String, String, String, String, String, String, Int32)

[image]

Yubin7 Ver2.5
AdvZip..::..GetIncAddress メソッド (Boolean, String, String%, String%, String%, String%, String%, Int32%)
AdvZip クラス 使用例 参照
住所文字列から一致する住所情報と件数を取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int GetIncAddress(
    bool findFirst,
    string address,
    out string pref,
    out string city1,
    out string city2,
    out string town,
    out string townExt,
    ref int dataCount
)
Visual Basic (宣言)
Public Function GetIncAddress ( _
    findFirst As Boolean, _
    address As String, _
    <OutAttribute> ByRef pref As String, _
    <OutAttribute> ByRef city1 As String, _
    <OutAttribute> ByRef city2 As String, _
    <OutAttribute> ByRef town As String, _
    <OutAttribute> ByRef townExt As String, _
    ByRef dataCount As Integer _
) As Integer

パラメータ

findFirst
Type: System..::..Boolean
初回取得の場合 True、初回以降、連続して該当する住所の取得を行う場合 False を指定します。
address
Type: System..::..String
検索の基となる、住所文字列を指定します。
pref
Type: System..::..String %
都道府県名を格納する変数を指定します。
city1
Type: System..::..String %
市名を格納する変数を指定します。
city2
Type: System..::..String %
"city1" に続く市町村名を格納する変数を指定します。
town
Type: System..::..String %
町域名を格納する変数を指定します。
townExt
Type: System..::..String %
町域名以降を格納する変数を指定します。
dataCount
Type: System..::..Int32 %
件数を格納する変数を指定します。

戻り値

該当住所なし：0

該当住所あり：0 以外

解説

address に設定する文字列は、漢字、ひらがな、半角、全角カタカナを使用する事が可能です。

・文字列の指定と取得例

例 1：「と」を指定すると、「栃木県」「東京都」「富山県」「鳥取県」「徳島県」が取得されます。

例 2：「とう」を指定すると、「東京都」が取得されます。

例 3：「東京都ち」を指定すると、「東京都千代田区」「東京都中央区」「東京都調布市」が取得されます。

・各レベル先頭に「*(半角アスタリスク)」を指定する事でレベル以下全てが一致する住所が取得されます。

例 1：「*」を指定すると、47 都道府県全てが取得されます。

例 2：「東京都*」を指定すると、東京都の全ての区、市、郡名が取得されます。

例 3：「東京都中央区 *」を指定すると、東京都中央区の全ての町域名が取得されます。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetIncAddress.txt"))
{
    string address = "福井県*"; // 検索文字列
    string pref = null;         // 都道府県名
    string city1 = null;        // 市名 1
    string city2 = null;        // 市名 2
    string town = null;         // 町域名
    string townExt = null;      // 町域名以降
    int dataCount = 0;          // 件数
    int ret;
    // 検索文字列を基に検索を行い、該当する住所情報と件数を取得します。(1 回目)
    ret = advZip.GetIncAddress(true, address, out pref, out city1, out city2, out town, out townExt, ref dataCount);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    while (ret != 0)
    {
        // 取得した住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(pref + "," + city1 + "," + city2 + "," + town + "," + townExt);
        // 検索文字列を基に検索を行い、該当する住所情報を取得します。(2 回目以降)
        ret = advZip.GetIncAddress(false, address, out pref, out city1, out city2, out town, out townExt);
    }
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetIncAddress.txt")
    Dim address As String = "福井県*" ' 検索文字列
    Dim pref As String = Nothing      ' 都道府県名
    Dim city1 As String = Nothing     ' 市名 1
    Dim city2 As String = Nothing     ' 市名 2
    Dim town As String = Nothing      ' 町域名
    Dim townExt As String = Nothing   ' 町域名以降
    Dim dataCount As Integer = 0      ' 件数
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、該当する住所情報と件数を取得します。(1 回目)
    ret = advZip.GetIncAddress(True, address, pref, city1, city2, town, townExt, dataCount)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    While ret <> 0
        ' 取得した住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(pref & "," & city1 & "," & city2 & "," & town & "," & townExt)
        ' 検索文字列を基に検索を行い、該当する住所情報を取得します。(2 回目以降)
        ret = advZip.GetIncAddress(False, address, pref, city1, city2, town, townExt)
    End While
End Using

参照

AdvZip クラス
GetIncAddress オーバーロード


GetIncAddress メソッド (Boolean, String, String, String, String, String, String, String, String, String, String, String)

[image]

Yubin7 Ver2.5
AdvZip..::..GetIncAddress メソッド (Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%)
AdvZip クラス 使用例 参照
住所文字列から一致する住所情報を取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int GetIncAddress(
    bool findFirst,
    string address,
    out string pref,
    out string city1,
    out string city2,
    out string town,
    out string townExt,
    out string prefRuby,
    out string city1Ruby,
    out string city2Ruby,
    out string townRuby,
    out string townExtRuby
)
Visual Basic (宣言)
Public Function GetIncAddress ( _
    findFirst As Boolean, _
    address As String, _
    <OutAttribute> ByRef pref As String, _
    <OutAttribute> ByRef city1 As String, _
    <OutAttribute> ByRef city2 As String, _
    <OutAttribute> ByRef town As String, _
    <OutAttribute> ByRef townExt As String, _
    <OutAttribute> ByRef prefRuby As String, _
    <OutAttribute> ByRef city1Ruby As String, _
    <OutAttribute> ByRef city2Ruby As String, _
    <OutAttribute> ByRef townRuby As String, _
    <OutAttribute> ByRef townExtRuby As String _
) As Integer

パラメータ

findFirst
Type: System..::..Boolean
初回取得の場合 True、初回以降、連続して該当する住所の取得を行う場合 False を指定します。
address
Type: System..::..String
検索の基となる、住所文字列を指定します。
pref
Type: System..::..String %
都道府県名を格納する変数を指定します。
city1
Type: System..::..String %
市名を格納する変数を指定します。
city2
Type: System..::..String %
"city1" に続く市町村名を格納する変数を指定します。
town
Type: System..::..String %
町域名を格納する変数を指定します。
townExt
Type: System..::..String %
町域名以降を格納する変数を指定します。
prefRuby
Type: System..::..String %
都道府県名(カタカナ)を格納する変数を指定します。
city1Ruby
Type: System..::..String %
市名(カタカナ)を格納する変数を指定します。
city2Ruby
Type: System..::..String %
"city1Ruby" に続く市町村名(カタカナ)を格納する変数を指定します。
townRuby
Type: System..::..String %
町域名(カタカナ)を格納する変数を指定します。
townExtRuby
Type: System..::..String %
町域名以降(カタカナ)を格納する変数を指定します。

戻り値

該当住所なし：0

該当住所あり：0 以外

解説

address に設定する文字列は、漢字、ひらがな、半角、全角カタカナを使用する事が可能です。

・文字列の指定と取得例

例 1：「と」を指定すると、「栃木県」「東京都」「富山県」「鳥取県」「徳島県」が取得されます。

例 2：「とう」を指定すると、「東京都」が取得されます。

例 3：「東京都ち」を指定すると、「東京都千代田区」「東京都中央区」「東京都調布市」が取得されます。

・各レベル先頭に「*(半角アスタリスク)」を指定する事でレベル以下全てが一致する住所が取得されます。

例 1：「*」を指定すると、47 都道府県全てが取得されます。

例 2：「東京都*」を指定すると、東京都の全ての区、市、郡名が取得されます。

例 3：「東京都中央区 *」を指定すると、東京都中央区の全ての町域名が取得されます。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetIncAddress.txt"))
{
    string address = "福井県*"; // 検索文字列
    string pref = null;         // 都道府県名
    string city1 = null;        // 市名 1
    string city2 = null;        // 市名 2
    string town = null;         // 町域名
    string townExt = null;      // 町域名以降
    string prefRuby = null;     // 都道府県名(カタカナ)
    string city1Ruby = null;    // 市名 1(カタカナ)
    string city2Ruby = null;    // 市名 2(カタカナ)
    string townRuby = null;     // 町域名(カタカナ)
    string townExtRuby = null;  // 町域名以降(カタカナ)
    int ret;
    // 検索文字列を基に検索を行い、該当する住所情報を取得します。(1 回目)
    ret = advZip.GetIncAddress(true, address, out pref, out city1, out city2, out town, out townExt, out prefRuby, out city1Ruby, out city2Ruby, out townRuby, out townExtRuby);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    while (ret != 0)
    {
        // 取得した住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(pref + "," + city1 + "," + city2 + "," + town + "," + townExt + "," + prefRuby + "," + city1Ruby + "," + city2Ruby + "," + townRuby + "," + townExtRuby);
        // 検索文字列を基に検索を行い、該当する住所情報を取得します。(2 回目以降)
        ret = advZip.GetIncAddress(false, address, out pref, out city1, out city2, out town, out townExt, out prefRuby, out city1Ruby, out city2Ruby, out townRuby, out townExtRuby);
    }
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetIncAddress.txt")
    Dim address As String = "福井県*"   ' 検索文字列
    Dim pref As String = Nothing        ' 都道府県名
    Dim city1 As String = Nothing       ' 市名 1
    Dim city2 As String = Nothing       ' 市名 2
    Dim town As String = Nothing        ' 町域名
    Dim townExt As String = Nothing     ' 町域名以降
    Dim prefRuby As String = Nothing    ' 都道府県名(カタカナ)
    Dim city1Ruby As String = Nothing   ' 市名 1(カタカナ)
    Dim city2Ruby As String = Nothing   ' 市名 2(カタカナ)
    Dim townRuby As String = Nothing    ' 町域名(カタカナ)
    Dim townExtRuby As String = Nothing ' 町域名以降(カタカナ)
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、該当する住所情報を取得します。(1 回目)
    ret = advZip.GetIncAddress(True, address, pref, city1, city2, town, townExt, prefRuby, city1Ruby, city2Ruby, townRuby, townExtRuby)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    While ret <> 0
        ' 取得した住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(pref & "," & city1 & "," & city2 & "," & town & "," & townExt & "," & prefRuby & "," & city1Ruby & "," & city2Ruby & "," & townRuby & "," & townExtRuby)
        ' 検索文字列を基に検索を行い、該当する住所情報を取得します。(2 回目以降)
        ret = advZip.GetIncAddress(False, address, pref, city1, city2, town, townExt, prefRuby, city1Ruby, city2Ruby, townRuby, townExtRuby)
    End While
End Using

参照

AdvZip クラス
GetIncAddress オーバーロード


GetIncAddress メソッド (Boolean, String, String, String, String, String, String, String, String, String, String, String, Int32)

[image]

Yubin7 Ver2.5
AdvZip..::..GetIncAddress メソッド (Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, Int32%)
AdvZip クラス 使用例 参照
住所文字列から一致する住所情報と件数を取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int GetIncAddress(
    bool findFirst,
    string address,
    out string pref,
    out string city1,
    out string city2,
    out string town,
    out string townExt,
    out string prefRuby,
    out string city1Ruby,
    out string city2Ruby,
    out string townRuby,
    out string townExtRuby,
    ref int dataCount
)
Visual Basic (宣言)
Public Function GetIncAddress ( _
    findFirst As Boolean, _
    address As String, _
    <OutAttribute> ByRef pref As String, _
    <OutAttribute> ByRef city1 As String, _
    <OutAttribute> ByRef city2 As String, _
    <OutAttribute> ByRef town As String, _
    <OutAttribute> ByRef townExt As String, _
    <OutAttribute> ByRef prefRuby As String, _
    <OutAttribute> ByRef city1Ruby As String, _
    <OutAttribute> ByRef city2Ruby As String, _
    <OutAttribute> ByRef townRuby As String, _
    <OutAttribute> ByRef townExtRuby As String, _
    ByRef dataCount As Integer _
) As Integer

パラメータ

findFirst
Type: System..::..Boolean
初回取得の場合 True、初回以降、連続して該当する住所の取得を行う場合 False を指定します。
address
Type: System..::..String
検索の基となる、住所文字列を指定します。
pref
Type: System..::..String %
都道府県名を格納する変数を指定します。
city1
Type: System..::..String %
市名を格納する変数を指定します。
city2
Type: System..::..String %
"city1" に続く市町村名を格納する変数を指定します。
town
Type: System..::..String %
町域名を格納する変数を指定します。
townExt
Type: System..::..String %
町域名以降を格納する変数を指定します。
prefRuby
Type: System..::..String %
都道府県名(カタカナ)を格納する変数を指定します。
city1Ruby
Type: System..::..String %
市名(カタカナ)を格納する変数を指定します。
city2Ruby
Type: System..::..String %
"city1Ruby" に続く市町村名(カタカナ)を格納する変数を指定します。
townRuby
Type: System..::..String %
町域名(カタカナ)を格納する変数を指定します。
townExtRuby
Type: System..::..String %
町域名以降(カタカナ)を格納する変数を指定します。
dataCount
Type: System..::..Int32 %
件数を格納する変数を指定します。

戻り値

該当住所なし：0

該当住所あり：0 以外

解説

address に設定する文字列は、漢字、ひらがな、半角、全角カタカナを使用する事が可能です。

・文字列の指定と取得例

例 1：「と」を指定すると、「栃木県」「東京都」「富山県」「鳥取県」「徳島県」が取得されます。

例 2：「とう」を指定すると、「東京都」が取得されます。

例 3：「東京都ち」を指定すると、「東京都千代田区」「東京都中央区」「東京都調布市」が取得されます。

・各レベル先頭に「*(半角アスタリスク)」を指定する事でレベル以下全てが一致する住所が取得されます。

例 1：「*」を指定すると、47 都道府県全てが取得されます。

例 2：「東京都*」を指定すると、東京都の全ての区、市、郡名が取得されます。

例 3：「東京都中央区 *」を指定すると、東京都中央区の全ての町域名が取得されます。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetIncAddress.txt"))
{
    string address = "福井県*"; // 検索文字列
    string pref = null;         // 都道府県名
    string city1 = null;        // 市名 1
    string city2 = null;        // 市名 2
    string town = null;         // 町域名
    string townExt = null;      // 町域名以降
    string prefRuby = null;     // 都道府県名(カタカナ)
    string city1Ruby = null;    // 市名 1(カタカナ)
    string city2Ruby = null;    // 市名 2(カタカナ)
    string townRuby = null;     // 町域名(カタカナ)
    string townExtRuby = null;  // 町域名以降(カタカナ)
    int dataCount = 0;          // 件数
    int ret;
    // 検索文字列を基に検索を行い、該当する住所情報と件数を取得します。(1 回目)
    ret = advZip.GetIncAddress(true, address, out pref, out city1, out city2, out town, out townExt, out prefRuby, out city1Ruby, out city2Ruby, out townRuby, out townExtRuby, ref dataCount);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    while (ret != 0)
    {
        // 取得した住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(pref + "," + city1 + "," + city2 + "," + town + "," + townExt + "," + prefRuby + "," + city1Ruby + "," + city2Ruby + "," + townRuby + "," + townExtRuby);
        // 検索文字列を基に検索を行い、該当する住所情報を取得します。(2 回目以降)
        ret = advZip.GetIncAddress(false, address, out pref, out city1, out city2, out town, out townExt, out prefRuby, out city1Ruby, out city2Ruby, out townRuby, out townExtRuby);
    }
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetIncAddress.txt")
    Dim address As String = "福井県*"   ' 検索文字列
    Dim pref As String = Nothing        ' 都道府県名
    Dim city1 As String = Nothing       ' 市名 1
    Dim city2 As String = Nothing       ' 市名 2
    Dim town As String = Nothing        ' 町域名
    Dim townExt As String = Nothing     ' 町域名以降
    Dim prefRuby As String = Nothing    ' 都道府県名(カタカナ)
    Dim city1Ruby As String = Nothing   ' 市名 1(カタカナ)
    Dim city2Ruby As String = Nothing   ' 市名 2(カタカナ)
    Dim townRuby As String = Nothing    ' 町域名(カタカナ)
    Dim townExtRuby As String = Nothing ' 町域名以降(カタカナ)
    Dim dataCount As Integer = 0        ' 件数
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、該当する住所情報と件数を取得します。(1 回目)
    ret = advZip.GetIncAddress(True, address, pref, city1, city2, town, townExt, prefRuby, city1Ruby, city2Ruby, townRuby, townExtRuby, dataCount)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    While ret <> 0
        ' 取得した住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(pref & "," & city1 & "," & city2 & "," & town & "," & townExt & "," & prefRuby & "," & city1Ruby & "," & city2Ruby & "," & townRuby & "," & townExtRuby)
        ' 検索文字列を基に検索を行い、該当する住所情報を取得します。(2 回目以降)
        ret = advZip.GetIncAddress(False, address, pref, city1, city2, town, townExt, prefRuby, city1Ruby, city2Ruby, townRuby, townExtRuby)
    End While
End Using

参照

AdvZip クラス
GetIncAddress オーバーロード


GetJisCodeNow メソッド

[image]

Yubin7 Ver2.5
AdvZip..::..GetJisCodeNow メソッド
AdvZip クラス 使用例 参照
現在の JIS コードを取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public void GetJisCodeNow(
    out string jisCode
)
Visual Basic (宣言)
Public Sub GetJisCodeNow ( _
    <OutAttribute> ByRef jisCode As String _
)

パラメータ

jisCode
Type: System..::..String %
全国地方公共団体コードを格納する変数を指定します。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\Yubin7.txt"))
{
    string address = "福井県福井市成和1丁目2816番地"; // 検索文字列
    string zip7Code = null;                           // 7 桁郵便番号
    string jisCode = null;                            // 全国地方公共団体コード
    int ret;
    // 検索文字列を基に検索を行い、該当する 7 桁郵便番号を取得します。
    ret = advZip.Yubin7(address, out zip7Code);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    // 現在の全国地方公共団体コードを取得します。
    advZip.GetJisCodeNow(out jisCode);
    // 取得した 7 桁郵便番号と全国地方公共団体コードをテキストファイルに書き込みます。
    streamWriter.WriteLine(zip7Code + "," + jisCode);
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\Yubin7.txt")
    Dim address As String = "福井県福井市成和1丁目2816番地" ' 検索文字列
    Dim zip7Code As String = Nothing                        ' 7 桁郵便番号
    Dim jisCode As String = Nothing                         ' 全国地方公共団体コード
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、該当する 7 桁郵便番号を取得します。
    ret = advZip.Yubin7(address, zip7Code)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    ' 現在の全国地方公共団体コードを取得します。
    advZip.GetJisCodeNow(jisCode)
    ' 取得した 7 桁郵便番号と全国地方公共団体コードをテキストファイルに書き込みます。
    streamWriter.WriteLine(zip7Code & "," & jisCode)
End Using

参照

AdvZip クラス


GetMergeAddress メソッド

[image] [image]

Yubin7 Ver2.5
AdvZip..::..GetMergeAddress メソッド
AdvZip クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | GetMergeAddress(String, AdvZip..::..DifferenceInfo%) | 旧住所から市町村変更情報を取得します。
Public method | GetMergeAddress(String, AdvZip..::..DifferenceInfo%, Boolean, Boolean) | 旧住所から市町村変更情報を取得します。

参照

AdvZip クラス
AdvZip メンバ


GetMergeAddress メソッド (String, AdvZip.DifferenceInfo)

[image]

Yubin7 Ver2.5
AdvZip..::..GetMergeAddress メソッド (String, AdvZip..::..DifferenceInfo%)
AdvZip クラス 使用例 参照
旧住所から市町村変更情報を取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int GetMergeAddress(
    string address,
    out AdvZip..::..DifferenceInfo differenceInfo
)
Visual Basic (宣言)
Public Function GetMergeAddress ( _
    address As String, _
    <OutAttribute> ByRef differenceInfo As AdvZip..::..DifferenceInfo _
) As Integer

パラメータ

address
Type: System..::..String
検索の基となる、住所文字列を指定します。
differenceInfo
Type: AdvanceSoftware.Yubin7.AdvZip..::..AdvZip..::..DifferenceInfo %
市町村変更情報を保持する DifferenceInfo クラスを指定します。

戻り値

エラー時：0

正常時：0 以外(各ビットの値により、取得された住所の特徴を知ることができます。)

Bit0：正常時は必ず「1」になります。

Bit1：「京都の省略住所」の場合「1」になります。

Bit2：「以下に掲載がない場合」という表現の場合「1」になります。

Bit3：「都道府県名省略住所」の場合「1」になります。

Bit4：「市、または郡名の省略住所」の場合「1」になります。

Bit7：郵便番号辞書に存在する住所の場合「1」になります。

解説

第 3 引数、第 4 引数を省略した場合、使用辞書と検索条件は以下になります。

使用辞書：差分辞書と郵便番号辞書

検索条件：完全一致

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetMergeAddress.txt"))
{
    string address = "福井県丹生郡清水町小羽"; // 検索文字列
    AdvanceSoftware.Yubin7.AdvZip.AdvZip.DifferenceInfo differenceInfo = new AdvanceSoftware.Yubin7.AdvZip.AdvZip.DifferenceInfo();
    int ret;
    // 検索文字列を基に検索を行い、該当する市町村変更情報を取得します。
    ret = advZip.GetMergeAddress(address, out differenceInfo);
    // 郵便番号辞書に存在する住所
    if ((ret & 0x80) != 0)
    {
        MessageBox.Show("郵便番号辞書に存在する住所です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    // 更新履歴あり
    else if (ret != 0 && differenceInfo.mergeInfos != null)
    {
        for (int i = 0; i < differenceInfo.mergeInfos.Length; i++)
        {
            // 取得した市町村変更情報をテキストファイルに書き込みます。
            streamWriter.WriteLine(differenceInfo.mergeInfos[i].prefName + differenceInfo.mergeInfos[i].cityName + differenceInfo.mergeInfos[i].townName);
        }
    }
    // 更新履歴なし
    else
    {
        MessageBox.Show("入力した住所の更新履歴はありません。", "エラー", MessageBoxButtons.OK);
        return;
    }
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetMergeAddress.txt")
    Dim address As String = "福井県丹生郡清水町小羽" ' 検索文字列
    Dim differenceInfo As New AdvanceSoftware.Yubin7.AdvZip.AdvZip.DifferenceInfo()
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、該当する市町村変更情報を取得します。
    ret = advZip.GetMergeAddress(address, differenceInfo)
    ' 郵便番号辞書に存在する住所
    If ((ret And &H80) <> 0) Then
        MessageBox.Show("郵便番号辞書に存在する住所です。", "エラー", MessageBoxButtons.OK)
        Return
    ' 更新履歴あり
    ElseIf (ret <> 0 AndAlso (Not differenceInfo.mergeInfos Is Nothing)) Then
        For i As Integer = 0 To differenceInfo.mergeInfos.Length - 1
            ' 取得した市町村変更情報をテキストファイルに書き込みます。
            streamWriter.WriteLine(differenceInfo.mergeInfos(i).prefName & differenceInfo.mergeInfos(i).cityName & differenceInfo.mergeInfos(i).townName)
        Next
    ' 更新履歴なし
    Else
        MessageBox.Show("入力した住所の更新履歴はありません。", "エラー", MessageBoxButtons.OK)
        Return
    End If
End Using

参照

AdvZip クラス
GetMergeAddress オーバーロード


GetMergeAddress メソッド (String, AdvZip.DifferenceInfo, Boolean, Boolean)

[image]

Yubin7 Ver2.5
AdvZip..::..GetMergeAddress メソッド (String, AdvZip..::..DifferenceInfo%, Boolean, Boolean)
AdvZip クラス 使用例 参照
旧住所から市町村変更情報を取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int GetMergeAddress(
    string address,
    out AdvZip..::..DifferenceInfo differenceInfo,
    bool useDiffOnly,
    bool compareMode
)
Visual Basic (宣言)
Public Function GetMergeAddress ( _
    address As String, _
    <OutAttribute> ByRef differenceInfo As AdvZip..::..DifferenceInfo, _
    useDiffOnly As Boolean, _
    compareMode As Boolean _
) As Integer

パラメータ

address
Type: System..::..String
検索の基となる、住所文字列を指定します。
differenceInfo
Type: AdvanceSoftware.Yubin7.AdvZip..::..AdvZip..::..DifferenceInfo %
市町村変更情報を保持する DifferenceInfo クラスを指定します。
useDiffOnly
Type: System..::..Boolean

使用する辞書を指定します。

True：差分辞書のみを使用します。

False：差分辞書と郵便番号辞書を使用します。

compareMode
Type: System..::..Boolean

検索条件を指定します。

True：完全一致

False：部分一致

戻り値

エラー時：0

正常時：0 以外(各ビットの値により、取得された住所の特徴を知ることができます。)

Bit0：正常時は必ず「1」になります。

Bit1：「京都の省略住所」の場合「1」になります。

Bit2：「以下に掲載がない場合」という表現の場合「1」になります。

Bit3：「都道府県名省略住所」の場合「1」になります。

Bit4：「市、または郡名の省略住所」の場合「1」になります。

Bit7：郵便番号辞書に存在する住所(「以下に掲載がない場合」を除く)の場合「1」になります。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetMergeAddress.txt"))
{
    string address = "福井県丹生郡清水町小羽"; // 検索文字列
    AdvanceSoftware.Yubin7.AdvZip.AdvZip.DifferenceInfo differenceInfo = new AdvanceSoftware.Yubin7.AdvZip.AdvZip.DifferenceInfo();
    int ret;
    // 検索文字列を基に検索を行い、該当する市町村変更情報を取得します。
    // (使用辞書：差分辞書のみ、検索条件：部分一致)
    ret = advZip.GetMergeAddress(address, out differenceInfo, true, false);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("入力した住所の更新履歴はありません。", "エラー", MessageBoxButtons.OK);
        return;
    }
    for (int i = 0; i < differenceInfo.mergeInfos.Length; i++)
    {
        // 取得した市町村変更情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(differenceInfo.mergeInfos[i].prefName + differenceInfo.mergeInfos[i].cityName + differenceInfo.mergeInfos[i].townName);
    }
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetMergeAddress.txt")
    Dim address As String = "福井県丹生郡清水町小羽" ' 検索文字列
    Dim differenceInfo As New AdvanceSoftware.Yubin7.AdvZip.AdvZip.DifferenceInfo()
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、該当する市町村変更情報を取得します。
    ret = advZip.GetMergeAddress(address, differenceInfo, True, False)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("入力した住所の更新履歴はありません。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    For i As Integer = 0 To differenceInfo.mergeInfos.Length - 1
        ' 取得した市町村変更情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(differenceInfo.mergeInfos(i).prefName & differenceInfo.mergeInfos(i).cityName & differenceInfo.mergeInfos(i).townName)
    Next
End Using

参照

AdvZip クラス
GetMergeAddress オーバーロード


GetZipAddress メソッド

[image] [image]

Yubin7 Ver2.5
AdvZip..::..GetZipAddress メソッド
AdvZip クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | GetZipAddress(Boolean, String, String%, String%, String%, String%, String%, String%, String%) | 郵便番号から住所情報を取得します。
Public method | GetZipAddress(Boolean, String, String%, String%, String%, String%, String%, String%, String%, Int32%) | 郵便番号から住所情報と件数を取得します。
Public method | GetZipAddress(Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%) | 郵便番号から住所情報を取得します。
Public method | GetZipAddress(Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, Int32%) | 郵便番号から住所情報と件数を取得します。

参照

AdvZip クラス
AdvZip メンバ


GetZipAddress メソッド (Boolean, String, String, String, String, String, String, String, String)

[image]

Yubin7 Ver2.5
AdvZip..::..GetZipAddress メソッド (Boolean, String, String%, String%, String%, String%, String%, String%, String%)
AdvZip クラス 使用例 参照
郵便番号から住所情報を取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int GetZipAddress(
    bool findFirst,
    string zipCode,
    out string zip5Code,
    out string zip7Code,
    out string pref,
    out string city1,
    out string city2,
    out string town,
    out string townExt
)
Visual Basic (宣言)
Public Function GetZipAddress ( _
    findFirst As Boolean, _
    zipCode As String, _
    <OutAttribute> ByRef zip5Code As String, _
    <OutAttribute> ByRef zip7Code As String, _
    <OutAttribute> ByRef pref As String, _
    <OutAttribute> ByRef city1 As String, _
    <OutAttribute> ByRef city2 As String, _
    <OutAttribute> ByRef town As String, _
    <OutAttribute> ByRef townExt As String _
) As Integer

パラメータ

findFirst
Type: System..::..Boolean
初回取得の場合 True、初回以降、連続して該当する住所の取得を行う場合 False を指定します。
zipCode
Type: System..::..String
検索の基となる、3 桁 / 5 桁 / 7 桁の郵便番号を指定します。
zip5Code
Type: System..::..String %
5 桁郵便番号を格納する変数を指定します。
zip7Code
Type: System..::..String %
7 桁郵便番号を格納する変数を指定します。
pref
Type: System..::..String %
都道府県名を格納する変数を指定します。
city1
Type: System..::..String %
市名を格納する変数を指定します。
city2
Type: System..::..String %
"city1" に続く市町村名を格納する変数を指定します。
town
Type: System..::..String %
町域名を格納する変数を指定します。
townExt
Type: System..::..String %
町域名以降を格納する変数を指定します。

戻り値

エラー時：0

正常時：0 以外(各ビットの値により、取得された住所の特徴を知ることができます。)

Bit0：正常時は必ず「1」になります。

Bit2：「以下に掲載がない場合」に該当する郵便番号の場合「1」になります。

Bit5：「次のビルを除く」に該当する郵便番号の場合「1」になります。

Bit6：「の次に番地がくる場合」に該当する郵便番号の場合「1」になります。

解説

与えられた引数が 3 桁郵便番号の場合・・・3 桁郵便番号－00～99 として一致する 5 桁郵便番号を取得します。

与えられた引数が 5 桁郵便番号の場合・・・5 桁郵便番号全てが一致するデータを取得します。

与えられた引数が 7 桁郵便番号の場合・・・7 桁郵便番号全てが一致するデータを取得します。

なお、通常 3 桁郵便番号を基に設定した場合は旧 5 桁郵便番号で一致するものを取得しますが、このメソッドを呼び出す前に SetZip7OnlyMode メソッドを呼び出すことで、7 桁郵便番号を取得するモードに設定できます。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetZipAddress.txt"))
{
    string zipCode = "918"; // 検索文字列
    string zip5Code = null; // 5 桁郵便番号
    string zip7Code = null; // 7 桁郵便番号
    string pref = null;     // 都道府県名
    string city1 = null;    // 市名 1
    string city2 = null;    // 市名 2
    string town = null;     // 町域名
    string townExt = null;  // 町域名以降
    int ret;
    // 検索文字列を基に検索を行い、該当する住所情報を取得します。(1 回目)
    ret = advZip.GetZipAddress(true, zipCode, out zip5Code, out zip7Code, out pref, out city1, out city2, out town, out townExt);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("郵便番号が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    while (ret != 0)
    {
        // 取得した住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code + "," + zip7Code + "," + pref + "," + city1 + "," + city2 + "," + town + "," + townExt);
        // 検索文字列を基に検索を行い、該当する住所情報を取得します。(2 回目以降)
        ret = advZip.GetZipAddress(false, zipCode, out zip5Code, out zip7Code, out pref, out city1, out city2, out town, out townExt);
    }
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetZipAddress.txt")
    Dim zipCode As String = "918"    ' 検索文字列
    Dim zip5Code As String = Nothing ' 5 桁郵便番号
    Dim zip7Code As String = Nothing ' 7 桁郵便番号
    Dim pref As String = Nothing     ' 都道府県名
    Dim city1 As String = Nothing    ' 市名 1
    Dim city2 As String = Nothing    ' 市名 2
    Dim town As String = Nothing     ' 町域名
    Dim townExt As String = Nothing  ' 町域名以降
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、該当する住所情報を取得します。(1 回目)
    ret = advZip.GetZipAddress(True, zipCode, zip5Code, zip7Code, pref, city1, city2, town, townExt)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("郵便番号が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    While ret <> 0
        ' 取得した住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code & "," & zip7Code & "," & pref & "," & city1 & "," & city2 & "," & town & "," & townExt)
        ' 検索文字列を基に検索を行い、該当する住所情報を取得します。(2 回目以降)
        ret = advZip.GetZipAddress(False, zipCode, zip5Code, zip7Code, pref, city1, city2, town, townExt)
    End While
End Using

参照

AdvZip クラス
GetZipAddress オーバーロード


GetZipAddress メソッド (Boolean, String, String, String, String, String, String, String, String, Int32)

[image]

Yubin7 Ver2.5
AdvZip..::..GetZipAddress メソッド (Boolean, String, String%, String%, String%, String%, String%, String%, String%, Int32%)
AdvZip クラス 使用例 参照
郵便番号から住所情報と件数を取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int GetZipAddress(
    bool findFirst,
    string zipCode,
    out string zip5Code,
    out string zip7Code,
    out string pref,
    out string city1,
    out string city2,
    out string town,
    out string townExt,
    ref int dataCount
)
Visual Basic (宣言)
Public Function GetZipAddress ( _
    findFirst As Boolean, _
    zipCode As String, _
    <OutAttribute> ByRef zip5Code As String, _
    <OutAttribute> ByRef zip7Code As String, _
    <OutAttribute> ByRef pref As String, _
    <OutAttribute> ByRef city1 As String, _
    <OutAttribute> ByRef city2 As String, _
    <OutAttribute> ByRef town As String, _
    <OutAttribute> ByRef townExt As String, _
    ByRef dataCount As Integer _
) As Integer

パラメータ

findFirst
Type: System..::..Boolean
初回取得の場合 True、初回以降、連続して該当する住所の取得を行う場合 False を指定します。
zipCode
Type: System..::..String
検索の基となる、3 桁 / 5 桁 / 7 桁の郵便番号を指定します。
zip5Code
Type: System..::..String %
5 桁郵便番号を格納する変数を指定します。
zip7Code
Type: System..::..String %
7 桁郵便番号を格納する変数を指定します。
pref
Type: System..::..String %
都道府県名を格納する変数を指定します。
city1
Type: System..::..String %
市名を格納する変数を指定します。
city2
Type: System..::..String %
"city1" に続く市町村名を格納する変数を指定します。
town
Type: System..::..String %
町域名を格納する変数を指定します。
townExt
Type: System..::..String %
町域名以降を格納する変数を指定します。
dataCount
Type: System..::..Int32 %
件数を格納する変数を指定します。

戻り値

エラー時：0

正常時：0 以外(各ビットの値により、取得された住所の特徴を知ることができます。)

Bit0：正常時は必ず「1」になります。

Bit2：「以下に掲載がない場合」に該当する郵便番号の場合「1」になります。

Bit5：「次のビルを除く」に該当する郵便番号の場合「1」になります。

Bit6：「の次に番地がくる場合」に該当する郵便番号の場合「1」になります。

解説

与えられた引数が 3 桁郵便番号の場合・・・3 桁郵便番号－00～99 として一致する 5 桁郵便番号を取得します。

与えられた引数が 5 桁郵便番号の場合・・・5 桁郵便番号全てが一致するデータを取得します。

与えられた引数が 7 桁郵便番号の場合・・・7 桁郵便番号全てが一致するデータを取得します。

なお、通常 3 桁郵便番号を基に設定した場合は旧 5 桁郵便番号で一致するものを取得しますが、このメソッドを呼び出す前に SetZip7OnlyMode メソッドを呼び出すことで、7 桁郵便番号を取得するモードに設定できます。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetZipAddress.txt"))
{
    string zipCode = "918"; // 検索文字列
    string zip5Code = null; // 5 桁郵便番号
    string zip7Code = null; // 7 桁郵便番号
    string pref = null;     // 都道府県名
    string city1 = null;    // 市名 1
    string city2 = null;    // 市名 2
    string town = null;     // 町域名
    string townExt = null;  // 町域名以降
    int dataCount = 0;      // 件数
    int ret;
    // 検索文字列を基に検索を行い、該当する住所情報と件数を取得します。(1 回目)
    ret = advZip.GetZipAddress(true, zipCode, out zip5Code, out zip7Code, out pref, out city1, out city2, out town, out townExt, ref dataCount);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("郵便番号が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    while (ret != 0)
    {
        // 取得した住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code + "," + zip7Code + "," + pref + "," + city1 + "," + city2 + "," + town + "," + townExt);
        // 検索文字列を基に検索を行い、該当する住所情報を取得します。(2 回目以降)
        ret = advZip.GetZipAddress(false, zipCode, out zip5Code, out zip7Code, out pref, out city1, out city2, out town, out townExt);
    }
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetZipAddress.txt")
    Dim zipCode As String = "918"    ' 検索文字列
    Dim zip5Code As String = Nothing ' 5 桁郵便番号
    Dim zip7Code As String = Nothing ' 7 桁郵便番号
    Dim pref As String = Nothing     ' 都道府県名
    Dim city1 As String = Nothing    ' 市名 1
    Dim city2 As String = Nothing    ' 市名 2
    Dim town As String = Nothing     ' 町域名
    Dim townExt As String = Nothing  ' 町域名以降
    Dim dataCount As Integer = 0     ' 件数
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、該当する住所情報と件数を取得します。(1 回目)
    ret = advZip.GetZipAddress(True, zipCode, zip5Code, zip7Code, pref, city1, city2, town, townExt, dataCount)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("郵便番号が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    While ret <> 0
        ' 取得した住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code & "," & zip7Code & "," & pref & "," & city1 & "," & city2 & "," & town & "," & townExt)
        ' 検索文字列を基に検索を行い、該当する住所情報を取得します。(2 回目以降)
        ret = advZip.GetZipAddress(False, zipCode, zip5Code, zip7Code, pref, city1, city2, town, townExt)
    End While
End Using

参照

AdvZip クラス
GetZipAddress オーバーロード


GetZipAddress メソッド (Boolean, String, String, String, String, String, String, String, String, String, String, String, String, String)

[image]

Yubin7 Ver2.5
AdvZip..::..GetZipAddress メソッド (Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%)
AdvZip クラス 使用例 参照
郵便番号から住所情報を取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int GetZipAddress(
    bool findFirst,
    string zipCode,
    out string zip5Code,
    out string zip7Code,
    out string pref,
    out string city1,
    out string city2,
    out string town,
    out string townExt,
    out string prefRuby,
    out string city1Ruby,
    out string city2Ruby,
    out string townRuby,
    out string townExtRuby
)
Visual Basic (宣言)
Public Function GetZipAddress ( _
    findFirst As Boolean, _
    zipCode As String, _
    <OutAttribute> ByRef zip5Code As String, _
    <OutAttribute> ByRef zip7Code As String, _
    <OutAttribute> ByRef pref As String, _
    <OutAttribute> ByRef city1 As String, _
    <OutAttribute> ByRef city2 As String, _
    <OutAttribute> ByRef town As String, _
    <OutAttribute> ByRef townExt As String, _
    <OutAttribute> ByRef prefRuby As String, _
    <OutAttribute> ByRef city1Ruby As String, _
    <OutAttribute> ByRef city2Ruby As String, _
    <OutAttribute> ByRef townRuby As String, _
    <OutAttribute> ByRef townExtRuby As String _
) As Integer

パラメータ

findFirst
Type: System..::..Boolean
初回取得の場合 True、初回以降、連続して該当する住所の取得を行う場合 False を指定します。
zipCode
Type: System..::..String
検索の基となる、3 桁 / 5 桁 / 7 桁の郵便番号を指定します。
zip5Code
Type: System..::..String %
5 桁郵便番号を格納する変数を指定します。
zip7Code
Type: System..::..String %
7 桁郵便番号を格納する変数を指定します。
pref
Type: System..::..String %
都道府県名を格納する変数を指定します。
city1
Type: System..::..String %
市名を格納する変数を指定します。
city2
Type: System..::..String %
"city1" に続く市町村名を格納する変数を指定します。
town
Type: System..::..String %
町域名を格納する変数を指定します。
townExt
Type: System..::..String %
町域名以降を格納する変数を指定します。
prefRuby
Type: System..::..String %
都道府県名(カタカナ)を格納する変数を指定します。
city1Ruby
Type: System..::..String %
市名(カタカナ)を格納する変数を指定します。
city2Ruby
Type: System..::..String %
"city1Ruby" に続く市町村名(カタカナ)を格納する変数を指定します。
townRuby
Type: System..::..String %
町域名(カタカナ)を格納する変数を指定します。
townExtRuby
Type: System..::..String %
町域名以降(カタカナ)を格納する変数を指定します。

戻り値

エラー時：0

正常時：0 以外(各ビットの値により、取得された住所の特徴を知ることができます。)

Bit0：正常時は必ず「1」になります。

Bit2：「以下に掲載がない場合」に該当する郵便番号の場合「1」になります。

Bit5：「次のビルを除く」に該当する郵便番号の場合「1」になります。

Bit6：「の次に番地がくる場合」に該当する郵便番号の場合「1」になります。

解説

与えられた引数が 3 桁郵便番号の場合・・・3 桁郵便番号－00～99 として一致する 5 桁郵便番号を取得します。

与えられた引数が 5 桁郵便番号の場合・・・5 桁郵便番号全てが一致するデータを取得します。

与えられた引数が 7 桁郵便番号の場合・・・7 桁郵便番号全てが一致するデータを取得します。

なお、通常 3 桁郵便番号を基に設定した場合は旧 5 桁郵便番号で一致するものを取得しますが、このメソッドを呼び出す前に SetZip7OnlyMode メソッドを呼び出すことで、7 桁郵便番号を取得するモードに設定できます。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetZipAddress.txt"))
{
    string zipCode = "918";     // 検索文字列
    string zip5Code = null;     // 5 桁郵便番号
    string zip7Code = null;     // 7 桁郵便番号
    string pref = null;         // 都道府県名
    string city1 = null;        // 市名 1
    string city2 = null;        // 市名 2
    string town = null;         // 町域名
    string townExt = null;      // 町域名以降
    string prefRuby = null;     // 都道府県名(カタカナ)
    string city1Ruby = null;    // 市名 1(カタカナ)
    string city2Ruby = null;    // 市名 2(カタカナ)
    string townRuby = null;     // 町域名(カタカナ)
    string townExtRuby = null;  // 町域名以降(カタカナ)
    int ret;
    // 検索文字列を基に検索を行い、該当する住所情報を取得します。(1 回目)
    ret = advZip.GetZipAddress(true, zipCode, out zip5Code, out zip7Code, out pref, out city1, out city2, out town, out townExt, out prefRuby, out city1Ruby, out city2Ruby, out townRuby, out townExtRuby);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("郵便番号が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    while (ret != 0)
    {
        // 取得した住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code + "," + zip7Code + "," + pref + "," + city1 + "," + city2 + "," + town + "," + townExt + "," + prefRuby + "," + city1Ruby + "," + city2Ruby + "," + townRuby + "," + townExtRuby);
        // 検索文字列を基に検索を行い、該当する住所情報を取得します。(2 回目以降)
        ret = advZip.GetZipAddress(false, zipCode, out zip5Code, out zip7Code, out pref, out city1, out city2, out town, out townExt, out prefRuby, out city1Ruby, out city2Ruby, out townRuby, out townExtRuby);
    }
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetZipAddress.txt")
    Dim zipCode As String = "918"       ' 検索文字列
    Dim zip5Code As String = Nothing    ' 5 桁郵便番号
    Dim zip7Code As String = Nothing    ' 7 桁郵便番号
    Dim pref As String = Nothing        ' 都道府県名
    Dim city1 As String = Nothing       ' 市名 1
    Dim city2 As String = Nothing       ' 市名 2
    Dim town As String = Nothing        ' 町域名
    Dim townExt As String = Nothing     ' 町域名以降
    Dim prefRuby As String = Nothing    ' 都道府県名(カタカナ)
    Dim city1Ruby As String = Nothing   ' 市名 1(カタカナ)
    Dim city2Ruby As String = Nothing   ' 市名 2(カタカナ)
    Dim townRuby As String = Nothing    ' 町域名(カタカナ)
    Dim townExtRuby As String = Nothing ' 町域名以降(カタカナ)
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、該当する住所情報を取得します。(1 回目)
    ret = advZip.GetZipAddress(True, zipCode, zip5Code, zip7Code, pref, city1, city2, town, townExt, prefRuby, city1Ruby, city2Ruby, townRuby, townExtRuby)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("郵便番号が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    While ret <> 0
        ' 取得した住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code & "," & zip7Code & "," & pref & "," & city1 & "," & city2 & "," & town & "," & townExt & "," & prefRuby & "," & city1Ruby & "," & city2Ruby & "," & townRuby & "," & townExtRuby)
        ' 検索文字列を基に検索を行い、該当する住所情報を取得します。(2 回目以降)
        ret = advZip.GetZipAddress(False, zipCode, zip5Code, zip7Code, pref, city1, city2, town, townExt, prefRuby, city1Ruby, city2Ruby, townRuby, townExtRuby)
    End While
End Using

参照

AdvZip クラス
GetZipAddress オーバーロード


GetZipAddress メソッド (Boolean, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32)

[image]

Yubin7 Ver2.5
AdvZip..::..GetZipAddress メソッド (Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%, Int32%)
AdvZip クラス 使用例 参照
郵便番号から住所情報と件数を取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int GetZipAddress(
    bool findFirst,
    string zipCode,
    out string zip5Code,
    out string zip7Code,
    out string pref,
    out string city1,
    out string city2,
    out string town,
    out string townExt,
    out string prefRuby,
    out string city1Ruby,
    out string city2Ruby,
    out string townRuby,
    out string townExtRuby,
    ref int dataCount
)
Visual Basic (宣言)
Public Function GetZipAddress ( _
    findFirst As Boolean, _
    zipCode As String, _
    <OutAttribute> ByRef zip5Code As String, _
    <OutAttribute> ByRef zip7Code As String, _
    <OutAttribute> ByRef pref As String, _
    <OutAttribute> ByRef city1 As String, _
    <OutAttribute> ByRef city2 As String, _
    <OutAttribute> ByRef town As String, _
    <OutAttribute> ByRef townExt As String, _
    <OutAttribute> ByRef prefRuby As String, _
    <OutAttribute> ByRef city1Ruby As String, _
    <OutAttribute> ByRef city2Ruby As String, _
    <OutAttribute> ByRef townRuby As String, _
    <OutAttribute> ByRef townExtRuby As String, _
    ByRef dataCount As Integer _
) As Integer

パラメータ

findFirst
Type: System..::..Boolean
初回取得の場合 True、初回以降、連続して該当する住所の取得を行う場合 False を指定します。
zipCode
Type: System..::..String
検索の基となる、3 桁 / 5 桁 / 7 桁の郵便番号を指定します。
zip5Code
Type: System..::..String %
5 桁郵便番号を格納する変数を指定します。
zip7Code
Type: System..::..String %
7 桁郵便番号を格納する変数を指定します。
pref
Type: System..::..String %
都道府県名を格納する変数を指定します。
city1
Type: System..::..String %
市名を格納する変数を指定します。
city2
Type: System..::..String %
"city1" に続く市町村名を格納する変数を指定します。
town
Type: System..::..String %
町域名を格納する変数を指定します。
townExt
Type: System..::..String %
町域名以降を格納する変数を指定します。
prefRuby
Type: System..::..String %
都道府県名(カタカナ)を格納する変数を指定します。
city1Ruby
Type: System..::..String %
市名(カタカナ)を格納する変数を指定します。
city2Ruby
Type: System..::..String %
"city1Ruby" に続く市町村名(カタカナ)を格納する変数を指定します。
townRuby
Type: System..::..String %
町域名(カタカナ)を格納する変数を指定します。
townExtRuby
Type: System..::..String %
町域名以降(カタカナ)を格納する変数を指定します。
dataCount
Type: System..::..Int32 %
件数を格納する変数を指定します。

戻り値

エラー時：0

正常時：0 以外(各ビットの値により、取得された住所の特徴を知ることができます。)

Bit0：正常時は必ず「1」になります。

Bit2：「以下に掲載がない場合」に該当する郵便番号の場合「1」になります。

Bit5：「次のビルを除く」に該当する郵便番号の場合「1」になります。

Bit6：「の次に番地がくる場合」に該当する郵便番号の場合「1」になります。

解説

与えられた引数が 3 桁郵便番号の場合・・・3 桁郵便番号－00～99 として一致する 5 桁郵便番号を取得します。

与えられた引数が 5 桁郵便番号の場合・・・5 桁郵便番号全てが一致するデータを取得します。

与えられた引数が 7 桁郵便番号の場合・・・7 桁郵便番号全てが一致するデータを取得します。

なお、通常 3 桁郵便番号を基に設定した場合は旧 5 桁郵便番号で一致するものを取得しますが、このメソッドを呼び出す前に SetZip7OnlyMode メソッドを呼び出すことで、7 桁郵便番号を取得するモードに設定できます。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetZipAddress.txt"))
{
    string zipCode = "918";     // 検索文字列
    string zip5Code = null;     // 5 桁郵便番号
    string zip7Code = null;     // 7 桁郵便番号
    string pref = null;         // 都道府県名
    string city1 = null;        // 市名 1
    string city2 = null;        // 市名 2
    string town = null;         // 町域名
    string townExt = null;      // 町域名以降
    string prefRuby = null;     // 都道府県名(カタカナ)
    string city1Ruby = null;    // 市名 1(カタカナ)
    string city2Ruby = null;    // 市名 2(カタカナ)
    string townRuby = null;     // 町域名(カタカナ)
    string townExtRuby = null;  // 町域名以降(カタカナ)
    int dataCount = 0;          // 件数
    int ret;
    // 検索文字列を基に検索を行い、該当する住所情報と件数を取得します。(1 回目)
    ret = advZip.GetZipAddress(true, zipCode, out zip5Code, out zip7Code, out pref, out city1, out city2, out town, out townExt, out prefRuby, out city1Ruby, out city2Ruby, out townRuby, out townExtRuby, ref dataCount);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("郵便番号が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    while (ret != 0)
    {
        // 取得した住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code + "," + zip7Code + "," + pref + "," + city1 + "," + city2 + "," + town + "," + townExt + "," + prefRuby + "," + city1Ruby + "," + city2Ruby + "," + townRuby + "," + townExtRuby);
        // 検索文字列を基に検索を行い、該当する住所情報を取得します。(2 回目以降)
        ret = advZip.GetZipAddress(false, zipCode, out zip5Code, out zip7Code, out pref, out city1, out city2, out town, out townExt, out prefRuby, out city1Ruby, out city2Ruby, out townRuby, out townExtRuby);
    }
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetZipAddress.txt")
    Dim zipCode As String = "918"       ' 検索文字列
    Dim zip5Code As String = Nothing    ' 5 桁郵便番号
    Dim zip7Code As String = Nothing    ' 7 桁郵便番号
    Dim pref As String = Nothing        ' 都道府県名
    Dim city1 As String = Nothing       ' 市名 1
    Dim city2 As String = Nothing       ' 市名 2
    Dim town As String = Nothing        ' 町域名
    Dim townExt As String = Nothing     ' 町域名以降
    Dim prefRuby As String = Nothing    ' 都道府県名(カタカナ)
    Dim city1Ruby As String = Nothing   ' 市名 1(カタカナ)
    Dim city2Ruby As String = Nothing   ' 市名 2(カタカナ)
    Dim townRuby As String = Nothing    ' 町域名(カタカナ)
    Dim townExtRuby As String = Nothing ' 町域名以降(カタカナ)
    Dim dataCount As Integer = 0        ' 件数
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、該当する住所情報と件数を取得します。(1 回目)
    ret = advZip.GetZipAddress(True, zipCode, zip5Code, zip7Code, pref, city1, city2, town, townExt, prefRuby, city1Ruby, city2Ruby, townRuby, townExtRuby, dataCount)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("郵便番号が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    While ret <> 0
        ' 取得した住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code & "," & zip7Code & "," & pref & "," & city1 & "," & city2 & "," & town & "," & townExt & "," & prefRuby & "," & city1Ruby & "," & city2Ruby & "," & townRuby & "," & townExtRuby)
        ' 検索文字列を基に検索を行い、該当する住所情報を取得します。(2 回目以降)
        ret = advZip.GetZipAddress(False, zipCode, zip5Code, zip7Code, pref, city1, city2, town, townExt, prefRuby, city1Ruby, city2Ruby, townRuby, townExtRuby)
    End While
End Using

参照

AdvZip クラス
GetZipAddress オーバーロード


GetZipAddressCmp メソッド

[image] [image]

Yubin7 Ver2.5
AdvZip..::..GetZipAddressCmp メソッド
AdvZip クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | GetZipAddressCmp(Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%) | 郵便番号から大口事業所住所情報を取得します。
Public method | GetZipAddressCmp(Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%, Int32%) | 郵便番号から大口事業所住所情報と件数を取得します。

参照

AdvZip クラス
AdvZip メンバ


GetZipAddressCmp メソッド (Boolean, String, String, String, String, String, String, String, String, String)

[image]

Yubin7 Ver2.5
AdvZip..::..GetZipAddressCmp メソッド (Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%)
AdvZip クラス 使用例 参照
郵便番号から大口事業所住所情報を取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int GetZipAddressCmp(
    bool findFirst,
    string zipCode,
    out string zip5Code,
    out string zip7Code,
    out string pref,
    out string city1,
    out string city2,
    out string town,
    out string townExt,
    out string companyName
)
Visual Basic (宣言)
Public Function GetZipAddressCmp ( _
    findFirst As Boolean, _
    zipCode As String, _
    <OutAttribute> ByRef zip5Code As String, _
    <OutAttribute> ByRef zip7Code As String, _
    <OutAttribute> ByRef pref As String, _
    <OutAttribute> ByRef city1 As String, _
    <OutAttribute> ByRef city2 As String, _
    <OutAttribute> ByRef town As String, _
    <OutAttribute> ByRef townExt As String, _
    <OutAttribute> ByRef companyName As String _
) As Integer

パラメータ

findFirst
Type: System..::..Boolean
初回取得の場合 True、初回以降、連続して該当する住所の取得を行う場合 False を指定します。
zipCode
Type: System..::..String
検索の基となる、大口事業所個別番号を指定します。
zip5Code
Type: System..::..String %
5 桁郵便番号を格納する変数を指定します。
zip7Code
Type: System..::..String %
大口事業所個別番号を格納する変数を指定します。
pref
Type: System..::..String %
都道府県名を格納する変数を指定します。
city1
Type: System..::..String %
市名を格納する変数を指定します。
city2
Type: System..::..String %
"city1" に続く市町村名を格納する変数を指定します。
town
Type: System..::..String %
町域名を格納する変数を指定します。
townExt
Type: System..::..String %
町域名以降を格納する変数を指定します。
companyName
Type: System..::..String %
大口事業所名を格納する変数を指定します。

戻り値

該当住所なし：0

該当住所あり：0 以外

解説

通常 3 桁郵便番号を基に設定した場合は旧 5 桁郵便番号で一致するものを取得しますが、このメソッドを呼び出す前に SetZip7OnlyMode メソッドを呼び出すことで、7 桁郵便番号を取得するモードに設定できます。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetZipAddressCmp.txt"))
{
    string zipCode = "918";    // 検索文字列
    string zip5Code = null;    // 5 桁郵便番号
    string zip7Code = null;    // 7 桁郵便番号
    string pref = null;        // 都道府県名
    string city1 = null;       // 市名 1
    string city2 = null;       // 市名 2
    string town = null;        // 町域名
    string townExt = null;     // 町域名以降
    string companyName = null; // 大口事業所名
    int ret;
    // 検索文字列を基に検索を行い、該当する大口事業所住所情報を取得します。(1 回目)
    ret = advZip.GetZipAddressCmp(true, zipCode, out zip5Code, out zip7Code, out pref, out city1, out city2, out town, out townExt, out companyName);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("郵便番号が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    while (ret != 0)
    {
        // 取得した大口事業所住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code + "," + zip7Code + "," + pref + "," + city1 + "," + city2 + "," + town + "," + townExt + "," + companyName);
        // 検索文字列を基に検索を行い、該当する大口事業所住所情報を取得します。(2 回目以降)
        ret = advZip.GetZipAddressCmp(false, zipCode, out zip5Code, out zip7Code, out pref, out city1, out city2, out town, out townExt, out companyName);
    }
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetZipAddressCmp.txt")
    Dim zipCode As String = "918"       ' 検索文字列
    Dim zip5Code As String = Nothing    ' 5 桁郵便番号
    Dim zip7Code As String = Nothing    ' 7 桁郵便番号
    Dim pref As String = Nothing        ' 都道府県名
    Dim city1 As String = Nothing       ' 市名 1
    Dim city2 As String = Nothing       ' 市名 2
    Dim town As String = Nothing        ' 町域名
    Dim townExt As String = Nothing     ' 町域名以降
    Dim companyName As String = Nothing ' 大口事業所名
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、該当する大口事業所住所情報を取得します。(1 回目)
    ret = advZip.GetZipAddressCmp(True, zipCode, zip5Code, zip7Code, pref, city1, city2, town, townExt, companyName)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("郵便番号が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    While ret <> 0
        ' 取得した大口事業所住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code & "," & zip7Code & "," & pref & "," & city1 & "," & city2 & "," & town & "," & townExt & "," & companyName)
        ' 検索文字列を基に検索を行い、該当する大口事業所住所情報を取得します。(2 回目以降)
        ret = advZip.GetZipAddressCmp(False, zipCode, zip5Code, zip7Code, pref, city1, city2, town, townExt, companyName)
    End While
End Using

参照

AdvZip クラス
GetZipAddressCmp オーバーロード


GetZipAddressCmp メソッド (Boolean, String, String, String, String, String, String, String, String, String, Int32)

[image]

Yubin7 Ver2.5
AdvZip..::..GetZipAddressCmp メソッド (Boolean, String, String%, String%, String%, String%, String%, String%, String%, String%, Int32%)
AdvZip クラス 使用例 参照
郵便番号から大口事業所住所情報と件数を取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int GetZipAddressCmp(
    bool findFirst,
    string zipCode,
    out string zip5Code,
    out string zip7Code,
    out string pref,
    out string city1,
    out string city2,
    out string town,
    out string townExt,
    out string companyName,
    ref int dataCount
)
Visual Basic (宣言)
Public Function GetZipAddressCmp ( _
    findFirst As Boolean, _
    zipCode As String, _
    <OutAttribute> ByRef zip5Code As String, _
    <OutAttribute> ByRef zip7Code As String, _
    <OutAttribute> ByRef pref As String, _
    <OutAttribute> ByRef city1 As String, _
    <OutAttribute> ByRef city2 As String, _
    <OutAttribute> ByRef town As String, _
    <OutAttribute> ByRef townExt As String, _
    <OutAttribute> ByRef companyName As String, _
    ByRef dataCount As Integer _
) As Integer

パラメータ

findFirst
Type: System..::..Boolean
初回取得の場合 True、初回以降、連続して該当する住所の取得を行う場合 False を指定します。
zipCode
Type: System..::..String
検索の基となる、大口事業所個別番号を指定します。
zip5Code
Type: System..::..String %
5 桁郵便番号を格納する変数を指定します。
zip7Code
Type: System..::..String %
大口事業所個別番号を格納する変数を指定します。
pref
Type: System..::..String %
都道府県名を格納する変数を指定します。
city1
Type: System..::..String %
市名を格納する変数を指定します。
city2
Type: System..::..String %
"city1" に続く市町村名を格納する変数を指定します。
town
Type: System..::..String %
町域名を格納する変数を指定します。
townExt
Type: System..::..String %
町域名以降を格納する変数を指定します。
companyName
Type: System..::..String %
大口事業所名を格納する変数を指定します。
dataCount
Type: System..::..Int32 %
件数を格納する変数を指定します。

戻り値

該当住所なし：0

該当住所あり：0 以外

解説

通常 3 桁郵便番号を基に設定した場合は旧 5 桁郵便番号で一致するものを取得しますが、このメソッドを呼び出す前に SetZip7OnlyMode メソッドを呼び出すことで、7 桁郵便番号を取得するモードに設定できます。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetZipAddressCmp.txt"))
{
    string zipCode = "918";    // 検索文字列
    string zip5Code = null;    // 5 桁郵便番号
    string zip7Code = null;    // 7 桁郵便番号
    string pref = null;        // 都道府県名
    string city1 = null;       // 市名 1
    string city2 = null;       // 市名 2
    string town = null;        // 町域名
    string townExt = null;     // 町域名以降
    string companyName = null; // 大口事業所名
    int dataCount = 0;         // 件数
    int ret;
    // 検索文字列を基に検索を行い、該当する大口事業所住所情報と件数を取得します。(1 回目)
    ret = advZip.GetZipAddressCmp(true, zipCode, out zip5Code, out zip7Code, out pref, out city1, out city2, out town, out townExt, out companyName, ref dataCount);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("郵便番号が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    while (ret != 0)
    {
        // 取得した大口事業所住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code + "," + zip7Code + "," + pref + "," + city1 + "," + city2 + "," + town + "," + townExt + "," + companyName);
        // 検索文字列を基に検索を行い、該当する大口事業所住所情報を取得します。(2 回目以降)
        ret = advZip.GetZipAddressCmp(false, zipCode, out zip5Code, out zip7Code, out pref, out city1, out city2, out town, out townExt, out companyName);
    }
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetZipAddressCmp.txt")
    Dim zipCode As String = "918"       ' 検索文字列
    Dim zip5Code As String = Nothing    ' 5 桁郵便番号
    Dim zip7Code As String = Nothing    ' 7 桁郵便番号
    Dim pref As String = Nothing        ' 都道府県名
    Dim city1 As String = Nothing       ' 市名 1
    Dim city2 As String = Nothing       ' 市名 2
    Dim town As String = Nothing        ' 町域名
    Dim townExt As String = Nothing     ' 町域名以降
    Dim companyName As String = Nothing ' 大口事業所名
    Dim dataCount As Integer = 0        ' 件数
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、該当する大口事業所住所情報と件数を取得します。(1 回目)
    ret = advZip.GetZipAddressCmp(True, zipCode, zip5Code, zip7Code, pref, city1, city2, town, townExt, companyName, dataCount)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("郵便番号が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    While ret <> 0
        ' 取得した大口事業所住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code & "," & zip7Code & "," & pref & "," & city1 & "," & city2 & "," & town & "," & townExt & "," & companyName)
        ' 検索文字列を基に検索を行い、該当する大口事業所住所情報を取得します。(2 回目以降)
        ret = advZip.GetZipAddressCmp(False, zipCode, zip5Code, zip7Code, pref, city1, city2, town, townExt, companyName)
    End While
End Using

参照

AdvZip クラス
GetZipAddressCmp オーバーロード


GetZipDecision メソッド

[image] [image]

Yubin7 Ver2.5
AdvZip..::..GetZipDecision メソッド
AdvZip クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | GetZipDecision(String, String%, String%, String%, String%, String%) | 郵便番号から確定する住所情報を取得します。
Public method | GetZipDecision(String, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%) | 郵便番号から確定する住所情報を取得します。

参照

AdvZip クラス
AdvZip メンバ


GetZipDecision メソッド (String, String, String, String, String, String)

[image]

Yubin7 Ver2.5
AdvZip..::..GetZipDecision メソッド (String, String%, String%, String%, String%, String%)
AdvZip クラス 使用例 参照
郵便番号から確定する住所情報を取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int GetZipDecision(
    string zipCode,
    out string pref,
    out string city1,
    out string city2,
    out string town,
    out string townExt
)
Visual Basic (宣言)
Public Function GetZipDecision ( _
    zipCode As String, _
    <OutAttribute> ByRef pref As String, _
    <OutAttribute> ByRef city1 As String, _
    <OutAttribute> ByRef city2 As String, _
    <OutAttribute> ByRef town As String, _
    <OutAttribute> ByRef townExt As String _
) As Integer

パラメータ

zipCode
Type: System..::..String
検索の基となる、3 桁 / 5 桁 / 7 桁の郵便番号を指定します。
pref
Type: System..::..String %
都道府県名を格納する変数を指定します。
city1
Type: System..::..String %
市名を格納する変数を指定します。
city2
Type: System..::..String %
"city1" に続く市町村名を格納する変数を指定します。
town
Type: System..::..String %
町域名を格納する変数を指定します。
townExt
Type: System..::..String %
町域名以降を格納する変数を指定します。

戻り値

エラー時：0

正常時：0 以外(各ビットの値により、取得された住所の特徴を知ることができます。)

Bit0：正常時は必ず「1」になります。

Bit2：「以下に掲載がない場合」に該当する郵便番号の場合「1」になります。

Bit5：「次のビルを除く」に該当する郵便番号の場合「1」になります。

Bit6：「の次に番地がくる場合」に該当する郵便番号の場合「1」になります。

解説

通常 3 桁郵便番号を基に設定した場合は旧 5 桁郵便番号で一致するものを取得しますが、このメソッドを呼び出す前に SetZip7OnlyMode メソッドを呼び出すことで、7 桁郵便番号を取得するモードに設定できます。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetZipDecision.txt"))
{
    string zipCode = "918"; // 検索文字列
    string pref = null;     // 都道府県名
    string city1 = null;    // 市名 1
    string city2 = null;    // 市名 2
    string town = null;     // 町域名
    string townExt = null;  // 町域名以降
    int ret;
    // 検索文字列を基に検索を行い、確定する住所情報を取得します。
    ret = advZip.GetZipDecision(zipCode, out pref, out city1, out city2, out town, out townExt);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("郵便番号が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    // 取得した住所情報をテキストファイルに書き込みます。
    streamWriter.WriteLine(pref + "," + city1 + "," + city2 + "," + town + "," + townExt);
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetZipDecision.txt")
    Dim zipCode As String = "918"   ' 検索文字列
    Dim pref As String = Nothing    ' 都道府県名
    Dim city1 As String = Nothing   ' 市名 1
    Dim city2 As String = Nothing   ' 市名 2
    Dim town As String = Nothing    ' 町域名
    Dim townExt As String = Nothing ' 町域名以降
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、確定する住所情報を取得します。
    ret = advZip.GetZipDecision(zipCode, pref, city1, city2, town, townExt)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("郵便番号が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    ' 取得した住所情報をテキストファイルに書き込みます。
    streamWriter.WriteLine(pref & "," & city1 & "," & city2 & "," & town & "," & townExt)
End Using

参照

AdvZip クラス
GetZipDecision オーバーロード


GetZipDecision メソッド (String, String, String, String, String, String, String, String, String, String, String)

[image]

Yubin7 Ver2.5
AdvZip..::..GetZipDecision メソッド (String, String%, String%, String%, String%, String%, String%, String%, String%, String%, String%)
AdvZip クラス 使用例 参照
郵便番号から確定する住所情報を取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int GetZipDecision(
    string zipCode,
    out string pref,
    out string city1,
    out string city2,
    out string town,
    out string townExt,
    out string prefRuby,
    out string city1Ruby,
    out string city2Ruby,
    out string townRuby,
    out string townExtRuby
)
Visual Basic (宣言)
Public Function GetZipDecision ( _
    zipCode As String, _
    <OutAttribute> ByRef pref As String, _
    <OutAttribute> ByRef city1 As String, _
    <OutAttribute> ByRef city2 As String, _
    <OutAttribute> ByRef town As String, _
    <OutAttribute> ByRef townExt As String, _
    <OutAttribute> ByRef prefRuby As String, _
    <OutAttribute> ByRef city1Ruby As String, _
    <OutAttribute> ByRef city2Ruby As String, _
    <OutAttribute> ByRef townRuby As String, _
    <OutAttribute> ByRef townExtRuby As String _
) As Integer

パラメータ

zipCode
Type: System..::..String
検索の基となる、3 桁 / 5 桁 / 7 桁の郵便番号を指定します。
pref
Type: System..::..String %
都道府県名を格納する変数を指定します。
city1
Type: System..::..String %
市名を格納する変数を指定します。
city2
Type: System..::..String %
"city1" に続く市町村名を格納する変数を指定します。
town
Type: System..::..String %
町域名を格納する変数を指定します。
townExt
Type: System..::..String %
町域名以降を格納する変数を指定します。
prefRuby
Type: System..::..String %
都道府県名(カタカナ)を格納する変数を指定します。
city1Ruby
Type: System..::..String %
市名(カタカナ)を格納する変数を指定します。
city2Ruby
Type: System..::..String %
"city1Ruby" に続く市町村名(カタカナ)を格納する変数を指定します。
townRuby
Type: System..::..String %
町域名(カタカナ)を格納する変数を指定します。
townExtRuby
Type: System..::..String %
町域名以降(カタカナ)を格納する変数を指定します。

戻り値

エラー時：0

正常時：0 以外(各ビットの値により、取得された住所の特徴を知ることができます。)

Bit0：正常時は必ず「1」になります。

Bit2：「以下に掲載がない場合」に該当する郵便番号の場合「1」になります。

Bit5：「次のビルを除く」に該当する郵便番号の場合「1」になります。

Bit6：「の次に番地がくる場合」に該当する郵便番号の場合「1」になります。

解説

通常 3 桁郵便番号を基に設定した場合は旧 5 桁郵便番号で一致するものを取得しますが、このメソッドを呼び出す前に SetZip7OnlyMode メソッドを呼び出すことで、7 桁郵便番号を取得するモードに設定できます。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetZipDecision.txt"))
{
    string zipCode = "918";    // 検索文字列
    string pref = null;        // 都道府県名
    string city1 = null;       // 市名 1
    string city2 = null;       // 市名 2
    string town = null;        // 町域名
    string townExt = null;     // 町域名以降
    string prefRuby = null;    // 都道府県名(カタカナ)
    string city1Ruby = null;   // 市名 1(カタカナ)
    string city2Ruby = null;   // 市名 2(カタカナ)
    string townRuby = null;    // 町域名(カタカナ)
    string townExtRuby = null; // 町域名以降(カタカナ)
    int ret;
    // 検索文字列を基に検索を行い、確定する住所情報を取得します。
    ret = advZip.GetZipDecision(zipCode, out pref, out city1, out city2, out town, out townExt, out prefRuby, out city1Ruby, out city2Ruby, out townRuby, out townExtRuby);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("郵便番号が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    // 取得した住所情報をテキストファイルに書き込みます。
    streamWriter.WriteLine(pref + "," + city1 + "," + city2 + "," + town + "," + townExt + "," + prefRuby + "," + city1Ruby + "," + city2Ruby + "," + townRuby + "," + townExtRuby);
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetZipDecision.txt")
    Dim zipCode As String = "918"       ' 検索文字列
    Dim pref As String = Nothing        ' 都道府県名
    Dim city1 As String = Nothing       ' 市名 1
    Dim city2 As String = Nothing       ' 市名 2
    Dim town As String = Nothing        ' 町域名
    Dim townExt As String = Nothing     ' 町域名以降
    Dim prefRuby As String = Nothing    ' 都道府県名(カタカナ)
    Dim city1Ruby As String = Nothing   ' 市名 1(カタカナ)
    Dim city2Ruby As String = Nothing   ' 市名 2(カタカナ)
    Dim townRuby As String = Nothing    ' 町域名(カタカナ)
    Dim townExtRuby As String = Nothing ' 町域名以降(カタカナ)
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、確定する住所情報を取得します。
    ret = advZip.GetZipDecision(zipCode, pref, city1, city2, town, townExt, prefRuby, city1Ruby, city2Ruby, townRuby, townExtRuby)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("郵便番号が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    ' 取得した住所情報をテキストファイルに書き込みます。
    streamWriter.WriteLine(pref & "," & city1 & "," & city2 & "," & town & "," & townExt & "," & prefRuby & "," & city1Ruby & "," & city2Ruby & "," & townRuby & "," & townExtRuby)
End Using

参照

AdvZip クラス
GetZipDecision オーバーロード


GetZipDicVersion メソッド

[image]

Yubin7 Ver2.5
AdvZip..::..GetZipDicVersion メソッド
AdvZip クラス 使用例 参照
郵便番号辞書のバージョンを取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public string GetZipDicVersion(
    DictionaryInfo id
)
Visual Basic (宣言)
Public Function GetZipDicVersion ( _
    id As DictionaryInfo _
) As String

パラメータ

id
Type: AdvanceSoftware.Yubin7.AdvZip..::..DictionaryInfo
辞書情報を表す DictionaryInfo を指定します。

戻り値

郵便番号辞書のバージョン。(文字列)

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetZipDicVersion.txt"))
{
    string version;
    string assureDate;
    string releaseDate;
    string createDate;
    // 郵便番号辞書のバージョンを取得します。
    version = advZip.GetZipDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.Version);
    // 郵便番号辞書のデータ保証日を取得します。
    assureDate = advZip.GetZipDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.AssureDate);
    // 郵便番号辞書のデータ公開日を取得します。
    releaseDate = advZip.GetZipDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.ReleaseDate);
    // 郵便番号辞書のファイル生成日を取得します。
    createDate = advZip.GetZipDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.CreateDate);
    // 取得した郵便番号辞書の情報をテキストファイルに書き込みます。
    streamWriter.WriteLine("バージョン : " + version);
    streamWriter.WriteLine("データ保証日 : " + assureDate);
    streamWriter.WriteLine("データ公開日 : " + releaseDate);
    streamWriter.WriteLine("ファイル生成日 : " + createDate);
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetZipDicVersion.txt")
    Dim version As String
    Dim assureDate As String
    Dim releaseDate As String
    Dim createDate As String
    ' 郵便番号辞書のバージョンを取得します。
    version = advZip.GetZipDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.Version)
    ' 郵便番号辞書のデータ保証日を取得します。
    assureDate = advZip.GetZipDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.AssureDate)
    ' 郵便番号辞書のデータ公開日を取得します。
    releaseDate = advZip.GetZipDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.ReleaseDate)
    ' 郵便番号辞書のファイル生成日を取得します。
    createDate = advZip.GetZipDicVersion(AdvanceSoftware.Yubin7.AdvZip.DictionaryInfo.CreateDate)
    ' 取得した郵便番号辞書の情報をテキストファイルに書き込みます。
    streamWriter.WriteLine("バージョン : " & version)
    streamWriter.WriteLine("データ保証日 : " & assureDate)
    streamWriter.WriteLine("データ公開日 : " & releaseDate)
    streamWriter.WriteLine("ファイル生成日 : " & createDate)
End Using

参照

AdvZip クラス


SeparateAddress メソッド

[image]

Yubin7 Ver2.5
AdvZip..::..SeparateAddress メソッド
AdvZip クラス 使用例 参照
住所文字列を区切ります。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int SeparateAddress(
    string address,
    out string zip5Code,
    out string zip7Code,
    out string pref,
    out string city1,
    out string city2,
    out string town,
    out string townExt
)
Visual Basic (宣言)
Public Function SeparateAddress ( _
    address As String, _
    <OutAttribute> ByRef zip5Code As String, _
    <OutAttribute> ByRef zip7Code As String, _
    <OutAttribute> ByRef pref As String, _
    <OutAttribute> ByRef city1 As String, _
    <OutAttribute> ByRef city2 As String, _
    <OutAttribute> ByRef town As String, _
    <OutAttribute> ByRef townExt As String _
) As Integer

パラメータ

address
Type: System..::..String
分割の基となる、住所文字列を指定します。
zip5Code
Type: System..::..String %
5 桁郵便番号を格納する変数を指定します。
zip7Code
Type: System..::..String %
7 桁郵便番号を格納する変数を指定します。
pref
Type: System..::..String %
都道府県名を格納する変数を指定します。
city1
Type: System..::..String %
市名を格納する変数を指定します。
city2
Type: System..::..String %
"city1" に続く市町村名を格納する変数を指定します。
town
Type: System..::..String %
町域名を格納する変数を指定します。
townExt
Type: System..::..String %
町域名以降を格納する変数を指定します。

戻り値

エラー時：0

正常時：0 以外(各ビットの値により、取得された住所の特徴を知ることができます。)

Bit0：変換ができた場合必ず「1」になります。

Bit1：「京都の省略住所」の場合「1」になります。

Bit2：「以下に掲載がない場合」という表現の場合「1」になります。

Bit3：「都道府県名省略住所」の場合「1」になります。

Bit4：「市、または郡名の省略住所」の場合「1」になります。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\SeparateAddress.txt"))
{
    string address = "福井県福井市成和1丁目2816番地"; // 住所文字列
    string zip5Code = null;                           // 5 桁郵便番号
    string zip7Code = null;                           // 7 桁郵便番号
    string pref = null;                               // 都道府県名
    string city1 = null;                              // 市名 1
    string city2 = null;                              // 市名 2
    string town = null;                               // 町域名
    string townExt = null;                            // 町域名以降
    int ret;
    // 住所文字列を最小単位に分割します。
    ret = advZip.SeparateAddress(address, out zip5Code, out zip7Code, out pref, out city1, out city2, out town, out townExt);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    // 取得した住所情報をテキストファイルに書き込みます。
    streamWriter.WriteLine(zip5Code + "," + zip7Code + "," + pref + "," + city1 + "," + city2 + "," + town + "," + townExt);
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\SeparateAddress.txt")
    Dim address As String = "福井県福井市成和1丁目2816番地" ' 住所文字列
    Dim zip5Code As String = Nothing                        ' 5 桁郵便番号
    Dim zip7Code As String = Nothing                        ' 7 桁郵便番号
    Dim pref As String = Nothing                            ' 都道府県名
    Dim city1 As String = Nothing                           ' 市名 1
    Dim city2 As String = Nothing                           ' 市名 2
    Dim town As String = Nothing                            ' 町域名
    Dim townExt As String = Nothing                         ' 町域名以降
    Dim ret As Integer
    ' 住所文字列を最小単位に分割します。
    ret = advZip.SeparateAddress(address, zip5Code, zip7Code, pref, city1, city2, town, townExt)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    ' 取得した住所情報をテキストファイルに書き込みます。
    streamWriter.WriteLine(zip5Code & "," & zip7Code & "," & pref & "," & city1 & "," & city2 & "," & town & "," & townExt)
End Using

参照

AdvZip クラス


SetZip7OnlyMode メソッド

[image]

Yubin7 Ver2.5
AdvZip..::..SetZip7OnlyMode メソッド
AdvZip クラス 使用例 参照
7 桁郵便番号を取得するモードに設定します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public void SetZip7OnlyMode()
Visual Basic (宣言)
Public Sub SetZip7OnlyMode

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\GetZipAddress.txt"))
{
    string zipCode = "918"; // 検索文字列
    string zip5Code = null; // 5 桁郵便番号
    string zip7Code = null; // 7 桁郵便番号
    string pref = null;     // 都道府県名
    string city1 = null;    // 市名 1
    string city2 = null;    // 市名 2
    string town = null;     // 町域名
    string townExt = null;  // 町域名以降
    int ret;

    // 7 桁郵便番号取得モードに設定します。
    advZip.SetZip7OnlyMode();

    // 検索文字列を基に検索を行い、該当する住所情報を取得します。(1 回目)
    ret = advZip.GetZipAddress(true, zipCode, out zip5Code, out zip7Code, out pref, out city1, out city2, out town, out townExt);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("郵便番号が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    while (ret != 0)
    {
        // 取得した住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code + "," + zip7Code + "," + pref + "," + city1 + "," + city2 + "," + town + "," + townExt);
        // 検索文字列を基に検索を行い、該当する住所情報を取得します。(2 回目以降)
        ret = advZip.GetZipAddress(false, zipCode, out zip5Code, out zip7Code, out pref, out city1, out city2, out town, out townExt);
    }
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\GetZipAddress.txt")
    Dim zipCode As String = "918"    ' 検索文字列
    Dim zip5Code As String = Nothing ' 5 桁郵便番号
    Dim zip7Code As String = Nothing ' 7 桁郵便番号
    Dim pref As String = Nothing     ' 都道府県名
    Dim city1 As String = Nothing    ' 市名 1
    Dim city2 As String = Nothing    ' 市名 2
    Dim town As String = Nothing     ' 町域名
    Dim townExt As String = Nothing  ' 町域名以降
    Dim ret As Integer

    ' 7 桁郵便番号取得モードに設定します。
    'advZip.SetZip7OnlyMode()

    ' 検索文字列を基に検索を行い、該当する住所情報を取得します。(1 回目)
    ret = advZip.GetZipAddress(True, zipCode, zip5Code, zip7Code, pref, city1, city2, town, townExt)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("郵便番号が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    While ret <> 0
        ' 取得した住所情報をテキストファイルに書き込みます。
        streamWriter.WriteLine(zip5Code & "," & zip7Code & "," & pref & "," & city1 & "," & city2 & "," & town & "," & townExt)
        ' 検索文字列を基に検索を行い、該当する住所情報を取得します。(2 回目以降)
        ret = advZip.GetZipAddress(False, zipCode, zip5Code, zip7Code, pref, city1, city2, town, townExt)
    End While
End Using
Sub

参照

AdvZip クラス


Yubin5 メソッド

[image] [image]

Yubin7 Ver2.5
AdvZip..::..Yubin5 メソッド
AdvZip クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | Yubin5(String, String%) | 住所から 5 桁郵便番号を取得します。
Public method | Yubin5(String, String%, String%) | 住所から 5 桁郵便番号とバーコードデータを取得します。

参照

AdvZip クラス
AdvZip メンバ


Yubin5 メソッド (String, String)

[image]

Yubin7 Ver2.5
AdvZip..::..Yubin5 メソッド (String, String%)
AdvZip クラス 使用例 参照
住所から 5 桁郵便番号を取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int Yubin5(
    string address,
    out string zip5Code
)
Visual Basic (宣言)
Public Function Yubin5 ( _
    address As String, _
    <OutAttribute> ByRef zip5Code As String _
) As Integer

パラメータ

address
Type: System..::..String
検索の基となる、住所文字列を指定します。
zip5Code
Type: System..::..String %
5 桁郵便番号を格納する変数を指定します。

戻り値

エラー時：0

正常時：0 以外(各ビットの値により、取得された住所の特徴を知ることができます。)

Bit0：変換ができた場合必ず「1」になります。

Bit1：「京都の省略住所」の場合「1」になります。

Bit2：「以下に掲載がない場合」という表現の場合「1」になります。

Bit3：「都道府県名省略住所」の場合「1」になります。

Bit4：「市、または郡名の省略住所」の場合「1」になります。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\Yubin5.txt"))
{
    string address = "福井県福井市成和1丁目2816番地"; // 検索文字列
    string zip5Code = null;                           // 5 桁郵便番号
    int ret;
    // 検索文字列を基に検索を行い、該当する 5 桁郵便番号を取得します。
    ret = advZip.Yubin5(address, out zip5Code);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    // 取得した 5 桁郵便番号をテキストファイルに書き込みます。
    streamWriter.WriteLine(zip5Code);
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\Yubin5.txt")
    Dim address As String = "福井県福井市成和1丁目2816番地" ' 検索文字列
    Dim zip5Code As String = Nothing                        ' 5 桁郵便番号
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、該当する 5 桁郵便番号を取得します。
    ret = advZip.Yubin5(address, zip5Code)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    ' 取得した 5 桁郵便番号をテキストファイルに書き込みます。
    streamWriter.WriteLine(zip5Code)
End Using

参照

AdvZip クラス
Yubin5 オーバーロード


Yubin5 メソッド (String, String, String)

[image]

Yubin7 Ver2.5
AdvZip..::..Yubin5 メソッド (String, String%, String%)
AdvZip クラス 使用例 参照
住所から 5 桁郵便番号とバーコードデータを取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int Yubin5(
    string address,
    out string zip5Code,
    out string barCode
)
Visual Basic (宣言)
Public Function Yubin5 ( _
    address As String, _
    <OutAttribute> ByRef zip5Code As String, _
    <OutAttribute> ByRef barCode As String _
) As Integer

パラメータ

address
Type: System..::..String
検索の基となる、住所文字列を指定します。
zip5Code
Type: System..::..String %
5 桁郵便番号を格納する変数を指定します。
barCode
Type: System..::..String %
バーコードデータを格納する変数を指定します。

戻り値

エラー時：0

正常時：0 以外(各ビットの値により、取得された住所の特徴を知ることができます。)

Bit0：変換ができた場合必ず「1」になります。

Bit1：「京都の省略住所」の場合「1」になります。

Bit2：「以下に掲載がない場合」という表現の場合「1」になります。

Bit3：「都道府県名省略住所」の場合「1」になります。

Bit4：「市、または郡名の省略住所」の場合「1」になります。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\Yubin5.txt"))
{
    string address = "福井県福井市成和1丁目2816番地"; // 検索文字列
    string zip5Code = null;                           // 5 桁郵便番号
    string barCode = null;                            // バーコードデータ
    int ret;
    // 検索文字列を基に検索を行い、該当する 5 桁郵便番号とバーコードデータを取得します。
    ret = advZip.Yubin5(address, out zip5Code, out barCode);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    // 取得した 5 桁郵便番号とバーコードデータをテキストファイルに書き込みます。
    streamWriter.WriteLine(zip5Code + "," + barCode);
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\Yubin5.txt")
    Dim address As String = "福井県福井市成和1丁目2816番地" ' 検索文字列
    Dim zip5Code As String = Nothing                        ' 5 桁郵便番号
    Dim barCode As String = Nothing                         ' バーコードデータ
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、該当する 5 桁郵便番号とバーコードデータを取得します。
    ret = advZip.Yubin5(address, zip5Code, barCode)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    ' 取得した 5 桁郵便番号とバーコードデータをテキストファイルに書き込みます。
    streamWriter.WriteLine(zip5Code & "," & barCode)
End Using

参照

AdvZip クラス
Yubin5 オーバーロード


Yubin57 メソッド

[image] [image]

Yubin7 Ver2.5
AdvZip..::..Yubin57 メソッド
AdvZip クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | Yubin57(String, String%, String%) | 住所から 5 桁郵便番号と 7 桁郵便番号を取得します。
Public method | Yubin57(String, String%, String%, String%) | 住所から 5 桁郵便番号と 7 桁郵便番号とバーコードデータを取得します。

参照

AdvZip クラス
AdvZip メンバ


Yubin57 メソッド (String, String, String)

[image]

Yubin7 Ver2.5
AdvZip..::..Yubin57 メソッド (String, String%, String%)
AdvZip クラス 使用例 参照
住所から 5 桁郵便番号と 7 桁郵便番号を取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int Yubin57(
    string address,
    out string zip5Code,
    out string zip7Code
)
Visual Basic (宣言)
Public Function Yubin57 ( _
    address As String, _
    <OutAttribute> ByRef zip5Code As String, _
    <OutAttribute> ByRef zip7Code As String _
) As Integer

パラメータ

address
Type: System..::..String
検索の基となる、住所文字列を指定します。
zip5Code
Type: System..::..String %
5 桁郵便番号を格納する変数を指定します。
zip7Code
Type: System..::..String %
7 桁郵便番号を格納する変数を指定します。

戻り値

エラー時：0

正常時：0 以外(各ビットの値により、取得された住所の特徴を知ることができます。)

Bit0：変換ができた場合必ず「1」になります。

Bit1：「京都の省略住所」の場合「1」になります。

Bit2：「以下に掲載がない場合」という表現の場合「1」になります。

Bit3：「都道府県名省略住所」の場合「1」になります。

Bit4：「市、または郡名の省略住所」の場合「1」になります。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\Yubin57.txt"))
{
    string address = "福井県福井市成和1丁目2816番地"; // 検索文字列
    string zip5Code = null;                           // 5 桁郵便番号
    string zip7Code = null;                           // 7 桁郵便番号
    int ret;
    // 検索文字列を基に検索を行い、該当する 5 桁郵便番号と 7 桁郵便番号を取得します。
    ret = advZip.Yubin57(address, out zip5Code, out zip7Code);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    // 取得した 5 桁郵便番号と 7 桁郵便番号をテキストファイルに書き込みます。
    streamWriter.WriteLine(zip5Code + "," + zip7Code);
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\Yubin57.txt")
    Dim address As String = "福井県福井市成和1丁目2816番地" ' 検索文字列
    Dim zip5Code As String = Nothing                        ' 5 桁郵便番号
    Dim zip7Code As String = Nothing                        ' 7 桁郵便番号
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、該当する 5 桁郵便番号と 7 桁郵便番号を取得します。
    ret = advZip.Yubin57(address, zip5Code, zip7Code)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    ' 取得した 5 桁郵便番号と 7 桁郵便番号をテキストファイルに書き込みます。
    streamWriter.WriteLine(zip5Code & "," & zip7Code)
End Using

参照

AdvZip クラス
Yubin57 オーバーロード


Yubin57 メソッド (String, String, String, String)

[image]

Yubin7 Ver2.5
AdvZip..::..Yubin57 メソッド (String, String%, String%, String%)
AdvZip クラス 使用例 参照
住所から 5 桁郵便番号と 7 桁郵便番号とバーコードデータを取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int Yubin57(
    string address,
    out string zip5Code,
    out string zip7Code,
    out string barCode
)
Visual Basic (宣言)
Public Function Yubin57 ( _
    address As String, _
    <OutAttribute> ByRef zip5Code As String, _
    <OutAttribute> ByRef zip7Code As String, _
    <OutAttribute> ByRef barCode As String _
) As Integer

パラメータ

address
Type: System..::..String
検索の基となる、住所文字列を指定します。
zip5Code
Type: System..::..String %
5 桁郵便番号を格納する変数を指定します。
zip7Code
Type: System..::..String %
7 桁郵便番号を格納する変数を指定します。
barCode
Type: System..::..String %
バーコードデータを格納する変数を指定します。

戻り値

エラー時：0

正常時：0 以外(各ビットの値により、取得された住所の特徴を知ることができます。)

Bit0：変換ができた場合必ず「1」になります。

Bit1：「京都の省略住所」の場合「1」になります。

Bit2：「以下に掲載がない場合」という表現の場合「1」になります。

Bit3：「都道府県名省略住所」の場合「1」になります。

Bit4：「市、または郡名の省略住所」の場合「1」になります。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\Yubin57.txt"))
{
    string address = "福井県福井市成和1丁目2816番地"; // 検索文字列
    string zip5Code = null;                           // 5 桁郵便番号
    string zip7Code = null;                           // 7 桁郵便番号
    string barCode = null;                            // バーコードデータ
    int ret;
    // 検索文字列を基に検索を行い、該当する 5 桁郵便番号と 7 桁郵便番号とバーコードデータを取得します。
    ret = advZip.Yubin57(address, out zip5Code, out zip7Code, out barCode);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    // 取得した 5 桁郵便番号と 7 桁郵便番号とバーコードデータをテキストファイルに書き込みます。
    streamWriter.WriteLine(zip5Code + "," + zip7Code + "," + barCode);
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\Yubin57.txt")
    Dim address As String = "福井県福井市成和1丁目2816番地" ' 検索文字列
    Dim zip5Code As String = Nothing                        ' 5 桁郵便番号
    Dim zip7Code As String = Nothing                        ' 7 桁郵便番号
    Dim barCode As String = Nothing                         ' バーコードデータ
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、該当する 5 桁郵便番号と 7 桁郵便番号とバーコードデータを取得します。
    ret = advZip.Yubin57(address, zip5Code, zip7Code, barCode)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    ' 取得した 5 桁郵便番号と 7 桁郵便番号とバーコードデータをテキストファイルに書き込みます。
    streamWriter.WriteLine(zip5Code & "," & zip7Code & "," & barCode)
End Using

参照

AdvZip クラス
Yubin57 オーバーロード


Yubin7 メソッド

[image] [image]

Yubin7 Ver2.5
AdvZip..::..Yubin7 メソッド
AdvZip クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | Yubin7(String, String%) | 住所から 7 桁郵便番号を取得します。
Public method | Yubin7(String, String%, String%) | 住所から 7 桁郵便番号とバーコードデータを取得します。

参照

AdvZip クラス
AdvZip メンバ


Yubin7 メソッド (String, String)

[image]

Yubin7 Ver2.5
AdvZip..::..Yubin7 メソッド (String, String%)
AdvZip クラス 使用例 参照
住所から 7 桁郵便番号を取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int Yubin7(
    string address,
    out string zip7Code
)
Visual Basic (宣言)
Public Function Yubin7 ( _
    address As String, _
    <OutAttribute> ByRef zip7Code As String _
) As Integer

パラメータ

address
Type: System..::..String
検索の基となる、住所文字列を指定します。
zip7Code
Type: System..::..String %
7 桁郵便番号を格納する変数を指定します。

戻り値

エラー時：0

正常時：0 以外(各ビットの値により、取得された住所の特徴を知ることができます。)

Bit0：変換ができた場合必ず「1」になります。

Bit1：「京都の省略住所」の場合「1」になります。

Bit2：「以下に掲載がない場合」という表現の場合「1」になります。

Bit3：「都道府県名省略住所」の場合「1」になります。

Bit4：「市、または郡名の省略住所」の場合「1」になります。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\Yubin7.txt"))
{
    string address = "福井県福井市成和1丁目2816番地"; // 検索文字列
    string zip7Code = null;                           // 7 桁郵便番号
    int ret;
    // 検索文字列を基に検索を行い、該当する 7 桁郵便番号を取得します。
    ret = advZip.Yubin7(address, out zip7Code);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    // 取得した 7 桁郵便番号をテキストファイルに書き込みます。
    streamWriter.WriteLine(zip7Code);
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\Yubin7.txt")
    Dim address As String = "福井県福井市成和1丁目2816番地" ' 検索文字列
    Dim zip7Code As String = Nothing                        ' 7 桁郵便番号
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、該当する 7 桁郵便番号を取得します。
    ret = advZip.Yubin7(address, zip7Code)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    ' 取得した 7 桁郵便番号をテキストファイルに書き込みます。
    streamWriter.WriteLine(zip7Code)
End Using

参照

AdvZip クラス
Yubin7 オーバーロード


Yubin7 メソッド (String, String, String)

[image]

Yubin7 Ver2.5
AdvZip..::..Yubin7 メソッド (String, String%, String%)
AdvZip クラス 使用例 参照
住所から 7 桁郵便番号とバーコードデータを取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int Yubin7(
    string address,
    out string zip7Code,
    out string barCode
)
Visual Basic (宣言)
Public Function Yubin7 ( _
    address As String, _
    <OutAttribute> ByRef zip7Code As String, _
    <OutAttribute> ByRef barCode As String _
) As Integer

パラメータ

address
Type: System..::..String
検索の基となる、住所文字列を指定します。
zip7Code
Type: System..::..String %
7 桁郵便番号を格納する変数を指定します。
barCode
Type: System..::..String %
バーコードデータを格納する変数を指定します。

戻り値

エラー時：0

正常時：0 以外(各ビットの値により、取得された住所の特徴を知ることができます。)

Bit0：変換ができた場合必ず「1」になります。

Bit1：「京都の省略住所」の場合「1」になります。

Bit2：「以下に掲載がない場合」という表現の場合「1」になります。

Bit3：「都道府県名省略住所」の場合「1」になります。

Bit4：「市、または郡名の省略住所」の場合「1」になります。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\Yubin7.txt"))
{
    string address = "福井県福井市成和1丁目2816番地"; // 検索文字列
    string zip7Code = null;                           // 7 桁郵便番号
    string barCode = null;                            // バーコードデータ
    int ret;
    // 検索文字列を基に検索を行い、該当する 7 桁郵便番号とバーコードデータを取得します。
    ret = advZip.Yubin7(address, out zip7Code, out barCode);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    // 取得した 7 桁郵便番号とバーコードデータをテキストファイルに書き込みます。
    streamWriter.WriteLine(zip7Code + "," + barCode);
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\Yubin7.txt")
    Dim address As String = "福井県福井市成和1丁目2816番地" ' 検索文字列
    Dim zip7Code As String = Nothing                        ' 7 桁郵便番号
    Dim barCode As String = Nothing                         ' バーコードデータ
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、該当する 7 桁郵便番号とバーコードデータを取得します。
    ret = advZip.Yubin7(address, zip7Code, barCode)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    ' 取得した 7 桁郵便番号とバーコードデータをテキストファイルに書き込みます。
    streamWriter.WriteLine(zip7Code & "," & barCode)
End Using

参照

AdvZip クラス
Yubin7 オーバーロード


Yubin7JisCode メソッド

[image]

Yubin7 Ver2.5
AdvZip..::..Yubin7JisCode メソッド
AdvZip クラス 使用例 参照
住所から全国地方公共団体コードを取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int Yubin7JisCode(
    string address,
    out string jisCode,
    out string zip7Code,
    out string barCode
)
Visual Basic (宣言)
Public Function Yubin7JisCode ( _
    address As String, _
    <OutAttribute> ByRef jisCode As String, _
    <OutAttribute> ByRef zip7Code As String, _
    <OutAttribute> ByRef barCode As String _
) As Integer

パラメータ

address
Type: System..::..String
検索の基となる、住所文字列を指定します。
jisCode
Type: System..::..String %
全国地方公共団体コードを格納する変数を指定します。
zip7Code
Type: System..::..String %
7 桁郵便番号を格納する変数を指定します。
barCode
Type: System..::..String %
バーコードデータを格納する変数を指定します。

戻り値

エラー時：0

正常時：0 以外(各ビットの値により、取得された住所の特徴を知ることができます。)

Bit0：変換ができた場合必ず「1」になります。

Bit1：「京都の省略住所」の場合「1」になります。

Bit2：「以下に掲載がない場合」という表現の場合「1」になります。

Bit3：「都道府県名省略住所」の場合「1」になります。

Bit4：「市、または郡名の省略住所」の場合「1」になります。

使用例

コピーC#
using (System.IO.StreamWriter streamWriter = new System.IO.StreamWriter(Application.StartupPath + @"\Yubin7JisCode.txt"))
{
    string address = "福井県福井市成和1丁目2816番地"; // 検索文字列
    string jisCode = null;                            // 全国地方公共団体コード
    string zip7Code = null;                           // 7 桁郵便番号
    string barCode = null;                            // バーコードデータ
    int ret;
    // 検索文字列を基に検索を行い、該当する全国地方公共団体コードと 7 桁郵便番号とバーコードデータを取得します。
    ret = advZip.Yubin7JisCode(address, out jisCode, out zip7Code, out barCode);
    // エラーを判定します。
    if (ret == 0)
    {
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK);
        return;
    }
    // 取得した全国地方公共団体コードと 7 桁郵便番号とバーコードデータをテキストファイルに書き込みます。
    streamWriter.WriteLine(jisCode + "," + zip7Code + "," + barCode);
}
コピーVB.NET
Using streamWriter As New System.IO.StreamWriter(Application.StartupPath & "\Yubin7JisCode.txt")
    Dim address As String = "福井県福井市成和1丁目2816番地" ' 検索文字列
    Dim jisCode As String = Nothing                         ' 全国地方公共団体コード
    Dim zip7Code As String = Nothing                        ' 7 桁郵便番号
    Dim barCode As String = Nothing                         ' バーコードデータ
    Dim ret As Integer
    ' 検索文字列を基に検索を行い、該当する全国地方公共団体コードと 7 桁郵便番号とバーコードデータを取得します。
    ret = advZip.Yubin7JisCode(address, jisCode, zip7Code, barCode)
    ' エラーを判定します。
    If (ret = 0) Then
        MessageBox.Show("住所が不正です。", "エラー", MessageBoxButtons.OK)
        Return
    End If
    ' 取得した全国地方公共団体コードと 7 桁郵便番号とバーコードデータをテキストファイルに書き込みます。
    streamWriter.WriteLine(jisCode & "," & zip7Code & "," & barCode)
End Using

参照

AdvZip クラス


AdvZip プロパティ

[image] [image]

Yubin7 Ver2.5
AdvZip プロパティ
AdvZip クラス 参照

AdvZip データ型で公開されるメンバを以下に示します。

プロパティ

 | 名前 | 説明
Public property | DictionaryPath | 辞書ファイルのパスを指定します。
Public property | ErrorMessage | エラーメッセージを取得します。
Public property | ErrorNo | エラーナンバーを取得します。
Public property | HyphenMode | ハイフン付加モードを設定、取得します。
Public property | KyotoStreetMode | 京都住所の通り名表記の検索モードを設定します。
Public property | ReloadInterval | 辞書を再読み込みするインターバル間隔をミリ秒単位で設定します。
Public property | UseAdvZipParam | フラグ設定ファイルを使用するかを指定します。
Public property | UseAdvZipTable | 特殊漢字テーブルを使用するかを指定します。

参照

AdvZip クラス


DictionaryPath プロパティ

[image]

Yubin7 Ver2.5
AdvZip..::..DictionaryPath プロパティ
AdvZip クラス 使用例 参照
辞書ファイルのパスを指定します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public string DictionaryPath { set; }
Visual Basic (宣言)
Public WriteOnly Property DictionaryPath As String
    Set

プロパティ値

辞書ファイルのパスを表す string。

使用例

コピーC#
// 辞書ファイルのパスを "C:\Dictionary" に設定します。
advZip.DictionaryPath = @"C:\Dictionary";
コピーVB.NET
' 辞書ファイルのパスを "C:\Dictionary" に設定します。
advZip.DictionaryPath = "C:\Dictionary"

参照

AdvZip クラス


ErrorMessage プロパティ

[image]

Yubin7 Ver2.5
AdvZip..::..ErrorMessage プロパティ
AdvZip クラス 使用例 参照
エラーメッセージを取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public string ErrorMessage { get; }
Visual Basic (宣言)
Public ReadOnly Property ErrorMessage As String
    Get

プロパティ値

変換処理時のエラーメッセージを表す string。

使用例

コピーC#
string address = "福井県福井市成和1丁目2816番地"; // 検索文字列
string zip7Code = null;                           // 7 桁郵便番号
int ret;
// 検索文字列を基に検索を行い、該当する 7 桁郵便番号を取得します。
ret = advZip.Yubin7(address, out zip7Code);
// エラー処理
if (advZip.ErrorNo != AdvanceSoftware.Yubin7.AdvZip.ErrorNo.NoError)
{
    // エラーメッセージを表示します。
    MessageBox.Show(advZip.ErrorMessage);
}
コピーVB.NET
Dim address As String = "福井県福井市成和1丁目2816番地" ' 検索文字列
Dim zip7Code As String = Nothing                        ' 7 桁郵便番号
Dim ret As Integer
' 検索文字列を基に検索を行い、該当する 7 桁郵便番号を取得します。
ret = advZip.Yubin7(address, zip7Code)
' エラー処理
If (advZip.ErrorNo <> AdvanceSoftware.Yubin7.AdvZip.ErrorNo.NoError) Then
    ' エラーメッセージを表示します。
    MessageBox.Show(advZip.ErrorMessage)
    Return
End If

参照

AdvZip クラス


ErrorNo プロパティ

[image]

Yubin7 Ver2.5
AdvZip..::..ErrorNo プロパティ
AdvZip クラス 使用例 参照
エラーナンバーを取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public ErrorNo ErrorNo { get; }
Visual Basic (宣言)
Public ReadOnly Property ErrorNo As ErrorNo
    Get

プロパティ値

エラーナンバーを表す ErrorNo。

使用例

コピーC#
string address = "福井県福井市成和1丁目2816番地"; // 検索文字列
string zip7Code = null;                           // 7 桁郵便番号
int ret;
// 検索文字列を基に検索を行い、該当する 7 桁郵便番号を取得します。
ret = advZip.Yubin7(address, out zip7Code);
// エラー処理
if (advZip.ErrorNo != AdvanceSoftware.Yubin7.AdvZip.ErrorNo.NoError)
{
    // エラーメッセージを表示します。
    MessageBox.Show(advZip.ErrorMessage);
}
コピーVB.NET
Dim address As String = "福井県福井市成和1丁目2816番地" ' 検索文字列
Dim zip7Code As String = Nothing                        ' 7 桁郵便番号
Dim ret As Integer
' 検索文字列を基に検索を行い、該当する 7 桁郵便番号を取得します。
ret = advZip.Yubin7(address, zip7Code)
' エラー処理
If (advZip.ErrorNo <> AdvanceSoftware.Yubin7.AdvZip.ErrorNo.NoError) Then
    ' エラーメッセージを表示します。
    MessageBox.Show(advZip.ErrorMessage)
    Return
End If

参照

AdvZip クラス


HyphenMode プロパティ

[image]

Yubin7 Ver2.5
AdvZip..::..HyphenMode プロパティ
AdvZip クラス 使用例 参照
ハイフン付加モードを設定、取得します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public HyphenMode HyphenMode { get; set; }
Visual Basic (宣言)
Public Property HyphenMode As HyphenMode
    Get
    Set

プロパティ値

ハイフン付加モードを表す HyphenMode。

使用例

コピーC#
// ハイフン付加モードを None に設定します。(ハイフン無し)
advZip.HyphenMode = AdvanceSoftware.Yubin7.AdvZip.HyphenMode.None;
コピーVB.NET
' ハイフン付加モードを None に設定します。(ハイフン無し)
advZip.HyphenMode = AdvanceSoftware.Yubin7.AdvZip.HyphenMode.None

参照

AdvZip クラス


KyotoStreetMode プロパティ

[image]

Yubin7 Ver2.5
AdvZip..::..KyotoStreetMode プロパティ
AdvZip クラス 使用例 参照
京都住所の通り名表記の検索モードを設定します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public bool KyotoStreetMode { set; }
Visual Basic (宣言)
Public WriteOnly Property KyotoStreetMode As Boolean
    Set

プロパティ値

京都住所の通り名表記を検索対象とする場合は true。

使用例

コピーC#
// 京都住所の通り名表記を検索対象とします。
advZip.KyotoStreetMode = true;
コピーVB.NET
' 京都住所の通り名表記を検索対象とします。
advZip.KyotoStreetMode = True

参照

AdvZip クラス


ReloadInterval プロパティ

[image]

Yubin7 Ver2.5
AdvZip..::..ReloadInterval プロパティ
AdvZip クラス 使用例 参照
辞書を再読み込みするインターバル間隔をミリ秒単位で設定します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public double ReloadInterval { set; }
Visual Basic (宣言)
Public WriteOnly Property ReloadInterval As Double
    Set

プロパティ値

辞書を再読み込みするインターバル間隔(ミリ秒単位)。

使用例

コピーC#
// 辞書を再読み込みするインターバル間隔を 10000(10 秒) に設定します。
advZip.ReloadInterval = 10000;
コピーVB.NET
' 辞書を再読み込みするインターバル間隔を 10000(10 秒) に設定します。
advZip.ReloadInterval = 10000

参照

AdvZip クラス


UseAdvZipParam プロパティ

[image]

Yubin7 Ver2.5
AdvZip..::..UseAdvZipParam プロパティ
AdvZip クラス 使用例 参照
フラグ設定ファイルを使用するかを指定します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public bool UseAdvZipParam { set; }
Visual Basic (宣言)
Public WriteOnly Property UseAdvZipParam As Boolean
    Set

プロパティ値

フラグ設定ファイルを使用する場合は true。

解説

フラグ設定ファイルの詳細については、「フラグ設定ファイル」を参照してください。

使用例

コピーC#
// フラグ設定ファイルを使用します。
advZip.UseAdvZipParam = true;
コピーVB.NET
' フラグ設定ファイルを使用します。
advZip.UseAdvZipParam = True

参照

AdvZip クラス


UseAdvZipTable プロパティ

[image]

Yubin7 Ver2.5
AdvZip..::..UseAdvZipTable プロパティ
AdvZip クラス 使用例 参照
特殊漢字テーブルを使用するかを指定します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public bool UseAdvZipTable { set; }
Visual Basic (宣言)
Public WriteOnly Property UseAdvZipTable As Boolean
    Set

プロパティ値

特殊漢字テーブルを使用する場合は true。

解説

特殊漢字テーブルの詳細については、「特殊漢字テーブルファイル」を参照してください。

使用例

コピーC#
// 特殊漢字テーブルを使用します。
advZip.UseAdvZipTable = true;
コピーVB.NET
' 特殊漢字テーブルを使用します。
advZip.UseAdvZipTable = True

参照

AdvZip クラス


AdvZip イベント

[image] [image]

Yubin7 Ver2.5
AdvZip イベント
AdvZip クラス 参照

AdvZip データ型で公開されるメンバを以下に示します。

イベント

 | 名前 | 説明
Public event | Error | 変換処理に失敗した時に発生します。

参照

AdvZip クラス


Error イベント

[image]

Yubin7 Ver2.5
AdvZip..::..Error イベント
AdvZip クラス 使用例 参照
変換処理に失敗した時に発生します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public event AdvZipErrorEventHandler Error
Visual Basic (宣言)
Public Event Error As AdvZipErrorEventHandler

使用例

コピーC#
// 郵便番号変換エンジンのインスタンス生成
AdvanceSoftware.Yubin7.AdvZip.AdvZip advZip = new AdvanceSoftware.Yubin7.AdvZip.AdvZip();
private void InitializeComponent()
{
    // 郵便番号変換エンジンのエラーイベントに advZip_Error メソッドを関連付け
    advZip.Error += new AdvanceSoftware.Yubin7.AdvZip.AdvZipErrorEventHandler(advZip_Error);
}
// エラーイベント
void advZip_Error(object sender, AdvanceSoftware.Yubin7.AdvZip.AdvZipErrorEventArgs e)
{
    MessageBox.Show(advZip.ErrorMessage);
}
コピーVB.NET
' 郵便番号変換エンジンのインスタンス生成
Private WithEvents advZip As AdvanceSoftware.Yubin7.AdvZip.AdvZip = New AdvanceSoftware.Yubin7.AdvZip.AdvZip()
' エラーイベント
Private Sub advZip_Error(ByVal sender As Object, ByVal e As AdvanceSoftware.Yubin7.AdvZip.AdvZipErrorEventArgs) Handles advZip.Error
    MessageBox.Show(advZip.ErrorMessage)
End Sub

参照

AdvZip クラス


AdvZip.DifferenceInfo クラス

[image]

Yubin7 Ver2.5
AdvZip..::..DifferenceInfo クラス
AdvZip クラス メンバ 参照
差分データ情報

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public class DifferenceInfo
Visual Basic (宣言)
Public Class DifferenceInfo

継承階層

System..::..Object
AdvanceSoftware.Yubin7.AdvZip..::..AdvZip..::..DifferenceInfo

参照

AdvZip..::..DifferenceInfo メンバ


AdvZip.DifferenceInfo メンバ

[image] [image]

Yubin7 Ver2.5
AdvZip..::..DifferenceInfo メンバ
AdvZip..::..DifferenceInfo クラス コンストラクタ フィールド 参照

AdvZip クラス

AdvZip..::..DifferenceInfo データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | AdvZip..::..DifferenceInfo | Initializes a new instance of the AdvZip..::..DifferenceInfo class

フィールド

 | 名前 | 説明
Public field | city1 | 市1(旧住所)
Public field | city2 | 市2(旧住所)
Public field | mergeInfos | 住所変更情報
Public field | pref | 都道府県名(旧住所)
Public field | town | 町域名(旧住所)
Public field | townExt | 町域以降(旧住所)

参照

AdvZip..::..DifferenceInfo クラス


AdvZip.DifferenceInfo コンストラクタ

[image]

Yubin7 Ver2.5
AdvZip..::..DifferenceInfo コンストラクタ
AdvZip..::..DifferenceInfo クラス 参照
Initializes a new instance of the AdvZip..::..DifferenceInfo class

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public DifferenceInfo()
Visual Basic (宣言)
Public Sub New

参照

AdvZip..::..DifferenceInfo クラス


AdvZip.DifferenceInfo フィールド

[image] [image]

Yubin7 Ver2.5
AdvZip..::..DifferenceInfo フィールド
AdvZip..::..DifferenceInfo クラス 参照

AdvZip..::..DifferenceInfo データ型で公開されるメンバを以下に示します。

フィールド

 | 名前 | 説明
Public field | city1 | 市1(旧住所)
Public field | city2 | 市2(旧住所)
Public field | mergeInfos | 住所変更情報
Public field | pref | 都道府県名(旧住所)
Public field | town | 町域名(旧住所)
Public field | townExt | 町域以降(旧住所)

参照

AdvZip..::..DifferenceInfo クラス


city1 フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..DifferenceInfo..::..city1 フィールド
AdvZip..::..DifferenceInfo クラス 参照
市1(旧住所)

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public string city1
Visual Basic (宣言)
Public city1 As String

参照

AdvZip..::..DifferenceInfo クラス


city2 フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..DifferenceInfo..::..city2 フィールド
AdvZip..::..DifferenceInfo クラス 参照
市2(旧住所)

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public string city2
Visual Basic (宣言)
Public city2 As String

参照

AdvZip..::..DifferenceInfo クラス


mergeInfos フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..DifferenceInfo..::..mergeInfos フィールド
AdvZip..::..DifferenceInfo クラス 参照
住所変更情報

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public AdvZip..::..MergeInfo[] mergeInfos
Visual Basic (宣言)
Public mergeInfos As AdvZip..::..MergeInfo()

参照

AdvZip..::..DifferenceInfo クラス


pref フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..DifferenceInfo..::..pref フィールド
AdvZip..::..DifferenceInfo クラス 参照
都道府県名(旧住所)

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public string pref
Visual Basic (宣言)
Public pref As String

参照

AdvZip..::..DifferenceInfo クラス


town フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..DifferenceInfo..::..town フィールド
AdvZip..::..DifferenceInfo クラス 参照
町域名(旧住所)

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public string town
Visual Basic (宣言)
Public town As String

参照

AdvZip..::..DifferenceInfo クラス


townExt フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..DifferenceInfo..::..townExt フィールド
AdvZip..::..DifferenceInfo クラス 参照
町域以降(旧住所)

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public string townExt
Visual Basic (宣言)
Public townExt As String

参照

AdvZip..::..DifferenceInfo クラス


AdvZip.MergeInfo クラス

[image]

Yubin7 Ver2.5
AdvZip..::..MergeInfo クラス
AdvZip クラス メンバ 参照
住所変更情報

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public class MergeInfo
Visual Basic (宣言)
Public Class MergeInfo

継承階層

System..::..Object
AdvanceSoftware.Yubin7.AdvZip..::..AdvZip..::..MergeInfo

参照

AdvZip..::..MergeInfo メンバ


AdvZip.MergeInfo メンバ

[image] [image]

Yubin7 Ver2.5
AdvZip..::..MergeInfo メンバ
AdvZip..::..MergeInfo クラス コンストラクタ フィールド 参照

AdvZip クラス

AdvZip..::..MergeInfo データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | AdvZip..::..MergeInfo | Initializes a new instance of the AdvZip..::..MergeInfo class

フィールド

 | 名前 | 説明
Public field | cityCode | 全国地方公共団体コード
Public field | cityName | 市区町村名
Public field | cityRuby | 市区町村名(カナ)
Public field | date | 実施日
Public field | hasNumber | 丁目を有する町域の場合の表示
Public field | isModify | 更新の表示
Public field | modifyReason | 変更理由
Public field | multiAddresss | 1 つの郵便番号で 2 つ以上の町域を表す場合の表示
Public field | multiNumber | 小字ごとに番地が起番されている場合の表示
Public field | multiZipCode | 1 町域が 2 つ以上の郵便番号で表される場合の表示
Public field | prefName | 都道府県名
Public field | prefRuby | 都道府県名(カナ)
Public field | townName | 町域名
Public field | townRuby | 町域名(カナ)
Public field | zip5Code | 5 桁郵便番号
Public field | zip7Code | 7 桁郵便番号

参照

AdvZip..::..MergeInfo クラス


AdvZip.MergeInfo コンストラクタ

[image]

Yubin7 Ver2.5
AdvZip..::..MergeInfo コンストラクタ
AdvZip..::..MergeInfo クラス 参照
Initializes a new instance of the AdvZip..::..MergeInfo class

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public MergeInfo()
Visual Basic (宣言)
Public Sub New

参照

AdvZip..::..MergeInfo クラス


AdvZip.MergeInfo フィールド

[image] [image]

Yubin7 Ver2.5
AdvZip..::..MergeInfo フィールド
AdvZip..::..MergeInfo クラス 参照

AdvZip..::..MergeInfo データ型で公開されるメンバを以下に示します。

フィールド

 | 名前 | 説明
Public field | cityCode | 全国地方公共団体コード
Public field | cityName | 市区町村名
Public field | cityRuby | 市区町村名(カナ)
Public field | date | 実施日
Public field | hasNumber | 丁目を有する町域の場合の表示
Public field | isModify | 更新の表示
Public field | modifyReason | 変更理由
Public field | multiAddresss | 1 つの郵便番号で 2 つ以上の町域を表す場合の表示
Public field | multiNumber | 小字ごとに番地が起番されている場合の表示
Public field | multiZipCode | 1 町域が 2 つ以上の郵便番号で表される場合の表示
Public field | prefName | 都道府県名
Public field | prefRuby | 都道府県名(カナ)
Public field | townName | 町域名
Public field | townRuby | 町域名(カナ)
Public field | zip5Code | 5 桁郵便番号
Public field | zip7Code | 7 桁郵便番号

参照

AdvZip..::..MergeInfo クラス


cityCode フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..MergeInfo..::..cityCode フィールド
AdvZip..::..MergeInfo クラス 参照
全国地方公共団体コード

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public ushort cityCode
Visual Basic (宣言)
Public cityCode As UShort

参照

AdvZip..::..MergeInfo クラス


cityName フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..MergeInfo..::..cityName フィールド
AdvZip..::..MergeInfo クラス 参照
市区町村名

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public string cityName
Visual Basic (宣言)
Public cityName As String

参照

AdvZip..::..MergeInfo クラス


cityRuby フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..MergeInfo..::..cityRuby フィールド
AdvZip..::..MergeInfo クラス 参照
市区町村名(カナ)

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public string cityRuby
Visual Basic (宣言)
Public cityRuby As String

参照

AdvZip..::..MergeInfo クラス


date フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..MergeInfo..::..date フィールド
AdvZip..::..MergeInfo クラス 参照
実施日

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public DateTime date
Visual Basic (宣言)
Public date As DateTime

参照

AdvZip..::..MergeInfo クラス


hasNumber フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..MergeInfo..::..hasNumber フィールド
AdvZip..::..MergeInfo クラス 参照
丁目を有する町域の場合の表示

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public short hasNumber
Visual Basic (宣言)
Public hasNumber As Short

解説

0：該当しない

1：該当する

参照

AdvZip..::..MergeInfo クラス


isModify フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..MergeInfo..::..isModify フィールド
AdvZip..::..MergeInfo クラス 参照
更新の表示

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public short isModify
Visual Basic (宣言)
Public isModify As Short

解説

0：変更なし

1：変更あり

2：廃止

参照

AdvZip..::..MergeInfo クラス


modifyReason フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..MergeInfo..::..modifyReason フィールド
AdvZip..::..MergeInfo クラス 参照
変更理由

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public short modifyReason
Visual Basic (宣言)
Public modifyReason As Short

解説

0：変更なし

1：市政・区政・町政・分区・政令指定都市施行

2：住居表示の実施

3：区画整理

4：郵便区調整等

5：訂正

6：廃止

参照

AdvZip..::..MergeInfo クラス


multiAddresss フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..MergeInfo..::..multiAddresss フィールド
AdvZip..::..MergeInfo クラス 参照
1 つの郵便番号で 2 つ以上の町域を表す場合の表示

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public short multiAddresss
Visual Basic (宣言)
Public multiAddresss As Short

解説

0：該当しない

1：該当する

参照

AdvZip..::..MergeInfo クラス


multiNumber フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..MergeInfo..::..multiNumber フィールド
AdvZip..::..MergeInfo クラス 参照
小字ごとに番地が起番されている場合の表示

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public short multiNumber
Visual Basic (宣言)
Public multiNumber As Short

解説

0：該当しない

1：該当する

参照

AdvZip..::..MergeInfo クラス


multiZipCode フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..MergeInfo..::..multiZipCode フィールド
AdvZip..::..MergeInfo クラス 参照
1 町域が 2 つ以上の郵便番号で表される場合の表示

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public short multiZipCode
Visual Basic (宣言)
Public multiZipCode As Short

解説

0：該当しない

1：該当する

参照

AdvZip..::..MergeInfo クラス


prefName フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..MergeInfo..::..prefName フィールド
AdvZip..::..MergeInfo クラス 参照
都道府県名

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public string prefName
Visual Basic (宣言)
Public prefName As String

参照

AdvZip..::..MergeInfo クラス


prefRuby フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..MergeInfo..::..prefRuby フィールド
AdvZip..::..MergeInfo クラス 参照
都道府県名(カナ)

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public string prefRuby
Visual Basic (宣言)
Public prefRuby As String

参照

AdvZip..::..MergeInfo クラス


townName フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..MergeInfo..::..townName フィールド
AdvZip..::..MergeInfo クラス 参照
町域名

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public string townName
Visual Basic (宣言)
Public townName As String

参照

AdvZip..::..MergeInfo クラス


townRuby フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..MergeInfo..::..townRuby フィールド
AdvZip..::..MergeInfo クラス 参照
町域名(カナ)

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public string townRuby
Visual Basic (宣言)
Public townRuby As String

参照

AdvZip..::..MergeInfo クラス


zip5Code フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..MergeInfo..::..zip5Code フィールド
AdvZip..::..MergeInfo クラス 参照
5 桁郵便番号

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public string zip5Code
Visual Basic (宣言)
Public zip5Code As String

参照

AdvZip..::..MergeInfo クラス


zip7Code フィールド

[image]

Yubin7 Ver2.5
AdvZip..::..MergeInfo..::..zip7Code フィールド
AdvZip..::..MergeInfo クラス 参照
7 桁郵便番号

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public string zip7Code
Visual Basic (宣言)
Public zip7Code As String

参照

AdvZip..::..MergeInfo クラス


AdvZipErrorEventArgs クラス

[image]

Yubin7 Ver2.5
AdvZipErrorEventArgs クラス
メンバ 参照
AdvZip クラスの Error イベントのデータを提供します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public class AdvZipErrorEventArgs : EventArgs
Visual Basic (宣言)
Public Class AdvZipErrorEventArgs _
    Inherits EventArgs

継承階層

System..::..Object
System..::..EventArgs
AdvanceSoftware.Yubin7.AdvZip..::..AdvZipErrorEventArgs

参照

AdvZipErrorEventArgs メンバ


AdvZipErrorEventArgs メンバ

[image] [image]

Yubin7 Ver2.5
AdvZipErrorEventArgs メンバ
AdvZipErrorEventArgs クラス コンストラクタ プロパティ 参照

AdvZipErrorEventArgs データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | AdvZipErrorEventArgs | 新しい AdvZip クラスの Error イベントを初期化します。

プロパティ

 | 名前 | 説明
Public property | ErrorNo | エラーナンバーを処理します。(内部使用のみ。)

参照

AdvZipErrorEventArgs クラス


AdvZipErrorEventArgs コンストラクタ

[image]

Yubin7 Ver2.5
AdvZipErrorEventArgs コンストラクタ
AdvZipErrorEventArgs クラス 参照
新しい AdvZip クラスの Error イベントを初期化します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public AdvZipErrorEventArgs(
    ErrorNo errorNo
)
Visual Basic (宣言)
Public Sub New ( _
    errorNo As ErrorNo _
)

パラメータ

errorNo
Type: AdvanceSoftware.Yubin7.AdvZip..::..ErrorNo
ErrorNo を指定します。

参照

AdvZipErrorEventArgs クラス


AdvZipErrorEventArgs プロパティ

[image] [image]

Yubin7 Ver2.5
AdvZipErrorEventArgs プロパティ
AdvZipErrorEventArgs クラス 参照

AdvZipErrorEventArgs データ型で公開されるメンバを以下に示します。

プロパティ

 | 名前 | 説明
Public property | ErrorNo | エラーナンバーを処理します。(内部使用のみ。)

参照

AdvZipErrorEventArgs クラス


ErrorNo プロパティ

[image]

Yubin7 Ver2.5
AdvZipErrorEventArgs..::..ErrorNo プロパティ
AdvZipErrorEventArgs クラス 参照
エラーナンバーを処理します。(内部使用のみ。)

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public ErrorNo ErrorNo { get; }
Visual Basic (宣言)
Public ReadOnly Property ErrorNo As ErrorNo
    Get

参照

AdvZipErrorEventArgs クラス


AdvZipErrorEventHandler デリゲート

[image]

Yubin7 Ver2.5
AdvZipErrorEventHandler デリゲート
参照
AdvZip クラスの Error イベントを処理するメソッドを表します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public delegate void AdvZipErrorEventHandler(
    Object sender,
    AdvZipErrorEventArgs e
)
Visual Basic (宣言)
Public Delegate Sub AdvZipErrorEventHandler ( _
    sender As Object, _
    e As AdvZipErrorEventArgs _
)

パラメータ

sender
Type: System..::..Object
e
Type: AdvanceSoftware.Yubin7.AdvZip..::..AdvZipErrorEventArgs

参照


DictionaryInfo 列挙体

[image]

Yubin7 Ver2.5
DictionaryInfo 列挙体
参照
辞書情報

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public enum DictionaryInfo
Visual Basic (宣言)
Public Enumeration DictionaryInfo

メンバ

メンバ名 | 説明
Serial |
Version |
ReleaseDate |
AssureDate |
CreateDate |

参照


ErrorNo 列挙体

[image]

Yubin7 Ver2.5
ErrorNo 列挙体
参照
エラーナンバーを示す識別子を指定します。

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public enum ErrorNo
Visual Basic (宣言)
Public Enumeration ErrorNo

メンバ

メンバ名 | 説明
NoError | エラーなし
NotOpen | 未オープンエラー。
DictionaryError | 辞書ファイルオープンエラー。
ReadError | 読み込みエラー。
HeaderReadError | ヘッダー読み込みエラー。
PrefReadError | 県データ読み込みエラー。
DistReadError | 群データ読み込みエラー。
CityReadError | 市町村データ読み込みエラー。
ExtReadError | 拡張部１読み込みエラー。
TownReadError | 町域データ読み込みエラー。
NoData | データがありません。

参照


HyphenMode 列挙体

[image]

Yubin7 Ver2.5
HyphenMode 列挙体
参照
ハイフン付加モード

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public enum HyphenMode
Visual Basic (宣言)
Public Enumeration HyphenMode

メンバ

メンバ名 | 説明
None |
Set |

参照


Tools クラス

[image]

Yubin7 Ver2.5
Tools クラス
メンバ 参照
Tools クラス

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public class Tools
Visual Basic (宣言)
Public Class Tools

継承階層

System..::..Object
AdvanceSoftware.Yubin7.AdvZip..::..Tools

参照

Tools メンバ


Tools メンバ

[image] [image]

Yubin7 Ver2.5
Tools メンバ
Tools クラス コンストラクタ 参照

Tools データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | Tools | Initializes a new instance of the Tools class

参照

Tools クラス


Tools コンストラクタ

[image]

Yubin7 Ver2.5
Tools コンストラクタ
Tools クラス 参照
Initializes a new instance of the Tools class

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public Tools()
Visual Basic (宣言)
Public Sub New

参照

Tools クラス


Tools.AdvZipParam クラス

[image]

Yubin7 Ver2.5
Tools..::..AdvZipParam クラス
Tools クラス メンバ 参照
AdvZipParam クラス

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public class AdvZipParam
Visual Basic (宣言)
Public Class AdvZipParam

継承階層

System..::..Object
AdvanceSoftware.Yubin7.AdvZip..::..Tools..::..AdvZipParam

参照

Tools..::..AdvZipParam メンバ


Tools.AdvZipParam メンバ

[image] [image]

Yubin7 Ver2.5
Tools..::..AdvZipParam メンバ
Tools..::..AdvZipParam クラス コンストラクタ プロパティ 参照

Tools クラス

Tools..::..AdvZipParam データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | Tools..::..AdvZipParam | Initializes a new instance of the Tools..::..AdvZipParam class

プロパティ

 | 名前 | 説明
Public property | KanjiNumberConvertLevel | KanjiNumberConvertLevel
Public property | KanjiTableOff | KanjiTableOff

参照

Tools..::..AdvZipParam クラス


Tools.AdvZipParam コンストラクタ

[image]

Yubin7 Ver2.5
Tools..::..AdvZipParam コンストラクタ
Tools..::..AdvZipParam クラス 参照
Initializes a new instance of the Tools..::..AdvZipParam class

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public AdvZipParam()
Visual Basic (宣言)
Public Sub New

参照

Tools..::..AdvZipParam クラス


Tools.AdvZipParam プロパティ

[image] [image]

Yubin7 Ver2.5
Tools..::..AdvZipParam プロパティ
Tools..::..AdvZipParam クラス 参照

Tools..::..AdvZipParam データ型で公開されるメンバを以下に示します。

プロパティ

 | 名前 | 説明
Public property | KanjiNumberConvertLevel | KanjiNumberConvertLevel
Public property | KanjiTableOff | KanjiTableOff

参照

Tools..::..AdvZipParam クラス


KanjiNumberConvertLevel プロパティ

[image]

Yubin7 Ver2.5
Tools..::..AdvZipParam..::..KanjiNumberConvertLevel プロパティ
Tools..::..AdvZipParam クラス 参照
KanjiNumberConvertLevel

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int KanjiNumberConvertLevel { get; set; }
Visual Basic (宣言)
Public Property KanjiNumberConvertLevel As Integer
    Get
    Set

参照

Tools..::..AdvZipParam クラス


KanjiTableOff プロパティ

[image]

Yubin7 Ver2.5
Tools..::..AdvZipParam..::..KanjiTableOff プロパティ
Tools..::..AdvZipParam クラス 参照
KanjiTableOff

名前空間: AdvanceSoftware.Yubin7.AdvZip
アセンブリ: Yubin7.AdvZip (Yubin7.AdvZip.dll 内) バージョン: 2.6.5270.1202 (2.6.5270.1202)

構文

C#
public int KanjiTableOff { get; set; }
Visual Basic (宣言)
Public Property KanjiTableOff As Integer
    Get
    Set

参照

Tools..::..AdvZipParam クラス


AdvanceSoftware.Yubin7.BarCode 名前空間

[image]

Yubin7 Ver2.5
AdvanceSoftware.Yubin7.BarCode 名前空間
AdvanceSoftware.Yubin7.BarCode 名前空間には、バーコードクラスが含まれています。

クラス

 | クラス | 説明
Public class | BarCode | BarCode クラス
Public class | BarCodeErrorEventArgs | BarCode クラスの Error イベントのデータを提供します。

構造体

 | 構造体 | 説明
Public structure | BarCodeSize | BarCodeSize 構造体
Public structure | BarCodeSizeD | BarCodeSizeD 構造体

デリゲート

 | デリゲート | 説明
Public delegate | BarCodeErrorEventHandler | BarCode クラスの Error イベントを処理するメソッドを表します。

列挙体

 | 列挙体 | 説明
Public enumeration | ErrorNo | エラーナンバーを示す識別子を指定します。
Public enumeration | Rotate | バーコードの回転方向を指定します。
Public enumeration | Unit | バーコードの生成単位を指定します。


BarCode クラス

[image]

Yubin7 Ver2.5
BarCode クラス
メンバ 参照
BarCode クラス

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public class BarCode : Component
Visual Basic (宣言)
Public Class BarCode _
    Inherits Component

継承階層

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
AdvanceSoftware.Yubin7.BarCode..::..BarCode

参照

BarCode メンバ
AdvanceSoftware.Yubin7.BarCode 名前空間


BarCode メンバ

[image] [image]

Yubin7 Ver2.5
BarCode メンバ
BarCode クラス コンストラクタ メソッド プロパティ イベント 参照

BarCode データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | BarCode()()()() | コンストラクタ
Public method | BarCode(IContainer) | コンストラクタ

メソッド

 | 名前 | 説明
Public method | GetBarCodeImage(ImageFormat) | バーコードのイメージを作成します。
Public method | GetBarCodeImage(ImageFormat, Boolean) | バーコードのイメージを作成します。
Public method | GetScaleSize | 指定した単位でバーコードのサイズを取得します。

プロパティ

 | 名前 | 説明
Public property | _Unit | バーコードの生成単位を設定、取得します。
Public property | BackColor | バーコードシンボルの背景色を設定、取得します。
Public property | BarColor | バーの色を設定、取得します。
Public property | BarHeight | バーコードの高さを設定、取得します。
Public property | BarWidth | バーコードの幅を設定、取得します。
Public property | BlackRatio | 黒バーの太さの比率を設定、取得します。
Public property | DpiX | X 軸方向の解像度を設定、取得します。(ピクセル単位)
Public property | DpiY | Y 軸方向の解像度を設定、取得します。(ピクセル単位)
Public property | EmfType | 拡張メタファイル(EMF)に格納されるレコードの品質を設定します。
Public property | ErrorMessage | エラーメッセージを取得します。
Public property | ErrorNo | エラーナンバーを取得します。
Public property | InternalValue | 整形後のバーコードデータを取得します。
Public property | Point | ポイントを設定、取得します。(郵便カスタマバーコード)
Public property | Rotate | バーコードの回転方向を設定、取得します。
Public property | Unit | バーコードの生成単位を設定、取得します。
Public property | Value | バーコードデータを設定、取得します。(文字列)

イベント

 | 名前 | 説明
Public event | Error | バーコードの作成に失敗した時に発生します。

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


BarCode コンストラクタ

[image] [image]

Yubin7 Ver2.5
BarCode コンストラクタ
BarCode クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | BarCode()()()() | コンストラクタ
Public method | BarCode(IContainer) | コンストラクタ

参照

BarCode クラス
BarCode メンバ
AdvanceSoftware.Yubin7.BarCode 名前空間


BarCode コンストラクタ

[image]

Yubin7 Ver2.5
BarCode コンストラクタ
BarCode クラス 参照
コンストラクタ

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public BarCode()
Visual Basic (宣言)
Public Sub New

参照

BarCode クラス
BarCode オーバーロード
AdvanceSoftware.Yubin7.BarCode 名前空間


BarCode コンストラクタ (IContainer)

[image]

Yubin7 Ver2.5
BarCode コンストラクタ (IContainer)
BarCode クラス 参照
コンストラクタ

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public BarCode(
    IContainer container
)
Visual Basic (宣言)
Public Sub New ( _
    container As IContainer _
)

パラメータ

container
Type: System.ComponentModel..::..IContainer
System.ComponentModel.IContainer を指定します。

参照

BarCode クラス
BarCode オーバーロード
AdvanceSoftware.Yubin7.BarCode 名前空間


BarCode メソッド

[image] [image]

Yubin7 Ver2.5
BarCode メソッド
BarCode クラス 参照

BarCode データ型で公開されるメンバを以下に示します。

メソッド

 | 名前 | 説明
Public method | GetBarCodeImage(ImageFormat) | バーコードのイメージを作成します。
Public method | GetBarCodeImage(ImageFormat, Boolean) | バーコードのイメージを作成します。
Public method | GetScaleSize | 指定した単位でバーコードのサイズを取得します。

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


GetBarCodeImage メソッド

[image] [image]

Yubin7 Ver2.5
BarCode..::..GetBarCodeImage メソッド
BarCode クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | GetBarCodeImage(ImageFormat) | バーコードのイメージを作成します。
Public method | GetBarCodeImage(ImageFormat, Boolean) | バーコードのイメージを作成します。

参照

BarCode クラス
BarCode メンバ
AdvanceSoftware.Yubin7.BarCode 名前空間


GetBarCodeImage メソッド (ImageFormat)

[image]

Yubin7 Ver2.5
BarCode..::..GetBarCodeImage メソッド (ImageFormat)
BarCode クラス 使用例 参照
バーコードのイメージを作成します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public Image GetBarCodeImage(
    ImageFormat format
)
Visual Basic (宣言)
Public Function GetBarCodeImage ( _
    format As ImageFormat _
) As Image

パラメータ

format
Type: System.Drawing.Imaging..::..ImageFormat
保存する Image のImageFormat。

戻り値

このメソッドが作成する Image。

使用例

コピーC#
// バーコードデータを設定します。
barCode.Value = "91882391-2816";
// バーコードイメージ (拡張メタファイル) を生成します。
Image barCodeImage = barCode.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf);
コピーVB.NET
' バーコードデータを設定します。
barCode.Value = "91882391-2816"
' バーコードイメージ (拡張メタファイル) を生成します。
Dim barCodeImage As Image = barCode.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf)

参照

BarCode クラス
GetBarCodeImage オーバーロード
AdvanceSoftware.Yubin7.BarCode 名前空間


GetBarCodeImage メソッド (ImageFormat, Boolean)

[image]

Yubin7 Ver2.5
BarCode..::..GetBarCodeImage メソッド (ImageFormat, Boolean)
BarCode クラス 使用例 参照
バーコードのイメージを作成します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public Image GetBarCodeImage(
    ImageFormat format,
    bool resolution
)
Visual Basic (宣言)
Public Function GetBarCodeImage ( _
    format As ImageFormat, _
    resolution As Boolean _
) As Image

パラメータ

format
Type: System.Drawing.Imaging..::..ImageFormat
保存する Image のImageFormat。
resolution
Type: System..::..Boolean
DpiX プロパティ、DpiY プロパティの解像度で Bitmap を作成する場合、true を設定します。

戻り値

このメソッドが作成する Image。

使用例

コピーC#
barCode.Unit = AdvanceSoftware.Yubin7.BarCode.Unit.Pixel;
barCode.DpiX = 600;
barCode.DpiY = 600;
barCode.Value = "91882391-2816";
// バーコードイメージ (ビットマップ) を DpiX、DpiY プロパティの解像度で生成します。
Image barCodeImage = barCode.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp, true);
コピーVB.NET
barCode.Unit = AdvanceSoftware.Yubin7.BarCode.Unit.Pixel
barCode.DpiX = 600
barCode.DpiY = 600
barCode.Value = "91882391-2816"
' バーコードイメージ (ビットマップ) を DpiX、DpiY プロパティの解像度で生成します。
Dim barCodeImage As Image = barCode.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp, True)

参照

BarCode クラス
GetBarCodeImage オーバーロード
AdvanceSoftware.Yubin7.BarCode 名前空間


GetScaleSize メソッド

[image]

Yubin7 Ver2.5
BarCode..::..GetScaleSize メソッド
BarCode クラス 使用例 参照
指定した単位でバーコードのサイズを取得します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public BarCodeSizeD GetScaleSize(
    Unit unit
)
Visual Basic (宣言)
Public Function GetScaleSize ( _
    unit As Unit _
) As BarCodeSizeD

パラメータ

unit
Type: AdvanceSoftware.Yubin7.BarCode..::..Unit
取得するサイズの単位を表す Unit 列挙体。

戻り値

バーコードのサイズ。

使用例

コピーC#
// バーコードデータを設定します。
barCode.Value = "91882391-2816";
AdvanceSoftware.Yubin7.BarCode.BarCodeSizeD  barCodeSizeD;
// バーコードイメージのサイズを ミリ(mm) 単位で取得します。
barCodeSizeD = barCode.GetScaleSize(AdvanceSoftware.Yubin7.BarCode.Unit.Millimeter);
コピーVB.NET
' バーコードデータを設定します。
barCode.Value = "91882391-2816"
Dim barCodeSizeD As AdvanceSoftware.Yubin7.BarCode.BarCodeSizeD
' バーコードイメージのサイズを ミリ(mm) 単位で取得します。
barCodeSizeD = barCode.GetScaleSize(AdvanceSoftware.Yubin7.BarCode.Unit.Millimeter)

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


BarCode プロパティ

[image] [image]

Yubin7 Ver2.5
BarCode プロパティ
BarCode クラス 参照

BarCode データ型で公開されるメンバを以下に示します。

プロパティ

 | 名前 | 説明
Public property | _Unit | バーコードの生成単位を設定、取得します。
Public property | BackColor | バーコードシンボルの背景色を設定、取得します。
Public property | BarColor | バーの色を設定、取得します。
Public property | BarHeight | バーコードの高さを設定、取得します。
Public property | BarWidth | バーコードの幅を設定、取得します。
Public property | BlackRatio | 黒バーの太さの比率を設定、取得します。
Public property | DpiX | X 軸方向の解像度を設定、取得します。(ピクセル単位)
Public property | DpiY | Y 軸方向の解像度を設定、取得します。(ピクセル単位)
Public property | EmfType | 拡張メタファイル(EMF)に格納されるレコードの品質を設定します。
Public property | ErrorMessage | エラーメッセージを取得します。
Public property | ErrorNo | エラーナンバーを取得します。
Public property | InternalValue | 整形後のバーコードデータを取得します。
Public property | Point | ポイントを設定、取得します。(郵便カスタマバーコード)
Public property | Rotate | バーコードの回転方向を設定、取得します。
Public property | Unit | バーコードの生成単位を設定、取得します。
Public property | Value | バーコードデータを設定、取得します。(文字列)

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


_Unit プロパティ

[image]

Yubin7 Ver2.5
BarCode..::.._Unit プロパティ
BarCode クラス 参照
バーコードの生成単位を設定、取得します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public Unit _Unit { get; set; }
Visual Basic (宣言)
Public Property _Unit As Unit
    Get
    Set

プロパティ値

バーコードの生成単位を表す Unit。(既定値：Unit.Pixel)

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


BackColor プロパティ

[image]

Yubin7 Ver2.5
BarCode..::..BackColor プロパティ
BarCode クラス 使用例 参照
バーコードシンボルの背景色を設定、取得します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public Color BackColor { get; set; }
Visual Basic (宣言)
Public Property BackColor As Color
    Get
    Set

プロパティ値

バーコードシンボルの色を表す Color。(既定値：Color.White)

使用例

コピーC#
// バーコードイメージの背景色を "赤色" に設定します。
barCode.BackColor = System.Drawing.Color.Red;
// バーコードデータを設定します。
barCode.Value = "91882391-2816";
コピーVB.NET
' バーコードイメージの背景色を "赤色" に設定します。
barCode.BackColor = System.Drawing.Color.Red
' バーコードデータを設定します。
barCode.Value = "91882391-2816"

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


BarColor プロパティ

[image]

Yubin7 Ver2.5
BarCode..::..BarColor プロパティ
BarCode クラス 使用例 参照
バーの色を設定、取得します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public Color BarColor { get; set; }
Visual Basic (宣言)
Public Property BarColor As Color
    Get
    Set

プロパティ値

バーの色を表す Color。(既定値：Color.Black)

使用例

コピーC#
// バーの色を "赤色" に設定します。
barCode.BarColor = System.Drawing.Color.Red;
// バーコードデータを設定します。
barCode.Value = "91882391-2816";
コピーVB.NET
' バーの色を "赤色" に設定します。
barCode.BarColor = System.Drawing.Color.Red
' バーコードデータを設定します。
barCode.Value = "91882391-2816"

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


BarHeight プロパティ

[image]

Yubin7 Ver2.5
BarCode..::..BarHeight プロパティ
BarCode クラス 使用例 参照
バーコードの高さを設定、取得します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public double BarHeight { get; set; }
Visual Basic (宣言)
Public Property BarHeight As Double
    Get
    Set

プロパティ値

バーコードの高さを表す double。(既定値：0.0)

解説

プロパティ値が 0 の場合、バーコードの高さは自動で設定されます。

使用例

コピーC#
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode.Unit = AdvanceSoftware.Yubin7.BarCode.Unit.Millimeter;
// バーコードイメージの高さを "3.0mm" に設定します。
barCode.BarHeight = 3.0;
// バーコードデータを設定します。
barCode.Value = "91882391-2816";
コピーVB.NET
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode.Unit = AdvanceSoftware.Yubin7.BarCode.Unit.Millimeter
' バーコードイメージの高さを "3.0mm" に設定します。
barCode.BarHeight = 3.0
' バーコードデータを設定します。
barCode.Value = "91882391-2816"

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


BarWidth プロパティ

[image]

Yubin7 Ver2.5
BarCode..::..BarWidth プロパティ
BarCode クラス 使用例 参照
バーコードの幅を設定、取得します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public double BarWidth { get; set; }
Visual Basic (宣言)
Public Property BarWidth As Double
    Get
    Set

プロパティ値

バーコードの高さを表す double。(既定値：0.0)

解説

プロパティ値が 0 の場合、バーコードの幅は自動で設定されます。

使用例

コピーC#
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode.Unit = AdvanceSoftware.Yubin7.BarCode.Unit.Millimeter;
// バーコードイメージの幅を "80.0mm" に設定します。
barCode.BarWidth = 80.0;
// バーコードデータを設定します。
barCode.Value = "91882391-2816";
コピーVB.NET
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode.Unit = AdvanceSoftware.Yubin7.BarCode.Unit.Millimeter
' バーコードイメージの幅を "80.0mm" に設定します。
barCode.BarWidth = 80.0
' バーコードデータを設定します。
barCode.Value = "91882391-2816"

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


BlackRatio プロパティ

[image]

Yubin7 Ver2.5
BarCode..::..BlackRatio プロパティ
BarCode クラス 使用例 参照
黒バーの太さの比率を設定、取得します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public int BlackRatio { get; set; }
Visual Basic (宣言)
Public Property BlackRatio As Integer
    Get
    Set

プロパティ値

黒バーの太さの比率を表す int。(既定値：100)

解説

設定範囲：50 ～ 150

使用例

コピーC#
// 黒バーの太さ比率を "150%" に設定します。
barCode.BlackRatio = 150;
// バーコードデータを設定します。
barCode.Value = "91882391-2816";
コピーVB.NET
' 黒バーの太さ比率を "150%" に設定します。
barCode.BlackRatio = 150
' バーコードデータを設定します。
barCode.Value = "91882391-2816"

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


DpiX プロパティ

[image]

Yubin7 Ver2.5
BarCode..::..DpiX プロパティ
BarCode クラス 使用例 参照
X 軸方向の解像度を設定、取得します。(ピクセル単位)

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public double DpiX { get; set; }
Visual Basic (宣言)
Public Property DpiX As Double
    Get
    Set

プロパティ値

X 軸方向の解像度を表す double。(既定値：96.0)

使用例

コピーC#
barCode.Unit = AdvanceSoftware.Yubin7.BarCode.Unit.Pixel;
// X 軸方向の解像度を "600dpi" に設定します。
barCode.DpiX = 600;
// Y 軸方向の解像度を "600dpi" に設定します。
barCode.DpiY = 600;
// バーコードデータを設定します。
barCode.Value = "91882391-2816";
コピーVB.NET
barCode.Unit = AdvanceSoftware.Yubin7.BarCode.Unit.Pixel
' X 軸方向の解像度を "600dpi" に設定します。
barCode.DpiX = 600
' Y 軸方向の解像度を "600dpi" に設定します。
barCode.DpiY = 600
' バーコードデータを設定します。
barCode.Value = "91882391-2816"

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


DpiY プロパティ

[image]

Yubin7 Ver2.5
BarCode..::..DpiY プロパティ
BarCode クラス 使用例 参照
Y 軸方向の解像度を設定、取得します。(ピクセル単位)

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public double DpiY { get; set; }
Visual Basic (宣言)
Public Property DpiY As Double
    Get
    Set

プロパティ値

Y 軸方向の解像度を表す double。(既定値：96.0)

使用例

コピーC#
barCode.Unit = AdvanceSoftware.Yubin7.BarCode.Unit.Pixel;
// X 軸方向の解像度を "600dpi" に設定します。
barCode.DpiX = 600;
// Y 軸方向の解像度を "600dpi" に設定します。
barCode.DpiY = 600;
// バーコードデータを設定します。
barCode.Value = "91882391-2816";
コピーVB.NET
barCode.Unit = AdvanceSoftware.Yubin7.BarCode.Unit.Pixel
' X 軸方向の解像度を "600dpi" に設定します。
barCode.DpiX = 600
' Y 軸方向の解像度を "600dpi" に設定します。
barCode.DpiY = 600
' バーコードデータを設定します。
barCode.Value = "91882391-2816"

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


EmfType プロパティ

[image]

Yubin7 Ver2.5
BarCode..::..EmfType プロパティ
BarCode クラス 使用例 参照
拡張メタファイル(EMF)に格納されるレコードの品質を設定します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public EmfType EmfType { get; set; }
Visual Basic (宣言)
Public Property EmfType As EmfType
    Get
    Set

プロパティ値

拡張メタファイルのレコード品質を表す EmfType。(既定値：EmfType.EmfPlusDual)

使用例

コピーC#
// 拡張メタファイルのレコード品質を "EmfOnly" に設定します。
barCode.EmfType = System.Drawing.Imaging.EmfType.EmfOnly;
// バーコードデータを設定します。
barCode.Value = "91882391-2816";
Image barCodeImage = barCode.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf);
コピーVB.NET
' 拡張メタファイルのレコード品質を "EmfOnly" に設定します。
barCode.EmfType = System.Drawing.Imaging.EmfType.EmfOnly
' バーコードデータを設定します。
barCode.Value = "91882391-2816"
Dim barCodeImage As Image = barCode.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf)

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


ErrorMessage プロパティ

[image]

Yubin7 Ver2.5
BarCode..::..ErrorMessage プロパティ
BarCode クラス 使用例 参照
エラーメッセージを取得します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public string ErrorMessage { get; }
Visual Basic (宣言)
Public ReadOnly Property ErrorMessage As String
    Get

プロパティ値

バーコード生成時のエラーメッセージを表す string。

使用例

コピーC#
// バーコードデータを設定します。
barCode.Value = "91882391-2816";
// エラー処理
if (barCode.ErrorNo != AdvanceSoftware.Yubin7.BarCode.ErrorNo.NoError)
{
    // エラーメッセージを表示します。
    MessageBox.Show(barCode.ErrorMessage);
}
コピーVB.NET
' バーコードデータを設定します。
barCode.Value = "91882391-2816"
' エラー処理
If barCode.ErrorNo <> AdvanceSoftware.Yubin7.BarCode.ErrorNo.NoError Then
    ' エラーメッセージを表示します。
    MessageBox.Show(barCode.ErrorMessage)
End If

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


ErrorNo プロパティ

[image]

Yubin7 Ver2.5
BarCode..::..ErrorNo プロパティ
BarCode クラス 使用例 参照
エラーナンバーを取得します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public ErrorNo ErrorNo { get; }
Visual Basic (宣言)
Public ReadOnly Property ErrorNo As ErrorNo
    Get

プロパティ値

バーコード生成時のエラーナンバーを表す ErrorNo。

使用例

コピーC#
// バーコードデータを設定します。
barCode.Value = "91882391-2816";
// エラー処理
if (barCode.ErrorNo != AdvanceSoftware.Yubin7.BarCode.ErrorNo.NoError)
{
    // エラーメッセージを表示します。
    MessageBox.Show(barCode.ErrorMessage);
}
コピーVB.NET
' バーコードデータを設定します。
barCode.Value = "91882391-2816"
' エラー処理
If barCode.ErrorNo <> AdvanceSoftware.Yubin7.BarCode.ErrorNo.NoError Then
    ' エラーメッセージを表示します。
    MessageBox.Show(barCode.ErrorMessage)
End If

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


InternalValue プロパティ

[image]

Yubin7 Ver2.5
BarCode..::..InternalValue プロパティ
BarCode クラス 使用例 参照
整形後のバーコードデータを取得します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public string InternalValue { get; }
Visual Basic (宣言)
Public ReadOnly Property InternalValue As String
    Get

プロパティ値

整形後のバーコードデータを表す string。

使用例

コピーC#
// バーコードデータを設定します。
barCode.Value = "91882391-2816";
Image barCodeImage = barCode.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf);
// 整形後のバーコードデータを取得します。
string internalValue = barCode.InternalValue;
コピーVB.NET
' バーコードデータを設定します。
barCode.Value = "91882391-2816"
Dim barCodeImage As Image = barCode.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf)
' 整形後のバーコードデータを取得します。
Dim internalValue As String = barCode.InternalValue

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


Point プロパティ

[image]

Yubin7 Ver2.5
BarCode..::..Point プロパティ
BarCode クラス 使用例 参照
ポイントを設定、取得します。(郵便カスタマバーコード)

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public double Point { get; set; }
Visual Basic (宣言)
Public Property Point As Double
    Get
    Set

プロパティ値

バーコードのポイントを表す double。(既定値：8.0)

解説

設定範囲：8.0 ～ 20.0

使用例

コピーC#
// 郵便カスタマバーコードのポイントを "10.0" に設定します。
barCode.Point = 10.0;
// バーコードデータを設定します。
barCode.Value = "91882391-2816";
コピーVB.NET
' 郵便カスタマバーコードのポイントを "10.0" に設定します。
barCode.Point = 10.0
' バーコードデータを設定します。
barCode.Value = "91882391-2816"

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


Rotate プロパティ

[image]

Yubin7 Ver2.5
BarCode..::..Rotate プロパティ
BarCode クラス 使用例 参照
バーコードの回転方向を設定、取得します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public Rotate Rotate { get; set; }
Visual Basic (宣言)
Public Property Rotate As Rotate
    Get
    Set

プロパティ値

バーコードの回転方向を表す Rotate。(既定値：Rotate.Rotate0)

使用例

コピーC#
// バーコードイメージの向きを "時計回りで 90 度回転" に設定します。
barCode.Rotate = AdvanceSoftware.Yubin7.BarCode.Rotate.Rotate90;
// バーコードデータを設定します。
barCode.Value = "91882391-2816";
コピーVB.NET
' バーコードイメージの向きを "時計回りで 90 度回転" に設定します。
barCode.Rotate = AdvanceSoftware.Yubin7.BarCode.Rotate.Rotate90
' バーコードデータを設定します。
barCode.Value = "91882391-2816"

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


Unit プロパティ

[image]

Yubin7 Ver2.5
BarCode..::..Unit プロパティ
BarCode クラス 使用例 参照
バーコードの生成単位を設定、取得します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public Unit Unit { get; set; }
Visual Basic (宣言)
Public Property Unit As Unit
    Get
    Set

プロパティ値

バーコードの生成単位を表す Unit。(既定値：Unit.Pixel)

使用例

コピーC#
// バーコードイメージの生成単位を "ピクセル(px)" に設定します。
barCode.Unit = AdvanceSoftware.Yubin7.BarCode.Unit.Pixel;
// バーコードデータを設定します。
barCode.Value = "91882391-2816";
コピーVB.NET
' バーコードイメージの生成単位を "ピクセル(px)" に設定します。
barCode.Unit = AdvanceSoftware.Yubin7.BarCode.Unit.Pixel
' バーコードデータを設定します。
barCode.Value = "91882391-2816"

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


Value プロパティ

[image]

Yubin7 Ver2.5
BarCode..::..Value プロパティ
BarCode クラス 使用例 参照
バーコードデータを設定、取得します。(文字列)

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public string Value { get; set; }
Visual Basic (宣言)
Public Property Value As String
    Get
    Set

プロパティ値

バーコードデータを表す string。

解説

バーコードデータ以外に、住所を設定してバーコードを生成する事も可能です。

使用例

コピーC#
// バーコードデータを設定します。
barCode.Value = "91882391-2816";
コピーVB.NET
' バーコードデータを設定します。
barCode.Value = "91882391-2816"

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


BarCode イベント

[image] [image]

Yubin7 Ver2.5
BarCode イベント
BarCode クラス 参照

BarCode データ型で公開されるメンバを以下に示します。

イベント

 | 名前 | 説明
Public event | Error | バーコードの作成に失敗した時に発生します。

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


Error イベント

[image]

Yubin7 Ver2.5
BarCode..::..Error イベント
BarCode クラス 使用例 参照
バーコードの作成に失敗した時に発生します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public event BarCodeErrorEventHandler Error
Visual Basic (宣言)
Public Event Error As BarCodeErrorEventHandler

使用例

コピーC#
// バーコードクラスのインスタンス生成
AdvanceSoftware.Yubin7.BarCode.BarCode barCode = new AdvanceSoftware.Yubin7.BarCode.BarCode();
private void InitializeComponent()
{
    // バーコードクラスのエラーイベントに barCode_Error メソッドを関連付け
    barCode.Error += barCode_Error;
}
// エラーイベント
void barCode_Error(object sender, AdvanceSoftware.Yubin7.BarCode.BarCodeErrorEventArgs e)
{
    MessageBox.Show(barCode.ErrorMessage);
}
コピーVB.NET
' バーコードクラスのインスタンス生成(WithEvents)
Private WithEvents barCode As AdvanceSoftware.Yubin7.BarCode.BarCode = New AdvanceSoftware.Yubin7.BarCode.BarCode()
' エラーイベント
Private Sub barCode_Error(sender As Object, e As AdvanceSoftware.Yubin7.BarCode.BarCodeErrorEventArgs) Handles barCode.Error
    MessageBox.Show(barCode.ErrorMessage)
End Sub

参照

BarCode クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


BarCodeErrorEventArgs クラス

[image]

Yubin7 Ver2.5
BarCodeErrorEventArgs クラス
メンバ 参照
BarCode クラスの Error イベントのデータを提供します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public class BarCodeErrorEventArgs : EventArgs
Visual Basic (宣言)
Public Class BarCodeErrorEventArgs _
    Inherits EventArgs

継承階層

System..::..Object
System..::..EventArgs
AdvanceSoftware.Yubin7.BarCode..::..BarCodeErrorEventArgs

参照

BarCodeErrorEventArgs メンバ
AdvanceSoftware.Yubin7.BarCode 名前空間


BarCodeErrorEventArgs メンバ

[image] [image]

Yubin7 Ver2.5
BarCodeErrorEventArgs メンバ
BarCodeErrorEventArgs クラス コンストラクタ プロパティ 参照

BarCodeErrorEventArgs データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | BarCodeErrorEventArgs | 新しい BarCode クラスの Error イベントを初期化します。

プロパティ

 | 名前 | 説明
Public property | ErrorNo | エラーナンバーを処理します。(内部使用のみ。)

参照

BarCodeErrorEventArgs クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


BarCodeErrorEventArgs コンストラクタ

[image]

Yubin7 Ver2.5
BarCodeErrorEventArgs コンストラクタ
BarCodeErrorEventArgs クラス 参照
新しい BarCode クラスの Error イベントを初期化します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public BarCodeErrorEventArgs(
    ErrorNo errorNo
)
Visual Basic (宣言)
Public Sub New ( _
    errorNo As ErrorNo _
)

パラメータ

errorNo
Type: AdvanceSoftware.Yubin7.BarCode..::..ErrorNo
ErrorNo を指定します。

参照

BarCodeErrorEventArgs クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


BarCodeErrorEventArgs プロパティ

[image] [image]

Yubin7 Ver2.5
BarCodeErrorEventArgs プロパティ
BarCodeErrorEventArgs クラス 参照

BarCodeErrorEventArgs データ型で公開されるメンバを以下に示します。

プロパティ

 | 名前 | 説明
Public property | ErrorNo | エラーナンバーを処理します。(内部使用のみ。)

参照

BarCodeErrorEventArgs クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


ErrorNo プロパティ

[image]

Yubin7 Ver2.5
BarCodeErrorEventArgs..::..ErrorNo プロパティ
BarCodeErrorEventArgs クラス 参照
エラーナンバーを処理します。(内部使用のみ。)

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public ErrorNo ErrorNo { get; }
Visual Basic (宣言)
Public ReadOnly Property ErrorNo As ErrorNo
    Get

参照

BarCodeErrorEventArgs クラス
AdvanceSoftware.Yubin7.BarCode 名前空間


BarCodeErrorEventHandler デリゲート

[image]

Yubin7 Ver2.5
BarCodeErrorEventHandler デリゲート
参照
BarCode クラスの Error イベントを処理するメソッドを表します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public delegate void BarCodeErrorEventHandler(
    Object sender,
    BarCodeErrorEventArgs e
)
Visual Basic (宣言)
Public Delegate Sub BarCodeErrorEventHandler ( _
    sender As Object, _
    e As BarCodeErrorEventArgs _
)

パラメータ

sender
Type: System..::..Object
e
Type: AdvanceSoftware.Yubin7.BarCode..::..BarCodeErrorEventArgs

参照

AdvanceSoftware.Yubin7.BarCode 名前空間


BarCodeSize 構造体

[image]

Yubin7 Ver2.5
BarCodeSize 構造体
メンバ 参照
BarCodeSize 構造体

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public struct BarCodeSize
Visual Basic (宣言)
Public Structure BarCodeSize

参照

BarCodeSize メンバ
AdvanceSoftware.Yubin7.BarCode 名前空間


BarCodeSize メンバ

[image] [image]

Yubin7 Ver2.5
BarCodeSize メンバ
BarCodeSize 構造体 コンストラクタ フィールド 参照

BarCodeSize データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | BarCodeSize | コンストラクタ

フィールド

 | 名前 | 説明
Public field | Height | 高さ
Public field | Width | 幅

参照

BarCodeSize 構造体
AdvanceSoftware.Yubin7.BarCode 名前空間


BarCodeSize コンストラクタ

[image]

Yubin7 Ver2.5
BarCodeSize コンストラクタ
BarCodeSize 構造体 参照
コンストラクタ

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public BarCodeSize(
    int w,
    int h
)
Visual Basic (宣言)
Public Sub New ( _
    w As Integer, _
    h As Integer _
)

パラメータ

w
Type: System..::..Int32
幅。
h
Type: System..::..Int32
高さ。

参照

BarCodeSize 構造体
AdvanceSoftware.Yubin7.BarCode 名前空間


BarCodeSize フィールド

[image] [image]

Yubin7 Ver2.5
BarCodeSize フィールド
BarCodeSize 構造体 参照

BarCodeSize データ型で公開されるメンバを以下に示します。

フィールド

 | 名前 | 説明
Public field | Height | 高さ
Public field | Width | 幅

参照

BarCodeSize 構造体
AdvanceSoftware.Yubin7.BarCode 名前空間


Height フィールド

[image]

Yubin7 Ver2.5
BarCodeSize..::..Height フィールド
BarCodeSize 構造体 参照
高さ

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public int Height
Visual Basic (宣言)
Public Height As Integer

参照

BarCodeSize 構造体
AdvanceSoftware.Yubin7.BarCode 名前空間


Width フィールド

[image]

Yubin7 Ver2.5
BarCodeSize..::..Width フィールド
BarCodeSize 構造体 参照
幅

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public int Width
Visual Basic (宣言)
Public Width As Integer

参照

BarCodeSize 構造体
AdvanceSoftware.Yubin7.BarCode 名前空間


BarCodeSizeD 構造体

[image]

Yubin7 Ver2.5
BarCodeSizeD 構造体
メンバ 参照
BarCodeSizeD 構造体

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public struct BarCodeSizeD
Visual Basic (宣言)
Public Structure BarCodeSizeD

参照

BarCodeSizeD メンバ
AdvanceSoftware.Yubin7.BarCode 名前空間


BarCodeSizeD メンバ

[image] [image]

Yubin7 Ver2.5
BarCodeSizeD メンバ
BarCodeSizeD 構造体 コンストラクタ フィールド 参照

BarCodeSizeD データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | BarCodeSizeD | コンストラクタ

フィールド

 | 名前 | 説明
Public field | Height | 高さ
Public field | Width | 幅

参照

BarCodeSizeD 構造体
AdvanceSoftware.Yubin7.BarCode 名前空間


BarCodeSizeD コンストラクタ

[image]

Yubin7 Ver2.5
BarCodeSizeD コンストラクタ
BarCodeSizeD 構造体 参照
コンストラクタ

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public BarCodeSizeD(
    double w,
    double h
)
Visual Basic (宣言)
Public Sub New ( _
    w As Double, _
    h As Double _
)

パラメータ

w
Type: System..::..Double
幅。
h
Type: System..::..Double
高さ。

参照

BarCodeSizeD 構造体
AdvanceSoftware.Yubin7.BarCode 名前空間


BarCodeSizeD フィールド

[image] [image]

Yubin7 Ver2.5
BarCodeSizeD フィールド
BarCodeSizeD 構造体 参照

BarCodeSizeD データ型で公開されるメンバを以下に示します。

フィールド

 | 名前 | 説明
Public field | Height | 高さ
Public field | Width | 幅

参照

BarCodeSizeD 構造体
AdvanceSoftware.Yubin7.BarCode 名前空間


Height フィールド

[image]

Yubin7 Ver2.5
BarCodeSizeD..::..Height フィールド
BarCodeSizeD 構造体 参照
高さ

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public double Height
Visual Basic (宣言)
Public Height As Double

参照

BarCodeSizeD 構造体
AdvanceSoftware.Yubin7.BarCode 名前空間


Width フィールド

[image]

Yubin7 Ver2.5
BarCodeSizeD..::..Width フィールド
BarCodeSizeD 構造体 参照
幅

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public double Width
Visual Basic (宣言)
Public Width As Double

参照

BarCodeSizeD 構造体
AdvanceSoftware.Yubin7.BarCode 名前空間


ErrorNo 列挙体

[image]

Yubin7 Ver2.5
ErrorNo 列挙体
参照
エラーナンバーを示す識別子を指定します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public enum ErrorNo
Visual Basic (宣言)
Public Enumeration ErrorNo

メンバ

メンバ名 | 説明
NoError | エラーなし
Unit | Unit の設定に失敗しました。
Point | Point の設定に失敗しました。
Rotate | Rotate の設定に失敗しました。
DpiX | DpiX の設定に失敗しました。
DpiY | DpiY の設定に失敗しました。
BlackRatio | BlackRatio の設定に失敗しました。
BarHeight | BarHeight の設定に失敗しました。
BarWidth | BarWidth の設定に失敗しました。
Value | Value の設定に失敗しました。

参照

AdvanceSoftware.Yubin7.BarCode 名前空間


Rotate 列挙体

[image]

Yubin7 Ver2.5
Rotate 列挙体
参照
バーコードの回転方向を指定します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public enum Rotate
Visual Basic (宣言)
Public Enumeration Rotate

メンバ

メンバ名 | 説明
Rotate0 | 0 度
Rotate90 | 90 度
Rotate180 | 180 度
Rotate270 | 270 度

参照

AdvanceSoftware.Yubin7.BarCode 名前空間


Unit 列挙体

[image]

Yubin7 Ver2.5
Unit 列挙体
参照
バーコードの生成単位を指定します。

名前空間: AdvanceSoftware.Yubin7.BarCode
アセンブリ: Yubin7.BarCode (Yubin7.BarCode.dll 内) バージョン: 2.5.5270.1020 (2.5.5270.1020)

構文

C#
public enum Unit
Visual Basic (宣言)
Public Enumeration Unit

メンバ

メンバ名 | 説明
Pixel | ピクセル
Millimeter | ミリ
Inch | インチ
Point | ポイント

参照

AdvanceSoftware.Yubin7.BarCode 名前空間


BlackRatio プロパティ

[image]

Yubin7 Ver2.6
BlackRatio プロパティ

黒バーの太さの比率を設定、取得します。

構文

object.BlackRatio = nBlackRatio

プロパティ値

黒バーの太さの比率。(既定値：100%)

解説

カスタマバーコードイメージのバー色の濃さ(黒バーの太さの比率)を、100% を基準として設定します。値の取得も可能です。設定できる範囲は 50%～150% です。

参照

Access 用カスタマバーコードコントロール

©2014 Advance Software inc. All rights reserved.


DpiX プロパティ

[image]

Yubin7 Ver2.6
DpiX プロパティ

横方向の解像度を設定、取得します。

構文

object.DpiX = nDpiX

プロパティ値

横方向の解像度。(既定値：96.0)

解説

Unit プロパティで「ドット (dot)」を設定した場合、DpiX、DpiYプロパティで設定された解像度が有効になります。 DpiX プロパティには横方向の解像度を、DpiY プロパティには縦方向の解像度を設定します。カスタマバーコードを出力する機器(プリンターやディスプレイ等)の解像度を設定してください。例えば、出力するプリンタの解像度が縦方向 1440dpi、横方向 720dpi の設定で出力する場合、DpiY プロパティは、1440、DpiX プロパティは、720 を設定します。 また、出力するプリンターの解像度を縦横共に 600dpi の設定で出力する場合、DpiX、DpiYプロパティ共に 600 を設定します。

参照

Access 用カスタマバーコードコントロール

©2014 Advance Software inc. All rights reserved.


DpiY プロパティ

[image]

Yubin7 Ver2.6
DpiY プロパティ

縦方向の解像度を設定、取得します。

構文

object.DpiY = nDpiY

プロパティ値

縦方向の解像度。(既定値：96.0)

解説

Unit プロパティで「ドット (dot)」を設定した場合、DpiX、DpiYプロパティで設定された解像度が有効になります。 DpiX プロパティには横方向の解像度を、DpiY プロパティには縦方向の解像度を設定します。カスタマバーコードを出力する機器(プリンターやディスプレイ等)の解像度を設定してください。例えば、出力するプリンタの解像度が縦方向 1440dpi、横方向 720dpi の設定で出力する場合、DpiY プロパティは、1440、DpiX プロパティは、720 を設定します。 また、出力するプリンターの解像度を縦横共に 600dpi の設定で出力する場合、DpiX、DpiYプロパティ共に 600 を設定します。

参照

Access 用カスタマバーコードコントロール

©2014 Advance Software inc. All rights reserved.


Point プロパティ

[image]

Yubin7 Ver2.6
Point プロパティ

バーコードのサイズをポイントで設定、取得します。

構文

object.Point = nPoint

プロパティ値

バーコードのポイント。

解説

推奨値は、8 ～ 12 ポイントです。Unit プロパティで「ドット (dot)」を設定した場合、有効になり、DpiX、DpiYプロパティで設定された解像度を基に自動再計算します。

参照

Access 用カスタマバーコードコントロール

©2014 Advance Software inc. All rights reserved.


BlackRatio プロパティ

[image]

Yubin7 Ver2.6
Rotate プロパティ

バーコードの回転方向を設定、取得します。

構文

object.Rotate = nRotate

プロパティ値

バーコードの回転方向を表す Rotate。(既定値：rt0)

解説

基本的に、横方向の場合は「回転しない」、縦方向の場合は「270°回転」を設定します。

参照

Access 用カスタマバーコードコントロールプロパティ一覧

©2014 Advance Software inc. All rights reserved.


Unit プロパティ

[image]

Yubin7 Ver2.6
Unit プロパティ

バーコードの生成単位を設定、取得します。

構文

object.Unit = nUnit

プロパティ値

バーコードの生成単位を表す Unit。(既定値：dot)

解説

カスタマバーコードでサイズ設定に関する Point プロパティで使用する単位を設定します。Unit プロパティで「ドット (dot)」を設定した場合、Point プロパティの設定値は、DpiX、DpiYプロパティに設定された解像度を基に自動再計算されます。

参照

Access 用カスタマバーコードコントロール

©2014 Advance Software inc. All rights reserved.