VB-BarCode 5.0 for .NET の概要

[image]

VB-BarCode 5.0 for .NET
VB-BarCode 5.0 for .NET の概要

VB-BarCode 5.0 for .NET は、.NET Framework に完全対応した高精度バーコード生成コンポーネントです。 100 % マネージコードで実装したコンパクトなコンポーネントなので、Windows フォームアプリケーションや ASP.NET Web、WPF アプリケーションなどで、簡単にバーコードを追加して高精度なイメージを出力することができます。新たに SVG 形式のバーコード出力にも対応しております。

システム動作環境

VB-BarCode 5.0 for .NET の動作環境を説明します。

製品のインストールとアンインストール

VB-BarCode 5.0 for .NET のインストールとアンインストールする方法を説明します。

体験版について

VB-BarCode 5.0 for .NET の体験版について説明します。

アプリケーションのライセンス体系

VB-BarCode 5.0 for .NET のライセンス体系を説明します。

サポートサービス

VB-BarCode 5.0 for .NET のサポートサービスを説明します。

サンプル

VB-BarCode 5.0 for .NET の付属サンプルの格納先を説明します。

VB-BarCode 5.0 for .NET ヘルプ フィードバック

このヘルプについてのご提案や障害報告をお送りいただく場合は、弊社 Web サイトのユーザーサポートフォームよりご連絡ください。

  • ドキュメントに表記されている会社名、製品名は一般に各社の商標または登録商標です。
  • 製品の仕様は品質改良の為、予告なく変更することがあります。

©2020 Advance Software inc. All rights reserved.


システム動作環境

[image]

VB-BarCode 5.0 for .NET
システム動作環境

VB-BarCode 5.0 for .NET の動作環境を次に示します。

このトピックは、次のセクションを含みます。

  • 開発環境
  • 実行環境
メモ:

開発、実行環境すべて日本語環境のみサポートします。

開発環境

OS

Windows 8.1/10
Windows Server 2012/2012 R2/2016/2019

ハードディスク

300MB 以上の空き容量が必要です。

メモリ

2GB 以上の利用可能メモリが必要です。

Visual Studio

Visual Studio 2012/2013/2015/2017/2019

開発言語

Visual Basic.NET、Visual C＃

実行環境

OS

Windows 8.1/10
Windows Server 2012/2012 R2/2016/2019

.NET Framework

.NET Framework 4.5.2/4.6/4.6.1/4.6.2/4.7/4.7.1/4.7.2/4.8

参照

VB-BarCode 5.0 for .NET の概要

©2020 Advance Software inc. All rights reserved.


製品のインストールとアンインストール

[image]

VB-BarCode 5.0 for .NET
製品のインストールとアンインストール

VB-BarCode 5.0 for .NET のインストールで登録されるアセンブリ一覧、および、アンインストール方法を説明します。

このトピックは、次のセクションを含みます。

  • VB-BarCode 5.0 for .NET アセンブリ一覧
  • 製品のアンインストール

VB-BarCode 5.0 for .NET アセンブリ一覧

VB-BarCode 5.0 for .NET のインストールプログラムによって、グローバル アセンブリ キャッシュへ登録される DLL 一覧を以下に記載します。

グローバルアセンブリ名 | アセンブリファイル名
VBBarCode.BarCode.v5 | VBBarCode.BarCode.v5.dll
VBBarCode.Wpf.BarCode.v5 | VBBarCode.Wpf.BarCode.v5.dll
メモ:

一覧にあるアセンブリは、VB-BarCode 5.0 for .NET インストールフォルダ内の Bin フォルダにインストールされます。

インストールプログラムによって登録されない場合は、「アプリケーションの配布」の [再配布可能ファイルの配置] にある方法でグローバル アセンブリ キャッシュへの登録を行ってください。

製品のアンインストール

本製品をアンインストールする場合、下記のいずれかの手順で対応してください。

スタートメニューからアンインストールするには

  1. [スタート] メニューの [プログラム] - [VB-BarCode 5.0 for .NET] - [アンインストール] をクリックします。

  2. 画面に従い、アンインストールを実行します。

「プログラムの追加と削除」からアンインストールするには

  1. [スタート] メニューの [コントロール パネル] をクリックします。

  2. [プログラムと機能] をクリックします。

  3. 一覧の [VB-BarCode 5.0 for .NET] を右クリックして、[アンインストールと変更] をクリックします。

  4. 画面に従い、アンインストールを実行します。

メモ:

インストール後に製品のファイルを移動した場合や、INSTALL.LOG ファイルを削除した場合、アンインストールされません。 また、製品に収録されているサンプル プロジェクトなど、Visual Studio によって作成、編集されたファイルについては、アンインストールできません。

参照

VB-BarCode 5.0 for .NET の概要
アプリケーションの配布


体験版について

[image]

VB-BarCode 5.0 for .NET
体験版について

VB-BarCode 5.0 for .NET 体験版は、製品版と同様に全ての機能をお試しいただくことが可能ですが、以下の制限事項がございます。

制限事項

  • 作成されるバーコードイメージの一部に、「Advance Software」と出力されます。このため、体験版で印刷したバーコードを読み取ることができない場合があります。
  • 体験版の DLL は実行環境での動作検証以外の目的で配布することはできません。

注意:

製品版をインストールする場合、体験版を必ずアンインストールしてからインストールを実行してください。

参照

VB-BarCode 5.0 for .NET の概要

©2020 Advance Software inc. All rights reserved.


アプリケーションのライセンス体系

[image]

VB-BarCode 5.0 for .NET
アプリケーションのライセンス体系

VB-BarCode 5.0 for .NET を組み込んだアプリケーションの配布は、アプリケーションの種類によりライセンス体系が異なります。

このトピックは、次のセクションを含みます。

  • クライアントアプリケーション
  • サーバーアプリケーション

クライアントアプリケーション

ロイヤリティーフリーで配布することができます。

サーバーアプリケーション

VB-BarCode 5.0 for .NET を使用して作成したアプリケーションを運用するサーバーに対し、サーバーライセンスが必要です。

サーバーライセンス

必要条件 | VB-BarCode 5.0 for .NET アセンブリを使用したサーバーアプリケーションを運用する場合に必要なサーバーライセンスです。
価格 | 1 ライセンスあたり / 120,000円 (税込 132,000円)
商品構成 | ライセンス数や契約内容を記載した契約書(ライセンス証書)のみになります。
保守 | 保守契約が必要となる場合、サーバーライセンス保守契約(年間)の購入が必要になります。
お問い合わせ | サーバーライセンス、サーバーライセンス保守契約のお申し込みやお問い合わせは、「サポートサービス」よりお問い合わせください。
Note メモ:
保守付きのサーバーライセンスもご用意しております。詳しくは、お問い合わせください。

参照

VB-BarCode 5.0 for .NET の概要
サポートサービス


サポートサービス

[image]

VB-BarCode 5.0 for .NET
サポートサービス

VB-BarCode 5.0 for .NET の Readme、および、ヘルプに記述されていない事項、または動作に関するご不明な点などについては、サポートサービスをご利用ください。

このトピックは、次のセクションを含みます。

  • お問い合わせについて
  • ユーザー登録について
  • お問い合わせいただく前に
  • お問い合わせ窓口

お問い合わせについて

VB-BarCode 5.0 for .NET 以外の事柄やプログラミング技法など一般的なご質問、または、動作保証環境外での使用によるご質問にはお答えいたしかねます。あらかじめ、ご了承ください。

ユーザー登録について

サポートサービスをご利用いただくにあたり、製品のユーザー登録が必要になります。 登録されていない場合は、サポートサービスを利用できませんので、お問合せいただく前に必ずユーザー登録を行ってください。 ユーザー登録は、製品に同梱されているユーザー登録カードに、必要事項を記入してご郵送いただくか、弊社 Web サイトの ユーザー登録ページ からもご登録いただくことができます。

お問い合わせいただく前に

サポートサービスでは下記の情報が必要になります。 お問い合わせいただく前に、あらかじめこれらの情報をご用意ください。 なお、弊社 Web サイトのサポート情報の内容により解決いただける場合もございます。 お問い合わせいただく前に、弊社 Web サイトの サポート情報 の内容をもう一度ご確認ください。

ユーザー情報

  1. VB-BarCode 5.0 for .NET のシリアルナンバー (製品パッケージ内「インストール情報」という用紙に記載されています。)
  2. 会社名
  3. 部署名
  4. 担当者名
  5. 連絡先 (電話番号)
  6. FAX 番号
  7. E-Mail アドレス

お問い合わせ内容

  1. 製品名
  2. VB-BarCode 5.0 for .NET の詳細バージョン
  3. 使用マシンの OS
  4. OS のサービスパック
  5. .NET Framework のバージョンとサービスパックのバージョン
  6. Visual Studio のバージョンとサービスパックのバージョン
  7. アプリケーションを実行する Internet Explorer のバージョン

問題となっている現象の内容

  1. 現象の詳細内容
  2. 現象発生までの経緯
  3. 現象発生箇所
  4. 現象を再現できる簡単なプロジェクト一式、もしくは、コーディングの一部

お問い合わせ窓口

サポートサービスは、電話、FAX、E-Mail で受け付けております。 また、弊社 Web サイトの お問い合わせ窓口では、ユーザーサポートフォームを用意しています。あわせてご確認ください。 月曜日～金曜日 (祝祭日、弊社特別休業日を除く) にご利用いただけます。 また、営業日以外にいただいた FAX / E-Mail でのお問い合わせは、翌営業日に回答いたします。

製品の操作方法や仕様に関するお問い合わせ窓口

電話番号 | 0776-21-9172
FAX 番号 | 0776-21-9022
E-Mail | vb-barcode@adv.co.jp
受付時間 | 10：00 ～ 12：00 / 13：30 ～ 17：00

製品の営業に関するお問い合わせ窓口

電話番号 | 0776-21-9008
FAX 番号 | 0776-21-9022
E-Mail | info@adv.co.jp
受付時間 | 9：00 ～ 12：00 / 13：00 ～ 18：00

参照

VB-BarCode 5.0 for .NET の概要

©2020 Advance Software inc. All rights reserved.


VB-BarCode 5.0 for .NET 対応バーコード一覧

[image]

VB-BarCode 5.0 for .NET
VB-BarCode 5.0 for .NET 対応バーコード一覧
参照

VB-BarCode 5.0 for .NET で設定可能なバーコード一覧を以下に示します。 作成したバーコードイメージは、イメージファイルとして出力したり、直接印刷することができます。

このトピックは、次のセクションを含みます。

  • JAN コード
  • UPC コード
  • ITF コード
  • Codabar (NW-7)
  • Code39
  • Code128
  • GS1-128 (旧称 : UCC/EAN128)
  • 公共料金等代理収納 GS1-128
  • 郵便カスタマバーコード
  • QR コード
  • PDF417

Note メモ:

各バーコードの作成方法は、バーコードタイプ別の作成方法を参照してください。

JAN コード

JAN13 (標準バージョン 13 桁)

JAN8 (短縮バージョン 8 桁)

UPC コード

UPC-A (A バージョン)

UPC-E (E バージョン)

ITF コード

ITF-6 (アドオンバージョン 6 桁)

ITF-14 (標準バージョン 14 桁)

ITF-16 (拡張バージョン 16 桁)

ITF (自由桁)

Codabar (NW-7)

Code39

Code128

GS1-128 (旧称 : UCC/EAN128)

公共料金等代理収納 GS1-128

郵便カスタマバーコード

QR コード

モデル 1

モデル 2

「QR コード」は、株式会社デンソーウェーブの登録商標です。

PDF417

標準

簡易

参照

VB-BarCode 5.0 for .NET の概要

©2020 Advance Software inc. All rights reserved.


サンプル

[image]

VB-BarCode 5.0 for .NET
サンプル
参照

VB-BarCode 5.0 for .NET には、Visual Basic、および、Visual C# で作成したサンプルファイルが付属しています。

VB-BarCode 5.0 for .NET のサンプルファイルは、Visual Studio 2012 / 2013 / 2015 / 2017 / 2019 共通で使用できるサンプルファイルがインストールされます。 また、VB-BarCode 5.0 for .NET をアンインストールすると、サンプルファイルも削除されます。

開発言語ごとにサンプルファイルの既定の場所を以下の表に示します。 %install% は、VB-BarCode 5.0 for .NET のインストールフォルダ (C:\Program Files\VB-BarCode5\ など) を表します。

サンプルファイルの種類 | サンプルファイルの場所
Visual Basic Windows サンプル(WindowsSample) | \%install%\Samples\VB\WindowsSample
Visual Basic WPF サンプル(WpfSample) | \%install%\Samples\VB\WpfSample
Visual Basic ASP.NET Web フォーム サンプル(AspNetSample) | \%install%\Samples\VB\AspNetSample
Visual C# Windows サンプル(WindowsSample) | \%install%\Samples\CS\WindowsSample
Visual C# WPF サンプル(WpfSample) | \%install%\Samples\CS\WpfSample
Visual C# ASP.NET Web フォーム サンプル(AspNetSample) | \%install%\Samples\CS\AspNetSample

参照

VB-BarCode 5.0 for .NET の概要
アプリケーションの配布


アプリケーションの配布

[image]

VB-BarCode 5.0 for .NET
アプリケーションの配布

ここでは、VB-BarCode 5.0 for .NET の再配布可能ファイルや再配布方法について説明します。

再配布可能ファイルについて

VB-BarCode 5.0 for .NET の再配布可能ファイルについて説明します。

Windows フォーム アプリケーションの配布方法

Windows フォーム アプリケーションの配布方法を説明します。

Web アプリケーションの配布方法

Web アプリケーションの配布方法を説明します。


再配布可能ファイルについて

[image]

VB-BarCode 5.0 for .NET
再配布可能ファイルについて

VB-BarCode 5.0 for .NET を使用して作成したアプリケーションを配布する場合、以下の再配布可能ファイルをアプリケーションと一緒に配布してください。

このトピックは、次のセクションを含みます。

  • 再配布可能ファイル
  • 再配布可能ファイルの格納場所
  • 再配布の条件

再配布可能ファイル

ファイル名 | 内容
VBBarCode.BarCode.v5.dll | バーコードコンポーネント
VBBarCode.Wpf.BarCode.v5.dll | WPF 用バーコードコンポーネント
VBBarCode.BarCode.v5.resources.dll | 英語対応リソースアセンブリ
VBBarCode.Wpf.BarCode.v5.resources.dll | 英語対応リソースアセンブリ(WPF)

再配布可能ファイルの格納場所

再配布可能ファイル (DLL) は、インストールフォルダ内の下記のフォルダに格納されます。

<%Install%>Bin

メモ:
%install% は、VB-BarCode 5.0 for .NET のインストールフォルダ (C:Program Files\VB-BarCode5\ など) を表します。

再配布の条件

本製品の使用許諾

本製品を VB-BarCode 5.0 for .NET 自体の販売の妨げになる可能性を持つ類似製品に組み込んで、配布することはできません。なお、再配布するアプリケーションの種類によってライセンス形態が以下のように異なります。

  • クライアントアプリケーションとして再配布する場合

    本製品を組み込んで作成したプログラムを、ロイヤリティフリーでクライアント環境に配布することができます。

  • サーバーアプリケーションとして再配布する場合

    配布するサーバー環境(OS)分の「サーバーライセンス」が必要となります。

    • 著作権表示

    本製品は、アドバンスソフトウェア株式会社が有する著作権により保護されております。
    本製品を配布する際、可能な限り、アドバンスソフトウェアの著作権表示をしていただく必要があります。著作権表示は以下の通りに表示してください。

  • パッケージ (店頭などに配置する形態の製品の梱包物のこと) に対する表示方法

    本製品は、アドバンスソフトウェア株式会社の著作物である「VB-BarCode 5.0 for .NET」を再配布条件に基づき使用しています。

  • マニュアル、またはこれに類する物への表示方法

    本製品は、アドバンスソフトウェア株式会社の著作物である「VB-BarCode 5.0 for .NET」を再配布条件に基づき使用しています。

  • プログラム使用許諾契約書、またはこれに類する物への表示方法

    本製品は、アドバンスソフトウェア株式会社の著作物である「VB-BarCode 5.0 for .NET」を再配布条件に基づき使用しています。 アドバンスソフトウェア株式会社の著作物はバックアップの目的以外では一切の複写を許可しません。

    • 再配布先のサポート

    再配布先のサポートについては、一切行いません。サポートは再配布元であるお客様において行ってください。なお、サーバーライセンスを取得した配布先の弊社製品に関するサポートは、サーバーライセンスの保守契約が必要になります。サーバーライセンスの保守契約の詳細やお申し込みについては、「サポートサービス」よりお問い合わせください。


クライアントアプリケーションを配布する

[image]

VB-BarCode 5.0 for .NET
クライアントアプリケーションを配布する
参照

クライアントアプリケーション(Windows フォームアプリケーション、WPF アプリケーション等)を配布する手順を以下に示します。

配布するアプリケーションをビルドする

  1. Visual Studio でソリューションからアプリケーションを開き、ビルドします。

    メモ:

    アプリケーションでビルド時に参照されている再配布可能ファイル(DLL)と実際に実行環境に配布する再配布可能ファイル(DLL)のアセンブリバージョンは同一である必要があります。

再配布可能ファイルを配布するには

  • アプリケーションと同じフォルダにコピーする方法

    アプリケーションフォルダ内に [Bin] フォルダを作成し、VB-BarCode 5.0 for .NET の再配布可能ファイル(DLL)一式をアプリケーション(EXE等)と同じフォルダ内にコピーします。

  • gacutil.exe を使用してグローバルアセンブリキャッシュ(GAC)へ登録する方法

    .NET Framework SDK のグローバルアセンブリキャッシュツール (gacutil.exe) を使用して登録します。 コマンドプロンプト、または「ファイル名を指定して実行」ダイアログボックスで以下のように実行します。

    コピー登録例
    C:\gacutil.exe /i "C:\Program Files\Application\VBBarCode.BarCode.v5.dll"

    登録例は、gacutil.exe が C ドライブのルートに存在し、VB-BarCode 5.0 for .NET の再配布可能ファイル(VBBarCode.BarCode.v5.dll) が C:\Program Files\Application フォルダにあると仮定しています。また、登録を解除する場合、以下のように実行します。

    コピー 解除例
    C:\gacutil.exe /u "VBBarCode.BarCode.v5"
    メモ:

    登録の解除は、dll ファイル名ではなくアセンブリ名を指定します。

  • Windows エクスプローラ上でグローバルアセンブリキャッシュ (GAC) へ登録する方法

    VB-BarCode 5.0 for .NET のアセンブリは、Windows エクスプローラ上で、グローバルアセンブリキャッシュ (例：C:\Windows\assembly) にドラッグ アンド ドロップすることが可能です。なお、グローバルアセンブリキャッシュの登録や解除方法の詳細については、Visual Studio のオンラインヘルプを参照してください。

    Note 注意:

    環境によってはこの方法で登録できない場合があります。

    • 参照

    アプリケーションの配布

    ©2020 Advance Software inc. All rights reserved.


Web アプリケーションを配布する

[image]

VB-BarCode 5.0 for .NET
Web アプリケーションを配布する
参照

Web アプリケーションの配布について、VB-BarCode 5.0 for .NET サンプルの Web サンプル (AspNetSample) を使用し、IIS マネージャを起動して Web アプリケーションの仮想ディレクトリを作成する手順を以下に示します。

Caution note 注意:

このトピックの手順で Web アプリケーションを配布する場合、ローカル コンピュータに インターネット インフォメーション サービス (IIS) がインストールされている必要があります。また、ローカル コンピュータの Administrators グループのメンバとしてログオンするか、適切な権限が委任されている必要があります。

配布するアプリケーションをビルドする

  1. Visual Studio でソリューションからアプリケーションを開き、ビルドします。

    メモ:

    アプリケーションでビルド時に参照されている再配布可能ファイル(DLL)と実際に実行環境に配布する再配布可能ファイル(DLL)のアセンブリバージョンは同一である必要があります。

[ファイル名を指定して実行] から IIS マネージャを起動するには

  1. [スタート] メニューの [ファイル名を指定して実行] をクリックします。

  2. [名前] ボックスに "inetmgr" と入力して [OK] ボタンをクリックします。

[管理ツール] から IIS マネージャを起動するには

  1. [スタート] メニューの [コントロール パネル] をクリックします。

  2. [管理ツール] 内の [インターネット インフォメーション サービス] をクリックします。

仮想ディレクトリを作成するには (IIS 7.5)

  1. 次の Web サンプルのインストールフォルダ内に格納されているソリューションファイル (WebFormBasic.sln) からプロジェクトを開き、Visual Studio 上でサンプルをビルドします。

    Visual Basic
    \%install%\Samples\VB\AspNetSample
    Visual C#
    \%install%\Samples\CS\AspNetSample

  2. IIS マネージャで、仮想ディレクトリを追加するローカル コンピュータおよび Web サイトを展開します。仮想ディレクトリを作成するサイトまたはフォルダを右クリックし、[仮想ディレクトリの追加] をクリックして、[仮想ディレクトリの追加] 画面を表示します。

  3. [エイリアス] ボックスに、仮想ディレクトリの名前 "AspNetSample" を入力します。

  4. [物理パス] ボックスのボタン ( ボタン02) をクリックして、[フォルダの参照] 画面を表示します。

  5. 次の Web サンプルのインストールフォルダを選択して [OK] ボタンをクリックします。

    Visual Basic
    \%install%\Samples\VB\AspNetSample
    Visual C#
    \%install%\Samples\CS\AspNetSample
    Note メモ:

    %install% は、VB-BarCode 5.0 for .NET のインストールフォルダ (C:\Program Files\VB-BarCode5\ など) を表します。

  6. 追加した仮想ディレクトリ "WebSample" を右クリックして、[アプリケーションへの変換] をクリックします。

  7. [アプリケーションの追加] 画面の [OK] ボタンをクリックします。

  8. IIS マネージャを終了します。

再配布可能ファイルを配布するには

  • アプリケーションと同じフォルダにコピーする方法

    アプリケーションフォルダ内に [Bin] フォルダを作成し、VB-BarCode 5.0 for .NET の再配布可能ファイル(DLL)一式をフォルダ内にコピーします。

  • gacutil.exe を使用してグローバルアセンブリキャッシュ (GAC) へ登録する方法

    .NET Framework SDK のグローバルアセンブリキャッシュツール (gacutil.exe) を使用して登録します。 コマンドプロンプト、または「ファイル名を指定して実行」ダイアログボックスで以下のように実行します。

    コピー登録例
    C:\gacutil.exe /i "C:\Program Files\Application\VBBarCode.BarCode.v5.dll"

    登録例は、gacutil.exe が C ドライブのルートに存在し、VB-BarCode 5.0 for .NET の再配布可能ファイル(VBBarCode.BarCode.v5.dll) が C:\Program Files\Application フォルダにあると仮定しています。また、登録を解除する場合、以下のように実行します。

    コピー 解除例
    C:\gacutil.exe /u "VBBarCode.BarCode.v5"
    メモ:

    登録の解除は、dll ファイル名ではなくアセンブリ名を指定します。

  • Windows エクスプローラ上でグローバルアセンブリキャッシュ (GAC) へ登録する方法

    VB-BarCode 5.0 for .NET のアセンブリは、Windows エクスプローラ上で、グローバルアセンブリキャッシュ (例：C:\Windows\assembly) にドラッグ アンド ドロップすることが可能です。なお、グローバルアセンブリキャッシュの登録や解除方法の詳細については、Visual Studio のオンラインヘルプを参照してください。

    Note 注意:

    環境によってはこの方法で登録できない場合があります。

    • 参照

    アプリケーションの配布

    ©2020 Advance Software inc. All rights reserved.


使用準備
参照

Visual Studio のプロジェクトで、VB-BarCode 5.0 for .NET を使用するための手順をこのトピックで説明します。 VB-BarCode 5.0 for .NET では、使用するアプリケーションによってプロジェクトに組み込むアセンブリが下記のように異なります。

ファイル名 | 説明
VBBarCode.BarCode.v5.dll | Windows、ASP.NET Web アプリケーションで使用します。
VBBarCode.Wpf.BarCode.v5.dll | WPF アプリケーションで使用します。
上記アセンブリをバーコードコントロール、バーコードコンポーネントとして各アプリケーションで使用する方法については、 下記の内容を参照してください。

バーコードコントロールを追加する

Windows フォーム アプリケーションでバーコードコントロールを追加する

Windows フォーム アプリケーションでバーコードコントロールとして使用する手順について説明します。

WPF アプリケーションでバーコードコントロールを追加する

WPF アプリケーションでバーコードコントロールとして使用する手順について説明します。

バーコードコンポーネントを追加する

Windows フォーム アプリケーションでバーコードコンポーネントを追加する

Windows フォーム アプリケーションでバーコードコンポーネントとして使用する手順について説明します。

ASP.NET Web アプリケーションでバーコードコンポーネントを追加する

ASP.NET Web アプリケーションでバーコードコンポーネントとして使用する手順について説明します。

WPF アプリケーションでバーコードコンポーネントを追加する

WPF アプリケーションでバーコードコンポーネントとして使用する手順について説明します。

参照

使用準備

©2020 Advance Software inc. All rights reserved.


Windows フォーム アプリケーションでバーコードコントロールを追加する

[image]

VB-BarCode 5.0 for .NET
Windows フォーム アプリケーションでバーコードコントロールを追加する
参照

このトピックでは、Windows フォーム アプリケーションでバーコードコントロールを追加する方法を説明します。

ツールボックスにコントロールを登録するには

  1. [表示] メニューの [ツールボックス] をクリックしてツールボックスを表示します。

  2. ツールボックスにカーソルを合わせて右クリックし、[タブの追加] をクリックしてコントロールを追加するタブを作成します。この手順ではタブ名を 「AdvanceSoftware」 とします。

  3. 追加したタブにカーソルを合わせて上で右クリックし、[アイテムの選択] をクリックして [ツールボックス アイテムの選択] ダイアログを表示します。

  4. [.NET Framework コンポーネント] タブを選択し、次のチェックボックスをオンにして [OK] ボタンをクリックします。

  5. 次のコントロールが追加されます。

フォームに配置するには

  1. ツールボックスを表示し、追加したコントロールをフォームにドラッグ アンド ドロップします。

  2. コントロールをフォームに配置した後、参照設定に次の内容が追加されます。

    3. 追加される内容
    VBBarCode.BarCode.v5

参照

使用準備

©2020 Advance Software inc. All rights reserved.


WPF アプリケーションでバーコードコントロールを追加する

[image]

VB-BarCode 5.0 for .NET
WPF アプリケーションでバーコードコントロールを追加する
参照

このトピックでは、WPF アプリケーションでバーコードコントロールを追加する方法を説明します。

ツールボックスにコンポーネントを登録するには

  1. [表示] メニューの [ツールボックス] をクリックしてツールボックスを表示します。

  2. ツールボックスにカーソルを合わせて右クリックし、[タブの追加] をクリックしてコンポーネントを追加するタブを作成します。この手順ではタブ名を 「AdvanceSoftware」 とします。

  3. 追加したタブにカーソルを合わせて上で右クリックし、[アイテムの選択] をクリックして [ツールボックス アイテムの選択] ダイアログを表示します。

  4. [WPF コンポーネント] タブを選択し、次のチェックボックスをオンにして [OK] ボタンをクリックします。

  5. 次のコントロールが追加されます。

フォームに配置するには

  1. ツールボックスを表示し、追加したコントロールをフォームにドラッグ アンド ドロップします。

  2. コントロールをフォームに配置した後、参照設定に次の内容が追加されます。

    3. 追加される内容
    VBBarCode.Wpf.BarCode.v5

参照

使用準備

©2020 Advance Software inc. All rights reserved.


ASP.NET Web アプリケーションでバーコードコントロールを追加する

[image]

VB-BarCode 5.0 for .NET
ASP.NET Web アプリケーションでバーコードコントロールを追加する
参照

このトピックでは、ASP.NET Web アプリケーションでバーコードコントロールを追加する方法を説明します。

ツールボックスにコンポーネントを登録するには

  1. [表示] メニューの [ツールボックス] をクリックしてツールボックスを表示します。

  2. ツールボックスにカーソルを合わせて右クリックし、[タブの追加] をクリックしてコンポーネントを追加するタブを作成します。この手順ではタブ名を 「AdvanceSoftware」 とします。

  3. 追加したタブにカーソルを合わせて上で右クリックし、[アイテムの選択] をクリックして [ツールボックス アイテムの選択] ダイアログを表示します。

  4. [.NET Framework コンポーネント] タブを選択し、次のチェックボックスをオンにして [OK] ボタンをクリックします。

  5. 次のコンポーネントが追加されます。

フォームに配置するには

  1. ツールボックスを表示し、追加したコンポーネントをフォームにドラッグ アンド ドロップします。

  2. コンポーネントをフォームに配置した後、参照設定に次の内容が追加されます。

    3. 追加される内容
    VBBarCode.BarCode.v5

参照

使用準備

©2020 Advance Software inc. All rights reserved.


Windows フォーム アプリケーションでバーコードコンポーネントを追加する

[image]

VB-BarCode 5.0 for .NET
Windows フォーム アプリケーションでバーコードコンポーネントを追加する
参照

このトピックでは、Windows フォーム アプリケーションにてバーコードコンポーネントを追加する方法を説明します。

このトピックは、次のセクションを含みます。

  • ツールボックスから追加する
  • 参照設定から追加する

ツールボックスから追加する

このセクションでは、Visual Studio のツールボックスに バーコードコンポーネントを登録し、フォームに配置する方法を説明します。

バーコードコンポーネントをツールボックスから追加するには

  1. [表示] メニューの [ツールボックス] をクリックしてツールボックスを表示します。

  2. ツールボックスにカーソルを合わせて右クリックし、[タブの追加] をクリックして コンポーネントを追加するタブを作成します。この手順ではタブ名を 「AdvanceSoftware」 とします。

  3. 追加したタブにカーソルを合わせて上で右クリックし、[アイテムの選択] をクリックして [ツールボックス アイテムの選択] ダイアログを表示します。

  4. [.NET Framework コンポーネント] タブを選択し、次のチェックボックスをオンにして [OK] ボタンをクリックします。

  5. 次のコンポーネントが追加されます。

フォームに配置するには

  1. ツールボックスを表示し、追加したコンポーネントをフォームにドラッグ アンド ドロップします。

  2. コンポーネントをフォームに配置した後、参照設定に次の内容が追加されます。

    3. 追加される内容
    VBBarCode.BarCode.v5

参照設定から追加する

このセクションでは、Visual Studio のソリューション エクスプローラー上で コンポーネントの参照を追加し、コード上でインスタンスを生成する方法を説明します。

コンポーネントの参照を追加するには

  1. [表示] メニューの [ソリューション エクスプローラー] をクリックしてソリューション エクスプローラーを表示します。

  2. ソリューション エクスプローラーのプロジェクトを右クリックし、[追加] - [参照] をクリックして [参照マネージャー] ダイアログを表示します。

  3. [アセンブリ] - [拡張] タブで、次のコンポーネント名を選択して [OK] ボタンをクリックします。

    コンポーネント名
    AdvanceSoftware.VBBarCode

  4. 参照設定に次の内容が追加されます。

    追加される内容
    VBBarCode.BarCode.v5

コード上でインスタンスを生成するには

  1. 次のコードを追加します。

    コピー C#
    private AdvanceSoftware.VBBarCode.BarCode barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
    コピー VB.NET
    Private WithEvents BarCode1 As New AdvanceSoftware.VBBarCode.BarCode

  2. エラーイベントは次のように追加します。

    コピー C#
    private void Form1_Load(object sender, EventArgs e)
{
    barCode1.Error +=
       new AdvanceSoftware.VBBarCode.BarCodeErrorEventHandler(
       this.barCode1_Error);
}

private void barCode1_Error(object sender,
    AdvanceSoftware.VBBarCode.BarCodeErrorEventArgs e)
{
    // ここにエラー発生時の処理を追加します。
}
    コピー VB.NET
    Private Sub BarCode1_Error(ByVal sender As Object, _
    ByVal e As AdvanceSoftware.VBBarCode.BarCodeErrorEventArgs) _
    Handles BarCode1.Error

    ' ここにエラー発生時の処理を追加します。
End Sub

参照

使用準備

©2020 Advance Software inc. All rights reserved.


WPF アプリケーションでバーコードコンポーネントを追加する

[image]

VB-BarCode 5.0 for .NET
WPF アプリケーションでバーコードコンポーネントを追加する
参照

このトピックでは、WPF アプリケーションでバーコードコンポーネントを追加する方法を説明します。

参照設定から追加するには

  1. [表示] メニューの [ソリューション エクスプローラー] をクリックしてソリューション エクスプローラーを表示します。

  2. ソリューション エクスプローラーのプロジェクトを右クリックし、[追加] - [参照] をクリックして [参照マネージャー] ダイアログを表示します。

  3. [アセンブリ] - [拡張] タブで、次のコンポーネント名を選択して [OK] ボタンをクリックします。

    コンポーネント名
    AdvanceSoftware.Wpf.VBBarCode

  4. 参照設定に次の内容が追加されます。

    追加される内容
    VBBarCode.Wpf.BarCode.v5

コード上でインスタンスを生成するには

  1. 次のコードを追加します。

    コピー C#
    private AdvanceSoftware.VBBarCode.Wpf.BarCode barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
    コピー VB.NET
    Private WithEvents BarCode1 As New AdvanceSoftware.VBBarCode.Wpf.BarCode

  2. エラーイベントは次のように追加します。

    コピー C#
    private void Form1_Load(object sender, EventArgs e)
{
    barCode1.Error +=
       new AdvanceSoftware.VBBarCode.BarCodeErrorEventHandler(
       this.barCode1_Error);
}

private void barCode1_Error(object sender,
    AdvanceSoftware.VBBarCode.BarCodeErrorEventArgs e)
{
    // ここにエラー発生時の処理を追加します。
}
    コピー VB.NET
    Private Sub BarCode1_Error(ByVal sender As Object, _
    ByVal e As AdvanceSoftware.VBBarCode.BarCodeErrorEventArgs) _
    Handles BarCode1.Error

    ' ここにエラー発生時の処理を追加します。
End Sub

参照

使用準備

©2020 Advance Software inc. All rights reserved.


ASP.NET Web アプリケーションでバーコードコンポーネントを追加する

[image]

VB-BarCode 5.0 for .NET
ASP.NET Web アプリケーションでバーコードコンポーネントを追加する
参照

このトピックでは、ASP.NET Web アプリケーションにてバーコードコンポーネントを追加する方法を説明します。

このトピックは、次のセクションを含みます。

  • ツールボックスから追加する
  • 参照設定から追加する

ツールボックスから追加する

このセクションでは、Visual Studio のツールボックスに バーコードコンポーネントを登録し、コンポーネントデザイナに配置する方法を説明します。

バーコードコンポーネントをツールボックスから追加するには

  1. Web フォームを表示し、[表示] メニューの [コンポーネント デザイナ] をクリックしてコンポーネントデザイナを表示します。

  2. [表示] メニューの [ツールボックス] をクリックしてツールボックスを表示します。

  3. ツールボックスにカーソルを合わせて右クリックし、[タブの追加] をクリックして コンポーネントを追加するタブを作成します。この手順ではタブ名を 「AdvanceSoftware」 とします。

  4. 追加したタブにカーソルを合わせて上で右クリックし、[アイテムの選択] をクリックして [ツールボックス アイテムの選択] ダイアログを表示します。

  5. [.NET Framework コンポーネント] タブを選択し、次のチェックボックスをオンにして [OK] ボタンをクリックします。

  6. 次のコンポーネントが追加されます。

コンポーネントデザイナに配置するには

  1. ツールボックスを表示し、追加したコンポーネントをコンポーネントデザイナにドラッグ アンド ドロップします。

  2. コンポーネントをコンポーネントデザイナに配置した後、参照設定に次の内容が追加されます。

    3. 追加される内容
    VBBarCode.BarCode.v5

  3. 配置したコンポーネントは、InitializeComponent メソッドに追加されるので、メソッドを呼び出して使用します。

    コードのコピーC#
    private AdvanceSoftware.VBBarCode.BarCode barCode1;
private System.ComponentModel.IContainer components;

protected void Page_Load(object sender, EventArgs e)
{

    if (!IsPostBack)
    {
        // InitializeComponent メソッドの呼び出し
              InitializeComponent();

    }
}

private void InitializeComponent()
{
    this.components = new System.ComponentModel.Container();
    this.barCode1 = new AdvanceSoftware.VBBarCode.BarCode(this.components);
    //
    // barCode1
    //
    this.barCode1.Element = 2D;
    this.barCode1.Font = new System.Drawing.Font("ＭＳ ゴシック", 5F);
    this.barCode1.QREscapeCode = ((byte)(0));
    this.barCode1.Zoom = 80;

}
    コードのコピーVB.NET
    Private components As System.ComponentModel.IContainer
Private WithEvents BarCode1 As AdvanceSoftware.VBBarCode.BarCode

Private Sub InitializeComponent()
    Me.components = New System.ComponentModel.Container()
    Me.BarCode1 = New AdvanceSoftware.VBBarCode.BarCode(Me.components)
    '
    'BarCode1
    '
    Me.BarCode1.Element = 2.0R
    Me.BarCode1.Font = New System.Drawing.Font("ＭＳ ゴシック", 5.0!)
    Me.BarCode1.QREscapeCode = CType(0, Byte)
    Me.BarCode1.Zoom = 80

End Sub

Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load
    If Not IsPostBack Then
        ' InitializeComponent メソッドの呼び出し
              InitializeComponent()
    End If
End Sub

参照設定から追加する

このセクションでは、Visual Studio のソリューション エクスプローラー上で コンポーネントの参照を追加し、コード上でインスタンスを生成する方法を説明します。

コンポーネントの参照を追加するには

  1. [表示] メニューの [ソリューション エクスプローラー] をクリックしてソリューション エクスプローラーを表示します。

  2. ソリューション エクスプローラーのプロジェクトを右クリックし、[追加] - [参照] をクリックして [参照マネージャー] ダイアログを表示します。

  3. [アセンブリ] - [拡張] タブで、次のコンポーネント名を選択して [OK] ボタンをクリックします。

    コンポーネント名
    AdvanceSoftware.VBBarCode

  4. 参照設定に次の内容が追加されます。

    追加される内容
    VBBarCode.BarCode.v5

コード上でインスタンスを生成するには

  1. 次のコードを追加します。

    コピー C#
    private AdvanceSoftware.VBBarCode.BarCode barCode1 =new AdvanceSoftware.VBBarCode.BarCode();
    コピー VB.NET
    Private WithEvents BarCode1 As New AdvanceSoftware.VBBarCode.BarCode

  2. エラーイベントは次のように追加します。

    コピー C#
    private void Form1_Load(object sender, EventArgs e)
{
    barCode1.Error +=
       new AdvanceSoftware.VBBarCode.BarCodeErrorEventHandler(
       this.barCode1_Error);
}

private void barCode1_Error(object sender,
    AdvanceSoftware.VBBarCode.BarCodeErrorEventArgs e)
{
    // ここにエラー発生時の処理を追加します。
}
    コピー VB.NET
    Private Sub BarCode1_Error(ByVal sender As Object, _
    ByVal e As AdvanceSoftware.VBBarCode.BarCodeErrorEventArgs) _
    Handles BarCode1.Error

    ' ここにエラー発生時の処理を追加します。
End Sub

参照

使用準備

©2020 Advance Software inc. All rights reserved.


新機能(SVG 出力機能)

[image]

VB-BarCode 5.0 for .NET
新機能(SVG 出力機能)
参照

VB-BarCode 5.0 for .NET は、新たに SVG 形式、SVGZ 形式(圧縮 SVG)でバーコードを出力することができます。

SVG 形式とは

SVG、SVGZ 形式は、ベクタ形式の画像になります。ベクタ形式とは、複数の点(アンカー)の位置とそれを繋いだ線等を数値データとして記憶し再現する形式をベクタ形式といいます。拡大、縮小など、サイズを変更した場合でも画像の精度が維持され、劣化しづらい性質があります。

SVG 形式、SVGZ 形式を出力する

SVG 形式、SVGZ 形式でバーコードを出力する方法などは、以下のページに掲載しています。

アプリケーションの種類 | 出力形式
Windows フォーム アプリケーション | SVG 形式のバーコードイメージを出力する
 | 圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する
WPF アプリケーション | SVG 形式のバーコードイメージを出力する
 | 圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する
ASP.NET Web アプリケーション | SVG 形式のバーコードイメージを出力する
 | 圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する

参照

バーコードを出力する

©2020 Advance Software inc. All rights reserved.


バーコードタイプ別の対応プロパティ一覧

[image]

VB-BarCode 5.0 for .NET
バーコードタイプ別の対応プロパティ一覧
参照

VB-BarCode 5.0 for .NET で設定可能なバーコードごとに使用可能なプロパティの一覧を以下に示します。

このトピックは、次のセクションを含みます。

  • バーコードコントロール
  • バーコードコンポーネント
  • WPF バーコードコントロール
  • WPF バーコードコンポーネント

バーコードコントロール

プロパティ名 | JAN コード | UPC コード | ITF コード | Codabar(NW-7) | Code39 | Code128 | GS1-128 (旧称 : UCC/EAN128) | 公共料金等代理収納 GS1-128 | 郵便カスタマバーコード | QR コード | PDF417
BackColor | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
BarColor | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
BarHeight | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
BarRatio | - | - | - | ○ | ○ | - | - | - | - | - | -
BarWidth | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
BinaryValue | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
BlackBarRevision | - | - | - | - | - | ○ | ○ | ○ | - | - | -
BlackRatio | ○ | ○ | ○ | - | - | - | - | - | ○ | ○ | ○
CharGap | - | - | - | ○ | ○ | - | - | - | - | - | -
CharSize | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
CheckCharMode | ○ | ○ | ○ | ○ | ○ | - | - | - | - | - | -
CheckPattern | - | - | - | ○ | - | - | - | - | - | - | -
Codeset | - | - | - | - | - | ○ | ○ | - | - | - | -
DpiX | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
DpiY | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
Element | - | - | - | ○ | ○ | ○ | ○ | ○ | - | ○ | ○
EmfType | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
ErrorMessage | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
ErrorNo | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
FlatHeight | ○ | ○ | - | - | - | - | - | - | - | - | -
Font | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
InternalQRVersion | - | - | - | - | - | - | - | - | - | ○ | -
InternalValue | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
MessageAlign | - | - | - | - | - | - | - | ○ | - | - | -
PDFColumn | - | - | - | - | - | - | - | - | - | - | ○
PDFInitialSymbol | - | - | - | - | - | - | - | - | - | - | ○
PDFLevel | - | - | - | - | - | - | - | - | - | - | ○
PDFModel | - | - | - | - | - | - | - | - | - | - | ○
PDFRatio | - | - | - | - | - | - | - | - | - | - | ○
PDFRow | - | - | - | - | - | - | - | - | - | - | ○
Point | - | - | - | - | - | - | - | - | ○ | - | -
QRConnect | - | - | - | - | - | - | - | - | - | ○ | -
QREscapeCode | - | - | - | - | - | - | - | - | - | ○ | -
QRLevel | - | - | - | - | - | - | - | - | - | ○ | -
QRMask | - | - | - | - | - | - | - | - | - | ○ | -
QRModel | - | - | - | - | - | - | - | - | - | ○ | -
QRSymbolNumber | - | - | - | - | - | - | - | - | - | ○ | -
QRVersion | - | - | - | - | - | - | - | - | - | ○ | -
Quiet | - | - | - | ○ | ○ | ○ | ○ | ○ | - | ○ | ○
RePaint | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
Rotate | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
ShowBearer | - | - | ○ | - | - | - | - | - | - | - | -
ShowMessage | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
StartChar | - | - | - | ○ | - | - | - | - | - | - | -
StopChar | - | - | - | ○ | - | - | - | - | - | - | -
TextRenderingHint | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
Type | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
Unit | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
Value | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
WhiteBarRevision | - | - | - | - | - | ○ | ○ | ○ | - | - | -
Zoom | ○ | ○ | ○ | - | - | - | - | - | - | - | -

バーコードコンポーネント

プロパティ名 | JAN コード | UPC コード | ITF コード | Codabar(NW-7) | Code39 | Code128 | GS1-128 (旧称 : UCC/EAN128) | 公共料金等代理収納 GS1-128 | 郵便カスタマバーコード | QR コード | PDF417
BackColor | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
BarColor | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
BarHeight | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
BarRatio | - | - | - | ○ | ○ | - | - | - | - | - | -
BarWidth | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
BinaryValue | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
BlackBarRevision | - | - | - | - | - | ○ | ○ | ○ | - | - | -
BlackRatio | ○ | ○ | ○ | - | - | - | - | - | ○ | ○ | ○
CharGap | - | - | - | ○ | ○ | - | - | - | - | - | -
CharSize | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
CheckCharMode | ○ | ○ | ○ | ○ | ○ | - | - | - | - | - | -
CheckPattern | - | - | - | ○ | - | - | - | - | - | - | -
Codeset | - | - | - | - | - | ○ | ○ | - | - | - | -
DpiX | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
DpiY | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
Element | - | - | - | ○ | ○ | ○ | ○ | ○ | - | ○ | ○
EmfType | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
ErrorMessage | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
ErrorNo | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
FlatHeight | ○ | ○ | - | - | - | - | - | - | - | - | -
Font | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
InternalQRVersion | - | - | - | - | - | - | - | - | - | ○ | -
InternalValue | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
MessageAlign | - | - | - | - | - | - | - | ○ | - | - | -
PDFColumn | - | - | - | - | - | - | - | - | - | - | ○
PDFInitialSymbol | - | - | - | - | - | - | - | - | - | - | ○
PDFLevel | - | - | - | - | - | - | - | - | - | - | ○
PDFModel | - | - | - | - | - | - | - | - | - | - | ○
PDFRatio | - | - | - | - | - | - | - | - | - | - | ○
PDFRow | - | - | - | - | - | - | - | - | - | - | ○
Point | - | - | - | - | - | - | - | - | ○ | - | -
QRConnect | - | - | - | - | - | - | - | - | - | ○ | -
QREscapeCode | - | - | - | - | - | - | - | - | - | ○ | -
QRLevel | - | - | - | - | - | - | - | - | - | ○ | -
QRMask | - | - | - | - | - | - | - | - | - | ○ | -
QRModel | - | - | - | - | - | - | - | - | - | ○ | -
QRSymbolNumber | - | - | - | - | - | - | - | - | - | ○ | -
QRVersion | - | - | - | - | - | - | - | - | - | ○ | -
Quiet | - | - | - | ○ | ○ | ○ | ○ | ○ | - | ○ | ○
Rotate | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
ShowBearer | - | - | ○ | - | - | - | - | - | - | - | -
ShowMessage | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
StartChar | - | - | - | ○ | - | - | - | - | - | - | -
StopChar | - | - | - | ○ | - | - | - | - | - | - | -
TextRenderingHint | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
Type | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
Unit | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
Value | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
WhiteBarRevision | - | - | - | - | - | ○ | ○ | ○ | - | - | -
Zoom | ○ | ○ | ○ | - | - | - | - | - | - | - | -

WPF バーコードコントロール

プロパティ名 | JAN コード | UPC コード | ITF コード | Codabar(NW-7) | Code39 | Code128 | GS1-128 (旧称 : UCC/EAN128) | 公共料金等代理収納 GS1-128 | 郵便カスタマバーコード | QR コード | PDF417
BackColor | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
BarColor | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
BarHeight | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
BarRatio | - | - | - | ○ | ○ | - | - | - | - | - | -
BarWidth | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
BinaryValue | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
BlackBarRevision | - | - | - | - | - | ○ | ○ | ○ | - | - | -
BlackRatio | ○ | ○ | ○ | - | - | - | - | - | ○ | ○ | ○
CharGap | - | - | - | ○ | ○ | - | - | - | - | - | -
CharSize | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
CheckCharMode | ○ | ○ | ○ | ○ | ○ | - | - | - | - | - | -
CheckPattern | - | - | - | ○ | - | - | - | - | - | - | -
Codeset | - | - | - | - | - | ○ | ○ | - | - | - | -
DpiX | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
DpiY | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
Element | - | - | - | ○ | ○ | ○ | ○ | ○ | - | ○ | ○
ErrorMessage | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
ErrorNo | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
FlatHeight | ○ | ○ | - | - | - | - | - | - | - | - | -
Font | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
FontStyle | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
FontWeight | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
InternalQRVersion | - | - | - | - | - | - | - | - | - | ○ | -
InternalValue | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
MessageAlign | - | - | - | - | - | - | - | ○ | - | - | -
PDFColumn | - | - | - | - | - | - | - | - | - | - | ○
PDFInitialSymbol | - | - | - | - | - | - | - | - | - | - | ○
PDFLevel | - | - | - | - | - | - | - | - | - | - | ○
PDFModel | - | - | - | - | - | - | - | - | - | - | ○
PDFRatio | - | - | - | - | - | - | - | - | - | - | ○
PDFRow | - | - | - | - | - | - | - | - | - | - | ○
Point | - | - | - | - | - | - | - | - | ○ | - | -
QRConnect | - | - | - | - | - | - | - | - | - | ○ | -
QREscapeCode | - | - | - | - | - | - | - | - | - | ○ | -
QRLevel | - | - | - | - | - | - | - | - | - | ○ | -
QRMask | - | - | - | - | - | - | - | - | - | ○ | -
QRModel | - | - | - | - | - | - | - | - | - | ○ | -
QRSymbolNumber | - | - | - | - | - | - | - | - | - | ○ | -
QRVersion | - | - | - | - | - | - | - | - | - | ○ | -
Quiet | - | - | - | ○ | ○ | ○ | ○ | ○ | - | ○ | ○
RePaint | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
Rotate | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
ShowBearer | - | - | ○ | - | - | - | - | - | - | - | -
ShowMessage | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
StartChar | - | - | - | ○ | - | - | - | - | - | - | -
StopChar | - | - | - | ○ | - | - | - | - | - | - | -
Type | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
Unit | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
Value | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
WhiteBarRevision | - | - | - | - | - | ○ | ○ | ○ | - | - | -
Zoom | ○ | ○ | ○ | - | - | - | - | - | - | - | -

WPF バーコードコンポーネント

プロパティ名 | JAN コード | UPC コード | ITF コード | Codabar(NW-7) | Code39 | Code128 | GS1-128 (旧称 : UCC/EAN128) | 公共料金等代理収納 GS1-128 | 郵便カスタマバーコード | QR コード | PDF417
BackColor | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
BarColor | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
BarHeight | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
BarRatio | - | - | - | ○ | ○ | - | - | - | - | - | -
BarWidth | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
BinaryValue | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
BlackBarRevision | - | - | - | - | - | ○ | ○ | ○ | - | - | -
BlackRatio | ○ | ○ | ○ | - | - | - | - | - | ○ | ○ | ○
CharGap | - | - | - | ○ | ○ | - | - | - | - | - | -
CharSize | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
CheckCharMode | ○ | ○ | ○ | ○ | ○ | - | - | - | - | - | -
CheckPattern | - | - | - | ○ | - | - | - | - | - | - | -
Codeset | - | - | - | - | - | ○ | ○ | - | - | - | -
DpiX | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
DpiY | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
Element | - | - | - | ○ | ○ | ○ | ○ | ○ | - | ○ | ○
ErrorMessage | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
ErrorNo | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
FlatHeight | ○ | ○ | - | - | - | - | - | - | - | - | -
Font | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
FontStyle | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
FontWeight | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
InternalQRVersion | - | - | - | - | - | - | - | - | - | ○ | -
InternalValue | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
MessageAlign | - | - | - | - | - | - | - | ○ | - | - | -
PDFColumn | - | - | - | - | - | - | - | - | - | - | ○
PDFInitialSymbol | - | - | - | - | - | - | - | - | - | - | ○
PDFLevel | - | - | - | - | - | - | - | - | - | - | ○
PDFModel | - | - | - | - | - | - | - | - | - | - | ○
PDFRatio | - | - | - | - | - | - | - | - | - | - | ○
PDFRow | - | - | - | - | - | - | - | - | - | - | ○
Point | - | - | - | - | - | - | - | - | ○ | - | -
QRConnect | - | - | - | - | - | - | - | - | - | ○ | -
QREscapeCode | - | - | - | - | - | - | - | - | - | ○ | -
QRLevel | - | - | - | - | - | - | - | - | - | ○ | -
QRMask | - | - | - | - | - | - | - | - | - | ○ | -
QRModel | - | - | - | - | - | - | - | - | - | ○ | -
QRSymbolNumber | - | - | - | - | - | - | - | - | - | ○ | -
QRVersion | - | - | - | - | - | - | - | - | - | ○ | -
Quiet | - | - | - | ○ | ○ | ○ | ○ | ○ | - | ○ | ○
Rotate | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
ShowBearer | - | - | ○ | - | - | - | - | - | - | - | -
ShowMessage | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | - | - | -
StartChar | - | - | - | ○ | - | - | - | - | - | - | -
StopChar | - | - | - | ○ | - | - | - | - | - | - | -
Type | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
Unit | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
Value | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
WhiteBarRevision | - | - | - | - | - | ○ | ○ | ○ | - | - | -
Zoom | ○ | ○ | ○ | - | - | - | - | - | - | - | -

参照

VB-BarCode 5.0 for .NET の概要

©2020 Advance Software inc. All rights reserved.


バーコードタイプ別の作成方法

[image]

VB-BarCode 5.0 for .NET
バーコードタイプ別の作成方法

ここでは、VB-BarCode 5.0 for .NET のバーコードタイプ別の作成方法について説明します。

JAN コードを作成する

JAN コードを作成する方法を説明します。

UPC コードを作成する

UPC コードを作成する方法を説明します。

ITF コードを作成する

ITF コードを作成する方法を説明します。

Codabar(NW-7)を作成する

Codabar(NW-7)を作成する方法を説明します。

Code39 を作成する

Code39 を作成する方法を説明します。

Code128 を作成する

Code128 を作成する方法を説明します。

GS1-128 (旧称 : UCC/EAN128) を作成する

GS1-128 (旧称 : UCC/EAN128) を作成する方法を説明します。

公共料金等代理収納 GS1-128 を作成する

公共料金等代理収納 GS1-128 を作成する方法を説明します。

郵便カスタマバーコードを作成する

郵便カスタマバーコードを作成する方法を説明します。

QR コードを作成する

QR コードを作成する方法を説明します。

PDF417 コードを作成する

PDF417 コードを作成する方法を説明します。


JAN コードを作成する

[image]

VB-BarCode 5.0 for .NET
JAN コードを作成する
参照

このトピックでは、JAN コードを作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • JAN 13 コード(標準バージョン 13 桁)を作成する
  • JAN 8 コード(短縮バージョン 8 桁)を作成する

JAN 13 コード(標準バージョン 13 桁)を作成する

このセクションでは、JAN 13 コード(標準バージョン 13 桁)を作成する方法を説明します。

次のコードは、JAN 13 コード(標準バージョン 13 桁)を作成するサンプルコードです。

コピーC#
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// JAN コードの倍率を 100 に設定します。
barCodeControl1.Zoom = 100;
// 13 桁目チェックデジットは自動で付加されます。
barCodeControl1.Value = "499385766919";
コピーVB.NET
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' JAN コードの倍率を 100 に設定します。
BarCodeControl1.Zoom = 100
' 13 桁目チェックデジットは自動で付加されます。
BarCodeControl1.Value = "499385766919"

JAN 8 コード(短縮バージョン 8 桁)を作成する

このセクションでは、JAN 8 コード(短縮バージョン 8 桁)を作成する方法を説明します。

次のコードは、JAN 8 コード(短縮バージョン 8 桁)を作成するサンプルコードです。

コピーC#
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN8;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// JAN コードの倍率を 100 に設定します。
barCodeControl1.Zoom = 100;
// 8 桁目チェックデジットは自動で付加されます。
barCodeControl1.Value = "4993857";
コピーVB.NET
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN8
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' JAN コードの倍率を 100 に設定します。
BarCodeControl1.Zoom = 100
' 8 桁目チェックデジットは自動で付加されます。
BarCodeControl1.Value = "4993857"

参照

バーコードタイプ別の作成方法
Type
Unit
DpiX
DpiY
Value
Zoom


UPC コードを作成する

[image]

VB-BarCode 5.0 for .NET
UPC コードを作成する
参照

このトピックでは、UPC コードを作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • UPC-A (A バージョン)を作成する
  • UPC-E (E バージョン)を作成する

UPC-A (A バージョン)を作成する

このセクションでは、UPC-A (A バージョン)を作成する方法を説明します。

次のコードは、UPC-A (A バージョン)を作成するサンプルコードです。

コピーC#
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.UPCA;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// UPC コードの倍率を 100 に設定します。
barCodeControl1.Zoom = 100;
// 12 桁目チェックデジットは自動で付加されます。
barCodeControl1.Value = "01234567891";
コピーVB.NET
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.UPCA
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' UPC コードの倍率を 100 に設定します。
BarCodeControl1.Zoom = 100
' 12 桁目チェックデジットは自動で付加されます。
BarCodeControl1.Value = "01234567891"

UPC-E (E バージョン)を作成する

このセクションでは、UPC-E (E バージョン)を作成する方法を説明します。

次のコードは、UPC-E (E バージョン)を作成するサンプルコードです。

コピーC#
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.UPCE;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// UPC コードの倍率を 100 に設定します。
barCodeControl1.Zoom = 100;
// 8 桁目チェックデジットは自動で付加されます。
barCodeControl1.Value = "0123456";
コピーVB.NET
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.UPCE
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' UPC コードの倍率を 100 に設定します。
BarCodeControl1.Zoom = 100
' 8 桁目チェックデジットは自動で付加されます。
BarCodeControl1.Value = "0123456"

参照

バーコードタイプ別の作成方法
Type
Unit
DpiX
DpiY
Value
Zoom


ITF コードを作成する

[image]

VB-BarCode 5.0 for .NET
ITF コードを作成する
参照

このトピックでは、ITF コードを作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • ITF-6 (アドオンバージョン 6 桁)を作成する
  • ITF-14 (標準バージョン 14 桁)を作成する
  • ITF-16 (拡張バージョン 16 桁)を作成する
  • ITF (自由桁)を作成する

ITF-6 (アドオンバージョン 6 桁)を作成する

このセクションでは、ITF-6 (アドオンバージョン 6 桁)を作成する方法を説明します。

次のコードは、ITF-6 (アドオンバージョン 6 桁)を作成するサンプルコードです。

コピーC#
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.ITF6;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// バーコードの倍率を 100 に設定します。
barCodeControl1.Zoom = 100;
// 6 桁目チェックデジットは自動で付加されます。
barCodeControl1.Value = "01234";
コピーVB.NET
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.ITF6
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' バーコードの倍率を 100 に設定します。
BarCodeControl1.Zoom = 100
' 6 桁目チェックデジットは自動で付加されます。
BarCodeControl1.Value = "01234"

ITF-14 (標準バージョン 14 桁)を作成する

このセクションでは、ITF-14 (標準バージョン 14 桁)を作成する方法を説明します。

次のコードは、ITF-14 (標準バージョン 14 桁)を作成するサンプルコードです。

コピーC#
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.ITF14;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// バーコードの倍率を 100 に設定します。
barCodeControl1.Zoom = 100;
// 14 桁目チェックデジットは自動で付加されます。
barCodeControl1.Value = "0123456789012";
コピーVB.NET
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.ITF14
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' バーコードの倍率を 100 に設定します。
BarCodeControl1.Zoom = 100
' 14 桁目チェックデジットは自動で付加されます。
BarCodeControl1.Value = "0123456789012"

ITF-16 (拡張バージョン 16 桁)を作成する

このセクションでは、ITF-16 (拡張バージョン 16 桁)を作成する方法を説明します。

次のコードは、ITF-16 (拡張バージョン 16 桁)を作成するサンプルコードです。

コピーC#
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.ITF16;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// バーコードの倍率を 100 に設定します。
barCodeControl1.Zoom = 100;
// 16 桁目チェックデジットは自動で付加されます。
barCodeControl1.Value = "012345678901234";
コピーVB.NET
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.ITF16
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' バーコードの倍率を 100 に設定します。
BarCodeControl1.Zoom = 100
' 16 桁目チェックデジットは自動で付加されます。
BarCodeControl1.Value = "012345678901234"

ITF (自由桁)を作成する

このセクションでは、ITF (自由桁)を作成する方法を説明します。

次のコードは、ITF (自由桁)を作成するサンプルコードです。

コピーC#
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.ITF;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// バーコードの倍率を 100 に設定します。
barCodeControl1.Zoom = 100;
//  最終桁チェックデジットは自動で付加されます。
barCodeControl1.Value = "01234567890123456789";
コピーVB.NET
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.ITF
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' バーコードの倍率を 100 に設定します。
BarCodeControl1.Zoom = 100
' 最終桁チェックデジットは自動で付加されます。
BarCodeControl1.Value = "01234567890123456789"

参照

バーコードタイプ別の作成方法
Type
Unit
DpiX
DpiY
Value
Zoom


Codabar (NW-7)を作成する
参照

このトピックでは、Codabar (NW-7)を作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • Codabar (NW-7)を作成する

Codabar (NW-7)を作成する

このセクションでは、Codabar (NW-7)を作成する方法を説明します。

次のコードは、Codabar (NW-7)を作成するサンプルコードです。

コピーC#
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// チェックデジットの計算方法を "モジュラス 10 / ウエイト 3" に設定します。
barCodeControl1.CheckPattern = AdvanceSoftware.VBBarCode.CheckPattern.Modulus10Weight3;
// スタートキャラクタを "c" に設定します。
barCodeControl1.StartChar = 'c';
// ストップキャラクタを "c" に設定します。
barCodeControl1.StopChar = 'c';
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCodeControl1.Element = 6;
barCodeControl1.Value = "0123456789";
コピーVB.NET
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' チェックデジットの計算方法を "モジュラス 10 / ウエイト 3" に設定します。
BarCodeControl1.CheckPattern = AdvanceSoftware.VBBarCode.CheckPattern.Modulus10Weight3
' スタートキャラクタを "c" に設定します。
BarCodeControl1.StartChar = "c"
' ストップキャラクタを "c" に設定します。
BarCodeControl1.StopChar = "c"
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCodeControl1.Element = 6
BarCodeControl1.Value = "0123456789"

参照

バーコードタイプ別の作成方法
Type
Unit
DpiX
DpiY
Element
Value
CheckPattern
StartChar
StopChar


Code39 を作成する
参照

このトピックでは、Code39 を作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • Code39 を作成する

Code39 を作成する

このセクションでは、Code39 を作成する方法を説明します。

次のコードは、Code39 を作成するサンプルコードです。

コピーC#
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code39;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// キャラクタ間のギャップを 50.0 に設定します。(Code39 のみ設定可能)
barCodeControl1.CharGap = 50;
// バーコードの最小エレメント値(バーコード幅)を 6 ピクセルに設定します。Unit プロパティの単位で設定します。
barCodeControl1.Element = 6;
barCodeControl1.Value = "0123456789";
コピーVB.NET
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code39
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
// キャラクタ間のギャップを 50.0 に設定します。(Code39 のみ設定可能)
BarCodeControl1.CharGap = 50
' バーコードの最小エレメント値(バーコード幅)を 6 ピクセルに設定します。Unit プロパティの単位で設定します。
BarCodeControl1.Element = 6
BarCodeControl1.Value = "0123456789"

参照

バーコードタイプ別の作成方法
Type
Unit
DpiX
DpiY
Element
Value
CharGap


Code128 を作成する
参照

このトピックでは、Code128 を作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • Code128 を作成する
  • FNC1 コードを挿入する
  • コードセットを切り替える
  • ドット補正をする

Code128 を作成する

このセクションでは、Code128 を作成する方法を説明します。

次のコードは、Code128 を作成するサンプルコードです。

コピーC#
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// スタートコードセット B に設定します。
barCodeControl1.Codeset = AdvanceSoftware.VBBarCode.Codeset.CodesetB;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCodeControl1.Element = 6;
barCodeControl1.Value = "abc123";
コピーVB.NET
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' スタートコードセット B に設定します。
BarCodeControl1.Codeset = AdvanceSoftware.VBBarCode.Codeset.CodesetB
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCodeControl1.Element = 6
BarCodeControl1.Value = "abc123"

FNC1 コードを挿入する

このセクションでは、FNC1 コード等の制御コードを手動で設定する方法を説明します。"チルダ＋制御コード名"のように「~」(チルダ)で始まる文字列を指定することでバーコードデータに任意の制御コードを設定することが可能です。

次のコードは、FNC1 コードを挿入するサンプルコードです。

コピーC#
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// スタートコードセット C に設定します。
barCodeControl1.Codeset = AdvanceSoftware.VBBarCode.Codeset.CodesetC;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCodeControl1.Element = 6;
// バーコードデータの先頭に FNC1 コードを手動で設定します。
barCodeControl1.Value = "~FNC1" + "123";
コピーVB.NET
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' スタートコードセット C に設定します。
BarCodeControl1.Codeset = AdvanceSoftware.VBBarCode.Codeset.CodesetC
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCodeControl1.Element = 6
' バーコードデータの先頭に FNC1 コードを手動で設定します。
BarCodeControl1.Value = "~FNC1" & "123"

コードセットを切り替える

このセクションでは、コードセットを切り替える方法を説明します。"チルダ＋制御コード(コードセット)名"のように「~」(チルダ)で始まる文字列を指定することでバーコードデータ内で指定した位置でコードセットを切り替えることが可能です。

次のコードは、コードセットを切り替えるサンプルコードです。

コピーC#
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// スタートコードセット C に設定します。
barCodeControl1.Codeset = AdvanceSoftware.VBBarCode.Codeset.CodesetC;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCodeControl1.Element = 6;
// バーコードデータの途中でコードセット B に手動で切り替えます。
barCodeControl1.Value = 12 + "~CODEB" + "abc";
コピーVB.NET
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' スタートコードセット C に設定します。
BarCodeControl1.Codeset = AdvanceSoftware.VBBarCode.Codeset.CodesetC
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCodeControl1.Element = 6
' バーコードデータの途中でコードセット B に手動で切り替えます。
BarCodeControl1.Value = 12 & "~CODEB" & "abc"

ドット補正をする

このセクションでは、ドット補正をする方法を説明します。

次のコードは、BlackBarRevision、WhiteBarRevision プロパティでドット補正をするサンプルコードです。

コピーC#
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// スタートコードセット B に設定します。
barCodeControl1.Codeset = AdvanceSoftware.VBBarCode.Codeset.CodesetB;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCodeControl1.Element = 6;
barCodeControl1.Value = "abc123";
// 黒バーのドット補正値を "+1" に設定します。
barCodeControl1.BlackBarRevision = 1;
// 白バーのドット補正値を "-1" に設定します。
barCodeControl1.WhiteBarRevision = -1;
コピーVB.NET
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' スタートコードセット B に設定します。
BarCodeControl1.Codeset = AdvanceSoftware.VBBarCode.Codeset.CodesetB
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCodeControl1.Element = 6
BarCodeControl1.Value = "abc123"
' 黒バーのドット補正値を "+1" に設定します。
BarCodeControl1.BlackBarRevision = 1
' 白バーのドット補正値を "-1" に設定します。
BarCodeControl1.WhiteBarRevision = -1

参照

バーコードタイプ別の作成方法
Type
Unit
DpiX
DpiY
Value
Element
Codeset
BlackBarRevision
WhiteBarRevision


GS1-128 を作成する
参照

このトピックでは、GS1-128 を作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • GS1-128 を作成する
  • ドット補正をする
Note メモ:

GS1-128 であることを示す、スタートコード後の FNC1 は、Type プロパティで GS1 を設定することで自動付加されます。括弧 "("、")" はバーコードイメージ下部のバーコード文字列にのみ表示され、データには含まれません。

GS1-128 を作成する

このセクションでは、GS1-128 を作成する方法を説明します。

次のコードは、GS1-128 を作成するサンプルコードです。

コピーC#
string barCodeData =
"(01)" +           // AI(01)
"14993857669199" + // 商品コード
"(17)" +           // AI(17)
"200101" +         // 有効期限
"(30)" +           // AI(30)
"10" +             // 数量
"~FNC1" +          // 可変データの区切りを示す FNC1
"(10)" +           // AI(10)
"~CODEB" +         // Code B に切り替え
"ABC123";          // ロット番号

barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.GS1;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// スタートコードセット C に設定します。
barCodeControl1.Codeset = AdvanceSoftware.VBBarCode.Codeset.CodesetC;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCodeControl1.Element = 6;
barCodeControl1.Value = barCodeData;
コピーVB.NET
Dim barCodeData As String
barCodeData = "(01)"             ' AI(01)
barCodeData += "14993857669199"  ' 商品コード
barCodeData += "(17)"            ' AI(17)
barCodeData += "200101"          ' 有効期限
barCodeData += "(30)"            ' AI(30)
barCodeData += "10"              ' 数量
barCodeData += "~FNC1"           ' 可変データの区切りを示す FNC1
barCodeData += "(10)"            ' AI(10)
barCodeData += "~CODEB"          ' Code B に切り替え
barCodeData += "ABC123"          ' ロット番号

BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.GS1
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' スタートコードセット C に設定します。
BarCodeControl1.Codeset = AdvanceSoftware.VBBarCode.Codeset.CodesetC
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCodeControl1.Element = 6
BarCodeControl1.Value = barCodeData
Note メモ:

データの途中で FNC1 などの制御コードを挿入する場合、"チルダ＋制御コード名" を入力します。(例："~FNC1"、"~CODEB" など)

ドット補正をする

このセクションでは、ドット補正をする方法を説明します。

次のコードは、BlackBarRevision、WhiteBarRevision プロパティでドット補正をするサンプルコードです。

コピーC#
"(01)" +           // AI(01)
"14993857669199" + // 商品コード
"(17)" +           // AI(17)
"200101" +         // 有効期限
"(30)" +           // AI(30)
"10" +             // 数量
"~FNC1" +          // 可変データの区切りを示す FNC1
"(10)" +           // AI(10)
"~CODEB" +         // Code B に切り替え
"ABC123";          // ロット番号

barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.GS1;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// スタートコードセット C に設定します。
barCodeControl1.Codeset = AdvanceSoftware.VBBarCode.Codeset.CodesetC;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCodeControl1.Element = 6;
barCodeControl1.Value = barCodeData;
// 黒バーのドット補正値を "+1" に設定します。
barCodeControl1.BlackBarRevision = 1;
// 白バーのドット補正値を "-1" に設定します。
barCodeControl1.WhiteBarRevision = -1;
コピーVB.NET
Dim barCodeData As String
barCodeData = "(01)"             ' AI(01)
barCodeData += "14993857669199"  ' 商品コード
barCodeData += "(17)"            ' AI(17)
barCodeData += "200101"          ' 有効期限
barCodeData += "(30)"            ' AI(30)
barCodeData += "10"              ' 数量
barCodeData += "~FNC1"           ' 可変データの区切りを示す FNC1
barCodeData += "(10)"            ' AI(10)
barCodeData += "~CODEB"          ' Code B に切り替え
barCodeData += "ABC123"          ' ロット番号

BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.GS1
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' スタートコードセット C に設定します。
BarCodeControl1.Codeset = AdvanceSoftware.VBBarCode.Codeset.CodesetC
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCodeControl1.Element = 6
BarCodeControl1.Value = barCodeData
' 黒バーのドット補正値を "+1" に設定します。
BarCodeControl1.BlackBarRevision = 1
' 白バーのドット補正値を "-1" に設定します。
BarCodeControl1.WhiteBarRevision = -1

参照

バーコードタイプ別の作成方法
Type
Unit
DpiX
DpiY
Value
Element
Codeset
BlackBarRevision
WhiteBarRevision


公共料金代理収納 GS1-128 を作成する
参照

このトピックでは、公共料金代理収納 GS1-128 を作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • 公共料金代理収納 GS1-128 を作成する
  • ドット補正をする
Note メモ:

公共料金代理収納 GS1-128 であることを示す、スタートコード後の FNC1 は、Type プロパティで GS1 を設定することで自動付加されます。

公共料金代理収納 GS1-128 を作成する

このセクションでは、公共料金代理収納 GS1-128 を作成する方法を説明します。

次のコードは、公共料金代理収納 GS1-128 を作成するサンプルコードです。

コピーC#
string barCodeData =
"91" +                      // 識別子
"912345" +                  // メーカーコード
"1234567890123456789211" +  // 自由使用欄、再発行区分
"020331" +                  // 支払い期限日
"0" +                       // 印紙フラグ
"123456";                   // 支払い金額

barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.GS1Fixed;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCodeControl1.Element = 6;
barCodeControl1.Value = barCodeData;
コピーVB.NET
Dim barCodeData As String
barCodeData = "91"                      ' 識別子
barCodeData += "912345"                 ' メーカーコード
barCodeData += "1234567890123456789211" ' 自由使用欄、再発行区分
barCodeData += "020331"                 ' 支払い期限日
barCodeData += "0"                      ' 印紙フラグ
barCodeData += "123456"                 ' 支払い金額

BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.GS1Fixed
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCodeControl1.Element = 6
BarCodeControl1.Value = barCodeData

ドット補正をする

このセクションでは、ドット補正をする方法を説明します。

次のコードは、BlackBarRevision、WhiteBarRevision プロパティでドット補正をするサンプルコードです。

コピーC#
string barCodeData =
"91" +                      // 識別子
"912345" +                  // メーカーコード
"1234567890123456789211" +  // 自由使用欄、再発行区分
"020331" +                  // 支払い期限日
"0" +                       // 印紙フラグ
"123456";                   // 支払い金額

barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.GS1Fixed;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCodeControl1.Element = 6;
barCodeControl1.Value = barCodeData;
// 黒バーのドット補正値を "+2" に設定します。
barCodeControl1.BlackBarRevision = 2;
// 白バーのドット補正値を "+2" に設定します。
barCodeControl1.WhiteBarRevision = 2;
コピーVB.NET
Dim barCodeData As String
barCodeData = "91"                      ' 識別子
barCodeData += "912345"                 ' メーカーコード
barCodeData += "1234567890123456789211" ' 自由使用欄、再発行区分
barCodeData += "020331"                 ' 支払い期限日
barCodeData += "0"                      ' 印紙フラグ
barCodeData += "123456"                 ' 支払い金額

BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.GS1Fixed
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCodeControl1.Element = 6
BarCodeControl1.Value = barCodeData
' 黒バーのドット補正値を "+2" に設定します。
BarCodeControl1.BlackBarRevision = 2
' 白バーのドット補正値を "+2" に設定します。
BarCodeControl1.WhiteBarRevision = 2

参照

バーコードタイプ別の作成方法
Type
Unit
DpiX
DpiY
Value
Element
BlackBarRevision
WhiteBarRevision


カスタマバーコードを作成する
参照

このトピックでは、カスタマバーコードを作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • カスタマバーコードを作成する
Note メモ:

住所データからバーコードデータへの変換には対応していません。

カスタマバーコードを作成する

このセクションでは、カスタマバーコードを作成する方法を説明します。

次のコードは、カスタマバーコードを作成するサンプルコードです。

コピーC#
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.CustomerBarCode;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// 郵便カスタマバーコードのポイントを "10.0" に設定します。
barCodeControl1.Point = 10.0;
barCodeControl1.Value = "91882391-2816";
コピーVB.NET
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.CustomerBarCode
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' 郵便カスタマバーコードのポイントを "10.0" に設定します。
BarCodeControl1.Point = 10.0
BarCodeControl1.Value = "91882391-2816"

参照

バーコードタイプ別の作成方法
Type
Unit
DpiX
DpiY
Point
Value


PDF417 を作成する
参照

このトピックでは、PDF417 を作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • PDF417 を作成する

PDF417 を作成する

このセクションでは、PDF417 を作成する方法を説明します。

次のコードは、PDF417 を作成するサンプルコードです。

コピーC#
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCodeControl1.Element = 6;
// PDF417 の列数を "15列" に設定します。
barCodeControl1.PDFColumn = 15;
// PDF417 の初期化シンボルを "付加する" に設定します。
barCodeControl1.PDFInitialSymbol = true;
// PDF417 のエラー訂正レベルを "レベル5" に設定します。
barCodeControl1.PDFLevel = 5;
// PDF417 シンボルを "簡易 PDF417" に設定します。
barCodeControl1.PDFModel = AdvanceSoftware.VBBarCode.PDFModel.Truncated;
// PDF417 の行数を "10行" に設定します。
barCodeControl1.PDFRow = 10;
barCodeControl1.Value = "01234567890123456789";
コピーVB.NET
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCodeControl1.Element = 6
' PDF417 の列数を "15列" に設定します。
BarCodeControl1.PDFColumn = 15
' PDF417 の初期化シンボルを "付加する" に設定します。
BarCodeControl1.PDFInitialSymbol = True
' PDF417 のエラー訂正レベルを "レベル5" に設定します。
BarCodeControl1.PDFLevel = 5
' PDF417 シンボルを "簡易 PDF417" に設定します。
BarCodeControl1.PDFModel = AdvanceSoftware.VBBarCode.PDFModel.Truncated
' PDF417 の行数を "10行" に設定します。
BarCodeControl1.PDFRow = 10
BarCodeControl1.Value = "01234567890123456789"

参照

バーコードタイプ別の作成方法
Type
Unit
DpiX
DpiY
Element
Value
PDFColumn
PDFInitialSymbol
PDFLevel
PDFModel
PDFRow


QR コードを作成する
参照

このトピックでは、QR コードを作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • QR コードを作成する
  • QR コードを携帯で読み取る
  • QR コードを自動で連結する
  • QR コードを手動で連結する

QR コードを作成する

このセクションでは、QR コードを作成する方法を説明します。

次のコードは、QR コードを作成するサンプルコードです。

コピーC#
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// QR コードのエラー訂正レベルを "H" に設定します。
barCodeControl1.QRLevel = AdvanceSoftware.VBBarCode.QRLevel.LevelH;
// QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
barCodeControl1.QRMask = AdvanceSoftware.VBBarCode.QRMask.Mask000;
// QR コードのモデルを "モデル 1" に設定します。
barCodeControl1.QRModel = AdvanceSoftware.VBBarCode.QRModel.Model1;
// QR コードの型番を "10 型" に設定します。
barCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10;
barCodeControl1.Element = 10;
barCodeControl1.Value = "123456789";
コピーVB.NET
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' QR コードのエラー訂正レベルを "H" に設定します。
BarCodeControl1.QRLevel = AdvanceSoftware.VBBarCode.QRLevel.LevelH
' QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
BarCodeControl1.QRMask = AdvanceSoftware.VBBarCode.QRMask.Mask000
' QR コードのモデルを "モデル 1" に設定します。
BarCodeControl1.QRModel = AdvanceSoftware.VBBarCode.QRModel.Model1
' QR コードの型番を "10 型" に設定します。
BarCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10
BarCodeControl1.Element = 10
BarCodeControl1.Value = "123456789"

QR コードを携帯で読み取る

このセクションでは、QR コードを携帯で読み取る方法を説明します。

Note メモ:

携帯電話で読み取り可能な QR コードの仕様は、各携帯電話のキャリアによって細かい仕様は異なりますが、基本的な仕様は、モデル(モデル 2)、バージョン(１～10)に統一されています。

次のコードは、QRModel プロパティでモデルを [Model2] に設定し、QRVersion プロパティでバージョン [10] を設定するサンプルコードです。

コピーC#
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// QR コードのエラー訂正レベルを "H" に設定します。
barCodeControl1.QRLevel = AdvanceSoftware.VBBarCode.QRLevel.LevelH;
// QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
barCodeControl1.QRMask = AdvanceSoftware.VBBarCode.QRMask.Mask000;
// QR コードのモデルを "モデル 2" に設定します。
barCodeControl1.QRModel = AdvanceSoftware.VBBarCode.QRModel.Model2;
// QR コードの型番を "10 型" に設定します。
barCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10;
barCodeControl1.Element = 10;
barCodeControl1.Value = "123456789";
コピーVB.NET
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' QR コードのエラー訂正レベルを "H" に設定します。
BarCodeControl1.QRLevel = AdvanceSoftware.VBBarCode.QRLevel.LevelH
' QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
BarCodeControl1.QRMask = AdvanceSoftware.VBBarCode.QRMask.Mask000
' QR コードのモデルを "モデル 2" に設定します。
BarCodeControl1.QRModel = AdvanceSoftware.VBBarCode.QRModel.Model2
' QR コードの型番を "10 型" に設定します。
BarCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10
BarCodeControl1.Element = 10
BarCodeControl1.Value = "123456789"

QR コードを自動で連結する

このセクションでは、QR コードを自動で連結する方法を説明します。

次のコードは、QRConnect プロパティで [AutoConnect] を設定し、QR コードを自動で連結して作成するサンプルコードです。

コピーC#
int nSymbolCnt;
nSymbolCnt = 0;
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// QR コードのエラー訂正レベルを "H" に設定します。
barCodeControl1.QRLevel = AdvanceSoftware.VBBarCode.QRLevel.LevelH;
// QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
barCodeControl1.QRMask = AdvanceSoftware.VBBarCode.QRMask.Mask000;
// QR コードのモデルを "モデル 2" に設定します。
barCodeControl1.QRModel = AdvanceSoftware.VBBarCode.QRModel.Model2;
// QR コードの型番を "2 型" に設定します。
barCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version2;
barCodeControl1.Element = 10;
// 連結 QR コードを自動で作成します。
barCodeControl1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.AutoConnect;
// シンボル番号を初期化します。
barCodeControl1.QRSymbolNumber = 0;
barCodeControl1.Value = "123456789123456789123456789123456789";
// 分割 QR コード数をチェックします。
if (barCodeControl1.ErrorNo == AdvanceSoftware.VBBarCode.ErrorNo.QRSymbolOver)
{
    MessageBox.Show("連結シンボル数を超えました。");
}
// ループ文で1シンボルずつQRコードを出力(emfファイル保存)します。
for (int nSymbol=0; nSymbol<3; ++nSymbol)
{
    barCodeControl1.QRSymbolNumber = nSymbol;
    if (barCodeControl1.ErrorNo == AdvanceSoftware.VBBarCode.ErrorNo.QRConnectPos)
    {
        return;
    }
    else
    {
        nSymbolCnt = nSymbolCnt + 1;
        barCodeControl1.Save(Application.StartupPath + @"\QRCode" + nSymbolCnt.ToString() + ".emf", System.Drawing.Imaging.ImageFormat.Emf);
    }
}
コピーVB.NET
Dim nSymbolCnt As Integer
Dim nSymbol As Integer
nSymbolCnt = 0
nSymbol = 0
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' QR コードのエラー訂正レベルを "H" に設定します。
BarCodeControl1.QRLevel = AdvanceSoftware.VBBarCode.QRLevel.LevelH
' QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
BarCodeControl1.QRMask = AdvanceSoftware.VBBarCode.QRMask.Mask000
' QR コードのモデルを "モデル 2" に設定します。
BarCodeControl1.QRModel = AdvanceSoftware.VBBarCode.QRModel.Model2
' QR コードの型番を "2 型" に設定します。
BarCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version2
BarCodeControl1.Element = 10
' 連結 QR コードを自動で作成します。
BarCodeControl1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.AutoConnect
' シンボル番号を初期化します。
BarCodeControl1.QRSymbolNumber = 0
BarCodeControl1.Value = "123456789123456789123456789123456789"
' 分割 QR コード数をチェックします。
If BarCodeControl1.ErrorNo = AdvanceSoftware.VBBarCode.ErrorNo.QRSymbolOver Then
    MessageBox.Show("連結シンボル数を超えました。")
    Exit Sub
End If
' ループ文で1シンボルずつQRコードを出力(emfファイル保存)します。
For nSymbol = 0 To 2
    BarCodeControl1.QRSymbolNumber = nSymbol
    ' 次に作成する QR コードがなければループを抜ける
    If BarCodeControl1.ErrorNo = AdvanceSoftware.VBBarCode.ErrorNo.QRConnectPos Then
        Exit For
    Else
        nSymbolCnt += 1
        BarCodeControl1.Save(Application.StartupPath & "\QRCode" & nSymbolCnt.ToString() & ".emf", System.Drawing.ImageFormat.Emf)
    End If
Next

QR コードを手動で連結する

このセクションでは、QR コードを手動で連結する方法を説明します。

次のコードは、QRConnect プロパティで [ManualConnect] を設定し、QR コードを手動で連結して作成するサンプルコードです。任意のエスケープコードを設定して、エスケープコードで QR コードを分割します。

コピーC#
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
// QR コードのエラー訂正レベルを "H" に設定します。
barCodeControl1.QRLevel = AdvanceSoftware.VBBarCode.QRLevel.LevelH;
// QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
barCodeControl1.QRMask = AdvanceSoftware.VBBarCode.QRMask.Mask000;
// QR コードのモデルを "モデル 2" に設定します。
barCodeControl1.QRModel = AdvanceSoftware.VBBarCode.QRModel.Model2;
// QR コードの型番を "2 型" に設定します。
barCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version2;
barCodeControl1.Element = 10;
// 連結 QR コードを手動で作成します。
barCodeControl1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect;
// QR コードのエスケープコードを "% (0x25)" に設定します。
barCodeControl1.QREscapeCode = 0x25;
barCodeControl1.Value = "12345%SABCDE";
// 1 つ目の連結 QR コードを出力します。
barCodeControl1.QRSymbolNumber = 0;
barCodeControl1.Save(Application.StartupPath + @"\QRCode1.emf", System.Drawing.Imaging.ImageFormat.Emf);
// 2 つ目の連結 QR コードを出力します。
barCodeControl1.QRSymbolNumber = 1;
barCodeControl1.Save(Application.StartupPath + @"\QRCode2.emf", System.Drawing.Imaging.ImageFormat.Emf);
コピーVB.NET
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
' QR コードのエラー訂正レベルを "H" に設定します。
BarCodeControl1.QRLevel = AdvanceSoftware.VBBarCode.QRLevel.LevelH
' QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
BarCodeControl1.QRMask = AdvanceSoftware.VBBarCode.QRMask.Mask000
' QR コードのモデルを "モデル 2" に設定します。
BarCodeControl1.QRModel = AdvanceSoftware.VBBarCode.QRModel.Model2
' QR コードの型番を "2 型" に設定します。
BarCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version2
BarCodeControl1.Element = 10
' 連結 QR コードを手動で作成します。
BarCodeControl1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect
' QR コードのエスケープコードを "% (0x25)" に設定します。
BarCodeControl1.QREscapeCode = &H25
BarCodeControl1.Value = "12345%SABCDE"
' 1 つ目の連結 QR コードを出力します。
BarCodeControl1.QRSymbolNumber = 0
BarCodeControl1.Save(Application.StartupPath & "\QRCode1.emf", System.Drawing.ImageFormat.Emf)
' 2 つ目の連結 QR コードを出力します。
BarCodeControl1.QRSymbolNumber = 1
BarCodeControl1.Save(Application.StartupPath & "\QRCode2.emf", System.Drawing.ImageFormat.Emf)

参照

バーコードタイプ別の作成方法
Type
Unit
DpiX
DpiY
Value
QRConnect
QREscapeCode
QRLevel
QRMask
QRModel
QRSymbolNumber
QRVersion


基本操作

[image]

VB-BarCode 5.0 for .NET
基本操作

ここでは、VB-BarCode 5.0 for .NET の基本操作について説明します。

バーコードのサイズを変更する

バーコードのサイズを変更する方法を説明します。

高精度なバーコードを作成する

高精度なバーコードを作成する方法を説明します。

バーコードを出力する

さまざまなバーコードの出力方法を説明します。


バーコードのサイズを変更する

[image]

VB-BarCode 5.0 for .NET
バーコードのサイズを変更する
参照

VB-BarCode 5.0 for .NET では、バーコードのサイズを変更することが可能なメソッドやプロパティが複数あります。このトピックでは、バーコードのサイズを変更する方法を説明します。

このトピックは、次のセクションを含みます。

  • Element プロパティで最小エレメント幅を変更する
  • BarWidth プロパティでバーコードの幅を変更する
  • BarHeight プロパティでバーコードの高さを変更する

Element プロパティで最小エレメント幅を変更する

このセクションでは、Element プロパティで最小エレメント幅を変更する方法を説明します。最小エレメント幅を変更することでバーコードの幅を変更することが可能です。Unit プロパティで設定した単位で最小エレメント値が設定されます。

次のコードは、Element プロパティで最小エレメントを設定するサンプルコードです。

コピーC#
// バーコードイメージの生成単位をピクセルに設定します。
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// バーコードイメージの最小エレメント値を "1ピクセル" に設定します。
barCode1.Element = 1;
コピーVB.NET
' バーコードイメージの生成単位をピクセルに設定します。
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' バーコードイメージの最小エレメント値を "1ピクセル" に設定します。
BarCode1.Element = 1

BarWidth プロパティでバーコードの幅を変更する

このセクションでは、BarWidth プロパティでバーコードの幅を変更する方法を説明します。Unit プロパティで設定した単位でバーコード幅が設定されます。

次のコードは、BarWidth プロパティでバーコードの幅を変更するサンプルコードです。

コピーC#
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードイメージの幅を "60.0mm" に設定します。
barCode1.BarWidth = 60.0;
コピーVB.NET
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードイメージの幅を "60.0mm" に設定します。
BarCode1.BarWidth = 60.0

BarHeight プロパティでバーコードの高さを変更する

このセクションでは、BarHeight プロパティでバーコードの高さを変更する方法を説明します。Unit プロパティで設定した単位でバーコードの高さが設定されます。

次のコードは、BarHeight プロパティでバーコードの高さを変更するサンプルコードです。

コピーC#
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードイメージの高さを "30.0mm" に設定します。
barCode1.BarHeight = 30.0;
コピーVB.NET
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードイメージの高さを "30.0mm" に設定します。
BarCode1.BarHeight = 30.0

参照

基本操作
Element
BarWidth
BarHeight


高精度なバーコードを出力する

[image]

VB-BarCode 5.0 for .NET
高精度なバーコードを出力する
参照

VB-BarCode 5.0 for .NET で生成したバーコードに、太りや細りが発生する、または、バーコードリーダーで読み取れない場合、精度の低いバーコードが生成されている可能性があります。このトピックでは、VB-BarCode 5.0 for .NET で高精度なバーコードを出力するための対処方法について説明します。

このトピックは、次のセクションを含みます。

  • 高精度なバーコードを印刷する
  • 高精度なイメージファイルを保存する

高精度なバーコードを印刷する

高精度なバーコードを印刷するための対処方法を説明します。

プリンタの解像度について

高解像度での印刷をお勧めします。解像度が高い場合でも、 印刷時にトナーを省略したり高速印刷モードが選択されていると精度の低いバーコードが印刷される場合があります。 そのため、プリンタの設定にて画像を高画質で印刷することができる設定にしてください。

なお、Code128、GS1-128 のバーコードでは、バーコードのバー、スペースごとにドット単位でエレメント幅を補正することができます。 ドット補正により印刷品質を向上させることが可能です。 詳細については バーコードタイプ別の作成方法内の該当するバーコード作成方法ページをご確認ください。

Unit プロパティでピクセル単位でのバーコードを生成する

Unit プロパティでバーコードの生成単位をピクセル（Pixel）以外を指定した場合、 精度の低いバーコードが生成される場合があるため、ピクセル単位でバーコードを生成してください。

DpiX、DpiY プロパティの値について

DpiX、DpiY プロパティで設定した解像度と印刷する際の解像度が異なっている場合、 精度の低いバーコードが生成されます。そのため、DpiX、DpiY プロパティの値は、 バーコードを印刷するプリンタの解像度と同じ値を設定してください。

印刷方法について

VB-BarCode 5.0 for .NET の Print メソッド以外のクリップボードに転送、または、他のアプリケーションにて印刷を行った場合、 印刷するアプリケーションにより、バーコードイメージの拡大や縮小が行われて VB-BarCode 5.0 for .NET で指定したサイズに印刷されないことや、 太りや細りの発生による精度の悪いバーコードイメージが印刷される場合があります。 そのため、VB-BarCode 5.0 for .NET で設定したサイズでバーコードを直接印刷することが可能な Print メソッドを使用する方法をご検討ください。

高精度なイメージファイルを保存する

高精度なバーコードイメージファイルを保存するための対処方法を説明します。

バーコードイメージのファイル形式について

高精度なバーコードイメージファイルとして保存する場合、拡張メタ形式(EMF)、または SVG 形式で保存することをお勧めします。 ビットマップ形式 (BMP) で保存した場合、ビットマップの性質により、バーの太りや細りが目立ち、 精度の低いバーコードが生成される可能性があります。

Note メモ:

生成したバーコードに、そのバーコードでは使用することができない文字 (例 : Codabar の場合、スタート・ストップコード以外に、英字は使用不可) が含まれている場合、 VB-BarCode 5.0 for .NET は与えられたバーコードメッセージにて使用不可文字のチェックを行っていないため、 バーコードリーダーで読み取ることができません。そのため、各バーコードにて使用可能な文字列を設定してください。

参照

基本操作

©2020 Advance Software inc. All rights reserved.


バーコードを出力する

[image]

VB-BarCode 5.0 for .NET
バーコードを出力する

VB-BarCode 5.0 for .NET では、直接印刷、画像、SVG 形式でバーコードを出力することが可能です。ここでは、アプリケーションの種類別にバーコードを出力する方法について説明します。

Windows フォーム アプリケーションを使用する

Windows フォーム アプリケーションでバーコードを出力する方法を説明します。

WPF アプリケーションを使用する

WPF アプリケーションでバーコードを出力する方法を説明します。

Web サイト / Web アプリケーションを使用する

Web サイト / Web アプリケーションでバーコードを出力する方法を説明します。


Windows フォーム アプリケーションを使用する

[image]

VB-BarCode 5.0 for .NET
Windows フォーム アプリケーションを使用する

ここでは、Windows フォーム アプリケーションでバーコードを出力する方法を説明します。

バーコードイメージを出力する

Windows フォーム アプリケーションでバーコードイメージを出力する方法を説明します。

SVG 形式のバーコードイメージを出力する

Windows フォーム アプリケーションでSVG 形式のバーコードイメージを出力する方法を説明します。

圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する

Windows フォーム アプリケーションで圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する方法を説明します。

直接印刷する

Windows フォーム アプリケーションで直接印刷する方法を説明します。


バーコードイメージを出力する

[image]

VB-BarCode 5.0 for .NET
バーコードイメージを出力する
参照

このトピックでは、Windows フォーム アプリケーション上でバーコードコントロールを使用してバーコードイメージを出力する手順とバーコードコンポーネントを使用してバーコードイメージを出力する手順を説明します。 以下の手順では、新規に作成した Windows フォーム アプリケーションに バーコードコントロール、または、バーコードコンポーネントを追加してバーコードイメージを出力します。

このトピックは、次のセクションを含みます。

  • バーコードイメージを出力する (バーコードコントロール)
    •
  • バーコードイメージを出力する (バーコードコンポーネント)

バーコードイメージを出力する (バーコードコントロール)

  1. [ファイル] - [新しいプロジェクト] から新しい Windows フォーム アプリケーションを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームに バーコードコントロールを配置します。

    Note メモ:

    バーコードコントロールの配置方法は「バーコードコントロールを追加する」を参照してください。

  4. Button1 のイベントにプロジェクトに追加した バーコードコントロールでバーコードイメージを出力する、下記サンプルコードを追加します。

    Note メモ:

    保存方法や保存可能な画像の形式は、「Save メソッド」を参照してください。

    コピーC#
    barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
barCodeControl1.Zoom = 100;
barCodeControl1.Value = "499385766919";
// バーコードイメージを出力します。
barCodeControl1.Save(@"C:\BarCodeImage.jpg", System.Drawing.Imaging.ImageFormat.Bmp,true);
    コピーVB.NET
    BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
BarCodeControl1.Zoom = 100
BarCodeControl1.Value = "499385766919"
' バーコードイメージを出力します。
BarCodeControl1.Save("C:\BarCodeImage.jpg", System.Drawing.Imaging.ImageFormat.Bmp, True)

  5. Button1 をクリックするとバーコードイメージを出力します。

バーコードイメージを出力する (バーコードコンポーネント)

  1. [ファイル] - [新しいプロジェクト] から新しい Windows フォーム アプリケーションを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにバーコードコンポーネントを追加します。このセクションでは、バーコードコンポーネントを [ツールボックスから追加する] 手順で追加します。

    Note メモ:

    バーコードコンポーネントの追加方法は「バーコードコンポーネントを追加する」を参照してください。

  4. Button1 のイベントにプロジェクトに追加したバーコードコンポーネントでバーコードイメージを出力する、下記サンプルコードを追加します。

    Note メモ:

    保存方法や保存可能な画像の形式は、「Save メソッド」を参照してください。

    コピーC#
    barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
barCode1.DpiX = 600;
barCode1.DpiY = 600;
barCode1.Zoom = 100;
barCode1.Value = "499385766919";
// バーコードイメージを出力します。
barCode1.Save(@"C:\BarCodeImage.jpg", System.Drawing.Imaging.ImageFormat.Bmp,true);
    コピーVB.NET
    BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
BarCode1.DpiX = 600
BarCode1.DpiY = 600
BarCode1.Zoom = 100
BarCode1.Value = "499385766919"
' バーコードイメージを出力します。
BarCode1.Save("C:\BarCodeImage.jpg", System.Drawing.Imaging.ImageFormat.Bmp, True)

  5. Button1 をクリックするとバーコードイメージを出力します。

参照

Windows フォーム アプリケーションを使用する


SVG 形式のバーコードイメージを出力する

[image]

VB-BarCode 5.0 for .NET
SVG 形式のバーコードイメージを出力する
参照

このトピックでは、Windows フォーム アプリケーション上でバーコードコントロールを使用して SVG 形式のバーコードイメージを出力する手順とバーコードコンポーネントを使用して SVG 形式のバーコードイメージを出力する手順を説明します。 以下の手順では、新規に作成した Windows フォーム アプリケーションに バーコードコントロール、バーコードコンポーネントを追加してSVG 形式のバーコードイメージを出力します。

このトピックは、次のセクションを含みます。

  • SVG 形式のバーコードイメージを出力する (バーコードコントロール)
    •
  • SVG 形式のバーコードイメージを出力する (バーコードコンポーネント)

SVG 形式のバーコードイメージを出力する (バーコードコントロール)

  1. [ファイル] - [新しいプロジェクト] から新しい Windows フォーム アプリケーションを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームに バーコードコントロールを配置します。

    Note メモ:

    バーコードコントロールの配置方法は「バーコードコントロールを追加する」を参照してください。

  4. Button1 のイベントにプロジェクトに追加した バーコードコントロールで SVG 形式のバーコードイメージを出力する、下記サンプルコードを追加します。

    Note メモ:

    SaveSvg メソッドの詳細は、「SaveSvg メソッド」を参照してください。

    コピーC#
    barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
barCodeControl1.Zoom = 100;
barCodeControl1.Value = "499385766919";
//  SVG 形式のバーコードイメージを出力します。
barCodeControl1.SaveSvg(@"C:\BarCodeImage.svg");
    コピーVB.NET
    BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
BarCodeControl1.Zoom = 100
BarCodeControl1.Value = "499385766919"
'  SVG 形式のバーコードイメージを出力します。
BarCodeControl1.SaveSvg("C:\BarCodeImage.svg")

  5. Button1 をクリックするとバーコードイメージを出力します。

SVG 形式のバーコードイメージを出力する (バーコードコンポーネント)

  1. [ファイル] - [新しいプロジェクト] から新しい Windows フォーム アプリケーションを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにバーコードコンポーネントを追加します。このセクションでは、バーコードコンポーネントを [ツールボックスから追加する] 手順で追加します。

    Note メモ:

    バーコードコンポーネントの追加方法は「バーコードコンポーネントを追加する」を参照してください。

  4. Button1 のイベントにプロジェクトに追加したバーコードコンポーネントでSVG 形式のバーコードイメージを出力する、下記サンプルコードを追加します。

    Note メモ:

    SaveSvg メソッドの詳細は、「SaveSvg メソッド」を参照してください。

    コピーC#
    barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
barCode1.DpiX = 600;
barCode1.DpiY = 600;
barCode1.Zoom = 100;
barCode1.Value = "499385766919";
//  SVG 形式のバーコードイメージを出力します。
barCode1.SaveSvg(@"C:\BarCodeImage.svg");
    コピーVB.NET
    BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
BarCode1.DpiX = 600
BarCode1.DpiY = 600
BarCode1.Zoom = 100
BarCode1.Value = "499385766919"
' SVG 形式のバーコードイメージを出力します。
BarCode1.SaveSvg("C:\BarCodeImage.svg")

  5. Button1 をクリックするとバーコードイメージを出力します。

参照

Windows フォーム アプリケーションを使用する


圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する

[image]

VB-BarCode 5.0 for .NET
圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する
参照

このトピックでは、Windows フォーム アプリケーション上でバーコードコントロールを使用して 圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する手順とバーコードコンポーネントを使用して 圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する手順を説明します。 以下の手順では、新規に作成した Windows フォーム アプリケーションに バーコードコントロール、バーコードコンポーネントを追加して圧縮 SVG 形式(SVGZ)のバーコードイメージを出力します。

このトピックは、次のセクションを含みます。

  • 圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する (バーコードコントロール)
    •
  • 圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する (バーコードコンポーネント)

圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する (バーコードコントロール)

  1. [ファイル] - [新しいプロジェクト] から新しい Windows フォーム アプリケーションを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームに バーコードコントロールを配置します。

    Note メモ:

    バーコードコントロールの配置方法は「バーコードコントロールを追加する」を参照してください。

  4. Button1 のイベントにプロジェクトに追加した バーコードコントロールで 圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する、下記サンプルコードを追加します。

    Note メモ:

    SaveSvgz メソッドの詳細は、「SaveSvgz メソッド」を参照してください。

    コピーC#
    barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
barCodeControl1.Zoom = 100;
barCodeControl1.Value = "499385766919";
//  圧縮 SVG 形式(SVGZ)のバーコードイメージを出力します。
barCodeControl1.SaveSvgz(@"C:\BarCodeImage.svgz");
    コピーVB.NET
    BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
BarCodeControl1.Zoom = 100
BarCodeControl1.Value = "499385766919"
'  圧縮 SVG 形式(SVGZ)のバーコードイメージを出力します。
BarCodeControl1.SaveSvgz("C:\BarCodeImage.svgz")

  5. Button1 をクリックするとバーコードイメージを出力します。

圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する (バーコードコンポーネント)

  1. [ファイル] - [新しいプロジェクト] から新しい Windows フォーム アプリケーションを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにバーコードコンポーネントを追加します。このセクションでは、バーコードコンポーネントを [ツールボックスから追加する] 手順で追加します。

    Note メモ:

    バーコードコンポーネントの追加方法は「バーコードコンポーネントを追加する」を参照してください。

  4. Button1 のイベントにプロジェクトに追加したバーコードコンポーネントで圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する、下記サンプルコードを追加します。

    Note メモ:

    SaveSvgz メソッドの詳細は、「SaveSvgz メソッド」を参照してください。

    コピーC#
    barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
barCode1.DpiX = 600;
barCode1.DpiY = 600;
barCode1.Zoom = 100;
barCode1.Value = "499385766919";
//  圧縮 SVG 形式(SVGZ)のバーコードイメージを出力します。
barCode1.SaveSvgz(@"C:\BarCodeImage.svgz");
    コピーVB.NET
    BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
BarCode1.DpiX = 600
BarCode1.DpiY = 600
BarCode1.Zoom = 100
BarCode1.Value = "499385766919"
' 圧縮 SVG 形式(SVGZ)のバーコードイメージを出力します。
BarCode1.SaveSvgz("C:\BarCodeImage.svgz")

  5. Button1 をクリックするとバーコードイメージを出力します。

参照

Windows フォーム アプリケーションを使用する


直接印刷する

[image]

VB-BarCode 5.0 for .NET
直接印刷する
参照

このトピックでは、Windows フォーム アプリケーション上でバーコードコントロールを使用して直接印刷する手順とバーコードコンポーネントを使用して直接印刷する手順を説明します。 以下の手順では、新規に作成した Windows フォーム アプリケーションに バーコードコントロール、バーコードコンポーネントを追加して直接印刷します。

このトピックは、次のセクションを含みます。

  • 直接印刷する (バーコードコントロール)
    •
  • 直接印刷する (バーコードコンポーネント)

直接印刷する (バーコードコントロール)

  1. [ファイル] - [新しいプロジェクト] から新しい Windows フォーム アプリケーションを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームに バーコードコントロールを配置します。

    Note メモ:

    バーコードコントロールの配置方法は「バーコードコントロールを追加する」を参照してください。

  4. バーコードコントロールをクリックし、下記のようにプロパティの値を変更します。

    プロパティ名 | 設定値
    Size | 20, 20(任意の値を設定してください)
    Visible | False

  5. Button1 のイベントにプロジェクトに追加した バーコードコントロールで直接印刷する、下記サンプルコードを追加します。

    コピーC#
    barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// プリンタの解像度に合わせて設定します。
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
barCodeControl1.Zoom = 100;
barCodeControl1.Value = "499385766919";
// Print メソッドで印刷します。
barCodeControl1.Print();
    コピーVB.NET
    BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' プリンタの解像度に合わせて設定します。
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
BarCodeControl1.Zoom = 100
BarCodeControl1.Value = "499385766919"
' Print メソッドで印刷します。
BarCodeControl1.Print()

  6. Button1 をクリックすると直接印刷します。

直接印刷する (バーコードコンポーネント)

  1. [ファイル] - [新しいプロジェクト] から新しい Windows フォーム アプリケーションを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにバーコードコンポーネントを追加します。このセクションでは、バーコードコンポーネントを [ツールボックスから追加する] 手順で追加します。

    Note メモ:

    バーコードコンポーネントの追加方法は「バーコードコンポーネントを追加する」を参照してください。

  4. Button1 のイベントにプロジェクトに追加したバーコードコンポーネントで直接印刷する、下記サンプルコードを追加します。

    コピーC#
    barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// プリンタの解像度に合わせて設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
barCode1.Zoom = 100;
barCode1.Value = "499385766919";
// Print メソッドで印刷します。
barCode1.Print();
    コピーVB.NET
    BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' プリンタの解像度に合わせて設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
BarCode1.Zoom = 100
BarCode1.Value = "499385766919"
' Print メソッドで印刷します。
BarCode1.Print()

  5. Button1 をクリックすると直接印刷します。

参照

Windows フォーム アプリケーションを使用する


WPF アプリケーションを使用する

[image]

VB-BarCode 5.0 for .NET
WPF アプリケーションを使用する

ここでは、WPF アプリケーションでバーコードを出力する方法を説明します。

バーコードイメージを出力する

WPF アプリケーションでバーコードイメージを出力する方法を説明します。

SVG 形式のバーコードイメージを出力する

WPF アプリケーションで SVG 形式のバーコードイメージを出力する方法を説明します。

圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する

WPF アプリケーションで圧縮 SVG 形式(SVGZ)バーコードイメージを出力する方法を説明します。


バーコードイメージを出力する

[image]

VB-BarCode 5.0 for .NET
バーコードイメージを出力する
参照

このトピックでは、WPF アプリケーション上でバーコードコントロールを使用してバーコードイメージを出力する手順とバーコードコンポーネントを使用してバーコードイメージを出力する手順を説明します。 以下の手順では、新規に作成した WPF アプリケーションに バーコードコントロール、バーコードコンポーネントを追加してバーコードイメージを出力します。

このトピックは、次のセクションを含みます。

  • バーコードイメージを出力する (バーコードコントロール)
    •
  • バーコードイメージを出力する (バーコードコンポーネント)

バーコードイメージを出力する (バーコードコントロール)

  1. [ファイル] - [新しいプロジェクト] から新しい WPF アプリケーションを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームに バーコードコントロールを配置します。

    Note メモ:

    バーコードコントロールの配置方法は「バーコードコントロールを追加する」を参照してください。

  4. バーコードコントロールをクリックし、プロパティの名前を以下のように設定します。

    プロジェクト言語 | 名前
    C# | barCodeControl1
    VB | BarCodeControl1

  5. Button1 のイベントにプロジェクトに追加した バーコードコントロールでバーコードイメージを出力する、下記サンプルコードを追加します。

    Note メモ:

    保存方法や保存可能な画像の形式は、「Save メソッド」を参照してください。

    コピーC#
    barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
barCodeControl1.Zoom = 100;
barCodeControl1.Value = "499385766919";
// バーコードイメージを出力します。
barCodeControl1.Save(@"C:\BarCodeImage.bmp");
    コピーVB.NET
    BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
BarCodeControl1.Zoom = 100
BarCodeControl1.Value = "499385766919"
' バーコードイメージを出力します。
BarCodeControl1.Save("C:\BarCodeImage.bmp")

  6. Button1 をクリックするとバーコードイメージを出力します。

バーコードイメージを出力する (バーコードコンポーネント)

  1. [ファイル] - [新しいプロジェクト] から新しい WPF アプリケーションを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにバーコードコンポーネントを追加します。このセクションでは、バーコードコンポーネントを [参照設定から追加する] 手順で追加します。

    Note メモ:

    バーコードコンポーネントの追加方法は「バーコードコンポーネントを追加する」を参照してください。

  4. バーコードコンポーネントをクリックし、プロパティの名前を以下のように設定します。

    プロジェクト言語 | 名前
    C# | barCode1
    VB | BarCode1

  5. Button1 のイベントにプロジェクトに追加したバーコードコンポーネントでバーコードイメージを出力する、下記サンプルコードを追加します。

    Note メモ:

    保存方法や保存可能な画像の形式は、「Save メソッド」を参照してください。

    コピーC#
    barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
barCode1.DpiX = 600;
barCode1.DpiY = 600;
barCode1.Zoom = 100;
barCode1.Value = "499385766919";
// バーコードイメージを出力します。
barCode1.Save(@"C:\BarCodeImage.bmp");
    コピーVB.NET
    BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
BarCode1.DpiX = 600
BarCode1.DpiY = 600
BarCode1.Zoom = 100
BarCode1.Value = "499385766919"
' バーコードイメージを出力します。
BarCode1.Save("C:\BarCodeImage.bmp")

  6. Button1 をクリックするとバーコードイメージを出力します。

参照

WPF アプリケーションを使用する


SVG 形式のバーコードイメージを出力する

[image]

VB-BarCode 5.0 for .NET
SVG 形式のバーコードイメージを出力する
参照

このトピックでは、WPF アプリケーション上でバーコードコントロールを使用して SVG 形式のバーコードイメージを出力する手順とバーコードコンポーネントを使用して SVG 形式のバーコードイメージを出力する手順を説明します。 以下の手順では、新規に作成した WPF アプリケーションに バーコードコントロール、バーコードコンポーネントを追加してSVG 形式のバーコードイメージを出力します。

このトピックは、次のセクションを含みます。

  • SVG 形式のバーコードイメージを出力する (バーコードコントロール)
    •
  • SVG 形式のバーコードイメージを出力する (バーコードコンポーネント)

SVG 形式のバーコードイメージを出力する (バーコードコントロール)

  1. [ファイル] - [新しいプロジェクト] から新しい WPF アプリケーションを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームに バーコードコントロールを配置します。

    Note メモ:

    バーコードコントロールの配置方法は「バーコードコントロールを追加する」を参照してください。

  4. バーコードコントロールをクリックし、プロパティの名前を以下のように設定します。

    プロジェクト言語 | 名前
    C# | barCodeControl1
    VB | BarCodeControl1

  5. Button1 のイベントにプロジェクトに追加した バーコードコントロールで SVG 形式のバーコードイメージを出力する、下記サンプルコードを追加します。

    Note メモ:

    SaveSvg メソッドの詳細は、「SaveSvg メソッド」を参照してください。

    コピーC#
    barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
barCodeControl1.Zoom = 100;
barCodeControl1.Value = "499385766919";
//  SVG 形式のバーコードイメージを出力します。
barCodeControl1.SaveSvg(@"C:\BarCodeImage.svg");
    コピーVB.NET
    BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
BarCodeControl1.Zoom = 100
BarCodeControl1.Value = "499385766919"
'  SVG 形式のバーコードイメージを出力します。
BarCodeControl1.SaveSvg("C:\BarCodeImage.svg")

  6. Button1 をクリックするとバーコードイメージを出力します。

SVG 形式のバーコードイメージを出力する (バーコードコンポーネント)

  1. [ファイル] - [新しいプロジェクト] から新しい WPF アプリケーションを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにバーコードコンポーネントを追加します。このセクションでは、バーコードコンポーネントを [参照設定から追加する] 手順で追加します。

    Note メモ:

    バーコードコンポーネントの追加方法は「バーコードコンポーネントを追加する」を参照してください。

  4. バーコードコンポーネントをクリックし、プロパティの名前を以下のように設定します。

    プロジェクト言語 | 名前
    C# | barCode1
    VB | BarCode1

  5. Button1 のイベントにプロジェクトに追加したバーコードコンポーネントでSVG 形式のバーコードイメージを出力する、下記サンプルコードを追加します。

    Note メモ:

    SaveSvg メソッドの詳細は、「SaveSvg メソッド」を参照してください。

    コピーC#
    barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
barCode1.DpiX = 600;
barCode1.DpiY = 600;
barCode1.Zoom = 100;
barCode1.Value = "499385766919";
//  SVG 形式のバーコードイメージを出力します。
barCode1.SaveSvg(@"C:\BarCodeImage.svg");
    コピーVB.NET
    BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
BarCode1.DpiX = 600
BarCode1.DpiY = 600
BarCode1.Zoom = 100
BarCode1.Value = "499385766919"
' SVG 形式のバーコードイメージを出力します。
BarCode1.SaveSvg("C:\BarCodeImage.svg")

  6. Button1 をクリックするとバーコードイメージを出力します。

参照

WPF アプリケーションを使用する


圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する

[image]

VB-BarCode 5.0 for .NET
圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する
参照

このトピックでは、WPF アプリケーション上でバーコードコントロールを使用して 圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する手順とバーコードコンポーネントを使用して 圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する手順を説明します。 以下の手順では、新規に作成した WPF アプリケーションに バーコードコントロール、バーコードコンポーネントを追加して圧縮 SVG 形式(SVGZ)のバーコードイメージを出力します。

このトピックは、次のセクションを含みます。

  • 圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する (バーコードコントロール)
    •
  • 圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する (バーコードコンポーネント)

圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する (バーコードコントロール)

  1. [ファイル] - [新しいプロジェクト] から新しい WPF アプリケーションを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームに バーコードコントロールを配置します。

    Note メモ:

    バーコードコントロールの配置方法は「バーコードコントロールを追加する」を参照してください。

  4. バーコードコントロールをクリックし、プロパティの名前を以下のように設定します。

    プロジェクト言語 | 名前
    C# | barCodeControl1
    VB | BarCodeControl1

  5. Button1 のイベントにプロジェクトに追加した バーコードコントロールで 圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する、下記サンプルコードを追加します。

    Note メモ:

    SaveSvgz メソッドの詳細は、「SaveSvgz メソッド」を参照してください。

    コピーC#
    barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
barCodeControl1.Zoom = 100;
barCodeControl1.Value = "499385766919";
//  圧縮 SVG 形式(SVGZ)のバーコードイメージを出力します。
barCodeControl1.SaveSvgz(@"C:\BarCodeImage.svgz");
    コピーVB.NET
    BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
BarCodeControl1.Zoom = 100
BarCodeControl1.Value = "499385766919"
'  圧縮 SVG 形式(SVGZ)のバーコードイメージを出力します。
BarCodeControl1.SaveSvgz("C:\BarCodeImage.svgz")

  6. Button1 をクリックするとバーコードイメージを出力します。

圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する (バーコードコンポーネント)

  1. [ファイル] - [新しいプロジェクト] から新しい WPF アプリケーションを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにバーコードコンポーネントを追加します。このセクションでは、バーコードコンポーネントを [参照設定から追加する] 手順で追加します。

    Note メモ:

    バーコードコンポーネントの追加方法は「バーコードコンポーネントを追加する」を参照してください。

  4. バーコードコンポーネントをクリックし、プロパティの名前を以下のように設定します。

    プロジェクト言語 | 名前
    C# | barCode1
    VB | BarCode1

  5. Button1 のイベントにプロジェクトに追加したバーコードコンポーネントで圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する、下記サンプルコードを追加します。

    Note メモ:

    SaveSvgz メソッドの詳細は、「SaveSvgz メソッド」を参照してください。

    コピーC#
    barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
barCode1.DpiX = 600;
barCode1.DpiY = 600;
barCode1.Zoom = 100;
barCode1.Value = "499385766919";
//  圧縮 SVG 形式(SVGZ)のバーコードイメージを出力します。
barCode1.SaveSvgz(@"C:\BarCodeImage.svgz");
    コピーVB.NET
    BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
BarCode1.DpiX = 600
BarCode1.DpiY = 600
BarCode1.Zoom = 100
BarCode1.Value = "499385766919"
' 圧縮 SVG 形式(SVGZ)のバーコードイメージを出力します。
BarCode1.SaveSvgz("C:\BarCodeImage.svgz")

  6. Button1 をクリックするとバーコードイメージを出力します。

参照

WPF アプリケーションを使用する


ASP.NET Web アプリケーションを使用する

[image]

VB-BarCode 5.0 for .NET
ASP.NET Web アプリケーションを使用する

ここでは、ASP.NET Web アプリケーションでバーコードを出力する方法を説明します。

バーコードイメージを出力する

ASP.NET Web アプリケーションでバーコードイメージを出力する方法を説明します。

SVG 形式のバーコードイメージを出力する

ASP.NET Web アプリケーションでSVG 形式のバーコードイメージを出力する方法を説明します。

圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する

ASP.NET Web アプリケーションで圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する方法を説明します。


バーコードイメージを出力する

[image]

VB-BarCode 5.0 for .NET
バーコードイメージを出力する
参照

このトピックでは、ASP.NET Web アプリケーション上でバーコードコンポーネントを使用してバーコードイメージを出力する手順を説明します。 以下の手順では、新規に作成した ASP.NET Web アプリケーションにバーコードコンポーネントを追加してバーコードイメージを出力します。

このトピックは、次のセクションを含みます。

  • バーコードイメージを出力する (バーコードコンポーネント)

バーコードイメージを出力する (バーコードコンポーネント)

  1. [ファイル] - [新しいプロジェクト] から新しい ASP.NET Web アプリケーションを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにバーコードコンポーネントを追加します。このセクションでは、バーコードコンポーネントを [ツールボックスから追加する] 手順で追加します。

    Note メモ:

    バーコードコンポーネントの追加方法は「バーコードコンポーネントを追加する」を参照してください。

  4. Button1 のイベントにプロジェクトに追加したバーコードコンポーネントでバーコードイメージを出力する、下記サンプルコードを追加します。

    Note メモ:

    保存方法や保存可能な画像の形式は、「Save メソッド」を参照してください。

    コピーC#
    barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
barCode1.DpiX = 600;
barCode1.DpiY = 600;
barCode1.Zoom = 100;
barCode1.Value = "499385766919";
// バーコードイメージを出力します。
barCode1.Save(@"C:\BarCodeImage.jpg", System.Drawing.Imaging.ImageFormat.Bmp,true);
    コピーVB.NET
    BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
BarCode1.DpiX = 600
BarCode1.DpiY = 600
BarCode1.Zoom = 100
BarCode1.Value = "499385766919"
' バーコードイメージを出力します。
BarCode1.Save("C:\BarCodeImage.jpg", System.Drawing.Imaging.ImageFormat.Bmp, True)

  5. Button1 をクリックするとバーコードイメージを出力します。

参照

ASP.NET Web アプリケーションを使用する


SVG 形式のバーコードイメージを出力する

[image]

VB-BarCode 5.0 for .NET
SVG 形式のバーコードイメージを出力する
参照

このトピックでは、ASP.NET Web アプリケーション上でバーコードコンポーネントを使用して SVG 形式のバーコードイメージを出力する手順を説明します。 以下の手順では、新規に作成した ASP.NET Web アプリケーションにバーコードコンポーネントを追加して SVG 形式のバーコードイメージを出力し、任意の HTML タグに SVG を指定することで Web ページにバーコードを表示させます。

このトピックは、次のセクションを含みます。

  • SVG 形式のバーコードイメージを出力する (バーコードコンポーネント)

SVG 形式のバーコードイメージを出力する (バーコードコンポーネント)

  1. [ファイル] - [新しいプロジェクト] から新しい ASP.NET Web アプリケーションを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにバーコードコンポーネントを追加します。このセクションでは、バーコードコンポーネントを [ツールボックスから追加する] 手順で追加します。

    Note メモ:

    バーコードコンポーネントの追加方法は「バーコードコンポーネントを追加する」を参照してください。

  4. SVG 形式で作成したバーコードイメージを表示させる以下のタグをデザイナ画面に追加します。

    コピーHTML
    <div id="BarCodeImage" runat="server"/>

  5. Button1 のイベントにプロジェクトに追加したバーコードコンポーネントでSVG 形式のバーコードイメージを出力する、下記サンプルコードを追加します。

    Note メモ:

    SaveSvg メソッドの詳細は、「SaveSvg メソッド」を参照してください。

    コピーC#
    barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
barCode1.DpiX = 600;
barCode1.DpiY = 600;
barCode1.Zoom = 100;
barCode1.Value = "499385766919";
// SVG 形式のバーコードイメージを出力します。
System.IO.MemoryStream ms = new System.IO.MemoryStream();
barCode1.SaveSvg(ms);
// SVG を HTML タグに設定します。
BarCodeImage.InnerHtml = System.Text.Encoding.UTF8.GetString(ms.ToArray());
    コピーVB.NET
    BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
BarCode1.DpiX = 600
BarCode1.DpiY = 600
BarCode1.Zoom = 100
BarCode1.Value = "499385766919"
' SVG 形式のバーコードイメージを出力します。
Dim ms As New System.IO.MemoryStream()
BarCode1.SaveSvg(ms)
' SVG を HTML タグに設定します。
BarCodeImage.InnerHtml = System.Text.Encoding.UTF8.GetString(ms.ToArray())

  6. Button1 をクリックするとバーコードイメージを出力します。

参照

ASP.NET Web アプリケーションを使用する


圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する

[image]

VB-BarCode 5.0 for .NET
圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する
参照

このトピックでは、ASP.NET Web アプリケーション上でバーコードコンポーネントを使用して 圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する手順を説明します。 以下の手順では、新規に作成した ASP.NET Web アプリケーションにバーコードコンポーネントを追加して SVGZ 形式のバーコードイメージを出力します。

このトピックは、次のセクションを含みます。

  • 圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する (バーコードコンポーネント)

圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する (バーコードコンポーネント)

  1. [ファイル] - [新しいプロジェクト] から新しい ASP.NET Web アプリケーションを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにバーコードコンポーネントを追加します。このセクションでは、バーコードコンポーネントを [ツールボックスから追加する] 手順で追加します。

    Note メモ:

    バーコードコンポーネントの追加方法は「バーコードコンポーネントを追加する」を参照してください。

  4. Button1 のイベントにプロジェクトに追加したバーコードコンポーネントで圧縮 SVG 形式(SVGZ)のバーコードイメージを出力する、下記サンプルコードを追加します。

    Note メモ:

    SaveSvgz メソッドの詳細は、「SaveSvgz メソッド」を参照してください。
    コピーC#
    barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
barCode1.DpiX = 600;
barCode1.DpiY = 600;
barCode1.Zoom = 100;
barCode1.Value = "499385766919";
//  圧縮 SVG 形式(SVGZ)のバーコードイメージを出力します。
barCodeControl1.SaveSvgz(@"C:\BarCodeImage.svgz");
    コピーVB.NET
    BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
BarCode1.DpiX = 600
BarCode1.DpiY = 600
BarCode1.Zoom = 100
BarCode1.Value = "499385766919"
'  圧縮 SVG 形式(SVGZ)のバーコードイメージを出力します。
BarCodeControl1.SaveSvgz("C:\BarCodeImage.svgz")

  5. Button1 をクリックするとバーコードイメージを出力します。

参照

ASP.NET Web アプリケーションを使用する


VB-BarCode 4 からの移行

[image]

VB-BarCode 5.0 for .NET
VB-BarCode 4 からの移行

ここでは、VB-BarCode 4 からの移行方法を説明します。

移行手順

VB-BarCode 4 からの移行手順を説明します。

VB-BarCode 4 メンバ対応表

VB-BarCode 4 から VB-BarCode 5.0 for .NET へ移行する際に使用できるメンバ一覧を説明します。

参照

旧バージョンとの互換性、共存

©2020 Advance Software inc. All rights reserved.


移行手順
参照

このトピックでは、VB-BarCode 4 のプロジェクトを修正し、VB-BarCode 5.0 for .NET へ移行する際の手順を説明します。

移行手順

  1. プロジェクトから、VB-BarCode 4 のバーコードコンポーネント、バーコードコントロールを削除します。

    フォームに以下のようにバーコードコンポーネントやバーコードコントロールが配置されている場合、削除します。

    バーコードコンポーネント

    バーコードコントロール

  2. 参照設定から VB-BarCode 4 の以下のアセンブリを削除します。

    コンポーネント名 (.NET Framework 2.0 用)
    AdvanceSoftware.VBBarCode4.BarCode.2
    AdvanceSoftware.VBBarCode4.Silverlight.BarCode.2
    AdvanceSoftware.VBBarCode4.Web.BarCode.2
    AdvanceSoftware.VBBarCode4.WPF.BarCode.2
    コンポーネント名 (.NET Framework 4 用)
    AdvanceSoftware.VBBarCode4.BarCode.4
    AdvanceSoftware.VBBarCode4.Silverlight.BarCode.4
    AdvanceSoftware.VBBarCode4.Web.BarCode.4
    AdvanceSoftware.VBBarCode4.WPF.BarCode.4
    Note メモ:

    VB-BarCode 5.0 for .NET では、Silverlight アプリケーションに対応しておりません。

  3. 使用しているアプリケーションのターゲットフレームワークを NET Framework 4.5.2 以上のバージョンに設定します。

  4. 下記ページを参考に、プロジェクトの参照設定にアプリケーションに対応したバーコードコンポーネント、または、バーコードコントロールを追加します。

    Note メモ:

    バーコードコンポーネント、バーコードコントロールの追加方法は、使用準備を参照してください。

  5. 手順 4 でフォームにバーコードコンポーネントを貼り付けた場合、バーコードコンポーネントの Name プロパティの値を VB-BarCode 4 で使用していたバーコードコンポーネント名に変更します。

    ※上記例は、VB-BarCode 4 でバーコードコンポーネント名 "BarCodeControl1" を使用していたものとします。

  6. VB-BarCode 4 メンバ対応表やクラス ライブラリ リファレンスを参考にコードを修正します。

参照

VB-BarCode 4 からの移行
VB-BarCode 4 メンバ対応表
旧バージョンとの互換性、共存


VB-BarCode 4 メンバ対応表

[image]

VB-BarCode 5.0 for .NET
VB-BarCode 4 メンバ対応表
参照

VB-BarCode 4 のメンバを基に作成された VB-BarCode 5.0 for .NET のメンバ対応表です。
VB-BarCode 4 を使用した経験のある開発者が VB-BarCode 5.0 for .NET のアプリケーションを作成する際の手引きとしてご利用ください。

このトピックは、次のセクションを含みます。

  • AdvanceSoftware.VBBarCode4 名前空間
  • AdvanceSoftware.VBBarCode4.WPF 名前空間
Note メモ:

VB-BarCode 5.0 for .NET では、Silverlight アプリケーション用のコントロールは廃止され、Silverlight アプリケーション未対応となります。上記コントロールからの移行については、移行先のアプリケーションの合わせたメンバ対応表をご参照ください。移行先が Windows / ASP.NET Web アプリケーションの場合、AdvanceSoftware.VBBarCode4 名前空間のセクション、WPF アプリケーションの場合、AdvanceSoftware.VBBarCode4.WPF 名前空間のセクションをご参照ください。

AdvanceSoftware.VBBarCode4 名前空間

このセクションは、次のサブセクションを含みます。

  • BarCode クラス
  • BarCodeControl クラス
  • BarCodeErrorEventArgs クラス
  • BarCodeType 列挙体
  • CheckPattern 列挙体
  • Codeset 列挙体
  • ErrorNo 列挙体
  • PDFModel 列挙体
  • QRConnect 列挙体
  • QRLevel 列挙体
  • QRMask 列挙体
  • QRModel 列挙体
  • QRVersion 列挙体
  • Rotate 列挙体
  • Unit 列挙体

BarCode クラス

VB-BarCode 4 メンバ(メソッド) | VB-BarCode 5.0 for .NET メンバ(メソッド)
AdvanceSoftware.VBBarCode4.BarCode.GetBarCodeImage | AdvanceSoftware.VBBarCode.BarCode.GetBarCodeImage
AdvanceSoftware.VBBarCode4.BarCode.GetScaleSize | AdvanceSoftware.VBBarCode.BarCode.GetScaleSize
AdvanceSoftware.VBBarCode4.BarCode.Print | AdvanceSoftware.VBBarCode.BarCode.Print
AdvanceSoftware.VBBarCode4.BarCode.Save | AdvanceSoftware.VBBarCode.BarCode.Save
VB-BarCode 4 メンバ(プロパティ) | VB-BarCode 5.0 for .NET メンバ(プロパティ)
AdvanceSoftware.VBBarCode4.BarCode._Type | AdvanceSoftware.VBBarCode.BarCode._Type
AdvanceSoftware.VBBarCode4.BarCode._Unit | AdvanceSoftware.VBBarCode.BarCode._Unit
AdvanceSoftware.VBBarCode4.BarCode.BackColor | AdvanceSoftware.VBBarCode.BarCode.BackColor
AdvanceSoftware.VBBarCode4.BarCode.BarColor | AdvanceSoftware.VBBarCode.BarCode.BarColor
AdvanceSoftware.VBBarCode4.BarCode.BarHeight | AdvanceSoftware.VBBarCode.BarCode.BarHeight
AdvanceSoftware.VBBarCode4.BarCode.BarRatio | AdvanceSoftware.VBBarCode.BarCode.BarRatio
AdvanceSoftware.VBBarCode4.BarCode.BarWidth | AdvanceSoftware.VBBarCode.BarCode.BarWidth
AdvanceSoftware.VBBarCode4.BarCode.BinaryValue | AdvanceSoftware.VBBarCode.BarCode.BinaryValue
AdvanceSoftware.VBBarCode4.BarCode.BlackBarRevision | AdvanceSoftware.VBBarCode.BarCode.BlackBarRevision
AdvanceSoftware.VBBarCode4.BarCode.BlackRatio | AdvanceSoftware.VBBarCode.BarCode.BlackRatio
AdvanceSoftware.VBBarCode4.BarCode.CharGap | AdvanceSoftware.VBBarCode.BarCode.CharGap
AdvanceSoftware.VBBarCode4.BarCode.CharSize | AdvanceSoftware.VBBarCode.BarCode.CharSize
AdvanceSoftware.VBBarCode4.BarCode.CheckCharMode | AdvanceSoftware.VBBarCode.BarCode.CheckCharMode
AdvanceSoftware.VBBarCode4.BarCode.CheckPattern | AdvanceSoftware.VBBarCode.BarCode.CheckPattern
AdvanceSoftware.VBBarCode4.BarCode.Codeset | AdvanceSoftware.VBBarCode.BarCode.Codeset
AdvanceSoftware.VBBarCode4.BarCode.DpiX | AdvanceSoftware.VBBarCode.BarCode.DpiX
AdvanceSoftware.VBBarCode4.BarCode.DpiY | AdvanceSoftware.VBBarCode.BarCode.DpiY
AdvanceSoftware.VBBarCode4.BarCode.Element | AdvanceSoftware.VBBarCode.BarCode.Element
AdvanceSoftware.VBBarCode4.BarCode.EmfType | AdvanceSoftware.VBBarCode.BarCode.EmfType
AdvanceSoftware.VBBarCode4.BarCode.ErrorMessage | AdvanceSoftware.VBBarCode.BarCode.ErrorMessage
AdvanceSoftware.VBBarCode4.BarCode.ErrorNo | AdvanceSoftware.VBBarCode.BarCode.ErrorNo
AdvanceSoftware.VBBarCode4.BarCode.FlatHeight | AdvanceSoftware.VBBarCode.BarCode.FlatHeight
AdvanceSoftware.VBBarCode4.BarCode.Font | AdvanceSoftware.VBBarCode.BarCode.Font
AdvanceSoftware.VBBarCode4.BarCode.InternalQRVersion | AdvanceSoftware.VBBarCode.BarCode.InternalQRVersion
AdvanceSoftware.VBBarCode4.BarCode.InternalValue | AdvanceSoftware.VBBarCode.BarCode.InternalValue
AdvanceSoftware.VBBarCode4.BarCode.PDFColumn | AdvanceSoftware.VBBarCode.BarCode.PDFColumn
AdvanceSoftware.VBBarCode4.BarCode.PDFInitialSymbol | AdvanceSoftware.VBBarCode.BarCode.PDFInitialSymbol
AdvanceSoftware.VBBarCode4.BarCode.PDFLevel | AdvanceSoftware.VBBarCode.BarCode.PDFLevel
AdvanceSoftware.VBBarCode4.BarCode.PDFModel | AdvanceSoftware.VBBarCode.BarCode.PDFModel
AdvanceSoftware.VBBarCode4.BarCode.PDFRatio | AdvanceSoftware.VBBarCode.BarCode.PDFRatio
AdvanceSoftware.VBBarCode4.BarCode.PDFRow | AdvanceSoftware.VBBarCode.BarCode.PDFRow
AdvanceSoftware.VBBarCode4.BarCode.Point | AdvanceSoftware.VBBarCode.BarCode.Point
AdvanceSoftware.VBBarCode4.BarCode.QRConnect | AdvanceSoftware.VBBarCode.BarCode.QRConnect
AdvanceSoftware.VBBarCode4.BarCode.QREscapeCode | AdvanceSoftware.VBBarCode.BarCode.QREscapeCode
AdvanceSoftware.VBBarCode4.BarCode.QRLevel | AdvanceSoftware.VBBarCode.BarCode.QRLevel
AdvanceSoftware.VBBarCode4.BarCode.QRMask | AdvanceSoftware.VBBarCode.BarCode.QRMask
AdvanceSoftware.VBBarCode4.BarCode.QRModel | AdvanceSoftware.VBBarCode.BarCode.QRModel
AdvanceSoftware.VBBarCode4.BarCode.QRSymbolNumber | AdvanceSoftware.VBBarCode.BarCode.QRSymbolNumber
AdvanceSoftware.VBBarCode4.BarCode.QRVersion | AdvanceSoftware.VBBarCode.BarCode.QRVersion
AdvanceSoftware.VBBarCode4.BarCode.Quiet | AdvanceSoftware.VBBarCode.BarCode.Quiet
AdvanceSoftware.VBBarCode4.BarCode.Rotate | AdvanceSoftware.VBBarCode.BarCode.Rotate
AdvanceSoftware.VBBarCode4.BarCode.ShowBearer | AdvanceSoftware.VBBarCode.BarCode.ShowBearer
AdvanceSoftware.VBBarCode4.BarCode.ShowMessage | AdvanceSoftware.VBBarCode.BarCode.ShowMessage
AdvanceSoftware.VBBarCode4.BarCode.StartChar | AdvanceSoftware.VBBarCode.BarCode.StartChar
AdvanceSoftware.VBBarCode4.BarCode.StopChar | AdvanceSoftware.VBBarCode.BarCode.StopChar
AdvanceSoftware.VBBarCode4.BarCode.TextRenderingHint | AdvanceSoftware.VBBarCode.BarCode.TextRenderingHint
AdvanceSoftware.VBBarCode4.BarCode.Type | AdvanceSoftware.VBBarCode.BarCode.Type
AdvanceSoftware.VBBarCode4.BarCode.Unit | AdvanceSoftware.VBBarCode.BarCode.Unit
AdvanceSoftware.VBBarCode4.BarCode.Value | AdvanceSoftware.VBBarCode.BarCode.Value
AdvanceSoftware.VBBarCode4.BarCode.WhiteBarRevision | AdvanceSoftware.VBBarCode.BarCode.WhiteBarRevision
AdvanceSoftware.VBBarCode4.BarCode.Zoom | AdvanceSoftware.VBBarCode.BarCode.Zoom
VB-BarCode 4 メンバ(イベント) | VB-BarCode 5.0 for .NET メンバ(イベント)
Error | AdvanceSoftware.VBBarCode.BarCode.Error

BarCodeControl クラス

VB-BarCode 4 メンバ(メソッド) | VB-BarCode 5.0 for .NET メンバ(メソッド)
AdvanceSoftware.VBBarCode4.BarCodeControl.GetBarCodeImage | AdvanceSoftware.VBBarCode.BarCodeControl.GetBarCodeImage
AdvanceSoftware.VBBarCode4.BarCodeControl.GetScaleSize | AdvanceSoftware.VBBarCode.BarCodeControl.GetScaleSize
AdvanceSoftware.VBBarCode4.BarCodeControl.Print | AdvanceSoftware.VBBarCode.BarCodeControl.Print
AdvanceSoftware.VBBarCode4.BarCodeControl.Save | AdvanceSoftware.VBBarCode.BarCodeControl.Save
VB-BarCode 4 メンバ(プロパティ) | VB-BarCode 5.0 for .NET メンバ(プロパティ)
AdvanceSoftware.VBBarCode4.BarCodeControl._Type | AdvanceSoftware.VBBarCode.BarCodeControl._Type
AdvanceSoftware.VBBarCode4.BarCodeControl._Unit | AdvanceSoftware.VBBarCode.BarCodeControl._Unit
AdvanceSoftware.VBBarCode4.BarCodeControl.BackColor | AdvanceSoftware.VBBarCode.BarCodeControl.BackColor
AdvanceSoftware.VBBarCode4.BarCodeControl.BarColor | AdvanceSoftware.VBBarCode.BarCodeControl.BarColor
AdvanceSoftware.VBBarCode4.BarCodeControl.BarHeight | AdvanceSoftware.VBBarCode.BarCodeControl.BarHeight
AdvanceSoftware.VBBarCode4.BarCodeControl.BarRatio | AdvanceSoftware.VBBarCode.BarCodeControl.BarRatio
AdvanceSoftware.VBBarCode4.BarCodeControl.BarWidth | AdvanceSoftware.VBBarCode.BarCodeControl.BarWidth
AdvanceSoftware.VBBarCode4.BarCodeControl.BinaryValue | AdvanceSoftware.VBBarCode.BarCodeControl.BinaryValue
AdvanceSoftware.VBBarCode4.BarCodeControl.BlackBarRevision | AdvanceSoftware.VBBarCode.BarCodeControl.BlackBarRevision
AdvanceSoftware.VBBarCode4.BarCodeControl.BlackRatio | AdvanceSoftware.VBBarCode.BarCodeControl.BlackRatio
AdvanceSoftware.VBBarCode4.BarCodeControl.CharGap | AdvanceSoftware.VBBarCode.BarCodeControl.CharGap
AdvanceSoftware.VBBarCode4.BarCodeControl.CharSize | AdvanceSoftware.VBBarCode.BarCodeControl.CharSize
AdvanceSoftware.VBBarCode4.BarCodeControl.CheckCharMode | AdvanceSoftware.VBBarCode.BarCodeControl.CheckCharMode
AdvanceSoftware.VBBarCode4.BarCodeControl.CheckPattern | AdvanceSoftware.VBBarCode.BarCodeControl.CheckPattern
AdvanceSoftware.VBBarCode4.BarCodeControl.Codeset | AdvanceSoftware.VBBarCode.BarCodeControl.Codeset
AdvanceSoftware.VBBarCode4.BarCodeControl.DpiX | AdvanceSoftware.VBBarCode.BarCodeControl.DpiX
AdvanceSoftware.VBBarCode4.BarCodeControl.DpiY | AdvanceSoftware.VBBarCode.BarCodeControl.DpiY
AdvanceSoftware.VBBarCode4.BarCodeControl.Element | AdvanceSoftware.VBBarCode.BarCodeControl.Element
AdvanceSoftware.VBBarCode4.BarCodeControl.EmfType | AdvanceSoftware.VBBarCode.BarCodeControl.EmfType
AdvanceSoftware.VBBarCode4.BarCodeControl.ErrorMessage | AdvanceSoftware.VBBarCode.BarCodeControl.ErrorMessage
AdvanceSoftware.VBBarCode4.BarCodeControl.ErrorNo | AdvanceSoftware.VBBarCode.BarCodeControl.ErrorNo
AdvanceSoftware.VBBarCode4.BarCodeControl.FlatHeight | AdvanceSoftware.VBBarCode.BarCodeControl.FlatHeight
AdvanceSoftware.VBBarCode4.BarCodeControl.Font | AdvanceSoftware.VBBarCode.BarCodeControl.Font
AdvanceSoftware.VBBarCode4.BarCodeControl.InternalQRVersion | AdvanceSoftware.VBBarCode.BarCodeControl.InternalQRVersion
AdvanceSoftware.VBBarCode4.BarCodeControl.InternalValue | AdvanceSoftware.VBBarCode.BarCodeControl.InternalValue
AdvanceSoftware.VBBarCode4.BarCodeControl.PDFColumn | AdvanceSoftware.VBBarCode.BarCodeControl.PDFColumn
AdvanceSoftware.VBBarCode4.BarCodeControl.PDFInitialSymbol | AdvanceSoftware.VBBarCode.BarCodeControl.PDFInitialSymbol
AdvanceSoftware.VBBarCode4.BarCodeControl.PDFLevel | AdvanceSoftware.VBBarCode.BarCodeControl.PDFLevel
AdvanceSoftware.VBBarCode4.BarCodeControl.PDFModel | AdvanceSoftware.VBBarCode.BarCodeControl.PDFModel
AdvanceSoftware.VBBarCode4.BarCodeControl.PDFRatio | AdvanceSoftware.VBBarCode.BarCodeControl.PDFRatio
AdvanceSoftware.VBBarCode4.BarCodeControl.PDFRow | AdvanceSoftware.VBBarCode.BarCodeControl.PDFRow
AdvanceSoftware.VBBarCode4.BarCodeControl.Point | AdvanceSoftware.VBBarCode.BarCodeControl.Point
AdvanceSoftware.VBBarCode4.BarCodeControl.QRConnect | AdvanceSoftware.VBBarCode.BarCodeControl.QRConnect
AdvanceSoftware.VBBarCode4.BarCodeControl.QREscapeCode | AdvanceSoftware.VBBarCode.BarCodeControl.QREscapeCode
AdvanceSoftware.VBBarCode4.BarCodeControl.QRLevel | AdvanceSoftware.VBBarCode.BarCodeControl.QRLevel
AdvanceSoftware.VBBarCode4.BarCodeControl.QRMask | AdvanceSoftware.VBBarCode.BarCodeControl.QRMask
AdvanceSoftware.VBBarCode4.BarCodeControl.QRModel | AdvanceSoftware.VBBarCode.BarCodeControl.QRModel
AdvanceSoftware.VBBarCode4.BarCodeControl.QRSymbolNumber | AdvanceSoftware.VBBarCode.BarCodeControl.QRSymbolNumber
AdvanceSoftware.VBBarCode4.BarCodeControl.QRVersion | AdvanceSoftware.VBBarCode.BarCodeControl.QRVersion
AdvanceSoftware.VBBarCode4.BarCodeControl.Quiet | AdvanceSoftware.VBBarCode.BarCodeControl.Quiet
AdvanceSoftware.VBBarCode4.BarCodeControl.RePaint | AdvanceSoftware.VBBarCode.BarCodeControl.RePaint
AdvanceSoftware.VBBarCode4.BarCodeControl.Rotate | AdvanceSoftware.VBBarCode.BarCodeControl.Rotate
AdvanceSoftware.VBBarCode4.BarCodeControl.ShowBearer | AdvanceSoftware.VBBarCode.BarCodeControl.ShowBearer
AdvanceSoftware.VBBarCode4.BarCodeControl.ShowMessage | AdvanceSoftware.VBBarCode.BarCodeControl.ShowMessage
AdvanceSoftware.VBBarCode4.BarCodeControl.StartChar | AdvanceSoftware.VBBarCode.BarCodeControl.StartChar
AdvanceSoftware.VBBarCode4.BarCodeControl.StopChar | AdvanceSoftware.VBBarCode.BarCodeControl.StopChar
AdvanceSoftware.VBBarCode4.BarCodeControl.TextRenderingHint | AdvanceSoftware.VBBarCode.BarCodeControl.TextRenderingHint
AdvanceSoftware.VBBarCode4.BarCodeControl.Type | AdvanceSoftware.VBBarCode.BarCodeControl.Type
AdvanceSoftware.VBBarCode4.BarCodeControl.Unit | AdvanceSoftware.VBBarCode.BarCodeControl.Unit
AdvanceSoftware.VBBarCode4.BarCodeControl.Value | AdvanceSoftware.VBBarCode.BarCodeControl.Value
AdvanceSoftware.VBBarCode4.BarCodeControl.WhiteBarRevision | AdvanceSoftware.VBBarCode.BarCodeControl.WhiteBarRevision
AdvanceSoftware.VBBarCode4.BarCodeControl.Zoom | AdvanceSoftware.VBBarCode.BarCodeControl.Zoom
VB-BarCode 4 メンバ(イベント) | VB-BarCode 5.0 for .NET メンバ(イベント)
Error | AdvanceSoftware.VBBarCode.BarCodeControl.Error

BarCodeErrorEventArgs クラス

VB-BarCode 4 メンバ(プロパティ) | VB-BarCode 5.0 for .NET メンバ(プロパティ)
AdvanceSoftware.VBBarCode4.BarCodeErrorEventArgs.ErrorNo | AdvanceSoftware.VBBarCode.BarCodeErrorEventArgs.ErrorNo

BarCodeType 列挙体

VB-BarCode 4 メンバ | VB-BarCode 5.0 for .NET メンバ
AdvanceSoftware.VBBarCode4.BarCodeType.JAN13 | AdvanceSoftware.VBBarCode.BarCodeType.JAN13
AdvanceSoftware.VBBarCode4.BarCodeType.JAN8 | AdvanceSoftware.VBBarCode.BarCodeType.JAN8
AdvanceSoftware.VBBarCode4.BarCodeType.UPCA | AdvanceSoftware.VBBarCode.BarCodeType.UPCA
AdvanceSoftware.VBBarCode4.BarCodeType.UPCE | AdvanceSoftware.VBBarCode.BarCodeType.UPCE
AdvanceSoftware.VBBarCode4.BarCodeType.ITF6 | AdvanceSoftware.VBBarCode.BarCodeType.ITF6
AdvanceSoftware.VBBarCode4.BarCodeType.ITF14 | AdvanceSoftware.VBBarCode.BarCodeType.ITF14
AdvanceSoftware.VBBarCode4.BarCodeType.ITF16 | AdvanceSoftware.VBBarCode.BarCodeType.ITF16
AdvanceSoftware.VBBarCode4.BarCodeType.ITF | AdvanceSoftware.VBBarCode.BarCodeType.ITF
AdvanceSoftware.VBBarCode4.BarCodeType.Codabar | AdvanceSoftware.VBBarCode.BarCodeType.Codabar
AdvanceSoftware.VBBarCode4.BarCodeType.Code39 | AdvanceSoftware.VBBarCode.BarCodeType.Code39
AdvanceSoftware.VBBarCode4.BarCodeType.Code128 | AdvanceSoftware.VBBarCode.BarCodeType.Code128
AdvanceSoftware.VBBarCode4.BarCodeType.GS1 | AdvanceSoftware.VBBarCode.BarCodeType.GS1
AdvanceSoftware.VBBarCode4.BarCodeType.CustomerBarCode | AdvanceSoftware.VBBarCode.BarCodeType.CustomerBarCode
AdvanceSoftware.VBBarCode4.BarCodeType.QRCode | AdvanceSoftware.VBBarCode.BarCodeType.QRCode
AdvanceSoftware.VBBarCode4.BarCodeType.PDF417 | AdvanceSoftware.VBBarCode.BarCodeType.PDF417
AdvanceSoftware.VBBarCode4.BarCodeType.GS1Fixed | AdvanceSoftware.VBBarCode.BarCodeType.GS1Fixed

CheckPattern 列挙体

VB-BarCode 4 メンバ | VB-BarCode 5.0 for .NET メンバ
AdvanceSoftware.VBBarCode4.CheckPattern.Modulus16 | AdvanceSoftware.VBBarCode.CheckPattern.Modulus16
AdvanceSoftware.VBBarCode4.CheckPattern.Modulus10Weight2 | AdvanceSoftware.VBBarCode.CheckPattern.Modulus10Weight2
AdvanceSoftware.VBBarCode4.CheckPattern.Modulus10Weight3 | AdvanceSoftware.VBBarCode.CheckPattern.Modulus10Weight3
AdvanceSoftware.VBBarCode4.CheckPattern.Modulus11 | AdvanceSoftware.VBBarCode.CheckPattern.Modulus11
AdvanceSoftware.VBBarCode4.CheckPattern.Modulus11Weight | AdvanceSoftware.VBBarCode.CheckPattern.Modulus11Weight
AdvanceSoftware.VBBarCode4.CheckPattern.SevenCheckDR | AdvanceSoftware.VBBarCode.CheckPattern.SevenCheckDR
AdvanceSoftware.VBBarCode4.CheckPattern.Runes | AdvanceSoftware.VBBarCode.CheckPattern.Runes

Codeset 列挙体

VB-BarCode 4 メンバ | VB-BarCode 5.0 for .NET メンバ
AdvanceSoftware.VBBarCode4.Codeset.Auto | AdvanceSoftware.VBBarCode.Codeset.Auto
AdvanceSoftware.VBBarCode4.Codeset.CodesetA | AdvanceSoftware.VBBarCode.Codeset.CodesetA
AdvanceSoftware.VBBarCode4.Codeset.CodesetB | AdvanceSoftware.VBBarCode.Codeset.CodesetB
AdvanceSoftware.VBBarCode4.Codeset.CodesetC | AdvanceSoftware.VBBarCode.Codeset.CodesetC

ErrorNo 列挙体

VB-BarCode 4 メンバ | VB-BarCode 5.0 for .NET メンバ
AdvanceSoftware.VBBarCode4.ErrorNo.NoError | AdvanceSoftware.VBBarCode.ErrorNo.NoError
AdvanceSoftware.VBBarCode4.ErrorNo.Type | AdvanceSoftware.VBBarCode.ErrorNo.Type
AdvanceSoftware.VBBarCode4.ErrorNo.Unit | AdvanceSoftware.VBBarCode.ErrorNo.Unit
AdvanceSoftware.VBBarCode4.ErrorNo.Zoom | AdvanceSoftware.VBBarCode.ErrorNo.Zoom
AdvanceSoftware.VBBarCode4.ErrorNo.Point | AdvanceSoftware.VBBarCode.ErrorNo.Point
AdvanceSoftware.VBBarCode4.ErrorNo.Rotate | AdvanceSoftware.VBBarCode.ErrorNo.Rotate
AdvanceSoftware.VBBarCode4.ErrorNo.DpiX | AdvanceSoftware.VBBarCode.ErrorNo.DpiX
AdvanceSoftware.VBBarCode4.ErrorNo.DpiY | AdvanceSoftware.VBBarCode.ErrorNo.DpiY
AdvanceSoftware.VBBarCode4.ErrorNo.BlackRatio | AdvanceSoftware.VBBarCode.ErrorNo.BlackRatio
AdvanceSoftware.VBBarCode4.ErrorNo.BarHeight | AdvanceSoftware.VBBarCode.ErrorNo.BarHeight
AdvanceSoftware.VBBarCode4.ErrorNo.BarWidth | AdvanceSoftware.VBBarCode.ErrorNo.BarWidth
AdvanceSoftware.VBBarCode4.ErrorNo.Element | AdvanceSoftware.VBBarCode.ErrorNo.Element
AdvanceSoftware.VBBarCode4.ErrorNo.Quiet | AdvanceSoftware.VBBarCode.ErrorNo.Quiet
AdvanceSoftware.VBBarCode4.ErrorNo.BarRatio | AdvanceSoftware.VBBarCode.ErrorNo.BarRatio
AdvanceSoftware.VBBarCode4.ErrorNo.CharGap | AdvanceSoftware.VBBarCode.ErrorNo.CharGap
AdvanceSoftware.VBBarCode4.ErrorNo.CharSize | AdvanceSoftware.VBBarCode.ErrorNo.CharSize
AdvanceSoftware.VBBarCode4.ErrorNo.CheckPattern | AdvanceSoftware.VBBarCode.ErrorNo.CheckPattern
AdvanceSoftware.VBBarCode4.ErrorNo.CodeSet | AdvanceSoftware.VBBarCode.ErrorNo.CodeSet
AdvanceSoftware.VBBarCode4.ErrorNo.Value | AdvanceSoftware.VBBarCode.ErrorNo.Value
AdvanceSoftware.VBBarCode4.ErrorNo.CheckDigit | AdvanceSoftware.VBBarCode.ErrorNo.CheckDigit
AdvanceSoftware.VBBarCode4.ErrorNo.QRModel | AdvanceSoftware.VBBarCode.ErrorNo.QRModel
AdvanceSoftware.VBBarCode4.ErrorNo.QRVersion | AdvanceSoftware.VBBarCode.ErrorNo.QRVersion
AdvanceSoftware.VBBarCode4.ErrorNo.QRLevel | AdvanceSoftware.VBBarCode.ErrorNo.QRLevel
AdvanceSoftware.VBBarCode4.ErrorNo.QRConnectAct | AdvanceSoftware.VBBarCode.ErrorNo.QRConnectAct
AdvanceSoftware.VBBarCode4.ErrorNo.QRConnect | AdvanceSoftware.VBBarCode.ErrorNo.QRConnect
AdvanceSoftware.VBBarCode4.ErrorNo.QRSourceIsEmpty | AdvanceSoftware.VBBarCode.ErrorNo.QRSourceIsEmpty
AdvanceSoftware.VBBarCode4.ErrorNo.QRSourceIsLarge | AdvanceSoftware.VBBarCode.ErrorNo.QRSourceIsLarge
AdvanceSoftware.VBBarCode4.ErrorNo.QRConnectPos | AdvanceSoftware.VBBarCode.ErrorNo.QRConnectPos
AdvanceSoftware.VBBarCode4.ErrorNo.QREscSeq | AdvanceSoftware.VBBarCode.ErrorNo.QREscSeq
AdvanceSoftware.VBBarCode4.ErrorNo.QRECIAssin | AdvanceSoftware.VBBarCode.ErrorNo.QRECIAssin
AdvanceSoftware.VBBarCode4.ErrorNo.QRKanji | AdvanceSoftware.VBBarCode.ErrorNo.QRKanji
AdvanceSoftware.VBBarCode4.ErrorNo.QRNumChar | AdvanceSoftware.VBBarCode.ErrorNo.QRNumChar
AdvanceSoftware.VBBarCode4.ErrorNo.QRAnkChar | AdvanceSoftware.VBBarCode.ErrorNo.QRAnkChar
AdvanceSoftware.VBBarCode4.ErrorNo.QRByteChar | AdvanceSoftware.VBBarCode.ErrorNo.QRByteChar
AdvanceSoftware.VBBarCode4.ErrorNo.QRKanjiChar | AdvanceSoftware.VBBarCode.ErrorNo.QRKanjiChar
AdvanceSoftware.VBBarCode4.ErrorNo.QRSymbolOver | AdvanceSoftware.VBBarCode.ErrorNo.QRSymbolOver
AdvanceSoftware.VBBarCode4.ErrorNo.QRConnectMode | AdvanceSoftware.VBBarCode.ErrorNo.QRConnectMode
AdvanceSoftware.VBBarCode4.ErrorNo.QRTooManySymbol | AdvanceSoftware.VBBarCode.ErrorNo.QRTooManySymbol
AdvanceSoftware.VBBarCode4.ErrorNo.QRMask | AdvanceSoftware.VBBarCode.ErrorNo.QRMask
AdvanceSoftware.VBBarCode4.ErrorNo.PDFModel | AdvanceSoftware.VBBarCode.ErrorNo.PDFModel
AdvanceSoftware.VBBarCode4.ErrorNo.PDFColumn | AdvanceSoftware.VBBarCode.ErrorNo.PDFColumn
AdvanceSoftware.VBBarCode4.ErrorNo.PDFRow | AdvanceSoftware.VBBarCode.ErrorNo.PDFRow
AdvanceSoftware.VBBarCode4.ErrorNo.PDFLevel | AdvanceSoftware.VBBarCode.ErrorNo.PDFLevel
AdvanceSoftware.VBBarCode4.ErrorNo.PDFAspectRatio | AdvanceSoftware.VBBarCode.ErrorNo.PDFAspectRatio
AdvanceSoftware.VBBarCode4.ErrorNo.PDFSourceIsEmpty | AdvanceSoftware.VBBarCode.ErrorNo.PDFSourceIsEmpty
AdvanceSoftware.VBBarCode4.ErrorNo.PDFSourceIsLarge | AdvanceSoftware.VBBarCode.ErrorNo.PDFSourceIsLarge
AdvanceSoftware.VBBarCode4.ErrorNo.PDFGLIValue | AdvanceSoftware.VBBarCode.ErrorNo.PDFGLIValue
AdvanceSoftware.VBBarCode4.ErrorNo.PDFNumChar | AdvanceSoftware.VBBarCode.ErrorNo.PDFNumChar
AdvanceSoftware.VBBarCode4.ErrorNo.PDFTextChar | AdvanceSoftware.VBBarCode.ErrorNo.PDFTextChar
AdvanceSoftware.VBBarCode4.ErrorNo.PDFByteChar | AdvanceSoftware.VBBarCode.ErrorNo.PDFByteChar
AdvanceSoftware.VBBarCode4.ErrorNo.PDFSymbolOver | AdvanceSoftware.VBBarCode.ErrorNo.PDFSymbolOver

PDFModel 列挙体

VB-BarCode 4 メンバ | VB-BarCode 5.0 for .NET メンバ
AdvanceSoftware.VBBarCode4.PDFModel.Default | AdvanceSoftware.VBBarCode.PDFModel.Default
AdvanceSoftware.VBBarCode4.PDFModel.Truncated | AdvanceSoftware.VBBarCode.PDFModel.Truncated

QRConnect 列挙体

VB-BarCode 4 メンバ | VB-BarCode 5.0 for .NET メンバ
AdvanceSoftware.VBBarCode4.QRConnect.NotConnect | AdvanceSoftware.VBBarCode.QRConnect.NotConnect
AdvanceSoftware.VBBarCode4.QRConnect.AutoConnect | AdvanceSoftware.VBBarCode.QRConnect.AutoConnect
AdvanceSoftware.VBBarCode4.QRConnect.ManualConnect | AdvanceSoftware.VBBarCode.QRConnect.ManualConnect

QRLevel 列挙体

VB-BarCode 4 メンバ | VB-BarCode 5.0 for .NET メンバ
AdvanceSoftware.VBBarCode4.QRLevel.LevelL | AdvanceSoftware.VBBarCode.QRLevel.LevelL
AdvanceSoftware.VBBarCode4.QRLevel.LevelM | AdvanceSoftware.VBBarCode.QRLevel.LevelM
AdvanceSoftware.VBBarCode4.QRLevel.LevelQ | AdvanceSoftware.VBBarCode.QRLevel.LevelQ
AdvanceSoftware.VBBarCode4.QRLevel.LevelH | AdvanceSoftware.VBBarCode.QRLevel.LevelH

QRMask 列挙体

VB-BarCode 4 メンバ | VB-BarCode 5.0 for .NET メンバ
AdvanceSoftware.VBBarCode4.QRMask.MaskAuto | AdvanceSoftware.VBBarCode.QRMask.MaskAuto
AdvanceSoftware.VBBarCode4.QRMask.Mask000 | AdvanceSoftware.VBBarCode.QRMask.Mask000
AdvanceSoftware.VBBarCode4.QRMask.Mask001 | AdvanceSoftware.VBBarCode.QRMask.Mask001
AdvanceSoftware.VBBarCode4.QRMask.Mask010 | AdvanceSoftware.VBBarCode.QRMask.Mask010
AdvanceSoftware.VBBarCode4.QRMask.Mask011 | AdvanceSoftware.VBBarCode.QRMask.Mask011
AdvanceSoftware.VBBarCode4.QRMask.Mask100 | AdvanceSoftware.VBBarCode.QRMask.Mask100
AdvanceSoftware.VBBarCode4.QRMask.Mask101 | AdvanceSoftware.VBBarCode.QRMask.Mask101
AdvanceSoftware.VBBarCode4.QRMask.Mask110 | AdvanceSoftware.VBBarCode.QRMask.Mask110
AdvanceSoftware.VBBarCode4.QRMask.Mask111 | AdvanceSoftware.VBBarCode.QRMask.Mask111

QRModel 列挙体

VB-BarCode 4 メンバ | VB-BarCode 5.0 for .NET メンバ
AdvanceSoftware.VBBarCode4.QRModel.Model1 | AdvanceSoftware.VBBarCode.QRModel.Model1
AdvanceSoftware.VBBarCode4.QRModel.Model2 | AdvanceSoftware.VBBarCode.QRModel.Model2

QRVersion 列挙体

VB-BarCode 4 メンバ | VB-BarCode 5.0 for .NET メンバ
AdvanceSoftware.VBBarCode4.QRVersion.VersionAuto | AdvanceSoftware.VBBarCode.QRVersion.VersionAuto
AdvanceSoftware.VBBarCode4.QRVersion.Version1 | AdvanceSoftware.VBBarCode.QRVersion.Version1
AdvanceSoftware.VBBarCode4.QRVersion.Version2 | AdvanceSoftware.VBBarCode.QRVersion.Version2
AdvanceSoftware.VBBarCode4.QRVersion.Version3 | AdvanceSoftware.VBBarCode.QRVersion.Version3
AdvanceSoftware.VBBarCode4.QRVersion.Version4 | AdvanceSoftware.VBBarCode.QRVersion.Version4
AdvanceSoftware.VBBarCode4.QRVersion.Version5 | AdvanceSoftware.VBBarCode.QRVersion.Version5
AdvanceSoftware.VBBarCode4.QRVersion.Version6 | AdvanceSoftware.VBBarCode.QRVersion.Version6
AdvanceSoftware.VBBarCode4.QRVersion.Version7 | AdvanceSoftware.VBBarCode.QRVersion.Version7
AdvanceSoftware.VBBarCode4.QRVersion.Version8 | AdvanceSoftware.VBBarCode.QRVersion.Version8
AdvanceSoftware.VBBarCode4.QRVersion.Version9 | AdvanceSoftware.VBBarCode.QRVersion.Version9
AdvanceSoftware.VBBarCode4.QRVersion.Version10 | AdvanceSoftware.VBBarCode.QRVersion.Version10
AdvanceSoftware.VBBarCode4.QRVersion.Version11 | AdvanceSoftware.VBBarCode.QRVersion.Version11
AdvanceSoftware.VBBarCode4.QRVersion.Version12 | AdvanceSoftware.VBBarCode.QRVersion.Version12
AdvanceSoftware.VBBarCode4.QRVersion.Version13 | AdvanceSoftware.VBBarCode.QRVersion.Version13
AdvanceSoftware.VBBarCode4.QRVersion.Version14 | AdvanceSoftware.VBBarCode.QRVersion.Version14
AdvanceSoftware.VBBarCode4.QRVersion.Version15 | AdvanceSoftware.VBBarCode.QRVersion.Version15
AdvanceSoftware.VBBarCode4.QRVersion.Version16 | AdvanceSoftware.VBBarCode.QRVersion.Version16
AdvanceSoftware.VBBarCode4.QRVersion.Version17 | AdvanceSoftware.VBBarCode.QRVersion.Version17
AdvanceSoftware.VBBarCode4.QRVersion.Version18 | AdvanceSoftware.VBBarCode.QRVersion.Version18
AdvanceSoftware.VBBarCode4.QRVersion.Version19 | AdvanceSoftware.VBBarCode.QRVersion.Version19
AdvanceSoftware.VBBarCode4.QRVersion.Version20 | AdvanceSoftware.VBBarCode.QRVersion.Version20
AdvanceSoftware.VBBarCode4.QRVersion.Version21 | AdvanceSoftware.VBBarCode.QRVersion.Version21
AdvanceSoftware.VBBarCode4.QRVersion.Version22 | AdvanceSoftware.VBBarCode.QRVersion.Version22
AdvanceSoftware.VBBarCode4.QRVersion.Version23 | AdvanceSoftware.VBBarCode.QRVersion.Version23
AdvanceSoftware.VBBarCode4.QRVersion.Version24 | AdvanceSoftware.VBBarCode.QRVersion.Version24
AdvanceSoftware.VBBarCode4.QRVersion.Version25 | AdvanceSoftware.VBBarCode.QRVersion.Version25
AdvanceSoftware.VBBarCode4.QRVersion.Version26 | AdvanceSoftware.VBBarCode.QRVersion.Version26
AdvanceSoftware.VBBarCode4.QRVersion.Version27 | AdvanceSoftware.VBBarCode.QRVersion.Version27
AdvanceSoftware.VBBarCode4.QRVersion.Version28 | AdvanceSoftware.VBBarCode.QRVersion.Version28
AdvanceSoftware.VBBarCode4.QRVersion.Version29 | AdvanceSoftware.VBBarCode.QRVersion.Version29
AdvanceSoftware.VBBarCode4.QRVersion.Version30 | AdvanceSoftware.VBBarCode.QRVersion.Version30
AdvanceSoftware.VBBarCode4.QRVersion.Version31 | AdvanceSoftware.VBBarCode.QRVersion.Version31
AdvanceSoftware.VBBarCode4.QRVersion.Version32 | AdvanceSoftware.VBBarCode.QRVersion.Version32
AdvanceSoftware.VBBarCode4.QRVersion.Version33 | AdvanceSoftware.VBBarCode.QRVersion.Version33
AdvanceSoftware.VBBarCode4.QRVersion.Version34 | AdvanceSoftware.VBBarCode.QRVersion.Version34
AdvanceSoftware.VBBarCode4.QRVersion.Version35 | AdvanceSoftware.VBBarCode.QRVersion.Version35
AdvanceSoftware.VBBarCode4.QRVersion.Version36 | AdvanceSoftware.VBBarCode.QRVersion.Version36
AdvanceSoftware.VBBarCode4.QRVersion.Version37 | AdvanceSoftware.VBBarCode.QRVersion.Version37
AdvanceSoftware.VBBarCode4.QRVersion.Version38 | AdvanceSoftware.VBBarCode.QRVersion.Version38
AdvanceSoftware.VBBarCode4.QRVersion.Version39 | AdvanceSoftware.VBBarCode.QRVersion.Version39
AdvanceSoftware.VBBarCode4.QRVersion.Version40 | AdvanceSoftware.VBBarCode.QRVersion.Version40

Rotate 列挙体

VB-BarCode 4 メンバ | VB-BarCode 5.0 for .NET メンバ
AdvanceSoftware.VBBarCode4.Rotate.Rotate0 | AdvanceSoftware.VBBarCode.Rotate.Rotate0
AdvanceSoftware.VBBarCode4.Rotate.Rotate90 | AdvanceSoftware.VBBarCode.Rotate.Rotate90
AdvanceSoftware.VBBarCode4.Rotate.Rotate180 | AdvanceSoftware.VBBarCode.Rotate.Rotate180
AdvanceSoftware.VBBarCode4.Rotate.Rotate270 | AdvanceSoftware.VBBarCode.Rotate.Rotate270

Unit 列挙体

VB-BarCode 4 メンバ | VB-BarCode 5.0 for .NET メンバ
AdvanceSoftware.VBBarCode4.Unit.Pixel | AdvanceSoftware.VBBarCode.Unit.Pixel
AdvanceSoftware.VBBarCode4.Unit.Millimeter | AdvanceSoftware.VBBarCode.Unit.Millimeter
AdvanceSoftware.VBBarCode4.Unit.Inch | AdvanceSoftware.VBBarCode.Unit.Inch
AdvanceSoftware.VBBarCode4.Unit.Point | AdvanceSoftware.VBBarCode.Unit.Point

AdvanceSoftware.VBBarCode4.WPF 名前空間

このセクションは、次のサブセクションを含みます。

  • BarCode クラス
  • BarCodeControl クラス

BarCode クラス

VB-BarCode 4 メンバ(メソッド) | VB-BarCode 5.0 for .NET メンバ(メソッド)
AdvanceSoftware.VBBarCode4.WPF.BarCode.GetBarCodeImage | AdvanceSoftware.VBBarCode.Wpf.BarCode.GetBarCodeImage
AdvanceSoftware.VBBarCode4.WPF.BarCode.GetScaleSize | AdvanceSoftware.VBBarCode.Wpf.BarCode.GetScaleSize
AdvanceSoftware.VBBarCode4.WPF.BarCode.Save | AdvanceSoftware.VBBarCode.Wpf.BarCode.Save
VB-BarCode 4 メンバ(プロパティ) | VB-BarCode 5.0 for .NET メンバ(プロパティ)
AdvanceSoftware.VBBarCode4.WPF.BarCode._Type | AdvanceSoftware.VBBarCode.Wpf.BarCode._Type
AdvanceSoftware.VBBarCode4.WPF.BarCode._Unit | AdvanceSoftware.VBBarCode.Wpf.BarCode._Unit
AdvanceSoftware.VBBarCode4.WPF.BarCode.BackColor | AdvanceSoftware.VBBarCode.Wpf.BarCode.BackColor
AdvanceSoftware.VBBarCode4.WPF.BarCode.BarColor | AdvanceSoftware.VBBarCode.Wpf.BarCode.BarColor
AdvanceSoftware.VBBarCode4.WPF.BarCode.BarHeight | AdvanceSoftware.VBBarCode.Wpf.BarCode.BarHeight
AdvanceSoftware.VBBarCode4.WPF.BarCode.BarRatio | AdvanceSoftware.VBBarCode.Wpf.BarCode.BarRatio
AdvanceSoftware.VBBarCode4.WPF.BarCode.BarWidth | AdvanceSoftware.VBBarCode.Wpf.BarCode.BarWidth
AdvanceSoftware.VBBarCode4.WPF.BarCode.BinaryValue | AdvanceSoftware.VBBarCode.Wpf.BarCode.BinaryValue
AdvanceSoftware.VBBarCode4.WPF.BarCode.BlackBarRevision | AdvanceSoftware.VBBarCode.Wpf.BarCode.BlackBarRevision
AdvanceSoftware.VBBarCode4.WPF.BarCode.BlackRatio | AdvanceSoftware.VBBarCode.Wpf.BarCode.BlackRatio
AdvanceSoftware.VBBarCode4.WPF.BarCode.CharGap | AdvanceSoftware.VBBarCode.Wpf.BarCode.CharGap
AdvanceSoftware.VBBarCode4.WPF.BarCode.CharSize | AdvanceSoftware.VBBarCode.Wpf.BarCode.CharSize
AdvanceSoftware.VBBarCode4.WPF.BarCode.CheckCharMode | AdvanceSoftware.VBBarCode.Wpf.BarCode.CheckCharMode
AdvanceSoftware.VBBarCode4.WPF.BarCode.CheckPattern | AdvanceSoftware.VBBarCode.Wpf.BarCode.CheckPattern
AdvanceSoftware.VBBarCode4.WPF.BarCode.Codeset | AdvanceSoftware.VBBarCode.Wpf.BarCode.Codeset
AdvanceSoftware.VBBarCode4.WPF.BarCode.DpiX | AdvanceSoftware.VBBarCode.Wpf.BarCode.DpiX
AdvanceSoftware.VBBarCode4.WPF.BarCode.DpiY | AdvanceSoftware.VBBarCode.Wpf.BarCode.DpiY
AdvanceSoftware.VBBarCode4.WPF.BarCode.Element | AdvanceSoftware.VBBarCode.Wpf.BarCode.Element
AdvanceSoftware.VBBarCode4.WPF.BarCode.ErrorMessage | AdvanceSoftware.VBBarCode.Wpf.BarCode.ErrorMessage
AdvanceSoftware.VBBarCode4.WPF.BarCode.ErrorNo | AdvanceSoftware.VBBarCode.Wpf.BarCode.ErrorNo
AdvanceSoftware.VBBarCode4.WPF.BarCode.FlatHeight | AdvanceSoftware.VBBarCode.Wpf.BarCode.FlatHeight
AdvanceSoftware.VBBarCode4.WPF.BarCode.Font | AdvanceSoftware.VBBarCode.Wpf.BarCode.Font
AdvanceSoftware.VBBarCode4.WPF.BarCode.FontStyle | AdvanceSoftware.VBBarCode.Wpf.BarCode.FontStyle
AdvanceSoftware.VBBarCode4.WPF.BarCode.FontWeight | AdvanceSoftware.VBBarCode.Wpf.BarCode.FontWeight
AdvanceSoftware.VBBarCode4.WPF.BarCode.InternalQRVersion | AdvanceSoftware.VBBarCode.Wpf.BarCode.InternalQRVersion
AdvanceSoftware.VBBarCode4.WPF.BarCode.InternalValue | AdvanceSoftware.VBBarCode.Wpf.BarCode.InternalValue
AdvanceSoftware.VBBarCode4.WPF.BarCode.PDFColumn | AdvanceSoftware.VBBarCode.Wpf.BarCode.PDFColumn
AdvanceSoftware.VBBarCode4.WPF.BarCode.PDFInitialSymbol | AdvanceSoftware.VBBarCode.Wpf.BarCode.PDFInitialSymbol
AdvanceSoftware.VBBarCode4.WPF.BarCode.PDFLevel | AdvanceSoftware.VBBarCode.Wpf.BarCode.PDFLevel
AdvanceSoftware.VBBarCode4.WPF.BarCode.PDFModel | AdvanceSoftware.VBBarCode.Wpf.BarCode.PDFModel
AdvanceSoftware.VBBarCode4.WPF.BarCode.PDFRatio | AdvanceSoftware.VBBarCode.Wpf.BarCode.PDFRatio
AdvanceSoftware.VBBarCode4.WPF.BarCode.PDFRow | AdvanceSoftware.VBBarCode.Wpf.BarCode.PDFRow
AdvanceSoftware.VBBarCode4.WPF.BarCode.Point | AdvanceSoftware.VBBarCode.Wpf.BarCode.Point
AdvanceSoftware.VBBarCode4.WPF.BarCode.QRConnect | AdvanceSoftware.VBBarCode.Wpf.BarCode.QRConnect
AdvanceSoftware.VBBarCode4.WPF.BarCode.QREscapeCode | AdvanceSoftware.VBBarCode.Wpf.BarCode.QREscapeCode
AdvanceSoftware.VBBarCode4.WPF.BarCode.QRLevel | AdvanceSoftware.VBBarCode.Wpf.BarCode.QRLevel
AdvanceSoftware.VBBarCode4.WPF.BarCode.QRMask | AdvanceSoftware.VBBarCode.Wpf.BarCode.QRMask
AdvanceSoftware.VBBarCode4.WPF.BarCode.QRModel | AdvanceSoftware.VBBarCode.Wpf.BarCode.QRModel
AdvanceSoftware.VBBarCode4.WPF.BarCode.QRSymbolNumber | AdvanceSoftware.VBBarCode.Wpf.BarCode.QRSymbolNumber
AdvanceSoftware.VBBarCode4.WPF.BarCode.QRVersion | AdvanceSoftware.VBBarCode.Wpf.BarCode.QRVersion
AdvanceSoftware.VBBarCode4.WPF.BarCode.Quiet | AdvanceSoftware.VBBarCode.Wpf.BarCode.Quiet
AdvanceSoftware.VBBarCode4.WPF.BarCode.Rotate | AdvanceSoftware.VBBarCode.Wpf.BarCode.Rotate
AdvanceSoftware.VBBarCode4.WPF.BarCode.ShowBearer | AdvanceSoftware.VBBarCode.Wpf.BarCode.ShowBearer
AdvanceSoftware.VBBarCode4.WPF.BarCode.ShowMessage | AdvanceSoftware.VBBarCode.Wpf.BarCode.ShowMessage
AdvanceSoftware.VBBarCode4.WPF.BarCode.StartChar | AdvanceSoftware.VBBarCode.Wpf.BarCode.StartChar
AdvanceSoftware.VBBarCode4.WPF.BarCode.StopChar | AdvanceSoftware.VBBarCode.Wpf.BarCode.StopChar
AdvanceSoftware.VBBarCode4.WPF.BarCode.Type | AdvanceSoftware.VBBarCode.Wpf.BarCode.Type
AdvanceSoftware.VBBarCode4.WPF.BarCode.Unit | AdvanceSoftware.VBBarCode.Wpf.BarCode.Unit
AdvanceSoftware.VBBarCode4.WPF.BarCode.Value | AdvanceSoftware.VBBarCode.Wpf.BarCode.Value
AdvanceSoftware.VBBarCode4.WPF.BarCode.WhiteBarRevision | AdvanceSoftware.VBBarCode.Wpf.BarCode.WhiteBarRevision
AdvanceSoftware.VBBarCode4.WPF.BarCode.Zoom | AdvanceSoftware.VBBarCode.Wpf.BarCode.Zoom
VB-BarCode 4 メンバ(イベント) | VB-BarCode 5.0 for .NET メンバ(イベント)
AdvanceSoftware.VBBarCode4.WPF.BarCode.Error | AdvanceSoftware.VBBarCode.Wpf.BarCode.Error

BarCodeControl クラス

VB-BarCode 4 メンバ(メソッド) | VB-BarCode 5.0 for .NET メンバ(メソッド)
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.GetBarCodeImage | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.GetBarCodeImage
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.InitializeComponent | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.InitializeComponent
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.Save | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.Save
VB-BarCode 4 メンバ(プロパティ) | VB-BarCode 5.0 for .NET メンバ(プロパティ)
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl._Type | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl._Type
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl._Unit | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl._Unit
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.BackColor | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.BackColor
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.BarColor | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.BarColor
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.BarHeight | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.BarHeight
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.BarRatio | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.BarRatio
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.BarWidth | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.BarWidth
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.BinaryValue | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.BinaryValue
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.BlackBarRevision | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.BlackBarRevision
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.BlackRatio | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.BlackRatio
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.CharGap | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.CharGap
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.CharSize | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.CharSize
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.CheckCharMode | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.CheckCharMode
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.CheckPattern | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.CheckPattern
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.Codeset | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.Codeset
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.DpiX | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.DpiX
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.DpiY | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.DpiY
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.Element | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.Element
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.ErrorMessage | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.ErrorMessage
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.ErrorNo | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.ErrorNo
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.FlatHeight | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.FlatHeight
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.Font | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.Font
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.FontFamily | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.FontFamily
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.FontSize | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.FontSize
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.FontStretch | AdvanceSoftware.VBBarCode.Wpf.BarCodeContro.FontStretch
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.FontStyle | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.FontStyle
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.FontWeight | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl..FontWeight
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.InternalQRVersion | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.InternalQRVersion
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.InternalValue | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.InternalValue
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.PDFColumn | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.PDFColumn
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.PDFInitialSymbol | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.PDFInitialSymbol
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.PDFLevel | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.PDFLevel
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.PDFModel | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.PDFModel
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.PDFRatio | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.PDFRatio
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.PDFRow | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.PDFRow
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.Point | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.Point
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.QRConnect | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.QRConnect
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.QREscapeCode | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.QREscapeCode
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.QRLevel | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.QRLevel
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.QRMask | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.QRMask
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.QRModel | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.QRModel
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.QRSymbolNumber | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.QRSymbolNumber
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.QRVersion | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.QRVersion
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.Quiet | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.Quiet
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.RePaint | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.RePaint
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.Rotate | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.Rotate
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.ShowBearer | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.ShowBearer
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.ShowMessage | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.ShowMessage
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.StartChar | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.StartChar
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.StopChar | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.StopChar
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.Type | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.Type
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.Unit | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.Unit
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.Value | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.Value
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.WhiteBarRevision | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.WhiteBarRevision
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.Zoom | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.Zoom
VB-BarCode 4 メンバ(イベント) | VB-BarCode 5.0 for .NET メンバ(イベント)
AdvanceSoftware.VBBarCode4.WPF.BarCodeControl.Error | AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.Error

参照

VB-BarCode 4 からの移行

©2020 Advance Software inc. All rights reserved.


旧バージョンとの互換性、共存

[image]

VB-BarCode 5.0 for .NET
旧バージョンとの互換性、共存

このトピックでは、旧バージョンとの互換性、共存について説明します。

このトピックは、次のセクションを含みます。

  • 旧バージョンとの互換性
  • 旧バージョンとの共存

旧バージョンとの互換性

VB-BarCode 5.0 for .NET は、VB-BarCode シリーズのバージョン間で互換性はありません。

また、移行ツールも用意されておりませんので、旧バージョンで作成したプロジェクト、アプリケーションを VB-BarCode 5.0 for .NET で使用することはできません。この場合、新規にアプリケーションを作成していただく必要があります。

旧バージョンとの共存

VB-BarCode シリーズの以下のバージョンは、VB-BarCode 5.0 for .NET と同一の開発環境、実行環境に共存させることができます。

バージョン | 補足事項
VB-BarCode Ver2.0 | ActiveX 版
VB-BarCode .NET | .NET 版
VB-BarCode 4 | .NET 版

参照

VB-BarCode 4 からの移行

©2020 Advance Software inc. All rights reserved.


よくあるご質問

[image]

VB-BarCode 5.0 for .NET
よくあるご質問

このトピックでは、VB-BarCode 5.0 for .NET のよくあるご質問について説明します。さらに詳しい内容は、弊社ホームページの「よくあるご質問」をご参照ください。

このトピックは、次のセクションを含みます。

  • 英語版など、日本語以外の環境に対応していますか。
  • 64ビット版 Windows に対応していますか。
  • 体験版をアンインストールせずに、製品版をインストールしても良いでしょうか。
  • 体験版で作成したアプリケーションを製品版に置き換えて使用しても問題はないでしょうか。
  • インスタンス生成時(起動)に時間が掛かる。
  • 旧バージョンの VB-BarCode から移行する方法を教えてください。

英語版など、日本語以外の環境に対応していますか。

VB-BarCode 5.0 for .NET は、日本語の環境のみ対応しています。英語版など、日本語以外の環境では動作を保証しておりません。

64 ビット版 Windows に対応していますか。

VB-BarCode 5.0 for .NET に収録のアプリケーション、および、製品アセンブリファイル(.dll)は、プラットフォーム(x86,x64)による依存はありません。そのため、どちらのプラットフォームでも使用可能です。

体験版をアンインストールせずに、製品版をインストールしても良いでしょうか。

体験版と製品版は共存することができません。そのため、VB-BarCode 5.0 for .NET の体験版を事前にアンインストールし、製品版をインストールしてください。

体験版で作成したアプリケーションを製品版に置き換えて使用しても問題はないでしょうか。

VB-BarCode 5.0 for .NET 体験版で作成したアプリケーションを、製品版に置き換えて使用することができます。なお、VB-BarCode 5.0 for .NET のアセンブリファイルをアプリケーションフォルダに配置して実行している場合、製品版のファイルをコピーしてご対応ください。

インスタンス生成時(起動)に時間が掛かる。

VB-BarCode 5.0 for .NET は、セキュリティ強化のためアセンブリにデジタル署名を追加しております。デジタル署名が追加されたアセンブリを使用した場合、インターネットに接続されていない環境等、環境によって、インスタンス生成時に処理に時間が掛かる場合がございます。その場合、VB-BarCode 5.0 for .NET ではデジタル署名なしのアセンブリをご用意しており、プロジェクトで参照するアセンブリファイルを入れ替えていただくことで動作が改善する可能性がございます。デジタル署名なしのアセンブリは、製品インストールフォルダ内 [Bin]-[Unsigned] フォルダに格納しております。

旧バージョンの VB-BarCode から移行する方法を教えてください。

VB-BarCode 5.0 for .NET は旧バージョンと互換性がないため、アセンブリの差し替えやコードの修正によって、旧バージョンからの移行が可能です。
移行手順やメンバ対応表などの詳細については「旧バージョンからの移行」を参照してください。


VB-BarCode 5.0 for .NET オブジェクト機能一覧

[image]

VB-BarCode 5.0 for .NET
VB-BarCode 5.0 for .NET オブジェクト機能一覧

ここでは、VB-BarCode 5.0 for .NET でオブジェクト別に設定可能なオブジェクト機能一覧について説明します。クラスライブラリのオブジェクト別逆引き検索ページとしてご使用ください。

バーコードコントロール

バーコードコントロールのオブジェクト機能一覧を説明します。

バーコードコンポーネント

バーコードコンポーネントのオブジェクト機能一覧を説明します。

WPF バーコードコントロール

WPF バーコードコントロールのオブジェクト機能一覧を説明します。

WPF バーコードコンポーネント

WPF バーコードコンポーネントのオブジェクト機能一覧を説明します。


バーコードコントロール

[image]

VB-BarCode 5.0 for .NET
バーコードコントロール
参照

このトピックでは、バーコードコントロールで使用可能なオブジェクト機能一覧を確認することが可能です。

BarCodeControl クラス

メソッド名 | 説明
GetBarCodeImage | バーコードのイメージを作成します。
GetScaleSize | 指定した単位でバーコードのサイズを取得します。
Print | バーコードを印刷します。
Save | バーコードのイメージを保存します。
SaveSvg | バーコードの SVG イメージを保存します。
SaveSvgz | バーコードの圧縮 SVG イメージを保存します。
プロパティ名 | 説明
BackColor | バーコードシンボルの背景色を設定、取得します。 (Overrides Control.BackColor.)
BarColor | バーの色を設定、取得します。
BarHeight | バーコードの高さを設定、取得します。
BarRatio | 太バーのエレメント率を設定、取得します。(Codabar、Code39)
BarWidth | バーコードの幅を設定、取得します。
BinaryValue | バーコードデータを設定、取得します。(バイナリ)
BlackBarRevision | 黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
BlackRatio | 黒バーの太さの比率を設定、取得します。
CharGap | キャラクタ間のギャップを設定、取得します。(Codabar、Code39)
CharSize | バーコードキャラクタのフォントサイズを設定、取得します。
CheckCharMode | 自動でチェックキャラクタを付加するかを設定、取得します。
CheckPattern | チェックデジットの計算方法を設定、取得します。(Codabar)
Codeset | スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))
DpiX | X 軸方向の解像度を設定、取得します。(ピクセル単位)
DpiY | Y 軸方向の解像度を設定、取得します。(ピクセル単位)
Element | 最小エレメント値を設定、取得します。
EmfType | 拡張メタファイル(EMF)に格納されるレコードの品質を設定します。
ErrorMessage | エラーメッセージを取得します。
ErrorNo | エラーナンバーを取得します。
FlatHeight | ガードバーの均等化を設定、取得します。(JAN、UPC)
Font | バーコードメッセージのフォントを設定、取得します。 (Overrides Control.Font.)
InternalQRVersion | QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。
InternalValue | 整形後のバーコードデータを取得します。
MessageAlign | バーコードメッセージの表示横位置を設定、取得します。(GS1Fixed)
PDFColumn | PDF417 の列数を設定、取得します。
PDFInitialSymbol | PDF417 の初期化シンボルを設定、取得します。
PDFLevel | PDF417 のエラー訂正レベルを設定、取得します。
PDFModel | PDF417 シンボルを設定、取得します。
PDFRatio | PDF417 の 1 モジュールの縦横比を設定、取得します。
PDFRow | PDF417 の行数を設定、取得します。
Point | ポイントを設定、取得します。(郵便カスタマバーコード)
QRConnect | 連結 QR コードを作成するかを設定、取得します。
QREscapeCode | QR コードのエスケープコードを設定、取得します。
QRLevel | QR コードの誤り訂正レベルを設定、取得します。
QRMask | QR コードのマスクパターンを設定、取得します。
QRModel | QR コードのモデルを設定、取得します。
QRSymbolNumber | 連結 QR コードで出力するシンボル番号を設定、取得します。
QRVersion | QR コードの型番を設定、取得します。
Quiet | 余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金代理収納 GS1-128)
RePaint | プロパティ変更時の再描画を行うかどうかを設定します。
Rotate | バーコードの回転方向を設定、取得します。
ShowBearer | ベアラバーを表示するかを設定、取得します。(ITF)
ShowMessage | バーコードメッセージを表示するかを設定、取得します。
StartChar | スタートキャラクタを設定、取得します。(Codabar)
StopChar | ストップキャラクタを設定、取得します。(Codabar)
TextRenderingHint | バーコードキャラクタのテキストレンダリングの品質を設定、取得します。
Type | バーコードの種類を設定、取得します。
Unit | バーコードの生成単位を設定、取得します。
Value | バーコードデータを設定、取得します。(文字列)
WhiteBarRevision | 白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
Zoom | 倍率を設定、取得します。(JAN、UPC、ITF)

参照

VB-BarCode 5.0 for .NET の概要

©2020 Advance Software inc. All rights reserved.


バーコードコンポーネント

[image]

VB-BarCode 5.0 for .NET
バーコードコンポーネント
参照

このトピックでは、バーコードコンポーネントで使用可能なオブジェクト機能一覧を確認することが可能です。

BarCode クラス

メソッド名 | 説明
GetBarCodeImage | バーコードのイメージを作成します。
GetScaleSize | 指定した単位でバーコードのサイズを取得します。
Print | バーコードを印刷します。
Save | バーコードのイメージを保存します。
SaveSvg | バーコードの SVG イメージを保存します。
SaveSvgz | バーコードの圧縮 SVG イメージを保存します。
プロパティ名 | 説明
BackColor | バーコードシンボルの背景色を設定、取得します。
BarColor | バーの色を設定、取得します。
BarHeight | バーコードの高さを設定、取得します。
BarRatio | 太バーのエレメント率を設定、取得します。(Codabar、Code39)
BarWidth | バーコードの幅を設定、取得します。
BinaryValue | バーコードデータを設定、取得します。(バイナリ)
BlackBarRevision | 黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
BlackRatio | 黒バーの太さの比率を設定、取得します。
CharGap | キャラクタ間のギャップを設定、取得します。(Codabar、Code39)
CharSize | バーコードキャラクタのフォントサイズを設定、取得します。
CheckCharMode | 自動でチェックキャラクタを付加するかを設定、取得します。
CheckPattern | チェックデジットの計算方法を設定、取得します。(Codabar)
Codeset | スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))
DpiX | X 軸方向の解像度を設定、取得します。(ピクセル単位)
DpiY | Y 軸方向の解像度を設定、取得します。(ピクセル単位)
Element | 最小エレメント値を設定、取得します。
EmfType | 拡張メタファイル(EMF)に格納されるレコードの品質を設定します。
ErrorMessage | エラーメッセージを取得します。
ErrorNo | エラーナンバーを取得します。
FlatHeight | ガードバーの均等化を設定、取得します。(JAN、UPC)
Font | バーコードメッセージのフォントを設定、取得します。
InternalQRVersion | QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。
InternalValue | 整形後のバーコードデータを取得します。
MessageAlign | バーコードメッセージの表示横位置を設定、取得します。(GS1Fixed)
PDFColumn | PDF417 の列数を設定、取得します。
PDFInitialSymbol | PDF417 の初期化シンボルを設定、取得します。
PDFLevel | PDF417 のエラー訂正レベルを設定、取得します。
PDFModel | PDF417 シンボルを設定、取得します。
PDFRatio | PDF417 の 1 モジュールの縦横比を設定、取得します。
PDFRow | PDF417 の行数を設定、取得します。
Point | ポイントを設定、取得します。(郵便カスタマバーコード)
QRConnect | 連結 QR コードを作成するかを設定、取得します。
QREscapeCode | QR コードのエスケープコードを設定、取得します。
QRLevel | QR コードの誤り訂正レベルを設定、取得します。
QRMask | QR コードのマスクパターンを設定、取得します。
QRModel | QR コードのモデルを設定、取得します。
QRSymbolNumber | 連結 QR コードで出力するシンボル番号を設定、取得します。
QRVersion | QR コードの型番を設定、取得します。
Quiet | 余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金代理収納 GS1-128)
Rotate | バーコードの回転方向を設定、取得します。
ShowBearer | ベアラバーを表示するかを設定、取得します。(ITF)
ShowMessage | バーコードメッセージを表示するかを設定、取得します。
StartChar | スタートキャラクタを設定、取得します。(Codabar)
StopChar | ストップキャラクタを設定、取得します。(Codabar)
TextRenderingHint | バーコードキャラクタのテキストレンダリングの品質を設定、取得します。
Type | バーコードの種類を設定、取得します。
Unit | バーコードの生成単位を設定、取得します。
Value | バーコードデータを設定、取得します。(文字列)
WhiteBarRevision | 白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
Zoom | 倍率を設定、取得します。(JAN、UPC、ITF)

参照

VB-BarCode 5.0 for .NET の概要

©2020 Advance Software inc. All rights reserved.


WPF バーコードコントロール

[image]

VB-BarCode 5.0 for .NET
WPF バーコードコントロール
参照

このトピックでは、WPF バーコードコントロールで使用可能なオブジェクト機能一覧を確認することが可能です。

BarCodeControl クラス(WPF)

メソッド名 | 説明
GetBarCodeImage | バーコードのビットマップイメージを作成します。
GetScaleSize | 指定した単位でバーコードのサイズを取得します。
Save | バーコードのイメージをビットマップ形式で保存します。
SaveSvg | バーコードの SVG イメージを保存します。
SaveSvgz | バーコードの圧縮 SVG イメージを保存します。
プロパティ名 | 説明
BackColor | バーコードシンボルの背景色を設定、取得します。
BarColor | バーの色を設定、取得します。
BarHeight | バーコードの高さを設定、取得します。
BarRatio | 太バーのエレメント率を設定、取得します。(Codabar、Code39)
BarWidth | バーコードの幅を設定、取得します。
BinaryValue | バーコードデータを設定、取得します。(バイナリ)
BlackBarRevision | 黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
BlackRatio | 黒バーの太さの比率を設定、取得します。
CharGap | キャラクタ間のギャップを設定、取得します。(Codabar、Code39)
CharSize | バーコードキャラクタのフォントサイズを設定、取得します。
CheckCharMode | 自動でチェックキャラクタを付加するかを設定、取得します。
CheckPattern | チェックデジットの計算方法を設定、取得します。(Codabar)
Codeset | スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))
DpiX | X 軸方向の解像度を設定、取得します。(ピクセル単位)
DpiY | Y 軸方向の解像度を設定、取得します。(ピクセル単位)
Element | 最小エレメント値を設定、取得します。
ErrorMessage | 最小エレメント値を設定、取得します。
ErrorNo | エラーナンバーを取得します。
FlatHeight | ガードバーの均等化を設定、取得します。(JAN、UPC)
Font | バーコードメッセージのフォントを設定、取得します。
FontStyle | バーコードキャラクタのフォントスタイルを設定、取得します。
FontWeight | バーコードキャラクタのフォントウエイトを設定、取得します。
InternalQRVersion | QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。
InternalValue | 整形後のバーコードデータを取得します。
MessageAlign | バーコードメッセージの表示横位置を設定、取得します。(GS1Fixed)
PDFColumn | PDF417 の列数を設定、取得します。
PDFInitialSymbol | PDF417 の初期化シンボルを設定、取得します。
PDFLevel | PDF417 のエラー訂正レベルを設定、取得します。
PDFModel | PDF417 シンボルを設定、取得します。
PDFRatio | PDF417 の 1 モジュールの縦横比を設定、取得します。
PDFRow | PDF417 の行数を設定、取得します。
Point | ポイントを設定、取得します。(郵便カスタマバーコード)
QRConnect | 連結 QR コードを作成するかを設定、取得します。
QREscapeCode | QR コードのエスケープコードを設定、取得します。
QRLevel | QR コードの誤り訂正レベルを設定、取得します。
QRMask | QR コードのマスクパターンを設定、取得します。
QRModel | QR コードのモデルを設定、取得します。
QRSymbolNumber | 連結 QR コードで出力するシンボル番号を設定、取得します。
QRVersion | QR コードの型番を設定、取得します。
Quiet | 余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金代理収納 GS1-128)
RePaint | プロパティ変更時の再描画を行うかどうかを設定します。
Rotate | バーコードの回転方向を設定、取得します。
ShowBearer | ベアラバーを表示するかを設定、取得します。(ITF)
ShowMessage | バーコードメッセージを表示するかを設定、取得します。
StartChar | スタートキャラクタを設定、取得します。(Codabar)
StopChar | ストップキャラクタを設定、取得します。(Codabar)
Type | バーコードの種類を設定、取得します。
Unit | バーコードの生成単位を設定、取得します。
Value | バーコードデータを設定、取得します。(文字列)
WhiteBarRevision | 白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
Zoom | 倍率を設定、取得します。(JAN、UPC、ITF)

参照

VB-BarCode 5.0 for .NET の概要

©2020 Advance Software inc. All rights reserved.


WPF バーコードコンポーネント

[image]

VB-BarCode 5.0 for .NET
WPF バーコードコンポーネント
参照

このトピックでは、WPF バーコードコンポーネントで使用可能なオブジェクト機能一覧を確認することが可能です。

BarCode クラス(WPF)

メソッド名 | 説明
GetBarCodeImage | バーコードのビットマップイメージを作成します。
GetScaleSize | 指定した単位でバーコードのサイズを取得します。
Save | バーコードのイメージをビットマップ形式で保存します。
SaveSvg | バーコードの SVG イメージを保存します。
SaveSvgz | バーコードの圧縮 SVG イメージを保存します。
プロパティ名 | 説明
BackColor | バーコードシンボルの背景色を設定、取得します。
BarColor | バーの色を設定、取得します。
BarHeight | バーコードの高さを設定、取得します。
BarRatio | 太バーのエレメント率を設定、取得します。(Codabar、Code39)
BarWidth | バーコードの幅を設定、取得します。
BinaryValue | バーコードデータを設定、取得します。(バイナリ)
BlackBarRevision | 黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
BlackRatio | 黒バーの太さの比率を設定、取得します。
CharGap | キャラクタ間のギャップを設定、取得します。(Codabar、Code39)
CharSize | バーコードキャラクタのフォントサイズを設定、取得します。
CheckCharMode | 自動でチェックキャラクタを付加するかを設定、取得します。
CheckPattern | チェックデジットの計算方法を設定、取得します。(Codabar)
Codeset | スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))
DpiX | X 軸方向の解像度を設定、取得します。(ピクセル単位)
DpiY | Y 軸方向の解像度を設定、取得します。(ピクセル単位)
Element | 最小エレメント値を設定、取得します。
ErrorMessage | エラーメッセージを取得します。
ErrorNo | エラーナンバーを取得します。
FlatHeight | ガードバーの均等化を設定、取得します。(JAN、UPC)
Font | バーコードメッセージのフォントを設定、取得します。
FontStyle | バーコードキャラクタのフォントスタイルを設定、取得します
FontWeight | バーコードキャラクタのフォントウエイトを設定、取得します。
InternalQRVersion | QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。
InternalValue | 整形後のバーコードデータを取得します。
MessageAlign | バーコードメッセージの表示横位置を設定、取得します。(GS1Fixed)
PDFColumn | PDF417 の列数を設定、取得します。
PDFInitialSymbol | PDF417 の初期化シンボルを設定、取得します。
PDFLevel | PDF417 のエラー訂正レベルを設定、取得します。
PDFModel | PDF417 シンボルを設定、取得します。
PDFRatio | PDF417 の 1 モジュールの縦横比を設定、取得します。
PDFRow | PDF417 の行数を設定、取得します。
Point | ポイントを設定、取得します。(郵便カスタマバーコード)
QRConnect | 連結 QR コードを作成するかを設定、取得します。
QREscapeCode | QR コードのエスケープコードを設定、取得します。
QRLevel | QR コードの誤り訂正レベルを設定、取得します。
QRMask | QR コードのマスクパターンを設定、取得します。
QRModel | QR コードのモデルを設定、取得します。
QRSymbolNumber | 連結 QR コードで出力するシンボル番号を設定、取得します。
QRVersion | QR コードの型番を設定、取得します。
Quiet | 余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金代理収納 GS1-128)
Rotate | バーコードの回転方向を設定、取得します。
ShowBearer | ベアラバーを表示するかを設定、取得します。(ITF)
ShowMessage | バーコードメッセージを表示するかを設定、取得します。
StartChar | スタートキャラクタを設定、取得します。(Codabar)
StopChar | ストップキャラクタを設定、取得します。(Codabar)
Type | バーコードの種類を設定、取得します。
Unit | バーコードの生成単位を設定、取得します。
Value | バーコードデータを設定、取得します。(文字列)
WhiteBarRevision | 白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
Zoom | 倍率を設定、取得します。(JAN、UPC、ITF)

参照

VB-BarCode 5.0 for .NET の概要

©2020 Advance Software inc. All rights reserved.


クラス ライブラリ リファレンス

[image]

VB-BarCode 5.0 for .NET
クラス ライブラリ リファレンス
このクラス ライブラリは、VB-BarCode 5.0 for .NET に含まれているクラス、インターフェイス、および値型のライブラリです。VB-BarCode 5.0 for .NET のアプリケーションを作成する場合の基礎となるようにデザインされています。

名前空間

名前空間 | 説明
AdvanceSoftware.VBBarCode | AdvanceSoftware.VBBarCode 名前空間には、BarCode コンポーネントが含まれています。
AdvanceSoftware.VBBarCode.Wpf | AdvanceSoftware.VBBarCode.Wpf 名前空間には、WPFBarCode コンポーネントが含まれています。


AdvanceSoftware.VBBarCode 名前空間

[image]

VB-BarCode 5.0 for .NET
AdvanceSoftware.VBBarCode 名前空間
AdvanceSoftware.VBBarCode 名前空間には、BarCode コンポーネントが含まれています。

クラス

 | クラス | 説明
Public class | BarCode | BarCode クラス
Public class | BarCodeControl | BarCodeControl クラス
Public class | BarCodeErrorEventArgs | BarCode クラスの Error イベントのデータを提供します。

構造体

 | 構造体 | 説明
Public structure | BarCodeSize | BarCodeSize 構造体
Public structure | BarCodeSizeD | BarCodeSizeD 構造体

デリゲート

 | デリゲート | 説明
Public delegate | BarCodeErrorEventHandler | BarCode クラスの Error イベントを処理するメソッドを表します。

列挙体

 | 列挙体 | 説明
Public enumeration | BarCodeType | バーコードの種類を指定します。
Public enumeration | CheckPattern | チェックデジットの計算方法を指定します。
Public enumeration | Codeset | スタートコードセットを指定します。
Public enumeration | ErrorNo | エラーナンバーを示す識別子を指定します。
Public enumeration | MessageAlign | バーコードメッセージの表示横位置を指定します。
Public enumeration | PDFModel | PDF417 シンボルを指定します。
Public enumeration | QRConnect | QRコードの連結モードを指定します。
Public enumeration | QRLevel | QR コードの誤り訂正レベルを指定します。
Public enumeration | QRMask | QR コードのマスクパターンを指定します。
Public enumeration | QRModel | QR コードのモデルを指定します。
Public enumeration | QRVersion | QR コードの型番を指定します。
Public enumeration | Rotate | バーコードの回転方向を指定します。
Public enumeration | Unit | バーコードの生成単位を指定します。


BarCode クラス

[image]

VB-BarCode 5.0 for .NET
BarCode クラス
メンバ 参照
BarCode クラス

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public class BarCode : Component
Visual Basic (宣言)
Public Class BarCode _
    Inherits Component

継承階層

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
AdvanceSoftware.VBBarCode..::..BarCode

参照

BarCode メンバ
AdvanceSoftware.VBBarCode 名前空間


BarCode メンバ

[image] [image]

VB-BarCode 5.0 for .NET
BarCode メンバ
BarCode クラス コンストラクタ メソッド プロパティ イベント 参照

BarCode データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | BarCode()()()() | コンストラクタ
Public method | BarCode(IContainer) | コンストラクタ

メソッド

 | 名前 | 説明
Public method | GetBarCodeImage(ImageFormat) | バーコードのイメージを作成します。
Public method | GetBarCodeImage(ImageFormat, Boolean) | バーコードのイメージを作成します。
Public method | GetScaleSize | 指定した単位でバーコードのサイズを取得します。
Public method | Print()()()() | バーコードを印刷します。
Public method | Print(String) | バーコードを印刷します。
Public method | Print(Double, Double) | バーコードを印刷します。
Public method | Print(Double, Double, String) | バーコードを印刷します。
Public method | Save(Stream, ImageFormat) | バーコードのイメージを保存します。
Public method | Save(String, ImageFormat) | バーコードのイメージを保存します。
Public method | Save(Stream, ImageFormat, Boolean) | バーコードのイメージを保存します。
Public method | Save(String, ImageFormat, Boolean) | バーコードのイメージを保存します。
Public method | SaveSvg(Stream) | バーコードの SVG イメージを保存します。
Public method | SaveSvg(String) | バーコードの SVG イメージを保存します。
Public method | SaveSvgz(Stream) | バーコードの圧縮 SVG イメージを保存します。
Public method | SaveSvgz(String) | バーコードの圧縮 SVG イメージを保存します。

プロパティ

 | 名前 | 説明
Public property | _Type | バーコードの種類を設定、取得します。
Public property | _Unit | バーコードの生成単位を設定、取得します。
Public property | BackColor | バーコードシンボルの背景色を設定、取得します。
Public property | BarColor | バーの色を設定、取得します。
Public property | BarHeight | バーコードの高さを設定、取得します。
Public property | BarRatio | 太バーのエレメント率を設定、取得します。(Codabar、Code39)
Public property | BarWidth | バーコードの幅を設定、取得します。
Public property | BinaryValue | バーコードデータを設定、取得します。(バイナリ)
Public property | BlackBarRevision | 黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
Public property | BlackRatio | 黒バーの太さの比率を設定、取得します。
Public property | CharGap | キャラクタ間のギャップを設定、取得します。(Codabar、Code39)
Public property | CharSize | バーコードキャラクタのフォントサイズを設定、取得します。
Public property | CheckCharMode | 自動でチェックキャラクタを付加するかを設定、取得します。
Public property | CheckPattern | チェックデジットの計算方法を設定、取得します。(Codabar)
Public property | Codeset | スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))
Public property | DpiX | X 軸方向の解像度を設定、取得します。(ピクセル単位)
Public property | DpiY | Y 軸方向の解像度を設定、取得します。(ピクセル単位)
Public property | Element | 最小エレメント値を設定、取得します。
Public property | EmfType | 拡張メタファイル(EMF)に格納されるレコードの品質を設定します。
Public property | ErrorMessage | エラーメッセージを取得します。
Public property | ErrorNo | エラーナンバーを取得します。
Public property | FlatHeight | ガードバーの均等化を設定、取得します。(JAN、UPC)
Public property | Font | バーコードメッセージのフォント名、フォントスタイルを設定、取得します。
Public property | InternalQRVersion | QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。
Public property | InternalValue | 整形後のバーコードデータを取得します。
Public property | MessageAlign | バーコードメッセージの表示横位置を設定、取得します。(GS1Fixed)
Public property | PDFColumn | PDF417 の列数を設定、取得します。
Public property | PDFInitialSymbol | PDF417 の初期化シンボルを設定、取得します。
Public property | PDFLevel | PDF417 のエラー訂正レベルを設定、取得します。
Public property | PDFModel | PDF417 シンボルを設定、取得します。
Public property | PDFRatio | PDF417 の 1 モジュールの縦横比を設定、取得します。
Public property | PDFRow | PDF417 の行数を設定、取得します。
Public property | Point | ポイントを設定、取得します。(郵便カスタマバーコード)
Public property | QRConnect | 連結 QR コードを作成するかを設定、取得します。
Public property | QREscapeCode | QR コードのエスケープコードを設定、取得します。
Public property | QRLevel | QR コードの誤り訂正レベルを設定、取得します。
Public property | QRMask | QR コードのマスクパターンを設定、取得します。
Public property | QRModel | QR コードのモデルを設定、取得します。
Public property | QRSymbolNumber | 連結 QR コードで出力するシンボル番号を設定、取得します。
Public property | QRVersion | QR コードの型番を設定、取得します。
Public property | Quiet | 余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金代理収納 GS1-128)
Public property | Rotate | バーコードの回転方向を設定、取得します。
Public property | ShowBearer | ベアラバーを表示するかを設定、取得します。(ITF)
Public property | ShowMessage | バーコードメッセージを表示するかを設定、取得します。
Public property | StartChar | スタートキャラクタを設定、取得します。(Codabar)
Public property | StopChar | ストップキャラクタを設定、取得します。(Codabar)
Public property | TextRenderingHint | バーコードキャラクタのテキストレンダリングの品質を設定、取得します。
Public property | Type | バーコードの種類を設定、取得します。
Public property | Unit | バーコードの生成単位を設定、取得します。
Public property | Value | バーコードデータを設定、取得します。(文字列)
Public property | WhiteBarRevision | 白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
Public property | Zoom | 倍率を設定、取得します。(JAN、UPC、ITF)

イベント

 | 名前 | 説明
Public event | Error | バーコードの作成に失敗した時に発生します。

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


BarCode コンストラクタ

[image] [image]

VB-BarCode 5.0 for .NET
BarCode コンストラクタ
BarCode クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | BarCode()()()() | コンストラクタ
Public method | BarCode(IContainer) | コンストラクタ

参照

BarCode クラス
BarCode メンバ
AdvanceSoftware.VBBarCode 名前空間


BarCode コンストラクタ

[image]

VB-BarCode 5.0 for .NET
BarCode コンストラクタ
BarCode クラス 参照
コンストラクタ

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public BarCode()
Visual Basic (宣言)
Public Sub New

参照

BarCode クラス
BarCode オーバーロード
AdvanceSoftware.VBBarCode 名前空間


BarCode コンストラクタ (IContainer)

[image]

VB-BarCode 5.0 for .NET
BarCode コンストラクタ (IContainer)
BarCode クラス 参照
コンストラクタ

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public BarCode(
    IContainer container
)
Visual Basic (宣言)
Public Sub New ( _
    container As IContainer _
)

パラメータ

container
Type: System.ComponentModel..::..IContainer
System.ComponentModel.IContainer を指定します。

参照

BarCode クラス
BarCode オーバーロード
AdvanceSoftware.VBBarCode 名前空間


BarCode メソッド

[image] [image]

VB-BarCode 5.0 for .NET
BarCode メソッド
BarCode クラス 参照

BarCode データ型で公開されるメンバを以下に示します。

メソッド

 | 名前 | 説明
Public method | GetBarCodeImage(ImageFormat) | バーコードのイメージを作成します。
Public method | GetBarCodeImage(ImageFormat, Boolean) | バーコードのイメージを作成します。
Public method | GetScaleSize | 指定した単位でバーコードのサイズを取得します。
Public method | Print()()()() | バーコードを印刷します。
Public method | Print(String) | バーコードを印刷します。
Public method | Print(Double, Double) | バーコードを印刷します。
Public method | Print(Double, Double, String) | バーコードを印刷します。
Public method | Save(Stream, ImageFormat) | バーコードのイメージを保存します。
Public method | Save(String, ImageFormat) | バーコードのイメージを保存します。
Public method | Save(Stream, ImageFormat, Boolean) | バーコードのイメージを保存します。
Public method | Save(String, ImageFormat, Boolean) | バーコードのイメージを保存します。
Public method | SaveSvg(Stream) | バーコードの SVG イメージを保存します。
Public method | SaveSvg(String) | バーコードの SVG イメージを保存します。
Public method | SaveSvgz(Stream) | バーコードの圧縮 SVG イメージを保存します。
Public method | SaveSvgz(String) | バーコードの圧縮 SVG イメージを保存します。

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


GetBarCodeImage メソッド

[image] [image]

VB-BarCode 5.0 for .NET
BarCode..::..GetBarCodeImage メソッド
BarCode クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | GetBarCodeImage(ImageFormat) | バーコードのイメージを作成します。
Public method | GetBarCodeImage(ImageFormat, Boolean) | バーコードのイメージを作成します。

参照

BarCode クラス
BarCode メンバ
AdvanceSoftware.VBBarCode 名前空間


GetBarCodeImage メソッド (ImageFormat)

[image]

VB-BarCode 5.0 for .NET
BarCode..::..GetBarCodeImage メソッド (ImageFormat)
BarCode クラス 使用例 参照
バーコードのイメージを作成します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Image GetBarCodeImage(
    ImageFormat format
)
Visual Basic (宣言)
Public Function GetBarCodeImage ( _
    format As ImageFormat _
) As Image

パラメータ

format
Type: System.Drawing.Imaging..::..ImageFormat
保存する Image のImageFormat。

戻り値

このメソッドが作成する Image。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// バーコードイメージ (拡張メタファイル) を生成します。
Image imgBarCode = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf);
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' バーコードイメージ (拡張メタファイル) を生成します。
Dim imgBarCode As Image = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf)

参照

BarCode クラス
GetBarCodeImage オーバーロード
AdvanceSoftware.VBBarCode 名前空間


GetBarCodeImage メソッド (ImageFormat, Boolean)

[image]

VB-BarCode 5.0 for .NET
BarCode..::..GetBarCodeImage メソッド (ImageFormat, Boolean)
BarCode クラス 使用例 参照
バーコードのイメージを作成します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Image GetBarCodeImage(
    ImageFormat format,
    bool resolution
)
Visual Basic (宣言)
Public Function GetBarCodeImage ( _
    format As ImageFormat, _
    resolution As Boolean _
) As Image

パラメータ

format
Type: System.Drawing.Imaging..::..ImageFormat
保存する Image のImageFormat。
resolution
Type: System..::..Boolean
DpiX プロパティ、DpiY プロパティの解像度で Bitmap を作成する場合、true を設定します。

戻り値

このメソッドが作成する Image。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
barCode1.DpiX = 600;
barCode1.DpiY = 600;
barCode1.Value = "1234567890123";
// バーコードイメージ (ビットマップ) を DpiX, DpiY プロパティの解像度で生成します。
Image imgBarCode = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp, true);
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
BarCode1.DpiX = 600
BarCode1.DpiY = 600
BarCode1.Value = "1234567890123"
' バーコードイメージ (ビットマップ) を DpiX, DpiY プロパティの解像度で生成します。
Dim imgBarCode As Image = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp, True)

参照

BarCode クラス
GetBarCodeImage オーバーロード
AdvanceSoftware.VBBarCode 名前空間


GetScaleSize メソッド

[image]

VB-BarCode 5.0 for .NET
BarCode..::..GetScaleSize メソッド
BarCode クラス 使用例 参照
指定した単位でバーコードのサイズを取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public BarCodeSizeD GetScaleSize(
    Unit unit
)
Visual Basic (宣言)
Public Function GetScaleSize ( _
    unit As Unit _
) As BarCodeSizeD

パラメータ

unit
Type: AdvanceSoftware.VBBarCode..::..Unit
取得するサイズの単位を表す Unit 列挙体。

戻り値

バーコードのサイズ。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
AdvanceSoftware.VBBarCode.BarCodeSizeD barCodeSizeD;
// バーコードイメージのサイズを ミリ(mm) 単位で取得します。
barCodeSizeD = barCode1.GetScaleSize(AdvanceSoftware.VBBarCode.Unit.Millimeter);
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
Dim BarCodeSizeD As AdvanceSoftware.VBBarCode.BarCodeSizeD
' バーコードイメージのサイズを ミリ(mm) 単位で取得します。
BarCodeSizeD = BarCode1.GetScaleSize(AdvanceSoftware.VBBarCode.Unit.Millimeter)

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


Print メソッド

[image] [image]

VB-BarCode 5.0 for .NET
BarCode..::..Print メソッド
BarCode クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | Print()()()() | バーコードを印刷します。
Public method | Print(String) | バーコードを印刷します。
Public method | Print(Double, Double) | バーコードを印刷します。
Public method | Print(Double, Double, String) | バーコードを印刷します。

参照

BarCode クラス
BarCode メンバ
AdvanceSoftware.VBBarCode 名前空間


Print メソッド

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Print メソッド
BarCode クラス 使用例 参照
バーコードを印刷します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool Print()
Visual Basic (宣言)
Public Function Print As Boolean

戻り値

印刷が成功した場合 true を返します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// バーコードイメージを印刷します。
barCode1.Print();
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' バーコードイメージを印刷します。
BarCode1.Print()

参照

BarCode クラス
Print オーバーロード
AdvanceSoftware.VBBarCode 名前空間


Print メソッド (String)

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Print メソッド (String)
BarCode クラス 使用例 参照
バーコードを印刷します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool Print(
    string documentName
)
Visual Basic (宣言)
Public Function Print ( _
    documentName As String _
) As Boolean

パラメータ

documentName
Type: System..::..String
印刷ドキュメント名を指定します。

戻り値

印刷が成功した場合 true を返します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// 印刷ドキュメント名を指定してバーコードイメージを印刷します。
barCode1.Print("バーコード印刷");
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' 印刷ドキュメント名を指定してバーコードイメージを印刷します。
BarCode1.Print("バーコード印刷")

参照

BarCode クラス
Print オーバーロード
AdvanceSoftware.VBBarCode 名前空間


Print メソッド (Double, Double)

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Print メソッド (Double, Double)
BarCode クラス 使用例 参照
バーコードを印刷します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool Print(
    double x,
    double y
)
Visual Basic (宣言)
Public Function Print ( _
    x As Double, _
    y As Double _
) As Boolean

パラメータ

x
Type: System..::..Double
印刷するバーコードイメージの開始位置、x 座標を設定します。
y
Type: System..::..Double
印刷するバーコードイメージの開始位置、y 座標を設定します。

戻り値

印刷が成功した場合 true を返します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
barCode1.Value = "1234567890123";
// 描画位置のオフセット(x:10.0mm / y:10.0mm)を指定してバーコードイメージを印刷します。
barCode1.Print(10.0, 10.0);
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
BarCode1.Value = "1234567890123"
' 描画位置のオフセット(x:10.0mm / y:10.0mm)を指定してバーコードイメージを印刷します。
BarCode1.Print(10.0, 10.0)

参照

BarCode クラス
Print オーバーロード
AdvanceSoftware.VBBarCode 名前空間


Print メソッド (Double, Double, String)

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Print メソッド (Double, Double, String)
BarCode クラス 使用例 参照
バーコードを印刷します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool Print(
    double x,
    double y,
    string documentName
)
Visual Basic (宣言)
Public Function Print ( _
    x As Double, _
    y As Double, _
    documentName As String _
) As Boolean

パラメータ

x
Type: System..::..Double
印刷するバーコードイメージの開始位置、x 座標を設定します。
y
Type: System..::..Double
印刷するバーコードイメージの開始位置、y 座標を設定します。
documentName
Type: System..::..String
印刷ドキュメント名を指定します。

戻り値

印刷が成功した場合 true を返します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
barCode1.Value = "1234567890123";
// 描画位置のオフセット(x:10.0mm / y:10.0mm)と印刷ドキュメント名を指定してバーコードイメージを印刷します。
barCode1.Print(10.0, 10.0, "バーコード印刷");
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
BarCode1.Value = "1234567890123"
' 描画位置のオフセット(x:10.0mm / y:10.0mm)と印刷ドキュメント名を指定してバーコードイメージを印刷します。
BarCode1.Print(10.0, 10.0, "バーコード印刷")

参照

BarCode クラス
Print オーバーロード
AdvanceSoftware.VBBarCode 名前空間


Save メソッド

[image] [image]

VB-BarCode 5.0 for .NET
BarCode..::..Save メソッド
BarCode クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | Save(Stream, ImageFormat) | バーコードのイメージを保存します。
Public method | Save(String, ImageFormat) | バーコードのイメージを保存します。
Public method | Save(Stream, ImageFormat, Boolean) | バーコードのイメージを保存します。
Public method | Save(String, ImageFormat, Boolean) | バーコードのイメージを保存します。

参照

BarCode クラス
BarCode メンバ
AdvanceSoftware.VBBarCode 名前空間


Save メソッド (Stream, ImageFormat)

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Save メソッド (Stream, ImageFormat)
BarCode クラス 使用例 参照
バーコードのイメージを保存します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool Save(
    Stream stream,
    ImageFormat format
)
Visual Basic (宣言)
Public Function Save ( _
    stream As Stream, _
    format As ImageFormat _
) As Boolean

パラメータ

stream
Type: System.IO..::..Stream
イメージが保存される Stream。
format
Type: System.Drawing.Imaging..::..ImageFormat
保存する Image の ImageFormat。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// バーコードイメージを保存します。
FileStream fileStream = new FileStream(@"C:\BarCode.jpg", FileMode.Create);
barCode1.Save(fileStream, ImageFormat.Jpeg);
fileStream.Close();
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' バーコードイメージを保存します。
Dim FileStream As FileStream = New FileStream("C:\BarCode.jpg", FileMode.Create)
BarCode1.Save(FileStream, ImageFormat.Jpeg)
FileStream.Close()

参照

BarCode クラス
Save オーバーロード
AdvanceSoftware.VBBarCode 名前空間


Save メソッド (String, ImageFormat)

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Save メソッド (String, ImageFormat)
BarCode クラス 使用例 参照
バーコードのイメージを保存します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool Save(
    string fileName,
    ImageFormat format
)
Visual Basic (宣言)
Public Function Save ( _
    fileName As String, _
    format As ImageFormat _
) As Boolean

パラメータ

fileName
Type: System..::..String
バーコードイメージの保存先ファイルの名前を格納している文字列。
format
Type: System.Drawing.Imaging..::..ImageFormat
保存する Image の ImageFormat。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// バーコードイメージを保存します。
barCode1.Save(@"C:\BarCode.jpg", ImageFormat.Jpeg);
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' バーコードイメージを保存します。
BarCode1.Save("C:\BarCode.jpg", ImageFormat.Jpeg)

参照

BarCode クラス
Save オーバーロード
AdvanceSoftware.VBBarCode 名前空間


Save メソッド (Stream, ImageFormat, Boolean)

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Save メソッド (Stream, ImageFormat, Boolean)
BarCode クラス 使用例 参照
バーコードのイメージを保存します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool Save(
    Stream stream,
    ImageFormat format,
    bool resolution
)
Visual Basic (宣言)
Public Function Save ( _
    stream As Stream, _
    format As ImageFormat, _
    resolution As Boolean _
) As Boolean

パラメータ

stream
Type: System.IO..::..Stream
イメージが保存される Stream。
format
Type: System.Drawing.Imaging..::..ImageFormat
保存する Image の ImageFormat。
resolution
Type: System..::..Boolean
DpiX プロパティ、DpiY プロパティの解像度で Bitmap を作成する場合、true を設定します。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.DpiX = 600;
barCode1.DpiY = 600;
barCode1.Value = "1234567890123";
// バーコードイメージを保存します。
FileStream fileStream = new FileStream(@"C:\BarCode.bmp", FileMode.Create);
barCode1.Save(fileStream, ImageFormat.Bmp, true);
fileStream.Close();
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.DpiX = 600
BarCode1.DpiY = 600
BarCode1.Value = "1234567890123"
' バーコードイメージを保存します。
Dim FileStream As FileStream = New FileStream("C:\BarCode.bmp", FileMode.Create)
BarCode1.Save(FileStream, ImageFormat.Bmp, True)
FileStream.Close()

参照

BarCode クラス
Save オーバーロード
AdvanceSoftware.VBBarCode 名前空間


Save メソッド (String, ImageFormat, Boolean)

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Save メソッド (String, ImageFormat, Boolean)
BarCode クラス 使用例 参照
バーコードのイメージを保存します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool Save(
    string fileName,
    ImageFormat format,
    bool resolution
)
Visual Basic (宣言)
Public Function Save ( _
    fileName As String, _
    format As ImageFormat, _
    resolution As Boolean _
) As Boolean

パラメータ

fileName
Type: System..::..String
バーコードイメージの保存先ファイルの名前を格納している文字列。
format
Type: System.Drawing.Imaging..::..ImageFormat
保存する Image の ImageFormat。
resolution
Type: System..::..Boolean
DpiX プロパティ、DpiY プロパティの解像度で Bitmap を作成する場合、true を設定します。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.DpiX = 600;
barCode1.DpiY = 600;
barCode1.Value = "1234567890123";
// バーコードイメージを保存します。
barCode1.Save(@"C:\BarCode.bmp", ImageFormat.Bmp, true);
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.DpiX = 600
BarCode1.DpiY = 600
BarCode1.Value = "1234567890123"
' バーコードイメージを保存します。
BarCode1.Save("C:\BarCode.bmp", ImageFormat.Bmp, True)

参照

BarCode クラス
Save オーバーロード
AdvanceSoftware.VBBarCode 名前空間


SaveSvg メソッド

[image] [image]

VB-BarCode 5.0 for .NET
BarCode..::..SaveSvg メソッド
BarCode クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | SaveSvg(Stream) | バーコードの SVG イメージを保存します。
Public method | SaveSvg(String) | バーコードの SVG イメージを保存します。

参照

BarCode クラス
BarCode メンバ
AdvanceSoftware.VBBarCode 名前空間


SaveSvg メソッド (Stream)

[image]

VB-BarCode 5.0 for .NET
BarCode..::..SaveSvg メソッド (Stream)
BarCode クラス 使用例 参照
バーコードの SVG イメージを保存します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool SaveSvg(
    Stream stream
)
Visual Basic (宣言)
Public Function SaveSvg ( _
    stream As Stream _
) As Boolean

パラメータ

stream
Type: System.IO..::..Stream
イメージが保存される Stream。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// バーコードイメージを保存します。
FileStream fileStream = new FileStream(@"C:\BarCode.svg", FileMode.Create);
barCode1.SaveSvg(fileStream);
fileStream.Close();
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' バーコードイメージを保存します。
Dim FileStream As FileStream = New FileStream("C:\BarCode.svg", FileMode.Create)
BarCode1.SaveSvg(FileStream)
FileStream.Close()

参照

BarCode クラス
SaveSvg オーバーロード
AdvanceSoftware.VBBarCode 名前空間


SaveSvg メソッド (String)

[image]

VB-BarCode 5.0 for .NET
BarCode..::..SaveSvg メソッド (String)
BarCode クラス 使用例 参照
バーコードの SVG イメージを保存します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool SaveSvg(
    string fileName
)
Visual Basic (宣言)
Public Function SaveSvg ( _
    fileName As String _
) As Boolean

パラメータ

fileName
Type: System..::..String
バーコードイメージの保存先ファイルの名前を格納している文字列。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// バーコードイメージを保存します。
barCode1.SaveSvg(@"C:\BarCode.svg");
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' バーコードイメージを保存します。
BarCode1.SaveSvg("C:\BarCode.svg")

参照

BarCode クラス
SaveSvg オーバーロード
AdvanceSoftware.VBBarCode 名前空間


SaveSvgz メソッド

[image] [image]

VB-BarCode 5.0 for .NET
BarCode..::..SaveSvgz メソッド
BarCode クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | SaveSvgz(Stream) | バーコードの圧縮 SVG イメージを保存します。
Public method | SaveSvgz(String) | バーコードの圧縮 SVG イメージを保存します。

参照

BarCode クラス
BarCode メンバ
AdvanceSoftware.VBBarCode 名前空間


SaveSvgz メソッド (Stream)

[image]

VB-BarCode 5.0 for .NET
BarCode..::..SaveSvgz メソッド (Stream)
BarCode クラス 使用例 参照
バーコードの圧縮 SVG イメージを保存します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool SaveSvgz(
    Stream stream
)
Visual Basic (宣言)
Public Function SaveSvgz ( _
    stream As Stream _
) As Boolean

パラメータ

stream
Type: System.IO..::..Stream
イメージが保存される Stream。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// バーコードイメージを保存します。
FileStream fileStream = new FileStream(@"C:\BarCode.svgz", FileMode.Create);
barCode1.SaveSvgz(fileStream);
fileStream.Close();
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' バーコードイメージを保存します。
Dim FileStream As FileStream = New FileStream("C:\BarCode.svgz", FileMode.Create)
BarCode1.SaveSvgz(FileStream)
FileStream.Close()

参照

BarCode クラス
SaveSvgz オーバーロード
AdvanceSoftware.VBBarCode 名前空間


SaveSvgz メソッド (String)

[image]

VB-BarCode 5.0 for .NET
BarCode..::..SaveSvgz メソッド (String)
BarCode クラス 使用例 参照
バーコードの圧縮 SVG イメージを保存します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool SaveSvgz(
    string fileName
)
Visual Basic (宣言)
Public Function SaveSvgz ( _
    fileName As String _
) As Boolean

パラメータ

fileName
Type: System..::..String
バーコードイメージの保存先ファイルの名前を格納している文字列。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// バーコードイメージを保存します。
barCode1.SaveSvgz(@"C:\BarCode.svgz");
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' バーコードイメージを保存します。
BarCode1.SaveSvgz("C:\BarCode.svgz")

参照

BarCode クラス
SaveSvgz オーバーロード
AdvanceSoftware.VBBarCode 名前空間


BarCode プロパティ

[image] [image]

VB-BarCode 5.0 for .NET
BarCode プロパティ
BarCode クラス 参照

BarCode データ型で公開されるメンバを以下に示します。

プロパティ

 | 名前 | 説明
Public property | _Type | バーコードの種類を設定、取得します。
Public property | _Unit | バーコードの生成単位を設定、取得します。
Public property | BackColor | バーコードシンボルの背景色を設定、取得します。
Public property | BarColor | バーの色を設定、取得します。
Public property | BarHeight | バーコードの高さを設定、取得します。
Public property | BarRatio | 太バーのエレメント率を設定、取得します。(Codabar、Code39)
Public property | BarWidth | バーコードの幅を設定、取得します。
Public property | BinaryValue | バーコードデータを設定、取得します。(バイナリ)
Public property | BlackBarRevision | 黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
Public property | BlackRatio | 黒バーの太さの比率を設定、取得します。
Public property | CharGap | キャラクタ間のギャップを設定、取得します。(Codabar、Code39)
Public property | CharSize | バーコードキャラクタのフォントサイズを設定、取得します。
Public property | CheckCharMode | 自動でチェックキャラクタを付加するかを設定、取得します。
Public property | CheckPattern | チェックデジットの計算方法を設定、取得します。(Codabar)
Public property | Codeset | スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))
Public property | DpiX | X 軸方向の解像度を設定、取得します。(ピクセル単位)
Public property | DpiY | Y 軸方向の解像度を設定、取得します。(ピクセル単位)
Public property | Element | 最小エレメント値を設定、取得します。
Public property | EmfType | 拡張メタファイル(EMF)に格納されるレコードの品質を設定します。
Public property | ErrorMessage | エラーメッセージを取得します。
Public property | ErrorNo | エラーナンバーを取得します。
Public property | FlatHeight | ガードバーの均等化を設定、取得します。(JAN、UPC)
Public property | Font | バーコードメッセージのフォント名、フォントスタイルを設定、取得します。
Public property | InternalQRVersion | QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。
Public property | InternalValue | 整形後のバーコードデータを取得します。
Public property | MessageAlign | バーコードメッセージの表示横位置を設定、取得します。(GS1Fixed)
Public property | PDFColumn | PDF417 の列数を設定、取得します。
Public property | PDFInitialSymbol | PDF417 の初期化シンボルを設定、取得します。
Public property | PDFLevel | PDF417 のエラー訂正レベルを設定、取得します。
Public property | PDFModel | PDF417 シンボルを設定、取得します。
Public property | PDFRatio | PDF417 の 1 モジュールの縦横比を設定、取得します。
Public property | PDFRow | PDF417 の行数を設定、取得します。
Public property | Point | ポイントを設定、取得します。(郵便カスタマバーコード)
Public property | QRConnect | 連結 QR コードを作成するかを設定、取得します。
Public property | QREscapeCode | QR コードのエスケープコードを設定、取得します。
Public property | QRLevel | QR コードの誤り訂正レベルを設定、取得します。
Public property | QRMask | QR コードのマスクパターンを設定、取得します。
Public property | QRModel | QR コードのモデルを設定、取得します。
Public property | QRSymbolNumber | 連結 QR コードで出力するシンボル番号を設定、取得します。
Public property | QRVersion | QR コードの型番を設定、取得します。
Public property | Quiet | 余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金代理収納 GS1-128)
Public property | Rotate | バーコードの回転方向を設定、取得します。
Public property | ShowBearer | ベアラバーを表示するかを設定、取得します。(ITF)
Public property | ShowMessage | バーコードメッセージを表示するかを設定、取得します。
Public property | StartChar | スタートキャラクタを設定、取得します。(Codabar)
Public property | StopChar | ストップキャラクタを設定、取得します。(Codabar)
Public property | TextRenderingHint | バーコードキャラクタのテキストレンダリングの品質を設定、取得します。
Public property | Type | バーコードの種類を設定、取得します。
Public property | Unit | バーコードの生成単位を設定、取得します。
Public property | Value | バーコードデータを設定、取得します。(文字列)
Public property | WhiteBarRevision | 白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
Public property | Zoom | 倍率を設定、取得します。(JAN、UPC、ITF)

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


_Type プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::.._Type プロパティ
BarCode クラス 使用例 参照
バーコードの種類を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public BarCodeType _Type { get; set; }
Visual Basic (宣言)
Public Property _Type As BarCodeType
    Get
    Set

プロパティ値

バーコードのタイプを表す BarCodeType。(既定値：BarCodeType.JAN13)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
// 生成するバーコードイメージを "JAN13" に設定します。
barCode1._Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
' 生成するバーコードイメージを "JAN13" に設定します。
BarCode1._Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


_Unit プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::.._Unit プロパティ
BarCode クラス 使用例 参照
バーコードの生成単位を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Unit _Unit { get; set; }
Visual Basic (宣言)
Public Property _Unit As Unit
    Get
    Set

プロパティ値

バーコードの生成単位を表す Unit。(既定値：Unit.Pixel)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1._Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1._Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


BackColor プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..BackColor プロパティ
BarCode クラス 使用例 参照
バーコードシンボルの背景色を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Color BackColor { get; set; }
Visual Basic (宣言)
Public Property BackColor As Color
    Get
    Set

プロパティ値

バーコードシンボルの背景色を表す Color。(既定値：Color.White)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの背景色を "赤色" に設定します。
barCode1.BackColor = System.Drawing.Color.Red;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの背景色を "赤色" に設定します。
BarCode1.BackColor = System.Drawing.Color.Red
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


BarColor プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..BarColor プロパティ
BarCode クラス 使用例 参照
バーの色を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Color BarColor { get; set; }
Visual Basic (宣言)
Public Property BarColor As Color
    Get
    Set

プロパティ値

バーの色を表す Color。(既定値：Color.Black)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーの色を "赤色" に設定します。
barCode1.BarColor = System.Drawing.Color.Red;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーの色を "赤色" に設定します。
BarCode1.BarColor = System.Drawing.Color.Red
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


BarHeight プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..BarHeight プロパティ
BarCode クラス 使用例 参照
バーコードの高さを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double BarHeight { get; set; }
Visual Basic (宣言)
Public Property BarHeight As Double
    Get
    Set

プロパティ値

バーコードの高さを表す double。(既定値：0.0)

解説

プロパティ値が 0 の場合、バーコードの高さは自動で設定されます。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードイメージの高さを "30.0mm" に設定します。
barCode1.BarHeight = 30.0;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードイメージの高さを "30.0mm" に設定します。
BarCode1.BarHeight = 30.0
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


BarRatio プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..BarRatio プロパティ
BarCode クラス 使用例 参照
太バーのエレメント率を設定、取得します。(Codabar、Code39)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double BarRatio { get; set; }
Visual Basic (宣言)
Public Property BarRatio As Double
    Get
    Set

プロパティ値

太バーのエレメント率を表す double。(既定値：2.0)

解説

設定範囲

最小エレメント値が 0.508mm 未満：2.2 ～ 3.0

最小エレメント値が 0.508mm 以上：2.0 ～ 3.0

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// 太バーのエレメント率を "2.5" に設定します。
barCode1.BarRatio = 2.5;
barCode1.Value = "1234567890";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' 太バーのエレメント率を "2.5" に設定します。
BarCode1.BarRatio = 2.5
BarCode1.Value = "1234567890"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


BarWidth プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..BarWidth プロパティ
BarCode クラス 使用例 参照
バーコードの幅を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double BarWidth { get; set; }
Visual Basic (宣言)
Public Property BarWidth As Double
    Get
    Set

プロパティ値

バーコードの幅を表す double。(既定値：0.0)

解説

プロパティ値が 0 の場合、バーコードの幅は自動で設定されます。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードイメージの幅を "60.0mm" に設定します。
barCode1.BarWidth = 60.0;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードイメージの幅を "60.0mm" に設定します。
BarCode1.BarWidth = 60.0
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


BinaryValue プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..BinaryValue プロパティ
BarCode クラス 使用例 参照
バーコードデータを設定、取得します。(バイナリ)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public byte[] BinaryValue { set; }
Visual Basic (宣言)
Public WriteOnly Property BinaryValue As Byte()
    Set

プロパティ値

バーコードデータを表す Byte。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// "12345ABCDE"
Byte[] btByte = new Byte[] { 49, 50, 51, 52, 53, 65, 66, 67, 68, 69 };
// バーコードデータを設定します。 (バイナリ)
barCode1.BinaryValue = btByte;
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' "12345ABCDE"
Dim btByte() As Byte = New Byte() {49, 50, 51, 52, 53, 65, 66, 67, 68, 69}
' バーコードデータを設定します。 (バイナリ)
BarCode1.BinaryValue = btByte

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


BlackBarRevision プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..BlackBarRevision プロパティ
BarCode クラス 使用例 参照
黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int BlackBarRevision { get; set; }
Visual Basic (宣言)
Public Property BlackBarRevision As Integer
    Get
    Set

プロパティ値

黒バーのドット補正値を表す int。(既定値：0)

解説

Unit プロパティの値が、Unit.Pixel の場合、有効になります。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128;
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 黒バーのドット補正値を "+2" に設定します。
barCode1.BlackBarRevision = 2;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 黒バーのドット補正値を "+2" に設定します。
BarCode1.BlackBarRevision = 2
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


BlackRatio プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..BlackRatio プロパティ
BarCode クラス 使用例 参照
黒バーの太さの比率を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int BlackRatio { get; set; }
Visual Basic (宣言)
Public Property BlackRatio As Integer
    Get
    Set

プロパティ値

黒バーの太さの比率を表す int。(既定値：100)

解説

設定範囲：50 ～ 150

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// 黒バーの太さ比率を "150%" に設定します。
barCode1.BlackRatio = 150;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' 黒バーの太さ比率を "150%" に設定します。
BarCode1.BlackRatio = 150
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


CharGap プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..CharGap プロパティ
BarCode クラス 使用例 参照
キャラクタ間のギャップを設定、取得します。(Codabar、Code39)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double CharGap { get; set; }
Visual Basic (宣言)
Public Property CharGap As Double
    Get
    Set

プロパティ値

キャラクタ間のギャップを表す double。(既定値：0.0)

解説

プロパティ値が 0 の場合、キャラクタ間のギャップは自動で設定されます。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code39;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードキャラクタの間隔を "2.0mm" に設定します。
barCode1.CharGap = 2.0;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code39
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードキャラクタの間隔を "2.0mm" に設定します。
BarCode1.CharGap = 2.0
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


CharSize プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..CharSize プロパティ
BarCode クラス 使用例 参照
バーコードキャラクタのフォントサイズを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double CharSize { get; set; }
Visual Basic (宣言)
Public Property CharSize As Double
    Get
    Set

プロパティ値

バーコードキャラクタのフォントサイズを表す double。(既定値：0.0)

解説

プロパティ値が 0 の場合、バーコードキャラクタのフォントサイズは自動で設定されます。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードメッセージのフォントサイズを "10.0mm" に設定します。
barCode1.CharSize = 10.0;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードメッセージのフォントサイズを "10.0mm" に設定します。
BarCode1.CharSize = 10.0
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


CheckCharMode プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..CheckCharMode プロパティ
BarCode クラス 使用例 参照
自動でチェックキャラクタを付加するかを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool CheckCharMode { get; set; }
Visual Basic (宣言)
Public Property CheckCharMode As Boolean
    Get
    Set

プロパティ値

チェックキャラクタのモードを表す bool。(既定値：true)

解説

プロパティ値が true の場合、自動でチェックキャラクタを付加します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// チェックキャラクタを "付加しない" に設定します。
barCode1.CheckCharMode = false;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' チェックキャラクタを "付加しない" に設定します。
BarCode1.CheckCharMode = False
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


CheckPattern プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..CheckPattern プロパティ
BarCode クラス 使用例 参照
チェックデジットの計算方法を設定、取得します。(Codabar)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public CheckPattern CheckPattern { get; set; }
Visual Basic (宣言)
Public Property CheckPattern As CheckPattern
    Get
    Set

プロパティ値

チェックデジットの計算方法を表す CheckPattern。(既定値：CheckPattern.Modulus16)

解説

CheckPattern.Modulus11(モジュラス 11) を設定した場合、計算に必要なバーコードメッセージは 6 桁以上必要になります。6 桁未満の場合は、Modulus10Weight3(モジュラス10 / ウエイト3) で計算されます。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// チェックデジットの計算方法を "モジュラス 11" に設定します。
barCode1.CheckPattern = AdvanceSoftware.VBBarCode.CheckPattern.Modulus11;
barCode1.Value = "12345678";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' チェックデジットの計算方法を "モジュラス 11" に設定します。
BarCode1.CheckPattern = AdvanceSoftware.VBBarCode.CheckPattern.Modulus11
BarCode1.Value = "12345678"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


Codeset プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Codeset プロパティ
BarCode クラス 使用例 参照
スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Codeset Codeset { get; set; }
Visual Basic (宣言)
Public Property Codeset As Codeset
    Get
    Set

プロパティ値

スタートコードセットを表す Codeset。(既定値：Codeset.CodesetAuto)

解説

プロパティ値が CodeSet.CodesetAuto の場合、バーコードデータの先頭の文字でコードセットが決まります。

先頭キャラクタが ~(チルダ) の場合、コードセットA に設定されます。

先頭キャラクタがアルファベットの場合、コードセットB に設定されます。

先頭から 2 キャラクタが数字の場合、コードセット C に設定されます。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128;
// Code128 を "コードセット B" に設定します。
barCode1.Codeset = AdvanceSoftware.VBBarCode.Codeset.CodesetB;
barCode1.Value = "abc123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128
' Code128 を "コードセット B" に設定します。
BarCode1.Codeset = AdvanceSoftware.VBBarCode.Codeset.CodesetB
BarCode1.Value = "abc123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


DpiX プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..DpiX プロパティ
BarCode クラス 使用例 参照
X 軸方向の解像度を設定、取得します。(ピクセル単位)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double DpiX { get; set; }
Visual Basic (宣言)
Public Property DpiX As Double
    Get
    Set

プロパティ値

X 軸方向の解像度を表す double。(既定値：96.0)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// X 軸方向の解像度を "600dpi" に設定します。
barCode1.DpiX = 600;
// Y 軸方向の解像度を "600dpi" に設定します。
barCode1.DpiY = 600;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' X 軸方向の解像度を "600dpi" に設定します。
BarCode1.DpiX = 600
' Y 軸方向の解像度を "600dpi" に設定します。
BarCode1.DpiY = 600
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


DpiY プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..DpiY プロパティ
BarCode クラス 使用例 参照
Y 軸方向の解像度を設定、取得します。(ピクセル単位)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double DpiY { get; set; }
Visual Basic (宣言)
Public Property DpiY As Double
    Get
    Set

プロパティ値

Y 軸方向の解像度を表す double。(既定値：96.0)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// X 軸方向の解像度を "600dpi" に設定します。
barCode1.DpiX = 600;
// Y 軸方向の解像度を "600dpi" に設定します。
barCode1.DpiY = 600;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' X 軸方向の解像度を "600dpi" に設定します。
BarCode1.DpiX = 600
' Y 軸方向の解像度を "600dpi" に設定します。
BarCode1.DpiY = 600
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


Element プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Element プロパティ
BarCode クラス 使用例 参照
最小エレメント値を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double Element { get; set; }
Visual Basic (宣言)
Public Property Element As Double
    Get
    Set

プロパティ値

最小エレメント値を表す double。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードイメージの最小エレメント値を "0.191mm" に設定します。
barCode1.Element = 0.191;
barCode1.Value = "1234567890";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードイメージの最小エレメント値を "0.191mm" に設定します。
BarCode1.Element = 0.191
BarCode1.Value = "1234567890"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


EmfType プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..EmfType プロパティ
BarCode クラス 使用例 参照
拡張メタファイル(EMF)に格納されるレコードの品質を設定します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public EmfType EmfType { get; set; }
Visual Basic (宣言)
Public Property EmfType As EmfType
    Get
    Set

プロパティ値

拡張メタファイルのレコード品質を表す EmfType。(既定値：EmfType.EmfPlusDual)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// 拡張メタファイルのレコード品質を "EmfOnly" に設定します。
barCode1.EmfType = System.Drawing.Imaging.EmfType.EmfOnly;
barCode1.Value = "1234567890123";
Image imgBarCode = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf);
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' 拡張メタファイルのレコード品質を "EmfOnly" に設定します。
BarCode1.EmfType = System.Drawing.Imaging.EmfType.EmfOnly
BarCode1.Value = "1234567890123"
Dim imgBarCode As Image = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf)

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


ErrorMessage プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..ErrorMessage プロパティ
BarCode クラス 使用例 参照
エラーメッセージを取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public string ErrorMessage { get; }
Visual Basic (宣言)
Public ReadOnly Property ErrorMessage As String
    Get

プロパティ値

バーコード生成時のエラーメッセージを表す string。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// エラー処理
if (barCode1.ErrorNo != AdvanceSoftware.VBBarCode.ErrorNo.NoError)
{
    // エラーメッセージを表示します。
    MessageBox.Show(barCode1.ErrorMessage);
}
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' エラー処理
If BarCode1.ErrorNo <> AdvanceSoftware.VBBarCode.ErrorNo.NoError Then
    ' エラーメッセージを表示します。
    MessageBox.Show(BarCode1.ErrorMessage)
End If

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


ErrorNo プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..ErrorNo プロパティ
BarCode クラス 使用例 参照
エラーナンバーを取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public ErrorNo ErrorNo { get; }
Visual Basic (宣言)
Public ReadOnly Property ErrorNo As ErrorNo
    Get

プロパティ値

バーコード生成時のエラーナンバーを表す ErrorNo。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// エラー処理
if (barCode1.ErrorNo != AdvanceSoftware.VBBarCode.ErrorNo.NoError)
{
    // エラーメッセージを表示します。
    MessageBox.Show(barCode1.ErrorMessage);
}
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' エラー処理
If BarCode1.ErrorNo <> AdvanceSoftware.VBBarCode.ErrorNo.NoError Then
    ' エラーメッセージを表示します。
    MessageBox.Show(BarCode1.ErrorMessage)
End If

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


FlatHeight プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..FlatHeight プロパティ
BarCode クラス 使用例 参照
ガードバーの均等化を設定、取得します。(JAN、UPC)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool FlatHeight { get; set; }
Visual Basic (宣言)
Public Property FlatHeight As Boolean
    Get
    Set

プロパティ値

ガードバーの均等化を表す bool。(既定値：false)

解説

プロパティ値が true の場合、ガードバーを均等化します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// ガードバーの長さを均等に設定します。
barCode1.FlatHeight = true;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' ガードバーの長さを均等に設定します。
BarCode1.FlatHeight = True
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


Font プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Font プロパティ
BarCode クラス 使用例 参照
バーコードメッセージのフォント名、フォントスタイルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Font Font { get; set; }
Visual Basic (宣言)
Public Property Font As Font
    Get
    Set

プロパティ値

バーコードメッセージのフォントを表す Font。

解説

このプロパティは、バーコードメッセージのフォント名、フォントスタイルを設定することができます。 フォントサイズは反映されないため、CharSize プロパティで設定して下さい。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードメッセージを "フォント名：ＭＳ 明朝 , フォントスタイル：斜体" に設定します。
barCode1.Font = new System.Drawing.Font("ＭＳ 明朝", 9, FontStyle.Italic);
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードメッセージを "フォント名：ＭＳ 明朝 , フォントスタイル：斜体" に設定します。
BarCode1.Font = New System.Drawing.Font("ＭＳ 明朝", 9, FontStyle.Italic)
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


InternalQRVersion プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..InternalQRVersion プロパティ
BarCode クラス 使用例 参照
QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRVersion InternalQRVersion { get; }
Visual Basic (宣言)
Public ReadOnly Property InternalQRVersion As QRVersion
    Get

プロパティ値

QR コードの型番を表す QRVersion。

解説

プロパティ値が QRVersion.VersionAuto の場合、QR コードの型番は自動で設定されます。

QRModel プロパティの値により、QRVersion.VersionAuto 以外の設定範囲が異なります。

設定範囲(QRModel1)：QRVersion.QRVersion1 ～ QRVersion14

設定範囲(QRModel2)：QRVersion.QRVersion1 ～ QRVersion40

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
barCode1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.VersionAuto;
barCode1.Value = "12345ABCDE";
Image imgBarCode = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf);
// 自動設定された QR コード の型番を取得します。
AdvanceSoftware.VBBarCode.QRVersion internalQRVersion = barCode1.InternalQRVersion;
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
BarCode1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.VersionAuto
BarCode1.Value = "12345ABCDE"
Dim imgBarCode As Image = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf)
' 自動設定された QR コード の型番を取得します。
Dim internalQRVersion As AdvanceSoftware.VBBarCode.QRVersion = BarCode1.InternalQRVersion

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


InternalValue プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..InternalValue プロパティ
BarCode クラス 使用例 参照
整形後のバーコードデータを取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public string InternalValue { get; }
Visual Basic (宣言)
Public ReadOnly Property InternalValue As String
    Get

プロパティ値

整形後のバーコードデータを表す string。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
Image imgBarCode = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf);
// 整形後のバーコードデータを取得します。
string internalValue = barCode1.InternalValue;
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
Dim imgBarCode As Image = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf)
' 整形後のバーコードデータを取得します。
Dim internalValue As String = BarCode1.InternalValue

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


MessageAlign プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..MessageAlign プロパティ
BarCode クラス 使用例 参照
バーコードメッセージの表示横位置を設定、取得します。(GS1Fixed)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public MessageAlign MessageAlign { get; set; }
Visual Basic (宣言)
Public Property MessageAlign As MessageAlign
    Get
    Set

プロパティ値

バーコードメッセージの表示横位置を表す MessageAlign。(既定値：MessageAlign.Center)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.GS1Fixed;
// バーコードメッセージの横位置を "左詰め" に設定します。(GS1Fixed)
barCode1.MessageAlign = AdvanceSoftware.VBBarCode.MessageAlign.Left;
barCode1.Value = "91012345678901234567890123456789012345678901";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.GS1Fixed
' バーコードメッセージの横位置を "左詰め" に設定します。(GS1Fixed)
BarCode1.MessageAlign = AdvanceSoftware.VBBarCode.MessageAlign.Left
BarCode1.Value = "91012345678901234567890123456789012345678901"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


PDFColumn プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..PDFColumn プロパティ
BarCode クラス 使用例 参照
PDF417 の列数を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int PDFColumn { get; set; }
Visual Basic (宣言)
Public Property PDFColumn As Integer
    Get
    Set

プロパティ値

PDF417 の列数を表す int。(既定値：0)

解説

設定範囲：0 ～ 40

プロパティ値が 0 の場合、縦横比 1:2 で PDF417 を作成します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 の列数を "15列" に設定します。
barCode1.PDFColumn = 15;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 の列数を "15列" に設定します。
BarCode1.PDFColumn = 15
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


PDFInitialSymbol プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..PDFInitialSymbol プロパティ
BarCode クラス 使用例 参照
PDF417 の初期化シンボルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool PDFInitialSymbol { get; set; }
Visual Basic (宣言)
Public Property PDFInitialSymbol As Boolean
    Get
    Set

プロパティ値

PDF417 の初期化シンボルを表す bool。(既定値：false)

解説

プロパティ値が true の場合、初期化シンボルを付加した PDF417 を作成します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 の初期化シンボルを "付加する" に設定します。
barCode1.PDFInitialSymbol = true;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 の初期化シンボルを "付加する" に設定します。
BarCode1.PDFInitialSymbol = True
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


PDFLevel プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..PDFLevel プロパティ
BarCode クラス 使用例 参照
PDF417 のエラー訂正レベルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int PDFLevel { get; set; }
Visual Basic (宣言)
Public Property PDFLevel As Integer
    Get
    Set

プロパティ値

PDF417 のエラー訂正レベルを表す int。(既定値：0)

解説

設定範囲：0 ～ 8

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 のエラー訂正レベルを "レベル7" に設定します。
barCode1.PDFLevel = 7;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 のエラー訂正レベルを "レベル7" に設定します。
BarCode1.PDFLevel = 7
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


PDFModel プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..PDFModel プロパティ
BarCode クラス 使用例 参照
PDF417 シンボルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public PDFModel PDFModel { get; set; }
Visual Basic (宣言)
Public Property PDFModel As PDFModel
    Get
    Set

プロパティ値

PDF417 シンボルを表す PDFModel。(既定値：PDFModel.Default)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 シンボルを "簡易 PDF417" に設定します。
barCode1.PDFModel = AdvanceSoftware.VBBarCode.PDFModel.Truncated;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 シンボルを "簡易 PDF417" に設定します。
BarCode1.PDFModel = AdvanceSoftware.VBBarCode.PDFModel.Truncated
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


PDFRatio プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..PDFRatio プロパティ
BarCode クラス 使用例 参照
PDF417 の 1 モジュールの縦横比を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double PDFRatio { get; set; }
Visual Basic (宣言)
Public Property PDFRatio As Double
    Get
    Set

プロパティ値

PDF417 の 1 モジュールの縦横比を表す double。(既定値：7.5)

解説

設定範囲：1.0 ～ 10.0

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 の 1 モジュールの幅との縦横比を "5.0" に設定します。
barCode1.PDFRatio = 5.0;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 の 1 モジュールの幅との縦横比を "5.0" に設定します。
BarCode1.PDFRatio = 5.0
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


PDFRow プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..PDFRow プロパティ
BarCode クラス 使用例 参照
PDF417 の行数を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int PDFRow { get; set; }
Visual Basic (宣言)
Public Property PDFRow As Integer
    Get
    Set

プロパティ値

PDF417 の行数を表す int。(既定値：0)

解説

設定範囲：0、3 ～ 90

プロパティ値が 0 の場合、縦横比 1:2 で PDF417 を作成します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 の行数を "10行" に設定します。
barCode1.PDFRow = 10;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 の行数を "10行" に設定します。
BarCode1.PDFRow = 10
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


Point プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Point プロパティ
BarCode クラス 使用例 参照
ポイントを設定、取得します。(郵便カスタマバーコード)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double Point { get; set; }
Visual Basic (宣言)
Public Property Point As Double
    Get
    Set

プロパティ値

バーコードのポイントを表す double。(既定値：10.0)

解説

設定範囲：6.0 ～ 14.0

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.CustomerBarCode;
// 郵便カスタマバーコードのポイントを "10.0" に設定します。
barCode1.Point = 10.0;
barCode1.Value = "91882391-2816";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.CustomerBarCode
' 郵便カスタマバーコードのポイントを "10.0" に設定します。
BarCode1.Point = 10.0
BarCode1.Value = "91882391-2816"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


QRConnect プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..QRConnect プロパティ
BarCode クラス 使用例 参照
連結 QR コードを作成するかを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRConnect QRConnect { get; set; }
Visual Basic (宣言)
Public Property QRConnect As QRConnect
    Get
    Set

プロパティ値

連結 QR コードの設定を表す QRConnect。(既定値：QRConnect.NotConnect)

解説

プロパティ値が QRConnect.AutoConnect、QRConnect.ManualConnect の場合、QRVersion プロパティを QRVersion.VersionAuto 以外に設定します。

また、QRConnect.ManualConnect の場合、QREscapeCode プロパティを使用して分割する位置のエスケープコードを設定します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10;
// QR コード を "連結 QR コード(手動)" に設定します。
barCode1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect;
// QR コードのエスケープコードを "% (0x25)" に設定します。
barCode1.QREscapeCode = 0x25;
barCode1.Value = "12345%SABCDE";
// 連結 QR コードで出力するシンボル番号を "0" に設定します。
barCode1.QRSymbolNumber = 0;
barCode1.Save(@"C:\Barcode1.bmp", ImageFormat.Bmp);
// 連結 QR コードで出力するシンボル番号を "1" に設定します。
barCode1.QRSymbolNumber = 1;
barCode1.Save(@"C:\Barcode2.bmp", ImageFormat.Bmp);
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10
' QR コード を "連結 QR コード(手動)" に設定します。
BarCode1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect
' QR コードのエスケープコードを "% (&H25)" に設定します。
BarCode1.QREscapeCode = &H25
BarCode1.Value = "12345%SABCDE"
' 連結 QR コードで出力するシンボル番号を "0" に設定します。
BarCode1.QRSymbolNumber = 0
BarCode1.Save("C:\Barcode1.bmp", ImageFormat.Bmp)
' 連結 QR コードで出力するシンボル番号を "1" に設定します。
BarCode1.QRSymbolNumber = 1
BarCode1.Save("C:\Barcode2.bmp", ImageFormat.Bmp)

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


QREscapeCode プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..QREscapeCode プロパティ
BarCode クラス 使用例 参照
QR コードのエスケープコードを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public byte QREscapeCode { get; set; }
Visual Basic (宣言)
Public Property QREscapeCode As Byte
    Get
    Set

プロパティ値

QR コードのエスケープコードを表す Byte。(既定値：0x00)

解説

Value プロパティや、ValueB プロパティに設定するバーコードデータの分割する位置に、"エスケープコード" + "S" を設定します。バーコードデータにエスケープコードと同じ文字がある場合、バーコードメッセージ側の該当する文字を二つ連続して設定してください。

このプロパティは、QRConnect プロパティの値が、QRConnect.ManualConnect の場合に有効です。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10;
// QR コード を "連結 QR コード(手動)" に設定します。
barCode1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect;
// QR コードのエスケープコードを "% (0x25)" に設定します。
barCode1.QREscapeCode = 0x25;
barCode1.Value = "12345%SABCDE";
// 連結 QR コードで出力するシンボル番号を "0" に設定します。
barCode1.QRSymbolNumber = 0;
barCode1.Save(@"C:\Barcode1.bmp", ImageFormat.Bmp);
// 連結 QR コードで出力するシンボル番号を "1" に設定します。
barCode1.QRSymbolNumber = 1;
barCode1.Save(@"C:\Barcode2.bmp", ImageFormat.Bmp);
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10
' QR コード を "連結 QR コード(手動)" に設定します。
BarCode1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect
' QR コードのエスケープコードを "% (&H25)" に設定します。
BarCode1.QREscapeCode = &H25
BarCode1.Value = "12345%SABCDE"
' 連結 QR コードで出力するシンボル番号を "0" に設定します。
BarCode1.QRSymbolNumber = 0
BarCode1.Save("C:\Barcode1.bmp", ImageFormat.Bmp)
' 連結 QR コードで出力するシンボル番号を "1" に設定します。
BarCode1.QRSymbolNumber = 1
BarCode1.Save("C:\Barcode2.bmp", ImageFormat.Bmp)

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


QRLevel プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..QRLevel プロパティ
BarCode クラス 使用例 参照
QR コードの誤り訂正レベルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRLevel QRLevel { get; set; }
Visual Basic (宣言)
Public Property QRLevel As QRLevel
    Get
    Set

プロパティ値

QR コードの誤り訂正レベルを表す QRLevel。(既定値：QRLevel.LevelM)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードのエラー訂正レベルを "H" に設定します。
barCode1.QRLevel = AdvanceSoftware.VBBarCode.QRLevel.LevelH;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードのエラー訂正レベルを "H" に設定します。
BarCode1.QRLevel = AdvanceSoftware.VBBarCode.QRLevel.LevelH
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


QRMask プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..QRMask プロパティ
BarCode クラス 使用例 参照
QR コードのマスクパターンを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRMask QRMask { get; set; }
Visual Basic (宣言)
Public Property QRMask As QRMask
    Get
    Set

プロパティ値

QR コードのマスクパターンを表す QRMask。(既定値：QRMask.MaskAuto)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
barCode1.QRMask = AdvanceSoftware.VBBarCode.QRMask.Mask000;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
BarCode1.QRMask = AdvanceSoftware.VBBarCode.QRMask.Mask000
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


QRModel プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..QRModel プロパティ
BarCode クラス 使用例 参照
QR コードのモデルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRModel QRModel { get; set; }
Visual Basic (宣言)
Public Property QRModel As QRModel
    Get
    Set

プロパティ値

QR コードのモデルを表す QRModel。(既定値：QRModel.Model1)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードのモデルを "モデル 2" に設定します。
barCode1.QRModel = AdvanceSoftware.VBBarCode.QRModel.Model2;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードのモデルを "モデル 2" に設定します。
BarCode1.QRModel = AdvanceSoftware.VBBarCode.QRModel.Model2
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


QRSymbolNumber プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..QRSymbolNumber プロパティ
BarCode クラス 使用例 参照
連結 QR コードで出力するシンボル番号を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int QRSymbolNumber { get; set; }
Visual Basic (宣言)
Public Property QRSymbolNumber As Integer
    Get
    Set

プロパティ値

連結 QR コードのシンボル番号を表す int。(既定値：0)

解説

設定範囲：0 ～ 15

このプロパティは、QRConnect プロパティの値が、QRConnect.AutoConnect、QRConnect.ManualConnect の場合に有効です。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10;
// QR コード を "連結 QR コード(手動)" に設定します。
barCode1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect;
// QR コードのエスケープコードを "% (0x25)" に設定します。
barCode1.QREscapeCode = 0x25;
barCode1.Value = "12345%SABCDE";
// 連結 QR コードで出力するシンボル番号を "0" に設定します。
barCode1.QRSymbolNumber = 0;
barCode1.Save(@"C:\Barcode1.bmp", ImageFormat.Bmp);
// 連結 QR コードで出力するシンボル番号を "1" に設定します。
barCode1.QRSymbolNumber = 1;
barCode1.Save(@"C:\Barcode2.bmp", ImageFormat.Bmp);
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10
' QR コード を "連結 QR コード(手動)" に設定します。
BarCode1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect
' QR コードのエスケープコードを "% (&H25)" に設定します。
BarCode1.QREscapeCode = &H25
BarCode1.Value = "12345%SABCDE"
' 連結 QR コードで出力するシンボル番号を "0" に設定します。
BarCode1.QRSymbolNumber = 0
BarCode1.Save("C:\Barcode1.bmp", ImageFormat.Bmp)
' 連結 QR コードで出力するシンボル番号を "1" に設定します。
BarCode1.QRSymbolNumber = 1
BarCode1.Save("C:\Barcode2.bmp", ImageFormat.Bmp)

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


QRVersion プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..QRVersion プロパティ
BarCode クラス 使用例 参照
QR コードの型番を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRVersion QRVersion { get; set; }
Visual Basic (宣言)
Public Property QRVersion As QRVersion
    Get
    Set

プロパティ値

QR コードの型番を表す QRVersion。(既定値：QRVersion.VersionAuto)

解説

プロパティ値が QRVersion.VersionAuto の場合、QR コードの型番は自動で設定されます。

QRModel プロパティの値により、QRVersion.VersionAuto 以外の設定範囲が異なります。

設定範囲(QRModel1)：QRVersion.QRVersion1 ～ QRVersion14

設定範囲(QRModel2)：QRVersion.QRVersion1 ～ QRVersion40

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


Quiet プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Quiet プロパティ
BarCode クラス 使用例 参照
余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金代理収納 GS1-128)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double Quiet { get; set; }
Visual Basic (宣言)
Public Property Quiet As Double
    Get
    Set

解説

プロパティ値が 0 の場合、バーコードの余白は自動で設定されます。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードイメージの余白幅を "2.5mm" に設定します。
barCode1.Quiet = 2.5;
barCode1.Value = "1234567890";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードイメージの余白幅を "2.5mm" に設定します。
BarCode1.Quiet = 2.5
BarCode1.Value = "1234567890"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


Rotate プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Rotate プロパティ
BarCode クラス 使用例 参照
バーコードの回転方向を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Rotate Rotate { get; set; }
Visual Basic (宣言)
Public Property Rotate As Rotate
    Get
    Set

プロパティ値

バーコードの回転方向を表す Rotate。(既定値：Rotate.Rotate0)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの向きを "時計回りで 90 度回転" に設定します。
barCode1.Rotate = AdvanceSoftware.VBBarCode.Rotate.Rotate90;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの向きを "時計回りで 90 度回転" に設定します。
BarCode1.Rotate = AdvanceSoftware.VBBarCode.Rotate.Rotate90
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


ShowBearer プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..ShowBearer プロパティ
BarCode クラス 使用例 参照
ベアラバーを表示するかを設定、取得します。(ITF)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool ShowBearer { get; set; }
Visual Basic (宣言)
Public Property ShowBearer As Boolean
    Get
    Set

プロパティ値

ベアラバーの表示モードを表す bool。(既定値：true)

解説

プロパティ値が true の場合、ベアラバーを表示します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.ITF16;
// ITF16 のベアラバーを "表示しない" に設定します。
barCode1.ShowBearer = false;
barCode1.Value = "1234567890123456";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.ITF16
' ITF16 のベアラバーを "表示しない" に設定します。
BarCode1.ShowBearer = False
BarCode1.Value = "1234567890123456"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


ShowMessage プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..ShowMessage プロパティ
BarCode クラス 使用例 参照
バーコードメッセージを表示するかを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool ShowMessage { get; set; }
Visual Basic (宣言)
Public Property ShowMessage As Boolean
    Get
    Set

プロパティ値

バーコードメッセージの表示モードを表す bool。(既定値：true)

解説

プロパティ値が true の場合、バーコードメッセージを表示します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードメッセージを "表示しない" に設定します。
barCode1.ShowMessage = false;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードメッセージを "表示しない" に設定します。
BarCode1.ShowMessage = False
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


StartChar プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..StartChar プロパティ
BarCode クラス 使用例 参照
スタートキャラクタを設定、取得します。(Codabar)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public char StartChar { get; set; }
Visual Basic (宣言)
Public Property StartChar As Char
    Get
    Set

プロパティ値

スタートキャラクタを表す char。(既定値：'a')

解説

設定可能な値：'a'、'b'、'c'、'd'、't'、'n'、'*'、'e'、'A'、'B'、'C'、'D'

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// Codabar のスタートキャラクタを "c" に設定します。
barCode1.StartChar = 'c';
barCode1.Value = "1234567890";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' Codabar のスタートキャラクタを "c" に設定します。
BarCode1.StartChar = "c"
BarCode1.Value = "1234567890"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


StopChar プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..StopChar プロパティ
BarCode クラス 使用例 参照
ストップキャラクタを設定、取得します。(Codabar)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public char StopChar { get; set; }
Visual Basic (宣言)
Public Property StopChar As Char
    Get
    Set

プロパティ値

ストップキャラクタを表す char。(既定値：'a')

解説

設定可能な値：'a'、'b'、'c'、'd'、't'、'n'、'*'、'e'、'A'、'B'、'C'、'D'

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// Codabar のストップキャラクタを "c" に設定します。
barCode1.StopChar = 'c';
barCode1.Value = "1234567890";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' Codabar のストップキャラクタを "c" に設定します。
BarCode1.StopChar = "c"
BarCode1.Value = "1234567890"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


TextRenderingHint プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..TextRenderingHint プロパティ
BarCode クラス 使用例 参照
バーコードキャラクタのテキストレンダリングの品質を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public TextRenderingHint TextRenderingHint { get; set; }
Visual Basic (宣言)
Public Property TextRenderingHint As TextRenderingHint
    Get
    Set

プロパティ値

バーコードキャラクタのテキストレンダリングを表す TextRenderingHint。(既定値：TextRenderingHint.SystemDefault)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードメッセージのテキストレンダリングの品質を "SingleBitPerPixel" に設定します。
barCode1.TextRenderingHint = System.Drawing.Text.TextRenderingHint.SingleBitPerPixel;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードメッセージのテキストレンダリングの品質を "SingleBitPerPixel" に設定します。
BarCode1.TextRenderingHint = System.Drawing.Text.TextRenderingHint.SingleBitPerPixel
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


Type プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Type プロパティ
BarCode クラス 使用例 参照
バーコードの種類を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public BarCodeType Type { get; set; }
Visual Basic (宣言)
Public Property Type As BarCodeType
    Get
    Set

プロパティ値

バーコードのタイプを表す BarCodeType。(既定値：BarCodeType.JAN13)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
// 生成するバーコードイメージを "JAN13" に設定します。
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
' 生成するバーコードイメージを "JAN13" に設定します。
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


Unit プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Unit プロパティ
BarCode クラス 使用例 参照
バーコードの生成単位を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Unit Unit { get; set; }
Visual Basic (宣言)
Public Property Unit As Unit
    Get
    Set

プロパティ値

バーコードの生成単位を表す Unit。(既定値：Unit.Pixel)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


Value プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Value プロパティ
BarCode クラス 使用例 参照
バーコードデータを設定、取得します。(文字列)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public string Value { get; set; }
Visual Basic (宣言)
Public Property Value As String
    Get
    Set

プロパティ値

バーコードデータを表す string。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードデータを設定します。 (文字列)
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードデータを設定します。 (文字列)
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


WhiteBarRevision プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..WhiteBarRevision プロパティ
BarCode クラス 使用例 参照
白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int WhiteBarRevision { get; set; }
Visual Basic (宣言)
Public Property WhiteBarRevision As Integer
    Get
    Set

プロパティ値

白バーのドット補正値を表す int。(既定値：0)

解説

Unit プロパティの値が、Unit.Pixel の場合、有効になります。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128;
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 白バーのドット補正値を "+2" に設定します。
barCode1.WhiteBarRevision = 2;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 白バーのドット補正値を "+2" に設定します。
BarCode1.WhiteBarRevision = 2
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


Zoom プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Zoom プロパティ
BarCode クラス 使用例 参照
倍率を設定、取得します。(JAN、UPC、ITF)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int Zoom { get; set; }
Visual Basic (宣言)
Public Property Zoom As Integer
    Get
    Set

プロパティ値

バーコードの倍率を表す int。(既定値：100)

解説

設定範囲(JAN、UPC)：50 ～ 200

設定範囲(ITF)：25 ～ 120

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの表示倍率を "200%" に設定します。
barCode1.Zoom = 200;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの表示倍率を "200%" に設定します。
BarCode1.Zoom = 200
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


BarCode イベント

[image] [image]

VB-BarCode 5.0 for .NET
BarCode イベント
BarCode クラス 参照

BarCode データ型で公開されるメンバを以下に示します。

イベント

 | 名前 | 説明
Public event | Error | バーコードの作成に失敗した時に発生します。

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


Error イベント

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Error イベント
BarCode クラス 使用例 参照
バーコードの作成に失敗した時に発生します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public event BarCodeErrorEventHandler Error
Visual Basic (宣言)
Public Event Error As BarCodeErrorEventHandler

使用例

コピーC#
// バーコードクラスのインスタンス生成
private AdvanceSoftware.VBBarCode.BarCode barCode1 = new AdvanceSoftware.VBBarCode.BarCode();
private void InitializeComponent()
{
    // バーコードクラスのエラーイベントに barCode1_Error メソッドを関連付け
    this.barCode1.Error += new AdvanceSoftware.VBBarCode.BarCode.BarCodeErrorEventHandler(barCode1_Error);
}
// バーコードクラスのエラーイベント
private void barCode1_Error(object sender, AdvanceSoftware.VBBarCode.BarCode.BarCodeErrorEventArgs e)
{
    MessageBox.Show(barCode1.ErrorMessage);
}
コピーVB.NET
' バーコードクラスのインスタンス生成 (WithEvents)
Private WithEvents BarCode1 As AdvanceSoftware.VBBarCode.BarCode = New AdvanceSoftware.VBBarCode.BarCode()
' バーコードクラスのエラーイベント
Private Sub BarCode1_Error(ByVal sender As Object, ByVal e As AdvanceSoftware.VBBarCode.BarCode.BarCodeErrorEventArgs) Handles BarCode1.Error
    MessageBox.Show(BarCode1.ErrorMessage)
End Sub

参照

BarCode クラス
AdvanceSoftware.VBBarCode 名前空間


BarCodeControl クラス

[image]

VB-BarCode 5.0 for .NET
BarCodeControl クラス
メンバ 参照
BarCodeControl クラス

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public class BarCodeControl : UserControl
Visual Basic (宣言)
Public Class BarCodeControl _
    Inherits UserControl

継承階層

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
AdvanceSoftware.VBBarCode..::..BarCodeControl

参照

BarCodeControl メンバ
AdvanceSoftware.VBBarCode 名前空間


BarCodeControl メンバ

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeControl メンバ
BarCodeControl クラス コンストラクタ メソッド プロパティ イベント 参照

BarCodeControl データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | BarCodeControl | コンストラクタ

メソッド

 | 名前 | 説明
Public method | GetBarCodeImage(ImageFormat) | バーコードのイメージを作成します。
Public method | GetBarCodeImage(ImageFormat, Boolean) | バーコードのイメージを作成します。
Public method | GetScaleSize | 指定した単位でバーコードのサイズを取得します。
Public method | Print()()()() | バーコードを印刷します。
Public method | Print(String) | バーコードを印刷します。
Public method | Print(Double, Double) | バーコードを印刷します。
Public method | Print(Double, Double, String) | バーコードを印刷します。
Public method | Save(Stream, ImageFormat) | バーコードのイメージを保存します。
Public method | Save(String, ImageFormat) | バーコードのイメージを保存します。
Public method | Save(Stream, ImageFormat, Boolean) | バーコードのイメージを保存します。
Public method | Save(String, ImageFormat, Boolean) | バーコードのイメージを保存します。
Public method | SaveSvg(Stream) | バーコードの SVG イメージを保存します。
Public method | SaveSvg(String) | バーコードの SVG イメージを保存します。
Public method | SaveSvgz(Stream) | バーコードの圧縮 SVG イメージを保存します。
Public method | SaveSvgz(String) | バーコードの圧縮 SVG イメージを保存します。

プロパティ

 | 名前 | 説明
Public property | _Type | バーコードの種類を設定、取得します。
Public property | _Unit | バーコードの生成単位を設定、取得します。
Public property | BackColor | バーコードシンボルの背景色を設定、取得します。 (Overrides Control..::..BackColor.)
Public property | BarColor | バーの色を設定、取得します。
Public property | BarHeight | バーコードの高さを設定、取得します。
Public property | BarRatio | 太バーのエレメント率を設定、取得します。(Codabar、Code39)
Public property | BarWidth | バーコードの幅を設定、取得します。
Public property | BinaryValue | バーコードデータを設定、取得します。(バイナリ)
Public property | BlackBarRevision | 黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
Public property | BlackRatio | 黒バーの太さの比率を設定、取得します。
Public property | CharGap | キャラクタ間のギャップを設定、取得します。(Codabar、Code39)
Public property | CharSize | バーコードキャラクタのフォントサイズを設定、取得します。
Public property | CheckCharMode | 自動でチェックキャラクタを付加するかを設定、取得します。
Public property | CheckPattern | チェックデジットの計算方法を設定、取得します。(Codabar)
Public property | Codeset | スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))
Public property | DpiX | X 軸方向の解像度を設定、取得します。(ピクセル単位)
Public property | DpiY | Y 軸方向の解像度を設定、取得します。(ピクセル単位)
Public property | Element | 最小エレメント値を設定、取得します。
Public property | EmfType | 拡張メタファイル(EMF)に格納されるレコードの品質を設定します。
Public property | ErrorMessage | エラーメッセージを取得します。
Public property | ErrorNo | エラーナンバーを取得します。
Public property | FlatHeight | ガードバーの均等化を設定、取得します。(JAN、UPC)
Public property | Font | バーコードメッセージのフォント名、フォントスタイルを設定、取得します。 (Overrides Control..::..Font.)
Public property | InternalQRVersion | QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。
Public property | InternalValue | 整形後のバーコードデータを取得します。
Public property | MessageAlign | バーコードメッセージの表示横位置を設定、取得します。(GS1Fixed)
Public property | PDFColumn | PDF417 の列数を設定、取得します。
Public property | PDFInitialSymbol | PDF417 の初期化シンボルを設定、取得します。
Public property | PDFLevel | PDF417 のエラー訂正レベルを設定、取得します。
Public property | PDFModel | PDF417 シンボルを設定、取得します。
Public property | PDFRatio | PDF417 の 1 モジュールの縦横比を設定、取得します。
Public property | PDFRow | PDF417 の行数を設定、取得します。
Public property | Point | ポイントを設定、取得します。(郵便カスタマバーコード)
Public property | QRConnect | 連結 QR コードを作成するかを設定、取得します。
Public property | QREscapeCode | QR コードのエスケープコードを設定、取得します。
Public property | QRLevel | QR コードの誤り訂正レベルを設定、取得します。
Public property | QRMask | QR コードのマスクパターンを設定、取得します。
Public property | QRModel | QR コードのモデルを設定、取得します。
Public property | QRSymbolNumber | 連結 QR コードで出力するシンボル番号を設定、取得します。
Public property | QRVersion | QR コードの型番を設定、取得します。
Public property | Quiet | 余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金代理収納 GS1-128)
Public property | RePaint | プロパティ変更時の再描画を行うかどうかを設定します。
Public property | Rotate | バーコードの回転方向を設定、取得します。
Public property | ShowBearer | ベアラバーを表示するかを設定、取得します。(ITF)
Public property | ShowMessage | バーコードメッセージを表示するかを設定、取得します。
Public property | StartChar | スタートキャラクタを設定、取得します。(Codabar)
Public property | StopChar | ストップキャラクタを設定、取得します。(Codabar)
Public property | TextRenderingHint | バーコードキャラクタのテキストレンダリングの品質を設定、取得します。
Public property | Type | バーコードの種類を設定、取得します。
Public property | Unit | バーコードの生成単位を設定、取得します。
Public property | Value | バーコードデータを設定、取得します。(文字列)
Public property | WhiteBarRevision | 白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
Public property | Zoom | 倍率を設定、取得します。(JAN、UPC、ITF)

イベント

 | 名前 | 説明
Public event | Error | バーコードの作成に失敗した時に発生します。

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


BarCodeControl コンストラクタ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl コンストラクタ
BarCodeControl クラス 参照
コンストラクタ

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public BarCodeControl()
Visual Basic (宣言)
Public Sub New

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


BarCodeControl メソッド

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeControl メソッド
BarCodeControl クラス 参照

BarCodeControl データ型で公開されるメンバを以下に示します。

メソッド

 | 名前 | 説明
Public method | GetBarCodeImage(ImageFormat) | バーコードのイメージを作成します。
Public method | GetBarCodeImage(ImageFormat, Boolean) | バーコードのイメージを作成します。
Public method | GetScaleSize | 指定した単位でバーコードのサイズを取得します。
Public method | Print()()()() | バーコードを印刷します。
Public method | Print(String) | バーコードを印刷します。
Public method | Print(Double, Double) | バーコードを印刷します。
Public method | Print(Double, Double, String) | バーコードを印刷します。
Public method | Save(Stream, ImageFormat) | バーコードのイメージを保存します。
Public method | Save(String, ImageFormat) | バーコードのイメージを保存します。
Public method | Save(Stream, ImageFormat, Boolean) | バーコードのイメージを保存します。
Public method | Save(String, ImageFormat, Boolean) | バーコードのイメージを保存します。
Public method | SaveSvg(Stream) | バーコードの SVG イメージを保存します。
Public method | SaveSvg(String) | バーコードの SVG イメージを保存します。
Public method | SaveSvgz(Stream) | バーコードの圧縮 SVG イメージを保存します。
Public method | SaveSvgz(String) | バーコードの圧縮 SVG イメージを保存します。

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


GetBarCodeImage メソッド

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..GetBarCodeImage メソッド
BarCodeControl クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | GetBarCodeImage(ImageFormat) | バーコードのイメージを作成します。
Public method | GetBarCodeImage(ImageFormat, Boolean) | バーコードのイメージを作成します。

参照

BarCodeControl クラス
BarCodeControl メンバ
AdvanceSoftware.VBBarCode 名前空間


GetBarCodeImage メソッド (ImageFormat)

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..GetBarCodeImage メソッド (ImageFormat)
BarCodeControl クラス 使用例 参照
バーコードのイメージを作成します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Image GetBarCodeImage(
    ImageFormat format
)
Visual Basic (宣言)
Public Function GetBarCodeImage ( _
    format As ImageFormat _
) As Image

パラメータ

format
Type: System.Drawing.Imaging..::..ImageFormat
保存する Image のImageFormat。

戻り値

このメソッドが作成する Image。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
// バーコードイメージ (拡張メタファイル) を生成します。
Image imgBarCode = barCodeControl1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf);
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
' バーコードイメージ (拡張メタファイル) を生成します。
Dim imgBarCode As Image = BarCodeControl1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf)

参照

BarCodeControl クラス
GetBarCodeImage オーバーロード
AdvanceSoftware.VBBarCode 名前空間


GetBarCodeImage メソッド (ImageFormat, Boolean)

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..GetBarCodeImage メソッド (ImageFormat, Boolean)
BarCodeControl クラス 使用例 参照
バーコードのイメージを作成します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Image GetBarCodeImage(
    ImageFormat format,
    bool resolution
)
Visual Basic (宣言)
Public Function GetBarCodeImage ( _
    format As ImageFormat, _
    resolution As Boolean _
) As Image

パラメータ

format
Type: System.Drawing.Imaging..::..ImageFormat
保存する Image のImageFormat。
resolution
Type: System..::..Boolean
DpiX プロパティ、DpiY プロパティの解像度で Bitmap を作成する場合、true を設定します。

戻り値

このメソッドが作成する Image。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
barCodeControl1.Value = "1234567890123";
// バーコードイメージ (ビットマップ) を DpiX, DpiY プロパティの解像度で生成します。
Image imgBarCode = barCodeControl1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp, true);
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
BarCodeControl1.Value = "1234567890123"
' バーコードイメージ (ビットマップ) を DpiX, DpiY プロパティの解像度で生成します。
Dim imgBarCode As Image = BarCodeControl1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp, True)

参照

BarCodeControl クラス
GetBarCodeImage オーバーロード
AdvanceSoftware.VBBarCode 名前空間


GetScaleSize メソッド

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..GetScaleSize メソッド
BarCodeControl クラス 使用例 参照
指定した単位でバーコードのサイズを取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public BarCodeSizeD GetScaleSize(
    Unit unit
)
Visual Basic (宣言)
Public Function GetScaleSize ( _
    unit As Unit _
) As BarCodeSizeD

パラメータ

unit
Type: AdvanceSoftware.VBBarCode..::..Unit
取得するサイズの単位を表す Unit 列挙体。

戻り値

バーコードのサイズ。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
AdvanceSoftware.VBBarCode.BarCodeSizeD barCodeSizeD;
// バーコードイメージのサイズを ミリ(mm) 単位で取得します。
barCodeSizeD = barCodeControl1.GetScaleSize(AdvanceSoftware.VBBarCode.Unit.Millimeter);
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
Dim BarCodeSizeD As AdvanceSoftware.VBBarCode.BarCodeSizeD
' バーコードイメージのサイズを ミリ(mm) 単位で取得します。
BarCodeSizeD = BarCodeControl1.GetScaleSize(AdvanceSoftware.VBBarCode.Unit.Millimeter)

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


Print メソッド

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Print メソッド
BarCodeControl クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | Print()()()() | バーコードを印刷します。
Public method | Print(String) | バーコードを印刷します。
Public method | Print(Double, Double) | バーコードを印刷します。
Public method | Print(Double, Double, String) | バーコードを印刷します。

参照

BarCodeControl クラス
BarCodeControl メンバ
AdvanceSoftware.VBBarCode 名前空間


Print メソッド

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Print メソッド
BarCodeControl クラス 使用例 参照
バーコードを印刷します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool Print()
Visual Basic (宣言)
Public Function Print As Boolean

戻り値

印刷が成功した場合 true を返します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
// バーコードイメージを印刷します。
barCodeControl1.Print();
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
' バーコードイメージを印刷します。
BarCodeControl1.Print()

参照

BarCodeControl クラス
Print オーバーロード
AdvanceSoftware.VBBarCode 名前空間


Print メソッド (String)

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Print メソッド (String)
BarCodeControl クラス 使用例 参照
バーコードを印刷します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool Print(
    string documentName
)
Visual Basic (宣言)
Public Function Print ( _
    documentName As String _
) As Boolean

パラメータ

documentName
Type: System..::..String
印刷ドキュメント名を指定します。

戻り値

印刷が成功した場合 true を返します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
// 印刷ドキュメント名を指定してバーコードイメージを印刷します。
barCodeControl1.Print("バーコード印刷");
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
' 印刷ドキュメント名を指定してバーコードイメージを印刷します。
BarCodeControl1.Print("バーコード印刷")

参照

BarCodeControl クラス
Print オーバーロード
AdvanceSoftware.VBBarCode 名前空間


Print メソッド (Double, Double)

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Print メソッド (Double, Double)
BarCodeControl クラス 使用例 参照
バーコードを印刷します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool Print(
    double x,
    double y
)
Visual Basic (宣言)
Public Function Print ( _
    x As Double, _
    y As Double _
) As Boolean

パラメータ

x
Type: System..::..Double
印刷するバーコードイメージの開始位置、x 座標を設定します。
y
Type: System..::..Double
印刷するバーコードイメージの開始位置、y 座標を設定します。

戻り値

印刷が成功した場合 true を返します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
barCodeControl1.Value = "1234567890123";
// 描画位置のオフセット(x:10.0mm / y:10.0mm)を指定してバーコードイメージを印刷します。
barCodeControl1.Print(10.0, 10.0);
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
BarCodeControl1.Value = "1234567890123"
' 描画位置のオフセット(x:10.0mm / y:10.0mm)を指定してバーコードイメージを印刷します。
BarCodeControl1.Print(10.0, 10.0)

参照

BarCodeControl クラス
Print オーバーロード
AdvanceSoftware.VBBarCode 名前空間


Print メソッド (Double, Double, String)

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Print メソッド (Double, Double, String)
BarCodeControl クラス 使用例 参照
バーコードを印刷します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool Print(
    double x,
    double y,
    string documentName
)
Visual Basic (宣言)
Public Function Print ( _
    x As Double, _
    y As Double, _
    documentName As String _
) As Boolean

パラメータ

x
Type: System..::..Double
印刷するバーコードイメージの開始位置、x 座標を設定します。
y
Type: System..::..Double
印刷するバーコードイメージの開始位置、y 座標を設定します。
documentName
Type: System..::..String
印刷ドキュメント名を指定します。

戻り値

印刷が成功した場合 true を返します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
barCodeControl1.Value = "1234567890123";
// 描画位置のオフセット(x:10.0mm / y:10.0mm)と印刷ドキュメント名を指定してバーコードイメージを印刷します。
barCodeControl1.Print(10.0, 10.0, "バーコード印刷");
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
BarCodeControl1.Value = "1234567890123"
' 描画位置のオフセット(x:10.0mm / y:10.0mm)と印刷ドキュメント名を指定してバーコードイメージを印刷します。
BarCodeControl1.Print(10.0, 10.0, "バーコード印刷")

参照

BarCodeControl クラス
Print オーバーロード
AdvanceSoftware.VBBarCode 名前空間


Save メソッド

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Save メソッド
BarCodeControl クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | Save(Stream, ImageFormat) | バーコードのイメージを保存します。
Public method | Save(String, ImageFormat) | バーコードのイメージを保存します。
Public method | Save(Stream, ImageFormat, Boolean) | バーコードのイメージを保存します。
Public method | Save(String, ImageFormat, Boolean) | バーコードのイメージを保存します。

参照

BarCodeControl クラス
BarCodeControl メンバ
AdvanceSoftware.VBBarCode 名前空間


Save メソッド (Stream, ImageFormat)

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Save メソッド (Stream, ImageFormat)
BarCodeControl クラス 使用例 参照
バーコードのイメージを保存します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public void Save(
    Stream stream,
    ImageFormat format
)
Visual Basic (宣言)
Public Sub Save ( _
    stream As Stream, _
    format As ImageFormat _
)

パラメータ

stream
Type: System.IO..::..Stream
イメージが保存される Stream。
format
Type: System.Drawing.Imaging..::..ImageFormat
保存する Image の ImageFormat。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
// バーコードイメージを保存します。
FileStream fileStream = new FileStream(@"C:\BarCode.jpg", FileMode.Create);
barCodeControl1.Save(fileStream, ImageFormat.Jpeg);
fileStream.Close();
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
' バーコードイメージを保存します。
Dim FileStream As FileStream = New FileStream("C:\BarCode.jpg", FileMode.Create)
BarCodeControl1.Save(FileStream, ImageFormat.Jpeg)
FileStream.Close()

参照

BarCodeControl クラス
Save オーバーロード
AdvanceSoftware.VBBarCode 名前空間


Save メソッド (String, ImageFormat)

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Save メソッド (String, ImageFormat)
BarCodeControl クラス 使用例 参照
バーコードのイメージを保存します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public void Save(
    string fileName,
    ImageFormat format
)
Visual Basic (宣言)
Public Sub Save ( _
    fileName As String, _
    format As ImageFormat _
)

パラメータ

fileName
Type: System..::..String
バーコードイメージの保存先ファイルの名前を格納している文字列。
format
Type: System.Drawing.Imaging..::..ImageFormat
保存する Image の ImageFormat。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
// バーコードイメージを保存します。
barCodeControl1.Save(@"C:\BarCode.jpg", ImageFormat.Jpeg);
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
' バーコードイメージを保存します。
BarCodeControl1.Save("C:\BarCode.jpg", ImageFormat.Jpeg)

参照

BarCodeControl クラス
Save オーバーロード
AdvanceSoftware.VBBarCode 名前空間


Save メソッド (Stream, ImageFormat, Boolean)

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Save メソッド (Stream, ImageFormat, Boolean)
BarCodeControl クラス 使用例 参照
バーコードのイメージを保存します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public void Save(
    Stream stream,
    ImageFormat format,
    bool resolution
)
Visual Basic (宣言)
Public Sub Save ( _
    stream As Stream, _
    format As ImageFormat, _
    resolution As Boolean _
)

パラメータ

stream
Type: System.IO..::..Stream
イメージが保存される Stream。
format
Type: System.Drawing.Imaging..::..ImageFormat
保存する Image の ImageFormat。
resolution
Type: System..::..Boolean
DpiX プロパティ、DpiY プロパティの解像度で Bitmap を作成する場合、true を設定します。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
barCodeControl1.Value = "1234567890123";
// バーコードイメージを保存します。
FileStream fileStream = new FileStream(@"C:\BarCode.bmp", FileMode.Create);
barCodeControl1.Save(fileStream, ImageFormat.Bmp, true);
fileStream.Close();
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
BarCodeControl1.Value = "1234567890123"
' バーコードイメージを保存します。
Dim FileStream As FileStream = New FileStream("C:\BarCode.bmp", FileMode.Create)
BarCodeControl1.Save(FileStream, ImageFormat.Bmp, True)
FileStream.Close()

参照

BarCodeControl クラス
Save オーバーロード
AdvanceSoftware.VBBarCode 名前空間


Save メソッド (String, ImageFormat, Boolean)

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Save メソッド (String, ImageFormat, Boolean)
BarCodeControl クラス 使用例 参照
バーコードのイメージを保存します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public void Save(
    string fileName,
    ImageFormat format,
    bool resolution
)
Visual Basic (宣言)
Public Sub Save ( _
    fileName As String, _
    format As ImageFormat, _
    resolution As Boolean _
)

パラメータ

fileName
Type: System..::..String
バーコードイメージの保存先ファイルの名前を格納している文字列。
format
Type: System.Drawing.Imaging..::..ImageFormat
保存する Image の ImageFormat。
resolution
Type: System..::..Boolean
DpiX プロパティ、DpiY プロパティの解像度で Bitmap を作成する場合、true を設定します。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.DpiX = 600;
barCodeControl1.DpiY = 600;
barCodeControl1.Value = "1234567890123";
// バーコードイメージを保存します。
barCodeControl1.Save(@"C:\BarCode.bmp", ImageFormat.Bmp, true);
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.DpiX = 600
BarCodeControl1.DpiY = 600
BarCodeControl1.Value = "1234567890123"
' バーコードイメージを保存します。
BarCodeControl1.Save("C:\BarCode.bmp", ImageFormat.Bmp, True)

参照

BarCodeControl クラス
Save オーバーロード
AdvanceSoftware.VBBarCode 名前空間


SaveSvg メソッド

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..SaveSvg メソッド
BarCodeControl クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | SaveSvg(Stream) | バーコードの SVG イメージを保存します。
Public method | SaveSvg(String) | バーコードの SVG イメージを保存します。

参照

BarCodeControl クラス
BarCodeControl メンバ
AdvanceSoftware.VBBarCode 名前空間


SaveSvg メソッド (Stream)

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..SaveSvg メソッド (Stream)
BarCodeControl クラス 使用例 参照
バーコードの SVG イメージを保存します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public void SaveSvg(
    Stream stream
)
Visual Basic (宣言)
Public Sub SaveSvg ( _
    stream As Stream _
)

パラメータ

stream
Type: System.IO..::..Stream
イメージが保存される Stream。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
// バーコードイメージを保存します。
FileStream fileStream = new FileStream(@"C:\BarCode.svg", FileMode.Create);
barCodeControl1.SaveSvg(fileStream);
fileStream.Close();
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
' バーコードイメージを保存します。
Dim FileStream As FileStream = New FileStream("C:\BarCode.svg", FileMode.Create)
BarCodeControl1.SaveSvg(FileStream)
FileStream.Close()

参照

BarCodeControl クラス
SaveSvg オーバーロード
AdvanceSoftware.VBBarCode 名前空間


SaveSvg メソッド (String)

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..SaveSvg メソッド (String)
BarCodeControl クラス 使用例 参照
バーコードの SVG イメージを保存します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public void SaveSvg(
    string fileName
)
Visual Basic (宣言)
Public Sub SaveSvg ( _
    fileName As String _
)

パラメータ

fileName
Type: System..::..String
バーコードイメージの保存先ファイルの名前を格納している文字列。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
// バーコードイメージを保存します。
barCodeControl1.SaveSvg(@"C:\BarCode.svg");
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
' バーコードイメージを保存します。
BarCodeControl1.SaveSvg("C:\BarCode.svg")

参照

BarCodeControl クラス
SaveSvg オーバーロード
AdvanceSoftware.VBBarCode 名前空間


SaveSvgz メソッド

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..SaveSvgz メソッド
BarCodeControl クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | SaveSvgz(Stream) | バーコードの圧縮 SVG イメージを保存します。
Public method | SaveSvgz(String) | バーコードの圧縮 SVG イメージを保存します。

参照

BarCodeControl クラス
BarCodeControl メンバ
AdvanceSoftware.VBBarCode 名前空間


SaveSvgz メソッド (Stream)

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..SaveSvgz メソッド (Stream)
BarCodeControl クラス 使用例 参照
バーコードの圧縮 SVG イメージを保存します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public void SaveSvgz(
    Stream stream
)
Visual Basic (宣言)
Public Sub SaveSvgz ( _
    stream As Stream _
)

パラメータ

stream
Type: System.IO..::..Stream
イメージが保存される Stream。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
// バーコードイメージを保存します。
FileStream fileStream = new FileStream(@"C:\BarCode.svgz", FileMode.Create);
barCodeControl1.SaveSvgz(fileStream);
fileStream.Close();
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
' バーコードイメージを保存します。
Dim FileStream As FileStream = New FileStream("C:\BarCode.svgz", FileMode.Create)
BarCodeControl1.SaveSvgz(FileStream)
FileStream.Close()

参照

BarCodeControl クラス
SaveSvgz オーバーロード
AdvanceSoftware.VBBarCode 名前空間


SaveSvgz メソッド (String)

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..SaveSvgz メソッド (String)
BarCodeControl クラス 使用例 参照
バーコードの圧縮 SVG イメージを保存します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public void SaveSvgz(
    string fileName
)
Visual Basic (宣言)
Public Sub SaveSvgz ( _
    fileName As String _
)

パラメータ

fileName
Type: System..::..String
バーコードイメージの保存先ファイルの名前を格納している文字列。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
// バーコードイメージを保存します。
barCodeControl1.SaveSvgz(@"C:\BarCode.svgz");
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
' バーコードイメージを保存します。
BarCodeControl1.SaveSvgz("C:\BarCode.svgz")

参照

BarCodeControl クラス
SaveSvgz オーバーロード
AdvanceSoftware.VBBarCode 名前空間


BarCodeControl プロパティ

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeControl プロパティ
BarCodeControl クラス 参照

BarCodeControl データ型で公開されるメンバを以下に示します。

プロパティ

 | 名前 | 説明
Public property | _Type | バーコードの種類を設定、取得します。
Public property | _Unit | バーコードの生成単位を設定、取得します。
Public property | BackColor | バーコードシンボルの背景色を設定、取得します。 (Overrides Control..::..BackColor.)
Public property | BarColor | バーの色を設定、取得します。
Public property | BarHeight | バーコードの高さを設定、取得します。
Public property | BarRatio | 太バーのエレメント率を設定、取得します。(Codabar、Code39)
Public property | BarWidth | バーコードの幅を設定、取得します。
Public property | BinaryValue | バーコードデータを設定、取得します。(バイナリ)
Public property | BlackBarRevision | 黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
Public property | BlackRatio | 黒バーの太さの比率を設定、取得します。
Public property | CharGap | キャラクタ間のギャップを設定、取得します。(Codabar、Code39)
Public property | CharSize | バーコードキャラクタのフォントサイズを設定、取得します。
Public property | CheckCharMode | 自動でチェックキャラクタを付加するかを設定、取得します。
Public property | CheckPattern | チェックデジットの計算方法を設定、取得します。(Codabar)
Public property | Codeset | スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))
Public property | DpiX | X 軸方向の解像度を設定、取得します。(ピクセル単位)
Public property | DpiY | Y 軸方向の解像度を設定、取得します。(ピクセル単位)
Public property | Element | 最小エレメント値を設定、取得します。
Public property | EmfType | 拡張メタファイル(EMF)に格納されるレコードの品質を設定します。
Public property | ErrorMessage | エラーメッセージを取得します。
Public property | ErrorNo | エラーナンバーを取得します。
Public property | FlatHeight | ガードバーの均等化を設定、取得します。(JAN、UPC)
Public property | Font | バーコードメッセージのフォント名、フォントスタイルを設定、取得します。 (Overrides Control..::..Font.)
Public property | InternalQRVersion | QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。
Public property | InternalValue | 整形後のバーコードデータを取得します。
Public property | MessageAlign | バーコードメッセージの表示横位置を設定、取得します。(GS1Fixed)
Public property | PDFColumn | PDF417 の列数を設定、取得します。
Public property | PDFInitialSymbol | PDF417 の初期化シンボルを設定、取得します。
Public property | PDFLevel | PDF417 のエラー訂正レベルを設定、取得します。
Public property | PDFModel | PDF417 シンボルを設定、取得します。
Public property | PDFRatio | PDF417 の 1 モジュールの縦横比を設定、取得します。
Public property | PDFRow | PDF417 の行数を設定、取得します。
Public property | Point | ポイントを設定、取得します。(郵便カスタマバーコード)
Public property | QRConnect | 連結 QR コードを作成するかを設定、取得します。
Public property | QREscapeCode | QR コードのエスケープコードを設定、取得します。
Public property | QRLevel | QR コードの誤り訂正レベルを設定、取得します。
Public property | QRMask | QR コードのマスクパターンを設定、取得します。
Public property | QRModel | QR コードのモデルを設定、取得します。
Public property | QRSymbolNumber | 連結 QR コードで出力するシンボル番号を設定、取得します。
Public property | QRVersion | QR コードの型番を設定、取得します。
Public property | Quiet | 余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金代理収納 GS1-128)
Public property | RePaint | プロパティ変更時の再描画を行うかどうかを設定します。
Public property | Rotate | バーコードの回転方向を設定、取得します。
Public property | ShowBearer | ベアラバーを表示するかを設定、取得します。(ITF)
Public property | ShowMessage | バーコードメッセージを表示するかを設定、取得します。
Public property | StartChar | スタートキャラクタを設定、取得します。(Codabar)
Public property | StopChar | ストップキャラクタを設定、取得します。(Codabar)
Public property | TextRenderingHint | バーコードキャラクタのテキストレンダリングの品質を設定、取得します。
Public property | Type | バーコードの種類を設定、取得します。
Public property | Unit | バーコードの生成単位を設定、取得します。
Public property | Value | バーコードデータを設定、取得します。(文字列)
Public property | WhiteBarRevision | 白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
Public property | Zoom | 倍率を設定、取得します。(JAN、UPC、ITF)

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


_Type プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::.._Type プロパティ
BarCodeControl クラス 使用例 参照
バーコードの種類を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public BarCodeType _Type { get; set; }
Visual Basic (宣言)
Public Property _Type As BarCodeType
    Get
    Set

プロパティ値

バーコードのタイプを表す BarCodeType。(既定値：BarCodeType.JAN13)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
// 生成するバーコードイメージを "JAN13" に設定します。
barCodeControl1._Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
' 生成するバーコードイメージを "JAN13" に設定します。
BarCodeControl1._Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


_Unit プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::.._Unit プロパティ
BarCodeControl クラス 使用例 参照
バーコードの生成単位を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Unit _Unit { get; set; }
Visual Basic (宣言)
Public Property _Unit As Unit
    Get
    Set

プロパティ値

バーコードの生成単位を表す Unit。(既定値：Unit.Pixel)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCodeControl1._Unit = AdvanceSoftware.BarCode.Unit.Millimeter;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCodeControl1._Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


BackColor プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..BackColor プロパティ
BarCodeControl クラス 使用例 参照
バーコードシンボルの背景色を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public override Color BackColor { get; set; }
Visual Basic (宣言)
Public Overrides Property BackColor As Color
    Get
    Set

プロパティ値

バーコードシンボルの背景色を表す Color。(既定値：Color.White)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの背景色を "赤色" に設定します。
barCodeControl1.BackColor = System.Drawing.Color.Red;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの背景色を "赤色" に設定します。
BarCodeControl1.BackColor = System.Drawing.Color.Red
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


BarColor プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..BarColor プロパティ
BarCodeControl クラス 使用例 参照
バーの色を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Color BarColor { get; set; }
Visual Basic (宣言)
Public Property BarColor As Color
    Get
    Set

プロパティ値

バーの色を表す Color。(既定値：Color.Black)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーの色を "赤色" に設定します。
barCodeControl1.BarColor = System.Drawing.Color.Red;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーの色を "赤色" に設定します。
BarCodeControl1.BarColor = System.Drawing.Color.Red
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


BarHeight プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..BarHeight プロパティ
BarCodeControl クラス 使用例 参照
バーコードの高さを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double BarHeight { get; set; }
Visual Basic (宣言)
Public Property BarHeight As Double
    Get
    Set

プロパティ値

バーコードの高さを表す double。(既定値：0.0)

解説

プロパティ値が 0 の場合、バーコードの高さは自動で設定されます。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードイメージの高さを "30.0mm" に設定します。
barCodeControl1.BarHeight = 30.0;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードイメージの高さを "30.0mm" に設定します。
BarCodeControl1.BarHeight = 30.0
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


BarRatio プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..BarRatio プロパティ
BarCodeControl クラス 使用例 参照
太バーのエレメント率を設定、取得します。(Codabar、Code39)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double BarRatio { get; set; }
Visual Basic (宣言)
Public Property BarRatio As Double
    Get
    Set

プロパティ値

太バーのエレメント率を表す double。(既定値：2.0)

解説

設定範囲

最小エレメント値が 0.508mm 未満：2.2 ～ 3.0

最小エレメント値が 0.508mm 以上：2.0 ～ 3.0

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// 太バーのエレメント率を "2.5" に設定します。
barCodeControl1.BarRatio = 2.5;
barCodeControl1.Value = "1234567890";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' 太バーのエレメント率を "2.5" に設定します。
BarCodeControl1.BarRatio = 2.5
BarCodeControl1.Value = "1234567890"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


BarWidth プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..BarWidth プロパティ
BarCodeControl クラス 使用例 参照
バーコードの幅を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double BarWidth { get; set; }
Visual Basic (宣言)
Public Property BarWidth As Double
    Get
    Set

プロパティ値

バーコードの幅を表す double。(既定値：0.0)

解説

プロパティ値が 0 の場合、バーコードの幅は自動で設定されます。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードイメージの幅を "60.0mm" に設定します。
barCodeControl1.BarWidth = 60.0;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードイメージの幅を "60.0mm" に設定します。
BarCodeControl1.BarWidth = 60.0
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


BinaryValue プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..BinaryValue プロパティ
BarCodeControl クラス 使用例 参照
バーコードデータを設定、取得します。(バイナリ)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public byte[] BinaryValue { set; }
Visual Basic (宣言)
Public WriteOnly Property BinaryValue As Byte()
    Set

プロパティ値

バーコードデータを表す Byte。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// "12345ABCDE"
Byte[] btByte = new Byte[] { 49, 50, 51, 52, 53, 65, 66, 67, 68, 69 };
// バーコードデータを設定します。 (バイナリ)
barCodeControl1.BinaryValue = btByte;
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' "12345ABCDE"
Dim btByte() As Byte = New Byte() {49, 50, 51, 52, 53, 65, 66, 67, 68, 69}
' バーコードデータを設定します。 (バイナリ)
BarCodeControl1.BinaryValue = btByte

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


BlackBarRevision プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..BlackBarRevision プロパティ
BarCodeControl クラス 使用例 参照
黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int BlackBarRevision { get; set; }
Visual Basic (宣言)
Public Property BlackBarRevision As Integer
    Get
    Set

プロパティ値

黒バーのドット補正値を表す int。(既定値：0)

解説

Unit プロパティの値が、Unit.Pixel の場合、有効になります。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 黒バーのドット補正値を "+2" に設定します。
barCodeControl1.BlackBarRevision = 2;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 黒バーのドット補正値を "+2" に設定します。
BarCodeControl1.BlackBarRevision = 2
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


BlackRatio プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..BlackRatio プロパティ
BarCodeControl クラス 使用例 参照
黒バーの太さの比率を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int BlackRatio { get; set; }
Visual Basic (宣言)
Public Property BlackRatio As Integer
    Get
    Set

プロパティ値

黒バーの太さの比率を表す int。(既定値：100)

解説

設定範囲：50 ～ 150

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// 黒バーの太さ比率を "150%" に設定します。
barCodeControl1.BlackRatio = 150;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' 黒バーの太さ比率を "150%" に設定します。
BarCodeControl1.BlackRatio = 150
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


CharGap プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..CharGap プロパティ
BarCodeControl クラス 使用例 参照
キャラクタ間のギャップを設定、取得します。(Codabar、Code39)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double CharGap { get; set; }
Visual Basic (宣言)
Public Property CharGap As Double
    Get
    Set

プロパティ値

キャラクタ間のギャップを表す double。(既定値：0.0)

解説

プロパティ値が 0 の場合、キャラクタ間のギャップは自動で設定されます。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code39;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードキャラクタの間隔を "2.0mm" に設定します。
barCodeControl1.CharGap = 2.0;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code39
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードキャラクタの間隔を "2.0mm" に設定します。
BarCodeControl1.CharGap = 2.0
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


CharSize プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..CharSize プロパティ
BarCodeControl クラス 使用例 参照
バーコードキャラクタのフォントサイズを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double CharSize { get; set; }
Visual Basic (宣言)
Public Property CharSize As Double
    Get
    Set

プロパティ値

バーコードキャラクタのフォントサイズを表す double。(既定値：0.0)

解説

プロパティ値が 0 の場合、バーコードキャラクタのフォントサイズは自動で設定されます。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードメッセージのフォントサイズを "10.0mm" に設定します。
barCodeControl1.CharSize = 10.0;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードメッセージのフォントサイズを "10.0mm" に設定します。
BarCodeControl1.CharSize = 10.0
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


CheckCharMode プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..CheckCharMode プロパティ
BarCodeControl クラス 使用例 参照
自動でチェックキャラクタを付加するかを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool CheckCharMode { get; set; }
Visual Basic (宣言)
Public Property CheckCharMode As Boolean
    Get
    Set

プロパティ値

チェックキャラクタのモードを表す bool。(既定値：true)

解説

プロパティ値が true の場合、自動でチェックキャラクタを付加します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// チェックキャラクタを "付加しない" に設定します。
barCodeControl1.CheckCharMode = false;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' チェックキャラクタを "付加しない" に設定します。
BarCodeControl1.CheckCharMode = False
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


CheckPattern プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..CheckPattern プロパティ
BarCodeControl クラス 使用例 参照
チェックデジットの計算方法を設定、取得します。(Codabar)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public CheckPattern CheckPattern { get; set; }
Visual Basic (宣言)
Public Property CheckPattern As CheckPattern
    Get
    Set

プロパティ値

チェックデジットの計算方法を表す CheckPattern。(既定値：CheckPattern.Modulus16)

解説

CheckPattern.Modulus11(モジュラス 11) を設定した場合、計算に必要なバーコードメッセージは 6 桁以上必要になります。6 桁未満の場合は、Modulus10Weight3(モジュラス10 / ウエイト3) で計算されます。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// チェックデジットの計算方法を "モジュラス 11" に設定します。
barCodeControl1.CheckPattern = AdvanceSoftware.VBBarCode.CheckPattern.Modulus11;
barCodeControl1.Value = "12345678";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' チェックデジットの計算方法を "モジュラス 11" に設定します。
BarCodeControl1.CheckPattern = AdvanceSoftware.VBBarCode.CheckPattern.Modulus11
BarCodeControl1.Value = "12345678"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


Codeset プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Codeset プロパティ
BarCodeControl クラス 使用例 参照
スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Codeset Codeset { get; set; }
Visual Basic (宣言)
Public Property Codeset As Codeset
    Get
    Set

プロパティ値

スタートコードセットを表す Codeset。(既定値：Codeset.CodesetAuto)

解説

プロパティ値が CodeSet.CodesetAuto の場合、バーコードデータの先頭の文字でコードセットが決まります。

先頭キャラクタが ~(チルダ) の場合、コードセットA に設定されます。

先頭キャラクタがアルファベットの場合、コードセットB に設定されます。

先頭から 2 キャラクタが数字の場合、コードセット C に設定されます。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128;
// Code128 を "コードセット B" に設定します。
barCodeControl1.Codeset = AdvanceSoftware.VBBarCode.Codeset.CodesetB;
barCodeControl1.Value = "abc123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128
' Code128 を "コードセット B" に設定します。
BarCodeControl1.Codeset = AdvanceSoftware.VBBarCode.Codeset.CodesetB
BarCodeControl1.Value = "abc123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


DpiX プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..DpiX プロパティ
BarCodeControl クラス 使用例 参照
X 軸方向の解像度を設定、取得します。(ピクセル単位)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double DpiX { get; set; }
Visual Basic (宣言)
Public Property DpiX As Double
    Get
    Set

プロパティ値

X 軸方向の解像度を表す double。(既定値：96.0)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// X 軸方向の解像度を "600dpi" に設定します。
barCodeControl1.DpiX = 600;
// Y 軸方向の解像度を "600dpi" に設定します。
barCodeControl1.DpiY = 600;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' X 軸方向の解像度を "600dpi" に設定します。
BarCodeControl1.DpiX = 600
' Y 軸方向の解像度を "600dpi" に設定します。
BarCodeControl1.DpiY = 600
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


DpiY プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..DpiY プロパティ
BarCodeControl クラス 使用例 参照
Y 軸方向の解像度を設定、取得します。(ピクセル単位)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double DpiY { get; set; }
Visual Basic (宣言)
Public Property DpiY As Double
    Get
    Set

プロパティ値

Y 軸方向の解像度を表す double。(既定値：96.0)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// X 軸方向の解像度を "600dpi" に設定します。
barCodeControl1.DpiX = 600;
// Y 軸方向の解像度を "600dpi" に設定します。
barCodeControl1.DpiY = 600;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' X 軸方向の解像度を "600dpi" に設定します。
BarCodeControl1.DpiX = 600
' Y 軸方向の解像度を "600dpi" に設定します。
BarCodeControl1.DpiY = 600
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


Element プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Element プロパティ
BarCodeControl クラス 使用例 参照
最小エレメント値を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double Element { get; set; }
Visual Basic (宣言)
Public Property Element As Double
    Get
    Set

プロパティ値

最小エレメント値を表す double。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードイメージの最小エレメント値を "0.191mm" に設定します。
barCodeControl1.Element = 0.191;
barCodeControl1.Value = "1234567890";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードイメージの最小エレメント値を "0.191mm" に設定します。
BarCodeControl1.Element = 0.191
BarCodeControl1.Value = "1234567890"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


EmfType プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..EmfType プロパティ
BarCodeControl クラス 使用例 参照
拡張メタファイル(EMF)に格納されるレコードの品質を設定します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public EmfType EmfType { get; set; }
Visual Basic (宣言)
Public Property EmfType As EmfType
    Get
    Set

プロパティ値

拡張メタファイルのレコード品質を表す EmfType。(既定値：EmfType.EmfPlusDual)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// 拡張メタファイルのレコード品質を "EmfOnly" に設定します。
barCodeControl1.EmfType = System.Drawing.Imaging.EmfType.EmfOnly;
barCodeControl1.Value = "1234567890123";
Image imgBarCode = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf);
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' 拡張メタファイルのレコード品質を "EmfOnly" に設定します。
BarCodeControl1.EmfType = System.Drawing.Imaging.EmfType.EmfOnly
BarCodeControl1.Value = "1234567890123"
Dim imgBarCode As Image = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf)

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


ErrorMessage プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..ErrorMessage プロパティ
BarCodeControl クラス 使用例 参照
エラーメッセージを取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public string ErrorMessage { get; }
Visual Basic (宣言)
Public ReadOnly Property ErrorMessage As String
    Get

プロパティ値

バーコード生成時のエラーメッセージを表す string。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
// エラー処理
if (barCodeControl1.ErrorNo != AdvanceSoftware.VBBarCode.ErrorNo.NoError)
{
    // エラーメッセージを表示します。
    MessageBox.Show(barCodeControl1.ErrorMessage);
}
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
' エラー処理
If BarCodeControl1.ErrorNo <> AdvanceSoftware.VBBarCode.ErrorNo.NoError Then
    ' エラーメッセージを表示します。
    MessageBox.Show(BarCodeControl1.ErrorMessage)
End If

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


ErrorNo プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..ErrorNo プロパティ
BarCodeControl クラス 使用例 参照
エラーナンバーを取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public ErrorNo ErrorNo { get; }
Visual Basic (宣言)
Public ReadOnly Property ErrorNo As ErrorNo
    Get

プロパティ値

バーコード生成時のエラーナンバーを表す ErrorNo。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
// エラー処理
if (barCodeControl1.ErrorNo != AdvanceSoftware.VBBarCode.ErrorNo.NoError)
{
    // エラーメッセージを表示します。
    MessageBox.Show(barCodeControl1.ErrorMessage);
}
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
' エラー処理
If BarCodeControl1.ErrorNo <> AdvanceSoftware.VBBarCode.ErrorNo.NoError Then
    ' エラーメッセージを表示します。
    MessageBox.Show(BarCodeControl1.ErrorMessage)
End If

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


FlatHeight プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..FlatHeight プロパティ
BarCodeControl クラス 使用例 参照
ガードバーの均等化を設定、取得します。(JAN、UPC)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool FlatHeight { get; set; }
Visual Basic (宣言)
Public Property FlatHeight As Boolean
    Get
    Set

プロパティ値

ガードバーの均等化を表す bool。(既定値：false)

解説

プロパティ値が true の場合、ガードバーを均等化します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// ガードバーの長さを均等に設定します。
barCodeControl1.FlatHeight = true;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' ガードバーの長さを均等に設定します。
BarCodeControl1.FlatHeight = True
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


Font プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Font プロパティ
BarCodeControl クラス 使用例 参照
バーコードメッセージのフォント名、フォントスタイルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public override Font Font { get; set; }
Visual Basic (宣言)
Public Overrides Property Font As Font
    Get
    Set

プロパティ値

バーコードメッセージのフォントを表す Font。

解説

このプロパティは、バーコードメッセージのフォント名、フォントスタイルを設定することができます。 フォントサイズは反映されないため、CharSize プロパティで設定して下さい。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードメッセージを "フォント名：ＭＳ 明朝 , フォントスタイル：斜体" に設定します。
barCodeControl1.Font = new System.Drawing.Font("ＭＳ 明朝", 9, FontStyle.Italic);
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードメッセージを "フォント名：ＭＳ 明朝 , フォントスタイル：斜体" に設定します。
BarCodeControl1.Font = New System.Drawing.Font("ＭＳ 明朝", 9, FontStyle.Italic)
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


InternalQRVersion プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..InternalQRVersion プロパティ
BarCodeControl クラス 使用例 参照
QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRVersion InternalQRVersion { get; }
Visual Basic (宣言)
Public ReadOnly Property InternalQRVersion As QRVersion
    Get

プロパティ値

QR コードの型番を表す QRVersion。

解説

プロパティ値が QRVersion.VersionAuto の場合、QR コードの型番は自動で設定されます。

QRModel プロパティの値により、QRVersion.VersionAuto 以外の設定範囲が異なります。

設定範囲(QRModel1)：QRVersion.QRVersion1 ～ QRVersion14

設定範囲(QRModel2)：QRVersion.QRVersion1 ～ QRVersion40

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
barCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.VersionAuto;
barCodeControl1.Value = "12345ABCDE";
Image imgBarCode = barCodeControl1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf);
// 自動設定された QR コード の型番を取得します。
AdvanceSoftware.VBBarCode.QRVersion internalQRVersion = barCodeControl1.InternalQRVersion;
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
BarCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.VersionAuto
BarCodeControl1.Value = "12345ABCDE"
Dim imgBarCode As Image = BarCodeControl1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf)
' 自動設定された QR コード の型番を取得します。
Dim internalQRVersion As AdvanceSoftware.VBBarCode.QRVersion = BarCodeControl1.InternalQRVersion

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


InternalValue プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..InternalValue プロパティ
BarCodeControl クラス 使用例 参照
整形後のバーコードデータを取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public string InternalValue { get; }
Visual Basic (宣言)
Public ReadOnly Property InternalValue As String
    Get

プロパティ値

整形後のバーコードデータを表す string。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
Image imgBarCode = barCodeControl1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf);
// 整形後のバーコードデータを取得します。
string internalValue = barCodeControl1.InternalValue;
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
Dim imgBarCode As Image = BarCodeControl1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf)
' 整形後のバーコードデータを取得します。
Dim internalValue As String = BarCodeControl1.InternalValue

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


MessageAlign プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..MessageAlign プロパティ
BarCodeControl クラス 使用例 参照
バーコードメッセージの表示横位置を設定、取得します。(GS1Fixed)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public MessageAlign MessageAlign { get; set; }
Visual Basic (宣言)
Public Property MessageAlign As MessageAlign
    Get
    Set

プロパティ値

バーコードメッセージの表示横位置を表す MessageAlign。(既定値：MessageAlign.Center)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.GS1Fixed;
// バーコードメッセージの横位置を "左詰め" に設定します。(GS1Fixed)
barCodeControl1.MessageAlign = AdvanceSoftware.VBBarCode.MessageAlign.Left;
barCodeControl1.Value = "91012345678901234567890123456789012345678901";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.GS1Fixed
' バーコードメッセージの横位置を "左詰め" に設定します。(GS1Fixed)
BarCodeControl1.MessageAlign = AdvanceSoftware.VBBarCode.MessageAlign.Left
BarCodeControl1.Value = "91012345678901234567890123456789012345678901"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


PDFColumn プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..PDFColumn プロパティ
BarCodeControl クラス 使用例 参照
PDF417 の列数を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int PDFColumn { get; set; }
Visual Basic (宣言)
Public Property PDFColumn As Integer
    Get
    Set

プロパティ値

PDF417 の列数を表す int。(既定値：0)

解説

設定範囲：0 ～ 40

プロパティ値が 0 の場合、縦横比 1:2 で PDF417 を作成します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 の列数を "15列" に設定します。
barCodeControl1.PDFColumn = 15;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 の列数を "15列" に設定します。
BarCodeControl1.PDFColumn = 15
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


PDFInitialSymbol プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..PDFInitialSymbol プロパティ
BarCodeControl クラス 使用例 参照
PDF417 の初期化シンボルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool PDFInitialSymbol { get; set; }
Visual Basic (宣言)
Public Property PDFInitialSymbol As Boolean
    Get
    Set

プロパティ値

PDF417 の初期化シンボルを表す bool。(既定値：false)

解説

プロパティ値が true の場合、初期化シンボルを付加した PDF417 を作成します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 の初期化シンボルを "付加する" に設定します。
barCodeControl1.PDFInitialSymbol = true;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 の初期化シンボルを "付加する" に設定します。
BarCodeControl1.PDFInitialSymbol = True
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


PDFLevel プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..PDFLevel プロパティ
BarCodeControl クラス 使用例 参照
PDF417 のエラー訂正レベルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int PDFLevel { get; set; }
Visual Basic (宣言)
Public Property PDFLevel As Integer
    Get
    Set

プロパティ値

PDF417 のエラー訂正レベルを表す int。(既定値：0)

解説

設定範囲：0 ～ 8

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 のエラー訂正レベルを "レベル7" に設定します。
barCodeControl1.PDFLevel = 7;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 のエラー訂正レベルを "レベル7" に設定します。
BarCodeControl1.PDFLevel = 7
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


PDFModel プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..PDFModel プロパティ
BarCodeControl クラス 使用例 参照
PDF417 シンボルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public PDFModel PDFModel { get; set; }
Visual Basic (宣言)
Public Property PDFModel As PDFModel
    Get
    Set

プロパティ値

PDF417 シンボルを表す PDFModel。(既定値：PDFModel.Default)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 シンボルを "簡易 PDF417" に設定します。
barCodeControl1.PDFModel = AdvanceSoftware.VBBarCode.PDFModel.Truncated;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 シンボルを "簡易 PDF417" に設定します。
BarCodeControl1.PDFModel = AdvanceSoftware.VBBarCode.PDFModel.Truncated
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


PDFRatio プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..PDFRatio プロパティ
BarCodeControl クラス 使用例 参照
PDF417 の 1 モジュールの縦横比を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double PDFRatio { get; set; }
Visual Basic (宣言)
Public Property PDFRatio As Double
    Get
    Set

プロパティ値

PDF417 の 1 モジュールの縦横比を表す double。(既定値：7.5)

解説

設定範囲：1.0 ～ 10.0

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 の 1 モジュールの幅との縦横比を "5.0" に設定します。
barCodeControl1.PDFRatio = 5.0;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 の 1 モジュールの幅との縦横比を "5.0" に設定します。
BarCodeControl1.PDFRatio = 5.0
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


PDFRow プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..PDFRow プロパティ
BarCodeControl クラス 使用例 参照
PDF417 の行数を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int PDFRow { get; set; }
Visual Basic (宣言)
Public Property PDFRow As Integer
    Get
    Set

プロパティ値

PDF417 の行数を表す int。(既定値：0)

解説

設定範囲：0、3 ～ 90

プロパティ値が 0 の場合、縦横比 1:2 で PDF417 を作成します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 の行数を "10行" に設定します。
barCodeControl1.PDFRow = 10;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 の行数を "10行" に設定します。
BarCodeControl1.PDFRow = 10
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


Point プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Point プロパティ
BarCodeControl クラス 使用例 参照
ポイントを設定、取得します。(郵便カスタマバーコード)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double Point { get; set; }
Visual Basic (宣言)
Public Property Point As Double
    Get
    Set

プロパティ値

バーコードのポイントを表す double。(既定値：10.0)

解説

設定範囲：6.0 ～ 14.0

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.CustomerBarCode;
// 郵便カスタマバーコードのポイントを "10.0" に設定します。
barCodeControl1.Point = 10.0;
barCodeControl1.Value = "91882391-2816";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.CustomerBarCode
' 郵便カスタマバーコードのポイントを "10.0" に設定します。
BarCodeControl1.Point = 10.0
BarCodeControl1.Value = "91882391-2816"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


QRConnect プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..QRConnect プロパティ
BarCodeControl クラス 使用例 参照
連結 QR コードを作成するかを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRConnect QRConnect { get; set; }
Visual Basic (宣言)
Public Property QRConnect As QRConnect
    Get
    Set

プロパティ値

連結 QR コードの設定を表す QRConnect。(既定値：QRConnect.NotConnect)

解説

プロパティ値が QRConnect.AutoConnect、QRConnect.ManualConnect の場合、QRVersion プロパティを QRVersion.VersionAuto 以外に設定します。

また、QRConnect.ManualConnect の場合、QREscapeCode プロパティを使用して分割する位置のエスケープコードを設定します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10;
// QR コード を "連結 QR コード(手動)" に設定します。
barCodeControl1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect;
// QR コードのエスケープコードを "% (0x25)" に設定します。
barCodeControl1.QREscapeCode = 0x25;
barCodeControl1.Value = "12345%SABCDE";
// 連結 QR コードで出力するシンボル番号を "0" に設定します。
barCodeControl1.QRSymbolNumber = 0;
barCodeControl1.Save(@"C:\Barcode1.bmp", ImageFormat.Bmp);
// 連結 QR コードで出力するシンボル番号を "1" に設定します。
barCodeControl1.QRSymbolNumber = 1;
barCodeControl1.Save(@"C:\Barcode2.bmp", ImageFormat.Bmp);
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10
' QR コード を "連結 QR コード(手動)" に設定します。
BarCodeControl1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect
' QR コードのエスケープコードを "% (&H25)" に設定します。
BarCodeControl1.QREscapeCode = &H25
BarCodeControl1.Value = "12345%SABCDE"
' 連結 QR コードで出力するシンボル番号を "0" に設定します。
BarCodeControl1.QRSymbolNumber = 0
BarCodeControl1.Save("C:\Barcode1.bmp", ImageFormat.Bmp)
' 連結 QR コードで出力するシンボル番号を "1" に設定します。
BarCodeControl1.QRSymbolNumber = 1
BarCodeControl1.Save("C:\Barcode2.bmp", ImageFormat.Bmp)

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


QREscapeCode プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..QREscapeCode プロパティ
BarCodeControl クラス 使用例 参照
QR コードのエスケープコードを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public byte QREscapeCode { get; set; }
Visual Basic (宣言)
Public Property QREscapeCode As Byte
    Get
    Set

プロパティ値

QR コードのエスケープコードを表す Byte。(既定値：0x00)

解説

Value プロパティや、ValueB プロパティに設定するバーコードデータの分割する位置に、"エスケープコード" + "S" を設定します。バーコードデータにエスケープコードと同じ文字がある場合、バーコードメッセージ側の該当する文字を二つ連続して設定してください。

このプロパティは、QRConnect プロパティの値が、QRConnect.ManualConnect の場合に有効です。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10;
// QR コード を "連結 QR コード(手動)" に設定します。
barCodeControl1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect;
// QR コードのエスケープコードを "% (0x25)" に設定します。
barCodeControl1.QREscapeCode = 0x25;
barCodeControl1.Value = "12345%SABCDE";
// 連結 QR コードで出力するシンボル番号を "1" に設定します。
barCodeControl1.QRSymbolNumber = 1;
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10
' QR コード を "連結 QR コード(手動)" に設定します。
BarCodeControl1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect
' QR コードのエスケープコードを "% (&H25)" に設定します。
BarCodeControl1.QREscapeCode = &H25
BarCodeControl1.Value = "12345%SABCDE"
' 連結 QR コードで出力するシンボル番号を "1" に設定します。
BarCodeControl1.QRSymbolNumber = 1

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


QRLevel プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..QRLevel プロパティ
BarCodeControl クラス 使用例 参照
QR コードの誤り訂正レベルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRLevel QRLevel { get; set; }
Visual Basic (宣言)
Public Property QRLevel As QRLevel
    Get
    Set

プロパティ値

QR コードの誤り訂正レベルを表す QRLevel。(既定値：QRLevel.LevelM)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードのエラー訂正レベルを "H" に設定します。
barCodeControl1.QRLevel = AdvanceSoftware.VBBarCode.QRLevel.LevelH;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードのエラー訂正レベルを "H" に設定します。
BarCodeControl1.QRLevel = AdvanceSoftware.VBBarCode.QRLevel.LevelH
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


QRMask プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..QRMask プロパティ
BarCodeControl クラス 使用例 参照
QR コードのマスクパターンを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRMask QRMask { get; set; }
Visual Basic (宣言)
Public Property QRMask As QRMask
    Get
    Set

プロパティ値

QR コードのマスクパターンを表す QRMask。(既定値：QRMask.MaskAuto)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
barCodeControl1.QRMask = AdvanceSoftware.VBBarCode.QRMask.Mask000;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
BarCodeControl1.QRMask = AdvanceSoftware.VBBarCode.QRMask.Mask000
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


QRModel プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..QRModel プロパティ
BarCodeControl クラス 使用例 参照
QR コードのモデルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRModel QRModel { get; set; }
Visual Basic (宣言)
Public Property QRModel As QRModel
    Get
    Set

プロパティ値

QR コードのモデルを表す QRModel。(既定値：QRModel.Model1)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードのモデルを "モデル 2" に設定します。
barCodeControl1.QRModel = AdvanceSoftware.VBBarCode.QRModel.Model2;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードのモデルを "モデル 2" に設定します。
BarCodeControl1.QRModel = AdvanceSoftware.VBBarCode.QRModel.Model2
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


QRSymbolNumber プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..QRSymbolNumber プロパティ
BarCodeControl クラス 使用例 参照
連結 QR コードで出力するシンボル番号を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int QRSymbolNumber { get; set; }
Visual Basic (宣言)
Public Property QRSymbolNumber As Integer
    Get
    Set

プロパティ値

連結 QR コードのシンボル番号を表す int。(既定値：0)

解説

設定範囲：0 ～ 15

このプロパティは、QRConnect プロパティの値が、QRConnect.AutoConnect、QRConnect.ManualConnect の場合に有効です。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10;
// QR コード を "連結 QR コード(手動)" に設定します。
barCodeControl1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect;
// QR コードのエスケープコードを "% (0x25)" に設定します。
barCodeControl1.QREscapeCode = 0x25;
barCodeControl1.Value = "12345%SABCDE";
// 連結 QR コードで出力するシンボル番号を "0" に設定します。
barCodeControl1.QRSymbolNumber = 0;
barCodeControl1.Save(@"C:\Barcode1.bmp", ImageFormat.Bmp);
// 連結 QR コードで出力するシンボル番号を "1" に設定します。
barCodeControl1.QRSymbolNumber = 1;
barCodeControl1.Save(@"C:\Barcode2.bmp", ImageFormat.Bmp);
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10
' QR コード を "連結 QR コード(手動)" に設定します。
BarCodeControl1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect
' QR コードのエスケープコードを "% (&H25)" に設定します。
BarCodeControl1.QREscapeCode = &H25
BarCodeControl1.Value = "12345%SABCDE"
' 連結 QR コードで出力するシンボル番号を "0" に設定します。
BarCodeControl1.QRSymbolNumber = 0
BarCodeControl1.Save("C:\Barcode1.bmp", ImageFormat.Bmp)
' 連結 QR コードで出力するシンボル番号を "1" に設定します。
BarCodeControl1.QRSymbolNumber = 1
BarCodeControl1.Save("C:\Barcode2.bmp", ImageFormat.Bmp)

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


QRVersion プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..QRVersion プロパティ
BarCodeControl クラス 使用例 参照
QR コードの型番を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRVersion QRVersion { get; set; }
Visual Basic (宣言)
Public Property QRVersion As QRVersion
    Get
    Set

プロパティ値

QR コードの型番を表す QRVersion。(既定値：QRVersion.VersionAuto)

解説

プロパティ値が QRVersion.VersionAuto の場合、QR コードの型番は自動で設定されます。

QRModel プロパティの値により、QRVersion.VersionAuto 以外の設定範囲が異なります。

設定範囲(QRModel1)：QRVersion.QRVersion1 ～ QRVersion14

設定範囲(QRModel2)：QRVersion.QRVersion1 ～ QRVersion40

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


Quiet プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Quiet プロパティ
BarCodeControl クラス 使用例 参照
余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金代理収納 GS1-128)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double Quiet { get; set; }
Visual Basic (宣言)
Public Property Quiet As Double
    Get
    Set

解説

プロパティ値が 0 の場合、バーコードの余白は自動で設定されます。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードイメージの余白幅を "2.5mm" に設定します。
barCodeControl1.Quiet = 2.5;
barCodeControl1.Value = "1234567890";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードイメージの余白幅を "2.5mm" に設定します。
BarCodeControl1.Quiet = 2.5
BarCodeControl1.Value = "1234567890"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


RePaint プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..RePaint プロパティ
BarCodeControl クラス 使用例 参照
プロパティ変更時の再描画を行うかどうかを設定します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool RePaint { set; }
Visual Basic (宣言)
Public WriteOnly Property RePaint As Boolean
    Set

プロパティ値

プロパティ変更時に再描画を行うかを表す bool。(既定値：true)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
// プロパティ変更時に再描画を行わないように設定します。
barCodeControl1.RePaint = false;
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
' プロパティ変更時に再描画を行わないように設定します。
BarCodeControl1.RePaint = False
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


Rotate プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Rotate プロパティ
BarCodeControl クラス 使用例 参照
バーコードの回転方向を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Rotate Rotate { get; set; }
Visual Basic (宣言)
Public Property Rotate As Rotate
    Get
    Set

プロパティ値

バーコードの回転方向を表す Rotate。(既定値：Rotate.Rotate0)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの向きを "時計回りで 90 度回転" に設定します。
barCodeControl1.Rotate = AdvanceSoftware.VBBarCode.Rotate.Rotate90;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの向きを "時計回りで 90 度回転" に設定します。
BarCodeControl1.Rotate = AdvanceSoftware.VBBarCode.Rotate.Rotate90
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


ShowBearer プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..ShowBearer プロパティ
BarCodeControl クラス 使用例 参照
ベアラバーを表示するかを設定、取得します。(ITF)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool ShowBearer { get; set; }
Visual Basic (宣言)
Public Property ShowBearer As Boolean
    Get
    Set

プロパティ値

ベアラバーの表示モードを表す bool。(既定値：true)

解説

プロパティ値が true の場合、ベアラバーを表示します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.ITF16;
// ITF16 のベアラバーを "表示しない" に設定します。
barCodeControl1.ShowBearer = false;
barCodeControl1.Value = "1234567890123456";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.ITF16
' ITF16 のベアラバーを "表示しない" に設定します。
BarCodeControl1.ShowBearer = False
BarCodeControl1.Value = "1234567890123456"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


ShowMessage プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..ShowMessage プロパティ
BarCodeControl クラス 使用例 参照
バーコードメッセージを表示するかを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool ShowMessage { get; set; }
Visual Basic (宣言)
Public Property ShowMessage As Boolean
    Get
    Set

プロパティ値

バーコードメッセージの表示モードを表す bool。(既定値：true)

解説

プロパティ値が true の場合、バーコードメッセージを表示します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードメッセージを "表示しない" に設定します。
barCodeControl1.ShowMessage = false;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードメッセージを "表示しない" に設定します。
BarCodeControl1.ShowMessage = False
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


StartChar プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..StartChar プロパティ
BarCodeControl クラス 使用例 参照
スタートキャラクタを設定、取得します。(Codabar)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public char StartChar { get; set; }
Visual Basic (宣言)
Public Property StartChar As Char
    Get
    Set

プロパティ値

スタートキャラクタを表す char。(既定値：'a')

解説

設定可能な値：'a'、'b'、'c'、'd'、't'、'n'、'*'、'e'、'A'、'B'、'C'、'D'

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// Codabar のスタートキャラクタを "c" に設定します。
barCodeControl1.StartChar = 'c';
barCodeControl1.Value = "1234567890";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' Codabar のスタートキャラクタを "c" に設定します。
BarCodeControl1.StartChar = "c"
BarCodeControl1.Value = "1234567890"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


StopChar プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..StopChar プロパティ
BarCodeControl クラス 使用例 参照
ストップキャラクタを設定、取得します。(Codabar)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public char StopChar { get; set; }
Visual Basic (宣言)
Public Property StopChar As Char
    Get
    Set

プロパティ値

ストップキャラクタを表す char。(既定値：'a')

解説

設定可能な値：'a'、'b'、'c'、'd'、't'、'n'、'*'、'e'、'A'、'B'、'C'、'D'

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// Codabar のストップキャラクタを "c" に設定します。
barCodeControl1.StopChar = 'c';
barCodeControl1.Value = "1234567890";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' Codabar のストップキャラクタを "c" に設定します。
BarCodeControl1.StopChar = "c"
BarCodeControl1.Value = "1234567890"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


TextRenderingHint プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..TextRenderingHint プロパティ
BarCodeControl クラス 使用例 参照
バーコードキャラクタのテキストレンダリングの品質を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public TextRenderingHint TextRenderingHint { get; set; }
Visual Basic (宣言)
Public Property TextRenderingHint As TextRenderingHint
    Get
    Set

プロパティ値

バーコードキャラクタのテキストレンダリングを表す TextRenderingHint。(既定値：TextRenderingHint.SystemDefault)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードメッセージのテキストレンダリングの品質を "SingleBitPerPixel" に設定します。
barCodeControl1.TextRenderingHint = System.Drawing.Text.TextRenderingHint.SingleBitPerPixel;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードメッセージのテキストレンダリングの品質を "SingleBitPerPixel" に設定します。
BarCodeControl1.TextRenderingHint = System.Drawing.Text.TextRenderingHint.SingleBitPerPixel
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


Type プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Type プロパティ
BarCodeControl クラス 使用例 参照
バーコードの種類を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public BarCodeType Type { get; set; }
Visual Basic (宣言)
Public Property Type As BarCodeType
    Get
    Set

プロパティ値

バーコードのタイプを表す BarCodeType。(既定値：BarCodeType.JAN13)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
// 生成するバーコードイメージを "JAN13" に設定します。
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
' 生成するバーコードイメージを "JAN13" に設定します。
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


Unit プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Unit プロパティ
BarCodeControl クラス 使用例 参照
バーコードの生成単位を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Unit Unit { get; set; }
Visual Basic (宣言)
Public Property Unit As Unit
    Get
    Set

プロパティ値

バーコードの生成単位を表す Unit。(既定値：Unit.Pixel)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


Value プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Value プロパティ
BarCodeControl クラス 使用例 参照
バーコードデータを設定、取得します。(文字列)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public string Value { get; set; }
Visual Basic (宣言)
Public Property Value As String
    Get
    Set

プロパティ値

バーコードデータを表す string。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードデータを設定します。 (文字列)
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードデータを設定します。 (文字列)
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


WhiteBarRevision プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..WhiteBarRevision プロパティ
BarCodeControl クラス 使用例 参照
白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int WhiteBarRevision { get; set; }
Visual Basic (宣言)
Public Property WhiteBarRevision As Integer
    Get
    Set

プロパティ値

白バーのドット補正値を表す int。(既定値：0)

解説

Unit プロパティの値が、Unit.Pixel の場合、有効になります。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 白バーのドット補正値を "+2" に設定します。
barCodeControl1.WhiteBarRevision = 2;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 白バーのドット補正値を "+2" に設定します。
BarCodeControl1.WhiteBarRevision = 2
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


Zoom プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Zoom プロパティ
BarCodeControl クラス 使用例 参照
倍率を設定、取得します。(JAN、UPC、ITF)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int Zoom { get; set; }
Visual Basic (宣言)
Public Property Zoom As Integer
    Get
    Set

プロパティ値

バーコードの倍率を表す int。(既定値：100)

解説

設定範囲(JAN、UPC)：50 ～ 200

設定範囲(ITF)：25 ～ 120

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの表示倍率を "200%" に設定します。
barCodeControl1.Zoom = 200;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの表示倍率を "200%" に設定します。
BarCodeControl1.Zoom = 200
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


BarCodeControl イベント

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeControl イベント
BarCodeControl クラス 参照

BarCodeControl データ型で公開されるメンバを以下に示します。

イベント

 | 名前 | 説明
Public event | Error | バーコードの作成に失敗した時に発生します。

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


Error イベント

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Error イベント
BarCodeControl クラス 使用例 参照
バーコードの作成に失敗した時に発生します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public event BarCodeErrorEventHandler Error
Visual Basic (宣言)
Public Event Error As BarCodeErrorEventHandler

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
private AdvanceSoftware.VBBarCode.BarCodeControl barCodeControl1 = new AdvanceSoftware.VBBarCode.BarCodeControl();
private void InitializeComponent()
{
    // バーコードクラスのエラーイベントに barCode1_Error メソッドを関連付け
    this.barCodeControl1.Error += new AdvanceSoftware.VBBarCode.BarCodeControl.BarCodeErrorEventHandler(barCodeControl1_Error);
}
// バーコードクラスのエラーイベント
private void barCodeControl1_Error(object sender, AdvanceSoftware.VBBarCode.BarCodeControl.BarCodeErrorEventArgs e)
{
    MessageBox.Show(barCodeControl1.ErrorMessage);
}
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成 (WithEvents)
Private WithEvents BarCodeControl1 As AdvanceSoftware.VBBarCode.BarCodeControl = New AdvanceSoftware.VBBarCode.BarCodeControl()
' バーコードクラスのエラーイベント
Private Sub BarCodeControl1_Error(ByVal sender As Object, ByVal e As AdvanceSoftware.VBBarCode.BarCodeControl.BarCodeErrorEventArgs) Handles BarCodeControl1.Error
    MessageBox.Show(BarCodeControl1.ErrorMessage)
End Sub

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode 名前空間


BarCodeErrorEventArgs クラス

[image]

VB-BarCode 5.0 for .NET
BarCodeErrorEventArgs クラス
メンバ 参照
BarCode クラスの Error イベントのデータを提供します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public class BarCodeErrorEventArgs : EventArgs
Visual Basic (宣言)
Public Class BarCodeErrorEventArgs _
    Inherits EventArgs

継承階層

System..::..Object
System..::..EventArgs
AdvanceSoftware.VBBarCode..::..BarCodeErrorEventArgs

参照

BarCodeErrorEventArgs メンバ
AdvanceSoftware.VBBarCode 名前空間


BarCodeErrorEventArgs メンバ

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeErrorEventArgs メンバ
BarCodeErrorEventArgs クラス コンストラクタ プロパティ 参照

BarCodeErrorEventArgs データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | BarCodeErrorEventArgs | 新しい BarCode クラスの Error イベントを初期化します。

プロパティ

 | 名前 | 説明
Public property | ErrorNo | エラーナンバーを処理します。(内部使用のみ。)

参照

BarCodeErrorEventArgs クラス
AdvanceSoftware.VBBarCode 名前空間


BarCodeErrorEventArgs コンストラクタ

[image]

VB-BarCode 5.0 for .NET
BarCodeErrorEventArgs コンストラクタ
BarCodeErrorEventArgs クラス 参照
新しい BarCode クラスの Error イベントを初期化します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public BarCodeErrorEventArgs(
    ErrorNo errorNo
)
Visual Basic (宣言)
Public Sub New ( _
    errorNo As ErrorNo _
)

パラメータ

errorNo
Type: AdvanceSoftware.VBBarCode..::..ErrorNo
ErrorNo を指定します。

参照

BarCodeErrorEventArgs クラス
AdvanceSoftware.VBBarCode 名前空間


BarCodeErrorEventArgs プロパティ

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeErrorEventArgs プロパティ
BarCodeErrorEventArgs クラス 参照

BarCodeErrorEventArgs データ型で公開されるメンバを以下に示します。

プロパティ

 | 名前 | 説明
Public property | ErrorNo | エラーナンバーを処理します。(内部使用のみ。)

参照

BarCodeErrorEventArgs クラス
AdvanceSoftware.VBBarCode 名前空間


ErrorNo プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeErrorEventArgs..::..ErrorNo プロパティ
BarCodeErrorEventArgs クラス 参照
エラーナンバーを処理します。(内部使用のみ。)

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public ErrorNo ErrorNo { get; }
Visual Basic (宣言)
Public ReadOnly Property ErrorNo As ErrorNo
    Get

参照

BarCodeErrorEventArgs クラス
AdvanceSoftware.VBBarCode 名前空間


BarCodeErrorEventHandler デリゲート

[image]

VB-BarCode 5.0 for .NET
BarCodeErrorEventHandler デリゲート
参照
BarCode クラスの Error イベントを処理するメソッドを表します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public delegate void BarCodeErrorEventHandler(
    Object sender,
    BarCodeErrorEventArgs e
)
Visual Basic (宣言)
Public Delegate Sub BarCodeErrorEventHandler ( _
    sender As Object, _
    e As BarCodeErrorEventArgs _
)

パラメータ

sender
Type: System..::..Object
e
Type: AdvanceSoftware.VBBarCode..::..BarCodeErrorEventArgs

参照

AdvanceSoftware.VBBarCode 名前空間


BarCodeSize 構造体

[image]

VB-BarCode 5.0 for .NET
BarCodeSize 構造体
メンバ 参照
BarCodeSize 構造体

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public struct BarCodeSize
Visual Basic (宣言)
Public Structure BarCodeSize

参照

BarCodeSize メンバ
AdvanceSoftware.VBBarCode 名前空間


BarCodeSize メンバ

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeSize メンバ
BarCodeSize 構造体 コンストラクタ フィールド 参照

BarCodeSize データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | BarCodeSize | コンストラクタ

フィールド

 | 名前 | 説明
Public field | Height | 高さ
Public field | Width | 幅

参照

BarCodeSize 構造体
AdvanceSoftware.VBBarCode 名前空間


BarCodeSize コンストラクタ

[image]

VB-BarCode 5.0 for .NET
BarCodeSize コンストラクタ
BarCodeSize 構造体 参照
コンストラクタ

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public BarCodeSize(
    int w,
    int h
)
Visual Basic (宣言)
Public Sub New ( _
    w As Integer, _
    h As Integer _
)

パラメータ

w
Type: System..::..Int32
幅。
h
Type: System..::..Int32
高さ。

参照

BarCodeSize 構造体
AdvanceSoftware.VBBarCode 名前空間


BarCodeSize フィールド

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeSize フィールド
BarCodeSize 構造体 参照

BarCodeSize データ型で公開されるメンバを以下に示します。

フィールド

 | 名前 | 説明
Public field | Height | 高さ
Public field | Width | 幅

参照

BarCodeSize 構造体
AdvanceSoftware.VBBarCode 名前空間


Height フィールド

[image]

VB-BarCode 5.0 for .NET
BarCodeSize..::..Height フィールド
BarCodeSize 構造体 参照
高さ

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int Height
Visual Basic (宣言)
Public Height As Integer

参照

BarCodeSize 構造体
AdvanceSoftware.VBBarCode 名前空間


Width フィールド

[image]

VB-BarCode 5.0 for .NET
BarCodeSize..::..Width フィールド
BarCodeSize 構造体 参照
幅

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int Width
Visual Basic (宣言)
Public Width As Integer

参照

BarCodeSize 構造体
AdvanceSoftware.VBBarCode 名前空間


BarCodeSizeD 構造体

[image]

VB-BarCode 5.0 for .NET
BarCodeSizeD 構造体
メンバ 参照
BarCodeSizeD 構造体

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public struct BarCodeSizeD
Visual Basic (宣言)
Public Structure BarCodeSizeD

参照

BarCodeSizeD メンバ
AdvanceSoftware.VBBarCode 名前空間


BarCodeSizeD メンバ

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeSizeD メンバ
BarCodeSizeD 構造体 コンストラクタ フィールド 参照

BarCodeSizeD データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | BarCodeSizeD | コンストラクタ

フィールド

 | 名前 | 説明
Public field | Height | 高さ
Public field | Width | 幅

参照

BarCodeSizeD 構造体
AdvanceSoftware.VBBarCode 名前空間


BarCodeSizeD コンストラクタ

[image]

VB-BarCode 5.0 for .NET
BarCodeSizeD コンストラクタ
BarCodeSizeD 構造体 参照
コンストラクタ

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public BarCodeSizeD(
    double w,
    double h
)
Visual Basic (宣言)
Public Sub New ( _
    w As Double, _
    h As Double _
)

パラメータ

w
Type: System..::..Double
幅。
h
Type: System..::..Double
高さ。

参照

BarCodeSizeD 構造体
AdvanceSoftware.VBBarCode 名前空間


BarCodeSizeD フィールド

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeSizeD フィールド
BarCodeSizeD 構造体 参照

BarCodeSizeD データ型で公開されるメンバを以下に示します。

フィールド

 | 名前 | 説明
Public field | Height | 高さ
Public field | Width | 幅

参照

BarCodeSizeD 構造体
AdvanceSoftware.VBBarCode 名前空間


Height フィールド

[image]

VB-BarCode 5.0 for .NET
BarCodeSizeD..::..Height フィールド
BarCodeSizeD 構造体 参照
高さ

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double Height
Visual Basic (宣言)
Public Height As Double

参照

BarCodeSizeD 構造体
AdvanceSoftware.VBBarCode 名前空間


Width フィールド

[image]

VB-BarCode 5.0 for .NET
BarCodeSizeD..::..Width フィールド
BarCodeSizeD 構造体 参照
幅

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double Width
Visual Basic (宣言)
Public Width As Double

参照

BarCodeSizeD 構造体
AdvanceSoftware.VBBarCode 名前空間


BarCodeType 列挙体

[image]

VB-BarCode 5.0 for .NET
BarCodeType 列挙体
参照
バーコードの種類を指定します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public enum BarCodeType
Visual Basic (宣言)
Public Enumeration BarCodeType

メンバ

メンバ名 | 説明
JAN13 | JAN コード(標準バージョン 13 桁)
JAN8 | JAN コード(短縮バージョン 8 桁)
UPCA | UPC コード(A バージョン)
UPCE | UPC コード(E バージョン)
ITF6 | ITF コード(アドオンバージョン 6 桁)
ITF14 | ITF コード(標準バージョン 14 桁)
ITF16 | ITF コード(拡張バージョン 16 桁)
ITF | ITF コード(自由桁)
Codabar | NW-7(Codabar)
Code39 | コード39
Code128 | コード128
GS1 | GS1-128(旧：UCC/EAN128)
GS1Fixed | 公共料金代理収納 GS1-128
CustomerBarCode | 郵便カスタマバーコード
QRCode | QR コード
PDF417 | PDF417

参照

AdvanceSoftware.VBBarCode 名前空間


CheckPattern 列挙体

[image]

VB-BarCode 5.0 for .NET
CheckPattern 列挙体
参照
チェックデジットの計算方法を指定します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public enum CheckPattern
Visual Basic (宣言)
Public Enumeration CheckPattern

メンバ

メンバ名 | 説明
Modulus16 | モジュラス 16
Modulus10Weight2 | モジュラス 10 / ウェイト 2
Modulus10Weight3 | モジュラス 10 / ウェイト 3
Modulus11 | モジュラス 11
Modulus11Weight | 加重モジュラス 11
SevenCheckDR | 7 チェック DR
Runes | ルーンズ

参照

AdvanceSoftware.VBBarCode 名前空間


Codeset 列挙体

[image]

VB-BarCode 5.0 for .NET
Codeset 列挙体
参照
スタートコードセットを指定します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public enum Codeset
Visual Basic (宣言)
Public Enumeration Codeset

メンバ

メンバ名 | 説明
Auto | 自動でコードセットを設定
CodesetA | コードセット A
CodesetB | コードセット B
CodesetC | コードセット C

参照

AdvanceSoftware.VBBarCode 名前空間


ErrorNo 列挙体

[image]

VB-BarCode 5.0 for .NET
ErrorNo 列挙体
参照
エラーナンバーを示す識別子を指定します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public enum ErrorNo
Visual Basic (宣言)
Public Enumeration ErrorNo

メンバ

メンバ名 | 説明
NoError | エラーなし
Type | Type の設定に失敗しました。
Unit | Unit の設定に失敗しました。
Zoom | Zoom の設定に失敗しました。
Point | Point の設定に失敗しました。
Rotate | Rotate の設定に失敗しました。
DpiX | DpiX の設定に失敗しました。
DpiY | DpiY の設定に失敗しました。
BlackRatio | BlackRatio の設定に失敗しました。
BarHeight | BarHeight の設定に失敗しました。
BarWidth | BarWidth の設定に失敗しました。
Element | Element の設定に失敗しました。
Quiet | Quiet の設定に失敗しました。
BarRatio | BarRatio の設定に失敗しました。
CharGap | CharGap の設定に失敗しました。
CharSize | CharSize の設定に失敗しました。
CheckPattern | CheckPattern の設定に失敗しました。
CodeSet | CodeSet の設定に失敗しました。
Value | Value の設定に失敗しました。
CheckDigit | CheckDigit の設定に失敗しました。
QRModel | QRModel の設定に失敗しました。
QRVersion | QRVersion の設定に失敗しました。
QRLevel | QRLevel の設定に失敗しました。
QRConnectAct | 連結モードが間違っています。
QRConnect | QRConnect の設定に失敗しました。
QRSourceIsEmpty | データが空です。
QRSourceIsLarge | データが長すぎます。
QRConnectPos | 連結番号が違います。
QREscSeq | エスケープシーケンスが違います。
QRECIAssin | ECI 割り当て番号が違います。
QRKanji | 漢字コードが違います。
QRNumChar | 数字モードに適合しない文字が含まれています。
QRAnkChar | 英数字モードに適合しない文字が含まれています。
QRByteChar | バイトモードに適合しない文字が含まれています。
QRKanjiChar | 漢字モードに適合しない文字が含まれています。
QRSymbolOver | シンボルデータ領域を超えました。
QRConnectMode | 連結動作 2 以外で連結モードが設定されています。
QRTooManySymbol | 連結シンボル数が 16 を超えました。
QRMask | QRMask の設定に失敗しました。
PDFModel | PDFModel の設定に失敗しました。
PDFColumn | PDFColumn の設定に失敗しました。
PDFRow | PDFRow の設定に失敗しました。
PDFLevel | PDFLevel の設定に失敗しました。
PDFAspectRatio | 縦横比が違います。
PDFSourceIsEmpty | データが空です。
PDFSourceIsLarge | データが長すぎます。
PDFGLIValue | GLI 値が違います。
PDFNumChar | 数字モードに適合しない文字が含まれています。
PDFTextChar | テキストモードに適合しない文字が含まれています。
PDFByteChar | バイトモードに適合しない文字が含まれています。
PDFSymbolOver | シンボルデータ領域を超えました。

参照

AdvanceSoftware.VBBarCode 名前空間


MessageAlign 列挙体

[image]

VB-BarCode 5.0 for .NET
MessageAlign 列挙体
参照
バーコードメッセージの表示横位置を指定します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public enum MessageAlign
Visual Basic (宣言)
Public Enumeration MessageAlign

メンバ

メンバ名 | 説明
Left | 左詰め
Center | 中央揃え

参照

AdvanceSoftware.VBBarCode 名前空間


PDFModel 列挙体

[image]

VB-BarCode 5.0 for .NET
PDFModel 列挙体
参照
PDF417 シンボルを指定します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public enum PDFModel
Visual Basic (宣言)
Public Enumeration PDFModel

メンバ

メンバ名 | 説明
Default | 標準の PDF417
Truncated | 簡易 PDF417

参照

AdvanceSoftware.VBBarCode 名前空間


QRConnect 列挙体

[image]

VB-BarCode 5.0 for .NET
QRConnect 列挙体
参照
QRコードの連結モードを指定します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public enum QRConnect
Visual Basic (宣言)
Public Enumeration QRConnect

メンバ

メンバ名 | 説明
NotConnect | 連結 QR コードを作成しない
AutoConnect | 連結QRコードを作成(自動)
ManualConnect | 連結 QR コードを作成(手動)

参照

AdvanceSoftware.VBBarCode 名前空間


QRLevel 列挙体

[image]

VB-BarCode 5.0 for .NET
QRLevel 列挙体
参照
QR コードの誤り訂正レベルを指定します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public enum QRLevel
Visual Basic (宣言)
Public Enumeration QRLevel

メンバ

メンバ名 | 説明
LevelL | L(復元率 7%)
LevelM | M(復元率 15%)
LevelQ | Q(復元率 25%)
LevelH | H(復元率 30%)

参照

AdvanceSoftware.VBBarCode 名前空間


QRMask 列挙体

[image]

VB-BarCode 5.0 for .NET
QRMask 列挙体
参照
QR コードのマスクパターンを指定します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public enum QRMask
Visual Basic (宣言)
Public Enumeration QRMask

メンバ

メンバ名 | 説明
MaskAuto | 自動でマスク処理を行う
Mask000 | マスクパターン参照子 000
Mask001 | マスクパターン参照子 001
Mask010 | マスクパターン参照子 010
Mask011 | マスクパターン参照子 011
Mask100 | マスクパターン参照子 100
Mask101 | マスクパターン参照子 101
Mask110 | マスクパターン参照子 110
Mask111 | マスクパターン参照子 111

参照

AdvanceSoftware.VBBarCode 名前空間


QRModel 列挙体

[image]

VB-BarCode 5.0 for .NET
QRModel 列挙体
参照
QR コードのモデルを指定します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public enum QRModel
Visual Basic (宣言)
Public Enumeration QRModel

メンバ

メンバ名 | 説明
Model1 | モデル 1
Model2 | モデル 2

参照

AdvanceSoftware.VBBarCode 名前空間


QRVersion 列挙体

[image]

VB-BarCode 5.0 for .NET
QRVersion 列挙体
参照
QR コードの型番を指定します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public enum QRVersion
Visual Basic (宣言)
Public Enumeration QRVersion

メンバ

メンバ名 | 説明
VersionAuto | 自動で型番を設定
Version1 | 1 型
Version2 | 2 型
Version3 | 3 型
Version4 | 4 型
Version5 | 5 型
Version6 | 6 型
Version7 | 7 型
Version8 | 8 型
Version9 | 9 型
Version10 | 10 型
Version11 | 11 型
Version12 | 12 型
Version13 | 13 型
Version14 | 14 型
Version15 | 15 型
Version16 | 16 型
Version17 | 17 型
Version18 | 18 型
Version19 | 19 型
Version20 | 20 型
Version21 | 21 型
Version22 | 22 型
Version23 | 23 型
Version24 | 24 型
Version25 | 25 型
Version26 | 26 型
Version27 | 27 型
Version28 | 28 型
Version29 | 29 型
Version30 | 30 型
Version31 | 31 型
Version32 | 32 型
Version33 | 33 型
Version34 | 34 型
Version35 | 35 型
Version36 | 36 型
Version37 | 37 型
Version38 | 38 型
Version39 | 39 型
Version40 | 40 型

参照

AdvanceSoftware.VBBarCode 名前空間


Rotate 列挙体

[image]

VB-BarCode 5.0 for .NET
Rotate 列挙体
参照
バーコードの回転方向を指定します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public enum Rotate
Visual Basic (宣言)
Public Enumeration Rotate

メンバ

メンバ名 | 説明
Rotate0 | 0 度
Rotate90 | 90 度
Rotate180 | 180 度
Rotate270 | 270 度

参照

AdvanceSoftware.VBBarCode 名前空間


Unit 列挙体

[image]

VB-BarCode 5.0 for .NET
Unit 列挙体
参照
バーコードの生成単位を指定します。

名前空間: AdvanceSoftware.VBBarCode
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)
VBBarCode.BarCode.v5 (VBBarCode.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public enum Unit
Visual Basic (宣言)
Public Enumeration Unit

メンバ

メンバ名 | 説明
Pixel | ピクセル
Millimeter | ミリ
Inch | インチ
Point | ポイント

参照

AdvanceSoftware.VBBarCode 名前空間


AdvanceSoftware.VBBarCode.Wpf 名前空間

[image]

VB-BarCode 5.0 for .NET
AdvanceSoftware.VBBarCode.Wpf 名前空間
AdvanceSoftware.VBBarCode.Wpf 名前空間には、WPFBarCode コンポーネントが含まれています。

クラス

 | クラス | 説明
Public class | BarCode | BarCode クラス
Public class | BarCodeControl | BarCodeControl クラス


BarCode クラス

[image]

VB-BarCode 5.0 for .NET
BarCode クラス
メンバ 参照
BarCode クラス

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public class BarCode
Visual Basic (宣言)
Public Class BarCode

継承階層

System..::..Object
AdvanceSoftware.VBBarCode.Wpf..::..BarCode

参照

BarCode メンバ
AdvanceSoftware.VBBarCode.Wpf 名前空間


BarCode メンバ

[image] [image]

VB-BarCode 5.0 for .NET
BarCode メンバ
BarCode クラス コンストラクタ メソッド プロパティ イベント 参照

BarCode データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | BarCode | コンストラクタ

メソッド

 | 名前 | 説明
Public method | GetBarCodeImage | バーコードのビットマップイメージを作成します。
Public method | GetScaleSize | 指定した単位でバーコードのサイズを取得します。
Public method | Save(Stream) | バーコードのイメージをビットマップ形式で保存します。
Public method | Save(String) | バーコードのイメージをビットマップ形式で保存します。
Public method | SaveSvg(Stream) | バーコードの SVG イメージを保存します。
Public method | SaveSvg(String) | バーコードの SVG イメージを保存します。
Public method | SaveSvgz(Stream) | バーコードの圧縮 SVG イメージを保存します。
Public method | SaveSvgz(String) | バーコードの圧縮 SVG イメージを保存します。

プロパティ

 | 名前 | 説明
Public property | _Type | バーコードの種類を設定、取得します。
Public property | _Unit | バーコードの生成単位を設定、取得します。
Public property | BackColor | バーコードシンボルの背景色を設定、取得します。
Public property | BarColor | バーの色を設定、取得します。
Public property | BarHeight | バーコードの高さを設定、取得します。
Public property | BarRatio | 太バーのエレメント率を設定、取得します。(Codabar、Code39)
Public property | BarWidth | バーコードの幅を設定、取得します。
Public property | BinaryValue | バーコードデータを設定、取得します。(バイナリ)
Public property | BlackBarRevision | 黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
Public property | BlackRatio | 黒バーの太さの比率を設定、取得します。
Public property | CharGap | キャラクタ間のギャップを設定、取得します。(Codabar、Code39)
Public property | CharSize | バーコードキャラクタのフォントサイズを設定、取得します。
Public property | CheckCharMode | 自動でチェックキャラクタを付加するかを設定、取得します。
Public property | CheckPattern | チェックデジットの計算方法を設定、取得します。(Codabar)
Public property | Codeset | スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))
Public property | DpiX | X 軸方向の解像度を設定、取得します。(ピクセル単位)
Public property | DpiY | Y 軸方向の解像度を設定、取得します。(ピクセル単位)
Public property | Element | 最小エレメント値を設定、取得します。
Public property | ErrorMessage | エラーメッセージを取得します。
Public property | ErrorNo | エラーナンバーを取得します。
Public property | FlatHeight | ガードバーの均等化を設定、取得します。(JAN、UPC)
Public property | Font | バーコードメッセージのフォント名を設定、取得します。
Public property | FontStyle | バーコードキャラクタのフォントスタイルを設定、取得します。
Public property | FontWeight | バーコードメッセージのフォントウエイトを設定、取得します。
Public property | InternalQRVersion | QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。
Public property | InternalValue | 整形後のバーコードデータを取得します。
Public property | MessageAlign | バーコードメッセージの表示横位置を設定、取得します。(GS1Fixed)
Public property | PDFColumn | PDF417 の列数を設定、取得します。
Public property | PDFInitialSymbol | PDF417 の初期化シンボルを設定、取得します。
Public property | PDFLevel | PDF417 のエラー訂正レベルを設定、取得します。
Public property | PDFModel | PDF417 シンボルを設定、取得します。
Public property | PDFRatio | PDF417 の 1 モジュールの縦横比を設定、取得します。
Public property | PDFRow | PDF417 の行数を設定、取得します。
Public property | Point | ポイントを設定、取得します。(郵便カスタマバーコード)
Public property | QRConnect | 連結 QR コードを作成するかを設定、取得します。
Public property | QREscapeCode | QR コードのエスケープコードを設定、取得します。
Public property | QRLevel | QR コードの誤り訂正レベルを設定、取得します。
Public property | QRMask | QR コードのマスクパターンを設定、取得します。
Public property | QRModel | QR コードのモデルを設定、取得します。
Public property | QRSymbolNumber | 連結 QR コードで出力するシンボル番号を設定、取得します。
Public property | QRVersion | QR コードの型番を設定、取得します。
Public property | Quiet | 余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金代理収納 GS1-128)
Public property | Rotate | バーコードの回転方向を設定、取得します。
Public property | ShowBearer | ベアラバーを表示するかを設定、取得します。(ITF)
Public property | ShowMessage | バーコードメッセージを表示するかを設定、取得します。
Public property | StartChar | スタートキャラクタを設定、取得します。(Codabar)
Public property | StopChar | ストップキャラクタを設定、取得します。(Codabar)
Public property | Type | バーコードの種類を設定、取得します。
Public property | Unit | バーコードの生成単位を設定、取得します。
Public property | Value | バーコードデータを設定、取得します。(文字列)
Public property | WhiteBarRevision | 白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
Public property | Zoom | 倍率を設定、取得します。(JAN、UPC、ITF)

イベント

 | 名前 | 説明
Public event | Error | バーコードの作成に失敗した時に発生します。

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BarCode コンストラクタ

[image]

VB-BarCode 5.0 for .NET
BarCode コンストラクタ
BarCode クラス 参照
コンストラクタ

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public BarCode()
Visual Basic (宣言)
Public Sub New

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BarCode メソッド

[image] [image]

VB-BarCode 5.0 for .NET
BarCode メソッド
BarCode クラス 参照

BarCode データ型で公開されるメンバを以下に示します。

メソッド

 | 名前 | 説明
Public method | GetBarCodeImage | バーコードのビットマップイメージを作成します。
Public method | GetScaleSize | 指定した単位でバーコードのサイズを取得します。
Public method | Save(Stream) | バーコードのイメージをビットマップ形式で保存します。
Public method | Save(String) | バーコードのイメージをビットマップ形式で保存します。
Public method | SaveSvg(Stream) | バーコードの SVG イメージを保存します。
Public method | SaveSvg(String) | バーコードの SVG イメージを保存します。
Public method | SaveSvgz(Stream) | バーコードの圧縮 SVG イメージを保存します。
Public method | SaveSvgz(String) | バーコードの圧縮 SVG イメージを保存します。

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


GetBarCodeImage メソッド

[image]

VB-BarCode 5.0 for .NET
BarCode..::..GetBarCodeImage メソッド
BarCode クラス 使用例 参照
バーコードのビットマップイメージを作成します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public ImageSource GetBarCodeImage()
Visual Basic (宣言)
Public Function GetBarCodeImage As ImageSource

戻り値

このメソッドが作成する BitmapSource。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// バーコードイメージを生成します。
ImageSource imgBarCode = barCode1.GetBarCodeImage();
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' バーコードイメージを生成します。
Dim imgBarCode As ImageSource = BarCode1.GetBarCodeImage()

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


GetScaleSize メソッド

[image]

VB-BarCode 5.0 for .NET
BarCode..::..GetScaleSize メソッド
BarCode クラス 使用例 参照
指定した単位でバーコードのサイズを取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public BarCodeSizeD GetScaleSize(
    Unit unit
)
Visual Basic (宣言)
Public Function GetScaleSize ( _
    unit As Unit _
) As BarCodeSizeD

パラメータ

unit
Type: AdvanceSoftware.VBBarCode..::..Unit
取得するサイズの単位を表す Unit 列挙体。

戻り値

バーコードのサイズ。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
AdvanceSoftware.VBBarCode.BarCodeSizeD barCodeSizeD;
// バーコードイメージのサイズを ミリ(mm) 単位で取得します。
barCodeSizeD = barCode1.GetScaleSize(AdvanceSoftware.VBBarCode.Unit.Millimeter);
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
Dim BarCodeSizeD As AdvanceSoftware.VBBarCode.BarCodeSizeD
' バーコードイメージのサイズを ミリ(mm) 単位で取得します。
BarCodeSizeD = BarCode1.GetScaleSize(AdvanceSoftware.VBBarCode.Unit.Millimeter)

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Save メソッド

[image] [image]

VB-BarCode 5.0 for .NET
BarCode..::..Save メソッド
BarCode クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | Save(Stream) | バーコードのイメージをビットマップ形式で保存します。
Public method | Save(String) | バーコードのイメージをビットマップ形式で保存します。

参照

BarCode クラス
BarCode メンバ
AdvanceSoftware.VBBarCode.Wpf 名前空間


Save メソッド (Stream)

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Save メソッド (Stream)
BarCode クラス 使用例 参照
バーコードのイメージをビットマップ形式で保存します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool Save(
    Stream stream
)
Visual Basic (宣言)
Public Function Save ( _
    stream As Stream _
) As Boolean

パラメータ

stream
Type: System.IO..::..Stream
イメージが保存される Stream。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// バーコードイメージを保存します。
FileStream fileStream = new FileStream(@"C:\BarCode.bmp", FileMode.Create);
barCode1.Save(fileStream);
fileStream.Close();
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' バーコードイメージを保存します。
Dim FileStream As FileStream = New FileStream("C:\BarCode.bmp", FileMode.Create)
BarCode1.Save(FileStream)
FileStream.Close()

参照

BarCode クラス
Save オーバーロード
AdvanceSoftware.VBBarCode.Wpf 名前空間


Save メソッド (String)

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Save メソッド (String)
BarCode クラス 使用例 参照
バーコードのイメージをビットマップ形式で保存します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool Save(
    string fileName
)
Visual Basic (宣言)
Public Function Save ( _
    fileName As String _
) As Boolean

パラメータ

fileName
Type: System..::..String
バーコードイメージの保存先ファイル名を格納している文字列。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// バーコードイメージを保存します。
barCode1.Save(@"C:\BarCode.bmp");
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' バーコードイメージを保存します。
BarCode1.Save("C:\BarCode.bmp")

参照

BarCode クラス
Save オーバーロード
AdvanceSoftware.VBBarCode.Wpf 名前空間


SaveSvg メソッド

[image] [image]

VB-BarCode 5.0 for .NET
BarCode..::..SaveSvg メソッド
BarCode クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | SaveSvg(Stream) | バーコードの SVG イメージを保存します。
Public method | SaveSvg(String) | バーコードの SVG イメージを保存します。

参照

BarCode クラス
BarCode メンバ
AdvanceSoftware.VBBarCode.Wpf 名前空間


SaveSvg メソッド (Stream)

[image]

VB-BarCode 5.0 for .NET
BarCode..::..SaveSvg メソッド (Stream)
BarCode クラス 使用例 参照
バーコードの SVG イメージを保存します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool SaveSvg(
    Stream stream
)
Visual Basic (宣言)
Public Function SaveSvg ( _
    stream As Stream _
) As Boolean

パラメータ

stream
Type: System.IO..::..Stream
イメージが保存される Stream。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// バーコードイメージを保存します。
FileStream fileStream = new FileStream(@"C:\BarCode.svg", FileMode.Create);
barCode1.SaveSvg(fileStream);
fileStream.Close();
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' バーコードイメージを保存します。
Dim FileStream As FileStream = New FileStream("C:\BarCode.svg", FileMode.Create)
BarCode1.SaveSvg(FileStream)
FileStream.Close()

参照

BarCode クラス
SaveSvg オーバーロード
AdvanceSoftware.VBBarCode.Wpf 名前空間


SaveSvg メソッド (String)

[image]

VB-BarCode 5.0 for .NET
BarCode..::..SaveSvg メソッド (String)
BarCode クラス 使用例 参照
バーコードの SVG イメージを保存します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool SaveSvg(
    string fileName
)
Visual Basic (宣言)
Public Function SaveSvg ( _
    fileName As String _
) As Boolean

パラメータ

fileName
Type: System..::..String
バーコードイメージの保存先ファイル名を格納している文字列。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// バーコードイメージを保存します。
barCode1.SaveSvg(@"C:\BarCode.svg");
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' バーコードイメージを保存します。
BarCode1.SaveSvg("C:\BarCode.svg")

参照

BarCode クラス
SaveSvg オーバーロード
AdvanceSoftware.VBBarCode.Wpf 名前空間


SaveSvgz メソッド

[image] [image]

VB-BarCode 5.0 for .NET
BarCode..::..SaveSvgz メソッド
BarCode クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | SaveSvgz(Stream) | バーコードの圧縮 SVG イメージを保存します。
Public method | SaveSvgz(String) | バーコードの圧縮 SVG イメージを保存します。

参照

BarCode クラス
BarCode メンバ
AdvanceSoftware.VBBarCode.Wpf 名前空間


SaveSvgz メソッド (Stream)

[image]

VB-BarCode 5.0 for .NET
BarCode..::..SaveSvgz メソッド (Stream)
BarCode クラス 使用例 参照
バーコードの圧縮 SVG イメージを保存します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool SaveSvgz(
    Stream stream
)
Visual Basic (宣言)
Public Function SaveSvgz ( _
    stream As Stream _
) As Boolean

パラメータ

stream
Type: System.IO..::..Stream
イメージが保存される Stream。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// バーコードイメージを保存します。
FileStream fileStream = new FileStream(@"C:\BarCode.svgz", FileMode.Create);
barCode1.SaveSvgz(fileStream);
fileStream.Close();
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' バーコードイメージを保存します。
Dim FileStream As FileStream = New FileStream("C:\BarCode.svgz", FileMode.Create)
BarCode1.SaveSvgz(FileStream)
FileStream.Close()

参照

BarCode クラス
SaveSvgz オーバーロード
AdvanceSoftware.VBBarCode.Wpf 名前空間


SaveSvgz メソッド (String)

[image]

VB-BarCode 5.0 for .NET
BarCode..::..SaveSvgz メソッド (String)
BarCode クラス 使用例 参照
バーコードの圧縮 SVG イメージを保存します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool SaveSvgz(
    string fileName
)
Visual Basic (宣言)
Public Function SaveSvgz ( _
    fileName As String _
) As Boolean

パラメータ

fileName
Type: System..::..String
バーコードイメージの保存先ファイル名を格納している文字列。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// バーコードイメージを保存します。
barCode1.SaveSvgz(@"C:\BarCode.svgz");
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' バーコードイメージを保存します。
BarCode1.SaveSvgz("C:\BarCode.svgz")

参照

BarCode クラス
SaveSvgz オーバーロード
AdvanceSoftware.VBBarCode.Wpf 名前空間


BarCode プロパティ

[image] [image]

VB-BarCode 5.0 for .NET
BarCode プロパティ
BarCode クラス 参照

BarCode データ型で公開されるメンバを以下に示します。

プロパティ

 | 名前 | 説明
Public property | _Type | バーコードの種類を設定、取得します。
Public property | _Unit | バーコードの生成単位を設定、取得します。
Public property | BackColor | バーコードシンボルの背景色を設定、取得します。
Public property | BarColor | バーの色を設定、取得します。
Public property | BarHeight | バーコードの高さを設定、取得します。
Public property | BarRatio | 太バーのエレメント率を設定、取得します。(Codabar、Code39)
Public property | BarWidth | バーコードの幅を設定、取得します。
Public property | BinaryValue | バーコードデータを設定、取得します。(バイナリ)
Public property | BlackBarRevision | 黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
Public property | BlackRatio | 黒バーの太さの比率を設定、取得します。
Public property | CharGap | キャラクタ間のギャップを設定、取得します。(Codabar、Code39)
Public property | CharSize | バーコードキャラクタのフォントサイズを設定、取得します。
Public property | CheckCharMode | 自動でチェックキャラクタを付加するかを設定、取得します。
Public property | CheckPattern | チェックデジットの計算方法を設定、取得します。(Codabar)
Public property | Codeset | スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))
Public property | DpiX | X 軸方向の解像度を設定、取得します。(ピクセル単位)
Public property | DpiY | Y 軸方向の解像度を設定、取得します。(ピクセル単位)
Public property | Element | 最小エレメント値を設定、取得します。
Public property | ErrorMessage | エラーメッセージを取得します。
Public property | ErrorNo | エラーナンバーを取得します。
Public property | FlatHeight | ガードバーの均等化を設定、取得します。(JAN、UPC)
Public property | Font | バーコードメッセージのフォント名を設定、取得します。
Public property | FontStyle | バーコードキャラクタのフォントスタイルを設定、取得します。
Public property | FontWeight | バーコードメッセージのフォントウエイトを設定、取得します。
Public property | InternalQRVersion | QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。
Public property | InternalValue | 整形後のバーコードデータを取得します。
Public property | MessageAlign | バーコードメッセージの表示横位置を設定、取得します。(GS1Fixed)
Public property | PDFColumn | PDF417 の列数を設定、取得します。
Public property | PDFInitialSymbol | PDF417 の初期化シンボルを設定、取得します。
Public property | PDFLevel | PDF417 のエラー訂正レベルを設定、取得します。
Public property | PDFModel | PDF417 シンボルを設定、取得します。
Public property | PDFRatio | PDF417 の 1 モジュールの縦横比を設定、取得します。
Public property | PDFRow | PDF417 の行数を設定、取得します。
Public property | Point | ポイントを設定、取得します。(郵便カスタマバーコード)
Public property | QRConnect | 連結 QR コードを作成するかを設定、取得します。
Public property | QREscapeCode | QR コードのエスケープコードを設定、取得します。
Public property | QRLevel | QR コードの誤り訂正レベルを設定、取得します。
Public property | QRMask | QR コードのマスクパターンを設定、取得します。
Public property | QRModel | QR コードのモデルを設定、取得します。
Public property | QRSymbolNumber | 連結 QR コードで出力するシンボル番号を設定、取得します。
Public property | QRVersion | QR コードの型番を設定、取得します。
Public property | Quiet | 余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金代理収納 GS1-128)
Public property | Rotate | バーコードの回転方向を設定、取得します。
Public property | ShowBearer | ベアラバーを表示するかを設定、取得します。(ITF)
Public property | ShowMessage | バーコードメッセージを表示するかを設定、取得します。
Public property | StartChar | スタートキャラクタを設定、取得します。(Codabar)
Public property | StopChar | ストップキャラクタを設定、取得します。(Codabar)
Public property | Type | バーコードの種類を設定、取得します。
Public property | Unit | バーコードの生成単位を設定、取得します。
Public property | Value | バーコードデータを設定、取得します。(文字列)
Public property | WhiteBarRevision | 白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
Public property | Zoom | 倍率を設定、取得します。(JAN、UPC、ITF)

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


_Type プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::.._Type プロパティ
BarCode クラス 使用例 参照
バーコードの種類を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public BarCodeType _Type { get; set; }
Visual Basic (宣言)
Public Property _Type As BarCodeType
    Get
    Set

プロパティ値

バーコードのタイプを表す BarCodeType。(既定値：BarCodeType.JAN13)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
// 生成するバーコードイメージを "JAN13" に設定します。
barCode1._Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
' 生成するバーコードイメージを "JAN13" に設定します。
BarCode1._Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


_Unit プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::.._Unit プロパティ
BarCode クラス 使用例 参照
バーコードの生成単位を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Unit _Unit { get; set; }
Visual Basic (宣言)
Public Property _Unit As Unit
    Get
    Set

プロパティ値

バーコードの生成単位を表す Unit。(既定値：Unit.Pixel)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1._Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1._Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BackColor プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..BackColor プロパティ
BarCode クラス 使用例 参照
バーコードシンボルの背景色を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Color BackColor { get; set; }
Visual Basic (宣言)
Public Property BackColor As Color
    Get
    Set

プロパティ値

バーコードシンボルの背景色を表す Color。(既定値：Color.White)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの背景色を "赤色" に設定します。
barCode1.BackColor = System.Windows.Media.Colors.Red;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの背景色を "赤色" に設定します。
BarCode1.BackColor = System.Windows.Media.Colors.Red
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BarColor プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..BarColor プロパティ
BarCode クラス 使用例 参照
バーの色を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Color BarColor { get; set; }
Visual Basic (宣言)
Public Property BarColor As Color
    Get
    Set

プロパティ値

バーの色を表す Color。(既定値：Color.Black)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーの色を "赤色" に設定します。
barCode1.BarColor = System.Windows.Media.Colors.Red;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーの色を "赤色" に設定します。
BarCode1.BarColor = System.Windows.Media.Colors.Red
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BarHeight プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..BarHeight プロパティ
BarCode クラス 使用例 参照
バーコードの高さを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double BarHeight { get; set; }
Visual Basic (宣言)
Public Property BarHeight As Double
    Get
    Set

プロパティ値

バーコードの高さを表す double。(既定値：0.0)

解説

プロパティ値が 0 の場合、バーコードの高さは自動で設定されます。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードイメージの高さを "30.0mm" に設定します。
barCode1.BarHeight = 30.0;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードイメージの高さを "30.0mm" に設定します。
BarCode1.BarHeight = 30.0
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BarRatio プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..BarRatio プロパティ
BarCode クラス 使用例 参照
太バーのエレメント率を設定、取得します。(Codabar、Code39)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double BarRatio { get; set; }
Visual Basic (宣言)
Public Property BarRatio As Double
    Get
    Set

プロパティ値

太バーのエレメント率を表す double。(既定値：2.0)

解説

設定範囲

最小エレメント値が 0.508mm 未満：2.2 ～ 3.0

最小エレメント値が 0.508mm 以上：2.0 ～ 3.0

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// 太バーのエレメント率を "2.5" に設定します。
barCode1.BarRatio = 2.5;
barCode1.Value = "1234567890";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' 太バーのエレメント率を "2.5" に設定します。
BarCode1.BarRatio = 2.5
BarCode1.Value = "1234567890"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BarWidth プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..BarWidth プロパティ
BarCode クラス 使用例 参照
バーコードの幅を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double BarWidth { get; set; }
Visual Basic (宣言)
Public Property BarWidth As Double
    Get
    Set

プロパティ値

バーコードの幅を表す double。(既定値：0.0)

解説

プロパティ値が 0 の場合、バーコードの幅は自動で設定されます。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードイメージの幅を "60.0mm" に設定します。
barCode1.BarWidth = 60.0;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードイメージの幅を "60.0mm" に設定します。
BarCode1.BarWidth = 60.0
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BinaryValue プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..BinaryValue プロパティ
BarCode クラス 使用例 参照
バーコードデータを設定、取得します。(バイナリ)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public byte[] BinaryValue { set; }
Visual Basic (宣言)
Public WriteOnly Property BinaryValue As Byte()
    Set

プロパティ値

バーコードデータを表す Byte。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// "12345ABCDE"
Byte[] btByte = new Byte[] { 49, 50, 51, 52, 53, 65, 66, 67, 68, 69 };
// バーコードデータを設定します。 (バイナリ)
barCode1.BinaryValue = btByte;
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' "12345ABCDE"
Dim btByte() As Byte = New Byte() {49, 50, 51, 52, 53, 65, 66, 67, 68, 69}
' バーコードデータを設定します。 (バイナリ)
BarCode1.BinaryValue = btByte

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BlackBarRevision プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..BlackBarRevision プロパティ
BarCode クラス 使用例 参照
黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int BlackBarRevision { get; set; }
Visual Basic (宣言)
Public Property BlackBarRevision As Integer
    Get
    Set

プロパティ値

黒バーのドット補正値を表す int。(既定値：0)

解説

Unit プロパティの値が、Unit.Pixel の場合、有効になります。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128;
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 黒バーのドット補正値を "+2" に設定します。
barCode1.BlackBarRevision = 2;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 黒バーのドット補正値を "+2" に設定します。
BarCode1.BlackBarRevision = 2
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BlackRatio プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..BlackRatio プロパティ
BarCode クラス 使用例 参照
黒バーの太さの比率を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int BlackRatio { get; set; }
Visual Basic (宣言)
Public Property BlackRatio As Integer
    Get
    Set

プロパティ値

黒バーの太さの比率を表す int。(既定値：100)

解説

設定範囲：50 ～ 150

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// 黒バーの太さ比率を "150%" に設定します。
barCode1.BlackRatio = 150;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' 黒バーの太さ比率を "150%" に設定します。
BarCode1.BlackRatio = 150
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


CharGap プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..CharGap プロパティ
BarCode クラス 使用例 参照
キャラクタ間のギャップを設定、取得します。(Codabar、Code39)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double CharGap { get; set; }
Visual Basic (宣言)
Public Property CharGap As Double
    Get
    Set

プロパティ値

キャラクタ間のギャップを表す double。(既定値：0.0)

解説

プロパティ値が 0 の場合、キャラクタ間のギャップは自動で設定されます。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code39;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードキャラクタの間隔を "2.0mm" に設定します。
barCode1.CharGap = 2.0;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code39
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードキャラクタの間隔を "2.0mm" に設定します。
BarCode1.CharGap = 2.0
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


CharSize プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..CharSize プロパティ
BarCode クラス 使用例 参照
バーコードキャラクタのフォントサイズを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double CharSize { get; set; }
Visual Basic (宣言)
Public Property CharSize As Double
    Get
    Set

プロパティ値

バーコードキャラクタのフォントサイズを表す double。(既定値：0.0)

解説

プロパティ値が 0 の場合、バーコードキャラクタのフォントサイズは自動で設定されます。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードメッセージのフォントサイズを "10.0mm" に設定します。
barCode1.CharSize = 10.0;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードメッセージのフォントサイズを "10.0mm" に設定します。
BarCode1.CharSize = 10.0
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


CheckCharMode プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..CheckCharMode プロパティ
BarCode クラス 使用例 参照
自動でチェックキャラクタを付加するかを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool CheckCharMode { get; set; }
Visual Basic (宣言)
Public Property CheckCharMode As Boolean
    Get
    Set

プロパティ値

チェックキャラクタのモードを表す bool。(既定値：true)

解説

プロパティ値が true の場合、自動でチェックキャラクタを付加します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// チェックキャラクタを "付加しない" に設定します。
barCode1.CheckCharMode = false;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' チェックキャラクタを "付加しない" に設定します。
BarCode1.CheckCharMode = False
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


CheckPattern プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..CheckPattern プロパティ
BarCode クラス 使用例 参照
チェックデジットの計算方法を設定、取得します。(Codabar)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public CheckPattern CheckPattern { get; set; }
Visual Basic (宣言)
Public Property CheckPattern As CheckPattern
    Get
    Set

プロパティ値

チェックデジットの計算方法を表す CheckPattern。(既定値：CheckPattern.Modulus16)

解説

CheckPattern.Modulus11(モジュラス 11) を設定した場合、計算に必要なバーコードメッセージは 6 桁以上必要になります。6 桁未満の場合は、Modulus10Weight3(モジュラス10 / ウエイト3) で計算されます。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// チェックデジットの計算方法を "モジュラス 11" に設定します。
barCode1.CheckPattern = AdvanceSoftware.VBBarCode.CheckPattern.Modulus11;
barCode1.Value = "12345678";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' チェックデジットの計算方法を "モジュラス 11" に設定します。
BarCode1.CheckPattern = AdvanceSoftware.VBBarCode.CheckPattern.Modulus11
BarCode1.Value = "12345678"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Codeset プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Codeset プロパティ
BarCode クラス 使用例 参照
スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Codeset Codeset { get; set; }
Visual Basic (宣言)
Public Property Codeset As Codeset
    Get
    Set

プロパティ値

スタートコードセットを表す Codeset。(既定値：Codeset.CodesetAuto)

解説

プロパティ値が CodeSet.CodesetAuto の場合、バーコードデータの先頭の文字でコードセットが決まります。

先頭キャラクタが ~(チルダ) の場合、コードセットA に設定されます。

先頭キャラクタがアルファベットの場合、コードセットB に設定されます。

先頭から 2 キャラクタが数字の場合、コードセット C に設定されます。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128;
// Code128 を "コードセット B" に設定します。
barCode1.Codeset = AdvanceSoftware.VBBarCode.Codeset.CodesetB;
barCode1.Value = "abc123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128
' Code128 を "コードセット B" に設定します。
BarCode1.Codeset = AdvanceSoftware.VBBarCode.Codeset.CodesetB
BarCode1.Value = "abc123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


DpiX プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..DpiX プロパティ
BarCode クラス 使用例 参照
X 軸方向の解像度を設定、取得します。(ピクセル単位)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double DpiX { get; set; }
Visual Basic (宣言)
Public Property DpiX As Double
    Get
    Set

プロパティ値

X 軸方向の解像度を表す double。(既定値：96.0)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// X 軸方向の解像度を "600dpi" に設定します。
barCode1.DpiX = 600;
// Y 軸方向の解像度を "600dpi" に設定します。
barCode1.DpiY = 600;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' X 軸方向の解像度を "600dpi" に設定します。
BarCode1.DpiX = 600
' Y 軸方向の解像度を "600dpi" に設定します。
BarCode1.DpiY = 600
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


DpiY プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..DpiY プロパティ
BarCode クラス 使用例 参照
Y 軸方向の解像度を設定、取得します。(ピクセル単位)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double DpiY { get; set; }
Visual Basic (宣言)
Public Property DpiY As Double
    Get
    Set

プロパティ値

Y 軸方向の解像度を表す double。(既定値：96.0)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// X 軸方向の解像度を "600dpi" に設定します。
barCode1.DpiX = 600;
// Y 軸方向の解像度を "600dpi" に設定します。
barCode1.DpiY = 600;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' X 軸方向の解像度を "600dpi" に設定します。
BarCode1.DpiX = 600
' Y 軸方向の解像度を "600dpi" に設定します。
BarCode1.DpiY = 600
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Element プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Element プロパティ
BarCode クラス 使用例 参照
最小エレメント値を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double Element { get; set; }
Visual Basic (宣言)
Public Property Element As Double
    Get
    Set

プロパティ値

最小エレメント値を表す double。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードイメージの最小エレメント値を "0.191mm" に設定します。
barCode1.Element = 0.191;
barCode1.Value = "1234567890";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードイメージの最小エレメント値を "0.191mm" に設定します。
BarCode1.Element = 0.191
BarCode1.Value = "1234567890"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


ErrorMessage プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..ErrorMessage プロパティ
BarCode クラス 使用例 参照
エラーメッセージを取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public string ErrorMessage { get; }
Visual Basic (宣言)
Public ReadOnly Property ErrorMessage As String
    Get

プロパティ値

バーコード生成時のエラーメッセージを表す string。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// エラー処理
if (barCode1.ErrorNo != AdvanceSoftware.VBBarCode.ErrorNo.NoError)
{
    // エラーメッセージを表示します。
    MessageBox.Show(barCode1.ErrorMessage);
}
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' エラー処理
If BarCode1.ErrorNo <> AdvanceSoftware.VBBarCode.ErrorNo.NoError Then
    ' エラーメッセージを表示します。
    MessageBox.Show(BarCode1.ErrorMessage)
End If

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


ErrorNo プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..ErrorNo プロパティ
BarCode クラス 使用例 参照
エラーナンバーを取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public ErrorNo ErrorNo { get; }
Visual Basic (宣言)
Public ReadOnly Property ErrorNo As ErrorNo
    Get

プロパティ値

バーコード生成時のエラーナンバーを表す ErrorNo。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// エラー処理
if (barCode1.ErrorNo != AdvanceSoftware.VBBarCode.ErrorNo.NoError)
{
    // エラーメッセージを表示します。
    MessageBox.Show(barCode1.ErrorMessage);
}
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' エラー処理
If BarCode1.ErrorNo <> AdvanceSoftware.VBBarCode.ErrorNo.NoError Then
    ' エラーメッセージを表示します。
    MessageBox.Show(BarCode1.ErrorMessage)
End If

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


FlatHeight プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..FlatHeight プロパティ
BarCode クラス 使用例 参照
ガードバーの均等化を設定、取得します。(JAN、UPC)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool FlatHeight { get; set; }
Visual Basic (宣言)
Public Property FlatHeight As Boolean
    Get
    Set

プロパティ値

ガードバーの均等化を表す bool。(既定値：false)

解説

プロパティ値が true の場合、ガードバーを均等化します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// ガードバーの長さを均等に設定します。
barCode1.FlatHeight = true;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' ガードバーの長さを均等に設定します。
BarCode1.FlatHeight = True
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Font プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Font プロパティ
BarCode クラス 使用例 参照
バーコードメッセージのフォント名を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public FontFamily Font { get; set; }
Visual Basic (宣言)
Public Property Font As FontFamily
    Get
    Set

プロパティ値

バーコードメッセージのフォントを表す Font。

解説

このプロパティは、バーコードメッセージのフォント名を設定することができます。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードメッセージのフォントを "ＭＳ 明朝" に設定します。
barCode1.Font = new System.Windows.Media.FontFamily("ＭＳ 明朝");
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードメッセージのフォントを "ＭＳ 明朝" に設定します。
BarCode1.Font = New System.Windows.Media.FontFamily("ＭＳ 明朝")
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


FontStyle プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..FontStyle プロパティ
BarCode クラス 使用例 参照
バーコードキャラクタのフォントスタイルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public FontStyle FontStyle { get; set; }
Visual Basic (宣言)
Public Property FontStyle As FontStyle
    Get
    Set

プロパティ値

バーコードキャラクタのフォントスタイルを表す FontStyle。

解説

このプロパティは、バーコードキャラクタのフォントスタイルを設定することができます。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードメッセージのフォントスタイルを "斜体" に設定します。
barCode1.FontStyle = System.Windows.FontStyles.Italic;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードメッセージのフォントスタイルを "斜体" に設定します。
BarCode1.FontStyle = System.Windows.FontStyles.Italic
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


FontWeight プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..FontWeight プロパティ
BarCode クラス 使用例 参照
バーコードメッセージのフォントウエイトを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public FontWeight FontWeight { get; set; }
Visual Basic (宣言)
Public Property FontWeight As FontWeight
    Get
    Set

プロパティ値

バーコードメッセージのフォントウエイトを表す FontWeight。

解説

このプロパティは、バーコードメッセージのフォントウエイトを設定することができます。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードメッセージのフォントウエイトを "太字" に設定します。
barCode1.FontWeight = System.Windows.FontWeights.Bold;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードメッセージのフォントウエイトを "太字" に設定します。
BarCode1.FontWeight = System.Windows.FontWeights.Bold
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


InternalQRVersion プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..InternalQRVersion プロパティ
BarCode クラス 使用例 参照
QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRVersion InternalQRVersion { get; }
Visual Basic (宣言)
Public ReadOnly Property InternalQRVersion As QRVersion
    Get

プロパティ値

QR コードの型番を表す QRVersion。

解説

プロパティ値が QRVersion.VersionAuto の場合、QR コードの型番は自動で設定されます。

QRModel プロパティの値により、QRVersion.VersionAuto 以外の設定範囲が異なります。

設定範囲(QRModel1)：QRVersion.QRVersion1 ～ QRVersion14

設定範囲(QRModel2)：QRVersion.QRVersion1 ～ QRVersion40

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
barCode1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.VersionAuto;
barCode1.Value = "12345ABCDE";
ImageSource imgBarCode = barCode1.GetBarCodeImage();
// 自動設定された QR コード の型番を取得します。
AdvanceSoftware.VBBarCode.QRVersion internalQRVersion = barCode1.InternalQRVersion;
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
BarCode1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.VersionAuto
BarCode1.Value = "12345ABCDE"
Dim imgBarCode As ImageSource = BarCode1.GetBarCodeImage()
' 自動設定された QR コード の型番を取得します。
Dim internalQRVersion As AdvanceSoftware.VBBarCode.QRVersion = BarCode1.InternalQRVersion

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


InternalValue プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..InternalValue プロパティ
BarCode クラス 使用例 参照
整形後のバーコードデータを取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public string InternalValue { get; }
Visual Basic (宣言)
Public ReadOnly Property InternalValue As String
    Get

プロパティ値

整形後のバーコードデータを表す string。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
ImageSource imgBarCode = barCode1.GetBarCodeImage();
// 整形後のバーコードデータを取得します。
string internalValue = barCode1.InternalValue;
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
Dim imgBarCode As ImageSource = BarCode1.GetBarCodeImage()
' 整形後のバーコードデータを取得します。
Dim internalValue As String = BarCode1.InternalValue

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


MessageAlign プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..MessageAlign プロパティ
BarCode クラス 使用例 参照
バーコードメッセージの表示横位置を設定、取得します。(GS1Fixed)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public MessageAlign MessageAlign { get; set; }
Visual Basic (宣言)
Public Property MessageAlign As MessageAlign
    Get
    Set

プロパティ値

バーコードメッセージの表示横位置を表す MessageAlign。(既定値：MessageAlign.Center)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.GS1Fixed;
// バーコードメッセージの横位置を "左詰め" に設定します。(GS1Fixed)
barCode1.MessageAlign = AdvanceSoftware.VBBarCode.MessageAlign.Left;
barCode1.Value = "91012345678901234567890123456789012345678901";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.GS1Fixed
' バーコードメッセージの横位置を "左詰め" に設定します。(GS1Fixed)
BarCode1.MessageAlign = AdvanceSoftware.VBBarCode.MessageAlign.Left
BarCode1.Value = "91012345678901234567890123456789012345678901"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


PDFColumn プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..PDFColumn プロパティ
BarCode クラス 使用例 参照
PDF417 の列数を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int PDFColumn { get; set; }
Visual Basic (宣言)
Public Property PDFColumn As Integer
    Get
    Set

プロパティ値

PDF417 の列数を表す int。(既定値：0)

解説

設定範囲：0 ～ 40

プロパティ値が 0 の場合、縦横比 1:2 で PDF417 を作成します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 の列数を "15列" に設定します。
barCode1.PDFColumn = 15;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 の列数を "15列" に設定します。
BarCode1.PDFColumn = 15
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


PDFInitialSymbol プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..PDFInitialSymbol プロパティ
BarCode クラス 使用例 参照
PDF417 の初期化シンボルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool PDFInitialSymbol { get; set; }
Visual Basic (宣言)
Public Property PDFInitialSymbol As Boolean
    Get
    Set

プロパティ値

PDF417 の初期化シンボルを表す bool。(既定値：false)

解説

プロパティ値が true の場合、初期化シンボルを付加した PDF417 を作成します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 の初期化シンボルを "付加する" に設定します。
barCode1.PDFInitialSymbol = true;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 の初期化シンボルを "付加する" に設定します。
BarCode1.PDFInitialSymbol = True
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


PDFLevel プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..PDFLevel プロパティ
BarCode クラス 使用例 参照
PDF417 のエラー訂正レベルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int PDFLevel { get; set; }
Visual Basic (宣言)
Public Property PDFLevel As Integer
    Get
    Set

プロパティ値

PDF417 のエラー訂正レベルを表す int。(既定値：0)

解説

設定範囲：0 ～ 8

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 のエラー訂正レベルを "レベル7" に設定します。
barCode1.PDFLevel = 7;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 のエラー訂正レベルを "レベル7" に設定します。
BarCode1.PDFLevel = 7
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


PDFModel プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..PDFModel プロパティ
BarCode クラス 使用例 参照
PDF417 シンボルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public PDFModel PDFModel { get; set; }
Visual Basic (宣言)
Public Property PDFModel As PDFModel
    Get
    Set

プロパティ値

PDF417 シンボルを表す PDFModel。(既定値：PDFModel.Default)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 シンボルを "簡易 PDF417" に設定します。
barCode1.PDFModel = AdvanceSoftware.VBBarCode.PDFModel.Truncated;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 シンボルを "簡易 PDF417" に設定します。
BarCode1.PDFModel = AdvanceSoftware.VBBarCode.PDFModel.Truncated
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


PDFRatio プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..PDFRatio プロパティ
BarCode クラス 使用例 参照
PDF417 の 1 モジュールの縦横比を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double PDFRatio { get; set; }
Visual Basic (宣言)
Public Property PDFRatio As Double
    Get
    Set

プロパティ値

PDF417 の 1 モジュールの縦横比を表す double。(既定値：7.5)

解説

設定範囲：1.0 ～ 10.0

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 の 1 モジュールの幅との縦横比を "5.0" に設定します。
barCode1.PDFRatio = 5.0;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 の 1 モジュールの幅との縦横比を "5.0" に設定します。
BarCode1.PDFRatio = 5.0
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


PDFRow プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..PDFRow プロパティ
BarCode クラス 使用例 参照
PDF417 の行数を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int PDFRow { get; set; }
Visual Basic (宣言)
Public Property PDFRow As Integer
    Get
    Set

プロパティ値

PDF417 の行数を表す int。(既定値：0)

解説

設定範囲：0、3 ～ 90

プロパティ値が 0 の場合、縦横比 1:2 で PDF417 を作成します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 の行数を "10行" に設定します。
barCode1.PDFRow = 10;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 の行数を "10行" に設定します。
BarCode1.PDFRow = 10
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Point プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Point プロパティ
BarCode クラス 使用例 参照
ポイントを設定、取得します。(郵便カスタマバーコード)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double Point { get; set; }
Visual Basic (宣言)
Public Property Point As Double
    Get
    Set

プロパティ値

バーコードのポイントを表す double。(既定値：10.0)

解説

設定範囲：6.0 ～ 14.0

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.CustomerBarCode;
// 郵便カスタマバーコードのポイントを "10.0" に設定します。
barCode1.Point = 10.0;
barCode1.Value = "91882391-2816";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.CustomerBarCode
' 郵便カスタマバーコードのポイントを "10.0" に設定します。
BarCode1.Point = 10.0
BarCode1.Value = "91882391-2816"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


QRConnect プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..QRConnect プロパティ
BarCode クラス 使用例 参照
連結 QR コードを作成するかを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRConnect QRConnect { get; set; }
Visual Basic (宣言)
Public Property QRConnect As QRConnect
    Get
    Set

プロパティ値

連結 QR コードの設定を表す QRConnect。(既定値：QRConnect.NotConnect)

解説

プロパティ値が QRConnect.AutoConnect、QRConnect.ManualConnect の場合、QRVersion プロパティを QRVersion.VersionAuto 以外に設定します。

また、QRConnect.ManualConnect の場合、QREscapeCode プロパティを使用して分割する位置のエスケープコードを設定します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10;
// QR コード を "連結 QR コード(手動)" に設定します。
barCode1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect;
// QR コードのエスケープコードを "% (0x25)" に設定します。
barCode1.QREscapeCode = 0x25;
barCode1.Value = "12345%SABCDE";
// 連結 QR コードで出力するシンボル番号を "0" に設定します。
barCode1.QRSymbolNumber = 0;
barCode1.Save(@"C:\Barcode1.bmp");
// 連結 QR コードで出力するシンボル番号を "1" に設定します。
barCode1.QRSymbolNumber = 1;
barCode1.Save(@"C:\Barcode2.bmp");
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10
' QR コード を "連結 QR コード(手動)" に設定します。
BarCode1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect
' QR コードのエスケープコードを "% (&H25)" に設定します。
BarCode1.QREscapeCode = &H25
BarCode1.Value = "12345%SABCDE"
' 連結 QR コードで出力するシンボル番号を "0" に設定します。
BarCode1.QRSymbolNumber = 0
BarCode1.Save("C:\Barcode1.bmp")
' 連結 QR コードで出力するシンボル番号を "1" に設定します。
BarCode1.QRSymbolNumber = 1
BarCode1.Save("C:\Barcode2.bmp")

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


QREscapeCode プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..QREscapeCode プロパティ
BarCode クラス 使用例 参照
QR コードのエスケープコードを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public byte QREscapeCode { get; set; }
Visual Basic (宣言)
Public Property QREscapeCode As Byte
    Get
    Set

プロパティ値

QR コードのエスケープコードを表す Byte。(既定値：0x00)

解説

Value プロパティや、ValueB プロパティに設定するバーコードデータの分割する位置に、"エスケープコード" + "S" を設定します。バーコードデータにエスケープコードと同じ文字がある場合、バーコードメッセージ側の該当する文字を二つ連続して設定してください。

このプロパティは、QRConnect プロパティの値が、QRConnect.ManualConnect の場合に有効です。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10;
// QR コード を "連結 QR コード(手動)" に設定します。
barCode1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect;
// QR コードのエスケープコードを "% (0x25)" に設定します。
barCode1.QREscapeCode = 0x25;
barCode1.Value = "12345%SABCDE";
// 連結 QR コードで出力するシンボル番号を "0" に設定します。
barCode1.QRSymbolNumber = 0;
barCode1.Save(@"C:\Barcode1.bmp");
// 連結 QR コードで出力するシンボル番号を "1" に設定します。
barCode1.QRSymbolNumber = 1;
barCode1.Save(@"C:\Barcode2.bmp");
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10
' QR コード を "連結 QR コード(手動)" に設定します。
BarCode1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect
' QR コードのエスケープコードを "% (&H25)" に設定します。
BarCode1.QREscapeCode = &H25
BarCode1.Value = "12345%SABCDE"
' 連結 QR コードで出力するシンボル番号を "0" に設定します。
BarCode1.QRSymbolNumber = 0
BarCode1.Save("C:\Barcode1.bmp")
' 連結 QR コードで出力するシンボル番号を "1" に設定します。
BarCode1.QRSymbolNumber = 1
BarCode1.Save("C:\Barcode2.bmp")

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


QRLevel プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..QRLevel プロパティ
BarCode クラス 使用例 参照
QR コードの誤り訂正レベルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRLevel QRLevel { get; set; }
Visual Basic (宣言)
Public Property QRLevel As QRLevel
    Get
    Set

プロパティ値

QR コードの誤り訂正レベルを表す QRLevel。(既定値：QRLevel.LevelM)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードのエラー訂正レベルを "H" に設定します。
barCode1.QRLevel = AdvanceSoftware.VBBarCode.QRLevel.LevelH;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードのエラー訂正レベルを "H" に設定します。
BarCode1.QRLevel = AdvanceSoftware.VBBarCode.QRLevel.LevelH
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


QRMask プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..QRMask プロパティ
BarCode クラス 使用例 参照
QR コードのマスクパターンを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRMask QRMask { get; set; }
Visual Basic (宣言)
Public Property QRMask As QRMask
    Get
    Set

プロパティ値

QR コードのマスクパターンを表す QRMask。(既定値：QRMask.MaskAuto)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
barCode1.QRMask = AdvanceSoftware.VBBarCode.QRMask.Mask000;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
BarCode1.QRMask = AdvanceSoftware.VBBarCode.QRMask.Mask000
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


QRModel プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..QRModel プロパティ
BarCode クラス 使用例 参照
QR コードのモデルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRModel QRModel { get; set; }
Visual Basic (宣言)
Public Property QRModel As QRModel
    Get
    Set

プロパティ値

QR コードのモデルを表す QRModel。(既定値：QRModel.Model1)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードのモデルを "モデル 2" に設定します。
barCode1.QRModel = AdvanceSoftware.VBBarCode.QRModel.Model2;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードのモデルを "モデル 2" に設定します。
BarCode1.QRModel = AdvanceSoftware.VBBarCode.QRModel.Model2
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


QRSymbolNumber プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..QRSymbolNumber プロパティ
BarCode クラス 使用例 参照
連結 QR コードで出力するシンボル番号を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int QRSymbolNumber { get; set; }
Visual Basic (宣言)
Public Property QRSymbolNumber As Integer
    Get
    Set

プロパティ値

連結 QR コードのシンボル番号を表す int。(既定値：0)

解説

設定範囲：0 ～ 15

このプロパティは、QRConnect プロパティの値が、QRConnect.AutoConnect、QRConnect.ManualConnect の場合に有効です。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10;
// QR コード を "連結 QR コード(手動)" に設定します。
barCode1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect;
// QR コードのエスケープコードを "% (0x25)" に設定します。
barCode1.QREscapeCode = 0x25;
barCode1.Value = "12345%SABCDE";
// 連結 QR コードで出力するシンボル番号を "0" に設定します。
barCode1.QRSymbolNumber = 0;
barCode1.Save(@"C:\Barcode1.bmp");
// 連結 QR コードで出力するシンボル番号を "1" に設定します。
barCode1.QRSymbolNumber = 1;
barCode1.Save(@"C:\Barcode2.bmp");
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10
' QR コード を "連結 QR コード(手動)" に設定します。
BarCode1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect
' QR コードのエスケープコードを "% (&H25)" に設定します。
BarCode1.QREscapeCode = &H25
BarCode1.Value = "12345%SABCDE"
' 連結 QR コードで出力するシンボル番号を "0" に設定します。
BarCode1.QRSymbolNumber = 0
BarCode1.Save("C:\Barcode1.bmp")
' 連結 QR コードで出力するシンボル番号を "1" に設定します。
BarCode1.QRSymbolNumber = 1
BarCode1.Save("C:\Barcode2.bmp")

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


QRVersion プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..QRVersion プロパティ
BarCode クラス 使用例 参照
QR コードの型番を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRVersion QRVersion { get; set; }
Visual Basic (宣言)
Public Property QRVersion As QRVersion
    Get
    Set

プロパティ値

QR コードの型番を表す QRVersion。(既定値：QRVersion.VersionAuto)

解説

プロパティ値が QRVersion.VersionAuto の場合、QR コードの型番は自動で設定されます。

QRModel プロパティの値により、QRVersion.VersionAuto 以外の設定範囲が異なります。

設定範囲(QRModel1)：QRVersion.QRVersion1 ～ QRVersion14

設定範囲(QRModel2)：QRVersion.QRVersion1 ～ QRVersion40

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Quiet プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Quiet プロパティ
BarCode クラス 使用例 参照
余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金代理収納 GS1-128)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double Quiet { get; set; }
Visual Basic (宣言)
Public Property Quiet As Double
    Get
    Set

解説

プロパティ値が 0 の場合、バーコードの余白は自動で設定されます。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードイメージの余白幅を "2.5mm" に設定します。
barCode1.Quiet = 2.5;
barCode1.Value = "1234567890";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードイメージの余白幅を "2.5mm" に設定します。
BarCode1.Quiet = 2.5
BarCode1.Value = "1234567890"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Rotate プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Rotate プロパティ
BarCode クラス 使用例 参照
バーコードの回転方向を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Rotate Rotate { get; set; }
Visual Basic (宣言)
Public Property Rotate As Rotate
    Get
    Set

プロパティ値

バーコードの回転方向を表す Rotate。(既定値：Rotate.Rotate0)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの向きを "時計回りで 90 度回転" に設定します。
barCode1.Rotate = AdvanceSoftware.VBBarCode.Rotate.Rotate90;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの向きを "時計回りで 90 度回転" に設定します。
BarCode1.Rotate = AdvanceSoftware.VBBarCode.Rotate.Rotate90
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


ShowBearer プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..ShowBearer プロパティ
BarCode クラス 使用例 参照
ベアラバーを表示するかを設定、取得します。(ITF)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool ShowBearer { get; set; }
Visual Basic (宣言)
Public Property ShowBearer As Boolean
    Get
    Set

プロパティ値

ベアラバーの表示モードを表す bool。(既定値：true)

解説

プロパティ値が true の場合、ベアラバーを表示します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.ITF16;
// ITF16 のベアラバーを "表示しない" に設定します。
barCode1.ShowBearer = false;
barCode1.Value = "1234567890123456";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.ITF16
' ITF16 のベアラバーを "表示しない" に設定します。
BarCode1.ShowBearer = False
BarCode1.Value = "1234567890123456"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


ShowMessage プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..ShowMessage プロパティ
BarCode クラス 使用例 参照
バーコードメッセージを表示するかを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool ShowMessage { get; set; }
Visual Basic (宣言)
Public Property ShowMessage As Boolean
    Get
    Set

プロパティ値

バーコードメッセージの表示モードを表す bool。(既定値：true)

解説

プロパティ値が true の場合、バーコードメッセージを表示します。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードメッセージを "表示しない" に設定します。
barCode1.ShowMessage = false;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードメッセージを "表示しない" に設定します。
BarCode1.ShowMessage = False
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


StartChar プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..StartChar プロパティ
BarCode クラス 使用例 参照
スタートキャラクタを設定、取得します。(Codabar)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public char StartChar { get; set; }
Visual Basic (宣言)
Public Property StartChar As Char
    Get
    Set

プロパティ値

スタートキャラクタを表す char。(既定値：'a')

解説

設定可能な値：'a'、'b'、'c'、'd'、't'、'n'、'*'、'e'、'A'、'B'、'C'、'D'

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// Codabar のスタートキャラクタを "c" に設定します。
barCode1.StartChar = 'c';
barCode1.Value = "1234567890";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' Codabar のスタートキャラクタを "c" に設定します。
BarCode1.StartChar = "c"
BarCode1.Value = "1234567890"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


StopChar プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..StopChar プロパティ
BarCode クラス 使用例 参照
ストップキャラクタを設定、取得します。(Codabar)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public char StopChar { get; set; }
Visual Basic (宣言)
Public Property StopChar As Char
    Get
    Set

プロパティ値

ストップキャラクタを表す char。(既定値：'a')

解説

設定可能な値：'a'、'b'、'c'、'd'、't'、'n'、'*'、'e'、'A'、'B'、'C'、'D'

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// Codabar のストップキャラクタを "c" に設定します。
barCode1.StopChar = 'c';
barCode1.Value = "1234567890";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' Codabar のストップキャラクタを "c" に設定します。
BarCode1.StopChar = "c"
BarCode1.Value = "1234567890"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Type プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Type プロパティ
BarCode クラス 使用例 参照
バーコードの種類を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public BarCodeType Type { get; set; }
Visual Basic (宣言)
Public Property Type As BarCodeType
    Get
    Set

プロパティ値

バーコードのタイプを表す BarCodeType。(既定値：BarCodeType.JAN13)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
// 生成するバーコードイメージを "JAN13" に設定します。
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
' 生成するバーコードイメージを "JAN13" に設定します。
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Unit プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Unit プロパティ
BarCode クラス 使用例 参照
バーコードの生成単位を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Unit Unit { get; set; }
Visual Basic (宣言)
Public Property Unit As Unit
    Get
    Set

プロパティ値

バーコードの生成単位を表す Unit。(既定値：Unit.Pixel)

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Value プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Value プロパティ
BarCode クラス 使用例 参照
バーコードデータを設定、取得します。(文字列)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public string Value { get; set; }
Visual Basic (宣言)
Public Property Value As String
    Get
    Set

プロパティ値

バーコードデータを表す string。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードデータを設定します。 (文字列)
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードデータを設定します。 (文字列)
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


WhiteBarRevision プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..WhiteBarRevision プロパティ
BarCode クラス 使用例 参照
白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int WhiteBarRevision { get; set; }
Visual Basic (宣言)
Public Property WhiteBarRevision As Integer
    Get
    Set

プロパティ値

白バーのドット補正値を表す int。(既定値：0)

解説

Unit プロパティの値が、Unit.Pixel の場合、有効になります。

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128;
barCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 白バーのドット補正値を "+2" に設定します。
barCode1.WhiteBarRevision = 2;
barCode1.Value = "12345ABCDE";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128
BarCode1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 白バーのドット補正値を "+2" に設定します。
BarCode1.WhiteBarRevision = 2
BarCode1.Value = "12345ABCDE"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Zoom プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Zoom プロパティ
BarCode クラス 使用例 参照
倍率を設定、取得します。(JAN、UPC、ITF)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int Zoom { get; set; }
Visual Basic (宣言)
Public Property Zoom As Integer
    Get
    Set

プロパティ値

バーコードの倍率を表す int。(既定値：100)

解説

設定範囲(JAN、UPC)：50 ～ 200

設定範囲(ITF)：25 ～ 120

使用例

コピーC#
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
barCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの表示倍率を "200%" に設定します。
barCode1.Zoom = 200;
barCode1.Value = "1234567890123";
コピーVB.NET
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
BarCode1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの表示倍率を "200%" に設定します。
BarCode1.Zoom = 200
BarCode1.Value = "1234567890123"

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BarCode イベント

[image] [image]

VB-BarCode 5.0 for .NET
BarCode イベント
BarCode クラス 参照

BarCode データ型で公開されるメンバを以下に示します。

イベント

 | 名前 | 説明
Public event | Error | バーコードの作成に失敗した時に発生します。

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Error イベント

[image]

VB-BarCode 5.0 for .NET
BarCode..::..Error イベント
BarCode クラス 使用例 参照
バーコードの作成に失敗した時に発生します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public event BarCodeErrorEventHandler Error
Visual Basic (宣言)
Public Event Error As BarCodeErrorEventHandler

使用例

コピーC#
// バーコードクラスのインスタンス生成
private AdvanceSoftware.VBBarCode.Wpf.BarCode barCode1 = new AdvanceSoftware.VBBarCode.Wpf.BarCode();
private void InitializeComponent()
{
    // バーコードクラスのエラーイベントに barCode1_Error メソッドを関連付け
    this.barCode1.Error += new AdvanceSoftware.VBBarCode.Wpf.BarCodeErrorEventHandler(barCode1_Error);
}
// バーコードクラスのエラーイベント
private void barCode1_Error(object sender, AdvanceSoftware.VBBarCode.Wpf.BarCodeErrorEventArgs e)
{
    MessageBox.Show(barCode1.ErrorMessage);
}
コピーVB.NET
' バーコードクラスのインスタンス生成 (WithEvents)
Private WithEvents BarCode1 As AdvanceSoftware.VBBarCode.Wpf.BarCode = New AdvanceSoftware.VBBarCode.Wpf.BarCode()
' バーコードクラスのエラーイベント
Private Sub BarCode1_Error(ByVal sender As Object, ByVal e As AdvanceSoftware.VBBarCode.Wpf.BarCodeErrorEventArgs) Handles BarCode1.Error
    MessageBox.Show(BarCode1.ErrorMessage)
End Sub

参照

BarCode クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BarCodeControl クラス

[image]

VB-BarCode 5.0 for .NET
BarCodeControl クラス
メンバ 参照
BarCodeControl クラス
BarCodeControl

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public class BarCodeControl : UserControl,
    IComponentConnector
Visual Basic (宣言)
Public Class BarCodeControl _
    Inherits UserControl _
    Implements IComponentConnector

継承階層

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
System.Windows.Controls..::..UserControl
AdvanceSoftware.VBBarCode.Wpf..::..BarCodeControl

参照

BarCodeControl メンバ
AdvanceSoftware.VBBarCode.Wpf 名前空間


BarCodeControl メンバ

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeControl メンバ
BarCodeControl クラス コンストラクタ メソッド プロパティ イベント 参照

BarCodeControl データ型で公開されるメンバを以下に示します。

コンストラクタ

 | 名前 | 説明
Public method | BarCodeControl | コンストラクタ

メソッド

 | 名前 | 説明
Public method | GetBarCodeImage | バーコードのビットマップイメージを作成します。
Public method | GetScaleSize | 指定した単位でバーコードのサイズを取得します。
Public method | InitializeComponent | InitializeComponent
Public method | Save(Stream) | バーコードのイメージをビットマップ形式で保存します。
Public method | Save(String) | バーコードのイメージをビットマップ形式で保存します。
Public method | SaveSvg(Stream) | バーコードの SVG イメージを保存します。
Public method | SaveSvg(String) | バーコードの SVG イメージを保存します。
Public method | SaveSvgz(Stream) | バーコードの圧縮 SVG イメージを保存します。
Public method | SaveSvgz(String) | バーコードの圧縮 SVG イメージを保存します。

プロパティ

 | 名前 | 説明
Public property | _Type | バーコードの種類を設定、取得します。
Public property | _Unit | バーコードの生成単位を設定、取得します。
Public property | BackColor | バーコードシンボルの背景色を設定、取得します。
Public property | BarColor | バーの色を設定、取得します。
Public property | BarHeight | バーコードの高さを設定、取得します。
Public property | BarRatio | 太バーのエレメント率を設定、取得します。(Codabar、Code39)
Public property | BarWidth | バーコードの幅を設定、取得します。
Public property | BinaryValue | バーコードデータを設定、取得します。(バイナリ)
Public property | BlackBarRevision | 黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
Public property | BlackRatio | 黒バーの太さの比率を設定、取得します。
Public property | CharGap | キャラクタ間のギャップを設定、取得します。(Codabar、Code39)
Public property | CharSize | バーコードキャラクタのフォントサイズを設定、取得します。
Public property | CheckCharMode | 自動でチェックキャラクタを付加するかを設定、取得します。
Public property | CheckPattern | チェックデジットの計算方法を設定、取得します。(Codabar)
Public property | Codeset | スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))
Public property | DpiX | X 軸方向の解像度を設定、取得します。(ピクセル単位)
Public property | DpiY | Y 軸方向の解像度を設定、取得します。(ピクセル単位)
Public property | Element | 最小エレメント値を設定、取得します。
Public property | ErrorMessage | エラーメッセージを取得します。
Public property | ErrorNo | エラーナンバーを取得します。
Public property | FlatHeight | ガードバーの均等化を設定、取得します。(JAN、UPC)
Public property | Font | バーコードメッセージのフォント名を設定、取得します。
Public property | FontStyle | バーコードキャラクタのフォントスタイルを設定、取得します。
Public property | FontWeight | バーコードキャラクタのフォントウエイトを設定、取得します。
Public property | InternalQRVersion | QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。
Public property | InternalValue | 整形後のバーコードデータを取得します。
Public property | MessageAlign | バーコードメッセージの表示横位置を設定、取得します。(GS1Fixed)
Public property | PDFColumn | PDF417 の列数を設定、取得します。
Public property | PDFInitialSymbol | PDF417 の初期化シンボルを設定、取得します。
Public property | PDFLevel | PDF417 のエラー訂正レベルを設定、取得します。
Public property | PDFModel | PDF417 シンボルを設定、取得します。
Public property | PDFRatio | PDF417 の 1 モジュールの縦横比を設定、取得します。
Public property | PDFRow | PDF417 の行数を設定、取得します。
Public property | Point | ポイントを設定、取得します。(郵便カスタマバーコード)
Public property | QRConnect | 連結 QR コードを作成するかを設定、取得します。
Public property | QREscapeCode | QR コードのエスケープコードを設定、取得します。
Public property | QRLevel | QR コードの誤り訂正レベルを設定、取得します。
Public property | QRMask | QR コードのマスクパターンを設定、取得します。
Public property | QRModel | QR コードのモデルを設定、取得します。
Public property | QRSymbolNumber | 連結 QR コードで出力するシンボル番号を設定、取得します。
Public property | QRVersion | QR コードの型番を設定、取得します。
Public property | Quiet | 余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金代理収納 GS1-128)
Public property | RePaint | プロパティ変更時の再描画を行うかどうかを設定します。
Public property | Rotate | バーコードの回転方向を設定、取得します。
Public property | ShowBearer | ベアラバーを表示するかを設定、取得します。(ITF)
Public property | ShowMessage | バーコードメッセージを表示するかを設定、取得します。
Public property | StartChar | スタートキャラクタを設定、取得します。(Codabar)
Public property | StopChar | ストップキャラクタを設定、取得します。(Codabar)
Public property | Type | バーコードの種類を設定、取得します。
Public property | Unit | バーコードの生成単位を設定、取得します。
Public property | Value | バーコードデータを設定、取得します。(文字列)
Public property | WhiteBarRevision | 白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
Public property | Zoom | 倍率を設定、取得します。(JAN、UPC、ITF)

イベント

 | 名前 | 説明
Public event | Error | バーコードの作成に失敗した時に発生します。

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BarCodeControl コンストラクタ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl コンストラクタ
BarCodeControl クラス 参照
コンストラクタ

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public BarCodeControl()
Visual Basic (宣言)
Public Sub New

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BarCodeControl メソッド

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeControl メソッド
BarCodeControl クラス 参照

BarCodeControl データ型で公開されるメンバを以下に示します。

メソッド

 | 名前 | 説明
Public method | GetBarCodeImage | バーコードのビットマップイメージを作成します。
Public method | GetScaleSize | 指定した単位でバーコードのサイズを取得します。
Public method | InitializeComponent | InitializeComponent
Public method | Save(Stream) | バーコードのイメージをビットマップ形式で保存します。
Public method | Save(String) | バーコードのイメージをビットマップ形式で保存します。
Public method | SaveSvg(Stream) | バーコードの SVG イメージを保存します。
Public method | SaveSvg(String) | バーコードの SVG イメージを保存します。
Public method | SaveSvgz(Stream) | バーコードの圧縮 SVG イメージを保存します。
Public method | SaveSvgz(String) | バーコードの圧縮 SVG イメージを保存します。

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


GetBarCodeImage メソッド

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..GetBarCodeImage メソッド
BarCodeControl クラス 使用例 参照
バーコードのビットマップイメージを作成します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public ImageSource GetBarCodeImage()
Visual Basic (宣言)
Public Function GetBarCodeImage As ImageSource

戻り値

このメソッドが作成する BitmapSource。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
// バーコードイメージを生成します。
ImageSource imgBarCode = barCodeControl1.GetBarCodeImage();
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
' バーコードイメージを生成します。
Dim imgBarCode As ImageSource = BarCodeControl1.GetBarCodeImage()

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


GetScaleSize メソッド

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..GetScaleSize メソッド
BarCodeControl クラス 使用例 参照
指定した単位でバーコードのサイズを取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public BarCodeSizeD GetScaleSize(
    Unit unit
)
Visual Basic (宣言)
Public Function GetScaleSize ( _
    unit As Unit _
) As BarCodeSizeD

パラメータ

unit
Type: AdvanceSoftware.VBBarCode..::..Unit
取得するサイズの単位を表す Unit 列挙体。

戻り値

バーコードのサイズ。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
AdvanceSoftware.VBBarCode.BarCodeSizeD barCodeSizeD;
// バーコードイメージのサイズを ミリ(mm) 単位で取得します。
barCodeSizeD = barCodeControl1.GetScaleSize(AdvanceSoftware.VBBarCode.Unit.Millimeter);
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
Dim BarCodeSizeD As AdvanceSoftware.VBBarCode.BarCodeSizeD
' バーコードイメージのサイズを ミリ(mm) 単位で取得します。
BarCodeSizeD = BarCodeControl1.GetScaleSize(AdvanceSoftware.VBBarCode.Unit.Millimeter)

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


InitializeComponent メソッド

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..InitializeComponent メソッド
BarCodeControl クラス 参照
InitializeComponent

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public void InitializeComponent()
Visual Basic (宣言)
Public Sub InitializeComponent

Implements

IComponentConnector..::..InitializeComponent()()()()

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Save メソッド

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Save メソッド
BarCodeControl クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | Save(Stream) | バーコードのイメージをビットマップ形式で保存します。
Public method | Save(String) | バーコードのイメージをビットマップ形式で保存します。

参照

BarCodeControl クラス
BarCodeControl メンバ
AdvanceSoftware.VBBarCode.Wpf 名前空間


Save メソッド (Stream)

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Save メソッド (Stream)
BarCodeControl クラス 使用例 参照
バーコードのイメージをビットマップ形式で保存します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool Save(
    Stream stream
)
Visual Basic (宣言)
Public Function Save ( _
    stream As Stream _
) As Boolean

パラメータ

stream
Type: System.IO..::..Stream
イメージが保存される Stream。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
// バーコードイメージを保存します。
FileStream fileStream = new FileStream(@"C:\BarCode.bmp", FileMode.Create);
barCodeControl1.Save(fileStream);
fileStream.Close();
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
' バーコードイメージを保存します。
Dim FileStream As FileStream = New FileStream("C:\BarCode.bmp", FileMode.Create)
BarCodeControl1.Save(FileStream)
FileStream.Close()

参照

BarCodeControl クラス
Save オーバーロード
AdvanceSoftware.VBBarCode.Wpf 名前空間


Save メソッド (String)

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Save メソッド (String)
BarCodeControl クラス 使用例 参照
バーコードのイメージをビットマップ形式で保存します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool Save(
    string fileName
)
Visual Basic (宣言)
Public Function Save ( _
    fileName As String _
) As Boolean

パラメータ

fileName
Type: System..::..String
バーコードイメージの保存先ファイル名を格納している文字列。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
// バーコードイメージを保存します。
barCodeControl1.Save(@"C:\BarCode.bmp");
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
' バーコードイメージを保存します。
BarCodeControl1.Save("C:\BarCode.bmp")

参照

BarCodeControl クラス
Save オーバーロード
AdvanceSoftware.VBBarCode.Wpf 名前空間


SaveSvg メソッド

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..SaveSvg メソッド
BarCodeControl クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | SaveSvg(Stream) | バーコードの SVG イメージを保存します。
Public method | SaveSvg(String) | バーコードの SVG イメージを保存します。

参照

BarCodeControl クラス
BarCodeControl メンバ
AdvanceSoftware.VBBarCode.Wpf 名前空間


SaveSvg メソッド (Stream)

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..SaveSvg メソッド (Stream)
BarCodeControl クラス 使用例 参照
バーコードの SVG イメージを保存します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool SaveSvg(
    Stream stream
)
Visual Basic (宣言)
Public Function SaveSvg ( _
    stream As Stream _
) As Boolean

パラメータ

stream
Type: System.IO..::..Stream
イメージが保存される Stream。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
// バーコードイメージを保存します。
FileStream fileStream = new FileStream(@"C:\BarCode.svg", FileMode.Create);
barCodeControl1.SaveSvg(fileStream);
fileStream.Close();
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
' バーコードイメージを保存します。
Dim FileStream As FileStream = New FileStream("C:\BarCode.svg", FileMode.Create)
BarCodeControl1.SaveSvg(FileStream)
FileStream.Close()

参照

BarCodeControl クラス
SaveSvg オーバーロード
AdvanceSoftware.VBBarCode.Wpf 名前空間


SaveSvg メソッド (String)

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..SaveSvg メソッド (String)
BarCodeControl クラス 使用例 参照
バーコードの SVG イメージを保存します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool SaveSvg(
    string fileName
)
Visual Basic (宣言)
Public Function SaveSvg ( _
    fileName As String _
) As Boolean

パラメータ

fileName
Type: System..::..String
バーコードイメージの保存先ファイル名を格納している文字列。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
// バーコードイメージを保存します。
barCodeControl1.SaveSvg(@"C:\BarCode.svg");
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
' バーコードイメージを保存します。
BarCodeControl1.SaveSvg("C:\BarCode.svg")

参照

BarCodeControl クラス
SaveSvg オーバーロード
AdvanceSoftware.VBBarCode.Wpf 名前空間


SaveSvgz メソッド

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..SaveSvgz メソッド
BarCodeControl クラス 参照

オーバーロードの一覧

 | 名前 | 説明
Public method | SaveSvgz(Stream) | バーコードの圧縮 SVG イメージを保存します。
Public method | SaveSvgz(String) | バーコードの圧縮 SVG イメージを保存します。

参照

BarCodeControl クラス
BarCodeControl メンバ
AdvanceSoftware.VBBarCode.Wpf 名前空間


SaveSvgz メソッド (Stream)

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..SaveSvgz メソッド (Stream)
BarCodeControl クラス 使用例 参照
バーコードの圧縮 SVG イメージを保存します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool SaveSvgz(
    Stream stream
)
Visual Basic (宣言)
Public Function SaveSvgz ( _
    stream As Stream _
) As Boolean

パラメータ

stream
Type: System.IO..::..Stream
イメージが保存される Stream。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
// バーコードイメージを保存します。
FileStream fileStream = new FileStream(@"C:\BarCode.svgz", FileMode.Create);
barCodeControl1.SaveSvgz(fileStream);
fileStream.Close();
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
' バーコードイメージを保存します。
Dim FileStream As FileStream = New FileStream("C:\BarCode.svgz", FileMode.Create)
BarCodeControl1.SaveSvgz(FileStream)
FileStream.Close()

参照

BarCodeControl クラス
SaveSvgz オーバーロード
AdvanceSoftware.VBBarCode.Wpf 名前空間


SaveSvgz メソッド (String)

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..SaveSvgz メソッド (String)
BarCodeControl クラス 使用例 参照
バーコードの圧縮 SVG イメージを保存します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool SaveSvgz(
    string fileName
)
Visual Basic (宣言)
Public Function SaveSvgz ( _
    fileName As String _
) As Boolean

パラメータ

fileName
Type: System..::..String
バーコードイメージの保存先ファイル名を格納している文字列。

戻り値

保存が成功した場合 true を返します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
// バーコードイメージを保存します。
barCodeControl1.SaveSvgz(@"C:\BarCode.svgz");
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
' バーコードイメージを保存します。
BarCodeControl1.SaveSvgz("C:\BarCode.svgz")

参照

BarCodeControl クラス
SaveSvgz オーバーロード
AdvanceSoftware.VBBarCode.Wpf 名前空間


BarCodeControl プロパティ

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeControl プロパティ
BarCodeControl クラス 参照

BarCodeControl データ型で公開されるメンバを以下に示します。

プロパティ

 | 名前 | 説明
Public property | _Type | バーコードの種類を設定、取得します。
Public property | _Unit | バーコードの生成単位を設定、取得します。
Public property | BackColor | バーコードシンボルの背景色を設定、取得します。
Public property | BarColor | バーの色を設定、取得します。
Public property | BarHeight | バーコードの高さを設定、取得します。
Public property | BarRatio | 太バーのエレメント率を設定、取得します。(Codabar、Code39)
Public property | BarWidth | バーコードの幅を設定、取得します。
Public property | BinaryValue | バーコードデータを設定、取得します。(バイナリ)
Public property | BlackBarRevision | 黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
Public property | BlackRatio | 黒バーの太さの比率を設定、取得します。
Public property | CharGap | キャラクタ間のギャップを設定、取得します。(Codabar、Code39)
Public property | CharSize | バーコードキャラクタのフォントサイズを設定、取得します。
Public property | CheckCharMode | 自動でチェックキャラクタを付加するかを設定、取得します。
Public property | CheckPattern | チェックデジットの計算方法を設定、取得します。(Codabar)
Public property | Codeset | スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))
Public property | DpiX | X 軸方向の解像度を設定、取得します。(ピクセル単位)
Public property | DpiY | Y 軸方向の解像度を設定、取得します。(ピクセル単位)
Public property | Element | 最小エレメント値を設定、取得します。
Public property | ErrorMessage | エラーメッセージを取得します。
Public property | ErrorNo | エラーナンバーを取得します。
Public property | FlatHeight | ガードバーの均等化を設定、取得します。(JAN、UPC)
Public property | Font | バーコードメッセージのフォント名を設定、取得します。
Public property | FontStyle | バーコードキャラクタのフォントスタイルを設定、取得します。
Public property | FontWeight | バーコードキャラクタのフォントウエイトを設定、取得します。
Public property | InternalQRVersion | QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。
Public property | InternalValue | 整形後のバーコードデータを取得します。
Public property | MessageAlign | バーコードメッセージの表示横位置を設定、取得します。(GS1Fixed)
Public property | PDFColumn | PDF417 の列数を設定、取得します。
Public property | PDFInitialSymbol | PDF417 の初期化シンボルを設定、取得します。
Public property | PDFLevel | PDF417 のエラー訂正レベルを設定、取得します。
Public property | PDFModel | PDF417 シンボルを設定、取得します。
Public property | PDFRatio | PDF417 の 1 モジュールの縦横比を設定、取得します。
Public property | PDFRow | PDF417 の行数を設定、取得します。
Public property | Point | ポイントを設定、取得します。(郵便カスタマバーコード)
Public property | QRConnect | 連結 QR コードを作成するかを設定、取得します。
Public property | QREscapeCode | QR コードのエスケープコードを設定、取得します。
Public property | QRLevel | QR コードの誤り訂正レベルを設定、取得します。
Public property | QRMask | QR コードのマスクパターンを設定、取得します。
Public property | QRModel | QR コードのモデルを設定、取得します。
Public property | QRSymbolNumber | 連結 QR コードで出力するシンボル番号を設定、取得します。
Public property | QRVersion | QR コードの型番を設定、取得します。
Public property | Quiet | 余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金代理収納 GS1-128)
Public property | RePaint | プロパティ変更時の再描画を行うかどうかを設定します。
Public property | Rotate | バーコードの回転方向を設定、取得します。
Public property | ShowBearer | ベアラバーを表示するかを設定、取得します。(ITF)
Public property | ShowMessage | バーコードメッセージを表示するかを設定、取得します。
Public property | StartChar | スタートキャラクタを設定、取得します。(Codabar)
Public property | StopChar | ストップキャラクタを設定、取得します。(Codabar)
Public property | Type | バーコードの種類を設定、取得します。
Public property | Unit | バーコードの生成単位を設定、取得します。
Public property | Value | バーコードデータを設定、取得します。(文字列)
Public property | WhiteBarRevision | 白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)
Public property | Zoom | 倍率を設定、取得します。(JAN、UPC、ITF)

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


_Type プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::.._Type プロパティ
BarCodeControl クラス 使用例 参照
バーコードの種類を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public BarCodeType _Type { get; set; }
Visual Basic (宣言)
Public Property _Type As BarCodeType
    Get
    Set

プロパティ値

バーコードのタイプを表す BarCodeType。(既定値：BarCodeType.JAN13)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
// 生成するバーコードイメージを "JAN13" に設定します。
barCodeControl1._Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
' 生成するバーコードイメージを "JAN13" に設定します。
BarCodeControl1._Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


_Unit プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::.._Unit プロパティ
BarCodeControl クラス 使用例 参照
バーコードの生成単位を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Unit _Unit { get; set; }
Visual Basic (宣言)
Public Property _Unit As Unit
    Get
    Set

プロパティ値

バーコードの生成単位を表す Unit。(既定値：Unit.Pixel)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCodeControl1._Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCodeControl1._Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BackColor プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..BackColor プロパティ
BarCodeControl クラス 使用例 参照
バーコードシンボルの背景色を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Color BackColor { get; set; }
Visual Basic (宣言)
Public Property BackColor As Color
    Get
    Set

プロパティ値

バーコードシンボルの背景色を表す Color。(既定値：Color.White)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの背景色を "赤色" に設定します。
barCodeControl1.BackColor = System.Windows.Media.Colors.Red;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの背景色を "赤色" に設定します。
BarCodeControl1.BackColor = System.Windows.Media.Colors.Red
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BarColor プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..BarColor プロパティ
BarCodeControl クラス 使用例 参照
バーの色を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Color BarColor { get; set; }
Visual Basic (宣言)
Public Property BarColor As Color
    Get
    Set

プロパティ値

バーの色を表す Color。(既定値：Color.Black)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーの色を "赤色" に設定します。
barCodeControl1.BarColor = System.Windows.Media.Colors.Red;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーの色を "赤色" に設定します。
BarCodeControl1.BarColor = System.Windows.Media.Colors.Red
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BarHeight プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..BarHeight プロパティ
BarCodeControl クラス 使用例 参照
バーコードの高さを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double BarHeight { get; set; }
Visual Basic (宣言)
Public Property BarHeight As Double
    Get
    Set

プロパティ値

バーコードの高さを表す double。(既定値：0.0)

解説

プロパティ値が 0 の場合、バーコードの高さは自動で設定されます。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードイメージの高さを "30.0mm" に設定します。
barCodeControl1.BarHeight = 30.0;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードイメージの高さを "30.0mm" に設定します。
BarCodeControl1.BarHeight = 30.0
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BarRatio プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..BarRatio プロパティ
BarCodeControl クラス 使用例 参照
太バーのエレメント率を設定、取得します。(Codabar、Code39)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double BarRatio { get; set; }
Visual Basic (宣言)
Public Property BarRatio As Double
    Get
    Set

プロパティ値

太バーのエレメント率を表す double。(既定値：2.0)

解説

設定範囲

最小エレメント値が 0.508mm 未満：2.2 ～ 3.0

最小エレメント値が 0.508mm 以上：2.0 ～ 3.0

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// 太バーのエレメント率を "2.5" に設定します。
barCodeControl1.BarRatio = 2.5;
barCodeControl1.Value = "1234567890";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' 太バーのエレメント率を "2.5" に設定します。
BarCodeControl1.BarRatio = 2.5
BarCodeControl1.Value = "1234567890"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BarWidth プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..BarWidth プロパティ
BarCodeControl クラス 使用例 参照
バーコードの幅を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double BarWidth { get; set; }
Visual Basic (宣言)
Public Property BarWidth As Double
    Get
    Set

プロパティ値

バーコードの幅を表す double。(既定値：0.0)

解説

プロパティ値が 0 の場合、バーコードの幅は自動で設定されます。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードイメージの幅を "60.0mm" に設定します。
barCodeControl1.BarWidth = 60.0;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードイメージの幅を "60.0mm" に設定します。
BarCodeControl1.BarWidth = 60.0
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BinaryValue プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..BinaryValue プロパティ
BarCodeControl クラス 使用例 参照
バーコードデータを設定、取得します。(バイナリ)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public byte[] BinaryValue { set; }
Visual Basic (宣言)
Public WriteOnly Property BinaryValue As Byte()
    Set

プロパティ値

バーコードデータを表す Byte。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// "12345ABCDE"
Byte[] btByte = new Byte[] { 49, 50, 51, 52, 53, 65, 66, 67, 68, 69 };
// バーコードデータを設定します。 (バイナリ)
barCodeControl1.BinaryValue = btByte;
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' "12345ABCDE"
Dim btByte() As Byte = New Byte() {49, 50, 51, 52, 53, 65, 66, 67, 68, 69}
' バーコードデータを設定します。 (バイナリ)
BarCodeControl1.BinaryValue = btByte

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BlackBarRevision プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..BlackBarRevision プロパティ
BarCodeControl クラス 使用例 参照
黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int BlackBarRevision { get; set; }
Visual Basic (宣言)
Public Property BlackBarRevision As Integer
    Get
    Set

プロパティ値

黒バーのドット補正値を表す int。(既定値：0)

解説

Unit プロパティの値が、Unit.Pixel の場合、有効になります。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 黒バーのドット補正値を "+2" に設定します。
barCodeControl1.BlackBarRevision = 2;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 黒バーのドット補正値を "+2" に設定します。
BarCodeControl1.BlackBarRevision = 2
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BlackRatio プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..BlackRatio プロパティ
BarCodeControl クラス 使用例 参照
黒バーの太さの比率を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int BlackRatio { get; set; }
Visual Basic (宣言)
Public Property BlackRatio As Integer
    Get
    Set

プロパティ値

黒バーの太さの比率を表す int。(既定値：100)

解説

設定範囲：50 ～ 150

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// 黒バーの太さ比率を "150%" に設定します。
barCodeControl1.BlackRatio = 150;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' 黒バーの太さ比率を "150%" に設定します。
BarCodeControl1.BlackRatio = 150
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


CharGap プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..CharGap プロパティ
BarCodeControl クラス 使用例 参照
キャラクタ間のギャップを設定、取得します。(Codabar、Code39)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double CharGap { get; set; }
Visual Basic (宣言)
Public Property CharGap As Double
    Get
    Set

プロパティ値

キャラクタ間のギャップを表す double。(既定値：0.0)

解説

プロパティ値が 0 の場合、キャラクタ間のギャップは自動で設定されます。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code39;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードキャラクタの間隔を "2.0mm" に設定します。
barCodeControl1.CharGap = 2.0;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code39
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードキャラクタの間隔を "2.0mm" に設定します。
BarCodeControl1.CharGap = 2.0
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


CharSize プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..CharSize プロパティ
BarCodeControl クラス 使用例 参照
バーコードキャラクタのフォントサイズを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double CharSize { get; set; }
Visual Basic (宣言)
Public Property CharSize As Double
    Get
    Set

プロパティ値

バーコードキャラクタのフォントサイズを表す double。(既定値：0.0)

解説

プロパティ値が 0 の場合、バーコードキャラクタのフォントサイズは自動で設定されます。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードメッセージのフォントサイズを "10.0" に設定します。
barCodeControl1.CharSize = 10.0;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードメッセージのフォントサイズを "10.0" に設定します。
BarCodeControl1.CharSize = 10.0
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


CheckCharMode プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..CheckCharMode プロパティ
BarCodeControl クラス 使用例 参照
自動でチェックキャラクタを付加するかを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool CheckCharMode { get; set; }
Visual Basic (宣言)
Public Property CheckCharMode As Boolean
    Get
    Set

プロパティ値

チェックキャラクタのモードを表す bool。(既定値：true)

解説

プロパティ値が true の場合、自動でチェックキャラクタを付加します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// チェックキャラクタを "付加しない" に設定します。
barCodeControl1.CheckCharMode = false;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' チェックキャラクタを "付加しない" に設定します。
BarCodeControl1.CheckCharMode = False
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


CheckPattern プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..CheckPattern プロパティ
BarCodeControl クラス 使用例 参照
チェックデジットの計算方法を設定、取得します。(Codabar)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public CheckPattern CheckPattern { get; set; }
Visual Basic (宣言)
Public Property CheckPattern As CheckPattern
    Get
    Set

プロパティ値

チェックデジットの計算方法を表す CheckPattern。(既定値：CheckPattern.Modulus16)

解説

CheckPattern.Modulus11(モジュラス 11) を設定した場合、計算に必要なバーコードメッセージは 6 桁以上必要になります。6 桁未満の場合は、Modulus10Weight3(モジュラス10 / ウエイト3) で計算されます。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// チェックデジットの計算方法を "モジュラス 11" に設定します。
barCodeControl1.CheckPattern = AdvanceSoftware.VBBarCode.CheckPattern.Modulus11;
barCodeControl1.Value = "12345678";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' チェックデジットの計算方法を "モジュラス 11" に設定します。
BarCodeControl1.CheckPattern = AdvanceSoftware.VBBarCode.CheckPattern.Modulus11
BarCodeControl1.Value = "12345678"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Codeset プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Codeset プロパティ
BarCodeControl クラス 使用例 参照
スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Codeset Codeset { get; set; }
Visual Basic (宣言)
Public Property Codeset As Codeset
    Get
    Set

プロパティ値

スタートコードセットを表す Codeset。(既定値：Codeset.CodesetAuto)

解説

プロパティ値が CodeSet.CodesetAuto の場合、バーコードデータの先頭の文字でコードセットが決まります。

先頭キャラクタが ~(チルダ) の場合、コードセットA に設定されます。

先頭キャラクタがアルファベットの場合、コードセットB に設定されます。

先頭から 2 キャラクタが数字の場合、コードセット C に設定されます。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128;
// Code128 を "コードセット B" に設定します。
barCodeControl1.Codeset = AdvanceSoftware.VBBarCode.Codeset.CodesetB;
barCodeControl1.Value = "abc123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128
' Code128 を "コードセット B" に設定します。
BarCodeControl1.Codeset = AdvanceSoftware.VBBarCode.Codeset.CodesetB
BarCodeControl1.Value = "abc123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


DpiX プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..DpiX プロパティ
BarCodeControl クラス 使用例 参照
X 軸方向の解像度を設定、取得します。(ピクセル単位)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double DpiX { get; set; }
Visual Basic (宣言)
Public Property DpiX As Double
    Get
    Set

プロパティ値

X 軸方向の解像度を表す double。(既定値：96.0)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// X 軸方向の解像度を "600dpi" に設定します。
barCodeControl1.DpiX = 600;
// Y 軸方向の解像度を "600dpi" に設定します。
barCodeControl1.DpiY = 600;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' X 軸方向の解像度を "600dpi" に設定します。
BarCodeControl1.DpiX = 600
' Y 軸方向の解像度を "600dpi" に設定します。
BarCodeControl1.DpiY = 600
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


DpiY プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..DpiY プロパティ
BarCodeControl クラス 使用例 参照
Y 軸方向の解像度を設定、取得します。(ピクセル単位)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double DpiY { get; set; }
Visual Basic (宣言)
Public Property DpiY As Double
    Get
    Set

プロパティ値

Y 軸方向の解像度を表す double。(既定値：96.0)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// X 軸方向の解像度を "600dpi" に設定します。
barCodeControl1.DpiX = 600;
// Y 軸方向の解像度を "600dpi" に設定します。
barCodeControl1.DpiY = 600;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' X 軸方向の解像度を "600dpi" に設定します。
BarCodeControl1.DpiX = 600
' Y 軸方向の解像度を "600dpi" に設定します。
BarCodeControl1.DpiY = 600
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Element プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Element プロパティ
BarCodeControl クラス 使用例 参照
最小エレメント値を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double Element { get; set; }
Visual Basic (宣言)
Public Property Element As Double
    Get
    Set

プロパティ値

最小エレメント値を表す double。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードイメージの最小エレメント値を "0.191mm" に設定します。
barCodeControl1.Element = 0.191;
barCodeControl1.Value = "1234567890";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードイメージの最小エレメント値を "0.191mm" に設定します。
BarCodeControl1.Element = 0.191
BarCodeControl1.Value = "1234567890"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


ErrorMessage プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..ErrorMessage プロパティ
BarCodeControl クラス 使用例 参照
エラーメッセージを取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public string ErrorMessage { get; }
Visual Basic (宣言)
Public ReadOnly Property ErrorMessage As String
    Get

プロパティ値

バーコード生成時のエラーメッセージを表す string。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
// エラー処理
if (barCodeControl1.ErrorNo != AdvanceSoftware.VBBarCode.ErrorNo.NoError)
{
    // エラーメッセージを表示します。
    MessageBox.Show(barCodeControl1.ErrorMessage);
}
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
' エラー処理
If BarCodeControl1.ErrorNo <> AdvanceSoftware.VBBarCode.ErrorNo.NoError Then
    ' エラーメッセージを表示します。
    MessageBox.Show(BarCodeControl1.ErrorMessage)
End If

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


ErrorNo プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..ErrorNo プロパティ
BarCodeControl クラス 使用例 参照
エラーナンバーを取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public ErrorNo ErrorNo { get; }
Visual Basic (宣言)
Public ReadOnly Property ErrorNo As ErrorNo
    Get

プロパティ値

バーコード生成時のエラーナンバーを表す ErrorNo。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
// エラー処理
if (barCodeControl1.ErrorNo != AdvanceSoftware.VBBarCode.ErrorNo.NoError)
{
    // エラーメッセージを表示します。
    MessageBox.Show(barCodeControl1.ErrorMessage);
}
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
' エラー処理
If BarCodeControl1.ErrorNo <> AdvanceSoftware.VBBarCode.ErrorNo.NoError Then
    ' エラーメッセージを表示します。
    MessageBox.Show(BarCodeControl1.ErrorMessage)
End If

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


FlatHeight プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..FlatHeight プロパティ
BarCodeControl クラス 使用例 参照
ガードバーの均等化を設定、取得します。(JAN、UPC)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool FlatHeight { get; set; }
Visual Basic (宣言)
Public Property FlatHeight As Boolean
    Get
    Set

プロパティ値

ガードバーの均等化を表す bool。(既定値：false)

解説

プロパティ値が true の場合、ガードバーを均等化します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// ガードバーの長さを均等に設定します。
barCodeControl1.FlatHeight = true;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' ガードバーの長さを均等に設定します。
BarCodeControl1.FlatHeight = True
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Font プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Font プロパティ
BarCodeControl クラス 使用例 参照
バーコードメッセージのフォント名を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public FontFamily Font { get; set; }
Visual Basic (宣言)
Public Property Font As FontFamily
    Get
    Set

プロパティ値

バーコードメッセージのフォントを表す Font。

解説

このプロパティは、バーコードメッセージのフォント名を設定することができます。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードメッセージのフォントを "ＭＳ 明朝" に設定します。
barCodeControl1.Font = new System.Windows.Media.FontFamily("ＭＳ 明朝");
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードメッセージのフォントを "ＭＳ 明朝" に設定します。
BarCodeControl1.Font = New System.Windows.Media.FontFamily("ＭＳ 明朝")
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


FontStyle プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..FontStyle プロパティ
BarCodeControl クラス 使用例 参照
バーコードキャラクタのフォントスタイルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public FontStyle FontStyle { get; set; }
Visual Basic (宣言)
Public Property FontStyle As FontStyle
    Get
    Set

プロパティ値

バーコードキャラクタのフォントスタイルを表す FontStyle。

解説

このプロパティは、バーコードキャラクタのフォントスタイルを設定することができます。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードメッセージのフォントスタイルを "斜体" に設定します。
barCodeControl1.FontStyle = System.Windows.FontStyles.Italic;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードメッセージのフォントスタイルを "斜体" に設定します。
BarCodeControl1.FontStyle = System.Windows.FontStyles.Italic
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


FontWeight プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..FontWeight プロパティ
BarCodeControl クラス 使用例 参照
バーコードキャラクタのフォントウエイトを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public FontWeight FontWeight { get; set; }
Visual Basic (宣言)
Public Property FontWeight As FontWeight
    Get
    Set

プロパティ値

バーコードキャラクタのフォントウエイトを表す FontWeight。

解説

このプロパティは、バーコードキャラクタのフォントウエイトを設定することができます。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードメッセージのフォントウエイトを "太字" に設定します。
barCodeControl1.FontWeight = System.Windows.FontWeights.Bold;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードメッセージのフォントウエイトを "太字" に設定します。
BarCodeControl1.FontWeight = System.Windows.FontWeights.Bold
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


InternalQRVersion プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..InternalQRVersion プロパティ
BarCodeControl クラス 使用例 参照
QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRVersion InternalQRVersion { get; }
Visual Basic (宣言)
Public ReadOnly Property InternalQRVersion As QRVersion
    Get

プロパティ値

QR コードの型番を表す QRVersion。

解説

プロパティ値が QRVersion.VersionAuto の場合、QR コードの型番は自動で設定されます。

QRModel プロパティの値により、QRVersion.VersionAuto 以外の設定範囲が異なります。

設定範囲(QRModel1)：QRVersion.QRVersion1 ～ QRVersion14

設定範囲(QRModel2)：QRVersion.QRVersion1 ～ QRVersion40

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
barCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.VersionAuto;
barCodeControl1.Value = "12345ABCDE";
ImageSource imgBarCode = barCodeControl1.GetBarCodeImage();
// 自動設定された QR コード の型番を取得します。
AdvanceSoftware.VBBarCode.QRVersion internalQRVersion = barCodeControl1.InternalQRVersion;
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
BarCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.VersionAuto
BarCodeControl1.Value = "12345ABCDE"
Dim imgBarCode As ImageSource = BarCodeControl1.GetBarCodeImage()
' 自動設定された QR コード の型番を取得します。
Dim internalQRVersion As AdvanceSoftware.VBBarCode.QRVersion = BarCodeControl1.InternalQRVersion

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


InternalValue プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..InternalValue プロパティ
BarCodeControl クラス 使用例 参照
整形後のバーコードデータを取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public string InternalValue { get; }
Visual Basic (宣言)
Public ReadOnly Property InternalValue As String
    Get

プロパティ値

整形後のバーコードデータを表す string。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
ImageSource imgBarCode = barCodeControl1.GetBarCodeImage();
// 整形後のバーコードデータを取得します。
string internalValue = barCodeControl1.InternalValue;
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"
Dim imgBarCode As ImageSource = BarCodeControl1.GetBarCodeImage()
' 整形後のバーコードデータを取得します。
Dim internalValue As String = BarCodeControl1.InternalValue

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


MessageAlign プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..MessageAlign プロパティ
BarCodeControl クラス 使用例 参照
バーコードメッセージの表示横位置を設定、取得します。(GS1Fixed)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public MessageAlign MessageAlign { get; set; }
Visual Basic (宣言)
Public Property MessageAlign As MessageAlign
    Get
    Set

プロパティ値

バーコードメッセージの表示横位置を表す MessageAlign。(既定値：MessageAlign.Center)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.GS1Fixed;
// バーコードメッセージの横位置を "左詰め" に設定します。(GS1Fixed)
barCodeControl1.MessageAlign = AdvanceSoftware.VBBarCode.MessageAlign.Left;
barCodeControl1.Value = "91012345678901234567890123456789012345678901";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.GS1Fixed
' バーコードメッセージの横位置を "左詰め" に設定します。(GS1Fixed)
BarCodeControl1.MessageAlign = AdvanceSoftware.VBBarCode.MessageAlign.Left
BarCodeControl1.Value = "91012345678901234567890123456789012345678901"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


PDFColumn プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..PDFColumn プロパティ
BarCodeControl クラス 使用例 参照
PDF417 の列数を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int PDFColumn { get; set; }
Visual Basic (宣言)
Public Property PDFColumn As Integer
    Get
    Set

プロパティ値

PDF417 の列数を表す int。(既定値：0)

解説

設定範囲：0 ～ 40

プロパティ値が 0 の場合、縦横比 1:2 で PDF417 を作成します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 の列数を "15列" に設定します。
barCodeControl1.PDFColumn = 15;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 の列数を "15列" に設定します。
BarCodeControl1.PDFColumn = 15
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


PDFInitialSymbol プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..PDFInitialSymbol プロパティ
BarCodeControl クラス 使用例 参照
PDF417 の初期化シンボルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool PDFInitialSymbol { get; set; }
Visual Basic (宣言)
Public Property PDFInitialSymbol As Boolean
    Get
    Set

プロパティ値

PDF417 の初期化シンボルを表す bool。(既定値：false)

解説

プロパティ値が true の場合、初期化シンボルを付加した PDF417 を作成します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 の初期化シンボルを "付加する" に設定します。
barCodeControl1.PDFInitialSymbol = true;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 の初期化シンボルを "付加する" に設定します。
BarCodeControl1.PDFInitialSymbol = True
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


PDFLevel プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..PDFLevel プロパティ
BarCodeControl クラス 使用例 参照
PDF417 のエラー訂正レベルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int PDFLevel { get; set; }
Visual Basic (宣言)
Public Property PDFLevel As Integer
    Get
    Set

プロパティ値

PDF417 のエラー訂正レベルを表す int。(既定値：0)

解説

設定範囲：0 ～ 8

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 のエラー訂正レベルを "レベル7" に設定します。
barCodeControl1.PDFLevel = 7;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 のエラー訂正レベルを "レベル7" に設定します。
BarCodeControl1.PDFLevel = 7
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


PDFModel プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..PDFModel プロパティ
BarCodeControl クラス 使用例 参照
PDF417 シンボルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public PDFModel PDFModel { get; set; }
Visual Basic (宣言)
Public Property PDFModel As PDFModel
    Get
    Set

プロパティ値

PDF417 シンボルを表す PDFModel。(既定値：PDFModel.Default)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 シンボルを "簡易 PDF417" に設定します。
barCodeControl1.PDFModel = AdvanceSoftware.VBBarCode.PDFModel.Truncated;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 シンボルを "簡易 PDF417" に設定します。
BarCodeControl1.PDFModel = AdvanceSoftware.VBBarCode.PDFModel.Truncated
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


PDFRatio プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..PDFRatio プロパティ
BarCodeControl クラス 使用例 参照
PDF417 の 1 モジュールの縦横比を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double PDFRatio { get; set; }
Visual Basic (宣言)
Public Property PDFRatio As Double
    Get
    Set

プロパティ値

PDF417 の 1 モジュールの縦横比を表す double。(既定値：7.5)

解説

設定範囲：1.0 ～ 10.0

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 の 1 モジュールの幅との縦横比を "5.0" に設定します。
barCodeControl1.PDFRatio = 5.0;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 の 1 モジュールの幅との縦横比を "5.0" に設定します。
BarCodeControl1.PDFRatio = 5.0
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


PDFRow プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..PDFRow プロパティ
BarCodeControl クラス 使用例 参照
PDF417 の行数を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int PDFRow { get; set; }
Visual Basic (宣言)
Public Property PDFRow As Integer
    Get
    Set

プロパティ値

PDF417 の行数を表す int。(既定値：0)

解説

設定範囲：0、3 ～ 90

プロパティ値が 0 の場合、縦横比 1:2 で PDF417 を作成します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417;
// PDF417 の行数を "10行" に設定します。
barCodeControl1.PDFRow = 10;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.PDF417
' PDF417 の行数を "10行" に設定します。
BarCodeControl1.PDFRow = 10
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Point プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Point プロパティ
BarCodeControl クラス 使用例 参照
ポイントを設定、取得します。(郵便カスタマバーコード)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double Point { get; set; }
Visual Basic (宣言)
Public Property Point As Double
    Get
    Set

プロパティ値

バーコードのポイントを表す double。(既定値：10.0)

解説

設定範囲：6.0 ～ 14.0

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.CustomerBarCode;
// 郵便カスタマバーコードのポイントを "10.0" に設定します。
barCodeControl1.Point = 10.0;
barCodeControl1.Value = "91882391-2816";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.CustomerBarCode
' 郵便カスタマバーコードのポイントを "10.0" に設定します。
BarCodeControl1.Point = 10.0
BarCodeControl1.Value = "91882391-2816"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


QRConnect プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..QRConnect プロパティ
BarCodeControl クラス 使用例 参照
連結 QR コードを作成するかを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRConnect QRConnect { get; set; }
Visual Basic (宣言)
Public Property QRConnect As QRConnect
    Get
    Set

プロパティ値

連結 QR コードの設定を表す QRConnect。(既定値：QRConnect.NotConnect)

解説

プロパティ値が QRConnect.AutoConnect、QRConnect.ManualConnect の場合、QRVersion プロパティを QRVersion.VersionAuto 以外に設定します。

また、QRConnect.ManualConnect の場合、QREscapeCode プロパティを使用して分割する位置のエスケープコードを設定します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10;
// QR コード を "連結 QR コード(手動)" に設定します。
barCodeControl1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect;
// QR コードのエスケープコードを "% (0x25)" に設定します。
barCodeControl1.QREscapeCode = 0x25;
barCodeControl1.Value = "12345%SABCDE";
// 連結 QR コードで出力するシンボル番号を "0" に設定します。
barCodeControl1.QRSymbolNumber = 0;
barCodeControl1.Save(@"C:\Barcode1.bmp");
// 連結 QR コードで出力するシンボル番号を "1" に設定します。
barCodeControl1.QRSymbolNumber = 1;
barCodeControl1.Save(@"C:\Barcode2.bmp");
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10
' QR コード を "連結 QR コード(手動)" に設定します。
BarCodeControl1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect
' QR コードのエスケープコードを "% (&H25)" に設定します。
BarCodeControl1.QREscapeCode = &H25
BarCodeControl1.Value = "12345%SABCDE"
' 連結 QR コードで出力するシンボル番号を "0" に設定します。
BarCodeControl1.QRSymbolNumber = 0
BarCodeControl1.Save("C:\Barcode1.bmp")
' 連結 QR コードで出力するシンボル番号を "1" に設定します。
BarCodeControl1.QRSymbolNumber = 1
BarCodeControl1.Save("C:\Barcode2.bmp")

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


QREscapeCode プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..QREscapeCode プロパティ
BarCodeControl クラス 使用例 参照
QR コードのエスケープコードを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public byte QREscapeCode { get; set; }
Visual Basic (宣言)
Public Property QREscapeCode As Byte
    Get
    Set

プロパティ値

QR コードのエスケープコードを表す Byte。(既定値：0x00)

解説

Value プロパティや、ValueB プロパティに設定するバーコードデータの分割する位置に、"エスケープコード" + "S" を設定します。バーコードデータにエスケープコードと同じ文字がある場合、バーコードメッセージ側の該当する文字を二つ連続して設定してください。

このプロパティは、QRConnect プロパティの値が、QRConnect.ManualConnect の場合に有効です。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10;
// QR コード を "連結 QR コード(手動)" に設定します。
barCodeControl1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect;
// QR コードのエスケープコードを "% (0x25)" に設定します。
barCodeControl1.QREscapeCode = 0x25;
barCodeControl1.Value = "12345%SABCDE";
// 連結 QR コードで出力するシンボル番号を "0" に設定します。
barCodeControl1.QRSymbolNumber = 0;
barCodeControl1.Save(@"C:\Barcode1.bmp");
// 連結 QR コードで出力するシンボル番号を "1" に設定します。
barCodeControl1.QRSymbolNumber = 1;
barCodeControl1.Save(@"C:\Barcode2.bmp");
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10
' QR コード を "連結 QR コード(手動)" に設定します。
BarCodeControl1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect
' QR コードのエスケープコードを "% (&H25)" に設定します。
BarCodeControl1.QREscapeCode = &H25
BarCodeControl1.Value = "12345%SABCDE"
' 連結 QR コードで出力するシンボル番号を "0" に設定します。
BarCodeControl1.QRSymbolNumber = 0
BarCodeControl1.Save("C:\Barcode1.bmp")
' 連結 QR コードで出力するシンボル番号を "1" に設定します。
BarCodeControl1.QRSymbolNumber = 1
BarCodeControl1.Save("C:\Barcode2.bmp")

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


QRLevel プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..QRLevel プロパティ
BarCodeControl クラス 使用例 参照
QR コードの誤り訂正レベルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRLevel QRLevel { get; set; }
Visual Basic (宣言)
Public Property QRLevel As QRLevel
    Get
    Set

プロパティ値

QR コードの誤り訂正レベルを表す QRLevel。(既定値：QRLevel.LevelM)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードのエラー訂正レベルを "H" に設定します。
barCodeControl1.QRLevel = AdvanceSoftware.VBBarCode.QRLevel.LevelH;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードのエラー訂正レベルを "H" に設定します。
BarCodeControl1.QRLevel = AdvanceSoftware.VBBarCode.QRLevel.LevelH
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


QRMask プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..QRMask プロパティ
BarCodeControl クラス 使用例 参照
QR コードのマスクパターンを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRMask QRMask { get; set; }
Visual Basic (宣言)
Public Property QRMask As QRMask
    Get
    Set

プロパティ値

QR コードのマスクパターンを表す QRMask。(既定値：QRMask.MaskAuto)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
barCodeControl1.QRMask = AdvanceSoftware.VBBarCode.QRMask.Mask000;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
BarCodeControl1.QRMask = AdvanceSoftware.VBBarCode.QRMask.Mask000
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


QRModel プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..QRModel プロパティ
BarCodeControl クラス 使用例 参照
QR コードのモデルを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRModel QRModel { get; set; }
Visual Basic (宣言)
Public Property QRModel As QRModel
    Get
    Set

プロパティ値

QR コードのモデルを表す QRModel。(既定値：QRModel.Model1)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードのモデルを "モデル 2" に設定します。
barCodeControl1.QRModel = AdvanceSoftware.VBBarCode.QRModel.Model2;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードのモデルを "モデル 2" に設定します。
BarCodeControl1.QRModel = AdvanceSoftware.VBBarCode.QRModel.Model2
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


QRSymbolNumber プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..QRSymbolNumber プロパティ
BarCodeControl クラス 使用例 参照
連結 QR コードで出力するシンボル番号を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int QRSymbolNumber { get; set; }
Visual Basic (宣言)
Public Property QRSymbolNumber As Integer
    Get
    Set

プロパティ値

連結 QR コードのシンボル番号を表す int。(既定値：0)

解説

設定範囲：0 ～ 15

このプロパティは、QRConnect プロパティの値が、QRConnect.AutoConnect、QRConnect.ManualConnect の場合に有効です。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10;
// QR コード を "連結 QR コード(手動)" に設定します。
barCodeControl1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect;
// QR コードのエスケープコードを "% (0x25)" に設定します。
barCodeControl1.QREscapeCode = 0x25;
barCodeControl1.Value = "12345%SABCDE";
// 連結 QR コードで出力するシンボル番号を "0" に設定します。
barCodeControl1.QRSymbolNumber = 0;
barCodeControl1.Save(@"C:\Barcode1.bmp");
// 連結 QR コードで出力するシンボル番号を "1" に設定します。
barCodeControl1.QRSymbolNumber = 1;
barCodeControl1.Save(@"C:\Barcode2.bmp");
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10
' QR コード を "連結 QR コード(手動)" に設定します。
BarCodeControl1.QRConnect = AdvanceSoftware.VBBarCode.QRConnect.ManualConnect
' QR コードのエスケープコードを "% (&H25)" に設定します。
BarCodeControl1.QREscapeCode = &H25
BarCodeControl1.Value = "12345%SABCDE"
' 連結 QR コードで出力するシンボル番号を "0" に設定します。
BarCodeControl1.QRSymbolNumber = 0
BarCodeControl1.Save("C:\Barcode1.bmp")
' 連結 QR コードで出力するシンボル番号を "1" に設定します。
BarCodeControl1.QRSymbolNumber = 1
BarCodeControl1.Save("C:\Barcode2.bmp")

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


QRVersion プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..QRVersion プロパティ
BarCodeControl クラス 使用例 参照
QR コードの型番を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public QRVersion QRVersion { get; set; }
Visual Basic (宣言)
Public Property QRVersion As QRVersion
    Get
    Set

プロパティ値

QR コードの型番を表す QRVersion。(既定値：QRVersion.VersionAuto)

解説

プロパティ値が QRVersion.VersionAuto の場合、QR コードの型番は自動で設定されます。

QRModel プロパティの値により、QRVersion.VersionAuto 以外の設定範囲が異なります。

設定範囲(QRModel1)：QRVersion.QRVersion1 ～ QRVersion14

設定範囲(QRModel2)：QRVersion.QRVersion1 ～ QRVersion40

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCodeControl1.QRVersion = AdvanceSoftware.VBBarCode.QRVersion.Version10
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Quiet プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Quiet プロパティ
BarCodeControl クラス 使用例 参照
余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金代理収納 GS1-128)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public double Quiet { get; set; }
Visual Basic (宣言)
Public Property Quiet As Double
    Get
    Set

解説

プロパティ値が 0 の場合、バーコードの余白は自動で設定されます。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
// バーコードイメージの余白幅を "2.5mm" に設定します。
barCodeControl1.Quiet = 2.5;
barCodeControl1.Value = "1234567890";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
' バーコードイメージの余白幅を "2.5mm" に設定します。
BarCodeControl1.Quiet = 2.5
BarCodeControl1.Value = "1234567890"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


RePaint プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..RePaint プロパティ
BarCodeControl クラス 使用例 参照
プロパティ変更時の再描画を行うかどうかを設定します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool RePaint { set; }
Visual Basic (宣言)
Public WriteOnly Property RePaint As Boolean
    Set

プロパティ値

プロパティ変更時に再描画を行うかを表す bool。(既定値：true)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
// プロパティ変更時に再描画を行わないように設定します。
barCodeControl1.RePaint = false;
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
' プロパティ変更時に再描画を行わないように設定します。
BarCodeControl1.RePaint = False
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Rotate プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Rotate プロパティ
BarCodeControl クラス 使用例 参照
バーコードの回転方向を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Rotate Rotate { get; set; }
Visual Basic (宣言)
Public Property Rotate As Rotate
    Get
    Set

プロパティ値

バーコードの回転方向を表す Rotate。(既定値：Rotate.Rotate0)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの向きを "時計回りで 90 度回転" に設定します。
barCodeControl1.Rotate = AdvanceSoftware.VBBarCode.Rotate.Rotate90;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの向きを "時計回りで 90 度回転" に設定します。
BarCodeControl1.Rotate = AdvanceSoftware.VBBarCode.Rotate.Rotate90
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


ShowBearer プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..ShowBearer プロパティ
BarCodeControl クラス 使用例 参照
ベアラバーを表示するかを設定、取得します。(ITF)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool ShowBearer { get; set; }
Visual Basic (宣言)
Public Property ShowBearer As Boolean
    Get
    Set

プロパティ値

ベアラバーの表示モードを表す bool。(既定値：true)

解説

プロパティ値が true の場合、ベアラバーを表示します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.ITF16;
// ITF16 のベアラバーを "表示しない" に設定します。
barCodeControl1.ShowBearer = false;
barCodeControl1.Value = "1234567890123456";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.ITF16
' ITF16 のベアラバーを "表示しない" に設定します。
BarCodeControl1.ShowBearer = False
BarCodeControl1.Value = "1234567890123456"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


ShowMessage プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..ShowMessage プロパティ
BarCodeControl クラス 使用例 参照
バーコードメッセージを表示するかを設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public bool ShowMessage { get; set; }
Visual Basic (宣言)
Public Property ShowMessage As Boolean
    Get
    Set

プロパティ値

バーコードメッセージの表示モードを表す bool。(既定値：true)

解説

プロパティ値が true の場合、バーコードメッセージを表示します。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードメッセージを "表示しない" に設定します。
barCodeControl1.ShowMessage = false;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードメッセージを "表示しない" に設定します。
BarCodeControl1.ShowMessage = False
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


StartChar プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..StartChar プロパティ
BarCodeControl クラス 使用例 参照
スタートキャラクタを設定、取得します。(Codabar)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public char StartChar { get; set; }
Visual Basic (宣言)
Public Property StartChar As Char
    Get
    Set

プロパティ値

スタートキャラクタを表す char。(既定値：'a')

解説

設定可能な値：'a'、'b'、'c'、'd'、't'、'n'、'*'、'e'、'A'、'B'、'C'、'D'

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// Codabar のスタートキャラクタを "c" に設定します。
barCodeControl1.StartChar = 'c';
barCodeControl1.Value = "1234567890";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' Codabar のスタートキャラクタを "c" に設定します。
BarCodeControl1.StartChar = "c"
BarCodeControl1.Value = "1234567890"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


StopChar プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..StopChar プロパティ
BarCodeControl クラス 使用例 参照
ストップキャラクタを設定、取得します。(Codabar)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public char StopChar { get; set; }
Visual Basic (宣言)
Public Property StopChar As Char
    Get
    Set

プロパティ値

ストップキャラクタを表す char。(既定値：'a')

解説

設定可能な値：'a'、'b'、'c'、'd'、't'、'n'、'*'、'e'、'A'、'B'、'C'、'D'

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar;
// Codabar のストップキャラクタを "c" に設定します。
barCodeControl1.StopChar = 'c';
barCodeControl1.Value = "1234567890";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Codabar
' Codabar のストップキャラクタを "c" に設定します。
BarCodeControl1.StopChar = "c"
BarCodeControl1.Value = "1234567890"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Type プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Type プロパティ
BarCodeControl クラス 使用例 参照
バーコードの種類を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public BarCodeType Type { get; set; }
Visual Basic (宣言)
Public Property Type As BarCodeType
    Get
    Set

プロパティ値

バーコードのタイプを表す BarCodeType。(既定値：BarCodeType.JAN13)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
// 生成するバーコードイメージを "JAN13" に設定します。
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
' 生成するバーコードイメージを "JAN13" に設定します。
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Unit プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Unit プロパティ
BarCodeControl クラス 使用例 参照
バーコードの生成単位を設定、取得します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public Unit Unit { get; set; }
Visual Basic (宣言)
Public Property Unit As Unit
    Get
    Set

プロパティ値

バーコードの生成単位を表す Unit。(既定値：Unit.Pixel)

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Millimeter
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Value プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Value プロパティ
BarCodeControl クラス 使用例 参照
バーコードデータを設定、取得します。(文字列)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public string Value { get; set; }
Visual Basic (宣言)
Public Property Value As String
    Get
    Set

プロパティ値

バーコードデータを表す string。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードデータを設定します。 (文字列)
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードデータを設定します。 (文字列)
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


WhiteBarRevision プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..WhiteBarRevision プロパティ
BarCodeControl クラス 使用例 参照
白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金代理収納 GS1-128)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int WhiteBarRevision { get; set; }
Visual Basic (宣言)
Public Property WhiteBarRevision As Integer
    Get
    Set

プロパティ値

白バーのドット補正値を表す int。(既定値：0)

解説

Unit プロパティの値が、Unit.Pixel の場合、有効になります。

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128;
barCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel;
// 白バーのドット補正値を "+2" に設定します。
barCodeControl1.WhiteBarRevision = 2;
barCodeControl1.Value = "12345ABCDE";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.Code128
BarCodeControl1.Unit = AdvanceSoftware.VBBarCode.Unit.Pixel
' 白バーのドット補正値を "+2" に設定します。
BarCodeControl1.WhiteBarRevision = 2
BarCodeControl1.Value = "12345ABCDE"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Zoom プロパティ

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Zoom プロパティ
BarCodeControl クラス 使用例 参照
倍率を設定、取得します。(JAN、UPC、ITF)

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public int Zoom { get; set; }
Visual Basic (宣言)
Public Property Zoom As Integer
    Get
    Set

プロパティ値

バーコードの倍率を表す int。(既定値：100)

解説

設定範囲(JAN、UPC)：50 ～ 200

設定範囲(ITF)：25 ～ 120

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
barCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13;
// バーコードイメージの表示倍率を "200%" に設定します。
barCodeControl1.Zoom = 200;
barCodeControl1.Value = "1234567890123";
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成
BarCodeControl1 = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
BarCodeControl1.Type = AdvanceSoftware.VBBarCode.BarCodeType.JAN13
' バーコードイメージの表示倍率を "200%" に設定します。
BarCodeControl1.Zoom = 200
BarCodeControl1.Value = "1234567890123"

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


BarCodeControl イベント

[image] [image]

VB-BarCode 5.0 for .NET
BarCodeControl イベント
BarCodeControl クラス 参照

BarCodeControl データ型で公開されるメンバを以下に示します。

イベント

 | 名前 | 説明
Public event | Error | バーコードの作成に失敗した時に発生します。

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


Error イベント

[image]

VB-BarCode 5.0 for .NET
BarCodeControl..::..Error イベント
BarCodeControl クラス 使用例 参照
バーコードの作成に失敗した時に発生します。

名前空間: AdvanceSoftware.VBBarCode.Wpf
アセンブリ: VBBarCode.Wpf.BarCode.v5 (VBBarCode.Wpf.BarCode.v5.dll 内) バージョン: 5.0.5270.1008 (5.0.5270.1008)

構文

C#
public event BarCodeErrorEventHandler Error
Visual Basic (宣言)
Public Event Error As BarCodeErrorEventHandler

使用例

コピーC#
// バーコードコントロールクラスのインスタンス生成
private AdvanceSoftware.VBBarCode.Wpf.BarCodeControl barCodeControl1 = new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl();
private void InitializeComponent()
{
    // バーコードクラスのエラーイベントに barCode1_Error メソッドを関連付け
    this.barCodeControl1.Error += new AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.BarCodeErrorEventHandler(barCodeControl1_Error);
}
// バーコードクラスのエラーイベント
private void barCodeControl1_Error(object sender, AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.BarCodeErrorEventArgs e)
{
    MessageBox.Show(barCodeControl1.ErrorMessage);
}
コピーVB.NET
' バーコードコントロールクラスのインスタンス生成 (WithEvents)
Private WithEvents BarCodeControl1 As AdvanceSoftware.VBBarCode.Wpf.BarCodeControl = New AdvanceSoftware.VBBarCode.Wpf.BarCodeControl()
' バーコードクラスのエラーイベント
Private Sub BarCodeControl1_Error(ByVal sender As Object, ByVal e As AdvanceSoftware.VBBarCode.Wpf.BarCodeControl.BarCodeErrorEventArgs) Handles BarCodeControl1.Error
    MessageBox.Show(BarCodeControl1.ErrorMessage)
End Sub

参照

BarCodeControl クラス
AdvanceSoftware.VBBarCode.Wpf 名前空間


VB-BarCode 5.0 for .NET の概要

[image]

VB-BarCode 5.0 for .NET
VB-BarCode 5.0 for .NET の概要

VB-BarCode 5.0 for .NET は、.NET Framework に完全対応した高精度バーコード生成コンポーネントです。 100 % マネージコードで実装したコンパクトなコンポーネントなので、Windows フォームアプリケーションや ASP.NET Web、WPF アプリケーションなどで、簡単にバーコードを追加して高精度なイメージを出力することができます。新たに SVG 形式のバーコード出力にも対応しております。

システム動作環境

VB-BarCode 5.0 for .NET の動作環境を説明します。

製品のインストールとアンインストール

VB-BarCode 5.0 for .NET のインストールとアンインストールする方法を説明します。

体験版について

VB-BarCode 5.0 for .NET の体験版について説明します。

アプリケーションのライセンス体系

VB-BarCode 5.0 for .NET のライセンス体系を説明します。

サポートサービス

VB-BarCode 5.0 for .NET のサポートサービスを説明します。

サンプル

VB-BarCode 5.0 for .NET の付属サンプルの格納先を説明します。

VB-BarCode 5.0 for .NET ヘルプ フィードバック

このヘルプについてのご提案や障害報告をお送りいただく場合は、弊社 Web サイトのユーザーサポートフォームよりご連絡ください。

  • ドキュメントに表記されている会社名、製品名は一般に各社の商標または登録商標です。
  • 製品の仕様は品質改良の為、予告なく変更することがあります。