ExcelCreator 12.0 for .NET の概要

ExcelCreator 12.0 for .NET は、プログラム上で Excel ファイルを高速に生成する「Excel ファイル生成ツール」です。独自の技術で Excel ファイルを生成するため、動作環境に Excel のインストールは不要です。.NET 6 / 8 対応により、Windows の他、Linux 上での動作にも対応し、サーバーやクラウド環境で Excel/PDF/HTML ファイルをダイレクトに生成するアプリケーションを構築できます。

システム動作環境

ExcelCreator 12.0 for .NET の動作環境を説明します。

体験版について

体験版について説明します。

ライセンスファイルを指定する

体験版から製品版へ移行するためのライセンスファイルの指定方法を説明します。

製品のインストールとアンインストール

製品のインストールとアンインストールをする方法を説明します。

アプリケーションの配布

アプリケーションを配布する方法を説明します。

ライセンス体系

ExcelCreator 12.0 for .NET のライセンス体系について説明します。

サポートサービス

ExcelCreator 12.0 for .NET のサポートサービスについて説明します。

サンプル

ExcelCreator 12.0 for .NET のサンプルプログラムの格納場所について説明します。

ExcelCreator 12.0 for .NET ヘルプ フィードバック

このヘルプについてのご提案や障害報告をお送りいただく場合は、弊社 Web サイトの「ユーザーサポートフォーム」よりご連絡ください。

  • ドキュメントに表記されている会社名、製品名は一般に各社の商標または登録商標です。
  • 製品の仕様は品質改良の為、予告なく変更することがあります。

© 2025 Advance Software Co., Ltd. All Rights Reserved.


システム動作環境

ExcelCreator 12.0 for .NET の動作環境は以下の通りです。

このトピックは、次のセクションを含みます。

  • システム動作環境
  • 参照
システム動作環境 (※1)
OS (※2) | Windows 10/11 Windows Server 2016/2019/2022 Red Hat Enterprise Linux 8.x/9.x (※4) Ubuntu (※4)
開発ツール | Visual Studio 2019/2022
開発言語 | Visual C#、Visual Basic .NET
フレームワーク | .NET 6 / 8 .NET Framework 4.6.2 ～ 4.8.1
Excel バージョン (※3) | Excel 2003/2007/2010/2013/2016/2019/2021
Note メモ:

(※1) 日本語版環境でのみ動作保証を行っております。

(※2) 開発環境は Windows のみ動作保証を行っております。

(※3) xls, xlsx形式の Excel ファイルに対応しております。Excel 2007 以降の互換モードで作成された xls 形式には対応しておりません。

(※4) .NET プロジェクトのみ動作に対応
参照
ExcelCreator 12.0 for .NET の概要


体験版について

ExcelCreator 12.0 for .NET は、製品版と同様に全ての機能をお試しいただくことが可能な体験版をご用意しております。このトピックでは、体験版について説明します。

このトピックは、次のセクションを含みます。

  • 体験版のダウンロード先
  • 体験版の制限事項
  • 体験版を製品版に移行する
  • 参照
体験版のダウンロード先

ExcelCreator 12.0 for .NET 体験版は、弊社 Web サイトの「ダウンロードコーナー」または「nuget.org」から入手できます。

Note 注意:

製品 CD-ROM からインストールした場合でも、後述の製品版への移行手順を行わない限り体験版として動作します。
体験版の制限事項

体験版では、以下の制限があります。

  • Excel、PDF ファイルを作成すると、作成されたブックに体験版であることをあらわすメッセージ文字列が設定されたシートが末尾に追加され、アクティブシートとなります。
  • Excel、PDF ファイルを作成すると、作成されたブックの全シートのフッターに体験版であることをあらわすメッセージ文字列が出力されます。
  • HTML ファイルを作成すると、作成されたファイルのページ下部に体験版であることをあらわすメッセージ文字列が出力されます。
  • 体験版として動作させる場合、DLL は実行環境での動作検証以外の目的で配布することはできません。
体験版を製品版に移行する

ExcelCreator 12.0 for .NET は、ライセンスファイルを読み込むことで製品版に移行することが可能です。nuget.org からのダウンロードおよび、購入した CD-ROM のインストーラーからインストールした場合でも、ライセンスファイルを読み込まない限りは体験版として動作します。体験版から製品版に移行する手順は以下の通りです。

  1. 「ExcelCreator 12」を購入します。「ExcelCreator 12」を購入した際、8 桁のシリアルナンバーが発行されます。

    Note メモ:

    「ExcelCreator 12」 は、ExcelCreator 12.0 for .NET を収録したパッケージの名称です。製品の購入に関するご質問は、「サポートサービス」をご参照ください。

  2. 手順 1 で発行されたシリアルナンバーを確認の上、弊社 Web サイトの「ライセンス手続き」から申請し、ライセンスファイルを入手します。

  3. CD-ROM から ExcelCreator 12.0 for .NET をインストールします。(※既に体験版をインストールしている場合は不要です。)

  4. ExcelCreator 12.0 for .NET を使用するプロジェクトのソースコード上でライセンスファイルを指定して実行すると、製品版として動作します。ソースコード上での指定方法は、「ライセンスファイルを指定する」をご参照ください。

参照
ExcelCreator 12.0 for .NET の概要
ライセンスファイルを指定する


ライセンスファイルを指定する

ExcelCreator 12.0 for .NET では、製品 CD-ROM からインストールした場合でも製品版として動作させるにはライセンスファイルを指定する必要があります。ここでは、ライセンスファイルの指定方法を説明します。

このトピックは、次のセクションを含みます。

  • ライセンスファイルの注意事項
  • ライセンスファイルをファイルパスで指定する
  • ライセンスファイルを埋め込みリソースで指定する
  • 参照
Note メモ:
  • ライセンスファイルの指定をする場合、「使用準備」の手順をもとにプロジェクトに ExcelCreator 12.0 for .NET を追加してください。
  • ライセンスファイルの申請は、弊社 Web サイトの「ライセンス手続き」から行うことができます。
ライセンスファイルの注意事項

ライセンスファイルには、以下の注意事項があります。

  • ライセンスファイルを指定しない場合、ExcelCreator 12.0 for .NET は体験版として動作します。
  • ライセンスファイルを、第三者に再使用権を許諾したり、譲渡、移転することはできません。
  • ライセンスファイルは、流出、紛失しないよう大切に保管してください。
  • ライセンスファイルは、編集すると正しく動作しません。編集せずにそのまま使用してください。
ライセンスファイルをファイルパスで指定する

次のコードは、Creator.SetLicense メソッドでライセンスファイル(AdvanceSoftware.ExcelCreator12.License.xml)の物理ファイルパスを指定するサンプルコードです。

C#
VB
コピー
// C:\Data フォルダに配置したライセンスファイルの物理パスを指定します。
creator1.SetLicense("C:\\Data\AdvanceSoftware.ExcelCreator12.License.xml");
creator1.OpenBook("C:\\Data\\Out.xlsx","C:\\Data\\Template.xlsx");
creator1.CloseBook(true);
' C:\Data フォルダに配置したライセンスファイルの物理パスを指定します。
Creator1.SetLicense("C:\Data\AdvanceSoftware.ExcelCreator12.License.xml")
Creator1.OpenBook("C:\Data\Out.xlsx","C:\Data\Template.xlsx")
Creator1.CloseBook(True)
Note メモ:

SetLicense メソッドはコンポーネントのインスタンスに対し 1 回のみ実行し、ファイル作成処理ごとに毎回実行する必要はありません。
ライセンスファイルを埋め込みリソースで指定する

  1. プロジェクトを開き、[プロジェクト] メニューの [既存項目の追加] を選択します。

  2. [既存項目の追加] ダイアログより、ライセンスファイル(AdvanceSoftware.ExcelCreator12.License.xml)を選択して、[追加] ボタンをクリックします。

  3. ソリューション エクスプローラから追加したライセンスファイルが、プロジェクトに登録されていることを確認します。

  4. 引き続き、ソリューション エクスプローラから追加したライセンスファイルを選択し、[プロパティ] ウィンドウの [ビルドアクション] を「埋め込まれたリソース」に変更します。

  5. 以上でプロジェクトへの登録は完了です。下記のサンプルコードにて対応してください。

  6. 次のコードは、埋め込みリソースとしてプロジェクトに埋め込んだライセンスファイル(AdvanceSoftware.ExcelCreator12.License.xml)を指定するサンプルコードです。

    7. C#
    VB
    コピー
    // ソリューション名は「WinFormsApp1」とします。
System.Reflection.Assembly myAssembly = System.Reflection.Assembly.GetExecutingAssembly();
System.IO.Stream tempStreamLicense = myAssembly.GetManifestResourceStream("WinFormsApp1.AdvanceSoftware.ExcelCreator12.License.xml");
// 埋め込まれたライセンスファイルを指定します。
creator1.SetLicense(tempStreamLicense);
creator1.OpenBook("C:\\Data\\Out.xlsx","C:\\Data\\Template.xlsx");
creator1.CloseBook(true);
    ' ソリューション名は「WinFormsApp1」とします。
Dim myAssembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
Dim tempStreamLicense As System.IO.Stream = myAssembly.GetManifestResourceStream("WinFormsApp1.AdvanceSoftware.ExcelCreator12.License.xml")
' 埋め込まれたライセンスファイルを指定します。
Creator1.SetLicense(tempStreamLicense)
Creator1.OpenBook("C:\Data\Out.xlsx","C:\Data\Template.xlsx")
Creator1.CloseBook(True)
    Note メモ:

    SetLicense メソッドはコンポーネントのインスタンスに対し 1 回のみ実行し、ファイル作成処理ごとに毎回実行する必要はありません。
参照
ExcelCreator 12.0 for .NET の概要
体験版について


製品のインストールとアンインストール

ExcelCreator 12.0 for .NET のインストーラーでインストールされるパッケージファイル一覧、および、アンインストール方法を説明します。

このトピックは、次のセクションを含みます。

  • 製品のパッケージファイル一覧
  • 製品のアンインストール
  • 参照
製品のパッケージファイル一覧

ExcelCreator 12.0 for .NET のインストールプログラムによってインストールされるパッケージファイルの一覧を以下に記載します。

パッケージファイル名

AdvanceSoftware.ExcelCreator.BarCode.12.X.X.nupkg

AdvanceSoftware.ExcelCreator.Creator.12.X.X.nupkg

AdvanceSoftware.ExcelCreator.Document.12.X.X.nupkg

AdvanceSoftware.ExcelCreator.Html.Creator.12.X.X.nupkg

AdvanceSoftware.ExcelCreator.Pdf.Creator.12.X.X.nupkg

AdvanceSoftware.ExcelCreator.Shared.12.X.X.nupkg

AdvanceSoftware.ExcelCreator.View.12.X.X.nupkg

AdvanceSoftware.ExcelCreator.Xls.Core.12.X.X.nupkg

AdvanceSoftware.ExcelCreator.Xlsx.Core.12.X.X.nupkg

AdvanceSoftware.ExcelCreator.Xlsx.CreatorExpress.12.X.X.nupkg

Note メモ:

12.X.X の X 部分は、製品バージョンごとで異なります。
製品のアンインストール

ExcelCreator 12.0 for .NET をアンインストールする場合、下記のいずれかの手順で対応してください。

スタートメニューからアンインストールするには

  1. [スタート] のプログラム一覧から [ExcelCreator 12.0 for .NET] - [アンインストール] をクリックします。

  2. 画面に従い、アンインストールを実行します。

「アプリと機能」からアンインストールするには

  1. [スタート] - [設定] - [アプリ] をクリックします。

  2. [アプリと機能] 一覧の [ExcelCreator 12.0 for .NET] をクリックして [アンインストール] をクリックします。

  3. 画面に従い、アンインストールを実行します。

参照
ExcelCreator 12.0 for .NET の概要


アプリケーションの配布

ExcelCreator 12.0 for .NET を使用して作成したアプリケーションを配布する場合、再配布可能ファイルをアプリケーションと一緒に配布してください。このトピックでは、アプリケーションの配布について説明します。

このトピックは、次のセクションを含みます。

  • 再配布可能ファイル一覧
  • 再配布可能ファイルの配布
  • 再配布の条件
  • 参照
再配布可能ファイル一覧

ExcelCreator 12.0 for .NET の再配布可能ファイルは以下の通りです。

ファイル名 | 内容
AdvanceSoftware.ExcelCreator.BarCode.dll | BarCode コンポーネント
AdvanceSoftware.ExcelCreator.Creator.dll | Creator コンポーネント
AdvanceSoftware.ExcelCreator.Document.dll | ドキュメントクラス
AdvanceSoftware.ExcelCreator.Html.Creator.dll | HTML 生成クラス
AdvanceSoftware.ExcelCreator.Pdf.Creator.dll | PDF 生成クラス
AdvanceSoftware.ExcelCreator.Shared.dll | 共有クラス
AdvanceSoftware.ExcelCreator.View.dll | 描画クラス
AdvanceSoftware.ExcelCreator.Xls.Core.dll | Excel ファイル生成クラス (xls 形式)
AdvanceSoftware.ExcelCreator.Xlsx.Core.dll | Excel ファイル生成クラス (xlsx 形式)
AdvanceSoftware.ExcelCreator.Xlsx.CreatorExpress.dll | Express コンポーネント
AdvanceSoftware.ExcelCreator.BarCode.resources.dll | 英語対応リソースアセンブリ (BarCode コンポーネント)
AdvanceSoftware.ExcelCreator.Creator.resources.dll | 英語対応リソースアセンブリ (Creator コンポーネント)
AdvanceSoftware.ExcelCreator.Xlsx.CreatorExpress.resources.dll | 英語対応リソースアセンブリ (Express コンポーネント)
Note メモ:

Express コンポーネントの詳細な内容については、ExcelCreator 12.0 for .NET Express のヘルプをご確認ください。
ExcelCreator 12.0 for .NET Express ヘルプ

<%install%>Help\ExcelCreator12_Express.chm

  %install% は、ExcelCreator 12.0 for .NET のインストールフォルダ (C:\Program Files(x86)\XlsCrt12\ など) を表します。
再配布可能ファイルの配布

実行環境に再配布可能ファイルを配布する場合、再配布可能ファイル (DLL) は、アプリケーションと同じフォルダに配置してください。

Note メモ:

ExcelCreator 12.0 for .NET 再配布可能ファイルは、アプリケーションに ExcelCreator 12.0 for .NET の NuGet パッケージをインストールすることで追加されます。再配布可能ファイルは、アプリケーションの発行時に自動でアプリケーションと同一フォルダにコピーされます。
再配布の条件

ExcelCreator 12.0 for .NET を再配布する際は、以下の条件をご確認ください。

著作権表示について

本製品は、アドバンスソフトウェア株式会社が有する著作権により保護されております。本製品を配布する際、パッケージ (店頭などに配置する形態の製品の梱包物のこと)、マニュアル、プログラム使用許諾契約書等、またはこれに類する物へアドバンスソフトウェアの著作権表示をしていただく必要があります。著作権表示は以下の通りに表示してください。

  1. ExcelCreator 12.0 for .NET
  2. Copyright (C) 2025 Advance Software Co., Ltd.

再配布先のサポート

再配布先のサポートについては、一切行いません。サポートは再配布元であるお客様において行ってください。なお、サーバーライセンスを取得した配布先の弊社製品に関するサポートは、サーバーライセンスの保守契約が必要になります。サーバーライセンスの保守契約の詳細やお申し込みについては、「サポートサービス」よりお問い合わせください。

参照
ExcelCreator 12.0 for .NET の概要
ライセンスファイルを指定する


ライセンス体系

ExcelCreator 12.0 for .NET を組み込んだアプリケーションの配布は、アプリケーションの種類によりライセンス体系が異なります。

このトピックは、次のセクションを含みます。

  • クライアントアプリケーション
  • サーバーアプリケーション
  • 参照
クライアントアプリケーション

クライアントアプリケーションの場合、ロイヤリティフリーで配布することができます。クライアントアプリケーションは、EXE やバッチファイル等、単独で動作し、外部アプリケーションなどから連動して動作することのないアプリケーションとします。

サーバーアプリケーション

ExcelCreator 12.0 for .NET を使用して作成したサーバーアプリケーションを運用する環境に対し、サーバーライセンスが必要です。

「サーバーアプリケーション」とは、以下の形態のアプリケーションとします。

  1. Web アプリケーションやサービスとして動作するプログラム。
  2. Web アプリケーションやサービスと連動して動作するプログラム。
  3. プログラムを用いて作成したファイル、データ等をネットワークを介してほかのコンピュータへ配信、提供する非対話型プログラム。
  4. ほかのコンピュータの操作で、特定のコンピュータ上で動作するプログラム。

サーバーライセンス

必要条件 | ExcelCreator 12.0 for .NET を使用して作成したサーバーアプリケーション(関連する機能含む)を運用するサーバー環境(OS)数分、必要なライセンスです。運用環境には、サーバー運用ライセンスが必要です。待機環境には、サーバー待機ライセンスが必要です。
価格 | サーバー運用ライセンス 1 ライセンスあたり / 200,000円(税込220,000円) サーバー待機ライセンス 1 ライセンスあたり / 60,000円(税込66,000円)
商品構成 | ライセンス数や契約内容を記載した契約書(ライセンス証書)のみになります。
保守 | 保守契約が必要となる場合、サーバー運用ライセンス保守契約(年間)の購入が必要になります。
お問い合わせ | サーバーライセンス、サーバー運用ライセンス保守契約のお申し込みやお問い合わせは、「サポートサービス」よりお問い合わせください。
参照
ExcelCreator 12.0 for .NET の概要


サポートサービス

ExcelCreator 12.0 for .NET の Readme および、ヘルプに記述されていない事項や動作に関するご不明な点などについては、サポートサービスをご利用ください。

このトピックは、次のセクションを含みます。

  • お問い合わせについて
  • ユーザー登録について
  • お問い合わせいただく前に
  • お問い合わせ窓口
  • 参照
お問い合わせについて

ExcelCreator 12.0 for .NET 以外の事柄やプログラミング技法などの一般的なご質問、または、動作保証環境外での使用によるご質問にはお答えいたしかねます。あらかじめご了承ください。

ユーザー登録について

サポートサービスをご利用いただくにあたり、製品のユーザー登録が必要になります。 登録されていない場合はサポートサービスを利用できませんので、お問合せいただく前に必ずユーザー登録を行ってください。 ユーザー登録は、製品に同梱されているユーザー登録カードに必要事項を記入してご郵送いただくか、弊社 Web サイトの「ユーザー登録ページ」からもご登録いただくことができます。

お問い合わせいただく前に

ユーザー情報

  1. ExcelCreator 12.0 for .NET のシリアルナンバー (製品パッケージ内の用紙に記載されています。)
  2. 会社名
  3. 部署名
  4. 担当者名
  5. 連絡先 (電話番号)
  6. FAX 番号
  7. E-Mail アドレス

お問い合わせ内容

  1. 製品名
  2. ExcelCreator 12.0 for .NET の詳細バージョン
  3. 使用マシンの OS
  4. OS のサービスパック
  5. フレームワークのバージョンとサービスパックのバージョン
  6. Visual Studio のバージョンとサービスパックのバージョン
  7. Excel のバージョンとサービスパックのバージョン
  8. アプリケーションを実行するブラウザ名とバージョン

問題となっている現象の内容

  1. 現象の詳細内容
  2. 現象発生までの経緯
  3. 現象発生箇所
  4. 現象を再現できる簡単なプロジェクト一式、もしくは、コーディングの一部
お問い合わせ窓口

サポートサービスは、電話、E-Mail、FAX で受け付けております。弊社 Web サイトにて「問い合わせフォーム」もご用意しておりますので、あわせてご確認ください。
月曜日～金曜日 (祝祭日、弊社特別休業日を除く) にご利用いただけます。営業日以外にいただいた E-Mail / FAX でのお問い合わせは、翌営業日に回答いたします。

製品の操作方法や仕様に関するお問い合わせ窓口

電話番号 | 0776-21-9172
FAX 番号 | 0776-21-9022
E-Mail | xlscrt@adv.co.jp
受付時間 | 10：00 ～ 12：00 / 13：30 ～ 17：00

製品の営業に関するお問い合わせ窓口

電話番号 | 0776-21-9008
FAX 番号 | 0776-21-9022
E-Mail | info@adv.co.jp
受付時間 | 9：00 ～ 12：00 / 13：00 ～ 18：00
参照
ExcelCreator 12.0 for .NET の概要


サンプル

ExcelCreator 12.0 for .NET のサンプルは以下の通りです。

このトピックは、次のセクションを含みます。

  • サンプル(.NET)
  • サンプル(.NET Framework)
  • 参照
サンプル(.NET)
サンプルの種類 | 開発言語 | サンプルの場所
ASP.NET Core MVC サンプル(AspNetCoreMvc) | Visual C# | <%install%>Samples\.NET\CS\AspNetCoreMvc
WinForms サンプル(Creator コンポーネント版) | Visual C# | <%install%>Samples\.NET\CS\WinForms
 | Visual Basic .NET | <%install%>Samples\.NET\VB\WinForms
サンプル(.NET Framework)
サンプルの種類 | 開発言語 | サンプルの場所
ASP.NET MVC サンプル(AspNetMvc) | Visual C# | <%install%>Samples\.NET Framework\CS\AspNetMvc
 | Visual Basic .NET | <%install%>Samples\.NET Framework\VB\AspNetMvc
WindowsForms サンプル(Creator コンポーネント版) | Visual C# | <%install%>Samples\.NET Framework\CS\WindowsForms
 | Visual Basic .NET | <%install%>Samples\.NET Framework\VB\WindowsForms
Note メモ:

%install% は、ExcelCreator 12.0 for .NET のインストールフォルダ (C:\Program Files(x86)\XlsCrt12\ など) を表します。
参照
ExcelCreator 12.0 for .NET の概要


使用準備

ここでは、ExcelCreator 12.0 for .NET の使用準備について説明します。

コンポーネントの種類について

コンポ―ネントの種類について説明します。

NuGet パッケージをインストールする

ExcelCreator 12.0 for .NET の NuGet パッケージをインストールする方法を説明します。

Creator コンポーネントを追加する

Creator コンポーネントを追加する方法を説明します。

BarCode コンポーネントを追加する

BarCode コンポーネントを追加する方法を説明します。


コンポーネントの種類について

ここでは、ExcelCreator 12.0 for .NET に含まれるコンポーネントについて説明します。

Creator コンポーネント

値や書式の設定、図形の挿入、行列の操作、ページ設定など、細やかな Excel ファイルの生成や編集を目的とするコンポーネントです。(xls/xlsx 両形式に対応)

BarCode コンポーネント

バーコードイメージの生成を目的とするコンポーネントです。

Express コンポーネント

使用できる機能を制限し、大量データを高速に設定することを目的とするコンポーネントです。(xlsx 形式に対応)

Note メモ:

Express コンポーネントについては、ExcelCreator 12.0 for .NET Express のヘルプをご確認ください。
ExcelCreator 12.0 for .NET Express ヘルプ

<%install%>Help\ExcelCreator12_Express.chm

  %install% は、ExcelCreator 12.0 for .NET のインストールフォルダ (C:\Program Files(x86)\XlsCrt12\ など) を表します。


NuGet パッケージをインストールする

ExcelCreator 12.0 for .NET では、コンポーネントを使用する前に NuGet パッケージをインストールする必要があります。このトピックでは、.NET プロジェクトを例に NuGet パッケージをインストールする方法を説明します。
.NET Framework プロジェクトでも手順は同様です。

このトピックは、次のセクションを含みます。

  • インストーラーから NuGet パッケージをインストールする
  • nuget.org から NuGet パッケージをインストールする
  • 参照
インストーラーから NuGet パッケージをインストールする

このトピックでは、インストーラーから NuGet パッケージをインストールする方法を説明します。

  1. ExcelCreator 12.0 for .NET インストーラーを起動し、ExcelCreator 12.0 for .NET をインストールします。

  2. Visual Studio を起動し、[ファイル] - [新しいプロジェクトの作成] から、任意の .NET プロジェクトを作成します。ここでは「Windows フォーム アプリ」を作成します。

  3. [ツール] - [オプション] からオプションダイアログを開きます。

  4. [NuGet パッケージ マネージャー] - [パッケージ ソース] からパッケージソース一覧を表示し、「+」アイコンをクリックして以下の内容でローカルのパッケージソースを追加し、[OK] ボタンをクリックします。

    名前

    ExcelCreator12

    ソース

    製品インストールフォルダのパス(C:\Program Files (x86)\XlsCrt12\Bin など)

  5. ソリューションエクスプローラーからソリューション名を右クリックし、[ソリューションの NuGet パッケージの管理] をクリックして Nuget パッケージの管理画面を開きます。

  6. 手順 4 で作成したパッケージ ソース(ExcelCreator12)を設定後、[参照] タブ内に表示される「AdvanceSoftware.ExcelCreator.Creator」のパッケージファイルを選択し、[インストール] ボタンをクリックしてパッケージファイルをインストールします。

    BarCode コンポーネントを利用する場合、「AdvanceSoftware.ExcelCreator.BarCode」のパッケージファイルを選択し、[インストール] ボタンをクリックしてパッケージファイルをインストールします。

  7. パッケージインストール完了後、コンポーネントを追加します。コンポーネントの追加は、 「コンポーネントを追加する」を参照してください。

nuget.org から NuGet パッケージをインストールする

このトピックでは、nuget.org から NuGet パッケージをインストールする方法を説明します。

  1. Visual Studio を起動し、[ファイル] - [新しいプロジェクトの作成] から、任意の .NET プロジェクトを作成します。ここでは「Windows フォーム アプリ」を作成します。

  2. ソリューションエクスプローラーからソリューションを右クリックし、[ソリューションの NuGet パッケージの管理] を選択します。

  3. パッケージソースに nuget.org を指定すると [参照] タブにパッケージ一覧が表示されるため、検索ボックスで「AdvanceSoftware.ExcelCreator.Creator」を検索します。

  4. パッケージファイルを選択し、[インストール] ボタンをクリックしてパッケージファイルをインストールします。

    BarCode コンポーネントを利用する場合、「AdvanceSoftware.ExcelCreator.BarCode」のパッケージファイルを選択し、[インストール] ボタンをクリックしてパッケージファイルをインストールします。

  5. パッケージインストール完了後、コンポーネントを追加します。コンポーネントの追加は、 「コンポーネントを追加する」を参照してください。

参照
使用準備
ライセンスファイルを指定する


Creator コンポーネントを追加する

ここでは、Creator コンポーネントを追加する手順を説明します。

このトピックは、次のセクションを含みます。

  • インスタンスを手動で生成する
  • ツールボックスから追加する
  • 参照
Note メモ:

事前に ExcelCreator 12.0 for .NET の NuGet パッケージをインストールする必要があります。インストール方法は「NuGet パッケージをインストールする」をご確認ください。
インスタンスを手動で生成する

このセクションでは、コード上でインスタンスを生成する方法を説明します。

コード上でインスタンスを生成するには

C#
VB
コピー
private AdvanceSoftware.ExcelCreator.Creator creator1 = new AdvanceSoftware.ExcelCreator.Creator();
Private WithEvents Creator1 As New AdvanceSoftware.ExcelCreator.Creator

エラーイベントを実装するには

C#
VB
コピー
private void Form1_Load(object sender, EventArgs e)
{
    creator1.Error +=
        new AdvanceSoftware.ExcelCreator.CreatorErrorEventHandler(
        this.creator1_Error);
}

private void creator1_Error(object sender,
    AdvanceSoftware.ExcelCreator.CreatorErrorEventArgs e)
{
    // ここにエラー発生時の処理を追加します。
}

Private Sub Creator1_Error(sender As Object, _
    e As AdvanceSoftware.ExcelCreator.CreatorErrorEventArgs) _
    Handles Creator1.Error
    ' ここにエラー発生時の処理を追加します。
End Sub
Note メモ:

ExcelCreator 12.0 for .NET では、ErrorNo プロパティ、ErrorMessage プロパティでエラーの詳細を確認することができます。
ツールボックスから追加する

このセクションでは、コンポーネントをツールボックスからフォームに配置する方法を説明します。

ツールボックスから追加するには

  1. [表示] メニューの [ツールボックス] をクリックしてツールボックスを表示します。

  2. [Creator(AdvanceSoftware.ExcelCreator)] を選択し、フォームにドラッグ アンド ドロップして配置します。

エラーイベントを実装するには

  1. フォームに貼り付けたコンポーネントを選択します。

  2. [プロパティ] ウィンドウの [イベント( [image])] ボタンをクリックします。

  3. イベント一覧から [Error] を選択し、Enter キーを押下します。

  4. Error イベントが追加されます。

    Note メモ:

    ExcelCreator 12.0 for .NET では、ErrorNo プロパティ、ErrorMessage プロパティでエラーの詳細を確認することができます。
参照
NuGet パッケージをインストールする
使用準備


BarCode コンポーネントを追加する

ここでは、BarCode コンポーネントを追加する手順を説明します。

このトピックは、次のセクションを含みます。

  • インスタンスを手動で生成する
  • ツールボックスから追加する
  • 参照
Note メモ:

事前に ExcelCreator 12.0 for .NET の NuGet パッケージをインストールする必要があります。インストール方法は「NuGet パッケージをインストールする」をご確認ください。
インスタンスを手動で生成する

このセクションでは、コード上でインスタンスを生成する方法を説明します。

コード上でインスタンスを生成するには

C#
VB
コピー
private AdvanceSoftware.ExcelCreator.BarCode.BarCode barCode1 = new new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
Private WithEvents BarCode1 As New AdvanceSoftware.ExcelCreator.BarCode.BarCode

エラーイベントを実装するには

C#
VB
コピー
private void Form1_Load(object sender, EventArgs e)
{
    barCode1.Error +=
        new AdvanceSoftware.ExcelCreator.BarCode.BarCodeErrorEventHandler(
        this.barCode1_Error);
}

private void barCode1_Error(object sender,
    AdvanceSoftware.ExcelCreator.BarCode.BarCodeErrorEventArgs e)
{
    // ここにエラー発生時の処理を追加します。
}

Private Sub BarCode1_Error(sender As Object, _
    e As AdvanceSoftware.ExcelCreator.BarCode.BarCodeErrorEventArgs) _
    Handles BarCode1.Error
    ' ここにエラー発生時の処理を追加します。
End Sub
Note メモ:

ExcelCreator 12.0 for .NET では、ErrorNo プロパティ、ErrorMessage プロパティでエラーの詳細を確認することができます。
ツールボックスから追加する

このセクションでは、コンポーネントをツールボックスからフォームに配置する方法を説明します。

ツールボックスから追加するには

  1. [表示] メニューの [ツールボックス] をクリックしてツールボックスを表示します。

  2. [BarCode(AdvanceSoftware.ExcelCreator.BarCode)] を選択し、フォームにドラッグ アンド ドロップして配置します。

エラーイベントを実装するには

  1. フォームに貼り付けたコンポーネントを選択します。

  2. [プロパティ] ウィンドウの [イベント( [image])] ボタンをクリックします。

  3. イベント一覧から [Error] を選択し、Enter キーを押下します。

  4. Error イベントが追加されます。

    Note メモ:

    ExcelCreator 12.0 for .NET では、ErrorNo プロパティ、ErrorMessage プロパティでエラーの詳細を確認することができます。
参照
NuGet パッケージをインストールする
使用準備


ExcelCreator 12.0 for .NET の新機能

ここでは、ExcelCreator 12.0 for .NET の新機能について説明します。

PDF 出力に関する新機能

PDF 出力に関する新機能について説明します。

HTML に関する新機能

HTML に関する新機能を説明します。

バーコード出力に対応

バーコードイメージを出力する方法を説明します。


PDF に関する新機能

ここでは、PDF に関する新機能について説明します。

PDF ファイルに電子署名、タイムスタンプを設定する

PDF ファイルに電子署名およびタイムスタンプを設定する方法について説明します。

PDF ファイルにグラフイメージを追加する

PDF ファイルにグラフイメージを追加する方法を説明します。


PDF ファイルに電子署名、タイムスタンプを設定する

ExcelCreator 12.0 for .NET では、PDF ファイル出力時に電子署名、タイムスタンプを付与することが可能です。このトピックでは、電子署名およびタイムスタンプを付与する方法を説明します。

このトピックは、次のセクションを含みます。

  • ローカル証明書(pfx)データで電子署名を付与する
  • 電子署名にタイムスタンプを付与する
  • 証明書ストアを利用して電子署名を付与する
  • 参照
Note メモ:

タイムスタンプ付与の際にはインターネットへの接続が必要となります。
ローカル証明書(pfx)データで電子署名を付与する

次のコードは、ローカル証明書(pfx)データで電子署名を付与するサンプルコードです。

C#
VB
コピー
// 連絡先に "info@adv.co.jp" を設定します。
creator1.Pdf.Signature.Contact = "info@adv.co.jp";
// 署名時刻に 2024/4/1 12:00:00 を設定します。
creator1.Pdf.Signature.Date = new DateTime(2024, 4, 1, 12, 0, 0);
// 場所に "日本" を設定します。
creator1.Pdf.Signature.Location = "日本";
// 理由に "稟議" を設定します。
creator1.Pdf.Signature.Reason = "稟議";
// ローカル証明書(pfx)データに "C:\Certificate.pfx" ファイルの内容を設定します。
creator1.Pdf.Signature.CertificateData = System.IO.File.ReadAllBytes(@"C:\Certificate.pfx");
// ローカル証明書(pfx)データのパスワード "pass" を設定します。
creator1.Pdf.Signature.CertificatePassword = "pass";

' 連絡先に "info@adv.co.jp" を設定します。
Creator1.Pdf.Signature.Contact = "info@adv.co.jp"
' 署名時刻に 2024/4/1 12:00:00 を設定します。
Creator1.Pdf.Signature.Contact = new DateTime(2024, 4, 1, 12, 0, 0)
' 場所に "日本" を設定します。
Creator1.Pdf.Signature.Location = "日本"
' 理由に "稟議" を設定します。
Creator1.Pdf.Signature.Reason = "稟議"
' ローカル証明書(pfx)データ "C:\Certificate.pfx" ファイルの内容を設定します。
Creator1.Pdf.Signature.CertificateData = System.IO.File.ReadAllBytes("C:\Certificate.pfx")
' ローカル証明書(pfx)データのパスワード "pass" を設定します。
Creator1.Pdf.Signature.CertificatePassword = "pass"
電子署名にタイムスタンプを付与する

このセクションでは、電子署名にタイムスタンプを付与する方法を説明します。

次のコードは、タイムスタンプサーバーの URL を設定し、設定された URL でタイムスタンプトークンが取得された場合、電子署名に埋め込みタイムスタンプを付加するサンプルコードです。

C#
VB
コピー
// タイムスタンプサーバーの URL "https://freetsa.org/tsr" を設定します。
creator1.Pdf.Signature.TimeStampUrl = "https://freetsa.org/tsr";
// タイムスタンプサーバーの ユーザー名 "user" を設定します。
creator1.Pdf.Signature.TimeStampUser = "user";
// タイムスタンプサーバーの パスワード "pass" を設定します。
creator1.Pdf.Signature.TimeStampPassword = "pass";
' 証明書(pfx)ファイルのパス "https://freetsa.org/tsr" を設定します。
Creator1.Pdf.Signature.TimeStampUrl = "https://freetsa.org/tsr"
' タイムスタンプサーバーの ユーザー名 "user" を設定します。
Creator1.Pdf.Signature.TimeStampUser = "user"
' タイムスタンプサーバーの パスワード "pass" を設定します。
Creator1.Pdf.Signature.TimeStampPassword = "pass"
証明書ストアを利用して電子署名を付与する

このセクションでは、証明書ストアを利用して電子署名を付与する方法を説明します。

次のコードは、Windows の証明書ストアを利用して電子署名を付与するサンプルコードです。

C#
VB
コピー
using System.Security.Cryptography.X509Certificates;

// 証明書ストアの現在のユーザ（Windowsアカウント）の「個人」を開く
X509Store store = new X509Store(StoreName.My, StoreLocation.CurrentUser);
store.Open(OpenFlags.ReadOnly | OpenFlags.OpenExistingOnly);
// 証明書を有効期間内のものに絞り込む
// 最後のtrueは証明のパスが正式なもののみ取り出す指定。自己証明書の場合はfalseにする
X509Certificate2Collection col_all = store.Certificates;
X509Certificate2Collection col_date = col_all.Find(X509FindType.FindByTimeValid, DateTime.Now, true);
// 次に署名者の名前（CA証明書のCNなど）で絞り込む
X509Certificate2Collection col_issuer = col_date.Find(X509FindType.FindByIssuerName, User, true);
// 証明書を設定
creator1.Pdf.Signature.WindowsCertificate = col_issuer[0];
Imports System.Security.Cryptography.X509Certificates

' 証明書ストアの現在のユーザ（Windowsアカウント）の「個人」を開く
Dim store As New X509Store(StoreName.My, StoreLocation.CurrentUser)
store.Open(OpenFlags.ReadOnly Or OpenFlags.OpenExistingOnly)
' 証明書を有効期間内のものに絞り込む
' 最後のtrueは証明のパスが正式なもののみ取り出す指定。自己証明書の場合はfalseにする
Dim col_all As X509Certificate2Collection = store.Certificates
Dim col_date As X509Certificate2Collection = col_all.Find(X509FindType.FindByTimeValid, DateTime.Now, True)
' 次に署名者の名前（CA証明書のCNなど）で絞り込む
Dim col_issuer As X509Certificate2Collection = col_date.Find(X509FindType.FindByIssuerName, User, True)
' 証明書を設定
Creator1.Pdf.Signature.WindowsCertificate = col_issuer(0)
参照
ExcelCreator 12.0 for .NET 新機能
オブジェクト機能一覧(PdfSignature クラス)


PDF ファイルにグラフイメージを追加する

ExcelCreator 12.0 for .NET では、テンプレートの Excel ファイルに登録されたグラフ情報を取得し、外部のグラフイメージ生成処理と組み合わせる事で、 出力する PDF ファイルにグラフイメージを追加することが可能です。 このトピックでは、PDF ファイルにグラフイメージを追加する手順を説明します。

なお、ExcelCreator 12.0 for .NET ではグラフイメージ生成の機能を実装しておらず、外部のサードパーティ製ライブラリ等を使用して独自に実装する必要があります。

このトピックは、次のセクションを含みます。

  • 出力 PDF ファイルに反映するグラフイメージを設定する
  • 参照
出力 PDF ファイルに反映するグラフイメージを設定する

  1. テンプレートになる Excel ファイル(Template.xlsx)を用意します。ここでは、下記の様なファイルを用意しました。

  2. 次のコードは、シート内に登録されたグラフの情報を取得し、出力 PDF ファイルに反映するグラフイメージを設定するサンプルコードです。

    C#
    VB
    コピー
    // グラフの数を取得
int chartCount = creator1.GetChartCount();
for (int i = 0; i < chartCount; i++)
{
    // グラフ情報を取得
    ChartData chartData = creator1.GetChartData(i, 330);

    // ChartData からの Image オブジェクト生成処理は独自に実装する必要があります。
    // ※以下の Image オブジェクト生成処理(GetChartImage)は弊社 Web サイトにて公開しているサンプルプログラムに付属しています。
    Image chartImage = chartCreator.GetChartImage(chartData);
    // PDF ファイルにのみ出力されるチャートを設定します。
    creator1.Pos(chartData.col, chartData.row).Canvas.AddChart(chartImage, chartData);
}

    ' グラフの数を取得
Dim chartCount = Creator1.GetChartCount()
For i = 0 To chartCount - 1
    ' グラフ情報を取得
    Dim chartData = Creator1.GetChartData(i, 330)

    ' ChartData からの Image オブジェクト生成処理は独自に実装する必要があります。
    ' ※以下の Image オブジェクト生成処理(GetChartImage)は弊社 Web サイトにて公開しているサンプルプログラムに付属しています。
    Dim chartImage As Image = ChartCreator.GetChartImage(chartData)
    ' PDF ファイルにのみ出力されるチャートを設定します。
    Creator1.Pos(chartData.col, chartData.row).Canvas.AddChart(chartImage, chartData)
Next
    Note メモ:

    ※グラフ情報(ChartData)からグラフイメージ生成を行う処理(GetChartImage)は、サードパーティ製のライブラリを利用して独自に実装する必要があります。 使用方法についてはご利用のライブラリのマニュアル等をご参照ください。不明点については、「概要」の「サポートサービス」 から弊社サポート窓口までお問い合わせください。

  3. 出力した PDF ファイルを開き、グラフイメージが反映されていることを確認します。

参照
ExcelCreator 12.0 for .NET 新機能
オブジェクト機能一覧(CellCanvas クラス)


HTML に関する新機能

ここでは、HTML に関する新機能を説明します。

Web ブラウザ上でセルの編集、値の更新を行う

Web ブラウザ上で入力した値を Excel ファイルのシートに書き込む方法を説明します。

HTML テーブル展開時に対応する Excel 修飾機能

HTML テーブル展開時に対応する Excel 修飾機能について説明します。

編集可能セルを切り替える

編集可能セルを切り替える方法について説明します。


Web ブラウザ上でセルの編集、値の更新を行う

ExcelCreator 12.0 for .NET では、Excel ファイル(xls/xlsx 形式)のシートの内容を HTML テーブルに展開し、Webブラウザ上に表示することが可能です。また、Web ブラウザ上で編集した値を反映した Excel/PDF ファイルを出力することができます。

このトピックは、次のセクションを含みます。全てのセクションを上から順に行うことで、Web ブラウザ上でセルの編集を行い、値の書き込みを行う動作を確認できます。

  • 事前準備
  • ExcelCreator の機能を追加するコントローラーとビューを追加する
  • Creator コンポーネントを追加する
  • JavaScript の外部ファイルを追加する
  • Excel ファイルのシートの内容を HTML テキストで取得する
  • Web ブラウザ上で編集した値を Excel ファイルのシートに書き込む
  • 参照
事前準備

  1. Visual Studio を起動し、[ファイル] - [新しいプロジェクトの作成] から .NET の ASP.NET Core Web アプリ(MVC)のプロジェクトを作成します。

  2. [ソリューション エクスプローラ] - プロジェクト名を右クリックし、[追加] から [新しいフォルダー] を選択してフォルダーを追加します。

    追加フォルダ名
    App_Data

  3. テンプレートになる Excel ファイルを [App_Data] フォルダに格納します。 ここでは、製品サンプルで使用している下記テンプレートファイル(TemplateHtml.xlsx)を [App_Data] フォルダにコピーします。

    ・[サンプル格納先] - <%install%>Samples\.NET\CS\AspNetCoreMvc

ExcelCreator の機能を追加するコントローラーとビューを追加する

このセクションでは、新規プロジェクトに ExcelCreator 12.0 for .NET の機能を追加するためのコントローラーとビューを作成する方法を説明します。

  1. [表示] メニューの [ソリューション エクスプローラ] をクリックしてソリューションエクスプローラを表示します。

  2. [ソリューション エクスプローラ] - [Controllers] を右クリックし、[追加] から [コントローラー] を選択します。

  3. [MVC コントローラー - 空] を選択し追加します。ここではコントローラー名を "GetHtmlController" とします。

  4. [ソリューション エクスプローラ] - [Views] を右クリックし、[追加] から [新しいフォルダ] を選択し、フォルダ名を "GetHtml"とします。

  5. [ソリューション エクスプローラ] - [Views] - [GetHtml] を右クリックし、[追加] から [ビュー] を選択し、[Razor ビュー] を追加します。

  6. [ビュー名] を "Index" として追加します。

Creator コンポーネントを追加する

このセクションでは、Creator コンポーネントを追加する方法を説明します。

  1. ソリューションエクスプローラーからソリューション名を右クリックし、[ソリューションの NuGet パッケージの管理] をクリックして NuGet パッケージの管理画面を開きます。

  2. [パッケージ ソース] に「nuget.org」、または「NuGet パッケージ ソースをインストールする」で追加した「ExcelCreator12」 を設定後、[参照] タブ内に表示される「AdvanceSoftware.ExcelCreator」のパッケージファイルを選択し、[インストール] ボタンをクリックしてパッケージファイルをインストールします。

JavaScript の外部ファイルを追加する

このセクションでは、JavaScript の外部ファイルを追加する方法を説明します。

  1. ExcelCreator 12.0 for .NET のインストールフォルダ内 [Bin] - [v12.X.X] - [Scripts] フォルダより下記外部ファイルおよびフォルダをコピーし、プロジェクトの [wwwroot] - [js] フォルダに配置します。

    JavaScript 外部ファイル名
    jquery-1.9.0.min.js
    formula.js
    tablecreator.js
    ui

  2. 「ExcelCreator の機能を追加するコントローラーとビューを作成する 」で作成した "Index.cshtml" のコードを開き、スクリプトファイルのインクルードを追加します。

    HTML
    コピー
    <script type="text/javascript" src="/js/jquery-1.9.0.min.js"></script>
<script type="text/javascript" src="/js/ui/js/jquery-ui-1.10.0.custom.min.js"></script>
<script type="text/javascript" src="/js/ui/i18n/jquery.ui.datepicker-ja.js"></script>
<script type="text/javascript" src="/js/formula.js"></script>
<script type="text/javascript" src="/js/tablecreator.js"></script>

  3. 引き続き、HTML テーブル表示用のコードとスクリプトを追加します。

    HTML
    コピー
    <div>
    <form id="form" action="@Url.Action("Index", "GetHtml")" method="post">
        <input id="vals" name="jsonvalue" type="hidden" />
        <button type="submit">編集内容を Excel ファイルに反映</button>
    </form>
</div>
<hr />

<script type="text/javascript" src="/js/jquery-1.9.0.min.js"></script>
<script type="text/javascript" src="/js/ui/js/jquery-ui-1.10.0.custom.min.js"></script>
<script type="text/javascript" src="/js/ui/i18n/jquery.ui.datepicker-ja.js"></script>
<script type="text/javascript" src="/js/formula.js"></script>
<script type="text/javascript" src="/js/tablecreator.js"></script>

<div id="ectable">@Html.Raw(ViewData["table"])</div>
<script type="text/javascript">
        $("#form").submit(() => {
            let vals = excelcreatorTable.GetModifiedValues();
            $("#vals").val(vals);
        });
</script>
Excel ファイルのシートの内容を HTML テキストで取得する

このセクションでは、GetHtmlText メソッドを使用して Excel ファイルのシートの内容を HTML テキストで取得する方法を説明します。

  1. 「ExcelCreator の機能を追加するコントローラーとビューを作成する 」で作成した "GetHtmlController.cs" の Index メソッドを次のコードに置き換えます。

    C#
    コピー
    namespace WebApplication1.Controllers
{
    public class GetHtmlController : Controller
    {
        private readonly ILogger<GetHtmlController> _logger;
        private string templateFilePath;

        public GetHtmlController(ILogger<GetHtmlController> logger, IWebHostEnvironment env)
        {
            _logger = logger;
            templateFilePath = Path.Combine(env.ContentRootPath, "App_Data");
        }

        public IActionResult Index()
        {
            var creator1 = new Creator();
            creator1.Error += (s, e) => _logger.Log(LogLevel.Error, e.ErrorNo.ToString());
            creator1.Html.EditMode = EditMode.All;
            creator1.ReadBook(Path.Combine(templateFilePath, "TemplateHtml.xlsx"));
            // HTML テキストを取得します。
            ViewData["table"] = creator1.GetHtmlText();
            creator1.CloseBook(true);
            return View();
        }
    }
}

  2. アプリケーションを実行し、URL(https://localhost:XXXXX/GetHtml/Index)を設定すると Excel ファイルのシートの内容がブラウザ上に表示されます。

Web ブラウザ上で編集した値を Excel ファイルのシートに書き込む

このセクションでは、Web ブラウザ上で編集した値を JavaScript で JSON 文字列として取得し、内容を SetJsonValue メソッドで Excel ファイルのシートに書き込む方法を説明します。

  1. 「ExcelCreator の機能を追加するコントローラーとビューを作成する 」で作成した "GetHtmlController.cs" にメソッドを追加します。

    C#
    コピー
    public IActionResult Index()
{
    var creator1 = new Creator();
    creator1.Error += (s, e) => _logger.Log(LogLevel.Error, e.ErrorNo.ToString());
    creator1.Html.EditMode = EditMode.All;
    creator1.ReadBook(Path.Combine(templateFilePath, "TemplateHtml.xlsx"));
    // HTML テキストを取得します。
    ViewData["table"] = creator1.GetHtmlText();
    creator1.CloseBook(true);
    return View();
}
[HttpPost]
public IActionResult Index(string jsonValue)
{
    System.IO.MemoryStream excelStream = new System.IO.MemoryStream();
    var creator1 = new Creator();
    creator1.Error += (s, e) => _logger.Log(LogLevel.Error, e.ErrorNo.ToString());
    creator1.Html.EditMode = EditMode.All;
    creator1.OpenBook(excelStream, Path.Combine(templateFilePath, "TemplateHtml.xlsx"));
    // tablecreator.js で取得した JSON 文字列を設定します
    creator1.SetJsonValue(jsonValue, true);
    ViewData["table"] = creator1.GetHtmlText();
    creator1.CloseBook(true);
    return File(excelStream.ToArray(), "application/vnd.openxmlformats-officedocument.spreadsheetml.sheet", "output.xlsx");
}

  2. アプリケーションを実行し、URL(https://localhost:XXXXX/GetHtml/Index)を設定して Excel ファイルのシートの内容がブラウザ上に表示されたら、値の編集を行います。ここでは 表示形式 - 標準 の「Advance Software」と入力されているセルを選択し、「ExcelCreator 12.0 for .NET」に編集して[編集内容を Excel ファイルに反映]ボタンをクリックします。
    正常に処理が完了すると、Excel ファイルが出力されます。

  3. 出力された Excel ファイル(output.xlsx)を開き、編集した値が反映されていることを確認します。

参照
ExcelCreator 12.0 for .NET 新機能
オブジェクト機能一覧(Creator クラス)


HTML テーブル展開時に対応する Excel 修飾機能

Excel ファイルのシートの内容を HTML テーブルに展開する際に対応する Excel 修飾機能を一覧で表します。 一覧に掲載のない機能は、基本的に動作保証を行っていない機能となります。 詳細については「サポートサービス」よりお問い合わせください。

Note メモ:

「表示」は対象シートの Web ブラウザ上での初期表示を示します。「再表示」は Web ブラウザ上で入力した値に対応して表示が反映されるかを示します。

書式 / Excel メニュー対応一覧表

[○ = 対応、× = 未対応、△ = 一部対応、－ = 該当なし]
Excel 書式設定(設定項目) 表示 再表示
[セルの書式設定]-[表示形式]-[分類]
標準, 文字列 | ○ | ○
数値, パーセンテージ | ○ | △(*1)
日付 | ○ | △(*2)
通貨, 会計, 時刻, 分数, 指数, その他, ユーザー定義 | ○ | ×
[セルの書式設定]-[配置]
横位置 (標準 / 左詰め / 中央揃え / 右詰め) | ○(*3) | ○(*3)
横位置 (繰り返し / 両端揃え / 選択範囲内で中央 / 均等割り付け) | × | ×
縦位置 (上詰め / 中央揃え / 下詰め) | ○ | ○
縦位置 (両端揃え / 均等割り付け) | × | ×
折り返して全体を表示する | ○ | ○
縮小して全体を表示する | × | ×
セルを結合する | ○ | ○
方向 (縦書き / -90～90 度) | × | ×
[セルの書式設定]-[フォント]
フォント名 | ○ | ○
フォントスタイル (標準 / 斜体 / 太字 / 太字斜体) | ○ | ○
フォントサイズ (1～409) | ○ | ○
下線 (なし / 下線) | ○ | ○
下線 (二重下線) | × | ×
フォントの色 | ○ | ○
文字飾り (取り消し線) | ○ | ○
文字飾り (上付き / 下付き) | × | ×
[セルの書式設定]-[罫線]
罫線 (上 / 下 / 左 / 右) | ○ | －
罫線 (左上がり / 右上がり) | × | －
線 (スタイル) | ○(*4) | －
線 (色) | ○ | －
[セルの書式設定]-[塗りつぶし(パターン)]
セルの塗りつぶしの色 | ○(*5) | －
セルのパターン | ○ | －
[スタイル(書式)]
条件付き書式 | △(*6) | ×
[セル]
行の高さ (高さ / 非表示) | ○(*7) | ×
列の幅 (幅 / 標準の幅 / 非表示) | ○(*7) | ×
[関数]
ABS, AND, AVERAGE, CHOOSE, COLUMN, COLUMNS, CONCATENATE, COUNT, COUNTIF, EXACT, FIND, HLOOKUP, IF, INDEX, INDIRECT, INT, ISBLANK, ISERROR, LARGE, LEFT, LOOKUP, MATCH, MAX, MID, MIN, MOD, NOT, OFFSET, OR, PRODUCT, RANK, REPLACE, RIGHT, ROUND, ROUNDDOWN, ROUNDUP, ROW, ROWS, SEARCH, SIGN, SMALL, SUBSTITUTE, SUM, SUMIF, TRIM, TRUNC, VALUE, VLOOKUP | ○(*8) | ○(*8)
上記以外の関数 | × | ×
[図]
図 | ○ | －
図形 | × | －
[グラフ]
グラフ | × | －
[テキスト]
テキストボックス | × | －
ヘッダー / フッター | × | －
ワードアート | × | －
[テーマ]
テーマ | × | －
[コメント]
コメント | × | －
[保護]
シートの保護 | ○ | －
ブックの保護 | ○ | －
[パスワード]
アクセス許可 | × | －
シートの保護 | ○ | －
ブックの保護 | × | －
Note メモ:

(*1)Web ブラウザ上での再表示では一部の書式のみ対応しています。

(*2)Web ブラウザ上での再表示では DateFormat プロパティで対応可能な形式のみ対応しています。

(*3)インデントには対応しておりません。

(*4)一部の罫線の種類は Web ブラウザ上で破線もしくは点線として表現されます。

(*5)グラデーションには対応しておりません。

(*6) [セルの書式設定]で対応する機能のみ初期表示が可能です。

(*7)行の高さ、および列の幅の自動調整には対応しておりません。

(*8)Excel の計算式の四則演算( + / - * ^) の扱いが可能です。
     Excel の計算式の文字列連結子 ( & ) の扱いが可能です。
     Excel の計算式の比較演算子 ( =, >, <, >=, <=, <> ) の扱いが可能です。
     括弧による優先順位変更が可能です。
     関数内の関数の入れ子が可能です。
     計算式の指定が Excel と一部異なる場合があります。


編集可能セルを切り替える

ExcelCreator 12.0 for .NET では、EditMode プロパティを使用して Web ブラウザ上に表示した Excel ファイルのシート内の編集可能セルを切り替えることが可能です。 このトピックでは、編集可能セルについて説明します。

このトピックは、次のセクションを含みます。

  • EditMode プロパティによる編集可能セルの切り替え
  • 参照
EditMode プロパティによる編集可能セルの切り替え

このセクションでは、編集可能セルの切り替えについて説明します。

下記画像は、製品サンプルで使用されているテンプレートファイルから一部を抜粋した Excel ファイルのシートです。
EditMode プロパティに EditMode 列挙体のメンバを渡すことで、編集可能セルを切り替えることが可能です。

列挙体のメンバごとによる編集可能セルは以下になります。

  • EditMode = EditMode.All

    ① の範囲内全てのセルの編集が可能になります。

  • EditMode = EditMode.UnlockedCells

    ② のロックが掛かっていないセルのみ編集が可能になります。

  • EditMode = EditMode.NamedCells

    ③ の名前の付いたセルのみ編集が可能になります。

  • EditMode = EditMode.NotEdit

    ① の範囲内全てのセルで編集ができません。

    • Note メモ:

    数式が登録されているセルは、① ～ ③ 共通で編集ができません。
    参照
    ExcelCreator 12.0 for .NET 新機能
    オブジェクト機能一覧(HtmlOption クラス)


バーコードを作成する

ExcelCreator 12.0 for .NET では、バーコードコンポーネントを使用して JAN、GS1-128、カスタマバーコード、QR コードなどのバーコードイメージを作成することが可能です。ここでは、作成可能なバーコードの種類やバーコードイメージの作成方法などを説明します。

バーコードコンポーネントで作成可能なバーコードの種類

バーコードコンポーネントで作成可能なバーコードの種類を説明します。

バーコードタイプ別の作成方法

バーコードタイプ別の作成方法を説明します。


バーコードコンポーネントで作成可能なバーコードの種類

バーコードコンポーネントでは、JAN、GS1-128、カスタマバーコード、QR コードなどのバーコードイメージを作成することが可能です。作成したバーコードイメージは、Excel ファイルに挿入して保存、PDF ファイルに出力することができます。バーコードコンポーネントの対応バーコードを次に示します。

このトピックは、次のセクションを含みます。

  • JAN コード
  • UPC コード
  • ITF コード
  • Codabar (NW-7)
  • Code39
  • Code128
  • GS1-128 (旧称 : UCC/EAN128)
  • 公共料金等代理収納 GS1-128
  • カスタマバーコード
  • QR コード
  • PDF417
  • 参照
JAN コード

JAN13 (標準バージョン 13 桁)

JAN8 (短縮バージョン 8 桁)

UPC コード

UPC-A (A バージョン)

UPC-E (E バージョン)

ITF コード

ITF-6 (アドオンバージョン 6 桁)

ITF-14 (標準バージョン 14 桁)

ITF-16 (拡張バージョン 16 桁)

ITF (自由桁)

Codabar (NW-7)

Codabar

Code39

Code39

Code128

Code128

GS1-128 (旧称 : UCC/EAN128)

GS1-128

公共料金等代理収納 GS1-128

公共料金等代理収納 GS1-128

カスタマバーコード

カスタマバーコード

QR コード

モデル1

モデル2

「QR コード」は、株式会社デンソーウェーブの登録商標です。

PDF417

標準

簡易

参照
バーコードを作成する


バーコードタイプ別の作成方法

ここでは、ExcelCreator 12.0 for .NET のバーコードタイプ別の作成方法について説明します。

JAN コードを作成する

JAN コードを作成する方法を説明します。

UPC コードを作成する

UPC コードを作成する方法を説明します。

ITF コードを作成する

ITF コードを作成する方法を説明します。

Codabar (NW-7) を作成する

Codabar (NW-7) を作成する方法を説明します。

Code39 を作成する

Code39 を作成する方法を説明します。

Code128 を作成する

Code128 を作成する方法を説明します。

GS1-128 (旧称 : UCC/EAN128) を作成する

GS1-128 (旧称 : UCC/EAN128) を作成する方法を説明します。

公共料金等代理収納 GS1-128 を作成する

公共料金等代理収納 GS1-128 を作成する方法を説明します。

カスタマバーコードを作成する

カスタマバーコードを作成する方法を説明します。

QR コードを作成する

QR コードを作成する方法を説明します。

PDF417 コードを作成する

PDF417 コードを作成する方法を説明します。


JAN コードを作成する

ここでは、JAN コードを作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • JAN 13 コード (標準バージョン 13 桁) を作成する
  • JAN 8 コード (短縮バージョン 8 桁) を作成する
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」の「BarCode コンポーネントを追加する」を参照してください。
JAN 13 コード (標準バージョン 13 桁) を作成する

このセクションでは、JAN 13 コード (標準バージョン 13 桁) を作成する方法を説明します。

次のコードは、JAN 13 コード (標準バージョン 13 桁) を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// JAN コードの倍率を 100 に設定します。
barCode1.Zoom = 100;
// 13 桁目チェックデジットは自動で付加されます。
barCode1.Value = "499385774922";
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' JAN コードの倍率を 100 に設定します。
BarCode1.Zoom = 100
' 13 桁目チェックデジットは自動で付加されます。
BarCode1.Value = "499385774922"
JAN 8 コード (短縮バージョン 8 桁) を作成する

このセクションでは、JAN 8 コード (短縮バージョン 8 桁) を作成する方法を説明します。

次のコードは、JAN 8 コード (短縮バージョン 8 桁) を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN8;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// JAN コードの倍率を 100 に設定します。
barCode1.Zoom = 100;
// 8 桁目チェックデジットは自動で付加されます。
barCode1.Value = "4993857";
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN8
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' JAN コードの倍率を 100 に設定します。
BarCode1.Zoom = 100
' 8 桁目チェックデジットは自動で付加されます。
BarCode1.Value = "4993857"
参照
バーコードタイプ別の作成方法
オブジェクト機能一覧 (BarCode コンポーネント)


UPC コードを作成する

ここでは、UPC コードを作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • UPC-A (A バージョン) を作成する
  • UPC-E (E バージョン) を作成する
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」の「BarCode コンポーネントを追加する」を参照してください。
UPC-A (A バージョン) を作成する

このセクションでは、UPC-A (A バージョン) を作成する方法を説明します。

次のコードは、UPC-A (A バージョン) を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.UPCA;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// UPC コードの倍率を 100 に設定します。
barCode1.Zoom = 100;
// 12 桁目チェックデジットは自動で付加されます。
barCode1.Value = "01234567891";
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.UPCA
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' UPC コードの倍率を 100 に設定します。
BarCode1.Zoom = 100
' 12 桁目チェックデジットは自動で付加されます。
BarCode1.Value = "01234567891"
UPC-E (E バージョン) を作成する

このセクションでは、UPC-E (E バージョン) を作成する方法を説明します。

次のコードは、UPC-E (E バージョン) を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.UPCE;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// UPC コードの倍率を 100 に設定します。
barCode1.Zoom = 100;
// 8 桁目チェックデジットは自動で付加されます。
barCode1.Value = "0123456";
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.UPCE
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' UPC コードの倍率を 100 に設定します。
BarCode1.Zoom = 100
' 8 桁目チェックデジットは自動で付加されます。
BarCode1.Value = "0123456"
参照
バーコードタイプ別の作成方法
オブジェクト機能一覧 (BarCode コンポーネント)


ITF コードを作成する

ここでは、ITF コードを作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • ITF-6 (アドオンバージョン 6 桁) を作成する
  • ITF-14 (標準バージョン 14 桁) を作成する
  • ITF-16 (拡張バージョン 16 桁) を作成する
  • ITF (自由桁) を作成する
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」の「BarCode コンポーネントを追加する」を参照してください。
ITF-6 (アドオンバージョン 6 桁) を作成する

このセクションでは、ITF-6 (アドオンバージョン 6 桁) を作成する方法を説明します。

次のコードは、ITF-6 (アドオンバージョン 6 桁) を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.ITF6;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// バーコードの倍率を 100 に設定します。
barCode1.Zoom = 100;
// 6 桁目チェックデジットは自動で付加されます。
barCode1.Value = "01234";
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.ITF6
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' バーコードの倍率を 100 に設定します。
BarCode1.Zoom = 100
' 6 桁目チェックデジットは自動で付加されます。
BarCode1.Value = "01234"
ITF-14 (標準バージョン 14 桁) を作成する

このセクションでは、ITF-14 (標準バージョン 14 桁) を作成する方法を説明します。

次のコードは、ITF-14 (標準バージョン 14 桁) を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.ITF14;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// バーコードの倍率を 100 に設定します。
barCode1.Zoom = 100;
// 14 桁目チェックデジットは自動で付加されます。
barCode1.Value = "0123456789012";
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.ITF14
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' バーコードの倍率を 100 に設定します。
BarCode1.Zoom = 100
' 14 桁目チェックデジットは自動で付加されます。
BarCode1.Value = "0123456789012"
ITF-16 (拡張バージョン 16 桁)を作成する

このセクションでは、ITF-16 (拡張バージョン 16 桁) を作成する方法を説明します。

次のコードは、ITF-16 (拡張バージョン 16 桁) を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.ITF16;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// バーコードの倍率を 100 に設定します。
barCode1.Zoom = 100;
// 16 桁目チェックデジットは自動で付加されます。
barCode1.Value = "012345678901234";
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.ITF16
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' バーコードの倍率を 100 に設定します。
BarCode1.Zoom = 100
' 16 桁目チェックデジットは自動で付加されます。
BarCode1.Value = "012345678901234"
ITF (自由桁) を作成する

このセクションでは、ITF (自由桁) を作成する方法を説明します。

次のコードは、ITF (自由桁) を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.ITF;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// バーコードの倍率を 100 に設定します。
barCode1.Zoom = 100;
// 最終桁チェックデジットは自動で付加されます。
barCode1.Value = "01234567890123456789";
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.ITF
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' バーコードの倍率を 100 に設定します。
BarCode1.Zoom = 100
' 最終桁チェックデジットは自動で付加されます。
BarCode1.Value = "01234567890123456789"
参照
バーコードタイプ別の作成方法
オブジェクト機能一覧 (BarCode コンポーネント)


Codabar (NW-7) を作成する

ここでは、Codabar (NW-7) を作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • Codabar (NW-7) を作成する
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」の「BarCode コンポーネントを追加する」を参照してください。
Codabar (NW-7) を作成する

このセクションでは、Codabar (NW-7) を作成する方法を説明します。

次のコードは、Codabar (NW-7) を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Codabar;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// チェックデジットの計算方法を "モジュラス 10 / ウエイト 2" に設定します。
barCode1.CheckPattern = AdvanceSoftware.ExcelCreator.BarCode.CheckPattern.Modulus10Weight2;
// スタートキャラクタを "c" に設定します。
barCode1.StartChar = 'c';
// ストップキャラクタを "c" に設定します。
barCode1.StopChar = 'c';
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
barCode1.Value = "0123456789";
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Codabar
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' チェックデジットの計算方法を "モジュラス 10 / ウエイト 2" に設定します。
BarCode1.CheckPattern = AdvanceSoftware.ExcelCreator.BarCode.CheckPattern.Modulus10Weight2
' スタートキャラクタを "c" に設定します。
BarCode1.StartChar = "c"
' ストップキャラクタを "c" に設定します。
BarCode1.StopChar = "c"
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
BarCode1.Value = "0123456789"
参照
バーコードタイプ別の作成方法
オブジェクト機能一覧 (BarCode コンポーネント)


Code39 を作成する

ここでは、Code39 を作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • Code39 を作成する
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」の「BarCode コンポーネントを追加する」を参照してください。
Code39 を作成する

このセクションでは、Code39 を作成する方法を説明します。

次のコードは、Code39 を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Code39;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// キャラクタ間のギャップを 50 ピクセルに設定します。(Code39 のみ設定可能)
barCode1.CharGap = 50;
// バーコードの最小エレメント値(バーコード幅)を 6 ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
barCode1.Value = "0123456789";
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Code39
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' キャラクタ間のギャップを 50 ピクセルに設定します。(Code39 のみ設定可能)
BarCode1.CharGap = 50
' バーコードの最小エレメント値(バーコード幅)を 6 ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
BarCode1.Value = "0123456789"
参照
バーコードタイプ別の作成方法
オブジェクト機能一覧 (BarCode コンポーネント)


Code128 を作成する

ここでは、Code128 を作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • Code128 を作成する
  • FNC1 コードの挿入する
  • コードセットを切り替える
  • ドット補正をする
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」の「BarCode コンポーネントを追加する」を参照してください。
Code128 を作成する

このセクションでは、Code128 を作成する方法を説明します。

次のコードは、Code128 を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Code128;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// スタートコードセット B に設定します。
barCode1.Codeset = AdvanceSoftware.ExcelCreator.BarCode.Codeset.CodesetB;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
barCode1.Value = "abc123";
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Code128
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' スタートコードセット B に設定します。
BarCode1.Codeset = AdvanceSoftware.ExcelCreator.BarCode.Codeset.CodesetB
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
BarCode1.Value = "abc123"
FNC1 コードを挿入する

このセクションでは、FNC1 コード等の制御コードを手動で設定する方法を説明します。"チルダ＋制御コード名"のように「~」 (チルダ) で始まる文字列を指定することでバーコードデータに任意の制御コードを設定することが可能です。

次のコードは、FNC1 コードを挿入するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Code128;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// スタートコードセット C に設定します。
barCode1.Codeset = AdvanceSoftware.ExcelCreator.BarCode.Codeset.CodesetC;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
// バーコードデータの先頭に FNC1 コードを手動で設定します。
barCode1.Value = "~FNC1" + "1234";
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Code128
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' スタートコードセット C に設定します。
BarCode1.Codeset = AdvanceSoftware.ExcelCreator.BarCode.Codeset.CodesetC
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
' バーコードデータの先頭に FNC1 コードを手動で設定します。
BarCode1.Value = "~FNC1" & "1234"
コードセットを切り替える

このセクションでは、コードセットを切り替える方法を説明します。"チルダ＋制御コード (コードセット) 名"のように「~」 (チルダ) で始まる文字列を指定することでバーコードデータ内で指定した位置でコードセットを切り替えることが可能です。

次のコードは、コードセットを切り替えるサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Code128;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// スタートコードセット C に設定します。
barCode1.Codeset = AdvanceSoftware.ExcelCreator.BarCode.Codeset.CodesetC;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
// バーコードデータの途中でコードセット B に手動で切り替えます。
barCode1.Value = 12 + "~CODEB" + "abc";
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Code128
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' スタートコードセット C に設定します。
BarCode1.Codeset = AdvanceSoftware.ExcelCreator.BarCode.Codeset.CodesetC
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
' バーコードデータの途中でコードセット B に手動で切り替えます。
BarCode1.Value = 12 & "~CODEB" & "abc"
ドット補正をする

このセクションでは、ドット補正をする方法を説明します。

次のコードは、BlackBarRevision、WhiteBarRevision プロパティでドット補正をするサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Code128;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// スタートコードセット B に設定します。
barCode1.Codeset = AdvanceSoftware.ExcelCreator.BarCode.Codeset.CodesetB;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
barCode1.Value = "abc123";
// 黒バーのドット補正値を "+1" に設定します。
barCode1.BlackBarRevision = 1;
// 白バーのドット補正値を "-1" に設定します。
barCode1.WhiteBarRevision = -1;
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Code128
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' スタートコードセット B に設定します。
BarCode1.Codeset = AdvanceSoftware.ExcelCreator.BarCode.Codeset.CodesetB
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
BarCode1.Value = "abc123"
' 黒バーのドット補正値を "+1" に設定します。
BarCode1.BlackBarRevision = 1
' 白バーのドット補正値を "-1" に設定します。
BarCode1.WhiteBarRevision = -1
参照
バーコードタイプ別の作成方法
オブジェクト機能一覧 (BarCode コンポーネント)


GS1-128 を作成する

ここでは、GS1-128 を作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • GS1-128 を作成する
  • ドット補正をする
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」の「BarCode コンポーネントを追加する」を参照してください。
Note メモ:

・GS1-128 であることを示す、スタートコード後の FNC1 は、Type プロパティで GS1 を設定することで自動付加されます。

・括弧 "("、")" はバーコードイメージ下部のバーコード文字列にのみ表示され、データには含まれません。
GS1-128 を作成する

このセクションでは、GS1-128 を作成する方法を説明します

次のコードは、GS1-128 を作成するサンプルコードです。

C#
VB
コピー
string barCodeData =
    "(01)" +           // AI(01)
    "14993857749228" + // 商品コード
    "(17)" +           // AI(17)
    "200101" +         // 有効期限
    "(30)" +           // AI(30)
    "10" +             // 数量
    "~FNC1" +          // 可変データの区切りを示す FNC1
    "(10)" +           // AI(10)
    "~CODEB" +         // Code B に切り替え
    "ABC123";          // ロット番号

barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.GS1;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// スタートコードセット C に設定します。
barCode1.Codeset = AdvanceSoftware.ExcelCreator.BarCode.Codeset.CodesetC;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
barCode1.Value = barCodeData;
Dim barCodeData As String
barCodeData = "(01)"             ' AI(01)
barCodeData += "14993857749228"  ' 商品コード
barCodeData += "(17)"            ' AI(17)
barCodeData += "200101"          ' 有効期限
barCodeData += "(30)"            ' AI(30)
barCodeData += "10"              ' 数量
barCodeData += "~FNC1"           ' 可変データの区切りを示す FNC1
barCodeData += "(10)"            ' AI(10)
barCodeData += "~CODEB"          ' Code B に切り替え
barCodeData += "ABC123"          ' ロット番号

BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.GS1
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' スタートコードセット C に設定します。
BarCode1.Codeset = AdvanceSoftware.ExcelCreator.BarCode.Codeset.CodesetC
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
BarCode1.Value = barCodeData
Note メモ:

データの途中で FNC1 などの制御コードを挿入する場合、"チルダ＋制御コード名" を入力します。(例："~FNC1"、"~CODEB" など)
ドット補正をする

このセクションでは、ドット補正をする方法を説明します。

次のコードは、BlackBarRevision、WhiteBarRevision プロパティでドット補正をするサンプルコードです。

C#
VB
コピー
string barCodeData =
    "(01)" +           // AI(01)
    "14993857749228" + // 商品コード
    "(17)" +           // AI(17)
    "200101" +         // 有効期限
    "(30)" +           // AI(30)
    "10" +             // 数量
    "~FNC1" +          // 可変データの区切りを示す FNC1
    "(10)" +           // AI(10)
    "~CODEB" +         // Code B に切り替え
    "ABC123";          // ロット番号

barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.GS1;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// スタートコードセット C に設定します。
barCode1.Codeset = AdvanceSoftware.ExcelCreator.BarCode.Codeset.CodesetC;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
barCode1.Value = barCodeData;
// 黒バーのドット補正値を "+1" に設定します。
barCode1.BlackBarRevision = 1;
// 白バーのドット補正値を "-1" に設定します。
barCode1.WhiteBarRevision = -1;
Dim barCodeData As String
barCodeData = "(01)"             ' AI(01)
barCodeData += "14993857749228"  ' 商品コード
barCodeData += "(17)"            ' AI(17)
barCodeData += "200101"          ' 有効期限
barCodeData += "(30)"            ' AI(30)
barCodeData += "10"              ' 数量
barCodeData += "~FNC1"           ' 可変データの区切りを示す FNC1
barCodeData += "(10)"            ' AI(10)
barCodeData += "~CODEB"          ' Code B に切り替え
barCodeData += "ABC123"          ' ロット番号

BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.GS1
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' スタートコードセット C に設定します。
BarCode1.Codeset = AdvanceSoftware.ExcelCreator.BarCode.Codeset.CodesetC
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
BarCode1.Value = barCodeData
' 黒バーのドット補正値を "+1" に設定します。
BarCode1.BlackBarRevision = 1
' 白バーのドット補正値を "-1" に設定します。
BarCode1.WhiteBarRevision = -1
参照
バーコードタイプ別の作成方法
オブジェクト機能一覧 (BarCode コンポーネント)


公共料金等代理収納 GS1-128 を作成する

ここでは、公共料金等代理収納 GS1-128 を作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • 公共料金等代理収納 GS1-128 を作成する
  • ドット補正をする
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」の「BarCode コンポーネントを追加する」を参照してください。
Note メモ:

公共料金等代理収納 GS1-128 であることを示すスタートコード後の FNC1 は、Type プロパティで GS1Fixed を設定することで自動付加されます。
公共料金等代理収納 GS1-128 を作成する

このセクションでは、公共料金等代理収納 GS1-128 を作成する方法を説明します。

次のコードは、公共料金等代理収納 GS1-128 を作成するサンプルコードです。

C#
VB
コピー
string barCodeData =
    "91" +                      // 識別子
    "912345" +                  // メーカーコード
    "1234567890123456789211" +  // 自由使用欄、再発行区分
    "020331" +                  // 支払い期限日
    "0" +                       // 印紙フラグ
    "123456";                   // 支払い金額

barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.GS1Fixed;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
barCode1.Value = barCodeData;
Dim barCodeData As String
barCodeData = "91"                      ' 識別子
barCodeData += "912345"                 ' メーカーコード
barCodeData += "1234567890123456789211" ' 自由使用欄、再発行区分
barCodeData += "020331"                 ' 支払い期限日
barCodeData += "0"                      ' 印紙フラグ
barCodeData += "123456"                 ' 支払い金額

BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.GS1Fixed
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
BarCode1.Value = barCodeData
ドット補正をする

このセクションでは、ドット補正をする方法を説明します。

次のコードは、BlackBarRevision、WhiteBarRevision プロパティでドット補正をするサンプルコードです。

C#
VB
コピー
string barCodeData =
    "91" +                      // 識別子
    "912345" +                  // メーカーコード
    "1234567890123456789211" +  // 自由使用欄、再発行区分
    "020331" +                  // 支払い期限日
    "0" +                       // 印紙フラグ
    "123456";                   // 支払い金額

barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.GS1Fixed;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
barCode1.Value = barCodeData;
// 黒バーのドット補正値を "+1" に設定します。
barCode1.BlackBarRevision = 1;
// 白バーのドット補正値を "-1" に設定します。
barCode1.WhiteBarRevision = -1;
Dim barCodeData As String
barCodeData = "91"                      ' 識別子
barCodeData += "912345"                 ' メーカーコード
barCodeData += "1234567890123456789211" ' 自由使用欄、再発行区分
barCodeData += "020331"                 ' 支払い期限日
barCodeData += "0"                      ' 印紙フラグ
barCodeData += "123456"                 ' 支払い金額

BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.GS1Fixed
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
BarCode1.Value = barCodeData
' 黒バーのドット補正値を "+1" に設定します。
BarCode1.BlackBarRevision = 1
' 白バーのドット補正値を "-1" に設定します。
BarCode1.WhiteBarRevision = -1
参照
バーコードタイプ別の作成方法
オブジェクト機能一覧 (BarCode コンポーネント)


カスタマバーコードを作成する

ここでは、カスタマバーコードを作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • カスタマバーコードを作成する
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」の「BarCode コンポーネントを追加する」を参照してください。
Note メモ:

住所データからバーコードデータへの変換には対応していません。
カスタマバーコードを作成する

このセクションでは、カスタマバーコードを作成する方法を説明します。

次のコードは、カスタマバーコードを作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.CustomerBarCode;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// カスタマバーコードのポイントを "10.0" に設定します。
barCode1.Point = 10.0;
barCode1.Value = "91882391-2816";
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.CustomerBarCode
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' カスタマバーコードのポイントを "10.0" に設定します。
BarCode1.Point = 10.0
BarCode1.Value = "91882391-2816"
参照
バーコードタイプ別の作成方法
オブジェクト機能一覧 (BarCode コンポーネント)


QR コードを作成する

ここでは、QR コードを作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • QR コードを作成する
  • QR コードを携帯で読み取る
  • QR コードを自動で連結する
  • QR コードを手動で連結する
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」の「BarCode コンポーネントを追加する」を参照してください。
QR コードを作成する

このセクションでは、QR コードを作成する方法を説明します。

次のコードは、QR コードを作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// QR コードのエラー訂正レベルを "H" に設定します。
barCode1.QRLevel = AdvanceSoftware.ExcelCreator.BarCode.QRLevel.LevelH;
// QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
barCode1.QRMask = AdvanceSoftware.ExcelCreator.BarCode.QRMask.Mask000;
// QR コードのモデルを "モデル 1" に設定します。
barCode1.QRModel = AdvanceSoftware.ExcelCreator.BarCode.QRModel.Model1;
// QR コードの型番を "10 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.ExcelCreator.BarCode.QRVersion.Version10;
barCode1.Element = 10;
barCode1.Value = "123456789";
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' QR コードのエラー訂正レベルを "H" に設定します。
BarCode1.QRLevel = AdvanceSoftware.ExcelCreator.BarCode.QRLevel.LevelH
' QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
BarCode1.QRMask = AdvanceSoftware.ExcelCreator.BarCode.QRMask.Mask000
' QR コードのモデルを "モデル 1" に設定します。
BarCode1.QRModel = AdvanceSoftware.ExcelCreator.BarCode.QRModel.Model1
' QR コードの型番を "10 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.ExcelCreator.BarCode.QRVersion.Version10
BarCode1.Element = 10
BarCode1.Value = "123456789"
QR コードを携帯で読み取る

このセクションでは、QR コードを携帯で読み取る方法を説明します。

Note メモ:

携帯電話で読み取り可能な QR コードの仕様は、各携帯電話のキャリアによって細かい仕様は異なりますが、基本的な仕様は、モデル (モデル 2)、バージョン (1～10) に統一されています。

次のコードは、QRModel プロパティでモデルを [Model2] に設定し、QRVersion プロパティでバージョン [10] を設定するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// QR コードのモデルを "モデル 2" に設定します。
barCode1.QRModel = AdvanceSoftware.ExcelCreator.BarCode.QRModel.Model2;
// QR コードの型番を "10 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.ExcelCreator.BarCode.QRVersion.Version10;
barCode1.Element = 10;
barCode1.Value = "https://www.adv.co.jp/";
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' QR コードのモデルを "モデル 2" に設定します。
BarCode1.QRModel = AdvanceSoftware.ExcelCreator.BarCode.QRModel.Model2
' QR コードの型番を "10 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.ExcelCreator.BarCode.QRVersion.Version10
BarCode1.Element = 10
BarCode1.Value = "https://www.adv.co.jp/"
QR コードを自動で連結する

このセクションでは、QR コードを自動で連結する方法を説明します。

次のコードは、QRConnect プロパティで [AutoConnect] を設定し、QR コードを自動で連結して作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// QR コードのモデルを "モデル 2" に設定します。
barCode1.QRModel = AdvanceSoftware.ExcelCreator.BarCode.QRModel.Model2;
// QR コードの型番を "2 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.ExcelCreator.BarCode.QRVersion.Version2;
barCode1.Element = 10;
// 連結 QR コードを自動で作成します。
barCode1.QRConnect = AdvanceSoftware.ExcelCreator.BarCode.QRConnect.AutoConnect;
// シンボル番号を初期化します。
barCode1.QRSymbolNumber = 0;
barCode1.Value = "123456789123456789123456789123456789";

System.Drawing.Image img;
AdvanceSoftware.ExcelCreator.BarCode.BarCodeSizeD barCodeSizeD;
// 最大シンボル数分ループを回し、1 シンボルずつ帳票に出力します。
for (int symbol = 0; symbol < 16; symbol++)
{
    // 出力する QR コードのシンボル番号を指定します。(0～15)
    barCode1.QRSymbolNumber = symbol;
    // QR イメージを取得します。
    img = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Png);
    // イメージの取得に失敗した場合(シンボル数を超えた場合)ループを抜けます。
    if (barCode1.ErrorNo == AdvanceSoftware.ExcelCreator.BarCode.ErrorNo.QRConnectPos)
        break;
    // QR コードの実寸を取得します。
    barCodeSizeD = barCode1.GetScaleSize(AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter);
    // 指定した番号の QR イメージを任意のセルに挿入します。
    creator1.Pos(symbol, 0).Drawing.AddImage(img, barCodeSizeD.Width, barCodeSizeD.Height);
}
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' QR コードのモデルを "モデル 2" に設定します。
BarCode1.QRModel = AdvanceSoftware.ExcelCreator.BarCode.QRModel.Model2
' QR コードの型番を "2 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.ExcelCreator.BarCode.QRVersion.Version2
BarCode1.Element = 10
' 連結 QR コードを自動で作成します。
BarCode1.QRConnect = AdvanceSoftware.ExcelCreator.BarCode.QRConnect.AutoConnect
' シンボル番号を初期化します。
BarCode1.QRSymbolNumber = 0
BarCode1.Value = "123456789123456789123456789123456789"

Dim symbol As Integer
Dim img As System.Drawing.Image
Dim BarCodeSizeD As AdvanceSoftware.ExcelCreator.BarCode.BarCodeSizeD
' 最大シンボル数分ループを回し、1 シンボルずつ帳票に出力します。
For symbol = 0 To 15
    ' 出力する QR コードのシンボル番号を指定します。(0～15)
    BarCode1.QRSymbolNumber = symbol
    ' QR イメージを取得します。
    img = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Png)
    ' イメージの取得に失敗した場合(シンボル数を超えた場合)ループを抜けます。
    If (BarCode1.ErrorNo = AdvanceSoftware.ExcelCreator.BarCode.ErrorNo.QRConnectPos) Then
        Exit For
    End If
    ' QR コードの実寸を取得します。
    BarCodeSizeD = BarCode1.GetScaleSize(AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter)
    ' 指定した番号の QR イメージを任意のセルに挿入します。
    Creator1.Pos(symbol, 0).Drawing.AddImage(img, BarCodeSizeD.Width, BarCodeSizeD.Height)
Next
QR コードを手動で連結する

このセクションでは、QR コードを手動で連結する方法を説明します。

次のコードは、QRConnect プロパティで [ManualConnect] を設定し、QR コードを手動で連結して作成するサンプルコードです。任意のエスケープコード + "S" を設定して、QR コードを分割します。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// QR コードのモデルを "モデル 2" に設定します。
barCode1.QRModel = AdvanceSoftware.ExcelCreator.BarCode.QRModel.Model2;
// QR コードの型番を "2 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.ExcelCreator.BarCode.QRVersion.Version2;
barCode1.Element = 10;
// 連結 QR コードを手動で作成します。
barCode1.QRConnect = AdvanceSoftware.ExcelCreator.BarCode.QRConnect.ManualConnect;
// QR コードのエスケープコードを "% (0x25)" に設定します。
barCode1.QREscapeCode = 0x25;
barCode1.Value = "12345%SABCDE";

System.Drawing.Image img1, img2;
AdvanceSoftware.ExcelCreator.BarCode.BarCodeSizeD barCodeSizeD;
// QR コードの実寸を取得します。
barCodeSizeD = barCode1.GetScaleSize(AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter);
// 1 つ目の連結 QR コードを出力します。
barCode1.QRSymbolNumber = 0;
img1 = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Png);
cellReport1.Cell("A1").Drawing.AddImage(img1, barCodeSizeD.Width, barCodeSizeD.Height);
// 2 つ目の連結 QR コードを出力します。
barCode1.QRSymbolNumber = 1;
img2 = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Png);
cellReport1.Cell("B1").Drawing.AddImage(img2, barCodeSizeD.Width, barCodeSizeD.Height);
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' QR コードのモデルを "モデル 2" に設定します。
BarCode1.QRModel = AdvanceSoftware.ExcelCreator.BarCode.QRModel.Model2
' QR コードの型番を "2 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.ExcelCreator.BarCode.QRVersion.Version2
BarCode1.Element = 10
' 連結 QR コードを手動で作成します。
BarCode1.QRConnect = AdvanceSoftware.ExcelCreator.BarCode.QRConnect.ManualConnect
' QR コードのエスケープコードを "% (0x25)" に設定します。
BarCode1.QREscapeCode = &H25
BarCode1.Value = "12345%SABCDE"

Dim img1, img2 As System.Drawing.Image
Dim BarCodeSizeD As AdvanceSoftware.ExcelCreator.BarCode.BarCodeSizeD
' QR コードの実寸を取得します。
BarCodeSizeD = BarCode1.GetScaleSize(AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter)
' 1 つ目の連結 QR コードを出力します。
BarCode1.QRSymbolNumber = 0
img1 = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Png)
CellReport1.Cell("A1").Drawing.AddImage(img1, BarCodeSizeD.Width, BarCodeSizeD.Height)
' 2 つ目の連結 QR コードを出力します。
BarCode1.QRSymbolNumber = 0
img2 = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Png)
CellReport1.Cell("B1").Drawing.AddImage(img2, BarCodeSizeD.Width, BarCodeSizeD.Height)
参照
バーコードタイプ別の作成方法
オブジェクト機能一覧 (BarCode コンポーネント)


PDF417 を作成する

ここでは、PDF417 を作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • PDF417 を作成する
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」の「BarCode コンポーネントを追加する」を参照してください。
PDF417 を作成する

このセクションでは、PDF417 を作成する方法を説明します。

次のコードは、PDF417 を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.PDF417;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
// PDF417 の列数を "15列" に設定します。
barCode1.PDFColumn = 15;
// PDF417 の初期化シンボルを "付加する" に設定します。
barCode1.PDFInitialSymbol = true;
// PDF417 のエラー訂正レベルを "レベル5" に設定します。
barCode1.PDFLevel = 5;
// PDF417 シンボルを "簡易 PDF417" に設定します。
barCode1.PDFModel = AdvanceSoftware.ExcelCreator.BarCode.PDFModel.Truncated;
// PDF417 の行数を "10行" に設定します。
barCode1.PDFRow = 10;
barCode1.Value = "01234567890123456789";
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.PDF417
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
' PDF417 の列数を "15列" に設定します。
BarCode1.PDFColumn = 15
' PDF417 の初期化シンボルを "付加する" に設定します。
BarCode1.PDFInitialSymbol = True
' PDF417 のエラー訂正レベルを "レベル5" に設定します。
BarCode1.PDFLevel = 5
' PDF417 シンボルを "簡易 PDF417" に設定します。
BarCode1.PDFModel = AdvanceSoftware.ExcelCreator.BarCode.PDFModel.Truncated
' PDF417 の行数を "10行" に設定します。
BarCode1.PDFRow = 10
BarCode1.Value = "01234567890123456789"
参照
バーコードタイプ別の作成方法
オブジェクト機能一覧 (BarCode コンポーネント)


ExcelCreator 12.0 for .NET の対応する Excel 修飾機能

ExcelCreator 12.0 for .NET で設定可能な Excel の機能およびデザイン Excel ファイルに設定してある Excel の各種設定が、Excel、PDF、HTML ファイル出力時に反映されるかを表します。
掲載のない機能は基本的に動作保証を行っていない機能となりますが、詳細については「サポートサービス」よりお問い合わせください。

項目について

新規設定 / 編集 | ExcelCreator 12.0 for .NET で Excel ファイルの新規作成や編集を行う場合に対応する関数の有無を表します。
オーバーレイ | デザイン Excel ファイルに設定してある Excel の各種設定が、ExcelCreator 12.0 for .NET で出力した Excel、PDF、HTML ファイルに引き継がれるかを表します。 ※Excel 2007 以降の互換モードで作成された xls 形式のファイルは正式な動作確認、保証をしていません。

機能一覧表

[○ = 対応、× = 未対応、△ = 制限あり、－ = 該当なし]
Excel 設定項目 | 対応関数 | 新規設定 / 編集 | xls 形式 オーバーレイ |  |  | xlsx 形式 オーバーレイ
 |  |  | Excel | PDF | HTML | Excel | PDF | HTML
[ページ設定] - [ページ]
印刷の向き (縦 / 横) Size ○ ○ ○ － ○ ○ －
拡大縮小印刷 (拡大 / 縮小) Size ○ ○ ○ ○ ○ ○ ○
拡大縮小印刷 (横 1~32767×縦 1~32767) × × ○ × × ○ × ×
用紙サイズ Size
SizeFree 		○ ○ ○ ○ ○ ○ ○
印刷品質 × × ○ － － ○ － －
先頭ページ番号 × × ○ × － ○ × －
[ページ設定] - [余白]
余白 (上 / 下 / 左 / 右 / ヘッダー / フッター) Margin ○ ○ ○ × ○ ○ ×
余白 (ページ中央：水平 / 垂直) Center ○ ○ ○ × ○ ○ ×
[ページ設定] - [ヘッダー / フッター]
ヘッダー / フッター (左詰 [&L] / 中央揃え [&C] / 右詰 [&R] / 二重下線 [&E] / 上付き文字 [&X] / 下付き文字 [&Y] / 太字 [&B] / 斜体 [&I] / 下線付き [&U] / 取り消し線 [&S] / 日付 [&D] / 時刻 [&T] / シート見出し名 [&A] / ページ番号 [&P] / 表示 [&&] / 総ページ数 [&N] / フォント名 [&"フォント名"] / フォントサイズ [&nn]) Header
Header2
Footer
Footer2 		○ ○ ○ × ○ ○ ×
ヘッダー / フッター (ファイル名 [&F]) × × ○ × × ○ × ×
ヘッダー / フッター (図) × × ○ × × ○ × ×
[ページ設定] - [シート]
印刷範囲 PrintArea
ApplyPrintArea 		○ ○ △(*1) × ○ △(*1) ×
印刷タイトル (行のタイトル / 列のタイトル) PrintTitle ApplyPrintTitle ○ ○ △(*2) × ○ △(*2) ×
ページの方向 (左から右へ / 上から下へ) PageOrder ○ ○ ○ － ○ ○ －
[コピー] (*3)
セルコピー Copy ○ － － － － － －
行コピー RowCopy ○ － － － － － －
列コピー ColumnCopy ○ － － － － － －
[貼り付け] (*3)
セル貼り付け Paste ○ － － － － － －
行貼り付け RowPaste ○ － － － － － －
列貼り付け ColumnPaste ○ － － － － － －
コピーしたセルを行挿入 RowInsertCopied ○ － － － － － －
コピーしたセルを列挿入 ColumnInsertCopied ○ － － － － － －
[クリア]
セルクリア Clear ○ － － － － － －
行クリア RowClear ○ － － － － － －
列クリア ColumnClear ○ － － － － － －
[削除]
セル削除 × × － － － － － －
行削除 RowDelete ○ － － － － － －
列削除 ColumnDelete ○ － － － － － －
[シートの削除 / 移動 / コピー]
シート削除 DeleteSheet ○ － － － － － －
シート移動 × × － － － － － －
シートコピー(*4) CopySheet ○ － － － － － －
[表示]
ズーム (倍率) Zoom ○ ○ × × ○ × ×
改ページプレビュー × × ○ － － ○ － －
[挿入]
セル挿入 × － － － － － － －
行挿入 RowInsert ○ － － － － － －
列挿入 ColumnInsert ○ － － － － － －
ワークシート挿入 AddSheet ○ － － － － － －
改ページ Break ○ ○ ○ － ○ ○ －
コメント × × ○ × × ○ × ×
ワードアート × × ○ × × ○ × ×
グラフ(*5) × × ○ △(*6) × ○ △(*6) ×
グラフシート × × × × × × × ×
名前の定義 × × △(*7) － － △(*7) － －
関数の挿入 Func ○ ○ △(*8) △(*8) ○ △(*8) △(*8)
図 (bmp、dib、gif、jpg、png) AddImage ○ ○ ○ ○ ○ ○ ○
オブジェクト × × ○ × × ○ × ×
オートシェイプ AddShape
AddLine 		○ ○ △(*9) × ○ △(*9) ×
テキストボックス AddTextBox ○ ○ ○ × ○ ○ ×
グループ化 (オブジェクト) × × ○ × × ○ × ×
[オートシェイプの書式設定] - [色と線]
[図形の書式設定] - [塗りつぶし] / [線の色] / [線のスタイル]
塗りつぶし (単色) FillColor
FillColor2 		○ ○ ○ × ○ ○ ×
塗りつぶし (塗りつぶしなし) ShapeNoFill ○ ○ ○ × ○ ○ ×
塗りつぶし効果 / 塗りつぶし (グラデーション) × × ○ × × ○ × ×
塗りつぶし (透明 / 透過性) × × ○ × × ○ × ×
線の色 (単色) LineColor
LineColor2 		○ ○ ○ × ○ ○ ×
線の色 (透明 / 透過性) × × ○ × × ○ × ×
実線 / 点線 LineStyle ○ ○ ○ × ○ ○ ×
太さ / 幅 LineWeight ○ ○ ○ × ○ ○ ×
コネクタ × × ○ × × ○ × ×
始点のスタイル / 種類 / サイズ ArrowTypeS ○ ○ ○ × ○ ○ ×
終点のスタイル / 種類 / サイズ ArrowTyoeE ○ ○ ○ × ○ ○ ×
[テキストボックスの書式設定] - [配置]
[図形の書式設定] - [テキストボックス] - [テキストのレイアウト]
文字の配置 (縦位置 / 横位置) / 垂直方向の配置 TextAlign
TextAnchor 		○ ○ ○ × ○ ○ ×
方向 / 文字列の方向 TextVertical ○ ○ △(*10) × ○ △(*10) ×
[テキストボックスの書式設定] - [フォント] (*11)
フォント名 FontName ○ ○ ○ × ○ ○ ×
スタイル (標準 / 太字 / 斜体) FontStyle ○ ○ ○ × ○ ○ ×
サイズ FontPoint ○ ○ ○ × ○ ○ ×
下線 / 下線のスタイル (なし / 下線 / 二重下線) FontULine ○ ○ ○ × ○ ○ ×
色 / フォントの色 FontColor
FontColor2 		○ ○ ○ × ○ ○ ×
文字飾り (取り消し線 / 上付き / 下付き) × × ○ ○ × ○ ○ ×
[セルの書式設定] - [表示形式]
分類（標準 / 数値 / 通貨 / 会計 / 日付 / 時刻 / パーセンテージ / 分数 / 指数 / 文字列 / その他 / ユーザー定義) Format ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [配置]
横位置 (標準 / 左詰め / 中央揃え / 右詰め / 繰り返し / 両端揃え / 選択範囲内で中央 / 均等割り付け) HorizontalAlignment ○ ○ △(*12) △(*13) ○ △(*12) △(*13)
縦位置 (上詰め / 中央揃え / 下詰め / 両端揃え / 均等割り付け) VerticalAlignment ○ ○ ○ △(*14) ○ ○ △(*14)
文字の制御 (折り返して全体を表示する) WrapText ○ ○ ○ ○ ○ ○ ○
文字の制御 (縮小して全体を表示する) ShrinkToFit ○ ○ ○ × ○ ○ ×
文字の制御 (セルを結合する) MergeCells ○ ○ ○ ○ ○ ○ ○
方向 (縦書き / -90～90 度) Orientation ○ ○ ○ × ○ ○ ×
[セルの書式設定] - [フォント] (*11)
フォント名 FontName ○ ○ ○ ○ ○ ○ ○
スタイル (標準 / 太字 / 斜体 / 太字＋斜体) FontStyle ○ ○ ○ ○ ○ ○ ○
サイズ FontPoint ○ ○ ○ ○ ○ ○ ○
下線 (なし / 下線 / 二重下線) FontULine ○ ○ ○ △(*15) ○ ○ △(*15)
色 FontColor
FontColor2 		○ ○ ○ ○ ○ ○ ○
文字飾り (取り消し線 / 上付き / 下付き) FontStyle ○ ○ ○ △(*16) ○ ○ △(*16)
[セルの書式設定] - [罫線]
プリセット (外枠) Box ○ ○ ○ ○ ○ ○ ○
罫線 (上) LineTop ○ ○ ○ ○ ○ ○ ○
罫線 (下) LineBottom ○ ○ ○ ○ ○ ○ ○
罫線 (左) LineLeft ○ ○ ○ ○ ○ ○ ○
罫線 (右) LineRight ○ ○ ○ ○ ○ ○ ○
罫線 (左上がり) LineLeftUp ○ ○ ○ × ○ ○ ×
罫線 (右上がり) LineRightUp ○ ○ ○ × ○ ○ ×
罫線 (方向 -90～90 度) × × ○ × × ○ × ×
線 (スタイル) Box
LineTop
LineBottom
LineLeft
LineRight
LineLeftUp
LineRightUp 		○ ○ ○ △(*17) ○ ○ △(*17)
罫線 (色) Box
LineTop
LineBottom
LineLeft
LineRight
LineLeftUp
LineRightUp 		○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [パターン] / [塗りつぶし]
セルの網掛け (色) / 背景色 BackColor
BackColor2 		○ ○ ○ ○ ○ ○ ○
塗りつぶし効果 (グラデーション) × × － － － ○ × ×
パターンの色 ForeColor
ForeColor2 		○ ○ ○ ○ ○ ○ ○
セルの網掛け (パターン) / パターンの種類 Pattern ○ ○ ○ ○ ○ ○ ○
[書式] - [行] / [列]
高さ / 行の高さ RowHeight ○ ○ ○ ○ ○ ○ ○
高さ / 行の高さの自動調整 × × × × × × × ×
幅 / 列の幅 ColWidth ○ ○ ○ ○ ○ ○ ○
幅 / 列の幅の自動調整 × × × × × × × ×
[書式] - [シート]
名前の変更 / シート名の変更 SheetName ○ ○ ○ － ○ ○ －
非表示 / 再表示 × × ○ － － ○ － －
[書式]
条件付き書式 × × × × × × × ×
[ツール]
[開発]
マクロ × × × × × × × ×
[ツール]-[オプション] - [全般]
[Excel のオプション] - [基本設定]
標準フォント名 DefaultFontName ○ ○ ○ ○ ○ ○ ○
標準フォントサイズ DefaultFontPoint ○ ○ ○ ○ ○ ○ ○
[ツール] - [保護]
[校閲]
シートの保護 × × ○ － － ○ － －
ブックの保護 × × × － － × － －
ブックのシート数 CreateBook (*18) ○ ○ － － ○ － －
[データ]
フィルタ × × × × × × × ×
集計 × × × × × × × ×
入力規則 × × × × × × × ×
ピボットテーブル × × × × × × × ×
アウトライン × × × × × × × ×
[ウィンドウ]
[表示]
分割 × × ○ － － ○ － －
ウィンドウ枠の固定 × × ○ － － ○ － －
[ページレイアウト]
テーマ × × － － － × × ×
Note メモ:

(*1)ApplyPrintArea プロパティにて対応。

(*2)ApplyPrintTitle プロパティにて対応。

(*3)Excel シートをまたいだ処理には未対応。

(*4)同一 Excel ファイルのシートコピーのみ対応。

(*5)グラフの編集には未対応。

(*6)テンプレートの Excel ファイルに登録されたグラフ情報の取得、および出力した PDF ファイルにグラフイメージを追加する機能に対応。グラフイメージ生成処理はユーザーが独自に実装する必要があります。

(*7)ブック名が設定された名前の定義には未対応。

(*8)一部関数は ReCalcValue プロパティにて対応。

(*9)出力可能なオートシェイプは(右図)のみです。ただし、Excel 2007 以降で作成した xls ファイルでは台形に未対応。

(*10)文字列の方向 (縦書き) で半角英数字の描画は未対応。

(*11)同一セル内、テキストボックス内で複数の書式を設定することはできません。

(*12)横位置 (繰り返し) は未対応。

(*13)横位置 (繰り返し / 両端揃え / 選択範囲内で中央) は未対応。

(*14)縦位置 (両端揃え / 均等割り付け) は未対応。

(*15)下線 (二重下線) は未対応。

(*16)文字飾り (上付き / 下付き) は未対応。

(*17)直線以外のスタイルは、破線、点線として表示されます。

(*18)新規に Excel ファイルを作成する場合のみシート数を設定することができます。

 描画可能なオートシェイプ


基本操作

ここでは、ExcelCreator 12.0 for .NET の基本操作について説明します。

Excel ファイル生成時の動作モードを設定する

大量データを使用する場合の Excel ファイル生成の動作モードを設定する方法を説明します。

Excel ファイルをオープン、クローズする

さまざまなファイルの作成方法と出力方法を説明します。

ブック属性を設定する

ブック属性を設定する方法を説明します。

シートを操作する

シートの操作方法や属性の設定方法を説明します。

セルを操作する

セルの操作方法や、値、属性、オブジェクトの設定方法を説明します。

PDF 出力オプションを設定する

出力 PDF ファイルのオプションの設定方法を説明します。

HTML 出力オプションを設定する

出力 HTML ファイルのオプションの設定方法を説明します。


Excel ファイル生成の動作モードを設定する

ExcelCreator 12.0 for .NET では、Excel ファイル生成時の動作モードを選択することが可能です。このモードを使用することで、通常の動作モードよりメモリ消費量を少なく抑えることができ、大量のデータを扱う処理にも対応することができます。

このトピックは、次のセクションを含みます。

  • StreamMode プロパティを使用する
  • StreamMode=File 使用時の制限
  • 参照
StreamMode プロパティを使用する

Excel ファイル生成時の動作モード切り替えは、StreamMode プロパティを使用します。

値 | 動作
Memory | 通常の動作モードです。(既定値)
File | 通常の動作モードよりメモリ消費量を少なく抑え、Excel ファイルを生成します。

次のコードは、StreamMode プロパティを File に設定して Excel ファイルをオーバーレイオープンします。

C#
VB
コピー
creator1.StreamMode = AdvanceSoftware.ExcelCreator.StreamMode.File;
creator1.OpenBook("C:\\Data\\Out.xlsx", "C:\\Data\\Template.xlsx");
creator1.CloseBook(true);
Creator1.StreamMode = AdvanceSoftware.ExcelCreator.StreamMode.File
Creator1.OpenBook("C:\Data\Out.xlsx", "C:\Data\Template.xlsx")
Creator1.CloseBook(True)
StreamMode=File 使用時の制限

StreamMode プロパティを File に設定して Excel ファイル生成を行う場合、次の機能が使用できません。

変数名を使用したセルの指定

変数名（セルに設定した特定のキーワード文字列（"**" から始まる文字列））でセルを指定することができません。StreamMode=File 時に使用した場合、「動作モードエラー」となります。
また、オーバーレイオープンでオーバーレイ元の Excel ファイルに変数名が設定されている場合、作成した Excel ファイルから変数名の文字列は削除されません。

Note メモ:

変数名の使用に関する詳細は、「セルを指定する」をご確認ください。

未対応のプロパティ、メソッド一覧

StreamMode プロパティを File に設定して Excel ファイル生成を行う場合の未対応のプロパティ、メソッドの一覧です。

Note メモ:

(*) のメソッドを使用した場合、「動作モードエラー」となります。

メソッド／プロパティ | 動作
Clear メソッド(*) | セルのデータをクリアします。
Copy メソッド(*) | セルのデータをコピーします。
Paste メソッド(*) | コピーしたセルのデータを貼り付けます。
ColumnClear メソッド(*) | 列をクリアします。
ColumnCopy メソッド(*) | 列をコピーします。
ColumnPaste メソッド(*) | コピーした列を貼り付けます。
ColumnDelete メソッド(*) | 列を削除します。
ColumnInsert メソッド(*) | 列を挿入します。
ColumnInsertCopied メソッド(*) | 挿入した列にコピーします。
RowClear メソッド(*) | 行をクリアします。
RowCopy メソッド(*) | 行をコピーします。
RowPaste メソッド(*) | コピーした行を貼り付けます。
RowDelete メソッド(*) | 行を削除します。
RowInsert メソッド(*) | 行を挿入します。
RowInsertCopied メソッド(*) | 挿入した行をコピーします。
TableRowDelete メソッド(*) | 複数行を削除します。
TableRowInsert メソッド(*) | 複数行を挿入します。
GetMaxArea メソッド(*) | データ、または、属性の最終座標を取得します。
GetMaxData メソッド(*) | データの最終座標を取得します。
CopySheet メソッド(*) | シートをコピーします。
GetVarNamePos メソッド | 変数名の座標を取得します。
VarCheck メソッド | 変数名の有無をチェックします。
Keyword プロパティ | 変数名のキーワード文字列を指定します。
VarInsertMode プロパティ | 変数名の差し込みモードを指定します。
InitFormulaAnswer プロパティ | 計算式の結果をクリアします。
参照
オブジェクト機能一覧 (Creator クラス)
基本操作


Excel ファイルをオープン、クローズする

ExcelCreator 12.0 for .NET では、オープン処理でファイルの作成方法、クローズ処理でファイルの出力方法を設定することが可能です。ここでは、さまざまなファイルの作成方法と出力方法を説明します。

Excel ファイルを新規作成する

Excel ファイルを新規作成する方法を説明します。

複数の Excel ファイルを作成する

複数の Excel ファイルを新規作成する方法を説明します。

Excel ファイルを上書きオープンする

既存の Excel ファイルを上書きでオープンする方法を説明します。

Excel ファイルをオーバーレイオープンする

既存の Excel ファイルをテンプレートとしてオープンする方法を説明します。

Excel ファイルをオーバーレイオープンする (埋め込み)

プロジェクトに埋め込んだ Excel ファイルをオープンする方法を説明します。

Excel ファイルを読み取り専用でオープンする

既存の Excel ファイルを読み取り専用でオープンする方法を説明します。

PDF ファイルを出力する

PDF ファイルを作成する方法を説明します。

PDF ファイル出力時のフォントについて

PDF ファイル出力時のフォントについて説明します。

HTML ファイルを出力する

HTML ファイルを作成する方法を説明します。


Excel ファイルを新規作成する

ExcelCreator 12.0 for .NET では、CreateBook メソッドを使用して Excel ファイルを新規作成することが可能で、シート数や Excel ファイルバージョンも同時に指定できます。 処理の最後には、CloseBook メソッドを呼び出し、Excel ファイルをクローズする必要があります。このトピックでは、Excel ファイルの新規作成方法を説明します。

このトピックは、次のセクションを含みます。

  • Excel ファイルを新規作成する
  • Excel ファイルを新規作成する (ストリーム出力)
  • 参照
Excel ファイルを新規作成する

次のコードは、シート数：3、Excel バージョン：2021 で C:\Data フォルダに Excel ファイル (Out.xlsx) を新規作成するサンプルコードです。

C#
VB
コピー
// シート数:3、Excel バージョン:2021 で C:\Data フォルダに Excel ファイル (Out.xlsx) を新規作成します。
creator1.CreateBook(@"C:\Data\Out.xlsx", 3, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021);
creator1.CloseBook(true);
' シート数:3、Excel バージョン:2021 で C:\Data フォルダに Excel ファイル (Out.xlsx) を新規作成します。
Creator1.CreateBook("C:\Data\Out.xlsx", 3, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021)
Creator1.CloseBook(True)
Excel ファイルを新規作成する (ストリーム出力)

次のコードは、シート数:3、Excel バージョン:2021 で Excel ファイルを新規作成し、ストリームに出力するサンプルコードです。

C#
VB
コピー
System.IO.MemoryStream strmExcel = new System.IO.MemoryStream();
// シート数:3、Excel バージョン:2021 で Excel ファイルを新規作成し、ストリームに出力します。
creator1.CreateBook(strmExcel, 3, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021);
creator1.CloseBook(true);
strmExcel.Close();
Dim strmExcel As System.IO.Stream = New System.IO.MemoryStream
' シート数:3、Excel バージョン:2021 で Excel ファイルを新規作成し、ストリームに出力します。
Creator1.CreateBook(strmExcel, 3, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021)
Creator1.CloseBook(True)
strmExcel.Close()
参照
オブジェクト機能一覧 (Creator クラス)
基本操作


複数の Excel ファイルを作成する

ExcelCreator 12.0 for .NET では、CreateBookEx メソッドで複数の Excel ファイルを新規作成し、複数の Excel ファイルを制御することが可能です。新規作成、または、オープンした Excel ファイルの識別用オブジェクトを元に、プログラムで SelectBook メソッドを使用して複数の Excel ファイルを扱うことができます。処理の最後には、CloseBookEx メソッドを呼び出し、Excel ファイルをクローズする必要があります。このトピックでは、複数の Excel ファイルを新規作成し、複数の Excel ファイルを制御する方法を説明します。

このトピックは、次のセクションを含みます。

  • 複数のファイルを作成してファイルに出力する
  • 複数のファイルを作成してストリームに出力する
  • 参照
複数のファイルを作成してファイルに出力する

次のコードは、同時に 2 つの Excel ファイルを新規作成し、各ファイルの先頭シートの A1 セルに文字列を設定してファイルに出力するサンプルコードです。

C#
VB
コピー
object book1 = 0;
object book2 = 0;

// 1 つ目の Excel ファイルを新規に作成します
creator1.CreateBookEx("C:\\Data\\ExcelFile01.xlsx", 3, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021, out book1);
// 2 つ目の Excel ファイルを新規に作成します
creator1.CreateBookEx("C:\\Data\\ExcelFile02.xlsx", 3, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021, out book2);
// 1 つ目の Excel ファイルを選択し、文字列を設定します
creator1.SelectBook(book1);
creator1.Cell("A1").Str = "アドバンスソフトウェア株式会社";
// 2 つ目の Excel ファイルを選択し、文字列を設定します
creator1.SelectBook(book2);
creator1.Cell("A1").Str = "advance software";
// Excelファイルを閉じます
creator1.CloseBookEx(true, book1);
creator1.CloseBookEx(true, book2);
Dim book1 As Object = 0
Dim book2 As Object = 0

' 1 つ目の Excel ファイルを新規に作成します
Creator1.CreateBookEx("C:\Data\ExcelFile01.xlsx", 3, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021, book1)
' 2 つ目の Excel ファイルを新規に作成します
Creator1.CreateBookEx("C:\Data\ExcelFile02.xlsx", 3, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021, book2)
' 1 つ目の Excel ファイルを選択し、文字列を設定します
Creator1.SelectBook(book1)
Creator1.Cell("A1").Str = "アドバンスソフトウェア株式会社"
' 2 つ目の Excel ファイルを選択し、文字列を設定します
Creator1.SelectBook(book2)
Creator1.Cell("A1").Str = "advance software"
' Excel ファイルを閉じます
Creator1.CloseBookEx(True, book1)
Creator1.CloseBookEx(True, book2)
複数のファイルを作成してストリームに出力する

次のコードは、同時に 2 つの Excel ファイルを新規作成し、各ファイルの先頭シートの A1 セルに文字列を設定してストリームに出力するサンプルコードです。

C#
VB
コピー
object book1 = 0;
object book2 = 0;
System.IO.MemoryStream outStreamExcel1 = new System.IO.MemoryStream();
System.IO.MemoryStream outStreamExcel2 = new System.IO.MemoryStream();

// 1 つ目の Excel ファイルを新規に作成します
creator1.CreateBookEx(outStreamExcel1, 3, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021, out book1);
// 2 つ目の Excel ファイルを新規に作成します
creator1.CreateBookEx(outStreamExcel2, 3, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021, out book2);
// 1 つ目の Excel ファイルを選択し、文字列を設定します
creator1.SelectBook(book1);
creator1.Cell("A1").Str = "アドバンスソフトウェア株式会社";
// 2 つ目の Excel ファイルを選択し、文字列を設定します
creator1.SelectBook(book2);
creator1.Cell("A1").Str = "advance software";
// Excelファイルを閉じます
creator1.CloseBookEx(true, book1);
creator1.CloseBookEx(true, book2);
// ストリームを閉じます
outStreamExcel1.Close();
outStreamExcel2.Close();
Dim book1 As Object = 0
Dim book2 As Object = 0
Dim outStreamExcel1 As System.IO.Stream = New System.IO.MemoryStream
Dim outStreamExcel2 As System.IO.Stream = New System.IO.MemoryStream

' 1 つ目の Excel ファイルを新規に作成します
Creator1.CreateBookEx(outStreamExcel1, 3, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021, book1)
' 2 つ目の Excel ファイルを新規に作成します
Creator1.CreateBookEx(outStreamExcel2, 3, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021, book2)
' 1 つ目の Excel ファイルを選択し、文字列を設定します
Creator1.SelectBook(book1)
Creator1.Cell("A1").Str = "アドバンスソフトウェア株式会社"
' 2 つ目の Excel ファイルを選択し、文字列を設定します
Creator1.SelectBook(book2)
Creator1.Cell("A1").Str = "advance software"
' Excel ファイルを閉じます
Creator1.CloseBookEx(True, book1)
Creator1.CloseBookEx(True, book2)
' ストリームを閉じます
outStreamExcel1.Close()
outStreamExcel2.Close()
参照
オブジェクト機能一覧 (Creator クラス)
基本操作


Excel ファイルを上書きオープンする

ExcelCreator 12.0 for .NET では、OpenBook メソッドを使用して既存の Excel ファイルを上書きオープンすることが可能です。処理の最後には CloseBook メソッドを呼び出し、Excel ファイルをクローズする必要があります。 このトピックでは、既存の Excel ファイルを上書きオープンする方法を説明します。

Excel ファイルを上書きオープンする

次のコードは C:\Data フォルダにある Excel ファイル (Template.xlsx) を上書きでオープンするサンプルコードです。

C#
VB
コピー
// C:\Data フォルダにある Excel ファイル (Template.xlsx) を上書きでオープンします。
creator1.OpenBook("C:\\Data\\Template.xlsx", "");
creator1.CloseBook(true);
' C:\Data フォルダにある Excel ファイル (Template.xlsx) を上書きでオープンします。
Creator1.OpenBook("C:\Data\Template.xlsx", "")
Creator1.CloseBook(True)
参照
オブジェクト機能一覧 (Creator クラス)
基本操作


Excel ファイルをオーバーレイオープンする

ExcelCreator 12.0 for .NET では、OpenBook メソッドを使用して既存の Excel ファイルをテンプレートとしてオープンし、別のファイルとして保存することが可能です。 処理の最後には、CloseBook メソッドを呼び出し、Excel ファイルをクローズする必要があります。このトピックでは、既存の Excel ファイルをオーバーレイオープンする方法を説明します。

このトピックは、次のセクションを含みます。

  • オーバーレイオープンしてファイルに出力する
  • オーバーレイオープンしてストリームに出力する
  • 参照
オーバーレイオープンしてファイルに出力する

次のコードは、C:\Data フォルダにある Excel ファイル (Template.xlsx) をオーバーレイオープンして C:\Data フォルダに Out.xlsx として出力するサンプルコードです。

C#
VB
コピー
// C:\Data フォルダにある Excel ファイル (Template.xlsx) をオーバーレイオープンして C:\Data フォルダに Out.xlsx として出力します。
creator1.OpenBook("C:\\Data\\Out.xlsx","C:\\Data\\Template.xlsx");
creator1.CloseBook(true);
' C:\Data フォルダにある Excel ファイル (Template.xlsx) をオーバーレイオープンして C:\Data フォルダに Out.xlsx として出力します。
Creator1.OpenBook("C:\Data\Out.xlsx","C:\Data\Template.xlsx")
Creator1.CloseBook(True)
オーバーレイオープンしてストリームに出力する

次のコードは、C:\Data フォルダにある Excel ファイル (Template.xlsx) をオープンしてストリームに出力するサンプルコードです。

C#
VB
コピー
System.IO.MemoryStream strmExcel = new System.IO.MemoryStream();
// C:\Data フォルダにある Excel ファイル (Template.xlsx) をオーバーレイオープンしてストリームに出力します。
creator1.OpenBook(strmExcel, "C:\\Data\\Template.xlsx");
creator1.CloseBook(true);
strmExcel.Close();
Dim strmExcel As System.IO.Stream = New System.IO.MemoryStream
' C:\Data フォルダにある Excel ファイル (Template.xlsx) をオーバーレイオープンしてストリームに出力します。
Creator1.OpenBook(strmExcel, "C:\Data\Template.xlsx")
Creator1.CloseBook(True)
strmExcel.Close()
参照
オブジェクト機能一覧 (Creator クラス)
基本操作


Excel ファイルをオーバーレイオープンする (埋め込み)

ExcelCreator 12.0 for .NET では、あらかじめオーバーレイ元ファイルをプログラムに埋め込みリソースとして登録しておくことができます。 このトピックでは、Excel ファイルをプロジェクトで埋め込みリソースとして登録し、 OpenBookEmbed メソッドを使用してオープンする方法を説明します。 処理の最後には CloseBook メソッドを呼び出し、Excel ファイルをクローズする必要があります。

このトピックは、次のセクションを含みます。

  • Excel ファイルを埋め込みリソースとしてプロジェクトに登録する
  • 埋め込みリソースをオーバーレイオープンしてファイルに出力する
  • 埋め込みリソースをオーバーレイオープンしてストリームに出力する
  • 参照
Excel ファイルを埋め込みリソースとしてプロジェクトに登録する

  1. プロジェクトを開いて[プロジェクト名] を右クリックし、[追加] - [既存項目の追加] を選択します。

  2. [既存項目の追加] ダイアログから Excel ファイルを選択し、[追加] ボタンをクリックします。

  3. ソリューション エクスプローラから、追加した Excel ファイルがプロジェクトに登録されていることを確認します。

  4. 引き続き、ソリューション エクスプローラ上で追加した Excel ファイルを選択し、[プロパティ] ウィンドウの [ビルドアクション] を 「埋め込みリソース」 に変更します。

  5. 以上でプロジェクトへの登録は完了です。

埋め込みリソースをオーバーレイオープンしてファイルに出力する

次のコードは、埋め込みリソースとしてプロジェクトに埋め込んだ Excel ファイルをオーバレイオープンして C:\Data フォルダに Out.xlsx として出力するサンプルコードです。

C#
VB
コピー
System.Reflection.Assembly myAssembly = System.Reflection.Assembly.GetExecutingAssembly();
System.IO.Stream tempStreamExcel = myAssembly.GetManifestResourceStream("WindowsFormsApp1.Template.xlsx");
// 埋め込んだリソースをオーバーレイオープンします。
creator1.OpenBookEmbed("C:\\Data\\Out.xlsx", tempStreamExcel);
creator1.Cell("A1").Str = "Excel ファイル出力";
creator1.CloseBook(true);
// リソースを閉じます。
tempStreamExcel.Close();
Dim myAssembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
Dim tempStreamExcel As System.IO.Stream = myAssembly.GetManifestResourceStream("WinFormsApp1.Template.xlsx")
' 埋め込んだリソースをオーバーレイオープンします。
Creator1.OpenBookEmbed("C:\Data\Out.xlsx", tempStreamExcel)
Creator1.Cell("A1").Str = "Excel ファイル出力"
Creator1.CloseBook(True)
' リソースを閉じます。
tempStreamExcel.Close()
埋め込みリソースをオーバーレイオープンしてストリームに出力する

次のコードは、埋め込みリソースとしてプロジェクトに埋め込んだ Excel ファイルをオーバレイオープンしてストリームに出力するサンプルコードです。

C#
VB
コピー
System.Reflection.Assembly myAssembly = System.Reflection.Assembly.GetExecutingAssembly();
System.IO.MemoryStream outStreamExcel = new System.IO.MemoryStream();
System.IO.Stream tempStreamExcel = myAssembly.GetManifestResourceStream("WindowsFormsApp1.Template.xlsx");
// 埋め込んだリソースをオーバーレイオープンします。
creator1.OpenBookEmbed(outStreamExcel, tempStreamExcel);
creator1.Cell("A1").Str = "ストリーム出力";
creator1.CloseBook(true);
// リソースを閉じます。
tempStreamExcel.Close();
outStreamExcel.Close();
Dim myAssembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
Dim tempStreamExcel As System.IO.Stream = myAssembly.GetManifestResourceStream("WinFormsApp1.Template.xlsx")
Dim outStreamExcel As System.IO.Stream = New System.IO.MemoryStream
' 埋め込んだリソースをオーバーレイオープンし、ストリームに出力します。
Creator1.OpenBookEmbed(outStreamExcel, tempStreamExcel)
Creator1.Cell("A1").Str = "ストリーム出力"
Creator1.CloseBook(True)
' リソースを閉じます。
tempStreamExcel.Close()
outStreamExcel.Close()
参照
オブジェクト機能一覧 (Creator クラス)
基本操作


Excel ファイルを読み取り専用でオープンする

ExcelCreator 12.0 for .NET では、ReadBook メソッドを使用して既存の Excel ファイルを読み取り専用でオープンすることが可能です。処理の最後には、CloseBook メソッドを呼び出し、Excel ファイルをクローズする必要があります。このトピックでは、既存の Excel ファイルを読み取り専用でオープンする方法を説明します。

Excel ファイルを読み取り専用でオープンする

次のコードは C:\Data フォルダにある Excel ファイル (Template.xlsx) を読み取り専用でオープンし、A1 セルの値を取得するサンプルコードです。

C#
VB
コピー
object objectData;
// C:\Data フォルダにある Excel ファイル (Template.xlsx) を読み取り専用でオープンします。
creator1.ReadBook("C:\\Data\\Template.xlsx");
// A1 セルの値を取得します。
objectData = creator1.Cell("A1").Value;
creator1.CloseBook(true);

Dim objectData As Object
' C:\Data フォルダにある Excel ファイル (Template.xlsx) を読み取り専用でオープンします。
Creator1.ReadBook("C:\Data\Template.xlsx")
' A1 セルの値を取得します。
objectData = Creator1.Cell("A1").Value
Creator1.CloseBook(True)
参照
オブジェクト機能一覧 (Creator クラス)
基本操作


PDF ファイルを出力する

ExcelCreator 12.0 for .NET では、CloseBook メソッドの引数にファイル名を指定することで PDF ファイルを出力することが可能です。このトピックでは、PDF ファイルを出力する方法を説明します。

このトピックは、次のセクションを含みます。

  • ファイルパスを指定して出力する
  • ストリームを指定して出力する
  • PDF ファイルのみ出力する
  • 参照
Note メモ:

出力時のフォントに関する注意点は 「PDF ファイル出力時のフォントについて」 をご確認ください。
ファイルパスを指定して出力する

次のコードは、オーバーレイオープンで作成した Out.xlsx を基に、ファイルパスを指定して PDF ファイルを出力するサンプルコードです。

C#
VB
コピー
// オーバーレイオープンで作成した Out.xlsx を基に、ファイルパスを指定して PDF ファイルを出力します。
creator1.OpenBook("C:\\Data\\Out.xlsx", "C:\\Data\\Template.xlsx");
creator1.CloseBook(true, "C:\\Data\\OutFile.pdf", false);
' オーバーレイオープンで作成した Out.xlsx を基に、ファイルパスを指定して PDF ファイルを出力します。
Creator1.OpenBook("C:\Data\Out.xlsx", "C:\Data\Template.xlsx")
Creator1.CloseBook(True, "C:\Data\OutFile.pdf", False)
ストリームを指定して出力する

次のコードは、オーバーレイオープンで作成した Out.xlsx を基に、ストリームを指定して PDF ファイルを出力するサンプルコードです。

C#
VB
コピー
System.IO.FileStream pdfFileStream = new System.IO.FileStream("C:\\Data\\OutStream.pdf", System.IO.FileMode.Create);
// オーバーレイオープンで作成した Out.xlsx を基に、ストリームを指定して PDF ファイルを出力します。
creator1.OpenBook("C:\\Data\\Out.xlsx", "C:\\Data\\Template.xlsx");
creator1.CloseBook(true, pdfFileStream, false);
pdfFileStream.Close();
Dim pdfFileStream As New System.IO.FileStream("C:\Data\OutStream.pdf", System.IO.FileMode.Create)
' オーバーレイオープンで作成した Out.xlsx を基に、ストリームを指定して PDF ファイルを出力します。
Creator1.OpenBook("C:\Data\Out.xlsx", "C:\Data\Template.xlsx")
Creator1.CloseBook(True, pdfFileStream, False)
pdfFileStream.Close()
PDF ファイルのみ出力する

PDF ファイルのみを出力する場合、CloseBook メソッドの引数 isDeleteFile に True を指定します。

次のコードは、オーバーレイオープンで作成した Out.xlsx を基にして PDF ファイルを出力します。基となる Excel ファイル(Out.xlsx)は削除して、PDF ファイルのみを出力します。

C#
VB
コピー
// オーバーレイオープンで作成した Out.xlsx を基にして PDF ファイルのみを出力します。
creator1.OpenBook("C:\\Data\\Out.xlsx", "C:\\Data\\Template.xlsx");
creator1.CloseBook(true, "C:\\Data\\OutFile.pdf", true);
' オーバーレイオープンで作成した Out.xlsx を基にして PDF ファイルのみを出力します。
Creator1.OpenBook("C:\Data\Out.xlsx", "C:\Data\Template.xlsx")
Creator1.CloseBook(True, "C:\Data\OutFile.pdf", True)
参照
PDF 出力オプションを設定する
オブジェクト機能一覧 (PdfOption クラス)
基本操作


PDF ファイル出力時のフォントについて

PDF 出力を行う環境では、あらかじめ Excel ファイル内で指定されるフォント(ファイル)を配布する必要があります。また、「ＭＳ Ｐゴシック」など他環境への配布が困難な Windows OS や Office 製品のバンドルフォントについては、「プリセットフォント機能」により制限付きでの文字出力に対応します。

このトピックは、次のセクションを含みます。

  • フォントディレクトリについて
  • フォントファイル、外字ファイルの配布時の注意点
  • プリセットフォント機能について
  • 参照
フォントディレクトリについて

Windows OS、非 Windows OS 既定のフォントディレクトリは下記の通りです。ただし、フォントディレクトリは OS のインストール方法やディストリビューション、バージョンで異なる場合があります。詳細は各 OS の技術資料をご確認ください。

各 OS のフォントディレクトリ

Windows OS | "C:\Windows\Fonts\"
非 Windows OS | "~/.fonts/" または "/usr/share/fonts/"
フォントファイル、外字ファイルの配布時の注意点

実行環境にフォントファイルを配置する場合、次の点にご注意ください。

  • 外字(EUDC.TTE)ファイルはフォントディレクトリに配置するか、EUDCFiles プロパティでの指定が必要です。EUDCFiles プロパティの使用方法は 「外字を切り替える」 をご確認ください。
  • ttf 、ttc 形式のフォントファイルに対応します。
  • フォントの配布時は、著作者に対し配布や利用条件を確認いただく必要があります。また、弊社では配布に関する内容にお答えすることはできません。
プリセットフォント機能について

プリセットフォント機能の対応フォント

プリセットフォントは、Windows 10 Version 1903 ならびに Office 2019 時点で収録されたバンドルフォントを対象としています。

プリセットフォント機能の動作

プリセットフォントの参照時は、次の仕様で出力されます。

  • 文字集合規格「Adobe-Japan1-2」に収録される文字の出力に対応します。
  • 上記の文字集合に該当しない文字は '?' で出力されます。
  • 文字の埋め込みは行われません。
  • プリセットフォント参照時の帳票出力では文字サイズを独自の仕様で算出しているため、Windows OS の帳票出力と比較し、文字間隔や位置などの描画内容が一致しない場合があります。

該当フォントが無い場合の動作

プリセットフォントを含め該当フォントがない場合は、次の仕様で出力されます。

  • 製品内部のフォントリンク情報を参照し、他のフォントでの出力を試みます。
  • 該当フォントが存在しない場合、文字種により次の文字で出力されます。
    全角文字・・・「Microsoft Sans Serif」で文字 '?' が出力されます。
    半角文字・・・「Microsoft Sans Serif」で指定文字が出力されます。
  • 文字の埋め込みは行われません。
参照
PDF ファイルを出力する
PDF 出力オプションを設定する
基本操作


HTML ファイルを出力する

ExcelCreator 12.0 for .NET では、CloseBook メソッドの引数にファイル名を指定することで HTML ファイルを出力することが可能です。このトピックでは、HTML ファイルを出力する方法を説明します。

このトピックは、次のセクションを含みます。

  • 事前準備
  • ファイルパスを指定して出力する
  • ストリームを指定して出力する
  • HTML ファイルのみ出力する
  • 参照
事前準備

HTML ファイルを出力する場合、製品インストール先の [Bin] - [v12.X.X] フォルダ内にある [Scripts] フォルダをコピーし、HTML ファイルの出力先と同一フォルダに配置してください。

Note メモ:

v12.X.X の X 部分はバージョンごとに異なります。
ファイルパスを指定して出力する

次のコードは、オーバーレイオープンで作成した Out.xlsx を基に、ファイルパスを指定して HTML ファイルを出力するサンプルコードです。

C#
VB
コピー
// オーバーレイオープンで作成した Out.xlsx を基に、ファイルパスを指定して HTML ファイルを出力します。
creator1.OpenBook("C:\\Data\\Out.xlsx", "C:\\Data\\Template.xlsx");
creator1.CloseBook(true, null, "C:\\Data\\OutFile.html", false);
' オーバーレイオープンで作成した Out.xlsx を基に、ファイルパスを指定して HTML ファイルを出力します。
Creator1.OpenBook("C:\Data\Out.xlsx", "C:\Data\Template.xlsx")
Creator1.CloseBook(True, Nothing, "C:\Data\OutFile.html", False)
ストリームを指定して出力する

次のコードは、オーバーレイオープンで作成した Out.xlsx を基に、ストリームを指定して HTML ファイルを出力するサンプルコードです。

C#
VB
コピー
System.IO.FileStream htmlFileStream = new System.IO.FileStream("C:\\Data\\OutStream.html", System.IO.FileMode.Create);
// オーバーレイオープンで作成した Out.xlsx を基に、ストリームを指定して HTML ファイルを出力します。
creator1.OpenBook("C:\\Data\\Out.xlsx", "C:\\Data\\Template.xlsx");
creator1.CloseBook(true, null, htmlFileStream, false);
htmlFileStream.Close();
Dim htmlFileStream As New System.IO.FileStream("C:\Data\OutStream.html", System.IO.FileMode.Create)
' オーバーレイオープンで作成した Out.xlsx を基に、ストリームを指定して HTML ファイルを出力します。
Creator1.OpenBook("C:\Data\Out.xlsx", "C:\Data\Template.xlsx")
Creator1.CloseBook(True, Nothing, htmlFileStream, False)
htmlFileStream.Close()
HTML ファイルのみ出力する

HTML ファイルのみを出力する場合、CloseBook メソッドの引数 isDeleteFile に True を指定します。

次のコードは、オーバーレイオープンで作成した Out.xlsx を基にして HTML ファイルを出力します。基となる Excel ファイル(Out.xlsx)は削除して、HTML ファイルのみを出力します。

C#
VB
コピー
// オーバーレイオープンで作成した Out.xlsx を基にして HTML ファイルのみを出力します。
creator1.OpenBook("C:\\Data\\Out.xlsx", "C:\\Data\\Template.xlsx");
creator1.CloseBook(true, null, "C:\\Data\\OutFile.html", true);
' オーバーレイオープンで作成した Out.xlsx を基にして HTML ファイルのみを出力します。
Creator1.OpenBook("C:\Data\Out.xlsx", "C:\Data\Template.xlsx")
Creator1.CloseBook(True, Nothing, "C:\Data\OutFile.html", True)
参照
HTML 出力オプションを設定する
オブジェクト機能一覧 (HtmlOption クラス)
基本操作


ブック属性を設定する

ExcelCreator 12.0 for .NET では、ブックの属性を設定することが可能です。このトピックでは、ブック属性を設定する方法を説明します。

このトピックは、次のセクションを含みます。

  • ブックのデフォルトフォントサイズを設定する
  • ブックのデフォルトフォントを設定する
  • 参照
ブックのデフォルトフォントサイズを設定する

次のコードは、DefaultFontPoint プロパティでブックのデフォルトフォントサイズを 15 ポイントに設定するサンプルコードです。

C#
VB
コピー
// ブックのデフォルトフォントサイズを 15 ポイントに設定します。
creator1.DefaultFontPoint = 15;
' ブックのデフォルトフォントサイズを 15 ポイントに設定します。
Creator1.DefaultFontPoint = 15
ブックのデフォルトフォントを設定する

次のコードは、DefaultFontName プロパティでブックのデフォルトフォントを [ＭＳ 明朝] に設定するサンプルコードです。

C#
VB
コピー
// ブックのデフォルトフォントを [ＭＳ 明朝] に設定します。
creator1.DefaultFontName = "ＭＳ 明朝";
' ブックのデフォルトフォントを [ＭＳ 明朝] に設定します。
Creator1.DefaultFontName = "ＭＳ 明朝"
参照
オブジェクト機能一覧 (Creator クラス)
基本操作


シートを操作する

ExcelCreator 12.0 for .NET では、Excel シートの操作が可能です。ここでは、シートの操作方法や属性の設定方法を説明します。

シートを指定する

操作シートを指定する方法を説明します。

シートを追加、コピー、削除する

シートを追加、コピー、削除する方法を説明します。

シート属性を設定する

シート属性を設定する方法を説明します。


シートを指定する

ExcelCreator 12.0 for .NET では、Excel ファイルの任意のシートを指定することが可能です。このトピックでは、シートを指定する方法を説明します。

このトピックは、次のセクションを含みます。

  • 操作するシート番号を設定する
  • アクティブシートを設定する
  • 参照
操作するシート番号を設定する

次のコードは、SheetNo プロパティで 2 シート目を操作対象シートに設定し、A1 セルに文字列 "アドバンスソフトウェア" を設定するサンプルコードです。

C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx","C:\\Data\\Template.xlsx");
// 2 シート目を操作対象シートに設定します。
creator1.SheetNo = 1;
// 2 シート目の A1 セルに文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("A1").Value = "アドバンスソフトウェア";
creator1.CloseBook(true);
Creator1.OpenBook("C:\Data\Out.xlsx","C:\Data\Template.xlsx")
' 2 シート目を操作対象シートに設定します。
Creator1.SheetNo = 1
' 2 シート目の A1 セルに文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("A1").Value = "アドバンスソフトウェア"
Creator1.CloseBook(True)
アクティブシートを設定する

次のコードは、ActiveSheet プロパティで 1 シート目をアクティブシートに設定するサンプルコードです。

C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx","C:\\Data\\Template.xlsx");
// 1 シート目をアクティブシートに設定します。
creator1.ActiveSheet = 0;
creator1.CloseBook(true);
Creator1.OpenBook("C:\Data\Out.xlsx","C:\Data\Template.xlsx")
' 1 シート目をアクティブシートに設定します。
Creator1.ActiveSheet = 0
Creator1.CloseBook(True)
Note メモ:

シート番号は 0 が開始番号になります。
参照
オブジェクト機能一覧 (Creator クラス)
基本操作


シートを追加、コピー、削除する

ExcelCreator 12.0 for .NET では、Excel ファイルの任意のシートを追加、コピー、削除することが可能です。このトピックでは、シートを追加、コピー、削除する方法を説明します。

このトピックは、次のセクションを含みます。

  • シートを追加する
  • シートをコピーする
  • シートを削除する
  • 参照
シートを追加する

次のコードは、AddSheet メソッドで 2 シート目に 3 つのシートを追加するサンプルコードです。

C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx", "C:\\Data\\Template.xlsx");
// AddSheet メソッドで 2 シート目に 3 つのシートを追加します。
creator1.AddSheet(3, 1);
creator1.CloseBook(true);
Creator1.OpenBook("C:\Data\Out.xlsx", "C:\Data\Template.xlsx")
' AddSheet メソッドで 2 シート目に 3 つのシートを追加します。
Creator1.AddSheet(3, 1)
Creator1.CloseBook(True)
シートをコピーする

次のコードは、CopySheet メソッドで 1 シート目をコピーし、2 シート目にコピーしたシート (NEW) を追加するサンプルコードです。

Note メモ:

シート名が未入力の場合は、自動でシート名が設定されます。
C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx", "C:\\Data\\Template.xlsx");
// CopySheet メソッドで 1 シート目をコピーし、2 シート目にコピーしたシート (NEW) を追加します。
creator1.CopySheet(0, 1, "NEW");
creator1.CloseBook(true);
Creator1.OpenBook("C:\Data\Out.xlsx", "C:\Data\Template.xlsx")
' CopySheet メソッドで 1 シート目をコピーし、2 シート目にコピーしたシート (NEW) を追加します。
Creator1.CopySheet(0, 1, "NEW")
Creator1.CloseBook(True)
シートを削除する

次のコードは、DeleteSheet メソッドで 1 シート目から 2 シート分のシートを削除するサンプルコードです。

C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx", "C:\\Data\\Template.xlsx");
// DeleteSheet メソッドで 1 シート目から 2 シート分のシートを削除します。
creator1.DeleteSheet(0, 2);
creator1.CloseBook(true);
Creator1.OpenBook("C:\Data\Out.xlsx", "C:\Data\Template.xlsx")
' DeleteSheet メソッドで 1 シート目から 2 シート分のシートを削除します。
Creator1.DeleteSheet(0, 2)
Creator1.CloseBook(True)
参照
オブジェクト機能一覧 (Creator クラス)
基本操作


シート属性を設定する

ExcelCreator 12.0 for .NET では、シートの属性を設定することが可能です。このトピックでは、シート属性を設定する方法を説明します。

このトピックは、次のセクションを含みます。

  • 印刷範囲を設定する
  • 印刷タイトルを設定する
  • ヘッダー、フッターを設定する
  • 参照
印刷範囲を設定する

このセクションでは、印刷範囲を設定する方法を説明します。

次のコードは、PrintArea メソッドで印刷範囲 (A1:H40 セル) 設定するサンプルコードです。

C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx","C:\\Data\\Template.xlsx");
// PrintArea メソッドで印刷範囲 (A1:H40 セル) 設定します。
creator1.PrintArea(0, 0, 7, 39);
creator1.CloseBook(true);
Creator1.OpenBook("C:\Data\Out.xlsx","C:\Data\Template.xlsx")
' PrintArea メソッドで印刷範囲 (A1:H40 セル) 設定します。
Creator1.PrintArea(0, 0, 7, 39)
Creator1.CloseBook(True)
印刷タイトルを設定する

このセクションでは、印刷タイトルを設定する方法を説明します。

印刷タイトル (行) を設定する

次のコードは、PrintTitle メソッドで印刷タイトル (行) を 1-6 行目に設定するサンプルコードです。

C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx","C:\\Data\\Template.xlsx");
// PrintTitle メソッドで印刷タイトル (行) を 1-6 行目に設定します。
creator1.PrintTitle(0, 5, -1, -1);
creator1.CloseBook(true);
Creator1.OpenBook("C:\Data\Out.xlsx","C:\Data\Template.xlsx")
' PrintTitle メソッドで印刷タイトル (行) を 1-6 行目に設定します。
Creator1.PrintTitle(0, 5, -1, -1)
Creator1.CloseBook(True)

印刷タイトル (列) を設定する

次のコードは、PrintTitle メソッドで印刷タイトル (列) を B-C 列目に設定するサンプルコードです。

C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx","C:\\Data\\Template.xlsx");
// PrintTitle メソッドで印刷タイトル (列) を B-C 列目に設定します。
creator1.PrintTitle(-1, -1, 1, 2);
creator1.CloseBook(true);
Creator1.OpenBook("C:\Data\Out.xlsx","C:\Data\Template.xlsx")
' PrintTitle メソッドで印刷タイトル (列) を B-C 列目に設定します。
Creator1.PrintTitle(-1, -1, 1, 2)
Creator1.CloseBook(True)
Note メモ:

SheetNo プロパティで指定したシートが対象です。既に行タイトルや列タイトルが設定されている場合は上書きされます。
ヘッダー、フッターを設定する

このセクションでは、ヘッダー、フッターを設定する方法を説明します。

Header、Footer メソッドでヘッダー、フッターを設定する

次のコードは、ヘッダーの中央ヘッダーに文字列 (請求書)、フッターの右フッターにページ番号を設定するサンプルコードです。

C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx","C:\\Data\\Template.xlsx");
// ヘッダーの中央ヘッダーに文字列 (請求書) を設定します。
creator1.Header("", "請求書", "");
// フッターの右フッターにページ番号を設定します。
creator1.Footer("", "", "&P");
creator1.CloseBook(true);
Creator1.OpenBook("C:\Data\Out.xlsx","C:\Data\Template.xlsx")
' ヘッダーの中央ヘッダーに文字列 (請求書) を設定します。
Creator1.Header("", "請求書", "")
' フッターの右フッターにページ番号を設定します。
Creator1.Footer("", "", "&P")
Creator1.CloseBook(True)

Header2、Footer2 メソッドでヘッダー、フッターを設定する

次のコードは、先頭ページはヘッダーの中央ヘッダーに文字列 (請求書)、フッターの右フッターにページ番号/全体のページ数を設定し、 先頭ページ以外のページはヘッダーの中央ヘッダーに文字列 (明細)、フッターの右フッターにページ番号を設定するサンプルコードです。

C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx","C:\\Data\\Template.xlsx");
// HeaderFooterMode プロパティに FirstPage(先頭ページのみ別指定) を設定します。
creator1.HeaderFooterMode = AdvanceSoftware.ExcelCreator.HeaderFooterMode.FirstPage;
// 先頭ページのヘッダーの中央ヘッダーに文字列 (請求書) を設定します。
creator1.Header2("", "請求書", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.First);
// 先頭ページのフッターの右フッターにページ番号/全体のページ数を設定します。
creator1.Footer2("", "", "&P/&N", AdvanceSoftware.ExcelCreator.HeaderFooterType.First);
// 先頭ページ以外のページのヘッダーの中央ヘッダーに文字列 (明細)を設定します。
creator1.Header2("", "明細", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.Normal);
// 先頭ページ以外のページのフッターの右フッターにページ番号を設定します。
creator1.Footer2("", "", "&P", AdvanceSoftware.ExcelCreator.HeaderFooterType.Normal);
creator1.CloseBook(true);
Creator1.OpenBook("C:\Data\Out.xlsx","C:\Data\Template.xlsx")
' HeaderFooterMode プロパティに FirstPage(先頭ページのみ別指定) を設定します。
Creator1.HeaderFooterMode = AdvanceSoftware.ExcelCreator.HeaderFooterMode.FirstPage
' 先頭ページのヘッダーの中央ヘッダーに文字列 (請求書) を設定します。
Creator1.Header2("", "請求書", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.First)
' 先頭ページのフッターの右フッターにページ番号/全体のページ数を設定します。
Creator1.Footer2("", "", "&P/&N", AdvanceSoftware.ExcelCreator.HeaderFooterType.First)
' 先頭ページ以外のページのヘッダーの中央ヘッダーに文字列 (明細)を設定します。
Creator1.Header2("", "明細", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.Normal)
' 先頭ページ以外のページのフッターの右フッターにページ番号を設定します。
Creator1.Footer2("", "", "&P", AdvanceSoftware.ExcelCreator.HeaderFooterType.Normal)
Creator1.CloseBook(True)
Note メモ:

Header2、Footer2 メソッドは、Xlsx 形式を扱う場合のみ使用できます。

対応する書式コード一覧

書式コード | 内容
&L | 左詰
&C | 中央揃え
&R | 右詰
&E | 二重下線
&X | 上付き文字
&Y | 下付き文字
&B | ボールド
&I | イタリック
&U | 下線
&S | 取消線
&P | ページ番号
&P+99 | ページ番号に値を加えて表示
&P-99 | ページ番号に値を引いて表示
&D | 現在の日付
&T | 現在の時刻
&A | シート見出し
&& | & (アンパサンド) を表示
&"フォント名" | フォントを設定
&99 | フォントサイズを設定
&N | 全体のページ数
参照
オブジェクト機能一覧 (Creator クラス)
基本操作


セルを操作する

ExcelCreator 12.0 for .NET では、Excel ファイルのセルの操作が可能です。ここでは、セルの操作方法や、値、属性、オブジェクトの設定方法を説明します。

セルを指定する

セルを指定する方法を説明します。

値を設定、取得する

値を設定、取得する方法を説明します。

計算式を設定、取得する

計算式を設定、取得する方法を説明します。

セルをコピー、クリアする

セルをコピー、クリアする方法を説明します。

行、列をコピー、クリア、挿入、削除する

行、列をコピー、クリア、挿入、削除する方法を説明します。

セル属性を設定する

セル属性を設定する方法を説明します。

セルを範囲指定する

セルを範囲指定する方法を説明します。

日付の値を設定、取得する

日付の値を設定、取得する方法を説明します。

画像、オートシェイプを設定する

画像、オートシェイプなどのオブジェクトを設定する方法を説明します。

複数の列挙体メンバを設定する

引数に 2 つ以上の列挙体のメンバを設定する方法を説明します。


セルを指定する

ExcelCreator 12.0 for .NET では Cell / Pos メソッドを使用し、さまざまな方法でセルを指定して値を設定することが可能です。このトピックでは、セルの指定方法を説明します。

このトピックは、次のセクションを含みます。

  • A1 参照形式によるセルの指定
  • 座標によるセルの指定
  • 変数名によるセルの指定
  • セル名によるセルの指定
  • 参照
A1 参照形式によるセルの指定

このセクションでは、A1 参照形式でセルを指定する方法を説明します。

次のコードは、Cell メソッドを使用して A1 参照形式で A1 セルを指定し、文字列 "アドバンスソフトウェア" を設定するサンプルコードです。

C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx","C:\\Data\\Template.xlsx");
// A1 セルに文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("A1").Value = "アドバンスソフトウェア";
creator1.CloseBook(true);
Creator1.OpenBook("C:\Data\Out.xlsx","C:\Data\Template.xlsx")
' A1 セルに文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("A1").Value = "アドバンスソフトウェア"
Creator1.CloseBook(True)
座標によるセルの指定

このセクションでは、座標形式でセルを指定する方法を説明します。

Note メモ:

座標形式で指定する場合、Pos メソッドの第一引数が x 軸(列)、第二引数が y軸(行) になります。

次のコードは、Pos メソッドを使用して座標形式で A5 セルを指定し、文字列 "アドバンスソフトウェア" を設定するサンプルコードです。

C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx","C:\\Data\\Template.xlsx");
// A5 セルに文字列 "アドバンスソフトウェア" を設定します。
creator1.Pos(0, 4).Value = "アドバンスソフトウェア";
creator1.CloseBook(true);
Creator1.OpenBook("C:\Data\Out.xlsx","C:\Data\Template.xlsx")
' A5 セルに文字列 "アドバンスソフトウェア" を設定します。
Creator1.Pos(0, 4).Value = "アドバンスソフトウェア"
Creator1.CloseBook(True)
変数名によるセルの指定

ExcelCreator 12.0 for .NET では、Excel ファイルのセルに予め設定された連続する 2 つのアスタリスク(**)から始まる文字列を変数名として扱います。このセクションでは、変数名でセルを指定する方法を説明します。

Note メモ:

既定では、連続する 2 つのアスタリスク (**) から始まる文字列を変数名として扱いますが、「Keyword プロパティ」を使用することで、変数名のキーワード文字をアスタリスク (*) から別の文字に変更することが可能です。

次のコードは、Cell メソッドで A1 セルに設定した変数名 "**Name" を指定し、文字列 "アドバンスソフトウェア" を設定するサンプルコードです。

C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx","C:\\Data\\Template.xlsx");
// A1 セルに予め変数名 "**Name" を設定し、Cell メソッドで変数名を指定して、文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("**Name").Value = "アドバンスソフトウェア";
creator1.CloseBook(true);
Creator1.OpenBook("C:\Data\Out.xlsx","C:\Data\Template.xlsx")
' A1 セルに予め変数名 "**Name" を設定し、Cell メソッドで変数名を指定して、文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("**Name").Value = "アドバンスソフトウェア"
Creator1.CloseBook(True)
セル名によるセルの指定

ExcelCreator 12.0 for .NET では、Excel ファイルのセルに予め設定されたセル名を指定することができます。このセクションでは、セル名でセルを指定する方法を説明します。

次のコードは、Cell メソッドで A1 セルに設定したセル名 "CellName" を指定し、文字列 "アドバンスソフトウェア" を設定するサンプルコードです。

C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx","C:\\Data\\Template.xlsx");
// A1 セルに予めセル名 "CellName" を設定し、Cell メソッドでセル名を指定して、文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("CellName").Value = "アドバンスソフトウェア";
creator1.CloseBook(true);
Creator1.OpenBook("C:\Data\Out.xlsx","C:\Data\Template.xlsx")
' A1 セルに予めセル名 "CellName" を設定し、Cell メソッドでセル名を指定して、文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("CellName").Value = "アドバンスソフトウェア"
Creator1.CloseBook(True)
参照
オブジェクト機能一覧 (Creator クラス)
基本操作


値を設定、取得する

ExcelCreator 12.0 for .NET では、文字列や整数値、小数値などの数値を設定、取得することが可能です。このトピックでは、さまざまな値の設定、取得方法を説明します。

このトピックは、次のセクションを含みます。

  • 値を設定する
  • 値を取得する
  • 参照
値を設定する

次のコードは、それぞれのセルに文字列、数値、小数を設定するサンプルコードです。

C#
VB
コピー
// Str プロパティで A1 セルに文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("A1").Str = "アドバンスソフトウェア";
// Long プロパティで A2 セルに数値 100 を設定します。
creator1.Cell("A2").Long = 100;
// Double プロパティで A3 セルに小数 1.5 を設定します。
creator1.Cell("A3").Double = 1.5;
// Value プロパティで A4 セルに文字列 "Advance Software" を設定します。
creator1.Cell("A4").Value = "Advance Software";
// Value プロパティで A5 セルに数値 200 を設定します。
creator1.Cell("A5").Value = 200;
' Str プロパティで A1 セルに文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("A1").Str = "アドバンスソフトウェア"
' Long プロパティで A2 セルに数値 100 を設定します。
Creator1.Cell("A2").Long = 100
' Double プロパティで A3 セルに小数 1.5 を設定します。
Creator1.Cell("A3").Double = 1.5
' Value プロパティで A4 セルに文字列 "Advance Software" を設定します。
Creator1.Cell("A4").Value = "Advance Software"
' Value プロパティで A5 セルに数値 200 を設定します。
Creator1.Cell("A5").Value = 200
値を取得する

次のコードは、それぞれのセルに設定された数値、小数、文字列を取得するサンプルコードです。

C#
VB
コピー
int intData;
double doubleData;
object objectData;

// Long プロパティで A1 セルの数値を取得します。
intData = creator1.Cell("A1").Long;
// Double プロパティで A2 セルの小数を取得します。
doubleData = creator1.Cell("A2").Double;
// Value プロパティで A3 セルの文字列 (object 型) を取得します。
objectData = creator1.Cell("A3").Value;
Dim intData As Integer
Dim doubleData As Double
Dim objectData As Object

' Long プロパティで A1 セルの数値を取得します。
intData = Creator1.Cell("A1").Long
' Double プロパティで A2 セルの小数を取得します。
doubleData = Creator1.Cell("A2").Double
' Value プロパティで A3 セルの文字列 (object 型) を取得します。
objectData = Creator1.Cell("A3").Value
参照
オブジェクト機能一覧 (Creator クラス)
基本操作


計算式を設定、取得する

ExcelCreator 12.0 for .NET では、プログラムから計算式を設定することや、Excel ファイルに設定された計算式文字列を取得することが可能です。このトピックでは計算式の設定方法、計算式文字列の取得方法を説明します。

このトピックは、次のセクションを含みます。

  • 計算式を設定する
  • 計算式を取得する
  • 参照
計算式を設定する

このセクションでは、計算式と計算結果を設定する方法を説明します。

計算結果を Excel 側で設定する

次のコードは、Func メソッドに計算式、FullCalcOnLoad プロパティに True を設定し、出力した Excel ファイルのオープン時に Excel 側の機能で計算結果を設定するサンプルコードです。

C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx","C:\\Data\\Template.xlsx");
// A1 セルに数値 100、A2 セルに数値 200 を設定し、A3 セルに 計算式 "=A1+A2" を設定します。
creator1.Cell("A1").Value = 100;
creator1.Cell("A2").Value = 200;
creator1.Cell("A3").Func("=A1+A2", null);
// B1 セルに数値 100、B2 セルに数値 200 を設定し、B3 セルに 計算式 "=SUM(B1:B2)" を設定します。
creator1.Cell("B1").Value = 100;
creator1.Cell("B2").Value = 200;
creator1.Cell("B3").Func("=SUM(B1:B2)", null);
// ブックオープン時に Excel 側で再計算が行われるよう設定します。
creator1.FullCalcOnLoad = true;
creator1.CloseBook(true);
Creator1.OpenBook("C:\Data\Out.xlsx","C:\Data\Template.xlsx")
' A1 セルに数値 100、A2 セルに数値 200 を設定し、A3 セルに 計算式 "=A1+A2" を設定します。
Creator1.Cell("A1").Value = 100
Creator1.Cell("A2").Value = 200
Creator1.Cell("A3").Func("=A1+A2", Nothing)
' B1 セルに数値 100、B2 セルに数値 200 を設定し、B3 セルに 計算式 "=SUM(B1:B2)" を設定します。
Creator1.Cell("B1").Value = 100
Creator1.Cell("B2").Value = 200
Creator1.Cell("B3").Func("=SUM(B1:B2)", Nothing)
' ブックオープン時に Excel 側で再計算が行われるよう設定します。
Creator1.FullCalcOnLoad = True
Creator1.CloseBook(True)
Note 注意:

PDF ファイルや HTML ファイルの再計算は ReCalcValue プロパティで対応しています。詳細は以下の項目をご確認ください。

  • [PDF 出力オプションを設定する] - [計算結果を反映する]
  • [HTML 出力オプションを設定する] - [計算結果を反映する]

計算結果を手動で設定する

次のコードは、Func メソッドに計算式と計算結果を設定し、出力後のファイルに反映させるサンプルコードです。

C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx","C:\\Data\\Template.xlsx");
// A1 セルに数値 100、A2 セルに数値 200 を設定し、A3 セルに 計算式 "=A1+A2" と、計算結果 300 を設定します。
creator1.Cell("A1").Value = 100;
creator1.Cell("A2").Value = 200;
creator1.Cell("A3").Func("=A1+A2", 300);
// B1 セルに数値 100、B2 セルに数値 200 を設定し、B3 セルに 計算式 "=SUM(B1:B2)" と、計算結果 300 を設定します
creator1.Cell("B1").Value = 100;
creator1.Cell("B2").Value = 200;
creator1.Cell("B3").Func("=SUM(B1:B2)", 300);
creator1.CloseBook(true);
Creator1.OpenBook("C:\Data\Out.xlsx","C:\Data\Template.xlsx")
' A1 セルに数値 100、A2 セルに数値 200 を設定し、A3 セルに 計算式 "=A1+A2" と、計算結果 300 を設定します。
Creator1.Cell("A1").Value = 100
Creator1.Cell("A2").Value = 200
Creator1.Cell("A3").Func("=A1+A2", 300)
' B1 セルに数値 100、B2 セルに数値 200 を設定し、B3 セルに 計算式 "=SUM(B1:B2)" と、計算結果 300 を設定します
Creator1.Cell("B1").Value = 100
Creator1.Cell("B2").Value = 200
Creator1.Cell("B3").Func("=SUM(B1:B2)", 300)
Creator1.CloseBook(True)
Note 注意:

FullCalcOnLoad プロパティを使用した場合は、Excel 側の計算結果が反映されます。
計算式を取得する

次のコードは、セルに設定された計算式文字列を取得するサンプルコードです。

C#
VB
コピー
string formulaData;
// A1 セルに設定された計算式文字列を取得します。
formulaData = creator1.Cell("A1").FormulaString;
Dim formulaData As String
' A1 セルに設定された計算式文字列を取得します。
formulaData = Creator1.Cell("A1").FormulaString
参照
オブジェクト機能一覧 (Creator クラス)
基本操作


セルをコピー、クリアする

ExcelCreator 12.0 for .NET では、Cell / Pos メソッドでセルを指定し、Copy メソッドや Paste メソッドでセルのコピーや貼り付け、Clear メソッドでセルをクリアすることが可能です。このトピックでは、セルのコピーや貼り付け、クリアの方法を説明します。

このトピックは、次のセクションを含みます。

  • セルをコピーする
  • セルをクリアする
  • 参照
セルをコピーする

このセクションでは Copy メソッド、Paste メソッドでセルのコピーや貼付けをする方法を説明します。

セルをコピーする（単一セルコピー）

次のコードは、Copy メソッドでセルのコピー、貼り付けをするサンプルコードです。

C#
VB
コピー
// A1 セルをコピーし、B1 セルに貼り付けます。
creator1.Cell("A1").Copy("B1");
' A1 セルをコピーし、B1 セルに貼り付けます。
Creator1.Cell("A1").Copy("B1")

セルをコピーする（範囲セルコピー）

次のコードは、Copy メソッドで範囲セルのコピー、貼り付けをするサンプルコードです。

C#
VB
コピー
// A1:B1 セルをコピーし、C1 セルに貼り付けます。
creator1.Cell("A1:B1").Copy("C1");
' A1:B1 セルをコピーし、C1 セルに貼り付けます。
Creator1.Cell("A1:B1").Copy("C1")

セルをコピーする（メモリ上にコピー）

次のコードは、Copy メソッドでセルをコピーし、Paste メソッドで貼り付けをするサンプルコードです。

C#
VB
コピー
// Copy メソッドで A1 セルをコピーします。
creator1.Cell("A1").Copy();
// コピーしたセルを Paste メソッドで B1 セルに貼り付けます。
creator1.Cell("B1").Paste();
' Copy メソッドで A1 セルをコピーします。
Creator1.Cell("A1").Copy()
' コピーしたセルを Paste メソッドで B1 セルに貼り付けます。
Creator1.Cell("B1").Paste()
セルをクリアする

このセクションでは セルに設定された値、属性をクリアする方法を説明します。

セルをクリアする（単一セルクリア）

次のコードは、Clear メソッドで A1 セルの値、A2 セルの属性をクリアするサンプルコードです。

C#
VB
コピー
// A1 セルの値をクリアします。
creator1.Cell("A1").Clear(AdvanceSoftware.ExcelCreator.CellClearMode.Value);
// A2 セルの属性をクリアします。
creator1.Cell("A2").Clear(AdvanceSoftware.ExcelCreator.CellClearMode.Attr);
' A1 セルの値をクリアします。
Creator1.Cell("A1").Clear(AdvanceSoftware.ExcelCreator.CellClearMode.Value)
' A2 セルの属性をクリアします。
Creator1.Cell("A2").Clear(AdvanceSoftware.ExcelCreator.CellClearMode.Attr)

セルをクリアする（範囲セルクリア）

次のコードは、Clear メソッドで A1:B1 セルの値、属性をクリアするサンプルコードです。

C#
VB
コピー
// A1:B1 セルの値と属性をクリアします。
creator1.Cell("A1:B1").Clear(AdvanceSoftware.ExcelCreator.CellClearMode.All);
' A1:B1 セルの値と属性をクリアします。
Creator1.Cell("A1:B1").Clear(AdvanceSoftware.ExcelCreator.CellClearMode.All)
参照
オブジェクト機能一覧 (Cell クラス)
基本操作


行、列をコピー、クリア、挿入、削除する

ExcelCreator 12.0 for .NET では、行、列単位でコピー、クリア、挿入、削除をすることが可能です。このトピックでは、行、列単位でコピー、クリア、挿入、削除をする方法を説明します。

このトピックは、次のセクションを含みます。

  • 行、列をコピーする
  • 行、列をクリアする
  • 行、列を挿入する
  • 行、列を削除する
  • 参照
行、列をコピーする

このセクションでは、行、列単位でコピー、貼り付けをする方法を説明します。

行をコピーする

次のコードは、RowCopy メソッドで 1 行目をコピーし、2 行目に貼り付けるサンプルコードです。

C#
VB
コピー
// 1 行目をコピーし、2 行目に貼り付けます。
creator1.RowCopy(0, 1);
' 1 行目をコピーし、2 行目に貼り付けます。
Creator1.RowCopy(0, 1)
Note メモ:

RowCopy メソッドでは複数行をコピーすることはできません。「Copy メソッド」でセル範囲を指定することで複数セルをコピーすることが可能です。

列をコピーする

次のコードは、ColumnCopy メソッドで A 列をコピーし、B 列に貼り付けるサンプルコードです。

C#
VB
コピー
// A 列をコピーし、B 列に貼り付けます。
creator1.ColumnCopy(0, 1);
' A 列をコピーし、B 列に貼り付けます。
Creator1.ColumnCopy(0, 1)
Note メモ:

ColumnCopy メソッドでは複数列をコピーすることはできません。「Copy メソッド」でセル範囲を指定することで複数セルをコピーすることが可能です。
行、列をクリアする

このセクションでは、行、列単位で値、属性をクリアする方法を説明します。

行をクリアする

次のコードは、RowClear メソッドで 1 行目から 5 行分クリアするサンプルコードです。

C#
VB
コピー
// 1 行目から 5 行分クリアします。
creator1.RowClear(0, 5);
' 1 行目から 5 行分クリアします。
Creator1.RowClear(0, 5)

列をクリアする

次のコードは、ColumnClear メソッドで A 列 から 5 列分クリアするサンプルコードです。

C#
VB
コピー
// A 列 から 5 列分クリアします。
creator1.ColumnClear(0, 5);
' A 列 から 5 列分クリアします。
Creator1.ColumnClear(0, 5)
行、列を挿入する

このセクションでは、行、列を挿入する方法を説明します。

行を挿入する

次のコードは、RowInsert メソッドで 1 行目から 2 行分の行を挿入するサンプルコードです。

C#
VB
コピー
// 1 行目から 2 行分の行を挿入します。
creator1.RowInsert(0, 2);
' 1 行目から 2 行分の行を挿入します。
Creator1.RowInsert(0, 2)

列を挿入する

次のコードは、ColumnInsert メソッドで A 列 から 2 列分の列を挿入するサンプルコードです。

C#
VB
コピー
// A 列 から 2 列分の列を挿入します。
creator1.ColumnInsert(0, 2);
' A 列 から 2 列分の列を挿入します。
Creator1.ColumnInsert(0, 2)
行、列を削除する

このセクションでは、行、列を削除する方法を説明します。

行を削除する

次のコードは、RowDelete メソッドで 2 行目から 3 行分の行を削除するサンプルコードです。

C#
VB
コピー
// 2 行目から 3 行分の行を削除します。
creator1.RowDelete(1, 3);
' 2 行目から 3 行分の行を削除します。
Creator1.RowDelete(1, 3)

列を削除する

次のコードは、ColumnDelete メソッドで B 列 から 3 列分の列を削除するサンプルコードです。

C#
VB
コピー
// B 列 から 3 列分の列を削除します。
creator1.ColumnDelete(1, 3);
' B 列 から 3 列分の列を削除します。
Creator1.ColumnDelete(1, 3)
参照
オブジェクト機能一覧 (Creator クラス)
基本操作


セル属性を設定する

ExcelCreator 12.0 for .NET では、セルの属性を設定することが可能です。このトピックでは、属性を設定する方法を説明します。

このトピックは、次のセクションを含みます。

  • フォント属性を設定する
  • 書式を設定する
  • セルを結合する
  • 文字列の縦位置、横位置を設定する
  • セルの背景色、パターンを設定する
  • セルの罫線を設定する
  • 参照
フォント属性を設定する

このセクションでは、フォントの属性を設定する方法を説明します。

次のコードは、A1 セルのフォント属性に [MS 明朝、太字、14pt、赤字] を設定するサンプルコードです。

C#
VB
コピー
// フォント名 [ＭＳ 明朝] を設定します。
creator1.Cell("A1").Attr.FontName = "ＭＳ 明朝";
// フォントカラー [赤] を設定します。
creator1.Cell("A1").Attr.FontColor = System.Drawing.Color.Red;
// フォントスタイル [太字] を設定します。
creator1.Cell("A1").Attr.FontStyle = AdvanceSoftware.ExcelCreator.FontStyle.Bold;
// フォントサイズ [14] を設定します。
creator1.Cell("A1").Attr.FontPoint = 14;
' フォント名 [ＭＳ 明朝] を設定します。
Creator1.Cell("A1").Attr.FontName = "ＭＳ 明朝"
' フォントカラー [赤] を設定します。
Creator1.Cell("A1").Attr.FontColor = System.Drawing.Color.Red
' フォントスタイル [太字] を設定します。
Creator1.Cell("A1").Attr.FontStyle = AdvanceSoftware.ExcelCreator.FontStyle.Bold
' フォントサイズ [14] を設定します。
Creator1.Cell("A1").Attr.FontPoint = 14
書式を設定する

このセクションでは、書式を設定する方法を説明します。

次のコードは、Format プロパティで A1 セルに数値の書式と数値 1,000,000 を設定するサンプルコードです。

C#
VB
コピー
// A1 セルに数値の書式を設定します。
creator1.Cell("A1").Attr.Format = "#,##0_ ";
// A1 セルに数値 1,000,000 を設定します。
creator1.Cell("A1").Long = 1000000;
' A1 セルに数値の書式を設定します。
Creator1.Cell("A1").Attr.Format = "#,##0_ "
' A1 セルに数値 1,000,000 を設定します。
Creator1.Cell("A1").Long = 1000000
セルを結合する

このセクションでは、セルを結合する方法を説明します。

次のコードは、MergeCells プロパティで A1:C3 セルを結合するサンプルコードです。

C#
VB
コピー
// A1:C3 セルを結合します。
creator1.Cell("A1:C3").Attr.MergeCells = true;
' A1:C3 セルを結合します。
Creator1.Cell("A1:C3").Attr.MergeCells = True
文字列の縦位置、横位置を設定する

このセクションでは、文字列の縦位置、横位置を設定する方法を説明します。

次のコードは、VerticalAlignment プロパティで A1 セルの文字列の縦位置 [上詰め]、HorizontalAlignment プロパティで B1 セルの文字列の横位置 [右詰め] を設定するサンプルコードです。

C#
VB
コピー
// A1 セルに文字列の縦位置 [上詰め] を設定します。
creator1.Cell("A1").Attr.VerticalAlignment = AdvanceSoftware.ExcelCreator.VerticalAlignment.Top;
// B1 セルに文字列の横位置 [右詰め] を設定します。
creator1.Cell("B1").Attr.HorizontalAlignment = AdvanceSoftware.ExcelCreator.HorizontalAlignment.Right;
' A1 セルに文字列の縦位置 [上詰め] を設定します。
Creator1.Cell("A1").Attr.VerticalAlignment = AdvanceSoftware.ExcelCreator.VerticalAlignment.Top
' B1 セルに文字列の横位置 [右詰め] を設定します。
Creator1.Cell("B1").Attr.HorizontalAlignment = AdvanceSoftware.ExcelCreator.HorizontalAlignment.Right
セルの背景色、パターンを設定する

このセクションでは、セルの背景色、パターンを設定する方法を説明します。

セルの背景色を設定する

次のコードは、BackColor プロパティで A1 セルの背景色を [赤] に、BackColor2 プロパティで B1 セルの背景色を [青] に設定するサンプルコードです。

Note メモ:

BackColor プロパティは、Xlsx 形式を扱う場合のみ使用できます。
C#
VB
コピー
// A1 セルに背景色 [赤] を設定します。
creator1.Cell("A1").Attr.BackColor = System.Drawing.Color.Red;
// B1 セルに背景色 [青] を設定します。
creator1.Cell("B1").Attr.BackColor2 = AdvanceSoftware.ExcelCreator.xlColor.Blue;
' A1 セルに背景色 [赤] を設定します。
Creator1.Cell("A1").Attr.BackColor = System.Drawing.Color.Red
' B1 セルに背景色 [青] を設定します。
Creator1.Cell("B1").Attr.BackColor2 = AdvanceSoftware.ExcelCreator.xlColor.Blue

セルのパターンを設定する

次のコードは、Pattern プロパティで A1 セルにパターン [右下がり斜線 縞]、BackColor プロパティでパターン背景色 [緑]、ForeColor プロパティでパターン前景色 [青] で設定し、Pattern プロパティで B1 セルにパターン [左下がり斜線 縞]、BackColor2 プロパティでパターン背景色 [赤]、ForeColor2 プロパティでパターン前景色 [水色] を設定するサンプルコードです。

Note メモ:

BackColor、ForeColor プロパティは、Xlsx 形式を扱う場合のみ使用できます。
C#
VB
コピー
// A1 セルにパターン [左下がり斜線 縞] を設定します。
creator1.Cell("A1").Attr.Pattern = AdvanceSoftware.ExcelCreator.Pattern.DarkUp;
// A1 セルに背景色 [緑] を設定します。
creator1.Cell("A1").Attr.BackColor = System.Drawing.Color.Green;
// A1 セルに前景色 [青] を設定します。
creator1.Cell("A1").Attr.ForeColor = System.Drawing.Color.Blue;
// B1 セルにパターン [右下がり斜線 縞] を設定します。
creator1.Cell("B1").Attr.Pattern = AdvanceSoftware.ExcelCreator.Pattern.DarkDown;
// B1 セルに背景色 [赤] を設定します。
creator1.Cell("B1").Attr.BackColor2 = AdvanceSoftware.ExcelCreator.xlColor.Red;
// B1 セルに前景色 [水色] を設定します。
creator1.Cell("B1").Attr.ForeColor2 = AdvanceSoftware.ExcelCreator.xlColor.Cyan;
' A1 セルにパターン [左下がり斜線 縞] を設定します。
Creator1.Cell("A1").Attr.Pattern = AdvanceSoftware.ExcelCreator.Pattern.DarkUp
' A1 セルに背景色 [緑] を設定します。
Creator1.Cell("A1").Attr.BackColor = System.Drawing.Color.Green
' A1 セルに前景色 [青] を設定します。
Creator1.Cell("A1").Attr.ForeColor = System.Drawing.Color.Blue
' B1 セルにパターン [右下がり斜線 縞] を設定します。
Creator1.Cell("B1").Attr.Pattern = AdvanceSoftware.ExcelCreator.Pattern.DarkDown
' B1 セルに背景色 [赤] を設定します。
Creator1.Cell("B1").Attr.BackColor2 = AdvanceSoftware.ExcelCreator.xlColor.Red
' B1 セルに前景色 [水色] を設定します。
Creator1.Cell("B1").Attr.ForeColor2 = AdvanceSoftware.ExcelCreator.xlColor.Cyan
セルの罫線を設定する

このセクションでは、セルの罫線を設定する方法を説明します。

次のコードは、それぞれのセルに上罫線、下罫線、左罫線、右罫線、左上がり罫線、右上がり罫線を設定するサンプルコードです。

Note メモ:

Xlsx 形式を扱う場合のみ、Color 構造体での色の指定も可能です。
C#
VB
コピー
// LineTop メソッドで B2 セルに上罫線（実線、青）を設定します。
creator1.Cell("B2").Attr.LineTop(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, AdvanceSoftware.ExcelCreator.xlColor.Blue);
// LineBottom メソッドで B3 セルに下罫線（実線、ピンク）を設定します。
creator1.Cell("B3").Attr.LineBottom(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, AdvanceSoftware.ExcelCreator.xlColor.Pink);
// LineLeft メソッドで C2 セルに左罫線（二重線、黒）を設定します。
creator1.Cell("C2").Attr.LineLeft(AdvanceSoftware.ExcelCreator.BorderStyle.Double, AdvanceSoftware.ExcelCreator.xlColor.Black);
// LineRight メソッドで C3 セルに右罫線（二重線、緑）を設定します。
creator1.Cell("C3").Attr.LineRight(AdvanceSoftware.ExcelCreator.BorderStyle.Double, AdvanceSoftware.ExcelCreator.xlColor.Green);
// LineLeftUp メソッドで D2 セルに左上がり罫線（太線、赤）を設定します。
creator1.Cell("D2").Attr.LineLeftUp(AdvanceSoftware.ExcelCreator.BorderStyle.Medium, AdvanceSoftware.ExcelCreator.xlColor.Red);
// LineRightUp メソッドで D3 セルに右上がり罫線（太線、黄）を設定します。
creator1.Cell("D3").Attr.LineRightUp(AdvanceSoftware.ExcelCreator.BorderStyle.Medium, AdvanceSoftware.ExcelCreator.xlColor.Yellow);

' LineTop メソッドで B2 セルに上罫線（実線、青）を設定します。
Creator1.Cell("B2").Attr.LineTop(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, AdvanceSoftware.ExcelCreator.xlColor.Blue)
' LineBottom メソッドで B3 セルに下罫線（実線、ピンク）を設定します。
Creator1.Cell("B3").Attr.LineBottom(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, AdvanceSoftware.ExcelCreator.xlColor.Pink)
' LineLeft メソッドで C2 セルに左罫線（二重線、黒）を設定します。
Creator1.Cell("C2").Attr.LineLeft(AdvanceSoftware.ExcelCreator.BorderStyle.Double, AdvanceSoftware.ExcelCreator.xlColor.Black)
' LineRight メソッドで C3 セルに右罫線（二重線、緑）を設定します。
Creator1.Cell("C3").Attr.LineRight(AdvanceSoftware.ExcelCreator.BorderStyle.Double, AdvanceSoftware.ExcelCreator.xlColor.Green)
' LineLeftUp メソッドで D2 セルに左上がり罫線（太線、赤）を設定します。
Creator1.Cell("D2").Attr.LineLeftUp(AdvanceSoftware.ExcelCreator.BorderStyle.Medium, AdvanceSoftware.ExcelCreator.xlColor.Red)
' LineRightUp メソッドで D3 セルに右上がり罫線（太線、黄）を設定します。
Creator1.Cell("D3").Attr.LineRightUp(AdvanceSoftware.ExcelCreator.BorderStyle.Medium, AdvanceSoftware.ExcelCreator.xlColor.Yellow)
参照
オブジェクト機能一覧 (CellAttr クラス)
基本操作


セルを範囲指定する

ExcelCreator 12.0 for .NET では、Cell / Pos メソッドを使用し、さまざまな方法でセルやセル範囲を指定して値を設定することが可能です。このトピックでは、セルの指定方法を説明します。

このトピックは、次のセクションを含みます。

  • Cell メソッドでセルを範囲指定する
  • Pos メソッドでセルを範囲指定する
  • 参照
Note メモ:

セル範囲を指定して値の取得を行った場合は、指定範囲の左上のセルの値を取得します。
Cell メソッドでセルを範囲指定する

次のコードは、Cell メソッドで A1:C4 セルを範囲指定し、値と書式を設定するサンプルコードです。

C#
VB
コピー
// Cell メソッドでセル範囲(A1:C4)を指定し、値と書式を設定します。
creator1.Cell("A1:C4").Attr.FontName = "ＭＳ ゴシック";
creator1.Cell("A1:C4").Attr.FontPoint = 14;
creator1.Cell("A1:C4").Attr.BackColor2 = AdvanceSoftware.ExcelCreator.xlColor.Cyan;
creator1.Cell("A1:C4").Value = "abc";
' Cell メソッドでセル範囲(A1:C4)を指定し、値と書式を設定します。
Creator1.Cell("A1:C4").Attr.FontName = "ＭＳ ゴシック"
Creator1.Cell("A1:C4").Attr.FontPoint = 14
Creator1.Cell("A1:C4").Attr.BackColor2 = AdvanceSoftware.ExcelCreator.xlColor.Cyan
Creator1.Cell("A1:C4").Value = "abc"
Pos メソッドでセルを範囲指定する

次のコードは、Pos メソッドで A1:C4 セルを範囲指定し、値と書式を設定するサンプルコードです。

C#
VB
コピー
// Pos メソッドでセル範囲(A1:C4)を指定し、値と書式を設定します。
creator1.Pos(0, 0, 2, 3).Attr.FontName = "ＭＳ ゴシック";
creator1.Pos(0, 0, 2, 3).Attr.FontPoint = 14;
creator1.Pos(0, 0, 2, 3).Attr.BackColor2 = AdvanceSoftware.ExcelCreator.xlColor.Cyan;
creator1.Pos(0, 0, 2, 3).Value = "abc";
' Pos メソッドでセル範囲(A1:C4)を指定し、値と書式を設定します。
Creator1.Pos(0, 0, 2, 3).Attr.FontName = "ＭＳ ゴシック"
Creator1.Pos(0, 0, 2, 3).Attr.FontPoint = 14
Creator1.Pos(0, 0, 2, 3).Attr.BackColor2 = AdvanceSoftware.ExcelCreator.xlColor.Cyan
Creator1.Pos(0, 0, 2, 3).Value = "abc"
参照
オブジェクト機能一覧 (Creator クラス)
基本操作


日付の値の設定、取得する

ExcelCreator 12.0 for .NET では、日付の値を設定、取得することが可能です。
Excel ファイルのセルに設定された日付の値は、Excel ファイル内部でシリアル値（数値）として管理されています。 そのため、Str、Value プロパティ等でそのまま日付形式で値を設定、取得することはできないため、 各言語のサポートするデータ変換関数を使用して、日付型のデータとして扱う必要があります。 このトピックでは、日付の値を設定、取得する方法を説明します。

このトピックは、次のセクションを含みます。

  • 日付の値を設定する
  • 日付の値を取得する
  • 和暦の表示形式を設定する
  • 参照
日付の値を設定する

次のコードは、A1 セルに日付の値を設定するサンプルコードです。

C#
VB
コピー
// 日付 "2025/1/1" を日付型のデータに変換し、Value プロパティで A1 セルに設定します。
creator1.Cell("A1").Value = Convert.ToDateTime("2025/1/1").ToOADate();
// A1 セルに日付の書式を設定します。(例 2025/1/1)
creator1.Cell("A1").Attr.Format = "yyyy/m/d";
' 日付 "2025/1/1" を日付型のデータに変換し、Value プロパティで A1 セルに設定します。
Creator1.Cell("A1").Value = Convert.ToDateTime("2025/1/1").ToOADate()
' A1 セルに日付の書式を設定します。(例 2025/1/1)
Creator1.Cell("A1").Attr.Format = "yyyy/m/d"
日付の値を取得する

次のコードは、Excel ファイルの A1 セルにあらかじめ設定された日付(2021年1月1日)を文字列で取得するサンプルコードです。

C#
VB
コピー
// Excel の表示形式が反映された文字列を取得します。(例 2025年1月1日)
string strDate1;
strDate1 = creator1.Cell("A1").FormattedString;

// シリアル値から一旦 DateTime 型に変換した上で任意の書式で文字列を取得します。(例 2025/1/1)
DateTime dtDate;
string strDate2;
dtDate = DateTime.FromOADate(Convert.ToDouble(creator1.Cell("A1").Value));
strDate2 = dtDate.ToString("yyyy/M/d");

' Excel の表示形式が反映された文字列を取得します。(例 2025年1月1日)
Dim strDate1 As String
strDate1 = Creator1.Cell("A1").FormattedString;

' シリアル値から一旦 DateTime 型に変換した上で任意の書式で文字列を取得します。(例 2025/1/1)
Dim dtDate As DateTime
Dim strDate2 As String
dtDate = DateTime.FromOADate(Convert.ToDouble(Creator1.Cell("A1").Value))
strDate2 = dtDate.ToString("yyyy/M/d")
和暦の表示形式を設定する

次のコードは、A1 セルに日付と和暦の表示形式を設定するサンプルコードです。
ExcelCreator 12.0 for .NET で和暦の表示形式 [令和##年##月##日] を設定する場合、 Excel 上で正しく表示するためには日付の言語/地域を指定する必要があります。

C#
VB
コピー
// 日付 "2025/1/1" を日付型のデータに変換し、Value プロパティで A1 セルに設定します。
creator1.Cell("A1").Value = Convert.ToDateTime("2025/1/1").ToOADate();
// A1 セルに和暦の表示形式を設定します。
creator1.Cell("A1").Attr.Format = "[$-ja-JP]ggge\"年\"m\"月\"d\"日\";@";
' 日付 "2025/1/1" を日付型のデータに変換し、Value プロパティで A1 セルに設定します。
Creator1.Cell("A1").Value = Convert.ToDateTime("2025/1/1").ToOADate()
' A1 セルに和暦の表示形式を設定します。
Creator1.Cell("A1").Attr.Format = "[$-ja-JP]ggge""年""m""月""d""日"";@"
参照
オブジェクト機能一覧 (Creator クラス)
基本操作


画像、オートシェイプを設定する

ExcelCreator 12.0 for .NET では 画像、オートシェイプ、テキストボックス、ラインを設定することが可能です。このトピックでは、それらの設定方法を説明します。

このトピックは、次のセクションを含みます。

  • 画像ファイルを設定する
  • オートシェイプを設定する
  • テキストボックスを設定する
  • ラインを設定する
  • 参照
画像ファイルを設定する

次のコードは、A1 セルに画像ファイル (C:\Data\Sample.bmp) を縦、横 50 ミリメートルで設定するサンプルコードです。

C#
VB
コピー
// ScaleMode プロパティでスケールモード [ミリ] を設定します。
creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Millimeter;
// AddImage メソッドで 縦、横 50 ミリメートルで画像ファイルを設定します。
creator1.Cell("A1").Drawing.AddImage("C:\\Data\\Sample.bmp", -1, -1, -1, -1, 50, 50);
' ScaleMode プロパティでスケールモード [ミリ] を設定します。
Creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Millimeter
' AddImage メソッドで縦、横 50 ミリメートルで画像ファイルを設定します。
Creator1.Cell("A1").Drawing.AddImage("C:\Data\Sample.bmp", -1, -1, -1, -1, 50, 50)
オートシェイプを設定する

次のコードは、B2 セルにオートシェイプ [楕円] を塗りつぶし色 [青] でセルのサイズに合わせて設定するサンプルコードです。

C#
VB
コピー
// B2 セルにオートシェイプの塗りつぶし色 [青] を設定します。
creator1.Cell("B2").Drawing.FillColor = System.Drawing.Color.Blue;
// B2 セルにオートシェイプ [楕円] を設定します。
creator1.Cell("B2").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse);
' B2 セルにオートシェイプの塗りつぶし色 [青] を設定します。
Creator1.Cell("B2").Drawing.FillColor = System.Drawing.Color.Blue
' B2 セルにオートシェイプ [楕円] を設定します。
Creator1.Cell("B2").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse)
テキストボックスを設定する

次のコードは、B2:D5 セルに横書きテキストボックスを文字列の位置 [縦位置:中央揃え、横位置:中央揃え] でセルのサイズに合わせて設定するサンプルコードです。

C#
VB
コピー
// B2:D5 セルにテキストボックスの文字の回転 [横書き] を設定します。
creator1.Cell("B2:D5").Drawing.TextVertical = AdvanceSoftware.ExcelCreator.TextVertical.Horz;
// B2:D5 セルにテキストボックスの水平方向の文字位置 [中央揃え] を設定します。
creator1.Cell("B2:D5").Drawing.TextAlign = AdvanceSoftware.ExcelCreator.TextAlign.Center;
// B2:D5 セルにテキストボックスの垂直方向の文字位置 [中央揃え] を設定します。
creator1.Cell("B2:D5").Drawing.TextAnchor = AdvanceSoftware.ExcelCreator.TextAnchor.Center;
// B2:D5 セルにテキストボックス [長方形] と文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("B2:D5").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Rect, "アドバンスソフトウェア");
' B2:D5 セルにテキストボックスの文字の回転 [横書き] を設定します。
Creator1.Cell("B2:D5").Drawing.TextVertical = AdvanceSoftware.ExcelCreator.TextVertical.Horz
' B2:D5 セルにテキストボックスの水平方向の文字位置 [中央揃え] を設定します。
Creator1.Cell("B2:D5").Drawing.TextAlign = AdvanceSoftware.ExcelCreator.TextAlign.Center
' B2:D5 セルにテキストボックスの垂直方向の文字位置 [中央揃え] を設定します。
Creator1.Cell("B2:D5").Drawing.TextAnchor = AdvanceSoftware.ExcelCreator.TextAnchor.Center
' B2:D5 セルにテキストボックス [長方形] と文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("B2:D5").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Rect, "アドバンスソフトウェア")
ラインを設定する

次のコードは、B2:D5 セルにラインカラー [青] でセルのサイズに合わせてラインを設定するサンプルコードです。

C#
VB
コピー
// B2:D5 セルにラインカラー [青] を設定します。
creator1.Cell("B2:D5").Drawing.LineColor = System.Drawing.Color.Blue;
// B2:D5 セルにラインを設定します。
creator1.Cell("B2:D5").Drawing.AddLine(AdvanceSoftware.ExcelCreator.ShapeType.Line);
' B2:D5 セルにラインカラー [青] を設定します。
Creator1.Cell("B2:D5").Drawing.LineColor = System.Drawing.Color.Blue
' B2:D5 セルにラインを設定します。
Creator1.Cell("B2:D5").Drawing.AddLine(AdvanceSoftware.ExcelCreator.ShapeType.Line)
参照
オブジェクト機能一覧 (Drawing クラス)
基本操作


複数の列挙体メンバを設定する

ExcelCreator 12.0 for .NET では、2 つ以上の列挙体メンバを設定することができます。このトピックでは、複数の列挙体メンバの設定に対応しているプロパティと、複数の列挙体メンバを一度に設定する方法を説明します。

このトピックは、次のセクションを含みます。

  • 対応するプロパティ一覧
  • 複数の列挙体メンバを一度に設定する
  • 参照
対応するプロパティ一覧

次の表は、複数の列挙体メンバの設定に対応しているプロパティの一覧です。

クラス名 | プロパティ名 | 説明
Creator | VarInsertMode | 変数名の挿入モードを設定します。
CellAttr | FontStyle | Excel ファイルのセル属性を設定します。
Drawing | FontStyle | テキストボックスのフォントスタイルを設定します。
 | LineStyle | オートシェイプの線種を設定します。
Creator | Center | ページ中央を指定します。
PdfOption | Permit | PDF ファイルの権限を設定します。
複数の列挙体メンバを一度に設定する

次のコードは、FontStyle プロパティを使用して [太字] と [上付き] のフォントスタイルを設定するサンプルコードです。

C#
VB
コピー
// B2 セルにフォントスタイル (太字 + 上付き) を設定します。
creator1.Cell("B2").Attr.FontStyle =
    AdvanceSoftware.ExcelCreator.FontStyle.Bold | AdvanceSoftware.ExcelCreator.FontStyle.Up;
// B2 セルに文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("B2").Str = "アドバンスソフトウェア";
' B2 セルにフォントスタイル (太字 + 上付き) を設定します。
Creator1.Cell("B2").Attr.FontStyle = _
    AdvanceSoftware.ExcelCreator.FontStyle.Bold Or AdvanceSoftware.ExcelCreator.FontStyle.Up
' B2 セルに文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("B2").Str = "アドバンスソフトウェア"
参照
オブジェクト機能一覧
基本操作


PDF 出力オプションを設定する

ExcelCreator 12.0 for .NET では、出力 PDF ファイルのプロパティ、透過画像、計算結果、外字の埋め込みを設定することが可能です。ここでは、各オプションの設定方法について説明します。

文書のプロパティを設定する

出力 PDF ファイルのプロパティを設定する方法を説明します。

計算結果を反映する

出力 PDF ファイルに計算結果を反映する方法を説明します。

外字を切り替える

出力 PDF ファイルの外字を切り替える方法を説明します。


文書のプロパティを設定する

ExcelCreator 12.0 for .NET では、出力する PDF ファイルのプロパティを設定することが可能です。このトピックでは、PDF ファイルのプロパティを設定する方法を説明します。

このトピックは、次のセクションを含みます。

  • ファイルの概要、詳細情報を設定する
  • 文書のセキュリティを設定する
  • フォントを埋め込む
  • 参照
ファイルの概要、詳細情報を設定する

このセクションでは、概要タブの情報を設定する方法を説明します。

次のコードは、「タイトル」、「作成者」、「サブタイトル」、「アプリケーション」、「PDF 変換」項目を設定するサンプルコードです。

C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx", "C:\\Data\\Template.xlsx");
// タイトルを設定します。
creator1.Pdf.Title = "サンプル文書";
// 作成者を設定します。
creator1.Pdf.Author = "AdvanceSoftware corp.";
// サブタイトルを設定します。
creator1.Pdf.Subject = "ExcelCreator 12.0 for .NET で出力した PDF ファイルです。";
// アプリケーションを設定します。
creator1.Pdf.Application = "Sample Application";
// PDF 変換を設定します。
creator1.Pdf.Producer = "ExcelCreator 12.0 for .NET";
creator1.CloseBook(true, "C:\\Data\\OutFile.pdf", false);
Creator1.OpenBook("C:\Data\Out.xlsx", "C:\Data\Template.xlsx")
' タイトルを設定します。
Creator1.Pdf.Title = "サンプル文書"
' 作成者を設定します。
Creator1.Pdf.Author = "AdvanceSoftware corp."
' サブタイトルを設定します。
Creator1.Pdf.Subject = "ExcelCreator 12.0 for .NET で出力した PDF ファイルです。"
' アプリケーションを設定します。
Creator1.Pdf.Application = "Sample Application"
' PDF 変換を設定します。
Creator1.Pdf.Producer = "ExcelCreator 12.0 for .NET"
Creator1.CloseBook(True, "C:\Data\OutFile.pdf", False)
文書のセキュリティを設定する

このセクションでは、セキュリティタブの情報を設定する方法を説明します。

次のコードは、暗号化レベル「Acrobat6_RC4_128」でオーナーパスワードを "owner"、ユーザーパスワードを "user" に設定し、「高精度な印刷」と「内容のコピー」を許可するサンプルコードです。

C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx", "C:\\Data\\Template.xlsx");
// 暗号化レベルを [128-bit RC4] に設定します。
creator1.Pdf.EncryptionType = AdvanceSoftware.ExcelCreator.PdfEncryptionType.Acrobat6_RC4_128;
// オーナーパスワード(owner)、ユーザーパスワード(user)を設定します。
creator1.Pdf.OwnerPassword = "owner";
creator1.Pdf.UserPassword = "user";
// PDF ファイルの権限で [高精度な印刷] と [内容のコピー] の許可を設定します。
AdvanceSoftware.ExcelCreator.PdfPermit pdfPermit = 0;
pdfPermit = pdfPermit | AdvanceSoftware.ExcelCreator.PdfPermit.PrintHigh | AdvanceSoftware.ExcelCreator.PdfPermit.Copy;
creator1.Pdf.Permit = pdfPermit;
creator1.CloseBook(true, "C:\\Data\\OutFile.pdf", false);
Creator1.OpenBook("C:\Data\Out.xlsx", "C:\Data\Template.xlsx")
' 暗号化レベルを [128-bit RC4] に設定します。
Creator1.Pdf.EncryptionType = AdvanceSoftware.ExcelCreator.PdfEncryptionType.Acrobat6_RC4_128
' オーナーパスワード(owner)、ユーザーパスワード(user)を設定します。
Creator1.Pdf.OwnerPassword = "owner"
Creator1.Pdf.UserPassword = "user"
' PDF ファイルの権限で [高精度な印刷] と [内容のコピー] の許可を設定します。
Dim pdfPermit As AdvanceSoftware.ExcelCreator.PdfPermit = 0
pdfPermit = pdfPermit Or AdvanceSoftware.ExcelCreator.PdfPermit.PrintHigh Or AdvanceSoftware.ExcelCreator.PdfPermit.Copy
Creator1.Pdf.Permit = pdfPermit
Creator1.CloseBook(True, "C:\Data\OutFile.pdf", False)
フォントを埋め込む

このセクションでは、PDF ファイルにフォントを埋め込む方法を説明します。

次のコードは、EmbedFonts プロパティで「メイリオ」フォントを埋め込むサンプルコードです。

C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx", "C:\\Data\\Template.xlsx");
// [メイリオ] フォントを埋め込みます。
creator1.Pdf.EmbedFonts = new String[] { "メイリオ" };
creator1.CloseBook(true, "C:\\Data\\OutFile.pdf", false);
Creator1.OpenBook("C:\Data\Out.xlsx", "C:\Data\Template.xlsx")
' [メイリオ] フォントを埋め込みます。
Creator1.Pdf.EmbedFonts = New String () { "メイリオ" }
Creator1.CloseBook(True, "C:\Data\OutFile.pdf", False)
Note メモ:

"*" を設定した場合、使用しているフォントを全て埋め込みます。
参照
PDF ファイルを出力する
PDF ファイル出力時のフォントについて
オブジェクト機能一覧 (PdfOption クラス)
基本操作


計算結果を反映する

ExcelCreator 12.0 for .NET では、ReCalcValue プロパティを使用して出力 PDF ファイルに計算結果を反映することが可能です。このトピックでは、計算結果を反映する方法を説明します。

このトピックは、次のセクションを含みます。

  • 計算結果を反映する
  • 対応する関数、演算子一覧
  • 参照
計算結果を反映する

次のコードは、A3 セルに設定した計算式が、PDF 出力時に再計算されるように設定するサンプルコードです。

C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx", "C:\\Data\\Template.xlsx");
creator1.Cell("A1").Value = 100;
creator1.Cell("A2").Value = 200;
creator1.Cell("A3").Func("=A1+A2", null);
// PDF 出力時に計算式が再計算されるように設定します。
creator1.Pdf.ReCalcValue = true;
creator1.CloseBook(true, "C:\\Data\\OutFile.pdf", false);
Creator1.OpenBook("C:\Data\Out.xlsx", "C:\Data\Template.xlsx")
Creator1.Cell("A1").Value = 100
Creator1.Cell("A2").Value = 200
Creator1.Cell("A3").Func("=A1+A2", Nothing)
' PDF 出力時に計算式が再計算されるように設定します。
Creator1.Pdf.ReCalcValue = True
Creator1.CloseBook(True, "C:\Data\OutFile.pdf", False)
対応する関数、演算子一覧

ReCalcValue プロパティを True に設定することで ExcelCreator 12.0 for .NET の独自の機能で計算式を再計算し、PDF ファイルに計算結果を反映することが可能です。 使用可能な関数に制限があるため、基本的な関数を再計算する場合に適しています。

演算子 / 関数名 | 値の型
単項式 | 数値, 文字列またはセル
加算 (+) | 数値
減算 (-) | 数値
乗算 (*) | 数値
除算 (/) | 数値
余算 (Mod) | 数値
べき乗 (^) | 数値
文字列の連結 (&) | 文字列, 文字列
大小比較 (>) | 数値
大小比較 (>=) | 数値
大小比較 (<) | 数値
大小比較 (<=) | 数値
正否判定 (=) | 数値, 文字列またはセル
正否判定 (<>) | 数値, 文字列またはセル
括弧 ()での優先 | 数値
ABS | 数値
AND | 論理式1, 論理式2
ASC | 文字列
AVERAGE | 数値, ･･･(可変)
CHAR | 数値,値(可変)
CHOOSE | 数値
COLUMN | セル(省略可)
COLUMNS | セル範囲
CONCATENATE | 文字列, ･･･(可変)
COUNT | セル範囲, ･･･(可変)
COUNTA | 値, ･･･(可変)
COUNTBLANK | セル範囲
COUNTIF | セル範囲, 文字列または数値
COUNTIFS | セル範囲, 文字列, ･･･(可変)
DATE | 数値, 数値, 数値
DATEDIF | 数値, 数値, 文字列
DAY | 日付
EDATE | 日付, 数値
EXACT | 文字列, 文字列
FALSE | 論理値
FIND | 文字列, 文字列, 数値(省略可)
HLOOKUP | 文字列または数値, セル範囲, 数値, 論理値(省略可)
IF | 論理式, 数値または文字列, 数値または文字列(省略可)
INDEX | セル範囲, 数値, 数値(省略可)
INDIRECT | 文字列, 論理値(省略可、trueのみ)
INT | 数値
ISBLANK | セル
ISERROR | セル(計算式)
ISNUMBER | セル
LARGE | セル範囲, 数値
LEFT | 文字列, 数値
LEN | 文字列
LOOKUP | 文字列, セル範囲, セル範囲
LOWER | 文字列
MATCH | セル, セル範囲, 数値(省略可)
MAX | 数値, ･･･(可変)
MID | 文字列, 数値, 数値
MIN | 数値, ･･･(可変)
MOD | 数値, 数値
MONTH | 日付
NOT | 計算式
NOW | なし※表示形式で日付の指定が必要
OFFSET | セル範囲,数値,数値,数値(省略可),数値(省略可)
OR | 論理式1, 論理式2
PRODUCT | 数値, ･･･(可変)
QUOTIENT | 数値, 数値
RANK | 数値, セル範囲, 数値
REPLACE | 文字列, 数値, 数値, 文字列
RIGHT | 文字列, 数値
ROUND | 数値, 数値
ROUNDDOWN | 数値, 数値
ROUNDUP | 数値, 数値
ROW | セル(省略可)
ROWS | セル範囲
SEARCH | 文字列, 文字列, 数値(省略可)
SIGN | 数値
SMALL | セル範囲, 数値
SUBSTITUTE | 文字列, 文字列, 文字列, 文字列
SUM(セル) | セル範囲(数値)
SUM(値) | 数値, 数値
SUMIF | セル範囲, 文字列または数値, セル範囲
SUMIFS | セル範囲,セル範囲,文字列,･･･(可変)
TEXT | 数値,文字列
TIME | 数値,数値,数値
TODAY | なし※表示形式で日付の指定が必要
TRIM | 文字列
TRUE | 論理値
TRUNC | 数値, 数値(省略可)
UPPER | 文字列
VALUE | 文字列
VLOOKUP | 文字列または数値, セル範囲, 数値, 論理値(省略可)
WEEKDAY | 日付, 数値(省略可)
YEAR | 日付
Note メモ:
  • Excel ファイルの再計算には未対応です。
  • 対応表に記載のない関数は未対応です。
  • 対応表に記載のない型での設定は未対応です。
  • RC 形式、セル名での座標指定は未対応です。
  • 配列数式には未対応です。
  • VLOOKUP、HLOOKUP での論理値 = False 時、近似値を取得するには表が昇順である必要があります。
  • 「値または数値」、「座標」については、単体セル座標の指定も可能です。
  • 論理値の計算結果は 1 (True)、0 (False) となります。
  • 処理速度が低下する可能性があります。
  • 製品独自の機能で再計算するため、Excel の再計算結果と必ずしも一致するとは限りません。
参照
PDF ファイルを出力する
オブジェクト機能一覧 (PdfOption クラス)
基本操作


外字を切り替える

ExcelCreator 12.0 for .NET では、PDF ファイルの外字を切り替えることができます。また、外字ファイルはフォント毎に指定することもできます。このトピックでは外字の切り替え方法を説明します。

このトピックは、次のセクションを含みます。

  • 外字を切り替えるには
  • フォントファイル配布時の注意点
  • サンプルコード
  • 参照
外字を切り替えるには

EUDCFiles プロパティを使用して外字の切り替えが可能です。EUDCFiles プロパティには第 1 要素に「フォント名」、第 2 要素に「ファイルパス」の String 配列をリストで格納します。また、第 1 要素と第 2 要素の組み合わせによって、フォントごとに外字ファイルを切り替えたり、環境の外字設定を読み込まない等の設定ができます。

組み合わせのパターンは下記の通りです。

第 1 要素 (フォント名) | 動作
特定のフォント名 | このフォントに対して、ファイルパスに設定した外字ファイルを参照します。また、環境の同一フォントの設定は無視されます。
SystemDefaultEUDCFont | 全てのフォントに対して、ファイルパスに設定した外字ファイルを参照します。また、環境のデフォルトの設定は無視されます。
空文字 ("") | 環境の全ての外字設定は無視されます。
第 2 要素 (ファイルパス) | 動作
存在するファイルパス | 指定したフォントに対して、このパスの外字ファイルが取り込まれます。また、環境の同一フォントの設定は無視されます。
存在しないファイルパス | 指定したフォントに対して、外字の設定は無視されます。また、環境に同一フォントの設定がある場合、環境の設定が読み込まれます。
空文字 ("") | 指定したフォントに対して、外字の設定は無視されます。また、環境の同一フォントの設定は無視されます。
フォントファイル配布時の注意点

PDF ファイル出力を行う環境では、あらかじめ Excel ブック内で指定されるフォントファイルを配布する必要があります。
詳細は、「PDF ファイル出力時のフォントについて」をご確認ください。

サンプルコード

次のコードは、環境の外字設定を無視して、"ＭＳ Ｐゴシック" に対して Gaiji1.tte、"ＭＳ 明朝" に対して Gaiji2.tte の外字ファイルを取り込むサンプルコードです。

C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx", "C:\\Data\\Template.xlsx");
// 環境の外字設定を無視して、"ＭＳ Ｐゴシック" の外字を指定します。
creator1.Pdf.EUDCFiles = new string[][] { new string[] { "", "" }, new string[] { "ＭＳ Ｐゴシック", @"C:\Gaiji1.tte" }, new string[] { "ＭＳ 明朝", @"C:\Gaiji2.tte" } };
creator1.CloseBook(true, "C:\\Data\\OutFile.pdf", false);
Creator1.OpenBook("C:\Data\Out.xlsx", "C:\Data\Template.xlsx")
' 環境の外字設定を無視して、"ＭＳ Ｐゴシック" の外字を指定します。
Creator1.Pdf.EUDCFiles = New String()() {New String() {"", ""}, New String() {"ＭＳ Ｐゴシック", "C:\Gaiji1.tte"}, New String() {"ＭＳ 明朝", "C:\Gaiji2.tte"}}
Creator1.CloseBook(True, "C:\Data\OutFile.pdf", False)
参照
PDF ファイルを出力する
PDF ファイル出力時のフォントについて
オブジェクト機能一覧 (PdfOption クラス)
基本操作


HTML 出力オプションを設定する

ExcelCreator 12.0 for .NET では、出力 HTML ファイルのオプション、計算結果を設定することが可能です。ここでは、各オプションの設定方法について説明します。

ファイルの出力オプションを設定する

出力 HTML ファイルのオプションを設定する方法を説明します。

計算結果を反映する

出力 HTML ファイルに計算結果を反映する方法を説明します。


ファイルの出力オプションを設定する

ExcelCreator 12.0 for .NET では、出力する HTML ファイルのオプションを設定することが可能です。このトピックでは、HTML ファイルの出力オプションを設定する方法を説明します。

このトピックは、次のセクションを含みます。

  • ファイルの出力オプションを設定する
  • 参照
ファイルの出力オプションを設定する

次のコードは、HTML ヘッダに<meta>タグを追加し、DOCTYPE 宣言、ページのタイトル、テーブルの余白、テーブルの表示倍率を設定するサンプルコードです。

C#
VB
コピー
// HTML ヘッダに<meta>タグを追加します。
creator1.Html.AddHeader("<meta name=\"author\" content=\"アドバンスソフトウェア株式会社\">");
// DOCTYPE 宣言を [Standard] に設定します。
creator1.Html.DocType = AdvanceSoftware.ExcelCreator.DocType.Standard;
// ページのタイトルを [ExcelCreator 12.0 for .NET] に設定します。
creator1.Html.Title = "ExcelCreator 12.0 for .NET";
// テーブルの余白 (左：100px、上：100px、右：200px、下：200px) を設定します
creator1.Html.TableMargin = new System.Drawing.Rectangle(100, 100, 200, 200);
// テーブルの表示倍率を [200%] に設定します。
creator1.Html.TableScale = 200;
' HTML ヘッダに<meta>タグを追加します。
Creator1.Html.AddHeader("<meta name=""author"" content=""アドバンスソフトウェア株式会社"">")
' DOCTYPE 宣言を [Standard] に設定します。
Creator1.Html.DocType = AdvanceSoftware.ExcelCreator.DocType.Standard
' ページのタイトルを [ExcelCreator 12.0 for .NET] に設定します。
Creator1.Html.Title = "ExcelCreator 12.0 for .NET"
' テーブルの余白 (左：100px、上：100px、右：200px、下：200px) を設定します
Creator1.Html.TableMargin = New System.Drawing.Rectangle(100, 100, 200, 200)
' テーブルの表示倍率を [200%] に設定します。
Creator1.Html.TableScale = 200
参照
HTML ファイルを出力する
オブジェクト機能一覧 (HtmlOption クラス)
基本操作


計算結果を反映する

ExcelCreator 12.0 for .NET では、ReCalcValue プロパティを使用して出力 HTML ファイルに計算結果を反映することが可能です。このトピックでは、計算結果を反映する方法を説明します。

このトピックは、次のセクションを含みます。

  • 計算結果を反映する
  • 対応する関数、演算子一覧
  • 参照
計算結果を反映する

次のコードは、A3 セルに設定した計算式が、HTML 出力時に再計算されるように設定するサンプルコードです。

C#
VB
コピー
creator1.OpenBook("C:\\Data\\Out.xlsx", "C:\\Data\\Template.xlsx");
creator1.Cell("A1").Value = 100;
creator1.Cell("A2").Value = 200;
creator1.Cell("A3").Func("=A1+A2", null);
// HTML 出力時に計算式が再計算されるように設定します。
creator1.Html.ReCalcValue = true;
creator1.CloseBook(true, null, "C:\\Data\\OutFile.html", false);
Creator1.OpenBook("C:\Data\Out.xlsx", "C:\Data\Template.xlsx")
Creator1.Cell("A1").Value = 100
Creator1.Cell("A2").Value = 200
Creator1.Cell("A3").Func("=A1+A2", Nothing)
' HTML 出力時に計算式が再計算されるように設定します。
Creator1.Html.ReCalcValue = True
Creator1.CloseBook(True, Nothing, "C:\Data\OutFile.html", False)
対応する関数、演算子一覧

ReCalcValue プロパティを True に設定することで ExcelCreator 12.0 for .NET の独自の機能で計算式を再計算し、HTML ファイルに計算結果を反映することが可能です。 使用可能な関数に制限があるため、基本的な関数を再計算する場合に適しています。

演算子 / 関数名 | 値の型
単項式 | 数値, 文字列またはセル
加算 (+) | 数値
減算 (-) | 数値
乗算 (*) | 数値
除算 (/) | 数値
余算 (Mod) | 数値
べき乗 (^) | 数値
文字列の連結 (&) | 文字列, 文字列
大小比較 (>) | 数値
大小比較 (>=) | 数値
大小比較 (<) | 数値
大小比較 (<=) | 数値
正否判定 (=) | 数値, 文字列またはセル
正否判定 (<>) | 数値, 文字列またはセル
括弧 ()での優先 | 数値
ABS | 数値
AND | 論理式1, 論理式2
ASC | 文字列
AVERAGE | 数値, ･･･(可変)
CHAR | 数値,値(可変)
CHOOSE | 数値
COLUMN | セル(省略可)
COLUMNS | セル範囲
CONCATENATE | 文字列, ･･･(可変)
COUNT | セル範囲, ･･･(可変)
COUNTA | 値, ･･･(可変)
COUNTBLANK | セル範囲
COUNTIF | セル範囲, 文字列または数値
COUNTIFS | セル範囲, 文字列, ･･･(可変)
DATE | 数値, 数値, 数値
DATEDIF | 数値, 数値, 文字列
DAY | 日付
EDATE | 日付, 数値
EXACT | 文字列, 文字列
FALSE | 論理値
FIND | 文字列, 文字列, 数値(省略可)
HLOOKUP | 文字列または数値, セル範囲, 数値, 論理値(省略可)
IF | 論理式, 数値または文字列, 数値または文字列(省略可)
INDEX | セル範囲, 数値, 数値(省略可)
INDIRECT | 文字列, 論理値(省略可、trueのみ)
INT | 数値
ISBLANK | セル
ISERROR | セル(計算式)
ISNUMBER | セル
LARGE | セル範囲, 数値
LEFT | 文字列, 数値
LEN | 文字列
LOOKUP | 文字列, セル範囲, セル範囲
LOWER | 文字列
MATCH | セル, セル範囲, 数値(省略可)
MAX | 数値, ･･･(可変)
MID | 文字列, 数値, 数値
MIN | 数値, ･･･(可変)
MOD | 数値, 数値
MONTH | 日付
NOT | 計算式
NOW | なし※表示形式で日付の指定が必要
OFFSET | セル範囲,数値,数値,数値(省略可),数値(省略可)
OR | 論理式1, 論理式2
PRODUCT | 数値, ･･･(可変)
QUOTIENT | 数値, 数値
RANK | 数値, セル範囲, 数値
REPLACE | 文字列, 数値, 数値, 文字列
RIGHT | 文字列, 数値
ROUND | 数値, 数値
ROUNDDOWN | 数値, 数値
ROUNDUP | 数値, 数値
ROW | セル(省略可)
ROWS | セル範囲
SEARCH | 文字列, 文字列, 数値(省略可)
SIGN | 数値
SMALL | セル範囲, 数値
SUBSTITUTE | 文字列, 文字列, 文字列, 文字列
SUM(セル) | セル範囲(数値)
SUM(値) | 数値, 数値
SUMIF | セル範囲, 文字列または数値, セル範囲
SUMIFS | セル範囲,セル範囲,文字列,･･･(可変)
TEXT | 数値,文字列
TIME | 数値,数値,数値
TODAY | なし※表示形式で日付の指定が必要
TRIM | 文字列
TRUE | 論理値
TRUNC | 数値, 数値(省略可)
UPPER | 文字列
VALUE | 文字列
VLOOKUP | 文字列または数値, セル範囲, 数値, 論理値(省略可)
WEEKDAY | 日付, 数値(省略可)
YEAR | 日付
Note メモ:
  • Excel ファイルの再計算には未対応です。
  • 対応表に記載のない関数は未対応です。
  • 対応表に記載のない型での設定は未対応です。
  • RC 形式、セル名での座標指定は未対応です。
  • 配列数式には未対応です。
  • VLOOKUP、HLOOKUP での論理値 = False 時、近似値を取得するには表が昇順である必要があります。
  • 「値または数値」、「座標」については、単体セル座標の指定も可能です。
  • 論理値の計算結果は 1 (True)、0 (False) となります。
  • 処理速度が低下する可能性があります。
  • 製品独自の機能で再計算するため、Excel の再計算結果と必ずしも一致するとは限りません。
参照
HTML ファイルを出力する
オブジェクト機能一覧 (HtmlOption クラス)
基本操作


データソースから値を設定する

ExcelCreator 12.0 for .NET では、データソースを設定することで、データベースのデータを一括で Excel ファイルに書き込むことが可能です。このトピックでは、データソースを設定し、Excel ファイルにデータを書き込む方法を説明します。

データソースから値を設定する

次のコードは、A1 セルを基点にデータセットを書き込むサンプルコードです。

C#
VB
コピー
private void button1_Click(object sender, EventArgs e)
{
    creator1.CreateBook("C:\\Data\\Out.xlsx", 3, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021);
    // データセットを作成します。
    DataSet dataSet = CreateData();
    // A1 セルをカレントセルに設定します。
    creator1.Cell("A1");
    // カレントセルを基点にデータセットを書き込みます。
    creator1.SetDataSource(dataSet);
    creator1.CloseBook(true);
}
private DataSet CreateData()
{
    DataSet dataSet = new DataSet();
    DataTable dataTable = new DataTable();

    dataTable.TableName = "製品一覧";
    dataTable.Columns.Add("商品名");
    dataTable.Columns.Add("単価");
    dataSet.Tables.Add(dataTable);
    for (int i = 1; i <= 3; i++)
    {
        DataRow row = dataSet.Tables[0].NewRow();
        row[0] = "商品名" + i;
        row[1] = "単価" + i;
        dataSet.Tables[0].Rows.Add(row);
    }
    return dataSet;
}
Private Sub Button1_Click(sender As Object, e As EventArgs) Handles Button1.Click
    Creator1.CreateBook("C:\Data\Out.xlsx", 3, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021)
    ' データセットを作成します。
    Dim dataSet As DataSet = CreateData()
    ' A1 セルをカレントセルに設定します。
    Creator1.Cell("A1")
    ' カレントセルを基点にデータセットを書き込みます。
    Creator1.SetDataSource(dataSet)
    Creator1.CloseBook(True)
End Sub

Private Function CreateData() As DataSet
    Dim dataSet As DataSet = New DataSet()
    Dim dataTable As DataTable = New DataTable()

    dataTable.TableName = "製品一覧"
    dataTable.Columns.Add("商品名")
    dataTable.Columns.Add("単価")
    dataSet.Tables.Add(dataTable)

    For i As Integer = 1 To 3
        Dim row As DataRow = dataTable.NewRow
        row(0) = "商品名" & i
        row(1) = "単価" & i
        dataTable.Rows.Add(row)
    Next
    Return dataSet
End Function
参照
オブジェクト機能一覧 (Creator クラス)
基本操作


よくあるご質問

ここでは、ExcelCreator 12.0 for .NET のよくあるご質問について説明します。さらに詳しい内容は、弊社ホームページの「FAQ(よくあるご質問と回答)」をご参照ください。

このトピックは、次のセクションを含みます。

＜営業関連のご質問＞
  • 「ExcelCreator 12」の収録製品を教えてください。
  • 製品のシリアルナンバーがわかりません。
  • ライセンスファイルについて教えてください。
  • ライセンスファイルの入手方法を教えてください。
  • 保守（サポート）期間を教えてください。
  • アプリケーションを開発する際のライセンス形態を教えてください。
  • アプリケーションを配布する際のライセンス形態を教えてください。
  • 待機系、開発、検証用環境にもサーバーライセンスは必要でしょうか。
＜技術関連のご質問＞
  • 日本語以外の環境に対応していますか。
  • 32 ビットと 64 ビットのどちらにも対応していますか。
  • Linux に対応していますか。
  • .NET Framework に対応していますか。
  • 旧バージョンの ExcelCreator から移行する方法を教えて下さい。
  • サンプルプログラムはありますか。
  • プロジェクトに追加する NuGet パッケージを教えてください。
  • 体験版がインストールされた環境に製品版をインストールできますか。
  • 体験版で作成したアプリケーションを製品版に切り替えてもそのまま使用できますか。
  • 体験版から製品版に切り替える方法を教えてください。
  • ライセンスファイルの使用方法を教えてください。
  • 対応する Excel の修飾機能を教えてください。
  • VBA やマクロの編集、実行に対応していますか。
  • ExcelCreator 12.0 for .NET を組み込んだアプリケーションが実行できません。
  • 出力に時間がかかります。
  • 出力 PDF と Excel の印刷結果が一致しません。

＜営業関連のご質問＞

「ExcelCreator 12」の収録製品を教えてください。

「ExcelCreator 12」は以下の製品を収録しています。

  • ExcelCreator 12.0 for .NET (.NET / .NET Framework 対応)

動作環境に関する詳細は「システム動作環境」をご確認ください。

製品のシリアルナンバーがわかりません。

製品パッケージ内のインストール情報カードをご確認ください。

ライセンスファイルについて教えてください。

ExcelCreator 12.0 for .NET では、製品版としてご利用いただくためにライセンスファイルによる認証が必要となります。ライセンスファイルの入手方法および使用方法は以下の項目をご確認ください。

  • ライセンスファイルの入手方法を教えてください。
  • ライセンスファイルの使用方法を教えてください。
ライセンスファイルの入手方法を教えてください。

ライセンスファイルは以下の専用ページより申請を行っていただくことで発行されます。ライセンス申請の際、製品のシリアルナンバーが必要となりますので、あらかじめご用意ください。

〇ライセンス手続き
https://www.adv.co.jp/support/license.php

保守（サポート）期間を教えてください。

開発ライセンス（基本パック、追加ライセンス）の購入後 1 年間、もしくは、製品販売終了後 6 ヶ月間のうち、どちらか短い期間を無償保守期間としております。無償保守期間終了後もサポート窓口より一般的なお問い合わせに対応しています。

また、サーバーライセンスの場合、別途サーバーライセンス保守契約が必要となります。詳細は「サポートサービス」よりお問い合わせください。

アプリケーションを開発する際のライセンス形態を教えてください。

開発ライセンスは製品をインストールおよび開発作業を行う開発端末数分必要となります。
製品の基本パック 1 本につき、インストールメディア(CD-ROM)と 1 開発ライセンスが付属します。2 本目からは、インストールメディアが付属しない開発ライセンスのみを「追加ライセンス」でご購入いただくことが可能です。

  • (例1)
    マシン A に ExcelCreator 12.0 for .NET をインストール
    →基本パック 1 本(1 開発ライセンス)必要

  • (例2)
    マシン A に ExcelCreator 12.0 for .NET をインストール
    マシン B に ExcelCreator 12.0 for .NET をインストール
    →基本パック 2 本(2 開発ライセンス)または、基本パック 1 本+追加ライセンス 1 本(あわせて 2 開発ライセンス)必要
アプリケーションを配布する際のライセンス形態を教えてください。

ExcelCreator 12.0 for .NET を使用して開発したクライアントアプリケーションを実行環境へ配布する場合、ランタイムファイルの配布はロイヤリティフリーです。

ExcelCreator 12.0 for .NET をサーバーアプリケーション(関連する機能を含む)に組み込んで配布する場合、配布するサーバーの環境(OS)分のサーバーライセンスを購入してください。
なお、サーバーライセンスの詳しい内容は、「サポートサービス」よりお問い合わせください。

待機系、開発、検証用環境にもサーバーライセンスは必要でしょうか。

待機環境には「サーバー待機ライセンス」が必要です。開発、検証用環境にはサーバーライセンスは必要ありません。

＜技術関連のご質問＞

日本語以外の環境に対応していますか。

英語版など、日本語以外の環境では動作を保証しておりません。

32 ビットと 64 ビットのどちらにも対応していますか。

ExcelCreator 12.0 for .NET の提供するモジュールは AnyCPU でビルドを行っているため、32 ビットと 64 ビットのどちらにも対応しています。

Linux に対応していますか。

Linux 上での実行には対応していますが、開発には対応していません。

  • 開発環境：Windows のみ対応
  • 実行環境：Windows、Linux に対応
.NET Framework に対応していますか。

対応しています。詳細は「システム動作環境」をご確認ください。

旧バージョンの ExcelCreator から移行する方法を教えて下さい。

旧バージョンの ExcelCreator と互換性はなく、移行ツールもありません。

サンプルプログラムはありますか。

基本操作を確認できるサンプルプログラムをご用意しています。なお、サンプルプログラムは体験版にも付属されています。

プロジェクトに追加する NuGet パッケージを教えてください。

ご利用いただくコンポーネントによって追加するパッケージが異なります。以下のパッケージ以外は依存関係として自動でインストールされるため、個別に追加する必要はありません。

  • Creator コンポーネント：AdvanceSoftware.ExcelCreator.Creator
  • BarCode コンポーネント：AdvanceSoftware.ExcelCreator.BarCode
  • Express コンポーネント：AdvanceSoftware.ExcelCreator.Xlsx.CreatorExpress

各コンポーネントの詳細は、ヘルプファイル内の「コンポーネントの種類について」をご確認ください。

体験版がインストールされた環境に製品版をインストールできますか。

製品版をインストールしなおす必要はありません。製品版への切り替え方法は以下の項目をご確認ください。

  • 体験版から製品版に切り替える方法を教えてください。
体験版で作成したアプリケーションを製品版に切り替えてもそのまま使用できますか。

使用できます。製品版への切り替え方法は以下の項目をご確認ください。

  • 体験版から製品版に切り替える方法を教えてください。
体験版から製品版に切り替える方法を教えてください。

ExcelCreator 12.0 for .NET ではライセンスファイルを使用して製品版の認証を行います。ライセンスファイルの入手方法、使用方法は以下の項目をご確認ください。

  • ライセンスファイルの入手方法を教えてください。
  • ライセンスファイルの使用方法を教えてください。
ライセンスファイルの使用方法を教えてください。

SetLicense メソッドでライセンスファイルの情報を設定します。詳細は、ヘルプファイル内の「ライセンスファイルを指定する」をご確認ください。

対応する Excel の修飾機能を教えてください。

ヘルプファイル内の「対応する Excel 修飾機能」をご確認ください。

VBA やマクロの編集、実行に対応していますか。

VBA やマクロの編集、実行には対応していません。

ExcelCreator 12.0 for .NET を組み込んだアプリケーションが実行できません。
  1. 開発されたアプリケーションの対象フレームワークをご確認ください。
  2. 1. で確認した対象フレームワークが実行環境に適用されているかご確認ください。
  3. Linux 環境の場合は「libgdiplus」がインストールされているかご確認ください。
出力に時間がかかります。

ExcelCreator 12.0 for .NET では、次のような場合に時間がかかる傾向があります。

  1. 扱うデータ量(セル数、書式)が多い場合
  2. 結合セルや計算式が多数設定されている場合
  3. セルの塗りつぶしやオブジェクトの書式で以下のパターンを設定されている場合
    50%灰色 / 75%灰色 / 25%灰色 / 左下がり斜線 格子 / 12.5%灰色 / 6.25%灰色
出力 PDF と Excel の印刷結果が一致しません。

ExcelCreator は製品独自の描画仕様で PDF イメージを生成しているため、Excel の印刷結果と完全には一致しません。なお、違いが発生しやすい傾向として以下のことが考えられます。

  • 出力時の解像度について
    ExcelCreator 12.0 for .NET の PDF 出力と Excel による印刷で出力時の解像度が異なる可能性があります。
    テンプレート Excel シートの [ページ設定] - [印刷品質] に設定されている解像度を PdfOption.Quality プロパティに設定して動作をご確認ください。

    // PDF ファイル作成時の解像度を "600" に設定します。
    creator1.Pdf.Quality = 600;
    creator1.CloseBook(true, "C:\\Data\\Out.pdf", false);

  • テンプレート Excel ファイルの デフォルトフォントについて
    テンプレート Excel ファイルの デフォルトフォントが游ゴシックの場合、ＭＳ Ｐゴシック 11pt に変更して動作をご確認ください。

  • 対応していない機能について
    ExcelCreator 12.0 for .NET の PDF 出力では、グラフ、一部のオートシェイプ、コントロール類の反映に対応していません。
    上記以外にも未対応の Excel 修飾機能がございますが、詳細はヘルプファイル内の「対応する Excel 修飾機能」をご確認ください。


旧バージョンとの互換性、共存

このトピックでは、旧バージョンとの互換性、共存について説明します。

このトピックは、次のセクションを含みます。

  • 旧バージョンとの互換性
  • 旧バージョンとの共存
旧バージョンとの互換性

ExcelCreator 12.0 for .NET と ExcelCreator シリーズのバージョン間で互換性はありません。また、移行ツールも用意していないため、旧バージョンで作成したプロジェクトやアプリケーションを ExcelCreator 12.0 for .NET で使用することはできません。

旧バージョンとの共存

ExcelCreator 12.0 for .NET は、ExcelCreator シリーズの次のバージョンと同じ環境にインストール、アプリケーションを配布することが可能です。

バージョン | 補足事項
ExcelCreator Ver3.0 | ActiveX 版、xls 形式に対応
ExcelCreator Ver3.6 | ActiveX 版、xlsx 形式に対応
ExcelCreator 5.0 for .NET | .NET Framework 版、xls 形式に対応
ExcelCreator 6.0 for .NET | .NET Framework 版、xlsx 形式に対応
ExcelCreator 8.0 for .NET | .NET Framework 版、xlsx 形式に対応
ExcelCreator 10.0 for .NET | .NET Framework 版、xls / xlsx 両形式に対応
ExcelCreator 11.0 for .NET | .NET 版、xls / xlsx 両形式に対応


オブジェクト機能一覧

ここでは、ExcelCreator 12.0 for .NET でオブジェクト別に設定可能なメソッド・プロパティ・イベント一覧について説明します。

Creator コンポーネント

Creator コンポーネントのオブジェクト機能一覧を説明します。

BarCode コンポーネント

BarCode コンポーネントのオブジェクト機能一覧を説明します。


Creator コンポーネント

このトピックでは、Creator コンポーネントで使用可能なオブジェクト機能一覧を確認することが可能です。

このトピックは、次のセクションを含みます。

  • Cell クラス
  • CellAttr クラス
  • CellCanvas クラス
  • Creator クラス
  • Drawing クラス
  • HtmlOption クラス
  • PdfOption クラス
  • PdfSignature クラス
Cell クラス
メソッド名 | 説明
Activate | アクティブセルを設定します。
Clear | セルをクリアします。
Copy | セルをコピーします。
Double2 | 実数値と属性番号を設定します。
Func | 計算式を設定します。
Int642 | long 値と属性番号を設定します。(xlsx 用)
Long2 | 数値と属性番号を設定します。
Paste | コピーしたセルを貼り付けます。
Str2 | 文字列と属性番号を設定します。
Value2 | 属性番号を指定して値を設定します。
プロパティ名 | 説明
Attr | Attr を取得します。
AttrNo | 属性番号を設定、取得します。
Break | 改ページを設定します。
ColWidth | セル幅を設定、取得します。
Double | 実数値を設定します。
Drawing | Drawing を取得します。
FormattedString | 書式化された文字列を取得します。
FormulaString | 計算式文字列を取得します。
Int64 | long 値を設定します。(xlsx 用)
Long | 数値を設定します。
RowHeight | 行の高さを設定、取得します。
Str | 文字列を設定します。
Value | 値を設定、取得します。
CellAttr クラス
メソッド名 | 説明
Box | Box 罫線を設定します。
LineBottom | 下罫線を設定します。
LineLeft | 左罫線を設定します。
LineLeftUp | 左上がり罫線を設定します。
LineRight | 右罫線を設定します。
LineRightUp | 右上がり罫線を設定します。
LineTop | 上罫線を設定します。
プロパティ名 | 説明
BackColor | 背景色(Color 構造体)を設定します。(xlsx 用)
BackColor2 | 背景色(xlColor 列挙体)を設定します。
FontColor | フォントカラー(Color 構造体)を設定します。(xlsx 用)
FontColor2 | フォントカラー(xlColor 列挙体)を設定します。
FontName | フォント名を設定します。
FontPoint | フォントポイントを設定します。
FontStyle | フォントスタイルを設定します。
FontULine | フォント下線を設定します。
ForeColor | 前景色(Color 構造体)を設定します。(xlsx 用)
ForeColor2 | 前景色(xlColor 列挙体)を設定します。
Format | 表示書式を設定します。
HorizontalAlignment | 文字の配置の横位置を設定します。
Locked | セルのロックを設定、取得します。
MergeCells | セルの結合を設定します。
Orientation | 文字の配置の回転を設定します。
Pattern | パターンを設定します。
ShrinkToFit | 縮小して全体を表示を設定します。
VerticalAlignment | 文字の配置の縦位置を設定します。
WrapText | 折り返して全体を表示を設定します。
CellCanvas クラス
メソッド名 | 説明
AddChart メソッド | グラフを設定します。
AddImage メソッド | イメージを設定します。
Creator クラス
メソッド名 | 説明
AddSheet | シートを追加します。
Cell | Cell を取得します。
CloseBook | ブックをクローズします。
CloseBookEx | ブックをクローズします。
ColumnClear | 列をクリアします。
ColumnCopy | 列をコピーします。
ColumnDelete | 列を削除します。
ColumnInsert | 列を挿入します。
ColumnInsertCopied | コピーした列を挿入します。
ColumnPaste | コピーした列を貼り付けします。
CopySheet | シートをコピーします。
CreateBook | ブックを新規作成します。
CreateBookEx | ブックを新規作成します。
DeleteSheet | シートを削除します。
Footer | フッターを設定します。
Footer2 | 設定ページを指定してフッターを設定します。(xlsx 用)
GetChartCount | 選択したシートに含まれるグラフ数を取得します。
GetChartData | グラフ情報を取得します。
GetHtmlText | HTML テキストを取得します。
GetMaxArea | データ、または、属性の終了座標を取得します。
GetMaxData | データの終了座標を取得します。
GetMergeCells | 結合セルの座標一覧を取得します。
GetNamePos | 指定したセル名の座標(0～)を取得します。
GetRangeAddress | 指定したセル名の座標一覧を取得します。
GetVarNamePos | 指定した変数名の座標(0～)を取得します。
Header | ヘッダーを設定します。
Header2 | 設定ページを指定してヘッダーを設定します。(xlsx 用)
Margin | 余白を設定します。
OpenBook | ブックをオープンします。
OpenBookEmbed | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEmbedEx | バイナリデータを元ファイルとして複数のブックをオープンします。
OpenBookEx | 複数のブックをオープンします。
Pos | Cell を取得します。
PrintArea | 印刷範囲を設定します。
PrintTitle | 印刷タイトルを設定します。
ReadBook | ブックを読み取り専用でオープンします。
ReadBookEx | 複数のブックを読み取り専用でオープンします。
RowClear | 行をクリアします。
RowCopy | 行をコピーします。
RowDelete | 行を削除します。
RowInsert | 行を挿入します。
RowInsertCopied | コピーした行を挿入します。
RowPaste | コピーした行を貼り付けします。
SelectBook | 処理の対象となるブックを切り替えます。
SetDataSource | データソースからセルに値を設定します。
SetJsonValue | JSON 文字列による Excel ファイルへの書き込みをします。
SetLicense | ライセンスを設定します。
SheetName2 | シート番号からシート名を取得します。
SheetNo2 | シート名からシート番号を取得します。
Size | 用紙設定を行います。
SizeFree | ユーザー定義用紙を設定します。
TableRowDelete | テーブル範囲に含まれる行を削除します。(xlsx 用)
TableRowInsert | テーブル範囲に行を挿入します。(xlsx 用)
VarCheck | 指定した変数名が存在するかをチェックします。
プロパティ名 | 説明
ActiveSheet | アクティブシートを設定、取得します。
Center | ページ中央を指定します。
ChangeNameAddressMode | セル名のセル位置調整モードを設定します。(xlsx 用)
ChangeRefSheetAddressMode | 計算式内のセル位置調整モードを設定します。
DefaultFontName | 標準のフォント名を設定します。
DefaultFontPoint | 標準のフォントサイズを設定します。
DoubleMode | 浮動小数点の有効桁数モードを設定、取得します。
ErrorMessage | エラーメッセージを取得します。
ErrorNo | エラーナンバーを取得します。
ExcelFileType | Excel ファイル種別を設定します。
FullCalcOnLoad | ブックオープン時の再計算の有効モードを設定します。(xlsx 用)
GetVarNames | 変数名の座標一覧を取得します。
HeaderFooterMode | ヘッダー／フッターの設定モードを設定します。(xlsx 用)
InitFormulaAnswer | 計算結果の初期化モードを設定します。(xlsx 用)
IsHiddenSheet | 現在のシートが非表示シートかどうかを取得します。
IsPdfSaved | PDF ファイル出力の状態を取得します。
Keyword | 変数名の先頭キーワード文字列を設定します。
MergeCellAreaCheckMode | 結合セルの範囲チェックモードを設定します。
ModeGrid | グリッド線の表示モードを設定します。
PageOrder | ページの方向を指定します。
RangeNames | 名前の一覧を取得します。
RefSheet | 参照するシート名を設定します。(xls 用)
ScaleMode | スケールモードを設定、取得します。
SheetCount | シート数を取得します。
SheetName | シート名を設定、取得します。
SheetNo | シート番号を設定します。
StreamMode | データを展開するストリームのモードを設定します。
TabSelected | シートの選択を指定します。
TemporaryPath | 一時ファイルのパスを設定、取得します。
VarInsertMode | 変数名挿入モードを設定します。
VarNameMode | 変数名の設定を行う Keyword 、VarInsertMode プロパティの動作モードを指定します。
WaitTimeout | 同時アクセス時の待ち時間をミリ秒単位で指定します。
Zoom | 倍率を設定します。
イベント名 | 説明
Error | エラーイベント。
Drawing クラス
メソッド名 | 説明
AddImage | イメージを設定します。
AddLine | 線を設定します。
AddShape | オートシェイプを設定します。
AddTextBox | テキストボックスを設定します。
Init | 設定内容をクリア（初期化）します。
プロパティ名 | 説明
ArrowTypeE | 矢印の終点のスタイル、サイズを設定します。
ArrowTypeS | 矢印の始点のスタイル、サイズを設定します。
FillColor | 塗りつぶし色(Color 構造体)を設定します。
FillColor2 | 塗りつぶし色(xlColor 列挙体)を設定します。
FontColor | テキストボックスのフォントの色(Color 構造体)を設定します。(xlsx 用)
FontColor2 | テキストボックスのフォントの色(xlColor 列挙体)を設定します。
FontName | テキストボックスのフォント名を設定します。
FontPoint | テキストボックスのフォントサイズを設定します。
FontStyle | テキストボックスのフォントスタイルを設定します。
FontULine | テキストボックスのフォントの下線を設定します。
LineColor | 線の色(Color 構造体)を設定します。
LineColor2 | 線の色(xlColor 列挙体)を設定します。
LineStyle | 線種を設定します。
LineWeight | 線の太さを設定します。
ShapeNoFill | オートシェイプ・テキストボックスの「塗りつぶしなし」を設定します。
TextAlign | テキストボックスの水平方向の文字位置を設定します。
TextAnchor | テキストボックスの垂直方向の文字位置を設定します。
TextVertical | テキストボックスの文字の回転を設定します。
HtmlOption クラス
メソッド名 | 説明
AddHeader | HTML ヘッダーを追加します。
プロパティ名 | 説明
DateFormat | 日付の編集フォーマットを設定します。
DocType | HTML の DOCTYPE を指定します。
EditMode | セルの編集モードを設定します。
ErrorFormulaCellColor | エラーとなった計算式のセルの色を指定します。
ImagePath | イメージ用一時フォルダのパスを指定します。
NamedCells | 編集対象の名前の付けられたセルを設定します。
PageZoom | シートを HTML に展開する際の拡大縮小率を設定します。
ReCalcValue | 簡易な計算式の再計算フラグを設定します。
RefSheets | データを参照するシート名を指定します。
ScriptPath | スクリプトフォルダのパスを指定します。
TableMargin | テーブルの余白を設定します。
TableScale | テーブルの倍率を設定します。
TableSize | テーブルのサイズを取得します。
Title | HTML のタイトルを設定します。
PdfOption クラス
プロパティ名 | 説明
Application | PDF のアプリケーションを設定します。
ApplyPrintArea | PDF ファイル出力時に印刷範囲を適用するかを指定します。
ApplyPrintTitle | PDF ファイル出力時に印刷タイトルを適用するかを指定します。
Author | PDF の作成者を設定します。
CreateFileWithoutSignature | 電子署名、タイムスタンプ付与失敗時に PDF ファイルを生成するかを指定します。
EmbedFonts | 埋め込むフォントを設定します。
EncryptionType | PDF ファイルの暗号化強度を設定します。
EUDCFiles | PDF ファイルで使用する外字ファイル名と対象とするフォント名を指定します。
ImageType | イメージの種類を設定します。
IsReplaceYenSign | PDF ファイルに出力する文字列の "¥" マークの扱いを指定します。
OwnerPassword | PDF ファイルのオーナーパスワードを設定します。
PatternQuality | PDF のパターンの解像度を設定します。
Permit | PDF ファイルの権限を設定します。
Producer | PDF 変換を設定します。
Quality | PDF ファイル作成時の解像度を設定します。
ReCalcValue | 計算式の再計算の有無を指定します。
StreamMode | PDF ファイル出力時の StreamMode を指定します。
Subject | PDF のサブタイトルを設定します。
Title | PDF のタイトルを設定します。
UserPassword | PDF ファイルのユーザーパスワードを設定します。
PdfSignature クラス
プロパティ名 | 説明
Capacity | PDF ファイルの電子署名データに割り当てられたバイト数を取得、または取得します。
CertificateData | ローカルの証明書(pfx)データを設定、取得します。
CertificatePassword | ローカルの証明書(pfx)データのパスワードを設定、取得します。
Contact | 署名の連絡先を設定、取得します。
Date | 署名時刻を設定、取得します。
Location | 署名の場所を設定、取得します。
Reason | 署名の理由を設定、取得します。
TimeStampPassword | 署名の埋め込みタイムスタンプサーバーのパスワードを設定、取得します。
TimeStampUrl | 署名の埋め込みタイムスタンプサーバーの URL を設定、取得します。
TimeStampUser | 署名の埋め込みタイムスタンプサーバーのユーザー名を設定、取得します。
WindowsCertificate | Windows 証明書を設定、取得します。
参照
オブジェクト機能一覧


BarCode コンポーネント

このトピックでは、BarCode コンポーネントで使用可能なオブジェクト機能一覧を確認することが可能です。

このトピックは、次のセクションを含みます。

  • BarCode クラス
BarCode クラス
メソッド名 | 説明
GetBarCodeImage | バーコードのイメージを作成します。
GetScaleSize | 指定した単位でバーコードのサイズを取得します。
SetLicense | ライセンスを設定します。
プロパティ名 | 説明
BackColor | バーコードシンボルの背景色を設定、取得します。
BarColor | バーの色を設定、取得します。
BarHeight | バーコードの高さを設定、取得します。
BarRatio | 太バーのエレメント率を設定、取得します。(Codabar、Code39)
BarWidth | バーコードの幅を設定、取得します。
BinaryValue | バーコードデータを設定、取得します。(バイナリ)
BlackBarRevision | 黒バーの太さの比率を設定、取得します。
BlackRatio | 黒バーの太さの比率を設定、取得します。
CharGap | キャラクタ間のギャップを設定、取得します。(Codabar、Code39) 。
CharSize | バーコードメッセージのフォントサイズを設定、取得します。
CheckCharMode | 自動でチェックキャラクタを付加するかを設定、取得します。
CheckPattern | チェックデジットの計算方法を設定、取得します。(Codabar)
Codeset | スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128)、公共料金等代理収納 GS1-128)
DpiX | X 軸方向の解像度を設定、取得します。(ピクセル単位)
DpiY | Y 軸方向の解像度を設定、取得します。(ピクセル単位)
Element | 最小エレメント値を設定、取得します。
EmfType | 拡張メタファイル(EMF)に格納されるレコードの品質を設定します。
ErrorMessage | エラーメッセージを取得します。
ErrorNo | エラーナンバーを取得します。
FlatHeight | ガードバーの均等化を設定、取得します。(JAN、UPC)
Font | バーコードメッセージのフォントを設定、取得します。
InternalQRVersion | QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。
InternalValue | 整形後のバーコードデータを取得します。
MessageAlign | バーコードメッセージの表示横位置を設定、取得します。(GS1Fixed)
PDFColumn | PDF417 の列数を設定、取得します。
PDFInitialSymbol | PDF417 の初期化シンボルを設定、取得します。
PDFLevel | PDF417 のエラー訂正レベルを設定、取得します。
PDFModel | PDF417 シンボルを設定、取得します。
PDFRatio | PDF417 の 1 モジュールの縦横比を設定、取得します。
PDFRow | PDF417 の行数を設定、取得します。
Point | ポイントを設定、取得します。(カスタマバーコード)
QRConnect | 連結 QR コードを作成するかを設定、取得します。
QREscapeCode | QR コードのエスケープコードを設定、取得します。
QRLevel | QR コードの誤り訂正レベルを設定、取得します。
QRMask | QR コードのマスクパターンを設定、取得します。
QRModel | QR コードのモデルを設定、取得します。
QRSymbolNumber | 連結 QR コードで出力するシンボル番号を設定、取得します。
QRVersion | QR コードの型番を設定、取得します。
Quiet | 余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金等代理収納 GS1-128)
Rotate | バーコードの回転方向を設定、取得します。
ShowBearer | ベアラバーを表示するかを設定、取得します。(ITF)
ShowMessage | バーコードメッセージを表示するかを設定、取得します。
StartChar | スタートキャラクタを設定、取得します。(Codabar)
StopChar | ストップキャラクタを設定、取得します。(Codabar)
TextRenderingHint | バーコードメッセージのテキストレンダリングの品質を設定、取得します。
Type | バーコードの種類を設定、取得します。
Unit | バーコードの生成単位を設定、取得します。
Value | バーコードデータを設定、取得します。(文字列)
ValueEncoding | バーコードデータのエンコード方式を設定、取得します。(QRCode, PDF417)
WhiteBarRevision | 白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金等代理収納 GS1-128)
Zoom | 倍率を設定、取得します。(JAN、UPC、ITF)
イベント名 | 説明
Error | バーコードの作成に失敗した時に発生します。
参照
オブジェクト機能一覧


クラス ライブラリ リファレンス

このクラス ライブラリは、ExcelCreator 12.0 for .NET に含まれているクラス、インターフェイス、および値型のライブラリです。ExcelCreator 12.0 for .NET のアプリケーションを作成する場合の基礎となるようにデザインされています。
名前空間
名前空間 | 説明
AdvanceSoftware.Charting.Properties | AdvanceSoftware.Charting.Properties 名前空間
AdvanceSoftware.ExcelCreator | AdvanceSoftware.ExcelCreator 名前空間には、Creator コンポーネントが含まれています。
AdvanceSoftware.ExcelCreator.BarCode | AdvanceSoftware.ExcelCreator.BarCode 名前空間には、BarCode コンポーネントが含まれています。


AdvanceSoftware.Charting.Properties 名前空間

AdvanceSoftware.Charting.Properties 名前空間
クラス
 | クラス | 説明
Public クラス | ApproximateCurve | 系列1 近似曲線 1
Public クラス | Axis | 軸
Public クラス | AxisLabel | 軸ラベル
Public クラス | CategoryAxis | 項目軸 (テキスト)
Public クラス | ChartData | グラフ情報
Public クラス | ChartPosition | グラフ位置
Public クラス | ChartProperties | グラフのオプション
Public クラス | ChartTitle | グラフタイトル
Public クラス | DataLabel | 系列1 データラベル
Public クラス | DataPoint | データポイント
Public クラス | DataPointValue | データポイントの値
Public クラス | DataTable | データテーブル
Public クラス | DateAxis | 項目軸 (日付)
Public クラス | ErrorRange | 系列1 Y 誤差範囲
Public クラス | Fill | 塗りつぶし
Public クラス | Font | フォント
Public クラス | GridLine | 目盛線
Public クラス | Legend | 凡例
Public クラス | LegendEntry | 凡例項目
Public クラス | Line | 枠線
Public クラス | LineEnd | 矢印の種類、サイズ
Public クラス | NumberFormat | 表示形式
Public クラス | Placement | 配置、テキストボックス
Public クラス | PlotArea | プロットエリア
Public クラス | Series | 系列1
Public クラス | TextProperties | 文字のオプション
Public クラス | ValueAxis | 値軸
列挙体
 | 列挙体 | 説明
Public 列挙体 | AxisType | 軸の種類
Public 列挙体 | BuiltInUnit | 表示単位
Public 列挙体 | ChartType | グラフの種類
Public 列挙体 | CompoundLineType | 一重線/多重線
Public 列挙体 | CrossBetween | 軸位置
Public 列挙体 | Crosses | 軸との交点
Public 列挙体 | DataLabelPosition | データラベルの位置
Public 列挙体 | LabelShowType | ラベルの表示種別
Public 列挙体 | LegendPosition | 凡例の位置
Public 列挙体 | LineCapType | 線の先端
Public 列挙体 | LineDashType | 実線/点線
Public 列挙体 | LineEndLength | 矢印のサイズ (長さ)
Public 列挙体 | LineEndType | 矢印の種類
Public 列挙体 | LineEndWidth | 矢印のサイズ (幅)
Public 列挙体 | LineJoinType | 線の結合点
Public 列挙体 | Orientation | 軸の方向
Public 列挙体 | TextCapsType | 大文字の種類
Public 列挙体 | TextStrikeType | 取り消し線の種類
Public 列挙体 | TextUnderlineType | 下線のスタイル
Public 列挙体 | TextVerticalType | 文字列の方向
Public 列挙体 | TickLabelPosition | ラベルの位置
Public 列挙体 | TickMark | 目盛の種類
Public 列挙体 | TimeUnit | 時間の単位


ApproximateCurve クラス

系列1 近似曲線 1
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesApproximateCurve

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class ApproximateCurve
Public Class ApproximateCurve

ApproximateCurve 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


ApproximateCurve フィールド

ApproximateCurve 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
トップ
関連項目

参照

ApproximateCurve クラス
AdvanceSoftware.Charting.Properties 名前空間


ApproximateCurve.chartProperties フィールド

ExcelCreator 12.0 for .NET

ApproximateCurvechartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

ApproximateCurve クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis クラス

軸
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesAxis
AdvanceSoftware.Charting.PropertiesCategoryAxis
AdvanceSoftware.Charting.PropertiesDateAxis
AdvanceSoftware.Charting.PropertiesValueAxis

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Axis
Public Class Axis

Axis 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | axisLabel | ラベル
Public フィールド | axisMajorGrid | 目盛線
Public フィールド | axisMinorGrid | 補助目盛線
Public フィールド | chartProperties | グラフのオプション
Public フィールド | crosses | 縦、横軸との交点 (自動、最大項目)
Public フィールド | crossingValue | 縦、横軸との交点 (項目番号)
Public フィールド | majorTickMark | 目盛の種類
Public フィールド | minorTickMark | 補助目盛の種類
Public フィールド | numberFormat | 表示形式
Public フィールド | orientation | 軸を反転する、日付を逆順にする
Public フィールド | textProperties | 文字のオプション
Public フィールド | tickLabelPosition | ラベルの位置
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Axis フィールド

Axis 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | axisLabel | ラベル
Public フィールド | axisMajorGrid | 目盛線
Public フィールド | axisMinorGrid | 補助目盛線
Public フィールド | chartProperties | グラフのオプション
Public フィールド | crosses | 縦、横軸との交点 (自動、最大項目)
Public フィールド | crossingValue | 縦、横軸との交点 (項目番号)
Public フィールド | majorTickMark | 目盛の種類
Public フィールド | minorTickMark | 補助目盛の種類
Public フィールド | numberFormat | 表示形式
Public フィールド | orientation | 軸を反転する、日付を逆順にする
Public フィールド | textProperties | 文字のオプション
Public フィールド | tickLabelPosition | ラベルの位置
トップ
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.axisLabel フィールド

AxisaxisLabel フィールド

ラベル

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public AxisLabel axisLabel
Public axisLabel As AxisLabel

フィールド値

型: AxisLabel
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.axisMajorGrid フィールド

AxisaxisMajorGrid フィールド

目盛線

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public GridLine axisMajorGrid
Public axisMajorGrid As GridLine

フィールド値

型: GridLine
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.axisMinorGrid フィールド

AxisaxisMinorGrid フィールド

補助目盛線

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public GridLine axisMinorGrid
Public axisMinorGrid As GridLine

フィールド値

型: GridLine
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.chartProperties フィールド

AxischartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.crosses フィールド

Axiscrosses フィールド

縦、横軸との交点 (自動、最大項目)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Crosses crosses
Public crosses As Crosses

フィールド値

型: Crosses
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.crossingValue フィールド

AxiscrossingValue フィールド

縦、横軸との交点 (項目番号)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double crossingValue
Public crossingValue As Double

フィールド値

型: Double
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.majorTickMark フィールド

AxismajorTickMark フィールド

目盛の種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TickMark majorTickMark
Public majorTickMark As TickMark

フィールド値

型: TickMark
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.minorTickMark フィールド

AxisminorTickMark フィールド

補助目盛の種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TickMark minorTickMark
Public minorTickMark As TickMark

フィールド値

型: TickMark
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.numberFormat フィールド

AxisnumberFormat フィールド

表示形式

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public NumberFormat numberFormat
Public numberFormat As NumberFormat

フィールド値

型: NumberFormat
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.orientation フィールド

Axisorientation フィールド

軸を反転する、日付を逆順にする

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Orientation orientation
Public orientation As Orientation

フィールド値

型: Orientation
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.textProperties フィールド

AxistextProperties フィールド

文字のオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextProperties textProperties
Public textProperties As TextProperties

フィールド値

型: TextProperties
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.tickLabelPosition フィールド

AxistickLabelPosition フィールド

ラベルの位置

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TickLabelPosition tickLabelPosition
Public tickLabelPosition As TickLabelPosition

フィールド値

型: TickLabelPosition
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


AxisLabel クラス

軸ラベル
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesAxisLabel

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class AxisLabel
Public Class AxisLabel

AxisLabel 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | text | 軸ラベルのテキスト
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


AxisLabel フィールド

AxisLabel 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | text | 軸ラベルのテキスト
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

AxisLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


AxisLabel.chartProperties フィールド

AxisLabelchartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

AxisLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


AxisLabel.text フィールド

AxisLabeltext フィールド

軸ラベルのテキスト

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string text
Public text As String

フィールド値

型: String
関連項目

参照

AxisLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


AxisLabel.textProperties フィールド

AxisLabeltextProperties フィールド

文字のオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextProperties textProperties
Public textProperties As TextProperties

フィールド値

型: TextProperties
関連項目

参照

AxisLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


AxisType 列挙体

軸の種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum AxisType
Public Enumeration AxisType
メンバー
メンバー | 値 | 説明
Primary | 0 | 主軸
Secondary | 1 | 第 2 軸
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


BuiltInUnit 列挙体

表示単位

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum BuiltInUnit
Public Enumeration BuiltInUnit
メンバー
メンバー | 値 | 説明
Hundreds | 0 | 百
Thousands | 1 | 千
TenThousands | 2 | 万
HundredThousands | 3 | 十万
Millions | 4 | 百万
TenMillions | 5 | 千万
HundredMillions | 6 | 億
Billions | 7 | 十億
Trillions | 8 | 兆
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


CategoryAxis クラス

項目軸 (テキスト)
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesAxis
AdvanceSoftware.Charting.PropertiesCategoryAxis

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class CategoryAxis : Axis
Public Class CategoryAxis
    Inherits Axis

CategoryAxis 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | crossBetween | 軸位置
Public フィールド | labelOffset | 軸からの距離
Public フィールド | tickLabelSkip | ラベルの間隔
Public フィールド | tickMarkSkip | 目盛の間隔
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


CategoryAxis フィールド

CategoryAxis 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | crossBetween | 軸位置
Public フィールド | labelOffset | 軸からの距離
Public フィールド | tickLabelSkip | ラベルの間隔
Public フィールド | tickMarkSkip | 目盛の間隔
トップ
関連項目

参照

CategoryAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


CategoryAxis.crossBetween フィールド

CategoryAxiscrossBetween フィールド

軸位置

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public CrossBetween crossBetween
Public crossBetween As CrossBetween

フィールド値

型: CrossBetween
関連項目

参照

CategoryAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


CategoryAxis.labelOffset フィールド

CategoryAxislabelOffset フィールド

軸からの距離

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int labelOffset
Public labelOffset As Integer

フィールド値

型: Int32
関連項目

参照

CategoryAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


CategoryAxis.tickLabelSkip フィールド

CategoryAxistickLabelSkip フィールド

ラベルの間隔

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public uint tickLabelSkip
Public tickLabelSkip As UInteger

フィールド値

型: UInt32
関連項目

参照

CategoryAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


CategoryAxis.tickMarkSkip フィールド

CategoryAxistickMarkSkip フィールド

目盛の間隔

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public uint tickMarkSkip
Public tickMarkSkip As UInteger

フィールド値

型: UInt32
関連項目

参照

CategoryAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData クラス

グラフ情報
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesChartData

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class ChartData
Public Class ChartData

ChartData 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartPosition | グラフの位置
Public フィールド | chartProperties | グラフのオプション
Public フィールド | chartTitle | グラフタイトル
Public フィールド | col | 列
Public フィールド | height | 高さ
Public フィールド | legend | 凡例
Public フィールド | offsetX | オフセット X
Public フィールド | offsetY | オフセット Y
Public フィールド | plotArea | プロットエリア
Public フィールド | resolution | 解像度
Public フィールド | roundedCorners | 角を丸くする
Public フィールド | row | 行
Public フィールド | textProperties | 文字のオプション
Public フィールド | width | 幅
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


ChartData フィールド

ChartData 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartPosition | グラフの位置
Public フィールド | chartProperties | グラフのオプション
Public フィールド | chartTitle | グラフタイトル
Public フィールド | col | 列
Public フィールド | height | 高さ
Public フィールド | legend | 凡例
Public フィールド | offsetX | オフセット X
Public フィールド | offsetY | オフセット Y
Public フィールド | plotArea | プロットエリア
Public フィールド | resolution | 解像度
Public フィールド | roundedCorners | 角を丸くする
Public フィールド | row | 行
Public フィールド | textProperties | 文字のオプション
Public フィールド | width | 幅
トップ
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.chartPosition フィールド

ChartDatachartPosition フィールド

グラフの位置

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartPosition chartPosition
Public chartPosition As ChartPosition

フィールド値

型: ChartPosition
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.chartProperties フィールド

ChartDatachartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.chartTitle フィールド

ChartDatachartTitle フィールド

グラフタイトル

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartTitle chartTitle
Public chartTitle As ChartTitle

フィールド値

型: ChartTitle
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.col フィールド

ChartDatacol フィールド

列

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int col
Public col As Integer

フィールド値

型: Int32
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.height フィールド

ChartDataheight フィールド

高さ

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int height
Public height As Integer

フィールド値

型: Int32
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.legend フィールド

ChartDatalegend フィールド

凡例

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Legend legend
Public legend As Legend

フィールド値

型: Legend
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.offsetX フィールド

ChartDataoffsetX フィールド

オフセット X

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int offsetX
Public offsetX As Integer

フィールド値

型: Int32
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.offsetY フィールド

ChartDataoffsetY フィールド

オフセット Y

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int offsetY
Public offsetY As Integer

フィールド値

型: Int32
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.plotArea フィールド

ChartDataplotArea フィールド

プロットエリア

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PlotArea plotArea
Public plotArea As PlotArea

フィールド値

型: PlotArea
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.resolution フィールド

ChartDataresolution フィールド

解像度

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int resolution
Public resolution As Integer

フィールド値

型: Int32
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.roundedCorners フィールド

ChartDataroundedCorners フィールド

角を丸くする

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool roundedCorners
Public roundedCorners As Boolean

フィールド値

型: Boolean
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.row フィールド

ChartDatarow フィールド

行

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int row
Public row As Integer

フィールド値

型: Int32
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.textProperties フィールド

ChartDatatextProperties フィールド

文字のオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextProperties textProperties
Public textProperties As TextProperties

フィールド値

型: TextProperties
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.width フィールド

ChartDatawidth フィールド

幅

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int width
Public width As Integer

フィールド値

型: Int32
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartPosition クラス

グラフ位置
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesChartPosition

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class ChartPosition
Public Class ChartPosition

ChartPosition 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | ex | グラフ位置の終了 X 座標
Public フィールド | exh | グラフ位置の終了 X オフセット
Public フィールド | ey | グラフ位置の終了 Y 座標
Public フィールド | eyv | グラフ位置の終了 Y オフセット
Public フィールド | sx | グラフ位置の開始 X 座標
Public フィールド | sxh | グラフ位置の開始 X オフセット
Public フィールド | sy | グラフ位置の開始 Y 座標
Public フィールド | syv | グラフ位置の開始 Y オフセット
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


ChartPosition フィールド

ChartPosition 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | ex | グラフ位置の終了 X 座標
Public フィールド | exh | グラフ位置の終了 X オフセット
Public フィールド | ey | グラフ位置の終了 Y 座標
Public フィールド | eyv | グラフ位置の終了 Y オフセット
Public フィールド | sx | グラフ位置の開始 X 座標
Public フィールド | sxh | グラフ位置の開始 X オフセット
Public フィールド | sy | グラフ位置の開始 Y 座標
Public フィールド | syv | グラフ位置の開始 Y オフセット
トップ
関連項目

参照

ChartPosition クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartPosition.ex フィールド

ChartPositionex フィールド

グラフ位置の終了 X 座標

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int ex
Public ex As Integer

フィールド値

型: Int32
関連項目

参照

ChartPosition クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartPosition.exh フィールド

ChartPositionexh フィールド

グラフ位置の終了 X オフセット

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int exh
Public exh As Integer

フィールド値

型: Int32
関連項目

参照

ChartPosition クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartPosition.ey フィールド

ChartPositioney フィールド

グラフ位置の終了 Y 座標

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int ey
Public ey As Integer

フィールド値

型: Int32
関連項目

参照

ChartPosition クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartPosition.eyv フィールド

ChartPositioneyv フィールド

グラフ位置の終了 Y オフセット

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int eyv
Public eyv As Integer

フィールド値

型: Int32
関連項目

参照

ChartPosition クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartPosition.sx フィールド

ChartPositionsx フィールド

グラフ位置の開始 X 座標

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int sx
Public sx As Integer

フィールド値

型: Int32
関連項目

参照

ChartPosition クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartPosition.sxh フィールド

ChartPositionsxh フィールド

グラフ位置の開始 X オフセット

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int sxh
Public sxh As Integer

フィールド値

型: Int32
関連項目

参照

ChartPosition クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartPosition.sy フィールド

ChartPositionsy フィールド

グラフ位置の開始 Y 座標

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int sy
Public sy As Integer

フィールド値

型: Int32
関連項目

参照

ChartPosition クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartPosition.syv フィールド

ChartPositionsyv フィールド

グラフ位置の開始 Y オフセット

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int syv
Public syv As Integer

フィールド値

型: Int32
関連項目

参照

ChartPosition クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartProperties クラス

グラフのオプション
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesChartProperties

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class ChartProperties
Public Class ChartProperties

ChartProperties 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | fill | 塗りつぶし
Public フィールド | line | 枠線
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


ChartProperties フィールド

ChartProperties 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | fill | 塗りつぶし
Public フィールド | line | 枠線
トップ
関連項目

参照

ChartProperties クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartProperties.fill フィールド

ChartPropertiesfill フィールド

塗りつぶし

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Fill fill
Public fill As Fill

フィールド値

型: Fill
関連項目

参照

ChartProperties クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartProperties.line フィールド

ChartPropertiesline フィールド

枠線

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Line line
Public line As Line

フィールド値

型: Line
関連項目

参照

ChartProperties クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartTitle クラス

グラフタイトル
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesChartTitle

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class ChartTitle
Public Class ChartTitle

ChartTitle 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | text | タイトルのテキスト
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


ChartTitle フィールド

ChartTitle 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | text | タイトルのテキスト
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

ChartTitle クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartTitle.chartProperties フィールド

ChartTitlechartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

ChartTitle クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartTitle.text フィールド

ChartTitletext フィールド

タイトルのテキスト

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string text
Public text As String

フィールド値

型: String
関連項目

参照

ChartTitle クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartTitle.textProperties フィールド

ChartTitletextProperties フィールド

文字のオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextProperties textProperties
Public textProperties As TextProperties

フィールド値

型: TextProperties
関連項目

参照

ChartTitle クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartType 列挙体

グラフの種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ChartType
Public Enumeration ChartType
メンバー
メンバー | 値 | 説明
Column | 0 | 集合縦棒
Bar | 1 | 集合横棒
Line | 2 | 折れ線
Pie | 3 | 円
Doughnut | 4 | ドーナツ
Area | 5 | 面
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


CompoundLineType 列挙体

一重線/多重線

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum CompoundLineType
Public Enumeration CompoundLineType
メンバー
メンバー | 値 | 説明
Single | 0 | 一重線
Double | 1 | 二重線
ThickThin | 2 | 太線 + 細線
ThinThick | 3 | 細線 + 太線
Triple | 4 | 三重線
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


CrossBetween 列挙体

軸位置

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum CrossBetween
Public Enumeration CrossBetween
メンバー
メンバー | 値 | 説明
Between | 0 | 目盛の間
MidpointOfCategory | 1 | 目盛
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Crosses 列挙体

軸との交点

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum Crosses
Public Enumeration Crosses
メンバー
メンバー | 値 | 説明
AutoZero | 0 | 自動
Maximum | 1 | 最大項目
Minimum | 2 | 最小項目
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


DataLabel クラス

系列1 データラベル
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesDataLabel

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class DataLabel
Public Class DataLabel

DataLabel 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | numberFormat | 表示形式
Public フィールド | position | ラベルの位置
Public フィールド | rangeString | セルの値
Public フィールド | separator | 区切り文字
Public フィールド | showType | ラベルの内容
Public フィールド | text | ラベルのテキスト
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


DataLabel フィールド

DataLabel 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | numberFormat | 表示形式
Public フィールド | position | ラベルの位置
Public フィールド | rangeString | セルの値
Public フィールド | separator | 区切り文字
Public フィールド | showType | ラベルの内容
Public フィールド | text | ラベルのテキスト
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

DataLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


DataLabel.chartProperties フィールド

DataLabelchartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

DataLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


DataLabel.numberFormat フィールド

DataLabelnumberFormat フィールド

表示形式

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public NumberFormat numberFormat
Public numberFormat As NumberFormat

フィールド値

型: NumberFormat
関連項目

参照

DataLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


DataLabel.position フィールド

DataLabelposition フィールド

ラベルの位置

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public DataLabelPosition position
Public position As DataLabelPosition

フィールド値

型: DataLabelPosition
関連項目

参照

DataLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


DataLabel.rangeString フィールド

DataLabelrangeString フィールド

セルの値

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string rangeString
Public rangeString As String

フィールド値

型: String
関連項目

参照

DataLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


DataLabel.separator フィールド

DataLabelseparator フィールド

区切り文字

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string separator
Public separator As String

フィールド値

型: String
関連項目

参照

DataLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


DataLabel.showType フィールド

DataLabelshowType フィールド

ラベルの内容

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LabelShowType showType
Public showType As LabelShowType

フィールド値

型: LabelShowType
関連項目

参照

DataLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


DataLabel.text フィールド

DataLabeltext フィールド

ラベルのテキスト

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string text
Public text As String

フィールド値

型: String
関連項目

参照

DataLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


DataLabel.textProperties フィールド

DataLabeltextProperties フィールド

文字のオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextProperties textProperties
Public textProperties As TextProperties

フィールド値

型: TextProperties
関連項目

参照

DataLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


DataLabelPosition 列挙体

データラベルの位置

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum DataLabelPosition
Public Enumeration DataLabelPosition
メンバー
メンバー | 値 | 説明
BestFit | 0 | 自動
Bottom | 1 | 下
Center | 2 | 中央
InsideBase | 3 | 内側軸寄り
InsideEnd | 4 | 内側先端
Left | 5 | 左
OutsideEnd | 6 | 外側先端
Right | 7 | 右
Top | 8 | 上
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


DataPoint クラス

データポイント
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesDataPoint

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class DataPoint
Public Class DataPoint

DataPoint 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | invertColor | 負の値を反転するときの色、透明度
Public フィールド | invertIfNegative | 負の値を反転する
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


DataPoint フィールド

DataPoint 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | invertColor | 負の値を反転するときの色、透明度
Public フィールド | invertIfNegative | 負の値を反転する
トップ
関連項目

参照

DataPoint クラス
AdvanceSoftware.Charting.Properties 名前空間


DataPoint.chartProperties フィールド

DataPointchartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

DataPoint クラス
AdvanceSoftware.Charting.Properties 名前空間


DataPoint.invertColor フィールド

DataPointinvertColor フィールド

負の値を反転するときの色、透明度

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color invertColor
Public invertColor As Color

フィールド値

型: Color
関連項目

参照

DataPoint クラス
AdvanceSoftware.Charting.Properties 名前空間


DataPoint.invertIfNegative フィールド

DataPointinvertIfNegative フィールド

負の値を反転する

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool invertIfNegative
Public invertIfNegative As Boolean

フィールド値

型: Boolean
関連項目

参照

DataPoint クラス
AdvanceSoftware.Charting.Properties 名前空間


DataPointValue クラス

データポイントの値
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesDataPointValue

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class DataPointValue
Public Class DataPointValue

DataPointValue 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | categoryValue | 項目軸 (テキスト) の文字列
Public フィールド | dataLabel | データ ラベルのプロパティ
Public フィールド | dataPoint | データポイントのプロパティ
Public フィールド | xValue | x 値
Public フィールド | yValue | y 値
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


DataPointValue フィールド

DataPointValue 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | categoryValue | 項目軸 (テキスト) の文字列
Public フィールド | dataLabel | データ ラベルのプロパティ
Public フィールド | dataPoint | データポイントのプロパティ
Public フィールド | xValue | x 値
Public フィールド | yValue | y 値
トップ
関連項目

参照

DataPointValue クラス
AdvanceSoftware.Charting.Properties 名前空間


DataPointValue.categoryValue フィールド

DataPointValuecategoryValue フィールド

項目軸 (テキスト) の文字列

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string categoryValue
Public categoryValue As String

フィールド値

型: String
関連項目

参照

DataPointValue クラス
AdvanceSoftware.Charting.Properties 名前空間


DataPointValue.dataLabel フィールド

DataPointValuedataLabel フィールド

データ ラベルのプロパティ

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public DataLabel dataLabel
Public dataLabel As DataLabel

フィールド値

型: DataLabel
関連項目

参照

DataPointValue クラス
AdvanceSoftware.Charting.Properties 名前空間


DataPointValue.dataPoint フィールド

DataPointValuedataPoint フィールド

データポイントのプロパティ

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public DataPoint dataPoint
Public dataPoint As DataPoint

フィールド値

型: DataPoint
関連項目

参照

DataPointValue クラス
AdvanceSoftware.Charting.Properties 名前空間


DataPointValue.xValue フィールド

DataPointValuexValue フィールド

x 値

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double xValue
Public xValue As Double

フィールド値

型: Double
関連項目

参照

DataPointValue クラス
AdvanceSoftware.Charting.Properties 名前空間


DataPointValue.yValue フィールド

DataPointValueyValue フィールド

y 値

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double yValue
Public yValue As Double

フィールド値

型: Double
関連項目

参照

DataPointValue クラス
AdvanceSoftware.Charting.Properties 名前空間


DataTable クラス

データテーブル
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesDataTable

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class DataTable
Public Class DataTable

DataTable 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


DataTable フィールド

DataTable 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

DataTable クラス
AdvanceSoftware.Charting.Properties 名前空間


DataTable.chartProperties フィールド

DataTablechartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

DataTable クラス
AdvanceSoftware.Charting.Properties 名前空間


DataTable.textProperties フィールド

DataTabletextProperties フィールド

文字のオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextProperties textProperties
Public textProperties As TextProperties

フィールド値

型: TextProperties
関連項目

参照

DataTable クラス
AdvanceSoftware.Charting.Properties 名前空間


DateAxis クラス

項目軸 (日付)
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesAxis
AdvanceSoftware.Charting.PropertiesDateAxis

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class DateAxis : Axis
Public Class DateAxis
    Inherits Axis

DateAxis 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | baseTimeUnit | 軸の設定
Public フィールド | crossBetween | 軸位置
Public フィールド | majorTimeUnit | 目盛間隔 (目盛) 単位
Public フィールド | majorUnit | 目盛間隔 (目盛)
Public フィールド | maximum | 境界値 (最大値)
Public フィールド | minimum | 境界値 (最小値)
Public フィールド | minorTimeUnit | 目盛間隔 (補助目盛) 単位
Public フィールド | minorUnit | 目盛間隔 (補助目盛)
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


DateAxis フィールド

DateAxis 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | baseTimeUnit | 軸の設定
Public フィールド | crossBetween | 軸位置
Public フィールド | majorTimeUnit | 目盛間隔 (目盛) 単位
Public フィールド | majorUnit | 目盛間隔 (目盛)
Public フィールド | maximum | 境界値 (最大値)
Public フィールド | minimum | 境界値 (最小値)
Public フィールド | minorTimeUnit | 目盛間隔 (補助目盛) 単位
Public フィールド | minorUnit | 目盛間隔 (補助目盛)
トップ
関連項目

参照

DateAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


DateAxis.baseTimeUnit フィールド

DateAxisbaseTimeUnit フィールド

軸の設定

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TimeUnit baseTimeUnit
Public baseTimeUnit As TimeUnit

フィールド値

型: TimeUnit
関連項目

参照

DateAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


DateAxis.crossBetween フィールド

DateAxiscrossBetween フィールド

軸位置

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public CrossBetween crossBetween
Public crossBetween As CrossBetween

フィールド値

型: CrossBetween
関連項目

参照

DateAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


DateAxis.majorTimeUnit フィールド

DateAxismajorTimeUnit フィールド

目盛間隔 (目盛) 単位

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TimeUnit majorTimeUnit
Public majorTimeUnit As TimeUnit

フィールド値

型: TimeUnit
関連項目

参照

DateAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


DateAxis.majorUnit フィールド

DateAxismajorUnit フィールド

目盛間隔 (目盛)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double majorUnit
Public majorUnit As Double

フィールド値

型: Double
関連項目

参照

DateAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


DateAxis.maximum フィールド

DateAxismaximum フィールド

境界値 (最大値)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double maximum
Public maximum As Double

フィールド値

型: Double
関連項目

参照

DateAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


DateAxis.minimum フィールド

DateAxisminimum フィールド

境界値 (最小値)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double minimum
Public minimum As Double

フィールド値

型: Double
関連項目

参照

DateAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


DateAxis.minorTimeUnit フィールド

DateAxisminorTimeUnit フィールド

目盛間隔 (補助目盛) 単位

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TimeUnit minorTimeUnit
Public minorTimeUnit As TimeUnit

フィールド値

型: TimeUnit
関連項目

参照

DateAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


DateAxis.minorUnit フィールド

DateAxisminorUnit フィールド

目盛間隔 (補助目盛)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double minorUnit
Public minorUnit As Double

フィールド値

型: Double
関連項目

参照

DateAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


ErrorRange クラス

系列1 Y 誤差範囲
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesErrorRange

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class ErrorRange
Public Class ErrorRange

ErrorRange 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


ErrorRange フィールド

ErrorRange 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
トップ
関連項目

参照

ErrorRange クラス
AdvanceSoftware.Charting.Properties 名前空間


ErrorRange.chartProperties フィールド

ErrorRangechartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

ErrorRange クラス
AdvanceSoftware.Charting.Properties 名前空間


Fill クラス

塗りつぶし
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesFill

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Fill
Public Class Fill

Fill 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | color | 色、透明度
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Fill フィールド

Fill 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | color | 色、透明度
トップ
関連項目

参照

Fill クラス
AdvanceSoftware.Charting.Properties 名前空間


Fill.color フィールド

Fillcolor フィールド

色、透明度

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color color
Public color As Color

フィールド値

型: Color
関連項目

参照

Fill クラス
AdvanceSoftware.Charting.Properties 名前空間


Font クラス

フォント
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesFont

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Font
Public Class Font

Font 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | baseline | 相対位置 (上付き、下付き)
Public フィールド | capsType | 大文字の種類
Public フィールド | eastAsianFontName | 日本語用のフォント
Public フィールド | latinFontName | 英数字用のフォント
Public フィールド | normalizeHeights | 文字の高さを揃える
Public フィールド | size | サイズ(pt 単位)
Public フィールド | spacing | 文字間
Public フィールド | strikeType | 取り消し線、二重取り消し線
Public フィールド | style | スタイル
Public フィールド | underlineColor | 下線の色
Public フィールド | underlineType | 下線のスタイル
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Font フィールド

Font 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | baseline | 相対位置 (上付き、下付き)
Public フィールド | capsType | 大文字の種類
Public フィールド | eastAsianFontName | 日本語用のフォント
Public フィールド | latinFontName | 英数字用のフォント
Public フィールド | normalizeHeights | 文字の高さを揃える
Public フィールド | size | サイズ(pt 単位)
Public フィールド | spacing | 文字間
Public フィールド | strikeType | 取り消し線、二重取り消し線
Public フィールド | style | スタイル
Public フィールド | underlineColor | 下線の色
Public フィールド | underlineType | 下線のスタイル
トップ
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.baseline フィールド

Fontbaseline フィールド

相対位置 (上付き、下付き)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int baseline
Public baseline As Integer

フィールド値

型: Int32
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.capsType フィールド

FontcapsType フィールド

大文字の種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextCapsType capsType
Public capsType As TextCapsType

フィールド値

型: TextCapsType
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.eastAsianFontName フィールド

FonteastAsianFontName フィールド

日本語用のフォント

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string eastAsianFontName
Public eastAsianFontName As String

フィールド値

型: String
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.latinFontName フィールド

FontlatinFontName フィールド

英数字用のフォント

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string latinFontName
Public latinFontName As String

フィールド値

型: String
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.normalizeHeights フィールド

FontnormalizeHeights フィールド

文字の高さを揃える

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool normalizeHeights
Public normalizeHeights As Boolean

フィールド値

型: Boolean
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.size フィールド

Fontsize フィールド

サイズ(pt 単位)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public float size
Public size As Single

フィールド値

型: Single
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.spacing フィールド

Fontspacing フィールド

文字間

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double spacing
Public spacing As Double

フィールド値

型: Double
幅 (間隔) / 0 : 標準、正 : 文字間隔を広げる、負 : 文字間隔をつめる
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.strikeType フィールド

FontstrikeType フィールド

取り消し線、二重取り消し線

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextStrikeType strikeType
Public strikeType As TextStrikeType

フィールド値

型: TextStrikeType
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.style フィールド

Fontstyle フィールド

スタイル

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public FontStyle style
Public style As FontStyle

フィールド値

型: FontStyle
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.underlineColor フィールド

FontunderlineColor フィールド

下線の色

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color underlineColor
Public underlineColor As Color

フィールド値

型: Color
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.underlineType フィールド

FontunderlineType フィールド

下線のスタイル

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextUnderlineType underlineType
Public underlineType As TextUnderlineType

フィールド値

型: TextUnderlineType
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


GridLine クラス

目盛線
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesGridLine

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class GridLine
Public Class GridLine

GridLine 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


GridLine フィールド

GridLine 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
トップ
関連項目

参照

GridLine クラス
AdvanceSoftware.Charting.Properties 名前空間


GridLine.chartProperties フィールド

GridLinechartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

GridLine クラス
AdvanceSoftware.Charting.Properties 名前空間


LabelShowType 列挙体

ラベルの表示種別

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
[FlagsAttribute]
public enum LabelShowType
<FlagsAttribute>
Public Enumeration LabelShowType
メンバー
メンバー | 値 | 説明
None | 0 | なし
DataLabelsRange | 1 | セルの値
SeriesName | 2 | 系列名
CategoryName | 4 | 分類名
Value | 8 | 値
LeaderLines | 16 | 引き出し線を表示する
LegendKey | 32 | 凡例マーカー
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Legend クラス

凡例
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesLegend

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Legend
Public Class Legend

Legend 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | legendEntries | 凡例項目
Public フィールド | overlay | 凡例をグラフに重ねずに表示する
Public フィールド | position | 凡例の位置
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Legend フィールド

Legend 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | legendEntries | 凡例項目
Public フィールド | overlay | 凡例をグラフに重ねずに表示する
Public フィールド | position | 凡例の位置
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

Legend クラス
AdvanceSoftware.Charting.Properties 名前空間


Legend.chartProperties フィールド

LegendchartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

Legend クラス
AdvanceSoftware.Charting.Properties 名前空間


Legend.legendEntries フィールド

LegendlegendEntries フィールド

凡例項目

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public List legendEntries
Public legendEntries As List

フィールド値

型: ListT
関連項目

参照

Legend クラス
AdvanceSoftware.Charting.Properties 名前空間


Legend.overlay フィールド

Legendoverlay フィールド

凡例をグラフに重ねずに表示する

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool overlay
Public overlay As Boolean

フィールド値

型: Boolean
関連項目

参照

Legend クラス
AdvanceSoftware.Charting.Properties 名前空間


Legend.position フィールド

Legendposition フィールド

凡例の位置

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LegendPosition position
Public position As LegendPosition

フィールド値

型: LegendPosition
関連項目

参照

Legend クラス
AdvanceSoftware.Charting.Properties 名前空間


Legend.textProperties フィールド

LegendtextProperties フィールド

文字のオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextProperties textProperties
Public textProperties As TextProperties

フィールド値

型: TextProperties
関連項目

参照

Legend クラス
AdvanceSoftware.Charting.Properties 名前空間


LegendEntry クラス

凡例項目
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesLegendEntry

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class LegendEntry
Public Class LegendEntry

LegendEntry 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


LegendEntry フィールド

LegendEntry 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

LegendEntry クラス
AdvanceSoftware.Charting.Properties 名前空間


LegendEntry.textProperties フィールド

LegendEntrytextProperties フィールド

文字のオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextProperties textProperties
Public textProperties As TextProperties

フィールド値

型: TextProperties
関連項目

参照

LegendEntry クラス
AdvanceSoftware.Charting.Properties 名前空間


LegendPosition 列挙体

凡例の位置

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum LegendPosition
Public Enumeration LegendPosition
メンバー
メンバー | 値 | 説明
Bottom | 0 | 下
TopRight | 1 | 右上
Left | 2 | 左
Right | 3 | 右
Top | 4 | 上
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Line クラス

枠線
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesLine

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Line
Public Class Line

Line 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | capType | 線の先端
Public フィールド | color | 色、透明度
Public フィールド | compoundType | 一重線/多重線
Public フィールド | dashType | 実線/点線
Public フィールド | headEnd | 始点矢印の種類、サイズ
Public フィールド | joinType | 線の結合点
Public フィールド | tailEnd | 終点矢印の種類、サイズ
Public フィールド | width | 幅(px 単位)
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Line フィールド

Line 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | capType | 線の先端
Public フィールド | color | 色、透明度
Public フィールド | compoundType | 一重線/多重線
Public フィールド | dashType | 実線/点線
Public フィールド | headEnd | 始点矢印の種類、サイズ
Public フィールド | joinType | 線の結合点
Public フィールド | tailEnd | 終点矢印の種類、サイズ
Public フィールド | width | 幅(px 単位)
トップ
関連項目

参照

Line クラス
AdvanceSoftware.Charting.Properties 名前空間


Line.capType フィールド

LinecapType フィールド

線の先端

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LineCapType capType
Public capType As LineCapType

フィールド値

型: LineCapType
関連項目

参照

Line クラス
AdvanceSoftware.Charting.Properties 名前空間


Line.color フィールド

Linecolor フィールド

色、透明度

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color color
Public color As Color

フィールド値

型: Color
関連項目

参照

Line クラス
AdvanceSoftware.Charting.Properties 名前空間


Line.compoundType フィールド

LinecompoundType フィールド

一重線/多重線

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public CompoundLineType compoundType
Public compoundType As CompoundLineType

フィールド値

型: CompoundLineType
関連項目

参照

Line クラス
AdvanceSoftware.Charting.Properties 名前空間


Line.dashType フィールド

LinedashType フィールド

実線/点線

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LineDashType dashType
Public dashType As LineDashType

フィールド値

型: LineDashType
関連項目

参照

Line クラス
AdvanceSoftware.Charting.Properties 名前空間


Line.headEnd フィールド

LineheadEnd フィールド

始点矢印の種類、サイズ

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LineEnd headEnd
Public headEnd As LineEnd

フィールド値

型: LineEnd
関連項目

参照

Line クラス
AdvanceSoftware.Charting.Properties 名前空間


Line.joinType フィールド

LinejoinType フィールド

線の結合点

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LineJoinType joinType
Public joinType As LineJoinType

フィールド値

型: LineJoinType
関連項目

参照

Line クラス
AdvanceSoftware.Charting.Properties 名前空間


Line.tailEnd フィールド

LinetailEnd フィールド

終点矢印の種類、サイズ

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LineEnd tailEnd
Public tailEnd As LineEnd

フィールド値

型: LineEnd
関連項目

参照

Line クラス
AdvanceSoftware.Charting.Properties 名前空間


Line.width フィールド

Linewidth フィールド

幅(px 単位)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int width
Public width As Integer

フィールド値

型: Int32
関連項目

参照

Line クラス
AdvanceSoftware.Charting.Properties 名前空間


LineCapType 列挙体

線の先端

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum LineCapType
Public Enumeration LineCapType
メンバー
メンバー | 値 | 説明
Round | 0 | 丸
Square | 1 | 四角
Flat | 2 | フラット
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


LineDashType 列挙体

実線/点線

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum LineDashType
Public Enumeration LineDashType
メンバー
メンバー | 値 | 説明
Solid | 0 | 実線
Dot | 1 | 点線
Dash | 2 | 破線
LargeDash | 3 | 長破線
DashDot | 4 | 一点鎖線
LargeDashDot | 5 | 長鎖線
LargeDashDotDot | 6 | 長二点鎖線
SystemDash | 7 | 点線 (角)
SystemDot | 8 | 点線 (丸)
SystemDashDot | 9 | システム鎖線
SystemDashDotDot | 10 | システム二点鎖線
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


LineEnd クラス

矢印の種類、サイズ
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesLineEnd

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class LineEnd
Public Class LineEnd

LineEnd 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | length | 矢印のサイズ (長さ)
Public フィールド | type | 矢印の種類
Public フィールド | width | 矢印のサイズ (幅)
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


LineEnd フィールド

LineEnd 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | length | 矢印のサイズ (長さ)
Public フィールド | type | 矢印の種類
Public フィールド | width | 矢印のサイズ (幅)
トップ
関連項目

参照

LineEnd クラス
AdvanceSoftware.Charting.Properties 名前空間


LineEnd.length フィールド

LineEndlength フィールド

矢印のサイズ (長さ)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LineEndLength length
Public length As LineEndLength

フィールド値

型: LineEndLength
関連項目

参照

LineEnd クラス
AdvanceSoftware.Charting.Properties 名前空間


LineEnd.type フィールド

LineEndtype フィールド

矢印の種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LineEndType type
Public type As LineEndType

フィールド値

型: LineEndType
関連項目

参照

LineEnd クラス
AdvanceSoftware.Charting.Properties 名前空間


LineEnd.width フィールド

LineEndwidth フィールド

矢印のサイズ (幅)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LineEndWidth width
Public width As LineEndWidth

フィールド値

型: LineEndWidth
関連項目

参照

LineEnd クラス
AdvanceSoftware.Charting.Properties 名前空間


LineEndLength 列挙体

矢印のサイズ (長さ)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum LineEndLength
Public Enumeration LineEndLength
メンバー
メンバー | 値 | 説明
Small | 0 | 小
Medium | 1 | 中
Large | 2 | 大
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


LineEndType 列挙体

矢印の種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum LineEndType
Public Enumeration LineEndType
メンバー
メンバー | 値 | 説明
None | 0 | 矢印なし
Triangle | 1 | 矢印
Stealth | 2 | 鋭い矢印
Diamond | 3 | ひし形矢印
Oval | 4 | 円形矢印
Arrow | 5 | 開いた矢印
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


LineEndWidth 列挙体

矢印のサイズ (幅)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum LineEndWidth
Public Enumeration LineEndWidth
メンバー
メンバー | 値 | 説明
Small | 0 | 小
Medium | 1 | 中
Large | 2 | 大
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


LineJoinType 列挙体

線の結合点

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum LineJoinType
Public Enumeration LineJoinType
メンバー
メンバー | 値 | 説明
Round | 0 | 丸
Bevel | 1 | 面取り
Miter | 2 | 角
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


NumberFormat クラス

表示形式
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesNumberFormat

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class NumberFormat
Public Class NumberFormat

NumberFormat 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | formatCode | 表示形式コード
Public フィールド | linkedToSource | シートとリンクする
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


NumberFormat フィールド

NumberFormat 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | formatCode | 表示形式コード
Public フィールド | linkedToSource | シートとリンクする
トップ
関連項目

参照

NumberFormat クラス
AdvanceSoftware.Charting.Properties 名前空間


NumberFormat.formatCode フィールド

NumberFormatformatCode フィールド

表示形式コード

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string formatCode
Public formatCode As String

フィールド値

型: String
関連項目

参照

NumberFormat クラス
AdvanceSoftware.Charting.Properties 名前空間


NumberFormat.linkedToSource フィールド

NumberFormatlinkedToSource フィールド

シートとリンクする

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool linkedToSource
Public linkedToSource As Boolean

フィールド値

型: Boolean
関連項目

参照

NumberFormat クラス
AdvanceSoftware.Charting.Properties 名前空間


Orientation 列挙体

軸の方向

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum Orientation
Public Enumeration Orientation
メンバー
メンバー | 値 | 説明
MaximumToMinimum | 0 | 軸を反転する
MinimumToMaximum | 1 | 軸を反転しない
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Placement クラス

配置、テキストボックス
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesPlacement

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Placement
Public Class Placement

Placement 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | margin | 余白 (左、右、上、下)
Public フィールド | overflow | テキストを図形からはみ出して表示する
Public フィールド | rotation | ユーザー設定の角度
Public フィールド | shapeAutoFit | テキストに合わせて図形のサイズを調整する
Public フィールド | verticalType | 文字列の方向
Public フィールド | wrap | 図形内でテキストを折り返す
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Placement フィールド

Placement 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | margin | 余白 (左、右、上、下)
Public フィールド | overflow | テキストを図形からはみ出して表示する
Public フィールド | rotation | ユーザー設定の角度
Public フィールド | shapeAutoFit | テキストに合わせて図形のサイズを調整する
Public フィールド | verticalType | 文字列の方向
Public フィールド | wrap | 図形内でテキストを折り返す
トップ
関連項目

参照

Placement クラス
AdvanceSoftware.Charting.Properties 名前空間


Placement.margin フィールド

Placementmargin フィールド

余白 (左、右、上、下)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Rectangle margin
Public margin As Rectangle

フィールド値

型: Rectangle
関連項目

参照

Placement クラス
AdvanceSoftware.Charting.Properties 名前空間


Placement.overflow フィールド

Placementoverflow フィールド

テキストを図形からはみ出して表示する

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool overflow
Public overflow As Boolean

フィールド値

型: Boolean
関連項目

参照

Placement クラス
AdvanceSoftware.Charting.Properties 名前空間


Placement.rotation フィールド

Placementrotation フィールド

ユーザー設定の角度

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int rotation
Public rotation As Integer

フィールド値

型: Int32
関連項目

参照

Placement クラス
AdvanceSoftware.Charting.Properties 名前空間


Placement.shapeAutoFit フィールド

PlacementshapeAutoFit フィールド

テキストに合わせて図形のサイズを調整する

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool shapeAutoFit
Public shapeAutoFit As Boolean

フィールド値

型: Boolean
関連項目

参照

Placement クラス
AdvanceSoftware.Charting.Properties 名前空間


Placement.verticalType フィールド

PlacementverticalType フィールド

文字列の方向

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextVerticalType verticalType
Public verticalType As TextVerticalType

フィールド値

型: TextVerticalType
関連項目

参照

Placement クラス
AdvanceSoftware.Charting.Properties 名前空間


Placement.wrap フィールド

Placementwrap フィールド

図形内でテキストを折り返す

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool wrap
Public wrap As Boolean

フィールド値

型: Boolean
関連項目

参照

Placement クラス
AdvanceSoftware.Charting.Properties 名前空間


PlotArea クラス

プロットエリア
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesPlotArea

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class PlotArea
Public Class PlotArea

PlotArea 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | axisX | 第 1 軸 横(項目)軸
Public フィールド | axisX2 | 第 2 軸 横(項目)軸
Public フィールド | axisY | 第 1 軸 縦(値)軸
Public フィールド | axisY2 | 第 2 軸 縦(値)軸
Public フィールド | chartProperties | グラフのオプション
Public フィールド | dataTable | データテーブル
Public フィールド | series | 系列
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


PlotArea フィールド

PlotArea 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | axisX | 第 1 軸 横(項目)軸
Public フィールド | axisX2 | 第 2 軸 横(項目)軸
Public フィールド | axisY | 第 1 軸 縦(値)軸
Public フィールド | axisY2 | 第 2 軸 縦(値)軸
Public フィールド | chartProperties | グラフのオプション
Public フィールド | dataTable | データテーブル
Public フィールド | series | 系列
トップ
関連項目

参照

PlotArea クラス
AdvanceSoftware.Charting.Properties 名前空間


PlotArea.axisX フィールド

PlotAreaaxisX フィールド

第 1 軸 横(項目)軸

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Axis axisX
Public axisX As Axis

フィールド値

型: Axis
関連項目

参照

PlotArea クラス
AdvanceSoftware.Charting.Properties 名前空間


PlotArea.axisX2 フィールド

PlotAreaaxisX2 フィールド

第 2 軸 横(項目)軸

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Axis axisX2
Public axisX2 As Axis

フィールド値

型: Axis
関連項目

参照

PlotArea クラス
AdvanceSoftware.Charting.Properties 名前空間


PlotArea.axisY フィールド

PlotAreaaxisY フィールド

第 1 軸 縦(値)軸

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Axis axisY
Public axisY As Axis

フィールド値

型: Axis
関連項目

参照

PlotArea クラス
AdvanceSoftware.Charting.Properties 名前空間


PlotArea.axisY2 フィールド

PlotAreaaxisY2 フィールド

第 2 軸 縦(値)軸

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Axis axisY2
Public axisY2 As Axis

フィールド値

型: Axis
関連項目

参照

PlotArea クラス
AdvanceSoftware.Charting.Properties 名前空間


PlotArea.chartProperties フィールド

PlotAreachartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

PlotArea クラス
AdvanceSoftware.Charting.Properties 名前空間


PlotArea.dataTable フィールド

PlotAreadataTable フィールド

データテーブル

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public DataTable dataTable
Public dataTable As DataTable

フィールド値

型: DataTable
関連項目

参照

PlotArea クラス
AdvanceSoftware.Charting.Properties 名前空間


PlotArea.series フィールド

PlotAreaseries フィールド

系列

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public List series
Public series As List

フィールド値

型: ListT
関連項目

参照

PlotArea クラス
AdvanceSoftware.Charting.Properties 名前空間


Series クラス

系列1
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesSeries

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Series
Public Class Series

Series 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | approximateCurve | 系列1 近似曲線 1
Public フィールド | axisType | 使用する軸
Public フィールド | chartProperties | グラフのオプション
Public フィールド | chartType | グラフの種類
Public フィールド | dataLabel | 系列1 データ ラベル
Public フィールド | dataPointValues | データポイント
Public フィールド | errorRange | 系列1 Y 誤差範囲
Public フィールド | gapWidth | 要素の間隔(% 単位)
Public フィールド | invertColor | 負の値を反転するときの色、透明度
Public フィールド | invertIfNegative | 負の値を反転する
Public フィールド | overlap | 系列の重なり(% 単位)
Public フィールド | text | 系列名
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Series フィールド

Series 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | approximateCurve | 系列1 近似曲線 1
Public フィールド | axisType | 使用する軸
Public フィールド | chartProperties | グラフのオプション
Public フィールド | chartType | グラフの種類
Public フィールド | dataLabel | 系列1 データ ラベル
Public フィールド | dataPointValues | データポイント
Public フィールド | errorRange | 系列1 Y 誤差範囲
Public フィールド | gapWidth | 要素の間隔(% 単位)
Public フィールド | invertColor | 負の値を反転するときの色、透明度
Public フィールド | invertIfNegative | 負の値を反転する
Public フィールド | overlap | 系列の重なり(% 単位)
Public フィールド | text | 系列名
トップ
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.approximateCurve フィールド

SeriesapproximateCurve フィールド

系列1 近似曲線 1

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public List approximateCurve
Public approximateCurve As List

フィールド値

型: ListT
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.axisType フィールド

SeriesaxisType フィールド

使用する軸

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public AxisType axisType
Public axisType As AxisType

フィールド値

型: AxisType
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.chartProperties フィールド

SerieschartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.chartType フィールド

SerieschartType フィールド

グラフの種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartType chartType
Public chartType As ChartType

フィールド値

型: ChartType
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.dataLabel フィールド

SeriesdataLabel フィールド

系列1 データ ラベル

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public DataLabel dataLabel
Public dataLabel As DataLabel

フィールド値

型: DataLabel
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.dataPointValues フィールド

SeriesdataPointValues フィールド

データポイント

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public List dataPointValues
Public dataPointValues As List

フィールド値

型: ListT
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.errorRange フィールド

SerieserrorRange フィールド

系列1 Y 誤差範囲

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorRange errorRange
Public errorRange As ErrorRange

フィールド値

型: ErrorRange
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.gapWidth フィールド

SeriesgapWidth フィールド

要素の間隔(% 単位)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int gapWidth
Public gapWidth As Integer

フィールド値

型: Int32
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.invertColor フィールド

SeriesinvertColor フィールド

負の値を反転するときの色、透明度

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color invertColor
Public invertColor As Color

フィールド値

型: Color
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.invertIfNegative フィールド

SeriesinvertIfNegative フィールド

負の値を反転する

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool invertIfNegative
Public invertIfNegative As Boolean

フィールド値

型: Boolean
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.overlap フィールド

Seriesoverlap フィールド

系列の重なり(% 単位)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int overlap
Public overlap As Integer

フィールド値

型: Int32
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.text フィールド

Seriestext フィールド

系列名

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string text
Public text As String

フィールド値

型: String
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


TextCapsType 列挙体

大文字の種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TextCapsType
Public Enumeration TextCapsType
メンバー
メンバー | 値 | 説明
None | 0 | なし
Small | 1 | 小型英大文字
All | 2 | すべて大文字
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


TextProperties クラス

文字のオプション
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesTextProperties

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class TextProperties
Public Class TextProperties

TextProperties 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | fill | 文字の塗りつぶし
Public フィールド | font | フォント
Public フィールド | line | 文字の輪郭
Public フィールド | placement | テキストボックス
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


TextProperties フィールド

TextProperties 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | fill | 文字の塗りつぶし
Public フィールド | font | フォント
Public フィールド | line | 文字の輪郭
Public フィールド | placement | テキストボックス
トップ
関連項目

参照

TextProperties クラス
AdvanceSoftware.Charting.Properties 名前空間


TextProperties.fill フィールド

TextPropertiesfill フィールド

文字の塗りつぶし

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Fill fill
Public fill As Fill

フィールド値

型: Fill
関連項目

参照

TextProperties クラス
AdvanceSoftware.Charting.Properties 名前空間


TextProperties.font フィールド

TextPropertiesfont フィールド

フォント

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Font font
Public font As Font

フィールド値

型: Font
関連項目

参照

TextProperties クラス
AdvanceSoftware.Charting.Properties 名前空間


TextProperties.line フィールド

TextPropertiesline フィールド

文字の輪郭

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Line line
Public line As Line

フィールド値

型: Line
関連項目

参照

TextProperties クラス
AdvanceSoftware.Charting.Properties 名前空間


TextProperties.placement フィールド

TextPropertiesplacement フィールド

テキストボックス

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Placement placement
Public placement As Placement

フィールド値

型: Placement
関連項目

参照

TextProperties クラス
AdvanceSoftware.Charting.Properties 名前空間


TextStrikeType 列挙体

取り消し線の種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TextStrikeType
Public Enumeration TextStrikeType
メンバー
メンバー | 値 | 説明
NoStrike | 0 | なし
SingleStrike | 1 | 取り消し線
DoubleStrike | 2 | 二重取り消し線
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


TextUnderlineType 列挙体

下線のスタイル

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TextUnderlineType
Public Enumeration TextUnderlineType
メンバー
メンバー | 値 | 説明
None | 0 | なし
Single | 1 | 一重線
Double | 2 | 二重線
Heavy | 3 | 太線
Dotted | 4 | 点線
HeavyDotted | 5 | 太点線
Dashed | 6 | 破線
HeavyDashed | 7 | 太破線
LongDashed | 8 | 長破線
HeavyLongDashed | 9 | 長太破線
DotDash | 10 | 一点鎖線
HeavyDotDash | 11 | 太一点鎖線
DotDotDash | 12 | 二点鎖線
HeavyDotDotDash | 13 | 太二点鎖線
Wavy | 14 | 波線
HeavyWavy | 15 | 太波線
DoubleWavy | 16 | 二重波線
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


TextVerticalType 列挙体

文字列の方向

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TextVerticalType
Public Enumeration TextVerticalType
メンバー
メンバー | 値 | 説明
Horizontal | 0 | 横書き
Vertical | 1 | 右へ 90 度回転
Vertical270 | 2 | 左へ 90 度回転
EastAsianVertical | 3 | 縦書き
WordArtVerticalRightToLeft | 4 | 縦書き (半角文字含む)
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


TickLabelPosition 列挙体

ラベルの位置

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TickLabelPosition
Public Enumeration TickLabelPosition
メンバー
メンバー | 値 | 説明
High | 0 | 上端/右端
Low | 1 | 下端/左端
NextTo | 2 | 軸の下/左
None | 3 | なし
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


TickMark 列挙体

目盛の種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TickMark
Public Enumeration TickMark
メンバー
メンバー | 値 | 説明
Cross | 0 | 交差
Inside | 1 | 内向き
None | 2 | なし
Outside | 3 | 外向き
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


TimeUnit 列挙体

時間の単位

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TimeUnit
Public Enumeration TimeUnit
メンバー
メンバー | 値 | 説明
Days | 0 | 日
Months | 1 | 月
Years | 2 | 年
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


ValueAxis クラス

値軸
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesAxis
AdvanceSoftware.Charting.PropertiesValueAxis

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class ValueAxis : Axis
Public Class ValueAxis
    Inherits Axis

ValueAxis 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | builtInDisplayUnit | 表示単位 (組み込み)
Public フィールド | customDisplayUnit | 表示単位 (任意)
Public フィールド | logarithmicBase | 対数目盛を表示する (基数)
Public フィールド | majorUnit | 目盛間隔 (目盛)
Public フィールド | maximum | 境界値 (最大値)
Public フィールド | minimum | 境界値 (最小値)
Public フィールド | minorUnit | 目盛間隔 (補助目盛)
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


ValueAxis フィールド

ValueAxis 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | builtInDisplayUnit | 表示単位 (組み込み)
Public フィールド | customDisplayUnit | 表示単位 (任意)
Public フィールド | logarithmicBase | 対数目盛を表示する (基数)
Public フィールド | majorUnit | 目盛間隔 (目盛)
Public フィールド | maximum | 境界値 (最大値)
Public フィールド | minimum | 境界値 (最小値)
Public フィールド | minorUnit | 目盛間隔 (補助目盛)
トップ
関連項目

参照

ValueAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


ValueAxis.builtInDisplayUnit フィールド

ValueAxisbuiltInDisplayUnit フィールド

表示単位 (組み込み)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public BuiltInUnit builtInDisplayUnit
Public builtInDisplayUnit As BuiltInUnit

フィールド値

型: BuiltInUnit
関連項目

参照

ValueAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


ValueAxis.customDisplayUnit フィールド

ValueAxiscustomDisplayUnit フィールド

表示単位 (任意)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double customDisplayUnit
Public customDisplayUnit As Double

フィールド値

型: Double
関連項目

参照

ValueAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


ValueAxis.logarithmicBase フィールド

ValueAxislogarithmicBase フィールド

対数目盛を表示する (基数)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double logarithmicBase
Public logarithmicBase As Double

フィールド値

型: Double
関連項目

参照

ValueAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


ValueAxis.majorUnit フィールド

ValueAxismajorUnit フィールド

目盛間隔 (目盛)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double majorUnit
Public majorUnit As Double

フィールド値

型: Double
関連項目

参照

ValueAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


ValueAxis.maximum フィールド

ValueAxismaximum フィールド

境界値 (最大値)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double maximum
Public maximum As Double

フィールド値

型: Double
関連項目

参照

ValueAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


ValueAxis.minimum フィールド

ValueAxisminimum フィールド

境界値 (最小値)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double minimum
Public minimum As Double

フィールド値

型: Double
関連項目

参照

ValueAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


ValueAxis.minorUnit フィールド

ValueAxisminorUnit フィールド

目盛間隔 (補助目盛)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double minorUnit
Public minorUnit As Double

フィールド値

型: Double
関連項目

参照

ValueAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


AdvanceSoftware.ExcelCreator 名前空間

AdvanceSoftware.ExcelCreator 名前空間には、Creator コンポーネントが含まれています。
クラス
 | クラス | 説明
Public クラス | Cell | Excel ファイルのセルの指定やデータ設定を行います。Creator オブジェクトを通じてこのクラスにアクセスします。
Public クラス | CellAttr | Excel ファイルのセル属性を設定します。Creator オブジェクトを通じてこのクラスにアクセスします。
Public クラス | CellCanvas | CellCanvas クラス
Public クラス | CellPosition | セル位置を扱う CellPosition クラスです。
Public クラス | CellPositionCollection | セル位置を配列で管理する CellPositionCollection クラスです。
Public クラス | Creator | Xls / Xlsx 形式のファイルを作成するコンポーネントです。
Public クラス | CreatorErrorEventArgs | Error イベントのデータを提供します。
Public クラス | Drawing | Excel ファイルにイメージファイルや図形を設定します。Creator オブジェクトを通じてこのクラスにアクセスします。
Public クラス | HtmlOption | HTML 出力のオプションを設定します。Creator オブジェクトを通じてこのクラスにアクセスします。
Public クラス | PdfOption | PDF 出力のオプションを設定します。Creator オブジェクトを通じてこのクラスにアクセスします。
Public クラス | PdfSignature | PDF 出力のオプションを設定します。Creator オブジェクトを通じてこのクラスにアクセスします。
デリゲート
 | デリゲート | 説明
Public デリゲート | CreatorErrorEventHandler | Error イベントを処理するメソッドを表します。
列挙体
 | 列挙体 | 説明
Public 列挙体 | ArrowType | 矢印タイプ、サイズを示す識別子を指定します。
Public 列挙体 | BorderStyle | 線種を示す識別子を指定します。
Public 列挙体 | BoxType | ボックス罫線タイプを示す識別子を指定します。
Public 列挙体 | CellClearMode | セルクリアモードを示す識別子を指定します。
Public 列挙体 | DateFormat | 日付フォーマットを示す識別子を指定します。
Public 列挙体 | DocType | HTML の DOCTYPE を示す識別子を指定します。
Public 列挙体 | EditMode | セルの編集モードを示す識別子を指定します。
Public 列挙体 | ErrorNo | エラーナンバーを示す識別子を指定します。
Public 列挙体 | ExcelFileType | Excel ファイル種別を示す識別子を指定します。
Public 列挙体 | FillType | 塗りつぶしタイプを示す識別子を指定します。
Public 列挙体 | FontStyle | フォントスタイルを示す識別子を指定します。
Public 列挙体 | FontULine | フォント下線を示す識別子を指定します。
Public 列挙体 | HeaderFooterMode | ヘッダー/フッター設定モードを示す識別子を指定します。
Public 列挙体 | HeaderFooterType | ヘッダー/フッター設定タイプを示す識別子を指定します。
Public 列挙体 | HorizontalAlignment | 水平方向の位置を示す識別子を指定します。
Public 列挙体 | HtmlOutputType | HTML の出力タイプを示す識別子を指定します。
Public 列挙体 | ImageType | イメージタイプを示す識別子を指定します。
Public 列挙体 | LineStyle | オートシェイプの線種を示す識別子を指定します。
Public 列挙体 | MaxEndPoint | データや属性の範囲を示す識別子を指定します。
Public 列挙体 | Orientation | 文字の方向を示す識別子を指定します。
Public 列挙体 | PageCenter | ページ中央を示す識別子を指定します。
Public 列挙体 | PageOrder | ページの方向を示す識別子を指定します。
Public 列挙体 | PageOrientation | 用紙方向を示す識別子を指定します。
Public 列挙体 | Pattern | パターンを示す識別子を指定します。
Public 列挙体 | PdfEncryptionType | PDF の暗号化強度を示す識別子を指定します。
Public 列挙体 | PdfPermit | PDF の権限を示す識別子を指定します。
Public 列挙体 | ProgressType | プログレスタイプを示す識別子を指定します。
Public 列挙体 | ScaleMode | スケールモードを示す識別子を指定します。
Public 列挙体 | ShapeType | シェイプタイプを示す識別子を指定します。
Public 列挙体 | StreamMode | データを展開するストリームモードを示す識別子を指定します。
Public 列挙体 | TextAlign | テキストボックスの水平方向の文字位置を示す識別子を指定します。
Public 列挙体 | TextAnchor | テキストボックスの垂直方向の文字位置を示す識別子を指定します。
Public 列挙体 | TextBoxFontStyle | テキストボックスのフォントスタイルを示す識別子を指定します。
Public 列挙体 | TextVertical | テキストボックスの縦書きを示す識別子を指定します。
Public 列挙体 | VarInsertMode | 変数名挿入モードを示す識別子を指定します。
Public 列挙体 | VarNameMode | 変数名キーワードの扱いを示す識別子を指定します。
Public 列挙体 | VerticalAlignment | 垂直方向の位置を示す識別子を指定します。
Public 列挙体 | xlColor | カラーを示す識別子を指定します。
Public 列挙体 | xlsVersion | Excel ファイル(Xls 形式)のバージョンを示す識別子を指定します。
Public 列挙体 | xlsxVersion | Excel ファイル(Xlsx 形式)のバージョンを示す識別子を指定します。


ArrowType 列挙体

矢印タイプ、サイズを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ArrowType
Public Enumeration ArrowType
メンバー
メンバー | 値 | 説明
None | 0 | なし
Triangle | 1 | 三角形
Arrow | 5 | ライン
Stealth | 2 | 鋭角
Diamond | 3 | ひし形
Oval | 4 | 丸
Small | 0 | 小さく
Medium | 16 | 普通
Large | 32 | 大きく
Short | 0 | 短い
Normal | 64 | 普通
Long | 128 | 長い
関連項目

参照

AdvanceSoftware.ExcelCreator 名前空間


BorderStyle 列挙体

線種を示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum BorderStyle
Public Enumeration BorderStyle
メンバー
メンバー | 値 | 説明
None | 0x00000000 | なし
Thin | 0x01000000 | 実線
Medium | 0x02000000 | 太線
Dashed | 0x03000000 | 破線
Dotted | 0x04000000 | 点線
Thick | 0x05000000 | 極太線
Double | 0x06000000 | 二重線
Hair | 0x07000000 | 細実線
MediumDashed | 0x08000000 | 中破線
DashDot | 0x09000000 | 細一点鎖線
MediumDashDot | 0x0A000000 | 中一点鎖線
DashDotDot | 0x0B000000 | 細二点鎖線
MediumDashDotDot | 0x0C000000 | 中二点鎖線
SlantDashDot | 0x0D000000 | 中一点斜鎖線
関連項目

参照


BoxType 列挙体

ボックス罫線タイプを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum BoxType
Public Enumeration BoxType
メンバー
メンバー | 値 | 説明
Box | 0 | 箱線
Ltc | 1 | 格子線
Over | 2 | 上横線
Under | 3 | 下横線
Left | 4 | 左縦線
Right | 5 | 右縦線
関連項目

参照


Cell クラス

Excel ファイルのセルの指定やデータ設定を行います。Creator オブジェクトを通じてこのクラスにアクセスします。
継承階層
SystemObject
AdvanceSoftware.ExcelCreatorCell

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Cell
Public Class Cell

Cell 型は下記のメンバーを公開します。

コンストラクター
 | 名前 | 説明
Public メソッド | Cell | コンストラクター
トップ
プロパティ
 | 名前 | 説明
Public プロパティ | Attr | CellAttr を取得します。
 | AttrNo | 属性番号を設定、取得します。
 | Break | 改ページを設定します。
 | ColWidth | セル幅を設定、取得します。
 | Double | 実数値を設定、取得します。
Public プロパティ | Drawing | Drawing を取得します。
 | FormattedString | 書式を反映した文字列を取得します。
 | FormulaString | 計算式文字列を取得します。
 | Int64 | long 値を設定、取得します。
 | Long | 数値を設定、取得します。
 | RowHeight | 行高を設定、取得します。
 | Str | 文字列を設定、取得します。
 | Value | 値を設定、取得します。
トップ
メソッド
名前 | 説明
Activate | アクティブセルを設定します。
Clear | セルをクリアします。
Clear(CellClearMode) | モードを指定してセルをクリアします。
Copy | セルをコピーします。
Copy(String) | セルをコピーします。
Double2 | 実数値と属性番号を設定します。
Func | 計算式を設定します。
Int642 | long 値と属性番号を設定します。
Long2 | 数値と属性番号を設定します。
Paste | コピーしたセルを貼り付けます。
Str2 | 文字列と属性番号を設定します。
Value2 | 属性番号を指定して値を設定します。
トップ
関連項目

参照


Cell コンストラクター

コンストラクター

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Cell(
    Creator parent
)
Public Sub New (
    parent As Creator
)

パラメーター

parent
型: AdvanceSoftware.ExcelCreatorCreator
AdvanceSoftware.ExcelCreator.Creator を指定します。
関連項目

参照

Cell クラス


Cell プロパティ

Cell 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
Public プロパティ | Attr | CellAttr を取得します。
 | AttrNo | 属性番号を設定、取得します。
 | Break | 改ページを設定します。
 | ColWidth | セル幅を設定、取得します。
 | Double | 実数値を設定、取得します。
Public プロパティ | Drawing | Drawing を取得します。
 | FormattedString | 書式を反映した文字列を取得します。
 | FormulaString | 計算式文字列を取得します。
 | Int64 | long 値を設定、取得します。
 | Long | 数値を設定、取得します。
 | RowHeight | 行高を設定、取得します。
 | Str | 文字列を設定、取得します。
 | Value | 値を設定、取得します。
トップ
関連項目

参照

Cell クラス


Cell.Attr プロパティ

CellAttr プロパティ

CellAttr を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public CellAttr Attr { get; }
Public ReadOnly Property Attr As CellAttr
    Get

プロパティ値

型: CellAttr
セル属性を設定するための CellAttr クラス。
解説
このクラスの全てのメンバの一覧については、CellAttr クラスのメンバを参照してください。
関連項目

参照

Cell クラス


Cell.AttrNo プロパティ

CellAttrNo プロパティ

属性番号を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int AttrNo { get; set; }
Public Property AttrNo As Integer
    Get
    Set

プロパティ値

型: Int32
セルの属性番号。
解説
AttrNo プロパティを使用して、各セルで保持する罫線や表示形式等の書式情報を属性番号として取得します。 取得した属性番号は Value2 メソッドを使用して、データの差し込みと同時に取得した属性番号と 同じ書式情報を設定することができます。
例
C#
VB
コピー
int attrNo;
// A1 セルの属性番号を取得します。
attrNo = creator1.Cell("A1").AttrNo;
// B1 セルに A1 セルから取得した属性番号を指定して "アドバンスソフトウェア" を設定します。
creator1.Cell("B1").Value2("アドバンスソフトウェア", attrNo);
Dim attrNo As Integer
' A1 セルの属性番号を取得します。
attrNo = Creator1.Cell("A1").AttrNo
' B1 セルに A1 セルから取得した属性番号を指定して "アドバンスソフトウェア" を設定します。
Creator1.Cell("B1").Value2("アドバンスソフトウェア", attrNo)
関連項目

参照

Cell クラス


Cell.Break プロパティ

CellBreak プロパティ

改ページを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool Break { set; }
Public WriteOnly Property Break As Boolean
    Set

プロパティ値

型: Boolean
改ページを設定する場合は True。
例
C#
VB
コピー
// 10 行目に改ページを設定します。
creator1.Cell("10").Break = true;
' 10 行目に改ページを設定します。
Creator1.Cell("10").Break = True
関連項目

参照

Cell クラス


Cell.ColWidth プロパティ

CellColWidth プロパティ

セル幅を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double ColWidth { get; set; }
Public Property ColWidth As Double
    Get
    Set

プロパティ値

型: Double
セルの幅(文字数単位)。
解説
列幅を半角文字数 (0 ～ 255 文字) で設定します。0 を設定した場合は非表示列となります。
例
C#
VB
コピー
// A 列の列幅を 20 文字数分に設定します。
creator1.Cell("A").ColWidth = 20.0;
// A 列と同じ列幅を B 列に設定します。
double colWidth = creator1.Cell("A").ColWidth;
creator1.Cell("B").ColWidth = colWidth;
' A 列の列幅を 20 文字数分に設定します。
Creator1.Cell("A").ColWidth = 20.0
' A 列と同じ列幅を B 列に設定します。
Dim colWidth As Double = Creator1.Cell("A").ColWidth
Creator1.Cell("B").ColWidth = colWidth
関連項目

参照

Cell クラス


Cell.Double プロパティ

CellDouble プロパティ

実数値を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double Double { get; set; }
Public Property Double As Double
    Get
    Set

プロパティ値

型: Double
セルの値(実数値)。
例
C#
VB
コピー
// セル A1 に 1.5 を設定します。
creator1.Cell("A1").Double = 1.5;
' セル A1 に 1.5 を設定します。
Creator1.Cell("A1").Double = 1.5
関連項目

参照

Cell クラス


Cell.Drawing プロパティ

CellDrawing プロパティ

Drawing を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Drawing Drawing { get; }
Public ReadOnly Property Drawing As Drawing
    Get

プロパティ値

型: Drawing
Excel ファイルにイメージファイルや図形を設定するための Drawing クラス。
解説
このクラスの全てのメンバの一覧については、Drawing クラスのメンバを参照してください。
関連項目

参照

Cell クラス


Cell.FormattedString プロパティ

CellFormattedString プロパティ

書式を反映した文字列を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string FormattedString { get; }
Public ReadOnly Property FormattedString As String
    Get

プロパティ値

型: String
書式を反映した文字列。
例
C#
VB
コピー
// A1 セルの書式を反映した文字列を取得します。
string formattedString = creator1.Cell("A1").FormattedString;
' A1 セルの書式を反映した文字列を取得します。
Dim formattedString As String = Creator1.Cell("A1").FormattedString
関連項目

参照

Cell クラス


Cell.FormulaString プロパティ

CellFormulaString プロパティ

計算式文字列を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string FormulaString { get; }
Public ReadOnly Property FormulaString As String
    Get

プロパティ値

型: String
計算式文字列。
例
C#
VB
コピー
// A1 セルの計算式文字列を取得します。
string formula = creator1.Cell("A1").FormulaString;
// 取得した計算式文字列を B1 セルに設定します。
creator1.Cell("B1").Func("=" + formula, null);
' A1 セルの計算式文字列を取得します。
Dim formula As String = Creator1.Cell("A1").FormulaString
' 取得した計算式文字列を B1 セルに設定します。
Creator1.Cell("B1").Func("=" & formula, Nothing)
関連項目

参照

Cell クラス


Cell.Int64 プロパティ

CellInt64 プロパティ

long 値を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public long Int64 { get; set; }
Public Property Int64 As Long
    Get
    Set

プロパティ値

型: Int64
セルの値(long 値)。
解説
Xlsx 形式のみ対応しています。
例
C#
VB
コピー
// A1 セルに 100 を設定します。
creator1.Cell("A1").Int64 = 100;
' A1 セルに 100 を設定します。
Creator1.Cell("A1").Int64 = 100
関連項目

参照

Cell クラス


Cell.Long プロパティ

CellLong プロパティ

数値を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int Long { get; set; }
Public Property Long As Integer
    Get
    Set

プロパティ値

型: Int32
セルの値(数値)。
例
C#
VB
コピー
// A1 セルに 100 を設定します。
creator1.Cell("A1").Long = 100;
' A1 セルに 100 を設定します。
Creator1.Cell("A1").Long = 100
関連項目

参照

Cell クラス


Cell.RowHeight プロパティ

CellRowHeight プロパティ

行高を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double RowHeight { get; set; }
Public Property RowHeight As Double
    Get
    Set

プロパティ値

型: Double
セルの高さ(ポイント単位)。
解説
高さをポイント(0 ～ 409 ポイント)で設定します。0 を設定した場合は非表示行となります。
例
C#
VB
コピー
// 1 行目の行高を 21.0 ポイントに設定します。
creator1.Cell("1").RowHeight = 21.0;
// 1 行目と同じ行高を 2 行目に設定します。
double rowHeight = creator1.Cell("1").RowHeight;
creator1.Cell("2").RowHeight = rowHeight;
' 1 行目の行高を 21.0 ポイントに設定します。
Creator1.Cell("1").RowHeight = 21.0
' 1 行目と同じ行高を 2 行目に設定します。
Dim rowHeight As Double = Creator1.Cell("1").RowHeight
Creator1.Cell("2").RowHeight = rowHeight
関連項目

参照

Cell クラス


Cell.Str プロパティ

CellStr プロパティ

文字列を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Str { get; set; }
Public Property Str As String
    Get
    Set

プロパティ値

型: String
セルの値(文字列)。
例
C#
VB
コピー
// A1 セルに文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("A1").Str = "アドバンスソフトウェア";
// B1 セルに文字列 "100" を設定します。
creator1.Cell("B1").Str = "100";
' A1 セルに文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("A1").Str = "アドバンスソフトウェア"
' B1 セルに文字列 "100" を設定します。
Creator1.Cell("B1").Str = "100"
関連項目

参照

Cell クラス


Cell.Value プロパティ

CellValue プロパティ

値を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set

プロパティ値

型: Object
セルの値。
解説
文字列を設定した場合は文字列として値が設定され、数値で設定した場合は数値として設定されます。
例
C#
VB
コピー
// A1 セルに文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("A1").Value = "アドバンスソフトウェア";
// B1 セルに数値 100 を設定します。
creator1.Cell("B1").Value = 100;
' A1 セルに文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("A1").Value = "アドバンスソフトウェア"
' B1 セルに数値 100 を設定します。
Creator1.Cell("B1").Value = 100
関連項目

参照

Cell クラス


Cell メソッド

Cell 型は下記のメンバーを公開します。

メソッド
名前 | 説明
Activate | アクティブセルを設定します。
Clear | セルをクリアします。
Clear(CellClearMode) | モードを指定してセルをクリアします。
Copy | セルをコピーします。
Copy(String) | セルをコピーします。
Double2 | 実数値と属性番号を設定します。
Func | 計算式を設定します。
Int642 | long 値と属性番号を設定します。
Long2 | 数値と属性番号を設定します。
Paste | コピーしたセルを貼り付けます。
Str2 | 文字列と属性番号を設定します。
Value2 | 属性番号を指定して値を設定します。
トップ
関連項目

参照

Cell クラス


Cell.Activate メソッド

CellActivate メソッド

アクティブセルを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Activate()
Public Sub Activate
例
C#
VB
コピー
// A1 をアクティブセルに設定します。
creator1.Cell("A1").Activate();
' A1 をアクティブセルに設定します。
Creator1.Cell("A1").Activate()
関連項目

参照

Cell クラス


Cell.Clear メソッド

CellClear メソッド

オーバーロードの一覧
名前 | 説明
Clear | セルをクリアします。
Clear(CellClearMode) | モードを指定してセルをクリアします。
トップ
関連項目

参照

Cell クラス


Cell.Clear メソッド

CellClear メソッド

セルをクリアします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Clear()
Public Sub Clear
例
C#
VB
コピー
// A1 セルのデータと属性をクリアします。
creator1.Cell("A1").Clear();
' A1 セルのデータと属性をクリアします。
Creator1.Cell("A1").Clear()
関連項目

参照

Cell クラス
Clear オーバーロード


Cell.Clear メソッド (CellClearMode)

CellClear メソッド (CellClearMode)

モードを指定してセルをクリアします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Clear(
    CellClearMode cellClearMode
)
Public Sub Clear (
    cellClearMode As CellClearMode
)

パラメーター

cellClearMode
型: AdvanceSoftware.ExcelCreatorCellClearMode
AdvanceSoftware.ExcelCreator.CellClearMode を指定します。
例
C#
VB
コピー
// A1 セルのデータ、属性をクリアします。
creator1.Cell("A1").Clear(AdvanceSoftware.ExcelCreator.CellClearMode.All);
// A2 セルの属性をクリアします。
creator1.Cell("A2").Clear(AdvanceSoftware.ExcelCreator.CellClearMode.Attr);
// A3 セルのデータをクリアします。
creator1.Cell("A3").Clear(AdvanceSoftware.ExcelCreator.CellClearMode.Value);
' A1 セルのデータ、属性をクリアします。
Creator1.Cell("A1").Clear(AdvanceSoftware.ExcelCreator.CellClearMode.All)
' A2 セルの属性をクリアします。
Creator1.Cell("A2").Clear(AdvanceSoftware.ExcelCreator.CellClearMode.Attr)
' A3 セルのデータをクリアします。
Creator1.Cell("A3").Clear(AdvanceSoftware.ExcelCreator.CellClearMode.Value)
関連項目

参照

Cell クラス
Clear オーバーロード


Cell.Copy メソッド

CellCopy メソッド

オーバーロードの一覧
名前 | 説明
Copy | セルをコピーします。
Copy(String) | セルをコピーします。
トップ
関連項目

参照

Cell クラス


Cell.Copy メソッド

CellCopy メソッド

セルをコピーします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Copy()
Public Sub Copy
解説
引数を省略した場合、セルがメモリ上にコピーされ、Cell.Paste メソッドで設定したセルに貼り付けることができます。
例
C#
VB
コピー
// A1 セルをメモリ上にコピーします。
creator1.Cell("A1").Copy();
// メモリ上にコピーしたセルを B1 セルに貼り付けます。
creator1.Cell("B1").Paste();
' A1 セルをメモリ上にコピーします。
Creator1.Cell("A1").Copy()
' メモリ上にコピーしたセルを B1 セルに貼り付けます。
Creator1.Cell("B1").Paste()
関連項目

参照

Cell クラス
Copy オーバーロード


Cell.Copy メソッド (String)

CellCopy メソッド (String)

セルをコピーします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Copy(
    string cell
)
Public Sub Copy (
    cell As String
)

パラメーター

cell
型: SystemString
コピー先のセル名を A1 形式で指定します。
例
C#
VB
コピー
// A1 セルをコピーして B1 セルに貼り付けます。
creator1.Cell("A1").Copy("B1");
' A1 セルをコピーして B1 セルに貼り付けます。
Creator1.Cell("A1").Copy("B1")
関連項目

参照

Cell クラス
Copy オーバーロード


Cell.Double2 メソッド

CellDouble2 メソッド

実数値と属性番号を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Double2(
    double val,
    int attr
)
Public Sub Double2 (
    val As Double,
    attr As Integer
)

パラメーター

val
型: SystemDouble
セルの値(実数値)。
attr
型: SystemInt32
属性番号
解説
設定する属性番号については、AttrNo プロパティを参照してください。
例
C#
VB
コピー
int attrNo;
// A1 セルの属性番号を取得します。
attrNo = creator1.Cell("A1").AttrNo;
// B1 セルに A1 セルから取得した属性番号を指定して 1.5 を設定します。
creator1.Cell("B1").Double2(1.5, attrNo);
Dim attrNo As Integer
' A1 セルの属性番号を取得します。
attrNo = Creator1.Cell("A1").AttrNo
' B1 セルに A1 セルから取得した属性番号を指定して 1.5 を設定します。
Creator1.Cell("B1").Double2(1.5, attrNo)
関連項目

参照

Cell クラス


Cell.Func メソッド

CellFunc メソッド

計算式を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Func(
    string function,
    Object answer
)
Public Sub Func (
    function As String,
    answer As Object
)

パラメーター

function
型: SystemString
計算式文字列を設定します。
answer
型: SystemObject
計算式の解を設定します。
解説
セルに計算式を設定する場合、このメソッドを使用します。 計算式の解を設定することで、出力ファイルに計算結果を反映させることができます。
例
C#
VB
コピー
creator1.Cell("A1").Value = 100;
creator1.Cell("B1").Value = 200;
// 計算式 "=A1+B1" を C1 セルに設定します。
creator1.Cell("C1").Func("=A1+B1", null);
// 計算式 "=A1+B1" と計算結果 300 を C2 セルに設定します。
creator1.Cell("C2").Func("=A1+B1", 300);
Creator1.Cell("A1").Value = 100
Creator1.Cell("B1").Value = 200
' 計算式 "=A1+B1" を C1 セルに設定します。
Creator1.Cell("C1").Func("=A1+B1", Nothing)
' 計算式 "=A1+B1" と計算結果 300 を C2 セルに設定します。
Creator1.Cell("C2").Func("=A1+B1", 300)
関連項目

参照

Cell クラス


Cell.Int642 メソッド

CellInt642 メソッド

long 値と属性番号を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Int642(
    long val,
    int attr
)
Public Sub Int642 (
    val As Long,
    attr As Integer
)

パラメーター

val
型: SystemInt64
セルの値(long 値)。
attr
型: SystemInt32
属性番号
解説

設定する属性番号については、AttrNo プロパティを参照してください。

Xlsx 形式のみ対応しています。

例
C#
VB
コピー
int attrNo;
// A1 セルの属性番号を取得します。
attrNo = creator1.Cell("A1").AttrNo;
// B1 セルに A1 セルから取得した属性番号を指定して 100 を設定します。
creator1.Cell("B1").Int642(100, attrNo);
Dim attrNo As Integer
' A1 セルの属性番号を取得します。
attrNo = Creator1.Cell("A1").AttrNo
' B1 セルに A1 セルから取得した属性番号を指定して 100 を設定します。
Creator1.Cell("B1").Int642(100, attrNo)
関連項目

参照

Cell クラス


Cell.Long2 メソッド

CellLong2 メソッド

数値と属性番号を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Long2(
    int val,
    int attr
)
Public Sub Long2 (
    val As Integer,
    attr As Integer
)

パラメーター

val
型: SystemInt32
セルの値(数値)。
attr
型: SystemInt32
属性番号
解説
設定する属性番号については、AttrNo プロパティを参照してください。
例
C#
VB
コピー
int attrNo;
// A1 セルの属性番号を取得します。
attrNo = creator1.Cell("A1").AttrNo;
// B1 セルに A1 セルから取得した属性番号を指定して 100 を設定します。
creator1.Cell("B1").Long2(100, attrNo);
Dim attrNo As Integer
' A1 セルの属性番号を取得します。
attrNo = Creator1.Cell("A1").AttrNo
' B1 セルに A1 セルから取得した属性番号を指定して 100 を設定します。
Creator1.Cell("B1").Long2(100, attrNo)
関連項目

参照

Cell クラス


Cell.Paste メソッド

CellPaste メソッド

コピーしたセルを貼り付けます。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Paste()
Public Sub Paste
解説
Copy メソッドでコピーしたセルを貼り付けます。
例
C#
VB
コピー
// A1 セルをメモリ上にコピーします。
creator1.Cell("A1").Copy();
// メモリ上にコピーしたセルを B1 セルに貼り付けます。
creator1.Cell("B1").Paste();
' A1 セルをメモリ上にコピーします。
Creator1.Cell("A1").Copy()
' メモリ上にコピーしたセルを B1 セルに貼り付けます。
Creator1.Cell("B1").Paste()
関連項目

参照

Cell クラス


Cell.Str2 メソッド

CellStr2 メソッド

文字列と属性番号を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Str2(
    string val,
    int attr
)
Public Sub Str2 (
    val As String,
    attr As Integer
)

パラメーター

val
型: SystemString
セルの値(文字列)。
attr
型: SystemInt32
属性番号
解説
設定する属性番号については、AttrNo プロパティを参照してください。
例
C#
VB
コピー
int attrNo;
// A1 セルの属性番号を取得します。
attrNo = creator1.Cell("A1").AttrNo;
// B1 セルに A1 セルから取得した属性番号を指定して "アドバンスソフトウェア" を設定します。
creator1.Cell("B1").Str2("アドバンスソフトウェア", attrNo);
Dim attrNo As Integer
' A1 セルの属性番号を取得します。
attrNo = Creator1.Cell("A1").AttrNo
' B1 セルに A1 セルから取得した属性番号を指定して "アドバンスソフトウェア" を設定します。
Creator1.Cell("B1").Str2("アドバンスソフトウェア", attrNo)
関連項目

参照

Cell クラス


Cell.Value2 メソッド

CellValue2 メソッド

属性番号を指定して値を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Value2(
    Object value,
    int attrNo
)
Public Sub Value2 (
    value As Object,
    attrNo As Integer
)

パラメーター

value
型: SystemObject
値を設定します。
attrNo
型: SystemInt32
属性番号を設定します。
解説
設定する属性番号については、AttrNo プロパティを参照してください。
例
C#
VB
コピー
int attrNo;
// A1 セルの属性番号を取得します。
attrNo = creator1.Cell("A1").AttrNo;
// B1 セルに A1 セルから取得した属性番号を指定して "アドバンスソフトウェア" を設定します。
creator1.Cell("B1").Value2("アドバンスソフトウェア", attrNo);
Dim attrNo As Integer
' A1 セルの属性番号を取得します。
attrNo = Creator1.Cell("A1").AttrNo
' B1 セルに A1 セルから取得した属性番号を指定して "アドバンスソフトウェア" を設定します。
Creator1.Cell("B1").Value2("アドバンスソフトウェア", attrNo)
関連項目

参照

Cell クラス


CellAttr クラス

Excel ファイルのセル属性を設定します。Creator オブジェクトを通じてこのクラスにアクセスします。
継承階層
SystemObject
AdvanceSoftware.ExcelCreatorCellAttr

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class CellAttr
Public Class CellAttr

CellAttr 型は下記のメンバーを公開します。

コンストラクター
 | 名前 | 説明
Public メソッド | CellAttr | コンストラクター
トップ
プロパティ
名前 | 説明
BackColor | 背景色(Color 構造体)を設定、取得します。
BackColor2 | 背景色(xlColor 列挙体)を設定、取得します。
FontColor | フォントカラー(Color 構造体)を設定します。
FontColor2 | フォントカラー(xlColor 列挙体)を設定します。
FontName | フォント名を設定します。
FontPoint | フォントサイズを設定します。
FontStyle | フォントスタイルを設定します。
FontULine | フォント下線を設定します。
ForeColor | 前景色(Color 構造体)を設定します。
ForeColor2 | 前景色(xlColor 列挙体)を設定します。
Format | 表示書式を設定、取得します。
HorizontalAlignment | 文字の配置の横位置を設定します。
Locked | セルのロックを設定、取得します。
MergeCells | セルの結合を設定します。
Orientation | 文字の配置の回転を設定します。
Pattern | パターンを設定します。
ShrinkToFit | 縮小して全体を表示を設定します。
VerticalAlignment | 文字の配置の縦位置を設定します。
WrapText | 折り返して全体を表示を設定します。
トップ
メソッド
名前 | 説明
Box(BoxType, BorderStyle, xlColor) | Box 罫線を設定します。線の色は xlColor 列挙体で指定します。
Box(BoxType, BorderStyle, Color) | Box 罫線を設定します。線の色は Color 構造体で指定します。
LineBottom(BorderStyle, xlColor) | 下罫線を設定します。線の色は xlColor 列挙体で指定します。
LineBottom(BorderStyle, Color) | 下罫線を設定します。線の色は Color 構造体で指定します。
LineLeft(BorderStyle, xlColor) | 左罫線を設定します。線の色は xlColor 列挙体で指定します。
LineLeft(BorderStyle, Color) | 左罫線を設定します。線の色は Color 構造体で指定します。
LineLeftUp(BorderStyle, xlColor) | 左上がり罫線を設定します。線の色は xlColor 列挙体で指定します。
LineLeftUp(BorderStyle, Color) | 左上がり罫線を設定します。線の色は Color 構造体で指定します。
LineRight(BorderStyle, xlColor) | 右罫線を設定します。線の色は xlColor 列挙体で指定します。
LineRight(BorderStyle, Color) | 右罫線を設定します。線の色は Color 構造体で指定します。
LineRightUp(BorderStyle, xlColor) | 右上がり罫線を設定します。線の色は xlColor 列挙体で指定します。
LineRightUp(BorderStyle, Color) | 右上がり罫線を設定します。線の色は Color 構造体で指定します。
LineTop(BorderStyle, xlColor) | 上罫線を設定します。線の色は xlColor 列挙体で指定します。
LineTop(BorderStyle, Color) | 上罫線を設定します。線の色は Color 構造体で指定します。
トップ
関連項目

参照


CellAttr コンストラクター

コンストラクター

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public CellAttr(
    Creator parent
)
Public Sub New (
    parent As Creator
)

パラメーター

parent
型: AdvanceSoftware.ExcelCreatorCreator
AdvanceSoftware.ExcelCreator.Creator を指定します。
関連項目

参照

CellAttr クラス


CellAttr プロパティ

CellAttr 型は下記のメンバーを公開します。

プロパティ
名前 | 説明
BackColor | 背景色(Color 構造体)を設定、取得します。
BackColor2 | 背景色(xlColor 列挙体)を設定、取得します。
FontColor | フォントカラー(Color 構造体)を設定します。
FontColor2 | フォントカラー(xlColor 列挙体)を設定します。
FontName | フォント名を設定します。
FontPoint | フォントサイズを設定します。
FontStyle | フォントスタイルを設定します。
FontULine | フォント下線を設定します。
ForeColor | 前景色(Color 構造体)を設定します。
ForeColor2 | 前景色(xlColor 列挙体)を設定します。
Format | 表示書式を設定、取得します。
HorizontalAlignment | 文字の配置の横位置を設定します。
Locked | セルのロックを設定、取得します。
MergeCells | セルの結合を設定します。
Orientation | 文字の配置の回転を設定します。
Pattern | パターンを設定します。
ShrinkToFit | 縮小して全体を表示を設定します。
VerticalAlignment | 文字の配置の縦位置を設定します。
WrapText | 折り返して全体を表示を設定します。
トップ
関連項目

参照

CellAttr クラス


CellAttr.BackColor プロパティ

CellAttrBackColor プロパティ

背景色(Color 構造体)を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

プロパティ値

型: Color
セルの背景色を表す Color 構造体。
解説
Xlsx 形式のみ対応しています。
例
C#
VB
コピー
// A1 セルに背景色 "赤" を設定します。
creator1.Cell("A1").Attr.BackColor = System.Drawing.Color.Red;
' A1 セルに背景色 "赤" を設定します。
Creator1.Cell("A1").Attr.BackColor = System.Drawing.Color.Red
関連項目

参照

CellAttr クラス


CellAttr.BackColor2 プロパティ

CellAttrBackColor2 プロパティ

背景色(xlColor 列挙体)を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public xlColor BackColor2 { get; set; }
Public Property BackColor2 As xlColor
    Get
    Set

プロパティ値

型: xlColor
セルの背景色を表す xlColor 列挙体。
解説
xlColor 列挙体のメンバを使用してセルの背景色を設定します。
例
C#
VB
コピー
// A1 セルに背景色 "赤" を設定します。
creator1.Cell("A1").Attr.BackColor2 = AdvanceSoftware.ExcelCreator.xlColor.Red;
' A1 セルに背景色 "赤" を設定します。
Creator1.Cell("A1").Attr.BackColor2 = AdvanceSoftware.ExcelCreator.xlColor.Red
関連項目

参照

CellAttr クラス


CellAttr.FontColor プロパティ

CellAttrFontColor プロパティ

フォントカラー(Color 構造体)を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color FontColor { set; }
Public WriteOnly Property FontColor As Color
    Set

プロパティ値

型: Color
セルのフォントカラーを表す Color 構造体。
解説
Xlsx 形式のみ対応しています。
例
C#
VB
コピー
// A1 セルにフォントカラー "赤" を設定します。
creator1.Cell("A1").Attr.FontColor = System.Drawing.Color.Red;
' A1 セルにフォントカラー "赤" を設定します。
Creator1.Cell("A1").Attr.FontColor = System.Drawing.Color.Red
関連項目

参照

CellAttr クラス


CellAttr.FontColor2 プロパティ

CellAttrFontColor2 プロパティ

フォントカラー(xlColor 列挙体)を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public xlColor FontColor2 { set; }
Public WriteOnly Property FontColor2 As xlColor
    Set

プロパティ値

型: xlColor
セルのフォントカラーを表す xlColor 列挙体。
解説
xlColor 列挙体のメンバを使用してセルのフォントカラーを設定します。
例
C#
VB
コピー
// A1 セルにフォントカラー "赤" を設定します。
creator1.Cell("A1").Attr.FontColor2 = AdvanceSoftware.ExcelCreator.xlColor.Red;
' A1 セルにフォントカラー "赤" を設定します。
Creator1.Cell("A1").Attr.FontColor2 = AdvanceSoftware.ExcelCreator.xlColor.Red
関連項目

参照

CellAttr クラス


CellAttr.FontName プロパティ

CellAttrFontName プロパティ

フォント名を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string FontName { set; }
Public WriteOnly Property FontName As String
    Set

プロパティ値

型: String
セルのフォント名。
例
C#
VB
コピー
// A1 セルにフォント名 "ＭＳ 明朝" を設定します。
creator1.Cell("A1").Attr.FontName = "ＭＳ 明朝";
' A1 セルにフォント名 "ＭＳ 明朝" を設定します。
Creator1.Cell("A1").Attr.FontName = "ＭＳ 明朝"
関連項目

参照

CellAttr クラス


CellAttr.FontPoint プロパティ

CellAttrFontPoint プロパティ

フォントサイズを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double FontPoint { set; }
Public WriteOnly Property FontPoint As Double
    Set

プロパティ値

型: Double
フォントサイズ(ポイント単位)。
解説
フォントサイズ(1 ～ 409 ポイント)を設定します。
例
C#
VB
コピー
// A1 セルにフォントサイズ 20.0 ポイントを設定します。
creator1.Cell("A1").Attr.FontPoint = 20.0;
' A1 セルにフォントサイズ 20.0 ポイントを設定します。
Creator1.Cell("A1").Attr.FontPoint = 20.0
関連項目

参照

CellAttr クラス


CellAttr.FontStyle プロパティ

CellAttrFontStyle プロパティ

フォントスタイルを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public FontStyle FontStyle { set; }
Public WriteOnly Property FontStyle As FontStyle
    Set

プロパティ値

型: FontStyle
フォントスタイルを表す FontStyle。
例
C#
VB
コピー
// A1 セルにフォントスタイル "太字" を設定します。
creator1.Cell("A1").Attr.FontStyle = AdvanceSoftware.ExcelCreator.FontStyle.Bold;
' A1 セルにフォントスタイル "太字" を設定します。
Creator1.Cell("A1").Attr.FontStyle = AdvanceSoftware.ExcelCreator.FontStyle.Bold
関連項目

参照

CellAttr クラス


CellAttr.FontULine プロパティ

CellAttrFontULine プロパティ

フォント下線を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public FontULine FontULine { set; }
Public WriteOnly Property FontULine As FontULine
    Set

プロパティ値

型: FontULine
セルのフォントの下線を表す FontULine。
例
C#
VB
コピー
// A1 セルにフォント下線 "標準" を設定します。
creator1.Cell("A1").Attr.FontULine = AdvanceSoftware.ExcelCreator.FontULine.Normal;
' A1 セルにフォント下線 "標準" を設定します。
Creator1.Cell("A1").Attr.FontULine = AdvanceSoftware.ExcelCreator.FontULine.Normal
関連項目

参照

CellAttr クラス


CellAttr.ForeColor プロパティ

CellAttrForeColor プロパティ

前景色(Color 構造体)を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color ForeColor { set; }
Public WriteOnly Property ForeColor As Color
    Set

プロパティ値

型: Color
セルのパターンの前景色を表す Color 構造体。
解説
Xlsx 形式のみ対応しています。
例
C#
VB
コピー
// A1 セルにパターン "横 縞" を設定します。
creator1.Cell("A1").Attr.Pattern = AdvanceSoftware.ExcelCreator.Pattern.DarkHorizontal;
// A1 セルに前景色 "赤" を設定します。
creator1.Cell("A1").Attr.ForeColor = System.Drawing.Color.Red;
' A1 セルにパターン "横 縞" を設定します。
Creator1.Cell("A1").Attr.Pattern = AdvanceSoftware.ExcelCreator.Pattern.DarkHorizontal
' A1 セルに前景色 "赤" を設定します。
Creator1.Cell("A1").Attr.ForeColor = System.Drawing.Color.Red
関連項目

参照

CellAttr クラス


CellAttr.ForeColor2 プロパティ

CellAttrForeColor2 プロパティ

前景色(xlColor 列挙体)を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public xlColor ForeColor2 { set; }
Public WriteOnly Property ForeColor2 As xlColor
    Set

プロパティ値

型: xlColor
セルのパターンの前景色を表す xlColor 列挙体。
解説
xlColor 列挙体のメンバを使用してセルのパターンの前景色を設定します。
例
C#
VB
コピー
// A1 セルにパターン "横 縞" を設定します。
creator1.Cell("A1").Attr.Pattern = AdvanceSoftware.ExcelCreator.Pattern.DarkHorizontal;
// A1 セルに前景色 "赤" を設定します。
creator1.Cell("A1").Attr.ForeColor2 = AdvanceSoftware.ExcelCreator.xlColor.Red;
' A1 セルにパターン "横 縞" を設定します。
Creator1.Cell("A1").Attr.Pattern = AdvanceSoftware.ExcelCreator.Pattern.DarkHorizontal
' A1 セルに前景色 "赤" を設定します。
Creator1.Cell("A1").Attr.ForeColor2 = AdvanceSoftware.ExcelCreator.xlColor.Red
関連項目

参照

CellAttr クラス


CellAttr.Format プロパティ

CellAttrFormat プロパティ

表示書式を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Format { get; set; }
Public Property Format As String
    Get
    Set

プロパティ値

型: String
セルの書式を表す文字列。
解説
以下の記号を使用してセルの表示形式を設定します。
記号 | 説明
# | 有効桁数のみ表示します。(ゼロは表示しません)
0(ゼロ) | 数値の桁数が設定したゼロの数よりも少ない場合、ゼロが余分に表示されます。
? | 数値を小数点位置で揃えたり、分数であらわす場合に除算記号で揃えるように表示します。
,(カンマ) | 1000 単位の区切り記号として表示したり、数値を 1000 で割って四捨五入して表示します。
% | 数値に 100 を掛けてパーセント文字を追加して表示します。
@ | 文字列として表示します。
_(アンダーバー) | 文字幅分の間隔を空けて表示します。
*(アスタリスク) | 設定した文字をセル幅に達するまで繰り返し表示します。* に続けて繰り返し表示する文字を設定します。
[色] | 表示形式で色を設定するのに角カッコ ([]) で色を囲んで設定します。色コードは、書式部分の先頭に設定する必要があります。色には、黒、青、水、緑、紫、赤、白、黄を設定することができます。
yy | (年) 00 ～ 99
yyyy | (年) 1900 ～ 9999
m | (月) 1 ～ 12
mm | (月) 01 ～ 12
mmmm | (月) January ～ December
mmmmm | (月) J ～ D (月の頭文字)
d | (日) 1 ～ 31
dd | (日) 01 ～ 31
ddd | (日) Sun ～ Sat
dddd | (日) Sunday ～ Saturday
h | (時) 0 ～ 23
hh | (時) 00 ～ 23
m | (分) 0 ～ 59
mm | (分) 00 ～ 59
s | (秒) 0 ～ 59
ss | (秒) 00 ～ 59
h AM/PM | (時) 0 ～ 23 AM/PM (AM,PM は時間によりかわる)
h:m:s am/pm | (時) 0 ～ 23: (分) 0～59: (秒) 0～59 am/pm
例
C#
VB
コピー
// A1 セルに表示形式 "yyyy/m/d" を設定します。
creator1.Cell("A1").Attr.Format = "yyyy/m/d";
// A1 セルに日付 "2015/1/1" のシリアル値を設定します。
creator1.Cell("A1").Value = Convert.ToDateTime("2015/1/1").ToOADate();
' A1 セルに表示形式 "yyyy/m/d" を設定します。
Creator1.Cell("A1").Attr.Format = "yyyy/m/d"
' A1 セルに日付 "2015/1/1" のシリアル値を設定します。
Creator1.Cell("A1").Value = Convert.ToDateTime("2015/1/1").ToOADate()
関連項目

参照

CellAttr クラス


CellAttr.HorizontalAlignment プロパティ

CellAttrHorizontalAlignment プロパティ

文字の配置の横位置を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public HorizontalAlignment HorizontalAlignment { set; }
Public WriteOnly Property HorizontalAlignment As HorizontalAlignment
    Set

プロパティ値

型: HorizontalAlignment
セルの文字の横位置を表す HorizontalAlignment。
例
C#
VB
コピー
// A1 セルに横位置 "中央揃え" を設定します。
creator1.Cell("A1").Attr.HorizontalAlignment = AdvanceSoftware.ExcelCreator.HorizontalAlignment.Center;
' A1 セルに横位置 "中央揃え" を設定します。
Creator1.Cell("A1").Attr.HorizontalAlignment = AdvanceSoftware.ExcelCreator.HorizontalAlignment.Center
関連項目

参照

CellAttr クラス


CellAttr.Locked プロパティ

CellAttrLocked プロパティ

セルのロックを設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool Locked { get; set; }
Public Property Locked As Boolean
    Get
    Set

プロパティ値

型: Boolean
セルをロックする場合は True。
例
C#
VB
コピー
// A1 セルのロックを解除します。
creator1.Cell("A1").Attr.Locked = false;
' A1 セルのロックを解除します。
Creator1.Cell("A1").Attr.Locked = False
関連項目

参照

CellAttr クラス


CellAttr.MergeCells プロパティ

CellAttrMergeCells プロパティ

セルの結合を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool MergeCells { set; }
Public WriteOnly Property MergeCells As Boolean
    Set

プロパティ値

型: Boolean
セルを結合する場合は True。
例
C#
VB
コピー
// A1 セルと B1 セルを結合します。
creator1.Cell("A1:B1").Attr.MergeCells = true;
' A1 セルと B1 セルを結合します。
Creator1.Cell("A1:B1").Attr.MergeCells = True
関連項目

参照

CellAttr クラス


CellAttr.Orientation プロパティ

CellAttrOrientation プロパティ

文字の配置の回転を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Orientation Orientation { set; }
Public WriteOnly Property Orientation As Orientation
    Set

プロパティ値

型: Orientation
セルの文字の配置の回転方向を表す Orientation。
例
C#
VB
コピー
// A1 セルに文字方向 "縦書き" を設定します。
creator1.Cell("A1").Attr.Orientation = AdvanceSoftware.ExcelCreator.Orientation.Vert;
' A1 セルに文字方向 "縦書き" を設定します。
Creator1.Cell("A1").Attr.Orientation = AdvanceSoftware.ExcelCreator.Orientation.Vert
関連項目

参照

CellAttr クラス


CellAttr.Pattern プロパティ

CellAttrPattern プロパティ

パターンを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Pattern Pattern { set; }
Public WriteOnly Property Pattern As Pattern
    Set

プロパティ値

型: Pattern
セルのパターンを表す Pattern。
例
C#
VB
コピー
// A1 セルにパターン "横 縞" を設定します。
creator1.Cell("A1").Attr.Pattern = AdvanceSoftware.ExcelCreator.Pattern.DarkHorizontal;
// A1 セルに前景色 "赤" を設定します。
creator1.Cell("A1").Attr.ForeColor = System.Drawing.Color.Red;
' A1 セルにパターン "横 縞" を設定します。
Creator1.Cell("A1").Attr.Pattern = AdvanceSoftware.ExcelCreator.Pattern.DarkHorizontal
' A1 セルに前景色 "赤" を設定します。
Creator1.Cell("A1").Attr.ForeColor = System.Drawing.Color.Red
関連項目

参照

CellAttr クラス


CellAttr.ShrinkToFit プロパティ

CellAttrShrinkToFit プロパティ

縮小して全体を表示を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShrinkToFit { set; }
Public WriteOnly Property ShrinkToFit As Boolean
    Set

プロパティ値

型: Boolean
縮小して全体を表示する場合は True。
例
C#
VB
コピー
// A1 セルに "縮小して全体を表示する" を設定します。
creator1.Cell("A1").Attr.ShrinkToFit = true;
' A1 セルに "縮小して全体を表示する" を設定します。
Creator1.Cell("A1").Attr.ShrinkToFit = True
関連項目

参照

CellAttr クラス


CellAttr.VerticalAlignment プロパティ

CellAttrVerticalAlignment プロパティ

文字の配置の縦位置を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public VerticalAlignment VerticalAlignment { set; }
Public WriteOnly Property VerticalAlignment As VerticalAlignment
    Set

プロパティ値

型: VerticalAlignment
セルの文字の縦位置を表す VerticalAlignment。
例
C#
VB
コピー
// A1 セルに縦位置 "中央揃え" を設定します。
creator1.Cell("A1").Attr.VerticalAlignment = AdvanceSoftware.ExcelCreator.VerticalAlignment.Center;
' A1 セルに縦位置 "中央揃え" を設定します。
Creator1.Cell("A1").Attr.VerticalAlignment = AdvanceSoftware.ExcelCreator.VerticalAlignment.Center
関連項目

参照

CellAttr クラス


CellAttr.WrapText プロパティ

CellAttrWrapText プロパティ

折り返して全体を表示を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool WrapText { set; }
Public WriteOnly Property WrapText As Boolean
    Set

プロパティ値

型: Boolean
折り返して全体を表示する場合は True。
例
C#
VB
コピー
// A1 セルに "折り返して全体を表示する" を設定します。
creator1.Cell("A1").Attr.WrapText = true;
' A1 セルに "折り返して全体を表示する" を設定します。
Creator1.Cell("A1").Attr.WrapText = True
関連項目

参照

CellAttr クラス


CellAttr メソッド

メソッド
名前 | 説明
Box(BoxType, BorderStyle, xlColor) | Box 罫線を設定します。線の色は xlColor 列挙体で指定します。
Box(BoxType, BorderStyle, Color) | Box 罫線を設定します。線の色は Color 構造体で指定します。
LineBottom(BorderStyle, xlColor) | 下罫線を設定します。線の色は xlColor 列挙体で指定します。
LineBottom(BorderStyle, Color) | 下罫線を設定します。線の色は Color 構造体で指定します。
LineLeft(BorderStyle, xlColor) | 左罫線を設定します。線の色は xlColor 列挙体で指定します。
LineLeft(BorderStyle, Color) | 左罫線を設定します。線の色は Color 構造体で指定します。
LineLeftUp(BorderStyle, xlColor) | 左上がり罫線を設定します。線の色は xlColor 列挙体で指定します。
LineLeftUp(BorderStyle, Color) | 左上がり罫線を設定します。線の色は Color 構造体で指定します。
LineRight(BorderStyle, xlColor) | 右罫線を設定します。線の色は xlColor 列挙体で指定します。
LineRight(BorderStyle, Color) | 右罫線を設定します。線の色は Color 構造体で指定します。
LineRightUp(BorderStyle, xlColor) | 右上がり罫線を設定します。線の色は xlColor 列挙体で指定します。
LineRightUp(BorderStyle, Color) | 右上がり罫線を設定します。線の色は Color 構造体で指定します。
LineTop(BorderStyle, xlColor) | 上罫線を設定します。線の色は xlColor 列挙体で指定します。
LineTop(BorderStyle, Color) | 上罫線を設定します。線の色は Color 構造体で指定します。
トップ
関連項目

参照

CellAttr クラス


CellAttr.Box メソッド

CellAttrBox メソッド

オーバーロードの一覧
名前 | 説明
Box(BoxType, BorderStyle, xlColor) | Box 罫線を設定します。線の色は xlColor 列挙体で指定します。
Box(BoxType, BorderStyle, Color) | Box 罫線を設定します。線の色は Color 構造体で指定します。
トップ
関連項目

参照

CellAttr クラス


CellAttr.Box メソッド (BoxType, BorderStyle, xlColor)

CellAttrBox メソッド (BoxType, BorderStyle, xlColor)

Box 罫線を設定します。線の色は xlColor 列挙体で指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Box(
    BoxType boxType,
    BorderStyle borderStyle,
    xlColor borderColor
)
Public Sub Box (
    boxType As BoxType,
    borderStyle As BorderStyle,
    borderColor As xlColor
)

パラメーター

boxType
型: AdvanceSoftware.ExcelCreatorBoxType
Box タイプを設定します。
borderStyle
型: AdvanceSoftware.ExcelCreatorBorderStyle
線種を設定します。
borderColor
型: AdvanceSoftware.ExcelCreatorxlColor
線の色を設定します。
例
C#
VB
コピー
// A1:E5 セルに "Box 罫線 (Box タイプ：格子線、線種：実線、線色：黒)" を設定します。
creator1.Cell("A1:E5").Attr.Box(AdvanceSoftware.ExcelCreator.BoxType.Ltc, AdvanceSoftware.ExcelCreator.BorderStyle.Thin, AdvanceSoftware.ExcelCreator.xlColor.Black);
' A1:E5 セルに "Box 罫線 (Box タイプ：格子線、線種：実線、線色：黒)" を設定します。
Creator1.Cell("A1:E5").Attr.Box(AdvanceSoftware.ExcelCreator.BoxType.Ltc, AdvanceSoftware.ExcelCreator.BorderStyle.Thin, AdvanceSoftware.ExcelCreator.xlColor.Black)
関連項目

参照

CellAttr クラス
Box オーバーロード


CellAttr.Box メソッド (BoxType, BorderStyle, Color)

CellAttrBox メソッド (BoxType, BorderStyle, Color)

Box 罫線を設定します。線の色は Color 構造体で指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Box(
    BoxType boxType,
    BorderStyle borderStyle,
    Color borderColor
)
Public Sub Box (
    boxType As BoxType,
    borderStyle As BorderStyle,
    borderColor As Color
)

パラメーター

boxType
型: AdvanceSoftware.ExcelCreatorBoxType
Box タイプを設定します。
borderStyle
型: AdvanceSoftware.ExcelCreatorBorderStyle
線種を設定します。
borderColor
型: System.DrawingColor
線の色を設定します。
解説
Xlsx 形式のみ対応しています。
例
C#
VB
コピー
// A1:E5 セルに Box 罫線（Box タイプ：格子線、線種：実線、線色：黒）を設定します。
creator1.Cell("A1:E5").Attr.Box(AdvanceSoftware.ExcelCreator.BoxType.Ltc, AdvanceSoftware.ExcelCreator.BorderStyle.Thin, System.Drawing.Color.Black);
' A1:E5 セルに Box 罫線（Box タイプ：格子線、線種：実線、線色：黒）を設定します。
Creator1.Cell("A1:E5").Attr.Box(AdvanceSoftware.ExcelCreator.BoxType.Ltc, AdvanceSoftware.ExcelCreator.BorderStyle.Thin, System.Drawing.Color.Black)
関連項目

参照

CellAttr クラス
Box オーバーロード


CellAttr.LineBottom メソッド

CellAttrLineBottom メソッド

オーバーロードの一覧
名前 | 説明
LineBottom(BorderStyle, xlColor) | 下罫線を設定します。線の色は xlColor 列挙体で指定します。
LineBottom(BorderStyle, Color) | 下罫線を設定します。線の色は Color 構造体で指定します。
トップ
関連項目

参照

CellAttr クラス


CellAttr.LineBottom メソッド (BorderStyle, xlColor)

CellAttrLineBottom メソッド (BorderStyle, xlColor)

下罫線を設定します。線の色は xlColor 列挙体で指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineBottom(
    BorderStyle borderStyle,
    xlColor borderColor
)
Public Sub LineBottom (
    borderStyle As BorderStyle,
    borderColor As xlColor
)

パラメーター

borderStyle
型: AdvanceSoftware.ExcelCreatorBorderStyle
線種を設定します。
borderColor
型: AdvanceSoftware.ExcelCreatorxlColor
線の色を設定します。
例
C#
VB
コピー
// A1:E5 セルに "下罫線 (線種：実線、線色：黒)" を設定します。
creator1.Cell("A1:E5").Attr.LineBottom(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, AdvanceSoftware.ExcelCreator.xlColor.Black);
' A1:E5 セルに "下罫線 (線種：実線、線色：黒)" を設定します。
Creator1.Cell("A1:E5").Attr.LineBottom(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, AdvanceSoftware.ExcelCreator.xlColor.Black)
関連項目

参照

CellAttr クラス
LineBottom オーバーロード


CellAttr.LineBottom メソッド (BorderStyle, Color)

CellAttrLineBottom メソッド (BorderStyle, Color)

下罫線を設定します。線の色は Color 構造体で指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineBottom(
    BorderStyle borderStyle,
    Color borderColor
)
Public Sub LineBottom (
    borderStyle As BorderStyle,
    borderColor As Color
)

パラメーター

borderStyle
型: AdvanceSoftware.ExcelCreatorBorderStyle
線種を設定します。
borderColor
型: System.DrawingColor
線の色を設定します。
解説
Xlsx 形式のみ対応しています。
例
C#
VB
コピー
// A1:E5 セルに "下罫線 (線種：実線、線色：黒)" を設定します。
creator1.Cell("A1:E5").Attr.LineBottom(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, System.Drawing.Color.Black);
' A1:E5 セルに "下罫線 (線種：実線、線色：黒)" を設定します。
Creator1.Cell("A1:E5").Attr.LineBottom(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, System.Drawing.Color.Black)
関連項目

参照

CellAttr クラス
LineBottom オーバーロード


CellAttr.LineLeft メソッド

CellAttrLineLeft メソッド

オーバーロードの一覧
名前 | 説明
LineLeft(BorderStyle, xlColor) | 左罫線を設定します。線の色は xlColor 列挙体で指定します。
LineLeft(BorderStyle, Color) | 左罫線を設定します。線の色は Color 構造体で指定します。
トップ
関連項目

参照

CellAttr クラス


CellAttr.LineLeft メソッド (BorderStyle, xlColor)

CellAttrLineLeft メソッド (BorderStyle, xlColor)

左罫線を設定します。線の色は xlColor 列挙体で指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineLeft(
    BorderStyle borderStyle,
    xlColor borderColor
)
Public Sub LineLeft (
    borderStyle As BorderStyle,
    borderColor As xlColor
)

パラメーター

borderStyle
型: AdvanceSoftware.ExcelCreatorBorderStyle
線種を設定します。
borderColor
型: AdvanceSoftware.ExcelCreatorxlColor
線の色を設定します。
例
C#
VB
コピー
// A1:E5 セルに "左罫線 (線種：実線、線色：黒)" を設定します。
creator1.Cell("A1:E5").Attr.LineLeft(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, AdvanceSoftware.ExcelCreator.xlColor.Black);
' A1:E5 セルに "左罫線 (線種：実線、線色：黒)" を設定します。
Creator1.Cell("A1:E5").Attr.LineLeft(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, AdvanceSoftware.ExcelCreator.xlColor.Black)
関連項目

参照

CellAttr クラス
LineLeft オーバーロード


CellAttr.LineLeft メソッド (BorderStyle, Color)

CellAttrLineLeft メソッド (BorderStyle, Color)

左罫線を設定します。線の色は Color 構造体で指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineLeft(
    BorderStyle borderStyle,
    Color borderColor
)
Public Sub LineLeft (
    borderStyle As BorderStyle,
    borderColor As Color
)

パラメーター

borderStyle
型: AdvanceSoftware.ExcelCreatorBorderStyle
線種を設定します。
borderColor
型: System.DrawingColor
線の色を設定します。
解説
Xlsx 形式のみ対応しています。
例
C#
VB
コピー
// A1:E5 セルに "左罫線 (線種：実線、線色：黒)" を設定します。
creator1.Cell("A1:E5").Attr.LineLeft(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, System.Drawing.Color.Black);
' A1:E5 セルに "左罫線 (線種：実線、線色：黒)" を設定します。
Creator1.Cell("A1:E5").Attr.LineLeft(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, System.Drawing.Color.Black)
関連項目

参照

CellAttr クラス
LineLeft オーバーロード


CellAttr.LineLeftUp メソッド

CellAttrLineLeftUp メソッド

オーバーロードの一覧
名前 | 説明
LineLeftUp(BorderStyle, xlColor) | 左上がり罫線を設定します。線の色は xlColor 列挙体で指定します。
LineLeftUp(BorderStyle, Color) | 左上がり罫線を設定します。線の色は Color 構造体で指定します。
トップ
関連項目

参照

CellAttr クラス


CellAttr.LineLeftUp メソッド (BorderStyle, xlColor)

CellAttrLineLeftUp メソッド (BorderStyle, xlColor)

左上がり罫線を設定します。線の色は xlColor 列挙体で指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineLeftUp(
    BorderStyle borderStyle,
    xlColor borderColor
)
Public Sub LineLeftUp (
    borderStyle As BorderStyle,
    borderColor As xlColor
)

パラメーター

borderStyle
型: AdvanceSoftware.ExcelCreatorBorderStyle
線種を設定します。
borderColor
型: AdvanceSoftware.ExcelCreatorxlColor
線の色を設定します。
例
C#
VB
コピー
// A1:E5 セルに "左上がり罫線 (線種：実線、線色：黒)" を設定します。
creator1.Cell("A1:E5").Attr.LineLeftUp(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, AdvanceSoftware.ExcelCreator.xlColor.Black);
' A1:E5 セルに "左上がり罫線 (線種：実線、線色：黒)" を設定します。
Creator1.Cell("A1:E5").Attr.LineLeftUp(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, AdvanceSoftware.ExcelCreator.xlColor.Black)
関連項目

参照

CellAttr クラス
LineLeftUp オーバーロード


CellAttr.LineLeftUp メソッド (BorderStyle, Color)

CellAttrLineLeftUp メソッド (BorderStyle, Color)

左上がり罫線を設定します。線の色は Color 構造体で指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineLeftUp(
    BorderStyle borderStyle,
    Color borderColor
)
Public Sub LineLeftUp (
    borderStyle As BorderStyle,
    borderColor As Color
)

パラメーター

borderStyle
型: AdvanceSoftware.ExcelCreatorBorderStyle
線種を設定します。
borderColor
型: System.DrawingColor
線の色を設定します。
解説
Xlsx 形式のみ対応しています。
例
C#
VB
コピー
// A1:E5 セルに "左上がり罫線 (線種：実線、線色：黒)" を設定します。
creator1.Cell("A1:E5").Attr.LineLeftUp(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, System.Drawing.Color.Black);
' A1:E5 セルに "左上がり罫線 (線種：実線、線色：黒)" を設定します。
Creator1.Cell("A1:E5").Attr.LineLeftUp(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, System.Drawing.Color.Black)
関連項目

参照

CellAttr クラス
LineLeftUp オーバーロード


CellAttr.LineRight メソッド

CellAttrLineRight メソッド

オーバーロードの一覧
名前 | 説明
LineRight(BorderStyle, xlColor) | 右罫線を設定します。線の色は xlColor 列挙体で指定します。
LineRight(BorderStyle, Color) | 右罫線を設定します。線の色は Color 構造体で指定します。
トップ
関連項目

参照

CellAttr クラス


CellAttr.LineRight メソッド (BorderStyle, xlColor)

CellAttrLineRight メソッド (BorderStyle, xlColor)

右罫線を設定します。線の色は xlColor 列挙体で指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineRight(
    BorderStyle borderStyle,
    xlColor borderColor
)
Public Sub LineRight (
    borderStyle As BorderStyle,
    borderColor As xlColor
)

パラメーター

borderStyle
型: AdvanceSoftware.ExcelCreatorBorderStyle
線種を設定します。
borderColor
型: AdvanceSoftware.ExcelCreatorxlColor
線の色を設定します。
例
C#
VB
コピー
// A1:E5 セルに "右罫線 (線種：実線、線色：黒)" を設定します。
creator1.Cell("A1:E5").Attr.LineRight(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, AdvanceSoftware.ExcelCreator.xlColor.Black);
' A1:E5 セルに "右罫線 (線種：実線、線色：黒)" を設定します。
Creator1.Cell("A1:E5").Attr.LineRight(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, AdvanceSoftware.ExcelCreator.xlColor.Black)
関連項目

参照

CellAttr クラス
LineRight オーバーロード


CellAttr.LineRight メソッド (BorderStyle, Color)

CellAttrLineRight メソッド (BorderStyle, Color)

右罫線を設定します。線の色は Color 構造体で指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineRight(
    BorderStyle borderStyle,
    Color borderColor
)
Public Sub LineRight (
    borderStyle As BorderStyle,
    borderColor As Color
)

パラメーター

borderStyle
型: AdvanceSoftware.ExcelCreatorBorderStyle
線種を設定します。
borderColor
型: System.DrawingColor
線の色を設定します。
解説
Xlsx 形式のみ対応しています。
例
C#
VB
コピー
// A1:E5 セルに "右罫線 (線種：実線、線色：黒)" を設定します。
creator1.Cell("A1:E5").Attr.LineRight(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, System.Drawing.Color.Black);
' A1:E5 セルに "右罫線 (線種：実線、線色：黒)"を設定します。
Creator1.Cell("A1:E5").Attr.LineRight(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, System.Drawing.Color.Black)
関連項目

参照

CellAttr クラス
LineRight オーバーロード


CellAttr.LineRightUp メソッド

CellAttrLineRightUp メソッド

オーバーロードの一覧
名前 | 説明
LineRightUp(BorderStyle, xlColor) | 右上がり罫線を設定します。線の色は xlColor 列挙体で指定します。
LineRightUp(BorderStyle, Color) | 右上がり罫線を設定します。線の色は Color 構造体で指定します。
トップ
関連項目

参照

CellAttr クラス


CellAttr.LineRightUp メソッド (BorderStyle, xlColor)

CellAttrLineRightUp メソッド (BorderStyle, xlColor)

右上がり罫線を設定します。線の色は xlColor 列挙体で指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineRightUp(
    BorderStyle borderStyle,
    xlColor borderColor
)
Public Sub LineRightUp (
    borderStyle As BorderStyle,
    borderColor As xlColor
)

パラメーター

borderStyle
型: AdvanceSoftware.ExcelCreatorBorderStyle
線種を設定します。
borderColor
型: AdvanceSoftware.ExcelCreatorxlColor
線の色を設定します。
例
C#
VB
コピー
// A1:E5 セルに "右上がり罫線 (線種：実線、線色：黒)" を設定します。
creator1.Cell("A1:E5").Attr.LineRightUp(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, AdvanceSoftware.ExcelCreator.xlColor.Black);
' A1:E5 セルに "右上がり罫線 (線種：実線、線色：黒)" を設定します。
Creator1.Cell("A1:E5").Attr.LineRightUp(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, AdvanceSoftware.ExcelCreator.xlColor.Black)
関連項目

参照

CellAttr クラス
LineRightUp オーバーロード


CellAttr.LineRightUp メソッド (BorderStyle, Color)

CellAttrLineRightUp メソッド (BorderStyle, Color)

右上がり罫線を設定します。線の色は Color 構造体で指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineRightUp(
    BorderStyle borderStyle,
    Color borderColor
)
Public Sub LineRightUp (
    borderStyle As BorderStyle,
    borderColor As Color
)

パラメーター

borderStyle
型: AdvanceSoftware.ExcelCreatorBorderStyle
線種を設定します。
borderColor
型: System.DrawingColor
線の色を設定します。
解説
Xlsx 形式のみ対応しています。
例
C#
VB
コピー
// A1:E5 セルに "右上がり罫線 (線種：実線、線色：黒)" を設定します。
creator1.Cell("A1:E5").Attr.LineRightUp(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, System.Drawing.Color.Black);
' A1:E5 セルに "右上がり罫線 (線種：実線、線色：黒)" を設定します。
Creator1.Cell("A1:E5").Attr.LineRightUp(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, System.Drawing.Color.Black)
関連項目

参照

CellAttr クラス
LineRightUp オーバーロード


CellAttr.LineTop メソッド

CellAttrLineTop メソッド

オーバーロードの一覧
名前 | 説明
LineTop(BorderStyle, xlColor) | 上罫線を設定します。線の色は xlColor 列挙体で指定します。
LineTop(BorderStyle, Color) | 上罫線を設定します。線の色は Color 構造体で指定します。
トップ
関連項目

参照

CellAttr クラス


CellAttr.LineTop メソッド (BorderStyle, xlColor)

CellAttrLineTop メソッド (BorderStyle, xlColor)

上罫線を設定します。線の色は xlColor 列挙体で指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineTop(
    BorderStyle borderStyle,
    xlColor borderColor
)
Public Sub LineTop (
    borderStyle As BorderStyle,
    borderColor As xlColor
)

パラメーター

borderStyle
型: AdvanceSoftware.ExcelCreatorBorderStyle
線種を設定します。
borderColor
型: AdvanceSoftware.ExcelCreatorxlColor
線の色を設定します。
例
C#
VB
コピー
// A1:E5 セルに "上罫線 (線種：実線、線色：黒)" を設定します。
creator1.Cell("A1:E5").Attr.LineTop(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, AdvanceSoftware.ExcelCreator.xlColor.Black);
' A1:E5 セルに "上罫線 (線種：実線、線色：黒)" を設定します。
Creator1.Cell("A1:E5").Attr.LineTop(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, AdvanceSoftware.ExcelCreator.xlColor.Black)
関連項目

参照

CellAttr クラス
LineTop オーバーロード


CellAttr.LineTop メソッド (BorderStyle, Color)

CellAttrLineTop メソッド (BorderStyle, Color)

上罫線を設定します。線の色は Color 構造体で指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineTop(
    BorderStyle borderStyle,
    Color borderColor
)
Public Sub LineTop (
    borderStyle As BorderStyle,
    borderColor As Color
)

パラメーター

borderStyle
型: AdvanceSoftware.ExcelCreatorBorderStyle
線種を設定します。
borderColor
型: System.DrawingColor
線の色を設定します。
解説
Xlsx 形式のみ対応しています。
例
C#
VB
コピー
// A1:E5 セルに "上罫線 (線種：実線、線色：黒)" を設定します。
creator1.Cell("A1:E5").Attr.LineTop(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, System.Drawing.Color.Black);
' A1:E5 セルに "上罫線 (線種：実線、線色：黒)" を設定します。
Creator1.Cell("A1:E5").Attr.LineTop(AdvanceSoftware.ExcelCreator.BorderStyle.Thin, System.Drawing.Color.Black)
関連項目

参照

CellAttr クラス
LineTop オーバーロード


CellCanvas クラス

CellCanvas クラス
継承階層
SystemObject
AdvanceSoftware.ExcelCreatorCellCanvas

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class CellCanvas
Public Class CellCanvas

CellCanvas 型は下記のメンバーを公開します。

コンストラクター
 | 名前 | 説明
Public メソッド | CellCanvas | コンストラクター
トップ
メソッド
名前 | 説明
AddChart | グラフを設定します。
AddImage(Image) | イメージを設定します。
AddImage(String) | イメージを設定します。
AddImage(Image, Double, Double) | イメージを設定します。
AddImage(String, Double, Double) | イメージを設定します。
AddImage(Image, Double, Double, Double, Double) | イメージを設定します。
AddImage(String, Double, Double, Double, Double) | イメージを設定します。
トップ
関連項目

参照


CellCanvas コンストラクター

コンストラクター

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public CellCanvas(
    Creator parent
)
Public Sub New (
    parent As Creator
)

パラメーター

parent
型: AdvanceSoftware.ExcelCreatorCreator
AdvanceSoftware.ExcelCreator.Creator を指定します。
関連項目

参照

CellCanvas クラス


CellCanvas メソッド

CellCanvas 型は下記のメンバーを公開します。

メソッド
名前 | 説明
AddChart | グラフを設定します。
AddImage(Image) | イメージを設定します。
AddImage(String) | イメージを設定します。
AddImage(Image, Double, Double) | イメージを設定します。
AddImage(String, Double, Double) | イメージを設定します。
AddImage(Image, Double, Double, Double, Double) | イメージを設定します。
AddImage(String, Double, Double, Double, Double) | イメージを設定します。
トップ
関連項目

参照

CellCanvas クラス


CellCanvas.AddChart メソッド

CellCanvasAddChart メソッド

グラフを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddChart(
    Image image,
    ChartData chartData
)
Public Sub AddChart (
    image As Image,
    chartData As ChartData
)

パラメーター

image
型: System.DrawingImage
イメージクラスを設定します。
chartData
型: AdvanceSoftware.Charting.PropertiesChartData
追加するグラフ情報を設定します。
例
C#
VB
コピー
// グラフの数を取得
int chartCount = creator1.GetChartCount();
for (int i = 0; i < chartCount; i++)
{
    // グラフ情報を取得
    ChartData chartData = creator1.GetChartData(i, 330);
    // ChartData からの Image オブジェクト生成処理は
    // 独自に実装する必要があります。
    // 画像は PDF ファイルにのみ反映されます。
    Image chartImage = ChartCreator.GetChartImage(chartData);
    creator1.Pos(chartData.col, chartData.row).Canvas.AddChart(chartImage, chartData);
}
' グラフの数を取得
Dim chartCount = Creator1.GetChartCount()
For i = 0 To chartCount - 1
    ' グラフ情報を取得
    Dim chartData = Creator1.GetChartData(i, 330)
    ' ChartData からの Image オブジェクト生成処理は
    ' 独自に実装する必要があります。
    ' 画像は PDF ファイルにのみ反映されます。
    Dim chartImage As Image = ChartCreator.GetChartImage(chartData)
    Creator1.Pos(chartData.col, chartData.row).Canvas.AddChart(chartImage, chartData)
Next
関連項目

参照

CellCanvas クラス


CellCanvas.AddImage メソッド

CellCanvasAddImage メソッド

オーバーロードの一覧
名前 | 説明
AddImage(Image) | イメージを設定します。
AddImage(String) | イメージを設定します。
AddImage(Image, Double, Double) | イメージを設定します。
AddImage(String, Double, Double) | イメージを設定します。
AddImage(Image, Double, Double, Double, Double) | イメージを設定します。
AddImage(String, Double, Double, Double, Double) | イメージを設定します。
トップ
関連項目

参照

CellCanvas クラス


CellCanvas.AddImage メソッド (Image)

CellCanvasAddImage メソッド (Image)

イメージを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    Image image
)
Public Sub AddImage (
    image As Image
)

パラメーター

image
型: System.DrawingImage
イメージクラスを設定します。
例
C#
VB
コピー
System.Drawing.Image image = System.Drawing.Image.FromFile(@"C:\image.bmp");
// A1 セルに画像を設定します。
// 画像は PDF ファイルにのみ反映されます。
creator1.Cell("A1").Canvas.AddImage(image);
Dim image As System.Drawing.Image = System.Drawing.Image.FromFile("C:\image.bmp")
' A1 セルに画像を設定します。
' 画像は PDF ファイルにのみ反映されます。
Creator1.Cell("A1").Canvas.AddImage(image)
関連項目

参照

CellCanvas クラス
AddImage オーバーロード


CellCanvas.AddImage メソッド (String)

CellCanvasAddImage メソッド (String)

イメージを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    string fileName
)
Public Sub AddImage (
    fileName As String
)

パラメーター

fileName
型: SystemString
イメージのファイル名を設定します。
例
C#
VB
コピー
// A1 セルに画像を設定します。
// 画像は PDF ファイルにのみ反映されます。
creator1.Cell("A1").Canvas.AddImage(@"C:\image.bmp");
' A1 セルに画像を設定します。
' 画像は PDF ファイルにのみ反映されます。
Creator1.Cell("A1").Canvas.AddImage("C:\image.bmp")
関連項目

参照

CellCanvas クラス
AddImage オーバーロード


CellCanvas.AddImage メソッド (Image, Double, Double)

CellCanvasAddImage メソッド (Image, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    Image image,
    double offsetX,
    double offsetY
)
Public Sub AddImage (
    image As Image,
    offsetX As Double,
    offsetY As Double
)

パラメーター

image
型: System.DrawingImage
イメージクラスを設定します。
offsetX
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
offsetY
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
creator1.ScaleMode = ScaleMode.Pixel;
System.Drawing.Image image = System.Drawing.Image.FromFile(@"C:\image.bmp");
// A1 セルを基点とし、開始オフセット (100px,100px) の位置から画像を設定します。
// 画像は PDF ファイルにのみ反映されます。
creator1.Cell("A1").Canvas.AddImage(image, 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
Creator1.ScaleMode = ScaleMode.Pixel
Dim image As System.Drawing.Image = System.Drawing.Image.FromFile("C:\image.bmp")
' A1 セルを基点とし、開始オフセット (100px,100px) の位置から画像を設定します。
' 画像は PDF ファイルにのみ反映されます。
Creator1.Cell("A1").Canvas.AddImage(image, 100, 100)
関連項目

参照

CellCanvas クラス
AddImage オーバーロード


CellCanvas.AddImage メソッド (String, Double, Double)

CellCanvasAddImage メソッド (String, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    string fileName,
    double offsetX,
    double offsetY
)
Public Sub AddImage (
    fileName As String,
    offsetX As Double,
    offsetY As Double
)

パラメーター

fileName
型: SystemString
イメージのファイル名を設定します。
offsetX
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
offsetY
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
creator1.ScaleMode = ScaleMode.Pixel;
// A1 セルを基点とし、開始オフセット (100px,100px) の位置から画像を設定します。
// 画像は PDF ファイルにのみ反映されます。
creator1.Cell("A1").Canvas.AddImage(@"C:\image.bmp", 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
Creator1.ScaleMode = ScaleMode.Pixel
' A1 セルを基点とし、開始オフセット (100px,100px) の位置から画像を設定します。
' 画像は PDF ファイルにのみ反映されます。
Creator1.Cell("A1").Canvas.AddImage("C:\image.bmp", 100, 100)
関連項目

参照

CellCanvas クラス
AddImage オーバーロード


CellCanvas.AddImage メソッド (Image, Double, Double, Double, Double)

CellCanvasAddImage メソッド (Image, Double, Double, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    Image image,
    double offsetX,
    double offsetY,
    double width,
    double height
)
Public Sub AddImage (
    image As Image,
    offsetX As Double,
    offsetY As Double,
    width As Double,
    height As Double
)

パラメーター

image
型: System.DrawingImage
イメージクラスを設定します。
offsetX
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
offsetY
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
width
型: SystemDouble
イメージの幅を設定します。
height
型: SystemDouble
イメージの高さを設定します。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
creator1.ScaleMode = ScaleMode.Pixel;
System.Drawing.Image image = System.Drawing.Image.FromFile(@"C:\image.bmp");
// A1 セルを基点とし、開始オフセット (50px,50px) の位置から画像 (幅：150px, 高さ：150px)
// を設定します。
// 画像は PDF ファイルにのみ反映されます。
creator1.Cell("A1").Canvas.AddImage(image, 50, 50, 150, 150);
' スケールモードを "ピクセル(px)" に設定します。
Creator1.ScaleMode = ScaleMode.Pixel
Dim image As System.Drawing.Image = System.Drawing.Image.FromFile("C:\image.bmp")
' A1 セルを基点とし、開始オフセット (50px,50px) の位置から画像 (幅：150px, 高さ：150px)
' を設定します。
' 画像は PDF ファイルにのみ反映されます。
Creator1.Cell("A1").Canvas.AddImage(image, 50, 50, 150, 150)
関連項目

参照

CellCanvas クラス
AddImage オーバーロード


CellCanvas.AddImage メソッド (String, Double, Double, Double, Double)

CellCanvasAddImage メソッド (String, Double, Double, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    string fileName,
    double offsetX,
    double offsetY,
    double width,
    double height
)
Public Sub AddImage (
    fileName As String,
    offsetX As Double,
    offsetY As Double,
    width As Double,
    height As Double
)

パラメーター

fileName
型: SystemString
イメージのファイル名を設定します。
offsetX
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
offsetY
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
width
型: SystemDouble
イメージの幅を設定します。
height
型: SystemDouble
イメージの高さを設定します。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
creator1.ScaleMode = ScaleMode.Pixel;
// A1 セルを基点とし、開始オフセット (50px,50px) の位置から画像 (幅：150px, 高さ：150px)
// を設定します。
// 画像は PDF ファイルにのみ反映されます。
creator1.Cell("A1").Canvas.AddImage(@"C:\image.bmp", 50, 50, 150, 150);
' スケールモードを "ピクセル(px)" に設定します。
Creator1.ScaleMode = ScaleMode.Pixel
' A1 セルを基点とし、開始オフセット (50px,50px) の位置から画像 (幅：150px, 高さ：150px)
' を設定します。
' 画像は PDF ファイルにのみ反映されます。
Creator1.Cell("A1").Canvas.AddImage("C:\image.bmp", 50, 50, 150, 150)
関連項目

参照

CellCanvas クラス
AddImage オーバーロード


CellClearMode 列挙体

セルクリアモードを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum CellClearMode
Public Enumeration CellClearMode
メンバー
メンバー | 値 | 説明
All | 0 | 値と属性をクリアします。
Value | 1 | 値のみをクリアします。
Attr | 2 | 属性のみをクリアします。
関連項目

参照


CellPosition クラス

セル位置を扱う CellPosition クラスです。
継承階層
SystemObject
AdvanceSoftware.ExcelCreatorCellPosition

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class CellPosition
Public Class CellPosition

CellPosition 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
Public プロパティ | CellString | セル位置を示す文字列を取得します。
Public プロパティ | ex | 終了 X 座標を取得します。
Public プロパティ | ey | 終了 Y 座標を取得します。
Public プロパティ | sx | 開始 X 座標を取得します。
Public プロパティ | sy | 開始 Y 座標を取得します。
Public プロパティ | VarName | 変数名を設定、取得します。
トップ
関連項目

参照


CellPosition プロパティ

CellPosition 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
Public プロパティ | CellString | セル位置を示す文字列を取得します。
Public プロパティ | ex | 終了 X 座標を取得します。
Public プロパティ | ey | 終了 Y 座標を取得します。
Public プロパティ | sx | 開始 X 座標を取得します。
Public プロパティ | sy | 開始 Y 座標を取得します。
Public プロパティ | VarName | 変数名を設定、取得します。
トップ
関連項目

参照

CellPosition クラス


CellPosition.CellString プロパティ

CellPositionCellString プロパティ

セル位置を示す文字列を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string CellString { get; }
Public ReadOnly Property CellString As String
    Get

プロパティ値

型: String
セル位置を示す文字列。
関連項目

参照

CellPosition クラス


CellPosition.ex プロパティ

CellPositionex プロパティ

終了 X 座標を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int ex { get; }
Public ReadOnly Property ex As Integer
    Get

プロパティ値

型: Int32
終了 X 座標。
関連項目

参照

CellPosition クラス


CellPosition.ey プロパティ

CellPositioney プロパティ

終了 Y 座標を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int ey { get; }
Public ReadOnly Property ey As Integer
    Get

プロパティ値

型: Int32
終了 Y 座標。
関連項目

参照

CellPosition クラス


CellPosition.sx プロパティ

CellPositionsx プロパティ

開始 X 座標を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int sx { get; }
Public ReadOnly Property sx As Integer
    Get

プロパティ値

型: Int32
開始 X 座標。
関連項目

参照

CellPosition クラス


CellPosition.sy プロパティ

CellPositionsy プロパティ

開始 Y 座標を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int sy { get; }
Public ReadOnly Property sy As Integer
    Get

プロパティ値

型: Int32
開始 Y 座標。
関連項目

参照

CellPosition クラス


CellPosition.VarName プロパティ

CellPositionVarName プロパティ

変数名を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string VarName { get; set; }
Public Property VarName As String
    Get
    Set

プロパティ値

型: String
関連項目

参照

CellPosition クラス


CellPositionCollection クラス

セル位置を配列で管理する CellPositionCollection クラスです。
継承階層
System.Collections.GenericListT
AdvanceSoftware.ExcelCreatorCellPositionCollection

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class CellPositionCollection : List
Public Class CellPositionCollection
    Inherits List

CellPositionCollection 型は下記のメンバーを公開します。

プロパティ
名前 | 説明
Name | セル名を取得します。
トップ
関連項目

参照


CellPositionCollection プロパティ

CellPositionCollection 型は下記のメンバーを公開します。

プロパティ
名前 | 説明
Name | セル名を取得します。
トップ
関連項目

参照

CellPositionCollection クラス


CellPositionCollection.Name プロパティ

CellPositionCollectionName プロパティ

セル名を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Name { get; }
Public ReadOnly Property Name As String
    Get

プロパティ値

型: String
セル名。
例
C#
VB
コピー
// セル名 "NAMAE1" の座標一覧を取得します。
AdvanceSoftware.ExcelCreator.CellPositionCollection rangeAddress;
rangeAddress = creator1.GetRangeAddress("NAMAE1");
// 座標一覧のセル名を取得します。
string rangeAddressName = rangeAddress.Name;
' セル名 "NAMAE1" の座標一覧を取得します。
Dim rangeAddress As AdvanceSoftware.ExcelCreator.CellPositionCollection
rangeAddress = Creator1.GetRangeAddress("NAMAE1")
' 座標一覧のセル名を取得します。
Dim rangeAddressName As String = rangeAddress.Name
関連項目

参照

CellPositionCollection クラス


Creator クラス

Xls / Xlsx 形式のファイルを作成するコンポーネントです。
継承階層
System.ComponentModelComponent
AdvanceSoftware.ExcelCreatorCreator

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Creator : Component
Public Class Creator
    Inherits Component

Creator 型は下記のメンバーを公開します。

コンストラクター
 | 名前 | 説明
Public メソッド | Creator | コンストラクター
Public メソッド | Creator(IContainer) | コンストラクター
トップ
プロパティ
 | 名前 | 説明
 | ActiveSheet | アクティブシートを設定、取得します。
 | Center | ページ中央を指定します。
 | ChangeNameAddressMode | セル名位置調整モードを設定します。
 | ChangeRefSheetAddressMode | 計算式内のセル位置調整モードを設定します。
 | DefaultFontName | 標準のフォント名を設定します。
 | DefaultFontPoint | 標準のフォントサイズを設定します。
 | DoubleMode | 浮動小数点の有効桁数モードを設定、取得します。
 | ErrorMessage | エラーメッセージを取得します。
 | ErrorNo | エラーナンバーを取得します。
 | ExcelFileType | Excel ファイル種別を設定します。
 | FullCalcOnLoad | ブックオープン時の再計算の有効モードを設定します。
 | GetVarNames | 変数名の座標一覧を取得します。
 | HeaderFooterMode | ヘッダー/フッターの設定モードを設定します。
Public プロパティ | Html | HTML のオプションを指定するための HtmlOption を取得します。
 | InitFormulaAnswer | 計算結果の初期化モードを設定します。
 | IsHiddenSheet | 現在のシートが非表示シートかどうかを取得します。
 | IsPdfSaved | PDF ファイル出力の状態を取得します。
 | Keyword | 変数名の先頭キーワード文字列を設定します。
 | MergeCellAreaCheckMode | 結合セルの範囲チェックモードを設定します。
 | ModeGrid | グリッド線の表示モードを設定します。True を設定するとグリッド線を表示します。
 | PageOrder | ページの方向を指定します。
Public プロパティ | Pdf | PDF のオプションを指定するための PdfOption を取得します。
 | RangeNames | セル名の一覧を取得します。
 | RefSheet | 参照するシート名を設定します。
 | ScaleMode | スケールモードを設定、取得します。
 | SheetCount | シート数を取得します。
 | SheetName | シート名を設定、取得します。
 | SheetNo | シート番号を設定します。
 | StreamMode | データを展開するストリームモードを設定します。
 | TabSelected | シートの選択を指定します。
 | TemporaryPath | 一時ファイルのパスを設定、取得します。
 | VarInsertMode | 変数名挿入モードを設定します。
 | VarNameMode | 変数名の設定を行う Keyword 、VarInsertMode プロパティの動作モードを指定します。
 | WaitTimeout | 同時アクセス時の待ち時間をミリ秒単位で指定します。
 | Zoom | 倍率を設定します。
トップ
メソッド
名前 | 説明
AddSheet(Int32) | シートを追加します。
AddSheet(Int32, Int32) | シートを追加します。
Cell(String) | Cell を取得します。
Cell(String, Int32, Int32) | Cell を取得します。
CloseBook(Boolean) | ブックをクローズします。
CloseBook(Boolean, Stream, Boolean) | ブックをクローズします。
CloseBook(Boolean, String, Boolean) | ブックをクローズします。
CloseBook(Boolean, Stream, Stream, Boolean) | ブックをクローズします。
CloseBook(Boolean, String, String, Boolean) | ブックをクローズします。
CloseBookEx(Boolean, Object) | ブックをクローズします。
CloseBookEx(Boolean, Object, Stream, Boolean) | ブックをクローズします。
CloseBookEx(Boolean, Object, String, Boolean) | ブックをクローズします。
CloseBookEx(Boolean, Object, Stream, Stream, Boolean) | ブックをクローズします。
CloseBookEx(Boolean, Object, String, String, Boolean) | ブックをクローズします。
ColumnClear(Int32) | 列をクリアします。
ColumnClear(Int32, Int32) | 列をクリアします。
ColumnCopy(Int32) | 列をコピーします。
ColumnCopy(Int32, Int32) | 列をコピーします。
ColumnDelete(Int32) | 列を削除します。
ColumnDelete(Int32, Int32) | 列を削除します。
ColumnInsert(Int32) | 列を挿入します。
ColumnInsert(Int32, Int32) | 列を挿入します。
ColumnInsertCopied(Int32) | コピーした列を挿入します。
ColumnInsertCopied(Int32, Int32) | コピーした列を挿入します。
ColumnPaste | コピーした列を貼り付けます。
CopySheet | シートをコピーします。
CreateBook(Stream, Int32, xlsVersion) | Xls 形式のブックを新規作成します。
CreateBook(Stream, Int32, xlsxVersion) | Xlsx 形式のブックを新規作成します。
CreateBook(String, Int32, xlsVersion) | Xls 形式のブックを新規作成します。
CreateBook(String, Int32, xlsxVersion) | Xlsx 形式のブックを新規作成します。
CreateBookEx(Stream, Int32, xlsVersion, Object) | Xls 形式のブックを新規作成します。
CreateBookEx(Stream, Int32, xlsxVersion, Object) | Xlsx 形式のブックを新規作成します。
CreateBookEx(String, Int32, xlsVersion, Object) | Xls 形式のブックを新規作成します。
CreateBookEx(String, Int32, xlsxVersion, Object) | Xlsx 形式のブックを新規作成します。
DeleteSheet | シートを削除します。
Footer | フッターを設定します。
Footer2 | フッターを設定します。
GetChartCount | グラフの数を取得します。
GetChartData | グラフ情報を取得します。
GetHtmlText(HtmlOutputType) | HTML テキストを取得します。
GetHtmlText(String, HtmlOutputType) | HTML テキストを取得します。
GetMaxArea | データ、または、属性の終了座標を取得します。
GetMaxArea(MaxEndPoint) | データ、または、属性の終了座標を取得します。
GetMaxData | データの終了座標を取得します。
GetMaxData(MaxEndPoint) | データの終了座標を取得します。
GetMergeCells | 結合セルの座標一覧を取得します。
GetNamePos | 指定したセル名の座標(0～)を取得します。
GetRangeAddress | 指定したセル名の座標一覧を取得します。
GetVarNamePos | 指定した変数名の座標(0～)を取得します。
Header | ヘッダーを設定します。
Header2 | ヘッダーを設定します。
Margin | 余白を設定します。
OpenBook(Stream, String) | ブックをオープンします。
OpenBook(String, String) | ブックをオープンします。
OpenBook(Stream, String, String) | ブックをオープンします。
OpenBook(String, String, String) | ブックをオープンします。
OpenBookEmbed(Stream, Byte) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEmbed(Stream, Stream) | Stream を元ファイルとしてブックをオープンします。
OpenBookEmbed(String, Byte) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEmbed(String, Stream) | Stream を元ファイルとしてブックをオープンします。
OpenBookEmbedEx(Stream, Byte, Object) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEmbedEx(Stream, Stream, Object) | Stream を元ファイルとしてブックをオープンします。
OpenBookEmbedEx(String, Byte, Object) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEmbedEx(String, Stream, Object) | Stream を元ファイルとしてブックをオープンします。
OpenBookEx(Stream, Byte, Object) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEx(Stream, Stream, Object) | Stream を元ファイルとしてブックをオープンします。
OpenBookEx(Stream, String, Object) | ブックをオープンします。
OpenBookEx(String, Byte, Object) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEx(String, Stream, Object) | Stream を元ファイルとしてブックをオープンします。
OpenBookEx(String, String, Object) | ブックをオープンします。
OpenBookEx(Stream, Byte, String, Object) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEx(Stream, Stream, String, Object) | Stream を元ファイルとしてブックをオープンします。
OpenBookEx(Stream, String, String, Object) | ブックをオープンします。
OpenBookEx(String, Byte, String, Object) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEx(String, Stream, String, Object) | Stream を元ファイルとしてブックをオープンします。
OpenBookEx(String, String, String, Object) | ブックをオープンします。
Pos(Int32, Int32) | Cell を取得します。
Pos(Int32, Int32, Int32, Int32) | Cell を取得します。
PrintArea | 印刷範囲を設定します。
PrintTitle | 印刷タイトルを設定します。
ReadBook | ブックを読み取り専用でオープンします。
ReadBookEx | ブックを読み取り専用でオープンします。
RowClear(Int32) | 行をクリアします。
RowClear(Int32, Int32) | 行をクリアします。
RowCopy(Int32) | 行をコピーします。
RowCopy(Int32, Int32) | 行をコピーします。
RowDelete(Int32) | 行を削除します。
RowDelete(Int32, Int32) | 行を削除します。
RowInsert(Int32) | 行を挿入します。
RowInsert(Int32, Int32) | 行を挿入します。
RowInsertCopied(Int32) | コピーした行を挿入します。
RowInsertCopied(Int32, Int32) | コピーした行を挿入します。
RowPaste | コピーした行を貼り付けします。
SelectBook | 処理の対象となるブックを切り替えます。
SetDataSource | データソースからセルに値を設定します。
SetJsonValue | JSON 文字列による Excel ファイルへの書き込みをします。
SetLicense(Stream) | ライセンス情報を設定します。
SetLicense(String) | ライセンス情報を設定します。
SheetName2 | シート番号からシート名を取得します。
SheetNo2 | シート名からシート番号を取得します。
Size(PaperKind) | 用紙を設定します。
Size(Int32, PaperKind) | 用紙を設定します。
Size(PageOrientation, PaperKind) | 用紙を設定します。
Size(PageOrientation, Int32, PaperKind) | 用紙を設定します。
SizeFree | ユーザー定義用紙を設定します。
TableRowDelete(Int32) | テーブル範囲に含まれる行を削除します。
TableRowDelete(Int32, Int32) | テーブル範囲に含まれる行を削除します。
TableRowInsert(Int32) | テーブル範囲に行を挿入します。
TableRowInsert(Int32, Int32) | テーブル範囲に行を挿入します。
VarCheck | 指定した変数名が存在するかをチェックします。
トップ
イベント
名前 | 説明
Error | エラーイベント
トップ
関連項目

参照


Creator コンストラクター

オーバーロードの一覧
 | 名前 | 説明
Public メソッド | Creator | コンストラクター
Public メソッド | Creator(IContainer) | コンストラクター
トップ
関連項目

参照

Creator クラス


Creator コンストラクター

コンストラクター

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Creator()
Public Sub New
関連項目

参照

Creator クラス
Creator オーバーロード


Creator コンストラクター (IContainer)

コンストラクター

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Creator(
    IContainer container
)
Public Sub New (
    container As IContainer
)

パラメーター

container
型: System.ComponentModelIContainer
IContainer を指定します。
関連項目

参照

Creator クラス
Creator オーバーロード


Creator プロパティ

Creator 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
 | ActiveSheet | アクティブシートを設定、取得します。
 | Center | ページ中央を指定します。
 | ChangeNameAddressMode | セル名位置調整モードを設定します。
 | ChangeRefSheetAddressMode | 計算式内のセル位置調整モードを設定します。
 | DefaultFontName | 標準のフォント名を設定します。
 | DefaultFontPoint | 標準のフォントサイズを設定します。
 | DoubleMode | 浮動小数点の有効桁数モードを設定、取得します。
 | ErrorMessage | エラーメッセージを取得します。
 | ErrorNo | エラーナンバーを取得します。
 | ExcelFileType | Excel ファイル種別を設定します。
 | FullCalcOnLoad | ブックオープン時の再計算の有効モードを設定します。
 | GetVarNames | 変数名の座標一覧を取得します。
 | HeaderFooterMode | ヘッダー/フッターの設定モードを設定します。
Public プロパティ | Html | HTML のオプションを指定するための HtmlOption を取得します。
 | InitFormulaAnswer | 計算結果の初期化モードを設定します。
 | IsHiddenSheet | 現在のシートが非表示シートかどうかを取得します。
 | IsPdfSaved | PDF ファイル出力の状態を取得します。
 | Keyword | 変数名の先頭キーワード文字列を設定します。
 | MergeCellAreaCheckMode | 結合セルの範囲チェックモードを設定します。
 | ModeGrid | グリッド線の表示モードを設定します。True を設定するとグリッド線を表示します。
 | PageOrder | ページの方向を指定します。
Public プロパティ | Pdf | PDF のオプションを指定するための PdfOption を取得します。
 | RangeNames | セル名の一覧を取得します。
 | RefSheet | 参照するシート名を設定します。
 | ScaleMode | スケールモードを設定、取得します。
 | SheetCount | シート数を取得します。
 | SheetName | シート名を設定、取得します。
 | SheetNo | シート番号を設定します。
 | StreamMode | データを展開するストリームモードを設定します。
 | TabSelected | シートの選択を指定します。
 | TemporaryPath | 一時ファイルのパスを設定、取得します。
 | VarInsertMode | 変数名挿入モードを設定します。
 | VarNameMode | 変数名の設定を行う Keyword 、VarInsertMode プロパティの動作モードを指定します。
 | WaitTimeout | 同時アクセス時の待ち時間をミリ秒単位で指定します。
 | Zoom | 倍率を設定します。
トップ
関連項目

参照

Creator クラス


Creator.ActiveSheet プロパティ

CreatorActiveSheet プロパティ

アクティブシートを設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int ActiveSheet { get; set; }
Public Property ActiveSheet As Integer
    Get
    Set

プロパティ値

型: Int32
アクティブシートに設定するシート番号(0～)。
例
C#
VB
コピー
// 2 シート目をアクティブシートに設定します。
creator1.ActiveSheet = 1;
' 2 シート目をアクティブシートに設定します。
Creator1.ActiveSheet = 1
関連項目

参照

Creator クラス


Creator.Center プロパティ

CreatorCenter プロパティ

ページ中央を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PageCenter Center { set; }
Public WriteOnly Property Center As PageCenter
    Set

プロパティ値

型: PageCenter
ページ中央を表す PageCenter。
例
C#
VB
コピー
// ページ中央を "水平、垂直" に設定します。
creator1.Center = AdvanceSoftware.ExcelCreator.PageCenter.Horz | AdvanceSoftware.ExcelCreator.PageCenter.Vert;
' ページ中央を "水平、垂直" に設定します。
Creator1.Center = AdvanceSoftware.ExcelCreator.PageCenter.Horz Or AdvanceSoftware.ExcelCreator.PageCenter.Vert
関連項目

参照

Creator クラス


Creator.ChangeNameAddressMode プロパティ

CreatorChangeNameAddressMode プロパティ

セル名位置調整モードを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ChangeNameAddressMode { get; set; }
Public Property ChangeNameAddressMode As Boolean
    Get
    Set

プロパティ値

型: Boolean
行列の挿入、削除時にセル名の座標を移動する場合、True。
解説
初期値は False で座標移動は行いません。 Xlsx 形式のみ対応しています。Xls 形式は標準で座標移動を行います。
例
C#
VB
コピー
creator1.OpenBook(@"C:\Out1.xlsx", @"C:\Book1.xlsx");
// 行列の挿入、削除時にセル名の座標が移動されるよう設定します。
creator1.ChangeNameAddressMode = true;
creator1.RowInsert(0, 1);
creator1.Cell("NAMAE1").Value = "アドバンスソフトウェア";
creator1.CloseBook(true);
Creator1.OpenBook("C:\Out1.xlsx", "C:\Book1.xlsx")
' 行列の挿入、削除時にセル名の座標が移動されるよう設定します。
Creator1.ChangeNameAddressMode = True
Creator1.RowInsert(0, 1)
Creator1.Cell("NAMAE1").Value = "アドバンスソフトウェア"
Creator1.CloseBook(True)
関連項目

参照

Creator クラス


Creator.ChangeRefSheetAddressMode プロパティ

CreatorChangeRefSheetAddressMode プロパティ

計算式内のセル位置調整モードを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ChangeRefSheetAddressMode { get; set; }
Public Property ChangeRefSheetAddressMode As Boolean
    Get
    Set

プロパティ値

型: Boolean
計算式内のセル位置調整モード。
例
C#
VB
コピー
// シートを参照する計算式セルをコピーした場合に計算式内のセル位置が調整されるよう設定します。
creator1.ChangeRefSheetAddressMode = true;
' シートを参照する計算式セルをコピーした場合に計算式内のセル位置が調整されるよう設定します。
Creator1.ChangeRefSheetAddressMode = True
関連項目

参照

Creator クラス


Creator.DefaultFontName プロパティ

CreatorDefaultFontName プロパティ

標準のフォント名を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string DefaultFontName { set; }
Public WriteOnly Property DefaultFontName As String
    Set

プロパティ値

型: String
標準のフォント名。
例
C#
VB
コピー
// 標準のフォント名を "ＭＳ 明朝" に設定します。
creator1.DefaultFontName = "ＭＳ 明朝";
' 標準のフォント名を "ＭＳ 明朝" に設定します。
Creator1.DefaultFontName = "ＭＳ 明朝"
関連項目

参照

Creator クラス


Creator.DefaultFontPoint プロパティ

CreatorDefaultFontPoint プロパティ

標準のフォントサイズを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double DefaultFontPoint { set; }
Public WriteOnly Property DefaultFontPoint As Double
    Set

プロパティ値

型: Double
標準のフォントサイズ。
例
C#
VB
コピー
// 標準のフォントサイズを 16 ポイントに設定します。
creator1.DefaultFontPoint = 16;
' 標準のフォントサイズを 16 ポイントに設定します。
Creator1.DefaultFontPoint = 16
関連項目

参照

Creator クラス


Creator.DoubleMode プロパティ

CreatorDoubleMode プロパティ

浮動小数点の有効桁数モードを設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool DoubleMode { get; set; }
Public Property DoubleMode As Boolean
    Get
    Set

プロパティ値

型: Boolean
数値の有効桁数を 15 桁に設定する場合、True。
解説
初期値は、False で 12 桁までの数値が有効桁数となっています。 13 桁以上の数値を設定する場合、True を設定します。
例
C#
VB
コピー
// 数値の有効桁数を 15 桁に設定します。
creator1.DoubleMode = true;
' 数値の有効桁数を 15 桁に設定します。
Creator1.DoubleMode = True
関連項目

参照

Creator クラス


Creator.ErrorMessage プロパティ

CreatorErrorMessage プロパティ

エラーメッセージを取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string ErrorMessage { get; }
Public ReadOnly Property ErrorMessage As String
    Get

プロパティ値

型: String
エラーメッセージ(文字列)。
例
C#
VB
コピー
// 何らかのエラーが発生した場合、エラーメッセージを表示します。
if (creator1.ErrorNo != AdvanceSoftware.ExcelCreator.ErrorNo.NoError)
{
    MessageBox.Show(creator1.ErrorMessage);
}
' 何らかのエラーが発生した場合、エラー番号を表示します。
If Creator1.ErrorNo <> AdvanceSoftware.ExcelCreator.ErrorNo.NoError Then
    MessageBox.Show(Creator1.ErrorMessage)
End If
関連項目

参照

Creator クラス


Creator.ErrorNo プロパティ

CreatorErrorNo プロパティ

エラーナンバーを取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo ErrorNo { get; }
Public ReadOnly Property ErrorNo As ErrorNo
    Get

プロパティ値

型: ErrorNo
エラーナンバーを表す ErrorNo。
例
C#
VB
コピー
// 何らかのエラーが発生した場合、エラーメッセージを表示します。
if (creator1.ErrorNo != AdvanceSoftware.ExcelCreator.ErrorNo.NoError)
{
    MessageBox.Show(creator1.ErrorMessage);
}
' 何らかのエラーが発生した場合、エラー番号を表示します。
If Creator1.ErrorNo <> AdvanceSoftware.ExcelCreator.ErrorNo.NoError Then
    MessageBox.Show(Creator1.ErrorMessage)
End If
関連項目

参照

Creator クラス


Creator.ExcelFileType プロパティ

CreatorExcelFileType プロパティ

Excel ファイル種別を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ExcelFileType ExcelFileType { get; set; }
Public Property ExcelFileType As ExcelFileType
    Get
    Set

プロパティ値

型: ExcelFileType
Excel ファイル種別を表す ExcelFileType。
例
C#
VB
コピー
// Excel ファイル種別を xlsx に設定します。
creator1.ExcelFileType = AdvanceSoftware.ExcelCreator.ExcelFileType.xlsx;
// "C:\Book1.xlsx" をオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
creator1.OpenBook(@"C:\Out1.xlsx", @"C:\Book1.xlsx");
creator1.CloseBook(true);
' Excel ファイル種別を xlsx に設定します。
Creator1.ExcelFileType = AdvanceSoftware.ExcelCreator.ExcelFileType.xlsx
' "C:\Book1.xlsx" をオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
Creator1.OpenBook("C:\Out1.xlsx", "C:\Book1.xlsx")
Creator1.CloseBook(True)
関連項目

参照

Creator クラス


Creator.FullCalcOnLoad プロパティ

CreatorFullCalcOnLoad プロパティ

ブックオープン時の再計算の有効モードを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool FullCalcOnLoad { set; }
Public WriteOnly Property FullCalcOnLoad As Boolean
    Set

プロパティ値

型: Boolean
ブックオープン時の再計算を有効にする場合、True。
例
C#
VB
コピー
creator1.OpenBook(@"C:\Out1.xlsx", @"C:\Book1.xlsx");
// ブックオープン時に再計算が行われるよう設定します。
creator1.FullCalcOnLoad = true;
creator1.CloseBook(true);
Creator1.OpenBook("C:\Out1.xlsx", "C:\Book1.xlsx")
' ブックオープン時に再計算が行われるよう設定します。
Creator1.FullCalcOnLoad = True
Creator1.CloseBook(True)
関連項目

参照

Creator クラス


Creator.GetVarNames プロパティ

CreatorGetVarNames プロパティ

変数名の座標一覧を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public CellPositionCollection GetVarNames { get; }
Public ReadOnly Property GetVarNames As CellPositionCollection
    Get

戻り値

型: CellPositionCollection
セルの座標を示す CellPositionCollection。
例
C#
VB
コピー
// 変数名の座標一覧を取得します。
AdvanceSoftware.ExcelCreator.CellPositionCollection varNames;
varNames = creator1.GetVarNames;
foreach (AdvanceSoftware.ExcelCreator.CellPosition varName in varNames)
{
    // 変数名毎で処理を行うことができます。
    // ...
}
' 変数名の座標一覧を取得します。
Dim varNames As AdvanceSoftware.ExcelCreator.CellPositionCollection
varNames = Creator1.GetVarNames
For Each varName As AdvanceSoftware.ExcelCreator.CellPosition In varNames
    ' 変数名毎で処理を行うことができます。
    ' ...
Next
関連項目

参照

Creator クラス


Creator.HeaderFooterMode プロパティ

CreatorHeaderFooterMode プロパティ

ヘッダー/フッターの設定モードを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public HeaderFooterMode HeaderFooterMode { set; }
Public WriteOnly Property HeaderFooterMode As HeaderFooterMode
    Set

プロパティ値

型: HeaderFooterMode
ヘッダー/フッターの設定モードを表す HeaderFooterMode。
解説
Xlsx 形式のみ対応しています。
例
C#
VB
コピー
// ヘッダー/フッターの設定を先頭ページのみ別指定にします。
creator1.HeaderFooterMode = AdvanceSoftware.ExcelCreator.HeaderFooterMode.FirstPage;
// 先頭ページの中央ヘッダーに文字列 "先頭ページのヘッダー" を設定します。
creator1.Header2("", "先頭ページのヘッダー", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.First);
// 先頭ページの中央フッターに文字列 "先頭ページのフッター" を設定します。
creator1.Footer2("", "先頭ページのフッター", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.First);
// 標準ページの中央ヘッダーに文字列 "標準ページのヘッダー" を設定します。
creator1.Header2("", "標準ページのヘッダー", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.Normal);
// 標準ページの中央フッターに文字列 "標準ページのフッター" を設定します。
creator1.Footer2("", "標準ページのフッター", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.Normal);
' ヘッダー/フッターの設定を先頭ページのみ別指定にします。
Creator1.HeaderFooterMode = AdvanceSoftware.ExcelCreator.HeaderFooterMode.FirstPage
' 先頭ページの中央ヘッダーに文字列 "先頭ページのヘッダー" を設定します。
Creator1.Header2("", "先頭ページのヘッダー", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.First)
' 先頭ページの中央フッターに文字列 "先頭ページのフッター" を設定します。
Creator1.Footer2("", "先頭ページのフッター", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.First)
' 標準ページの中央ヘッダーに文字列 "標準ページのヘッダー" を設定します。
Creator1.Header2("", "標準ページのヘッダー", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.Normal)
' 標準ページの中央フッターに文字列 "標準ページのフッター" を設定します。
Creator1.Footer2("", "標準ページのフッター", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.Normal)
関連項目

参照

Creator クラス


Creator.Html プロパティ

CreatorHtml プロパティ

HTML のオプションを指定するための HtmlOption を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public HtmlOption Html { get; }
Public ReadOnly Property Html As HtmlOption
    Get

プロパティ値

型: HtmlOption
HTML 出力のオプションを設定するための HtmlOption クラス。
解説
このクラスの全てのメンバの一覧については、HtmlOption クラスのメンバを参照してください。
関連項目

参照

Creator クラス


Creator.InitFormulaAnswer プロパティ

CreatorInitFormulaAnswer プロパティ

計算結果の初期化モードを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool InitFormulaAnswer { set; }
Public WriteOnly Property InitFormulaAnswer As Boolean
    Set

プロパティ値

型: Boolean
計算結果の初期化モードを有効にする場合、True。
例
C#
VB
コピー
creator1.OpenBook(@"C:\Out1.xlsx", @"C:\Book1.xlsx");
// 計算結果を初期化するよう設定します。
creator1.InitFormulaAnswer = true;
creator1.CloseBook(true);
Creator1.OpenBook("C:\Out1.xlsx", "C:\Book1.xlsx")
' 計算結果を初期化するよう設定します。
Creator1.InitFormulaAnswer = True
Creator1.CloseBook(True)
関連項目

参照

Creator クラス


Creator.IsHiddenSheet プロパティ

CreatorIsHiddenSheet プロパティ

現在のシートが非表示シートかどうかを取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool IsHiddenSheet { get; }
Public ReadOnly Property IsHiddenSheet As Boolean
    Get

プロパティ値

型: Boolean
非表示シートの場合、True。
例
C#
VB
コピー
// 現在のシートが非表示シートかどうかを取得します。
bool isHiddenSheet = creator1.IsHiddenSheet;
' 現在のシートが非表示シートかどうかを取得します。
Dim isHiddenSheet As Boolean = Creator1.IsHiddenSheet
関連項目

参照

Creator クラス


Creator.IsPdfSaved プロパティ

CreatorIsPdfSaved プロパティ

PDF ファイル出力の状態を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool IsPdfSaved { get; }
Public ReadOnly Property IsPdfSaved As Boolean
    Get

プロパティ値

型: Boolean
PDF ファイルの生成に成功した場合：True
例
C#
VB
コピー
creator1.OpenBook(@"C:\Out1.xlsx", @"C:\Book1.xlsx");
// PDF ファイルを "C:\Out1.pdf" に出力します。
creator1.CloseBook(true, @"C:\Out1.pdf", false);
// PDF ファイルの生成結果を取得します。
bool isPdfSaved = creator1.IsPdfSaved;
Creator1.OpenBook("C:\Out1.xlsx", "C:\Book1.xlsx")
' PDF ファイルを "C:\Out1.pdf" に出力します。
Creator1.CloseBook(True, "C:\Out1.pdf", False)
' PDF ファイルの生成結果を取得します。
Dim isPdfSaved As Boolean = Creator1.IsPdfSaved
関連項目

参照

Creator クラス


Creator.Keyword プロパティ

CreatorKeyword プロパティ

変数名の先頭キーワード文字列を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Keyword { set; }
Public WriteOnly Property Keyword As String
    Set

プロパティ値

型: String
キーワードとして使用する文字列(最大 64 文字)。(既定値:"**")。
解説
先頭キーワード文字列は Excel で文字として認識可能で、かつ、 半角文字のみ設定することができます。 なお、以下の文字、及び文字列は先頭キーワード文字列として使用することはできません。
, | コンマ
_[ | アンダースコア + 大かっこ
例
C#
VB
コピー
// 変数名の先頭キーワード文字列を "!!" に設定します。
creator1.Keyword = "!!";
creator1.OpenBook(@"C:\Out1.xlsx", @"C:\Book1.xlsx");
creator1.Cell("!!HENSU1").Value = "アドバンスソフトウェア";
creator1.CloseBook(true);
' 変数名の先頭キーワード文字列を "!!" に設定します。
Creator1.Keyword = "!!"
Creator1.OpenBook("C:\Out1.xlsx", "C:\Book1.xlsx")
Creator1.Cell("!!HENSU1").Value = "アドバンスソフトウェア"
Creator1.CloseBook(True)
関連項目

参照

Creator クラス


Creator.MergeCellAreaCheckMode プロパティ

CreatorMergeCellAreaCheckMode プロパティ

結合セルの範囲チェックモードを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool MergeCellAreaCheckMode { set; }
Public WriteOnly Property MergeCellAreaCheckMode As Boolean
    Set

プロパティ値

型: Boolean
結合セルの範囲チェックを行わないようにする場合、False。
例
C#
VB
コピー
// 結合セルの範囲チェックを行わないよう設定します。
creator1.MergeCellAreaCheckMode = false;
' 結合セルの範囲チェックを行わないよう設定します。
Creator1.MergeCellAreaCheckMode = False
関連項目

参照

Creator クラス


Creator.ModeGrid プロパティ

CreatorModeGrid プロパティ

グリッド線の表示モードを設定します。True を設定するとグリッド線を表示します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ModeGrid { set; }
Public WriteOnly Property ModeGrid As Boolean
    Set

プロパティ値

型: Boolean
例
C#
VB
コピー
// シートのグリッド線を非表示に設定します。
creator1.ModeGrid = false;
' シートのグリッド線を非表示に設定します。
Creator1.ModeGrid = False
関連項目

参照

Creator クラス


Creator.PageOrder プロパティ

CreatorPageOrder プロパティ

ページの方向を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PageOrder PageOrder { set; }
Public WriteOnly Property PageOrder As PageOrder
    Set

プロパティ値

型: PageOrder
ページの方向を表す PageOrder。
例
C#
VB
コピー
// ページの方向を "上から下" に設定します。
creator1.PageOrder = AdvanceSoftware.ExcelCreator.PageOrder.BottomFromTop;
' ページの方向を "上から下" に設定します。
Creator1.PageOrder = AdvanceSoftware.ExcelCreator.PageOrder.BottomFromTop
関連項目

参照

Creator クラス


Creator.Pdf プロパティ

CreatorPdf プロパティ

PDF のオプションを指定するための PdfOption を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PdfOption Pdf { get; }
Public ReadOnly Property Pdf As PdfOption
    Get

プロパティ値

型: PdfOption
PDF 出力のオプションを設定するための PdfOption クラス。
解説
このクラスの全てのメンバの一覧については、PdfOption クラスのメンバを参照してください。
関連項目

参照

Creator クラス


Creator.RangeNames プロパティ

CreatorRangeNames プロパティ

セル名の一覧を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string[] RangeNames { get; }
Public ReadOnly Property RangeNames As String()
    Get

プロパティ値

型: String
例
C#
VB
コピー
// セル名の一覧を取得します。
string[] rangeNames = creator1.RangeNames;
' セル名の一覧を取得します。
Dim rangeNames As String() = Creator1.RangeNames
関連項目

参照

Creator クラス


Creator.RefSheet プロパティ

CreatorRefSheet プロパティ

参照するシート名を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string RefSheet { set; }
Public WriteOnly Property RefSheet As String
    Set

プロパティ値

型: String
参照するシート名。(複数シートを参照する場合はスラッシュ(/)で区切って設定します)
解説
Xls 形式でシートの参照を含む計算式を設定する場合、予め RefSheet プロパティで参照するシート名を指定する必要があります。 Xlsx 形式では指定は不要です。
例
C#
VB
コピー
// 2 シート目のシート名を "シート2" に設定して、A1 セルに 200 を設定します。
creator1.SheetNo = 1;
creator1.SheetName = "シート2";
creator1.Cell("A1").Value = 200;
// 1 シート目のシート名を "シート1" に設定して、A1 セルに 100 を設定します。
creator1.SheetNo = 0;
creator1.SheetName = "シート1";
creator1.Cell("A1").Value = 100;
// 参照するシート名を指定して、計算式を設定します。
creator1.RefSheet = "シート1/シート2";
creator1.Cell("A2").Func("=シート1!A1+シート2!A1", null);
' 2 シート目のシート名を "シート2" に設定して、A1 セルに 200 を設定します。
Creator1.SheetNo = 1
Creator1.SheetName = "シート2"
Creator1.Cell("A1").Value = 200
' 1 シート目のシート名を "シート1" に設定して、A1 セルに 100 を設定します。
Creator1.SheetNo = 0
Creator1.SheetName = "シート1"
Creator1.Cell("A1").Value = 100
' 参照するシート名を指定して、計算式を設定します。
Creator1.RefSheet = "シート1/シート2"
Creator1.Cell("A2").Func("=シート1!A1+シート2!A1", Nothing)
関連項目

参照

Creator クラス


Creator.ScaleMode プロパティ

CreatorScaleMode プロパティ

スケールモードを設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ScaleMode ScaleMode { get; set; }
Public Property ScaleMode As ScaleMode
    Get
    Set

プロパティ値

型: ScaleMode
サイズの単位を表す ScaleMode。
解説
Drawing / CellCanvas クラスの各メソッドを使用して図やシェイプを設定する際の座標、サイズの単位を設定します。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel;
// A1 セルに画像 (幅：100px、高さ：100px) を設定します。
creator1.Cell("A1").Drawing.AddImage(@"C:\image.bmp", 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
Creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel
' A1 セルに画像 (幅：100px、高さ：100px) を設定します。
Creator1.Cell("A1").Drawing.AddImage("C:\image.bmp", 100, 100)
関連項目

参照

Creator クラス


Creator.SheetCount プロパティ

CreatorSheetCount プロパティ

シート数を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int SheetCount { get; }
Public ReadOnly Property SheetCount As Integer
    Get

プロパティ値

型: Int32
シート数。
例
C#
VB
コピー
// シート数を取得します。
int sheetCount = creator1.SheetCount;
' シート数を取得します。
Dim sheetCount As Integer = Creator1.SheetCount
関連項目

参照

Creator クラス


Creator.SheetName プロパティ

CreatorSheetName プロパティ

シート名を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string SheetName { get; set; }
Public Property SheetName As String
    Get
    Set

プロパティ値

型: String
シート名。
例
C#
VB
コピー
// 操作対象シートを 2 シート目に設定します。
creator1.SheetNo = 1;
// シート名を "シート２" に設定します。
creator1.SheetName = "シート２";
' 操作対象シートを 2 シート目に設定します。
Creator1.SheetNo = 1
' シート名を "シート２" に設定します。
Creator1.SheetName = "シート２"
関連項目

参照

Creator クラス


Creator.SheetNo プロパティ

CreatorSheetNo プロパティ

シート番号を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int SheetNo { set; }
Public WriteOnly Property SheetNo As Integer
    Set

プロパティ値

型: Int32
操作対象とするシート番号(0～)。
例
C#
VB
コピー
// 操作対象シートを 2 シート目に設定します。
creator1.SheetNo = 1;
// シート名を "シート２" に設定します。
creator1.SheetName = "シート２";
' 操作対象シートを 2 シート目に設定します。
Creator1.SheetNo = 1
' シート名を "シート２" に設定します。
Creator1.SheetName = "シート２"
関連項目

参照

Creator クラス


Creator.StreamMode プロパティ

CreatorStreamMode プロパティ

データを展開するストリームモードを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public StreamMode StreamMode { set; }
Public WriteOnly Property StreamMode As StreamMode
    Set

プロパティ値

型: StreamMode
データを展開するストリームモードを表す StreamMode。
解説
データをファイルに展開することでメモリ使用量を抑えることが可能ですが、行列の操作や変数名でのセル指定など、一部の機能が使用できなくなります。
例
C#
VB
コピー
// データをファイルに展開するよう設定します。
creator1.StreamMode = AdvanceSoftware.ExcelCreator.StreamMode.File;
creator1.OpenBook(@"C:\Out1.xlsx", @"C:\Book1.xlsx");
creator1.CloseBook(true);
' データをファイルに展開するよう設定します。
Creator1.StreamMode = AdvanceSoftware.ExcelCreator.StreamMode.File
Creator1.OpenBook("C:\Out1.xlsx", "C:\Book1.xlsx")
Creator1.CloseBook(True)
関連項目

参照

Creator クラス


Creator.TabSelected プロパティ

CreatorTabSelected プロパティ

シートの選択を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool TabSelected { set; }
Public WriteOnly Property TabSelected As Boolean
    Set

プロパティ値

型: Boolean
シートを選択状態に設定する場合、True。
例
C#
VB
コピー
// 操作対象シートを 2 シート目に設定します。
creator1.SheetNo = 1;
// シートを選択状態に設定します。
creator1.TabSelected = true;
' 操作対象シートを 2 シート目に設定します。
Creator1.SheetNo = 1
' シートを選択状態に設定します。
Creator1.TabSelected = True
関連項目

参照

Creator クラス


Creator.TemporaryPath プロパティ

CreatorTemporaryPath プロパティ

一時ファイルのパスを設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string TemporaryPath { get; set; }
Public Property TemporaryPath As String
    Get
    Set

プロパティ値

型: String
一時ファイルのパス。
例
C#
VB
コピー
// 一時ファイルの作成先のパスを "C:\Temp" に指定します。
creator1.TemporaryPath = @"C:\Temp";
creator1.OpenBook(@"C:\Out1.xlsx", @"C:\Book1.xlsx");
creator1.CloseBook(true);
' 一時ファイルの作成先のパスを "C:\Temp" に指定します。
Creator1.TemporaryPath = "C:\Temp"
Creator1.OpenBook("C:\Out1.xlsx", "C:\Book1.xlsx")
Creator1.CloseBook(True)
関連項目

参照

Creator クラス


Creator.VarInsertMode プロパティ

CreatorVarInsertMode プロパティ

変数名挿入モードを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public VarInsertMode VarInsertMode { set; }
Public WriteOnly Property VarInsertMode As VarInsertMode
    Set

プロパティ値

型: VarInsertMode
変数名の差し込みモードを表す VarInsertMode。
例
C#
VB
コピー
// 計算結果が変数名となるセルを変数名として扱わないよう設定する。
creator1.VarInsertMode = AdvanceSoftware.ExcelCreator.VarInsertMode.InvalidAnswer;
creator1.OpenBook(@"C:\Out1.xlsx", @"C:\Book1.xlsx");
creator1.CloseBook(true);
' 計算結果が変数名となるセルを変数名として扱わないよう設定する。
Creator1.VarInsertMode = AdvanceSoftware.ExcelCreator.VarInsertMode.InvalidAnswer
Creator1.OpenBook("C:\Out1.xlsx", "C:\Book1.xlsx")
Creator1.CloseBook(True)
関連項目

参照

Creator クラス


Creator.VarNameMode プロパティ

CreatorVarNameMode プロパティ

変数名の設定を行う Keyword 、VarInsertMode プロパティの動作モードを指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public VarNameMode VarNameMode { set; }
Public WriteOnly Property VarNameMode As VarNameMode
    Set

プロパティ値

型: VarNameMode
変数名の動作モードを表す VarNameMode。(既定値:VarNameMode.Shared)。
解説
変数名キーワード文字列と差し込みモードはアプリケーション全体で設定値が共有されています。 Web アプリケーションで変数名を変更する場合は「VarNameMode.Private」を指定し、インスタンス 単位で変数名の設定値を管理するように変更してください。
例
C#
VB
コピー
// 変数名キーワード文字列、差し込みモードの管理を「インスタンス単位」に指定します。
creator1.VarNameMode = AdvanceSoftware.ExcelCreator.VarNameMode.Private;
creator1.VarInsertMode = AdvanceSoftware.ExcelCreator.VarInsertMode.InvalidAnswer;
creator1.Keyword = "!!";
creator1.OpenBook(@"C:\Out1.xlsx", @"C:\Book1.xlsx");
creator1.Cell("!!HENSU1").Value = "アドバンスソフトウェア";
creator1.CloseBook(true);
' 変数名キーワード文字列、差し込みモードの管理を「インスタンス単位」に指定します。
Creator1.VarNameMode = AdvanceSoftware.ExcelCreator.VarNameMode.Private
Creator1.VarInsertMode = AdvanceSoftware.ExcelCreator.VarInsertMode.InvalidAnswer
Creator1.Keyword = "!!"
Creator1.OpenBook("C:\Out1.xlsx", "C:\Book1.xlsx")
Creator1.Cell("!!HENSU1").Value = "アドバンスソフトウェア"
Creator1.CloseBook(True)
関連項目

参照

Creator クラス


Creator.WaitTimeout プロパティ

CreatorWaitTimeout プロパティ

同時アクセス時の待ち時間をミリ秒単位で指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public uint WaitTimeout { set; }
Public WriteOnly Property WaitTimeout As UInteger
    Set

プロパティ値

型: UInt32
ブック作成、オープン時の排他処理の最大の待ち時間。
解説
大きいサイズの Excel ファイルを使用する場合や、 同時アクセスのクライアント数が多い場合等に、Excel ファイルの作成で 待ち時間が経過してミューテックスエラーが発生する場合は、 WaiteTimout プロパティの値を変更して待ち時間を増やしてください。
例
C#
VB
コピー
creator1.ExcelFileType = AdvanceSoftware.ExcelCreator.ExcelFileType.xlsx;
// 待ち時間を 10000(10 秒) に設定します。
creator1.WaitTimeout = 10000;
creator1.OpenBook(@"C:\Out1.xlsx", @"C:\Book1.xlsx");
creator1.CloseBook(true);
Creator1.ExcelFileType = AdvanceSoftware.ExcelCreator.ExcelFileType.xlsx
' 待ち時間を 10000(10 秒) に設定します。
Creator1.WaitTimeout = 10000
Creator1.OpenBook("C:\Out1.xlsx", "C:\Book1.xlsx")
Creator1.CloseBook(True)
関連項目

参照

Creator クラス


Creator.Zoom プロパティ

CreatorZoom プロパティ

倍率を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int Zoom { set; }
Public WriteOnly Property Zoom As Integer
    Set

プロパティ値

型: Int32
倍率。
例
C#
VB
コピー
// 表示倍率を "120%" に設定します。
creator1.Zoom = 120;
' 表示倍率を "120%" に設定します。
Creator1.Zoom = 120
関連項目

参照

Creator クラス


Creator メソッド

Creator 型は下記のメンバーを公開します。

メソッド
名前 | 説明
AddSheet(Int32) | シートを追加します。
AddSheet(Int32, Int32) | シートを追加します。
Cell(String) | Cell を取得します。
Cell(String, Int32, Int32) | Cell を取得します。
CloseBook(Boolean) | ブックをクローズします。
CloseBook(Boolean, Stream, Boolean) | ブックをクローズします。
CloseBook(Boolean, String, Boolean) | ブックをクローズします。
CloseBook(Boolean, Stream, Stream, Boolean) | ブックをクローズします。
CloseBook(Boolean, String, String, Boolean) | ブックをクローズします。
CloseBookEx(Boolean, Object) | ブックをクローズします。
CloseBookEx(Boolean, Object, Stream, Boolean) | ブックをクローズします。
CloseBookEx(Boolean, Object, String, Boolean) | ブックをクローズします。
CloseBookEx(Boolean, Object, Stream, Stream, Boolean) | ブックをクローズします。
CloseBookEx(Boolean, Object, String, String, Boolean) | ブックをクローズします。
ColumnClear(Int32) | 列をクリアします。
ColumnClear(Int32, Int32) | 列をクリアします。
ColumnCopy(Int32) | 列をコピーします。
ColumnCopy(Int32, Int32) | 列をコピーします。
ColumnDelete(Int32) | 列を削除します。
ColumnDelete(Int32, Int32) | 列を削除します。
ColumnInsert(Int32) | 列を挿入します。
ColumnInsert(Int32, Int32) | 列を挿入します。
ColumnInsertCopied(Int32) | コピーした列を挿入します。
ColumnInsertCopied(Int32, Int32) | コピーした列を挿入します。
ColumnPaste | コピーした列を貼り付けます。
CopySheet | シートをコピーします。
CreateBook(Stream, Int32, xlsVersion) | Xls 形式のブックを新規作成します。
CreateBook(Stream, Int32, xlsxVersion) | Xlsx 形式のブックを新規作成します。
CreateBook(String, Int32, xlsVersion) | Xls 形式のブックを新規作成します。
CreateBook(String, Int32, xlsxVersion) | Xlsx 形式のブックを新規作成します。
CreateBookEx(Stream, Int32, xlsVersion, Object) | Xls 形式のブックを新規作成します。
CreateBookEx(Stream, Int32, xlsxVersion, Object) | Xlsx 形式のブックを新規作成します。
CreateBookEx(String, Int32, xlsVersion, Object) | Xls 形式のブックを新規作成します。
CreateBookEx(String, Int32, xlsxVersion, Object) | Xlsx 形式のブックを新規作成します。
DeleteSheet | シートを削除します。
Footer | フッターを設定します。
Footer2 | フッターを設定します。
GetChartCount | グラフの数を取得します。
GetChartData | グラフ情報を取得します。
GetHtmlText(HtmlOutputType) | HTML テキストを取得します。
GetHtmlText(String, HtmlOutputType) | HTML テキストを取得します。
GetMaxArea | データ、または、属性の終了座標を取得します。
GetMaxArea(MaxEndPoint) | データ、または、属性の終了座標を取得します。
GetMaxData | データの終了座標を取得します。
GetMaxData(MaxEndPoint) | データの終了座標を取得します。
GetMergeCells | 結合セルの座標一覧を取得します。
GetNamePos | 指定したセル名の座標(0～)を取得します。
GetRangeAddress | 指定したセル名の座標一覧を取得します。
GetVarNamePos | 指定した変数名の座標(0～)を取得します。
Header | ヘッダーを設定します。
Header2 | ヘッダーを設定します。
Margin | 余白を設定します。
OpenBook(Stream, String) | ブックをオープンします。
OpenBook(String, String) | ブックをオープンします。
OpenBook(Stream, String, String) | ブックをオープンします。
OpenBook(String, String, String) | ブックをオープンします。
OpenBookEmbed(Stream, Byte) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEmbed(Stream, Stream) | Stream を元ファイルとしてブックをオープンします。
OpenBookEmbed(String, Byte) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEmbed(String, Stream) | Stream を元ファイルとしてブックをオープンします。
OpenBookEmbedEx(Stream, Byte, Object) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEmbedEx(Stream, Stream, Object) | Stream を元ファイルとしてブックをオープンします。
OpenBookEmbedEx(String, Byte, Object) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEmbedEx(String, Stream, Object) | Stream を元ファイルとしてブックをオープンします。
OpenBookEx(Stream, Byte, Object) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEx(Stream, Stream, Object) | Stream を元ファイルとしてブックをオープンします。
OpenBookEx(Stream, String, Object) | ブックをオープンします。
OpenBookEx(String, Byte, Object) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEx(String, Stream, Object) | Stream を元ファイルとしてブックをオープンします。
OpenBookEx(String, String, Object) | ブックをオープンします。
OpenBookEx(Stream, Byte, String, Object) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEx(Stream, Stream, String, Object) | Stream を元ファイルとしてブックをオープンします。
OpenBookEx(Stream, String, String, Object) | ブックをオープンします。
OpenBookEx(String, Byte, String, Object) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEx(String, Stream, String, Object) | Stream を元ファイルとしてブックをオープンします。
OpenBookEx(String, String, String, Object) | ブックをオープンします。
Pos(Int32, Int32) | Cell を取得します。
Pos(Int32, Int32, Int32, Int32) | Cell を取得します。
PrintArea | 印刷範囲を設定します。
PrintTitle | 印刷タイトルを設定します。
ReadBook | ブックを読み取り専用でオープンします。
ReadBookEx | ブックを読み取り専用でオープンします。
RowClear(Int32) | 行をクリアします。
RowClear(Int32, Int32) | 行をクリアします。
RowCopy(Int32) | 行をコピーします。
RowCopy(Int32, Int32) | 行をコピーします。
RowDelete(Int32) | 行を削除します。
RowDelete(Int32, Int32) | 行を削除します。
RowInsert(Int32) | 行を挿入します。
RowInsert(Int32, Int32) | 行を挿入します。
RowInsertCopied(Int32) | コピーした行を挿入します。
RowInsertCopied(Int32, Int32) | コピーした行を挿入します。
RowPaste | コピーした行を貼り付けします。
SelectBook | 処理の対象となるブックを切り替えます。
SetDataSource | データソースからセルに値を設定します。
SetJsonValue | JSON 文字列による Excel ファイルへの書き込みをします。
SetLicense(Stream) | ライセンス情報を設定します。
SetLicense(String) | ライセンス情報を設定します。
SheetName2 | シート番号からシート名を取得します。
SheetNo2 | シート名からシート番号を取得します。
Size(PaperKind) | 用紙を設定します。
Size(Int32, PaperKind) | 用紙を設定します。
Size(PageOrientation, PaperKind) | 用紙を設定します。
Size(PageOrientation, Int32, PaperKind) | 用紙を設定します。
SizeFree | ユーザー定義用紙を設定します。
TableRowDelete(Int32) | テーブル範囲に含まれる行を削除します。
TableRowDelete(Int32, Int32) | テーブル範囲に含まれる行を削除します。
TableRowInsert(Int32) | テーブル範囲に行を挿入します。
TableRowInsert(Int32, Int32) | テーブル範囲に行を挿入します。
VarCheck | 指定した変数名が存在するかをチェックします。
トップ
関連項目

参照

Creator クラス


Creator.AddSheet メソッド

CreatorAddSheet メソッド

オーバーロードの一覧
名前 | 説明
AddSheet(Int32) | シートを追加します。
AddSheet(Int32, Int32) | シートを追加します。
トップ
関連項目

参照

Creator クラス


Creator.AddSheet メソッド (Int32)

CreatorAddSheet メソッド (Int32)

シートを追加します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddSheet(
    int sheetCount
)
Public Sub AddSheet (
    sheetCount As Integer
)

パラメーター

sheetCount
型: SystemInt32
追加するシート数を指定します。
例
C#
VB
コピー
// シート末尾に 2 シート分追加します。
creator1.AddSheet(2);
' シート末尾に 2 シート分追加します。
Creator1.AddSheet(2)
関連項目

参照

Creator クラス
AddSheet オーバーロード


Creator.AddSheet メソッド (Int32, Int32)

CreatorAddSheet メソッド (Int32, Int32)

シートを追加します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddSheet(
    int sheetCount,
    int insertPosition
)
Public Sub AddSheet (
    sheetCount As Integer,
    insertPosition As Integer
)

パラメーター

sheetCount
型: SystemInt32
追加するシート数を指定します。
insertPosition
型: SystemInt32
シートを追加する位置(0～)を指定します。
例
C#
VB
コピー
// 1 シート目から 2 シート分追加します。
creator1.AddSheet(2, 0);
' 1 シート目から 2 シート分追加します。
Creator1.AddSheet(2, 0)
関連項目

参照

Creator クラス
AddSheet オーバーロード


Creator.Cell メソッド

CreatorCell メソッド

オーバーロードの一覧
名前 | 説明
Cell(String) | Cell を取得します。
Cell(String, Int32, Int32) | Cell を取得します。
トップ
関連項目

参照

Creator クラス


Creator.Cell メソッド (String)

CreatorCell メソッド (String)

Cell を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Cell Cell(
    string c
)
Public Function Cell (
    c As String
) As Cell

パラメーター

c
型: SystemString
セルを指定します。

戻り値

型: Cell
Cell を返します。
解説
A1 形式、変数名、セル名で指定します。 変数名、セル名は、Excel ファイルに設定しておく必要があります。
例
C#
VB
コピー
// A1 参照形式でセルを指定します。
creator1.Cell("A1").Value = "アドバンスソフトウェア";
// 変数名でセルを指定します。
creator1.Cell("**HENSU1").Value = "アドバンスソフトウェア";
// セル名でセルを指定します。
creator1.Cell("NAMAE1").Value = "アドバンスソフトウェア";
' A1 参照形式でセルを指定します。
Creator1.Cell("A1").Value = "アドバンスソフトウェア"
' 変数名でセルを指定します。
Creator1.Cell("**HENSU1").Value = "アドバンスソフトウェア"
' セル名でセルを指定します。
Creator1.Cell("NAMAE1").Value = "アドバンスソフトウェア"
関連項目

参照

Creator クラス
Cell オーバーロード


Creator.Cell メソッド (String, Int32, Int32)

CreatorCell メソッド (String, Int32, Int32)

Cell を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Cell Cell(
    string c,
    int cx,
    int cy
)
Public Function Cell (
    c As String,
    cx As Integer,
    cy As Integer
) As Cell

パラメーター

c
型: SystemString
セルを指定します。
cx
型: SystemInt32
x 方向へのオフセット(0～)を指定します。
cy
型: SystemInt32
y 方向へのオフセット(0～)を指定します。

戻り値

型: Cell
Cell を返します。
例
C#
VB
コピー
// A10 セルに文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("A10", 0, 0).Value = "アドバンスソフトウェア";
// B12 セルに文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("A10", 1, 2).Value = "アドバンスソフトウェア";
' A10 セルに文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("A10", 0, 0).Value = "アドバンスソフトウェア"
' B12 セルに文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("A10", 1, 2).Value = "アドバンスソフトウェア"
関連項目

参照

Creator クラス
Cell オーバーロード


Creator.CloseBook メソッド

CreatorCloseBook メソッド

オーバーロードの一覧
名前 | 説明
CloseBook(Boolean) | ブックをクローズします。
CloseBook(Boolean, Stream, Boolean) | ブックをクローズします。
CloseBook(Boolean, String, Boolean) | ブックをクローズします。
CloseBook(Boolean, Stream, Stream, Boolean) | ブックをクローズします。
CloseBook(Boolean, String, String, Boolean) | ブックをクローズします。
トップ
関連項目

参照

Creator クラス


Creator.CloseBook メソッド (Boolean)

CreatorCloseBook メソッド (Boolean)

ブックをクローズします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void CloseBook(
    bool closeMode
)
Public Sub CloseBook (
    closeMode As Boolean
)

パラメーター

closeMode
型: SystemBoolean
クローズモードを指定します。False を指定すると変更内容は破棄されファイル出力は行われません。
例
C#
VB
コピー
// "C:\Book1.xlsx" をオーバーレイオープンし、"C:\Out1.xlsx" を作成します。
creator1.OpenBook(@"C:\Out1.xlsx", @"C:\Book1.xlsx");
// ブックをクローズします。
creator1.CloseBook(true);
' "C:\Book1.xlsx" をオーバーレイオープンし、"C:\Out1.xlsx" を作成します。
Creator1.OpenBook("C:\Out1.xlsx", "C:\Book1.xlsx")
' ブックをクローズします。
Creator1.CloseBook(True)
関連項目

参照

Creator クラス
CloseBook オーバーロード


Creator.CloseBook メソッド (Boolean, Stream, Boolean)

CreatorCloseBook メソッド (Boolean, Stream, Boolean)

ブックをクローズします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void CloseBook(
    bool closeMode,
    Stream pdfStream,
    bool isDeleteFile
)
Public Sub CloseBook (
    closeMode As Boolean,
    pdfStream As Stream,
    isDeleteFile As Boolean
)

パラメーター

closeMode
型: SystemBoolean
クローズモードを指定します。False を指定すると変更内容は破棄されファイル出力は行われません。
pdfStream
型: System.IOStream
保存する PDF ストリームを指定します。
isDeleteFile
型: SystemBoolean
作成した Excel ファイルを破棄するかを指定します。
例
C#
VB
コピー
// "C:\Book1.xlsx" をオーバーレイオープンし、"C:\Out1.xlsx" を作成します。
creator1.OpenBook(@"C:\Out1.xlsx", @"C:\Book1.xlsx");
// PDF ファイルを pdfStream に出力します。
System.IO.MemoryStream pdfStream = new System.IO.MemoryStream();
creator1.CloseBook(true, pdfStream, false);
' "C:\Book1.xlsx" をオーバーレイオープンし、"C:\Out1.xlsx" を作成します。
Creator1.OpenBook("C:\Out1.xlsx", "C:\Book1.xlsx")
' PDF ファイルを pdfStream に出力します。
Dim pdfStream As New System.IO.MemoryStream()
Creator1.CloseBook(True, pdfStream, False)
関連項目

参照

Creator クラス
CloseBook オーバーロード


Creator.CloseBook メソッド (Boolean, String, Boolean)

CreatorCloseBook メソッド (Boolean, String, Boolean)

ブックをクローズします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void CloseBook(
    bool closeMode,
    string pdfFileName,
    bool isDeleteFile
)
Public Sub CloseBook (
    closeMode As Boolean,
    pdfFileName As String,
    isDeleteFile As Boolean
)

パラメーター

closeMode
型: SystemBoolean
クローズモードを指定します。False を指定すると変更内容は破棄されファイル出力は行われません。
pdfFileName
型: SystemString
保存する PDF ファイル名を指定します。
isDeleteFile
型: SystemBoolean
作成した Excel ファイルを破棄するかを指定します。
例
C#
VB
コピー
// "C:\Book1.xlsx" をオーバーレイオープンし、"C:\Out1.xlsx" を作成します。
creator1.OpenBook(@"C:\Out1.xlsx", @"C:\Book1.xlsx");
// PDF ファイルを "C:\Out1.pdf" に出力します。
creator1.CloseBook(true, @"C:\Out1.pdf", false);
' "C:\Book1.xlsx" をオーバーレイオープンし、"C:\Out1.xlsx" を作成します。
Creator1.OpenBook("C:\Out1.xlsx", "C:\Book1.xlsx")
' PDF ファイルを "C:\Out1.pdf" に出力します。
Creator1.CloseBook(True, "C:\Out1.pdf", False)
関連項目

参照

Creator クラス
CloseBook オーバーロード


Creator.CloseBook メソッド (Boolean, Stream, Stream, Boolean)

CreatorCloseBook メソッド (Boolean, Stream, Stream, Boolean)

ブックをクローズします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void CloseBook(
    bool closeMode,
    Stream pdfStream,
    Stream htmlStream,
    bool isDeleteFile
)
Public Sub CloseBook (
    closeMode As Boolean,
    pdfStream As Stream,
    htmlStream As Stream,
    isDeleteFile As Boolean
)

パラメーター

closeMode
型: SystemBoolean
クローズモードを指定します。False を指定すると変更内容は破棄されファイル出力は行われません。
pdfStream
型: System.IOStream
保存する PDF ストリームを指定します。
htmlStream
型: System.IOStream
保存する HTML ストリームを指定します。
isDeleteFile
型: SystemBoolean
作成した Excel ファイルを破棄するかを指定します。
例
C#
VB
コピー
// "C:\Book1.xlsx" をオーバーレイオープンし、"C:\Out1.xlsx" を作成します。
creator1.OpenBook(@"C:\Out1.xlsx", @"C:\Book1.xlsx");
// PDF ファイルを pdfStream、HTML ファイルを htmlStream に出力します。
System.IO.MemoryStream pdfStream = new System.IO.MemoryStream();
System.IO.MemoryStream htmlStream = new System.IO.MemoryStream();
creator1.CloseBook(true, pdfStream, htmlStream, false);
' "C:\Book1.xlsx" をオーバーレイオープンし、"C:\Out1.xlsx" を作成します。
Creator1.OpenBook("C:\Out1.xlsx", "C:\Book1.xlsx")
' PDF ファイルを pdfStream、HTML ファイルを htmlStream に出力します。
Dim pdfStream As New System.IO.MemoryStream()
Dim htmlStream As New System.IO.MemoryStream()
Creator1.CloseBook(True, pdfStream, htmlStream, False)
関連項目

参照

Creator クラス
CloseBook オーバーロード


Creator.CloseBook メソッド (Boolean, String, String, Boolean)

CreatorCloseBook メソッド (Boolean, String, String, Boolean)

ブックをクローズします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void CloseBook(
    bool closeMode,
    string pdfFileName,
    string htmlFileName,
    bool isDeleteFile
)
Public Sub CloseBook (
    closeMode As Boolean,
    pdfFileName As String,
    htmlFileName As String,
    isDeleteFile As Boolean
)

パラメーター

closeMode
型: SystemBoolean
クローズモードを指定します。False を指定すると変更内容は破棄されファイル出力は行われません。
pdfFileName
型: SystemString
保存する PDF ファイル名を指定します。
htmlFileName
型: SystemString
保存する HTML ファイル名を指定します。
isDeleteFile
型: SystemBoolean
作成した Excel ファイルを破棄するかを指定します。
例
C#
VB
コピー
// "C:\Book1.xlsx" をオーバーレイオープンし、"C:\Out1.xlsx" を作成します。
creator1.OpenBook(@"C:\Out1.xlsx", @"C:\Book1.xlsx");
// PDF ファイルを "C:\Out1.pdf"、HTML ファイルを "C:\Out1.html" に出力します。
creator1.CloseBook(true, @"C:\Out1.pdf", @"C:\Out1.html", false);
' "C:\Book1.xlsx" をオーバーレイオープンし、"C:\Out1.xlsx" を作成します。
Creator1.OpenBook("C:\Out1.xlsx", "C:\Book1.xlsx")
' PDF ファイルを "C:\Out1.pdf"、HTML ファイルを "C:\Out1.html" に出力します。
Creator1.CloseBook(True, "C:\Out1.pdf", "C:\Out1.html", False)
関連項目

参照

Creator クラス
CloseBook オーバーロード


Creator.CloseBookEx メソッド

CreatorCloseBookEx メソッド

オーバーロードの一覧
名前 | 説明
CloseBookEx(Boolean, Object) | ブックをクローズします。
CloseBookEx(Boolean, Object, Stream, Boolean) | ブックをクローズします。
CloseBookEx(Boolean, Object, String, Boolean) | ブックをクローズします。
CloseBookEx(Boolean, Object, Stream, Stream, Boolean) | ブックをクローズします。
CloseBookEx(Boolean, Object, String, String, Boolean) | ブックをクローズします。
トップ
関連項目

参照

Creator クラス


Creator.CloseBookEx メソッド (Boolean, Object)

CreatorCloseBookEx メソッド (Boolean, Object)

ブックをクローズします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void CloseBookEx(
    bool closeMode,
    Object bookInfo
)
Public Sub CloseBookEx (
    closeMode As Boolean,
    bookInfo As Object
)

パラメーター

closeMode
型: SystemBoolean
クローズモードを指定します。False を指定すると変更内容は破棄されファイル出力は行われません。
bookInfo
型: SystemObject
ブックを識別するための object 型のハンドルを指定します。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 1 つ目のブック(C:\Book1.xlsx) をオーバーレイオープンし、"C:\Out1.xlsx" を作成します。
creator1.OpenBookEx(@"C:\Out1.xlsx", @"C:\Book1.xlsx", out bookInfo1);
// 2 つ目のブック(C:\Book2.xlsx) をオーバーレイオープンし、"C:\Out2.xlsx" を作成します。
creator1.OpenBookEx(@"C:\Out2.xlsx", @"C:\Book2.xlsx", out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 1 つ目のブック(C:\Book1.xlsx) をオーバーレイオープンし、"C:\Out1.xlsx" を作成します。
Creator1.OpenBookEx("C:\Out1.xlsx", "C:\Book1.xlsx", bookInfo1)
' 2 つ目のブック(C:\Book2.xlsx) をオーバーレイオープンし、"C:\Out2.xlsx" を作成します。
Creator1.OpenBookEx("C:\Out2.xlsx", "C:\Book2.xlsx", bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス
CloseBookEx オーバーロード


Creator.CloseBookEx メソッド (Boolean, Object, Stream, Boolean)

CreatorCloseBookEx メソッド (Boolean, Object, Stream, Boolean)

ブックをクローズします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void CloseBookEx(
    bool closeMode,
    Object bookInfo,
    Stream pdfStream,
    bool isDeleteFile
)
Public Sub CloseBookEx (
    closeMode As Boolean,
    bookInfo As Object,
    pdfStream As Stream,
    isDeleteFile As Boolean
)

パラメーター

closeMode
型: SystemBoolean
クローズモードを指定します。False を指定すると変更内容は破棄されファイル出力は行われません。
bookInfo
型: SystemObject
ブックを識別するための object 型のハンドルを指定します。
pdfStream
型: System.IOStream
保存する PDF ストリームを指定します。
isDeleteFile
型: SystemBoolean
作成した Excel ファイルを破棄するかを指定します。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 1 つ目のブック(C:\Book1.xlsx) をオーバーレイオープンし、"C:\Out1.xlsx" を作成します。
creator1.OpenBookEx(@"C:\Out1.xlsx", @"C:\Book1.xlsx", out bookInfo1);
// 2 つ目のブック(C:\Book2.xlsx) をオーバーレイオープンし、"C:\Out2.xlsx" を作成します。
creator1.OpenBookEx(@"C:\Out2.xlsx", @"C:\Book2.xlsx", out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// PDF ファイルを pdfStream1 に出力し、1 つ目のブックをクローズします。
System.IO.MemoryStream pdfStream1 = new System.IO.MemoryStream();
creator1.CloseBookEx(true, bookInfo1, pdfStream1, false);
// PDF ファイルを pdfStream2 に出力し、2 つ目のブックをクローズします。
System.IO.MemoryStream pdfStream2 = new System.IO.MemoryStream();
creator1.CloseBookEx(true, bookInfo2, pdfStream2, false);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 1 つ目のブック(C:\Book1.xlsx) をオーバーレイオープンし、"C:\Out1.xlsx" を作成します。
Creator1.OpenBookEx("C:\Out1.xlsx", "C:\Book1.xlsx", bookInfo1)
' 2 つ目のブック(C:\Book2.xlsx) をオーバーレイオープンし、"C:\Out2.xlsx" を作成します。
Creator1.OpenBookEx("C:\Out2.xlsx", "C:\Book2.xlsx", bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' PDF ファイルを pdfStream1 に出力し、1 つ目のブックをクローズします。
Dim pdfStream1 As New System.IO.MemoryStream()
Creator1.CloseBookEx(True, bookInfo1, pdfStream1, False)
' PDF ファイルを pdfStream2 に出力し、2 つ目のブックをクローズします。
Dim pdfStream2 As New System.IO.MemoryStream()
Creator1.CloseBookEx(True, bookInfo2, pdfStream2, False)
関連項目

参照

Creator クラス
CloseBookEx オーバーロード


Creator.CloseBookEx メソッド (Boolean, Object, String, Boolean)

CreatorCloseBookEx メソッド (Boolean, Object, String, Boolean)

ブックをクローズします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void CloseBookEx(
    bool closeMode,
    Object bookInfo,
    string pdfFileName,
    bool isDeleteFile
)
Public Sub CloseBookEx (
    closeMode As Boolean,
    bookInfo As Object,
    pdfFileName As String,
    isDeleteFile As Boolean
)

パラメーター

closeMode
型: SystemBoolean
クローズモードを指定します。False を指定すると変更内容は破棄されファイル出力は行われません。
bookInfo
型: SystemObject
ブックを識別するための object 型のハンドルを指定します。
pdfFileName
型: SystemString
保存する PDF ファイル名を指定します。
isDeleteFile
型: SystemBoolean
作成した Excel ファイルを破棄するかを指定します。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 1 つ目のブック(C:\Book1.xlsx) をオーバーレイオープンし、"C:\Out1.xlsx" を作成します。
creator1.OpenBookEx(@"C:\Out1.xlsx", @"C:\Book1.xlsx", out bookInfo1);
// 2 つ目のブック(C:\Book2.xlsx) をオーバーレイオープンし、"C:\Out2.xlsx" を作成します。
creator1.OpenBookEx(@"C:\Out2.xlsx", @"C:\Book2.xlsx", out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// PDF ファイルを "C:\Out1.pdf" に出力し、1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1, @"C:\Out1.pdf", false);
// PDF ファイルを "C:\Out2.pdf" に出力し、2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2, @"C:\Out2.pdf", false);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 1 つ目のブック(C:\Book1.xlsx) をオーバーレイオープンし、"C:\Out1.xlsx" を作成します。
Creator1.OpenBookEx("C:\Out1.xlsx", "C:\Book1.xlsx", bookInfo1)
' 2 つ目のブック(C:\Book2.xlsx) をオーバーレイオープンし、"C:\Out2.xlsx" を作成します。
Creator1.OpenBookEx("C:\Out2.xlsx", "C:\Book2.xlsx", bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' PDF ファイルを "C:\Out1.pdf" に出力し、1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1, "C:\Out1.pdf", False)
' PDF ファイルを "C:\Out2.pdf" に出力し、2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2, "C:\Out2.pdf", False)
関連項目

参照

Creator クラス
CloseBookEx オーバーロード


Creator.CloseBookEx メソッド (Boolean, Object, Stream, Stream, Boolean)

CreatorCloseBookEx メソッド (Boolean, Object, Stream, Stream, Boolean)

ブックをクローズします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void CloseBookEx(
    bool closeMode,
    Object bookInfo,
    Stream pdfStream,
    Stream htmlStream,
    bool isDeleteFile
)
Public Sub CloseBookEx (
    closeMode As Boolean,
    bookInfo As Object,
    pdfStream As Stream,
    htmlStream As Stream,
    isDeleteFile As Boolean
)

パラメーター

closeMode
型: SystemBoolean
クローズモードを指定します。False を指定すると変更内容は破棄されファイル出力は行われません。
bookInfo
型: SystemObject
ブックを識別するための object 型のハンドルを指定します。
pdfStream
型: System.IOStream
保存する PDF ストリームを指定します。
htmlStream
型: System.IOStream
保存する HTML ストリームを指定します。
isDeleteFile
型: SystemBoolean
作成した Excel ファイルを破棄するかを指定します。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 1 つ目のブック(C:\Book1.xlsx) をオーバーレイオープンし、"C:\Out1.xlsx" を作成します。
creator1.OpenBookEx(@"C:\Out1.xlsx", @"C:\Book1.xlsx", out bookInfo1);
// 2 つ目のブック(C:\Book2.xlsx) をオーバーレイオープンし、"C:\Out2.xlsx" を作成します。
creator1.OpenBookEx(@"C:\Out2.xlsx", @"C:\Book2.xlsx", out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// PDF ファイルを pdfStream1、HTML ファイルを htmlStream1 に出力し、1 つ目のブックをクローズします。
System.IO.MemoryStream pdfStream1 = new System.IO.MemoryStream();
System.IO.MemoryStream htmlStream1 = new System.IO.MemoryStream();
creator1.CloseBookEx(true, bookInfo1, pdfStream1, htmlStream1, false);
// PDF ファイルを pdfStream2、HTML ファイルを htmlStream2 に出力し、2 つ目のブックをクローズします。
System.IO.MemoryStream pdfStream2 = new System.IO.MemoryStream();
System.IO.MemoryStream htmlStream2 = new System.IO.MemoryStream();
creator1.CloseBookEx(true, bookInfo2, pdfStream2, htmlStream2, false);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 1 つ目のブック(C:\Book1.xlsx) をオーバーレイオープンし、"C:\Out1.xlsx" を作成します。
Creator1.OpenBookEx("C:\Out1.xlsx", "C:\Book1.xlsx", bookInfo1)
' 2 つ目のブック(C:\Book2.xlsx) をオーバーレイオープンし、"C:\Out2.xlsx" を作成します。
Creator1.OpenBookEx("C:\Out2.xlsx", "C:\Book2.xlsx", bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' PDF ファイルを pdfStream1、HTML ファイルを htmlStream1 に出力し、1 つ目のブックをクローズします。
Dim pdfStream1 As New System.IO.MemoryStream()
Dim htmlStream1 As New System.IO.MemoryStream()
Creator1.CloseBookEx(True, bookInfo1, pdfStream1, htmlStream1, False)
' PDF ファイルを pdfStream2、HTML ファイルを htmlStream2 に出力し、2 つ目のブックをクローズします。
Dim pdfStream2 As New System.IO.MemoryStream()
Dim htmlStream2 As New System.IO.MemoryStream()
Creator1.CloseBookEx(True, bookInfo2, pdfStream2, htmlStream2, False)
関連項目

参照

Creator クラス
CloseBookEx オーバーロード


Creator.CloseBookEx メソッド (Boolean, Object, String, String, Boolean)

CreatorCloseBookEx メソッド (Boolean, Object, String, String, Boolean)

ブックをクローズします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void CloseBookEx(
    bool closeMode,
    Object bookInfo,
    string pdfFileName,
    string htmlFileName,
    bool isDeleteFile
)
Public Sub CloseBookEx (
    closeMode As Boolean,
    bookInfo As Object,
    pdfFileName As String,
    htmlFileName As String,
    isDeleteFile As Boolean
)

パラメーター

closeMode
型: SystemBoolean
クローズモードを指定します。False を指定すると変更内容は破棄されファイル出力は行われません。
bookInfo
型: SystemObject
ブックを識別するための object 型のハンドルを指定します。
pdfFileName
型: SystemString
保存する PDF ファイル名を指定します。
htmlFileName
型: SystemString
保存する HTML ファイル名を指定します。
isDeleteFile
型: SystemBoolean
作成した Excel ファイルを破棄するかを指定します。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 1 つ目のブック(C:\Book1.xlsx) をオーバーレイオープンし、"C:\Out1.xlsx" を作成します。
creator1.OpenBookEx(@"C:\Out1.xlsx", @"C:\Book1.xlsx", out bookInfo1);
// 2 つ目のブック(C:\Book2.xlsx) をオーバーレイオープンし、"C:\Out2.xlsx" を作成します。
creator1.OpenBookEx(@"C:\Out2.xlsx", @"C:\Book2.xlsx", out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// PDF ファイルを "C:\Out1.pdf"、HTML ファイルを "C:\Out1.html" に出力し、1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1, @"C:\Out1.pdf", @"C:\Out1.html", false);
// PDF ファイルを "C:\Out2.pdf"、HTML ファイルを "C:\Out2.html" に出力し、2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2, @"C:\Out2.pdf", @"C:\Out2.html", false);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 1 つ目のブック(C:\Book1.xlsx) をオーバーレイオープンし、"C:\Out1.xlsx" を作成します。
Creator1.OpenBookEx("C:\Out1.xlsx", "C:\Book1.xlsx", bookInfo1)
' 2 つ目のブック(C:\Book2.xlsx) をオーバーレイオープンし、"C:\Out2.xlsx" を作成します。
Creator1.OpenBookEx("C:\Out2.xlsx", "C:\Book2.xlsx", bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' PDF ファイルを "C:\Out1.pdf"、HTML ファイルを "C:\Out1.html" に出力し、1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1, "C:\Out1.pdf", "C:\Out1.html", False)
' PDF ファイルを "C:\Out2.pdf"、HTML ファイルを "C:\Out2.html" に出力し、2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2, "C:\Out2.pdf", "C:\Out2.html", False)
関連項目

参照

Creator クラス
CloseBookEx オーバーロード


Creator.ColumnClear メソッド

CreatorColumnClear メソッド

オーバーロードの一覧
名前 | 説明
ColumnClear(Int32) | 列をクリアします。
ColumnClear(Int32, Int32) | 列をクリアします。
トップ
関連項目

参照

Creator クラス


Creator.ColumnClear メソッド (Int32)

CreatorColumnClear メソッド (Int32)

列をクリアします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnClear(
    int sx
)
Public Sub ColumnClear (
    sx As Integer
)

パラメーター

sx
型: SystemInt32
クリアする列(0～)を指定します。
例
C#
VB
コピー
// A 列をクリアします。
creator1.ColumnClear(0);
' A 列をクリアします。
Creator1.ColumnClear(0)
関連項目

参照

Creator クラス
ColumnClear オーバーロード


Creator.ColumnClear メソッド (Int32, Int32)

CreatorColumnClear メソッド (Int32, Int32)

列をクリアします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnClear(
    int sx,
    int count
)
Public Sub ColumnClear (
    sx As Integer,
    count As Integer
)

パラメーター

sx
型: SystemInt32
クリアする列(0～)を指定します。
count
型: SystemInt32
クリアする列数を指定します。
例
C#
VB
コピー
// A 列から 5 列分クリアします。
creator1.ColumnClear(0, 5);
' A 列から 5 列分クリアします。
Creator1.ColumnClear(0, 5)
関連項目

参照

Creator クラス
ColumnClear オーバーロード


Creator.ColumnCopy メソッド

CreatorColumnCopy メソッド

オーバーロードの一覧
名前 | 説明
ColumnCopy(Int32) | 列をコピーします。
ColumnCopy(Int32, Int32) | 列をコピーします。
トップ
関連項目

参照

Creator クラス


Creator.ColumnCopy メソッド (Int32)

CreatorColumnCopy メソッド (Int32)

列をコピーします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnCopy(
    int sx
)
Public Sub ColumnCopy (
    sx As Integer
)

パラメーター

sx
型: SystemInt32
コピーする列(0～)を指定します。
例
C#
VB
コピー
// A 列をメモリ上にコピーします。
creator1.ColumnCopy(0);
// コピーした列を B 列に貼り付けます。
creator1.ColumnPaste(1);
' A 列をメモリ上にコピーします。
Creator1.ColumnCopy(0)
' コピーした列を B 列に貼り付けます。
Creator1.ColumnPaste(1)
関連項目

参照

Creator クラス
ColumnCopy オーバーロード


Creator.ColumnCopy メソッド (Int32, Int32)

CreatorColumnCopy メソッド (Int32, Int32)

列をコピーします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnCopy(
    int sx,
    int dx
)
Public Sub ColumnCopy (
    sx As Integer,
    dx As Integer
)

パラメーター

sx
型: SystemInt32
コピーする列(0～)を指定します。
dx
型: SystemInt32
貼り付けする列を指定します。
例
C#
VB
コピー
// A 列をコピーして B 列に貼り付けます。
creator1.ColumnCopy(0, 1);
' A 列をコピーして B 列に貼り付けます。
Creator1.ColumnCopy(0, 1)
関連項目

参照

Creator クラス
ColumnCopy オーバーロード


Creator.ColumnDelete メソッド

CreatorColumnDelete メソッド

オーバーロードの一覧
名前 | 説明
ColumnDelete(Int32) | 列を削除します。
ColumnDelete(Int32, Int32) | 列を削除します。
トップ
関連項目

参照

Creator クラス


Creator.ColumnDelete メソッド (Int32)

CreatorColumnDelete メソッド (Int32)

列を削除します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnDelete(
    int sx
)
Public Sub ColumnDelete (
    sx As Integer
)

パラメーター

sx
型: SystemInt32
削除する列(0～)を指定します。
例
C#
VB
コピー
// A 列を削除します。
creator1.ColumnDelete(0);
' A 列を削除します。
Creator1.ColumnDelete(0)
関連項目

参照

Creator クラス
ColumnDelete オーバーロード


Creator.ColumnDelete メソッド (Int32, Int32)

CreatorColumnDelete メソッド (Int32, Int32)

列を削除します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnDelete(
    int sx,
    int count
)
Public Sub ColumnDelete (
    sx As Integer,
    count As Integer
)

パラメーター

sx
型: SystemInt32
削除する列(0～)を指定します。
count
型: SystemInt32
削除する列数を指定します。
例
C#
VB
コピー
// A 列から 5 列分削除します。
creator1.ColumnDelete(0, 5);
' A 列から 5 列分削除します。
Creator1.ColumnDelete(0, 5)
関連項目

参照

Creator クラス
ColumnDelete オーバーロード


Creator.ColumnInsert メソッド

CreatorColumnInsert メソッド

オーバーロードの一覧
名前 | 説明
ColumnInsert(Int32) | 列を挿入します。
ColumnInsert(Int32, Int32) | 列を挿入します。
トップ
関連項目

参照

Creator クラス


Creator.ColumnInsert メソッド (Int32)

CreatorColumnInsert メソッド (Int32)

列を挿入します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnInsert(
    int sx
)
Public Sub ColumnInsert (
    sx As Integer
)

パラメーター

sx
型: SystemInt32
挿入する列(0～)を指定します。
例
C#
VB
コピー
// A 列に 1 列分挿入します。
creator1.ColumnInsert(0);
' A 列に 1 列分挿入します。
Creator1.ColumnInsert(0)
関連項目

参照

Creator クラス
ColumnInsert オーバーロード


Creator.ColumnInsert メソッド (Int32, Int32)

CreatorColumnInsert メソッド (Int32, Int32)

列を挿入します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnInsert(
    int sx,
    int count
)
Public Sub ColumnInsert (
    sx As Integer,
    count As Integer
)

パラメーター

sx
型: SystemInt32
挿入する列(0～)を指定します。
count
型: SystemInt32
挿入する列数を指定します。
例
C#
VB
コピー
// A 列に 5 列分挿入します。
creator1.ColumnInsert(0, 5);
' A 列に 5 列分挿入します。
Creator1.ColumnInsert(0, 5)
関連項目

参照

Creator クラス
ColumnInsert オーバーロード


Creator.ColumnInsertCopied メソッド

CreatorColumnInsertCopied メソッド

オーバーロードの一覧
名前 | 説明
ColumnInsertCopied(Int32) | コピーした列を挿入します。
ColumnInsertCopied(Int32, Int32) | コピーした列を挿入します。
トップ
関連項目

参照

Creator クラス


Creator.ColumnInsertCopied メソッド (Int32)

CreatorColumnInsertCopied メソッド (Int32)

コピーした列を挿入します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnInsertCopied(
    int sx
)
Public Sub ColumnInsertCopied (
    sx As Integer
)

パラメーター

sx
型: SystemInt32
挿入する列(0～)を指定します。
例
C#
VB
コピー
// A 列をメモリ上にコピーします。
creator1.ColumnCopy(0);
// コピーした列を B 列に挿入します。
creator1.ColumnInsertCopied(1);
' A 列をメモリ上にコピーします。
Creator1.ColumnCopy(0)
' コピーした列を B 列に挿入します。
Creator1.ColumnInsertCopied(1)
関連項目

参照

Creator クラス
ColumnInsertCopied オーバーロード


Creator.ColumnInsertCopied メソッド (Int32, Int32)

CreatorColumnInsertCopied メソッド (Int32, Int32)

コピーした列を挿入します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnInsertCopied(
    int sx,
    int count
)
Public Sub ColumnInsertCopied (
    sx As Integer,
    count As Integer
)

パラメーター

sx
型: SystemInt32
挿入する列(0～)を指定します。
count
型: SystemInt32
挿入する列数を指定します。
例
C#
VB
コピー
// A 列をメモリ上にコピーします。
creator1.ColumnCopy(0);
// コピーした列を B 列に 5 列分挿入します。
creator1.ColumnInsertCopied(1, 5);
' A 列をメモリ上にコピーします。
Creator1.ColumnCopy(0)
' コピーした列を B 列に 5 列分挿入します。
Creator1.ColumnInsertCopied(1, 5)
関連項目

参照

Creator クラス
ColumnInsertCopied オーバーロード


Creator.ColumnPaste メソッド

CreatorColumnPaste メソッド

コピーした列を貼り付けます。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnPaste(
    int dx
)
Public Sub ColumnPaste (
    dx As Integer
)

パラメーター

dx
型: SystemInt32
貼り付けする列(0～)を指定します。
例
C#
VB
コピー
// A 列をメモリ上にコピーします。
creator1.ColumnCopy(0);
// コピーした列を B 列に貼り付けます。
creator1.ColumnPaste(1);
' A 列をメモリ上にコピーします。
Creator1.ColumnCopy(0)
' コピーした列を B 列に貼り付けます。
Creator1.ColumnPaste(1)
関連項目

参照

Creator クラス


Creator.CopySheet メソッド

CreatorCopySheet メソッド

シートをコピーします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void CopySheet(
    int sheetNo,
    int insertPosition,
    string sheetName
)
Public Sub CopySheet (
    sheetNo As Integer,
    insertPosition As Integer,
    sheetName As String
)

パラメーター

sheetNo
型: SystemInt32
コピーするシートの番号(0～)を指定します。
insertPosition
型: SystemInt32
コピー先のシートの位置(0～)を指定します。
sheetName
型: SystemString
コピー先のシート名を指定します。
例
C#
VB
コピー
// 1 シート目をコピーし、シート名を "コピー先シート" に設定して 2 シート目に挿入します。
creator1.CopySheet(0, 1, "コピー先シート");
' 1 シート目をコピーし、シート名を "コピー先シート" に設定して 2 シート目に挿入します。
Creator1.CopySheet(0, 1, "コピー先シート")
関連項目

参照

Creator クラス


Creator.CreateBook メソッド

CreatorCreateBook メソッド

オーバーロードの一覧
名前 | 説明
CreateBook(Stream, Int32, xlsVersion) | Xls 形式のブックを新規作成します。
CreateBook(Stream, Int32, xlsxVersion) | Xlsx 形式のブックを新規作成します。
CreateBook(String, Int32, xlsVersion) | Xls 形式のブックを新規作成します。
CreateBook(String, Int32, xlsxVersion) | Xlsx 形式のブックを新規作成します。
トップ
関連項目

参照

Creator クラス


Creator.CreateBook メソッド (Stream, Int32, xlsVersion)

CreatorCreateBook メソッド (Stream, Int32, xlsVersion)

Xls 形式のブックを新規作成します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int CreateBook(
    Stream outStream,
    int sheetCount,
    xlsVersion version
)
Public Function CreateBook (
    outStream As Stream,
    sheetCount As Integer,
    version As xlsVersion
) As Integer

パラメーター

outStream
型: System.IOStream
作成するブックのストリームを指定します。
sheetCount
型: SystemInt32
作成するブックのシート数を指定します。
version
型: AdvanceSoftware.ExcelCreatorxlsVersion
作成するブックのバージョンを指定します。

戻り値

型: Int32
ブックの新規作成に成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
// Excel ファイル(シート数 : 1、バージョン : 2003)を新規作成し、outStream に出力します。
System.IO.MemoryStream outStream = new System.IO.MemoryStream();
creator1.CreateBook(outStream, 1, AdvanceSoftware.ExcelCreator.xlsVersion.ver2003);
creator1.CloseBook(true);
' Excel ファイル(シート数 : 1、バージョン : 2003)を新規作成し、outStream に出力します。
Dim outStream As New System.IO.MemoryStream()
Creator1.CreateBook(outStream, 1, AdvanceSoftware.ExcelCreator.xlsVersion.ver2003)
Creator1.CloseBook(True)
関連項目

参照

Creator クラス
CreateBook オーバーロード


Creator.CreateBook メソッド (Stream, Int32, xlsxVersion)

CreatorCreateBook メソッド (Stream, Int32, xlsxVersion)

Xlsx 形式のブックを新規作成します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int CreateBook(
    Stream outStream,
    int sheetCount,
    xlsxVersion version
)
Public Function CreateBook (
    outStream As Stream,
    sheetCount As Integer,
    version As xlsxVersion
) As Integer

パラメーター

outStream
型: System.IOStream
作成するブックのストリームを指定します。
sheetCount
型: SystemInt32
作成するブックのシート数を指定します。
version
型: AdvanceSoftware.ExcelCreatorxlsxVersion
作成するブックのバージョンを指定します。

戻り値

型: Int32
ブックの新規作成に成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
// Excel ファイル(シート数 : 1、バージョン : 2021)を新規作成し、outStream に出力します。
System.IO.MemoryStream outStream = new System.IO.MemoryStream();
creator1.CreateBook(outStream, 1, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021);
creator1.CloseBook(true);
' Excel ファイル(シート数 : 1、バージョン : 2021)を新規作成し、outStream に出力します。
Dim outStream As New System.IO.MemoryStream()
Creator1.CreateBook(outStream, 1, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021)
Creator1.CloseBook(True)
関連項目

参照

Creator クラス
CreateBook オーバーロード


Creator.CreateBook メソッド (String, Int32, xlsVersion)

CreatorCreateBook メソッド (String, Int32, xlsVersion)

Xls 形式のブックを新規作成します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int CreateBook(
    string fileName,
    int sheetCount,
    xlsVersion version
)
Public Function CreateBook (
    fileName As String,
    sheetCount As Integer,
    version As xlsVersion
) As Integer

パラメーター

fileName
型: SystemString
作成するブックのファイル名を指定します。
sheetCount
型: SystemInt32
作成するブックのシート数を指定します。
version
型: AdvanceSoftware.ExcelCreatorxlsVersion
作成するブックのバージョンを指定します。

戻り値

型: Int32
ブックの新規作成に成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
// Excel ファイル(シート数 : 1、バージョン : 2003)を新規作成し、"C:\Out1.xls" に出力します。
creator1.CreateBook(@"C:\Out1.xls", 1, AdvanceSoftware.ExcelCreator.xlsVersion.ver2003);
creator1.CloseBook(true);
' Excel ファイル(シート数 : 1、バージョン : 2003)を新規作成し、"C:\Out1.xls" に出力します。
Creator1.CreateBook("C:\Out1.xls", 1, AdvanceSoftware.ExcelCreator.xlsVersion.ver2003)
Creator1.CloseBook(True)
関連項目

参照

Creator クラス
CreateBook オーバーロード


Creator.CreateBook メソッド (String, Int32, xlsxVersion)

CreatorCreateBook メソッド (String, Int32, xlsxVersion)

Xlsx 形式のブックを新規作成します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int CreateBook(
    string fileName,
    int sheetCount,
    xlsxVersion version
)
Public Function CreateBook (
    fileName As String,
    sheetCount As Integer,
    version As xlsxVersion
) As Integer

パラメーター

fileName
型: SystemString
作成するブックのファイル名を指定します。
sheetCount
型: SystemInt32
作成するブックのシート数を指定します。
version
型: AdvanceSoftware.ExcelCreatorxlsxVersion
作成するブックのバージョンを指定します。

戻り値

型: Int32
ブックの新規作成に成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
// Excel ファイル(シート数 : 1、バージョン : 2021)を新規作成し、"C:\Out1.xlsx" に出力します。
creator1.CreateBook(@"C:\Out1.xlsx", 1, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021);
creator1.CloseBook(true);
' Excel ファイル(シート数 : 1、バージョン : 2021)を新規作成し、"C:\Out1.xlsx" に出力します。
Creator1.CreateBook("C:\Out1.xlsx", 1, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021)
Creator1.CloseBook(True)
関連項目

参照

Creator クラス
CreateBook オーバーロード


Creator.CreateBookEx メソッド

CreatorCreateBookEx メソッド

オーバーロードの一覧
名前 | 説明
CreateBookEx(Stream, Int32, xlsVersion, Object) | Xls 形式のブックを新規作成します。
CreateBookEx(Stream, Int32, xlsxVersion, Object) | Xlsx 形式のブックを新規作成します。
CreateBookEx(String, Int32, xlsVersion, Object) | Xls 形式のブックを新規作成します。
CreateBookEx(String, Int32, xlsxVersion, Object) | Xlsx 形式のブックを新規作成します。
トップ
関連項目

参照

Creator クラス


Creator.CreateBookEx メソッド (Stream, Int32, xlsVersion, Object)

CreatorCreateBookEx メソッド (Stream, Int32, xlsVersion, Object)

Xls 形式のブックを新規作成します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int CreateBookEx(
    Stream outStream,
    int sheetCount,
    xlsVersion version,
    out Object bookInfo
)
Public Function CreateBookEx (
    outStream As Stream,
    sheetCount As Integer,
    version As xlsVersion,
    <OutAttribute> ByRef bookInfo As Object
) As Integer

パラメーター

outStream
型: System.IOStream
作成するブックのストリームを指定します。
sheetCount
型: SystemInt32
作成するブックのシート数を指定します。
version
型: AdvanceSoftware.ExcelCreatorxlsVersion
作成するブックのバージョンを指定します。
bookInfo
型: SystemObject
ブックを識別するためのハンドルを受け取る object 型への参照を指定します。

戻り値

型: Int32
ブックの新規作成に成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 1 つ目のブック(シート数 : 1、バージョン : 2003)を新規作成し、outStream1 に出力します。
System.IO.MemoryStream outStream1 = new System.IO.MemoryStream();
creator1.CreateBookEx(outStream1, 1, AdvanceSoftware.ExcelCreator.xlsVersion.ver2003, out bookInfo1);
// 2 つ目のブック(シート数 : 2、バージョン : 2003)を新規作成し、outStream2 に出力します。
System.IO.MemoryStream outStream2 = new System.IO.MemoryStream();
creator1.CreateBookEx(outStream2, 2, AdvanceSoftware.ExcelCreator.xlsVersion.ver2003, out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 1 つ目のブック(シート数 : 1、バージョン : 2003)を新規作成し、outStream1 に出力します。
Dim outStream1 As New System.IO.MemoryStream()
Creator1.CreateBookEx(outStream1, 1, AdvanceSoftware.ExcelCreator.xlsVersion.ver2003, bookInfo1)
' 2 つ目のブック(シート数 : 2、バージョン : 2003)を新規作成し、outStream2 に出力します。
Dim outStream2 As New System.IO.MemoryStream()
Creator1.CreateBookEx(outStream2, 2, AdvanceSoftware.ExcelCreator.xlsVersion.ver2003, bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス
CreateBookEx オーバーロード


Creator.CreateBookEx メソッド (Stream, Int32, xlsxVersion, Object)

CreatorCreateBookEx メソッド (Stream, Int32, xlsxVersion, Object)

Xlsx 形式のブックを新規作成します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int CreateBookEx(
    Stream outStream,
    int sheetCount,
    xlsxVersion version,
    out Object bookInfo
)
Public Function CreateBookEx (
    outStream As Stream,
    sheetCount As Integer,
    version As xlsxVersion,
    <OutAttribute> ByRef bookInfo As Object
) As Integer

パラメーター

outStream
型: System.IOStream
作成するブックのストリームを指定します。
sheetCount
型: SystemInt32
作成するブックのシート数を指定します。
version
型: AdvanceSoftware.ExcelCreatorxlsxVersion
作成するブックのバージョンを指定します。
bookInfo
型: SystemObject
ブックを識別するためのハンドルを受け取る object 型への参照を指定します。

戻り値

型: Int32
ブックの新規作成に成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 1 つ目のブック(シート数 : 1、バージョン : 2021)を新規作成し、outStream1 に出力します。
System.IO.MemoryStream outStream1 = new System.IO.MemoryStream();
creator1.CreateBookEx(outStream1, 1, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021, out bookInfo1);
// 2 つ目のブック(シート数 : 2、バージョン : 2021)を新規作成し、outStream2 に出力します。
System.IO.MemoryStream outStream2 = new System.IO.MemoryStream();
creator1.CreateBookEx(outStream2, 2, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021, out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 1 つ目のブック(シート数 : 1、バージョン : 2021)を新規作成し、outStream1 に出力します。
Dim outStream1 As New System.IO.MemoryStream()
Creator1.CreateBookEx(outStream1, 1, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021, bookInfo1)
' 2 つ目のブック(シート数 : 2、バージョン : 2021)を新規作成し、outStream2 に出力します。
Dim outStream2 As New System.IO.MemoryStream()
Creator1.CreateBookEx(outStream2, 2, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021, bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス
CreateBookEx オーバーロード


Creator.CreateBookEx メソッド (String, Int32, xlsVersion, Object)

CreatorCreateBookEx メソッド (String, Int32, xlsVersion, Object)

Xls 形式のブックを新規作成します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int CreateBookEx(
    string fileName,
    int sheetCount,
    xlsVersion version,
    out Object bookInfo
)
Public Function CreateBookEx (
    fileName As String,
    sheetCount As Integer,
    version As xlsVersion,
    <OutAttribute> ByRef bookInfo As Object
) As Integer

パラメーター

fileName
型: SystemString
作成するブックのファイル名を指定します。
sheetCount
型: SystemInt32
作成するブックのシート数を指定します。
version
型: AdvanceSoftware.ExcelCreatorxlsVersion
作成するブックのバージョンを指定します。
bookInfo
型: SystemObject
ブックを識別するためのハンドルを受け取る object 型への参照を指定します。

戻り値

型: Int32
ブックの新規作成に成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 1 つ目のブック(シート数 : 1、バージョン : 2003)を新規作成し、"C:\Out1.xls" に出力します。
creator1.CreateBookEx(@"C:\Out1.xls", 1, AdvanceSoftware.ExcelCreator.xlsVersion.ver2003, out bookInfo1);
// 2 つ目のブック(シート数 : 2、バージョン : 2003)を新規作成し、"C:\Out2.xls" に出力します。
creator1.CreateBookEx(@"C:\Out2.xls", 2, AdvanceSoftware.ExcelCreator.xlsVersion.ver2003, out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 1 つ目のブック(シート数 : 1、バージョン : 2003)を新規作成し、"C:\Out1.xls" に出力します。
Creator1.CreateBookEx("C:\Out1.xls", 1, AdvanceSoftware.ExcelCreator.xlsVersion.ver2003, bookInfo1)
' 2 つ目のブック(シート数 : 2、バージョン : 2003)を新規作成し、"C:\Out2.xls" に出力します。
Creator1.CreateBookEx("C:\Out2.xls", 2, AdvanceSoftware.ExcelCreator.xlsVersion.ver2003, bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス
CreateBookEx オーバーロード


Creator.CreateBookEx メソッド (String, Int32, xlsxVersion, Object)

CreatorCreateBookEx メソッド (String, Int32, xlsxVersion, Object)

Xlsx 形式のブックを新規作成します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int CreateBookEx(
    string fileName,
    int sheetCount,
    xlsxVersion version,
    out Object bookInfo
)
Public Function CreateBookEx (
    fileName As String,
    sheetCount As Integer,
    version As xlsxVersion,
    <OutAttribute> ByRef bookInfo As Object
) As Integer

パラメーター

fileName
型: SystemString
作成するブックのファイル名を指定します。
sheetCount
型: SystemInt32
作成するブックのシート数を指定します。
version
型: AdvanceSoftware.ExcelCreatorxlsxVersion
作成するブックのバージョンを指定します。
bookInfo
型: SystemObject
ブックを識別するためのハンドルを受け取る object 型への参照を指定します。

戻り値

型: Int32
ブックの新規作成に成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 1 つ目のブック(シート数 : 1、バージョン : 2021)を新規作成し、"C:\Out1.xlsx" に出力します。
creator1.CreateBookEx(@"C:\Out1.xlsx", 1, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021, out bookInfo1);
// 2 つ目のブック(シート数 : 2、バージョン : 2021)を新規作成し、"C:\Out2.xlsx" に出力します。
creator1.CreateBookEx(@"C:\Out2.xlsx", 2, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021, out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 1 つ目のブック(シート数 : 1、バージョン : 2021)を新規作成し、"C:\Out1.xlsx" に出力します。
Creator1.CreateBookEx("C:\Out1.xlsx", 1, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021, bookInfo1)
' 2 つ目のブック(シート数 : 2、バージョン : 2021)を新規作成し、"C:\Out2.xlsx" に出力します。
Creator1.CreateBookEx("C:\Out2.xlsx", 2, AdvanceSoftware.ExcelCreator.xlsxVersion.ver2021, bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス
CreateBookEx オーバーロード


Creator.DeleteSheet メソッド

CreatorDeleteSheet メソッド

シートを削除します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void DeleteSheet(
    int sheetNo,
    int deleteCount
)
Public Sub DeleteSheet (
    sheetNo As Integer,
    deleteCount As Integer
)

パラメーター

sheetNo
型: SystemInt32
削除するシートの番号(0～)を指定します。
deleteCount
型: SystemInt32
削除するシート数を指定します。
例
C#
VB
コピー
// 1 シート目から 2 シート分削除します。
creator1.DeleteSheet(0, 2);
' 1 シート目から 2 シート分削除します。
Creator1.DeleteSheet(0, 2)
関連項目

参照

Creator クラス


Creator.Footer メソッド

CreatorFooter メソッド

フッターを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Footer(
    string left,
    string center,
    string right
)
Public Sub Footer (
    left As String,
    center As String,
    right As String
)

パラメーター

left
型: SystemString
左フッターを設定します。
center
型: SystemString
中央フッターを設定します。
right
型: SystemString
右フッターを設定します。
解説
下記の書式コードに対応しています。
書式コード | 内容
&L | 左詰
&C | 中央揃え
&R | 右詰
&E | 二重下線
&X | 上付き文字
&Y | 下付き文字
&B | ボールド
&I | イタリック
&U | 下線
&S | 取消線
&P | ページ番号
&P+99 | ページ番号に値を加えて表示
&P-99 | ページ番号に値を引いて表示
&D | 現在の日付
&T | 現在の時刻
&A | シート見出し
&& | & (アンパサンド) を表示
&"フォント" | フォントを設定
&99 | フォントサイズを設定
&N | 全体のページ数
例
C#
VB
コピー
// 右ヘッダーに "現在の日付" を設定します。
creator1.Header("", "", "&D");
// 中央フッターに "ページ番号/全体ページ数" を設定します。
creator1.Footer("", "&P/&N", "");
' 右ヘッダーに "現在の日付" を設定します。
Creator1.Header("", "", "&D")
' 中央フッターに "ページ番号/全体ページ数" を設定します。
Creator1.Footer("", "&P/&N", "")
関連項目

参照

Creator クラス


Creator.Footer2 メソッド

CreatorFooter2 メソッド

フッターを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Footer2(
    string left,
    string center,
    string right,
    HeaderFooterType headerFooterType
)
Public Sub Footer2 (
    left As String,
    center As String,
    right As String,
    headerFooterType As HeaderFooterType
)

パラメーター

left
型: SystemString
左フッターを設定します。
center
型: SystemString
中央フッターを設定します。
right
型: SystemString
右フッターを設定します。
headerFooterType
型: AdvanceSoftware.ExcelCreatorHeaderFooterType
フッターのタイプを指定します。
解説
Excel 2007 以降のヘッダー/フッターにあるオプションを指定してフッターを設定します。 Xlsx 形式のみ対応しています。
例
C#
VB
コピー
// ヘッダー/フッターの設定を先頭ページのみ別指定にします。
creator1.HeaderFooterMode = AdvanceSoftware.ExcelCreator.HeaderFooterMode.FirstPage;
// 先頭ページの中央ヘッダーに文字列 "先頭ページのヘッダー" を設定します。
creator1.Header2("", "先頭ページのヘッダー", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.First);
// 先頭ページの中央フッターに文字列 "先頭ページのフッター" を設定します。
creator1.Footer2("", "先頭ページのフッター", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.First);
// 標準ページの中央ヘッダーに文字列 "標準ページのヘッダー" を設定します。
creator1.Header2("", "標準ページのヘッダー", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.Normal);
// 標準ページの中央フッターに文字列 "標準ページのフッター" を設定します。
creator1.Footer2("", "標準ページのフッター", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.Normal);
' ヘッダー/フッターの設定を先頭ページのみ別指定にします。
Creator1.HeaderFooterMode = AdvanceSoftware.ExcelCreator.HeaderFooterMode.FirstPage
' 先頭ページの中央ヘッダーに文字列 "先頭ページのヘッダー" を設定します。
Creator1.Header2("", "先頭ページのヘッダー", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.First)
' 先頭ページの中央フッターに文字列 "先頭ページのフッター" を設定します。
Creator1.Footer2("", "先頭ページのフッター", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.First)
' 標準ページの中央ヘッダーに文字列 "標準ページのヘッダー" を設定します。
Creator1.Header2("", "標準ページのヘッダー", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.Normal)
' 標準ページの中央フッターに文字列 "標準ページのフッター" を設定します。
Creator1.Footer2("", "標準ページのフッター", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.Normal)
関連項目

参照

Creator クラス


Creator.GetChartCount メソッド

CreatorGetChartCount メソッド

グラフの数を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int GetChartCount()
Public Function GetChartCount As Integer

戻り値

型: Int32
グラフの数
例
C#
VB
コピー
// グラフの数を取得します。
int chartCount = creator1.GetChartCount();
' グラフの数を取得します。
Dim chartCount = Creator1.GetChartCount()
関連項目

参照

Creator クラス


Creator.GetChartData メソッド

CreatorGetChartData メソッド

グラフ情報を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartData GetChartData(
    int index,
    int resolution
)
Public Function GetChartData (
    index As Integer,
    resolution As Integer
) As ChartData

パラメーター

index
型: SystemInt32
取得するグラフのインデックスを設定します。
resolution
型: SystemInt32
取得するグラフイメージの解像度を設定します。(Excel では 330dpi)

戻り値

型: ChartData
グラフ情報
例
C#
VB
コピー
// グラフの数を取得
int chartCount = creator1.GetChartCount();
for (int i = 0; i < chartCount; i++)
{
    // グラフ情報を取得
    ChartData chartData = creator1.GetChartData(i, 330);
    // ChartData からの Image オブジェクト生成処理は
    // 独自に実装する必要があります。
    // ChartCreator クラスをサンプルとして用意しています。
    Image chartImage = ChartCreator.GetChartImage(chartData);
    creator1.Pos(chartData.col, chartData.row).Canvas.AddChart(chartImage, chartData);
}
' グラフの数を取得
Dim chartCount = Creator1.GetChartCount()
For i = 0 To chartCount
    ' グラフ情報を取得
    Dim chartData = Creator1.GetChartData(i, 330)
    ' ChartData からの Image オブジェクト生成処理は
    ' 独自に実装する必要があります。
    ' ChartCreator クラスをサンプルとして用意しています。
    Dim chartImage As Image = ChartCreator.GetChartImage(chartData)
    Creator1.Pos(chartData.col, chartData.row).Canvas.AddChart(chartImage, chartData)
Next
関連項目

参照

Creator クラス


Creator.GetHtmlText メソッド

CreatorGetHtmlText メソッド

オーバーロードの一覧
名前 | 説明
GetHtmlText(HtmlOutputType) | HTML テキストを取得します。
GetHtmlText(String, HtmlOutputType) | HTML テキストを取得します。
トップ
関連項目

参照

Creator クラス


Creator.GetHtmlText メソッド (HtmlOutputType)

CreatorGetHtmlText メソッド (HtmlOutputType)

HTML テキストを取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string GetHtmlText(
    HtmlOutputType htmlOutputType = HtmlOutputType.Table
)
Public Function GetHtmlText (
    Optional htmlOutputType As HtmlOutputType = HtmlOutputType.Table
) As String

パラメーター

htmlOutputType (Optional)
型: AdvanceSoftware.ExcelCreatorHtmlOutputType
取得する HTML テキストの形式(テーブル/HTML)

戻り値

型: String
HTML テキストを返します。
例
C#
VB
コピー
// HTML テキストを取得します。
string html = creator1.GetHtmlText(HtmlOutputType.Table);
' HTML テキストを取得します。
Dim html As String = Creator1.GetHtmlText(HtmlOutputType.Table)
関連項目

参照

Creator クラス
GetHtmlText オーバーロード


Creator.GetHtmlText メソッド (String, HtmlOutputType)

CreatorGetHtmlText メソッド (String, HtmlOutputType)

HTML テキストを取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string GetHtmlText(
    string tableName,
    HtmlOutputType htmlOutputType = HtmlOutputType.Table
)
Public Function GetHtmlText (
    tableName As String,
    Optional htmlOutputType As HtmlOutputType = HtmlOutputType.Table
) As String

パラメーター

tableName
型: SystemString
テーブル名を指定します。
htmlOutputType (Optional)
型: AdvanceSoftware.ExcelCreatorHtmlOutputType
取得する HTML テキストの形式(テーブル/HTML)

戻り値

型: String
HTML テキストを返します。
例
C#
VB
コピー
// テーブル名を "table1" に指定して HTML テキストを取得します。
string html = creator1.GetHtmlText("table1", HtmlOutputType.Table);
' テーブル名を "table1" に指定して HTML テキストを取得します。
Dim html As String = Creator1.GetHtmlText("table1", HtmlOutputType.Table)
関連項目

参照

Creator クラス
GetHtmlText オーバーロード


Creator.GetMaxArea メソッド

CreatorGetMaxArea メソッド

オーバーロードの一覧
名前 | 説明
GetMaxArea | データ、または、属性の終了座標を取得します。
GetMaxArea(MaxEndPoint) | データ、または、属性の終了座標を取得します。
トップ
関連項目

参照

Creator クラス


Creator.GetMaxArea メソッド

CreatorGetMaxArea メソッド

データ、または、属性の終了座標を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Point GetMaxArea()
Public Function GetMaxArea As Point

戻り値

型: Point
データ、または、属性の終了座標。
例
C#
VB
コピー
// データ、属性が設定されたセルの最大行と最大列の交点座標を取得します。
System.Drawing.Point maxArea = creator1.GetMaxArea();
' データ、属性が設定されたセルの最大行と最大列の交点座標を取得します。
Dim maxArea As System.Drawing.Point = Creator1.GetMaxArea()
関連項目

参照

Creator クラス
GetMaxArea オーバーロード


Creator.GetMaxArea メソッド (MaxEndPoint)

CreatorGetMaxArea メソッド (MaxEndPoint)

データ、または、属性の終了座標を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Point GetMaxArea(
    MaxEndPoint maxEndPoint
)
Public Function GetMaxArea (
    maxEndPoint As MaxEndPoint
) As Point

パラメーター

maxEndPoint
型: AdvanceSoftware.ExcelCreatorMaxEndPoint
取得する座標の種別を指定します。

戻り値

型: Point
データ、または、属性の終了座標。
例
C#
VB
コピー
// データ、属性が設定されたセルの最終座標を取得します。
System.Drawing.Point maxArea = creator1.GetMaxArea(AdvanceSoftware.ExcelCreator.MaxEndPoint.EndPoint);
' データ、属性が設定されたセルの最終座標を取得します。
Dim maxArea As System.Drawing.Point = Creator1.GetMaxArea(AdvanceSoftware.ExcelCreator.MaxEndPoint.EndPoint)
関連項目

参照

Creator クラス
GetMaxArea オーバーロード


Creator.GetMaxData メソッド

CreatorGetMaxData メソッド

オーバーロードの一覧
名前 | 説明
GetMaxData | データの終了座標を取得します。
GetMaxData(MaxEndPoint) | データの終了座標を取得します。
トップ
関連項目

参照

Creator クラス


Creator.GetMaxData メソッド

CreatorGetMaxData メソッド

データの終了座標を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Point GetMaxData()
Public Function GetMaxData As Point

戻り値

型: Point
データの終了座標。
例
C#
VB
コピー
// データが設定されたセルの最終座標を取得します。
System.Drawing.Point maxData = creator1.GetMaxData();
' データが設定されたセルの最終座標を取得します。
Dim maxData As System.Drawing.Point = Creator1.GetMaxData()
関連項目

参照

Creator クラス
GetMaxData オーバーロード


Creator.GetMaxData メソッド (MaxEndPoint)

CreatorGetMaxData メソッド (MaxEndPoint)

データの終了座標を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Point GetMaxData(
    MaxEndPoint maxEndPoint
)
Public Function GetMaxData (
    maxEndPoint As MaxEndPoint
) As Point

パラメーター

maxEndPoint
型: AdvanceSoftware.ExcelCreatorMaxEndPoint
取得する座標の種別を指定します。

戻り値

型: Point
データの終了座標。
例
C#
VB
コピー
// データが設定されたセルの最大行と最大列の交点座標を取得します。
System.Drawing.Point maxData = creator1.GetMaxData(AdvanceSoftware.ExcelCreator.MaxEndPoint.MaxPoint);
' データが設定されたセルの最大行と最大列の交点座標を取得します。
Dim maxData As System.Drawing.Point = Creator1.GetMaxData(AdvanceSoftware.ExcelCreator.MaxEndPoint.MaxPoint)
関連項目

参照

Creator クラス
GetMaxData オーバーロード


Creator.GetMergeCells メソッド

CreatorGetMergeCells メソッド

結合セルの座標一覧を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public CellPositionCollection GetMergeCells()
Public Function GetMergeCells As CellPositionCollection

戻り値

型: CellPositionCollection
セルの座標を示す CellPositionCollection。
例
C#
VB
コピー
// 結合セルの座標一覧を取得します。
AdvanceSoftware.ExcelCreator.CellPositionCollection mergeCells;
mergeCells = creator1.GetMergeCells();
foreach (AdvanceSoftware.ExcelCreator.CellPosition mergeCell in mergeCells)
{
    // 結合セル毎で処理を行うことができます。
    // ...
}
' 結合セルの座標一覧を取得します。
Dim mergeCells As AdvanceSoftware.ExcelCreator.CellPositionCollection
mergeCells = Creator1.GetMergeCells()
For Each mergeCell As AdvanceSoftware.ExcelCreator.CellPosition In mergeCells
    ' 結合セル毎で処理を行うことができます。
    ' ...
Next
関連項目

参照

Creator クラス


Creator.GetNamePos メソッド

CreatorGetNamePos メソッド

指定したセル名の座標(0～)を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Point GetNamePos(
    string cellName
)
Public Function GetNamePos (
    cellName As String
) As Point

パラメーター

cellName
型: SystemString
セル名を指定します。

戻り値

型: Point
セル名の座標(0～)。
例
C#
VB
コピー
// セル名 "NAMAE1" の座標を取得します。
System.Drawing.Point namePos = creator1.GetNamePos("NAMAE1");
' セル名 "NAMAE1" の座標を取得します。
Dim namePos As System.Drawing.Point = Creator1.GetNamePos("NAMAE1")
関連項目

参照

Creator クラス


Creator.GetRangeAddress メソッド

CreatorGetRangeAddress メソッド

指定したセル名の座標一覧を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public CellPositionCollection GetRangeAddress(
    string name
)
Public Function GetRangeAddress (
    name As String
) As CellPositionCollection

パラメーター

name
型: SystemString
セル名を指定します。

戻り値

型: CellPositionCollection
セルの座標を示す CellPositionCollection。
例
C#
VB
コピー
// セル名 "NAMAE1" の座標一覧を取得します。
AdvanceSoftware.ExcelCreator.CellPositionCollection rangeAddress;
rangeAddress = creator1.GetRangeAddress("NAMAE1");
foreach (AdvanceSoftware.ExcelCreator.CellPosition cellPosition in rangeAddress)
{
    // セル名 "NAMAE1" の参照範囲毎で処理を行うことができます。
    // ...
}
' セル名 "NAMAE1" の座標一覧を取得します。
Dim rangeAddress As AdvanceSoftware.ExcelCreator.CellPositionCollection
rangeAddress = Creator1.GetRangeAddress("NAMAE1")
For Each cellPosition As AdvanceSoftware.ExcelCreator.CellPosition In rangeAddress
    ' セル名 "NAMAE1" の参照範囲毎で処理を行うことができます。
    ' ...
Next
関連項目

参照

Creator クラス


Creator.GetVarNamePos メソッド

CreatorGetVarNamePos メソッド

指定した変数名の座標(0～)を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Point GetVarNamePos(
    string varName,
    int index
)
Public Function GetVarNamePos (
    varName As String,
    index As Integer
) As Point

パラメーター

varName
型: SystemString
変数名を指定します。
index
型: SystemInt32
変数名が複数ある場合、取得する変数名のインデックス(0～)を指定します。

戻り値

型: Point
変数名の座標(0～)。
例
C#
VB
コピー
// 変数名 "**HENSU1" の 1 番目の座標を取得します。
System.Drawing.Point varNamePos = creator1.GetVarNamePos("**HENSU1", 0);
' 変数名 "**HENSU1" の 1 番目の座標を取得します。
Dim varNamePos As System.Drawing.Point = Creator1.GetVarNamePos("**HENSU1", 0)
関連項目

参照

Creator クラス


Creator.Header メソッド

CreatorHeader メソッド

ヘッダーを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Header(
    string left,
    string center,
    string right
)
Public Sub Header (
    left As String,
    center As String,
    right As String
)

パラメーター

left
型: SystemString
左ヘッダーを設定します。
center
型: SystemString
中央ヘッダーを設定します。
right
型: SystemString
右ヘッダーを設定します。
解説
下記の書式コードに対応しています。
書式コード | 内容
&L | 左詰
&C | 中央揃え
&R | 右詰
&E | 二重下線
&X | 上付き文字
&Y | 下付き文字
&B | ボールド
&I | イタリック
&U | 下線
&S | 取消線
&P | ページ番号
&P+99 | ページ番号に値を加えて表示
&P-99 | ページ番号に値を引いて表示
&D | 現在の日付
&T | 現在の時刻
&A | シート見出し
&& | & (アンパサンド) を表示
&"フォント" | フォントを設定
&99 | フォントサイズを設定
&N | 全体のページ数
例
C#
VB
コピー
// 右ヘッダーに "現在の日付" を設定します。
creator1.Header("", "", "&D");
// 中央フッターに "ページ番号/全体ページ数" を設定します。
creator1.Footer("", "&P/&N", "");
' 右ヘッダーに "現在の日付" を設定します。
Creator1.Header("", "", "&D")
' 中央フッターに "ページ番号/全体ページ数" を設定します。
Creator1.Footer("", "&P/&N", "")
関連項目

参照

Creator クラス


Creator.Header2 メソッド

CreatorHeader2 メソッド

ヘッダーを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Header2(
    string left,
    string center,
    string right,
    HeaderFooterType headerFooterType
)
Public Sub Header2 (
    left As String,
    center As String,
    right As String,
    headerFooterType As HeaderFooterType
)

パラメーター

left
型: SystemString
左ヘッダーを設定します。
center
型: SystemString
中央ヘッダーを設定します。
right
型: SystemString
右ヘッダーを設定します。
headerFooterType
型: AdvanceSoftware.ExcelCreatorHeaderFooterType
ヘッダーのタイプを指定します。
解説
Excel 2007 以降のヘッダー/フッターにあるオプションを指定してヘッダーを設定します。
例
C#
VB
コピー
// ヘッダー/フッターの設定を先頭ページのみ別指定にします。
creator1.HeaderFooterMode = AdvanceSoftware.ExcelCreator.HeaderFooterMode.FirstPage;
// 先頭ページの中央ヘッダーに文字列 "先頭ページのヘッダー" を設定します。
creator1.Header2("", "先頭ページのヘッダー", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.First);
// 先頭ページの中央フッターに文字列 "先頭ページのフッター" を設定します。
creator1.Footer2("", "先頭ページのフッター", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.First);
// 標準ページの中央ヘッダーに文字列 "標準ページのヘッダー" を設定します。
creator1.Header2("", "標準ページのヘッダー", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.Normal);
// 標準ページの中央フッターに文字列 "標準ページのフッター" を設定します。
creator1.Footer2("", "標準ページのフッター", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.Normal);
' ヘッダー/フッターの設定を先頭ページのみ別指定にします。
Creator1.HeaderFooterMode = AdvanceSoftware.ExcelCreator.HeaderFooterMode.FirstPage
' 先頭ページの中央ヘッダーに文字列 "先頭ページのヘッダー" を設定します。
Creator1.Header2("", "先頭ページのヘッダー", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.First)
' 先頭ページの中央フッターに文字列 "先頭ページのフッター" を設定します。
Creator1.Footer2("", "先頭ページのフッター", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.First)
' 標準ページの中央ヘッダーに文字列 "標準ページのヘッダー" を設定します。
Creator1.Header2("", "標準ページのヘッダー", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.Normal)
' 標準ページの中央フッターに文字列 "標準ページのフッター" を設定します。
Creator1.Footer2("", "標準ページのフッター", "", AdvanceSoftware.ExcelCreator.HeaderFooterType.Normal)
関連項目

参照

Creator クラス


Creator.Margin メソッド

CreatorMargin メソッド

余白を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Margin(
    int left,
    int right,
    int top,
    int bottom,
    int header,
    int footer
)
Public Sub Margin (
    left As Integer,
    right As Integer,
    top As Integer,
    bottom As Integer,
    header As Integer,
    footer As Integer
)

パラメーター

left
型: SystemInt32
左余白を設定します。
right
型: SystemInt32
右余白を設定します。
top
型: SystemInt32
上余白を設定します。
bottom
型: SystemInt32
下余白を設定します。
header
型: SystemInt32
ヘッダーの余白を設定します。
footer
型: SystemInt32
フッターの余白を設定します。
解説
-1 を指定した場合はオーバーレイ元ファイルの設定値が適用されます。
例
C#
VB
コピー
// 余白 (左：10mm、右：10mm、上：10mm、下：10mm、ヘッダー：5mm、フッター：5mm) を設定します。
creator1.Margin(10, 10, 10, 10, 5, 5);
' 余白 (左：10mm、右：10mm、上：10mm、下：10mm、ヘッダー：5mm、フッター：5mm) を設定します。
Creator1.Margin(10, 10, 10, 10, 5, 5)
関連項目

参照

Creator クラス


Creator.OpenBook メソッド

CreatorOpenBook メソッド

オーバーロードの一覧
名前 | 説明
OpenBook(Stream, String) | ブックをオープンします。
OpenBook(String, String) | ブックをオープンします。
OpenBook(Stream, String, String) | ブックをオープンします。
OpenBook(String, String, String) | ブックをオープンします。
トップ
関連項目

参照

Creator クラス


Creator.OpenBook メソッド (Stream, String)

CreatorOpenBook メソッド (Stream, String)

ブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBook(
    Stream outStream,
    string templateName
)
Public Function OpenBook (
    outStream As Stream,
    templateName As String
) As Integer

パラメーター

outStream
型: System.IOStream
作成するブックのストリームを指定します。
templateName
型: SystemString
オーバーレイ元ファイル名を指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
// "C:\Book1.xlsx" をオーバーレイオープンし、outStream に出力します。
System.IO.MemoryStream outStream = new System.IO.MemoryStream();
creator1.OpenBook(outStream, @"C:\Book1.xlsx");
creator1.CloseBook(true);
' "C:\Book1.xlsx" をオーバーレイオープンし、outStream に出力します。
Dim outStream As New System.IO.MemoryStream()
Creator1.OpenBook(outStream, "C:\Book1.xlsx")
Creator1.CloseBook(True)
関連項目

参照

Creator クラス
OpenBook オーバーロード


Creator.OpenBook メソッド (String, String)

CreatorOpenBook メソッド (String, String)

ブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBook(
    string fileName,
    string templateName
)
Public Function OpenBook (
    fileName As String,
    templateName As String
) As Integer

パラメーター

fileName
型: SystemString
オープンするブックのファイル名を指定します。
templateName
型: SystemString
オーバーレイ元ファイル名を指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
// "C:\Book1.xlsx" をオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
creator1.OpenBook(@"C:\Out1.xlsx", @"C:\Book1.xlsx");
creator1.CloseBook(true);
' "C:\Book1.xlsx" をオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
Creator1.OpenBook("C:\Out1.xlsx", "C:\Book1.xlsx")
Creator1.CloseBook(True)
関連項目

参照

Creator クラス
OpenBook オーバーロード


Creator.OpenBook メソッド (Stream, String, String)

CreatorOpenBook メソッド (Stream, String, String)

ブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBook(
    Stream outStream,
    string templateName,
    string password
)
Public Function OpenBook (
    outStream As Stream,
    templateName As String,
    password As String
) As Integer

パラメーター

outStream
型: System.IOStream
作成するブックのストリームを指定します。
templateName
型: SystemString
オーバーレイ元ファイル名を指定します。
password
型: SystemString
オーバーレイ元ファイルの読み取りパスワードを指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
解説
出力後の Excel ファイルに読み取りパスワードを引き継ぐことはできません。
例
C#
VB
コピー
// 読み取りパスワード "password" を指定して "C:\Book1_pass.xlsx" をオーバーレイオープンし、outStream に出力します。
System.IO.MemoryStream outStream = new System.IO.MemoryStream();
creator1.OpenBook(outStream, @"C:\Book1_pass.xlsx", "password");
creator1.CloseBook(true);
' 読み取りパスワード "password" を指定して "C:\Book1_pass.xlsx" をオーバーレイオープンし、outStream に出力します。
Dim outStream As New System.IO.MemoryStream()
Creator1.OpenBook(outStream, "C:\Book1_pass.xlsx", "password")
Creator1.CloseBook(True)
関連項目

参照

Creator クラス
OpenBook オーバーロード


Creator.OpenBook メソッド (String, String, String)

CreatorOpenBook メソッド (String, String, String)

ブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBook(
    string fileName,
    string templateName,
    string password
)
Public Function OpenBook (
    fileName As String,
    templateName As String,
    password As String
) As Integer

パラメーター

fileName
型: SystemString
オープンするブックのファイル名を指定します。
templateName
型: SystemString
オーバーレイ元ファイル名を指定します。
password
型: SystemString
オーバーレイ元ファイルの読み取りパスワードを指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
解説
出力後の Excel ファイルに読み取りパスワードを引き継ぐことはできません。
例
C#
VB
コピー
// 読み取りパスワード "password" を指定して "C:\Book1_pass.xlsx" をオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
creator1.OpenBook(@"C:\Out1.xlsx", @"C:\Book1_pass.xlsx", "password");
creator1.CloseBook(true);
' 読み取りパスワード "password" を指定して "C:\Book1_pass.xlsx" をオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
Creator1.OpenBook("C:\Out1.xlsx", "C:\Book1_pass.xlsx", "password")
Creator1.CloseBook(True)
関連項目

参照

Creator クラス
OpenBook オーバーロード


Creator.OpenBookEmbed メソッド

CreatorOpenBookEmbed メソッド

オーバーロードの一覧
名前 | 説明
OpenBookEmbed(Stream, Byte) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEmbed(Stream, Stream) | Stream を元ファイルとしてブックをオープンします。
OpenBookEmbed(String, Byte) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEmbed(String, Stream) | Stream を元ファイルとしてブックをオープンします。
トップ
関連項目

参照

Creator クラス


Creator.OpenBookEmbed メソッド (Stream, Byte[])

CreatorOpenBookEmbed メソッド (Stream, Byte)

バイナリデータを元ファイルとしてブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBookEmbed(
    Stream outStream,
    byte[] bytes
)
Public Function OpenBookEmbed (
    outStream As Stream,
    bytes As Byte()
) As Integer

パラメーター

outStream
型: System.IOStream
作成するブックのストリームを指定します。
bytes
型: SystemByte
オーバーレイ元ファイルのバイナリデータを指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
// 現在実行中のアセンブリを取得します。
System.Reflection.Assembly assembly = System.Reflection.Assembly.GetExecutingAssembly();
// 埋め込んだテンプレートファイル(.resx)の基本名とアセンブリの参照を指定します。
System.Resources.ResourceManager resourceManager = new System.Resources.ResourceManager("WindowsApplication1.Book1", assembly);
// 埋め込んだテンプレートファイル(.resx)をオーバーレイオープンし、outStream に出力します。
System.IO.MemoryStream outStream = new System.IO.MemoryStream();
creator1.OpenBookEmbed(outStream, (byte[])resourceManager.GetObject("ResourceID1"));
creator1.CloseBook(true);
' 現在実行中のアセンブリを取得します。
Dim assembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
' 埋め込んだテンプレートファイル(.resx)の基本名とアセンブリの参照を指定します。
Dim resourceManager As New System.Resources.ResourceManager("WindowsApplication1.Book1", assembly)
' 埋め込んだテンプレートファイル(.resx)をオーバーレイオープンし、outStream に出力します。
Dim outStream As New System.IO.MemoryStream()
Creator1.OpenBookEmbed(outStream, CType(resourceManager.GetObject("ResourceID1"), Byte()))
Creator1.CloseBook(True)
関連項目

参照

Creator クラス
OpenBookEmbed オーバーロード


Creator.OpenBookEmbed メソッド (Stream, Stream)

CreatorOpenBookEmbed メソッド (Stream, Stream)

Stream を元ファイルとしてブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBookEmbed(
    Stream outStream,
    Stream sourceStream
)
Public Function OpenBookEmbed (
    outStream As Stream,
    sourceStream As Stream
) As Integer

パラメーター

outStream
型: System.IOStream
作成するブックのストリームを指定します。
sourceStream
型: System.IOStream
オーバーレイ元ファイルのストリームを指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
// 現在実行中のアセンブリを取得します。
System.Reflection.Assembly assembly = System.Reflection.Assembly.GetExecutingAssembly();
// 埋め込んだテンプレートファイル(.xlsx)のストリームを取得します。
System.IO.Stream sourceStream = assembly.GetManifestResourceStream("WindowsApplication1.Book1.xlsx");
// 埋め込んだテンプレートファイル(.xlsx)をオーバーレイオープンし、outStream に出力します。
System.IO.MemoryStream outStream = new System.IO.MemoryStream();
creator1.OpenBookEmbed(outStream, sourceStream);
creator1.CloseBook(true);
' 現在実行中のアセンブリを取得します。
Dim assembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
' 埋め込んだテンプレートファイル(.xlsx)のストリームを取得します。
Dim sourceStream As System.IO.Stream = assembly.GetManifestResourceStream("WindowsApplication1.Book1.xlsx")
' 埋め込んだテンプレートファイル(.xlsx)をオーバーレイオープンし、outStream に出力します。
Dim outStream As New System.IO.MemoryStream()
Creator1.OpenBookEmbed(outStream, sourceStream)
Creator1.CloseBook(True)
関連項目

参照

Creator クラス
OpenBookEmbed オーバーロード


Creator.OpenBookEmbed メソッド (String, Byte[])

CreatorOpenBookEmbed メソッド (String, Byte)

バイナリデータを元ファイルとしてブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBookEmbed(
    string fileName,
    byte[] bytes
)
Public Function OpenBookEmbed (
    fileName As String,
    bytes As Byte()
) As Integer

パラメーター

fileName
型: SystemString
オープンするブックのファイル名を指定します。
bytes
型: SystemByte
オーバーレイ元ファイルのバイナリデータを指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
// 現在実行中のアセンブリを取得します。
System.Reflection.Assembly assembly = System.Reflection.Assembly.GetExecutingAssembly();
// 埋め込んだテンプレートファイル(.resx)の基本名とアセンブリの参照を指定します。
System.Resources.ResourceManager resourceManager = new System.Resources.ResourceManager("WindowsApplication1.Book1", assembly);
// 埋め込んだテンプレートファイル(.resx)をオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
creator1.OpenBookEmbed(@"C:\Out1.xlsx", (byte[])resourceManager.GetObject("ResourceID1"));
creator1.CloseBook(true);
' 現在実行中のアセンブリを取得します。
Dim assembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
' 埋め込んだテンプレートファイル(.resx)の基本名とアセンブリの参照を指定します。
Dim resourceManager As New System.Resources.ResourceManager("WindowsApplication1.Book1", assembly)
' 埋め込んだテンプレートファイル(.resx)をオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
Creator1.OpenBookEmbed("C:\Out1.xlsx", CType(resourceManager.GetObject("ResourceID1"), Byte()))
Creator1.CloseBook(True)
関連項目

参照

Creator クラス
OpenBookEmbed オーバーロード


Creator.OpenBookEmbed メソッド (String, Stream)

CreatorOpenBookEmbed メソッド (String, Stream)

Stream を元ファイルとしてブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBookEmbed(
    string fileName,
    Stream sourceStream
)
Public Function OpenBookEmbed (
    fileName As String,
    sourceStream As Stream
) As Integer

パラメーター

fileName
型: SystemString
オープンするブックのファイル名を指定します。
sourceStream
型: System.IOStream
オーバーレイ元ファイルのストリームを指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
// 現在実行中のアセンブリを取得します。
System.Reflection.Assembly assembly = System.Reflection.Assembly.GetExecutingAssembly();
// 埋め込んだテンプレートファイル(.xlsx)のストリームを取得します。
System.IO.Stream sourceStream = assembly.GetManifestResourceStream("WindowsApplication1.Book1.xlsx");
// 埋め込んだテンプレートファイル(.xlsx)をオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
creator1.OpenBookEmbed(@"C:\Out1.xlsx", sourceStream);
creator1.CloseBook(true);
' 現在実行中のアセンブリを取得します。
Dim assembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
' 埋め込んだテンプレートファイル(.xlsx)のストリームを取得します。
Dim sourceStream As System.IO.Stream = assembly.GetManifestResourceStream("WindowsApplication1.Book1.xlsx")
' 埋め込んだテンプレートファイル(.xlsx)をオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
Creator1.OpenBookEmbed("C:\Out1.xlsx", sourceStream)
Creator1.CloseBook(True)
関連項目

参照

Creator クラス
OpenBookEmbed オーバーロード


Creator.OpenBookEmbedEx メソッド

CreatorOpenBookEmbedEx メソッド

オーバーロードの一覧
名前 | 説明
OpenBookEmbedEx(Stream, Byte, Object) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEmbedEx(Stream, Stream, Object) | Stream を元ファイルとしてブックをオープンします。
OpenBookEmbedEx(String, Byte, Object) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEmbedEx(String, Stream, Object) | Stream を元ファイルとしてブックをオープンします。
トップ
関連項目

参照

Creator クラス


Creator.OpenBookEmbedEx メソッド (Stream, Byte[], Object)

CreatorOpenBookEmbedEx メソッド (Stream, Byte, Object)

バイナリデータを元ファイルとしてブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBookEmbedEx(
    Stream outStream,
    byte[] bytes,
    out Object bookInfo
)
Public Function OpenBookEmbedEx (
    outStream As Stream,
    bytes As Byte(),
    <OutAttribute> ByRef bookInfo As Object
) As Integer

パラメーター

outStream
型: System.IOStream
作成するブックのストリームを指定します。
bytes
型: SystemByte
オーバーレイ元ファイルのバイナリデータを指定します。
bookInfo
型: SystemObject
ブックを識別するためのハンドルを受け取る object 型への参照を指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 現在実行中のアセンブリを取得します。
System.Reflection.Assembly assembly = System.Reflection.Assembly.GetExecutingAssembly();
// 埋め込んだテンプレートファイル(.resx)の基本名とアセンブリの参照を指定します。
System.Resources.ResourceManager resourceManager = new System.Resources.ResourceManager("WindowsApplication1.Books", assembly);
// 埋め込んだ 1 つ目のブックをオーバーレイオープンし、outStream1 に出力します。
System.IO.MemoryStream outStream1 = new System.IO.MemoryStream();
creator1.OpenBookEmbedEx(outStream1, (byte[])resourceManager.GetObject("ResourceID1"), out bookInfo1);
// 埋め込んだ 2 つ目のブックをオーバーレイオープンし、outStream2 に出力します。
System.IO.MemoryStream outStream2 = new System.IO.MemoryStream();
creator1.OpenBookEmbedEx(outStream2, (byte[])resourceManager.GetObject("ResourceID2"), out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 現在実行中のアセンブリを取得します。
Dim assembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
' 埋め込んだテンプレートファイル(.resx)の基本名とアセンブリの参照を指定します。
Dim resourceManager As New System.Resources.ResourceManager("WindowsApplication1.Books", assembly)
' 埋め込んだ 1 つ目のブックをオーバーレイオープンし、outStream1 に出力します。
Dim outStream1 As New System.IO.MemoryStream()
Creator1.OpenBookEmbedEx(outStream1, CType(resourceManager.GetObject("ResourceID1"), Byte()), bookInfo1)
' 埋め込んだ 2 つ目のブックをオーバーレイオープンし、outStream2 に出力します。
Dim outStream2 As New System.IO.MemoryStream()
Creator1.OpenBookEmbedEx(outStream2, CType(resourceManager.GetObject("ResourceID2"), Byte()), bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス
OpenBookEmbedEx オーバーロード


Creator.OpenBookEmbedEx メソッド (Stream, Stream, Object)

CreatorOpenBookEmbedEx メソッド (Stream, Stream, Object)

Stream を元ファイルとしてブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBookEmbedEx(
    Stream outStream,
    Stream sourceStream,
    out Object bookInfo
)
Public Function OpenBookEmbedEx (
    outStream As Stream,
    sourceStream As Stream,
    <OutAttribute> ByRef bookInfo As Object
) As Integer

パラメーター

outStream
型: System.IOStream
作成するブックのストリームをを指定します。
sourceStream
型: System.IOStream
オーバーレイ元ファイルのストリームを指定します。
bookInfo
型: SystemObject
ブックを識別するためのハンドルを受け取る object 型への参照を指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 現在実行中のアセンブリを取得します。
System.Reflection.Assembly assembly = System.Reflection.Assembly.GetExecutingAssembly();
// 埋め込んだ 1 つ目のブックをオーバーレイオープンし、outStream1 に出力します。
System.IO.Stream sourceStream1 = assembly.GetManifestResourceStream("WindowsApplication1.Book1.xlsx");
System.IO.MemoryStream outStream1 = new System.IO.MemoryStream();
creator1.OpenBookEmbedEx(outStream1, sourceStream1, out bookInfo1);
// 埋め込んだ 2 つ目のブックをオーバーレイオープンし、outStream2 に出力します。
System.IO.Stream sourceStream2 = assembly.GetManifestResourceStream("WindowsApplication1.Book2.xlsx");
System.IO.MemoryStream outStream2 = new System.IO.MemoryStream();
creator1.OpenBookEmbedEx(outStream2, sourceStream2, out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 現在実行中のアセンブリを取得します。
Dim assembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
' 埋め込んだ 1 つ目のブックをオーバーレイオープンし、outStream1 に出力します。
Dim sourceStream1 As System.IO.Stream = assembly.GetManifestResourceStream("WindowsApplication1.Book1.xlsx")
Dim outStream1 As New System.IO.MemoryStream()
Creator1.OpenBookEmbedEx(outStream1, sourceStream1, bookInfo1)
' 埋め込んだ 2 つ目のブックをオーバーレイオープンし、outStream2 に出力します。
Dim sourceStream2 As System.IO.Stream = assembly.GetManifestResourceStream("WindowsApplication1.Book2.xlsx")
Dim outStream2 As New System.IO.MemoryStream()
Creator1.OpenBookEmbedEx(outStream2, sourceStream2, bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス
OpenBookEmbedEx オーバーロード


Creator.OpenBookEmbedEx メソッド (String, Byte[], Object)

CreatorOpenBookEmbedEx メソッド (String, Byte, Object)

バイナリデータを元ファイルとしてブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBookEmbedEx(
    string fileName,
    byte[] bytes,
    out Object bookInfo
)
Public Function OpenBookEmbedEx (
    fileName As String,
    bytes As Byte(),
    <OutAttribute> ByRef bookInfo As Object
) As Integer

パラメーター

fileName
型: SystemString
作成するブックのファイル名を指定します。
bytes
型: SystemByte
オーバーレイ元ファイルのバイナリデータを指定します。
bookInfo
型: SystemObject
ブックを識別するためのハンドルを受け取る object 型への参照を指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 現在実行中のアセンブリを取得します。
System.Reflection.Assembly assembly = System.Reflection.Assembly.GetExecutingAssembly();
// 埋め込んだテンプレートファイル(.resx)の基本名とアセンブリの参照を指定します。
System.Resources.ResourceManager resourceManager = new System.Resources.ResourceManager("WindowsApplication1.Books", assembly);
// 埋め込んだ 1 つ目のブックをオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
creator1.OpenBookEmbedEx(@"C:\Out1.xlsx", (byte[])resourceManager.GetObject("ResourceID1"), out bookInfo1);
// 埋め込んだ 2 つ目のブックをオーバーレイオープンし、"C:\Out2.xlsx" に出力します。
creator1.OpenBookEmbedEx(@"C:\Out2.xlsx", (byte[])resourceManager.GetObject("ResourceID2"), out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 現在実行中のアセンブリを取得します。
Dim assembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
' 埋め込んだテンプレートファイル(.resx)の基本名とアセンブリの参照を指定します。
Dim resourceManager As New System.Resources.ResourceManager("WindowsApplication1.Books", assembly)
' 埋め込んだ 1 つ目のブックをオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
Creator1.OpenBookEmbedEx("C:\Out1.xlsx", CType(resourceManager.GetObject("ResourceID1"), Byte()), bookInfo1)
' 埋め込んだ 2 つ目のブックをオーバーレイオープンし、"C:\Out2.xlsx" に出力します。
Creator1.OpenBookEmbedEx("C:\Out2.xlsx", CType(resourceManager.GetObject("ResourceID2"), Byte()), bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス
OpenBookEmbedEx オーバーロード


Creator.OpenBookEmbedEx メソッド (String, Stream, Object)

CreatorOpenBookEmbedEx メソッド (String, Stream, Object)

Stream を元ファイルとしてブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBookEmbedEx(
    string fileName,
    Stream sourceStream,
    out Object bookInfo
)
Public Function OpenBookEmbedEx (
    fileName As String,
    sourceStream As Stream,
    <OutAttribute> ByRef bookInfo As Object
) As Integer

パラメーター

fileName
型: SystemString
作成するブックのファイル名を指定します。
sourceStream
型: System.IOStream
オーバーレイ元ファイルのストリームを指定します。
bookInfo
型: SystemObject
ブックを識別するためのハンドルを受け取る object 型への参照を指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 現在実行中のアセンブリを取得します。
System.Reflection.Assembly assembly = System.Reflection.Assembly.GetExecutingAssembly();
// 埋め込んだ 1 つ目のブックをオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
System.IO.Stream sourceStream1 = assembly.GetManifestResourceStream("WindowsApplication1.Book1.xlsx");
creator1.OpenBookEmbedEx(@"C:\Out1.xlsx", sourceStream1, out bookInfo1);
// 埋め込んだ 2 つ目のブックをオーバーレイオープンし、"C:\Out2.xlsx" に出力します。
System.IO.Stream sourceStream2 = assembly.GetManifestResourceStream("WindowsApplication1.Book2.xlsx");
creator1.OpenBookEmbedEx(@"C:\Out2.xlsx", sourceStream2, out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 現在実行中のアセンブリを取得します。
Dim assembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
' 埋め込んだ 1 つ目のブックをオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
Dim sourceStream1 As System.IO.Stream = assembly.GetManifestResourceStream("WindowsApplication1.Book1.xlsx")
Creator1.OpenBookEmbedEx("C:\Out1.xlsx", sourceStream1, bookInfo1)
' 埋め込んだ 2 つ目のブックをオーバーレイオープンし、"C:\Out2.xlsx" に出力します。
Dim sourceStream2 As System.IO.Stream = assembly.GetManifestResourceStream("WindowsApplication1.Book2.xlsx")
Creator1.OpenBookEmbedEx("C:\Out2.xlsx", sourceStream2, bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス
OpenBookEmbedEx オーバーロード


Creator.OpenBookEx メソッド

CreatorOpenBookEx メソッド

オーバーロードの一覧
名前 | 説明
OpenBookEx(Stream, Byte, Object) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEx(Stream, Stream, Object) | Stream を元ファイルとしてブックをオープンします。
OpenBookEx(Stream, String, Object) | ブックをオープンします。
OpenBookEx(String, Byte, Object) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEx(String, Stream, Object) | Stream を元ファイルとしてブックをオープンします。
OpenBookEx(String, String, Object) | ブックをオープンします。
OpenBookEx(Stream, Byte, String, Object) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEx(Stream, Stream, String, Object) | Stream を元ファイルとしてブックをオープンします。
OpenBookEx(Stream, String, String, Object) | ブックをオープンします。
OpenBookEx(String, Byte, String, Object) | バイナリデータを元ファイルとしてブックをオープンします。
OpenBookEx(String, Stream, String, Object) | Stream を元ファイルとしてブックをオープンします。
OpenBookEx(String, String, String, Object) | ブックをオープンします。
トップ
関連項目

参照

Creator クラス


Creator.OpenBookEx メソッド (Stream, Byte[], Object)

CreatorOpenBookEx メソッド (Stream, Byte, Object)

バイナリデータを元ファイルとしてブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBookEx(
    Stream outStream,
    byte[] bytes,
    out Object bookInfo
)
Public Function OpenBookEx (
    outStream As Stream,
    bytes As Byte(),
    <OutAttribute> ByRef bookInfo As Object
) As Integer

パラメーター

outStream
型: System.IOStream
作成するブックのストリームを指定します。
bytes
型: SystemByte
オーバーレイ元ファイルのバイナリデータを指定します。
bookInfo
型: SystemObject
ブックを識別するためのハンドルを受け取る object 型への参照を指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 現在実行中のアセンブリを取得します。
System.Reflection.Assembly assembly = System.Reflection.Assembly.GetExecutingAssembly();
// 埋め込んだテンプレートファイル(.resx)の基本名とアセンブリの参照を指定します。
System.Resources.ResourceManager resourceManager = new System.Resources.ResourceManager("WindowsApplication1.Books", assembly);
// 埋め込んだ 1 つ目のブックをオーバーレイオープンし、outStream1 に出力します。
System.IO.MemoryStream outStream1 = new System.IO.MemoryStream();
creator1.OpenBookEx(outStream1, (byte[])resourceManager.GetObject("ResourceID1"), out bookInfo1);
// 埋め込んだ 2 つ目のブックをオーバーレイオープンし、outStream2 に出力します。
System.IO.MemoryStream outStream2 = new System.IO.MemoryStream();
creator1.OpenBookEx(outStream2, (byte[])resourceManager.GetObject("ResourceID2"), out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 現在実行中のアセンブリを取得します。
Dim assembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
' 埋め込んだテンプレートファイル(.resx)の基本名とアセンブリの参照を指定します。
Dim resourceManager As New System.Resources.ResourceManager("WindowsApplication1.Books", assembly)
' 埋め込んだ 1 つ目のブックをオーバーレイオープンし、outStream1 に出力します。
Dim outStream1 As New System.IO.MemoryStream()
Creator1.OpenBookEx(outStream1, CType(resourceManager.GetObject("ResourceID1"), Byte()), bookInfo1)
' 埋め込んだ 2 つ目のブックをオーバーレイオープンし、outStream2 に出力します。
Dim outStream2 As New System.IO.MemoryStream()
Creator1.OpenBookEx(outStream2, CType(resourceManager.GetObject("ResourceID2"), Byte()), bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス
OpenBookEx オーバーロード


Creator.OpenBookEx メソッド (Stream, Stream, Object)

CreatorOpenBookEx メソッド (Stream, Stream, Object)

Stream を元ファイルとしてブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBookEx(
    Stream outStream,
    Stream sourceStream,
    out Object bookInfo
)
Public Function OpenBookEx (
    outStream As Stream,
    sourceStream As Stream,
    <OutAttribute> ByRef bookInfo As Object
) As Integer

パラメーター

outStream
型: System.IOStream
作成するブックのストリームを指定します。
sourceStream
型: System.IOStream
オーバーレイ元ファイルのストリームを指定します。
bookInfo
型: SystemObject
ブックを識別するためのハンドルを受け取る object 型への参照を指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 現在実行中のアセンブリを取得します。
System.Reflection.Assembly assembly = System.Reflection.Assembly.GetExecutingAssembly();
// 埋め込んだ 1 つ目のブックをオーバーレイオープンし、outStream1 に出力します。
System.IO.Stream sourceStream1 = assembly.GetManifestResourceStream("WindowsApplication1.Book1.xlsx");
System.IO.MemoryStream outStream1 = new System.IO.MemoryStream();
creator1.OpenBookEx(outStream1, sourceStream1, out bookInfo1);
// 埋め込んだ 2 つ目のブックをオーバーレイオープンし、outStream2 に出力します。
System.IO.Stream sourceStream2 = assembly.GetManifestResourceStream("WindowsApplication1.Book2.xlsx");
System.IO.MemoryStream outStream2 = new System.IO.MemoryStream();
creator1.OpenBookEx(outStream2, sourceStream2, out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 現在実行中のアセンブリを取得します。
Dim assembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
' 埋め込んだ 1 つ目のブックをオーバーレイオープンし、outStream1 に出力します。
Dim sourceStream1 As System.IO.Stream = assembly.GetManifestResourceStream("WindowsApplication1.Book1.xlsx")
Dim outStream1 As New System.IO.MemoryStream()
Creator1.OpenBookEx(outStream1, sourceStream1, bookInfo1)
' 埋め込んだ 2 つ目のブックをオーバーレイオープンし、outStream2 に出力します。
Dim sourceStream2 As System.IO.Stream = assembly.GetManifestResourceStream("WindowsApplication1.Book2.xlsx")
Dim outStream2 As New System.IO.MemoryStream()
Creator1.OpenBookEx(outStream2, sourceStream2, bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス
OpenBookEx オーバーロード


Creator.OpenBookEx メソッド (Stream, String, Object)

CreatorOpenBookEx メソッド (Stream, String, Object)

ブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBookEx(
    Stream outStream,
    string templateName,
    out Object bookInfo
)
Public Function OpenBookEx (
    outStream As Stream,
    templateName As String,
    <OutAttribute> ByRef bookInfo As Object
) As Integer

パラメーター

outStream
型: System.IOStream
オープンするブックのストリームを指定します。
templateName
型: SystemString
オーバーレイ元ファイル名を指定します。
bookInfo
型: SystemObject
ブックを識別するためのハンドルを受け取る object 型への参照を指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 1 つ目のブックをオーバーレイオープンし、outStream1 に出力します。
System.IO.MemoryStream outStream1 = new System.IO.MemoryStream();
creator1.OpenBookEx(outStream1, @"C:\Book1.xlsx", out bookInfo1);
// 2 つ目のブックをオーバーレイオープンし、outStream2 に出力します。
System.IO.MemoryStream outStream2 = new System.IO.MemoryStream();
creator1.OpenBookEx(outStream2, @"C:\Book2.xlsx", out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 1 つ目のブックをオーバーレイオープンし、outStream1 に出力します。
Dim outStream1 As New System.IO.MemoryStream()
Creator1.OpenBookEx(outStream1, "C:\Book1.xlsx", bookInfo1)
' 2 つ目のブックをオーバーレイオープンし、outStream2 に出力します。
Dim outStream2 As New System.IO.MemoryStream()
Creator1.OpenBookEx(outStream2, "C:\Book2.xlsx", bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス
OpenBookEx オーバーロード


Creator.OpenBookEx メソッド (String, Byte[], Object)

CreatorOpenBookEx メソッド (String, Byte, Object)

バイナリデータを元ファイルとしてブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBookEx(
    string fileName,
    byte[] bytes,
    out Object bookInfo
)
Public Function OpenBookEx (
    fileName As String,
    bytes As Byte(),
    <OutAttribute> ByRef bookInfo As Object
) As Integer

パラメーター

fileName
型: SystemString
作成するブックのファイル名を指定します。
bytes
型: SystemByte
オーバーレイ元ファイルのバイナリデータを指定します。
bookInfo
型: SystemObject
ブックを識別するためのハンドルを受け取る object 型への参照を指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 現在実行中のアセンブリを取得します。
System.Reflection.Assembly assembly = System.Reflection.Assembly.GetExecutingAssembly();
// 埋め込んだテンプレートファイル(.resx)の基本名とアセンブリの参照を指定します。
System.Resources.ResourceManager resourceManager = new System.Resources.ResourceManager("WindowsApplication1.Books", assembly);
// 埋め込んだ 1 つ目のブックをオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
creator1.OpenBookEx(@"C:\Out1.xlsx", (byte[])resourceManager.GetObject("ResourceID1"), out bookInfo1);
// 埋め込んだ 2 つ目のブックをオーバーレイオープンし、"C:\Out2.xlsx" に出力します。
creator1.OpenBookEx(@"C:\Out2.xlsx", (byte[])resourceManager.GetObject("ResourceID2"), out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 現在実行中のアセンブリを取得します。
Dim assembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
' 埋め込んだテンプレートファイル(.resx)の基本名とアセンブリの参照を指定します。
Dim resourceManager As New System.Resources.ResourceManager("WindowsApplication1.Books", assembly)
' 埋め込んだ 1 つ目のブックをオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
Creator1.OpenBookEx("C:\Out1.xlsx", CType(resourceManager.GetObject("ResourceID1"), Byte()), bookInfo1)
' 埋め込んだ 2 つ目のブックをオーバーレイオープンし、"C:\Out2.xlsx" に出力します。
Creator1.OpenBookEx("C:\Out2.xlsx", CType(resourceManager.GetObject("ResourceID2"), Byte()), bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス
OpenBookEx オーバーロード


Creator.OpenBookEx メソッド (String, Stream, Object)

CreatorOpenBookEx メソッド (String, Stream, Object)

Stream を元ファイルとしてブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBookEx(
    string fileName,
    Stream sourceStream,
    out Object bookInfo
)
Public Function OpenBookEx (
    fileName As String,
    sourceStream As Stream,
    <OutAttribute> ByRef bookInfo As Object
) As Integer

パラメーター

fileName
型: SystemString
作成するブックのファイル名を指定します。
sourceStream
型: System.IOStream
オーバーレイ元ファイルのストリームを指定します。
bookInfo
型: SystemObject
ブックを識別するためのハンドルを受け取る object 型への参照を指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 現在実行中のアセンブリを取得します。
System.Reflection.Assembly assembly = System.Reflection.Assembly.GetExecutingAssembly();
// 埋め込んだ 1 つ目のブックをオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
System.IO.Stream sourceStream1 = assembly.GetManifestResourceStream("WindowsApplication1.Book1.xlsx");
creator1.OpenBookEx(@"C:\Out1.xlsx", sourceStream1, out bookInfo1);
// 埋め込んだ 2 つ目のブックをオーバーレイオープンし、"C:\Out2.xlsx" に出力します。
System.IO.Stream sourceStream2 = assembly.GetManifestResourceStream("WindowsApplication1.Book2.xlsx");
creator1.OpenBookEx(@"C:\Out2.xlsx", sourceStream2, out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 現在実行中のアセンブリを取得します。
Dim assembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
' 埋め込んだ 1 つ目のブックをオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
Dim sourceStream1 As System.IO.Stream = assembly.GetManifestResourceStream("WindowsApplication1.Book1.xlsx")
Creator1.OpenBookEx("C:\Out1.xlsx", sourceStream1, bookInfo1)
' 埋め込んだ 2 つ目のブックをオーバーレイオープンし、"C:\Out2.xlsx" に出力します。
Dim sourceStream2 As System.IO.Stream = assembly.GetManifestResourceStream("WindowsApplication1.Book2.xlsx")
Creator1.OpenBookEx("C:\Out2.xlsx", sourceStream2, bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス
OpenBookEx オーバーロード


Creator.OpenBookEx メソッド (String, String, Object)

CreatorOpenBookEx メソッド (String, String, Object)

ブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBookEx(
    string fileName,
    string templateName,
    out Object bookInfo
)
Public Function OpenBookEx (
    fileName As String,
    templateName As String,
    <OutAttribute> ByRef bookInfo As Object
) As Integer

パラメーター

fileName
型: SystemString
オープンするブックのファイル名を指定します。
templateName
型: SystemString
オーバーレイ元ファイル名を指定します。
bookInfo
型: SystemObject
ブックを識別するためのハンドルを受け取る object 型への参照を指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 1 つ目のブック(C:\Book1.xlsx)をオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
creator1.OpenBookEx(@"C:\Out1.xlsx", @"C:\Book1.xlsx", out bookInfo1);
// 2 つ目のブック(C:\Book2.xlsx)をオーバーレイオープンし、"C:\Out2.xlsx" に出力します。
creator1.OpenBookEx(@"C:\Out2.xlsx", @"C:\Book2.xlsx", out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 1 つ目のブック(C:\Book1.xlsx)をオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
Creator1.OpenBookEx("C:\Out1.xlsx", "C:\Book1.xlsx", bookInfo1)
' 2 つ目のブック(C:\Book2.xlsx)をオーバーレイオープンし、"C:\Out2.xlsx" に出力します。
Creator1.OpenBookEx("C:\Out2.xlsx", "C:\Book2.xlsx", bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス
OpenBookEx オーバーロード


Creator.OpenBookEx メソッド (Stream, Byte[], String, Object)

CreatorOpenBookEx メソッド (Stream, Byte, String, Object)

バイナリデータを元ファイルとしてブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBookEx(
    Stream outStream,
    byte[] bytes,
    string password,
    out Object bookInfo
)
Public Function OpenBookEx (
    outStream As Stream,
    bytes As Byte(),
    password As String,
    <OutAttribute> ByRef bookInfo As Object
) As Integer

パラメーター

outStream
型: System.IOStream
作成するブックのストリームを指定します。
bytes
型: SystemByte
オーバーレイ元ファイルのバイナリデータを指定します。
password
型: SystemString
オーバーレイ元ファイルの読み取りパスワードを指定します。
bookInfo
型: SystemObject
ブックを識別するためのハンドルを受け取る object 型への参照を指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
解説
出力後の Excel ファイルに読み取りパスワードを引き継ぐことはできません。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 現在実行中のアセンブリを取得します。
System.Reflection.Assembly assembly = System.Reflection.Assembly.GetExecutingAssembly();
// 埋め込んだテンプレートファイル(.resx)の基本名とアセンブリの参照を指定します。
System.Resources.ResourceManager resourceManager = new System.Resources.ResourceManager("WindowsApplication1.Books", assembly);
// 読み取りパスワード "password" を指定して埋め込んだ 1 つ目のブックをオーバーレイオープンし、outStream1 に出力します。
System.IO.MemoryStream outStream1 = new System.IO.MemoryStream();
creator1.OpenBookEx(outStream1, (byte[])resourceManager.GetObject("ResourceID1"), "password", out bookInfo1);
// 読み取りパスワード "password" を指定して埋め込んだ 2 つ目のブックをオーバーレイオープンし、outStream2 に出力します。
System.IO.MemoryStream outStream2 = new System.IO.MemoryStream();
creator1.OpenBookEx(outStream2, (byte[])resourceManager.GetObject("ResourceID2"), "password", out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 現在実行中のアセンブリを取得します。
Dim assembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
' 埋め込んだテンプレートファイル(.resx)の基本名とアセンブリの参照を指定します。
Dim resourceManager As New System.Resources.ResourceManager("WindowsApplication1.Books", assembly)
' 読み取りパスワード "password" を指定して埋め込んだ 1 つ目のブックをオーバーレイオープンし、outStream1 に出力します。
Dim outStream1 As New System.IO.MemoryStream()
Creator1.OpenBookEx(outStream1, CType(resourceManager.GetObject("ResourceID1"), Byte()), "password", bookInfo1)
' 読み取りパスワード "password" を指定して埋め込んだ 2 つ目のブックをオーバーレイオープンし、outStream2 に出力します。
Dim outStream2 As New System.IO.MemoryStream()
Creator1.OpenBookEx(outStream2, CType(resourceManager.GetObject("ResourceID2"), Byte()), "password", bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス
OpenBookEx オーバーロード


Creator.OpenBookEx メソッド (Stream, Stream, String, Object)

CreatorOpenBookEx メソッド (Stream, Stream, String, Object)

Stream を元ファイルとしてブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBookEx(
    Stream outStream,
    Stream sourceStream,
    string password,
    out Object bookInfo
)
Public Function OpenBookEx (
    outStream As Stream,
    sourceStream As Stream,
    password As String,
    <OutAttribute> ByRef bookInfo As Object
) As Integer

パラメーター

outStream
型: System.IOStream
作成するブックのストリームを指定します。
sourceStream
型: System.IOStream
オーバーレイ元ファイルのストリームを指定します。
password
型: SystemString
オーバーレイ元ファイルの読み取りパスワードを指定します。
bookInfo
型: SystemObject
ブックを識別するためのハンドルを受け取る object 型への参照を指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
解説
出力後の Excel ファイルに読み取りパスワードを引き継ぐことはできません。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 現在実行中のアセンブリを取得します。
System.Reflection.Assembly assembly = System.Reflection.Assembly.GetExecutingAssembly();
// 読み取りパスワード "password" を指定して埋め込んだ 1 つ目のブックをオーバーレイオープンし、outStream1 に出力します。
System.IO.Stream sourceStream1 = assembly.GetManifestResourceStream("WindowsApplication1.Book1_pass.xlsx");
System.IO.MemoryStream outStream1 = new System.IO.MemoryStream();
creator1.OpenBookEx(outStream1, sourceStream1, "password", out bookInfo1);
// 読み取りパスワード "password" を指定して埋め込んだ 2 つ目のブックをオーバーレイオープンし、outStream2 に出力します。
System.IO.Stream sourceStream2 = assembly.GetManifestResourceStream("WindowsApplication1.Book2_pass.xlsx");
System.IO.MemoryStream outStream2 = new System.IO.MemoryStream();
creator1.OpenBookEx(outStream2, sourceStream2, "password", out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 現在実行中のアセンブリを取得します。
Dim assembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
' 読み取りパスワード "password" を指定して埋め込んだ 1 つ目のブックをオーバーレイオープンし、outStream1 に出力します。
Dim sourceStream1 As System.IO.Stream = assembly.GetManifestResourceStream("WindowsApplication1.Book1_pass.xlsx")
Dim outStream1 As New System.IO.MemoryStream()
Creator1.OpenBookEx(outStream1, sourceStream1, "password", bookInfo1)
' 読み取りパスワード "password" を指定して埋め込んだ 2 つ目のブックをオーバーレイオープンし、outStream2 に出力します。
Dim sourceStream2 As System.IO.Stream = assembly.GetManifestResourceStream("WindowsApplication1.Book2_pass.xlsx")
Dim outStream2 As New System.IO.MemoryStream()
Creator1.OpenBookEx(outStream2, sourceStream2, "password", bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス
OpenBookEx オーバーロード


Creator.OpenBookEx メソッド (Stream, String, String, Object)

CreatorOpenBookEx メソッド (Stream, String, String, Object)

ブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBookEx(
    Stream outStream,
    string templateName,
    string password,
    out Object bookInfo
)
Public Function OpenBookEx (
    outStream As Stream,
    templateName As String,
    password As String,
    <OutAttribute> ByRef bookInfo As Object
) As Integer

パラメーター

outStream
型: System.IOStream
オープンするブックのストリームを指定します。
templateName
型: SystemString
オーバーレイ元ファイル名を指定します。
password
型: SystemString
オーバーレイ元ファイルの読み取りパスワードを指定します。
bookInfo
型: SystemObject
ブックを識別するためのハンドルを受け取る object 型への参照を指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
解説
出力後の Excel ファイルに読み取りパスワードを引き継ぐことはできません。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 読み取りパスワード "password" を指定して 1 つ目のブックをオーバーレイオープンし、outStream1 に出力します。
System.IO.MemoryStream outStream1 = new System.IO.MemoryStream();
creator1.OpenBookEx(outStream1, @"C:\Book1_pass.xlsx", "password", out bookInfo1);
// 読み取りパスワード "password" を指定して 2 つ目のブックをオーバーレイオープンし、outStream2 に出力します。
System.IO.MemoryStream outStream2 = new System.IO.MemoryStream();
creator1.OpenBookEx(outStream2, @"C:\Book2_pass.xlsx", "password", out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 読み取りパスワード "password" を指定して 1 つ目のブックをオーバーレイオープンし、outStream1 に出力します。
Dim outStream1 As New System.IO.MemoryStream()
Creator1.OpenBookEx(outStream1, "C:\Book1_pass.xlsx", "password", bookInfo1)
' 読み取りパスワード "password" を指定して 2 つ目のブックをオーバーレイオープンし、outStream2 に出力します。
Dim outStream2 As New System.IO.MemoryStream()
Creator1.OpenBookEx(outStream2, "C:\Book2_pass.xlsx", "password", bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス
OpenBookEx オーバーロード


Creator.OpenBookEx メソッド (String, Byte[], String, Object)

CreatorOpenBookEx メソッド (String, Byte, String, Object)

バイナリデータを元ファイルとしてブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBookEx(
    string fileName,
    byte[] bytes,
    string password,
    out Object bookInfo
)
Public Function OpenBookEx (
    fileName As String,
    bytes As Byte(),
    password As String,
    <OutAttribute> ByRef bookInfo As Object
) As Integer

パラメーター

fileName
型: SystemString
作成するブックのファイル名を指定します。
bytes
型: SystemByte
オーバーレイ元ファイルのバイナリデータを指定します。
password
型: SystemString
オーバーレイ元ファイルの読み取りパスワードを指定します。
bookInfo
型: SystemObject
ブックを識別するためのハンドルを受け取る object 型への参照を指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
解説
出力後の Excel ファイルに読み取りパスワードを引き継ぐことはできません。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 現在実行中のアセンブリを取得します。
System.Reflection.Assembly assembly = System.Reflection.Assembly.GetExecutingAssembly();
// 埋め込んだテンプレートファイル(.resx)の基本名とアセンブリの参照を指定します。
System.Resources.ResourceManager resourceManager = new System.Resources.ResourceManager("WindowsApplication1.Books", assembly);
// 読み取りパスワード "password" を指定して埋め込んだ 1 つ目のブックをオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
creator1.OpenBookEx(@"C:\Out1.xlsx", (byte[])resourceManager.GetObject("ResourceID1"), "password", out bookInfo1);
// 読み取りパスワード "password" を指定して埋め込んだ 2 つ目のブックをオーバーレイオープンし、"C:\Out2.xlsx" に出力します。
creator1.OpenBookEx(@"C:\Out2.xlsx", (byte[])resourceManager.GetObject("ResourceID2"), "password", out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 現在実行中のアセンブリを取得します。
Dim assembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
' 埋め込んだテンプレートファイル(.resx)の基本名とアセンブリの参照を指定します。
Dim resourceManager As New System.Resources.ResourceManager("WindowsApplication1.Books", assembly)
' 読み取りパスワード "password" を指定して埋め込んだ 1 つ目のブックをオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
Creator1.OpenBookEx("C:\Out1.xlsx", CType(resourceManager.GetObject("ResourceID1"), Byte()), "password", bookInfo1)
' 読み取りパスワード "password" を指定して埋め込んだ 2 つ目のブックをオーバーレイオープンし、"C:\Out2.xlsx" に出力します。
Creator1.OpenBookEx("C:\Out2.xlsx", CType(resourceManager.GetObject("ResourceID2"), Byte()), "password", bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス
OpenBookEx オーバーロード


Creator.OpenBookEx メソッド (String, Stream, String, Object)

CreatorOpenBookEx メソッド (String, Stream, String, Object)

Stream を元ファイルとしてブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBookEx(
    string fileName,
    Stream sourceStream,
    string password,
    out Object bookInfo
)
Public Function OpenBookEx (
    fileName As String,
    sourceStream As Stream,
    password As String,
    <OutAttribute> ByRef bookInfo As Object
) As Integer

パラメーター

fileName
型: SystemString
作成するブックのファイル名を指定します。
sourceStream
型: System.IOStream
オーバーレイ元ファイルのストリームを指定します。
password
型: SystemString
オーバーレイ元ファイルの読み取りパスワードを指定します。
bookInfo
型: SystemObject
ブックを識別するためのハンドルを受け取る object 型への参照を指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
解説
出力後の Excel ファイルに読み取りパスワードを引き継ぐことはできません。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 現在実行中のアセンブリを取得します。
System.Reflection.Assembly assembly = System.Reflection.Assembly.GetExecutingAssembly();
// 読み取りパスワード "password" を指定して埋め込んだ 1 つ目のブックをオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
System.IO.Stream sourceStream1 = assembly.GetManifestResourceStream("WindowsApplication1.Book1_pass.xlsx");
creator1.OpenBookEx(@"C:\Out1.xlsx", sourceStream1, "password", out bookInfo1);
// 読み取りパスワード "password" を指定して埋め込んだ 2 つ目のブックをオーバーレイオープンし、"C:\Out2.xlsx" に出力します。
System.IO.Stream sourceStream2 = assembly.GetManifestResourceStream("WindowsApplication1.Book2_pass.xlsx");
creator1.OpenBookEx(@"C:\Out2.xlsx", sourceStream2, "password", out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 現在実行中のアセンブリを取得します。
Dim assembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
' 読み取りパスワード "password" を指定して埋め込んだ 1 つ目のブックをオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
Dim sourceStream1 As System.IO.Stream = assembly.GetManifestResourceStream("WindowsApplication1.Book1_pass.xlsx")
Creator1.OpenBookEx("C:\Out1.xlsx", sourceStream1, "password", bookInfo1)
' 読み取りパスワード "password" を指定して埋め込んだ 2 つ目のブックをオーバーレイオープンし、"C:\Out2.xlsx" に出力します。
Dim sourceStream2 As System.IO.Stream = assembly.GetManifestResourceStream("WindowsApplication1.Book2_pass.xlsx")
Creator1.OpenBookEx("C:\Out2.xlsx", sourceStream2, "password", bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス
OpenBookEx オーバーロード


Creator.OpenBookEx メソッド (String, String, String, Object)

CreatorOpenBookEx メソッド (String, String, String, Object)

ブックをオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int OpenBookEx(
    string fileName,
    string templateName,
    string password,
    out Object bookInfo
)
Public Function OpenBookEx (
    fileName As String,
    templateName As String,
    password As String,
    <OutAttribute> ByRef bookInfo As Object
) As Integer

パラメーター

fileName
型: SystemString
オープンするブックのファイル名を指定します。
templateName
型: SystemString
オーバーレイ元ファイル名を指定します。
password
型: SystemString
オーバーレイ元ファイルの読み取りパスワードを指定します。
bookInfo
型: SystemObject
ブックを識別するためのハンドルを受け取る object 型への参照を指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
解説
出力後の Excel ファイルに読み取りパスワードを引き継ぐことはできません。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 読み取りパスワード "password" を指定して 1 つ目のブックをオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
creator1.OpenBookEx(@"C:\Out1.xlsx", @"C:\Book1_pass.xlsx", "password", out bookInfo1);
// 読み取りパスワード "password" を指定して 2 つ目のブックをオーバーレイオープンし、"C:\Out2.xlsx" に出力します。
creator1.OpenBookEx(@"C:\Out2.xlsx", @"C:\Book2_pass.xlsx", "password", out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 読み取りパスワード "password" を指定して 1 つ目のブックをオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
Creator1.OpenBookEx("C:\Out1.xlsx", "C:\Book1_pass.xlsx", "password", bookInfo1)
' 読み取りパスワード "password" を指定して 2 つ目のブックをオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
Creator1.OpenBookEx("C:\Out2.xlsx", "C:\Book2_pass.xlsx", "password", bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス
OpenBookEx オーバーロード


Creator.Pos メソッド

CreatorPos メソッド

オーバーロードの一覧
名前 | 説明
Pos(Int32, Int32) | Cell を取得します。
Pos(Int32, Int32, Int32, Int32) | Cell を取得します。
トップ
関連項目

参照

Creator クラス


Creator.Pos メソッド (Int32, Int32)

CreatorPos メソッド (Int32, Int32)

Cell を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Cell Pos(
    int sx,
    int sy
)
Public Function Pos (
    sx As Integer,
    sy As Integer
) As Cell

パラメーター

sx
型: SystemInt32
x 座標(0～)を指定します。
sy
型: SystemInt32
y 座標(0～)を指定します。

戻り値

型: Cell
Cell を返します。
解説
A1(0, 0)を基点として、座標で指定します。
例
C#
VB
コピー
// A1 セルに文字列 "アドバンスソフトウェア" を設定します。
creator1.Pos(0, 0).Value = "アドバンスソフトウェア";
// B1 セルに文字列 "アドバンスソフトウェア" を設定します。
creator1.Pos(1, 0).Value = "アドバンスソフトウェア";
' A1 セルに文字列 "アドバンスソフトウェア" を設定します。
Creator1.Pos(0, 0).Value = "アドバンスソフトウェア"
' B1 セルに文字列 "アドバンスソフトウェア" を設定します。
Creator1.Pos(1, 0).Value = "アドバンスソフトウェア"
関連項目

参照

Creator クラス
Pos オーバーロード


Creator.Pos メソッド (Int32, Int32, Int32, Int32)

CreatorPos メソッド (Int32, Int32, Int32, Int32)

Cell を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Cell Pos(
    int sx,
    int sy,
    int ex,
    int ey
)
Public Function Pos (
    sx As Integer,
    sy As Integer,
    ex As Integer,
    ey As Integer
) As Cell

パラメーター

sx
型: SystemInt32
開始 x 座標(0～)を指定します。
sy
型: SystemInt32
開始 y 座標(0～)を指定します。
ex
型: SystemInt32
終了 x 座標(0～)を指定します。
ey
型: SystemInt32
終了 y 座標(0～)を指定します。

戻り値

型: Cell
Cell を返します。
例
C#
VB
コピー
// A1 セルに文字列 "アドバンスソフトウェア" を設定します。
creator1.Pos(0, 0, 0, 0).Value = "アドバンスソフトウェア";
// A1:B2 セルに文字列 "アドバンスソフトウェア" を設定します。
creator1.Pos(0, 0, 1, 1).Value = "アドバンスソフトウェア";
' A1 セルに文字列 "アドバンスソフトウェア" を設定します。
Creator1.Pos(0, 0, 0, 0).Value = "アドバンスソフトウェア"
' A1:B2 セルに文字列 "アドバンスソフトウェア" を設定します。
Creator1.Pos(0, 0, 1, 1).Value = "アドバンスソフトウェア"
関連項目

参照

Creator クラス
Pos オーバーロード


Creator.PrintArea メソッド

CreatorPrintArea メソッド

印刷範囲を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void PrintArea(
    int sx,
    int sy,
    int ex,
    int ey
)
Public Sub PrintArea (
    sx As Integer,
    sy As Integer,
    ex As Integer,
    ey As Integer
)

パラメーター

sx
型: SystemInt32
開始 x 座標(0～)を設定します。
sy
型: SystemInt32
開始 y 座標(0～)を設定します。
ex
型: SystemInt32
終了 x 座標(0～)を設定します。
ey
型: SystemInt32
終了 y 座標(0～)を設定します。
解説
PDF ファイル出力時に印刷範囲を適用する場合は PdfOption.ApplyPrintArea プロパティに True を設定してください。
例
C#
VB
コピー
// A1:E10 セルを印刷範囲に設定します。
creator1.PrintArea(0, 0, 4, 9);
' A1:E10 セルを印刷範囲に設定します。
Creator1.PrintArea(0, 0, 4, 9)
関連項目

参照

Creator クラス


Creator.PrintTitle メソッド

CreatorPrintTitle メソッド

印刷タイトルを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void PrintTitle(
    int sy,
    int ey,
    int sx,
    int ex
)
Public Sub PrintTitle (
    sy As Integer,
    ey As Integer,
    sx As Integer,
    ex As Integer
)

パラメーター

sy
型: SystemInt32
開始 y 座標(0～)を設定します。
ey
型: SystemInt32
終了 y 座標(0～)を設定します。
sx
型: SystemInt32
開始 x 座標(0～)を設定します。
ex
型: SystemInt32
終了 x 座標(0～)を設定します。
解説
PDF ファイル出力時に印刷範囲を適用する場合は PdfOption.ApplyPrintTitle プロパティに True を設定してください。
例
C#
VB
コピー
// 1 ～ 2 行目をタイトル行に設定します。
creator1.PrintTitle(0, 1, -1, -1);
// A ～ B 列目をタイトル列に設定します。
creator1.PrintTitle(-1, -1, 0, 1);
' 1 ～ 2 行目をタイトル行に設定します。
Creator1.PrintTitle(0, 1, -1, -1)
' A ～ B 列目をタイトル列に設定します。
Creator1.PrintTitle(-1, -1, 0, 1)
関連項目

参照

Creator クラス


Creator.ReadBook メソッド

CreatorReadBook メソッド

ブックを読み取り専用でオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int ReadBook(
    string fileName
)
Public Function ReadBook (
    fileName As String
) As Integer

パラメーター

fileName
型: SystemString
オープンするブックのファイル名を指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
// "C:\Book1.xlsx" を読み取り専用でオープンします。
creator1.ReadBook(@"C:\Book1.xlsx");
creator1.CloseBook(true);
' "C:\Book1.xlsx" を読み取り専用でオープンします。
Creator1.ReadBook("C:\Book1.xlsx")
Creator1.CloseBook(True)
関連項目

参照

Creator クラス


Creator.ReadBookEx メソッド

CreatorReadBookEx メソッド

ブックを読み取り専用でオープンします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int ReadBookEx(
    string fileName,
    out Object bookInfo
)
Public Function ReadBookEx (
    fileName As String,
    <OutAttribute> ByRef bookInfo As Object
) As Integer

パラメーター

fileName
型: SystemString
オープンするブックのファイル名を指定します。
bookInfo
型: SystemObject
ブックを識別するためのハンドルを受け取る object 型への参照を指定します。

戻り値

型: Int32
ブックのオープンに成功した場合 0、失敗した場合 -1。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 1 つ目のブックを読み取り専用でオープンします。
creator1.ReadBookEx(@"C:\Book1.xlsx", out bookInfo1);
// 2 つ目のブックを読み取り専用でオープンします。
creator1.ReadBookEx(@"C:\Book2.xlsx", out bookInfo2);

// 1 つ目のブックを選択し、セル値を取得します。
creator1.SelectBook(bookInfo1);
object value1 = creator1.Cell("A1").Value;
// 2 つ目のブックを選択し、セル値を取得します。
creator1.SelectBook(bookInfo2);
object value2 = creator1.Cell("A1").Value;

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 1 つ目のブックを読み取り専用でオープンします。
Creator1.ReadBookEx("C:\Book1.xlsx", bookInfo1)
' 2 つ目のブックを読み取り専用でオープンします。
Creator1.ReadBookEx("C:\Book2.xlsx", bookInfo2)

' 1 つ目のブックを選択し、セル値を取得します。
Creator1.SelectBook(bookInfo1)
Dim value1 As Object = Creator1.Cell("A1").Value
' 2 つ目のブックを選択し、セル値を取得します。
Creator1.SelectBook(bookInfo2)
Dim value2 As Object = Creator1.Cell("A1").Value

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス


Creator.RowClear メソッド

CreatorRowClear メソッド

オーバーロードの一覧
名前 | 説明
RowClear(Int32) | 行をクリアします。
RowClear(Int32, Int32) | 行をクリアします。
トップ
関連項目

参照

Creator クラス


Creator.RowClear メソッド (Int32)

CreatorRowClear メソッド (Int32)

行をクリアします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowClear(
    int sy
)
Public Sub RowClear (
    sy As Integer
)

パラメーター

sy
型: SystemInt32
クリアする行(0～)を指定します。
例
C#
VB
コピー
// 1 行目をクリアします。
creator1.RowClear(0);
' 1 行目をクリアします。
Creator1.RowClear(0)
関連項目

参照

Creator クラス
RowClear オーバーロード


Creator.RowClear メソッド (Int32, Int32)

CreatorRowClear メソッド (Int32, Int32)

行をクリアします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowClear(
    int sy,
    int count
)
Public Sub RowClear (
    sy As Integer,
    count As Integer
)

パラメーター

sy
型: SystemInt32
クリアする行(0～)を指定します。
count
型: SystemInt32
クリアする行数を指定します。
例
C#
VB
コピー
// 1 行目から 5 行分クリアします。
creator1.RowClear(0, 5);
' 1 行目から 5 行分クリアします。
Creator1.RowClear(0, 5)
関連項目

参照

Creator クラス
RowClear オーバーロード


Creator.RowCopy メソッド

CreatorRowCopy メソッド

オーバーロードの一覧
名前 | 説明
RowCopy(Int32) | 行をコピーします。
RowCopy(Int32, Int32) | 行をコピーします。
トップ
関連項目

参照

Creator クラス


Creator.RowCopy メソッド (Int32)

CreatorRowCopy メソッド (Int32)

行をコピーします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowCopy(
    int sy
)
Public Sub RowCopy (
    sy As Integer
)

パラメーター

sy
型: SystemInt32
コピーする行(0～)を指定します。
例
C#
VB
コピー
// 1 行目をメモリ上にコピーします。
creator1.RowCopy(0);
// コピーした行を 2 行目に貼り付けます。
creator1.RowPaste(1);
' 1 行目をメモリ上にコピーします。
Creator1.RowCopy(0)
' コピーした行を 2 行目に貼り付けます。
Creator1.RowPaste(1)
関連項目

参照

Creator クラス
RowCopy オーバーロード


Creator.RowCopy メソッド (Int32, Int32)

CreatorRowCopy メソッド (Int32, Int32)

行をコピーします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowCopy(
    int sy,
    int dy
)
Public Sub RowCopy (
    sy As Integer,
    dy As Integer
)

パラメーター

sy
型: SystemInt32
コピーする行(0～)を指定します。
dy
型: SystemInt32
貼り付けする行(0～)を指定します。
解説
行をコピーします。dy に -1 を指定した時は sy で指定した行がメモリ上にコピーされ、 RowPaste メソッドで指定した行に貼り付けることができます。
例
C#
VB
コピー
// 1 行目をコピーして 2 行目に貼り付けます。
creator1.RowCopy(0, 1);
' 1 行目をコピーして 2 行目に貼り付けます。
Creator1.RowCopy(0, 1)
関連項目

参照

Creator クラス
RowCopy オーバーロード


Creator.RowDelete メソッド

CreatorRowDelete メソッド

オーバーロードの一覧
名前 | 説明
RowDelete(Int32) | 行を削除します。
RowDelete(Int32, Int32) | 行を削除します。
トップ
関連項目

参照

Creator クラス


Creator.RowDelete メソッド (Int32)

CreatorRowDelete メソッド (Int32)

行を削除します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowDelete(
    int sy
)
Public Sub RowDelete (
    sy As Integer
)

パラメーター

sy
型: SystemInt32
削除する行(0～)を指定します。
例
C#
VB
コピー
// 1 行目を削除します。
creator1.RowDelete(0);
' 1 行目を削除します。
Creator1.RowDelete(0)
関連項目

参照

Creator クラス
RowDelete オーバーロード


Creator.RowDelete メソッド (Int32, Int32)

CreatorRowDelete メソッド (Int32, Int32)

行を削除します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowDelete(
    int sy,
    int count
)
Public Sub RowDelete (
    sy As Integer,
    count As Integer
)

パラメーター

sy
型: SystemInt32
削除する行(0～)を指定します。
count
型: SystemInt32
削除する行数を指定します。
例
C#
VB
コピー
// 1 行目から 5 行分削除します。
creator1.RowDelete(0, 5);
' 1 行目から 5 行分削除します。
Creator1.RowDelete(0, 5)
関連項目

参照

Creator クラス
RowDelete オーバーロード


Creator.RowInsert メソッド

CreatorRowInsert メソッド

オーバーロードの一覧
名前 | 説明
RowInsert(Int32) | 行を挿入します。
RowInsert(Int32, Int32) | 行を挿入します。
トップ
関連項目

参照

Creator クラス


Creator.RowInsert メソッド (Int32)

CreatorRowInsert メソッド (Int32)

行を挿入します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowInsert(
    int sy
)
Public Sub RowInsert (
    sy As Integer
)

パラメーター

sy
型: SystemInt32
挿入する行(0～)を指定します。
例
C#
VB
コピー
// 1 行目に 1 行分挿入します。
creator1.RowInsert(0);
' 1 行目に 1 行分挿入します。
Creator1.RowInsert(0)
関連項目

参照

Creator クラス
RowInsert オーバーロード


Creator.RowInsert メソッド (Int32, Int32)

CreatorRowInsert メソッド (Int32, Int32)

行を挿入します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowInsert(
    int sy,
    int count
)
Public Sub RowInsert (
    sy As Integer,
    count As Integer
)

パラメーター

sy
型: SystemInt32
挿入する行(0～)を指定します。
count
型: SystemInt32
挿入する行数を指定します。
例
C#
VB
コピー
// 1 行目に 5 行分挿入します。
creator1.RowInsert(0, 5);
' 1 行目に 5 行分挿入します。
Creator1.RowInsert(0, 5)
関連項目

参照

Creator クラス
RowInsert オーバーロード


Creator.RowInsertCopied メソッド

CreatorRowInsertCopied メソッド

オーバーロードの一覧
名前 | 説明
RowInsertCopied(Int32) | コピーした行を挿入します。
RowInsertCopied(Int32, Int32) | コピーした行を挿入します。
トップ
関連項目

参照

Creator クラス


Creator.RowInsertCopied メソッド (Int32)

CreatorRowInsertCopied メソッド (Int32)

コピーした行を挿入します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowInsertCopied(
    int sy
)
Public Sub RowInsertCopied (
    sy As Integer
)

パラメーター

sy
型: SystemInt32
挿入する行(0～)を指定します。
解説
RowCopy メソッドでコピーした行を挿入します。
例
C#
VB
コピー
// 1 行目をメモリ上にコピーします。
creator1.RowCopy(0);
// コピーした行を 2 行目に挿入します。
creator1.RowInsertCopied(1);
' 1 行目をメモリ上にコピーします。
Creator1.RowCopy(0)
' コピーした行を 2 行目に挿入します。
Creator1.RowInsertCopied(1)
関連項目

参照

Creator クラス
RowInsertCopied オーバーロード


Creator.RowInsertCopied メソッド (Int32, Int32)

CreatorRowInsertCopied メソッド (Int32, Int32)

コピーした行を挿入します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowInsertCopied(
    int sy,
    int count
)
Public Sub RowInsertCopied (
    sy As Integer,
    count As Integer
)

パラメーター

sy
型: SystemInt32
挿入する行(0～)を指定します。
count
型: SystemInt32
挿入する行数を指定します。
例
C#
VB
コピー
// 1 行目をメモリ上にコピーします。
creator1.RowCopy(0);
// コピーした行を 2 行目に 5 行分挿入します。
creator1.RowInsertCopied(1, 5);
' 1 行目をメモリ上にコピーします。
Creator1.RowCopy(0)
' コピーした行を 2 行目に 5 行分挿入します。
Creator1.RowInsertCopied(1, 5)
関連項目

参照

Creator クラス
RowInsertCopied オーバーロード


Creator.RowPaste メソッド

CreatorRowPaste メソッド

コピーした行を貼り付けします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowPaste(
    int dy
)
Public Sub RowPaste (
    dy As Integer
)

パラメーター

dy
型: SystemInt32
貼り付けする行(0～)を指定します。
解説
RowCopy メソッドでメモリ上にコピーした行を、引数 dy で指定した行に貼り付けます。
例
C#
VB
コピー
// 1 行目をメモリ上にコピーします。
creator1.RowCopy(0);
// コピーした行を 2 行目に貼り付けます。
creator1.RowPaste(1);
' 1 行目をメモリ上にコピーします。
Creator1.RowCopy(0)
' コピーした行を 2 行目に貼り付けます。
Creator1.RowPaste(1)
関連項目

参照

Creator クラス


Creator.SelectBook メソッド

CreatorSelectBook メソッド

処理の対象となるブックを切り替えます。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void SelectBook(
    Object bookInfo
)
Public Sub SelectBook (
    bookInfo As Object
)

パラメーター

bookInfo
型: SystemObject
操作対象とする Excel ファイルの識別 ID を指定します。
例
C#
VB
コピー
object bookInfo1;
object bookInfo2;
// 1 つ目のブック(C:\Book1.xlsx)をオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
creator1.OpenBookEx(@"C:\Out1.xlsx", @"C:\Book1.xlsx", out bookInfo1);
// 2 つ目のブック(C:\Book2.xlsx)をオーバーレイオープンし、"C:\Out2.xlsx" に出力します。
creator1.OpenBookEx(@"C:\Out2.xlsx", @"C:\Book2.xlsx", out bookInfo2);

// 1 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo1);
creator1.Cell("A1").Value = "Book1";
// 2 つ目のブックを選択し、文字列を設定します。
creator1.SelectBook(bookInfo2);
creator1.Cell("A1").Value = "Book2";

// 1 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo1);
// 2 つ目のブックをクローズします。
creator1.CloseBookEx(true, bookInfo2);
Dim bookInfo1 As Object
Dim bookInfo2 As Object
' 1 つ目のブック(C:\Book1.xlsx)をオーバーレイオープンし、"C:\Out1.xlsx" に出力します。
Creator1.OpenBookEx("C:\Out1.xlsx", "C:\Book1.xlsx", bookInfo1)
' 2 つ目のブック(C:\Book2.xlsx)をオーバーレイオープンし、"C:\Out2.xlsx" に出力します。
Creator1.OpenBookEx("C:\Out2.xlsx", "C:\Book2.xlsx", bookInfo2)

' 1 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo1)
Creator1.Cell("A1").Value = "Book1"
' 2 つ目のブックを選択し、文字列を設定します。
Creator1.SelectBook(bookInfo2)
Creator1.Cell("A1").Value = "Book2"

' 1 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo1)
' 2 つ目のブックをクローズします。
Creator1.CloseBookEx(True, bookInfo2)
関連項目

参照

Creator クラス


Creator.SetDataSource メソッド

CreatorSetDataSource メソッド

データソースからセルに値を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void SetDataSource(
    Object dataSource
)
Public Sub SetDataSource (
    dataSource As Object
)

パラメーター

dataSource
型: SystemObject
データソースを指定します。
例
C#
VB
コピー
// データソースから DataSet オブジェクトを作成します。
DataSet dataSet = CreateDataSet();
// A1 セルをカレントセルに設定します。
creator1.Cell("A1");
// カレントセルを基点にデータセットを書き込みます。
creator1.SetDataSource(dataSet);
' データソースから DataSet オブジェクトを作成します。
Dim dataSet As DataSet = CreateDataSet()
' A1 セルをカレントセルに設定します。
Creator1.Cell("A1")
' カレントセルを基点にデータセットを書き込みます。
Creator1.SetDataSource(dataSet)
関連項目

参照

Creator クラス


Creator.SetJsonValue メソッド

CreatorSetJsonValue メソッド

JSON 文字列による Excel ファイルへの書き込みをします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void SetJsonValue(
    string jsonValue,
    bool overWriteFormula
)
Public Sub SetJsonValue (
    jsonValue As String,
    overWriteFormula As Boolean
)

パラメーター

jsonValue
型: SystemString
JSON 文字列
overWriteFormula
型: SystemBoolean
計算式の上書き
例
C#
VB
コピー
// tablecreator.js で取得した JSON 文字列を設定します。
creator1.SetJsonValue(jsonValue, true);
' tablecreator.js で取得した JSON 文字列を設定します。
Creator1.SetJsonValue(jsonValue, true)
関連項目

参照

Creator クラス


Creator.SetLicense メソッド

CreatorSetLicense メソッド

オーバーロードの一覧
名前 | 説明
SetLicense(Stream) | ライセンス情報を設定します。
SetLicense(String) | ライセンス情報を設定します。
トップ
関連項目

参照

Creator クラス


Creator.SetLicense メソッド (Stream)

CreatorSetLicense メソッド (Stream)

ライセンス情報を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void SetLicense(
    Stream stream
)
Public Sub SetLicense (
    stream As Stream
)

パラメーター

stream
型: System.IOStream
ライセンスファイルのストリーム
解説
SetLicense メソッドはコンポーネントのインスタンスごとに 1 回呼び出すのみで問題なく、ファイル出力のたびに呼び出す必要はありません。
例
C#
VB
コピー
// ライセンス情報を設定します。
creator1.SetLicense(licenseStream);
// 複数のブックを作成します。
for (int i = 0; i < 5; i++)
{
    // ここで毎回呼び出す必要はありません。
    //creator1.SetLicense(licenseStream);

    creator1.OpenBook(String.Format(@"C:\Out{0}.xlsx", i), @"C:\Book1.xlsx");
    creator1.Cell("A1").Value = i;
    creator1.CloseBook(true);
}
' ライセンス情報を設定します。
Creator1.SetLicense(licenseStream)
' 複数のブックを作成します。
For i As Integer = 0 To 4
    ' ここで毎回呼び出す必要はありません。
    'Creator1.SetLicense(licenseStream)

    Creator1.OpenBook(String.Format("C:\Out{0}.xlsx", i), "C:\Book1.xlsx")
    Creator1.Cell("A1").Value = i
    Creator1.CloseBook(True)
Next
関連項目

参照

Creator クラス
SetLicense オーバーロード


Creator.SetLicense メソッド (String)

CreatorSetLicense メソッド (String)

ライセンス情報を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void SetLicense(
    string path
)
Public Sub SetLicense (
    path As String
)

パラメーター

path
型: SystemString
ライセンスファイルのパス
解説
SetLicense メソッドはコンポーネントのインスタンスごとに 1 回呼び出すのみで問題なく、ファイル出力のたびに呼び出す必要はありません。
例
C#
VB
コピー
// ライセンス情報を設定します。
creator1.SetLicense(@"C:\AdvanceSoftware.ExcelCreator12.License.xml");
// 複数のブックを作成します。
for (int i = 0; i < 5; i++)
{
    // ここで毎回呼び出す必要はありません。
    //creator1.SetLicense(@"C:\AdvanceSoftware.ExcelCreator12.License.xml");

    creator1.OpenBook(String.Format(@"C:\Out{0}.xlsx", i), @"C:\Book1.xlsx");
    creator1.Cell("A1").Value = i;
    creator1.CloseBook(true);
}
' ライセンス情報を設定します。
Creator1.SetLicense("C:\AdvanceSoftware.ExcelCreator12.License.xml")
' 複数のブックを作成します。
For i As Integer = 0 To 4
    ' ここで毎回呼び出す必要はありません。
    'Creator1.SetLicense("C:\AdvanceSoftware.ExcelCreator12.License.xml")

    Creator1.OpenBook(String.Format("C:\Out{0}.xlsx", i), "C:\Book1.xlsx")
    Creator1.Cell("A1").Value = i
    Creator1.CloseBook(True)
Next
関連項目

参照

Creator クラス
SetLicense オーバーロード


Creator.SheetName2 メソッド

CreatorSheetName2 メソッド

シート番号からシート名を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string SheetName2(
    int sheetNo
)
Public Function SheetName2 (
    sheetNo As Integer
) As String

パラメーター

sheetNo
型: SystemInt32
シート名を取得するシートの番号(0～)を指定します。

戻り値

型: String
シート名を返します。
例
C#
VB
コピー
// 2 シート目のシート名を取得します。
string sheetName = creator1.SheetName2(1);
' 2 シート目のシート名を取得します。
Dim sheetName As String = Creator1.SheetName2(1)
関連項目

参照

Creator クラス


Creator.SheetNo2 メソッド

CreatorSheetNo2 メソッド

シート名からシート番号を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int SheetNo2(
    string sheetName
)
Public Function SheetNo2 (
    sheetName As String
) As Integer

パラメーター

sheetName
型: SystemString
シート番号を取得するシート名を指定します。

戻り値

型: Int32
シート番号を返します。
例
C#
VB
コピー
// シート名 "Sheet2" のシート番号を取得します。
int sheetNo = creator1.SheetNo2("Sheet2");
' シート名 "Sheet2" のシート番号を取得します。
Dim sheetNo As Integer = Creator1.SheetNo2("Sheet2")
関連項目

参照

Creator クラス


Creator.Size メソッド

CreatorSize メソッド

オーバーロードの一覧
名前 | 説明
Size(PaperKind) | 用紙を設定します。
Size(Int32, PaperKind) | 用紙を設定します。
Size(PageOrientation, PaperKind) | 用紙を設定します。
Size(PageOrientation, Int32, PaperKind) | 用紙を設定します。
トップ
関連項目

参照

Creator クラス


Creator.Size メソッド (PaperKind)

CreatorSize メソッド (PaperKind)

用紙を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Size(
    PaperKind paperSize
)
Public Sub Size (
    paperSize As PaperKind
)

パラメーター

paperSize
型: System.Drawing.PrintingPaperKind
用紙サイズを設定します。
解説
各設定値は -2 で省略可能です。省略した場合、オーバーレイ元ファイルの設定を引き継ぎます。（新規作成の場合、用紙サイズ : A4 となります。)
例
C#
VB
コピー
// 用紙サイズを "A5" に設定します。
creator1.Size(System.Drawing.Printing.PaperKind.A5);
' 用紙サイズを "A5" に設定します。
Creator1.Size(System.Drawing.Printing.PaperKind.A5)
関連項目

参照

Creator クラス
Size オーバーロード


Creator.Size メソッド (Int32, PaperKind)

CreatorSize メソッド (Int32, PaperKind)

用紙を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Size(
    int scale,
    PaperKind paperSize
)
Public Sub Size (
    scale As Integer,
    paperSize As PaperKind
)

パラメーター

scale
型: SystemInt32
倍率を設定します。
paperSize
型: System.Drawing.PrintingPaperKind
用紙サイズを設定します。
解説
各設定値は -2 で省略可能です。省略した場合、オーバーレイ元ファイルの設定を引き継ぎます。（新規作成の場合、倍率 : 100%、用紙サイズ : A4 となります。)
例
C#
VB
コピー
// 倍率を "120%"、用紙サイズを "A5" に設定します。
creator1.Size(120, System.Drawing.Printing.PaperKind.A5);
' 倍率を "120%"、用紙サイズを "A5" に設定します。
Creator1.Size(120, System.Drawing.Printing.PaperKind.A5)
関連項目

参照

Creator クラス
Size オーバーロード


Creator.Size メソッド (PageOrientation, PaperKind)

CreatorSize メソッド (PageOrientation, PaperKind)

用紙を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Size(
    PageOrientation orientation,
    PaperKind paperSize
)
Public Sub Size (
    orientation As PageOrientation,
    paperSize As PaperKind
)

パラメーター

orientation
型: AdvanceSoftware.ExcelCreatorPageOrientation
用紙方向を設定します。
paperSize
型: System.Drawing.PrintingPaperKind
用紙サイズを設定します。
解説
各設定値は -2 で省略可能です。省略した場合、オーバーレイ元ファイルの設定を引き継ぎます。（新規作成の場合、用紙方向 : 縦、用紙サイズ : A4 となります。)
例
C#
VB
コピー
// 用紙方向を "横"、用紙サイズを "A5" に設定します。
creator1.Size(AdvanceSoftware.ExcelCreator.PageOrientation.Landscape, System.Drawing.Printing.PaperKind.A5);
' 用紙方向を "横"、用紙サイズを "A5" に設定します。
Creator1.Size(AdvanceSoftware.ExcelCreator.PageOrientation.Landscape, System.Drawing.Printing.PaperKind.A5)
関連項目

参照

Creator クラス
Size オーバーロード


Creator.Size メソッド (PageOrientation, Int32, PaperKind)

CreatorSize メソッド (PageOrientation, Int32, PaperKind)

用紙を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Size(
    PageOrientation orientation,
    int scale,
    PaperKind paperSize
)
Public Sub Size (
    orientation As PageOrientation,
    scale As Integer,
    paperSize As PaperKind
)

パラメーター

orientation
型: AdvanceSoftware.ExcelCreatorPageOrientation
用紙方向を設定します。
scale
型: SystemInt32
倍率を設定します。
paperSize
型: System.Drawing.PrintingPaperKind
用紙サイズを設定します。
解説
各設定値は -2 で省略可能です。省略した場合、オーバーレイ元ファイルの設定を引き継ぎます。（新規作成の場合、用紙方向 : 縦、倍率 : 100%、用紙サイズ : A4 となります。)
例
C#
VB
コピー
// 用紙方向を "横"、倍率を "120%"、用紙サイズを "A5" に設定します。
creator1.Size(AdvanceSoftware.ExcelCreator.PageOrientation.Landscape, 120, System.Drawing.Printing.PaperKind.A5);
' 用紙方向を "横"、倍率を "120%"、用紙サイズを "A5" に設定します。
Creator1.Size(AdvanceSoftware.ExcelCreator.PageOrientation.Landscape, 120, System.Drawing.Printing.PaperKind.A5)
関連項目

参照

Creator クラス
Size オーバーロード


Creator.SizeFree メソッド

CreatorSizeFree メソッド

ユーザー定義用紙を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void SizeFree(
    double width,
    double height,
    string paperName
)
Public Sub SizeFree (
    width As Double,
    height As Double,
    paperName As String
)

パラメーター

width
型: SystemDouble
用紙の幅を設定します。
height
型: SystemDouble
用紙の高さを設定します。
paperName
型: SystemString
用紙名を設定します
解説
プリントサーバーのプロパティであらかじめ登録した用紙名を引数 paperName に、用紙サイズ(高さ・幅)を引数 width と height に設定してください。
例
C#
VB
コピー
// 用紙サイズを "ユーザー定義用紙1(200mm×300mm)" に設定します。
creator1.SizeFree(200, 300, "ユーザー定義用紙1(200mm×300mm)");
' 用紙サイズを "ユーザー定義用紙1(200mm×300mm)" に設定します。
Creator1.SizeFree(200, 300, "ユーザー定義用紙1(200mm×300mm)")
関連項目

参照

Creator クラス


Creator.TableRowDelete メソッド

CreatorTableRowDelete メソッド

オーバーロードの一覧
名前 | 説明
TableRowDelete(Int32) | テーブル範囲に含まれる行を削除します。
TableRowDelete(Int32, Int32) | テーブル範囲に含まれる行を削除します。
トップ
関連項目

参照

Creator クラス


Creator.TableRowDelete メソッド (Int32)

CreatorTableRowDelete メソッド (Int32)

テーブル範囲に含まれる行を削除します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void TableRowDelete(
    int sy
)
Public Sub TableRowDelete (
    sy As Integer
)

パラメーター

sy
型: SystemInt32
削除する行(0～)を指定します。
解説
Xlsx 形式のみ対応しています。テーブル範囲に含まれる行を削除する場合、TableRowDelete、RowDelete メソッド単体では、正しくテーブルの行情報を削除することができないため、 RowDelete メソッドと合わせて使用する必要があります。
例
C#
VB
コピー
// テーブルの 3 行目の行を削除します。
creator1.RowDelete(2);
creator1.TableRowDelete(2);
' テーブルの 3 行目の行を削除します。
Creator1.RowDelete(2)
Creator1.TableRowDelete(2)
関連項目

参照

Creator クラス
TableRowDelete オーバーロード


Creator.TableRowDelete メソッド (Int32, Int32)

CreatorTableRowDelete メソッド (Int32, Int32)

テーブル範囲に含まれる行を削除します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void TableRowDelete(
    int sy,
    int count
)
Public Sub TableRowDelete (
    sy As Integer,
    count As Integer
)

パラメーター

sy
型: SystemInt32
削除する行(0～)を指定します。
count
型: SystemInt32
削除する行数を指定します。
解説
Xlsx 形式のみ対応しています。テーブル範囲に含まれる行を削除する場合、TableRowDelete、RowDelete メソッド単体では、正しくテーブルの行情報を削除することができないため、 RowDelete メソッドと合わせて使用する必要があります。
例
C#
VB
コピー
// テーブルの 3 行目から 5 行分を削除します。
creator1.RowDelete(2, 5);
creator1.TableRowDelete(2, 5);
' テーブルの 3 行目から 5 行分を削除します。
Creator1.RowDelete(2, 5)
Creator1.TableRowDelete(2, 5)
関連項目

参照

Creator クラス
TableRowDelete オーバーロード


Creator.TableRowInsert メソッド

CreatorTableRowInsert メソッド

オーバーロードの一覧
名前 | 説明
TableRowInsert(Int32) | テーブル範囲に行を挿入します。
TableRowInsert(Int32, Int32) | テーブル範囲に行を挿入します。
トップ
関連項目

参照

Creator クラス


Creator.TableRowInsert メソッド (Int32)

CreatorTableRowInsert メソッド (Int32)

テーブル範囲に行を挿入します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void TableRowInsert(
    int sy
)
Public Sub TableRowInsert (
    sy As Integer
)

パラメーター

sy
型: SystemInt32
挿入する行(0～)を指定します。
解説
Xlsx 形式のみ対応しています。テーブル範囲に行を挿入する場合、TableRowInsert、RowInsert メソッド単体では、正しくテーブルの行情報を挿入することができないため、 RowInsert メソッドと合わせて使用する必要があります。
例
C#
VB
コピー
// テーブルの 3 行目に行を挿入します。
creator1.RowInsert(2);
creator1.TableRowInsert(2);
' テーブルの 3 行目に行を挿入します。
Creator1.RowInsert(2)
Creator1.TableRowInsert(2)
関連項目

参照

Creator クラス
TableRowInsert オーバーロード


Creator.TableRowInsert メソッド (Int32, Int32)

CreatorTableRowInsert メソッド (Int32, Int32)

テーブル範囲に行を挿入します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void TableRowInsert(
    int sy,
    int count
)
Public Sub TableRowInsert (
    sy As Integer,
    count As Integer
)

パラメーター

sy
型: SystemInt32
挿入する行(0～)を指定します。
count
型: SystemInt32
挿入する行数を指定します。
解説
Xlsx 形式のみ対応しています。テーブル範囲に行を挿入する場合、TableRowInsert、RowInsert メソッド単体では、正しくテーブルの行情報を挿入することができないため、 RowInsert メソッドと合わせて使用する必要があります。
例
C#
VB
コピー
// テーブルの 3 行目から 5 行分挿入します。
creator1.RowInsert(2, 5);
creator1.TableRowInsert(2, 5);
' テーブルの 3 行目から 5 行分挿入します。
Creator1.RowInsert(2, 5)
Creator1.TableRowInsert(2, 5)
関連項目

参照

Creator クラス
TableRowInsert オーバーロード


Creator.VarCheck メソッド

CreatorVarCheck メソッド

指定した変数名が存在するかをチェックします。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool VarCheck(
    string varName
)
Public Function VarCheck (
    varName As String
) As Boolean

パラメーター

varName
型: SystemString
変数名を指定します。

戻り値

型: Boolean
変数名が存在する場合、True を返します。
解説
存在しない変数名に書式や値を設定するとエラーが発生するため、あらかじめ、変数名が存在するか確認を行うことができます。
例
C#
VB
コピー
// 変数名 "**HENSU1" が存在するかをチェックします。
bool varCheck = creator1.VarCheck("**HENSU1");
' 変数名 "**HENSU1" が存在するかをチェックします。
Dim varCheck As Boolean = Creator1.VarCheck("**HENSU1")
関連項目

参照

Creator クラス


Creator イベント

Creator 型は下記のメンバーを公開します。

イベント
名前 | 説明
Error | エラーイベント
トップ
関連項目

参照

Creator クラス


Creator.Error イベント

CreatorError イベント

エラーイベント

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public event CreatorErrorEventHandler Error
Public Event Error As CreatorErrorEventHandler

値

型: AdvanceSoftware.ExcelCreatorCreatorErrorEventHandler
解説
エラー発生時のエラー番号を取得する場合は、CreatorErrorEventArgs の ErrorNo プロパティを参照します。
例
C#
VB
コピー
private void Form1_Load(object sender, EventArgs e)
{
    creator1.Error +=
        new AdvanceSoftware.ExcelCreator.CreatorErrorEventHandler(
        this.creator1_Error);
}

private void creator1_Error(object sender,
    AdvanceSoftware.ExcelCreator.CreatorErrorEventArgs e)
{
    // ここにエラー発生時の処理を追加します。
}
Private Sub Creator1_Error(sender As Object, _
    e As AdvanceSoftware.ExcelCreator.CreatorErrorEventArgs) _
    Handles Creator1.Error
    ' ここにエラー発生時の処理を追加します。
End Sub
関連項目

参照

Creator クラス


CreatorErrorEventArgs クラス

Error イベントのデータを提供します。
継承階層
SystemObject
SystemEventArgs
AdvanceSoftware.ExcelCreatorCreatorErrorEventArgs

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class CreatorErrorEventArgs : EventArgs
Public Class CreatorErrorEventArgs
    Inherits EventArgs

CreatorErrorEventArgs 型は下記のメンバーを公開します。

コンストラクター
 | 名前 | 説明
Public メソッド | CreatorErrorEventArgs | コンストラクター
トップ
プロパティ
 | 名前 | 説明
Public プロパティ | ErrorNo | エラーナンバーを取得します。
トップ
関連項目

参照


CreatorErrorEventArgs コンストラクター

コンストラクター

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public CreatorErrorEventArgs(
    ErrorNo _errorNo
)
Public Sub New (
    _errorNo As ErrorNo
)

パラメーター

_errorNo
型: AdvanceSoftware.ExcelCreatorErrorNo
エラーナンバーを表す、ErrorNo。
関連項目

参照

CreatorErrorEventArgs クラス


CreatorErrorEventArgs プロパティ

CreatorErrorEventArgs 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
Public プロパティ | ErrorNo | エラーナンバーを取得します。
トップ
関連項目

参照

CreatorErrorEventArgs クラス


CreatorErrorEventArgs.ErrorNo プロパティ

CreatorErrorEventArgsErrorNo プロパティ

エラーナンバーを取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo ErrorNo { get; }
Public ReadOnly Property ErrorNo As ErrorNo
    Get

プロパティ値

型: ErrorNo
関連項目

参照

CreatorErrorEventArgs クラス


CreatorErrorEventHandler デリゲート

Error イベントを処理するメソッドを表します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public delegate void CreatorErrorEventHandler(
    Object sender,
    CreatorErrorEventArgs e
)
Public Delegate Sub CreatorErrorEventHandler (
    sender As Object,
    e As CreatorErrorEventArgs
)

パラメーター

sender
型: SystemObject
e
型: AdvanceSoftware.ExcelCreatorCreatorErrorEventArgs
関連項目

参照


DateFormat 列挙体

日付フォーマットを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum DateFormat
Public Enumeration DateFormat
メンバー
メンバー | 値 | 説明
Slash | 0 | スラッシュ区切り
Japanese | 1 | 年月日区切り
Hyphen | 2 | ハイフン区切り
関連項目

参照


DocType 列挙体

HTML の DOCTYPE を示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum DocType
Public Enumeration DocType
メンバー
メンバー | 値 | 説明
Standard | 1 | HTML Living Standard
Html4 | 4 | Html4
Html5 | 5 | Html5
関連項目

参照


Drawing クラス

Excel ファイルにイメージファイルや図形を設定します。Creator オブジェクトを通じてこのクラスにアクセスします。
継承階層
SystemObject
AdvanceSoftware.ExcelCreatorDrawing

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Drawing
Public Class Drawing

Drawing 型は下記のメンバーを公開します。

コンストラクター
 | 名前 | 説明
Public メソッド | Drawing | コンストラクター
トップ
プロパティ
名前 | 説明
ArrowTypeE | 矢印の終点のスタイル、サイズを設定します。
ArrowTypeS | 矢印の始点のスタイル、サイズを設定します。
FillColor | 塗りつぶし色を設定します。
FillColor2 | 塗りつぶし色を設定します。
FontColor | テキストボックスのフォントの色を設定します。
FontColor2 | テキストボックスのフォントの色を設定します。
FontName | テキストボックスのフォント名を設定します。
FontPoint | テキストボックスのフォントサイズを設定します。
FontStyle | テキストボックスのフォントスタイルを設定します。
FontULine | テキストボックスのフォントの下線を設定します。
LineColor | 線の色を設定します。
LineColor2 | 線の色を設定します。
LineStyle | 線種を設定します。
LineWeight | 線の太さを設定します。
ShapeNoFill | オートシェイプ・テキストボックスの「塗りつぶしなし」を設定します。
TextAlign | テキストボックスの水平方向の文字位置を設定します。
TextAnchor | テキストボックスの垂直方向の文字位置を設定します。
TextVertical | テキストボックスの文字の回転を設定します。
トップ
メソッド
名前 | 説明
AddImage(Image) | イメージを設定します。
AddImage(String) | イメージを設定します。
AddImage(Image, Double, Double) | イメージを設定します。
AddImage(String, Double, Double) | イメージを設定します。
AddImage(Image, Double, Double, Double, Double) | イメージを設定します。
AddImage(String, Double, Double, Double, Double) | イメージを設定します。
AddImage(Image, Double, Double, Double, Double, Double, Double) | イメージを設定します。
AddImage(String, Double, Double, Double, Double, Double, Double) | イメージを設定します。
AddLine(ShapeType) | 線を設定します。
AddLine(ShapeType, Double, Double) | 線を設定します。
AddLine(ShapeType, Double, Double, Double, Double) | 線を設定します。
AddLine(ShapeType, Double, Double, Double, Double, Double, Double) | 線を設定します。
AddShape(ShapeType) | オートシェイプを設定します。
AddShape(ShapeType, Double, Double) | オートシェイプを設定します。
AddShape(ShapeType, Double, Double, Double, Double) | オートシェイプを設定します。
AddShape(ShapeType, Double, Double, Double, Double, Double, Double) | オートシェイプを設定します。
AddTextBox(ShapeType, String) | テキストボックスを設定します。
AddTextBox(ShapeType, String, Double, Double) | テキストボックスを設定します。
AddTextBox(ShapeType, String, Double, Double, Double, Double) | テキストボックスを設定します。
AddTextBox(ShapeType, String, Double, Double, Double, Double, Double, Double) | テキストボックスを設定します。
Init | 初期化処理を行います。
トップ
関連項目

参照


Drawing コンストラクター

コンストラクター

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Drawing(
    Creator parent
)
Public Sub New (
    parent As Creator
)

パラメーター

parent
型: AdvanceSoftware.ExcelCreatorCreator
AdvanceSoftware.ExcelCreator.Creator を指定します。
関連項目

参照

Drawing クラス


Drawing プロパティ

Drawing 型は下記のメンバーを公開します。

プロパティ
名前 | 説明
ArrowTypeE | 矢印の終点のスタイル、サイズを設定します。
ArrowTypeS | 矢印の始点のスタイル、サイズを設定します。
FillColor | 塗りつぶし色を設定します。
FillColor2 | 塗りつぶし色を設定します。
FontColor | テキストボックスのフォントの色を設定します。
FontColor2 | テキストボックスのフォントの色を設定します。
FontName | テキストボックスのフォント名を設定します。
FontPoint | テキストボックスのフォントサイズを設定します。
FontStyle | テキストボックスのフォントスタイルを設定します。
FontULine | テキストボックスのフォントの下線を設定します。
LineColor | 線の色を設定します。
LineColor2 | 線の色を設定します。
LineStyle | 線種を設定します。
LineWeight | 線の太さを設定します。
ShapeNoFill | オートシェイプ・テキストボックスの「塗りつぶしなし」を設定します。
TextAlign | テキストボックスの水平方向の文字位置を設定します。
TextAnchor | テキストボックスの垂直方向の文字位置を設定します。
TextVertical | テキストボックスの文字の回転を設定します。
トップ
関連項目

参照

Drawing クラス


Drawing.ArrowTypeE プロパティ

DrawingArrowTypeE プロパティ

矢印の終点のスタイル、サイズを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ArrowType ArrowTypeE { set; }
Public WriteOnly Property ArrowTypeE As ArrowType
    Set

プロパティ値

型: ArrowType
矢印の終点のスタイル、サイズを表す ArrowType。
例
C#
VB
コピー
// 線の色「赤」を設定します。
creator1.Cell("A2:C3").Drawing.LineColor = System.Drawing.Color.Red;
// 線の太さ「5」を設定します。
creator1.Cell("A2:C3").Drawing.LineWeight = 5;
// 線のスタイル「二重線」を設定します。
creator1.Cell("A2:C3").Drawing.LineStyle = AdvanceSoftware.ExcelCreator.LineStyle.Double;
// 線の矢印(始点)「丸」「短い」を設定します。
creator1.Cell("A2:C3").Drawing.ArrowTypeS = AdvanceSoftware.ExcelCreator.ArrowType.Oval | AdvanceSoftware.ExcelCreator.ArrowType.Short;
// 線の矢印(終点)「三角形」を設定します。
creator1.Cell("A2:C3").Drawing.ArrowTypeE = AdvanceSoftware.ExcelCreator.ArrowType.Triangle;
creator1.Cell("A2:C3").Drawing.AddLine(AdvanceSoftware.ExcelCreator.ShapeType.Line);
' 線の色「赤」を設定します。
Creator1.Cell("A2:C3").Drawing.LineColor = System.Drawing.Color.Red
' 線の太さ「5」を設定します。
Creator1.Cell("A2:C3").Drawing.LineWeight = 5
' 線のスタイル「二重線」を設定します。
Creator1.Cell("A2:C3").Drawing.LineStyle = AdvanceSoftware.ExcelCreator.LineStyle.Double
' 線の矢印(始点)「丸」「短い」を設定します。
Creator1.Cell("A2:C3").Drawing.ArrowTypeS = AdvanceSoftware.ExcelCreator.ArrowType.Oval + AdvanceSoftware.ExcelCreator.ArrowType.Short
' 線の矢印(終点)「三角形」を設定します。
Creator1.Cell("A2:C3").Drawing.ArrowTypeE = AdvanceSoftware.ExcelCreator.ArrowType.Triangle
Creator1.Cell("A2:C3").Drawing.AddLine(AdvanceSoftware.ExcelCreator.ShapeType.Line)
関連項目

参照

Drawing クラス


Drawing.ArrowTypeS プロパティ

DrawingArrowTypeS プロパティ

矢印の始点のスタイル、サイズを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ArrowType ArrowTypeS { set; }
Public WriteOnly Property ArrowTypeS As ArrowType
    Set

プロパティ値

型: ArrowType
矢印の始点のスタイル、サイズを表す ArrowType。
例
C#
VB
コピー
// 線の色「赤」を設定します。
creator1.Cell("A2:C3").Drawing.LineColor = System.Drawing.Color.Red;
// 線の太さ「5」を設定します。
creator1.Cell("A2:C3").Drawing.LineWeight = 5;
// 線のスタイル「二重線」を設定します。
creator1.Cell("A2:C3").Drawing.LineStyle = AdvanceSoftware.ExcelCreator.LineStyle.Double;
// 線の矢印(始点)「丸」「短い」を設定します。
creator1.Cell("A2:C3").Drawing.ArrowTypeS = AdvanceSoftware.ExcelCreator.ArrowType.Oval | AdvanceSoftware.ExcelCreator.ArrowType.Short;
// 線の矢印(終点)「三角形」を設定します。
creator1.Cell("A2:C3").Drawing.ArrowTypeE = AdvanceSoftware.ExcelCreator.ArrowType.Triangle;
creator1.Cell("A2:C3").Drawing.AddLine(AdvanceSoftware.ExcelCreator.ShapeType.Line);
' 線の色「赤」を設定します。
Creator1.Cell("A2:C3").Drawing.LineColor = System.Drawing.Color.Red
' 線の太さ「5」を設定します。
Creator1.Cell("A2:C3").Drawing.LineWeight = 5
' 線のスタイル「二重線」を設定します。
Creator1.Cell("A2:C3").Drawing.LineStyle = AdvanceSoftware.ExcelCreator.LineStyle.Double
' 線の矢印(始点)「丸」「短い」を設定します。
Creator1.Cell("A2:C3").Drawing.ArrowTypeS = AdvanceSoftware.ExcelCreator.ArrowType.Oval + AdvanceSoftware.ExcelCreator.ArrowType.Short
' 線の矢印(終点)「三角形」を設定します。
Creator1.Cell("A2:C3").Drawing.ArrowTypeE = AdvanceSoftware.ExcelCreator.ArrowType.Triangle
Creator1.Cell("A2:C3").Drawing.AddLine(AdvanceSoftware.ExcelCreator.ShapeType.Line)
関連項目

参照

Drawing クラス


Drawing.FillColor プロパティ

DrawingFillColor プロパティ

塗りつぶし色を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color FillColor { set; }
Public WriteOnly Property FillColor As Color
    Set

プロパティ値

型: Color
シェイプの塗りつぶし色を表す Color 構造体。
例
C#
VB
コピー
// オートシェイプの塗りつぶし色を "青色" に設定します。
creator1.Cell("A1").Drawing.FillColor = System.Drawing.Color.Blue;
// A1 セルにオートシェイプ "円/楕円" を設定します。
creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse);
' オートシェイプの塗りつぶし色を "青色" に設定します。
Creator1.Cell("A1").Drawing.FillColor = System.Drawing.Color.Blue
' A1 セルにオートシェイプ "円/楕円" を設定します。
Creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse)
関連項目

参照

Drawing クラス


Drawing.FillColor2 プロパティ

DrawingFillColor2 プロパティ

塗りつぶし色を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public xlColor FillColor2 { set; }
Public WriteOnly Property FillColor2 As xlColor
    Set

プロパティ値

型: xlColor
シェイプの塗りつぶし色を表す xlColor 列挙体。
例
C#
VB
コピー
// オートシェイプの塗りつぶし色を "青色" に設定します。
creator1.Cell("A1").Drawing.FillColor2 = AdvanceSoftware.ExcelCreator.xlColor.Blue;
// A1 セルにオートシェイプ "円/楕円" を設定します。
creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse);
' オートシェイプの塗りつぶし色を "青色" に設定します。
Creator1.Cell("A1").Drawing.FillColor2 = AdvanceSoftware.ExcelCreator.xlColor.Blue
' A1 セルにオートシェイプ "円/楕円" を設定します。
Creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse)
関連項目

参照

Drawing クラス


Drawing.FontColor プロパティ

DrawingFontColor プロパティ

テキストボックスのフォントの色を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color FontColor { set; }
Public WriteOnly Property FontColor As Color
    Set

プロパティ値

型: Color
テキストボックスのフォントカラーを表す Color 構造体。
例
C#
VB
コピー
// テキストボックスのフォントの色を "赤色" に設定します。
creator1.Cell("A1").Drawing.FontColor = System.Drawing.Color.Red;
// A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア");
' テキストボックスのフォントの色を "赤色" に設定します。
Creator1.Cell("A1").Drawing.FontColor = System.Drawing.Color.Red
' A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア")
関連項目

参照

Drawing クラス


Drawing.FontColor2 プロパティ

DrawingFontColor2 プロパティ

テキストボックスのフォントの色を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public xlColor FontColor2 { set; }
Public WriteOnly Property FontColor2 As xlColor
    Set

プロパティ値

型: xlColor
テキストボックスのフォントカラーを表す xlColor 列挙体。
例
C#
VB
コピー
// テキストボックスのフォントの色を "赤色" に設定します。
creator1.Cell("A1").Drawing.FontColor2 = AdvanceSoftware.ExcelCreator.xlColor.Red;
// A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア");
' テキストボックスのフォントの色を "赤色" に設定します。
Creator1.Cell("A1").Drawing.FontColor2 = AdvanceSoftware.ExcelCreator.xlColor.Red
' A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア")
関連項目

参照

Drawing クラス


Drawing.FontName プロパティ

DrawingFontName プロパティ

テキストボックスのフォント名を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string FontName { set; }
Public WriteOnly Property FontName As String
    Set

プロパティ値

型: String
テキストボックスのフォント名。
例
C#
VB
コピー
// テキストボックスのフォント名を "ＭＳ 明朝" に設定します。
creator1.Cell("A1").Drawing.FontName = "ＭＳ 明朝";
// A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア");
' テキストボックスのフォント名を "ＭＳ 明朝" に設定します。
Creator1.Cell("A1").Drawing.FontName = "ＭＳ 明朝"
' A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア")
関連項目

参照

Drawing クラス


Drawing.FontPoint プロパティ

DrawingFontPoint プロパティ

テキストボックスのフォントサイズを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double FontPoint { set; }
Public WriteOnly Property FontPoint As Double
    Set

プロパティ値

型: Double
テキストボックスのフォントサイズ(ポイント単位)。
例
C#
VB
コピー
// テキストボックスのフォントサイズを 20.0 ポイントに設定します。
creator1.Cell("A1").Drawing.FontPoint = 20;
// A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア");
' テキストボックスのフォントサイズを 20.0 ポイントに設定します。
Creator1.Cell("A1").Drawing.FontPoint = 20.0
' A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア")
関連項目

参照

Drawing クラス


Drawing.FontStyle プロパティ

DrawingFontStyle プロパティ

テキストボックスのフォントスタイルを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextBoxFontStyle FontStyle { set; }
Public WriteOnly Property FontStyle As TextBoxFontStyle
    Set

プロパティ値

型: TextBoxFontStyle
テキストボックスのフォントスタイルを表す TextBoxFontStyle。
例
C#
VB
コピー
// テキストボックスのフォントスタイルを "太字" に設定します。
creator1.Cell("A1").Drawing.FontStyle = AdvanceSoftware.ExcelCreator.TextBoxFontStyle.Bold;
// A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア");
' テキストボックスのフォントスタイルを "太字" に設定します。
Creator1.Cell("A1").Drawing.FontStyle = AdvanceSoftware.ExcelCreator.TextBoxFontStyle.Bold
' A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア")
関連項目

参照

Drawing クラス


Drawing.FontULine プロパティ

DrawingFontULine プロパティ

テキストボックスのフォントの下線を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public FontULine FontULine { set; }
Public WriteOnly Property FontULine As FontULine
    Set

プロパティ値

型: FontULine
テキストボックスのフォントの下線を表す FontULine。
例
C#
VB
コピー
// テキストボックスのフォントの下線を "標準" に設定します。
creator1.Cell("A1").Drawing.FontULine = AdvanceSoftware.ExcelCreator.FontULine.Normal;
// A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア");
' テキストボックスのフォントの下線を "標準" に設定します。
Creator1.Cell("A1").Drawing.FontULine = AdvanceSoftware.ExcelCreator.FontULine.Normal
' A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア")
関連項目

参照

Drawing クラス


Drawing.LineColor プロパティ

DrawingLineColor プロパティ

線の色を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color LineColor { set; }
Public WriteOnly Property LineColor As Color
    Set

プロパティ値

型: Color
線の色を表す Color 構造体。
例
C#
VB
コピー
// 線の色を "赤色" に設定します。
creator1.Cell("A1").Drawing.LineColor = System.Drawing.Color.Red;
// A1 セルにオートシェイプ "円/楕円" を設定します。
creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse);
' 線の色を "赤色" に設定します。
Creator1.Cell("A1").Drawing.LineColor = System.Drawing.Color.Red
' A1 セルにオートシェイプ "円/楕円" を設定します。
Creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse)
関連項目

参照

Drawing クラス


Drawing.LineColor2 プロパティ

DrawingLineColor2 プロパティ

線の色を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public xlColor LineColor2 { set; }
Public WriteOnly Property LineColor2 As xlColor
    Set

プロパティ値

型: xlColor
線の色を表す xlColor 列挙体。
例
C#
VB
コピー
// 線の色を "赤色" に設定します。
creator1.Cell("A1").Drawing.LineColor2 = AdvanceSoftware.ExcelCreator.xlColor.Red;
// A1 セルにオートシェイプ "円/楕円" を設定します。
creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse);
' 線の色を "赤色" に設定します。
Creator1.Cell("A1").Drawing.LineColor2 = AdvanceSoftware.ExcelCreator.xlColor.Red
' A1 セルにオートシェイプ "円/楕円" を設定します。
Creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse)
関連項目

参照

Drawing クラス


Drawing.LineStyle プロパティ

DrawingLineStyle プロパティ

線種を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LineStyle LineStyle { set; }
Public WriteOnly Property LineStyle As LineStyle
    Set

プロパティ値

型: LineStyle
線種を表す LineStyle。
例
C#
VB
コピー
// 線の種類を "二重線" に設定します。
creator1.Cell("A1").Drawing.LineStyle = AdvanceSoftware.ExcelCreator.LineStyle.Double;
// A1 セルにオートシェイプ "円/楕円" を設定します。
creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse);
// 線の種類を "角点線、上が太い二重線" に設定します。
creator1.Cell("A10").Drawing.LineStyle = AdvanceSoftware.ExcelCreator.LineStyle.SysDash | AdvanceSoftware.ExcelCreator.LineStyle.ThickThin;
// A10 セルにオートシェイプ "角丸四角形" を設定します。
creator1.Cell("A10").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.RoundRect);
' 線の種類を "二重線" に設定します。
Creator1.Cell("A1").Drawing.LineStyle = AdvanceSoftware.ExcelCreator.LineStyle.Double
' A1 セルにオートシェイプ "円/楕円" を設定します。
Creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse)
' 線の種類を "角点線、上が太い二重線" に設定します。
Creator1.Cell("A10").Drawing.LineStyle = AdvanceSoftware.ExcelCreator.LineStyle.SysDash Or AdvanceSoftware.ExcelCreator.LineStyle.ThickThin
' A10 セルにオートシェイプ "角丸四角形" を設定します。
Creator1.Cell("A10").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.RoundRect)
関連項目

参照

Drawing クラス


Drawing.LineWeight プロパティ

DrawingLineWeight プロパティ

線の太さを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double LineWeight { set; }
Public WriteOnly Property LineWeight As Double
    Set

プロパティ値

型: Double
線の太さ。
例
C#
VB
コピー
// 線の太さを 5 に設定します。
creator1.Cell("A1").Drawing.LineWeight = 5;
// A1 セルにオートシェイプ "円/楕円" を設定します。
creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse);
' 線の太さを 5 に設定します。
Creator1.Cell("A1").Drawing.LineWeight = 5
' A1 セルにオートシェイプ "円/楕円" を設定します。
Creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse)
関連項目

参照

Drawing クラス


Drawing.ShapeNoFill プロパティ

DrawingShapeNoFill プロパティ

オートシェイプ・テキストボックスの「塗りつぶしなし」を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShapeNoFill { set; }
Public WriteOnly Property ShapeNoFill As Boolean
    Set

プロパティ値

型: Boolean
True : 塗りつぶしなし、False : 塗りつぶしあり
例
C#
VB
コピー
// オートシェイプを "塗りつぶしあり" に設定します。
creator1.Cell("A1").Drawing.ShapeNoFill = false;
// A1 セルにオートシェイプ "円/楕円" を設定します。
creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse);
' オートシェイプを "塗りつぶしあり" に設定します。
Creator1.Cell("A1").Drawing.ShapeNoFill = False
' A1 セルにオートシェイプ "円/楕円" を設定します。
Creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse)
関連項目

参照

Drawing クラス


Drawing.TextAlign プロパティ

DrawingTextAlign プロパティ

テキストボックスの水平方向の文字位置を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextAlign TextAlign { set; }
Public WriteOnly Property TextAlign As TextAlign
    Set

プロパティ値

型: TextAlign
テキストの水平方向の文字位置を表す TextAlign。
例
C#
VB
コピー
// テキストボックスの水平方向の文字位置を "中央揃え" に設定します。
creator1.Cell("A1").Drawing.TextAlign = AdvanceSoftware.ExcelCreator.TextAlign.Center;
// A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア");
' テキストボックスの水平方向の文字位置を "中央揃え" に設定します。
Creator1.Cell("A1").Drawing.TextAlign = AdvanceSoftware.ExcelCreator.TextAlign.Center
' A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア")
関連項目

参照

Drawing クラス


Drawing.TextAnchor プロパティ

DrawingTextAnchor プロパティ

テキストボックスの垂直方向の文字位置を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextAnchor TextAnchor { set; }
Public WriteOnly Property TextAnchor As TextAnchor
    Set

プロパティ値

型: TextAnchor
テキストの垂直方向の文字位置を表す TextAnchor。
例
C#
VB
コピー
// テキストボックスの垂直方向の文字位置を "中央揃え" に設定します。
creator1.Cell("A1").Drawing.TextAnchor = AdvanceSoftware.ExcelCreator.TextAnchor.Center;
// A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア");
' テキストボックスの垂直方向の文字位置を "中央揃え" に設定します。
Creator1.Cell("A1").Drawing.TextAnchor = AdvanceSoftware.ExcelCreator.TextAnchor.Center
' A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア")
関連項目

参照

Drawing クラス


Drawing.TextVertical プロパティ

DrawingTextVertical プロパティ

テキストボックスの文字の回転を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextVertical TextVertical { set; }
Public WriteOnly Property TextVertical As TextVertical
    Set

プロパティ値

型: TextVertical
テキストの回転を表す TextVertical。
例
C#
VB
コピー
// テキストボックスの文字列の方向を "縦書き" に設定します。
creator1.Cell("A1").Drawing.TextVertical = AdvanceSoftware.ExcelCreator.TextVertical.EaVert;
// A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア");
' テキストボックスの文字列の方向を "縦書き" に設定します。
Creator1.Cell("A1").Drawing.TextVertical = AdvanceSoftware.ExcelCreator.TextVertical.EaVert
' A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア")
関連項目

参照

Drawing クラス


Drawing メソッド

Drawing 型は下記のメンバーを公開します。

メソッド
名前 | 説明
AddImage(Image) | イメージを設定します。
AddImage(String) | イメージを設定します。
AddImage(Image, Double, Double) | イメージを設定します。
AddImage(String, Double, Double) | イメージを設定します。
AddImage(Image, Double, Double, Double, Double) | イメージを設定します。
AddImage(String, Double, Double, Double, Double) | イメージを設定します。
AddImage(Image, Double, Double, Double, Double, Double, Double) | イメージを設定します。
AddImage(String, Double, Double, Double, Double, Double, Double) | イメージを設定します。
AddLine(ShapeType) | 線を設定します。
AddLine(ShapeType, Double, Double) | 線を設定します。
AddLine(ShapeType, Double, Double, Double, Double) | 線を設定します。
AddLine(ShapeType, Double, Double, Double, Double, Double, Double) | 線を設定します。
AddShape(ShapeType) | オートシェイプを設定します。
AddShape(ShapeType, Double, Double) | オートシェイプを設定します。
AddShape(ShapeType, Double, Double, Double, Double) | オートシェイプを設定します。
AddShape(ShapeType, Double, Double, Double, Double, Double, Double) | オートシェイプを設定します。
AddTextBox(ShapeType, String) | テキストボックスを設定します。
AddTextBox(ShapeType, String, Double, Double) | テキストボックスを設定します。
AddTextBox(ShapeType, String, Double, Double, Double, Double) | テキストボックスを設定します。
AddTextBox(ShapeType, String, Double, Double, Double, Double, Double, Double) | テキストボックスを設定します。
Init | 初期化処理を行います。
トップ
関連項目

参照

Drawing クラス


Drawing.AddImage メソッド

DrawingAddImage メソッド

オーバーロードの一覧
名前 | 説明
AddImage(Image) | イメージを設定します。
AddImage(String) | イメージを設定します。
AddImage(Image, Double, Double) | イメージを設定します。
AddImage(String, Double, Double) | イメージを設定します。
AddImage(Image, Double, Double, Double, Double) | イメージを設定します。
AddImage(String, Double, Double, Double, Double) | イメージを設定します。
AddImage(Image, Double, Double, Double, Double, Double, Double) | イメージを設定します。
AddImage(String, Double, Double, Double, Double, Double, Double) | イメージを設定します。
トップ
関連項目

参照

Drawing クラス


Drawing.AddImage メソッド (Image)

DrawingAddImage メソッド (Image)

イメージを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    Image image
)
Public Sub AddImage (
    image As Image
)

パラメーター

image
型: System.DrawingImage
イメージクラスを設定します。
例
C#
VB
コピー
System.Drawing.Image image = System.Drawing.Image.FromFile(@"C:\image.bmp");
// A1 セルに画像を設定します。
creator1.Cell("A1").Drawing.AddImage(image);
Dim image As System.Drawing.Image = System.Drawing.Image.FromFile("C:\image.bmp")
' A1 セルに画像を設定します。
Creator1.Cell("A1").Drawing.AddImage(image)
関連項目

参照

Drawing クラス
AddImage オーバーロード


Drawing.AddImage メソッド (String)

DrawingAddImage メソッド (String)

イメージを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    string fileName
)
Public Sub AddImage (
    fileName As String
)

パラメーター

fileName
型: SystemString
イメージのファイル名を設定します。
例
C#
VB
コピー
// A1 セルに画像を設定します。
creator1.Cell("A1").Drawing.AddImage(@"C:\image.bmp");
' A1 セルに画像を設定します。
Creator1.Cell("A1").Drawing.AddImage("C:\image.bmp")
関連項目

参照

Drawing クラス
AddImage オーバーロード


Drawing.AddImage メソッド (Image, Double, Double)

DrawingAddImage メソッド (Image, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    Image image,
    double width,
    double height
)
Public Sub AddImage (
    image As Image,
    width As Double,
    height As Double
)

パラメーター

image
型: System.DrawingImage
イメージクラスを設定します。
width
型: SystemDouble
イメージの幅を設定します。
height
型: SystemDouble
イメージの高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
System.Drawing.Image image = System.Drawing.Image.FromFile(@"C:\image.bmp");
// スケールモードを "ピクセル(px)" に設定します。
creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel;
// A1 セルに画像 (幅：100px、高さ：100px) を設定します。
creator1.Cell("A1").Drawing.AddImage(image, 100, 100);
Dim image As System.Drawing.Image = System.Drawing.Image.FromFile("C:\image.bmp")
' スケールモードを "ピクセル(px)" に設定します。
Creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel
' A1 セルに画像 (幅：100px、高さ：100px) を設定します。
Creator1.Cell("A1").Drawing.AddImage(image, 100, 100)
関連項目

参照

Drawing クラス
AddImage オーバーロード


Drawing.AddImage メソッド (String, Double, Double)

DrawingAddImage メソッド (String, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    string fileName,
    double width,
    double height
)
Public Sub AddImage (
    fileName As String,
    width As Double,
    height As Double
)

パラメーター

fileName
型: SystemString
イメージのファイル名を設定します。
width
型: SystemDouble
イメージの幅を設定します。
height
型: SystemDouble
イメージの高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel;
// A1 セルに画像 (幅：100px、高さ：100px) を設定します。
creator1.Cell("A1").Drawing.AddImage(@"C:\image.bmp", 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
Creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel
' A1 セルに画像 (幅：100px、高さ：100px) を設定します。
Creator1.Cell("A1").Drawing.AddImage("C:\image.bmp", 100, 100)
関連項目

参照

Drawing クラス
AddImage オーバーロード


Drawing.AddImage メソッド (Image, Double, Double, Double, Double)

DrawingAddImage メソッド (Image, Double, Double, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    Image image,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff
)
Public Sub AddImage (
    image As Image,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double
)

パラメーター

image
型: System.DrawingImage
イメージクラスを設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
System.Drawing.Image image = System.Drawing.Image.FromFile(@"C:\image.bmp");
// スケールモードを "ピクセル(px)" に設定します。
creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
// の位置に画像を設定します。
creator1.Cell("A1").Drawing.AddImage(image, 50, 50, 150, 150);
Dim image As System.Drawing.Image = System.Drawing.Image.FromFile("C:\image.bmp")
' スケールモードを "ピクセル(px)" に設定します。
Creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
' の位置に画像を設定します。
Creator1.Cell("A1").Drawing.AddImage(image, 50, 50, 150, 150)
関連項目

参照

Drawing クラス
AddImage オーバーロード


Drawing.AddImage メソッド (String, Double, Double, Double, Double)

DrawingAddImage メソッド (String, Double, Double, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    string fileName,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff
)
Public Sub AddImage (
    fileName As String,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double
)

パラメーター

fileName
型: SystemString
イメージのファイル名を設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
// の位置に画像を設定します。
creator1.Cell("A1").Drawing.AddImage(@"C:\image.bmp", 50, 50, 150, 150);
' スケールモードを "ピクセル(px)" に設定します。
Creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
' の位置に画像を設定します。
Creator1.Cell("A1").Drawing.AddImage("C:\image.bmp", 50, 50, 150, 150)
関連項目

参照

Drawing クラス
AddImage オーバーロード


Drawing.AddImage メソッド (Image, Double, Double, Double, Double, Double, Double)

DrawingAddImage メソッド (Image, Double, Double, Double, Double, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    Image image,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff,
    double width,
    double height
)
Public Sub AddImage (
    image As Image,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double,
    width As Double,
    height As Double
)

パラメーター

image
型: System.DrawingImage
イメージクラスを設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
width
型: SystemDouble
イメージの幅を設定します。
height
型: SystemDouble
イメージの高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
System.Drawing.Image image = System.Drawing.Image.FromFile(@"C:\image.bmp");
// スケールモードを "ピクセル(px)" に設定します。
creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から画像 (幅：100px、高さ：100px)
// を設定します。
// 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
creator1.Cell("A1").Drawing.AddImage(image, 50, 50, 300, 300, 100, 100);
Dim image As System.Drawing.Image = System.Drawing.Image.FromFile("C:\image.bmp")
' スケールモードを "ピクセル(px)" に設定します。
Creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から画像 (幅：100px、高さ：100px)
' を設定します。
' 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
Creator1.Cell("A1").Drawing.AddImage(image, 50, 50, 300, 300, 100, 100)
関連項目

参照

Drawing クラス
AddImage オーバーロード


Drawing.AddImage メソッド (String, Double, Double, Double, Double, Double, Double)

DrawingAddImage メソッド (String, Double, Double, Double, Double, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    string fileName,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff,
    double width,
    double height
)
Public Sub AddImage (
    fileName As String,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double,
    width As Double,
    height As Double
)

パラメーター

fileName
型: SystemString
イメージのファイル名を設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
width
型: SystemDouble
イメージの幅を設定します。
height
型: SystemDouble
イメージの高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から画像 (幅：100px、高さ：100px)
// を設定します。
// 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
creator1.Cell("A1").Drawing.AddImage(@"C:\image.bmp", 50, 50, 300, 300, 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
Creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から画像 (幅：100px、高さ：100px)
' を設定します。
' 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
Creator1.Cell("A1").Drawing.AddImage("C:\image.bmp", 50, 50, 300, 300, 100, 100)
関連項目

参照

Drawing クラス
AddImage オーバーロード


Drawing.AddLine メソッド

DrawingAddLine メソッド

オーバーロードの一覧
名前 | 説明
AddLine(ShapeType) | 線を設定します。
AddLine(ShapeType, Double, Double) | 線を設定します。
AddLine(ShapeType, Double, Double, Double, Double) | 線を設定します。
AddLine(ShapeType, Double, Double, Double, Double, Double, Double) | 線を設定します。
トップ
関連項目

参照

Drawing クラス


Drawing.AddLine メソッド (ShapeType)

DrawingAddLine メソッド (ShapeType)

線を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddLine(
    ShapeType type
)
Public Sub AddLine (
    type As ShapeType
)

パラメーター

type
型: AdvanceSoftware.ExcelCreatorShapeType
線の種類を設定します。
例
C#
VB
コピー
// A1 セルに "直線" を設定します。
creator1.Cell("A1").Drawing.AddLine(AdvanceSoftware.ExcelCreator.ShapeType.Line);
' A1 セルに "直線" を設定します。
Creator1.Cell("A1").Drawing.AddLine(AdvanceSoftware.ExcelCreator.ShapeType.Line)
関連項目

参照

Drawing クラス
AddLine オーバーロード


Drawing.AddLine メソッド (ShapeType, Double, Double)

DrawingAddLine メソッド (ShapeType, Double, Double)

線を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddLine(
    ShapeType type,
    double width,
    double height
)
Public Sub AddLine (
    type As ShapeType,
    width As Double,
    height As Double
)

パラメーター

type
型: AdvanceSoftware.ExcelCreatorShapeType
線の種類を設定します。
width
型: SystemDouble
線の領域の幅を設定します。
height
型: SystemDouble
線の領域の高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel;
// A1 セルに "直線 (幅：100px、高さ：100px)" を設定します。
creator1.Cell("A1").Drawing.AddLine(AdvanceSoftware.ExcelCreator.ShapeType.Line, 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
Creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel
' A1 セルに "直線 (幅：100px、高さ：100px)" を設定します。
Creator1.Cell("A1").Drawing.AddLine(AdvanceSoftware.ExcelCreator.ShapeType.Line, 100, 100)
関連項目

参照

Drawing クラス
AddLine オーバーロード


Drawing.AddLine メソッド (ShapeType, Double, Double, Double, Double)

DrawingAddLine メソッド (ShapeType, Double, Double, Double, Double)

線を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddLine(
    ShapeType type,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff
)
Public Sub AddLine (
    type As ShapeType,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double
)

パラメーター

type
型: AdvanceSoftware.ExcelCreatorShapeType
線の種類を設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
// の位置に "直線" を設定します。
creator1.Cell("A1").Drawing.AddLine(AdvanceSoftware.ExcelCreator.ShapeType.Line, 50, 50, 150, 150);
' スケールモードを "ピクセル(px)" に設定します。
Creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
' の位置に "直線" を設定します。
Creator1.Cell("A1").Drawing.AddLine(AdvanceSoftware.ExcelCreator.ShapeType.Line, 50, 50, 150, 150)
関連項目

参照

Drawing クラス
AddLine オーバーロード


Drawing.AddLine メソッド (ShapeType, Double, Double, Double, Double, Double, Double)

DrawingAddLine メソッド (ShapeType, Double, Double, Double, Double, Double, Double)

線を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddLine(
    ShapeType type,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff,
    double width,
    double height
)
Public Sub AddLine (
    type As ShapeType,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double,
    width As Double,
    height As Double
)

パラメーター

type
型: AdvanceSoftware.ExcelCreatorShapeType
線の種類を設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
width
型: SystemDouble
線の領域の幅を設定します。
height
型: SystemDouble
線の領域の高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から直線 (幅：100px、高さ：100px)
// を設定します。
// 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
creator1.Cell("A1").Drawing.AddLine(AdvanceSoftware.ExcelCreator.ShapeType.Line, 50, 50, 300, 300, 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
Creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から直線 (幅：100px、高さ：100px)
' を設定します。
' 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
Creator1.Cell("A1").Drawing.AddLine(AdvanceSoftware.ExcelCreator.ShapeType.Line, 50, 50, 300, 300, 100, 100)
関連項目

参照

Drawing クラス
AddLine オーバーロード


Drawing.AddShape メソッド

DrawingAddShape メソッド

オーバーロードの一覧
名前 | 説明
AddShape(ShapeType) | オートシェイプを設定します。
AddShape(ShapeType, Double, Double) | オートシェイプを設定します。
AddShape(ShapeType, Double, Double, Double, Double) | オートシェイプを設定します。
AddShape(ShapeType, Double, Double, Double, Double, Double, Double) | オートシェイプを設定します。
トップ
関連項目

参照

Drawing クラス


Drawing.AddShape メソッド (ShapeType)

DrawingAddShape メソッド (ShapeType)

オートシェイプを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddShape(
    ShapeType type
)
Public Sub AddShape (
    type As ShapeType
)

パラメーター

type
型: AdvanceSoftware.ExcelCreatorShapeType
オートシェイプの種類を設定します。
例
C#
VB
コピー
// A1 セルにオートシェイプ "円/楕円" を設定します。
creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse);
' A1 セルにオートシェイプ "円/楕円" を設定します。
Creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse)
関連項目

参照

Drawing クラス
AddShape オーバーロード


Drawing.AddShape メソッド (ShapeType, Double, Double)

DrawingAddShape メソッド (ShapeType, Double, Double)

オートシェイプを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddShape(
    ShapeType type,
    double width,
    double height
)
Public Sub AddShape (
    type As ShapeType,
    width As Double,
    height As Double
)

パラメーター

type
型: AdvanceSoftware.ExcelCreatorShapeType
オートシェイプの種類を設定します。
width
型: SystemDouble
オートシェイプの幅を設定します。
height
型: SystemDouble
オートシェイプの高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel;
// A1 セルにオートシェイプ "円/楕円 (幅：100px、高さ：100px)" を設定します。
creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
Creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel
' A1 セルにオートシェイプ "円/楕円 (幅：100px、高さ：100px)" を設定します。
Creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, 100, 100)
関連項目

参照

Drawing クラス
AddShape オーバーロード


Drawing.AddShape メソッド (ShapeType, Double, Double, Double, Double)

DrawingAddShape メソッド (ShapeType, Double, Double, Double, Double)

オートシェイプを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddShape(
    ShapeType type,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff
)
Public Sub AddShape (
    type As ShapeType,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double
)

パラメーター

type
型: AdvanceSoftware.ExcelCreatorShapeType
オートシェイプの種類を設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
// の位置に "円/楕円" を設定します。
creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, 50, 50, 150, 150);
' スケールモードを "ピクセル(px)" に設定します。
Creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
' の位置に "円/楕円" を設定します。
Creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, 50, 50, 150, 150)
関連項目

参照

Drawing クラス
AddShape オーバーロード


Drawing.AddShape メソッド (ShapeType, Double, Double, Double, Double, Double, Double)

DrawingAddShape メソッド (ShapeType, Double, Double, Double, Double, Double, Double)

オートシェイプを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddShape(
    ShapeType type,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff,
    double width,
    double height
)
Public Sub AddShape (
    type As ShapeType,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double,
    width As Double,
    height As Double
)

パラメーター

type
型: AdvanceSoftware.ExcelCreatorShapeType
オートシェイプの種類を設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
width
型: SystemDouble
オートシェイプの幅を設定します。
height
型: SystemDouble
オートシェイプの高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から "円/楕円 (幅：100px、高さ：100px)"
// を設定します。
// 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, 50, 50, 300, 300, 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
Creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から "円/楕円 (幅：100px、高さ：100px)"
' を設定します。
' 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
Creator1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, 50, 50, 300, 300, 100, 100)
関連項目

参照

Drawing クラス
AddShape オーバーロード


Drawing.AddTextBox メソッド

DrawingAddTextBox メソッド

オーバーロードの一覧
名前 | 説明
AddTextBox(ShapeType, String) | テキストボックスを設定します。
AddTextBox(ShapeType, String, Double, Double) | テキストボックスを設定します。
AddTextBox(ShapeType, String, Double, Double, Double, Double) | テキストボックスを設定します。
AddTextBox(ShapeType, String, Double, Double, Double, Double, Double, Double) | テキストボックスを設定します。
トップ
関連項目

参照

Drawing クラス


Drawing.AddTextBox メソッド (ShapeType, String)

DrawingAddTextBox メソッド (ShapeType, String)

テキストボックスを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddTextBox(
    ShapeType type,
    string text
)
Public Sub AddTextBox (
    type As ShapeType,
    text As String
)

パラメーター

type
型: AdvanceSoftware.ExcelCreatorShapeType
テキストボックスの種類を設定します。
text
型: SystemString
テキストを設定します。
例
C#
VB
コピー
// A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア");
' A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア")
関連項目

参照

Drawing クラス
AddTextBox オーバーロード


Drawing.AddTextBox メソッド (ShapeType, String, Double, Double)

DrawingAddTextBox メソッド (ShapeType, String, Double, Double)

テキストボックスを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddTextBox(
    ShapeType type,
    string text,
    double width,
    double height
)
Public Sub AddTextBox (
    type As ShapeType,
    text As String,
    width As Double,
    height As Double
)

パラメーター

type
型: AdvanceSoftware.ExcelCreatorShapeType
テキストボックスの種類を設定します。
text
型: SystemString
テキストを設定します。
width
型: SystemDouble
テキストボックスの幅を設定します。
height
型: SystemDouble
テキストボックスの高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel;
// A1 セルにテキストボックス "円/楕円 (幅：100px、高さ：100px)" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア", 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
Creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel
' A1 セルにテキストボックス "円/楕円 (幅：100px、高さ：100px)" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
Creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア", 100, 100)
関連項目

参照

Drawing クラス
AddTextBox オーバーロード


Drawing.AddTextBox メソッド (ShapeType, String, Double, Double, Double, Double)

DrawingAddTextBox メソッド (ShapeType, String, Double, Double, Double, Double)

テキストボックスを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddTextBox(
    ShapeType type,
    string text,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff
)
Public Sub AddTextBox (
    type As ShapeType,
    text As String,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double
)

パラメーター

type
型: AdvanceSoftware.ExcelCreatorShapeType
テキストボックスの種類を設定します。
text
型: SystemString
テキストを設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
// の位置に "円/楕円" を設定し、ボックス内に文字列"アドバンスソフトウェア" を設定します。
creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア", 50, 50, 150, 150);
' スケールモードを "ピクセル(px)" に設定します。
Creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
' の位置に "円/楕円" を設定し、ボックス内に文字列"アドバンスソフトウェア" を設定します。
Creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア", 50, 50, 150, 150)
関連項目

参照

Drawing クラス
AddTextBox オーバーロード


Drawing.AddTextBox メソッド (ShapeType, String, Double, Double, Double, Double, Double, Double)

DrawingAddTextBox メソッド (ShapeType, String, Double, Double, Double, Double, Double, Double)

テキストボックスを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddTextBox(
    ShapeType type,
    string text,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff,
    double width,
    double height
)
Public Sub AddTextBox (
    type As ShapeType,
    text As String,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double,
    width As Double,
    height As Double
)

パラメーター

type
型: AdvanceSoftware.ExcelCreatorShapeType
テキストボックスの種類を設定します。
text
型: SystemString
テキストを設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
width
型: SystemDouble
テキストボックスの幅を設定します。
height
型: SystemDouble
テキストボックスの高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から"円/楕円 (幅：100px、高さ：100px)" を設定し、
// ボックス内に文字列"アドバンスソフトウェア" を設定します。
// 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア", 50, 50, 300, 300, 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
Creator1.ScaleMode = AdvanceSoftware.ExcelCreator.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から"円/楕円 (幅：100px、高さ：100px)" を設定し、
' ボックス内に文字列"アドバンスソフトウェア" を設定します。
' 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
Creator1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ExcelCreator.ShapeType.Ellipse, "アドバンスソフトウェア", 50, 50, 300, 300, 100, 100)
関連項目

参照

Drawing クラス
AddTextBox オーバーロード


Drawing.Init メソッド

DrawingInit メソッド

初期化処理を行います。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Init()
Public Sub Init
解説
設定内容をクリア（初期化）します。
例
C#
VB
コピー
// 線の色「青」を設定します。
creator1.Cell("F4:G8").Drawing.LineColor = Color.Blue;
// 線の太さ「3」を設定します。
creator1.Cell("F4:G8").Drawing.LineWeight = 3;
// 線のスタイル「破線」を設定します。
creator1.Cell("F4:G8").Drawing.LineStyle = AdvanceSoftware.ExcelCreator.LineStyle.Dash;
// 線の矢印(始点)「ひし形」「大きく」を設定します。
creator1.Cell("F4:G8").Drawing.ArrowTypeS = AdvanceSoftware.ExcelCreator.ArrowType.Diamond | AdvanceSoftware.ExcelCreator.ArrowType.Large;
// 線の矢印(終点)「ライン」「小さく」を設定します。
creator1.Cell("F4:G8").Drawing.ArrowTypeE = AdvanceSoftware.ExcelCreator.ArrowType.Arrow | AdvanceSoftware.ExcelCreator.ArrowType.Small;
creator1.Cell("F4:G8").Drawing.AddLine(AdvanceSoftware.ExcelCreator.ShapeType.Line);
// シェイプ情報を初期化します。
creator1.Cell("F4:G8").Drawing.Init();
// 線の色「赤」を設定します。
creator1.Cell("A2:C3").Drawing.LineColor = Color.Red;
// 線の太さ「5」を設定します。
creator1.Cell("A2:C3").Drawing.LineWeight = 5;
// 線のスタイル「二重線」を設定します。
creator1.Cell("A2:C3").Drawing.LineStyle = AdvanceSoftware.ExcelCreator.LineStyle.Double;
// 線の矢印(始点)「丸」「短い」を設定します。
creator1.Cell("A2:C3").Drawing.ArrowTypeS = AdvanceSoftware.ExcelCreator.ArrowType.Oval | AdvanceSoftware.ExcelCreator.ArrowType.Short;
// 線の矢印(終点)「三角形」を設定します。
creator1.Cell("A2:C3").Drawing.ArrowTypeE = AdvanceSoftware.ExcelCreator.ArrowType.Triangle;
creator1.Cell("A2:C3").Drawing.AddLine(AdvanceSoftware.ExcelCreator.ShapeType.Line);
// シェイプ情報を初期化します。
creator1.Cell("A2:C3").Drawing.Init();
' 線の色「青」を設定します。
Creator1.Cell("F4:G8").Drawing.LineColor = Color.Blue
' 線の太さ「3」を設定します。
Creator1.Cell("F4:G8").Drawing.LineWeight = 3
' 線のスタイル「破線」を設定します。
Creator1.Cell("F4:G8").Drawing.LineStyle = AdvanceSoftware.ExcelCreator.LineStyle.Dash
' 線の矢印(始点)「ひし形」「大きく」を設定します。
Creator1.Cell("F4:G8").Drawing.ArrowTypeS = AdvanceSoftware.ExcelCreator.ArrowType.Diamond + AdvanceSoftware.ExcelCreator.ArrowType.Large
' 線の矢印(終点)「ライン」「小さく」を設定します。
Creator1.Cell("F4:G8").Drawing.ArrowTypeE = AdvanceSoftware.ExcelCreator.ArrowType.Arrow + AdvanceSoftware.ExcelCreator.ArrowType.Small
Creator1.Cell("F4:G8").Drawing.AddLine(AdvanceSoftware.ExcelCreator.ShapeType.Line)
' シェイプ情報を初期化します。
Creator1.Cell("F4:G8").Drawing.Init()
' 線の色「赤」を設定します。
Creator1.Cell("A2:C3").Drawing.LineColor = Color.Red
' 線の太さ「5」を設定します。
Creator1.Cell("A2:C3").Drawing.LineWeight = 5
' 線のスタイル「二重線」を設定します。
Creator1.Cell("A2:C3").Drawing.LineStyle = AdvanceSoftware.ExcelCreator.LineStyle.Double
' 線の矢印(始点)「丸」「短い」を設定します。
Creator1.Cell("A2:C3").Drawing.ArrowTypeS = AdvanceSoftware.ExcelCreator.ArrowType.Oval + AdvanceSoftware.ExcelCreator.ArrowType.Short
' 線の矢印(終点)「三角形」を設定します。
Creator1.Cell("A2:C3").Drawing.ArrowTypeE = AdvanceSoftware.ExcelCreator.ArrowType.Triangle
Creator1.Cell("A2:C3").Drawing.AddLine(AdvanceSoftware.ExcelCreator.ShapeType.Line)
' シェイプ情報を初期化します。
Creator1.Cell("A2:C3").Drawing.Init()
関連項目

参照

Drawing クラス


EditMode 列挙体

セルの編集モードを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum EditMode
Public Enumeration EditMode
メンバー
メンバー | 値 | 説明
NotEdit | 0 | 編集を許可しない
UnlockedCells | 1 | ロックされていないセルを編集可能
NamedCells | 2 | 名前の付けられたセルのみ編集可能
All | 99 | すべて編集を許可
関連項目

参照


ErrorNo 列挙体

エラーナンバーを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ErrorNo
Public Enumeration ErrorNo
メンバー
メンバー | 値 | 説明
NoError | 0 | エラーなし。
CannotOpen | 1 | ファイルがオープンできません。
FileHandle | 2 | 無効なファイルハンドルです。
NotOpen | 3 | 未オープンエラー。
SheetNo | 4 | シートナンバーエラー。
Write | 5 | 書き込みエラー。
Action | 6 | 動作モードエラー。
DataKind | 7 | データ種別エラー。
ErrorValue | 8 | エラー値。
ComboFile | 9 | 複合形式エラー。
Clear | 20 | クリアエラー。
Copy | 21 | コピーエラー。
Paste | 22 | 貼り付けエラー。
Insert | 23 | 挿入エラー。
Delete | 24 | 削除エラー。
Length | 31 | 長さエラー。
Locate | 32 | 座標エラー。
Attr | 33 | 属性番号エラー。
Param | 34 | パラメータエラー。
NoData | 35 | データがありません。
EndOfData | 36 | データの終わりです。
VarPoint | 37 | 指定した変数が存在しません。
BreakCount | 38 | 改ページ数が制限を越えました。
InternalMemory | 40 | 内部メモリエラー。
Memory | 41 | メモリエラー。
Internal | 50 | 内部エラー。
Function | 100 | 計算式形式エラー。
DupOpen | 200 | 既にオープンしています。
ExcelOpen | 203 | Excel がオープンできません。
NotSheet | 205 | 指定したシートが存在しません。
NotPrinter | 213 | 利用可能なプリンタが存在しません。
SaveStop | 214 | 保存を中止しました。
SaveAbort | 216 | 保存に失敗しました。
NotVariable | 217 | 変数文字列が見つかりません。
FileType | 220 | インストールされている Excel のバージョンでは処理できません。
Version | 224 | バージョンエラー。
SaveStream | 225 | 保存先ストリームエラー。
SaveDelete | 226 | Excel ファイルの削除に失敗しました。
Create | 300 | ファイル作成エラー。
TempCreate | 301 | 一時ファイルが作成できません。
TempOpen | 302 | 一時ファイルがオープンできません。
Stream | 303 | ストリームエラー。
Protect | 304 | 保護されたシートです。
Mutex | 400 | ミューテックスエラー。
MaxFileName | 401 | ファイル名が長すぎます。
InvalidFileName | 402 | 無効なファイル名です。
EmbedFile | 403 | 埋め込みエラー。
Document | 500 | ドキュメントが作成されていません。
LicenseNotFound | 600 | ライセンス情報が見つかりません。
LicenseFileAccess | 601 | ライセンスファイルにアクセスできません。
LicenseLoad | 602 | ライセンス情報が読み込めません。
License | 603 | ライセンス認証エラー。
PdfSignatureAbort | 700 | PDF ファイルへの電子署名付与に失敗しました。
PdfSignatureTimeStampAbort | 701 | PDF ファイルへの署名タイムスタンプ付与に失敗しました。
PdfDocumentTimeStampAbort | 702 | PDF ファイルへのドキュメントタイムスタンプ付与に失敗しました。
関連項目

参照


ExcelFileType 列挙体

Excel ファイル種別を示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ExcelFileType
Public Enumeration ExcelFileType
メンバー
メンバー | 値 | 説明
xls | 0 | xls 形式を指定します。
xlsx | 1 | xlsx 形式を指定します。
関連項目

参照


FillType 列挙体

塗りつぶしタイプを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum FillType
Public Enumeration FillType
メンバー
メンバー | 値 | 説明
Fill | 0 | 塗りつぶし
Pattern | 1 | パターン
Texture | 2 | テクスチャ
Gradation | 4 | グラデーション
Translucence | 5 | 半透明にする
None | 6 | なし
関連項目

参照


FontStyle 列挙体

フォントスタイルを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum FontStyle
Public Enumeration FontStyle
メンバー
メンバー | 値 | 説明
Normal | 0 | 標準
Bold | 1 | 太字
Italic | 2 | 斜体
BoldItalic | 3 | 太字＋斜体
Strike | 4 | 打ち消し線
Up | 8 | 上付き
Down | 16 | 下付き
関連項目

参照


FontULine 列挙体

フォント下線を示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum FontULine
Public Enumeration FontULine
メンバー
メンバー | 値 | 説明
None | 0 | なし
Normal | 1 | 標準
Double | 2 | 二重線
関連項目

参照


HeaderFooterMode 列挙体

ヘッダー/フッター設定モードを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum HeaderFooterMode
Public Enumeration HeaderFooterMode
メンバー
メンバー | 値 | 説明
Normal | 0 | 標準
OddEven | 1 | 奇数/偶数ページ別指定
FirstPage | 2 | 先頭ページのみ別指定
All | 3 | 奇数/偶数ページ別指定、先頭ページのみ別指定
関連項目

参照


HeaderFooterType 列挙体

ヘッダー/フッター設定タイプを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum HeaderFooterType
Public Enumeration HeaderFooterType
メンバー
メンバー | 値 | 説明
Normal | 0 | 標準
Even | 1 | 奇数/偶数ページ
First | 2 | 先頭ページ
関連項目

参照


HorizontalAlignment 列挙体

水平方向の位置を示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum HorizontalAlignment
Public Enumeration HorizontalAlignment
メンバー
メンバー | 値 | 説明
General | 20 | 標準
Left | 21 | 左詰め
Center | 22 | 中央揃え
Right | 23 | 右詰め
Fill | 24 | 繰り返し
Justify | 25 | 両端揃え
CenterContinuous | 26 | 選択範囲内で中央
Distributed | 27 | 均等割り付け
関連項目

参照


HtmlOption クラス

HTML 出力のオプションを設定します。Creator オブジェクトを通じてこのクラスにアクセスします。
継承階層
SystemObject
AdvanceSoftware.ExcelCreatorHtmlOption

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class HtmlOption
Public Class HtmlOption

HtmlOption 型は下記のメンバーを公開します。

コンストラクター
 | 名前 | 説明
Public メソッド | HtmlOption | コンストラクター
トップ
プロパティ
名前 | 説明
DateFormat | 日付の編集フォーマットを設定します。
DocType | HTML の DOCTYPE を指定します。
EditMode | セルの編集モードを設定します。
ErrorFormulaCellColor | エラーとなった計算式のセルの色を指定します。
ImagePath | イメージ用一時フォルダのパスを指定します。
NamedCells | 編集対象の名前の付けられたセルを設定します。
PageZoom | シートを HTML に展開する際の拡大縮小率を設定します。
ReCalcValue | 対応する計算式の再計算フラグを設定します。
RefSheets | データを参照するシート名を指定します。
ScriptPath | スクリプトフォルダのパスを指定します。
TableMargin | テーブルの余白を設定します。
TableScale | テーブルの倍率を設定します。
TableSize | テーブルのサイズを取得します。
Title | HTML のタイトルを設定します。
トップ
メソッド
名前 | 説明
AddHeader | HTML ヘッダーを追加します。
トップ
関連項目

参照


HtmlOption コンストラクター

コンストラクター

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public HtmlOption(
    Creator parent
)
Public Sub New (
    parent As Creator
)

パラメーター

parent
型: AdvanceSoftware.ExcelCreatorCreator
AdvanceSoftware.ExcelCreator.Creator を指定します。
関連項目

参照

HtmlOption クラス


HtmlOption プロパティ

HtmlOption 型は下記のメンバーを公開します。

プロパティ
名前 | 説明
DateFormat | 日付の編集フォーマットを設定します。
DocType | HTML の DOCTYPE を指定します。
EditMode | セルの編集モードを設定します。
ErrorFormulaCellColor | エラーとなった計算式のセルの色を指定します。
ImagePath | イメージ用一時フォルダのパスを指定します。
NamedCells | 編集対象の名前の付けられたセルを設定します。
PageZoom | シートを HTML に展開する際の拡大縮小率を設定します。
ReCalcValue | 対応する計算式の再計算フラグを設定します。
RefSheets | データを参照するシート名を指定します。
ScriptPath | スクリプトフォルダのパスを指定します。
TableMargin | テーブルの余白を設定します。
TableScale | テーブルの倍率を設定します。
TableSize | テーブルのサイズを取得します。
Title | HTML のタイトルを設定します。
トップ
関連項目

参照

HtmlOption クラス


HtmlOption.DateFormat プロパティ

HtmlOptionDateFormat プロパティ

日付の編集フォーマットを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public DateFormat DateFormat { set; }
Public WriteOnly Property DateFormat As DateFormat
    Set

プロパティ値

型: DateFormat
日付の編集フォーマット。
例
C#
VB
コピー
// スラッシュ区切りで日付を表示します (例 : 2025/01/01)
creator1.Html.DateFormat = DateFormat.Slash;
// 年月日区切りで日付を表示します (例 : 2025年01月01日)
creator1.Html.DateFormat = DateFormat.Japanese;
// ハイフン区切りで日付を表示します (例 : 2025-01-01)
creator1.Html.DateFormat = DateFormat.Hyphen;
' スラッシュ区切りで日付を表示します (例 : 2025/01/01)
Creator1.Html.DateFormat = DateFormat.Slash
' 年月日区切りで日付を表示します (例 : 2025年01月01日)
Creator1.Html.DateFormat = DateFormat.Japanese
' ハイフン区切りで日付を表示します (例 : 2025-01-01)
Creator1.Html.DateFormat = DateFormat.Hyphen
関連項目

参照

HtmlOption クラス


HtmlOption.DocType プロパティ

HtmlOptionDocType プロパティ

HTML の DOCTYPE を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public DocType DocType { set; }
Public WriteOnly Property DocType As DocType
    Set

プロパティ値

型: DocType
HTML の DOCTYPE を表す DocType。
例
C#
VB
コピー
// DOCTYPE 宣言を "HTML Living Standard" に指定します。
creator1.Html.DocType = AdvanceSoftware.ExcelCreator.DocType.Standard;
' DOCTYPE 宣言を "HTML Living Standard" に指定します。
Creator1.Html.DocType = AdvanceSoftware.ExcelCreator.DocType.Standard
関連項目

参照

HtmlOption クラス


HtmlOption.EditMode プロパティ

HtmlOptionEditMode プロパティ

セルの編集モードを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public EditMode EditMode { set; }
Public WriteOnly Property EditMode As EditMode
    Set

プロパティ値

型: EditMode
セルの編集モード。
例
C#
VB
コピー
// 全てのセルの編集を許可します。
creator1.Html.EditMode = EditMode.All;
// 全てのセルの編集を許可しません。
creator1.Html.EditMode = EditMode.NotEdit;
// ロックされていないセルのみ編集を許可します。
creator1.Html.EditMode = EditMode.UnlockedCells;
// 名前の付けられたセルのみ編集を許可します。
creator1.Html.EditMode = EditMode.NamedCells;
' 全てのセルの編集を許可します。
Creator1.Html.EditMode = EditMode.All
' 全てのセルの編集を許可しません。
Creator1.Html.EditMode = EditMode.NotEdit
' ロックされていないセルのみ編集を許可します。
Creator1.Html.EditMode = EditMode.UnlockedCells
' 名前の付けられたセルのみ編集を許可します。
Creator1.Html.EditMode = EditMode.NamedCells
関連項目

参照

HtmlOption クラス


HtmlOption.ErrorFormulaCellColor プロパティ

HtmlOptionErrorFormulaCellColor プロパティ

エラーとなった計算式のセルの色を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color ErrorFormulaCellColor { set; }
Public WriteOnly Property ErrorFormulaCellColor As Color
    Set

プロパティ値

型: Color
エラーとなった計算式のセルの色を表す Color。
例
C#
VB
コピー
// 未対応の計算式、および、エラーとなった計算式のセルの背景色を赤色に設定します。
creator1.Html.ErrorFormulaCellColor = System.Drawing.Color.Red;
' 未対応の計算式、および、エラーとなった計算式のセルの背景色を赤色に設定します。
Creator1.Html.ErrorFormulaCellColor = System.Drawing.Color.Red
関連項目

参照

HtmlOption クラス


HtmlOption.ImagePath プロパティ

HtmlOptionImagePath プロパティ

イメージ用一時フォルダのパスを指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string ImagePath { set; }
Public WriteOnly Property ImagePath As String
    Set

プロパティ値

型: String
イメージ用一時フォルダのパス。
例
C#
VB
コピー
// 画像を保存する一時フォルダのパスを "../images" に設定します。
creator1.Html.ImagePath = "../images";
' 画像を保存する一時フォルダのパスを "../images" に設定します。
Creator1.Html.ImagePath = "../images"
関連項目

参照

HtmlOption クラス


HtmlOption.NamedCells プロパティ

HtmlOptionNamedCells プロパティ

編集対象の名前の付けられたセルを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string[] NamedCells { set; }
Public WriteOnly Property NamedCells As String()
    Set

プロパティ値

型: String
編集対象の名前の付けられたセル。
例
C#
VB
コピー
// 名前の付けられたセルのみ編集を許可します。
creator1.Html.EditMode = EditMode.NamedCells;
// 名前 "セル1" と "セル2" が付けられたセルのみ編集を許可します。
creator1.Html.NamedCells = new string[] { "セル1", "セル2" };
' 名前の付けられたセルのみ編集を許可します。
Creator1.Html.EditMode = EditMode.NamedCells
' 名前 "セル1" と "セル2" が付けられたセルのみ編集を許可します。
Creator1.Html.NamedCells = New String() { "セル1", "セル2" }
関連項目

参照

HtmlOption クラス


HtmlOption.PageZoom プロパティ

HtmlOptionPageZoom プロパティ

シートを HTML に展開する際の拡大縮小率を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int PageZoom { set; }
Public WriteOnly Property PageZoom As Integer
    Set

プロパティ値

型: Int32
シートを HTML に展開する際の拡大縮小率。
例
C#
VB
コピー
// 拡大縮小率を 100% に設定します。
creator1.Html.PageZoom = 100;
' 拡大縮小率を 100% に設定します。
Creator1.Html.PageZoom = 100
関連項目

参照

HtmlOption クラス


HtmlOption.ReCalcValue プロパティ

HtmlOptionReCalcValue プロパティ

対応する計算式の再計算フラグを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ReCalcValue { get; set; }
Public Property ReCalcValue As Boolean
    Get
    Set

プロパティ値

型: Boolean
HTML 出力時に計算式の再計算が行われるようにする場合 True。
例
C#
VB
コピー
creator1.Cell("A1").Value = 100;
creator1.Cell("A2").Value = 200;
creator1.Cell("A3").Func("=A1+A2", null);
// HTML 出力時に計算式の再計算が行われるよう設定します。
creator1.Html.ReCalcValue = true;
Creator1.Cell("A1").Value = 100
Creator1.Cell("A2").Value = 200
Creator1.Cell("A3").Func("=A1+A2", Nothing)
' HTML 出力時に計算式の再計算が行われるよう設定します。
Creator1.Html.ReCalcValue = True
関連項目

参照

HtmlOption クラス


HtmlOption.RefSheets プロパティ

HtmlOptionRefSheets プロパティ

データを参照するシート名を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string[] RefSheets { set; }
Public WriteOnly Property RefSheets As String()
    Set

プロパティ値

型: String
データを参照するシート名。
例
C#
VB
コピー
creator1.SheetNo = 0;
// シート "Sheet2"、"Sheet3" のデータを参照します。
creator1.Html.RefSheets = new string[] { "Sheet2", "Sheet3" };
Creator1.SheetNo = 0
' シート "Sheet2"、"Sheet3" のデータを参照します。
Creator1.Html.RefSheets = New String() { "Sheet2", "Sheet3" }
関連項目

参照

HtmlOption クラス


HtmlOption.ScriptPath プロパティ

HtmlOptionScriptPath プロパティ

スクリプトフォルダのパスを指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string ScriptPath { set; }
Public WriteOnly Property ScriptPath As String
    Set

プロパティ値

型: String
スクリプトフォルダのパス。
例
C#
VB
コピー
// スクリプトフォルダのパスを "../Scripts/" に設定します。
creator1.Html.ScriptPath = "../Scripts/";
' スクリプトフォルダのパスを "../Scripts/" に設定します。
Creator1.Html.ScriptPath = "../Scripts/"
関連項目

参照

HtmlOption クラス


HtmlOption.TableMargin プロパティ

HtmlOptionTableMargin プロパティ

テーブルの余白を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Rectangle TableMargin { set; }
Public WriteOnly Property TableMargin As Rectangle
    Set

プロパティ値

型: Rectangle
テーブルの余白を表す Rectangle。
例
C#
VB
コピー
// テーブルの余白 (左：100px、上：100px、右：200px、下：200px) を設定します。
creator1.Html.TableMargin = new System.Drawing.Rectangle(100, 100, 200, 200);
' テーブルの余白 (左：100px、上：100px、右：200px、下：200px) を設定します。
Creator1.Html.TableMargin = New System.Drawing.Rectangle(100, 100, 200, 200)
関連項目

参照

HtmlOption クラス


HtmlOption.TableScale プロパティ

HtmlOptionTableScale プロパティ

テーブルの倍率を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int TableScale { set; }
Public WriteOnly Property TableScale As Integer
    Set

プロパティ値

型: Int32
テーブルの倍率。
例
C#
VB
コピー
// テーブルの表示倍率を 200% に設定します。
creator1.Html.TableScale = 200;
' テーブルの表示倍率を 200% に設定します。
Creator1.Html.TableScale = 200
関連項目

参照

HtmlOption クラス


HtmlOption.TableSize プロパティ

HtmlOptionTableSize プロパティ

テーブルのサイズを取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Size TableSize { get; }
Public ReadOnly Property TableSize As Size
    Get

プロパティ値

型: Size
テーブルのサイズ(ピクセル単位)を表す Size。
例
C#
VB
コピー
// 作成したテーブルのサイズを取得します。
Size tableSize = creator1.Html.TableSize;
' 作成したテーブルのサイズを取得します。
Dim tableSize As Size = Creator1.Html.TableSize
関連項目

参照

HtmlOption クラス


HtmlOption.Title プロパティ

HtmlOptionTitle プロパティ

HTML のタイトルを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Title { set; }
Public WriteOnly Property Title As String
    Set

プロパティ値

型: String
HTML 文書のタイトル。(既定値 : ExcelCreator 12.0 for .NET)
例
C#
VB
コピー
// HTML 文書のタイトルを "タイトル" に設定します。
creator1.Html.Title = "タイトル";
' HTML 文書のタイトルを "タイトル" に設定します。
Creator1.Html.Title = "タイトル"
関連項目

参照

HtmlOption クラス


HtmlOption メソッド

HtmlOption 型は下記のメンバーを公開します。

メソッド
名前 | 説明
AddHeader | HTML ヘッダーを追加します。
トップ
関連項目

参照

HtmlOption クラス


HtmlOption.AddHeader メソッド

HtmlOptionAddHeader メソッド

HTML ヘッダーを追加します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddHeader(
    string header
)
Public Sub AddHeader (
    header As String
)

パラメーター

header
型: SystemString
HTML ヘッダーを設定します。
例
C#
VB
コピー
// HTML ヘッダーに <meta> タグを追加します。
creator1.Html.AddHeader("<meta name=\"author\" content=\"アドバンスソフトウェア株式会社\">");
' HTML ヘッダーに <meta> タグを追加します。
Creator1.Html.AddHeader("<meta name=""author"" content=""アドバンスソフトウェア株式会社"">")
関連項目

参照

HtmlOption クラス


HtmlOutputType 列挙体

HTML の出力タイプを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum HtmlOutputType
Public Enumeration HtmlOutputType
メンバー
メンバー | 値 | 説明
Table | 0 | Table データ形式出力
Html | 1 | HTML データ形式出力
関連項目

参照


ImageType 列挙体

イメージタイプを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ImageType
Public Enumeration ImageType
メンバー
メンバー | 値 | 説明
JPEG | 0 | Jpeg 形式
GIF | 1 | Gif 形式
BMP | 2 | Bitmap 形式
AUTO | 3 | 自動判定
関連項目

参照


LineStyle 列挙体

オートシェイプの線種を示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum LineStyle
Public Enumeration LineStyle
メンバー
メンバー | 値 | 説明
None | 0 | なし
Normal | 1 | 実線
SysDot | 2 | [Xls] 丸点線, [Xlsx] 角点線
SysDash | 3 | [Xls] 角点線, [Xlsx] システム破線
Dash | 4 | 破線
DashDot | 5 | 一点鎖線
LongDash | 6 | 長破線
LongDashDot | 7 | 長一点鎖線
LongDashDotDot | 8 | 長二点鎖線
Round | 9 | 内部使用
XlsxRoundDot | 10 | 丸点線(Xlsx用)
Single | 16 | 実線
Double | 32 | 二重線
ThickThin | 48 | 上が太い二重線
ThinThick | 64 | 下が太い二重線
Triple | 80 | 三重線
解説
実線/点線(Normal、SysDot、SysDash、Dash、DashDot、LongDash、LongDashDot、LongDashDotDot、XlsxRoundDot)と スタイル(Single、 Double、ThickThin、ThinThick、Triple)を or 演算子で連結して設定することができます。
関連項目

参照


MaxEndPoint 列挙体

データや属性の範囲を示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum MaxEndPoint
Public Enumeration MaxEndPoint
メンバー
メンバー | 値 | 説明
MaxPoint | 0 | x と y が交わる位置の座標を取得します。
EndPoint | 1 | 最終座標を取得します。
関連項目

参照


Orientation 列挙体

文字の方向を示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum Orientation
Public Enumeration Orientation
メンバー
メンバー | 値 | 説明
Horz | 100 | 横書き
Vert | 101 | 縦書き
RvTurn90 | 102 | -90 度回転
Turn90 | 103 | 90 度回転
関連項目

参照


PageCenter 列挙体

ページ中央を示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum PageCenter
Public Enumeration PageCenter
メンバー
メンバー | 値 | 説明
None | 0 | なし
Horz | 1 | 水平
Vert | 2 | 垂直
関連項目

参照


PageOrder 列挙体

ページの方向を示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum PageOrder
Public Enumeration PageOrder
メンバー
メンバー | 値 | 説明
RightFromLeft | 0 | 左から右
BottomFromTop | 1 | 上から下
関連項目

参照


PageOrientation 列挙体

用紙方向を示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum PageOrientation
Public Enumeration PageOrientation
メンバー
メンバー | 値 | 説明
Landscape | 0 | 横
Default | 1 | 標準
Portrait | 2 | 縦
関連項目

参照


Pattern 列挙体

パターンを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum Pattern
Public Enumeration Pattern
メンバー
メンバー | 値 | 説明
None | 0x01000000 | 塗りつぶしなし
Solid | 0x02000000 | 塗りつぶし
MediumGray | 0x03000000 | 50% 灰色
DarkGray | 0x04000000 | 75% 灰色
LightGray | 0x05000000 | 25% 灰色
DarkHorizontal | 0x06000000 | 横 縞
DarkVertical | 0x07000000 | 縦 縞
DarkDown | 0x08000000 | 右下がり斜線 縞
DarkUp | 0x09000000 | 左下がり斜線 縞
DarkGrid | 0x0A000000 | 左下がり斜線 格子
DarkTrellis | 0x0B000000 | 極太線 左下がり斜線 格子
LightHorizontal | 0x0C000000 | 実線 横 縞
LightVertical | 0x0D000000 | 実線 縦 縞
LightDown | 0x0E000000 | 実線 右下がり斜線 縞
LightUp | 0x0F000000 | 実線 左下がり斜線 縞
LightGrid | 0x10000000 | 実線 横 格子
LightTrellis | 0x11000000 | 実線 左下がり斜線 格子
Gray125 | 0x12000000 | 12.5% 灰色
Gray0625 | 0x13000000 | 6.25% 灰色
関連項目

参照


PdfEncryptionType 列挙体

PDF の暗号化強度を示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum PdfEncryptionType
Public Enumeration PdfEncryptionType
メンバー
メンバー | 値 | 説明
NoPassword | 0 | パスワードなし
Acrobat3_RC4_40 | 1 | 40-bit RC4
Acrobat5_RC4_128 | 2 | 128-bit RC4
Acrobat6_RC4_128 | 3 | 128-bit RC4
Acrobat7_AES_128 | 4 | 128-bit AES
Acrobat10_AES_256 | 6 | 256-bit AES(Acrobat 10)
関連項目

参照


PdfOption クラス

PDF 出力のオプションを設定します。Creator オブジェクトを通じてこのクラスにアクセスします。
継承階層
SystemObject
AdvanceSoftware.ExcelCreatorPdfOption

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class PdfOption
Public Class PdfOption

PdfOption 型は下記のメンバーを公開します。

コンストラクター
 | 名前 | 説明
Public メソッド | PdfOption | コンストラクター
トップ
プロパティ
 | 名前 | 説明
 | Application | PDF のアプリケーションを設定します。
 | ApplyPrintArea | PDF ファイル出力時に印刷範囲を適用するかを指定します。
 | ApplyPrintTitle | PDF ファイル出力時に印刷タイトルを適用するかを指定します。
 | Author | PDF の作成者を設定します。
 | CreateFileWithoutSignature | 電子署名、タイムスタンプ付与失敗時に PDF ファイルを生成するかを指定します。
 | EmbedFonts | PDF ファイルに埋め込むフォントを設定します。
 | EncryptionType | PDF ファイルの暗号化強度を設定します。PdfEncryptionType 列挙体で指定してください。
 | EUDCFiles | PDF ファイルで使用する外字ファイル名と対象とするフォント名を指定します。 フォントの種類毎に外字ファイルを切り替えることが可能です。
 | ImageType | イメージの種類を設定します。
 | IsReplaceYenSign | PDF ファイルに出力する文字列の"\"マークの扱いを指定します。
 | OwnerPassword | PDF ファイルのオーナーパスワードを設定します。
 | PatternQuality | PDF のパターンの解像度を設定します。
 | Permit | PDF ファイルの権限を設定します。複数の権限を指定する時は PdfPermit 列挙体を or(|) で連結します。
 | Producer | PDF 変換を設定します。
 | Quality | PDF の解像度を設定します。
 | ReCalcValue | 計算式の再計算を行うかを指定します。
Public プロパティ | Signature | PdfSignature を取得します。
 | StreamMode | PDF ファイル出力時の一時データの作成先を指定します。
 | Subject | PDF のサブタイトルを設定します。
 | Title | PDF のタイトルを設定します。
 | UserPassword | PDF ファイルのユーザーパスワードを設定します。
トップ
関連項目

参照


PdfOption コンストラクター

コンストラクター

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PdfOption(
    Creator parent
)
Public Sub New (
    parent As Creator
)

パラメーター

parent
型: AdvanceSoftware.ExcelCreatorCreator
AdvanceSoftware.ExcelCreator.Creator を指定します。
関連項目

参照

PdfOption クラス


PdfOption プロパティ

PdfOption 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
 | Application | PDF のアプリケーションを設定します。
 | ApplyPrintArea | PDF ファイル出力時に印刷範囲を適用するかを指定します。
 | ApplyPrintTitle | PDF ファイル出力時に印刷タイトルを適用するかを指定します。
 | Author | PDF の作成者を設定します。
 | CreateFileWithoutSignature | 電子署名、タイムスタンプ付与失敗時に PDF ファイルを生成するかを指定します。
 | EmbedFonts | PDF ファイルに埋め込むフォントを設定します。
 | EncryptionType | PDF ファイルの暗号化強度を設定します。PdfEncryptionType 列挙体で指定してください。
 | EUDCFiles | PDF ファイルで使用する外字ファイル名と対象とするフォント名を指定します。 フォントの種類毎に外字ファイルを切り替えることが可能です。
 | ImageType | イメージの種類を設定します。
 | IsReplaceYenSign | PDF ファイルに出力する文字列の"\"マークの扱いを指定します。
 | OwnerPassword | PDF ファイルのオーナーパスワードを設定します。
 | PatternQuality | PDF のパターンの解像度を設定します。
 | Permit | PDF ファイルの権限を設定します。複数の権限を指定する時は PdfPermit 列挙体を or(|) で連結します。
 | Producer | PDF 変換を設定します。
 | Quality | PDF の解像度を設定します。
 | ReCalcValue | 計算式の再計算を行うかを指定します。
Public プロパティ | Signature | PdfSignature を取得します。
 | StreamMode | PDF ファイル出力時の一時データの作成先を指定します。
 | Subject | PDF のサブタイトルを設定します。
 | Title | PDF のタイトルを設定します。
 | UserPassword | PDF ファイルのユーザーパスワードを設定します。
トップ
関連項目

参照

PdfOption クラス


PdfOption.Application プロパティ

PdfOptionApplication プロパティ

PDF のアプリケーションを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Application { set; }
Public WriteOnly Property Application As String
    Set

プロパティ値

型: String
PDF ファイルの文書のプロパティ概要「アプリケーション」。(既定値 : ExcelCreator 12.0 for .NET)
例
C#
VB
コピー
// PDF ファイルの文書のプロパティ「アプリケーション」に "アプリケーション" を設定します。
creator1.Pdf.Application = "アプリケーション";
' PDF ファイルの文書のプロパティ「アプリケーション」に "アプリケーション" を設定します。
Creator1.Pdf.Application = "アプリケーション"
関連項目

参照

PdfOption クラス


PdfOption.ApplyPrintArea プロパティ

PdfOptionApplyPrintArea プロパティ

PDF ファイル出力時に印刷範囲を適用するかを指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ApplyPrintArea { set; }
Public WriteOnly Property ApplyPrintArea As Boolean
    Set

プロパティ値

型: Boolean
PDF ファイル出力時に印刷範囲を適用する場合 True。
例
C#
VB
コピー
// PDF ファイル出力時に印刷範囲を適用します。
creator1.Pdf.ApplyPrintArea = true;
' PDF ファイル出力時に印刷範囲を適用します。
Creator1.Pdf.ApplyPrintArea = True
関連項目

参照

PdfOption クラス


PdfOption.ApplyPrintTitle プロパティ

PdfOptionApplyPrintTitle プロパティ

PDF ファイル出力時に印刷タイトルを適用するかを指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ApplyPrintTitle { set; }
Public WriteOnly Property ApplyPrintTitle As Boolean
    Set

プロパティ値

型: Boolean
PDF ファイル出力時に印刷タイトルを適用する場合 True。
例
C#
VB
コピー
// PDF ファイル出力時に印刷タイトルを適用します。
creator1.Pdf.ApplyPrintTitle = true;
' PDF ファイル出力時に印刷タイトルを適用します。
Creator1.Pdf.ApplyPrintTitle = True
関連項目

参照

PdfOption クラス


PdfOption.Author プロパティ

PdfOptionAuthor プロパティ

PDF の作成者を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Author { set; }
Public WriteOnly Property Author As String
    Set

プロパティ値

型: String
PDF ファイルの文書のプロパティ概要「作成者」。(既定値:Advance Software Co., Ltd.)
例
C#
VB
コピー
// PDF ファイルの文書のプロパティ「作成者」に "作成者" を設定します。
creator1.Pdf.Author = "作成者";
' PDF ファイルの文書のプロパティ「作成者」に "作成者" を設定します。
Creator1.Pdf.Author = "作成者"
関連項目

参照

PdfOption クラス


PdfOption.CreateFileWithoutSignature プロパティ

PdfOptionCreateFileWithoutSignature プロパティ

電子署名、タイムスタンプ付与失敗時に PDF ファイルを生成するかを指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool CreateFileWithoutSignature { get; set; }
Public Property CreateFileWithoutSignature As Boolean
    Get
    Set

プロパティ値

型: Boolean
付与失敗時に署名なしの PDF ファイルを生成する場合は True。
例
C#
VB
コピー
// 電子署名の付与失敗時に署名なしのファイルが出力されるように設定します。
creator1.Pdf.CreateFileWithoutSignature = true;
' 電子署名の付与失敗時に署名なしのファイルが出力されるように設定します。
Creator1.Pdf.CreateFileWithoutSignature = True
関連項目

参照

PdfOption クラス


PdfOption.EmbedFonts プロパティ

PdfOptionEmbedFonts プロパティ

PDF ファイルに埋め込むフォントを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string[] EmbedFonts { set; }
Public WriteOnly Property EmbedFonts As String()
    Set

プロパティ値

型: String
PDF ファイルに埋め込むフォント名。
解説
設定したフォントが Excel ファイルで使用されていない場合は、PDF ファイルには埋め込まれません。 "*" を設定した場合、Excel ファイルで使用しているフォントを全て埋め込みます。
例
C#
VB
コピー
// PDF ファイルにフォント "ＭＳ Ｐゴシック" を埋め込みます。
creator1.Pdf.EmbedFonts = new String[] { "ＭＳ Ｐゴシック" };
' PDF ファイルにフォント "ＭＳ Ｐゴシック" を埋め込みます。
Creator1.Pdf.EmbedFonts = New String() {"ＭＳ Ｐゴシック"}
関連項目

参照

PdfOption クラス


PdfOption.EncryptionType プロパティ

PdfOptionEncryptionType プロパティ

PDF ファイルの暗号化強度を設定します。PdfEncryptionType 列挙体で指定してください。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PdfEncryptionType EncryptionType { set; }
Public WriteOnly Property EncryptionType As PdfEncryptionType
    Set

プロパティ値

型: PdfEncryptionType
PDF ファイルの暗号化強度を表す PdfEncryptionType。
例
C#
VB
コピー
// PDF ファイルの暗号化強度を "Acrobat6_RC4_128" に設定します。
creator1.Pdf.EncryptionType = AdvanceSoftware.ExcelCreator.PdfEncryptionType.Acrobat6_RC4_128;
creator1.Pdf.OwnerPassword = "owner";
creator1.Pdf.UserPassword = "user";
AdvanceSoftware.ExcelCreator.PdfPermit pdfPermit = 0;
pdfPermit = pdfPermit | AdvanceSoftware.ExcelCreator.PdfPermit.PrintHigh | AdvanceSoftware.ExcelCreator.PdfPermit.Copy;
creator1.Pdf.Permit = pdfPermit;
' PDF ファイルの暗号化強度を "Acrobat6_RC4_128" に設定します。
Creator1.Pdf.EncryptionType = AdvanceSoftware.ExcelCreator.PdfEncryptionType.Acrobat6_RC4_128
Creator1.Pdf.OwnerPassword = "owner"
Creator1.Pdf.UserPassword = "user"
Dim pdfPermit As AdvanceSoftware.ExcelCreator.PdfPermit = 0
pdfPermit = pdfPermit Or AdvanceSoftware.ExcelCreator.PdfPermit.PrintHigh Or AdvanceSoftware.ExcelCreator.PdfPermit.Copy
Creator1.Pdf.Permit = pdfPermit
関連項目

参照

PdfOption クラス


PdfOption.EUDCFiles プロパティ

PdfOptionEUDCFiles プロパティ

PDF ファイルで使用する外字ファイル名と対象とするフォント名を指定します。 フォントの種類毎に外字ファイルを切り替えることが可能です。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string[][] EUDCFiles { set; }
Public WriteOnly Property EUDCFiles As String()()
    Set

プロパティ値

型: String
フォント名とフォントファイルのフルパスのリスト(配列)
解説

フォント名と、ファイルパスの設定方法により、PDF で使用される外字の状態が異なります。

【フォント名】

・パターン1・・・特定のフォント名

ファイルパスに設定された外字ファイルを参照します。環境の同一フォントに対する外字設定は無視されます。

・パターン2・・・SystemDefaultEUDCFont

環境に設定されたデフォルトの外字設定を、ファイルパスに設定した外字ファイルから読み込みます。環境のデフォルトのフォント設定は無視されます。

・パターン3・・・空文字("")

環境に登録されたすべての外字設定を無視します。使用する外字を全て手動で指定したい場合は、この設定を含めてください。

【ファイルパス】

・パターン1・・・存在するファイルパス

指定したフォントに対して、このパスの外字ファイルが取り込まれます。

・パターン2・・・存在しないファイルパス

指定したフォントの外字設定は無視され、環境に同一フォントの外字設定がある場合、そちらが読み込まれます。

・パターン3・・・空文字("")

指定したフォントに対する、外字の設定を行ないません。環境の設定も無視されます。

例
C#
VB
コピー
// 環境の外字設定を無視して "ＭＳ 明朝" の外字ファイルを指定します。
creator1.Pdf.EUDCFiles = new string[][] { new string[] { "ＭＳ 明朝", @"C:\ms_mintyou1.TTE" }, new string[] { "", "" } };
' 環境の外字設定を無視して "ＭＳ 明朝" の外字ファイルを指定します。
Creator1.Pdf.EUDCFiles = New String()() {New String() {"ＭＳ 明朝", "C:\ms_mintyou1.TTE"}, New String() {"", ""}}
関連項目

参照

PdfOption クラス


PdfOption.ImageType プロパティ

PdfOptionImageType プロパティ

イメージの種類を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ImageType ImageType { set; }
Public WriteOnly Property ImageType As ImageType
    Set

プロパティ値

型: ImageType
イメージの種類を表す ImageType。
例
C#
VB
コピー
// PDF ファイルに出力するイメージの種類を "GIF 形式" に設定します。
creator1.Pdf.ImageType = AdvanceSoftware.ExcelCreator.ImageType.GIF;
' PDF ファイルに出力するイメージの種類を "GIF 形式" に設定します。
Creator1.Pdf.ImageType = AdvanceSoftware.ExcelCreator.ImageType.GIF
関連項目

参照

PdfOption クラス


PdfOption.IsReplaceYenSign プロパティ

PdfOptionIsReplaceYenSign プロパティ

PDF ファイルに出力する文字列の"\"マークの扱いを指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool IsReplaceYenSign { set; }
Public WriteOnly Property IsReplaceYenSign As Boolean
    Set

プロパティ値

型: Boolean
\ マークをバックスラッシュとして扱う場合 False。
例
C#
VB
コピー
// \ マークをバックスラッシュとして扱います。
creator1.Pdf.IsReplaceYenSign = false;
' \ マークをバックスラッシュとして扱います。
Creator1.Pdf.IsReplaceYenSign = False
関連項目

参照

PdfOption クラス


PdfOption.OwnerPassword プロパティ

PdfOptionOwnerPassword プロパティ

PDF ファイルのオーナーパスワードを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string OwnerPassword { set; }
Public WriteOnly Property OwnerPassword As String
    Set

プロパティ値

型: String
PDF ファイルのオーナーパスワード。
例
C#
VB
コピー
creator1.Pdf.EncryptionType = AdvanceSoftware.ExcelCreator.PdfEncryptionType.Acrobat6_RC4_128;
// PDF ファイルのオーナーパスワードを "owner" に設定します。
creator1.Pdf.OwnerPassword = "owner";
creator1.Pdf.UserPassword = "user";
AdvanceSoftware.ExcelCreator.PdfPermit pdfPermit = 0;
pdfPermit = pdfPermit | AdvanceSoftware.ExcelCreator.PdfPermit.PrintHigh | AdvanceSoftware.ExcelCreator.PdfPermit.Copy;
creator1.Pdf.Permit = pdfPermit;
Creator1.Pdf.EncryptionType = AdvanceSoftware.ExcelCreator.PdfEncryptionType.Acrobat6_RC4_128
' PDF ファイルのオーナーパスワードを "owner" に設定します。
Creator1.Pdf.OwnerPassword = "owner"
Creator1.Pdf.UserPassword = "user"
Dim pdfPermit As AdvanceSoftware.ExcelCreator.PdfPermit = 0
pdfPermit = pdfPermit Or AdvanceSoftware.ExcelCreator.PdfPermit.PrintHigh Or AdvanceSoftware.ExcelCreator.PdfPermit.Copy
Creator1.Pdf.Permit = pdfPermit
関連項目

参照

PdfOption クラス


PdfOption.PatternQuality プロパティ

PdfOptionPatternQuality プロパティ

PDF のパターンの解像度を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int PatternQuality { set; }
Public WriteOnly Property PatternQuality As Integer
    Set

プロパティ値

型: Int32
PDF に出力する場合のセルパターンの解像度。
例
C#
VB
コピー
// PDF ファイル作成時のセルパターンの解像度を "600" に設定します。
creator1.Pdf.PatternQuality = 600;
' PDF ファイル作成時のセルパターンの解像度を "600" に設定します。
Creator1.Pdf.PatternQuality = 600
関連項目

参照

PdfOption クラス


PdfOption.Permit プロパティ

PdfOptionPermit プロパティ

PDF ファイルの権限を設定します。複数の権限を指定する時は PdfPermit 列挙体を or(|) で連結します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PdfPermit Permit { set; }
Public WriteOnly Property Permit As PdfPermit
    Set

プロパティ値

型: PdfPermit
PDF ファイルの権限を表す PdfPermit。
例
C#
VB
コピー
creator1.Pdf.EncryptionType = AdvanceSoftware.ExcelCreator.PdfEncryptionType.Acrobat6_RC4_128;
creator1.Pdf.OwnerPassword = "owner";
creator1.Pdf.UserPassword = "user";
// PDF ファイルの権限で「高精度な印刷」と「内容のコピー」を許可します。
AdvanceSoftware.ExcelCreator.PdfPermit pdfPermit = 0;
pdfPermit = pdfPermit | AdvanceSoftware.ExcelCreator.PdfPermit.PrintHigh | AdvanceSoftware.ExcelCreator.PdfPermit.Copy;
creator1.Pdf.Permit = pdfPermit;
Creator1.Pdf.EncryptionType = AdvanceSoftware.ExcelCreator.PdfEncryptionType.Acrobat6_RC4_128
Creator1.Pdf.OwnerPassword = "owner"
Creator1.Pdf.UserPassword = "user"
' PDF ファイルの権限で「高精度な印刷」と「内容のコピー」を許可します。
Dim pdfPermit As AdvanceSoftware.ExcelCreator.PdfPermit = 0
pdfPermit = pdfPermit Or AdvanceSoftware.ExcelCreator.PdfPermit.PrintHigh Or AdvanceSoftware.ExcelCreator.PdfPermit.Copy
Creator1.Pdf.Permit = pdfPermit
関連項目

参照

PdfOption クラス


PdfOption.Producer プロパティ

PdfOptionProducer プロパティ

PDF 変換を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Producer { set; }
Public WriteOnly Property Producer As String
    Set

プロパティ値

型: String
PDF ファイルの文書のプロパティ概要「PDF 変換」。(既定値 : ExcelCreator 12.0 for .NET)
例
C#
VB
コピー
// PDF ファイルの文書のプロパティ「PDF 変換」に "PDF 変換" を設定します。
creator1.Pdf.Producer = "PDF 変換";
' PDF ファイルの文書のプロパティ「PDF 変換」に "PDF 変換" を設定します。
Creator1.Pdf.Producer = "PDF 変換"
関連項目

参照

PdfOption クラス


PdfOption.Quality プロパティ

PdfOptionQuality プロパティ

PDF の解像度を設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int Quality { set; }
Public WriteOnly Property Quality As Integer
    Set

プロパティ値

型: Int32
PDF ファイルの解像度。
例
C#
VB
コピー
// PDF ファイル作成時の解像度を "600" に設定します。
creator1.Pdf.Quality = 600;
' PDF ファイル作成時の解像度を "600" に設定します。
Creator1.Pdf.Quality = 600
関連項目

参照

PdfOption クラス


PdfOption.ReCalcValue プロパティ

PdfOptionReCalcValue プロパティ

計算式の再計算を行うかを指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ReCalcValue { get; set; }
Public Property ReCalcValue As Boolean
    Get
    Set

プロパティ値

型: Boolean
PDF 出力時に計算式が再計算されるようにする場合 True。
例
C#
VB
コピー
creator1.Cell("A1").Value = 100;
creator1.Cell("A2").Value = 200;
creator1.Cell("A3").Func("=A1+A2", null);
// PDF 出力時に計算式が再計算されるように設定します。
creator1.Pdf.ReCalcValue = true;
Creator1.Cell("A1").Value = 100
Creator1.Cell("A2").Value = 200
Creator1.Cell("A3").Func("=A1+A2", Nothing)
' PDF 出力時に計算式が再計算されるように設定します。
Creator1.Pdf.ReCalcValue = True
関連項目

参照

PdfOption クラス


PdfOption.Signature プロパティ

PdfOptionSignature プロパティ

PdfSignature を取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PdfSignature Signature { get; }
Public ReadOnly Property Signature As PdfSignature
    Get

プロパティ値

型: PdfSignature
PDF に付加する署名のオプションを設定するための PdfSignature クラス。
解説
このクラスの全てのメンバの一覧については、PdfSignature クラスのメンバを参照してください。
関連項目

参照

PdfOption クラス


PdfOption.StreamMode プロパティ

PdfOptionStreamMode プロパティ

PDF ファイル出力時の一時データの作成先を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public StreamMode StreamMode { set; }
Public WriteOnly Property StreamMode As StreamMode
    Set

プロパティ値

型: StreamMode
解説
Memory の場合は処理速度を優先し、File の場合はメモリ使用量を優先します。 デフォルトは Memory です。
例
C#
VB
コピー
// PDF ファイル出力時の動作モードを File に設定します。
creator1.Pdf.StreamMode = AdvanceSoftware.ExcelCreator.StreamMode.File;
' PDF ファイル出力時の動作モードを File に設定します。
Creator1.Pdf.StreamMode = AdvanceSoftware.ExcelCreator.StreamMode.File
関連項目

参照

PdfOption クラス


PdfOption.Subject プロパティ

PdfOptionSubject プロパティ

PDF のサブタイトルを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Subject { set; }
Public WriteOnly Property Subject As String
    Set

プロパティ値

型: String
PDF ファイルの文書のプロパティ概要「サブタイトル」。
例
C#
VB
コピー
// PDF ファイルの文書のプロパティ「サブタイトル」に "サブタイトル" を設定します。
creator1.Pdf.Subject = "サブタイトル";
' PDF ファイルの文書のプロパティ「サブタイトル」に "サブタイトル" を設定します。
Creator1.Pdf.Subject = "サブタイトル"
関連項目

参照

PdfOption クラス


PdfOption.Title プロパティ

PdfOptionTitle プロパティ

PDF のタイトルを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Title { set; }
Public WriteOnly Property Title As String
    Set

プロパティ値

型: String
PDF ファイルの文書のプロパティ概要「タイトル」。(既定値 : ExcelCreator 12.0 for .NET)
例
C#
VB
コピー
// PDF ファイルの文書のプロパティ「タイトル」に "タイトル" を設定します。
creator1.Pdf.Title = "タイトル";
' PDF ファイルの文書のプロパティ「タイトル」に "タイトル" を設定します。
Creator1.Pdf.Title = "タイトル"
関連項目

参照

PdfOption クラス


PdfOption.UserPassword プロパティ

PdfOptionUserPassword プロパティ

PDF ファイルのユーザーパスワードを設定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Creator (in AdvanceSoftware.ExcelCreator.Creator.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string UserPassword { set; }
Public WriteOnly Property UserPassword As String
    Set

プロパティ値

型: String
PDF ファイルのユーザーパスワード。
例
C#
VB
コピー
creator1.Pdf.EncryptionType = AdvanceSoftware.ExcelCreator.PdfEncryptionType.Acrobat6_RC4_128;
creator1.Pdf.OwnerPassword = "owner";
// PDF ファイルのユーザーパスワードを "user" に設定します。
creator1.Pdf.UserPassword = "user";
AdvanceSoftware.ExcelCreator.PdfPermit pdfPermit = 0;
pdfPermit = pdfPermit | AdvanceSoftware.ExcelCreator.PdfPermit.PrintHigh | AdvanceSoftware.ExcelCreator.PdfPermit.Copy;
creator1.Pdf.Permit = pdfPermit;
Creator1.Pdf.EncryptionType = AdvanceSoftware.ExcelCreator.PdfEncryptionType.Acrobat6_RC4_128
Creator1.Pdf.OwnerPassword = "owner"
' PDF ファイルのユーザーパスワードを "user" に設定します。
Creator1.Pdf.UserPassword = "user"
Dim pdfPermit As AdvanceSoftware.ExcelCreator.PdfPermit = 0
pdfPermit = pdfPermit Or AdvanceSoftware.ExcelCreator.PdfPermit.PrintHigh Or AdvanceSoftware.ExcelCreator.PdfPermit.Copy
Creator1.Pdf.Permit = pdfPermit
関連項目

参照

PdfOption クラス


PdfPermit 列挙体

PDF の権限を示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum PdfPermit
Public Enumeration PdfPermit
メンバー
メンバー | 値 | 説明
Print | 4 | 低解像度のみ印刷許可
Change | 8 | 文書の編集の許可
Copy | 16 | 文書の選択、コピーの許可
Comment | 32 | 注釈の編集の許可
FormField | 256 | フォームに対する入力の許可
ContentAccess | 512 | 読み上げ機能の使用の許可
DocumentAssembly | 1024 | ページの挿入や削除や回転、しおり、サムネールの作成の許可
PrintHigh | 2048 | 高解像度の印刷許可
関連項目

参照


PdfSignature クラス

PDF 出力のオプションを設定します。Creator オブジェクトを通じてこのクラスにアクセスします。
継承階層
SystemObject
AdvanceSoftware.ExcelCreatorPdfSignature

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class PdfSignature
Public Class PdfSignature

PdfSignature 型は下記のメンバーを公開します。

プロパティ
名前 | 説明
Capacity | PDF ファイルの電子署名データに割り当てられたバイト数を設定、取得します。
CertificateData | ローカルの証明書(pfx)データを設定、取得します。
CertificatePassword | ローカルの証明書(pfx)データのパスワードを設定、取得します。
Contact | 署名の連絡先を設定、取得します。
Date | 署名時刻を設定、取得します。
Location | 署名の場所を設定、取得します。
Reason | 署名の理由を設定、取得します。
TimeStampPassword | 署名の埋め込みタイムスタンプサーバーのパスワードを設定、取得します。
TimeStampUrl | 署名の埋め込みタイムスタンプサーバーの URL を設定、取得します。
TimeStampUser | 署名の埋め込みタイムスタンプサーバーのユーザー名を設定、取得します。
WindowsCertificate | Windows 証明書を設定、取得します。
トップ
関連項目

参照


PdfSignature プロパティ

PdfSignature 型は下記のメンバーを公開します。

プロパティ
名前 | 説明
Capacity | PDF ファイルの電子署名データに割り当てられたバイト数を設定、取得します。
CertificateData | ローカルの証明書(pfx)データを設定、取得します。
CertificatePassword | ローカルの証明書(pfx)データのパスワードを設定、取得します。
Contact | 署名の連絡先を設定、取得します。
Date | 署名時刻を設定、取得します。
Location | 署名の場所を設定、取得します。
Reason | 署名の理由を設定、取得します。
TimeStampPassword | 署名の埋め込みタイムスタンプサーバーのパスワードを設定、取得します。
TimeStampUrl | 署名の埋め込みタイムスタンプサーバーの URL を設定、取得します。
TimeStampUser | 署名の埋め込みタイムスタンプサーバーのユーザー名を設定、取得します。
WindowsCertificate | Windows 証明書を設定、取得します。
トップ
関連項目

参照

PdfSignature クラス


PdfSignature.Capacity プロパティ

PdfSignatureCapacity プロパティ

PDF ファイルの電子署名データに割り当てられたバイト数を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int Capacity { get; set; }
Public Property Capacity As Integer
    Get
    Set

プロパティ値

型: Int32
電子署名データのバイト数
解説
指定サイズが電子署名データより小さい場合、サイズを拡張してリトライが行われます。 指定サイズ(上限5MB)が大きい場合、ファイルサイズが大きくなります。 未設定(0)時は既定値(16KB)が確保されます。
例
C#
VB
コピー
// 電子署名データの割り当てバイト数 に 100KB を設定します。
creator1.Pdf.Signature.Capacity = 102400;
' 電子署名データの割り当てバイト数 に 100KB を設定します。
Creator1.Pdf.Signature.Capacity = 102400
関連項目

参照

PdfSignature クラス


PdfSignature.CertificateData プロパティ

PdfSignatureCertificateData プロパティ

ローカルの証明書(pfx)データを設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public byte[] CertificateData { get; set; }
Public Property CertificateData As Byte()
    Get
    Set

プロパティ値

型: Byte
ローカルの証明書(pfx)データ(既定値はNull)
解説
設定されたローカル証明書データが有効な場合、電子署名が付加されます。 ローカル証明書データが無効、または未設定(Null)時は電子署名が付加されません。 Windows 証明書を設定する WindowsCertificate プロパティとは排他的に機能します。
例
C#
VB
コピー
// ローカルの証明書(pfx)データに "C:\Certificate.pfx" ファイルの内容を設定します。。
creator1.Pdf.Signature.CertificateData = System.IO.File.ReadAllBytes(@"C:\Certificate.pfx");
' ローカルの証明書(pfx)データ "C:\Certificate.pfx" ファイルの内容を設定します。
Creator1.Pdf.Signature.CertificateData = System.IO.File.ReadAllBytes("C:\Certificate.pfx")
関連項目

参照

PdfSignature クラス


PdfSignature.CertificatePassword プロパティ

PdfSignatureCertificatePassword プロパティ

ローカルの証明書(pfx)データのパスワードを設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string CertificatePassword { get; set; }
Public Property CertificatePassword As String
    Get
    Set

プロパティ値

型: String
ローカルの証明書(pfx)データのパスワード(既定値は空白)
例
C#
VB
コピー
// ローカルの証明書(pfx)データのパスワード "pass" を設定します。
creator1.Pdf.Signature.CertificatePassword = "pass";
' ローカルの証明書(pfx)データのパスワード "pass" を設定します。
Creator1.Pdf.Signature.CertificatePassword = "pass"
関連項目

参照

PdfSignature クラス


PdfSignature.Contact プロパティ

PdfSignatureContact プロパティ

署名の連絡先を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Contact { get; set; }
Public Property Contact As String
    Get
    Set

プロパティ値

型: String
連絡先(既定値は空白)
例
C#
VB
コピー
// 連絡先に "info@adv.co.jp" を設定します。
creator1.Pdf.Signature.Contact = "info@adv.co.jp";
' 連絡先に "info@adv.co.jp" を設定します。
Creator1.Pdf.Signature.Contact = "info@adv.co.jp"
関連項目

参照

PdfSignature クラス


PdfSignature.Date プロパティ

PdfSignatureDate プロパティ

署名時刻を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public DateTime Date { get; set; }
Public Property Date As DateTime
    Get
    Set

プロパティ値

型: DateTime
署名時刻(既定値はシステム時刻)
解説
DateTime.MinValue 設定時、未設定の場合は署名時のシステム時刻が設定されます。
例
C#
VB
コピー
// 署名時刻に 2024/4/1 12:00:00 を設定します。
creator1.Pdf.Signature.Date = new DateTime(2024, 4, 1, 12, 0, 0);
' 署名時刻に 2024/4/1 12:00:00 を設定します。
Creator1.Pdf.Signature.Contact = New DateTime(2024, 4, 1, 12, 0, 0)
関連項目

参照

PdfSignature クラス


PdfSignature.Location プロパティ

PdfSignatureLocation プロパティ

署名の場所を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Location { get; set; }
Public Property Location As String
    Get
    Set

プロパティ値

型: String
場所(既定値は空白)
例
C#
VB
コピー
// 場所に "日本" を設定します。
creator1.Pdf.Signature.Location = "日本";
' 場所に "日本" を設定します。
Creator1.Pdf.Signature.Location = "日本"
関連項目

参照

PdfSignature クラス


PdfSignature.Reason プロパティ

PdfSignatureReason プロパティ

署名の理由を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Reason { get; set; }
Public Property Reason As String
    Get
    Set

プロパティ値

型: String
理由(既定値は空白)
例
C#
VB
コピー
// 理由に "稟議" を設定します。
creator1.Pdf.Signature.Reason = "稟議";
' 理由に "稟議" を設定します。
Creator1.Pdf.Signature.Reason = "稟議"
関連項目

参照

PdfSignature クラス


PdfSignature.TimeStampPassword プロパティ

PdfSignatureTimeStampPassword プロパティ

署名の埋め込みタイムスタンプサーバーのパスワードを設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string TimeStampPassword { get; set; }
Public Property TimeStampPassword As String
    Get
    Set

プロパティ値

型: String
タイムスタンプサーバーのパスワード(既定値は空白)
解説
タイムスタンプトークンが取得できない場合は埋め込みタイムスタンプが付加されません。
例
C#
VB
コピー
// タイムスタンプサーバーの パスワード "pass" を設定します。
creator1.Pdf.Signature.TimeStampPassword = "pass";
' タイムスタンプサーバーの パスワード "pass" を設定します。
Creator1.Pdf.Signature.TimeStampPassword = "pass"
関連項目

参照

PdfSignature クラス


PdfSignature.TimeStampUrl プロパティ

PdfSignatureTimeStampUrl プロパティ

署名の埋め込みタイムスタンプサーバーの URL を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string TimeStampUrl { get; set; }
Public Property TimeStampUrl As String
    Get
    Set

プロパティ値

型: String
タイムスタンプサーバーの URL(既定値は空白)
解説
設定された URL でタイムスタンプトークンが取得された場合、電子署名に埋め込みタイムスタンプを付加します。 タイムスタンプトークンが取得できない、または未設定(空白)時は埋め込みタイムスタンプが付加されません。
例
C#
VB
コピー
// タイムスタンプサーバーの URL "https://freetsa.org/tsr" を設定します。
creator1.Pdf.Signature.TimeStampUrl = "https://freetsa.org/tsr";
' タイムスタンプサーバーの URL "https://freetsa.org/tsr" を設定します。
Creator1.Pdf.Signature.TimeStampUrl = "https://freetsa.org/tsr"
関連項目

参照

PdfSignature クラス


PdfSignature.TimeStampUser プロパティ

PdfSignatureTimeStampUser プロパティ

署名の埋め込みタイムスタンプサーバーのユーザー名を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string TimeStampUser { get; set; }
Public Property TimeStampUser As String
    Get
    Set

プロパティ値

型: String
タイムスタンプサーバーのユーザー名(既定値は空白)
解説
タイムスタンプトークンが取得できない場合は埋め込みタイムスタンプが付加されません。
例
C#
VB
コピー
// タイムスタンプサーバーの ユーザー名 "user" を設定します。
creator1.Pdf.Signature.TimeStampUser = "user";
' タイムスタンプサーバーの ユーザー名 "user" を設定します。
Creator1.Pdf.Signature.TimeStampUser = "user"
関連項目

参照

PdfSignature クラス


PdfSignature.WindowsCertificate プロパティ

PdfSignatureWindowsCertificate プロパティ

Windows 証明書を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public X509Certificate2 WindowsCertificate { get; set; }
Public Property WindowsCertificate As X509Certificate2
    Get
    Set

プロパティ値

型: X509Certificate2
Windows 証明書(既定値はNull)
解説
設定された Window 証明書が有効な場合、電子署名が付加されます。 Windows 証明書が無効、または未設定(Null)時は電子署名が付加されません。 ローカル証明書(pfx)データを設定する CertificateData プロパティとは排他的に機能します。
例
C#
VB
コピー
// Windows 証明書を設定します。
creator1.Pdf.Signature.WindowsCertificate = certificate;
' Windows 証明書を設定します。
Creator1.Pdf.Signature.WindowsCertificate = certificate
関連項目

参照

PdfSignature クラス


ProgressType 列挙体

プログレスタイプを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ProgressType
Public Enumeration ProgressType
メンバー
メンバー | 値 | 説明
Print | 1 | 印刷
File | 2 | ファイル出力
Data | 3 | データ処理
関連項目

参照


ScaleMode 列挙体

スケールモードを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ScaleMode
Public Enumeration ScaleMode
メンバー
メンバー | 値 | 説明
Twips | 1 | Twips
Point | 2 | ポイント
Pixel | 3 | ピクセル
Inch | 5 | インチ
Millimeter | 6 | ミリ
Centimeter | 7 | センチ
関連項目

参照


ShapeType 列挙体

シェイプタイプを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ShapeType
Public Enumeration ShapeType
メンバー
メンバー | 値 | 説明
Line | 1 | 直線 (Xls)(Xlsx)
LineInv | 2 | LineInv (Xlsx)
Triangle | 3 | 二等辺三角形 (Xls)(Xlsx)
RtTriangle | 4 | 直角三角形 (Xls)(Xlsx)
Rect | 5 | 正方形,長方形 (Xls)(Xlsx)
Diamond | 6 | ひし形 (Xls)(Xlsx)
Parallelogram | 7 | 平行四辺形 (Xls)(Xlsx)
Trapezoid | 8 | 台形 (Xls)(Xlsx)
NonIsoscelesTrapezoid | 9 | NonIsoscelesTrapezoid (Xlsx)
Pentagon | 10 | 五角形 (Xls)(Xlsx)
Hexagon | 11 | 六角形 (Xls)(Xlsx)
Heptagon | 12 | 七角形 (Xlsx)
Octagon | 13 | 八角形 (Xls)(Xlsx)
Decagon | 14 | 十角形 (Xlsx)
Dodecagon | 15 | 十二角形 (Xlsx)
Star4 | 16 | 星 4 (Xlsx)
Star5 | 17 | 星 5 (Xlsx)
Star6 | 18 | 星 6 (Xlsx)
Star7 | 19 | 星 7 (Xlsx)
Star8 | 20 | 星 8 (Xlsx)
Star10 | 21 | 星 10 (Xlsx)
Star12 | 22 | 星 12 (Xlsx)
Star16 | 23 | 星 16 (Xlsx)
Star24 | 24 | 星 24 (Xlsx)
Star32 | 25 | 星 32 (Xlsx)
RoundRect | 26 | 角丸四角形 (Xls)(Xlsx)
Round1Rect | 27 | 1 つの角を丸めた四角形 (Xlsx)
Round2SameRect | 28 | 片側の 2 つの角を丸めた四角形 (Xlsx)
Round2DiagRect | 29 | 対角する 2 つの角を丸めた四角形 (Xlsx)
SnipRoundRect | 30 | 1 つの角を丸めた四角形 (Xlsx)
Snip1Rect | 31 | 1 つの角を切り取った四角形 (Xlsx)
Snip2SameRect | 32 | 片側の 2 つの角を切り取った四角形 (Xlsx)
Snip2DiagRect | 33 | 対角する 2 つの角を切り取った四角形 (Xlsx)
Plaque | 34 | ブローチ (Xls)(Xlsx)
Ellipse | 35 | 円,楕円 (Xls)(Xlsx)
Teardrop | 36 | 涙形 (Xlsx)
HomePlate | 37 | ホームベース (Xlsx)
Chevron | 38 | 山形 (Xlsx)
PieWedge | 39 | PieWedge (Xlsx)
Pie | 40 | パイ (Xlsx)
BlockArc | 41 | アーチ (Xlsx)
Donut | 42 | ドーナツ (Xlsx)
NoSmoking | 43 | 禁止 (Xlsx)
RightArrow | 44 | 右矢印 (Xlsx)
LeftArrow | 45 | 左矢印 (Xlsx)
UpArrow | 46 | 上矢印 (Xlsx)
DownArrow | 47 | 下矢印 (Xlsx)
StripedRightArrow | 48 | ストライプ矢印 (Xlsx)
NotchedRightArrow | 49 | V 字形矢印 (Xlsx)
BentUpArrow | 50 | 屈折矢印 (Xlsx)
LeftRightArrow | 51 | 左右矢印 (Xlsx)
UpDownArrow | 52 | 上下矢印 (Xlsx)
LeftUpArrow | 53 | 二方向矢印 (Xlsx)
LeftRightUpArrow | 54 | 三方向矢印 (Xlsx)
QuadArrow | 55 | 四方向矢印 (Xlsx)
LeftArrowCallout | 56 | 左矢印吹き出し (Xlsx)
RightArrowCallout | 57 | 右矢印吹き出し (Xlsx)
UpArrowCallout | 58 | 上矢印吹き出し (Xlsx)
DownArrowCallout | 56 | 下矢印吹き出し (Xlsx)
LeftRightArrowCallout | 60 | 左右矢印吹き出し (Xlsx)
UpDownArrowCallout | 61 | 上下ブロック矢印付吹き出し (Xlsx)
QuadArrowCallout | 62 | 四方向矢印吹き出し (Xlsx)
BentArrow | 63 | 曲折矢印 (Xlsx)
UturnArrow | 64 | U ターン矢印 (Xlsx)
CircularArrow | 65 | 環状矢印 (Xlsx)
LeftCircularArrow | 66 | LeftCircularArrow (Xlsx)
LeftRightCircularArrow | 67 | LeftRightCircularArrow (Xlsx)
CurvedRightArrow | 68 | 右カーブ矢印 (Xlsx)
CurvedLeftArrow | 69 | 左カーブ矢印 (Xlsx)
CurvedUpArrow | 70 | 上カーブ矢印 (Xlsx)
CurvedDownArrow | 71 | 下カーブ矢印 (Xlsx)
SwooshArrow | 72 | SwooshArrow (Xlsx)
Cube | 73 | 直方体 (Xls)(Xlsx)
Can | 74 | 円柱 (Xls)(Xlsx)
LightningBolt | 75 | 稲妻 (Xlsx)
Heart | 76 | ハート (Xlsx)
Sun | 77 | 太陽 (Xlsx)
Moon | 78 | 月 (Xlsx)
SmileyFace | 79 | スマイル (Xlsx)
IrregularSeal1 | 80 | 爆発 1 (Xlsx)
IrregularSeal2 | 81 | 爆発 2 (Xlsx)
FoldedCorner | 82 | メモ (Xls)(Xlsx)
Bevel | 83 | 額縁 (Xls)(Xlsx)
Frame | 84 | フレーム (Xlsx)
HalfFrame | 85 | ハーフフレーム (Xlsx)
Corner | 86 | L 字 (Xlsx)
DiagStripe | 87 | 斜め縞 (Xlsx)
Chord | 88 | 弦 (Xlsx)
Arc | 89 | 円弧 (Xlsx)
LeftBracket | 90 | 左大かっこ (Xls)(Xlsx)
RightBracket | 91 | 右大かっこ (Xls)(Xlsx)
LeftBrace | 92 | 左中かっこ (Xlsx)
RightBrace | 93 | 右中かっこ (Xlsx)
BracketPair | 94 | 大かっこ (Xls)(Xlsx)
BracePair | 95 | 中かっこ (Xls)(Xlsx)
StraightConnector1 | 96 | 直線矢印コネクタ (Xlsx)
BentConnector2 | 97 | カギ線コネクタ 2 (Xlsx)
BentConnector3 | 98 | カギ線コネクタ 3 (Xlsx)
BentConnector4 | 99 | カギ線コネクタ 4 (Xlsx)
BentConnector5 | 100 | カギ線コネクタ 5 (Xlsx)
CurvedConnector2 | 101 | 曲線コネクタ 2 (Xlsx)
CurvedConnector3 | 102 | 曲線コネクタ 3 (Xlsx)
CurvedConnector4 | 103 | 曲線コネクタ 4 (Xlsx)
CurvedConnector5 | 104 | 曲線コネクタ 5 (Xlsx)
Callout1 | 105 | 線吹き出し 1 (Xlsx)
Callout2 | 106 | 線吹き出し 2 (Xlsx)
Callout3 | 107 | 線吹き出し 3 (Xlsx)
AccentCallout1 | 108 | 強調線吹き出し 1 (Xlsx)
AccentCallout2 | 109 | 強調線吹き出し 2 (Xlsx)
AccentCallout3 | 110 | 強調線吹き出し 3 (Xlsx)
BorderCallout1 | 111 | 枠付き線吹き出し 1 (Xlsx)
BorderCallout2 | 112 | 枠付き線吹き出し 2 (Xlsx)
BorderCallout3 | 113 | 枠付き線吹き出し 3 (Xlsx)
AccentBorderCallout1 | 114 | 枠付き強調線吹き出し 1 (Xlsx)
AccentBorderCallout2 | 115 | 枠付き強調線吹き出し 2 (Xlsx)
AccentBorderCallout3 | 116 | 枠付き強調線吹き出し 3 (Xlsx)
WedgeRectCallout | 117 | 四角形吹き出し (Xlsx)
WedgeRoundRectCallout | 118 | 角丸四角形吹き出し (Xlsx)
WedgeEllipseCallout | 119 | 円形吹き出し (Xlsx)
CloudCallout | 120 | 雲形吹き出し (Xlsx)
Cloud | 121 | 雲 (Xlsx)
Ribbon | 122 | 下リボン (Xlsx)
Ribbon2 | 123 | 上リボン (Xlsx)
EllipseRibbon | 124 | 下カーブ リボン (Xlsx)
EllipseRibbon2 | 125 | 上カーブ リボン (Xlsx)
LeftRightRibbon | 126 | LeftRightRibbon (Xlsx)
VerticalScroll | 127 | 縦巻き (Xlsx)
HorizontalScroll | 128 | 横巻き (Xlsx)
Wave | 129 | 大波 (Xlsx)
DoubleWave | 130 | 小波 (Xlsx)
Plus | 131 | 十字形 (Xls)(Xlsx)
FlowChartProcess | 132 | フローチャート : 処理 (Xlsx)
FlowChartDecision | 133 | フローチャート : 判断 (Xlsx)
FlowChartInputOutput | 134 | フローチャート : データ (Xlsx)
FlowChartPredefinedProcess | 135 | フローチャート : 定義済み処理 (Xlsx)
FlowChartInternalStorage | 136 | フローチャート : 内部記憶 (Xlsx)
FlowChartDocument | 137 | フローチャート : 書類 (Xlsx)
FlowChartMultidocument | 138 | フローチャート : 複数書類 (Xlsx)
FlowChartTerminator | 139 | フローチャート : 端子 (Xlsx)
FlowChartPreparation | 140 | フローチャート : 準備 (Xlsx)
FlowChartManualInput | 141 | フローチャート : 手操作入力 (Xlsx)
FlowChartManualOperation | 142 | フローチャート : 手作業 (Xlsx)
FlowChartConnector | 143 | フローチャート : 結合子 (Xlsx)
FlowChartPunchedCard | 144 | フローチャート : カード (Xlsx)
FlowChartPunchedTape | 145 | フローチャート : せん孔テープ (Xlsx)
FlowChartSummingJunction | 146 | フローチャート : 和接合 (Xlsx)
FlowChartOr | 147 | フローチャート : 論理和 (Xlsx)
FlowChartCollate | 148 | フローチャート : 照合 (Xlsx)
FlowChartSort | 149 | フローチャート : 分類 (Xlsx)
FlowChartExtract | 150 | フローチャート : 抜出し (Xlsx)
FlowChartMerge | 151 | フローチャート : 組合せ (Xlsx)
FlowChartOfflineStorage | 152 | フローチャート : OfflineStorage (Xlsx)
FlowChartOnlineStorage | 153 | フローチャート : 記憶データ (Xlsx)
FlowChartMagneticTape | 154 | フローチャート : 順次アクセス記憶 (Xlsx)
FlowChartMagneticDisk | 155 | フローチャート : 磁気ディスク (Xlsx)
FlowChartMagneticDrum | 156 | フローチャート : 直接アクセス記憶 (Xlsx)
FlowChartDisplay | 157 | フローチャート : 表示 (Xlsx)
FlowChartDelay | 158 | フローチャート : 論理積ゲート (Xlsx)
FlowChartAlternateProcess | 159 | フローチャート : 代替処理 (Xlsx)
FlowChartOffpageConnector | 160 | フローチャート : 他ページ結合子 (Xlsx)
ActionButtonBlank | 161 | アクションボタン ： ブランク (Xlsx)
ActionButtonHome | 162 | アクションボタン ： ホーム (Xlsx)
ActionButtonHelp | 163 | アクションボタン ： ヘルプ (Xlsx)
ActionButtonInformation | 164 | アクションボタン ： 情報 (Xlsx)
ActionButtonForwardNext | 165 | アクションボタン ： 次へ (Xlsx)
ActionButtonBackPrevious | 166 | アクションボタン ： 前へ (Xlsx)
ActionButtonEnd | 167 | アクションボタン ： 終了 (Xlsx)
ActionButtonBeginning | 168 | アクションボタン ： 開始 (Xlsx)
ActionButtonReturn | 169 | アクションボタン ： 戻る (Xlsx)
ActionButtonDocument | 170 | アクションボタン ： ドキュメント (Xlsx)
ActionButtonSound | 171 | アクションボタン ： サウンド (Xlsx)
ActionButtonMovie | 172 | アクションボタン ： 動画 (Xlsx)
Gear6 | 173 | ギア 6 (Xlsx)
Gear9 | 174 | ギア 9 (Xlsx)
Funnel | 175 | Funnel (Xlsx)
MathPlus | 176 | 加算記号 (Xlsx)
MathMinus | 177 | 減算記号 (Xlsx)
MathMultiply | 178 | 乗算記号 (Xlsx)
MathDivide | 179 | 除算記号 (Xlsx)
MathEqual | 180 | 等号 (Xlsx)
MathNotEqual | 181 | 不等号 (Xlsx)
CornerTabs | 182 | CornerTabs (Xlsx)
SquareTabs | 183 | SquareTabs (Xlsx)
PlaqueTabs | 184 | PlaqueTabs (Xlsx)
ChartX | 185 | ChartX (Xlsx)
ChartStar | 186 | ChartStar (Xlsx)
ChartPlus | 187 | ChartPlus (Xlsx)
Quadrangle | 4114 | 四角形 (Xls)(Xlsx)
Rhombic | 4162 | ひし形 (Xls)(Xlsx)
CornerQuadrangle | 4130 | 角丸四角形 (Xls)(Xlsx)
IsoscelesTriangle | 4178 | 二等辺三角形 (Xls)(Xlsx)
RightTriangle | 4194 | 直角三角形 (Xls)(Xlsx)
CrissCross | 4274 | 十字形 (Xls)(Xlsx)
Pentagonal | 4994 | 五角形 (Xls)(Xlsx)
Cylinder | 4450 | 円柱 (Xls)(Xlsx)
Rectangular | 4354 | 直方体 (Xls)(Xlsx)
PictureFrame | 5442 | 額縁 (Xls)(Xlsx)
Memo | 5138 | メモ (Xls)(Xlsx)
Brackets | 7058 | 大括弧 (Xls)(Xlsx)
CurlyBrace | 7074 | 中括弧 (Xls)(Xlsx)
Broach | 4434 | ブローチ (Xls)(Xlsx)
LeftBrackets | 5458 | 左大括弧 (Xls)(Xlsx)
RightBrackets | 5474 | 右大括弧 (Xls)(Xlsx)
関連項目

参照


StreamMode 列挙体

データを展開するストリームモードを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum StreamMode
Public Enumeration StreamMode
メンバー
メンバー | 値 | 説明
Memory | 0 | メモリ上に展開します。
File | 1 | ファイルに展開します。
関連項目

参照


TextAlign 列挙体

テキストボックスの水平方向の文字位置を示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TextAlign
Public Enumeration TextAlign
メンバー
メンバー | 値 | 説明
Center | 1 | 中央揃え
Justy | 3 | 両端揃え
Left | 5 | 左詰め
Right | 6 | 右詰め
関連項目

参照


TextAnchor 列挙体

テキストボックスの垂直方向の文字位置を示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TextAnchor
Public Enumeration TextAnchor
メンバー
メンバー | 値 | 説明
Top | 1 | 上詰め
Center | 2 | 中央揃え
Bottom | 3 | 下詰め
Justify | 4 | 両端揃え
関連項目

参照


TextBoxFontStyle 列挙体

テキストボックスのフォントスタイルを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TextBoxFontStyle
Public Enumeration TextBoxFontStyle
メンバー
メンバー | 値 | 説明
Normal | 0 | 標準
Bold | 1 | 太字
Italic | 2 | 斜体
関連項目

参照


TextVertical 列挙体

テキストボックスの縦書きを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TextVertical
Public Enumeration TextVertical
メンバー
メンバー | 値 | 説明
EaVert | 1 | 縦書き
Horz | 2 | 横書き
Vert | 4 | 右へ90°回転
Vert270 | 5 | 左へ90°回転
WordArtVertRtl | 7 | 縦書き
関連項目

参照


VarInsertMode 列挙体

変数名挿入モードを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum VarInsertMode
Public Enumeration VarInsertMode
メンバー
メンバー | 値 | 説明
All | 0 | 全ての変数名にデータを挿し込みます。
InvalidAnswer | 1 | 数式結果の変数名以外にデータを挿し込みます。
InvalidTextBox | 2 | テキストボックスの変数名以外にデータを挿し込みます。
InvalidCellText | 4 | セルの変数名以外にデータを挿し込みます。
関連項目

参照


VarNameMode 列挙体

変数名キーワードの扱いを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum VarNameMode
Public Enumeration VarNameMode
メンバー
メンバー | 値 | 説明
Shared | 0 | スレッド間で共通のキーワードとして指定する
Private | 1 | スレッドごとに異なるキーワードとして指定する
関連項目

参照


VerticalAlignment 列挙体

垂直方向の位置を示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum VerticalAlignment
Public Enumeration VerticalAlignment
メンバー
メンバー | 値 | 説明
Top | 1 | 上詰め
Center | 2 | 中央揃え
Bottom | 3 | 下詰め
Justify | 4 | 両端揃え
Distributed | 5 | 均等割り付け
関連項目

参照


xlColor 列挙体

カラーを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum xlColor
Public Enumeration xlColor
メンバー
メンバー | 値 | 説明
Auto | 0x70000000 | 自動
Black | 0x70000008 | 黒
White | 0x70000009 | 白
Red | 0x7000000A | 赤
Green | 0x7000000B | 緑
Blue | 0x7000000C | 青
Yellow | 0x7000000D | 黄
Pink | 0x7000000E | ピンク
Cyan | 0x7000000F | 水色
DarkRed | 0x70000010 | 濃い赤
DarkGreen | 0x70000011 | 濃い緑
DarkBlue | 0x70000012 | 濃い青
DarkYellow | 0x70000013 | 濃い黄
Purple | 0x70000014 | 紫
BlueGreen | 0x70000015 | 青緑
Gray25 | 0x70000016 | 25% 灰色
Gray50 | 0x70000017 | 50% 灰色
Gray | 0x70000018 | グレー
Plum | 0x70000019 | プラム
Ivory | 0x7000001A | アイボリー
LightBlue | 0x7000001B | 薄い水色
DarkPurple | 0x7000001C | 濃い紫
Coral | 0x7000001D | コーラル
OceanBlue | 0x7000001E | オーシャンブルー
IceBlue | 0x7000001F | アイスブルー
DarkBlue2 | 0x70000020 | 濃い青2
Pink2 | 0x70000021 | ピンク2
Yellow2 | 0x70000022 | 黄2
Cyan2 | 0x70000023 | 水色2
Purple2 | 0x70000024 | 紫2
DarkRed2 | 0x70000025 | 濃い赤2
BlueGreen2 | 0x70000026 | 青緑2
Blue2 | 0x70000027 | 青2
SkyBlue | 0x70000028 | スカイブルー
LightCyan2 | 0x70000029 | 薄い水色2
LightGreen | 0x7000002A | 薄い緑
LightYellow | 0x7000002B | 薄い黄
VeilBlue | 0x7000002C | ベールブルー
Rose | 0x7000002D | ローズ
Lavender | 0x7000002E | ラベンダー
Beige | 0x7000002F | ベージュ
LightBlue2 | 0x70000030 | 薄い青2
AquaBlue | 0x70000031 | アクア
Lime | 0x70000032 | ライム
Gold | 0x70000033 | ゴールド
LightOrange | 0x70000034 | 薄いオレンジ
Orange | 0x70000035 | オレンジ
BlueGrey | 0x70000036 | ブルーグレー
Gray40 | 0x70000037 | 40% 灰色
DarkBlueGreen | 0x70000038 | 濃い青緑
SeaGreen | 0x70000039 | シーグリーン
DarkGreen2 | 0x7000003A | 濃い緑2
Olive | 0x7000003B | オリーブ
Brown | 0x7000003C | 茶
Plum2 | 0x7000003D | プラム2
Indigo | 0x7000003E | インディゴ
Gray80 | 0x7000003F | 80% 灰色
関連項目

参照


xlsVersion 列挙体

Excel ファイル(Xls 形式)のバージョンを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum xlsVersion
Public Enumeration xlsVersion
メンバー
メンバー | 値 | 説明
ver2003 | 2003 | Excel 2003 の形式で作成します。
関連項目

参照


xlsxVersion 列挙体

Excel ファイル(Xlsx 形式)のバージョンを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator
アセンブリ: AdvanceSoftware.ExcelCreator.Shared (in AdvanceSoftware.ExcelCreator.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum xlsxVersion
Public Enumeration xlsxVersion
メンバー
メンバー | 値 | 説明
ver2007 | 2007 | Excel 2007 の形式で作成します。
ver2010 | 2010 | Excel 2010 の形式で作成します。
ver2013 | 2013 | Excel 2013 の形式で作成します。
ver2013S | -2013 | Excel 2013 Strict 形式で作成します。
ver2016 | 2016 | Excel 2016 の形式で作成します。
ver2016S | -2016 | Excel 2016 Strict 形式で作成します。
ver2019 | 2019 | Excel 2019 の形式で作成します。
ver2019S | -2019 | Excel 2019 Strict 形式で作成します。
ver2021 | 2021 | Excel 2021 の形式で作成します。
ver2021S | -2021 | Excel 2021 Strict 形式で作成します。
関連項目

参照


AdvanceSoftware.ExcelCreator.BarCode 名前空間

AdvanceSoftware.ExcelCreator.BarCode 名前空間には、BarCode コンポーネントが含まれています。
クラス
 | クラス | 説明
Public クラス | BarCode | BarCode クラス
Public クラス | BarCodeErrorEventArgs | BarCode クラスの Error イベントのデータを提供します。
構造体
 | 構造体 | 説明
Public 構造体 | BarCodeSizeD | BarCodeSizeD 構造体
デリゲート
 | デリゲート | 説明
Public デリゲート | BarCodeErrorEventHandler | BarCode クラスの Error イベントを処理するメソッドを表します。
列挙体
 | 列挙体 | 説明
Public 列挙体 | BarCodeType | バーコードの種類を指定します。
Public 列挙体 | CheckPattern | チェックデジットの計算方法を指定します。
Public 列挙体 | Codeset | スタートコードセットを指定します。
Public 列挙体 | ErrorNo | エラーナンバーを示す識別子を指定します。
Public 列挙体 | MessageAlign | バーコードメッセージの表示横位置を指定します。
Public 列挙体 | PDFModel | PDF417 シンボルを指定します。
Public 列挙体 | QRConnect | QRコードの連結モードを指定します。
Public 列挙体 | QRLevel | QR コードの誤り訂正レベルを指定します。
Public 列挙体 | QRMask | QR コードのマスクパターンを指定します。
Public 列挙体 | QRModel | QR コードのモデルを指定します。
Public 列挙体 | QRVersion | QR コードの型番を指定します。
Public 列挙体 | Rotate | バーコードの回転方向を指定します。
Public 列挙体 | Unit | バーコードの生成単位を指定します。
Public 列挙体 | ValueEncoding | バーコードデータのエンコード方式を指定します。(QRCode, PDF417)


BarCode クラス

BarCode クラス
継承階層
System.ComponentModelComponent
AdvanceSoftware.ExcelCreator.BarCodeBarCode

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class BarCode : Component
Public Class BarCode
    Inherits Component

BarCode 型は下記のメンバーを公開します。

コンストラクター
 | 名前 | 説明
Public メソッド | BarCode | コンストラクター
Public メソッド | BarCode(IContainer) | コンストラクター
トップ
プロパティ
名前 | 説明
_Type | バーコードの種類を設定、取得します。
_Unit | バーコードの生成単位を設定、取得します。
BackColor | バーコードシンボルの背景色を設定、取得します。
BarColor | バーの色を設定、取得します。
BarHeight | バーコードの高さを設定、取得します。
BarRatio | 太バーのエレメント率を設定、取得します。(Codabar、Code39)
BarWidth | バーコードの幅を設定、取得します。
BinaryValue | バーコードデータを設定します。(バイナリ値)
BlackBarRevision | 黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金等代理収納 GS1-128)
BlackRatio | 黒バーの太さの比率を設定、取得します。
CharGap | キャラクタ間のギャップを設定、取得します。(Codabar、Code39)
CharSize | バーコードメッセージのフォントサイズを設定、取得します。
CheckCharMode | 自動でチェックキャラクタを付加するかを設定、取得します。
CheckPattern | チェックデジットの計算方法を設定、取得します。(Codabar)
Codeset | スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))
DpiX | X 軸方向の解像度を設定、取得します。(ピクセル単位)
DpiY | Y 軸方向の解像度を設定、取得します。(ピクセル単位)
Element | 最小エレメント値を設定、取得します。
EmfType | 拡張メタファイル(EMF)に格納されるレコードの品質を設定、取得します。
ErrorMessage | エラーメッセージを取得します。
ErrorNo | エラーナンバーを取得します。
FlatHeight | ガードバーの均等化を設定、取得します。(JAN、UPC)
Font | バーコードメッセージのフォント名、フォントスタイルを設定、取得します。
InternalQRVersion | QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。
InternalValue | 整形後のバーコードデータを取得します。
MessageAlign | バーコードメッセージの表示横位置を設定、取得します。(公共料金等代理収納 GS1-128)
PDFColumn | PDF417 の列数を設定、取得します。
PDFInitialSymbol | PDF417 の初期化シンボルを設定、取得します。
PDFLevel | PDF417 のエラー訂正レベルを設定、取得します。
PDFModel | PDF417 シンボルを設定、取得します。
PDFRatio | PDF417 の 1 モジュールの縦横比を設定、取得します。
PDFRow | PDF417 の行数を設定、取得します。
Point | ポイントを設定、取得します。(カスタマバーコード)
QRConnect | 連結 QR コードを作成するかを設定、取得します。
QREscapeCode | QR コードのエスケープコードを設定、取得します。
QRLevel | QR コードの誤り訂正レベルを設定、取得します。
QRMask | QR コードのマスクパターンを設定、取得します。
QRModel | QR コードのモデルを設定、取得します。
QRSymbolNumber | 連結 QR コードで出力するシンボル番号を設定、取得します。
QRVersion | QR コードの型番を設定、取得します。
Quiet | 余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金等代理収納 GS1-128)
Rotate | バーコードの回転方向を設定、取得します。
ShowBearer | ベアラバーを表示するかを設定、取得します。(ITF)
ShowMessage | バーコードメッセージを表示するかを設定、取得します。
StartChar | スタートキャラクタを設定、取得します。(Codabar)
StopChar | ストップキャラクタを設定、取得します。(Codabar)
TextRenderingHint | バーコードキャラクタのテキストレンダリングの品質を設定、取得します。
Type | バーコードの種類を設定、取得します。
Unit | バーコードの生成単位を設定、取得します。
Value | バーコードデータを設定、取得します。(文字列)
ValueEncoding | バーコードデータのエンコード方式を設定、取得します。(QRCode, PDF417)
WhiteBarRevision | 白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金等代理収納 GS1-128)
Zoom | 倍率を設定、取得します。(JAN、UPC、ITF)
トップ
メソッド
名前 | 説明
GetBarCodeImage(ImageFormat) | バーコードのイメージを作成します。
GetBarCodeImage(ImageFormat, Boolean) | バーコードのイメージを作成します。
GetScaleSize | 指定した単位でバーコードのサイズを取得します。
SetLicense(Stream) | ライセンス情報を設定します。
SetLicense(String) | ライセンス情報を設定します。
トップ
イベント
名前 | 説明
Error | バーコードの作成に失敗した時に発生します。
トップ
関連項目

参照

AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode コンストラクター

オーバーロードの一覧
 | 名前 | 説明
Public メソッド | BarCode | コンストラクター
Public メソッド | BarCode(IContainer) | コンストラクター
トップ
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode コンストラクター

コンストラクター

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public BarCode()
Public Sub New
関連項目

参照

BarCode クラス
BarCode オーバーロード
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode コンストラクター (IContainer)

コンストラクター

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public BarCode(
    IContainer container
)
Public Sub New (
    container As IContainer
)

パラメーター

container
型: System.ComponentModelIContainer
System.ComponentModel.IContainer を指定します。
関連項目

参照

BarCode クラス
BarCode オーバーロード
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode プロパティ

BarCode 型は下記のメンバーを公開します。

プロパティ
名前 | 説明
_Type | バーコードの種類を設定、取得します。
_Unit | バーコードの生成単位を設定、取得します。
BackColor | バーコードシンボルの背景色を設定、取得します。
BarColor | バーの色を設定、取得します。
BarHeight | バーコードの高さを設定、取得します。
BarRatio | 太バーのエレメント率を設定、取得します。(Codabar、Code39)
BarWidth | バーコードの幅を設定、取得します。
BinaryValue | バーコードデータを設定します。(バイナリ値)
BlackBarRevision | 黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金等代理収納 GS1-128)
BlackRatio | 黒バーの太さの比率を設定、取得します。
CharGap | キャラクタ間のギャップを設定、取得します。(Codabar、Code39)
CharSize | バーコードメッセージのフォントサイズを設定、取得します。
CheckCharMode | 自動でチェックキャラクタを付加するかを設定、取得します。
CheckPattern | チェックデジットの計算方法を設定、取得します。(Codabar)
Codeset | スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))
DpiX | X 軸方向の解像度を設定、取得します。(ピクセル単位)
DpiY | Y 軸方向の解像度を設定、取得します。(ピクセル単位)
Element | 最小エレメント値を設定、取得します。
EmfType | 拡張メタファイル(EMF)に格納されるレコードの品質を設定、取得します。
ErrorMessage | エラーメッセージを取得します。
ErrorNo | エラーナンバーを取得します。
FlatHeight | ガードバーの均等化を設定、取得します。(JAN、UPC)
Font | バーコードメッセージのフォント名、フォントスタイルを設定、取得します。
InternalQRVersion | QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。
InternalValue | 整形後のバーコードデータを取得します。
MessageAlign | バーコードメッセージの表示横位置を設定、取得します。(公共料金等代理収納 GS1-128)
PDFColumn | PDF417 の列数を設定、取得します。
PDFInitialSymbol | PDF417 の初期化シンボルを設定、取得します。
PDFLevel | PDF417 のエラー訂正レベルを設定、取得します。
PDFModel | PDF417 シンボルを設定、取得します。
PDFRatio | PDF417 の 1 モジュールの縦横比を設定、取得します。
PDFRow | PDF417 の行数を設定、取得します。
Point | ポイントを設定、取得します。(カスタマバーコード)
QRConnect | 連結 QR コードを作成するかを設定、取得します。
QREscapeCode | QR コードのエスケープコードを設定、取得します。
QRLevel | QR コードの誤り訂正レベルを設定、取得します。
QRMask | QR コードのマスクパターンを設定、取得します。
QRModel | QR コードのモデルを設定、取得します。
QRSymbolNumber | 連結 QR コードで出力するシンボル番号を設定、取得します。
QRVersion | QR コードの型番を設定、取得します。
Quiet | 余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金等代理収納 GS1-128)
Rotate | バーコードの回転方向を設定、取得します。
ShowBearer | ベアラバーを表示するかを設定、取得します。(ITF)
ShowMessage | バーコードメッセージを表示するかを設定、取得します。
StartChar | スタートキャラクタを設定、取得します。(Codabar)
StopChar | ストップキャラクタを設定、取得します。(Codabar)
TextRenderingHint | バーコードキャラクタのテキストレンダリングの品質を設定、取得します。
Type | バーコードの種類を設定、取得します。
Unit | バーコードの生成単位を設定、取得します。
Value | バーコードデータを設定、取得します。(文字列)
ValueEncoding | バーコードデータのエンコード方式を設定、取得します。(QRCode, PDF417)
WhiteBarRevision | 白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金等代理収納 GS1-128)
Zoom | 倍率を設定、取得します。(JAN、UPC、ITF)
トップ
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode._Type プロパティ

BarCode_Type プロパティ

バーコードの種類を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public BarCodeType _Type { get; set; }
Public Property _Type As BarCodeType
    Get
    Set

プロパティ値

型: BarCodeType
バーコードのタイプを表す BarCodeType。(既定値：BarCodeType.JAN13)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
// 生成するバーコードイメージを "JAN13" に設定します。
barCode1._Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
' 生成するバーコードイメージを "JAN13" に設定します。
BarCode1._Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode._Unit プロパティ

BarCode_Unit プロパティ

バーコードの生成単位を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Unit _Unit { get; set; }
Public Property _Unit As Unit
    Get
    Set

プロパティ値

型: Unit
バーコードの生成単位を表す Unit。(既定値：Unit.Pixel)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1._Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1._Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.BackColor プロパティ

BarCodeBackColor プロパティ

バーコードシンボルの背景色を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

プロパティ値

型: Color
バーコードシンボルの背景色を表す Color。(既定値：Color.White)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
// バーコードイメージの背景色を "赤色" に設定します。
barCode1.BackColor = System.Drawing.Color.Red;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
' バーコードイメージの背景色を "赤色" に設定します。
BarCode1.BackColor = System.Drawing.Color.Red
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.BarColor プロパティ

BarCodeBarColor プロパティ

バーの色を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color BarColor { get; set; }
Public Property BarColor As Color
    Get
    Set

プロパティ値

型: Color
バーの色を表す Color。(既定値：Color.Black)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
// バーの色を "赤色" に設定します。
barCode1.BarColor = System.Drawing.Color.Red;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
' バーの色を "赤色" に設定します。
BarCode1.BarColor = System.Drawing.Color.Red
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.BarHeight プロパティ

BarCodeBarHeight プロパティ

バーコードの高さを設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double BarHeight { get; set; }
Public Property BarHeight As Double
    Get
    Set

プロパティ値

型: Double
バーコードの高さを表す double。(既定値：0.0)
解説
プロパティ値は Unit プロパティのサイズ単位で扱われます。 プロパティ値が 0 の場合、バーコードの高さは自動で設定されます。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter;
// バーコードイメージの高さを "30.0mm" に設定します。
barCode1.BarHeight = 30.0;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter
' バーコードイメージの高さを "30.0mm" に設定します。
BarCode1.BarHeight = 30.0
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.BarRatio プロパティ

BarCodeBarRatio プロパティ

太バーのエレメント率を設定、取得します。(Codabar、Code39)

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double BarRatio { get; set; }
Public Property BarRatio As Double
    Get
    Set

プロパティ値

型: Double
太バーのエレメント率を表す double。(既定値：2.0)
解説

設定範囲

最小エレメント値が 0.508mm 未満：2.2 ～ 3.0

最小エレメント値が 0.508mm 以上：2.0 ～ 3.0

例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Codabar;
// 太バーのエレメント率を "2.5" に設定します。
barCode1.BarRatio = 2.5;
barCode1.Value = "1234567890";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Codabar
' 太バーのエレメント率を "2.5" に設定します。
BarCode1.BarRatio = 2.5
BarCode1.Value = "1234567890"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.BarWidth プロパティ

BarCodeBarWidth プロパティ

バーコードの幅を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double BarWidth { get; set; }
Public Property BarWidth As Double
    Get
    Set

プロパティ値

型: Double
バーコードの幅を表す double。(既定値：0.0)
解説
プロパティ値は Unit プロパティのサイズ単位で扱われます。 プロパティ値が 0 の場合、バーコードの幅は自動で設定されます。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter;
// バーコードイメージの幅を "60.0mm" に設定します。
barCode1.BarWidth = 60.0;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter
' バーコードイメージの幅を "60.0mm" に設定します。
BarCode1.BarWidth = 60.0
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.BinaryValue プロパティ

BarCodeBinaryValue プロパティ

バーコードデータを設定します。(バイナリ値)

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public byte[] BinaryValue { set; }
Public WriteOnly Property BinaryValue As Byte()
    Set

プロパティ値

型: Byte
バーコードデータを表す Byte[]。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode;
// "12345ABCDE"
Byte[] btByte = new Byte[] { 49, 50, 51, 52, 53, 65, 66, 67, 68, 69 };
// バーコードデータを設定します。 (バイナリ値)
barCode1.BinaryValue = btByte;
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode
' "12345ABCDE"
Dim btByte() As Byte = New Byte() {49, 50, 51, 52, 53, 65, 66, 67, 68, 69}
' バーコードデータを設定します。 (バイナリ値)
BarCode1.BinaryValue = btByte
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.BlackBarRevision プロパティ

BarCodeBlackBarRevision プロパティ

黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金等代理収納 GS1-128)

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int BlackBarRevision { get; set; }
Public Property BlackBarRevision As Integer
    Get
    Set

プロパティ値

型: Int32
黒バーのドット補正値を表す int。(既定値：0)
解説
Unit プロパティの値が Unit.Pixel の場合、有効になります。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Code128;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 黒バーのドット補正値を "+2" に設定します。
barCode1.BlackBarRevision = 2;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Code128
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 黒バーのドット補正値を "+2" に設定します。
BarCode1.BlackBarRevision = 2
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.BlackRatio プロパティ

BarCodeBlackRatio プロパティ

黒バーの太さの比率を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int BlackRatio { get; set; }
Public Property BlackRatio As Integer
    Get
    Set

プロパティ値

型: Int32
黒バーの太さの比率を表す int。(既定値：100)
解説
設定範囲：50 ～ 150
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
// 黒バーの太さ比率を "150%" に設定します。
barCode1.BlackRatio = 150;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
' 黒バーの太さ比率を "150%" に設定します。
BarCode1.BlackRatio = 150
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.CharGap プロパティ

BarCodeCharGap プロパティ

キャラクタ間のギャップを設定、取得します。(Codabar、Code39)

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double CharGap { get; set; }
Public Property CharGap As Double
    Get
    Set

プロパティ値

型: Double
キャラクタ間のギャップを表す double。(既定値：0.0)
解説
プロパティ値は Unit プロパティのサイズ単位で扱われます。 プロパティ値が 0 の場合、キャラクタ間のギャップは自動で設定されます。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Code39;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter;
// バーコードキャラクタの間隔を "2.0mm" に設定します。
barCode1.CharGap = 2.0;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Code39
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter
' バーコードキャラクタの間隔を "2.0mm" に設定します。
BarCode1.CharGap = 2.0
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.CharSize プロパティ

BarCodeCharSize プロパティ

バーコードメッセージのフォントサイズを設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double CharSize { get; set; }
Public Property CharSize As Double
    Get
    Set

プロパティ値

型: Double
バーコードメッセージのフォントサイズを表す double。(既定値：0.0)
解説
プロパティ値は Unit プロパティのサイズ単位で扱われます。 プロパティ値が 0 の場合、バーコードメッセージのフォントサイズは自動で設定されます。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter;
// バーコードメッセージのフォントサイズを "10.0mm" に設定します。
barCode1.CharSize = 10.0;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter
' バーコードメッセージのフォントサイズを "10.0mm" に設定します。
BarCode1.CharSize = 10.0
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.CheckCharMode プロパティ

BarCodeCheckCharMode プロパティ

自動でチェックキャラクタを付加するかを設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool CheckCharMode { get; set; }
Public Property CheckCharMode As Boolean
    Get
    Set

プロパティ値

型: Boolean
チェックキャラクタのモードを表す bool。(既定値：true)
解説
プロパティ値が true の場合、自動でチェックキャラクタを付加します。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
// チェックキャラクタを "付加しない" に設定します。
barCode1.CheckCharMode = false;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
' チェックキャラクタを "付加しない" に設定します。
BarCode1.CheckCharMode = False
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.CheckPattern プロパティ

BarCodeCheckPattern プロパティ

チェックデジットの計算方法を設定、取得します。(Codabar)

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public CheckPattern CheckPattern { get; set; }
Public Property CheckPattern As CheckPattern
    Get
    Set

プロパティ値

型: CheckPattern
チェックデジットの計算方法を表す CheckPattern。(既定値：CheckPattern.Modulus16)
解説
CheckPattern.Modulus11(モジュラス 11) を設定した場合、計算に必要なバーコードメッセージは 6 桁以上必要になります。6 桁未満の場合は、Modulus10Weight3(モジュラス10 / ウエイト3) で計算されます。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Codabar;
// チェックデジットの計算方法を "モジュラス 11" に設定します。
barCode1.CheckPattern = AdvanceSoftware.ASReport.BarCode.CheckPattern.Modulus11;
barCode1.Value = "12345678";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Codabar
' チェックデジットの計算方法を "モジュラス 11" に設定します。
BarCode1.CheckPattern = AdvanceSoftware.ExcelCreator.BarCode.CheckPattern.Modulus11
BarCode1.Value = "12345678"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.Codeset プロパティ

BarCodeCodeset プロパティ

スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Codeset Codeset { get; set; }
Public Property Codeset As Codeset
    Get
    Set

プロパティ値

型: Codeset
スタートコードセットを表す Codeset。(既定値：Codeset.CodesetAuto)
解説
プロパティ値が CodeSet.CodesetAuto の場合、バーコードデータの先頭の文字でコードセットが決まります。

先頭キャラクタが ~(チルダ) の場合、コードセットA に設定されます。

先頭キャラクタがアルファベットの場合、コードセットB に設定されます。

先頭から 2 キャラクタが数字の場合、コードセット C に設定されます。

例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Code128;
// Code128 を "コードセット B" に設定します。
barCode1.Codeset = AdvanceSoftware.ExcelCreator.BarCode.Codeset.CodesetB;
barCode1.Value = "abc123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Code128
' Code128 を "コードセット B" に設定します。
BarCode1.Codeset = AdvanceSoftware.ExcelCreator.BarCode.Codeset.CodesetB
BarCode1.Value = "abc123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.DpiX プロパティ

BarCodeDpiX プロパティ

X 軸方向の解像度を設定、取得します。(ピクセル単位)

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double DpiX { get; set; }
Public Property DpiX As Double
    Get
    Set

プロパティ値

型: Double
X 軸方向の解像度を表す double。(既定値：96.0)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// X 軸方向の解像度を "600dpi" に設定します。
barCode1.DpiX = 600;
// Y 軸方向の解像度を "600dpi" に設定します。
barCode1.DpiY = 600;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' X 軸方向の解像度を "600dpi" に設定します。
BarCode1.DpiX = 600
' Y 軸方向の解像度を "600dpi" に設定します。
BarCode1.DpiY = 600
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.DpiY プロパティ

BarCodeDpiY プロパティ

Y 軸方向の解像度を設定、取得します。(ピクセル単位)

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double DpiY { get; set; }
Public Property DpiY As Double
    Get
    Set

プロパティ値

型: Double
Y 軸方向の解像度を表す double。(既定値：96.0)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// X 軸方向の解像度を "600dpi" に設定します。
barCode1.DpiX = 600;
// Y 軸方向の解像度を "600dpi" に設定します。
barCode1.DpiY = 600;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' X 軸方向の解像度を "600dpi" に設定します。
BarCode1.DpiX = 600
' Y 軸方向の解像度を "600dpi" に設定します。
BarCode1.DpiY = 600
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.Element プロパティ

BarCodeElement プロパティ

最小エレメント値を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double Element { get; set; }
Public Property Element As Double
    Get
    Set

プロパティ値

型: Double
最小エレメント値を表す double。
解説
プロパティ値は Unit プロパティのサイズ単位で扱われます。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Codabar;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter;
// バーコードイメージの最小エレメント値を "0.191mm" に設定します。
barCode1.Element = 0.191;
barCode1.Value = "1234567890";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Codabar
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter
' バーコードイメージの最小エレメント値を "0.191mm" に設定します。
BarCode1.Element = 0.191
BarCode1.Value = "1234567890"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.EmfType プロパティ

BarCodeEmfType プロパティ

拡張メタファイル(EMF)に格納されるレコードの品質を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public EmfType EmfType { get; set; }
Public Property EmfType As EmfType
    Get
    Set

プロパティ値

型: EmfType
拡張メタファイルのレコード品質を表す EmfType。(既定値：EmfType.EmfPlusDual)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
// 拡張メタファイルのレコード品質を "EmfOnly" に設定します。
barCode1.EmfType = System.Drawing.Imaging.EmfType.EmfOnly;
barCode1.Value = "1234567890123";
Image imgBarCode = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf);
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
' 拡張メタファイルのレコード品質を "EmfOnly" に設定します。
BarCode1.EmfType = System.Drawing.Imaging.EmfType.EmfOnly
BarCode1.Value = "1234567890123"
Dim imgBarCode As Image = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf)
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.ErrorMessage プロパティ

BarCodeErrorMessage プロパティ

エラーメッセージを取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string ErrorMessage { get; }
Public ReadOnly Property ErrorMessage As String
    Get

プロパティ値

型: String
バーコード生成時のエラーメッセージを表す string。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// エラー処理
if (barCode1.ErrorNo != AdvanceSoftware.ExcelCreator.BarCode.ErrorNo.NoError)
{
    // エラーメッセージを表示します。
    MessageBox.Show(barCode1.ErrorMessage);
}
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' エラー処理
If BarCode1.ErrorNo <> AdvanceSoftware.ExcelCreator.BarCode.ErrorNo.NoError Then
    ' エラーメッセージを表示します。
    MessageBox.Show(BarCode1.ErrorMessage)
End If
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.ErrorNo プロパティ

BarCodeErrorNo プロパティ

エラーナンバーを取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo ErrorNo { get; }
Public ReadOnly Property ErrorNo As ErrorNo
    Get

プロパティ値

型: ErrorNo
バーコード生成時のエラーナンバーを表す ErrorNo。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// エラー処理
if (barCode1.ErrorNo != AdvanceSoftware.ExcelCreator.BarCode.ErrorNo.NoError)
{
    // エラーメッセージを表示します。
    MessageBox.Show(barCode1.ErrorMessage);
}
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' エラー処理
If BarCode1.ErrorNo <> AdvanceSoftware.ExcelCreator.BarCode.ErrorNo.NoError Then
    ' エラーメッセージを表示します。
    MessageBox.Show(BarCode1.ErrorMessage)
End If
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.FlatHeight プロパティ

BarCodeFlatHeight プロパティ

ガードバーの均等化を設定、取得します。(JAN、UPC)

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool FlatHeight { get; set; }
Public Property FlatHeight As Boolean
    Get
    Set

プロパティ値

型: Boolean
ガードバーの均等化を表す bool。(既定値：false)
解説
プロパティ値が true の場合、ガードバーを均等化します。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
// ガードバーの長さを均等に設定します。
barCode1.FlatHeight = true;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
' ガードバーの長さを均等に設定します。
BarCode1.FlatHeight = True
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.Font プロパティ

BarCodeFont プロパティ

バーコードメッセージのフォント名、フォントスタイルを設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Font Font { get; set; }
Public Property Font As Font
    Get
    Set

プロパティ値

型: Font
バーコードメッセージのフォントを表す Font。
解説
このプロパティは、バーコードメッセージのフォント名、フォントスタイルを設定することができます。 フォントサイズは反映されないため、CharSize プロパティで設定して下さい。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
// バーコードメッセージを "フォント名：ＭＳ 明朝 , フォントスタイル：斜体" に設定します。
barCode1.Font = new System.Drawing.Font("ＭＳ 明朝", 9, System.Drawing.FontStyle.Italic);
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
' バーコードメッセージを "フォント名：ＭＳ 明朝 , フォントスタイル：斜体" に設定します。
BarCode1.Font = New System.Drawing.Font("ＭＳ 明朝", 9, System.Drawing.FontStyle.Italic)
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.InternalQRVersion プロパティ

BarCodeInternalQRVersion プロパティ

QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public QRVersion InternalQRVersion { get; }
Public ReadOnly Property InternalQRVersion As QRVersion
    Get

プロパティ値

型: QRVersion
QR コードの型番を表す QRVersion。
解説
プロパティ値が QRVersion.VersionAuto の場合、QR コードの型番は自動で設定されます。

QRModel プロパティの値により、QRVersion.VersionAuto 以外の設定範囲が異なります。

設定範囲(QRModel1)：QRVersion.QRVersion1 ～ QRVersion14

設定範囲(QRModel2)：QRVersion.QRVersion1 ～ QRVersion40

例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode;
barCode1.QRVersion = AdvanceSoftware.ExcelCreator.BarCode.QRVersion.VersionAuto;
barCode1.Value = "12345ABCDE";
Image imgBarCode = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
// 自動設定された QR コード の型番を取得します。
AdvanceSoftware.ExcelCreator.BarCode.QRVersion internalQRVersion = barCode1.InternalQRVersion;
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode
BarCode1.QRVersion = AdvanceSoftware.ExcelCreator.BarCode.QRVersion.VersionAuto
BarCode1.Value = "12345ABCDE"
Dim imgBarCode As Image = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp)
' 自動設定された QR コード の型番を取得します。
Dim internalQRVersion As AdvanceSoftware.ExcelCreator.BarCode.QRVersion = BarCode1.InternalQRVersion
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.InternalValue プロパティ

BarCodeInternalValue プロパティ

整形後のバーコードデータを取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string InternalValue { get; }
Public ReadOnly Property InternalValue As String
    Get

プロパティ値

型: String
整形後のバーコードデータを表す string。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
Image imgBarCode = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
// 整形後のバーコードデータを取得します。
string internalValue = barCode1.InternalValue;
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
Dim imgBarCode As Image = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp)
' 整形後のバーコードデータを取得します。
Dim internalValue As String = BarCode1.InternalValue
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.MessageAlign プロパティ

BarCodeMessageAlign プロパティ

バーコードメッセージの表示横位置を設定、取得します。(公共料金等代理収納 GS1-128)

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public MessageAlign MessageAlign { get; set; }
Public Property MessageAlign As MessageAlign
    Get
    Set

プロパティ値

型: MessageAlign
バーコードメッセージの表示横位置を表す MessageAlign。(既定値：MessageAlign.Center)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.GS1Fixed;
// バーコードメッセージの横位置を "左詰め" に設定します。(公共料金等代理収納 GS1-128)
barCode1.MessageAlign = AdvanceSoftware.ExcelCreator.BarCode.MessageAlign.Left;
barCode1.Value = "91012345678901234567890123456789012345678901";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.GS1Fixed
' バーコードメッセージの横位置を "左詰め" に設定します。(公共料金等代理収納 GS1-128)
BarCode1.MessageAlign = AdvanceSoftware.ExcelCreator.BarCode.MessageAlign.Left
BarCode1.Value = "91012345678901234567890123456789012345678901"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.PDFColumn プロパティ

BarCodePDFColumn プロパティ

PDF417 の列数を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int PDFColumn { get; set; }
Public Property PDFColumn As Integer
    Get
    Set

プロパティ値

型: Int32
PDF417 の列数を表す int。(既定値：0)
解説
設定範囲：0 ～ 40

プロパティ値が 0 の場合、縦横比 1:2 で PDF417 を作成します。

例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.PDF417;
// PDF417 の列数を "15列" に設定します。
barCode1.PDFColumn = 15;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.PDF417
' PDF417 の列数を "15列" に設定します。
BarCode1.PDFColumn = 15
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.PDFInitialSymbol プロパティ

BarCodePDFInitialSymbol プロパティ

PDF417 の初期化シンボルを設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool PDFInitialSymbol { get; set; }
Public Property PDFInitialSymbol As Boolean
    Get
    Set

プロパティ値

型: Boolean
PDF417 の初期化シンボルを表す bool。(既定値：false)
解説
プロパティ値が true の場合、初期化シンボルを付加した PDF417 を作成します。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.PDF417;
// PDF417 の初期化シンボルを "付加する" に設定します。
barCode1.PDFInitialSymbol = true;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.PDF417
' PDF417 の初期化シンボルを "付加する" に設定します。
BarCode1.PDFInitialSymbol = True
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.PDFLevel プロパティ

BarCodePDFLevel プロパティ

PDF417 のエラー訂正レベルを設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int PDFLevel { get; set; }
Public Property PDFLevel As Integer
    Get
    Set

プロパティ値

型: Int32
PDF417 のエラー訂正レベルを表す int。(既定値：0)
解説
設定範囲：0 ～ 8
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.PDF417;
// PDF417 のエラー訂正レベルを "レベル7" に設定します。
barCode1.PDFLevel = 7;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.PDF417
' PDF417 のエラー訂正レベルを "レベル7" に設定します。
BarCode1.PDFLevel = 7
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.PDFModel プロパティ

BarCodePDFModel プロパティ

PDF417 シンボルを設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PDFModel PDFModel { get; set; }
Public Property PDFModel As PDFModel
    Get
    Set

プロパティ値

型: PDFModel
PDF417 シンボルを表す PDFModel。(既定値：PDFModel.Default)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.PDF417;
// PDF417 シンボルを "簡易 PDF417" に設定します。
barCode1.PDFModel = AdvanceSoftware.ExcelCreator.BarCode.PDFModel.Truncated;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.PDF417
' PDF417 シンボルを "簡易 PDF417" に設定します。
BarCode1.PDFModel = AdvanceSoftware.ExcelCreator.BarCode.PDFModel.Truncated
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.PDFRatio プロパティ

BarCodePDFRatio プロパティ

PDF417 の 1 モジュールの縦横比を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double PDFRatio { get; set; }
Public Property PDFRatio As Double
    Get
    Set

プロパティ値

型: Double
PDF417 の 1 モジュールの縦横比を表す double。(既定値：7.5)
解説
設定範囲：1.0 ～ 10.0
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.PDF417;
// PDF417 の 1 モジュールの幅との縦横比を "5.0" に設定します。
barCode1.PDFRatio = 5.0;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.PDF417
' PDF417 の 1 モジュールの幅との縦横比を "5.0" に設定します。
BarCode1.PDFRatio = 5.0
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.PDFRow プロパティ

BarCodePDFRow プロパティ

PDF417 の行数を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int PDFRow { get; set; }
Public Property PDFRow As Integer
    Get
    Set

プロパティ値

型: Int32
PDF417 の行数を表す int。(既定値：0)
解説
設定範囲：0、3 ～ 90

プロパティ値が 0 の場合、縦横比 1:2 で PDF417 を作成します。

例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.PDF417;
// PDF417 の行数を "10行" に設定します。
barCode1.PDFRow = 10;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.PDF417
' PDF417 の行数を "10行" に設定します。
BarCode1.PDFRow = 10
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.Point プロパティ

BarCodePoint プロパティ

ポイントを設定、取得します。(カスタマバーコード)

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double Point { get; set; }
Public Property Point As Double
    Get
    Set

プロパティ値

型: Double
バーコードのポイントを表す double。(既定値：10.0)
解説
設定範囲：6.0 ～ 14.0
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.CustomerBarCode;
// カスタマバーコードのポイントを "10.0" に設定します。
barCode1.Point = 10.0;
barCode1.Value = "91882391-2816";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.CustomerBarCode
' カスタマバーコードのポイントを "10.0" に設定します。
BarCode1.Point = 10.0
BarCode1.Value = "91882391-2816"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.QRConnect プロパティ

BarCodeQRConnect プロパティ

連結 QR コードを作成するかを設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public QRConnect QRConnect { get; set; }
Public Property QRConnect As QRConnect
    Get
    Set

プロパティ値

型: QRConnect
連結 QR コードの設定を表す QRConnect。(既定値：QRConnect.NotConnect)
解説
プロパティ値が QRConnect.AutoConnect、QRConnect.ManualConnect の場合、QRVersion プロパティを QRVersion.VersionAuto 以外に設定します。

また、QRConnect.ManualConnect の場合、QREscapeCode プロパティを使用して分割する位置のエスケープコードを設定します。

例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.ExcelCreator.BarCode.QRVersion.Version10;
// QR コード を "連結 QR コード(手動)" に設定します。
barCode1.QRConnect = AdvanceSoftware.ExcelCreator.BarCode.QRConnect.ManualConnect;
// QR コードのエスケープコードを "% (0x25)" に設定します。
barCode1.QREscapeCode = 0x25;
barCode1.Value = "12345%SABCDE";
// 連結 QR コードで出力するシンボル番号を "0" に設定します。
barCode1.QRSymbolNumber = 0;
Image image1 = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
// 連結 QR コードで出力するシンボル番号を "1" に設定します。
barCode1.QRSymbolNumber = 1;
Image image2 = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.ExcelCreator.BarCode.QRVersion.Version10
' QR コード を "連結 QR コード(手動)" に設定します。
BarCode1.QRConnect = AdvanceSoftware.ExcelCreator.BarCode.QRConnect.ManualConnect
' QR コードのエスケープコードを "% (&H25)" に設定します。
BarCode1.QREscapeCode = &H25
BarCode1.Value = "12345%SABCDE"
' 連結 QR コードで出力するシンボル番号を "0" に設定します。
BarCode1.QRSymbolNumber = 0
Dim image1 As Image = BarCode1.GetBarCodeImage(Imaging.ImageFormat.Bmp)
' 連結 QR コードで出力するシンボル番号を "1" に設定します。
BarCode1.QRSymbolNumber = 1
Dim image2 As Image = BarCode1.GetBarCodeImage(Imaging.ImageFormat.Bmp)
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.QREscapeCode プロパティ

BarCodeQREscapeCode プロパティ

QR コードのエスケープコードを設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public byte QREscapeCode { get; set; }
Public Property QREscapeCode As Byte
    Get
    Set

プロパティ値

型: Byte
QR コードのエスケープコードを表す Byte。(既定値：0x00)
解説
Value プロパティや、BinaryValue プロパティに設定するバーコードデータの分割する位置に、"エスケープコード" + "S" を設定します。バーコードデータにエスケープコードと同じ文字がある場合、バーコードメッセージ側の該当する文字を二つ連続して設定してください。

このプロパティは、QRConnect プロパティの値が、QRConnect.ManualConnect の場合に有効です。

例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.ExcelCreator.BarCode.QRVersion.Version10;
// QR コード を "連結 QR コード(手動)" に設定します。
barCode1.QRConnect = AdvanceSoftware.ExcelCreator.BarCode.QRConnect.ManualConnect;
// QR コードのエスケープコードを "% (0x25)" に設定します。
barCode1.QREscapeCode = 0x25;
barCode1.Value = "12345%SABCDE";
// 連結 QR コードで出力するシンボル番号を "0" に設定します。
barCode1.QRSymbolNumber = 0;
Image image1 = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
// 連結 QR コードで出力するシンボル番号を "1" に設定します。
barCode1.QRSymbolNumber = 1;
Image image2 = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.ExcelCreator.BarCode.QRVersion.Version10
' QR コード を "連結 QR コード(手動)" に設定します。
BarCode1.QRConnect = AdvanceSoftware.ExcelCreator.BarCode.QRConnect.ManualConnect
' QR コードのエスケープコードを "% (&H25)" に設定します。
BarCode1.QREscapeCode = &H25
BarCode1.Value = "12345%SABCDE"
' 連結 QR コードで出力するシンボル番号を "0" に設定します。
BarCode1.QRSymbolNumber = 0
Dim image1 As Image = BarCode1.GetBarCodeImage(Imaging.ImageFormat.Bmp)
' 連結 QR コードで出力するシンボル番号を "1" に設定します。
BarCode1.QRSymbolNumber = 1
Dim image2 As Image = BarCode1.GetBarCodeImage(Imaging.ImageFormat.Bmp)
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.QRLevel プロパティ

BarCodeQRLevel プロパティ

QR コードの誤り訂正レベルを設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public QRLevel QRLevel { get; set; }
Public Property QRLevel As QRLevel
    Get
    Set

プロパティ値

型: QRLevel
QR コードの誤り訂正レベルを表す QRLevel。(既定値：QRLevel.LevelM)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode;
// QR コードのエラー訂正レベルを "H" に設定します。
barCode1.QRLevel = AdvanceSoftware.ExcelCreator.BarCode.QRLevel.LevelH;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode
' QR コードのエラー訂正レベルを "H" に設定します。
BarCode1.QRLevel = AdvanceSoftware.ExcelCreator.BarCode.QRLevel.LevelH
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.QRMask プロパティ

BarCodeQRMask プロパティ

QR コードのマスクパターンを設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public QRMask QRMask { get; set; }
Public Property QRMask As QRMask
    Get
    Set

プロパティ値

型: QRMask
QR コードのマスクパターンを表す QRMask。(既定値：QRMask.MaskAuto)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode;
// QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
barCode1.QRMask = AdvanceSoftware.ExcelCreator.BarCode.QRMask.Mask000;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode
' QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
BarCode1.QRMask = AdvanceSoftware.ExcelCreator.BarCode.QRMask.Mask000
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.QRModel プロパティ

BarCodeQRModel プロパティ

QR コードのモデルを設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public QRModel QRModel { get; set; }
Public Property QRModel As QRModel
    Get
    Set

プロパティ値

型: QRModel
QR コードのモデルを表す QRModel。(既定値：QRModel.Model1)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode;
// QR コードのモデルを "モデル 2" に設定します。
barCode1.QRModel = AdvanceSoftware.ExcelCreator.BarCode.QRModel.Model2;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode
' QR コードのモデルを "モデル 2" に設定します。
BarCode1.QRModel = AdvanceSoftware.ExcelCreator.BarCode.QRModel.Model2
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.QRSymbolNumber プロパティ

BarCodeQRSymbolNumber プロパティ

連結 QR コードで出力するシンボル番号を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int QRSymbolNumber { get; set; }
Public Property QRSymbolNumber As Integer
    Get
    Set

プロパティ値

型: Int32
連結 QR コードのシンボル番号を表す int。(既定値：0)
解説
設定範囲：0 ～ 15

このプロパティは、QRConnect プロパティの値が、QRConnect.AutoConnect、QRConnect.ManualConnect の場合に有効です。

例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.ExcelCreator.BarCode.QRVersion.Version10;
// QR コード を "連結 QR コード(手動)" に設定します。
barCode1.QRConnect = AdvanceSoftware.ExcelCreator.BarCode.QRConnect.ManualConnect;
// QR コードのエスケープコードを "% (0x25)" に設定します。
barCode1.QREscapeCode = 0x25;
barCode1.Value = "12345%SABCDE";
// 連結 QR コードで出力するシンボル番号を "0" に設定します。
barCode1.QRSymbolNumber = 0;
Image image1 = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
// 連結 QR コードで出力するシンボル番号を "1" に設定します。
barCode1.QRSymbolNumber = 1;
Image image2 = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.ExcelCreator.BarCode.QRVersion.Version10
' QR コード を "連結 QR コード(手動)" に設定します。
BarCode1.QRConnect = AdvanceSoftware.ExcelCreator.BarCode.QRConnect.ManualConnect
' QR コードのエスケープコードを "% (&H25)" に設定します。
BarCode1.QREscapeCode = &H25
BarCode1.Value = "12345%SABCDE"
' 連結 QR コードで出力するシンボル番号を "0" に設定します。
BarCode1.QRSymbolNumber = 0
Dim image1 As Image = BarCode1.GetBarCodeImage(Imaging.ImageFormat.Bmp)
' 連結 QR コードで出力するシンボル番号を "1" に設定します。
BarCode1.QRSymbolNumber = 1
Dim image2 As Image = BarCode1.GetBarCodeImage(Imaging.ImageFormat.Bmp)
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.QRVersion プロパティ

BarCodeQRVersion プロパティ

QR コードの型番を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public QRVersion QRVersion { get; set; }
Public Property QRVersion As QRVersion
    Get
    Set

プロパティ値

型: QRVersion
QR コードの型番を表す QRVersion。(既定値：QRVersion.VersionAuto)
解説
プロパティ値が QRVersion.VersionAuto の場合、QR コードの型番は自動で設定されます。

QRModel プロパティの値により、QRVersion.VersionAuto 以外の設定範囲が異なります。

設定範囲(QRModel1)：QRVersion.QRVersion1 ～ QRVersion14

設定範囲(QRModel2)：QRVersion.QRVersion1 ～ QRVersion40

例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.ExcelCreator.BarCode.QRVersion.Version10;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.ExcelCreator.BarCode.QRVersion.Version10
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.Quiet プロパティ

BarCodeQuiet プロパティ

余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金等代理収納 GS1-128)

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double Quiet { get; set; }
Public Property Quiet As Double
    Get
    Set

プロパティ値

型: Double
余白のサイズを表す double。(既定値：0.0)
解説
プロパティ値は Unit プロパティのサイズ単位で扱われます。 プロパティ値が 0 の場合、バーコードの余白は自動で設定されます。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Codabar;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter;
// バーコードイメージの余白幅を "2.5mm" に設定します。
barCode1.Quiet = 2.5;
barCode1.Value = "1234567890";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Codabar
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter
' バーコードイメージの余白幅を "2.5mm" に設定します。
BarCode1.Quiet = 2.5
BarCode1.Value = "1234567890"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.Rotate プロパティ

BarCodeRotate プロパティ

バーコードの回転方向を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Rotate Rotate { get; set; }
Public Property Rotate As Rotate
    Get
    Set

プロパティ値

型: Rotate
バーコードの回転方向を表す Rotate。(既定値：Rotate.Rotate0)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
// バーコードイメージの向きを "時計回りで 90 度回転" に設定します。
barCode1.Rotate = AdvanceSoftware.ExcelCreator.BarCode.Rotate.Rotate90;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
' バーコードイメージの向きを "時計回りで 90 度回転" に設定します。
BarCode1.Rotate = AdvanceSoftware.ExcelCreator.BarCode.Rotate.Rotate90
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.ShowBearer プロパティ

BarCodeShowBearer プロパティ

ベアラバーを表示するかを設定、取得します。(ITF)

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowBearer { get; set; }
Public Property ShowBearer As Boolean
    Get
    Set

プロパティ値

型: Boolean
ベアラバーの表示モードを表す bool。(既定値：true)
解説
プロパティ値が true の場合、ベアラバーを表示します。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.ITF16;
// ITF16 のベアラバーを "表示しない" に設定します。
barCode1.ShowBearer = false;
barCode1.Value = "1234567890123456";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.ITF16
' ITF16 のベアラバーを "表示しない" に設定します。
BarCode1.ShowBearer = False
BarCode1.Value = "1234567890123456"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.ShowMessage プロパティ

BarCodeShowMessage プロパティ

バーコードメッセージを表示するかを設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowMessage { get; set; }
Public Property ShowMessage As Boolean
    Get
    Set

プロパティ値

型: Boolean
バーコードメッセージの表示モードを表す bool。(既定値：true)
解説
プロパティ値が true の場合、バーコードメッセージを表示します。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
// バーコードメッセージを "表示しない" に設定します。
barCode1.ShowMessage = false;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
' バーコードメッセージを "表示しない" に設定します。
BarCode1.ShowMessage = False
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.StartChar プロパティ

BarCodeStartChar プロパティ

スタートキャラクタを設定、取得します。(Codabar)

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public char StartChar { get; set; }
Public Property StartChar As Char
    Get
    Set

プロパティ値

型: Char
スタートキャラクタを表す char。(既定値：'a')
解説
設定可能な値：'a'、'b'、'c'、'd'、't'、'n'、'*'、'e'、'A'、'B'、'C'、'D'
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Codabar;
// Codabar のスタートキャラクタを "c" に設定します。
barCode1.StartChar = 'c';
barCode1.Value = "1234567890";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Codabar
' Codabar のスタートキャラクタを "c" に設定します。
BarCode1.StartChar = "c"
BarCode1.Value = "1234567890"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.StopChar プロパティ

BarCodeStopChar プロパティ

ストップキャラクタを設定、取得します。(Codabar)

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public char StopChar { get; set; }
Public Property StopChar As Char
    Get
    Set

プロパティ値

型: Char
ストップキャラクタを表す char。(既定値：'a')
解説
設定可能な値：'a'、'b'、'c'、'd'、't'、'n'、'*'、'e'、'A'、'B'、'C'、'D'
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Codabar;
// Codabar のストップキャラクタを "c" に設定します。
barCode1.StopChar = 'c';
barCode1.Value = "1234567890";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Codabar
' Codabar のストップキャラクタを "c" に設定します。
BarCode1.StopChar = "c"
BarCode1.Value = "1234567890"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.TextRenderingHint プロパティ

BarCodeTextRenderingHint プロパティ

バーコードキャラクタのテキストレンダリングの品質を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextRenderingHint TextRenderingHint { get; set; }
Public Property TextRenderingHint As TextRenderingHint
    Get
    Set

プロパティ値

型: TextRenderingHint
バーコードキャラクタのテキストレンダリングを表す TextRenderingHint。(既定値：TextRenderingHint.SystemDefault)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
// バーコードメッセージのテキストレンダリングの品質を "SingleBitPerPixel" に設定します。
barCode1.TextRenderingHint = System.Drawing.Text.TextRenderingHint.SingleBitPerPixel;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
' バーコードメッセージのテキストレンダリングの品質を "SingleBitPerPixel" に設定します。
BarCode1.TextRenderingHint = System.Drawing.Text.TextRenderingHint.SingleBitPerPixel
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.Type プロパティ

BarCodeType プロパティ

バーコードの種類を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public BarCodeType Type { get; set; }
Public Property Type As BarCodeType
    Get
    Set

プロパティ値

型: BarCodeType
バーコードのタイプを表す BarCodeType。(既定値：BarCodeType.JAN13)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
// 生成するバーコードイメージを "JAN13" に設定します。
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
' 生成するバーコードイメージを "JAN13" に設定します。
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.Unit プロパティ

BarCodeUnit プロパティ

バーコードの生成単位を設定、取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Unit Unit { get; set; }
Public Property Unit As Unit
    Get
    Set

プロパティ値

型: Unit
バーコードの生成単位を表す Unit。(既定値：Unit.Pixel)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.Value プロパティ

BarCodeValue プロパティ

バーコードデータを設定、取得します。(文字列)

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Value { get; set; }
Public Property Value As String
    Get
    Set

プロパティ値

型: String
バーコードデータを表す string。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
// バーコードデータを設定します。 (文字列)
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
' バーコードデータを設定します。 (文字列)
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.ValueEncoding プロパティ

BarCodeValueEncoding プロパティ

バーコードデータのエンコード方式を設定、取得します。(QRCode, PDF417)

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ValueEncoding ValueEncoding { get; set; }
Public Property ValueEncoding As ValueEncoding
    Get
    Set

プロパティ値

型: ValueEncoding
バーコードデータのエンコード方式を表す ValueEncoding。(既定値：ValueEncoding.ShiftJIS")
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode;
// バーコードデータのエンコード方式を "UTF-8" に設定します。
barCode1.ValueEncoding = AdvanceSoftware.ExcelCreator.BarCode.ValueEncoding.UTF8;
barCode1.Value = "日本語";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.QRCode
' バーコードデータのエンコード方式を "UTF-8" に設定します。
BarCode1.ValueEncoding = AdvanceSoftware.ExcelCreator.BarCode.ValueEncoding.UTF8
BarCode1.Value = "日本語"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.WhiteBarRevision プロパティ

BarCodeWhiteBarRevision プロパティ

白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金等代理収納 GS1-128)

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int WhiteBarRevision { get; set; }
Public Property WhiteBarRevision As Integer
    Get
    Set

プロパティ値

型: Int32
白バーのドット補正値を表す int。(既定値：0)
解説
Unit プロパティの値が、Unit.Pixel の場合、有効になります。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Code128;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
// 白バーのドット補正値を "+2" に設定します。
barCode1.WhiteBarRevision = 2;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.Code128
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
' 白バーのドット補正値を "+2" に設定します。
BarCode1.WhiteBarRevision = 2
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.Zoom プロパティ

BarCodeZoom プロパティ

倍率を設定、取得します。(JAN、UPC、ITF)

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int Zoom { get; set; }
Public Property Zoom As Integer
    Get
    Set

プロパティ値

型: Int32
バーコードの倍率を表す int。(既定値：100)
解説

設定範囲(JAN、UPC)：50 ～ 200

設定範囲(ITF)：25 ～ 120

例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
// バーコードイメージの表示倍率を "200%" に設定します。
barCode1.Zoom = 200;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
' バーコードイメージの表示倍率を "200%" に設定します。
BarCode1.Zoom = 200
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode メソッド

BarCode 型は下記のメンバーを公開します。

メソッド
名前 | 説明
GetBarCodeImage(ImageFormat) | バーコードのイメージを作成します。
GetBarCodeImage(ImageFormat, Boolean) | バーコードのイメージを作成します。
GetScaleSize | 指定した単位でバーコードのサイズを取得します。
SetLicense(Stream) | ライセンス情報を設定します。
SetLicense(String) | ライセンス情報を設定します。
トップ
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.GetBarCodeImage メソッド

BarCodeGetBarCodeImage メソッド

オーバーロードの一覧
名前 | 説明
GetBarCodeImage(ImageFormat) | バーコードのイメージを作成します。
GetBarCodeImage(ImageFormat, Boolean) | バーコードのイメージを作成します。
トップ
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.GetBarCodeImage メソッド (ImageFormat)

BarCodeGetBarCodeImage メソッド (ImageFormat)

バーコードのイメージを作成します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Image GetBarCodeImage(
    ImageFormat format
)
Public Function GetBarCodeImage (
    format As ImageFormat
) As Image

パラメーター

format
型: System.Drawing.ImagingImageFormat
保存する Image のImageFormat。

戻り値

型: Image
このメソッドが作成する Image。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// バーコードイメージ (ビットマップ) を生成します。
Image imgBarCode = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' バーコードイメージ (ビットマップ) を生成します。
Dim imgBarCode As Image = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp)
関連項目

参照

BarCode クラス
GetBarCodeImage オーバーロード
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.GetBarCodeImage メソッド (ImageFormat, Boolean)

BarCodeGetBarCodeImage メソッド (ImageFormat, Boolean)

バーコードのイメージを作成します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Image GetBarCodeImage(
    ImageFormat format,
    bool resolution
)
Public Function GetBarCodeImage (
    format As ImageFormat,
    resolution As Boolean
) As Image

パラメーター

format
型: System.Drawing.ImagingImageFormat
保存する Image のImageFormat。
resolution
型: SystemBoolean
DpiX プロパティ、DpiY プロパティの解像度で Bitmap を作成する場合、true を設定します。

戻り値

型: Image
このメソッドが作成する Image。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel;
barCode1.DpiX = 600;
barCode1.DpiY = 600;
barCode1.Value = "1234567890123";
// バーコードイメージ (ビットマップ) を DpiX, DpiY プロパティの解像度で生成します。
Image imgBarCode = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp, true);
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.ExcelCreator.BarCode.Unit.Pixel
BarCode1.DpiX = 600
BarCode1.DpiY = 600
BarCode1.Value = "1234567890123"
' バーコードイメージ (ビットマップ) を DpiX, DpiY プロパティの解像度で生成します。
Dim imgBarCode As Image = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp, True)
関連項目

参照

BarCode クラス
GetBarCodeImage オーバーロード
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.GetScaleSize メソッド

BarCodeGetScaleSize メソッド

指定した単位でバーコードのサイズを取得します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public BarCodeSizeD GetScaleSize(
    Unit unit
)
Public Function GetScaleSize (
    unit As Unit
) As BarCodeSizeD

パラメーター

unit
型: AdvanceSoftware.ExcelCreator.BarCodeUnit
取得するサイズの単位を表す Unit 列挙体。

戻り値

型: BarCodeSizeD
バーコードのサイズ。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
AdvanceSoftware.ExcelCreator.BarCode.BarCodeSizeD barCodeSizeD;
// バーコードイメージのサイズを ミリ(mm) 単位で取得します。
barCodeSizeD = barCode1.GetScaleSize(AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter);
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
Dim BarCodeSizeD As AdvanceSoftware.ExcelCreator.BarCode.BarCodeSizeD
' バーコードイメージのサイズを ミリ(mm) 単位で取得します。
BarCodeSizeD = BarCode1.GetScaleSize(AdvanceSoftware.ExcelCreator.BarCode.Unit.Millimeter)
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.SetLicense メソッド

BarCodeSetLicense メソッド

オーバーロードの一覧
名前 | 説明
SetLicense(Stream) | ライセンス情報を設定します。
SetLicense(String) | ライセンス情報を設定します。
トップ
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.SetLicense メソッド (Stream)

BarCodeSetLicense メソッド (Stream)

ライセンス情報を設定します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void SetLicense(
    Stream stream
)
Public Sub SetLicense (
    stream As Stream
)

パラメーター

stream
型: System.IOStream
ライセンスファイルのストリーム
解説
SetLicense メソッドはインスタンスごとに 1 回呼び出してください。バーコード出力のたびに呼び出す必要はありません。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
// ライセンス情報を設定します。
barCode1.SetLicense(licenseStream);
// 複数のバーコードを作成します。
for (int i = 0; i < 5; i++)
{
    // ここで毎回呼び出す必要はありません。
    //barCode1.SetLicense(licenseStream);

    barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
    barCode1.Value = "1234567890123";
    Image imgBarCode = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
}
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
' ライセンス情報を設定します。
BarCode1.SetLicense(licenseStream)
' 複数のバーコードを作成します。
For i As Integer = 0 To 4
    ' ここで毎回呼び出す必要はありません。
    'BarCode1.SetLicense(licenseStream)

    BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
    BarCode1.Value = "1234567890123"
    Dim imgBarCode As Image = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp)
Next
関連項目

参照

BarCode クラス
SetLicense オーバーロード
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.SetLicense メソッド (String)

BarCodeSetLicense メソッド (String)

ライセンス情報を設定します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void SetLicense(
    string path
)
Public Sub SetLicense (
    path As String
)

パラメーター

path
型: SystemString
ライセンスファイルのパス
解説
SetLicense メソッドはインスタンスごとに 1 回呼び出してください。バーコード出力のたびに呼び出す必要はありません。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ExcelCreator.BarCode.BarCode();
// ライセンス情報を設定します。
barCode1.SetLicense(@"C:\AdvanceSoftware.ExcelCreator12.License.xml");
// 複数のバーコードを作成します。
for (int i = 0; i < 5; i++)
{
    // ここで毎回呼び出す必要はありません。
    //barCode1.SetLicense(@"C:\AdvanceSoftware.ExcelCreator12.License.xml");

    barCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13;
    barCode1.Value = "1234567890123";
    Image imgBarCode = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
}
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ExcelCreator.BarCode.BarCode()
' ライセンス情報を設定します。
BarCode1.SetLicense("C:\AdvanceSoftware.ExcelCreator12.License.xml")
' 複数のバーコードを作成します。
For i As Integer = 0 To 4
    ' ここで毎回呼び出す必要はありません。
    'BarCode1.SetLicense("C:\AdvanceSoftware.ExcelCreator12.License.xml")

    BarCode1.Type = AdvanceSoftware.ExcelCreator.BarCode.BarCodeType.JAN13
    BarCode1.Value = "1234567890123"
    Dim imgBarCode As Image = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp)
Next
関連項目

参照

BarCode クラス
SetLicense オーバーロード
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode イベント

BarCode 型は下記のメンバーを公開します。

イベント
名前 | 説明
Error | バーコードの作成に失敗した時に発生します。
トップ
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCode.Error イベント

BarCodeError イベント

バーコードの作成に失敗した時に発生します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public event BarCodeErrorEventHandler Error
Public Event Error As BarCodeErrorEventHandler

値

型: AdvanceSoftware.ExcelCreator.BarCodeBarCodeErrorEventHandler
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
private AdvanceSoftware.ExcelCreator.BarCode barCode1 = new AdvanceSoftware.ExcelCreator.BarCode();
private void InitializeComponent()
{
    // バーコードクラスのエラーイベントに barCode1_Error メソッドを関連付け
    this.barCode1.Error += new AdvanceSoftware.ExcelCreator.BarCode.BarCodeErrorEventHandler(barCode1_Error);
}
// バーコードクラスのエラーイベント
private void barCode1_Error(object sender, AdvanceSoftware.ExcelCreator.BarCode.BarCodeErrorEventArgs e)
{
    MessageBox.Show(barCode1.ErrorMessage);
}
' バーコードクラスのインスタンス生成 (WithEvents)
Private WithEvents BarCode1 As AdvanceSoftware.ExcelCreator.BarCode = New AdvanceSoftware.ExcelCreator.BarCode()
' バーコードクラスのエラーイベント
Private Sub BarCode1_Error(ByVal sender As Object, ByVal e As AdvanceSoftware.ExcelCreator.BarCode.BarCodeErrorEventArgs) Handles BarCode1.Error
    MessageBox.Show(BarCode1.ErrorMessage)
End Sub
関連項目

参照

BarCode クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCodeErrorEventArgs クラス

BarCode クラスの Error イベントのデータを提供します。
継承階層
SystemObject
SystemEventArgs
AdvanceSoftware.ExcelCreator.BarCodeBarCodeErrorEventArgs

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class BarCodeErrorEventArgs : EventArgs
Public Class BarCodeErrorEventArgs
    Inherits EventArgs

BarCodeErrorEventArgs 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
Public プロパティ | ErrorNo | エラーナンバーを処理します。
トップ
関連項目

参照

AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCodeErrorEventArgs プロパティ

BarCodeErrorEventArgs 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
Public プロパティ | ErrorNo | エラーナンバーを処理します。
トップ
関連項目

参照

BarCodeErrorEventArgs クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCodeErrorEventArgs.ErrorNo プロパティ

BarCodeErrorEventArgsErrorNo プロパティ

エラーナンバーを処理します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo ErrorNo { get; }
Public ReadOnly Property ErrorNo As ErrorNo
    Get

プロパティ値

型: ErrorNo
関連項目

参照

BarCodeErrorEventArgs クラス
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCodeErrorEventHandler デリゲート

BarCode クラスの Error イベントを処理するメソッドを表します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public delegate void BarCodeErrorEventHandler(
    Object sender,
    BarCodeErrorEventArgs e
)
Public Delegate Sub BarCodeErrorEventHandler (
    sender As Object,
    e As BarCodeErrorEventArgs
)

パラメーター

sender
型: SystemObject
e
型: AdvanceSoftware.ExcelCreator.BarCodeBarCodeErrorEventArgs
関連項目

参照

AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCodeSizeD 構造体

BarCodeSizeD 構造体

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public struct BarCodeSizeD
Public Structure BarCodeSizeD

BarCodeSizeD 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | Height | 高さ
Public フィールド | Width | 幅
トップ
関連項目

参照

AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCodeSizeD フィールド

BarCodeSizeD 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | Height | 高さ
Public フィールド | Width | 幅
トップ
関連項目

参照

BarCodeSizeD 構造体
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCodeSizeD.Height フィールド

BarCodeSizeDHeight フィールド

高さ

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double Height
Public Height As Double

フィールド値

型: Double
関連項目

参照

BarCodeSizeD 構造体
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCodeSizeD.Width フィールド

BarCodeSizeDWidth フィールド

幅

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double Width
Public Width As Double

フィールド値

型: Double
関連項目

参照

BarCodeSizeD 構造体
AdvanceSoftware.ExcelCreator.BarCode 名前空間


BarCodeType 列挙体

バーコードの種類を指定します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum BarCodeType
Public Enumeration BarCodeType
メンバー
メンバー | 値 | 説明
JAN13 | 0 | JAN コード(標準バージョン 13 桁)
JAN8 | 1 | JAN コード(短縮バージョン 8 桁)
UPCA | 2 | UPC コード(A バージョン)
UPCE | 3 | UPC コード(E バージョン)
ITF6 | 4 | ITF コード(アドオンバージョン 6 桁)
ITF14 | 5 | ITF コード(標準バージョン 14 桁)
ITF16 | 6 | ITF コード(拡張バージョン 16 桁)
ITF | 7 | ITF コード(自由桁)
Codabar | 8 | Codabar(NW-7)
Code39 | 9 | Code39
Code128 | 10 | Code128
GS1 | 11 | GS1-128(旧：UCC/EAN128)
GS1Fixed | 12 | 公共料金等代理収納 GS1-128
CustomerBarCode | 13 | カスタマバーコード
QRCode | 14 | QR コード
PDF417 | 15 | PDF417
関連項目

参照

AdvanceSoftware.ExcelCreator.BarCode 名前空間


CheckPattern 列挙体

チェックデジットの計算方法を指定します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum CheckPattern
Public Enumeration CheckPattern
メンバー
メンバー | 値 | 説明
Modulus16 | 0 | モジュラス 16
Modulus10Weight2 | 1 | モジュラス 10 / ウェイト 2
Modulus10Weight3 | 2 | モジュラス 10 / ウェイト 3
Modulus11 | 3 | モジュラス 11
Modulus11Weight | 4 | 加重モジュラス 11
SevenCheckDR | 5 | 7 チェック DR
Runes | 6 | ルーンズ
関連項目

参照

AdvanceSoftware.ExcelCreator.BarCode 名前空間


Codeset 列挙体

スタートコードセットを指定します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum Codeset
Public Enumeration Codeset
メンバー
メンバー | 値 | 説明
Auto | 0 | 自動でコードセットを設定
CodesetA | 1 | コードセット A
CodesetB | 2 | コードセット B
CodesetC | 3 | コードセット C
関連項目

参照

AdvanceSoftware.ExcelCreator.BarCode 名前空間


ErrorNo 列挙体

エラーナンバーを示す識別子を指定します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ErrorNo
Public Enumeration ErrorNo
メンバー
メンバー | 値 | 説明
NoError | 0 | エラーなし
Type | 101 | Type の設定に失敗しました。
Unit | 102 | Unit の設定に失敗しました。
Zoom | 103 | Zoom の設定に失敗しました。
Point | 104 | Point の設定に失敗しました。
Rotate | 105 | Rotate の設定に失敗しました。
DpiX | 106 | DpiX の設定に失敗しました。
DpiY | 107 | DpiY の設定に失敗しました。
BlackRatio | 108 | BlackRatio の設定に失敗しました。
BarHeight | 109 | BarHeight の設定に失敗しました。
BarWidth | 110 | BarWidth の設定に失敗しました。
Element | 111 | Element の設定に失敗しました。
Quiet | 112 | Quiet の設定に失敗しました。
BarRatio | 113 | BarRatio の設定に失敗しました。
CharGap | 114 | CharGap の設定に失敗しました。
CharSize | 115 | CharSize の設定に失敗しました。
CheckPattern | 116 | CheckPattern の設定に失敗しました。
CodeSet | 117 | CodeSet の設定に失敗しました。
Value | 118 | Value の設定に失敗しました。
CheckDigit | 119 | CheckDigit の設定に失敗しました。
ValueEncoding | 120 | ValueEncoding の設定に失敗しました。
QRModel | 200 | QRModel の設定に失敗しました。
QRVersion | 201 | QRVersion の設定に失敗しました。
QRLevel | 202 | QRLevel の設定に失敗しました。
QRConnectAct | 203 | 連結モードが間違っています。
QRConnect | 204 | QRConnect の設定に失敗しました。
QRSourceIsEmpty | 205 | データが空です。
QRSourceIsLarge | 206 | データが長すぎます。
QRConnectPos | 207 | 連結番号が違います。
QREscSeq | 208 | エスケープシーケンスが違います。
QRECIAssin | 209 | ECI 割り当て番号が違います。
QRKanji | 210 | 漢字コードが違います。
QRNumChar | 211 | 数字モードに適合しない文字が含まれています。
QRAnkChar | 212 | 英数字モードに適合しない文字が含まれています。
QRByteChar | 213 | バイトモードに適合しない文字が含まれています。
QRKanjiChar | 214 | 漢字モードに適合しない文字が含まれています。
QRSymbolOver | 215 | シンボルデータ領域を超えました。
QRConnectMode | 216 | 連結動作 2 以外で連結モードが設定されています。
QRTooManySymbol | 217 | 連結シンボル数が 16 を超えました。
QRMask | 218 | QRMask の設定に失敗しました。
PDFModel | 300 | PDFModel の設定に失敗しました。
PDFColumn | 301 | PDFColumn の設定に失敗しました。
PDFRow | 302 | PDFRow の設定に失敗しました。
PDFLevel | 303 | PDFLevel の設定に失敗しました。
PDFAspectRatio | 304 | 縦横比が違います。
PDFSourceIsEmpty | 305 | データが空です。
PDFSourceIsLarge | 306 | データが長すぎます。
PDFGLIValue | 307 | GLI 値が違います。
PDFNumChar | 308 | 数字モードに適合しない文字が含まれています。
PDFTextChar | 309 | テキストモードに適合しない文字が含まれています。
PDFByteChar | 310 | バイトモードに適合しない文字が含まれています。
PDFSymbolOver | 311 | シンボルデータ領域を超えました。
LicenseNotFound | 400 | ライセンス情報が見つかりません。
LicenseFileAccess | 401 | ライセンスファイルにアクセスできません。
LicenseLoad | 402 | ライセンス情報が読み込めません。
License | 403 | ライセンス認証エラー。
Platform | 404 | 動作環境エラー。
関連項目

参照

AdvanceSoftware.ExcelCreator.BarCode 名前空間


MessageAlign 列挙体

バーコードメッセージの表示横位置を指定します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum MessageAlign
Public Enumeration MessageAlign
メンバー
メンバー | 値 | 説明
Left | 0 | 左詰め
Center | 1 | 中央揃え
関連項目

参照

AdvanceSoftware.ExcelCreator.BarCode 名前空間


PDFModel 列挙体

PDF417 シンボルを指定します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum PDFModel
Public Enumeration PDFModel
メンバー
メンバー | 値 | 説明
Default | 0 | 標準の PDF417
Truncated | 1 | 簡易 PDF417
関連項目

参照

AdvanceSoftware.ExcelCreator.BarCode 名前空間


QRConnect 列挙体

QRコードの連結モードを指定します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum QRConnect
Public Enumeration QRConnect
メンバー
メンバー | 値 | 説明
NotConnect | 0 | 連結 QR コードを作成しない
AutoConnect | 1 | 連結QRコードを作成(自動)
ManualConnect | 2 | 連結 QR コードを作成(手動)
関連項目

参照

AdvanceSoftware.ExcelCreator.BarCode 名前空間


QRLevel 列挙体

QR コードの誤り訂正レベルを指定します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum QRLevel
Public Enumeration QRLevel
メンバー
メンバー | 値 | 説明
LevelL | 0 | L(復元率 7%)
LevelM | 1 | M(復元率 15%)
LevelQ | 2 | Q(復元率 25%)
LevelH | 3 | H(復元率 30%)
関連項目

参照

AdvanceSoftware.ExcelCreator.BarCode 名前空間


QRMask 列挙体

QR コードのマスクパターンを指定します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum QRMask
Public Enumeration QRMask
メンバー
メンバー | 値 | 説明
MaskAuto | 0 | 自動でマスク処理を行う
Mask000 | 1 | マスクパターン参照子 000
Mask001 | 2 | マスクパターン参照子 001
Mask010 | 3 | マスクパターン参照子 010
Mask011 | 4 | マスクパターン参照子 011
Mask100 | 5 | マスクパターン参照子 100
Mask101 | 6 | マスクパターン参照子 101
Mask110 | 7 | マスクパターン参照子 110
Mask111 | 8 | マスクパターン参照子 111
関連項目

参照

AdvanceSoftware.ExcelCreator.BarCode 名前空間


QRModel 列挙体

QR コードのモデルを指定します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum QRModel
Public Enumeration QRModel
メンバー
メンバー | 値 | 説明
Model1 | 1 | モデル 1
Model2 | 2 | モデル 2
関連項目

参照

AdvanceSoftware.ExcelCreator.BarCode 名前空間


QRVersion 列挙体

QR コードの型番を指定します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum QRVersion
Public Enumeration QRVersion
メンバー
メンバー | 値 | 説明
VersionAuto | 0 | 自動で型番を設定
Version1 | 1 | 1 型
Version2 | 2 | 2 型
Version3 | 3 | 3 型
Version4 | 4 | 4 型
Version5 | 5 | 5 型
Version6 | 6 | 6 型
Version7 | 7 | 7 型
Version8 | 8 | 8 型
Version9 | 9 | 9 型
Version10 | 10 | 10 型
Version11 | 11 | 11 型
Version12 | 12 | 12 型
Version13 | 13 | 13 型
Version14 | 14 | 14 型
Version15 | 15 | 15 型
Version16 | 16 | 16 型
Version17 | 17 | 17 型
Version18 | 18 | 18 型
Version19 | 19 | 19 型
Version20 | 20 | 20 型
Version21 | 21 | 21 型
Version22 | 22 | 22 型
Version23 | 23 | 23 型
Version24 | 24 | 24 型
Version25 | 25 | 25 型
Version26 | 26 | 26 型
Version27 | 27 | 27 型
Version28 | 28 | 28 型
Version29 | 29 | 29 型
Version30 | 30 | 30 型
Version31 | 31 | 31 型
Version32 | 32 | 32 型
Version33 | 33 | 33 型
Version34 | 34 | 34 型
Version35 | 35 | 35 型
Version36 | 36 | 36 型
Version37 | 37 | 37 型
Version38 | 38 | 38 型
Version39 | 39 | 39 型
Version40 | 40 | 40 型
関連項目

参照

AdvanceSoftware.ExcelCreator.BarCode 名前空間


Rotate 列挙体

バーコードの回転方向を指定します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum Rotate
Public Enumeration Rotate
メンバー
メンバー | 値 | 説明
Rotate0 | 0 | 0 度
Rotate90 | 1 | 90 度
Rotate180 | 2 | 180 度
Rotate270 | 3 | 270 度
関連項目

参照

AdvanceSoftware.ExcelCreator.BarCode 名前空間


Unit 列挙体

バーコードの生成単位を指定します。

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum Unit
Public Enumeration Unit
メンバー
メンバー | 値 | 説明
Pixel | 0 | ピクセル
Millimeter | 1 | ミリ
Inch | 2 | インチ
Point | 3 | ポイント
関連項目

参照

AdvanceSoftware.ExcelCreator.BarCode 名前空間


ValueEncoding 列挙体

バーコードデータのエンコード方式を指定します。(QRCode, PDF417)

名前空間: AdvanceSoftware.ExcelCreator.BarCode
アセンブリ: AdvanceSoftware.ExcelCreator.BarCode (in AdvanceSoftware.ExcelCreator.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ValueEncoding
Public Enumeration ValueEncoding
メンバー
メンバー | 値 | 説明
ShiftJIS | 0 | Shift-JIS
UTF8 | 1 | UTF-8
関連項目

参照

AdvanceSoftware.ExcelCreator.BarCode 名前空間