AS-Report 12.0 for .NET の概要

AS-Report 12.0 for .NET は、Excel で帳票をデザインする帳票ツールです。帳票ツール独自のデザイナ機能はなく、使い慣れた Excel がそのまま帳票デザイナとなり、フォント、属性、表示形式などの多彩なセル書式設定の他、オートシェイプや図の挿入などで美しい帳票デザインを作成することができます。エンドユーザーがちょっとした変更をしたい場合にも、デザイナが Excel であることが威力を発揮します。

システム動作環境

AS-Report 12.0 for .NET の動作環境を説明します。

体験版について

体験版について説明します。

ライセンスファイルを指定する

体験版から製品版へ移行するためのライセンスファイルの指定方法を説明します。

製品のインストールとアンインストール

製品のインストールとアンインストールをする方法を説明します。

アプリケーションの配布

アプリケーションを配布する方法を説明します。

ライセンス体系

AS-Report 12.0 for .NET のライセンス体系について説明します。

サポートサービス

AS-Report 12.0 for .NET のサポートサービスについて説明します。

サンプル

AS-Report 12.0 for .NET のサンプルプログラムの格納場所について説明します。

AS-Report 12.0 for .NET ヘルプ フィードバック

このヘルプについてのご提案や障害報告をお送りいただく場合は、弊社 Web サイトの「ユーザーサポートフォーム」よりご連絡ください。

  • ドキュメントに表記されている会社名、製品名は一般に各社の商標または登録商標です。
  • 製品の仕様は品質改良の為、予告なく変更することがあります。

© 2025 Advance Software Co., Ltd. All Rights Reserved.


システム動作環境

AS-Report 12.0 for .NET の動作環境は以下の通りです。

このトピックは、次のセクションを含みます。

  • システム動作環境
  • 参照
システム動作環境 (※1)
OS (※2) | Windows 10/11 Windows Server 2016/2019/2022/2025 Red Hat Enterprise Linux 8.x/9.x (※4) Ubuntu (※4)
開発ツール | Visual Studio 2019/2022
開発言語 | Visual C#、Visual Basic .NET
フレームワーク | .NET 6 / 8 .NET Framework 4.6.2 ～ 4.8.1
Excel バージョン (※3) | Excel 2003/2007/2010/2013/2016/2019/2021/2024
Web ブラウザ | Google Chrome、Microsoft Edge
Note メモ:

(※1) 日本語版環境でのみ動作保証を行っております。

(※2) 開発環境は Windows のみ動作保証を行っております。

(※3) xls, xlsx形式の Excel ファイルに対応しております。Excel 2007 以降の互換モードで作成された xls 形式には対応しておりません。

(※4) .NET プロジェクトのみ動作に対応
参照
AS-Report 12.0 for .NET の概要


体験版について

AS-Report 12.0 for .NET は、製品版と同様に全ての機能をお試しいただくことが可能な体験版をご用意しております。このトピックでは、体験版について説明します。

このトピックは、次のセクションを含みます。

  • 体験版のダウンロード先
  • 体験版の制限事項
  • 体験版を製品版に移行する
  • 参照
体験版のダウンロード先

AS-Report 12.0 for .NET 体験版は、弊社ホームページの「ダウンロードコーナー」または「nuget.org」から入手できます。

Note 注意:

製品 CD-ROM からインストールした場合でも、後述の製品版への移行手順を行わない限り体験版として動作します。
Note 注意:

依存関係にある外部ライブラリをインストールするため、 オフライン環境ではプロジェクトに対して製品をインストールできません。
製品をプロジェクトにインストールする際には以下の点を満たす環境であることをご確認ください。

  • オンライン環境であること
  • nuget.org が有効なパッケージソースとして登録されていること

体験版の制限事項

体験版では、以下の制限があります。

  • 作成した帳票のフッターに、体験版であることをあらわすメッセージ文字列が出力されます。
  • 作成した帳票の末尾に、体験版であることをあらわすメッセージ文字列が設定されたページが追加されます。
  • バーコードコンポーネントで作成したバーコードイメージの一部に「Advance Software Co., Ltd.」の文字列が出力されます。
  • 体験版として動作させる場合、DLL は実行環境での動作検証以外の目的で配布することはできません。
体験版を製品版に移行する

AS-Report 12.0 for .NET は、ライセンスファイルを読み込むことで製品版に移行することが可能です。nuget.org からのダウンロードおよび、購入した CD-ROM のインストーラーからインストールした場合でも、ライセンスファイルを読み込まない限りは体験版として動作します。体験版から製品版に移行する手順は以下の通りです。

  1. 「AS-Report 12」を購入します。「AS-Report 12」を購入した際、8 桁のシリアルナンバーが発行されます。

    Note メモ:

    「AS-Report 12」 は、AS-Report 12.0 for .NET を収録したパッケージの名称です。製品の購入に関するご質問は、「サポートサービス」をご参照ください。

  2. 手順 1 で発行されたシリアルナンバーを確認の上、弊社ホームページの「ライセンス手続き」から申請し、ライセンスファイルを入手します。

  3. CD-ROM から AS-Report 12.0 for .NET をインストールします。(※既に体験版をインストールしている場合は不要です。)

  4. AS-Report 12.0 for .NET を使用するプロジェクトのソースコード上でライセンスファイルを指定して実行すると、製品版として動作します。ソースコード上での指定方法は、「ライセンスファイルを指定する」をご参照ください。

参照
AS-Report 12.0 for .NET の概要
ライセンスファイルを指定する


ライセンスファイルを指定する

AS-Report 12.0 for .NET では、製品 CD-ROM からインストールした場合でも製品版として動作させるにはライセンスファイルを指定する必要があります。ここでは、ライセンスファイルの指定方法を説明します。

このトピックは、次のセクションを含みます。

  • ライセンスファイルの注意事項
  • ライセンスファイルをファイルパスで指定する
  • ライセンスファイルを埋め込みリソースで指定する
  • 参照
Note メモ:
  • ライセンスファイルの指定をする場合、「使用準備」の手順をもとにプロジェクトに AS-Report 12.0 for .NET を追加してください。
  • ライセンスファイルの申請は、弊社ホームページの「ライセンス手続き」から行うことができます。
ライセンスファイルの注意事項

ライセンスファイルには、以下の注意事項があります。

  • ライセンスファイルを指定しない場合、AS-Report 12.0 for .NET は体験版として動作します。
  • ライセンスファイルを、第三者に再使用権を許諾したり、譲渡、移転することはできません。
  • ライセンスファイルは、流出、紛失しないよう大切に保管してください。
  • ライセンスファイルは、編集すると正しく動作しません。編集せずにそのまま使用してください。
ライセンスファイルをファイルパスで指定する

次のコードは、SetLicense メソッドでライセンスファイル(Advancesoftware.ASReport12.License.xml)の物理ファイルパスを指定するサンプルコードです。
ライセンスファイルは、コンポーネントごとに設定する必要があります。

C#
VB
コピー
// C:\Data フォルダに配置したライセンスファイルの物理パスを指定します。
cellReport1.SetLicense(@"C:\Data\Advancesoftware.ASReport12.License.xml");
barCode1.SetLicense(@"C:\Data\Advancesoftware.ASReport12.License.xml");
// バーコードイメージを作成します。
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
AdvanceSoftware.ASReport.BarCode.BarCodeSizeD size =
    barCode1.GetScaleSize(AdvanceSoftware.ASReport.BarCode.Unit.Millimeter);
// バーコード付き帳票を作成します。
cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("B5").Drawing.AddImage(
    barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Png),
    size.Width,
    size.Height);
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
' C:\Data フォルダに配置したライセンスファイルの物理パスを指定します。
CellReport1.SetLicense("C:\Data\Advancesoftware.ASReport12.License.xml")
BarCode1.SetLicense("C:\Data\Advancesoftware.ASReport12.License.xml")
' バーコードイメージを作成します。
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
Dim Size As AdvanceSoftware.ASReport.BarCode.BarCodeSizeD =
    BarCode1.GetScaleSize(AdvanceSoftware.ASReport.BarCode.Unit.Millimeter)
' バーコード付き帳票を作成します。
CellReport1.Report.Start()
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("B5").Drawing.AddImage(
    BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Png),
    Size.Width,
    Size.Height)
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
Note メモ:

SetLicense メソッドはコンポーネントのインスタンスに対し 1 回のみ実行し、帳票作成処理ごとに毎回実行する必要はありません。
ライセンスファイルを埋め込みリソースで指定する

  1. プロジェクトを開き、[プロジェクト] メニューの [既存項目の追加] を選択します。

  2. [既存項目の追加] ダイアログより、ライセンスファイル(Advancesoftware.ASReport12.License.xml)を選択して、[追加] ボタンをクリックします。

  3. ソリューション エクスプローラから追加したライセンスファイルが、プロジェクトに登録されていることを確認します。

  4. 引き続き、ソリューション エクスプローラから追加したライセンスファイルを選択し、[プロパティ] ウィンドウの [ビルドアクション] を「埋め込まれたリソース」に変更します。

  5. 以上でプロジェクトへの登録は完了です。下記のサンプルコードにて対応してください。

  6. 次のコードは、プロジェクトに埋め込んだライセンスファイル(Advancesoftware.ASReport12.License.xml)を指定するサンプルコードです。
    ライセンスファイルは、コンポーネントごとに設定する必要があります。

    7. C#
    VB
    コピー
    System.Reflection.Assembly myAssembly = System.Reflection.Assembly.GetExecutingAssembly();
System.IO.Stream tempStreamLicense =
    myAssembly.GetManifestResourceStream("WinFormsApp1.Advancesoftware.ASReport12.License.xml");

// 埋め込まれたライセンスファイルを指定します。
cellReport1.SetLicense(tempStreamLicense);
tempStreamLicense.Position = 0;
barCode1.SetLicense(tempStreamLicense);
// バーコードイメージを作成します。
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
AdvanceSoftware.ASReport.BarCode.BarCodeSizeD size =
    barCode1.GetScaleSize(AdvanceSoftware.ASReport.BarCode.Unit.Millimeter);
// バーコード付き帳票を作成します。
cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("B5").Drawing.AddImage(
    barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Png),
    size.Width,
    size.Height);
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
    Dim myAssembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
Dim tempStreamLicense As System.IO.Stream =
    myAssembly.GetManifestResourceStream("WinFormsApp1.Advancesoftware.ASReport12.License.xml")

' 埋め込まれたライセンスファイルを指定します。
CellReport1.SetLicense(tempStreamLicense)
tempStreamLicense.Position = 0
BarCode1.SetLicense(tempStreamLicense)
' バーコードイメージを作成します。
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
Dim Size As AdvanceSoftware.ASReport.BarCode.BarCodeSizeD =
    BarCode1.GetScaleSize(AdvanceSoftware.ASReport.BarCode.Unit.Millimeter)
' バーコード付き帳票を作成します。
CellReport1.Report.Start()
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("B5").Drawing.AddImage(
    BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Png),
    Size.Width,
    Size.Height)
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
    Note メモ:

    SetLicense メソッドはコンポーネントのインスタンスに対し 1 回のみ実行し、帳票作成処理ごとに毎回実行する必要はありません。
参照
AS-Report 12.0 for .NET の概要
体験版について


製品のインストールとアンインストール

AS-Report 12.0 for .NET のインストーラーでインストールされるパッケージファイル一覧、および、アンインストール方法を説明します。

このトピックは、次のセクションを含みます。

  • 製品のパッケージファイル一覧
  • 製品のアンインストール
  • 参照
製品のパッケージファイル一覧

AS-Report 12.0 for .NET のインストールプログラムによってインストールされるパッケージファイルの一覧を以下に記載します。

パッケージファイル名

AdvanceSoftware.ASReport.BarCode.12.X.X.nupkg

AdvanceSoftware.ASReport.CellReport.12.X.X.nupkg

AdvanceSoftware.ASReport.Document.12.X.X.nupkg

AdvanceSoftware.ASReport.Pdf.Creator.12.X.X.nupkg

AdvanceSoftware.ASReport.Shared.12.X.X.nupkg

AdvanceSoftware.ASReport.Svg.Creator.12.X.X.nupkg

AdvanceSoftware.ASReport.View.12.X.X.nupkg

AdvanceSoftware.ASReport.Viewer.12.X.X.nupkg

AdvanceSoftware.ASReport.Wpf.Viewer.12.X.X.nupkg

AdvanceSoftware.ASReport.Xls.Core.12.X.X.nupkg

AdvanceSoftware.ASReport.Xlsx.Core.12.X.X.nupkg
Note メモ:

12.X.X の X 部分は、製品バージョンごとで異なります。
製品のアンインストール

AS-Report 12.0 for .NET をアンインストールする場合、下記のいずれかの手順で対応してください。

スタートメニューからアンインストールするには

  1. [スタート] のプログラム一覧から [AS-Report 12.0 for .NET] - [アンインストール] をクリックします。

  2. 画面に従い、アンインストールを実行します。

「アプリと機能」からアンインストールするには

  1. [スタート] - [設定] - [アプリ] をクリックします。

  2. [アプリと機能] 一覧の [AS-Report 12.0 for .NET] をクリックして [アンインストール] をクリックします。

  3. 画面に従い、アンインストールを実行します。

参照
AS-Report 12.0 for .NET の概要


アプリケーションの配布

AS-Report 12.0 for .NET を使用して作成したアプリケーションを配布する場合、再配布可能ファイルをアプリケーションと一緒に配布してください。このトピックでは、アプリケーションの配布について説明します。

このトピックは、次のセクションを含みます。

  • 再配布可能ファイル一覧
  • 再配布可能ファイルの配布
  • 再配布の条件
  • 参照
再配布可能ファイル一覧

AS-Report 12.0 for .NET の再配布可能ファイルは以下の通りです。

ファイル名 | 内容
AdvanceSoftware.ASReport.BarCode.dll | バーコードコンポーネント
AdvanceSoftware.ASReport.CellReport.dll | レポートコンポーネント (xls / xlsx 形式対応)
AdvanceSoftware.ASReport.Document.dll | ドキュメントクラス
AdvanceSoftware.ASReport.Pdf.Creator.dll | PDF 生成クラス
AdvanceSoftware.ASReport.Shared.dll | 共有クラス
AdvanceSoftware.ASReport.Svg.Creator.dll | SVG 出力クラス
AdvanceSoftware.ASReport.View.dll | 描画クラス
AdvanceSoftware.ASReport.Viewer.dll | Windows フォーム用ビューア
AdvanceSoftware.ASReport.Wpf.Viewer.dll | WPF 用ビューア
AdvanceSoftware.ASReport.Xls.Core.dll | Excel ファイル生成クラス (Xls 形式)
AdvanceSoftware.ASReport.Xlsx.Core.dll | Excel ファイル生成クラス (Xlsx 形式)
AdvanceSoftware.ASReport.Document.resources.dll | 英語対応リソースアセンブリ (レポートコンポーネント共通)
AdvanceSoftware.ASReport.BarCode.resources.dll | 英語対応リソースアセンブリ (バーコードコンポーネント共通)
AdvanceSoftware.ASReport.Viewer.resources.dll | 英語対応リソースアセンブリ (Windows フォーム用ビューア)
AdvanceSoftware.ASReport.Wpf.Viewer.resources.dll | 英語対応リソースアセンブリ (WPF 用ビューア)
ファイル名(スクリプト) | 内容
asreport.viewer.1.X.X.js | Web 用ビューア向けスクリプト (※1.X.X の X 部分はバージョン番号です)
gunzip.min.js | Web 用ビューア依存ファイル
jquery-3.7.1.min.js | jQuery3.7.1 ライブラリファイル
再配布可能ファイルの配布

実行環境に再配布可能ファイルを配布する場合、再配布可能ファイル (DLL) は、アプリケーションと同じフォルダに配置してください。

Note メモ:

AS-Report 12.0 for .NET 再配布可能ファイルは、アプリケーションに AS-Report 12.0 for .NET の NuGet パッケージをインストールすることで追加されます。再配布可能ファイルは、アプリケーションの発行時に自動でアプリケーションと同一フォルダにコピーされます。
再配布の条件

AS-Report 12.0 for .NET を再配布する際は、以下の条件をご確認ください。

著作権表示について

本製品は、アドバンスソフトウェア株式会社が有する著作権により保護されております。本製品を配布する際、パッケージ (店頭などに配置する形態の製品の梱包物のこと)、マニュアル、プログラム使用許諾契約書等、またはこれに類する物へアドバンスソフトウェアの著作権表示をしていただく必要があります。著作権表示は以下の通りに表示してください。

  1. AS-Report 12.0 for .NET
  2. Copyright (C) 2025 Advance Software Co., Ltd.

再配布先のサポート

再配布先のサポートについては、一切行いません。サポートは再配布元であるお客様において行ってください。なお、サーバーライセンスを取得した配布先の弊社製品に関するサポートは、サーバーライセンスの保守契約が必要になります。サーバーライセンスの保守契約の詳細やお申し込みについては、「サポートサービス」よりお問い合わせください。

参照
AS-Report 12.0 for .NET の概要
ライセンスファイルを指定する


ライセンス体系

AS-Report 12.0 for .NET を組み込んだアプリケーションの配布は、アプリケーションの種類によりライセンス体系が異なります。

このトピックは、次のセクションを含みます。

  • クライアントアプリケーション
  • サーバーアプリケーション
  • 参照
クライアントアプリケーション

クライアントアプリケーションの場合、ロイヤリティフリーで配布することができます。クライアントアプリケーションは、EXE やバッチファイル等、単独で動作し、外部アプリケーションなどから連動して動作することのないアプリケーションとします。

サーバーアプリケーション

AS-Report 12.0 for .NET を使用して作成したサーバーアプリケーションを運用する環境に対し、サーバーライセンスが必要です。

「サーバーアプリケーション」とは、以下の形態のアプリケーションとします。

  1. Web アプリケーションやサービスとして動作するプログラム。
  2. Web アプリケーションやサービスと連動して動作するプログラム。
  3. プログラムを用いて作成したファイル、データ等をネットワークを介してほかのコンピュータへ配信、提供する非対話型プログラム。
  4. リモートデスクトップなど、他のコンピュータの操作により、特定のコンピュータ上で動作するアプリケーション。

AS-Report 12.0 for .NET サーバーライセンス

必要条件 | AS-Report 12.0 for .NET を使用して作成したサーバーアプリケーション(関連する機能を含む)を運用するサーバー環境(OS)数分、必要なライセンスです。運用環境には、サーバー運用ライセンスが必要です。待機環境には、サーバー待機ライセンスが必要です。
価格 | サーバー運用ライセンス 1 ライセンスあたり / 250,000円(税込275,000円) サーバー待機ライセンス 1 ライセンスあたり / 75,000円(税込82,500円)
商品構成 | ライセンス数や契約内容を記載した契約書(ライセンス証書)のみになります。
保守 | 保守契約が必要となる場合、サーバー運用ライセンス保守契約(年間)の購入が必要になります。
お問い合わせ | サーバーライセンス、サーバー運用ライセンス保守契約のお申し込みやお問い合わせは、「サポートサービス」よりお問い合わせください。
参照
AS-Report 12.0 for .NET の概要


サポートサービス

AS-Report 12.0 for .NET の Readme および、ヘルプに記述されていない事項や動作に関するご不明な点などについては、サポートサービスをご利用ください。

このトピックは、次のセクションを含みます。

  • お問い合わせについて
  • ユーザー登録について
  • お問い合わせいただく前に
  • お問い合わせ窓口
  • 参照
お問い合わせについて

AS-Report 12.0 for .NET 以外の事柄やプログラミング技法などの一般的なご質問、または、動作保証環境外での使用によるご質問にはお答えいたしかねます。あらかじめご了承ください。

ユーザー登録について

サポートサービスをご利用いただくにあたり、製品のユーザー登録が必要になります。 登録されていない場合はサポートサービスを利用できませんので、お問合せいただく前に必ずユーザー登録を行ってください。 ユーザー登録は、製品に同梱されているユーザー登録カードに必要事項を記入してご郵送いただくか、弊社 Web サイトの「ユーザー登録ページ」からもご登録いただくことができます。

お問い合わせいただく前に

ユーザー情報

  1. AS-Report 12.0 for .NET のシリアルナンバー (製品パッケージ内のインストール情報カードに記載されています。)
  2. 会社名
  3. 部署名
  4. 担当者名
  5. 連絡先 (電話番号)
  6. FAX 番号
  7. E-Mail アドレス

お問い合わせ内容

  1. 製品名
  2. AS-Report 12.0 for .NET の詳細バージョン
  3. 使用マシンの OS
  4. OS のサービスパック
  5. フレームワークのバージョンとサービスパックのバージョン
  6. Visual Studio のバージョンとサービスパックのバージョン
  7. Excel のバージョンとサービスパックのバージョン
  8. アプリケーションを実行するブラウザ名とバージョン

問題となっている現象の内容

  1. 現象の詳細内容
  2. 現象発生までの経緯
  3. 現象発生箇所
  4. 現象を再現できる簡単なプロジェクト一式、もしくは、コーディングの一部
お問い合わせ窓口

サポートサービスは、電話、E-Mail、FAX で受け付けております。弊社 Web サイトにて「問い合わせフォーム」もご用意しておりますので、あわせてご確認ください。
月曜日～金曜日 (祝祭日、弊社特別休業日を除く) にご利用いただけます。営業日以外にいただいた E-Mail / FAX でのお問い合わせは、翌営業日に回答いたします。

製品の操作方法や仕様に関するお問い合わせ窓口

電話番号 | 0776-21-9172
FAX 番号 | 0776-21-9022
E-Mail | as-report@adv.co.jp
受付時間 | 10：00 ～ 12：00 / 13：30 ～ 17：00

製品の営業に関するお問い合わせ窓口

電話番号 | 0776-21-9008
FAX 番号 | 0776-21-9022
E-Mail | info@adv.co.jp
受付時間 | 9：00 ～ 12：00 / 13：00 ～ 18：00
参照
AS-Report 12.0 for .NET の概要


サンプル

AS-Report 12.0 for .NET のサンプルは以下の通りです。

このトピックは、次のセクションを含みます。

  • サンプル(.NET)
  • サンプル(.NET Framework)
  • 参照
サンプル(.NET)
サンプルの種類 | 開発言語 | サンプルの場所
ASP.NET Core MVC 機能紹介サンプル(AspNetCoreMvc) | Visual C# | <%install%>Samples\.NET\CS\AspNetCoreMvc
ASP.NET Core MVC 帳票プレビューサンプル(AspNetCoreMvcForm) | Visual C# | <%install%>Samples\.NET\CS\AspNetCoreMvcForm
Windows フォームサンプル(WinForms) | Visual C# | <%install%>Samples\.NET\CS\WinForms
 | Visual Basic .NET | <%install%>Samples\.NET\VB\WinForms
WPF サンプル(Wpf) | Visual C# | <%install%>Samples\.NET\CS\Wpf
 | Visual Basic .NET | <%install%>Samples\.NET\VB\Wpf
サンプル(.NET Framework)
サンプルの種類 | 開発言語 | サンプルの場所
ASP.NET MVC 機能紹介サンプル(AspNetMvc) | Visual C# | <%install%>Samples\.NET Framework\CS\AspNetMvc
 | Visual Basic .NET | <%install%>Samples\.NET Framework\VB\AspNetMvc
ASP.NET Web フォーム帳票プレビューサンプル(AspNetWebForm) | Visual C# | <%install%>Samples\.NET Framework\CS\AspNetWebForm
 | Visual Basic .NET | <%install%>Samples\.NET Framework\VB\AspNetWebForm
Windows フォームサンプル(WindowsForms) | Visual C# | <%install%>Samples\.NET Framework\CS\WindowsForms
 | Visual Basic .NET | <%install%>Samples\.NET Framework\VB\WindowsForms
WPF サンプル(Wpf) | Visual C# | <%install%>Samples\.NET Framework\CS\Wpf
 | Visual Basic .NET | <%install%>Samples\.NET Framework\VB\Wpf
Note メモ:

%install% は、AS-Report 12.0 for .NET のインストールフォルダ (C:\Program Files(x86)\AS-Report12\ など) を表します。
参照
AS-Report 12.0 for .NET の概要


AS-Report 12.0 for .NET に関する新機能

ここでは、AS-Report 12.0 for .NET の新機能について説明します。

PDF ファイルに電子署名、タイムスタンプを設定する

PDF ファイルに電子署名およびタイムスタンプを設定する方法について説明します。

PDF ファイルにグラフイメージを追加する

PDF ファイルにグラフイメージを追加する方法を説明します。


PDF ファイルに電子署名、タイムスタンプを設定する

AS-Report 12.0 for .NET では、PDF ファイル出力時に電子署名、タイムスタンプを付与することが可能です。このトピックでは、電子署名およびタイムスタンプを付与する方法を説明します。

このトピックは、次のセクションを含みます。

  • ローカル証明書(pfx)データで電子署名を付与する
  • 電子署名にタイムスタンプを付与する
  • 証明書ストアを利用して電子署名を付与する
  • 参照
Note メモ:

タイムスタンプ付与の際にはインターネットへの接続が必要となります。
ローカル証明書(pfx)データで電子署名を付与する

次のコードは、ローカル証明書(pfx)データで電子署名を付与するサンプルコードです。

C#
VB
コピー
// 連絡先に "info@adv.co.jp" を設定します。
cellReport1.Pdf.Signature.Contact = "info@adv.co.jp";
// 署名時刻に 2025/4/1 12:00:00 を設定します。
cellReport1.Pdf.Signature.Date = new DateTime(2025, 4, 1, 12, 0, 0);
// 場所に "日本" を設定します。
cellReport1.Pdf.Signature.Location = "日本";
// 理由に "稟議" を設定します。
cellReport1.Pdf.Signature.Reason = "稟議";
// ローカル証明書(pfx)データに "C:\Certificate.pfx" ファイルの内容を設定します。
cellReport1.Pdf.Signature.CertificateData = System.IO.File.ReadAllBytes(@"C:\Certificate.pfx");
// ローカル証明書(pfx)データのパスワード "pass" を設定します。
cellReport1.Pdf.Signature.CertificatePassword = "pass";

' 連絡先に "info@adv.co.jp" を設定します。
CellReport1.Pdf.Signature.Contact = "info@adv.co.jp"
' 署名時刻に 2025/4/1 12:00:00 を設定します。
CellReport1.Pdf.Signature.Contact = new DateTime(2025, 4, 1, 12, 0, 0)
' 場所に "日本" を設定します。
CellReport1.Pdf.Signature.Location = "日本"
' 理由に "稟議" を設定します。
CellReport1.Pdf.Signature.Reason = "稟議"
' ローカル証明書(pfx)データ "C:\Certificate.pfx" ファイルの内容を設定します。
CellReport1.Pdf.Signature.CertificateData = System.IO.File.ReadAllBytes("C:\Certificate.pfx")
' ローカル証明書(pfx)データのパスワード "pass" を設定します。
CellReport1.Pdf.Signature.CertificatePassword = "pass"
電子署名にタイムスタンプを付与する

このセクションでは、電子署名にタイムスタンプを付与する方法を説明します。

次のコードは、タイムスタンプサーバーの URL を設定し、設定された URL でタイムスタンプトークンが取得された場合、電子署名に埋め込みタイムスタンプを付加するサンプルコードです。

C#
VB
コピー
// タイムスタンプサーバーの URL "https://freetsa.org/tsr" を設定します。
cellReport1.Pdf.Signature.TimeStampUrl = "https://freetsa.org/tsr";
// タイムスタンプサーバーの ユーザー名 "user" を設定します。
cellReport1.Pdf.Signature.TimeStampUser = "user";
// タイムスタンプサーバーの パスワード "pass" を設定します。
cellReport1.Pdf.Signature.TimeStampPassword = "pass";
' 証明書(pfx)ファイルのパス "https://freetsa.org/tsr" を設定します。
CellReport1.Pdf.Signature.TimeStampUrl = "https://freetsa.org/tsr"
' タイムスタンプサーバーの ユーザー名 "user" を設定します。
CellReport1.Pdf.Signature.TimeStampUser = "user"
' タイムスタンプサーバーの パスワード "pass" を設定します。
CellReport1.Pdf.Signature.TimeStampPassword = "pass"
証明書ストアを利用して電子署名を付与する

このセクションでは、証明書ストアを利用して電子署名を付与する方法を説明します。

次のコードは、Windows の証明書ストアを利用して電子署名を付与するサンプルコードです。

C#
VB
コピー
using System.Security.Cryptography.X509Certificates;

// 証明書ストアの現在のユーザ（Windowsアカウント）の「個人」を開く
X509Store store = new X509Store(StoreName.My, StoreLocation.CurrentUser);
store.Open(OpenFlags.ReadOnly | OpenFlags.OpenExistingOnly);
// 証明書を有効期間内のものに絞り込む
// 最後のtrueは証明のパスが正式なもののみ取り出す指定。自己証明書の場合はfalseにする
X509Certificate2Collection col_all = store.Certificates;
X509Certificate2Collection col_date = col_all.Find(X509FindType.FindByTimeValid, DateTime.Now, true);
// 次に署名者の名前（CA証明書のCNなど）で絞り込む
X509Certificate2Collection col_issuer = col_date.Find(X509FindType.FindByIssuerName, User, true);
// 証明書を設定
cellReport1.Pdf.Signature.WindowsCertificate = col_issuer[0];
Imports System.Security.Cryptography.X509Certificates

' 証明書ストアの現在のユーザ（Windowsアカウント）の「個人」を開く
Dim store As New X509Store(StoreName.My, StoreLocation.CurrentUser)
store.Open(OpenFlags.ReadOnly Or OpenFlags.OpenExistingOnly)
' 証明書を有効期間内のものに絞り込む
' 最後のtrueは証明のパスが正式なもののみ取り出す指定。自己証明書の場合はfalseにする
Dim col_all As X509Certificate2Collection = store.Certificates
Dim col_date As X509Certificate2Collection = col_all.Find(X509FindType.FindByTimeValid, DateTime.Now, True)
' 次に署名者の名前（CA証明書のCNなど）で絞り込む
Dim col_issuer As X509Certificate2Collection = col_date.Find(X509FindType.FindByIssuerName, User, True)
' 証明書を設定
CellReport1.Pdf.Signature.WindowsCertificate = col_issuer(0)
参照
AS-Report 12.0 for .NET 新機能
オブジェクト機能一覧(PdfSignature クラス)


PDF ファイルにグラフイメージを追加する

AS-Report 12.0 for .NET では、テンプレートの Excel ファイルに登録されたグラフ情報を取得し、外部のグラフイメージ生成処理と組み合わせる事で、 出力する PDF ファイルにグラフイメージを追加することが可能です。 このトピックでは、PDF ファイルにグラフイメージを追加する手順を説明します。

なお、AS-Report 12.0 for .NET ではグラフイメージ生成の機能を実装しておらず、外部のサードパーティ製ライブラリ等を使用して独自に実装する必要があります。

このトピックは、次のセクションを含みます。

  • 出力 PDF ファイルに反映するグラフイメージを設定する
  • 参照
Note メモ:

グラフ情報の取得については、xlsx 形式ファイルのみ対応しています。
出力 PDF ファイルに反映するグラフイメージを設定する

  1. テンプレートになる Excel ファイル(Template.xlsx)を用意します。ここでは、下記の様なファイルを用意しました。

  2. 次のコードは、シート内に登録されたグラフの情報を取得し、出力 PDF ファイルに反映するグラフイメージを設定するサンプルコードです。

    C#
    VB
    コピー
    // グラフの数を取得
int chartCount = cellReport1.GetChartCount();
for (int i = 0; i < chartCount; i++)
{
    // グラフ情報を取得
    ChartData chartData = cellReport1.GetChartData(i, 330);

    // ChartData からの Image オブジェクト生成処理は独自に実装する必要があります。
    // ※以下の Image オブジェクト生成処理(GetChartImage)は弊社 Web サイトにて公開しているサンプルプログラムに付属しています。
    Image chartImage = chartCreator.GetChartImage(chartData);
    // PDF ファイルにのみ出力されるチャートを設定します。
    cellReport1.Pos(chartData.col, chartData.row).Canvas.AddChart(chartImage, chartData);
}

    ' グラフの数を取得
Dim chartCount = CellReport1.GetChartCount()
For i = 0 To chartCount - 1
    ' グラフ情報を取得
    Dim chartData = CellReport1.GetChartData(i, 330)

    ' ChartData からの Image オブジェクト生成処理は独自に実装する必要があります。
    ' ※以下の Image オブジェクト生成処理(GetChartImage)は弊社 Web サイトにて公開しているサンプルプログラムに付属しています。
    Dim chartImage As Image = ChartCreator.GetChartImage(chartData)
    ' PDF ファイルにのみ出力されるチャートを設定します。
    CellReport1.Pos(chartData.col, chartData.row).Canvas.AddChart(chartImage, chartData)
Next
    Note メモ:

    ※グラフ情報(ChartData)からグラフイメージ生成を行う処理(GetChartImage)は、サードパーティ製のライブラリを利用して独自に実装する必要があります。 使用方法についてはご利用のライブラリのマニュアル等をご参照ください。不明点については、「概要」の「サポートサービス」 から弊社サポート窓口までお問い合わせください。

  3. 帳票出力処理を行い、プレビューを確認します。

  4. 出力した PDF ファイルを開き、グラフイメージが反映されていることを確認します。

参照
AS-Report 12.0 for .NET 新機能
オブジェクト機能一覧(CellCanvas クラス)


使用準備

ここでは、AS-Report 12.0 for .NET の使用準備について説明します。

NuGet パッケージ ソースを追加する

NuGet パッケージ ソースを追加する方法を説明します。

Windows フォーム アプリ

Windows フォーム アプリにレポートコンポーネントとバーコードコンポーネントと Windows フォーム用ビューアを追加する方法を説明します。

WPF アプリ

WPF アプリにレポートコンポーネントとバーコードコンポーネントと WPF 用ビューアを追加する方法を説明します。

ASP.NET Core Web アプリ(MVC)

ASP.NET Core Web アプリ(MVC)にレポートコンポーネントとバーコードコンポーネントと Web 用ビューアを追加する方法を説明します。


NuGet パッケージ ソースを追加する

ここでは、NuGet パッケージソースを追加する方法を説明します。

Note メモ:

依存関係にある外部ライブラリをインストールするため、 オフライン環境ではプロジェクトに対して製品をインストールできません。
製品をプロジェクトにインストールする際には以下の点を満たす環境であることをご確認ください。

  • オンライン環境であること
  • nuget.org が有効なパッケージソースとして登録されていること

このトピックは、次のセクションを含みます。

  • NuGet パッケージ ソースを追加する
  • 参照
NuGet パッケージ ソースを追加する

  1. AS-Report 12.0 for .NET インストーラーを起動し、AS-Report 12.0 for .NET をインストールします。

  2. Visual Studio を起動し、[ツール] - [オプション] からオプションダイアログを開きます。

  3. [NuGet パッケージ マネージャー] - [パッケージ ソース] からパッケージソース一覧を表示し、「+」アイコンをクリックして以下の内容でローカルのパッケージソースを追加し、[OK] ボタンをクリックします。

    名前

    AS-Report 12

    ソース

    製品インストールフォルダのパス(C:\Program Files (x86)\AS-Report12\Bin など)
参照
使用準備


Windows フォーム アプリ

Windows フォーム アプリでは、帳票ドキュメントを作成するレポートコンポーネントと、バーコードイメージを作成するバーコードコンポーネント、帳票出力をする Windows フォーム用ビューアを追加することが可能です。ここでは、レポートコンポーネントとバーコードコンポーネントと Windows フォーム用ビューアを追加する方法を説明します。

レポートコンポーネントを追加する

レポートコンポーネントを追加する方法を説明します。

バーコードコンポーネントを追加する

バーコードコンポーネントを追加する方法を説明します。

Windows フォーム用ビューアを追加する

Windows フォーム用ビューアを追加する方法を説明します。


レポートコンポーネントを追加する

ここでは、レポートコンポーネントを追加する手順を説明します。

このトピックは、次のセクションを含みます。

  • インスタンスを手動で生成する
  • ツールボックスから追加する
  • 参照
Note メモ:

依存関係にある外部ライブラリをインストールするため、 オフライン環境ではプロジェクトに対して製品をインストールできません。
製品をプロジェクトにインストールする際には以下の点を満たす環境であることをご確認ください。

  • オンライン環境であること
  • nuget.org が有効なパッケージソースとして登録されていること
インスタンスを手動で生成する

このセクションでは、コード上でインスタンスを生成する方法を説明します。

  1. Visual Studio を起動し、[ファイル] - [新しいプロジェクトの作成] から .NET の Windows フォーム アプリのプロジェクトを作成します。

  2. ソリューションエクスプローラーからソリューション名を右クリックし、[ソリューションの NuGet パッケージの管理] をクリックして NuGet パッケージの管理画面を開きます。

  3. [パッケージ ソース] に 「nuget.org」、または、「NuGet パッケージ ソースを追加する」 で追加した 「AS-Report 12」 を設定後、[参照] タブ内に表示される 「AdvanceSoftware.ASReport.CellReport」 のパッケージファイルを選択し、[インストール] ボタンをクリックしてパッケージファイルをインストールします。

  4. 次のコードを追加します。

    C#
    VB
    コピー
    private AdvanceSoftware.ASReport.CellReport cellReport1 = new AdvanceSoftware.ASReport.CellReport();

    Private WithEvents CellReport1 As New AdvanceSoftware.ASReport.CellReport

  5. エラーイベントは次のように追加します。

    C#
    VB
    コピー
    private void Form1_Load(object sender, EventArgs e)
{
    cellReport1.Error +=
        new AdvanceSoftware.ASReport.ReportErrorEventHandler(
        this.cellReport1_Error);
}

private void cellReport1_Error(object sender,
    AdvanceSoftware.ASReport.ReportErrorEventArgs e)
{
    // ここにエラー発生時の処理を追加します。
}

    Private Sub CellReport1_Error(sender As Object, _
    e As AdvanceSoftware.ASReport.ReportErrorEventArgs) _
    Handles CellReport1.Error
    ' ここにエラー発生時の処理を追加します。
End Sub
    Note メモ:

    AS-Report 12.0 for .NET では、「ErrorNo プロパティ」、「ErrorMessage プロパティ」 でエラーの詳細を確認することができます。
ツールボックスから追加する

このセクションでは、コンポーネントをツールボックスからフォームに配置する方法を説明します。

  1. Visual Studio を起動し、[ファイル] - [新しいプロジェクトの作成] から .NET の Windows フォーム アプリのプロジェクトを作成します。

  2. ソリューションエクスプローラーからソリューション名を右クリックし、[ソリューションの NuGet パッケージの管理] をクリックして NuGet パッケージの管理画面を開きます。

  3. [パッケージ ソース] に nuget.org、または、「NuGet パッケージ ソースを追加する」で追加した AS-Report 12 を設定後、[参照] タブ内に表示される「AdvanceSoftware.ASReport.CellReport」のパッケージファイルを選択し、[インストール] ボタンをクリックしてパッケージファイルをインストールします。

  4. [表示] メニューの [ツールボックス] をクリックしてツールボックスを表示します。

  5. [CellReport(AdvanceSoftware.ASReport)] を選択し、フォームにドラッグ アンド ドロップして配置します。

エラーイベントを実装するには

  1. フォームに貼り付けたコンポーネントを選択します。

  2. [プロパティ] ウィンドウの [イベント( [image])] ボタンをクリックします。

  3. イベント一覧から [Error] を選択し、Enter キーを押下します。

  4. Error イベントが追加されます。

    Note メモ:

    AS-Report 12.0 for .NET では、「ErrorNo プロパティ」、「ErrorMessage プロパティ」 でエラーの詳細を確認することができます。
参照
NuGet パッケージ ソースを追加する
使用準備


バーコードコンポーネントを追加する

ここでは、バーコードコンポーネントを追加する手順を説明します。

このトピックは、次のセクションを含みます。

  • インスタンスを手動で生成する
  • ツールボックスから追加する
  • 参照
Note メモ:

依存関係にある外部ライブラリをインストールするため、 オフライン環境ではプロジェクトに対して製品をインストールできません。
製品をプロジェクトにインストールする際には以下の点を満たす環境であることをご確認ください。

  • オンライン環境であること
  • nuget.org が有効なパッケージソースとして登録されていること
インスタンスを手動で生成する

このセクションでは、コード上でインスタンスを生成する方法を説明します。

  1. Visual Studio を起動し、[ファイル] - [新しいプロジェクトの作成] から .NET の Windows フォーム アプリのプロジェクトを作成します。

  2. ソリューションエクスプローラーからソリューション名を右クリックし、[ソリューションの NuGet パッケージの管理] をクリックして NuGet パッケージの管理画面を開きます。

  3. [パッケージ ソース] に 「nuget.org」、または、「NuGet パッケージ ソースを追加する」 で追加した 「AS-Report 12」 を設定後、[参照] タブ内に表示される 「AdvanceSoftware.ASReport.BarCode」 のパッケージファイルを選択し、[インストール] ボタンをクリックしてパッケージファイルをインストールします。

  4. 次のコードを追加します。

    C#
    VB
    コピー
    private AdvanceSoftware.ASReport.BarCode.BarCode barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
    Private WithEvents BarCode1 As New AdvanceSoftware.ASReport.BarCode.BarCode

  5. エラーイベントは次のように追加します。

    C#
    VB
    コピー
    private void Form1_Load(object sender, EventArgs e)
{
    barCode1.Error +=
        new AdvanceSoftware.ASReport.BarCode.BarCodeErrorEventHandler(
        this.barCode1_Error);
}

private void barCode1_Error(object sender,
AdvanceSoftware.ASReport.BarCode.BarCodeErrorEventArgs e)
{
    // ここにエラー発生時の処理を追加します。
}
    Private Sub BarCode1_Error(sender As Object, _
    e As AdvanceSoftware.ASReport.BarCode.BarCodeErrorEventArgs) _
    Handles BarCode1.Error
    ' ここにエラー発生時の処理を追加します。
End Sub
    Note メモ:

    AS-Report 12.0 for .NET では、「ErrorNo プロパティ」、「ErrorMessage プロパティ」 でエラーの詳細を確認することができます。
ツールボックスから追加する

このセクションでは、コンポーネントをツールボックスからフォームに配置する方法を説明します。

  1. Visual Studio を起動し、[ファイル] - [新しいプロジェクトの作成] から .NET の Windows フォーム アプリのプロジェクトを作成します。

  2. ソリューションエクスプローラーからソリューション名を右クリックし、[ソリューションの NuGet パッケージの管理] をクリックして NuGet パッケージの管理画面を開きます。

  3. [パッケージ ソース] に「nuget.org」、または、「AS-Report12」 を設定後、[参照] タブ内に表示される「AdvanceSoftware.ASReport.BarCode」のパッケージファイルを選択し、[インストール] ボタンをクリックしてパッケージファイルをインストールします。

  4. [表示] メニューの [ツールボックス] をクリックしてツールボックスを表示します。

  5. [BarCode(AdvanceSoftware.ASReport)] を選択し、フォームにドラッグ アンド ドロップして配置します。

エラーイベントを実装するには

  1. フォームに貼り付けたコンポーネントを選択します。

  2. [プロパティ] ウィンドウの [イベント( [image])] ボタンをクリックします。

  3. イベント一覧から [Error] を選択し、Enter キーを押下します。

  4. Error イベントが追加されます。

    Note メモ:

    AS-Report 12.0 for .NET では、「ErrorNo プロパティ」、「ErrorMessage プロパティ」 でエラーの詳細を確認することができます。
参照
NuGet パッケージ ソースを追加する
使用準備


Windows フォーム用ビューアを追加する

ここでは、Windows フォーム用ビューアを追加する手順を説明します。

このトピックは、次のセクションを含みます。

  • ツールボックスから追加する
  • 参照
Note メモ:

依存関係にある外部ライブラリをインストールするため、 オフライン環境ではプロジェクトに対して製品をインストールできません。
製品をプロジェクトにインストールする際には以下の点を満たす環境であることをご確認ください。

  • オンライン環境であること
  • nuget.org が有効なパッケージソースとして登録されていること
ツールボックスから追加する

このセクションでは、Windows フォーム用ビューアをツールボックスからフォームに配置する方法を説明します。

  1. Visual Studio を起動し、[ファイル] - [新しいプロジェクトの作成] から .NET の Windows フォーム アプリのプロジェクトを作成します。

  2. ソリューションエクスプローラーからソリューション名を右クリックし、[ソリューションの NuGet パッケージの管理] をクリックして NuGet パッケージの管理画面を開きます。

  3. [パッケージ ソース] に 「nuget.org」、または、「NuGet パッケージ ソースを追加する」 で追加した 「AS-Report 12」 を設定後、[参照] タブ内に表示される 「AdvanceSoftware.ASReport.Viewer」 のパッケージファイルを選択し、[インストール] ボタンをクリックしてパッケージファイルをインストールします。

  4. [表示] メニューの [ツールボックス] をクリックしてツールボックスを表示します。

  5. [ViewerControl(AdvanceSoftware.ASReport)] を選択し、フォームにドラッグ アンド ドロップして配置します。

    Note メモ:

    Windows フォーム用ビューアの各イベントの実装方法は、「イベントを実装する」-「Windows フォーム用ビューア」を参照してください。
参照
NuGet パッケージ ソースを追加する
使用準備


WPF アプリ

WPF アプリでは、帳票ドキュメントを作成するレポートコンポーネントと、バーコードイメージを作成するバーコードコンポーネント、帳票の出力をする WPF 用ビューアを追加することが可能です。ここでは、レポートコンポーネントとバーコードコンポーネントと WPF 用ビューアを追加する方法を説明します。

レポートコンポーネントを追加する

レポートコンポーネントを追加する方法を説明します。

バーコードコンポーネントを追加する

バーコードコンポーネントを追加する方法を説明します。

WPF 用ビューアを追加する

WPF 用ビューアを追加する方法を説明します。


レポートコンポーネントを追加する

ここでは、レポートコンポーネントを追加する手順を説明します。

このトピックは、次のセクションを含みます。

  • インスタンスを手動で生成する
  • 参照
Note メモ:

依存関係にある外部ライブラリをインストールするため、 オフライン環境ではプロジェクトに対して製品をインストールできません。
製品をプロジェクトにインストールする際には以下の点を満たす環境であることをご確認ください。

  • オンライン環境であること
  • nuget.org が有効なパッケージソースとして登録されていること
インスタンスを手動で生成する

このセクションでは、コード上でインスタンスを生成する方法を説明します。

  1. Visual Studio を起動し、[ファイル] - [新しいプロジェクトの作成] から .NET の WPF アプリのプロジェクトを作成します。

  2. ソリューションエクスプローラーからソリューション名を右クリックし、[ソリューションの NuGet パッケージの管理] をクリックして NuGet パッケージの管理画面を開きます。

  3. [パッケージ ソース] に 「nuget.org」、または、「NuGet パッケージ ソースを追加する」 で追加した 「AS-Report 12」 を設定後、[参照] タブ内に表示される 「AdvanceSoftware.ASReport.CellReport」 のパッケージファイルを選択し、[インストール] ボタンをクリックしてパッケージファイルをインストールします。

  4. 次のコードを追加します。

    C#
    VB
    コピー
    private AdvanceSoftware.ASReport.CellReport cellReport1 = new AdvanceSoftware.ASReport.CellReport();
    Private WithEvents CellReport1 As New AdvanceSoftware.ASReport.CellReport

  5. エラーイベントは次のように追加します。

    C#
    VB
    コピー
    private void Window_Loaded(object sender, RoutedEventArgs e)
{
    cellReport1.Error +=
        new AdvanceSoftware.ASReport.ReportErrorEventHandler(
        this.cellReport1_Error);
}

private void cellReport1_Error(object sender,
    AdvanceSoftware.ASReport.ReportErrorEventArgs e)
{
    // ここにエラー発生時の処理を追加します。
}
    Private Sub CellReport1_Error(sender As Object, _
    e As AdvanceSoftware.ASReport.ReportErrorEventArgs) _
    Handles CellReport1.Error
    ' ここにエラー発生時の処理を追加します。
End Sub
    Note メモ:

    AS-Report 12.0 for .NET では、「ErrorNo プロパティ」、「ErrorMessage プロパティ」 でエラーの詳細を確認することができます。
参照
NuGet パッケージ ソースを追加する
使用準備


バーコードコンポーネントを追加する

ここでは、バーコードコンポーネントを追加する手順を説明します。

このトピックは、次のセクションを含みます。

  • インスタンスを手動で生成する
  • 参照
Note メモ:

依存関係にある外部ライブラリをインストールするため、 オフライン環境ではプロジェクトに対して製品をインストールできません。
製品をプロジェクトにインストールする際には以下の点を満たす環境であることをご確認ください。

  • オンライン環境であること
  • nuget.org が有効なパッケージソースとして登録されていること
インスタンスを手動で生成する

このセクションでは、コード上でインスタンスを生成する方法を説明します。

  1. Visual Studio を起動し、[ファイル] - [新しいプロジェクトの作成] から .NET の WPF アプリのプロジェクトを作成します。

  2. ソリューションエクスプローラーからソリューション名を右クリックし、[ソリューションの NuGet パッケージの管理] をクリックして NuGet パッケージの管理画面を開きます。

  3. [パッケージ ソース] に 「nuget.org」、または、「NuGet パッケージ ソースを追加する」 で追加した 「AS-Report 12」 を設定後、[参照] タブ内に表示される 「AdvanceSoftware.ASReport.BarCode」 のパッケージファイルを選択し、[インストール] ボタンをクリックしてパッケージファイルをインストールします。

  4. 次のコードを追加します。

    C#
    VB
    コピー
    private AdvanceSoftware.ASReport.BarCode.BarCode barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
    Private WithEvents BarCode1 As New AdvanceSoftware.ASReport.BarCode.BarCode

  5. エラーイベントは次のように追加します。

    C#
    VB
    コピー
    private void Window_Loaded(object sender, RoutedEventArgs e)
{
    barCode1.Error +=
        new AdvanceSoftware.ASReport.BarCode.BarCodeErrorEventHandler(
        this.barCode1_Error);
}

private void barCode1_Error(object sender,
AdvanceSoftware.ASReport.BarCode.BarCodeErrorEventArgs e)
{
    // ここにエラー発生時の処理を追加します。
}
    Private Sub BarCode1_Error(sender As Object, _
    e As AdvanceSoftware.ASReport.BarCode.BarCodeErrorEventArgs) _
    Handles BarCode1.Error
    ' ここにエラー発生時の処理を追加します。
End Sub
    Note メモ:

    AS-Report 12.0 for .NET では、「ErrorNo プロパティ」、「ErrorMessage プロパティ」 でエラーの詳細を確認することができます。
参照
NuGet パッケージ ソースを追加する
使用準備


WPF 用ビューアを追加する

ここでは、WPF 用ビューアを追加する手順を説明します。

このトピックは、次のセクションを含みます。

  • XAML に手動で追加する
  • 参照
Note メモ:

依存関係にある外部ライブラリをインストールするため、 オフライン環境ではプロジェクトに対して製品をインストールできません。
製品をプロジェクトにインストールする際には以下の点を満たす環境であることをご確認ください。

  • オンライン環境であること
  • nuget.org が有効なパッケージソースとして登録されていること
XAML に手動で追加する

このセクションでは、WPF 用ビューアを XAML に手動で追加する方法を説明します。

  1. Visual Studio を起動し、[ファイル] - [新しいプロジェクトの作成] から .NET の WPF アプリのプロジェクトを作成します。

  2. ソリューションエクスプローラーからソリューション名を右クリックし、[ソリューションの NuGet パッケージの管理] をクリックして NuGet パッケージの管理画面を開きます。

  3. [パッケージ ソース] に 「nuget.org」、または、「NuGet パッケージ ソースを追加する」 で追加した 「AS-Report 12」 を設定後、[参照] タブ内に表示される 「AdvanceSoftware.ASReport.Wpf.Viewer」 のパッケージファイルを選択し、[インストール] ボタンをクリックしてパッケージファイルをインストールします。

  4. ウィンドウの XAML ビューを表示します。

  5. Window タグ内に以下のコードを追加します。

    XAML
    コピー
    xmlns:Wpf="clr-namespace:AdvanceSoftware.ASReport.Wpf;assembly=AdvanceSoftware.ASReport.Wpf.Viewer"

  6. Grid タグの開始と終了の間に WPF 用ビューアを追加します。

    XAML
    コピー
    <Wpf:ViewerControl HorizontalAlignment="Left" Margin="10,10,0,0" VerticalAlignment="Top"/>

  7. 1 度ビルドを行います。

  8. WPF 用ビューアが表示されます。任意のサイズに調整します。

  9. [プロパティ] ウィンドウの [名前] に「ViewerControl1」と入力します。

Note メモ:

WPF 用ビューアの各イベントの実装方法は、「イベントを実装する」-「WPF 用ビューア」を参照してください。
参照
NuGet パッケージ ソースを追加する
使用準備


ASP.NET Core Web アプリ(MVC)

ASP.NET Core Web アプリ(MVC)では、帳票ドキュメントを作成するレポートコンポーネントと、Web ブラウザ上で帳票を出力する Web 用ビューア、バーコードイメージを作成するバーコードコンポーネントを追加することが可能です。ここでは、レポートコンポーネントと Web 用ビューアとバーコードコンポーネントを追加する方法を説明します。

レポートコンポーネントを追加する

レポートコンポーネントを追加する方法を説明します。

バーコードコンポーネントを追加する

バーコードコンポーネントを追加する方法を説明します。

Web 用ビューアを追加する

Web 用ビューアを追加する方法を説明します。


レポートコンポーネントを追加する

ここでは、レポートコンポーネントを追加する手順を説明します。

このトピックは、次のセクションを含みます。全てのセクションを上から順に行うことで、レポートコンポーネントで Excel 保存をする動作まで確認できます。

  • AS-Report の機能を追加するコントローラーを作成する
  • レポートコンポーネントを追加する
  • 参照
Note メモ:

依存関係にある外部ライブラリをインストールするため、 オフライン環境ではプロジェクトに対して製品をインストールできません。
製品をプロジェクトにインストールする際には以下の点を満たす環境であることをご確認ください。

  • オンライン環境であること
  • nuget.org が有効なパッケージソースとして登録されていること
AS-Report の機能を追加するコントローラーを作成する

このセクションでは、新規プロジェクトに AS-Report 12.0 for .NET の機能を追加するためのコントローラーを作成する方法を説明します。

  1. Visual Studio を起動し、[ファイル] - [新しいプロジェクトの作成] から .NET の ASP.NET Core Web アプリ(MVC)のプロジェクトを作成します。

  2. [表示] メニューの [ソリューション エクスプローラ] をクリックしてソリューションエクスプローラを表示します。

  3. [ソリューション エクスプローラ] - [Controllers] を右クリックし、[追加] から [コントローラー] を選択します。

  4. [MVC コントローラー - 空] を選択し追加します。ここではコントローラー名を "InvoiceController" とします。

レポートコンポーネントを追加する

このセクションでは、レポートコンポーネントを追加する方法を説明します。

  1. ソリューションエクスプローラーからソリューション名を右クリックし、[ソリューションの NuGet パッケージの管理] をクリックして NuGet パッケージの管理画面を開きます。

  2. [パッケージ ソース] に 「nuget.org」、または、「NuGet パッケージ ソースを追加する」 で追加した 「AS-Report 12」 を設定後、[参照] タブ内に表示される 「AdvanceSoftware.ASReport.CellReport」 のパッケージファイルを選択し、[インストール] ボタンをクリックしてパッケージファイルをインストールします。

  3. 「AS-Report の機能を追加するコントローラを作成する 」で作成した "InvoiceController.cs" の Index メソッドを次のコードに置き換え、エラーイベントを追加します。

    C#
    コピー
    public IActionResult Index()
{
    // インスタンスを生成
    AdvanceSoftware.ASReport.CellReport cellReport1 = new AdvanceSoftware.ASReport.CellReport();
    cellReport1.Error += new AdvanceSoftware.ASReport.ReportErrorEventHandler(cellReport1_Error);
    // 帳票作成処理
    cellReport1.Report.Start();
    cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
    cellReport1.Page.Start("Sheet1", "1");
    cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
    cellReport1.Page.End();
    cellReport1.Report.End();
    // Excel ファイルを excelStream に出力
    System.IO.MemoryStream excelStream = new System.IO.MemoryStream();
    cellReport1.Report.SaveAs(excelStream);

    return File(excelStream.ToArray(), "application/vnd.openxmlformats-officedocument.spreadsheetml.sheet", "out.xlsx");
}
void cellReport1_Error(object sender, AdvanceSoftware.ASReport.ReportErrorEventArgs e)
{
    // ここにエラー発生時の処理を追加します。
}

  4. アプリケーションを実行し、URL(https://localhost:XXXX/Invoice/Index)を設定すると Excel 保存します。

参照
NuGet パッケージ ソースを追加する
使用準備


バーコードコンポーネントを追加する

ここでは、バーコードコンポーネントを追加する手順を説明します。

このトピックは、次のセクションを含みます。全てのセクションを上から順に行うことで、バーコードコンポーネントでバーコードイメージを生成する動作まで確認できます。

  • AS-Report の機能を追加するコントローラーを作成する
  • バーコードコンポーネントを追加する
  • 参照
Note メモ:

依存関係にある外部ライブラリをインストールするため、 オフライン環境ではプロジェクトに対して製品をインストールできません。
製品をプロジェクトにインストールする際には以下の点を満たす環境であることをご確認ください。

  • オンライン環境であること
  • nuget.org が有効なパッケージソースとして登録されていること
AS-Report の機能を追加するコントローラーを作成する

このセクションでは、新規プロジェクトに AS-Report 12.0 for .NET の機能を追加するためのコントローラーを作成する方法を説明します。

  1. Visual Studio を起動し、[ファイル] - [新しいプロジェクトの作成] から .NET の ASP.NET Core Web アプリ(MVC)のプロジェクトを作成します。

  2. [表示] メニューの [ソリューション エクスプローラ] をクリックしてソリューションエクスプローラを表示します。

  3. [ソリューション エクスプローラ] - [Controllers] を右クリックし、[追加] から [コントローラー] を選択します。

  4. [MVC コントローラー - 空] を選択し追加します。ここではコントローラー名を "InvoiceController" とします。

バーコードコンポーネントを追加する

このセクションでは、バーコードコンポーネントを追加する方法を説明します。

  1. ソリューションエクスプローラーからソリューション名を右クリックし、[ソリューションの NuGet パッケージの管理] をクリックして NuGet パッケージの管理画面を開きます。

  2. [パッケージ ソース] に 「nuget.org」、または、「NuGet パッケージ ソースを追加する」 で追加した 「AS-Report 12」 を設定後、[参照] タブ内に表示される 「AdvanceSoftware.ASReport.BarCode」 のパッケージファイルを選択し、[インストール] ボタンをクリックしてパッケージファイルをインストールします。

  3. 「AS-Report の機能を追加するコントローラーを作成する 」で作成した "InvoiceController.cs" の Index メソッドを次のコードに置き換え、エラーイベントを追加します。

    C#
    コピー
    public IActionResult Index()
{
    // インスタンスを生成
    AdvanceSoftware.ASReport.BarCode.BarCode barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
    barCode1.Error += new AdvanceSoftware.ASReport.BarCode.BarCodeErrorEventHandler(barCode1_Error);

    barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
    barCode1.Value = "1234567890123";
    // バーコードイメージ (拡張メタファイル) を生成します。
    System.Drawing.Image imgBarCode = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf);

    return Content("バーコードイメージを生成");
}
void barCode1_Error(object sender, AdvanceSoftware.ASReport.BarCode.BarCodeErrorEventArgs e)
{
    // ここにエラー発生時の処理を追加します。
}

  4. アプリケーションを実行し、URL(https://localhost:XXXXX/Invoice/Index)を設定するとバーコードイメージを生成します。

参照
NuGet パッケージ ソースを追加する
使用準備


Web 用ビューアを追加する

ここでは、Web 用ビューアを追加する手順を説明します。

このトピックは、次のセクションを含みます。全てのセクションを上から順に行うことで、Web 用ビューアにプレビューする動作まで確認できます。

  • AS-Report の機能を追加するコントローラーとビューを作成する
  • レポートコンポーネントを追加する
  • Web 用ビューアを追加する
  • 参照
Note メモ:

依存関係にある外部ライブラリをインストールするため、 オフライン環境ではプロジェクトに対して製品をインストールできません。
製品をプロジェクトにインストールする際には以下の点を満たす環境であることをご確認ください。

  • オンライン環境であること
  • nuget.org が有効なパッケージソースとして登録されていること
AS-Report の機能を追加するコントローラーとビューを作成する

このセクションでは、新規プロジェクトに AS-Report 12.0 for .NET の機能を追加するためのコントローラーとビューを作成する方法を説明します。

  1. Visual Studio を起動し、[ファイル] - [新しいプロジェクトの作成] から .NET の ASP.NET Core Web アプリ(MVC)のプロジェクトを作成します。

  2. [表示] メニューの [ソリューション エクスプローラ] をクリックしてソリューションエクスプローラを表示します。

  3. [ソリューション エクスプローラ] - [Controllers] を右クリックし、[追加] から [コントローラー] を選択します。

  4. [MVC コントローラー - 空] を選択し追加します。ここではコントローラー名を "InvoiceController" とします。

  5. [ソリューション エクスプローラ] - [Views] を右クリックし、[追加] から [新しいフォルダ] を選択し、フォルダ名を "Invoice"とします。

  6. [ソリューション エクスプローラ] - [Views] - [Invoice] を右クリックし、[追加] から [ビュー] を選択し、[Razor ビュー] を追加します。

  7. [ビュー名] を "index" として追加します。

レポートコンポーネントを追加する

このセクションでは、レポートコンポーネントを追加する方法を説明します。

Note メモ:

Web 用ビューアの機能を使用する場合は、レポートコンポーネントを追加する必要があります。

  1. ソリューションエクスプローラーからソリューション名を右クリックし、[ソリューションの NuGet パッケージの管理] をクリックして NuGet パッケージの管理画面を開きます。

  2. [パッケージ ソース] に 「nuget.org」、または、「NuGet パッケージ ソースを追加する」 で追加した 「AS-Report 12」 を設定後、[参照] タブ内に表示される 「AdvanceSoftware.ASReport.CellReport」 のパッケージファイルを選択し、[インストール] ボタンをクリックしてパッケージファイルをインストールします。

  3. 「AS-Report の機能を追加するコントローラーとビューを作成する 」で作成した "InvoiceController.cs" の Index メソッドを次のコードに置き換え、エラーイベントを追加します。

    C#
    コピー
    public IActionResult Index()
{
    // インスタンスを生成
    AdvanceSoftware.ASReport.CellReport cellReport1 = new AdvanceSoftware.ASReport.CellReport();
    cellReport1.Error += new AdvanceSoftware.ASReport.ReportErrorEventHandler(cellReport1_Error);
    // 帳票作成処理
    cellReport1.Report.Start();
    cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
    cellReport1.Page.Start("Sheet1", "1");
    cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
    cellReport1.Page.End();
    cellReport1.Report.End();
    // SVGZ 形式で帳票ドキュメントを取得します。
    string reportDocument = cellReport1.Report.GetSvgzReport(
        AdvanceSoftware.ASReport.SvgSaveType.IncludeExcelPdf);
    ViewData["document"] = reportDocument;

    return View();
}
void cellReport1_Error(object sender, AdvanceSoftware.ASReport.ReportErrorEventArgs e)
{
    // ここにエラー発生時の処理を追加します。
}
Web 用ビューアを追加する

このセクションでは、Web 用ビューアを追加する方法を説明します。

  1. AS-Report 12.0 for .NET のインストールフォルダ内 [Bin] - [v12.X.X] - [Scripts] フォルダより下記外部ファイルをコピーし、プロジェクトの [wwwroot] - [js] フォルダに格納します。

    JavaScript 外部ファイル名
    asreport.viewer.1.X.X.js
    gunzip.min.js
    jquery-3.7.1.min.js
    Note メモ:

    1.X.X の X 部分はバージョン番号です

  2. 「AS-Report の機能を追加するコントローラーとビューを作成する 」で作成した "Index.cshtml" のコードを開き、Web 用ビューアのインクルードを追加します。

    HTML
    コピー
    <!-- "＊" には使用するスクリプトファイルのバージョンを入力 -->
<script type="text/javascript" src="/js/asreport.viewer.1.＊.＊.js"></script>
<script type="text/javascript" src="/js/gunzip.min.js"></script>
<script type="text/javascript" src="/js/jquery-3.7.1.min.js"></script>

  3. 引き続き、ビューア表示用の HTML コードとスクリプトを追加します。

    HTML
    コピー
    <!--帳票ドキュメント格納用のDIV要素(id="documentcontainer")を用意。ViewData で帳票ドキュメントを挿入-->
<div id="documentcontainer" style="display:none;">
    @Html.Raw(ViewData["document"])
</div>

<!--ビューア配置用のDIV要素(id="viewercontainer")を用意。width、height でサイズ指定-->
<div id="viewercontainer" style="width:100%;height:650px;" >
</div>

<!--ビューアの表示とプレビュー実行-->
<script type="text/javascript">
$(function() {
    // ビューアを id名[viewercontainer] の DIV 要素に表示
    viewer = new CellReport.Viewer('viewercontainer');
    // id名[documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込み、プレビューを実施
    viewer.report('documentcontainer');
});
</script>

  4. アプリケーションを実行し、URL(https://localhost:XXXXX/Invoice/Index)を設定するとプレビューします。

参照
NuGet パッケージ ソースを追加する
使用準備


帳票作成機能の選び方

AS-Report 12.0 for .NET では、多様な帳票を作成するための機能を用意しています。このトピックではそれぞれの帳票作成機能の特徴を説明します。

機能の種類 | 機能の特徴 | 機能紹介ページ
Page.Start - Page.End | ・基本的なコーディングで帳票作成が可能 ・固定行の帳票向き ・Excel保存時、Page.Start-End ごとにシートを作成 | ・同じシートにある 1 ページの帳票デザインを使用する ・同じシートにある 2 ページの帳票デザインを使用する ・シートごとにある帳票デザインを使用する
Page.Repeat - Page.Next (Page.Start - Page.End 間で使用) | ・複製したい行範囲を指定することで複数ページの帳票作成が可能 ・複雑な可変帳票向き ・Excel保存時、同一シートに複数ページを作成 | ・同じシートにある 1 ページの帳票デザインを使用する ・Page.Repeat - Page.Next 機能を使用する
Section.Start - Section.End | ・雛形とするヘッダー行、フッター行、明細行をあらかじめ指定することで容易に可変帳票の作成が可能 ・シンプルな可変帳票向き ・Excel保存時、「ページごとに別シート」か「同一シートに複数ページ」かを選択可能 | ・セクションレポート機能を使用する


Excel インストールが必要な場合

AS-Report 12.0 for .NET では、製品の独自機能による出力方法と環境にインストールされた Excel を使用する出力方法があります。このトピックでは、環境に Excel インストールが必要な場合について説明します。

このトピックは、次のセクションを含みます。

  • 環境の Excel を使用して出力する
  • Excel 使用時のみ反映できる主な機能
  • 制限事項
  • サンプルコード
環境の Excel を使用して出力する

下記のいずれかの設定や出力をする場合に、環境に Excel のインストールが必要です。

  • ExcelMode プロパティに True を設定する
  • レポートコンポーネントから直接印刷をする
  • ReportMode.Legacy で Excel ファイル保存をする
Excel 使用時のみ反映できる主な機能(※1)

下記は、製品の独自機能による出力方法では未対応ですが、Excel を使用することで出力結果に反映させることができます。

  • 印刷範囲、印刷タイトルを反映した印刷
  • 計算式の再計算(※2)
Note メモ:

(※1)本項目では一部の機能のみ紹介しています。詳細は「対応する Excel 修飾機能」を参照してください。

(※2)一部の計算式は ApplyFormula プロパティでも対応しています。詳細は「計算式を再計算する」を参照してください。

制限事項

非対話型アプリケーション(Web アプリケーション、バッチ処理、など)では、Excel を使用した出力に対応していません。Excel の機能を使用するとエラー(NotExcel)を返却します。

サンプルコード

次のコードは、ExcelMode プロパティを設定して帳票出力をするサンプルコードです。

C#
VB
コピー
// 環境の Excel オブジェクトを使用して帳票を出力します
cellReport1.ExcelMode = true;
cellReport1.FileName = @"C\:Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
' 環境の Excel オブジェクトを使用して帳票を出力します
CellReport1.ExcelMode = True
CellReport1.FileName = "C\:Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\Out1.xlsx")


基本操作

ここでは、AS-Report 12.0 for .NET の基本操作について説明します。

デザインファイル、ドキュメントを設定する

帳票の雛形となるデザインファイルや帳票ドキュメントを設定する方法について説明します。

シートを設定する

帳票の雛形となるデザインシートやシート名を設定する方法について説明します。

セルを編集する

セルの指定方法や、データ、書式、オブジェクトの設定方法について説明します。

帳票を出力する

アプリケーションごとの印刷、プレビュー、ファイル出力 (Excel / PDF) する方法について説明します。

PDF 出力オプションを設定する

出力 PDF ファイルのオプションの設定方法を説明します。

バーコードを設定する

各種バーコードを設定する方法について説明します。

イベントを実装する

各種イベントを設定する方法について説明します。

複数ページの帳票を作成する

複数ページの帳票を作成する方法について説明します。

可変明細の帳票を作成する

可変明細の帳票を作成する方法について説明します。


デザインファイル、ドキュメントを設定する

AS-Report 12.0 for .NET では、デザインファイル(雛形の Excel ファイル)を使用して帳票を出力することができ、帳票ドキュメントを複数作成することで出力時に切り替えて出力することもできます。ここでは、プログラムからデザインファイルの指定方法や帳票ドキュメントの作成手順について説明します。

プログラムからデザインファイルを指定する

プログラムからデザインファイルを指定する方法について説明します。

デザインファイルをプログラムに埋め込む

デザインファイルを埋め込みリソースとして使用する方法について説明します。

デザインファイルを使用せずに帳票を作成する

デザインファイルを使用せずに、新規で帳票を作成する方法について説明します。

ドキュメントを作成する

帳票のドキュメントを作成する方法について説明します。


プログラムからデザインファイルを指定する

このトピックでは、Excel で作成したデザインファイル (雛形の Excel ファイル) を使用して帳票を出力する場合のデザインファイルの指定方法を説明します。 デザインファイルの指定は、FileName プロパティでデザインファイルを指定し、Report.File メソッドを呼び出します。

プログラムからデザインファイルを指定する

次のコードは C:\Book1.xlsx に配置したデザインファイル (Book1.xlsx) を使用するサンプルコードです。

C#
VB
コピー
// デザインファイルのファイルパスを指定します。
cellReport1.FileName = @"C:\Book1.xlsx";
// 帳票ドキュメントの作成を開始します。
cellReport1.Report.Start();
// デザインファイルを読み込みます。
cellReport1.Report.File();
// 第 1 引数に使用する Excel ファイルのシート名、第 2 引数に出力する帳票のページ数を指定します。
cellReport1.Page.Start("Sheet1", "1");
// Excel シート "Sheet1" を使用した帳票ページの作成を終了します。
cellReport1.Page.End();
// 帳票ドキュメントの作成を終了します。
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
' デザインファイルのファイルパスを指定します。
CellReport1.FileName = "C:\Book1.xlsx"
' 帳票ドキュメントの作成を開始します。
CellReport1.Report.Start()
' デザインファイルを読み込みます。
CellReport1.Report.File()
' 第 1 引数に使用する Excel ファイルのシート名、第 2 引数に出力する帳票のページ数を指定します。
CellReport1.Page.Start("Sheet1", "1")
' Excel シート "Sheet1" を使用した帳票ページの作成を終了します。
CellReport1.Page.End()
' 帳票ドキュメントの作成を終了します。
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\Out1.xlsx")
参照
メソッド・プロパティ・イベント機能一覧 (レポートコンポーネント)
デザインファイルを設定する


デザインファイルをプログラムに埋め込む

AS-Report 12.0 for .NET は、プログラムにデザインファイル (雛形の Excel ファイル) を埋め込んで使用することができます。 このトピックでは、プログラムにデザインファイルを埋め込みリソースとして登録する方法とその使用方法を説明します。

このトピックは、次のセクションを含みます。

  • Excel ファイルを埋め込みリソースとして使用する
  • 参照
Excel ファイルを埋め込みリソースとして使用する

  1. [新しいプロジェクトの作成] から新しい Windows フォーム アプリを作成します。
    (※アプリケーション名は「EmbedExcel」とします。)

  2. フォームに Button (Button1) と レポートコンポーネントを配置します。 レポートコンポーネントの配置方法は「レポートコンポーネントを追加する」を参照してください。

  3. [プロジェクト] - [追加] - [既存の項目] からデザインファイル (Book1.xlsx) を選択して、[追加] ボタンをクリックします。
    (※ソリューションエクスプローラより、追加したデザインファイルがプロジェクトに登録されていることを確認します。)

  4. 引き続き、ソリューションエクスプローラ上で追加したデザインファイルを選択し、 [プロパティ] ウィンドウの [ビルドアクション] を「埋め込みリソース」に変更します。

  5. Button1 のクリックイベントに、埋め込んだデザインファイルを使用して PDF ファイルを作成する下記のサンプルコードを設定します。

    C#
    VB
    コピー
    System.Reflection.Assembly myAssembly;
System.IO.Stream strmExcel;
myAssembly = System.Reflection.Assembly.GetExecutingAssembly();
strmExcel = myAssembly.GetManifestResourceStream("EmbedExcel.Book1.xlsx");

cellReport1.Report.Start();
cellReport1.Report.Embed(strmExcel);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "Excel ファイルを埋め込みリソースとして使用する";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
    Dim myAssembly As System.Reflection.Assembly
Dim strmExcel As System.IO.Stream
myAssembly = System.Reflection.Assembly.GetExecutingAssembly()
strmExcel = myAssembly.GetManifestResourceStream("EmbedExcel.Book1.xlsx")

CellReport1.Report.Start()
CellReport1.Report.Embed(strmExcel)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "Excel ファイルを埋め込みリソースとして使用する"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\Out1.xlsx")

  6. 以上で設定完了です。ボタンをクリックすると埋め込んだデザインファイルを使用して PDF ファイルを保存します。

参照
メソッド・プロパティ・イベント機能一覧 (レポートコンポーネント)
デザインファイルを設定する


デザインファイルを使用せずに帳票を作成する

このトピックでは、デザインファイル(雛形の Excel ファイル)を使用せずに、新規で帳票を作成する方法を説明します。 新規で帳票を作成する場合、Report.Create メソッドを呼び出します。

デザインファイルを使用せずに帳票を作成する

次のコードはデザインファイルを使用せずに新規で帳票を作成するサンプルコードです。

C#
VB
コピー
cellReport1.Report.Start();
// Create メソッドで帳票の新規作成を開始します。第 1 引数には Excel バージョンを指定します。
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.Report.Start()
' Create メソッドで帳票の新規作成を開始します。第 1 引数には Excel バージョンを指定します。
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\Out1.xlsx")
参照
メソッド・プロパティ・イベント機能一覧 (レポートコンポーネント)
デザインファイルを設定する


ドキュメントを作成する

AS-Report 12.0 for .NET では、デザインファイル(雛形の Excel ファイル)を元にデータを差し込んだ帳票ドキュメントを作成し、帳票ドキュメントをビューアコントロールに設定することで帳票を出力することができます。作成する帳票ドキュメントには、Report.Start メソッドで名前をつけることもできます。このトピックではドキュメントの作成方法を説明します。

このトピックは、次のセクションを含みます。

  • 帳票ドキュメントを作成する
  • 帳票ドキュメントに名前を設定する
  • 複数の帳票ドキュメントを作成する
  • 参照
帳票ドキュメントを作成する

次のコードは帳票ドキュメントを作成するサンプルコードです。

C#
VB
コピー
cellReport1.FileName = @"C:¥Book1.xlsx";
viewerControl1.Clear();
// 帳票の作成を開始します。
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "Document";
cellReport1.Page.End();
cellReport1.Report.End();
// ビューアコントロールに帳票ドキュメントを設定します。
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
ViewerControl1.Clear()
' 帳票ドキュメントの作成を開始します。
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "Document"
CellReport1.Page.End()
CellReport1.Report.End()
' ビューアコントロールに帳票ドキュメントを設定します。
ViewerControl1.Document = CellReport1.Document
帳票ドキュメントに名前を設定する

次のコードは帳票ドキュメントに名前を付けるサンプルコードです。

C#
VB
コピー
cellReport1.FileName = @"C:¥Book1.xlsx";
viewerControl1.Clear();
// 帳票ドキュメントの名前を "Document1" に設定し、ドキュメントの作成を開始します。
cellReport1.Report.Start("Document1");
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "Document1";
cellReport1.Page.End();
cellReport1.Report.End();
// GetDocument メソッドの第 1 引数に取得するドキュメント名を指定します。
viewerControl1.Document = cellReport1.GetDocument("Document1");
CellReport1.FileName = "C:\Book1.xlsx"
ViewerControl1.Clear()
' 帳票ドキュメントの名前を "Document1" に設定し、ドキュメントの作成を開始します。
CellReport1.Report.Start("Document1")
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "Document1"
CellReport1.Page.End()
CellReport1.Report.End()
' GetDocument メソッドの第 1 引数に取得するドキュメント名を指定します。
ViewerControl1.Document = CellReport1.GetDocument("Document1")
複数の帳票ドキュメントを作成する

次のコードは帳票ドキュメント "Document1" と "Document2" を作成し、CellReport1.GetDocument メソッドで指定したドキュメントを取得するサンプルコードです。

C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
viewerControl1.Clear();
// 帳票ドキュメントの名前を "Document1" に設定し、ドキュメントの作成を開始します。
cellReport1.Report.Start("Document1");
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "Document1";
cellReport1.Page.End();
cellReport1.Report.End();
// 帳票ドキュメントの名前を "Document2" に設定し、ドキュメントの作成を開始します。
cellReport1.Report.Start(ReportMode.Speed, "Document2");
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "Document2";
cellReport1.Page.End();
cellReport1.Report.End();
// GetDocument メソッドで帳票ドキュメント "Document2" を取得します。
viewerControl1.Document = cellReport1.GetDocument("Document2");
CellReport1.FileName = "C:\Book1.xlsx"
ViewerControl1.Clear()
' 帳票ドキュメントの名前を "Document1" に設定し、ドキュメントの作成を開始します。
CellReport1.Report.Start("Document1")
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "Document1"
CellReport1.Page.End()
CellReport1.Report.End()
' 帳票ドキュメントの名前を "Document2" に設定し、ドキュメントの作成を開始します。
CellReport1.Report.Start(ReportMode.Speed, "Document2")
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "Document2"
CellReport1.Page.End()
CellReport1.Report.End()
' GetDocument メソッドで帳票ドキュメント "Document2" を取得します。
ViewerControl1.Document = CellReport1.GetDocument("Document2")
参照
メソッド・プロパティ・イベント機能一覧 (レポートコンポーネント)
デザインファイル、ドキュメントを設定する


シートを設定する

AS-Report 12.0 for .NET では、デザインシートの指定やシート名に任意の文字列を設定して帳票を出力することが可能です。ここでは、プログラムからデザインシートを指定する手順とシート名を設定する手順について説明します。

デザインシートを指定する

帳票の出力対象となる Excel シートを指定する方法を説明します。

シート名を変更する

出力帳票のシート名を変更する方法を説明します。


デザインシートを指定する

AS-Report 12.0 for .NET では、デザインファイル(雛形の Excel ファイル)の任意の Excel シートを元に帳票ドキュメントを作成します。任意の Excel シートを選択するには Page.Start メソッドを使用します。また、複数の Excel シートを選択して帳票を作成することも可能です。このトピックでは、シートの指定方法を説明します。

このトピックは、次のセクションを含みます。

  • Excel デザインシートを指定する
  • 複数の Excel デザインシートを指定する
  • 参照
Excel デザインシートを指定する

次のコードは、"Book1.xlsx" のシート "Sheet2" を元に帳票を出力するサンプルコードです。

C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
// Page.Start メソッドの第 1 引数に使用するシート名 "Sheet2" を設定します。
cellReport1.Page.Start("Sheet2", "1");
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
' Page.Start メソッドの第 1 引数に使用するシート名 "Sheet2" を設定します。
CellReport1.Page.Start("Sheet2", "1")
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\Out1.xlsx")
複数の Excel デザインシートを指定する

次のコードは、"Book1.xlsx" のシート "Sheet1" と "Sheet2" を元に帳票を出力するサンプルコードです。

C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
// Page.Start メソッドの第 1 引数に使用するシート名 "Sheet1" を設定します。
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Page.End();
// Page.Start メソッドの第 1 引数に使用するシート名 "Sheet2" を設定します。
cellReport1.Page.Start("Sheet2", "1");
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
' Page.Start メソッドの第 1 引数に使用するシート名 "Sheet1" を設定します。
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Page.End()
' Page.Start メソッドの第 1 引数に使用するシート名 "Sheet2" を設定します。
CellReport1.Page.Start("Sheet2", "1")
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\Out1.xlsx")
参照
メソッド・プロパティ・イベント機能一覧 (レポートコンポーネント)
シートを設定する


シート名を変更する

AS-Report 12.0 for .NET では、出力帳票のシート名を任意の名前へ変更することができます。このトピックでは、出力帳票のシート名を変更する方法について説明します。

Note メモ:

ReportMode.Legacy ではデザインファイルを使用して帳票を作成する場合、デザインファイル上の既存のシート名を設定することはできません。
シート名を変更する

次のコードは出力帳票のシート名を変更するサンプルコードです。

C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
// 出力帳票のシート名を "Sheet1" から "シート１" に変更します。
cellReport1.Page.Name = "シート１";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
' 出力帳票のシート名を "Sheet1" から "シート１" に変更します。
CellReport1.Page.Name = "シート１"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\Out1.xlsx")
参照
メソッド・プロパティ・イベント機能一覧 (レポートコンポーネント)
シートを設定する


セルを編集する

AS-Report 12.0 for .NET では、セルを指定して値、書式、オブジェクトの設定をすることが可能です。ここでは、プログラムからセルを編集する手順について説明します。

セルを指定する

値、書式、オブジェクトの設定対象となるセルを指定する方法を説明します。

値を設定、取得する

値を設定、取得する方法を説明します。

日付の値を設定、取得する

日付データを設定、取得する方法を説明します。

計算式を再計算する

計算式を再計算する方法について説明します。

セルをコピー、クリアする

セルをコピー、クリアする方法を説明します。

行、列をコピー、クリア、挿入、削除する

行、列をコピー、クリア、挿入、削除する方法を説明します。

セル属性を設定する

セル属性を設定する方法を説明します。

ページ属性を設定する

ページ属性を設定する方法を説明します。

複数の列挙体メンバを設定する

引数に 2 つ以上の列挙体のメンバを設定する方法を説明します。

画像、オートシェイプを設定する

画像、オートシェイプなどのオブジェクトを設定する方法を説明します。


セルを指定する

AS-Report 12.0 for .NET では Cell / Pos メソッドを使用し、さまざまな方法でセルを指定して値を設定することが可能です。このトピックでは、セルの指定方法を説明します。

このトピックは、次のセクションを含みます。

  • A1 参照形式によるセルの指定
  • 座標によるセルの指定
  • 変数名によるセルの指定
  • セル名によるセルの指定
  • 参照
A1 参照形式によるセルの指定

このセクションでは、A1 参照形式でセルを指定する方法を説明します。

次のコードは、Cell メソッドを使用して A1 参照形式で A1 セルを指定し、文字列 "アドバンスソフトウェア" を設定するサンプルコードです。

C#
VB
コピー
// A1 セルに文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
' A1 セルに文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
座標によるセルの指定

このセクションでは、座標形式でセルを指定する方法を説明します。

Note メモ:

座標形式で指定する場合、Pos メソッドの第一引数が x 軸(列)、第二引数が y軸(行) になります。

次のコードは、Pos メソッドを使用して座標形式で A5 セルを指定し、文字列 "アドバンスソフトウェア" を設定するサンプルコードです。

C#
VB
コピー
// A5 セルに文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Pos(0, 4).Value = "アドバンスソフトウェア";
' A5 セルに文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Pos(0, 4).Value = "アドバンスソフトウェア"
変数名によるセルの指定

AS-Report 12.0 for .NET では、Excel ファイルのセルに予め設定された連続する 2 つのアスタリスク(**)から始まる文字列を変数名として扱います。このセクションでは、変数名でセルを指定する方法を説明します。

Note メモ:

既定では、連続する 2 つのアスタリスク (**) から始まる文字列を変数名として扱いますが、「Keyword プロパティ」を使用することで、変数名のキーワード文字をアスタリスク (*) から別の文字に変更することが可能です。

次のコードは、Cell メソッドで A1 セルに設定した変数名 "**Name" を指定し、文字列 "アドバンスソフトウェア" を設定するサンプルコードです。

C#
VB
コピー
// A1 セルに予め変数名 "**Name" を設定し、Cell メソッドで変数名を指定して、文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Cell("**Name").Value = "アドバンスソフトウェア";
' A1 セルに予め変数名 "**Name" を設定し、Cell メソッドで変数名を指定して、文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Cell("**Name").Value = "アドバンスソフトウェア"
セル名によるセルの指定

AS-Report 12.0 for .NET では、Excel ファイルのセルに予め設定されたセル名を指定することができます。このセクションでは、セル名でセルを指定する方法を説明します。

次のコードは、Cell メソッドで A1 セルに設定したセル名 "CellName" を指定し、文字列 "アドバンスソフトウェア" を設定するサンプルコードです。

C#
VB
コピー
// A1 セルに予めセル名 "CellName" を設定し、Cell メソッドでセル名を指定して、文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Cell("CellName").Value = "アドバンスソフトウェア";
' A1 セルに予めセル名 "CellName" を設定し、Cell メソッドでセル名を指定して、文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Cell("CellName").Value = "アドバンスソフトウェア"
参照
メソッド・プロパティ・イベント機能一覧 (レポートコンポーネント)
基本操作


値を設定、取得する

AS-Report 12.0 for .NET では、Cell / Pos メソッドでセルを指定し、 Value / Str プロパティ、Func メソッドで目的のデータを設定、取得することが可能です。このトピックでは、さまざまな値の設定、取得方法を説明します。

このトピックは、次のセクションを含みます。

  • 値を設定、取得する
  • 計算式を設定する
  • 参照
値を設定、取得する

AS-Report 12.0 for .NET では、Value / Str プロパティなどで数値や文字列などの値を設定、取得することが可能です。このセクションでは、値の設定、取得方法を説明します。

値を設定する

次のコードは、それぞれのセルに文字列、数値を設定するサンプルコードです。

C#
VB
コピー
// Str プロパティで A1 セルに文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Cell("A1").Str = "アドバンスソフトウェア";
// Value プロパティで A2 セルに文字列 "Advance Software" を設定します。
cellReport1.Cell("A2").Value = "Advance Software";
// Value プロパティで A3 セルに数値 200 を設定します。
cellReport1.Cell("A3").Value = 200;
' Str プロパティで A1 セルに文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Cell("A1").Str = "アドバンスソフトウェア"
' Value プロパティで A2 セルに文字列 "Advance Software" を設定します。
CellReport1.Cell("A2").Value = "Advance Software"
' Value プロパティで A3 セルに数値 200 を設定します。
CellReport1.Cell("A3").Value = 200

値を取得する

次のコードは、それぞれのセルに設定された文字列、数値を取得するサンプルコードです。

Note メモ:

値の取得は、A1 参照形式、座標、セル名によるセル指定にのみ対応しており、変数名によるセル指定では対応していません。
C#
VB
コピー
string strData;
object objectData;
int intData;

// Str プロパティで A1 セルの文字列を取得します。
strData = cellReport1.Cell("A1").Str;
// Value プロパティで A2 セルの文字列(object 型)を取得します。
objectData = cellReport1.Cell("A2").Value;
// Value プロパティで A3 セルの数値を取得します。
intData = (int)cellReport1.Cell("A3").Value;
Dim strData As String
Dim objectData As Object
Dim intData As Integer

' Str プロパティで A1 セルの文字列を取得します。
strData = CellReport1.Cell("A1").Str
' Value プロパティで A2 セルの文字列(object 型)を取得します。
objectData = CellReport1.Cell("A2").Value
' Value プロパティで A3 セルの数値を取得します。
intData = CellReport1.Cell("A3").Value
計算式を設定する

AS-Report 12.0 for .NET では、プログラムから計算式を設定することが可能です。このセクションでは計算式の設定方法を説明します。

Note メモ:

計算式を取得することはできません。なお、計算式の再計算方法は「 計算式を再計算する 」を参照してください。

プログラムから計算式を設定する

次のコードは、A1 セル、A2 セル、B1 セル、B2 セルに値を設定し、A3 セルには四則演算記号を使用した数式と結果、B3 セルには Excel 関数と結果を設定するサンプルコードです。

C#
VB
コピー
// A1 セルに数値 100、A2 セルに数値 200 を設定し、A3 セルに 計算式 "=A1+A2" と、計算結果 300 を設定します。
cellReport1.Cell("A1").Value = 100;
cellReport1.Cell("A2").Value = 200;
cellReport1.Cell("A3").Func("=A1+A2", 300);
// B1 セルに数値 100、B2 セルに数値 200 を設定し、B3 セルに 計算式 "=SUM(B1:B2)" と、計算結果 300 を設定します
cellReport1.Cell("B1").Value = 100;
cellReport1.Cell("B2").Value = 200;
cellReport1.Cell("B3").Func("=SUM(B1:B2)", 300);
' A1 セルに数値 100、A2 セルに数値 200 を設定し、A3 セルに 計算式 "=A1+A2" と、計算結果 300 を設定します。
CellReport1.Cell("A1").Value = 100
CellReport1.Cell("A2").Value = 200
CellReport1.Cell("A3").Func("=A1+A2", 300)
' B1 セルに数値 100、B2 セルに数値 200 を設定し、B3 セルに 計算式 "=SUM(B1:B2)" と、計算結果 300 を設定します
CellReport1.Cell("B1").Value = 100
CellReport1.Cell("B2").Value = 200
CellReport1.Cell("B3").Func("=SUM(B1:B2)", 300)
参照
メソッド・プロパティ・イベント機能一覧 (レポートコンポーネント)
セルを編集する


日付の値を設定、取得する

AS-Report 12.0 for .NET では、日付の値を設定、取得することが可能です。Excel ファイルのセルに設定された日付の値は、Excel ファイル内部でシリアル値（数値）として管理されています。 そのため、Str、Value プロパティ等でそのまま日付形式で値を設定、取得することはできないため、 各言語のサポートするデータ変換関数を使用して、日付型のデータとして扱う必要があります。 このトピックでは、日付の値を設定、取得する方法を説明します。

このトピックは、次のセクションを含みます。

  • 日付の値を設定する
  • 日付の値を取得する
  • 和暦の表示形式を設定する
  • 参照
日付の値を設定する

このセクションでは、日付の値の設定方法を説明します。

次のコードは、A1 セルに日付の値を設定するサンプルコードです。

C#
VB
コピー
// 日付 "2025/1/1" を日付型のデータに変換し、Value プロパティで A1 セルに設定します。
cellReport1.Cell("A1").Value = Convert.ToDateTime("2025/1/1").ToOADate();
// A1 セルに日付の書式を設定します。(例 2025/1/1)
cellReport1.Cell("A1").Attr.Format = "yyyy/m/d";
' 日付 "2025/1/1" を日付型のデータに変換し、Value プロパティで A1 セルに設定します。
CellReport1.Cell("A1").Value = Convert.ToDateTime("2025/1/1").ToOADate()
' A1 セルに日付の書式を設定します。(例 2025/1/1)
CellReport1.Cell("A1").Attr.Format = "yyyy/m/d"
日付の値を取得する

このセクションでは、セルに予め設定された日付の値の取得方法を説明します。

次のコードは、Excel ファイルの A1 セルに予め設定された日付の値を取得後、文字列に変換するサンプルコードです。

C#
VB
コピー
DateTime dtDate;
string strDate;

// Value プロパティで A1 セルに設定された日付の値を取得します。
dtDate = DateTime.FromOADate(Convert.ToDouble(cellReport1.Cell("A1").Value));
// 取得した日付の値を文字列型に変換します。
strDate = dtDate.ToString("yyyy/M/d");
Dim dtDate As DateTime
Dim strDate As String

' Value プロパティで A1 セルに設定された日付の値を取得します。
dtDate = DateTime.FromOADate(Convert.ToDouble(CellReport1.Cell("A1").Value))
' 取得した日付の値を文字列型に変換します。
strDate = dtDate.ToString("yyyy/M/d")
和暦の表示形式を設定する

このセクションでは、和暦の表示形式を設定する方法を説明します。

AS-Report 12.0 for .NET で和暦の表示形式 [令和##年##月##日] を設定する場合、 Excel 上で正しく表示するためには、日付の言語/地域を指定する必要があります。

次のコードは、A1 セルに日付と和暦の表示形式を設定するサンプルコードです。

C#
VB
コピー
// 日付 "2025/1/1" を日付型のデータに変換し、Value プロパティで A1 セルに設定します。
cellReport1.Cell("A1").Value = Convert.ToDateTime("2025/1/1").ToOADate();
// A1 セルに和暦の表示形式を設定します。
cellReport1.Cell("A1").Attr.Format = "[$-411]ggge\"年\"m\"月\"d\"日\";@";
' 日付 "2025/1/1" を日付型のデータに変換し、Value プロパティで A1 セルに設定します。
CellReport1.Cell("A1").Value = Convert.ToDateTime("2025/1/1").ToOADate()
' A1 セルに和暦の表示形式を設定します。
CellReport1.Cell("A1").Attr.Format = "[$-411]ggge""年""m""月""d""日"";@"
参照
メソッド・プロパティ・イベント機能一覧 (レポートコンポーネント)
セルを編集する


計算式を再計算する

AS-Report 12.0 for .NET では、デザインファイルに設定されている計算式やコード上から設定した計算式を再計算する事ができます。このトピックでは、AS-Report 12.0 for .NET で計算式を再計算する方法を説明します。

このトピックは、次のセクションを含みます。

  • ApplyFormula プロパティを使用する
  • ExcelMode プロパティを使用する
  • 参照
ApplyFormula プロパティを使用する

ApplyFormula プロパティを True に設定することで、AS-Report 12.0 for .NET の独自の機能で計算式を再計算します。使用可能な関数に制限があるため、基本的な関数が使用された計算式を再計算する場合に適しています。

ApplyFormula プロパティが対応する関数、演算子一覧

演算子 / 関数名 | 値の型
単項式 | 数値, 文字列またはセル
加算 (+) | 数値
減算 (-) | 数値
乗算 (*) | 数値
除算 (/) | 数値
余算 (Mod) | 数値
べき乗 (^) | 数値
文字列の連結 (&) | 文字列, 文字列
大小比較 (>) | 数値
大小比較 (>=) | 数値
大小比較 (<) | 数値
大小比較 (<=) | 数値
正否判定 (=) | 数値, 文字列またはセル
正否判定 (<>) | 数値, 文字列またはセル
括弧 ()での優先 | 数値
ABS | 数値
AND | 論理式1, 論理式2
ASC | 文字列
AVERAGE | 数値, ･･･(可変)
CHAR | 数値
CHOOSE | 数値,値(可変)
COLUMN | セル(省略可)
COLUMNS | セル範囲
CONCATENATE | 文字列, ･･･(可変)
COUNT | セル範囲, ･･･(可変)
COUNTA | 値, ･･･(可変)
COUNTBLANK | セル範囲
COUNTIF | セル範囲, 文字列または数値
COUNTIFS | セル範囲, 文字列, ･･･(可変)
DATE | 数値, 数値, 数値
DATEDIF | 数値, 数値, 文字列
DAY | 日付
EDATE | 日付, 数値
EXACT | 文字列, 文字列
FALSE | 論理値
FIND | 文字列, 文字列, 数値(省略可)
HLOOKUP | 文字列または数値, セル範囲, 数値, 論理値(省略可)
IF | 論理式, 数値または文字列, 数値または文字列(省略可)
INDEX | セル範囲, 数値, 数値(省略可)
INDIRECT | 文字列, 論理値(省略可、trueのみ)
INT | 数値
ISBLANK | セル
ISERROR | セル(計算式)
ISNUMBER | セル
LARGE | セル範囲, 数値
LEFT | 文字列, 数値
LEN | 文字列
LOOKUP | 文字列, セル範囲, セル範囲
LOWER | 文字列
MATCH | セル, セル範囲, 数値(省略可)
MAX | 数値, ･･･(可変)
MID | 文字列, 数値, 数値
MIN | 数値, ･･･(可変)
MOD | 数値, 数値
MONTH | 日付
NOT | 計算式
NOW | なし※表示形式で日付の指定が必要
OFFSET | セル範囲,数値,数値,数値(省略可),数値(省略可)
OR | 論理式1, 論理式2
PRODUCT | 数値, ･･･(可変)
QUOTIENT | 数値, 数値
RANK | 数値, セル範囲, 数値
REPLACE | 文字列, 数値, 数値, 文字列
RIGHT | 文字列, 数値
ROUND | 数値, 数値
ROUNDDOWN | 数値, 数値
ROUNDUP | 数値, 数値
ROW | セル(省略可)
ROWS | セル範囲
SEARCH | 文字列, 文字列, 数値(省略可)
SIGN | 数値
SMALL | セル範囲, 数値
SUBSTITUTE | 文字列, 文字列, 文字列, 文字列
SUM(セル) | セル範囲(数値)
SUM(値) | 数値, 数値
SUMIF | セル範囲, 文字列または数値, セル範囲
SUMIFS | セル範囲, セル範囲, 文字列, ･･･(可変)
TEXT | 数値, 文字列
TIME | 数値, 数値, 数値
TODAY | なし※表示形式で日付の指定が必要
TRIM | 文字列
TRUE | 論理値
TRUNC | 数値, 数値(省略可)
UPPER | 文字列
VALUE | 文字列
VLOOKUP | 文字列または数値, セル範囲, 数値, 論理値(省略可)
WEEKDAY | 日付, 数値(省略可)
YEAR | 日付
Note メモ:
  • Excel ファイルの再計算には未対応です。
  • 対応表に記載のない関数は未対応です。
  • 対応表に記載のない型での設定は未対応です。
  • RC 形式、セル名での座標指定は未対応です。
  • 配列数式には未対応です。
  • VLOOKUP、HLOOKUP での論理値 = False 時、近似値を取得するには表が昇順である必要があります。
  • 「値または数値」、「座標」については、単体セル座標の指定も可能です。
  • 論理値の計算結果は 1 (True)、0 (False) となります。
  • 処理速度が低下する可能性があります。
  • 製品独自の機能で再計算するため、Excel の再計算結果と必ずしも一致するとは限りません。

ApplyFormula プロパティを使用して計算式を再計算するには

次のコードは ApplyFormula プロパティを使用して計算式を再計算するサンプルコードです。

C#
VB
コピー
// 計算式の再計算機能を有効にします。
cellReport1.ApplyFormula = true;
cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = 100;
cellReport1.Cell("A2").Value = 200;
// A3 セルに計算式 "=SUM(A1:A2)" を設定します。
cellReport1.Cell("A3").Func("=SUM(A1:A2)", null);
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SavePdf(@"C:\out1.pdf");
' 計算式の再計算機能を有効にします。
CellReport1.ApplyFormula = True
CellReport1.Report.Start()
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = 100
CellReport1.Cell("A2").Value = 200
' A3 セルに計算式 "=SUM(A1:A2)" を設定します。
CellReport1.Cell("A3").Func("=SUM(A1:A2)", vbNullString)
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SavePdf("C:\Out1.pdf")
ExcelMode プロパティを使用する

ExcelMode プロパティを True に設定することで、環境にインストールされている Excel の機能で計算式を再計算します。Excel の機能で再計算をするため、高度な関数が使用された計算式を再計算する場合に適しています。

Note メモ:

ExcelMode プロパティを True に設定する場合、環境に Excel がインストールされている必要があります。 ExcelMode プロパティの詳細は 「Excel インストールが必要な場合」を参照してください。

ExcelMode プロパティを使用して計算式を再計算するには

次のコードは ExcelMode プロパティを使用して計算式を再計算するサンプルコードです。

C#
VB
コピー
// 環境にインストールされている Excel を使用して処理をします。
cellReport1.ExcelMode = true;
cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = 100;
cellReport1.Cell("A2").Value = 200;
// A3 セルに計算式 "=SUM(A1:A2)" を設定します。
cellReport1.Cell("A3").Func("=SUM(A1:A2)", null);
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SavePdf(@"C:\out1.pdf");
' 環境にインストールされている Excel を使用して処理をします。
CellReport1.ExcelMode = True
CellReport1.Report.Start()
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = 100
CellReport1.Cell("A2").Value = 200
' A3 セルに計算式 "=SUM(A1:A2)" を設定します。
CellReport1.Cell("A3").Func("=SUM(A1:A2)", vbNullString)
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SavePdf("C:\Out1.pdf")
参照
メソッド・プロパティ・イベント機能一覧 (レポートコンポーネント)
セルを編集する


セルをコピー、クリアする

AS-Report 12.0 for .NET では、Cell / Pos メソッドでセルを指定し、Copy メソッドや Paste メソッドでセルのコピーや貼り付け、Clear メソッドでセルをクリアすることが可能です。このトピックでは、セルのコピーや貼り付け、クリアの方法を説明します。

このトピックは、次のセクションを含みます。

  • セルをコピーする
  • セルをクリアする
  • 参照
セルをコピーする

このセクションでは Copy メソッド、Paste メソッドでセルのコピーや貼付けをする方法を説明します。

セルをコピーする（単一セルコピー）

次のコードは、Copy メソッドでセルのコピー、貼り付けをするサンプルコードです。

C#
VB
コピー
// A1 セルをコピーし、B1 セルに貼り付けます。
cellReport1.Cell("A1").Copy("B1");
' A1 セルをコピーし、B1 セルに貼り付けます。
CellReport1.Cell("A1").Copy("B1")

セルをコピーする（範囲セルコピー）

次のコードは、Copy メソッドで範囲セルのコピー、貼り付けをするサンプルコードです。

C#
VB
コピー
// A1:B1 セルをコピーし、C1 セルに貼り付けます。
cellReport1.Cell("A1:B1").Copy("C1");
' A1:B1 セルをコピーし、C1 セルに貼り付けます。
CellReport1.Cell("A1:B1").Copy("C1")

セルをコピーする（メモリ上にコピー）

次のコードは、Copy メソッドでセルをコピーし、Paste メソッドで貼り付けをするサンプルコードです。

C#
VB
コピー
// Copy メソッドで A1 セルをコピーします。
cellReport1.Cell("A1").Copy();
// コピーしたセルを Paste メソッドで B1 セルに貼り付けます。
cellReport1.Cell("B1").Paste();
' Copy メソッドで A1 セルをコピーします。
CellReport1.Cell("A1").Copy()
' コピーしたセルを Paste メソッドで B1 セルに貼り付けます。
CellReport1.Cell("B1").Paste()
セルをクリアする

このセクションでは セルに設定された値、属性をクリアする方法を説明します。

セルをクリアする（単一セルクリア）

次のコードは、Clear メソッドで A1 セルの値、A2 セルの属性をクリアするサンプルコードです。

C#
VB
コピー
// A1 セルの値をクリアします。
cellReport1.Cell("A1").Clear(AdvanceSoftware.ASReport.CellClearMode.Value);
// A2 セルの属性をクリアします。
cellReport1.Cell("A2").Clear(AdvanceSoftware.ASReport.CellClearMode.Attr);
' A1 セルの値をクリアします。
CellReport1.Cell("A1").Clear(AdvanceSoftware.ASReport.CellClearMode.Value)
' A2 セルの属性をクリアします。
CellReport1.Cell("A2").Clear(AdvanceSoftware.ASReport.CellClearMode.Attr)

セルをクリアする（範囲セルクリア）

次のコードは、Clear メソッドで A1:B1 セルの値、属性をクリアするサンプルコードです。

C#
VB
コピー
// A1:B1 セルの値と属性をクリアします。
cellReport1.Cell("A1:B1").Clear(AdvanceSoftware.ASReport.CellClearMode.All);
' A1:B1 セルの値と属性をクリアします。
CellReport1.Cell("A1:B1").Clear(AdvanceSoftware.ASReport.CellClearMode.All)
参照
メソッド・プロパティ・イベント機能一覧 (レポートコンポーネント)
セルを編集する


行、列をコピー、クリア、挿入、削除する

AS-Report 12.0 for .NET では、行、列単位でコピー、クリア、挿入、削除をすることが可能です。このトピックでは、行、列単位でのコピー、クリア、挿入、削除する方法を説明します。

このトピックは、次のセクションを含みます。

  • 行、列をコピーする
  • 行、列をクリアする
  • 行、列を挿入する
  • 行、列を削除する
  • 参照
Note 注意:

Page.Repeat - Page.Next メソッドの間で行列操作をすることはできません。
行、列をコピーする

このセクションでは、行、列単位でコピー、貼り付けをする方法を説明します。

行をコピーする

次のコードは、RowCopy メソッドで 1 行目をコピーし、2 行目に貼り付けるサンプルコードです。

C#
VB
コピー
// 1 行目をコピーし、2 行目に貼り付けます。
cellReport1.RowCopy(0, 1);
' 1 行目をコピーし、2 行目に貼り付けます。
CellReport1.RowCopy(0, 1)
Note メモ:

RowCopy メソッドでは複数行をコピーすることはできません。「Copy メソッド」でセル範囲を指定することで複数セルをコピーすることが可能です。

列をコピーする

次のコードは、ColumnCopy メソッドで A 列をコピーし、B 列に貼り付けるサンプルコードです。

C#
VB
コピー
// A 列をコピーし、B 列に貼り付けます。
cellReport1.ColumnCopy(0, 1);
' A 列をコピーし、B 列に貼り付けます。
CellReport1.ColumnCopy(0, 1)
Note メモ:

ColumnCopy メソッドでは複数列をコピーすることはできません。「Copy メソッド」でセル範囲を指定することで複数セルをコピーすることが可能です。
行、列をクリアする

このセクションでは、行、列単位で値、属性をクリアする方法を説明します。

行をクリアする

次のコードは、RowClear メソッドで 1 行目から 5 行分クリアするサンプルコードです。

C#
VB
コピー
// 1 行目から 5 行分クリアします。
cellReport1.RowClear(0, 5);
' 1 行目から 5 行分クリアします。
CellReport1.RowClear(0, 5)

列をクリアする

次のコードは、ColumnClear メソッドで A 列 から 5 列分クリアするサンプルコードです。

C#
VB
コピー
// A 列 から 5 列分クリアします。
cellReport1.ColumnClear(0, 5);
' A 列 から 5 列分クリアします。
CellReport1.ColumnClear(0, 5)
行、列を挿入する

このセクションでは、行、列を挿入する方法を説明します。

行を挿入する

次のコードは、RowInsert メソッドで 1 行目から 2 行分の行を挿入するサンプルコードです。

C#
VB
コピー
// 1 行目から 2 行分の行を挿入します。
cellReport1.RowInsert(0, 2);
' 1 行目から 2 行分の行を挿入します。
CellReport1.RowInsert(0, 2)

列を挿入する

次のコードは、ColumnInsert メソッドで A 列 から 2 列分の列を挿入するサンプルコードです。

C#
VB
コピー
// A 列 から 2 列分の列を挿入します。
cellReport1.ColumnInsert(0, 2);
' A 列 から 2 列分の列を挿入します。
CellReport1.ColumnInsert(0, 2)
行、列を削除する

このセクションでは、行、列を削除する方法を説明します。

行を削除する

次のコードは、RowDelete メソッドで 2 行目から 3 行分の行を削除するサンプルコードです。

C#
VB
コピー
// 2 行目から 3 行分の行を削除します。
cellReport1.RowDelete(1, 3);
' 2 行目から 3 行分の行を削除します。
CellReport1.RowDelete(1, 3)

列を削除する

次のコードは、ColumnDelete メソッドで B 列 から 3 列分の列を削除するサンプルコードです。

C#
VB
コピー
// B 列 から 3 列分の列を削除します。
cellReport1.ColumnDelete(1, 3);
' B 列 から 3 列分の列を削除します。
CellReport1.ColumnDelete(1, 3)
参照
メソッド・プロパティ・イベント機能一覧 (レポートコンポーネント)
セルを編集する


セル属性を設定する

AS-Report 12.0 for .NET では CellAttr クラスを使用し、セルにさまざまな属性を設定することが可能です。このトピックでは、セル属性を設定する方法を説明します。

このトピックは、次のセクションを含みます。

  • フォント属性を設定する
  • 書式を設定する
  • セルを結合する
  • 文字列の縦位置、横位置を設定する
  • セルの背景色、パターンを設定する
  • セルの罫線を設定する
  • 参照
フォント属性を設定する

このセクションでは、フォントの属性を設定する方法を説明します。

次のコードは、A1 セルのフォント属性に [MS 明朝、太字、14pt、赤字] を設定するサンプルコードです。

C#
VB
コピー
// フォント名 [ＭＳ 明朝] を設定します。
cellReport1.Cell("A1").Attr.FontName = "ＭＳ 明朝";
// フォントカラー [赤] を設定します。
cellReport1.Cell("A1").Attr.FontColor = System.Drawing.Color.Red;
// フォントスタイル [太字] を設定します。
cellReport1.Cell("A1").Attr.FontStyle = AdvanceSoftware.ASReport.FontStyle.Bold;
// フォントサイズ [14] を設定します。
cellReport1.Cell("A1").Attr.FontPoint = 14;
' フォント名 [ＭＳ 明朝] を設定します。
CellReport1.Cell("A1").Attr.FontName = "ＭＳ 明朝"
' フォントカラー [赤] を設定します。
CellReport1.Cell("A1").Attr.FontColor = System.Drawing.Color.Red
' フォントスタイル [太字] を設定します。
CellReport1.Cell("A1").Attr.FontStyle = AdvanceSoftware.ASReport.FontStyle.Bold
' フォントサイズ [14] を設定します。
CellReport1.Cell("A1").Attr.FontPoint = 14
書式を設定する

このセクションでは、書式を設定する方法を説明します。

次のコードは、Format プロパティで A1 セルに数値の書式と数値 1,000,000 を設定するサンプルコードです。

C#
VB
コピー
// A1 セルに数値の書式を設定します。
cellReport1.Cell("A1").Attr.Format = "#,##0_ ";
// A1 セルに数値 1,000,000 を設定します。
cellReport1.Cell("A1").Value = 1000000;
' A1 セルに数値の書式を設定します。
CellReport1.Cell("A1").Attr.Format = "#,##0_ "
' A1 セルに数値 1,000,000 を設定します。
CellReport1.Cell("A1").Value = 1000000
セルを結合する

このセクションでは、セルを結合する方法を説明します。

次のコードは、MergeCells プロパティで A1:C3 セルを結合するサンプルコードです。

C#
VB
コピー
// A1:C3 セルを結合します。
cellReport1.Cell("A1:C3").Attr.MergeCells = true;
' A1:C3 セルを結合します。
CellReport1.Cell("A1:C3").Attr.MergeCells = True
文字列の縦位置、横位置を設定する

このセクションでは、文字列の縦位置、横位置を設定する方法を説明します。

次のコードは、VerticalAlignment プロパティで A1 セルの文字列の縦位置 [上詰め]、HorizontalAlignment プロパティで B1 セルの文字列の横位置 [右詰め] を設定するサンプルコードです。

C#
VB
コピー
// A1 セルに文字列の縦位置 [上詰め] を設定します。
cellReport1.Cell("A1").Attr.VerticalAlignment = AdvanceSoftware.ASReport.VerticalAlignment.Top;
// B1 セルに文字列の横位置 [右詰め] を設定します。
cellReport1.Cell("B1").Attr.HorizontalAlignment = AdvanceSoftware.ASReport.HorizontalAlignment.Right;
' A1 セルに文字列の縦位置 [上詰め] を設定します。
CellReport1.Cell("A1").Attr.VerticalAlignment = AdvanceSoftware.ASReport.VerticalAlignment.Top
' B1 セルに文字列の横位置 [右詰め] を設定します。
CellReport1.Cell("B1").Attr.HorizontalAlignment = AdvanceSoftware.ASReport.HorizontalAlignment.Right
セルの背景色、パターンを設定する

このセクションでは、セルの背景色、パターンを設定する方法を説明します。

セルの背景色を設定する

次のコードは、BackColor プロパティで A1 セルの背景色を [赤] に、BackColor2 プロパティで B1 セルの背景色を [青] に設定するサンプルコードです。

Note メモ:

BackColor プロパティは、Xlsx 形式を扱う場合のみ使用できます。
C#
VB
コピー
// A1 セルに背景色 [赤] を設定します。
cellReport1.Cell("A1").Attr.BackColor = System.Drawing.Color.Red;
// B1 セルに背景色 [青] を設定します。
cellReport1.Cell("B1").Attr.BackColor2 = AdvanceSoftware.ASReport.xlColor.Blue;
' A1 セルに背景色 [赤] を設定します。
CellReport1.Cell("A1").Attr.BackColor = System.Drawing.Color.Red
' B1 セルに背景色 [青] を設定します。
CellReport1.Cell("B1").Attr.BackColor2 = AdvanceSoftware.ASReport.xlColor.Blue

セルのパターンを設定する

次のコードは、Pattern プロパティで A1 セルにパターン [右下がり斜線 縞]、BackColor プロパティでパターン背景色 [緑]、ForeColor プロパティでパターン前景色 [青] で設定し、Pattern プロパティで B1 セルにパターン [左下がり斜線 縞]、BackColor2 プロパティでパターン背景色 [赤]、ForeColor2 プロパティでパターン前景色 [水色] を設定するサンプルコードです。

Note メモ:

BackColor、ForeColor プロパティは、Xlsx 形式を扱う場合のみ使用できます。
C#
VB
コピー
// A1 セルにパターン [左下がり斜線 縞] を設定します。
cellReport1.Cell("A1").Attr.Pattern = AdvanceSoftware.ASReport.Pattern.DarkUp;
// A1 セルに背景色 [緑] を設定します。
cellReport1.Cell("A1").Attr.BackColor = System.Drawing.Color.Green;
// A1 セルに前景色 [青] を設定します。
cellReport1.Cell("A1").Attr.ForeColor = System.Drawing.Color.Blue;
// B1 セルにパターン [右下がり斜線 縞] を設定します。
cellReport1.Cell("B1").Attr.Pattern = AdvanceSoftware.ASReport.Pattern.DarkDown;
// B1 セルに背景色 [赤] を設定します。
cellReport1.Cell("B1").Attr.BackColor2 = AdvanceSoftware.ASReport.xlColor.Red;
// B1 セルに前景色 [水色] を設定します。
cellReport1.Cell("B1").Attr.ForeColor2 = AdvanceSoftware.ASReport.xlColor.Cyan;
' A1 セルにパターン [左下がり斜線 縞] を設定します。
CellReport1.Cell("A1").Attr.Pattern = AdvanceSoftware.ASReport.Pattern.DarkUp
' A1 セルに背景色 [緑] を設定します。
CellReport1.Cell("A1").Attr.BackColor = System.Drawing.Color.Green
' A1 セルに前景色 [青] を設定します。
CellReport1.Cell("A1").Attr.ForeColor = System.Drawing.Color.Blue
' B1 セルにパターン [右下がり斜線 縞] を設定します。
CellReport1.Cell("B1").Attr.Pattern = AdvanceSoftware.ASReport.Pattern.DarkDown
' B1 セルに背景色 [赤] を設定します。
CellReport1.Cell("B1").Attr.BackColor2 = AdvanceSoftware.ASReport.xlColor.Red
' B1 セルに前景色 [水色] を設定します。
CellReport1.Cell("B1").Attr.ForeColor2 = AdvanceSoftware.ASReport.xlColor.Cyan
セルの罫線を設定する

このセクションでは、セルの罫線を設定する方法を説明します。

次のコードは、それぞれのセルに上罫線、下罫線、左罫線、右罫線、左上がり罫線、右上がり罫線を設定するサンプルコードです。

Note メモ:

Xlsx 形式を扱う場合のみ、Color 構造体での色の指定も可能です。
C#
VB
コピー
// LineTop メソッドで B2 セルに上罫線（実線、青）を設定します。
cellReport1.Cell("B2").Attr.LineTop(AdvanceSoftware.ASReport.BorderStyle.Thin, AdvanceSoftware.ASReport.xlColor.Blue);
// LineBottom メソッドで B3 セルに下罫線（実線、ピンク）を設定します。
cellReport1.Cell("B3").Attr.LineBottom(AdvanceSoftware.ASReport.BorderStyle.Thin, AdvanceSoftware.ASReport.xlColor.Pink);
// LineLeft メソッドで C2 セルに左罫線（二重線、黒）を設定します。
cellReport1.Cell("C2").Attr.LineLeft(AdvanceSoftware.ASReport.BorderStyle.Double, AdvanceSoftware.ASReport.xlColor.Black);
// LineRight メソッドで C3 セルに右罫線（二重線、緑）を設定します。
cellReport1.Cell("C3").Attr.LineRight(AdvanceSoftware.ASReport.BorderStyle.Double, AdvanceSoftware.ASReport.xlColor.Green);
// LineLeftUp メソッドで D2 セルに左上がり罫線（太線、赤）を設定します。
cellReport1.Cell("D2").Attr.LineLeftUp(AdvanceSoftware.ASReport.BorderStyle.Medium, AdvanceSoftware.ASReport.xlColor.Red);
// LineRightUp メソッドで D3 セルに右上がり罫線（太線、黄）を設定します。
cellReport1.Cell("D3").Attr.LineRightUp(AdvanceSoftware.ASReport.BorderStyle.Medium, AdvanceSoftware.ASReport.xlColor.Yellow);

' LineTop メソッドで B2 セルに上罫線（実線、青）を設定します。
CellReport1.Cell("B2").Attr.LineTop(AdvanceSoftware.ASReport.BorderStyle.Thin, AdvanceSoftware.ASReport.xlColor.Blue)
' LineBottom メソッドで B3 セルに下罫線（実線、ピンク）を設定します。
CellReport1.Cell("B3").Attr.LineBottom(AdvanceSoftware.ASReport.BorderStyle.Thin, AdvanceSoftware.ASReport.xlColor.Pink)
' LineLeft メソッドで C2 セルに左罫線（二重線、黒）を設定します。
CellReport1.Cell("C2").Attr.LineLeft(AdvanceSoftware.ASReport.BorderStyle.Double, AdvanceSoftware.ASReport.xlColor.Black)
' LineRight メソッドで C3 セルに右罫線（二重線、緑）を設定します。
CellReport1.Cell("C3").Attr.LineRight(AdvanceSoftware.ASReport.BorderStyle.Double, AdvanceSoftware.ASReport.xlColor.Green)
' LineLeftUp メソッドで D2 セルに左上がり罫線（太線、赤）を設定します。
CellReport1.Cell("D2").Attr.LineLeftUp(AdvanceSoftware.ASReport.BorderStyle.Medium, AdvanceSoftware.ASReport.xlColor.Red)
' LineRightUp メソッドで D3 セルに右上がり罫線（太線、黄）を設定します。
CellReport1.Cell("D3").Attr.LineRightUp(AdvanceSoftware.ASReport.BorderStyle.Medium, AdvanceSoftware.ASReport.xlColor.Yellow)
参照
メソッド・プロパティ・イベント機能一覧 (レポートコンポーネント)
セルを編集する


ページ属性を設定する

AS-Report 12.0 for .NET では PageAttr クラスを使用し、ページにさまざまな属性を設定することが可能です。このトピックでは、ページ属性を設定する方法を説明します。

このトピックは、次のセクションを含みます。

  • ヘッダー、フッターを設定する
  • ページレイアウトを設定する
  • 用紙サイズ (定型) を設定する
  • 用紙サイズ (ユーザー定義) を設定する
  • 参照
ヘッダー、フッターを設定する

次のコードは、ヘッダーとフッターを設定するサンプルコードです。

C#
VB
コピー
// Header メソッドでヘッダー左側に現在の日付と時刻、中央に文字列と取り消し線、右側に文字列 (フォント: "ＭＳ Ｐ明朝") を設定します。
cellReport1.Page.Attr.Header("&D &T", "&Sヘッダー中央", "&\"ＭＳ Ｐ明朝\"ヘッダー右");
// Footer メソッドでフッター左側に文字列と一部に下線、中央にページ数、右側に文字列 (フォントサイズ: "14") を設定します。
cellReport1.Page.Attr.Footer("フッター&U左", "&P / &N", "&14フッター右");
' Header メソッドでヘッダー左側に現在の日付と時刻、中央に文字列と取り消し線、右側に文字列 (フォント: "ＭＳ Ｐ明朝") を設定します。
CellReport1.Page.Attr.Header("&D &T", "&Sヘッダー中央", "&""ＭＳ Ｐ明朝""ヘッダー右")
' Footer メソッドでフッター左側に文字列と一部に下線、中央にページ数、右側に文字列 (フォントサイズ: "14") を設定します。
CellReport1.Page.Attr.Footer("フッター&U左", "&P / &N", "&14フッター右")
ページレイアウトを設定する

次のコードは、PageAttr クラスを使用して、さまざまなページレイアウトを設定するサンプルコードです。

C#
VB
コピー
// Margin メソッドで余白 (左右 : 20mm、上下 : 15mm、ヘッダー・フッター : 10mm) を設定します。
cellReport1.Page.Attr.Margin(20, 20, 15, 15, 10, 10);
// Center プロパティでページ中央を水平、垂直方向に設定します。
cellReport1.Page.Attr.Center = AdvanceSoftware.ASReport.PageCenter.Horz | AdvanceSoftware.ASReport.PageCenter.Vert;
// PrintArea メソッドで印刷範囲を A1(0, 0) セルから H40(7, 39) セルの範囲に設定します。
cellReport1.Page.Attr.PrintArea(0, 0, 7, 39);
// PageOrder プロパティでページ方向を "左から右" に設定します。
cellReport1.Page.Attr.PageOrder = AdvanceSoftware.ASReport.PageOrder.RightFromLeft;
' Margin メソッドで余白 (左右 : 20mm、上下 : 15mm、ヘッダー・フッター : 10mm) を設定します。
CellReport1.Page.Attr.Margin(20, 20, 15, 15, 10, 10)
' Center プロパティでページ中央を水平、垂直方向に設定します。
CellReport1.Page.Attr.Center = AdvanceSoftware.ASReport.PageCenter.Horz Or AdvanceSoftware.ASReport.PageCenter.Vert
' PrintArea メソッドで印刷範囲を A1(0, 0) セルから H40(7, 39) セルの範囲に設定します。
CellReport1.Page.Attr.PrintArea(0, 0, 7, 39)
' PageOrder プロパティでページ方向を "左から右" に設定します。
CellReport1.Page.Attr.PageOrder = AdvanceSoftware.ASReport.PageOrder.RightFromLeft
用紙サイズ (定型) を設定する

次のコードは、Size メソッドで用紙サイズ "A3" を設定するサンプルコードです。

C#
VB
コピー
// Size メソッドで用紙サイズを "A3" に設定します。
cellReport1.Page.Attr.Size(System.Drawing.Printing.PaperKind.A3);
' Size メソッドで用紙サイズを "A3" に設定します。
CellReport1.Page.Attr.Size(System.Drawing.Printing.PaperKind.A3)
用紙サイズ (ユーザー定義) を設定する

次のコードは、SizeFree メソッドでユーザー定義用紙 "Custom"(200 × 100mm) を設定するサンプルコードです。

Note メモ:

SizeFree メソッドでユーザー定義用紙を設定する場合、予めプリントサーバーのプロパティでユーザー定義用紙を登録しておく必要があります。
C#
VB
コピー
// SizeFree メソッドで用紙サイズをユーザー定義用紙 "Custom"(200mm×100mm) に設定します。
cellReport1.Page.Attr.SizeFree(200, 100, "Custom");
' SizeFree メソッドで用紙サイズをユーザー定義用紙 "Custom"(200mm×100mm) に設定します。
CellReport1.Page.Attr.SizeFree(200, 100, "Custom")
参照
メソッド・プロパティ・イベント機能一覧 (レポートコンポーネント)
セルを編集する


複数の列挙体メンバを設定する

AS-Report 12.0 for .NET の一部のプロパティでは、2 つ以上の列挙体メンバを一度に設定することができます。このトピックでは、複数の列挙体メンバの設定に対応しているプロパティと、複数の列挙体メンバを一度に設定する方法を説明します。

このトピックは、次のセクションを含みます。

  • 対応するプロパティ一覧
  • 複数の列挙体メンバを一度に設定する
  • 参照
対応するプロパティ一覧

次の表は、複数の列挙体メンバの設定に対応しているプロパティの一覧です。

クラス名 | プロパティ名 | 説明
CellReport | VarInsertMode | 変数名の挿入モードを設定します。
CellAttr | FontStyle | セルのフォントスタイルを設定します。
Drawing | FontStyle | テキストボックスのフォントスタイルを設定します。
 | LineStyle | オートシェイプの線種を設定します。
PageAttr | Center | ページ中央を指定します。
PdfOption | Permit | PDF ファイルの権限を設定します。
複数の列挙体メンバを一度に設定する

次のコードは、FontStyle プロパティを使用して [太字] と [上付き] のフォントスタイルを設定するサンプルコードです。

C#
VB
コピー
// B2 セルにフォントスタイル (太字 + 上付き) を設定します。
cellReport1.Cell("B2").Attr.FontStyle =
    AdvanceSoftware.ASReport.FontStyle.Bold | AdvanceSoftware.ASReport.FontStyle.Up;
// B2 セルに文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Cell("B2").Str = "アドバンスソフトウェア";
' B2 セルにフォントスタイル (太字 + 上付き) を設定します。
CellReport1.Cell("B2").Attr.FontStyle = _
    AdvanceSoftware.ASReport.FontStyle.Bold Or AdvanceSoftware.ASReport.FontStyle.Up
' B2 セルに文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Cell("B2").Str = "アドバンスソフトウェア"
参照
メソッド・プロパティ・イベント機能一覧 (レポートコンポーネント)
セルを編集する


画像、オートシェイプを設定する

AS-Report 12.0 for .NET では 画像、オートシェイプ、テキストボックス、ラインを設定することが可能です。このトピックでは、それらの設定方法を説明します。

このトピックは、次のセクションを含みます。

  • 画像ファイルを設定する
  • オートシェイプを設定する
  • テキストボックスを設定する
  • ラインを設定する
  • 参照
画像ファイルを設定する

次のコードは、A1 セルに画像ファイル (C:\Data\Sample.bmp) を縦、横 50 ミリメートルで設定するサンプルコードです。

C#
VB
コピー
// ScaleMode プロパティでスケールモード [ミリ] を設定します。
cellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Millimeter;
// AddImage メソッドで 縦、横 50 ミリメートルで画像ファイルを設定します。
cellReport1.Cell("A1").Drawing.AddImage(@"C:\Data\Sample.bmp", -1, -1, -1, -1, 50, 50);
' ScaleMode プロパティでスケールモード [ミリ] を設定します。
CellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Millimeter
' AddImage メソッドで縦、横 50 ミリメートルで画像ファイルを設定します。
CellReport1.Cell("A1").Drawing.AddImage("C:\Data\Sample.bmp", -1, -1, -1, -1, 50, 50)
オートシェイプを設定する

次のコードは、B2 セルにオートシェイプ [楕円] を塗りつぶし色 [青] でセルのサイズに合わせて設定するサンプルコードです。

C#
VB
コピー
// B2 セルにオートシェイプの塗りつぶし色 [青] を設定します。
cellReport1.Cell("B2").Drawing.FillColor = System.Drawing.Color.Blue;
// B2 セルにオートシェイプ [楕円] を設定します。
cellReport1.Cell("B2").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse);
' B2 セルにオートシェイプの塗りつぶし色 [青] を設定します。
CellReport1.Cell("B2").Drawing.FillColor = System.Drawing.Color.Blue
' B2 セルにオートシェイプ [楕円] を設定します。
CellReport1.Cell("B2").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse)
テキストボックスを設定する

次のコードは、B2:D5 セルに横書きテキストボックスを文字列の位置 [横位置:中央揃え、縦位置:中央揃え] でセルのサイズに合わせて設定するサンプルコードです。

C#
VB
コピー
// B2:D5 セルにテキストボックスの文字の回転 [横書き] を設定します。
cellReport1.Cell("B2:D5").Drawing.TextVertical = AdvanceSoftware.ASReport.TextVertical.Horz;
// B2:D5 セルにテキストボックスの水平方向の文字位置 [中央揃え] を設定します。
cellReport1.Cell("B2:D5").Drawing.TextAlign = AdvanceSoftware.ASReport.TextAlign.Center;
// B2:D5 セルにテキストボックスの垂直方向の文字位置 [中央揃え] を設定します。
cellReport1.Cell("B2:D5").Drawing.TextAnchor = AdvanceSoftware.ASReport.TextAnchor.Center;
// B2:D5 セルにテキストボックス [長方形] と文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Cell("B2:D5").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Rect, "アドバンスソフトウェア");
' B2:D5 セルにテキストボックスの文字の回転 [横書き] を設定します。
CellReport1.Cell("B2:D5").Drawing.TextVertical = AdvanceSoftware.ASReport.TextVertical.Horz
' B2:D5 セルにテキストボックスの水平方向の文字位置 [中央揃え] を設定します。
CellReport1.Cell("B2:D5").Drawing.TextAlign = AdvanceSoftware.ASReport.TextAlign.Center
' B2:D5 セルにテキストボックスの垂直方向の文字位置 [中央揃え] を設定します。
CellReport1.Cell("B2:D5").Drawing.TextAnchor = AdvanceSoftware.ASReport.TextAnchor.Center
' B2:D5 セルにテキストボックス [長方形] と文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Cell("B2:D5").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Rect, "アドバンスソフトウェア")
ラインを設定する

次のコードは、B2:D5 セルにラインカラー [青] でセルのサイズに合わせてラインを設定するサンプルコードです。

C#
VB
コピー
// B2:D5 セルにラインカラー [青] を設定します。
cellReport1.Cell("B2:D5").Drawing.LineColor = System.Drawing.Color.Blue;
// B2:D5 セルにラインを設定します。
cellReport1.Cell("B2:D5").Drawing.AddLine(AdvanceSoftware.ASReport.ShapeType.Line);
' B2:D5 セルにラインカラー [青] を設定します。
CellReport1.Cell("B2:D5").Drawing.LineColor = System.Drawing.Color.Blue
' B2:D5 セルにラインを設定します。
CellReport1.Cell("B2:D5").Drawing.AddLine(AdvanceSoftware.ASReport.ShapeType.Line)
参照
メソッド・プロパティ・イベント機能一覧 (レポートコンポーネント)
セルを編集する


帳票を出力する

AS-Report 12.0 for .NET では、プレビュー、印刷、Excel、PDF 形式で帳票を出力することが可能です。ここでは、アプリケーションの種類別に帳票を出力する方法について説明します。

プレビュー画面のボタンを制御する

AS-Report 12.0 for .NET に付属の各プレビュー画面について説明します。

PDF ファイル出力時のフォントについて

PDF ファイル出力時にフォントを埋め込む方法を説明します

Windows フォーム アプリを使用する

Windows フォーム アプリで帳票を出力する方法を説明します。

WPF アプリを使用する

WPF アプリで帳票を出力する方法を説明します。

ASP.NET Core Web アプリ(MVC)を使用する

ASP.NET Core Web アプリ(MVC)で帳票を出力する方法を説明します。


プレビュー画面のボタンを制御する

このトピックでは、各ビューアのプレビュー画面をカスタマイズするための対応プロパティの一覧とプロパティが対応する設定について、説明します。プロパティは、プログラムから設定することができます。

このトピックは、次のセクションを含みます。

  • Windows フォーム用ビューア
  • WPF 用ビューア
  • Web 用ビューア
  • 参照
Windows フォーム用ビューア

Windows フォーム用ビューアで設定可能な個所は以下の通りになります。

Windows フォーム用ビューア画面

Note メモ:

Windows フォーム用ビューアのプレビュー画面で設定可能なプロパティは「ViewerControl クラス」を参照してください。
WPF 用ビューア

WPF 用ビューアで設定可能な個所は以下の通りになります。

WPF 用ビューア画面

Note メモ:

WPF 用ビューアのプレビュー画面で設定可能なプロパティは「ViewerControl クラス」を参照してください。
Web 用ビューア

Web 用ビューアで設定可能な個所は以下の通りになります。

Web 用ビューア画面

Note メモ:

Web 用ビューアのプレビュー画面で設定可能なプロパティは「Web 用ビューア」を参照してください。
参照
帳票を出力する


PDF ファイル出力時のフォントについて

PDF 出力を行う環境では、あらかじめ Excel ブック内で指定されるフォント(ファイル)を配布する必要があります。また、「ＭＳ Ｐゴシック」など他環境への配布が困難な Windows OS や Office 製品のバンドルフォントについては、「プリセットフォント機能」により制限付きでの文字出力に対応します。

このトピックは、次のセクションを含みます。

  • フォントディレクトリについて
  • フォントファイル、外字ファイルの配布時の注意点
  • プリセットフォント機能について
  • 参照
フォントディレクトリについて

Windows OS、非 Windows OS 既定のフォントディレクトリは下記の通りです。ただし、フォントディレクトリは OS のインストール方法やディストリビューション、バージョンで異なる場合があります。詳細は各 OS の技術資料をご確認ください。

各 OS のフォントディレクトリ

Windows OS | "C:\Windows\Fonts\"
非 Windows OS | "~/.fonts/" または "/usr/share/fonts/"
フォントファイル、外字ファイルの配布時の注意点

実行環境にフォントファイルを配置する場合、次の点にご注意ください。

  • 外字(EUDC.TTE)ファイルはフォントディレクトリに配置するか、EUDCFiles プロパティでの指定が必要です。EUDCFiles プロパティの使用方法は 「外字を切り替える」 をご確認ください。
  • ttf 、ttc 形式のフォントファイルに対応します。
  • フォントの配布時は、著作者に対し配布や利用条件を確認いただく必要があります。また、弊社では配布に関する内容にお答えすることはできません。
プリセットフォント機能について

プリセットフォント機能の対応フォント

プリセットフォントは、Windows 10 Version 1903 ならびに Office 2019 時点で収録されたバンドルフォントを対象としています。

プリセットフォント機能の動作

プリセットフォントの参照時は、次の仕様で出力されます。

  • 文字集合規格「Adobe-Japan1-2」に収録される文字の出力に対応します。
  • 上記の文字集合に該当しない文字は '?' で出力されます。
  • 文字の埋め込みは行われません。
  • プリセットフォント参照時の帳票出力では文字サイズを独自の仕様で算出しているため、Windows OS の帳票出力と比較し、文字間隔や位置などの描画内容が一致しない場合があります。

該当フォントが無い場合の動作

プリセットフォントを含め該当フォントがない場合は、次の仕様で出力されます。

  • 製品内部のフォントリンク情報を参照し、他のフォントでの出力を試みます。
  • 該当フォントが存在しない場合、文字種により次の文字で出力されます。
    全角文字・・・「Microsoft Sans Serif」で文字 '?' が出力されます。
    半角文字・・・「Microsoft Sans Serif」で指定文字が出力されます。
  • 文字の埋め込みは行われません。
参照
帳票を出力する
PDF 出力オプションを設定する


Windows フォーム アプリを使用する

ここでは、Windows フォーム アプリで帳票を出力する方法を説明します。

プレビューする

Windows フォーム アプリでプレビューする方法を説明します。

直接 Excel ファイルを保存する

Windows フォーム アプリで直接 Excel ファイルを保存する方法を説明します。

直接 PDF ファイルを保存する

Windows フォーム アプリで直接 PDF ファイルを保存する方法を説明します。

直接印刷する

Windows フォーム アプリで直接印刷する方法を説明します。


プレビューする

このトピックでは、Windows フォーム用ビューアを使用してプレビューする手順を説明します。以下の手順では、新規に作成した Windows フォーム アプリにレポートコンポーネント、 Windows フォーム用ビューアを追加してプレビューします。また、プレビュー画面のボタンから印刷および、Excel、PDF ファイルに保存することが可能です。

このトピックは、次のセクションを含みます。

  • プレビューする
  • プレビュー画面から Excel、PDF ファイルに保存する
  • プレビュー画面から印刷する
  • 参照
Note メモ:

プレビュー画面のボタンを制御することができます。詳細は「 プレビュー画面のボタンを制御する 」 を参照してください。

プレビューする

  1. [ファイル] - [新しいプロジェクト] から新しい Windows フォーム アプリを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにレポートコンポーネントを追加します。このセクションでは、レポートコンポーネントを [ツールボックスから追加する] 手順で追加します。

    Note メモ:

    レポートコンポーネントの追加方法は「レポートコンポーネントを追加する」を参照してください。

  4. フォームに Windows フォーム用ビューアを配置します。

    Note メモ:

    Windows フォーム用ビューアの配置方法は「Windows フォーム用ビューアを追加する」を参照してください。

  5. Windows フォーム用ビューア、フォームのサイズについてはドラッグ等で調節してください。

  6. Button1 のイベントにプロジェクトに追加したビューアを使用してプレビューする下記サンプルコードを追加します。

    C#
    VB
    コピー
    viewerControl1.Clear();
cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
    ViewerControl1.Clear()
CellReport1.Report.Start()
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document

  7. Button1 をクリックして、帳票をプレビューします。

プレビュー画面から Excel、PDF ファイルに保存する

  1. プレビュー画面の [ [image] ] ボタンをクリックします。なお、プレビューまでの手順については、[プレビューする] のセクションを参照してください。

  2. ファイルの保存ダイアログが表示されます。下記の項目を設定してファイルに保存します。

    • ファイル名
    • ファイルの種類(Excel、PDF ファイルの選択が可能)
プレビュー画面から印刷する

  1. プレビュー画面の [ [image] ] ボタンをクリックします。なお、プレビューまでの手順については、[プレビューする] のセクションを参照してください。

参照
Windows フォーム アプリを使用する


直接 Excel ファイルを保存する

このトピックでは、Windows フォーム用ビューアを使用して直接 Excel ファイルを保存する手順と、レポートコンポーネントを使用して直接 Excel ファイルを保存する手順を説明します。 以下の手順では、新規に作成した Windows フォーム アプリに Windows フォーム用ビューア、レポートコンポーネントを追加して Excel ファイルを保存します。

このトピックは、次のセクションを含みます。

  • 直接 Excel ファイルを保存する(Windows フォーム用ビューア)
  • 直接 Excel ファイルを保存する(レポートコンポーネント)
  • 参照
直接 Excel ファイルを保存する(Windows フォーム用ビューア)

  1. [ファイル] - [新しいプロジェクト] から新しい Windows フォーム アプリを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにレポートコンポーネントを追加します。このセクションでは、レポートコンポーネントを [ツールボックスから追加する] 手順で追加します。

    Note メモ:

    レポートコンポーネントの追加方法は「レポートコンポーネントを追加する」を参照してください。

  4. フォームに Windows フォーム用ビューアを配置します。

    Note メモ:

    Windows フォーム用ビューアの配置方法は 「 Windows フォーム用ビューアを追加する 」 を参照してください。

  5. Windows フォーム用ビューアをクリックし、下記のようにプロパティの値を変更します。

    プロパティ名 | 設定値
    Size | 64, 64(任意の値を設定してください)
    Visible | False

  6. Button1 のイベントに、Windows フォーム用ビューアで Excel ファイルを保存する、下記サンプルコードを追加します。

    C#
    VB
    コピー
    viewerControl1.Clear();
cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
// SaveAs メソッドで Excel ファイルを保存します。
// 引数には Excel ファイルの保存先のフルパスを設定します。
viewerControl1.SaveAs(@"C:\out.xlsx");
    ViewerControl1.Clear()
CellReport1.Report.Start()
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
' SaveAs メソッドで Excel ファイルを保存します。
' 引数には Excel ファイルの保存先のフルパスを設定します。
ViewerControl1.SaveAs("C:\out.xlsx")

  7. Button1 をクリックすると、C ドライブ直下に Excel ファイル(out.xlsx)を保存します。

直接 Excel ファイルを保存する(レポートコンポーネント)

  1. [ファイル] - [新しいプロジェクト] から新しい Windows フォーム アプリを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにレポートコンポーネントを追加します。このセクションでは、レポートコンポーネントを [ツールボックスから追加する] 手順で追加します。

    Note メモ:

    レポートコンポーネントの追加方法は「レポートコンポーネントを追加する」を参照してください。

  4. Button1 のイベントに、レポートコンポーネントで Excel ファイルを保存する、下記サンプルコードを追加します。

    C#
    VB
    コピー
    cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// SaveAs メソッドで Excel ファイルを保存します。
// 引数には Excel ファイルの保存先のフルパスを設定します。
cellReport1.Report.SaveAs(@"C:\out.xlsx");
    CellReport1.Report.Start()
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' SaveAs メソッドで Excel ファイルを保存します。
' 引数には Excel ファイルの保存先のフルパスを設定します。
CellReport1.Report.SaveAs("C:\out.xlsx")

  5. Button1 をクリックすると、C ドライブ直下に Excel ファイル(out.xlsx)を保存します。

参照
Windows フォーム アプリを使用する


直接 PDF ファイルを保存する

このトピックでは、Windows フォーム用ビューアを使用して直接 PDF ファイルを保存する手順と、レポートコンポーネントを使用して直接 PDF ファイルを保存する手順を説明します。 以下の手順では、新規に作成した Windows フォーム アプリに Windows フォーム用ビューア、レポートコンポーネントを追加して PDF ファイルを保存します。

このトピックは、次のセクションを含みます。

  • 直接 PDF ファイルを保存する(Windows フォーム用ビューア)
  • 直接 PDF ファイルを保存する(レポートコンポーネント)
  • 参照
直接 PDF ファイルを保存する(Windows フォーム用ビューア)

  1. [ファイル] - [新しいプロジェクト] から新しい Windows フォーム アプリを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにレポートコンポーネントを追加します。このセクションでは、レポートコンポーネントを [ツールボックスから追加する] 手順で追加します。

    Note メモ:

    レポートコンポーネントの追加方法は「レポートコンポーネントを追加する」を参照してください。

  4. フォームに Windows フォーム用ビューアを配置します。

    Note メモ:

    Windows フォーム用ビューアの配置方法は 「 Windows フォーム用ビューアを追加する 」 を参照してください。

  5. Windows フォーム用ビューアをクリックし、下記のようにプロパティの値を変更します。

    プロパティ名 | 設定値
    Size | 64, 64(任意の値を設定してください)
    Visible | False

  6. Button1 のイベントに、Windows フォーム用ビューアで PDF ファイルを保存する、下記サンプルコードを追加します。

    C#
    VB
    コピー
    viewerControl1.Clear();
cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
// SavePdf メソッドで PDF ファイルを保存します。
// 引数には PDF ファイルの保存先のフルパスを設定します。
viewerControl1.SavePdf(@"C:\out.pdf");
    ViewerControl1.Clear()
CellReport1.Report.Start()
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
' SavePdf メソッドで PDF ファイルを保存します。
' 引数には PDF ファイルの保存先のフルパスを設定します。
ViewerControl1.SavePdf("C:\out.pdf")

  7. Button1 をクリックすると、C ドライブ直下に PDF ファイル(out.pdf)を保存します。

直接 PDF ファイルを保存する(レポートコンポーネント)

  1. [ファイル] - [新しいプロジェクト] から新しい Windows フォーム アプリを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにレポートコンポーネントを追加します。このセクションでは、レポートコンポーネントを [ツールボックスから追加する] 手順で追加します。

    Note メモ:

    レポートコンポーネントの追加方法は「レポートコンポーネントを追加する」を参照してください。

  4. Button1 のイベントに、レポートコンポーネントで PDF ファイルを保存する、下記サンプルコードを追加します。

    C#
    VB
    コピー
    cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// SavePdf メソッドで PDF ファイルを保存します。
// 引数には PDF ファイルの保存先のフルパスを設定します。
cellReport1.Report.SavePdf(@"C:\out.pdf");
    CellReport1.Report.Start()
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' SavePdf メソッドで PDF ファイルを保存します。
' 引数には PDF ファイルの保存先のフルパスを設定します。
CellReport1.Report.SavePdf("C:\out.pdf")

  5. Button1 をクリックすると、C ドライブ直下に PDF ファイル(out.pdf)を保存します。

参照
Windows フォーム アプリを使用する


直接印刷する

このトピックでは、Windows フォーム用ビューアを使用して直接印刷する手順と、レポートコンポーネントを使用して直接印刷する手順を説明します。 以下の手順では、新規に作成した Windows フォーム アプリに Windows フォーム用ビューア、レポートコンポーネントを追加して印刷します。

このトピックは、次のセクションを含みます。

  • 直接印刷する(Windows フォーム用ビューア)
  • 直接印刷する(レポートコンポーネント)
  • 参照
直接印刷する(Windows フォーム用ビューア)

  1. [ファイル] - [新しいプロジェクト] から新しい Windows フォーム アプリを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにレポートコンポーネントを追加します。このセクションでは、レポートコンポーネントを [ツールボックスから追加する] 手順で追加します。

    Note メモ:

    レポートコンポーネントの追加方法は「レポートコンポーネントを追加する」を参照してください。

  4. フォームに Windows フォーム用ビューアを配置します。

    Note メモ:

    Windows フォーム用ビューアの配置方法は 「 Windows フォーム用ビューアを追加する 」 を参照してください。

  5. Windows フォーム用ビューアをクリックし、下記のようにプロパティの値を変更します。

    プロパティ名 | 設定値
    Size | 64, 64(任意の値を設定してください)
    Visible | False

  6. Button1 のイベントに、Windows フォーム用ビューアで印刷する、下記サンプルコードを追加します。

    C#
    VB
    コピー
    viewerControl1.Clear();
cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
// PrintOut メソッドで印刷します。
viewerControl1.PrintOut();
    ViewerControl1.Clear()
CellReport1.Report.Start()
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
' PrintOut メソッドで印刷します。
ViewerControl1.PrintOut()

  7. Button1 をクリックすると直接印刷します。

直接印刷する(レポートコンポーネント)
Note 注意:

レポートコンポーネントを使用して直接印刷を行う場合は、環境に Excel のインストールが必要です。

  1. [ファイル] - [新しいプロジェクト] から新しい Windows フォーム アプリを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにレポートコンポーネントを追加します。このセクションでは、レポートコンポーネントを [ツールボックスから追加する] 手順で追加します。

    Note メモ:

    レポートコンポーネントの追加方法は「レポートコンポーネントを追加する」を参照してください。

  4. Button1 のイベントに、レポートコンポーネントで印刷する、下記サンプルコードを追加します。

    C#
    VB
    コピー
    cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// PrintOut メソッドで印刷します。
cellReport1.Report.PrintOut("Microsoft XPS Document Writer", "1");
    CellReport1.Report.Start()
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' PrintOut メソッドで印刷します。
CellReport1.Report.PrintOut("Microsoft XPS Document Writer", "1")

  5. Button1 をクリックすると直接印刷します。

参照
Windows フォーム アプリを使用する


WPF アプリを使用する

ここでは、WPF アプリで帳票を出力する方法を説明します。

プレビューする

WPF アプリでプレビューする方法を説明します。

直接 Excel ファイルを保存する

WPF アプリで直接 Excel ファイルを保存する方法を説明します。

直接 PDF ファイルを保存する

WPF アプリで直接 PDF ファイルを保存する方法を説明します。

直接印刷する

WPF アプリで直接印刷する方法を説明します。


プレビューする

このトピックでは、WPF 用ビューアを使用してプレビューする手順を説明します。以下の手順では、新規に作成した WPF アプリにレポートコンポーネント、 WPF 用ビューアを追加してプレビューします。また、プレビュー画面のボタンから印刷および、Excel、PDF ファイルに保存することが可能です。

このトピックは、次のセクションを含みます。

  • プレビューする
  • プレビュー画面から Excel、PDF ファイルに保存する
  • プレビュー画面から印刷する
  • 参照
Note メモ:

プレビュー画面のボタンを制御することができます。詳細は「 プレビュー画面のボタンを制御する 」 を参照してください。

プレビューする

  1. [ファイル] - [新しいプロジェクト] から新しい WPF アプリを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにレポートコンポーネントを追加します。このセクションでは、レポートコンポーネントを [ツールボックスから追加する] 手順で追加します。

    Note メモ:

    レポートコンポーネントの追加方法は「レポートコンポーネントを追加する」を参照してください。

  4. フォームに WPF 用ビューアを配置します。

    Note メモ:

    WPF 用ビューアの配置方法は「WPF 用ビューアを追加する」を参照してください。

  5. WPF 用ビューア、フォームのサイズについてはドラッグ等で調節してください。

  6. Button1 のイベントにプロジェクトに追加したビューアを使用してプレビューする下記サンプルコードを追加します。

    C#
    VB
    コピー
    viewerControl1.Clear();
cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
    ViewerControl1.Clear()
CellReport1.Report.Start()
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document

  7. Button1 をクリックして、帳票をプレビューします。

プレビュー画面から Excel、PDF ファイルに保存する

  1. プレビュー画面の [ [image] ] ボタンをクリックします。なお、プレビューまでの手順については、[プレビューする] のセクションを参照してください。

  2. ファイルの保存ダイアログが表示されます。下記の項目を設定してファイルに保存します。

    • ファイル名
    • ファイルの種類(Excel、PDF ファイルの選択が可能)
プレビュー画面から印刷する

  1. プレビュー画面の [ [image] ] ボタンをクリックします。なお、プレビューまでの手順については、[プレビューする] のセクションを参照してください。

参照
WPF アプリを使用する


直接 Excel ファイルを保存する

このトピックでは、WPF 用ビューアを使用して直接 Excel ファイルを保存する手順と、レポートコンポーネントを使用して直接 Excel ファイルを保存する手順を説明します。 以下の手順では、新規に作成した WPF アプリに WPF 用ビューア、レポートコンポーネントを追加して Excel ファイルを保存します。

このトピックは、次のセクションを含みます。

  • 直接 Excel ファイルを保存する(WPF 用ビューア)
  • 直接 Excel ファイルを保存する(レポートコンポーネント)
  • 参照
直接 Excel ファイルを保存する(WPF 用ビューア)

  1. [ファイル] - [新しいプロジェクト] から新しい WPF アプリを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにレポートコンポーネントを追加します。このセクションでは、レポートコンポーネントを [参照の追加] から追加する手順で追加します。

    Note メモ:

    レポートコンポーネントの追加方法は 「 レポートコンポーネントを追加する 」 を参照してください。

  4. フォームに WPF 用ビューアを配置します。

    Note メモ:

    WPF 用ビューアの配置方法は 「 WPF 用ビューアを追加する 」 を参照してください。

  5. WPF 用ビューアをクリックし、下記のようにプロパティの値を変更します。

    プロパティ名 | 設定値
    Height | 40(任意の値を設定してください)
    Width | 40(任意の値を設定してください)
    Visibility | Collapsed

  6. Button1 のイベントに、WPF 用ビューアで Excel ファイルを保存する、下記サンプルコードを追加します。

    C#
    VB
    コピー
    viewerControl1.Clear();
cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
// SaveAs メソッドで Excel ファイルを保存します。
// 引数には Excel ファイルの保存先のフルパスを設定します。
viewerControl1.SaveAs(@"C:\out.xlsx");
    ViewerControl1.Clear()
CellReport1.Report.Start()
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
' SaveAs メソッドで Excel ファイルを保存します。
' 引数には Excel ファイルの保存先のフルパスを設定します。
ViewerControl1.SaveAs("C:\out.xlsx")

  7. Button1 をクリックすると、C ドライブ直下に Excel ファイル(out.xlsx)を保存します。

直接 Excel ファイルを保存する(レポートコンポーネント)

  1. [ファイル] - [新しいプロジェクト] から新しい WPF アプリを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにレポートコンポーネントを追加します。このセクションでは、レポートコンポーネントを [ツールボックスから追加する] 手順で追加します。

    Note メモ:

    レポートコンポーネントの追加方法は「レポートコンポーネントを追加する」を参照してください。

  4. Button1 のイベントに、レポートコンポーネントで Excel ファイルを保存する、下記サンプルコードを追加します。

    C#
    VB
    コピー
    cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// SaveAs メソッドで Excel ファイルを保存します。
// 引数には Excel ファイルの保存先のフルパスを設定します。
cellReport1.Report.SaveAs(@"C:\out.xlsx");
    CellReport1.Report.Start()
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' SaveAs メソッドで Excel ファイルを保存します。
' 引数には Excel ファイルの保存先のフルパスを設定します。
CellReport1.Report.SaveAs("C:\out.xlsx")

  5. Button1 をクリックすると、C ドライブ直下に Excel ファイル(out.xlsx)を保存します。

参照
WPF アプリを使用する


直接 PDF ファイルを保存する

このトピックでは、WPF 用ビューアを使用して直接 PDF ファイルを保存する手順と、レポートコンポーネントを使用して直接 PDF ファイルを保存する手順を説明します。 以下の手順では、新規に作成した WPF アプリに WPF 用ビューア、レポートコンポーネントを追加して PDF ファイルを保存します。

このトピックは、次のセクションを含みます。

  • 直接 PDF ファイルを保存する(WPF 用ビューア)
  • 直接 PDF ファイルを保存する(レポートコンポーネント)
  • 参照
直接 PDF ファイルを保存する(WPF 用ビューア)

  1. [ファイル] - [新しいプロジェクト] から新しい WPF アプリを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにレポートコンポーネントを追加します。このセクションでは、レポートコンポーネントを [参照の追加] から追加する手順で追加します。

    Note メモ:

    レポートコンポーネントの追加方法は 「 レポートコンポーネントを追加する 」 を参照してください。

  4. フォームに WPF 用ビューアを配置します。

    Note メモ:

    WPF 用ビューアの配置方法は 「 WPF 用ビューアを追加する 」 を参照してください。

  5. WPF 用ビューアをクリックし、下記のようにプロパティの値を変更します。

    プロパティ名 | 設定値
    Height | 40(任意の値を設定してください)
    Width | 40(任意の値を設定してください)
    Visibility | Collapsed

  6. Button1 のイベントに、WPF 用ビューアで PDF ファイルを保存する、下記サンプルコードを追加します。

    C#
    VB
    コピー
    viewerControl1.Clear();
cellReport1.Report.Start(ReportMode.Speed);
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
// SavePdf メソッドで PDF ファイルを保存します。
// 引数には PDF ファイルの保存先のフルパスを設定します。
viewerControl1.SavePdf(@"C:\out.pdf");
    ViewerControl1.Clear()
CellReport1.Report.Start(ReportMode.Speed)
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
' SavePdf メソッドで PDF ファイルを保存します。
' 引数には PDF ファイルの保存先のフルパスを設定します。
ViewerControl1.SavePdf("C:\out.pdf")

  7. Button1 をクリックすると、C ドライブ直下に PDF ファイル(out.pdf)を保存します。

直接 PDF ファイルを保存する(レポートコンポーネント)

  1. [ファイル] - [新しいプロジェクト] から新しい WPF アプリを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにレポートコンポーネントを追加します。このセクションでは、レポートコンポーネントを [ツールボックスから追加する] 手順で追加します。

    Note メモ:

    レポートコンポーネントの追加方法は「レポートコンポーネントを追加する」を参照してください。

  4. Button1 のイベントに、レポートコンポーネントで PDF ファイルを保存する、下記サンプルコードを追加します。

    C#
    VB
    コピー
    cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// SavePdf メソッドで PDF ファイルを保存します。
// 引数には PDF ファイルの保存先のフルパスを設定します。
cellReport1.Report.SavePdf(@"C:\out.pdf");
    CellReport1.Report.Start()
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' SavePdf メソッドで PDF ファイルを保存します。
' 引数には PDF ファイルの保存先のフルパスを設定します。
CellReport1.Report.SavePdf("C:\out.pdf")

  5. Button1 をクリックすると、C ドライブ直下に PDF ファイル(out.pdf)を保存します。

参照
WPF アプリを使用する


直接印刷する

このトピックでは、WPF 用ビューアを使用して直接印刷する手順と、レポートコンポーネントを使用して直接印刷する手順を説明します。 以下の手順では、新規に作成した WPF アプリに WPF 用ビューア、レポートコンポーネントを追加して印刷します。

このトピックは、次のセクションを含みます。

  • 直接印刷する(WPF 用ビューア)
  • 直接印刷する(レポートコンポーネント)
  • 参照
直接印刷する(WPF 用ビューア)

  1. [ファイル] - [新しいプロジェクト] から新しい WPF アプリを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにレポートコンポーネントを追加します。このセクションでは、レポートコンポーネントを [参照の追加] から追加する手順で追加します。

    Note メモ:

    レポートコンポーネントの追加方法は 「 レポートコンポーネントを追加する 」 を参照してください。

  4. フォームに WPF 用ビューアを配置します。

    Note メモ:

    WPF 用ビューアの配置方法は 「 WPF 用ビューアを追加する 」 を参照してください。

  5. WPF 用ビューアをクリックし、下記のようにプロパティの値を変更します。

    プロパティ名 | 設定値
    Height | 40(任意の値を設定してください)
    Width | 40(任意の値を設定してください)
    Visibility | Collapsed

  6. Button1 のイベントに、WPF 用ビューアで印刷する、下記サンプルコードを追加します。

    C#
    VB
    コピー
    viewerControl1.Clear();
cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
//PrintOut メソッドで印刷します。
viewerControl1.PrintOut();
    ViewerControl1.Clear()
CellReport1.Report.Start()
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
' PrintOut メソッドで印刷します。
viewerControl1.PrintOut()

  7. Button1 をクリックすると直接印刷します。

直接印刷する(レポートコンポーネント)
Note 注意:

レポートコンポーネントを使用して直接印刷を行う場合は、環境に Excel のインストールが必要です。

  1. [ファイル] - [新しいプロジェクト] から新しい WPF アプリを作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにレポートコンポーネントを追加します。このセクションでは、レポートコンポーネントを [ツールボックスから追加する] 手順で追加します。

    Note メモ:

    レポートコンポーネントの追加方法は「レポートコンポーネントを追加する」を参照してください。

  4. Button1 のイベントに、レポートコンポーネントで印刷する、下記サンプルコードを追加します。

    C#
    VB
    コピー
    cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// PrintOut メソッドで印刷します。
cellReport1.Report.PrintOut("Microsoft XPS Document Writer", "1");
    CellReport1.Report.Start()
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' PrintOut メソッドで印刷します。
CellReport1.Report.PrintOut("Microsoft XPS Document Writer", "1")

  5. Button1 をクリックすると直接印刷します。

参照
WPF アプリを使用する


ASP.NET Core Web アプリ(MVC)を使用する

ここでは、ASP.NET Core Web アプリ(MVC)で帳票を出力する方法を説明します。

プレビューする

ASP.NET Core Web アプリ(MVC)でプレビューする方法を説明します。

直接 Excel ファイルを保存する

ASP.NET Core Web アプリ(MVC)で直接 Excel ファイルを保存する方法を説明します。

直接 PDF ファイルを保存する

ASP.NET Core Web アプリ(MVC)で直接 PDF ファイルを保存する方法を説明します。

直接印刷する

ASP.NET Core Web アプリ(MVC)で直接印刷する方法を説明します。


プレビューする

このトピックでは、Web 用ビューアを使用してプレビューする手順を説明します。以下の手順では、新規に作成した ASP.NET Core Web アプリ(MVC)に Web 用ビューア、レポートコンポーネントを追加してプレビューします。また、プレビュー画面のボタンから印刷および、Excel、PDF ファイルに保存することが可能です。

このトピックは、次のセクションを含みます。

  • プレビューする
  • プレビュー画面から Excel、PDF ファイルに保存する
  • プレビュー画面から印刷する
  • 参照
Note メモ:

プレビュー画面のボタンを制御することができます。詳細は「プレビュー画面のボタンを制御する」を参照してください。

プレビューする

  1. [ファイル] - [新しいプロジェクト] から新しい ASP.NET Core Web アプリ(MVC)を作成します。

  2. モデル、またはコントローラにレポートコンポーネントを追加します。

    Note メモ:

    レポートコンポーネントの追加方法は「レポートコンポーネントを追加する」を参照してください。

  3. モデル、またはコントローラのコードを開き、ビューに対応したメソッド内にレポートコンポーネントで帳票ドキュメントを作成して SVGZ 形式で取得する、下記サンプルコードを追加します。

    C#
    コピー
    AdvanceSoftware.ASReport.CellReport cellReport1 = new AdvanceSoftware.ASReport.CellReport();
// 帳票作成処理
cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// SVGZ 形式で帳票ドキュメントを取得します。
string reportDocument = cellReport1.Report.GetSvgzReport(
    AdvanceSoftware.ASReport.SvgSaveType.IncludeExcelPdf);
ViewData["document"] = reportDocument;

return View();

  4. ビューに Web 用ビューアを追加します。

    Note メモ:

    Web 用ビューアの追加方法は「Web 用ビューアを追加する」を参照してください。

  5. ビューにビューア表示用の HTML コードとスクリプトを追加します。

    HTML
    コピー
    <!--帳票ドキュメント格納用のDIV要素(id="documentcontainer")を用意。ViewData で帳票ドキュメントを挿入-->
<div id="documentcontainer" style="display:none;">
    @Html.Raw(ViewData["document"])
</div>

<!--ビューア配置用のDIV要素(id="viewercontainer")を用意。width、height でサイズ指定-->
<div id="viewercontainer" style="width:100%;height:650px;">
</div>

<!--ビューアの表示とプレビュー実行-->
<script type="text/javascript">
$(function() {
    // ビューアを id名[viewercontainer] の DIV 要素に表示
    viewer = new CellReport.Viewer('viewercontainer');
    // id名[documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込み、プレビューを実施
    viewer.report('documentcontainer');
});
</script>

  6. アプリケーションを実行し、プレビューをします。

プレビュー画面から Excel、PDF ファイルに保存する

  1. プレビュー画面の [ [image] ] ボタンをクリックします。なお、プレビューまでの手順については、「プレビューする」のセクションを参照してください。

  2. Excel ファイル保存 [ [image] ]、PDF ファイル保存 [ [image]] のアイコンが表示されるので、出力ファイルのボタンをクリックしファイルを保存します。

プレビュー画面から印刷する

  1. プレビュー画面の [ [image] ] ボタンをクリックします。なお、プレビューまでの手順については、「プレビューする」のセクションを参照してください。

  2. 全ページ印刷 [ [image] ]、現在のページ印刷 [ [image] ] のアイコンが表示されるので、印刷を行うページのボタンをクリックします。

  3. 印刷ダイアログで出力プリンタを選択し、[印刷] ボタンをクリックすると印刷することが可能です。

    Note メモ:

    用紙設定はブラウザの [ページ設定] から設定する必要があります。
参照
ASP.NET Core Web アプリ(MVC)を使用する


直接 Excel ファイルを保存する

このトピックでは、Web 用ビューアを使用して直接 Excel ファイルを保存する手順と、レポートコンポーネントを使用して直接 Excel ファイルを保存する手順を説明します。以下の手順では、新規に作成した ASP.NET Core Web アプリ(MVC)に Web 用ビューア、レポートコンポーネントを追加して Excel ファイルを保存します。

このトピックは、次のセクションを含みます。

  • 直接 Excel ファイルを保存する(Web 用ビューア)
  • 直接 Excel ファイルを保存する(レポートコンポーネント)
  • 参照
直接 Excel ファイルを保存する(Web 用ビューア)

  1. [ファイル] - [新しいプロジェクト] から新しい ASP.NET Core Web アプリ(MVC)を作成します。

  2. モデル、またはコントローラにレポートコンポーネントを追加します。

    Note メモ:

    レポートコンポーネントの追加方法は「レポートコンポーネントを追加する」を参照してください。

  3. モデル、またはコントローラのコードを開き、ビューに対応したメソッド内にレポートコンポーネントで帳票ドキュメントを作成して SVGZ 形式で取得する、下記サンプルコードを追加します。

    C#
    コピー
    AdvanceSoftware.ASReport.CellReport cellReport1 = new AdvanceSoftware.ASReport.CellReport();
// 帳票作成処理
cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// SVGZ 形式で帳票ドキュメントを取得します。
string reportDocument = cellReport1.Report.GetSvgzReport(
    AdvanceSoftware.ASReport.SvgSaveType.IncludeExcelPdf);
ViewData["document"] = reportDocument;

return View();

  4. ビューに Web 用ビューアを追加します。

    Note メモ:

    Web 用ビューアの追加方法は「Web 用ビューアを追加する」を参照してください。

  5. ビューにビューア配置用の DIV 要素 (id="viewercontainer") の style を非表示 (display:none) を設定した HTML コードと Excel ファイルの保存を行うスクリプトを追加します。

    HTML
    コピー
    <!--帳票ドキュメント格納用のDIV要素(id="documentcontainer")を用意。ViewData で帳票ドキュメントを挿入-->
<div id="documentcontainer" style="display:none;">
    @Html.Raw(ViewData["document"])
</div>

<!--ビューア配置用の DIV 要素(id="viewercontainer")を用意し、ビューア非表示に設定する。-->
<div id="viewercontainer" style="display:none;">
</div>

<!--ビューアの表示と Excel ファイルの保存を実行-->
<script type="text/javascript">
$(function() {
    // ビューアを id名[viewercontainer] の DIV 要素に表示
    viewer = new CellReport.Viewer('viewercontainer');
    // プレビュー表示後に Excel ファイル保存のコールバックメソッドを記述
    var resovle = function () { viewer.saveExcel(); };
    // id名[documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込む
    viewer.report('documentcontainer', resovle);
});
</script>

  6. アプリケーションを実行し、Excel を保存します。

直接 Excel ファイルを保存する(レポートコンポーネント)

  1. [ファイル] - [新しいプロジェクト] から新しい ASP.NET Core Web アプリ(MVC)を作成します。

  2. モデル、またはコントローラにレポートコンポーネントを追加します。

    Note メモ:

    レポートコンポーネントの追加方法は「レポートコンポーネントを追加する」を参照してください。

  3. モデル、またはコントローラのコードを開き、レポートコンポーネントで Excel ファイルを出力する下記サンプルコードを追加します。

    C#
    コピー
    // インスタンスを生成
AdvanceSoftware.ASReport.CellReport cellReport1 = new AdvanceSoftware.ASReport.CellReport();
// 帳票作成処理
cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// Excel ファイルを excelStream に出力
System.IO.MemoryStream excelStream = new System.IO.MemoryStream();
cellReport1.Report.SaveAs(excelStream);

return File(excelStream.ToArray(), "application/vnd.openxmlformats-officedocument.spreadsheetml.sheet", "out.xlsx");

  4. アプリケーションを実行し、Excel ファイルを保存します。

参照
ASP.NET Core Web アプリ(MVC)を使用する


直接 PDF ファイルを保存する

このトピックでは、Web 用ビューアを使用して直接 PDF ファイルを保存する手順と、レポートコンポーネントを使用して直接 PDF ファイルを保存する手順を説明します。以下の手順では、新規に作成した ASP.NET Core Web アプリ(MVC)に Web 用ビューア、レポートコンポーネントを追加して PDF ファイルを保存します。

このトピックは、次のセクションを含みます。

  • 直接 PDF ファイルを保存する(Web 用ビューア)
  • 直接 PDF ファイルを保存する(レポートコンポーネント)
  • 参照
直接 PDF ファイルを保存する(Web 用ビューア)

  1. [ファイル] - [新しいプロジェクト] から新しい ASP.NET Core Web アプリ(MVC)を作成します。

  2. モデル、またはコントローラにレポートコンポーネントを追加します。

    Note メモ:

    レポートコンポーネントの追加方法は「レポートコンポーネントを追加する」を参照してください。

  3. モデル、またはコントローラのコードを開き、ビューに対応したメソッド内にレポートコンポーネントで帳票ドキュメントを作成して SVGZ 形式で取得する、下記サンプルコードを追加します。

    C#
    コピー
    AdvanceSoftware.ASReport.CellReport cellReport1 = new AdvanceSoftware.ASReport.CellReport();
// 帳票作成処理
cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// SVGZ 形式で帳票ドキュメントを取得します。
string reportDocument = cellReport1.Report.GetSvgzReport(
    AdvanceSoftware.ASReport.SvgSaveType.IncludeExcelPdf);
ViewData["document"] = reportDocument;

return View();

  4. ビューに Web 用ビューアを追加します。

    Note メモ:

    Web 用ビューアの追加方法は「Web 用ビューアを追加する」を参照してください。

  5. ビューにビューア配置用の DIV 要素 (id="viewercontainer") の style を非表示 (display:none) を設定した HTML コードと PDF ファイルの保存を行うスクリプトを追加します。

    HTML
    コピー
    <!--帳票ドキュメント格納用のDIV要素(id="documentcontainer")を用意。ViewData で帳票ドキュメントを挿入-->
<div id="documentcontainer" style="display:none;">
    @Html.Raw(ViewData["document"])
</div>

<!--ビューア配置用の DIV 要素(id="viewercontainer")を用意し、ビューア非表示に設定する。-->
<div id="viewercontainer" style="display:none;">
</div>

<!--ビューアの表示と PDF ファイルの保存を実行-->
<script type="text/javascript">
$(function() {
    // ビューアを id名[viewercontainer] の DIV 要素に表示
    viewer = new CellReport.Viewer('viewercontainer');
    // プレビュー表示後に PDF ファイル保存のコールバックメソッドを記述
    var resovle = function () { viewer.savePdf(); };
    // id名[documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込む
    viewer.report('documentcontainer', resovle);
});
</script>

  6. アプリケーションを実行し、PDF ファイルを保存します。

直接 PDF ファイルを保存する(レポートコンポーネント)

  1. [ファイル] - [新しいプロジェクト] から新しい ASP.NET Cor Web アプリ(MVC)を作成します。

  2. モデル、またはコントローラにレポートコンポーネントを追加します。

    Note メモ:

    レポートコンポーネントの追加方法は「レポートコンポーネントを追加する」を参照してください。

  3. モデル、またはコントローラのコードを開き、レポートコンポーネントで PDF ファイルを出力する下記サンプルコードを追加します。

    C#
    コピー
    // インスタンスを生成
AdvanceSoftware.ASReport.CellReport cellReport1 = new AdvanceSoftware.ASReport.CellReport();
// 帳票作成処理
cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// PDF ファイルを pdfStream に出力
System.IO.MemoryStream pdfStream = new System.IO.MemoryStream();
cellReport1.Report.SavePdf(pdfStream);

return File(pdfStream.ToArray(), "application/pdf");

  4. アプリケーションを実行し、PDF ファイルを保存します。

参照
ASP.NET Core Web アプリ(MVC)を使用する


直接印刷する

このトピックでは、Web 用ビューアを使用して直接印刷する手順を説明します。以下の手順では、新規に作成した ASP.NET Core Web アプリ(MVC)に Web 用ビューア、レポートコンポーネントを追加して 印刷します。

このトピックは、次のセクションを含みます。

  • 直接印刷をする(Web 用ビューア)
  • 参照
直接印刷をする(Web 用ビューア)
Note 注意:

ASP.NET Core Web アプリ(MVC) でのレポートコンポーネントからの直接印刷は未対応です。
Note メモ:

ASP.NET MVC 用ビューアの印刷はブラウザの印刷機能で行われるため、製品によるブラウザの印刷プレビューの表示/非表示は制御できません。

  1. [ファイル] - [新しいプロジェクト] から新しい ASP.NET Core Web アプリ(MVC)を作成します。

  2. モデル、またはコントローラにレポートコンポーネントを追加します。

    Note メモ:

    レポートコンポーネントの追加方法は「レポートコンポーネントを追加する」を参照してください。

  3. モデル、またはコントローラのコードを開き、ビューに対応したメソッド内にレポートコンポーネントで帳票ドキュメントを作成して SVGZ 形式で取得する、下記サンプルコードを追加します。

    C#
    コピー
    AdvanceSoftware.ASReport.CellReport cellReport1 = new AdvanceSoftware.ASReport.CellReport();
// 帳票作成処理
cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// SVGZ 形式で帳票ドキュメントを取得します。
string reportDocument = cellReport1.Report.GetSvgzReport
(AdvanceSoftware.ASReport.SvgSaveType.IncludeExcelPdf);
ViewData["document"] = reportDocument;

return View();

  4. ビューに Web 用ビューアを追加します。

    Note メモ:

    Web 用ビューアの追加方法は「Web 用ビューアを追加する」を参照してください。

  5. ビューにビューア配置用の DIV 要素(id="viewercontainer")の style を非表示(display:none)を設定した HTML コードと印刷を行うスクリプトを追加します。

    HTML
    コピー
    <!--帳票ドキュメント格納用のDIV要素(id="documentcontainer")を用意。ViewData で帳票ドキュメントを挿入-->
<div id="documentcontainer" style="display:none;">
    @Html.Raw(ViewData["document"])
</div>

<!--ビューア配置用の DIV 要素(id="viewercontainer")を用意し、ビューア非表示に設定する。-->
<div id="viewercontainer" style="display:none;">
</div>

<!--ビューアの表示と印刷を実行-->
<script type="text/javascript">
$(function() {
    // ビューアを id名[viewercontainer] の DIV 要素に表示
    viewer = new CellReport.Viewer('viewercontainer');
    // プレビュー表示後に印刷するコールバックメソッドを記述
    var resovle = function () { viewer.print(); };
    // id名[documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込む
    viewer.report('documentcontainer', resovle);
});
</script>

  6. アプリケーションを実行し、印刷を行います。

参照
ASP.NET Core Web アプリ(MVC)を使用する


PDF 出力オプションを設定する

AS-Report 12.0 for .NET では、出力 PDF ファイルのプロパティ、外字の埋め込みを設定することが可能です。ここでは、各オプションの設定方法について説明します。

文書のプロパティを設定する

出力 PDF ファイルのプロパティを設定する方法を説明します。

外字を切り替える

出力 PDF ファイルの外字を切り替える方法を説明します。


文書のプロパティを設定する

AS-Report 12.0 for .NET では、出力する PDF ファイルのプロパティを設定することが可能です。このトピックでは、PDF ファイルのプロパティを設定する方法を説明します。

このトピックは、次のセクションを含みます。

  • ファイルの概要、詳細情報を設定する
  • 文書のセキュリティを設定する
  • フォントを埋め込む
  • 参照
ファイルの概要、詳細情報を設定する

このセクションでは、概要タブの情報を設定する方法を説明します。

次のコードは、「タイトル」、「作成者」、「サブタイトル」、「アプリケーション」、「PDF 変換」項目を設定するサンプルコードです。

C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Page.End();
// タイトルを設定します。
cellReport1.Pdf.Title = "サンプル文書";
// 作成者を設定します。
cellReport1.Pdf.Author = "AdvanceSoftware corp.";
// サブタイトルを設定します。
cellReport1.Pdf.Subject = "AS-Report 12.0 for .NET で出力した PDF ファイルです。";
// アプリケーションを設定します。
cellReport1.Pdf.Application = "Sample Application";
// PDF 変換を設定します。
cellReport1.Pdf.Producer = "AS-Report 12.0 for .NET";
cellReport1.Report.End();
cellReport1.Report.SavePdf(@"C:\out1.pdf");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Page.End()
' タイトルを設定します。
CellReport1.Pdf.Title = "サンプル文書"
' 作成者を設定します。
CellReport1.Pdf.Author = "AdvanceSoftware corp."
' サブタイトルを設定します。
CellReport1.Pdf.Subject = "AS-Report 12.0 for .NET で出力した PDF ファイルです。"
' アプリケーションを設定します。
CellReport1.Pdf.Application = "Sample Application"
' PDF 変換を設定します。
CellReport1.Pdf.Producer = "AS-Report 12.0 for .NET"
CellReport1.Report.End()
CellReport1.Report.SavePdf("C:\Out1.pdf")
文書のセキュリティを設定する

このセクションでは、セキュリティタブの情報を設定する方法を説明します。

次のコードは、暗号化レベル「Acrobat6_RC4_128」でオーナーパスワードを "owner"、ユーザーパスワードを "user" に設定し、「高解像度印刷」と「内容のコピー」を許可するサンプルコードです。

C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Page.End();
// 暗号化レベルを [128-bit RC4] に設定します。
cellReport1.Pdf.EncryptionType = AdvanceSoftware.ASReport.PdfEncryptionType.Acrobat6_RC4_128;
// オーナーパスワード(owner)、ユーザーパスワード(user)を設定します。
cellReport1.Pdf.OwnerPassword = "owner";
cellReport1.Pdf.UserPassword = "user";
// PDF ファイルの権限で [高精度な印刷] と [内容のコピー] の許可を設定します。
AdvanceSoftware.ASReport.PdfPermit pdfPermit = 0;
pdfPermit = pdfPermit | AdvanceSoftware.ASReport.PdfPermit.PrintHigh | AdvanceSoftware.ASReport.PdfPermit.Copy;
cellReport1.Pdf.Permit = pdfPermit;
cellReport1.Report.End();
cellReport1.Report.SavePdf(@"C:\out1.pdf");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Page.End()
' 暗号化レベルを [128-bit RC4] に設定します。
CellReport1.Pdf.EncryptionType = AdvanceSoftware.ASReport.PdfEncryptionType.Acrobat6_RC4_128
' オーナーパスワード(owner)、ユーザーパスワード(user)を設定します。
CellReport1.Pdf.OwnerPassword = "owner"
CellReport1.Pdf.UserPassword = "user"
' PDF ファイルの権限で [高精度な印刷] と [内容のコピー] の許可を設定します。
Dim pdfPermit As AdvanceSoftware.ASReport.PdfPermit = 0
pdfPermit = pdfPermit Or AdvanceSoftware.ASReport.PdfPermit.PrintHigh Or AdvanceSoftware.ASReport.PdfPermit.Copy
CellReport1.Pdf.Permit = pdfPermit
CellReport1.Report.End()
CellReport1.Report.SavePdf("C:\Out1.pdf")
フォントを埋め込む

このセクションでは、PDF ファイルにフォントを埋め込む方法を説明します。

次のコードは、EmbedFonts プロパティで「メイリオ」フォントを埋め込むサンプルコードです。

C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Page.End();
// [メイリオ] フォントを埋め込みます。
cellReport1.Pdf.EmbedFonts = new String[] { "メイリオ" };
cellReport1.Report.End();
cellReport1.Report.SavePdf(@"C:\out1.pdf");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Page.End()
' [メイリオ] フォントを埋め込みます。
CellReport1.Pdf.EmbedFonts = New String () { "メイリオ" }
CellReport1.Report.End()
CellReport1.Report.SavePdf("C:\Out1.pdf")
Note メモ:

"*" を設定した場合、使用しているフォントを全て埋め込みます。
参照
メソッド・プロパティ・イベント機能一覧 (レポートコンポーネント)
PDF ファイル出力時のフォントについて
PDF 出力オプションを設定する


外字を切り替える

AS-Report 12.0 for .NET では、PDF ファイルの外字を切り替えることができます。また、外字ファイルはフォント毎に指定することもできます。このトピックでは外字の切り替え方法を説明します。

このトピックは、次のセクションを含みます。

  • 外字を切り替えるには
  • フォントファイル配布時の注意点
  • サンプルコード
  • 参照
外字を切り替えるには

EUDCFiles プロパティを使用して外字の切り替えが可能です。EUDCFiles プロパティには第 1 要素に「フォント名」、第 2 要素に「ファイルパス」の String 配列をリストで格納します。また、第 1 要素と第 2 要素の組み合わせによって、フォントごとに外字ファイルを切り替えたり、環境の外字設定を読み込まない等の設定ができます。

組み合わせのパターンは下記の通りです。

第 1 要素 (フォント名) | 動作
特定のフォント名 | このフォントに対して、ファイルパスに設定した外字ファイルを参照します。また、環境の同一フォントの設定は無視されます。
SystemDefaultEUDCFont | 全てのフォントに対して、ファイルパスに設定した外字ファイルを参照します。また、環境のデフォルトの設定は無視されます。
空文字 ("") | 環境の全ての外字設定は無視されます。
第 2 要素 (ファイルパス) | 動作
存在するファイルパス | 指定したフォントに対して、このパスの外字ファイルが取り込まれます。また、環境の同一フォントの設定は無視されます。
存在しないファイルパス | 指定したフォントに対して、外字の設定は無視されます。また、環境に同一フォントの設定がある場合、環境の設定が読み込まれます。
空文字 ("") | 指定したフォントに対して、外字の設定は無視されます。また、環境の同一フォントの設定は無視されます。
フォントファイル配布時の注意点

PDF ファイル出力を行う環境では、あらかじめ Excel ブック内で指定されるフォントファイルを配布する必要があります。
詳細は、「PDF ファイル出力時のフォントについて」をご確認ください。

サンプルコード

次のコードは、環境の外字設定を無視して、"ＭＳ Ｐゴシック" に対して Gaiji1.tte、"ＭＳ 明朝" に対して Gaiji2.tte の外字ファイルを取り込むサンプルコードです。

C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Page.End();
// 環境の外字設定を無視して、"ＭＳ Ｐゴシック" の外字を指定します。
cellReport1.Pdf.EUDCFiles = new string[][] { new string[] { "", "" }, new string[] { "ＭＳ Ｐゴシック", @"C:\Gaiji1.tte" }, new string[] { "ＭＳ 明朝", @"C:\Gaiji2.tte" } };
cellReport1.Report.End();
cellReport1.Report.SavePdf(@"C:\out1.pdf");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Page.End()
' 環境の外字設定を無視して、"ＭＳ Ｐゴシック" の外字を指定します。
CellReport1.Pdf.EUDCFiles = New String()() {New String() {"", ""}, New String() {"ＭＳ Ｐゴシック", "C:\Gaiji1.tte"}, New String() {"ＭＳ 明朝", "C:\Gaiji2.tte"}}
CellReport1.Report.End()
CellReport1.Report.SavePdf("C:\Out1.pdf")
参照
メソッド・プロパティ・イベント機能一覧 (レポートコンポーネント)
PDF ファイル出力時のフォントについて
PDF 出力オプションを設定する


バーコードを設定する

AS-Report 12.0 for .NET では、バーコードコンポーネントを使用して JAN、GS1-128、カスタマバーコード、QR コードなどのバーコードイメージを作成することが可能です。ここでは、作成可能なバーコードの種類やバーコードイメージの作成方法などを説明します。

バーコードコンポーネントで作成可能なバーコードの種類

バーコードコンポーネントで作成可能なバーコードの種類を説明します。

バーコードタイプ別の作成方法

バーコードタイプ別の作成方法を説明します。

バーコード付き帳票の作成方法

バーコードコンポーネントとレポートコンポーネントを使用して、バーコード付き帳票の作成方法を説明します。


バーコードコンポーネントで作成可能なバーコードの種類

バーコードコンポーネントでは、JAN、GS1-128、カスタマバーコード、QR コードなどのバーコードイメージを作成することが可能です。作成したバーコードイメージは、帳票ドキュメントに挿入してバーコード付きの帳票として出力することができます。バーコードコンポーネントの対応バーコードを次に示します。

このトピックは、次のセクションを含みます。

  • JAN コード
  • UPC コード
  • ITF コード
  • Codabar (NW-7)
  • Code39
  • Code128
  • GS1-128 (旧称 : UCC/EAN128)
  • 公共料金等代理収納 GS1-128
  • カスタマバーコード
  • QR コード
  • PDF417
  • 参照
JAN コード

JAN13 (標準バージョン 13 桁)

JAN8 (短縮バージョン 8 桁)

UPC コード

UPC-A (A バージョン)

UPC-E (E バージョン)

ITF コード

ITF-6 (アドオンバージョン 6 桁)

ITF-14 (標準バージョン 14 桁)

ITF-16 (拡張バージョン 16 桁)

ITF (自由桁)

Codabar (NW-7)

Codabar

Code39

Code39

Code128

Code128

GS1-128 (旧称 : UCC/EAN128)

GS1-128

公共料金等代理収納 GS1-128

公共料金等代理収納 GS1-128

カスタマバーコード

カスタマバーコード

QR コード

モデル1

モデル2

「QR コード」は、株式会社デンソーウェーブの登録商標です。

PDF417

標準

簡易

参照
バーコードを設定する


バーコードタイプ別の作成方法

ここでは、AS-Report 12.0 for .NET のバーコードタイプ別の作成方法について説明します。

JAN コードを作成する

JAN コードを作成する方法を説明します。

UPC コードを作成する

UPC コードを作成する方法を説明します。

ITF コードを作成する

ITF コードを作成する方法を説明します。

Codabar (NW-7) を作成する

Codabar (NW-7) を作成する方法を説明します。

Code39 を作成する

Code39 を作成する方法を説明します。

Code128 を作成する

Code128 を作成する方法を説明します。

GS1-128 (旧称 : UCC/EAN128) を作成する

GS1-128 (旧称 : UCC/EAN128) を作成する方法を説明します。

公共料金等代理収納 GS1-128 を作成する

公共料金等代理収納 GS1-128 を作成する方法を説明します。

カスタマバーコードを作成する

カスタマバーコードを作成する方法を説明します。

QR コードを作成する

QR コードを作成する方法を説明します。

PDF417 コードを作成する

PDF417 コードを作成する方法を説明します。


JAN コードを作成する

ここでは、JAN コードを作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • JAN 13 コード (標準バージョン 13 桁) を作成する
  • JAN 8 コード (短縮バージョン 8 桁) を作成する
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」からアプリケーションごとの追加方法を参照してください。
JAN 13 コード (標準バージョン 13 桁) を作成する

このセクションでは、JAN 13 コード (標準バージョン 13 桁) を作成する方法を説明します。

次のコードは、JAN 13 コード (標準バージョン 13 桁) を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// JAN コードの倍率を 100 に設定します。
barCode1.Zoom = 100;
// 13 桁目チェックデジットは自動で付加されます。
barCode1.Value = "499385774922";
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' JAN コードの倍率を 100 に設定します。
BarCode1.Zoom = 100
' 13 桁目チェックデジットは自動で付加されます。
BarCode1.Value = "499385774922"
JAN 8 コード (短縮バージョン 8 桁) を作成する

このセクションでは、JAN 8 コード (短縮バージョン 8 桁) を作成する方法を説明します。

次のコードは、JAN 8 コード (短縮バージョン 8 桁) を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN8;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// JAN コードの倍率を 100 に設定します。
barCode1.Zoom = 100;
// 8 桁目チェックデジットは自動で付加されます。
barCode1.Value = "4993857";
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN8
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' JAN コードの倍率を 100 に設定します。
BarCode1.Zoom = 100
' 8 桁目チェックデジットは自動で付加されます。
BarCode1.Value = "4993857"
参照
バーコードタイプ別の作成方法
メソッド・プロパティ・イベント機能一覧 (バーコードコンポーネント)


UPC コードを作成する

ここでは、UPC コードを作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • UPC-A (A バージョン) を作成する
  • UPC-E (E バージョン) を作成する
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」からアプリケーションごとの追加方法を参照してください。
UPC-A (A バージョン) を作成する

このセクションでは、UPC-A (A バージョン) を作成する方法を説明します。

次のコードは、UPC-A (A バージョン) を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.UPCA;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// UPC コードの倍率を 100 に設定します。
barCode1.Zoom = 100;
// 12 桁目チェックデジットは自動で付加されます。
barCode1.Value = "01234567891";
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.UPCA
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' UPC コードの倍率を 100 に設定します。
BarCode1.Zoom = 100
' 12 桁目チェックデジットは自動で付加されます。
BarCode1.Value = "01234567891"
UPC-E (E バージョン) を作成する

このセクションでは、UPC-E (E バージョン) を作成する方法を説明します。

次のコードは、UPC-E (E バージョン) を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.UPCE;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// UPC コードの倍率を 100 に設定します。
barCode1.Zoom = 100;
// 8 桁目チェックデジットは自動で付加されます。
barCode1.Value = "0123456";
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.UPCE
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' UPC コードの倍率を 100 に設定します。
BarCode1.Zoom = 100
' 8 桁目チェックデジットは自動で付加されます。
BarCode1.Value = "0123456"
参照
バーコードタイプ別の作成方法
メソッド・プロパティ・イベント機能一覧 (バーコードコンポーネント)


ITF コードを作成する

ここでは、ITF コードを作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • ITF-6 (アドオンバージョン 6 桁) を作成する
  • ITF-14 (標準バージョン 14 桁) を作成する
  • ITF-16 (拡張バージョン 16 桁) を作成する
  • ITF (自由桁) を作成する
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」からアプリケーションごとの追加方法を参照してください。

ITF-6 (アドオンバージョン 6 桁) を作成する

このセクションでは、ITF-6 (アドオンバージョン 6 桁) を作成する方法を説明します。

次のコードは、ITF-6 (アドオンバージョン 6 桁) を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.ITF6;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// バーコードの倍率を 100 に設定します。
barCode1.Zoom = 100;
// 6 桁目チェックデジットは自動で付加されます。
barCode1.Value = "01234";
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.ITF6
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' バーコードの倍率を 100 に設定します。
BarCode1.Zoom = 100
' 6 桁目チェックデジットは自動で付加されます。
BarCode1.Value = "01234"
ITF-14 (標準バージョン 14 桁) を作成する

このセクションでは、ITF-14 (標準バージョン 14 桁) を作成する方法を説明します。

次のコードは、ITF-14 (標準バージョン 14 桁) を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.ITF14;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// バーコードの倍率を 100 に設定します。
barCode1.Zoom = 100;
// 14 桁目チェックデジットは自動で付加されます。
barCode1.Value = "0123456789012";
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.ITF14
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' バーコードの倍率を 100 に設定します。
BarCode1.Zoom = 100
' 14 桁目チェックデジットは自動で付加されます。
BarCode1.Value = "0123456789012"
ITF-16 (拡張バージョン 16 桁)を作成する

このセクションでは、ITF-16 (拡張バージョン 16 桁) を作成する方法を説明します。

次のコードは、ITF-16 (拡張バージョン 16 桁) を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.ITF16;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// バーコードの倍率を 100 に設定します。
barCode1.Zoom = 100;
// 16 桁目チェックデジットは自動で付加されます。
barCode1.Value = "012345678901234";
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.ITF16
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' バーコードの倍率を 100 に設定します。
BarCode1.Zoom = 100
' 16 桁目チェックデジットは自動で付加されます。
BarCode1.Value = "012345678901234"
ITF (自由桁) を作成する

このセクションでは、ITF (自由桁) を作成する方法を説明します。

次のコードは、ITF (自由桁) を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.ITF;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// バーコードの倍率を 100 に設定します。
barCode1.Zoom = 100;
// 最終桁チェックデジットは自動で付加されます。
barCode1.Value = "01234567890123456789";
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.ITF
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' バーコードの倍率を 100 に設定します。
BarCode1.Zoom = 100
' 最終桁チェックデジットは自動で付加されます。
BarCode1.Value = "01234567890123456789"
参照
バーコードタイプ別の作成方法
メソッド・プロパティ・イベント機能一覧 (バーコードコンポーネント)


Codabar (NW-7) を作成する

ここでは、Codabar (NW-7) を作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • Codabar (NW-7) を作成する
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」からアプリケーションごとの追加方法を参照してください。
Codabar (NW-7) を作成する

このセクションでは、Codabar (NW-7) を作成する方法を説明します。

次のコードは、Codabar (NW-7) を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Codabar;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// チェックデジットの計算方法を "モジュラス 10 / ウエイト 2" に設定します。
barCode1.CheckPattern = AdvanceSoftware.ASReport.BarCode.CheckPattern.Modulus10Weight2;
// スタートキャラクタを "c" に設定します。
barCode1.StartChar = 'c';
// ストップキャラクタを "c" に設定します。
barCode1.StopChar = 'c';
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
barCode1.Value = "0123456789";
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Codabar
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' チェックデジットの計算方法を "モジュラス 10 / ウエイト 2" に設定します。
BarCode1.CheckPattern = AdvanceSoftware.ASReport.BarCode.CheckPattern.Modulus10Weight2
' スタートキャラクタを "c" に設定します。
BarCode1.StartChar = "c"
' ストップキャラクタを "c" に設定します。
BarCode1.StopChar = "c"
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
BarCode1.Value = "0123456789"
参照
バーコードタイプ別の作成方法
メソッド・プロパティ・イベント機能一覧 (バーコードコンポーネント)


Code39 を作成する

ここでは、Code39 を作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • Code39 を作成する
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」からアプリケーションごとの追加方法を参照してください。
Code39 を作成する

このセクションでは、Code39 を作成するを作成する方法を説明します。

次のコードは、Code39 を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Code39;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// キャラクタ間のギャップを 50 ピクセルに設定します。(Code39 のみ設定可能)
barCode1.CharGap = 50;
// バーコードの最小エレメント値(バーコード幅)を 6 ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
barCode1.Value = "0123456789";
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Code39
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' キャラクタ間のギャップを 50 ピクセルに設定します。(Code39 のみ設定可能)
BarCode1.CharGap = 50
' バーコードの最小エレメント値(バーコード幅)を 6 ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
BarCode1.Value = "0123456789"
参照
バーコードタイプ別の作成方法
メソッド・プロパティ・イベント機能一覧 (バーコードコンポーネント)


Code128 を作成する

ここでは、Code128 を作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • Code128 を作成する
  • FNC1 コードの挿入する
  • コードセットを切り替える
  • ドット補正をする
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」からアプリケーションごとの追加方法を参照してください。
Code128 を作成する

このセクションでは、Code128 を作成する方法を説明します。

次のコードは、Code128 を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Code128;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// スタートコードセット B に設定します。
barCode1.Codeset = AdvanceSoftware.ASReport.BarCode.Codeset.CodesetB;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
barCode1.Value = "abc123";
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Code128
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' スタートコードセット B に設定します。
BarCode1.Codeset = AdvanceSoftware.ASReport.BarCode.Codeset.CodesetB
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
BarCode1.Value = "abc123"
FNC1 コードを挿入する

このセクションでは、FNC1 コード等の制御コードを手動で設定する方法を説明します。"チルダ＋制御コード名"のように「~」 (チルダ) で始まる文字列を指定することでバーコードデータに任意の制御コードを設定することが可能です。

次のコードは、FNC1 コードを挿入するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Code128;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// スタートコードセット C に設定します。
barCode1.Codeset = AdvanceSoftware.ASReport.BarCode.Codeset.CodesetC;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
// バーコードデータの先頭に FNC1 コードを手動で設定します。
barCode1.Value = "~FNC1" + "1234";
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Code128
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' スタートコードセット C に設定します。
BarCode1.Codeset = AdvanceSoftware.ASReport.BarCode.Codeset.CodesetC
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
' バーコードデータの先頭に FNC1 コードを手動で設定します。
BarCode1.Value = "~FNC1" & "1234"
コードセットを切り替える

このセクションでは、コードセットを切り替える方法を説明します。"チルダ＋制御コード (コードセット) 名"のように「~」 (チルダ) で始まる文字列を指定することでバーコードデータ内で指定した位置でコードセットを切り替えることが可能です。

次のコードは、コードセットを切り替えるサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Code128;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// スタートコードセット C に設定します。
barCode1.Codeset = AdvanceSoftware.ASReport.BarCode.Codeset.CodesetC;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
// バーコードデータの途中でコードセット B に手動で切り替えます。
barCode1.Value = 12 + "~CODEB" + "abc";
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Code128
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' スタートコードセット C に設定します。
BarCode1.Codeset = AdvanceSoftware.ASReport.BarCode.Codeset.CodesetC
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
' バーコードデータの途中でコードセット B に手動で切り替えます。
BarCode1.Value = 12 & "~CODEB" & "abc"
ドット補正をする

このセクションでは、ドット補正をする方法を説明します。

次のコードは、BlackBarRevision、WhiteBarRevision プロパティでドット補正をするサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Code128;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// スタートコードセット B に設定します。
barCode1.Codeset = AdvanceSoftware.ASReport.BarCode.Codeset.CodesetB;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
barCode1.Value = "abc123";
// 黒バーのドット補正値を "+1" に設定します。
barCode1.BlackBarRevision = 1;
// 白バーのドット補正値を "-1" に設定します。
barCode1.WhiteBarRevision = -1;
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Code128
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' スタートコードセット B に設定します。
BarCode1.Codeset = AdvanceSoftware.ASReport.BarCode.Codeset.CodesetB
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
BarCode1.Value = "abc123"
' 黒バーのドット補正値を "+1" に設定します。
BarCode1.BlackBarRevision = 1
' 白バーのドット補正値を "-1" に設定します。
BarCode1.WhiteBarRevision = -1
参照
バーコードタイプ別の作成方法
メソッド・プロパティ・イベント機能一覧 (バーコードコンポーネント)


GS1-128 を作成する

ここでは、GS1-128 を作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • GS1-128 を作成する
  • ドット補正をする
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」からアプリケーションごとの追加方法を参照してください。
Note メモ:

・GS1-128 であることを示す、スタートコード後の FNC1 は、Type プロパティで GS1 を設定することで自動付加されます。

・括弧 "("、")" はバーコードイメージ下部のバーコード文字列にのみ表示され、データには含まれません。
GS1-128 を作成する

このセクションでは、GS1-128 を作成する方法を説明します

次のコードは、GS1-128 を作成するサンプルコードです。

C#
VB
コピー
string barCodeData =
    "(01)" +           // AI(01)
    "14993857749228" + // 商品コード
    "(17)" +           // AI(17)
    "200101" +         // 有効期限
    "(30)" +           // AI(30)
    "10" +             // 数量
    "~FNC1" +          // 可変データの区切りを示す FNC1
    "(10)" +           // AI(10)
    "~CODEB" +         // Code B に切り替え
    "ABC123";          // ロット番号

barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.GS1;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// スタートコードセット C に設定します。
barCode1.Codeset = AdvanceSoftware.ASReport.BarCode.Codeset.CodesetC;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
barCode1.Value = barCodeData;
Dim barCodeData As String
barCodeData = "(01)"             ' AI(01)
barCodeData += "14993857749228"  ' 商品コード
barCodeData += "(17)"            ' AI(17)
barCodeData += "200101"          ' 有効期限
barCodeData += "(30)"            ' AI(30)
barCodeData += "10"              ' 数量
barCodeData += "~FNC1"           ' 可変データの区切りを示す FNC1
barCodeData += "(10)"            ' AI(10)
barCodeData += "~CODEB"          ' Code B に切り替え
barCodeData += "ABC123"          ' ロット番号

BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.GS1
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' スタートコードセット C に設定します。
BarCode1.Codeset = AdvanceSoftware.ASReport.BarCode.Codeset.CodesetC
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
BarCode1.Value = barCodeData
Note メモ:

データの途中で FNC1 などの制御コードを挿入する場合、"チルダ＋制御コード名" を入力します。(例："~FNC1"、"~CODEB" など)
ドット補正をする

このセクションでは、ドット補正をする方法を説明します。

次のコードは、BlackBarRevision、WhiteBarRevision プロパティでドット補正をするサンプルコードです。

C#
VB
コピー
string barCodeData =
    "(01)" +           // AI(01)
    "14993857749228" + // 商品コード
    "(17)" +           // AI(17)
    "200101" +         // 有効期限
    "(30)" +           // AI(30)
    "10" +             // 数量
    "~FNC1" +          // 可変データの区切りを示す FNC1
    "(10)" +           // AI(10)
    "~CODEB" +         // Code B に切り替え
    "ABC123";          // ロット番号

barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.GS1;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// スタートコードセット C に設定します。
barCode1.Codeset = AdvanceSoftware.ASReport.BarCode.Codeset.CodesetC;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
barCode1.Value = barCodeData;
// 黒バーのドット補正値を "+1" に設定します。
barCode1.BlackBarRevision = 1;
// 白バーのドット補正値を "-1" に設定します。
barCode1.WhiteBarRevision = -1;
Dim barCodeData As String
barCodeData = "(01)"             ' AI(01)
barCodeData += "14993857749228"  ' 商品コード
barCodeData += "(17)"            ' AI(17)
barCodeData += "200101"          ' 有効期限
barCodeData += "(30)"            ' AI(30)
barCodeData += "10"              ' 数量
barCodeData += "~FNC1"           ' 可変データの区切りを示す FNC1
barCodeData += "(10)"            ' AI(10)
barCodeData += "~CODEB"          ' Code B に切り替え
barCodeData += "ABC123"          ' ロット番号

BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.GS1
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' スタートコードセット C に設定します。
BarCode1.Codeset = AdvanceSoftware.ASReport.BarCode.Codeset.CodesetC
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
BarCode1.Value = barCodeData
' 黒バーのドット補正値を "+1" に設定します。
BarCode1.BlackBarRevision = 1
' 白バーのドット補正値を "-1" に設定します。
BarCode1.WhiteBarRevision = -1
参照
バーコードタイプ別の作成方法
メソッド・プロパティ・イベント機能一覧 (バーコードコンポーネント)


公共料金等代理収納 GS1-128 を作成する

ここでは、公共料金等代理収納 GS1-128 を作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • 公共料金等代理収納 GS1-128 を作成する
  • ドット補正をする
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」からアプリケーションごとの追加方法を参照してください。
Note メモ:

公共料金等代理収納 GS1-128 であることを示すスタートコード後の FNC1 は、Type プロパティで GS1Fixed を設定することで自動付加されます。
公共料金等代理収納 GS1-128 を作成する

このセクションでは、公共料金等代理収納 GS1-128 を作成する方法を説明します。

次のコードは、公共料金等代理収納 GS1-128 を作成するサンプルコードです。

C#
VB
コピー
string barCodeData =
    "91" +                      // 識別子
    "912345" +                  // メーカーコード
    "1234567890123456789211" +  // 自由使用欄、再発行区分
    "020331" +                  // 支払い期限日
    "0" +                       // 印紙フラグ
    "123456";                   // 支払い金額

barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.GS1Fixed;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
barCode1.Value = barCodeData;
Dim barCodeData As String
barCodeData = "91"                      ' 識別子
barCodeData += "912345"                 ' メーカーコード
barCodeData += "1234567890123456789211" ' 自由使用欄、再発行区分
barCodeData += "020331"                 ' 支払い期限日
barCodeData += "0"                      ' 印紙フラグ
barCodeData += "123456"                 ' 支払い金額

BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.GS1Fixed
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
BarCode1.Value = barCodeData
ドット補正をする

このセクションでは、ドット補正をする方法を説明します。

次のコードは、BlackBarRevision、WhiteBarRevision プロパティでドット補正をするサンプルコードです。

C#
VB
コピー
string barCodeData =
    "91" +                      // 識別子
    "912345" +                  // メーカーコード
    "1234567890123456789211" +  // 自由使用欄、再発行区分
    "020331" +                  // 支払い期限日
    "0" +                       // 印紙フラグ
    "123456";                   // 支払い金額

barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.GS1Fixed;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
barCode1.Value = barCodeData;
// 黒バーのドット補正値を "+1" に設定します。
barCode1.BlackBarRevision = 1;
// 白バーのドット補正値を "-1" に設定します。
barCode1.WhiteBarRevision = -1;
Dim barCodeData As String
barCodeData = "91"                      ' 識別子
barCodeData += "912345"                 ' メーカーコード
barCodeData += "1234567890123456789211" ' 自由使用欄、再発行区分
barCodeData += "020331"                 ' 支払い期限日
barCodeData += "0"                      ' 印紙フラグ
barCodeData += "123456"                 ' 支払い金額

BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.GS1Fixed
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
BarCode1.Value = barCodeData
' 黒バーのドット補正値を "+1" に設定します。
BarCode1.BlackBarRevision = 1
' 白バーのドット補正値を "-1" に設定します。
BarCode1.WhiteBarRevision = -1
参照
バーコードタイプ別の作成方法
メソッド・プロパティ・イベント機能一覧 (バーコードコンポーネント)


カスタマバーコードを作成する

ここでは、カスタマバーコードを作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • カスタマバーコードを作成する
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」からアプリケーションごとの追加方法を参照してください。
Note メモ:

住所データからバーコードデータへの変換には対応していません。
カスタマバーコードを作成する

このセクションでは、カスタマバーコードを作成する方法を説明します。

次のコードは、カスタマバーコードを作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.CustomerBarCode;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// カスタマバーコードのポイントを "10.0" に設定します。
barCode1.Point = 10.0;
barCode1.Value = "91882391-2816";
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.CustomerBarCode
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' カスタマバーコードのポイントを "10.0" に設定します。
BarCode1.Point = 10.0
BarCode1.Value = "91882391-2816"
参照
バーコードタイプ別の作成方法
メソッド・プロパティ・イベント機能一覧 (バーコードコンポーネント)


QR コードを作成する

ここでは、QR コードを作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • QR コードを作成する
  • QR コードを携帯で読み取る
  • QR コードを自動で連結する
  • QR コードを手動で連結する
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」からアプリケーションごとの追加方法を参照してください。
QR コードを作成する

このセクションでは、QR コードを作成する方法を説明します。

次のコードは、QR コードを作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// QR コードのエラー訂正レベルを "H" に設定します。
barCode1.QRLevel = AdvanceSoftware.ASReport.BarCode.QRLevel.LevelH;
// QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
barCode1.QRMask = AdvanceSoftware.ASReport.BarCode.QRMask.Mask000;
// QR コードのモデルを "モデル 1" に設定します。
barCode1.QRModel = AdvanceSoftware.ASReport.BarCode.QRModel.Model1;
// QR コードの型番を "10 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.ASReport.BarCode.QRVersion.Version10;
barCode1.Element = 10;
barCode1.Value = "123456789";
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' QR コードのエラー訂正レベルを "H" に設定します。
BarCode1.QRLevel = AdvanceSoftware.ASReport.BarCode.QRLevel.LevelH
' QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
BarCode1.QRMask = AdvanceSoftware.ASReport.BarCode.QRMask.Mask000
' QR コードのモデルを "モデル 1" に設定します。
BarCode1.QRModel = AdvanceSoftware.ASReport.BarCode.QRModel.Model1
' QR コードの型番を "10 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.ASReport.BarCode.QRVersion.Version10
BarCode1.Element = 10
BarCode1.Value = "123456789"
QR コードを携帯で読み取る

このセクションでは、QR コードを携帯で読み取る方法を説明します。

Note メモ:

携帯電話で読み取り可能な QR コードの仕様は、各携帯電話のキャリアによって細かい仕様は異なりますが、基本的な仕様は、モデル (モデル 2)、バージョン (1～10) に統一されています。

次のコードは、QRModel プロパティでモデルを [Model2] に設定し、QRVersion プロパティでバージョン [10] を設定するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// QR コードのモデルを "モデル 2" に設定します。
barCode1.QRModel = AdvanceSoftware.ASReport.BarCode.QRModel.Model2;
// QR コードの型番を "10 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.ASReport.BarCode.QRVersion.Version10;
barCode1.Element = 10;
barCode1.Value = "https://www.adv.co.jp/";
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' QR コードのモデルを "モデル 2" に設定します。
BarCode1.QRModel = AdvanceSoftware.ASReport.BarCode.QRModel.Model2
' QR コードの型番を "10 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.ASReport.BarCode.QRVersion.Version10
BarCode1.Element = 10
BarCode1.Value = "https://www.adv.co.jp/"
QR コードを自動で連結する

このセクションでは、QR コードを自動で連結する方法を説明します。

次のコードは、QRConnect プロパティで [AutoConnect] を設定し、QR コードを自動で連結して作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// QR コードのモデルを "モデル 2" に設定します。
barCode1.QRModel = AdvanceSoftware.ASReport.BarCode.QRModel.Model2;
// QR コードの型番を "2 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.ASReport.BarCode.QRVersion.Version2;
barCode1.Element = 10;
// 連結 QR コードを自動で作成します。
barCode1.QRConnect = AdvanceSoftware.ASReport.BarCode.QRConnect.AutoConnect;
// シンボル番号を初期化します。
barCode1.QRSymbolNumber = 0;
barCode1.Value = "123456789123456789123456789123456789";

int nSymbol;
System.Drawing.Image img;
AdvanceSoftware.ASReport.BarCode.BarCodeSizeD barCodeSizeD;
// 最大シンボル数分ループを回し、1 シンボルずつ帳票に出力します。
for (nSymbol = 0; nSymbol < 16; nSymbol++)
{
    // 出力する QR コードのシンボル番号を指定します。(0～15)
    barCode1.QRSymbolNumber = nSymbol;
    // QR イメージを取得します。
    img = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Png);
    // イメージの取得に失敗した場合(シンボル数を超えた場合)ループを抜けます。
    if (barCode1.ErrorNo == AdvanceSoftware.ASReport.BarCode.ErrorNo.QRConnectPos)
        break;
    // QR コードの実寸を取得します。
    barCodeSizeD = barCode1.GetScaleSize(AdvanceSoftware.ASReport.BarCode.Unit.Millimeter);
    // 指定した番号の QR イメージを任意のセルに挿入します。
    cellReport1.Pos(nSymbol, 0).Drawing.AddImage(img, barCodeSizeD.Width, barCodeSizeD.Height);
}
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' QR コードのモデルを "モデル 2" に設定します。
BarCode1.QRModel = AdvanceSoftware.ASReport.BarCode.QRModel.Model2
' QR コードの型番を "2 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.ASReport.BarCode.QRVersion.Version2
BarCode1.Element = 10
' 連結 QR コードを自動で作成します。
BarCode1.QRConnect = AdvanceSoftware.ASReport.BarCode.QRConnect.AutoConnect
' シンボル番号を初期化します。
BarCode1.QRSymbolNumber = 0
BarCode1.Value = "123456789123456789123456789123456789"

Dim nSymbol As Integer
Dim img As System.Drawing.Image
Dim BarCodeSizeD As AdvanceSoftware.ASReport.BarCode.BarCodeSizeD
' 最大シンボル数分ループを回し、1 シンボルずつ帳票に出力します。
For nSymbol = 0 To 15
    ' 出力する QR コードのシンボル番号を指定します。(0～15)
    BarCode1.QRSymbolNumber = nSymbol
    ' QR イメージを取得します。
    img = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Png)
    ' イメージの取得に失敗した場合(シンボル数を超えた場合)ループを抜けます。
    If (BarCode1.ErrorNo = AdvanceSoftware.ASReport.BarCode.ErrorNo.QRConnectPos) Then
        Exit For
    End If
    ' QR コードの実寸を取得します。
    BarCodeSizeD = BarCode1.GetScaleSize(AdvanceSoftware.ASReport.BarCode.Unit.Millimeter)
    ' 指定した番号の QR イメージを任意のセルに挿入します。
    CellReport1.Pos(nSymbol, 0).Drawing.AddImage(img, BarCodeSizeD.Width, BarCodeSizeD.Height)
Next
QR コードを手動で連結する

このセクションでは、QR コードを手動で連結する方法を説明します。

次のコードは、QRConnect プロパティで [ManualConnect] を設定し、QR コードを手動で連結して作成するサンプルコードです。任意のエスケープコード + "S" を設定して、QR コードを分割します。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// QR コードのモデルを "モデル 2" に設定します。
barCode1.QRModel = AdvanceSoftware.ASReport.BarCode.QRModel.Model2;
// QR コードの型番を "2 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.ASReport.BarCode.QRVersion.Version2;
barCode1.Element = 10;
// 連結 QR コードを手動で作成します。
barCode1.QRConnect = AdvanceSoftware.ASReport.BarCode.QRConnect.ManualConnect;
// QR コードのエスケープコードを "% (0x25)" に設定します。
barCode1.QREscapeCode = 0x25;
barCode1.Value = "12345%SABCDE";

System.Drawing.Image img1, img2;
AdvanceSoftware.ASReport.BarCode.BarCodeSizeD barCodeSizeD;
// QR コードの実寸を取得します。
barCodeSizeD = barCode1.GetScaleSize(AdvanceSoftware.ASReport.BarCode.Unit.Millimeter);
// 1 つ目の連結 QR コードを出力します。
barCode1.QRSymbolNumber = 0;
img1 = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Png);
cellReport1.Cell("A1").Drawing.AddImage(img1, barCodeSizeD.Width, barCodeSizeD.Height);
// 2 つ目の連結 QR コードを出力します。
barCode1.QRSymbolNumber = 1;
img2 = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Png);
cellReport1.Cell("B1").Drawing.AddImage(img2, barCodeSizeD.Width, barCodeSizeD.Height);
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' QR コードのモデルを "モデル 2" に設定します。
BarCode1.QRModel = AdvanceSoftware.ASReport.BarCode.QRModel.Model2
' QR コードの型番を "2 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.ASReport.BarCode.QRVersion.Version2
BarCode1.Element = 10
' 連結 QR コードを手動で作成します。
BarCode1.QRConnect = AdvanceSoftware.ASReport.BarCode.QRConnect.ManualConnect
' QR コードのエスケープコードを "% (0x25)" に設定します。
BarCode1.QREscapeCode = &H25
BarCode1.Value = "12345%SABCDE"

Dim img1, img2 As System.Drawing.Image
Dim BarCodeSizeD As AdvanceSoftware.ASReport.BarCode.BarCodeSizeD
' QR コードの実寸を取得します。
BarCodeSizeD = BarCode1.GetScaleSize(AdvanceSoftware.ASReport.BarCode.Unit.Millimeter)
' 1 つ目の連結 QR コードを出力します。
BarCode1.QRSymbolNumber = 0
img1 = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Png)
CellReport1.Cell("A1").Drawing.AddImage(img1, BarCodeSizeD.Width, BarCodeSizeD.Height)
' 2 つ目の連結 QR コードを出力します。
BarCode1.QRSymbolNumber = 0
img2 = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Png)
CellReport1.Cell("B1").Drawing.AddImage(img2, BarCodeSizeD.Width, BarCodeSizeD.Height)
参照
バーコードタイプ別の作成方法
メソッド・プロパティ・イベント機能一覧 (バーコードコンポーネント)


PDF417 を作成する

ここでは、PDF417 を作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • PDF417 を作成する
  • 参照
Note メモ:

バーコードコンポーネントの追加方法は「使用準備」からアプリケーションごとの追加方法を参照してください。
PDF417 を作成する

このセクションでは、PDF417 を作成する方法を説明します。

次のコードは、PDF417 を作成するサンプルコードです。

C#
VB
コピー
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.PDF417;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 解像度を 600 に設定します。
barCode1.DpiX = 600;
barCode1.DpiY = 600;
// バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
barCode1.Element = 6;
// PDF417 の列数を "15列" に設定します。
barCode1.PDFColumn = 15;
// PDF417 の初期化シンボルを "付加する" に設定します。
barCode1.PDFInitialSymbol = true;
// PDF417 のエラー訂正レベルを "レベル5" に設定します。
barCode1.PDFLevel = 5;
// PDF417 シンボルを "簡易 PDF417" に設定します。
barCode1.PDFModel = AdvanceSoftware.ASReport.BarCode.PDFModel.Truncated;
// PDF417 の行数を "10行" に設定します。
barCode1.PDFRow = 10;
barCode1.Value = "01234567890123456789";
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.PDF417
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 解像度を 600 に設定します。
BarCode1.DpiX = 600
BarCode1.DpiY = 600
' バーコードの最小エレメント値(バーコード幅)を "6" ピクセルに設定します。Unit プロパティの単位で設定します。
BarCode1.Element = 6
' PDF417 の列数を "15列" に設定します。
BarCode1.PDFColumn = 15
' PDF417 の初期化シンボルを "付加する" に設定します。
BarCode1.PDFInitialSymbol = True
' PDF417 のエラー訂正レベルを "レベル5" に設定します。
BarCode1.PDFLevel = 5
' PDF417 シンボルを "簡易 PDF417" に設定します。
BarCode1.PDFModel = AdvanceSoftware.ASReport.BarCode.PDFModel.Truncated
' PDF417 の行数を "10行" に設定します。
BarCode1.PDFRow = 10
BarCode1.Value = "01234567890123456789"
参照
バーコードタイプ別の作成方法
メソッド・プロパティ・イベント機能一覧 (バーコードコンポーネント)


バーコード付き帳票の作成方法

ここでは、バーコードコンポーネントを使用してバーコード付き帳票を作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • JAN (13 桁) を使用したバーコード付き帳票の作成方法
  • 参照
JAN (13 桁) を使用したバーコード付き帳票の作成方法

このセクションでは、JAN(13 桁) を例に、バーコード付き帳票の作成方法を説明します。ここでは、Windows フォーム アプリを使用した手順になります。

  1. Visual Studio を起動し、[新しいプロジェクトの作成] から「Windows フォーム アプリ」を作成します。

  2. フォームに Button (Button1) を配置します。

  3. フォームにレポートコンポーネントを追加します。このセクションでは、レポートコンポーネントを [ツールボックスから追加する] 手順で追加します。

    Note メモ:

    レポートコンポーネントの追加方法は「レポートコンポーネントを追加する」を参照してください。

  4. バーコードコンポーネントを追加します。

    Note メモ:

    バーコードコンポーネントの追加方法は「バーコードコンポーネントを追加する」を参照してください。

  5. Button1 のイベントに、バーコードコンポーネントで作成した JAN コードを帳票に挿入して PDF ファイルに出力する、下記サンプルコードを追加します。

    C#
    VB
    コピー
    // レポートコンポ―ネント、バーコードコンポーネントにライセンス情報を設定します。
cellReport1.SetLicense(@"C:\Advancesoftware.ASReport12.License.xml");
barCode1.SetLicense(@"C:\Advancesoftware.ASReport12.License.xml");

// Type プロパティでバーコードの種類を "JAN13" に設定します。
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
// Unit プロパティでバーコードイメージのサイズの単位を "ピクセル" に設定します。
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// DpiX プロパティでバーコードの横方向の解像度を "600" に設定します。
barCode1.DpiX = 600;
// DpiY プロパティでバーコードの縦方向の解像度を "600" に設定します。
barCode1.DpiY = 600;
// Zoom プロパティでバーコードイメージの倍率を "100%" に設定します。
barCode1.Zoom = 100;
// CheckCharMode プロパティでチェックデジットの自動計算を無効に設定します。
barCode1.CheckCharMode = false;
// Value プロパティでバーコードデータを設定します。
barCode1.Value = "4993857749221";
// GetScaleSize メソッドで、バーコードのサイズをミリメートル単位で取得します。
AdvanceSoftware.ASReport.BarCode.BarCodeSizeD barCodeSizeD;
barCodeSizeD = barCode1.GetScaleSize(AdvanceSoftware.ASReport.BarCode.Unit.Millimeter);

// 帳票の作成を開始します。
cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024);
cellReport1.Page.Start("Sheet1", "1");
// AddImage メソッドで設定する画像のスケールモードをミリメートルに設定します。
cellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Millimeter;
// GetBarCodeImage メソッドで PNG 形式のバーコードイメージを取得し、AddImage メソッドで設定します。
// 第 2、3 引数には、取得したバーコードのサイズを設定します。
cellReport1.Cell("B5").Drawing.AddImage(
    barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Png), barCodeSizeD.Width, barCodeSizeD.Height);
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
    ' レポートコンポ―ネント、バーコードコンポーネントにライセンス情報を設定します。
CellReport1.SetLicense("C:\AdvanceSoftware.ASReport.License.xml")
BarCode1.SetLicense("C:\AdvanceSoftware.ASReport.License.xml")

' Type プロパティでバーコードの種類を "JAN13" に設定します。
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
' Unit プロパティでバーコードイメージのサイズの単位を "ピクセル" に設定します。
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' DpiX プロパティでバーコードの横方向の解像度を "600" に設定します。
BarCode1.DpiX = 600
' DpiY プロパティでバーコードの縦方向の解像度を "600" に設定します。
BarCode1.DpiY = 600
' Zoom プロパティでバーコードイメージの倍率を "100%" に設定します。
BarCode1.Zoom = 100
' CheckCharMode プロパティでチェックデジットの自動計算を無効に設定します。
BarCode1.CheckCharMode = False
' Value プロパティでバーコードデータを設定します。
BarCode1.Value = "4993857749221"
' GetScaleSize メソッドで、バーコードのサイズをミリメートル単位で取得します。
Dim BarCodeSizeD As AdvanceSoftware.ASReport.BarCode.BarCodeSizeD
BarCodeSizeD = BarCode1.GetScaleSize(AdvanceSoftware.ASReport.BarCode.Unit.Millimeter)

' 帳票の作成を開始します。
CellReport1.Report.Start()
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2024)
CellReport1.Page.Start("Sheet1", "1")
' AddImage メソッドで設定する画像のスケールモードをミリメートルに設定します。
CellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Millimeter
' GetBarCodeImage メソッドで PNG 形式のバーコードイメージを取得し、AddImage メソッドで設定します。
' 第 2、3 引数には、取得したバーコードのサイズを設定します。
CellReport1.Cell("B5").Drawing.AddImage(
    BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Png), BarCodeSizeD.Width, BarCodeSizeD.Height)
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\Out1.xlsx")

  6. Button1 をクリックすると、バーコードが設定された帳票を PDF ファイルに出力します。

参照
バーコードを設定する


イベントを実装する

AS-Report 12.0 for .NET のコンポーネントでは、エラーイベントやプログレスイベントを実装することが可能です。ここでは、各種イベントを実装する方法を説明します。

レポートコンポーネント

レポートコンポーネントのイベントを実装する方法を説明します。

バーコードコンポーネント

バーコードコンポーネントのイベントを実装する方法を説明します。

Windows フォーム用ビューア

Windows フォーム用ビューアのイベントを実装する方法を説明します。

WPF 用ビューア

WPF 用ビューアのイベントを実装する方法を説明します。


レポートコンポーネント

レポートコンポーネントではイベントを実装することが可能です。このトピックでは、レポートコンポーネントの各イベントを実装する方法を説明します。

このトピックは、次のセクションを含みます。

  • Error イベントを実装する
  • Progress イベントを実装する
  • SectionNewPage イベントを実装する
  • SectionEndPage イベントを実装する
  • 参照
Note メモ:

このトピックの手順を行う前に「レポートコンポーネントを追加する」の [ツールボックスから追加する] の手順でレポートコンポーネントを追加する必要があります。
Error イベントを実装する

このイベントは、帳票作成時にエラーを検知すると呼び出されます。このセクションでは、Error イベントの実装方法を説明します。

  1. フォームに貼り付けたレポートコンポーネントをクリックします。

  2. [プロパティ] 内の [イベント] ボタン ( [image] ) をクリックします。

  3. 使用できるイベントの一覧で、[Error] イベントをクリックします。

  4. イベント名の右にあるボックス( [image] )にカーソルを合わせて Enter キーを押下します。

  5. Error イベントが作成されます。

Progress イベントを実装する

このイベントは、ユーザー独自の処理進行状況の表示を行う場合に使用します。このセクションでは、Progress イベントの実装方法を説明します。

  1. フォームに貼り付けたレポートコンポーネントをクリックします。

  2. [プロパティ] 内の [イベント] ボタン ( [image] ) をクリックします。

  3. 使用できるイベントの一覧で、[Progress] イベントをクリックします。

  4. イベント名の右にあるボックス( [image] )にカーソルを合わせて Enter キーを押下します。

  5. Progress イベントが作成されます。

SectionNewPage イベントを実装する

このイベントは、セクションレポート機能で帳票を作成する際に、ヘッダー部へ値を設定する場合に呼び出して使用します。このセクションでは、SectionNewPage イベントの実装方法を説明します。

  1. フォームに貼り付けたレポートコンポーネントをクリックします。

  2. [プロパティ] 内の [イベント] ボタン ( [image] ) をクリックします。

  3. 使用できるイベントの一覧で、[SectionNewPage] イベントをクリックします。

  4. イベント名の右にあるボックス( [image] )にカーソルを合わせて Enter キーを押下します。

  5. SectionNewPage イベントが作成されます。

SectionEndPage イベントを実装する

このイベントは、セクションレポート機能で帳票を作成する際に、フッター部へ値を設定する場合に呼び出します。このセクションでは、SectionEndPage イベントの実装方法を説明します。

  1. フォームに貼り付けたレポートコンポーネントをクリックします。

  2. [プロパティ] 内の [イベント] ボタン ( [image] ) をクリックします。

  3. 使用できるイベントの一覧で、[SectionEndPage] イベントをクリックします。

  4. イベント名の右にあるボックス( [image] )にカーソルを合わせて Enter キーを押下します。

  5. SectionEndPage イベントが作成されます。

参照
メソッド・プロパティ・イベント機能一覧 (レポートコンポーネント)
イベントを実装する


バーコードコンポーネント

バーコードコンポーネントではイベントを実装することが可能です。このトピックでは、バーコードコンポーネントの各イベントを実装する方法を説明します。

このトピックは、次のセクションを含みます。

  • Error イベントを実装する
  • 参照
Note メモ:

このトピックの手順を行う前に「バーコードコンポーネントを追加する」の [ツールボックスから追加する] の手順でバーコードコンポーネントを追加する必要があります。
Error イベントを実装する

このイベントは、バーコード作成時にエラーを検知すると呼び出されます。このセクションでは、Error イベントの実装方法を説明します。

  1. フォームに貼り付けたバーコードコンポーネントをクリックします。

  2. [プロパティ] 内の [イベント] ボタン ( [image] ) をクリックします。

  3. 使用できるイベントの一覧で、[Error] イベントをクリックします。

  4. イベント名の右にあるボックス( [image] )にカーソルを合わせて Enter キーを押下します。

  5. Error イベントが作成されます。

参照
メソッド・プロパティ・イベント機能一覧 (バーコードコンポーネント)
イベントを実装する


Windows フォーム用ビューア

Windows フォーム用ビューアではイベントを実装することが可能です。このトピックでは、Windows フォーム用ビューアの各イベントを実装する方法を説明します。

このトピックは、次のセクションを含みます。

  • Error イベントを実装する
  • Progress イベントを実装する
Note メモ:

このトピックの手順を行う前に「Windows フォーム用ビューアを追加する 」の手順で Windows フォーム用ビューアを追加する必要があります。
Error イベントを実装する

このイベントは、帳票作成時にエラーを検知すると呼び出されます。このセクションでは、Error イベントの実装方法を説明します。

  1. フォームに貼り付けた Winfows フォーム用ビューアをクリックします。

  2. [プロパティ] 内の [イベント] ボタン ( [image] ) をクリックします。

  3. 使用できるイベントの一覧で、[Error] イベントをクリックします。

  4. イベント名の右にあるボックス( [image] )にカーソルを合わせて Enter キーを押下します。

  5. Error イベントが作成されます。

Progress イベントを実装する

このイベントは、ユーザー独自の処理進行状況の表示を行う場合に使用します。このセクションでは、Progress イベントの実装方法を説明します。

  1. フォームに貼り付けた Windows フォーム用ビューアをクリックします。

  2. [プロパティ] 内の [イベント] ボタン ( [image] ) をクリックします。

  3. 使用できるイベントの一覧で、[Progress] イベントをクリックします。

  4. イベント名の右にあるボックス( [image] )にカーソルを合わせて Enter キーを押下します。

  5. Progress イベントが作成されます。

参照
メソッド・プロパティ・イベント機能一覧 (レポートコンポーネント)
イベントを実装する


WPF 用ビューア

WPF 用ビューアではイベントを実装することが可能です。このトピックでは、WPF 用ビューアの各イベントを実装する方法を説明します。

このトピックは、次のセクションを含みます。

  • Error イベントを実装する
  • Progress イベントを実装する
Note メモ:

このトピックの手順を行う前に「WPF 用ビューアを追加する 」の手順で WPF 用ビューアを追加する必要があります。
Error イベントを実装する

このイベントは、帳票作成時にエラーを検知すると呼び出されます。このセクションでは、Error イベントの実装方法を説明します。

  1. ウィンドウに貼り付けた WPF 用ビューアをクリックします。

  2. [プロパティ] 内の [イベント] ボタン ( [image] ) をクリックします。

  3. 使用できるイベントの一覧で、[Error] イベントをクリックします。

  4. イベント名の右にあるボックス( [image] )にカーソルを合わせて Enter キーを押下します。

  5. Error イベントが作成されます。

Progress イベントを実装する

このイベントは、ユーザー独自の処理進行状況の表示を行う場合に使用します。このセクションでは、Progress イベントの実装方法を説明します。

  1. ウィンドウに貼り付けた WPF 用ビューアをクリックします。

  2. [プロパティ] 内の [イベント] ボタン ( [image] ) をクリックします。

  3. 使用できるイベントの一覧で、[Progress] イベントをクリックします。

  4. イベント名の右にあるボックス( [image] )にカーソルを合わせて Enter キーを押下します。

  5. Progress イベントが作成されます。

参照
メソッド・プロパティ・イベント機能一覧 (レポートコンポーネント)
イベントを実装する


複数ページの帳票を作成する

AS-Report 12.0 for .NET では、複数ページの帳票を作成することができます。ここでは、帳票デザインの構成ごとに複数ページの帳票ドキュメントを作成する方法を紹介します。

1 ページの帳票デザインを使用する

1 ページの帳票デザインから、複数ページの帳票を作成する方法を説明します。

同じシートにある 2 ページ以上の帳票デザインを使用する

同じシートで 2 ページ以上ある帳票デザインを使用して、複数ページの帳票を作成する方法を説明します。

シートごとにある帳票デザインを使用する

シートごとにある帳票デザインを使用して、複数ページの帳票を作成する方法を説明します。


1 ページの帳票デザインを使用する

ここでは、1 ページの帳票デザインから複数ページの帳票を作成する方法を説明します。

このトピックは、次のセクションを含みます。

  • Page.Start、Page.End メソッドを繰り返し設定する
  • Page.Repeat、Page.Next メソッドを繰り返し設定する
  • 参照
Page.Start、Page.End メソッドを繰り返し設定する

次のコードは、Page.Start、Page.End メソッドを 2 回繰り返して 2 ページ分の帳票を作成するサンプルコードです。

C#
VB
コピー
// "請求書" シートの 1 ページを使用して 2 ページ分の帳票を作成します。
cellReport1.Report.Start();
cellReport1.Report.File();
// 1 ページ目の帳票を作成します。
cellReport1.Page.Start("請求書", "1");
cellReport1.Cell("A1").Value = "1 ページ";
cellReport1.Page.End();
// 2 ページ目の帳票を作成します。
cellReport1.Page.Start("請求書", "1");
cellReport1.Cell("A1").Value = "2 ページ";
cellReport1.Page.End();
cellReport1.Report.End();
' "請求書" シートの 1 ページを使用して 2 ページ分の帳票を作成します。
CellReport1.Report.Start()
CellReport1.Report.File()
' 1 ページ目の帳票を作成します。
CellReport1.Page.Start("請求書", "1")
CellReport1.Cell("A1").Value = "1 ページ"
CellReport1.Page.End()
' 2 ページ目の帳票を作成します。
CellReport1.Page.Start("請求書", "1")
CellReport1.Cell("A1").Value = "2 ページ"
CellReport1.Page.End()
CellReport1.Report.End()
Note メモ:

Page.Start メソッドと Page.End メソッドは、必ず対でご使用ください。
Page.Repeat、Page.Next メソッドを繰り返し設定する

固定の帳票デザインであれば、Page.Repeat メソッド、Page.Next メソッドを使用して、指定行を累積させた複数ページの帳票を作成することもできます。
次のコードは、Page.Repeat、Page.Next メソッドを 2 回繰り返して 2 ページ分の帳票を作成するサンプルコードです。

C#
VB
コピー
// "請求書" シートの 1 ページを使用して 2 ページ分の帳票を作成します。
// ※Page.Repeat メソッド、Page.Next メソッドを使用。
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("請求書", "1");
// 1 ページ目の帳票を作成します。
cellReport1.Page.Repeat(1);
cellReport1.Cell("A1").Value = "1 ページ";
cellReport1.Page.Next(true);
// 2 ページ目の帳票を作成します。
cellReport1.Page.Repeat(1);
cellReport1.Cell("A1").Value = "2 ページ";
cellReport1.Page.Next(true);
cellReport1.Page.End();
cellReport1.Report.End();
' "請求書" シートの 1 ページを使用して 2 ページ分の帳票を作成します。
' ※Page.Repeat メソッド、Page.Next メソッドを使用。
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("請求書", "1")
' 1 ページ目の帳票を作成します。
CellReport1.Page.Repeat(1)
CellReport1.Cell("A1").Value = "1 ページ"
CellReport1.Page.Next(True)
' 2 ページ目の帳票を作成します。
CellReport1.Page.Repeat(1)
CellReport1.Cell("A1").Value = "2 ページ"
CellReport1.Page.Next(True)
CellReport1.Page.End()
CellReport1.Report.End()
Note メモ:

Page.Repeat メソッドと Page.Next メソッドは、必ず対でご使用ください。
参照
複数ページの帳票を作成する


同じシートにある 2 ページ以上の帳票デザインを使用する

ここでは、同じシートにある 2 ページ以上の帳票デザインを使用して、複数ページの帳票を作成する方法を説明します。

同じシートにある 2 ページ以上の帳票デザインを使用する

同じシートで 2 ページ以上ある帳票デザインを使用して複数ページの帳票を作成する場合、Page.Start メソッドの第 2 引数に対象となるページを指定します。
次のコードは、Page.Start メソッドに対象ページを指定し、2 ページ分の帳票を作成するサンプルコードです。

C#
VB
コピー
// "請求書" シートの 1、2 ページ目を使用して 2 ページ分の帳票を作成します。
cellReport1.Report.Start();
cellReport1.Report.File();
// Page.Start メソッドの第 2 引数に "1-2" と指定することで、指定ページ分の帳票が作成されます。
cellReport1.Page.Start("請求書", "1-2");
cellReport1.Page.End();
cellReport1.Report.End();
' "請求書" シートの 1、2 ページ目を使用して 2 ページの帳票を作成します。
CellReport1.Report.Start()
CellReport1.Report.File()
' Page.Start メソッドの第 2 引数に "1-2" と指定することで、指定ページ分の帳票が作成されます。
CellReport1.Page.Start("請求書", "1-2")
CellReport1.Page.End()
CellReport1.Report.End()
参照
複数ページの帳票を作成する


シートごとにある帳票デザインを使用する

ここでは、シートごとにある帳票デザインを使用して、複数ページの帳票を作成する方法を説明します。

シートごとにある帳票デザインを使用する

シートごとにある帳票デザインを使用して複数ページの帳票を作成する場合、Page.Start メソッドの第 1 引数に対象となるシート名を指定します。
次のコードは、Page.Start メソッドに異なるシート名を指定し、2 ページ分の帳票を作成するサンプルコードです。

C#
VB
コピー
// "請求書" シートの 1 ページ目と、"納品書" シートの 1 ページ目を使用して 2 ページの帳票を作成します。
cellReport1.Report.Start();
cellReport1.Report.File();
// 1 ページ目 (請求書) のデータを設定します。
cellReport1.Page.Start("請求書", "1");
cellReport1.Page.End();
// 2 ページ目 (納品書) のデータを設定します。
cellReport1.Page.Start("納品書", "1");
cellReport1.Page.End();
cellReport1.Report.End();
' "請求書" シートの 1 ページ目と、"納品書" シートの 1 ページ目を使用して 2 ページの帳票を作成します。
CellReport1.Report.Start()
CellReport1.Report.File()
' 1 ページ目 (請求書) のデータを設定します。
CellReport1.Page.Start("請求書", "1")
CellReport1.Page.End()
' 2 ページ目 (納品書) のデータを設定します。
CellReport1.Page.Start("納品書", "1")
CellReport1.Page.End()
CellReport1.Report.End()
参照
複数ページの帳票を作成する


可変明細の帳票を作成する

ここでは、可変明細帳票の基本的な作成方法について説明します。

Page.Report - Page.Next 機能を使用する

Page.Repeat メソッド、Page.Next メソッドを使用して、可変明細の帳票を作成する方法について説明します。

セクションレポート機能を使用する

Section クラス、SectionDetail クラスを使用して、可変明細の帳票を作成する方法について説明します。


Page.Repeat - Page.Next 機能を使用する

AS-Report 12.0 for .NET では、Page.Repeat メソッド、Page.Next メソッドを使用することで簡単に可変帳票を作成することができます。このトピックでは Page.Repeat メソッド、Page.Next メソッドを使用した可変帳票の基本的なコーディング手順を説明します。

Note メモ:

Section クラス、SectionDetail クラスを使用して可変帳票を作成することも可能です。詳細は「 セクションレポート機能を使用する」を参照してください。

可変帳票を作成するには

Page.Repeat メソッド、Page.Next メソッドを使用する事で簡単に可変帳票を作成することができます。このセクションでは Page.Repeat メソッド、Page.Next メソッドを使用した可変帳票の基本的なコーディング手順を説明します。

可変帳票の基本的なコーディング手順

基本的なコーディング手順を下記に示します。

  1. 帳票処理を開始します。(Page.Start メソッド)

  2. 帳票のヘッダーの位置を指定し、データを設定します。(Page.Repeat メソッド)

  3. ヘッダー行の処理を終了します。(Page.Next メソッド)

  4. 帳票の明細行の位置を指定し、データを設定します。(Page.Repeat メソッド)

  5. 明細行の処理を終了します。(Page.Next メソッド)

  6. 帳票のフッターの位置を指定し、データを設定します。(Page.Repeat メソッド)

  7. 最終行に改行を入れ、フッター行の処理を終了します。(Page.Next メソッド)

  8. 連続帳票処理を終了します。(Page.End メソッド)

サンプルコード

次のコードは、明細行が 8 行の帳票を作成するサンプルコードです。

デザインファイル | 出力帳票
デザインファイル | 出力帳票
C#
VB
コピー
private void Form1_Load(object sender, EventArgs e)
{
    cellReport1.FileName = @"C:\Book1.xlsx";
    cellReport1.Report.Start();
    cellReport1.Report.File();
    // 1. 連続帳票処理を開始します。
    cellReport1.Page.Start("Sheet1", "1-999");
    // 2. 帳票のヘッダーの位置を指定し、データを設定します。
    cellReport1.Page.Repeat(1, 4);
    cellReport1.Cell("**Tenpo").Value = "○○営業所";
    // 3. ヘッダー行の処理を終了します。("false" 指定時は改ページを挿入しない)
    cellReport1.Page.Next(false);
    for (int i = 1; i <= 8; i++)
    {
        // 4. 帳票の明細行の位置を指定し、データを設定します。
        cellReport1.Page.Repeat(5, 1);
        cellReport1.Cell("**Shouhin").Value = "商品" + i.ToString();
        cellReport1.Cell("**Tanka").Value = "単価" + i.ToString();
        cellReport1.Cell("**Suuryou").Value = "数量" + i.ToString();
        cellReport1.Cell("**Kingaku").Value = "金額" + i.ToString();
        // 5. 明細行の処理を終了します。("false" 指定時は改ページを挿入しない)
        cellReport1.Page.Next(false);
    }
    // 6. 帳票のフッターの位置を指定し、データを設定します。
    cellReport1.Page.Repeat(6, 1);
    cellReport1.Cell("**Bikou").Value = "備考";
    // 7. 最終行に改ページを挿入し、フッター行の処理を終了します。("true" 指定時は改ページを挿入する)
    cellReport1.Page.Next(true);
    // 8. 連続帳票処理を終了します。
    cellReport1.Page.End();
    cellReport1.Report.End();
    cellReport1.Report.SaveAs(@"C:\out1.xlsx");
}

Private Sub Form1_Load(sender As Object, e As EventArgs) Handles MyBase.Load
    CellReport1.FileName = "C:\Book1.xlsx"
    CellReport1.Report.Start()
    CellReport1.Report.File()
    ' 1. 連続帳票処理を開始します。
    CellReport1.Page.Start("Sheet1", "1-999")
    ' 2. 帳票のヘッダーの位置を指定し、データを設定します。
    CellReport1.Page.Repeat(1, 4)
    CellReport1.Cell("**Tenpo").Value = "○○営業所"
    CellReport1.Page.Next(False)
    ' 3. ヘッダー行の処理を終了します。("false" 指定時は改ページを挿入しない)
    For i As Integer = 1 To 8
        ' 4. 帳票の明細行の位置を指定し、データを設定します。
        CellReport1.Page.Repeat(5, 1)
        CellReport1.Cell("**Shouhin").Value = "商品" & i.ToString()
        CellReport1.Cell("**Tanka").Value = "単価" & i.ToString()
        CellReport1.Cell("**Suuryou").Value = "数量" & i.ToString()
        CellReport1.Cell("**Kingaku").Value = "金額" & i.ToString()
        ' 5. 明細行の処理を終了します。("false" 指定時は改ページを挿入しない)
        CellReport1.Page.Next(False)
    Next
    ' 6. 帳票のフッターの位置を指定し、データを設定します。
    CellReport1.Page.Repeat(6, 1)
    CellReport1.Cell("**Bikou").Value = "備考"
    ' 7. 最終行に改行を入れ、フッター行の処理を終了します。
    CellReport1.Page.Next(True)
    ' 8. 連続帳票処理を終了します。
    CellReport1.Page.End()
    CellReport1.Report.End()
    CellReport1.Report.SaveAs("C:\Out1.xlsx")
End Sub
参照
可変明細の帳票を作成する


セクションレポート機能を使用する

AS-Report 12.0 for .NET では、セクションレポート機能(Section クラス、SectionDetail クラス)を使用することで簡単に可変帳票を作成することができます。このトピックでは Section クラス、SectionDetail クラスを使用した可変帳票の基本的なコーディング手順を説明します。

Note メモ:

Page.Repeat メソッド、Page.Next メソッドを使用して可変帳票を作成することも可能です。詳細は「 Page.Repeat - Page.Next 機能を使用する」を参照してください。

このトピックは、次のセクションを含みます。

  • 可変帳票を作成するには
  • ヘッダーイベント、フッターイベントについて
  • 参照
可変帳票を作成するには

Section クラス、SectionDetail クラスを使用することで簡単に可変帳票を作成することができます。このセクションでは Section クラス、SectionDetail クラスを使用した可変帳票の基本的なコーディング手順を説明します。

可変帳票の基本的なコーディング手順

基本的なコーディング手順を下記に示します。

  1. ヘッダーイベント、フッターイベントを実装します。

  2. 帳票処理を開始します。(Section.Start メソッド)

  3. 帳票のヘッダー、フッターの位置を指定します。(Section.Header メソッド、Section.Footer メソッド)

  4. 各オプションを設定します。(Section.ReportToFill プロパティ、Section.MaxDetailCount プロパティ)

  5. 帳票の明細行の位置を指定します。(Section.Detail メソッド)

  6. 帳票の明細処理を開始します。(SectionDetail.Start メソッド)

  7. 帳票の明細部にデータを設定します。(SectionDetail.Cell メソッド、SectionDetail.Pos メソッド)

  8. 帳票の明細処理を終了します。(SectionDetail.Next メソッド)

  9. 連続帳票処理を終了します。(Section.End メソッド)

サンプルコード

次のコードは、1 ページの出力明細行を 5 行に設定し、8 明細分の帳票を作成するサンプルコードです。

デザインファイル | 出力帳票
デザインファイル | 出力帳票
C#
VB
コピー
// 1. ヘッダーイベント、フッターイベントを実装します。
void cellReport1_SectionNewPage(object sender, AdvanceSoftware.ASReport.SectionNewPageEventArgs e)
{
    e.Header.Cell("**Tenpo").Value = "○○営業所";
}
void cellReport1_SectionEndPage(object sender, AdvanceSoftware.ASReport.SectionEndPageEventArgs e)
{
    e.Footer.Cell("**Bikou").Value = "備考";
}
private void Form1_Load(object sender, EventArgs e)
{
    cellReport1.FileName = @"C:\Book1.xlsx";
    cellReport1.Report.Start();
    cellReport1.Report.File();
    // 2. 連続帳票処理を開始します。
    cellReport1.Section.Start("Sheet1", true);
    // 3. 帳票のヘッダー、フッターの位置を指定します。
    cellReport1.Section.Header("1:4");
    cellReport1.Section.Footer("6");
    // 4. 各オプションを設定します。
    cellReport1.Section.MaxDetailCount = 5;  // 1 ページの明細行数を指定します。
    cellReport1.Section.ReportToFill = true; // 1 ページに設定される明細行に関わらず、固定の明細行数(空白行含む)を出力します。
    // 5. 帳票の明細行の位置を指定します。
    AdvanceSoftware.ASReport.SectionDetail sectionDetail = cellReport1.Section.Detail("A5:F5");
    for (int i = 1; i <= 8; i++)
    {
        // 6. 帳票の明細処理を開始します。
        sectionDetail.Start();
        // 7. 帳票の明細部にデータを設定します。
        sectionDetail.Cell("**Shouhin").Value = "商品" + i.ToString();
        sectionDetail.Cell("**Tanka").Value = "単価" + i.ToString();
        sectionDetail.Cell("**Suuryou").Value = "数量" + i.ToString();
        sectionDetail.Cell("**Kingaku").Value = "金額" + i.ToString();
        // 8. 帳票の明細処理を終了します。
        sectionDetail.Next();
    }
    // 9. 連続帳票処理を終了します。
    cellReport1.Section.End();
    cellReport1.Report.End();
    cellReport1.Report.SaveAs(@"C:\out1.xlsx");
}

' 1. ヘッダーイベント、フッターイベントを実装します。
Private Sub CellReport1_SectionNewPage(sender As Object, e As AdvanceSoftware.ASReport.SectionNewPageEventArgs) Handles CellReport1.SectionNewPage
    e.Header.Cell("**Tenpo").Value = "○○営業所"
End Sub
Private Sub CellReport1_SectionEndPage(sender As Object, e As AdvanceSoftware.ASReport.SectionEndPageEventArgs) Handles CellReport1.SectionEndPage
    e.Footer.Cell("**Bikou").Value = "備考"
End Sub
Private Sub Form1_Load(sender As Object, e As EventArgs) Handles MyBase.Load
    CellReport1.FileName = "C:\Book1.xlsx"
    CellReport1.Report.Start()
    CellReport1.Report.File()
    ' 2. 連続帳票処理を開始します。
    CellReport1.Section.Start("Sheet1", true)
    ' 3. 帳票のヘッダー、フッターの位置を指定します。
    CellReport1.Section.Header("1:4")
    CellReport1.Section.Footer("6")
    ' 4. 各オプションを設定します。
    CellReport1.Section.MaxDetailCount = 5 ' 1 ページの明細行数を指定します。
    CellReport1.Section.ReportToFill = True' 1 ページに設定される明細行に関わらず、固定の明細行数(空白行含む)を出力します。
    ' 5. 帳票の明細行の位置を指定します。
    Dim sectionDetail As AdvanceSoftware.ASReport.SectionDetail = CellReport1.Section.Detail("A5:F5")
    For i As Integer = 1 To 8
        ' 6. 帳票の明細処理を開始します。
        sectionDetail.Start()
        ' 7. 帳票の明細部にデータを設定します。
        sectionDetail.Cell("**Shouhin").Value = "商品" & i.ToString()
        sectionDetail.Cell("**Tanka").Value = "単価" & i.ToString()
        sectionDetail.Cell("**Suuryou").Value = "数量" & i.ToString()
        sectionDetail.Cell("**Kingaku").Value = "金額" & i.ToString()
        ' 8. 帳票の明細処理を終了します。
        sectionDetail.Next()
    Next
    ' 9. 連続帳票処理を終了します。
    CellReport1.Section.End()
    CellReport1.Report.End()
    CellReport1.Report.SaveAs("C:\Out1.xlsx")
End Sub
ヘッダーイベント、フッターイベントについて

Section クラス、SectionDetail クラスを使用した可変帳票作成では、ヘッダーイベント、フッターイベントを使用して、ヘッダー、フッターにデータを設定します。このセクションではヘッダーイベント、フッターイベントの使用方法を説明します。

ヘッダーイベントを使用する

  1. ヘッダーイベントを実装します。

    Note メモ:

    ヘッダーイベントの実装方法については 「 SectionNewPage イベントを実装する」 を参照してください。

  2. SectionNewPageEventHandler の Header プロパティを使用してヘッダーにデータを設定します。下記サンプルコードではヘッダー部の A1 セルに現在のページ数を設定します。

    C#
    VB
    コピー
    void cellReport1_SectionNewPage(object sender, AdvanceSoftware.ASReport.SectionNewPageEventArgs e)
{
    // 現在のページ数を設定します。
    e.Header.Cell("A1").Value = e.PageNo.ToString() + "ページ";
}
    Private Sub CellReport1_SectionNewPage(sender As Object, e As AdvanceSoftware.ASReport.SectionNewPageEventArgs) Handles CellReport1.SectionNewPage
    ' 現在のページ数を設定します。
    e.Header.Cell("A1").Value = e.PageNo.ToString() & "ページ"
End Sub
Note メモ:

ページが新規作成されるたびにヘッダーイベントが実行されます。

フッターイベントを使用する

  1. フッターイベントを実装します。

    Note メモ:

    フッターイベントの実装方法については 「 SectionEndPage イベントを実装する」 を参照してください。

  2. SectionEndPageEventHandler の Footer プロパティを使用してフッターにデータを設定します。下記サンプルコードではフッター部の A10 セルに現在のページ数を設定します。

    C#
    VB
    コピー
    void cellReport1_SectionEndPage(object sender, AdvanceSoftware.ASReport.SectionEndPageEventArgs e)
{
    // 現在のページ数を設定します。
    e.Footer.Cell("A10").Value = e.PageNo.ToString() + "ページ";
}
    Private Sub CellReport1_SectionEndPage(sender As Object, e As AdvanceSoftware.ASReport.SectionEndPageEventArgs) Handles CellReport1.SectionEndPage
    ' 現在のページ数を設定します。
    e.Footer.Cell("A10").Value = e.PageNo.ToString() & "ページ"
End Sub
Note メモ:

明細行の最終行設定時か、帳票作成終了時にフッターイベントが実行されます。

参照
可変明細の帳票を作成する


対応する Excel 修飾機能

ここでは、AS-Report 12.0 for .NET のコンポーネント、コントロールで対応する Excel 修飾機能について説明します。

レポートコンポーネント(ReportMode=Speed)

レポートコンポーネント(ReportMode=Speed 使用時)が対応する Excel 修飾機能について説明します。

レポートコンポーネント(ReportMode=Legacy)

レポートコンポーネント(ReportMode=Legacy 使用時)が対応する Excel 修飾機能について説明します。

Windows フォーム用ビューア

Windows フォーム用ビューアが対応する Excel 修飾機能について説明します。

WPF 用ビューア

WPF 用ビューアが対応する Excel 修飾機能について説明します。

Web 用ビューア
Web 用ビューアが対応する Excel 修飾機能について説明します。


レポートコンポーネント(ReportMode.Speed) 対応機能一覧表

レポートコンポーネントで ReportMode.Speed を指定して帳票出力を行う際、デザインファイルに設定された Excel の各種設定が、印刷、Excel、PDF ファイル出力時に反映されるかを表します。掲載のない機能は、基本的に AS-Report 12.0 for .NET で動作保証を行っていない機能となりますが、詳細な対応状況は 「サポートサービス」よりお問い合わせください。

Note メモ:

Windows デスクトップ アプリケーション(Windows/WPF)を作成する場合は、出力時に AS-Report の独自機能を使用するか、Excel オブジェクトを使用するか、ExcelMode プロパティで切り替えることができます。詳しくは、「 Excel インストールが必要な場合」をご参照ください。

機能一覧表

[○ = 対応、× = 未対応、△ = 制限あり、－ = 該当なし]
Excel 設定項目 | 対応関数 | xls 形式 |  |  |  |  | xlsx 形式
 |  | AS-Report 機能のみを使用 |  | Excel オブジェクトを使用 |  |  | AS-Report 機能のみを使用 |  | Excel オブジェクトを使用
 |  | Excel | PDF | 印刷 | Excel | PDF | Excel | PDF | 印刷 | Excel | PDF
[ページ設定] - [ページ]
印刷の向き (縦 / 横) Size ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
拡大縮小印刷 (拡大 / 縮小) Size ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
拡大縮小印刷 (横 1~32767×縦 1~32767) × ○ × × ○ × ○ × × ○ ×
用紙サイズ Size
SizeFree 		○ ○ ○ ○ ○ ○ ○ ○ ○ ○
印刷品質 × ○ － － ○ － ○ － － ○ －
先頭ページ番号 × ○ × × ○ × ○ × × ○ ×
[ページ設定] - [余白]
余白 (上 / 下 / 左 / 右 / ヘッダー / フッター) Margin ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
余白 (ページ中央：水平 / 垂直) Center ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[ページ設定] - [ヘッダー / フッター]
ヘッダー / フッター (左詰 [&L] / 中央揃え [&C] / 右詰 [&R] / 二重下線 [&E] / 上付き文字 [&X] / 下付き文字 [&Y] / 太字 [&B] / 斜体 [&I] / 下線付き [&U] / 取り消し線 [&S] / 日付 [&D] / 時刻 [&T] / シート見出し名 [&A] / ページ番号 [&P] / & 表示 [&&] / 総ページ数 [&N] / フォント名 [&"フォント名"] / フォントサイズ [&nn]) Header
Footer
 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
ヘッダー / フッター (ファイル名 [&F]) × ○ × × ○ × ○ × × ○ ×
ヘッダー / フッター (図) × ○ × ○ ○ × ○ × ○ ○ ×
[ページ設定] - [シート]
印刷範囲 PrintArea
ApplyPrintArea 		○ ○ ○ ○ ○ ○ ○ ○ ○ ○
印刷タイトル (行のタイトル / 列のタイトル) PrintTitle
ApplyPrintTitle 		○ ○ ○ ○ ○ ○ ○ ○ ○ ○
ページの方向 (左から右へ / 上から下へ) PageOrder ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[ページ設定] - [シート]
改ページ Break ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
コメント × ○ × ○ ○ × ○ × ○ ○ ×
ワードアート × ○ × ○ ○ × ○ × ○ ○ ×
グラフ(*1) × ○ × ○ ○ ○ ○ △(*2) ○ ○ ○
グラフシート × × × × × × × × × × ×
名前の定義 × △(*3) － － △(*3) － △(*3) － － △(*3) －
関数の挿入 Func ○ △(*4) ○ ○ ○ ○ △(*4) ○ ○ ○
図 (emf、bmp、dib、gif、jpg、png) AddImage ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
オブジェクト × ○ × ○ ○ × ○ × ○ ○ ×
オートシェイプ AddShape
AddLine 		○ △(*5) ○ ○ △(*5) ○ △(*5) ○ ○ △(*5)
テキストボックス AddTextBox ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
グループ化 (オブジェクト) × × × × × × × × × × ×
[オートシェイプの書式設定] - [色と線]
[図形の書式設定] - [塗りつぶし] / [線の色] / [線のスタイル]
塗りつぶし (単色) FillColor
FillColor2 		○ ○ ○ ○ ○ ○ ○ ○ ○ ○
塗りつぶし (塗りつぶしなし) ShapeNoFill ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
塗りつぶし効果 / 塗りつぶし (グラデーション) × ○ × ○ ○ × ○ × ○ ○ ×
塗りつぶし (透明 / 透過性) × ○ × ○ ○ × ○ × ○ ○ ×
線の色 (単色) LineColor
LineColor2 		○ ○ ○ ○ ○ ○ ○ ○ ○ ○
線の色 (透明 / 透過性) × ○ × ○ ○ × ○ × ○ ○ ×
実線 / 点線 LineStyle ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
太さ / 幅 LineWeight ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
コネクタ × ○ × ○ ○ × ○ × ○ ○ ×
始点のスタイル / 種類 / サイズ ArrowTypeS ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
終点のスタイル / 種類 / サイズ ArrowTypeE ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[テキストボックスの書式設定] - [配置]
[図形の書式設定] - [テキストボックス] - [テキストのレイアウト]
文字の配置 (縦位置 / 横位置) / 垂直方向の配置 TextAlign
TextAnchor 		○ ○ ○ ○ ○ ○ ○ ○ ○ ○
方向 / 文字列の方向 TextVertical ○ △(*6) ○ ○ △(*6) ○ △(*6) ○ ○ △(*6)
[テキストボックスの書式設定] - [フォント](*7)
フォント名 FontName ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
スタイル (標準 / 太字 / 斜体) FontStyle ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
サイズ FontPoint ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
下線 / 下線のスタイル (なし / 下線 / 二重下線) FontULine ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
色 / フォントの色 FontColor
FontColor2 		○ ○ ○ ○ ○ ○ ○ ○ ○ ○
文字飾り (取り消し線 / 上付き / 下付き) × ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [表示形式]
分類（標準 / 数値 / 通貨 / 会計 / 日付 / 時刻 / パーセンテージ / 分数 / 指数 / 文字列 / その他 / ユーザー定義) Format ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [配置]
横位置 (標準 / 左詰め / 中央揃え / 右詰め / 繰り返し / 両端揃え / 選択範囲内で中央 / 均等割り付け) HorizontalAlignment ○ △(*8) ○ ○ △(*8) ○ △(*8) ○ ○ △(*8)
縦位置 (上詰め / 中央揃え / 下詰め / 両端揃え / 均等割り付け) VerticalAlignment ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
文字の制御 (折り返して全体を表示する) WrapText ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
文字の制御 (縮小して全体を表示する) ShrinkToFit ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
文字の制御 (セルを結合する) MergeCells ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
方向 (縦書き / -90～90 度) Orientation ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [フォント](*7)
フォント名 FontName ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
スタイル (標準 / 太字 / 斜体 / 太字＋斜体) FontStyle ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
サイズ FontPoint ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
下線 (なし / 下線 / 二重下線) FontULine ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
色 FontColor
FontColor2 		○ ○ ○ ○ ○ ○ ○ ○ ○ ○
文字飾り (取り消し線 / 上付き / 下付き) FontStyle ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [罫線]
プリセット (外枠) Box ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (上) LineTop ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (下) LineBottom ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (左) LineLeft ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (右) LineRight ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (左上がり) LineLeftUp ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (右上がり) LineRightUp ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (方向 -90～90 度) × ○ × ○ ○ × ○ × ○ ○ ×
線 (スタイル) Box
LineTop
LineBottom
LineLeft
LineRight
LineLeftUp
LineRightUp 		○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (色) Box
LineTop
LineBottom
LineLeft
LineRight
LineLeftUp
LineRightUp 		○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [パターン] / [塗りつぶし]
セルの網掛け (色) / 背景色 BackColor
BackColor2 		○ ○ ○ ○ ○ ○ ○ ○ ○ ○
塗りつぶし効果 (グラデーション) × － － － － － ○ × ○ ○ ×
パターンの色 ForeColor
ForeColor2 		○ ○ ○ ○ ○ ○ ○ ○ ○ ○
セルの網掛け (パターン) / パターンの種類 Pattern ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[書式] - [行] / [列]
高さ / 行の高さ RowHeight ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
高さ / 行の高さの自動調整 × × × × × × × × × × ×
幅 / 列の幅 ColWidth ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
幅 / 列の幅の自動調整 × × × × × × × × × × ×
[書式] - [シート]
名前の変更 / シート名の変更 Name ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
非表示 / 再表示 － － － － － － － － － － －
[書式]
条件付き書式 × × × × × × × × × × ×
[ツール]
[開発]
マクロ × × × × × × × × × × ×
[ツール]-[オプション] - [全般]
[Excel のオプション] - [基本設定]
標準フォント名 × ○ － － ○ － ○ － － ○ －
標準フォントサイズ × ○ － － ○ － ○ － － ○ －
[ツール] - [保護]
[校閲]
シートの保護 × ○ － － ○ － ○ － － ○ －
ブックの保護 × × － － × － × － － × －
[データ]
フィルタ × × × × × × × × × × ×
集計 × × × × × × × × × × ×
入力規則 × × × × × × × × × × ×
ピボットテーブル × × × × × × × × × × ×
アウトライン × × × × × × × × × × ×
[ウィンドウ]
[表示]
分割 × ○ － － ○ － ○ － － ○ －
ウィンドウ枠の固定 × ○ － － ○ － ○ － － ○ －
[ページレイアウト]
テーマ × － － － － － × × × × ×
Note メモ:

(*1)グラフの編集には未対応。

(*2)外部のサードパーティ製ライブラリ等を使用し、ユーザーがグラフイメージ生成機能を独自に実装する必要があります。

(*3)ブック名が設定された名前の定義には未対応。

(*4)ExcelMode プロパティを使用した再計算は未対応。一部関数は ApplyFormula プロパティにて対応。

(*5)描画可能なオートシェイプは(右図)のみです。ただし、Excel 2007 以降で作成した xls ファイルでは台形に未対応。

(*6)文字列の方向 (縦書き) で半角英数字の描画は未対応。

(*7)同一セル内、テキストボックス内で複数の書式を設定することはできません。

(*8)横位置 (繰り返し) は未対応。

 描画可能なオートシェイプ
参照
対応する Excel 修飾機能


レポートコンポーネント(ReportMode.Legacy) 対応機能一覧表

レポートコンポーネントで ReportMode.Legacy を指定して帳票出力を行う際、デザインファイルに設定された Excel の各種設定が、印刷、Excel、PDF ファイル出力時に反映されるかを表します。掲載のない機能は、基本的に AS-Report 12.0 for .NET で動作保証を行っていない機能となりますが、詳細な対応状況は 「サポートサービス」よりお問い合わせください。

Note メモ:

Windows デスクトップ アプリケーション(Windows/WPF)を作成する場合は、出力時に AS-Report の独自機能を使用するか、Excel オブジェクトを使用するか、ExcelMode プロパティで切り替えることができます。詳しくは、「 Excel インストールが必要な場合」をご参照ください。

機能一覧表

[○ = 対応、× = 未対応、△ = 制限あり、－ = 該当なし]
Excel 設定項目 | 対応関数 | xls 形式 |  |  |  | xlsx 形式
 |  | AS-Report 機能のみを使用(Windows/WPF/Web) | Excel オブジェクトを使用(Windows/WPF) |  |  | AS-Report 機能のみを使用(Windows/WPF/Web) | Excel オブジェクトを使用(Windows/WPF)
 |  | PDF | 印刷 | Excel | PDF | PDF | 印刷 | Excel | PDF
[ページ設定] - [ページ]
印刷の向き (縦 / 横) Size ○ ○ ○ ○ ○ ○ ○ ○
拡大縮小印刷 (拡大 / 縮小) Size ○ ○ ○ ○ ○ ○ ○ ○
拡大縮小印刷 (横 1~32767×縦 1~32767) × × × ○ × × × ○ ×
用紙サイズ Size
SizeFree 		○ ○ ○ ○ ○ ○ ○ ○
印刷品質 × － － ○ － － － ○ －
先頭ページ番号 × × × ○ × × × ○ ×
[ページ設定] - [余白]
余白 (上 / 下 / 左 / 右 / ヘッダー / フッター) Margin ○ ○ ○ ○ ○ ○ ○ ○
余白 (ページ中央：水平 / 垂直) Center ○ ○ ○ ○ ○ ○ ○ ○
[ページ設定] - [ヘッダー / フッター]
ヘッダー / フッター (左詰 [&L] / 中央揃え [&C] / 右詰 [&R] / 二重下線 [&E] / 上付き文字 [&X] / 下付き文字 [&Y] / 太字 [&B] / 斜体 [&I] / 下線付き [&U] / 取り消し線 [&S] / 日付 [&D] / 時刻 [&T] / シート見出し名 [&A] / ページ番号 [&P] / & 表示 [&&] / 総ページ数 [&N] / フォント名 [&"フォント名"] / フォントサイズ [&nn]) Header
Footer
 ○ ○ ○ ○ ○ ○ ○ ○
ヘッダー / フッター (ファイル名 [&F]) × × × ○ × × × ○ ×
ヘッダー / フッター (図) × × ○ ○ × × ○ ○ ×
[ページ設定] - [シート]
印刷範囲 PrintArea
ApplyPrintArea 		○ ○ ○ ○ ○ ○ ○ ○
印刷タイトル (行のタイトル / 列のタイトル) PrintTitle
ApplyPrintTitle 		○ ○ ○ ○ ○ ○ ○ ○
ページの方向 (左から右へ / 上から下へ) PageOrder ○ ○ ○ ○ ○ ○ ○ ○
[ページ設定] - [シート]
改ページ Break ○ ○ ○ ○ ○ ○ ○ ○
コメント × × ○ ○ × × ○ ○ ×
ワードアート × × ○ ○ × × ○ ○ ×
グラフ(*1) × × ○ ○ ○ △(*2) ○ ○ ○
グラフシート × × × × × × × × ×
名前の定義 × － － △(*3) － － － △(*3) －
関数の挿入 Func △(*4) ○ ○ ○ △(*4) ○ ○ ○
図 (emf、bmp、dib、gif、jpg、png) AddImage ○ ○ ○ ○ ○ ○ ○ ○
オブジェクト × × ○ ○ × × ○ ○ ×
オートシェイプ AddShape
AddLine 		△(*5) ○ ○ △(*5) △(*5) ○ ○ △(*5)
テキストボックス AddTextBox ○ ○ ○ ○ ○ ○ ○ ○
グループ化 (オブジェクト) × × × × × × × × ×
[オートシェイプの書式設定] - [色と線]
[図形の書式設定] - [塗りつぶし] / [線の色] / [線のスタイル]
塗りつぶし (単色) FillColor
FillColor2 		○ ○ ○ ○ ○ ○ ○ ○
塗りつぶし (塗りつぶしなし) ShapeNoFill ○ ○ ○ ○ ○ ○ ○ ○
塗りつぶし効果 / 塗りつぶし (グラデーション) × × ○ ○ × × ○ ○ ×
塗りつぶし (透明 / 透過性) × × ○ ○ × × ○ ○ ×
線の色 (単色) LineColor
LineColor2 		○ ○ ○ ○ ○ ○ ○ ○
線の色 (透明 / 透過性) × × ○ ○ × × ○ ○ ×
実線 / 点線 LineStyle ○ ○ ○ ○ ○ ○ ○ ○
太さ / 幅 LineWeight ○ ○ ○ ○ ○ ○ ○ ○
コネクタ × × ○ ○ × × ○ ○ ×
始点のスタイル / 種類 / サイズ ArrowTypeS ○ ○ ○ ○ ○ ○ ○ ○
終点のスタイル / 種類 / サイズ ArrowTypeE ○ ○ ○ ○ ○ ○ ○ ○
[テキストボックスの書式設定] - [配置]
[図形の書式設定] - [テキストボックス] - [テキストのレイアウト]
文字の配置 (縦位置 / 横位置) / 垂直方向の配置 TextAlign
TextAnchor 		○ ○ ○ ○ ○ ○ ○ ○
方向 / 文字列の方向 TextVertical △(*6) ○ ○ △(*6) △(*6) ○ ○ △(*6)
[テキストボックスの書式設定] - [フォント](*7)
フォント名 FontName ○ ○ ○ ○ ○ ○ ○ ○
スタイル (標準 / 太字 / 斜体) FontStyle ○ ○ ○ ○ ○ ○ ○ ○
サイズ FontPoint ○ ○ ○ ○ ○ ○ ○ ○
下線 / 下線のスタイル (なし / 下線 / 二重下線) FontULine ○ ○ ○ ○ ○ ○ ○ ○
色 / フォントの色 FontColor
FontColor2 		○ ○ ○ ○ ○ ○ ○ ○
文字飾り (取り消し線 / 上付き / 下付き) × ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [表示形式]
分類（標準 / 数値 / 通貨 / 会計 / 日付 / 時刻 / パーセンテージ / 分数 / 指数 / 文字列 / その他 / ユーザー定義) Format ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [配置]
横位置 (標準 / 左詰め / 中央揃え / 右詰め / 繰り返し / 両端揃え / 選択範囲内で中央 / 均等割り付け) HorizontalAlignment △(*8) ○ ○ △(*8) △(*8) ○ ○ △(*8)
縦位置 (上詰め / 中央揃え / 下詰め / 両端揃え / 均等割り付け) VerticalAlignment ○ ○ ○ ○ ○ ○ ○ ○
文字の制御 (折り返して全体を表示する) WrapText ○ ○ ○ ○ ○ ○ ○ ○
文字の制御 (縮小して全体を表示する) ShrinkToFit ○ ○ ○ ○ ○ ○ ○ ○
文字の制御 (セルを結合する) MergeCells ○ ○ ○ ○ ○ ○ ○ ○
方向 (縦書き / -90～90 度) Orientation ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [フォント](*7)
フォント名 FontName ○ ○ ○ ○ ○ ○ ○ ○
スタイル (標準 / 太字 / 斜体 / 太字＋斜体) FontStyle ○ ○ ○ ○ ○ ○ ○ ○
サイズ FontPoint ○ ○ ○ ○ ○ ○ ○ ○
下線 (なし / 下線 / 二重下線) FontULine ○ ○ ○ ○ ○ ○ ○ ○
色 FontColor
FontColor2 		○ ○ ○ ○ ○ ○ ○ ○
文字飾り (取り消し線 / 上付き / 下付き) FontStyle ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [罫線]
プリセット (外枠) Box ○ ○ ○ ○ ○ ○ ○ ○
罫線 (上) LineTop ○ ○ ○ ○ ○ ○ ○ ○
罫線 (下) LineBottom ○ ○ ○ ○ ○ ○ ○ ○
罫線 (左) LineLeft ○ ○ ○ ○ ○ ○ ○ ○
罫線 (右) LineRight ○ ○ ○ ○ ○ ○ ○ ○
罫線 (左上がり) LineLeftUp ○ ○ ○ ○ ○ ○ ○ ○
罫線 (右上がり) LineRightUp ○ ○ ○ ○ ○ ○ ○ ○
罫線 (方向 -90～90 度) × × ○ ○ × × ○ ○ ×
線 (スタイル) Box
LineTop
LineBottom
LineLeft
LineRight
LineLeftUp
LineRightUp 		○ ○ ○ ○ ○ ○ ○ ○
罫線 (色) Box
LineTop
LineBottom
LineLeft
LineRight
LineLeftUp
LineRightUp 		○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [パターン] / [塗りつぶし]
セルの網掛け (色) / 背景色 BackColor
BackColor2 		○ ○ ○ ○ ○ ○ ○ ○
塗りつぶし効果 (グラデーション) × － － － － × ○ ○ ×
パターンの色 ForeColor
ForeColor2 		○ ○ ○ ○ ○ ○ ○ ○
セルの網掛け (パターン) / パターンの種類 Pattern ○ ○ ○ ○ ○ ○ ○ ○
[書式] - [行] / [列]
高さ / 行の高さ RowHeight ○ ○ ○ ○ ○ ○ ○ ○
高さ / 行の高さの自動調整 × × × × × × × × ×
幅 / 列の幅 ColWidth ○ ○ ○ ○ ○ ○ ○ ○
幅 / 列の幅の自動調整 × × × × × × × × ×
[書式] - [シート]
名前の変更 / シート名の変更 Name ○ ○ ○ ○ ○ ○ ○ ○
非表示 / 再表示 － － － － － － － － －
[書式]
条件付き書式 × × × × × × × × ×
[ツール]
[開発]
マクロ × × × × × × × × ×
[ツール]-[オプション] - [全般]
[Excel のオプション] - [基本設定]
標準フォント名 × － － ○ － － － ○ －
標準フォントサイズ × － － ○ － － － ○ －
[ツール] - [保護]
[校閲]
シートの保護 × － － ○ － － － ○ －
ブックの保護 × － － × － － － × －
[データ]
フィルタ × × × × × × × × ×
集計 × × × × × × × × ×
入力規則 × × × × × × × × ×
ピボットテーブル × × × × × × × × ×
アウトライン × × × × × × × × ×
[ウィンドウ]
[表示]
分割 × － － ○ － － － ○ －
ウィンドウ枠の固定 × － － ○ － － － ○ －
[ページレイアウト]
テーマ × － － － － × × × ×
Note メモ:

(*1)グラフの編集には未対応。

(*2)外部のサードパーティ製ライブラリ等を使用し、ユーザーがグラフイメージ生成機能を独自に実装する必要があります。

(*3)ブック名が設定された名前の定義には未対応。

(*4)ExcelMode プロパティを使用した再計算は未対応。一部関数は ApplyFormula プロパティにて対応。

(*5)描画可能なオートシェイプは(右図)のみです。ただし、Excel 2007 以降で作成した xls ファイルでは台形に未対応。

(*6)文字列の方向 (縦書き) で半角英数字の描画は未対応。

(*7)同一セル内、テキストボックス内で複数の書式を設定することはできません。

(*8)横位置 (繰り返し) は未対応。

 描画可能なオートシェイプ
参照
対応する Excel 修飾機能


Windows フォーム用ビューア対応機能一覧表

Windows フォーム用ビューアで帳票出力を行う際、デザインファイルに設定された Excel の各種設定が、プレビュー、印刷、Excel、PDF ファイル出力時に反映されるかを表します。掲載のない機能は、基本的に AS-Report 12.0 for .NET で動作保証を行っていない機能となりますが、詳細な対応状況は 「サポートサービス」よりお問い合わせください。

Note メモ:

Windows デスクトップ アプリケーション(Windows/WPF)を作成する場合は、出力時に AS-Report の独自機能を使用するか、Excel オブジェクトを使用するか、ExcelMode プロパティで切り替えることができます。詳しくは、「 Excel インストールが必要な場合」をご参照ください。

機能一覧表

[○ = 対応、× = 未対応、△ = 制限あり、－ = 該当なし]
Excel 設定項目 | xls 形式 |  |  |  |  |  |  |  | xlsx 形式
 | AS-Report 機能のみを使用 |  |  |  | Excel オブジェクトを使用 |  |  |  | AS-Report 機能のみを使用 |  |  |  | Excel オブジェクトを使用
 | プレビュー | 印刷 | Excel | PDF | プレビュー | 印刷 | Excel | PDF | プレビュー | 印刷 | Excel | PDF | プレビュー | 印刷 | Excel | PDF
[ページ設定] - [ページ]
印刷の向き (縦 / 横) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
拡大縮小印刷 (拡大 / 縮小) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
拡大縮小印刷 (横 1~32767×縦 1~32767) × × ○ × × × ○ × × × ○ × × × ○ ×
用紙サイズ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
印刷品質 - - ○ - - - ○ - - - ○ - - - ○ -
先頭ページ番号 × × ○ × × × ○ × × × ○ × × × ○ ×
[ページ設定] - [余白]
余白 (上 / 下 / 左 / 右 / ヘッダー / フッター) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
余白 (ページ中央 水平 / 垂直) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[ページ設定] - [ヘッダー / フッター]
ヘッダー / フッター (左詰 [&L] / 中央揃え [&C] / 右詰 [&R] / 二重下線 [&E] / 上付き文字 [&X] / 下付き文字 [&Y] / 太字 [&B] / 斜体 [&I] / 下線付き [&U] / 取り消し線 [&S] / 日付 [&D] / 時刻 [&T] / シート見出し名 [&A] / ページ番号 [&P] / & 表示 [&&] / 総ページ数 [&N] / フォント名 [&"フォント名"] / フォントサイズ [&nn]) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
ヘッダー / フッター (ファイル名 [&F]) × × ○ × × × ○ × × × ○ × × × ○ ×
ヘッダー / フッター (図) × × ○ × × ○ ○ × × × ○ × × ○ ○ ×
[ページ設定] - [シート]
印刷範囲 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
印刷タイトル (行のタイトル / 列のタイトル) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
ページの方向 (左から右へ / 上から下へ) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[挿入]
改ページ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
コメント × × ○ × × ○ ○ × × × ○ × × ○ ○ ×
ワードアート × × ○ × × ○ ○ × × × ○ × × ○ ○ ×
グラフ (*1) × × ○ × ○ ○ ○ ○ × × ○ △ (*2) ○ ○ ○ ○
グラフシート × × × × × × × × × × × × × × × ×
名前の定義 - - △ (*3) - - - △ (*3) - - - △ (*3) - - - △ (*3) -
関数の挿入 △ (*4) △ (*4) ○ △ (*4) ○ ○ ○ ○ △ (*4) △ (*4) ○ △ (*4) ○ ○ ○ ○
図 (emf、bmp、dib、gif、jpg、png) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
オブジェクト × × ○ × × ○ ○ × × × ○ × × ○ ○ ×
オートシェイプ △ (*5) △ (*5) ○ △ (*5) △ (*5) ○ ○ △ (*5) △ (*5) △ (*5) ○ △ (*5) △ (*5) ○ ○ △ (*5)
グループ化 (オブジェクト) × × × × × × × × × × × × × × × ×
[オートシェイプの書式設定] - [色と線]
[図形の書式設定] - [塗りつぶし] / [線の色] / [線のスタイル]
塗りつぶし (単色) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
塗りつぶし (塗りつぶしなし) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
塗りつぶし効果 / 塗りつぶし (グラデーション) × × ○ × × ○ ○ × × × ○ × × ○ ○ ×
塗りつぶし (透明 / 透過性) × × ○ × × ○ ○ × × × ○ × × ○ ○ ×
線の色 (単色) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
線の色 (透明 / 透過性) × × ○ × × ○ ○ × × × ○ × × ○ ○ ×
スタイル / 太さ / 幅 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
実線 / 点線 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
コネクタ × × ○ × × ○ ○ × × × ○ × × ○ ○ ×
始点のスタイル / 種類 / サイズ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
終点のスタイル / 種類 / サイズ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[テキストボックスの書式設定] - [配置]
[図形の書式設定] - [テキストボックス] - [テキストのレイアウト]
文字の配置 (縦位置 / 横位置) / 垂直方向の配置 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
方向 / 文字列の方向 △ (*6) △ (*6) ○ △ (*6) △ (*6) ○ ○ △ (*6) △ (*6) △ (*6) ○ △ (*6) △ (*6) ○ ○ △ (*6)
[テキストボックスの書式設定] - [フォント] (*7)
フォント名 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
スタイル (標準 / 太字 / 斜体) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
サイズ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
下線 / 下線のスタイル (なし / 下線 / 二重下線) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
色 / フォントの色 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
文字飾り (取り消し線 / 上付き / 下付き) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [表示形式]
分類(標準 / 数値 / 通貨 / 会計 / 日付 / 時刻 / パーセンテージ / 分数 / 指数 / 文字列 / その他 / ユーザー定義) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [配置]
横位置 (標準 / 左詰め / 中央揃え / 右詰め / 繰り返し / 両端揃え / 選択範囲内で中央 / 均等割り付け) △ (*8) △ (*8) ○ △ (*8) △ (*8) ○ ○ △ (*8) △ (*8) △ (*8) ○ △ (*8) △ (*8) ○ ○ △ (*8)
縦位置 (上詰め / 中央揃え / 下詰め / 両端揃え / 均等割り付け) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
文字の制御 (折り返して全体を表示する) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
文字の制御 (縮小して全体を表示する) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
文字の制御 (セルを結合する) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
方向 (縦書き / -90～90 度) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [フォント] (*7)
フォント名 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
スタイル (標準 / 太字 / 斜体 / 太字+斜体) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
サイズ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
下線 (なし / 下線 / 二重下線) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
色 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
文字飾り (取り消し線 / 上付き / 下付き) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [罫線]
プリセット (外枠) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (上) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (下) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (左) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (右) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (左上がり) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (右上がり) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (方向 -90～90 度) × × ○ × × ○ ○ × × × ○ × × ○ ○ ×
線 (スタイル) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (色) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [パターン] / [塗りつぶし]
セルの網掛け (色) / 背景色 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
塗りつぶし効果 (グラデーション) - - - - - - - - × × ○ × × ○ ○ ×
パターンの色 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
セルの網掛け (パターン) / パターンの種類 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[書式] - [行] / [列]
高さ / 行の高さ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
高さ / 行の高さの自動調整 × × × × × × × × × × × × × × × ×
幅 / 列の幅 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
幅 / 列の幅の自動調整 × × × × × × × × × × × × × × × ×
[書式] - [シート]
名前の変更 / シート名の変更 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
非表示 / 再表示 - - - - - - - - - - - - - - - -
[書式]
条件付き書式 × × × × × × × × × × × × × × × ×
[ツール]
[開発]
マクロ × × × × × × × × × × × × × × × ×
[ツール] - [オプション] - [全般]
[Excel のオプション] - [基本設定]
標準フォント名 - - ○ - - - ○ - - - ○ - - - ○ -
標準フォントサイズ - - ○ - - - ○ - - - ○ - - - ○ -
[ツール] - [保護]
[校閲]
シートの保護 - - ○ - - - ○ - - - ○ - - - ○ -
ブックの保護 - - × - - - × - - - × - - - × -
[データ]
フィルタ × × × × × × × × × × × × × × × ×
集計 × × × × × × × × × × × × × × × ×
入力規則 × × × × × × × × × × × × × × × ×
ピボットテーブル × × × × × × × × × × × × × × × ×
アウトライン × × × × × × × × × × × × × × × ×
[ウィンドウ]
[表示]
分割 - - ○ - - - ○ - - - ○ - - - ○ -
ウィンドウ枠の固定 - - ○ - - - ○ - - - ○ - - - ○ -
[ページレイアウト]
テーマ - - - - - - - - × × × × × × × ×
Note メモ:

(*1)グラフの編集には未対応。

(*2)外部のサードパーティ製ライブラリ等を使用し、ユーザーがグラフイメージ生成機能を独自に実装する必要があります。

(*3)ブック名が設定された名前の定義には未対応。

(*4)ExcelMode プロパティを使用した再計算は未対応。一部関数は ApplyFormula プロパティにて対応。

(*5)描画可能なオートシェイプは(右図)のみです。ただし、Excel 2007 以降で作成した xls ファイルでは台形に未対応。

(*6)文字列の方向 (縦書き) で半角英数字の描画は未対応。

(*7)同一セル内、テキストボックス内で複数の書式を設定することはできません。

(*8)横位置 (繰り返し) は未対応。

 描画可能なオートシェイプ
参照
対応する Excel 修飾機能


WPF 用ビューア対応機能一覧表

WPF 用ビューアで帳票出力を行う際、デザインファイルに設定された Excel の各種設定が、プレビュー、印刷、Excel、PDF ファイル出力時に反映されるかを表します。掲載のない機能は、基本的に AS-Report 12.0 for .NET で動作保証を行っていない機能となりますが、詳細な対応状況は 「サポートサービス」よりお問い合わせください。

Note メモ:

Windows デスクトップ アプリケーション(Windows/WPF)を作成する場合は、出力時に AS-Report の独自機能を使用するか、Excel オブジェクトを使用するか、ExcelMode プロパティで切り替えることができます。詳しくは、「 Excel インストールが必要な場合」をご参照ください。

機能一覧表

[○ = 対応、× = 未対応、△ = 制限あり、－ = 該当なし]
Excel 設定項目 | xls 形式 |  |  |  |  |  |  |  | xlsx 形式
 | AS-Report 機能のみを使用 |  |  |  | Excel オブジェクトを使用 |  |  |  | AS-Report 機能のみを使用 |  |  |  | Excel オブジェクトを使用
 | プレビュー | 印刷 | Excel | PDF | プレビュー | 印刷 | Excel | PDF | プレビュー | 印刷 | Excel | PDF | プレビュー | 印刷 | Excel | PDF
[ページ設定] - [ページ]
印刷の向き (縦 / 横) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
拡大縮小印刷 (拡大 / 縮小) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
拡大縮小印刷 (横 1~32767×縦 1~32767) × × ○ × × × ○ × × × ○ × × × ○ ×
用紙サイズ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
印刷品質 - - ○ - - - ○ - - - ○ - - - ○ -
先頭ページ番号 × × ○ × × × ○ × × × ○ × × × ○ ×
[ページ設定] - [余白]
余白 (上 / 下 / 左 / 右 / ヘッダー / フッター) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
余白 (ページ中央 水平 / 垂直) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[ページ設定] - [ヘッダー / フッター]
ヘッダー / フッター (左詰 [&L] / 中央揃え [&C] / 右詰 [&R] / 二重下線 [&E] / 上付き文字 [&X] / 下付き文字 [&Y] / 太字 [&B] / 斜体 [&I] / 下線付き [&U] / 取り消し線 [&S] / 日付 [&D] / 時刻 [&T] / シート見出し名 [&A] / ページ番号 [&P] / & 表示 [&&] / 総ページ数 [&N] / フォント名 [&"フォント名"] / フォントサイズ [&nn]) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
ヘッダー / フッター (ファイル名 [&F]) × × ○ × × × ○ × × × ○ × × × ○ ×
ヘッダー / フッター (図) × × ○ × × ○ ○ × × × ○ × × ○ ○ ×
[ページ設定] - [シート]
印刷範囲 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
印刷タイトル (行のタイトル / 列のタイトル) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
ページの方向 (左から右へ / 上から下へ) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[挿入]
改ページ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
コメント × × ○ × × ○ ○ × × × ○ × × ○ ○ ×
ワードアート × × ○ × × ○ ○ × × × ○ × × ○ ○ ×
グラフ (*1) × × ○ × ○ ○ ○ ○ × × ○ △ (*2) ○ ○ ○ ○
グラフシート × × × × × × × × × × × × × × × ×
名前の定義 - - △ (*3) - - - △ (*3) - - - △ (*3) - - - △ (*3) -
関数の挿入 △ (*4) △ (*4) ○ △ (*4) ○ ○ ○ ○ △ (*4) △ (*4) ○ △ (*4) ○ ○ ○ ○
図 (emf、bmp、dib、gif、jpg、png) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
オブジェクト × × ○ × × ○ ○ × × × ○ × × ○ ○ ×
オートシェイプ △ (*5) △ (*5) ○ △ (*5) △ (*5) ○ ○ △ (*5) △ (*5) △ (*5) ○ △ (*5) △ (*5) ○ ○ △ (*5)
グループ化 (オブジェクト) × × × × × × × × × × × × × × × ×
[オートシェイプの書式設定] - [色と線]
[図形の書式設定] - [塗りつぶし] / [線の色] / [線のスタイル]
塗りつぶし (単色) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
塗りつぶし (塗りつぶしなし) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
塗りつぶし効果 / 塗りつぶし (グラデーション) × × ○ × × ○ ○ × × × ○ × × ○ ○ ×
塗りつぶし (透明 / 透過性) × × ○ × × ○ ○ × × × ○ × × ○ ○ ×
線の色 (単色) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
線の色 (透明 / 透過性) × × ○ × × ○ ○ × × × ○ × × ○ ○ ×
スタイル / 太さ / 幅 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
実線 / 点線 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
コネクタ × × ○ × × ○ ○ × × × ○ × × ○ ○ ×
始点のスタイル / 種類 / サイズ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
終点のスタイル / 種類 / サイズ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[テキストボックスの書式設定] - [配置]
[図形の書式設定] - [テキストボックス] - [テキストのレイアウト]
文字の配置 (縦位置 / 横位置) / 垂直方向の配置 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
方向 / 文字列の方向 △ (*6) △ (*6) ○ △ (*6) △ (*6) ○ ○ △ (*6) △ (*6) △ (*6) ○ △ (*6) △ (*6) ○ ○ △ (*6)
[テキストボックスの書式設定] - [フォント] (*7)
フォント名 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
スタイル (標準 / 太字 / 斜体) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
サイズ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
下線 / 下線のスタイル (なし / 下線 / 二重下線) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
色 / フォントの色 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
文字飾り (取り消し線 / 上付き / 下付き) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [表示形式]
分類(標準 / 数値 / 通貨 / 会計 / 日付 / 時刻 / パーセンテージ / 分数 / 指数 / 文字列 / その他 / ユーザー定義) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [配置]
横位置 (標準 / 左詰め / 中央揃え / 右詰め / 繰り返し / 両端揃え / 選択範囲内で中央 / 均等割り付け) △ (*8) △ (*8) ○ △ (*8) △ (*8) ○ ○ △ (*8) △ (*8) △ (*8) ○ △ (*8) △ (*8) ○ ○ △ (*8)
縦位置 (上詰め / 中央揃え / 下詰め / 両端揃え / 均等割り付け) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
文字の制御 (折り返して全体を表示する) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
文字の制御 (縮小して全体を表示する) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
文字の制御 (セルを結合する) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
方向 (縦書き / -90～90 度) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [フォント] (*7)
フォント名 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
スタイル (標準 / 太字 / 斜体 / 太字+斜体) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
サイズ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
下線 (なし / 下線 / 二重下線) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
色 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
文字飾り (取り消し線 / 上付き / 下付き) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [罫線]
プリセット (外枠) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (上) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (下) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (左) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (右) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (左上がり) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (右上がり) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (方向 -90～90 度) × × ○ × × ○ ○ × × × ○ × × ○ ○ ×
線 (スタイル) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
罫線 (色) ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [パターン] / [塗りつぶし]
セルの網掛け (色) / 背景色 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
塗りつぶし効果 (グラデーション) - - - - - - - - × × ○ × × ○ ○ ×
パターンの色 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
セルの網掛け (パターン) / パターンの種類 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
[書式] - [行] / [列]
高さ / 行の高さ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
高さ / 行の高さの自動調整 × × × × × × × × × × × × × × × ×
幅 / 列の幅 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
幅 / 列の幅の自動調整 × × × × × × × × × × × × × × × ×
[書式] - [シート]
名前の変更 / シート名の変更 ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○ ○
非表示 / 再表示 - - - - - - - - - - - - - - - -
[書式]
条件付き書式 × × × × × × × × × × × × × × × ×
[ツール]
[開発]
マクロ × × × × × × × × × × × × × × × ×
[ツール] - [オプション] - [全般]
[Excel のオプション] - [基本設定]
標準フォント名 - - ○ - - - ○ - - - ○ - - - ○ -
標準フォントサイズ - - ○ - - - ○ - - - ○ - - - ○ -
[ツール] - [保護]
[校閲]
シートの保護 - - ○ - - - ○ - - - ○ - - - ○ -
ブックの保護 - - × - - - × - - - × - - - × -
[データ]
フィルタ × × × × × × × × × × × × × × × ×
集計 × × × × × × × × × × × × × × × ×
入力規則 × × × × × × × × × × × × × × × ×
ピボットテーブル × × × × × × × × × × × × × × × ×
アウトライン × × × × × × × × × × × × × × × ×
[ウィンドウ]
[表示]
分割 - - ○ - - - ○ - - - ○ - - - ○ -
ウィンドウ枠の固定 - - ○ - - - ○ - - - ○ - - - ○ -
[ページレイアウト]
テーマ - - - - - - - - × × × × × × × ×
Note メモ:

(*1)グラフの編集には未対応。

(*2)外部のサードパーティ製ライブラリ等を使用し、ユーザーがグラフイメージ生成機能を独自に実装する必要があります。

(*3)ブック名が設定された名前の定義には未対応。

(*4)ExcelMode プロパティを使用した再計算は未対応。一部関数は ApplyFormula プロパティにて対応。

(*5)描画可能なオートシェイプは(右図)のみです。ただし、Excel 2007 以降で作成した xls ファイルでは台形に未対応。

(*6)文字列の方向 (縦書き) で半角英数字の描画は未対応。

(*7)同一セル内、テキストボックス内で複数の書式を設定することはできません。

(*8)横位置 (繰り返し) は未対応。

 描画可能なオートシェイプ
参照
対応する Excel 修飾機能


Web 用ビューア 対応機能一覧表

Web 用ビューアで帳票出力を行う際、デザインファイルに設定された Excel の各種設定が、プレビュー、印刷、Excel、PDF ファイル出力時に反映されるかを表します。掲載のない機能は、基本的に AS-Report 12.0 for .NET で動作保証を行っていない機能となりますが、詳細な対応状況は 「サポートサービス」よりお問い合わせください。

Note メモ:

印刷時の用紙設定はブラウザ側で設定する必要があります。

機能一覧表

[○ = 対応、× = 未対応、△ = 制限あり、－ = 該当なし]
Excel 設定項目 | xls 形式 |  |  |  | xlsx 形式
 | プレビュー | 印刷 | Excel | PDF | プレビュー | 印刷 | Excel | PDF
[ページ設定] - [ページ]
印刷の向き (縦 / 横) ○ ○ ○ ○ ○ ○ ○ ○
拡大縮小印刷 (拡大 / 縮小) ○ ○ ○ ○ ○ ○ ○ ○
拡大縮小印刷 (横 1~32767×縦 1~32767) × × ○ × × × ○ ×
用紙サイズ ○ ○ ○ ○ ○ ○ ○ ○
印刷品質 － － ○ － － － ○ －
先頭ページ番号 × × ○ × × × ○ ×
[ページ設定] - [余白]
余白 (上 / 下 / 左 / 右 / ヘッダー / フッター) ○ ○ ○ ○ ○ ○ ○ ○
余白 (ページ中央：水平 / 垂直) ○ ○ ○ ○ ○ ○ ○ ○
[ページ設定] - [ヘッダー / フッター]
ヘッダー / フッター (左詰 [&L] / 中央揃え [&C] / 右詰 [&R] / 二重下線 [&E] / 上付き文字 [&X] / 下付き文字 [&Y] / 太字 [&B] / 斜体 [&I] / 下線付き [&U] / 取り消し線 [&S] / 日付 [&D] / 時刻 [&T] / シート見出し名 [&A] / ページ番号 [&P] / & 表示 [&&] / 総ページ数 [&N] / フォント名 [&"フォント名"] / フォントサイズ [&nn]) ○ ○ ○ ○ ○ ○ ○ ○
ヘッダー / フッター (ファイル名 [&F]) × × ○ × × × ○ ×
ヘッダー / フッター (図) × × ○ × × × ○ ×
[ページ設定] - [シート]
印刷範囲 ○ ○ ○ ○ ○ ○ ○ ○
印刷タイトル (行のタイトル / 列のタイトル) ○ ○ ○ ○ ○ ○ ○ ○
ページの方向 (左から右へ / 上から下へ) ○ ○ ○ ○ ○ ○ ○ ○
[挿入]
改ページ ○ ○ ○ ○ ○ ○ ○ ○
コメント × × ○ × × × ○ ×
ワードアート × × ○ × × × ○ ×
グラフ (*1) × × ○ × × × ○ △ (*2)
グラフシート × × × × × × × ×
名前の定義 － － △(*3) － － － △(*3) －
関数の挿入 △(*4) △(*4) ○ △(*4) △(*4) △(*4) ○ △(*4)
図 (emf、bmp、dib、gif、jpg、png) ○ ○ ○ ○ ○ ○ ○ ○
オブジェクト × × ○ × × × ○ ×
オートシェイプ △(*5) △(*5) ○ △(*5) △(*5) △(*5) ○ △(*5)
テキストボックス ○ ○ ○ ○ ○ ○ ○ ○
グループ化 (オブジェクト) × × × × × × × ×
[オートシェイプの書式設定] - [色と線]
[図形の書式設定] - [塗りつぶし] / [線の色] / [線のスタイル]
塗りつぶし (単色) ○ ○ ○ ○ ○ ○ ○ ○
塗りつぶし (塗りつぶしなし) ○ ○ ○ ○ ○ ○ ○ ○
塗りつぶし効果 / 塗りつぶし (グラデーション) × × ○ × × × ○ ×
塗りつぶし (透明 / 透過性) × × ○ × × × ○ ×
線の色 (単色) ○ ○ ○ ○ ○ ○ ○ ○
線の色 (透明 / 透過性) × × ○ × × × ○ ×
実線 / 点線 ○ ○ ○ ○ ○ ○ ○ ○
太さ / 幅 ○ ○ ○ ○ ○ ○ ○ ○
コネクタ × × ○ × × × ○ ×
始点のスタイル / 種類 / サイズ ○ ○ ○ ○ ○ ○ ○ ○
終点のスタイル / 種類 / サイズ ○ ○ ○ ○ ○ ○ ○ ○
[テキストボックスの書式設定] - [配置]
[図形の書式設定] - [テキストボックス] - [テキストのレイアウト]
文字の配置 (縦位置 / 横位置) / 垂直方向の配置 ○ ○ ○ ○ ○ ○ ○ ○
方向 / 文字列の方向 △(*6) △(*6) ○ △(*6) △(*6) △(*6) ○ △(*6)
[テキストボックスの書式設定] - [フォント](*7)
フォント名 ○ ○ ○ ○ ○ ○ ○ ○
スタイル (標準 / 太字 / 斜体) ○ ○ ○ ○ ○ ○ ○ ○
サイズ ○ ○ ○ ○ ○ ○ ○ ○
下線 / 下線のスタイル (なし / 下線 / 二重下線) ○ ○ ○ ○ ○ ○ ○ ○
色 / フォントの色 ○ ○ ○ ○ ○ ○ ○ ○
文字飾り (取り消し線 / 上付き / 下付き) ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [表示形式]
分類（標準 / 数値 / 通貨 / 会計 / 日付 / 時刻 / パーセンテージ / 分数 / 指数 / 文字列 / その他 / ユーザー定義) ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [配置]
横位置 (標準 / 左詰め / 中央揃え / 右詰め / 繰り返し / 両端揃え / 選択範囲内で中央 / 均等割り付け) △(*8) △(*8) ○ △(*8) △(*8) △(*8) ○ △(*8)
縦位置 (上詰め / 中央揃え / 下詰め / 両端揃え / 均等割り付け) ○ ○ ○ ○ ○ ○ ○ ○
文字の制御 (折り返して全体を表示する) ○ ○ ○ ○ ○ ○ ○ ○
文字の制御 (縮小して全体を表示する) ○ ○ ○ ○ ○ ○ ○ ○
文字の制御 (セルを結合する) ○ ○ ○ ○ ○ ○ ○ ○
方向 (縦書き / -90～90 度) ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [フォント](*7)
フォント名 ○ ○ ○ ○ ○ ○ ○ ○
スタイル (標準 / 太字 / 斜体 / 太字＋斜体) ○ ○ ○ ○ ○ ○ ○ ○
サイズ ○ ○ ○ ○ ○ ○ ○ ○
下線 (なし / 下線 / 二重下線) ○ ○ ○ ○ ○ ○ ○ ○
色 ○ ○ ○ ○ ○ ○ ○ ○
文字飾り (取り消し線 / 上付き / 下付き) ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [罫線]
プリセット (外枠) ○ ○ ○ ○ ○ ○ ○ ○
罫線 (上) ○ ○ ○ ○ ○ ○ ○ ○
罫線 (下) ○ ○ ○ ○ ○ ○ ○ ○
罫線 (左) ○ ○ ○ ○ ○ ○ ○ ○
罫線 (右) ○ ○ ○ ○ ○ ○ ○ ○
罫線 (左上がり) ○ ○ ○ ○ ○ ○ ○ ○
罫線 (右上がり) ○ ○ ○ ○ ○ ○ ○ ○
罫線 (方向 -90～90 度) × × ○ × × × ○ ×
線 (スタイル) ○ ○ ○ ○ ○ ○ ○ ○
罫線 (色) ○ ○ ○ ○ ○ ○ ○ ○
[セルの書式設定] - [パターン] / [塗りつぶし]
セルの網掛け (色) / 背景色 ○ ○ ○ ○ ○ ○ ○ ○
塗りつぶし効果 (グラデーション) － － － － × × ○ ×
パターンの色 ○ ○ ○ ○ ○ ○ ○ ○
セルの網掛け (パターン) / パターンの種類 ○ ○ ○ ○ ○ ○ ○ ○
[書式] - [行] / [列]
高さ / 行の高さ ○ ○ ○ ○ ○ ○ ○ ○
高さ / 行の高さの自動調整 × × × × × × × ×
幅 / 列の幅 ○ ○ ○ ○ ○ ○ ○ ○
幅 / 列の幅の自動調整 × × × × × × × ×
[書式] - [シート]
名前の変更 / シート名の変更 ○ ○ ○ ○ ○ ○ ○ ○
非表示 / 再表示 － － － － － － － －
[書式]
条件付き書式 × × × × × × × ×
[ツール]
[開発]
マクロ × × × × × × × ×
[ツール]-[オプション] - [全般]
[Excel のオプション] - [基本設定]
標準フォント名 － － ○ － － － ○ －
標準フォントサイズ － － ○ － － － ○ －
[ツール] - [保護]
[校閲]
シートの保護 － － ○ － － － ○ －
ブックの保護 － － × － － － × －
[データ]
フィルタ × × × × × × × ×
集計 × × × × × × × ×
入力規則 × × × × × × × ×
ピボットテーブル × × × × × × × ×
アウトライン × × × × × × × ×
[ウィンドウ]
[表示]
分割 － － ○ － － － ○ －
ウィンドウ枠の固定 － － ○ － － － ○ －
[ページレイアウト]
テーマ － － － － × × × ×
Note メモ:

(*1)グラフの編集には未対応。

(*2)外部のサードパーティ製ライブラリ等を使用し、ユーザーがグラフイメージ生成機能を独自に実装する必要があります。

(*3)ブック名が設定された名前の定義には未対応。

(*4)ExcelMode プロパティを使用した再計算は未対応。一部関数は、ApplyFormula プロパティにて対応。

(*5)描画可能なオートシェイプは(右図)のみです。

(*6)文字列の方向 (縦書き) で半角英数字の描画は未対応。

(*7)同一セル内、テキストボックス内で複数の書式を設定することはできません。

(*8)横位置 (繰り返し) は未対応。

 描画可能なオートシェイプ
参照
対応する Excel 修飾機能


よくあるご質問

ここでは、AS-Report 12.0 for .NET のよくあるご質問について説明します。さらに詳しい内容は、弊社ホームページの「FAQ(よくあるご質問と回答)」をご参照ください。

このトピックは、次のセクションを含みます。

＜営業関連のご質問＞
  • 「AS-Report 12」の収録製品を教えてください。
  • 製品のシリアルナンバーがわかりません。
  • ライセンスファイルについて教えてください。
  • ライセンスファイルの入手方法を教えてください。
  • 保守（サポート）期間を教えてください。
  • アプリケーションを開発する際のライセンス形態を教えてください。
  • アプリケーションを配布する際のライセンス形態を教えてください。
  • サーバーライセンスは待機系、開発、検証用環境にも必要でしょうか。
＜技術関連のご質問＞
  • 日本語以外の環境に対応していますか。
  • 32 ビットと 64 ビットのどちらにも対応していますか。
  • Linux に対応していますか。
  • .NET Framework に対応していますか。
  • 旧バージョンの VB-Report から移行する方法を教えて下さい。
  • サンプルプログラムはありますか。
  • プロジェクトに追加する NuGet パッケージを教えてください。
  • 体験版がインストールされた環境に製品版をインストールできますか。
  • 体験版で作成したアプリケーションを製品版に切り替えてもそのまま使用できますか。
  • 体験版から製品版に切り替える方法を教えてください。
  • ライセンスファイルの使用方法を教えてください。
  • 改変した JavaScript 外部ファイルは動作保証されますか。
  • 対応する Excel の修飾機能を教えてください。
  • VBA やマクロの編集、実行に対応していますか。
  • AS-Report 12.0 for .NET を組み込んだアプリケーションが実行できません。
  • 計算式の計算結果が更新されません。

＜営業関連のご質問＞

「AS-Report 12」の収録製品を教えてください。

「AS-Report 12」は以下の製品を収録しています。

  • AS-Report 12.0 for .NET (.NET / .NET Framework 対応)

動作環境に関する詳細は「システム動作環境」をご確認ください。

製品のシリアルナンバーがわかりません。

製品パッケージ内のインストール情報カードをご確認ください。

ライセンスファイルについて教えてください。

AS-Report 12.0 for .NET では、製品版としてご利用いただくためにライセンスファイルによる認証が必要となります。ライセンスファイルの入手方法および使用方法は以下の項目をご確認ください。

  • ライセンスファイルの入手方法を教えてください。
  • ライセンスファイルの使用方法を教えてください。
ライセンスファイルの入手方法を教えてください。

ライセンスファイルは以下の専用ページより申請を行っていただくことで発行されます。ライセンス申請の際、製品のシリアルナンバーが必要となりますので、あらかじめご用意ください。

〇ライセンス手続き
https://www.adv.co.jp/support/license.php

保守（サポート）期間を教えてください。

開発ライセンス（基本パック、追加ライセンス）の購入後 1 年間、もしくは、製品販売終了後 6 ヶ月間のうち、どちらか短い期間を無償保守期間としております。無償保守期間終了後もサポート窓口より一般的なお問い合わせに対応しています。

また、サーバーライセンスの場合、別途サーバーライセンス保守契約が必要となります。詳細は「サポートサービス」よりお問い合わせください。

アプリケーションを開発する際のライセンス形態を教えてください。

開発ライセンスは製品をインストールおよび開発作業を行う開発端末数分必要となります。
製品の基本パック 1 本につき、インストールメディア(CD-ROM)と 1 開発ライセンスが付属します。2 本目からは、インストールメディアが付属しない開発ライセンスのみを「追加ライセンス」でご購入いただくことが可能です。

  • (例1)
    マシン A に AS-Report 12.0 for .NET をインストール
    →基本パック 1 本(1 開発ライセンス)必要

  • (例2)
    マシン A に AS-Report 12.0 for .NET をインストール
    マシン B に AS-Report 12.0 for .NET をインストール
    →基本パック 2 本(2 開発ライセンス)または、基本パック 1 本＋追加ライセンス 1 本(あわせて 2 開発ライセンス)必要

アプリケーションを配布する際のライセンス形態を教えてください。

AS-Report 12.0 for .NET を使用して開発したクライアントアプリケーションを実行環境へ配布する場合、ランタイムファイルの配布はロイヤリティフリーです。

AS-Report 12.0 for .NET をサーバーアプリケーション(関連する機能を含む)に組み込んで配布する場合、配布するサーバーの環境(OS)分のサーバーライセンスを購入してください。
なお、サーバーライセンスの詳しい内容は、「サポートサービス」よりお問い合わせください。

サーバーアプリケーションの定義

サーバーアプリケーションとは、製品を組み込んだ以下の形態のアプリケーションとします。

  1. Web アプリケーションやサービスとして動作するプログラム。
  2. Web アプリケーションやサービスと連動して動作するプログラム。
  3. プログラムを用いて作成したファイル、データ等をネットワークを介してほかのコンピュータへ配信、提供する非対話型プログラム。
  4. リモートデスクトップなど、他のコンピュータの操作により、特定のコンピュータ上で動作するアプリケーション。
サーバーライセンスは待機系、開発、検証用環境にも必要でしょうか。

待機系には｢サーバー待機ライセンス｣が必要です。開発、検証用環境にはサーバーライセンスは必要ありません。

＜技術関連のご質問＞

日本語以外の環境に対応していますか。

英語版など、日本語以外の環境では動作を保証しておりません。

32 ビットと 64 ビットのどちらにも対応していますか。

AS-Report 12.0 for .NET の提供するモジュールは AnyCPU でビルドを行っているため、32 ビットと 64 ビットのどちらにも対応しています。

Linux に対応していますか。

プロジェクトの対象フレームワークによって異なります。
.NET 向けモジュールは Linux 上での実行が可能です。

[.NET 向けモジュール]
  • 開発環境：Windows のみ対応
  • 実行環境：Windows、Linux に対応
[.NET Framework 向けモジュール]
  • 開発環境：Windows のみ対応
  • 実行環境：Windows のみ対応
.NET Framework に対応していますか。

対応しています。詳細は｢ システム動作環境 ｣をご確認ください。

旧バージョンの VB-Report から移行する方法を教えて下さい。

旧バージョンの VB-Report と互換性はなく、移行ツールもありません。

サンプルプログラムはありますか。

基本操作を確認できるサンプルプログラムをご用意しています。なお、サンプルプログラムは体験版にも付属されています。

プロジェクトに追加する NuGet パッケージを教えてください。

ご利用いただくコンポーネントやコントロールによって追加するパッケージが異なります。以下のパッケージ以外は依存関係として自動でインストールされるため、個別に追加する必要はありません。

  • レポートコンポーネント：AdvanceSoftware.ASReport.CellReport
  • バーコードコンポーネント：AdvanceSoftware.ASReport.BarCode
  • Windows フォーム用ビューア：AdvanceSoftware.ASReport.Viewer
  • WPF 用ビューア：AdvanceSoftware.ASReport.Wpf.Viewer
体験版がインストールされた環境に製品版をインストールできますか。

製品版をインストールしなおす必要はありません。製品版への切り替え方法は以下の項目をご確認ください。

  • 体験版から製品版に切り替える方法を教えてください。
体験版で作成したアプリケーションを製品版に切り替えてもそのまま使用できますか。

使用できます。製品版への切り替え方法は以下の項目をご確認ください。

  • 体験版から製品版に切り替える方法を教えてください。
体験版から製品版に切り替える方法を教えてください。

AS-Report 12.0 for .NET ではライセンスファイルを使用して製品版の認証を行います。ライセンスファイルの指定を行わない場合、体験版として動作します。

ライセンスファイルの入手方法、使用方法は以下の項目をご確認ください。

  • ライセンスファイルの入手方法を教えてください。
  • ライセンスファイルの使用方法を教えてください。
ライセンスファイルの使用方法を教えてください。

SetLicense メソッドでライセンスファイルの情報を設定します。詳細は、ヘルプファイル内の「ライセンスファイルを指定する」をご確認ください。

改変した JavaScript 外部ファイルは動作保証されますか。

AS-Report 12.0 for .NET で提供している JavaScript 外部ファイル(gunzip.min.js、など)は、提供時の状態でのみ弊社にて動作保証を行っております。そのため、コードを部分的に改変したり、お客様が独自に作成したファイルを使用した場合の動作については、弊社にて動作保証を行っておりません。

対応する Excel の修飾機能を教えてください。

ヘルプファイル内の「対応する Excel 修飾機能」をご確認ください。

VBA やマクロの編集、実行に対応していますか。

VBA やマクロの編集、実行には対応していません。

AS-Report 12.0 for .NET を組み込んだアプリケーションが実行できません。
  1. 実行環境に製品が対応するフレームワークが適用されているかご確認ください。
  2. Linux 環境の場合は「libgdiplus」がインストールされているかご確認ください。
計算式の計算結果が更新されません。

AS-Report 12.0 for .NET で計算式の計算結果を更新 (再計算) する場合、ApplyFormula プロパティ、または、ExcelMode プロパティを True にすることで計算結果が更新されます。各プロパティの使用方法については「計算式を再計算する」を参照してください。


旧バージョンとの互換性、共存

このトピックでは、旧バージョンとの互換性、共存について説明します。

このトピックは、次のセクションを含みます。

  • 旧バージョンとの互換性
  • 旧バージョンとの共存
旧バージョンとの互換性

AS-Report 12.0 for .NET と VB-Report シリーズのバージョン間で互換性はありません。また、移行ツールも用意していないため、旧バージョンで作成したプロジェクトやアプリケーションを AS-Report 12.0 for .NET で使用することはできません。

旧バージョンとの共存

AS-Report 12.0 for .NET は、VB-Report シリーズの次のバージョンと同じ環境にインストール、アプリケーションを配布することが可能です。

バージョン | 補足事項
VB-Report Ver3.0 | ActiveX 版、xls 形式に対応
VB-Report Ver3.6 | ActiveX 版、xlsx 形式に対応
VB-Report 5.0 for .NET | .NET Framework 版、xls 形式に対応
VB-Report 6.0 for .NET | .NET Framework 版、xlsx 形式に対応
VB-Report 7.0 for .NET | .NET Framework 版、xls / xlsx 両形式に対応
VB-Report 8.0 for .NET | .NET Framework 版、xls / xlsx 両形式に対応
VB-Report 10.0 for .NET | .NET Framework 版、xls / xlsx 両形式に対応
VB-Report 11.0 for .NET | .NET 版、xls / xlsx 両形式に対応


VB-Report 10.0 / 11.0 for .NET メンバ対応表

VB-Report 10.0 for .NET / VB-Report 11.0 for .NET のメンバを基に作成された AS-Report 12.0 for .NET のメンバ対応表です。
AS-Report 12.0 for .NET は .NET / .NET Framework の両環境に対応した製品となるため、ソースコードの置き換え、流用の際にご活用ください。

Note メモ:

非対応、廃止、変更となったメンバのみ記載しています。記載のないメンバは名前空間以外の変更がないため、ソースコードを流用できます。

このトピックは、次のセクションを含みます。

  • 名前空間
  • AdvanceSoftware.ASReport 名前空間
名前空間
VB-Report 10.0 for .NET | VB-Report 11.0 for .NET | AS-Report 12.0 for .NET
AdvanceSoftwate.VBReport | AdvanceSoftwate.VBReport | AdvanceSoftware.ASReport
AdvanceSoftwate.VBReport.BarCode | AdvanceSoftwate.VBReport.BarCode | AdvanceSoftware.ASReport.BarCode
AdvanceSoftware.VBReport.Web | 廃止 | 廃止
AdvanceSoftware.VBReport.Wpf | AdvanceSoftware.VBReport.Wpf | AdvanceSoftware.ASReport.Wpf
AdvanceSoftware.ASReport 名前空間

このセクションは、次のサブセクションを含みます。

  • CellReport クラス
  • WebOption クラス
  • DocType 列挙体
  • ViewMode 列挙体
  • WebOutputType 列挙体
  • xlColor 列挙体
CellReport クラス
VB-Report 10.0 for .NET メンバ(プロパティ) | VB-Report 11.0 for .NET(プロパティ) | AS-Report 12.0 for .NET(プロパティ)
CellReport.ReportFileName | 廃止 | 廃止
CellReport.Web | 廃止 | 廃止
VB-Report 10.0 for .NET メンバ(メソッド) | VB-Report 11.0 for .NET(メソッド) | AS-Report 12.0 for .NET(メソッド)
CellReport.Run | 廃止 | 廃止
CellReport.SetCellInfo | 廃止 | 廃止
WebOption クラス
VB-Report 10.0 for .NET メンバ(プロパティ) | VB-Report 11.0 for .NET(プロパティ) | AS-Report 12.0 for .NET(プロパティ)
WebOption.HyperlinkEnabled | 廃止 | 廃止
WebOption.ImagePath | 廃止 | 廃止
WebOption.ScriptPath | 廃止 | 廃止
WebOption.ShowHeaderFooter | 廃止 | 廃止
DocType 列挙体
VB-Report 10.0 for .NET メンバ | VB-Report 11.0 for .NET メンバ | AS-Report 12.0 for .NET メンバ
DocType.Html4 | 廃止 | 廃止
DocType.Html5 | 廃止 | 廃止
ViewMode 列挙体
VB-Report 10.0 for .NET メンバ | VB-Report 11.0 for .NET メンバ | AS-Report 12.0 for .NET メンバ
ViewMode.Default | ViewMode.Default | OutputMode.All
ViewMode.View | ViewMode.View | OutputMode.NotExcel
ViewMode.Save | ViewMode.Save | OutputMode.ExcelOnly
WebOutputType 列挙体
VB-Report 10.0 for .NET メンバ | VB-Report 11.0 for .NET | AS-Report 12.0 for .NET
WebOutputType.Table | 廃止 | 廃止
WebOutputType.Html | 廃止 | 廃止
xlColor 列挙体
VB-Report 10.0 for .NET メンバ | VB-Report 11.0 for .NET | AS-Report 12.0 for .NET
xlColor.DrakBlue | xlColor.DrakBlue | xlColor.DarkBlue
xlColor.DrakYellow | xlColor.DrakYellow | xlColor.DarkYellow
xlColor.DrakPurple | xlColor.DrakPurple | xlColor.DarkPurple
xlColor.DrakBlue2 | xlColor.DrakBlue2 | xlColor.DarkBlue2


バージョン間プロパティ既定値 変更一覧

AS-Report 12.0 for .NET では、過去バージョンの製品から一部プロパティの既定値が変更となっています。
VB-Report 10.0 for .NET、VB-Report 11.0 for .NET を使用したプロジェクトのコードを流用する際にご活用ください。

CellReport クラス
プロパティ | VB-Report 11.0 for .NET VB-Report 10.0 for .NET | AS-Report 12.0 for .NET
ApplyFormula プロパティ | false | true
ApplyPrintArea プロパティ | false | true
ApplyPrintTitle プロパティ | false | true
ChangeNameAddressMode プロパティ | false | true
VarInsertMode プロパティ | VarInsertMode.All | VarInsertMode.InvalidAnswer


メソッド・プロパティ・イベント機能一覧

ここでは、AS-Report 12.0 for .NET でオブジェクト別に設定可能なメソッド・プロパティ・イベント一覧について説明します。クラスライブラリのオブジェクト別逆引き検索ページとしてご使用ください。

レポートコンポーネント

レポートコンポーネントのオブジェクト機能一覧を説明します。

バーコードコンポーネント

バーコードコンポーネントのオブジェクト機能一覧を説明します。

Windows フォーム用ビューア

Windows フォーム用ビューアのオブジェクト機能一覧を説明します。

WPF 用ビューア

WPF 用ビューアのオブジェクト機能一覧を説明します。

Web 用ビューア

Web 用ビューアのオブジェクト機能一覧を説明します。


レポートコンポーネント

このトピックでは、レポートコンポーネントで使用可能なオブジェクト機能一覧を確認することが可能です。

このトピックは、次のセクションを含みます。

  • Cell クラス
  • CellAttr クラス
  • CellCanvas クラス
  • CellReport クラス
  • Drawing クラス
  • Page クラス
  • PageAttr クラス
  • PdfOption クラス
  • PdfSignature クラス
  • Report クラス
  • Section クラス
  • SectionDetail クラス
  • SectionFooter クラス
  • SectionHeader クラス
Cell クラス
メソッド名 | 説明
Clear | セルをクリアします。
Copy | セルをコピーします。
Func | 計算式を設定します。
Paste | コピーしたセルを貼り付けます。
Value2 | 属性番号を指定して値を設定します。
プロパティ名 | 説明
Attr | Attr を取得します。
AttrNo | 属性番号を取得します。
Break | 改ページを設定します。
Canvas | Canvas を取得します。
ColWidth | セル幅を設定、取得します。
Drawing | Drawing を取得します。
FormattedString | 書式化された文字列を取得します。
RowHeight | 行高を設定、取得します。
Str | 文字列を設定、取得します。
Value | 値を設定、取得します。
CellAttr クラス
メソッド名 | 説明
Box | Box 罫線を設定します。
LineBottom | 下罫線を設定します。
LineLeft | 左罫線を設定します。
LineLeftUp | 左上がり罫線を設定します。
LineRight | 右罫線を設定します。
LineRightUp | 右上がり罫線を設定します。
LineTop | 上罫線を設定します。
プロパティ名 | 説明
BackColor | 背景色を設定します。(xlsx 形式のみ対応、Color 構造体で設定)
BackColor2 | 背景色を設定します。(xlsx、xls 両形式対応、xlColor 列挙体で設定)
FontColor | フォントカラーを設定します。(xlsx 形式のみ対応、Color 構造体で設定)
FontColor2 | フォントカラーを設定します。(xlsx、xls 両形式対応、xlColor 列挙体で設定)
FontName | フォント名を設定します。
FontPoint | フォントポイントを設定します。
FontStyle | フォントスタイルを設定します。
FontULine | フォント下線を設定します。
ForeColor | 前景色を設定します。(xlsx 形式のみ対応、Color 構造体で設定)
ForeColor2 | 前景色を設定します。(xlsx、xls 両形式対応、xlColor 列挙体で設定)
Format | 表示書式を設定します。
HorizontalAlignment | 文字の配置の横位置を設定します。
Locked | セルのロックを設定、取得します。
MergeCells | セルの結合を設定します。
Orientation | 文字の配置の回転を設定します。
Pattern | パターンを設定します。
ShrinkToFit | 縮小して全体を表示を設定します。
VerticalAlignment | 文字の配置の縦位置を設定します。
WrapText | 折り返して全体を表示を設定します。
CellCanvas クラス
メソッド名 | 説明
AddChart | グラフを設定します。
AddImage | イメージを設定します。
CellReport クラス
メソッド名 | 説明
Cell | Cell を取得します。
ClearDocument | ドキュメントを破棄します。
ColumnClear | 列をクリアします。
ColumnCopy | 列をコピーします。
ColumnDelete | 列を削除します。
ColumnInsert | 列を挿入します。
ColumnInsertCopied | コピーした列を挿入します。
ColumnPaste | コピーした列を貼り付けします。
GetChartCount | 選択したシートに含まれるグラフ数を取得します。(xlsx 形式のみ対応)
GetChartData | グラフ情報を取得します。(xlsx 形式のみ対応)
GetDocument | ビューアに渡すための AS-Report ドキュメントを取得します。
GetMaxArea | データ、属性が設定されたセルの終了座標を取得します。
GetMaxData | データが設定されたセルの終了座標を取得します。
GetNamePos | 指定したセル名の座標(0～)を取得します。
GetVarNamePos | 指定した変数名の座標(0～)を取得します。
Pos | Cell を取得します。
RowClear | 行をクリアします。
RowCopy | 行をコピーします。
RowDelete | 行を削除します。
RowInsert | 行を挿入します。
RowInsertCopied | コピーした行を挿入します。
RowPaste | コピーした行を貼り付けします。
SetLicense | ライセンスを設定します。
TableRowDelete | テーブル範囲に含まれる行を削除します。
TableRowInsert | テーブル範囲に行を挿入します。
VarCheck | 指定した変数名が存在するかをチェックします。
プロパティ名 | 説明
ApplyFormula | 計算式の自動計算をするかどうかを設定、取得します。
ApplyPrintArea | 印刷範囲を有効にするかを設定、取得します。
ApplyPrintTitle | 印刷タイトルを有効にするかを設定、取得します。
ChangeNameAddressMode | セル名位置調整モードを設定します。
DefaultCell | 保存時のデフォルト選択セルを設定します。
DefaultSheet | 保存時のデフォルト選択シートを設定します。
Document | ビューアに渡すための既定の Document を取得します。
DoubleCellValueMode | double 型の数値をセルに格納する方法を指定します。(xlsx形式のみ)
DoubleMode | 浮動小数点の有効桁数モードを設定、取得します。
ErrorMessage | エラーメッセージを取得します。
ErrorNo | エラーナンバーを取得します。
ExcelMode | Excel オブジェクトを使用する、しないを設定します。
ExcelModeType | CellReport コンポーネント単体で ExcelMode プロパティを true に設定して使用する場合の Excel の起動モードを設定、取得します。
FileName | デザインファイル名を指定します。
Keyword | 変数名の先頭キーワード文字列を設定します。
OverFit | 帳票を 1 ページに収まるよう表示するかを設定します。
Page | Page を取得します。
PageInfo | 使用するページ情報を指定します。
Pdf | PDF ファイルのオプションを指定するための PdfOption を取得します。
ReleaseExcelTask | Excel オブジェクトの動作を設定します。
Report | Report を取得します。
SaveAsLowMemoryMode | Excel ファイル (xls) 保存時の処理動作を指定します。
ScaleMode | スケールモードを設定、取得します。
Section | Section を取得します。
SheetName | 使用するシート名を指定します。
StreamMode | ビューアデータの保持モードを指定します。
TemporaryPath | 一時ファイルのパスを設定、取得します。
UseTwoExcelTasks | ExcelMode で使用する Excel のタスク数を指定します。
VarInsertMode | 変数名挿入モードを設定します。
VarNameMode | 変数名の設定を行う Keyword 、VarInsertMode プロパティの動作モードを指定します。
WaitTimeout | 同時アクセス時の待ち時間をミリ秒単位で指定します。
イベント名 | 説明
Error | Error イベント。
Progress | Progress イベント。
RunPageStart | RunPageStart イベント。
RunReportStart | RunReportStart イベント。
SectionEndPage | SectionEndPage イベント。
SectionNewPage | SectionNewPage イベント。
Drawing クラス
メソッド名 | 説明
AddImage | イメージを設定します。
AddLine | 線を設定します。
AddShape | オートシェイプを設定します。
AddTextBox | テキストボックスを設定します。
Init | 初期化処理をします。
プロパティ名 | 説明
ArrowTypeE | 矢印の終点のスタイル、サイズを設定します。
ArrowTypeS | 矢印の始点のスタイル、サイズを設定します。
FillColor | 塗りつぶし色を設定します。
FillColor2 | 塗りつぶし色を設定します。
FontColor | テキストボックスのフォントの色を設定します。(xlsx 形式のみ対応、Color 構造体で設定)
FontColor2 | テキストボックスのフォントの色を設定します。(xlsx、xls 両形式対応、xlColor 列挙体で設定)
FontName | テキストボックスのフォント名を設定します。
FontPoint | テキストボックスのフォントサイズを設定します。
FontStyle | テキストボックスのフォントスタイルを設定します。
FontULine | テキストボックスのフォントの下線を設定します。
LineColor | 線の色を設定します。(xlsx 形式のみ対応、Color 構造体で設定)
LineColor2 | 線の色を設定します。(xlsx、xls 両形式対応、xlColor 列挙体で設定)
LineStyle | 線種を設定します。
LineWeight | 線の太さを設定します。
ShapeNoFill | オートシェイプ・テキストボックスの「塗りつぶしなし」を設定します。
TextAlign | テキストボックスの水平方向の文字位置を設定します。
TextAnchor | テキストボックスの垂直方向の文字位置を設定します。
TextVertical | テキストボックスの文字の回転を設定します。
Page クラス
メソッド名 | 説明
End | ページの終了を指定します。
Next | ページ内での繰り返しの終了を指定します。
Repeat | ページ内での繰り返しの開始を指定します。
Start | ページの開始を指定します。
プロパティ名 | 説明
Attr | ページ属性を設定するための PageAttr を取得します。
Name | シート名を指定します。
TotalCount | 総ページ数を取得します。
VarNames | 変数名の一覧を取得します。
PageAttr クラス
メソッド名 | 説明
Footer | フッターを設定します。
Header | ヘッダーを設定します。
Margin | 余白を設定します。
PrintArea | 印刷範囲を設定します。
PrintTitle | 印刷タイトルを設定します。
Size | 用紙設定をします。
SizeFree | ユーザー定義用紙を設定します。
プロパティ名 | 説明
Center | ページ中央を指定します。
PageOrder | ページの方向を指定します。
TabSelected | シートの選択を設定します。
PdfOption クラス
プロパティ名 | 説明
Application | PDF ファイルのアプリケーションを設定します。
Author | PDF ファイルの作成者を設定します。
CreateFileWithoutSignature | 電子署名、タイムスタンプ付与失敗時に PDF ファイルを生成するかを指定します。
EmbedFonts | PDF ファイルに埋め込むフォントを設定します。
EncryptionType | PDF ファイルの暗号化強度を設定します。PdfEncryptionType 列挙体で指定してください。
EUDCFiles | PDF ファイルで使用する外字ファイル名と対象とするフォント名を指定します。 フォントの種類毎に外字ファイルを切り替えることが可能です。
ImageType | PDF ファイルのイメージの種類を設定します。
IsReplaceYenSign | PDF ファイルに出力する文字列の"\"マークの扱いを指定します。
OwnerPassword | PDF ファイルのオーナーパスワードを設定します。
PetternQuality | PDF ファイル作成時のパターンの解像度を設定します。
Permit | PDF ファイルの権限を設定します。複数の指定時は PdfPermit 列挙体を or(||) で連結します。
Producer | PDF ファイルの PDF 変換を設定します。
Quality | PDF ファイル作成時の解像度を設定します。
Signature | PdfSignature を取得します。
Subject | PDF ファイルのサブタイトルを設定します。
Title | PDF ファイルのタイトルを設定します。
UserPassword | PDF ファイルのユーザーパスワードを設定します。
PdfSignature クラス
プロパティ名 | 説明
Capacity | PDF ファイルの電子署名データに割り当てられたバイト数を設定、取得します。
CertificateData | ローカルの証明書(pfx)データを設定、取得します。
CertificatePassword | ローカルの証明書(pfx)データのパスワードを設定、取得します。
Contact | 署名の連絡先を設定、取得します。
Date | 署名時刻を設定、取得します。
Location | 署名の場所を設定、取得します。
Reason | 署名の理由を設定、取得します。
TimeStampPassword | 署名の埋め込みタイムスタンプサーバーのパスワードを設定、取得します。
TimeStampUrl | 署名の埋め込みタイムスタンプサーバーの URL を設定、取得します。
TimeStampUser | 署名の埋め込みタイムスタンプサーバーのユーザー名を設定、取得します。
WindowsCertificate | Windows 証明書を設定、取得します。
Report クラス
メソッド名 | 説明
Create | 帳票を新規作成します。
Embed | 埋め込んだデザインファイルを使用して帳票の作成を開始します。
End | 帳票の作成を終了します。
File | デザインファイルを使用して帳票の作成を開始します。
GetSvgReport | 作成した帳票を SVG 形式で取得します。
GetSvgzReport | 作成した帳票を SVGZ 形式で取得します。
PrintOut | 印刷を行います。
SaveAs | 作成した帳票を Excel 形式で保存します。
SavePdf | 作成した帳票を PDF 形式で保存します。
Start | 帳票の作成を開始します。
Section クラス
メソッド名 | 説明
Detail | 連続帳票処理の明細部を指定します。
End | 連続帳票の終了を指定します。
Footer | 連続帳票処理のフッター部を指定します。
Header | 連続帳票処理のヘッダー部を指定します。
Start | 連続帳票の開始を指定します。
プロパティ名 | 説明
MaxDetailCount | 1ページの明細数を指定します。
ReportToFill | 明細行を最終行まで設定するかを指定します。
SectionDetail クラス
メソッド名 | 説明
Cell | Cell を取得します。
Next | 連続帳票の明細処理を終了します。
Pos | Cell を取得します。
Start | 連続帳票に明細行を追加します。
SectionFooter クラス
メソッド名 | 説明
Cell | Cell を取得します。
Pos | Cell を取得します。
SectionHeader クラス
メソッド名 | 説明
Cell | Cell を取得します。
Pos | Cell を取得します。
参照
メソッド・プロパティ・イベント機能一覧


バーコードコンポーネント

このトピックでは、バーコードコンポーネントで使用可能なオブジェクト機能一覧を確認することが可能です。

このトピックは、次のセクションを含みます。

  • バーコードクラス
バーコードクラス
メソッド名 | 説明
GetBarCodeImage | バーコードのイメージを作成します。
GetScaleSize | 指定した単位でバーコードのサイズを取得します。
SetLicense | ライセンスを設定します。
プロパティ名 | 説明
BackColor | バーコードシンボルの背景色を設定、取得します。
BarColor | バーの色を設定、取得します。
BarHeight | バーコードの高さを設定、取得します。
BarRatio | 太バーのエレメント率を設定、取得します。(Codabar、Code39)
BarWidth | バーコードの幅を設定、取得します。
BinaryValue | バーコードデータを設定、取得します。(バイナリ)
BlackBarRevision | 黒バーの太さの比率を設定、取得します。
BlackRatio | 黒バーの太さの比率を設定、取得します。
CharGap | キャラクタ間のギャップを設定、取得します。(Codabar、Code39) 。
CharSize | バーコードメッセージのフォントサイズを設定、取得します。
CheckCharMode | 自動でチェックキャラクタを付加するかを設定、取得します。
CheckPattern | チェックデジットの計算方法を設定、取得します。(Codabar)
Codeset | スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128)、公共料金等代理収納 GS1-128)
DpiX | X 軸方向の解像度を設定、取得します。(ピクセル単位)
DpiY | Y 軸方向の解像度を設定、取得します。(ピクセル単位)
Element | 最小エレメント値を設定、取得します。
EmfType | 拡張メタファイル(EMF)に格納されるレコードの品質を設定します。
ErrorMessage | エラーメッセージを取得します。
ErrorNo | エラーナンバーを取得します。
FlatHeight | ガードバーの均等化を設定、取得します。(JAN、UPC)
Font | バーコードメッセージのフォントを設定、取得します。
InternalQRVersion | QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。
InternalValue | 整形後のバーコードデータを取得します。
MessageAlign | バーコードメッセージの表示横位置を設定、取得します。(GS1Fixed)
PDFColumn | PDF417 の列数を設定、取得します。
PDFInitialSymbol | PDF417 の初期化シンボルを設定、取得します。
PDFLevel | PDF417 のエラー訂正レベルを設定、取得します。
PDFModel | PDF417 シンボルを設定、取得します。
PDFRatio | PDF417 の 1 モジュールの縦横比を設定、取得します。
PDFRow | PDF417 の行数を設定、取得します。
Point | ポイントを設定、取得します。(カスタマバーコード)
QRConnect | 連結 QR コードを作成するかを設定、取得します。
QREscapeCode | QR コードのエスケープコードを設定、取得します。
QRLevel | QR コードの誤り訂正レベルを設定、取得します。
QRMask | QR コードのマスクパターンを設定、取得します。
QRModel | QR コードのモデルを設定、取得します。
QRSymbolNumber | 連結 QR コードで出力するシンボル番号を設定、取得します。
QRVersion | QR コードの型番を設定、取得します。
Quiet | 余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金等代理収納 GS1-128)
Rotate | バーコードの回転方向を設定、取得します。
ShowBearer | ベアラバーを表示するかを設定、取得します。(ITF)
ShowMessage | バーコードメッセージを表示するかを設定、取得します。
StartChar | スタートキャラクタを設定、取得します。(Codabar)
StopChar | ストップキャラクタを設定、取得します。(Codabar)
TextRenderingHint | バーコードメッセージのテキストレンダリングの品質を設定、取得します。
Type | バーコードの種類を設定、取得します。
Unit | バーコードの生成単位を設定、取得します。
Value | バーコードデータを設定、取得します。(文字列)
ValueEncoding | バーコードデータのエンコード方式を設定、取得します。(QRCode, PDF417)
WhiteBarRevision | 白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金等代理収納 GS1-128)
Zoom | 倍率を設定、取得します。(JAN、UPC、ITF)
イベント名 | 説明
Error | バーコードの作成に失敗した時に発生します。
参照
メソッド・プロパティ・イベント機能一覧


Windows フォーム用ビューア

このトピックでは、Windows フォーム用ビューアで使用可能なオブジェクト機能一覧を確認することが可能です。

このトピックは、次のセクションを含みます。

  • Printer クラス
  • ViewerControl クラス
Printer クラス
プロパティ名 | 説明
ColorMode | カラーモードを設定、取得します。
Copies | 部数を設定、取得します。
Duplex | 両面印刷を設定、取得します。
ForceCollate | 部数分印刷ジョブを発行し、強制的に部単位印刷を行うかどうかを設定します。
IgnoreInvalidArea | ViewerControl を使用した帳票出力時にプリンターの印字可能領域を適用するかどうかを設定します。
JobPages | 1ジョブあたりのページ数を指定します。
Name | プリンタ名を取得します。
PaperSource | 用紙トレイを設定、取得します。
PrinterResolution | 解像度を設定、取得します。
ViewerControl クラス
メソッド名 | 説明
Clear | 帳票をクリアします。
PrintOut | 印刷します。
SaveAs | Excel ファイルに保存します。
SavePdf | PDF ファイルに保存します。
SetPrinter | プリンタの設定をします。
プロパティ名 | 説明
Document | プレビューする Document を設定します。
EnableAllButton | ツールバーの全体を表示ボタンを有効にするかどうかを設定します。
EnableAsideButton | ツールバーの横に合わせるボタンを有効にするかどうかを設定します。
EnableFirstButton | ツールバーの最初のボタンを有効にするかどうかを設定します。
EnableLastButton | ツールバーの最後のボタンを有効にするかどうかを設定します。
EnableLengthwiseButton | ツールバーの縦に合わせるボタンを有効にするかどうかを設定します。
EnableNextButton | ツールバーの次ページボタンを有効にするかどうかを設定します。
EnablePrevButton | ツールバーの前ページボタンを有効にするかどうかを設定します。
EnablePrintButton | ツールバーの印刷ボタンを有効にするかどうかを設定します。
EnableSaveButton | ツールバーの保存ボタンを有効にするかどうかを設定します。
EnableZoomButton | ツールバーの倍率ボタンを有効にするかどうかを設定します。
ErrorMessage | エラーメッセージを取得します。
ErrorNo | エラーナンバーを取得します。
InternalViewZoom | 表示する倍率を取得します。
IsPdfSaved | PDF ファイルに保存されたかどうかを取得します。
IsPrinted | 印刷されたかどうかを取得します。
IsSaved | Excel ファイルに保存されたかどうかを取得します。
OverFit | 帳票を 1 ページに収まるよう表示するかを設定します。
PageCount | 総ページ数を取得します。
PrintButtonMode | 印刷ボタンの動作を指定します。
PrintDocumentName | 印刷のドキュメント名を設定します。
Printer | Printer を取得します。
PrinterName | 現在選択されているプリンタ名を取得します。
PrintType | 印刷タイプを設定します。
ProgressDescription | プログレスダイアログのユーザーメッセージを設定します。
SaveFileName | 保存時のデフォルトファイル名を設定、取得します。
SaveKind | 保存時のファイルの種類を設定、取得します。
SaveMessage | 保存処理終了後に表示するメッセージ文字列を設定します。
ShowAllButton | ツールバーの全体を表示ボタンを表示するかどうかを設定します。
ShowAsideButton | ツールバーの横に合わせるボタンを表示するかどうかを設定します。
ShowFirstButton | ツールバーの最初のページボタンを表示するかどうかを設定します。
ShowInvalidArea | 印字可能領域を表示するかどうかを設定します。
ShowLastButton | ツールバーの最後のページボタンを表示するかどうかを設定します。
ShowLengthwiseButton | ツールバーの縦に合わせるボタンを表示するかどうかを設定します。
ShowMarginArea | 余白領域を表示するかどうかを設定します。
ShowNextButton | ツールバーの次ページボタンを表示するかどうかを設定します。
ShowPrevButton | ツールバーの前ページボタンを表示するかどうかを設定します。
ShowPrintButton | ツールバーの印刷ボタンを表示するかどうかを設定します。
ShowPrintMenu | ツールバーの印刷メニューの表示を変更します。
ShowPrintMenuItem | ツールバーの印刷ボタンのメニュー「印刷(P)」を表示するかどうかを設定します。
ShowProgressDialog | プログレスダイアログを表示する、しないを設定します。
ShowReportFrame | 帳票の枠組み(罫線、背景色)を表示するかどうかを設定します。
ShowSaveButton | ツールバーの保存ボタンを表示するかどうかを設定します。
ShowSetPrinterMenuItem | ツールバーの印刷ボタンのメニュー「プリンタの設定」を表示するかどうかを設定します。
ShowSheetName | ステータスバーのシート名を表示するかどうかを設定します。
ShowStatusBar | ステータスバーを表示するかどうかを設定します。
ShowToolBar | ツールバーを表示するかどうかを設定します。
ShowUseExcelPrint | 印刷ダイアログの「Excel を使用して印刷する」チェックボックスを表示する、しないを設定します。
ShowZoomButton | ツールバーの倍率ボタンを表示するかどうかを設定します。
SizingGrip | ステータスバーにサイズ変更ハンドルを付けるかどうかを設定します。
ToolBarIcon | ツールバーのアイコンのサイズを設定します。
ToolBarIconType | ツールバーのアイコンのタイプを設定、取得します。
ViewerStatus | プレビューコントロールのステータス(待機、動作中)を取得します。
ViewPage | 表示するページを設定します。
ViewZoom | 表示する倍率を設定します。
イベント名 | 説明
Error | エラーイベント
Progress | プログレスイベント
参照
メソッド・プロパティ・イベント機能一覧


WPF 用ビューア

このトピックでは、WPF 用ビューアで使用可能なオブジェクト機能一覧を確認することが可能です。

このトピックは、次のセクションを含みます。

  • Printer クラス
  • ViewerControl クラス
Printer クラス
プロパティ名 | 説明
CopyCount | 部数を設定、取得します。
Duplexing | 両面印刷を設定、取得します。
InputBin | 用紙トレイを設定、取得します。
JobPages | 1ジョブあたりのページ数を指定します。
Name | プリンタ名を取得します。
PageResolution | 解像度を設定、取得します。
ViewerControl クラス
メソッド名 | 説明
Clear | 帳票をクリアします。
Dispose | Dispose メソッド。
PrintOut | 印刷を行います。
SaveAs | Excel ファイルに保存します。
SavePdf | PDF ファイルに保存します。
SetPrinter | プリンタの設定をします。
プロパティ名 | 説明
Document | プレビューする Document を設定します。
EnableAllButton | ツールバーの全体を表示ボタンを有効にするかどうかを設定します。
EnableAsideButton | ツールバーの横に合わせるボタンを有効にするかどうかを設定します。
EnableFirstButton | ツールバーの最初のボタンを有効にするかどうかを設定します。
EnableLastButton | ツールバーの最後のボタンを有効にするかどうかを設定します。
EnableLengthwiseButton | ツールバーの縦に合わせるボタンを有効にするかどうかを設定します。
EnableNextButton | ツールバーの次ページボタンを有効にするかどうかを設定します。
EnablePrevButton | ツールバーの前ページボタンを有効にするかどうかを設定します。
EnablePrintButton | ツールバーの印刷ボタンを有効にするかどうかを設定します。
EnableSaveButton | ツールバーの保存ボタンを有効にするかどうかを設定します。
EnableZoomButton | ツールバーの倍率ボタンを有効にするかどうかを設定します。
ErrorMessage | エラーメッセージを取得します。
ErrorNo | エラーナンバーを取得します。
InternalViewZoom | 表示する倍率を取得します。
IsPdfSaved | PDF ファイルに保存されたかどうかを取得します。
IsPrinted | 印刷されたかどうかを取得します。
IsSaved | Excel ファイルに保存されたかどうかを取得します。
OverFit | 帳票を 1 ページにおさまるよう表示するかを設定します。
Owner | コントロールのオーナーを指定します。
PageCount | 総ページ数を取得します。
PrintDocumentName | 印刷のドキュメント名を設定します。
Printer | Printer を取得します。
PrinterName | 現在選択されているプリンタ名を取得します。
PrintType | 印刷タイプを設定します。
ProgressDescription | プログレスダイアログのユーザーメッセージ設定します。
SaveFileName | 保存時のデフォルトファイル名を設定、取得します。
SaveKind | 保存時のファイルの種類を設定、取得します。
SaveMessage | 保存処理終了後に表示するメッセージ文字列を設定します。
ShowAllButton | ツールバーの全体を表示ボタンを表示するかどうかを設定します。
ShowAsideButton | ツールバーの横に合わせるボタンを表示するかどうかを設定します。
ShowFirstButton | ツールバーの最初のページボタンを表示するかどうかを設定します。
ShowInvalidArea | 印字可能領域を表示するかどうかを設定します。
ShowLastButton | ツールバーの最後のページボタンを表示するかどうかを設定します。
ShowLengthwiseButton | ツールバーの縦に合わせるボタンを表示するかどうかを設定します。
ShowMarginArea | 余白領域を表示するかどうかを設定します。
ShowNextButton | ツールバーの次ページボタンを表示するかどうかを設定します。
ShowPrevButton | ツールバーの前ページボタンを表示するかどうかを設定します。
ShowPrintButton | ツールバーの印刷ボタンを表示するかどうかを設定します。
ShowProgressDialog | プログレスダイアログを表示する、しないを設定します。
ShowReportFrame | 帳票の枠組み(罫線、背景色) を表示するかどうかを設定します。
ShowSaveButton | ツールバーの保存ボタンを表示するかどうかを設定します。
ShowSheetName | ステータスバーのシート名を表示するかどうかを設定します。
ShowStatusBar | ステータスバーを表示するかどうかを設定します。
ShowToolBar | ツールバーを表示するかどうかを設定します。
ShowUseExcelPrint | 印刷ダイアログの「Excel を使用して印刷する」チェックボックスを表示する、しないを設定します。
ShowZoomButton | ツールバーの倍率ボタンを表示するかどうかを設定します。
ToolBarIcon | ツールバーのアイコンのサイズを設定します。
ToolBarIconType | ツールバーのアイコンのタイプを設定します。
ViewerStatus | プレビューコントロールのステータス(待機、動作中)を取得します。
ViewPage | 表示するページを設定します。
ViewZoom | 表示する倍率を設定します。
イベント名 | 説明
Error | エラーイベント
Progress | プログレスイベント
参照
メソッド・プロパティ・イベント機能一覧


Web 用ビューア

このトピックでは、Web 用ビューアで使用可能なオブジェクト機能一覧を確認することが可能です。

このトピックは、次のセクションを含みます。

    Web 用ビューアクラス
Web 用ビューア クラス
コンストラクター | 説明
CellReport.Viewer | Web 用ビューアのコンストラクターです。
メソッド名 | 説明
report | 帳票ドキュメントを読み込み、プレビューを表示します。
reportUri | 帳票ドキュメントを Uri 指定で取得し、プレビューを表示します。
getErrorMessage | エラーメッセージを取得します。
setPageNo | プレビューの表示ページの切り替えを行います。
setPageZoom | プレビューの表示倍率を指定します。
saveExcel | Excel ファイルの保存を行います。
savePdf | PDF ファイルの保存を行います。
print | 帳票の印刷処理を行います。
setSaveExcelFileName | Excel ファイル保存時のファイル名を指定します。
setSavePdfFileName | PDF ファイル保存時のファイル名を指定します。
setToolBarVisibility | ツールバーの表示有無を指定します。
setPrintMenuButtonVisibility | 印刷メニューボタンの表示有無を指定します。
setSaveMenuButtonVisibility | 保存メニューボタンの表示有無を指定します。
setPrintAllButtonVisibility | 全ページ印刷ボタンの表示有無を指定します。
setPrintCurrentButtonVisibility | 現在のページ印刷ボタンの表示有無を指定します。
setSaveExcelButtonVisibility | Excel ファイル保存ボタンの表示有無を指定します。
setSavePdfButtonVisibility | PDF ファイル保存ボタンの表示有無を指定します。
setPageFirstButtonVisibility | 先頭ページボタンの表示有無を指定します。
setPagePrevButtonVisibility | 前ページボタンの表示有無を指定します。
setPageNextButtonVisibility | 次ページボタンの表示有無を指定します。
setPageLastButtonVisibility | 最終ページボタンの表示有無を指定します。
setZoomButtonVisibility | 拡大縮小ページボタンの表示有無を指定します。
setZoomSelectVisibility | 拡大縮小リストボックスの表示有無を指定します。
setStatusBarVisibility | ステータスバーの表示有無を指定します。
参照
メソッド・プロパティ・イベント機能一覧


CellReport.Viewer コンストラクタ

AS-Report 12.0 for .NET

CellReport.Viewer コンストラクター
Web 用ビューア(CellReport.Viewerクラス)のコンストラクターです。

構文
コピー
CellReport.Viewer [viewercontainerId] [locale]

パラメーター

viewercontainerId
ビューアを表示するための div 要素の id を指定します。
locale (任意)
ロケールを切り替えます。
ビューアでは初期のロケールで、日本語、英語が用意されています。
「asreport.viewer.resources.js」をインクルードし、ファイル内に異なる言語の設定をロケール情報の追加と、追加したロケールの指定でユーザー設定のロケールが使用できます。
(例) 'ja' → 日本語、'en' → 英語
解説
引数 viewercontainer に指定した id 名の DIV 要素にレポートビューアを展開します。レポートビューアのサイズは、DIV 要素の style 情報の height、width で指定できます。
また、style 情報に display:none を設定することで、非表示での帳票出力(ファイル保存、印刷)に対応します。
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer');
関連項目

参照

Web 用ビューア


report メソッド
html ページの div 要素に格納された帳票ドキュメントを読み込み、プレビューを表示します。
構文
コピー
object.report [documentcontainerId] [resolve] [reject]

パラメーター

documentcontainerId
帳票ドキュメントが格納された div 要素の id を指定します。
resolve (任意)
プレビュー表示成功後の処理をコールバックメソッドで指定します。印刷処理の呼び出しには、この引数での実装が必要です。
省略時、または undefined 指定時は何も行われません。
reject (任意)
処理エラー発生後の処理をコールバックメソッドで指定します。
省略時、または undefined 指定時は何も行われません。
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// プレビュー表示後に印刷処理を行うためのコールバックメソッドを記述します。
var resovle = function () { viewer.print(); };
var reject = function () { alert(viewer.getErrorMessage()); };
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer', resovle, reject);
関連項目

参照

Web 用ビューア


reportUri メソッド

帳票ドキュメントを Uri 指定で取得し、プレビューを表示します。

構文
コピー
object.reportUri [uri] [resolve] [reject]

パラメーター

uri
帳票ドキュメントの取得先(Uri)を設定します。
resolve (任意)
プレビュー表示成功後の処理をコールバックメソッドで指定します。印刷処理の呼び出しには、この引数での実装が必要です。
省略時、または undefined 指定時は何も行われません。
reject (任意)
処理エラー発生後の処理をコールバックメソッドで指定します。
省略時、または undefined 指定時は何も行われません。
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// プレビュー表示後に印刷処理を行うためのコールバックメソッドを記述します。
var resovle = function () { viewer.print(); };
var reject = function () { alert(viewer.getErrorMessage()); };
viewer.reportUri('/Invoice/Request?cname=1', resovle, reject);
関連項目

参照

Web 用ビューア


getErrorMessage メソッド

エラーメッセージを取得します。
構文
コピー
object.getErrorMessage []
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// プレビュー表示後に印刷処理を行うためのコールバックメソッドを記述します。
var resovle = function () { viewer.print(); };
var reject = function () { alert(viewer.getErrorMessage()); };
// 存在しない id の要素を指定(エラー発生)した場合。
viewer.report('dummy', resovle, reject);
関連項目

参照

Web 用ビューア


setPageNo メソッド

プレビューの表示ページの切り替えを行います。

構文
コピー
object.setPageNo [pageNo]

パラメーター

pageNo
ページ番号を指定します。
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// プレビュー表示後に5ページ目を表示するためのコールバックメソッドを記述します。
var resovle = function () { viewer.setPageNo(5); };
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer', resovle);
関連項目

参照

Web 用ビューア


setPageZoom メソッド

プレビューの表示倍率を指定します。

構文
コピー
object.setPageZoom [value]

パラメーター

value
表示倍率を % 値(20～600) で指定します。また、-1(全て表示)、-2(横にあわせる）、-3(縦にあわせる)の指定が可能です。
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// プレビュー表示後に表示倍率を200%に変更するためのコールバックメソッドを記述します。
var resovle = function () { viewer.setPageZoom(200); };
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer', resovle);
関連項目

参照

Web 用ビューア


saveExcel メソッド

Excel ファイルの保存を行います。Excel ファイルのファイル形式は帳票テンプレートのファイル形式に依存します。
構文
コピー
object.saveExcel []
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// プレビュー表示後に Excel ファイル保存のコールバックメソッドを記述します。
var resovle = function () { viewer.saveExcel(); };
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer', resovle);
関連項目

参照

Web 用ビューア


savePdf メソッド

PDF ファイルの保存を行います。
構文
コピー
object.savePdf []
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// プレビュー表示後に PDF ファイル保存のコールバックメソッドを記述します。
var resovle = function () { viewer.savePdf(); };
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer', resovle);
関連項目

参照

Web 用ビューア


print メソッド

帳票の印刷処理を行います。印刷時の動作はブラウザに依存します。

構文
コピー
object.print [pageNo]

パラメーター

pageNo (任意)
出力ページを指定したい場合に設定します。省略時は全ページ出力します。
(例1) 3ページ目を出力する。 → "3"
(例2) 3ページ目と6ページ目を出力する。 → "3,6"
(例3) 2ページ目から10ページ目を出力する。 → "2-10"
(例4) 2ページ目以降を出力する。 → "2-"
(例5) 5ページ目までを出力する。 → "-5"
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// プレビュー表示後に印刷のコールバックメソッドを記述します。
var resovle = function () {
  // 1～5ページ目を印刷
  viewer.print('1-5');
};
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer', resovle);
関連項目

参照

Web 用ビューア


setSaveExcelFileName メソッド

Excel ファイル保存時のファイル名を指定します。
構文
コピー
object.setSaveExcelFileName [fileName]

パラメーター

fileName
Excel ファイル名を指定します。ファイル名の指定にのみ対応し、パスを指定した場合は取り除かれます。
ファイル名の禁則文字のほか、'¥' 、';' 、'&' の指定はできません。 拡張子の省略時は、ファイル形式に合わせ ".xls" または ".xlsx" が付加されます。
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// Excelファイル名に 'Output.xlsx' を指定します。
viewer.setSaveExcelFileName('Output.xlsx');
// プレビュー表示後に Excel ファイル保存のコールバックメソッドを記述します。
var resovle = function () { viewer.saveExcel(); };
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer', resovle);
関連項目

参照

Web 用ビューア


setSavePdfFileName メソッド

PDF ファイル保存時のファイル名を指定します。

構文
コピー
object.setSavePdfFileName [fileName]

パラメーター

fileName
PDF ファイル名を指定します。ファイル名の指定にのみ対応し、パスを指定した場合は取り除かれます。
ファイル名の禁則文字のほか、'¥' 、';' 、'&' の指定はできません。拡張子の省略時は、".pdf" が付加されます。
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// PDF ファイル名に 'Output.pdf' を指定
viewer.setSavePdfFileName('Output.pdf');
// プレビュー表示後に PDF ファイル保存のコールバックメソッドを記述します。
var resovle = function () { viewer.savePdf(); };
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer', resovle);
関連項目

参照

Web 用ビューア


setToolBarVisibility メソッド

ツールバーの表示有無を指定します。

構文
コピー
object.setToolBarVisibility [visibility]

パラメーター

visibility
ツールバーを非表示にする場合は false。(既定値：true)
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// ツールバーを非表示に設定します。
viewer.setToolBarVisibility(false);
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer');
関連項目

参照

Web 用ビューア


setPrintMenuButtonVisibility メソッド

印刷メニューボタンの表示有無を指定します。

構文
コピー
object.setPrintMenuButtonVisibility [visibility]

パラメーター

visibility
印刷メニューボタンを非表示にする場合は false。(既定値：true)
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// 印刷メニューボタンを非表示に設定します。
viewer.setPrintMenuButtonVisibility(false);
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer');
関連項目

参照

Web 用ビューア


setSaveMenuButtonVisibility メソッド

保存メニューボタンの表示有無を指定します。

構文
コピー
object.setSaveMenuButtonVisibility [visibility]

パラメーター

visibility
保存メニューボタンを非表示にする場合は false。(既定値：true)
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// 保存メニューボタンを非表示に設定します。
viewer.setSaveMenuButtonVisibility(false);
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer');
関連項目

参照

Web 用ビューア


setPrintAllButtonVisibility メソッド

全ページ印刷ボタンの表示有無を指定します。

構文
コピー
object.setPrintAllButtonVisibility [visibility]

パラメーター

visibility
全ページ印刷ボタンを非表示にする場合は false。(既定値：true)
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// 全ページ印刷ボタンを非表示に設定します。
viewer.setPrintAllButtonVisibility(false);
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer');
関連項目

参照

Web 用ビューア


setPrintCurrentButtonVisibility メソッド

現在のページ印刷ボタンの表示有無を指定します。

構文
コピー
object.setPrintCurrentButtonVisibility [visibility]

パラメーター

visibility
現在のページ印刷ボタンを非表示にする場合は false。(既定値：true)
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// 現在のページ印刷ボタンを非表示に設定します。
viewer.setPrintCurrentButtonVisibility(false);
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer');
関連項目

参照

Web 用ビューア


setSaveExcelButtonVisibility メソッド

Excel ファイル保存ボタンの表示有無を指定します。

構文
コピー
object.setSaveExcelButtonVisibility [visibility]

パラメーター

visibility
Excel ファイル保存ボタンを非表示にする場合は false。(既定値：true)
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// Excel ファイル保存ボタンを非表示に設定します。
viewer.setSaveExcelButtonVisibility(false);
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer');
関連項目

参照

Web 用ビューア


setSavePdfButtonVisibility メソッド

PDF ファイル保存ボタンの表示有無を指定します。

構文
コピー
object.setSavePdfButtonVisibility [visibility]

パラメーター

visibility
PDF ファイル保存ボタンを非表示にする場合は false。(既定値：true)
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// PDF ファイル保存ボタンを非表示に設定します。
viewer.setSavePdfButtonVisibility(false);
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer');
関連項目

参照

Web 用ビューア


setPageFirstButtonVisibility メソッド

先頭ページボタンの表示有無を指定します。

構文
コピー
object.setPageFirstButtonVisibility [visibility]

パラメーター

visibility
先頭ページボタンを非表示にする場合は false。(既定値：true)
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// 先頭ページボタンを非表示に設定します。
viewer.setPageFirstButtonVisibility(false);
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer');
関連項目

参照

Web 用ビューア


setPagePrevButtonVisibility メソッド

前ページボタンの表示有無を指定します。

構文
コピー
object.setPagePrevButtonVisibility [visibility]

パラメーター

visibility
前ページボタンを非表示にする場合は false。(既定値：true)
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// 前ページボタンを非表示に設定します。
viewer.setPagePrevButtonVisibility(false);
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer');
関連項目

参照

Web 用ビューア


setPageNextButtonVisibility メソッド

次ページボタンの表示有無を指定します。

構文
コピー
object.setPageNextButtonVisibility [visibility]

パラメーター

visibility
次ページボタンを非表示にする場合は false。(既定値：true)
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// 次ページボタンを非表示に設定します。
viewer.setPageNextButtonVisibility(false);
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer');
関連項目

参照

Web 用ビューア


setPageLastButtonVisibility メソッド

最終ページボタンの表示有無を指定します。

構文
コピー
object.setPageLastButtonVisibility [visibility]

パラメーター

visibility
最終ページボタンを非表示にする場合は false。(既定値：true)
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// 最終ページボタンを非表示に設定します。
viewer.setPageLastButtonVisibility(false);
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer');
関連項目

参照

Web 用ビューア


setZoomButtonVisibility メソッド

拡大縮小ページボタンの表示有無を指定します。

構文
コピー
object.setZoomButtonVisibility [visibility]

パラメーター

visibility
拡大縮小ページボタンを非表示にする場合は false。(既定値：true)
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// 拡大縮小ページボタンを非表示に設定します。
viewer.setZoomButtonVisibility(false);
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer');
関連項目

参照

Web 用ビューア


setZoomSelectVisibility メソッド

拡大縮小リストボックスの表示有無を指定します。

構文
コピー
object.setZoomSelectVisibility [visibility]

パラメーター

visibility
拡大縮小リストボックスを非表示にする場合は false。(既定値：true)
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// 拡大縮小リストボックスを非表示に設定します。
viewer.setZoomSelectVisibility(false);
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer');
関連項目

参照

Web 用ビューア


setStatusBarVisibility メソッド

ステータスバーの表示有無を指定します。

構文
コピー
object.setStatusBarVisibility [visibility]

パラメーター

visibility
ステータスバーを非表示にする場合は false。(既定値：true)
例
JavaScript
コピー
// ビューアを id 名 [viewercontainer] の DIV 要素に表示します。
viewer = new CellReport.Viewer('viewercontainer');
// ステータスバーを非表示に設定します。
viewer.setStatusBarVisibility(false);
// id 名 [documentcontainer] の DIV 要素に格納された帳票ドキュメントを読み込みます。
viewer.report('documentcontainer');
関連項目

参照

Web 用ビューア


クラス ライブラリ リファレンス

このクラス ライブラリは、AS-Report 12.0 for .NET に含まれているクラス、インターフェイス、および値型のライブラリです。AS-Report 12.0 for .NET のアプリケーションを作成する場合の基礎となるようにデザインされています。
名前空間
名前空間 | 説明
AdvanceSoftware.ASReport | AdvanceSoftware.ASReport 名前空間には、Windows フォーム用ビューア、レポートコンポーネントが含まれています。
AdvanceSoftware.ASReport.BarCode | AdvanceSoftware.ASReport.BarCode 名前空間には、バーコードコンポーネントが含まれています。
AdvanceSoftware.ASReport.Wpf | AdvanceSoftware.ASReport.Wpf 名前空間には、WPF 用ビューアが含まれています。
AdvanceSoftware.Charting.Properties | AdvanceSoftware.Charting.Properties 名前空間には、CellReport コンポーネントのメソッドで使用するフィールド、列挙体が含まれています。


AdvanceSoftware.ASReport 名前空間

AdvanceSoftware.ASReport 名前空間には、Windows フォーム用ビューア、レポートコンポーネントが含まれています。
クラス
 | クラス | 説明
Public クラス | Cell | 帳票のセルの指定やデータ設定を行います。レポートコンポーネントを通じてこのクラスにアクセスします。
Public クラス | CellAttr | 帳票のセル属性を設定します。レポートコンポーネントを通じてこのクラスにアクセスします。
Public クラス | CellCanvas | 帳票にイメージファイルや図形を設定します。 このクラスで設定したイメージファイルや図形は Excel ファイルに反映されません。 レポートコンポーネントを通じてこのクラスにアクセスします。
Public クラス | CellReport | 帳票を作成するレポートコンポーネントです。
Public クラス | Drawing | 帳票にイメージファイルや図形を設定します。レポートコンポーネントを通じてこのクラスにアクセスします。
Public クラス | Page | 帳票の出力対象を指定します。レポートコンポーネントを通じてこのクラスにアクセスします。
Public クラス | PageAttr | 帳票のページ設定を行います。レポートコンポーネントを通じてこのクラスにアクセスします。
Public クラス | PdfOption | PDF ファイルのオプションを設定します。レポートコンポーネントを通じてこのクラスにアクセスします。
Public クラス | PdfSignature | PDF に付加する署名のオプションを設定します。レポートコンポーネントを通じてこのクラスにアクセスします。
Public クラス | Printer | 帳票の出力先プリンタの情報を扱う Printer オブジェクトです。ViewerControl オブジェクトを通じてこのクラスにアクセスします。
Public クラス | Report | 帳票の作成開始、終了、ならびに、デザインファイルの指定を行います。レポートコンポーネントを通じてこのクラスにアクセスします。
Public クラス | ReportErrorEventArgs | Error イベントのデータを提供します。
Public クラス | ReportProgressEventArgs | Progress イベントのデータを提供します。
Public クラス | RunPageStartEventArgs | RunPageStart イベントのデータを提供します。
Public クラス | Section | 連続帳票を指定します。レポートコンポーネントを通じてこのクラスにアクセスします。
Public クラス | SectionDetail | 連続帳票の明細行を指定します。レポートコンポーネントを通じてこのクラスにアクセスします。
Public クラス | SectionEndPageEventArgs | SectionEndPage イベントのデータを提供します。
Public クラス | SectionFooter | 連続帳票のフッターを指定します。レポートコンポーネントを通じてこのクラスにアクセスします。
Public クラス | SectionHeader | 連続帳票のヘッダーを指定します。レポートコンポーネントを通じてこのクラスにアクセスします。
Public クラス | SectionNewPageEventArgs | SectionNewPage イベントのデータを提供します。
Public クラス | ViewerControl | 帳票を出力する ViewerControl オブジェクトです。
デリゲート
 | デリゲート | 説明
Public デリゲート | ReportErrorEventHandler | Error イベントを処理するメソッドを表します。
Public デリゲート | ReportProgressEventHandler | Progress イベントを処理するメソッドを表します。
Public デリゲート | RunPageStartEventHandler | RunPageStart イベントを処理するメソッドを表します。
Public デリゲート | RunReportStartEventHandler | RunReportStart イベントを処理するメソッドを表します。
Public デリゲート | SectionEndPageEventHandler | SectionEndPage イベントを処理するメソッドを表します。
Public デリゲート | SectionNewPageEventHandler | SectionNewPage イベントを処理するメソッドを表します。
列挙体
 | 列挙体 | 説明
Public 列挙体 | ArrowType | 矢印タイプ、サイズを示す識別子を指定します。
Public 列挙体 | BorderStyle | 線種を示す識別子を指定します。
Public 列挙体 | BoxType | ボックス罫線タイプを示す識別子を指定します。
Public 列挙体 | CellClearMode | セルクリアモードを示す識別子を指定します。
Public 列挙体 | DocumentStatus | ドキュメントの状態を示す識別子を指定します。
Public 列挙体 | DoubleCellValueMode | 浮動小数点数値をセルに格納する方法を示す識別子を指定します。
Public 列挙体 | ErrorNo | エラーナンバーを示す識別子を指定します。
Public 列挙体 | ExcelModeType | ExcelMode = true 時の Excel 起動モードを指定します。
Public 列挙体 | ExcelVersion | Excel ファイルのバージョンを示す識別子を指定します。
Public 列挙体 | FillType | 塗りつぶしタイプを示す識別子を指定します。
Public 列挙体 | FontStyle | フォントスタイルを示す識別子を指定します。
Public 列挙体 | FontULine | フォント下線を示す識別子を指定します。
Public 列挙体 | HeaderFooterMode | ヘッダー/フッター設定モードを示す識別子を指定します。
Public 列挙体 | HeaderFooterType | ヘッダー/フッター設定タイプを示す識別子を指定します。
Public 列挙体 | HorizontalAlignment | 水平方向の位置を示す識別子を指定します。
Public 列挙体 | ImageType | イメージタイプを示す識別子を指定します。
Public 列挙体 | LineStyle | オートシェイプの線種を示す識別子を指定します。
Public 列挙体 | MaxEndPoint | データや属性の範囲を示す識別子を指定します。
Public 列挙体 | Orientation | 文字の方向を示す識別子を指定します。
Public 列挙体 | OutputMode | 出力モードを指定します。
Public 列挙体 | PageCenter | ページ中央を示す識別子を指定します。
Public 列挙体 | PageOrder | ページの方向を示す識別子を指定します。
Public 列挙体 | PageOrientation | 用紙方向を示す識別子を指定します。
Public 列挙体 | Pattern | パターンを示す識別子を指定します。
Public 列挙体 | PdfEncryptionType | PDF の暗号化強度を示す識別子を指定します。
Public 列挙体 | PdfPermit | PDF の権限を示す識別子を指定します。
Public 列挙体 | PrintButtonMode | 印刷ボタンの動作を指定します。
Public 列挙体 | PrintType | プリントタイプを示す識別子を指定します。
Public 列挙体 | ProgressType | プログレスタイプを示す識別子を指定します。
Public 列挙体 | ReleaseExcelTask | Excel タスクの動作を指定します。
Public 列挙体 | ReportFrame | 帳票の枠組みをプレビュー・印刷するかを指定します。
Public 列挙体 | ReportMode | レポートモードを指定します。
Public 列挙体 | SaveKind | ファイル保存ダイアログのファイルの種類に設定する形式を指定します。
Public 列挙体 | ScaleMode | スケールモードを示す識別子を指定します。
Public 列挙体 | ShapeType | シェイプタイプを示す識別子を指定します。
Public 列挙体 | StreamMode | データを展開するストリームモードを示す識別子を指定します。
Public 列挙体 | SvgSaveType | 保存するファイルのタイプを指定します。
Public 列挙体 | TextAlign | テキストボックスの水平方向の文字位置を示す識別子を指定します。
Public 列挙体 | TextAnchor | テキストボックスの垂直方向の文字位置を示す識別子を指定します。
Public 列挙体 | TextBoxFontStyle | テキストボックスのフォントスタイルを示す識別子を指定します。
Public 列挙体 | TextVertical | テキストボックスの縦書きを示す識別子を指定します。
Public 列挙体 | ToolBarIcon | ツールバーアイコンの大きさを指定します。
Public 列挙体 | ToolBarIconType | ツールバーアイコンのタイプを指定します。
Public 列挙体 | VarInsertMode | 変数名挿入モードを示す識別子を指定します。
Public 列挙体 | VarNameMode | 変数名キーワードの扱いを示す識別子を指定します。
Public 列挙体 | VerticalAlignment | 垂直方向の位置を示す識別子を指定します。
Public 列挙体 | ViewerClearMode | ビューアのクリアモードを示す識別子を指定します。
Public 列挙体 | ViewerStatus | ビューアの状態を示す識別子を指定します。
Public 列挙体 | ViewZoom | ビューズームを示す識別子を指定します。
Public 列挙体 | xlColor | カラーを示す識別子を指定します。
Public 列挙体 | xlsShapeType | シェイプタイプ(Xls)を示す識別子を指定します。
Public 列挙体 | xlsVersion | Excel ファイル(Xls 形式)のバージョンを示す識別子を指定します。
Public 列挙体 | xlsxShapeType | シェイプタイプ(Xlsx)を示す識別子を指定します。
Public 列挙体 | xlsxVersion | Excel ファイル(Xlsx 形式)のバージョンを示す識別子を指定します。


ArrowType 列挙体

矢印タイプ、サイズを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ArrowType
Public Enumeration ArrowType
メンバー
メンバー | 値 | 説明
None | 0 | なし
Triangle | 1 | 三角形
Arrow | 5 | ライン
Stealth | 2 | 鋭角
Diamond | 3 | ひし形
Oval | 4 | 丸
Small | 0 | 小さく
Medium | 16 | 普通
Large | 32 | 大きく
Short | 0 | 短い
Normal | 64 | 普通
Long | 128 | 長い
関連項目

参照

AdvanceSoftware.ASReport 名前空間


BorderStyle 列挙体

線種を示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum BorderStyle
Public Enumeration BorderStyle
メンバー
メンバー | 値 | 説明
None | 0x00000000 | なし
Thin | 0x01000000 | 実線
Medium | 0x02000000 | 太線
Dashed | 0x03000000 | 破線
Dotted | 0x04000000 | 点線
Thick | 0x05000000 | 極太線
Double | 0x06000000 | 二重線
Hair | 0x07000000 | 細実線
MediumDashed | 0x08000000 | 中破線
DashDot | 0x09000000 | 細一点鎖線
MediumDashDot | 0x0A000000 | 中一点鎖線
DashDotDot | 0x0B000000 | 細二点鎖線
MediumDashDotDot | 0x0C000000 | 中二点鎖線
SlantDashDot | 0x0D000000 | 中一点斜鎖線
関連項目

参照


BoxType 列挙体

ボックス罫線タイプを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum BoxType
Public Enumeration BoxType
メンバー
メンバー | 値 | 説明
Box | 0 | 箱線
Ltc | 1 | 格子線
Over | 2 | 上横線
Under | 3 | 下横線
Left | 4 | 左縦線
Right | 5 | 右縦線
関連項目

参照


Cell クラス

帳票のセルの指定やデータ設定を行います。レポートコンポーネントを通じてこのクラスにアクセスします。
継承階層
SystemObject
AdvanceSoftware.ASReportCell

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Cell
Public Class Cell

Cell 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
Public プロパティ | Attr | Attr を取得します。
 | AttrNo | 属性番号を設定、取得します。
 | Break | 改ページを設定します。
Public プロパティ | Canvas | Canvas を取得します。
 | ColWidth | セル幅を設定、取得します。
Public プロパティ | Drawing | Drawing を取得します。
 | FormattedString | 書式化された文字列を取得します。
 | RowHeight | 行高を設定、取得します。
 | Str | 文字列を設定、取得します。
 | Value | 値を設定、取得します。
トップ
メソッド
名前 | 説明
Clear | セルをクリアします。
Clear(CellClearMode) | モードを指定してセルをクリアします。
Copy | セルをコピーします。
Copy(String) | セルをコピーします。
Func | 計算式を設定します。
Paste | コピーしたセルを貼り付けます。
Value2 | 属性番号を指定して値を設定します。
トップ
関連項目

参照


Cell プロパティ

Cell 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
Public プロパティ | Attr | Attr を取得します。
 | AttrNo | 属性番号を設定、取得します。
 | Break | 改ページを設定します。
Public プロパティ | Canvas | Canvas を取得します。
 | ColWidth | セル幅を設定、取得します。
Public プロパティ | Drawing | Drawing を取得します。
 | FormattedString | 書式化された文字列を取得します。
 | RowHeight | 行高を設定、取得します。
 | Str | 文字列を設定、取得します。
 | Value | 値を設定、取得します。
トップ
関連項目

参照

Cell クラス


Cell.Attr プロパティ

CellAttr プロパティ

Attr を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public CellAttr Attr { get; }
Public ReadOnly Property Attr As CellAttr
    Get

プロパティ値

型: CellAttr
セルに属性を設定するための CellAttr クラス。
解説
このクラスの全てのメンバーの一覧については、CellAttr クラスのメンバーを参照してください。
関連項目

参照

Cell クラス


Cell.AttrNo プロパティ

CellAttrNo プロパティ

属性番号を設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int AttrNo { get; set; }
Public Property AttrNo As Integer
    Get
    Set

プロパティ値

型: Int32
セルの属性番号。
解説
AttrNo プロパティを使用して、各セルで保持する罫線や表示形式等の書式情報を属性番号として取得し、 取得した属性番号は Value2 メソッドを使用して、データの差し込みと同時に取得した属性番号と 同じ書式情報を設定することができます。
例
C#
VB
コピー
int attrNo;
// A1 セルの属性番号を取得します。
attrNo = cellReport1.Cell("A1").AttrNo;
// B1 セルに A1 セルから取得した属性番号を指定して "アドバンスソフトウェア" を設定します。
cellReport1.Cell("B1").Value2("アドバンスソフトウェア", attrNo);
Dim attrNo As Integer
' A1 セルの属性番号を取得します。
attrNo = CellReport1.Cell("A1").AttrNo
' B1 セルに A1 セルから取得した属性番号を指定して "アドバンスソフトウェア" を設定します。
CellReport1.Cell("B1").Value2("アドバンスソフトウェア", attrNo)
関連項目

参照

Cell クラス


Cell.Break プロパティ

CellBreak プロパティ

改ページを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool Break { set; }
Public WriteOnly Property Break As Boolean
    Set

プロパティ値

型: Boolean
改ページを設定する場合は true。
例
C#
VB
コピー
// 10 行目に改ページを設定します。
cellReport1.Cell("10").Break = true;
' 10 行目に改ページを設定します。
CellReport1.Cell("10").Break = True
関連項目

参照

Cell クラス


Cell.Canvas プロパティ

CellCanvas プロパティ

Canvas を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public CellCanvas Canvas { get; }
Public ReadOnly Property Canvas As CellCanvas
    Get

プロパティ値

型: CellCanvas
関連項目

参照

Cell クラス


Cell.ColWidth プロパティ

CellColWidth プロパティ

セル幅を設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double ColWidth { get; set; }
Public Property ColWidth As Double
    Get
    Set

プロパティ値

型: Double
セルの幅(文字数単位)。
解説
列幅を半角文字数 (0 ～ 255 文字) で設定します。0 を設定した場合は非表示列となります。
例
C#
VB
コピー
// A 列の列幅を 20 文字数分に設定します。
cellReport1.Cell("A").ColWidth = 20;
' A 列の列幅を 20 文字数分に設定します。
CellReport1.Cell("A").ColWidth = 20
関連項目

参照

Cell クラス


Cell.Drawing プロパティ

CellDrawing プロパティ

Drawing を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Drawing Drawing { get; }
Public ReadOnly Property Drawing As Drawing
    Get

プロパティ値

型: Drawing
帳票にイメージファイルや図形を設定するための Drawing クラス。
解説
このクラスの全てのメンバーの一覧については、Drawing クラスのメンバーを参照してください。
関連項目

参照

Cell クラス


Cell.FormattedString プロパティ

CellFormattedString プロパティ

書式化された文字列を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string FormattedString { get; }
Public ReadOnly Property FormattedString As String
    Get

プロパティ値

型: String
例
C#
VB
コピー
// A1 セルの書式化された文字列を取得します。
string formattedString = cellReport1.Cell("A1").FormattedString;
' A1 セルの書式化された文字列を取得します。
Dim formattedString As String = CellReport1.Cell("A1").FormattedString
関連項目

参照

Cell クラス


Cell.RowHeight プロパティ

CellRowHeight プロパティ

行高を設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double RowHeight { get; set; }
Public Property RowHeight As Double
    Get
    Set

プロパティ値

型: Double
セルの高さ(ポイント単位)。
解説
高さをポイント(0 ～ 409 ポイント)で設定します。0 を設定した場合は非表示行となります。
例
C#
VB
コピー
// 1 行目の行高を 21 ポイントに設定します。
cellReport1.Cell("1").RowHeight = 21;
' 1 行目の行高を 21 ポイントに設定します。
CellReport1.Cell("1").RowHeight = 21
関連項目

参照

Cell クラス


Cell.Str プロパティ

CellStr プロパティ

文字列を設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Str { get; set; }
Public Property Str As String
    Get
    Set

プロパティ値

型: String
セルの値(文字列)。
例
C#
VB
コピー
// A1 セルに文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Cell("A1").Str = "アドバンスソフトウェア";
// B1 セルに文字列 "100" を設定します。
cellReport1.Cell("B1").Str = "100";
' A1 セルに文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Cell("A1").Str = "アドバンスソフトウェア"
' B1 セルに文字列 "100" を設定します。
CellReport1.Cell("B1").Str = "100"
関連項目

参照

Cell クラス


Cell.Value プロパティ

CellValue プロパティ

値を設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set

プロパティ値

型: Object
セルの値。
解説
文字列を設定した場合は文字列として値が設定され、数値で設定した場合は数値として設定されます。
例
C#
VB
コピー
// A1 セルに文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
// B1 セルに数値 "100" を設定します。
cellReport1.Cell("B1").Value = 100;
' A1 セルに文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
' B1 セルに数値 "100" を設定します。
CellReport1.Cell("B1").Value = 100
関連項目

参照

Cell クラス


Cell メソッド

Cell 型は下記のメンバーを公開します。

メソッド
名前 | 説明
Clear | セルをクリアします。
Clear(CellClearMode) | モードを指定してセルをクリアします。
Copy | セルをコピーします。
Copy(String) | セルをコピーします。
Func | 計算式を設定します。
Paste | コピーしたセルを貼り付けます。
Value2 | 属性番号を指定して値を設定します。
トップ
関連項目

参照

Cell クラス


Cell.Clear メソッド

CellClear メソッド

オーバーロードの一覧
名前 | 説明
Clear | セルをクリアします。
Clear(CellClearMode) | モードを指定してセルをクリアします。
トップ
関連項目

参照

Cell クラス


Cell.Clear メソッド

CellClear メソッド

セルをクリアします。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Clear()
Public Sub Clear
例
C#
VB
コピー
// A1 セルのデータと属性をクリアします。
cellReport1.Cell("A1").Clear();
' A1 セルのデータと属性をクリアします。
CellReport1.Cell("A1").Clear()
関連項目

参照

Cell クラス
Clear オーバーロード


Cell.Clear メソッド (CellClearMode)

CellClear メソッド (CellClearMode)

モードを指定してセルをクリアします。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Clear(
    CellClearMode cellClearMode
)
Public Sub Clear (
    cellClearMode As CellClearMode
)

パラメーター

cellClearMode
型: AdvanceSoftware.ASReportCellClearMode
AdvanceSoftware.ASReport.CellClearMode を指定します。
例
C#
VB
コピー
// A1 セルのデータと属性をクリアします。
cellReport1.Cell("A1").Clear(AdvanceSoftware.ASReport.CellClearMode.All);
// B1 セルの属性をクリアします。
cellReport1.Cell("B1").Clear(AdvanceSoftware.ASReport.CellClearMode.Attr);
// C1 セルのデータをクリアします。
cellReport1.Cell("C1").Clear(AdvanceSoftware.ASReport.CellClearMode.Value);
' A1 セルのデータと属性をクリアします。
CellReport1.Cell("A1").Clear(AdvanceSoftware.ASReport.CellClearMode.All)
' B1 セルの属性をクリアします。
CellReport1.Cell("B1").Clear(AdvanceSoftware.ASReport.CellClearMode.Attr)
' C1 セルのデータをクリアします。
CellReport1.Cell("C1").Clear(AdvanceSoftware.ASReport.CellClearMode.Value)
関連項目

参照

Cell クラス
Clear オーバーロード


Cell.Copy メソッド

CellCopy メソッド

オーバーロードの一覧
名前 | 説明
Copy | セルをコピーします。
Copy(String) | セルをコピーします。
トップ
関連項目

参照

Cell クラス


Cell.Copy メソッド

CellCopy メソッド

セルをコピーします。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Copy()
Public Sub Copy
解説
引数を省略した場合、セルがメモリ上にコピーされ、Cell.Paste メソッドで指定したセルに貼り付けることができます。
例
C#
VB
コピー
// A1 セルをメモリ上にコピーします。
cellReport1.Cell("A1").Copy();
// メモリ上にコピーしたセルを B1 セルに貼り付けます。
cellReport1.Cell("B1").Paste();
' A1 セルをメモリ上にコピーします。
CellReport1.Cell("A1").Copy()
' メモリ上にコピーしたセルを B1 セルに貼り付けます。
CellReport1.Cell("B1").Paste()
関連項目

参照

Cell クラス
Copy オーバーロード


Cell.Copy メソッド (String)

CellCopy メソッド (String)

セルをコピーします。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Copy(
    string cell
)
Public Sub Copy (
    cell As String
)

パラメーター

cell
型: SystemString
コピー先のセル名を A1 形式で指定します。
例
C#
VB
コピー
// A1 セルをコピーして B1 セルに貼り付けます。
cellReport1.Cell("A1").Copy("B1");
' A1 セルをコピーして B1 セルに貼り付けます。
CellReport1.Cell("A1").Copy("B1")
関連項目

参照

Cell クラス
Copy オーバーロード


Cell.Func メソッド

CellFunc メソッド

計算式を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Func(
    string function,
    Object answer
)
Public Sub Func (
    function As String,
    answer As Object
)

パラメーター

function
型: SystemString
計算式文字列を設定します。
answer
型: SystemObject
計算式の解を設定します。
解説
セルに計算式を設定する場合、このメソッドを使用します。 計算式の解を設定することで、帳票に計算結果を出力することができます。
例
C#
VB
コピー
cellReport1.Cell("A1").Value = 100;
cellReport1.Cell("B1").Value = 200;
// 計算式 "=A1+B1" を C1 セルに設定します。
cellReport1.Cell("C1").Func("=A1+B1", null);
// 計算式 "=A1+B1" と計算結果 "300" を C2 セルに設定します。
cellReport1.Cell("C2").Func("=A1+B1", 300);
CellReport1.Cell("A1").Value = 100
CellReport1.Cell("B1").Value = 200
' 計算式 "=A1+B1" を C1 セルに設定します。
CellReport1.Cell("C1").Func("=A1+B1", Nothing)
' 計算式 "=A1+B1" と計算結果 "300" を C2 セルに設定します。
CellReport1.Cell("C2").Func("=A1+B1", 300)
関連項目

参照

Cell クラス


Cell.Paste メソッド

CellPaste メソッド

コピーしたセルを貼り付けます。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Paste()
Public Sub Paste
解説
Copy メソッドでコピーしたセルを貼り付けます。
例
C#
VB
コピー
// A1 セルをメモリ上にコピーします。
cellReport1.Cell("A1").Copy();
// メモリ上にコピーしたセルを B1 セルに貼り付けます。
cellReport1.Cell("B1").Paste();
' A1 セルをメモリ上にコピーします。
CellReport1.Cell("A1").Copy()
' メモリ上にコピーしたセルを B1 セルに貼り付けます。
CellReport1.Cell("B1").Paste()
関連項目

参照

Cell クラス


Cell.Value2 メソッド

CellValue2 メソッド

属性番号を指定して値を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Value2(
    Object value,
    int attrNo
)
Public Sub Value2 (
    value As Object,
    attrNo As Integer
)

パラメーター

value
型: SystemObject
値を設定します。
attrNo
型: SystemInt32
属性番号を設定します。
解説
設定する属性番号については、AttrNo プロパティを参照してください。
例
C#
VB
コピー
int attrNo;
// A1 セルの属性番号を取得します。
attrNo = cellReport1.Cell("A1").AttrNo;
// B1 セルに A1 セルから取得した属性番号を指定して "アドバンスソフトウェア" を設定します。
cellReport1.Cell("B1").Value2("アドバンスソフトウェア", attrNo);
Dim attrNo As Integer
' A1 セルの属性番号を取得します。
attrNo = CellReport1.Cell("A1").AttrNo
' B1 セルに A1 セルから取得した属性番号を指定して "アドバンスソフトウェア" を設定します。
CellReport1.Cell("B1").Value2("アドバンスソフトウェア", attrNo)
関連項目

参照

Cell クラス


CellAttr クラス

帳票のセル属性を設定します。レポートコンポーネントを通じてこのクラスにアクセスします。
継承階層
SystemObject
AdvanceSoftware.ASReportCellAttr

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class CellAttr
Public Class CellAttr

CellAttr 型は下記のメンバーを公開します。

プロパティ
名前 | 説明
BackColor | 背景色を設定します。(xlsx 形式のみ)
BackColor2 | 背景色を設定します。
FontColor | フォントカラーを設定します。(xlsx 形式のみ)
FontColor2 | フォントカラーを設定します。
FontName | フォント名を設定します。
FontPoint | フォントサイズを設定します。
FontStyle | フォントスタイルを設定します。
FontULine | フォント下線を設定します。
ForeColor | 前景色を設定します。(xlsx 形式のみ)
ForeColor2 | 前景色を設定します。
Format | 表示書式を設定します。
HorizontalAlignment | 文字の配置の横位置を設定します。
Locked | セルのロックを設定、取得します。
MergeCells | セルの結合を設定します。
Orientation | 文字の配置の回転を設定します。
Pattern | パターンを設定します。
ShrinkToFit | 縮小して全体を表示を設定します。
VerticalAlignment | 文字の配置の縦位置を設定します。
WrapText | 折り返して全体を表示を設定します。
トップ
メソッド
名前 | 説明
Box(BoxType, BorderStyle, xlColor) | Box 罫線を設定します。
Box(BoxType, BorderStyle, Color) | Box 罫線を設定します。(xlsx 形式のみ)
LineBottom(BorderStyle, xlColor) | 下罫線を設定します。
LineBottom(BorderStyle, Color) | 下罫線を設定します。(xlsx 形式のみ)
LineLeft(BorderStyle, xlColor) | 左罫線を設定します。
LineLeft(BorderStyle, Color) | 左罫線を設定します。(xlsx 形式のみ)
LineLeftUp(BorderStyle, xlColor) | 左上がり罫線を設定します。
LineLeftUp(BorderStyle, Color) | 左上がり罫線を設定します。(xlsx 形式のみ)
LineRight(BorderStyle, xlColor) | 右罫線を設定します。
LineRight(BorderStyle, Color) | 右罫線を設定します。(xlsx 形式のみ)
LineRightUp(BorderStyle, xlColor) | 右上がり罫線を設定します。
LineRightUp(BorderStyle, Color) | 右上がり罫線を設定します。(xlsx 形式のみ)
LineTop(BorderStyle, xlColor) | 上罫線を設定します。
LineTop(BorderStyle, Color) | 上罫線を設定します。(xlsx 形式のみ)
トップ
関連項目

参照


CellAttr プロパティ

CellAttr 型は下記のメンバーを公開します。

プロパティ
名前 | 説明
BackColor | 背景色を設定します。(xlsx 形式のみ)
BackColor2 | 背景色を設定します。
FontColor | フォントカラーを設定します。(xlsx 形式のみ)
FontColor2 | フォントカラーを設定します。
FontName | フォント名を設定します。
FontPoint | フォントサイズを設定します。
FontStyle | フォントスタイルを設定します。
FontULine | フォント下線を設定します。
ForeColor | 前景色を設定します。(xlsx 形式のみ)
ForeColor2 | 前景色を設定します。
Format | 表示書式を設定します。
HorizontalAlignment | 文字の配置の横位置を設定します。
Locked | セルのロックを設定、取得します。
MergeCells | セルの結合を設定します。
Orientation | 文字の配置の回転を設定します。
Pattern | パターンを設定します。
ShrinkToFit | 縮小して全体を表示を設定します。
VerticalAlignment | 文字の配置の縦位置を設定します。
WrapText | 折り返して全体を表示を設定します。
トップ
関連項目

参照

CellAttr クラス


CellAttr.BackColor プロパティ

CellAttrBackColor プロパティ

背景色を設定します。(xlsx 形式のみ)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color BackColor { set; }
Public WriteOnly Property BackColor As Color
    Set

プロパティ値

型: Color
セルの背景色を表す Color 構造体。
解説
Color 構造体を使用してセルの背景色を設定します。 xlsx 形式のファイルでのみ設定可能です。
例
C#
VB
コピー
// A1 セルの背景色を "赤色" に設定します。
cellReport1.Cell("A1").Attr.BackColor = System.Drawing.Color.Red;
' A1 セルの背景色を "赤色" に設定します。
CellReport1.Cell("A1").Attr.BackColor = System.Drawing.Color.Red
関連項目

参照

CellAttr クラス


CellAttr.BackColor2 プロパティ

CellAttrBackColor2 プロパティ

背景色を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public xlColor BackColor2 { set; }
Public WriteOnly Property BackColor2 As xlColor
    Set

プロパティ値

型: xlColor
セルの背景色を表す xlColor。
解説
xlColor 列挙体のメンバを使用してセルの背景色を設定します。
例
C#
VB
コピー
// A1 セルの背景色を "赤色" に設定します。
cellReport1.Cell("A1").Attr.BackColor2 = AdvanceSoftware.ASReport.xlColor.Red;
' A1 セルの背景色を "赤色" に設定します。
CellReport1.Cell("A1").Attr.BackColor2 = AdvanceSoftware.ASReport.xlColor.Red
関連項目

参照

CellAttr クラス


CellAttr.FontColor プロパティ

CellAttrFontColor プロパティ

フォントカラーを設定します。(xlsx 形式のみ)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color FontColor { set; }
Public WriteOnly Property FontColor As Color
    Set

プロパティ値

型: Color
セルのフォントカラーを表す Color 構造体。
解説
Color 構造体を使用してセルのフォントカラーを設定します。 xlsx 形式のファイルでのみ設定可能です。
例
C#
VB
コピー
// A1 セルのフォントカラーを "赤色" に設定します。
cellReport1.Cell("A1").Attr.FontColor = System.Drawing.Color.Red;
' A1 セルのフォントカラーを "赤色" に設定します。
CellReport1.Cell("A1").Attr.FontColor = System.Drawing.Color.Red
関連項目

参照

CellAttr クラス


CellAttr.FontColor2 プロパティ

CellAttrFontColor2 プロパティ

フォントカラーを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public xlColor FontColor2 { set; }
Public WriteOnly Property FontColor2 As xlColor
    Set

プロパティ値

型: xlColor
セルのフォントカラーを表す xlColor。
解説
xlColor 列挙体のメンバーを使用してセルのフォントカラーを設定します。
例
C#
VB
コピー
// A1 セルのフォントカラーを "赤色" に設定します。
cellReport1.Cell("A1").Attr.FontColor2 = AdvanceSoftware.ASReport.xlColor.Red;
' A1 セルのフォントカラーを "赤色" に設定します。
CellReport1.Cell("A1").Attr.FontColor2 = AdvanceSoftware.ASReport.xlColor.Red
関連項目

参照

CellAttr クラス


CellAttr.FontName プロパティ

CellAttrFontName プロパティ

フォント名を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string FontName { set; }
Public WriteOnly Property FontName As String
    Set

プロパティ値

型: String
セルのフォント名。
例
C#
VB
コピー
// A1 セルのフォント名を "ＭＳ 明朝" に設定します。
cellReport1.Cell("A1").Attr.FontName = "ＭＳ 明朝";
' A1 セルのフォント名を "ＭＳ 明朝" に設定します。
CellReport1.Cell("A1").Attr.FontName = "ＭＳ 明朝"
関連項目

参照

CellAttr クラス


CellAttr.FontPoint プロパティ

CellAttrFontPoint プロパティ

フォントサイズを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double FontPoint { set; }
Public WriteOnly Property FontPoint As Double
    Set

プロパティ値

型: Double
フォントサイズ(ポイント単位)。
解説
フォントサイズ(1 ～ 409 ポイント)を設定します。
例
C#
VB
コピー
// A1 セルのフォントサイズを "20" に設定します。
cellReport1.Cell("A1").Attr.FontPoint = 20;
' A1 セルのフォントサイズを "20" に設定します。
CellReport1.Cell("A1").Attr.FontPoint = 20
関連項目

参照

CellAttr クラス


CellAttr.FontStyle プロパティ

CellAttrFontStyle プロパティ

フォントスタイルを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public FontStyle FontStyle { set; }
Public WriteOnly Property FontStyle As FontStyle
    Set

プロパティ値

型: FontStyle
フォントスタイルを表す FontStyle。
例
C#
VB
コピー
// A1 セルのフォントスタイルを "太字" に設定します。
cellReport1.Cell("A1").Attr.FontStyle = AdvanceSoftware.ASReport.FontStyle.Bold;
// B1 セルのフォントスタイルを "太字、打消し線" に設定します。
cellReport1.Cell("B1").Attr.FontStyle = AdvanceSoftware.ASReport.FontStyle.Bold | AdvanceSoftware.ASReport.FontStyle.Strike;
' A1 セルのフォントスタイルを "太字" に設定します。
CellReport1.Cell("A1").Attr.FontStyle = AdvanceSoftware.ASReport.FontStyle.Bold
' B1 セルのフォントスタイルを "太字、打消し線" に設定します。
CellReport1.Cell("A1").Attr.FontStyle = AdvanceSoftware.ASReport.FontStyle.Bold Or AdvanceSoftware.ASReport.FontStyle.Strike
関連項目

参照

CellAttr クラス


CellAttr.FontULine プロパティ

CellAttrFontULine プロパティ

フォント下線を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public FontULine FontULine { set; }
Public WriteOnly Property FontULine As FontULine
    Set

プロパティ値

型: FontULine
セルのフォントの下線を表す FontULine。
例
C#
VB
コピー
// A1 セルのフォント下線を "標準" に設定します。
cellReport1.Cell("A1").Attr.FontULine = AdvanceSoftware.ASReport.FontULine.Normal;
' A1 セルのフォント下線を "標準" に設定します。
CellReport1.Cell("A1").Attr.FontULine = AdvanceSoftware.ASReport.FontULine.Normal
関連項目

参照

CellAttr クラス


CellAttr.ForeColor プロパティ

CellAttrForeColor プロパティ

前景色を設定します。(xlsx 形式のみ)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color ForeColor { set; }
Public WriteOnly Property ForeColor As Color
    Set

プロパティ値

型: Color
セルのパターンの前景色を表す Color 構造体。
解説
Color 構造体を使用してセルのパターンの前景色を設定します。 xlsx 形式のファイルでのみ設定可能です。
例
C#
VB
コピー
// A1 セルのパターンを "横 縞" に設定します。
cellReport1.Cell("A1").Attr.Pattern = AdvanceSoftware.ASReport.Pattern.DarkHorizontal;
// A1 セルの前景色を "赤色" に設定します。
cellReport1.Cell("A1").Attr.ForeColor = System.Drawing.Color.Red;
' A1 セルのパターンを "横 縞" に設定します。
CellReport1.Cell("A1").Attr.Pattern = AdvanceSoftware.ASReport.Pattern.DarkHorizontal
' A1 セルの前景色を "赤色" に設定します。
CellReport1.Cell("A1").Attr.ForeColor = System.Drawing.Color.Red
関連項目

参照

CellAttr クラス


CellAttr.ForeColor2 プロパティ

CellAttrForeColor2 プロパティ

前景色を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public xlColor ForeColor2 { set; }
Public WriteOnly Property ForeColor2 As xlColor
    Set

プロパティ値

型: xlColor
セルのパターンの前景色を表す xlColor。
解説
xlColor 列挙体のメンバーを使用してセルのパターンの前景色を設定します。
例
C#
VB
コピー
// A1 セルのパターンを "横 縞" に設定します。
cellReport1.Cell("A1").Attr.Pattern = AdvanceSoftware.ASReport.Pattern.DarkHorizontal;
// A1 セルの前景色を "赤色" に設定します。
cellReport1.Cell("A1").Attr.ForeColor2 = AdvanceSoftware.ASReport.xlColor.Red;
' A1 セルのパターンを "横 縞" に設定します。
CellReport1.Cell("A1").Attr.Pattern = AdvanceSoftware.ASReport.Pattern.DarkHorizontal
' A1 セルの前景色を "赤色" に設定します。
CellReport1.Cell("A1").Attr.ForeColor2 = AdvanceSoftware.ASReport.xlColor.Red
関連項目

参照

CellAttr クラス


CellAttr.Format プロパティ

CellAttrFormat プロパティ

表示書式を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Format { set; }
Public WriteOnly Property Format As String
    Set

プロパティ値

型: String
セルの書式を表す文字列。
解説
以下の記号を使用してセルの表示形式を設定します。
記号 | 説明
# | 有効桁数のみ表示します。(ゼロは表示しません)
0(ゼロ) | 数値の桁数が設定したゼロの数よりも少ない場合、ゼロが余分に表示されます。
? | 数値を小数点位置で揃えたり、分数であらわす場合に除算記号で揃えるように表示します。
,(カンマ) | 1000 単位の区切り記号として表示したり、数値を 1000 で割って四捨五入して表示します。
% | 数値に 100 を掛けてパーセント文字を追加して表示します。
@ | 文字列として表示します。
_(アンダーバー) | 文字幅分の間隔を空けて表示します。
*(アスタリスク) | 設定した文字をセル幅に達するまで繰り返し表示します。* に続けて繰り返し表示する記号を設定します。
[色] | 表示形式で色を設定するのに角カッコ ([]) で色を囲んで設定します。色コードは、書式部分の先頭に設定する必要があります。色には、黒、青、水、緑、紫、赤、白、黄を設定することができます。
yy | (年)00 ～ 99
yyyy | (年) 1900 ～ 9999
m | (月) 1 ～ 12
mm | (月) 01 ～ 12
mmmm | (月) January ～ December
mmmmm | (月) J ～ D (月の頭文字)
d | (日) 1 ～ 31
dd | (日) 01 ～ 31
ddd | (日) Sun ～ Sat
dddd | (日) Sunday ～ Saturday
h | (時) 0 ～ 23
hh | (時) 00 ～ 23
m | (分) 0 ～ 59
mm | (分) 00 ～ 59
s | (秒) 0 ～ 59
ss | (秒) 00 ～ 59
h AM/PM | (時) 0 ～ 23 AM/PM (AM,PM は時間によりかわる)
h:m:s am/pm | (時) 0 ～ 23: (分) 0～59: (秒) 0～59 am/pm
例
C#
VB
コピー
// A1 セルの表示形式を "yyyy/m/d" に設定します。
cellReport1.Cell("A1").Attr.Format = "yyyy/m/d";
// A1 セルに日付 "2022/1/1" を設定します。
cellReport1.Cell("A1").Value = Convert.ToDateTime("2022/1/1").ToOADate();
' A1 セルの表示形式を "yyyy/m/d" に設定します。
CellReport1.Cell("A1").Attr.Format = "yyyy/m/d"
' A1 セルに日付 "2022/1/1" を設定します。
CellReport1.Cell("A1").Value = Convert.ToDateTime("2022/1/1").ToOADate()
関連項目

参照

CellAttr クラス


CellAttr.HorizontalAlignment プロパティ

CellAttrHorizontalAlignment プロパティ

文字の配置の横位置を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public HorizontalAlignment HorizontalAlignment { set; }
Public WriteOnly Property HorizontalAlignment As HorizontalAlignment
    Set

プロパティ値

型: HorizontalAlignment
セルの文字の横位置を表す HorizontalAlignment。
例
C#
VB
コピー
// A1 セルのデータの横位置を "中央揃え" に設定します。
cellReport1.Cell("A1").Attr.HorizontalAlignment = AdvanceSoftware.ASReport.HorizontalAlignment.Center;
' A1 セルのデータの横位置を "中央揃え" に設定します。
CellReport1.Cell("A1").Attr.HorizontalAlignment = AdvanceSoftware.ASReport.HorizontalAlignment.Center
関連項目

参照

CellAttr クラス


CellAttr.Locked プロパティ

CellAttrLocked プロパティ

セルのロックを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool Locked { get; set; }
Public Property Locked As Boolean
    Get
    Set

プロパティ値

型: Boolean
セルをロックする場合は true。
例
C#
VB
コピー
// A1 セルのロックを解除します。
cellReport1.Cell("A1").Attr.Locked = false;
' A1 セルのロックを解除します。
CellReport1.Cell("A1").Attr.Locked = False
関連項目

参照

CellAttr クラス


CellAttr.MergeCells プロパティ

CellAttrMergeCells プロパティ

セルの結合を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool MergeCells { set; }
Public WriteOnly Property MergeCells As Boolean
    Set

プロパティ値

型: Boolean
セルを結合する場合は true。
例
C#
VB
コピー
// A1 セルと B1 セルを結合します。
cellReport1.Cell("A1:B1").Attr.MergeCells = true;
' A1 セルと B1 セルを結合します。
CellReport1.Cell("A1:B1").Attr.MergeCells = True
関連項目

参照

CellAttr クラス


CellAttr.Orientation プロパティ

CellAttrOrientation プロパティ

文字の配置の回転を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Orientation Orientation { set; }
Public WriteOnly Property Orientation As Orientation
    Set

プロパティ値

型: Orientation
セルの文字の配置の回転方向を表す Orientation。
例
C#
VB
コピー
// A1 セルの文字方向を "縦書き" に設定します。
cellReport1.Cell("A1").Attr.Orientation = AdvanceSoftware.ASReport.Orientation.Vert;
' A1 セルの文字方向を "縦書き" に設定します。
CellReport1.Cell("A1").Attr.Orientation = AdvanceSoftware.ASReport.Orientation.Vert
関連項目

参照

CellAttr クラス


CellAttr.Pattern プロパティ

CellAttrPattern プロパティ

パターンを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Pattern Pattern { set; }
Public WriteOnly Property Pattern As Pattern
    Set

プロパティ値

型: Pattern
セルのパターンを表す Pattern。
例
C#
VB
コピー
// A1 セルのパターンを "横 縞" に設定します。
cellReport1.Cell("A1").Attr.Pattern = AdvanceSoftware.ASReport.Pattern.DarkHorizontal;
// A1 セルの前景色を "赤色" に設定します。
cellReport1.Cell("A1").Attr.ForeColor = System.Drawing.Color.Red;
' A1 セルのパターンを "横 縞" に設定します。
CellReport1.Cell("A1").Attr.Pattern = AdvanceSoftware.ASReport.Pattern.DarkHorizontal
' A1 セルの前景色を "赤色" に設定します。
CellReport1.Cell("A1").Attr.ForeColor = System.Drawing.Color.Red
関連項目

参照

CellAttr クラス


CellAttr.ShrinkToFit プロパティ

CellAttrShrinkToFit プロパティ

縮小して全体を表示を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShrinkToFit { set; }
Public WriteOnly Property ShrinkToFit As Boolean
    Set

プロパティ値

型: Boolean
縮小して全体を表示する場合は true。
例
C#
VB
コピー
// A1 セルのデータを縮小して全体を表示します。
cellReport1.Cell("A1").Attr.ShrinkToFit = true;
' A1 セルのデータを縮小して全体を表示します。
CellReport1.Cell("A1").Attr.ShrinkToFit = True
関連項目

参照

CellAttr クラス


CellAttr.VerticalAlignment プロパティ

CellAttrVerticalAlignment プロパティ

文字の配置の縦位置を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public VerticalAlignment VerticalAlignment { set; }
Public WriteOnly Property VerticalAlignment As VerticalAlignment
    Set

プロパティ値

型: VerticalAlignment
セルの文字の縦位置を表す VerticalAlignment。
例
C#
VB
コピー
// A1 セルのデータの縦位置を "中央揃え" に設定します。
cellReport1.Cell("A1").Attr.VerticalAlignment = AdvanceSoftware.ASReport.VerticalAlignment.Center;
' A1 セルのデータの縦位置を "中央揃え" に設定します。
CellReport1.Cell("A1").Attr.VerticalAlignment = AdvanceSoftware.ASReport.VerticalAlignment.Center
関連項目

参照

CellAttr クラス


CellAttr.WrapText プロパティ

CellAttrWrapText プロパティ

折り返して全体を表示を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool WrapText { set; }
Public WriteOnly Property WrapText As Boolean
    Set

プロパティ値

型: Boolean
折り返して全体を表示する場合は true。
例
C#
VB
コピー
// A1 セルのデータを折り返して全体を表示します。
cellReport1.Cell("A1").Attr.WrapText = true;
' A1 セルのデータを折り返して全体を表示します。
CellReport1.Cell("A1").Attr.WrapText = True
関連項目

参照

CellAttr クラス


CellAttr メソッド

メソッド
名前 | 説明
Box(BoxType, BorderStyle, xlColor) | Box 罫線を設定します。
Box(BoxType, BorderStyle, Color) | Box 罫線を設定します。(xlsx 形式のみ)
LineBottom(BorderStyle, xlColor) | 下罫線を設定します。
LineBottom(BorderStyle, Color) | 下罫線を設定します。(xlsx 形式のみ)
LineLeft(BorderStyle, xlColor) | 左罫線を設定します。
LineLeft(BorderStyle, Color) | 左罫線を設定します。(xlsx 形式のみ)
LineLeftUp(BorderStyle, xlColor) | 左上がり罫線を設定します。
LineLeftUp(BorderStyle, Color) | 左上がり罫線を設定します。(xlsx 形式のみ)
LineRight(BorderStyle, xlColor) | 右罫線を設定します。
LineRight(BorderStyle, Color) | 右罫線を設定します。(xlsx 形式のみ)
LineRightUp(BorderStyle, xlColor) | 右上がり罫線を設定します。
LineRightUp(BorderStyle, Color) | 右上がり罫線を設定します。(xlsx 形式のみ)
LineTop(BorderStyle, xlColor) | 上罫線を設定します。
LineTop(BorderStyle, Color) | 上罫線を設定します。(xlsx 形式のみ)
トップ
関連項目

参照

CellAttr クラス


CellAttr.Box メソッド

CellAttrBox メソッド

オーバーロードの一覧
名前 | 説明
Box(BoxType, BorderStyle, xlColor) | Box 罫線を設定します。
Box(BoxType, BorderStyle, Color) | Box 罫線を設定します。(xlsx 形式のみ)
トップ
関連項目

参照

CellAttr クラス


CellAttr.Box メソッド (BoxType, BorderStyle, xlColor)

CellAttrBox メソッド (BoxType, BorderStyle, xlColor)

Box 罫線を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Box(
    BoxType boxType,
    BorderStyle borderStyle,
    xlColor borderColor
)
Public Sub Box (
    boxType As BoxType,
    borderStyle As BorderStyle,
    borderColor As xlColor
)

パラメーター

boxType
型: AdvanceSoftware.ASReportBoxType
Box タイプを設定します。
borderStyle
型: AdvanceSoftware.ASReportBorderStyle
線種を設定します。
borderColor
型: AdvanceSoftware.ASReportxlColor
線の色を設定します。
例
C#
VB
コピー
// A1:E5 セルに "Box 罫線 (Box タイプ：格子線、線種：実線、線色：黒)" を設定します。
cellReport1.Cell("A1:E5").Attr.Box(AdvanceSoftware.ASReport.BoxType.Ltc, AdvanceSoftware.ASReport.BorderStyle.Thin, AdvanceSoftware.ASReport.xlColor.Black);
' A1:E5 セルに "Box 罫線 (Box タイプ：格子線、線種：実線、線色：黒)" を設定します。
CellReport1.Cell("A1:E5").Attr.Box(AdvanceSoftware.ASReport.BoxType.Ltc, AdvanceSoftware.ASReport.BorderStyle.Thin, AdvanceSoftware.ASReport.xlColor.Black)
関連項目

参照

CellAttr クラス
Box オーバーロード


CellAttr.Box メソッド (BoxType, BorderStyle, Color)

CellAttrBox メソッド (BoxType, BorderStyle, Color)

Box 罫線を設定します。(xlsx 形式のみ)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Box(
    BoxType boxType,
    BorderStyle borderStyle,
    Color borderColor
)
Public Sub Box (
    boxType As BoxType,
    borderStyle As BorderStyle,
    borderColor As Color
)

パラメーター

boxType
型: AdvanceSoftware.ASReportBoxType
Box タイプを設定します。
borderStyle
型: AdvanceSoftware.ASReportBorderStyle
線種を設定します。
borderColor
型: System.DrawingColor
線の色を設定します。
解説
xlsx 形式のファイルでのみ設定可能です。
例
C#
VB
コピー
// A1:E5 セルに Box 罫線（Box タイプ：格子線、線種：実線、線色：黒）を設定します。
cellReport1.Cell("A1:E5").Attr.Box(AdvanceSoftware.ASReport.BoxType.Ltc, AdvanceSoftware.ASReport.BorderStyle.Thin, System.Drawing.Color.Black);
' A1:E5 セルに Box 罫線（Box タイプ：格子線、線種：実線、線色：黒）を設定します。
CellReport1.Cell("A1:E5").Attr.Box(AdvanceSoftware.ASReport.BoxType.Ltc, AdvanceSoftware.ASReport.BorderStyle.Thin, System.Drawing.Color.Black)
関連項目

参照

CellAttr クラス
Box オーバーロード


CellAttr.LineBottom メソッド

CellAttrLineBottom メソッド

オーバーロードの一覧
名前 | 説明
LineBottom(BorderStyle, xlColor) | 下罫線を設定します。
LineBottom(BorderStyle, Color) | 下罫線を設定します。(xlsx 形式のみ)
トップ
関連項目

参照

CellAttr クラス


CellAttr.LineBottom メソッド (BorderStyle, xlColor)

CellAttrLineBottom メソッド (BorderStyle, xlColor)

下罫線を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineBottom(
    BorderStyle borderStyle,
    xlColor borderColor
)
Public Sub LineBottom (
    borderStyle As BorderStyle,
    borderColor As xlColor
)

パラメーター

borderStyle
型: AdvanceSoftware.ASReportBorderStyle
線種を設定します。
borderColor
型: AdvanceSoftware.ASReportxlColor
線の色を設定します。
例
C#
VB
コピー
// A1:E5 セルに "下罫線 (線種：実線、線色：黒)" を設定します。
cellReport1.Cell("A1:E5").Attr.LineBottom(AdvanceSoftware.ASReport.BorderStyle.Thin, AdvanceSoftware.ASReport.xlColor.Black);
' A1:E5 セルに "下罫線 (線種：実線、線色：黒)" を設定します。
CellReport1.Cell("A1:E5").Attr.LineBottom(AdvanceSoftware.ASReport.BorderStyle.Thin, AdvanceSoftware.ASReport.xlColor.Black)
関連項目

参照

CellAttr クラス
LineBottom オーバーロード


CellAttr.LineBottom メソッド (BorderStyle, Color)

CellAttrLineBottom メソッド (BorderStyle, Color)

下罫線を設定します。(xlsx 形式のみ)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineBottom(
    BorderStyle borderStyle,
    Color borderColor
)
Public Sub LineBottom (
    borderStyle As BorderStyle,
    borderColor As Color
)

パラメーター

borderStyle
型: AdvanceSoftware.ASReportBorderStyle
線種を設定します。
borderColor
型: System.DrawingColor
線の色を設定します。
解説
xlsx 形式のファイルでのみ設定可能です。
例
C#
VB
コピー
// A1:E5 セルに "下罫線 (線種：実線、線色：黒)" を設定します。
cellReport1.Cell("A1:E5").Attr.LineBottom(AdvanceSoftware.ASReport.BorderStyle.Thin, System.Drawing.Color.Black);
' A1:E5 セルに "下罫線 (線種：実線、線色：黒)" を設定します。
CellReport1.Cell("A1:E5").Attr.LineBottom(AdvanceSoftware.ASReport.BorderStyle.Thin, System.Drawing.Color.Black)
関連項目

参照

CellAttr クラス
LineBottom オーバーロード


CellAttr.LineLeft メソッド

CellAttrLineLeft メソッド

オーバーロードの一覧
名前 | 説明
LineLeft(BorderStyle, xlColor) | 左罫線を設定します。
LineLeft(BorderStyle, Color) | 左罫線を設定します。(xlsx 形式のみ)
トップ
関連項目

参照

CellAttr クラス


CellAttr.LineLeft メソッド (BorderStyle, xlColor)

CellAttrLineLeft メソッド (BorderStyle, xlColor)

左罫線を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineLeft(
    BorderStyle borderStyle,
    xlColor borderColor
)
Public Sub LineLeft (
    borderStyle As BorderStyle,
    borderColor As xlColor
)

パラメーター

borderStyle
型: AdvanceSoftware.ASReportBorderStyle
線種を設定します。
borderColor
型: AdvanceSoftware.ASReportxlColor
線の色を設定します。
例
C#
VB
コピー
// A1:E5 セルに "左罫線 (線種：実線、線色：黒)" を設定します。
cellReport1.Cell("A1:E5").Attr.LineLeft(AdvanceSoftware.ASReport.BorderStyle.Thin, AdvanceSoftware.ASReport.xlColor.Black);
' A1:E5 セルに "左罫線 (線種：実線、線色：黒)" を設定します。
CellReport1.Cell("A1:E5").Attr.LineLeft(AdvanceSoftware.ASReport.BorderStyle.Thin, AdvanceSoftware.ASReport.xlColor.Black)
関連項目

参照

CellAttr クラス
LineLeft オーバーロード


CellAttr.LineLeft メソッド (BorderStyle, Color)

CellAttrLineLeft メソッド (BorderStyle, Color)

左罫線を設定します。(xlsx 形式のみ)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineLeft(
    BorderStyle borderStyle,
    Color borderColor
)
Public Sub LineLeft (
    borderStyle As BorderStyle,
    borderColor As Color
)

パラメーター

borderStyle
型: AdvanceSoftware.ASReportBorderStyle
線種を設定します。
borderColor
型: System.DrawingColor
線の色を設定します。
解説
xlsx 形式のファイルでのみ設定可能です。
例
C#
VB
コピー
// A1:E5 セルに "左罫線 (線種：実線、線色：黒)" を設定します。
cellReport1.Cell("A1:E5").Attr.LineLeft(AdvanceSoftware.ASReport.BorderStyle.Thin, System.Drawing.Color.Black);
' A1:E5 セルに "左罫線 (線種：実線、線色：黒)" を設定します。
CellReport1.Cell("A1:E5").Attr.LineLeft(AdvanceSoftware.ASReport.BorderStyle.Thin, System.Drawing.Color.Black)
関連項目

参照

CellAttr クラス
LineLeft オーバーロード


CellAttr.LineLeftUp メソッド

CellAttrLineLeftUp メソッド

オーバーロードの一覧
名前 | 説明
LineLeftUp(BorderStyle, xlColor) | 左上がり罫線を設定します。
LineLeftUp(BorderStyle, Color) | 左上がり罫線を設定します。(xlsx 形式のみ)
トップ
関連項目

参照

CellAttr クラス


CellAttr.LineLeftUp メソッド (BorderStyle, xlColor)

CellAttrLineLeftUp メソッド (BorderStyle, xlColor)

左上がり罫線を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineLeftUp(
    BorderStyle borderStyle,
    xlColor borderColor
)
Public Sub LineLeftUp (
    borderStyle As BorderStyle,
    borderColor As xlColor
)

パラメーター

borderStyle
型: AdvanceSoftware.ASReportBorderStyle
線種を設定します。
borderColor
型: AdvanceSoftware.ASReportxlColor
線の色を設定します。
例
C#
VB
コピー
// A1:E5 セルに "左上がり罫線 (線種：実線、線色：黒)" を設定します。
cellReport1.Cell("A1:E5").Attr.LineLeftUp(AdvanceSoftware.ASReport.BorderStyle.Thin, AdvanceSoftware.ASReport.xlColor.Black);
' A1:E5 セルに "左上がり罫線 (線種：実線、線色：黒)" を設定します。
CellReport1.Cell("A1:E5").Attr.LineLeftUp(AdvanceSoftware.ASReport.BorderStyle.Thin, AdvanceSoftware.ASReport.xlColor.Black)
関連項目

参照

CellAttr クラス
LineLeftUp オーバーロード


CellAttr.LineLeftUp メソッド (BorderStyle, Color)

CellAttrLineLeftUp メソッド (BorderStyle, Color)

左上がり罫線を設定します。(xlsx 形式のみ)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineLeftUp(
    BorderStyle borderStyle,
    Color borderColor
)
Public Sub LineLeftUp (
    borderStyle As BorderStyle,
    borderColor As Color
)

パラメーター

borderStyle
型: AdvanceSoftware.ASReportBorderStyle
線種を設定します。
borderColor
型: System.DrawingColor
線の色を設定します。
解説
xlsx 形式のファイルでのみ設定可能です。
例
C#
VB
コピー
// A1:E5 セルに "左上がり罫線 (線種：実線、線色：黒)" を設定します。
cellReport1.Cell("A1:E5").Attr.LineLeftUp(AdvanceSoftware.ASReport.BorderStyle.Thin, System.Drawing.Color.Black);
' A1:E5 セルに "左上がり罫線 (線種：実線、線色：黒)" を設定します。
CellReport1.Cell("A1:E5").Attr.LineLeftUp(AdvanceSoftware.ASReport.BorderStyle.Thin, System.Drawing.Color.Black)
関連項目

参照

CellAttr クラス
LineLeftUp オーバーロード


CellAttr.LineRight メソッド

CellAttrLineRight メソッド

オーバーロードの一覧
名前 | 説明
LineRight(BorderStyle, xlColor) | 右罫線を設定します。
LineRight(BorderStyle, Color) | 右罫線を設定します。(xlsx 形式のみ)
トップ
関連項目

参照

CellAttr クラス


CellAttr.LineRight メソッド (BorderStyle, xlColor)

CellAttrLineRight メソッド (BorderStyle, xlColor)

右罫線を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineRight(
    BorderStyle borderStyle,
    xlColor borderColor
)
Public Sub LineRight (
    borderStyle As BorderStyle,
    borderColor As xlColor
)

パラメーター

borderStyle
型: AdvanceSoftware.ASReportBorderStyle
線種を設定します。
borderColor
型: AdvanceSoftware.ASReportxlColor
線の色を設定します。
例
C#
VB
コピー
// A1:E5 セルに "右罫線 (線種：実線、線色：黒)" を設定します。
cellReport1.Cell("A1:E5").Attr.LineRight(AdvanceSoftware.ASReport.BorderStyle.Thin, AdvanceSoftware.ASReport.xlColor.Black);
' A1:E5 セルに "右罫線 (線種：実線、線色：黒)" を設定します。
CellReport1.Cell("A1:E5").Attr.LineRight(AdvanceSoftware.ASReport.BorderStyle.Thin, AdvanceSoftware.ASReport.xlColor.Black)
関連項目

参照

CellAttr クラス
LineRight オーバーロード


CellAttr.LineRight メソッド (BorderStyle, Color)

CellAttrLineRight メソッド (BorderStyle, Color)

右罫線を設定します。(xlsx 形式のみ)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineRight(
    BorderStyle borderStyle,
    Color borderColor
)
Public Sub LineRight (
    borderStyle As BorderStyle,
    borderColor As Color
)

パラメーター

borderStyle
型: AdvanceSoftware.ASReportBorderStyle
線種を設定します。
borderColor
型: System.DrawingColor
線の色を設定します。
解説
xlsx 形式のファイルでのみ設定可能です。
例
C#
VB
コピー
// A1:E5 セルに "右罫線 (線種：実線、線色：黒)" を設定します。
cellReport1.Cell("A1:E5").Attr.LineRight(AdvanceSoftware.ASReport.BorderStyle.Thin, System.Drawing.Color.Black);
' A1:E5 セルに "右罫線 (線種：実線、線色：黒)"を設定します。
CellReport1.Cell("A1:E5").Attr.LineRight(AdvanceSoftware.ASReport.BorderStyle.Thin, System.Drawing.Color.Black)
関連項目

参照

CellAttr クラス
LineRight オーバーロード


CellAttr.LineRightUp メソッド

CellAttrLineRightUp メソッド

オーバーロードの一覧
名前 | 説明
LineRightUp(BorderStyle, xlColor) | 右上がり罫線を設定します。
LineRightUp(BorderStyle, Color) | 右上がり罫線を設定します。(xlsx 形式のみ)
トップ
関連項目

参照

CellAttr クラス


CellAttr.LineRightUp メソッド (BorderStyle, xlColor)

CellAttrLineRightUp メソッド (BorderStyle, xlColor)

右上がり罫線を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineRightUp(
    BorderStyle borderStyle,
    xlColor borderColor
)
Public Sub LineRightUp (
    borderStyle As BorderStyle,
    borderColor As xlColor
)

パラメーター

borderStyle
型: AdvanceSoftware.ASReportBorderStyle
線種を設定します。
borderColor
型: AdvanceSoftware.ASReportxlColor
線の色を設定します。
例
C#
VB
コピー
// A1:E5 セルに "右上がり罫線 (線種：実線、線色：黒)" を設定します。
cellReport1.Cell("A1:E5").Attr.LineRightUp(AdvanceSoftware.ASReport.BorderStyle.Thin, AdvanceSoftware.ASReport.xlColor.Black);
' A1:E5 セルに "右上がり罫線 (線種：実線、線色：黒)" を設定します。
CellReport1.Cell("A1:E5").Attr.LineRightUp(AdvanceSoftware.ASReport.BorderStyle.Thin, AdvanceSoftware.ASReport.xlColor.Black)
関連項目

参照

CellAttr クラス
LineRightUp オーバーロード


CellAttr.LineRightUp メソッド (BorderStyle, Color)

CellAttrLineRightUp メソッド (BorderStyle, Color)

右上がり罫線を設定します。(xlsx 形式のみ)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineRightUp(
    BorderStyle borderStyle,
    Color borderColor
)
Public Sub LineRightUp (
    borderStyle As BorderStyle,
    borderColor As Color
)

パラメーター

borderStyle
型: AdvanceSoftware.ASReportBorderStyle
線種を設定します。
borderColor
型: System.DrawingColor
線の色を設定します。
解説
xlsx 形式のファイルでのみ設定可能です。
例
C#
VB
コピー
// A1:E5 セルに "右上がり罫線 (線種：実線、線色：黒)" を設定します。
cellReport1.Cell("A1:E5").Attr.LineRightUp(AdvanceSoftware.ASReport.BorderStyle.Thin, System.Drawing.Color.Black);
' A1:E5 セルに "右上がり罫線 (線種：実線、線色：黒)" を設定します。
CellReport1.Cell("A1:E5").Attr.LineRightUp(AdvanceSoftware.ASReport.BorderStyle.Thin, System.Drawing.Color.Black)
関連項目

参照

CellAttr クラス
LineRightUp オーバーロード


CellAttr.LineTop メソッド

CellAttrLineTop メソッド

オーバーロードの一覧
名前 | 説明
LineTop(BorderStyle, xlColor) | 上罫線を設定します。
LineTop(BorderStyle, Color) | 上罫線を設定します。(xlsx 形式のみ)
トップ
関連項目

参照

CellAttr クラス


CellAttr.LineTop メソッド (BorderStyle, xlColor)

CellAttrLineTop メソッド (BorderStyle, xlColor)

上罫線を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineTop(
    BorderStyle borderStyle,
    xlColor borderColor
)
Public Sub LineTop (
    borderStyle As BorderStyle,
    borderColor As xlColor
)

パラメーター

borderStyle
型: AdvanceSoftware.ASReportBorderStyle
線種を設定します。
borderColor
型: AdvanceSoftware.ASReportxlColor
線の色を設定します。
例
C#
VB
コピー
// A1:E5 セルに "上罫線 (線種：実線、線色：黒)" を設定します。
cellReport1.Cell("A1:E5").Attr.LineTop(AdvanceSoftware.ASReport.BorderStyle.Thin, AdvanceSoftware.ASReport.xlColor.Black);
' A1:E5 セルに "上罫線 (線種：実線、線色：黒)" を設定します。
CellReport1.Cell("A1:E5").Attr.LineTop(AdvanceSoftware.ASReport.BorderStyle.Thin, AdvanceSoftware.ASReport.xlColor.Black)
関連項目

参照

CellAttr クラス
LineTop オーバーロード


CellAttr.LineTop メソッド (BorderStyle, Color)

CellAttrLineTop メソッド (BorderStyle, Color)

上罫線を設定します。(xlsx 形式のみ)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void LineTop(
    BorderStyle borderStyle,
    Color borderColor
)
Public Sub LineTop (
    borderStyle As BorderStyle,
    borderColor As Color
)

パラメーター

borderStyle
型: AdvanceSoftware.ASReportBorderStyle
線種を設定します。
borderColor
型: System.DrawingColor
線の色を設定します。
解説
xlsx 形式のファイルでのみ設定可能です。
例
C#
VB
コピー
// A1:E5 セルに "上罫線 (線種：実線、線色：黒)" を設定します。
cellReport1.Cell("A1:E5").Attr.LineTop(AdvanceSoftware.ASReport.BorderStyle.Thin, System.Drawing.Color.Black);
' A1:E5 セルに "上罫線 (線種：実線、線色：黒)" を設定します。
CellReport1.Cell("A1:E5").Attr.LineTop(AdvanceSoftware.ASReport.BorderStyle.Thin, System.Drawing.Color.Black)
関連項目

参照

CellAttr クラス
LineTop オーバーロード


CellCanvas クラス

帳票にイメージファイルや図形を設定します。 このクラスで設定したイメージファイルや図形は Excel ファイルに反映されません。 レポートコンポーネントを通じてこのクラスにアクセスします。
継承階層
SystemObject
AdvanceSoftware.ASReportCellCanvas

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class CellCanvas
Public Class CellCanvas

CellCanvas 型は下記のメンバーを公開します。

メソッド
名前 | 説明
AddChart | グラフを設定します。
AddImage(Image) | イメージを設定します。
AddImage(String) | イメージを設定します。
AddImage(Image, Double, Double) | イメージを設定します。
AddImage(String, Double, Double) | イメージを設定します。
AddImage(Image, Double, Double, Double, Double) | イメージを設定します。
AddImage(String, Double, Double, Double, Double) | イメージを設定します。
トップ
関連項目

参照


CellCanvas メソッド

CellCanvas 型は下記のメンバーを公開します。

メソッド
名前 | 説明
AddChart | グラフを設定します。
AddImage(Image) | イメージを設定します。
AddImage(String) | イメージを設定します。
AddImage(Image, Double, Double) | イメージを設定します。
AddImage(String, Double, Double) | イメージを設定します。
AddImage(Image, Double, Double, Double, Double) | イメージを設定します。
AddImage(String, Double, Double, Double, Double) | イメージを設定します。
トップ
関連項目

参照

CellCanvas クラス


CellCanvas.AddChart メソッド

CellCanvasAddChart メソッド

グラフを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddChart(
    Image image,
    ChartData chartData
)
Public Sub AddChart (
    image As Image,
    chartData As ChartData
)

パラメーター

image
型: System.DrawingImage
イメージクラスを設定します。
chartData
型: AdvanceSoftware.Charting.PropertiesChartData
追加するグラフ情報を設定します。
例
C#
VB
コピー
// グラフの数を取得
int chartCount = cellReport1.GetChartCount();
for (int i = 0; i < chartCount; i++)
{
    // グラフ情報を取得
    ChartData chartData = cellReport1.GetChartData(i, 330);
    // ChartData からの Image オブジェクト生成処理は
    // 独自に実装する必要があります。
    // 画像は Excel 保存以外で反映されます。
    Image chartImage = ChartCreator.GetChartImage(chartData);
    cellReport1.Pos(chartData.col, chartData.row).Canvas.AddChart(chartImage, chartData);
}
' グラフの数を取得
Dim chartCount As Integer = CellReport1.GetChartCount()
For i = 0 To chartCount - 1
    ' グラフ情報を取得
    Dim chartData As ChartData = CellReport1.GetChartData(i, 330)
    ' ChartData からの Image オブジェクト生成処理は
    ' 独自に実装する必要があります。
    ' 画像は Excel 保存以外で反映されます。
    Dim chartImage As Image = ChartCreator.GetChartImage(chartData)
    CellReport1.Pos(chartData.col, chartData.row).Canvas.AddChart(chartImage, chartData)
Next
関連項目

参照

CellCanvas クラス


CellCanvas.AddImage メソッド

CellCanvasAddImage メソッド

オーバーロードの一覧
名前 | 説明
AddImage(Image) | イメージを設定します。
AddImage(String) | イメージを設定します。
AddImage(Image, Double, Double) | イメージを設定します。
AddImage(String, Double, Double) | イメージを設定します。
AddImage(Image, Double, Double, Double, Double) | イメージを設定します。
AddImage(String, Double, Double, Double, Double) | イメージを設定します。
トップ
関連項目

参照

CellCanvas クラス


CellCanvas.AddImage メソッド (Image)

CellCanvasAddImage メソッド (Image)

イメージを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    Image image
)
Public Sub AddImage (
    image As Image
)

パラメーター

image
型: System.DrawingImage
イメージクラスを設定します。
例
C#
VB
コピー
System.Drawing.Image image = System.Drawing.Image.FromFile(@"C:\image.bmp");
// A1 セルに画像を設定します。
// 画像は Excel 保存以外で反映されます。
cellReport1.Cell("A1").Canvas.AddImage(image);
Dim image As System.Drawing.Image = System.Drawing.Image.FromFile("C:\image.bmp")
' A1 セルに画像を設定します。
' 画像は Excel 保存以外で反映されます。
CellReport1.Cell("A1").Canvas.AddImage(image)
関連項目

参照

CellCanvas クラス
AddImage オーバーロード


CellCanvas.AddImage メソッド (String)

CellCanvasAddImage メソッド (String)

イメージを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    string fileName
)
Public Sub AddImage (
    fileName As String
)

パラメーター

fileName
型: SystemString
イメージのファイル名を設定します。
例
C#
VB
コピー
// A1 セルに画像を設定します。
// 画像は Excel 保存以外で反映されます。
cellReport1.Cell("A1").Canvas.AddImage(@"C:\image.bmp");
' A1 セルに画像を設定します。
' 画像は Excel 保存以外で反映されます。
CellReport1.Cell("A1").Canvas.AddImage("C:\image.bmp")
関連項目

参照

CellCanvas クラス
AddImage オーバーロード


CellCanvas.AddImage メソッド (Image, Double, Double)

CellCanvasAddImage メソッド (Image, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    Image image,
    double offsetX,
    double offsetY
)
Public Sub AddImage (
    image As Image,
    offsetX As Double,
    offsetY As Double
)

パラメーター

image
型: System.DrawingImage
イメージクラスを設定します。
offsetX
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
offsetY
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = ScaleMode.Pixel;
System.Drawing.Image image = System.Drawing.Image.FromFile(@"C:\image.bmp");
// A1 セルを基点とし、開始オフセット (100px,100px) の位置から画像を設定します。
// 画像は Excel 保存以外で反映されます。
cellReport1.Cell("A1").Canvas.AddImage(image, 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = ScaleMode.Pixel
Dim image As System.Drawing.Image = System.Drawing.Image.FromFile("C:\image.bmp")
' A1 セルを基点とし、開始オフセット (100px,100px) の位置から画像を設定します。
' 画像は Excel 保存以外で反映されます。
CellReport1.Cell("A1").Canvas.AddImage(image, 100, 100)
関連項目

参照

CellCanvas クラス
AddImage オーバーロード


CellCanvas.AddImage メソッド (String, Double, Double)

CellCanvasAddImage メソッド (String, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    string fileName,
    double offsetX,
    double offsetY
)
Public Sub AddImage (
    fileName As String,
    offsetX As Double,
    offsetY As Double
)

パラメーター

fileName
型: SystemString
イメージのファイル名を設定します。
offsetX
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
offsetY
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = ScaleMode.Pixel;
// A1 セルを基点とし、開始オフセット (100px,100px) の位置から画像を設定します。
// 画像は Excel 保存以外で反映されます。
cellReport1.Cell("A1").Canvas.AddImage(@"C:\image.bmp", 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = ScaleMode.Pixel
' A1 セルを基点とし、開始オフセット (100px,100px) の位置から画像を設定します。
' 画像は Excel 保存以外で反映されます。
CellReport1.Cell("A1").Canvas.AddImage("C:\image.bmp", 100, 100)
関連項目

参照

CellCanvas クラス
AddImage オーバーロード


CellCanvas.AddImage メソッド (Image, Double, Double, Double, Double)

CellCanvasAddImage メソッド (Image, Double, Double, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    Image image,
    double offsetX,
    double offsetY,
    double width,
    double height
)
Public Sub AddImage (
    image As Image,
    offsetX As Double,
    offsetY As Double,
    width As Double,
    height As Double
)

パラメーター

image
型: System.DrawingImage
イメージクラスを設定します。
offsetX
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
offsetY
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
width
型: SystemDouble
イメージの幅を設定します。
height
型: SystemDouble
イメージの高さを設定します。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = ScaleMode.Pixel;
System.Drawing.Image image = System.Drawing.Image.FromFile(@"C:\image.bmp");
// A1 セルを基点とし、開始オフセット (50px,50px) の位置から画像 (幅：150px, 高さ：150px)
// を設定します。
// 画像は Excel 保存以外で反映されます。
cellReport1.Cell("A1").Canvas.AddImage(image, 50, 50, 150, 150);
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = ScaleMode.Pixel
Dim image As System.Drawing.Image = System.Drawing.Image.FromFile("C:\image.bmp")
' A1 セルを基点とし、開始オフセット (50px,50px) の位置から画像 (幅：150px, 高さ：150px)
' を設定します。
' 画像は Excel 保存以外で反映されます。
CellReport1.Cell("A1").Canvas.AddImage(image, 50, 50, 150, 150)
関連項目

参照

CellCanvas クラス
AddImage オーバーロード


CellCanvas.AddImage メソッド (String, Double, Double, Double, Double)

CellCanvasAddImage メソッド (String, Double, Double, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    string fileName,
    double offsetX,
    double offsetY,
    double width,
    double height
)
Public Sub AddImage (
    fileName As String,
    offsetX As Double,
    offsetY As Double,
    width As Double,
    height As Double
)

パラメーター

fileName
型: SystemString
イメージのファイル名を設定します。
offsetX
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
offsetY
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
width
型: SystemDouble
イメージの幅を設定します。
height
型: SystemDouble
イメージの高さを設定します。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = ScaleMode.Pixel;
// A1 セルを基点とし、開始オフセット (50px,50px) の位置から画像 (幅：150px, 高さ：150px)
// を設定します。
// 画像は Excel 保存以外で反映されます。
cellReport1.Cell("A1").Canvas.AddImage(@"C:\image.bmp", 50, 50, 150, 150);
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = ScaleMode.Pixel
' A1 セルを基点とし、開始オフセット (50px,50px) の位置から画像 (幅：150px, 高さ：150px)
' を設定します。
' 画像は Excel 保存以外で反映されます。
CellReport1.Cell("A1").Canvas.AddImage("C:\image.bmp", 50, 50, 150, 150)
関連項目

参照

CellCanvas クラス
AddImage オーバーロード


CellClearMode 列挙体

セルクリアモードを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum CellClearMode
Public Enumeration CellClearMode
メンバー
メンバー | 値 | 説明
All | 0 | 値と属性をクリアします。
Value | 1 | 値のみをクリアします。
Attr | 2 | 属性のみをクリアします。
関連項目

参照


CellReport クラス

帳票を作成するレポートコンポーネントです。
継承階層
System.ComponentModelComponent
AdvanceSoftware.ASReportCellReport

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class CellReport : Component
Public Class CellReport
    Inherits Component

CellReport 型は下記のメンバーを公開します。

コンストラクター
 | 名前 | 説明
Public メソッド | CellReport | コンストラクター
Public メソッド | CellReport(IContainer) | コンストラクター
トップ
プロパティ
 | 名前 | 説明
 | ApplyFormula | 計算式の自動計算をするかどうかを設定、取得します。
 | ApplyPrintArea | 印刷範囲を有効にするかを設定、取得します。
 | ApplyPrintTitle | 印刷タイトルを有効にするかを設定、取得します。
 | ChangeNameAddressMode | セル名位置調整フラグを設定、取得します。
 | DefaultCell | 保存時のデフォルト選択セルを設定します。
 | DefaultSheet | 保存時のデフォルト選択シートを設定します。
 | Document | ビューアに渡すための既定の Document を取得します。
 | DoubleCellValueMode | double 型の数値をセルに格納する方法を指定します。(xlsx形式のみ)
 | DoubleMode | 浮動小数点の有効桁数モードを設定、取得します。
 | ErrorMessage | エラーメッセージを取得します。
 | ErrorNo | エラーナンバーを取得します。
 | ExcelMode | Excel を使用する、しないを設定します。
 | ExcelModeType | CellReport コンポーネント単体で ExcelMode プロパティを true に設定して使用する場合の Excel の起動モードを設定します。
 | FileName | デザインファイル名を指定します。
 | Keyword | 変数名の先頭キーワード文字列を設定します。
 | OverFit | 帳票を 1 ページに収まるよう表示するかを設定します。
Public プロパティ | Page | Page を取得します。
 | PageInfo | 使用するページ情報を指定します。
Public プロパティ | Pdf | PDF ファイルのオプションを指定するための PdfOption を取得します。
 | ReleaseExcelTask | Excel オブジェクトの動作を指定します。
Public プロパティ | Report | Report を取得します。
Public プロパティ | SaveAsLowMemoryMode | ReportMode.Legacy 時における Excel (xls) ファイルの保存時の処理動作を指定します。(既定値 : false)
 | ScaleMode | スケールモードを設定、取得します。
Public プロパティ | Section | Section を取得します。
 | SheetName | 使用するシート名を指定します。
 | StreamMode | ビューアデータの保持モードを指定します。
 | TemporaryPath | 一時ファイルのパスを設定、取得します。
 | UseTwoExcelTasks | ExcelMode で使用する Excel のタスク数を指定します。
 | VarInsertMode | 変数名挿入モードを設定します。
 | VarNameMode | 変数名の設定を行う Keyword 、VarInsertMode プロパティの動作モードを指定します。
 | WaitTimeout | 同時アクセス時の待ち時間をミリ秒単位で指定します。
トップ
メソッド
名前 | 説明
Cell(String) | Cell を取得します。
Cell(String, Int32, Int32) | Cell を取得します。
ClearDocument | ドキュメントを破棄します。
ColumnClear(Int32) | 列をクリアします。
ColumnClear(Int32, Int32) | 列をクリアします。
ColumnCopy(Int32) | 列をコピーします。
ColumnCopy(Int32, Int32) | 列をコピーします。
ColumnDelete(Int32) | 列を削除します。
ColumnDelete(Int32, Int32) | 列を削除します。
ColumnInsert(Int32) | 列を挿入します。
ColumnInsert(Int32, Int32) | 列を挿入します。
ColumnInsertCopied(Int32) | コピーした列を挿入します。
ColumnInsertCopied(Int32, Int32) | コピーした列を挿入します。
ColumnPaste | コピーした列を貼り付けします。
GetChartCount | グラフの数を取得します。(xlsx形式のみ)
GetChartData | グラフ情報を取得します。(xlsx形式のみ)
GetDocument | ビューアに渡すための AS-Report ドキュメントを取得します。
GetMaxArea | データ、属性が設定されたセルの終了座標を取得します。
GetMaxArea(MaxEndPoint) | データ、属性が設定されたセルの終了座標を取得します。
GetMaxData | データが設定されたセルの終了座標を取得します。
GetMaxData(MaxEndPoint) | データが設定されたセルの終了座標を取得します。
GetNamePos | 指定したセル名の座標(0～)を取得します。
GetVarNamePos | 指定した変数名の座標(0～)を取得します。
Pos(Int32, Int32) | Cell を取得します。
Pos(Int32, Int32, Int32, Int32) | Cell を取得します。
RowClear(Int32) | 行をクリアします。
RowClear(Int32, Int32) | 行をクリアします。
RowCopy(Int32) | 行をコピーします。
RowCopy(Int32, Int32) | 行をコピーします。
RowDelete(Int32) | 行を削除します。
RowDelete(Int32, Int32) | 行を削除します。
RowInsert(Int32) | 行を挿入します。
RowInsert(Int32, Int32) | 行を挿入します。
RowInsertCopied(Int32) | コピーした行を挿入します。
RowInsertCopied(Int32, Int32) | コピーした行を挿入します。
RowPaste | コピーした行を貼り付けします。
SetLicense(Stream) | ライセンス情報を設定します。
SetLicense(String) | ライセンス情報を設定します。
TableRowDelete(Int32) | テーブル範囲に含まれる行を削除します。
TableRowDelete(Int32, Int32) | テーブル範囲に含まれる行を削除します。
TableRowInsert(Int32) | テーブル範囲に行を挿入します。
TableRowInsert(Int32, Int32) | テーブル範囲に行を挿入します。
VarCheck | 指定した変数名が存在するかをチェックします。
トップ
イベント
名前 | 説明
Error | エラー発生時に発生します。
Progress | 処理進行状況の表示時に発生します。
RunPageStart | 帳票ページ処理開始時に発生します。
RunReportStart | 帳票処理開始時に発生します。
SectionEndPage | セクションの終了時に発生します。
SectionNewPage | セクションの開始時に発生します。
トップ
関連項目

参照


CellReport コンストラクター

オーバーロードの一覧
 | 名前 | 説明
Public メソッド | CellReport | コンストラクター
Public メソッド | CellReport(IContainer) | コンストラクター
トップ
関連項目

参照

CellReport クラス


CellReport コンストラクター

コンストラクター

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public CellReport()
Public Sub New
関連項目

参照

CellReport クラス
CellReport オーバーロード


CellReport コンストラクター (IContainer)

コンストラクター

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public CellReport(
    IContainer container
)
Public Sub New (
    container As IContainer
)

パラメーター

container
型: System.ComponentModelIContainer
IContainer を指定します。
関連項目

参照

CellReport クラス
CellReport オーバーロード


CellReport プロパティ

CellReport 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
 | ApplyFormula | 計算式の自動計算をするかどうかを設定、取得します。
 | ApplyPrintArea | 印刷範囲を有効にするかを設定、取得します。
 | ApplyPrintTitle | 印刷タイトルを有効にするかを設定、取得します。
 | ChangeNameAddressMode | セル名位置調整フラグを設定、取得します。
 | DefaultCell | 保存時のデフォルト選択セルを設定します。
 | DefaultSheet | 保存時のデフォルト選択シートを設定します。
 | Document | ビューアに渡すための既定の Document を取得します。
 | DoubleCellValueMode | double 型の数値をセルに格納する方法を指定します。(xlsx形式のみ)
 | DoubleMode | 浮動小数点の有効桁数モードを設定、取得します。
 | ErrorMessage | エラーメッセージを取得します。
 | ErrorNo | エラーナンバーを取得します。
 | ExcelMode | Excel を使用する、しないを設定します。
 | ExcelModeType | CellReport コンポーネント単体で ExcelMode プロパティを true に設定して使用する場合の Excel の起動モードを設定します。
 | FileName | デザインファイル名を指定します。
 | Keyword | 変数名の先頭キーワード文字列を設定します。
 | OverFit | 帳票を 1 ページに収まるよう表示するかを設定します。
Public プロパティ | Page | Page を取得します。
 | PageInfo | 使用するページ情報を指定します。
Public プロパティ | Pdf | PDF ファイルのオプションを指定するための PdfOption を取得します。
 | ReleaseExcelTask | Excel オブジェクトの動作を指定します。
Public プロパティ | Report | Report を取得します。
Public プロパティ | SaveAsLowMemoryMode | ReportMode.Legacy 時における Excel (xls) ファイルの保存時の処理動作を指定します。(既定値 : false)
 | ScaleMode | スケールモードを設定、取得します。
Public プロパティ | Section | Section を取得します。
 | SheetName | 使用するシート名を指定します。
 | StreamMode | ビューアデータの保持モードを指定します。
 | TemporaryPath | 一時ファイルのパスを設定、取得します。
 | UseTwoExcelTasks | ExcelMode で使用する Excel のタスク数を指定します。
 | VarInsertMode | 変数名挿入モードを設定します。
 | VarNameMode | 変数名の設定を行う Keyword 、VarInsertMode プロパティの動作モードを指定します。
 | WaitTimeout | 同時アクセス時の待ち時間をミリ秒単位で指定します。
トップ
関連項目

参照

CellReport クラス


CellReport.ApplyFormula プロパティ

CellReportApplyFormula プロパティ

計算式の自動計算をするかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ApplyFormula { get; set; }
Public Property ApplyFormula As Boolean
    Get
    Set

プロパティ値

型: Boolean
計算式を自動計算する場合、true。(既定値 : true)
解説
ExcelMode なしでも計算式の再計算が可能となりますが、 処理速度が低下する場合があります。 使用可能な関数に制限があります。
例
C#
VB
コピー
// 計算式の自動計算を有効にします。
cellReport1.ApplyFormula = true;
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = 100;
cellReport1.Cell("A2").Value = 200;
// A3 セルに計算式 "=A1+A2" を設定します。
cellReport1.Cell("A3").Func("=A1+A2", null);
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SavePdf(@"C:\out1.pdf");
' 計算式の自動計算を有効にします。
CellReport1.ApplyFormula = True
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = 100
CellReport1.Cell("A2").Value = 200
' A3 セルに計算式 "=A1+A2" を設定します。
CellReport1.Cell("A3").Func("=A1+A2", vbNullString)
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SavePdf("C:\out1.pdf")
関連項目

参照

CellReport クラス


CellReport.ApplyPrintArea プロパティ

CellReportApplyPrintArea プロパティ

印刷範囲を有効にするかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ApplyPrintArea { get; set; }
Public Property ApplyPrintArea As Boolean
    Get
    Set

プロパティ値

型: Boolean
印刷範囲を有効にする場合は true。(既定値 : true)
解説
例
C#
VB
コピー
// 印刷範囲を有効にします。
cellReport1.ApplyPrintArea = true;
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start(ReportMode.Speed);
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
' 印刷範囲を有効にします。
CellReport1.ApplyPrintArea = True
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start(ReportMode.Speed)
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
関連項目

参照

CellReport クラス


CellReport.ApplyPrintTitle プロパティ

CellReportApplyPrintTitle プロパティ

印刷タイトルを有効にするかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ApplyPrintTitle { get; set; }
Public Property ApplyPrintTitle As Boolean
    Get
    Set

プロパティ値

型: Boolean
印刷タイトルを有効にする場合は true。(既定値 : true)
解説
例
C#
VB
コピー
// 印刷タイトルを有効にします。
cellReport1.ApplyPrintTitle = true;
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start(ReportMode.Speed);
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
' 印刷タイトルを有効にします。
CellReport1.ApplyPrintTitle = True
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start(ReportMode.Speed)
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
関連項目

参照

CellReport クラス


CellReport.ChangeNameAddressMode プロパティ

CellReportChangeNameAddressMode プロパティ

セル名位置調整フラグを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ChangeNameAddressMode { get; set; }
Public Property ChangeNameAddressMode As Boolean
    Get
    Set

プロパティ値

型: Boolean
行列の挿入、削除時にセル名の座標を移動する場合、true。(既定値 : true)
解説
xlsx 形式のみ。xls 形式は標準で座標移動を行います。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
// セル名の座標を移動する
cellReport1.ChangeNameAddressMode = true;
cellReport1.RowInsert(0, 1);
cellReport1.Cell("NAMAE1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
' セル名の座標を移動する
CellReport1.ChangeNameAddressMode = True
CellReport1.RowInsert(0, 1)
CellReport1.Cell("NAMAE1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

CellReport クラス


CellReport.DefaultCell プロパティ

CellReportDefaultCell プロパティ

保存時のデフォルト選択セルを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string DefaultCell { get; set; }
Public Property DefaultCell As String
    Get
    Set

プロパティ値

型: String
Excel ファイル保存時のデフォルト選択セル。
解説
Report.Start メソッドの引数 ReportMode に ReportMode.Speed を設定した場合は有効になりません。
例
C#
VB
コピー
// Excel ファイル保存時のデフォルト選択セルを A1 セルに設定します。
cellReport1.DefaultCell = "A1";
' Excel ファイル保存時のデフォルト選択セルを A1 セルに設定します。
CellReport1.DefaultCell = "A1"
関連項目

参照

CellReport クラス


CellReport.DefaultSheet プロパティ

CellReportDefaultSheet プロパティ

保存時のデフォルト選択シートを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int DefaultSheet { get; set; }
Public Property DefaultSheet As Integer
    Get
    Set

プロパティ値

型: Int32
Excel ファイル保存時のデフォルト選択シート。
解説
Report.Start メソッドの引数 ReportMode に ReportMode.Speed を設定した場合は有効になりません。
例
C#
VB
コピー
// Excel ファイル保存時のデフォルト選択シートを 1 シート目に設定します。
cellReport1.DefaultSheet = 1;
' Excel ファイル保存時のデフォルト選択シートを 1 シート目に設定します。
CellReport1.DefaultSheet = 1
関連項目

参照

CellReport クラス


CellReport.Document プロパティ

CellReportDocument プロパティ

ビューアに渡すための既定の Document を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Document Document { get; }
Public ReadOnly Property Document As Document
    Get

プロパティ値

型: Document
ビューアに渡すための既定の Document を作成するための Document クラス。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// ビューアコントロールに帳票ドキュメントを設定します。
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' ビューアコントロールに帳票ドキュメントを設定します。
ViewerControl1.Document = CellReport1.Document
関連項目

参照

CellReport クラス


CellReport.DoubleCellValueMode プロパティ

CellReportDoubleCellValueMode プロパティ

double 型の数値をセルに格納する方法を指定します。(xlsx形式のみ)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public DoubleCellValueMode DoubleCellValueMode { set; }
Public WriteOnly Property DoubleCellValueMode As DoubleCellValueMode
    Set

プロパティ値

型: DoubleCellValueMode
数値の格納方法を IEEE754-2008 準拠に設定する場合、DoubleCellValueMode.G17。(既定値 : DoubleCellValueMode.Legacy)
例
C#
VB
コピー
// 数値の格納方法を IEEE754-2008 準拠に設定
cellReport1.DoubleCellValueMode = DoubleCellValueMode.G17;
' 数値の格納方法を IEEE754-2008 準拠に設定
CellReport1.DoubleCellValueMode = DoubleCellValueMode.G17
関連項目

参照

CellReport クラス


CellReport.DoubleMode プロパティ

CellReportDoubleMode プロパティ

浮動小数点の有効桁数モードを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool DoubleMode { get; set; }
Public Property DoubleMode As Boolean
    Get
    Set

プロパティ値

型: Boolean
数値の有効桁数を 15 桁に設定する場合、true。(既定値 : false)
解説
13 桁以上の数値を設定する場合、true を設定します。
例
C#
VB
コピー
// 数値の有効桁数を 15 桁に設定します。
cellReport1.DoubleMode = true;
cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2019);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = 123456789012345;
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SavePdf(@"C:\out1.pdf");
' 数値の有効桁数を 15 桁に設定します。
CellReport1.DoubleMode = True
CellReport1.Report.Start()
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2019)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = 123456789012345
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SavePdf("C:\out1.pdf")
関連項目

参照

CellReport クラス


CellReport.ErrorMessage プロパティ

CellReportErrorMessage プロパティ

エラーメッセージを取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string ErrorMessage { get; }
Public ReadOnly Property ErrorMessage As String
    Get

プロパティ値

型: String
エラーメッセージ(文字列)。
例
C#
VB
コピー
if (cellReport1.ErrorNo != AdvanceSoftware.ASReport.ErrorNo.NoError)
{
    // エラーメッセージを取得します。
    string errorMessage = cellReport1.ErrorMessage;
}
If CellReport1.ErrorNo <> AdvanceSoftware.ASReport.ErrorNo.NoError Then
    ' エラーメッセージを取得します。
    Dim errorMessage As String = CellReport1.ErrorMessage
End If
関連項目

参照

CellReport クラス


CellReport.ErrorNo プロパティ

CellReportErrorNo プロパティ

エラーナンバーを取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo ErrorNo { get; }
Public ReadOnly Property ErrorNo As ErrorNo
    Get

プロパティ値

型: ErrorNo
エラーナンバーを表す ErrorNo。
例
C#
VB
コピー
if (cellReport1.ErrorNo != AdvanceSoftware.ASReport.ErrorNo.NoError)
{
    // エラーメッセージを取得します。
    string errorMessage = cellReport1.ErrorMessage;
}
If CellReport1.ErrorNo <> AdvanceSoftware.ASReport.ErrorNo.NoError Then
    ' エラーメッセージを取得します。
    Dim errorMessage As String = CellReport1.ErrorMessage
End If
関連項目

参照

CellReport クラス


CellReport.ExcelMode プロパティ

CellReportExcelMode プロパティ

Excel を使用する、しないを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ExcelMode { get; set; }
Public Property ExcelMode As Boolean
    Get
    Set

プロパティ値

型: Boolean
Excel を使用する場合は true。(既定値 : false)
解説
ExcelMode = true で Excel オブジェクトを使用する場合は、実行環境に Excel がインストールされている必要があります。
例
C#
VB
コピー
// Excel オブジェクトを "使用する" に設定します。
cellReport1.ExcelMode = true;
cellReport1.Report.Start();
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2019);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
' Excel オブジェクトを "使用する" に設定します。
CellReport1.ExcelMode = True
CellReport1.Report.Start()
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2019)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

CellReport クラス


CellReport.ExcelModeType プロパティ

CellReportExcelModeType プロパティ

CellReport コンポーネント単体で ExcelMode プロパティを true に設定して使用する場合の Excel の起動モードを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ExcelModeType ExcelModeType { set; }
Public WriteOnly Property ExcelModeType As ExcelModeType
    Set

プロパティ値

型: ExcelModeType
ExcelMode = true 時の Excel 起動モードを表す ExcelModeType。(既定値 : ExcelModeType.Auto)
例
C#
VB
コピー
cellReport1.ExcelMode = true;
// Excel 起動モードを指定します。
cellReport1.ExcelModeType = ExcelModeType.Manual;
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.ExcelMode = True
' Excel 起動モードを指定します。
CellReport1.ExcelModeType = ExcelModeType.Manual
' デザインファイルに "C:\Book1.xlsx" を指定します。
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

CellReport クラス


CellReport.FileName プロパティ

CellReportFileName プロパティ

デザインファイル名を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set

プロパティ値

型: String
デザインファイル名。
例
C#
VB
コピー
// デザインファイルに "C:\Book1.xlsx" を指定します。
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
' デザインファイルに "C:\Book1.xlsx" を指定します。
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

CellReport クラス


CellReport.Keyword プロパティ

CellReportKeyword プロパティ

変数名の先頭キーワード文字列を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Keyword { get; set; }
Public Property Keyword As String
    Get
    Set

プロパティ値

型: String
キーワードとして使用する文字列(最大 64 文字)。(既定値:"**")。
解説
先頭キーワード文字列は Excel で文字として認識可能で、かつ、半角文字のみ設定することができます。 Report.Start メソッドを呼び出す前に変数名の先頭キーワード文字列を設定してください。 なお、以下の文字、及び文字列は先頭キーワード文字列として使用することはできません。
, | コンマ
_[ | アンダースコア + 大かっこ
例
C#
VB
コピー
// 変数名の先頭キーワード文字列を "!!" に設定します。
cellReport1.Keyword = "!!";
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("!!HENSU1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
' 変数名の先頭キーワード文字列を "!!" に設定します。
CellReport1.Keyword = "!!"
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("!!HENSU1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

CellReport クラス


CellReport.OverFit プロパティ

CellReportOverFit プロパティ

帳票を 1 ページに収まるよう表示するかを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool OverFit { get; set; }
Public Property OverFit As Boolean
    Get
    Set

プロパティ値

型: Boolean
帳票を用紙内に収める場合は true。(既定値 : false)
例
C#
VB
コピー
// "帳票を 1 ページに収めて出力する" に設定します。
cellReport1.OverFit = true;
' "帳票を 1 ページに収めて出力する" に設定します。
CellReport1.OverFit = True
関連項目

参照

CellReport クラス


CellReport.Page プロパティ

CellReportPage プロパティ

Page を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Page Page { get; }
Public ReadOnly Property Page As Page
    Get

プロパティ値

型: Page
ページの開始/終了、各種設定を行うための、Page クラス。
解説
このクラスの全てのメンバーの一覧については、Page クラスのメンバーを参照してください。
関連項目

参照

CellReport クラス


CellReport.PageInfo プロパティ

CellReportPageInfo プロパティ

使用するページ情報を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string PageInfo { get; set; }
Public Property PageInfo As String
    Get
    Set

プロパティ値

型: String
使用するページ情報(文字列)。(既定値 : "1-999999")
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
// 使用するシートを "Sheet1" に設定します。
cellReport1.SheetName = "Sheet1";
// 使用するページを "1" に設定します。
cellReport1.PageInfo = "1";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start();
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
' 使用するシートを "Sheet1" に設定します。
CellReport1.SheetName = "Sheet1"
' 使用するページを "1" に設定します。
CellReport1.PageInfo = "1"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start()
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

CellReport クラス


CellReport.Pdf プロパティ

CellReportPdf プロパティ

PDF ファイルのオプションを指定するための PdfOption を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PdfOption Pdf { get; }
Public ReadOnly Property Pdf As PdfOption
    Get

プロパティ値

型: PdfOption
PDF ファイルのオプションを設定するための PdfOption クラス。
解説
このクラスの全てのメンバーの一覧については、PdfOption クラスのメンバーを参照してください。
関連項目

参照

CellReport クラス


CellReport.ReleaseExcelTask プロパティ

CellReportReleaseExcelTask プロパティ

Excel オブジェクトの動作を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ReleaseExcelTask ReleaseExcelTask { get; set; }
Public Property ReleaseExcelTask As ReleaseExcelTask
    Get
    Set

プロパティ値

型: ReleaseExcelTask
Dispose : Excel オブジェクトを起動し続ける、OutputMethod : 出力処理の度に起動する。(既定値 : ReleaseExcelTask.Dispose)
例
C#
VB
コピー
cellReport1.ExcelMode = true;
// Excel オブジェクトを使用するときのみ起動します。
cellReport1.ReleaseExcelTask = AdvanceSoftware.ASReport.ReleaseExcelTask.OutputMethod;
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx", AdvanceSoftware.ASReport.ExcelVersion.ver2019);
CellReport1.ExcelMode = True
' Excel オブジェクトを使用するときのみ起動します。
CellReport1.ReleaseExcelTask = AdvanceSoftware.ASReport.ReleaseExcelTask.OutputMethod
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx", AdvanceSoftware.ASReport.ExcelVersion.ver2019)
関連項目

参照

CellReport クラス


CellReport.Report プロパティ

CellReportReport プロパティ

Report を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Report Report { get; }
Public ReadOnly Property Report As Report
    Get

プロパティ値

型: Report
帳票の作成開始、終了、ならびに、デザインファイルの指定するための Report クラス。
解説
このクラスの全てのメンバーの一覧については、Report クラスのメンバーを参照してください。
関連項目

参照

CellReport クラス


CellReport.SaveAsLowMemoryMode プロパティ

CellReportSaveAsLowMemoryMode プロパティ

ReportMode.Legacy 時における Excel (xls) ファイルの保存時の処理動作を指定します。(既定値 : false)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool SaveAsLowMemoryMode { get; set; }
Public Property SaveAsLowMemoryMode As Boolean
    Get
    Set

プロパティ値

型: Boolean
true : 省メモリモードで動作、false : メモリを途中解放しない ※true を設定した場合、xls ファイル保存時に 20 シートごとに解放してメモリ消費を抑えます。
関連項目

参照

CellReport クラス


CellReport.ScaleMode プロパティ

CellReportScaleMode プロパティ

スケールモードを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ScaleMode ScaleMode { get; set; }
Public Property ScaleMode As ScaleMode
    Get
    Set

プロパティ値

型: ScaleMode
サイズの単位を表す ScaleMode。(既定値 : ScaleMode.Millimeter)
解説
Drawing クラスの各メソッドを使用して図やシェイプを設定する際の座標、サイズの単位を設定します。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel;
// A1 セルに画像 (幅：100px、高さ：100px) を設定します。
cellReport1.Cell("A1").Drawing.AddImage(@"C:\image.bmp", 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel
' A1 セルに画像 (幅：100px、高さ：100px) を設定します。
CellReport1.Cell("A1").Drawing.AddImage("C:\image.bmp", 100, 100)
関連項目

参照

CellReport クラス


CellReport.Section プロパティ

CellReportSection プロパティ

Section を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Section Section { get; }
Public ReadOnly Property Section As Section
    Get

プロパティ値

型: Section
連続帳票の開始/終了、各種設定を行うための、Section クラス。
解説
このクラスの全てのメンバーの一覧については、Section クラスのメンバーを参照してください。
関連項目

参照

CellReport クラス


CellReport.SheetName プロパティ

CellReportSheetName プロパティ

使用するシート名を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string SheetName { get; set; }
Public Property SheetName As String
    Get
    Set

プロパティ値

型: String
使用するシート名。(既定値 : "Sheet1")
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
// 使用するシートを "Sheet1" に設定します。
cellReport1.SheetName = "Sheet1";
// 使用するページを "1" に設定します。
cellReport1.PageInfo = "1";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start();
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
' 使用するシートを "Sheet1" に設定します。
CellReport1.SheetName = "Sheet1"
' 使用するページを "1" に設定します。
CellReport1.PageInfo = "1"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start()
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

CellReport クラス


CellReport.StreamMode プロパティ

CellReportStreamMode プロパティ

ビューアデータの保持モードを指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public StreamMode StreamMode { set; }
Public WriteOnly Property StreamMode As StreamMode
    Set

プロパティ値

型: StreamMode
ビューアデータの保持モードを表す StreamMode。(既定値 : StreamMode.Memory)
例
C#
VB
コピー
// ビューアデータの保持モードを "File" に設定します。
cellReport1.StreamMode = AdvanceSoftware.ASReport.StreamMode.File;
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
' ビューアデータの保持モードを "File" に設定します。
CellReport1.StreamMode = AdvanceSoftware.ASReport.StreamMode.File
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

CellReport クラス


CellReport.TemporaryPath プロパティ

CellReportTemporaryPath プロパティ

一時ファイルのパスを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string TemporaryPath { get; set; }
Public Property TemporaryPath As String
    Get
    Set

プロパティ値

型: String
一時ファイルのパス。(既定値 : null)
解説
内部で作成する一時ファイルの出力先(パス)を設定、取得します。
例
C#
VB
コピー
// 一時ファイルのパスを "C:\Temp" に設定します。
cellReport1.TemporaryPath = @"C:\Temp";
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
' 一時ファイルのパスを "C:\Temp" に設定します。
CellReport1.TemporaryPath = "C:\Temp"
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

CellReport クラス


CellReport.UseTwoExcelTasks プロパティ

CellReportUseTwoExcelTasks プロパティ

ExcelMode で使用する Excel のタスク数を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool UseTwoExcelTasks { get; set; }
Public Property UseTwoExcelTasks As Boolean
    Get
    Set

プロパティ値

型: Boolean
true の場合、2 タスク使用し、ユーザー操作の Excel との競合を防ぎます。(既定値 : true)
例
C#
VB
コピー
// ExcelMode で使用する Excel のタスク数を 1 に設定します。
cellReport1.UseTwoExcelTasks = false;
cellReport1.ExcelMode = true;
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx", AdvanceSoftware.ASReport.ExcelVersion.ver2019);
' ExcelMode で使用する Excel のタスク数を 1 に設定します。
CellReport1.UseTwoExcelTasks = False
CellReport1.ExcelMode = True
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
cellReport1.Report.SaveAs("C:\out1.xlsx", AdvanceSoftware.ASReport.ExcelVersion.ver2019)
関連項目

参照

CellReport クラス


CellReport.VarInsertMode プロパティ

CellReportVarInsertMode プロパティ

変数名挿入モードを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public VarInsertMode VarInsertMode { set; }
Public WriteOnly Property VarInsertMode As VarInsertMode
    Set

プロパティ値

型: VarInsertMode
変数名の差し込みモードを表す VarInsertMode。(既定値 : VarInsertMode.InvalidAnswer)
解説
デザインファイルのオープン前、Report.Start メソッドを呼び出す前に設定してください。
例
C#
VB
コピー
// 変数名の挿入対象をテキストボックスの変数名以外に設定します。
cellReport1.VarInsertMode = AdvanceSoftware.ASReport.VarInsertMode.InvalidTextBox;
// VarNameMode 列挙型の複数のメンバーを or 演算子で連結して指定することができます。
// cellReport1.VarInsertMode = AdvanceSoftware.ASReport.VarInsertMode.InvalidTextBox | AdvanceSoftware.ASReport.VarInsertMode.InvalidAnswer;
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("**HENSU1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
' 変数名の挿入対象をテキストボックスの変数名以外に設定します。
CellReport1.VarInsertMode = AdvanceSoftware.ASReport.VarInsertMode.InvalidTextBox
' VarNameMode 列挙型の複数のメンバーを Or 演算子で連結して指定することができます。
' CellReport1.VarInsertMode = AdvanceSoftware.ASReport.VarInsertMode.InvalidTextBox Or AdvanceSoftware.ASReport.VarInsertMode.InvalidAnswer
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("**HENSU1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

CellReport クラス


CellReport.VarNameMode プロパティ

CellReportVarNameMode プロパティ

変数名の設定を行う Keyword 、VarInsertMode プロパティの動作モードを指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public VarNameMode VarNameMode { set; }
Public WriteOnly Property VarNameMode As VarNameMode
    Set

プロパティ値

型: VarNameMode
変数名の動作モードを表す VarNameMode。(既定値 : VarNameMode.Private)
解説
変数名キーワード文字列と差し込みモードはインスタンス単位で設定値が保持されています。 インスタンス間で設定値を共有する場合は「VarNameMode.Shared」を指定してください。
例
C#
VB
コピー
// 変数名キーワード文字列、差し込みモードの設定値をインスタンス間で共有するよう指定します。
cellReport1.VarNameMode = AdvanceSoftware.ASReport.VarNameMode.Shared;
cellReport1.VarInsertMode = AdvanceSoftware.ASReport.VarInsertMode.InvalidAnswer;
cellReport1.Keyword = "!!";
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Cell("!!HENSU1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
' 変数名キーワード文字列、差し込みモードの設定値をインスタンス間で共有するよう指定します。
CellReport1.VarNameMode = AdvanceSoftware.ASReport.VarNameMode.Shared
CellReport1.VarInsertMode = AdvanceSoftware.ASReport.VarInsertMode.InvalidAnswer
CellReport1.Keyword = "!!"
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("!!HENSU1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

CellReport クラス


CellReport.WaitTimeout プロパティ

CellReportWaitTimeout プロパティ

同時アクセス時の待ち時間をミリ秒単位で指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public uint WaitTimeout { set; }
Public WriteOnly Property WaitTimeout As UInteger
    Set

プロパティ値

型: UInt32
ブック作成、オープン時の排他処理の最大の待ち時間。
解説
大きいサイズの Excel ファイルをデザインファイルとして使用する、 同時アクセスのクライアント数が多い場合等に、 Excel ファイルの作成で待ち時間が経過してミューテックスエラーが発生する場合は、 WaiteTimout プロパティの値を変更して待ち時間を上げてください。
例
C#
VB
コピー
// 最大待ち時間を 10 秒に設定します。
cellReport1.WaitTimeout = 10000;
' 最大待ち時間を 10 秒に設定します。
CellReport1.WaitTimeout = 10000
関連項目

参照

CellReport クラス


CellReport メソッド

CellReport 型は下記のメンバーを公開します。

メソッド
名前 | 説明
Cell(String) | Cell を取得します。
Cell(String, Int32, Int32) | Cell を取得します。
ClearDocument | ドキュメントを破棄します。
ColumnClear(Int32) | 列をクリアします。
ColumnClear(Int32, Int32) | 列をクリアします。
ColumnCopy(Int32) | 列をコピーします。
ColumnCopy(Int32, Int32) | 列をコピーします。
ColumnDelete(Int32) | 列を削除します。
ColumnDelete(Int32, Int32) | 列を削除します。
ColumnInsert(Int32) | 列を挿入します。
ColumnInsert(Int32, Int32) | 列を挿入します。
ColumnInsertCopied(Int32) | コピーした列を挿入します。
ColumnInsertCopied(Int32, Int32) | コピーした列を挿入します。
ColumnPaste | コピーした列を貼り付けします。
GetChartCount | グラフの数を取得します。(xlsx形式のみ)
GetChartData | グラフ情報を取得します。(xlsx形式のみ)
GetDocument | ビューアに渡すための AS-Report ドキュメントを取得します。
GetMaxArea | データ、属性が設定されたセルの終了座標を取得します。
GetMaxArea(MaxEndPoint) | データ、属性が設定されたセルの終了座標を取得します。
GetMaxData | データが設定されたセルの終了座標を取得します。
GetMaxData(MaxEndPoint) | データが設定されたセルの終了座標を取得します。
GetNamePos | 指定したセル名の座標(0～)を取得します。
GetVarNamePos | 指定した変数名の座標(0～)を取得します。
Pos(Int32, Int32) | Cell を取得します。
Pos(Int32, Int32, Int32, Int32) | Cell を取得します。
RowClear(Int32) | 行をクリアします。
RowClear(Int32, Int32) | 行をクリアします。
RowCopy(Int32) | 行をコピーします。
RowCopy(Int32, Int32) | 行をコピーします。
RowDelete(Int32) | 行を削除します。
RowDelete(Int32, Int32) | 行を削除します。
RowInsert(Int32) | 行を挿入します。
RowInsert(Int32, Int32) | 行を挿入します。
RowInsertCopied(Int32) | コピーした行を挿入します。
RowInsertCopied(Int32, Int32) | コピーした行を挿入します。
RowPaste | コピーした行を貼り付けします。
SetLicense(Stream) | ライセンス情報を設定します。
SetLicense(String) | ライセンス情報を設定します。
TableRowDelete(Int32) | テーブル範囲に含まれる行を削除します。
TableRowDelete(Int32, Int32) | テーブル範囲に含まれる行を削除します。
TableRowInsert(Int32) | テーブル範囲に行を挿入します。
TableRowInsert(Int32, Int32) | テーブル範囲に行を挿入します。
VarCheck | 指定した変数名が存在するかをチェックします。
トップ
関連項目

参照

CellReport クラス


CellReport.Cell メソッド

CellReportCell メソッド

オーバーロードの一覧
名前 | 説明
Cell(String) | Cell を取得します。
Cell(String, Int32, Int32) | Cell を取得します。
トップ
関連項目

参照

CellReport クラス


CellReport.Cell メソッド (String)

CellReportCell メソッド (String)

Cell を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Cell Cell(
    string _cell
)
Public Function Cell (
    _cell As String
) As Cell

パラメーター

_cell
型: SystemString
セルを指定します。

戻り値

型: Cell
Cell を返します。
解説
A1 形式、変数名、セル名で指定します。 変数名、セル名は、デザインファイルに設定しておく必要があります。
例
C#
VB
コピー
// A1 参照形式でセルを指定します。
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
// 変数名でセルを指定します。
cellReport1.Cell("**HENSU1").Value = "アドバンスソフトウェア";
// セル名でセルを指定します。
cellReport1.Cell("NAMAE1").Value = "アドバンスソフトウェア";
' A1 参照形式でセルを指定します。
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
' 変数名でセルを指定します。
CellReport1.Cell("**HENSU1").Value = "アドバンスソフトウェア"
' セル名でセルを指定します。
CellReport1.Cell("NAMAE1").Value = "アドバンスソフトウェア"
関連項目

参照

CellReport クラス
Cell オーバーロード


CellReport.Cell メソッド (String, Int32, Int32)

CellReportCell メソッド (String, Int32, Int32)

Cell を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Cell Cell(
    string _cell,
    int cx,
    int cy
)
Public Function Cell (
    _cell As String,
    cx As Integer,
    cy As Integer
) As Cell

パラメーター

_cell
型: SystemString
セルを指定します。
cx
型: SystemInt32
x 方向へのオフセットを指定します。
cy
型: SystemInt32
y 方向へのオフセットを指定します。

戻り値

型: Cell
Cell を返します。
例
C#
VB
コピー
// A1 セルに文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Cell("A1", 0, 0).Value = "アドバンスソフトウェア";
// B1 セルに文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Cell("A1", 1, 0).Value = "アドバンスソフトウェア";
' A1 セルに文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Cell("A1", 0, 0).Value = "アドバンスソフトウェア"
' B1 セルに文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Cell("A1", 1, 0).Value = "アドバンスソフトウェア"
関連項目

参照

CellReport クラス
Cell オーバーロード


CellReport.ClearDocument メソッド

CellReportClearDocument メソッド

ドキュメントを破棄します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ClearDocument(
    string name
)
Public Function ClearDocument (
    name As String
) As Boolean

パラメーター

name
型: SystemString
Report.Start メソッドで指定したドキュメント名を指定します。

戻り値

型: Boolean
ドキュメントを破棄した場合 true を返します。
例
C#
VB
コピー
// 帳票ドキュメント "Document1" を破棄します。
cellReport1.ClearDocument("Document1");
' 帳票ドキュメント "Document1" を破棄します。
CellReport1.ClearDocument("Document1")
関連項目

参照

CellReport クラス


CellReport.ColumnClear メソッド

CellReportColumnClear メソッド

オーバーロードの一覧
名前 | 説明
ColumnClear(Int32) | 列をクリアします。
ColumnClear(Int32, Int32) | 列をクリアします。
トップ
関連項目

参照

CellReport クラス


CellReport.ColumnClear メソッド (Int32)

CellReportColumnClear メソッド (Int32)

列をクリアします。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnClear(
    int sx
)
Public Sub ColumnClear (
    sx As Integer
)

パラメーター

sx
型: SystemInt32
クリアする列(0～)を指定します。
例
C#
VB
コピー
// A 列をクリアします。
cellReport1.ColumnClear(0);
' A 列をクリアします。
CellReport1.ColumnClear(0)
関連項目

参照

CellReport クラス
ColumnClear オーバーロード


CellReport.ColumnClear メソッド (Int32, Int32)

CellReportColumnClear メソッド (Int32, Int32)

列をクリアします。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnClear(
    int sx,
    int count
)
Public Sub ColumnClear (
    sx As Integer,
    count As Integer
)

パラメーター

sx
型: SystemInt32
クリアする列(0～)を指定します。
count
型: SystemInt32
クリアする列数を指定します。
例
C#
VB
コピー
// A 列から 5 列分クリアします。
cellReport1.ColumnClear(0, 5);
' A 列から 5 列分クリアします。
CellReport1.ColumnClear(0, 5)
関連項目

参照

CellReport クラス
ColumnClear オーバーロード


CellReport.ColumnCopy メソッド

CellReportColumnCopy メソッド

オーバーロードの一覧
名前 | 説明
ColumnCopy(Int32) | 列をコピーします。
ColumnCopy(Int32, Int32) | 列をコピーします。
トップ
関連項目

参照

CellReport クラス


CellReport.ColumnCopy メソッド (Int32)

CellReportColumnCopy メソッド (Int32)

列をコピーします。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnCopy(
    int sx
)
Public Sub ColumnCopy (
    sx As Integer
)

パラメーター

sx
型: SystemInt32
コピーする列(0～)を指定します。
例
C#
VB
コピー
// A 列をメモリ上にコピーします。
cellReport1.ColumnCopy(0);
// コピーした列を B 列に貼り付けます。
cellReport1.ColumnPaste(1);
' A 列をメモリ上にコピーします。
CellReport1.ColumnCopy(0)
' コピーした列を B 列に貼り付けます。
CellReport1.ColumnPaste(1)
関連項目

参照

CellReport クラス
ColumnCopy オーバーロード


CellReport.ColumnCopy メソッド (Int32, Int32)

CellReportColumnCopy メソッド (Int32, Int32)

列をコピーします。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnCopy(
    int sx,
    int dx
)
Public Sub ColumnCopy (
    sx As Integer,
    dx As Integer
)

パラメーター

sx
型: SystemInt32
コピーする列(0～)を指定します。
dx
型: SystemInt32
貼り付けする列を指定します。
例
C#
VB
コピー
// A 列をコピーして B 列に貼り付けます。
cellReport1.ColumnCopy(0, 1);
' A 列をコピーして B 列に貼り付けます。
CellReport1.ColumnCopy(0, 1)
関連項目

参照

CellReport クラス
ColumnCopy オーバーロード


CellReport.ColumnDelete メソッド

CellReportColumnDelete メソッド

オーバーロードの一覧
名前 | 説明
ColumnDelete(Int32) | 列を削除します。
ColumnDelete(Int32, Int32) | 列を削除します。
トップ
関連項目

参照

CellReport クラス


CellReport.ColumnDelete メソッド (Int32)

CellReportColumnDelete メソッド (Int32)

列を削除します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnDelete(
    int sx
)
Public Sub ColumnDelete (
    sx As Integer
)

パラメーター

sx
型: SystemInt32
削除する列(0～)を指定します。
例
C#
VB
コピー
// A 列を削除します。
cellReport1.ColumnDelete(0);
' A 列を削除します。
CellReport1.ColumnDelete(0)
関連項目

参照

CellReport クラス
ColumnDelete オーバーロード


CellReport.ColumnDelete メソッド (Int32, Int32)

CellReportColumnDelete メソッド (Int32, Int32)

列を削除します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnDelete(
    int sx,
    int count
)
Public Sub ColumnDelete (
    sx As Integer,
    count As Integer
)

パラメーター

sx
型: SystemInt32
削除する列(0～)を指定します。
count
型: SystemInt32
削除する列数を指定します。
例
C#
VB
コピー
// A 列から 5 列分削除します。
cellReport1.ColumnDelete(0, 5);
' A 列から 5 列分削除します。
CellReport1.ColumnDelete(0, 5)
関連項目

参照

CellReport クラス
ColumnDelete オーバーロード


CellReport.ColumnInsert メソッド

CellReportColumnInsert メソッド

オーバーロードの一覧
名前 | 説明
ColumnInsert(Int32) | 列を挿入します。
ColumnInsert(Int32, Int32) | 列を挿入します。
トップ
関連項目

参照

CellReport クラス


CellReport.ColumnInsert メソッド (Int32)

CellReportColumnInsert メソッド (Int32)

列を挿入します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnInsert(
    int sx
)
Public Sub ColumnInsert (
    sx As Integer
)

パラメーター

sx
型: SystemInt32
挿入する列(0～)を指定します。
例
C#
VB
コピー
// A 列に 1 列分挿入します。
cellReport1.ColumnInsert(0);
' A 列に 1 列分挿入します。
CellReport1.ColumnInsert(0)
関連項目

参照

CellReport クラス
ColumnInsert オーバーロード


CellReport.ColumnInsert メソッド (Int32, Int32)

CellReportColumnInsert メソッド (Int32, Int32)

列を挿入します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnInsert(
    int sx,
    int count
)
Public Sub ColumnInsert (
    sx As Integer,
    count As Integer
)

パラメーター

sx
型: SystemInt32
挿入する列(0～)を指定します。
count
型: SystemInt32
挿入する列数を指定します。
例
C#
VB
コピー
// A 列に 5 列分挿入します。
cellReport1.ColumnInsert(0, 5);
' A 列に 5 列分挿入します。
CellReport1.ColumnInsert(0, 5)
関連項目

参照

CellReport クラス
ColumnInsert オーバーロード


CellReport.ColumnInsertCopied メソッド

CellReportColumnInsertCopied メソッド

オーバーロードの一覧
名前 | 説明
ColumnInsertCopied(Int32) | コピーした列を挿入します。
ColumnInsertCopied(Int32, Int32) | コピーした列を挿入します。
トップ
関連項目

参照

CellReport クラス


CellReport.ColumnInsertCopied メソッド (Int32)

CellReportColumnInsertCopied メソッド (Int32)

コピーした列を挿入します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnInsertCopied(
    int sx
)
Public Sub ColumnInsertCopied (
    sx As Integer
)

パラメーター

sx
型: SystemInt32
挿入する列(0～)を指定します。
例
C#
VB
コピー
// A 列をメモリ上にコピーします。
cellReport1.ColumnCopy(0);
// コピーした列を B 列に挿入します。
cellReport1.ColumnInsertCopied(1);
' A 列をメモリ上にコピーします。
CellReport1.ColumnCopy(0)
' コピーした列を B 列に挿入します。
CellReport1.ColumnInsertCopied(1)
関連項目

参照

CellReport クラス
ColumnInsertCopied オーバーロード


CellReport.ColumnInsertCopied メソッド (Int32, Int32)

CellReportColumnInsertCopied メソッド (Int32, Int32)

コピーした列を挿入します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnInsertCopied(
    int sx,
    int count
)
Public Sub ColumnInsertCopied (
    sx As Integer,
    count As Integer
)

パラメーター

sx
型: SystemInt32
挿入する列(0～)を指定します。
count
型: SystemInt32
挿入する列数を指定します。
例
C#
VB
コピー
// A 列をメモリ上にコピーします。
cellReport1.ColumnCopy(0);
// コピーした列を B 列に 5 列分挿入します。
cellReport1.ColumnInsertCopied(1, 5);
' A 列をメモリ上にコピーします。
CellReport1.ColumnCopy(0)
' コピーした列を B 列に 5 列分挿入します。
CellReport1.ColumnInsertCopied(1, 5)
関連項目

参照

CellReport クラス
ColumnInsertCopied オーバーロード


CellReport.ColumnPaste メソッド

CellReportColumnPaste メソッド

コピーした列を貼り付けします。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void ColumnPaste(
    int dx
)
Public Sub ColumnPaste (
    dx As Integer
)

パラメーター

dx
型: SystemInt32
貼り付けする列(0～)を指定します。
例
C#
VB
コピー
// A 列をメモリ上にコピーします。
cellReport1.ColumnCopy(0);
// コピーした列を B 列に貼り付けます。
cellReport1.ColumnPaste(1);
' A 列をメモリ上にコピーします。
CellReport1.ColumnCopy(0)
' コピーした列を B 列に貼り付けます。
CellReport1.ColumnPaste(1)
関連項目

参照

CellReport クラス


CellReport.GetChartCount メソッド

CellReportGetChartCount メソッド

グラフの数を取得します。(xlsx形式のみ)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int GetChartCount()
Public Function GetChartCount As Integer

戻り値

型: Int32
グラフの数
例
C#
VB
コピー
// グラフの数を取得します。
int chartCount = cellReport1.GetChartCount();
' グラフの数を取得します。
Dim chartCount As Integer = CellReport1.GetChartCount()
関連項目

参照

CellReport クラス


CellReport.GetChartData メソッド

CellReportGetChartData メソッド

グラフ情報を取得します。(xlsx形式のみ)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartData GetChartData(
    int index,
    int resolution
)
Public Function GetChartData (
    index As Integer,
    resolution As Integer
) As ChartData

パラメーター

index
型: SystemInt32
取得するグラフのインデックスを設定します。
resolution
型: SystemInt32
取得するグラフイメージの解像度を設定します。(Excel では 330dpi)

戻り値

型: ChartData
グラフ情報
例
C#
VB
コピー
// グラフの数を取得
int chartCount = cellReport1.GetChartCount();
for (int i = 0; i < chartCount; i++)
{
    // グラフ情報を取得
    ChartData chartData = cellReport1.GetChartData(i, 330);
    // ChartData からの Image オブジェクト生成処理は
    // 独自に実装する必要があります。
    // ChartCreator クラスをサンプルとして用意しています。
    Image chartImage = ChartCreator.GetChartImage(chartData);
    cellReport1.Pos(chartData.col, chartData.row).Canvas.AddChart(chartImage, chartData);
}
' グラフの数を取得
Dim chartCount As Integer = CellReport1.GetChartCount()
For i = 0 To chartCount
    ' グラフ情報を取得
    Dim chartData As ChartData = CellReport1.GetChartData(i, 330)
    ' ChartData からの Image オブジェクト生成処理は
    ' 独自に実装する必要があります。
    ' ChartCreator クラスをサンプルとして用意しています。
    Dim chartImage As Image = ChartCreator.GetChartImage(chartData)
    CellReport1.Pos(chartData.col, chartData.row).Canvas.AddChart(chartImage, chartData)
Next
関連項目

参照

CellReport クラス


CellReport.GetDocument メソッド

CellReportGetDocument メソッド

ビューアに渡すための AS-Report ドキュメントを取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Document GetDocument(
    string name
)
Public Function GetDocument (
    name As String
) As Document

パラメーター

name
型: SystemString
Report.Start メソッドで指定したドキュメント名を指定します。

戻り値

型: Document
Document を返します。
例
C#
VB
コピー
// 帳票ドキュメント名を "Document1" に設定します。
cellReport1.Report.Start("Document1");
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2019);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "Document1";
cellReport1.Page.End();
cellReport1.Report.End();
// ビューアコントロールに帳票ドキュメント "Document1" を設定します。
viewerControl1.Document = cellReport1.GetDocument("Document1");
' 帳票ドキュメント名を "Document1" に設定します。
CellReport1.Report.Start("Document1")
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2019)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "Document1"
CellReport1.Page.End()
CellReport1.Report.End()
' ビューアコントロールに帳票ドキュメント "Document1" を設定します。
ViewerControl1.Document = CellReport1.GetDocument("Document1")
関連項目

参照

CellReport クラス


CellReport.GetMaxArea メソッド

CellReportGetMaxArea メソッド

オーバーロードの一覧
名前 | 説明
GetMaxArea | データ、属性が設定されたセルの終了座標を取得します。
GetMaxArea(MaxEndPoint) | データ、属性が設定されたセルの終了座標を取得します。
トップ
関連項目

参照

CellReport クラス


CellReport.GetMaxArea メソッド

CellReportGetMaxArea メソッド

データ、属性が設定されたセルの終了座標を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Point GetMaxArea()
Public Function GetMaxArea As Point

戻り値

型: Point
データ、属性が設定されたセルの終了座標。
例
C#
VB
コピー
System.Drawing.Point point;
// データ、属性が設定されたセルの最終座標を取得します。
point = cellReport1.GetMaxArea();
Dim point As System.Drawing.Point
' データ、属性が設定されたセルの最終座標を取得します。
point = CellReport1.GetMaxArea()
関連項目

参照

CellReport クラス
GetMaxArea オーバーロード


CellReport.GetMaxArea メソッド (MaxEndPoint)

CellReportGetMaxArea メソッド (MaxEndPoint)

データ、属性が設定されたセルの終了座標を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Point GetMaxArea(
    MaxEndPoint point
)
Public Function GetMaxArea (
    point As MaxEndPoint
) As Point

パラメーター

point
型: AdvanceSoftware.ASReportMaxEndPoint
取得する座標の種別を指定します。

戻り値

型: Point
データ、属性が設定されたセルの終了座標。
例
C#
VB
コピー
System.Drawing.Point point;
// データ、属性が設定されたセルの最大行と最大列の交点座標を取得します。
point = cellReport1.GetMaxArea(AdvanceSoftware.ASReport.MaxEndPoint.MaxPoint);
Dim point As System.Drawing.Point
' データ、属性が設定されたセルの最大行と最大列の交点座標を取得します。
point = CellReport1.GetMaxArea(AdvanceSoftware.ASReport.MaxEndPoint.MaxPoint)
関連項目

参照

CellReport クラス
GetMaxArea オーバーロード


CellReport.GetMaxData メソッド

CellReportGetMaxData メソッド

オーバーロードの一覧
名前 | 説明
GetMaxData | データが設定されたセルの終了座標を取得します。
GetMaxData(MaxEndPoint) | データが設定されたセルの終了座標を取得します。
トップ
関連項目

参照

CellReport クラス


CellReport.GetMaxData メソッド

CellReportGetMaxData メソッド

データが設定されたセルの終了座標を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Point GetMaxData()
Public Function GetMaxData As Point

戻り値

型: Point
データが設定されたセルの終了座標。
例
C#
VB
コピー
System.Drawing.Point point;
// データが設定されたセルの最終座標を取得します。
point = cellReport1.GetMaxData();
Dim point As System.Drawing.Point
' データが設定されたセルの最終座標を取得します。
point = CellReport1.GetMaxData()
関連項目

参照

CellReport クラス
GetMaxData オーバーロード


CellReport.GetMaxData メソッド (MaxEndPoint)

CellReportGetMaxData メソッド (MaxEndPoint)

データが設定されたセルの終了座標を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Point GetMaxData(
    MaxEndPoint point
)
Public Function GetMaxData (
    point As MaxEndPoint
) As Point

パラメーター

point
型: AdvanceSoftware.ASReportMaxEndPoint
取得する座標の種別を指定します。

戻り値

型: Point
データが設定されたセルの終了座標。
例
C#
VB
コピー
System.Drawing.Point point;
// データが設定されたセルの最大行と最大列の交点座標を取得します。
point = cellReport1.GetMaxData(AdvanceSoftware.ASReport.MaxEndPoint.MaxPoint);
Dim point As System.Drawing.Point
' データが設定されたセルの最大行と最大列の交点座標を取得します。
point = CellReport1.GetMaxData(AdvanceSoftware.ASReport.MaxEndPoint.MaxPoint)
関連項目

参照

CellReport クラス
GetMaxData オーバーロード


CellReport.GetNamePos メソッド

CellReportGetNamePos メソッド

指定したセル名の座標(0～)を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Point GetNamePos(
    string cellName
)
Public Function GetNamePos (
    cellName As String
) As Point

パラメーター

cellName
型: SystemString
セル名を指定します。

戻り値

型: Point
セル名の座標(0～)。
例
C#
VB
コピー
System.Drawing.Point point;
// セル名 "NAMAE1" の座標を取得します。
point = cellReport1.GetNamePos("NAMAE1");
Dim point As System.Drawing.Point
' セル名 "NAMAE1" の座標を取得します。
point = CellReport1.GetNamePos("NAMAE1")
関連項目

参照

CellReport クラス


CellReport.GetVarNamePos メソッド

CellReportGetVarNamePos メソッド

指定した変数名の座標(0～)を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Point GetVarNamePos(
    string varName,
    int index
)
Public Function GetVarNamePos (
    varName As String,
    index As Integer
) As Point

パラメーター

varName
型: SystemString
変数名を指定します。
index
型: SystemInt32
変数名が複数ある場合、取得する変数名のインデックスを指定します。

戻り値

型: Point
変数名の座標(0～)。
例
C#
VB
コピー
System.Drawing.Point point;
// 変数名 "**HENSU1" の 1 番目の座標を取得します。
point = cellReport1.GetVarNamePos("**HENSU1", 0);
Dim point As System.Drawing.Point
' 変数名 "**HENSU1" の 1 番目の座標を取得します。
point = CellReport1.GetVarNamePos("**HENSU1", 0)
関連項目

参照

CellReport クラス


CellReport.Pos メソッド

CellReportPos メソッド

オーバーロードの一覧
名前 | 説明
Pos(Int32, Int32) | Cell を取得します。
Pos(Int32, Int32, Int32, Int32) | Cell を取得します。
トップ
関連項目

参照

CellReport クラス


CellReport.Pos メソッド (Int32, Int32)

CellReportPos メソッド (Int32, Int32)

Cell を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Cell Pos(
    int sx,
    int sy
)
Public Function Pos (
    sx As Integer,
    sy As Integer
) As Cell

パラメーター

sx
型: SystemInt32
x 座標(0～)を指定します。
sy
型: SystemInt32
y 座標(0～)を指定します。

戻り値

型: Cell
Cell を返します。
解説
A1(0, 0)を基点として、座標で指定します。
例
C#
VB
コピー
// A1 セルに文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Pos(0, 0).Value = "アドバンスソフトウェア";
// B1 セルに文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Pos(1, 0).Value = "アドバンスソフトウェア";
' A1 セルに文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Pos(0, 0).Value = "アドバンスソフトウェア"
' B1 セルに文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Pos(1, 0).Value = "アドバンスソフトウェア"
関連項目

参照

CellReport クラス
Pos オーバーロード


CellReport.Pos メソッド (Int32, Int32, Int32, Int32)

CellReportPos メソッド (Int32, Int32, Int32, Int32)

Cell を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Cell Pos(
    int sx,
    int sy,
    int ex,
    int ey
)
Public Function Pos (
    sx As Integer,
    sy As Integer,
    ex As Integer,
    ey As Integer
) As Cell

パラメーター

sx
型: SystemInt32
開始 x 座標(0～)を指定します。
sy
型: SystemInt32
開始 y 座標(0～)を指定します。
ex
型: SystemInt32
終了 x 座標(0～)を指定します。
ey
型: SystemInt32
終了 y 座標(0～)を指定します。

戻り値

型: Cell
Cell を返します。
例
C#
VB
コピー
// A1 セルに文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Pos(0, 0, 0, 0).Value = "アドバンスソフトウェア";
// A1:B2 セルに文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Pos(0, 0, 1, 1).Value = "アドバンスソフトウェア";
' A1 セルに文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Pos(0, 0, 0, 0).Value = "アドバンスソフトウェア"
' A1:B2 セルに文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Pos(0, 0, 1, 1).Value = "アドバンスソフトウェア"
関連項目

参照

CellReport クラス
Pos オーバーロード


CellReport.RowClear メソッド

CellReportRowClear メソッド

オーバーロードの一覧
名前 | 説明
RowClear(Int32) | 行をクリアします。
RowClear(Int32, Int32) | 行をクリアします。
トップ
関連項目

参照

CellReport クラス


CellReport.RowClear メソッド (Int32)

CellReportRowClear メソッド (Int32)

行をクリアします。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowClear(
    int sy
)
Public Sub RowClear (
    sy As Integer
)

パラメーター

sy
型: SystemInt32
クリアする行(0～)を指定します。
例
C#
VB
コピー
// 1 行目をクリアします。
cellReport1.RowClear(0);
' 1 行目をクリアします。
CellReport1.RowClear(0)
関連項目

参照

CellReport クラス
RowClear オーバーロード


CellReport.RowClear メソッド (Int32, Int32)

CellReportRowClear メソッド (Int32, Int32)

行をクリアします。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowClear(
    int sy,
    int count
)
Public Sub RowClear (
    sy As Integer,
    count As Integer
)

パラメーター

sy
型: SystemInt32
クリアする行(0～)を指定します。
count
型: SystemInt32
クリアする行数を指定します。
例
C#
VB
コピー
// 1 行目から 5 行分クリアします。
cellReport1.RowClear(0, 5);
' 1 行目から 5 行分クリアします。
CellReport1.RowClear(0, 5)
関連項目

参照

CellReport クラス
RowClear オーバーロード


CellReport.RowCopy メソッド

CellReportRowCopy メソッド

オーバーロードの一覧
名前 | 説明
RowCopy(Int32) | 行をコピーします。
RowCopy(Int32, Int32) | 行をコピーします。
トップ
関連項目

参照

CellReport クラス


CellReport.RowCopy メソッド (Int32)

CellReportRowCopy メソッド (Int32)

行をコピーします。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowCopy(
    int sy
)
Public Sub RowCopy (
    sy As Integer
)

パラメーター

sy
型: SystemInt32
コピーする行(0～)を指定します。
例
C#
VB
コピー
// 1 行目をメモリ上にコピーします。
cellReport1.RowCopy(0);
// コピーした行を 2 行目に貼り付けます。
cellReport1.RowPaste(1);
' 1 行目をメモリ上にコピーします。
CellReport1.RowCopy(0)
' コピーした行を 2 行目に貼り付けます。
CellReport1.RowPaste(1)
関連項目

参照

CellReport クラス
RowCopy オーバーロード


CellReport.RowCopy メソッド (Int32, Int32)

CellReportRowCopy メソッド (Int32, Int32)

行をコピーします。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowCopy(
    int sy,
    int dy
)
Public Sub RowCopy (
    sy As Integer,
    dy As Integer
)

パラメーター

sy
型: SystemInt32
コピーする行(0～)を指定します。
dy
型: SystemInt32
貼り付けする行(0～)を指定します。
解説
行をコピーします。dy に -1 を設定した時は sy で設定した行がメモリ上にコピーされ、 RowPaste メソッドで設定した行に貼り付けることができます。
例
C#
VB
コピー
// 1 行目をコピーして 2 行目に貼り付けます。
cellReport1.RowCopy(0, 1);
' 1 行目をコピーして 2 行目に貼り付けます。
CellReport1.RowCopy(0, 1)
関連項目

参照

CellReport クラス
RowCopy オーバーロード


CellReport.RowDelete メソッド

CellReportRowDelete メソッド

オーバーロードの一覧
名前 | 説明
RowDelete(Int32) | 行を削除します。
RowDelete(Int32, Int32) | 行を削除します。
トップ
関連項目

参照

CellReport クラス


CellReport.RowDelete メソッド (Int32)

CellReportRowDelete メソッド (Int32)

行を削除します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowDelete(
    int sy
)
Public Sub RowDelete (
    sy As Integer
)

パラメーター

sy
型: SystemInt32
削除する行(0～)を指定します。
例
C#
VB
コピー
// 1 行目を削除します。
cellReport1.RowDelete(0);
' 1 行目を削除します。
CellReport1.RowDelete(0)
関連項目

参照

CellReport クラス
RowDelete オーバーロード


CellReport.RowDelete メソッド (Int32, Int32)

CellReportRowDelete メソッド (Int32, Int32)

行を削除します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowDelete(
    int sy,
    int count
)
Public Sub RowDelete (
    sy As Integer,
    count As Integer
)

パラメーター

sy
型: SystemInt32
削除する行(0～)を指定します。
count
型: SystemInt32
削除する行数を指定します。
例
C#
VB
コピー
// 1 行目から 5 行分削除します。
cellReport1.RowDelete(0, 5);
' 1 行目から 5 行分削除します。
CellReport1.RowDelete(0, 5)
関連項目

参照

CellReport クラス
RowDelete オーバーロード


CellReport.RowInsert メソッド

CellReportRowInsert メソッド

オーバーロードの一覧
名前 | 説明
RowInsert(Int32) | 行を挿入します。
RowInsert(Int32, Int32) | 行を挿入します。
トップ
関連項目

参照

CellReport クラス


CellReport.RowInsert メソッド (Int32)

CellReportRowInsert メソッド (Int32)

行を挿入します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowInsert(
    int sy
)
Public Sub RowInsert (
    sy As Integer
)

パラメーター

sy
型: SystemInt32
挿入する行(0～)を指定します。
例
C#
VB
コピー
// 1 行目に 1 行分挿入します。
cellReport1.RowInsert(0);
' 1 行目に 1 行分挿入します。
CellReport1.RowInsert(0)
関連項目

参照

CellReport クラス
RowInsert オーバーロード


CellReport.RowInsert メソッド (Int32, Int32)

CellReportRowInsert メソッド (Int32, Int32)

行を挿入します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowInsert(
    int sy,
    int count
)
Public Sub RowInsert (
    sy As Integer,
    count As Integer
)

パラメーター

sy
型: SystemInt32
挿入する行(0～)を指定します。
count
型: SystemInt32
挿入する行数を指定します。
例
C#
VB
コピー
// 1 行目に 5 行分挿入します。
cellReport1.RowInsert(0, 5);
' 1 行目に 5 行分挿入します。
CellReport1.RowInsert(0, 5)
関連項目

参照

CellReport クラス
RowInsert オーバーロード


CellReport.RowInsertCopied メソッド

CellReportRowInsertCopied メソッド

オーバーロードの一覧
名前 | 説明
RowInsertCopied(Int32) | コピーした行を挿入します。
RowInsertCopied(Int32, Int32) | コピーした行を挿入します。
トップ
関連項目

参照

CellReport クラス


CellReport.RowInsertCopied メソッド (Int32)

CellReportRowInsertCopied メソッド (Int32)

コピーした行を挿入します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowInsertCopied(
    int sy
)
Public Sub RowInsertCopied (
    sy As Integer
)

パラメーター

sy
型: SystemInt32
挿入する行(0～)を指定します。
解説
RowCopy メソッドでコピーした行を挿入します。
例
C#
VB
コピー
// 1 行目をメモリ上にコピーします。
cellReport1.RowCopy(0);
// コピーした行を 2 行目に挿入します。
cellReport1.RowInsertCopied(1);
' 1 行目をメモリ上にコピーします。
CellReport1.RowCopy(0)
' コピーした行を 2 行目に挿入します。
CellReport1.RowInsertCopied(1)
関連項目

参照

CellReport クラス
RowInsertCopied オーバーロード


CellReport.RowInsertCopied メソッド (Int32, Int32)

CellReportRowInsertCopied メソッド (Int32, Int32)

コピーした行を挿入します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowInsertCopied(
    int sy,
    int count
)
Public Sub RowInsertCopied (
    sy As Integer,
    count As Integer
)

パラメーター

sy
型: SystemInt32
挿入する行(0～)を指定します。
count
型: SystemInt32
挿入する行数を指定します。
解説
RowCopy メソッドでコピーした行を挿入します。
例
C#
VB
コピー
// 1 行目をメモリ上にコピーします。
cellReport1.RowCopy(0);
// コピーした行を 2 行目に 5 行分挿入します。
cellReport1.RowInsertCopied(1, 5);
' 1 行目をメモリ上にコピーします。
CellReport1.RowCopy(0)
' コピーした行を 2 行目に 5 行分挿入します。
CellReport1.RowInsertCopied(1, 5)
関連項目

参照

CellReport クラス
RowInsertCopied オーバーロード


CellReport.RowPaste メソッド

CellReportRowPaste メソッド

コピーした行を貼り付けします。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void RowPaste(
    int dy
)
Public Sub RowPaste (
    dy As Integer
)

パラメーター

dy
型: SystemInt32
>貼り付けする行(0～)を指定します。
解説
RowCopy メソッドでメモリ上にコピーした行を、引数 dy の設定列に貼り付けます。
例
C#
VB
コピー
// 1 行目をメモリ上にコピーします。
cellReport1.RowCopy(0);
// コピーした行を 2 行目に貼り付けます。
cellReport1.RowPaste(1);
' 1 行目をメモリ上にコピーします。
CellReport1.RowCopy(0)
' コピーした行を 2 行目に貼り付けます。
CellReport1.RowPaste(1)
関連項目

参照

CellReport クラス


CellReport.SetLicense メソッド

CellReportSetLicense メソッド

オーバーロードの一覧
名前 | 説明
SetLicense(Stream) | ライセンス情報を設定します。
SetLicense(String) | ライセンス情報を設定します。
トップ
関連項目

参照

CellReport クラス


CellReport.SetLicense メソッド (Stream)

CellReportSetLicense メソッド (Stream)

ライセンス情報を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void SetLicense(
    Stream stream
)
Public Sub SetLicense (
    stream As Stream
)

パラメーター

stream
型: System.IOStream
ライセンスファイルのストリーム
解説
SetLicense メソッドはコンポーネントのインスタンスごとに 1 回呼び出すのみで問題なく、帳票出力のたびに呼び出す必要はありません。
例
C#
VB
コピー
// ライセンス情報を設定します。
cellReport1.SetLicense(licenseStream);
// 複数のブックを作成します。
for (int i = 0; i < 5; i++)
{
    // ここで毎回呼び出す必要はありません。
    //cellReport1.SetLicense(licenseStream);

    cellReport1.Report.Start();
    cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2019);
    cellReport1.Page.Start("Sheet1", "1");
    cellReport1.Cell("A1").Value = i;
    cellReport1.Page.End();
    cellReport1.Report.End();
    cellReport1.Report.SaveAs(String.Format(@"C:\Out{0}.xlsx", i));
}
' ライセンス情報を設定します。
CellReport1.SetLicense(licenseStream)
' 複数のブックを作成します。
For i As Integer = 0 To 4
    ' ここで毎回呼び出す必要はありません。
    'CellReport1.SetLicense(licenseStream)

    CellReport1.Report.Start()
    CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2019)
    CellReport1.Page.Start("Sheet1", "1")
    CellReport1.Cell("A1").Value = i
    CellReport1.Page.End()
    CellReport1.Report.End()
    CellReport1.Report.SaveAs(String.Format("C:\Out{0}.xlsx", i))
Next
関連項目

参照

CellReport クラス
SetLicense オーバーロード


CellReport.SetLicense メソッド (String)

CellReportSetLicense メソッド (String)

ライセンス情報を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void SetLicense(
    string path
)
Public Sub SetLicense (
    path As String
)

パラメーター

path
型: SystemString
ライセンスファイルのパス
解説
SetLicense メソッドはコンポーネントのインスタンスごとに 1 回呼び出すのみで問題なく、帳票出力のたびに呼び出す必要はありません。
例
C#
VB
コピー
// ライセンス情報を設定します。
cellReport1.SetLicense(@"C:\AdvanceSoftware.ASReport.License.xml");
// 複数のブックを作成します。
for (int i = 0; i < 5; i++)
{
    // ここで毎回呼び出す必要はありません。
    //cellReport1.SetLicense(@"C:\AdvanceSoftware.ASReport.License.xml");

    cellReport1.Report.Start();
    cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2019);
    cellReport1.Page.Start("Sheet1", "1");
    cellReport1.Cell("A1").Value = i;
    cellReport1.Page.End();
    cellReport1.Report.End();
    cellReport1.Report.SaveAs(String.Format(@"C:\Out{0}.xlsx", i));
}
' ライセンス情報を設定します。
CellReport1.SetLicense("C:\AdvanceSoftware.ASReport.License.xml")
' 複数のブックを作成します。
For i As Integer = 0 To 4
    ' ここで毎回呼び出す必要はありません。
    'CellReport1.SetLicense("C:\AdvanceSoftware.ASReport.License.xml")

    CellReport1.Report.Start()
    CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2019)
    CellReport1.Page.Start("Sheet1", "1")
    CellReport1.Cell("A1").Value = i
    CellReport1.Page.End()
    CellReport1.Report.End()
    CellReport1.Report.SaveAs(String.Format("C:\Out{0}.xlsx", i))
Next
関連項目

参照

CellReport クラス
SetLicense オーバーロード


CellReport.TableRowDelete メソッド

CellReportTableRowDelete メソッド

オーバーロードの一覧
名前 | 説明
TableRowDelete(Int32) | テーブル範囲に含まれる行を削除します。
TableRowDelete(Int32, Int32) | テーブル範囲に含まれる行を削除します。
トップ
関連項目

参照

CellReport クラス


CellReport.TableRowDelete メソッド (Int32)

CellReportTableRowDelete メソッド (Int32)

テーブル範囲に含まれる行を削除します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void TableRowDelete(
    int sy
)
Public Sub TableRowDelete (
    sy As Integer
)

パラメーター

sy
型: SystemInt32
削除する行(0～)を指定します。
解説
Excel で挿入したテーブル内の行を削除します。TableRowDelete、RowDelete メソッド単体では、正しくテーブルの行情報を削除することができないため、 RowDelete メソッドと合わせて使用する必要があります。
例
C#
VB
コピー
// テーブルの 2 行目を削除します。
cellReport1.RowDelete(1);
cellReport1.TableRowDelete(1);
' テーブルの 2 行目を削除します。
CellReport1.RowDelete(1)
CellReport1.TableRowDelete(1)
関連項目

参照

CellReport クラス
TableRowDelete オーバーロード


CellReport.TableRowDelete メソッド (Int32, Int32)

CellReportTableRowDelete メソッド (Int32, Int32)

テーブル範囲に含まれる行を削除します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void TableRowDelete(
    int sy,
    int count
)
Public Sub TableRowDelete (
    sy As Integer,
    count As Integer
)

パラメーター

sy
型: SystemInt32
削除する行(0～)を指定します。
count
型: SystemInt32
削除する行数を指定します。
解説
Excel で挿入したテーブル内の行を削除します。TableRowDelete、RowDelete メソッド単体では、正しくテーブルの行情報を削除することができないため、 RowDelete メソッドと合わせて使用する必要があります。
例
C#
VB
コピー
// テーブルの 2 行目から 5 行分削除します。
cellReport1.RowDelete(1, 5);
cellReport1.TableRowDelete(1, 5);
' テーブルの 2 行目から 5 行分削除します。
CellReport1.RowDelete(1, 5)
CellReport1.TableRowDelete(1, 5)
関連項目

参照

CellReport クラス
TableRowDelete オーバーロード


CellReport.TableRowInsert メソッド

CellReportTableRowInsert メソッド

オーバーロードの一覧
名前 | 説明
TableRowInsert(Int32) | テーブル範囲に行を挿入します。
TableRowInsert(Int32, Int32) | テーブル範囲に行を挿入します。
トップ
関連項目

参照

CellReport クラス


CellReport.TableRowInsert メソッド (Int32)

CellReportTableRowInsert メソッド (Int32)

テーブル範囲に行を挿入します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void TableRowInsert(
    int sy
)
Public Sub TableRowInsert (
    sy As Integer
)

パラメーター

sy
型: SystemInt32
挿入する行(0～)を指定します。
解説
Excel で挿入したテーブル内の行を挿入します。TableRowInsert、RowInsert メソッド単体では、正しくテーブルの行情報を挿入することができないため、 RowInsert メソッドと合わせて使用する必要があります。
例
C#
VB
コピー
// テーブルの 2 行目に 1 行分挿入します。
cellReport1.RowInsert(1);
cellReport1.TableRowInsert(1);
' テーブルの 2 行目に 1 行分挿入します。
CellReport1.RowInsert(1)
CellReport1.TableRowInsert(1)
関連項目

参照

CellReport クラス
TableRowInsert オーバーロード


CellReport.TableRowInsert メソッド (Int32, Int32)

CellReportTableRowInsert メソッド (Int32, Int32)

テーブル範囲に行を挿入します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void TableRowInsert(
    int sy,
    int count
)
Public Sub TableRowInsert (
    sy As Integer,
    count As Integer
)

パラメーター

sy
型: SystemInt32
挿入する行(0～)を指定します。
count
型: SystemInt32
挿入する行数を指定します。
解説
Excel で挿入したテーブル内の行を挿入します。TableRowInsert、RowInsert メソッド単体では、正しくテーブルの行情報を挿入することができないため、 RowInsert メソッドと合わせて使用する必要があります。
例
C#
VB
コピー
// テーブルの 2 行目に 5 行分挿入します。
cellReport1.RowInsert(1, 5);
cellReport1.TableRowInsert(1, 5);
' テーブルの 2 行目に 5 行分挿入します。
CellReport1.RowInsert(1, 5)
CellReport1.TableRowInsert(1, 5)
関連項目

参照

CellReport クラス
TableRowInsert オーバーロード


CellReport.VarCheck メソッド

CellReportVarCheck メソッド

指定した変数名が存在するかをチェックします。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool VarCheck(
    string varName
)
Public Function VarCheck (
    varName As String
) As Boolean

パラメーター

varName
型: SystemString
変数名を指定します。

戻り値

型: Boolean
変数名が存在する場合、true
解説
存在しない変数名セルに書式や値を設定するとエラーが発生するため、あらかじめ、変数名が存在するか確認を行うことができます。
例
C#
VB
コピー
bool varCheck;
// 変数名 "**HENSU1" が存在するかチェックします。
varCheck = cellReport1.VarCheck("**HENSU1");
Dim varCheck As Boolean
' 変数名 "**HENSU1" が存在するかチェックします。
varCheck = CellReport1.VarCheck("**HENSU1")
関連項目

参照

CellReport クラス


CellReport イベント

CellReport 型は下記のメンバーを公開します。

イベント
名前 | 説明
Error | エラー発生時に発生します。
Progress | 処理進行状況の表示時に発生します。
RunPageStart | 帳票ページ処理開始時に発生します。
RunReportStart | 帳票処理開始時に発生します。
SectionEndPage | セクションの終了時に発生します。
SectionNewPage | セクションの開始時に発生します。
トップ
関連項目

参照

CellReport クラス


CellReport.Error イベント

CellReportError イベント

エラー発生時に発生します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public event ReportErrorEventHandler Error
Public Event Error As ReportErrorEventHandler

値

型: AdvanceSoftware.ASReportReportErrorEventHandler
解説
エラー発生時のエラー番号を取得する場合は、ReportErrorEventArgs の ErrorNo プロパティを参照します。
例
C#
VB
コピー
private void InitializeComponent()
{
    cellReport1.Error += new AdvanceSoftware.ASReport.ReportErrorEventHandler(cellReport1_Error);
}
void cellReport1_Error(object sender, AdvanceSoftware.ASReport.ReportErrorEventArgs e)
{
    // エラーナンバーを表示します。
    MessageBox.Show(e.ErrorNo.ToString());
}
Private WithEvents CellReport1 As AdvanceSoftware.ASReport.CellReport = New AdvanceSoftware.ASReport.CellReport()
Private Sub CellReport1_Error(ByVal sender As Object, ByVal e As AdvanceSoftware.ASReport.ReportErrorEventArgs) Handles CellReport1.Error
    ' エラーナンバーを表示します。
    MessageBox.Show(e.ErrorNo.ToString())
End Sub
関連項目

参照

CellReport クラス


CellReport.Progress イベント

CellReportProgress イベント

処理進行状況の表示時に発生します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public event ReportProgressEventHandler Progress
Public Event Progress As ReportProgressEventHandler

値

型: AdvanceSoftware.ASReportReportProgressEventHandler
解説
ユーザー独自の処理進行状況の表示を行う場合に、このイベントで制御を行います。 現在の処理状況を取得する場合は、ReportProgressEventArgs の各プロパティを参照します。
例
C#
VB
コピー
private void InitializeComponent()
{
    cellReport1.Progress += new AdvanceSoftware.ASReport.ReportProgressEventHandler(cellReport1_Progress);
}
void cellReport1_Progress(object sender, AdvanceSoftware.ASReport.ReportProgressEventArgs e)
{
    // 現在のページ数を表示します。
    MessageBox.Show(e.Count.ToString());
}
Private WithEvents CellReport1 As AdvanceSoftware.ASReport.CellReport = New AdvanceSoftware.ASReport.CellReport()
Private Sub CellReport1_Progress(ByVal sender As Object, ByVal e As AdvanceSoftware.ASReport.ReportProgressEventArgs) Handles CellReport1.Progress
    ' 現在のページ数を表示します。
    MessageBox.Show(e.Count.ToString())
End Sub
関連項目

参照

CellReport クラス


CellReport.RunPageStart イベント

CellReportRunPageStart イベント

帳票ページ処理開始時に発生します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public event RunPageStartEventHandler RunPageStart
Public Event RunPageStart As RunPageStartEventHandler

値

型: AdvanceSoftware.ASReportRunPageStartEventHandler
解説
帳票ページ処理開始時に実行されます。
例
C#
VB
コピー
void cellReport1_RunPageStart(object sender, AdvanceSoftware.ASReport.RunPageStartEventArgs e)
{
    // ページ番号を表示します。
    MessageBox.Show(e.PageNo.ToString());
}
Private Sub CellReport1_RunPageStart(ByVal sender As Object, ByVal e As AdvanceSoftware.ASReport.RunPageStartEventArgs) Handles CellReport1.RunPageStart
    ' ページ番号を表示します。
    MessageBox.Show(e.PageNo.ToString())
End Sub
関連項目

参照

CellReport クラス


CellReport.RunReportStart イベント

CellReportRunReportStart イベント

帳票処理開始時に発生します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public event RunReportStartEventHandler RunReportStart
Public Event RunReportStart As RunReportStartEventHandler

値

型: AdvanceSoftware.ASReportRunReportStartEventHandler
解説
帳票処理開始時に実行されます。
例
C#
VB
コピー
void cellReport1_RunReportStart(object sender, EventArgs e)
{
    MessageBox.Show("帳票処理を開始します。");
}
Private Sub CellReport1_RunReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles CellReport1.RunReportStart
    MessageBox.Show("帳票処理を開始します。")
End Sub
関連項目

参照

CellReport クラス


CellReport.SectionEndPage イベント

CellReportSectionEndPage イベント

セクションの終了時に発生します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public event SectionEndPageEventHandler SectionEndPage
Public Event SectionEndPage As SectionEndPageEventHandler

値

型: AdvanceSoftware.ASReportSectionEndPageEventHandler
解説
フッターに値を設定する場合、SectionEndPageEventHandler の Footer プロパティを使用します。
例
C#
VB
コピー
private void InitializeComponent()
{
    cellReport1.SectionEndPage += new AdvanceSoftware.ASReport.SectionEndPageEventHandler(cellReport1_SectionEndPage);
}
void cellReport1_SectionEndPage(object sender, AdvanceSoftware.ASReport.SectionEndPageEventArgs e)
{
    // フッターの D6 セルに文字列 "アドバンスソフトウェア" を設定します。
    e.Footer.Cell("D6").Value = "アドバンスソフトウェア";
}
Private WithEvents CellReport1 As AdvanceSoftware.ASReport.CellReport = New AdvanceSoftware.ASReport.CellReport()
Private Sub CellReport1_SectionEndPage(ByVal sender As Object, ByVal e As AdvanceSoftware.ASReport.SectionEndPageEventArgs) Handles CellReport1.SectionEndPage
    ' フッターの D6 セルに文字列 "アドバンスソフトウェア" を設定します。
    e.Footer.Cell("D6").Value = "アドバンスソフトウェア"
End Sub
関連項目

参照

CellReport クラス


CellReport.SectionNewPage イベント

CellReportSectionNewPage イベント

セクションの開始時に発生します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public event SectionNewPageEventHandler SectionNewPage
Public Event SectionNewPage As SectionNewPageEventHandler

値

型: AdvanceSoftware.ASReportSectionNewPageEventHandler
解説
ヘッダーに値を設定する場合、SectionNewPageEventHandler の Header プロパティを使用します。
例
C#
VB
コピー
private void InitializeComponent()
{
    cellReport1.SectionNewPage += new AdvanceSoftware.ASReport.SectionNewPageEventHandler(cellReport1_SectionNewPage);
}
void cellReport1_SectionNewPage(object sender, AdvanceSoftware.ASReport.SectionNewPageEventArgs e)
{
    // ヘッダーの D3 セルに文字列 "アドバンスソフトウェア" を設定します。
    e.Header.Cell("D3").Value = "アドバンスソフトウェア";
}
Private WithEvents CellReport1 As AdvanceSoftware.ASReport.CellReport = New AdvanceSoftware.ASReport.CellReport()
Private Sub CellReport1_SectionNewPage(ByVal sender As Object, ByVal e As AdvanceSoftware.ASReport.SectionNewPageEventArgs) Handles CellReport1.SectionNewPage
    ' ヘッダーの D3 セルに文字列 "アドバンスソフトウェア" を設定します。
    e.Header.Cell("D3").Value = "アドバンスソフトウェア"
End Sub
関連項目

参照

CellReport クラス


DocumentStatus 列挙体

ドキュメントの状態を示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Document (in AdvanceSoftware.ASReport.Document.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum DocumentStatus
Public Enumeration DocumentStatus
メンバー
メンバー | 値 | 説明
Idling | 0 | 待機中
Running | 1 | レポート処理中
Printing | 2 | 印刷中
Saving | 3 | 保存中
関連項目

参照


DoubleCellValueMode 列挙体

浮動小数点数値をセルに格納する方法を示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum DoubleCellValueMode
Public Enumeration DoubleCellValueMode
メンバー
メンバー | 値 | 説明
Legacy | 0 | 有効桁数15桁の精度で数値文字列を格納
G17 | 1 | IEEE754-2008に準拠した文字列表現で数値文字列を格納
関連項目

参照


Drawing クラス

帳票にイメージファイルや図形を設定します。レポートコンポーネントを通じてこのクラスにアクセスします。
継承階層
SystemObject
AdvanceSoftware.ASReportDrawing

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Drawing
Public Class Drawing

Drawing 型は下記のメンバーを公開します。

プロパティ
名前 | 説明
ArrowTypeE | 矢印の終点のスタイル、サイズを設定します。
ArrowTypeS | 矢印の始点のスタイル、サイズを設定します。
FillColor | 塗りつぶし色を設定します。
FillColor2 | 塗りつぶし色を設定します。
FontColor | テキストボックスのフォントの色を設定します。(xlsx 形式のみ)
FontColor2 | テキストボックスのフォントの色を設定します。
FontName | テキストボックスのフォント名を設定します。
FontPoint | テキストボックスのフォントサイズを設定します。
FontStyle | テキストボックスのフォントスタイルを設定します。
FontULine | テキストボックスのフォントの下線を設定します。
LineColor | 線の色を設定します。(xlsx 形式のみ)
LineColor2 | 線の色を設定します。
LineStyle | 線種を設定します。
LineWeight | 線の太さを設定します。
ShapeNoFill | オートシェイプ・テキストボックスの「塗りつぶしなし」を設定します。
TextAlign | テキストボックスの水平方向の文字位置を設定します。
TextAnchor | テキストボックスの垂直方向の文字位置を設定します。
TextVertical | テキストボックスの文字の回転を設定します。
トップ
メソッド
名前 | 説明
AddImage(Image) | イメージを設定します。
AddImage(Metafile) | イメージを設定します。
AddImage(String) | イメージを設定します。
AddImage(Image, Double, Double) | イメージを設定します。
AddImage(Metafile, Double, Double) | イメージを設定します。
AddImage(String, Double, Double) | イメージを設定します。
AddImage(Image, Double, Double, Double, Double) | イメージを設定します。
AddImage(Metafile, Double, Double, Double, Double) | イメージを設定します。
AddImage(String, Double, Double, Double, Double) | イメージを設定します。
AddImage(Image, Double, Double, Double, Double, Double, Double) | イメージを設定します。
AddImage(Metafile, Double, Double, Double, Double, Double, Double) | イメージを設定します。
AddImage(String, Double, Double, Double, Double, Double, Double) | イメージを設定します。
AddLine(ShapeType) | 線を設定します。
AddLine(ShapeType, Double, Double) | 線を設定します。
AddLine(ShapeType, Double, Double, Double, Double) | 線を設定します。
AddLine(ShapeType, Double, Double, Double, Double, Double, Double) | 線を設定します。
AddShape(ShapeType) | オートシェイプを設定します。
AddShape(ShapeType, Double, Double) | オートシェイプを設定します。
AddShape(ShapeType, Double, Double, Double, Double) | オートシェイプを設定します。
AddShape(ShapeType, Double, Double, Double, Double, Double, Double) | オートシェイプを設定します。
AddTextBox(ShapeType, String) | テキストボックスを設定します。
AddTextBox(ShapeType, String, Double, Double) | テキストボックスを設定します。
AddTextBox(ShapeType, String, Double, Double, Double, Double) | テキストボックスを設定します。
AddTextBox(ShapeType, String, Double, Double, Double, Double, Double, Double) | テキストボックスを設定します。
Init | 初期処理を行います。
トップ
関連項目

参照


Drawing プロパティ

Drawing 型は下記のメンバーを公開します。

プロパティ
名前 | 説明
ArrowTypeE | 矢印の終点のスタイル、サイズを設定します。
ArrowTypeS | 矢印の始点のスタイル、サイズを設定します。
FillColor | 塗りつぶし色を設定します。
FillColor2 | 塗りつぶし色を設定します。
FontColor | テキストボックスのフォントの色を設定します。(xlsx 形式のみ)
FontColor2 | テキストボックスのフォントの色を設定します。
FontName | テキストボックスのフォント名を設定します。
FontPoint | テキストボックスのフォントサイズを設定します。
FontStyle | テキストボックスのフォントスタイルを設定します。
FontULine | テキストボックスのフォントの下線を設定します。
LineColor | 線の色を設定します。(xlsx 形式のみ)
LineColor2 | 線の色を設定します。
LineStyle | 線種を設定します。
LineWeight | 線の太さを設定します。
ShapeNoFill | オートシェイプ・テキストボックスの「塗りつぶしなし」を設定します。
TextAlign | テキストボックスの水平方向の文字位置を設定します。
TextAnchor | テキストボックスの垂直方向の文字位置を設定します。
TextVertical | テキストボックスの文字の回転を設定します。
トップ
関連項目

参照

Drawing クラス


Drawing.ArrowTypeE プロパティ

DrawingArrowTypeE プロパティ

矢印の終点のスタイル、サイズを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ArrowType ArrowTypeE { set; }
Public WriteOnly Property ArrowTypeE As ArrowType
    Set

プロパティ値

型: ArrowType
矢印の終点のスタイル、サイズを表す ArrowType。
例
C#
VB
コピー
// 矢印の始点のスタイル、サイズを "ひし形、短い" に設定します。
cellReport1.Cell("A1").Drawing.ArrowTypeS = AdvanceSoftware.ASReport.ArrowType.Diamond | AdvanceSoftware.ASReport.ArrowType.Short;
// 矢印の終点のスタイル、サイズを "三角形、長い" に設定します。
cellReport1.Cell("A1").Drawing.ArrowTypeE = AdvanceSoftware.ASReport.ArrowType.Triangle | AdvanceSoftware.ASReport.ArrowType.Long;
// A1 セルに "直線" を設定します。
cellReport1.Cell("A1").Drawing.AddLine(AdvanceSoftware.ASReport.ShapeType.Line);
' 矢印の始点のスタイル、サイズを "ひし形、短い" に設定します。
CellReport1.Cell("A1").Drawing.ArrowTypeS = AdvanceSoftware.ASReport.ArrowType.Diamond Or AdvanceSoftware.ASReport.ArrowType.Short
' 矢印の終点のスタイル、サイズを "三角形、長い" に設定します。
CellReport1.Cell("A1").Drawing.ArrowTypeE = AdvanceSoftware.ASReport.ArrowType.Triangle Or AdvanceSoftware.ASReport.ArrowType.Long
' A1 セルに "直線" を設定します。
CellReport1.Cell("A1").Drawing.AddLine(AdvanceSoftware.ASReport.ShapeType.Line)
関連項目

参照

Drawing クラス


Drawing.ArrowTypeS プロパティ

DrawingArrowTypeS プロパティ

矢印の始点のスタイル、サイズを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ArrowType ArrowTypeS { set; }
Public WriteOnly Property ArrowTypeS As ArrowType
    Set

プロパティ値

型: ArrowType
矢印の始点のスタイル、サイズを表す ArrowType。
例
C#
VB
コピー
// 矢印の始点のスタイル、サイズを "ひし形、短い" に設定します。
cellReport1.Cell("A1").Drawing.ArrowTypeS = AdvanceSoftware.ASReport.ArrowType.Diamond | AdvanceSoftware.ASReport.ArrowType.Short;
// 矢印の終点のスタイル、サイズを "三角形、長い" に設定します。
cellReport1.Cell("A1").Drawing.ArrowTypeE = AdvanceSoftware.ASReport.ArrowType.Triangle | AdvanceSoftware.ASReport.ArrowType.Long;
// A1 セルに "直線" を設定します。
cellReport1.Cell("A1").Drawing.AddLine(AdvanceSoftware.ASReport.ShapeType.Line);
' 矢印の始点のスタイル、サイズを "ひし形、短い" に設定します。
CellReport1.Cell("A1").Drawing.ArrowTypeS = AdvanceSoftware.ASReport.ArrowType.Diamond Or AdvanceSoftware.ASReport.ArrowType.Short
' 矢印の終点のスタイル、サイズを "三角形、長い" に設定します。
CellReport1.Cell("A1").Drawing.ArrowTypeE = AdvanceSoftware.ASReport.ArrowType.Triangle Or AdvanceSoftware.ASReport.ArrowType.Long
' A1 セルに "直線" を設定します。
CellReport1.Cell("A1").Drawing.AddLine(AdvanceSoftware.ASReport.ShapeType.Line)
関連項目

参照

Drawing クラス


Drawing.FillColor プロパティ

DrawingFillColor プロパティ

塗りつぶし色を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color FillColor { set; }
Public WriteOnly Property FillColor As Color
    Set

プロパティ値

型: Color
シェイプの塗りつぶし色を表す Color 構造体。
例
C#
VB
コピー
// オートシェイプの塗りつぶし色を "青色" に設定します。
cellReport1.Cell("A1").Drawing.FillColor = System.Drawing.Color.Blue;
// A1 セルにオートシェイプ "円/楕円" を設定します。
cellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse);
' オートシェイプの塗りつぶし色を "青色" に設定します。
CellReport1.Cell("A1").Drawing.FillColor = System.Drawing.Color.Blue
' A1 セルにオートシェイプ "円/楕円" を設定します。
CellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse)
関連項目

参照

Drawing クラス


Drawing.FillColor2 プロパティ

DrawingFillColor2 プロパティ

塗りつぶし色を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public xlColor FillColor2 { set; }
Public WriteOnly Property FillColor2 As xlColor
    Set

プロパティ値

型: xlColor
シェイプの塗りつぶし色を表す xlColor 列挙体。
例
C#
VB
コピー
// オートシェイプの塗りつぶし色を "青色" に設定します。
cellReport1.Cell("A1").Drawing.FillColor2 = AdvanceSoftware.ASReport.xlColor.Blue;
// A1 セルにオートシェイプ "円/楕円" を設定します。
cellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse);
' オートシェイプの塗りつぶし色を "青色" に設定します。
CellReport1.Cell("A1").Drawing.FillColor2 = AdvanceSoftware.ASReport.xlColor.Blue
' A1 セルにオートシェイプ "円/楕円" を設定します。
CellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse)
関連項目

参照

Drawing クラス


Drawing.FontColor プロパティ

DrawingFontColor プロパティ

テキストボックスのフォントの色を設定します。(xlsx 形式のみ)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color FontColor { set; }
Public WriteOnly Property FontColor As Color
    Set

プロパティ値

型: Color
テキストボックスのフォントカラーを表す Color 構造体。
解説
xlsx 形式のファイルでのみ設定可能です。
例
C#
VB
コピー
// テキストボックスのフォントの色を "赤色" に設定します。
cellReport1.Cell("A1").Drawing.FontColor = System.Drawing.Color.Red;
// A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア");
' テキストボックスのフォントの色を "赤色" に設定します。
CellReport1.Cell("A1").Drawing.FontColor = System.Drawing.Color.Red
' A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア")
関連項目

参照

Drawing クラス


Drawing.FontColor2 プロパティ

DrawingFontColor2 プロパティ

テキストボックスのフォントの色を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public xlColor FontColor2 { set; }
Public WriteOnly Property FontColor2 As xlColor
    Set

プロパティ値

型: xlColor
テキストボックスのフォントカラーを表す xlColor 列挙体。
例
C#
VB
コピー
// テキストボックスのフォントの色を "赤色" に設定します。
cellReport1.Cell("A1").Drawing.FontColor2 = AdvanceSoftware.ASReport.xlColor.Red;
// A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア");
' テキストボックスのフォントの色を "赤色" に設定します。
CellReport1.Cell("A1").Drawing.FontColor2 = AdvanceSoftware.ASReport.xlColor.Red
' A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア")
関連項目

参照

Drawing クラス


Drawing.FontName プロパティ

DrawingFontName プロパティ

テキストボックスのフォント名を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string FontName { set; }
Public WriteOnly Property FontName As String
    Set

プロパティ値

型: String
テキストボックスのフォント名。
例
C#
VB
コピー
// テキストボックスのフォント名を "ＭＳ 明朝" に設定します。
cellReport1.Cell("A1").Drawing.FontName = "ＭＳ 明朝";
// A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア");
' テキストボックスのフォント名を "ＭＳ 明朝" に設定します。
CellReport1.Cell("A1").Drawing.FontName = "ＭＳ 明朝"
' A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア")
関連項目

参照

Drawing クラス


Drawing.FontPoint プロパティ

DrawingFontPoint プロパティ

テキストボックスのフォントサイズを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double FontPoint { set; }
Public WriteOnly Property FontPoint As Double
    Set

プロパティ値

型: Double
テキストボックスのフォントサイズ(ポイント単位)。
例
C#
VB
コピー
// テキストボックスのフォントサイズを "20" に設定します。
cellReport1.Cell("A1").Drawing.FontPoint = 20;
// A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア");
' テキストボックスのフォントサイズを "20" に設定します。
CellReport1.Cell("A1").Drawing.FontPoint = 20
' A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア")
関連項目

参照

Drawing クラス


Drawing.FontStyle プロパティ

DrawingFontStyle プロパティ

テキストボックスのフォントスタイルを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextBoxFontStyle FontStyle { set; }
Public WriteOnly Property FontStyle As TextBoxFontStyle
    Set

プロパティ値

型: TextBoxFontStyle
テキストボックスのフォントスタイルを表す TextBoxFontStyle。
例
C#
VB
コピー
// テキストボックスのフォントスタイルを "太字" に設定します。
cellReport1.Cell("A1").Drawing.FontStyle = AdvanceSoftware.ASReport.TextBoxFontStyle.Bold;
// A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア");
' テキストボックスのフォントスタイルを "太字" に設定します。
CellReport1.Cell("A1").Drawing.FontStyle = AdvanceSoftware.ASReport.TextBoxFontStyle.Bold
' A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア")
関連項目

参照

Drawing クラス


Drawing.FontULine プロパティ

DrawingFontULine プロパティ

テキストボックスのフォントの下線を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public FontULine FontULine { set; }
Public WriteOnly Property FontULine As FontULine
    Set

プロパティ値

型: FontULine
テキストボックスのフォント下線を表す FontULine。
例
C#
VB
コピー
// テキストボックスのフォントの下線を "標準" に設定します。
cellReport1.Cell("A1").Drawing.FontULine = AdvanceSoftware.ASReport.FontULine.Normal;
// A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア");
' テキストボックスのフォントの下線を "標準" に設定します。
CellReport1.Cell("A1").Drawing.FontULine = AdvanceSoftware.ASReport.FontULine.Normal
' A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア")
関連項目

参照

Drawing クラス


Drawing.LineColor プロパティ

DrawingLineColor プロパティ

線の色を設定します。(xlsx 形式のみ)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color LineColor { set; }
Public WriteOnly Property LineColor As Color
    Set

プロパティ値

型: Color
線の色を表す Color 構造体。
解説
xlsx 形式のファイルでのみ設定可能です。
例
C#
VB
コピー
// 線の色を "赤色" に設定します。
cellReport1.Cell("A1").Drawing.LineColor = System.Drawing.Color.Red;
// A1 セルにオートシェイプ "円/楕円" を設定します。
cellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse);
' 線の色を "赤色" に設定します。
CellReport1.Cell("A1").Drawing.LineColor = System.Drawing.Color.Red
' A1 セルにオートシェイプ "円/楕円" を設定します。
CellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse)
関連項目

参照

Drawing クラス


Drawing.LineColor2 プロパティ

DrawingLineColor2 プロパティ

線の色を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public xlColor LineColor2 { set; }
Public WriteOnly Property LineColor2 As xlColor
    Set

プロパティ値

型: xlColor
線の色を表す xlColor 列挙体。
例
C#
VB
コピー
// 線の色を "赤色" に設定します。
cellReport1.Cell("A1").Drawing.LineColor2 = AdvanceSoftware.ASReport.xlColor.Red;
// A1 セルにオートシェイプ "円/楕円" を設定します。
cellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse);
' 線の色を "赤色" に設定します。
CellReport1.Cell("A1").Drawing.LineColor2 = AdvanceSoftware.ASReport.xlColor.Red
' A1 セルにオートシェイプ "円/楕円" を設定します。
CellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse)
関連項目

参照

Drawing クラス


Drawing.LineStyle プロパティ

DrawingLineStyle プロパティ

線種を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LineStyle LineStyle { set; }
Public WriteOnly Property LineStyle As LineStyle
    Set

プロパティ値

型: LineStyle
線種を表す LineStyle。
例
C#
VB
コピー
// 線の種類を "二重線" に設定します。
cellReport1.Cell("A1").Drawing.LineStyle = AdvanceSoftware.ASReport.LineStyle.Double;
// A1 セルにオートシェイプ "円/楕円" を設定します。
cellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse);
// 線の種類を "角点線、上が太い二重線" に設定します。
cellReport1.Cell("A10").Drawing.LineStyle = AdvanceSoftware.ASReport.LineStyle.SysDash | AdvanceSoftware.ASReport.LineStyle.ThickThin;
// A10 セルにオートシェイプ "角丸四角形" を設定します。
cellReport1.Cell("A10").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.RoundRect);
' 線の種類を "二重線" に設定します。
CellReport1.Cell("A1").Drawing.LineStyle = AdvanceSoftware.ASReport.LineStyle.Double
' A1 セルにオートシェイプ "円/楕円" を設定します。
CellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse)
' 線の種類を "角点線、上が太い二重線" に設定します。
CellReport1.Cell("A10").Drawing.LineStyle = AdvanceSoftware.ASReport.LineStyle.SysDash Or AdvanceSoftware.ASReport.LineStyle.ThickThin
' A10 セルにオートシェイプ "角丸四角形" を設定します。
CellReport1.Cell("A10").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.RoundRect)
関連項目

参照

Drawing クラス


Drawing.LineWeight プロパティ

DrawingLineWeight プロパティ

線の太さを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double LineWeight { set; }
Public WriteOnly Property LineWeight As Double
    Set

プロパティ値

型: Double
線の太さ。
例
C#
VB
コピー
// 線の太さを 5 に設定します。
cellReport1.Cell("A1").Drawing.LineWeight = 5;
// A1 セルにオートシェイプ "円/楕円" を設定します。
cellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse);
' 線の太さを 5 に設定します。
CellReport1.Cell("A1").Drawing.LineWeight = 5
' A1 セルにオートシェイプ "円/楕円" を設定します。
CellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse)
関連項目

参照

Drawing クラス


Drawing.ShapeNoFill プロパティ

DrawingShapeNoFill プロパティ

オートシェイプ・テキストボックスの「塗りつぶしなし」を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShapeNoFill { set; }
Public WriteOnly Property ShapeNoFill As Boolean
    Set

プロパティ値

型: Boolean
true : 塗りつぶしなし(xlsx 既定値)、false : 塗りつぶしあり(xls 既定値)。
例
C#
VB
コピー
// オートシェイプを "塗りつぶしあり" に設定します。
cellReport1.Cell("A1").Drawing.ShapeNoFill = false;
// A1 セルにオートシェイプ "円/楕円" を設定します。
cellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse);
' オートシェイプを "塗りつぶしあり" に設定します。
CellReport1.Cell("A1").Drawing.ShapeNoFill = False
' A1 セルにオートシェイプ "円/楕円" を設定します。
CellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse)
関連項目

参照

Drawing クラス


Drawing.TextAlign プロパティ

DrawingTextAlign プロパティ

テキストボックスの水平方向の文字位置を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextAlign TextAlign { set; }
Public WriteOnly Property TextAlign As TextAlign
    Set

プロパティ値

型: TextAlign
テキストの水平方向の文字位置を表す TextAlign。
例
C#
VB
コピー
// テキストボックスの水平方向の文字位置を "中央揃え" に設定します。
cellReport1.Cell("A1").Drawing.TextAlign = AdvanceSoftware.ASReport.TextAlign.Center;
// A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア");
' テキストボックスの水平方向の文字位置を "中央揃え" に設定します。
CellReport1.Cell("A1").Drawing.TextAlign = AdvanceSoftware.ASReport.TextAlign.Center
' A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア")
関連項目

参照

Drawing クラス


Drawing.TextAnchor プロパティ

DrawingTextAnchor プロパティ

テキストボックスの垂直方向の文字位置を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextAnchor TextAnchor { set; }
Public WriteOnly Property TextAnchor As TextAnchor
    Set

プロパティ値

型: TextAnchor
テキストの垂直方向の文字位置を表す TextAnchor。
例
C#
VB
コピー
// テキストボックスの垂直方向の文字位置を "中央揃え" に設定します。
cellReport1.Cell("A1").Drawing.TextAnchor = AdvanceSoftware.ASReport.TextAnchor.Center;
// A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア");
' テキストボックスの垂直方向の文字位置を "中央揃え" に設定します。
CellReport1.Cell("A1").Drawing.TextAnchor = AdvanceSoftware.ASReport.TextAnchor.Center
' A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア")
関連項目

参照

Drawing クラス


Drawing.TextVertical プロパティ

DrawingTextVertical プロパティ

テキストボックスの文字の回転を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextVertical TextVertical { set; }
Public WriteOnly Property TextVertical As TextVertical
    Set

プロパティ値

型: TextVertical
テキストの回転を表す TextVertical。
例
C#
VB
コピー
// テキストボックスの文字列の方向を "縦書き" に設定します。
cellReport1.Cell("A1").Drawing.TextVertical = AdvanceSoftware.ASReport.TextVertical.EaVert;
// A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア");
' テキストボックスの文字列の方向を "縦書き" に設定します。
CellReport1.Cell("A1").Drawing.TextVertical = AdvanceSoftware.ASReport.TextVertical.EaVert
' A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア")
関連項目

参照

Drawing クラス


Drawing メソッド

Drawing 型は下記のメンバーを公開します。

メソッド
名前 | 説明
AddImage(Image) | イメージを設定します。
AddImage(Metafile) | イメージを設定します。
AddImage(String) | イメージを設定します。
AddImage(Image, Double, Double) | イメージを設定します。
AddImage(Metafile, Double, Double) | イメージを設定します。
AddImage(String, Double, Double) | イメージを設定します。
AddImage(Image, Double, Double, Double, Double) | イメージを設定します。
AddImage(Metafile, Double, Double, Double, Double) | イメージを設定します。
AddImage(String, Double, Double, Double, Double) | イメージを設定します。
AddImage(Image, Double, Double, Double, Double, Double, Double) | イメージを設定します。
AddImage(Metafile, Double, Double, Double, Double, Double, Double) | イメージを設定します。
AddImage(String, Double, Double, Double, Double, Double, Double) | イメージを設定します。
AddLine(ShapeType) | 線を設定します。
AddLine(ShapeType, Double, Double) | 線を設定します。
AddLine(ShapeType, Double, Double, Double, Double) | 線を設定します。
AddLine(ShapeType, Double, Double, Double, Double, Double, Double) | 線を設定します。
AddShape(ShapeType) | オートシェイプを設定します。
AddShape(ShapeType, Double, Double) | オートシェイプを設定します。
AddShape(ShapeType, Double, Double, Double, Double) | オートシェイプを設定します。
AddShape(ShapeType, Double, Double, Double, Double, Double, Double) | オートシェイプを設定します。
AddTextBox(ShapeType, String) | テキストボックスを設定します。
AddTextBox(ShapeType, String, Double, Double) | テキストボックスを設定します。
AddTextBox(ShapeType, String, Double, Double, Double, Double) | テキストボックスを設定します。
AddTextBox(ShapeType, String, Double, Double, Double, Double, Double, Double) | テキストボックスを設定します。
Init | 初期処理を行います。
トップ
関連項目

参照

Drawing クラス


Drawing.AddImage メソッド

DrawingAddImage メソッド

オーバーロードの一覧
名前 | 説明
AddImage(Image) | イメージを設定します。
AddImage(Metafile) | イメージを設定します。
AddImage(String) | イメージを設定します。
AddImage(Image, Double, Double) | イメージを設定します。
AddImage(Metafile, Double, Double) | イメージを設定します。
AddImage(String, Double, Double) | イメージを設定します。
AddImage(Image, Double, Double, Double, Double) | イメージを設定します。
AddImage(Metafile, Double, Double, Double, Double) | イメージを設定します。
AddImage(String, Double, Double, Double, Double) | イメージを設定します。
AddImage(Image, Double, Double, Double, Double, Double, Double) | イメージを設定します。
AddImage(Metafile, Double, Double, Double, Double, Double, Double) | イメージを設定します。
AddImage(String, Double, Double, Double, Double, Double, Double) | イメージを設定します。
トップ
関連項目

参照

Drawing クラス


Drawing.AddImage メソッド (Image)

DrawingAddImage メソッド (Image)

イメージを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    Image image
)
Public Sub AddImage (
    image As Image
)

パラメーター

image
型: System.DrawingImage
イメージクラスを設定します。
例
C#
VB
コピー
System.Drawing.Image image = System.Drawing.Image.FromFile(@"C:\image.bmp");
// A1 セルに画像を設定します。
cellReport1.Cell("A1").Drawing.AddImage(image);
Dim image As System.Drawing.Image = System.Drawing.Image.FromFile("C:\image.bmp")
' A1 セルに画像を設定します。
CellReport1.Cell("A1").Drawing.AddImage(image)
関連項目

参照

Drawing クラス
AddImage オーバーロード


Drawing.AddImage メソッド (Metafile)

DrawingAddImage メソッド (Metafile)

イメージを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    Metafile metafile
)
Public Sub AddImage (
    metafile As Metafile
)

パラメーター

metafile
型: System.Drawing.ImagingMetafile
メタファイルクラスを設定します。
例
C#
VB
コピー
System.Drawing.Imaging.Metafile metafile = new System.Drawing.Imaging.Metafile(@"C:\image.emf");
// A1 セルに画像を設定します。
cellReport1.Cell("A1").Drawing.AddImage(metafile);
Dim metafile As System.Drawing.Imaging.Metafile = New System.Drawing.Imaging.Metafile("C:\image.emf")
' A1 セルに画像を設定します。
CellReport1.Cell("A1").Drawing.AddImage(metafile)
関連項目

参照

Drawing クラス
AddImage オーバーロード


Drawing.AddImage メソッド (String)

DrawingAddImage メソッド (String)

イメージを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    string fileName
)
Public Sub AddImage (
    fileName As String
)

パラメーター

fileName
型: SystemString
イメージのファイル名を設定します。
例
C#
VB
コピー
// A1 セルに画像を設定します。
cellReport1.Cell("A1").Drawing.AddImage(@"C:\image.bmp");
' A1 セルに画像を設定します。
CellReport1.Cell("A1").Drawing.AddImage("C:\image.bmp")
関連項目

参照

Drawing クラス
AddImage オーバーロード


Drawing.AddImage メソッド (Image, Double, Double)

DrawingAddImage メソッド (Image, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    Image image,
    double width,
    double height
)
Public Sub AddImage (
    image As Image,
    width As Double,
    height As Double
)

パラメーター

image
型: System.DrawingImage
イメージクラスを設定します。
width
型: SystemDouble
イメージの幅を設定します。
height
型: SystemDouble
イメージの高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
System.Drawing.Image image = System.Drawing.Image.FromFile(@"C:\image.bmp");
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel;
// A1 セルに画像 (幅：100px、高さ：100px) を設定します。
cellReport1.Cell("A1").Drawing.AddImage(image, 100, 100);
Dim image As System.Drawing.Image = System.Drawing.Image.FromFile("C:\image.bmp")
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel
' A1 セルに画像 (幅：100px、高さ：100px) を設定します。
CellReport1.Cell("A1").Drawing.AddImage(image, 100, 100)
関連項目

参照

Drawing クラス
AddImage オーバーロード


Drawing.AddImage メソッド (Metafile, Double, Double)

DrawingAddImage メソッド (Metafile, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    Metafile metafile,
    double width,
    double height
)
Public Sub AddImage (
    metafile As Metafile,
    width As Double,
    height As Double
)

パラメーター

metafile
型: System.Drawing.ImagingMetafile
メタファイルクラスを設定します。
width
型: SystemDouble
イメージの幅を設定します。
height
型: SystemDouble
イメージの高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
System.Drawing.Imaging.Metafile metafile = new System.Drawing.Imaging.Metafile(@"C:\image.emf");
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel;
// A1 セルに画像 (幅：100px、高さ：100px) を設定します。
cellReport1.Cell("A1").Drawing.AddImage(metafile, 100, 100);
Dim metafile As System.Drawing.Imaging.Metafile = New System.Drawing.Imaging.Metafile("C:\image.emf")
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel
' A1 セルに画像 (幅：100px、高さ：100px) を設定します。
CellReport1.Cell("A1").Drawing.AddImage(metafile, 100, 100)
関連項目

参照

Drawing クラス
AddImage オーバーロード


Drawing.AddImage メソッド (String, Double, Double)

DrawingAddImage メソッド (String, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    string fileName,
    double width,
    double height
)
Public Sub AddImage (
    fileName As String,
    width As Double,
    height As Double
)

パラメーター

fileName
型: SystemString
イメージのファイル名を設定します。
width
型: SystemDouble
イメージの幅を設定します。
height
型: SystemDouble
イメージの高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel;
// A1 セルに画像 (幅：100px、高さ：100px) を設定します。
cellReport1.Cell("A1").Drawing.AddImage(@"C:\image.bmp", 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel
' A1 セルに画像 (幅：100px、高さ：100px) を設定します。
CellReport1.Cell("A1").Drawing.AddImage("C:\image.bmp", 100, 100)
関連項目

参照

Drawing クラス
AddImage オーバーロード


Drawing.AddImage メソッド (Image, Double, Double, Double, Double)

DrawingAddImage メソッド (Image, Double, Double, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    Image image,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff
)
Public Sub AddImage (
    image As Image,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double
)

パラメーター

image
型: System.DrawingImage
イメージクラスを設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
System.Drawing.Image image = System.Drawing.Image.FromFile(@"C:\image.bmp");
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
// の位置に画像を設定します。
cellReport1.Cell("A1").Drawing.AddImage(image, 50, 50, 150, 150);
Dim image As System.Drawing.Image = System.Drawing.Image.FromFile("C:\image.bmp")
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
' の位置に画像を設定します。
CellReport1.Cell("A1").Drawing.AddImage(image, 50, 50, 150, 150)
関連項目

参照

Drawing クラス
AddImage オーバーロード


Drawing.AddImage メソッド (Metafile, Double, Double, Double, Double)

DrawingAddImage メソッド (Metafile, Double, Double, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    Metafile metafile,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff
)
Public Sub AddImage (
    metafile As Metafile,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double
)

パラメーター

metafile
型: System.Drawing.ImagingMetafile
メタファイルクラスを設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
System.Drawing.Imaging.Metafile metafile = new System.Drawing.Imaging.Metafile(@"C:\image.emf");
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
// の位置に画像を設定します。
cellReport1.Cell("A1").Drawing.AddImage(metafile, 50, 50, 150, 150);
Dim metafile As System.Drawing.Imaging.Metafile = New System.Drawing.Imaging.Metafile("C:\image.emf")
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
' の位置に画像を設定します。
CellReport1.Cell("A1").Drawing.AddImage(metafile, 50, 50, 150, 150)
関連項目

参照

Drawing クラス
AddImage オーバーロード


Drawing.AddImage メソッド (String, Double, Double, Double, Double)

DrawingAddImage メソッド (String, Double, Double, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    string fileName,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff
)
Public Sub AddImage (
    fileName As String,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double
)

パラメーター

fileName
型: SystemString
イメージのファイル名を設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
// の位置に画像を設定します。
cellReport1.Cell("A1").Drawing.AddImage(@"C:\image.bmp", 50, 50, 150, 150);
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
' の位置に画像を設定します。
CellReport1.Cell("A1").Drawing.AddImage("C:\image.bmp", 50, 50, 150, 150)
関連項目

参照

Drawing クラス
AddImage オーバーロード


Drawing.AddImage メソッド (Image, Double, Double, Double, Double, Double, Double)

DrawingAddImage メソッド (Image, Double, Double, Double, Double, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    Image image,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff,
    double width,
    double height
)
Public Sub AddImage (
    image As Image,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double,
    width As Double,
    height As Double
)

パラメーター

image
型: System.DrawingImage
イメージクラスを設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
width
型: SystemDouble
イメージの幅を設定します。
height
型: SystemDouble
イメージの高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
System.Drawing.Image image = System.Drawing.Image.FromFile(@"C:\image.bmp");
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から画像 (幅：100px、高さ：100px)
// を設定します。
// 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
cellReport1.Cell("A1").Drawing.AddImage(image, 50, 50, 300, 300, 100, 100);
Dim image As System.Drawing.Image = System.Drawing.Image.FromFile("C:\image.bmp")
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から画像 (幅：100px、高さ：100px)
' を設定します。
' 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
CellReport1.Cell("A1").Drawing.AddImage(image, 50, 50, 300, 300, 100, 100)
関連項目

参照

Drawing クラス
AddImage オーバーロード


Drawing.AddImage メソッド (Metafile, Double, Double, Double, Double, Double, Double)

DrawingAddImage メソッド (Metafile, Double, Double, Double, Double, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    Metafile metafile,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff,
    double width,
    double height
)
Public Sub AddImage (
    metafile As Metafile,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double,
    width As Double,
    height As Double
)

パラメーター

metafile
型: System.Drawing.ImagingMetafile
メタファイルクラスを設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
width
型: SystemDouble
イメージの幅を設定します。
height
型: SystemDouble
イメージの高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
System.Drawing.Imaging.Metafile metafile = new System.Drawing.Imaging.Metafile(@"C:\image.emf");
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から画像 (幅：100px、高さ：100px)
// を設定します。
// 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
cellReport1.Cell("A1").Drawing.AddImage(metafile, 50, 50, 300, 300, 100, 100);
Dim metafile As System.Drawing.Imaging.Metafile = New System.Drawing.Imaging.Metafile("C:\image.emf")
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から画像 (幅：100px、高さ：100px)
' を設定します。
' 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
CellReport1.Cell("A1").Drawing.AddImage(metafile, 50, 50, 300, 300, 100, 100)
関連項目

参照

Drawing クラス
AddImage オーバーロード


Drawing.AddImage メソッド (String, Double, Double, Double, Double, Double, Double)

DrawingAddImage メソッド (String, Double, Double, Double, Double, Double, Double)

イメージを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddImage(
    string fileName,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff,
    double width,
    double height
)
Public Sub AddImage (
    fileName As String,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double,
    width As Double,
    height As Double
)

パラメーター

fileName
型: SystemString
イメージのファイル名を設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
width
型: SystemDouble
イメージの幅を設定します。
height
型: SystemDouble
イメージの高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から画像 (幅：100px、高さ：100px)
// を設定します。
// 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
cellReport1.Cell("A1").Drawing.AddImage(@"C:\image.bmp", 50, 50, 300, 300, 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から画像 (幅：100px、高さ：100px)
' を設定します。
' 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
CellReport1.Cell("A1").Drawing.AddImage("C:\image.bmp", 50, 50, 300, 300, 100, 100)
関連項目

参照

Drawing クラス
AddImage オーバーロード


Drawing.AddLine メソッド

DrawingAddLine メソッド

オーバーロードの一覧
名前 | 説明
AddLine(ShapeType) | 線を設定します。
AddLine(ShapeType, Double, Double) | 線を設定します。
AddLine(ShapeType, Double, Double, Double, Double) | 線を設定します。
AddLine(ShapeType, Double, Double, Double, Double, Double, Double) | 線を設定します。
トップ
関連項目

参照

Drawing クラス


Drawing.AddLine メソッド (ShapeType)

DrawingAddLine メソッド (ShapeType)

線を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddLine(
    ShapeType type
)
Public Sub AddLine (
    type As ShapeType
)

パラメーター

type
型: AdvanceSoftware.ASReportShapeType
線の種類を設定します。
例
C#
VB
コピー
// A1 セルに "直線" を設定します。
cellReport1.Cell("A1").Drawing.AddLine(AdvanceSoftware.ASReport.ShapeType.Line);
' A1 セルに "直線" を設定します。
CellReport1.Cell("A1").Drawing.AddLine(AdvanceSoftware.ASReport.ShapeType.Line)
関連項目

参照

Drawing クラス
AddLine オーバーロード


Drawing.AddLine メソッド (ShapeType, Double, Double)

DrawingAddLine メソッド (ShapeType, Double, Double)

線を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddLine(
    ShapeType type,
    double width,
    double height
)
Public Sub AddLine (
    type As ShapeType,
    width As Double,
    height As Double
)

パラメーター

type
型: AdvanceSoftware.ASReportShapeType
線の種類を設定します。
width
型: SystemDouble
線の領域の幅を設定します。
height
型: SystemDouble
線の領域の高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel;
// A1 セルに "直線 (幅：100px、高さ：100px)" を設定します。
cellReport1.Cell("A1").Drawing.AddLine(AdvanceSoftware.ASReport.ShapeType.Line, 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel
' A1 セルに "直線 (幅：100px、高さ：100px)" を設定します。
CellReport1.Cell("A1").Drawing.AddLine(AdvanceSoftware.ASReport.ShapeType.Line, 100, 100)
関連項目

参照

Drawing クラス
AddLine オーバーロード


Drawing.AddLine メソッド (ShapeType, Double, Double, Double, Double)

DrawingAddLine メソッド (ShapeType, Double, Double, Double, Double)

線を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddLine(
    ShapeType type,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff
)
Public Sub AddLine (
    type As ShapeType,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double
)

パラメーター

type
型: AdvanceSoftware.ASReportShapeType
線の種類を設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
// の位置に "直線" を設定します。
cellReport1.Cell("A1").Drawing.AddLine(AdvanceSoftware.ASReport.ShapeType.Line, 50, 50, 150, 150);
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
' の位置に "直線" を設定します。
CellReport1.Cell("A1").Drawing.AddLine(AdvanceSoftware.ASReport.ShapeType.Line, 50, 50, 150, 150)
関連項目

参照

Drawing クラス
AddLine オーバーロード


Drawing.AddLine メソッド (ShapeType, Double, Double, Double, Double, Double, Double)

DrawingAddLine メソッド (ShapeType, Double, Double, Double, Double, Double, Double)

線を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddLine(
    ShapeType type,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff,
    double width,
    double height
)
Public Sub AddLine (
    type As ShapeType,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double,
    width As Double,
    height As Double
)

パラメーター

type
型: AdvanceSoftware.ASReportShapeType
線の種類を設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
width
型: SystemDouble
線の領域の幅を設定します。
height
型: SystemDouble
線の領域の高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から直線 (幅：100px、高さ：100px)
// を設定します。
// 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
cellReport1.Cell("A1").Drawing.AddLine(AdvanceSoftware.ASReport.ShapeType.Line, 50, 50, 300, 300, 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から直線 (幅：100px、高さ：100px)
' を設定します。
' 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
CellReport1.Cell("A1").Drawing.AddLine(AdvanceSoftware.ASReport.ShapeType.Line, 50, 50, 300, 300, 100, 100)
関連項目

参照

Drawing クラス
AddLine オーバーロード


Drawing.AddShape メソッド

DrawingAddShape メソッド

オーバーロードの一覧
名前 | 説明
AddShape(ShapeType) | オートシェイプを設定します。
AddShape(ShapeType, Double, Double) | オートシェイプを設定します。
AddShape(ShapeType, Double, Double, Double, Double) | オートシェイプを設定します。
AddShape(ShapeType, Double, Double, Double, Double, Double, Double) | オートシェイプを設定します。
トップ
関連項目

参照

Drawing クラス


Drawing.AddShape メソッド (ShapeType)

DrawingAddShape メソッド (ShapeType)

オートシェイプを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddShape(
    ShapeType type
)
Public Sub AddShape (
    type As ShapeType
)

パラメーター

type
型: AdvanceSoftware.ASReportShapeType
オートシェイプの種類を設定します。
例
C#
VB
コピー
// A1 セルにオートシェイプ "円/楕円" を設定します。
cellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse);
' A1 セルにオートシェイプ "円/楕円" を設定します。
CellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse)
関連項目

参照

Drawing クラス
AddShape オーバーロード


Drawing.AddShape メソッド (ShapeType, Double, Double)

DrawingAddShape メソッド (ShapeType, Double, Double)

オートシェイプを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddShape(
    ShapeType type,
    double width,
    double height
)
Public Sub AddShape (
    type As ShapeType,
    width As Double,
    height As Double
)

パラメーター

type
型: AdvanceSoftware.ASReportShapeType
オートシェイプの種類を設定します。
width
型: SystemDouble
オートシェイプの幅を設定します。
height
型: SystemDouble
オートシェイプの高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel;
// A1 セルにオートシェイプ "円/楕円 (幅：100px、高さ：100px)" を設定します。
cellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse, 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel
' A1 セルにオートシェイプ "円/楕円 (幅：100px、高さ：100px)" を設定します。
CellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse, 100, 100)
関連項目

参照

Drawing クラス
AddShape オーバーロード


Drawing.AddShape メソッド (ShapeType, Double, Double, Double, Double)

DrawingAddShape メソッド (ShapeType, Double, Double, Double, Double)

オートシェイプを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddShape(
    ShapeType type,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff
)
Public Sub AddShape (
    type As ShapeType,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double
)

パラメーター

type
型: AdvanceSoftware.ASReportShapeType
オートシェイプの種類を設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
// の位置に "円/楕円" を設定します。
cellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse, 50, 50, 150, 150);
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
' の位置に "円/楕円" を設定します。
CellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse, 50, 50, 150, 150)
関連項目

参照

Drawing クラス
AddShape オーバーロード


Drawing.AddShape メソッド (ShapeType, Double, Double, Double, Double, Double, Double)

DrawingAddShape メソッド (ShapeType, Double, Double, Double, Double, Double, Double)

オートシェイプを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddShape(
    ShapeType type,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff,
    double width,
    double height
)
Public Sub AddShape (
    type As ShapeType,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double,
    width As Double,
    height As Double
)

パラメーター

type
型: AdvanceSoftware.ASReportShapeType
オートシェイプの種類を設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
width
型: SystemDouble
オートシェイプの幅を設定します。
height
型: SystemDouble
オートシェイプの高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から "円/楕円 (幅：100px、高さ：100px)"
// を設定します。
// 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
cellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse, 50, 50, 300, 300, 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から "円/楕円 (幅：100px、高さ：100px)"
' を設定します。
' 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
CellReport1.Cell("A1").Drawing.AddShape(AdvanceSoftware.ASReport.ShapeType.Ellipse, 50, 50, 300, 300, 100, 100)
関連項目

参照

Drawing クラス
AddShape オーバーロード


Drawing.AddTextBox メソッド

DrawingAddTextBox メソッド

オーバーロードの一覧
名前 | 説明
AddTextBox(ShapeType, String) | テキストボックスを設定します。
AddTextBox(ShapeType, String, Double, Double) | テキストボックスを設定します。
AddTextBox(ShapeType, String, Double, Double, Double, Double) | テキストボックスを設定します。
AddTextBox(ShapeType, String, Double, Double, Double, Double, Double, Double) | テキストボックスを設定します。
トップ
関連項目

参照

Drawing クラス


Drawing.AddTextBox メソッド (ShapeType, String)

DrawingAddTextBox メソッド (ShapeType, String)

テキストボックスを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddTextBox(
    ShapeType type,
    string text
)
Public Sub AddTextBox (
    type As ShapeType,
    text As String
)

パラメーター

type
型: AdvanceSoftware.ASReportShapeType
テキストボックスの種類を設定します。
text
型: SystemString
テキストを設定します。
例
C#
VB
コピー
// A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア");
' A1 セルにテキストボックス "円/楕円" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア")
関連項目

参照

Drawing クラス
AddTextBox オーバーロード


Drawing.AddTextBox メソッド (ShapeType, String, Double, Double)

DrawingAddTextBox メソッド (ShapeType, String, Double, Double)

テキストボックスを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddTextBox(
    ShapeType type,
    string text,
    double width,
    double height
)
Public Sub AddTextBox (
    type As ShapeType,
    text As String,
    width As Double,
    height As Double
)

パラメーター

type
型: AdvanceSoftware.ASReportShapeType
テキストボックスの種類を設定します。
text
型: SystemString
テキストを設定します。
width
型: SystemDouble
テキストボックスの幅を設定します。
height
型: SystemDouble
テキストボックスの高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel;
// A1 セルにテキストボックス "円/楕円 (幅：100px、高さ：100px)" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア", 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel
' A1 セルにテキストボックス "円/楕円 (幅：100px、高さ：100px)" を設定し、ボックス内に文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア", 100, 100)
関連項目

参照

Drawing クラス
AddTextBox オーバーロード


Drawing.AddTextBox メソッド (ShapeType, String, Double, Double, Double, Double)

DrawingAddTextBox メソッド (ShapeType, String, Double, Double, Double, Double)

テキストボックスを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddTextBox(
    ShapeType type,
    string text,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff
)
Public Sub AddTextBox (
    type As ShapeType,
    text As String,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double
)

パラメーター

type
型: AdvanceSoftware.ASReportShapeType
テキストボックスの種類を設定します。
text
型: SystemString
テキストを設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
// の位置に "円/楕円" を設定し、ボックス内に文字列"アドバンスソフトウェア" を設定します。
cellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア", 50, 50, 150, 150);
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px)、終了オフセット (150px,150px)
' の位置に "円/楕円" を設定し、ボックス内に文字列"アドバンスソフトウェア" を設定します。
CellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア", 50, 50, 150, 150)
関連項目

参照

Drawing クラス
AddTextBox オーバーロード


Drawing.AddTextBox メソッド (ShapeType, String, Double, Double, Double, Double, Double, Double)

DrawingAddTextBox メソッド (ShapeType, String, Double, Double, Double, Double, Double, Double)

テキストボックスを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void AddTextBox(
    ShapeType type,
    string text,
    double sxoff,
    double syoff,
    double exoff,
    double eyoff,
    double width,
    double height
)
Public Sub AddTextBox (
    type As ShapeType,
    text As String,
    sxoff As Double,
    syoff As Double,
    exoff As Double,
    eyoff As Double,
    width As Double,
    height As Double
)

パラメーター

type
型: AdvanceSoftware.ASReportShapeType
テキストボックスの種類を設定します。
text
型: SystemString
テキストを設定します。
sxoff
型: SystemDouble
セルの左上から横方向への開始オフセットを設定します。
syoff
型: SystemDouble
セルの左上から縦方向への開始オフセットを設定します。
exoff
型: SystemDouble
セルの左上から横方向への終了オフセットを設定します。
eyoff
型: SystemDouble
セルの左上から縦方向への終了オフセットを設定します。
width
型: SystemDouble
テキストボックスの幅を設定します。
height
型: SystemDouble
テキストボックスの高さを設定します。
解説
パラメーターの単位は、ScaleMode プロパティで指定した単位が適用されます。
例
C#
VB
コピー
// スケールモードを "ピクセル(px)" に設定します。
cellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel;
// A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から"円/楕円 (幅：100px、高さ：100px)" を設定し、
// ボックス内に文字列"アドバンスソフトウェア" を設定します。
// 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
cellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア", 50, 50, 300, 300, 100, 100);
' スケールモードを "ピクセル(px)" に設定します。
CellReport1.ScaleMode = AdvanceSoftware.ASReport.ScaleMode.Pixel
' A1 セルの左上を基点とし、開始オフセット (50px,50px) の位置から"円/楕円 (幅：100px、高さ：100px)" を設定し、
' ボックス内に文字列"アドバンスソフトウェア" を設定します。
' 「終了オフセット」と「幅と高さ」では「幅と高さ」が優先されます。
CellReport1.Cell("A1").Drawing.AddTextBox(AdvanceSoftware.ASReport.ShapeType.Ellipse, "アドバンスソフトウェア", 50, 50, 300, 300, 100, 100)
関連項目

参照

Drawing クラス
AddTextBox オーバーロード


Drawing.Init メソッド

DrawingInit メソッド

初期処理を行います。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Init()
Public Sub Init
解説
設定内容をクリア（初期化）します。
例
C#
VB
コピー
// 線の色「青」を設定します。
cellReport1.Cell("F4:G8").Drawing.LineColor = Color.Blue;
// 線の太さ「3」を設定します。
cellReport1.Cell("F4:G8").Drawing.LineWeight = 3;
// 線のスタイル「破線」を設定します。
cellReport1.Cell("F4:G8").Drawing.LineStyle = AdvanceSoftware.ASReport.LineStyle.Dash;
// 線の矢印(始点)「ひし形」「大きく」を設定します。
cellReport1.Cell("F4:G8").Drawing.ArrowTypeS = AdvanceSoftware.ASReport.ArrowType.Diamond | AdvanceSoftware.ASReport.ArrowType.Large;
// 線の矢印(終点)「ライン」「小さく」を設定します。
cellReport1.Cell("F4:G8").Drawing.ArrowTypeE = AdvanceSoftware.ASReport.ArrowType.Arrow | AdvanceSoftware.ASReport.ArrowType.Small;
cellReport1.Cell("F4:G8").Drawing.AddLine(AdvanceSoftware.ASReport.ShapeType.Line);
// シェイプ情報を初期化します。
cellReport1.Cell("F4:G8").Drawing.Init();
// 線の色「赤」を設定します。
cellReport1.Cell("A2:C3").Drawing.LineColor = Color.Red;
// 線の太さ「5」を設定します。
cellReport1.Cell("A2:C3").Drawing.LineWeight = 5;
// 線のスタイル「二重線」を設定します。
cellReport1.Cell("A2:C3").Drawing.LineStyle = AdvanceSoftware.ASReport.LineStyle.Double;
// 線の矢印(始点)「丸」「短い」を設定します。
cellReport1.Cell("A2:C3").Drawing.ArrowTypeS = AdvanceSoftware.ASReport.ArrowType.Oval | AdvanceSoftware.ASReport.ArrowType.Short;
// 線の矢印(終点)「三角形」を設定します。
cellReport1.Cell("A2:C3").Drawing.ArrowTypeE = AdvanceSoftware.ASReport.ArrowType.Triangle;
cellReport1.Cell("A2:C3").Drawing.AddLine(AdvanceSoftware.ASReport.ShapeType.Line);
// シェイプ情報を初期化します。
cellReport1.Cell("A2:C3").Drawing.Init();
' 線の色「青」を設定します。
CellReport1.Cell("F4:G8").Drawing.LineColor = Color.Blue
' 線の太さ「3」を設定します。
CellReport1.Cell("F4:G8").Drawing.LineWeight = 3
' 線のスタイル「破線」を設定します。
CellReport1.Cell("F4:G8").Drawing.LineStyle = AdvanceSoftware.ASReport.LineStyle.Dash
' 線の矢印(始点)「ひし形」「大きく」を設定します。
CellReport1.Cell("F4:G8").Drawing.ArrowTypeS = AdvanceSoftware.ASReport.ArrowType.Diamond Or AdvanceSoftware.ASReport.ArrowType.Small
' 線の矢印(終点)「ライン」「小さく」を設定します。
CellReport1.Cell("F4:G8").Drawing.ArrowTypeE = AdvanceSoftware.ASReport.ArrowType.Arrow Or AdvanceSoftware.ASReport.ArrowType.Small
CellReport1.Cell("F4:G8").Drawing.AddLine(AdvanceSoftware.ASReport.ShapeType.Line)
' シェイプ情報を初期化します。
CellReport1.Cell("F4:G8").Drawing.Init()
' 線の色「赤」を設定します。
CellReport1.Cell("A2:C3").Drawing.LineColor = Color.Red
' 線の太さ「5」を設定します。
CellReport1.Cell("A2:C3").Drawing.LineWeight = 5
' 線のスタイル「二重線」を設定します。
CellReport1.Cell("A2:C3").Drawing.LineStyle = AdvanceSoftware.ASReport.LineStyle.Double
' 線の矢印(始点)「丸」「短い」を設定します。
CellReport1.Cell("A2:C3").Drawing.ArrowTypeS = AdvanceSoftware.ASReport.ArrowType.Oval Or AdvanceSoftware.ASReport.ArrowType.Short
' 線の矢印(終点)「三角形」を設定します。
CellReport1.Cell("A2:C3").Drawing.ArrowTypeE = AdvanceSoftware.ASReport.ArrowType.Triangle
CellReport1.Cell("A2:C3").Drawing.AddLine(AdvanceSoftware.ASReport.ShapeType.Line)
' シェイプ情報を初期化します。
CellReport1.Cell("A2:C3").Drawing.Init()
関連項目

参照

Drawing クラス


ErrorNo 列挙体

エラーナンバーを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ErrorNo
Public Enumeration ErrorNo
メンバー
メンバー | 値 | 説明
NoError | 0 | エラーなし。
CannotOpen | 1 | ファイルがオープンできません。
FileHandle | 2 | 無効なファイルハンドルです。
NotOpen | 3 | 未オープンエラー。
SheetNo | 4 | シートナンバーエラー。
Write | 5 | 書き込みエラー。
Action | 6 | 動作モードエラー。
DataKind | 7 | データ種別エラー。
ErrorValue | 8 | エラー値。
ComboFile | 9 | 複合形式エラー。
Clear | 20 | クリアエラー。
Copy | 21 | コピーエラー。
Paste | 22 | 貼り付けエラー。
Insert | 23 | 挿入エラー。
Delete | 24 | 削除エラー。
Length | 31 | 長さエラー。
Locate | 32 | 座標エラー。
Attr | 33 | 属性番号エラー。
Param | 34 | パラメータエラー。
NoData | 35 | データがありません。
EndOfData | 36 | データの終わりです。
VarPoint | 37 | 指定した変数が存在しません。
BreakCount | 38 | 改ページ数が制限を越えました。
InternalMemory | 40 | 内部メモリエラー。
Memory | 41 | メモリエラー。
Internal | 50 | 内部エラー。
Function | 100 | 計算式形式エラー。
DupOpen | 200 | 既にオープンしています。
NotExcel | 202 | Excel オブジェクトが見つかりません。
ExcelOpen | 203 | Excel がオープンできません。
StartEnd | 204 | Start と End が一致していません。
NotSheet | 205 | 指定したシートが存在しません。
NotPrinter | 213 | 利用可能なプリンタが存在しません。
SaveStop | 214 | 保存を中止しました。
CanvasObject | 215 | 指定したオブジェクトは利用できません。
SaveAbort | 216 | 保存に失敗しました。
NotVariable | 217 | 変数文字列が見つかりません。
PrintStop | 218 | 印刷を中止しました。
PrintAbort | 219 | 印刷に失敗しました。
FileType | 220 | インストールされている Excel のバージョンでは処理できません。
NowPrint | 221 | 印刷中はこの操作は行えません。
RepeatNext | 222 | Repeat と Next が一致していません。
InRepeatNext | 223 | Repeat,Next 中はこのプロパティ、メソッドは使用できません。
Version | 224 | バージョンエラー。
SaveStream | 225 | 保存先ストリームエラー。
SaveDelete | 226 | Excel ファイルの削除に失敗しました。
Start | 227 | Start がコールされていません。
Create | 300 | ファイル作成エラー。
TempCreate | 301 | 一時ファイルが作成できません。
TempOpen | 302 | 一時ファイルがオープンできません。
Stream | 303 | ストリームエラー。
Protect | 304 | 保護されたシートです。
Mutex | 400 | ミューテックスエラー。
MaxFileName | 401 | ファイル名が長すぎます。
InvalidFileName | 402 | 無効なファイル名です。
EmbedFile | 403 | 埋め込みエラー。
UseExcel | 404 | Excel が使用中のため操作できません。
Document | 500 | ドキュメントが作成されていません。
Reporting | 501 | レポート処理中です。
LicenseNotFound | 600 | ライセンス情報が見つかりません。
LicenseFileAccess | 601 | ライセンスファイルにアクセスできません。
LicenseLoad | 602 | ライセンス情報が読み込めません。
License | 603 | ライセンス認証エラー。
PdfSignatureAbort | 700 | PDFファイルへの電子署名付与が失敗しました。
PdfSignatureTimeStampAbort | 701 | PDFファイルへの署名タイムスタンプ付与が失敗しました。
PdfDocumentTimeStampAbort | 702 | PDFファイルへのドキュメントタイムスタンプ付与が失敗しました。
関連項目

参照


ExcelModeType 列挙体

ExcelMode = true 時の Excel 起動モードを指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ExcelModeType
Public Enumeration ExcelModeType
メンバー
メンバー | 値 | 説明
Auto | 0 | 自動
Manual | 1 | アプリケーションの種類に関わらず Excel を起動します。
関連項目

参照


ExcelVersion 列挙体

Excel ファイルのバージョンを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ExcelVersion
Public Enumeration ExcelVersion
メンバー
メンバー | 値 | 説明
ver2003 | 2003 | Excel 2003 の形式で作成します。
ver2007 | 2007 | Excel 2007 の形式で作成します。
ver2010 | 2010 | Excel 2010 の形式で作成します。
ver2013 | 2013 | Excel 2013 の形式で作成します。
ver2016 | 2016 | Excel 2016 の形式で作成します。
ver2019 | 2019 | Excel 2019 の形式で作成します。
ver2021 | 2021 | Excel 2021 の形式で作成します。
ver2024 | 2024 | Excel 2024 の形式で作成します。
関連項目

参照


FillType 列挙体

塗りつぶしタイプを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum FillType
Public Enumeration FillType
メンバー
メンバー | 値 | 説明
Fill | 0 | 塗りつぶし
Pattern | 1 | パターン
Texture | 2 | テクスチャ
Gradation | 4 | グラデーション
Translucence | 5 | 半透明にする
None | 6 | なし
関連項目

参照


FontStyle 列挙体

フォントスタイルを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum FontStyle
Public Enumeration FontStyle
メンバー
メンバー | 値 | 説明
Normal | 0 | 標準
Bold | 1 | 太字
Italic | 2 | 斜体
BoldItalic | 3 | 太字＋斜体
Strike | 4 | 打ち消し線
Up | 8 | 上付き
Down | 16 | 下付き
関連項目

参照


FontULine 列挙体

フォント下線を示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum FontULine
Public Enumeration FontULine
メンバー
メンバー | 値 | 説明
None | 0 | なし
Normal | 1 | 標準
Double | 2 | 二重線
関連項目

参照


HeaderFooterMode 列挙体

ヘッダー/フッター設定モードを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum HeaderFooterMode
Public Enumeration HeaderFooterMode
メンバー
メンバー | 値 | 説明
Normal | 0 | 標準
OddEven | 1 | 奇数/偶数ページ別指定
FirstPage | 2 | 先頭ページのみ別指定
All | 3 | 奇数/偶数ページ別指定、先頭ページのみ別指定
関連項目

参照


HeaderFooterType 列挙体

ヘッダー/フッター設定タイプを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum HeaderFooterType
Public Enumeration HeaderFooterType
メンバー
メンバー | 値 | 説明
Normal | 0 | 標準
Even | 1 | 奇数/偶数ページ
First | 2 | 先頭ページ
関連項目

参照


HorizontalAlignment 列挙体

水平方向の位置を示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum HorizontalAlignment
Public Enumeration HorizontalAlignment
メンバー
メンバー | 値 | 説明
General | 20 | 標準
Left | 21 | 左詰め
Center | 22 | 中央揃え
Right | 23 | 右詰め
Fill | 24 | 繰り返し
Justify | 25 | 両端揃え
CenterContinuous | 26 | 選択範囲内で中央
Distributed | 27 | 均等割り付け
関連項目

参照


ImageType 列挙体

イメージタイプを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ImageType
Public Enumeration ImageType
メンバー
メンバー | 値 | 説明
JPEG | 0 | Jpeg 形式
GIF | 1 | Gif 形式
BMP | 2 | Bitmap 形式
AUTO | 3 | 自動判定
関連項目

参照


LineStyle 列挙体

オートシェイプの線種を示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum LineStyle
Public Enumeration LineStyle
メンバー
メンバー | 値 | 説明
None | 0 | なし
Normal | 1 | 実線
SysDot | 2 | [Xls] 丸点線, [Xlsx] 角点線
SysDash | 3 | [Xls] 角点線, [Xlsx] システム破線
Dash | 4 | 破線
DashDot | 5 | 一点鎖線
LongDash | 6 | 長破線
LongDashDot | 7 | 長一点鎖線
LongDashDotDot | 8 | 長二点鎖線
Round | 9 | 内部使用
XlsxRoundDot | 10 | 丸点線(Xlsx用)
Single | 16 | 実線
Double | 32 | 二重線
ThickThin | 48 | 上が太い二重線
ThinThick | 64 | 下が太い二重線
Triple | 80 | 三重線
解説
実線/点線(Normal、SysDot、SysDash、Dash、DashDot、LongDash、LongDashDot、LongDashDotDot、XlsxRoundDot)と スタイル(Single、 Double、ThickThin、ThinThick、Triple)を or 演算子で連結して設定することができます。
関連項目

参照


MaxEndPoint 列挙体

データや属性の範囲を示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum MaxEndPoint
Public Enumeration MaxEndPoint
メンバー
メンバー | 値 | 説明
MaxPoint | 0 | x と y が交わる位置の座標を取得します。
EndPoint | 1 | 最終座標を取得します。
関連項目

参照


Orientation 列挙体

文字の方向を示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum Orientation
Public Enumeration Orientation
メンバー
メンバー | 値 | 説明
Horz | 100 | 横書き
Vert | 101 | 縦書き
RvTurn90 | 102 | -90 度回転
Turn90 | 103 | 90 度回転
関連項目

参照


OutputMode 列挙体

出力モードを指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum OutputMode
Public Enumeration OutputMode
メンバー
メンバー | 値 | 説明
All | 0 | 出力用のデータをすべて作成します。
NotExcel | 1 | Excel 保存以外(プレビュー、印刷、PDF 出力)に必要なデータのみを作成します。
ExcelOnly | 2 | Excel 保存に必要なデータのみを作成します。
関連項目

参照


Page クラス

帳票の出力対象を指定します。レポートコンポーネントを通じてこのクラスにアクセスします。
継承階層
SystemObject
AdvanceSoftware.ASReportPage

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Page
Public Class Page

Page 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
Public プロパティ | Attr | ページ属性を設定するための PageAttr を取得します。
 | Name | シート名を指定します。
 | TotalCount | 総ページ数を取得します。
 | VarNames | 変数名の一覧を取得します。
トップ
メソッド
名前 | 説明
End | ページの終了を指定します。
Next | ページ内での繰り返しの終了を指定します。
Next(Boolean) | ページ内での繰り返しの終了を指定します。
Repeat(Int32) | ページ内での繰り返しの開始を指定します。
Repeat(Int32, Int32) | ページ内での繰り返しの開始を指定します。
Start | ページの開始を指定します。
Start(String, String) | ページの開始を指定します。
トップ
関連項目

参照


Page プロパティ

Page 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
Public プロパティ | Attr | ページ属性を設定するための PageAttr を取得します。
 | Name | シート名を指定します。
 | TotalCount | 総ページ数を取得します。
 | VarNames | 変数名の一覧を取得します。
トップ
関連項目

参照

Page クラス


Page.Attr プロパティ

PageAttr プロパティ

ページ属性を設定するための PageAttr を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PageAttr Attr { get; }
Public ReadOnly Property Attr As PageAttr
    Get

プロパティ値

型: PageAttr
ページ属性の設定を行うための、PageAttr クラス。
解説
このクラスの全てのメンバーの一覧については、PageAttr クラスのメンバーを参照してください。
関連項目

参照

Page クラス


Page.Name プロパティ

PageName プロパティ

シート名を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Name { set; }
Public WriteOnly Property Name As String
    Set

プロパティ値

型: String
保存時のシート名。
解説
デザインファイルを使用して帳票を作成する場合、既存のシート名を設定することはできません。
例
C#
VB
コピー
// シート名を "シート１" に設定します。
cellReport1.Page.Name = "シート１";
' シート名を "シート１" に設定します。
CellReport1.Page.Name = "シート１"
関連項目

参照

Page クラス


Page.TotalCount プロパティ

PageTotalCount プロパティ

総ページ数を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int TotalCount { get; }
Public ReadOnly Property TotalCount As Integer
    Get

プロパティ値

型: Int32
帳票の総ページ数。
解説
総ページ数は、Page.End メソッドの後に取得してください。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
// 総ページ数を取得します。
int totalCount = cellReport1.Page.TotalCount;
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
' 総ページ数を取得します。
Dim totalCount As Integer = CellReport1.Page.TotalCount
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Page クラス


Page.VarNames プロパティ

PageVarNames プロパティ

変数名の一覧を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public CellPositionCollection VarNames { get; }
Public ReadOnly Property VarNames As CellPositionCollection
    Get

プロパティ値

型: CellPositionCollection
CellPosition クラスのコレクション(CellPositionCollection)
例
C#
VB
コピー
AdvanceSoftware.ASReport.CellPositionCollection cellPositionCollection;
// 変数名の一覧を取得します。
cellPositionCollection = cellReport1.Page.VarNames;
Dim cellPositionCollection As AdvanceSoftware.ASReport.CellPositionCollection
' 変数名の一覧を取得します。
cellPositionCollection = CellReport1.Page.VarNames
関連項目

参照

Page クラス


Page メソッド

Page 型は下記のメンバーを公開します。

メソッド
名前 | 説明
End | ページの終了を指定します。
Next | ページ内での繰り返しの終了を指定します。
Next(Boolean) | ページ内での繰り返しの終了を指定します。
Repeat(Int32) | ページ内での繰り返しの開始を指定します。
Repeat(Int32, Int32) | ページ内での繰り返しの開始を指定します。
Start | ページの開始を指定します。
Start(String, String) | ページの開始を指定します。
トップ
関連項目

参照

Page クラス


Page.End メソッド

PageEnd メソッド

ページの終了を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void End()
Public Sub End
解説
Page.Start、Page.End メソッドは、必ず 1 対 1 で設定してください。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
// 使用するシートを "Sheet1"、使用するページを "1 ページ" に設定します。
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
' 使用するシートを "Sheet1"、使用するページを "1 ページ" に設定します。
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Page クラス


Page.Next メソッド

PageNext メソッド

オーバーロードの一覧
名前 | 説明
Next | ページ内での繰り返しの終了を指定します。
Next(Boolean) | ページ内での繰り返しの終了を指定します。
トップ
関連項目

参照

Page クラス


Page.Next メソッド

PageNext メソッド

ページ内での繰り返しの終了を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Next()
Public Sub Next
解説
Page.Start メソッドと Page.End メソッドの間に呼び出してください。 1 つのシートで複数ページを作成する場合に、Page.Repeat メソッドと Page.Next メソッドをページ数分繰り返し呼び出します(改ページが挿入されます)。作成された帳票は、保存時に 1 つのシートに複数ページとして保存されます。 Page.Repeat メソッドと Page.Next メソッドは必ず対で呼び出します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1-99999");
// 1 行目から 5 行分のデザインを元に、1 シートに 10 ページの帳票を作成します。
for (int i = 1; i <= 10; i++)
{
    cellReport1.Page.Repeat(1, 5);
    cellReport1.Cell("A1").Value = i.ToString() + "ページ目";
    cellReport1.Page.Next();
}
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1-99999")
' 1 行目から 5 行分のデザインを元に、1 シートに 10 ページの帳票を作成します。
For i As Integer = 1 To 10
    CellReport1.Page.Repeat(1, 5)
    CellReport1.Cell("A1").Value = i.ToString() + "ページ目"
    CellReport1.Page.Next()
Next
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Page クラス
Next オーバーロード


Page.Next メソッド (Boolean)

PageNext メソッド (Boolean)

ページ内での繰り返しの終了を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Next(
    bool pageBreak
)
Public Sub Next (
    pageBreak As Boolean
)

パラメーター

pageBreak
型: SystemBoolean
改ページを挿入するかどうかを指定します。true を設定すると改ページが挿入されます。
解説
Page.Start メソッドと Page.End メソッドの間に呼び出してください。 1 つのシートで複数ページを作成する場合に、Page.Repeat メソッドと Page.Next メソッドをページ数分繰り返し呼び出します。作成された帳票は、保存時に 1 つのシートに複数ページとして保存されます。 Page.Repeat メソッドと Page.Next メソッドは必ず対で呼び出します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1-99999");
// 1 行目から 5 行分のデザインを元に、1 シートに 10 ページの帳票を作成します。
for (int i = 1; i <= 10; i++)
{
    cellReport1.Page.Repeat(1, 5);
    cellReport1.Cell("A1").Value = i.ToString() + "ページ目";
    cellReport1.Page.Next(true);
}
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1-99999")
' 1 行目から 5 行分のデザインを元に、1 シートに 10 ページの帳票を作成します。
For i As Integer = 1 To 10
    CellReport1.Page.Repeat(1, 5)
    CellReport1.Cell("A1").Value = i.ToString() + "ページ目"
    CellReport1.Page.Next(True)
Next
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Page クラス
Next オーバーロード


Page.Repeat メソッド

PageRepeat メソッド

オーバーロードの一覧
名前 | 説明
Repeat(Int32) | ページ内での繰り返しの開始を指定します。
Repeat(Int32, Int32) | ページ内での繰り返しの開始を指定します。
トップ
関連項目

参照

Page クラス


Page.Repeat メソッド (Int32)

PageRepeat メソッド (Int32)

ページ内での繰り返しの開始を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Repeat(
    int rowNo
)
Public Sub Repeat (
    rowNo As Integer
)

パラメーター

rowNo
型: SystemInt32
使用する開始行番号(1～)を設定します。
解説
Page.Start メソッドと Page.End メソッドの間に呼び出してください。 1 つのシートで複数ページを作成する場合に、Page.Repeat メソッドと Page.Next メソッドをページ数分繰り返し呼び出します。作成された帳票は、保存時に 1 つのシートに複数ページとして保存されます。 Page.Repeat メソッドと Page.Next メソッドは必ず対で呼び出します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1-99999");
// 1 行目からデータが設定されている行までのデザインを元に、1 シートに 10 ページの帳票を作成します。
for (int i = 1; i <= 10; i++)
{
    cellReport1.Page.Repeat(1);
    cellReport1.Cell("A1").Value = i.ToString() + "ページ目";
    cellReport1.Page.Next(true);
}
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1-99999")
' 1 行目からデータが設定されている行までのデザインを元に、1 シートに 10 ページの帳票を作成します。
For i As Integer = 1 To 10
    CellReport1.Page.Repeat(1)
    CellReport1.Cell("A1").Value = i.ToString() + "ページ目"
    CellReport1.Page.Next(True)
Next
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Page クラス
Repeat オーバーロード


Page.Repeat メソッド (Int32, Int32)

PageRepeat メソッド (Int32, Int32)

ページ内での繰り返しの開始を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Repeat(
    int rowNo,
    int count
)
Public Sub Repeat (
    rowNo As Integer,
    count As Integer
)

パラメーター

rowNo
型: SystemInt32
使用する開始行番号(1～)を設定します。
count
型: SystemInt32
使用する行数を設定します。
解説
Page.Start メソッドと Page.End メソッドの間に呼び出してください。 1 つのシートで複数ページを作成する場合に、Page.Repeat メソッドと Page.Next メソッドをページ数分繰り返し呼び出します。作成された帳票は、保存時に 1 つのシートに複数ページとして保存されます。 Page.Repeat メソッドと Page.Next メソッドは必ず対で呼び出します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1-99999");
// 1 行目から 5 行分のデザインを元に、1 シートに 10 ページの帳票を作成します。
for (int i = 1; i <= 10; i++)
{
    cellReport1.Page.Repeat(1, 5);
    cellReport1.Cell("A1").Value = i.ToString() + "ページ目";
    cellReport1.Page.Next(true);
}
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1-99999")
' 1 行目から 5 行分のデザインを元に、1 シートに 10 ページの帳票を作成します。
For i As Integer = 1 To 10
    CellReport1.Page.Repeat(1, 5)
    CellReport1.Cell("A1").Value = i.ToString() + "ページ目"
    CellReport1.Page.Next(True)
Next
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Page クラス
Repeat オーバーロード


Page.Start メソッド

PageStart メソッド

オーバーロードの一覧
名前 | 説明
Start | ページの開始を指定します。
Start(String, String) | ページの開始を指定します。
トップ
関連項目

参照

Page クラス


Page.Start メソッド

PageStart メソッド

ページの開始を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Start()
Public Sub Start
解説
Page.Start、Page.End メソッドは、必ず 1 対 1 で設定してください。 引数を省略した場合、SheetName、PageInfo プロパティの値が使用されます。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
// 使用するシートを "Sheet1" に設定します。
cellReport1.SheetName = "Sheet1";
// 使用するページを "1" に設定します。
cellReport1.PageInfo = "1";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start();
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
' 使用するシートを "Sheet1" に設定します。
CellReport1.SheetName = "Sheet1"
' 使用するページを "1" に設定します。
CellReport1.PageInfo = "1"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start()
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Page クラス
Start オーバーロード


Page.Start メソッド (String, String)

PageStart メソッド (String, String)

ページの開始を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Start(
    string sheetName,
    string pageInfo
)
Public Sub Start (
    sheetName As String,
    pageInfo As String
)

パラメーター

sheetName
型: SystemString
使用するシート名を設定します。
pageInfo
型: SystemString
使用するページを設定します。
解説
Page.Start、Page.End メソッドは、必ず 1 対 1 で設定してください。 引数を省略した場合、SheetName、PageInfo プロパティの値が使用されます。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
// 使用するシートを "Sheet1"、使用するページを "1 ページ" に設定します。
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
' 使用するシートを "Sheet1"、使用するページを "1 ページ" に設定します。
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Page クラス
Start オーバーロード


PageAttr クラス

帳票のページ設定を行います。レポートコンポーネントを通じてこのクラスにアクセスします。
継承階層
SystemObject
AdvanceSoftware.ASReportPageAttr

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class PageAttr
Public Class PageAttr

PageAttr 型は下記のメンバーを公開します。

プロパティ
名前 | 説明
Center | ページ中央を指定します。
PageOrder | ページの方向を指定します。
TabSelected | シートの選択を設定します。
トップ
メソッド
名前 | 説明
Footer | フッターを設定します。
Header | ヘッダーを設定します。
Margin | 余白を設定します。
PrintArea | 印刷範囲を設定します。
PrintTitle | 印刷タイトルを設定します。
Size(PaperKind) | 用紙設定をします。
Size(Int32, PaperKind) | 用紙設定をします。
Size(PageOrientation, PaperKind) | 用紙設定をします。
Size(PageOrientation, Int32, PaperKind) | 用紙設定をします。
SizeFree(Double, Double, String) | ユーザー定義用紙を設定します。
SizeFree(Double, Double, String, String) | ユーザー定義用紙を設定します。
トップ
関連項目

参照


PageAttr プロパティ

PageAttr 型は下記のメンバーを公開します。

プロパティ
名前 | 説明
Center | ページ中央を指定します。
PageOrder | ページの方向を指定します。
TabSelected | シートの選択を設定します。
トップ
関連項目

参照

PageAttr クラス


PageAttr.Center プロパティ

PageAttrCenter プロパティ

ページ中央を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PageCenter Center { set; }
Public WriteOnly Property Center As PageCenter
    Set

プロパティ値

型: PageCenter
ページ中央を表す PageCenter。
例
C#
VB
コピー
// ページ中央を "水平、垂直" に設定します。
cellReport1.Page.Attr.Center = AdvanceSoftware.ASReport.PageCenter.Horz | AdvanceSoftware.ASReport.PageCenter.Vert;
' ページ中央を "水平、垂直" に設定します。
CellReport1.Page.Attr.Center = AdvanceSoftware.ASReport.PageCenter.Horz Or AdvanceSoftware.ASReport.PageCenter.Vert
関連項目

参照

PageAttr クラス


PageAttr.PageOrder プロパティ

PageAttrPageOrder プロパティ

ページの方向を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PageOrder PageOrder { set; }
Public WriteOnly Property PageOrder As PageOrder
    Set

プロパティ値

型: PageOrder
ページの方向を表す PageOrder。
例
C#
VB
コピー
// ページの方向を "上から下" に設定します。
cellReport1.Page.Attr.PageOrder = AdvanceSoftware.ASReport.PageOrder.BottomFromTop;
' ページの方向を "上から下" に設定します。
CellReport1.Page.Attr.PageOrder = AdvanceSoftware.ASReport.PageOrder.BottomFromTop
関連項目

参照

PageAttr クラス


PageAttr.TabSelected プロパティ

PageAttrTabSelected プロパティ

シートの選択を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool TabSelected { set; }
Public WriteOnly Property TabSelected As Boolean
    Set

プロパティ値

型: Boolean
true:シートを選択状態にする false:シートを選択状態にしない
例
C#
VB
コピー
// 現在のシートを選択状態にします。
cellReport1.Page.Attr.TabSelected = true;
' 現在のシートを選択状態します。
CellReport1.Page.Attr.TabSelected = True
関連項目

参照

PageAttr クラス


PageAttr メソッド

PageAttr 型は下記のメンバーを公開します。

メソッド
名前 | 説明
Footer | フッターを設定します。
Header | ヘッダーを設定します。
Margin | 余白を設定します。
PrintArea | 印刷範囲を設定します。
PrintTitle | 印刷タイトルを設定します。
Size(PaperKind) | 用紙設定をします。
Size(Int32, PaperKind) | 用紙設定をします。
Size(PageOrientation, PaperKind) | 用紙設定をします。
Size(PageOrientation, Int32, PaperKind) | 用紙設定をします。
SizeFree(Double, Double, String) | ユーザー定義用紙を設定します。
SizeFree(Double, Double, String, String) | ユーザー定義用紙を設定します。
トップ
関連項目

参照

PageAttr クラス


PageAttr.Footer メソッド

PageAttrFooter メソッド

フッターを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Footer(
    string left,
    string center,
    string right
)
Public Sub Footer (
    left As String,
    center As String,
    right As String
)

パラメーター

left
型: SystemString
左フッターを設定します。
center
型: SystemString
中央フッターを設定します。
right
型: SystemString
右フッターを設定します。
解説
下記の書式コードに対応しています。
書式コード | 内容
&L | 左詰
&C | 中央揃え
&R | 右詰
&E | 二重下線
&X | 上付き文字
&Y | 下付き文字
&B | ボールド
&I | イタリック
&U | 下線
&S | 取消線
&P | ページ番号
&P+99 | ページ番号に値を加えて表示
&P-99 | ページ番号に値を引いて表示
&D | 現在の日付
&T | 現在の時刻
&A | シート見出し
&& | & (アンパサンド) を表示
&"フォント" | フォントを設定
&99 | フォントサイズを設定
&N | 全体のページ数
例
C#
VB
コピー
// 右ヘッダーに "現在の日付" を設定します。
cellReport1.Page.Attr.Header("", "", "&D");
// 中央フッターに "ページ番号/全体ページ数" を設定します。
cellReport1.Page.Attr.Footer("", "&P/&N","");
' 右ヘッダーに "現在の日付" を設定します。
CellReport1.Page.Attr.Header("", "", "&D")
' 中央フッターに "ページ番号/全体ページ数" を設定します。
CellReport1.Page.Attr.Footer("", "&P/&N", "")
関連項目

参照

PageAttr クラス


PageAttr.Header メソッド

PageAttrHeader メソッド

ヘッダーを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Header(
    string left,
    string center,
    string right
)
Public Sub Header (
    left As String,
    center As String,
    right As String
)

パラメーター

left
型: SystemString
左ヘッダーを設定します。
center
型: SystemString
中央ヘッダーを設定します。
right
型: SystemString
右ヘッダーを設定します。
解説
下記の書式コードに対応しています。
書式コード | 内容
&L | 左詰
&C | 中央揃え
&R | 右詰
&E | 二重下線
&X | 上付き文字
&Y | 下付き文字
&B | ボールド
&I | イタリック
&U | 下線
&S | 取消線
&P | ページ番号
&P+99 | ページ番号に値を加えて表示
&P-99 | ページ番号に値を引いて表示
&D | 現在の日付
&T | 現在の時刻
&A | シート見出し
&& | & (アンパサンド) を表示
&"フォント" | フォントを設定
&99 | フォントサイズを設定
&N | 全体のページ数
例
C#
VB
コピー
// 右ヘッダーに "現在の日付" を設定します。
cellReport1.Page.Attr.Header("", "", "&D");
// 中央フッターに "ページ番号/全体ページ数" を設定します。
cellReport1.Page.Attr.Footer("", "&P/&N","");
' 右ヘッダーに "現在の日付" を設定します。
CellReport1.Page.Attr.Header("", "", "&D")
' 中央フッターに "ページ番号/全体ページ数" を設定します。
CellReport1.Page.Attr.Footer("", "&P/&N", "")
関連項目

参照

PageAttr クラス


PageAttr.Margin メソッド

PageAttrMargin メソッド

余白を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Margin(
    int left,
    int right,
    int top,
    int bottom,
    int header,
    int footer
)
Public Sub Margin (
    left As Integer,
    right As Integer,
    top As Integer,
    bottom As Integer,
    header As Integer,
    footer As Integer
)

パラメーター

left
型: SystemInt32
左余白を設定します。
right
型: SystemInt32
右余白を設定します。
top
型: SystemInt32
上余白を設定します。
bottom
型: SystemInt32
下余白を設定します。
header
型: SystemInt32
ヘッダーの余白を設定します。
footer
型: SystemInt32
フッターの余白を設定します。
解説
-1 を指定した場合はデザインファイルの設定値が適用されます。
例
C#
VB
コピー
// 余白 (左：10mm、右：10mm、上：10mm、下：10mm、ヘッダー：5mm、フッター：5mm) を設定します。
cellReport1.Page.Attr.Margin(10, 10, 10, 10, 5, 5);
' 余白 (左：10mm、右：10mm、上：10mm、下：10mm、ヘッダー：5mm、フッター：5mm) を設定します。
CellReport1.Page.Attr.Margin(10, 10, 10, 10, 5, 5)
関連項目

参照

PageAttr クラス


PageAttr.PrintArea メソッド

PageAttrPrintArea メソッド

印刷範囲を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void PrintArea(
    int sx,
    int sy,
    int ex,
    int ey
)
Public Sub PrintArea (
    sx As Integer,
    sy As Integer,
    ex As Integer,
    ey As Integer
)

パラメーター

sx
型: SystemInt32
開始 x 座標(0～)を設定します。
sy
型: SystemInt32
開始 y 座標(0～)を設定します。
ex
型: SystemInt32
終了 x 座標(0～)を設定します。
ey
型: SystemInt32
終了 y 座標(0～)を設定します。
解説
PrintArea メソッドで設定した印刷範囲は、Excel ファイル出力の時のみ有効になります。
例
C#
VB
コピー
// A1:E10 セルを印刷範囲に設定します。
cellReport1.Page.Attr.PrintArea(0, 0, 4, 9);
' A1:E10 セルを印刷範囲に設定します。
CellReport1.Page.Attr.PrintArea(0, 0, 4, 9)
関連項目

参照

PageAttr クラス


PageAttr.PrintTitle メソッド

PageAttrPrintTitle メソッド

印刷タイトルを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void PrintTitle(
    int sy,
    int ey,
    int sx,
    int ex
)
Public Sub PrintTitle (
    sy As Integer,
    ey As Integer,
    sx As Integer,
    ex As Integer
)

パラメーター

sy
型: SystemInt32
開始 y 座標(0～)を設定します。
ey
型: SystemInt32
終了 y 座標(0～)を設定します。
sx
型: SystemInt32
開始 x 座標(0～)を設定します。
ex
型: SystemInt32
終了 x 座標(0～)を設定します。
解説
PrintTitle メソッドで設定した印刷タイトルは、Excel ファイル出力の時のみ有効になります。
例
C#
VB
コピー
// 1 ～ 2 行目をタイトル行に設定します。
cellReport1.Page.Attr.PrintTitle(0, 1, -1, -1);
' 1 ～ 2 行目をタイトル行に設定します。
CellReport1.Page.Attr.PrintTitle(0, 1, -1, -1)
関連項目

参照

PageAttr クラス


PageAttr.Size メソッド

PageAttrSize メソッド

オーバーロードの一覧
名前 | 説明
Size(PaperKind) | 用紙設定をします。
Size(Int32, PaperKind) | 用紙設定をします。
Size(PageOrientation, PaperKind) | 用紙設定をします。
Size(PageOrientation, Int32, PaperKind) | 用紙設定をします。
トップ
関連項目

参照

PageAttr クラス


PageAttr.Size メソッド (PaperKind)

PageAttrSize メソッド (PaperKind)

用紙設定をします。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Size(
    PaperKind paperSize
)
Public Sub Size (
    paperSize As PaperKind
)

パラメーター

paperSize
型: System.Drawing.PrintingPaperKind
用紙サイズを設定します。
解説
各設定値は -2 で省略可能です。省略した場合、デザインファイルの設定を引き継ぎます。（新規作成の場合、既定値 A4 になります。）
例
C#
VB
コピー
// 用紙サイズを "A5" に設定します。
cellReport1.Page.Attr.Size(System.Drawing.Printing.PaperKind.A5);
' 用紙サイズを "A5" に設定します。
CellReport1.Page.Attr.Size(System.Drawing.Printing.PaperKind.A5)
関連項目

参照

PageAttr クラス
Size オーバーロード


PageAttr.Size メソッド (Int32, PaperKind)

PageAttrSize メソッド (Int32, PaperKind)

用紙設定をします。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Size(
    int scale,
    PaperKind paperSize
)
Public Sub Size (
    scale As Integer,
    paperSize As PaperKind
)

パラメーター

scale
型: SystemInt32
倍率を設定します。
paperSize
型: System.Drawing.PrintingPaperKind
用紙サイズを設定します。
解説
各設定値は -2 で省略可能です。省略した場合、デザインファイルの設定を引き継ぎます。（新規作成の場合、既定値 A4 になります。）
例
C#
VB
コピー
// 倍率を "120%"、用紙サイズを "A5" に設定します。
cellReport1.Page.Attr.Size(120, System.Drawing.Printing.PaperKind.A5);
' 倍率を "120%"、用紙サイズを "A5" に設定します。
CellReport1.Page.Attr.Size(120, System.Drawing.Printing.PaperKind.A5)
関連項目

参照

PageAttr クラス
Size オーバーロード


PageAttr.Size メソッド (PageOrientation, PaperKind)

PageAttrSize メソッド (PageOrientation, PaperKind)

用紙設定をします。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Size(
    PageOrientation orientation,
    PaperKind paperSize
)
Public Sub Size (
    orientation As PageOrientation,
    paperSize As PaperKind
)

パラメーター

orientation
型: AdvanceSoftware.ASReportPageOrientation
用紙方向を設定します。
paperSize
型: System.Drawing.PrintingPaperKind
用紙サイズを設定します。
解説
各設定値は -2 で省略可能です。省略した場合、デザインファイルの設定を引き継ぎます。（新規作成の場合、既定値 A4 になります。）
例
C#
VB
コピー
// 用紙方向を "横"、用紙サイズを "A5" に設定します。
cellReport1.Page.Attr.Size(AdvanceSoftware.ASReport.PageOrientation.Landscape, System.Drawing.Printing.PaperKind.A5);
' 用紙方向を "横"、用紙サイズを "A5" に設定します。
CellReport1.Page.Attr.Size(AdvanceSoftware.ASReport.PageOrientation.Landscape, System.Drawing.Printing.PaperKind.A5)
関連項目

参照

PageAttr クラス
Size オーバーロード


PageAttr.Size メソッド (PageOrientation, Int32, PaperKind)

PageAttrSize メソッド (PageOrientation, Int32, PaperKind)

用紙設定をします。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Size(
    PageOrientation orientation,
    int scale,
    PaperKind paperSize
)
Public Sub Size (
    orientation As PageOrientation,
    scale As Integer,
    paperSize As PaperKind
)

パラメーター

orientation
型: AdvanceSoftware.ASReportPageOrientation
用紙方向を設定します。
scale
型: SystemInt32
倍率を設定します。
paperSize
型: System.Drawing.PrintingPaperKind
用紙サイズを設定します。
解説
各設定値は -2 で省略可能です。省略した場合、デザインファイルの設定を引き継ぎます。（新規作成の場合、既定値 A4 になります。）
例
C#
VB
コピー
// 用紙方向を "横"、倍率を "120%"、用紙サイズを "A5" に設定します。
cellReport1.Page.Attr.Size(AdvanceSoftware.ASReport.PageOrientation.Landscape, 120, System.Drawing.Printing.PaperKind.A5);
' 用紙方向を "横"、倍率を "120%"、用紙サイズを "A5" に設定します。
CellReport1.Page.Attr.Size(AdvanceSoftware.ASReport.PageOrientation.Landscape, 120, System.Drawing.Printing.PaperKind.A5)
関連項目

参照

PageAttr クラス
Size オーバーロード


PageAttr.SizeFree メソッド

PageAttrSizeFree メソッド

オーバーロードの一覧
名前 | 説明
SizeFree(Double, Double, String) | ユーザー定義用紙を設定します。
SizeFree(Double, Double, String, String) | ユーザー定義用紙を設定します。
トップ
関連項目

参照

PageAttr クラス


PageAttr.SizeFree メソッド (Double, Double, String)

PageAttrSizeFree メソッド (Double, Double, String)

ユーザー定義用紙を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void SizeFree(
    double width,
    double height,
    string paperName
)
Public Sub SizeFree (
    width As Double,
    height As Double,
    paperName As String
)

パラメーター

width
型: SystemDouble
用紙の幅を設定します。
height
型: SystemDouble
用紙の高さを設定します。
paperName
型: SystemString
用紙名を設定します
解説
プリントサーバーのプロパティで登録した用紙名を引数 paperName に、用紙サイズ(高さ・幅)を引数 width と height に設定してください。
例
C#
VB
コピー
// 用紙サイズを "ユーザー定義用紙1(200mm×300mm)" に設定します。
cellReport1.Page.Attr.SizeFree(200, 300, "ユーザー定義用紙1");
' 用紙サイズを "ユーザー定義用紙1(200mm×300mm)" に設定します。
CellReport1.Page.Attr.SizeFree(200, 300, "ユーザー定義用紙1")
関連項目

参照

PageAttr クラス
SizeFree オーバーロード


PageAttr.SizeFree メソッド (Double, Double, String, String)

PageAttrSizeFree メソッド (Double, Double, String, String)

ユーザー定義用紙を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void SizeFree(
    double width,
    double height,
    string paperName,
    string printerName
)
Public Sub SizeFree (
    width As Double,
    height As Double,
    paperName As String,
    printerName As String
)

パラメーター

width
型: SystemDouble
用紙の幅を設定します。
height
型: SystemDouble
用紙の高さを設定します。
paperName
型: SystemString
用紙名を設定します
printerName
型: SystemString
プリンタ名を設定します
解説
プリントサーバーのプロパティで登録した用紙名を引数 paperName に、用紙サイズ(高さ・幅)を引数 width と height に設定してください。
例
C#
VB
コピー
// 用紙サイズを "ユーザー定義用紙1(200mm×300mm)" に設定します。
cellReport1.Page.Attr.SizeFree(200, 300, "ユーザー定義用紙1", "Microsoft XPS Document Writer");
' 用紙サイズを "ユーザー定義用紙1(200mm×300mm)" に設定します。
CellReport1.Page.Attr.SizeFree(200, 300, "ユーザー定義用紙1", "Microsoft XPS Document Writer")
関連項目

参照

PageAttr クラス
SizeFree オーバーロード


PageCenter 列挙体

ページ中央を示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum PageCenter
Public Enumeration PageCenter
メンバー
メンバー | 値 | 説明
None | 0 | なし
Horz | 1 | 水平
Vert | 2 | 垂直
関連項目

参照


PageOrder 列挙体

ページの方向を示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum PageOrder
Public Enumeration PageOrder
メンバー
メンバー | 値 | 説明
RightFromLeft | 0 | 左から右
BottomFromTop | 1 | 上から下
関連項目

参照


PageOrientation 列挙体

用紙方向を示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum PageOrientation
Public Enumeration PageOrientation
メンバー
メンバー | 値 | 説明
Landscape | 0 | 横
Default | 1 | 標準
Portrait | 2 | 縦
関連項目

参照


Pattern 列挙体

パターンを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum Pattern
Public Enumeration Pattern
メンバー
メンバー | 値 | 説明
None | 0x01000000 | 塗りつぶしなし
Solid | 0x02000000 | 塗りつぶし
MediumGray | 0x03000000 | 50% 灰色
DarkGray | 0x04000000 | 75% 灰色
LightGray | 0x05000000 | 25% 灰色
DarkHorizontal | 0x06000000 | 横 縞
DarkVertical | 0x07000000 | 縦 縞
DarkDown | 0x08000000 | 右下がり斜線 縞
DarkUp | 0x09000000 | 左下がり斜線 縞
DarkGrid | 0x0A000000 | 左下がり斜線 格子
DarkTrellis | 0x0B000000 | 極太線 左下がり斜線 格子
LightHorizontal | 0x0C000000 | 実線 横 縞
LightVertical | 0x0D000000 | 実線 縦 縞
LightDown | 0x0E000000 | 実線 右下がり斜線 縞
LightUp | 0x0F000000 | 実線 左下がり斜線 縞
LightGrid | 0x10000000 | 実線 横 格子
LightTrellis | 0x11000000 | 実線 左下がり斜線 格子
Gray125 | 0x12000000 | 12.5% 灰色
Gray0625 | 0x13000000 | 6.25% 灰色
関連項目

参照


PdfEncryptionType 列挙体

PDF の暗号化強度を示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum PdfEncryptionType
Public Enumeration PdfEncryptionType
メンバー
メンバー | 値 | 説明
NoPassword | 0 | パスワードなし
Acrobat3_RC4_40 | 1 | 40-bit RC4
Acrobat5_RC4_128 | 2 | 128-bit RC4
Acrobat6_RC4_128 | 3 | 128-bit RC4
Acrobat7_AES_128 | 4 | 128-bit AES
Acrobat10_AES_256 | 6 | 256-bit AES(Acrobat 10)
関連項目

参照


PdfOption クラス

PDF ファイルのオプションを設定します。レポートコンポーネントを通じてこのクラスにアクセスします。
継承階層
SystemObject
AdvanceSoftware.ASReportPdfOption

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class PdfOption
Public Class PdfOption

PdfOption 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
 | Application | PDF ファイルのアプリケーションを設定します。
 | Author | PDF ファイルの作成者を設定します。
 | CreateFileWithoutSignature | 電子署名、タイムスタンプ付与失敗時に PDF ファイルを生成するかを指定します。
 | EmbedFonts | PDF ファイルに埋め込むフォントを設定します。
 | EncryptionType | PDF ファイルの暗号化強度を設定します。
 | EUDCFiles | PDF ファイルで使用する外字ファイル名と対象とするフォント名を指定します。 フォントの種類毎に外字ファイルを切り替えることが可能です。
 | ImageType | PDF ファイルのイメージの種類を設定します。
 | IsReplaceYenSign | PDF ファイルに出力する文字列の"\"マークの扱いを指定します。
 | OwnerPassword | PDF ファイルのオーナーパスワードを設定します。
 | PatternQuality | PDF ファイル作成時のパターンの解像度を設定します。
 | Permit | PDF ファイルの権限を設定します。
 | Producer | PDF ファイルの PDF 変換を設定します。
 | Quality | PDF ファイル作成時の解像度を設定します。
Public プロパティ | Signature | PDF に付加する署名のオブションを設定するための PdfSignature を取得します。
 | Subject | PDF ファイルのサブタイトルを設定します。
 | Title | PDF ファイルのタイトルを設定します。
 | UserPassword | PDF ファイルのユーザーパスワードを設定します。
トップ
関連項目

参照


PdfOption プロパティ

PdfOption 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
 | Application | PDF ファイルのアプリケーションを設定します。
 | Author | PDF ファイルの作成者を設定します。
 | CreateFileWithoutSignature | 電子署名、タイムスタンプ付与失敗時に PDF ファイルを生成するかを指定します。
 | EmbedFonts | PDF ファイルに埋め込むフォントを設定します。
 | EncryptionType | PDF ファイルの暗号化強度を設定します。
 | EUDCFiles | PDF ファイルで使用する外字ファイル名と対象とするフォント名を指定します。 フォントの種類毎に外字ファイルを切り替えることが可能です。
 | ImageType | PDF ファイルのイメージの種類を設定します。
 | IsReplaceYenSign | PDF ファイルに出力する文字列の"\"マークの扱いを指定します。
 | OwnerPassword | PDF ファイルのオーナーパスワードを設定します。
 | PatternQuality | PDF ファイル作成時のパターンの解像度を設定します。
 | Permit | PDF ファイルの権限を設定します。
 | Producer | PDF ファイルの PDF 変換を設定します。
 | Quality | PDF ファイル作成時の解像度を設定します。
Public プロパティ | Signature | PDF に付加する署名のオブションを設定するための PdfSignature を取得します。
 | Subject | PDF ファイルのサブタイトルを設定します。
 | Title | PDF ファイルのタイトルを設定します。
 | UserPassword | PDF ファイルのユーザーパスワードを設定します。
トップ
関連項目

参照

PdfOption クラス


PdfOption.Application プロパティ

PdfOptionApplication プロパティ

PDF ファイルのアプリケーションを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Application { set; }
Public WriteOnly Property Application As String
    Set

プロパティ値

型: String
PDF ファイルの文書のプロパティ概要「アプリケーション」。(既定値:VB-Report 12.0 for .NET)
例
C#
VB
コピー
// PDF ファイルのアプリケーションに文字列 "アプリケーション" を設定します。
cellReport1.Pdf.Application = "アプリケーション";
' PDF ファイルのアプリケーションに文字列 "アプリケーション" を設定します。
CellReport1.Pdf.Application = "アプリケーション"
関連項目

参照

PdfOption クラス


PdfOption.Author プロパティ

PdfOptionAuthor プロパティ

PDF ファイルの作成者を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Author { set; }
Public WriteOnly Property Author As String
    Set

プロパティ値

型: String
PDF ファイルの文書のプロパティ概要「作成者」。(既定値:Advance Software Co., Ltd.)
例
C#
VB
コピー
// PDF ファイルの作成者に文字列 "アドバンスソフトウェア" を設定します。
cellReport1.Pdf.Author = "アドバンスソフトウェア";
' PDF ファイルの作成者に文字列 "アドバンスソフトウェア" を設定します。
CellReport1.Pdf.Author = "アドバンスソフトウェア"
関連項目

参照

PdfOption クラス


PdfOption.CreateFileWithoutSignature プロパティ

PdfOptionCreateFileWithoutSignature プロパティ

電子署名、タイムスタンプ付与失敗時に PDF ファイルを生成するかを指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool CreateFileWithoutSignature { get; set; }
Public Property CreateFileWithoutSignature As Boolean
    Get
    Set

プロパティ値

型: Boolean
付与失敗時に署名なしの PDF ファイルを生成する場合は true。(既定値:false)
例
C#
VB
コピー
// 電子署名の付与失敗時に署名なしのファイルが出力されるように設定します。
cellReport1.Pdf.CreateFileWithoutSignature = true;
' 電子署名の付与失敗時に署名なしのファイルが出力されるように設定します。
CellReport1.Pdf.CreateFileWithoutSignature = True
関連項目

参照

PdfOption クラス


PdfOption.EmbedFonts プロパティ

PdfOptionEmbedFonts プロパティ

PDF ファイルに埋め込むフォントを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string[] EmbedFonts { set; }
Public WriteOnly Property EmbedFonts As String()
    Set

プロパティ値

型: String
PDF ファイルに埋め込むフォント名。
解説
設定したフォントが帳票内で使用されていない場合は、PDF ファイルには埋め込まれません。 "*" を設定した場合、帳票内で使用しているフォントを全て埋め込みます。
例
C#
VB
コピー
// PDF ファイルにフォント "ＭＳ Ｐゴシック" を埋め込みます。
cellReport1.Pdf.EmbedFonts = new String[] { "ＭＳ Ｐゴシック" };
' PDF ファイルにフォント "ＭＳ Ｐゴシック" を埋め込みます。
CellReport1.Pdf.EmbedFonts = New String() {"ＭＳ Ｐゴシック"}
関連項目

参照

PdfOption クラス


PdfOption.EncryptionType プロパティ

PdfOptionEncryptionType プロパティ

PDF ファイルの暗号化強度を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PdfEncryptionType EncryptionType { set; }
Public WriteOnly Property EncryptionType As PdfEncryptionType
    Set

プロパティ値

型: PdfEncryptionType
PDF の暗号化強度を表す PdfEncryptionType 列挙体。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
// PDF ファイルの暗号化強度を "Acrobat6_RC4_128" に設定します。
cellReport1.Pdf.EncryptionType = AdvanceSoftware.ASReport.PdfEncryptionType.Acrobat6_RC4_128;
cellReport1.Pdf.OwnerPassword = "owner";
cellReport1.Pdf.UserPassword = "user";
AdvanceSoftware.ASReport.PdfPermit pdfPermit = 0;
pdfPermit = pdfPermit | AdvanceSoftware.ASReport.PdfPermit.PrintHigh | AdvanceSoftware.ASReport.PdfPermit.Copy;
cellReport1.Pdf.Permit = pdfPermit;
cellReport1.Report.End();
cellReport1.Report.SavePdf(@"C:\out1.pdf");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
' PDF ファイルの暗号化強度を "Acrobat6_RC4_128" に設定します。
CellReport1.Pdf.EncryptionType = AdvanceSoftware.ASReport.PdfEncryptionType.Acrobat6_RC4_128
CellReport1.Pdf.OwnerPassword = "owner"
CellReport1.Pdf.UserPassword = "user"
Dim pdfPermit As AdvanceSoftware.ASReport.PdfPermit = 0
pdfPermit = pdfPermit Or AdvanceSoftware.ASReport.PdfPermit.PrintHigh Or AdvanceSoftware.ASReport.PdfPermit.Copy
CellReport1.Pdf.Permit = pdfPermit
CellReport1.Report.End()
CellReport1.Report.SavePdf("C:\out1.pdf")
関連項目

参照

PdfOption クラス


PdfOption.EUDCFiles プロパティ

PdfOptionEUDCFiles プロパティ

PDF ファイルで使用する外字ファイル名と対象とするフォント名を指定します。 フォントの種類毎に外字ファイルを切り替えることが可能です。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string[][] EUDCFiles { set; }
Public WriteOnly Property EUDCFiles As String()()
    Set

プロパティ値

型: String
解説
フォント名と、ファイルパスの設定方法により、PDF で使用される外字の状態が異なります。 【フォント名】 ・パターン1・・・特定のフォント名 ファイルパスに設定された外字ファイルを参照します。 環境の同一フォントに対する外字設定は無視されます。 ・パターン2・・・SystemDefaultEUDCFont 環境に設定されたデフォルトの外字設定を、ファイルパスに設定した外字ファイルから読み込みます。 環境のデフォルトのフォント設定は無視されます。 ・パターン3・・・空文字("") 環境に登録されたすべての外字設定を無視します。 使用する外字を全て手動で指定したい場合は、この設定を含めてください。 【ファイルパス】 ・パターン1・・・存在するファイルパス 指定したフォントに対して、このパスの外字ファイルが取り込まれます。 ・パターン2・・・存在しないファイルパス 指定したフォントの外字設定は無視され、環境に同一フォントの 外字設定がある場合、そちらが読み込まれます。 ・パターン3・・・空文字("") 指定したフォントに対する、外字の設定を行ないません。 環境の設定も無視されます。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
// 環境の外字設定を無視して "ＭＳ 明朝" の外字を指定します。
cellReport1.Pdf.EUDCFiles = new string[][] { new string[] { "ＭＳ 明朝", @"C:\ms_mintyou.TTE" }, new string[] { "", "" } };
cellReport1.Report.End();
cellReport1.Report.SavePdf(@"C:\out1.pdf");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
' 環境の外字設定を無視して "ＭＳ 明朝" の外字を指定します。
CellReport1.Pdf.EUDCFiles = New String()() {New String() {"ＭＳ 明朝", "C:\ms_mintyou.TTE"}, New String() {"", ""}}
CellReport1.Report.End()
CellReport1.Report.SavePdf("C:\out1.pdf")
関連項目

参照

PdfOption クラス


PdfOption.ImageType プロパティ

PdfOptionImageType プロパティ

PDF ファイルのイメージの種類を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ImageType ImageType { set; }
Public WriteOnly Property ImageType As ImageType
    Set

プロパティ値

型: ImageType
PDF ファイルのイメージの種類を表す ImageType。
解説
挿入するイメージ画像の形式に合わせて設定します。
例
C#
VB
コピー
// PDF ファイルのイメージの種類を "GIF 形式" に設定します。
cellReport1.Pdf.ImageType = AdvanceSoftware.ASReport.ImageType.GIF;
' PDF ファイルのイメージの種類を "GIF 形式" に設定します。
CellReport1.Pdf.ImageType = AdvanceSoftware.ASReport.ImageType.GIF
関連項目

参照

PdfOption クラス


PdfOption.IsReplaceYenSign プロパティ

PdfOptionIsReplaceYenSign プロパティ

PDF ファイルに出力する文字列の"\"マークの扱いを指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool IsReplaceYenSign { set; }
Public WriteOnly Property IsReplaceYenSign As Boolean
    Set

プロパティ値

型: Boolean
円記号(U+00A5)をバックスラッシュとして扱う場合は false。
例
C#
VB
コピー
// 円マークをバックスラッシュに変換します。
cellReport1.Pdf.IsReplaceYenSign = false;
' 円マークをバックスラッシュに変換します。
CellReport1.Pdf.IsReplaceYenSign = False
関連項目

参照

PdfOption クラス


PdfOption.OwnerPassword プロパティ

PdfOptionOwnerPassword プロパティ

PDF ファイルのオーナーパスワードを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string OwnerPassword { set; }
Public WriteOnly Property OwnerPassword As String
    Set

プロパティ値

型: String
オーナーパスワード。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Pdf.EncryptionType = AdvanceSoftware.ASReport.PdfEncryptionType.Acrobat6_RC4_128;
// PDF ファイルのオーナーパスワードを "owner" に設定します。
cellReport1.Pdf.OwnerPassword = "owner";
cellReport1.Pdf.UserPassword = "user";
AdvanceSoftware.ASReport.PdfPermit pdfPermit = 0;
pdfPermit = pdfPermit | AdvanceSoftware.ASReport.PdfPermit.PrintHigh | AdvanceSoftware.ASReport.PdfPermit.Copy;
cellReport1.Pdf.Permit = pdfPermit;
cellReport1.Report.End();
cellReport1.Report.SavePdf(@"C:\out1.pdf");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Pdf.EncryptionType = AdvanceSoftware.ASReport.PdfEncryptionType.Acrobat6_RC4_128
' PDF ファイルのオーナーパスワードを "owner" に設定します。
CellReport1.Pdf.OwnerPassword = "owner"
CellReport1.Pdf.UserPassword = "user"
Dim pdfPermit As AdvanceSoftware.ASReport.PdfPermit = 0
pdfPermit = pdfPermit Or AdvanceSoftware.ASReport.PdfPermit.PrintHigh Or AdvanceSoftware.ASReport.PdfPermit.Copy
CellReport1.Pdf.Permit = pdfPermit
CellReport1.Report.End()
CellReport1.Report.SavePdf("C:\out1.pdf")
関連項目

参照

PdfOption クラス


PdfOption.PatternQuality プロパティ

PdfOptionPatternQuality プロパティ

PDF ファイル作成時のパターンの解像度を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int PatternQuality { set; }
Public WriteOnly Property PatternQuality As Integer
    Set

プロパティ値

型: Int32
PDF ファイル作成時のセルパターンの解像度。
例
C#
VB
コピー
// PDF ファイル作成時のパターンの解像度を "600" に設定します。
 cellReport1.Pdf.PatternQuality = 600;
' PDF ファイル作成時のパターンの解像度を "600" に設定します。
CellReport1.Pdf.PatternQuality = 600
関連項目

参照

PdfOption クラス


PdfOption.Permit プロパティ

PdfOptionPermit プロパティ

PDF ファイルの権限を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PdfPermit Permit { set; }
Public WriteOnly Property Permit As PdfPermit
    Set

プロパティ値

型: PdfPermit
PDF の権限を表す PdfPermit 列挙体。複数の指定時は PdfPermit 列挙体のメンバーを or(|) 演算子で連結します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Pdf.EncryptionType = AdvanceSoftware.ASReport.PdfEncryptionType.Acrobat6_RC4_128;
cellReport1.Pdf.OwnerPassword = "owner";
cellReport1.Pdf.UserPassword = "user";
// PDF ファイルの権限で「高精度な印刷」と「内容のコピー」を許可します。
AdvanceSoftware.ASReport.PdfPermit pdfPermit = 0;
pdfPermit = pdfPermit | AdvanceSoftware.ASReport.PdfPermit.PrintHigh | AdvanceSoftware.ASReport.PdfPermit.Copy;
cellReport1.Pdf.Permit = pdfPermit;
cellReport1.Report.End();
cellReport1.Report.SavePdf(@"C:\out1.pdf");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Pdf.EncryptionType = AdvanceSoftware.ASReport.PdfEncryptionType.Acrobat6_RC4_128
CellReport1.Pdf.OwnerPassword = "owner"
CellReport1.Pdf.UserPassword = "user"
' PDF ファイルの権限で「高精度な印刷」と「内容のコピー」を許可します。
Dim pdfPermit As AdvanceSoftware.ASReport.PdfPermit = 0
pdfPermit = pdfPermit Or AdvanceSoftware.ASReport.PdfPermit.PrintHigh Or AdvanceSoftware.ASReport.PdfPermit.Copy
CellReport1.Pdf.Permit = pdfPermit
CellReport1.Report.End()
CellReport1.Report.SavePdf("C:\out1.pdf")
関連項目

参照

PdfOption クラス


PdfOption.Producer プロパティ

PdfOptionProducer プロパティ

PDF ファイルの PDF 変換を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Producer { set; }
Public WriteOnly Property Producer As String
    Set

プロパティ値

型: String
PDF ファイルの文書のプロパティ概要「PDF 変換」。(既定値:VB-Report 12.0 for .NET)
例
C#
VB
コピー
// PDF ファイルの PDF 変換に文字列 "PDF 変換" を設定します。
cellReport1.Pdf.Producer = "PDF 変換";
' PDF ファイルの PDF 変換に文字列 "PDF 変換" を設定します。
CellReport1.Pdf.Producer = "PDF 変換"
関連項目

参照

PdfOption クラス


PdfOption.Quality プロパティ

PdfOptionQuality プロパティ

PDF ファイル作成時の解像度を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int Quality { set; }
Public WriteOnly Property Quality As Integer
    Set

プロパティ値

型: Int32
PDF ファイル作成時の解像度。
例
C#
VB
コピー
// PDF ファイル作成時の解像度を "600" に設定します。
 cellReport1.Pdf.Quality = 600;
' PDF ファイル作成時の解像度を "600" に設定します。
CellReport1.Pdf.Quality = 600
関連項目

参照

PdfOption クラス


PdfOption.Signature プロパティ

PdfOptionSignature プロパティ

PDF に付加する署名のオブションを設定するための PdfSignature を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PdfSignature Signature { get; }
Public ReadOnly Property Signature As PdfSignature
    Get

プロパティ値

型: PdfSignature
PDF に付加する署名のオプションを設定するための PdfSignature クラス。
解説
このクラスの全てのメンバの一覧については、PdfSignature クラスのメンバを参照してください。
関連項目

参照

PdfOption クラス


PdfOption.Subject プロパティ

PdfOptionSubject プロパティ

PDF ファイルのサブタイトルを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Subject { set; }
Public WriteOnly Property Subject As String
    Set

プロパティ値

型: String
PDF ファイルの文書のプロパティ概要「サブタイトル」。(既定値:シート名)
例
C#
VB
コピー
// PDF ファイルのサブタイトルに文字列 "サブタイトル" を設定します。
cellReport1.Pdf.Subject = "サブタイトル";
' PDF ファイルのサブタイトルに文字列 "サブタイトル" を設定します。
CellReport1.Pdf.Subject = "サブタイトル"
関連項目

参照

PdfOption クラス


PdfOption.Title プロパティ

PdfOptionTitle プロパティ

PDF ファイルのタイトルを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Title { set; }
Public WriteOnly Property Title As String
    Set

プロパティ値

型: String
PDF ファイルの文書のプロパティ概要「タイトル」。(既定値:VB-Report 12.0 for .NET)
例
C#
VB
コピー
// PDF ファイルのタイトルに文字列 "タイトル" を設定します。
cellReport1.Pdf.Title = "タイトル";
' PDF ファイルのタイトルに文字列 "タイトル" を設定します。
CellReport1.Pdf.Title = "タイトル"
関連項目

参照

PdfOption クラス


PdfOption.UserPassword プロパティ

PdfOptionUserPassword プロパティ

PDF ファイルのユーザーパスワードを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string UserPassword { set; }
Public WriteOnly Property UserPassword As String
    Set

プロパティ値

型: String
ユーザーパスワード。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Pdf.EncryptionType = AdvanceSoftware.ASReport.PdfEncryptionType.Acrobat6_RC4_128;
cellReport1.Pdf.OwnerPassword = "owner";
// PDF ファイルのユーザーパスワードを "user" に設定します。
cellReport1.Pdf.UserPassword = "user";
AdvanceSoftware.ASReport.PdfPermit pdfPermit = 0;
pdfPermit = pdfPermit | AdvanceSoftware.ASReport.PdfPermit.PrintHigh | AdvanceSoftware.ASReport.PdfPermit.Copy;
cellReport1.Pdf.Permit = pdfPermit;
cellReport1.Report.End();
cellReport1.Report.SavePdf(@"C:\out1.pdf");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Pdf.EncryptionType = AdvanceSoftware.ASReport.PdfEncryptionType.Acrobat6_RC4_128
CellReport1.Pdf.OwnerPassword = "owner"
' PDF ファイルのユーザーパスワードを "user" に設定します。
CellReport1.Pdf.UserPassword = "user"
Dim pdfPermit As AdvanceSoftware.ASReport.PdfPermit = 0
pdfPermit = pdfPermit Or AdvanceSoftware.ASReport.PdfPermit.PrintHigh Or AdvanceSoftware.ASReport.PdfPermit.Copy
CellReport1.Pdf.Permit = pdfPermit
CellReport1.Report.End()
CellReport1.Report.SavePdf("C:\out1.pdf")
関連項目

参照

PdfOption クラス


PdfPermit 列挙体

PDF の権限を示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum PdfPermit
Public Enumeration PdfPermit
メンバー
メンバー | 値 | 説明
Print | 4 | 低解像度のみ印刷許可
Change | 8 | 文書の編集の許可
Copy | 16 | 文書の選択、コピーの許可
Comment | 32 | 注釈の編集の許可
FormField | 256 | フォームに対する入力の許可
ContentAccess | 512 | 読み上げ機能の使用の許可
DocumentAssembly | 1024 | ページの挿入や削除や回転、しおり、サムネールの作成の許可
PrintHigh | 2048 | 高解像度の印刷許可
関連項目

参照


PdfSignature クラス

PDF に付加する署名のオプションを設定します。レポートコンポーネントを通じてこのクラスにアクセスします。
継承階層
SystemObject
AdvanceSoftware.ASReportPdfSignature

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class PdfSignature
Public Class PdfSignature

PdfSignature 型は下記のメンバーを公開します。

プロパティ
名前 | 説明
Capacity | PDF ファイルの電子署名データに割り当てられたバイト数を設定、取得します。
CertificateData | ローカルの証明書(pfx)データを設定、取得します。
CertificatePassword | ローカルの証明書(pfx)データのパスワードを設定、取得します。
Contact | 署名の連絡先を設定、取得します。
Date | 署名時刻を設定、取得します。
Location | 署名の場所を設定、取得します。
Reason | 署名の理由を設定、取得します。
TimeStampPassword | 署名の埋め込みタイムスタンプサーバーのパスワードを設定、取得します。
TimeStampUrl | 署名の埋め込みタイムスタンプサーバーの URL を設定、取得します。
TimeStampUser | 署名の埋め込みタイムスタンプサーバーのユーザー名を設定、取得します。
WindowsCertificate | Windows 証明書を設定、取得します。
トップ
関連項目

参照


PdfSignature プロパティ

PdfSignature 型は下記のメンバーを公開します。

プロパティ
名前 | 説明
Capacity | PDF ファイルの電子署名データに割り当てられたバイト数を設定、取得します。
CertificateData | ローカルの証明書(pfx)データを設定、取得します。
CertificatePassword | ローカルの証明書(pfx)データのパスワードを設定、取得します。
Contact | 署名の連絡先を設定、取得します。
Date | 署名時刻を設定、取得します。
Location | 署名の場所を設定、取得します。
Reason | 署名の理由を設定、取得します。
TimeStampPassword | 署名の埋め込みタイムスタンプサーバーのパスワードを設定、取得します。
TimeStampUrl | 署名の埋め込みタイムスタンプサーバーの URL を設定、取得します。
TimeStampUser | 署名の埋め込みタイムスタンプサーバーのユーザー名を設定、取得します。
WindowsCertificate | Windows 証明書を設定、取得します。
トップ
関連項目

参照

PdfSignature クラス


PdfSignature.Capacity プロパティ

PdfSignatureCapacity プロパティ

PDF ファイルの電子署名データに割り当てられたバイト数を設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int Capacity { get; set; }
Public Property Capacity As Integer
    Get
    Set

プロパティ値

型: Int32
電子署名データのバイト数
解説
指定サイズが電子署名データより小さい場合、サイズを拡張してリトライが行われます。 指定サイズ(上限5MB)が大きい場合、ファイルサイズが大きくなります。 未設定(0)時は既定値(16KB)が確保されます。
例
C#
VB
コピー
// 電子署名データの割り当てバイト数 に 100KB を設定します。
cellReport1.Pdf.Signature.Capacity = 102400;
' 電子署名データの割り当てバイト数 に 100KB を設定します。
CellReport1.Pdf.Signature.Capacity = 102400
関連項目

参照

PdfSignature クラス


PdfSignature.CertificateData プロパティ

PdfSignatureCertificateData プロパティ

ローカルの証明書(pfx)データを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public byte[] CertificateData { get; set; }
Public Property CertificateData As Byte()
    Get
    Set

プロパティ値

型: Byte
ローカルの証明書(pfx)データ(既定値:Null)
解説
設定されたローカル証明書データが有効な場合、電子署名が付加されます。 ローカル証明書データが無効、または未設定(Null)時は電子署名が付加されません。 Windows 証明書を設定する WindowsCertificate プロパティとは排他的に機能します。
例
C#
VB
コピー
// ローカルの証明書(pfx)データに "C:\Certificate.pfx" ファイルの内容を設定します。。
cellReport1.Pdf.Signature.CertificateData = System.IO.File.ReadAllBytes(@"C:\Certificate.pfx");
' ローカルの証明書(pfx)データ "C:\Certificate.pfx" ファイルの内容を設定します。
CellReport1.Pdf.Signature.CertificateData = System.IO.File.ReadAllBytes("C:\Certificate.pfx")
関連項目

参照

PdfSignature クラス


PdfSignature.CertificatePassword プロパティ

PdfSignatureCertificatePassword プロパティ

ローカルの証明書(pfx)データのパスワードを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string CertificatePassword { get; set; }
Public Property CertificatePassword As String
    Get
    Set

プロパティ値

型: String
ローカルの証明書(pfx)データのパスワード(既定値:空白)
例
C#
VB
コピー
// ローカルの証明書(pfx)データのパスワード "pass" を設定します。
cellReport1.Pdf.Signature.CertificatePassword = "pass";
' ローカルの証明書(pfx)データのパスワード "pass" を設定します。
CellReport1.Pdf.Signature.CertificatePassword = "pass"
関連項目

参照

PdfSignature クラス


PdfSignature.Contact プロパティ

PdfSignatureContact プロパティ

署名の連絡先を設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Contact { get; set; }
Public Property Contact As String
    Get
    Set

プロパティ値

型: String
連絡先(既定値:空白)
例
C#
VB
コピー
// 連絡先に "info@adv.co.jp" を設定します。
cellReport1.Pdf.Signature.Contact = "info@adv.co.jp";
' 連絡先に "info@adv.co.jp" を設定します。
CellReport1.Pdf.Signature.Contact = "info@adv.co.jp"
関連項目

参照

PdfSignature クラス


PdfSignature.Date プロパティ

PdfSignatureDate プロパティ

署名時刻を設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public DateTime Date { get; set; }
Public Property Date As DateTime
    Get
    Set

プロパティ値

型: DateTime
署名時刻(既定値:システム時刻)
解説
DateTime.MinValue 設定時、未設定の場合は署名時のシステム時刻が設定されます。
例
C#
VB
コピー
// 署名時刻に 2024/4/1 12:00:00 を設定します。
cellReport1.Pdf.Signature.Date = new DateTime(2024, 4, 1, 12, 0, 0);
' 署名時刻に 2024/4/1 12:00:00 を設定します。
CellReport1.Pdf.Signature.Contact = New DateTime(2024, 4, 1, 12, 0, 0)
関連項目

参照

PdfSignature クラス


PdfSignature.Location プロパティ

PdfSignatureLocation プロパティ

署名の場所を設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Location { get; set; }
Public Property Location As String
    Get
    Set

プロパティ値

型: String
場所(既定値:空白)
例
C#
VB
コピー
// 場所に "日本" を設定します。
cellReport1.Pdf.Signature.Location = "日本";
' 場所に "日本" を設定します。
CellReport1.Pdf.Signature.Location = "日本"
関連項目

参照

PdfSignature クラス


PdfSignature.Reason プロパティ

PdfSignatureReason プロパティ

署名の理由を設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Reason { get; set; }
Public Property Reason As String
    Get
    Set

プロパティ値

型: String
理由(既定値:空白)
例
C#
VB
コピー
// 理由に "稟議" を設定します。
cellReport1.Pdf.Signature.Reason = "稟議";
' 理由に "稟議" を設定します。
CellReport1.Pdf.Signature.Reason = "稟議"
関連項目

参照

PdfSignature クラス


PdfSignature.TimeStampPassword プロパティ

PdfSignatureTimeStampPassword プロパティ

署名の埋め込みタイムスタンプサーバーのパスワードを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string TimeStampPassword { get; set; }
Public Property TimeStampPassword As String
    Get
    Set

プロパティ値

型: String
タイムスタンプサーバーのパスワード(既定値:空白)
解説
タイムスタンプトークンが取得できない場合は埋め込みタイムスタンプが付加されません。
例
C#
VB
コピー
// タイムスタンプサーバーの パスワード "pass" を設定します。
cellReport1.Pdf.Signature.TimeStampPassword = "pass";
' タイムスタンプサーバーの パスワード "pass" を設定します。
CellReport1.Pdf.Signature.TimeStampPassword = "pass"
関連項目

参照

PdfSignature クラス


PdfSignature.TimeStampUrl プロパティ

PdfSignatureTimeStampUrl プロパティ

署名の埋め込みタイムスタンプサーバーの URL を設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string TimeStampUrl { get; set; }
Public Property TimeStampUrl As String
    Get
    Set

プロパティ値

型: String
タイムスタンプサーバーの URL(既定値:空白)
解説
設定された URL でタイムスタンプトークンが取得された場合、電子署名に埋め込みタイムスタンプを付加します。 タイムスタンプトークンが取得できない、または未設定(空白)時は埋め込みタイムスタンプが付加されません。
例
C#
VB
コピー
// タイムスタンプサーバーの URL "https://freetsa.org/tsr" を設定します。
cellReport1.Pdf.Signature.TimeStampUrl = "https://freetsa.org/tsr";
' タイムスタンプサーバーの URL "https://freetsa.org/tsr" を設定します。
CellReport1.Pdf.Signature.TimeStampUrl = "https://freetsa.org/tsr"
関連項目

参照

PdfSignature クラス


PdfSignature.TimeStampUser プロパティ

PdfSignatureTimeStampUser プロパティ

署名の埋め込みタイムスタンプサーバーのユーザー名を設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string TimeStampUser { get; set; }
Public Property TimeStampUser As String
    Get
    Set

プロパティ値

型: String
タイムスタンプサーバーのユーザー名(既定値:空白)
解説
タイムスタンプトークンが取得できない場合は埋め込みタイムスタンプが付加されません。
例
C#
VB
コピー
// タイムスタンプサーバーの ユーザー名 "user" を設定します。
cellReport1.Pdf.Signature.TimeStampUser = "user";
' タイムスタンプサーバーの ユーザー名 "user" を設定します。
CellReport1.Pdf.Signature.TimeStampUser = "user"
関連項目

参照

PdfSignature クラス


PdfSignature.WindowsCertificate プロパティ

PdfSignatureWindowsCertificate プロパティ

Windows 証明書を設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public X509Certificate2 WindowsCertificate { get; set; }
Public Property WindowsCertificate As X509Certificate2
    Get
    Set

プロパティ値

型: X509Certificate2
Windows 証明書(既定値:Null)
解説
設定された Window 証明書が有効な場合、電子署名が付加されます。 Windows 証明書が無効、または未設定(Null)時は電子署名が付加されません。 ローカル証明書(pfx)データを設定する CertificateData プロパティとは排他的に機能します。
例
C#
VB
コピー
// Windows 証明書を設定します。
cellReport1.Pdf.Signature.WindowsCertificate = certificate;
' Windows 証明書を設定します。
CellReport1.Pdf.Signature.WindowsCertificate = certificate
関連項目

参照

PdfSignature クラス


PrintButtonMode 列挙体

印刷ボタンの動作を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum PrintButtonMode
Public Enumeration PrintButtonMode
メンバー
メンバー | 値 | 説明
Print | 0 | 直接印刷
Menu | 1 | 印刷メニュー表示
Dialog | 2 | 印刷ダイアログ表示
関連項目

参照


Printer クラス

帳票の出力先プリンタの情報を扱う Printer オブジェクトです。ViewerControl オブジェクトを通じてこのクラスにアクセスします。
継承階層
SystemObject
AdvanceSoftware.ASReportPrinter

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Printer
Public Class Printer

Printer 型は下記のメンバーを公開します。

コンストラクター
 | 名前 | 説明
Public メソッド | Printer | コンストラクター
トップ
プロパティ
 | 名前 | 説明
 | ColorMode | カラーモードを設定、取得します。
 | Copies | 部数を設定、取得します。
 | Duplex | 両面印刷を設定、取得します。
 | ForceCollate | 部数分印刷ジョブを発行し、強制的に部単位印刷を行うかどうかを設定します。
Public プロパティ | IgnoreInvalidArea | ViewerControl を使用した帳票出力時にプリンターの印字可能領域を適用するかどうかを設定します。
 | JobPages | 1ジョブあたりのページ数を指定します。
 | Name | プリンタ名を取得します。
 | PaperSource | 用紙トレイを設定、取得します。
 | PrinterResolution | 解像度を設定、取得します。
トップ
関連項目

参照


Printer コンストラクター

コンストラクター

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Printer(
    ViewerControl viewer
)
Public Sub New (
    viewer As ViewerControl
)

パラメーター

viewer
型: AdvanceSoftware.ASReportViewerControl
AdvanceSoftware.ASReport.ViewerControl を指定します。
関連項目

参照

Printer クラス


Printer プロパティ

Printer 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
 | ColorMode | カラーモードを設定、取得します。
 | Copies | 部数を設定、取得します。
 | Duplex | 両面印刷を設定、取得します。
 | ForceCollate | 部数分印刷ジョブを発行し、強制的に部単位印刷を行うかどうかを設定します。
Public プロパティ | IgnoreInvalidArea | ViewerControl を使用した帳票出力時にプリンターの印字可能領域を適用するかどうかを設定します。
 | JobPages | 1ジョブあたりのページ数を指定します。
 | Name | プリンタ名を取得します。
 | PaperSource | 用紙トレイを設定、取得します。
 | PrinterResolution | 解像度を設定、取得します。
トップ
関連項目

参照

Printer クラス


Printer.ColorMode プロパティ

PrinterColorMode プロパティ

カラーモードを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ColorMode { get; set; }
Public Property ColorMode As Boolean
    Get
    Set

プロパティ値

型: Boolean
解説
ExcelMode = True 時は設定は反映されません。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// カラーモードを "カラー" に設定します。
viewerControl1.Printer.ColorMode = true;
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' カラーモードを "カラー" に設定します。
ViewerControl1.Printer.ColorMode = True
ViewerControl1.Document = CellReport1.Document
関連項目

参照

Printer クラス


Printer.Copies プロパティ

PrinterCopies プロパティ

部数を設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public short Copies { get; set; }
Public Property Copies As Short
    Get
    Set

プロパティ値

型: Int16
印刷部数
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// 印刷部数を "3 部" に設定します。
viewerControl1.Printer.Copies = 3;
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' 印刷部数を "3 部" に設定します。
ViewerControl1.Printer.Copies = 3
ViewerControl1.Document = CellReport1.Document
関連項目

参照

Printer クラス


Printer.Duplex プロパティ

PrinterDuplex プロパティ

両面印刷を設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Duplex Duplex { get; set; }
Public Property Duplex As Duplex
    Get
    Set

プロパティ値

型: Duplex
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1-99999");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// 両面印刷を設定します。
viewerControl1.Printer.Duplex = System.Drawing.Printing.Duplex.Horizontal;
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1-99999")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' 両面印刷を設定します。
ViewerControl1.Printer.Duplex = System.Drawing.Printing.Duplex.Horizontal
ViewerControl1.Document = CellReport1.Document
関連項目

参照

Printer クラス


Printer.ForceCollate プロパティ

PrinterForceCollate プロパティ

部数分印刷ジョブを発行し、強制的に部単位印刷を行うかどうかを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ForceCollate { set; }
Public WriteOnly Property ForceCollate As Boolean
    Set

プロパティ値

型: Boolean
True：強制的に部単位印刷を行う。 False：強制的に部単位印刷を行わない。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1-99999");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// 強制的に部単位印刷を行います。
viewerControl1.Printer.ForceCollate = true;
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1-99999")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' 強制的に部単位印刷を行います。
ViewerControl1.Printer.ForceCollate = True
ViewerControl1.Document = CellReport1.Document
関連項目

参照

Printer クラス


Printer.IgnoreInvalidArea プロパティ

PrinterIgnoreInvalidArea プロパティ

ViewerControl を使用した帳票出力時にプリンターの印字可能領域を適用するかどうかを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool IgnoreInvalidArea { get; set; }
Public Property IgnoreInvalidArea As Boolean
    Get
    Set

プロパティ値

型: Boolean
True：印字可能領域を無視する。 False：印字可能領域を適用する。
関連項目

参照

Printer クラス


Printer.JobPages プロパティ

PrinterJobPages プロパティ

1ジョブあたりのページ数を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int JobPages { get; set; }
Public Property JobPages As Integer
    Get
    Set

プロパティ値

型: Int32
ページ数(既定値：0[全ページ])
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1-99999");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// 1 ジョブあたりのページ数を 1 ページに設定します。
viewerControl1.Printer.JobPages = 1;
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1-99999")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' 1 ジョブあたりのページ数を 1 ページに設定します。
ViewerControl1.Printer.JobPages = 1
ViewerControl1.Document = CellReport1.Document
関連項目

参照

Printer クラス


Printer.Name プロパティ

PrinterName プロパティ

プリンタ名を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Name { get; }
Public ReadOnly Property Name As String
    Get

プロパティ値

型: String
プリンタ名
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// プリンタ名を取得します。
string name = viewerControl1.Printer.Name;
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' プリンタ名を取得します。
Dim name As String = ViewerControl1.Printer.Name
ViewerControl1.Document = CellReport1.Document
関連項目

参照

Printer クラス


Printer.PaperSource プロパティ

PrinterPaperSource プロパティ

用紙トレイを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PaperSource PaperSource { get; set; }
Public Property PaperSource As PaperSource
    Get
    Set

プロパティ値

型: PaperSource
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// 給紙方法を "手差し" に設定します。
System.Drawing.Printing.PrintDocument printDocument = new System.Drawing.Printing.PrintDocument();
for (int i = 0; i < printDocument.PrinterSettings.PaperSources.Count; i++)
{
    if (printDocument.PrinterSettings.PaperSources[i].SourceName.Equals("手差し"))
    {
        viewerControl1.Printer.PaperSource = printDocument.PrinterSettings.PaperSources[i];
    }
}
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' 給紙方法を "手差し" に設定します。
Dim printDocument As System.Drawing.Printing.PrintDocument = New System.Drawing.Printing.PrintDocument()
For i As Integer = 0 To printDocument.PrinterSettings.PaperSources.Count - 1
    If printDocument.PrinterSettings.PaperSources(i).SourceName.Equals("手差し") Then
        ViewerControl1.Printer.PaperSource = printDocument.PrinterSettings.PaperSources(i)
    End If
Next
ViewerControl1.Document = CellReport1.Document
関連項目

参照

Printer クラス


Printer.PrinterResolution プロパティ

PrinterPrinterResolution プロパティ

解像度を設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PrinterResolution PrinterResolution { get; set; }
Public Property PrinterResolution As PrinterResolution
    Get
    Set

プロパティ値

型: PrinterResolution
解像度
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// X、Y 方向の解像度を "600" に設定します。
System.Drawing.Printing.PrintDocument printDocument = new System.Drawing.Printing.PrintDocument();
for (int i = 0; i < printDocument.PrinterSettings.PrinterResolutions.Count; i++)
{
    if (printDocument.PrinterSettings.PrinterResolutions[i].X == 600 && printDocument.PrinterSettings.PrinterResolutions[i].Y == 600)
    {
        viewerControl1.Printer.PrinterResolution = printDocument.PrinterSettings.PrinterResolutions[i];
    }
}
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' X、Y 方向の解像度を "600" に設定します。
Dim printDocument As System.Drawing.Printing.PrintDocument = New System.Drawing.Printing.PrintDocument
For i As Integer = 0 To printDocument.PrinterSettings.PrinterResolutions.Count - 1
    If printDocument.PrinterSettings.PrinterResolutions(i).X = 600 AndAlso printDocument.PrinterSettings.PrinterResolutions(i).Y = 600 Then
        ViewerControl1.Printer.PrinterResolution = printDocument.PrinterSettings.PrinterResolutions(i)
    End If
Next
ViewerControl1.Document = CellReport1.Document
関連項目

参照

Printer クラス


PrintType 列挙体

プリントタイプを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum PrintType
Public Enumeration PrintType
メンバー
メンバー | 値 | 説明
All | 0 | 全てのページを印刷します。
Now | 1 | 現在のページを印刷します。
Set | 2 | 指定したページを印刷します。
関連項目

参照


ProgressType 列挙体

プログレスタイプを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ProgressType
Public Enumeration ProgressType
メンバー
メンバー | 値 | 説明
Print | 1 | 印刷
File | 2 | ファイル出力
Data | 3 | データ処理
関連項目

参照


ReleaseExcelTask 列挙体

Excel タスクの動作を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Document (in AdvanceSoftware.ASReport.Document.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ReleaseExcelTask
Public Enumeration ReleaseExcelTask
メンバー
メンバー | 値 | 説明
Dispose | 0 | Excel オブジェクトを起動し続けます。
OutputMethod | 1 | 出力処理の度に起動します。
関連項目

参照


Report クラス

帳票の作成開始、終了、ならびに、デザインファイルの指定を行います。レポートコンポーネントを通じてこのクラスにアクセスします。
継承階層
SystemObject
AdvanceSoftware.ASReportReport

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Report
Public Class Report

Report 型は下記のメンバーを公開します。

メソッド
名前 | 説明
Create | 帳票を新規作成します。
Embed(Byte) | 埋め込んだデザインファイルを使用して帳票の作成を開始します。
Embed(Stream) | 埋め込んだデザインファイルを使用して帳票の作成を開始します。
End | 帳票の作成を終了します。
File | デザインファイルを使用して帳票の作成を開始します。
File(Stream) | ストリーム経由でデザインファイルを使用して帳票の作成を開始します。
GetSvgReport | 作成した帳票を SVG 形式で取得します。
GetSvgReport(SvgSaveType) | 作成した帳票を SVG 形式で取得します。
GetSvgzReport | 作成した帳票を SVGZ 形式で取得します。
GetSvgzReport(SvgSaveType) | 作成した帳票を SVGZ 形式で取得します。
PrintOut | 印刷を行います。
PrintOut(String, String) | 印刷を行います。
PrintOut(String, String, Int32) | 印刷を行います。
PrintOut(String, String, Int32, Boolean) | 印刷を行います。
SaveAs(Stream) | 作成した帳票を Excel ファイルに保存します。
SaveAs(String) | 作成した帳票を Excel ファイルに保存します。
SaveAs(String, ExcelVersion) | 作成した帳票を Excel ファイルに保存します。
SavePdf(Stream) | 作成した帳票を PDF 形式で保存します。
SavePdf(String) | 作成した帳票を PDF 形式で保存します。
Start | 帳票の作成を開始します。
Start(OutputMode) | 帳票の作成を開始します。(出力モードを指定)
Start(ReportMode) | 帳票の作成を開始します。(レポートモードを指定)
Start(String) | 帳票の作成を開始します。(帳票の識別名を指定)
Start(OutputMode, String) | 帳票の作成を開始します。(出力モード、帳票の識別名を指定)
Start(ReportMode, OutputMode) | 帳票の作成を開始します。(レポートモード、出力モードを指定)
Start(ReportMode, String) | 帳票の作成を開始します。(レポートモード、帳票の識別名を指定)
Start(ReportMode, OutputMode, String) | 帳票の作成を開始します。(レポートモード、出力モード、帳票の識別名を指定)
トップ
関連項目

参照


Report メソッド

Report 型は下記のメンバーを公開します。

メソッド
名前 | 説明
Create | 帳票を新規作成します。
Embed(Byte) | 埋め込んだデザインファイルを使用して帳票の作成を開始します。
Embed(Stream) | 埋め込んだデザインファイルを使用して帳票の作成を開始します。
End | 帳票の作成を終了します。
File | デザインファイルを使用して帳票の作成を開始します。
File(Stream) | ストリーム経由でデザインファイルを使用して帳票の作成を開始します。
GetSvgReport | 作成した帳票を SVG 形式で取得します。
GetSvgReport(SvgSaveType) | 作成した帳票を SVG 形式で取得します。
GetSvgzReport | 作成した帳票を SVGZ 形式で取得します。
GetSvgzReport(SvgSaveType) | 作成した帳票を SVGZ 形式で取得します。
PrintOut | 印刷を行います。
PrintOut(String, String) | 印刷を行います。
PrintOut(String, String, Int32) | 印刷を行います。
PrintOut(String, String, Int32, Boolean) | 印刷を行います。
SaveAs(Stream) | 作成した帳票を Excel ファイルに保存します。
SaveAs(String) | 作成した帳票を Excel ファイルに保存します。
SaveAs(String, ExcelVersion) | 作成した帳票を Excel ファイルに保存します。
SavePdf(Stream) | 作成した帳票を PDF 形式で保存します。
SavePdf(String) | 作成した帳票を PDF 形式で保存します。
Start | 帳票の作成を開始します。
Start(OutputMode) | 帳票の作成を開始します。(出力モードを指定)
Start(ReportMode) | 帳票の作成を開始します。(レポートモードを指定)
Start(String) | 帳票の作成を開始します。(帳票の識別名を指定)
Start(OutputMode, String) | 帳票の作成を開始します。(出力モード、帳票の識別名を指定)
Start(ReportMode, OutputMode) | 帳票の作成を開始します。(レポートモード、出力モードを指定)
Start(ReportMode, String) | 帳票の作成を開始します。(レポートモード、帳票の識別名を指定)
Start(ReportMode, OutputMode, String) | 帳票の作成を開始します。(レポートモード、出力モード、帳票の識別名を指定)
トップ
関連項目

参照

Report クラス


Report.Create メソッド

ReportCreate メソッド

帳票を新規作成します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Create(
    ExcelVersion version
)
Public Sub Create (
    version As ExcelVersion
)

パラメーター

version
型: AdvanceSoftware.ASReportExcelVersion
Excel ファイルのバージョンを指定します。
例
C#
VB
コピー
cellReport1.Report.Start();
// Excel 2019 の形式で帳票を新規作成します。
cellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2019);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.Report.Start()
' Excel 2019 の形式で帳票を新規作成します。
CellReport1.Report.Create(AdvanceSoftware.ASReport.ExcelVersion.ver2019)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Report クラス


Report.Embed メソッド

ReportEmbed メソッド

オーバーロードの一覧
名前 | 説明
Embed(Byte) | 埋め込んだデザインファイルを使用して帳票の作成を開始します。
Embed(Stream) | 埋め込んだデザインファイルを使用して帳票の作成を開始します。
トップ
関連項目

参照

Report クラス


Report.Embed メソッド (Byte[])

ReportEmbed メソッド (Byte)

埋め込んだデザインファイルを使用して帳票の作成を開始します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Embed(
    byte[] bytes
)
Public Sub Embed (
    bytes As Byte()
)

パラメーター

bytes
型: SystemByte
リソースから取得したバイト配列を設定します。
例
C#
VB
コピー
// 現在実行中のアセンブリを取得します。
System.Reflection.Assembly assembly = System.Reflection.Assembly.GetExecutingAssembly();
// 埋め込んだデザインファイル(.resx)の基本名とアセンブリの参照を指定します。
System.Resources.ResourceManager resourceManager = new System.Resources.ResourceManager("WindowsApplication1.Book1", assembly);
cellReport1.Report.Start();
// 埋め込んだデザインファイル(.resx)を使用して帳票の作成を開始します。
cellReport1.Report.Embed((byte[])resourceManager.GetObject("ResourceID1"));
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
' 現在実行中のアセンブリを取得します。
Dim assembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
' 埋め込んだデザインファイル(.resx)の基本名とアセンブリの参照を指定します。
Dim resourceManager As System.Resources.ResourceManager = New System.Resources.ResourceManager("WindowsApplication1.Book1", assembly)
CellReport1.Report.Start()
' 埋め込んだデザインファイル(.resx)を使用して帳票の作成を開始します。
CellReport1.Report.Embed(CType(resourceManager.GetObject("ResourceID1"), Byte()))
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Report クラス
Embed オーバーロード


Report.Embed メソッド (Stream)

ReportEmbed メソッド (Stream)

埋め込んだデザインファイルを使用して帳票の作成を開始します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Embed(
    Stream stream
)
Public Sub Embed (
    stream As Stream
)

パラメーター

stream
型: System.IOStream
リソースから取得した Stream を設定します。
例
C#
VB
コピー
// 現在実行中のアセンブリを取得します。
System.Reflection.Assembly assembly = System.Reflection.Assembly.GetExecutingAssembly();
// 埋め込んだデザインファイル(.xlsx)のストリームを取得します。
System.IO.Stream stream = assembly.GetManifestResourceStream(this.GetType().Namespace + ".Book1.xlsx");
cellReport1.Report.Start();
// 埋め込んだデザインファイル(.xlsx)を使用して帳票の作成を開始します。
cellReport1.Report.Embed(stream);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
stream.Close();
' 現在実行中のアセンブリを取得します。
Dim assembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
' 埋め込んだデザインファイル(.xlsx)のストリームを取得します。
Dim stream As System.IO.Stream = assembly.GetManifestResourceStream(Me.GetType().Namespace + ".Book1.xlsx")
CellReport1.Report.Start()
' 埋め込んだデザインファイル(.xlsx)を使用して帳票の作成を開始します。
CellReport1.Report.Embed(stream)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
stream.Close()
関連項目

参照

Report クラス
Embed オーバーロード


Report.End メソッド

ReportEnd メソッド

帳票の作成を終了します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void End()
Public Sub End
解説
Report.Start、End メソッド は、必ず 1 対 1 で設定してください。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
// 帳票の作成を開始します。
cellReport1.Report.Start();
// デザインファイルを使用します。
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
// 帳票の作成を終了します。
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
' 帳票の作成を開始します。
CellReport1.Report.Start()
' デザインファイルを使用します。
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
' 帳票の作成を終了します。
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Report クラス


Report.File メソッド

ReportFile メソッド

オーバーロードの一覧
名前 | 説明
File | デザインファイルを使用して帳票の作成を開始します。
File(Stream) | ストリーム経由でデザインファイルを使用して帳票の作成を開始します。
トップ
関連項目

参照

Report クラス


Report.File メソッド

ReportFile メソッド

デザインファイルを使用して帳票の作成を開始します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void File()
Public Sub File
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
// 帳票の作成を開始します。
cellReport1.Report.Start();
// デザインファイルを使用します。
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
// 帳票の作成を終了します。
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
' 帳票の作成を開始します。
CellReport1.Report.Start()
' デザインファイルを使用します。
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
' 帳票の作成を終了します。
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Report クラス
File オーバーロード


Report.File メソッド (Stream)

ReportFile メソッド (Stream)

ストリーム経由でデザインファイルを使用して帳票の作成を開始します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void File(
    Stream stream
)
Public Sub File (
    stream As Stream
)

パラメーター

stream
型: System.IOStream
デザインファイルの Stream を設定します。
例
C#
VB
コピー
// 現在実行中のアセンブリを取得します。
System.Reflection.Assembly assembly = System.Reflection.Assembly.GetExecutingAssembly();
// 埋め込んだデザインファイル(.xlsx)のストリームを取得します。
System.IO.Stream stream = assembly.GetManifestResourceStream(this.GetType().Namespace + ".Book1.xlsx");
cellReport1.Report.Start();
// 埋め込んだデザインファイル(.xlsx)を使用して帳票の作成を開始します。
cellReport1.Report.File(stream);
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
stream.Close();
' 現在実行中のアセンブリを取得します。
Dim assembly As System.Reflection.Assembly = System.Reflection.Assembly.GetExecutingAssembly()
' 埋め込んだデザインファイル(.xlsx)のストリームを取得します。
Dim stream As System.IO.Stream = assembly.GetManifestResourceStream(Me.GetType().Namespace + ".Book1.xlsx")
CellReport1.Report.Start()
' 埋め込んだデザインファイル(.xlsx)を使用して帳票の作成を開始します。
CellReport1.Report.File(stream)
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
stream.Close()
関連項目

参照

Report クラス
File オーバーロード


Report.GetSvgReport メソッド

ReportGetSvgReport メソッド

オーバーロードの一覧
名前 | 説明
GetSvgReport | 作成した帳票を SVG 形式で取得します。
GetSvgReport(SvgSaveType) | 作成した帳票を SVG 形式で取得します。
トップ
関連項目

参照

Report クラス


Report.GetSvgReport メソッド

ReportGetSvgReport メソッド

作成した帳票を SVG 形式で取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string GetSvgReport()
Public Function GetSvgReport As String

戻り値

型: String
作成した SVG 形式の帳票を Base64 でエンコードされた文字列で返します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// 作成した帳票を SVG 形式で取得します。
String s = cellReport1.Report.GetSvgReport();
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' 作成した帳票を SVG 形式で取得します。
Dim s As String = CellReport1.Report.GetSvgReport()
関連項目

参照

Report クラス
GetSvgReport オーバーロード


Report.GetSvgReport メソッド (SvgSaveType)

ReportGetSvgReport メソッド (SvgSaveType)

作成した帳票を SVG 形式で取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string GetSvgReport(
    SvgSaveType svgSaveType
)
Public Function GetSvgReport (
    svgSaveType As SvgSaveType
) As String

パラメーター

svgSaveType
型: AdvanceSoftware.ASReportSvgSaveType
保存するファイルのタイプを表す SvgSaveType。

戻り値

型: String
作成した SVG 形式の帳票を Base64 でエンコードされた文字列で返します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// 作成した帳票を SVG 形式で取得します。
String s = cellReport1.Report.GetSvgReport(AdvanceSoftware.ASReport.SvgSaveType.Default);
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' 作成した帳票を SVG 形式で取得します。
Dim s As String = CellReport1.Report.GetSvgReport(AdvanceSoftware.ASReport.SvgSaveType.Default)
関連項目

参照

Report クラス
GetSvgReport オーバーロード


Report.GetSvgzReport メソッド

ReportGetSvgzReport メソッド

オーバーロードの一覧
名前 | 説明
GetSvgzReport | 作成した帳票を SVGZ 形式で取得します。
GetSvgzReport(SvgSaveType) | 作成した帳票を SVGZ 形式で取得します。
トップ
関連項目

参照

Report クラス


Report.GetSvgzReport メソッド

ReportGetSvgzReport メソッド

作成した帳票を SVGZ 形式で取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string GetSvgzReport()
Public Function GetSvgzReport As String

戻り値

型: String
作成した SVGZ 形式の帳票を Base64 でエンコードされた文字列で返します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// 作成した帳票を SVGZ 形式で取得します。
String s = cellReport1.Report.GetSvgzReport();
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' 作成した帳票を SVGZ 形式で取得します。
Dim s As String = CellReport1.Report.GetSvgzReport()
関連項目

参照

Report クラス
GetSvgzReport オーバーロード


Report.GetSvgzReport メソッド (SvgSaveType)

ReportGetSvgzReport メソッド (SvgSaveType)

作成した帳票を SVGZ 形式で取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string GetSvgzReport(
    SvgSaveType svgSaveType
)
Public Function GetSvgzReport (
    svgSaveType As SvgSaveType
) As String

パラメーター

svgSaveType
型: AdvanceSoftware.ASReportSvgSaveType
保存するファイルのタイプを表す SvgSaveType。

戻り値

型: String
作成した SVGZ 形式の帳票を Base64 でエンコードされた文字列で返します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// 作成した帳票を SVGZ 形式で取得します。
String s = cellReport1.Report.GetSvgzReport(AdvanceSoftware.ASReport.SvgSaveType.Default);
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' 作成した帳票を SVGZ 形式で取得します。
Dim s As String = CellReport1.Report.GetSvgzReport(AdvanceSoftware.ASReport.SvgSaveType.Default)
関連項目

参照

Report クラス
GetSvgzReport オーバーロード


Report.PrintOut メソッド

ReportPrintOut メソッド

オーバーロードの一覧
名前 | 説明
PrintOut | 印刷を行います。
PrintOut(String, String) | 印刷を行います。
PrintOut(String, String, Int32) | 印刷を行います。
PrintOut(String, String, Int32, Boolean) | 印刷を行います。
トップ
関連項目

参照

Report クラス


Report.PrintOut メソッド

ReportPrintOut メソッド

印刷を行います。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void PrintOut()
Public Sub PrintOut
解説
ViewerControl を使用せず、CellReport コンポーネントから直接印刷を行う場合、 実行環境に Excel のインストールが必要です。 また、xlsx 形式は Excel 2007 以降のバージョンが必要です。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// 印刷を行います。
cellReport1.Report.PrintOut();
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' 印刷を行います。
CellReport1.Report.PrintOut()
関連項目

参照

Report クラス
PrintOut オーバーロード


Report.PrintOut メソッド (String, String)

ReportPrintOut メソッド (String, String)

印刷を行います。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void PrintOut(
    string printerName,
    string printPageInfo
)
Public Sub PrintOut (
    printerName As String,
    printPageInfo As String
)

パラメーター

printerName
型: SystemString
プリンタ名を指定します。
printPageInfo
型: SystemString
印刷するページを指定します。
解説
ViewerControl を使用せず、CellReport コンポーネントから直接印刷を行う場合、 実行環境に Excel のインストールが必要です。 また、xlsx 形式は Excel 2007 以降のバージョンが必要です。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// プリンタ名 "Microsoft XPS Document Writer" を使用して、1 ページ目の印刷を行います。
cellReport1.Report.PrintOut("Microsoft XPS Document Writer", "1");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' プリンタ名 "Microsoft XPS Document Writer" を使用して、1 ページ目の印刷を行います。
CellReport1.Report.PrintOut("Microsoft XPS Document Writer", "1")
関連項目

参照

Report クラス
PrintOut オーバーロード


Report.PrintOut メソッド (String, String, Int32)

ReportPrintOut メソッド (String, String, Int32)

印刷を行います。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void PrintOut(
    string printerName,
    string printPageInfo,
    int copies
)
Public Sub PrintOut (
    printerName As String,
    printPageInfo As String,
    copies As Integer
)

パラメーター

printerName
型: SystemString
プリンタ名を指定します。
printPageInfo
型: SystemString
印刷するページを指定します。
copies
型: SystemInt32
印刷部数を指定します。
解説
ViewerControl を使用せず、CellReport コンポーネントから直接印刷を行う場合、 実行環境に Excel のインストールが必要です。 また、xlsx 形式は Excel 2007 以降のバージョンが必要です。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// プリンタ名 "Microsoft XPS Document Writer" を使用して、1 ページ目を 2 部印刷します。
cellReport1.Report.PrintOut("Microsoft XPS Document Writer", "1", 2);
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' プリンタ名 "Microsoft XPS Document Writer" を使用して、1 ページ目を 2 部印刷します。
CellReport1.Report.PrintOut("Microsoft XPS Document Writer", "1", 2)
関連項目

参照

Report クラス
PrintOut オーバーロード


Report.PrintOut メソッド (String, String, Int32, Boolean)

ReportPrintOut メソッド (String, String, Int32, Boolean)

印刷を行います。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void PrintOut(
    string printerName,
    string printPageInfo,
    int copies,
    bool forceCollate
)
Public Sub PrintOut (
    printerName As String,
    printPageInfo As String,
    copies As Integer,
    forceCollate As Boolean
)

パラメーター

printerName
型: SystemString
プリンタ名を指定します。
printPageInfo
型: SystemString
印刷するページを指定します。
copies
型: SystemInt32
印刷部数を指定します。
forceCollate
型: SystemBoolean
強制的に部単位印刷を行うかどうかを指定します。
解説
ViewerControl を使用せず、CellReport コンポーネントから直接印刷を行う場合、 実行環境に Excel のインストールが必要です。 また、xlsx 形式は Excel 2007 以降のバージョンが必要です。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// プリンタ名 "Microsoft XPS Document Writer" を使用して、1 ページ目を 2 部印刷します。
cellReport1.Report.PrintOut("Microsoft XPS Document Writer", "1", 2, true);
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' プリンタ名 "Microsoft XPS Document Writer" を使用して、1 ページ目を 2 部印刷します。
CellReport1.Report.PrintOut("Microsoft XPS Document Writer", "1", 2, True)
関連項目

参照

Report クラス
PrintOut オーバーロード


Report.SaveAs メソッド

ReportSaveAs メソッド

オーバーロードの一覧
名前 | 説明
SaveAs(Stream) | 作成した帳票を Excel ファイルに保存します。
SaveAs(String) | 作成した帳票を Excel ファイルに保存します。
SaveAs(String, ExcelVersion) | 作成した帳票を Excel ファイルに保存します。
トップ
関連項目

参照

Report クラス


Report.SaveAs メソッド (Stream)

ReportSaveAs メソッド (Stream)

作成した帳票を Excel ファイルに保存します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void SaveAs(
    Stream stream
)
Public Sub SaveAs (
    stream As Stream
)

パラメーター

stream
型: System.IOStream
保存先 Stream を指定します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
System.IO.MemoryStream memoryStream = new System.IO.MemoryStream();
// Excel ファイルをストリームに出力します。
cellReport1.Report.SaveAs(memoryStream);
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
Dim memoryStream As System.IO.MemoryStream = New System.IO.MemoryStream()
' Excel ファイルをストリームに出力します。
CellReport1.Report.SaveAs(memoryStream)
関連項目

参照

Report クラス
SaveAs オーバーロード


Report.SaveAs メソッド (String)

ReportSaveAs メソッド (String)

作成した帳票を Excel ファイルに保存します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void SaveAs(
    string fileName
)
Public Sub SaveAs (
    fileName As String
)

パラメーター

fileName
型: SystemString
Excel ファイル名を指定します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// Excel ファイルを "C:\out1.xlsx" に保存します。
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' Excel ファイルを "C:\out1.xlsx" に保存します。
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Report クラス
SaveAs オーバーロード


Report.SaveAs メソッド (String, ExcelVersion)

ReportSaveAs メソッド (String, ExcelVersion)

作成した帳票を Excel ファイルに保存します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void SaveAs(
    string fileName,
    ExcelVersion version
)
Public Sub SaveAs (
    fileName As String,
    version As ExcelVersion
)

パラメーター

fileName
型: SystemString
Excel ファイル名を指定します。
version
型: AdvanceSoftware.ASReportExcelVersion
Excel のバージョンを指定します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// Excel 2019 の形式で Excel ファイルを "C:\out1.xlsx" に保存します。
cellReport1.Report.SaveAs(@"C:\out1.xlsx", AdvanceSoftware.ASReport.ExcelVersion.ver2019);
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1-99999")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' Excel 2019 の形式で Excel ファイルを "C:\out1.xlsx" に保存します。
CellReport1.Report.SaveAs("C:\out1.xlsx", AdvanceSoftware.ASReport.ExcelVersion.ver2019)
関連項目

参照

Report クラス
SaveAs オーバーロード


Report.SavePdf メソッド

ReportSavePdf メソッド

オーバーロードの一覧
名前 | 説明
SavePdf(Stream) | 作成した帳票を PDF 形式で保存します。
SavePdf(String) | 作成した帳票を PDF 形式で保存します。
トップ
関連項目

参照

Report クラス


Report.SavePdf メソッド (Stream)

ReportSavePdf メソッド (Stream)

作成した帳票を PDF 形式で保存します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void SavePdf(
    Stream stream
)
Public Sub SavePdf (
    stream As Stream
)

パラメーター

stream
型: System.IOStream
保存先 Stream を指定します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
System.IO.MemoryStream memoryStream = new System.IO.MemoryStream();
// PDF ファイルをストリームに出力します。
cellReport1.Report.SavePdf(memoryStream);
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
Dim memoryStream As System.IO.MemoryStream = New System.IO.MemoryStream()
' PDF ファイルをストリームに出力します。
CellReport1.Report.SavePdf(memoryStream)
関連項目

参照

Report クラス
SavePdf オーバーロード


Report.SavePdf メソッド (String)

ReportSavePdf メソッド (String)

作成した帳票を PDF 形式で保存します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void SavePdf(
    string fileName
)
Public Sub SavePdf (
    fileName As String
)

パラメーター

fileName
型: SystemString
PDF ファイル名を指定します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// PDF ファイルを "C:\out1.pdf" に保存します。
cellReport1.Report.SavePdf(@"C:\out1.pdf");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' PDF ファイルを "C:\out1.pdf" に保存します。
CellReport1.Report.SavePdf("C:\out1.pdf")
関連項目

参照

Report クラス
SavePdf オーバーロード


Report.Start メソッド

ReportStart メソッド

オーバーロードの一覧
名前 | 説明
Start | 帳票の作成を開始します。
Start(OutputMode) | 帳票の作成を開始します。(出力モードを指定)
Start(ReportMode) | 帳票の作成を開始します。(レポートモードを指定)
Start(String) | 帳票の作成を開始します。(帳票の識別名を指定)
Start(OutputMode, String) | 帳票の作成を開始します。(出力モード、帳票の識別名を指定)
Start(ReportMode, OutputMode) | 帳票の作成を開始します。(レポートモード、出力モードを指定)
Start(ReportMode, String) | 帳票の作成を開始します。(レポートモード、帳票の識別名を指定)
Start(ReportMode, OutputMode, String) | 帳票の作成を開始します。(レポートモード、出力モード、帳票の識別名を指定)
トップ
関連項目

参照

Report クラス


Report.Start メソッド

ReportStart メソッド

帳票の作成を開始します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Start()
Public Sub Start
解説
Report.Start、End メソッド は、必ず 1 対 1 で設定してください。 Report.Start メソッドの引数に ReportMode を指定せず呼び出した場合、ReportMode.Speed で帳票を作成します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
// 帳票の作成を開始します。
cellReport1.Report.Start();
// デザインファイルを使用します。
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
// 帳票の作成を終了します。
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
' 帳票の作成を開始します。
CellReport1.Report.Start()
' デザインファイルを使用します。
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
' 帳票の作成を終了します。
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Report クラス
Start オーバーロード


Report.Start メソッド (OutputMode)

ReportStart メソッド (OutputMode)

帳票の作成を開始します。(出力モードを指定)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Start(
    OutputMode outputMode
)
Public Sub Start (
    outputMode As OutputMode
)

パラメーター

outputMode
型: AdvanceSoftware.ASReportOutputMode
出力モードを指定します。
解説
Report.Start、End メソッド は、必ず 1 対 1 で設定してください。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
// 出力モードを Excel のみに設定して帳票の作成を開始します。
cellReport1.Report.Start(OutputMode.ExcelOnly);
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
' 出力モードを Excel のみに設定して帳票の作成を開始します。
CellReport1.Report.Start(OutputMode.ExcelOnly)
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Report クラス
Start オーバーロード


Report.Start メソッド (ReportMode)

ReportStart メソッド (ReportMode)

帳票の作成を開始します。(レポートモードを指定)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Start(
    ReportMode reportMode
)
Public Sub Start (
    reportMode As ReportMode
)

パラメーター

reportMode
型: AdvanceSoftware.ASReportReportMode
レポートモードを指定します。
解説
Report.Start、End メソッド は、必ず 1 対 1 で設定してください。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
// 帳票作成モードを ReportMode.Speed に設定して帳票の作成を開始します。
cellReport1.Report.Start(ReportMode.Speed);
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
' 帳票作成モードを ReportMode.Speed に設定して帳票の作成を開始します。
CellReport1.Report.Start(ReportMode.Speed)
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Report クラス
Start オーバーロード


Report.Start メソッド (String)

ReportStart メソッド (String)

帳票の作成を開始します。(帳票の識別名を指定)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Start(
    string documentName
)
Public Sub Start (
    documentName As String
)

パラメーター

documentName
型: SystemString
帳票を識別するための名前を設定します。
解説
Report.Start、End メソッド は、必ず 1 対 1 で設定してください。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
// 帳票ドキュメント名を "Document1" に設定して帳票の作成を開始します。
cellReport1.Report.Start("Document1");
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
' 帳票ドキュメント名を "Document1" に設定して帳票の作成を開始します。
CellReport1.Report.Start("Document1")
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Report クラス
Start オーバーロード


Report.Start メソッド (OutputMode, String)

ReportStart メソッド (OutputMode, String)

帳票の作成を開始します。(出力モード、帳票の識別名を指定)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Start(
    OutputMode outputMode,
    string documentName
)
Public Sub Start (
    outputMode As OutputMode,
    documentName As String
)

パラメーター

outputMode
型: AdvanceSoftware.ASReportOutputMode
出力モードを指定します。
documentName
型: SystemString
帳票を識別するための名前を設定します。
解説
Report.Start、End メソッド は、必ず 1 対 1 で設定してください。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
// 出力モードを Excel のみ、帳票ドキュメント名を "Document1" に設定して帳票の作成を開始します。
cellReport1.Report.Start(OutputMode.ExcelOnly, "Document1");
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
' 出力モードを Excel のみ、帳票ドキュメント名を "Document1" に設定して帳票の作成を開始します。
CellReport1.Report.Start(OutputMode.ExcelOnly, "Document1")
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Report クラス
Start オーバーロード


Report.Start メソッド (ReportMode, OutputMode)

ReportStart メソッド (ReportMode, OutputMode)

帳票の作成を開始します。(レポートモード、出力モードを指定)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Start(
    ReportMode reportMode,
    OutputMode outputMode
)
Public Sub Start (
    reportMode As ReportMode,
    outputMode As OutputMode
)

パラメーター

reportMode
型: AdvanceSoftware.ASReportReportMode
レポートモードを指定します。
outputMode
型: AdvanceSoftware.ASReportOutputMode
出力モードを指定します。
解説
Report.Start、End メソッド は、必ず 1 対 1 で設定してください。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
// 帳票作成モードを ReportMode.Speed、出力モードを Excel のみに設定して帳票の作成を開始します。
cellReport1.Report.Start(ReportMode.Speed, OutputMode.ExcelOnly);
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
' 帳票作成モードを ReportMode.Speed、出力モードを Excel のみに設定して帳票の作成を開始します。
CellReport1.Report.Start(ReportMode.Speed, OutputMode.ExcelOnly)
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Report クラス
Start オーバーロード


Report.Start メソッド (ReportMode, String)

ReportStart メソッド (ReportMode, String)

帳票の作成を開始します。(レポートモード、帳票の識別名を指定)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Start(
    ReportMode reportMode,
    string documentName
)
Public Sub Start (
    reportMode As ReportMode,
    documentName As String
)

パラメーター

reportMode
型: AdvanceSoftware.ASReportReportMode
レポートモードを指定します。
documentName
型: SystemString
帳票を識別するための名前を設定します。
解説
Report.Start、End メソッド は、必ず 1 対 1 で設定してください。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
// 帳票作成モードを ReportMode.Speed、帳票ドキュメント名を "Document1" に設定して帳票の作成を開始します。
cellReport1.Report.Start(ReportMode.Speed, "Document1");
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
' 帳票作成モードを ReportMode.Speed、帳票ドキュメント名を "Document1" に設定して帳票の作成を開始します。
CellReport1.Report.Start(ReportMode.Speed, "Document1")
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Report クラス
Start オーバーロード


Report.Start メソッド (ReportMode, OutputMode, String)

ReportStart メソッド (ReportMode, OutputMode, String)

帳票の作成を開始します。(レポートモード、出力モード、帳票の識別名を指定)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Start(
    ReportMode reportMode,
    OutputMode outputMode,
    string documentName
)
Public Sub Start (
    reportMode As ReportMode,
    outputMode As OutputMode,
    documentName As String
)

パラメーター

reportMode
型: AdvanceSoftware.ASReportReportMode
レポートモードを指定します。
outputMode
型: AdvanceSoftware.ASReportOutputMode
出力モードを指定します。
documentName
型: SystemString
帳票を識別するための名前を設定します。
解説
Report.Start、End メソッド は、必ず 1 対 1 で設定してください。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
// 帳票作成モードを ReportMode.Speed、出力モードを Excel のみ
// 帳票ドキュメント名を "Document1" に設定して帳票の作成を開始します。
cellReport1.Report.Start(ReportMode.Speed, OutputMode.ExcelOnly, "Document1");
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
' 帳票作成モードを ReportMode.Speed、出力モードを Excel のみ
' 帳票ドキュメント名を "Document1" に設定して帳票の作成を開始します。
CellReport1.Report.Start(ReportMode.Speed, OutputMode.ExcelOnly, "Document1")
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Report クラス
Start オーバーロード


ReportErrorEventArgs クラス

Error イベントのデータを提供します。
継承階層
SystemObject
SystemEventArgs
AdvanceSoftware.ASReportReportErrorEventArgs

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Document (in AdvanceSoftware.ASReport.Document.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class ReportErrorEventArgs : EventArgs
Public Class ReportErrorEventArgs
    Inherits EventArgs

ReportErrorEventArgs 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
Public プロパティ | ErrorNo | エラーナンバーを取得します。
トップ
関連項目

参照


ReportErrorEventArgs プロパティ

ReportErrorEventArgs 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
Public プロパティ | ErrorNo | エラーナンバーを取得します。
トップ
関連項目

参照

ReportErrorEventArgs クラス


ReportErrorEventArgs.ErrorNo プロパティ

ReportErrorEventArgsErrorNo プロパティ

エラーナンバーを取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Document (in AdvanceSoftware.ASReport.Document.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo ErrorNo { get; }
Public ReadOnly Property ErrorNo As ErrorNo
    Get

プロパティ値

型: ErrorNo
関連項目

参照

ReportErrorEventArgs クラス


ReportErrorEventHandler デリゲート

Error イベントを処理するメソッドを表します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Document (in AdvanceSoftware.ASReport.Document.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public delegate void ReportErrorEventHandler(
    Object sender,
    ReportErrorEventArgs e
)
Public Delegate Sub ReportErrorEventHandler (
    sender As Object,
    e As ReportErrorEventArgs
)

パラメーター

sender
型: SystemObject
e
型: AdvanceSoftware.ASReportReportErrorEventArgs
関連項目

参照


ReportFrame 列挙体

帳票の枠組みをプレビュー・印刷するかを指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ReportFrame
Public Enumeration ReportFrame
メンバー
メンバー | 値 | 説明
All | 0 | プレビュー・印刷時に枠組みを表示します。
Preview | 1 | プレビュー時のみ枠組みを表示します。
Print | 2 | 印刷時のみ枠組みを表示します。
None | 3 | 枠組みを非表示にします。
関連項目

参照


ReportMode 列挙体

レポートモードを指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ReportMode
Public Enumeration ReportMode
メンバー
メンバー | 値 | 説明
Speed | 0 | 高速モードで帳票を作成します。
Legacy | 1 | VB-Report 8.0 for .NET と同じ方式で帳票を作成します。
関連項目

参照


ReportProgressEventArgs クラス

Progress イベントのデータを提供します。
継承階層
SystemObject
SystemEventArgs
AdvanceSoftware.ASReportReportProgressEventArgs

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Document (in AdvanceSoftware.ASReport.Document.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class ReportProgressEventArgs : EventArgs
Public Class ReportProgressEventArgs
    Inherits EventArgs

ReportProgressEventArgs 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
 | Count | 現在のページ数やシート数を取得します。
Public プロパティ | Stop | 処理を制御します。
 | Total | 全体の総ページ数や総シート数を取得します。
Public プロパティ | Type | プログレスタイプを取得します。
トップ
関連項目

参照


ReportProgressEventArgs プロパティ

ReportProgressEventArgs 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
 | Count | 現在のページ数やシート数を取得します。
Public プロパティ | Stop | 処理を制御します。
 | Total | 全体の総ページ数や総シート数を取得します。
Public プロパティ | Type | プログレスタイプを取得します。
トップ
関連項目

参照

ReportProgressEventArgs クラス


ReportProgressEventArgs.Count プロパティ

ReportProgressEventArgsCount プロパティ

現在のページ数やシート数を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Document (in AdvanceSoftware.ASReport.Document.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

プロパティ値

型: Int32
現在のページ数、シート数を表す、Int32。
解説
印刷、PDF ファイル保存の場合は「ページ数」となり、Excel ファイル保存の場合は「シート数」になります。
例
C#
VB
コピー
private void InitializeComponent()
{
    cellReport1.Progress += new AdvanceSoftware.ASReport.ReportProgressEventHandler(cellReport1_Progress);
}
void cellReport1_Progress(object sender, AdvanceSoftware.ASReport.ReportProgressEventArgs e)
{
    // 現在のページ数を表示します。
    MessageBox.Show(e.Count.ToString());
}
Private WithEvents CellReport1 As AdvanceSoftware.ASReport.CellReport = New AdvanceSoftware.ASReport.CellReport()
Private Sub CellReport1_Progress(ByVal sender As Object, ByVal e As AdvanceSoftware.ASReport.ReportProgressEventArgs) Handles CellReport1.Progress
    ' 現在のページ数を表示します。
    MessageBox.Show(e.Count.ToString())
End Sub
関連項目

参照

ReportProgressEventArgs クラス


ReportProgressEventArgs.Stop プロパティ

ReportProgressEventArgsStop プロパティ

処理を制御します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Document (in AdvanceSoftware.ASReport.Document.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool Stop { get; set; }
Public Property Stop As Boolean
    Get
    Set

プロパティ値

型: Boolean
処理を中断する場合、true。
関連項目

参照

ReportProgressEventArgs クラス


ReportProgressEventArgs.Total プロパティ

ReportProgressEventArgsTotal プロパティ

全体の総ページ数や総シート数を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Document (in AdvanceSoftware.ASReport.Document.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int Total { get; }
Public ReadOnly Property Total As Integer
    Get

プロパティ値

型: Int32
全体の総ページ数、総シート数を表す、Int32。
解説
印刷、PDF ファイル保存の場合は「ページ数」となり、Excel ファイル保存の場合は「シート数」になります。
例
C#
VB
コピー
private void InitializeComponent()
{
    cellReport1.Progress += new AdvanceSoftware.ASReport.ReportProgressEventHandler(cellReport1_Progress);
}
void cellReport1_Progress(object sender, AdvanceSoftware.ASReport.ReportProgressEventArgs e)
{
    // 総ページ数を表示します。
    MessageBox.Show(e.Total.ToString());
}
Private WithEvents CellReport1 As AdvanceSoftware.ASReport.CellReport = New AdvanceSoftware.ASReport.CellReport()
Private Sub CellReport1_Progress(ByVal sender As Object, ByVal e As AdvanceSoftware.ASReport.ReportProgressEventArgs) Handles CellReport1.Progress
    ' 総ページ数を表示します。
    MessageBox.Show(e.Total.ToString())
End Sub
関連項目

参照

ReportProgressEventArgs クラス


ReportProgressEventArgs.Type プロパティ

ReportProgressEventArgsType プロパティ

プログレスタイプを取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Document (in AdvanceSoftware.ASReport.Document.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ProgressType Type { get; }
Public ReadOnly Property Type As ProgressType
    Get

プロパティ値

型: ProgressType
プログレスタイプを表す、ProgressType。
関連項目

参照

ReportProgressEventArgs クラス


ReportProgressEventHandler デリゲート

Progress イベントを処理するメソッドを表します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Document (in AdvanceSoftware.ASReport.Document.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public delegate void ReportProgressEventHandler(
    Object sender,
    ReportProgressEventArgs e
)
Public Delegate Sub ReportProgressEventHandler (
    sender As Object,
    e As ReportProgressEventArgs
)

パラメーター

sender
型: SystemObject
e
型: AdvanceSoftware.ASReportReportProgressEventArgs
関連項目

参照


RunPageStartEventArgs クラス

RunPageStart イベントのデータを提供します。
継承階層
SystemObject
SystemEventArgs
AdvanceSoftware.ASReportRunPageStartEventArgs

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class RunPageStartEventArgs : EventArgs
Public Class RunPageStartEventArgs
    Inherits EventArgs

RunPageStartEventArgs 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
Public プロパティ | PageNo | ページナンバーを取得します。
トップ
関連項目

参照


RunPageStartEventArgs プロパティ

RunPageStartEventArgs 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
Public プロパティ | PageNo | ページナンバーを取得します。
トップ
関連項目

参照

RunPageStartEventArgs クラス


RunPageStartEventArgs.PageNo プロパティ

RunPageStartEventArgsPageNo プロパティ

ページナンバーを取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int PageNo { get; }
Public ReadOnly Property PageNo As Integer
    Get

プロパティ値

型: Int32
関連項目

参照

RunPageStartEventArgs クラス


RunPageStartEventHandler デリゲート

RunPageStart イベントを処理するメソッドを表します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public delegate void RunPageStartEventHandler(
    Object sender,
    RunPageStartEventArgs e
)
Public Delegate Sub RunPageStartEventHandler (
    sender As Object,
    e As RunPageStartEventArgs
)

パラメーター

sender
型: SystemObject
e
型: AdvanceSoftware.ASReportRunPageStartEventArgs
関連項目

参照


RunReportStartEventHandler デリゲート

RunReportStart イベントを処理するメソッドを表します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public delegate void RunReportStartEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub RunReportStartEventHandler (
    sender As Object,
    e As EventArgs
)

パラメーター

sender
型: SystemObject
e
型: SystemEventArgs
関連項目

参照


SaveKind 列挙体

ファイル保存ダイアログのファイルの種類に設定する形式を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum SaveKind
Public Enumeration SaveKind
メンバー
メンバー | 値 | 説明
All | 0 | Excel ファイルと PDF ファイルを設定します。
ExcelOnly | 1 | Excel ファイルのみ設定します。
PdfOnly | 2 | PDF ファイルのみ設定します。
関連項目

参照


ScaleMode 列挙体

スケールモードを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ScaleMode
Public Enumeration ScaleMode
メンバー
メンバー | 値 | 説明
Twips | 1 | Twips
Point | 2 | ポイント
Pixel | 3 | ピクセル
Inch | 5 | インチ
Millimeter | 6 | ミリ
Centimeter | 7 | センチ
関連項目

参照


Section クラス

連続帳票を指定します。レポートコンポーネントを通じてこのクラスにアクセスします。
継承階層
SystemObject
AdvanceSoftware.ASReportSection

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Section
Public Class Section

Section 型は下記のメンバーを公開します。

プロパティ
名前 | 説明
MaxDetailCount | 1 ページの明細数を指定します。
ReportToFill | 明細行を最終行まで設定するかを指定します。
トップ
メソッド
名前 | 説明
Detail | 連続帳票処理の明細部を指定します。
End | 連続帳票の終了を指定します。
Footer | 連続帳票処理のフッター部を指定します。
Header | 連続帳票処理のヘッダー部を指定します。
Start(Boolean) | 連続帳票の開始を指定します。
Start(String, Boolean) | 連続帳票の開始を指定します。
トップ
関連項目

参照


Section プロパティ

Section 型は下記のメンバーを公開します。

プロパティ
名前 | 説明
MaxDetailCount | 1 ページの明細数を指定します。
ReportToFill | 明細行を最終行まで設定するかを指定します。
トップ
関連項目

参照

Section クラス


Section.MaxDetailCount プロパティ

SectionMaxDetailCount プロパティ

1 ページの明細数を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int MaxDetailCount { set; }
Public WriteOnly Property MaxDetailCount As Integer
    Set

プロパティ値

型: Int32
1 ページの明細数。(既定値 : 0)
解説
0 を指定した場合 1 ページに収まる最大明細数が自動で設定されます。
例
C#
VB
コピー
// 1 ページの明細数を 5 行に設定します。
cellReport1.Section.MaxDetailCount = 5;
' 1 ページの明細数を 5 行に設定します。
CellReport1.Section.MaxDetailCount = 5
関連項目

参照

Section クラス


Section.ReportToFill プロパティ

SectionReportToFill プロパティ

明細行を最終行まで設定するかを指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ReportToFill { get; set; }
Public Property ReportToFill As Boolean
    Get
    Set

プロパティ値

型: Boolean
明細行を最終行まで設定する場合は true。(既定値 : false)
例
C#
VB
コピー
// 明細行を最終行まで設定します。
cellReport1.Section.ReportToFill = true;
' 明細行を最終行まで設定します。
CellReport1.Section.ReportToFill = True
関連項目

参照

Section クラス


Section メソッド

Section 型は下記のメンバーを公開します。

メソッド
名前 | 説明
Detail | 連続帳票処理の明細部を指定します。
End | 連続帳票の終了を指定します。
Footer | 連続帳票処理のフッター部を指定します。
Header | 連続帳票処理のヘッダー部を指定します。
Start(Boolean) | 連続帳票の開始を指定します。
Start(String, Boolean) | 連続帳票の開始を指定します。
トップ
関連項目

参照

Section クラス


Section.Detail メソッド

SectionDetail メソッド

連続帳票処理の明細部を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public SectionDetail Detail(
    string cell
)
Public Function Detail (
    cell As String
) As SectionDetail

パラメーター

cell
型: SystemString
セルの範囲を指定します。

戻り値

型: SectionDetail
SectionDetail を返します。
解説
セルの範囲(例："A1:B10") のほか、行の範囲 ("1:10")の指定も可能です。
例
C#
VB
コピー
// 連続帳票処理の明細部を "A5:D5" セルに設定します。
AdvanceSoftware.ASReport.SectionDetail sectionDetail = cellReport1.Section.Detail("A5:D5");
' 連続帳票処理の明細部を "A5:D5" に設定します。
Dim sectionDetail As AdvanceSoftware.ASReport.SectionDetail = CellReport1.Section.Detail("A5:D5")
関連項目

参照

Section クラス


Section.End メソッド

SectionEnd メソッド

連続帳票の終了を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void End()
Public Sub End
解説
Section.End、Section.Start メソッドは、必ず 1 対 1 で設定してください。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
// 使用するシートを "Sheet1"、出力方法を "1 シート毎に帳票ページ出力" に設定して
// 連続帳票処理を開始します。
cellReport1.Section.Start("Sheet1", false);
cellReport1.Section.Header("A1:D4");
cellReport1.Section.Footer("A6:D6");
AdvanceSoftware.ASReport.SectionDetail sectionDetail = cellReport1.Section.Detail("A5:D5");
for (int i = 0; i < 5; i++)
{
    sectionDetail.Start();
    sectionDetail.Cell("A5").Value = "アドバンスソフトウェア";
    sectionDetail.Next();
}
// 連続帳票処理を終了します。
cellReport1.Section.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
' 使用するシートを "Sheet1"、出力方法を "1 シート毎に帳票ページ出力" に設定して
' 連続帳票処理を開始します。
CellReport1.Section.Start("Sheet1", False)
CellReport1.Section.Header("A1:D4")
CellReport1.Section.Footer("A6:D6")
Dim sectionDetail As AdvanceSoftware.ASReport.SectionDetail = CellReport1.Section.Detail("A5:D5")
For i As Integer = 0 To 4
    sectionDetail.Start()
    sectionDetail.Cell("A5").Value = "アドバンスソフトウェア"
    sectionDetail.Next()
Next
' 連続帳票処理を終了します。
CellReport1.Section.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Section クラス


Section.Footer メソッド

SectionFooter メソッド

連続帳票処理のフッター部を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Footer(
    string cell
)
Public Sub Footer (
    cell As String
)

パラメーター

cell
型: SystemString
セルの範囲を指定します。
解説
セルの範囲(例："A1:B10") のほか、行の範囲 ("1:10")の指定も可能です。
例
C#
VB
コピー
// 連続帳票処理のフッター部を "A6:D6" セルに設定します。
cellReport1.Section.Footer("A6:D6");
' 連続帳票処理のフッター部を "A6:D6" セルに設定します。
CellReport1.Section.Footer("A6:D6")
関連項目

参照

Section クラス


Section.Header メソッド

SectionHeader メソッド

連続帳票処理のヘッダー部を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Header(
    string cell
)
Public Sub Header (
    cell As String
)

パラメーター

cell
型: SystemString
セルの範囲を指定します。
解説
セルの範囲(例："A1:B10") のほか、行の範囲 ("1:10")の指定も可能です。
例
C#
VB
コピー
// 連続帳票処理のヘッダー部を "A1:D4" セルに設定します。
cellReport1.Section.Header("A1:D4");
' 連続帳票処理のヘッダー部を "A1:D4" セルに設定します。
CellReport1.Section.Header("A1:D4")
関連項目

参照

Section クラス


Section.Start メソッド

SectionStart メソッド

オーバーロードの一覧
名前 | 説明
Start(Boolean) | 連続帳票の開始を指定します。
Start(String, Boolean) | 連続帳票の開始を指定します。
トップ
関連項目

参照

Section クラス


Section.Start メソッド (Boolean)

SectionStart メソッド (Boolean)

連続帳票の開始を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Start(
    bool isPageRepeat
)
Public Sub Start (
    isPageRepeat As Boolean
)

パラメーター

isPageRepeat
型: SystemBoolean
false(規定値)：１シート毎に帳票ページ出力 true：1シート内に帳票ページを複数出力
解説
Section.Start、Section.End メソッドは、必ず 1 対 1 で設定してください。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
// 使用するシートを "Sheet1" に設定します。
cellReport1.SheetName = "Sheet1";
cellReport1.Report.Start();
cellReport1.Report.File();
// 出力方法を "1 シート毎に帳票ページ出力" に設定して連続帳票処理を開始します。
cellReport1.Section.Start(false);
cellReport1.Section.Header("A1:D4");
cellReport1.Section.Footer("A6:D6");
AdvanceSoftware.ASReport.SectionDetail sectionDetail = cellReport1.Section.Detail("A5:D5");
for (int i = 0; i < 5; i++)
{
    sectionDetail.Start();
    sectionDetail.Cell("A5").Value = "アドバンスソフトウェア";
    sectionDetail.Next();
}
// 連続帳票処理を終了します。
cellReport1.Section.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
' 使用するシートを "Sheet1" に設定します。
CellReport1.SheetName = "Sheet1"
CellReport1.Report.Start()
CellReport1.Report.File()
' 出力方法を "1 シート毎に帳票ページ出力" に設定して連続帳票処理を開始します。
CellReport1.Section.Start(False)
CellReport1.Section.Header("A1:D4")
CellReport1.Section.Footer("A6:D6")
Dim sectionDetail As AdvanceSoftware.ASReport.SectionDetail = CellReport1.Section.Detail("A5:D5")
For i As Integer = 0 To 4
    sectionDetail.Start()
    sectionDetail.Cell("A5").Value = "アドバンスソフトウェア"
    sectionDetail.Next()
Next
' 連続帳票処理を終了します。
CellReport1.Section.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Section クラス
Start オーバーロード


Section.Start メソッド (String, Boolean)

SectionStart メソッド (String, Boolean)

連続帳票の開始を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Start(
    string sheetName,
    bool isPageRepeat
)
Public Sub Start (
    sheetName As String,
    isPageRepeat As Boolean
)

パラメーター

sheetName
型: SystemString
使用するシート名を設定します。
isPageRepeat
型: SystemBoolean
false(規定値)：１シート毎に帳票ページ出力 true：1シート内に帳票ページを複数出力
解説
Section.Start、Section.End メソッドは、必ず 1 対 1 で設定してください。 デザイン時に SheetName プロパティを設定した場合、引数を省略することができます。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
// 使用するシートを "Sheet1"、出力方法を "1 シート毎に帳票ページ出力" に設定して
// 連続帳票処理を開始します。
cellReport1.Section.Start("Sheet1", false);
cellReport1.Section.Header("A1:D4");
cellReport1.Section.Footer("A6:D6");
AdvanceSoftware.ASReport.SectionDetail sectionDetail = cellReport1.Section.Detail("A5:D5");
for (int i = 0; i < 5; i++)
{
    sectionDetail.Start();
    sectionDetail.Cell("A5").Value = "アドバンスソフトウェア";
    sectionDetail.Next();
}
// 連続帳票処理を終了します。
cellReport1.Section.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
' 使用するシートを "Sheet1"、出力方法を "1 シート毎に帳票ページ出力" に設定して
' 連続帳票処理を開始します。
CellReport1.Section.Start("Sheet1", False)
CellReport1.Section.Header("A1:D4")
CellReport1.Section.Footer("A6:D6")
Dim sectionDetail As AdvanceSoftware.ASReport.SectionDetail = CellReport1.Section.Detail("A5:D5")
For i As Integer = 0 To 4
    sectionDetail.Start()
    sectionDetail.Cell("A5").Value = "アドバンスソフトウェア"
    sectionDetail.Next()
Next
' 連続帳票処理を終了します。
CellReport1.Section.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

Section クラス
Start オーバーロード


SectionDetail クラス

連続帳票の明細行を指定します。レポートコンポーネントを通じてこのクラスにアクセスします。
継承階層
SystemObject
AdvanceSoftware.ASReportSectionDetail

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class SectionDetail
Public Class SectionDetail

SectionDetail 型は下記のメンバーを公開します。

メソッド
名前 | 説明
Cell | Cell を取得します。
Next | 連続帳票の明細処理を終了します。
Next(Boolean) | 連続帳票の明細処理を終了します。
Pos | Cell を取得します。
Start | 連続帳票に明細行を追加します。
トップ
関連項目

参照


SectionDetail メソッド

SectionDetail 型は下記のメンバーを公開します。

メソッド
名前 | 説明
Cell | Cell を取得します。
Next | 連続帳票の明細処理を終了します。
Next(Boolean) | 連続帳票の明細処理を終了します。
Pos | Cell を取得します。
Start | 連続帳票に明細行を追加します。
トップ
関連項目

参照

SectionDetail クラス


SectionDetail.Cell メソッド

SectionDetailCell メソッド

Cell を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Cell Cell(
    string cell
)
Public Function Cell (
    cell As String
) As Cell

パラメーター

cell
型: SystemString
セルを指定します。

戻り値

型: Cell
Cell を返します。
解説
A1 形式、変数名、セル名で指定します。 明細の行数に関わらず、Section.Detailメソッドの範囲のセルがそのまま指定可能です。 変数名、セル名は、デザインファイルに設定しておく必要があります。
例
C#
VB
コピー
// A5 セルに文字列 "アドバンスソフトウェア" を設定します。
sectionDetail.Cell("A5").Value = "アドバンスソフトウェア";
' A5 セルに文字列 "アドバンスソフトウェア" を設定します。
sectionDetail.Cell("A5").Value = "アドバンスソフトウェア"
関連項目

参照

SectionDetail クラス


SectionDetail.Next メソッド

SectionDetailNext メソッド

オーバーロードの一覧
名前 | 説明
Next | 連続帳票の明細処理を終了します。
Next(Boolean) | 連続帳票の明細処理を終了します。
トップ
関連項目

参照

SectionDetail クラス


SectionDetail.Next メソッド

SectionDetailNext メソッド

連続帳票の明細処理を終了します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Next()
Public Sub Next
解説
Detail.Start メソッドと Detail.Next メソッドは対で呼び出す必要があります。 明細行がページの終端の場合、Footer イベントが発生します。 引数なしの場合、自動で改ページ処理が行われます。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Section.Start("Sheet1", false);
cellReport1.Section.Header("A1:D4");
cellReport1.Section.Footer("A6:D6");
AdvanceSoftware.ASReport.SectionDetail sectionDetail = cellReport1.Section.Detail("A5:D5");
for (int i = 0; i < 5; i++)
{
    // 連続帳票の明細処理を開始します。
    sectionDetail.Start();
    sectionDetail.Cell("A5").Value = "アドバンスソフトウェア";
    // 連続帳票の明細処理を終了します。
    sectionDetail.Next();
}
cellReport1.Section.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Section.Start("Sheet1", False)
CellReport1.Section.Header("A1:D4")
CellReport1.Section.Footer("A6:D6")
Dim sectionDetail As AdvanceSoftware.ASReport.SectionDetail = CellReport1.Section.Detail("A5:D5")
For i As Integer = 0 To 4
    ' 連続帳票の明細処理を開始します。
    sectionDetail.Start()
    sectionDetail.Cell("A5").Value = "アドバンスソフトウェア"
    ' 連続帳票の明細処理を終了します。
    sectionDetail.Next()
Next
CellReport1.Section.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

SectionDetail クラス
Next オーバーロード


SectionDetail.Next メソッド (Boolean)

SectionDetailNext メソッド (Boolean)

連続帳票の明細処理を終了します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Next(
    bool breakPage
)
Public Sub Next (
    breakPage As Boolean
)

パラメーター

breakPage
型: SystemBoolean
強制改ページ true:改ページを行う false:改ページしない
解説
Detail.Start メソッドと Detail.Next メソッドは対で呼び出す必要があります。 明細行がページの終端の場合、Footer イベントが発生します。 途中で改ページを行う場合は、引数に true を設定してください。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Section.Start("Sheet1", false);
cellReport1.Section.Header("A1:D4");
cellReport1.Section.Footer("A6:D6");
AdvanceSoftware.ASReport.SectionDetail sectionDetail = cellReport1.Section.Detail("A5:D5");
for (int i = 0; i < 5; i++)
{
    // 連続帳票の明細処理を開始します。
    sectionDetail.Start();
    sectionDetail.Cell("A5").Value = "アドバンスソフトウェア";
    // 改ページを挿入して連続帳票の明細処理を終了します。
    sectionDetail.Next(true);
}
cellReport1.Section.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Section.Start("Sheet1", False)
CellReport1.Section.Header("A1:D4")
CellReport1.Section.Footer("A6:D6")
Dim sectionDetail As AdvanceSoftware.ASReport.SectionDetail = CellReport1.Section.Detail("A5:D5")
For i As Integer = 0 To 4
    ' 連続帳票の明細処理を開始します。
    sectionDetail.Start()
    sectionDetail.Cell("A5").Value = "アドバンスソフトウェア"
    ' 改ページを挿入して連続帳票の明細処理を終了します。
    sectionDetail.Next(True)
Next
CellReport1.Section.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

SectionDetail クラス
Next オーバーロード


SectionDetail.Pos メソッド

SectionDetailPos メソッド

Cell を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Cell Pos(
    int sx,
    int sy
)
Public Function Pos (
    sx As Integer,
    sy As Integer
) As Cell

パラメーター

sx
型: SystemInt32
x 座標(0～)を指定します。
sy
型: SystemInt32
y 座標(0～)を指定します。

戻り値

型: Cell
Cell を返します。
解説
A1(0, 0)を基点として、座標で指定します。 明細の行数に関わらず、Section.Detailメソッドの範囲の座標がそのまま指定可能です。
例
C#
VB
コピー
// A5 セルに文字列 "アドバンスソフトウェア" を設定します。
sectionDetail.Pos(0, 4).Value = "アドバンスソフトウェア";
' A5 セルに文字列 "アドバンスソフトウェア" を設定します。
sectionDetail.Pos(0, 4).Value = "アドバンスソフトウェア"
関連項目

参照

SectionDetail クラス


SectionDetail.Start メソッド

SectionDetailStart メソッド

連続帳票に明細行を追加します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Start()
Public Sub Start
解説
Detail.Start メソッドで明細行を追加した後、Detail.Cell メソッドで値の設定が可能です。 Detail.Start メソッドと Detail.Next メソッドは対で呼び出す必要があります。 ページの 1行目の挿入を行う場合、Header イベントが発生します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Section.Start("Sheet1", false);
cellReport1.Section.Header("A1:D4");
cellReport1.Section.Footer("A6:D6");
AdvanceSoftware.ASReport.SectionDetail sectionDetail = cellReport1.Section.Detail("A5:D5");
for (int i = 0; i < 5; i++)
{
    // 連続帳票の明細処理を開始します。
    sectionDetail.Start();
    sectionDetail.Cell("A5").Value = "アドバンスソフトウェア";
    // 連続帳票の明細処理を終了します。
    sectionDetail.Next();
}
cellReport1.Section.End();
cellReport1.Report.End();
cellReport1.Report.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Section.Start("Sheet1", False)
CellReport1.Section.Header("A1:D4")
CellReport1.Section.Footer("A6:D6")
Dim sectionDetail As AdvanceSoftware.ASReport.SectionDetail = CellReport1.Section.Detail("A5:D5")
For i As Integer = 0 To 4
    ' 連続帳票の明細処理を開始します。
    sectionDetail.Start()
    sectionDetail.Cell("A5").Value = "アドバンスソフトウェア"
    ' 連続帳票の明細処理を終了します。
    sectionDetail.Next()
Next
CellReport1.Section.End()
CellReport1.Report.End()
CellReport1.Report.SaveAs("C:\out1.xlsx")
関連項目

参照

SectionDetail クラス


SectionEndPageEventArgs クラス

SectionEndPage イベントのデータを提供します。
継承階層
SystemObject
SystemEventArgs
AdvanceSoftware.ASReportSectionEndPageEventArgs

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class SectionEndPageEventArgs : EventArgs
Public Class SectionEndPageEventArgs
    Inherits EventArgs

SectionEndPageEventArgs 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
Public プロパティ | Footer | フッターを設定するための SectionFooter を取得します。
 | PageNo | 現在のページ数を取得します。
Public プロパティ | SheetName | デザインファイルで使用したシート名を取得します。
トップ
関連項目

参照


SectionEndPageEventArgs プロパティ

SectionEndPageEventArgs 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
Public プロパティ | Footer | フッターを設定するための SectionFooter を取得します。
 | PageNo | 現在のページ数を取得します。
Public プロパティ | SheetName | デザインファイルで使用したシート名を取得します。
トップ
関連項目

参照

SectionEndPageEventArgs クラス


SectionEndPageEventArgs.Footer プロパティ

SectionEndPageEventArgsFooter プロパティ

フッターを設定するための SectionFooter を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public SectionFooter Footer { get; }
Public ReadOnly Property Footer As SectionFooter
    Get

プロパティ値

型: SectionFooter
フッターを設定するための SectionFooter クラス。
解説
このクラスの全てのメンバーの一覧については、SectionFooter クラスのメンバーを参照してください。
関連項目

参照

SectionEndPageEventArgs クラス


SectionEndPageEventArgs.PageNo プロパティ

SectionEndPageEventArgsPageNo プロパティ

現在のページ数を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int PageNo { get; }
Public ReadOnly Property PageNo As Integer
    Get

プロパティ値

型: Int32
現在のページ数を表す、Int32。
例
C#
VB
コピー
private void InitializeComponent()
{
    cellReport1.SectionEndPage += new AdvanceSoftware.ASReport.SectionEndPageEventHandler(cellReport1_SectionEndPage);
}
void cellReport1_SectionEndPage(object sender, AdvanceSoftware.ASReport.SectionEndPageEventArgs e)
{
    // 現在のページ数を取得します。
    int pageNo =  e.PageNo;
}
Private WithEvents CellReport1 As AdvanceSoftware.ASReport.CellReport = New AdvanceSoftware.ASReport.CellReport()
Private Sub CellReport1_SectionEndPage(ByVal sender As Object, ByVal e As AdvanceSoftware.ASReport.SectionEndPageEventArgs) Handles CellReport1.SectionEndPage
    ' 現在のページ数を取得します。
    Dim pageNo As Integer = e.PageNo
End Sub
関連項目

参照

SectionEndPageEventArgs クラス


SectionEndPageEventArgs.SheetName プロパティ

SectionEndPageEventArgsSheetName プロパティ

デザインファイルで使用したシート名を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string SheetName { get; }
Public ReadOnly Property SheetName As String
    Get

プロパティ値

型: String
シート名を表す、String。
関連項目

参照

SectionEndPageEventArgs クラス


SectionEndPageEventHandler デリゲート

SectionEndPage イベントを処理するメソッドを表します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public delegate void SectionEndPageEventHandler(
    Object sender,
    SectionEndPageEventArgs e
)
Public Delegate Sub SectionEndPageEventHandler (
    sender As Object,
    e As SectionEndPageEventArgs
)

パラメーター

sender
型: SystemObject
e
型: AdvanceSoftware.ASReportSectionEndPageEventArgs
関連項目

参照


SectionFooter クラス

連続帳票のフッターを指定します。レポートコンポーネントを通じてこのクラスにアクセスします。
継承階層
SystemObject
AdvanceSoftware.ASReportSectionFooter

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class SectionFooter
Public Class SectionFooter

SectionFooter 型は下記のメンバーを公開します。

メソッド
名前 | 説明
Cell | Cell を取得します。
Pos(Int32, Int32) | Cell を取得します。
Pos(Int32, Int32, Int32, Int32) | Cell を取得します。
トップ
関連項目

参照


SectionFooter メソッド

SectionFooter 型は下記のメンバーを公開します。

メソッド
名前 | 説明
Cell | Cell を取得します。
Pos(Int32, Int32) | Cell を取得します。
Pos(Int32, Int32, Int32, Int32) | Cell を取得します。
トップ
関連項目

参照

SectionFooter クラス


SectionFooter.Cell メソッド

SectionFooterCell メソッド

Cell を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Cell Cell(
    string cell
)
Public Function Cell (
    cell As String
) As Cell

パラメーター

cell
型: SystemString
セルを指定します。

戻り値

型: Cell
Cell を返します。
解説
A1 形式、変数名、セル名で指定します。 変数名、セル名は、デザインファイルにあらかじめ設定しておく必要があります。
例
C#
VB
コピー
private void InitializeComponent()
{
    cellReport1.SectionEndPage += new AdvanceSoftware.ASReport.SectionEndPageEventHandler(cellReport1_SectionEndPage);
}
void cellReport1_SectionEndPage(object sender, AdvanceSoftware.ASReport.SectionEndPageEventArgs e)
{
    // フッター部の D6 セルに文字列 "アドバンスソフトウェア" を設定します。
    e.Footer.Cell("D6").Value = "アドバンスソフトウェア";
}
Private WithEvents CellReport1 As AdvanceSoftware.ASReport.CellReport = New AdvanceSoftware.ASReport.CellReport()
Private Sub CellReport1_SectionEndPage(ByVal sender As Object, ByVal e As AdvanceSoftware.ASReport.SectionEndPageEventArgs) Handles CellReport1.SectionEndPage
    ' フッター部の D6 セルに文字列 "アドバンスソフトウェア" を設定します。
    e.Footer.Cell("D6").Value = "アドバンスソフトウェア"
End Sub
関連項目

参照

SectionFooter クラス


SectionFooter.Pos メソッド

SectionFooterPos メソッド

オーバーロードの一覧
名前 | 説明
Pos(Int32, Int32) | Cell を取得します。
Pos(Int32, Int32, Int32, Int32) | Cell を取得します。
トップ
関連項目

参照

SectionFooter クラス


SectionFooter.Pos メソッド (Int32, Int32)

SectionFooterPos メソッド (Int32, Int32)

Cell を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Cell Pos(
    int sx,
    int sy
)
Public Function Pos (
    sx As Integer,
    sy As Integer
) As Cell

パラメーター

sx
型: SystemInt32
x 座標(0～)を指定します。
sy
型: SystemInt32
y 座標(0～)を指定します。

戻り値

型: Cell
Cell を返します。
解説
A1(0, 0)を基点として、座標で指定します。
例
C#
VB
コピー
private void InitializeComponent()
{
    cellReport1.SectionEndPage += new AdvanceSoftware.ASReport.SectionEndPageEventHandler(cellReport1_SectionEndPage);
}
void cellReport1_SectionEndPage(object sender, AdvanceSoftware.ASReport.SectionEndPageEventArgs e)
{
    // フッター部の D6 セルに文字列 "アドバンスソフトウェア" を設定します。
    e.Footer.Pos(3, 5).Value = "アドバンスソフトウェア";
}
Private WithEvents CellReport1 As AdvanceSoftware.ASReport.CellReport = New AdvanceSoftware.ASReport.CellReport()
Private Sub CellReport1_SectionEndPage(ByVal sender As Object, ByVal e As AdvanceSoftware.ASReport.SectionEndPageEventArgs) Handles CellReport1.SectionEndPage
    ' フッター部の D6 セルに文字列 "アドバンスソフトウェア" を設定します。
    e.Footer.Pos(3, 5).Value = "アドバンスソフトウェア"
End Sub
関連項目

参照

SectionFooter クラス
Pos オーバーロード


SectionFooter.Pos メソッド (Int32, Int32, Int32, Int32)

SectionFooterPos メソッド (Int32, Int32, Int32, Int32)

Cell を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Cell Pos(
    int sx,
    int sy,
    int ex,
    int ey
)
Public Function Pos (
    sx As Integer,
    sy As Integer,
    ex As Integer,
    ey As Integer
) As Cell

パラメーター

sx
型: SystemInt32
開始 x 座標(0～)を指定します。
sy
型: SystemInt32
開始 y 座標(0～)を指定します。
ex
型: SystemInt32
終了 x 座標(0～)を指定します。
ey
型: SystemInt32
終了 y 座標(0～)を指定します。

戻り値

型: Cell
Cell を返します。
解説
A1(0, 0)を基点として、座標で指定します。
例
C#
VB
コピー
private void InitializeComponent()
{
    cellReport1.SectionEndPage += new AdvanceSoftware.ASReport.SectionEndPageEventHandler(cellReport1_SectionEndPage);
}
void cellReport1_SectionEndPage(object sender, AdvanceSoftware.ASReport.SectionEndPageEventArgs e)
{
    // フッター部の C6:D6 セルに文字列 "アドバンスソフトウェア" を設定します。
    e.Footer.Pos(2, 5, 3, 5).Value = "アドバンスソフトウェア";
}
Private WithEvents CellReport1 As AdvanceSoftware.ASReport.CellReport = New AdvanceSoftware.ASReport.CellReport()
Private Sub CellReport1_SectionEndPage(ByVal sender As Object, ByVal e As AdvanceSoftware.ASReport.SectionEndPageEventArgs) Handles CellReport1.SectionEndPage
    ' フッター部の C6:D6 セルに文字列 "アドバンスソフトウェア" を設定します。
    e.Footer.Pos(2, 5, 3, 5).Value = "アドバンスソフトウェア"
End Sub
関連項目

参照

SectionFooter クラス
Pos オーバーロード


SectionHeader クラス

連続帳票のヘッダーを指定します。レポートコンポーネントを通じてこのクラスにアクセスします。
継承階層
SystemObject
AdvanceSoftware.ASReportSectionHeader

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class SectionHeader
Public Class SectionHeader

SectionHeader 型は下記のメンバーを公開します。

メソッド
名前 | 説明
Cell | Cell を取得します。
Pos(Int32, Int32) | Cell を取得します。
Pos(Int32, Int32, Int32, Int32) | Cell を取得します。
トップ
関連項目

参照


SectionHeader メソッド

SectionHeader 型は下記のメンバーを公開します。

メソッド
名前 | 説明
Cell | Cell を取得します。
Pos(Int32, Int32) | Cell を取得します。
Pos(Int32, Int32, Int32, Int32) | Cell を取得します。
トップ
関連項目

参照

SectionHeader クラス


SectionHeader.Cell メソッド

SectionHeaderCell メソッド

Cell を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Cell Cell(
    string cell
)
Public Function Cell (
    cell As String
) As Cell

パラメーター

cell
型: SystemString
セルを指定します。

戻り値

型: Cell
Cell を返します。
解説
A1 形式、変数名、セル名で指定します。 変数名、セル名は、デザインファイルにあらかじめ設定しておく必要があります。
例
C#
VB
コピー
private void InitializeComponent()
{
    cellReport1.SectionNewPage += new AdvanceSoftware.ASReport.SectionNewPageEventHandler(cellReport1_SectionNewPage);
}
void cellReport1_SectionNewPage(object sender, AdvanceSoftware.ASReport.SectionNewPageEventArgs e)
{
    // ヘッダー部の D3 セルに文字列 "アドバンスソフトウェア" を設定します。
    e.Header.Cell("D3").Value = "アドバンスソフトウェア";
}
Private WithEvents CellReport1 As AdvanceSoftware.ASReport.CellReport = New AdvanceSoftware.ASReport.CellReport()
Private Sub CellReport1_SectionNewPage(ByVal sender As Object, ByVal e As AdvanceSoftware.ASReport.SectionNewPageEventArgs) Handles CellReport1.SectionNewPage
    ' ヘッダー部の D3 セルに文字列 "アドバンスソフトウェア" を設定します。
    e.Header.Cell("D3").Value = "アドバンスソフトウェア"
End Sub
関連項目

参照

SectionHeader クラス


SectionHeader.Pos メソッド

SectionHeaderPos メソッド

オーバーロードの一覧
名前 | 説明
Pos(Int32, Int32) | Cell を取得します。
Pos(Int32, Int32, Int32, Int32) | Cell を取得します。
トップ
関連項目

参照

SectionHeader クラス


SectionHeader.Pos メソッド (Int32, Int32)

SectionHeaderPos メソッド (Int32, Int32)

Cell を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Cell Pos(
    int sx,
    int sy
)
Public Function Pos (
    sx As Integer,
    sy As Integer
) As Cell

パラメーター

sx
型: SystemInt32
x 座標(0～)を指定します。
sy
型: SystemInt32
y 座標(0～)を指定します。

戻り値

型: Cell
Cell を返します。
解説
A1(0, 0)を基点として、座標で指定します。
例
C#
VB
コピー
private void InitializeComponent()
{
    cellReport1.SectionNewPage += new AdvanceSoftware.ASReport.SectionNewPageEventHandler(cellReport1_SectionNewPage);
}
void cellReport1_SectionNewPage(object sender, AdvanceSoftware.ASReport.SectionNewPageEventArgs e)
{
    // ヘッダー部の D3 セルに文字列 "アドバンスソフトウェア" を設定します。
    e.Header.Pos(3, 2).Value = "アドバンスソフトウェア";
}
Private WithEvents CellReport1 As AdvanceSoftware.ASReport.CellReport = New AdvanceSoftware.ASReport.CellReport()
Private Sub CellReport1_SectionNewPage(ByVal sender As Object, ByVal e As AdvanceSoftware.ASReport.SectionNewPageEventArgs) Handles CellReport1.SectionNewPage
    ' ヘッダー部の D3 セルに文字列 "アドバンスソフトウェア" を設定します。
    e.Header.Pos(3, 2).Value = "アドバンスソフトウェア"
End Sub
関連項目

参照

SectionHeader クラス
Pos オーバーロード


SectionHeader.Pos メソッド (Int32, Int32, Int32, Int32)

SectionHeaderPos メソッド (Int32, Int32, Int32, Int32)

Cell を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Cell Pos(
    int sx,
    int sy,
    int ex,
    int ey
)
Public Function Pos (
    sx As Integer,
    sy As Integer,
    ex As Integer,
    ey As Integer
) As Cell

パラメーター

sx
型: SystemInt32
開始 x 座標(0～)を指定します。
sy
型: SystemInt32
開始 y 座標(0～)を指定します。
ex
型: SystemInt32
終了 x 座標(0～)を指定します。
ey
型: SystemInt32
終了 y 座標(0～)を指定します。

戻り値

型: Cell
Cell を返します。
解説
A1(0, 0)を基点として、座標で指定します。
例
C#
VB
コピー
private void InitializeComponent()
{
    cellReport1.SectionNewPage += new AdvanceSoftware.ASReport.SectionNewPageEventHandler(cellReport1_SectionNewPage);
}
void cellReport1_SectionNewPage(object sender, AdvanceSoftware.ASReport.SectionNewPageEventArgs e)
{
    // ヘッダー部の C3:D3 セルに文字列 "アドバンスソフトウェア" を設定します。
    e.Header.Pos(2, 2, 3, 2).Value = "アドバンスソフトウェア";
}
Private WithEvents CellReport1 As AdvanceSoftware.ASReport.CellReport = New AdvanceSoftware.ASReport.CellReport()
Private Sub CellReport1_SectionNewPage(ByVal sender As Object, ByVal e As AdvanceSoftware.ASReport.SectionNewPageEventArgs) Handles CellReport1.SectionNewPage
    ' ヘッダー部の C3:D3 セルに文字列 "アドバンスソフトウェア" を設定します。
    e.Header.Pos(2, 2, 3, 2).Value = "アドバンスソフトウェア"
End Sub
関連項目

参照

SectionHeader クラス
Pos オーバーロード


SectionNewPageEventArgs クラス

SectionNewPage イベントのデータを提供します。
継承階層
SystemObject
SystemEventArgs
AdvanceSoftware.ASReportSectionNewPageEventArgs

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class SectionNewPageEventArgs : EventArgs
Public Class SectionNewPageEventArgs
    Inherits EventArgs

SectionNewPageEventArgs 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
Public プロパティ | Header | ヘッダーを設定するための SectionHeader を取得します。
Public プロパティ | PageNo | 現在のページ数を取得します。
Public プロパティ | SheetName | デザインファイルで使用したシート名を取得します。
トップ
関連項目

参照


SectionNewPageEventArgs プロパティ

SectionNewPageEventArgs 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
Public プロパティ | Header | ヘッダーを設定するための SectionHeader を取得します。
Public プロパティ | PageNo | 現在のページ数を取得します。
Public プロパティ | SheetName | デザインファイルで使用したシート名を取得します。
トップ
関連項目

参照

SectionNewPageEventArgs クラス


SectionNewPageEventArgs.Header プロパティ

SectionNewPageEventArgsHeader プロパティ

ヘッダーを設定するための SectionHeader を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public SectionHeader Header { get; }
Public ReadOnly Property Header As SectionHeader
    Get

プロパティ値

型: SectionHeader
ヘッダーを設定するための SectionHeader クラス。
解説
このクラスの全てのメンバーの一覧については、SectionHeader クラスのメンバーを参照してください。
関連項目

参照

SectionNewPageEventArgs クラス


SectionNewPageEventArgs.PageNo プロパティ

SectionNewPageEventArgsPageNo プロパティ

現在のページ数を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int PageNo { get; }
Public ReadOnly Property PageNo As Integer
    Get

プロパティ値

型: Int32
現在のページ数を表す、Int32。
関連項目

参照

SectionNewPageEventArgs クラス


SectionNewPageEventArgs.SheetName プロパティ

SectionNewPageEventArgsSheetName プロパティ

デザインファイルで使用したシート名を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string SheetName { get; }
Public ReadOnly Property SheetName As String
    Get

プロパティ値

型: String
シート名を表す、String。
関連項目

参照

SectionNewPageEventArgs クラス


SectionNewPageEventHandler デリゲート

SectionNewPage イベントを処理するメソッドを表します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.CellReport (in AdvanceSoftware.ASReport.CellReport.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public delegate void SectionNewPageEventHandler(
    Object sender,
    SectionNewPageEventArgs e
)
Public Delegate Sub SectionNewPageEventHandler (
    sender As Object,
    e As SectionNewPageEventArgs
)

パラメーター

sender
型: SystemObject
e
型: AdvanceSoftware.ASReportSectionNewPageEventArgs
関連項目

参照


ShapeType 列挙体

シェイプタイプを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ShapeType
Public Enumeration ShapeType
メンバー
メンバー | 値 | 説明
Line | 1 | 直線 (Xls)(Xlsx)
LineInv | 2 | LineInv (Xlsx)
Triangle | 3 | 二等辺三角形 (Xls)(Xlsx)
RtTriangle | 4 | 直角三角形 (Xls)(Xlsx)
Rect | 5 | 正方形,長方形 (Xls)(Xlsx)
Diamond | 6 | ひし形 (Xls)(Xlsx)
Parallelogram | 7 | 平行四辺形 (Xls)(Xlsx)
Trapezoid | 8 | 台形 (Xls)(Xlsx)
NonIsoscelesTrapezoid | 9 | NonIsoscelesTrapezoid (Xlsx)
Pentagon | 10 | 五角形 (Xls)(Xlsx)
Hexagon | 11 | 六角形 (Xls)(Xlsx)
Heptagon | 12 | 七角形 (Xlsx)
Octagon | 13 | 八角形 (Xls)(Xlsx)
Decagon | 14 | 十角形 (Xlsx)
Dodecagon | 15 | 十二角形 (Xlsx)
Star4 | 16 | 星 4 (Xlsx)
Star5 | 17 | 星 5 (Xlsx)
Star6 | 18 | 星 6 (Xlsx)
Star7 | 19 | 星 7 (Xlsx)
Star8 | 20 | 星 8 (Xlsx)
Star10 | 21 | 星 10 (Xlsx)
Star12 | 22 | 星 12 (Xlsx)
Star16 | 23 | 星 16 (Xlsx)
Star24 | 24 | 星 24 (Xlsx)
Star32 | 25 | 星 32 (Xlsx)
RoundRect | 26 | 角丸四角形 (Xls)(Xlsx)
Round1Rect | 27 | 1 つの角を丸めた四角形 (Xlsx)
Round2SameRect | 28 | 片側の 2 つの角を丸めた四角形 (Xlsx)
Round2DiagRect | 29 | 対角する 2 つの角を丸めた四角形 (Xlsx)
SnipRoundRect | 30 | 1 つの角を丸めた四角形 (Xlsx)
Snip1Rect | 31 | 1 つの角を切り取った四角形 (Xlsx)
Snip2SameRect | 32 | 片側の 2 つの角を切り取った四角形 (Xlsx)
Snip2DiagRect | 33 | 対角する 2 つの角を切り取った四角形 (Xlsx)
Plaque | 34 | ブローチ (Xls)(Xlsx)
Ellipse | 35 | 円,楕円 (Xls)(Xlsx)
Teardrop | 36 | 涙形 (Xlsx)
HomePlate | 37 | ホームベース (Xlsx)
Chevron | 38 | 山形 (Xlsx)
PieWedge | 39 | PieWedge (Xlsx)
Pie | 40 | パイ (Xlsx)
BlockArc | 41 | アーチ (Xlsx)
Donut | 42 | ドーナツ (Xlsx)
NoSmoking | 43 | 禁止 (Xlsx)
RightArrow | 44 | 右矢印 (Xlsx)
LeftArrow | 45 | 左矢印 (Xlsx)
UpArrow | 46 | 上矢印 (Xlsx)
DownArrow | 47 | 下矢印 (Xlsx)
StripedRightArrow | 48 | ストライプ矢印 (Xlsx)
NotchedRightArrow | 49 | V 字形矢印 (Xlsx)
BentUpArrow | 50 | 屈折矢印 (Xlsx)
LeftRightArrow | 51 | 左右矢印 (Xlsx)
UpDownArrow | 52 | 上下矢印 (Xlsx)
LeftUpArrow | 53 | 二方向矢印 (Xlsx)
LeftRightUpArrow | 54 | 三方向矢印 (Xlsx)
QuadArrow | 55 | 四方向矢印 (Xlsx)
LeftArrowCallout | 56 | 左矢印吹き出し (Xlsx)
RightArrowCallout | 57 | 右矢印吹き出し (Xlsx)
UpArrowCallout | 58 | 上矢印吹き出し (Xlsx)
DownArrowCallout | 56 | 下矢印吹き出し (Xlsx)
LeftRightArrowCallout | 60 | 左右矢印吹き出し (Xlsx)
UpDownArrowCallout | 61 | 上下ブロック矢印付吹き出し (Xlsx)
QuadArrowCallout | 62 | 四方向矢印吹き出し (Xlsx)
BentArrow | 63 | 曲折矢印 (Xlsx)
UturnArrow | 64 | U ターン矢印 (Xlsx)
CircularArrow | 65 | 環状矢印 (Xlsx)
LeftCircularArrow | 66 | LeftCircularArrow (Xlsx)
LeftRightCircularArrow | 67 | LeftRightCircularArrow (Xlsx)
CurvedRightArrow | 68 | 右カーブ矢印 (Xlsx)
CurvedLeftArrow | 69 | 左カーブ矢印 (Xlsx)
CurvedUpArrow | 70 | 上カーブ矢印 (Xlsx)
CurvedDownArrow | 71 | 下カーブ矢印 (Xlsx)
SwooshArrow | 72 | SwooshArrow (Xlsx)
Cube | 73 | 直方体 (Xls)(Xlsx)
Can | 74 | 円柱 (Xls)(Xlsx)
LightningBolt | 75 | 稲妻 (Xlsx)
Heart | 76 | ハート (Xlsx)
Sun | 77 | 太陽 (Xlsx)
Moon | 78 | 月 (Xlsx)
SmileyFace | 79 | スマイル (Xlsx)
IrregularSeal1 | 80 | 爆発 1 (Xlsx)
IrregularSeal2 | 81 | 爆発 2 (Xlsx)
FoldedCorner | 82 | メモ (Xls)(Xlsx)
Bevel | 83 | 額縁 (Xls)(Xlsx)
Frame | 84 | フレーム (Xlsx)
HalfFrame | 85 | ハーフフレーム (Xlsx)
Corner | 86 | L 字 (Xlsx)
DiagStripe | 87 | 斜め縞 (Xlsx)
Chord | 88 | 弦 (Xlsx)
Arc | 89 | 円弧 (Xlsx)
LeftBracket | 90 | 左大かっこ (Xls)(Xlsx)
RightBracket | 91 | 右大かっこ (Xls)(Xlsx)
LeftBrace | 92 | 左中かっこ (Xlsx)
RightBrace | 93 | 右中かっこ (Xlsx)
BracketPair | 94 | 大かっこ (Xls)(Xlsx)
BracePair | 95 | 中かっこ (Xls)(Xlsx)
StraightConnector1 | 96 | 直線矢印コネクタ (Xlsx)
BentConnector2 | 97 | カギ線コネクタ 2 (Xlsx)
BentConnector3 | 98 | カギ線コネクタ 3 (Xlsx)
BentConnector4 | 99 | カギ線コネクタ 4 (Xlsx)
BentConnector5 | 100 | カギ線コネクタ 5 (Xlsx)
CurvedConnector2 | 101 | 曲線コネクタ 2 (Xlsx)
CurvedConnector3 | 102 | 曲線コネクタ 3 (Xlsx)
CurvedConnector4 | 103 | 曲線コネクタ 4 (Xlsx)
CurvedConnector5 | 104 | 曲線コネクタ 5 (Xlsx)
Callout1 | 105 | 線吹き出し 1 (Xlsx)
Callout2 | 106 | 線吹き出し 2 (Xlsx)
Callout3 | 107 | 線吹き出し 3 (Xlsx)
AccentCallout1 | 108 | 強調線吹き出し 1 (Xlsx)
AccentCallout2 | 109 | 強調線吹き出し 2 (Xlsx)
AccentCallout3 | 110 | 強調線吹き出し 3 (Xlsx)
BorderCallout1 | 111 | 枠付き線吹き出し 1 (Xlsx)
BorderCallout2 | 112 | 枠付き線吹き出し 2 (Xlsx)
BorderCallout3 | 113 | 枠付き線吹き出し 3 (Xlsx)
AccentBorderCallout1 | 114 | 枠付き強調線吹き出し 1 (Xlsx)
AccentBorderCallout2 | 115 | 枠付き強調線吹き出し 2 (Xlsx)
AccentBorderCallout3 | 116 | 枠付き強調線吹き出し 3 (Xlsx)
WedgeRectCallout | 117 | 四角形吹き出し (Xlsx)
WedgeRoundRectCallout | 118 | 角丸四角形吹き出し (Xlsx)
WedgeEllipseCallout | 119 | 円形吹き出し (Xlsx)
CloudCallout | 120 | 雲形吹き出し (Xlsx)
Cloud | 121 | 雲 (Xlsx)
Ribbon | 122 | 下リボン (Xlsx)
Ribbon2 | 123 | 上リボン (Xlsx)
EllipseRibbon | 124 | 下カーブ リボン (Xlsx)
EllipseRibbon2 | 125 | 上カーブ リボン (Xlsx)
LeftRightRibbon | 126 | LeftRightRibbon (Xlsx)
VerticalScroll | 127 | 縦巻き (Xlsx)
HorizontalScroll | 128 | 横巻き (Xlsx)
Wave | 129 | 大波 (Xlsx)
DoubleWave | 130 | 小波 (Xlsx)
Plus | 131 | 十字形 (Xls)(Xlsx)
FlowChartProcess | 132 | フローチャート : 処理 (Xlsx)
FlowChartDecision | 133 | フローチャート : 判断 (Xlsx)
FlowChartInputOutput | 134 | フローチャート : データ (Xlsx)
FlowChartPredefinedProcess | 135 | フローチャート : 定義済み処理 (Xlsx)
FlowChartInternalStorage | 136 | フローチャート : 内部記憶 (Xlsx)
FlowChartDocument | 137 | フローチャート : 書類 (Xlsx)
FlowChartMultidocument | 138 | フローチャート : 複数書類 (Xlsx)
FlowChartTerminator | 139 | フローチャート : 端子 (Xlsx)
FlowChartPreparation | 140 | フローチャート : 準備 (Xlsx)
FlowChartManualInput | 141 | フローチャート : 手操作入力 (Xlsx)
FlowChartManualOperation | 142 | フローチャート : 手作業 (Xlsx)
FlowChartConnector | 143 | フローチャート : 結合子 (Xlsx)
FlowChartPunchedCard | 144 | フローチャート : カード (Xlsx)
FlowChartPunchedTape | 145 | フローチャート : せん孔テープ (Xlsx)
FlowChartSummingJunction | 146 | フローチャート : 和接合 (Xlsx)
FlowChartOr | 147 | フローチャート : 論理和 (Xlsx)
FlowChartCollate | 148 | フローチャート : 照合 (Xlsx)
FlowChartSort | 149 | フローチャート : 分類 (Xlsx)
FlowChartExtract | 150 | フローチャート : 抜出し (Xlsx)
FlowChartMerge | 151 | フローチャート : 組合せ (Xlsx)
FlowChartOfflineStorage | 152 | フローチャート : OfflineStorage (Xlsx)
FlowChartOnlineStorage | 153 | フローチャート : 記憶データ (Xlsx)
FlowChartMagneticTape | 154 | フローチャート : 順次アクセス記憶 (Xlsx)
FlowChartMagneticDisk | 155 | フローチャート : 磁気ディスク (Xlsx)
FlowChartMagneticDrum | 156 | フローチャート : 直接アクセス記憶 (Xlsx)
FlowChartDisplay | 157 | フローチャート : 表示 (Xlsx)
FlowChartDelay | 158 | フローチャート : 論理積ゲート (Xlsx)
FlowChartAlternateProcess | 159 | フローチャート : 代替処理 (Xlsx)
FlowChartOffpageConnector | 160 | フローチャート : 他ページ結合子 (Xlsx)
ActionButtonBlank | 161 | アクションボタン ： ブランク (Xlsx)
ActionButtonHome | 162 | アクションボタン ： ホーム (Xlsx)
ActionButtonHelp | 163 | アクションボタン ： ヘルプ (Xlsx)
ActionButtonInformation | 164 | アクションボタン ： 情報 (Xlsx)
ActionButtonForwardNext | 165 | アクションボタン ： 次へ (Xlsx)
ActionButtonBackPrevious | 166 | アクションボタン ： 前へ (Xlsx)
ActionButtonEnd | 167 | アクションボタン ： 終了 (Xlsx)
ActionButtonBeginning | 168 | アクションボタン ： 開始 (Xlsx)
ActionButtonReturn | 169 | アクションボタン ： 戻る (Xlsx)
ActionButtonDocument | 170 | アクションボタン ： ドキュメント (Xlsx)
ActionButtonSound | 171 | アクションボタン ： サウンド (Xlsx)
ActionButtonMovie | 172 | アクションボタン ： 動画 (Xlsx)
Gear6 | 173 | ギア 6 (Xlsx)
Gear9 | 174 | ギア 9 (Xlsx)
Funnel | 175 | Funnel (Xlsx)
MathPlus | 176 | 加算記号 (Xlsx)
MathMinus | 177 | 減算記号 (Xlsx)
MathMultiply | 178 | 乗算記号 (Xlsx)
MathDivide | 179 | 除算記号 (Xlsx)
MathEqual | 180 | 等号 (Xlsx)
MathNotEqual | 181 | 不等号 (Xlsx)
CornerTabs | 182 | CornerTabs (Xlsx)
SquareTabs | 183 | SquareTabs (Xlsx)
PlaqueTabs | 184 | PlaqueTabs (Xlsx)
ChartX | 185 | ChartX (Xlsx)
ChartStar | 186 | ChartStar (Xlsx)
ChartPlus | 187 | ChartPlus (Xlsx)
Quadrangle | 4114 | 四角形 (Xls)(Xlsx)
Rhombic | 4162 | ひし形 (Xls)(Xlsx)
CornerQuadrangle | 4130 | 角丸四角形 (Xls)(Xlsx)
IsoscelesTriangle | 4178 | 二等辺三角形 (Xls)(Xlsx)
RightTriangle | 4194 | 直角三角形 (Xls)(Xlsx)
CrissCross | 4274 | 十字形 (Xls)(Xlsx)
Pentagonal | 4994 | 五角形 (Xls)(Xlsx)
Cylinder | 4450 | 円柱 (Xls)(Xlsx)
Rectangular | 4354 | 直方体 (Xls)(Xlsx)
PictureFrame | 5442 | 額縁 (Xls)(Xlsx)
Memo | 5138 | メモ (Xls)(Xlsx)
Brackets | 7058 | 大括弧 (Xls)(Xlsx)
CurlyBrace | 7074 | 中括弧 (Xls)(Xlsx)
Broach | 4434 | ブローチ (Xls)(Xlsx)
LeftBrackets | 5458 | 左大括弧 (Xls)(Xlsx)
RightBrackets | 5474 | 右大括弧 (Xls)(Xlsx)
関連項目

参照


StreamMode 列挙体

データを展開するストリームモードを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum StreamMode
Public Enumeration StreamMode
メンバー
メンバー | 値 | 説明
Memory | 0 | メモリ上に展開します。
File | 1 | ファイルに展開します。
関連項目

参照


SvgSaveType 列挙体

保存するファイルのタイプを指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum SvgSaveType
Public Enumeration SvgSaveType
メンバー
メンバー | 値 | 説明
Default | 0 | 標準(Svg のみ)
IncludeExcel | 1 | Svg + Excel
IncludePdf | 2 | Svg + Pdf
IncludeExcelPdf | 3 | Svg + Excel + Pdf
関連項目

参照


TextAlign 列挙体

テキストボックスの水平方向の文字位置を示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TextAlign
Public Enumeration TextAlign
メンバー
メンバー | 値 | 説明
Center | 1 | 中央揃え
Justy | 3 | 両端揃え
Left | 5 | 左詰め
Right | 6 | 右詰め
関連項目

参照


TextAnchor 列挙体

テキストボックスの垂直方向の文字位置を示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TextAnchor
Public Enumeration TextAnchor
メンバー
メンバー | 値 | 説明
Top | 1 | 上詰め
Center | 2 | 中央揃え
Bottom | 3 | 下詰め
Justify | 4 | 両端揃え
関連項目

参照


TextBoxFontStyle 列挙体

テキストボックスのフォントスタイルを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TextBoxFontStyle
Public Enumeration TextBoxFontStyle
メンバー
メンバー | 値 | 説明
Normal | 0 | 標準
Bold | 1 | 太字
Italic | 2 | 斜体
関連項目

参照


TextVertical 列挙体

テキストボックスの縦書きを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TextVertical
Public Enumeration TextVertical
メンバー
メンバー | 値 | 説明
EaVert | 1 | 縦書き
Horz | 2 | 横書き
Vert | 4 | 右へ90°回転
Vert270 | 5 | 左へ90°回転
WordArtVertRtl | 7 | 縦書き
関連項目

参照


ToolBarIcon 列挙体

ツールバーアイコンの大きさを指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ToolBarIcon
Public Enumeration ToolBarIcon
メンバー
メンバー | 値 | 説明
SmallIcon | 0 | 小
MiddleIcon | 1 | 中
LargeIcon | 2 | 大
関連項目

参照


ToolBarIconType 列挙体

ツールバーアイコンのタイプを指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ToolBarIconType
Public Enumeration ToolBarIconType
メンバー
メンバー | 値 | 説明
Type1 | 0 | タイプ１
Type2 | 1 | タイプ２
関連項目

参照


VarInsertMode 列挙体

変数名挿入モードを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum VarInsertMode
Public Enumeration VarInsertMode
メンバー
メンバー | 値 | 説明
All | 0 | 全ての変数名にデータを挿し込みます。
InvalidAnswer | 1 | 数式結果の変数名以外にデータを挿し込みます。
InvalidTextBox | 2 | テキストボックスの変数名以外にデータを挿し込みます。
InvalidCellText | 4 | セルの変数名以外にデータを挿し込みます。
関連項目

参照


VarNameMode 列挙体

変数名キーワードの扱いを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum VarNameMode
Public Enumeration VarNameMode
メンバー
メンバー | 値 | 説明
Shared | 0 | スレッド間で共通のキーワードとして指定する
Private | 1 | スレッドごとに異なるキーワードとして指定する
関連項目

参照


VerticalAlignment 列挙体

垂直方向の位置を示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum VerticalAlignment
Public Enumeration VerticalAlignment
メンバー
メンバー | 値 | 説明
Top | 1 | 上詰め
Center | 2 | 中央揃え
Bottom | 3 | 下詰め
Justify | 4 | 両端揃え
Distributed | 5 | 均等割り付け
関連項目

参照


ViewerClearMode 列挙体

ビューアのクリアモードを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ViewerClearMode
Public Enumeration ViewerClearMode
メンバー
メンバー | 値 | 説明
All | 0 | 全てクリア
Document | 1 | Document 関連のみクリア
関連項目

参照


ViewerControl クラス

帳票を出力する ViewerControl オブジェクトです。
継承階層
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
AdvanceSoftware.ASReportViewerControl

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class ViewerControl : UserControl
Public Class ViewerControl
    Inherits UserControl

ViewerControl 型は下記のメンバーを公開します。

コンストラクター
 | 名前 | 説明
Public メソッド | ViewerControl | コンストラクター
トップ
プロパティ
 | 名前 | 説明
 | Document | プレビューする Document を設定します。
 | EnableAllButton | ツールバーの全体を表示ボタンを有効にするかどうかを設定、取得します。
 | EnableAsideButton | ツールバーの横に合わせるボタンを有効にするかどうかを設定、取得します。
 | EnableFirstButton | ツールバーの最初のページボタンを有効にするかどうかを設定、取得します。
 | EnableLastButton | ツールバーの最後のページボタンを有効にするかどうかを設定、取得します。
 | EnableLengthwiseButton | ツールバーの縦に合わせるボタンを有効にするかどうかを設定、取得します。
 | EnableNextButton | ツールバーの次ページボタンを有効にするかどうかを設定、取得します。
 | EnablePrevButton | ツールバーの前ページボタンを有効にするかどうかを設定、取得します。
 | EnablePrintButton | ツールバーの印刷ボタンを有効にするかどうかを設定、取得します。
 | EnableSaveButton | ツールバーの保存ボタンを有効にするかどうかを設定、取得します。
 | EnableZoomButton | ツールバーの倍率ボタンを有効にするかどうかを設定、取得します。
 | ErrorMessage | エラーメッセージを取得します。
 | ErrorNo | エラーナンバーを取得します。
 | InternalViewZoom | 表示する倍率を取得します。
 | IsPdfSaved | PDF ファイルに保存されたかどうかを取得します。
 | IsPrinted | 印刷されたかどうかを取得します。
 | IsSaved | 保存されたかどうかを取得します。
 | OverFit | 帳票を 1 ページに収まるよう表示するかを設定、取得します。
 | PageCount | 総ページ数を取得します。
 | PrintButtonMode | 印刷ボタンの動作を設定、取得します。
 | PrintDocumentName | 印刷のドキュメント名を設定します。
Public プロパティ | Printer | Printer を取得します。
 | PrinterName | 現在選択されているプリンタ名を取得します。
 | PrintType | 印刷タイプを設定、取得します。
 | ProgressDescription | プログレスダイアログのユーザーメッセージを設定します。
 | SaveFileName | 保存時のデフォルトファイル名を設定、取得します。
 | SaveKind | 保存時のファイルの種類を設定、取得します。
 | SaveMessage | 保存処理終了後に表示するメッセージ文字列を設定します。
 | ShowAllButton | ツールバーの全体を表示ボタンを表示するかどうかを設定、取得します。
 | ShowAsideButton | ツールバーの横に合わせるボタンを表示するかどうかを設定、取得します。
 | ShowFirstButton | ツールバーの最初のページボタンを表示するかどうかを設定、取得します。
 | ShowInvalidArea | 印字可能領域を表示するかどうかを設定、取得します。
 | ShowLastButton | ツールバーの最後のページボタンを表示するかどうかを設定、取得します。
 | ShowLengthwiseButton | ツールバーの縦に合わせるボタンを表示するかどうかを設定、取得します。
 | ShowMarginArea | 余白領域を表示するかどうかを設定、取得します。
 | ShowNextButton | ツールバーの次ページボタンを表示するかどうかを設定、取得します。
 | ShowPrevButton | ツールバーの前ページボタンを表示するかどうかを設定、取得します。
 | ShowPrintButton | ツールバーの印刷ボタンを表示するかどうかを設定、取得します。
 | ShowPrintMenu | ツールバーの印刷メニューを表示するかどうかを設定、取得します。
 | ShowPrintMenuItem | ツールバーの印刷ボタンのメニュー「印刷(P)」を表示するかどうかを設定、取得します。
 | ShowProgressDialog | プログレスダイアログを表示する、しないを設定、取得します。
 | ShowReportFrame | 帳票の枠組み(罫線、背景色)を表示するかどうかを設定、取得します。
 | ShowSaveButton | ツールバーの保存ボタンを表示するかどうかを設定、取得します。
 | ShowSetPrinterMenuItem | ツールバーの印刷ボタンのメニュー「プリンタの設定(S)」を表示するかどうかを設定、取得します。
 | ShowSheetName | ステータスバーのシート名を表示するかどうかを設定、取得します。
 | ShowStatusBar | ステータスバーを表示するかどうかを設定、取得します。
 | ShowToolBar | ツールバーを表示するかどうかを設定、取得します。
 | ShowUseExcelPrint | 印刷ダイアログの「Excel を使用して印刷する」チェックボックスを表示する、しないを設定、取得します。
 | ShowZoomButton | ツールバーの倍率ボタンを表示するかどうかを設定、取得します。
 | SizingGrip | ステータスバーにサイズ変更ハンドルを付けるかどうかを設定、取得します。
 | ToolBarIcon | ツールバーのアイコンのサイズを設定、取得します。
 | ToolBarIconType | ツールバーのアイコンのタイプを設定、取得します。
 | ViewerStatus | ビューアコントロールのステータス(待機、動作中)を取得します。
 | ViewPage | 表示するページを設定、取得します。
 | ViewZoom | 表示する倍率を設定、取得します。
トップ
メソッド
名前 | 説明
Clear | 帳票表示をクリアします。
Clear(ViewerClearMode) | 帳票表示をクリアします。(ViewerClearMode)
PrintOut | 印刷します。
PrintOut(String) | 印刷します。
PrintOut(String, String) | 印刷します。
PrintOut(String, String, Int16) | 印刷します。
SaveAs(String) | Excel ファイルに保存します。
SaveAs(String, ExcelVersion) | Excel ファイルに保存します。
SavePdf(Stream) | PDF ファイルに保存します。
SavePdf(String) | PDF ファイルに保存します。
SetPrinter | プリンタの設定をします。
トップ
イベント
名前 | 説明
Error | エラーイベント
Progress | プログレスイベント
トップ
関連項目

参照


ViewerControl コンストラクター

コンストラクター

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ViewerControl()
Public Sub New
関連項目

参照

ViewerControl クラス


ViewerControl プロパティ

ViewerControl 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
 | Document | プレビューする Document を設定します。
 | EnableAllButton | ツールバーの全体を表示ボタンを有効にするかどうかを設定、取得します。
 | EnableAsideButton | ツールバーの横に合わせるボタンを有効にするかどうかを設定、取得します。
 | EnableFirstButton | ツールバーの最初のページボタンを有効にするかどうかを設定、取得します。
 | EnableLastButton | ツールバーの最後のページボタンを有効にするかどうかを設定、取得します。
 | EnableLengthwiseButton | ツールバーの縦に合わせるボタンを有効にするかどうかを設定、取得します。
 | EnableNextButton | ツールバーの次ページボタンを有効にするかどうかを設定、取得します。
 | EnablePrevButton | ツールバーの前ページボタンを有効にするかどうかを設定、取得します。
 | EnablePrintButton | ツールバーの印刷ボタンを有効にするかどうかを設定、取得します。
 | EnableSaveButton | ツールバーの保存ボタンを有効にするかどうかを設定、取得します。
 | EnableZoomButton | ツールバーの倍率ボタンを有効にするかどうかを設定、取得します。
 | ErrorMessage | エラーメッセージを取得します。
 | ErrorNo | エラーナンバーを取得します。
 | InternalViewZoom | 表示する倍率を取得します。
 | IsPdfSaved | PDF ファイルに保存されたかどうかを取得します。
 | IsPrinted | 印刷されたかどうかを取得します。
 | IsSaved | 保存されたかどうかを取得します。
 | OverFit | 帳票を 1 ページに収まるよう表示するかを設定、取得します。
 | PageCount | 総ページ数を取得します。
 | PrintButtonMode | 印刷ボタンの動作を設定、取得します。
 | PrintDocumentName | 印刷のドキュメント名を設定します。
Public プロパティ | Printer | Printer を取得します。
 | PrinterName | 現在選択されているプリンタ名を取得します。
 | PrintType | 印刷タイプを設定、取得します。
 | ProgressDescription | プログレスダイアログのユーザーメッセージを設定します。
 | SaveFileName | 保存時のデフォルトファイル名を設定、取得します。
 | SaveKind | 保存時のファイルの種類を設定、取得します。
 | SaveMessage | 保存処理終了後に表示するメッセージ文字列を設定します。
 | ShowAllButton | ツールバーの全体を表示ボタンを表示するかどうかを設定、取得します。
 | ShowAsideButton | ツールバーの横に合わせるボタンを表示するかどうかを設定、取得します。
 | ShowFirstButton | ツールバーの最初のページボタンを表示するかどうかを設定、取得します。
 | ShowInvalidArea | 印字可能領域を表示するかどうかを設定、取得します。
 | ShowLastButton | ツールバーの最後のページボタンを表示するかどうかを設定、取得します。
 | ShowLengthwiseButton | ツールバーの縦に合わせるボタンを表示するかどうかを設定、取得します。
 | ShowMarginArea | 余白領域を表示するかどうかを設定、取得します。
 | ShowNextButton | ツールバーの次ページボタンを表示するかどうかを設定、取得します。
 | ShowPrevButton | ツールバーの前ページボタンを表示するかどうかを設定、取得します。
 | ShowPrintButton | ツールバーの印刷ボタンを表示するかどうかを設定、取得します。
 | ShowPrintMenu | ツールバーの印刷メニューを表示するかどうかを設定、取得します。
 | ShowPrintMenuItem | ツールバーの印刷ボタンのメニュー「印刷(P)」を表示するかどうかを設定、取得します。
 | ShowProgressDialog | プログレスダイアログを表示する、しないを設定、取得します。
 | ShowReportFrame | 帳票の枠組み(罫線、背景色)を表示するかどうかを設定、取得します。
 | ShowSaveButton | ツールバーの保存ボタンを表示するかどうかを設定、取得します。
 | ShowSetPrinterMenuItem | ツールバーの印刷ボタンのメニュー「プリンタの設定(S)」を表示するかどうかを設定、取得します。
 | ShowSheetName | ステータスバーのシート名を表示するかどうかを設定、取得します。
 | ShowStatusBar | ステータスバーを表示するかどうかを設定、取得します。
 | ShowToolBar | ツールバーを表示するかどうかを設定、取得します。
 | ShowUseExcelPrint | 印刷ダイアログの「Excel を使用して印刷する」チェックボックスを表示する、しないを設定、取得します。
 | ShowZoomButton | ツールバーの倍率ボタンを表示するかどうかを設定、取得します。
 | SizingGrip | ステータスバーにサイズ変更ハンドルを付けるかどうかを設定、取得します。
 | ToolBarIcon | ツールバーのアイコンのサイズを設定、取得します。
 | ToolBarIconType | ツールバーのアイコンのタイプを設定、取得します。
 | ViewerStatus | ビューアコントロールのステータス(待機、動作中)を取得します。
 | ViewPage | 表示するページを設定、取得します。
 | ViewZoom | 表示する倍率を設定、取得します。
トップ
関連項目

参照

ViewerControl クラス


ViewerControl.Document プロパティ

ViewerControlDocument プロパティ

プレビューする Document を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Document Document { set; }
Public WriteOnly Property Document As Document
    Set

プロパティ値

型: Document
解説
プレビュー表示を行う Document。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// ビューアコントロールに帳票ドキュメントを設定します。
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' ビューアコントロールに帳票ドキュメントを設定します。
ViewerControl1.Document = CellReport1.Document
関連項目

参照

ViewerControl クラス


ViewerControl.EnableAllButton プロパティ

ViewerControlEnableAllButton プロパティ

ツールバーの全体を表示ボタンを有効にするかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool EnableAllButton { get; set; }
Public Property EnableAllButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「全体を表示」ボタンを有効にしない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "全体を表示" ボタンを無効にします。
viewerControl1.EnableAllButton = false;
' ツールバーの "全体を表示" ボタンを無効にします。
ViewerControl1.EnableAllButton = False
関連項目

参照

ViewerControl クラス


ViewerControl.EnableAsideButton プロパティ

ViewerControlEnableAsideButton プロパティ

ツールバーの横に合わせるボタンを有効にするかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool EnableAsideButton { get; set; }
Public Property EnableAsideButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「横に合わせる」ボタンを有効にしない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "横に合わせる" ボタンを無効にします。
viewerControl1.EnableAsideButton = false;
' ツールバーの "横に合わせる" ボタンを無効にします。
ViewerControl1.EnableAsideButton = False
関連項目

参照

ViewerControl クラス


ViewerControl.EnableFirstButton プロパティ

ViewerControlEnableFirstButton プロパティ

ツールバーの最初のページボタンを有効にするかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool EnableFirstButton { get; set; }
Public Property EnableFirstButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「最初のページ」ボタンを有効にしない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "最初のページ" ボタンを無効にします。
viewerControl1.EnableFirstButton = false;
' ツールバーの "最初のページ" ボタンを無効にします。
ViewerControl1.EnableFirstButton = False
関連項目

参照

ViewerControl クラス


ViewerControl.EnableLastButton プロパティ

ViewerControlEnableLastButton プロパティ

ツールバーの最後のページボタンを有効にするかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool EnableLastButton { get; set; }
Public Property EnableLastButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「最後のページ」ボタンを有効にしない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "最後のページ" ボタンを無効にします。
viewerControl1.EnableLastButton = false;
' ツールバーの "最後のページ" ボタンを無効にします。
ViewerControl1.EnableLastButton = False
関連項目

参照

ViewerControl クラス


ViewerControl.EnableLengthwiseButton プロパティ

ViewerControlEnableLengthwiseButton プロパティ

ツールバーの縦に合わせるボタンを有効にするかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool EnableLengthwiseButton { get; set; }
Public Property EnableLengthwiseButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「縦に合わせる」ボタンを有効にしない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "縦に合わせる" ボタンを無効にします。
viewerControl1.EnableLengthwiseButton = false;
' ツールバーの "縦に合わせる" ボタンを無効にします。
ViewerControl1.EnableLengthwiseButton = False
関連項目

参照

ViewerControl クラス


ViewerControl.EnableNextButton プロパティ

ViewerControlEnableNextButton プロパティ

ツールバーの次ページボタンを有効にするかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool EnableNextButton { get; set; }
Public Property EnableNextButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「次ページ」ボタンを有効にしない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "次ページ" ボタンを無効にします。
viewerControl1.EnableNextButton = false;
' ツールバーの "次ページ" ボタンを無効にします。
ViewerControl1.EnableNextButton = False
関連項目

参照

ViewerControl クラス


ViewerControl.EnablePrevButton プロパティ

ViewerControlEnablePrevButton プロパティ

ツールバーの前ページボタンを有効にするかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool EnablePrevButton { get; set; }
Public Property EnablePrevButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「前ページ」ボタンを有効にしない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "前ページ" ボタンを無効にします。
viewerControl1.EnablePrevButton = false;
' ツールバーの "前ページ" ボタンを無効にします。
ViewerControl1.EnablePrevButton = False
関連項目

参照

ViewerControl クラス


ViewerControl.EnablePrintButton プロパティ

ViewerControlEnablePrintButton プロパティ

ツールバーの印刷ボタンを有効にするかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool EnablePrintButton { get; set; }
Public Property EnablePrintButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「印刷」ボタンを有効にしない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "印刷" ボタンを無効にします。
viewerControl1.EnablePrintButton = false;
' ツールバーの "印刷" ボタンを無効にします。
ViewerControl1.EnablePrintButton = False
関連項目

参照

ViewerControl クラス


ViewerControl.EnableSaveButton プロパティ

ViewerControlEnableSaveButton プロパティ

ツールバーの保存ボタンを有効にするかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool EnableSaveButton { get; set; }
Public Property EnableSaveButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「保存」ボタンを有効にしない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "保存" ボタンを無効にします。
viewerControl1.EnableSaveButton = false;
' ツールバーの "保存" ボタンを無効にします。
ViewerControl1.EnableSaveButton = False
関連項目

参照

ViewerControl クラス


ViewerControl.EnableZoomButton プロパティ

ViewerControlEnableZoomButton プロパティ

ツールバーの倍率ボタンを有効にするかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool EnableZoomButton { get; set; }
Public Property EnableZoomButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「倍率」ボタンを有効にしない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "倍率" ボタンを無効にします。
viewerControl1.EnableZoomButton = false;
' ツールバーの "倍率" ボタンを無効にします。
ViewerControl1.EnableZoomButton = False
関連項目

参照

ViewerControl クラス


ViewerControl.ErrorMessage プロパティ

ViewerControlErrorMessage プロパティ

エラーメッセージを取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string ErrorMessage { get; }
Public ReadOnly Property ErrorMessage As String
    Get

プロパティ値

型: String
エラーメッセージ(文字列)。
例
C#
VB
コピー
if (viewerControl1.ErrorNo != AdvanceSoftware.ASReport.ErrorNo.NoError)
{
    // エラーメッセージを表示します。
    MessageBox.Show(viewerControl1.ErrorMessage);
}
If ViewerControl1.ErrorNo <> AdvanceSoftware.ASReport.ErrorNo.NoError Then
    ' エラーメッセージを表示します。
    MessageBox.Show(ViewerControl1.ErrorMessage)
End If
関連項目

参照

ViewerControl クラス


ViewerControl.ErrorNo プロパティ

ViewerControlErrorNo プロパティ

エラーナンバーを取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo ErrorNo { get; }
Public ReadOnly Property ErrorNo As ErrorNo
    Get

プロパティ値

型: ErrorNo
エラーナンバーを表す ErrorNo。
例
C#
VB
コピー
if (viewerControl1.ErrorNo != AdvanceSoftware.ASReport.ErrorNo.NoError)
{
    // エラーメッセージを表示します。
    MessageBox.Show(viewerControl1.ErrorMessage);
}
If ViewerControl1.ErrorNo <> AdvanceSoftware.ASReport.ErrorNo.NoError Then
    ' エラーメッセージを表示します。
    MessageBox.Show(ViewerControl1.ErrorMessage)
End If
関連項目

参照

ViewerControl クラス


ViewerControl.InternalViewZoom プロパティ

ViewerControlInternalViewZoom プロパティ

表示する倍率を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int InternalViewZoom { get; }
Public ReadOnly Property InternalViewZoom As Integer
    Get

プロパティ値

型: Int32
プレビューの表示倍率。
例
C#
VB
コピー
// 表示する倍率を取得します。
int internalViewZoom = viewerControl1.InternalViewZoom;
' 表示する倍率を取得します。
Dim internalViewZoom As Integer = ViewerControl1.InternalViewZoom
関連項目

参照

ViewerControl クラス


ViewerControl.IsPdfSaved プロパティ

ViewerControlIsPdfSaved プロパティ

PDF ファイルに保存されたかどうかを取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool IsPdfSaved { get; }
Public ReadOnly Property IsPdfSaved As Boolean
    Get

プロパティ値

型: Boolean
PDF ファイルに保存された場合は true。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
viewerControl1.SavePdf(@"C:\out1.pdf");
// PDF ファイルに保存されたかどうかを取得します。
bool isPDFSaved = viewerControl1.IsPdfSaved;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
ViewerControl1.SavePdf("C:\out1.pdf")
' PDF ファイルに保存されたかどうかを取得します。
Dim isPDFSaved As Boolean = ViewerControl1.IsPdfSaved
関連項目

参照

ViewerControl クラス


ViewerControl.IsPrinted プロパティ

ViewerControlIsPrinted プロパティ

印刷されたかどうかを取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool IsPrinted { get; }
Public ReadOnly Property IsPrinted As Boolean
    Get

プロパティ値

型: Boolean
印刷された場合は true。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
viewerControl1.PrintOut();
// 印刷されたかどうかを取得します。
bool isPrinted = viewerControl1.IsPrinted;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
ViewerControl1.PrintOut()
' 印刷されたかどうかを取得します。
Dim isPrinted As Boolean = ViewerControl1.IsPrinted
関連項目

参照

ViewerControl クラス


ViewerControl.IsSaved プロパティ

ViewerControlIsSaved プロパティ

保存されたかどうかを取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool IsSaved { get; }
Public ReadOnly Property IsSaved As Boolean
    Get

プロパティ値

型: Boolean
保存された場合は true。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
viewerControl1.SaveAs(@"C:\out1.xlsx");
// 保存されたかどうかを取得します。
bool isSaved = viewerControl1.IsSaved;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
ViewerControl1.SaveAs("C:\out1.xlsx")
' 保存されたかどうかを取得します。
Dim isSaved As Boolean = ViewerControl1.IsSaved
関連項目

参照

ViewerControl クラス


ViewerControl.OverFit プロパティ

ViewerControlOverFit プロパティ

帳票を 1 ページに収まるよう表示するかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool OverFit { get; set; }
Public Property OverFit As Boolean
    Get
    Set

プロパティ値

型: Boolean
帳票を用紙内に収める場合は true。
解説
作成した帳票が設定の用紙からはみ出す場合、帳票を自動的に用紙内に収める設定をします。 デザインファイル作成時にページ設定を行ったプリンタと、VB-Report 12.0 for .NET で帳票出力するプリンタが異なる場合、 1 ページに収まっていた帳票が用紙を超える時があり、OverFit プロパティを true に設定することで、 用紙内に収まるよう自動補正して出力します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// 帳票を 1 ページに収めて表示します。
viewerControl1.OverFit = true;
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' 帳票を 1 ページに収めて表示します。
ViewerControl1.OverFit = True
ViewerControl1.Document = CellReport1.Document
関連項目

参照

ViewerControl クラス


ViewerControl.PageCount プロパティ

ViewerControlPageCount プロパティ

総ページ数を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int PageCount { get; }
Public ReadOnly Property PageCount As Integer
    Get

プロパティ値

型: Int32
作成された帳票のページ数
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1-99999");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
// 総ページ数を取得します。
int pageCount = viewerControl1.PageCount;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1-99999")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
' 総ページ数を取得します。
Dim pageCount As Integer = ViewerControl1.PageCount
関連項目

参照

ViewerControl クラス


ViewerControl.PrintButtonMode プロパティ

ViewerControlPrintButtonMode プロパティ

印刷ボタンの動作を設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PrintButtonMode PrintButtonMode { get; set; }
Public Property PrintButtonMode As PrintButtonMode
    Get
    Set

プロパティ値

型: PrintButtonMode
直接印刷は Print。印刷メニュー表示は Menu。印刷ダイアログ表示は Dialog。(既定値：Print)
例
C#
VB
コピー
// 印刷ボタン押下時の動作を "印刷ダイアログ表示" に設定します。
viewerControl1.PrintButtonMode = AdvanceSoftware.ASReport.PrintButtonMode.Dialog;
' 印刷ボタン押下時の動作を "印刷ダイアログ表示" に設定します。
ViewerControl1.PrintButtonMode = AdvanceSoftware.ASReport.PrintButtonMode.Dialog
関連項目

参照

ViewerControl クラス


ViewerControl.PrintDocumentName プロパティ

ViewerControlPrintDocumentName プロパティ

印刷のドキュメント名を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string PrintDocumentName { set; }
Public WriteOnly Property PrintDocumentName As String
    Set

プロパティ値

型: String
印刷時のドキュメント名。(既定値：VB-Report 12.0 for .NET) ※ExcelMode = false 時のみ有効となります。
例
C#
VB
コピー
// 印刷ドキュメント名を "PrintDocument1" に設定します。
viewerControl1.PrintDocumentName = "PrintDocument1";
' 印刷ドキュメント名を "PrintDocument1" に設定します。
ViewerControl1.PrintDocumentName = "PrintDocument1"
関連項目

参照

ViewerControl クラス


ViewerControl.Printer プロパティ

ViewerControlPrinter プロパティ

Printer を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Printer Printer { get; }
Public ReadOnly Property Printer As Printer
    Get

プロパティ値

型: Printer
出力先プリンタの情報を扱うための、Printer クラス。
解説
このクラスの全てのメンバの一覧については、Printer クラスのメンバを参照してください。
関連項目

参照

ViewerControl クラス


ViewerControl.PrinterName プロパティ

ViewerControlPrinterName プロパティ

現在選択されているプリンタ名を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string PrinterName { get; }
Public ReadOnly Property PrinterName As String
    Get

プロパティ値

型: String
現在選択されているプリンタ名。
例
C#
VB
コピー
// 現在選択されているプリンタ名を取得します。
string printerName = viewerControl1.PrinterName;
' 現在選択されているプリンタ名を取得します。
Dim printerName As String = ViewerControl1.PrinterName
関連項目

参照

ViewerControl クラス


ViewerControl.PrintType プロパティ

ViewerControlPrintType プロパティ

印刷タイプを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PrintType PrintType { get; set; }
Public Property PrintType As PrintType
    Get
    Set

プロパティ値

型: PrintType
印刷タイプを表す、PrintType。
例
C#
VB
コピー
// 印刷対象のページを現在のページに設定します。
viewerControl1.PrintType = AdvanceSoftware.ASReport.PrintType.Now;
' 印刷対象のページを現在のページに設定します。
ViewerControl1.PrintType = AdvanceSoftware.ASReport.PrintType.Now
関連項目

参照

ViewerControl クラス


ViewerControl.ProgressDescription プロパティ

ViewerControlProgressDescription プロパティ

プログレスダイアログのユーザーメッセージを設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string[] ProgressDescription { set; }
Public WriteOnly Property ProgressDescription As String()
    Set

プロパティ値

型: String
null:表示無し(規定値)、string[]:行毎のメッセージ(例) new string[]{"1行目","2行目"}
例
C#
VB
コピー
// プログレスダイアログのユーザーメッセージの 1 行目に "処理中" 、2 行目に "しばらくお待ち下さい" を設定します。
viewerControl1.ProgressDescription = new string[] { "処理中", "しばらくお待ち下さい" };
' プログレスダイアログのユーザーメッセージの 1 行目に "処理中" 、2 行目に "しばらくお待ち下さい" を設定します。
ViewerControl1.ProgressDescription = New String() { "処理中", "しばらくお待ち下さい" }
関連項目

参照

ViewerControl クラス


ViewerControl.SaveFileName プロパティ

ViewerControlSaveFileName プロパティ

保存時のデフォルトファイル名を設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string SaveFileName { get; set; }
Public Property SaveFileName As String
    Get
    Set

プロパティ値

型: String
ファイル保存時のデフォルトファイル名。
例
C#
VB
コピー
// 保存時のデフォルトファイル名を "out1" に設定します。
viewerControl1.SaveFileName = "out1";
' 保存時のデフォルトファイル名を "out1" に設定します。
ViewerControl1.SaveFileName = "out1"
関連項目

参照

ViewerControl クラス


ViewerControl.SaveKind プロパティ

ViewerControlSaveKind プロパティ

保存時のファイルの種類を設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public SaveKind SaveKind { get; set; }
Public Property SaveKind As SaveKind
    Get
    Set

プロパティ値

型: SaveKind
保存するファイルの種類を表す、SaveKind。
例
C#
VB
コピー
// ファイル保存ダイアログのファイルの種類を "PDF ファイルのみ" に設定します。
viewerControl1.SaveKind = AdvanceSoftware.ASReport.SaveKind.PdfOnly;
' ファイル保存ダイアログのファイルの種類を "PDF ファイルのみ" に設定します。
ViewerControl1.SaveKind = AdvanceSoftware.ASReport.SaveKind.PdfOnly
関連項目

参照

ViewerControl クラス


ViewerControl.SaveMessage プロパティ

ViewerControlSaveMessage プロパティ

保存処理終了後に表示するメッセージ文字列を設定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string SaveMessage { set; }
Public WriteOnly Property SaveMessage As String
    Set

プロパティ値

型: String
保存終了時に表示するメッセージ。
例
C#
VB
コピー
// 保存処理終了後に表示するメッセージ文字列を "保存が完了しました。" に設定します。
viewerControl1.SaveMessage = "保存が完了しました。";
' 保存処理終了後に表示するメッセージ文字列を "保存が完了しました。" に設定します。
ViewerControl1.SaveMessage = "保存が完了しました。"
関連項目

参照

ViewerControl クラス


ViewerControl.ShowAllButton プロパティ

ViewerControlShowAllButton プロパティ

ツールバーの全体を表示ボタンを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowAllButton { get; set; }
Public Property ShowAllButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「全体を表示」ボタンを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "全体を表示" ボタンを非表示にします。
viewerControl1.ShowAllButton = false;
' ツールバーの "全体を表示" ボタンを非表示にします。
ViewerControl1.ShowAllButton = False
関連項目

参照

ViewerControl クラス


ViewerControl.ShowAsideButton プロパティ

ViewerControlShowAsideButton プロパティ

ツールバーの横に合わせるボタンを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowAsideButton { get; set; }
Public Property ShowAsideButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「横に合わせる」ボタンを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "横に合わせる" ボタンを非表示にします。
viewerControl1.ShowAsideButton = false;
' ツールバーの "横に合わせる" ボタンを非表示にします。
ViewerControl1.ShowAsideButton = False
関連項目

参照

ViewerControl クラス


ViewerControl.ShowFirstButton プロパティ

ViewerControlShowFirstButton プロパティ

ツールバーの最初のページボタンを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowFirstButton { get; set; }
Public Property ShowFirstButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「最初のページ」ボタンを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "最初のページ" ボタンを非表示にします。
viewerControl1.ShowFirstButton = false;
' ツールバーの "最初のページ" ボタンを非表示にします。
ViewerControl1.ShowFirstButton = False
関連項目

参照

ViewerControl クラス


ViewerControl.ShowInvalidArea プロパティ

ViewerControlShowInvalidArea プロパティ

印字可能領域を表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowInvalidArea { get; set; }
Public Property ShowInvalidArea As Boolean
    Get
    Set

プロパティ値

型: Boolean
印字可能領域を表示する場合は true。(既定値：false)
例
C#
VB
コピー
// プレビュー画面に印字可能領域を表示します。
viewerControl1.ShowInvalidArea = true;
' プレビュー画面に印字可能領域を表示します。
ViewerControl1.ShowInvalidArea = True
関連項目

参照

ViewerControl クラス


ViewerControl.ShowLastButton プロパティ

ViewerControlShowLastButton プロパティ

ツールバーの最後のページボタンを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowLastButton { get; set; }
Public Property ShowLastButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「最後のページ」ボタンを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "最後のページ" ボタンを非表示にします。
viewerControl1.ShowLastButton = false;
' ツールバーの "最後のページ" ボタンを非表示にします。
ViewerControl1.ShowLastButton = False
関連項目

参照

ViewerControl クラス


ViewerControl.ShowLengthwiseButton プロパティ

ViewerControlShowLengthwiseButton プロパティ

ツールバーの縦に合わせるボタンを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowLengthwiseButton { get; set; }
Public Property ShowLengthwiseButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「縦に合わせる」ボタンを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "縦に合わせる" ボタンを非表示にします。
viewerControl1.ShowLengthwiseButton = false;
' ツールバーの "縦に合わせる" ボタンを非表示にします。
ViewerControl1.ShowLengthwiseButton = False
関連項目

参照

ViewerControl クラス


ViewerControl.ShowMarginArea プロパティ

ViewerControlShowMarginArea プロパティ

余白領域を表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowMarginArea { get; set; }
Public Property ShowMarginArea As Boolean
    Get
    Set

プロパティ値

型: Boolean
余白領域を表示する場合は true。(既定値：false)
例
C#
VB
コピー
// プレビュー画面に余白領域を表示します。
viewerControl1.ShowMarginArea = true;
' プレビュー画面に余白領域を表示します。
ViewerControl1.ShowMarginArea = True
関連項目

参照

ViewerControl クラス


ViewerControl.ShowNextButton プロパティ

ViewerControlShowNextButton プロパティ

ツールバーの次ページボタンを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowNextButton { get; set; }
Public Property ShowNextButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「次ページ」ボタンを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "次ページ" ボタンを非表示にします。
viewerControl1.ShowNextButton = false;
' ツールバーの "次ページ" ボタンを非表示にします。
ViewerControl1.ShowNextButton = False
関連項目

参照

ViewerControl クラス


ViewerControl.ShowPrevButton プロパティ

ViewerControlShowPrevButton プロパティ

ツールバーの前ページボタンを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowPrevButton { get; set; }
Public Property ShowPrevButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「前ページ」ボタンを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "前ページ" ボタンを非表示にします。
viewerControl1.ShowPrevButton = false;
' ツールバーの "前ページ" ボタンを非表示にします。
ViewerControl1.ShowPrevButton = False
関連項目

参照

ViewerControl クラス


ViewerControl.ShowPrintButton プロパティ

ViewerControlShowPrintButton プロパティ

ツールバーの印刷ボタンを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowPrintButton { get; set; }
Public Property ShowPrintButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「印刷」ボタンを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "印刷" ボタンを非表示にします。
viewerControl1.ShowPrintButton = false;
' ツールバーの "印刷" ボタンを非表示にします。
ViewerControl1.ShowPrintButton = False
関連項目

参照

ViewerControl クラス


ViewerControl.ShowPrintMenu プロパティ

ViewerControlShowPrintMenu プロパティ

ツールバーの印刷メニューを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowPrintMenu { get; set; }
Public Property ShowPrintMenu As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーにメニュー展開なしの「印刷」ボタンを表示する場合は false。(既定値：ture)
例
C#
VB
コピー
// ツールバーの "印刷" ボタンのメニューを非表示にします。
viewerControl1.ShowPrintMenu = false;
' ツールバーの "印刷" ボタンのメニューを非表示にします。
ViewerControl1.ShowPrintMenu = False
関連項目

参照

ViewerControl クラス


ViewerControl.ShowPrintMenuItem プロパティ

ViewerControlShowPrintMenuItem プロパティ

ツールバーの印刷ボタンのメニュー「印刷(P)」を表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowPrintMenuItem { get; set; }
Public Property ShowPrintMenuItem As Boolean
    Get
    Set

プロパティ値

型: Boolean
ツールバーの印刷ボタンのメニュー「印刷(P)」を表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "印刷" ボタンのメニュー項目 "印刷(P)" を非表示にします。
viewerControl1.ShowPrintMenuItem = false;
' ツールバーの "印刷" ボタンのメニュー項目 "印刷(P)" を非表示にします。
ViewerControl1.ShowPrintMenuItem = False
関連項目

参照

ViewerControl クラス


ViewerControl.ShowProgressDialog プロパティ

ViewerControlShowProgressDialog プロパティ

プログレスダイアログを表示する、しないを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowProgressDialog { get; set; }
Public Property ShowProgressDialog As Boolean
    Get
    Set

プロパティ値

型: Boolean
プログレスダイアログを表示する場合は true。(既定値：true)
解説
VB-Report 12.0 for .NET で帳票出力時に表示されるプログレスダイアログを非表示にする場合、false に設定します。 また、false に設定した場合、Progress イベントで処理の進行状況を通知することができます。 なお、ExcelMode プロパティに true を設定した場合、帳票の出力時に上記のプログレスダイアログとは別の、 Excel の処理経過を示すプログレスダイアログを表示します。 Excel の処理経過を示すプログレスダイアログは、ShowProgressDialog プロパティで非表示にすること はできません。
例
C#
VB
コピー
// 帳票出力時のプログレスダイアログを非表示にします。
viewerControl1.ShowProgressDialog = false;
' 帳票出力時のプログレスダイアログを非表示にします。
ViewerControl1.ShowProgressDialog = False
関連項目

参照

ViewerControl クラス


ViewerControl.ShowReportFrame プロパティ

ViewerControlShowReportFrame プロパティ

帳票の枠組み(罫線、背景色)を表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ReportFrame ShowReportFrame { get; set; }
Public Property ShowReportFrame As ReportFrame
    Get
    Set

プロパティ値

型: ReportFrame
帳票の枠組み(罫線、背景色)をプレビュー・印刷するかを指定する ReportFrame。
例
C#
VB
コピー
// プレビュー時のみ帳票の枠組みを表示します。
viewerControl1.ShowReportFrame = AdvanceSoftware.ASReport.ReportFrame.Preview;
' プレビュー時のみ帳票の枠組みを表示します。
ViewerControl1.ShowReportFrame = AdvanceSoftware.ASReport.ReportFrame.Preview
関連項目

参照

ViewerControl クラス


ViewerControl.ShowSaveButton プロパティ

ViewerControlShowSaveButton プロパティ

ツールバーの保存ボタンを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowSaveButton { get; set; }
Public Property ShowSaveButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「保存」ボタンを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "保存" ボタンを非表示にします。
viewerControl1.ShowSaveButton = false;
' ツールバーの "保存" ボタンを非表示にします。
ViewerControl1.ShowSaveButton = False
関連項目

参照

ViewerControl クラス


ViewerControl.ShowSetPrinterMenuItem プロパティ

ViewerControlShowSetPrinterMenuItem プロパティ

ツールバーの印刷ボタンのメニュー「プリンタの設定(S)」を表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowSetPrinterMenuItem { get; set; }
Public Property ShowSetPrinterMenuItem As Boolean
    Get
    Set

プロパティ値

型: Boolean
ツールバーの印刷ボタンのメニュー「プリンタの設定(S)」を表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "印刷" ボタンのメニュー項目 "プリンタの設定(S)" を非表示にします。
viewerControl1.ShowSetPrinterMenuItem = false;
' ツールバーの "印刷" ボタンのメニュー項目 "プリンタの設定(S)" を非表示にします。
ViewerControl1.ShowSetPrinterMenuItem = False
関連項目

参照

ViewerControl クラス


ViewerControl.ShowSheetName プロパティ

ViewerControlShowSheetName プロパティ

ステータスバーのシート名を表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowSheetName { get; set; }
Public Property ShowSheetName As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ステータスバーのシート名を表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ステータスバーのシート名を非表示にします。
viewerControl1.ShowSheetName = false;
' ステータスバーのシート名を非表示にします。
ViewerControl1.ShowSheetName = False
関連項目

参照

ViewerControl クラス


ViewerControl.ShowStatusBar プロパティ

ViewerControlShowStatusBar プロパティ

ステータスバーを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowStatusBar { get; set; }
Public Property ShowStatusBar As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ステータスバーを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ステータスバーを非表示にします。
viewerControl1.ShowStatusBar = false;
' ステータスバーを非表示にします。
ViewerControl1.ShowStatusBar = False
関連項目

参照

ViewerControl クラス


ViewerControl.ShowToolBar プロパティ

ViewerControlShowToolBar プロパティ

ツールバーを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowToolBar { get; set; }
Public Property ShowToolBar As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーを非表示にします。
viewerControl1.ShowToolBar = false;
' ツールバーを非表示にします。
ViewerControl1.ShowToolBar = False
関連項目

参照

ViewerControl クラス


ViewerControl.ShowUseExcelPrint プロパティ

ViewerControlShowUseExcelPrint プロパティ

印刷ダイアログの「Excel を使用して印刷する」チェックボックスを表示する、しないを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowUseExcelPrint { get; set; }
Public Property ShowUseExcelPrint As Boolean
    Get
    Set

プロパティ値

型: Boolean
印刷ダイアログの「Excel を使用して印刷する」チェックボックスを表示する場合は true。(既定値：false)
例
C#
VB
コピー
// 印刷ダイアログの "Excel を使用して印刷する" チェックボックスを表示します。
viewerControl1.ShowUseExcelPrint = true;
' 印刷ダイアログの "Excel を使用して印刷する" チェックボックスを表示します。
ViewerControl1.ShowUseExcelPrint = True
関連項目

参照

ViewerControl クラス


ViewerControl.ShowZoomButton プロパティ

ViewerControlShowZoomButton プロパティ

ツールバーの倍率ボタンを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowZoomButton { get; set; }
Public Property ShowZoomButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「倍率」ボタンを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "倍率" ボタンを非表示にします。
viewerControl1.ShowZoomButton = false;
' ツールバーの "倍率" ボタンを非表示にします。
ViewerControl1.ShowZoomButton = False
関連項目

参照

ViewerControl クラス


ViewerControl.SizingGrip プロパティ

ViewerControlSizingGrip プロパティ

ステータスバーにサイズ変更ハンドルを付けるかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool SizingGrip { get; set; }
Public Property SizingGrip As Boolean
    Get
    Set

プロパティ値

型: Boolean
ステータスバーにサイズ変更ハンドルを付けない場合は false。(既定値：true)
例
C#
VB
コピー
// ステータスバーのサイズ変更ハンドルを非表示にします。
viewerControl1.SizingGrip = false;
' ステータスバーのサイズ変更ハンドルを非表示にします。
ViewerControl1.SizingGrip = False
関連項目

参照

ViewerControl クラス


ViewerControl.ToolBarIcon プロパティ

ViewerControlToolBarIcon プロパティ

ツールバーのアイコンのサイズを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ToolBarIcon ToolBarIcon { get; set; }
Public Property ToolBarIcon As ToolBarIcon
    Get
    Set

プロパティ値

型: ToolBarIcon
ツールバーのアイコンのサイズを表す、ToolBarIcon
例
C#
VB
コピー
// ツールバーのアイコンのサイズを "小" に設定します。
viewerControl1.ToolBarIcon = AdvanceSoftware.ASReport.ToolBarIcon.SmallIcon;
' ツールバーのアイコンのサイズを "小" に設定します。
ViewerControl1.ToolBarIcon = AdvanceSoftware.ASReport.ToolBarIcon.SmallIcon
関連項目

参照

ViewerControl クラス


ViewerControl.ToolBarIconType プロパティ

ViewerControlToolBarIconType プロパティ

ツールバーのアイコンのタイプを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ToolBarIconType ToolBarIconType { get; set; }
Public Property ToolBarIconType As ToolBarIconType
    Get
    Set

プロパティ値

型: ToolBarIconType
ツールバーのアイコンのタイプを表す、ToolBarIconType
例
C#
VB
コピー
// ツールバーのアイコンのタイプを "2" に設定します。
viewerControl1.ToolBarIconType = AdvanceSoftware.ASReport.ToolBarIconType.Type2;
' ツールバーのアイコンのタイプを "2" に設定します。
ViewerControl1.ToolBarIconType = AdvanceSoftware.ASReport.ToolBarIconType.Type2
関連項目

参照

ViewerControl クラス


ViewerControl.ViewerStatus プロパティ

ViewerControlViewerStatus プロパティ

ビューアコントロールのステータス(待機、動作中)を取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ViewerStatus ViewerStatus { get; }
Public ReadOnly Property ViewerStatus As ViewerStatus
    Get

プロパティ値

型: ViewerStatus
Idling:待機、Running:レポート処理中、Saving:保存中、Printing:印刷中
例
C#
VB
コピー
// ビューアコントロールのステータスを取得します。
AdvanceSoftware.ASReport.ViewerStatus viewerStatus = viewerControl1.ViewerStatus;
' ビューアコントロールのステータスを取得します。
Dim viewerStatus As AdvanceSoftware.ASReport.ViewerStatus = ViewerControl1.ViewerStatus
関連項目

参照

ViewerControl クラス


ViewerControl.ViewPage プロパティ

ViewerControlViewPage プロパティ

表示するページを設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int ViewPage { get; set; }
Public Property ViewPage As Integer
    Get
    Set

プロパティ値

型: Int32
プレビュー表示するページ番号。(既定値：1)
例
C#
VB
コピー
// プレビュー表示するページを 2 ページ目に設定します。
viewerControl1.ViewPage = 2;
' プレビュー表示するページを 2 ページ目に設定します。
ViewerControl1.ViewPage = 2
関連項目

参照

ViewerControl クラス


ViewerControl.ViewZoom プロパティ

ViewerControlViewZoom プロパティ

表示する倍率を設定、取得します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int ViewZoom { get; set; }
Public Property ViewZoom As Integer
    Get
    Set

プロパティ値

型: Int32
プレビューの表示倍率。(既定値：100)
解説
設定可能な値 : 20% ～ 600%、-1(全体を表示する)、-2(横に合わせる)、-3(縦に合わせる)
例
C#
VB
コピー
// プレビューの表示倍率を "120%" に設定します。
viewerControl1.ViewZoom = 120;
' プレビューの表示倍率を "120%" に設定します。
ViewerControl1.ViewZoom = 120
関連項目

参照

ViewerControl クラス


ViewerControl メソッド

ViewerControl 型は下記のメンバーを公開します。

メソッド
名前 | 説明
Clear | 帳票表示をクリアします。
Clear(ViewerClearMode) | 帳票表示をクリアします。(ViewerClearMode)
PrintOut | 印刷します。
PrintOut(String) | 印刷します。
PrintOut(String, String) | 印刷します。
PrintOut(String, String, Int16) | 印刷します。
SaveAs(String) | Excel ファイルに保存します。
SaveAs(String, ExcelVersion) | Excel ファイルに保存します。
SavePdf(Stream) | PDF ファイルに保存します。
SavePdf(String) | PDF ファイルに保存します。
SetPrinter | プリンタの設定をします。
トップ
関連項目

参照

ViewerControl クラス


ViewerControl.Clear メソッド

ViewerControlClear メソッド

オーバーロードの一覧
名前 | 説明
Clear | 帳票表示をクリアします。
Clear(ViewerClearMode) | 帳票表示をクリアします。(ViewerClearMode)
トップ
関連項目

参照

ViewerControl クラス


ViewerControl.Clear メソッド

ViewerControlClear メソッド

帳票表示をクリアします。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Clear()
Public Sub Clear
例
C#
VB
コピー
// 帳票表示をクリアします。
viewerControl1.Clear();
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
' 帳票表示をクリアします。
ViewerControl1.Clear()
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
関連項目

参照

ViewerControl クラス
Clear オーバーロード


ViewerControl.Clear メソッド (ViewerClearMode)

ViewerControlClear メソッド (ViewerClearMode)

帳票表示をクリアします。(ViewerClearMode)

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Clear(
    ViewerClearMode mode
)
Public Sub Clear (
    mode As ViewerClearMode
)

パラメーター

mode
型: AdvanceSoftware.ASReportViewerClearMode
クリアモードを示す識別子を指定します。
例
C#
VB
コピー
// ドキュメントのみをクリアします。
viewerControl1.Clear(AdvanceSoftware.ASReport.ViewerClearMode.Document);
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
' ドキュメントのみをクリアします。
ViewerControl1.Clear(AdvanceSoftware.ASReport.ViewerClearMode.Document)
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
関連項目

参照

ViewerControl クラス
Clear オーバーロード


ViewerControl.PrintOut メソッド

ViewerControlPrintOut メソッド

オーバーロードの一覧
名前 | 説明
PrintOut | 印刷します。
PrintOut(String) | 印刷します。
PrintOut(String, String) | 印刷します。
PrintOut(String, String, Int16) | 印刷します。
トップ
関連項目

参照

ViewerControl クラス


ViewerControl.PrintOut メソッド

ViewerControlPrintOut メソッド

印刷します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo PrintOut()
Public Function PrintOut As ErrorNo

戻り値

型: ErrorNo
エラーナンバーを返します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
// 印刷を行います。
viewerControl1.PrintOut();
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
' 印刷を行います。
ViewerControl1.PrintOut()
関連項目

参照

ViewerControl クラス
PrintOut オーバーロード


ViewerControl.PrintOut メソッド (String)

ViewerControlPrintOut メソッド (String)

印刷します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo PrintOut(
    string documentName
)
Public Function PrintOut (
    documentName As String
) As ErrorNo

パラメーター

documentName
型: SystemString
ドキュメント名を指定します。※ExcelMode = false 時のみドキュメント名を指定できます。

戻り値

型: ErrorNo
エラーナンバーを返します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
// 印刷ドキュメント名を "PrintDocument1" に設定して印刷を行います。
viewerControl1.PrintOut("PrintDocument1");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
' 印刷ドキュメント名を "PrintDocument1" に設定して印刷を行います。
ViewerControl1.PrintOut("PrintDocument1")
関連項目

参照

ViewerControl クラス
PrintOut オーバーロード


ViewerControl.PrintOut メソッド (String, String)

ViewerControlPrintOut メソッド (String, String)

印刷します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo PrintOut(
    string documentName,
    string pageInfo
)
Public Function PrintOut (
    documentName As String,
    pageInfo As String
) As ErrorNo

パラメーター

documentName
型: SystemString
ドキュメント名を指定します。※ExcelMode = false 時のみドキュメント名を指定できます。
pageInfo
型: SystemString
印刷するページを指定します。

戻り値

型: ErrorNo
エラーナンバーを返します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1-99999");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
// 印刷ドキュメント名を "PrintDocument1" に設定して 2 ページ目の印刷を行います。
viewerControl1.PrintOut("PrintDocument1", "2");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1-99999")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
' 印刷ドキュメント名を "PrintDocument1" に設定して 2 ページ目の印刷を行います。
ViewerControl1.PrintOut("PrintDocument1", "2")
関連項目

参照

ViewerControl クラス
PrintOut オーバーロード


ViewerControl.PrintOut メソッド (String, String, Int16)

ViewerControlPrintOut メソッド (String, String, Int16)

印刷します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo PrintOut(
    string documentName,
    string pageInfo,
    short printCopies
)
Public Function PrintOut (
    documentName As String,
    pageInfo As String,
    printCopies As Short
) As ErrorNo

パラメーター

documentName
型: SystemString
ドキュメント名を指定します。※ExcelMode = false 時のみドキュメント名を指定できます。
pageInfo
型: SystemString
印刷するページを指定します。
printCopies
型: SystemInt16
印刷部数を指定します。

戻り値

型: ErrorNo
エラーナンバーを返します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1-99999");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
// 印刷ドキュメント名を "PrintDocument1" に設定して 2 ページ目を 3 部印刷します。
viewerControl1.PrintOut("PrintDocument1", "2", 3);
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1-99999")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
' 印刷ドキュメント名を "PrintDocument1" に設定して 2 ページ目を 3 部印刷します。
ViewerControl1.PrintOut("PrintDocument1", "2", 3)
関連項目

参照

ViewerControl クラス
PrintOut オーバーロード


ViewerControl.SaveAs メソッド

ViewerControlSaveAs メソッド

オーバーロードの一覧
名前 | 説明
SaveAs(String) | Excel ファイルに保存します。
SaveAs(String, ExcelVersion) | Excel ファイルに保存します。
トップ
関連項目

参照

ViewerControl クラス


ViewerControl.SaveAs メソッド (String)

ViewerControlSaveAs メソッド (String)

Excel ファイルに保存します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo SaveAs(
    string fileName
)
Public Function SaveAs (
    fileName As String
) As ErrorNo

パラメーター

fileName
型: SystemString
ファイル名を指定します。

戻り値

型: ErrorNo
エラーナンバーを返します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
// Excel ファイルを "C:\out1.xlsx" に保存します。
viewerControl1.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
' Excel ファイルを "C:\out1.xlsx" に保存します。
ViewerControl1.SaveAs("C:\out1.xlsx")
関連項目

参照

ViewerControl クラス
SaveAs オーバーロード


ViewerControl.SaveAs メソッド (String, ExcelVersion)

ViewerControlSaveAs メソッド (String, ExcelVersion)

Excel ファイルに保存します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo SaveAs(
    string fileName,
    ExcelVersion version
)
Public Function SaveAs (
    fileName As String,
    version As ExcelVersion
) As ErrorNo

パラメーター

fileName
型: SystemString
ファイル名を指定します。
version
型: AdvanceSoftware.ASReportExcelVersion
バージョンを指定します。

戻り値

型: ErrorNo
エラーナンバーを返します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
// Excel 2019 の形式で Excel ファイルを "C:\out1.xlsx" に保存します。
viewerControl1.SaveAs(@"C:\out1.xlsx", AdvanceSoftware.ASReport.ExcelVersion.ver2019);
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
' Excel 2019 の形式で Excel ファイルを "C:\out1.xlsx" に保存します。
ViewerControl1.SaveAs("C:\out1.xlsx", AdvanceSoftware.ASReport.ExcelVersion.ver2019)
関連項目

参照

ViewerControl クラス
SaveAs オーバーロード


ViewerControl.SavePdf メソッド

ViewerControlSavePdf メソッド

オーバーロードの一覧
名前 | 説明
SavePdf(Stream) | PDF ファイルに保存します。
SavePdf(String) | PDF ファイルに保存します。
トップ
関連項目

参照

ViewerControl クラス


ViewerControl.SavePdf メソッド (Stream)

ViewerControlSavePdf メソッド (Stream)

PDF ファイルに保存します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo SavePdf(
    Stream fileStream
)
Public Function SavePdf (
    fileStream As Stream
) As ErrorNo

パラメーター

fileStream
型: System.IOStream
Stream を指定します。

戻り値

型: ErrorNo
エラーナンバーを返します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
System.IO.MemoryStream memoryStream = new System.IO.MemoryStream();
// PDF ファイルをストリームに出力します。
viewerControl1.SavePdf(memoryStream);
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
Dim memoryStream As System.IO.MemoryStream = New System.IO.MemoryStream()
' PDF ファイルをストリームに出力します。
ViewerControl1.SavePdf(memoryStream)
関連項目

参照

ViewerControl クラス
SavePdf オーバーロード


ViewerControl.SavePdf メソッド (String)

ViewerControlSavePdf メソッド (String)

PDF ファイルに保存します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo SavePdf(
    string fileName
)
Public Function SavePdf (
    fileName As String
) As ErrorNo

パラメーター

fileName
型: SystemString
ファイル名を指定します。

戻り値

型: ErrorNo
エラーナンバーを返します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
// PDF ファイルを "C:\out1.pdf" に保存します。
viewerControl1.SavePdf(@"C:\out1.pdf");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
' PDF ファイルを "C:\out1.pdf" に保存します。
ViewerControl1.SavePdf("C:\out1.pdf")
関連項目

参照

ViewerControl クラス
SavePdf オーバーロード


ViewerControl.SetPrinter メソッド

ViewerControlSetPrinter メソッド

プリンタの設定をします。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool SetPrinter(
    bool dialogMode,
    string setPrinterName
)
Public Function SetPrinter (
    dialogMode As Boolean,
    setPrinterName As String
) As Boolean

パラメーター

dialogMode
型: SystemBoolean
プリンタの設定ダイアログを表示するかを指定します。
setPrinterName
型: SystemString
プリンタ名を指定します。

戻り値

型: Boolean
正しく設定が行われた場合 true を返します。
解説
プリンタの設定ダイアログを表示することができます。 プリンタの設定ダイアログを表示した場合、ExcelMode プロパティが false の時、 プリンタの設定ダイアログで設定した給紙方法、印刷部数を帳票出力に適用することができます。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// プリンタの設定ダイアログを表示せずに使用するプリンタを "Microsoft XPS Document Writer" に設定します。
viewerControl1.SetPrinter(false, "Microsoft XPS Document Writer");
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' プリンタの設定ダイアログを表示せずに使用するプリンタを "Microsoft XPS Document Writer" に設定します。
ViewerControl1.SetPrinter(False, "Microsoft XPS Document Writer")
ViewerControl1.Document = CellReport1.Document
関連項目

参照

ViewerControl クラス


ViewerControl イベント

ViewerControl 型は下記のメンバーを公開します。

イベント
名前 | 説明
Error | エラーイベント
Progress | プログレスイベント
トップ
関連項目

参照

ViewerControl クラス


ViewerControl.Error イベント

ViewerControlError イベント

エラーイベント

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public event ReportErrorEventHandler Error
Public Event Error As ReportErrorEventHandler

値

型: AdvanceSoftware.ASReportReportErrorEventHandler
解説
エラー発生時のエラー番号を取得する場合は、ReportErrorEventArgs の ErrorNo プロパティを参照します。 また、ErrorNo プロパティは、ErrorNo 列挙体の値を返します。
例
C#
VB
コピー
private void InitializeComponent()
{
    viewerControl1.Error += new AdvanceSoftware.ASReport.ReportErrorEventHandler(viewerControl1_Error);
}
void viewerControl1_Error(object sender, AdvanceSoftware.ASReport.ReportErrorEventArgs e)
{
    // エラーナンバーを表示します。
    MessageBox.Show(e.ErrorNo.ToString());
}
Private Sub ViewerControl1_Error(ByVal sender As Object, ByVal e As AdvanceSoftware.ASReport.ReportErrorEventArgs) Handles ViewerControl1.Error
    ' エラーナンバーを表示します。
    MessageBox.Show(e.ErrorNo.ToString())
End Sub
関連項目

参照

ViewerControl クラス


ViewerControl.Progress イベント

ViewerControlProgress イベント

プログレスイベント

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public event ReportProgressEventHandler Progress
Public Event Progress As ReportProgressEventHandler

値

型: AdvanceSoftware.ASReportReportProgressEventHandler
解説
ShowProgressDialog プロパティで 表示しない(false)を設定した場合、このイベントが発生します。 ユーザー独自の処理進行状況の表示を行う場合に、このイベントで制御を行います。 現在の処理状況を取得する場合は、ReportProgressEventArgs の各プロパティを参照します。
例
C#
VB
コピー
private void InitializeComponent()
{
    viewerControl1.Progress += new AdvanceSoftware.ASReport.ReportProgressEventHandler(viewerControl1_Progress);
}
void viewerControl1_Progress(object sender, AdvanceSoftware.ASReport.ReportProgressEventArgs e)
{
    // 現在のページ数を表示します。
    MessageBox.Show(e.Count.ToString());
}
Private Sub ViewerControl1_Progress(ByVal sender As Object, ByVal e As AdvanceSoftware.ASReport.ReportProgressEventArgs) Handles ViewerControl1.Progress
    ' 現在のページ数を表示します。
    MessageBox.Show(e.Count.ToString())
End Sub
関連項目

参照

ViewerControl クラス


ViewerStatus 列挙体

ビューアの状態を示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Viewer (in AdvanceSoftware.ASReport.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ViewerStatus
Public Enumeration ViewerStatus
メンバー
メンバー | 値 | 説明
Idling | 0 | 待機中
Running | 1 | レポート処理中
Printing | 2 | 印刷中
Saving | 3 | 保存中
関連項目

参照


ViewZoom 列挙体

ビューズームを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ViewZoom
Public Enumeration ViewZoom
メンバー
メンバー | 値 | 説明
PageFit | -1 | 全体の表示
WidthFit | -2 | 横に合わせる
HeightFit | -3 | 縦に合わせる
関連項目

参照


xlColor 列挙体

カラーを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum xlColor
Public Enumeration xlColor
メンバー
メンバー | 値 | 説明
Auto | 0x70000000 | 自動
Black | 0x70000008 | 黒
White | 0x70000009 | 白
Red | 0x7000000A | 赤
Green | 0x7000000B | 緑
Blue | 0x7000000C | 青
Yellow | 0x7000000D | 黄
Pink | 0x7000000E | ピンク
Cyan | 0x7000000F | 水色
DarkRed | 0x70000010 | 濃い赤
DarkGreen | 0x70000011 | 濃い緑
DarkBlue | 0x70000012 | 濃い青
DarkYellow | 0x70000013 | 濃い黄
Purple | 0x70000014 | 紫
BlueGreen | 0x70000015 | 青緑
Gray25 | 0x70000016 | 25% 灰色
Gray50 | 0x70000017 | 50% 灰色
Gray | 0x70000018 | グレー
Plum | 0x70000019 | プラム
Ivory | 0x7000001A | アイボリー
LightBlue | 0x7000001B | 薄い水色
DarkPurple | 0x7000001C | 濃い紫
Coral | 0x7000001D | コーラル
OceanBlue | 0x7000001E | オーシャンブルー
IceBlue | 0x7000001F | アイスブルー
DarkBlue2 | 0x70000020 | 濃い青2
Pink2 | 0x70000021 | ピンク2
Yellow2 | 0x70000022 | 黄2
Cyan2 | 0x70000023 | 水色2
Purple2 | 0x70000024 | 紫2
DarkRed2 | 0x70000025 | 濃い赤2
BlueGreen2 | 0x70000026 | 青緑2
Blue2 | 0x70000027 | 青2
SkyBlue | 0x70000028 | スカイブルー
LightCyan2 | 0x70000029 | 薄い水色2
LightGreen | 0x7000002A | 薄い緑
LightYellow | 0x7000002B | 薄い黄
VeilBlue | 0x7000002C | ベールブルー
Rose | 0x7000002D | ローズ
Lavender | 0x7000002E | ラベンダー
Beige | 0x7000002F | ベージュ
LightBlue2 | 0x70000030 | 薄い青2
AquaBlue | 0x70000031 | アクア
Lime | 0x70000032 | ライム
Gold | 0x70000033 | ゴールド
LightOrange | 0x70000034 | 薄いオレンジ
Orange | 0x70000035 | オレンジ
BlueGrey | 0x70000036 | ブルーグレー
Gray40 | 0x70000037 | 40% 灰色
DarkBlueGreen | 0x70000038 | 濃い青緑
SeaGreen | 0x70000039 | シーグリーン
DarkGreen2 | 0x7000003A | 濃い緑2
Olive | 0x7000003B | オリーブ
Brown | 0x7000003C | 茶
Plum2 | 0x7000003D | プラム2
Indigo | 0x7000003E | インディゴ
Gray80 | 0x7000003F | 80% 灰色
関連項目

参照


xlsShapeType 列挙体

シェイプタイプ(Xls)を示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum xlsShapeType
Public Enumeration xlsShapeType
メンバー
メンバー | 値 | 説明
Line | 322 | 直線, 矢印
Quadrangle | 18 | 四角形
Parallelogram | 114 | 平行四辺形
Trapezoid | 130 | 台形
Rhombic | 66 | ひし形
CornerQuadrangle | 34 | 角丸四角形
Octagon | 162 | 八角形
IsoscelesTriangle | 82 | 二等辺三角形
RightTriangle | 98 | 直角三角形
Ellipse | 50 | 楕円
Hexagon | 146 | 六角形
CrissCross | 178 | 十字形
Pentagonal | 898 | 五角形
Cylinder | 354 | 円柱
Rectangular | 258 | 直方体
PictureFrame | 1346 | 額縁
Memo | 1042 | メモ
Brackets | 2962 | 大括弧
CurlyBrace | 2978 | 中括弧
Broach | 338 | ブローチ
LeftBrackets | 1362 | 左大括弧
RightBrackets | 1378 | 右大括弧
関連項目

参照


xlsVersion 列挙体

Excel ファイル(Xls 形式)のバージョンを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum xlsVersion
Public Enumeration xlsVersion
メンバー
メンバー | 値 | 説明
ver2003 | 2003 | Excel 2003 の形式で作成します。
関連項目

参照


xlsxShapeType 列挙体

シェイプタイプ(Xlsx)を示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum xlsxShapeType
Public Enumeration xlsxShapeType
メンバー
メンバー | 値 | 説明
Line | 1 | 直線
LineInv | 2 | LineInv
Triangle | 3 | 二等辺三角形
RtTriangle | 4 | 直角三角形
Rect | 5 | 正方形,長方形
Diamond | 6 | ひし形
Parallelogram | 7 | 平行四辺形
Trapezoid | 8 | 台形
NonIsoscelesTrapezoid | 9 | NonIsoscelesTrapezoid
Pentagon | 10 | 五角形
Hexagon | 11 | 六角形
Heptagon | 12 | 七角形
Octagon | 13 | 八角形
Decagon | 14 | 十角形
Dodecagon | 15 | 十二角形
Star4 | 16 | 星 4
Star5 | 17 | 星 5
Star6 | 18 | 星 6
Star7 | 19 | 星 7
Star8 | 20 | 星 8
Star10 | 21 | 星 10
Star12 | 22 | 星 12
Star16 | 23 | 星 16
Star24 | 24 | 星 24
Star32 | 25 | 星 32
RoundRect | 26 | 角丸四角形
Round1Rect | 27 | 1 つの角を丸めた四角形
Round2SameRect | 28 | 片側の 2 つの角を丸めた四角形
Round2DiagRect | 29 | 対角する 2 つの角を丸めた四角形
SnipRoundRect | 30 | 1 つの角を丸めた四角形
Snip1Rect | 31 | 1 つの角を切り取った四角形
Snip2SameRect | 32 | 片側の 2 つの角を切り取った四角形
Snip2DiagRect | 33 | 対角する 2 つの角を切り取った四角形
Plaque | 34 | ブローチ
Ellipse | 35 | 円,楕円
Teardrop | 36 | 涙形
HomePlate | 37 | ホームベース
Chevron | 38 | 山形
PieWedge | 39 | PieWedge
Pie | 40 | パイ
BlockArc | 41 | アーチ
Donut | 42 | ドーナツ
NoSmoking | 43 | 禁止
RightArrow | 44 | 右矢印
LeftArrow | 45 | 左矢印
UpArrow | 46 | 上矢印
DownArrow | 47 | 下矢印
StripedRightArrow | 48 | ストライプ矢印
NotchedRightArrow | 49 | V 字形矢印
BentUpArrow | 50 | 屈折矢印
LeftRightArrow | 51 | 左右矢印
UpDownArrow | 52 | 上下矢印
LeftUpArrow | 53 | 二方向矢印
LeftRightUpArrow | 54 | 三方向矢印
QuadArrow | 55 | 四方向矢印
LeftArrowCallout | 56 | 左矢印吹き出し
RightArrowCallout | 57 | 右矢印吹き出し
UpArrowCallout | 58 | 上矢印吹き出し
DownArrowCallout | 56 | 下矢印吹き出し
LeftRightArrowCallout | 60 | 左右矢印吹き出し
UpDownArrowCallout | 61 | 上下ブロック矢印付吹き出し
QuadArrowCallout | 62 | 四方向矢印吹き出し
BentArrow | 63 | 曲折矢印
UturnArrow | 64 | U ターン矢印
CircularArrow | 65 | 環状矢印
LeftCircularArrow | 66 | LeftCircularArrow
LeftRightCircularArrow | 67 | LeftRightCircularArrow
CurvedRightArrow | 68 | 右カーブ矢印
CurvedLeftArrow | 69 | 左カーブ矢印
CurvedUpArrow | 70 | 上カーブ矢印
CurvedDownArrow | 71 | 下カーブ矢印
SwooshArrow | 72 | SwooshArrow
Cube | 73 | 直方体
Can | 74 | 円柱
LightningBolt | 75 | 稲妻
Heart | 76 | ハート
Sun | 77 | 太陽
Moon | 78 | 月
SmileyFace | 79 | スマイル
IrregularSeal1 | 80 | 爆発 1
IrregularSeal2 | 81 | 爆発 2
FoldedCorner | 82 | メモ
Bevel | 83 | 額縁
Frame | 84 | フレーム
HalfFrame | 85 | ハーフフレーム
Corner | 86 | L 字
DiagStripe | 87 | 斜め縞
Chord | 88 | 弦
Arc | 89 | 円弧
LeftBracket | 90 | 左大かっこ
RightBracket | 91 | 右大かっこ
LeftBrace | 92 | 左中かっこ
RightBrace | 93 | 右中かっこ
BracketPair | 94 | 大かっこ
BracePair | 95 | 中かっこ
StraightConnector1 | 96 | 直線矢印コネクタ
BentConnector2 | 97 | カギ線コネクタ 2
BentConnector3 | 98 | カギ線コネクタ 3
BentConnector4 | 99 | カギ線コネクタ 4
BentConnector5 | 100 | カギ線コネクタ 5
CurvedConnector2 | 101 | 曲線コネクタ 2
CurvedConnector3 | 102 | 曲線コネクタ 3
CurvedConnector4 | 103 | 曲線コネクタ 4
CurvedConnector5 | 104 | 曲線コネクタ 5
Callout1 | 105 | 線吹き出し 1
Callout2 | 106 | 線吹き出し 2
Callout3 | 107 | 線吹き出し 3
AccentCallout1 | 108 | 強調線吹き出し 1
AccentCallout2 | 109 | 強調線吹き出し 2
AccentCallout3 | 110 | 強調線吹き出し 3
BorderCallout1 | 111 | 枠付き線吹き出し 1
BorderCallout2 | 112 | 枠付き線吹き出し 2
BorderCallout3 | 113 | 枠付き線吹き出し 3
AccentBorderCallout1 | 114 | 枠付き強調線吹き出し 1
AccentBorderCallout2 | 115 | 枠付き強調線吹き出し 2
AccentBorderCallout3 | 116 | 枠付き強調線吹き出し 3
WedgeRectCallout | 117 | 四角形吹き出し
WedgeRoundRectCallout | 118 | 角丸四角形吹き出し
WedgeEllipseCallout | 119 | 円形吹き出し
CloudCallout | 120 | 雲形吹き出し
Cloud | 121 | 雲
Ribbon | 122 | 下リボン
Ribbon2 | 123 | 上リボン
EllipseRibbon | 124 | 下カーブ リボン
EllipseRibbon2 | 125 | 上カーブ リボン
LeftRightRibbon | 126 | LeftRightRibbon
VerticalScroll | 127 | 縦巻き
HorizontalScroll | 128 | 横巻き
Wave | 129 | 大波
DoubleWave | 130 | 小波
Plus | 131 | 十字形
FlowChartProcess | 132 | フローチャート : 処理
FlowChartDecision | 133 | フローチャート : 判断
FlowChartInputOutput | 134 | フローチャート : データ
FlowChartPredefinedProcess | 135 | フローチャート : 定義済み処理
FlowChartInternalStorage | 136 | フローチャート : 内部記憶
FlowChartDocument | 137 | フローチャート : 書類
FlowChartMultidocument | 138 | フローチャート : 複数書類
FlowChartTerminator | 139 | フローチャート : 端子
FlowChartPreparation | 140 | フローチャート : 準備
FlowChartManualInput | 141 | フローチャート : 手操作入力
FlowChartManualOperation | 142 | フローチャート : 手作業
FlowChartConnector | 143 | フローチャート : 結合子
FlowChartPunchedCard | 144 | フローチャート : カード
FlowChartPunchedTape | 145 | フローチャート : せん孔テープ
FlowChartSummingJunction | 146 | フローチャート : 和接合
FlowChartOr | 147 | フローチャート : 論理和
FlowChartCollate | 148 | フローチャート : 照合
FlowChartSort | 149 | フローチャート : 分類
FlowChartExtract | 150 | フローチャート : 抜出し
FlowChartMerge | 151 | フローチャート : 組合せ
FlowChartOfflineStorage | 152 | フローチャート : OfflineStorage
FlowChartOnlineStorage | 153 | フローチャート : 記憶データ
FlowChartMagneticTape | 154 | フローチャート : 順次アクセス記憶
FlowChartMagneticDisk | 155 | フローチャート : 磁気ディスク
FlowChartMagneticDrum | 156 | フローチャート : 直接アクセス記憶
FlowChartDisplay | 157 | フローチャート : 表示
FlowChartDelay | 158 | フローチャート : 論理積ゲート
FlowChartAlternateProcess | 159 | フローチャート : 代替処理
FlowChartOffpageConnector | 160 | フローチャート : 他ページ結合子
ActionButtonBlank | 161 | アクションボタン ： ブランク
ActionButtonHome | 162 | アクションボタン ： ホーム
ActionButtonHelp | 163 | アクションボタン ： ヘルプ
ActionButtonInformation | 164 | アクションボタン ： 情報
ActionButtonForwardNext | 165 | アクションボタン ： 次へ
ActionButtonBackPrevious | 166 | アクションボタン ： 前へ
ActionButtonEnd | 167 | アクションボタン ： 終了
ActionButtonBeginning | 168 | アクションボタン ： 開始
ActionButtonReturn | 169 | アクションボタン ： 戻る
ActionButtonDocument | 170 | アクションボタン ： ドキュメント
ActionButtonSound | 171 | アクションボタン ： サウンド
ActionButtonMovie | 172 | アクションボタン ： 動画
Gear6 | 173 | ギア 6
Gear9 | 174 | ギア 9
Funnel | 175 | Funnel
MathPlus | 176 | 加算記号
MathMinus | 177 | 減算記号
MathMultiply | 178 | 乗算記号
MathDivide | 179 | 除算記号
MathEqual | 180 | 等号
MathNotEqual | 181 | 不等号
CornerTabs | 182 | CornerTabs
SquareTabs | 183 | SquareTabs
PlaqueTabs | 184 | PlaqueTabs
ChartX | 185 | ChartX
ChartStar | 186 | ChartStar
ChartPlus | 187 | ChartPlus
関連項目

参照


xlsxVersion 列挙体

Excel ファイル(Xlsx 形式)のバージョンを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum xlsxVersion
Public Enumeration xlsxVersion
メンバー
メンバー | 値 | 説明
ver2007 | 2007 | Excel 2007 の形式で作成します。
ver2010 | 2010 | Excel 2010 の形式で作成します。
ver2013 | 2013 | Excel 2013 の形式で作成します。
ver2013S | -2013 | Excel 2013 Strict 形式で作成します。
ver2016 | 2016 | Excel 2016 の形式で作成します。
ver2016S | -2016 | Excel 2016 Strict 形式で作成します。
ver2019 | 2019 | Excel 2019 の形式で作成します。
ver2019S | -2019 | Excel 2019 Strict 形式で作成します。
ver2021 | 2021 | Excel 2021 の形式で作成します。
ver2021S | -2021 | Excel 2021 Strict 形式で作成します。
ver2024 | 2024 | Excel 2024 の形式で作成します。
ver2024S | -2024 | Excel 2024 Strict 形式で作成します。
関連項目

参照


AdvanceSoftware.ASReport.BarCode 名前空間

AdvanceSoftware.ASReport.BarCode 名前空間には、バーコードコンポーネントが含まれています。
クラス
 | クラス | 説明
Public クラス | BarCode | BarCode クラス
Public クラス | BarCodeErrorEventArgs | BarCode クラスの Error イベントのデータを提供します。
構造体
 | 構造体 | 説明
Public 構造体 | BarCodeSizeD | BarCodeSizeD 構造体
デリゲート
 | デリゲート | 説明
Public デリゲート | BarCodeErrorEventHandler | BarCode クラスの Error イベントを処理するメソッドを表します。
列挙体
 | 列挙体 | 説明
Public 列挙体 | BarCodeType | バーコードの種類を指定します。
Public 列挙体 | CheckPattern | チェックデジットの計算方法を指定します。
Public 列挙体 | Codeset | スタートコードセットを指定します。
Public 列挙体 | ErrorNo | エラーナンバーを示す識別子を指定します。
Public 列挙体 | MessageAlign | バーコードメッセージの表示横位置を指定します。
Public 列挙体 | PDFModel | PDF417 シンボルを指定します。
Public 列挙体 | QRConnect | QR コードの連結モードを指定します。
Public 列挙体 | QRLevel | QR コードの誤り訂正レベルを指定します。
Public 列挙体 | QRMask | QR コードのマスクパターンを指定します。
Public 列挙体 | QRModel | QR コードのモデルを指定します。
Public 列挙体 | QRVersion | QR コードの型番を指定します。
Public 列挙体 | Rotate | バーコードの回転方向を指定します。
Public 列挙体 | Unit | バーコードの生成単位を指定します。
Public 列挙体 | ValueEncoding | バーコードデータのエンコード方式を指定します。(QRCode, PDF417)


BarCode クラス

BarCode クラス
継承階層
System.ComponentModelComponent
AdvanceSoftware.ASReport.BarCodeBarCode

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class BarCode : Component
Public Class BarCode
    Inherits Component

BarCode 型は下記のメンバーを公開します。

コンストラクター
 | 名前 | 説明
Public メソッド | BarCode | コンストラクター
Public メソッド | BarCode(IContainer) | コンストラクター
トップ
プロパティ
名前 | 説明
BackColor | バーコードシンボルの背景色を設定、取得します。
BarColor | バーの色を設定、取得します。
BarHeight | バーコードの高さを設定、取得します。
BarRatio | 太バーのエレメント率を設定、取得します。(Codabar、Code39)
BarWidth | バーコードの幅を設定、取得します。
BinaryValue | バーコードデータを設定します。(バイナリ値)
BlackBarRevision | 黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金等代理収納 GS1-128)
BlackRatio | 黒バーの太さの比率を設定、取得します。
CharGap | キャラクタ間のギャップを設定、取得します。(Codabar、Code39)
CharSize | バーコードメッセージのフォントサイズを設定、取得します。
CheckCharMode | 自動でチェックキャラクタを付加するかを設定、取得します。
CheckPattern | チェックデジットの計算方法を設定、取得します。(Codabar)
Codeset | スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))
DpiX | X 軸方向の解像度を設定、取得します。(ピクセル単位)
DpiY | Y 軸方向の解像度を設定、取得します。(ピクセル単位)
Element | 最小エレメント値を設定、取得します。
EmfType | 拡張メタファイル(EMF)に格納されるレコードの品質を設定、取得します。
ErrorMessage | エラーメッセージを取得します。
ErrorNo | エラーナンバーを取得します。
FlatHeight | ガードバーの均等化を設定、取得します。(JAN、UPC)
Font | バーコードメッセージのフォント名、フォントスタイルを設定、取得します。
InternalQRVersion | QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。
InternalValue | 整形後のバーコードデータを取得します。
MessageAlign | バーコードメッセージの表示横位置を設定、取得します。(公共料金等代理収納 GS1-128)
PDFColumn | PDF417 の列数を設定、取得します。
PDFInitialSymbol | PDF417 の初期化シンボルを設定、取得します。
PDFLevel | PDF417 のエラー訂正レベルを設定、取得します。
PDFModel | PDF417 シンボルを設定、取得します。
PDFRatio | PDF417 の 1 モジュールの縦横比を設定、取得します。
PDFRow | PDF417 の行数を設定、取得します。
Point | ポイントを設定、取得します。(カスタマバーコード)
QRConnect | 連結 QR コードを作成するかを設定、取得します。
QREscapeCode | QR コードのエスケープコードを設定、取得します。
QRLevel | QR コードの誤り訂正レベルを設定、取得します。
QRMask | QR コードのマスクパターンを設定、取得します。
QRModel | QR コードのモデルを設定、取得します。
QRSymbolNumber | 連結 QR コードで出力するシンボル番号を設定、取得します。
QRVersion | QR コードの型番を設定、取得します。
Quiet | 余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金等代理収納 GS1-128)
Rotate | バーコードの回転方向を設定、取得します。
ShowBearer | ベアラバーを表示するかを設定、取得します。(ITF)
ShowMessage | バーコードメッセージを表示するかを設定、取得します。
StartChar | スタートキャラクタを設定、取得します。(Codabar)
StopChar | ストップキャラクタを設定、取得します。(Codabar)
TextRenderingHint | バーコードキャラクタのテキストレンダリングの品質を設定、取得します。
Type | バーコードの種類を設定、取得します。
Unit | バーコードの生成単位を設定、取得します。
Value | バーコードデータを設定、取得します。(文字列)
ValueEncoding | バーコードデータのエンコード方式を設定、取得します。(QRCode, PDF417)
WhiteBarRevision | 白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金等代理収納 GS1-128)
Zoom | 倍率を設定、取得します。(JAN、UPC、ITF)
トップ
メソッド
名前 | 説明
GetBarCodeImage(ImageFormat) | バーコードのイメージを作成します。
GetBarCodeImage(ImageFormat, Boolean) | バーコードのイメージを作成します。
GetScaleSize | 指定した単位でバーコードのサイズを取得します。
SetLicense(Stream) | ライセンス情報を設定します。
SetLicense(String) | ライセンス情報を設定します。
トップ
イベント
名前 | 説明
Error | バーコードの作成に失敗した時に発生します。
トップ
関連項目

参照

AdvanceSoftware.ASReport.BarCode 名前空間


BarCode コンストラクター

オーバーロードの一覧
 | 名前 | 説明
Public メソッド | BarCode | コンストラクター
Public メソッド | BarCode(IContainer) | コンストラクター
トップ
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode コンストラクター

コンストラクター

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public BarCode()
Public Sub New
関連項目

参照

BarCode クラス
BarCode オーバーロード
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode コンストラクター (IContainer)

コンストラクター

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public BarCode(
    IContainer container
)
Public Sub New (
    container As IContainer
)

パラメーター

container
型: System.ComponentModelIContainer
System.ComponentModel.IContainer を指定します。
関連項目

参照

BarCode クラス
BarCode オーバーロード
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode プロパティ

BarCode 型は下記のメンバーを公開します。

プロパティ
名前 | 説明
BackColor | バーコードシンボルの背景色を設定、取得します。
BarColor | バーの色を設定、取得します。
BarHeight | バーコードの高さを設定、取得します。
BarRatio | 太バーのエレメント率を設定、取得します。(Codabar、Code39)
BarWidth | バーコードの幅を設定、取得します。
BinaryValue | バーコードデータを設定します。(バイナリ値)
BlackBarRevision | 黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金等代理収納 GS1-128)
BlackRatio | 黒バーの太さの比率を設定、取得します。
CharGap | キャラクタ間のギャップを設定、取得します。(Codabar、Code39)
CharSize | バーコードメッセージのフォントサイズを設定、取得します。
CheckCharMode | 自動でチェックキャラクタを付加するかを設定、取得します。
CheckPattern | チェックデジットの計算方法を設定、取得します。(Codabar)
Codeset | スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))
DpiX | X 軸方向の解像度を設定、取得します。(ピクセル単位)
DpiY | Y 軸方向の解像度を設定、取得します。(ピクセル単位)
Element | 最小エレメント値を設定、取得します。
EmfType | 拡張メタファイル(EMF)に格納されるレコードの品質を設定、取得します。
ErrorMessage | エラーメッセージを取得します。
ErrorNo | エラーナンバーを取得します。
FlatHeight | ガードバーの均等化を設定、取得します。(JAN、UPC)
Font | バーコードメッセージのフォント名、フォントスタイルを設定、取得します。
InternalQRVersion | QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。
InternalValue | 整形後のバーコードデータを取得します。
MessageAlign | バーコードメッセージの表示横位置を設定、取得します。(公共料金等代理収納 GS1-128)
PDFColumn | PDF417 の列数を設定、取得します。
PDFInitialSymbol | PDF417 の初期化シンボルを設定、取得します。
PDFLevel | PDF417 のエラー訂正レベルを設定、取得します。
PDFModel | PDF417 シンボルを設定、取得します。
PDFRatio | PDF417 の 1 モジュールの縦横比を設定、取得します。
PDFRow | PDF417 の行数を設定、取得します。
Point | ポイントを設定、取得します。(カスタマバーコード)
QRConnect | 連結 QR コードを作成するかを設定、取得します。
QREscapeCode | QR コードのエスケープコードを設定、取得します。
QRLevel | QR コードの誤り訂正レベルを設定、取得します。
QRMask | QR コードのマスクパターンを設定、取得します。
QRModel | QR コードのモデルを設定、取得します。
QRSymbolNumber | 連結 QR コードで出力するシンボル番号を設定、取得します。
QRVersion | QR コードの型番を設定、取得します。
Quiet | 余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金等代理収納 GS1-128)
Rotate | バーコードの回転方向を設定、取得します。
ShowBearer | ベアラバーを表示するかを設定、取得します。(ITF)
ShowMessage | バーコードメッセージを表示するかを設定、取得します。
StartChar | スタートキャラクタを設定、取得します。(Codabar)
StopChar | ストップキャラクタを設定、取得します。(Codabar)
TextRenderingHint | バーコードキャラクタのテキストレンダリングの品質を設定、取得します。
Type | バーコードの種類を設定、取得します。
Unit | バーコードの生成単位を設定、取得します。
Value | バーコードデータを設定、取得します。(文字列)
ValueEncoding | バーコードデータのエンコード方式を設定、取得します。(QRCode, PDF417)
WhiteBarRevision | 白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金等代理収納 GS1-128)
Zoom | 倍率を設定、取得します。(JAN、UPC、ITF)
トップ
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.BackColor プロパティ

BarCodeBackColor プロパティ

バーコードシンボルの背景色を設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

プロパティ値

型: Color
バーコードシンボルの背景色を表す Color。(既定値：Color.White)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
// バーコードイメージの背景色を "赤色" に設定します。
barCode1.BackColor = System.Drawing.Color.Red;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
' バーコードイメージの背景色を "赤色" に設定します。
BarCode1.BackColor = System.Drawing.Color.Red
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.BarColor プロパティ

BarCodeBarColor プロパティ

バーの色を設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color BarColor { get; set; }
Public Property BarColor As Color
    Get
    Set

プロパティ値

型: Color
バーの色を表す Color。(既定値：Color.Black)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
// バーの色を "赤色" に設定します。
barCode1.BarColor = System.Drawing.Color.Red;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
' バーの色を "赤色" に設定します。
BarCode1.BarColor = System.Drawing.Color.Red
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.BarHeight プロパティ

BarCodeBarHeight プロパティ

バーコードの高さを設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double BarHeight { get; set; }
Public Property BarHeight As Double
    Get
    Set

プロパティ値

型: Double
バーコードの高さを表す double。(既定値：0.0)
解説
プロパティ値は Unit プロパティのサイズ単位で扱われます。 プロパティ値が 0 の場合、バーコードの高さは自動で設定されます。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Millimeter;
// バーコードイメージの高さを "30.0mm" に設定します。
barCode1.BarHeight = 30.0;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Millimeter
' バーコードイメージの高さを "30.0mm" に設定します。
BarCode1.BarHeight = 30.0
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.BarRatio プロパティ

BarCodeBarRatio プロパティ

太バーのエレメント率を設定、取得します。(Codabar、Code39)

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double BarRatio { get; set; }
Public Property BarRatio As Double
    Get
    Set

プロパティ値

型: Double
太バーのエレメント率を表す double。(既定値：2.0)
解説

設定範囲

最小エレメント値が 0.508mm 未満：2.2 ～ 3.0

最小エレメント値が 0.508mm 以上：2.0 ～ 3.0

例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Codabar;
// 太バーのエレメント率を "2.5" に設定します。
barCode1.BarRatio = 2.5;
barCode1.Value = "1234567890";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Codabar
' 太バーのエレメント率を "2.5" に設定します。
BarCode1.BarRatio = 2.5
BarCode1.Value = "1234567890"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.BarWidth プロパティ

BarCodeBarWidth プロパティ

バーコードの幅を設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double BarWidth { get; set; }
Public Property BarWidth As Double
    Get
    Set

プロパティ値

型: Double
バーコードの幅を表す double。(既定値：0.0)
解説
プロパティ値は Unit プロパティのサイズ単位で扱われます。 プロパティ値が 0 の場合、バーコードの幅は自動で設定されます。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Millimeter;
// バーコードイメージの幅を "60.0mm" に設定します。
barCode1.BarWidth = 60.0;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Millimeter
' バーコードイメージの幅を "60.0mm" に設定します。
BarCode1.BarWidth = 60.0
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.BinaryValue プロパティ

BarCodeBinaryValue プロパティ

バーコードデータを設定します。(バイナリ値)

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public byte[] BinaryValue { set; }
Public WriteOnly Property BinaryValue As Byte()
    Set

プロパティ値

型: Byte
バーコードデータを表す Byte[]。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode;
// "12345ABCDE"
Byte[] btByte = new Byte[] { 49, 50, 51, 52, 53, 65, 66, 67, 68, 69 };
// バーコードデータを設定します。 (バイナリ値)
barCode1.BinaryValue = btByte;
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode
' "12345ABCDE"
Dim btByte() As Byte = New Byte() {49, 50, 51, 52, 53, 65, 66, 67, 68, 69}
' バーコードデータを設定します。 (バイナリ値)
BarCode1.BinaryValue = btByte
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.BlackBarRevision プロパティ

BarCodeBlackBarRevision プロパティ

黒バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金等代理収納 GS1-128)

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int BlackBarRevision { get; set; }
Public Property BlackBarRevision As Integer
    Get
    Set

プロパティ値

型: Int32
黒バーのドット補正値を表す int。(既定値：0)
解説
Unit プロパティの値が Unit.Pixel の場合、有効になります。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Code128;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 黒バーのドット補正値を "+2" に設定します。
barCode1.BlackBarRevision = 2;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Code128
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 黒バーのドット補正値を "+2" に設定します。
BarCode1.BlackBarRevision = 2
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.BlackRatio プロパティ

BarCodeBlackRatio プロパティ

黒バーの太さの比率を設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int BlackRatio { get; set; }
Public Property BlackRatio As Integer
    Get
    Set

プロパティ値

型: Int32
黒バーの太さの比率を表す int。(既定値：100)
解説
設定範囲：50 ～ 150
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
// 黒バーの太さ比率を "150%" に設定します。
barCode1.BlackRatio = 150;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
' 黒バーの太さ比率を "150%" に設定します。
BarCode1.BlackRatio = 150
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.CharGap プロパティ

BarCodeCharGap プロパティ

キャラクタ間のギャップを設定、取得します。(Codabar、Code39)

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double CharGap { get; set; }
Public Property CharGap As Double
    Get
    Set

プロパティ値

型: Double
キャラクタ間のギャップを表す double。(既定値：0.0)
解説
プロパティ値は Unit プロパティのサイズ単位で扱われます。 プロパティ値が 0 の場合、キャラクタ間のギャップは自動で設定されます。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Code39;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Millimeter;
// バーコードキャラクタの間隔を "2.0mm" に設定します。
barCode1.CharGap = 2.0;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Code39
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Millimeter
' バーコードキャラクタの間隔を "2.0mm" に設定します。
BarCode1.CharGap = 2.0
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.CharSize プロパティ

BarCodeCharSize プロパティ

バーコードメッセージのフォントサイズを設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double CharSize { get; set; }
Public Property CharSize As Double
    Get
    Set

プロパティ値

型: Double
バーコードメッセージのフォントサイズを表す double。(既定値：0.0)
解説
プロパティ値は Unit プロパティのサイズ単位で扱われます。 プロパティ値が 0 の場合、バーコードメッセージのフォントサイズは自動で設定されます。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Millimeter;
// バーコードメッセージのフォントサイズを "10.0mm" に設定します。
barCode1.CharSize = 10.0;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Millimeter
' バーコードメッセージのフォントサイズを "10.0mm" に設定します。
BarCode1.CharSize = 10.0
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.CheckCharMode プロパティ

BarCodeCheckCharMode プロパティ

自動でチェックキャラクタを付加するかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool CheckCharMode { get; set; }
Public Property CheckCharMode As Boolean
    Get
    Set

プロパティ値

型: Boolean
チェックキャラクタのモードを表す bool。(既定値：true)
解説
プロパティ値が true の場合、自動でチェックキャラクタを付加します。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
// チェックキャラクタを "付加しない" に設定します。
barCode1.CheckCharMode = false;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
' チェックキャラクタを "付加しない" に設定します。
BarCode1.CheckCharMode = False
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.CheckPattern プロパティ

BarCodeCheckPattern プロパティ

チェックデジットの計算方法を設定、取得します。(Codabar)

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public CheckPattern CheckPattern { get; set; }
Public Property CheckPattern As CheckPattern
    Get
    Set

プロパティ値

型: CheckPattern
チェックデジットの計算方法を表す CheckPattern。(既定値：CheckPattern.Modulus16)
解説
CheckPattern.Modulus11(モジュラス 11) を設定した場合、計算に必要なバーコードメッセージは 6 桁以上必要になります。6 桁未満の場合は、Modulus10Weight3(モジュラス10 / ウエイト3) で計算されます。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Codabar;
// チェックデジットの計算方法を "モジュラス 11" に設定します。
barCode1.CheckPattern = AdvanceSoftware.ASReport.BarCode.CheckPattern.Modulus11;
barCode1.Value = "12345678";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Codabar
' チェックデジットの計算方法を "モジュラス 11" に設定します。
BarCode1.CheckPattern = AdvanceSoftware.ASReport.BarCode.CheckPattern.Modulus11
BarCode1.Value = "12345678"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.Codeset プロパティ

BarCodeCodeset プロパティ

スタートコードセットを設定、取得します。(Code128、GS1-128(旧称：UCC/EAN-128))

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Codeset Codeset { get; set; }
Public Property Codeset As Codeset
    Get
    Set

プロパティ値

型: Codeset
スタートコードセットを表す Codeset。(既定値：Codeset.CodesetAuto)
解説
プロパティ値が CodeSet.CodesetAuto の場合、バーコードデータの先頭の文字でコードセットが決まります。

先頭キャラクタが ~(チルダ) の場合、コードセットA に設定されます。

先頭キャラクタがアルファベットの場合、コードセットB に設定されます。

先頭から 2 キャラクタが数字の場合、コードセット C に設定されます。

例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Code128;
// Code128 を "コードセット B" に設定します。
barCode1.Codeset = AdvanceSoftware.ASReport.BarCode.Codeset.CodesetB;
barCode1.Value = "abc123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Code128
' Code128 を "コードセット B" に設定します。
BarCode1.Codeset = AdvanceSoftware.ASReport.BarCode.Codeset.CodesetB
BarCode1.Value = "abc123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.DpiX プロパティ

BarCodeDpiX プロパティ

X 軸方向の解像度を設定、取得します。(ピクセル単位)

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double DpiX { get; set; }
Public Property DpiX As Double
    Get
    Set

プロパティ値

型: Double
X 軸方向の解像度を表す double。(既定値：96.0)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// X 軸方向の解像度を "600dpi" に設定します。
barCode1.DpiX = 600;
// Y 軸方向の解像度を "600dpi" に設定します。
barCode1.DpiY = 600;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' X 軸方向の解像度を "600dpi" に設定します。
BarCode1.DpiX = 600
' Y 軸方向の解像度を "600dpi" に設定します。
BarCode1.DpiY = 600
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.DpiY プロパティ

BarCodeDpiY プロパティ

Y 軸方向の解像度を設定、取得します。(ピクセル単位)

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double DpiY { get; set; }
Public Property DpiY As Double
    Get
    Set

プロパティ値

型: Double
Y 軸方向の解像度を表す double。(既定値：96.0)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// X 軸方向の解像度を "600dpi" に設定します。
barCode1.DpiX = 600;
// Y 軸方向の解像度を "600dpi" に設定します。
barCode1.DpiY = 600;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' X 軸方向の解像度を "600dpi" に設定します。
BarCode1.DpiX = 600
' Y 軸方向の解像度を "600dpi" に設定します。
BarCode1.DpiY = 600
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.Element プロパティ

BarCodeElement プロパティ

最小エレメント値を設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double Element { get; set; }
Public Property Element As Double
    Get
    Set

プロパティ値

型: Double
最小エレメント値を表す double。
解説
プロパティ値は Unit プロパティのサイズ単位で扱われます。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Codabar;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Millimeter;
// バーコードイメージの最小エレメント値を "0.191mm" に設定します。
barCode1.Element = 0.191;
barCode1.Value = "1234567890";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Codabar
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Millimeter
' バーコードイメージの最小エレメント値を "0.191mm" に設定します。
BarCode1.Element = 0.191
BarCode1.Value = "1234567890"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.EmfType プロパティ

BarCodeEmfType プロパティ

拡張メタファイル(EMF)に格納されるレコードの品質を設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public EmfType EmfType { get; set; }
Public Property EmfType As EmfType
    Get
    Set

プロパティ値

型: EmfType
拡張メタファイルのレコード品質を表す EmfType。(既定値：EmfType.EmfPlusDual)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
// 拡張メタファイルのレコード品質を "EmfOnly" に設定します。
barCode1.EmfType = System.Drawing.Imaging.EmfType.EmfOnly;
barCode1.Value = "1234567890123";
Image imgBarCode = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf);
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
' 拡張メタファイルのレコード品質を "EmfOnly" に設定します。
BarCode1.EmfType = System.Drawing.Imaging.EmfType.EmfOnly
BarCode1.Value = "1234567890123"
Dim imgBarCode As Image = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Emf)
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.ErrorMessage プロパティ

BarCodeErrorMessage プロパティ

エラーメッセージを取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string ErrorMessage { get; }
Public ReadOnly Property ErrorMessage As String
    Get

プロパティ値

型: String
バーコード生成時のエラーメッセージを表す string。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// エラー処理
if (barCode1.ErrorNo != AdvanceSoftware.ASReport.BarCode.ErrorNo.NoError)
{
    // エラーメッセージを表示します。
    MessageBox.Show(barCode1.ErrorMessage);
}
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' エラー処理
If BarCode1.ErrorNo <> AdvanceSoftware.ASReport.BarCode.ErrorNo.NoError Then
    ' エラーメッセージを表示します。
    MessageBox.Show(BarCode1.ErrorMessage)
End If
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.ErrorNo プロパティ

BarCodeErrorNo プロパティ

エラーナンバーを取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo ErrorNo { get; }
Public ReadOnly Property ErrorNo As ErrorNo
    Get

プロパティ値

型: ErrorNo
バーコード生成時のエラーナンバーを表す ErrorNo。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// エラー処理
if (barCode1.ErrorNo != AdvanceSoftware.ASReport.BarCode.ErrorNo.NoError)
{
    // エラーメッセージを表示します。
    MessageBox.Show(barCode1.ErrorMessage);
}
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' エラー処理
If BarCode1.ErrorNo <> AdvanceSoftware.ASReport.BarCode.ErrorNo.NoError Then
    ' エラーメッセージを表示します。
    MessageBox.Show(BarCode1.ErrorMessage)
End If
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.FlatHeight プロパティ

BarCodeFlatHeight プロパティ

ガードバーの均等化を設定、取得します。(JAN、UPC)

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool FlatHeight { get; set; }
Public Property FlatHeight As Boolean
    Get
    Set

プロパティ値

型: Boolean
ガードバーの均等化を表す bool。(既定値：false)
解説
プロパティ値が true の場合、ガードバーを均等化します。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
// ガードバーの長さを均等に設定します。
barCode1.FlatHeight = true;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
' ガードバーの長さを均等に設定します。
BarCode1.FlatHeight = True
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.Font プロパティ

BarCodeFont プロパティ

バーコードメッセージのフォント名、フォントスタイルを設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Font Font { get; set; }
Public Property Font As Font
    Get
    Set

プロパティ値

型: Font
バーコードメッセージのフォントを表す Font。
解説
このプロパティは、バーコードメッセージのフォント名、フォントスタイルを設定することができます。 フォントサイズは反映されないため、CharSize プロパティで設定して下さい。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
// バーコードメッセージを "フォント名：ＭＳ 明朝 , フォントスタイル：斜体" に設定します。
barCode1.Font = new System.Drawing.Font("ＭＳ 明朝", 9, System.Drawing.FontStyle.Italic);
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
' バーコードメッセージを "フォント名：ＭＳ 明朝 , フォントスタイル：斜体" に設定します。
BarCode1.Font = New System.Drawing.Font("ＭＳ 明朝", 9, System.Drawing.FontStyle.Italic)
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.InternalQRVersion プロパティ

BarCodeInternalQRVersion プロパティ

QRVersion に QRVersion.VersionAuto が設定された場合の自動設定された QR コードの型番を取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public QRVersion InternalQRVersion { get; }
Public ReadOnly Property InternalQRVersion As QRVersion
    Get

プロパティ値

型: QRVersion
QR コードの型番を表す QRVersion。
解説
プロパティ値が QRVersion.VersionAuto の場合、QR コードの型番は自動で設定されます。

QRModel プロパティの値により、QRVersion.VersionAuto 以外の設定範囲が異なります。

設定範囲(QRModel1)：QRVersion.QRVersion1 ～ QRVersion14

設定範囲(QRModel2)：QRVersion.QRVersion1 ～ QRVersion40

例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode;
barCode1.QRVersion = AdvanceSoftware.ASReport.BarCode.QRVersion.VersionAuto;
barCode1.Value = "12345ABCDE";
Image imgBarCode = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
// 自動設定された QR コード の型番を取得します。
AdvanceSoftware.ASReport.BarCode.QRVersion internalQRVersion = barCode1.InternalQRVersion;
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode
BarCode1.QRVersion = AdvanceSoftware.ASReport.BarCode.QRVersion.VersionAuto
BarCode1.Value = "12345ABCDE"
Dim imgBarCode As Image = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp)
' 自動設定された QR コード の型番を取得します。
Dim internalQRVersion As AdvanceSoftware.ASReport.BarCode.QRVersion = BarCode1.InternalQRVersion
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.InternalValue プロパティ

BarCodeInternalValue プロパティ

整形後のバーコードデータを取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string InternalValue { get; }
Public ReadOnly Property InternalValue As String
    Get

プロパティ値

型: String
整形後のバーコードデータを表す string。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
Image imgBarCode = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
// 整形後のバーコードデータを取得します。
string internalValue = barCode1.InternalValue;
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
Dim imgBarCode As Image = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp)
' 整形後のバーコードデータを取得します。
Dim internalValue As String = BarCode1.InternalValue
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.MessageAlign プロパティ

BarCodeMessageAlign プロパティ

バーコードメッセージの表示横位置を設定、取得します。(公共料金等代理収納 GS1-128)

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public MessageAlign MessageAlign { get; set; }
Public Property MessageAlign As MessageAlign
    Get
    Set

プロパティ値

型: MessageAlign
バーコードメッセージの表示横位置を表す MessageAlign。(既定値：MessageAlign.Center)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.GS1Fixed;
// バーコードメッセージの横位置を "左詰め" に設定します。(公共料金等代理収納 GS1-128)
barCode1.MessageAlign = AdvanceSoftware.ASReport.BarCode.MessageAlign.Left;
barCode1.Value = "91012345678901234567890123456789012345678901";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.GS1Fixed
' バーコードメッセージの横位置を "左詰め" に設定します。(公共料金等代理収納 GS1-128)
BarCode1.MessageAlign = AdvanceSoftware.ASReport.BarCode.MessageAlign.Left
BarCode1.Value = "91012345678901234567890123456789012345678901"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.PDFColumn プロパティ

BarCodePDFColumn プロパティ

PDF417 の列数を設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int PDFColumn { get; set; }
Public Property PDFColumn As Integer
    Get
    Set

プロパティ値

型: Int32
PDF417 の列数を表す int。(既定値：0)
解説
設定範囲：0 ～ 40

プロパティ値が 0 の場合、縦横比 1:2 で PDF417 を作成します。

例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.PDF417;
// PDF417 の列数を "15列" に設定します。
barCode1.PDFColumn = 15;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.PDF417
' PDF417 の列数を "15列" に設定します。
BarCode1.PDFColumn = 15
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.PDFInitialSymbol プロパティ

BarCodePDFInitialSymbol プロパティ

PDF417 の初期化シンボルを設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool PDFInitialSymbol { get; set; }
Public Property PDFInitialSymbol As Boolean
    Get
    Set

プロパティ値

型: Boolean
PDF417 の初期化シンボルを表す bool。(既定値：false)
解説
プロパティ値が true の場合、初期化シンボルを付加した PDF417 を作成します。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.PDF417;
// PDF417 の初期化シンボルを "付加する" に設定します。
barCode1.PDFInitialSymbol = true;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.PDF417
' PDF417 の初期化シンボルを "付加する" に設定します。
BarCode1.PDFInitialSymbol = True
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.PDFLevel プロパティ

BarCodePDFLevel プロパティ

PDF417 のエラー訂正レベルを設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int PDFLevel { get; set; }
Public Property PDFLevel As Integer
    Get
    Set

プロパティ値

型: Int32
PDF417 のエラー訂正レベルを表す int。(既定値：0)
解説
設定範囲：0 ～ 8
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.PDF417;
// PDF417 のエラー訂正レベルを "レベル7" に設定します。
barCode1.PDFLevel = 7;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.PDF417
' PDF417 のエラー訂正レベルを "レベル7" に設定します。
BarCode1.PDFLevel = 7
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.PDFModel プロパティ

BarCodePDFModel プロパティ

PDF417 シンボルを設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PDFModel PDFModel { get; set; }
Public Property PDFModel As PDFModel
    Get
    Set

プロパティ値

型: PDFModel
PDF417 シンボルを表す PDFModel。(既定値：PDFModel.Default)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.PDF417;
// PDF417 シンボルを "簡易 PDF417" に設定します。
barCode1.PDFModel = AdvanceSoftware.ASReport.BarCode.PDFModel.Truncated;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.PDF417
' PDF417 シンボルを "簡易 PDF417" に設定します。
BarCode1.PDFModel = AdvanceSoftware.ASReport.BarCode.PDFModel.Truncated
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.PDFRatio プロパティ

BarCodePDFRatio プロパティ

PDF417 の 1 モジュールの縦横比を設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double PDFRatio { get; set; }
Public Property PDFRatio As Double
    Get
    Set

プロパティ値

型: Double
PDF417 の 1 モジュールの縦横比を表す double。(既定値：7.5)
解説
設定範囲：1.0 ～ 10.0
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.PDF417;
// PDF417 の 1 モジュールの幅との縦横比を "5.0" に設定します。
barCode1.PDFRatio = 5.0;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.PDF417
' PDF417 の 1 モジュールの幅との縦横比を "5.0" に設定します。
BarCode1.PDFRatio = 5.0
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.PDFRow プロパティ

BarCodePDFRow プロパティ

PDF417 の行数を設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int PDFRow { get; set; }
Public Property PDFRow As Integer
    Get
    Set

プロパティ値

型: Int32
PDF417 の行数を表す int。(既定値：0)
解説
設定範囲：0、3 ～ 90

プロパティ値が 0 の場合、縦横比 1:2 で PDF417 を作成します。

例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.PDF417;
// PDF417 の行数を "10行" に設定します。
barCode1.PDFRow = 10;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.PDF417
' PDF417 の行数を "10行" に設定します。
BarCode1.PDFRow = 10
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.Point プロパティ

BarCodePoint プロパティ

ポイントを設定、取得します。(カスタマバーコード)

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double Point { get; set; }
Public Property Point As Double
    Get
    Set

プロパティ値

型: Double
バーコードのポイントを表す double。(既定値：10.0)
解説
設定範囲：6.0 ～ 14.0
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.CustomerBarCode;
// カスタマバーコードのポイントを "10.0" に設定します。
barCode1.Point = 10.0;
barCode1.Value = "91882391-2816";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.CustomerBarCode
' カスタマバーコードのポイントを "10.0" に設定します。
BarCode1.Point = 10.0
BarCode1.Value = "91882391-2816"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.QRConnect プロパティ

BarCodeQRConnect プロパティ

連結 QR コードを作成するかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public QRConnect QRConnect { get; set; }
Public Property QRConnect As QRConnect
    Get
    Set

プロパティ値

型: QRConnect
連結 QR コードの設定を表す QRConnect。(既定値：QRConnect.NotConnect)
解説
プロパティ値が QRConnect.AutoConnect、QRConnect.ManualConnect の場合、QRVersion プロパティを QRVersion.VersionAuto 以外に設定します。

また、QRConnect.ManualConnect の場合、QREscapeCode プロパティを使用して分割する位置のエスケープコードを設定します。

例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.ASReport.BarCode.QRVersion.Version10;
// QR コード を "連結 QR コード(手動)" に設定します。
barCode1.QRConnect = AdvanceSoftware.ASReport.BarCode.QRConnect.ManualConnect;
// QR コードのエスケープコードを "% (0x25)" に設定します。
barCode1.QREscapeCode = 0x25;
barCode1.Value = "12345%SABCDE";
// 連結 QR コードで出力するシンボル番号を "0" に設定します。
barCode1.QRSymbolNumber = 0;
Image image1 = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
// 連結 QR コードで出力するシンボル番号を "1" に設定します。
barCode1.QRSymbolNumber = 1;
Image image2 = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.ASReport.BarCode.QRVersion.Version10
' QR コード を "連結 QR コード(手動)" に設定します。
BarCode1.QRConnect = AdvanceSoftware.ASReport.BarCode.QRConnect.ManualConnect
' QR コードのエスケープコードを "% (&H25)" に設定します。
BarCode1.QREscapeCode = &H25
BarCode1.Value = "12345%SABCDE"
' 連結 QR コードで出力するシンボル番号を "0" に設定します。
BarCode1.QRSymbolNumber = 0
Dim image1 As Image = BarCode1.GetBarCodeImage(Imaging.ImageFormat.Bmp)
' 連結 QR コードで出力するシンボル番号を "1" に設定します。
BarCode1.QRSymbolNumber = 1
Dim image2 As Image = BarCode1.GetBarCodeImage(Imaging.ImageFormat.Bmp)
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.QREscapeCode プロパティ

BarCodeQREscapeCode プロパティ

QR コードのエスケープコードを設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public byte QREscapeCode { get; set; }
Public Property QREscapeCode As Byte
    Get
    Set

プロパティ値

型: Byte
QR コードのエスケープコードを表す Byte。(既定値：0x00)
解説
Value プロパティや、BinaryValue プロパティに設定するバーコードデータの分割する位置に、"エスケープコード" + "S" を設定します。バーコードデータにエスケープコードと同じ文字がある場合、バーコードメッセージ側の該当する文字を二つ連続して設定してください。

このプロパティは、QRConnect プロパティの値が、QRConnect.ManualConnect の場合に有効です。

例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.ASReport.BarCode.QRVersion.Version10;
// QR コード を "連結 QR コード(手動)" に設定します。
barCode1.QRConnect = AdvanceSoftware.ASReport.BarCode.QRConnect.ManualConnect;
// QR コードのエスケープコードを "% (0x25)" に設定します。
barCode1.QREscapeCode = 0x25;
barCode1.Value = "12345%SABCDE";
// 連結 QR コードで出力するシンボル番号を "0" に設定します。
barCode1.QRSymbolNumber = 0;
Image image1 = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
// 連結 QR コードで出力するシンボル番号を "1" に設定します。
barCode1.QRSymbolNumber = 1;
Image image2 = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.ASReport.BarCode.QRVersion.Version10
' QR コード を "連結 QR コード(手動)" に設定します。
BarCode1.QRConnect = AdvanceSoftware.ASReport.BarCode.QRConnect.ManualConnect
' QR コードのエスケープコードを "% (&H25)" に設定します。
BarCode1.QREscapeCode = &H25
BarCode1.Value = "12345%SABCDE"
' 連結 QR コードで出力するシンボル番号を "0" に設定します。
BarCode1.QRSymbolNumber = 0
Dim image1 As Image = BarCode1.GetBarCodeImage(Imaging.ImageFormat.Bmp)
' 連結 QR コードで出力するシンボル番号を "1" に設定します。
BarCode1.QRSymbolNumber = 1
Dim image2 As Image = BarCode1.GetBarCodeImage(Imaging.ImageFormat.Bmp)
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.QRLevel プロパティ

BarCodeQRLevel プロパティ

QR コードの誤り訂正レベルを設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public QRLevel QRLevel { get; set; }
Public Property QRLevel As QRLevel
    Get
    Set

プロパティ値

型: QRLevel
QR コードの誤り訂正レベルを表す QRLevel。(既定値：QRLevel.LevelM)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode;
// QR コードのエラー訂正レベルを "H" に設定します。
barCode1.QRLevel = AdvanceSoftware.ASReport.BarCode.QRLevel.LevelH;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode
' QR コードのエラー訂正レベルを "H" に設定します。
BarCode1.QRLevel = AdvanceSoftware.ASReport.BarCode.QRLevel.LevelH
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.QRMask プロパティ

BarCodeQRMask プロパティ

QR コードのマスクパターンを設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public QRMask QRMask { get; set; }
Public Property QRMask As QRMask
    Get
    Set

プロパティ値

型: QRMask
QR コードのマスクパターンを表す QRMask。(既定値：QRMask.MaskAuto)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode;
// QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
barCode1.QRMask = AdvanceSoftware.ASReport.BarCode.QRMask.Mask000;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode
' QR コードのマスクパターンを "マスクパターン参照子 000" に設定します。
BarCode1.QRMask = AdvanceSoftware.ASReport.BarCode.QRMask.Mask000
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.QRModel プロパティ

BarCodeQRModel プロパティ

QR コードのモデルを設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public QRModel QRModel { get; set; }
Public Property QRModel As QRModel
    Get
    Set

プロパティ値

型: QRModel
QR コードのモデルを表す QRModel。(既定値：QRModel.Model1)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode;
// QR コードのモデルを "モデル 2" に設定します。
barCode1.QRModel = AdvanceSoftware.ASReport.BarCode.QRModel.Model2;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode
' QR コードのモデルを "モデル 2" に設定します。
BarCode1.QRModel = AdvanceSoftware.ASReport.BarCode.QRModel.Model2
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.QRSymbolNumber プロパティ

BarCodeQRSymbolNumber プロパティ

連結 QR コードで出力するシンボル番号を設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int QRSymbolNumber { get; set; }
Public Property QRSymbolNumber As Integer
    Get
    Set

プロパティ値

型: Int32
連結 QR コードのシンボル番号を表す int。(既定値：0)
解説
設定範囲：0 ～ 15

このプロパティは、QRConnect プロパティの値が、QRConnect.AutoConnect、QRConnect.ManualConnect の場合に有効です。

例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.ASReport.BarCode.QRVersion.Version10;
// QR コード を "連結 QR コード(手動)" に設定します。
barCode1.QRConnect = AdvanceSoftware.ASReport.BarCode.QRConnect.ManualConnect;
// QR コードのエスケープコードを "% (0x25)" に設定します。
barCode1.QREscapeCode = 0x25;
barCode1.Value = "12345%SABCDE";
// 連結 QR コードで出力するシンボル番号を "0" に設定します。
barCode1.QRSymbolNumber = 0;
Image image1 = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
// 連結 QR コードで出力するシンボル番号を "1" に設定します。
barCode1.QRSymbolNumber = 1;
Image image2 = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.ASReport.BarCode.QRVersion.Version10
' QR コード を "連結 QR コード(手動)" に設定します。
BarCode1.QRConnect = AdvanceSoftware.ASReport.BarCode.QRConnect.ManualConnect
' QR コードのエスケープコードを "% (&H25)" に設定します。
BarCode1.QREscapeCode = &H25
BarCode1.Value = "12345%SABCDE"
' 連結 QR コードで出力するシンボル番号を "0" に設定します。
BarCode1.QRSymbolNumber = 0
Dim image1 As Image = BarCode1.GetBarCodeImage(Imaging.ImageFormat.Bmp)
' 連結 QR コードで出力するシンボル番号を "1" に設定します。
BarCode1.QRSymbolNumber = 1
Dim image2 As Image = BarCode1.GetBarCodeImage(Imaging.ImageFormat.Bmp)
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.QRVersion プロパティ

BarCodeQRVersion プロパティ

QR コードの型番を設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public QRVersion QRVersion { get; set; }
Public Property QRVersion As QRVersion
    Get
    Set

プロパティ値

型: QRVersion
QR コードの型番を表す QRVersion。(既定値：QRVersion.VersionAuto)
解説
プロパティ値が QRVersion.VersionAuto の場合、QR コードの型番は自動で設定されます。

QRModel プロパティの値により、QRVersion.VersionAuto 以外の設定範囲が異なります。

設定範囲(QRModel1)：QRVersion.QRVersion1 ～ QRVersion14

設定範囲(QRModel2)：QRVersion.QRVersion1 ～ QRVersion40

例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode;
// QR コードの型番を "10 型" に設定します。
barCode1.QRVersion = AdvanceSoftware.ASReport.BarCode.QRVersion.Version10;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode
' QR コードの型番を "10 型" に設定します。
BarCode1.QRVersion = AdvanceSoftware.ASReport.BarCode.QRVersion.Version10
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.Quiet プロパティ

BarCodeQuiet プロパティ

余白のサイズを設定、取得します。(Codabar、Code39、Code128、GS1-128(旧称：UCC/EAN-128)、QRCode、PDF417、公共料金等代理収納 GS1-128)

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double Quiet { get; set; }
Public Property Quiet As Double
    Get
    Set

プロパティ値

型: Double
余白のサイズを表す double。(既定値：0.0)
解説
プロパティ値は Unit プロパティのサイズ単位で扱われます。 プロパティ値が 0 の場合、バーコードの余白は自動で設定されます。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Codabar;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Millimeter;
// バーコードイメージの余白幅を "2.5mm" に設定します。
barCode1.Quiet = 2.5;
barCode1.Value = "1234567890";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Codabar
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Millimeter
' バーコードイメージの余白幅を "2.5mm" に設定します。
BarCode1.Quiet = 2.5
BarCode1.Value = "1234567890"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.Rotate プロパティ

BarCodeRotate プロパティ

バーコードの回転方向を設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Rotate Rotate { get; set; }
Public Property Rotate As Rotate
    Get
    Set

プロパティ値

型: Rotate
バーコードの回転方向を表す Rotate。(既定値：Rotate.Rotate0)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
// バーコードイメージの向きを "時計回りで 90 度回転" に設定します。
barCode1.Rotate = AdvanceSoftware.ASReport.BarCode.Rotate.Rotate90;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
' バーコードイメージの向きを "時計回りで 90 度回転" に設定します。
BarCode1.Rotate = AdvanceSoftware.ASReport.BarCode.Rotate.Rotate90
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.ShowBearer プロパティ

BarCodeShowBearer プロパティ

ベアラバーを表示するかを設定、取得します。(ITF)

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowBearer { get; set; }
Public Property ShowBearer As Boolean
    Get
    Set

プロパティ値

型: Boolean
ベアラバーの表示モードを表す bool。(既定値：true)
解説
プロパティ値が true の場合、ベアラバーを表示します。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.ITF16;
// ITF16 のベアラバーを "表示しない" に設定します。
barCode1.ShowBearer = false;
barCode1.Value = "1234567890123456";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.ITF16
' ITF16 のベアラバーを "表示しない" に設定します。
BarCode1.ShowBearer = False
BarCode1.Value = "1234567890123456"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.ShowMessage プロパティ

BarCodeShowMessage プロパティ

バーコードメッセージを表示するかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowMessage { get; set; }
Public Property ShowMessage As Boolean
    Get
    Set

プロパティ値

型: Boolean
バーコードメッセージの表示モードを表す bool。(既定値：true)
解説
プロパティ値が true の場合、バーコードメッセージを表示します。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
// バーコードメッセージを "表示しない" に設定します。
barCode1.ShowMessage = false;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
' バーコードメッセージを "表示しない" に設定します。
BarCode1.ShowMessage = False
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.StartChar プロパティ

BarCodeStartChar プロパティ

スタートキャラクタを設定、取得します。(Codabar)

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public char StartChar { get; set; }
Public Property StartChar As Char
    Get
    Set

プロパティ値

型: Char
スタートキャラクタを表す char。(既定値：'a')
解説
設定可能な値：'a'、'b'、'c'、'd'、't'、'n'、'*'、'e'、'A'、'B'、'C'、'D'
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Codabar;
// Codabar のスタートキャラクタを "c" に設定します。
barCode1.StartChar = 'c';
barCode1.Value = "1234567890";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Codabar
' Codabar のスタートキャラクタを "c" に設定します。
BarCode1.StartChar = "c"
BarCode1.Value = "1234567890"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.StopChar プロパティ

BarCodeStopChar プロパティ

ストップキャラクタを設定、取得します。(Codabar)

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public char StopChar { get; set; }
Public Property StopChar As Char
    Get
    Set

プロパティ値

型: Char
ストップキャラクタを表す char。(既定値：'a')
解説
設定可能な値：'a'、'b'、'c'、'd'、't'、'n'、'*'、'e'、'A'、'B'、'C'、'D'
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Codabar;
// Codabar のストップキャラクタを "c" に設定します。
barCode1.StopChar = 'c';
barCode1.Value = "1234567890";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Codabar
' Codabar のストップキャラクタを "c" に設定します。
BarCode1.StopChar = "c"
BarCode1.Value = "1234567890"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.TextRenderingHint プロパティ

BarCodeTextRenderingHint プロパティ

バーコードキャラクタのテキストレンダリングの品質を設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextRenderingHint TextRenderingHint { get; set; }
Public Property TextRenderingHint As TextRenderingHint
    Get
    Set

プロパティ値

型: TextRenderingHint
バーコードキャラクタのテキストレンダリングを表す TextRenderingHint。(既定値：TextRenderingHint.SystemDefault)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
// バーコードメッセージのテキストレンダリングの品質を "SingleBitPerPixel" に設定します。
barCode1.TextRenderingHint = System.Drawing.Text.TextRenderingHint.SingleBitPerPixel;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
' バーコードメッセージのテキストレンダリングの品質を "SingleBitPerPixel" に設定します。
BarCode1.TextRenderingHint = System.Drawing.Text.TextRenderingHint.SingleBitPerPixel
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.Type プロパティ

BarCodeType プロパティ

バーコードの種類を設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public BarCodeType Type { get; set; }
Public Property Type As BarCodeType
    Get
    Set

プロパティ値

型: BarCodeType
バーコードのタイプを表す BarCodeType。(既定値：BarCodeType.JAN13)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
// 生成するバーコードイメージを "JAN13" に設定します。
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
' 生成するバーコードイメージを "JAN13" に設定します。
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.Unit プロパティ

BarCodeUnit プロパティ

バーコードの生成単位を設定、取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Unit Unit { get; set; }
Public Property Unit As Unit
    Get
    Set

プロパティ値

型: Unit
バーコードの生成単位を表す Unit。(既定値：Unit.Pixel)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
// バーコードイメージの生成単位を "ミリ(mm)" に設定します。
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Millimeter;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
' バーコードイメージの生成単位を "ミリ(mm)" に設定します。
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Millimeter
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.Value プロパティ

BarCodeValue プロパティ

バーコードデータを設定、取得します。(文字列)

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Value { get; set; }
Public Property Value As String
    Get
    Set

プロパティ値

型: String
バーコードデータを表す string。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
// バーコードデータを設定します。 (文字列)
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
' バーコードデータを設定します。 (文字列)
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.ValueEncoding プロパティ

BarCodeValueEncoding プロパティ

バーコードデータのエンコード方式を設定、取得します。(QRCode, PDF417)

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ValueEncoding ValueEncoding { get; set; }
Public Property ValueEncoding As ValueEncoding
    Get
    Set

プロパティ値

型: ValueEncoding
バーコードデータのエンコード方式を表す ValueEncoding。(既定値：ValueEncoding.ShiftJIS)
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode;
// バーコードデータのエンコード方式を "UTF-8" に設定します。
barCode1.ValueEncoding = AdvanceSoftware.ASReport.BarCode.ValueEncoding.UTF8;
barCode1.Value = "日本語";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.QRCode
' バーコードデータのエンコード方式を "UTF-8" に設定します。
BarCode1.ValueEncoding = AdvanceSoftware.ASReport.BarCode.ValueEncoding.UTF8
BarCode1.Value = "日本語"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.WhiteBarRevision プロパティ

BarCodeWhiteBarRevision プロパティ

白バーのドット補正値を設定、取得します。(Code128、GS1-128(旧称:EAN/UCC-128)、公共料金等代理収納 GS1-128)

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int WhiteBarRevision { get; set; }
Public Property WhiteBarRevision As Integer
    Get
    Set

プロパティ値

型: Int32
白バーのドット補正値を表す int。(既定値：0)
解説
Unit プロパティの値が、Unit.Pixel の場合、有効になります。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Code128;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
// 白バーのドット補正値を "+2" に設定します。
barCode1.WhiteBarRevision = 2;
barCode1.Value = "12345ABCDE";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.Code128
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
' 白バーのドット補正値を "+2" に設定します。
BarCode1.WhiteBarRevision = 2
BarCode1.Value = "12345ABCDE"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.Zoom プロパティ

BarCodeZoom プロパティ

倍率を設定、取得します。(JAN、UPC、ITF)

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int Zoom { get; set; }
Public Property Zoom As Integer
    Get
    Set

プロパティ値

型: Int32
バーコードの倍率を表す int。(既定値：100)
解説

設定範囲(JAN、UPC)：50 ～ 200

設定範囲(ITF)：25 ～ 120

例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
// バーコードイメージの表示倍率を "200%" に設定します。
barCode1.Zoom = 200;
barCode1.Value = "1234567890123";
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
' バーコードイメージの表示倍率を "200%" に設定します。
BarCode1.Zoom = 200
BarCode1.Value = "1234567890123"
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode メソッド

BarCode 型は下記のメンバーを公開します。

メソッド
名前 | 説明
GetBarCodeImage(ImageFormat) | バーコードのイメージを作成します。
GetBarCodeImage(ImageFormat, Boolean) | バーコードのイメージを作成します。
GetScaleSize | 指定した単位でバーコードのサイズを取得します。
SetLicense(Stream) | ライセンス情報を設定します。
SetLicense(String) | ライセンス情報を設定します。
トップ
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.GetBarCodeImage メソッド

BarCodeGetBarCodeImage メソッド

オーバーロードの一覧
名前 | 説明
GetBarCodeImage(ImageFormat) | バーコードのイメージを作成します。
GetBarCodeImage(ImageFormat, Boolean) | バーコードのイメージを作成します。
トップ
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.GetBarCodeImage メソッド (ImageFormat)

BarCodeGetBarCodeImage メソッド (ImageFormat)

バーコードのイメージを作成します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Image GetBarCodeImage(
    ImageFormat format
)
Public Function GetBarCodeImage (
    format As ImageFormat
) As Image

パラメーター

format
型: System.Drawing.ImagingImageFormat
保存する Image のImageFormat。

戻り値

型: Image
このメソッドが作成する Image。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
// バーコードイメージ (ビットマップ) を生成します。
Image imgBarCode = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
' バーコードイメージ (ビットマップ) を生成します。
Dim imgBarCode As Image = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp)
関連項目

参照

BarCode クラス
GetBarCodeImage オーバーロード
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.GetBarCodeImage メソッド (ImageFormat, Boolean)

BarCodeGetBarCodeImage メソッド (ImageFormat, Boolean)

バーコードのイメージを作成します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Image GetBarCodeImage(
    ImageFormat format,
    bool resolution
)
Public Function GetBarCodeImage (
    format As ImageFormat,
    resolution As Boolean
) As Image

パラメーター

format
型: System.Drawing.ImagingImageFormat
保存する Image のImageFormat。
resolution
型: SystemBoolean
DpiX プロパティ、DpiY プロパティの解像度で Bitmap を作成する場合、true を設定します。

戻り値

型: Image
このメソッドが作成する Image。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
barCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel;
barCode1.DpiX = 600;
barCode1.DpiY = 600;
barCode1.Value = "1234567890123";
// バーコードイメージ (ビットマップ) を DpiX, DpiY プロパティの解像度で生成します。
Image imgBarCode = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp, true);
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
BarCode1.Unit = AdvanceSoftware.ASReport.BarCode.Unit.Pixel
BarCode1.DpiX = 600
BarCode1.DpiY = 600
BarCode1.Value = "1234567890123"
' バーコードイメージ (ビットマップ) を DpiX, DpiY プロパティの解像度で生成します。
Dim imgBarCode As Image = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp, True)
関連項目

参照

BarCode クラス
GetBarCodeImage オーバーロード
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.GetScaleSize メソッド

BarCodeGetScaleSize メソッド

指定した単位でバーコードのサイズを取得します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public BarCodeSizeD GetScaleSize(
    Unit unit
)
Public Function GetScaleSize (
    unit As Unit
) As BarCodeSizeD

パラメーター

unit
型: AdvanceSoftware.ASReport.BarCodeUnit
取得するサイズの単位を表す Unit 列挙体。

戻り値

型: BarCodeSizeD
バーコードのサイズ。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
barCode1.Value = "1234567890123";
AdvanceSoftware.ASReport.BarCode.BarCodeSizeD barCodeSizeD;
// バーコードイメージのサイズを ミリ(mm) 単位で取得します。
barCodeSizeD = barCode1.GetScaleSize(AdvanceSoftware.ASReport.BarCode.Unit.Millimeter);
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
BarCode1.Value = "1234567890123"
Dim BarCodeSizeD As AdvanceSoftware.ASReport.BarCode.BarCodeSizeD
' バーコードイメージのサイズを ミリ(mm) 単位で取得します。
BarCodeSizeD = BarCode1.GetScaleSize(AdvanceSoftware.ASReport.BarCode.Unit.Millimeter)
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.SetLicense メソッド

BarCodeSetLicense メソッド

オーバーロードの一覧
名前 | 説明
SetLicense(Stream) | ライセンス情報を設定します。
SetLicense(String) | ライセンス情報を設定します。
トップ
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.SetLicense メソッド (Stream)

BarCodeSetLicense メソッド (Stream)

ライセンス情報を設定します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void SetLicense(
    Stream stream
)
Public Sub SetLicense (
    stream As Stream
)

パラメーター

stream
型: System.IOStream
ライセンスファイルのストリーム
解説
SetLicense メソッドはインスタンスごとに 1 回呼び出してください。バーコード出力のたびに呼び出す必要はありません。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
// ライセンス情報を設定します。
barCode1.SetLicense(licenseStream);
// 複数のバーコードを作成します。
for (int i = 0; i < 5; i++)
{
    // ここで毎回呼び出す必要はありません。
    //barCode1.SetLicense(licenseStream);

    barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
    barCode1.Value = "1234567890123";
    Image imgBarCode = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
}
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
' ライセンス情報を設定します。
BarCode1.SetLicense(licenseStream)
' 複数のバーコードを作成します。
For i As Integer = 0 To 4
    ' ここで毎回呼び出す必要はありません。
    'BarCode1.SetLicense(licenseStream)

    BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
    BarCode1.Value = "1234567890123"
    Dim imgBarCode As Image = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp)
Next
関連項目

参照

BarCode クラス
SetLicense オーバーロード
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.SetLicense メソッド (String)

BarCodeSetLicense メソッド (String)

ライセンス情報を設定します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void SetLicense(
    string path
)
Public Sub SetLicense (
    path As String
)

パラメーター

path
型: SystemString
ライセンスファイルのパス
解説
SetLicense メソッドはインスタンスごとに 1 回呼び出してください。バーコード出力のたびに呼び出す必要はありません。
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
// ライセンス情報を設定します。
barCode1.SetLicense(@"C:\AdvanceSoftware.ASReport.License.xml");
// 複数のバーコードを作成します。
for (int i = 0; i < 5; i++)
{
    // ここで毎回呼び出す必要はありません。
    //barCode1.SetLicense(@"C:\AdvanceSoftware.ASReport.License.xml");

    barCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13;
    barCode1.Value = "1234567890123";
    Image imgBarCode = barCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp);
}
' バーコードクラスのインスタンス生成
BarCode1 = New AdvanceSoftware.ASReport.BarCode.BarCode()
' ライセンス情報を設定します。
BarCode1.SetLicense("C:\AdvanceSoftware.ASReport.License.xml")
' 複数のバーコードを作成します。
For i As Integer = 0 To 4
    ' ここで毎回呼び出す必要はありません。
    'BarCode1.SetLicense("C:\AdvanceSoftware.ASReport.License.xml")

    BarCode1.Type = AdvanceSoftware.ASReport.BarCode.BarCodeType.JAN13
    BarCode1.Value = "1234567890123"
    Dim imgBarCode As Image = BarCode1.GetBarCodeImage(System.Drawing.Imaging.ImageFormat.Bmp)
Next
関連項目

参照

BarCode クラス
SetLicense オーバーロード
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode イベント

BarCode 型は下記のメンバーを公開します。

イベント
名前 | 説明
Error | バーコードの作成に失敗した時に発生します。
トップ
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCode.Error イベント

BarCodeError イベント

バーコードの作成に失敗した時に発生します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public event BarCodeErrorEventHandler Error
Public Event Error As BarCodeErrorEventHandler

値

型: AdvanceSoftware.ASReport.BarCodeBarCodeErrorEventHandler
例
C#
VB
コピー
// バーコードクラスのインスタンス生成
private AdvanceSoftware.ASReport.BarCode.BarCode barCode1 = new AdvanceSoftware.ASReport.BarCode.BarCode();
private void InitializeComponent()
{
    // バーコードクラスのエラーイベントに barCode1_Error メソッドを関連付け
    this.barCode1.Error += new AdvanceSoftware.ASReport.BarCode.BarCodeErrorEventHandler(BarCode1_Error);
}
// バーコードクラスのエラーイベント
private void BarCode1_Error(object sender, AdvanceSoftware.ASReport.BarCode.BarCodeErrorEventArgs e)
{
    MessageBox.Show(barCode1.ErrorMessage);
}
' バーコードクラスのインスタンス生成 (WithEvents)
Private WithEvents BarCode1 As AdvanceSoftware.ASReport.BarCode.BarCode = New AdvanceSoftware.ASReport.BarCode.BarCode()
' バーコードクラスのエラーイベント
Private Sub BarCode1_Error(ByVal sender As Object, ByVal e As AdvanceSoftware.ASReport.BarCode.BarCodeErrorEventArgs) Handles BarCode1.Error
    MessageBox.Show(BarCode1.ErrorMessage)
End Sub
関連項目

参照

BarCode クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCodeErrorEventArgs クラス

BarCode クラスの Error イベントのデータを提供します。
継承階層
SystemObject
SystemEventArgs
AdvanceSoftware.ASReport.BarCodeBarCodeErrorEventArgs

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class BarCodeErrorEventArgs : EventArgs
Public Class BarCodeErrorEventArgs
    Inherits EventArgs

BarCodeErrorEventArgs 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
Public プロパティ | ErrorNo | エラーナンバーを処理します。
トップ
関連項目

参照

AdvanceSoftware.ASReport.BarCode 名前空間


BarCodeErrorEventArgs プロパティ

BarCodeErrorEventArgs 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
Public プロパティ | ErrorNo | エラーナンバーを処理します。
トップ
関連項目

参照

BarCodeErrorEventArgs クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCodeErrorEventArgs.ErrorNo プロパティ

BarCodeErrorEventArgsErrorNo プロパティ

エラーナンバーを処理します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo ErrorNo { get; }
Public ReadOnly Property ErrorNo As ErrorNo
    Get

プロパティ値

型: ErrorNo
関連項目

参照

BarCodeErrorEventArgs クラス
AdvanceSoftware.ASReport.BarCode 名前空間


BarCodeErrorEventHandler デリゲート

BarCode クラスの Error イベントを処理するメソッドを表します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public delegate void BarCodeErrorEventHandler(
    Object sender,
    BarCodeErrorEventArgs e
)
Public Delegate Sub BarCodeErrorEventHandler (
    sender As Object,
    e As BarCodeErrorEventArgs
)

パラメーター

sender
型: SystemObject
e
型: AdvanceSoftware.ASReport.BarCodeBarCodeErrorEventArgs
関連項目

参照

AdvanceSoftware.ASReport.BarCode 名前空間


BarCodeSizeD 構造体

BarCodeSizeD 構造体

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public struct BarCodeSizeD
Public Structure BarCodeSizeD

BarCodeSizeD 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | Height | 高さ
Public フィールド | Width | 幅
トップ
関連項目

参照

AdvanceSoftware.ASReport.BarCode 名前空間


BarCodeSizeD フィールド

BarCodeSizeD 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | Height | 高さ
Public フィールド | Width | 幅
トップ
関連項目

参照

BarCodeSizeD 構造体
AdvanceSoftware.ASReport.BarCode 名前空間


BarCodeSizeD.Height フィールド

BarCodeSizeDHeight フィールド

高さ

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double Height
Public Height As Double

フィールド値

型: Double
関連項目

参照

BarCodeSizeD 構造体
AdvanceSoftware.ASReport.BarCode 名前空間


BarCodeSizeD.Width フィールド

BarCodeSizeDWidth フィールド

幅

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double Width
Public Width As Double

フィールド値

型: Double
関連項目

参照

BarCodeSizeD 構造体
AdvanceSoftware.ASReport.BarCode 名前空間


BarCodeType 列挙体

バーコードの種類を指定します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum BarCodeType
Public Enumeration BarCodeType
メンバー
メンバー | 値 | 説明
JAN13 | 0 | JAN コード(標準バージョン 13 桁)
JAN8 | 1 | JAN コード(短縮バージョン 8 桁)
UPCA | 2 | UPC コード(A バージョン)
UPCE | 3 | UPC コード(E バージョン)
ITF6 | 4 | ITF コード(アドオンバージョン 6 桁)
ITF14 | 5 | ITF コード(標準バージョン 14 桁)
ITF16 | 6 | ITF コード(拡張バージョン 16 桁)
ITF | 7 | ITF コード(自由桁)
Codabar | 8 | Codabar(NW-7)
Code39 | 9 | Code39
Code128 | 10 | Code128
GS1 | 11 | GS1-128(旧：UCC/EAN128)
GS1Fixed | 12 | 公共料金等代理収納 GS1-128
CustomerBarCode | 13 | カスタマバーコード
QRCode | 14 | QR コード
PDF417 | 15 | PDF417
関連項目

参照

AdvanceSoftware.ASReport.BarCode 名前空間


CheckPattern 列挙体

チェックデジットの計算方法を指定します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum CheckPattern
Public Enumeration CheckPattern
メンバー
メンバー | 値 | 説明
Modulus16 | 0 | モジュラス 16
Modulus10Weight2 | 1 | モジュラス 10 / ウェイト 2
Modulus10Weight3 | 2 | モジュラス 10 / ウェイト 3
Modulus11 | 3 | モジュラス 11
Modulus11Weight | 4 | 加重モジュラス 11
SevenCheckDR | 5 | 7 チェック DR
Runes | 6 | ルーンズ
関連項目

参照

AdvanceSoftware.ASReport.BarCode 名前空間


Codeset 列挙体

スタートコードセットを指定します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum Codeset
Public Enumeration Codeset
メンバー
メンバー | 値 | 説明
Auto | 0 | 自動でコードセットを設定
CodesetA | 1 | コードセット A
CodesetB | 2 | コードセット B
CodesetC | 3 | コードセット C
関連項目

参照

AdvanceSoftware.ASReport.BarCode 名前空間


ErrorNo 列挙体

エラーナンバーを示す識別子を指定します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ErrorNo
Public Enumeration ErrorNo
メンバー
メンバー | 値 | 説明
NoError | 0 | エラーなし
Type | 101 | Type の設定に失敗しました。
Unit | 102 | Unit の設定に失敗しました。
Zoom | 103 | Zoom の設定に失敗しました。
Point | 104 | Point の設定に失敗しました。
Rotate | 105 | Rotate の設定に失敗しました。
DpiX | 106 | DpiX の設定に失敗しました。
DpiY | 107 | DpiY の設定に失敗しました。
BlackRatio | 108 | BlackRatio の設定に失敗しました。
BarHeight | 109 | BarHeight の設定に失敗しました。
BarWidth | 110 | BarWidth の設定に失敗しました。
Element | 111 | Element の設定に失敗しました。
Quiet | 112 | Quiet の設定に失敗しました。
BarRatio | 113 | BarRatio の設定に失敗しました。
CharGap | 114 | CharGap の設定に失敗しました。
CharSize | 115 | CharSize の設定に失敗しました。
CheckPattern | 116 | CheckPattern の設定に失敗しました。
CodeSet | 117 | CodeSet の設定に失敗しました。
Value | 118 | Value の設定に失敗しました。
CheckDigit | 119 | CheckDigit の設定に失敗しました。
ValueEncoding | 120 | ValueEncoding の設定に失敗しました。
QRModel | 200 | QRModel の設定に失敗しました。
QRVersion | 201 | QRVersion の設定に失敗しました。
QRLevel | 202 | QRLevel の設定に失敗しました。
QRConnectAct | 203 | 連結モードが間違っています。
QRConnect | 204 | QRConnect の設定に失敗しました。
QRSourceIsEmpty | 205 | データが空です。
QRSourceIsLarge | 206 | データが長すぎます。
QRConnectPos | 207 | 連結番号が違います。
QREscSeq | 208 | エスケープシーケンスが違います。
QRECIAssin | 209 | ECI 割り当て番号が違います。
QRKanji | 210 | 漢字コードが違います。
QRNumChar | 211 | 数字モードに適合しない文字が含まれています。
QRAnkChar | 212 | 英数字モードに適合しない文字が含まれています。
QRByteChar | 213 | バイトモードに適合しない文字が含まれています。
QRKanjiChar | 214 | 漢字モードに適合しない文字が含まれています。
QRSymbolOver | 215 | シンボルデータ領域を超えました。
QRConnectMode | 216 | 連結動作 2 以外で連結モードが設定されています。
QRTooManySymbol | 217 | 連結シンボル数が 16 を超えました。
QRMask | 218 | QRMask の設定に失敗しました。
PDFModel | 300 | PDFModel の設定に失敗しました。
PDFColumn | 301 | PDFColumn の設定に失敗しました。
PDFRow | 302 | PDFRow の設定に失敗しました。
PDFLevel | 303 | PDFLevel の設定に失敗しました。
PDFAspectRatio | 304 | 縦横比が違います。
PDFSourceIsEmpty | 305 | データが空です。
PDFSourceIsLarge | 306 | データが長すぎます。
PDFGLIValue | 307 | GLI 値が違います。
PDFNumChar | 308 | 数字モードに適合しない文字が含まれています。
PDFTextChar | 309 | テキストモードに適合しない文字が含まれています。
PDFByteChar | 310 | バイトモードに適合しない文字が含まれています。
PDFSymbolOver | 311 | シンボルデータ領域を超えました。
LicenseNotFound | 400 | ライセンス情報が見つかりません。
LicenseFileAccess | 401 | ライセンスファイルにアクセスできません。
LicenseLoad | 402 | ライセンス情報が読み込めません。
License | 403 | ライセンス認証エラー。
Platform | 404 | 動作環境エラー。
関連項目

参照

AdvanceSoftware.ASReport.BarCode 名前空間


MessageAlign 列挙体

バーコードメッセージの表示横位置を指定します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum MessageAlign
Public Enumeration MessageAlign
メンバー
メンバー | 値 | 説明
Left | 0 | 左詰め
Center | 1 | 中央揃え
関連項目

参照

AdvanceSoftware.ASReport.BarCode 名前空間


PDFModel 列挙体

PDF417 シンボルを指定します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum PDFModel
Public Enumeration PDFModel
メンバー
メンバー | 値 | 説明
Default | 0 | 標準の PDF417
Truncated | 1 | 簡易 PDF417
関連項目

参照

AdvanceSoftware.ASReport.BarCode 名前空間


QRConnect 列挙体

QR コードの連結モードを指定します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum QRConnect
Public Enumeration QRConnect
メンバー
メンバー | 値 | 説明
NotConnect | 0 | 連結 QR コードを作成しない
AutoConnect | 1 | 連結QRコードを作成(自動)
ManualConnect | 2 | 連結 QR コードを作成(手動)
関連項目

参照

AdvanceSoftware.ASReport.BarCode 名前空間


QRLevel 列挙体

QR コードの誤り訂正レベルを指定します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum QRLevel
Public Enumeration QRLevel
メンバー
メンバー | 値 | 説明
LevelL | 0 | L(復元率 7%)
LevelM | 1 | M(復元率 15%)
LevelQ | 2 | Q(復元率 25%)
LevelH | 3 | H(復元率 30%)
関連項目

参照

AdvanceSoftware.ASReport.BarCode 名前空間


QRMask 列挙体

QR コードのマスクパターンを指定します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum QRMask
Public Enumeration QRMask
メンバー
メンバー | 値 | 説明
MaskAuto | 0 | 自動でマスク処理を行う
Mask000 | 1 | マスクパターン参照子 000
Mask001 | 2 | マスクパターン参照子 001
Mask010 | 3 | マスクパターン参照子 010
Mask011 | 4 | マスクパターン参照子 011
Mask100 | 5 | マスクパターン参照子 100
Mask101 | 6 | マスクパターン参照子 101
Mask110 | 7 | マスクパターン参照子 110
Mask111 | 8 | マスクパターン参照子 111
関連項目

参照

AdvanceSoftware.ASReport.BarCode 名前空間


QRModel 列挙体

QR コードのモデルを指定します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum QRModel
Public Enumeration QRModel
メンバー
メンバー | 値 | 説明
Model1 | 1 | モデル 1
Model2 | 2 | モデル 2
関連項目

参照

AdvanceSoftware.ASReport.BarCode 名前空間


QRVersion 列挙体

QR コードの型番を指定します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum QRVersion
Public Enumeration QRVersion
メンバー
メンバー | 値 | 説明
VersionAuto | 0 | 自動で型番を設定
Version1 | 1 | 1 型
Version2 | 2 | 2 型
Version3 | 3 | 3 型
Version4 | 4 | 4 型
Version5 | 5 | 5 型
Version6 | 6 | 6 型
Version7 | 7 | 7 型
Version8 | 8 | 8 型
Version9 | 9 | 9 型
Version10 | 10 | 10 型
Version11 | 11 | 11 型
Version12 | 12 | 12 型
Version13 | 13 | 13 型
Version14 | 14 | 14 型
Version15 | 15 | 15 型
Version16 | 16 | 16 型
Version17 | 17 | 17 型
Version18 | 18 | 18 型
Version19 | 19 | 19 型
Version20 | 20 | 20 型
Version21 | 21 | 21 型
Version22 | 22 | 22 型
Version23 | 23 | 23 型
Version24 | 24 | 24 型
Version25 | 25 | 25 型
Version26 | 26 | 26 型
Version27 | 27 | 27 型
Version28 | 28 | 28 型
Version29 | 29 | 29 型
Version30 | 30 | 30 型
Version31 | 31 | 31 型
Version32 | 32 | 32 型
Version33 | 33 | 33 型
Version34 | 34 | 34 型
Version35 | 35 | 35 型
Version36 | 36 | 36 型
Version37 | 37 | 37 型
Version38 | 38 | 38 型
Version39 | 39 | 39 型
Version40 | 40 | 40 型
関連項目

参照

AdvanceSoftware.ASReport.BarCode 名前空間


Rotate 列挙体

バーコードの回転方向を指定します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum Rotate
Public Enumeration Rotate
メンバー
メンバー | 値 | 説明
Rotate0 | 0 | 0 度
Rotate90 | 1 | 90 度
Rotate180 | 2 | 180 度
Rotate270 | 3 | 270 度
関連項目

参照

AdvanceSoftware.ASReport.BarCode 名前空間


Unit 列挙体

バーコードの生成単位を指定します。

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum Unit
Public Enumeration Unit
メンバー
メンバー | 値 | 説明
Pixel | 0 | ピクセル
Millimeter | 1 | ミリ
Inch | 2 | インチ
Point | 3 | ポイント
関連項目

参照

AdvanceSoftware.ASReport.BarCode 名前空間


ValueEncoding 列挙体

バーコードデータのエンコード方式を指定します。(QRCode, PDF417)

名前空間: AdvanceSoftware.ASReport.BarCode
アセンブリ: AdvanceSoftware.ASReport.BarCode (in AdvanceSoftware.ASReport.BarCode.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ValueEncoding
Public Enumeration ValueEncoding
メンバー
メンバー | 値 | 説明
ShiftJIS | 0 | Shift-JIS
UTF8 | 1 | UTF-8
関連項目

参照

AdvanceSoftware.ASReport.BarCode 名前空間


AdvanceSoftware.ASReport.Wpf 名前空間

AdvanceSoftware.ASReport.Wpf 名前空間には、WPF 用ビューアが含まれています。
クラス
 | クラス | 説明
Public クラス | Printer | 帳票の出力先プリンタの情報を扱う Printer オブジェクトです。ViewerControl オブジェクトを通じてこのクラスにアクセスします。
Public クラス | ViewerControl | 帳票を出力する ViewerControl オブジェクトです。
列挙体
 | 列挙体 | 説明
Public 列挙体 | ReportFrame | 帳票の枠組みをプレビュー・印刷するかを指定します。
Public 列挙体 | SaveKind | ファイル保存ダイアログのファイルの種類に設定する形式を指定します。
Public 列挙体 | ToolBarIcon | ツールバーアイコンの大きさを指定します。
Public 列挙体 | ToolBarIconType | ツールバーアイコンのタイプを指定します。
Public 列挙体 | ViewerStatus | ViewerStatus


Printer クラス

帳票の出力先プリンタの情報を扱う Printer オブジェクトです。ViewerControl オブジェクトを通じてこのクラスにアクセスします。
継承階層
SystemObject
AdvanceSoftware.ASReport.WpfPrinter

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Printer
Public Class Printer

Printer 型は下記のメンバーを公開します。

プロパティ
名前 | 説明
CopyCount | 部数を設定、取得します。
Duplexing | 両面印刷を設定、取得します。
InputBin | 用紙トレイを設定、取得します。
JobPages | 1ジョブあたりのページ数を指定します。
Name | プリンタ名を取得します。
PageResolution | 解像度を設定、取得します。
トップ
関連項目

参照

AdvanceSoftware.ASReport.Wpf 名前空間


Printer プロパティ

Printer 型は下記のメンバーを公開します。

プロパティ
名前 | 説明
CopyCount | 部数を設定、取得します。
Duplexing | 両面印刷を設定、取得します。
InputBin | 用紙トレイを設定、取得します。
JobPages | 1ジョブあたりのページ数を指定します。
Name | プリンタ名を取得します。
PageResolution | 解像度を設定、取得します。
トップ
関連項目

参照

Printer クラス
AdvanceSoftware.ASReport.Wpf 名前空間


Printer.CopyCount プロパティ

PrinterCopyCount プロパティ

部数を設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int CopyCount { get; set; }
Public Property CopyCount As Integer
    Get
    Set

プロパティ値

型: Int32
印刷部数
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// 印刷部数を "3 部" に設定します。
viewerControl1.Printer.CopyCount = 3;
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' 印刷部数を "3 部" に設定します。
ViewerControl1.Printer.CopyCount = 3
ViewerControl1.Document = CellReport1.Document
関連項目

参照

Printer クラス
AdvanceSoftware.ASReport.Wpf 名前空間


Printer.Duplexing プロパティ

PrinterDuplexing プロパティ

両面印刷を設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Duplexing Duplexing { get; set; }
Public Property Duplexing As Duplexing
    Get
    Set

プロパティ値

型: Duplexing
両面印刷の設定を表す Duplexing。
解説
ExcelMode = true 時は両面印刷の設定は反映されません。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1-99999");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// 1 ジョブあたりのページ数を全ページに設定します。
viewerControl1.Printer.JobPages = 0;
// 両面印刷を設定します。
viewerControl1.Printer.Duplexing = System.Printing.Duplexing.TwoSidedShortEdge;
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1-99999")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' 1 ジョブあたりのページ数を全ページに設定します。
ViewerControl1.Printer.JobPages = 0
' 両面印刷を設定します。
ViewerControl1.Printer.Duplexing = System.Printing.Duplexing.TwoSidedShortEdge
ViewerControl1.Document = CellReport1.Document
関連項目

参照

Printer クラス
AdvanceSoftware.ASReport.Wpf 名前空間


Printer.InputBin プロパティ

PrinterInputBin プロパティ

用紙トレイを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public InputBin InputBin { get; set; }
Public Property InputBin As InputBin
    Get
    Set

プロパティ値

型: InputBin
印刷トレイの設定を表す InputBin。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// 給紙方法を "手差し" に設定します。
viewerControl1.Printer.InputBin = System.Printing.InputBin.Manual;
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' 給紙方法を "手差し" に設定します。
ViewerControl1.Printer.InputBin = System.Printing.InputBin.Manual
ViewerControl1.Document = CellReport1.Document
関連項目

参照

Printer クラス
AdvanceSoftware.ASReport.Wpf 名前空間


Printer.JobPages プロパティ

PrinterJobPages プロパティ

1ジョブあたりのページ数を指定します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int JobPages { get; set; }
Public Property JobPages As Integer
    Get
    Set

プロパティ値

型: Int32
ページ数(既定値：1 全ページ:0)
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1-99999");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// 1 ジョブあたりのページ数を全ページに設定します。
viewerControl1.Printer.JobPages = 0;
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1-99999")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' 1 ジョブあたりのページ数を全ページに設定します。
ViewerControl1.Printer.JobPages = 0
ViewerControl1.Document = CellReport1.Document
関連項目

参照

Printer クラス
AdvanceSoftware.ASReport.Wpf 名前空間


Printer.Name プロパティ

PrinterName プロパティ

プリンタ名を取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string Name { get; }
Public ReadOnly Property Name As String
    Get

プロパティ値

型: String
プリンタ名
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// プリンタ名を取得します。
string name = viewerControl1.Printer.Name;
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' プリンタ名を取得します。
Dim name As String = ViewerControl1.Printer.Name
ViewerControl1.Document = CellReport1.Document
関連項目

参照

Printer クラス
AdvanceSoftware.ASReport.Wpf 名前空間


Printer.PageResolution プロパティ

PrinterPageResolution プロパティ

解像度を設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PageResolution PageResolution { get; set; }
Public Property PageResolution As PageResolution
    Get
    Set

プロパティ値

型: PageResolution
解像度
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// X、Y 方向の解像度を "600" に設定します。
System.Printing.PageResolution pageResolution = new System.Printing.PageResolution(600, 600);
viewerControl1.Printer.PageResolution = pageResolution;
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' X、Y 方向の解像度を "600" に設定します。
Dim pageResolution As System.Printing.PageResolution = New System.Printing.PageResolution(600, 600)
ViewerControl1.Printer.PageResolution = pageResolution
ViewerControl1.Document = CellReport1.Document
関連項目

参照

Printer クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ReportFrame 列挙体

帳票の枠組みをプレビュー・印刷するかを指定します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ReportFrame
Public Enumeration ReportFrame
メンバー
メンバー | 値 | 説明
All | 0 | プレビュー・印刷時に枠組みを表示します。
Preview | 1 | プレビュー時のみ枠組みを表示します。
Print | 2 | 印刷時のみ枠組みを表示します。
None | 3 | 枠組みを非表示にします。
関連項目

参照

AdvanceSoftware.ASReport.Wpf 名前空間


SaveKind 列挙体

ファイル保存ダイアログのファイルの種類に設定する形式を指定します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum SaveKind
Public Enumeration SaveKind
メンバー
メンバー | 値 | 説明
All | 0 | Excel ファイルと PDF ファイルを設定します。
ExcelOnly | 1 | Excel ファイルのみ設定します。
PdfOnly | 2 | PDF ファイルのみ設定します。
関連項目

参照

AdvanceSoftware.ASReport.Wpf 名前空間


ToolBarIcon 列挙体

ツールバーアイコンの大きさを指定します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ToolBarIcon
Public Enumeration ToolBarIcon
メンバー
メンバー | 値 | 説明
SmallIcon | 0 | 小
MiddleIcon | 1 | 中
LargeIcon | 2 | 大
関連項目

参照

AdvanceSoftware.ASReport.Wpf 名前空間


ToolBarIconType 列挙体

ツールバーアイコンのタイプを指定します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ToolBarIconType
Public Enumeration ToolBarIconType
メンバー
メンバー | 値 | 説明
Type1 | 0 | タイプ１
Type2 | 1 | タイプ２
関連項目

参照

AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl クラス

帳票を出力する ViewerControl オブジェクトです。
ViewerControl
継承階層
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
AdvanceSoftware.ASReport.WpfViewerControl

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class ViewerControl : UserControl,
    IComponentConnector
Public Class ViewerControl
    Inherits UserControl
    Implements IComponentConnector

ViewerControl 型は下記のメンバーを公開します。

コンストラクター
 | 名前 | 説明
Public メソッド | ViewerControl | コンストラクター
トップ
プロパティ
 | 名前 | 説明
 | Document | プレビューする Document を設定します。
 | EnableAllButton | ツールバーの全体を表示ボタンを有効にするかどうかを設定、取得します。
 | EnableAsideButton | ツールバーの横に合わせるボタンを有効にするかどうかを設定、取得します。
 | EnableFirstButton | ツールバーの最初のページボタンを有効にするかどうかを設定、取得します。
 | EnableLastButton | ツールバーの最後のページボタンを有効にするかどうかを設定、取得します。
 | EnableLengthwiseButton | ツールバーの縦に合わせるボタンを有効にするかどうかを設定、取得します。
 | EnableNextButton | ツールバーの次ページボタンを有効にするかどうかを設定、取得します。
 | EnablePrevButton | ツールバーの前ページボタンを有効にするかどうかを設定、取得します。
 | EnablePrintButton | ツールバーの印刷ボタンを有効にするかどうかを設定、取得します。
 | EnableSaveButton | ツールバーの保存ボタンを有効にするかどうかを設定、取得します。
 | EnableZoomButton | ツールバーの倍率ボタンを有効にするかどうかを設定、取得します。
 | ErrorMessage | エラーメッセージを取得します。
 | ErrorNo | エラーナンバーを取得します。
 | InternalViewZoom | 表示する倍率を取得します。
 | IsPdfSaved | PDF ファイルに保存されたかどうかを取得します。
 | IsPrinted | 印刷されたかどうかを取得します。
 | IsSaved | 保存されたかどうかを取得します。
 | OverFit | 帳票を 1 ページに収まるよう表示するかを設定、取得します。
Public プロパティ | Owner | コントロールのオーナーを設定、取得します。
 | PageCount | 総ページ数を取得します。
 | PrintDocumentName | 印刷のドキュメント名を設定します。
Public プロパティ | Printer | Printer を取得します。
 | PrinterName | 現在選択されているプリンタ名を取得します。
 | PrintType | 印刷タイプを設定、取得します。
 | ProgressDescription | プログレスダイアログのユーザーメッセージを設定、取得します。
 | SaveFileName | 保存時のデフォルトファイル名を設定、取得します。
 | SaveKind | 保存時のファイルの種類を設定、取得します。
 | SaveMessage | 保存処理終了後に表示するメッセージ文字列を設定します。
 | ShowAllButton | ツールバーの全体を表示ボタンを表示するかどうかを設定、取得します。
 | ShowAsideButton | ツールバーの横に合わせるボタンを表示するかどうかを設定、取得します。
 | ShowFirstButton | ツールバーの最初のページボタンを表示するかどうかを設定、取得します。
 | ShowInvalidArea | 印字可能領域を表示するかどうかを設定、取得します。
 | ShowLastButton | ツールバーの最後のページボタンを表示するかどうかを設定、取得します。
 | ShowLengthwiseButton | ツールバーの縦に合わせるボタンを表示するかどうかを設定、取得します。
 | ShowMarginArea | 余白領域を表示するかどうかを設定、取得します。
 | ShowNextButton | ツールバーの次ページボタンを表示するかどうかを設定、取得します。
 | ShowPrevButton | ツールバーの前ページボタンを表示するかどうかを設定、取得します。
 | ShowPrintButton | ツールバーの印刷ボタンを表示するかどうかを設定、取得します。
 | ShowProgressDialog | プログレスダイアログを表示する、しないを設定、取得します。
 | ShowReportFrame | 帳票の枠組み(罫線、背景色)を表示するかどうかを設定、取得します。
 | ShowSaveButton | ツールバーの保存ボタンを表示するかどうかを設定、取得します。
 | ShowSheetName | ステータスバーのシート名を表示するかどうかを設定、取得します。
 | ShowStatusBar | ステータスバーを表示するかどうかを設定、取得します。
 | ShowToolBar | ツールバーを表示するかどうかを設定、取得します。
 | ShowUseExcelPrint | 印刷ダイアログの「Excel を使用して印刷する」チェックボックスを表示する、しないを設定、取得します。
 | ShowZoomButton | ツールバーの倍率ボタンを表示するかどうかを設定、取得します。
 | ToolBarIcon | ツールバーのアイコンのサイズを設定、取得します。
 | ToolBarIconType | ツールバーのアイコンのタイプを設定します。
 | ViewerStatus | プレビューコントロールのステータス(待機、動作中)を取得します。
 | ViewPage | 表示するページを設定、取得します。
 | ViewZoom | 表示する倍率を設定、取得します。
トップ
メソッド
 | 名前 | 説明
 | Clear | 帳票表示をクリアします。
Public メソッド | Dispose | Dispose メソッド
 | PrintOut | 印刷します。
 | PrintOut(String) | 印刷します。
 | PrintOut(String, String) | 印刷します。
 | PrintOut(String, String, Int32) | 印刷します。
 | SaveAs(String) | Excel ファイルに保存します。
 | SaveAs(String, ExcelVersion) | Excel ファイルに保存します。
 | SavePdf(Stream) | PDF ファイルに保存します。
 | SavePdf(String) | PDF ファイルに保存します。
 | SetPrinter | プリンタの設定をします。
トップ
イベント
名前 | 説明
Error | エラーイベント
Progress | プログレスイベント
トップ
関連項目

参照

AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl コンストラクター

コンストラクター

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ViewerControl()
Public Sub New
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl プロパティ

ViewerControl 型は下記のメンバーを公開します。

プロパティ
 | 名前 | 説明
 | Document | プレビューする Document を設定します。
 | EnableAllButton | ツールバーの全体を表示ボタンを有効にするかどうかを設定、取得します。
 | EnableAsideButton | ツールバーの横に合わせるボタンを有効にするかどうかを設定、取得します。
 | EnableFirstButton | ツールバーの最初のページボタンを有効にするかどうかを設定、取得します。
 | EnableLastButton | ツールバーの最後のページボタンを有効にするかどうかを設定、取得します。
 | EnableLengthwiseButton | ツールバーの縦に合わせるボタンを有効にするかどうかを設定、取得します。
 | EnableNextButton | ツールバーの次ページボタンを有効にするかどうかを設定、取得します。
 | EnablePrevButton | ツールバーの前ページボタンを有効にするかどうかを設定、取得します。
 | EnablePrintButton | ツールバーの印刷ボタンを有効にするかどうかを設定、取得します。
 | EnableSaveButton | ツールバーの保存ボタンを有効にするかどうかを設定、取得します。
 | EnableZoomButton | ツールバーの倍率ボタンを有効にするかどうかを設定、取得します。
 | ErrorMessage | エラーメッセージを取得します。
 | ErrorNo | エラーナンバーを取得します。
 | InternalViewZoom | 表示する倍率を取得します。
 | IsPdfSaved | PDF ファイルに保存されたかどうかを取得します。
 | IsPrinted | 印刷されたかどうかを取得します。
 | IsSaved | 保存されたかどうかを取得します。
 | OverFit | 帳票を 1 ページに収まるよう表示するかを設定、取得します。
Public プロパティ | Owner | コントロールのオーナーを設定、取得します。
 | PageCount | 総ページ数を取得します。
 | PrintDocumentName | 印刷のドキュメント名を設定します。
Public プロパティ | Printer | Printer を取得します。
 | PrinterName | 現在選択されているプリンタ名を取得します。
 | PrintType | 印刷タイプを設定、取得します。
 | ProgressDescription | プログレスダイアログのユーザーメッセージを設定、取得します。
 | SaveFileName | 保存時のデフォルトファイル名を設定、取得します。
 | SaveKind | 保存時のファイルの種類を設定、取得します。
 | SaveMessage | 保存処理終了後に表示するメッセージ文字列を設定します。
 | ShowAllButton | ツールバーの全体を表示ボタンを表示するかどうかを設定、取得します。
 | ShowAsideButton | ツールバーの横に合わせるボタンを表示するかどうかを設定、取得します。
 | ShowFirstButton | ツールバーの最初のページボタンを表示するかどうかを設定、取得します。
 | ShowInvalidArea | 印字可能領域を表示するかどうかを設定、取得します。
 | ShowLastButton | ツールバーの最後のページボタンを表示するかどうかを設定、取得します。
 | ShowLengthwiseButton | ツールバーの縦に合わせるボタンを表示するかどうかを設定、取得します。
 | ShowMarginArea | 余白領域を表示するかどうかを設定、取得します。
 | ShowNextButton | ツールバーの次ページボタンを表示するかどうかを設定、取得します。
 | ShowPrevButton | ツールバーの前ページボタンを表示するかどうかを設定、取得します。
 | ShowPrintButton | ツールバーの印刷ボタンを表示するかどうかを設定、取得します。
 | ShowProgressDialog | プログレスダイアログを表示する、しないを設定、取得します。
 | ShowReportFrame | 帳票の枠組み(罫線、背景色)を表示するかどうかを設定、取得します。
 | ShowSaveButton | ツールバーの保存ボタンを表示するかどうかを設定、取得します。
 | ShowSheetName | ステータスバーのシート名を表示するかどうかを設定、取得します。
 | ShowStatusBar | ステータスバーを表示するかどうかを設定、取得します。
 | ShowToolBar | ツールバーを表示するかどうかを設定、取得します。
 | ShowUseExcelPrint | 印刷ダイアログの「Excel を使用して印刷する」チェックボックスを表示する、しないを設定、取得します。
 | ShowZoomButton | ツールバーの倍率ボタンを表示するかどうかを設定、取得します。
 | ToolBarIcon | ツールバーのアイコンのサイズを設定、取得します。
 | ToolBarIconType | ツールバーのアイコンのタイプを設定します。
 | ViewerStatus | プレビューコントロールのステータス(待機、動作中)を取得します。
 | ViewPage | 表示するページを設定、取得します。
 | ViewZoom | 表示する倍率を設定、取得します。
トップ
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.Document プロパティ

ViewerControlDocument プロパティ

プレビューする Document を設定します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Document Document { set; }
Public WriteOnly Property Document As Document
    Set

プロパティ値

型: Document
解説
プレビューする Document。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// ビューアコントロールに帳票ドキュメントを設定します。
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' ビューアコントロールに帳票ドキュメントを設定します。
ViewerControl1.Document = CellReport1.Document
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.EnableAllButton プロパティ

ViewerControlEnableAllButton プロパティ

ツールバーの全体を表示ボタンを有効にするかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool EnableAllButton { get; set; }
Public Property EnableAllButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「全体を表示」ボタンを有効にしない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "全体を表示" ボタンを無効にします。
viewerControl1.EnableAllButton = false;
' ツールバーの "全体を表示" ボタンを無効にします。
ViewerControl1.EnableAllButton = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.EnableAsideButton プロパティ

ViewerControlEnableAsideButton プロパティ

ツールバーの横に合わせるボタンを有効にするかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool EnableAsideButton { get; set; }
Public Property EnableAsideButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「横に合わせる」ボタンを有効にしない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "横に合わせる" ボタンを無効にします。
viewerControl1.EnableAsideButton = false;
' ツールバーの "横に合わせる" ボタンを無効にします。
ViewerControl1.EnableAsideButton = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.EnableFirstButton プロパティ

ViewerControlEnableFirstButton プロパティ

ツールバーの最初のページボタンを有効にするかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool EnableFirstButton { get; set; }
Public Property EnableFirstButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「最初のページ」ボタンを有効にしない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "最初のページ" ボタンを無効にします。
viewerControl1.EnableFirstButton = false;
' ツールバーの "最初のページ" ボタンを無効にします。
ViewerControl1.EnableFirstButton = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.EnableLastButton プロパティ

ViewerControlEnableLastButton プロパティ

ツールバーの最後のページボタンを有効にするかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool EnableLastButton { get; set; }
Public Property EnableLastButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「最後のページ」ボタンを有効にしない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "最後のページ" ボタンを無効にします。
viewerControl1.EnableLastButton = false;
' ツールバーの "最後のページ" ボタンを無効にします。
ViewerControl1.EnableLastButton = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.EnableLengthwiseButton プロパティ

ViewerControlEnableLengthwiseButton プロパティ

ツールバーの縦に合わせるボタンを有効にするかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool EnableLengthwiseButton { get; set; }
Public Property EnableLengthwiseButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「縦に合わせる」ボタンを有効にしない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "縦に合わせる" ボタンを無効にします。
viewerControl1.EnableLengthwiseButton = false;
' ツールバーの "縦に合わせる" ボタンを無効にします。
ViewerControl1.EnableLengthwiseButton = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.EnableNextButton プロパティ

ViewerControlEnableNextButton プロパティ

ツールバーの次ページボタンを有効にするかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool EnableNextButton { get; set; }
Public Property EnableNextButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「次ページ」ボタンを有効にしない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "次ページ" ボタンを無効にします。
viewerControl1.EnableNextButton = false;
' ツールバーの "次ページ" ボタンを無効にします。
ViewerControl1.EnableNextButton = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.EnablePrevButton プロパティ

ViewerControlEnablePrevButton プロパティ

ツールバーの前ページボタンを有効にするかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool EnablePrevButton { get; set; }
Public Property EnablePrevButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「前ページ」ボタンを有効にしない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "前ページ" ボタンを無効にします。
viewerControl1.EnablePrevButton = false;
' ツールバーの "前ページ" ボタンを無効にします。
ViewerControl1.EnablePrevButton = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.EnablePrintButton プロパティ

ViewerControlEnablePrintButton プロパティ

ツールバーの印刷ボタンを有効にするかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool EnablePrintButton { get; set; }
Public Property EnablePrintButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「印刷」ボタンを有効にしない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "印刷" ボタンを無効にします。
viewerControl1.EnablePrintButton = false;
' ツールバーの "印刷" ボタンを無効にします。
ViewerControl1.EnablePrintButton = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.EnableSaveButton プロパティ

ViewerControlEnableSaveButton プロパティ

ツールバーの保存ボタンを有効にするかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool EnableSaveButton { get; set; }
Public Property EnableSaveButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「保存」ボタンを有効にしない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "保存" ボタンを無効にします。
viewerControl1.EnableSaveButton = false;
' ツールバーの "保存" ボタンを無効にします。
ViewerControl1.EnableSaveButton = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.EnableZoomButton プロパティ

ViewerControlEnableZoomButton プロパティ

ツールバーの倍率ボタンを有効にするかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool EnableZoomButton { get; set; }
Public Property EnableZoomButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「倍率」ボタンを有効にしない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "倍率" ボタンを無効にします。
viewerControl1.EnableZoomButton = false;
' ツールバーの "倍率" ボタンを無効にします。
ViewerControl1.EnableZoomButton = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ErrorMessage プロパティ

ViewerControlErrorMessage プロパティ

エラーメッセージを取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string ErrorMessage { get; }
Public ReadOnly Property ErrorMessage As String
    Get

プロパティ値

型: String
エラーメッセージ(文字列)。
例
C#
VB
コピー
if (viewerControl1.ErrorNo != AdvanceSoftware.ASReport.ErrorNo.NoError)
{
    // エラーメッセージを表示します。
    MessageBox.Show(viewerControl1.ErrorMessage);
}
If ViewerControl1.ErrorNo <> AdvanceSoftware.ASReport.ErrorNo.NoError Then
    ' エラーメッセージを表示します。
    MessageBox.Show(ViewerControl1.ErrorMessage)
End If
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ErrorNo プロパティ

ViewerControlErrorNo プロパティ

エラーナンバーを取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo ErrorNo { get; }
Public ReadOnly Property ErrorNo As ErrorNo
    Get

プロパティ値

型: ErrorNo
エラーナンバーを表す ErrorNo。
例
C#
VB
コピー
if (viewerControl1.ErrorNo != AdvanceSoftware.ASReport.ErrorNo.NoError)
{
    // エラーメッセージを表示します。
    MessageBox.Show(viewerControl1.ErrorMessage);
}
If ViewerControl1.ErrorNo <> AdvanceSoftware.ASReport.ErrorNo.NoError Then
    ' エラーメッセージを表示します。
    MessageBox.Show(ViewerControl1.ErrorMessage)
End If
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.InternalViewZoom プロパティ

ViewerControlInternalViewZoom プロパティ

表示する倍率を取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int InternalViewZoom { get; }
Public ReadOnly Property InternalViewZoom As Integer
    Get

プロパティ値

型: Int32
プレビューの表示倍率。
例
C#
VB
コピー
// 表示する倍率を取得します。
int internalViewZoom = viewerControl1.InternalViewZoom;
' 表示する倍率を取得します。
Dim internalViewZoom As Integer = ViewerControl1.InternalViewZoom
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.IsPdfSaved プロパティ

ViewerControlIsPdfSaved プロパティ

PDF ファイルに保存されたかどうかを取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool IsPdfSaved { get; }
Public ReadOnly Property IsPdfSaved As Boolean
    Get

プロパティ値

型: Boolean
PDF ファイルに保存された場合は true。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
viewerControl1.SavePdf(@"C:\out1.pdf");
// PDF ファイルに保存されたかどうかを取得します。
bool isPdfSaved = viewerControl1.IsPdfSaved;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
ViewerControl1.SavePdf("C:\out1.pdf")
' PDF ファイルに保存されたかどうかを取得します。
Dim isPdfSaved As Boolean = ViewerControl1.IsPdfSaved
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.IsPrinted プロパティ

ViewerControlIsPrinted プロパティ

印刷されたかどうかを取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool IsPrinted { get; }
Public ReadOnly Property IsPrinted As Boolean
    Get

プロパティ値

型: Boolean
印刷された場合は true。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
viewerControl1.PrintOut();
// 印刷されたかどうかを取得します。
bool isPrinted = viewerControl1.IsPrinted;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
ViewerControl1.PrintOut()
' 印刷されたかどうかを取得します。
Dim isPrinted As Boolean = ViewerControl1.IsPrinted
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.IsSaved プロパティ

ViewerControlIsSaved プロパティ

保存されたかどうかを取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool IsSaved { get; }
Public ReadOnly Property IsSaved As Boolean
    Get

プロパティ値

型: Boolean
保存された場合は true。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
viewerControl1.SaveAs(@"C:\out1.xlsx");
// 保存されたかどうかを取得します。
bool isSaved = viewerControl1.IsSaved;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
ViewerControl1.SaveAs("C:\out1.xlsx")
' 保存されたかどうかを取得します。
Dim isSaved As Boolean = ViewerControl1.IsSaved
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.OverFit プロパティ

ViewerControlOverFit プロパティ

帳票を 1 ページに収まるよう表示するかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool OverFit { get; set; }
Public Property OverFit As Boolean
    Get
    Set

プロパティ値

型: Boolean
帳票を用紙内に収める場合は true。
解説
作成した帳票が設定の用紙からはみ出す場合、帳票を自動的に用紙内に収める設定をします。 デザインファイル作成時にページ設定を行ったプリンタと、VB-Report 12.0 for .NET で帳票出力するプリンタが異なる場合、 1 ページに収まっていた帳票が用紙を超える時があり、OverFit プロパティを true に設定することで、 用紙内に収まるよう自動補正して出力します。 ※ExcelMode = false 時のみ有効になります。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// 帳票を 1 ページに収めて表示します。
viewerControl1.OverFit = true;
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' 帳票を 1 ページに収めて表示します。
ViewerControl1.OverFit = True
ViewerControl1.Document = CellReport1.Document
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.Owner プロパティ

ViewerControlOwner プロパティ

コントロールのオーナーを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Window Owner { get; set; }
Public Property Owner As Window
    Get
    Set

プロパティ値

型: Window
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.PageCount プロパティ

ViewerControlPageCount プロパティ

総ページ数を取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int PageCount { get; }
Public ReadOnly Property PageCount As Integer
    Get

プロパティ値

型: Int32
作成された帳票のページ数
例
C#
VB
コピー
// 総ページ数を取得します。
int pageCount = viewerControl1.PageCount;
' 総ページ数を取得します。
Dim pageCount As Integer = ViewerControl1.PageCount
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.PrintDocumentName プロパティ

ViewerControlPrintDocumentName プロパティ

印刷のドキュメント名を設定します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string PrintDocumentName { set; }
Public WriteOnly Property PrintDocumentName As String
    Set

プロパティ値

型: String
印刷時のドキュメント名。(既定値：VB-Report 12.0 for .NET) ※ ExcelMode = false 時のみ有効となります。
例
C#
VB
コピー
// 印刷ドキュメント名を "PrintDocument1" に設定します。
viewerControl1.PrintDocumentName = "PrintDocument1";
' 印刷ドキュメント名を "PrintDocument1" に設定します。
ViewerControl1.PrintDocumentName = "PrintDocument1"
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.Printer プロパティ

ViewerControlPrinter プロパティ

Printer を取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Printer Printer { get; }
Public ReadOnly Property Printer As Printer
    Get

プロパティ値

型: Printer
出力先プリンタの情報を扱うための、Printer クラス。
解説
このクラスの全てのメンバの一覧については、Printer クラスのメンバを参照してください。
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.PrinterName プロパティ

ViewerControlPrinterName プロパティ

現在選択されているプリンタ名を取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string PrinterName { get; }
Public ReadOnly Property PrinterName As String
    Get

プロパティ値

型: String
現在選択されているプリンタ名。
例
C#
VB
コピー
// 現在選択されているプリンタ名を取得します。
string printerName = viewerControl1.PrinterName;
' 現在選択されているプリンタ名を取得します。
Dim printerName As String = ViewerControl1.PrinterName
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.PrintType プロパティ

ViewerControlPrintType プロパティ

印刷タイプを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PrintType PrintType { get; set; }
Public Property PrintType As PrintType
    Get
    Set

プロパティ値

型: PrintType
印刷タイプを表す、PrintType。
例
C#
VB
コピー
// 印刷対象のページを現在のページに設定します。
viewerControl1.PrintType = AdvanceSoftware.ASReport.PrintType.Now;
' 印刷対象のページを現在のページに設定します。
ViewerControl1.PrintType = AdvanceSoftware.ASReport.PrintType.Now
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ProgressDescription プロパティ

ViewerControlProgressDescription プロパティ

プログレスダイアログのユーザーメッセージを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string[] ProgressDescription { get; set; }
Public Property ProgressDescription As String()
    Get
    Set

プロパティ値

型: String
null:表示無し(規定値)、string[]:行毎のメッセージ(例) new string[]{"1行目","2行目"}
例
C#
VB
コピー
// プログレスダイアログのユーザーメッセージに文字列 "処理中" を設定します。
viewerControl1.ProgressDescription = new string[] { "処理中" };
' プログレスダイアログのユーザーメッセージに文字列 "処理中" を設定します。
ViewerControl1.ProgressDescription = New String() {"処理中"}
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.SaveFileName プロパティ

ViewerControlSaveFileName プロパティ

保存時のデフォルトファイル名を設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string SaveFileName { get; set; }
Public Property SaveFileName As String
    Get
    Set

プロパティ値

型: String
ファイル保存時のデフォルトファイル名。
例
C#
VB
コピー
// 保存時のデフォルトファイル名を "out1" に設定します。
viewerControl1.SaveFileName = "out1";
' 保存時のデフォルトファイル名を "out1" に設定します。
ViewerControl1.SaveFileName = "out1"
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.SaveKind プロパティ

ViewerControlSaveKind プロパティ

保存時のファイルの種類を設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public SaveKind SaveKind { get; set; }
Public Property SaveKind As SaveKind
    Get
    Set

プロパティ値

型: SaveKind
保存するファイルの種類を表す、SaveKind。
例
C#
VB
コピー
// ファイル保存ダイアログのファイルの種類を "PDF ファイルのみ" に設定します。
viewerControl1.SaveKind = AdvanceSoftware.ASReport.Wpf.SaveKind.PdfOnly;
' ファイル保存ダイアログのファイルの種類を "PDF ファイルのみ" に設定します。
ViewerControl1.SaveKind = AdvanceSoftware.ASReport.Wpf.SaveKind.PdfOnly
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.SaveMessage プロパティ

ViewerControlSaveMessage プロパティ

保存処理終了後に表示するメッセージ文字列を設定します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string SaveMessage { set; }
Public WriteOnly Property SaveMessage As String
    Set

プロパティ値

型: String
保存終了時に表示するメッセージ。
例
C#
VB
コピー
// 保存処理終了後に表示するメッセージ文字列を "保存が完了しました。" に設定します。
viewerControl1.SaveMessage = "保存が完了しました。";
' 保存処理終了後に表示するメッセージ文字列を "保存が完了しました。" に設定します。
ViewerControl1.SaveMessage = "保存が完了しました。"
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ShowAllButton プロパティ

ViewerControlShowAllButton プロパティ

ツールバーの全体を表示ボタンを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowAllButton { get; set; }
Public Property ShowAllButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「全体を表示」ボタンを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "全体を表示" ボタンを非表示にします。
viewerControl1.ShowAllButton = false;
' ツールバーの "全体を表示" ボタンを非表示にします。
ViewerControl1.ShowAllButton = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ShowAsideButton プロパティ

ViewerControlShowAsideButton プロパティ

ツールバーの横に合わせるボタンを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowAsideButton { get; set; }
Public Property ShowAsideButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「横に合わせる」ボタンを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "横に合わせる" ボタンを非表示にします。
viewerControl1.ShowAsideButton = false;
' ツールバーの "横に合わせる" ボタンを非表示にします。
ViewerControl1.ShowAsideButton = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ShowFirstButton プロパティ

ViewerControlShowFirstButton プロパティ

ツールバーの最初のページボタンを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowFirstButton { get; set; }
Public Property ShowFirstButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「最初のページ」ボタンを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "最初のページ" ボタンを非表示にします。
viewerControl1.ShowFirstButton = false;
' ツールバーの "最初のページ" ボタンを非表示にします。
ViewerControl1.ShowFirstButton = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ShowInvalidArea プロパティ

ViewerControlShowInvalidArea プロパティ

印字可能領域を表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowInvalidArea { get; set; }
Public Property ShowInvalidArea As Boolean
    Get
    Set

プロパティ値

型: Boolean
印字可能領域を表示する場合は true。(既定値：false)
例
C#
VB
コピー
// プレビュー画面に印字可能領域を表示します。
viewerControl1.ShowInvalidArea = true;
' プレビュー画面に印字可能領域を表示します。
ViewerControl1.ShowInvalidArea = True
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ShowLastButton プロパティ

ViewerControlShowLastButton プロパティ

ツールバーの最後のページボタンを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowLastButton { get; set; }
Public Property ShowLastButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「最後のページ」ボタンを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "最後のページ" ボタンを非表示にします。
viewerControl1.ShowLastButton = false;
' ツールバーの "最後のページ" ボタンを非表示にします。
ViewerControl1.ShowLastButton = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ShowLengthwiseButton プロパティ

ViewerControlShowLengthwiseButton プロパティ

ツールバーの縦に合わせるボタンを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowLengthwiseButton { get; set; }
Public Property ShowLengthwiseButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「縦に合わせる」ボタンを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "縦に合わせる" ボタンを非表示にします。
viewerControl1.ShowLengthwiseButton = false;
' ツールバーの "縦に合わせる" ボタンを非表示にします。
ViewerControl1.ShowLengthwiseButton = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ShowMarginArea プロパティ

ViewerControlShowMarginArea プロパティ

余白領域を表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowMarginArea { get; set; }
Public Property ShowMarginArea As Boolean
    Get
    Set

プロパティ値

型: Boolean
余白領域を表示する場合は true。(既定値：false)
例
C#
VB
コピー
// プレビュー画面に余白領域を表示します。
viewerControl1.ShowMarginArea = true;
' プレビュー画面に余白領域を表示します。
ViewerControl1.ShowMarginArea = True
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ShowNextButton プロパティ

ViewerControlShowNextButton プロパティ

ツールバーの次ページボタンを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowNextButton { get; set; }
Public Property ShowNextButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「次ページ」ボタンを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "次ページ" ボタンを非表示にします。
viewerControl1.ShowNextButton = false;
' ツールバーの "次ページ" ボタンを非表示にします。
ViewerControl1.ShowNextButton = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ShowPrevButton プロパティ

ViewerControlShowPrevButton プロパティ

ツールバーの前ページボタンを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowPrevButton { get; set; }
Public Property ShowPrevButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「前ページ」ボタンを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "前ページ" ボタンを非表示にします。
viewerControl1.ShowPrevButton = false;
' ツールバーの "前ページ" ボタンを非表示にします。
ViewerControl1.ShowPrevButton = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ShowPrintButton プロパティ

ViewerControlShowPrintButton プロパティ

ツールバーの印刷ボタンを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowPrintButton { get; set; }
Public Property ShowPrintButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「印刷」ボタンを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "印刷" ボタンを非表示にします。
viewerControl1.ShowPrintButton = false;
' ツールバーの "印刷" ボタンを非表示にします。
ViewerControl1.ShowPrintButton = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ShowProgressDialog プロパティ

ViewerControlShowProgressDialog プロパティ

プログレスダイアログを表示する、しないを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowProgressDialog { get; set; }
Public Property ShowProgressDialog As Boolean
    Get
    Set

プロパティ値

型: Boolean
プログレスダイアログを非表示にする場合は false。(既定値：true)
解説
VB-Report 12.0 for .NET で帳票出力時に表示されるプログレスダイアログを非表示にする場合、false に設定します。 また、false に設定した場合、Progress イベントで処理の進行状況を通知することができます。 なお、ExcelMode プロパティに true を設定した場合、帳票の出力時に上記のプログレスダイアログとは別の、 Excel の処理経過を示すプログレスダイアログを表示します。 Excel の処理経過を示すプログレスダイアログは、ShowProgressDialog プロパティで非表示にすること はできません。
例
C#
VB
コピー
// 帳票出力時のプログレスダイアログを非表示にします。
viewerControl1.ShowProgressDialog = false;
' 帳票出力時のプログレスダイアログを非表示にします。
ViewerControl1.ShowProgressDialog = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ShowReportFrame プロパティ

ViewerControlShowReportFrame プロパティ

帳票の枠組み(罫線、背景色)を表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ReportFrame ShowReportFrame { get; set; }
Public Property ShowReportFrame As ReportFrame
    Get
    Set

プロパティ値

型: ReportFrame
帳票の枠組み(罫線、背景色)をプレビュー・印刷するかを指定する ReportFrame。
例
C#
VB
コピー
// プレビュー時のみ帳票の枠組みを表示します。
viewerControl1.ShowReportFrame = AdvanceSoftware.ASReport.Wpf.ReportFrame.Preview;
' プレビュー時のみ帳票の枠組みを表示します。
ViewerControl1.ShowReportFrame = AdvanceSoftware.ASReport.Wpf.ReportFrame.Preview
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ShowSaveButton プロパティ

ViewerControlShowSaveButton プロパティ

ツールバーの保存ボタンを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowSaveButton { get; set; }
Public Property ShowSaveButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「保存」ボタンを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "保存" ボタンを非表示にします。
viewerControl1.ShowSaveButton = false;
' ツールバーの "保存" ボタンを非表示にします。
ViewerControl1.ShowSaveButton = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ShowSheetName プロパティ

ViewerControlShowSheetName プロパティ

ステータスバーのシート名を表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowSheetName { get; set; }
Public Property ShowSheetName As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ステータスバーのシート名を表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ステータスバーのシート名を非表示にします。
viewerControl1.ShowSheetName = false;
' ステータスバーのシート名を非表示にします。
ViewerControl1.ShowSheetName = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ShowStatusBar プロパティ

ViewerControlShowStatusBar プロパティ

ステータスバーを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowStatusBar { get; set; }
Public Property ShowStatusBar As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ステータスバーを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ステータスバーを非表示にします。
viewerControl1.ShowStatusBar = false;
' ステータスバーを非表示にします。
ViewerControl1.ShowStatusBar = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ShowToolBar プロパティ

ViewerControlShowToolBar プロパティ

ツールバーを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowToolBar { get; set; }
Public Property ShowToolBar As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーを非表示にします。
viewerControl1.ShowToolBar = false;
' ツールバーを非表示にします。
ViewerControl1.ShowToolBar = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ShowUseExcelPrint プロパティ

ViewerControlShowUseExcelPrint プロパティ

印刷ダイアログの「Excel を使用して印刷する」チェックボックスを表示する、しないを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowUseExcelPrint { get; set; }
Public Property ShowUseExcelPrint As Boolean
    Get
    Set

プロパティ値

型: Boolean
印刷ダイアログの「Excel を使用して印刷する」チェックボックスを表示する場合は true。(既定値：false)
例
C#
VB
コピー
// 印刷ダイアログの "Excel を使用して印刷する" チェックボックスを表示します。
viewerControl1.ShowUseExcelPrint = true;
' 印刷ダイアログの "Excel を使用して印刷する" チェックボックスを表示します。
ViewerControl1.ShowUseExcelPrint = True
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ShowZoomButton プロパティ

ViewerControlShowZoomButton プロパティ

ツールバーの倍率ボタンを表示するかどうかを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool ShowZoomButton { get; set; }
Public Property ShowZoomButton As Boolean
    Get
    Set

プロパティ値

型: Boolean
プレビュー画面ツールバーの「倍率」ボタンを表示しない場合は false。(既定値：true)
例
C#
VB
コピー
// ツールバーの "倍率" ボタンを非表示にします。
viewerControl1.ShowZoomButton = false;
' ツールバーの "倍率" ボタンを非表示にします。
ViewerControl1.ShowZoomButton = False
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ToolBarIcon プロパティ

ViewerControlToolBarIcon プロパティ

ツールバーのアイコンのサイズを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ToolBarIcon ToolBarIcon { get; set; }
Public Property ToolBarIcon As ToolBarIcon
    Get
    Set

プロパティ値

型: ToolBarIcon
ツールバーのアイコンのサイズを表す、ToolBarIcon
例
C#
VB
コピー
// ツールバーのアイコンのサイズを "小" に設定します。
viewerControl1.ToolBarIcon = AdvanceSoftware.ASReport.Wpf.ToolBarIcon.SmallIcon;
' ツールバーのアイコンのサイズを "小" に設定します。
ViewerControl1.ToolBarIcon = AdvanceSoftware.ASReport.Wpf.ToolBarIcon.SmallIcon
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ToolBarIconType プロパティ

ViewerControlToolBarIconType プロパティ

ツールバーのアイコンのタイプを設定します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ToolBarIconType ToolBarIconType { get; set; }
Public Property ToolBarIconType As ToolBarIconType
    Get
    Set

プロパティ値

型: ToolBarIconType
ツールバーのアイコンのタイプを表す、ToolBarIconType
例
C#
VB
コピー
// ツールバーのアイコンのタイプを "2" に設定します。
viewerControl1.ToolBarIconType = AdvanceSoftware.ASReport.Wpf.ToolBarIconType.Type2;
' ツールバーのアイコンのタイプを "2" に設定します。
ViewerControl1.ToolBarIconType = AdvanceSoftware.ASReport.Wpf.ToolBarIconType.Type2
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ViewerStatus プロパティ

ViewerControlViewerStatus プロパティ

プレビューコントロールのステータス(待機、動作中)を取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ViewerStatus ViewerStatus { get; }
Public ReadOnly Property ViewerStatus As ViewerStatus
    Get

プロパティ値

型: ViewerStatus
Idling:待機、Running:レポート処理中、Saving:保存中、Printing:印刷中
例
C#
VB
コピー
// ビューアコントロールのステータスを取得します。
AdvanceSoftware.ASReport.Wpf.ViewerStatus viewerStatus = viewerControl1.ViewerStatus;
' ビューアコントロールのステータスを取得します。
Dim viewerStatus As AdvanceSoftware.ASReport.Wpf.ViewerStatus = ViewerControl1.ViewerStatus
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ViewPage プロパティ

ViewerControlViewPage プロパティ

表示するページを設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int ViewPage { get; set; }
Public Property ViewPage As Integer
    Get
    Set

プロパティ値

型: Int32
プレビュー表示するページ番号。(既定値：1)
例
C#
VB
コピー
// 最初にプレビュー表示するページを 2 ページ目に設定します。
viewerControl1.ViewPage = 2;
' 最初にプレビュー表示するページを 2 ページ目に設定します。
ViewerControl1.ViewPage = 2
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.ViewZoom プロパティ

ViewerControlViewZoom プロパティ

表示する倍率を設定、取得します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int ViewZoom { get; set; }
Public Property ViewZoom As Integer
    Get
    Set

プロパティ値

型: Int32
プレビューの表示倍率。(既定値：100)
解説
設定可能な値 : 20% ～ 600%、-1(全)、-2(横)、-3(縦)
例
C#
VB
コピー
// プレビューの表示倍率を "120%" に設定します。
viewerControl1.ViewZoom = 120;
' プレビューの表示倍率を "120%" に設定します。
ViewerControl1.ViewZoom = 120
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl メソッド

ViewerControl 型は下記のメンバーを公開します。

メソッド
 | 名前 | 説明
 | Clear | 帳票表示をクリアします。
Public メソッド | Dispose | Dispose メソッド
 | PrintOut | 印刷します。
 | PrintOut(String) | 印刷します。
 | PrintOut(String, String) | 印刷します。
 | PrintOut(String, String, Int32) | 印刷します。
 | SaveAs(String) | Excel ファイルに保存します。
 | SaveAs(String, ExcelVersion) | Excel ファイルに保存します。
 | SavePdf(Stream) | PDF ファイルに保存します。
 | SavePdf(String) | PDF ファイルに保存します。
 | SetPrinter | プリンタの設定をします。
トップ
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.Clear メソッド

ViewerControlClear メソッド

帳票表示をクリアします。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Clear()
Public Sub Clear
例
C#
VB
コピー
// 帳票表示をクリアします。
viewerControl1.Clear();
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
' 帳票表示をクリアします。
ViewerControl1.Clear()
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.Dispose メソッド

ViewerControlDispose メソッド

Dispose メソッド

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public void Dispose()
Public Sub Dispose
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.PrintOut メソッド

ViewerControlPrintOut メソッド

オーバーロードの一覧
名前 | 説明
PrintOut | 印刷します。
PrintOut(String) | 印刷します。
PrintOut(String, String) | 印刷します。
PrintOut(String, String, Int32) | 印刷します。
トップ
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.PrintOut メソッド

ViewerControlPrintOut メソッド

印刷します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo PrintOut()
Public Function PrintOut As ErrorNo

戻り値

型: ErrorNo
エラーナンバーを返します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
// 印刷を行います。
viewerControl1.PrintOut();
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
' 印刷を行います。
ViewerControl1.PrintOut()
関連項目

参照

ViewerControl クラス
PrintOut オーバーロード
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.PrintOut メソッド (String)

ViewerControlPrintOut メソッド (String)

印刷します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo PrintOut(
    string documentName
)
Public Function PrintOut (
    documentName As String
) As ErrorNo

パラメーター

documentName
型: SystemString
ドキュメント名を指定します。※ExcelMode = false 時のみドキュメント名を指定できます。

戻り値

型: ErrorNo
エラーナンバーを返します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
// 印刷ドキュメント名を "PrintDocument1" に設定して印刷を行います。
viewerControl1.PrintOut("PrintDocument1");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
' 印刷ドキュメント名を "PrintDocument1" に設定して印刷を行います。
ViewerControl1.PrintOut("PrintDocument1")
関連項目

参照

ViewerControl クラス
PrintOut オーバーロード
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.PrintOut メソッド (String, String)

ViewerControlPrintOut メソッド (String, String)

印刷します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo PrintOut(
    string documentName,
    string pageInfo
)
Public Function PrintOut (
    documentName As String,
    pageInfo As String
) As ErrorNo

パラメーター

documentName
型: SystemString
ドキュメント名を指定します。※ExcelMode = false 時のみドキュメント名を指定できます。
pageInfo
型: SystemString
印刷するページを指定します。

戻り値

型: ErrorNo
エラーナンバーを返します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1-99999");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
// 印刷ドキュメント名を "PrintDocument1" に設定して 2 ページ目の印刷を行います。
viewerControl1.PrintOut("PrintDocument1", "2");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1-99999")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
' 印刷ドキュメント名を "PrintDocument1" に設定して 2 ページ目の印刷を行います。
ViewerControl1.PrintOut("PrintDocument1", "2")
関連項目

参照

ViewerControl クラス
PrintOut オーバーロード
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.PrintOut メソッド (String, String, Int32)

ViewerControlPrintOut メソッド (String, String, Int32)

印刷します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo PrintOut(
    string documentName,
    string pageInfo,
    int printCopies
)
Public Function PrintOut (
    documentName As String,
    pageInfo As String,
    printCopies As Integer
) As ErrorNo

パラメーター

documentName
型: SystemString
ドキュメント名を指定します。※ExcelMode = false 時のみドキュメント名を指定できます。
pageInfo
型: SystemString
印刷するページを指定します。
printCopies
型: SystemInt32
印刷部数を指定します。

戻り値

型: ErrorNo
エラーナンバーを返します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1-99999");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
// 印刷ドキュメント名を "PrintDocument1" に設定して 2 ページ目を 3 部印刷します。
viewerControl1.PrintOut("PrintDocument1", "2", 3);
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1-99999")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
' 印刷ドキュメント名を "PrintDocument1" に設定して 2 ページ目を 3 部印刷します。
 ViewerControl1.PrintOut("PrintDocument1", "2", 3)
関連項目

参照

ViewerControl クラス
PrintOut オーバーロード
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.SaveAs メソッド

ViewerControlSaveAs メソッド

オーバーロードの一覧
名前 | 説明
SaveAs(String) | Excel ファイルに保存します。
SaveAs(String, ExcelVersion) | Excel ファイルに保存します。
トップ
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.SaveAs メソッド (String)

ViewerControlSaveAs メソッド (String)

Excel ファイルに保存します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo SaveAs(
    string fileName
)
Public Function SaveAs (
    fileName As String
) As ErrorNo

パラメーター

fileName
型: SystemString
ファイル名を指定します。

戻り値

型: ErrorNo
エラーナンバーを返します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
// Excel ファイルを "C:\out1.xlsx" に保存します。
viewerControl1.SaveAs(@"C:\out1.xlsx");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
' Excel ファイルを "C:\out1.xlsx" に保存します。
ViewerControl1.SaveAs("C:\out1.xlsx")
関連項目

参照

ViewerControl クラス
SaveAs オーバーロード
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.SaveAs メソッド (String, ExcelVersion)

ViewerControlSaveAs メソッド (String, ExcelVersion)

Excel ファイルに保存します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo SaveAs(
    string fileName,
    ExcelVersion version
)
Public Function SaveAs (
    fileName As String,
    version As ExcelVersion
) As ErrorNo

パラメーター

fileName
型: SystemString
ファイル名を指定します。
version
型: AdvanceSoftware.ASReportExcelVersion
バージョンを指定します。

戻り値

型: ErrorNo
エラーナンバーを返します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
//  Excel 2019 の形式で Excel ファイルを "C:\out1.xlsx" に保存します。
viewerControl1.SaveAs(@"C:\out1.xlsx", AdvanceSoftware.ASReport.ExcelVersion.ver2019);
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
' Excel 2019 の形式で Excel ファイルを "C:\out1.xlsx" に保存します。
ViewerControl1.SaveAs("C:\out1.xlsx", AdvanceSoftware.ASReport.ExcelVersion.ver2019)
関連項目

参照

ViewerControl クラス
SaveAs オーバーロード
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.SavePdf メソッド

ViewerControlSavePdf メソッド

オーバーロードの一覧
名前 | 説明
SavePdf(Stream) | PDF ファイルに保存します。
SavePdf(String) | PDF ファイルに保存します。
トップ
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.SavePdf メソッド (Stream)

ViewerControlSavePdf メソッド (Stream)

PDF ファイルに保存します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo SavePdf(
    Stream fileStream
)
Public Function SavePdf (
    fileStream As Stream
) As ErrorNo

パラメーター

fileStream
型: System.IOStream
Stream を指定します。

戻り値

型: ErrorNo
エラーナンバーを返します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
System.IO.MemoryStream memoryStream = new System.IO.MemoryStream();
// PDF ファイルをストリームに出力します。
viewerControl1.SavePdf(memoryStream);
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
Dim memoryStream As System.IO.MemoryStream = New System.IO.MemoryStream()
' PDF ファイルをストリームに出力します。
ViewerControl1.SavePdf(memoryStream)
関連項目

参照

ViewerControl クラス
SavePdf オーバーロード
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.SavePdf メソッド (String)

ViewerControlSavePdf メソッド (String)

PDF ファイルに保存します。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorNo SavePdf(
    string fileName
)
Public Function SavePdf (
    fileName As String
) As ErrorNo

パラメーター

fileName
型: SystemString
ファイル名を指定します。

戻り値

型: ErrorNo
エラーナンバーを返します。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
viewerControl1.Document = cellReport1.Document;
// PDF ファイルを "C:\out1.pdf" に保存します。
viewerControl1.SavePdf(@"C:\out1.pdf");
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
ViewerControl1.Document = CellReport1.Document
' PDF ファイルを "C:\out1.pdf" に保存します。
ViewerControl1.SavePdf("C:\out1.pdf")
関連項目

参照

ViewerControl クラス
SavePdf オーバーロード
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.SetPrinter メソッド

ViewerControlSetPrinter メソッド

プリンタの設定をします。

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool SetPrinter(
    bool dialogMode,
    string setPrinterName
)
Public Function SetPrinter (
    dialogMode As Boolean,
    setPrinterName As String
) As Boolean

パラメーター

dialogMode
型: SystemBoolean
プリンタの設定ダイアログを表示するかを指定します。
setPrinterName
型: SystemString
プリンタ名を指定します。

戻り値

型: Boolean
正しく設定が行われた場合 true を返します。
解説
プリンタの設定ダイアログを表示することができます。 プリンタの設定ダイアログを表示した場合、ExcelMode プロパティが false の時、 プリンタの設定ダイアログで設定した給紙方法、印刷部数を帳票出力に適用することができます。
例
C#
VB
コピー
cellReport1.FileName = @"C:\Book1.xlsx";
cellReport1.Report.Start();
cellReport1.Report.File();
cellReport1.Page.Start("Sheet1", "1");
cellReport1.Cell("A1").Value = "アドバンスソフトウェア";
cellReport1.Page.End();
cellReport1.Report.End();
// プリンタの設定ダイアログを表示せずに使用するプリンタを "Microsoft XPS Document Writer" に設定します。
viewerControl1.SetPrinter(false, "Microsoft XPS Document Writer");
viewerControl1.Document = cellReport1.Document;
CellReport1.FileName = "C:\Book1.xlsx"
CellReport1.Report.Start()
CellReport1.Report.File()
CellReport1.Page.Start("Sheet1", "1")
CellReport1.Cell("A1").Value = "アドバンスソフトウェア"
CellReport1.Page.End()
CellReport1.Report.End()
' プリンタの設定ダイアログを表示せずに使用するプリンタを "Microsoft XPS Document Writer" に設定します。
ViewerControl1.SetPrinter(False, "Microsoft XPS Document Writer")
ViewerControl1.Document = CellReport1.Document
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl イベント

ViewerControl 型は下記のメンバーを公開します。

イベント
名前 | 説明
Error | エラーイベント
Progress | プログレスイベント
トップ
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.Error イベント

ViewerControlError イベント

エラーイベント

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public event ReportErrorEventHandler Error
Public Event Error As ReportErrorEventHandler

値

型: AdvanceSoftware.ASReportReportErrorEventHandler
解説
エラー発生時のエラー番号を取得する場合は、ReportErrorEventArgs の ErrorNo プロパティを参照します。 また、ErrorNo プロパティは、ErrorNo 列挙体の値を返します。
例
C#
VB
コピー
private void InitializeComponent()
{
    viewerControl1.Error += new AdvanceSoftware.ASReport.ReportErrorEventHandler(viewerControl1_Error);
}
void viewerControl1_Error(object sender, AdvanceSoftware.ASReport.ReportErrorEventArgs e)
{
    // エラーナンバーを表示します。
    MessageBox.Show(e.ErrorNo.ToString());
}
Private Sub ViewerControl1_Error(ByVal sender As Object, ByVal e As AdvanceSoftware.ASReport.ReportErrorEventArgs) Handles ViewerControl1.Error
    ' エラーナンバーを表示します。
    MessageBox.Show(e.ErrorNo.ToString())
End Sub
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerControl.Progress イベント

ViewerControlProgress イベント

プログレスイベント

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public event ReportProgressEventHandler Progress
Public Event Progress As ReportProgressEventHandler

値

型: AdvanceSoftware.ASReportReportProgressEventHandler
解説
ShowProgressDialog プロパティで 表示しない(false)を設定した場合、このイベントが発生します。 ユーザー独自の処理進行状況の表示を行う場合に、このイベントで制御を行います。 現在の処理状況を取得する場合は、ReportProgressEventArgs の各プロパティを参照します。
例
C#
VB
コピー
private void InitializeComponent()
{
    viewerControl1.Progress += new AdvanceSoftware.ASReport.ReportProgressEventHandler(viewerControl1_Progress);
}
void viewerControl1_Progress(object sender, AdvanceSoftware.ASReport.ReportProgressEventArgs e)
{
    // 現在のページ数を表示します。
    MessageBox.Show(e.Count.ToString());
}
Private Sub ViewerControl1_Progress(ByVal sender As Object, ByVal e As AdvanceSoftware.ASReport.ReportProgressEventArgs) Handles ViewerControl1.Progress
    ' 現在のページ数を表示します。
    MessageBox.Show(e.Count.ToString())
End Sub
関連項目

参照

ViewerControl クラス
AdvanceSoftware.ASReport.Wpf 名前空間


ViewerStatus 列挙体

ViewerStatus

名前空間: AdvanceSoftware.ASReport.Wpf
アセンブリ: AdvanceSoftware.ASReport.Wpf.Viewer (in AdvanceSoftware.ASReport.Wpf.Viewer.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ViewerStatus
Public Enumeration ViewerStatus
メンバー
メンバー | 値 | 説明
Idling | 0 | 待機中
Running | 1 | レポート処理中
Printing | 2 | 印刷中
Saving | 3 | 保存中
関連項目

参照

AdvanceSoftware.ASReport.Wpf 名前空間


AdvanceSoftware.Charting.Properties 名前空間

AdvanceSoftware.Charting.Properties 名前空間には、CellReport コンポーネントのメソッドで使用するフィールド、列挙体が含まれています。
クラス
 | クラス | 説明
Public クラス | ApproximateCurve | 系列1 近似曲線 1
Public クラス | Axis | 軸
Public クラス | AxisLabel | 軸ラベル
Public クラス | CategoryAxis | 項目軸 (テキスト)
Public クラス | ChartData | グラフ情報
Public クラス | ChartPosition | グラフ位置
Public クラス | ChartProperties | グラフのオプション
Public クラス | ChartTitle | グラフタイトル
Public クラス | DataLabel | 系列1 データラベル
Public クラス | DataPoint | データポイント
Public クラス | DataPointValue | データポイントの値
Public クラス | DataTable | データテーブル
Public クラス | DateAxis | 項目軸 (日付)
Public クラス | ErrorRange | 系列1 Y 誤差範囲
Public クラス | Fill | 塗りつぶし
Public クラス | Font | フォント
Public クラス | GridLine | 目盛線
Public クラス | Legend | 凡例
Public クラス | LegendEntry | 凡例項目
Public クラス | Line | 枠線
Public クラス | LineEnd | 矢印の種類、サイズ
Public クラス | NumberFormat | 表示形式
Public クラス | Placement | 配置、テキストボックス
Public クラス | PlotArea | プロットエリア
Public クラス | Series | 系列1
Public クラス | TextProperties | 文字のオプション
Public クラス | ValueAxis | 値軸
列挙体
 | 列挙体 | 説明
Public 列挙体 | AxisType | 軸の種類
Public 列挙体 | BuiltInUnit | 表示単位
Public 列挙体 | ChartType | グラフの種類
Public 列挙体 | CompoundLineType | 一重線/多重線
Public 列挙体 | CrossBetween | 軸位置
Public 列挙体 | Crosses | 軸との交点
Public 列挙体 | DataLabelPosition | データラベルの位置
Public 列挙体 | LabelShowType | ラベルの表示種別
Public 列挙体 | LegendPosition | 凡例の位置
Public 列挙体 | LineCapType | 線の先端
Public 列挙体 | LineDashType | 実線/点線
Public 列挙体 | LineEndLength | 矢印のサイズ (長さ)
Public 列挙体 | LineEndType | 矢印の種類
Public 列挙体 | LineEndWidth | 矢印のサイズ (幅)
Public 列挙体 | LineJoinType | 線の結合点
Public 列挙体 | Orientation | 軸の方向
Public 列挙体 | TextCapsType | 大文字の種類
Public 列挙体 | TextStrikeType | 取り消し線の種類
Public 列挙体 | TextUnderlineType | 下線のスタイル
Public 列挙体 | TextVerticalType | 文字列の方向
Public 列挙体 | TickLabelPosition | ラベルの位置
Public 列挙体 | TickMark | 目盛の種類
Public 列挙体 | TimeUnit | 時間の単位


ApproximateCurve クラス

系列1 近似曲線 1
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesApproximateCurve

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class ApproximateCurve
Public Class ApproximateCurve

ApproximateCurve 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


ApproximateCurve フィールド

ApproximateCurve 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
トップ
関連項目

参照

ApproximateCurve クラス
AdvanceSoftware.Charting.Properties 名前空間


ApproximateCurve.chartProperties フィールド

ApproximateCurvechartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

ApproximateCurve クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis クラス

軸
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesAxis
AdvanceSoftware.Charting.PropertiesCategoryAxis
AdvanceSoftware.Charting.PropertiesDateAxis
AdvanceSoftware.Charting.PropertiesValueAxis

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Axis
Public Class Axis

Axis 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | axisLabel | ラベル
Public フィールド | axisMajorGrid | 目盛線
Public フィールド | axisMinorGrid | 補助目盛線
Public フィールド | chartProperties | グラフのオプション
Public フィールド | crosses | 縦、横軸との交点 (自動、最大項目)
Public フィールド | crossingValue | 縦、横軸との交点 (項目番号)
Public フィールド | majorTickMark | 目盛の種類
Public フィールド | minorTickMark | 補助目盛の種類
Public フィールド | numberFormat | 表示形式
Public フィールド | orientation | 軸を反転する、日付を逆順にする
Public フィールド | textProperties | 文字のオプション
Public フィールド | tickLabelPosition | ラベルの位置
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Axis フィールド

Axis 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | axisLabel | ラベル
Public フィールド | axisMajorGrid | 目盛線
Public フィールド | axisMinorGrid | 補助目盛線
Public フィールド | chartProperties | グラフのオプション
Public フィールド | crosses | 縦、横軸との交点 (自動、最大項目)
Public フィールド | crossingValue | 縦、横軸との交点 (項目番号)
Public フィールド | majorTickMark | 目盛の種類
Public フィールド | minorTickMark | 補助目盛の種類
Public フィールド | numberFormat | 表示形式
Public フィールド | orientation | 軸を反転する、日付を逆順にする
Public フィールド | textProperties | 文字のオプション
Public フィールド | tickLabelPosition | ラベルの位置
トップ
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.axisLabel フィールド

AxisaxisLabel フィールド

ラベル

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public AxisLabel axisLabel
Public axisLabel As AxisLabel

フィールド値

型: AxisLabel
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.axisMajorGrid フィールド

AxisaxisMajorGrid フィールド

目盛線

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public GridLine axisMajorGrid
Public axisMajorGrid As GridLine

フィールド値

型: GridLine
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.axisMinorGrid フィールド

AxisaxisMinorGrid フィールド

補助目盛線

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public GridLine axisMinorGrid
Public axisMinorGrid As GridLine

フィールド値

型: GridLine
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.chartProperties フィールド

AxischartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.crosses フィールド

Axiscrosses フィールド

縦、横軸との交点 (自動、最大項目)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Crosses crosses
Public crosses As Crosses

フィールド値

型: Crosses
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.crossingValue フィールド

AxiscrossingValue フィールド

縦、横軸との交点 (項目番号)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double crossingValue
Public crossingValue As Double

フィールド値

型: Double
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.majorTickMark フィールド

AxismajorTickMark フィールド

目盛の種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TickMark majorTickMark
Public majorTickMark As TickMark

フィールド値

型: TickMark
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.minorTickMark フィールド

AxisminorTickMark フィールド

補助目盛の種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TickMark minorTickMark
Public minorTickMark As TickMark

フィールド値

型: TickMark
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.numberFormat フィールド

AxisnumberFormat フィールド

表示形式

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public NumberFormat numberFormat
Public numberFormat As NumberFormat

フィールド値

型: NumberFormat
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.orientation フィールド

Axisorientation フィールド

軸を反転する、日付を逆順にする

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Orientation orientation
Public orientation As Orientation

フィールド値

型: Orientation
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.textProperties フィールド

AxistextProperties フィールド

文字のオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextProperties textProperties
Public textProperties As TextProperties

フィールド値

型: TextProperties
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


Axis.tickLabelPosition フィールド

AxistickLabelPosition フィールド

ラベルの位置

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TickLabelPosition tickLabelPosition
Public tickLabelPosition As TickLabelPosition

フィールド値

型: TickLabelPosition
関連項目

参照

Axis クラス
AdvanceSoftware.Charting.Properties 名前空間


AxisLabel クラス

軸ラベル
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesAxisLabel

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class AxisLabel
Public Class AxisLabel

AxisLabel 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | text | 軸ラベルのテキスト
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


AxisLabel フィールド

AxisLabel 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | text | 軸ラベルのテキスト
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

AxisLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


AxisLabel.chartProperties フィールド

AxisLabelchartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

AxisLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


AxisLabel.text フィールド

AxisLabeltext フィールド

軸ラベルのテキスト

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string text
Public text As String

フィールド値

型: String
関連項目

参照

AxisLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


AxisLabel.textProperties フィールド

AxisLabeltextProperties フィールド

文字のオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextProperties textProperties
Public textProperties As TextProperties

フィールド値

型: TextProperties
関連項目

参照

AxisLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


AxisType 列挙体

軸の種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum AxisType
Public Enumeration AxisType
メンバー
メンバー | 値 | 説明
Primary | 0 | 主軸
Secondary | 1 | 第 2 軸
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


BuiltInUnit 列挙体

表示単位

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum BuiltInUnit
Public Enumeration BuiltInUnit
メンバー
メンバー | 値 | 説明
Hundreds | 0 | 百
Thousands | 1 | 千
TenThousands | 2 | 万
HundredThousands | 3 | 十万
Millions | 4 | 百万
TenMillions | 5 | 千万
HundredMillions | 6 | 億
Billions | 7 | 十億
Trillions | 8 | 兆
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


CategoryAxis クラス

項目軸 (テキスト)
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesAxis
AdvanceSoftware.Charting.PropertiesCategoryAxis

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class CategoryAxis : Axis
Public Class CategoryAxis
    Inherits Axis

CategoryAxis 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | crossBetween | 軸位置
Public フィールド | labelOffset | 軸からの距離
Public フィールド | tickLabelSkip | ラベルの間隔
Public フィールド | tickMarkSkip | 目盛の間隔
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


CategoryAxis フィールド

CategoryAxis 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | crossBetween | 軸位置
Public フィールド | labelOffset | 軸からの距離
Public フィールド | tickLabelSkip | ラベルの間隔
Public フィールド | tickMarkSkip | 目盛の間隔
トップ
関連項目

参照

CategoryAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


CategoryAxis.crossBetween フィールド

CategoryAxiscrossBetween フィールド

軸位置

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public CrossBetween crossBetween
Public crossBetween As CrossBetween

フィールド値

型: CrossBetween
関連項目

参照

CategoryAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


CategoryAxis.labelOffset フィールド

CategoryAxislabelOffset フィールド

軸からの距離

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int labelOffset
Public labelOffset As Integer

フィールド値

型: Int32
関連項目

参照

CategoryAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


CategoryAxis.tickLabelSkip フィールド

CategoryAxistickLabelSkip フィールド

ラベルの間隔

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public uint tickLabelSkip
Public tickLabelSkip As UInteger

フィールド値

型: UInt32
関連項目

参照

CategoryAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


CategoryAxis.tickMarkSkip フィールド

CategoryAxistickMarkSkip フィールド

目盛の間隔

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public uint tickMarkSkip
Public tickMarkSkip As UInteger

フィールド値

型: UInt32
関連項目

参照

CategoryAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData クラス

グラフ情報
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesChartData

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class ChartData
Public Class ChartData

ChartData 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartPosition | グラフの位置
Public フィールド | chartProperties | グラフのオプション
Public フィールド | chartTitle | グラフタイトル
Public フィールド | col | 列
Public フィールド | height | 高さ
Public フィールド | legend | 凡例
Public フィールド | offsetX | オフセット X
Public フィールド | offsetY | オフセット Y
Public フィールド | plotArea | プロットエリア
Public フィールド | resolution | 解像度
Public フィールド | roundedCorners | 角を丸くする
Public フィールド | row | 行
Public フィールド | textProperties | 文字のオプション
Public フィールド | width | 幅
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


ChartData フィールド

ChartData 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartPosition | グラフの位置
Public フィールド | chartProperties | グラフのオプション
Public フィールド | chartTitle | グラフタイトル
Public フィールド | col | 列
Public フィールド | height | 高さ
Public フィールド | legend | 凡例
Public フィールド | offsetX | オフセット X
Public フィールド | offsetY | オフセット Y
Public フィールド | plotArea | プロットエリア
Public フィールド | resolution | 解像度
Public フィールド | roundedCorners | 角を丸くする
Public フィールド | row | 行
Public フィールド | textProperties | 文字のオプション
Public フィールド | width | 幅
トップ
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.chartPosition フィールド

ChartDatachartPosition フィールド

グラフの位置

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartPosition chartPosition
Public chartPosition As ChartPosition

フィールド値

型: ChartPosition
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.chartProperties フィールド

ChartDatachartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.chartTitle フィールド

ChartDatachartTitle フィールド

グラフタイトル

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartTitle chartTitle
Public chartTitle As ChartTitle

フィールド値

型: ChartTitle
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.col フィールド

ChartDatacol フィールド

列

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int col
Public col As Integer

フィールド値

型: Int32
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.height フィールド

ChartDataheight フィールド

高さ

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int height
Public height As Integer

フィールド値

型: Int32
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.legend フィールド

ChartDatalegend フィールド

凡例

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Legend legend
Public legend As Legend

フィールド値

型: Legend
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.offsetX フィールド

ChartDataoffsetX フィールド

オフセット X

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int offsetX
Public offsetX As Integer

フィールド値

型: Int32
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.offsetY フィールド

ChartDataoffsetY フィールド

オフセット Y

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int offsetY
Public offsetY As Integer

フィールド値

型: Int32
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.plotArea フィールド

ChartDataplotArea フィールド

プロットエリア

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public PlotArea plotArea
Public plotArea As PlotArea

フィールド値

型: PlotArea
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.resolution フィールド

ChartDataresolution フィールド

解像度

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int resolution
Public resolution As Integer

フィールド値

型: Int32
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.roundedCorners フィールド

ChartDataroundedCorners フィールド

角を丸くする

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool roundedCorners
Public roundedCorners As Boolean

フィールド値

型: Boolean
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.row フィールド

ChartDatarow フィールド

行

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int row
Public row As Integer

フィールド値

型: Int32
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.textProperties フィールド

ChartDatatextProperties フィールド

文字のオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextProperties textProperties
Public textProperties As TextProperties

フィールド値

型: TextProperties
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartData.width フィールド

ChartDatawidth フィールド

幅

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int width
Public width As Integer

フィールド値

型: Int32
関連項目

参照

ChartData クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartPosition クラス

グラフ位置
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesChartPosition

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class ChartPosition
Public Class ChartPosition

ChartPosition 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | ex | グラフ位置の終了 X 座標
Public フィールド | exh | グラフ位置の終了 X オフセット
Public フィールド | ey | グラフ位置の終了 Y 座標
Public フィールド | eyv | グラフ位置の終了 Y オフセット
Public フィールド | sx | グラフ位置の開始 X 座標
Public フィールド | sxh | グラフ位置の開始 X オフセット
Public フィールド | sy | グラフ位置の開始 Y 座標
Public フィールド | syv | グラフ位置の開始 Y オフセット
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


ChartPosition フィールド

ChartPosition 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | ex | グラフ位置の終了 X 座標
Public フィールド | exh | グラフ位置の終了 X オフセット
Public フィールド | ey | グラフ位置の終了 Y 座標
Public フィールド | eyv | グラフ位置の終了 Y オフセット
Public フィールド | sx | グラフ位置の開始 X 座標
Public フィールド | sxh | グラフ位置の開始 X オフセット
Public フィールド | sy | グラフ位置の開始 Y 座標
Public フィールド | syv | グラフ位置の開始 Y オフセット
トップ
関連項目

参照

ChartPosition クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartPosition.ex フィールド

ChartPositionex フィールド

グラフ位置の終了 X 座標

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int ex
Public ex As Integer

フィールド値

型: Int32
関連項目

参照

ChartPosition クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartPosition.exh フィールド

ChartPositionexh フィールド

グラフ位置の終了 X オフセット

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int exh
Public exh As Integer

フィールド値

型: Int32
関連項目

参照

ChartPosition クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartPosition.ey フィールド

ChartPositioney フィールド

グラフ位置の終了 Y 座標

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int ey
Public ey As Integer

フィールド値

型: Int32
関連項目

参照

ChartPosition クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartPosition.eyv フィールド

ChartPositioneyv フィールド

グラフ位置の終了 Y オフセット

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int eyv
Public eyv As Integer

フィールド値

型: Int32
関連項目

参照

ChartPosition クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartPosition.sx フィールド

ChartPositionsx フィールド

グラフ位置の開始 X 座標

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int sx
Public sx As Integer

フィールド値

型: Int32
関連項目

参照

ChartPosition クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartPosition.sxh フィールド

ChartPositionsxh フィールド

グラフ位置の開始 X オフセット

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int sxh
Public sxh As Integer

フィールド値

型: Int32
関連項目

参照

ChartPosition クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartPosition.sy フィールド

ChartPositionsy フィールド

グラフ位置の開始 Y 座標

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int sy
Public sy As Integer

フィールド値

型: Int32
関連項目

参照

ChartPosition クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartPosition.syv フィールド

ChartPositionsyv フィールド

グラフ位置の開始 Y オフセット

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int syv
Public syv As Integer

フィールド値

型: Int32
関連項目

参照

ChartPosition クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartProperties クラス

グラフのオプション
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesChartProperties

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class ChartProperties
Public Class ChartProperties

ChartProperties 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | fill | 塗りつぶし
Public フィールド | line | 枠線
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


ChartProperties フィールド

ChartProperties 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | fill | 塗りつぶし
Public フィールド | line | 枠線
トップ
関連項目

参照

ChartProperties クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartProperties.fill フィールド

ChartPropertiesfill フィールド

塗りつぶし

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Fill fill
Public fill As Fill

フィールド値

型: Fill
関連項目

参照

ChartProperties クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartProperties.line フィールド

ChartPropertiesline フィールド

枠線

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Line line
Public line As Line

フィールド値

型: Line
関連項目

参照

ChartProperties クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartTitle クラス

グラフタイトル
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesChartTitle

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class ChartTitle
Public Class ChartTitle

ChartTitle 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | text | タイトルのテキスト
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


ChartTitle フィールド

ChartTitle 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | text | タイトルのテキスト
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

ChartTitle クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartTitle.chartProperties フィールド

ChartTitlechartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

ChartTitle クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartTitle.text フィールド

ChartTitletext フィールド

タイトルのテキスト

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string text
Public text As String

フィールド値

型: String
関連項目

参照

ChartTitle クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartTitle.textProperties フィールド

ChartTitletextProperties フィールド

文字のオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextProperties textProperties
Public textProperties As TextProperties

フィールド値

型: TextProperties
関連項目

参照

ChartTitle クラス
AdvanceSoftware.Charting.Properties 名前空間


ChartType 列挙体

グラフの種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum ChartType
Public Enumeration ChartType
メンバー
メンバー | 値 | 説明
Column | 0 | 集合縦棒
Bar | 1 | 集合横棒
Line | 2 | 折れ線
Pie | 3 | 円
Doughnut | 4 | ドーナツ
Area | 5 | 面
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


CompoundLineType 列挙体

一重線/多重線

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum CompoundLineType
Public Enumeration CompoundLineType
メンバー
メンバー | 値 | 説明
Single | 0 | 一重線
Double | 1 | 二重線
ThickThin | 2 | 太線 + 細線
ThinThick | 3 | 細線 + 太線
Triple | 4 | 三重線
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


CrossBetween 列挙体

軸位置

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum CrossBetween
Public Enumeration CrossBetween
メンバー
メンバー | 値 | 説明
Between | 0 | 目盛の間
MidpointOfCategory | 1 | 目盛
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Crosses 列挙体

軸との交点

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum Crosses
Public Enumeration Crosses
メンバー
メンバー | 値 | 説明
AutoZero | 0 | 自動
Maximum | 1 | 最大項目
Minimum | 2 | 最小項目
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


DataLabel クラス

系列1 データラベル
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesDataLabel

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class DataLabel
Public Class DataLabel

DataLabel 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | numberFormat | 表示形式
Public フィールド | position | ラベルの位置
Public フィールド | rangeString | セルの値
Public フィールド | separator | 区切り文字
Public フィールド | showType | ラベルの内容
Public フィールド | text | ラベルのテキスト
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


DataLabel フィールド

DataLabel 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | numberFormat | 表示形式
Public フィールド | position | ラベルの位置
Public フィールド | rangeString | セルの値
Public フィールド | separator | 区切り文字
Public フィールド | showType | ラベルの内容
Public フィールド | text | ラベルのテキスト
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

DataLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


DataLabel.chartProperties フィールド

DataLabelchartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

DataLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


DataLabel.numberFormat フィールド

DataLabelnumberFormat フィールド

表示形式

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public NumberFormat numberFormat
Public numberFormat As NumberFormat

フィールド値

型: NumberFormat
関連項目

参照

DataLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


DataLabel.position フィールド

DataLabelposition フィールド

ラベルの位置

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public DataLabelPosition position
Public position As DataLabelPosition

フィールド値

型: DataLabelPosition
関連項目

参照

DataLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


DataLabel.rangeString フィールド

DataLabelrangeString フィールド

セルの値

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string rangeString
Public rangeString As String

フィールド値

型: String
関連項目

参照

DataLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


DataLabel.separator フィールド

DataLabelseparator フィールド

区切り文字

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string separator
Public separator As String

フィールド値

型: String
関連項目

参照

DataLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


DataLabel.showType フィールド

DataLabelshowType フィールド

ラベルの内容

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LabelShowType showType
Public showType As LabelShowType

フィールド値

型: LabelShowType
関連項目

参照

DataLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


DataLabel.text フィールド

DataLabeltext フィールド

ラベルのテキスト

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string text
Public text As String

フィールド値

型: String
関連項目

参照

DataLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


DataLabel.textProperties フィールド

DataLabeltextProperties フィールド

文字のオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextProperties textProperties
Public textProperties As TextProperties

フィールド値

型: TextProperties
関連項目

参照

DataLabel クラス
AdvanceSoftware.Charting.Properties 名前空間


DataLabelPosition 列挙体

データラベルの位置

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum DataLabelPosition
Public Enumeration DataLabelPosition
メンバー
メンバー | 値 | 説明
BestFit | 0 | 自動
Bottom | 1 | 下
Center | 2 | 中央
InsideBase | 3 | 内側軸寄り
InsideEnd | 4 | 内側先端
Left | 5 | 左
OutsideEnd | 6 | 外側先端
Right | 7 | 右
Top | 8 | 上
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


DataPoint クラス

データポイント
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesDataPoint

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class DataPoint
Public Class DataPoint

DataPoint 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | invertColor | 負の値を反転するときの色、透明度
Public フィールド | invertIfNegative | 負の値を反転する
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


DataPoint フィールド

DataPoint 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | invertColor | 負の値を反転するときの色、透明度
Public フィールド | invertIfNegative | 負の値を反転する
トップ
関連項目

参照

DataPoint クラス
AdvanceSoftware.Charting.Properties 名前空間


DataPoint.chartProperties フィールド

DataPointchartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

DataPoint クラス
AdvanceSoftware.Charting.Properties 名前空間


DataPoint.invertColor フィールド

DataPointinvertColor フィールド

負の値を反転するときの色、透明度

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color invertColor
Public invertColor As Color

フィールド値

型: Color
関連項目

参照

DataPoint クラス
AdvanceSoftware.Charting.Properties 名前空間


DataPoint.invertIfNegative フィールド

DataPointinvertIfNegative フィールド

負の値を反転する

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool invertIfNegative
Public invertIfNegative As Boolean

フィールド値

型: Boolean
関連項目

参照

DataPoint クラス
AdvanceSoftware.Charting.Properties 名前空間


DataPointValue クラス

データポイントの値
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesDataPointValue

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class DataPointValue
Public Class DataPointValue

DataPointValue 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | categoryValue | 項目軸 (テキスト) の文字列
Public フィールド | dataLabel | データ ラベルのプロパティ
Public フィールド | dataPoint | データポイントのプロパティ
Public フィールド | xValue | x 値
Public フィールド | yValue | y 値
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


DataPointValue フィールド

DataPointValue 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | categoryValue | 項目軸 (テキスト) の文字列
Public フィールド | dataLabel | データ ラベルのプロパティ
Public フィールド | dataPoint | データポイントのプロパティ
Public フィールド | xValue | x 値
Public フィールド | yValue | y 値
トップ
関連項目

参照

DataPointValue クラス
AdvanceSoftware.Charting.Properties 名前空間


DataPointValue.categoryValue フィールド

DataPointValuecategoryValue フィールド

項目軸 (テキスト) の文字列

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string categoryValue
Public categoryValue As String

フィールド値

型: String
関連項目

参照

DataPointValue クラス
AdvanceSoftware.Charting.Properties 名前空間


DataPointValue.dataLabel フィールド

DataPointValuedataLabel フィールド

データ ラベルのプロパティ

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public DataLabel dataLabel
Public dataLabel As DataLabel

フィールド値

型: DataLabel
関連項目

参照

DataPointValue クラス
AdvanceSoftware.Charting.Properties 名前空間


DataPointValue.dataPoint フィールド

DataPointValuedataPoint フィールド

データポイントのプロパティ

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public DataPoint dataPoint
Public dataPoint As DataPoint

フィールド値

型: DataPoint
関連項目

参照

DataPointValue クラス
AdvanceSoftware.Charting.Properties 名前空間


DataPointValue.xValue フィールド

DataPointValuexValue フィールド

x 値

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double xValue
Public xValue As Double

フィールド値

型: Double
関連項目

参照

DataPointValue クラス
AdvanceSoftware.Charting.Properties 名前空間


DataPointValue.yValue フィールド

DataPointValueyValue フィールド

y 値

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double yValue
Public yValue As Double

フィールド値

型: Double
関連項目

参照

DataPointValue クラス
AdvanceSoftware.Charting.Properties 名前空間


DataTable クラス

データテーブル
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesDataTable

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class DataTable
Public Class DataTable

DataTable 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


DataTable フィールド

DataTable 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

DataTable クラス
AdvanceSoftware.Charting.Properties 名前空間


DataTable.chartProperties フィールド

DataTablechartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

DataTable クラス
AdvanceSoftware.Charting.Properties 名前空間


DataTable.textProperties フィールド

DataTabletextProperties フィールド

文字のオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextProperties textProperties
Public textProperties As TextProperties

フィールド値

型: TextProperties
関連項目

参照

DataTable クラス
AdvanceSoftware.Charting.Properties 名前空間


DateAxis クラス

項目軸 (日付)
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesAxis
AdvanceSoftware.Charting.PropertiesDateAxis

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class DateAxis : Axis
Public Class DateAxis
    Inherits Axis

DateAxis 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | baseTimeUnit | 軸の設定
Public フィールド | crossBetween | 軸位置
Public フィールド | majorTimeUnit | 目盛間隔 (目盛) 単位
Public フィールド | majorUnit | 目盛間隔 (目盛)
Public フィールド | maximum | 境界値 (最大値)
Public フィールド | minimum | 境界値 (最小値)
Public フィールド | minorTimeUnit | 目盛間隔 (補助目盛) 単位
Public フィールド | minorUnit | 目盛間隔 (補助目盛)
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


DateAxis フィールド

DateAxis 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | baseTimeUnit | 軸の設定
Public フィールド | crossBetween | 軸位置
Public フィールド | majorTimeUnit | 目盛間隔 (目盛) 単位
Public フィールド | majorUnit | 目盛間隔 (目盛)
Public フィールド | maximum | 境界値 (最大値)
Public フィールド | minimum | 境界値 (最小値)
Public フィールド | minorTimeUnit | 目盛間隔 (補助目盛) 単位
Public フィールド | minorUnit | 目盛間隔 (補助目盛)
トップ
関連項目

参照

DateAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


DateAxis.baseTimeUnit フィールド

DateAxisbaseTimeUnit フィールド

軸の設定

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TimeUnit baseTimeUnit
Public baseTimeUnit As TimeUnit

フィールド値

型: TimeUnit
関連項目

参照

DateAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


DateAxis.crossBetween フィールド

DateAxiscrossBetween フィールド

軸位置

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public CrossBetween crossBetween
Public crossBetween As CrossBetween

フィールド値

型: CrossBetween
関連項目

参照

DateAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


DateAxis.majorTimeUnit フィールド

DateAxismajorTimeUnit フィールド

目盛間隔 (目盛) 単位

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TimeUnit majorTimeUnit
Public majorTimeUnit As TimeUnit

フィールド値

型: TimeUnit
関連項目

参照

DateAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


DateAxis.majorUnit フィールド

DateAxismajorUnit フィールド

目盛間隔 (目盛)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double majorUnit
Public majorUnit As Double

フィールド値

型: Double
関連項目

参照

DateAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


DateAxis.maximum フィールド

DateAxismaximum フィールド

境界値 (最大値)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double maximum
Public maximum As Double

フィールド値

型: Double
関連項目

参照

DateAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


DateAxis.minimum フィールド

DateAxisminimum フィールド

境界値 (最小値)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double minimum
Public minimum As Double

フィールド値

型: Double
関連項目

参照

DateAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


DateAxis.minorTimeUnit フィールド

DateAxisminorTimeUnit フィールド

目盛間隔 (補助目盛) 単位

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TimeUnit minorTimeUnit
Public minorTimeUnit As TimeUnit

フィールド値

型: TimeUnit
関連項目

参照

DateAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


DateAxis.minorUnit フィールド

DateAxisminorUnit フィールド

目盛間隔 (補助目盛)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double minorUnit
Public minorUnit As Double

フィールド値

型: Double
関連項目

参照

DateAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


ErrorRange クラス

系列1 Y 誤差範囲
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesErrorRange

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class ErrorRange
Public Class ErrorRange

ErrorRange 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


ErrorRange フィールド

ErrorRange 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
トップ
関連項目

参照

ErrorRange クラス
AdvanceSoftware.Charting.Properties 名前空間


ErrorRange.chartProperties フィールド

ErrorRangechartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

ErrorRange クラス
AdvanceSoftware.Charting.Properties 名前空間


Fill クラス

塗りつぶし
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesFill

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Fill
Public Class Fill

Fill 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | color | 色、透明度
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Fill フィールド

Fill 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | color | 色、透明度
トップ
関連項目

参照

Fill クラス
AdvanceSoftware.Charting.Properties 名前空間


Fill.color フィールド

Fillcolor フィールド

色、透明度

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color color
Public color As Color

フィールド値

型: Color
関連項目

参照

Fill クラス
AdvanceSoftware.Charting.Properties 名前空間


Font クラス

フォント
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesFont

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Font
Public Class Font

Font 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | baseline | 相対位置 (上付き、下付き)
Public フィールド | capsType | 大文字の種類
Public フィールド | eastAsianFontName | 日本語用のフォント
Public フィールド | latinFontName | 英数字用のフォント
Public フィールド | normalizeHeights | 文字の高さを揃える
Public フィールド | size | サイズ(pt 単位)
Public フィールド | spacing | 文字間
Public フィールド | strikeType | 取り消し線、二重取り消し線
Public フィールド | style | スタイル
Public フィールド | underlineColor | 下線の色
Public フィールド | underlineType | 下線のスタイル
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Font フィールド

Font 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | baseline | 相対位置 (上付き、下付き)
Public フィールド | capsType | 大文字の種類
Public フィールド | eastAsianFontName | 日本語用のフォント
Public フィールド | latinFontName | 英数字用のフォント
Public フィールド | normalizeHeights | 文字の高さを揃える
Public フィールド | size | サイズ(pt 単位)
Public フィールド | spacing | 文字間
Public フィールド | strikeType | 取り消し線、二重取り消し線
Public フィールド | style | スタイル
Public フィールド | underlineColor | 下線の色
Public フィールド | underlineType | 下線のスタイル
トップ
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.baseline フィールド

Fontbaseline フィールド

相対位置 (上付き、下付き)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int baseline
Public baseline As Integer

フィールド値

型: Int32
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.capsType フィールド

FontcapsType フィールド

大文字の種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextCapsType capsType
Public capsType As TextCapsType

フィールド値

型: TextCapsType
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.eastAsianFontName フィールド

FonteastAsianFontName フィールド

日本語用のフォント

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string eastAsianFontName
Public eastAsianFontName As String

フィールド値

型: String
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.latinFontName フィールド

FontlatinFontName フィールド

英数字用のフォント

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string latinFontName
Public latinFontName As String

フィールド値

型: String
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.normalizeHeights フィールド

FontnormalizeHeights フィールド

文字の高さを揃える

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool normalizeHeights
Public normalizeHeights As Boolean

フィールド値

型: Boolean
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.size フィールド

Fontsize フィールド

サイズ(pt 単位)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public float size
Public size As Single

フィールド値

型: Single
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.spacing フィールド

Fontspacing フィールド

文字間

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double spacing
Public spacing As Double

フィールド値

型: Double
幅 (間隔) / 0 : 標準、正 : 文字間隔を広げる、負 : 文字間隔をつめる
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.strikeType フィールド

FontstrikeType フィールド

取り消し線、二重取り消し線

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextStrikeType strikeType
Public strikeType As TextStrikeType

フィールド値

型: TextStrikeType
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.style フィールド

Fontstyle フィールド

スタイル

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public FontStyle style
Public style As FontStyle

フィールド値

型: FontStyle
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.underlineColor フィールド

FontunderlineColor フィールド

下線の色

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color underlineColor
Public underlineColor As Color

フィールド値

型: Color
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


Font.underlineType フィールド

FontunderlineType フィールド

下線のスタイル

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextUnderlineType underlineType
Public underlineType As TextUnderlineType

フィールド値

型: TextUnderlineType
関連項目

参照

Font クラス
AdvanceSoftware.Charting.Properties 名前空間


GridLine クラス

目盛線
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesGridLine

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class GridLine
Public Class GridLine

GridLine 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


GridLine フィールド

GridLine 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
トップ
関連項目

参照

GridLine クラス
AdvanceSoftware.Charting.Properties 名前空間


GridLine.chartProperties フィールド

GridLinechartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

GridLine クラス
AdvanceSoftware.Charting.Properties 名前空間


LabelShowType 列挙体

ラベルの表示種別

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
[FlagsAttribute]
public enum LabelShowType
<FlagsAttribute>
Public Enumeration LabelShowType
メンバー
メンバー | 値 | 説明
None | 0 | なし
DataLabelsRange | 1 | セルの値
SeriesName | 2 | 系列名
CategoryName | 4 | 分類名
Value | 8 | 値
LeaderLines | 16 | 引き出し線を表示する
LegendKey | 32 | 凡例マーカー
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Legend クラス

凡例
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesLegend

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Legend
Public Class Legend

Legend 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | legendEntries | 凡例項目
Public フィールド | overlay | 凡例をグラフに重ねずに表示する
Public フィールド | position | 凡例の位置
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Legend フィールド

Legend 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | chartProperties | グラフのオプション
Public フィールド | legendEntries | 凡例項目
Public フィールド | overlay | 凡例をグラフに重ねずに表示する
Public フィールド | position | 凡例の位置
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

Legend クラス
AdvanceSoftware.Charting.Properties 名前空間


Legend.chartProperties フィールド

LegendchartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

Legend クラス
AdvanceSoftware.Charting.Properties 名前空間


Legend.legendEntries フィールド

LegendlegendEntries フィールド

凡例項目

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public List legendEntries
Public legendEntries As List

フィールド値

型: ListT
関連項目

参照

Legend クラス
AdvanceSoftware.Charting.Properties 名前空間


Legend.overlay フィールド

Legendoverlay フィールド

凡例をグラフに重ねずに表示する

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool overlay
Public overlay As Boolean

フィールド値

型: Boolean
関連項目

参照

Legend クラス
AdvanceSoftware.Charting.Properties 名前空間


Legend.position フィールド

Legendposition フィールド

凡例の位置

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LegendPosition position
Public position As LegendPosition

フィールド値

型: LegendPosition
関連項目

参照

Legend クラス
AdvanceSoftware.Charting.Properties 名前空間


Legend.textProperties フィールド

LegendtextProperties フィールド

文字のオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextProperties textProperties
Public textProperties As TextProperties

フィールド値

型: TextProperties
関連項目

参照

Legend クラス
AdvanceSoftware.Charting.Properties 名前空間


LegendEntry クラス

凡例項目
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesLegendEntry

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class LegendEntry
Public Class LegendEntry

LegendEntry 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


LegendEntry フィールド

LegendEntry 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | textProperties | 文字のオプション
トップ
関連項目

参照

LegendEntry クラス
AdvanceSoftware.Charting.Properties 名前空間


LegendEntry.textProperties フィールド

LegendEntrytextProperties フィールド

文字のオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextProperties textProperties
Public textProperties As TextProperties

フィールド値

型: TextProperties
関連項目

参照

LegendEntry クラス
AdvanceSoftware.Charting.Properties 名前空間


LegendPosition 列挙体

凡例の位置

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum LegendPosition
Public Enumeration LegendPosition
メンバー
メンバー | 値 | 説明
Bottom | 0 | 下
TopRight | 1 | 右上
Left | 2 | 左
Right | 3 | 右
Top | 4 | 上
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Line クラス

枠線
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesLine

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Line
Public Class Line

Line 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | capType | 線の先端
Public フィールド | color | 色、透明度
Public フィールド | compoundType | 一重線/多重線
Public フィールド | dashType | 実線/点線
Public フィールド | headEnd | 始点矢印の種類、サイズ
Public フィールド | joinType | 線の結合点
Public フィールド | tailEnd | 終点矢印の種類、サイズ
Public フィールド | width | 幅(px 単位)
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Line フィールド

Line 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | capType | 線の先端
Public フィールド | color | 色、透明度
Public フィールド | compoundType | 一重線/多重線
Public フィールド | dashType | 実線/点線
Public フィールド | headEnd | 始点矢印の種類、サイズ
Public フィールド | joinType | 線の結合点
Public フィールド | tailEnd | 終点矢印の種類、サイズ
Public フィールド | width | 幅(px 単位)
トップ
関連項目

参照

Line クラス
AdvanceSoftware.Charting.Properties 名前空間


Line.capType フィールド

LinecapType フィールド

線の先端

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LineCapType capType
Public capType As LineCapType

フィールド値

型: LineCapType
関連項目

参照

Line クラス
AdvanceSoftware.Charting.Properties 名前空間


Line.color フィールド

Linecolor フィールド

色、透明度

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color color
Public color As Color

フィールド値

型: Color
関連項目

参照

Line クラス
AdvanceSoftware.Charting.Properties 名前空間


Line.compoundType フィールド

LinecompoundType フィールド

一重線/多重線

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public CompoundLineType compoundType
Public compoundType As CompoundLineType

フィールド値

型: CompoundLineType
関連項目

参照

Line クラス
AdvanceSoftware.Charting.Properties 名前空間


Line.dashType フィールド

LinedashType フィールド

実線/点線

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LineDashType dashType
Public dashType As LineDashType

フィールド値

型: LineDashType
関連項目

参照

Line クラス
AdvanceSoftware.Charting.Properties 名前空間


Line.headEnd フィールド

LineheadEnd フィールド

始点矢印の種類、サイズ

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LineEnd headEnd
Public headEnd As LineEnd

フィールド値

型: LineEnd
関連項目

参照

Line クラス
AdvanceSoftware.Charting.Properties 名前空間


Line.joinType フィールド

LinejoinType フィールド

線の結合点

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LineJoinType joinType
Public joinType As LineJoinType

フィールド値

型: LineJoinType
関連項目

参照

Line クラス
AdvanceSoftware.Charting.Properties 名前空間


Line.tailEnd フィールド

LinetailEnd フィールド

終点矢印の種類、サイズ

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LineEnd tailEnd
Public tailEnd As LineEnd

フィールド値

型: LineEnd
関連項目

参照

Line クラス
AdvanceSoftware.Charting.Properties 名前空間


Line.width フィールド

Linewidth フィールド

幅(px 単位)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int width
Public width As Integer

フィールド値

型: Int32
関連項目

参照

Line クラス
AdvanceSoftware.Charting.Properties 名前空間


LineCapType 列挙体

線の先端

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum LineCapType
Public Enumeration LineCapType
メンバー
メンバー | 値 | 説明
Round | 0 | 丸
Square | 1 | 四角
Flat | 2 | フラット
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


LineDashType 列挙体

実線/点線

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum LineDashType
Public Enumeration LineDashType
メンバー
メンバー | 値 | 説明
Solid | 0 | 実線
Dot | 1 | 点線
Dash | 2 | 破線
LargeDash | 3 | 長破線
DashDot | 4 | 一点鎖線
LargeDashDot | 5 | 長鎖線
LargeDashDotDot | 6 | 長二点鎖線
SystemDash | 7 | 点線 (角)
SystemDot | 8 | 点線 (丸)
SystemDashDot | 9 | システム鎖線
SystemDashDotDot | 10 | システム二点鎖線
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


LineEnd クラス

矢印の種類、サイズ
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesLineEnd

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class LineEnd
Public Class LineEnd

LineEnd 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | length | 矢印のサイズ (長さ)
Public フィールド | type | 矢印の種類
Public フィールド | width | 矢印のサイズ (幅)
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


LineEnd フィールド

LineEnd 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | length | 矢印のサイズ (長さ)
Public フィールド | type | 矢印の種類
Public フィールド | width | 矢印のサイズ (幅)
トップ
関連項目

参照

LineEnd クラス
AdvanceSoftware.Charting.Properties 名前空間


LineEnd.length フィールド

LineEndlength フィールド

矢印のサイズ (長さ)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LineEndLength length
Public length As LineEndLength

フィールド値

型: LineEndLength
関連項目

参照

LineEnd クラス
AdvanceSoftware.Charting.Properties 名前空間


LineEnd.type フィールド

LineEndtype フィールド

矢印の種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LineEndType type
Public type As LineEndType

フィールド値

型: LineEndType
関連項目

参照

LineEnd クラス
AdvanceSoftware.Charting.Properties 名前空間


LineEnd.width フィールド

LineEndwidth フィールド

矢印のサイズ (幅)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public LineEndWidth width
Public width As LineEndWidth

フィールド値

型: LineEndWidth
関連項目

参照

LineEnd クラス
AdvanceSoftware.Charting.Properties 名前空間


LineEndLength 列挙体

矢印のサイズ (長さ)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum LineEndLength
Public Enumeration LineEndLength
メンバー
メンバー | 値 | 説明
Small | 0 | 小
Medium | 1 | 中
Large | 2 | 大
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


LineEndType 列挙体

矢印の種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum LineEndType
Public Enumeration LineEndType
メンバー
メンバー | 値 | 説明
None | 0 | 矢印なし
Triangle | 1 | 矢印
Stealth | 2 | 鋭い矢印
Diamond | 3 | ひし形矢印
Oval | 4 | 円形矢印
Arrow | 5 | 開いた矢印
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


LineEndWidth 列挙体

矢印のサイズ (幅)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum LineEndWidth
Public Enumeration LineEndWidth
メンバー
メンバー | 値 | 説明
Small | 0 | 小
Medium | 1 | 中
Large | 2 | 大
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


LineJoinType 列挙体

線の結合点

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum LineJoinType
Public Enumeration LineJoinType
メンバー
メンバー | 値 | 説明
Round | 0 | 丸
Bevel | 1 | 面取り
Miter | 2 | 角
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


NumberFormat クラス

表示形式
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesNumberFormat

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class NumberFormat
Public Class NumberFormat

NumberFormat 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | formatCode | 表示形式コード
Public フィールド | linkedToSource | シートとリンクする
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


NumberFormat フィールド

NumberFormat 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | formatCode | 表示形式コード
Public フィールド | linkedToSource | シートとリンクする
トップ
関連項目

参照

NumberFormat クラス
AdvanceSoftware.Charting.Properties 名前空間


NumberFormat.formatCode フィールド

NumberFormatformatCode フィールド

表示形式コード

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string formatCode
Public formatCode As String

フィールド値

型: String
関連項目

参照

NumberFormat クラス
AdvanceSoftware.Charting.Properties 名前空間


NumberFormat.linkedToSource フィールド

NumberFormatlinkedToSource フィールド

シートとリンクする

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool linkedToSource
Public linkedToSource As Boolean

フィールド値

型: Boolean
関連項目

参照

NumberFormat クラス
AdvanceSoftware.Charting.Properties 名前空間


Orientation 列挙体

軸の方向

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum Orientation
Public Enumeration Orientation
メンバー
メンバー | 値 | 説明
MaximumToMinimum | 0 | 軸を反転する
MinimumToMaximum | 1 | 軸を反転しない
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Placement クラス

配置、テキストボックス
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesPlacement

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Placement
Public Class Placement

Placement 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | margin | 余白 (左、右、上、下)
Public フィールド | overflow | テキストを図形からはみ出して表示する
Public フィールド | rotation | ユーザー設定の角度
Public フィールド | shapeAutoFit | テキストに合わせて図形のサイズを調整する
Public フィールド | verticalType | 文字列の方向
Public フィールド | wrap | 図形内でテキストを折り返す
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Placement フィールド

Placement 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | margin | 余白 (左、右、上、下)
Public フィールド | overflow | テキストを図形からはみ出して表示する
Public フィールド | rotation | ユーザー設定の角度
Public フィールド | shapeAutoFit | テキストに合わせて図形のサイズを調整する
Public フィールド | verticalType | 文字列の方向
Public フィールド | wrap | 図形内でテキストを折り返す
トップ
関連項目

参照

Placement クラス
AdvanceSoftware.Charting.Properties 名前空間


Placement.margin フィールド

Placementmargin フィールド

余白 (左、右、上、下)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Rectangle margin
Public margin As Rectangle

フィールド値

型: Rectangle
関連項目

参照

Placement クラス
AdvanceSoftware.Charting.Properties 名前空間


Placement.overflow フィールド

Placementoverflow フィールド

テキストを図形からはみ出して表示する

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool overflow
Public overflow As Boolean

フィールド値

型: Boolean
関連項目

参照

Placement クラス
AdvanceSoftware.Charting.Properties 名前空間


Placement.rotation フィールド

Placementrotation フィールド

ユーザー設定の角度

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int rotation
Public rotation As Integer

フィールド値

型: Int32
関連項目

参照

Placement クラス
AdvanceSoftware.Charting.Properties 名前空間


Placement.shapeAutoFit フィールド

PlacementshapeAutoFit フィールド

テキストに合わせて図形のサイズを調整する

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool shapeAutoFit
Public shapeAutoFit As Boolean

フィールド値

型: Boolean
関連項目

参照

Placement クラス
AdvanceSoftware.Charting.Properties 名前空間


Placement.verticalType フィールド

PlacementverticalType フィールド

文字列の方向

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public TextVerticalType verticalType
Public verticalType As TextVerticalType

フィールド値

型: TextVerticalType
関連項目

参照

Placement クラス
AdvanceSoftware.Charting.Properties 名前空間


Placement.wrap フィールド

Placementwrap フィールド

図形内でテキストを折り返す

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool wrap
Public wrap As Boolean

フィールド値

型: Boolean
関連項目

参照

Placement クラス
AdvanceSoftware.Charting.Properties 名前空間


PlotArea クラス

プロットエリア
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesPlotArea

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class PlotArea
Public Class PlotArea

PlotArea 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | axisX | 第 1 軸 横(項目)軸
Public フィールド | axisX2 | 第 2 軸 横(項目)軸
Public フィールド | axisY | 第 1 軸 縦(値)軸
Public フィールド | axisY2 | 第 2 軸 縦(値)軸
Public フィールド | chartProperties | グラフのオプション
Public フィールド | dataTable | データテーブル
Public フィールド | series | 系列
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


PlotArea フィールド

PlotArea 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | axisX | 第 1 軸 横(項目)軸
Public フィールド | axisX2 | 第 2 軸 横(項目)軸
Public フィールド | axisY | 第 1 軸 縦(値)軸
Public フィールド | axisY2 | 第 2 軸 縦(値)軸
Public フィールド | chartProperties | グラフのオプション
Public フィールド | dataTable | データテーブル
Public フィールド | series | 系列
トップ
関連項目

参照

PlotArea クラス
AdvanceSoftware.Charting.Properties 名前空間


PlotArea.axisX フィールド

PlotAreaaxisX フィールド

第 1 軸 横(項目)軸

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Axis axisX
Public axisX As Axis

フィールド値

型: Axis
関連項目

参照

PlotArea クラス
AdvanceSoftware.Charting.Properties 名前空間


PlotArea.axisX2 フィールド

PlotAreaaxisX2 フィールド

第 2 軸 横(項目)軸

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Axis axisX2
Public axisX2 As Axis

フィールド値

型: Axis
関連項目

参照

PlotArea クラス
AdvanceSoftware.Charting.Properties 名前空間


PlotArea.axisY フィールド

PlotAreaaxisY フィールド

第 1 軸 縦(値)軸

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Axis axisY
Public axisY As Axis

フィールド値

型: Axis
関連項目

参照

PlotArea クラス
AdvanceSoftware.Charting.Properties 名前空間


PlotArea.axisY2 フィールド

PlotAreaaxisY2 フィールド

第 2 軸 縦(値)軸

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Axis axisY2
Public axisY2 As Axis

フィールド値

型: Axis
関連項目

参照

PlotArea クラス
AdvanceSoftware.Charting.Properties 名前空間


PlotArea.chartProperties フィールド

PlotAreachartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

PlotArea クラス
AdvanceSoftware.Charting.Properties 名前空間


PlotArea.dataTable フィールド

PlotAreadataTable フィールド

データテーブル

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public DataTable dataTable
Public dataTable As DataTable

フィールド値

型: DataTable
関連項目

参照

PlotArea クラス
AdvanceSoftware.Charting.Properties 名前空間


PlotArea.series フィールド

PlotAreaseries フィールド

系列

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public List series
Public series As List

フィールド値

型: ListT
関連項目

参照

PlotArea クラス
AdvanceSoftware.Charting.Properties 名前空間


Series クラス

系列1
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesSeries

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class Series
Public Class Series

Series 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | approximateCurve | 系列1 近似曲線 1
Public フィールド | axisType | 使用する軸
Public フィールド | chartProperties | グラフのオプション
Public フィールド | chartType | グラフの種類
Public フィールド | dataLabel | 系列1 データ ラベル
Public フィールド | dataPointValues | データポイント
Public フィールド | errorRange | 系列1 Y 誤差範囲
Public フィールド | gapWidth | 要素の間隔(% 単位)
Public フィールド | invertColor | 負の値を反転するときの色、透明度
Public フィールド | invertIfNegative | 負の値を反転する
Public フィールド | overlap | 系列の重なり(% 単位)
Public フィールド | text | 系列名
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


Series フィールド

Series 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | approximateCurve | 系列1 近似曲線 1
Public フィールド | axisType | 使用する軸
Public フィールド | chartProperties | グラフのオプション
Public フィールド | chartType | グラフの種類
Public フィールド | dataLabel | 系列1 データ ラベル
Public フィールド | dataPointValues | データポイント
Public フィールド | errorRange | 系列1 Y 誤差範囲
Public フィールド | gapWidth | 要素の間隔(% 単位)
Public フィールド | invertColor | 負の値を反転するときの色、透明度
Public フィールド | invertIfNegative | 負の値を反転する
Public フィールド | overlap | 系列の重なり(% 単位)
Public フィールド | text | 系列名
トップ
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.approximateCurve フィールド

SeriesapproximateCurve フィールド

系列1 近似曲線 1

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public List approximateCurve
Public approximateCurve As List

フィールド値

型: ListT
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.axisType フィールド

SeriesaxisType フィールド

使用する軸

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public AxisType axisType
Public axisType As AxisType

フィールド値

型: AxisType
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.chartProperties フィールド

SerieschartProperties フィールド

グラフのオプション

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartProperties chartProperties
Public chartProperties As ChartProperties

フィールド値

型: ChartProperties
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.chartType フィールド

SerieschartType フィールド

グラフの種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ChartType chartType
Public chartType As ChartType

フィールド値

型: ChartType
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.dataLabel フィールド

SeriesdataLabel フィールド

系列1 データ ラベル

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public DataLabel dataLabel
Public dataLabel As DataLabel

フィールド値

型: DataLabel
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.dataPointValues フィールド

SeriesdataPointValues フィールド

データポイント

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public List dataPointValues
Public dataPointValues As List

フィールド値

型: ListT
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.errorRange フィールド

SerieserrorRange フィールド

系列1 Y 誤差範囲

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public ErrorRange errorRange
Public errorRange As ErrorRange

フィールド値

型: ErrorRange
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.gapWidth フィールド

SeriesgapWidth フィールド

要素の間隔(% 単位)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int gapWidth
Public gapWidth As Integer

フィールド値

型: Int32
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.invertColor フィールド

SeriesinvertColor フィールド

負の値を反転するときの色、透明度

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Color invertColor
Public invertColor As Color

フィールド値

型: Color
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.invertIfNegative フィールド

SeriesinvertIfNegative フィールド

負の値を反転する

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public bool invertIfNegative
Public invertIfNegative As Boolean

フィールド値

型: Boolean
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.overlap フィールド

Seriesoverlap フィールド

系列の重なり(% 単位)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public int overlap
Public overlap As Integer

フィールド値

型: Int32
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


Series.text フィールド

Seriestext フィールド

系列名

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public string text
Public text As String

フィールド値

型: String
関連項目

参照

Series クラス
AdvanceSoftware.Charting.Properties 名前空間


TextCapsType 列挙体

大文字の種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TextCapsType
Public Enumeration TextCapsType
メンバー
メンバー | 値 | 説明
None | 0 | なし
Small | 1 | 小型英大文字
All | 2 | すべて大文字
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


TextProperties クラス

文字のオプション
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesTextProperties

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class TextProperties
Public Class TextProperties

TextProperties 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | fill | 文字の塗りつぶし
Public フィールド | font | フォント
Public フィールド | line | 文字の輪郭
Public フィールド | placement | テキストボックス
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


TextProperties フィールド

TextProperties 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | fill | 文字の塗りつぶし
Public フィールド | font | フォント
Public フィールド | line | 文字の輪郭
Public フィールド | placement | テキストボックス
トップ
関連項目

参照

TextProperties クラス
AdvanceSoftware.Charting.Properties 名前空間


TextProperties.fill フィールド

TextPropertiesfill フィールド

文字の塗りつぶし

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Fill fill
Public fill As Fill

フィールド値

型: Fill
関連項目

参照

TextProperties クラス
AdvanceSoftware.Charting.Properties 名前空間


TextProperties.font フィールド

TextPropertiesfont フィールド

フォント

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Font font
Public font As Font

フィールド値

型: Font
関連項目

参照

TextProperties クラス
AdvanceSoftware.Charting.Properties 名前空間


TextProperties.line フィールド

TextPropertiesline フィールド

文字の輪郭

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Line line
Public line As Line

フィールド値

型: Line
関連項目

参照

TextProperties クラス
AdvanceSoftware.Charting.Properties 名前空間


TextProperties.placement フィールド

TextPropertiesplacement フィールド

テキストボックス

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public Placement placement
Public placement As Placement

フィールド値

型: Placement
関連項目

参照

TextProperties クラス
AdvanceSoftware.Charting.Properties 名前空間


TextStrikeType 列挙体

取り消し線の種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TextStrikeType
Public Enumeration TextStrikeType
メンバー
メンバー | 値 | 説明
NoStrike | 0 | なし
SingleStrike | 1 | 取り消し線
DoubleStrike | 2 | 二重取り消し線
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


TextUnderlineType 列挙体

下線のスタイル

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TextUnderlineType
Public Enumeration TextUnderlineType
メンバー
メンバー | 値 | 説明
None | 0 | なし
Single | 1 | 一重線
Double | 2 | 二重線
Heavy | 3 | 太線
Dotted | 4 | 点線
HeavyDotted | 5 | 太点線
Dashed | 6 | 破線
HeavyDashed | 7 | 太破線
LongDashed | 8 | 長破線
HeavyLongDashed | 9 | 長太破線
DotDash | 10 | 一点鎖線
HeavyDotDash | 11 | 太一点鎖線
DotDotDash | 12 | 二点鎖線
HeavyDotDotDash | 13 | 太二点鎖線
Wavy | 14 | 波線
HeavyWavy | 15 | 太波線
DoubleWavy | 16 | 二重波線
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


TextVerticalType 列挙体

文字列の方向

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TextVerticalType
Public Enumeration TextVerticalType
メンバー
メンバー | 値 | 説明
Horizontal | 0 | 横書き
Vertical | 1 | 右へ 90 度回転
Vertical270 | 2 | 左へ 90 度回転
EastAsianVertical | 3 | 縦書き
WordArtVerticalRightToLeft | 4 | 縦書き (半角文字含む)
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


TickLabelPosition 列挙体

ラベルの位置

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TickLabelPosition
Public Enumeration TickLabelPosition
メンバー
メンバー | 値 | 説明
High | 0 | 上端/右端
Low | 1 | 下端/左端
NextTo | 2 | 軸の下/左
None | 3 | なし
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


TickMark 列挙体

目盛の種類

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TickMark
Public Enumeration TickMark
メンバー
メンバー | 値 | 説明
Cross | 0 | 交差
Inside | 1 | 内向き
None | 2 | なし
Outside | 3 | 外向き
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


TimeUnit 列挙体

時間の単位

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public enum TimeUnit
Public Enumeration TimeUnit
メンバー
メンバー | 値 | 説明
Days | 0 | 日
Months | 1 | 月
Years | 2 | 年
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


ValueAxis クラス

値軸
継承階層
SystemObject
AdvanceSoftware.Charting.PropertiesAxis
AdvanceSoftware.Charting.PropertiesValueAxis

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public class ValueAxis : Axis
Public Class ValueAxis
    Inherits Axis

ValueAxis 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | builtInDisplayUnit | 表示単位 (組み込み)
Public フィールド | customDisplayUnit | 表示単位 (任意)
Public フィールド | logarithmicBase | 対数目盛を表示する (基数)
Public フィールド | majorUnit | 目盛間隔 (目盛)
Public フィールド | maximum | 境界値 (最大値)
Public フィールド | minimum | 境界値 (最小値)
Public フィールド | minorUnit | 目盛間隔 (補助目盛)
トップ
関連項目

参照

AdvanceSoftware.Charting.Properties 名前空間


ValueAxis フィールド

ValueAxis 型は下記のメンバーを公開します。

フィールド
 | 名前 | 説明
Public フィールド | builtInDisplayUnit | 表示単位 (組み込み)
Public フィールド | customDisplayUnit | 表示単位 (任意)
Public フィールド | logarithmicBase | 対数目盛を表示する (基数)
Public フィールド | majorUnit | 目盛間隔 (目盛)
Public フィールド | maximum | 境界値 (最大値)
Public フィールド | minimum | 境界値 (最小値)
Public フィールド | minorUnit | 目盛間隔 (補助目盛)
トップ
関連項目

参照

ValueAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


ValueAxis.builtInDisplayUnit フィールド

ValueAxisbuiltInDisplayUnit フィールド

表示単位 (組み込み)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public BuiltInUnit builtInDisplayUnit
Public builtInDisplayUnit As BuiltInUnit

フィールド値

型: BuiltInUnit
関連項目

参照

ValueAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


ValueAxis.customDisplayUnit フィールド

ValueAxiscustomDisplayUnit フィールド

表示単位 (任意)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double customDisplayUnit
Public customDisplayUnit As Double

フィールド値

型: Double
関連項目

参照

ValueAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


ValueAxis.logarithmicBase フィールド

ValueAxislogarithmicBase フィールド

対数目盛を表示する (基数)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double logarithmicBase
Public logarithmicBase As Double

フィールド値

型: Double
関連項目

参照

ValueAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


ValueAxis.majorUnit フィールド

ValueAxismajorUnit フィールド

目盛間隔 (目盛)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double majorUnit
Public majorUnit As Double

フィールド値

型: Double
関連項目

参照

ValueAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


ValueAxis.maximum フィールド

ValueAxismaximum フィールド

境界値 (最大値)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double maximum
Public maximum As Double

フィールド値

型: Double
関連項目

参照

ValueAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


ValueAxis.minimum フィールド

ValueAxisminimum フィールド

境界値 (最小値)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double minimum
Public minimum As Double

フィールド値

型: Double
関連項目

参照

ValueAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


ValueAxis.minorUnit フィールド

ValueAxisminorUnit フィールド

目盛間隔 (補助目盛)

名前空間: AdvanceSoftware.Charting.Properties
アセンブリ: AdvanceSoftware.ASReport.Shared (in AdvanceSoftware.ASReport.Shared.dll) バージョン: 12.0.0
構文
C#
VB
コピー
public double minorUnit
Public minorUnit As Double

フィールド値

型: Double
関連項目

参照

ValueAxis クラス
AdvanceSoftware.Charting.Properties 名前空間


AS-Report 12.0 for .NET の概要

AS-Report 12.0 for .NET は、Excel で帳票をデザインする帳票ツールです。帳票ツール独自のデザイナ機能はなく、使い慣れた Excel がそのまま帳票デザイナとなり、フォント、属性、表示形式などの多彩なセル書式設定の他、オートシェイプや図の挿入などで美しい帳票デザインを作成することができます。エンドユーザーがちょっとした変更をしたい場合にも、デザイナが Excel であることが威力を発揮します。

システム動作環境

AS-Report 12.0 for .NET の動作環境を説明します。

体験版について

体験版について説明します。

ライセンスファイルを指定する

体験版から製品版へ移行するためのライセンスファイルの指定方法を説明します。

製品のインストールとアンインストール

製品のインストールとアンインストールをする方法を説明します。

アプリケーションの配布

アプリケーションを配布する方法を説明します。

ライセンス体系

AS-Report 12.0 for .NET のライセンス体系について説明します。

サポートサービス

AS-Report 12.0 for .NET のサポートサービスについて説明します。

サンプル

AS-Report 12.0 for .NET のサンプルプログラムの格納場所について説明します。

AS-Report 12.0 for .NET ヘルプ フィードバック

このヘルプについてのご提案や障害報告をお送りいただく場合は、弊社 Web サイトの「ユーザーサポートフォーム」よりご連絡ください。

  • ドキュメントに表記されている会社名、製品名は一般に各社の商標または登録商標です。
  • 製品の仕様は品質改良の為、予告なく変更することがあります。