Welcome to SecureDELTA APP v2.56

Welcome to SecureDELTA™ APP v2.56

SecureDELTATM APP v2.56

SecureDELTA™ APP v2.56 creates binary diff files from two distinct files, called source and target. It also creates self extracting installers or patch files, that you may freely distribute, with no royalties to your clients, proving that a license for SecureDELTA is acquired. Once launched on your client’s machine, the installer will secure update or patch the source file and convert it into an exact replica of the target file.

SecureDELTA™ is a complex application that combines the creation of create binary diff files similar with deployment of self-extracting installers, we call SecureDELTA Installers. You may chose from SecurePATCH , SecureCMDLine or SecureWIZARD styles.

SecureDELTA™ offers superior performance compared to the next leading competitors, when it comes to memory usage, processor time needed to create the binary diff file and diff file sizes.

SecureDELTA™ is priced at a fraction of the cost of the next leading competitors.

SecureDELTATM APP v2.56 Details

SecureDELTA™ output files are further optimized so that any data compression software, method or algorithm applied on these delta files will result in even better results than the next leading competitors'.

SecureDELTA™ creates patch files for a single file. If you need to create a patch for multiple files, simply pack the files into an uncompressed (stored) archive or a custom format of your own. It is always a good practice and you will get much better results when the patch will be applied to uncompressed files.

SecureDELTA™ needs an active connection to the internet to verify the license information. No personal information is sent over the internet but the necessary data for license validation.

SecureDELTA™ does not stores nor keeps any user-related information. License information is stored locally in windows registry location and the internet connection is only used for verification of trial and licensed versions.

SecureDELTATM APP v2.56 Licensing:

We hope you find SecureDELTA useful. We will continue to work hard to bring the most advanced technology in Software Update!

Purchasing a license from us or from our partners will entitle you to a full year of customer support while most of our competitors offer a limited 6 month support.

Some of the benefits of licensing our technology:

    • Licensed customers of SecureDELTA™ APP may freely distribute any installers created by SecureDELTA™ Application.
    • Free customer and technical support, free updates to SecureDELTA application for 1 year come standard with any license.
    • Support license could also be extended for a very affordable fee.

agersoftware srl. Technology partnerships

Recently, agersoftware srl has entered a strategic partnership with NetLUP ™ Xtreme Technologies. Its R & D division created the XtremeDELTA™ powerful engine which empowers SecureDELTA™ APP since version 2.55 to achieve performance superior to any other binary diff engine we have been thoroughly tested.

As a result of this carefully chosen partnership, further releases of SecureDELTA will include a highly optimized data compression solution developed by XtremeZIP™ division of our strategic technology partners. This combines the benefits of SecureDELTA™ data compression optimizations with a highly sophisticated data compression method, giving you our client, the best performance around when it comes to delta updates and incremental data compression.

XtremeDELTA is marketed exclusively by agersoftware through SecureUPDATE Suite of Products.

Copyright © & ™ 2019-2029 by agersoftware srl. All Rights Reserved.


SecureDELTA Help Content

SecureDELTA APP Help Content

SecureDELTA Help Content:

1. Introduction

1.1 Glossary

1.2 What's new

1.3 SecureDELTA Prices

2. Getting Started

2.1 System Requirements

2.2 Getting help

3. Using SecureDELTA

1.1 Glossary

1.2 What's new

1.3 SecureDELTA Prices

4. SecureDELTA Update Process, the SecureUPDATE

2.1 System Requirements

2.2 Getting help

5. How SecureDELTA compares

1.1 Glossary

1.2 What's new

1.3 SecureDELTA Prices

6. GUI

6.1 SecureENCODE Page:

6.1.1 Adding Source File .

6.1.2 Adding Target File .

6.1.3 Picking a Destination folder for the SecureDELTA binary diff file .

6.1.4 Setting a Name for SecureDELTA binary diff file.

6.1.5 Setting Extended options for SecureDELTA Engine .

6.1.6 Adding Versioning – always a good practice .

6.1.7 Creating the SecureDELTA binary diff file .

6.1.8 The Abort operation .

6.1.9 Other GUI (Graphical User Interface) settings or controls

6.2 SecureDECODE Page:

6.2.1 Decode Page Elements

6.2.2 Select SOURCE file.

6.2.3 Select SecureDELTA file

6.2.4 Edit TARGET file name.

6.2.5 Decoding a SecureDELTA file

6.3 SecureDEPLOY Page:

6.3.1 Setting initial parameters

6.3.2 Adding customer information

6.3.3 Installer options

6.3.4 Installer window style - part 1

6.3.5 Installer window style - part 2

6.3.6 Installer window style - part 3

6.3.7 SecureDELTA Installer - part 1

6.3.8 SecureDELTA Installer - part 2

6.3.9 Building the SecureDELTA installer

6.3.10 Executing the SecurePATCH file - part 1

6.3.11 Executing the SecurePATCH file - part 2

6.3.12 Executing the SecurePATCH file - part 3

6.4 About Page

6.4.1 Component Versions

6.4.2 Partnerships & Copyright

6.4.3 Licensing Information

6.4.4 Trial Registration

6.5 Trademarks Page

7. SecureSFX

7.1 What is a SecureSFX Installer

7.2 SecureSFX internal structure

7.3 SecureSFX decoding engine

7.4 SecureSFX user options

7.5 SecureSFX payload

7.5 SecureSFX Warning and Error Messages

7.6 SecurePATCH

7.6.1 SecurePATCH - part 1

7.6.2 SecurePATCH - part 2

7.6.3 SecurePATCH - part 3

7.7 SecureCMDLine

7.7.1 SecureCMDLine parameter -i

7.7.2 SecureCMDLine parameter -v

7.7.3 SecureCMDLine Installer

7.8 SecureWIZARD

7.8.1 SecureWIZARD Welcome Page

7.8.2 SecureWIZARD Source File Location

7.8.3 SecureWIZARD Validations

7.8.4 SecureWIZARD Public Key Location

7.8.5 SecureWIZARD File Already Updated

7.8.6 SecureWIZARD Updating Page

7.8.7 SecureWIZARD Completion Page

8. Other GUI Elements

9. Unicode Information

10. Software Update Good Practice

11. About agersoftware

8.1 About agersoftware

8.2 agersoftware Trademarks

8.3 agersoftware eStore

8.4 agersoftware Contact information

12. Legal Information

12.1 Terms and Conditions

12.2 Privacy Policy

12.3 Cookies Policy

12.4 GDPR Policy

13. Geolocations

14. EULA


SecureDELTA Package Content

SecureDELTA APP v2.56.109

SecureDELTATM Installation Package Content:

SecureDELTA™ for Windows v2.55 Installation Package contains the following files:

    1. ReadMe.txt - the read me file.
    2. License.txt - end user license agreement and warranty statement file.
    3. SecureDELTA_Manual.chm - this help file.
    4. SecureDELTA_Trial.exe - the application (executable file) for Windows x86/x64 platforms.
    5. SecureDECODE_TRIAL_v2.55_x86/x64.dll - SecureDECODE Engine file in Dynamic Link Library format for Windows 32/64 bit platforms.
    6. SecureENCODE_TRIAL_v2.55_x86/x64.dll - SecureENCODE Engine file in Dynamic Link Library format for Windows 32/64 bit platforms.
    7. LexActivator.dll- the licensing engine in Dynamic Link Library format for Windows x64


1. Introduction

Introducing SecureDELTA™ APP v2.56

Industrial Grade Advanced Software Update Solutions!

*

1. Introduction

Contents:

1.1 Glossary of Used Terms

1.2 What's new in version 2.56

1.3 SecureDELTA Prices


1.1 Glossary

1. Introduction ››

1.1 Glossary of used terms

GLOSSARY TERM | DESCRIPTION
SecureUPDATE™ | Our flagship suite of products (applications) designed to excel in all aspects of secure software updating.
SecureUPDATE™ file | A SecureDELTA or XtremeDELTA type file. They are both binary diff (differencing) files but the building strategy applied consists in totally different algorithms. See below Data Differencing.
SecureDELTA™ | Our flagship application designed to create a binary diff (differencing) file from source and target files. The name comes from the name of the algorithm it uses. See below Data Differencing.
SecureSFX ™ | Generic title for SecureDELTA™ self-extracting installer.
SecurePATCH ™ | SecureDELTA™ self-extracting Installer with a dialog-like behavior (also: SecureDELTA™ Installer, Installer Stub, SecureDELTA™ SFX Stub Installer, SecurePATCH™)
SecureWIZARD ™ | SecureDELTA™ self-extracting Installer with a Wizard like behavior (buttons Back, Next, Finish/Close)
SecureCMDLine ™ | SecureDELTA™ self-extracting Installer that runs in a command line.
SecurePKG™ | SecureDELTA Signing Tool. A standalone executable that could be used to sign/verify SecureUPDATE files from the command line
Secure Encoding | The process to create a SecureUPDATE file. It takes two files, source and target and produces a binary diff file. More info on this page .
Secure Decoding | The reverse process of SecureUPDATE. It recreates an exact replica of the target file, given the source and the binary diff file. More info on this page .
Data differencing | In computer science and information theory, data differencing or differential compression is producing a technical description of the difference between two sets of data – a source and a target. Formally, a data differencing algorithm takes as input source data and target data, and produces difference data such that given the source data and the difference data, one can reconstruct the target data ("patching" the source with the difference to produce the target).
Patch | A patch is a set of changes to a software program or its supporting data designed to update, fix or improve it. This includes fixing security vulnerabilities and/or other bugs, with such patches usually being called bugfixes or just patches. Patches may also be used to improve software functionality, usability or performance.
binary diff file / diff file | In computing, the diff utility is a data comparison tool that calculates and displays the differences between two files. Unlike edit distance notions used for other purposes, diff is line-oriented rather than character-oriented. Implemented with an algorithm like Levenshtein distance which tries to determine the smallest set of deletions and insertions to create one file from the other
SFX / SEA | A self-extracting archive (SFX / SEA) is a computer executable program which contains compressed data in an archive file combined with machine-executable program instructions to extract this information on a compatible operating system and without the necessity for a suitable extractor to be already installed on the target computer. The executable part of the file is known as the stub and the non-executable part the archive
Stub | Referred to it mostly as Stub engine. It is a standalone decoding software program optimized in size and customized to perform different extra tasks, for instance, decode from an attached payload.
Adler32 | A checksum algorithm which was invented by Mark Adler in 1995. It is a modification of the Fletcher checksum. Compared to a cyclic redundancy check of the same length, it trades reliability for speed (preferring the latter).
CRC32 | A cyclic redundancy check (CRC) is an error-detecting code commonly used in digital networks and storage devices to detect accidental changes to raw data. Blocks of data entering these systems get a short check value attached, based on the remainder of a polynomial division of their contents. On retrieval, the calculation is repeated and, in the event the check values do not match, corrective action can be taken against data corruption.
XtremeDELTA algorithm | An advanced binary diff file creation algorithm, developed by the R & D division of NetLUP Xtreme Technologies, agersoftware's strategic technology partner. More details on this on their website, at https://xtremedelta.com
SecureDELTA algorithm | The advanced binary diff file creation algorithm used by our application with the same name, SecureDELTA. It has been developed by the R & D division of agersoftware.
PEAK MEMORY | The maximum amount of memory which was used by the processes or sub-process that is being reported.
CPU TIME | Total processor time, in seconds, used by a process, since it started. CPU time is an indication of how much processing time that the process has used since the process has started. It is basically calculated by: CPU Time of Process = Process Uptime * CPU Utilization of Process
LOCAL or TEST PC (test machine) | The workstation or PC SecureDELTA for Windows is running on. The software has to be either licensed on within the 30 day trial in order to run.
REMOTE or USER PC (user machine) | User PC is your client's PC. This is the remote machine where you will deliver your SecurePATCH files or the binary diff files created with SecureDELTA application.
Transform | A transformation is an revertible function f that maps a set X to itself, i.e. f : X → X. A transformation may simply refer to any function, regardless of domain.
Redundancy | In Information theory , redundancy measures the fractional difference between the entropy H(X) of an ensemble X, and its maximum possible value. Informally, it is the amount of wasted "space" used to transmit certain data. Data compression is a way to reduce or eliminate unwanted redundancy, while check-sums are a way of adding desired redundancy for purposes of error detection when communicating over a noisy channel of limited capacity .
Entropy | Information entropy is the average rate at which information is produced by a stochastic ( randomly determined process) source of data.
MiB | The mebibyte is a multiple of the unit byte for digital information. The binary prefix mebi means 220; therefore one mebibyte is equal to 1048576bytes, i.e., 1024 kibibytes . The unit symbol for the mebibyte is MiB. The unit was established by the International Electrotechnical Commission (IEC) in 1998.
KiB | The kibibyte is a multiple of the unit byte for quantities of digital information . The binary prefix kibi means 210, or 1024; therefore, 1 kibibyte is 1024 bytes. The unit symbol for the kibibyte is KiB. The unit was established by the International Electrotechnical Commission (IEC) in 1998.


1.2 What's new in version 2.56

1. Introduction ››

1.2 What's new SecureDELTA APP v2.56.109

SecureDELTATM v2.56 Key Features:

KEY FEATURES IN V2.56:

Ability to Sign SecureUPDATE Files (SecureDELTA and XtremeDELTA binary diff files)

Ability to Create Signing Keys

Ability to Review SecureUPDATE files

New SecureSFX Types:

      • SecureCMDLine Self-Extracting Installer
      • SecureWIZARD Self-Extracting Installer

More features improved including:

      • Improved SecureSFX GUI, UX and User Options
      • Improved SecureDELTA UI & UX (developed by .Xtreme.UI. division of NetLUP Xtreme Technologies)
      • Improved Integration of XtremeDELTA Engine (developed and produced by XtremeDELTA division of NetLUP Xtreme Technologies)
      • SecureSFX logging and error reporting
      • SecureDELTA ™ Engine is now at version 2.56.109.6440

Graphical User Interface has been designed in collaboration with the .Xtreme.UI. ™ division of NetLUP™ Xtreme Technologies srl.

Data Compression Elements © XtremeZIP ™ division of NetLUP™ Xtreme Technologies srl.

For Trademarks, please read more here.


1.3 SecureDELTA APP Prices

1. Introduction ››

1.3 SecureDELTA™ APP Licensing Price

SecureDELTATM v2.56.109 Licensing Prices:

SecureDELTA creates secure binary diff files & secure self-extracting installers!

SecureDELTA offers you the capabilities of next Leading Competitor's software combined!

Save more than $1700 in licensing fees alone when you purchase a license of SecureDELTA for Windows.

Checkout our online eStore today and help future product development you can also benefit from today!

Our future development depends on your licenses! Thank you!

(*) Information excerpt from leading competitors BuyNow's page.

Comparison made on December 30th, 2019 using list prices and features included with the purchase of a software license.

Prices reflect the regular license price and excluded promotional offers. Comparison is provided for information purposes only.

SecureDELTA mark is a trademark of agersoftware srl. All rights reserved.


2. Getting Started

2. Getting Started with SecureDELTA

Contents:

2.1 System Requirements

2.2 Getting help


2.1 System requirements

2. Getting Started ››

2.1 SecureDELTA™ APP System Requirements:

SecureDELTATM v2.55 for Windows System Requirements:

When creating DELTA file ( Secure Encoding / SecureENCODING ):

Secure ENCODING Minimum System requirements
Memory | 2 GB.
Graphics Card | No requirement
CPU | No requirement
Disk Space | depends on target file size
Operating System | Windows 7, Windows 8, or Windows 10

See different how different file sizes affect memory requirements here .

When reconstructing Target from the DELTA file ( Secure Decoding transform / SecureDECODING ):

Secure ENCODING Minimum System requirements
Memory | 8-12MiB of RAM
Graphics Card | No requirement
CPU | No requirement
Disk Space | depends on target file size
Operating System | Windows 7, Windows 8, or Windows 10

Please note: Secure DECODING technology from SecureDELTA™ is designed to run in low memory environments.


2.2 Getting help

2. Getting Started ››

2.2 SecureDELTA™ Online Help:

SecureDELTATM Online Support Links:

Email: support@agersoftware.com

Wiki Pages: https://wiki.agersoftware.com

Forum: https://forum.agersoftware.com

Support Site: https://support.agersoftware.com


3. Using SecureDELTA™ APP

3. Using SecureDELTA APP

Contents:

3.1 SecureDELTA Output files

3.2 SecureDELTA Permissions


3.1 SecureDELTA Output Files

3. Using SecureDELTA™ APP ››

3.1 SecureDELTA output files

Contents:

During the binary diff file creation process we call SecureENCODING , SecureDELTA APP creates two types of files:

1. SecureUPDATE binary diff file:

This file is output on the Encode page. Applying the secure encoding ( SecureENCODING ) over Source and Target files results in a binary delta file to which a ".SecureDELTA" or ".XtremeDELTA" filename extension is applied.

Please note, this is not a SecureSFX (secure self-eXtracting file). It only the payload needed by SecureSFX, which contains the headers and the set of commands and the binary data (payload) needed to reconstruct on a remove location a bit-by-bit identical target file

2. SecureSFX file:

This file is output on the Installer page. SecureDELTA application outputs a SFX (Self-eXtracting Stub Installer, or SecureDELTA Installer), we also call the SecurePATCH ™ file.

When launched remotely on your client's pc, it will use the source file located within the same folder, to output a target file, bit-by-bit identical with the target file it was created against in the SecureENCODING process.

During the SecureENCODING process, the old file will be renamed with a ".backup" filename extension.


3.2 SecureDELTA Permissions

3. Using SecureDELTA™ APP ››

3.2 SecureDELTA Permissions

Contents:

In order to verify active licenses, SecureDELTA needs an internet connection to be available from time to time.

Connections are only made for the sole purpose of connecting to the License Server and verifying active license.

No other information is sent. No personal information is sent over the internet.

The license validation is done using a third-party vendor. If you have any questions please let us know and we will send you additional information that they have provided to us!

We do not sell, trade, or rent your personal identification information to others.

We may share generic aggregated demographic information not linked to any personal identification information regarding visitors and users with our business partners, trusted affiliates and advertisers for the purposes outlined above.

For example License Validation cannot be done without using the IP information.

We may use third party service provider(s) to help us operate our business and administer activities on our behalf, such as sending newsletters or surveys.

We may share your information with these third parties for those limited purposes. For example: Google Analytics aggregated information.

For more information please see our privacy policy here


3.2.1 Installation Permissions

3. Using SecureDELTA™ APP ›› 3.2 SecureDELTA Permissions ››

3.2.1 SecureDELTA Installation Permissions

Contents:

SecureDELTA Installation Permissions:

In order to install SecureDELTA APP, you must agree to Windows UAC (User Account Control feature) popup by pressing YES.

If you wish to find out more information, click on the Show mode details link.

You may select the 1st link to view information about agersoftware Digital Signing Certificate details:

You can change the UAC setting from your Control Panel application or from the second link.

The following dialog box opens and you may adjust the notification bar according to your


4. SecureUPDATE Process

4. The SecureUPDATE Process

Contents:

4.1 Software Update Process - part 1

4.2 Software Update Process - part 2

4.3 Creating a delta file

4.4 SecureDELTA Encryption

4.5 Secure vs Non-Secure deltas

4.6 SecureENCODING

4.7 SecureDECODING

4.8 SecureENCODING vs SecureDECODING


4.1 Software update process - part 1

4. SecureUPDATE Process ››

4.1 Software Update Process - Part I

Contents:

Software Update Process - part 1

Software update process involves two files and two transforms

    • 1st file is called the source file, old file or initial file.
    • 2nd file is usually called target file, new file or destination file.

The two transforms:

We call the two transforms SecureENCODING and SecureDECODING :

SecureENCODING : The method which creates the delta binary patch file and takes specifically care of optimizing the encryption so that it does not hurt compression. More info on this page .

SecureDECODING : The patching of the source file into becoming bit-by-bit identical to the target file which also includes decrypting of the SecurePATCH. More info on this page .

SecureUPDATE : Software Update process through SecureDELTA


4.2 Software Update process - part 2

4. SecureUPDATE Process ››

4.2 Software Update Process - Part II

Contents:

Software Update Process - part 2

Software update process involves two files

    • First file is called the source file, old file or initial file.
    • The second file is usually called target file, new file or destination file.

There are two transforms that involve the two files.

    • The binary diff file creation (also called delta or patch). We call this process or transform, SecureENCODE. See more here.
    • The patching of the source file into becoming bit-by-bit identical to the target file. We call this process or transform, SecureDECODE. See more here.


4.3 Creating a binary diff (delta) file

4. SecureUPDATE Process ››

4.3 Constructing a Delta file

Contents:

Constructing a Delta file

Here is an example to better understand what a binary diff file is and how target is recreated from the source file and the delta file.

Step 1

E.G.

The content of the source (old) file is: “abcdfghjq”

The content of the target (new) file is: “abcdefgijkrxy”

We note symbol (character) positions starting at 0. At position 0 we have symbol 'a' in the old file and symbol 'a', also, in the new file, and so on so forth. See attached table at column POSITION.

Creating a Delta file means finding a solution to the problem that is often called “the longest common subsequence” problem.

When a Delta file is created, we use only the two files, the source and the target. Thus, we first define a set of commands or instructions, that 'tells' the delta creation application how to construct the new content relying only on the old content.

The processing is done byte by byte, or symbol by symbol, starting at position 0 and comparing symbols from the target file with the symbols in the old file.

Step 2

These instructions are:

      • insert (symbol): we note this command with a plus sign, since it signals an addition of content, ‘+’
      • delete (symbol): we note this command with a minus sign, since it signals a removal of content, ‘-’
      • copy (symbol): we note this command with ‘#’. Current character will be copied from the old file to the new file.

"Insert" (symbol) command is interpreted by inserting the symbol present at the current position in the source (old) file into target (new) file at its current position.

Step 3

Since we are interested in creating the target (new) file, we start by recreating the new content. The above commands are inserted as instructions to reconstruct the new file while leaving out older content which is found to be obsolete.

Following these steps, the new content is now:

# (‘a’ is left out, since it is common to the old content)

# (‘b’left out) # (‘c’ left out)

# (‘d’ left out) command insert (+, e, at position 4… ) and so on so forth

Here is the attached table for all the steps taken to construct the binary diff file.

POSITION | OLD FILE | NEW FILE | DELTA | COMMENT | CURRENT INDEX
0 | a | a | # | Copy ‘a’ | 0
1 | b | b | # | Copy ‘b’ | 1
2 | c | c | # | Copy ‘c’ | 2
3 | d | d | # | Copy ‘d’ | 3
4 | f | e | +e | Add ‘e’ | 4
5 | g | f | # | Copy ‘f’ | 5
6 | h | g | # | Copy ‘g’ / Remove ‘h’ | 6
7 | j | i |  | Add ‘i’ | 7
8 | q | j |  | Copy ‘j’ / Remove ‘q’ | 8
9 | z | k |  | Add ‘k’ | 9
10 |  | r |  | Add ‘r’ | 10
11 |  | x |  | Add ‘x’ | 11
12 |  | y |  | Add ‘y’ | 12

The binary diff file now has the following content: # # # # + e # # - h + i # - q + k + r + x + y

Step 4

We could also write these commands and data (also called payload) in a much more compact form, by removing the obvious redundancy: # # # # will become #.3 meaning just copy data from position current position to current position + 3

See attached table for newly compacted commands:

POSITION | COMMAND | START FROM POSITION | END AT POSITION | DESCRIPTION | COMMENT
0 | # | 0 | 3 | Copy data from position 0 to position 3 | Copy ‘abcd’
1 | +e | 4 | 4 | add ‘e’ at the next position, 4 | +e
2 | # | 5 | 6 | Copy data from position 5 to position 6 | Copy ‘fg’
3 | -h | 6 | 6 | Remove data from position 6 to position 6 | -h
4 | +i | 7 | 7 | Copy data from position 7 to position 7 | +I
5 | # | 8 | 8 | Copy data from position 8 to position 8 | Copy ‘j’
6 | -q | 8 | 8 | Remove data from position 8 to position 8 | -q
7 | + | 9 | 12 | Add ‘krxy’ | +k +r +x +y

As a side note: We always copy data from the source file (old) to the target file (new file).


4.4 SecureDELTA Encryption

4. SecureUPDATE Process ››

4.4 SecureDELTA File Encryption

Contents:

How is a SecureDELTA file ENCRYPTED?

SecureDELTA APP v2.56 introduces another layer of Encryption by using the SecureDELTA Public key on top of the existing encryption!

As noted in the previous slides, the binary diff file will have the following content: # # # # +e # # -h +i # -q +k +r +x +y. Total symbols: 23

In the next step, we write this stream of commands and data in a much more compact form, by removing the obvious redundancy: #3+e#-h+i#-q+krxy. Total symbols: 17.

Already a more compact form, a 26% reduction in size using the formula: 1 – (new symbols count / old symbols count)

However, it is noticeable that the more characters that are inserted, the more visible the input (original message) could become.

For instance, the last command inserts symbols from the current position up to the 12th position.

This means symbols that are copyied from the old file are visible in a non-secure binary delta file.

SecureDELTA solves this by using a proprietary encryption algorithm which is applied on SecurePATCH file data:

ENCRYPTED BINARY DIFF FILE (secured diff file) | versus | UNENCRYPTED BINARY DIFF FILE (non-secured diff file)

Special attention is given to newly inserted symbols as they are not allowed to appear in the ‘clear’. Also, higher consideration is given to the fact that this encryption should not affect a further compression of the file.

The performance of data compression is not affected by more than 1%, on non-secure patches vs SecurePATCH files.

We value your data security therefore, we strive to protect it from ‘curious’ eyes at each step we take.


4.5 Secure vs Non-Secure deltas

4. SecureUPDATE Process ››

4.5 Secure vs Non-Secure DELTA file(s)

Contents:

As specified in the previous chapters...

We’ve chosen the name SecureDELTA to show you that you are not only creating a binary diff file or delta when you are using SecureDELTA, but you also create a specially encrypted file.

Example given: SecureDELTA vs Leading Competitor software

1. SecureDELTA creates secured delta (binary diff) files

2. See how the competition works. E.G.: Leading Competitor software creates non secured delta (binary diff) files


4.5.1 Non-secure deltas

4. SecureUPDATE Process ›› 4.5 Secure vs Non-Secure deltas ››

4.5.1 The competition and its Non-Secure DELTA files

Contents:

As specified in the previous slides...

We will give an example on how SecureDELTA creates secured binary diff files and how the competition, here, Leading Competitor software creates non secured binary diff files

Here is a SCENARIO:

A SECRET KEY is appended in the end of the TARGET FILE. The SOURCE file will be ‘patched’ with a delta file containing a SECRET KEY which SHOULD NOT be visible during the update.

Here is the target file content with the SECRET KEY appended in the end. The SECRET KEY is marked with a red square:

After creating the Leading Competitor binary diff file it is noticeable that it contains the SECRET KEY in the clear, see below:

Also, other pieces of information are visible, for instance file paths or any other binary information.

Leading Competitor binary diff files may leave most of the information in the clear, exactly as it appears in the TARGET file.

Leading Competitor binary diff files may contain unsecured data from the target file in plain text when such data needs to be copied from the target file.

Choose SecureDELTA to protect your data!

Given the unknown method of securing a transport channel for the binary diff file: if you use a Leading Competitor software and your diff files are sent over a non-secure channel, you are simply sending your binary diff file with a plain, in sight, Secret KEY over the (internet) network.


4.5.2 SecureDELTA creates secure diffs

4. SecureUPDATE Process ›› 4.5 Secure vs Non-Secure deltas ››

4.5.2 SecureDELTA creates secured diff files

Contents:

SecureDELTA application creates SECURE BINARY DIFF FILE, we called SECURE SFX

As specified in the previous slides, SecureDELTA creates SecureSFX TM file(s):

Let's resume the example above: A SECRET KEY is appended in the end of the TARGET FILE. This means that the source file will have to be ‘patched’ with a binary diff (delta) file containing a SecretKEY.

This is the target content appended at the end of the target file with the secret KEY:

The SecurePATCH binary diff file created by SecureDELTA application will no longer contain the SecretKey in the clear:

Even searching for a portion of the SecretKEY or the SecretKEY itself, will render the search useless. The SecretKEY is nowhere to be found in the SecurePATCH file.


4.6 Secure ENCODING Process

4. SecureUPDATE Process ››

4.6 SecureENCODING Process:

SecureENCODING Process:

SecureENCODING Process:

We describe the file update procedure as being formed out of two transforms.

The first transform we call Secure Encoding, is the process of creating the a secured binary diff file. This transform ALWAYS happens on the TEST PC .

1st file: The first file is the source file (initial file). It can be any file, usually, an older version than the target file.

2nd file: The target file. It is a newer version of the initial (source) file.

This output file is not compressed but only encrypted. Further compression could be applied on this binary diff file.

We have carefully chosen the encryption method to further allow any compression method to work with a minimum impact in speed and performance.


4.7 Secure DECODING Process

4. SecureUPDATE Process ››

4.7 Secure DECODING Process:

SecureDECODING Process:

SecureDECODING Process:

We describe the file update procedure as being formed out of two transforms.

The second transform we call Secure Decoding. It is the process of applying the patch on the source file and creating a bit-by-bit identical file with the original target file used in Secure Encoding.

1st file: First file is the source file (initial file). This has to be an exact replica on your machine and on your client's machine . It is compared using stored fingerprinting information (in the securedelta file) and it has to be an identical match with the file that has been used to create the SecureDELTA binary diff in the first place.

2nd file: the Second file is always a SecureDELTA file or a Self-eXtracting Installer ( SecurePATCH TM )

The output is the target file or a new file which is bit-by-bit idential with the target file used when creating the SecureDELTA binary diff.

Secure Decoding is simply the reverse transform of Secure Encoding.


4.8 Secure ENCODING vs DECODING

4. SecureUPDATE Process ››

4.8 Secure ENCODING vs Secure DECODING:

SecureENCODING vs SecureDECODING:

Here is a short table to understand what files are used during SecureENCODE and SecureDECODE processes:

TRANSFORM | FILE 1 | FILE 2 | OUTPUT | LOCATION | CONTEXT
SecureENCODING | Source (initial, old) file | Target (new) file | SecureDELTA file | TEST PC (LOCAL) | Encoding Step ( Encode Page ) within SecureDELTA Application
 |  | not needed | SecurePATCH file |  | Installer Step ( Installer Page ) within SecureDELTA Application
SecureDECODING | Source file (*) | SecureDELTA file | Target file (**) | TEST PC (LOCAL) | For testing purposes only. Decoding Step ( Decode Page ) within SecureDELTA Application
 |  | SecurePATCH file |  | USER PC (REMOTE) | SecurePatching of Source file!
Comments: | Source file is ALWAYS required in Encoding and Decoding and its content MUST not CHANGE! |  |  |  |

Please NOTE:

(*) - Do not attempt to update a file that can change or has been changed already, on user's machine, before you apply the SecurePATCH file.

The source file from the User machine has to be bit-by-bit identical, otherwise the SecureUPDATE process will not start.

(**) - this file is a replica bit-by-bit of the Target file from the TEST PC, that has been used to create the SecureDELTA binary diff.

The source (old) and the target files usually have the same name, therefore, the source file will get renamed on user's machine.


5. SecureDELTA vs the competition

5. SecureDELTA vs the competition

Contents:

5.1 Test Files.

5.2 Test Results.

5.3 CPU Usage.

5.4 Memory Requirements.

5.5 Test machine configuration


5.1 Test files

5. SecureDELTA vs the competition ››

5.1 SecureDELTA Test Files

SecureDELTA Test Files:

For our example we will use test files from the “Incremental Compression Benchmark” tests of Matt Mahoney. The tests are explained on this page, here .

The reason for choosing these test files:

      • Files are publicly available for download and test. Test Files can be downloaded from this link.
      • Other test results are available on this page.
      • You can compare our results below with other publicly available result.

Test data description:

"The test data (88 MB, compressed with zpaq -method 2) consists of two directories:

      • mingw44 - 116 MB in 1409 files in 215 directories.
      • mingw45 - 152 MB in 1522 files in 362 directories."

SecureDELTA works like most leading competitor software, accepting only two files for input. Therefor, as a precondition to our tests, the above folders have been compacted separately, with a storing option, in two different files.

These two files have roughly the same sizes as Matt’s test files (zip headers added a few extra KBytes):

mingw_44.stored - size: 111 MiBytes

mingw_45.stored - size: 152 MiBytes


5.2 Test results

5. SecureDELTA vs the competition ››

5.2 SecureDELTA Test Results

SecureDELTA Test Results:

Here are test results on the two files described above :

mingw_44.stored - 116 MiB

mingw_45.stored - 152 MiB

Application | Ver | Binary diff file size (bytes) | PEAK Memory | PEAK CPU Usage | Options | ZIPPED (Max, -9) | Encoding Time (CPU TIME)* | Temporary File Size (bytes) | Comment
SecureDELTA v2.55 | v2.55.107.2081 | 59,161,229 | 539 MiB | 25% | XtremeDELTA | 40,687,441 | 22s | N/A | GUI
Leading Competitor #1 | MFC 6.0 Client Sample Built 07-09-2019 | 102,255,149 | 415 MiB | 25% | MFC 6.0 Client Sample | 79,619,786 | 29s | 105,662,186 bytes | MFC 6.0 Client Sample
Other competitor software | v3.0.4 | 73,418,076 | 286MiB | 25% | -e -I0 -9 -S djw -vfs | 73,153,524 | 29s | N/A |
Leading Competitor #2 | v9.04.0.1 12-Sept-2019 | 86,760,887 |  | 95% | SPEED: 15 RAM USAGE: 32000 | - | 32min 57s | N/A | cmd line. Files with different names, stored in two separate folders
Leading Competitor #2 (different options) | - | 79,664,092 |  | 95% | SPEED: 15 RAM USAGE: 32000 | - | - | N/A | cmd line. File have same names, 44_stored and 44_stored in two separate folders 44 and 45
Leading Competitor #2 (different options) | - | 78,561,452 |  | 95% | SPEED: 10 RAM USAGE: 520000 | - | - | N/A | - same -
Leading Competitor #2 (different options) | - | 77,691,331 |  | 95% | SPEED: 7 RAM USAGE: 720000 | - | 1h 30min+ | N/A | - same -
Leading Competitor #2 (different options) | - | 76,266,298 |  | 96% | SPEED: 3 RAM USAGE: 720000 | - | 15h 40min+ | N/A | - same -

See test machine configuration here .

(*) CPU Time as reported by Task Manager, v10.0.17134.1

More description here .

Comparison made on December 30th, 2019 using list prices and features included with the purchase of a software license.

Prices reflect the regular license price and excluded promotional offers.

Comparison is provided for information purposes only.

All leading competitors are being used here only for the express purposes of this comparison. The trademarks are the property of their respective owners.

SecureDELTA mark is a trademark of agersoftware srl. All rights reserved.


5.3 CPU Usage

5. SecureDELTA vs the competition ››

5.3 SecureDELTA CPU Usage

SecureDELTA Test Results:

SecureDELTA application for Windows is designed for minimum CPU usage.

This way you can arrange for more binary diff files to be created simultaneously, or your work is not to be impacted in any way due to the low CPU usage.

We have performed tests with more than 4 (four) processes of SecureDELTA running simultaneously. We could easily access and work well on the test machine.

Per CPU processor or core, SecureDELTA CPU load tops at most 25%.


5.4 SecureDELTA Memory Requirements

5. SecureDELTA vs the competition ››

5.4 SecureDELTA MEMORY Requirements

Contents:

5.4.1 Memory requirements for SecureENCODING

5.4.2 Memory requirements for SecureDECODING


5.4.1 SecureENCODE Memory Requirements

5. SecureDELTA vs the competition ›› 5.4 SecureDELTA Memory Requirements ››

5.4.1 MEMORY Requirements for Encoding

( SecureENCODE )

SecureENCODE Memory Requirements:

We have performed tests to show how SecureDELTA for Windows v2.56 impacts the Operating System when it creates binary diff file or different sizes.

For this test, we are creating a zero delta file, a binary differencing file created from two identical files. Please note the speed and the memory consumption of SecureENCODING procedure varies heavily on the type of data.

The more redundant the data is, the less information is holds therefore few memory is required to hold and further process that information.

See below the differences on memory requirements from a 300MiB file to a 400MiB file. Even if the 400MiB file is bigger in size, its data is more redundant, therefore the memory requirement is lower, 451MiB versus 639MiB+.

We have chosen slightly redundant files with some exceptions for these tests. See details below.

SecureDELTA algorithm:

FILE SIZE |  | MEMORY USED (MiB) PEAK MEMORY(**) | SecureDELTA File Size (KiB*) | DETAILS
Source File (MiB*) | Target File (MiB*) |  |  |
100 MiB | 100 MiB | 163 MiB | 1.673 KiB |
200 MiB | 200 MiB | 250 MiB | 2.482 KiB |
300 MiB | 300 MiB | 639 MiB | 3.362 KiB |
400 MiB | 400 MiB | 451 MiB | 4.718 KiB | The total memory used usually depends on the redundancy of files. The higher the redundancy, the faster the encoding operating gets. Also, the operation requires less memory (RAM).
500 MiB | 500 MiB | 862 MiB | 6.303 KiB |
600 MiB | 600 MiB | 963 MiB | 7.319 KiB |
700 MiB | 700 MiB | 1.072 MiB | 7.926 KiB |
800 MiB | 800 MiB | 1.374 MiB | 8.996 KiB |
900 MiB | 900 MiB | 1.376 MiB | 9.747 KiB | The total memory used greatly depends on the redundancy of files. The higher the redundancy, the faster the encoding operating gets. Also, the operation requires less memory (RAM).
1.000 MiB | 1.000 MiB | 1.458 MiB | 10.701 KiB |
1.100 MiB | 1.100 MiB | 1.561 MiB | 11.661 KiB |
1.200 MiB | 1.200 MiB | 1.702 MiB | 12.650 KiB |
1.300 MiB | 1.300 MiB | 1.961 MiB | 13.969 KiB |
1.400 MiB | 1.400 MiB | 1.943 MiB | 14.094 KiB |
1.500 MiB | 1.500 MiB | 2.178 MiB | 16.195 KiB |
1.600 MiB | 1.600 MiB | 2.280 MiB | 17.204 KiB |
1.700 MiB | 1.700 MiB | 2.407 MiB | 17.067 KiB |
1.800 MiB | 1.800 MiB | 2.610 MiB | 19.253 KiB |
1.900 MiB | 1.900 MiB | 2.672 MiB | 18.957 KiB |

XtremeDELTA algorithm:

FILE SIZE(s) in MiB* |  | MEMORY USED (PEAK MEMORY) | XtremeDELTA File Size (KiB) | COMMENTS
Source File | Target File |  |  |
100 MiB | 100 MiB | 346 MiB | 0.223 KiB |
200 MiB | 200 MiB | 608 MiB | 0.223 KiB |
300 MiB | 300 MiB | 1.129 MiB | 0.223 KiB |
400 MiB | 400 MiB | 1.102 MiB | 0.223 KiB | Slightly more redundant file.
500 MiB | 500 MiB | 1.656 MiB | 0.223 KiB |
600 MiB | 600 MiB | 1.917 MiB | 0.223 KiB |
700 MiB | 700 MiB | 2.167 MiB | 0.223 KiB |
800 MiB | 800 MiB | 2.691 MiB | 0.223 KiB |
900 MiB | 900 MiB | 2.675 MiB | 0.223 KiB |
1.000 MiB | 1.000 MiB | 2.911 MiB | 0.225 KiB |
1.100 MiB | 1.100 MiB | 3.165 MiB | 0.225 KiB |
1.200 MiB | 1.200 MiB | 3.418 MiB | 0.225 KiB |
1.300 MiB | 1.300 MiB | 3.849 MiB | 0.225 KiB |
1.400 MiB | 1.400 MiB | 3.923 MiB | 0.225 KiB |
1.500 MiB | 1.500 MiB | 4.333 MiB | 0.225 KiB |
1.600 MiB | 1.600 MiB | 4.578 MiB | 0.225 KiB |
1.700 MiB | 1.700 MiB | 4.860 MiB | 0.225 KiB |
1.800 MiB | 1.800 MiB | 5.292 MiB | 0.225 KiB |
1.900 MiB | 1.900 MiB | 5.357 MiB | 0.225 KiB |

Legend:

( *) MiB, KiB - See glossary .

( **) PEAK Memory - See glossary .

(***) Redundancy - See glossary .

See test machine configuration here .


5.4.2 SecureDECODE Memory Requirements

5. SecureDELTA vs the competition ›› 5.4 SecureDELTA Memory Requirements ››

5.4.2 MEMORY Requirements for Decoding

( SecureDECODE )

SecureDECODE Memory Requirements:

SecureDELTA in normal mode

    • SecureDELTA algorithm:

FILE SIZE* |  | MEMORY USED (PEAK MEMORY**)
Source File* | Target File* |
100 MiB | 100 MiB | 6 MiB
200 MiB | 200 MiB | -
300 MiB | 300 MiB | -
400 MiB | 400 MiB | -
500 MiB | 500 MiB | -
600 MiB | 600 MiB | -
700 MiB | 700 MiB | -
800 MiB | 800 MiB | -
900 MiB | 900 MiB | -
1.000 MiB | 1.000 MiB | -
1.100 MiB | 1.100 MiB | -
1.200 MiB | 1.200 MiB | -
1.300 MiB | 1.300 MiB | -
1.400 MiB | 1.400 MiB | -
1.500 MiB | 1.500 MiB | -
1.600 MiB | 1.600 MiB | -
1.700 MiB | 1.700 MiB | -
1.800 MiB | 1.800 MiB | -
1.900 MiB | 1.900 MiB | -

SecureDELTA in xtreme mode

    • XtremeDELTA algorithm:

FILE SIZE* |  | MEMORY USED (PEAK MEMORY**)
Source File | Target File |
100 MiB | 100 MiB | 6 MiB
200 MiB | 200 MiB | -
300 MiB | 300 MiB | -
400 MiB | 400 MiB | -
500 MiB | 500 MiB | -
600 MiB | 600 MiB | -
700 MiB | 700 MiB | -
800 MiB | 800 MiB | -
900 MiB | 900 MiB | -
1.000 MiB | 1.000 MiB | -
1.100 MiB | 1.100 MiB | -
1.200 MiB | 1.200 MiB | -
1.300 MiB | 1.300 MiB | -
1.400 MiB | 1.400 MiB | -
1.500 MiB | 1.500 MiB | -
1.600 MiB | 1.600 MiB | -
1.700 MiB | 1.700 MiB | -
1.800 MiB | 1.800 MiB | -
1.900 MiB | 1.900 MiB | -

( *) MiB - See glossary .

( **) PEAK Memory - See glossary .

(***) Redundancy - See glossary .

See test machine configuration here .


5.5 Test Machine configuration

5. SecureDELTA vs the competition ››

5.5 Test Machine Configuration

Contents:

Comparsion Tests were performed on a Window 10 PRO PC with the following configuration:

Windows is (C) & TM Microsoft Corporation.


6. SecureDELTA for Windows GUI (Graphical User Interface)

6. SecureDELTA Encode PAGE

Contents:

6.1. SecureENCODE Page:

6.1.1 Adding Source File .

6.1.2 Adding Target File .

6.1.3 Picking a Destination folder for the SecureDELTA binary diff file .

6.1.4 Setting a Name for SecureDELTA binary diff file.

6.1.5 Setting Extended options for SecureDELTA Engine .

6.1.6 Adding Versioning – always a good practice .

6.1.7 Creating the SecureDELTA binary diff file .

6.1.8 The Abort operation .

6.1.9 Other GUI (Graphical User Interface) settings or controls

6.2. SecureDECODE Page:

6.2.1 Decode Page Elements

6.2.2 Select SOURCE file.

6.2.3 Select SecureDELTA file

6.2.4 Edit TARGET file name.

6.2.5 Decoding a SecureDELTA file

6.3. SecureSIGN Page:

6.3.1 Setting initial parameters

6.3.2 Adding customer information

6.3.3 Installer options

6.3.4 Installer window style - part 1

6.3.5 Installer window style - part 2

6.3.6 Installer window style - part 3

6.3.7 SecureDELTA Installer - part 1

6.3.8 SecureDELTA Installer - part 2

6.3.9 Building the SecureDELTA installer

6.3.10 Executing the SecurePATCH file - part 1

6.3.11 Executing the SecurePATCH file - part 2

6.3.12 Executing the SecurePATCH file - part 3

6.4. SecureREVIEW:

6.4.1 Decode Page Elements

6.4.2 Select SOURCE file.

6.4.3 Select SecureDELTA file

6.4.4 Edit TARGET file name.

6.4.5 Decoding a SecureDELTA file

6.5. SecureDEPLOY:

6.5.1 Decode Page Elements

6.5.2 Select SOURCE file.

6.5.3 Select SecureDELTA file

6.5.4 Edit TARGET file name.

6.5.5 Decoding a SecureDELTA file


6.1. SecureDELTA Welcome Page

6. SecureDELTA for Windows GUI (Graphical User Interface) ››

6.1 SecureDELTA - The Welcome Page

Contents:

6.1.1. SecureDELTA App Page Links

6.1.2. SecureDELTA External Links

Purpose:

SecureDELTA Welcome Page's purpose is to show off all App features into one single location.

It also helps you access easily a lot more information that would have been otherwise placed on different pages.


6.1.1 SecureDELTA App Page Links

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.1. SecureDELTA Welcome Page ››

6.1.1 SecureDELTA App Page Links

Description:

SecureDELTA Welcome Page's purpose is to display all App features into one single location.

Purpose:

The purpose of SecureDELTA page links is to allow an easy access to SecureDELTA App pages related to a specific content.

For example: A click on the Go to page associate with SecureENCODE will open the SecureENCODE Page


6.1.2 SecureDELTA App External Links

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.1. SecureDELTA Welcome Page ››

6.1.2 SecureDELTA External Links

Description:

SecureDELTA Welcome Page displays all app features into one single location.

Purpose:

The purpose of SecureDELTA page links is to allow easy access to SecureDELTA pages and also related websites. They include help, support or forum related resources.

Also, a link to application coupons and online store is present on this page.

The following links can be access from this page:

Online Wiki redirects you to https://wiki.securedelta.eu

Online Support redirects you to https://support.securedelta.eu

Online Forums redirects you to https://forum.securedelta.eu

Online Documentation redirects you to https://docs.securedelta.eu

Local Help File redirects you to https://docs.securedelta.eu if, for some reason, SecureDELTA App local help file is not found.

Online Store redirects you to https://estore.agersoftware.com

Use a coupon and save link opens the Coupons Page of SecureDELTA App .


6.2 SecureENCODE Page

6. SecureDELTA for Windows GUI (Graphical User Interface) ››

6.2 SecureENCODE PAGE

Contents:

6.2.1 Adding Source File .

6.2.2 Adding Target File .

6.2.3 Picking a Destination folder for the SecureDELTA binary diff file .

6.2.4 Setting a Name for SecureDELTA binary diff file.

6.2.5 Setting Extended options for SecureDELTA Engine .

6.2.6 Adding Versioning – always a good practice .

6.2.7 Creating the SecureDELTA binary diff file .

6.2.8 The Abort operation .

6.2.9 Other GUI (Graphical User Interface) settings or controls

SecureENCODE Page overview:


6.2.1 Selecting SecureENCODE Page

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.2 SecureENCODE Page ››

6.2.1 SecureENCODE Page

Selecting the SecureENCODE Page:

You may either select the SecureENCODE Page from the tab control

You may select SecureENCODE from the Welcome Page:


6.2.2 SecureENCODE Page GUI elements

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.2 SecureENCODE Page ››

6.2.2 SecureENCODE Page GUI Elements

SecureENCODE Page GUI Elements:

For a detailed description start with the next page.


6.2.3 How to add the source file

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.2 SecureENCODE Page ››

6.2.3 Adding Source File

Adding the Source File:

To add, modify or edit the source file name used to create the SecureDELTA binary diff files, there are multiple choices.

You may:

a) Edit the source file name combobox

b) Select / Press the browse button to open a File Open Dialog and select a file

c) Select / Press the combobox arrow and select from the list of previously used files


6.2.4 How to add the target file

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.2 SecureENCODE Page ››

6.2.4 Adding Target File

Adding the Target File:

To add, modify or edit the target file name used to create the SecureDELTA binary diff files, there are multiple choices.

You may:

a) Edit the source file name combobox

b) Press the browse button to open a File Open Dialog and select a file

c) Press the combobox arrow and select from the list of previously used files


6.2.5 How to pick a destination folder

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.2 SecureENCODE Page ››

6.2.5 SecureDELTA Destination Folder

Change destination folder for SecureDELTA file:

How to pick a destination folder for SecureDELTA file.

You may:

a) Edit the SecureDELTA file name in the edit box

b) Press the browse button to pick a destination folder for the SecureDELTA binary diff file.

c) Press the combobox arrow and select from the list of previously used files.


6.2.6 How to create the secure diff file

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.2 SecureENCODE Page ››

6.2.6 Create SecureDELTA File

Creating your first SecureDELTA file:

When all the information has been validated, the SecureENCODE button located on the SecureENCODE Page becomes enabled.

Once all the information has been verified, the following information appear in the Message window area:

You may press the Encode button to create the binary diff file. The progress bars update immediately with SecureDELTA callback information:

We have also added an updated progress bar control that displays the Estimated and Remaining Time of current action!


6.2.7 Encoding details dialog window

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.2 SecureENCODE Page ››

6.2.7 SecureENCODE PAGE

SecureENCODE Details Window Dialog:

SecureENCODE action finishes with a dialog that shows the following information:

Information about the source file:

    • Link to locate the source file in the explorer window
    • Size in bytes

Information about the target file:

    • Link to locate the target file in the explorer window
    • Size in bytes

Information about the binary diff file:

    • Link to locate the target file in the explorer window
    • Size in bytes

You may also chose not to show this dialog again, when "Do not show..." checkbox

is selected and the OK button is pressed.


6.2.8 How to set extended engine options

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.2 SecureENCODE Page ››

6.2.8 SecureDELTA Engine Options

Set extended engine options:

In the Extended Engine Options area from SecureENCODE Page...

...you may select to:

a) enable/disable the XtremeDELTA Engine options for boosting SecureUPDATE performance.

b) change the CPU priority for SecureDELTA application process.

c) change the Encryption Standard used. Currently, only Blowfish 448 bit encryption is used.


6.2.9 How to use versioning

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.2 SecureENCODE Page ››

6.2.9 How to use versioning

Creating your first SecureDELTA file:

It’s always a good practice to add version information for every file you want to update...

...and SecureDELTA App allows you to add this feature to your software updates!

Here are the steps to add versioning in the SecureDELTA:

a) Enable the "Use (file) versioning..." checkbox

This will enable the two edit boxes located next to the Source file version text and also the Target file version edit control

You may edit the version information. It will be inserted in the windows registry on the target machine once installation is done.

b) Use files that have already version information. If the version entry in any known file format (DLL, EXE, etc) is recognized and validated it will be automatically inserted into the edit control.

Example given, executable RNArcade.exe contains manifest version 1.02.000.0129

When this information is present, this information shows under property tab in windows explorer. E.G. SecureDELTA_Trial_v2.56.exe properties window from windows explorer:


6.2.10 How to abort current process

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.2 SecureENCODE Page ››

6.2.10 Aborting current action

How to abort the SecureENCODE action:

When the operation of SecureDELTA is ongoing, you may press the Abort button to stop the encoding or the decoding operation.

Once the Abort button is pressed, a warning MessageBox is shown:

Pressing Yes will abort the current operation. This applies to SecureENCODING and SecureDECODING processes, as well.


6.3 SecureDECODE Page

6. SecureDELTA for Windows GUI (Graphical User Interface) ››

6.3 SecureDECODE Page

Contents:

6.3.1 SecureDECODE Page GUI Elements

6.3.2 Select SOURCE file.

6.3.3 Select SecureDELTA file

6.3.4 Edit TARGET file name.

6.3.5 Decoding a SecureDELTA file

SecureDECODE Page overview:


6.3.1 Selecting the SecureDECODE Page

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.3 SecureDECODE Page ››

6.3.1 SecureDECODE Page

Selecting the SecureDECODE Page:

You may either select the SecureDECODE Page from the tab control:

Or you may select SecureDECODE from the Welcome Page!


6.3.2 SecureDECODE Page GUI elements

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.3 SecureDECODE Page ››

6.3.2 SecureDECODE Page GUI Elements

SecureDECODE Page GUI Elements:

Decode Page GUI Elements brief description

For a detailed description start with the next page


6.3.3 How to select a source file

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.3 SecureDECODE Page ››

6.3.3 How to select a source file

Selecting the source file:

How to select a source file

If you have already created the SecureDELTA file, by selecting the SecureDECODE header:

You will see the Source filename is automatically filled in with the same ‘initial’ file used to create the SecureDELTA file.

You may also edit the box associated with the Source filename or select using the combobox arrow a previously used file.


6.3.4 How to select a SecureDELTA file

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.3 SecureDECODE Page ››

6.3.4 Select the SecureDELTA File

Selecting the SecureDECODE file:

How to select a SecureDELTA file

If you have already created the SecureDELTA file, by selecting the Decode header

You will see the Source filename is automatically filled in with the same ‘initial’ file used to create the SecureDELTA file.

You may also edit the box associated with the Source filename or select using the combo-box arrow a previously used file.


6.3.5 How to select the Target file

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.3 SecureDECODE Page ››

6.3.5 Select the Target File

Selecting the Target file:

How to edit the Target file.

The Target file editbox is automatically filled in with the same target filename used to create the SecureDELTA file. See more on creating the SecureDELTA file here .

However, since the decoding process is used for testing only, it is always a good practice to use a different target file name than the one used in the Encoding process.

If the same file name used in encoding is used, the application will display a warning message, prompting the user to acknowledge if the original target file may be overwritten.

You must acknowledge and press the Yes button if it is desired to overwrite the original target file.

Also, you may chose a different target filename for the Decoding process.


6.3.6 Decoding a SecureDELTA file

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.3 SecureDECODE Page ››

6.4.1 Decoding SecureDELTA file

Decoding SecureDELTA File:

Decoding a secure delta file on DecodePage of SecureDELTA application - for Testing Purposes

*

To decode a secure delta file means to perform the inverse transform (transform-1) of the encoding operation.

The encoding transform we call Secure Encoding (see SecureENCODING ) and the inverse of this transform secure decoding (see SecureDECODING )

In a nutshell: To decode a SecureDELTA file means to update the source file or to apply the patch on the source file and create a new target file.

This transform is executed on the TEST PC. It is designed for testing purposes. For Production and Release, a SecurePATCH file will be executed on the clients' machine.

See more on Building the SecurePATCH file.

**

Performing the decoding transform

Step 1.

When all the required information for secure decoding have been validated, the Hints and Tips area will update the following message: "You may press ... "

See more GUI Elements on this page

Step 2.

Once all the information needed for Decoding has been validated, the user may press the Decode button to start the decoding process.

Step 3.

The progress bars immediately updates to reflect the percentages of the decoding process. The main status for the entire decoding operation is also updated.

User may also press the Abort button to cancel the decoding process at any time. See more on the abort procedure here.


6.4 SecureSIGN Page

6. SecureDELTA for Windows GUI (Graphical User Interface) ››

6.4 SecureSIGN Page

Contents:

6.4.1 Selecting SecureSIGN Page

6.4.2 Signing Overview

6.4.3 Create Signing Keys

6.4.4 How Signing Works on Local Machine(s)

6.4.5 How Validation Works on Target Machine(s)

SecureSIGN Page overview:


6.4.1 Selecting SecureSIGN Page

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.4 SecureSIGN Page ››

6.4.1 Selecting SecureSIGN Page

Selecting the SecureSIGN Page:

You may either select the SecureSIGN Page from the tab control:

Or you may select SecureSIGN from the Welcome Page!


6.4.2 Signing with ECDSA Overview

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.4 SecureSIGN Page ››

6.4.2 Signing Overview

Signing overview

The signing is done using ECDSA: Elliptic Curve Digital Signature Algorithm

For further reading on this algorithm, please access these external links:

    • Digital Signature Standard (DSS) (PDF) - Download PDF here
    • The Elliptic Curve Digital Signature Algorithm (ECDSA) Don Johnson and Alfred Menezes, Scott Vanstone - Certicom Research, Canada Dept. of Combinatorics & Optimization, University of Waterloo, Canada - Download PDF here
    • Accredited Standards Committee X9 , American National Standard X9.62-2005, Public Key Cryptography for the Financial Services Industry, The Elliptic Curve Digital Signature Algorithm (ECDSA), November 16, 2005.
    • Certicom Research, Standards for efficient cryptography, SEC 1: Elliptic Curve Cryptography , Version 2.0, May 21, 2009.
    • López, J. and Dahab, R. An Overview of Elliptic Curve Cryptography , Technical Report IC-00-10, State University of Campinas, 2000.
    • Daniel J. Bernstein , Pippenger's exponentiation algorithm , 2002.
    • Daniel R. L. Brown, Generic Groups, Collision Resistance, and ECDSA, Designs, Codes and Cryptography, 35, 119–152, 2005. ePrint version
    • Ian F. Blake, Gadiel Seroussi, and Nigel Smart , editors, Advances in Elliptic Curve Cryptography , London Mathematical Society Lecture Note Series 317, Cambridge University Press, 2005.
    • Hankerson, D.; Vanstone, S. ; Menezes, A. (2004). Guide to Elliptic Curve Cryptography. Springer Professional Computing. New York: Springer . doi : 10.1007/b97644 . ISBN 0-387-95273-X .


6.4.3 Creating the ECDSA Signing Keys

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.4 SecureSIGN Page ››

6.4.3 Creating the ECDSA Signing Keys

Creating the ECDSA Signing Keys

Two files are required to sign a SecureDELTA or XtremeDELTA package: the Private and the Public Key files.

The private/public key pair can only be generated by using the GUI on the SecureSIGN page.

If the pair of files is not located in the local folder when the application has started, SecureDELTA App displays the following message: "SecureKey files mismatch. Press "Generate..." to recreate the keys"

After the private/public keys are generated, they can only be removed manually. This is done to prevent accidental overwriting or the key. The reason is that after SecureUPDATE files (SecureDELTA or XtremeDELTA) are signed, they can only be processed (SecureDECODED) only if the Public Key from the exact pair of files used to Sign them is used.

Since SecureUPDATE file headers are encrypted there is no possible reconstruction of the header data without the right Public Key file. SecureUPDATE (SecureDELTA or XtremeDELTA) file(s) already signed get rendered completely unusable.

Please store your Private/Public KEY pairs in a safe dry place!

If you really want to remove them (manually), access the link "Manually Remove key files" link from the SecureSIGN page.

The following warning message will present you the information above:


6.4.4 Local Machine ECDSA Signing

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.4 SecureSIGN Page ››

6.4.4 Local Machine ECDSA Signing

How Signing works on Local Machine

SecureSIGNING takes place only on the LOCAL Machine.

On a Local Machine, the Private and the Public Keys co-exist. SecureSIGN makes use of the Private Key to sign SecureUPDATE files and the Public Key to validate them.

Steps to accomplish SecureSIGN:

Step 1: The binary data difference file is created in the form or a SecureUPDATE file ( SecureDELTA or XtremeDELTA)

Step 2: The Private/Public Key pair is generated using the ECDSA algorithm.

Step 3: SecureUPDATE files are encrypted using Public Key data.

Step 4: Depending on the chosen method, an MD5 or a SHA256 is computed on the whole SecureUPDATE diff file from Step 1.

Step 5: The MD5 or the SHA256 generated is signed using the Private key and the ECDSA algorithm.

Step 6: SecureUPDATE header file information is encrypted and secured.


6.4.5 Target Machine ECDSA Validation

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.4 SecureSIGN Page ››

6.4.5 Target Machine ECDSA Validation

How validation works on Target Machine(s)

Validation action usually takes place only the TARGET Machine.

On a TARGET Machine, only the Public Key should be present. SecureDELTA makes use of the Private Key to sign SecureUPDATE files and the Public Key to validate them.

Step 1: Depending on the stored algorithm, an MD5 or a SHA256 is computed on the whole SecureUPDATE diff file.

Step 2: The MD5 or the SHA256 generated is verified using the Public key and the ECDSA algorithm.

Step 3: After validation, sensitive header information is decrypted and SecureUPDATE process starts.

Recommendation: Use a secure channel to 'transport' the Public KEY on TARGET Machine(s)

Steps to accomplish SecureSIGN Validation on TARGET MACHINEs:


6.4.6 Signing SecureUPDATE File(s) - Part I

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.4 SecureSIGN Page ››

6.4.6 Signing SecureUPDATE File - Part I

Signing SecureUPDATE file(s) - Part I

To sign a SecureUPDATE file, the steps are:

a) Edit, Drag and Drop or select from the ComboBox a SecureUPDATE file (SecureDELTA or XtremeDELTA file)

b) Generate the Private/Public Key pairs, if files have not been already generated

Once this step has been accomplished, the Sign button get enabled, and the information "SecureDELTA file is ready for signing" appears.

There is a choice of a hashing algorithm, when the button is pressed or the split button arrow is pressed:

MD5 Hash selection will use the MD5 algorithm to create a fingerprint of the entire SecureUPDATE file. MD5 is a message-digest algorithm that is a widely used hash function producing a 128- bit hash value.

For further information on MD5 Message Digest, please see external RFC 1321 "The MD5 Message-Digest Algorithm RFC"

However, there is a well-documented weakness in the algorithm, that is why agersoftware decided to also include a 256bit message-digest algorithm, as another solution to signing binary diff files, called SHA.

MD5 produces a message/file-digest or a file fingerprint, for instance:

If a single bit is modified within the SecureUPDATE file content or header, the same MD5 algorithm applied on the file produces another result, for instance:

Mismatch fingerprints signal the fact that the SecureUPDATE file has been altered or modified. SecureDECODE will not install the update on the TARGET MACHINE!

SHA256 uses the 256bit version of the well known SHA algorithm.

For further information on the Secure HASH Algorithm Standards used, please access "Descriptions of SHA-256, SHA-384, and SHA-512" - Download PDF from csrc.nist.gov


6.4.7 Signing SecureUPDATE File(s) - Part II

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.4 SecureSIGN Page ››

6.4.7 Signing SecureUPDATE file(s) - Part II

Signing SecureUPDATE file(s) - Part II

Once the HASHING algorithm is selected, SecureDELTA App carries out the steps 3 to 6 (see full picture here ):

Step 3: SecureUPDATE files are encrypted using Public Key data.

Step 4: Depending on the chosen method, an MD5 or a SHA256 is computed on the whole SecureUPDATE diff file.

Step 5: The MD5 or the SHA256 generated is signed using the Private key and the ECDSA algorithm.

Step 6: SecureUPDATE header file information is encrypted and secured.

There is also a NOTE that accompanies the signing action:

A progress bar also displays, especially useful when signing large files. It estimates the entire process and displays remaining time, as well.

The signing process finalizes with the update of the text information area on "...file is already signed"

ECDSA Signing Process is now completed!

You have now the possibility to verify (validate) the SecureUPDATE file by using the Public Key file.


6.4.8 Validating SecureUPDATE file(s)

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.4 SecureSIGN Page ››

6.4.8 Validating SecureUPDATE File(s)

Validating (verifying) SecureUPDATE file(s)

To validate SecureUPDATE file(s), the steps are:

a) Edit, Drag and Drop or select from the ComboBox a SecureUPDATE file (SecureDELTA or XtremeDELTA file)

b) Assuming the SecureUPDATE is signed, you will immediately notice the following status text: "...file is already signed".

The Verify button is also shown:

c) Once pressed, the Verify operation launches the algorithmic verification of the file signature, by decrypting and validating the information and following the steps described here.

The result is immediately displayed in the GUI and the status text updates to "Successfully verified..."


6.5 SecureREVIEW Page

6. SecureDELTA for Windows GUI (Graphical User Interface) ››

6.5 SecureREVIEW Page

Contents:

6.4.1 Selecting SecureREVIEW Page

6.4.2 Select SOURCE file.

6.4.3 Select SecureDELTA file

6.4.4 Edit TARGET file name.

6.4.5 Decoding a SecureDELTA file

SecureREVIEW Page overview:


6.5.1 Selecting SecureREVIEW Page

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.5 SecureREVIEW Page ››

6.5.1 Selecting ScureREVIEW Page

Selecting the SecureREVIEW Page:

You may either select the SecureREVIEW Page from the tab control:

Or you may select SecureREVIEW from the Welcome Page!


6.5.2 SecureREVIEW GUI Elements

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.5 SecureREVIEW Page ››

6.5.2 SecureREVIEW GUI Elements

Selecting the SecureREVIEW Page:

SecureREVIEW Page displays information...

...about SecureUPDATE (SecureDELTA and XtremeDELTA) files and also user related information about SecureSFX files (SecurePATCH, SecureCMDLine, SecureWIZARD)

SecureSFX files are SecureDELTA Self-eXtracting-Files that bundle SecureDECODE engine with user options and SecureUPDATE files. See more on SecureDEPLOY page.

SecureREVIEW page contains two edit combo boxes and an informational control which displays associated information on selected files.


6.5.3 Reviewing SecureUPDATE file(s)

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.5 SecureREVIEW Page ››

6.5.3 Reviewing SecureUPDATE File(s)

Reviewing a SecureUPDATE file:

When a SecureUPDATE file is selected...

...either a SecureDELTA or an XtremeDELTA file, decrypted data from SecureUPDATE file header is displayed in the information control, see below.

The information control also displays additional information related to the SecureUPDATE process:

Minimum version to extract

Digital Signature presence

ADLER32 fingerprint information

Engine type - SecureDELTA or XtremeDELTA

Creation Time of the SecureUPDATE file

Source File information such as

      • Source filename
      • Source file version
      • Embedded file version (in case the file embeds versioning information)

Target File information

      • Target file version
      • Embedded file version (in case the file embeds versioning information)

The information alone is presented Read-Only and cannot be modified. When a certain cell is selected, the control displays also couple of rows of informational text on the bottom of the control:

For instance, if the Minimum Version is selected from the control, the informational text displays: "Minimum Version required to decode...

For the Engine Type, it take SecureDELTA or XtremeDELTA values:


6.5.4 Reviewing a SecureSFX file(s)

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.5 SecureREVIEW Page ››

6.5.4 Reviewing SecureSFX File(s)

Reviewing a SecureSFX file:

When a SecureSFX file is selected...

...decrypted data from SecureSFX file header is displayed in the information control.

The control also displays SecureDECODE Engine related information and other SecureSFX user related information. See below.

The user-related information are the following data:

    • Product and Company info
      • Product Name: The Name of the Product that is receiving the update.
      • WebLink: The company or product website link (URL)
      • Copyright: The Copyright information related to the company or the product that is receiving the update.
      • Company Name:
    • Installer Options:
      • At Start: Application StartUp behavior
      • At End: Application AtEnd behavior
    • Installer Window Style:
      • No Background Gradient Window
      • Standard with Caption Bar and Buttons (minimize, maximize, close)
      • Standard with Caption Bar only
      • Bordered, no Caption Bar
      • Just background
    • Installer Window Gradient
      • Background window
      • Solid Color
      • Product Name Text Color
      • Company Name Text Color
      • Product URL Text Color
      • Copyright Text Color

The "user" related information can be modified when SecureSFX file is created. More information here .


6.6 SecureDEPLOY Page

6. SecureDELTA for Windows GUI (Graphical User Interface) ››

6.6 SecureDEPLOY Page

Contents:

6.6.1 Setting initial parameters

6.6.2 Adding customer information

6.6.3 Installer options

6.6.4 Installer window style - part 1

6.6.5 Installer window style - part 2

6.6.6 Installer window style - part 3

6.6.7 SecureDELTA Installer - part 1

6.6.8 SecureDELTA Installer - part 2

6.6.9 Building the SecureDELTA installer

6.6.10 Executing the SecurePATCH file - part 1

6.6.11 Executing the SecurePATCH file - part 2

6.6.12 Executing the SecurePATCH file - part 3

SecureDEPLOY Installer Page overview:


6.6.1 Selecting SecureDEPLOY Page

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.6 SecureDEPLOY Page ››

6.6.1 Selecting SecureDEPLOY Page

Selecting the SecureDEPLOY Page:

You may either select the SecureDEPLOY Page from the tab control:

Or you may select SecureDEPLOY from the Welcome Page!


6.6.2 Setup Initial SecureSFX parameters

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.6 SecureDEPLOY Page ››

6.6.2 Setup initial SecureSFX parameters

Setting up initial SecureSFX parameters:

On the SecureDEPLOY page...

...you can create a SecureSFX Installer with one click.

That is if you want to use the default SecureSFX Options. If you use default settings, the only thing required to build a SecureSFX is the path to the SecureDELTA file.

All other parameters will be added by default. See here details on the default SecureSFX parameters.

Additional parameters can also be set to make a SecureSFX Installer unique and can be customize with additional details and information (see in the next sections).


6.6.3 Advanced SecureSFX Options

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.6 SecureDEPLOY Page ››

6.6.3 Advanced SecureSFX Options

Adding Advanced SecureSFX Options:

On SecureDEPLOY page...

...you may access Advanced SecureSFX Options by pressing the "More SecureSFX Options" button

Once selected, a SecureSFX Options dialog window displays where you may add, change or remove more information related to SecureSFX Installer you want to deploy in 4 different steps/areas:

STEP 1: Change, Add or Remove Product Name and Company

STEP 2: Change or Add Installer Gradient window

STEP 3: Change Target Machine settings

STEP 4: Set Other Options


6.6.3.1 Adding Customer Information

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.6 SecureDEPLOY Page ›› 6.6.3 Advanced SecureSFX Options ››

6.6.3 Adding Customer Information

Adding Customer Information:

Customer information is ZONE 1.

On here, you have an overview of the displayed text on the Gradient Window, see below, what text, text colors and shadows are used. They are used exclusively in the Gradient Window

You may change add or remove Product Name & Company related information, such as:

    • Product name and version for which the installer is created.
    • Company name for which the product belongs
    • Copyright information related to the user product
    • Company URL

You may decide to disable this information from displaying without deleting it.

Any text information will be displayed on the gradient window of the SecureSFX Installer only if the associated checkbox is checked.

Unchecking these check boxes will not delete the text information associated with them.

Also, each text string can be displayed with a 3D shadow or simple text:

This is controlled by the right-sided checkboxes.

You may also change the text color information as well:

The information you have provided will be finally displayed on the SecurePATCH gradient window:


6.6.3.2 Setting Up the Gradient Window

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.6 SecureDEPLOY Page ›› 6.6.3 Advanced SecureSFX Options ››

6.6.3.2 Setting Up Gradient Window

Displaying Gradient Window:

ZONE 2 is reserved for Gradient Window Set Up Information.

On here, you may select if you want to use the Gradient Window background and further customize it.

The Customer Information from ZONE 1 are used also in this Gradient Window

The dialog controls in this section are designed to make it easier for you to chose the type or the style of the gradient window.

Setting up a gradient window can be done in TWO STEPS:

Step 1:

First selection is the Window Style.

The values are the following:

    • No Background Window
    • Standard with Captions and Buttons
    • Standard with Caption only
    • Bordered no Caption
    • Just Background

See the differences on the Window Styles here

Once you select an option different from No Background Window, more options enable:

The Show Production Gradient Window checkbox will expand the gradient window into a full-screen window so that you can see the window exactly as it will appear on the target machine. See more on here .

The Color Style combo box may have the following values:

    • Solid Color
    • Vertical Gradient
    • Horizontal Gradient

When a Vertical or Horizontal Gradient is selected the solid color control enables to allow selection of two colors to create the gradient. See more details on here

The Picture Button will control the appearance of the Demo Gradient Window, if this is closed by the central button:

The information you provide in these controls will affect the style and the look of the Gradient Window


6.6.6 SecureSFX Installer Window Style - part 1

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.6 SecureDEPLOY Page ›› 6.6.3 Advanced SecureSFX Options ›› 6.6.3.2 Setting Up the Gradient Window ››

6.6.6 SecureSFX Installer Window Style - part 1

SecureSFX Installer Window Styles - part 1:

When you select an option...

...that is different from “No Gradient Window” option, more options could be set.

Background window combo box controls the way the gradient window appears when the Installer is running on your client’s machine.

Color Styles define the way the gradient is displayed within the Installer Gradient windows.

Values selected could be either Vertical or Horizontal Gradient

Choosing any will allow you to also select the gradient colors:

Press any color-selection combo box to select the ‘source’ and ‘target’ colors that define the gradient:

When the color-selection combo box is pressed, the color pick window shows up

Any color can be selected. The choice will immediately be considered and the mock-up

gradient window will update accordingly:

Select Vertical gradient

Pressing the blue icon button, a mock-up gradient window appears with text from the Installer Product and Company information area.

The result will be shown in the mock-up demo window as follows

Vertical gradient:

Horizontal gradient:


6.6.7 SecureSFX Installer Window Style - part 2

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.6 SecureDEPLOY Page ›› 6.6.3 Advanced SecureSFX Options ›› 6.6.3.2 Setting Up the Gradient Window ››

6.6.7 SecureSFX Installer Window Style - part 2

SecureSFX Installer Window Styles - part 2:

The SecureSFX Self-eXtracting Installer window may have the following window styles:

Style 1:

Standard Window with Caption and Buttons:

Style 2:

Standard Window with Caption and no Buttons:

Style 3:

Standard Window no Caption:

Style 4:

Just Background window

You may move this <demo> gradient window by dragging it with a mouse click in any of the painted window area.


6.6.8 SecureSFX Installer Window Style - part 3

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.6 SecureDEPLOY Page ›› 6.6.3 Advanced SecureSFX Options ›› 6.6.3.2 Setting Up the Gradient Window ››

6.6.8 SecureSFX Installer Window Style - part 3

SecureSFX Installer Window Styles - part 3:

When Show production Gradient Window” checkbox is checked...

...you will be able to see how the window will eventually look when the SecureSFX installer is launched on your clients’ machine.


6.6.3.3 Target Machine information

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.6 SecureDEPLOY Page ›› 6.6.3 Advanced SecureSFX Options ››

6.6.5 Target Machine Information

Target Machine information:

ZONE 3 is reserved to "Target Machine Information"

This information on this help page relates to the location of either the source file path or the public key file path

In case the source file and the PublicKey file (if the update is signed) are not located in the same folder with the SecureSFX file (when deployed on the TARGET Machine), the description below applies!

You may be able to specify a different path for the source file that will be update and also, a different path for the PublicKEY file.

You may set this information depending on how the files and folder are situated.

If TARGET MACHINE setup looks like the following:

Once you deploy the SecureSFX (SecureCMDLine, SecurePATCH or SecureWizard self-extracting stub installer) into the ROOT folder called herein DEMO_TARGET_LOCATION it will look for the Source file and the

PublicKey file within the same folder location (DEMO_Target_Location), finding none.

Because of this <demo> layout, on the TARGET Machine, the source file is located withing the "Source" sub-folder:

and the PublicKey file is located within the "PublicKey" sub-folder:

Therefore, for this demo case, the following settings apply:

1. Setting the SOURCE_FOLDER to APP_FOLDER (or INSTALL_FOLDER) and sub-folder "Source"

2. Setting the PUBLIC_KEY_FOLDER to APP_FOLDER (or INSTALL_FOLDER) and sub-folder "PublicKey"


6.6.3.4 Other SecureSFX Installer Options

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.6 SecureDEPLOY Page ›› 6.6.3 Advanced SecureSFX Options ››

6.6.4 SecureSFX Installer Options

Other SecureSFX Installer Options:

ZONE 4 is reserved to "Other SecureSFX Installer Options"

On here you have an overview of the extra options used with your SecureSFX:

Here is the description of the settings:

    • Allow SecureSFX to create a backup source file:

Description: When checked, the SecureSFX Installer will not remove the source file. The source file will get renamed to _source_file_name.SecuredBackup

    • Allow SecureSFX to browse for file:

Description: When checked, the SecureSFX Installer will prompt for a FileDialog in order to locate the source file. Unless the source file is located in current path or designated %SOURCE_FOLDER% path

    • Allow SecureSFX to rollback file(s):

Description: When checked, SecureSFX switches the system back to its original state, before the update began, if the update processes fails.

    • Allow SecureSFX to create a log file:

Description: When checked, the SecureSFX Installer will create a text log file where all steps and events are recorded.

    • Allow SecureSFX to use multi-threading

Description: When checked, the SecureSFX Installer starts two threads in order to check fingerprinting of source and payload in the background, for faster processing


6.6.3.5 SecureSFX Gradient Window

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.6 SecureDEPLOY Page ›› 6.6.3 Advanced SecureSFX Options ››

6.6.4 SecureSFX Gradient Window

SecureSFX Gradient Window:

The information you have provided...

...in the SecureSFX Options dialog will be finally displayed on the SecureSFX ( SecurePATCH and SecureWIZARD only) gradient window:

See more details here


6.6.9 Building the SecureSFX Installer

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.6 SecureDEPLOY Page ››

6.6.11 Building the SecureSFX Installer

Building the SecureSFX Installer:

5 Steps are required to build a fully-optioned SecureSFX.

Only 1 step is required if you want to build a SecureSFX with default options!

Here are shortly, the steps with their own description below:

STEP 1: Add payload name (SecureUPDATE file)

STEP 2: Edit SecureSFX name and output location

STEP 3: Change SecureSFX type (SecureCMDLine, SecurePATCH, SecureWIZARD)

STEP 4: Change Customer information

STEP 5: Press Create... button

In more details:

STEP 1: In order to create the SecureSFX Installer, you need to do select a payload - a SecureUPDATE file (SecureDELTA or XtremeDELTA)

Once a SecureUPDATE file has been loaded, it will be decrypted and a brief information will be displayed. This information relates to "File that will be Updated" and the "Version to be Updated To".

The placeholder for SecureUPDATE will also inform you to "Edit, select from the combolist or press the br...."

STEP 2: The second part of the window will allow you to input or edit the name of the SecureSFX file, and its location:

STEP 3: You may also change the type of the SecureSFX file, SecurePATCH, SecureCMDLine or SecureWIZARD:

Please note: for the 32it version you may only chose 32bit version - decoder engines.

STEP 4: Change the user -options if needed. See here .

STEP 5: If SecurePATCH is selected, the MakeSFX button changes to "Create SecurePATCH Installer":

If the SecureUPDATE file is signed, the following message box appears:

You may press the Do not show this dlg anymore or simply abort the process by pressing Cancel.

Pressing Yes will start the SFX Building process, and its following callback messages will be displayed in the lower window on this page.

The more details link will jump automatically to the SecureREVIEW page

After SecureSFX is created with the specified path, there you will see the output file:


6.7 About Page

6. SecureDELTA for Windows GUI (Graphical User Interface) ››

6.7 SecureDELTA About Page

Contents:

6.7.1 Component Versions

6.7.2 Partnerships & Copyright

6.7.3 Licensing Information

6.7.4 Trial Registration


6.7.1 Selecting the About Page

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.7 About Page ››

6.7.1 SecureDELTA About Page

Selecting the About Page:

You may either select the SecureDEPLOY Page from the tab control


6.7.2 Component Versions

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.7 About Page ››

6.7.2. SecureDELTA Component Versions

SecureDELTA Internal Modules Versions:

When the About Page is activated...

...SecureDELTA APP queries the working dll files for their Internal Component Versions.

It will show the following information as follows:

Module | Version | Type | Usage
Encoding DLL | 2.56.109.1017 | Dynamic Load Library | SecureENCODING
Decoding DLL | 2.56.109.2856 | Dynamic Load Library | SecureDECODING
Encoding LIB | 2.56.109.2856 | Library (static) | SecureENCODING
Decoding LIB | 2.56.109.2856 | Library (static) | SecureDECODING / SecureSFX
Delta Engine | 2.56.109.2081 | Internal SecureENCODING / DECODING engine | SecureENCODE/SecureDECODE
Test App | 2.56.109.2190 | SecureDELTA APP v2.56 for Windows GUI* | GUI
SecurePATCH | 2.56.109.2190 | SecureDELTA Installer (Patcher) | SecureDECODING / SecureSFX
SecureCMDLine | 2.56.109.2190 | SecureDELTA Command Line Installer (Patcher/Updater) | SecureDECODING / SecureSFX
SecureWIZARD | 2.56.109.2190 | SecureDELTA Wizard GUI Installer (Updater) | SecureDECODING / SecureSFX

All the above components are 32 and 64bit versions.

(*) The SecureDELTA v2.56 for Windows GUI has been developed in collaboration with XtremeUI Division of NetLUP Xtreme Technologies. Please see more here .

First column shows the Encoding component versions.

Second column shows the Decoding component versions

This page also displays Copyright information (see more here) and Licensing information (see more here) .


6.7.3 Partnerships & Copyright

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.7 About Page ››

6.7.2. SecureDELTA Component Versions

SecureDELTA Internal Modules Versions:

6.6.3. agersoftware Partnerships & Copyright Info

agersoftware srl has partnered with NetLUP Xtreme Technologies srl in order to create a powerful application that applies new and advanced data differencing algorithms.

After careful consideration, agersoftware srl has chosen NetLUP Xtreme Technologies srl as our Strategic Technology Partner.

XtremeDELTA Engine and XtremeZIP components are a great addition to SecureUPDATE Suite of Products that will continue to bring value to our partners and clients due to both our companies continuous development and support

Due to our sustainable development and implementation of advanced algorithms into our Software Update Applications, our clients will be provided with intensively tested, quality software and industrial grade software tools!

The partnerships area shows our partner logos and websites: XtremeDELTA, XtremeZIP and XtremeUI. The logos redirect you safely to our partner website(s) where you can find more information about their services:

LOGO / Partner | Description | ACTION
 | XtremeZIP Division of NetLUP Xtreme Technologies srl | It opens partner web-page https://www.xtremezip.com
 | XtremeDELTA Division of NetLUP Xtreme Technologies srl | It opens partner web-page https://www.xtremedelta.com
 | XtremeUI Division of NetLUP Xtreme Technologies srl | It opens partner web-page https://www.xtremeui.com

The page also displays Copyright information and and shows specific module or component copyright information as described here


6.7.4 Licensing Information

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.7 About Page ››

6.7.4. SecureDELTA Licensing Details

SecureDELTA Internal Modules Versions:

SecureDELTA Licensing details.

Each Trial License is valid for 30 days. If you use the software beyond this time frame, you should register otherwise SecureDELTA will not work anymore.

Purchasing information could be found on this page .

You may also register your trial and earn 5% off regular license price by selecting the “Activate Special Offer...” link.

Trial Information is shown in the About page, see below:


6.7.5 Trial Registration

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.7 About Page ››

6.7.5 SecureDELTA Trial Registration

SecureDELTA Internal Modules Versions:

SecureDELTA Trial Registration Details

You may be entitled for a 5% savings coupon when you register your Trial. The coupon applies to your next purchase of any SecureUPDATE product license.

Enter your name, your email and your company name (optional) and press ‘Activate Your Trial’ button.

You will be receiving soon your 5% savings coupon by email. You may always contact us by sending us an email to support or sales with any questions you may have related to our products.

Thank you for using our SecureDELTA Application for Windows, part of SecureUPDATE Suite of Products!


6.8 Special Offers Page

6. SecureDELTA for Windows GUI (Graphical User Interface) ››

6.7 Special Offers Page

Contents:

agersoftware has given a great deal of attention to trademarks!

We fully recognizes existing trademarks and trademark owners while constantly filling application for our own trademarks.

We fully understand that a trademark "ownership" is not absolute.

Here is an excerpt from LEGAL ENCYCLOPEDIA. See original text here

"...you can use a trademark belonging to another person or company if you use the mark for:

      • informational or editorial purposes to identify specific products and services, or
      • if your use is part of an accurate comparative product statement."

agersoftware srl claims the full ownwership and the full rights of usage of the following trademarks:

    • SecureUPDATE
    • SecureDELTA
    • SecureENCODE
    • SecureDECODE
    • SecurePATCH
    • SecureWIZARD
    • SecureCMDLine
    • SecurePackage
    • SecureCMD
    • SecureSDK
    • SecurePKG

More details online on our page here .


6.8.1 Partnerships & Copyright

6. SecureDELTA for Windows GUI (Graphical User Interface) ›› 6.8 Special Offers Page ››

6.7.1 agersoftware Copyright Info

agersoftware srl has chosen NetLUP Xtreme Technologies srl as Strategic Technology Partner.

The About page also displays Copyright information and and shows specific module or component copyright information as described here


7. SecureSFX™

7. SecureSFX

Contents:

7.1 What is a SecurePATCH file

7.2 SecurePATCH internal structure

7.3 SecurePATCH decoding engine

7.4 SecurePATCH user options

7.5 SecurePATCH payload

7.5 SecurePATCH Warning and Error Messages


7.1 What is a SecureSFX Installer

7. SecureSFX™ ››

7.1 What is a SecureSFX™ Installer?

What is a SecureSFX Installer?

*

A SecureSFX™ Installer is a self-eXtracting file created by SecureDELTA™ App.

Its purpose is to perform the SecureUPDATE on the source file(s) located on the Remote Machines.

They bundle a SecureDECODE engine, user options and a SecureUPDATE file all together into a single windows executable file.

**

It is also named SecureDELTA™ Installer throughout this document.

Licensing Information: You can ship SecureSFX files free of charge and with no royalties to your customers, once you acquire a license from our store.

Please see here


7.2 SecureSFX Internal structure

7. SecureSFX™ ››

7.2 SecureSFX™ Internal Structure

SecureSFX Internal Structure

A SecureSFX™ (SecureDELTA™ Installer) is made of three distinctive parts:

    • The SecureDecoding engine
    • The Installer (user) options
    • The payload


7.3 SecureSFX Decoding Engine

7. SecureSFX™ ››

7.3 SecureSFX™ Decoding Engine

SecureSFX Decoding Engine

SecureSFXTM Decoding Engine is a separate engine built and optimized for fast processing (patching) and the smallest possible footprint (system impact in memory and size).

The size of the SecureDELTA decoding engine is less than 124 KBytes when built for production mode (release built), including the GUI elements (UI, dialog boxes, etc).

SecureSFX Decoding Engine information:

SecureSFX | Build version | Actual footprint (KiB)
SecureCMDLine | 32bit | 117
SecurePATCH | 32bit | 138
SecureWIZARD | 32bit | 230

The current version of the SecureDELTA decoding engine can be checked on the About tab, under LIB Version:


7.4 SecureSFX User Options

7. SecureSFX™ ››

7.4 The SecureSFX Installer

The SecureSFX Installer:

SecureSFX™ User Options

The SecurePATCH file allows you to set certain user-related options or behavior parameters. They will influence mostly the way the SecureDELTA Installer works (either in background or in foreground displaying a window) but also what information it displays.

When you create a SecurePATCH file you want an easy way to edit your company and product information such as:

      • Product Name and version
      • Product Website
      • Your Copyright
      • Your Company Name and Website

All this information will get securely and encrypted stored in the Installation data section of the SecurePATCH file. This is the second section as depicted below:


7.5 SecureSFX Payload

7. SecureSFX™ ››

7.5 SecureSFX Payload

The SecureSFX Installer:

SecurePATCH™ Payload

The third section of the SecurePATCH file contains the payload. This payload is formed of a single file (archive) which is the SecureDELTA file.

The SecureDELTA file is the only parameters required when a SecurePATCH is created. All other parameters are filled in with default data.


7.5.1 Warning and Error Messages

7. SecureSFX™ ››

7.5.1 SecurePATCH Warning and Error Messages

SecureSFX Warning and Error Messages:

SecurePATCH Warning and Error MESSAGES

Here is a brief explanation of the most common SecurePATCH Warning and Error Messages:

ERROR MESSAGE # | ERROR MESSAGE | MESSAGE TYPE | DESCRIPTION
100 | Sourcefile not present. SecureUpdate cannot continue! | FATAL ERROR | If the source file is not present, the following error message appears. See MessageBox. This is a fatal error. SecurePATCH will not continue at this point since there is no source file to update.
101 | File has already been updated! | INFORMATION | Most likely the SecurePATCH has already updated the file since its fingerprinting result match the one fo target file. SecurePATCH will not continue at this point.


7.6 SecurePATCH SFX

7. SecureSFX™ ››

7.6 The SecurePATCH Installer

The SecurePATCH Installer:

*

A SecurePATCH Installer is another type of a SecureSFX (the self-eXtracting installer created by SecureDELTA™ APP)

Its purpose is to perform the SecureUPDATE on the source file(s) located on the Remote Machines.

They bundle a SecureDECODE engine, user options and a SecureUPDATE file all together into a single windows executable file.

**

A SecurePATCH Installer is built as a standalone dialog-based Windows application running on 32 / 64 bit Windows OS versions.

You can ship the SecurePATCH files created by SecureDELTA free of charge and with no royalties to your customers, once you acquire a license from our store.

Please see here .


7.6.1 SecurePATCH - part 1

7. SecureSFX™ ›› 7.6 SecurePATCH SFX ››

7.6.1 SecurePATCH - part 1

SecurePATCH file - part 1:

The SecureSFX Installer must be run in the same folder where the source file is located.

If you have selected the source file from a different location, on the Target Machine is must match its %SOURCE_PATH% location as well.

See more on setting the source folder in a different sub-folder or directory here .

Once it is executed, a background check is started to verify the validity of the installer, the payload, and the source file.

The presence of the source file and also the content is checked and verified with priority.

A trial dialog box is displayed when running in Trial Mode. This window does not show in Paid mode (licensed)!


7.6.2 SecurePATCH - part 2

7. SecureSFX™ ›› 7.6 SecurePATCH SFX ››

6.6.13 Executing SecurePATCH - part 2

Executing the SecurePATCH file - part 2:

When launched...

...all main events of the installer get recorded into a log file called SecureDELTA_Patch_Installer.log

The log file will be create in the same folder location with the source file and its content will be updated.

The file is always updated, never deleted by the Installer. Therefore, it will contain all the logged information from all the performed SW updates in that folder.

The log file logs important KEY actions and ERRORS like:

      • Pre-checks of the SecureSFX Self-Extracting Installer integrity
      • Fingerprint check of the payload (the SecureUPDATE file it contains)
      • Other validity check of the SecureEXE Self-Extracting Installer
      • Disk free space
      • Adler check on source file


7.6.3 SecurePATCH - part 3

7. SecureSFX™ ›› 7.6 SecurePATCH SFX ››

6.6.13 Executing SecurePATCH - part 3

Executing the SecurePATCH file - part 3:

When launched on your client's machine...

...the SecurePATCH Installer will execute three three steps.

Step 1: The SecurePATCH Self-eXtracting Installer displays a Trial window

This Trial window shows only in the Trial Mode. It will not be present in the Paid version.

The window displays:

      • the time and date of the Installer creation
      • agersoftware estore link
      • copyright information

Press the Continue button to advance to the next step where the installer payload and the source file will be pre-verified, verified, checked and processed.

Step 2: Acknowledge and press 'Continue' for the next step.

Pressing Continue will display the following dialog:

Here is a short explanation of the SecurePATCH window:

Step 3:

At this moment, SecurePATCH starts the following automatically background checks on separate threads:

- pre-checking of the SecurePATCH file (this verifies the overall structure)

- integrity check of the SecurePATCH file

These threads are started only if the Allow threading checkbox was previously checked with the SecureSFX file was created. See here .

When all the prerequisites are in order and have been verified, the update process will send a message to the user and highlight the Proceed button.

Once the button 'Start SecurePATCH' process is pressed, the Installer will update the source file from v1.100 to v1.200:

SecurePATCH will display a Message Box stating the process has been completed, once the SecureUPDATE process ends:


7.7 SecureCMDLine SFX

7. SecureSFX™ ››

7.7 The SecureCMDLine Installer

The SecureCDMLine Installer:

A SecureCMDLine Installer is another type of a SecureSFX (the self-eXtracting installer created by SecureDELTA™ APP)

The SecureCMDLine Installer is built as a standalone command line Windows application running on 32 / 64 bit Windows OS versions.

You can ship the SecureCMDLine files created by SecureDELTA App free of charge and with no royalties to your customers, once you acquire a license from our store.

Please see here .


7.7.1 SecureCMDLine parameter -i

7. SecureSFX™ ›› 7.7 SecureCMDLine SFX ››

7.7.1 SecureCMDLine Installer Parameter -i

The SecureCDMLine Installer:

When the SecureCMDLine Installer is executed with the following parameter:

-i param (from information)

...the Self-eXtracting installer will perform an internal scan of its payload and display additional information about the data, its variables and user options.

Here are the options used to create this SecureCMDLine:

Selecting a different Source_FOLDER location for the source folder, for instance, Source:

Please see more detail on folder structure here .

The SecureCMDLine installer will output (when run with -i parameter) and now SOURCE will appear as a sub-folder in the value for the %SOURCE_FOLDER% variable.

Also see more on variables here:

The folder structure on the Target Machine now MUST look like:

...because SecureCMDLine Installer will look for the source file name (_file_to_be_updated_v1.0) in folder %SOURCE_FOLDER% with the value equal to the sub-folder Source of the %APP_FOLDER% (the root location of your application) and


7.7.2 SecureCMDLine parameter -v

7. SecureSFX™ ›› 7.7 SecureCMDLine SFX ››

7.7.2 SecureCMDLine Installer Parameter -v

The SecureCDMLine Installer:

When the SecureCMDLine Installer is executed with the following parameter:

-v param (from verbose)

When using the -v parameter, the Self-eXtracting Installer is instructed to perform the SecureUPDATE action while displaying more information

The Self-eXtracting installer will also print out more information in case of errors.

Here is the regular output of the SecureCMDLine Installer in case the source file is missing:

When using the -v parameter, SecureCMDLine will display more information on this error:


7.7.3 Executing SecureCMDLine Installer

7. SecureSFX™ ›› 7.7 SecureCMDLine SFX ››

7.7.3 Executing SecureCMDLine Installer

Executing the SecureCDMLine Installer:

When the SecureCMDLine Installer is executed without any parameter...

...it will locate the source file that needs update.

Considering the following directory structure, from the Target Machine, where SecureCMDLine will be executed

The program output:

will report the error of not locating the source file in the expected location

Adding the source file at the expected location ( %SOURCE_FOLDER% = APPLICATION_FOLDER \ Source ):

SecureUPDATE operation finalizes successfully!

We can double check the SecureUPDATE operation:

and see that the content of the source file, _file_to_be_updated_v1.0 has been updated into _file_to_be_updated_v1.1 's content!

Let's execute the SecureCMDLine again with the -v parameter: See next slide ;


7.7.3.1 Executing with -v param

7. SecureSFX™ ›› 7.7 SecureCMDLine SFX ›› 7.7.3 Executing SecureCMDLine Installer ››

7.7.3.1 Executing SecureCMDLine Installer

Executing the SecureCDMLine Installer:

When the SecureCMDLine Installer is executed without any parameter...

...it will locate the source file that needs update.

Considering the following directory structure where SecureCMDLine is executed (the Source sub-folder is present with the source file within)

We execute the SecureCMDLine Installer now with the -v parameter:

We see the SecureCMDLine Installer displaying more information such as:

      • the temporary file created which is the target file replica
      • the deletion of the original file (the backup flag was not set)
      • renaming of the temporary file into the new source file with the target file identical content


7.8 SecureWIZARD SFX

7. SecureSFX™ ››

7.8 The SecureWIZARD Installer

The SecureWIZARD Installer:

A SecureWIZARD Installer is another type of a SecureSFX (the self-eXtracting installer created by SecureDELTA™ APP)

The SecureWIZARD Installer file is built as a wizard-like standalone `Windows application running on 32 / 64 bit Windows OS versions.

You can ship the SecureCMDLine files created by SecureDELTA App free of charge and with no royalties to your customers, once you acquire a license from our store.

Please see here .


7.8.1 SecureWIZARD Steps

7. SecureSFX™ ›› 7.8 SecureWIZARD SFX ››

7.8.1 SecureWIZARD Steps

The SecureWIZARD Installer:

When the SecureWIZARD Installer is executed it will guide the user with simple steps throughout the SecureUPDATE process.

Here are SecureWIZARD steps and pages:

- Welcome page

- Source file Location page

- Initial Files Validation page

- Public Key File Location page

- SecureUPDATE Process page

- Completion page


7.8.1.1 SecureWIZARD Welcome Page

7. SecureSFX™ ›› 7.8 SecureWIZARD SFX ›› 7.8.1 SecureWIZARD Steps ››

7.8.1.1 SecureWIZARD Welcome Page

The SecureWIZARD Installer Welcome Page

When launched, SecureWIZARD displays a Welcome Page

On here, SecureWIZARD lists the steps required for the SecureUPDATE process:

When checking the "Skip this welcome page..." no other versions of SecureWIZARD will show this page / dialog box.

The steps are:

    • Validation of the SecureWIZARD SFX
    • Validation of the source file authenticity
      • checking the fingerprinting and verifying this is the exact file for which the SecureDELTA binary diff file has been created
    • Validation of the SecureDELTA Payload
    • Validation of the Digital Signature
      • this step is performed only if the payload (the SecureUPDATE file used)


7.8.1.2 SecureWIZARD Source File Location

7. SecureSFX™ ›› 7.8 SecureWIZARD SFX ›› 7.8.1 SecureWIZARD Steps ››

7.8.1.2 SecureWIZARD Source File Location Page

The SecureWIZARD Installer Welcome Page

In this second step SecureWIZARD...

...displays information related to the source file location.

Once the source file is found...

...the Next button highlights the possibility to advance to another page

Please note the folder structure used in this test simulates the Target Machine file locations:

As instructed when the SecureSFX (this particular SecureWIZARD) has been created, it needs to search for the source file within the Source sub-folder. See here for more details.


7.8.1.3 SecureWIZARD Validations

7. SecureSFX™ ›› 7.8 SecureWIZARD SFX ›› 7.8.1 SecureWIZARD Steps ››

7.8.1.3 SecureWIZARD Validations

The SecureWIZARD Validations Page

In this third step SecureWIZARD...

...displays information related to the source file location.

Once the source file is found in the current location or at the expected %SOURCE_PATH% location, the Next button highlights the possibility to advance to another page

Please note the folder structure used in this test simulates the Target Machine file locations:

As instructed when the SecureSFX (this particular SecureWIZARD) has been created, it needs to search for the source file within the Source sub-folder. See here for more details.

If the SecureSFX has been created with the "Allow browse for file...", please see options here , you may press the browse button "..." and it will open a FileDialog window which will allow you to browse for the source file, in case the SecureSFX is unable to locate it using %SOURCE_FOLDER% variable path value.


7.8.1.4 SecureWIZARD PublicKey File Location

7. SecureSFX™ ›› 7.8 SecureWIZARD SFX ›› 7.8.1 SecureWIZARD Steps ››

7.8.1.4 SecureWIZARD PublicKey File Location

The SecureWIZARD PublicKey File Location Page

In this third step, SecureWIZARD...

...displays information related to the public key file location.

Once the public key file is found...

...in the current location or at the expected %PUBLICKEY_FOLDER% location, the Next button highlights the possibility to advance to another page

Please note the folder structure used in this test simulates the Target Machine file locations:

As instructed when the SecureWIZARD has been created, it needs to search for the source file within the PublicKey sub-folder. See here for more details.


7.8.1.5 SecureWIZARD File Already Updated

7. SecureSFX™ ›› 7.8 SecureWIZARD SFX ›› 7.8.1 SecureWIZARD Steps ››

7.8.1.5 SecureWIZARD File Already Updated

The SecureWIZARD File Already Updated:

When the SecureWIZARD Installer is executed...

...it verifies if the file is already updated.

On this page, SecureWIZARD checks the fingerprint information of the source file. If this matches the target file fingerprint, then the content of the source file has already been updated.

This verification is done in the Validation step/page .

After checking the CRC fingerprinting of the Source file, it is compared with the CRC fingerprint information from the Target file.

If thew two values match, the file has already been updated!

You can also see all the details in the SecureWIZARD log it creates while performing the SecureUPDATE:


7.8.1.6 SecureWIZARD Updating Page

7. SecureSFX™ ›› 7.8 SecureWIZARD SFX ›› 7.8.1 SecureWIZARD Steps ››

7.8.1.6 SecureWIZARD Updating Page

The SecureWIZARD Updating Page

After all verification completed, SecureWIZARD is ready to perform the SecureUPDATE action.

In order to apply update during the SecureUPDATE, SecureWIZARD performs final steps such as:

- a temporary file is created (patter is SecureDELTA_<number>.secureBackup)

- the source file is renamed to "source_file.SecureDELTA.Backup" (if the "Allow Backup ..." flag is set to TRUE)

- a new target file is create starting from the source file and the binary diff delta (SecureUPDATE file)

- the fingerprint of the newly created target file is matched against the information store in the SecureUPDATE file header

- if they match the newly created target file matches on the remote machine matches the target file (from the Local Machine) used to create the update.

- in this case, the source file is removed.

- the temporary file is renamed to the source filename.


7.8.1.7 SecureWIZARD Completion Page

7. SecureSFX™ ›› 7.8 SecureWIZARD SFX ›› 7.8.1 SecureWIZARD Steps ››

7.8.1.7 SecureWIZARD Completion Page

The SecureWIZARD Completion Page

Last SecureWIZARD page displays a short description of the updated source file.

This page lists the files that have been applied the SecureUPDATE.


8 Other GUI Elements

6.8 SecureDELTA Encode PAGE

Contents:

8.8.1 Managing Items in Edit Combo Boxes

8.8.2 Session Variables window dialog

8.8.3 Tooltips


8.1 Managing Items in Edit Combo Boxes

8 Other GUI Elements ››

8.1 Managing Items in Edit ComboBoxes

How to manage items in Edit Combo boxes

Managing items in any edit combo boxes, source, target or delta filename is as easy as selecting the last entry in the combobox marked as [Manage Items]

When you select [Manage Items], a new dialog box opens, with a main list control having the above items as list elements already populated in:

Using this dialog, you can rearrange the order of files (items) that appear in the associated combobox. You can also add new items, remove items and review information associated with the selected item.

The upper right icon-buttons have the following meaning:

NEW - Allows you to insert a new item in the list

DELETE - Deletes an item from the list

UP Arrow - Moves selected item up in the list

DOWN Arrow - Moves selected item down in the list

If you check the Include non existing files checkbox:

files that no longer exist will be kept in the list when pressing Save.

No action is done unless the Save button is pressed.


8.2 Session variables window dialog

8 Other GUI Elements ››

8.2 Session variables window dialog

Session variables

Session variables information...

...are located within the SecureDECODE Page.

When clicked, the link opens the Session Variables dialog displaying information about SecureDELTA Project Variables, SecureSFX variables, session and system variables:


8.2.1 SecureDELTA Project Variables

8 Other GUI Elements ›› 8.2 Session variables window dialog ››

8.2.1 SecureDELTA Project Variables

SecureDELTA Project Variables

SecureDELTA Project Variables are storage elements...

...whose values may change from a SecureDELTA Project to another. Hence the 'variable' name.

Some Variables have values that do not change from LOCAL to TARGET Machines, such as SecureSFX Variables. See here

%APP_FOLDER% variable represents the installation folder location of the main application. The main application on the Local Machine is SecureDELTA and on the Target Machine is the application that receives the SecureUPDATE file.

All the other variables remain unchanged between Local and Target Machine(s).

Here are SecureDELTA Project Variables

VARIABLE NAME | VARIABLE TITLE | DESCRIPTION | LOCAL MACHINE VALUE | TARGET MACHINE VALUE
%APP_FOLDER% | APPLICATION FOLDER | Main application installation folder | The folder where SecureDELTA App is installed. Ex: D:\Program files (x86)\agersoftware\SecureDELTA App\ | The folder where the main application that receives the SecureUPDATE is installed. Ex: D:\Program Files\PDF_Editor\
%SOURCE_FOLDER% | SOURCE FILE FOLDER | Folder where the source file is located | Folder where the source file is located | -
%PUBLIC_KEY_FOLDER% | PUBLIC KEY FOLDER | Folder where the Public Key file is located | Folder where the Public Key file is located | -
%INSTALLED_VER% | SOURCE FILE VERSION | The string or embedded versioning data of the source file | The string or embedded versioning data of the source file | -
%TARGETED_VER% | TARGET FILE VERSION | The string or embedded versioning data of the source file | The string or embedded versioning data of the source file | -


8.2.2 SecureSFX Variables

8 Other GUI Elements ›› 8.2 Session variables window dialog ››

8.2.2 SecureSFX Variables

SecureSFX Variables

SecureSFX Variables have same values...

...from LOCAL to TARGET Machines. They are user-input data and relate to product name, company information. You can see these values by selected the "More on session variables..." link from SecureDECODE page.

All SecureSFX variables remain unchanged between Local and Target Machine(s):

SecureSFX variables:

    • %PRODUCT_NAME% - It defines the name of the product that delivers the update. It can be edited here.
    • %COMPANY_URL% - It defines the name of the company or the product url. It can be edited here.
    • %COMPANY_NAME% - It defines the name of the company name that owns the product that delivers the update. It can be edited here.
    • %COPYRIGHT% - It defines the copyright associated with the product that delivers the update. It can be edited here.
    • %WINDOW_TITLE% - It defines the SecureSFX application window title.

Here are SecureSFX Project Variables

VARIABLE NAME | VARIABLE TITLE | DESCRIPTION | LOCAL MACHINE VALUE | TARGET MACHINE VALUE
%PRODUCT_NAME% | Product Name | Name of the application that receives the SecureUPDATE - user input | Name of the application that receives the SecureUPDATE - user input | -same-
%COMPANY_NAME% | Company Name | Name of the company that receives the SecureUPDATE - user input | Name of the company - user input | -same-
%COMPANY_URL% | Company URL | Company URL - user input | Company URL - user input | -same-
%COPYRIGHT% | Copyright | Copyright - user input | Copyright - user input | -same-
%WINDOW_TITLE% | SecureSFX Window Title | Window title for the SecureSFX application - user input | Window title for the SecureSFX application | -same-


8.2.3 System Variables

8 Other GUI Elements ›› 8.2 Session variables window dialog ››

8.2.3 System Variables

System Variables

System Variables...

...have different values from LOCAL to TARGET Machines

This is simply due to the fact that their values are OS dependent, such as:

- the Operating System Installation folder

- the Operating System Temporary folder

- the Computer Name

- etc


8.8.3 SecureDELTA Tooltips

8 Other GUI Elements ››

8.8.3 Tooltips

SecureDELTA Tooltips

SecureDELTA Tooltips are designed to give you a hint...

...some short informational text or at least a suggestion on what that control or window does and what to expect or to do regarding it.

For example, during the SecureENCODE action, a mouse hover over the Abort button will inform you that You may abort... this undergoing operation by pressing the Abort button.

Also, at any time, a mouse hovering a certain control or area could show you more information about the associated windows control:

For example, hovering over the Callback area:

Please note the control or window has to be able to receive the mouse notifications, so it should not be in the disabled state.


9. Information on UNICODE support

UNICODE support

The Unicode Standard is a standardized character code designed and used to better represent international texts for better display and storage. It uses a unique 16- or 32–bit value to represent each individual character, regardless of platform, language, or program. Using Unicode, anyone could develop a software product that will work with various platforms, languages, and most importantly will support different countries or regions. Unicode also allows data to be visible, displayed, stored and transported through many different systems.

There are two different forms of Unicode support available. This section describes the two forms of Unicode support as well as some of the features of and considerations for using that support. To obtain additional information about Unicode, visit the Unicode Home Page at www.unicode.org .

The first type of Unicode support is UCS-2 support. Most compilers use wide characters (that is, characters of the wchar_t type) and wide character strings (that is, strings of the wchar_t * type) that represent 2-byte Unicode symbols (characters). Narrow (non-wide) characters and narrow character strings represent EBCDIC characters, just as they do when the UCS-2 support is not enabled. The Unicode characters represent code points in CCSID 13488.

The second type of Unicode support is UTF-8 or UTF-32 support (also known as UTF support). When UNICODE UTF-32 options is specified, most compilers use wide characters and wide character strings that represent 4-byte Unicode characters. Each 4-byte symbol (character) represents a single UTF-32 character. Narrow characters and narrow character strings represent UTF-8 characters.

In a nutshell: Each UTF character is from 1 to 4 bytes in size. Most normal characters are a single byte in size, and, in fact, all 7-bit ASCII characters map directly to UTF-8 and are 1 byte in size. The UTF-8 characters represent code points in CCSID 1208.

All SecureUPDATE programs, applications and software is specifically designed to use, support, display and work with UNICODE symbols (characters) and strings.

*

Thank you for using our SecureDELTA™ Application for Windows, part of SecureUPDATE™ Suite of Products!

This has been a SecureDELTA™ Presentation. © agersoftware srl. All rights Reserved

*


10. Software Update Good Practice

10 Software Update Good Practice

SecureDELTA Tooltips

Software Update Good Practice:

Some simple rules to guide you along a successfully more secure, safer software update, with better results than before:

    1. Do not attempt to update software files that change (like setting files) on target machine, before you apply the SecurePATCH file. See here.

    2. Add versioning to your files. It will give you a better control over what version is already located on the TARGET PCs . See here .

    3. Always pay attention to already compressed files. The reason is that a small change in an uncompressed file could lead to major changes in the compressed form. Thus, creating a binary diff file from already compressed files should be avoided and it is not recommended.

    4. The same relates to encrypted files or encrypted data files. Try to avoid performing binary differencing on encrypted data. SecureDELTA already offers a method to securely encrypt the binary diff data it creates.


11. about agersoftware

11. About agersoftware s.r.l

Contents:

8.1 About agersoftware

8.2 agersoftware Trademarks

8.3 agersoftware eStore

8.4 agersoftware Contact information


11.1 About agersoftware

11. about agersoftware ››

11.1 About agersoftware s.r.l.

About agersoftware

Who are we:

A young team of professionals with combined experience of more than four decades in Information-Theory, Data Compression, Theory of Data Coding and Storage.

What we do:

Innovative, Secure, Industrial Grade Software Update solutions. Simply put, SecureUPDATE™

Our Target:

Build a comprehensive suite of tools specifically designed for particular platforms, while delivering tailored solutions for our clients value.

Our Focus:

Provide tailored solutions backed by well-researched processes. Build trust through personal attention to our clients needs when it comes to Secure Software Updates.

Our Vision:

"Building value and trust through security and innovation."


11.2 agersoftware Trademarks

11. about agersoftware ››

11.2 TradeMarks

Contents:

All trademarks used in this help document(manual) are being used only for the express purposes of features and price comparisons.

SecureDELTA mark is a trademark of agersoftware srl. All rights reserved.

**

All other trademarks and trade names may be used in this document to refer to either the entities claiming the marks and/or names or their products and are the property of their respective owners.

We disclaim proprietary interest in the trade-marks and names of others.

Agersoftware srl claims full ownership and the right of use of the following
TRADEMARKS:

SecureUPDATE, SecureDELTA, SecurePATCH, SecureCMDLine, SecureWIZARD,SecurePACKAGE, SecurePKG, SecureSDK,
SecureENCODE & SecureDECODE

SecureDELTA APP GUI (Graphical User Interface) has been designed in collaboration with XtremeUI division of NetLUP Xtreme Technologies srl.

Portions Copyright NetLUP Xtreme Technologies srl. Website: https://www.xtremeui.com

Agersoftware Website designed and powered by .Xtreme.UI. Web & GUI Design.

More information on agersoftware website page here .


11.3 agersoftware eStore

11. about agersoftware ››

11.3 agersoftware eStore information

Contents:

agersoftware estore:

You can visit our online store (agersoftware estore) 24/7:

https://estore.agersoftware.com

eStore contact info:

Our online store is open 24/7 at:

https://estore.agersoftware.com

Contact page for our store:

https://estore.agersoftware.com/contact-us/

By email:

sales@agersoftware.com

For more contact options see here

*

Thank you for using our SecureDELTA™ Application for Windows, part of SecureUPDATE™ Suite of Products!

This has been a SecureDELTA™ Presentation. © agersoftware srl. All rights Reserved

*


11.4 agersoftware Contact Information

11. about agersoftware ››

11.4 agersoftware contact information

Contents:

SecureDELTA™ APP v2.56

Advance Software Update Solutions!

We are here to help. We value your input and feedback.

We appreciate your business. Thank you!

agersoftware contact information:

We have the most friendly staff online 08AM to 08PM to answer all your questions.

You can always find them online at https://www.agersoftware.com

Email:

About support inquiry:

support@agersoftware.com

About generic inquiry:

contact@agersoftware.com ,

info@agersoftware.com

About sales inquiry:

sales@agersoftware.com

Email us about security issue(s) or concerns:

security@agersoftware.com

About website(s):

webmaster@agersoftware.com

Online Chat:

Available Online on any of our web pages on:

https://www.agersoftware.com

Email about online chat support:

onlinesupport@agersoftware.com

eStore:

Our online store is open 24/7 at:

https://estore.agersoftware.com

Contact page for our store:

https://estore.agersoftware.com/contact-us/

By email:

sales@agersoftware.com

*

Thank you for using our SecureDELTA™ Application for Windows, part of SecureUPDATE™ Suite of Products!

This has been a SecureDELTA™ Presentation. © agersoftware srl. All rights Reserved

*


12. Legal Information

12 Legal information

Contents:

12.1 Terms and conditions

12.2 Privacy Policy

12.3 Cookies Policy

12.4 GDPR Policy


12.1 Terms and conditions

12. Legal Information ››

12.1 Terms and Conditions

Contents:

Introduction

THIS IS A LEGAL AGREEMENT. BY ACCESSING THIS WEB SITE OR USING ANY SERVICE PROVIDED HEREIN, YOU ACCEPT AND AGREE TO BE BOUND BY ALL THE TERMS AND CONDITIONS OF THIS AGREEMENT.

PLEASE READ THIS ENTIRE AGREEMENT CAREFULLY BEFORE ACCEPTING ITS TERMS.

Parties

The parties to this Agreement are you, a visitor to this web site (“You”), and the owner and operator of this web site: AGER SOFTWARE SRL, a Romanian Limited Liability company (“AgerSoftware”). All references to “us”, “this web site” or “this site” shall be construed to mean AgerSoftware. If the user is not an individual, then “You” means Your company, its officers, members, agents, successors and assigns.

These Website Standard Terms and Conditions written on this webpage shall manage your use of our website, agersoftware website accessible on this page, here . These Terms will be applied fully and affect to your use of this Website. By using this Website, you agreed to accept all terms and conditions written in here. You must not use this Website if you disagree with any of these Website Standard Terms and Conditions.

Copyrights

The copyright in all material provided on this site is owned by AgerSoftware or by AgerSoftware’s licensor(s). You acknowledge and agree that this site contains proprietary information that is protected by applicable intellectual property and other laws. You further acknowledge and agree that information presented to You through this site, including text, graphics, logos, icons, images and software, and the arrangement and compilation of such content, are the property of AgerSoftware or its content suppliers and is protected by copyrights, trademarks, service marks, patents or other proprietary rights and laws.

AgerSoftware does not grant any license or authorization to any user of its copyrightable material or other intellectual property, by placing them on this site. Furthermore, except as stated herein, none of the material may be copied, reproduced, distributed, republished, downloaded, displayed, posted or transmitted in any form or by any means, including, but not limited to, electronic, mechanical, photocopying, recording, or otherwise, without the prior written permission of AgerSoftware or the copyright owner.

However, You may print a copy of the information on this site for Your personal, non-commercial internal use or records. In so doing, You may not modify the materials and You agree to retain all copyright and other proprietary notices contained in the materials. This permission does not give You any ownership rights in the information and terminates automatically if You breach any of these terms or conditions.

If You make any other use of this site, except as otherwise provided herein, You may violate copyright and other laws of Romania as well as applicable state laws and may be subject to penalties.

Cookies

We employ the use of cookies. By accessing agersoftware website, you agreed to use cookies in agreement with the agersoftware srl's Privacy Policy. Most interactive websites use cookies to let us retrieve the user’s details for each visit. Cookies are used by our website to enable the functionality of certain areas to make it easier for people visiting our website. Some of our affiliate/advertising partners may also use cookies.

Registration Data And Privacy

Registration may be required for you to download from this site, or for your participation in certain services offered at this site. You may need to provide certain current, complete, and accurate information about You as prompted to do so by the registration form (“Registration Data”), and maintain and update such registration information as required to keep such information current, complete and accurate.

You warrant that your Registration Data is accurate and current, and that You are authorized to provide such Registration Data. You authorize us to verify your Registration Data at any time. If any Registration Data that You provide is untrue, inaccurate, not current or incomplete, AgerSoftware retains the right, in its sole discretion, to suspend or terminate rights to use the services.

Registration Data and certain other information about You is subject to our Privacy Policy which may be accessed from the agersoftware.com estore page here . Solely to enable AgerSoftware to use such information You supply us internally and in good faith, so that we are not violating any rights You might have in that information, You grant to AgerSoftware a nonexclusive license to

    • (i) convert such information into digital format such that it can be read, utilized and displayed by AgerSoftware’s computers or any other technology currently in existence or hereafter developed capable of utilizing digital information, and
    • (ii) combine the information with other content provided by AgerSoftware, in each case by any method or means or in any medium whether now known or hereafter devised.

Registration By Children Under The Age of 18 Is Not Permitted.

REGISTRATION IS NOT AVAILABLE TO CHILDREN UNDER THE AGE OF 18.

IF A USER UNDER THE AGE OF 18 ATTEMPTS TO REGISTER WITH agersoftware.com, WE SHALL NOTIFY THE USER THAT HE OR SHE IS NOT ELIGIBLE, AND WE SHALL NOT COLLECT OR USE ANY PERSONAL INFORMATION FROM SUCH CHILD.

License

Unless otherwise stated, agersoftware srl and/or its licensors own the intellectual property rights for all material on agersoftware website. All intellectual property rights are reserved. You may access this from agersoftware website for your own personal use subjected to restrictions set in these terms and conditions.

You must not:

    • Republish material from agersoftware website
    • Sell, rent or sub-license material from agersoftware website
    • Reproduce, duplicate or copy material from agersoftware website
    • Redistribute content from agersoftware website

This Agreement shall begin on the date hereof.

Parts of this website offer an opportunity for users to post and exchange opinions and information in certain areas of the website. agersoftware srl does not filter, edit, publish or review Comments prior to their presence on the website. Comments do not reflect the views and opinions of agersoftware srl,its agents and/or affiliates. Comments reflect the views and opinions of the person who post their views and opinions. To the extent permitted by applicable laws, agersoftware srl shall not be liable for the Comments or for any liability, damages or expenses caused and/or suffered as a result of any use of and/or posting of and/or appearance of the Comments on this website.

agersoftware srl reserves the right to monitor all Comments and to remove any Comments which can be considered inappropriate, offensive or causes breach of these Terms and Conditions.

You warrant and represent that:

    • You are entitled to post the Comments on our website and have all necessary licenses and consents to do so;
    • The Comments do not invade any intellectual property right, including without limitation copyright, patent or trademark of any third party;
    • The Comments do not contain any defamatory, libelous, offensive, indecent or otherwise unlawful material which is an invasion of privacy
    • The Comments will not be used to solicit or promote business or custom or present commercial activities or unlawful activity.

You hereby grant agersoftware srl a non-exclusive license to use, reproduce, edit and authorize others to use, reproduce and edit any of your Comments in any and all forms, formats or media.

Hyperlinking to our Content

The following organizations may link to our Website without prior written approval:

    • Government agencies;
    • Search engines;
    • News organizations;
    • Online directory distributors may link to our Website in the same manner as they hyperlink to the Websites of other listed businesses; and
    • System wide Accredited Businesses except soliciting non-profit organizations, charity shopping malls, and charity fundraising groups which may not hyperlink to our Web site.

These organizations may link to our home page, to publications or to other Website information so long as the link: (a) is not in any way deceptive; (b) does not falsely imply sponsorship, endorsement or approval of the linking party and its products and/or services; and (c) fits within the context of the linking party’s site.

We may consider and approve other link requests from the following types of organizations:

    • commonly-known consumer and/or business information sources;
    • dot.com community sites;
    • associations or other groups representing charities;
    • online directory distributors;
    • internet portals;
    • accounting, law and consulting firms; and
    • educational institutions and trade associations.

We will approve link requests from these organizations if we decide that: (a) the link would not make us look unfavorably to ourselves or to our accredited businesses; (b) the organization does not have any negative records with us; (c) the benefit to us from the visibility of the hyperlink compensates the absence of agersoftware srl; and (d) the link is in the context of general resource information.

These organizations may link to our home page so long as the link: (a) is not in any way deceptive; (b) does not falsely imply sponsorship, endorsement or approval of the linking party and its products or services; and (c) fits within the context of the linking party’s site.

If you are one of the organizations listed in paragraph 2 above and are interested in linking to our website, you must inform us by sending an e-mail to agersoftware srl. Please include your name, your organization name, contact information as well as the URL of your site, a list of any URLs from which you intend to link to our Website, and a list of the URLs on our site to which you would like to link. Wait 2-3 weeks for a response.

Approved organizations may hyperlink to our Website as follows:

    • By use of our corporate name; or
    • By use of the uniform resource locator being linked to; or
    • By use of any other description of our Website being linked to that makes sense within the context and format of content on the linking party’s site.

No use of agersoftware srl's logo or other artwork will be allowed for linking absent a trademark license agreement.

iFrames

Without prior approval and written permission, you may not create frames around our Webpages that alter in any way the visual presentation or appearance of our Website.

Content Liability

We shall not be hold responsible for any content that appears on your Website. You agree to protect and defend us against all claims that is rising on your Website. No link(s) should appear on any Website that may be interpreted as libelous, obscene or criminal, or which infringes, otherwise violates, or advocates the infringement or other violation of, any third party rights.

Your Privacy

Please read Privacy Policy located within this document

Reservation of Rights

We reserve the right to request that you remove all links or any particular link to our Website. You approve to immediately remove all links to our Website upon request. We also reserve the right to amen these terms and conditions and it’s linking policy at any time. By continuously linking to our Website, you agree to be bound to and follow these linking terms and conditions.

Removal of links from our website

If you find any link on our Website that is offensive for any reason, you are free to contact and inform us any moment. We will consider requests to remove links but we are not obligated to or so or to respond to you directly.

We do not ensure that the information on this website is correct, we do not warrant its completeness or accuracy; nor do we promise to ensure that the website remains available or that the material on the website is kept up to date.

Disclaimer

To the maximum extent permitted by applicable law, we exclude all representations, warranties and conditions relating to our website and the use of this website. Nothing in this disclaimer will:

    • limit or exclude our or your liability for death or personal injury;
    • limit or exclude our or your liability for fraud or fraudulent misrepresentation;
    • limit any of our or your liabilities in any way that is not permitted under applicable law; or
    • exclude any of our or your liabilities that may not be excluded under applicable law.

The limitations and prohibitions of liability set in this Section and elsewhere in this disclaimer: (a) are subject to the preceding paragraph; and (b) govern all liabilities arising under the disclaimer, including liabilities arising in contract, in tort and for breach of statutory duty.

As long as the website and the information and services on the website are provided free of charge, we will not be liable for any loss or damage of any nature.

Intellectual Property Rights

Other than the content you own, under these Terms, agersoftware srl and/or its licensors own all the intellectual property rights and materials contained in this Website.

You are granted limited license only for purposes of viewing the material contained on this Website.

Trademarks

The trademarks, service marks, and logos (the “Trademarks”) used and displayed on this site are registered and unregistered Trademarks of AgerSoftware and others.

Nothing on this site should be construed as granting, by implication, estoppel, or otherwise, any license or right to use any Trademark displayed on the site, without the written permission of the Trademark owner. AgerSoftware aggressively enforces its intellectual property rights to the fullest extent of the law.

The Trademark(s) AgerSoftware, SecureUPDATE, SecureDELTA, SecurePATCH, SecureENCODE, SecureENCODING, SecureDECODE, SecureDECODING may not be used in any way, including in advertising or publicity pertaining to distribution of materials on this site, without prior, written permission.

Out strategic partner Trademark(s) NetLUP, NetLUP Xtreme Technologies, XtremeZIP, XtremeDELTA, XtremeUI may not be used in any way, including in advertising or publicity pertaining to distribution of materials on this site, without prior, written permission.

AgerSoftware prohibits use of any of the forgoing names or marks as a metatag or as a “hot” link to any AgerSoftware site unless establishment of such a link is approved in advance by AgerSoftware in writing. If You have any questions regarding any trademarks on the site, please contact AgerSoftware.

Restrictions

You are specifically restricted from all of the following:

    • publishing any Website material in any other media;
    • selling, sublicensing and/or otherwise commercializing any Website material;
    • publicly performing and/or showing any Website material;
    • using this Website in any way that is or may be damaging to this Website;
    • using this Website in any way that impacts user access to this Website;
    • using this Website contrary to applicable laws and regulations, or in any way may cause harm to the Website, or to any person or business entity;
    • engaging in any data mining, data harvesting, data extracting or any other similar activity in relation to this Website;
    • using this Website to engage in any advertising or marketing.

Certain areas of this Website are restricted from being access by you and agersoftware srl may further restrict access by you to any areas of this Website, at any time, in absolute discretion. Any user ID and password you may have for this Website are confidential and you must maintain confidentiality as well.

Your Content

In these Website Standard Terms and Conditions, "Your Content" shall mean any audio, video text, images or other material you choose to display on this Website. By displaying Your Content, you grant agersoftware srl a non-exclusive, worldwide irrevocable, sub licensable license to use, reproduce, adapt, publish, translate and distribute it in any and all media.

Your Content must be your own and must not be invading any third-party’s rights. agersoftware srl reserves the right to remove any of Your Content from this Website at any time without notice.

Your Privacy

Please read Privacy Policy .

No warranties. Limitation of liability

This Website is provided "as is," with all faults, and agersoftware srl express no representations or warranties, of any kind related to this Website or the materials contained on this Website. Also, nothing contained on this Website shall be interpreted as advising you.

In no event shall agersoftware srl, nor any of its officers, directors and employees, shall be held liable for anything arising out of or in any way connected with your use of this Website whether such liability is under contract. agersoftware srl, including its officers, directors and employees shall not be held liable for any indirect, consequential or special liability arising out of or in any way related to your use of this Website.

Indemnification. Severability.

You hereby indemnify to the fullest extent agersoftware srl from and against any and/or all liabilities, costs, demands, causes of action, damages and expenses arising in any way related to your breach of any of the provisions of these Terms.

If any provision of these Terms is found to be invalid under any applicable law, such provisions shall be deleted without affecting the remaining provisions herein.

Variation of Terms. Assignment

The agersoftware srl is allowed to assign, transfer, and subcontract its rights and/or obligations under these Terms without any notification. However, you are not allowed to assign, transfer, or subcontract any of your rights and/or obligations under these Terms.

agersoftware srl is permitted to revise these Terms at any time as it sees fit, and by using this Website you are expected to review these Terms on a regular basis.

Entire Agreement

These Terms constitute the entire agreement between agersoftware srl and you in relation to your use of this Website, and supersede all prior agreements and understandings.

Governing Law & Jurisdiction

These Terms will be governed by and interpreted in accordance with the laws of Romania, a European Union member, and you submit to the non-exclusive jurisdiction of other state and federal courts for the resolution of any disputes.


12.2 Privacy Policy

12. Legal Information ››

12.2 Privacy Policy

Contents:

Privacy Policy

agersoftware srl is located at:

Blvd. Dimitrie Pompeiu nr. 5-9, Bucharest
020335,

Romania

European Union

It is agersoftware srl's policy to respect your privacy regarding any information we may collect while operating our website. This Privacy Policy applies to https://www.agersoftware.com (hereinafter, "us", "we", or "https://www.agersoftware.com"). We respect your privacy and are committed to protecting personally identifiable information you may provide us through the Website. We have adopted this privacy policy ("Privacy Policy") to explain what information may be collected on our Website, how we use this information, and under what circumstances we may disclose the information to third parties. This Privacy Policy applies only to information we collect through the Website and does not apply to our collection of information from other sources.

This Privacy Policy, together with the Terms and conditions posted on our Website, set forth the general rules and policies governing your use of our Website. Depending on your activities when visiting our Website, you may be required to agree to additional terms and conditions.

For the purposes of this policy, agersoftware defines the term “User” as an entity who registers for our services through our website or an individual whose data you (our customer) collect and store using our services and the term “Visitor” as an individual that visits our website (e.g. https://agersoftware.com).

Website Visitors

Like most website operators, agersoftware srl collects non-personally-identifying information of the sort that web browsers and servers typically make available, such as the browser type, language preference, referring site, and the date and time of each visitor request. agersoftware srl's purpose in collecting non-personally identifying information is to better understand how agersoftware srl's visitors use its website. From time to time, agersoftware srl may release non-personally-identifying information in the aggregate, e.g., by publishing a report on trends in the usage of its website.

agersoftware srl also collects potentially personally-identifying information like Internet Protocol (IP) addresses for logged in users and for users leaving comments on https://www.agersoftware.com blog posts. agersoftware srl only discloses logged in user and commenter IP addresses under the same circumstances that it uses and discloses personally-identifying information as described below.

Gathering of Personally-Identifying Information

Certain visitors to agersoftware srl's websites choose to interact with agersoftware srl in ways that require agersoftware srl to gather personally-identifying information. The amount and type of information that agersoftware srl gathers depends on the nature of the interaction. For example, we ask visitors who sign up for an account at agersoftware's estore and provide a username, email address along with other information.

Sharing personal data

We do not sell, trade, or rent your personal identification information to others. We may share generic aggregated demographic information not linked to any personal identification information regarding visitors and users with our business partners, trusted affiliates and advertisers for the purposes outlined above. We may use third party service providers to help us operate our business and administer activities on our behalf, such as sending out newsletters or surveys. We may share your information with these third parties for those limited purposes.

Security

The security of your Personal Information is important to us, but remember that no method of transmission over the Internet, or method of electronic storage is 100% secure. While we strive to use commercially acceptable means to protect your Personal Information, we cannot guarantee its absolute security.

Advertisements

Ads appearing on our website may be delivered to users by advertising partners, who may set cookies. These cookies allow the ad server to recognize your computer each time they send you an online advertisement to compile information about you or others who use your computer. This information allows ad networks to, among other things, deliver targeted advertisements that they believe will be of most interest to you. This Privacy Policy covers the use of cookies by agersoftware srl and does not cover the use of cookies by any advertisers.

Links To External Sites

Our Service may contain links to external sites that are not operated by us. If you click on a third party link, you will be directed to that third party's site. We strongly advise you to review the Privacy Policy and terms and conditions of every site you visit. We have no control over, and assume no responsibility for the content, privacy policies or practices of any third party sites, products or services.

We may use Google AdWords

https://www.agersoftware.com uses the remarketing services to advertise on third party websites (including Google) to previous visitors to our site. It could mean that we advertise to previous visitors who haven't completed a task on our site, for example using the contact form to make an enquiry. This could be in the form of an advertisement on the Google search results page, or a site in the Google Display Network. Third-party vendors, including Google, use cookies to serve ads based on someone's past visits. Of course, any data collected will be used in accordance with our own privacy policy and Google's privacy policy.

You can set preferences for how Google advertises to you using the Google Ad Preferences page, and if you want to you can opt out of interest-based advertising entirely by cookie settings or permanently using a browser plugin.

Protection of Certain Personally-Identifying Information

agersoftware srl discloses potentially personally-identifying and personally-identifying information only to those of its employees, contractors and affiliated organizations that (i) need to know that information in order to process it on agersoftware srl's behalf or to provide services available at agersoftware srl's website, and (ii) that have agreed not to disclose it to others. Some of those employees, contractors and affiliated organizations may be located outside of your home country; by using agersoftware srl's website, you consent to the transfer of such information to them. agersoftware srl will not rent or sell potentially personally-identifying and personally-identifying information to anyone. Other than to its employees, contractors and affiliated organizations, as described above, agersoftware srl discloses potentially personally-identifying and personally-identifying information only in response to a subpoena, court order or other governmental request, or when agersoftware srl believes in good faith that disclosure is reasonably necessary to protect the property or rights of agersoftware srl, third parties or the public at large.

If you are a registered user of https://www.agersoftware.com and have supplied your email address, agersoftware srl may occasionally send you an email to tell you about new features, solicit your feedback, or just keep you up to date with what's going on with agersoftware srl and our products. We primarily use our blog to communicate this type of information, so we expect to keep this type of email to a minimum. If you send us a request (for example via a support email or via one of our feedback mechanisms), we reserve the right to publish it in order to help us clarify or respond to your request or to help us support other users. agersoftware srl takes all measures reasonably necessary to protect against the unauthorized access, use, alteration or destruction of potentially personally-identifying and personally-identifying information.

Aggregated Statistics

agersoftware srl may collect statistics about the behavior of visitors to its website. agersoftware srl may display this information publicly or provide it to others. However, agersoftware srl does not disclose your personally-identifying information.

Affiliate Disclosure

This site does not uses affiliate links and does not earn a commission from certain links. This does not affect your purchases or the price you may pay.

Cookies

To enrich and perfect your online experience, agersoftware srl uses "Cookies", similar technologies and services provided by others to display personalized content, appropriate advertising and store your preferences on your computer.

A cookie is a string of information that a website stores on a visitor's computer, and that the visitor's browser provides to the website each time the visitor returns. agersoftware srl uses cookies to help agersoftware srl identify and track visitors, their usage of https://www.agersoftware.com, and their website access preferences. agersoftware srl visitors who do not wish to have cookies placed on their computers should set their browsers to refuse cookies before using agersoftware srl's websites, with the drawback that certain features of agersoftware srl's websites may not function properly without the aid of cookies.

By continuing to navigate our website without changing your cookie settings, you hereby acknowledge and agree to agersoftware srl's use of cookies.

E-commerce

Those who engage in transactions with agersoftware srl – by purchasing agersoftware srl's services or products, are asked to provide additional information, including as necessary the personal and financial information required to process those transactions. In each case, agersoftware srl collects such information only insofar as is necessary or appropriate to fulfill the purpose of the visitor's interaction with agersoftware srl. agersoftware srl does not disclose personally-identifying information other than as described below. And visitors can always refuse to supply personally-identifying information, with the caveat that it may prevent them from engaging in certain website-related activities.

Business Transfers

If agersoftware srl, or substantially all of its assets, were acquired, or in the unlikely event that agersoftware srl goes out of business or enters bankruptcy, user information would be one of the assets that is transferred or acquired by a third party. You acknowledge that such transfers may occur, and that any acquirer of agersoftware srl may continue to use your personal information as set forth in this policy.

Privacy Policy Changes

Although most changes are likely to be minor, agersoftware srl may change its Privacy Policy from time to time, and in agersoftware srl's sole discretion. agersoftware srl encourages visitors to frequently check this page for any changes to its Privacy Policy. Your continued use of this site after any change in this Privacy Policy will constitute your acceptance of such change.

Contact Information

If you have any questions about this Privacy Policy, please contact us via email at legal@agersoftware.com .


12.3 Cookies Policy

12. Legal Information ››

12.3 Cookies Policy

Contents:

AgerSoftware Website Cookies Policy

Our website, https://www.agersoftware.com (the "Website"), is operated by AgerSoftware s.r.l.

What are cookies?

Cookies are a small text files that are stored in your web browser that allows agersoftware website or a third party to recognize you. Cookies can be used to collect, store and share bits of information about your activities across websites, including on agersoftware website website.

Cookies might be used for the following purposes:

    • To enable certain functions
    • To provide analytics
    • To store your preferences
    • To enable ad delivery and behavioral advertising

agersoftware website uses both session cookies and persistent cookies.

A session cookie is used to identify a particular visit to our Website. These cookies expire after a short time, or when you close your web browser after using our Website. We use these cookies to identify you during a single browsing session, such as when you log into our Website.

A persistent cookie will remain on your devices for a set period of time specified in the cookie. We use these cookies where we need to identify you over a longer period of time. For example, we would use a persistent cookie if you asked that we keep you signed in.

How do third parties use cookies on the agersoftware website?

Third party companies like analytics companies and ad networks generally use cookies to collect user information on an anonymous basis. They may use that information to build a profile of your activities on the agersoftware website and other websites that you've visited.

What are your cookies options?

If you don't like the idea of cookies or certain types of cookies, you can change your browser's settings to delete cookies that have already been set and to not accept new cookies. To learn more about how to do this, visit the help pages of your browser.

Please note, however, that if you delete cookies or do not accept them, you might not be able to use all of the features we offer, you may not be able to store your preferences, and some of our pages might not display properly.

Where can I find more information about cookies?

You can learn more about cookies by visiting the following third party websites:

    • All About Cookies.org


12.4 GDPR Policy

12. Legal Information ››

12.4 GDPR Policy

Contents:

At AgerSoftware website, accessible from https://www.agersoftware.com , one of our main priorities is the privacy of our visitors. This Privacy Policy document contains types of information that is collected and recorded by AgerSoftware website and how we use it.

If you have additional questions or require more information about our Privacy Policy, do not hesitate to contact us.

General Data Protection Regulation (GDPR)

We are a Data Controller of your information.

AgerSoftware SRL legal basis for collecting and using the personal information described in this Privacy Policy depends on the Personal Information we collect and the specific context in which we collect the information:

    • AgerSoftware SRL needs to perform a contract with you
    • You have given AgerSoftware SRL permission to do so
    • Processing your personal information is in AgerSoftware SRL legitimate interests
    • AgerSoftware SRL needs to comply with the law

AgerSoftware SRL will retain your personal information only for as long as is necessary for the purposes set out in this Privacy Policy. We will retain and use your information to the extent necessary to comply with our legal obligations, resolve disputes, and enforce our policies.

If you are a resident of the European Economic Area (EEA), you have certain data protection rights. If you wish to be informed what Personal Information we hold about you and if you want it to be removed from our systems, please contact us.

In certain circumstances, you have the following data protection rights:

    • The right to access, update or to delete the information we have on you.
    • The right of rectification.
    • The right to object.
    • The right of restriction.
    • The right to data portability
    • The right to withdraw consent

Log Files

AgerSoftware website follows a standard procedure of using log files. These files log visitors when they visit websites. All hosting companies do this and a part of hosting services' analytics. The information collected by log files include internet protocol (IP) addresses, browser type, Internet Service Provider (ISP), date and time stamp, referring/exit pages, and possibly the number of clicks. These are not linked to any information that is personally identifiable. The purpose of the information is for analyzing trends, administering the site, tracking users' movement on the website, and gathering demographic information.

Cookies and Web Beacons

Like any other website, AgerSoftware website uses 'cookies'. These cookies are used to store information including visitors' preferences, and the pages on the website that the visitor accessed or visited. The information is used to optimize the users' experience by customizing our web page content based on visitors' browser type and/or other information.

Google DoubleClick DART Cookie

Google is one of a third-party vendor on our site. It also uses cookies, known as DART cookies. We may use Google DoubleClick to serve ads to our site visitors based upon their visit to www.agersoftware.com and other sites on the internet. However, visitors may choose to decline the use of DART cookies by visiting the Google ad and content network Privacy Policy at the following URL – https://policies.google.com/technologies/ads

Our Advertising Partners

We may use advertisement services from our partners. Some of advertisers we may use on our site use cookies and web beacons. Our advertising partners are listed below. Each of our advertising partners has their own Privacy Policy for their policies on user data. For easier access, we hyperlinked to their Privacy Policies below.

    • Google

https://policies.google.com/technologies/ads

Privacy Policies

You may consult this list to find the Privacy Policy for each of the advertising partners of AgerSoftware website.

Third-party ad servers or ad networks uses technologies like cookies, JavaScript, or Web Beacons that are used in their respective advertisements and links that appear on AgerSoftware website, which are sent directly to users' browser. They automatically receive your IP address when this occurs. These technologies are used to measure the effectiveness of their advertising campaigns and/or to personalize the advertising content that you see on websites that you visit.

Note that AgerSoftware website has no access to or control over these cookies that are used by third-party advertisers.

Third Party Privacy Policies

AgerSoftware website's Privacy Policy does not apply to other advertisers or websites. Thus, we are advising you to consult the respective Privacy Policies of these third-party ad servers for more detailed information. It may include their practices and instructions about how to opt-out of certain options. You may find a complete list of these Privacy Policies and their links here: Privacy Policy Links.

You can choose to disable cookies through your individual browser options. To know more detailed information about cookie management with specific web browsers, it can be found at the browsers' respective websites. What Are Cookies?

Children's Information

Another part of our priority is adding protection for children while using the internet. We encourage parents and guardians to observe, participate in, and/or monitor and guide their online activity.

AgerSoftware website does not knowingly collect any Personal Identifiable Information from children under the age of 13. If you think that your child provided this kind of information on our website, we strongly encourage you to contact us immediately and we will do our best efforts to promptly remove such information from our records.

Online Privacy Policy Only

Our Privacy Policy created at GDPRPrivacyPolicy.net) applies only to our online activities and is valid for visitors to our website with regards to the information that they shared and/or collect in AgerSoftware website. This policy is not applicable to any information collected offline or via channels other than this website.

Consent

By using our website, you hereby consent to our Privacy Policy and agree to its terms.


13. GeoLocations

13 Geo-Locations

Contents:

SecureDELTA Help Document files have been edited at the following locations:

    • Bucharest, Romania
    • Istanbul, Turkey
    • Munich, Germany
    • Kiev, Ukraine


14. EULA

14 End-User-License-Agreement

Contents:

*** END USER LICENSE AGREEMENT ***

SecureDELTA™ APP for Windows v2.56

IMPORTANT: PLEASE READ THIS LICENSE CAREFULLY BEFORE USING THIS SOFTWARE.

The Software licensed under this Agreement consists of computer programs, libraries, data compilation(s) and documentation referred to as SecureDELTA APP version 2.56 (the "Software", "SecureDELTA")

"You" or "Licensee" means the entity evaluating SecureDELTA or the entity using a licensed version of SecureDELTA.

"COMPANY" or "Licensor" means the business entity agersoftware srl ("agersoftware", "agersoftware srl", "AgerSoftware S.R.L." or "AGERSOFTWARE" srl)

"Documentation" means the written or online posted documents or electronic information generally made available by Licensor to its customers relating to the operation and functionality of SecureDELTA, including user manuals, installation guides, and any "read me" or "help" files.

"Site" consists of a single physical address, unless otherwise specified and agreed upon in writing. Noncontinuous physical buildings are not the same "Site" for purposes of this EULA.

1. ACCEPTANCE

1.1. LICENSE GRANT

1.2.1. PERPETUAL TERMS FOR REGISTERED VERSION LICENSE

1.2.2. REGISTERED VERSION LICENSE GRANT FOR SINGLE COPIES (NON-NETWORK USE).

1.2.3. REGISTERED VERSION LICENSE GRANT FOR NETWORK USE.

1.2.4.1. RUNTIME LICENSE FOR PAID (REGISTERED) LICENSEE USERS.

1.2.4.1. RUNTIME LICENSE FOR TRIAL USERS.

1.2.5. PURCHASE OF ADDITIONAL LICENSES

1.2.6. RESTRICTIONS ON TRANSFER

2. EVALUATION LICENSE

2.1. EVALUATION LICENSE GRANT.

2.1.1. EVALUATION SOFTWARE USED IN PRODUCTION.

2.1.2. ACKNOWLEDGMENT AND RESERVATION OF RIGHTS.

2.1.3. YOUR DISTRIBUTION RIGHTS.

2.1.4. INSTALLATION AND SUPPORT.

2.1.5. NON-COMPETITION.

2.1.6. NO USE TO CREATE COMPETING PRODUCTS

2.1.7. CONSULTANCY

2.1.6. NO RUNTIME LICENSE FOR EVALUATORS.

2.1.8. UPGRADES AND SUPPORT SERVICES.

2.1.9. EVALUATION SOFTWARE.

2.1.10. DISTRIBUTION.

2.1.11. NONREDISTRIBUTABLE FILES.

3. SOFTWARE PURPOSE

4. USE AGREEMENT

4.1 USE

4.2 USE RESTRICTIONS

4.3. COPYRIGHT RESTRICTION

4.4. OWNERSHIP

4.5. INTELLECTUAL PROPERTY

4.6. COPYRIGHTS.

4.7 LIMITATION OF RESPONSIBILITY

4.8 WARRANTIES

5. LIMITATION OF LIABILITY

6. CONFIDENTIALITY

7. INDEMNIFICATION

8. MISCELLANEOUS PROVISIONS

8.1 SEVERABILITY.

8.2 ASSIGNMENT.

8.3 GOVERNING LAW and FORUM CHOICE.

8.4 INJUCTION RELIEF.

8.5 ENTIRE AGREEMENT

8.6 MODIFICATION AND WAIVER

9. TRADEMARK(s).

10. TERMINATION

10.1. DISCLAIMER OF WARRANTY. LIMITATION OF LIABILITIES.

11. NO WAIVER.

11.1. EXPORT RESTRICTIONS

11.1.1. MISCELLANEOUS TERMS AND CONDITIONS.

11.1.2. U.S. GOVERNMENT END USERS.

11.1.3. LICENSEE OUTSIDE THE U.S.

11.2. CONSENT OF USE OF DATA.

12. ENTIRE AGREEMENT.

Create, edited, copyright by:

agersoftware srl

Bucharest, Romania

EU

Contact/Questions:

sales@agersoftware.com

contact@agersoftware.com

support@agersoftware.com

Copyright © & ™ 2019-2029 by agersoftware srl. All Rights Reserved.


EULA Details

14. EULA ››

*** END USER LICENSE AGREEMENT ***

SecureDELTA™ APP for Windows v2.56

IMPORTANT: PLEASE READ THIS LICENSE CAREFULLY BEFORE USING THIS SOFTWARE.

The Software licensed under this Agreement consists of computer programs, libraries, data compilation(s) and documentation referred to as SecureDELTA, version 2.56 (the "Software", "SecureDELTA" or "SECUREDELTA")

"You" or "Licensee" means the entity evaluating SecureDELTA or the entity using a licensed version of SecureDELTA.

"COMPANY" or "Licensor" means the business entity agersoftware srl ("agersoftware", "agersoftware srl", "AgerSoftware S.R.L." or "AGERSOFTWARE" srl)

"Documentation" means the written or online posted documents or electronic information generally made available by Licensor to its customers relating to the operation and functionality of SecureDELTA, including user manuals, installation guides, and any "read me" or "help" files.

"Site" consists of a single physical address, unless otherwise specified and agreed upon in writing. Noncontiguous physical buildings are not the same "Site" for purposes of this EULA.

1. ACCEPTANCE

YOU ACCEPT AND AGREE TO BE BOUND BY THE TERMS OF THIS AGREEMENT BY SELECTING THE "ACCEPT" OPTION AND DOWNLOADING SECUREDELTA OR BY INSTALLING, USING, OR COPYING SECUREDELTA.

YOU MUST AGREE TO ALL OF THE TERMS OF THIS AGREEMENT BEFORE YOU WILL BE ALLOWED TO DOWNLOAD, INSTALL, AND USE SECUREDELTA.

IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS AGREEMENT, YOU MUST SELECT "DECLINE" AND YOU MUST NOT INSTALL, USE, OR COPY SECUREDELTA.

1.1. LICENSE GRANT

By receiving, opening the file package containing SecureDELTA, and/or using SecureDELTA, you agree that this End User License Agreement(EULA) is a legally binding and valid contract and agree to be bound by it. You agree to abide by the intellectual property laws and all of the terms and conditions of this Agreement.

Unless you have a different license agreement signed by agersoftware, your use of SecureDELTA indicates your acceptance of this license agreement and warranty.

Subject to the terms of this Agreement, agersoftware grants to you a limited, non-exclusive, non-transferable license, without right to sub-license, to use SecureDELTA in accordance with this Agreement and any other written agreement with agersoftware.

This Agreement entitles you to install and use one copy of SecureDELTA. You may install, use, access, display and run SecureDELTA at one "Site" under your ownership or control.

In addition, you may make one archival copy of SecureDELTA. The archival copy must be on a storage medium other than a hard drive, and may only be used for the reinstallation of SecureDELTA at the same location where the archival copy has been made.

This Agreement does not permit the installation or use, of multiple copies of SecureDELTA, or the installation of SecureDELTA on more than one computer at any given time, on a system that allows shared used of applications, on a multi-user network, or on any configuration or system of computers that allows multiple users.

Multiple copy use or installation is only allowed if you obtain an appropriate license and a licensing agreement for each user and each copy of SecureDELTA, from agersoftware or one of its distribution partners.

You agree that Remote access of SecureDELTA at the "Site" via modems, login or networks is not permitted. You agree to prevent transfer of SecureDELTA from the "Site" by use of administrative, hardware and/or software controls.

You may transfer SecureDELTA to another "Site" under your ownership or control, on a permanent basis, provided you retain no copies of SecureDELTA (including backup or archival copies) and the recipient agrees to the terms and conditions of this EULA. If the SecureDELTA copy is an upgrade, any transfer must include all prior versions of the SecureDELTA software, including all Media and Documentation.

For further information regarding multiple copy licensing of SecureDELTA, please contact agersoftware Sales Department at sales@agersoftware.com

1.2.1. PERPETUAL TERMS FOR REGISTERED VERSION LICENSE

The term of the license granted herein for the registered version of SecureDELTA shall be perpetual unless terminated by written notice by "You" for convenience or terminated by either party for material breach. Immediately upon termination of this license for any reason, You shall return to agersoftware all copies of SecureDELTA and documentation.

1.2.2. REGISTERED VERSION LICENSE GRANT FOR SINGLE COPIES (NON-NETWORK USE).

If You are a registered user of SecureDELTA, You are granted nonexclusive rights to install and use SecureDELTA by a single person who uses SecureDELTA only on one primary computer or workstation and optionally a secondary laptop computer or home computer, providing you are not using the Software concurrently on both locations. You may copy SecureDELTA for archival purposes, provided that any copy must contain the original Software's proprietary notices in unaltered form.

1.2.3. REGISTERED VERSION LICENSE GRANT FOR NETWORK USE.

If You are a registered user of SecureDELTA, You are granted non-exclusive rights to install and use SecureDELTA and/or transmit SecureDELTA over an internal computer network, provided You acquire and dedicate a licensed copy of SecureDELTA for each user who may access SecureDELTA concurrently with any other user. You may copy SecureDELTA for archival purposes, provided that any copy must contain the original Software's proprietary notices in unaltered form.

1.2.4.1. RUNTIME LICENSE FOR PAID (REGISTERED) LICENSEE USERS.

If You are a paid registered user of the "Software", You are granted nonexclusive rights to distribute the runtime applications called "SecureDELTA Installers" ("SecureDELTA Self Extracting Patch" files or "SecurePATCH" files) created by SecureDELTA on a royalty-free basis.

1.2.4.2. RUNTIME LICENSE FOR TRIAL USERS.

If You are and evaluating user of the "Software", You do not have the rights to distribute the runtime applications ("SecureDELTA Self Extracting Patch" files or "SecureDELTA Installers" or "SecurePATCH" files) created by SecureDELTA, under no circumstances

and under no environment that defines as production or commercial environment.

1.2.5. PURCHASE OF ADDITIONAL LICENSES

Registered users of SecureDELTA may purchase license(s) for additional authorized use of SecureDELTA in accordance with the "COMPANY" then-current volume pricing schedule.

Such additional licenses shall be governed by the terms and conditions stated hereof.

You agree that, absent agersoftware's express written acceptance thereof, the terms and conditions contained in any purchase order or other document issued by You to agersoftware for the purchase of additional licenses, shall not be binding on agersoftware to the extent that such terms and conditions are additional to or inconsistent with those contained in this Agreement.

If you do not agree to be bound by this agreement, immediately remove SecureDELTA from your computer and, if applicable, promptly return to agersoftware by mail any copies of SecureDELTA and related documentation and packaging in your possession.

1.2.6. RESTRICTIONS ON TRANSFER

Without first obtaining the express written consent of agersoftware, you may not assign your rights and obligations under this Agreement, or redistribute, encumber, sell, rent, lease, sublicense, or otherwise transfer your rights to SecureDELTA.

agersoftware does not transfer the title of the "Software" to you; the license granted to you is not a sale. This agreement is a binding legal agreement between agersoftware and the evaluators (or purchasers, users) of the "Software".

2 EVALUATION LICENSE

2.1. EVALUATION LICENSE GRANT.

Licensor hereby grants to Licensee a limited, non-exclusive, non-transferable, license to install and use 1 (one) copy of the "Software" solely for evaluation and trial purposes subject to the terms and conditions of this Agreement.

The trial license of the "Software" does not extend to ant comercial or any other form of production and/or delivery environment.

If You have downloaded or otherwise received an evaluation version of the Software, You are authorized to use the Software on a royalty-free basis for evaluation purposes during the initial evaluation period of thirty (30) days. During the evaluation period, You may copy the Software for archival purposes, provided that any copy must contain the original Software's proprietary notices in unaltered form. You have the option to register for full use of the Software at any time during the evaluation period by following the instructions in the accompanying documentation and/or on the "Software" screens, including the payment of the required license fee. Your use of the Software for any purpose after the expiration of the initial evaluation period is not authorized without written approval from agersoftware.

Upon expiration of the limited evaluation period, you must remove the "Software" from your computer or purchase a license for the "Software".

2.1.1. EVALUATION SOFTWARE USAGE IN PRODUCTION.

Evaluation Licensee may not use SecureDELTA in a production environment or in relationship with any commercial software or applications, being part of, or in connection with. Licensee may not make any use, or engage in any distribution, of the "Software" except as expressly authorized herein.

Licensee may not reverse engineer, decompile, disassemble, modify, alter in any way, show altered images of the "Software" or copies of the "Software", or without proper copyright acknowledgement, or make any other attempt to access the source code of the "Software", or make any additional copies of SecureDELTA for any purpose except such transient electronic copies as are necessary during the installation and use of a single copy of SecureDELTA on a single machine.

2.1.2. ACKNOWLEDGMENT AND RESERVATION OF RIGHTS.

Licensee acknowledges and agrees that Licensor owns all intellectual property and other proprietary rights in and to SecureDELTA, including, without limitation, all trademarks, service marks and tradenames associated with SecureDELTA as listed herein: SecureUPDATE, SecurePATCH, SecureENCODE, SecureENCODING, SecureDECODE and SecureDECODING.

Furthermore, Licensee acknowledges and agrees that this Agreement does not and shall not be construed to transfer or as a transfer, to Licensee, of any express or implied license to Licensor's intellectual property or other proprietary rights, except as expressly set forth herein.

All rights not expressly granted herein are reserved to the "COMPANY", including the right to make use of any and all trademarks, service marks and/or tradenames associated with SecureDELTA as listed herein: SecureUPDATE, SecurePATCH, SecureENCODE, SecureDECODE, SecureENCODING and SecureDECODING as it sees fit.

You further acknowledge and agree that all rights, title, and interest in and to the "Software" are and shall remain the exclusive property of the "COMPANY".

2.1.3. YOUR DISTRIBUTION RIGHTS.

To the distribution level that you have licensed, and except as specified in Sections 2.1.9. and 2.1.11. below (EVALUATION SOFTWARE and NONREDISTRIBUTABLE FILES), you have the right to reproduce and distribute SecureDELTA files and SecureDELTA generated files ("SecurePATCH" files), provided that you agree to indemnify, hold harmless, and defend the "COMPANY" from and against any claims or lawsuits, including attorney's fees, that arise or result from the use or distribution of your software product.

2.1.4. INSTALLATION AND SUPPORT.

Licensee is solely responsible for installation and configuration of SecureDELTA and does so at its own risk.

2.1.5. NON-COMPETITION.

Licensee shall not use all or any part of SecureDELTA, or any ideas, concepts, technology, know-how or other information embodied within or learned from SecureDELTA in any manner in competition with Licensor for a period of FIVE (5) years following the expiration or termination of this Agreement.

2.1.6. NO USE TO CREATE COMPETING PRODUCTS

YOU AGREE NOT TO USE SecureDELTA TO CREATE COMPETING PRODUCTS. You must not use SecureDELTA (or any part thereof including but not limited to provided Binary files, Generated Files, Object Code, Source Code and Documentation) to develop products competitive with SecureDELTA for a period of 5 (FIVE) years following the termination or during the lifetime of this agreement.

2.1.7. CONSULTANCY

YOU AGREE NOT TO USE SecureDELTA FOR CONSULTING AN INTERNAL OR EXTERNAL CLIENT, UNLESS CLIENT TO BE SERVED ALSO HAS SecureDELTA LICENSE.

You may not use SecureDELTA (or any part thereof) in connection with the provision of consulting or other services, whether for value or otherwise, on behalf of any third party unless both client and consultant hold current valid SecureDELTA EULAs.

2.1.8. NO RUNTIME LICENSE FOR EVALUATORS.

If You are a user of the Trial version of SecureDELTA, You are not granted any rights to distribute the runtime binary applications called "SecureDELTA Installers" ("SecureDELTA Self Extracting Patch Files", "SecureDelta Installers" or "SecurePatch files") produced by SecureDELTA and any related application of SecureDELTA if You do not have a Purchased License of the "Software".

2.1.9. UPGRADES AND SUPPORT SERVICES.

To use a version of SecureDELTA identified as an upgrade, you must also be licensed for the product identified by the "COMPANY" as eligible for the upgrade.

A product that is designated by the "COMPANY" as an upgrade, replaces and/or supplements the product that formed the eligibility for such upgrade and/or update.

You must use the resulting upgraded product only in accordance with the terms of this EULA. Any supplemental software code or "fixes" provided to you as part of the Technical Support Services shall be considered as part of the Software and subject also to the terms of this EULA.

2.1.10. EVALUATION SOFTWARE.

Evaluators are granted a limited license for the sole purpose of determining if SecureDELTA is suitable for their needs. Use of an Evaluation Copy of SecureDELTA for any other purpose by any person, partnership, corporation, government agency, educational facility, or other entity is strictly prohibited. You may not use an Evaluation Copy, notwithstanding other sections of this EULA, for commercial purposes, nor sell, or otherwise transfer it for value.

Commercial purposes include the right of use of SecureDELTA in the creation of publicly distributed computer software.

2.1.11. DISTRIBUTION.

SecureDELTA and the license herein granted shall not be copied, shared, distributed, re-sold, offered for re-sale, transferred or sub-licensed in whole or in part except that you may make one copy for archive purposes only.

For information about redistribution of SecureDELTA Products and/or SecureDELTA related products, please contact agersoftware Legal Department at legal@agersoftware.com

2.1.12. NONREDISTRIBUTABLE FILES.

You may not distribute the runtime binaries (Agersoftware_Decode_Dll_DEMO_TRIAL_v2.55_x64.dll, Agersoftware_Encode_Dll_DEMO_TRIAL_v2.55_x64.dll, Agersoftware_Encode_Dll_Full_v2.55_x64.dll, Agersoftware_Decode_Dll_Full_v2.55_x64.dll, LexActivator.dll, SecureDELTA_Trial.exe, SecureDELTA.exe, SecureDELTA_Manual.chm (SecureDELTA™_Help_Manual.chm)) for any reason. Licensee may not rent, lease, sell or otherwise attempt to make any commercial gain through use or distribution of SecureDELTA.

3. SOFTWARE PURPOSE

The "Software" has been designed for human interaction to help create binary diff files and SecureDELTA Installers (SecurePATCH files) that are to be used for the sole purpose of update and/or patch other existing software files, in relationship to your clients, given that "You" have already acquired a license.

If is forbidden to run, execute or spawn SecureDELTA application automatically or under any other way locally or remotely, from the internet or LAN, without human interaction, contrary to the intentional use for which the "Software" has been created.

4. USE AGREEMENT

4.1 USE

Your license to use SecureDELTA is limited to the number of licenses purchased by you.. You shall not allow others to use, copy or evaluate copies of SecureDELTA.

4.2 USE RESTRICTIONS

You shall use SecureDELTA in compliance with all applicable laws and not for any unlawful purpose. Without limiting the foregoing, use, display or distribution of SecureDELTA together with material that is pornographic, racist, vulgar, obscene, defamatory, libelous, abusive, promoting hatred, discriminating or displaying prejudice based on religion, ethnic heritage, race, sexual orientation or age is strictly prohibited.

Each licensed copy of SecureDELTA may be used on one single computer location by one user. Use of SecureDELTA means that you have loaded, installed, or run (including spawned or executed by human interaction or during an automated proces) SecureDELTA on a computer or similar device. If you install SecureDELTA onto a multi-user platform, server or network, each and every individual user of SecureDELTA must be licensed separately.

You may make one copy of SecureDELTA for backup purposes, providing you only have one copy installed on one computer being used by one person. Other users may not use your copy of SecureDELTA . The assignment, sublicense, networking, sale, or distribution of copies of SecureDELTA are strictly forbidden without the prior written consent of the "COMPANY".

It is a violation of this agreement to assign, sell, share, loan, rent, lease, borrow, network or transfer the use of SecureDELTA. If any person other than yourself uses SecureDELTA registered in your name, regardless of whether it is at the same time or different times, then this agreement is being violated and you are responsible for that violation!

You may also not: (i) permit others to use the Software, except for runtime suitability testing purposes;

(ii) modify or translate the Software;

(iii) reverse engineer, decompile, or disassemble the Software, except to the extent this restriction is expressly prohibited by applicable law; (v) develop or distribute applications that provide direct access to the Software's programming interface; (vi) bundle the Software in a development environment; (vii) copy the Software, except as expressly provided above; or (viii) remove or obscure any proprietary rights notices or labels on the Software.

4.3. COPYRIGHT RESTRICTION

This Software contains copyrighted material, trade secrets and other proprietary material. You shall not, and shall not attempt to, modify, reverse engineer, disassemble or decompile SecureDELTA. Nor can you create any derivative works or other works that are based upon or derived from SecureDELTA in whole or in part.

4.4. OWNERSHIP

agersoftware's name, logo and graphics file that represents SecureDELTA, SecureUPDATE, SecurePATCH and all other agersoftware marks and trademarks shall not be used in any way to promote products developed with SecureDELTA.

the "COMPANY" retains sole and exclusive ownership of all right, title and interest in and to SecureDELTA and all Intellectual Property rights relating thereto.

4.5. INTELLECTUAL PROPERTY

agersoftware and its suppliers own SecureDELTA and all intellectual property rights embodied therein, including copyrights and valuable trade secrets embodied in SecureDELTA's design and coding methodology. SecureDELTA is protected by EUROPEAN UNION copyright laws, United States copyright law and international treaty provisions. This Agreement provides You only a limited use license, and no ownership of any intellectual property.

4.6. COPYRIGHTS.

Copyright law and international copyright treaty provisions protect all parts of SecureDELTA, products and services. No program, code, part, image, audio sample, or text may be copied or used in any way by the user except as intended within the bounds of the single user program. All rights not expressly granted hereunder are reserved for the "COMPANY"

4.7 LIMITATION OF RESPONSIBILITY.

You will indemnify, hold harmless, and defend the "COMPANY", its employees, agents and distributors against any and all claims, proceedings, demand and costs resulting from or in any way connected with your use of the "COMPANY" 's Software.

In no event (including, without limitation, in the event of negligence) will the "COMPANY", its employees, agents or distributors be liable for any consequential, incidental, indirect, special or punitive damages whatsoever (including, without limitation, damages for loss of profits, loss of use, business interruption, loss of information or data, or pecuniary loss), in connection with or arising out of or related to this Agreement, SecureDELTA or the use or inability to use SecureDELTA or the furnishing, performance or use of any other matters hereunder whether based upon contract, tort or any other theory including negligence.

the "COMPANY"'s entire liability, without exception, is limited to the customers' reimbursement of the purchase price of SecureDELTA (maximum being the lesser of the amount paid by you and the suggested retail price as listed by the "COMPANY") in exchange for the return of the product, all copies, registration papers and manuals, and all materials that constitute a transfer of license from the customer back to the "COMPANY"

4.8 WARRANTIES

Except as expressly stated in writing, the "COMPANY" makes no representation or warranties in respect of this Software and expressly excludes all other warranties, expressed or implied, oral or written, including, without limitation, any implied warranties of merchantable quality or fitness for a particular purpose.

LICENSEE ACKNOWLEDGES THAT SECUREDELTA IS PROVIDED TO LICENSEE FOR EVALUATION PURPOSES ONLY. SECUREDELTA IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, ANY WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR NON-INFRINGEMENT. LICENSOR DOES NOT WARRANT THAT SECUREDELTA WILL BE BUG-FREE OR FREE FROM PROGRAM ERRORS. LICENSOR DOES NOT MAKE ANY REPRESENTATIONS REGARDING SECUREDELTA AND DOES NOT MAKE ANY WARRANTY REGARDING THE USE, INSTALLATION, OR THE RESULTS OF THE USE OF SECUREDELTA.

5. LIMITATION OF LIABILITY

UNDER NO CIRCUMSTANCES SHALL LICENSOR BE LIABLE TO LICENSEE OR ANY THIRD PARTY FOR ANY INDIRECT, INCIDENTAL, CONSEQUENTIAL, SPECIAL, EXEMPLARY, OR PUNITIVE DAMAGES, OR ANY OTHER PECUNIARY LOSS ARISING OUT OF THE INSTALLATION, USE, OR INABILITY TO USE SECUREDELTA (INCLUDING, WITHOUT LIMITATION, ANY LOSS OF DATA, COST OF PROCUREMENT OF SUBSTITUTE GOODS, DISRUPTION OF BUSINESS, LOSS OF PROFITS, OR ANY OTHER MATTER RELATING TO YOUR USE OR INABILITY TO USE SECUREDELTA or RELATED AGERSOFTWARE SOFTWARE PRODUCTS) OR RELATED IN ANY WAY TO THIS AGREEMENT OR THE SUBJECT THEREOF, WHETHER ARISING UNDER THEORIES OF CONTRACT, NEGLIGENCE, STRICT LIABILITY, TORT, OR OTHER THEORY, REGARDLESS WHETHER LICENSOR HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. THE LIMITATIONS, EXCLUSIONS AND DISCLAIMERS SET FORTH IN THIS EULA SHALL APPLY TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, EVEN IF ANY REMEDY FAILS OF ITS ESSENTIAL PURPOSE. NO OBLIGATION OR LIABILITY SHALL ARISE FROM LICENSOR’S RENDERING OF TECHNICAL OR OTHER ADVICE OR SERVICE IN CONNECTION WITH THIS AGREEMENT, INCLUDING, WITHOUT LIMITATION, ADVICE OR SERVICE RELATED TO THE INSTALLATION OR CONFIGURATION OF SECUREDELTA. Some states and jurisdictions do not allow exclusion or limitation of liability for consequential or incidental DAMAGES and so the above limits and exclusions may not entirely apply to licensee or may be limited by law.

6. CONFIDENTIALITY

SecureDELTA and related Documentation is confidential and trade secret information (the "Proprietary Information") that is proprietary to and solely owned by Licensor and its Licensors, together with all related copyrights and trademarks. Licensee agrees to maintain the Proprietary Information in strictest confidence for the benefit of Licensor. Licensee shall not make available or allow to be made available the Proprietary Information to any third party nor shall the Licensee use such Proprietary Information except as authorized by this Agreement.

7. INDEMNIFICATION

Licensee shall indemnify, defend, and hold harmless Licensor, and its directors, officers, trustees, shareholders, employees, subsidiaries, agents, successors and assigns from and against any and all claims, expenses, losses, damages, costs, liabilities and judgments, including without limitation reasonable attorneys’ fees and expenses, arising out of or relating to any claim, charge, suit, or threat of any kind by any third party resulting from or related to its use or misuse of SecureDELTA, failure to abide by the terms of this Agreement, or violation of any applicable law.

8. MISCELLANEOUS PROVISIONS

8.1 SEVERABILITY.

The provisions of this Agreement are severable. If any provision of this Agreement is held to be invalid, illegal, or unenforceable, such provision is to that extent to be deemed omitted and not part of this Agreement. The validity, legality, or enforceability of the remaining provisions shall in no way be affected or impaired thereby and shall be valid and enforceable to the maximum extent permitted by law.

8.2 ASSIGNMENT.

This Agreement shall be binding on and inure to the benefit of the parties hereto and their respective successors and assigns. Notwithstanding the foregoing, Licensee shall not assign, sublicense, or otherwise transfer all or any part of this Agreement without the prior written consent of Licensor.

8.3 GOVERNING LAW and FORUM CHOICE.

This Agreement shall be governed by the law of the Romania applicable therein and shall be construed as having been made in, without regard to that state's choice of law rules or conflict of law provisions. Licensee agrees that both venue and personal jurisdiction over Licensee shall be proper in a Romanian Court of Law where the "COMPANY" resides, for purposes of any disputes arising out of or related in any way to this Agreement, and Licensee hereby irrevocably consents to the jurisdiction of such courts.

You hereby irrevocably attorn and submit to the non-exclusive jurisdiction of the courts of Romania therefrom. If any provision shall be considered unlawful, void or otherwise unenforceable, then that provision shall be deemed severable from this License and not affect the validity and enforceability of any other provisions.

8.4 INJUCTION RELIEF.

Licensee acknowledges and agrees that monetary damages alone would not be an adequate remedy in the event of a material breach by Licensee of Licensee’s obligations under this Agreement and that, in such event, Licensor shall be entitled to injunctive relief to require Licensee to comply with Licensee’s obligations hereunder.

8.5 ENTIRE AGREEMENT

This Agreement constitutes the exclusive and entire agreement between the parties with respect to the subject matter hereof, and supersedes all prior agreements, negotiations, representations and proposals, written or oral, relating to the subject matter hereof

8.6 MODIFICATION AND WAIVER

No modification of this Agreement and no waiver of any breach of this Agreement shall be effective unless in writing and signed by an authorized representative of the party against whom enforcement is sought. No waiver of any breach of this Agreement and no course of dealing between the parties shall be construed as a waiver of any subsequent breach of this Agreement. The failure of either party at any time or times to require performance of any provision hereof shall in no manner affect the right at a later time to enforce such provision.

9. TRADEMARK(s).

SecureDELTA is a trademark of the "COMPANY". No right, rights, license, or interest to such trademark is granted hereunder, and you agree that no such right, license, or interest shall be asserted by you with respect to such trademark.

10. TERMINATION

Any failure to comply with the terms and conditions of this Agreement will result in automatic and immediate termination of this license. Upon termination of this license granted herein for any reason, you agree to immediately cease use of SecureDELTA and destroy all copies of SecureDELTA supplied under this Agreement.

This EULA is in effect until terminated. This EULA will terminate automatically if you fail to comply with the limitations described herein. On termination, you must destroy all copies of the Software.

The financial obligations incurred by you shall survive the expiration or termination of this license.

10.1. DISCLAIMER OF WARRANTY. LIMITATION OF LIABILITIES.

AGERSOFTWARE PROVIDES THE SOFTWARE "AS-IS", PROVIDED WITH ALL POSSIBLE FAULTS AND WITHOUT WARRANTIES AS TO PERFORMANCE OR MERCHANTABILITY OR ANY OTHER WARRANTIES WHETHER EXPRESSED OR IMPLIED. THIS DISCLAIMER CONCERNS ALL FILES GENERATED AND EDITED BY SECUREDELTA AS WELL. NEITHER AGERSOFTWARE NOR ANY OF ITS SUPPLIERS OR RESELLERS MAKES ANY WARRANTY OF ANY KIND, EXPRESS OR IMPLIED.

AGERSOFTWARE AND ITS SUPPLIERS SPECIFICALLY DISCLAIM THE IMPLIED WARRANTIES OF TITLE, NON-INFRINGEMENT, MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, SYSTEM INTEGRATION, AND DATA ACCURACY. THERE IS NO WARRANTY OR GUARANTEE THAT THE OPERATION OF THE SOFTWARE WILL BE UNINTERRUPTED, ERROR-FREE, OR VIRUS-FREE, OR THAT THE SOFTWARE WILL MEET ANY PARTICULAR CRITERIA OF PERFORMANCE, QUALITY, ACCURACY, PURPOSE, OR NEED.

YOU ASSUME THE ENTIRE RISK OF SELECTION, INSTALLATION, AND USE OF THE SOFTWARE. THIS DISCLAIMER OF WARRANTY CONSTITUTES AN ESSENTIAL PART OF THIS AGREEMENT. NO USE OF THE SOFTWARE IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS DISCLAIMER.

If implied warranties may not be disclaimed under applicable law, then ANY IMPLIED WARRANTIES ARE LIMITED IN DURATION TO THE PERIOD REQUIRED BY APPLICABLE LAW. Where limitations are not allowed on how long an implied warranty may last, then the above limitations may not apply to You. This warranty gives you specific rights, and You may have other rights which vary from jurisdiction to jurisdiction.

To the extent that this Warranty Statement is inconsistent with the jurisdiction where You use the Software, the Warranty Statement shall be deemed to be modified consistent with such local law. Under such local law, certain limitations may not apply, and you may have additional rights which vary from jurisdiction to jurisdiction. For example, some states in the United States and some jurisdictions outside the United States may: (i) preclude the disclaimers and limitations of this Warranty Statement from limiting the rights of a consumer; (ii) otherwise restrict the ability of a manufacturer to make such disclaimers or to impose such limitations; or (iii) grant the consumer additional legal rights, specify the duration of implied warranties which the manufacturer cannot disclaim, or prohibit limitations on how long an implied warranty lasts.

INDEPENDENT OF THE FORGOING PROVISIONS, IN NO EVENT AND UNDER NO LEGAL THEORY, INCLUDING WITHOUT LIMITATION, TORT, CONTRACT, OR STRICT PRODUCTS LIABILITY, SHALL AGERSOFTWARE SRL OR ANY OF ITS SUPPLIERS, OWNERS, SHAREHOLDERS OR MEMBERS OF AGERSOFTWARE PAID IN FULL, PART TIME OR CONTRACTORS, BE LIABLE TO YOU OR ANY OTHER PERSON FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF ANY KIND, INCLUDING WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER MALFUNCTION, OR ANY OTHER KIND OF COMMERCIAL DAMAGE, EVEN IF AGERSOFTWARE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. THIS LIMITATION SHALL NOT APPLY TO LIABILITY FOR DEATH OR PERSONAL INJURY TO THE EXTENT PROHIBITED BY APPLICABLE LAW. IN NO EVENT SHALL AGERSOFTWARE'S LIABILITY FOR ACTUAL DAMAGES FOR ANY CAUSE WHATSOEVER, AND REGARDLESS OF THE FORM OF ACTION, EXCEED THE AMOUNT OF THE PURCHASE PRICE PAID FOR THE SOFTWARE LICENSE.

11. NO WAIVER. The failure of either party to enforce any rights granted hereunder or to take action against the other party in the event of any breach hereunder shall not be deemed a waiver by that party as to subsequent enforcement of rights or the subsequent actions in the event of future breaches.

11.1 EXPORT RESTRICTIONS

You agree to comply with all export laws and restrictions and regulations of the United States or foreign agencies or authorities, and not to export or re-export the Software or any direct product thereof in violation of any such restrictions, laws or regulations, or without all necessary approvals.

As applicable, each party shall obtain and bear all expenses relating to any necessary licenses and/or exemptions with respect to its own export of the Software from the U.S.

Neither the Software nor the underlying information or technology may be electronically transmitted or otherwise exported or re-exported (i) into Cuba, Iran, Iraq, Libya, North Korea, Sudan, Syria or any other country subject to U.S. trade sanctions covering the Software, to individuals or entities controlled by such countries, or to nationals or residents of such countries other than nationals who are lawfully admitted permanent residents of countries not subject to such sanctions; or (ii) to anyone on the U.S. Treasury Department's list of Specially Designated Nationals and Blocked Persons or the U.S. Commerce Department's Table of Denial Orders. By downloading or using the Software, Licensee agrees to the foregoing and represents and warrants that it complies with these conditions.

11.1.1. MISCELLANEOUS TERMS AND CONDITIONS.

This Agreement constitutes the entire understanding of the parties with respect to the subject matter of this Agreement and merges all prior communications, representations, and agreements. This Agreement may be modified only by a written agreement signed by the parties. If any provision of this Agreement is held to be unenforceable for any reason, such provision shall be reformed only to the extent necessary to make it enforceable. This Agreement shall be construed under the laws of Romania, excluding rules regarding conflicts of law. The application the United Nations Convention of Contracts for the International Sale of Goods is expressly excluded. This license is written in English, and English is its controlling language.

10.1.2. U.S. GOVERNMENT END USERS.

The Software is a "commercial item," as that term is defined in 48 C.F.R. 2.101 (Oct. 1995), consisting of "commercial computer software" and "commercial computer software documentation," as such terms are used in 48 C.F.R. 12.212 (Sept. 1995). Consistent with 48 C.F.R. 12.212 and 48 C.F.R. 227.7202-1 through 227.7202-4 (June 1995), all U.S. Government End Users acquire the Software with only those rights set forth herein.

11.1.3. LICENSEE OUTSIDE THE U.S.

If You are located outside the U.S., then the following provisions shall apply: (i) Les parties aux presentes confirment leur volonte que cette convention de meme que tous les documents y compris tout avis qui siy rattache, soient rediges en langue anglaise (translation: "The parties confirm that this Agreement and all related documentation is and will be in the English language."); and (ii) You are responsible for complying with any local laws in your jurisdiction which might impact your right to import, export or use the Software, and You represent that You have complied with any regulations or registration procedures required by applicable law to make this license enforceable.

11.2. CONSENT OF USE OF DATA.

You agree that the "COMPANY" may collect and use information gathered in any manner as part of the product support services provided to you, if any, related to SecureDELTA.

the "COMPANY" may also use this information to provide notices to you which may be of use or interest to you, in regard to but not limited to all terms and conditions agreed upon herein.

12. ENTIRE AGREEMENT.

This EULA is the entire agreement between you and the "COMPANY" relating to SecureDELTA application, version 2.55, and it supersedes all prior or contemporaneous oral or written communications, proposals, and representations with respect to SecureDELTA or any other subject matter covered by this EULA.

Created, edited and Copyrights:

agersoftware srl

Bucharest, Romania

EU

Contact:

sales@agersoftware.com

contact@agersoftware.com

support@agersoftware.com