Altsoft.MergeSplitPDF Namespace

Altsoft MergeSplit PDF User's Guide reference library
Altsoft.MergeSplitPDF Namespace
Namespaces ► Altsoft.MergeSplitPDF
Declaration Syntax
C# Visual Basic
namespace Altsoft.MergeSplitPDF
Namespace Altsoft.MergeSplitPDF
Types
All Types Classes
Icon | Type | Description
 | PageRange |
 | PDFDestination |
 | PDFEngine |
 | PDFLog |
 | PDFSecuritySettings |
 | PDFSource |
2008 Microsoft Corporation. All rights reserved.


PageRange Class

PageRange Class
Namespaces ► Altsoft.MergeSplitPDF ► PageRange
Declaration Syntax
C# Visual Basic
public class PageRange
Public Class PageRange
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PageRange()()() |
 | Add(Int32) |
 | AddAllEven()()() |
 | AddAllOdd()()() |
 | AddRange(Int32, Int32) |
 | AddRange(Int32) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()() | (Inherited from Object.)
 | GetHashCode()()() | (Inherited from Object.)
 | GetPageNumbers(Int32) |
 | GetType()()() | (Inherited from Object.)
 | MemberwiseClone()()() | (Inherited from Object.)
 | ToString()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
PageRange

Assembly: MergeSplitPDF (Module: MergeSplitPDF)


Add Method (number)

Add Method (number)
Namespaces ► Altsoft.MergeSplitPDF ► PageRange ► Add(Int32)
Declaration Syntax
C# Visual Basic
public void Add(
    int number
)
Public Sub Add ( _
    number As Integer _
)
Parameters
number (Int32)


AddAllEven Method

AddAllEven Method
Namespaces ► Altsoft.MergeSplitPDF ► PageRange ► AddAllEven()()()
Declaration Syntax
C# Visual Basic
public void AddAllEven()
Public Sub AddAllEven


AddAllOdd Method

AddAllOdd Method
Namespaces ► Altsoft.MergeSplitPDF ► PageRange ► AddAllOdd()()()
Declaration Syntax
C# Visual Basic
public void AddAllOdd()
Public Sub AddAllOdd


AddRange Method

AddRange Method
Namespaces ► Altsoft.MergeSplitPDF ► PageRange ► AddRange()()()
Members
Icon | Member | Description
 | AddRange(Int32, Int32) |
 | AddRange(Int32) |


AddRange Method (from)

AddRange Method (from)
Namespaces ► Altsoft.MergeSplitPDF ► PageRange ► AddRange(Int32)
Declaration Syntax
C# Visual Basic
public void AddRange(
    int from
)
Public Sub AddRange ( _
    from As Integer _
)
Parameters
from (Int32)


AddRange Method (from, to)

AddRange Method (from, to)
Namespaces ► Altsoft.MergeSplitPDF ► PageRange ► AddRange(Int32, Int32)
Declaration Syntax
C# Visual Basic
public void AddRange(
    int from,
    int to
)
Public Sub AddRange ( _
    from As Integer, _
    to As Integer _
)
Parameters
from (Int32)
to (Int32)


GetPageNumbers Method (pageCount)

GetPageNumbers Method (pageCount)
Namespaces ► Altsoft.MergeSplitPDF ► PageRange ► GetPageNumbers(Int32)
Declaration Syntax
C# Visual Basic
public int[] GetPageNumbers(
    int pageCount
)
Public Function GetPageNumbers ( _
    pageCount As Integer _
) As Integer()
Parameters
pageCount (Int32)


PageRange Constructor

PageRange Constructor
Namespaces ► Altsoft.MergeSplitPDF ► PageRange ► PageRange()()()
Declaration Syntax
C# Visual Basic
public PageRange()
Public Sub New


PDFDestination Class

PDFDestination Class
Namespaces ► Altsoft.MergeSplitPDF ► PDFDestination
Declaration Syntax
C# Visual Basic
public class PDFDestination : IDisposable
Public Class PDFDestination _
    Implements IDisposable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddBackground(PDFSource) |
 | Close()()() |
 | DeleteJavaScript()()() |
 | IDisposable..::.Dispose()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()() | (Inherited from Object.)
 | GetHashCode()()() | (Inherited from Object.)
 | GetType()()() | (Inherited from Object.)
 | MemberwiseClone()()() | (Inherited from Object.)
 | Merge(PDFSource, Double) |
 | Merge(PDFSource, PDFLog, Double) |
 | PageCount |
 | Save(Stream, PDFLog) |
 | Save(String, PDFLog) |
 | Save(Stream, PDFLog, PDFSecuritySettings) |
 | Save(String, PDFLog, PDFSecuritySettings) |
 | ToString()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
PDFDestination


AddBackground Method (background)

AddBackground Method (background)
Namespaces ► Altsoft.MergeSplitPDF ► PDFDestination ► AddBackground(PDFSource)
Declaration Syntax
C# Visual Basic
public void AddBackground(
    PDFSource background
)
Public Sub AddBackground ( _
    background As PDFSource _
)
Parameters
background (PDFSource)


Close Method

Close Method
Namespaces ► Altsoft.MergeSplitPDF ► PDFDestination ► Close()()()
Declaration Syntax
C# Visual Basic
public void Close()
Public Sub Close


DeleteJavaScript Method

DeleteJavaScript Method
Namespaces ► Altsoft.MergeSplitPDF ► PDFDestination ► DeleteJavaScript()()()
Declaration Syntax
C# Visual Basic
public void DeleteJavaScript()
Public Sub DeleteJavaScript


Dispose Method

Dispose Method
Namespaces ► Altsoft.MergeSplitPDF ► PDFDestination ► IDisposable..::.Dispose()()()
Declaration Syntax
C# Visual Basic
void IDisposable.Dispose()
Private Sub Dispose Implements IDisposable.Dispose


Merge Method

Merge Method
Namespaces ► Altsoft.MergeSplitPDF ► PDFDestination ► Merge()()()
Members
Icon | Member | Description
 | Merge(PDFSource, Double) |
 | Merge(PDFSource, PDFLog, Double) |


Merge Method (source, log, weight)

Merge Method (source, log, weight)
Namespaces ► Altsoft.MergeSplitPDF ► PDFDestination ► Merge(PDFSource, PDFLog, Double)
Declaration Syntax
C# Visual Basic
public void Merge(
    PDFSource source,
    PDFLog log,
    double weight
)
Public Sub Merge ( _
    source As PDFSource, _
    log As PDFLog, _
    weight As Double _
)
Parameters
source (PDFSource)
log (PDFLog)
weight (Double)


Merge Method (source, weight)

Merge Method (source, weight)
Namespaces ► Altsoft.MergeSplitPDF ► PDFDestination ► Merge(PDFSource, Double)
Declaration Syntax
C# Visual Basic
public void Merge(
    PDFSource source,
    double weight
)
Public Sub Merge ( _
    source As PDFSource, _
    weight As Double _
)
Parameters
source (PDFSource)
weight (Double)


PageCount Property

PageCount Property
Namespaces ► Altsoft.MergeSplitPDF ► PDFDestination ► PageCount
Declaration Syntax
C# Visual Basic
public int PageCount { get; }
Public ReadOnly Property PageCount As Integer


Save Method

Save Method
Namespaces ► Altsoft.MergeSplitPDF ► PDFDestination ► Save()()()
Members
Icon | Member | Description
 | Save(Stream, PDFLog) |
 | Save(String, PDFLog) |
 | Save(Stream, PDFLog, PDFSecuritySettings) |
 | Save(String, PDFLog, PDFSecuritySettings) |


Save Method (path, log)

Save Method (path, log)
Namespaces ► Altsoft.MergeSplitPDF ► PDFDestination ► Save(String, PDFLog)
Declaration Syntax
C# Visual Basic
public void Save(
    string path,
    PDFLog log
)
Public Sub Save ( _
    path As String, _
    log As PDFLog _
)
Parameters
path (String)
log (PDFLog)


Save Method (path, log, settings)

Save Method (path, log, settings)
Namespaces ► Altsoft.MergeSplitPDF ► PDFDestination ► Save(String, PDFLog, PDFSecuritySettings)
Declaration Syntax
C# Visual Basic
public void Save(
    string path,
    PDFLog log,
    PDFSecuritySettings settings
)
Public Sub Save ( _
    path As String, _
    log As PDFLog, _
    settings As PDFSecuritySettings _
)
Parameters
path (String)
log (PDFLog)
settings (PDFSecuritySettings)


Save Method (stream, log)

Save Method (stream, log)
Namespaces ► Altsoft.MergeSplitPDF ► PDFDestination ► Save(Stream, PDFLog)
Declaration Syntax
C# Visual Basic
public void Save(
    Stream stream,
    PDFLog log
)
Public Sub Save ( _
    stream As Stream, _
    log As PDFLog _
)
Parameters
stream (Stream)
log (PDFLog)


Save Method (stream, log, settings)

Save Method (stream, log, settings)
Namespaces ► Altsoft.MergeSplitPDF ► PDFDestination ► Save(Stream, PDFLog, PDFSecuritySettings)
Declaration Syntax
C# Visual Basic
public void Save(
    Stream stream,
    PDFLog log,
    PDFSecuritySettings settings
)
Public Sub Save ( _
    stream As Stream, _
    log As PDFLog, _
    settings As PDFSecuritySettings _
)
Parameters
stream (Stream)
log (PDFLog)
settings (PDFSecuritySettings)


PDFEngine Class

PDFEngine Class
Namespaces ► Altsoft.MergeSplitPDF ► PDFEngine
Declaration Syntax
C# Visual Basic
public sealed class PDFEngine
Public NotInheritable Class PDFEngine
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PDFEngine()()() |
 | CreateDestination()()() |
 | CreateDestination(String) |
 | CreateDestination(Stream) |
 | CreateSource(String) |
 | CreateSource(Stream) |
 | Engine |
 | Equals(Object) | (Inherited from Object.)
 | Expires |
 | Finalize()()() | (Inherited from Object.)
 | GetHashCode()()() | (Inherited from Object.)
 | GetType()()() | (Inherited from Object.)
 | Load(String) |
 | MemberwiseClone()()() | (Inherited from Object.)
 | ProductEdition |
 | ToString()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
PDFEngine


CreateDestination Method

CreateDestination Method
Namespaces ► Altsoft.MergeSplitPDF ► PDFEngine ► CreateDestination()()()
Members
Icon | Member | Description
 | CreateDestination()()() |
 | CreateDestination(String) |
 | CreateDestination(Stream) |


CreateDestination Method

CreateDestination Method
Namespaces ► Altsoft.MergeSplitPDF ► PDFEngine ► CreateDestination()()()
Declaration Syntax
C# Visual Basic
public PDFDestination CreateDestination()
Public Function CreateDestination As PDFDestination


CreateDestination Method (stream)

CreateDestination Method (stream)
Namespaces ► Altsoft.MergeSplitPDF ► PDFEngine ► CreateDestination(Stream)
Declaration Syntax
C# Visual Basic
public PDFDestination CreateDestination(
    Stream stream
)
Public Function CreateDestination ( _
    stream As Stream _
) As PDFDestination
Parameters
stream (Stream)


CreateDestination Method (uri)

CreateDestination Method (uri)
Namespaces ► Altsoft.MergeSplitPDF ► PDFEngine ► CreateDestination(String)
Declaration Syntax
C# Visual Basic
public PDFDestination CreateDestination(
    string uri
)
Public Function CreateDestination ( _
    uri As String _
) As PDFDestination
Parameters
uri (String)


CreateSource Method

CreateSource Method
Namespaces ► Altsoft.MergeSplitPDF ► PDFEngine ► CreateSource()()()
Members
Icon | Member | Description
 | CreateSource(String) |
 | CreateSource(Stream) |


CreateSource Method (stream)

CreateSource Method (stream)
Namespaces ► Altsoft.MergeSplitPDF ► PDFEngine ► CreateSource(Stream)
Declaration Syntax
C# Visual Basic
public PDFSource CreateSource(
    Stream stream
)
Public Function CreateSource ( _
    stream As Stream _
) As PDFSource
Parameters
stream (Stream)


CreateSource Method (uri)

CreateSource Method (uri)
Namespaces ► Altsoft.MergeSplitPDF ► PDFEngine ► CreateSource(String)
Declaration Syntax
C# Visual Basic
public PDFSource CreateSource(
    string uri
)
Public Function CreateSource ( _
    uri As String _
) As PDFSource
Parameters
uri (String)


Engine Property

Engine Property
Namespaces ► Altsoft.MergeSplitPDF ► PDFEngine ► Engine
Declaration Syntax
C# Visual Basic
public static PDFEngine Engine { get; }
Public Shared ReadOnly Property Engine As PDFEngine


Expires Property

Expires Property
Namespaces ► Altsoft.MergeSplitPDF ► PDFEngine ► Expires
Declaration Syntax
C# Visual Basic
public DateTime Expires { get; }
Public ReadOnly Property Expires As DateTime


Load Method (serialKey)

Load Method (serialKey)
Namespaces ► Altsoft.MergeSplitPDF ► PDFEngine ► Load(String)
Declaration Syntax
C# Visual Basic
public void Load(
    string serialKey
)
Public Sub Load ( _
    serialKey As String _
)
Parameters
serialKey (String)


PDFEngine Constructor

PDFEngine Constructor
Namespaces ► Altsoft.MergeSplitPDF ► PDFEngine ► PDFEngine()()()
Declaration Syntax
C# Visual Basic
public PDFEngine()
Public Sub New


ProductEdition Property

ProductEdition Property
Namespaces ► Altsoft.MergeSplitPDF ► PDFEngine ► ProductEdition
Declaration Syntax
C# Visual Basic
public string ProductEdition { get; }
Public ReadOnly Property ProductEdition As String


PDFLog Class

PDFLog Class
Namespaces ► Altsoft.MergeSplitPDF ► PDFLog
Declaration Syntax
C# Visual Basic
public class PDFLog : IXmlSerializable
Public Class PDFLog _
    Implements IXmlSerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PDFLog()()() |
 | EndStage(Int32) |
 | Equals(Object) | (Inherited from Object.)
 | Failed(Exception, Int32) |
 | Finalize()()() | (Inherited from Object.)
 | GetHashCode()()() | (Inherited from Object.)
 | IXmlSerializable..::.GetSchema()()() |
 | GetType()()() | (Inherited from Object.)
 | MemberwiseClone()()() | (Inherited from Object.)
 | Message(String) |
 | IXmlSerializable..::.ReadXml(XmlReader) |
 | Save(String) |
 | Save(Stream, Boolean) |
 | StartStage(String, Double) |
 | TimeUsed |
 | ToString()()() | (Inherited from Object.)
 | IXmlSerializable..::.WriteXml(XmlWriter) |
Inheritance Hierarchy
Object
PDFLog


EndStage Method (stageDepth)

EndStage Method (stageDepth)
Namespaces ► Altsoft.MergeSplitPDF ► PDFLog ► EndStage(Int32)
Declaration Syntax
C# Visual Basic
public void EndStage(
    int stageDepth
)
Public Sub EndStage ( _
    stageDepth As Integer _
)
Parameters
stageDepth (Int32)


Failed Method (ex, stageDepth)

Failed Method (ex, stageDepth)
Namespaces ► Altsoft.MergeSplitPDF ► PDFLog ► Failed(Exception, Int32)
Declaration Syntax
C# Visual Basic
public void Failed(
    Exception ex,
    int stageDepth
)
Public Sub Failed ( _
    ex As Exception, _
    stageDepth As Integer _
)
Parameters
ex (Exception)
stageDepth (Int32)


GetSchema Method

GetSchema Method
Namespaces ► Altsoft.MergeSplitPDF ► PDFLog ► IXmlSerializable..::.GetSchema()()()
Declaration Syntax
C# Visual Basic
XmlSchema IXmlSerializable.GetSchema()
Private Function GetSchema As XmlSchema
    Implements IXmlSerializable.GetSchema


Message Method (message)

Message Method (message)
Namespaces ► Altsoft.MergeSplitPDF ► PDFLog ► Message(String)
Declaration Syntax
C# Visual Basic
public void Message(
    string message
)
Public Sub Message ( _
    message As String _
)
Parameters
message (String)


PDFLog Constructor

PDFLog Constructor
Namespaces ► Altsoft.MergeSplitPDF ► PDFLog ► PDFLog()()()
Declaration Syntax
C# Visual Basic
public PDFLog()
Public Sub New


ReadXml Method (n0032)

ReadXml Method (n0032)
Namespaces ► Altsoft.MergeSplitPDF ► PDFLog ► IXmlSerializable..::.ReadXml(XmlReader)
Declaration Syntax
C# Visual Basic
void IXmlSerializable.ReadXml(
    XmlReader n0032
)
Private Sub ReadXml ( _
    n0032 As XmlReader _
) Implements IXmlSerializable.ReadXml
Parameters
n0032 (XmlReader)


Save Method

Save Method
Namespaces ► Altsoft.MergeSplitPDF ► PDFLog ► Save()()()
Members
Icon | Member | Description
 | Save(String) |
 | Save(Stream, Boolean) |


Save Method (path)

Save Method (path)
Namespaces ► Altsoft.MergeSplitPDF ► PDFLog ► Save(String)
Declaration Syntax
C# Visual Basic
public void Save(
    string path
)
Public Sub Save ( _
    path As String _
)
Parameters
path (String)


Save Method (stream, closeStream)

Save Method (stream, closeStream)
Namespaces ► Altsoft.MergeSplitPDF ► PDFLog ► Save(Stream, Boolean)
Declaration Syntax
C# Visual Basic
public void Save(
    Stream stream,
    bool closeStream
)
Public Sub Save ( _
    stream As Stream, _
    closeStream As Boolean _
)
Parameters
stream (Stream)
closeStream (Boolean)


StartStage Method (stage, weight)

StartStage Method (stage, weight)
Namespaces ► Altsoft.MergeSplitPDF ► PDFLog ► StartStage(String, Double)
Declaration Syntax
C# Visual Basic
public int StartStage(
    string stage,
    double weight
)
Public Function StartStage ( _
    stage As String, _
    weight As Double _
) As Integer
Parameters
stage (String)
weight (Double)


TimeUsed Property

TimeUsed Property
Namespaces ► Altsoft.MergeSplitPDF ► PDFLog ► TimeUsed
Declaration Syntax
C# Visual Basic
public TimeSpan TimeUsed { get; }
Public ReadOnly Property TimeUsed As TimeSpan


WriteXml Method (n0033)

WriteXml Method (n0033)
Namespaces ► Altsoft.MergeSplitPDF ► PDFLog ► IXmlSerializable..::.WriteXml(XmlWriter)
Declaration Syntax
C# Visual Basic
void IXmlSerializable.WriteXml(
    XmlWriter n0033
)
Private Sub WriteXml ( _
    n0033 As XmlWriter _
) Implements IXmlSerializable.WriteXml
Parameters
n0033 (XmlWriter)


PDFSecuritySettings Class

PDFSecuritySettings Class
Namespaces ► Altsoft.MergeSplitPDF ► PDFSecuritySettings
Declaration Syntax
C# Visual Basic
public class PDFSecuritySettings
Public Class PDFSecuritySettings
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PDFSecuritySettings()()() |
 | CertificatePassword |
 | CertificatePath |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()() | (Inherited from Object.)
 | GetHashCode()()() | (Inherited from Object.)
 | GetType()()() | (Inherited from Object.)
 | MemberwiseClone()()() | (Inherited from Object.)
 | SignerLocation |
 | SignerName |
 | SigningReason |
 | ToString()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
PDFSecuritySettings


CertificatePassword Property

CertificatePassword Property
Namespaces ► Altsoft.MergeSplitPDF ► PDFSecuritySettings ► CertificatePassword
Declaration Syntax
C# Visual Basic
public string CertificatePassword { get; set; }
Public Property CertificatePassword As String


CertificatePath Property

CertificatePath Property
Namespaces ► Altsoft.MergeSplitPDF ► PDFSecuritySettings ► CertificatePath
Declaration Syntax
C# Visual Basic
public string CertificatePath { get; set; }
Public Property CertificatePath As String


PDFSecuritySettings Constructor

PDFSecuritySettings Constructor
Namespaces ► Altsoft.MergeSplitPDF ► PDFSecuritySettings ► PDFSecuritySettings()()()
Declaration Syntax
C# Visual Basic
public PDFSecuritySettings()
Public Sub New


SignerLocation Property

SignerLocation Property
Namespaces ► Altsoft.MergeSplitPDF ► PDFSecuritySettings ► SignerLocation
Declaration Syntax
C# Visual Basic
public string SignerLocation { get; set; }
Public Property SignerLocation As String


SignerName Property

SignerName Property
Namespaces ► Altsoft.MergeSplitPDF ► PDFSecuritySettings ► SignerName
Declaration Syntax
C# Visual Basic
public string SignerName { get; set; }
Public Property SignerName As String


SigningReason Property

SigningReason Property
Namespaces ► Altsoft.MergeSplitPDF ► PDFSecuritySettings ► SigningReason
Declaration Syntax
C# Visual Basic
public string SigningReason { get; set; }
Public Property SigningReason As String


PDFSource Class

PDFSource Class
Namespaces ► Altsoft.MergeSplitPDF ► PDFSource
Declaration Syntax
C# Visual Basic
public class PDFSource : IDisposable
Public Class PDFSource _
    Implements IDisposable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Close()()() |
 | DeleteJavaScript()()() |
 | IDisposable..::.Dispose()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()() | (Inherited from Object.)
 | GetHashCode()()() | (Inherited from Object.)
 | GetType()()() | (Inherited from Object.)
 | IsEncrypted |
 | MemberwiseClone()()() | (Inherited from Object.)
 | Split(String, PDFLog, Double) |
 | Split(PageRange, PDFLog, Double) |
 | ToString()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
PDFSource


Close Method

Close Method
Namespaces ► Altsoft.MergeSplitPDF ► PDFSource ► Close()()()
Declaration Syntax
C# Visual Basic
public void Close()
Public Sub Close


DeleteJavaScript Method

DeleteJavaScript Method
Namespaces ► Altsoft.MergeSplitPDF ► PDFSource ► DeleteJavaScript()()()
Declaration Syntax
C# Visual Basic
public void DeleteJavaScript()
Public Sub DeleteJavaScript


Dispose Method

Dispose Method
Namespaces ► Altsoft.MergeSplitPDF ► PDFSource ► IDisposable..::.Dispose()()()
Declaration Syntax
C# Visual Basic
void IDisposable.Dispose()
Private Sub Dispose Implements IDisposable.Dispose


IsEncrypted Property

IsEncrypted Property
Namespaces ► Altsoft.MergeSplitPDF ► PDFSource ► IsEncrypted
Declaration Syntax
C# Visual Basic
public bool IsEncrypted { get; }
Public ReadOnly Property IsEncrypted As Boolean


Split Method

Split Method
Namespaces ► Altsoft.MergeSplitPDF ► PDFSource ► Split()()()
Members
Icon | Member | Description
 | Split(String, PDFLog, Double) |
 | Split(PageRange, PDFLog, Double) |


Split Method (range, log, weight)

Split Method (range, log, weight)
Namespaces ► Altsoft.MergeSplitPDF ► PDFSource ► Split(PageRange, PDFLog, Double)
Declaration Syntax
C# Visual Basic
public PDFDestination Split(
    PageRange range,
    PDFLog log,
    double weight
)
Public Function Split ( _
    range As PageRange, _
    log As PDFLog, _
    weight As Double _
) As PDFDestination
Parameters
range (PageRange)
log (PDFLog)
weight (Double)


Split Method (range, log, weight)

Split Method (range, log, weight)
Namespaces ► Altsoft.MergeSplitPDF ► PDFSource ► Split(String, PDFLog, Double)
Declaration Syntax
C# Visual Basic
public PDFDestination Split(
    string range,
    PDFLog log,
    double weight
)
Public Function Split ( _
    range As String, _
    log As PDFLog, _
    weight As Double _
) As PDFDestination
Parameters
range (String)
log (PDFLog)
weight (Double)


Altsoft.MergeSplitPDF Namespace

Altsoft.MergeSplitPDF Namespace
Namespaces ► Altsoft.MergeSplitPDF
Declaration Syntax
C# Visual Basic
namespace Altsoft.MergeSplitPDF
Namespace Altsoft.MergeSplitPDF
Types
All Types Classes
Icon | Type | Description
 | PageRange |
 | PDFDestination |
 | PDFEngine |
 | PDFLog |
 | PDFSecuritySettings |
 | PDFSource |