Altsoft.Publisher

XML2PDF Formatting Engine
Altsoft.Publisher Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | APConfig | Altsoft formatting engine configuration.
Public class | APDestination | Output document.
Public class | APEngine | Facade class for Altsoft Xml2PDF functionality. This class cannot be inherited.
Public class | APLog | Operation log.
Public class | APSource | Input the document source.

Interfaces

 | Interface | Description
Public interface | APFileSystem | This interface allows you to override interaction of Xml2PDF Server with the file system of your computer.

Enumerations

 | Enumeration | Description
Public enumeration | APDestinationFormat | Available destination formats.
Public enumeration | APSourceFormat | Available source formats.

Send comments on this topic.

© Altsoft Company. All rights reserved.


APConfig Class

APConfig Class
See Also Example Members
[image]

Altsoft formatting engine configuration.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<GuidAttribute("05D17CD4-D9D7-42ea-8A7C-97AE4991C52C"), _
ClassInterfaceAttribute(ClassInterfaceType.AutoDual)>
Public Class APConfig
Inherits ConfigurationSection
Implements ICustomTypeDescriptor
C#
[GuidAttribute("05D17CD4-D9D7-42ea-8A7C-97AE4991C52C")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public class APConfig : ConfigurationSection, ICustomTypeDescriptor
C++
[GuidAttribute(L"05D17CD4-D9D7-42ea-8A7C-97AE4991C52C")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
ref class APConfig : ConfigurationSection, ICustomTypeDescriptor
J#
/** @attribute GuidAttribute("05D17CD4-D9D7-42ea-8A7C-97AE4991C52C") */
/** @attribute ClassInterfaceAttribute(ClassInterfaceType.AutoDual) */
public class APConfig extends ConfigurationSection implements ICustomTypeDescriptor
JScript
public
GuidAttribute("05D17CD4-D9D7-42ea-8A7C-97AE4991C52C")
ClassInterfaceAttribute(ClassInterfaceType.AutoDual)
class APConfig extends ConfigurationSection, ICustomTypeDescriptor

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.Configuration.ConfigurationSection
Altsoft.Publisher.APConfig

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APConfig Members
Altsoft.Publisher Namespace


APConfig Members

APConfig Members
See Also Example Properties Methods
[image]

Altsoft formatting engine configuration.

The following tables list the members exposed by APConfig.

Public Properties

 | Name | Description
Public property | AltOutput | ALT output settings.
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (inherited from ConfigurationElement)
Public property | FoInput | XSL-FO input options.
Public property | Fonts | Font-related settings.
Public property | HtmlInput | HTML input options.
Public property | Input | Set of general output options.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (inherited from ConfigurationElement)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (inherited from ConfigurationElement)
Public property | LockAttributes | Gets the collection of locked attributes (inherited from ConfigurationElement)
Public property | LockElements | Gets the collection of locked elements. (inherited from ConfigurationElement)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (inherited from ConfigurationElement)
Public property | Output | Set of general output options.
Public property | Page | Page settings.
Public property | PdfOutput | PDF output settings.
Public property | PSOutput | PS output settings.
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (inherited from ConfigurationSection)
Public property | Security | Security options.
Public property | SvgInput | SVG input options.
Public property | TIFFOutput | TIFF output settings.
Public property | WordInput | Set of options related to MS Word input.
Public property | WordMetadata | Set of options related to MS Word metadata.
Public property | XPSOutput | XPS output settings.
Top

Protected Properties

 | Name | Description
Family property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (inherited from ConfigurationElement)
Family property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (inherited from ConfigurationElement)
Family property | Item | Overloaded. Gets or sets a property, attribute, or child element of this ConfigurationElement object. (inherited from ConfigurationElement)
Family property | Properties | Gets the collection of properties. (inherited from ConfigurationElement)
Top

Public Methods

 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (inherited from ConfigurationElement)
Public method | LoadXml | Overloaded. Loads configuration settings from the given xml source.
Public method | SaveXml | Overloaded. Saves the current configuration settings to the file with the given path.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DeserializeElement | Overridden.
Family method | DeserializeSection | Overridden.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetRuntimeObject | Overridden.
Family method | Init | Sets the ConfigurationElement object to its initial state. (inherited from ConfigurationElement)
Family method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (inherited from ConfigurationElement)
Family method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded when implemented in a derived class. (inherited from ConfigurationSection)
Family method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (inherited from ConfigurationElement)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (inherited from ConfigurationElement)
Family method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (inherited from ConfigurationElement)
Family method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (inherited from ConfigurationElement)
Family method | PostDeserialize | Called after deserialization. (inherited from ConfigurationElement)
Family method | PreSerialize | Called before serialization. (inherited from ConfigurationElement)
Family method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (inherited from ConfigurationElement)
Family method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (inherited from ConfigurationSection)
Family method | SerializeElement | Overridden.
Family method | SerializeSection | Overridden.
Family method | SerializeToXmlElement | Overridden.
Family method | SetPropertyValue | Sets a property to the specified value. (inherited from ConfigurationElement)
Family method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (inherited from ConfigurationElement)
Family method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (inherited from ConfigurationElement)
Top

See Also

APConfig Class
Altsoft.Publisher Namespace


Properties

APConfig Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | AltOutput | ALT output settings.
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (inherited from ConfigurationElement)
Public property | FoInput | XSL-FO input options.
Public property | Fonts | Font-related settings.
Public property | HtmlInput | HTML input options.
Public property | Input | Set of general output options.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (inherited from ConfigurationElement)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (inherited from ConfigurationElement)
Public property | LockAttributes | Gets the collection of locked attributes (inherited from ConfigurationElement)
Public property | LockElements | Gets the collection of locked elements. (inherited from ConfigurationElement)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (inherited from ConfigurationElement)
Public property | Output | Set of general output options.
Public property | Page | Page settings.
Public property | PdfOutput | PDF output settings.
Public property | PSOutput | PS output settings.
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (inherited from ConfigurationSection)
Public property | Security | Security options.
Public property | SvgInput | SVG input options.
Public property | TIFFOutput | TIFF output settings.
Public property | WordInput | Set of options related to MS Word input.
Public property | WordMetadata | Set of options related to MS Word metadata.
Public property | XPSOutput | XPS output settings.
Top

Protected Properties

 | Name | Description
Family property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (inherited from ConfigurationElement)
Family property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (inherited from ConfigurationElement)
Family property | Item | Overloaded. Gets or sets a property, attribute, or child element of this ConfigurationElement object. (inherited from ConfigurationElement)
Family property | Properties | Gets the collection of properties. (inherited from ConfigurationElement)
Top

See Also

APConfig Class
Altsoft.Publisher Namespace


AltOutput Property

APConfig.AltOutput Property
[image]

ALT output settings.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute(GetType(ExpandableObjectConverter)), _
CategoryAttribute("Output Settings"), _
DisplayNameAttribute("ALT Output"), _
DescriptionAttribute("ALT output settings.")>
Public Property AltOutput As AltOutputSettings
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[CategoryAttribute("Output Settings")]
[DisplayNameAttribute("ALT Output")]
[DescriptionAttribute("ALT output settings.")]
public AltOutputSettings AltOutput { get; set; }
C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[CategoryAttribute(L"Output Settings")]
[DisplayNameAttribute(L"ALT Output")]
[DescriptionAttribute(L"ALT output settings.")]
public property AltOutputSettings AltOutput sealed {
AltOutputSettings get();
void set(AltOutputSettings value);
}
J#
/** @attribute TypeConverterAttribute(typeof(ExpandableObjectConverter)) */
/** @attribute CategoryAttribute("Output Settings") */
/** @attribute DisplayNameAttribute("ALT Output") */
/** @attribute DescriptionAttribute("ALT output settings.") */
/** property */
public AltOutputSettings get_AltOutput();

/** property */
public void set_AltOutput(AltOutputSettings value);
JScript
public function get AltOutput() : AltOutputSettings

public function set AltOutput(value : AltOutputSettings);

See Also

APConfig Class
Altsoft.Publisher Namespace


FoInput Property

APConfig.FoInput Property
[image]

XSL-FO input options.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute(GetType(ExpandableObjectConverter)), _
CategoryAttribute("Input Settings"), _
DisplayNameAttribute("XSL-FO Input"), _
DescriptionAttribute("XSL-FO input options.")>
Public Property FoInput As FoInputSettings
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[CategoryAttribute("Input Settings")]
[DisplayNameAttribute("XSL-FO Input")]
[DescriptionAttribute("XSL-FO input options.")]
public FoInputSettings FoInput { get; set; }
C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[CategoryAttribute(L"Input Settings")]
[DisplayNameAttribute(L"XSL-FO Input")]
[DescriptionAttribute(L"XSL-FO input options.")]
public property FoInputSettings FoInput sealed {
FoInputSettings get();
void set(FoInputSettings value);
}
J#
/** @attribute TypeConverterAttribute(typeof(ExpandableObjectConverter)) */
/** @attribute CategoryAttribute("Input Settings") */
/** @attribute DisplayNameAttribute("XSL-FO Input") */
/** @attribute DescriptionAttribute("XSL-FO input options.") */
/** property */
public FoInputSettings get_FoInput();

/** property */
public void set_FoInput(FoInputSettings value);
JScript
public function get FoInput() : FoInputSettings

public function set FoInput(value : FoInputSettings);

See Also

APConfig Class
Altsoft.Publisher Namespace


Fonts Property

APConfig.Fonts Property
[image]

Font-related settings.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Font-related settings."), _
CategoryAttribute("General Settings"), _
TypeConverterAttribute(GetType(ExpandableObjectConverter)), _
DisplayNameAttribute("Fonts")>
Public Property Fonts As FontsSettings
C#
[DescriptionAttribute("Font-related settings.")]
[CategoryAttribute("General Settings")]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[DisplayNameAttribute("Fonts")]
public FontsSettings Fonts { get; set; }
C++
[DescriptionAttribute(L"Font-related settings.")]
[CategoryAttribute(L"General Settings")]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[DisplayNameAttribute(L"Fonts")]
public property FontsSettings Fonts sealed {
FontsSettings get();
void set(FontsSettings value);
}
J#
/** @attribute DescriptionAttribute("Font-related settings.") */
/** @attribute CategoryAttribute("General Settings") */
/** @attribute TypeConverterAttribute(typeof(ExpandableObjectConverter)) */
/** @attribute DisplayNameAttribute("Fonts") */
/** property */
public FontsSettings get_Fonts();

/** property */
public void set_Fonts(FontsSettings value);
JScript
public function get Fonts() : FontsSettings

public function set Fonts(value : FontsSettings);

See Also

APConfig Class
Altsoft.Publisher Namespace


HtmlInput Property

APConfig.HtmlInput Property
[image]

HTML input options.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("HTML input options."), _
DisplayNameAttribute("HTML Input"), _
TypeConverterAttribute(GetType(ExpandableObjectConverter)), _
CategoryAttribute("Input Settings")>
Public Property HtmlInput As HtmlInputSettings
C#
[DescriptionAttribute("HTML input options.")]
[DisplayNameAttribute("HTML Input")]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[CategoryAttribute("Input Settings")]
public HtmlInputSettings HtmlInput { get; set; }
C++
[DescriptionAttribute(L"HTML input options.")]
[DisplayNameAttribute(L"HTML Input")]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[CategoryAttribute(L"Input Settings")]
public property HtmlInputSettings HtmlInput sealed {
HtmlInputSettings get();
void set(HtmlInputSettings value);
}
J#
/** @attribute DescriptionAttribute("HTML input options.") */
/** @attribute DisplayNameAttribute("HTML Input") */
/** @attribute TypeConverterAttribute(typeof(ExpandableObjectConverter)) */
/** @attribute CategoryAttribute("Input Settings") */
/** property */
public HtmlInputSettings get_HtmlInput();

/** property */
public void set_HtmlInput(HtmlInputSettings value);
JScript
public function get HtmlInput() : HtmlInputSettings

public function set HtmlInput(value : HtmlInputSettings);

See Also

APConfig Class
Altsoft.Publisher Namespace


Input Property

APConfig.Input Property
[image]

Set of general output options.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute(GetType(ExpandableObjectConverter)), _
CategoryAttribute("Input Settings"), _
DisplayNameAttribute("General Input"), _
DescriptionAttribute("General input-related settings.")>
Public Property Input As GeneralInputSettings
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[CategoryAttribute("Input Settings")]
[DisplayNameAttribute("General Input")]
[DescriptionAttribute("General input-related settings.")]
public GeneralInputSettings Input { get; set; }
C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[CategoryAttribute(L"Input Settings")]
[DisplayNameAttribute(L"General Input")]
[DescriptionAttribute(L"General input-related settings.")]
public property GeneralInputSettings Input sealed {
GeneralInputSettings get();
void set(GeneralInputSettings value);
}
J#
/** @attribute TypeConverterAttribute(typeof(ExpandableObjectConverter)) */
/** @attribute CategoryAttribute("Input Settings") */
/** @attribute DisplayNameAttribute("General Input") */
/** @attribute DescriptionAttribute("General input-related settings.") */
/** property */
public GeneralInputSettings get_Input();

/** property */
public void set_Input(GeneralInputSettings value);
JScript
public function get Input() : GeneralInputSettings

public function set Input(value : GeneralInputSettings);

See Also

APConfig Class
Altsoft.Publisher Namespace


Output Property

APConfig.Output Property
[image]

Set of general output options.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute(GetType(ExpandableObjectConverter)), _
DisplayNameAttribute("General Output"), _
DescriptionAttribute("Set of general output options."), _
CategoryAttribute("Output Settings")>
Public Property Output As GeneralOutputSettings
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[DisplayNameAttribute("General Output")]
[DescriptionAttribute("Set of general output options.")]
[CategoryAttribute("Output Settings")]
public GeneralOutputSettings Output { get; set; }
C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[DisplayNameAttribute(L"General Output")]
[DescriptionAttribute(L"Set of general output options.")]
[CategoryAttribute(L"Output Settings")]
public property GeneralOutputSettings Output sealed {
GeneralOutputSettings get();
void set(GeneralOutputSettings value);
}
J#
/** @attribute TypeConverterAttribute(typeof(ExpandableObjectConverter)) */
/** @attribute DisplayNameAttribute("General Output") */
/** @attribute DescriptionAttribute("Set of general output options.") */
/** @attribute CategoryAttribute("Output Settings") */
/** property */
public GeneralOutputSettings get_Output();

/** property */
public void set_Output(GeneralOutputSettings value);
JScript
public function get Output() : GeneralOutputSettings

public function set Output(value : GeneralOutputSettings);

See Also

APConfig Class
Altsoft.Publisher Namespace


Page Property

APConfig.Page Property
[image]

Page settings.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("General Settings"), _
TypeConverterAttribute(GetType(ExpandableObjectConverter)), _
DisplayNameAttribute("Page"), _
DescriptionAttribute("Page settings.")>
Public Property Page As PageSettings
C#
[CategoryAttribute("General Settings")]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[DisplayNameAttribute("Page")]
[DescriptionAttribute("Page settings.")]
public PageSettings Page { get; set; }
C++
[CategoryAttribute(L"General Settings")]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[DisplayNameAttribute(L"Page")]
[DescriptionAttribute(L"Page settings.")]
public property PageSettings Page sealed {
PageSettings get();
void set(PageSettings value);
}
J#
/** @attribute CategoryAttribute("General Settings") */
/** @attribute TypeConverterAttribute(typeof(ExpandableObjectConverter)) */
/** @attribute DisplayNameAttribute("Page") */
/** @attribute DescriptionAttribute("Page settings.") */
/** property */
public PageSettings get_Page();

/** property */
public void set_Page(PageSettings value);
JScript
public function get Page() : PageSettings

public function set Page(value : PageSettings);

See Also

APConfig Class
Altsoft.Publisher Namespace


PdfOutput Property

APConfig.PdfOutput Property
[image]

PDF output settings.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<DisplayNameAttribute("PDF Output"), _
TypeConverterAttribute(GetType(ExpandableObjectConverter)), _
CategoryAttribute("Output Settings"), _
DescriptionAttribute("PDF output settings.")>
Public Property PdfOutput As PdfOutputSettings
C#
[DisplayNameAttribute("PDF Output")]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[CategoryAttribute("Output Settings")]
[DescriptionAttribute("PDF output settings.")]
public PdfOutputSettings PdfOutput { get; set; }
C++
[DisplayNameAttribute(L"PDF Output")]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[CategoryAttribute(L"Output Settings")]
[DescriptionAttribute(L"PDF output settings.")]
public property PdfOutputSettings PdfOutput sealed {
PdfOutputSettings get();
void set(PdfOutputSettings value);
}
J#
/** @attribute DisplayNameAttribute("PDF Output") */
/** @attribute TypeConverterAttribute(typeof(ExpandableObjectConverter)) */
/** @attribute CategoryAttribute("Output Settings") */
/** @attribute DescriptionAttribute("PDF output settings.") */
/** property */
public PdfOutputSettings get_PdfOutput();

/** property */
public void set_PdfOutput(PdfOutputSettings value);
JScript
public function get PdfOutput() : PdfOutputSettings

public function set PdfOutput(value : PdfOutputSettings);

See Also

APConfig Class
Altsoft.Publisher Namespace


PSOutput Property

APConfig.PSOutput Property
[image]

PS output settings.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<DisplayNameAttribute("PS Output"), _
TypeConverterAttribute(GetType(ExpandableObjectConverter)), _
DescriptionAttribute("PS output settings."), _
CategoryAttribute("Output Settings")>
Public Property PSOutput As PSOutputSettings
C#
[DisplayNameAttribute("PS Output")]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[DescriptionAttribute("PS output settings.")]
[CategoryAttribute("Output Settings")]
public PSOutputSettings PSOutput { get; set; }
C++
[DisplayNameAttribute(L"PS Output")]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[DescriptionAttribute(L"PS output settings.")]
[CategoryAttribute(L"Output Settings")]
public property PSOutputSettings PSOutput sealed {
PSOutputSettings get();
void set(PSOutputSettings value);
}
J#
/** @attribute DisplayNameAttribute("PS Output") */
/** @attribute TypeConverterAttribute(typeof(ExpandableObjectConverter)) */
/** @attribute DescriptionAttribute("PS output settings.") */
/** @attribute CategoryAttribute("Output Settings") */
/** property */
public PSOutputSettings get_PSOutput();

/** property */
public void set_PSOutput(PSOutputSettings value);
JScript
public function get PSOutput() : PSOutputSettings

public function set PSOutput(value : PSOutputSettings);

See Also

APConfig Class
Altsoft.Publisher Namespace


Security Property

APConfig.Security Property
[image]

Security options.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute(GetType(ExpandableObjectConverter)), _
DescriptionAttribute("Security options."), _
CategoryAttribute("General Settings"), _
DisplayNameAttribute("Security")>
Public Property Security As SecuritySettings
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[DescriptionAttribute("Security options.")]
[CategoryAttribute("General Settings")]
[DisplayNameAttribute("Security")]
public SecuritySettings Security { get; set; }
C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[DescriptionAttribute(L"Security options.")]
[CategoryAttribute(L"General Settings")]
[DisplayNameAttribute(L"Security")]
public property SecuritySettings Security sealed {
SecuritySettings get();
void set(SecuritySettings value);
}
J#
/** @attribute TypeConverterAttribute(typeof(ExpandableObjectConverter)) */
/** @attribute DescriptionAttribute("Security options.") */
/** @attribute CategoryAttribute("General Settings") */
/** @attribute DisplayNameAttribute("Security") */
/** property */
public SecuritySettings get_Security();

/** property */
public void set_Security(SecuritySettings value);
JScript
public function get Security() : SecuritySettings

public function set Security(value : SecuritySettings);

See Also

APConfig Class
Altsoft.Publisher Namespace


SvgInput Property

APConfig.SvgInput Property
[image]

SVG input options.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<DisplayNameAttribute("SVG Input"), _
TypeConverterAttribute(GetType(ExpandableObjectConverter)), _
DescriptionAttribute("SVG input options."), _
CategoryAttribute("Input Settings")>
Public Property SvgInput As SvgInputSettings
C#
[DisplayNameAttribute("SVG Input")]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[DescriptionAttribute("SVG input options.")]
[CategoryAttribute("Input Settings")]
public SvgInputSettings SvgInput { get; set; }
C++
[DisplayNameAttribute(L"SVG Input")]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[DescriptionAttribute(L"SVG input options.")]
[CategoryAttribute(L"Input Settings")]
public property SvgInputSettings SvgInput sealed {
SvgInputSettings get();
void set(SvgInputSettings value);
}
J#
/** @attribute DisplayNameAttribute("SVG Input") */
/** @attribute TypeConverterAttribute(typeof(ExpandableObjectConverter)) */
/** @attribute DescriptionAttribute("SVG input options.") */
/** @attribute CategoryAttribute("Input Settings") */
/** property */
public SvgInputSettings get_SvgInput();

/** property */
public void set_SvgInput(SvgInputSettings value);
JScript
public function get SvgInput() : SvgInputSettings

public function set SvgInput(value : SvgInputSettings);

See Also

APConfig Class
Altsoft.Publisher Namespace


TIFFOutput Property

APConfig.TIFFOutput Property
[image]

TIFF output settings.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<DisplayNameAttribute("TIFF Output"), _
TypeConverterAttribute(GetType(ExpandableObjectConverter)), _
CategoryAttribute("Output Settings"), _
DescriptionAttribute("TIFF output settings.")>
Public Property TIFFOutput As TIFFOutputSettings
C#
[DisplayNameAttribute("TIFF Output")]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[CategoryAttribute("Output Settings")]
[DescriptionAttribute("TIFF output settings.")]
public TIFFOutputSettings TIFFOutput { get; set; }
C++
[DisplayNameAttribute(L"TIFF Output")]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[CategoryAttribute(L"Output Settings")]
[DescriptionAttribute(L"TIFF output settings.")]
public property TIFFOutputSettings TIFFOutput sealed {
TIFFOutputSettings get();
void set(TIFFOutputSettings value);
}
J#
/** @attribute DisplayNameAttribute("TIFF Output") */
/** @attribute TypeConverterAttribute(typeof(ExpandableObjectConverter)) */
/** @attribute CategoryAttribute("Output Settings") */
/** @attribute DescriptionAttribute("TIFF output settings.") */
/** property */
public TIFFOutputSettings get_TIFFOutput();

/** property */
public void set_TIFFOutput(TIFFOutputSettings value);
JScript
public function get TIFFOutput() : TIFFOutputSettings

public function set TIFFOutput(value : TIFFOutputSettings);

See Also

APConfig Class
Altsoft.Publisher Namespace


WordInput Property

APConfig.WordInput Property
[image]

Set of options related to MS Word input.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute(GetType(ExpandableObjectConverter)), _
DisplayNameAttribute("Word Input"), _
DescriptionAttribute("Set of options related to Word input."), _
CategoryAttribute("Input Settings")>
Public Property WordInput As WordInputSettings
C#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[DisplayNameAttribute("Word Input")]
[DescriptionAttribute("Set of options related to Word input.")]
[CategoryAttribute("Input Settings")]
public WordInputSettings WordInput { get; set; }
C++
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[DisplayNameAttribute(L"Word Input")]
[DescriptionAttribute(L"Set of options related to Word input.")]
[CategoryAttribute(L"Input Settings")]
public property WordInputSettings WordInput sealed {
WordInputSettings get();
void set(WordInputSettings value);
}
J#
/** @attribute TypeConverterAttribute(typeof(ExpandableObjectConverter)) */
/** @attribute DisplayNameAttribute("Word Input") */
/** @attribute DescriptionAttribute("Set of options related to Word input.") */
/** @attribute CategoryAttribute("Input Settings") */
/** property */
public WordInputSettings get_WordInput();

/** property */
public void set_WordInput(WordInputSettings value);
JScript
public function get WordInput() : WordInputSettings

public function set WordInput(value : WordInputSettings);

See Also

APConfig Class
Altsoft.Publisher Namespace


WordMetadata Property

APConfig.WordMetadata Property
[image]

Set of options related to MS Word metadata.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Set of options related to Word metadata."), _
TypeConverterAttribute(GetType(ExpandableObjectConverter)), _
DisplayNameAttribute("Word Metadata"), _
CategoryAttribute("Metadata Settings")>
Public Property WordMetadata As WordMetadataSettings
C#
[DescriptionAttribute("Set of options related to Word metadata.")]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[DisplayNameAttribute("Word Metadata")]
[CategoryAttribute("Metadata Settings")]
public WordMetadataSettings WordMetadata { get; set; }
C++
[DescriptionAttribute(L"Set of options related to Word metadata.")]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[DisplayNameAttribute(L"Word Metadata")]
[CategoryAttribute(L"Metadata Settings")]
public property WordMetadataSettings WordMetadata sealed {
WordMetadataSettings get();
void set(WordMetadataSettings value);
}
J#
/** @attribute DescriptionAttribute("Set of options related to Word metadata.") */
/** @attribute TypeConverterAttribute(typeof(ExpandableObjectConverter)) */
/** @attribute DisplayNameAttribute("Word Metadata") */
/** @attribute CategoryAttribute("Metadata Settings") */
/** property */
public WordMetadataSettings get_WordMetadata();

/** property */
public void set_WordMetadata(WordMetadataSettings value);
JScript
public function get WordMetadata() : WordMetadataSettings

public function set WordMetadata(value : WordMetadataSettings);

See Also

APConfig Class
Altsoft.Publisher Namespace


XPSOutput Property

APConfig.XPSOutput Property
[image]

XPS output settings.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Output Settings"), _
TypeConverterAttribute(GetType(ExpandableObjectConverter)), _
DisplayNameAttribute("XPS Output"), _
DescriptionAttribute("XPS output settings.")>
Public Property XPSOutput As XPSOutputSettings
C#
[CategoryAttribute("Output Settings")]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[DisplayNameAttribute("XPS Output")]
[DescriptionAttribute("XPS output settings.")]
public XPSOutputSettings XPSOutput { get; set; }
C++
[CategoryAttribute(L"Output Settings")]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[DisplayNameAttribute(L"XPS Output")]
[DescriptionAttribute(L"XPS output settings.")]
public property XPSOutputSettings XPSOutput sealed {
XPSOutputSettings get();
void set(XPSOutputSettings value);
}
J#
/** @attribute CategoryAttribute("Output Settings") */
/** @attribute TypeConverterAttribute(typeof(ExpandableObjectConverter)) */
/** @attribute DisplayNameAttribute("XPS Output") */
/** @attribute DescriptionAttribute("XPS output settings.") */
/** property */
public XPSOutputSettings get_XPSOutput();

/** property */
public void set_XPSOutput(XPSOutputSettings value);
JScript
public function get XPSOutput() : XPSOutputSettings

public function set XPSOutput(value : XPSOutputSettings);

See Also

APConfig Class
Altsoft.Publisher Namespace


Methods

APConfig Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (inherited from ConfigurationElement)
Public method | LoadXml | Overloaded. Loads configuration settings from the given xml source.
Public method | SaveXml | Overloaded. Saves the current configuration settings to the file with the given path.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DeserializeElement | Overridden.
Family method | DeserializeSection | Overridden.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetRuntimeObject | Overridden.
Family method | Init | Sets the ConfigurationElement object to its initial state. (inherited from ConfigurationElement)
Family method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (inherited from ConfigurationElement)
Family method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded when implemented in a derived class. (inherited from ConfigurationSection)
Family method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (inherited from ConfigurationElement)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (inherited from ConfigurationElement)
Family method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (inherited from ConfigurationElement)
Family method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (inherited from ConfigurationElement)
Family method | PostDeserialize | Called after deserialization. (inherited from ConfigurationElement)
Family method | PreSerialize | Called before serialization. (inherited from ConfigurationElement)
Family method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (inherited from ConfigurationElement)
Family method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (inherited from ConfigurationSection)
Family method | SerializeElement | Overridden.
Family method | SerializeSection | Overridden.
Family method | SerializeToXmlElement | Overridden.
Family method | SetPropertyValue | Sets a property to the specified value. (inherited from ConfigurationElement)
Family method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (inherited from ConfigurationElement)
Family method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (inherited from ConfigurationElement)
Top

See Also

APConfig Class
Altsoft.Publisher Namespace


DeserializeElement Method

APConfig.DeserializeElement Method
[image]

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DeserializeElement( _
ByVal reader As XmlReader, _
ByVal serializeCollectionKey As Boolean _
)
C#
protected override void DeserializeElement(
XmlReader reader,
bool serializeCollectionKey
)
C++
protected:
virtual void DeserializeElement(
XmlReader reader,
bool serializeCollectionKey
) override
J#
protected override void DeserializeElement(
XmlReader reader,
bool serializeCollectionKey
)
JScript
protected override function DeserializeElement(
reader : XmlReader,
serializeCollectionKey : bool
)

See Also

APConfig Class
Altsoft.Publisher Namespace


DeserializeSection Method

APConfig.DeserializeSection Method
[image]

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DeserializeSection( _
ByVal reader As XmlReader _
)
C#
protected override void DeserializeSection(
XmlReader reader
)
C++
protected:
virtual void DeserializeSection(
XmlReader reader
) override
J#
protected override void DeserializeSection(
XmlReader reader
)
JScript
protected override function DeserializeSection(
reader : XmlReader
)

See Also

APConfig Class
Altsoft.Publisher Namespace


GetRuntimeObject Method

APConfig.GetRuntimeObject Method
[image]

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetRuntimeObject() As Object
C#
protected override object GetRuntimeObject()
C++
protected:
virtual Object GetRuntimeObject() override
J#
protected override object GetRuntimeObject()
JScript
protected override function GetRuntimeObject() : Object

See Also

APConfig Class
Altsoft.Publisher Namespace


LoadXml Method

APConfig.LoadXml Method

Loads configuration settings from the given xml source.

Overload List

 | Name | Description
Public method | LoadXml (XmlReader) | Loads configuration settings from the given xml source.
Public method | LoadXml (XmlReader, APLog, Double) | Loads configuration settings from the given xml source.

See Also

APConfig Class
Altsoft.Publisher Namespace


LoadXml Method (XmlReader)

APConfig.LoadXml Method (XmlReader)
See Also Example
[image]

Loads configuration settings from the given xml source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub LoadXml( _
ByVal xml As XmlReader _
)
C#
public void LoadXml(
XmlReader xml
)
C++
public:
void LoadXml(
XmlReader xml
) sealed
J#
public void LoadXml(
XmlReader xml
)
JScript
public function LoadXml(
xml : XmlReader
)

Parameters

xml
Xml source reader.

See Also

APConfig Class
Altsoft.Publisher Namespace
APConfig.LoadXml Overload List


LoadXml Method (XmlReader, APLog, Double)

APConfig.LoadXml Method (XmlReader, APLog, Double)
See Also Example
[image]

Loads configuration settings from the given xml source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub LoadXml( _
ByVal xml As XmlReader, _
ByVal log As APLog, _
ByVal weight As Double _
)
C#
public void LoadXml(
XmlReader xml,
APLog log,
double weight
)
C++
public:
void LoadXml(
XmlReader xml,
APLog log,
double weight
) sealed
J#
public void LoadXml(
XmlReader xml,
APLog log,
double weight
)
JScript
public function LoadXml(
xml : XmlReader,
log : APLog,
weight : double
)

Parameters

xml
Xml source reader.
log
Operation log.
weight
Weight of the 'LoadXml' operation within the current log stage.

See Also

APConfig Class
Altsoft.Publisher Namespace
APConfig.LoadXml Overload List


SaveXml Method

APConfig.SaveXml Method

Saves the current configuration settings to the file with the given path.

Overload List

 | Name | Description
Public method | SaveXml (String, Boolean) | Saves the current configuration settings to the file with the given path.
Public method | SaveXml (XmlWriter, Boolean) | Saves the current configuration settings to the given xml writer.

See Also

APConfig Class
Altsoft.Publisher Namespace


SaveXml Method (String, Boolean)

APConfig.SaveXml Method (String, Boolean)
See Also Example
[image]

Saves the current configuration settings to the file with the given path.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveXml( _
ByVal path As String, _
ByVal fullMode As Boolean _
)
C#
public void SaveXml(
string path,
bool fullMode
)
C++
public:
void SaveXml(
String path,
bool fullMode
) sealed
J#
public void SaveXml(
string path,
bool fullMode
)
JScript
public function SaveXml(
path : String,
fullMode : bool
)

Parameters

path
Path to the output file.
fullMode
Indicates whether to save all the settings or those that are not default.

See Also

APConfig Class
Altsoft.Publisher Namespace
APConfig.SaveXml Overload List


SaveXml Method (XmlWriter, Boolean)

APConfig.SaveXml Method (XmlWriter, Boolean)
See Also Example
[image]

Saves the current configuration settings to the given xml writer.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveXml( _
ByVal xml As XmlWriter, _
ByVal fullMode As Boolean _
)
C#
public void SaveXml(
XmlWriter xml,
bool fullMode
)
C++
public:
void SaveXml(
XmlWriter xml,
bool fullMode
) sealed
J#
public void SaveXml(
XmlWriter xml,
bool fullMode
)
JScript
public function SaveXml(
xml : XmlWriter,
fullMode : bool
)

Parameters

xml
Xml output writer.
fullMode
Indicates whether to save all the settings or those that are not default.

See Also

APConfig Class
Altsoft.Publisher Namespace
APConfig.SaveXml Overload List


SerializeElement Method

APConfig.SerializeElement Method
[image]

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function SerializeElement( _
ByVal writer As XmlWriter, _
ByVal serializeCollectionKey As Boolean _
) As Boolean
C#
protected override bool SerializeElement(
XmlWriter writer,
bool serializeCollectionKey
)
C++
protected:
virtual bool SerializeElement(
XmlWriter writer,
bool serializeCollectionKey
) override
J#
protected override bool SerializeElement(
XmlWriter writer,
bool serializeCollectionKey
)
JScript
protected override function SerializeElement(
writer : XmlWriter,
serializeCollectionKey : bool
) : bool

See Also

APConfig Class
Altsoft.Publisher Namespace


SerializeSection Method

APConfig.SerializeSection Method
[image]

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function SerializeSection( _
ByVal parentElement As ConfigurationElement, _
ByVal name As String, _
ByVal saveMode As ConfigurationSaveMode _
) As String
C#
protected override string SerializeSection(
ConfigurationElement parentElement,
string name,
ConfigurationSaveMode saveMode
)
C++
protected:
virtual String SerializeSection(
ConfigurationElement parentElement,
String name,
ConfigurationSaveMode saveMode
) override
J#
protected override string SerializeSection(
ConfigurationElement parentElement,
string name,
ConfigurationSaveMode saveMode
)
JScript
protected override function SerializeSection(
parentElement : ConfigurationElement,
name : String,
saveMode : ConfigurationSaveMode
) : String

See Also

APConfig Class
Altsoft.Publisher Namespace


SerializeToXmlElement Method

APConfig.SerializeToXmlElement Method
[image]

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function SerializeToXmlElement( _
ByVal writer As XmlWriter, _
ByVal elementName As String _
) As Boolean
C#
protected override bool SerializeToXmlElement(
XmlWriter writer,
string elementName
)
C++
protected:
virtual bool SerializeToXmlElement(
XmlWriter writer,
String elementName
) override
J#
protected override bool SerializeToXmlElement(
XmlWriter writer,
string elementName
)
JScript
protected override function SerializeToXmlElement(
writer : XmlWriter,
elementName : String
) : bool

See Also

APConfig Class
Altsoft.Publisher Namespace


APDestination Class

APDestination Class
See Also Example Members
[image]

Output document.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual), _
GuidAttribute("940DF1C9-22CE-452d-BDBC-808140CA8232")>
Public Class APDestination
Implements IDisposable
C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("940DF1C9-22CE-452d-BDBC-808140CA8232")]
public class APDestination : IDisposable
C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"940DF1C9-22CE-452d-BDBC-808140CA8232")]
ref class APDestination : IDisposable
J#
/** @attribute ClassInterfaceAttribute(ClassInterfaceType.AutoDual) */
/** @attribute GuidAttribute("940DF1C9-22CE-452d-BDBC-808140CA8232") */
public class APDestination implements IDisposable
JScript
public
ClassInterfaceAttribute(ClassInterfaceType.AutoDual)
GuidAttribute("940DF1C9-22CE-452d-BDBC-808140CA8232")
class APDestination extends IDisposable

Remarks

There are three main types of Xml2PDF destinations.

Simple destinations.

To get simple destination you should call CreateDestination or CreateDestination factory method.

Typed destinations.

To get typed destination you should call CreateDestination or CreateDestination factory method.

Fast destinations.

To get fast destination you should call CreateFastDestination or CreateFastDestination factory method.

Inheritance Hierarchy

System.Object
Altsoft.Publisher.APDestination

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APDestination Members
Altsoft.Publisher Namespace
APEngine


APDestination Members

APDestination Members
See Also Example Properties Methods
[image]

Output document.

The following tables list the members exposed by APDestination.

Public Properties

 | Name | Description
Public property | PageCount | Current count of pages in the output document.
Top

Public Methods

 | Name | Description
Public method | AddBackground | Adds the given source document as background for the current output document.
Public method | Append | Overloaded. Appends the given source document to the end of the current output document.
Public method | Close | Closes the current output document.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GdiPrint |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPageBBox | Gets bounding box for a page with given page-number.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Save | Overloaded. Saves the current output document with the given output format to the given output stream.
Public method | SaveGDIPage | Saves specified page in a given graphics object with the given bounding box
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

APDestination Class
Altsoft.Publisher Namespace
APEngine


Properties

APDestination Properties
[image]

Public Properties

 | Name | Description
Public property | PageCount | Current count of pages in the output document.
Top

See Also

APDestination Class
Altsoft.Publisher Namespace
APEngine


PageCount Property

APDestination.PageCount Property
[image]

Current count of pages in the output document.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageCount As Integer
C#
public int PageCount { get; }
C++
public property int PageCount sealed {
int get();
}
J#
/** property */
public int get_PageCount();
JScript
public function get PageCount() : int

See Also

APDestination Class
Altsoft.Publisher Namespace


Methods

APDestination Methods
[image]

Public Methods

 | Name | Description
Public method | AddBackground | Adds the given source document as background for the current output document.
Public method | Append | Overloaded. Appends the given source document to the end of the current output document.
Public method | Close | Closes the current output document.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GdiPrint |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPageBBox | Gets bounding box for a page with given page-number.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Save | Overloaded. Saves the current output document with the given output format to the given output stream.
Public method | SaveGDIPage | Saves specified page in a given graphics object with the given bounding box
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

APDestination Class
Altsoft.Publisher Namespace
APEngine


AddBackground Method

APDestination.AddBackground Method
[image]

Adds the given source document as background for the current output document.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function AddBackground( _
ByVal source As APSource, _
ByVal fromPage As Integer, _
ByVal toPage As Integer, _
ByVal useOnlyFirstPage As Boolean, _
ByVal zIndex As Double _
) As APLog
C#
public APLog AddBackground(
APSource source,
int fromPage,
int toPage,
bool useOnlyFirstPage,
double zIndex
)
C++
public:
APLog AddBackground(
APSource source,
int fromPage,
int toPage,
bool useOnlyFirstPage,
double zIndex
) sealed
J#
public APLog AddBackground(
APSource source,
int fromPage,
int toPage,
bool useOnlyFirstPage,
double zIndex
)
JScript
public function AddBackground(
source : APSource,
fromPage : int,
toPage : int,
useOnlyFirstPage : bool,
zIndex : double
) : APLog

Parameters

source
Source document to be used as the background.
fromPage
Number of the first page in range where the background is to be set.
toPage
Number of the last page in range where the background is to be set.
useOnlyFirstPage
Specifies whether to use only first source page or the whole source document as the background.
zIndex
Z-index for the background.

Return Value

Operation log.

See Also

APDestination Class
Altsoft.Publisher Namespace


Append Method

APDestination.Append Method

Appends the given source document to the end of the current output document.

Overload List

 | Name | Description
Public method | Append (APSource) | Appends the given source document to the end of the current output document.
Public method | Append (APSource, APLog, Double) | Appends the given source document to the end of the current output document.

See Also

APDestination Class
Altsoft.Publisher Namespace


Append Method (APSource)

APDestination.Append Method (APSource)
See Also Example
[image]

Appends the given source document to the end of the current output document.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Append( _
ByVal source As APSource _
) As APLog
C#
public APLog Append(
APSource source
)
C++
public:
APLog Append(
APSource source
) sealed
J#
public APLog Append(
APSource source
)
JScript
public function Append(
source : APSource
) : APLog

Parameters

source
Source document.

Return Value

Operation log.

See Also

APDestination Class
Altsoft.Publisher Namespace
APDestination.Append Overload List


Append Method (APSource, APLog, Double)

APDestination.Append Method (APSource, APLog, Double)
See Also Example
[image]

Appends the given source document to the end of the current output document.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Append( _
ByVal source As APSource, _
ByVal log As APLog, _
ByVal weight As Double _
)
C#
public void Append(
APSource source,
APLog log,
double weight
)
C++
public:
void Append(
APSource source,
APLog log,
double weight
) sealed
J#
public void Append(
APSource source,
APLog log,
double weight
)
JScript
public function Append(
source : APSource,
log : APLog,
weight : double
)

Parameters

source
Source document.
log
Operation log.
weight
Weight of the 'Append' operation in the current log stage.

See Also

APDestination Class
Altsoft.Publisher Namespace
APDestination.Append Overload List


Close Method

APDestination.Close Method
[image]

Closes the current output document.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Close()
C#
public void Close()
C++
public:
void Close() sealed
J#
public void Close()
JScript
public function Close()

See Also

APDestination Class
Altsoft.Publisher Namespace


GdiPrint Method

APDestination.GdiPrint Method
[image]

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GdiPrint( _
ByVal printDoc As PrintDocument _
) As APLog
C#
public APLog GdiPrint(
PrintDocument printDoc
)
C++
public:
APLog GdiPrint(
PrintDocument printDoc
) sealed
J#
public APLog GdiPrint(
PrintDocument printDoc
)
JScript
public function GdiPrint(
printDoc : PrintDocument
) : APLog

See Also

APDestination Class
Altsoft.Publisher Namespace


GetPageBBox Method

APDestination.GetPageBBox Method
[image]

Gets bounding box for a page with given page-number.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPageBBox( _
ByVal pageNr As Integer _
) As RectangleF
C#
public RectangleF GetPageBBox(
int pageNr
)
C++
public:
RectangleF GetPageBBox(
int pageNr
) sealed
J#
public RectangleF GetPageBBox(
int pageNr
)
JScript
public function GetPageBBox(
pageNr : int
) : RectangleF

Parameters

pageNr
Zero-based page number.

Return Value

Bounding box for specified page.

See Also

APDestination Class
Altsoft.Publisher Namespace


Save Method

APDestination.Save Method

Saves the current output document with the given output format to the given output stream.

Overload List

 | Name | Description
Public method | Save (APDestinationFormat, Stream, APLog, Double) | Saves the current output document with the given output format to the given output stream.
Public method | Save (APDestinationFormat, String) | Saves the current output document with the given output format to the given file.
Public method | Save (APDestinationFormat, String, APLog, Double) | Saves the current output document with the given output format to the given file.

See Also

APDestination Class
Altsoft.Publisher Namespace


Save Method (APDestinationFormat, Stream, APLog, Double)

APDestination.Save Method (APDestinationFormat, Stream, APLog, Double)
See Also Example
[image]

Saves the current output document with the given output format to the given output stream.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Save( _
ByVal destFormat As APDestinationFormat, _
ByVal stream As Stream, _
ByVal log As APLog, _
ByVal weight As Double _
)
C#
public void Save(
APDestinationFormat destFormat,
Stream stream,
APLog log,
double weight
)
C++
public:
void Save(
APDestinationFormat destFormat,
Stream stream,
APLog log,
double weight
) sealed
J#
public void Save(
APDestinationFormat destFormat,
Stream stream,
APLog log,
double weight
)
JScript
public function Save(
destFormat : APDestinationFormat,
stream : Stream,
log : APLog,
weight : double
)

Parameters

destFormat
Ouput format.
stream
Output stream.
log
Operation log.
weight
The weight of the 'Save' operation in current log stage.

See Also

APDestination Class
Altsoft.Publisher Namespace
APDestination.Save Overload List


Save Method (APDestinationFormat, String)

APDestination.Save Method (APDestinationFormat, String)
See Also Example
[image]

Saves the current output document with the given output format to the given file.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Save( _
ByVal destFormat As APDestinationFormat, _
ByVal path As String _
) As APLog
C#
public APLog Save(
APDestinationFormat destFormat,
string path
)
C++
public:
APLog Save(
APDestinationFormat destFormat,
String path
) sealed
J#
public APLog Save(
APDestinationFormat destFormat,
string path
)
JScript
public function Save(
destFormat : APDestinationFormat,
path : String
) : APLog

Parameters

destFormat
Ouput format.
path
Path to the output file.

Return Value

Operation log.

See Also

APDestination Class
Altsoft.Publisher Namespace
APDestination.Save Overload List


Save Method (APDestinationFormat, String, APLog, Double)

APDestination.Save Method (APDestinationFormat, String, APLog, Double)
See Also Example
[image]

Saves the current output document with the given output format to the given file.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Save( _
ByVal destFormat As APDestinationFormat, _
ByVal path As String, _
ByVal log As APLog, _
ByVal weight As Double _
)
C#
public void Save(
APDestinationFormat destFormat,
string path,
APLog log,
double weight
)
C++
public:
void Save(
APDestinationFormat destFormat,
String path,
APLog log,
double weight
) sealed
J#
public void Save(
APDestinationFormat destFormat,
string path,
APLog log,
double weight
)
JScript
public function Save(
destFormat : APDestinationFormat,
path : String,
log : APLog,
weight : double
)

Parameters

destFormat
Ouput format.
path
Path to the output file.
log
Operation log.
weight
The weight of the 'Save' operation in current log stage.

See Also

APDestination Class
Altsoft.Publisher Namespace
APDestination.Save Overload List


SaveGDIPage Method

APDestination.SaveGDIPage Method
[image]

Saves specified page in a given graphics object with the given bounding box

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveGDIPage( _
ByVal pageNumber As Integer, _
ByVal graphics As Graphics, _
ByVal boundingBox As RectangleF _
)
C#
public void SaveGDIPage(
int pageNumber,
Graphics graphics,
RectangleF boundingBox
)
C++
public:
void SaveGDIPage(
int pageNumber,
Graphics graphics,
RectangleF boundingBox
) sealed
J#
public void SaveGDIPage(
int pageNumber,
Graphics graphics,
RectangleF boundingBox
)
JScript
public function SaveGDIPage(
pageNumber : int,
graphics : Graphics,
boundingBox : RectangleF
)

Parameters

pageNumber
Number of the page to save
graphics
Graphics object to save page to
boundingBox
Bounding box of the page being saved

See Also

APDestination Class
Altsoft.Publisher Namespace


APDestinationFormat Enumeration

APDestinationFormat Enumeration
[image]

Available destination formats.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enum APDestinationFormat
C#
public enum APDestinationFormat
C++
public enum class APDestinationFormat
J#
public enum APDestinationFormat
JScript
public enum APDestinationFormat

Members

Member Name | Description
PDF | Portable Document Format document.
XPS | XML Paper Specification document.
PS | PostScript document.
SVG | Scalable Vector Graphics format.
ALT | Altsoft Vector Graphics format.
XAML | XAML format.
GDIPlus | Obsolete. This element is obsolete. Only for compatibility with Xml2PDF 2007 GDI+ format.
BMP | BMP raster image format.
EMF | EMF image format.
GIF | GIF raster image format.
JPEG | JPEG raster image format.
PNG | PNG raster image format.
TIFF | TIFF raster image format.

See Also

Altsoft.Publisher Namespace


APEngine Class

APEngine Class
See Also Example Members
[image]

Facade class for Altsoft Xml2PDF functionality. This class cannot be inherited.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<GuidAttribute("54C0D56B-CF1A-423e-9E34-62F595461588"), _
ClassInterfaceAttribute(ClassInterfaceType.AutoDual)>
Public NotInheritable Class APEngine
Implements IDisposable
C#
[GuidAttribute("54C0D56B-CF1A-423e-9E34-62F595461588")]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
public sealed class APEngine : IDisposable
C++
[GuidAttribute(L"54C0D56B-CF1A-423e-9E34-62F595461588")]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
ref class APEngine sealed : IDisposable
J#
/** @attribute GuidAttribute("54C0D56B-CF1A-423e-9E34-62F595461588") */
/** @attribute ClassInterfaceAttribute(ClassInterfaceType.AutoDual) */
public final class APEngine implements IDisposable
JScript
public
GuidAttribute("54C0D56B-CF1A-423e-9E34-62F595461588")
ClassInterfaceAttribute(ClassInterfaceType.AutoDual)
final class APEngine extends IDisposable

Remarks

The APEngine is the root class of the Xml2PDF Server. It is used for storage of all the data required for formatting. All entire objects that are used in the Xml2PDF are created here. These are:

APConfig Set of options configuring a certain formatting call. It allows to set all general, input and output settings. All settings are grouped into classes (see Altsoft.Publisher.Configuration namespace). The APConfig is passed to the corresponding APDestination instance. It can't be shared between several APDestination instances.
APDestination

It is an output document. All APDestination instances can have one of the following types:

  • simple destination
  • typed destination
  • fast destination

The APDestination allows you to save any of its pages as an image, print the whole document through the GDI+ PrintDocument interface and allows saving it to one of the output formats (see APDestinationFormat).

Simple destination is one that doesn't contain the information about saving. It allows you saving a document several times into different formats. But it can not use critical features of the output format conflicting with other formats.

For example, PDF output format allows using 14 Standard PDF Type1 fonts. This can significantly reduce the size of an output file, but other output formats can not reproduce this feature.

Typed destination contains the information about its output format. This allows using critical features described above, but forbids saving to other formats. It also prohibits printing the document and saving pages as images.

Fast destination is intended for huge documents. It works according to the page-by-page rule: as soon as the formatting of a page is finished it is immidiately saved to the output. The rest of the document including resources is saved in the end of formatting process. Using this type of destination you are to define all information about the output at the creation time. Directly saving method is not used. Instead you use Close method. Consequently, fast destination knows its output format and works the same as Typed destination.

APSource

It is an input document. You can use several input documents for one destination. The source documents can be merged consequently with Append method and its overrides. Source document can also be used as a background with AddBackground method.

For xml-based documents you can use XSLT transformations with ApplyXSLT method and its overrides.

The typical use of the Xml2PDF Server contains several stages. You should do the following:

Copy Code
    Copy Code

             // create engine instance
             APEngine engine = new APEngine();

             // initialize engine with serial-key
             // you should use empty string for evaluation
             const string serialKey = "";
             engine.Load(serialKey);

             // create config
             APConfig config = engine.CreateConfig();

             // set config options
             config.Fonts.DefaultFont = "Arial";
             config.Output.DPI = 300;

             // create destination
             APDestination dest = engine.CreateDestination(config);
             // use CreateFastDestination() for fast destinations
             // APDestination dest = engine.CreateFastDestination(APDestinationFormat.PDF,
             //                                         "output.pdf", new APLog(), config);

             // create one or several sources and put it to the destination
             APSource srcFO = engine.CreateSourceFO("in1.fo");
             dest.Append(srcFO);

             APSource srcDoc = engine.CreateSourceWordDoc("in2.doc");
             dest.Append(srcDoc);

             // perform output actions with the destination
             dest.Save(APDestinationFormat.PDF, "output.pdf");
             // call Close() for fast destinations
             // dest.Close();

    Copy Code

             ' create engine instance
             Dim engine As APEngine = New APEngine

             ' initialize engine with serial-key
             ' you should use empty string for evaluation
             Const serialKey As String = ""
             engine.Load(serialKey)

             ' create config
             Dim config As APConfig = engine.CreateConfig()

             ' set config options
             config.Fonts.DefaultFont = "Arial"
             config.Output.DPI = 300

             ' create destination
             Dim dest As APDestination = engine.CreateDestination(config)
             ' use CreateFastDestination() for fast destinations
             ' Dim dest As APDestination = engine.CreateFastDestination(APDestinationFormat.PDF,
             '                                                "output.pdf", New APLog(), config)

             ' create one or several sources and put it to the destination
             Dim srcFO as APSource = engine.CreateSourceFO("in1.fo")
             dest.Append(srcFO)

             Dim srcDoc as APSource = engine.CreateSourceWordDoc("in2.doc")
             dest.Append(srcDoc)

             ' perform output actions with the destination
             dest.Save(APDestinationFormat.PDF, "output.pdf")
             ' call Close() for fast destinations
             ' dest.Close()

Inheritance Hierarchy

System.Object
Altsoft.Publisher.APEngine

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APEngine Members
Altsoft.Publisher Namespace


APEngine Members

APEngine Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Facade class for Altsoft Xml2PDF functionality. This class cannot be inherited.

The following tables list the members exposed by APEngine.

Public Constructors

Name | Description
APEngine | Overloaded.
Top

Public Properties

 | Name | Description
 | Engine | Gets the default Xml2PDF engine.
Public property | Expires | Gets the evaluation expiration date.
Public property | ProductEdition | Gets the current product edition.
Top

Public Methods

 | Name | Description
Public method | CreateConfig | Overloaded. Creates a new APConfig instance with the application default settings.
Public method | CreateDestination | Overloaded. Creates a new output document instance with the default settings.
Public method | CreateFastDestination | Overloaded. Creates a document optimized for huge input documents.
Public method | CreateSource | Overloaded. Creates a new APSource instance.
Public method | CreateSourceFO | Overloaded. Creates a new FO source.
Public method | CreateSourceSVG | Overloaded. Creates a new SVG source.
Public method | CreateSourceSVGZ | Overloaded. Creates a new SVGZ source.
Public method | CreateSourceWord2003Xml | Overloaded. Creates a new Word2003Xml source.
Public method | CreateSourceWordDoc | Overloaded. Creates a new WordDoc source.
Public method | CreateSourceWordDocX | Overloaded. Creates a new WordDocX source.
Public method | CreateSourceWordXml | Overloaded. Creates a new WordXml source.
Public method | CreateSourceXHTML | Overloaded. Creates a new XHTML source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Load | Overloaded. Initializes the Altsoft Xml2PDF library core. Used only in evaluation version.
Public method | LoadAppDefaults | Loads the application default settings from the configuration section with the given name.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Unload | Overloaded. Performs a clean-up of the resources used by the Altsoft Xml2PDF engine.
Top

Explicit Interface Implementations

Name | Description
APEngine | Overloaded.
Top

See Also

APEngine Class
Altsoft.Publisher Namespace


APEngine Constructor

APEngine Constructor

Overload List

 | Name | Description
Public method | APEngine | Creates a new instance of the thread-safe APEngine class.
Public method | APEngine (Boolean) | Creates a new instance of the APEngine class.
Public method | APEngine (Boolean, String) |
Public method | APEngine (Boolean, String, APFileSystem) |

See Also

APEngine Class
Altsoft.Publisher Namespace


APEngine Constructor ()

APEngine Constructor ()
See Also Example
[image]

Creates a new instance of the thread-safe APEngine class.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APEngine()
C++
public:
APEngine() sealed
J#
public APEngine()
JScript
public function APEngine()

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine Constructor Overload List


APEngine Constructor (Boolean)

APEngine Constructor (Boolean)
See Also Example
[image]

Creates a new instance of the APEngine class.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal synchronized As Boolean _
)
C#
public APEngine(
bool synchronized
)
C++
public:
APEngine(
bool synchronized
) sealed
J#
public APEngine(
bool synchronized
)
JScript
public function APEngine(
synchronized : bool
)

Parameters

synchronized
Indicates whether new Xml2PDF core should be thread-safe.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine Constructor Overload List


APEngine Constructor (Boolean, String[])

APEngine Constructor (Boolean, String[])
See Also Example
[image]

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal synchronized As Boolean, _
ByVal fontFolders As String() _
)
C#
public APEngine(
bool synchronized,
string[] fontFolders
)
C++
public:
APEngine(
bool synchronized,
array<String>^ fontFolders
) sealed
J#
public APEngine(
bool synchronized,
string[] fontFolders
)
JScript
public function APEngine(
synchronized : bool,
fontFolders : String[]
)

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine Constructor Overload List


APEngine Constructor (Boolean, String[], APFileSystem)

APEngine Constructor (Boolean, String[], APFileSystem)
See Also Example
[image]

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal synchronized As Boolean, _
ByVal fontFolders As String(), _
ByVal fileSystem As APFileSystem _
)
C#
public APEngine(
bool synchronized,
string[] fontFolders,
APFileSystem fileSystem
)
C++
public:
APEngine(
bool synchronized,
array<String>^ fontFolders,
APFileSystem fileSystem
) sealed
J#
public APEngine(
bool synchronized,
string[] fontFolders,
APFileSystem fileSystem
)
JScript
public function APEngine(
synchronized : bool,
fontFolders : String[],
fileSystem : APFileSystem
)

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine Constructor Overload List


Properties

APEngine Properties
[image]

Public Properties

 | Name | Description
 | Engine | Gets the default Xml2PDF engine.
Public property | Expires | Gets the evaluation expiration date.
Public property | ProductEdition | Gets the current product edition.
Top

See Also

APEngine Class
Altsoft.Publisher Namespace


Engine Property

APEngine.Engine Property
[image]

Gets the default Xml2PDF engine.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Engine As APEngine
C#
public static APEngine Engine { get; }
C++
public static property APEngine Engine {
APEngine get();
}
J#
/** property */
public APEngine get_Engine();
JScript
public function get Engine() : APEngine

See Also

APEngine Class
Altsoft.Publisher Namespace


Expires Property

APEngine.Expires Property
[image]

Gets the evaluation expiration date.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Expires As Date
C#
public DateTime Expires { get; }
C++
public property DateTime Expires sealed {
DateTime get();
}
J#
/** property */
public DateTime get_Expires();
JScript
public function get Expires() : DateTime

Remarks

If the DateTime returned by this property is less than Now - evaluation period is expired.

If the DateTime returned by this property equals to MaxValue - evaluation never expires.

See Also

APEngine Class
Altsoft.Publisher Namespace


ProductEdition Property

APEngine.ProductEdition Property
[image]

Gets the current product edition.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductEdition As String
C#
public string ProductEdition { get; }
C++
public property string ProductEdition sealed {
String get();
}
J#
/** property */
public string get_ProductEdition();
JScript
public function get ProductEdition() : String

Remarks

There are the following possible values:

  • Evaluation
  • Enterprise
  • Professional
  • Standard
  • Light

See Also

APEngine Class
Altsoft.Publisher Namespace


Methods

APEngine Methods
[image]

Public Methods

 | Name | Description
Public method | CreateConfig | Overloaded. Creates a new APConfig instance with the application default settings.
Public method | CreateDestination | Overloaded. Creates a new output document instance with the default settings.
Public method | CreateFastDestination | Overloaded. Creates a document optimized for huge input documents.
Public method | CreateSource | Overloaded. Creates a new APSource instance.
Public method | CreateSourceFO | Overloaded. Creates a new FO source.
Public method | CreateSourceSVG | Overloaded. Creates a new SVG source.
Public method | CreateSourceSVGZ | Overloaded. Creates a new SVGZ source.
Public method | CreateSourceWord2003Xml | Overloaded. Creates a new Word2003Xml source.
Public method | CreateSourceWordDoc | Overloaded. Creates a new WordDoc source.
Public method | CreateSourceWordDocX | Overloaded. Creates a new WordDocX source.
Public method | CreateSourceWordXml | Overloaded. Creates a new WordXml source.
Public method | CreateSourceXHTML | Overloaded. Creates a new XHTML source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Load | Overloaded. Initializes the Altsoft Xml2PDF library core. Used only in evaluation version.
Public method | LoadAppDefaults | Loads the application default settings from the configuration section with the given name.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Unload | Overloaded. Performs a clean-up of the resources used by the Altsoft Xml2PDF engine.
Top

See Also

APEngine Class
Altsoft.Publisher Namespace


CreateConfig Method

APEngine.CreateConfig Method

Creates a new APConfig instance with the application default settings.

Overload List

 | Name | Description
Public method | CreateConfig | Creates a new APConfig instance with the application default settings.
Public method | CreateConfig (Stream) | Creates a new APConfig instance using settings stored in the given stream.
Public method | CreateConfig (String) | Creates a new APConfig instance using settings stored in the given file.
Public method | CreateConfig (XmlReader) | Creates a new APConfig instance using settings stored in the xml source.

See Also

APEngine Class
Altsoft.Publisher Namespace


CreateConfig Method ()

APEngine.CreateConfig Method ()
See Also Example
[image]

Creates a new APConfig instance with the application default settings.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateConfig() As APConfig
C#
public APConfig CreateConfig()
C++
public:
APConfig CreateConfig() sealed
J#
public APConfig CreateConfig()
JScript
public function CreateConfig() : APConfig

Return Value

A new instance of APConfig.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateConfig Overload List


CreateConfig Method (Stream)

APEngine.CreateConfig Method (Stream)
See Also Example
[image]

Creates a new APConfig instance using settings stored in the given stream.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateConfig( _
ByVal stream As Stream _
) As APConfig
C#
public APConfig CreateConfig(
Stream stream
)
C++
public:
APConfig CreateConfig(
Stream stream
) sealed
J#
public APConfig CreateConfig(
Stream stream
)
JScript
public function CreateConfig(
stream : Stream
) : APConfig

Parameters

stream
A configuration stream.

Return Value

A new instance of APConfig.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateConfig Overload List


CreateConfig Method (String)

APEngine.CreateConfig Method (String)
See Also Example
[image]

Creates a new APConfig instance using settings stored in the given file.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateConfig( _
ByVal path As String _
) As APConfig
C#
public APConfig CreateConfig(
string path
)
C++
public:
APConfig CreateConfig(
String path
) sealed
J#
public APConfig CreateConfig(
string path
)
JScript
public function CreateConfig(
path : String
) : APConfig

Parameters

path
A path to a configuration file.

Return Value

A new instance of APConfig.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateConfig Overload List


CreateConfig Method (XmlReader)

APEngine.CreateConfig Method (XmlReader)
See Also Example
[image]

Creates a new APConfig instance using settings stored in the xml source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateConfig( _
ByVal xml As XmlReader _
) As APConfig
C#
public APConfig CreateConfig(
XmlReader xml
)
C++
public:
APConfig CreateConfig(
XmlReader xml
) sealed
J#
public APConfig CreateConfig(
XmlReader xml
)
JScript
public function CreateConfig(
xml : XmlReader
) : APConfig

Parameters

xml
A configuration Xml reader.

Return Value

A new instance of APConfig.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateConfig Overload List


CreateDestination Method

APEngine.CreateDestination Method

Creates a new output document instance with the default settings.

Overload List

 | Name | Description
Public method | CreateDestination | Creates a new output document instance with the default settings.
Public method | CreateDestination (APConfig) | Creates a new output document instance with the given settings.
Public method | CreateDestination (APConfig, APDestinationFormat) | Creates a new output document instance with the given settings.
Public method | CreateDestination (APDestinationFormat) | Creates a new output document instance with the default settings.

See Also

APEngine Class
Altsoft.Publisher Namespace


CreateDestination Method ()

APEngine.CreateDestination Method ()
See Also Example
[image]

Creates a new output document instance with the default settings.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateDestination() As APDestination
C#
public APDestination CreateDestination()
C++
public:
APDestination CreateDestination() sealed
J#
public APDestination CreateDestination()
JScript
public function CreateDestination() : APDestination

Return Value

A new instance of APDestination.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateDestination Overload List


CreateDestination Method (APConfig)

APEngine.CreateDestination Method (APConfig)
See Also Example
[image]

Creates a new output document instance with the given settings.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateDestination( _
ByVal config As APConfig _
) As APDestination
C#
public APDestination CreateDestination(
APConfig config
)
C++
public:
APDestination CreateDestination(
APConfig config
) sealed
J#
public APDestination CreateDestination(
APConfig config
)
JScript
public function CreateDestination(
config : APConfig
) : APDestination

Parameters

config
Settings for a new output document.

Return Value

A new instance of APDestination.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateDestination Overload List


CreateDestination Method (APConfig, APDestinationFormat)

APEngine.CreateDestination Method (APConfig, APDestinationFormat)
See Also Example
[image]

Creates a new output document instance with the given settings.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateDestination( _
ByVal config As APConfig, _
ByVal format As APDestinationFormat _
) As APDestination
C#
public APDestination CreateDestination(
APConfig config,
APDestinationFormat format
)
C++
public:
APDestination CreateDestination(
APConfig config,
APDestinationFormat format
) sealed
J#
public APDestination CreateDestination(
APConfig config,
APDestinationFormat format
)
JScript
public function CreateDestination(
config : APConfig,
format : APDestinationFormat
) : APDestination

Parameters

config
Settings for a new output document.
format
Format of new destaination.

Return Value

A new instance of APDestination.

Remarks

Creates a new output document with the predefined output format. This forbids its saving to any other output formats. It also forbids calling the following methods:

  • GdiPrint
  • SaveGDIPage

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateDestination Overload List


CreateDestination Method (APDestinationFormat)

APEngine.CreateDestination Method (APDestinationFormat)
See Also Example
[image]

Creates a new output document instance with the default settings.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateDestination( _
ByVal format As APDestinationFormat _
) As APDestination
C#
public APDestination CreateDestination(
APDestinationFormat format
)
C++
public:
APDestination CreateDestination(
APDestinationFormat format
) sealed
J#
public APDestination CreateDestination(
APDestinationFormat format
)
JScript
public function CreateDestination(
format : APDestinationFormat
) : APDestination

Parameters

format
Format of new destination.

Return Value

A new instance of APDestination.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateDestination Overload List


CreateFastDestination Method

APEngine.CreateFastDestination Method

Creates a document optimized for huge input documents.

Overload List

 | Name | Description
Public method | CreateFastDestination (APDestinationFormat, Stream, Boolean, APLog, APConfig) | Creates a document optimized for huge input documents.
Public method | CreateFastDestination (APDestinationFormat, String, APLog, APConfig) | Creates a document optimized for huge input documents.

See Also

APEngine Class
Altsoft.Publisher Namespace


CreateFastDestination Method (APDestinationFormat, Stream, Boolean, APLog, APConfig)

APEngine.CreateFastDestination Method (APDestinationFormat, Stream, Boolean, APLog, APConfig)
See Also Example
[image]

Creates a document optimized for huge input documents.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateFastDestination( _
ByVal format As APDestinationFormat, _
ByVal stream As Stream, _
ByVal closeStream As Boolean, _
ByVal log As APLog, _
ByVal config As APConfig _
) As APDestination
C#
public APDestination CreateFastDestination(
APDestinationFormat format,
Stream stream,
bool closeStream,
APLog log,
APConfig config
)
C++
public:
APDestination CreateFastDestination(
APDestinationFormat format,
Stream stream,
bool closeStream,
APLog log,
APConfig config
) sealed
J#
public APDestination CreateFastDestination(
APDestinationFormat format,
Stream stream,
bool closeStream,
APLog log,
APConfig config
)
JScript
public function CreateFastDestination(
format : APDestinationFormat,
stream : Stream,
closeStream : bool,
log : APLog,
config : APConfig
) : APDestination

Parameters

format
Format of a new destination.
stream
Output stream for a new destination.
closeStream
Indicates whether to close stream after saving.
log
Operation log.
config
Settings for a new destination.

Return Value

A new instance of APDestination.

Remarks

The logic behind its work is document saving page-by-page. Thus you should define the output format and stream beforehand.

Example

Copy Code
             // Next example formats huge input fo file to fast PDF.
             using (APEngine engine = new APEngine())
             {
                 // initialize engine in evaluation mode
                 engine.Load("");

                 // create default config
                 APConfig config = engine.CreateConfig();
                 // create operation log for saving
                 APLog log = new APLog();

                 // create fast PDF destination
                 using(APDestination fastPDF = engine.CreateFastDestination(APDestinationFormat.PDF, "output.pdf", log, config))
                 {
                     // append source fo to target PDF
                     using(APSource hugeFO = engine.CreateSourceFO("input.fo"))
                         fastPDF.Append(hugeFO);

                     // finalize saving
                     fastPDF.Close();
                 }
             }

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateFastDestination Overload List


CreateFastDestination Method (APDestinationFormat, String, APLog, APConfig)

APEngine.CreateFastDestination Method (APDestinationFormat, String, APLog, APConfig)
See Also Example
[image]

Creates a document optimized for huge input documents.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateFastDestination( _
ByVal format As APDestinationFormat, _
ByVal outputPath As String, _
ByVal log As APLog, _
ByVal config As APConfig _
) As APDestination
C#
public APDestination CreateFastDestination(
APDestinationFormat format,
string outputPath,
APLog log,
APConfig config
)
C++
public:
APDestination CreateFastDestination(
APDestinationFormat format,
String outputPath,
APLog log,
APConfig config
) sealed
J#
public APDestination CreateFastDestination(
APDestinationFormat format,
string outputPath,
APLog log,
APConfig config
)
JScript
public function CreateFastDestination(
format : APDestinationFormat,
outputPath : String,
log : APLog,
config : APConfig
) : APDestination

Parameters

format
Format of a new destination.
outputPath
Output path for a new destination.
log
Operation log.
config
Settings for a new destination.

Return Value

A new instance of APDestination.

Remarks

The logic behind its work is document saving page-by-page. Thus you should define the output format and stream beforehand.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateFastDestination Overload List


CreateSource Method

APEngine.CreateSource Method

Creates a new APSource instance.

Overload List

 | Name | Description
Public method | CreateSource (Stream, Boolean) | Creates a new APSource instance.
Public method | CreateSource (Stream, String, APSourceFormat, Boolean) | Creates a new APSource instance.
Public method | CreateSource (String) | Creates a new APSource instance.
Public method | CreateSource (String, APSourceFormat) | Creates a new APSource instance.

See Also

APEngine Class
Altsoft.Publisher Namespace


CreateSource Method (Stream, Boolean)

APEngine.CreateSource Method (Stream, Boolean)
See Also Example
[image]

Creates a new APSource instance.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSource( _
ByVal stream As Stream, _
ByVal takesOwnership As Boolean _
) As APSource
C#
public APSource CreateSource(
Stream stream,
bool takesOwnership
)
C++
public:
APSource CreateSource(
Stream stream,
bool takesOwnership
) sealed
J#
public APSource CreateSource(
Stream stream,
bool takesOwnership
)
JScript
public function CreateSource(
stream : Stream,
takesOwnership : bool
) : APSource

Parameters

stream
Source document stream.
takesOwnership
Indicates whether the new source takes ownership of stream.

Return Value

APSource instance.

Exceptions

Exception Type | Condition
ObjectDisposedException | APEngine instance is disposed.
InvalidOperationException | APEngine instance is not loaded. -or- APEngine instance is not in running mode.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateSource Overload List


CreateSource Method (Stream, String, APSourceFormat, Boolean)

APEngine.CreateSource Method (Stream, String, APSourceFormat, Boolean)
See Also Example
[image]

Creates a new APSource instance.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSource( _
ByVal stream As Stream, _
ByVal baseURI As String, _
ByVal format As APSourceFormat, _
ByVal takesOwnership As Boolean _
) As APSource
C#
public APSource CreateSource(
Stream stream,
string baseURI,
APSourceFormat format,
bool takesOwnership
)
C++
public:
APSource CreateSource(
Stream stream,
String baseURI,
APSourceFormat format,
bool takesOwnership
) sealed
J#
public APSource CreateSource(
Stream stream,
string baseURI,
APSourceFormat format,
bool takesOwnership
)
JScript
public function CreateSource(
stream : Stream,
baseURI : String,
format : APSourceFormat,
takesOwnership : bool
) : APSource

Parameters

stream
Source document stream.
baseURI
Base URI for source document.
format
Source document format.
takesOwnership
Indicates whether the new source takes ownership of stream.

Return Value

APSource instance.

Exceptions

Exception Type | Condition
ObjectDisposedException | APEngine instance is disposed.
InvalidOperationException | APEngine instance is not loaded. -or- APEngine instance is not in running mode.
ArgumentException | format is invalid or unsupported by the current product version. -or- baseURI is not valid path or URI.
ArgumentNullException | stream is null. -or- baseURI is null.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateSource Overload List


CreateSource Method (String)

APEngine.CreateSource Method (String)
See Also Example
[image]

Creates a new APSource instance.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSource( _
ByVal uri As String _
) As APSource
C#
public APSource CreateSource(
string uri
)
C++
public:
APSource CreateSource(
String uri
) sealed
J#
public APSource CreateSource(
string uri
)
JScript
public function CreateSource(
uri : String
) : APSource

Parameters

uri
Path or URI to the source document.

Return Value

The new APSource instance.

Exceptions

Exception Type | Condition
ObjectDisposedException | APEngine instance is disposed.
InvalidOperationException | APEngine instance is not loaded. -or- APEngine instance is not in running mode.
APSourceException | Source uri can not be opened.
ArgumentException | uri is not the valid path or URI.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateSource Overload List


CreateSource Method (String, APSourceFormat)

APEngine.CreateSource Method (String, APSourceFormat)
See Also Example
[image]

Creates a new APSource instance.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSource( _
ByVal uri As String, _
ByVal format As APSourceFormat _
) As APSource
C#
public APSource CreateSource(
string uri,
APSourceFormat format
)
C++
public:
APSource CreateSource(
String uri,
APSourceFormat format
) sealed
J#
public APSource CreateSource(
string uri,
APSourceFormat format
)
JScript
public function CreateSource(
uri : String,
format : APSourceFormat
) : APSource

Parameters

uri
Path or URI to source document.
format
Source document format.

Return Value

The new APSource instance.

Exceptions

Exception Type | Condition
ObjectDisposedException | APEngine instance is disposed.
InvalidOperationException | APEngine instance is notAPEngine -or- APEngine instance is not in running mode.
APSourceException | Source uri can not be opened.
ArgumentException | format is invalid or unsupported by the current product version. -or- uri is not the valid path or URI.
ArgumentNullException | uri is null.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateSource Overload List


CreateSourceFO Method

APEngine.CreateSourceFO Method

Creates a new FO source.

Overload List

 | Name | Description
Public method | CreateSourceFO (Stream, String, Boolean) | Creates a new FO source.
Public method | CreateSourceFO (String) | Creates a new FO source.

See Also

APEngine Class
Altsoft.Publisher Namespace


CreateSourceFO Method (Stream, String, Boolean)

APEngine.CreateSourceFO Method (Stream, String, Boolean)
See Also Example
[image]

Creates a new FO source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSourceFO( _
ByVal stream As Stream, _
ByVal baseURI As String, _
ByVal takesOwnership As Boolean _
) As APSource
C#
public APSource CreateSourceFO(
Stream stream,
string baseURI,
bool takesOwnership
)
C++
public:
APSource CreateSourceFO(
Stream stream,
String baseURI,
bool takesOwnership
) sealed
J#
public APSource CreateSourceFO(
Stream stream,
string baseURI,
bool takesOwnership
)
JScript
public function CreateSourceFO(
stream : Stream,
baseURI : String,
takesOwnership : bool
) : APSource

Parameters

stream
Source document stream.
baseURI
Base URI for source document.
takesOwnership
Indicates whether the new source takes ownership of stream.

Return Value

The new APSource instance.

Exceptions

Exception Type | Condition
ObjectDisposedException | APEngine instance is disposed.
InvalidOperationException | APEngine instance is not loaded. -or- APEngine instance is not in running mode.
ArgumentException | baseURI is not the valid path or URI.
ArgumentNullException | stream is null. -or- baseURI is null.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateSourceFO Overload List


CreateSourceFO Method (String)

APEngine.CreateSourceFO Method (String)
See Also Example
[image]

Creates a new FO source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSourceFO( _
ByVal uri As String _
) As APSource
C#
public APSource CreateSourceFO(
string uri
)
C++
public:
APSource CreateSourceFO(
String uri
) sealed
J#
public APSource CreateSourceFO(
string uri
)
JScript
public function CreateSourceFO(
uri : String
) : APSource

Parameters

uri
Path or URI to source document.

Return Value

The new APSource instance.

Exceptions

Exception Type | Condition
ObjectDisposedException | APEngine instance is disposed.
InvalidOperationException | APEngine instance is not loaded. -or- APEngine instance is not in running mode.
ArgumentNullException | uri is null.
APSourceException | Source uri can not be opened.
ArgumentException | uri is not the valid path or URI.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateSourceFO Overload List


CreateSourceSVG Method

APEngine.CreateSourceSVG Method

Creates a new SVG source.

Overload List

 | Name | Description
Public method | CreateSourceSVG (Stream, String, Boolean) | Creates a new SVG source.
Public method | CreateSourceSVG (String) | Creates a new SVG source.

See Also

APEngine Class
Altsoft.Publisher Namespace


CreateSourceSVG Method (Stream, String, Boolean)

APEngine.CreateSourceSVG Method (Stream, String, Boolean)
See Also Example
[image]

Creates a new SVG source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSourceSVG( _
ByVal stream As Stream, _
ByVal baseURI As String, _
ByVal takesOwnership As Boolean _
) As APSource
C#
public APSource CreateSourceSVG(
Stream stream,
string baseURI,
bool takesOwnership
)
C++
public:
APSource CreateSourceSVG(
Stream stream,
String baseURI,
bool takesOwnership
) sealed
J#
public APSource CreateSourceSVG(
Stream stream,
string baseURI,
bool takesOwnership
)
JScript
public function CreateSourceSVG(
stream : Stream,
baseURI : String,
takesOwnership : bool
) : APSource

Parameters

stream
Source document stream.
baseURI
Base URI for source document.
takesOwnership
Indicates whether the new source takes ownership of stream.

Return Value

The new APSource instance.

Exceptions

Exception Type | Condition
ObjectDisposedException | APEngine instance is disposed.
InvalidOperationException | APEngine instance is not loaded. -or- APEngine instance is not in running mode.
ArgumentException | baseURI is not the valid path or URI.
ArgumentNullException | stream is null. -or- baseURI is null.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateSourceSVG Overload List


CreateSourceSVG Method (String)

APEngine.CreateSourceSVG Method (String)
See Also Example
[image]

Creates a new SVG source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSourceSVG( _
ByVal uri As String _
) As APSource
C#
public APSource CreateSourceSVG(
string uri
)
C++
public:
APSource CreateSourceSVG(
String uri
) sealed
J#
public APSource CreateSourceSVG(
string uri
)
JScript
public function CreateSourceSVG(
uri : String
) : APSource

Parameters

uri
Path or URI to source document.

Return Value

The new APSource instance.

Exceptions

Exception Type | Condition
ObjectDisposedException | APEngine instance is disposed.
InvalidOperationException | APEngine instance is not loaded. -or- APEngine instance is not in running mode.
ArgumentNullException | uri is null.
APSourceException | Source uri can not be opened.
ArgumentException | uri is not the valid path or URI.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateSourceSVG Overload List


CreateSourceSVGZ Method

APEngine.CreateSourceSVGZ Method

Creates a new SVGZ source.

Overload List

 | Name | Description
Public method | CreateSourceSVGZ (Stream, String, Boolean) | Creates a new SVGZ source.
Public method | CreateSourceSVGZ (String) | Creates a new SVGZ source.

See Also

APEngine Class
Altsoft.Publisher Namespace


CreateSourceSVGZ Method (Stream, String, Boolean)

APEngine.CreateSourceSVGZ Method (Stream, String, Boolean)
See Also Example
[image]

Creates a new SVGZ source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSourceSVGZ( _
ByVal stream As Stream, _
ByVal baseURI As String, _
ByVal takesOwnership As Boolean _
) As APSource
C#
public APSource CreateSourceSVGZ(
Stream stream,
string baseURI,
bool takesOwnership
)
C++
public:
APSource CreateSourceSVGZ(
Stream stream,
String baseURI,
bool takesOwnership
) sealed
J#
public APSource CreateSourceSVGZ(
Stream stream,
string baseURI,
bool takesOwnership
)
JScript
public function CreateSourceSVGZ(
stream : Stream,
baseURI : String,
takesOwnership : bool
) : APSource

Parameters

stream
Source document stream.
baseURI
Base URI for source document.
takesOwnership
Indicates whether the new source takes ownership of stream.

Return Value

The new APSource instance.

Exceptions

Exception Type | Condition
ObjectDisposedException | APEngine instance is disposed.
InvalidOperationException | APEngine instance is not loaded. -or- APEngine instance is not in running mode.
ArgumentException | baseURI is not the valid path or URI.
ArgumentNullException | stream is null. -or- baseURI is null.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateSourceSVGZ Overload List


CreateSourceSVGZ Method (String)

APEngine.CreateSourceSVGZ Method (String)
See Also Example
[image]

Creates a new SVGZ source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSourceSVGZ( _
ByVal uri As String _
) As APSource
C#
public APSource CreateSourceSVGZ(
string uri
)
C++
public:
APSource CreateSourceSVGZ(
String uri
) sealed
J#
public APSource CreateSourceSVGZ(
string uri
)
JScript
public function CreateSourceSVGZ(
uri : String
) : APSource

Parameters

uri
Path or URI to source document.

Return Value

The new APSource instance.

Exceptions

Exception Type | Condition
ObjectDisposedException | APEngine instance is disposed.
InvalidOperationException | APEngine instance is not loaded. -or- APEngine instance is not in running mode.
ArgumentNullException | uri is null.
APSourceException | Source uri can not be opened.
ArgumentException | uri is not the valid path or URI.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateSourceSVGZ Overload List


CreateSourceWord2003Xml Method

APEngine.CreateSourceWord2003Xml Method

Creates a new Word2003Xml source.

Overload List

 | Name | Description
Public method | CreateSourceWord2003Xml (Stream, String, Boolean) | Creates a new Word2003Xml source.
Public method | CreateSourceWord2003Xml (String) | Creates a new Word2003Xml source.

See Also

APEngine Class
Altsoft.Publisher Namespace


CreateSourceWord2003Xml Method (Stream, String, Boolean)

APEngine.CreateSourceWord2003Xml Method (Stream, String, Boolean)
See Also Example
[image]

Creates a new Word2003Xml source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSourceWord2003Xml( _
ByVal stream As Stream, _
ByVal baseURI As String, _
ByVal takesOwnership As Boolean _
) As APSource
C#
public APSource CreateSourceWord2003Xml(
Stream stream,
string baseURI,
bool takesOwnership
)
C++
public:
APSource CreateSourceWord2003Xml(
Stream stream,
String baseURI,
bool takesOwnership
) sealed
J#
public APSource CreateSourceWord2003Xml(
Stream stream,
string baseURI,
bool takesOwnership
)
JScript
public function CreateSourceWord2003Xml(
stream : Stream,
baseURI : String,
takesOwnership : bool
) : APSource

Parameters

stream
Source document stream.
baseURI
Base URI for source document.
takesOwnership
Indicates whether the new source takes ownership of stream.

Return Value

The new APSource instance.

Exceptions

Exception Type | Condition
ObjectDisposedException | APEngine instance is disposed.
InvalidOperationException | APEngine instance is not loaded. -or- APEngine instance is not in running mode.
ArgumentException | baseURI is not the valid path or URI.
ArgumentNullException | stream is null. -or- baseURI is null.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateSourceWord2003Xml Overload List


CreateSourceWord2003Xml Method (String)

APEngine.CreateSourceWord2003Xml Method (String)
See Also Example
[image]

Creates a new Word2003Xml source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSourceWord2003Xml( _
ByVal uri As String _
) As APSource
C#
public APSource CreateSourceWord2003Xml(
string uri
)
C++
public:
APSource CreateSourceWord2003Xml(
String uri
) sealed
J#
public APSource CreateSourceWord2003Xml(
string uri
)
JScript
public function CreateSourceWord2003Xml(
uri : String
) : APSource

Parameters

uri
Path or URI to source document.

Return Value

The new APSource instance.

Exceptions

Exception Type | Condition
ObjectDisposedException | APEngine instance is disposed.
InvalidOperationException | APEngine instance is not loadedAPEnginePEngine instance is not in running mode.
ArgumentNullException | uri is null.
APSourceException | Source uri can not be opened.
ArgumentException | uri is not the valid path or URI.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateSourceWord2003Xml Overload List


CreateSourceWordDoc Method

APEngine.CreateSourceWordDoc Method

Creates a new WordDoc source.

Overload List

 | Name | Description
Public method | CreateSourceWordDoc (Stream, String, Boolean) | Creates a new WordDoc source.
Public method | CreateSourceWordDoc (String) | Creates a new WordDoc source.

See Also

APEngine Class
Altsoft.Publisher Namespace


CreateSourceWordDoc Method (Stream, String, Boolean)

APEngine.CreateSourceWordDoc Method (Stream, String, Boolean)
See Also Example
[image]

Creates a new WordDoc source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSourceWordDoc( _
ByVal stream As Stream, _
ByVal baseURI As String, _
ByVal takesOwnership As Boolean _
) As APSource
C#
public APSource CreateSourceWordDoc(
Stream stream,
string baseURI,
bool takesOwnership
)
C++
public:
APSource CreateSourceWordDoc(
Stream stream,
String baseURI,
bool takesOwnership
) sealed
J#
public APSource CreateSourceWordDoc(
Stream stream,
string baseURI,
bool takesOwnership
)
JScript
public function CreateSourceWordDoc(
stream : Stream,
baseURI : String,
takesOwnership : bool
) : APSource

Parameters

stream
Source document stream.
baseURI
Base URI for source document.
takesOwnership
Indicates whether the new source takes ownership of stream.

Return Value

The new APSource instance.

Exceptions

Exception Type | Condition
ObjectDisposedException | APEngine instance is disposed.
InvalidOperationException | APEngine instance is not loaded. -or- APEngine instance is not in running mode.
ArgumentException | baseURI is not the valid path or URI.
ArgumentNullException | stream is null. -or- baseURI is null.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateSourceWordDoc Overload List


CreateSourceWordDoc Method (String)

APEngine.CreateSourceWordDoc Method (String)
See Also Example
[image]

Creates a new WordDoc source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSourceWordDoc( _
ByVal uri As String _
) As APSource
C#
public APSource CreateSourceWordDoc(
string uri
)
C++
public:
APSource CreateSourceWordDoc(
String uri
) sealed
J#
public APSource CreateSourceWordDoc(
string uri
)
JScript
public function CreateSourceWordDoc(
uri : String
) : APSource

Parameters

uri
Path or URI to source document.

Return Value

The new APSource instance.

Exceptions

Exception Type | Condition
ObjectDisposedException | APEngine instance is disposed.
InvalidOperationException | APEngine instance is not loaded. -or- APEngine instance is not in running mode.
ArgumentNullException | uri is null.
APSourceException | Source uri can not be opened.
ArgumentException | uri is not the valid path or URI.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateSourceWordDoc Overload List


CreateSourceWordDocX Method

APEngine.CreateSourceWordDocX Method

Creates a new WordDocX source.

Overload List

 | Name | Description
Public method | CreateSourceWordDocX (Stream, String, Boolean) | Creates a new WordDocX source.
Public method | CreateSourceWordDocX (String) | Creates a new WordDocX source.

See Also

APEngine Class
Altsoft.Publisher Namespace


CreateSourceWordDocX Method (Stream, String, Boolean)

APEngine.CreateSourceWordDocX Method (Stream, String, Boolean)
See Also Example
[image]

Creates a new WordDocX source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSourceWordDocX( _
ByVal stream As Stream, _
ByVal baseURI As String, _
ByVal takesOwnership As Boolean _
) As APSource
C#
public APSource CreateSourceWordDocX(
Stream stream,
string baseURI,
bool takesOwnership
)
C++
public:
APSource CreateSourceWordDocX(
Stream stream,
String baseURI,
bool takesOwnership
) sealed
J#
public APSource CreateSourceWordDocX(
Stream stream,
string baseURI,
bool takesOwnership
)
JScript
public function CreateSourceWordDocX(
stream : Stream,
baseURI : String,
takesOwnership : bool
) : APSource

Parameters

stream
Source document stream.
baseURI
Base URI for source document.
takesOwnership
Indicates whether the new source takes ownership of stream.

Return Value

The new APSource instance.

Exceptions

Exception Type | Condition
ObjectDisposedException | APEngine instance is disposed.
InvalidOperationException | APEngine instance is not loaded. -or- APEngine instance is not in running mode.
ArgumentException | baseURI is not the valid path or URI.
ArgumentNullException | stream is null. -or- baseURI is null.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateSourceWordDocX Overload List


CreateSourceWordDocX Method (String)

APEngine.CreateSourceWordDocX Method (String)
See Also Example
[image]

Creates a new WordDocX source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSourceWordDocX( _
ByVal uri As String _
) As APSource
C#
public APSource CreateSourceWordDocX(
string uri
)
C++
public:
APSource CreateSourceWordDocX(
String uri
) sealed
J#
public APSource CreateSourceWordDocX(
string uri
)
JScript
public function CreateSourceWordDocX(
uri : String
) : APSource

Parameters

uri
Path or URI to source document.

Return Value

The new APSource instance.

Exceptions

Exception Type | Condition
ObjectDisposedException | APEngine instance is disposed.
InvalidOperationException | APEngine instance is not loaded. -or- APEngine instance is not in running mode.
ArgumentNullException | uri is null.
APSourceException | Source uri can not be opened.
ArgumentException | uri is not the valid path or URI.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateSourceWordDocX Overload List


CreateSourceWordXml Method

APEngine.CreateSourceWordXml Method

Creates a new WordXml source.

Overload List

 | Name | Description
Public method | CreateSourceWordXml (Stream, String, Boolean) | Creates a new WordXml source.
Public method | CreateSourceWordXml (String) | Creates a new WordXml source.

See Also

APEngine Class
Altsoft.Publisher Namespace


CreateSourceWordXml Method (Stream, String, Boolean)

APEngine.CreateSourceWordXml Method (Stream, String, Boolean)
See Also Example
[image]

Creates a new WordXml source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSourceWordXml( _
ByVal stream As Stream, _
ByVal baseURI As String, _
ByVal takesOwnership As Boolean _
) As APSource
C#
public APSource CreateSourceWordXml(
Stream stream,
string baseURI,
bool takesOwnership
)
C++
public:
APSource CreateSourceWordXml(
Stream stream,
String baseURI,
bool takesOwnership
) sealed
J#
public APSource CreateSourceWordXml(
Stream stream,
string baseURI,
bool takesOwnership
)
JScript
public function CreateSourceWordXml(
stream : Stream,
baseURI : String,
takesOwnership : bool
) : APSource

Parameters

stream
Source document stream.
baseURI
Base URI for source document.
takesOwnership
Indicates whether the new source takes ownership of stream.

Return Value

The new APSource instance.

Exceptions

Exception Type | Condition
ObjectDisposedException | APEngine instance is disposed.
InvalidOperationException | APEngine instance is not loaded. -or- APEngine instance is not in running mode.
ArgumentException | baseURI is not the valid path or URI.
ArgumentNullException | stream is null. -or- baseURI is null.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateSourceWordXml Overload List


CreateSourceWordXml Method (String)

APEngine.CreateSourceWordXml Method (String)
See Also Example
[image]

Creates a new WordXml source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSourceWordXml( _
ByVal uri As String _
) As APSource
C#
public APSource CreateSourceWordXml(
string uri
)
C++
public:
APSource CreateSourceWordXml(
String uri
) sealed
J#
public APSource CreateSourceWordXml(
string uri
)
JScript
public function CreateSourceWordXml(
uri : String
) : APSource

Parameters

uri
Path or URI to source document.

Return Value

The new APSource instance.

Exceptions

Exception Type | Condition
ObjectDisposedException | APEngine instance is disposed.
InvalidOperationException | APEngine instance is not loaded. -or- APEngine instance is not in running mode.
ArgumentNullException | uri is null.
APSourceException | Source uri can not be opened.
ArgumentException | uri is not the valid path or URI.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateSourceWordXml Overload List


CreateSourceXHTML Method

APEngine.CreateSourceXHTML Method

Creates a new XHTML source.

Overload List

 | Name | Description
Public method | CreateSourceXHTML (Stream, String, Boolean) | Creates a new XHTML source.
Public method | CreateSourceXHTML (String) | Creates a new XHTML source.

See Also

APEngine Class
Altsoft.Publisher Namespace


CreateSourceXHTML Method (Stream, String, Boolean)

APEngine.CreateSourceXHTML Method (Stream, String, Boolean)
See Also Example
[image]

Creates a new XHTML source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSourceXHTML( _
ByVal stream As Stream, _
ByVal baseURI As String, _
ByVal takesOwnership As Boolean _
) As APSource
C#
public APSource CreateSourceXHTML(
Stream stream,
string baseURI,
bool takesOwnership
)
C++
public:
APSource CreateSourceXHTML(
Stream stream,
String baseURI,
bool takesOwnership
) sealed
J#
public APSource CreateSourceXHTML(
Stream stream,
string baseURI,
bool takesOwnership
)
JScript
public function CreateSourceXHTML(
stream : Stream,
baseURI : String,
takesOwnership : bool
) : APSource

Parameters

stream
Source document stream.
baseURI
Base URI for source document.
takesOwnership
Indicates whether the new source takes ownership of stream.

Return Value

The new APSource instance.

Exceptions

Exception Type | Condition
ObjectDisposedException | APEngine instance is disposed.
InvalidOperationException | APEngine instance is not loaded. -or- APEngine instance is not in running mode.
ArgumentException | baseURI is not the valid path or URI.
ArgumentNullException | stream is null. -or- baseURI is null.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateSourceXHTML Overload List


CreateSourceXHTML Method (String)

APEngine.CreateSourceXHTML Method (String)
See Also Example
[image]

Creates a new XHTML source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSourceXHTML( _
ByVal uri As String _
) As APSource
C#
public APSource CreateSourceXHTML(
string uri
)
C++
public:
APSource CreateSourceXHTML(
String uri
) sealed
J#
public APSource CreateSourceXHTML(
string uri
)
JScript
public function CreateSourceXHTML(
uri : String
) : APSource

Parameters

uri
Path or URI to source document.

Return Value

The new APSource instance.

Exceptions

Exception Type | Condition
ObjectDisposedException | APEngine instance is disposed.
InvalidOperationException | APEngine instance is not loaded. -or- APEngine instance is not in running mode.
ArgumentNullException | uri is null.
APSourceException | Source uri can not be opened.
ArgumentException | uri is not the valid path or URI.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.CreateSourceXHTML Overload List


Load Method

APEngine.Load Method

Initializes the Altsoft Xml2PDF library core. Used only in evaluation version.

Overload List

 | Name | Description
Public method | Load | Initializes the Altsoft Xml2PDF library core. Used only in evaluation version.
Public method | Load (String) | Initializes the Altsoft Xml2PDF library core.
Public method | Load (String, APLog, Double) | Initializes the Altsoft Xml2PDF library core.

See Also

APEngine Class
Altsoft.Publisher Namespace


Load Method ()

APEngine.Load Method ()
See Also Example
[image]

Initializes the Altsoft Xml2PDF library core. Used only in evaluation version.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Load() As APLog
C#
public APLog Load()
C++
public:
APLog Load() sealed
J#
public APLog Load()
JScript
public function Load() : APLog

Return Value

Initialization log.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.Load Overload List


Load Method (String)

APEngine.Load Method (String)
See Also Example
[image]

Initializes the Altsoft Xml2PDF library core.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Load( _
ByVal serialKey As String _
) As APLog
C#
public APLog Load(
string serialKey
)
C++
public:
APLog Load(
String serialKey
) sealed
J#
public APLog Load(
string serialKey
)
JScript
public function Load(
serialKey : String
) : APLog

Parameters

serialKey
Serial key for the Altsoft formatting engine activation.

Return Value

Initialization log.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.Load Overload List


Load Method (String, APLog, Double)

APEngine.Load Method (String, APLog, Double)
See Also Example
[image]

Initializes the Altsoft Xml2PDF library core.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Load( _
ByVal serialKey As String, _
ByVal log As APLog, _
ByVal weight As Double _
)
C#
public void Load(
string serialKey,
APLog log,
double weight
)
C++
public:
void Load(
String serialKey,
APLog log,
double weight
) sealed
J#
public void Load(
string serialKey,
APLog log,
double weight
)
JScript
public function Load(
serialKey : String,
log : APLog,
weight : double
)

Parameters

serialKey
Serial key for the Altsoft formatting engine activation.
log
User-defined initialization log.
weight
Weight of Load within the parent operation - number in range [0,1].

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.Load Overload List


LoadAppDefaults Method

APEngine.LoadAppDefaults Method
[image]

Loads the application default settings from the configuration section with the given name.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub LoadAppDefaults( _
ByVal configSectionName As String _
)
C#
public void LoadAppDefaults(
string configSectionName
)
C++
public:
void LoadAppDefaults(
String configSectionName
) sealed
J#
public void LoadAppDefaults(
string configSectionName
)
JScript
public function LoadAppDefaults(
configSectionName : String
)

Parameters

configSectionName
Altsoft.Xml2PDF configuration section name.

Remarks

Xml2PDF is integrated with .NET application configuration. This means that you can declare preferred Xml2PDF defaults in the App.config of your user-end application.

See Also

APEngine Class
Altsoft.Publisher Namespace


Unload Method

APEngine.Unload Method

Performs a clean-up of the resources used by the Altsoft Xml2PDF engine.

Overload List

 | Name | Description
Public method | Unload | Performs a clean-up of the resources used by the Altsoft Xml2PDF engine.
Public method | Unload (APLog, Double) | Performs clean-up of the resources used by the Altsoft Xml2PDF engine.

See Also

APEngine Class
Altsoft.Publisher Namespace


Unload Method ()

APEngine.Unload Method ()
See Also Example
[image]

Performs a clean-up of the resources used by the Altsoft Xml2PDF engine.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Unload() As APLog
C#
public APLog Unload()
C++
public:
APLog Unload() sealed
J#
public APLog Unload()
JScript
public function Unload() : APLog

Return Value

The clean-up log.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.Unload Overload List


Unload Method (APLog, Double)

APEngine.Unload Method (APLog, Double)
See Also Example
[image]

Performs clean-up of the resources used by the Altsoft Xml2PDF engine.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Unload( _
ByVal log As APLog, _
ByVal weight As Double _
)
C#
public void Unload(
APLog log,
double weight
)
C++
public:
void Unload(
APLog log,
double weight
) sealed
J#
public void Unload(
APLog log,
double weight
)
JScript
public function Unload(
log : APLog,
weight : double
)

Parameters

log
User-defined clean-up log.
weight
Weight of the 'Load' operation within the current log stage.

See Also

APEngine Class
Altsoft.Publisher Namespace
APEngine.Unload Overload List


APFileSystem Interface

APFileSystem Interface
See Also Example Members
[image]

This interface allows you to override interaction of Xml2PDF Server with the file system of your computer.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface APFileSystem
C#
public interface APFileSystem
C++
interface class APFileSystem
J#
public interface APFileSystem
JScript
public interface APFileSystem

See Also

APFileSystem Members
Altsoft.Publisher Namespace


APFileSystem Members

APFileSystem Members
See Also Example Methods
[image]

This interface allows you to override interaction of Xml2PDF Server with the file system of your computer.

The following tables list the members exposed by APFileSystem.

Public Methods

 | Name | Description
Public method | OnGetDirFiles | Overrides getting files within given directory.
Public method | OnGetUriStream | Returns the stream of file with the given Uri.
Top

See Also

APFileSystem Interface
Altsoft.Publisher Namespace


Methods

APFileSystem Methods
[image]

Public Methods

 | Name | Description
Public method | OnGetDirFiles | Overrides getting files within given directory.
Public method | OnGetUriStream | Returns the stream of file with the given Uri.
Top

See Also

APFileSystem Interface
Altsoft.Publisher Namespace


OnGetDirFiles Method

APFileSystem.OnGetDirFiles Method
[image]

Overrides getting files within given directory.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Function OnGetDirFiles( _
ByVal dirUri As String, _
<OutAttribute> ByRef files As String _
) As Boolean
C#
bool OnGetDirFiles(
string dirUri,
out string files
)
C++
bool OnGetDirFiles(
String dirUri,
[OutAttribute] String% files
) abstract
J#
bool OnGetDirFiles(
string dirUri,
/** @attribute OutAttribute() */ /** @ref */ string files
)
JScript
function OnGetDirFiles(
dirUri : String,
OutAttribute files : String
) : bool

Parameters

dirUri
Full Uri to the directory.
files
Resulting collection of files

Return Value

true if the current process was overriden.

See Also

APFileSystem Interface
Altsoft.Publisher Namespace


OnGetUriStream Method

APFileSystem.OnGetUriStream Method
[image]

Returns the stream of file with the given Uri.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Function OnGetUriStream( _
ByVal fullUri As String, _
<OutAttribute> ByRef stream As Stream _
) As Boolean
C#
bool OnGetUriStream(
string fullUri,
out Stream stream
)
C++
bool OnGetUriStream(
String fullUri,
[OutAttribute] Stream% stream
) abstract
J#
bool OnGetUriStream(
string fullUri,
/** @attribute OutAttribute() */ /** @ref */ Stream stream
)
JScript
function OnGetUriStream(
fullUri : String,
OutAttribute stream : Stream
) : bool

Parameters

fullUri
Full Uri to the file.
stream
Resulting stream

Return Value

true if the current process was overriden.

See Also

APFileSystem Interface
Altsoft.Publisher Namespace


APLog Class

APLog Class
See Also Example Members
[image]

Operation log.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual), _
GuidAttribute("EB762F08-78FB-4b74-A586-F6CADFBB3AA1")>
Public Class APLog
Implements IXmlSerializable
C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("EB762F08-78FB-4b74-A586-F6CADFBB3AA1")]
public class APLog : IXmlSerializable
C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"EB762F08-78FB-4b74-A586-F6CADFBB3AA1")]
ref class APLog : IXmlSerializable
J#
/** @attribute ClassInterfaceAttribute(ClassInterfaceType.AutoDual) */
/** @attribute GuidAttribute("EB762F08-78FB-4b74-A586-F6CADFBB3AA1") */
public class APLog implements IXmlSerializable
JScript
public
ClassInterfaceAttribute(ClassInterfaceType.AutoDual)
GuidAttribute("EB762F08-78FB-4b74-A586-F6CADFBB3AA1")
class APLog extends IXmlSerializable

Inheritance Hierarchy

System.Object
Altsoft.Publisher.APLog

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APLog Members
Altsoft.Publisher Namespace


APLog Members

APLog Members
See Also Example Constructors Properties Methods Events
[image]

Operation log.

The following tables list the members exposed by APLog.

Public Constructors

 | Name | Description
Public method | APLog | Creates a new empty APLog.
Top

Public Properties

 | Name | Description
Public property | TimeUsed | Gets the time used by an operation.
Top

Public Methods

 | Name | Description
Public method | Add | Appends the information from the given log.
Public method | EndStage | Ends the stage at the given stage-depth.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Failed | Causes the application to fail at the stage with the given depth and with the given exception.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Message | Adds a new operation event message.
Public method | Save | Overloaded. Saves log to the given stream.
Public method | StartStage | Starts a new operation stage.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Public Events

 | Name | Description
Public event | OnEndStage | Event raised each time when stage ended.
Public event | OnMessage | Event raised for each new message;
Public event | OnProgress | Event raised each time when progress is changed.
Public event | OnStartStage | Event raised each time when new stage started.
Public event | OnWarning | Event raised for each new warning;
Top

See Also

APLog Class
Altsoft.Publisher Namespace


APLog Constructor

APLog Constructor
[image]

Creates a new empty APLog.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APLog()
C++
public:
APLog() sealed
J#
public APLog()
JScript
public function APLog()

See Also

APLog Class
Altsoft.Publisher Namespace


Properties

APLog Properties
[image]

Public Properties

 | Name | Description
Public property | TimeUsed | Gets the time used by an operation.
Top

See Also

APLog Class
Altsoft.Publisher Namespace


TimeUsed Property

APLog.TimeUsed Property
[image]

Gets the time used by an operation.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TimeUsed As TimeSpan
C#
public TimeSpan TimeUsed { get; }
C++
public property TimeSpan TimeUsed sealed {
TimeSpan get();
}
J#
/** property */
public TimeSpan get_TimeUsed();
JScript
public function get TimeUsed() : TimeSpan

See Also

APLog Class
Altsoft.Publisher Namespace


Methods

APLog Methods
[image]

Public Methods

 | Name | Description
Public method | Add | Appends the information from the given log.
Public method | EndStage | Ends the stage at the given stage-depth.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Failed | Causes the application to fail at the stage with the given depth and with the given exception.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Message | Adds a new operation event message.
Public method | Save | Overloaded. Saves log to the given stream.
Public method | StartStage | Starts a new operation stage.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

APLog Class
Altsoft.Publisher Namespace


Add Method

APLog.Add Method
[image]

Appends the information from the given log.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
ByVal log As APLog _
)
C#
public void Add(
APLog log
)
C++
public:
void Add(
APLog log
) sealed
J#
public void Add(
APLog log
)
JScript
public function Add(
log : APLog
)

Parameters

log
An APLog to be added.

See Also

APLog Class
Altsoft.Publisher Namespace


EndStage Method

APLog.EndStage Method
[image]

Ends the stage at the given stage-depth.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub EndStage( _
ByVal stageDepth As Integer _
)
C#
public void EndStage(
int stageDepth
)
C++
public:
void EndStage(
int stageDepth
) sealed
J#
public void EndStage(
int stageDepth
)
JScript
public function EndStage(
stageDepth : int
)

Parameters

stageDepth
Stage depth.

See Also

APLog Class
Altsoft.Publisher Namespace


Failed Method

APLog.Failed Method
[image]

Causes the application to fail at the stage with the given depth and with the given exception.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Failed( _
ByVal ex As Exception, _
ByVal stageDepth As Integer _
)
C#
public void Failed(
Exception ex,
int stageDepth
)
C++
public:
void Failed(
Exception ex,
int stageDepth
) sealed
J#
public void Failed(
Exception ex,
int stageDepth
)
JScript
public function Failed(
ex : Exception,
stageDepth : int
)

Parameters

ex
Exception to throw.
stageDepth
Stage depth.

See Also

APLog Class
Altsoft.Publisher Namespace


Message Method

APLog.Message Method
[image]

Adds a new operation event message.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Message( _
ByVal message As String _
)
C#
public void Message(
string message
)
C++
public:
void Message(
String message
) sealed
J#
public void Message(
string message
)
JScript
public function Message(
message : String
)

Parameters

message
Message string.

See Also

APLog Class
Altsoft.Publisher Namespace


Save Method

APLog.Save Method

Saves log to the given stream.

Overload List

 | Name | Description
Public method | Save (Stream, Boolean) | Saves log to the given stream.
Public method | Save (String) | Saves log to the given file.

See Also

APLog Class
Altsoft.Publisher Namespace


Save Method (Stream, Boolean)

APLog.Save Method (Stream, Boolean)
See Also Example
[image]

Saves log to the given stream.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Save( _
ByVal stream As Stream, _
ByVal closeStream As Boolean _
)
C#
public void Save(
Stream stream,
bool closeStream
)
C++
public:
void Save(
Stream stream,
bool closeStream
) sealed
J#
public void Save(
Stream stream,
bool closeStream
)
JScript
public function Save(
stream : Stream,
closeStream : bool
)

Parameters

stream
Output stream.
closeStream
Indicates to close the stream after saving.

See Also

APLog Class
Altsoft.Publisher Namespace
APLog.Save Overload List


Save Method (String)

APLog.Save Method (String)
See Also Example
[image]

Saves log to the given file.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Save( _
ByVal path As String _
)
C#
public void Save(
string path
)
C++
public:
void Save(
String path
) sealed
J#
public void Save(
string path
)
JScript
public function Save(
path : String
)

Parameters

path
Path to the output file.

See Also

APLog Class
Altsoft.Publisher Namespace
APLog.Save Overload List


StartStage Method

APLog.StartStage Method
[image]

Starts a new operation stage.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function StartStage( _
ByVal stage As String, _
ByVal weight As Double _
) As Integer
C#
public int StartStage(
string stage,
double weight
)
C++
public:
int StartStage(
String stage,
double weight
) sealed
J#
public int StartStage(
string stage,
double weight
)
JScript
public function StartStage(
stage : String,
weight : double
) : int

Parameters

stage
Stage description.
weight
Stage weight within the parent operation.

Return Value

Stage depth.

See Also

APLog Class
Altsoft.Publisher Namespace


Events

APLog Events
[image]

Public Events

 | Name | Description
Public event | OnEndStage | Event raised each time when stage ended.
Public event | OnMessage | Event raised for each new message;
Public event | OnProgress | Event raised each time when progress is changed.
Public event | OnStartStage | Event raised each time when new stage started.
Public event | OnWarning | Event raised for each new warning;
Top

See Also

APLog Class
Altsoft.Publisher Namespace


OnEndStage Event

APLog.OnEndStage Event
[image]

Event raised each time when stage ended.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Event OnEndStage As APLogStageHandler
C#
public event APLogStageHandler OnEndStage
C++
public:
virtual event APLogStageHandler OnEndStage {
void add(APLogStageHandler value) sealed ;
void remove(APLogStageHandler value) sealed ;
}
J#
/** event */
public final void add_OnEndStage(APLogStageHandler value);

/** event */
public final void remove_OnEndStage(APLogStageHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

APLog Class
Altsoft.Publisher Namespace


OnMessage Event

APLog.OnMessage Event
[image]

Event raised for each new message;

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Event OnMessage As APLogMessageHandler
C#
public event APLogMessageHandler OnMessage
C++
public:
virtual event APLogMessageHandler OnMessage {
void add(APLogMessageHandler value) sealed ;
void remove(APLogMessageHandler value) sealed ;
}
J#
/** event */
public final void add_OnMessage(APLogMessageHandler value);

/** event */
public final void remove_OnMessage(APLogMessageHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

APLog Class
Altsoft.Publisher Namespace


OnProgress Event

APLog.OnProgress Event
[image]

Event raised each time when progress is changed.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Event OnProgress As APLogProgressHandler
C#
public event APLogProgressHandler OnProgress
C++
public:
virtual event APLogProgressHandler OnProgress {
void add(APLogProgressHandler value) sealed ;
void remove(APLogProgressHandler value) sealed ;
}
J#
/** event */
public final void add_OnProgress(APLogProgressHandler value);

/** event */
public final void remove_OnProgress(APLogProgressHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

APLog Class
Altsoft.Publisher Namespace


OnStartStage Event

APLog.OnStartStage Event
[image]

Event raised each time when new stage started.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Event OnStartStage As APLogStageHandler
C#
public event APLogStageHandler OnStartStage
C++
public:
virtual event APLogStageHandler OnStartStage {
void add(APLogStageHandler value) sealed ;
void remove(APLogStageHandler value) sealed ;
}
J#
/** event */
public final void add_OnStartStage(APLogStageHandler value);

/** event */
public final void remove_OnStartStage(APLogStageHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

APLog Class
Altsoft.Publisher Namespace


OnWarning Event

APLog.OnWarning Event
[image]

Event raised for each new warning;

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Event OnWarning As APLogWarningHandler
C#
public event APLogWarningHandler OnWarning
C++
public:
virtual event APLogWarningHandler OnWarning {
void add(APLogWarningHandler value) sealed ;
void remove(APLogWarningHandler value) sealed ;
}
J#
/** event */
public final void add_OnWarning(APLogWarningHandler value);

/** event */
public final void remove_OnWarning(APLogWarningHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

APLog Class
Altsoft.Publisher Namespace


APSource Class

APSource Class
See Also Example Members
[image]

Input the document source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.AutoDual), _
GuidAttribute("FE099351-1B2C-454e-94DD-6EB31D287291")>
Public Class APSource
Implements IDisposable
C#
[ClassInterfaceAttribute(ClassInterfaceType.AutoDual)]
[GuidAttribute("FE099351-1B2C-454e-94DD-6EB31D287291")]
public class APSource : IDisposable
C++
[ClassInterfaceAttribute(ClassInterfaceType::AutoDual)]
[GuidAttribute(L"FE099351-1B2C-454e-94DD-6EB31D287291")]
ref class APSource : IDisposable
J#
/** @attribute ClassInterfaceAttribute(ClassInterfaceType.AutoDual) */
/** @attribute GuidAttribute("FE099351-1B2C-454e-94DD-6EB31D287291") */
public class APSource implements IDisposable
JScript
public
ClassInterfaceAttribute(ClassInterfaceType.AutoDual)
GuidAttribute("FE099351-1B2C-454e-94DD-6EB31D287291")
class APSource extends IDisposable

Inheritance Hierarchy

System.Object
Altsoft.Publisher.APSource

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APSource Members
Altsoft.Publisher Namespace


APSource Members

APSource Members
See Also Example Properties Methods
[image]

Input the document source.

The following tables list the members exposed by APSource.

Public Properties

 | Name | Description
Public property | Format | Gets the format of the current source.
Top

Public Methods

 | Name | Description
Public method | ApplyXSLT | Applies the given XSL transformation to the document source.
Public method | CheckFormat | Checks if the specified Format is valid for the current source. In case of Unknown determines the format of the current source.
Public method | Close | Disposes the current source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

APSource Class
Altsoft.Publisher Namespace


Properties

APSource Properties
[image]

Public Properties

 | Name | Description
Public property | Format | Gets the format of the current source.
Top

See Also

APSource Class
Altsoft.Publisher Namespace


Format Property

APSource.Format Property
[image]

Gets the format of the current source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Format As APSourceFormat
C#
public APSourceFormat Format { get; set; }
C++
public property APSourceFormat Format sealed {
APSourceFormat get();
void set(APSourceFormat value);
}
J#
/** property */
public APSourceFormat get_Format();

/** property */
public void set_Format(APSourceFormat value);
JScript
public function get Format() : APSourceFormat

public function set Format(value : APSourceFormat);

See Also

APSource Class
Altsoft.Publisher Namespace


Methods

APSource Methods
[image]

Public Methods

 | Name | Description
Public method | ApplyXSLT | Applies the given XSL transformation to the document source.
Public method | CheckFormat | Checks if the specified Format is valid for the current source. In case of Unknown determines the format of the current source.
Public method | Close | Disposes the current source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

APSource Class
Altsoft.Publisher Namespace


ApplyXSLT Method

APSource.ApplyXSLT Method
[image]

Applies the given XSL transformation to the document source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub ApplyXSLT( _
ByVal xsltUri As String, _
ByVal log As APLog _
)
C#
public void ApplyXSLT(
string xsltUri,
APLog log
)
C++
public:
void ApplyXSLT(
String xsltUri,
APLog log
) sealed
J#
public void ApplyXSLT(
string xsltUri,
APLog log
)
JScript
public function ApplyXSLT(
xsltUri : String,
log : APLog
)

Parameters

xsltUri
The path to the XSLT document.
log
User-defined log for the operation.

Exceptions

Exception Type | Condition
ArgumentNullException | xsltUri is null. -or- log is null.
ArgumentException | xsltUri is empty string. -or- xsltUri is not valid path or URI.

See Also

APSource Class
Altsoft.Publisher Namespace


CheckFormat Method

APSource.CheckFormat Method
[image]

Checks if the specified Format is valid for the current source. In case of Unknown determines the format of the current source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CheckFormat( _
ByVal log As APLog _
) As Boolean
C#
public bool CheckFormat(
APLog log
)
C++
public:
bool CheckFormat(
APLog log
) sealed
J#
public bool CheckFormat(
APLog log
)
JScript
public function CheckFormat(
log : APLog
) : bool

Parameters

log
User-defined log for the operation.

Return Value

True if the current source corresponds the specified format.

See Also

APSource Class
Altsoft.Publisher Namespace


Close Method

APSource.Close Method
[image]

Disposes the current source.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Close()
C#
public void Close()
C++
public:
void Close() sealed
J#
public void Close()
JScript
public function Close()

See Also

APSource Class
Altsoft.Publisher Namespace


APSourceFormat Enumeration

APSourceFormat Enumeration
[image]

Available source formats.

Namespace: Altsoft.Publisher
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enum APSourceFormat
C#
public enum APSourceFormat
C++
public enum class APSourceFormat
J#
public enum APSourceFormat
JScript
public enum APSourceFormat

Members

Member Name | Description
XSLT | Obsolete. XSLT sources are obsolete. Use APSource.ApplyXSLT methods instead. XSL transformation format
FO | XSL-FO format
SVG | SVG format
SVGZ | SVGZ format
XHTML | XHTML format
Word2003Xml | Word 2003 xml document
WordDoc | Word 97-2003 document
WordXml | Word xml document
WordDocX | Word document
ExcelXlsX | Excel document
PowerPointPptX | PowerPoint document
ALT | Alt document
MHT | MHT format
Unknown | Unknown type of document

See Also

Altsoft.Publisher Namespace


Altsoft.Publisher.Configuration

Altsoft.Publisher.Configuration Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | AltOutputSettings | ALT output settings.
Public class | FoInputSettings | XSL-FO input options.
Public class | FontsSettings | Font-related settings.
Public class | GeneralInputSettings | Set of general input options.
Public class | GeneralOutputSettings | Set of general output options.
Public class | HtmlInputSettings | HTML input options.
Public class | PageSettings | Page settings.
Public class | PdfOutputSettings | PDF output settings.
Public class | PSOutputSettings | PS output settings.
Public class | SecuritySettings | Security options.
Public class | Settings |
Public class | SvgInputSettings | SVG input options.
Public class | TIFFOutputSettings | TIFF output settings.
Public class | WordInputSettings | Word input options.
Public class | WordMetadataSettings | Word metadata options.
Public class | XPSOutputSettings | PS output settings.

Enumerations

 | Enumeration | Description
Public enumeration | PDFConformance | Available conformance levels.


AltOutputSettings Class

AltOutputSettings Class
See Also Example Members
[image]

ALT output settings.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class AltOutputSettings
Inherits Settings
C#
public class AltOutputSettings : Settings
C++
ref class AltOutputSettings : Settings
J#
public class AltOutputSettings extends Settings
JScript
public class AltOutputSettings extends Settings

Inheritance Hierarchy

System.Object
Altsoft.Publisher.Configuration.Settings
Altsoft.Publisher.Configuration.AltOutputSettings

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AltOutputSettings Members
Altsoft.Publisher.Configuration Namespace


AltOutputSettings Members

AltOutputSettings Members
See Also Example Properties Methods
[image]

ALT output settings.

The following tables list the members exposed by AltOutputSettings.

Public Properties

 | Name | Description
Public property | EmbedFonts | Indicates whether to embed fonts as base64 to output files.
Public property | EmbedImages | Indicates whether to embed images as base64 to output files.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Set | (inherited from Settings)
Public method | ToString | (inherited from Settings)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AltOutputSettings Class
Altsoft.Publisher.Configuration Namespace


Properties

AltOutputSettings Properties
[image]

Public Properties

 | Name | Description
Public property | EmbedFonts | Indicates whether to embed fonts as base64 to output files.
Public property | EmbedImages | Indicates whether to embed images as base64 to output files.
Top

See Also

AltOutputSettings Class
Altsoft.Publisher.Configuration Namespace


EmbedFonts Property

AltOutputSettings.EmbedFonts Property
[image]

Indicates whether to embed fonts as base64 to output files.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property EmbedFonts As Boolean
C#
public bool EmbedFonts { get; set; }
C++
public property bool EmbedFonts sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_EmbedFonts();

/** property */
public void set_EmbedFonts(bool value);
JScript
public function get EmbedFonts() : bool

public function set EmbedFonts(value : bool);

Remarks

When this option isn't set path to the file is written.

See Also

AltOutputSettings Class
Altsoft.Publisher.Configuration Namespace


EmbedImages Property

AltOutputSettings.EmbedImages Property
[image]

Indicates whether to embed images as base64 to output files.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property EmbedImages As Boolean
C#
public bool EmbedImages { get; set; }
C++
public property bool EmbedImages sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_EmbedImages();

/** property */
public void set_EmbedImages(bool value);
JScript
public function get EmbedImages() : bool

public function set EmbedImages(value : bool);

Remarks

When this option isn't set path to the file is written.

See Also

AltOutputSettings Class
Altsoft.Publisher.Configuration Namespace


FoInputSettings Class

FoInputSettings Class
See Also Example Members
[image]

XSL-FO input options.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class FoInputSettings
Inherits Settings
C#
public class FoInputSettings : Settings
C++
ref class FoInputSettings : Settings
J#
public class FoInputSettings extends Settings
JScript
public class FoInputSettings extends Settings

Inheritance Hierarchy

System.Object
Altsoft.Publisher.Configuration.Settings
Altsoft.Publisher.Configuration.FoInputSettings

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FoInputSettings Members
Altsoft.Publisher.Configuration Namespace


FoInputSettings Members

FoInputSettings Members
See Also Example Properties Methods
[image]

XSL-FO input options.

The following tables list the members exposed by FoInputSettings.

Public Properties

 | Name | Description
Public property | BorderMedium | Value for border-width='medium' in points.
Public property | BorderThick | Value for border-width='thick' in points.
Public property | BorderThin | Value for border-width='thin' in points.
Public property | ExtendedDimensions | Allows using dimension attributes like width or height on <fo:block../>.
Public property | FitText | Causes text overflows scaling to fit available space.
Public property | LineHeightNormal | Value for line-height='normal' in em.
Public property | MarginAuto | Value for margin='auto' in points.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Set | (inherited from Settings)
Public method | ToString | (inherited from Settings)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

FoInputSettings Class
Altsoft.Publisher.Configuration Namespace


Properties

FoInputSettings Properties
[image]

Public Properties

 | Name | Description
Public property | BorderMedium | Value for border-width='medium' in points.
Public property | BorderThick | Value for border-width='thick' in points.
Public property | BorderThin | Value for border-width='thin' in points.
Public property | ExtendedDimensions | Allows using dimension attributes like width or height on <fo:block../>.
Public property | FitText | Causes text overflows scaling to fit available space.
Public property | LineHeightNormal | Value for line-height='normal' in em.
Public property | MarginAuto | Value for margin='auto' in points.
Top

See Also

FoInputSettings Class
Altsoft.Publisher.Configuration Namespace


BorderMedium Property

FoInputSettings.BorderMedium Property
[image]

Value for border-width='medium' in points.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BorderMedium As Double
C#
public double BorderMedium { get; set; }
C++
public property double BorderMedium sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_BorderMedium();

/** property */
public void set_BorderMedium(double value);
JScript
public function get BorderMedium() : double

public function set BorderMedium(value : double);

See Also

FoInputSettings Class
Altsoft.Publisher.Configuration Namespace


BorderThick Property

FoInputSettings.BorderThick Property
[image]

Value for border-width='thick' in points.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BorderThick As Double
C#
public double BorderThick { get; set; }
C++
public property double BorderThick sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_BorderThick();

/** property */
public void set_BorderThick(double value);
JScript
public function get BorderThick() : double

public function set BorderThick(value : double);

See Also

FoInputSettings Class
Altsoft.Publisher.Configuration Namespace


BorderThin Property

FoInputSettings.BorderThin Property
[image]

Value for border-width='thin' in points.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BorderThin As Double
C#
public double BorderThin { get; set; }
C++
public property double BorderThin sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_BorderThin();

/** property */
public void set_BorderThin(double value);
JScript
public function get BorderThin() : double

public function set BorderThin(value : double);

See Also

FoInputSettings Class
Altsoft.Publisher.Configuration Namespace


ExtendedDimensions Property

FoInputSettings.ExtendedDimensions Property
[image]

Allows using dimension attributes like width or height on <fo:block../>.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedDimensions As Boolean
C#
public bool ExtendedDimensions { get; set; }
C++
public property bool ExtendedDimensions sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ExtendedDimensions();

/** property */
public void set_ExtendedDimensions(bool value);
JScript
public function get ExtendedDimensions() : bool

public function set ExtendedDimensions(value : bool);

See Also

FoInputSettings Class
Altsoft.Publisher.Configuration Namespace


FitText Property

FoInputSettings.FitText Property
[image]

Causes text overflows scaling to fit available space.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FitText As Boolean
C#
public bool FitText { get; set; }
C++
public property bool FitText sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_FitText();

/** property */
public void set_FitText(bool value);
JScript
public function get FitText() : bool

public function set FitText(value : bool);

See Also

FoInputSettings Class
Altsoft.Publisher.Configuration Namespace


LineHeightNormal Property

FoInputSettings.LineHeightNormal Property
[image]

Value for line-height='normal' in em.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LineHeightNormal As Double
C#
public double LineHeightNormal { get; set; }
C++
public property double LineHeightNormal sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_LineHeightNormal();

/** property */
public void set_LineHeightNormal(double value);
JScript
public function get LineHeightNormal() : double

public function set LineHeightNormal(value : double);

See Also

FoInputSettings Class
Altsoft.Publisher.Configuration Namespace


MarginAuto Property

FoInputSettings.MarginAuto Property
[image]

Value for margin='auto' in points.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MarginAuto As Double
C#
public double MarginAuto { get; set; }
C++
public property double MarginAuto sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_MarginAuto();

/** property */
public void set_MarginAuto(double value);
JScript
public function get MarginAuto() : double

public function set MarginAuto(value : double);

See Also

FoInputSettings Class
Altsoft.Publisher.Configuration Namespace


FontsSettings Class

FontsSettings Class
See Also Example Members
[image]

Font-related settings.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class FontsSettings
Inherits Settings
C#
public class FontsSettings : Settings
C++
ref class FontsSettings : Settings
J#
public class FontsSettings extends Settings
JScript
public class FontsSettings extends Settings

Inheritance Hierarchy

System.Object
Altsoft.Publisher.Configuration.Settings
Altsoft.Publisher.Configuration.FontsSettings

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FontsSettings Members
Altsoft.Publisher.Configuration Namespace


FontsSettings Members

FontsSettings Members
See Also Example Properties Methods
[image]

Font-related settings.

The following tables list the members exposed by FontsSettings.

Public Properties

 | Name | Description
Public property | DefaultFont | Default value for 'font-family'.
Public property | DefaultFontSize | Default value for font-size in points.
Public property | DefaultFontSizeScale | Default scale factor for font-size.
Public property | UsePostScriptFonts |
Public property | UsePseudoFonts |
Public property | UserFontsPath |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Set | (inherited from Settings)
Public method | ToString | (inherited from Settings)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

FontsSettings Class
Altsoft.Publisher.Configuration Namespace


Properties

FontsSettings Properties
[image]

Public Properties

 | Name | Description
Public property | DefaultFont | Default value for 'font-family'.
Public property | DefaultFontSize | Default value for font-size in points.
Public property | DefaultFontSizeScale | Default scale factor for font-size.
Public property | UsePostScriptFonts |
Public property | UsePseudoFonts |
Public property | UserFontsPath |
Top

See Also

FontsSettings Class
Altsoft.Publisher.Configuration Namespace


DefaultFont Property

FontsSettings.DefaultFont Property
[image]

Default value for 'font-family'.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultFont As String
C#
public string DefaultFont { get; set; }
C++
public property string DefaultFont sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DefaultFont();

/** property */
public void set_DefaultFont(string value);
JScript
public function get DefaultFont() : String

public function set DefaultFont(value : String);

See Also

FontsSettings Class
Altsoft.Publisher.Configuration Namespace


DefaultFontSize Property

FontsSettings.DefaultFontSize Property
[image]

Default value for font-size in points.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultFontSize As Double
C#
public double DefaultFontSize { get; set; }
C++
public property double DefaultFontSize sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_DefaultFontSize();

/** property */
public void set_DefaultFontSize(double value);
JScript
public function get DefaultFontSize() : double

public function set DefaultFontSize(value : double);

Remarks

Value for font-size='medium' in points.

See Also

FontsSettings Class
Altsoft.Publisher.Configuration Namespace


DefaultFontSizeScale Property

FontsSettings.DefaultFontSizeScale Property
[image]

Default scale factor for font-size.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultFontSizeScale As Double
C#
public double DefaultFontSizeScale { get; set; }
C++
public property double DefaultFontSizeScale sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_DefaultFontSizeScale();

/** property */
public void set_DefaultFontSizeScale(double value);
JScript
public function get DefaultFontSizeScale() : double

public function set DefaultFontSizeScale(value : double);

Remarks

Using the setting relative value for the font-size are calculated with the following formulas.

xx-small = medium / (font-scale)^3x-small = medium / (font-scale)^2small = medium / (font-scale)large = medium * (font-scale)x-large = medium * (font-scale)^2xx-large = medium * (font-scale)^3

See Also

FontsSettings Class
Altsoft.Publisher.Configuration Namespace


UsePostScriptFonts Property

FontsSettings.UsePostScriptFonts Property
[image]

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UsePostScriptFonts As Boolean
C#
public bool UsePostScriptFonts { get; set; }
C++
public property bool UsePostScriptFonts sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_UsePostScriptFonts();

/** property */
public void set_UsePostScriptFonts(bool value);
JScript
public function get UsePostScriptFonts() : bool

public function set UsePostScriptFonts(value : bool);

See Also

FontsSettings Class
Altsoft.Publisher.Configuration Namespace


UsePseudoFonts Property

FontsSettings.UsePseudoFonts Property
[image]

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UsePseudoFonts As Boolean
C#
public bool UsePseudoFonts { get; set; }
C++
public property bool UsePseudoFonts sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_UsePseudoFonts();

/** property */
public void set_UsePseudoFonts(bool value);
JScript
public function get UsePseudoFonts() : bool

public function set UsePseudoFonts(value : bool);

See Also

FontsSettings Class
Altsoft.Publisher.Configuration Namespace


UserFontsPath Property

FontsSettings.UserFontsPath Property
[image]

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UserFontsPath As String
C#
public string UserFontsPath { get; set; }
C++
public property string UserFontsPath sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_UserFontsPath();

/** property */
public void set_UserFontsPath(string value);
JScript
public function get UserFontsPath() : String

public function set UserFontsPath(value : String);

See Also

FontsSettings Class
Altsoft.Publisher.Configuration Namespace


GeneralInputSettings Class

GeneralInputSettings Class
See Also Example Members
[image]

Set of general input options.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class GeneralInputSettings
Inherits Settings
C#
public class GeneralInputSettings : Settings
C++
ref class GeneralInputSettings : Settings
J#
public class GeneralInputSettings extends Settings
JScript
public class GeneralInputSettings extends Settings

Inheritance Hierarchy

System.Object
Altsoft.Publisher.Configuration.Settings
Altsoft.Publisher.Configuration.GeneralInputSettings

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GeneralInputSettings Members
Altsoft.Publisher.Configuration Namespace


GeneralInputSettings Members

GeneralInputSettings Members
See Also Example Properties Methods
[image]

Set of general input options.

The following tables list the members exposed by GeneralInputSettings.

Public Properties

 | Name | Description
Public property | PixelsPerInch | Input resolution. Defines physical length of 1px.
Public property | RasterWMF | Supports WMF image format through rasterization.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Set | (inherited from Settings)
Public method | ToString | (inherited from Settings)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

GeneralInputSettings Class
Altsoft.Publisher.Configuration Namespace


Properties

GeneralInputSettings Properties
[image]

Public Properties

 | Name | Description
Public property | PixelsPerInch | Input resolution. Defines physical length of 1px.
Public property | RasterWMF | Supports WMF image format through rasterization.
Top

See Also

GeneralInputSettings Class
Altsoft.Publisher.Configuration Namespace


PixelsPerInch Property

GeneralInputSettings.PixelsPerInch Property
[image]

Input resolution. Defines physical length of 1px.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PixelsPerInch As Double
C#
public double PixelsPerInch { get; set; }
C++
public property double PixelsPerInch sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_PixelsPerInch();

/** property */
public void set_PixelsPerInch(double value);
JScript
public function get PixelsPerInch() : double

public function set PixelsPerInch(value : double);

See Also

GeneralInputSettings Class
Altsoft.Publisher.Configuration Namespace


RasterWMF Property

GeneralInputSettings.RasterWMF Property
[image]

Supports WMF image format through rasterization.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RasterWMF As Boolean
C#
public bool RasterWMF { get; set; }
C++
public property bool RasterWMF sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_RasterWMF();

/** property */
public void set_RasterWMF(bool value);
JScript
public function get RasterWMF() : bool

public function set RasterWMF(value : bool);

See Also

GeneralInputSettings Class
Altsoft.Publisher.Configuration Namespace


GeneralOutputSettings Class

GeneralOutputSettings Class
See Also Example Members
[image]

Set of general output options.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class GeneralOutputSettings
Inherits Settings
C#
public class GeneralOutputSettings : Settings
C++
ref class GeneralOutputSettings : Settings
J#
public class GeneralOutputSettings extends Settings
JScript
public class GeneralOutputSettings extends Settings

Inheritance Hierarchy

System.Object
Altsoft.Publisher.Configuration.Settings
Altsoft.Publisher.Configuration.GeneralOutputSettings

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GeneralOutputSettings Members
Altsoft.Publisher.Configuration Namespace


GeneralOutputSettings Members

GeneralOutputSettings Members
See Also Example Properties Methods
[image]

Set of general output options.

The following tables list the members exposed by GeneralOutputSettings.

Public Properties

 | Name | Description
Public property | CreationTime | Frozen creation time.
Public property | DPI | Output resolution.
Public property | MakeDownsampling | Indicates whether images must be downsampled.
Public property | PageNumbering | Wheather to restart page numbering for every document in "Merge document" mode
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Set | (inherited from Settings)
Public method | ToString | (inherited from Settings)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

GeneralOutputSettings Class
Altsoft.Publisher.Configuration Namespace


Properties

GeneralOutputSettings Properties
[image]

Public Properties

 | Name | Description
Public property | CreationTime | Frozen creation time.
Public property | DPI | Output resolution.
Public property | MakeDownsampling | Indicates whether images must be downsampled.
Public property | PageNumbering | Wheather to restart page numbering for every document in "Merge document" mode
Top

See Also

GeneralOutputSettings Class
Altsoft.Publisher.Configuration Namespace


CreationTime Property

GeneralOutputSettings.CreationTime Property
[image]

Frozen creation time.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CreationTime As String
C#
public string CreationTime { get; set; }
C++
public property string CreationTime sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_CreationTime();

/** property */
public void set_CreationTime(string value);
JScript
public function get CreationTime() : String

public function set CreationTime(value : String);

Remarks

If you use this option the document creation time will be fixed. Otherwise, a document formatted several times will give a result different at the binary level.

See Also

GeneralOutputSettings Class
Altsoft.Publisher.Configuration Namespace


DPI Property

GeneralOutputSettings.DPI Property
[image]

Output resolution.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DPI As Double
C#
public double DPI { get; set; }
C++
public property double DPI sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_DPI();

/** property */
public void set_DPI(double value);
JScript
public function get DPI() : double

public function set DPI(value : double);

Remarks

In GDI+ based raster formats defines output image resolution. In all vector formats indicates maximal resultion for document downsampled images.

See Also

GeneralOutputSettings Class
Altsoft.Publisher.Configuration Namespace


MakeDownsampling Property

GeneralOutputSettings.MakeDownsampling Property
[image]

Indicates whether images must be downsampled.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MakeDownsampling As Boolean
C#
public bool MakeDownsampling { get; set; }
C++
public property bool MakeDownsampling sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_MakeDownsampling();

/** property */
public void set_MakeDownsampling(bool value);
JScript
public function get MakeDownsampling() : bool

public function set MakeDownsampling(value : bool);

See Also

GeneralOutputSettings Class
Altsoft.Publisher.Configuration Namespace


PageNumbering Property

GeneralOutputSettings.PageNumbering Property
[image]

Wheather to restart page numbering for every document in "Merge document" mode

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PageNumbering As String
C#
public string PageNumbering { get; set; }
C++
public property string PageNumbering sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_PageNumbering();

/** property */
public void set_PageNumbering(string value);
JScript
public function get PageNumbering() : String

public function set PageNumbering(value : String);

See Also

GeneralOutputSettings Class
Altsoft.Publisher.Configuration Namespace


HtmlInputSettings Class

HtmlInputSettings Class
See Also Example Members
[image]

HTML input options.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class HtmlInputSettings
Inherits Settings
C#
public class HtmlInputSettings : Settings
C++
ref class HtmlInputSettings : Settings
J#
public class HtmlInputSettings extends Settings
JScript
public class HtmlInputSettings extends Settings

Inheritance Hierarchy

System.Object
Altsoft.Publisher.Configuration.Settings
Altsoft.Publisher.Configuration.HtmlInputSettings

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

HtmlInputSettings Members
Altsoft.Publisher.Configuration Namespace


HtmlInputSettings Members

HtmlInputSettings Members
See Also Example Properties Methods
[image]

HTML input options.

The following tables list the members exposed by HtmlInputSettings.

Public Properties

 | Name | Description
Public property | BorderMedium | Value for border-width='medium' in points.
Public property | BorderThick | Value for border-width='thick' in points.
Public property | BorderThin | Value for border-width='thin' in points.
Public property | H1 | When set indicates to include <h1> in boookmarks.
Public property | H2 | When set indicates to include <h2> in boookmarks.
Public property | H3 | When set indicates to include <h3> ion boookmarks.
Public property | H4 | When set indicates to include <h4> ion boookmarks.
Public property | H5 | When set indicates to include <h5> ion boookmarks.
Public property | H6 | When set indicates to include <h6> ion boookmarks.
Public property | Media | Media type, on which document should be presented.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Set | (inherited from Settings)
Public method | ToString | (inherited from Settings)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

HtmlInputSettings Class
Altsoft.Publisher.Configuration Namespace


Properties

HtmlInputSettings Properties
[image]

Public Properties

 | Name | Description
Public property | BorderMedium | Value for border-width='medium' in points.
Public property | BorderThick | Value for border-width='thick' in points.
Public property | BorderThin | Value for border-width='thin' in points.
Public property | H1 | When set indicates to include <h1> in boookmarks.
Public property | H2 | When set indicates to include <h2> in boookmarks.
Public property | H3 | When set indicates to include <h3> ion boookmarks.
Public property | H4 | When set indicates to include <h4> ion boookmarks.
Public property | H5 | When set indicates to include <h5> ion boookmarks.
Public property | H6 | When set indicates to include <h6> ion boookmarks.
Public property | Media | Media type, on which document should be presented.
Top

See Also

HtmlInputSettings Class
Altsoft.Publisher.Configuration Namespace


BorderMedium Property

HtmlInputSettings.BorderMedium Property
[image]

Value for border-width='medium' in points.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BorderMedium As Double
C#
public double BorderMedium { get; set; }
C++
public property double BorderMedium sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_BorderMedium();

/** property */
public void set_BorderMedium(double value);
JScript
public function get BorderMedium() : double

public function set BorderMedium(value : double);

See Also

HtmlInputSettings Class
Altsoft.Publisher.Configuration Namespace


BorderThick Property

HtmlInputSettings.BorderThick Property
[image]

Value for border-width='thick' in points.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BorderThick As Double
C#
public double BorderThick { get; set; }
C++
public property double BorderThick sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_BorderThick();

/** property */
public void set_BorderThick(double value);
JScript
public function get BorderThick() : double

public function set BorderThick(value : double);

See Also

HtmlInputSettings Class
Altsoft.Publisher.Configuration Namespace


BorderThin Property

HtmlInputSettings.BorderThin Property
[image]

Value for border-width='thin' in points.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BorderThin As Double
C#
public double BorderThin { get; set; }
C++
public property double BorderThin sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_BorderThin();

/** property */
public void set_BorderThin(double value);
JScript
public function get BorderThin() : double

public function set BorderThin(value : double);

See Also

HtmlInputSettings Class
Altsoft.Publisher.Configuration Namespace


H1 Property

HtmlInputSettings.H1 Property
[image]

When set indicates to include <h1> in boookmarks.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property H1 As Boolean
C#
public bool H1 { get; set; }
C++
public property bool H1 sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_H1();

/** property */
public void set_H1(bool value);
JScript
public function get H1() : bool

public function set H1(value : bool);

See Also

HtmlInputSettings Class
Altsoft.Publisher.Configuration Namespace


H2 Property

HtmlInputSettings.H2 Property
[image]

When set indicates to include <h2> in boookmarks.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property H2 As Boolean
C#
public bool H2 { get; set; }
C++
public property bool H2 sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_H2();

/** property */
public void set_H2(bool value);
JScript
public function get H2() : bool

public function set H2(value : bool);

See Also

HtmlInputSettings Class
Altsoft.Publisher.Configuration Namespace


H3 Property

HtmlInputSettings.H3 Property
[image]

When set indicates to include <h3> ion boookmarks.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property H3 As Boolean
C#
public bool H3 { get; set; }
C++
public property bool H3 sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_H3();

/** property */
public void set_H3(bool value);
JScript
public function get H3() : bool

public function set H3(value : bool);

See Also

HtmlInputSettings Class
Altsoft.Publisher.Configuration Namespace


H4 Property

HtmlInputSettings.H4 Property
[image]

When set indicates to include <h4> ion boookmarks.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property H4 As Boolean
C#
public bool H4 { get; set; }
C++
public property bool H4 sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_H4();

/** property */
public void set_H4(bool value);
JScript
public function get H4() : bool

public function set H4(value : bool);

See Also

HtmlInputSettings Class
Altsoft.Publisher.Configuration Namespace


H5 Property

HtmlInputSettings.H5 Property
[image]

When set indicates to include <h5> ion boookmarks.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property H5 As Boolean
C#
public bool H5 { get; set; }
C++
public property bool H5 sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_H5();

/** property */
public void set_H5(bool value);
JScript
public function get H5() : bool

public function set H5(value : bool);

See Also

HtmlInputSettings Class
Altsoft.Publisher.Configuration Namespace


H6 Property

HtmlInputSettings.H6 Property
[image]

When set indicates to include <h6> ion boookmarks.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property H6 As Boolean
C#
public bool H6 { get; set; }
C++
public property bool H6 sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_H6();

/** property */
public void set_H6(bool value);
JScript
public function get H6() : bool

public function set H6(value : bool);

See Also

HtmlInputSettings Class
Altsoft.Publisher.Configuration Namespace


Media Property

HtmlInputSettings.Media Property
[image]

Media type, on which document should be presented.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Media As String
C#
public string Media { get; set; }
C++
public property string Media sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Media();

/** property */
public void set_Media(string value);
JScript
public function get Media() : String

public function set Media(value : String);

See Also

HtmlInputSettings Class
Altsoft.Publisher.Configuration Namespace


PageSettings Class

PageSettings Class
See Also Example Members
[image]

Page settings.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class PageSettings
Inherits Settings
C#
public class PageSettings : Settings
C++
ref class PageSettings : Settings
J#
public class PageSettings extends Settings
JScript
public class PageSettings extends Settings

Inheritance Hierarchy

System.Object
Altsoft.Publisher.Configuration.Settings
Altsoft.Publisher.Configuration.PageSettings

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PageSettings Members
Altsoft.Publisher.Configuration Namespace


PageSettings Members

PageSettings Members
See Also Example Properties Methods
[image]

Page settings.

The following tables list the members exposed by PageSettings.

Public Properties

 | Name | Description
Public property | CropBottom | Default value of the bottom page margin in points.
Public property | CropLeft | Default value of the left page margin in points.
Public property | CropRight | Default value of the right page margin in points.
Public property | CropTop | Default value of the top page margin in points.
Public property | Height | Default value of the page height in points.
Public property | Width | Default value of the page width in points.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Set | (inherited from Settings)
Public method | ToString | (inherited from Settings)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PageSettings Class
Altsoft.Publisher.Configuration Namespace


Properties

PageSettings Properties
[image]

Public Properties

 | Name | Description
Public property | CropBottom | Default value of the bottom page margin in points.
Public property | CropLeft | Default value of the left page margin in points.
Public property | CropRight | Default value of the right page margin in points.
Public property | CropTop | Default value of the top page margin in points.
Public property | Height | Default value of the page height in points.
Public property | Width | Default value of the page width in points.
Top

See Also

PageSettings Class
Altsoft.Publisher.Configuration Namespace


CropBottom Property

PageSettings.CropBottom Property
[image]

Default value of the bottom page margin in points.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CropBottom As Double
C#
public double CropBottom { get; set; }
C++
public property double CropBottom sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_CropBottom();

/** property */
public void set_CropBottom(double value);
JScript
public function get CropBottom() : double

public function set CropBottom(value : double);

See Also

PageSettings Class
Altsoft.Publisher.Configuration Namespace


CropLeft Property

PageSettings.CropLeft Property
[image]

Default value of the left page margin in points.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CropLeft As Double
C#
public double CropLeft { get; set; }
C++
public property double CropLeft sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_CropLeft();

/** property */
public void set_CropLeft(double value);
JScript
public function get CropLeft() : double

public function set CropLeft(value : double);

See Also

PageSettings Class
Altsoft.Publisher.Configuration Namespace


CropRight Property

PageSettings.CropRight Property
[image]

Default value of the right page margin in points.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CropRight As Double
C#
public double CropRight { get; set; }
C++
public property double CropRight sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_CropRight();

/** property */
public void set_CropRight(double value);
JScript
public function get CropRight() : double

public function set CropRight(value : double);

See Also

PageSettings Class
Altsoft.Publisher.Configuration Namespace


CropTop Property

PageSettings.CropTop Property
[image]

Default value of the top page margin in points.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CropTop As Double
C#
public double CropTop { get; set; }
C++
public property double CropTop sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_CropTop();

/** property */
public void set_CropTop(double value);
JScript
public function get CropTop() : double

public function set CropTop(value : double);

See Also

PageSettings Class
Altsoft.Publisher.Configuration Namespace


Height Property

PageSettings.Height Property
[image]

Default value of the page height in points.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As Double
C#
public double Height { get; set; }
C++
public property double Height sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_Height();

/** property */
public void set_Height(double value);
JScript
public function get Height() : double

public function set Height(value : double);

See Also

PageSettings Class
Altsoft.Publisher.Configuration Namespace


Width Property

PageSettings.Width Property
[image]

Default value of the page width in points.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As Double
C#
public double Width { get; set; }
C++
public property double Width sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_Width();

/** property */
public void set_Width(double value);
JScript
public function get Width() : double

public function set Width(value : double);

See Also

PageSettings Class
Altsoft.Publisher.Configuration Namespace


PDFConformance Enumeration

PDFConformance Enumeration
[image]

Available conformance levels.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enum PDFConformance
C#
public enum PDFConformance
C++
public enum class PDFConformance
J#
public enum PDFConformance
JScript
public enum PDFConformance

Members

Member Name | Description
Default |
PDFX_1_2001 |
PDFX_1a_2001 |
PDFX_1a_2003 |
PDFX_3_2002 |
PDFX_3_2003 |
PDFX_4 |
PDFA_1a |
PDFA_1b |

See Also

Altsoft.Publisher.Configuration Namespace


PdfOutputSettings Class

PdfOutputSettings Class
See Also Example Members
[image]

PDF output settings.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class PdfOutputSettings
Inherits Settings
C#
public class PdfOutputSettings : Settings
C++
ref class PdfOutputSettings : Settings
J#
public class PdfOutputSettings extends Settings
JScript
public class PdfOutputSettings extends Settings

Inheritance Hierarchy

System.Object
Altsoft.Publisher.Configuration.Settings
Altsoft.Publisher.Configuration.PdfOutputSettings

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PdfOutputSettings Members
Altsoft.Publisher.Configuration Namespace


PdfOutputSettings Members

PdfOutputSettings Members
See Also Example Properties Methods
[image]

PDF output settings.

The following tables list the members exposed by PdfOutputSettings.

Public Properties

 | Name | Description
Public property | Conformance | Output PDF conformance level.
Public property | EmbedCMAP |
Public property | EmbedFonts |
Public property | IgnoreImageOpacity | Ignores opacity in source images.
Public property | Profile | Path to the output ICC profile file.
Public property | RegistryName | Internationally known name of the output ICC profile.
Public property | SubsetFonts |
Public property | UseAnsiEncoding |
Public property | UseBookmarks | Gets or sets value that indicates whether bookmarks should be used in output PDF document
Public property | UseCompression |
Public property | UseStdType1 | Allows to use standard PDF Type1 fonts.
Public property | UseStdType1Only | Prevents from using fonts different from standard PDF Type1.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Set | (inherited from Settings)
Public method | ToString | (inherited from Settings)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PdfOutputSettings Class
Altsoft.Publisher.Configuration Namespace


Properties

PdfOutputSettings Properties
[image]

Public Properties

 | Name | Description
Public property | Conformance | Output PDF conformance level.
Public property | EmbedCMAP |
Public property | EmbedFonts |
Public property | IgnoreImageOpacity | Ignores opacity in source images.
Public property | Profile | Path to the output ICC profile file.
Public property | RegistryName | Internationally known name of the output ICC profile.
Public property | SubsetFonts |
Public property | UseAnsiEncoding |
Public property | UseBookmarks | Gets or sets value that indicates whether bookmarks should be used in output PDF document
Public property | UseCompression |
Public property | UseStdType1 | Allows to use standard PDF Type1 fonts.
Public property | UseStdType1Only | Prevents from using fonts different from standard PDF Type1.
Top

See Also

PdfOutputSettings Class
Altsoft.Publisher.Configuration Namespace


Conformance Property

PdfOutputSettings.Conformance Property
[image]

Output PDF conformance level.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Conformance As PDFConformance
C#
public PDFConformance Conformance { get; set; }
C++
public property PDFConformance Conformance sealed {
PDFConformance get();
void set(PDFConformance value);
}
J#
/** property */
public PDFConformance get_Conformance();

/** property */
public void set_Conformance(PDFConformance value);
JScript
public function get Conformance() : PDFConformance

public function set Conformance(value : PDFConformance);

Remarks

You can set the following values:

  • default
  • pdf/x_1a_2001
  • pdf/x_1a_2003
  • pdf/x_3_2002
  • pdf/x_3_2003
  • pdf/a_1a
  • pdf/a_1b

See Also

PdfOutputSettings Class
Altsoft.Publisher.Configuration Namespace


EmbedCMAP Property

PdfOutputSettings.EmbedCMAP Property
[image]

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property EmbedCMAP As Boolean
C#
public bool EmbedCMAP { get; set; }
C++
public property bool EmbedCMAP sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_EmbedCMAP();

/** property */
public void set_EmbedCMAP(bool value);
JScript
public function get EmbedCMAP() : bool

public function set EmbedCMAP(value : bool);

See Also

PdfOutputSettings Class
Altsoft.Publisher.Configuration Namespace


EmbedFonts Property

PdfOutputSettings.EmbedFonts Property
[image]

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property EmbedFonts As Boolean
C#
public bool EmbedFonts { get; set; }
C++
public property bool EmbedFonts sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_EmbedFonts();

/** property */
public void set_EmbedFonts(bool value);
JScript
public function get EmbedFonts() : bool

public function set EmbedFonts(value : bool);

See Also

PdfOutputSettings Class
Altsoft.Publisher.Configuration Namespace


IgnoreImageOpacity Property

PdfOutputSettings.IgnoreImageOpacity Property
[image]

Ignores opacity in source images.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IgnoreImageOpacity As Boolean
C#
public bool IgnoreImageOpacity { get; set; }
C++
public property bool IgnoreImageOpacity sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IgnoreImageOpacity();

/** property */
public void set_IgnoreImageOpacity(bool value);
JScript
public function get IgnoreImageOpacity() : bool

public function set IgnoreImageOpacity(value : bool);

Remarks

Xml2PDF assumes that input images haven't got transparency.

See Also

PdfOutputSettings Class
Altsoft.Publisher.Configuration Namespace


Profile Property

PdfOutputSettings.Profile Property
[image]

Path to the output ICC profile file.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Profile As String
C#
public string Profile { get; set; }
C++
public property string Profile sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Profile();

/** property */
public void set_Profile(string value);
JScript
public function get Profile() : String

public function set Profile(value : String);

Remarks

Works together with Conformance option.

See Also

PdfOutputSettings Class
Altsoft.Publisher.Configuration Namespace


RegistryName Property

PdfOutputSettings.RegistryName Property
[image]

Internationally known name of the output ICC profile.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RegistryName As String
C#
public string RegistryName { get; set; }
C++
public property string RegistryName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_RegistryName();

/** property */
public void set_RegistryName(string value);
JScript
public function get RegistryName() : String

public function set RegistryName(value : String);

See Also

PdfOutputSettings Class
Altsoft.Publisher.Configuration Namespace


SubsetFonts Property

PdfOutputSettings.SubsetFonts Property
[image]

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SubsetFonts As Boolean
C#
public bool SubsetFonts { get; set; }
C++
public property bool SubsetFonts sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SubsetFonts();

/** property */
public void set_SubsetFonts(bool value);
JScript
public function get SubsetFonts() : bool

public function set SubsetFonts(value : bool);

See Also

PdfOutputSettings Class
Altsoft.Publisher.Configuration Namespace


UseAnsiEncoding Property

PdfOutputSettings.UseAnsiEncoding Property
[image]

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UseAnsiEncoding As Boolean
C#
public bool UseAnsiEncoding { get; set; }
C++
public property bool UseAnsiEncoding sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_UseAnsiEncoding();

/** property */
public void set_UseAnsiEncoding(bool value);
JScript
public function get UseAnsiEncoding() : bool

public function set UseAnsiEncoding(value : bool);

See Also

PdfOutputSettings Class
Altsoft.Publisher.Configuration Namespace


UseBookmarks Property

PdfOutputSettings.UseBookmarks Property
[image]

Gets or sets value that indicates whether bookmarks should be used in output PDF document

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UseBookmarks As Boolean
C#
public bool UseBookmarks { get; set; }
C++
public property bool UseBookmarks sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_UseBookmarks();

/** property */
public void set_UseBookmarks(bool value);
JScript
public function get UseBookmarks() : bool

public function set UseBookmarks(value : bool);

See Also

PdfOutputSettings Class
Altsoft.Publisher.Configuration Namespace


UseCompression Property

PdfOutputSettings.UseCompression Property
[image]

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UseCompression As Boolean
C#
public bool UseCompression { get; set; }
C++
public property bool UseCompression sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_UseCompression();

/** property */
public void set_UseCompression(bool value);
JScript
public function get UseCompression() : bool

public function set UseCompression(value : bool);

See Also

PdfOutputSettings Class
Altsoft.Publisher.Configuration Namespace


UseStdType1 Property

PdfOutputSettings.UseStdType1 Property
[image]

Allows to use standard PDF Type1 fonts.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UseStdType1 As Boolean
C#
public bool UseStdType1 { get; set; }
C++
public property bool UseStdType1 sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_UseStdType1();

/** property */
public void set_UseStdType1(bool value);
JScript
public function get UseStdType1() : bool

public function set UseStdType1(value : bool);

See Also

PdfOutputSettings Class
Altsoft.Publisher.Configuration Namespace


UseStdType1Only Property

PdfOutputSettings.UseStdType1Only Property
[image]

Prevents from using fonts different from standard PDF Type1.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UseStdType1Only As Boolean
C#
public bool UseStdType1Only { get; set; }
C++
public property bool UseStdType1Only sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_UseStdType1Only();

/** property */
public void set_UseStdType1Only(bool value);
JScript
public function get UseStdType1Only() : bool

public function set UseStdType1Only(value : bool);

See Also

PdfOutputSettings Class
Altsoft.Publisher.Configuration Namespace


PSOutputSettings Class

PSOutputSettings Class
See Also Example Members
[image]

PS output settings.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class PSOutputSettings
Inherits Settings
C#
public class PSOutputSettings : Settings
C++
ref class PSOutputSettings : Settings
J#
public class PSOutputSettings extends Settings
JScript
public class PSOutputSettings extends Settings

Inheritance Hierarchy

System.Object
Altsoft.Publisher.Configuration.Settings
Altsoft.Publisher.Configuration.PSOutputSettings

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PSOutputSettings Members
Altsoft.Publisher.Configuration Namespace


PSOutputSettings Members

PSOutputSettings Members
See Also Example Properties Methods
[image]

PS output settings.

The following tables list the members exposed by PSOutputSettings.

Public Properties

 | Name | Description
Public property | EmbedTrueTypeFonts | Indicates whether to embed True Type Fonts.
Public property | EmbedType1Fonts | Indicates whether to embed fonts type 1.
Public property | SubsetFonts | Indicates whether to embed fonts as base64 to output files.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Set | (inherited from Settings)
Public method | ToString | (inherited from Settings)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PSOutputSettings Class
Altsoft.Publisher.Configuration Namespace


Properties

PSOutputSettings Properties
[image]

Public Properties

 | Name | Description
Public property | EmbedTrueTypeFonts | Indicates whether to embed True Type Fonts.
Public property | EmbedType1Fonts | Indicates whether to embed fonts type 1.
Public property | SubsetFonts | Indicates whether to embed fonts as base64 to output files.
Top

See Also

PSOutputSettings Class
Altsoft.Publisher.Configuration Namespace


EmbedTrueTypeFonts Property

PSOutputSettings.EmbedTrueTypeFonts Property
[image]

Indicates whether to embed True Type Fonts.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property EmbedTrueTypeFonts As Boolean
C#
public bool EmbedTrueTypeFonts { get; set; }
C++
public property bool EmbedTrueTypeFonts sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_EmbedTrueTypeFonts();

/** property */
public void set_EmbedTrueTypeFonts(bool value);
JScript
public function get EmbedTrueTypeFonts() : bool

public function set EmbedTrueTypeFonts(value : bool);

Remarks

When this option isn't set path to the file is written.

See Also

PSOutputSettings Class
Altsoft.Publisher.Configuration Namespace


EmbedType1Fonts Property

PSOutputSettings.EmbedType1Fonts Property
[image]

Indicates whether to embed fonts type 1.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property EmbedType1Fonts As Boolean
C#
public bool EmbedType1Fonts { get; set; }
C++
public property bool EmbedType1Fonts sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_EmbedType1Fonts();

/** property */
public void set_EmbedType1Fonts(bool value);
JScript
public function get EmbedType1Fonts() : bool

public function set EmbedType1Fonts(value : bool);

Remarks

When this option isn't set path to the file is written.

See Also

PSOutputSettings Class
Altsoft.Publisher.Configuration Namespace


SubsetFonts Property

PSOutputSettings.SubsetFonts Property
[image]

Indicates whether to embed fonts as base64 to output files.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SubsetFonts As Boolean
C#
public bool SubsetFonts { get; set; }
C++
public property bool SubsetFonts sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SubsetFonts();

/** property */
public void set_SubsetFonts(bool value);
JScript
public function get SubsetFonts() : bool

public function set SubsetFonts(value : bool);

Remarks

When this option isn't set path to the file is written.

See Also

PSOutputSettings Class
Altsoft.Publisher.Configuration Namespace


SecuritySettings Class

SecuritySettings Class
See Also Example Members
[image]

Security options.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SecuritySettings
Inherits Settings
C#
public class SecuritySettings : Settings
C++
ref class SecuritySettings : Settings
J#
public class SecuritySettings extends Settings
JScript
public class SecuritySettings extends Settings

Inheritance Hierarchy

System.Object
Altsoft.Publisher.Configuration.Settings
Altsoft.Publisher.Configuration.SecuritySettings

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SecuritySettings Members
Altsoft.Publisher.Configuration Namespace


SecuritySettings Members

SecuritySettings Members
See Also Example Properties Methods
[image]

Security options.

The following tables list the members exposed by SecuritySettings.

Public Properties

 | Name | Description
Public property | CanExtract | Allows to extract digital information from the output document.
Public property | CanModify | Allows to modify output document.
Public property | CanPrint | Allows to print output document.
Public property | CanPrintHQ | Allows high quality printing of the output document.
Public property | CertificatePassword | Password to the signer's certificate.
Public property | CertificatePath | Path to the signer's certificate (*.pfx).
Public property | OwnerPassword | Owner password.
Public property | SignerContactInfo | Signer's contact information.
Public property | SignerLocation | Signer's location.
Public property | SignerName | Signer's name.
Public property | SigningReason | Signature description.
Public property | UserPassword | User password.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Set | (inherited from Settings)
Public method | ToString | (inherited from Settings)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SecuritySettings Class
Altsoft.Publisher.Configuration Namespace


Properties

SecuritySettings Properties
[image]

Public Properties

 | Name | Description
Public property | CanExtract | Allows to extract digital information from the output document.
Public property | CanModify | Allows to modify output document.
Public property | CanPrint | Allows to print output document.
Public property | CanPrintHQ | Allows high quality printing of the output document.
Public property | CertificatePassword | Password to the signer's certificate.
Public property | CertificatePath | Path to the signer's certificate (*.pfx).
Public property | OwnerPassword | Owner password.
Public property | SignerContactInfo | Signer's contact information.
Public property | SignerLocation | Signer's location.
Public property | SignerName | Signer's name.
Public property | SigningReason | Signature description.
Public property | UserPassword | User password.
Top

See Also

SecuritySettings Class
Altsoft.Publisher.Configuration Namespace


CanExtract Property

SecuritySettings.CanExtract Property
[image]

Allows to extract digital information from the output document.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CanExtract As Boolean
C#
public bool CanExtract { get; set; }
C++
public property bool CanExtract sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_CanExtract();

/** property */
public void set_CanExtract(bool value);
JScript
public function get CanExtract() : bool

public function set CanExtract(value : bool);

See Also

SecuritySettings Class
Altsoft.Publisher.Configuration Namespace


CanModify Property

SecuritySettings.CanModify Property
[image]

Allows to modify output document.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CanModify As Boolean
C#
public bool CanModify { get; set; }
C++
public property bool CanModify sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_CanModify();

/** property */
public void set_CanModify(bool value);
JScript
public function get CanModify() : bool

public function set CanModify(value : bool);

See Also

SecuritySettings Class
Altsoft.Publisher.Configuration Namespace


CanPrint Property

SecuritySettings.CanPrint Property
[image]

Allows to print output document.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CanPrint As Boolean
C#
public bool CanPrint { get; set; }
C++
public property bool CanPrint sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_CanPrint();

/** property */
public void set_CanPrint(bool value);
JScript
public function get CanPrint() : bool

public function set CanPrint(value : bool);

See Also

SecuritySettings Class
Altsoft.Publisher.Configuration Namespace


CanPrintHQ Property

SecuritySettings.CanPrintHQ Property
[image]

Allows high quality printing of the output document.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CanPrintHQ As Boolean
C#
public bool CanPrintHQ { get; set; }
C++
public property bool CanPrintHQ sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_CanPrintHQ();

/** property */
public void set_CanPrintHQ(bool value);
JScript
public function get CanPrintHQ() : bool

public function set CanPrintHQ(value : bool);

Remarks

This option prevents from making a faithful digital copy of the output document.

See Also

SecuritySettings Class
Altsoft.Publisher.Configuration Namespace


CertificatePassword Property

SecuritySettings.CertificatePassword Property
[image]

Password to the signer's certificate.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CertificatePassword As String
C#
public string CertificatePassword { get; set; }
C++
public property string CertificatePassword sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_CertificatePassword();

/** property */
public void set_CertificatePassword(string value);
JScript
public function get CertificatePassword() : String

public function set CertificatePassword(value : String);

Remarks

You can use document signatures only for PDF and XPS output.

See Also

SecuritySettings Class
Altsoft.Publisher.Configuration Namespace


CertificatePath Property

SecuritySettings.CertificatePath Property
[image]

Path to the signer's certificate (*.pfx).

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CertificatePath As String
C#
public string CertificatePath { get; set; }
C++
public property string CertificatePath sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_CertificatePath();

/** property */
public void set_CertificatePath(string value);
JScript
public function get CertificatePath() : String

public function set CertificatePath(value : String);

Remarks

You can use document signatures only for PDF and XPS output.

See Also

SecuritySettings Class
Altsoft.Publisher.Configuration Namespace


OwnerPassword Property

SecuritySettings.OwnerPassword Property
[image]

Owner password.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property OwnerPassword As String
C#
public string OwnerPassword { get; set; }
C++
public property string OwnerPassword sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_OwnerPassword();

/** property */
public void set_OwnerPassword(string value);
JScript
public function get OwnerPassword() : String

public function set OwnerPassword(value : String);

Remarks

Password reqiured to change the document security options.

If only document permissions are set and the owner password is not specified it will be random.

You can use passwords only for PDF output.

See Also

SecuritySettings Class
Altsoft.Publisher.Configuration Namespace


SignerContactInfo Property

SecuritySettings.SignerContactInfo Property
[image]

Signer's contact information.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SignerContactInfo As String
C#
public string SignerContactInfo { get; set; }
C++
public property string SignerContactInfo sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SignerContactInfo();

/** property */
public void set_SignerContactInfo(string value);
JScript
public function get SignerContactInfo() : String

public function set SignerContactInfo(value : String);

Remarks

You can use document signatures only for PDF and XPS output.

See Also

SecuritySettings Class
Altsoft.Publisher.Configuration Namespace


SignerLocation Property

SecuritySettings.SignerLocation Property
[image]

Signer's location.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SignerLocation As String
C#
public string SignerLocation { get; set; }
C++
public property string SignerLocation sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SignerLocation();

/** property */
public void set_SignerLocation(string value);
JScript
public function get SignerLocation() : String

public function set SignerLocation(value : String);

Remarks

You can use document signatures only for PDF and XPS output.

See Also

SecuritySettings Class
Altsoft.Publisher.Configuration Namespace


SignerName Property

SecuritySettings.SignerName Property
[image]

Signer's name.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SignerName As String
C#
public string SignerName { get; set; }
C++
public property string SignerName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SignerName();

/** property */
public void set_SignerName(string value);
JScript
public function get SignerName() : String

public function set SignerName(value : String);

Remarks

You can use document signatures only for PDF and XPS output.

See Also

SecuritySettings Class
Altsoft.Publisher.Configuration Namespace


SigningReason Property

SecuritySettings.SigningReason Property
[image]

Signature description.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SigningReason As String
C#
public string SigningReason { get; set; }
C++
public property string SigningReason sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SigningReason();

/** property */
public void set_SigningReason(string value);
JScript
public function get SigningReason() : String

public function set SigningReason(value : String);

Remarks

You can use document signatures only for PDF and XPS output.

See Also

SecuritySettings Class
Altsoft.Publisher.Configuration Namespace


UserPassword Property

SecuritySettings.UserPassword Property
[image]

User password.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UserPassword As String
C#
public string UserPassword { get; set; }
C++
public property string UserPassword sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_UserPassword();

/** property */
public void set_UserPassword(string value);
JScript
public function get UserPassword() : String

public function set UserPassword(value : String);

Remarks

Password required to view the document.

You can use passwords only for PDF output.

See Also

SecuritySettings Class
Altsoft.Publisher.Configuration Namespace


Settings Class

Settings Class
See Also Example Members
[image]

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<TypeDescriptionProviderAttribute(GetType(Settings_x002B_n10E2))>
Public MustInherit Class Settings
C#
[TypeDescriptionProviderAttribute(typeof(Settings_x002B_n10E2))]
public abstract class Settings
C++
[TypeDescriptionProviderAttribute(typeof(Settings_x002B_n10E2))]
ref class Settings abstract
J#
/** @attribute TypeDescriptionProviderAttribute(typeof(Settings_x002B_n10E2)) */
public class Settings
JScript
public
TypeDescriptionProviderAttribute(typeof(Settings_x002B_n10E2))
class Settings

Inheritance Hierarchy

System.Object
Altsoft.Publisher.Configuration.Settings
Derived types

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Settings Members
Altsoft.Publisher.Configuration Namespace


Settings Members

Settings Members
See Also Example Methods
[image]

The following tables list the members exposed by Settings.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Set |
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Settings Class
Altsoft.Publisher.Configuration Namespace


Methods

Settings Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Set |
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Settings Class
Altsoft.Publisher.Configuration Namespace


Set Method

Settings.Set Method
[image]

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Set( _
ByVal src As Settings _
)
C#
public void Set(
Settings src
)
C++
public:
void Set(
Settings src
) sealed
J#
public void Set(
Settings src
)
JScript
public function Set(
src : Settings
)

See Also

Settings Class
Altsoft.Publisher.Configuration Namespace


ToString Method

Settings.ToString Method
[image]

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

See Also

Settings Class
Altsoft.Publisher.Configuration Namespace


SvgInputSettings Class

SvgInputSettings Class
See Also Example Members
[image]

SVG input options.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SvgInputSettings
Inherits Settings
C#
public class SvgInputSettings : Settings
C++
ref class SvgInputSettings : Settings
J#
public class SvgInputSettings extends Settings
JScript
public class SvgInputSettings extends Settings

Inheritance Hierarchy

System.Object
Altsoft.Publisher.Configuration.Settings
Altsoft.Publisher.Configuration.SvgInputSettings

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SvgInputSettings Members
Altsoft.Publisher.Configuration Namespace


SvgInputSettings Members

SvgInputSettings Members
See Also Example Properties Methods
[image]

SVG input options.

The following tables list the members exposed by SvgInputSettings.

Public Properties

 | Name | Description
Public property | PrintNotFound | When set indicates to show not found images as red crosses.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Set | (inherited from Settings)
Public method | ToString | (inherited from Settings)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SvgInputSettings Class
Altsoft.Publisher.Configuration Namespace


Properties

SvgInputSettings Properties
[image]

Public Properties

 | Name | Description
Public property | PrintNotFound | When set indicates to show not found images as red crosses.
Top

See Also

SvgInputSettings Class
Altsoft.Publisher.Configuration Namespace


PrintNotFound Property

SvgInputSettings.PrintNotFound Property
[image]

When set indicates to show not found images as red crosses.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PrintNotFound As Boolean
C#
public bool PrintNotFound { get; set; }
C++
public property bool PrintNotFound sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_PrintNotFound();

/** property */
public void set_PrintNotFound(bool value);
JScript
public function get PrintNotFound() : bool

public function set PrintNotFound(value : bool);

See Also

SvgInputSettings Class
Altsoft.Publisher.Configuration Namespace


TIFFOutputSettings Class

TIFFOutputSettings Class
See Also Example Members
[image]

TIFF output settings.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class TIFFOutputSettings
Inherits Settings
C#
public class TIFFOutputSettings : Settings
C++
ref class TIFFOutputSettings : Settings
J#
public class TIFFOutputSettings extends Settings
JScript
public class TIFFOutputSettings extends Settings

Inheritance Hierarchy

System.Object
Altsoft.Publisher.Configuration.Settings
Altsoft.Publisher.Configuration.TIFFOutputSettings

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

TIFFOutputSettings Members
Altsoft.Publisher.Configuration Namespace


TIFFOutputSettings Members

TIFFOutputSettings Members
See Also Example Properties Methods
[image]

TIFF output settings.

The following tables list the members exposed by TIFFOutputSettings.

Public Properties

 | Name | Description
Public property | Compression | TIFF compression type.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Set | (inherited from Settings)
Public method | ToString | (inherited from Settings)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TIFFOutputSettings Class
Altsoft.Publisher.Configuration Namespace


Properties

TIFFOutputSettings Properties
[image]

Public Properties

 | Name | Description
Public property | Compression | TIFF compression type.
Top

See Also

TIFFOutputSettings Class
Altsoft.Publisher.Configuration Namespace


Compression Property

TIFFOutputSettings.Compression Property
[image]

TIFF compression type.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Compression As EncoderValue
C#
public EncoderValue Compression { get; set; }
C++
public property EncoderValue Compression sealed {
EncoderValue get();
void set(EncoderValue value);
}
J#
/** property */
public EncoderValue get_Compression();

/** property */
public void set_Compression(EncoderValue value);
JScript
public function get Compression() : EncoderValue

public function set Compression(value : EncoderValue);

Remarks

You can set the following values:

  • None
  • LZW
  • Rle
  • CCITT3
  • CCITT4

See Also

TIFFOutputSettings Class
Altsoft.Publisher.Configuration Namespace


WordInputSettings Class

WordInputSettings Class
See Also Example Members
[image]

Word input options.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class WordInputSettings
Inherits Settings
C#
public class WordInputSettings : Settings
C++
ref class WordInputSettings : Settings
J#
public class WordInputSettings extends Settings
JScript
public class WordInputSettings extends Settings

Inheritance Hierarchy

System.Object
Altsoft.Publisher.Configuration.Settings
Altsoft.Publisher.Configuration.WordInputSettings

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

WordInputSettings Members
Altsoft.Publisher.Configuration Namespace


WordInputSettings Members

WordInputSettings Members
See Also Example Properties Methods
[image]

Word input options.

The following tables list the members exposed by WordInputSettings.

Public Properties

 | Name | Description
Public property | BookmarksSource | What used for bookmarks generation.
Public property | CanNotEndLine | It's the set of characters after which line-break can not be done.
Public property | CanNotStartLine | It's the set of characters that can not start new line.
Public property | UpdateFields | Updates fields before printing.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Set | (inherited from Settings)
Public method | ToString | (inherited from Settings)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

WordInputSettings Class
Altsoft.Publisher.Configuration Namespace


Properties

WordInputSettings Properties
[image]

Public Properties

 | Name | Description
Public property | BookmarksSource | What used for bookmarks generation.
Public property | CanNotEndLine | It's the set of characters after which line-break can not be done.
Public property | CanNotStartLine | It's the set of characters that can not start new line.
Public property | UpdateFields | Updates fields before printing.
Top

See Also

WordInputSettings Class
Altsoft.Publisher.Configuration Namespace


BookmarksSource Property

WordInputSettings.BookmarksSource Property
[image]

What used for bookmarks generation.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BookmarksSource As String
C#
public string BookmarksSource { get; set; }
C++
public property string BookmarksSource sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_BookmarksSource();

/** property */
public void set_BookmarksSource(string value);
JScript
public function get BookmarksSource() : String

public function set BookmarksSource(value : String);

See Also

WordInputSettings Class
Altsoft.Publisher.Configuration Namespace


CanNotEndLine Property

WordInputSettings.CanNotEndLine Property
[image]

It's the set of characters after which line-break can not be done.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CanNotEndLine As String
C#
public string CanNotEndLine { get; set; }
C++
public property string CanNotEndLine sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_CanNotEndLine();

/** property */
public void set_CanNotEndLine(string value);
JScript
public function get CanNotEndLine() : String

public function set CanNotEndLine(value : String);

See Also

WordInputSettings Class
Altsoft.Publisher.Configuration Namespace


CanNotStartLine Property

WordInputSettings.CanNotStartLine Property
[image]

It's the set of characters that can not start new line.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CanNotStartLine As String
C#
public string CanNotStartLine { get; set; }
C++
public property string CanNotStartLine sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_CanNotStartLine();

/** property */
public void set_CanNotStartLine(string value);
JScript
public function get CanNotStartLine() : String

public function set CanNotStartLine(value : String);

See Also

WordInputSettings Class
Altsoft.Publisher.Configuration Namespace


UpdateFields Property

WordInputSettings.UpdateFields Property
[image]

Updates fields before printing.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UpdateFields As Boolean
C#
public bool UpdateFields { get; set; }
C++
public property bool UpdateFields sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_UpdateFields();

/** property */
public void set_UpdateFields(bool value);
JScript
public function get UpdateFields() : bool

public function set UpdateFields(value : bool);

See Also

WordInputSettings Class
Altsoft.Publisher.Configuration Namespace


WordMetadataSettings Class

WordMetadataSettings Class
See Also Example Members
[image]

Word metadata options.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class WordMetadataSettings
Inherits Settings
C#
public class WordMetadataSettings : Settings
C++
ref class WordMetadataSettings : Settings
J#
public class WordMetadataSettings extends Settings
JScript
public class WordMetadataSettings extends Settings

Inheritance Hierarchy

System.Object
Altsoft.Publisher.Configuration.Settings
Altsoft.Publisher.Configuration.WordMetadataSettings

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

WordMetadataSettings Members
Altsoft.Publisher.Configuration Namespace


WordMetadataSettings Members

WordMetadataSettings Members
See Also Example Properties Methods
[image]

Word metadata options.

The following tables list the members exposed by WordMetadataSettings.

Public Properties

 | Name | Description
Public property | AuthorMetadata | Defines a string, which be placed in author field in PDF document info
Public property | KeywordsMetadata | Defines a string, which be placed in Keywords field in PDF document info
Public property | SubjectMetadata | Defines a string, which be placed in Subject field in PDF document info
Public property | TitleMetadata | Defines a string, which be placed in Title field in PDF document info
Public property | UseDocumentMetadata | Use document metadata (title,author, etc) when saving to PDF
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Set | (inherited from Settings)
Public method | ToString | (inherited from Settings)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

WordMetadataSettings Class
Altsoft.Publisher.Configuration Namespace


Properties

WordMetadataSettings Properties
[image]

Public Properties

 | Name | Description
Public property | AuthorMetadata | Defines a string, which be placed in author field in PDF document info
Public property | KeywordsMetadata | Defines a string, which be placed in Keywords field in PDF document info
Public property | SubjectMetadata | Defines a string, which be placed in Subject field in PDF document info
Public property | TitleMetadata | Defines a string, which be placed in Title field in PDF document info
Public property | UseDocumentMetadata | Use document metadata (title,author, etc) when saving to PDF
Top

See Also

WordMetadataSettings Class
Altsoft.Publisher.Configuration Namespace


AuthorMetadata Property

WordMetadataSettings.AuthorMetadata Property
[image]

Defines a string, which be placed in author field in PDF document info

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AuthorMetadata As String
C#
public string AuthorMetadata { get; set; }
C++
public property string AuthorMetadata sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_AuthorMetadata();

/** property */
public void set_AuthorMetadata(string value);
JScript
public function get AuthorMetadata() : String

public function set AuthorMetadata(value : String);

See Also

WordMetadataSettings Class
Altsoft.Publisher.Configuration Namespace


KeywordsMetadata Property

WordMetadataSettings.KeywordsMetadata Property
[image]

Defines a string, which be placed in Keywords field in PDF document info

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property KeywordsMetadata As String
C#
public string KeywordsMetadata { get; set; }
C++
public property string KeywordsMetadata sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_KeywordsMetadata();

/** property */
public void set_KeywordsMetadata(string value);
JScript
public function get KeywordsMetadata() : String

public function set KeywordsMetadata(value : String);

See Also

WordMetadataSettings Class
Altsoft.Publisher.Configuration Namespace


SubjectMetadata Property

WordMetadataSettings.SubjectMetadata Property
[image]

Defines a string, which be placed in Subject field in PDF document info

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SubjectMetadata As String
C#
public string SubjectMetadata { get; set; }
C++
public property string SubjectMetadata sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SubjectMetadata();

/** property */
public void set_SubjectMetadata(string value);
JScript
public function get SubjectMetadata() : String

public function set SubjectMetadata(value : String);

See Also

WordMetadataSettings Class
Altsoft.Publisher.Configuration Namespace


TitleMetadata Property

WordMetadataSettings.TitleMetadata Property
[image]

Defines a string, which be placed in Title field in PDF document info

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TitleMetadata As String
C#
public string TitleMetadata { get; set; }
C++
public property string TitleMetadata sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_TitleMetadata();

/** property */
public void set_TitleMetadata(string value);
JScript
public function get TitleMetadata() : String

public function set TitleMetadata(value : String);

See Also

WordMetadataSettings Class
Altsoft.Publisher.Configuration Namespace


UseDocumentMetadata Property

WordMetadataSettings.UseDocumentMetadata Property
[image]

Use document metadata (title,author, etc) when saving to PDF

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UseDocumentMetadata As Boolean
C#
public bool UseDocumentMetadata { get; set; }
C++
public property bool UseDocumentMetadata sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_UseDocumentMetadata();

/** property */
public void set_UseDocumentMetadata(bool value);
JScript
public function get UseDocumentMetadata() : bool

public function set UseDocumentMetadata(value : bool);

See Also

WordMetadataSettings Class
Altsoft.Publisher.Configuration Namespace


XPSOutputSettings Class

XPSOutputSettings Class
See Also Example Members
[image]

PS output settings.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class XPSOutputSettings
Inherits Settings
C#
public class XPSOutputSettings : Settings
C++
ref class XPSOutputSettings : Settings
J#
public class XPSOutputSettings extends Settings
JScript
public class XPSOutputSettings extends Settings

Inheritance Hierarchy

System.Object
Altsoft.Publisher.Configuration.Settings
Altsoft.Publisher.Configuration.XPSOutputSettings

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

XPSOutputSettings Members
Altsoft.Publisher.Configuration Namespace


XPSOutputSettings Members

XPSOutputSettings Members
See Also Example Properties Methods
[image]

PS output settings.

The following tables list the members exposed by XPSOutputSettings.

Public Properties

 | Name | Description
Public property | ObfuscateFonts | Obfuscate fonts.
Public property | SubsetFonts | Indicates whether to embed fonts as base64 to output files.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Set | (inherited from Settings)
Public method | ToString | (inherited from Settings)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

XPSOutputSettings Class
Altsoft.Publisher.Configuration Namespace


Properties

XPSOutputSettings Properties
[image]

Public Properties

 | Name | Description
Public property | ObfuscateFonts | Obfuscate fonts.
Public property | SubsetFonts | Indicates whether to embed fonts as base64 to output files.
Top

See Also

XPSOutputSettings Class
Altsoft.Publisher.Configuration Namespace


ObfuscateFonts Property

XPSOutputSettings.ObfuscateFonts Property
[image]

Obfuscate fonts.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObfuscateFonts As Boolean
C#
public bool ObfuscateFonts { get; set; }
C++
public property bool ObfuscateFonts sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ObfuscateFonts();

/** property */
public void set_ObfuscateFonts(bool value);
JScript
public function get ObfuscateFonts() : bool

public function set ObfuscateFonts(value : bool);

Remarks

This option turns on font obfuscation. It is strogly recommended to be turn on.

See Also

XPSOutputSettings Class
Altsoft.Publisher.Configuration Namespace


SubsetFonts Property

XPSOutputSettings.SubsetFonts Property
[image]

Indicates whether to embed fonts as base64 to output files.

Namespace: Altsoft.Publisher.Configuration
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SubsetFonts As Boolean
C#
public bool SubsetFonts { get; set; }
C++
public property bool SubsetFonts sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SubsetFonts();

/** property */
public void set_SubsetFonts(bool value);
JScript
public function get SubsetFonts() : bool

public function set SubsetFonts(value : bool);

Remarks

When this option isn't set path to the file is written.

See Also

XPSOutputSettings Class
Altsoft.Publisher.Configuration Namespace


Altsoft.Publisher.Exceptions

Altsoft.Publisher.Exceptions Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | APDestinationException | Base class for destination-specific exceptions in Altsoft Xml2PDF.
Public class | APException | Base class for Altsoft Xml2PDF-specific exceptions.
Public class | APSourceException | Base class for source-specific exceptions in Altsoft Xml2PDF.


APDestinationException Class

APDestinationException Class
See Also Example Members
[image]

Base class for destination-specific exceptions in Altsoft Xml2PDF.

Namespace: Altsoft.Publisher.Exceptions
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class APDestinationException
Inherits APException
C#
public class APDestinationException : APException
C++
ref class APDestinationException : APException
J#
public class APDestinationException extends APException
JScript
public class APDestinationException extends APException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Altsoft.Publisher.Exceptions.APException
Altsoft.Publisher.Exceptions.APDestinationException

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APDestinationException Members
Altsoft.Publisher.Exceptions Namespace


APDestinationException Members

APDestinationException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Base class for destination-specific exceptions in Altsoft Xml2PDF.

The following tables list the members exposed by APDestinationException.

Public Constructors

Name | Description
APDestinationException | Overloaded. Initializes a new instance of the APDestinationException class.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
APDestinationException | Overloaded. Initializes a new instance of the APDestinationException class.
Top

See Also

APDestinationException Class
Altsoft.Publisher.Exceptions Namespace


APDestinationException Constructor

APDestinationException Constructor

Initializes a new instance of the APDestinationException class.

Overload List

 | Name | Description
Public method | APDestinationException | Initializes a new instance of the APDestinationException class.
Public method | APDestinationException (SerializationInfo, StreamingContext) |
Public method | APDestinationException (String) | Initializes a new instance of the APDestinationException class.
Public method | APDestinationException (String, Exception) | Initializes a new instance of the APDestinationException class.

See Also

APDestinationException Class
Altsoft.Publisher.Exceptions Namespace


APDestinationException Constructor ()

APDestinationException Constructor ()
See Also Example
[image]

Initializes a new instance of the APDestinationException class.

Namespace: Altsoft.Publisher.Exceptions
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APDestinationException()
C++
public:
APDestinationException() sealed
J#
public APDestinationException()
JScript
public function APDestinationException()

See Also

APDestinationException Class
Altsoft.Publisher.Exceptions Namespace
APDestinationException Constructor Overload List


APDestinationException Constructor (SerializationInfo, StreamingContext)

APDestinationException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Namespace: Altsoft.Publisher.Exceptions
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
public APDestinationException(
SerializationInfo info,
StreamingContext context
)
C++
public:
APDestinationException(
SerializationInfo info,
StreamingContext context
) sealed
J#
public APDestinationException(
SerializationInfo info,
StreamingContext context
)
JScript
public function APDestinationException(
info : SerializationInfo,
context : StreamingContext
)

See Also

APDestinationException Class
Altsoft.Publisher.Exceptions Namespace
APDestinationException Constructor Overload List


APDestinationException Constructor (String)

APDestinationException Constructor (String)
See Also Example
[image]

Initializes a new instance of the APDestinationException class.

Namespace: Altsoft.Publisher.Exceptions
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String _
)
C#
public APDestinationException(
string message
)
C++
public:
APDestinationException(
String message
) sealed
J#
public APDestinationException(
string message
)
JScript
public function APDestinationException(
message : String
)

Parameters

message
The exception message.

See Also

APDestinationException Class
Altsoft.Publisher.Exceptions Namespace
APDestinationException Constructor Overload List


APDestinationException Constructor (String, Exception)

APDestinationException Constructor (String, Exception)
See Also Example
[image]

Initializes a new instance of the APDestinationException class.

Namespace: Altsoft.Publisher.Exceptions
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
C#
public APDestinationException(
string message,
Exception innerException
)
C++
public:
APDestinationException(
String message,
Exception innerException
) sealed
J#
public APDestinationException(
string message,
Exception innerException
)
JScript
public function APDestinationException(
message : String,
innerException : Exception
)

Parameters

message
The exception message.
innerException
The inner exception.

See Also

APDestinationException Class
Altsoft.Publisher.Exceptions Namespace
APDestinationException Constructor Overload List


APException Class

APException Class
See Also Example Members
[image]

Base class for Altsoft Xml2PDF-specific exceptions.

Namespace: Altsoft.Publisher.Exceptions
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class APException
Inherits ApplicationException
C#
[SerializableAttribute]
public class APException : ApplicationException
C++
[SerializableAttribute]
ref class APException : ApplicationException
J#
/** @attribute SerializableAttribute() */
public class APException extends ApplicationException
JScript
public
SerializableAttribute
class APException extends ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Altsoft.Publisher.Exceptions.APException
Altsoft.Publisher.Exceptions.APDestinationException
Altsoft.Publisher.Exceptions.APSourceException

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APException Members
Altsoft.Publisher.Exceptions Namespace


APException Members

APException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Base class for Altsoft Xml2PDF-specific exceptions.

The following tables list the members exposed by APException.

Public Constructors

Name | Description
APException | Overloaded. Initializes a new instance of the APException class.
Top

Protected Constructors

Name | Description
APException | Overloaded. Initializes a new instance of the APException class.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
APException | Overloaded. Initializes a new instance of the APException class.
Top

See Also

APException Class
Altsoft.Publisher.Exceptions Namespace


APException Constructor

APException Constructor

Initializes a new instance of the APException class.

Overload List

 | Name | Description
Public method | APException | Initializes a new instance of the APException class.
Family method | APException (SerializationInfo, StreamingContext) |
Public method | APException (String) | Initializes a new instance of the APException class.
Public method | APException (String, Exception) | Initializes a new instance of the APException class.

See Also

APException Class
Altsoft.Publisher.Exceptions Namespace


APException Constructor ()

APException Constructor ()
See Also Example
[image]

Initializes a new instance of the APException class.

Namespace: Altsoft.Publisher.Exceptions
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APException()
C++
public:
APException() sealed
J#
public APException()
JScript
public function APException()

See Also

APException Class
Altsoft.Publisher.Exceptions Namespace
APException Constructor Overload List


APException Constructor (SerializationInfo, StreamingContext)

APException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Namespace: Altsoft.Publisher.Exceptions
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
protected APException(
SerializationInfo info,
StreamingContext context
)
C++
protected:
APException(
SerializationInfo info,
StreamingContext context
) sealed
J#
protected APException(
SerializationInfo info,
StreamingContext context
)
JScript
protected function APException(
info : SerializationInfo,
context : StreamingContext
)

See Also

APException Class
Altsoft.Publisher.Exceptions Namespace
APException Constructor Overload List


APException Constructor (String)

APException Constructor (String)
See Also Example
[image]

Initializes a new instance of the APException class.

Namespace: Altsoft.Publisher.Exceptions
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String _
)
C#
public APException(
string message
)
C++
public:
APException(
String message
) sealed
J#
public APException(
string message
)
JScript
public function APException(
message : String
)

Parameters

message
The exception message.

See Also

APException Class
Altsoft.Publisher.Exceptions Namespace
APException Constructor Overload List


APException Constructor (String, Exception)

APException Constructor (String, Exception)
See Also Example
[image]

Initializes a new instance of the APException class.

Namespace: Altsoft.Publisher.Exceptions
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
C#
public APException(
string message,
Exception innerException
)
C++
public:
APException(
String message,
Exception innerException
) sealed
J#
public APException(
string message,
Exception innerException
)
JScript
public function APException(
message : String,
innerException : Exception
)

Parameters

message
The exception message.
innerException
The inner exception.

See Also

APException Class
Altsoft.Publisher.Exceptions Namespace
APException Constructor Overload List


APSourceException Class

APSourceException Class
See Also Example Members
[image]

Base class for source-specific exceptions in Altsoft Xml2PDF.

Namespace: Altsoft.Publisher.Exceptions
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class APSourceException
Inherits APException
C#
public class APSourceException : APException
C++
ref class APSourceException : APException
J#
public class APSourceException extends APException
JScript
public class APSourceException extends APException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Altsoft.Publisher.Exceptions.APException
Altsoft.Publisher.Exceptions.APSourceException

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APSourceException Members
Altsoft.Publisher.Exceptions Namespace


APSourceException Members

APSourceException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Base class for source-specific exceptions in Altsoft Xml2PDF.

The following tables list the members exposed by APSourceException.

Public Constructors

Name | Description
APSourceException | Overloaded. Initializes a new instance of the APSourceException class.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
APSourceException | Overloaded. Initializes a new instance of the APSourceException class.
Top

See Also

APSourceException Class
Altsoft.Publisher.Exceptions Namespace


APSourceException Constructor

APSourceException Constructor

Initializes a new instance of the APSourceException class.

Overload List

 | Name | Description
Public method | APSourceException | Initializes a new instance of the APSourceException class.
Public method | APSourceException (SerializationInfo, StreamingContext) |
Public method | APSourceException (String) | Initializes a new instance of the APSourceException class.
Public method | APSourceException (String, Exception) | Initializes a new instance of the APSourceException class.

See Also

APSourceException Class
Altsoft.Publisher.Exceptions Namespace


APSourceException Constructor ()

APSourceException Constructor ()
See Also Example
[image]

Initializes a new instance of the APSourceException class.

Namespace: Altsoft.Publisher.Exceptions
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APSourceException()
C++
public:
APSourceException() sealed
J#
public APSourceException()
JScript
public function APSourceException()

See Also

APSourceException Class
Altsoft.Publisher.Exceptions Namespace
APSourceException Constructor Overload List


APSourceException Constructor (SerializationInfo, StreamingContext)

APSourceException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Namespace: Altsoft.Publisher.Exceptions
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
public APSourceException(
SerializationInfo info,
StreamingContext context
)
C++
public:
APSourceException(
SerializationInfo info,
StreamingContext context
) sealed
J#
public APSourceException(
SerializationInfo info,
StreamingContext context
)
JScript
public function APSourceException(
info : SerializationInfo,
context : StreamingContext
)

See Also

APSourceException Class
Altsoft.Publisher.Exceptions Namespace
APSourceException Constructor Overload List


APSourceException Constructor (String)

APSourceException Constructor (String)
See Also Example
[image]

Initializes a new instance of the APSourceException class.

Namespace: Altsoft.Publisher.Exceptions
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String _
)
C#
public APSourceException(
string message
)
C++
public:
APSourceException(
String message
) sealed
J#
public APSourceException(
string message
)
JScript
public function APSourceException(
message : String
)

Parameters

message
The exception message.

See Also

APSourceException Class
Altsoft.Publisher.Exceptions Namespace
APSourceException Constructor Overload List


APSourceException Constructor (String, Exception)

APSourceException Constructor (String, Exception)
See Also Example
[image]

Initializes a new instance of the APSourceException class.

Namespace: Altsoft.Publisher.Exceptions
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
C#
public APSourceException(
string message,
Exception innerException
)
C++
public:
APSourceException(
String message,
Exception innerException
) sealed
J#
public APSourceException(
string message,
Exception innerException
)
JScript
public function APSourceException(
message : String,
innerException : Exception
)

Parameters

message
The exception message.
innerException
The inner exception.

See Also

APSourceException Class
Altsoft.Publisher.Exceptions Namespace
APSourceException Constructor Overload List


Altsoft.Publisher.Logs

Altsoft.Publisher.Logs Namespace
See Also Example Hierarchy

Delegates

 | Delegate | Description
Public delegate | APLogMessageHandler | Handler for OnMessage event.
Public delegate | APLogProgressHandler | Handler for OnProgress event.
Public delegate | APLogStageHandler | Handler for OnStartStage & OnEndStage events.
Public delegate | APLogWarningHandler | Handler for OnWarning event.

Enumerations

 | Enumeration | Description
Public enumeration | APLogMessageType | Log message types.
Public enumeration | APLogWarningType | Log warning types.


APLogMessageHandler Delegate

APLogMessageHandler Delegate
[image]

Handler for OnMessage event.

Namespace: Altsoft.Publisher.Logs
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub APLogMessageHandler( _
ByVal type As APLogMessageType, _
ByVal message As String, _
ByVal source As Object _
)
C#
public delegate void APLogMessageHandler(
APLogMessageType type,
string message,
object source
)
C++
public delegate void APLogMessageHandler(
APLogMessageType type,
String message,
Object source
)
J#
/** delegate */
public delegate void APLogMessageHandler(
APLogMessageType type,
string message,
object source
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

Parameters

type
Message type.
message
Message string.
source
Message source.

See Also

Altsoft.Publisher.Logs Namespace


APLogMessageType Enumeration

APLogMessageType Enumeration
[image]

Log message types.

Namespace: Altsoft.Publisher.Logs
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enum APLogMessageType
C#
public enum APLogMessageType
C++
public enum class APLogMessageType
J#
public enum APLogMessageType
JScript
public enum APLogMessageType

Members

Member Name | Description
Unknown | Unknown message type.

See Also

Altsoft.Publisher.Logs Namespace


APLogProgressHandler Delegate

APLogProgressHandler Delegate
[image]

Handler for OnProgress event.

Namespace: Altsoft.Publisher.Logs
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub APLogProgressHandler( _
ByVal description As String, _
ByVal current As Double, _
ByVal overall As Double _
)
C#
public delegate void APLogProgressHandler(
string description,
double current,
double overall
)
C++
public delegate void APLogProgressHandler(
String description,
double current,
double overall
)
J#
/** delegate */
public delegate void APLogProgressHandler(
string description,
double current,
double overall
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

Parameters

description
Current operation description.
current
Current progress value.
overall
Overall progress value.

See Also

Altsoft.Publisher.Logs Namespace


APLogStageHandler Delegate

APLogStageHandler Delegate
[image]

Handler for OnStartStage & OnEndStage events.

Namespace: Altsoft.Publisher.Logs
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub APLogStageHandler( _
ByVal stageDescription As String, _
ByVal parentDescription As String, _
ByVal weight As Double _
)
C#
public delegate void APLogStageHandler(
string stageDescription,
string parentDescription,
double weight
)
C++
public delegate void APLogStageHandler(
String stageDescription,
String parentDescription,
double weight
)
J#
/** delegate */
public delegate void APLogStageHandler(
string stageDescription,
string parentDescription,
double weight
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

Parameters

stageDescription
Current stage description.
parentDescription
Parent stage description.
weight
Current stage weight.

See Also

Altsoft.Publisher.Logs Namespace


APLogWarningHandler Delegate

APLogWarningHandler Delegate
[image]

Handler for OnWarning event.

Namespace: Altsoft.Publisher.Logs
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub APLogWarningHandler( _
ByVal type As APLogWarningType, _
ByVal message As String, _
ByVal source As Object _
)
C#
public delegate void APLogWarningHandler(
APLogWarningType type,
string message,
object source
)
C++
public delegate void APLogWarningHandler(
APLogWarningType type,
String message,
Object source
)
J#
/** delegate */
public delegate void APLogWarningHandler(
APLogWarningType type,
string message,
object source
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

Parameters

type
Warning type.
message
Warning message.
source
Warning source.

See Also

Altsoft.Publisher.Logs Namespace


APLogWarningType Enumeration

APLogWarningType Enumeration
[image]

Log warning types.

Namespace: Altsoft.Publisher.Logs
Assembly: Altsoft.Xml2PDF.Formatting.Engine (in Altsoft.Xml2PDF.Formatting.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enum APLogWarningType
C#
public enum APLogWarningType
C++
public enum class APLogWarningType
J#
public enum APLogWarningType
JScript
public enum APLogWarningType

Members

Member Name | Description
Unknown | Unknown warning type.
CssAttribute | Unknown attribute in CSS
FoAttribute | Unknown attribute in FO
ImageNotFound | Some image resource wasnot found.
n0BB5 | Invalid formatting setting.

See Also

Altsoft.Publisher.Logs Namespace


Altsoft.Publisher Hierarchy

Altsoft.Publisher Hierarchy
System.Object
Altsoft.Publisher.APDestination ---- System.IDisposable
Altsoft.Publisher.APEngine ---- System.IDisposable
Altsoft.Publisher.APFileSystem
Altsoft.Publisher.APLog ---- System.Xml.Serialization.IXmlSerializable
Altsoft.Publisher.APSource ---- System.IDisposable
System.Configuration.ConfigurationElement
System.Configuration.ConfigurationSection
Altsoft.Publisher.APConfig ---- System.ComponentModel.ICustomTypeDescriptor
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Altsoft.Publisher.APDestinationFormat
Altsoft.Publisher.APSourceFormat

See Also

Altsoft.Publisher Namespace


Altsoft.Publisher.Configuration Hierarchy

Altsoft.Publisher.Configuration Hierarchy
System.Object
Altsoft.Publisher.Configuration.Settings
Altsoft.Publisher.Configuration.AltOutputSettings
Altsoft.Publisher.Configuration.FoInputSettings
Altsoft.Publisher.Configuration.FontsSettings
Altsoft.Publisher.Configuration.GeneralInputSettings
Altsoft.Publisher.Configuration.GeneralOutputSettings
Altsoft.Publisher.Configuration.HtmlInputSettings
Altsoft.Publisher.Configuration.PageSettings
Altsoft.Publisher.Configuration.PdfOutputSettings
Altsoft.Publisher.Configuration.PSOutputSettings
Altsoft.Publisher.Configuration.SecuritySettings
Altsoft.Publisher.Configuration.SvgInputSettings
Altsoft.Publisher.Configuration.TIFFOutputSettings
Altsoft.Publisher.Configuration.WordInputSettings
Altsoft.Publisher.Configuration.WordMetadataSettings
Altsoft.Publisher.Configuration.XPSOutputSettings
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Altsoft.Publisher.Configuration.PDFConformance

See Also

Altsoft.Publisher.Configuration Namespace


Altsoft.Publisher.Exceptions Hierarchy

Altsoft.Publisher.Exceptions Hierarchy
System.Object
System.Exception ---- System.Runtime.Serialization.ISerializable
System.ApplicationException
Altsoft.Publisher.Exceptions.APException
Altsoft.Publisher.Exceptions.APDestinationException
Altsoft.Publisher.Exceptions.APSourceException

See Also

Altsoft.Publisher.Exceptions Namespace


Altsoft.Publisher.Logs Hierarchy

Altsoft.Publisher.Logs Hierarchy
System.Object
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Altsoft.Publisher.Logs.APLogMessageHandler
Altsoft.Publisher.Logs.APLogProgressHandler
Altsoft.Publisher.Logs.APLogStageHandler
Altsoft.Publisher.Logs.APLogWarningHandler
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Altsoft.Publisher.Logs.APLogMessageType
Altsoft.Publisher.Logs.APLogWarningType

See Also

Altsoft.Publisher.Logs Namespace


SDK Link Manager

NDoc Utilities
SDK Link Manager

SDK Link Namespace


Settings Class Hierarchy

Settings Hierarchy

The following table lists the types derived from Settings .

Derived Types

Type | Description
AltOutputSettings | ALT output settings.
FoInputSettings | XSL-FO input options.
FontsSettings | Font-related settings.
GeneralInputSettings | Set of general input options.
GeneralOutputSettings | Set of general output options.
HtmlInputSettings | HTML input options.
PageSettings | Page settings.
PdfOutputSettings | PDF output settings.
PSOutputSettings | PS output settings.
SecuritySettings | Security options.
SvgInputSettings | SVG input options.
TIFFOutputSettings | TIFF output settings.
WordInputSettings | Word input options.
WordMetadataSettings | Word metadata options.
XPSOutputSettings | PS output settings.

See Also

Settings Class
Altsoft.Publisher.Configuration Namespace